"定义 Text 格式"对话框

[image]

"定义 Text 格式"对话框
Microsoft 已在线提供此产品的文档，以便为我们的客户提供最新信息。有关详细信息，请参阅 Microsoft Developer Network (MSDN) 资源页 (http://go.microsoft.com/fwlink/?LinkId=282669)。

© Microsoft Corporation。保留所有权利。


Access 文件

[image]

Access 文件


Excel 文件

[image]

Excel 文件


"选择系统数据库"对话框

[image]

"选择系统数据库"对话框


"ODBC Microsoft Excel 安装"对话框

[image]

"ODBC Microsoft Excel 安装"对话框


Paradox 文件

[image]

Paradox 文件


"新建数据库"对话框

[image]

"新建数据库"对话框


"ODBC Paradox 安装"对话框

[image]

"ODBC Paradox 安装"对话框


"ODBC Text 安装"对话框

[image]

"ODBC Text 安装"对话框


"设置高级选项"对话框

[image]

"设置高级选项"对话框


"ODBC Microsoft Access 安装"对话框

[image]

"ODBC Microsoft Access 安装"对话框


通用 ODBC 组件文件

[image]

通用 ODBC 组件文件


数据源转换

[image]

数据源转换


Text ISAM 文件

[image]

Text ISAM 文件


"ODBC dBASE 安装"对话框

[image]

"ODBC dBASE 安装"对话框


"选择数据库"对话框

[image]

"选择数据库"对话框


产品支持 (ODBC Jet)

[image]

产品支持 (ODBC Jet)


"压缩源数据库"对话框

[image]

"压缩源数据库"对话框


dBASE 文件

[image]

dBASE 文件


IISAM 注册表项

[image]

IISAM 注册表项


Access 系统数据库登录

[image]

Access 系统数据库登录


"选择索引"对话框

[image]

"选择索引"对话框


"选择工作簿"对话框

[image]

"选择工作簿"对话框


"修复数据库"对话框

[image]

"修复数据库"对话框


.topic 2
退出此对话框并且不保存任何更改。

.topic 3
标识数据源名称，例如 Payroll 或 Personnel。 在使用 Microsoft Excel 3.0 或 4.0 驱动程序时，指定 ODBC 驱动程序在其中搜索数据文件的默认数据目录。 对于 Microsoft Excel 5.0、7.0 或 97，指定 ODBC 驱动程序在其中搜索数据文件的默认数据工作簿。

.topic 4
数据源中数据的可选描述，例如，“雇佣日期、发薪记录和当前员工的考评”。

.topic 5
显示此对话框的帮助。

.topic 6
退出“设置”对话框并且保存更改。

.topic 7
选择此选项可使数据库为只读以禁止任何更新。

.topic 8
为确定每一列的数据类型而要扫描的行数。 对于 Microsoft Excel 驱动程序，该数目可以是从 1 到 16 的任何数字，默认为 8；如果设置为 0，则会扫描所有行。

.topic 9
单击可以打开“选择目录”对话框，从中可以选择包含您要访问的文件的目录。 在定义数据源目录时，指定包含 Microsoft Excel 3.0 或 4.0 的最常用 Excel 文件的目录。

.topic 10
单击可以打开“选择工作簿”对话框，从中可以选择包含您要访问的工作簿的目录。

.topic 11
选择该选项可使应用程序的当前工作目录成为数据源目录。 如果取消选中该选项，您可以通过单击“选择目录”按钮选择数据源目录。 对 Microsoft Excel 5.0、7.0 和 97 禁用。

.topic 12
指定所用文件的 Excel 版本。

.topic 13
使用这些选项可更改 Excel 文件的位置和版本。

.topic 14
使用这些选项可配置特定驱动程序的属性。

.topic 15
单击可配置特定驱动程序的属性。

.topic 16
所选 Excel 目录的位置。

.topic 17
所选 Excel 工作簿的位置。

.topic 201
单击可添加在“扩展名”框中键入的扩展名。

.topic 202
退出此对话框并且不保存任何更改。

.topic 203
标识数据源名称，例如 Payroll 或 Personnel，并且指定 ODBC 驱动程序在其中搜索数据文件的默认数据目录。

.topic 204
如果选择，则可以使用该目录中的所有文件。 如果取消选中，则“扩展名列表”将默认为 *.asc、*.csv、*.tab 和 *.txt 扩展名，并且您可以根据需要添加或删除特定扩展名。

.topic 205
单击以打开“定义文本格式”对话框，从中可以定义列格式并指定数据源目录中的表架构。

.topic 206
数据源中数据的可选描述，例如，“雇佣日期、发薪记录和当前员工的考评”。

.topic 207
使用 *.xxx 格式输入您要添加的文件扩展名。 例如，若要使用 .dat 文件，请键入扩展名 *.dat。

.topic 208
基于“默认”复选框的选中或取消选中状态，列出数据源中文本文件的文件扩展名。

.topic 214
使用这些选项可设置特定文件类型的格式。

.topic 215
使用这些选项可从“扩展名列表”中添加或删除非默认的文件扩展名。 若要添加文件扩展名，请取消选中“默认”复选框，然后在“扩展名”框中键入新扩展名并单击“添加”。

.topic 216
使用这些选项可选择文本文件的位置并显示文件名。

.topic 209
显示此对话框的帮助。

.topic 210
退出“设置”对话框并且保存更改。

.topic 211
单击可从“扩展名列表”中删除所选的文件扩展名。

.topic 212
单击可以打开“选择目录”对话框，从中可以选择包含您要访问的文件的目录。

.topic 213
选择该选项可使应用程序的当前工作目录成为数据源目录。 如果取消选中该选项，您可以通过单击“选择目录”选择数据源目录。

.topic 217
单击可以配置文本文件属性以及添加或删除文本文件类型。

.topic 218
标识文本文件的位置。

.topic 301
单击可使用“数据类型”、“名称”和“宽度”字段中的值添加列。

.topic 302
退出此对话框并且不保存任何更改。

.topic 321
将字符集指定为 ANSI 或 OEM。

.topic 303
对于在“表”列表中选择的项的格式，将字符集指定为 ANSI。

.topic 304
指定是否将选定表第一行的列用作列名称（如果选择则为 TRUE，如果清除则为 FALSE）。

.topic 305
列出“表”列表中所选表每列的列名称，并反映表中列的顺序。

.topic 319
允许您为所选文本文件定义列属性。

.topic 306
显示数据类型并且数据类型可以是 BIT、BYTE、CHAR、CURRENCY、DATE、FLOAT、INTEGER、LONGCHAR、SHORT 或 SINGLE。

.topic 307
用于分隔列的自定义分隔符。 长度只能是一个字符，不能使用双引号 (")。 从“格式”列表框中选择了“自定义分隔符”时将启用。

.topic 308
带分隔符或固定长度；如果带分隔符，则指示使用的分隔符类型。

.topic 309
根据“格式”列表框选定内容来扫描所选表的内容，从而为表中的列生成数据类型、名称和宽度值。 如果表为带分隔符的格式，则启用该选项。

.topic 310
显示此对话框的帮助。

.topic 311
使用“数据类型”、“名称”和“宽度”字段中的值修改所选列。

.topic 312
显示所选列的名称。 可用于为现有列或新列指定新的列名称。

.topic 313
退出此对话框并且保存更改。

.topic 314
删除所选的列。

.topic 315
设置列和列数据类型时，安装程序或驱动程序将扫描的行数。 如果未定义“表”列表中所选项的格式，则默认为 25，但可以为介于 1 和 32767 之间的任何数字。

.topic 316
列出与“ODBC Text 安装”对话框中指定的扩展名列表匹配的所有文件。 选择一个文件以便显示或修改其表属性。

.topic 320
使用这些选项可为选定的文本文件定义表属性。

.topic 317
列的宽度；对于 CHAR 或 LONGCHAR 列，可更改该宽度。 对于其他数据类型，将禁用“宽度”，并且不显示任何值。 如果未定义“表”列表中所选项的格式，则默认值为 1。

.topic 318
对于在“表”列表中选择的文件的格式，指定非 ANSI 字符集（默认值）。

.topic 401
退出此对话框并且不保存任何更改。

.topic 402
存储字段所采用的序列，ASCII（默认值）、国际、瑞典-芬兰或挪威-丹麦。

.topic 403
标识数据源名称，例如 Payroll 或 Personnel，并且指定 ODBC 驱动程序在其中搜索数据文件的默认数据目录。

.topic 404
数据源中数据的可选描述，例如，“雇佣日期、发薪记录和当前员工的考评”。

.topic 405
选择此选项后，数据库将以“独占”模式打开，这样每次只限一位用户访问该数据库，从而提高性能。 如果取消选择，数据库将以“共享”模式打开，多位用户可同时访问该数据库。

.topic 406
显示此对话框的帮助。

.topic 407
指定访问 Paradox 数据时要使用的网络访问样式：对于 Paradox 3.x 指定“3.x”，对于 Paradox 4.x 或 5.x 指定“4.x”。 对于 Paradox 版本 4.x 和 5.x，可设置为“3.x”或“4.x”；对于 Paradox 版本 3.x，该样式必须是“3.x”。

.topic 408
退出“设置”对话框并且保存更改。

.topic 409
不用的页在缓冲区中保留的时间（以十分之一秒为单位）。 默认值为 600 十分之一秒（即 60 秒）并且必须大于 0。

.topic 410
单击可以打开“选择目录”对话框，从中可以选择包含您要访问的文件的目录。

.topic 415
标识 Paradox 文件的位置。

.topic 411
在选择某一网络目录前，您必须在“用户名”文本框中输入您的 Paradox 用户名。 然后单击“选择网络目录”以选择某一网络目录。

.topic 416
包含 Paradox 锁数据库且还包含 Pdoxusrs.net 文件（Paradox 4.x 中）或 Paradox.net 文件（Paradox 5.x 中）的目录的路径。 如果该目录不包含这些文件之一，则 Paradox 驱动程序将创建一个。

.topic 412
选择该选项可使应用程序的当前工作目录成为数据源目录。 如果取消选中该选项，您可以通过单击“选择目录”选择数据源目录。

.topic 413
遇到锁时，向 Paradox 文件的其他用户显示的 Paradox 用户名。

.topic 414
指定使用的文件的 Paradox 版本 – 例如 Paradox 4.x 或 Paradox 5.x。

.topic 417
使用这些选项可选择和显示 Paradox 数据库的版本和位置。

.topic 418
使用这些选项可配置 Paradox 驱动程序。

.topic 419
单击可配置特定驱动程序的属性。

.topic 501
指定表大小统计信息是否为近似值。 该选项适用于使用 dBASE 驱动程序的所有数据源。

.topic 502
退出此对话框并且不保存任何更改。

.topic 503
存储字段所采用的序列，可选择 ASCII（默认值）或国际。

.topic 504
标识数据源名称，例如 Payroll 或 Personnel，并且指定 ODBC 驱动程序在其中搜索数据文件的默认数据目录。

.topic 505
数据源中数据的可选描述，例如，“雇佣日期、发薪记录和当前员工的考评”。

.topic 506
选择此选项后，数据库将以“独占”模式打开，这样每次只限一位用户访问该数据库，从而提高性能。 如果取消选择，数据库将以“共享”模式打开，多位用户可同时访问该数据库。

.topic 507
显示此对话框的帮助。

.topic 508
退出“设置”对话框并且保存更改。

.topic 509
不用的页在缓冲区中保留的时间（以十分之一秒为单位）。 默认值为 600 十分之一秒（即 60 秒）并且必须始终大于 0。

.topic 515
标识 dBASE 数据库的位置。

.topic 510
单击可以打开“选择目录”对话框，从中可以选择包含您要访问的文件的目录。

.topic 511
单击可以打开“选择索引”对话框，从中可以将 dBASE 文件与索引文件相关联。

.topic 512
指定是否可以检索或定位标记为已删除的行。 如果取消选中（默认设置），将不显示已删除的行；如果选中，则已删除的行将与未删除的行一样处置。

.topic 513
选择该选项可使应用程序的当前工作目录成为数据源目录。 如果取消选中该选项，您可以通过单击“选择目录”选择数据源目录。

.topic 514
指定使用的 dBASE 文件的版本；例如 dBASE III、dBASE IV 或 dBASE 5.0。

.topic 516
使用这些选项可选择和显示 dBASE 数据库的版本和位置。

.topic 517
使用这些选项可配置 dBASE 驱动程序。

.topic 518
单击可配置特定驱动程序的属性。

.topic 701
单击可设置用于改变性能的高级驱动程序选项。

.topic 702
内部缓冲区大小 (KB)，Microsoft Access 用来在磁盘之间传输数据。 默认大小为 2048 KB（显示为 2048）。 输入可被 256 整除的整数值。

.topic 703
退出此对话框并且不保存任何更改。

.topic 704
单击可创建 Access 数据库。

.topic 705
单击可减少现有 Access 数据库中浪费的空间。

.topic 706
标识数据源名称，例如 Payroll 或 Personnel，并且指定 ODBC 驱动程序在其中搜索数据文件的默认数据目录。

.topic 707
当前选择的 Access 数据库的位置。 若要选择某一数据库，请单击“选择”。

.topic 708
数据源中数据的可选描述，例如，“雇佣日期、发薪记录和当前员工的考评”。

.topic 709
选择此选项后，数据库将以“独占”模式打开，这样每次只限一位用户访问该数据库，从而提高性能。 如果取消选择，数据库将以“共享”模式打开，多位用户可同时访问该数据库。

.topic 710
显示此对话框的帮助。

.topic 711
如果不使用任何系统数据库，则选择此选项将以特定 Access 数据库的 Admin (DefaultUser) 用户的身份登录。

.topic 712
退出“设置”对话框并且保存更改。

.topic 713
不用的页在缓冲区中保留的时间（以十分之一秒为单位）。 默认值为 0.5 秒并且必须始终大于 0。

.topic 714
选择此选项可使数据库为只读以禁止任何更新。

.topic 715
单击此选项可修复损坏的 Access 数据库。

.topic 716
单击此选项可选择特定的 Access 数据库。

.topic 723
选择此选项以使用某一系统数据库。 然后单击“系统数据库”。

.topic 717
单击此选项可以打开“选择系统数据库”对话框，从中可以选择您要使用的系统（工作组）数据库。

.topic 718
使用这些选项可以查看 Access 数据库的位置并执行数据库维护功能。

.topic 719
使用这些选项可选择某一系统（工作组）数据库并查看其位置。

.topic 720
当前选择的 Access 数据库的位置。

.topic 721
使用这些选项可配置 Access 驱动程序。

.topic 722
单击可配置特定驱动程序的属性。