Measurement & Automation Explorerヘルプ

2021年7月、370694W-0112

Measurement & Automation Explorer (MAX) では、以下の操作を行うことができます。

  • NIハードウェアおよびソフトウェアを構成する
  • 構成データのバックアップおよび複製を行う
  • チャンネル、タスク、インタフェース、スケール、仮想計測器を作成、編集する
  • システムの動作確認を行う
  • システムに接続されているデバイスと計測器を表示する
  • NIソフトウェアを更新する

詳しくは、以下のトピックを参照してください。

法的情報

NIサービス

© 2004-2021 National Instruments Corporation.All rights reserved.

NIの著作権、特許、商標、保証、製品の警告、および輸出関連法規遵守については、<National Instruments>\_Legal Informationディレクトリを参照してください。


MAX概要

TMeasurement & Automation Explorer (MAX) は、NIデバイスおよびシステムへのアクセスを提供します。

MAXでは、以下の操作を行うことができます。

  • NIハードウェアおよびソフトウェアを構成する
  • チャンネル、タスク、インタフェース、スケール、仮想計測器を作成、編集する
  • システムの動作確認を行う
  • システムに接続されているデバイスと計測器を表示する
  • NIソフトウェアを更新する

MAXではインストールするNI製品に応じて、標準ツール以外にシステムの構成、診断、テストに使用可能な項目専用のツールを表示できます。MAXのアプリケーションメニューの内容やツールバーは、使用できるツール応じて異なります。

各メニュー項目の一般情報は、以下のリンクをクリックして参照してください。各デバイス固有のヘルプは、ヘルプメニューのデバイスのヘルプを参照してください。

  • ファイルメニュー
  • 編集メニュー
  • 表示メニュー
  • ツールメニュー
  • ヘルプメニュー
  • 一般的なヒント


MAXファイルメニュー

ファイルメニューには以下のオプションがあります。

新規→ウィンドウ―新しいMeasurement & Automation Explorer（MAX）のウィンドウを開きます。

すべて保存―MAXで行われたすべての保留中の変更内容を保存します。

レポートを作成―MAXレポートウィザードを開始します。このウィザードを使用して、ローカルまたはリモートシステムのシステム構成を含む印刷可能なレポートを作成します。

インポート―構成インポートウィザードを開始します。このウィザードを使用して、ファイルから構成データをインポートします。

エクスポート―構成エクスポートウィザードを開始します。このウィザードを使用して、構成データをファイルへエクスポートします。

終了―MAXを終了します。


MAX編集メニュー

編集メニューには以下のオプションがあります。

元に戻す―最後に行った操作を無効にします。ツリー構図で選択された項目でサポートされている場合のみ使用可能です。

やり直し―最後に取り消した操作をやり直します。ツリー構図で選択された項目でサポートされている場合のみ使用可能です。


MAX表示メニュー

表示メニューには以下のオプションがあります。

ツールバー―以下のとおり、ツールバーの表示オプションを設定します。

  • テキストラベル―ツールバーアイコンの下にツールバーのテキストラベルを表示します。
  • テキストを右側に表示―ツールバーアイコンの右側にツールバーのテキストラベルを表示します。
  • テキストラベルなし―ツールバーのアイコンのみを表示します。

ステータスバー―MAXウィンドウの下にあるステータスバーを表示または非表示にします。

構成―MAXツリー構図を表示または非表示にします。

ヘルプペーン―ヘルプを埋め込んだタスクリストを表示または非表示にします。また、ヘルプを表示またはヘルプを非表示ボタンをクリックしても、同じ操作を実行することができます。

更新―MAXツリー構図を更新します。また、<F5>キーを押してツリー構図を更新することもできます。


MAXツールメニュー

ツールメニューには以下の標準オプションがあります。

NI ネットワークブラウザ―ウェブブラウザを介してNI ネットワークデバイスを検出および構成するNI ネットワークブラウザを起動します。

NI登録ウィザード―NI製品の検出および登録を行い、技術サポートを促進して重要な更新の連絡を確認する際に役立ちます。提供していただいた情報は、ni.com/legalにある法令関連情報に従って処理されます。

Real-Time Hypervisorマネージャ―Real-Time Hypervisorシステムを構成し、管理します。Real-Time Hypervisorマネージャには、システム内のハードウェアデバイス用割り込みラインやオペレーティングシステムの割り当てなどの必要なHypervisor設定を構成するためのインタフェースが含まれます。Real-Time Hypervisorの詳細については、『Real-Time Hypervisor Help』（スタート→すべてのプログラム→National Instruments→Real-Time Hypervisor→Real-Time Hypervisor Help）を参照してください。

メモ メモ Real-Time Hypervisorマネージャメニュー項目は、この機能がインストールされた時のみに表示されます。

デスクトップPCユーティリティUSBドライブを作成―起動できるデスクトップPCのUSBドライブをLabVIEW Real-Time起動USBユーティリティを使用して再フォーマットします。

構成データをリセット―システム上のすべてのNI構成データをリセットします。

注意 注意 NI製品を使用する前にシステムを再起動する必要があります。構成データをリセット操作を選択した後で再起動せずにNI製品を使用すると、破損する場合があります。

MAXではインストールするNI製品に応じて、標準ツール以外にシステムの構成、診断、テストに使用可能な項目専用のツールを表示できます。MAXのアプリケーションメニューの内容やツールバーは、使用できるツール応じて異なります。


MAXヘルプメニュー

ヘルプメニューには以下のオプションがあります。

MAXヘルプ―メインのヘルプファイルを開きます。また、<F1>キーを押してヘルプファイルにアクセスすることもできます。

ヘルプトピック―インストール済みのMAXヘルプトピックにアクセスします。ここに表示されるトピックは、インストールされているNI製品に応じてことなります。

NIウェブサイト―技術サポートのページやウェブサイトのサーチエンジンなど、ni.com/のインターネットリソースへのリンクです。

技術サポート―MAX技術サポートリソースに関する情報とリンクが記載されています。

システム情報―システムの概要（オペレーティングシステム、CPU、RAM容量、インストールされているNIソフトウェアなど）を表示します。すべてコピー―クリックするとクリップボードに情報をコピーできるので、その情報をドキュメントに貼り付けできます。

更新を確認―NI更新サービスを起動して、製品の新しいバーションや更新を検索します。このNI更新サービスを使用して、ご使用の測定システムを迅速に更新します。

特許―NI製品の特許情報を表示します。

バージョン情報―プログラム名、バージョン、著作権を表示するMeasurement & Automation Explorerのバージョン情報ダイアログボックスを開きます。

インストールされているNI製品によっては、MAXの標準ツール以外に、システムの構成、診断、テストに使用できる特別ツールが表示される場合があります。MAXのアプリケーションメニューの内容やツールバーは、使用できるツール応じて異なります。


MAXの使用に関するヒント

MAXヒント

MAXを効果的に使用するためのヒントを以下に紹介します。

  • 最新情報に更新する―新規のインタフェースまたはデバイスのインストール後に表示を更新するには、表示→更新メニューを選択するか、<F5>キーを押します。ほとんどのデバイスとインタフェースは、自動的に更新されます。
  • 複数のウィンドウを使用する―MAXインタフェースの項目表示タブをウィンドウの外側へドラッグして分離し、複数の項目表示を一度に表示することができます。項目表示とは、ツリー構図の左側でデバイスをクリックすると表示されるタブ付きの中央ウィンドウです。通常、このウィンドウにはデバイスの構成設定が表示されます。タブのウィンドウを元の位置へ戻すには、タブを閉じるか、項目表示の近くへドラッグしてください。
  • ウィンドウを固定する―切り離した項目表示のツールバーにあるピンアイコン [image] をクリックすると、ツリー構図で他の項目を参照しても、このウィンドウが開いたまま維持されます。
  • ヘルプを表示する―ヘルプペーンの表示/非表示を切り替えるには、ヘルプウィンドウのすぐ上に表示されるヘルプを表示/非表示ボタンをクリックします。また、ヘルプペーンの上にあるヘルプを浮動ウィンドウへ移動ボタン [image] をクリックし、MAXインタフェースの外側へこのヘルプペーンを移動することもできます。ヘルプペーンを元の位置へ戻すには、再度ヘルプを浮動ウィンドウへ移動ボタンをクリックしてください。
  • 複数のデバイスを同時に構成する―同時に複数のデバイスまたはシステムを構成する場合、新規のMAXウィンドウ（ファイル→新規→ウィンドウメニュー項目）を作成するか、表示を固定します。
  • 複数のツリー項目を選択する―ツリー構図の項目を<Ctrl>または<Shift>キーを押しながら選択すると、複数の項目を同時に選択できます。複数の項目を選択すると、右側の表示がブランクになります。

    選択した項目グループがバッチコマンドの使用をサポートしている場合、ツールバーにバッチコマンドのボタンが表示され、選択された項目の1つを右クリックして詳細メニューを表示することができます。それ以外の場合、ツールバーはブランクになり、詳細メニューは表示されません。バッチコマンドを使用して、一度に複数の項目に同じ操作を行うことができます。

MAX項目

MAXには、以下の6つの標準の項目があります。

  • データ設定―このオプションを使用して、仮想チャンネル、タグ、およびデバイスとインタフェースで構成されたチャンネルまたは計測器へのエイリアスを作成します。
  • デバイスとインタフェース―このオプションを使用して、ユーザデバイスとインタフェースのリソースおよびその他の物理プロパティを構成します。
  • スケール―このオプションを使用して、集録したデータに実行する簡単な操作を設定します。
  • ソフトウェア―このオプションを使用して、インストールされたNIのソフトウェアを表示、起動、更新します。
  • IVI―このオプションを使用して、IVI計測器（IVI 1.x）またはIVIドライバ（IVI 2.0以上）を構成します。
  • リモートシステム―このオプションを使用して、イーサネットを介して接続されたデバイスとシステムを表示または構成します。


ネットワークデバイスを追加する

ネットワークデバイスには、このシステムから使用可能なネットワークおよびワイヤレスデバイスが含まれます。ネットワークデバイスにより、ネットワークを介して接続されたデバイスを表示し、構成することが可能です。

ネットワークデバイスとは

ネットワークデバイスは、ネットワークまたはワイヤレス接続によりアクセスが可能なデバイスです。このようなデバイスは複数のコンピュータからアクセスでき、リアルタイムオペレーティングシステムを実行しません。ネットワークデバイスは、リモートシステムと同じではありません。リモートシステムは、ネットワークを介して管理または構成が可能なリアルタイムターゲットで、ネットワークデバイスは、リアルタイムオペレーティングシステムを実行しません。

メモ メモ NI-VISA 4.6、NI-DAQmx 9.0、およびそれら以降のバージョンのみがこの機能をサポートしています。この機能をサポートしていないデバイスは、デバイスとインタフェースの下に表示されます。

ネットワークデバイスを追加する

ネットワークデバイスがこのリストに表示されない場合、ネットワークデバイスを追加をクリックし、追加するデバイスのタイプを選択します。ネットワークデバイスをMAXに追加してウィザードを完了します。

メモ メモ ネットワークデバイス機能をサポートしていないデバイスをMAXに追加するには、デバイスとインタフェースを右クリックして、新規作成を選択します。

ネットワークデバイスの設置についての詳細は、使用しているシステムのハードウェアのドキュメントを参照してください。


デバイスキャリブレーション

システム設定タブの外部キャリブレーションとセルフキャリブレーションセクションを使用し、デバイスの基本的なキャリブレーション情報を確認できます。

メモ デバイスがMAXで書き込み可能なキャリブレーションをサポートしない場合、キャリブレーションプロパティは読み取り専用になります。

外部キャリブレーション

外部キャリブレーションでは、高精度の外部標準を必ず使用してください。デバイスで外部キャリブレーションを実行すると、以下のステップが実行されます。

  1. デバイスのパフォーマンスが高精度の外部標準に対して測定されます。
  2. デバイスのパフォーマンスが外部標準で指定された範囲から外れている場合、調整が行われます。調整中、デバイスメモリの保護領域に新しいキャリブレーション定数が格納され、ユーザはこれを変更できません。これにより、キャリブレーションのトレーサビリティが保護されます。
  3. 調整後、デバイスのパフォーマンスは高精度の外部標準に対して再度測定されます。

外部キャリブレーションは、トレーサブルなキャリブレーション標準を維持する校正公的機関等が行う必要があります。詳細については、ni.com/services/calibrationをご覧ください。

メモ メモ デバイスのキャリブレーションがパスワードで保護されている場合、キャリブレーション日およびキャリブレーション期日を変更するにはキャリブレーションパスワードを入力する必要があります。
  • キャリブレーション日―このデバイスの前回の外部キャリブレーション日が指定されます。
  • キャリブレーション期日―この製品のキャリブレーション期日を入力します。新製品の場合、推奨されるキャリブレーション間隔は、製品を受け取った日に始まります。デバイスが書き込み可能なキャリブレーションをサポートしない場合、次回のキャリブレーションの推奨日は次回キャリブレーション推奨日に表示されます。
  • デバイス温度―前回の調整中に搭載温度センサにより測定されたデバイス温度を表示します。この値は、調整が行われると自動的に設定されます。
  • パスワードを変更―デバイスのキャリブレーションパスワードを変更するためのダイアログボックスを表示します。

セルフキャリブレーション

セルフキャリブレーションは、デバイスに格納されている搭載基準に対してキャリブレーション定数を調節します。外部キャリブレーションを行った環境以外でデバイスを使用するのに、いつでもセルフキャリブレーションを行ってデバイスを調節することができます。

新しいセルフキャリブレーション定数は、外部キャリブレーション中の調整により作成されたキャリブレーション定数に対して設定されるため、測定値はそれらの外部基準に対して追跡可能となります。セルフキャリブレーション定数は、外部キャリブレーションにより作成された定数とは異なるデバイスメモリ領域に格納されるため、セルフキャリブレーション定数の調整は外部キャリブレーション定数には影響しません。

  • キャリブレーション日―このデバイスの前回のセルフキャリブレーション日が指定されます。
  • デバイス温度―前回のセルフキャリブレーション中に搭載温度センサにより測定されたデバイス温度を表示します。


MAXレポートウィザードを使用する

MAXレポートウィザードを使用して、ご使用のシステムまたはリモートシステムをドキュメント化したり、技術サポートのシステム情報レポートを生成することができます。レポートには、MAXで表示できるすべての構成情報のほかに、製品全体に共通の設定、ソフトウェア情報、キャリブレーション情報などMAXツリー構図には表示されない情報を含めることができます。各項目に含まれる構成レベルの詳細は、その項目のドライバソフトウェアにより異なります。

構成レポート

構成レポートを生成するには、MAXレポートウィザード（ファイル→レポートを作成のメニュー選択）を起動して以下の手順に従ってください。

  1. レポートでの詳細レベル（簡易レポートまたはカスタムレポート）を選択します。簡易レポートはMAXツリー項目名とアイコンのみで構成されます。カスタムレポートでは、ドキュメント化する項目を選択して、それらの項目の詳細レポートを受信できます。
    メモ レポートで参照できる詳細内容は、インストールされた各製品がこの機能をサポートしているかどうかにより異なります。製品がレポート生成をサポートしていない場合、カスタムレポートを選択した場合でも、レポートは基本的なデバイスリストのみ生成します。
  2. レポートを取得するシステム（ローカルシステムまたはリモートシステム）を選択します。一度に1つのシステムのみしか選択できません。また、リモートシステムのIPアドレスを入力することができます。Nextをクリックします。
  3. レポートに含む項目を選択します。Nextをクリックします。
  4. 生成されるファイルの場所を指定します。MAXレポートウィザードは最後に入力した場所を記憶します。MAXレポートウィザードを初めて実行する場合、ファイルの場所はデフォルトでDocuments¥MAXディレクトリに設定されます。
    メモ ファイル名には.htmまたは.htmlの拡張子が必要です。
  5. 次へをクリックしてレポートを生成します。選択したシステムの複雑度によって、MAXレポートウィザードが完了するまで2、3分の時間を要する場合があります。
  6. 最終のダイアログに生成されたファイルの情報が表示されます。終了をクリックしてウィザードを閉じ、デフォルトブラウザでレポートを起動します。ウィザードを閉じた直後にレポートを表示したくない場合は、ウィザードが終了したらレポートを表示のチェックマークを外してください。

    レポートを変更する場合、HTMLファイルを編集するか、またはHTMLファイルを別のエディタにコピー&ペーストすることができます。
    ヒント 1つのファイルにレポートを保存するには、Internet Explorerでレポートを開き、ファイル→名前を付けて保存メニュー項目を選択します。ファイルの種類選択ボックスでWebアーカイブ、単一のファイル (*mht)を選択して、保存をクリックします。Internet Explorerのみで結果のファイルを開くことができます。

システム情報レポート

技術サポートのシステム情報レポートを生成するには、MAXレポートウィザード（ファイル→レポートを作成）を起動して技術サポートレポートを選択します。

ウィザードは、生成されたレポートおよび他に追加したいファイルを含む圧縮ファイルを作成します。


システム構成API関数リファレンス

システム構成アプリケーションプログラミングインタフェース（API）は、LabVIEW、LabWindowsTM/CVITM、およびMicrosoft Visual Studio .NETの3つのADE（アプリケーションプログラミングインタフェース）をサポートします。

メモ メモ これらのAPIのサポート範囲は、各製品のドライバソフトウェアに応じて異なります。

システム構成APIはMAX構成APIの代わりとなるもので、機能をさらに拡張します。このAPIには、システム構成を保存、システム構成レポートを作成、およびシステム内のデバイスを検知するVIや関数が含まれます。また、ソフトウェアをリモートシステムにインストールしたり、リモートシステムでのソフトウェアの検知および構成を行うVIも含まれます。

システム構成APIヘルプファイルの場所

各ADEのヘルプファイルについては、ご使用のコンピュータ上で以下の場所を参照してください。

プラットフォーム | インストール後の場所
LabVIEW | <LABVIEW>/help/nisyscfg.chm
LabWindows/CVI | <National Instruments>/Shared/CVI/nisyscfg/nisyscfgCVI.chm
Microsoft Visual Studio .NET | <MeasurementStudio>/Help/NINETSystemConfig.hxs

メモ これらのヘルプファイルを取得するには、まずADEをインストールした後、NIデバイスドライバのメディアからMAXをインストールする際に、適切なADEサポートを選択する必要があります。


トラブルシューティング

MAXをトラブルシュートする場合は、以下のトピックを参照してください。

  • MAXを起動すると「MAXデータベース接続エラー」が発生する
  • デバイスがMAXに表示されない
  • ターゲットが「一致しないIP設定」状態を返す
  • Windowsファイアウォール
  • エラーログを表示する
  • デスクトップPCユーティリティUSBドライブ


デスクトップPCユーティリティUSBドライブ

デスクトップPCユーティリティUSBドライブは、ハードドライブにLabVIEW Real-TimeがインストールされていてUSBの使用が可能なデスクトップPC上での、メンテナンス操作の実行に使用します。

メモ
  • ブート可能なUSBドライブを使用する必要があります。
  • このユーティリティを作成するには、ホストコンピュータ上で管理者の特権を持っていなくてはなりません。

ホストPCまたはPXIシステムからデスクトップPCフォーマットハードドライブディスクを作成するには、以下の手順に従ってください。

  1. USBドライブをUSBポートへ接続します。
    メモ デスクトップPCユーティリティUSBドライブとして使用するUSBドライブにアクセスする、すべてのアプリケーションおよびウィンドウを閉じてください。USBドライブが他の処理で使用中ではないようにしてください。
  2. MAXから、ツール→デスクトップPCユーティリティUSBドライブを作成のメニュー項目を選択します。
  3. はいをクリックし、デスクトップPCユーティリティUSBドライブの作成を確認します。
  4. 使用するユーティリティのバージョンを選択し、OKをクリックします。
  5. フォーマットするUSBドライブを選択し、デスクトップPCユーティリティUSBドライブとしてフォーマットします。OKをクリックします。
    注意 USB上のデータはすべて上書きされます。
  6. 必要に応じて、この操作が選択したUSBドライブ上のすべてのデータを破棄することを確認してください。

デスクトップPCユーティリティUSBドライブを使用するには、このドライブをリモートシステムとして使用するデスクトップPC上の空いているUSBポートに接続します。リモートデスクトップPCをオンまたは再起動します。

メモ USBドライブからの起動を可能にするには、USBデバイスを使用するコンピュータのBIOSを設定する必要があります。ブートシーケンスを設定し、最初にUSBドライブ上のブートファイルを検索します。

デスクトップPCユーティリティUSBドライブに、以下のメニュー選択が表示されます。

  1. Boot using software installed on the hard-disk.
    ハードドライブ上にインストールされたNI Real-Timeソフトウェアを使用するシステムを起動します。ハードドライブ上にNI Real-Timeソフトウェアをインストールしていない場合、ユーティリティはシステムをセーフモードで起動し、ソフトウェアをインストールできるようにします。
  2. Boot into safe mode.
    システムをセーフモードで起動します。この選択は、システムのネットワーク設定の構成、およびシステムに対するソフトウェアのインストールに必要な最小単位のサービスを提供します。このモードは、ハードドライブ上にインストール済みのソフトウェアに利用することはできないため、ハードドライブからのソフトウェアの起動に問題がある場合には回復および構成モードとして便利です。
  3. Reset network configuration.
    システムのIPアドレス、サブネットマスク、ゲートウェイ、DNSアドレスをクリアします。ターゲットを再起動すると、ターゲットが自動IP割り当てをサポートしている場合にIPアドレスが自動的に取得されます。ターゲットが0.0.0.0のIPアドレスで起動する場合、ネットワーク設定を再構成する必要があります。
  4. Clear password.
    システムのパスワードが設定されている場合、このパスワードをクリアします。
  5. Disable LabVIEW Real-Time start-up application.
    LabVIEW Real-Timeのスタートアップアプリケーションが存在する場合、この選択はシステムの開始時にabVIEW Real-Timeのスタートアップアプリケーションの実行を回避します。このアプリケーションを無効にした後、再度使用可能にするためには、LabVIEW Real-Timeの開発環境を使用する必要があります。
  6. Format hard disk.
    システムのハードドライブを再フォーマットし、ハードドライブから直接NI Real-Timeソフトウェアを起動できるようにします。この操作はハードドライブ上にある現在のデータをすべて破棄します。システムは、フォーマット完了後にハードディスクから初めて起動する時に、セーフモードで起動します。自動IPアドレス割り当てをサポートしているターゲットで、IPアドレスが割り当てられます。自動IPアドレス割り当てをサポートしていないターゲットについては、フォーマット後に初めてハードドライブからシステムを起動すると、0.0.0.0のIPアドレスでセーフモードとして起動します。これで、システムのネットワーク設定の構成、ハードドライブへのソフトウェアのインストールを行うことができます。
  7. Evaluate system
    システムのハードウェア構成を評価し、システムがNI Real-Timeソフトウェアを実行できるかを判断します。
  8. Advanced Ethernet Options
    リアルタイムオペレーティングシステムがロードし、使用するインテルi8254xチップセットベースの追加のイーサネットデバイスを指定するホワイトリストを作成することができます。使用しないデバイスを指定するブラックリストも作成する必要があります。

    Real-Timeターゲットのc:¥ni-rt¥system¥ethernetディレクトリまたはセーフモードUSBドライブのルートディレクトリにある適切にフォーマットされたenetwhitelist.iniファイルを作成して、イーサネットのホワイトリストを有効にします。
    メモ メモ ホワイトリストを有効にしても、すべてのインテルi8254xチップセットが動作するわけではありません。セーフモードUSBドライブでイーサネットのホワイトリストを有効にするには、USBドライブが起動時のReal-Timeターゲットにある唯一のUSBデバイスである必要があります。
  9. Reboot the system
    NIリアルタイムシステムを再起動します。
  10. Backup, Restore, or Replicate the Real-Time system
    最新のUSBフラッシュドライブを使用したNI Real-Timeシステムのバックアップ、復元、コピーオプションを提供します。


MAXを起動すると「MAXデータベース接続エラー」が発生する

多くの問題がこのエラーの原因として考えられます。このエラーをトラブルシュートするには、以下の手順を実行してください。

  • ファイアウォールとウィルス対策設定を確認します。管理者としてログインし、MAXとNI System Web Serverをブロック解除する必要がある場合があります。
  • NI Configuration Managerサービスが開始していることを確認します。
    1. 管理者権限を持つユーザとしてログインします。
    2. スタート→コントロールパネル→管理ツール→サービスを選択します。
    3. NI Configuration Managerサービスを右クリックし、ドロップダウンメニューからプロパティを選択します。
    4. サービス状態が開始になっていることを確認します。なっていない場合は、開始ボタンを使用してサービスを開始します。
    5. MAXを再起動します。
  • NI Configuration Managerがサービスリストに表示されていない場合はMAXのインストールを修復します。
    1. スタート→コントロールパネル→プログラムの追加と削除を選択します。
    2. National Instrumentsを選択し、変更と削除をクリックします。
    3. リストからNI Measurement & Automation Explorerを選択し、修復をクリックします。

稀なケースでは、MAXデータベースの破損がこのエラーの原因である場合があります。MAXデータベースをリセットする方法については、技術サポートデータベースの記事4GA9TOQAを参照してください。


デバイスがMAXに表示されない

ローカルデバイス

リモートシステム

ローカルデバイス

ローカルデバイスがMAXに表示されない場合は、以下の手順を実行してトラブルシュートします。

  • デバイスがWindowsデバイスマネージャーに表示されることを確認します。表示されない場合は、デバイスとローカルシステム間の接続を確認します。
  • デバイスがWindowsデバイスマネージャーに表示される場合は、正しいドライバがインストールされていることを確認します。ドライバの最新バージョンは、ni.com/driversからダウンロードできます。
  • 正しいドライバがインストールされている場合は、NI Device Loaderサービスが実行していることを確認します。
    1. 管理者権限を持つユーザとしてログインします。
    2. (Windows 7) スタート→コントロールパネル→管理ツール→サービスを選択します。(Windows XP) スタート→コントロールパネル→管理ツール→サービスを選択します。
    3. NI Device Loaderサービスを右クリックし、ドロップダウンメニューからプロパティを選択します。
    4. サービス状態が開始になっていることを確認します。なっていない場合は、開始ボタンを使用してサービスを開始します。
  • 表示→更新を選択するか、<F5>キーを押し、MAXの構成ツリーを更新します。

リモートシステム

リモートシステムがMAXに表示されない場合は、以下の手順を実行してトラブルシュートします。

  • 表示→更新を選択するか、<F5>キーを押し、MAXの構成ツリーを更新します。
  • システムが、MAXを実行しているコンピュータと同じサブネット上にあることを確認します。
  • 新しいリモートシステムを作成します。


ターゲットが「一致しないIP設定」状態を返す

ターゲットがホストマシンに接続されていても一致しないIP設定状態を返す場合があります。これは、ターゲットのIPアドレスとサブネットマスクがホストのサブネットマスクで指定された範囲外にあるために起こります。

(Phar Lap ETS、VxWorks) ネットワークアダプタがDHCPを使用するよう設定されている場合、ネットワークケーブルを接続したターゲットを再起動してターゲットに新しいIPアドレスを割り当てるよう試みます。スタティックIPアドレスを使用している場合は、ターゲットのIPアドレスがホストのIPアドレスと同じサブネットになるように手動で変更し、IPアドレスの不一致を解決できます。TCP/IPアドレスおよびサブネットについての詳細は、Microsoftのサポートドキュメントを参照してください。

(NI Linux Real-Time) 下の手順に従ってターゲットのIP設定をリセットします。

  1. デバイスのRESETボタンを5秒間押し続けます。
  2. STATUS LEDが黄色に変わったらRESETボタンを放します。これによってセーフモードになります。
  3. RESETボタンを5秒間押し続けます。
  4. STATUS LEDが黄色に変わったらRESETボタンを放します。これによってデバイスはセーフモードになり、DHCPを使用するようIP設定をリセットします。


エラーログを表示する

リモートシステムのエラーログを表示するには、エラーログを表示を使用します。MAX内でログにアクセスするには、ご使用のリモートシステムを右クリックしてエラーログを表示を選択します。


Windowsファイアウォール

Windowsのファイアウォールをご使用の場合、MAXの以下の動作に注意してください。

Windowsのファイアウォールが有効になっているときに、LabVIEW Real-Timeターゲット上でソフトウェアをアップデートすると、MAXおよびNI System Web Serverがネットワークを介して情報を受信できるようにするダイアログボックスが表示されます。このプログラムをブロックしない を選択すると、MAXでLabVIEW Real-Timeターゲットと通信することができます。

Microsoft Windows 8とNI製品の関係の詳細については、ni.com/windows8を参照してください。Microsoft Windows 7とNI製品の関係の詳細については、ni.com/windows7を参照してください。

メモ ICFまたはWindowsファイアウォールを有効または無効にするには、ネットワーク管理者特権でログｲﾝする必要があります。


インストール済みの製品

このセクションはインストールされた製品に関するヘルプを表示します。製品リストが表示されていない場合、ヘルプ→ヘルプトピックメニューを参照して、その製品のヘルプファイル（利用可能な場合）を検索することができます。


法的情報

限定的保証

著作権

商標

特許

輸出関連法規の遵守に関する情報

NI製品を使用する際の警告


限定的保証

本書は、「現状有姿」（as is）で提供されており、事前の通知なしに次の改訂版で変更される場合があります。最新版については、ni.com/manualsをご参照ください。National Instruments Corporation（以下「NI」という）は、本書の技術的な正確性を入念にチェックしております。ただし、NIは、本書に記載の情報の正確性について、一切の明示又は黙示の保証を行わず、技術的な誤りについて一切の責任を負いません。

NIは、請求日から1年間、ハードウェア製品について、当該製品が適用あるNIの公表された仕様に実質的に適合しないこととなるような素材及び製造技術上の欠陥は存在しないことを保証します。

NIは、請求日から90日間、（ⅰ）ソフトウェア製品が適用される付属のマニュアル文書に実質的に従って機能し、かつ（ⅱ）当該ソフトウェアの媒体に素材及び製造技術上の欠陥が存在しないことを保証します。

NIが適用ある保証期間中に欠陥又は不適合の通知を受領した場合、NIはその裁量により、（ⅰ）問題のある製品を修理若しくは交換し、又は（ⅱ）問題のある製品の料金を払い戻します。修理又は交換後のハードウェアは、当初の保証期間の残期間又は90日間のうちいずれか長い期間について保証されます。NIが問題のある製品を修理又は交換することを選択する場合、NIは、新品、又は新品と同等の性能及び信頼性を有し、当初の部品又は製品と少なくとも同等の機能を有する整備済みの部品又は製品を使用することができます。

お客様は製品をNIに返却する前に、NIからRMA番号を取得する必要があります。NIは、限定的保証の対象外のハードウェアの検査及び試験についてその費用を請求する権利を留保します。

限定的保証は、NI製品の欠陥が次のいずれかの事柄に起因するものである場合には適用されません：（NI以外の者によって実施された）不適切又は不十分なメンテナンス、設置、修理又は校正、許可を受けていない改変、不適切な環境、不適切なハードウェア又はソフトウェア・キーの使用、製品の仕様の範囲を超えた不適切な使用又は操作。不適切な電圧の印加、事故、誤用又は不注意、雷、洪水又は他の天災等の災害。

上記の救済手段は排他的なものであり、お客様が有する唯一の救済手段です。また、これらの救済手段がその主要な目的を達成しえない場合であっても適用されます。

本書に明示に規定される場合を除いては、NI製品は、いかなる種類の保証も付されることなく、｢現状有姿｣（as is）で提供されます。NIは、NI製品に関するいかなる保証（商品性の黙示の保証、特定目的適合性、第三者の所有権その他の財産権を侵害していないこと、及び取引慣行又は取引過程により生じうるあらゆる保証を含みます）も、明示、黙示を問わず、行いません。NIは、正確さ、的確性、信頼性その他いかなる点についても、NI製品の使用又は使用結果に関して、保証せず、またいかなる表明も行いません。NIは、NI製品の稼働に中断がなく、又は誤作動がないことを保証しません。

お客様とNIがNI製品を対象とする保証条件について、別途署名又は記名押印済みの契約を締結している場合、当該契約書における保証条件が適用されます。


輸出関連法規の遵守に関する情報

NIの輸出関連法規遵守に対する方針について、また必要なHTSコード、ECCN (Export Control Classification Number)、その他の輸出入に関する情報の取得方法については、「輸出関連法規の遵守に関する情報」(ni.com/legal) を参照してください。


著作権

著作権法に基づき、National Instruments Corporationの書面による事前の許可なく、本書のすべて又は一部を写真複写、記録、情報検索システムへの保存、及び翻訳を含め、電子的又は機械的ないかなる形式によっても複製又は転載することを禁止します。

NIは他者の知的財産を尊重しており、お客様も同様の方針に従われますようお願いいたします。NIソフトウェアは著作権法その他知的財産権に関する法律により保護されています。NIソフトウェアを用いて他者に帰属するソフトウェアその他のマテリアルを複製することは、適用あるライセンスの条件その他の法的規制に従ってそのマテリアルを複製できる場合に限り可能であるものとします。

エンドユーザ使用許諾契約及び他社製品の法的注意事項

エンドユーザ使用許諾契約（EULA）及び他社製品の法的注意事項は以下の場所にあります。

  • 注意事項は、<National Instruments>¥_Legal Information及び<National Instruments>ディレクトリにあります。
  • EULAは、<National Instruments>¥Shared¥MDF¥Legal¥licenseディレクトリにあります。
  • NI製品で作成したインストーラに法律情報を組み込む方法については、<National Instruments>¥_Legal Information.txtを確認してください。

米国政府の権利の制限

お客様が米国政府の機関、省又はその他の事業体 (「米国政府」と総称する) である場合、本書に記載の技術データの使用、複製、再製、公表、修正、開示又は転送は、民間機関用の連邦調達規則52.227-14と軍事機関用の国防省連邦調達規則補足252.227-7014及び252.227-7015に基づく限定権利条項の適用を受けます。

IVI Foundation Copyright Notice

Content from the IVI specifications reproduced with permission from the IVI Foundation.

The IVI Foundation and its member companies make no warranty of any kind with regard to this material, including, but not limited to, the implied warranties of merchantability and fitness for a particular purpose. The IVI Foundation and its member companies shall not be liable for errors contained herein or for incidental or consequential damages in connection with the furnishing, performance, or use of this material.


商標

NIの商標の詳細については、ni.com/trademarksに掲載されているNI Trademarks and Logo Guidelinesを参照してください。

ARM, Keil, and µVision are trademarks or registered of ARM Ltd or its subsidiaries.

LEGO, the LEGO logo, WEDO, and MINDSTORMS are trademarks of the LEGO Group.

TETRIX by Pitsco is a trademark of Pitsco, Inc.

FIELDBUS FOUNDATION™ and FOUNDATION™ are trademarks of the Fieldbus Foundation.

EtherCAT® is a registered trademark of and licensed by Beckhoff Automation GmbH.

CANopen® is a registered Community Trademark of CAN in Automation e.V.

DeviceNet™ and EtherNet/IP™ are trademarks of ODVA.

Go!, SensorDAQ, and Vernier are registered trademarks of Vernier Software & Technology. Vernier Software & Technology and vernier.com are trademarks or trade dress.

Xilinx is the registered trademark of Xilinx, Inc.

Taptite and Trilobular are registered trademarks of Research Engineering & Manufacturing Inc.

FireWire® is the registered trademark of Apple Inc.

Linux® is the registered trademark of Linus Torvalds in the U.S. and other countries.

Handle Graphics®, MATLAB®, Simulink®, Stateflow®, and xPC TargetBox® are registered trademarks, and Simulink Coder™, TargetBox™, and Target Language Compiler™ are trademarks of The MathWorks, Inc.

Tektronix®, Tek, and Tektronix, Enabling Technology are registered trademarks of Tektronix, Inc.

The Bluetooth® word mark is a registered trademark owned by the Bluetooth SIG, Inc.

The ExpressCard™ word mark and logos are owned by PCMCIA and any use of such marks by National Instruments is under license.

The mark LabWindows is used under a license from Microsoft Corporation. Windows is a registered trademark of Microsoft Corporation in the United States and other countries.

本書中に記載されたその他の製品名及び企業名は、それぞれの企業の商標又は商号です。

NI Partnerは、NIより独立している事業体であり、NIと何ら代理店、パートナーシップ又はジョイントベンチャーの関係にありません。


特許

NI製品を保護する特許については、ソフトウェアで参照できる特許情報 (ヘルプ→特許)、メディアに含まれているpatents.txtファイル、又はni.com/patentsからアクセスできる「特許情報」のうち、該当するリソースから参照してください。


National Instruments Corporation製品を使用する際の警告

お客様は、National Instruments Corporation（以下「NI」という）の製品がお客様のシステム又はアプリケーションに組み込まれるかどうかにかかわらず常にNI製品の適合性及び信頼性（システム又はアプリケーションの適切な設計、プロセス及び安全性を含みます）を確認し、検証する最終的な責任を負います。

NI製品は、生命若しくは安全の維持に不可欠なシステム、危険な環境若しくはフェイル・セーフ機能が必要となる他のあらゆる環境(原子力施設の運用、航空機ナビゲーション、航空交通管制システム、救命若しくは生命維持システムその他の医療装置の運用若しくは操作を含みます)、又はこの製品の欠陥が死亡、傷害、重大な財産損害若しくは環境被害をもたらしうるその他あらゆる用途における使用（以下｢高リスク用途｣と総称する）のために設計、製造又は試験されたものではありません。さらに、故障・機能不全を防ぐために、バックアップ及びシャットダウン機構の準備などの慎重な処置を講じる必要があります。NIは、NI製品の高リスク用途への適合性について、明示又は黙示を問わず、いかなる保証も行いません。


MAXの技術サポート

MAX構成レポートでは、選択されたシステムのドキュメント化用のレポートおよび技術サポートの目的用のシステム情報レポートの2種類のレポートが作成できます。

構成レポート

MAXレポートウィザード（ファイル→レポートを作成）を起動して簡易またはカスタムを選択して、構成レポートを生成します。このウィザードは、HTMLベースで選択したシステム構成のレポートを作成します。詳細については、MAXレポートウィザードを使用するを参照してください。

システム情報レポート

MAXレポートウィザード（ファイル→レポートを作成）を起動して技術サポートを選択して、技術サポートのシステム情報レポートを作成します。ウェブベースのNI技術サポート/サポートリクエストサービスを使用する際にこれらのレポートを含めて、問題を素早く解決することができます。詳細については、MAXレポートウィザードを使用するを参照してください。

技術サポートのリソース

ソフトウェアの更新を確認するには、ドライバと更新にアクセスします。NI技術サポートおよびサービスの詳細については、技術サポートリソースを参照してください。


NIサービス

NIは、お客さまを成功に導く手助けとしてグローバルサービスとサポートを提供しています。デプロイメントや継続的メンテナンスにおける計画から開発などの、アプリケーションライフサイクルの各段階で役立つトレーニングおよび認定プログラムに加え、製品サービスもご利用ください。

製品のサービスを利用するには、アカウントを作成するか、ni.com/myproductsで自分のMyNIユーザプロファイルにログインして、お客様の製品をご登録ください。

登録されているNI製品をご使用のユーザには次の特典があります。

  • 適用される製品のサービスへのアクセス。
  • オンラインアカウントによる簡単な製品管理。
  • 製品に関する重要な通知、ソフトウェア更新、サービス期限の通知を受信。

サービスとリソース

  • メンテナンスとハードウェアサービス―NIは、ご使用のシステムの確度および信頼性の要件を確認する手助けや、製品の寿命期間にわたって確度を維持し、ダウンタイムを最小限に抑えることができるように、保証や予備製品およびキャリブレーションサービスを提供しています。詳細については、ni.com/servicesをご覧ください。
    • 保証と修理―すべてのNIハードウェア製品には、5年まで延長可能な1年の標準保証が提供されています。NIの修理サービスは、高度な訓練を受けた技術者によりNIサービスセンターで迅速に行われ、修理に際しては純正部品のみを使用しています。
    • キャリブレーション―標準のキャリブレーションを通じて、計測器の測定性能を定量化および改善することができます。NIでは、最新式のキャリブレーションサービスを提供しています。ご使用の製品でキャリブレーションがサポートされている場合は、ni.com/calibrationからその製品のCalibration Certificateを入手できます。
  • システムインテグレーション―時間の制約がある場合や社内の技術リソースが不足している場合、またはプロジェクトで簡単に解消しないなどの問題がある場合は、NIパートナーネットワークによるサービスをご利用いただけます。詳しくは、最寄りのNI営業所にお電話いただくか、ni.com/partnersをご覧ください。
  • トレーニングと認定―NIのトレーニングおよび認定プログラムは、アプリケーション開発の習熟度と生産性を高める最も効果的な方法です。詳細については、ni.com/trainingをご覧ください。
    • 「NI LabVIEWスキルガイド」は、現在のアプリケーションの習熟度要件の確認を手助けし、これらのスキルを習得するための時間や予算の制約と個人的な学習方法の好みに合ったオプションを提供しています。これらのカスタムパスを確認するには、ni.com/skills-guideを参照してください。
    • NIでは、お客様のニーズに応じて、講師による各国の施設でのクラスや、お客様の施設で行う出張コース、およびオンラインコースなど、複数の言語および形式のコースを提供しています。
  • サポート―技術サポート（ni.com/support）には以下のリソースがあります。
    • セルフヘルプリソース―質問に対する回答やソリューションが必要な場合は、ナショナルインスツルメンツのウェブサイト（ni.com/support）でソフトウェアドライバとアップデート、検索可能な技術サポートデータベース、製品マニュアル、トラブルシューティングウィザード、種類豊富なサンプルプログラム、チュートリアル、アプリケーションノート、計測器ドライバなどをご利用いただけます。ユーザ登録されたお客様は、NIディスカッションフォーラム（ni.com/jp/dforum）にアクセスすることもできます。NIのアプリケーションエンジニアは、お客様からのご質問すべてにお答えしています。
    • ソフトウェアサポートサービスメンバーシップ―標準サポート・保守プログラム（SSP）は、NI Developer Suiteを含む大部分のNIソフトウェア製品に含まれる、毎年更新が必要なプログラムです。このプログラムでは、NIのアプリケーションエンジニアによる電話またはEメールでの個別サポートが提供されます。また、SSPの特典を必要な限り中断なく利用できる柔軟な延長契約オプションもご利用いただけます。詳細については、ni.com/sspをご覧ください。
  • 適合宣言（DoC）―適合宣言とは、適合宣言書によるさまざまな欧州閣僚理事会指令への適合宣言です。この制度により、電磁両立性（EMC）に対するユーザ保護や製品の安全性に関する情報が提供されます。ご使用の製品の適合宣言は、ni.com/product-certificationsから入手できます。

ご利用の地域のその他の技術サポートのオプションについては、ni.com/jp/servicesをご覧いただくか、またはni.com/contactから最寄の営業所までお問い合わせください。

また、弊社ウェブサイトのWorldwide Officesセクション（ni.com/niglobal（英語））から各支社のウェブサイトにアクセスすることもできます。各支社のサイトでは、お問い合わせ先、サポート電話番号、Eメールアドレス、現行のイベントなどに関する最新情報を提供しています。


JavaScriptが無効にされています。


VI Logger

VI Loggerはソフトウエアユーティリティで、データログタスクの定義と実行に使用します。VI Loggerには以下の機能があります。

  • 新規のVI Loggerタスクを作成する
  • VI Loggerタスクを変更する
  • VI Loggerタスクを実行する
  • 集録およびログの実行中にデータを表示する
  • 記録したデータを表示する

お使いのVI LoggerはこのバージョンのMAXと互換性がありません。VI Loggerをバージョン1.0.2にアップグレードするには、ftp://ftp.ni.com/support/vilogger/upgrades/1.0.2/から使用可能なパッチをインストールしてください。


データ設定

データ設定は、使用するシステムで構成された物理チャンネルへの記述的な名前の付いたショートカットのアクセスを提供します。ショートカットには、CANメッセージ、NI-DAQ仮想チャンネルとタスク、FieldPoint項目が含まれます。

使用方法

新規のショートカットを作成する

新しいショートカットを作成するには、データ設定を右クリックし、新規作成を選択します。表示されるオプションは、インストールされているNI製品に応じて異なります。

ショートカットをテストまたは削除する

どのNI製品がインストールされているかによって異なりますが、通常はショートカットを右クリックするとタスクを実行できます。

プロパティを表示または変更する

通常、ツリー構図のこれらのショートカットを右クリックしてプロパティを選択します。また、ソフトウェアによっては、項目の表示からプロパティを調整します。

NI製品でデータ設定を使用する詳細については、ヘルプ→ヘルプトピックメニュー項目にある製品別のヘルプを参照してください。NI製品のヘルプは、『MAXヘルプ』からアクセスすることもできます。MAXヘルプはヘルプメニューから起動するか、または<F1>を押してください。


デバイスとインタフェース

デバイスとインタフェースには、インストール済みで検出されたCAN、DAQ、FieldPointシリアルコントローラ、GPIB、IVI、Motion、シリアル、VISA、Vision、VXIのハードウェアが表示されます。

デバイスが表示されない場合

ツリー構図が更新されていない

<F5>キーを押すか、または表示→更新を選択してください。

ユーザデバイスはWindowsプラグアンドプレイと互換性がない可能性があります

ユーザデバイス用の構成ヘルプファイルをヘルプ→ヘルプトピックメニューから参照するか、または以下の付加情報からデバイスの追加方法を確認してください。

使用方法

既存デバイスを構成する

既存のNIデバイスを構成するには、ツリー構図のデバイス名を右クリックし構成を選択するか、ツールバーの構成ボタン [image] をクリックします。または、ご使用のソフトウェアによっては項目表示でプロパティを調整します。

非プラグアンドプレイデバイスを追加する

デバイスの中にはWindowsプラグアンドプレイの互換性がないものがあります。その場合、デバイスはデバイスとインタフェースの項目に自動的には表示されません。他のデバイスは、ネットワーク上の他のコンピュータにあることがあります。非プラグアンドプレイデバイスを追加するには、ツリー構図のデバイスとインタフェースを右クリックし新規作成を選択します。ウィザードを完了してください。

インストールされているデバイスが表示されない場合には、ハードウェア添付のクイックスタートガイド(Getting Started Information)とMAX製品特定のヘルプ(ヘルプ→ヘルプトピック)を参照して、ハードウェアのインストールおよび構成情報が適切かどうかを確認してください。ハードウェアのインストールの確認後も問題がある場合は、弊社のオンラインサポートのWebページを参照してください。

CAN | DAQ | FieldPoint
GPIB | IVI | モジュール式計測器
Motion | NI Switch Executive | NI Vision
シリアル | VISA | VXI

MAXでNI製品を使用する詳細については、ヘルプ→ヘルプトピックメニュー項目にある製品別のヘルプを参照してください。NI製品のヘルプは、『MAXヘルプ』からアクセスすることもできます。MAXヘルプはヘルプメニューから起動するか、または<F1>を押してください。


履歴データ

履歴データの項目から、すべてのデータベース、記録したデータ、または「データビュー」にアクセスすることができます。

使用方法

データを表示する

データベースとデータビューを表示および管理するには、ツリー構図の履歴データを展開します。Citadel 5 Universeを選択すると、Databasesビューに使用中のデータベースが表示されます。Citadel 5 Universeの下にデータビューが表示されます。

データベースを作成する

新規の空データベースを作成するには、履歴データを右クリックして新規作成を選択します。新規作成ウィザードでCitadel 5 Databaseを選択して次へをクリックします。手順に従って新規データベースを作成して終了をクリックします。履歴データの下のCitadel 5 Universeを選択すると、Databasesビューに新規データベースが表示されます。

Citadel 4 DatabaseをCitadel 5フォーマットへ変換する

Citadel 4 databaseをCitadel 5フォーマットへ変換するには、履歴データを右クリックして新規作成を選択します。新規作成ウィザードでConvert Citadel 4 Database to Citadel 5を選択して次へをクリックします。手順に従って、変換するデータベースと変換されたデータベースの位置を選択し、終了をクリックします。

データベースを削除する

データベースを削除するには、Databasesビューでデータベースを右クリックしてDetach/Deleteを選択します。Detach/Delete DatabaseダイアログボックスでDeleteを選択し、OKをクリックします。

新しいデータビューを作成する

新規のdata viewを作成するには、Citadel 5 Universeを右クリックしてNew→Alarms/Events ViewまたはNew→Trace Viewを選択します。ツリー構図で、Citadel 5 Universeの下に新しいデータビューが表示されます。

Citadel 4データを表示する

Citadel 4データを表示する詳細については、『Historical Data Viewer Help』およびCitadel 4 viewsとデータベースのタスクリストを参照してください。『Historical Data Viewer Help』を開くには、ヘルプ→ヘルプトピック→Historical Data Viewerを選択します。

詳細については、ヘルプ→ヘルプトピック→Historical Data Viewerメニューからアクセスできる『Historical Data Viewer Help』を参照してください。


IVI

IVIの項目から、Logical Name Wizardおよびご使用のすべてのIVI Logical Nameへアクセスすることができます。Logical Nameは、特定の仮想計測器のリファレンスです。

使用方法

仮想計測器の論理名を作成する

ご使用の仮想計測器の論理名を作成するには、IVIの項目を展開します。ツリー構図のLogicalNames項目を右クリックしてInsertを選択します。ウィザードを完了してください。

ヒント 新規のIVI Logical Name、仮想計測器、計測器ドライバ、デバイスを作成するには、項目を右クリックしてInsertを選択します。たとえば、新規の計測器ドライバを作成するには、ツリー構図のInstrument Drivers項目を右クリックして、Specific Driver SectionでLogical Name Wizardを開くInsertを選択します。

既存の仮想計測器プロパティを変更する

既存の仮想計測器を構成するには、ツリー構図のVirtual Instruments項目を選択します。ツリー構図の右にある項目表示に、それまでのすべての仮想計測器が表示されます。項目表示の仮想計測器を右クリックしてPropertiesを選択します。

計測器を入れ替える

計測器を入れ替えるには、ツリー構図のLogical Names項目を選択します。項目表示から入れ替える計測器のLogical Nameを右クリックして、Propertiesを選択します。ダイアログボックスでChangeボタンをクリックして、新規の計測器用の仮想計測器を作成または選択します。


NI Measurement & Automation Explorer

Measurement & Automation Explorer (MAX) は、NI製品へのアクセスを提供します。

使用方法

デバイスとインタフェースを管理する

ツリー構図の左にあるデバイスとインタフェースを選択します。デバイスのインストール方法については、NIハードウェアに添付のクイックスタートガイド (Getting Started Information) を参照してください。

NIソフトウェアを管理する

ツリー構図の左にあるソフトウェアを選択します。

デバイスの仮想チャンネルまたはタスクを管理する

ツリー構図の左にあるデータ設定を選択します。

仮想計測器のスケールを作成する

ツリー構図の左にあるスケールを選択します。

IVI計測器ドライバを構成する

ツリー構図の左にあるIVIを選択します。

デバイス構成ファイルをインポートまたはエクスポートする

ファイル→インポートまたはファイル→エクスポートメニュー項目を選択して構成ファイルのインポートおよびエクスポートを行います。すべてのデバイスがサポートされているわけではありません。各製品のドキュメントを参照してください。

メモ ツリー構図の項目の中にはデバイス特有なものがあります。たとえば、IVIの項目はIVIがインストールされている場合にのみ表示されます。

MAXの使用に関する詳細情報については、ヘルプメニューから利用可能なヘルプ項目を選択してください。ユーザデバイスの詳細については、NIの技術サポートのウェブサイトを参照してください。

MAXのこのバージョンの詳細については、readmeを開くか、ni.com/infoにアクセスし、以下のInfo Codeを入力してください。

  • SysCfgFixList―改善点およびバグの修正
  • SysCfgKnownIssues―既知の問題


スケール

スケールから、集録されたデータに対して実行する操作のために構成したすべてのスケールにアクセスできます。

使用方法

新規のカスタムスケールを作成する

新しいカスタムスケールを作成するには、ツリー構図のスケールを右クリックして新規作成を選択します。

スケールを削除する

構成からスケールを削除するには、ツリー構図のスケール名を右クリックして削除を選択します。

スケールプロパティを表示または変更する

スケールのプロパティを表示または変更するには、ツリー構図にあるチャンネル名を右クリックしてプロパティを選択します。また、ソフトウェアによっては構成の表示からプロパティを調整することもできます。

NI製品でスケールを使用する詳細については、ヘルプ→ヘルプトピックメニュー項目にある製品特定のヘルプを参照してください。NI製品のヘルプは、『MAXヘルプ』からアクセスすることもできます。MAXヘルプはヘルプメニューから起動するか、または<F1>を押してください。


ソフトウェア

ソフトウェアの項目ではインストールされているNIソフトウェアの表示、起動、更新ができます。

使用方法

ソフトウェア情報を表示する

ツリー構図のソフトウェアを展開します。

ソフトウェアを起動する

ツリー構図の製品名を右クリックして起動を選択します。

ソフトウェアを追加、変更、または削除する

ソフトウェアの変更と削除ボタンをクリックして、NIのソフトウェアを修正またはアンインストールするためのユーティリティを起動します。

ソフトウェアの更新を確認する

ツリー構図のソフトウェアを右クリックしてソフトウェアの更新を取得を選択します。NI更新サービスは、ご使用のソフトウェアの最新のリリースまたは更新について、NIのウェブサイトを検索して検索結果を返します。表示されたリストからダウンロードおよびインストールするソフトウェアを決定してください。また、ヘルプメニュー、またはソフトウェア項目ノードからもソフトウェアを更新できます。

NI更新サービスに表示されないソフトウェアの更新を確認する場合、ni.com/updatesのドライバと更新ページを参照してください。

NI製品の詳細については、ヘルプ→ヘルプトピックメニュー項目にある製品別のヘルプを参照してください。NI製品のヘルプは、『MAXヘルプ』からアクセスすることもできます。MAXヘルプはヘルプメニューから起動するか、または<F1>を押してください。


VI Logger

VI Loggerはソフトウエアユーティリティで、データログタスクの定義と実行に使用します。VI Loggerのライトパッケージは、NI-DAQmxデバイスの基本的なデータロギングおよび集録のツールを提供します。VI Loggerのフルパッケージには、NI-DAQmx、従来型NI-DAQ（レガシー）、FieldPointの各デバイスの追加機能が含まれます。

使用方法

新規のVI Loggerタスクを作成する

新規VI Loggerタスクを作成するには、MAXツリー構図のVI Logger Tasksを右クリックしてCreate Newを選択します。Create Newダイアログボックスから、タスク（Using NI-DAQmx、Using Traditional NI-DAQ、Using FieldPoint）で使用するデバイスのタイプを選択します。Finishボタンをクリックします。新規に作成されたタスクがツリー構図のVI Logger Tasksの下に表示されます。Task Attributesの表示、およびDAQmxチャンネル、仮想チャンネル、またはFieldPointチャンネルの表示を使用して、タスク設定を構成します。

VI Loggerタスクを変更する

タスクを変更するには、ツリー構図で変更するタスクを選択し、そのタスクのタブ付きVI Loggerウィンドウを表示します。停止および開始の条件、ロギングの条件、またはデータのエクスポート設定を編集することができます。Save Taskボタンをクリックして変更を保存します。

VI Loggerタスクを実行する

Task Attributesの表示のコントロールを使用して、VI Loggerタスクの集録およびロギングの条件を設定します。タスクを実行するには、ツリー構図からタスクを選択してツールバーのRun Taskボタンをクリックします。タスクに停止条件を指定しない場合、Stop taskボタンをクリックしない限り、タスクは手動で実行されます。

集録中およびロギング中にデータを表示する

Real Time Dataの表示を使用して、VI Loggerタスクの実行中にグラフィカルにデータを表示します。Real Time Dataの表示の左上隅でLED表示器 [image] を使用し、リアルタイムデータの表示から履歴データの表示に切り替えます。履歴データをスクロールできるように、赤いライトをクリックしてグラフを一時停止します。緑のライトをクリックして、リアルタイムデータの表示に戻リます。グラフの上の4つの矢印ボタンを使用して、VI Loggerがデータを集録した後にデータをスクロールします。

記録したデータを表示する

VI Loggerでデータを記録した後、VI Loggerはツリー構図内の関連タスクの下に表示されるデータをタスク実行に保存します。タスク実行のデフォルト名は、データロギングが開始された日付と時間です。表示するタスク実行をクリックします。タスク実行からデータのグラフを表示するには、履歴データの表示を使用します。グラフの上の4つの矢印ボタンを使用して、記録されたデータをスクロールします。

VI Loggerのライトパッケージからフルパッケージをアクティブ化する

ライトパッケージから、Tools→VI Logger→Activate All VI Logger 2.0 Featuresを選択します。ダイアログボックスから、Purchase Licenseボタンをクリックしてソフトウェアライセンスを購入できるウェブページを表示します。Activate Licenseボタンをクリックしてソフトウェアをアクティブ化します。VI Loggerフルパッケージをアクティブ化するには、有効なシリアル番号が必要になります。