Hilfe zum Measurement & Automation Explorer

Juli 2021, 370694W-0113

Im Measurement & Automation Explorer (MAX) können Sie:

  • Ihre Hard- und Software von NI konfigurieren
  • Sicherungskopien der Konfigurationsdaten anlegen
  • Kanäle, Tasks, Schnittstellen, Skalierungen und virtuelle Instrumente erstellen und bearbeiten
  • Systemdiagnosen ausführen
  • Mit dem System verbundene Geräte anzeigen
  • Software von NI aktualisieren

Weitere Informationen finden Sie unter folgenden Themen:

Rechtliche Hinweise

NI-Serviceleistungen

© 2004–2021 National Instruments Corporation. Alle Rechte vorbehalten.

Informationen zu NI-Urheberrechten, Patenten, Marken, Gewährleistungen, Produktwarnungen und zu den von NI eingehaltenen Exportbestimmungen erhalten Sie im Verzeichnis <National Instruments>\_Legal Information.


Übersicht über den MAX

Der Measurement & Automation Explorer (MAX) ermöglicht den Zugriff auf alle Geräte und Systeme von NI.

Mit dem MAX können Sie:

  • Ihre Hard- und Software von NI konfigurieren
  • Kanäle, Tasks, Schnittstellen, Skalierungen und virtuelle Instrumente erstellen und bearbeiten
  • Systemdiagnosen ausführen
  • Mit dem System verbundene Geräte anzeigen
  • Software von NI aktualisieren

Neben den Standardwerkzeugen kann der MAX auch je nach installierten NI-Produkten spezielle Werkzeuge enthalten, beispielsweise zur Konfiguration, Diagnose oder zum Testen eines Systems. Wenn Sie eine neue Komponente im MAX erstellen oder installieren, ändern sich die Menüs und die Symbolleiste entsprechend.

Für allgemeine Informationen zu jedem Menüpunkt klicken Sie auf die untenstehenden Links. Gerätespezifische Hinweise finden Sie in der jeweiligen Produkthilfe im Menü Hilfe.

  • Menü "Datei"
  • Menü "Bearbeiten"
  • Menü "Ansicht"
  • Menü "Werkzeuge"
  • Menü "Hilfe"
  • Hinweise


MAX-Menü "Datei"

Im Menü Datei gibt es folgende Optionen:

Neu»Fenster: Öffnet den Measurement & Automation Explorer (MAX) noch einmal in einem separaten Fenster.

Alle speichern: Speichert alle ungespeicherten Änderungen im MAX.

Protokoll erstellen: Startet den MAX-Protokollassistenten. Mit Hilfe des Assistenten zur Protokollerstellung können Sie einen druckbaren Bericht des lokalen Systems oder Netzwerksystems einschließlich der Systemkonfiguration erstellen.

Importieren: Startet den Assistenten zum Import von Konfigurationsdateien. Mit Hilfe dieses Assistenten können Sie eine Konfigurationsdatei importieren.

Exportieren: Startet den Assistenten zum Export von Konfigurationsdateien. Mit Hilfe dieses Assistenten können Sie eine Konfigurationsdatei exportieren.

Beenden: Beendet den MAX.


MAX-Menü "Bearbeiten"

Im Menü Bearbeiten gibt es folgende Optionen:

Rückgängig: Macht den letzten Arbeitsvorgang wieder rückgängig. Dieser Menüpunkt ist nur aktiviert, wenn er von der ausgewählten Komponente unterstützt wird.

Wiederherstellen: Stellt den letzten Arbeitsvorgang wieder her. Dieser Menüpunkt ist nur aktiviert, wenn er von der ausgewählten Komponente unterstützt wird.


MAX-Menü "Ansicht"

Im Menü Ansicht gibt es folgende Optionen:

Symbolleiste: Enthält folgende Optionen zur Darstellung der Symbolleiste:

  • Beschriftungen unten: Beschriftungen werden unter den Symbolen der Symbolleiste angezeigt.
  • Beschriftungen rechts: Beschriftungen werden rechts neben den Symbolen der Symbolleiste angezeigt.
  • Keine Beschriftungen: Es werden nur die Symbole angezeigt.

Statusleiste: Blendet die Statusleiste am unteren Rand des MAX-Fensters ein oder aus.

Konfiguration: Blendet die Baumstruktur ein oder aus.

Hilfefenster: Blendet die Hilfe im MAX ein oder aus. Alternativ kann auch die Schaltfläche "Hilfe einblenden/ausblenden" angeklickt werden.

Aktualisieren: Lädt die Ansicht der MAX-Konfiguration neu. Alternativ kann auch die Taste <F5> betätigt werden.


MAX-Menü "Werkzeuge"

Im Menü Werkzeuge gibt es folgende Standardoptionen:

NI-Netzwerkbrowser: Öffnet den NI-Netzwerkbrowser, mit dessen Hilfe Sie Netzwerkgeräte von NI automatisch über einen Webbrowser erkennen und konfigurieren können.

NI-Registrierungsassistent: Hilft Ihnen bei der Auffindung und Registrierung Ihrer Produkte von NI für besseren technischen Support und um sicherzustellen, dass Sie wichtige Produkt-Updates erhalten. Alle Ihre Angaben werden gemäß dem NI Privacy Statement auf ni.com/legal behandelt.

Real-Time Hypervisor Manager: Konfiguriert und verwaltet ein Real-Time-Hypervisor-System. Der Real-Time Hypervisor Manager enthält eine Benutzeroberfläche zum Konfigurieren der erforderlichen Hypervisor-Einstellungen, wie z. B. Interrupt-Leitungen und Betriebssystemzuweisungen für die Hardware im System. Weitere Informationen zum Real-Time Hypervisor finden Sie in der Hilfe zum Real-Time Hypervisor unter Start»Alle Programme»National Instruments»Real-Time Hypervisor»Real-Time Hypervisor Help.

Hinweis Hinweis Der Menüpunkt Real-Time Hypervisor Manager wird nur angezeigt, wenn die Komponente installiert ist.

Desktop-PC-Utility für USB-Laufwerk erstellen: Formatiert ein USB-Laufwerk mit einem LabVIEW-Real-Time-USB-Boot-Hilfsprogramm auf einem USB-bootfähigen Desktop-PC.

Konfigurationsdaten zurücksetzen: Setzt alle Konfigurationsdaten von NI auf dem System zurück.

Achtung Achtung Vor dem Verwenden von Produkten von NI muss das System neu gestartet werden. Wenn Sie nach Auswahl der Option Konfigurationsdaten zurücksetzen keinen Neustart durchführen, können Schäden an den Produkten von NI entstehen.

Neben den Standardwerkzeugen kann der MAX auch je nach installierten NI-Produkten spezielle Werkzeuge enthalten, beispielsweise zur Konfiguration, Diagnose oder zum Testen eines Systems. Wenn Sie eine neue Komponente im MAX erstellen oder installieren, ändern sich die Menüs entsprechend.


MAX-Menü "Hilfe"

Im Menü Hilfe gibt es folgende Optionen:

MAX-Hilfe: Öffnet die Hilfe zum MAX und seinen Funktionen. Alternativ kann auch die Taste <F1> betätigt werden.

Hilfethemen: Zeigt MAX-Hilfen zu verschiedenen Produkten an. Die Hilfethemen richten sich nach den installierten Produkten von NI.

NI im Web: Ermöglicht die Anzeige bestimmter Informationen auf der Website von NI ni.com. Hier finden Sie zum Beispiel technische Unterstützung.

Technische Unterstützung: Führt zu Informationen und Links zur technischen Unterstützung zum MAX.

Systeminformationen: Zeigt Angaben zum Betriebssystem an (z. B. Version, Prozessor, RAM oder installierte Programme von NI). Klicken Sie auf die Schaltfläche Alle kopieren, um die Angaben in die Zwischenablage zu kopieren und anschließend in ein Dokument einzufügen.

Updates suchen: Startet den NI-Update-Dienst, mit dem nach neueren Produktversionen und Updates gesucht werden kann. Mit dem NI-Update-Dienst können Sie Ihr System einfach und schnell auf den neuesten Stand bringen.

Patente: Zeigt Patentinformationen für NI-Produkte an.

Info: Öffnet ein Fenster mit dem Titel Measurement & Automation Explorer, in dem die verwendete Version und ein Hinweis zum Urheberrecht angezeigt werden.

Neben den Standardwerkzeugen kann der MAX auch je nach installierten NI-Produkten spezielle Werkzeuge enthalten, beispielsweise zur Konfiguration, Diagnose oder zum Testen eines Systems. Wenn Sie eine neue Komponente im MAX erstellen oder installieren, ändern sich die Menüs und die Symbolleiste entsprechend.


Hinweise zur Arbeit mit dem MAX

Hinweise zum MAX

Die folgenden Hinweise sollen Ihnen den Umgang mit dem MAX erleichtern:

  • Aktualisierung der Anzeige: Zur Aktualisierung der Anzeige nach dem Anschließen von Hardware oder Hinzufügen einer Schnittstelle klicken Sie auf den Menüpunkt Ansicht»Aktualisieren oder drücken Sie <F5>. Die meisten Geräte und Schnittstellen werden automatisch aktualisiert.
  • Anzeige mehrerer Ansichten: Eine Registerkarte mit der Einzelansicht zum jeweils ausgewählten Objekt kann aus der MAX-Oberfläche auf den Desktop gezogen werden, so dass sich mehrere Einzelansichten nebeneinander anordnen lassen. Die Einzelansicht ist das mittlere Fenster mit den Registerkarten, das nach Anklicken eines Geräts in der Baumstruktur erscheint. Darin sind in der Regel die Einstellungen zum Gerät zu sehen. Um den Ausgangszustand wiederherzustellen, schließen Sie das Fenster oder ziehen Sie es in die Nähe seiner ursprünglichen Position zurück.
  • Beibehalten von Ansichten: Klicken Sie in der Symbolleiste auf die Reißzwecke [image], um eine vom MAX losgelöste Ansicht geöffnet zu lassen, während Sie andere Komponenten der Baumstruktur anklicken.
  • Anzeige der Hilfe: Mit der Schaltfläche Hilfe einblenden/ausblenden, die sich über dem rechten Fenster befindet, kann die Hilfe ein- und ausgeblendet werden. Wenn Sie auf das Symbol [image] über dem rechten Hilfefenster klicken, wird die Hilfe in einem kleineren Fenster geöffnet, das beliebig auf dem Bildschirm verschoben werden kann. Um den Ausgangszustand wiederherzustellen, klicken Sie das Symbol noch einmal an.
  • Gleichzeitige Konfiguration von Geräten: Wenn mehrere Geräte oder Systeme gleichzeitig konfiguriert werden sollen, erstellen Sie über Datei»Neu»Fenster ein neues Fenster oder fixieren Sie mit dem Reißzweckensymbol eine Ansicht auf dem Bildschirm.
  • Auswahl mehrerer Baumstrukturkomponenten: Sie können in der Baumstruktur mehrere Objekte gleichzeitig auswählen, indem Sie während der Auswahl die Tasten <Strg> oder <Shift> gedrückt halten. Die rechte Ansicht wird dabei gelöscht.

    Wenn Sie mehrere Komponenten ausgewählt haben, auf die Batch-Befehle anwendbar sind, dann werden in der Symbolleiste Schaltflächen angezeigt und die Objekte haben ein Kontextmenü, das durch einen Rechtsklick auf eines der Objekte geöffnet werden kann. Ansonsten gibt es weder eine Symbolleiste noch Kontextmenüs. Batch-Befehle können auf mehrere Objekte gleichzeitig angewandt werden.

Kategorien im MAX

Im MAX gibt es folgende sechs Hauptkategorien:

  • Datenumgebung: Hier werden virtuelle Kanäle, Tags und Aliasnamen für Ihre Kanäle oder Messungen erstellt, die unter "Geräte und Schnittstellen" konfiguriert wurden.
  • Geräte und Schnittstellen: Hier werden die Ressourcen und andere physikalische Eigenschaften Ihrer Geräte und Schnittstellen festgelegt.
  • Skalierungen: Hier kann festgelegt werden, wie die aufgenommenen Messwerte zu verarbeiten sind.
  • Software: Hier werden Informationen zu Ihrer Software von NI angezeigt und es ist möglich, diese zu starten und zu aktualisieren.
  • IVI: Hier werden IVI-konforme Geräte (IVI 1.x) oder IVI-Treiber (ab IVI 2.0) konfiguriert.
  • Netzwerkumgebung: Hier werden alle Systeme konfiguriert, die via Ethernet mit Ihrem Rechner verbunden sind.


Hinzufügen von Netzwerkgeräten

Netzwerkgeräte enthält Netzwerkgeräte und drahtlose Geräte, die für dieses System zur Verfügung stehen. Mit der Option "Netzwerkgeräte" können Sie über ein Netzwerk verbundene Geräte anzeigen und konfigurieren.

Netzwerkgeräte

Ein Netzwerkgerät ist ein Gerät, auf das über ein Netzwerk oder eine drahtlose Verbindung zugegriffen werden kann. Der Zugriff auf solche Geräte kann von mehreren Rechnern erfolgen. Diese Geräte führen keine Echtzeitbetriebssysteme aus. Netzwerkgeräte unterscheiden sich von Netzwerksystemen. Ein Netzwerksystem ist ein Echtzeitsystem, das über ein Netzwerk verwaltet oder konfiguriert werden kann. Ein Netzwerkgerät kann dagegen kein Echtzeitbetriebssystem ausführen.

Hinweis Hinweis Diese Komponente wird nur von NI-VISA ab Version 4.6 und NI-DAQmx ab Version 9.0 unterstützt. Geräte, die diese Komponente nicht unterstützen, werden direkt unter Geräte und Schnittstellen angezeigt.

Hinzufügen eines Netzwerkgeräts

Wird ein Netzwerkgerät nicht in dieser Liste angezeigt, klicken Sie auf Netzwerkgerät hinzufügen und wählen Sie die Art des Geräts aus, das hinzugefügt werden soll. Folgen Sie den Anweisungen des Assistenten zum Hinzufügen eines Netzwerkgeräts.

Hinweis Hinweis Zum Hinzufügen von Geräten zum MAX, die die Option "Netzwerkgeräte" nicht unterstützen, klicken Sie mit der rechten Maustaste auf Geräte und Schnittstellen und wählen Sie Neu.

Welche Schritte zum Installieren von Netzwerkgeräten erforderlich sind, erfahren Sie in der Dokumentation zum System.


Gerätekalibrierung

Grundlegende Kalibrierangaben für Ihr Gerät werden in den Abschnitten Externe Kalibrierung und Selbstkalibrierung auf der Registerkarte Systemeinstellungen angezeigt.

Hinweis Kalibriereigenschaften sind schreibgeschützt, wenn Ihr Gerät das Schreiben in die Kalibrierung in MAX nicht unterstützt.

Externe Kalibrierung

Eine externe Kalibrierung (Eichung) muss unter hochgenauer Einhaltung bestimmter Eichstandard durchgeführt werden. Die externe Kalibrierung eines Geräts besteht aus folgenden Schritten:

  1. Die Leistung des Geräts wird mit hochgenauen externen Eichstandards verglichen.
  2. Wenn das Gerät nicht in dem durch die externen Eichstandards vorgegebenen Bereich funktioniert wird eine Anpassung vorgenommen. Während einer solchen Anpassung werden neue Kalibrierkonstanten in einem Bereich des Gerätespeichers abgelegt, der für den Anwender schreibgeschützt ist. Auf diese Weise bleibt die Kalibrierung nachvollziehbar.
  3. Nach der Anpassung wird die Leistung des Geräts erneut mit hochgenauen externen Eichstandards verglichen.

Eine Eichung darf nur von einem Messinstitut oder einer anderen Institution mit offiziellen Eichstandards vorgenommen werden. Weitere Informationen finden Sie auf der Website ni.com/calibration.

Hinweis Hinweis Wenn die Kalibrierung des Geräts durch ein Passwort geschützt ist, muss das Kalibrierpasswort erneut eingegeben werden, um Änderungen an Datum der Kalibrierung und Fälligkeitsdatum der Kalibrierung zu speichern.
  • Datum der Kalibrierung—Gibt das Datum der letzten externen Kalibrierung für das Gerät an.
  • Fälligkeitsdatum der Kalibrierung—Geben Sie das Datum ein, an dem dieses Produkt kalibriert werden soll. Bei neuen Produkten beginnt das empfohlene Kalibrierintervall mit dem Erhalt des Produkts. Wenn Ihr Gerät das Schreiben in die Kalibrierung nicht unterstützt, wird das empfohlene Datum für die nächste Kalibrierung im MAX unter Nächste Kalibrierung (empfohlen) angezeigt.
  • Gerätetemperatur—Zeigt die Temperatur des Geräts an, die während der letzten Anpassung von einem geräteeigenen Sensor gemessen wurde. Dieser Wert wird automatisch während der Anpassung eingestellt.
  • Passwort ändern—Zeigt ein Dialogfeld an, mit dem Sie das Kalibrierpasswort für das Gerät ändern können.

Selbstkalibrierung

Bei der Selbstkalibrierung werden die auf dem Gerät gespeicherten Kalibrierkonstanten einer neuen Umgebung entsprechend angepasst. Eine Selbstkalibrierung ist jederzeit möglich und dient dazu, ein Gerät an Umgebungen anzupassen, für die es ursprünglich nicht kalibriert wurde.

Die neuen Konstanten für die Selbstkalibrierung beziehen sich immer auf die Werte, die während der Anpassung bei der Eichung des Geräts festgelegt wurden. Dadurch wird gewährleistet, dass die Messergebnisse den Eichstandards entsprechend nachprüfbar sind. Die angepassten Konstanten für die Selbstkalibrierung überschreiben die bei der externen Kalibrierung festgelegten Konstanten jedoch nicht, da sich diese in einem anderen Bereich des Gerätespeichers befinden.

  • Datum der Kalibrierung—Zeigt das Datum der letzten Selbstkalibrierung für das Gerät an.
  • Gerätetemperatur—Zeigt die Temperatur des Geräts an, die während der letzten Selbstkalibrierung von einem geräteeigenen Sensor gemessen wurde.


Umgang mit dem MAX-Protokollassistenten

Mit dem MAX-Protokollassistenten können Sie Ihr System oder ein System im Netzwerk dokumentieren oder eine Zusammenfassung der Systemangaben zur technischen Unterstützung zusammenstellen. Die Zusammenfassung kann alle Konfigurationsdaten enthalten, die im MAX sichtbar sind, sowie Informationen, die der MAX-Übersicht nicht direkt zu entnehmen sind, zum Beispiel für mehrere Produkte geltende Einstellungen, Informationen zur Software oder Kalibrierdaten. Der Umfang der Informationen hängt von der Treibersoftware der jeweiligen Komponenten ab.

Konfigurationsprotokolle

Zur Zusammenstellung der Konfigurationsdaten starten Sie den MAX-Protokollassistenten über Datei»Protokoll erstellen und gehen nach folgenden Schritten vor:

  1. Wählen Sie aus, ob ein Einfaches Protokoll oder ein Benutzerdefiniertes Protokoll erstellt werden soll. In einem einfachen Protokoll sind nur die Komponenten der Baumstruktur mit den dazugehörigen Symbolen enthalten. Bei einem benutzerdefinierten Protokoll können Sie selbst bestimmen, welche Komponenten mit welchen Einzelheiten aufgenommen werden sollen.
    Hinweis Wie detailliert die Angaben sind, richtet sich danach, ob das Produkt diese Funktion unterstützt. Wenn das Produkt diese Funktion nicht unterstützt, ist im Protokoll auch bei Auswahl von Benutzerdefiniertes Protokoll nur eine einfache Liste von Geräten enthalten.
  2. Wählen Sie aus, ob das Protokoll für Ihr lokales System oder ein Netzwerksystem erstellt werden soll. Es kann immer nur ein System ausgewählt werden. Systeme in der Netzwerkumgebung können auch durch die IP-Adresse angegeben werden. Klicken Sie auf Weiter.
  3. Wählen Sie die Komponenten aus, die in das Protokoll aufgenommen werden sollen. Klicken Sie auf Weiter.
  4. Geben Sie den Pfad für die Dateien an, die erstellt werden sollen. Als Voreinstellung wird immer der zuletzt eingegebene Pfad angezeigt. Wenn Sie zum ersten Mal mit dem Protokollassistenten arbeiten, führt der Pfad zum Verzeichnis Eigene Dokumente\MAX.
    Hinweis Der Dateiname muss entweder die Erweiterung .htm oder .html haben.
  5. Klicken Sie zum Fortfahren auf Weiter. Die Erzeugung des Protokolls kann bei einer großen Anzahl von Geräten einige Minuten in Anspruch nehmen.
  6. Abschließend sehen Sie ein Dialogfeld, in dem angezeigt wird, welche Dateien erstellt wurden. Zum Schließen des Assistenten und Öffnen des Protokolls in Ihrem Standardbrowser klicken Sie auf Beenden. Deaktivieren Sie die Option Protokoll nach dem Schließen des Assistenten anzeigen, wenn das Protokoll nicht sofort nach dem Schließen des Assistenten angezeigt werden soll.

    Zum Ändern des Protokolls können Sie die entweder den Quelltext der HTML-Datei anzeigen oder ihn in einen HTML-Editor einfügen.
    Tipp Um das Protokoll in einer Datei zusammenzufassen, öffnen Sie es im Internet Explorer und klicken Sie auf Seite»Speichern unter. Wählen Sie unter Dateityp die Option Webarchiv, einzelne Datei (*.mht) aus und klicken Sie auf Speichern. Die erzeugte Datei kann allerdings nur mit dem Internet Explorer geöffnet werden.

Protokolle mit Systemangaben

Um alle relevanten Angaben für den technischen Support zusammenzufassen, starten Sie den MAX-Protokollassistenten über Datei»Protokoll erstellen und wählen Sie Protokoll für technische Unterstützung.

Nach Abschluss des Assistenten erhalten Sie eine komprimierte Datei mit den Systemdaten und allen anderen Dateien, die Sie hinzugefügt haben.


Funktionenübersicht zur API des Systemkonfigurators

Die API des Systemkonfigurators (Application Programming Interface - Programmieroberfläche) unterstützt drei verschiedene Entwicklungsumgebungen: LabVIEW, LabWindowsTM/CVITM und Microsoft Visual Studio .NET.

Hinweis Hinweis Die Unterstützung für diese APIs richtet sich nach der Treibersoftware des Geräts.

Die API des Systemkonfigurators ersetzt die MAX-Konfigurations-API und bietet einen erweiterten Funktionsumfang. Diese API enthält VIs und Funktionen zum Speichern von Systemkonfigurationen und Erstellen von Systemkonfigurationsprotokollen sowie neue VIs und Funktionen zum Erkennen von Geräten in Ihrem System. Außerdem enthält die API VIs zum Erkennen, Konfigurieren und Installieren von Software auf Systemen im Netzwerk.

Speicherorte für die Hilfedatei der API des Systemkonfigurators

Die Hilfedatei für die jeweilige Entwicklungsumgebung finden Sie unter:

Plattform | Speicherort nach Installation
LabVIEW | <LABVIEW>/help/nisyscfg.chm
LabWindows/CVI | <National Instruments>/Shared/CVI/nisyscfg/nisyscfgCVI.chm
Microsoft Visual Studio .NET | <MeasurementStudio>/Help/NINETSystemConfig.hxs

Hinweis Diese Hilfedateien stehen nur zur Verfügung, wenn zuerst die Entwicklungsumgebung und dann bei der Installation des MAX von der CD/DVD mit den NI-Gerätetreibern die Unterstützung für diese Entwicklungsumgebung ausgewählt wird.


Fehlersuche

Folgende Themen können bei der Fehlersuche im MAX hilfreich sein:

  • Ich erhalte einen "Fehler bei Verbindung mit MAX-Datenbank" beim Start von MAX
  • Mein Gerät wird nicht im MAX angezeigt
  • Mein Zielsystem gibt den Status "Inkonsistente IP-Einstellungen" aus
  • Windows-Firewall
  • Anzeigen von Fehlerprotokollen
  • Desktop-PC-Utility für USB-Laufwerke


Desktop-PC-Utility für USB-Laufwerke

Mit der Utility-Diskette für Desktop-PCs mit USB-Laufwerk können Sie Desktop-PCs mit USB-Anschluss instand halten, auf denen LabVIEW Real-Time läuft.

Hinweise
  • Es muss sich um ein bootfähiges USB-Gerät handeln.
  • Zur Erstellung des Hilfsprogramms benötigen Sie auf dem Host-Computer Administratorrechte.

Gehen Sie zum Erstellen einer Utility-Diskette für Ihren Host-PC oder Ihr PXI-System mit USB-Anschluss wie folgt vor:

  1. Verbinden Sie ein USB-Laufwerk mit einem der USB-Anschlüsse.
    Hinweis Schließen Sie alle Anwendungen und Fenster mit Zugriff auf das USB-Laufwerk, das für das Utility verwendet werden soll. Das USB-Laufwerk darf von keinem anderen Prozess genutzt werden.
  2. Wählen Sie im MAX Werkzeuge»Desktop-PC-Utility für USB-Laufwerk erstellen.
  3. Klicken Sie auf Ja, um zu bestätigen, dass Sie ein solches Utility erstellen möchten.
  4. Wählen Sie eine Version für das Utility aus und klicken Sie auf OK.
  5. Wählen Sie das USB-Laufwerk aus, das als Laufwerk für das USB-Utility formatiert werden soll. Klicken Sie auf OK.
    Achtung Alle Daten auf dem USB-Laufwerk werden überschrieben.
  6. Bestätigen Sie, falls Sie dazu aufgefordert werden, dass Sie alle vorhandenen Daten überschreiben möchten.

Zur Verwendung des USB-Laufwerks mit dem Utility schließen Sie es an den Desktop-PC an, der als fremder Host dient. Schalten Sie den PC ein oder führen Sie einen Reset durch.

Hinweis Bevor Sie das Laufwerk anschließen und den Computer damit starten, muss das BIOS des Computers entsprechend eingestellt werden. In der Startabfolge sollte zuerst nach Boot-Dateien auf dem USB-Laufwerk gesucht werden.

Das USB-Laufwerk-Utility für Desktop-PCs hat folgende Menüpunkte:

  1. Mit den installierten Programmen auf der Festplatte starten
    Startet das System mit Hilfe der installierten Real-Time-Software von NI. Wenn auf der Festplatte keine Real-Time-Software von NI installiert ist, wird das System im sicheren Modus hochgefahren, so dass die Software nachträglich installiert werden kann.
  2. Im sicheren Modus starten
    Fährt das System im sicheren Modus hoch. Bei dieser Option werden nur die Dienste gestartet, die für die Netzwerkeinstellungen des Systems und zum Installieren von Software erforderlich sind. In diesem Modus wird keine installierte Software verwendet. Daher eignet er sich besonders für den Fall, dass beim Systemstart von der Festplatte aus Probleme auftreten.
  3. Netzwerkkonfiguration zurücksetzen
    Löscht die IP-Adresse, Subnetzmaske, das Gateway und die DNS-Adresse. Nach dem Neustart erfasst das System automatisch eine IP-Adresse, wenn die automatische IP-Zuweisung unterstützt wird. Wenn die IP-Adresse des Zielsystems 0.0.0.0 lautet, müssen Sie die Netzwerkeinstellungen neu konfigurieren.
  4. Passwort löschen
    Löscht das Systempasswort, falls ein solches eingerichtet wurde.
  5. Automatischen Start von Real-Time-Anwendungen unterbinden
    Bei Auswahl dieser Option werden alle LabVIEW-Real-Time-Anwendungen unterbunden, die automatisch nach einem Neustart ausgeführt werden. Nach dem Deaktivieren des automatischen Programmstarts müssen Sie die entsprechende Anwendung in der LabVIEW-Real-Time-Entwicklungsumgebung wieder auf den automatischen Programmstart einstellen.
  6. Festplatte formatieren
    Formatiert die Festplatte des Systems neu, so dass NI-Real-Time-Software direkt von der Festplatte gestartet werden kann. Dabei gehen allerdings alle Daten auf der Festplatte verloren. Der erste Systemstart von der Festplatte aus nach der Formatierung wird im sicheren Modus durchgeführt. Systemen mit automatischer Zuweisung von IP-Adressen wird eine Adresse zugewiesen. Systeme ohne automatische Zuweisung werden nach der Formatierung der Festplatte im sicheren Modus mit der IP-Adresse 0.0.0.0 gestartet. Anschließend können Sie die Netzwerkeinstellungen des Systems neu konfigurieren und Programme auf der Festplatte installieren.
  7. System evaluieren
    Evaluiert die Hardwarekonfiguration eines Systems und gibt an, ob das System Real-Time-Software von NI ausführen kann.
  8. Erweiterte Ethernet-Einstellungen
    Ermöglicht das Erstellen einer Liste mit zusätzlichen Intel-i8254x-basierten Ethernet-Geräten, die vom Echtzeitbetriebssystem geladen und verwendet werden können. Sie müssen auch eine Liste mit Geräten erstellen, die nicht verwendet werden sollten.

    Aktivieren Sie die Liste mit erlaubten Geräten durch Erstellen einer ordnungsgemäß formatierten enetwhitelist.ini-Datei im Verzeichnis c:\ni-rt\system\ethernet des Echtzeitsystems oder im Stammverzeichnis eines USB-Laufwerks im sicheren Modus.
    Hinweis Hinweis Nicht alle Intel i8254x-Geräte werden akzeptiert, auch wenn die Liste der zulässigen Geräte aktiviert ist. Zum Aktivieren der Liste der zulässigen Ethernet-Geräte für ein USB-Laufwerk im sicheren Modus muss das USB-Laufwerk das einzige USB-Gerät während des Systemstarts im Echtzeitsystem sein.
  9. Neustart des Systems
    Startet das Echtzeitsystem von NI.
  10. Sichern, Wiederherstellen und Kopieren des Real-Time-Systems
    Bietet Optionen zum Anlegen von Sicherheitskopien, Wiederherstellen und Kopieren eines Real-Time-Systems von NI mit Hilfe des aktuellen USB-Laufwerks.


Ich erhalte einen "Fehler bei Verbindung mit MAX-Datenbank" beim Start von MAX

Mehrere Probleme können diesen Fehler verursachen. Führen Sie zur Fehlerbehebung folgende Schritte aus:

  • Prüfen Sie Ihre Einstellungen für Firewall und Antivirenprogramm. Zum Aufheben der Blockierung von MAX und NI-System-Webserver müssen Sie sich möglicherweise als Administrator anmelden.
  • Stellen Sie sicher, dass der Dienst "NI Configuration Manager" gestartet wurde.
    1. Melden Sie sich als Benutzer mit Administratorrechten an.
    2. Wählen Sie Start»Systemsteuerung»Verwaltung»Dienste.
    3. Klicken Sie mit der rechten Maustaste auf den Dienst NI Configuration Manager und wählen Sie Eigenschaften aus dem Dropdown-Menü aus.
    4. Stellen Sie sicher, dass der Dienststatus Gestartet lautet. Falls nicht, starten Sie den Dienst mit Hilfe der Schaltfläche Starten.
    5. Starten Sie MAX erneut.
  • Wenn der Dienst "NI Configuration Manager" nicht in der Liste Dienste angezeigt wird, reparieren Sie die MAX.
    1. Wählen Sie Start»Systemsteuerung»Software.
    2. Wählen Sie National Instruments und klicken Sie auf Software hinzufügen/entfernen.
    3. Wählen Sie NI Measurement & Automation Explorer aus der Liste und klicken Sie auf Reparieren.

In einigen seltenen Fällen, kann ein Fehler der MAX-Datenbank diesen Fehler verursachen. Weitere Informationen zum Zurücksetzen der MAX-Datenbank finden Sie im KnowledgeBase-Artikel 4GA9TOQA.


Mein Gerät wird nicht im MAX angezeigt

Lokale Geräte

Netzwerkumgebung

Lokale Geräte

Führen Sie zur Fehlersuche für ein lokales Gerät, das nicht im MAX angezeigt wird, folgende Schritte aus:

  • Prüfen Sie, ob das Gerät im Windows-Gerätemanager angezeigt wird. Wenn es nicht angezeigt wird, prüfen Sie die Verbindung zwischen dem Gerät und dem lokalen System.
  • Wenn Ihr Gerät im Windows-Gerätemanager aufgelistet ist, prüfen Sie, ob der korrekte Treiber installiert ist. Die neueste Version des Treibers steht auf ni.com/drivers zum Download bereit.
  • Wenn Sie den korrekten Treiber installiert haben, prüfen Sie, ob der Dienst "NI Device Loader" ausgeführt wird.
    1. Melden Sie sich als Benutzer mit Administratorrechten an.
    2. (Windows 7) Wählen Sie Start»Systemsteuerung»Verwaltung»Dienste. (Windows XP) Wählen Sie Start»Systemsteuerung»Verwaltung»Dienste.
    3. Klicken Sie mit der rechten Maustaste auf den Dienst NI Device Loader und wählen Sie Eigenschaften aus dem Dropdown-Menü aus.
    4. Stellen Sie sicher, dass der Dienststatus Gestartet lautet. Falls nicht, starten Sie den Dienst mit Hilfe der Schaltfläche Starten.
  • Zum Aktualisieren der MAX-Konfigurationsbaumstruktur wählen Sie Ansicht»Aktualisieren oder drücken Sie die Taste <F5>.

Systeme im Netzwerk

Führen Sie zur Fehlersuche für ein System im Netzwerk, das nicht im MAX angezeigt wird, folgende Schritte aus:

  • Zum Aktualisieren der MAX-Konfigurationsbaumstruktur wählen Sie Ansicht»Aktualisieren oder drücken Sie die Taste <F5>.
  • Prüfen Sie, dass sich das System im gleichen Subnetz befindet wie der Rechner, auf dem MAX ausgeführt wird.
  • Erstellen Sie ein neues System im Netzwerk.


Mein Zielsystem gibt den Status "Inkonsistente IP-Einstellungen" aus

Ihr Zielsystem kann möglicherweise den Status Inkonsistente IP-Einstellungen ausgeben, auch wenn das Zielsystem mit dem Host-Rechner verbunden ist. Dies ist der Fall, wenn die IP-Adresse und die Subnetzmaske des Zielsystems außerhalb des Bereichs liegen, der von der Host-Subnetzmaske festgelegt wird.

(Phar Lap ETS, VxWorks) Wenn der Netzwerkadapter auf "DHCP" gesetzt ist, starten Sie das Zielsystem erneut. Dazu muss das Netzwerkkabel verwendet werden, damit dem Zielsystem eine neue IP-Adresse zugewiesen werden kann. Bei Verwendung einer statischen IP-Adresse können die inkonsistenten IP-Einstellungen manuell ausgeglichen werden. Aktualisieren Sie dazu die IP-Adresse des Zielsystems so, dass sie sich im gleichen Subnetz wie die IP-Adresse des Hosts befindet. Weitere Informationen zu TCP/IP-Adressen und Subnetzen finden Sie unter Microsoft Support.

(NI Linux Real-Time) Führen Sie zum Zurücksetzen der IP-Einstellungen auf dem Zielsystem die folgenden Schritte aus.

  1. Halten Sie den Knopf Zurücksetzen am Gerät 5 Sekunden lang gedrückt.
  2. Lassen Sie den Knopf Zurücksetzen los, wenn die STATUS-LED gelb aufleuchtet. Dadurch wird das Gerät in den sicheren Modus versetzt.
  3. Halten Sie den Knopf Zurücksetzen 5 Sekunden lang gedrückt.
  4. Lassen Sie den Knopf Zurücksetzen los, wenn die STATUS-LED gelb aufleuchtet. Dadurch wird das Gerät in den sicheren Modus versetzt und die IP-Einstellungen werden zurückgesetzt, so dass DHCP verwendet wird.


Anzeigen von Fehlerprotokollen

Mit Fehlerprotokoll anzeigen können Sie Fehlerprotokolle des Netzwerksystems anzeigen. Klicken Sie das System dazu im MAX mit der rechten Maustaste an und wählen Sie Fehlerprotokoll anzeigen.


Windows-Firewall

Wenn die Windows-Firewall aktiviert ist, sind bezüglich der Verwendung des MAX folgende Hinweise zu beachten:

Bei Software-Updates auf einem LabVIEW-Real-Time-System bei aktivierter Windows-Firewall wird bei bestimmten Firewall-Einstellungen ein Dialogfeld eingeblendet, in dem Sie MAX und dem NI-System-Webserver die Kommunikation über das Netzwerk erlauben können. Aktivieren Sie in diesem Dialogfeld die Option Sperre für dieses Programm aufheben.

Die Nutzung von Produkten von NI unter Microsoft Windows 8 ist auf der Website ni.com/windows8 beschrieben. Die Nutzung von Produkten von NI unter Microsoft Windows 7 ist auf der Website ni.com/windows7 beschrieben.

Hinweis Die Windows-Firewall kann nur mit Administratorrechten aktiviert oder deaktiviert werden.


Installierte Produkte

In diesem Abschnitt sehen Sie die Hilfe zu den installierten Produkten. Wenn ein bestimmtes Produkt nicht in der Liste enthalten ist, wird es unter Umständen unter Hilfe»Hilfethemen aufgeführt (sofern dazu eine Hilfe vorhanden ist).


Rechtliche Hinweise

Beschränkte Gewährleistung

Copyright

Marken

Patente

Bestimmungen für die Ausfuhrkontrolle

Warnung zur Nutzung von Produkten von NI


Beschränkte Gewährleistung

Dieses Dokument wird "wie es ist" zur Verfügung gestellt, und NI kann den Inhalt dieses Dokuments ohne Ankündigung in zukünftigen Ausgaben ändern. Die jeweils aktuelle Version dieses Dokuments finden Sie auf der Website ni.com/manuals. NI prüft die technische Richtigkeit dieses Dokuments sorgfältig, übernimmt jedoch weder ausdrücklich noch stillschweigend irgendeine Gewährleistung für die Richtigkeit oder Vollständigkeit der in diesem Dokument enthaltenen Informationen und haftet nicht für Fehler.

NI garantiert bei Hardwareprodukten für die Dauer eines (1) Jahres ab Rechnungsdatum, dass das Produkt frei von Material- und Verarbeitungsfehlern ist und den von NI veröffentlichten anwendbaren Spezifikationen im Wesentlichen entspricht.

NI garantiert für einen Zeitraum von neunzig (90) Tagen ab Rechnungsdatum, dass NI-Software (i) im Wesentlichen gemäß der mitgelieferten schriftlichen Dokumentation funktioniert, und (ii) das Speichermedium, auf dem die Software geliefert wird, frei von Material- und Fabrikationsfehlern ist.

Wenn NI innerhalb der entsprechenden Gewährleistungsperiode über einen aufgetretenen Fehler oder eine nicht eingehaltene Spezifikation unterrichtet wird, dann wird NI nach eigenem Ermessen (i) das betroffene Produkt reparieren oder ersetzen oder (ii) den gezahlten Preis für das betroffene Produkt zurückerstatten. Die Gewährleistungsfrist für die reparierte oder ersetzte Hardware entspricht der Restzeit der Gewährleistungsfrist des ursprünglichen Produkts, sofern diese noch mindestens neunzig (90) Tage beträgt. Anderenfalls beträgt die Gewährleistungsfrist neunzig (90) Tage. Wenn sich NI dafür entscheidet, Hardware zu reparieren oder zu ersetzen, verwendet NI neue oder neuwertige Teile oder Produkte, welche in ihrer Leistung und Beständigkeit zumindest funktional neuen Teilen oder neuer Hardware entsprechen.

Vor dem Zurücksenden eines Produkts an NI müssen Sie von NI eine RMA-Nummer ("Return Material Authorization") anfordern. NI behält sich das Recht vor, für das Prüfen und Testen von Hardware eine Gebühr zu berechnen, für die unter der beschränkten Gewährleistung kein Garantieanspruch besteht.

Diese beschränkte Gewährleistung gilt nicht, wenn der Defekt des Produkts von unsachgemäßem oder inadäquatem Gebrauch; unsachgemäßer oder inadequater Installation, Reparatur oder Kalibrierung (welche von einem Dritten und nicht von NI vorgenommen wurde); eigenmächtigen Abänderungen; Betrieb in falscher Umgebung; Verwendung eines falschen Hardware- oder Softwareschlüssels; unsachgemäßer Verwendung oder Betrieb außerhalb der Spezifikation für das Produkt; unzulässigen Spannungen; Unfall; missbräuchlichem oder fahrlässigem Umgang oder einer Naturkatastrophe wie Blitzschlag, Überschwemmung oder anderen Naturgewalten herrührt.

Die einzigen und ausschließlichen Verpflichtungen von NI in Verbindung mit der Gewährleistung sind oben beschrieben und sind auch dann anwendbar, wenn der wesentliche Zweck dieser Verpflichtungen verfehlt wird.

Unter dem Vorbehalt der oben erwähnten Gewährleistungsausführungen werden die NI-Produkte geliefert, "wie sie sind", ohne jede zusätzliche Garantie oder Gewährleistung, weder ausdrücklich noch indirekt in irgendeiner Art, inbegriffen aber nicht ausschließlich jede Garantie oder Gewährleistung der Kommerzialisierung, Eignung für einen bestimmten Zweck oder Gewährleistung für das Bestehen rechtmäßigen Eigentums und die Nichtverletzung von Schutzrechten Dritter. Weder bestätigt noch garantiert NI den Gebrauch der Produkte oder der Resultate dieses Gebrauchs betreffend Richtigkeit, Präzision, Zuverlässigkeit oder anderem. NI garantiert auch nicht das ununterbrochene und fehlerfreie Funktionieren der Produkte.

Falls Sie eine separate, unterzeichnete Vereinbarung mit NI haben, die Gewährleistungsbedingungen der Produkte regelt, haben Gewährleistungsbedingungen in der separaten Vereinbarung Vorrang.


Bestimmungen für die Ausfuhrkontrolle

Informationen zu den Global-Trade-Compliance-Richtlinien von NI sowie zu Bezugsquellen für relevante HTS-Codes, ECCNs und andere Import-/Exportangaben finden Sie auf ni.com/legal unter der Überschrift Export Compliance Information.


Copyright

Gemäß den Bestimmungen des Urheberrechts darf diese Publikation ohne vorherige schriftliche Zustimmung der Firma National Instruments Corporation weder vollständig noch teilweise vervielfältigt oder verbreitet werden, gleich in welcher Form, ob elektronisch oder mechanisch. Das Verbot erfasst u. a. das Fotokopieren, das Aufzeichnen und das Speichern von Informationen in Informationsgewinnungssystemen sowie das Anfertigen von Übersetzungen gleich welcher Art.

NI achtet das geistige Eigentum anderer und fordert seine Nutzer auf, dies ebenso zu tun. Die Software von NI ist urheberrechtlich und durch andere Rechtsvorschriften zum Schutz geistigen Eigentums geschützt. Wenn Sie Software von NI nutzen, um Software oder andere Materialien, die im Eigentum Dritter stehen, zu vervielfältigen, dürfen Sie Software von NI nur insoweit nutzen, als Sie die betreffenden Materialien nach den jeweils anwendbaren Lizenzbestimmungen oder Rechtsvorschriften vervielfältigen dürfen.

Lizenzverträge von NI und Rechtshinweise von Drittanbietern

Lizenzverträge (EULAs) von NI und Rechtshinweise von Drittanbietern befinden sich in folgenden Verzeichnissen:

  • Rechtshinweise: <National Instruments>\_Legal Information und <National Instruments>
  • EULAs: <National Instruments>\Shared\MDF\Legal\license
  • Informationen zum Hinzufügen von Rechtshinweisen zu Installationsprogrammen, die mit Hilfe von NI-Produkten erzeugt werden: <National Instruments>\_Legal Information.txt

Eingeschränkte Rechte der US-Regierung

Für Behörden, Regierungsstellen oder andere Rechtsträger der US-Regierung ("Government") ist die Verwendung, Vervielfältigung, Reproduktion, Veröffentlichung, Änderung, Verbreitung oder Übertragung der technischen Daten in diesem Handbuch gemäß der folgenden Verordnungen der US-Bundesbehörden weiter beschränkt: Federal Acquisition Regulation 52.227-14 für zivile Behörden und Defense Federal Acquisition Regulation Supplement Section 252.227-7014 und 252.227-7015 für Militärbehörden.

IVI Foundation - Urheberrechtsvermerk

Content from the IVI specifications reproduced with permission from the IVI Foundation.

The IVI Foundation and its member companies make no warranty of any kind with regard to this material, including, but not limited to, the implied warranties of merchantability and fitness for a particular purpose. The IVI Foundation and its member companies shall not be liable for errors contained herein or for incidental or consequential damages in connection with the furnishing, performance, or use of this material.


Marken

Besuchen Sie NI Trademarks and Logo Guidelines auf ni.com/trademarks für weitere Informationen zu Marken von NI.

ARM, Keil, and µVision are trademarks or registered of ARM Ltd or its subsidiaries.

LEGO, the LEGO logo, WEDO, and MINDSTORMS are trademarks of the LEGO Group.

TETRIX by Pitsco is a trademark of Pitsco, Inc.

FIELDBUS FOUNDATION™ and FOUNDATION™ are trademarks of the Fieldbus Foundation.

EtherCAT® is a registered trademark of and licensed by Beckhoff Automation GmbH.

CANopen® is a registered Community Trademark of CAN in Automation e.V.

DeviceNet™ and EtherNet/IP™ are trademarks of ODVA.

Go!, SensorDAQ, and Vernier are registered trademarks of Vernier Software & Technology. Vernier Software & Technology and vernier.com are trademarks or trade dress.

Xilinx is the registered trademark of Xilinx, Inc.

Taptite and Trilobular are registered trademarks of Research Engineering & Manufacturing Inc.

FireWire® is the registered trademark of Apple Inc.

Linux® is the registered trademark of Linus Torvalds in the U.S. and other countries.

Handle Graphics®, MATLAB®, Simulink®, Stateflow®, and xPC TargetBox® are registered trademarks, and Simulink Coder™, TargetBox™, and Target Language Compiler™ are trademarks of The MathWorks, Inc.

Tektronix®, Tek, and Tektronix, Enabling Technology are registered trademarks of Tektronix, Inc.

The Bluetooth® word mark is a registered trademark owned by the Bluetooth SIG, Inc.

The ExpressCard™ word mark and logos are owned by PCMCIA and any use of such marks by National Instruments is under license.

The mark LabWindows is used under a license from Microsoft Corporation. Windows is a registered trademark of Microsoft Corporation in the United States and other countries.

Sonstige hierin erwähnte Produkt- und Firmenbezeichnungen sind Marken oder Handelsnamen der jeweiligen Unternehmen.

Ein NI Partner ist ein eigenständiges und von NI unabhängiges Unternehmen; zwischen einem NI Partner und NI besteht keine gesellschaftliche Verbindung und auch kein Auftragsverhältnis.


Patente

Nähere Informationen über den Patentschutz von NI-Produkten und -Technologien finden Sie unter Hilfe»Patente in Ihrer Software, in der Datei patents.txt auf Ihrem Datenträger oder unter Patent Notice auf der Website ni.com/patents.


Warnung zur Nutzung von Produkten von National Instruments

Warnung zur Nutzung von Produkten von National Instruments Corporation

Es liegt in Ihrer alleinigen Verantwortung, die Eignung und die Zuverlässigkeit der Produkte und Dienstleistungen für Ihre Zwecke zu prüfen und zu validieren, wenn die Produkte oder Dienstleistungen in Ihre Systeme oder Anwendungen eingebaut werden, inklusive der Eignung des Designs, Betriebsablaufs und des Sicherheitsniveaus solcher Systeme oder Anwendungen.

Die Produkte wurden nicht für lebens- oder sicherheitskritische Anwendungen, gefährliche Umgebungen oder für sonstige Verwendungen, die Ausfallsicherheit erfordern, entwickelt, hergestellt und getestet. Dazu gehören z. B. der Einsatz in der Atomkraft, der Flugzeugnavigation, der Luftverkehrskontrolle, in lebensrettenden, lebenserhaltenden oder ähnlichen medizinischen Systemen oder in sonstigen Anwendungen, bei denen die Fehlfunktion der Produkte oder Dienstleistungen zu erheblichen Schäden an Leib und Leben von Menschen, erheblicher Sachbeschädigung oder Umweltschäden führen kann (sog. "High-Risk Uses"). Darüber hinaus müssen angemessene Maßnahmen ergriffen werden, um gegen Fehlfunktionen der Produkte gesichert zu sein, z. B. durch Erstellen von Backups oder durch Mechanismen, die ein Ausschalten oder Herunterfahren des Produkts im Fehlerfall ermöglichen. NI leistet keine Gewähr, dass die Produkte für High-Risk Uses geeignet sind.


Technische Unterstützung zum MAX

Im MAX können Protokolle für die Dokumentation von Systemen und Protokolle mit für die technische Unterstützung hilfreichen Angaben zum System erstellt werden.

Konfigurationsprotokolle

Zum Erstellen eines Konfigurationsprotokolls starten Sie den MAX-Protokollassistenten (Datei»Protokoll erstellen) und wählen Sie die Option Einfaches Protokoll oder Benutzerdefiniertes Protokoll aus. Der Assistent erstellt eine HTML-Seite mit der Konfiguration des ausgewählten Systems. Weitere Informationen finden Sie unter Umgang mit dem MAX-Protokollassistenten.

Protokolle mit Systemangaben

Sie können die für den technischen Support relevanten Systemangaben zusammenfassen, indem Sie über Datei»Protokoll erstellen den MAX-Protokollassistenten starten und Technischer Support auswählen. Ein solches Protokoll kann sich als hilfreich erweisen, wenn Sie den technischen Support von NI im Web in Anspruch nehmen. Weitere Informationen finden Sie unter Umgang mit dem MAX-Protokollassistenten.

Informationen zu technischer Unterstützung

Zur Suche nach Software-Updates besuchen Sie Treiber und Updates. Informationen zum technischen Support und zu professionellen Serviceleistungen von NI finden Sie unter Technische Unterstützung und professioneller Service.


NI-Serviceleistungen

Wir möchten, dass Sie mit unseren Produkten erfolgreich sind. Daher bieten wir für alle unsere Produkte weltweiten Service und Support. Die Serviceleistungen dienen ergänzend zu den Trainings- und Zertifizierungsprogrammen von NI dazu, Anwendern über die gesamte Lebensdauer ihrer Systeme hinweg – angefangen bei der Planung über die Entwicklung bis hin zu Einsatz und regelmäßiger Wartung – unterstützend zur Seite zu stehen.

Erstellen Sie, um diese Serviceleistungen in Anspruch zu nehmen, ein MyNI-Benutzerkonto oder melden Sie sich mit Ihrem Benutzerprofil unter ni.com/myproducts an und registrieren Sie Ihr Produkt.

Als registrierter Nutzer von NI-Produkten genießen Sie folgende Vorteile:

  • Zugang zu Ihren Produktdienstleistungen
  • ein Online-Konto zur einfachen Produktverwaltung
  • Benachrichtigungen zu Software-Updates, kritischen Hardwarekomponenten und zum Ablauf des Servicezeitraums

Serviceleistungen und Ressourcen

  • Wartungs- und Hardwareservice—NI hilft Ihnen dabei, die Voraussetzungen für die Genauigkeit und Zuverlässigkeit Ihrer Systeme zu ermitteln, und bietet Gewährleistungen sowie Kalibrier- und Ersatzteildienste an, mit deren Hilfe Ihre höchsten Anforderungen erfüllt und Ausfallzeiten Ihrer Systeme minimiert werden. Weitere Informationen finden Sie auf ni.com/services.
    • Gewährleistungen und Reparaturdienste—NI übernimmt für Hardware eine einjährige Gewährleistung, die auf fünf Jahre verlängert werden kann. Reparaturen werden im NI Service Center von qualifiziertem Fachpersonal durchgeführt. Alle Reparaturen erfolgen zeitnah und unter Verwendung von Originalkomponenten.
    • Kalibrierung—Durch eine regelmäßige Kalibrierung lässt sich die Genauigkeit von Messgeräten quantifizieren und verbessern. NI bietet modernste Kalibrierdienstleistungen. Wenn Ihr Gerät kalibrierbar ist, finden Sie auf ni.com/calibration das zugehörige Kalibrierzertifikat.
  • Systemintegration—Wenn Sie aus Zeit-, Personalmangel oder anderen Gründen bei der Fertigstellung eines Projekts in Verzug geraten, kann Ihnen das NI Partner Network weiterhelfen. Für Informationen zu diesem Programm setzen Sie sich entweder telefonisch mit einer NI-Niederlassung in Ihrer Nähe in Verbindung oder besuchen Sie die Website ni.com/partners.
  • Schulung und Zertifizierung—Das NI-Trainings- und -Zertifizierungsprogramm ist die schnellste und effektivste Möglichkeit, Ihre Produktivität bei der Systementwicklung zu erhöhen. Weitere Informationen finden Sie auf ni.com/training.
    • Der Skills Guide hilft Ihnen dabei, den für eine bestimmte Anwendung benötigten Level an Know-How zu ermitteln, und bietet Optionen für zusätzliches Training. Dabei werden Zeit- und Budgetvorgaben und persönliche Vorlieben in Bezug auf den Wissenserwerb berücksichtigt. Weitere Informationen finden Sie auf ni.com/skills-guide.
    • Um individuellen Anforderungen besser gerecht zu werden, bietet NI weltweit Schulungen in verschiedenen Sprachen und Formaten an, darunter Kurse in den NI-eigenen Schulungszentren, Vor-Ort-Schulungen und Online-Schulungen.
  • Technische Unterstützung—Unterstützung erhalten Sie auf der Website ni.com/support in Form folgender Informationsquellen und Tools:
    • Technische Ressourcen—Die Website ni.com/support bietet Ihnen Soforthilfe bei Fragen und Problemen. Außerdem finden Sie hier Treiber, Updates, eine umfassende Wissensdatenbank (KnowledgeBase), Bedienungsanleitungen, Anleitungen zur Problemlösung, Tausende Beispielprogramme, Selbstlernkurse und Application Notes. Registrierte Nutzer können sich auch an den Diskussionsforen auf ni.com/forums (englisch) beteiligen. Jede im Forum eingereichte Frage wird garantiert beantwortet.
    • Teilnahme am SSP-Programm—Das Standard Service Program (SSP) ist ein einjähriger erneuerbarer Wartungsvertrag, der Bestandteil fast aller NI-Softwareprodukte, einschließlich der NI Developer Suite, ist. Teilnehmer dieses Programms können sich telefonisch oder per E-Mail direkt mit unseren Anwendungsingenieuren in Verbindung setzen und haben exklusiven Zugriff auf Selbstlernmodule unter ni.com/self-paced-training. Darüber hinaus bietet NI flexible Vertragsoptionen zum optionalen Verlängern Ihrer SSP-Leistungen. Weitere Informationen finden Sie auf ni.com/ssp.
  • Konformitätserklärung (DoC)—Mit der Konformitätserklärung wird bescheinigt, dass NI unter Verwendung der Konformitätserklärungen der entsprechenden Hersteller die EU-Richtlinien zum Verbraucherschutz einhält. Mit der DoC werden elektromagnetische Verträglichkeit und Sicherheit unserer Produkte garantiert. Das Produktzertifikat zu Ihrem Produkt finden Sie auf ni.com/certification.

Welche Art der technischen Unterstützung es in Ihrer Nähe gibt, erfahren Sie auf ni.com/services oder indem Sie sich mit einer Niederlassung von NI in Ihrer Nähe in Verbindung setzen (ni.com/contact).

Weitere Kontaktinformationen sowie Telefonnummern für technischen Support, E-Mail-Adressen und Informationen über Veranstaltungen finden Sie auf der Website ni.com/niglobal unter Worldwide Offices.


Javascript ist deaktiviert.


VI-Logger

Der VI-Logger ist ein Programm im MAX, mit dem Tasks zur Protokollierung von Daten erstellt und ausgeführt werden können. Mit dem VI-Logger sind folgende Arbeitsschritte möglich:

  • Erzeugen eines neuen Tasks für den VI-Logger
  • Bearbeiten eines Tasks für den VI-Logger
  • Starten eines Tasks für den VI-Logger
  • Anzeigen von Daten während der Aufnahme und Protokollierung
  • Anzeigen von protokollierten Daten

Ihre Version von "VI-Logger" ist nicht kompatibel mit dieser Version von MAX. Zum Aktualisieren von "VI-Logger" auf Version 1.0.2 installieren Sie das Patch von ftp://ftp.ni.com/support/vilogger/upgrades/1.0.2/.


Datenumgebung

Die Datenumgebung bildet eine Verknüpfung zu allen in Ihrem System konfigurierten physikalischen Kanälen. Die Namen der Kanäle sind individuell auswählbar. Die Verknüpfungen können beispielsweise für CAN-Nachrichten, virtuelle DAQ-Kanäle, DAQ-Tasks oder FieldPoint-Objekte stehen.

Mögliche Arbeitsschritte

Erstellen von Verknüpfungen

Zum Erstellen einer Verknüpfung klicken Sie mit der rechten Maustaste auf Datenumgebung und wählen Sie Neu. Die weiteren Optionen im Kontextmenü hängen von den installierten NI-Produkten ab.

Testen oder Entfernen einer Verknüpfung

In der Regel können Sie über einen rechten Mausklick auf eine Verknüpfung das gewünschte NI-Produkt testen oder entfernen.

Anzeigen und Bearbeiten von Eigenschaften

Auch diese Option ist von der Software abhängig. Normalerweise ist eine Verknüpfung mit der rechten Maustaste anzuklicken und die Option Eigenschaften auszuwählen. Bei manchen Objekten lassen sich die Eigenschaften in der Einzelansicht ändern.

Weitere Informationen zur Verwendung der Datenumgebung mit Produkten von NI erhalten Sie unter Hilfe»Hilfethemen. Sie können die Hilfe zu NI-Produkten auch von der MAX-Hilfe aus über den Menüpunkt Hilfe oder durch Drücken der Taste <F1> öffnen.


Geräte und Schnittstellen

Unter Geräte und Schnittstellen werden alle installierten und erkannten CAN-, DAQ-, FieldPoint-, GPIB-, IMAQ-, Motion-, Serial- und VXI-Hardwarekomponenten sowie Geräte angezeigt, die mit IVI oder VISA arbeiten.

Wenn Ihr Gerät nicht angezeigt wird, ...

haben Sie die Anzeige eventuell nicht aktualisiert.

Drücken Sie <F5> oder wählen Sie Ansicht»Aktualisieren.

ist Ihr Gerät möglicherweise kein Plug-and-Play-Gerät für Windows.

Lesen Sie die Hilfedatei zu Ihrem Gerät, die über Hilfe»Hilfethemen geöffnet wird, oder die Anweisungen zum Hinzufügen solcher Komponenten (weiter unten).

Mögliche Arbeitsschritte

Konfiguration eines vorhandenen Geräts

Zur Konfiguration von Hardwarekomponenten von NI, die bereits im MAX angezeigt werden, klicken Sie auf die Schaltfläche Konfigurieren in der Symbolleiste oder klicken Sie das Gerät in der Übersicht mit der rechten Maustaste an und wählen Sie Konfigurieren aus. Bei Verwendung bestimmter Softwarekomponenten lassen sich die Geräte nur in der Einzelansicht konfigurieren.

Hinzufügen eines Nicht-Plug-and-Play-Geräts

Einige Geräte sind nicht Windows-Plug&Play-kompatibel, d. h. sie werden nicht automatisch in der Liste der Geräte und Schnittstellen angezeigt. Andere Geräte sind möglicherweise auf einem anderen Computer Ihres Netzwerks installiert. Zum Hinzufügen solcher Geräte klicken Sie in der Übersicht mit der rechten Maustaste auf Geräte und Schnittstellen und wählen Sie Neu. Vervollständigen Sie den Assistenten.

Falls das Gerät immer noch nicht in der Liste erscheint, überprüfen Sie anhand der Installationsanleitung in der Gerätebeschreibung oder der produktspezifischen MAX-Hilfe (Hilfe»Hilfethemen), ob das Gerät ordnungsgemäß installiert ist. Wenn Sie sicher sind, dass die Hardware korrekt installiert ist, hilft Ihnen eventuell die Website für technische Unterstützung weiter:

CAN | DAQ | FieldPoint
GPIB | IVI | Modulare Instrumente
Motorsteuerung | NI Switch Executive | NI Vision
Seriell | VISA | VXI

Die Verwendung bestimmter NI-Produkte im MAX wird unter Hilfe»Hilfethemen erläutert. Sie können die Hilfe zu NI-Produkten auch von der MAX-Hilfe aus über den Menüpunkt Hilfe oder durch Drücken der Taste <F1> öffnen.


Historische Daten

Unter Historische Daten finden Sie alle Datenbanken und gespeicherten Daten (auch Datenansichten genannt).

Mögliche Arbeitsschritte

Anzeigen von Daten

Zum Anzeigen und Verwalten Ihrer Datenbanken und Datenansichten erweitern Sie die Kategorie Historische Daten in der Baumstruktur. Bei Auswahl von Citadel 5 Universe erscheinen Ihre Datenbanken in der Ansicht Databases. Ansonsten werden Ihre Datenbanken unter Citadel 5 Universe angezeigt.

Erstellen einer Datenbank

Zum Erstellen einer leeren Datenbank klicken Sie mit der rechten Maustaste auf Historische Daten und wählen Sie Neu. Klicken Sie auf Citadel 5 Database und anschließend auf Weiter. Folgen Sie den Anweisungen des Assistenten und klicken Sie zum Abschluss auf Beenden. Bei Auswahl von Citadel 5 Universe wird Ihre neue Datenbank in der Ansicht Databases unter Historische Daten angezeigt.

Umwandeln einer Citadel-4-Datenbank in das Citadel-5-Format

Zur Umwandlung einer Datenbank vom Citadel-4- in das Citadel-5-Format klicken Sie die Kategorie Historische Daten mit der rechten Maustaste an und wählen Sie Neu. Klicken Sie auf Convert Citadel 4 Database to Citadel 5 und anschließend auf Weiter. Folgen Sie den Anweisungen zur Auswahl einer Datenbank und eines Speicherorts für die umgewandelte Datenbank und klicken Sie auf Beenden.

Löschen einer Datenbank

Zum Löschen einer Datenbank klicken Sie diese in der Ansicht Databases mit der rechten Maustaste an und wählen Sie die Option Detach/Delete. Wählen Sie Löschen im Dialogfeld Detach/Delete Database und klicken Sie auf OK.

Erstellen einer Datenansicht

Um eine Datenansicht zu erstellen, klicken Sie mit der rechten Maustaste auf Citadel 5 Universe und wählen Sie Neu»Alarms/Events View oder Neu»Trace View. Ihre Datenansichten erscheinen in der Übersicht unter Citadel 5 Universe.

Anzeigen von Citadel-4-Daten

In der Hilfe Historical Data Viewer Help und in der Liste möglicher Arbeitsschritte in der Citadel-4-Ansicht erhalten Sie weitere Hinweise über die Darstellung von Citadel-4-Daten. Zum Öffnen der Historical Data Viewer Help wählen Sie Hilfe»Hilfethemen»Historical Data Viewer.

Weitere Informationen entnehmen Sie bitte der Hilfe Historical Data Viewer Help, die über Hilfe»Hilfethemen»Historical Data Viewer aufgerufen wird.


IVI

Über IVI gelangen Sie zum Alias-Assistenten und zu allen IVI-Aliasnamen. Ein Alias steht für ein bestimmtes virtuelles Instrument.

Mögliche Arbeitsschritte

Erstellen eines Alias für ein virtuelles Instrument

Zur Erstellung eines Aliasnamens erweitern Sie die IVI-Kategorie. Klicken Sie mit der rechten Maustaste auf Logical Names und wählen Sie Insert. Vervollständigen Sie den Assistenten.

Tipp Um IVI-Aliasnamen, virtuelle Instrumente, Gerätetreiber und Geräte hinzuzufügen, klicken Sie das Objekt mit der rechten Maustaste an und wählen Sie Insert. Wenn Sie zum Beispiel einen Namen für einen Gerätetreiber erstellen möchten, klicken Sie in der Übersicht die Kategorie Instrument Drivers mit der rechten Maustaste an und wählen Insert. Daraufhin wird im Abschnitt zum entsprechenden Treiber der Alias-Assistent geöffnet.

Bearbeiten der Einstellungen zu virtuellen Instrumenten

Zur Konfiguration eines virtuellen Instruments wählen Sie in der Übersicht die Kategorie Virtual Instruments aus. Alle vorhergehenden virtuellen Instrumente werden in der Objektansicht rechts neben der Baumstruktur angezeigt. Klicken Sie eines der virtuellen Instrumente in der Einzelansicht mit der rechten Maustaste an und wählen Sie Properties.

Austauschen von Instrumenten

Um einen logischen Namen einem anderen Instrument zuzuweisen, wählen Sie die Kategorie Logical Names aus. Klicken Sie den Namen mit der rechten Maustaste an und wählen Sie Properties. Klicken Sie auf Change, um das virtuelle Instrument für ein neues reales Gerät zu erstellen oder auszuwählen.


NI Measurement & Automation Explorer

Der Measurement & Automation Explorer (MAX) ermöglicht den Zugriff auf alle Produkte von NI.

Mögliche Arbeitsschritte

Konfigurieren von Geräten und Schnittstellen

Wählen Sie in der Übersicht die Kategorie Geräte und Schnittstellen aus. Hinweise zum Installieren Ihres Geräts finden Sie in der Dokumentation zu Ihrer Hardware von NI.

Verwalten der installierten Software von NI

Wählen Sie in der Übersicht die Kategorie Software aus.

Verwalten virtueller Kanäle oder Tasks für Geräte

Wählen Sie in der Übersicht die Kategorie Datenumgebung aus.

Erstellen von Skalierungen für ein virtuelles Instrument

Wählen Sie in der Übersicht die Kategorie Skalierungen aus.

Konfigurieren von IVI-Gerätetreibern

Wählen Sie in der Übersicht die Kategorie IVI aus.

Importieren und Exportieren von Konfigurationsdateien für Geräte

Klicken Sie auf Datei»Importieren oder Datei»Exportieren. Einige Geräte werden nicht unterstützt. Lesen Sie hierzu die Beschreibung zu Ihrem Produkt.

Hinweis Einige Kategorien sind gerätespezifisch. Die Kategorie "IVI" wird z. B. nur angezeigt, wenn IVI installiert ist.

Weitere Informationen zur Verwendung des MAX erhalten Sie in den Hilfethemen des MAX im Menü Hilfe. Für praktische Unterstützung oder spezielle Informationen zu Ihrer Hardware besuchen Sie den Bereich Technischer Support auf unserer Website.

Weitere Hinweise zu dieser Version von MAX finden Sie in der readme oder unter ni.com/info nach Eingabe der folgenden Infocodes:

  • SysCfgFixList—Verbesserungen und behobene Probleme
  • SysCfgKnownIssues—Bekannte Probleme


Skalierungen

Hier werden alle Skalierungen aufgeführt, die Sie für Messwerte festgelegt haben.

Mögliche Arbeitsschritte

Erstellen einer Skalierung

Klicken Sie zum Erstellen einer Skalierung mit der rechten Maustaste auf Skalierungen und wählen Sie Neu ...

Entfernen einer Skalierung

Zum Entfernen einer Skalierung klicken Sie diese in der Baumstruktur mit der rechten Maustaste an und wählen Sie Löschen.

Anzeigen und Bearbeiten von Skalierungen

Je nach installierter Software können Sie eine Skalierung mit der rechten Maustaste anklicken und die Option Eigenschaften auswählen oder die Eigenschaften in der Einzelansicht verändern.

Weitere Informationen zur Verwendung von Skalierungen mit Produkten von NI erhalten Sie unter Hilfe»Hilfethemen. Sie können die Hilfe zu NI-Produkten auch von der MAX-Hilfe aus über den Menüpunkt Hilfe oder durch Drücken der Taste <F1> öffnen.


Software

In der Kategorie Software werden alle installierten Programme von NI aufgeführt und es besteht die Möglichkeit, diese direkt zu starten oder zu aktualisieren.

Mögliche Arbeitsschritte

Anzeigen der installierten Software

Erweitern Sie die Kategorie Software in der Baumstruktur.

Starten der Software

Klicken Sie das jeweilige Produkt in der Übersicht mit der rechten Maustaste an und wählen Sie Starten.

Hinzufügen, Ändern und Entfernen von Software

Durch Anklicken der Option Software hinzufügen/ändern im Software-Kontextmenü können Sie Software von NI ändern oder deinstallieren.

Suchen nach Updates

Klicken Sie mit der rechten Maustaste auf Software und wählen Sie Nach Updates suchen. Wenn Sie auf diese Schaltfläche klicken, wird auf der Website von NI nach Updates für Ihre Software gesucht. Wählen Sie aus der Liste die Software aus, die Sie herunterladen und installieren möchten. Sie können Ihre Software auch über das Menü Hilfe oder die Kategorie Software aktualisieren.

Wenn Ihre Software nicht im NI-Update-Dienst angezeigt wird und Sie nach Updates suchen möchten, besuchen Sie die Seite Drivers and Updates unter ni.com/updates.

Weitere Informationen über NI-Produkte erhalten Sie unter Hilfe»Hilfethemen. Sie können die Hilfe zu NI-Produkten auch von der MAX-Hilfe aus über den Menüpunkt Hilfe oder durch Drücken der Taste <F1> öffnen.


VI-Logger

Der VI-Logger ist ein Programm im MAX, mit dem Tasks zur Protokollierung von Daten erstellt und ausgeführt werden können. Die Lite-Version des Programms bietet einfache Erfassungs- und Protokollfunktionen für DAQmx-Geräte. Im Komplettpaket gibt es zusätzliche Funktionen für FieldPoint-Geräte und Geräte, die mit NI-DAQmx oder dem traditionellen NI-DAQ-Treiber arbeiten.

Mögliche Arbeitsschritte

Erzeugen eines Tasks für den VI-Logger

Um einen Task für den VI-Logger zu erstellen, klicken Sie in der Übersicht mit der rechten Maustaste auf VI Logger Tasks und wählen Neu. Wählen Sie im Dialogfeld Hinzufügen aus, auf was für eine Art von Gerät sich der Task beziehen soll: Using NI-DAQmx, Using Traditional NI-DAQ oder Using FieldPoint. Klicken Sie auf die Schaltfläche Beenden. Der neue Task erscheint in der Übersicht unter VI Logger Tasks. Zur Ansicht oder Konfiguration des Tasks verwenden Sie die Ansicht "Task Attributes" oder "Virtual Channels", "DAQmx Channels" oder "FieldPoint Channels".

Bearbeiten eines Tasks für den VI-Logger

Zur Bearbeitung eines Tasks wählen Sie den gewünschten Task aus der Übersicht aus. Daraufhin öffnet sich ein Dialogfeld mit dem Titel "VI Logger", das mehrere Registerkarten enthält. Hier können Sie die Bedingungen für die Protokollierung, zum Beispiel den Beginn oder das Ende der Protokollierung, und die Einstellungen zum Export der Daten ändern. Klicken Sie anschließend zum Speichern der Änderungen auf Task speichern oder starten Sie den Task.

Starten eines Tasks für den VI-Logger

In der Ansicht "Task Attributes" können Sie die Bedingungen für die Erfassung und Aufzeichnung von Daten für den VI-Logger-Task festlegen. Zum Starten des Tasks klicken Sie ihn in der Übersicht an und klicken Sie auf die Schaltfläche Task starten in der Symbolleiste. Wenn nicht festgelegt ist, unter welchen Bedingungen der Task beendet werden soll, müssen Sie zum Beenden des Tasks auf die Schaltfläche Task stoppen klicken.

Anzeige der Daten während der Erfassung und Protokollierung

In der Ansicht "Real Time Data" können Sie sich die Daten während der Protokollierung grafisch anzeigen lassen. Mit der LED [image] in der linken oberen Ecke der Ansicht kann zwischen der Anzeige der laufend protokollierten Daten und aufgezeichneter Daten umgeschaltet werden. Durch einen Klick auf die rote LED wird die grafische Darstellung angehalten, so dass sie zu den aufgezeichneten Daten zurückscrollen können. Mit einem Klick auf die grüne LED wird wieder zu den aktuellen Daten gewechselt. Nach Ende der Protokollierung können Sie mit den vier Pfeiltasten durch den Graphen scrollen.

Anzeige der protokollierten Daten

Nach der Protokollierung von Daten werden diese unter einem ausgeführten Task gespeichert, der unter dem zugehörigen Task in der Übersicht angezeigt wird. Als Name des Tasks werden automatisch Datum und Uhrzeit des Protokollierungsbeginns eingefügt. Klicken Sie auf den Durchlauf, den Sie sehen möchten. Die dazugehörigen Daten werden in der Übersicht "Historische Daten" angezeigt. Scrollen Sie mit Hilfe der vier Pfeiltasten durch den Graphen mit den protokollierten Daten.

Aktivierung des Komplettpakets bei installiertem Lite-Paket des VI-Loggers

Klicken Sie auf das Lite-Paket und wählen Sie Werkzeuge»VI Logger»Activate All VI Logger 2.0 Features. Klicken Sie im anschließenden Dialogfeld auf die Schaltfläche Purchase License. Daraufhin öffnet sich eine Website, auf der die benötigte Lizenz gekauft werden kann. Klicken Sie dann zum Aktivieren auf die Schaltfläche Activate License. Zur Aktivierung des Komplettpakets des VI-Loggers ist eine gültige Seriennummer erforderlich.