Measurement & Automation Explorer帮助

2021年7月，370694W-0118

Measurement & Automation Explorer (MAX)用于完成以下任务：

  • 配置NI硬件和软件
  • 备份或复制配置数据
  • 创建和编辑通道、任务、接口、换算和虚拟仪器
  • 进行系统诊断
  • 查看与系统连接的设备和仪器
  • 更新NI软件

更多详细信息，请参考下列主题：

法律信息

NI服务

© 2004-2021 National Instruments Corporation. 版权所有

关于NI版权、专利权、商标、担保、产品警告及出口合规性的详细信息，位于<National Instruments>\_Legal Information目录。


MAX概述

Measurement & Automation Explorer (MAX)用于访问NI设备和系统。

通过MAX可完成下列操作：

  • 配置NI硬件和软件
  • 创建和编辑通道、任务、接口、换算和虚拟仪器
  • 进行系统诊断
  • 查看与系统连接的设备和仪器
  • 更新NI软件

除了标准工具，依据用户安装的NI产品，MAX还可提供某些特定工具，对系统进行配置、诊断和测试。MAX的应用程序菜单中将显示这些工具。

主要的菜单项如下：通过帮助菜单可访问设备的相应帮助文件。

  • 文件菜单
  • 编辑菜单
  • 查看菜单
  • 工具菜单
  • 帮助菜单
  • 使用技巧


MAX文件菜单

文件菜单包含下列选项：

新建»窗口－打开新的Measurement & Automation Explorer (MAX) 窗口。

保存全部－保存MAX中已有的全部改动。

创建报表－运行MAX报表向导。该向导用于为本地或远程系统创建包含系统配置信息的可打印报表。

导入－运行配置导入向导。通过该向导可从文件导入配置数据。

导出－运行配置导出向导。通过该向导可将配置数据导出至文件。

退出－退出MAX。


MAX编辑菜单

编辑菜单包含下列选项：

撤销－撤消上次的操作。仅当配置目录树中的选项支持该操作时才可用。

重做－取消上次的撤销操作。仅当配置目录树中的选项支持该操作时才可用。


MAX查看菜单

查看菜单包含下列选项：

工具栏－设置工具栏显示选项：

  • 文本标签－在工具栏图标下显示文本标签。
  • 右侧文本－在工具栏图标右侧显示工具栏文本标签。
  • 无文本标签－只显示工具栏图标。

状态栏－在MAX窗口底部显示或隐藏状态栏。

配置－显示MAX配置目录树。

帮助窗口－显示或隐藏任务列表的帮助。也可单击显示帮助或隐藏帮助按钮。

刷新－刷新MAX配置目录树。也可按<F5>键进行刷新。


MAX工具菜单

工具菜单包含下列选项：

NI网络浏览器－打开NI网络浏览器。用户可通过网络浏览器检测和配置NI网络设备。

NI注册向导－查找和注册NI产品，确保用户获得技术支持和重要更新。用户提交的信息受NI保密条款的保护，更多信息请登录ni.com/legal。

Real-Time Hypervisor管理器－配置和管理Real-Time Hypervisor系统。Real-Time Hypervisor管理器包含用于配置Real-Time Hypervisor设置（例如，系统中硬件设备的中断线和操作系统分配）的接口。关于Real-Time Hypervisor管理器的更多信息，见Real-Time Hypervisor帮助（开始»程序»National Instruments»Real-Time Hypervisor»Real-Time Hypervisor Help）。

注 注：只有在安装该功能后才显示Real-Time Hypervisor管理器菜单项。

创建台式机工具USB驱动器－重新格式化USB驱动器，写入用于LabVIEW Real-Time启动的USB工具，该工具适用于可通过USB启动的台式机。

重置配置数据－重置系统上的所有NI配置数据。

注意 警告：使用NI产品之前必须重启系统。如选择重置配置数据后未重启系统，可能会损坏NI产品。

除标准工具外，依据用户安装的NI产品，MAX还可提供某些特定工具，对系统进行配置、诊断和测试。MAX中的应用程序菜单中将显示此类工具。


MAX帮助菜单

帮助菜单包含下列选项：

MAX帮助－打开主帮助文件。也可按<F1>键打开帮助文件。

帮助主题－访问已经安装的MAX帮助主题。帮助主题的内容由用户安装的NI产品确定。

NI网站－通过访问ni.com，获取技术支持并搜索需要的信息。

技术支持－提供MAX技术支持资源的信息和链接。

系统信息－提供简要的系统信息（例如，操作系统版本、处理器信息、内存容量和已经安装的NI软件）。单击复制全部按钮可将信息复制到剪贴板，并粘贴到文档中。

检查更新－运行NI更新服务，获取新版本的产品和更新。NI更新服务可迅速、方便地对测量系统进行更新。

专利－显示NI的专利信息。

关于－打开关于MAX对话框，显示程序的名称、版本和版权声明。

除了标准工具，依据用户安装的NI产品，MAX还可提供其他工具，对系统进行配置、诊断和测试。MAX的应用程序菜单中将显示这些工具。


MAX使用技巧

MAX技巧

下文列出了一些MAX使用技巧：

  • 刷新视图－选择查看»刷新菜单项或按<F5>键，可查看安装新接口或设备后的视图。大多数设备和接口支持自动刷新功能。
  • 使用多个视图－单击并拖曳MAX接口视图选项卡，可取消选项卡的停靠功能，同时查看多个视图。单击配置目录树左侧的设备时，将显示位于中间的项视图，即由选项卡组成的窗口。该视图用于显示设备的配置设置。关闭选项卡或将其拖曳至项视图，可使选项卡窗口返回原有位置。
  • 锁定视图－单击未停靠的浮动视图的锁定图标 [image] ，可避免在浏览配置目录树中的其他项时关闭该视图。
  • 查看帮助－单击帮助窗口上的显示/隐藏帮助按钮可显示或隐藏帮助面板。单击帮助面板上的浮动按钮 [image] ，可将帮助面板移至MAX界面外。再次单击浮动按钮，帮助面板将返回原有位置。
  • 同时配置多个设备－如需同时配置多个设备或系统，可通过文件»新建»窗口创建新窗口或锁定视图。
  • 选择配置目录树中的多个项－按<Ctrl>或<Shift>键进行选择，可同时选取配置目录树中的多个项。这时，右侧的视图为空白。

    如选定的多个项支持批处理命令，将显示相应的工具栏，右键单击某个选定的项可显示即时帮助。否则，工具栏将为空白，相应的菜单也无法显示。批处理命令用于同时为多个项进行同样的操作。

MAX配置

通常，MAX包含以下6个类别：

  • 数据邻居－该选项用于为设备和接口中配置的通道或测量任务创建虚拟通道、标记或别名。
  • 设备和接口－该选项用于配置设备和接口的资源或其它物理属性。
  • 换算－该选项用于设置对采集数据进行的简单运算。
  • 软件－该选项用于查看、运行或更新已经安装的NI软件。
  • IVI－该选项用于配置IVI仪器(IVI 1.x)或IVI驱动程序（IVI 2.0或更高版本）。
  • 远程系统－该选项用于查看和配置通过以太网连接的设备和系统。


添加网络设备

网络设置包含系统可用的网络或无线设备，用于查看和配置通过网络连接的设备。

什么是网络设备？

网络设备是通过网络或无线连接的设备。网络设备不运行实时操作系统，可同时被多台计算机访问。网络设备不同于远程系统。远程系统是可通过网络管理和配置的实时终端，与不运行实时操作系统的网络设备有所区别。

注 注：NI-DAQmx 4.6、NI-DAQmx 9.0或更高版本支持该功能。设备和接口部分包含不支持该功能的设备。

添加网络设备

如列表中未显示网络设备，可单击添加网络设备，选择要添加的设备类型。按照向导提示在MAX中添加网络设备。

注 注：如需在MAX中添加不支持网络设备功能的设备，可单击设备和接口，选择新建。

关于安装网络设备的更多信息，见系统硬件的说明文档。


设备校准

在系统设置选项卡中通过外部校准和自校准查看设备的基本校准信息。

注 在MAX中，如设备不支持可写校准，校准属性为只读。

外部校准

外部校准必须以高精度外部标准执行。在设备上执行外部校准时请遵循下列步骤。

  1. 以高精度外部标准执行设备性能测量。
  2. 如设备超出外部标准指定的范围，执行调整。在调整过程中，新的校准常量被保存在设备内存中的被保护区域且不可改动，从而保证校准的可追溯性。
  3. 调整后，以高精度外部标准再次执行设备测量。

外部校准必须由度量实验室等保留可追溯校准标准的机构执行。详细信息请访问ni.com/calibration。

注 注：如设备校准为密码保护，必须输入校准密码以保存更改至校准日期和校准截止日期。
  • 校准日期－指定设备上一次外部校准的日期。
  • 校准截止日期－指定设备执行校准的推荐日期。如设备不支持可写校准，MAX在下次校准建议日期中显示下次校准的推荐日期。
  • 设备温度－显示使用板载温度传感器测量，上一次调整时的设备温度。在执行调整时自动设置该值。
  • 更改密码－显示允许用户更改设备校准密码的对话框。

自校准

自校准根据存储在设备上的板载基准调整校准常量。自校准可随时执行，以便在除外部校准的场合以外的环境中调整并使用设备。

新的自校准常量根据外部校准调整后的校准常量定义，以确保测量对外部标准的可追溯性。调整自校准常量不会影响通过外部校准创建的常量，因为它们存储在设备内存的不同区域。

  • 校准日期－显示设备上一次自校准的日期。
  • 设备温度－显示使用板载温度传感器测量，上一次自校准时的设备温度。


使用MAX报表向导

MAX报表向导用于为系统或远程系统创建文档或创建用于技术支持的系统信息报表。报表包含MAX中所有可见的配置信息，以及部分MAX配置目录树中不可见的信息（例如，全局产品设置、软件信息和校准信息）。具体的配置操作取决于产品的驱动程序软件。

配置报表

运行MAX报表向导（文件»创建报表）并完成下列步骤，可创建配置报表：

  1. 选择报表类型：简单报表或自定义报表。简单报表只包含MAX配置目录树中的项名和图标。在自定义报表中，可选择要包含的项并获取更多相关项的详细信息。
    注：报表中包含的信息取决于产品对该功能的支持。如产品不支持创建报表功能，即使选择自定义报表，报表也只包含基本的设备列表。
  2. 选择要创建报表的本地系统或远程系统。每次只能选择一个系统。也可输入远程系统的IP地址。单击 下一步。
  3. 选择要包含在系统中的项。单击 下一步。
  4. 指定生成文件的位置。MAX报表向导会自动记录上次输入的位置。第一次运行MAX报表向导时，默认位置为Documents\MAX目录。
    注：文件名必须以.htm或.html作为扩展名。
  5. 单击下一步，生成报表。MAX报表向导生成报表的时间由系统的复杂程度决定。
  6. 最后出现的对话框用于显示生成的文件。单击完成关闭向导，在默认浏览器中打开报表。如不需要在退出向导后直接查看报表，可取消勾选退出向导后查看报表。

    如需修改报表，可直接编辑HTML文件或在另一个编辑器中进行编辑。
    提示通过在IE中选择文件»另存为，可将报表保存为文件。在保存类型下拉列表中选择Web文档，单个文件(*mht)，单击保存。只能在IE中打开该文件。

系统信息报表

运行MAX报表向导（文件»创建报表），选择技术支持报表，可创建用于技术支持的系统信息报表。

向导生成的压缩文件包含报表和其他文件。


系统配置API函数参考

系统配置应用程序编程接口(API)支持三种不同的应用程序开发环境(ADE)：LabVIEW、LabWindowsTM/CVITM以及Microsoft Visual Studio .NET。

注 注：对API的支持程度取决于产品的驱动程序软件。

系统配置API可替换MAX配置API，并进行大量扩展。该API包含用于保存系统配置和创建系统配置报表的VI和函数，以及用于查找系统中设备的新VI和函数。该API包含的VI可在远程系统上发现、配置和安装软件。

系统配置API帮助文件位置

上述应用程序开发环境(ADE)的帮助文件分别位于：

平台 | 安装位置
LabVIEW | <LABVIEW>/help/nisyscfg.chm
LabWindows/CVI | <National Instruments>/Shared/CVI/nisyscfg/nisyscfgCVI.chm
Microsoft Visual Studio .NET | <MeasurementStudio>/Help/NINETSystemConfig.hxs

注：如需获取帮助文件，首先必须安装应用程序开发环境(ADE)，并在通过NI驱动程序光盘安装MAX时选择相应的ADE支持文件。


疑难解答

通过下列主题对MAX中出现的问题进行疑难解答。

  • 打开MAX时出现MAX数据库连接错误
  • 设备未出现在MAX中
  • 终端返回“不一致的IP设置”状态
  • Windows防火墙
  • 查看错误记录
  • 台式机工具USB驱动器


台式机工具USB驱动器

台式机工具USB驱动器可在装有LabVIEW Real-Time的带USB接口的台式机上进行维护操作。

注：
  • 必须使用可启动的USB设备。
  • 用户必须有主机的管理员权限。

按照下列步骤，在主机或PXI系统上创建台式机工具USB驱动器。

  1. 将USB驱动器插入USB端口。
    注：关闭所有访问USB驱动器的应用程序和窗口。确保USB驱动器未被其他进程使用。
  2. 在MAX菜单项中，选择工具»创建台式机工具USB驱动器。
  3. 单击是，确定需创建台式机工具USB驱动器。
  4. 选择所需工具的版本，单击确定。
  5. 选择USB驱动器，格式化后该USB驱动器将成为台式机工具USB驱动器。单击确定。
    警告：所有USB驱动器上的数据都将被覆盖。
  6. 如有必要，检查USB驱动器，确定是否销毁这些数据。

使用台式机的USB驱动器时，将其插入远程系统所在台式机的空USB端口。打开或重启台式机。

注：必须将使用该USB设备的计算机的BIOS设置为从USB驱动器启动。将启动顺序设为首先搜索USB驱动器上的启动文件。

台式机工具USB驱动器提供了下列菜单项：

  1. 使用安装在硬盘上的软件驱动。
    使用安装在硬盘上的NI Real-Time软件启动系统。如硬盘上未安装任何NI Real-Time软件，驱动盘将把系统启动至安全模式以安装所需软件。
  2. 启动至安全模式。
    将系统启动至安全模式。该选项包括配置系统网络设置以及系统安装软件时所需的最基本服务。安全模式并不动用安装在硬盘上的任何软件，从硬盘启动软件有困难时可将其作为恢复和配置模式使用。
  3. 重置网络配置
    清除系统的IP地址、子网掩码、网关和DNS地址。终端重启后，如终端支持自动IP分配，将自动获取IP地址。如终端启动时的IP地址是0.0.0.0，必须重新配置网络设置。
  4. 清除密码。
    清除任何先前设置的系统密码。
  5. 禁用LabVIEW Real-Time启动应用程序。
    如已有任何LabVIEW Real-Time启动应用程序，则该选项将在系统启动时阻止相关应用程序的运行。一旦应用程序被禁用，必须使用LabVIEW Real-Time开发环境将其重新启用。
  6. 格式化硬盘
    对系统硬盘重新格式化以直接从硬盘启动NI Real-Time软件。该操作将销毁当前硬盘上的所有数据。硬盘格式化后，首次从硬盘启动系统时，系统将启动至安全模式。为支持自动IP地址分配的终端被分配IP地址。对于不支持自动IP地址分配的终端，系统格式化后第一次从硬盘启动时，将启动至安全模式，IP地址为0.0.0.0。此后可配置系统的网络设置并将软件安装至硬盘上。
  7. 评估系统
    对系统的硬件配置进行评估，确定系统是否可运行NI Real-Time软件。
  8. 高级以太网选项
    允许用户通过可用设备列表指定Real-Time操作系统可加载和使用的附加Intel i8254x芯片组以太网设备。同时，还必须通过列表指定禁用设备。

    在RT终端的c:\ni-rt\system\ethernet目录下或安全模式USB驱动器的根目录下创建具有正确格式的enetwhitelist.ini文件，其中包含以太网可用设备列表。
    注 注：即使Intel i8254x芯片组位于可用设备列表中，也不是所有的Intel i8254x芯片组均可用。如需启用安全模式的USB驱动器，USB驱动器必须为Real-Time终端在启动时的唯一USB设备。
  9. 重启设备
    重新启动NI Real-Time系统。
  10. 备份、恢复和复制Real-Time系统
    使用当前USB闪存盘备份、恢复和复制NI Real-Time系统。


打开MAX时出现MAX数据库连接错误

多种原因均可能出现此错误。按照下列步骤解决错误故障。

  • 检查用户防火墙和防病毒设置。需要以管理员身份解除阻止MAX和NI System Web Server。
  • 确保NI Configuration Manager服务已启动。
    1. 以管理员身份登录。
    2. 选择开始»控制面板»管理工具»服务。
    3. 右键单击NI Configuration Manager服务，从快捷菜单中选择属性。
    4. 确保该服务的状态为已启动。如未启动，单击启动按钮启动该服务。
    5. 重启MAX。
  • 如NI Configuration Manager服务未出现在服务列表中，请修复MAX安装。
    1. 单击开始»控制面板»程序和功能。
    2. 选择NI软件，单击卸载/更改。
    3. 从产品列表中选择NI Measurement & Automation Explorer，单击修复。

在极少数情况下，MAX数据库崩溃也可能导致该错误。关于重置MAX数据库的详细信息，见知识库文章4GA9TOQA。


设备未出现在MAX中

本地设备

远程系统

本地设备

按照下列步骤解决本地设备未出现在MAX中的问题。

  • 验证设备是否出现在Windows设备管理器中。如未出现，检查设备与本地系统间的连接。
  • 如设备出现在Windows设备管理器中，验证是否安装了正确的驱动程序。访问ni.com/drivers，下载最新版本的驱动程序。
  • 如已安装正确的驱动程序，验证NI Device Loader服务是否运行。
    1. 以管理员身份登录。
    2. (Windows 7) 选择开始»控制面板»管理工具»服务。(Windows XP) 选择开始»控制面板»管理工具»服务。
    3. 右键单击NI Device Loader服务，从快捷菜单中选择属性。
    4. 确保该服务的状态为已启动。如未启动，单击启动按钮启动该服务。
  • 单击查看»刷新或按下<F5>键，刷新MAX配置目录树。

远程系统

按照下列步骤解决远程系统未出现在MAX中的问题。

  • 单击查看»刷新或按下<F5>键，刷新MAX配置目录树。
  • 验证系统是否与运行MAX的计算机处于同一子网。
  • 新建远程系统。


终端返回“不一致的IP设置”状态

即使终端成功连接至主机，终端仍然可能返回不一致IP设置状态。当终端的IP地址与子网掩码不在主机子网掩码指定的范围内时，会发生IP设置不一致。

(Phar Lap ETS, VxWorks) 如网络适配器设置为使用DHCP，请连接网线重启终端，为终端分配一个新的IP地址。如使用静态IP地址，可更新终端的IP地址，使其与主机IP地址位于同一子网手动修复不一致的IP设置。关于TCP/IP地址和子网的详细信息，请参考微软支持文档。

(NI Linux Real-Time) 按照下列步骤重置终端的IP设置。

  1. 在设备上按下RESET按钮并保持5秒。
  2. STATUS LED显示为黄色时，放开RESET按钮。此时设备进入安全模式。
  3. 按下RESET按钮并保持5秒。
  4. STATUS LED显示为黄色时，放开RESET按钮。此时设备进入安全模式，重置IP设备使用DHCP方式获取IP地址。


查看错误记录

使用查看错误记录选项，查看远程系统的错误记录。右键单击远程系统，选择查看错误记录，可在MAX中访问错误记录。


Windows防火墙

如使用了Windows防火墙，使用MAX时将会出现下列情况：

启用Windows防火墙时，在LabVIEW Real-Time终端上更新软件，将会出现对话框，要求用户允许MAX和NI System Web Server接收网络的信息。选择解除阻止该程序，MAX即可与LabVIEW RT终端进行通信。

关于Microsoft Windows 8和NI产品的更多信息，见ni.com/windows8。关于Microsoft Windows 7和NI产品的更多信息，见ni.com/windows7。

注：必须以管理员身份登录，才能启用或禁用Internet连接防火墙或Windows防火墙。


已安装产品

显示已安装产品的帮助。如显示到产品列表，可通过帮助»帮助主题菜单选择可用的产品帮助文件。


法律信息

有限质量担保

版权

商标

专利权

出口管制信息

关于使用NI产品的警告


有限质量担保

本文件系以“现状”提供，并且可能在将来的版本中不经通知而被修改。请登录ni.com/manuals获取最新版本。为实现技术上的准确性，NI已仔细审查本文件；但是，NI对于本文件所含信息的准确性不作任何明示或默示的保证，并对其错误不承担任何责任。

NI保证于NI发运产品之日起一(1)年内，硬件产品并不存在足以导致产品与NI发布规格实质性不符的材料或技术瑕疵。

NI保证于授予软件许可之日起九十(90)日内，软件(i) 功能将实质性符合软件所附之说明文件；(ii) 记录软件的媒体并无材料或技术瑕疵。

若NI于适用的质量担保期间内，接获瑕疵或不符通知，NI将自行决定：(i) 修复或更换瑕疵产品；或(ii) 退还瑕疵产品之相关费用。修复或更换后之硬件，其质量担保期间应为原质量担保期间之剩余日数，但不得少于九十(90)日。若NI选择修复或更换硬件，NI除可以使用新品外，亦可以使用效能及可靠程度等同于新品、功能至少等同于原始零件或硬件之翻新零件或产品。

客户将任何产品退回NI前，应取得NI的RMA编号。对于有限质量担保并未涵盖之硬件检查与测试，NI有权另行收取服务费用。

本有限质量担保不适用于由于下列事由所导致的产品瑕疵：不当维护、安装、修理或校准（并非由NI所执行者）；未经授权修改；不当环境；使用不当硬件或软件产品密钥；超过产品规格之不当使用或操作；不当电压；意外、错误使用或疏忽；或者自然灾害，比如雷击、水灾或其他天灾。

以上为客户有权主张之唯一救济方法，即使该等救济方法无法达到其主要目的，仍不影响其适用。

除本文件明确规定者外，产品均系以“现状”提供，并无任何保证，NI在此排除有关产品之一切明示或默示保证，包括但不限于“产品适合销售”、“产品满足特定目的”、“权利”、“无侵权”之保证，及因交易习惯或贸易惯例而产生之任何保证。NI并未针对产品之使用或使用结果，提供有关正确、精确、可靠程度或其他方面之保证、担保或声明。NI并未保证产品运作无中断或全无错误。

如果客户已和NI签署单独的含有覆盖产品的质量保证条款的书面协议，则以该单独协议中的质量保证条款为准。


出口管制信息

关于NI全球贸易合规性政策，以及如何获取HTS编码、ECCN和其他进出口数据的详细信息，请参考ni.com/legal/export-compliance/的Export Compliance Information。


版权

根据版权法，未经National Instruments公司事先书面同意，本发行物不得以任何形式（包括电子或机械形式）进行全部或部分复制或传播，包括影印、录制、储存于任何信息检索系统中，以及翻译。

National Instruments公司尊重他方的知识产权，也恳请用户能给予我们同样的尊重。NI软件受版权法及其他知识产权法的保护。在将NI软件用于复制为他方所有的软件或其他资料的任何场合，NI软件仅可用于在符合许可证或其他法律限制的情况下复制上述资料。

最终用户许可协议和第三方法律声明

可在下列位置找到最终用户许可协议(EULA)和第三方法律声明：

  • 法律声明位于<National Instruments>\_Legal Information和<National Instruments>目录下。
  • EULA位于<National Instruments>\Shared\MDF\Legal\license目录下。
  • 如需使NI产品生成的安装程序中包含法律相关信息，请查阅<National Instruments>\_Legal Information.txt。

美国政府的有限权利

如果客户隶属于美国政府的一个机构、部门、或其他单位，则本手册所涵盖的技术信息的使用、拷贝、复制、发布、修改、披露或传递应当受到适用于民间机构的联邦采购条例52.227-14和适用于军用机构的联邦国防采购条例补充规定252.227-7014和252.227-7015中有限权利条款的约束。

IVI Foundation版权声明

Content from the IVI specifications reproduced with permission from the IVI Foundation.

The IVI Foundation and its member companies make no warranty of any kind with regard to this material, including, but not limited to, the implied warranties of merchantability and fitness for a particular purpose. The IVI Foundation and its member companies shall not be liable for errors contained herein or for incidental or consequential damages in connection with the furnishing, performance, or use of this material.


商标

关于National Instruments商标的详细信息，请访问ni.com/trademarks的NI Trademarks and Logo Guidelines页面。

ARM, Keil, and µVision are trademarks or registered of ARM Ltd or its subsidiaries.

LEGO, the LEGO logo, WEDO, and MINDSTORMS are trademarks of the LEGO Group.

TETRIX by Pitsco is a trademark of Pitsco, Inc.

FIELDBUS FOUNDATION™ and FOUNDATION™ are trademarks of the Fieldbus Foundation.

EtherCAT® is a registered trademark of and licensed by Beckhoff Automation GmbH.

CANopen® is a registered Community Trademark of CAN in Automation e.V.

DeviceNet™ and EtherNet/IP™ are trademarks of ODVA.

Go!, SensorDAQ, and Vernier are registered trademarks of Vernier Software & Technology. Vernier Software & Technology and vernier.com are trademarks or trade dress.

Xilinx is the registered trademark of Xilinx, Inc.

Taptite and Trilobular are registered trademarks of Research Engineering & Manufacturing Inc.

FireWire® is the registered trademark of Apple Inc.

Linux® is the registered trademark of Linus Torvalds in the U.S. and other countries.

Handle Graphics®, MATLAB®, Real-Time Workshop®, Simulink®, Stateflow®, and xPC TargetBox® are registered trademarks, and Simulink Coder™, TargetBox™ and Target Language Compiler™ are trademarks of The MathWorks, Inc.

Tektronix®, Tek, and Tektronix, Enabling Technology are registered trademarks of Tektronix, Inc.

The Bluetooth® word mark is a registered trademark owned by the Bluetooth SIG, Inc.

The ExpressCard™ word mark and logos are owned by PCMCIA and any use of such marks by National Instruments is under license.

The mark LabWindows is used under a license from Microsoft Corporation. Windows is a registered trademark of Microsoft Corporation in the United States and other countries.

此处提及的其他产品和公司名称均为其各自公司的商标或商业名称。

National Instruments Alliance Partner Program的成员为独立于NI的商业实体，与NI无代理、合伙或合资关系。


专利权

关于NI产品和技术的专利权，请查看软件中的帮助»专利信息、光盘中的patents.txt文件或ni.com/patents上的National Instruments Patent Notice。


使用NI产品的注意事项

当用户的系统或程序包含NI产品时，用户应对测试和验证产品的适用性及可靠性承担最终责任，包括该系统或程序的合理设计、流程和安全等级。

产品之设计、制造、测试目的，并非针对生命或安全攸关系统、危险环境或其他需要故障保全功能之环境，包括核能设施、飞行器导航设备、航空交通控制系统、救生系统、维生系统或其他医疗器材，以及产品故障可能导致死亡、人身伤害、严重财产损害或环境灾害之其他应用方式（合称“高风险用途”）。此外，必须采取谨慎的措施应对故障，包括备份和关闭机制。NI明确否认对高风险用途的产品或服务的适用性作任何明示或默示的保证。


MAX技术支持

MAX可以生成两种报表：作为所选系统文档的配置报表和用于技术支持的系统信息报表。

配置报表

通过运行MAX报表向导（文件»创建报表），选择简易报表或自定义报表，可生成配置报表。向导将生成包含选定系统配置信息的HTML格式报表。更多信息，见使用MAX报表向导。

系统信息报表

运行MAX报表向导（文件»创建报表），选择技术支持，可生成用于技术支持的系统信息报表。通过NI技术支持/请求支持服务获取相关问题解决方案时可提交这些报表。更多信息，见使用MAX报表向导。

技术支持资源

访问驱动和更新可立即检查软件更新。关于NI技术支持和专业服务的更多信息，见技术支持资源。


NI服务

NI提供全球服务和支持，致力于帮助客户成功。用户可利用产品服务、培训及认证项目，满足应用程序生命周期各阶段的需求，包括计划、开发、部署及持续维护。

用户首先需要访问ni.com/myproducts，创建一个账号或登录MyNI用户账号，并注册产品。

NI产品注册用户可享有以下权益：

  • 访问可用的产品服务。
  • 在线账户有助于更加轻松地管理产品。
  • 接收关键更新、软件更新和服务到期提醒。

服务和资源

  • 维护和硬件服务－在整个系统生命周期中，NI帮助用户确定系统的精度和可靠性要求，并提供保修、替换和校准服务，从而帮助用户维护精度并将系统故障降至最低。详细信息见ni.com/services。
    • 保修和维修－所有NI硬件的标准保修期均为一年，保修期最多可延长至五年。NI提供及时维修服务，维修由受过专业训练的工厂技术人员在NI服务中心全部使用原厂配件完成。
    • 校准－定期校准有助于量化并提高仪器的测量性能。NI提供最先进的校准服务。如产品支持校准服务，可访问ni.com/calibration获取校准证书。
  • 系统集成－NI联盟伙伴(National Instruments Alliance Partner)可帮助解决时间限制、内部技术资源短缺或其他项目问题。详情请致电当地NI办事处或登录网站ni.com/alliance。
  • 培训与认证－NI培训和认证项目是提高应用开发熟练度和效率的最佳方式。详细信息见ni.com/training。
    • 技能指南可帮助用户确定当前应用开发的熟练度需求，并根据时间、预算限制和个人学习兴趣提供学习所需技能的选项列表。详细信息见ni.com/skills-guide。
    • NI提供多种语言和形式的培训课程，包括世界各地NI分支机构举办的面授培训、上门培训以及在线课程，满足不同客户的需求。
  • 技术支持－技术支持ni.com/support包括以下资源：
    • 自助技术资源－请访问ni.com/support，查阅有关软件驱动和更新、可搜索的知识库、产品手册、疑难解答向导、数千个范例程序、产品教程、应用指南、仪器驱动等相关信息。注册用户还可访问ni.com/forums参与NI论坛。NI应用工程师可确保您在线提交的问题得到解答。
    • 软件支持服务成员－标准服务项目(SSP)是可续订的一年制订阅服务，几乎每个NI软件产品均包含该服务，包括NI Developer Suite。标准服务项目成员可通过电话或电子邮件直接获取NI应用工程师的一对一技术支持，以及ni.com/self-paced-training提供的专享自选在线培训模块。NI还提供灵活的扩展合同选项，保证您可按照自身需求，持续地享受SSP权益。详细信息见ni.com/ssp。
  • 合规声明(DoC)－是NI对符合欧盟委员会要求所作的合规声明。该系统可确保电子产品的电磁兼容性(EMC)和安全性。请访问ni.com/certification获取产品的合规声明。

如需了解更多当地的技术支持服务，请访问ni.com/services或ni.com/contact与当地办事处联系。

您也可以访问ni.com/niglobal的全球办事处页面查找最新的办事处联系方式、技术支持电话、电子邮件地址及最新消息。


JavaScript已禁用。


VI记录器

VI记录器是用于定义和执行数据记录任务的软件工具。VI记录器用于完成下列任务：

  • 新建VI记录器任务
  • 修改VI记录器任务
  • 运行VI记录器任务
  • 在采集或记录操作时查看数据
  • 查看数据记录

VI记录器的版本与该版本的MAX不兼容。通过安装ftp://ftp.ni.com/support/vilogger/upgrades/1.0.2/补丁，可将VI记录器更新为1.0.2版。


数据邻居

数据邻居用于通过带有描述性名称的快捷方式，配置系统的物理通道。这些快捷方式包括CAN信息、NI-DAQ虚拟通道和任务，以及FieldPoint项。

操作指南

新建快捷方式

右键单击数据邻居，选择新建。根据用户所安装的NI产品，显示的选项有所不同。

测试或删除快捷方式

通常，右键单击快捷方式即可执行任务，具体任务由安装的NI产品确定。

查看或改变属性

通常，依据安装的软件，可右键单击配置目录树中的快捷方式并选择属性，或在项目视图中对属性进行调整。

关于在不同NI产品中使用数据邻居的更多信息，见帮助»帮助主题菜单栏中列出的产品帮助文档。也可通过帮助菜单或单击<F1>键，访问MAX帮助中的产品说明。


设备和接口

设备和接口用于显示已经安装或检测到的CAN、DAQ、FieldPoint串口控制器、GPIB、IVI、Motion、串口、VISA、Vision和VXI硬件。

如没有在列表中找到设备，原因可能是...

未刷新配置目录树

按<F5>或选择查看»刷新。

设备不支持Windows即插即用

关于添加此类设备的更多信息，可通过帮助»帮助主题查看设备的帮助文件或下列说明。

操作指南

配置现有设备

依据安装的软件，可选用如下方式配置设备：右键单击配置目录树中的设备名并选择配置，单击工具栏中的配置按钮 [image] ，或在项目视图中对属性进行调整。

添加即插即用设备

某些设备不支持Windows即插即用，因而无法在设备和接口列表中自动显示。位于网络中其它计算机上的设备。右键单击配置目录树中的设备和接口，选择新建，添加非即插即用设备。完成操作，关闭向导。

如安装的设备仍无法显示，可参见相关硬件的使用指南和MAX中的相关帮助（帮助»帮助主题），确认设备已正确安装并获取有关配置的信息。确认正确安装设备后，访问驱动程序的技术支持网页：

CAN | DAQ | FieldPoint
GPIB | IVI | 模块化仪器
运动控制 | NI Switch Executive | NI Vision
串口 | VISA | VXI

关于在MAX中使用NI产品的更多信息，见帮助»帮助主题菜单栏中列出的产品帮助文档。也可通过帮助菜单或单击<F1>键，访问MAX帮助中的产品说明。


历史数据

历史数据用于访问数据库、数据记录或数据视图。

操作指南

查看数据

如需查看和管理数据库或数据视图，可展开配置目录树中的历史数据。选择Citadel 5 Universe后，数据库将显示在数据库视图中。用户的数据视图位于Citadel 5 Universe下面。

创建数据库

如需创建新的数据库，可右键单击历史数据并选择新建。在新建向导中选择Citadel 5数据库，单击下一步。按照指示新建数据库，单击完成。选择历史数据类别下的Citadel 5 Universe后，数据库将显示在数据库视图中。

将Citadel 4数据库转换为Citadel 5格式

如需将Citadel 4格式的数据库转换为Citadel 5格式，可右键单击历史数据并选择新建。在新建向导中选择将Citadel 4数据库转换为Citadel 5格式，单击下一步。按照指示选择要转换的数据库和新数据库的位置，单击完成。

删除数据库

如需删除数据库，可右键单击数据库视图中的数据库，并选择分离/删除。在分离/删除数据库对话框中选择删除，单击确定。

新建数据视图

如需新建数据视图，可右键单击Citadel 5 Universe，并选择新建»警报/事件视图或新建»追踪视图。新的数据视图位于配置目录树中的Citadel 5 Universe下面。

查看Citadel 4数据

关于查看Citadel 4数据的更多信息，见历史数据查看器帮助，以及Citadel 4视图和数据库的帮助。通过帮助»帮助主题»历史数据查看器，可查看历史数据查看器帮助。

关于历史数据查看器的更多信息，可通过帮助»帮助主题»历史数据查看器，查阅历史数据查看器帮助。


IVI

IVI类别用于访问逻辑名称向导和IVI逻辑名称。逻辑名称是对某个虚拟仪器的引用。

操作指南

创建虚拟仪器的逻辑名称

展开IVI类别，为虚拟仪器创建逻辑名称。右键单击配置目录树中的逻辑名称选项，选择插入。完成操作，关闭向导。

提示 右键单击项并选择插入，可创建IVI逻辑名称、虚拟仪器、仪器驱动程序和设备。例如，右键单击配置目录树中的仪器驱动程序项并选择插入，可打开指定驱动程序部分的逻辑名称向导，创建新的仪器驱动程序。

修改已有的虚拟仪器属性

选择配置目录树中的虚拟仪器，可配置已有的虚拟仪器。所有的虚拟仪器都显示在配置目录树右侧的项视图中。右键单击项视图中的虚拟仪器，选择属性。

交换仪器

选择配置目录树中的逻辑名称项，对仪器进行交换。在项视图中，右键单击要交换仪器的逻辑名称，选择属性。在对话框中，单击更改按钮即可为新的物理仪器创建或选择虚拟仪器。


National Instruments Measurement & Automation Explorer

Measurement & Automation Explorer (MAX)用于访问NI产品。

操作指南

管理设备和接口

在配置目录树左侧选择设备和接口。如需获取安装设备的帮助信息，见NI硬件的入门指南。

管理已经安装的NI软件

在配置目录树左侧选择软件。

管理设备的虚拟通道和任务

在配置目录树左侧选择数据邻居。

创建虚拟仪器的换算

在配置目录树左侧选择换算。

配置IVI仪器驱动程序

在配置目录树左侧选择IVI。

导入/导出设备的配置文件

选择文件»导入或文件»导出菜单项，导入或导出配置文件。某些设备不支持该功能。更多信息，见设备相关文档。

注：某些类别只适用于特定设备。例如，IVI类别只适用于已经安装的IVI。

如需了解更多关于使用MAX的信息，可从帮助菜单中选择相应的帮助类别。如需获取更多帮助或了解设备的更多信息，可访问NI技术支持网站。

关于该版本MAX的详细信息，请查看自述文件或访问ni.com/info输入下列信息代码：

  • SysCfgFixList－改进和程序漏洞修补
  • SysCfgKnownIssues－已知问题


换算

换算包含所有已配置的换算，并对采集到的数据进行运算。

操作指南

新建自定义换算

右键单击配置目录树中的换算，选择新建。

删除换算

如需从配置中删除换算，可右键单击配置目录树中的换算名，选择删除。

查看或修改换算属性

依据安装的软件，可右键单击配置目录树中的通道名，选择属性，或在项目视图中对属性进行调整。

关于在不同NI产品中使用换算的更多信息，见帮助»帮助主题中列出的产品帮助文档。也可通过帮助菜单或单击<F1>键，访问MAX帮助中的产品说明。


软件

软件用于查看、运行和更新已经安装的NI软件。

操作指南

查看软件信息

在配置目录树中展开软件。

运行软件

右键单击配置目录树中的产品名称，选择运行。

添加、更改或删除软件

单击更改/删除软件按钮，可通过工具更改或卸载NI软件。

检查软件更新

右键单击配置目录树中的软件类别，选择获取软件更新。NI更新服务可搜索NI网站，获取相应的软件更新和搜索结果。根据返回的列表，用户可确定要下载并安装的软件。通过帮助菜单或软件类别也可对软件进行更新。

如NI更新服务未显示已安装的软件，可访问ni.com/updates的驱动和更新页面，检查更新。

关于NI产品的更多信息，可通过帮助»帮助主题菜单项，查阅产品的相应文档。也可通过帮助菜单或单击<F1>键，访问MAX帮助中的产品说明。


VI记录器

VI记录器是用于定义和执行数据记录任务的软件工具。简化版VI记录器包含用于NI-DAQmx设备的基本数据记录和采集工具。完整版VI记录器包含用于NI-DAQmx、传统NI-DAQ (Legacy)和FieldPoint设备的其它功能。

操作指南

新建VI记录器任务

右键单击MAX配置目录树中的VI记录器任务，选择新建，可创建新的VI记录器任务。在新建对话框中，选择用于任务的设备：使用NI-DAQmx、使用传统NI-DAQ或使用FieldPoint。单击完成按钮。新建的任务位于配置目录树中的VI记录器任务下面。通过任务属性视图、DAQmx、Virtual或FieldPoint通道视图可配置任务设置。

修改VI记录器任务

如需修改任务，可在配置目录树中选择任务，显示该任务的VI记录器窗口。编辑开始和停止条件、记录条件，或数据导出设置。单击保存任务按钮，或运行任务并保存更改。

运行VI记录器任务

通过任务属性视图中的控件可设置VI记录器任务的采集和记录条件。如需运行任务，可在配置目录树中选择该任务，并单击工具栏中的运行任务按钮。如没有指定任务的停止条件，必须单击停止任务按钮才能使任务停止执行。

在采集或记录操作时查看数据

实时数据视图用于以图形化方式查看VI记录器任务运行时的数据。实时数据视图左上角的指示灯 [image] 用于切换查看实时数据或历史数据。单击红色指示灯可暂停任务，查看历史数据。单击绿色指示灯，可查看实时数据。VI记录器获取的数据可通过图形上方的四个箭头进行查看。

查看数据记录

VI记录器将把数据保存在任务运行中，数据记录结束后，它位于配置目录树中的相关任务下方。任务运行的默认名称是数据记录开始时的时间和日期。单击要查看的任务运行。历史数据视图用于显示任务运行中数据的图形。图形上方的四个箭头用于浏览已经记录的数据。

激活简化版VI记录器，使其成为完整版

在简化版中，选择工具»VI记录器»激活VI记录器2.0的全部功能。在对话框中，单击购买许可证按钮，可显示用于购买许可证的页面。单击激活许可证按钮，激活软件。只用使用有效的序列号，才能激活完整版VI记录器。