Measurement & Automation Explorer Help for PXI

July 2021, 370703L-01

This help file explains how to use Measurement & Automation Explorer (MAX) to configure your PXI system.

For more information, refer to the following topics:

Legal Information

NI Services

© 2003–2021 National Instruments Corporation. All rights reserved.

Refer to the <National Instruments>\_Legal Information directory for information about NI copyright, patents, trademarks, warranties, product warnings, and export compliance.


Getting Started

To begin using your PXI system, all PXI chassis and controllers must be properly detected and identified as the correct model. If your PXI chassis is listed as Unidentified Chassis, continue to Chassis Identification.

All PXI Express chassis and controllers are detected and identified automatically. If your PXI Express chassis or controller is not displayed under Devices and Interfaces, contact your hardware vendor for assistance.


Chassis and Controller Detection

All supported NI PXI controllers and chassis are detected automatically and already should be listed under Devices and Interfaces. PXI controllers from other manufacturers cannot be detected automatically. All PXI Express controllers and chassis, regardless of manufacturer, are detected and configured automatically.


Chassis Identification

When a chassis is detected, the software may be unable to determine what model of chassis it is. When this is the case, the chassis appears as Unidentified Chassis. Chassis functionality is not enabled until the model is identified to the software. You may identify the chassis by selecting the model name for your chassis in the Model dropdown in the Settings tab for your chassis.


PXI System Settings

PXI System Settings is located under My System in MAX.

PXI Resource Manager

The Active PXI Resource Manager is responsible for creating and updating system description files that describe any PXI hardware in a system.

The PXI Systems Alliance (PXISA) manages the specifications for PXI which determine how a Resource Manager is allowed to behave in a system. While a system can contain multiple PXI Resource Managers, only one can be designated as the Active PXI Resource Manager.

In MAX, select National Instruments as the Active Resource Manager to make the following changes:

  • Set or modify a chassis number
  • Set or modify a chassis model

MAX provides the option of selecting the Active Resource Manager from what is available on the system.

Selection Mode

  • Automatically Selected—The Active Resource Manager is automatically selected according to rules set by the PXISA specifications.
  • User Selected—The Active Resource Manager is selected by the user.

Active Resource Manager (Read-only if Selection Mode is set to Automatic)

  • (None Selected)—An Active Resource Manager has not been selected.
  • <Resource Manager>—The selected Resource Manager is set to active.

The selector displays all Resource Managers that are detected in the PXISA services tree.

For more information about the PXI Resource Manager, refer to www.pxisa.org.

PXI Trigger Manager

A PXI Trigger Manager is responsible for:

  • Reservation functionality for the trigger bus lines in the chassis.
  • Routing functionality for the trigger bus lines in the chassis.
Note Note Routing functionality is available only if supported by the chassis hardware.

A PXI(e) chassis defaults to using either a model-specific or vendor-specific Trigger Manager if dictated by the chassis.

PXI(e) chassis that do not specify a PXI Trigger Manager use the system default. Chassis that use the system default Trigger Manager are only able to support trigger reservations. MAX provides the option of selecting the system default PXI Trigger Manager from what is available on the system.

Selection Mode

  • Automatically Selected—The system Default Trigger Manager is selected from the available default PXI Trigger Managers on the system.
  • User Selected—The PXI Trigger Manager is selected by the user.

For systems with only one Trigger Manager, this option is read-only.

Note Note If only one Trigger Manager exists on the system, the Selection Mode is set to Automatic.

Default Trigger Manager (Read-only if Selection Mode is set to Automatic)

  • <Vendor Trigger Managers>—The Default Trigger Manager is set to the specified vendor's Trigger Manager.

The selector shows all default Trigger Managers that are detected in the PXISA services tree.

For more information about the PXI Trigger Manager, refer to www.pxisa.org.


Trigger Routing and Reservation

What Are PXI Triggers?

PXI triggers are signals for synchronizing events between devices in a chassis. Devices in the chassis assert or de-assert these signals, and they are passed to other devices through trigger lines on the chassis backplane. Each trigger bus on a chassis backplane contains eight PXI trigger lines (PXI_Trig0 through PXI_Trig7). Each slot in a PXI chassis is connected to a single trigger bus and can transmit and receive signals over the trigger lines from any other device on the same bus. Most chassis contain only a single trigger bus, but some chassis, such as the PXIe-1095, have multiple trigger buses.

Chassis with a Single Trigger Bus

In chassis containing only a single bus, all slots share the same trigger bus and can communicate to each other using this bus. For example, the PXIe-1082 chassis has one trigger bus, and all slots (1–8) reside on this trigger bus. In this situation, a device in any slot can use the backplane to send triggers to a device in any other slot.

Chassis with Multiple Trigger Buses

Without further configuration, chassis with multiple trigger buses function like three separate single-segment chassis. A device in a slot connected to one trigger bus cannot use the trigger lines to communicate to a device connected to another trigger bus. To see what slots are assigned to each trigger bus, refer to the Bus Mappings Legend area of the Trigger view for your chassis.

When properly configured, NI software automatically connects bus segments when an NI driver API references modules on different PXI buses.

Trigger route types are dynamic (the default), Away from Bus 1, Away from Bus 2, and Away from Bus 3.

Note Note Refer to the NI KnowledgeBase article 32GFMIWD: Routing PXI Trigger Lines Across the Buses of Multisegment PXI Chassis, to learn more about trigger routing in PXI chassis with multiple trigger buses.


Frequently Asked Questions

Can I route PXI_Trig0 in Bus 1 to PXI_Trig0 in Bus 2 without also routing it to PXI_Trig0 in Bus 3?

No. When a trigger is routed from a bus, it is routed from the source bus to all other buses in the chassis.

Can I route PXI_Trig0 in Bus 1 to PXI_Trig1 in Bus 2?

No. Each route connects the trigger on the source bus to the same trigger on each other bus in the chassis.

Can I route triggers between two chassis?

This depends on the modules present in your chassis. Some modules can source triggers from the chassis backplane and drive them to a module in another chassis over a cabled connection. Consult the manuals for your PXI/PXI Express modules for additional details.


Programmatically Routing and Reserving Triggers

Programmatically Routing and Reserving Triggers in VISA

Programmatically routing and reserving triggers is possible using NI-VISA 3.0 and later on a per-module basis. After opening a VISA session to a PXI INSTR resource, you can reserve a trigger line on the trigger bus connected to the device. Additionally, trigger routing and reservation is available through a PXI BACKPLANE resource, available in NI-VISA 3.1 and later. For more information, refer to your NI-VISA documentation.

Programmatically Routing and Reserving Triggers in NI-DAQmx

NI-DAQmx supports programmatically routing and reserving triggers on a per-instrument basis. Refer to Triggering in the NI-DAQmx Help for complete documentation.


Troubleshooting

Why do my VISA instruments have unknown chassis and slot numbers?

You have not properly configured your PXI system. You must identify the PXI chassis model correctly before geographic addressing such as chassis and slot number is enabled. Follow the procedures in Getting Started to configure your PXI system correctly.

Why is my PXI LabVIEW Real-Time target disconnected?

MAX cannot find your system on the network. Ensure that the system is powered on and verify that the network equipment is functioning properly.

For more information about LabVIEW Real-Time target states, refer to System States in the MAX Remote Systems Help.


Legal Information

Limited Warranty

Copyright

Trademarks

Patents

Export Compliance Information

Warning Regarding Use of NI Products


Limited Warranty

This document is provided "as is" and is subject to being changed, without notice, in future editions. For the latest version, refer to ni.com/manuals. NI reviews this document carefully for technical accuracy; however, NI MAKES NO EXPRESS OR IMPLIED WARRANTIES AS TO THE ACCURACY OF THE INFORMATION CONTAINED HEREIN AND SHALL NOT BE LIABLE FOR ANY ERRORS.

NI warrants that its hardware products will be free of defects in materials and workmanship that cause the product to fail to substantially conform to the applicable NI published specifications for one (1) year from the date of invoice.

For a period of ninety (90) days from the date of invoice, NI warrants that (i) its software products will perform substantially in accordance with the applicable documentation provided with the software, and (ii) the software media will be free from defects in materials and workmanship.

If NI receives notice of a defect or non-conformance during the applicable warranty period, NI will, in its discretion: (i) repair or replace the affected product, or (ii) refund the fees paid for the affected product. Repaired or replaced hardware will be warranted for the remainder of the original warranty period or ninety (90) days, whichever is longer. If NI elects to repair or replace the product, NI may use new or refurbished parts or products that are equivalent to new in performance and reliability and are at least functionally equivalent to the original part or product.

You must obtain an RMA number from NI before returning any product to NI. NI reserves the right to charge a fee for examining and testing hardware not covered by the Limited Warranty.

This Limited Warranty does not apply if the defect of the product resulted from improper or inadequate maintenance, installation, repair, or calibration (performed by a party other than NI); unauthorized modification; improper environment; use of an improper hardware or software key; improper use or operation outside of the specification for the product; improper voltages; accident, abuse, or neglect; or a hazard such as lightning, flood, or other act of nature.

THE REMEDIES SET FORTH ABOVE ARE EXCLUSIVE AND THE CUSTOMER'S SOLE REMEDIES, AND SHALL APPLY EVEN IF SUCH REMEDIES FAIL OF THEIR ESSENTIAL PURPOSE.

EXCEPT AS EXPRESSLY SET FORTH HEREIN, PRODUCTS ARE PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND AND NI DISCLAIMS ALL WARRANTIES, EXPRESSED OR IMPLIED, WITH RESPECT TO THE PRODUCTS, INCLUDING ANY IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, TITLE OR NON-INFRINGEMENT, AND ANY WARRANTIES THAT MAY ARISE FROM USAGE OF TRADE OR COURSE OF DEALING. NI DOES NOT WARRANT, GUARANTEE, OR MAKE ANY REPRESENTATIONS REGARDING THE USE OF OR THE RESULTS OF THE USE OF THE PRODUCTS IN TERMS OF CORRECTNESS, ACCURACY, RELIABILITY, OR OTHERWISE. NI DOES NOT WARRANT THAT THE OPERATION OF THE PRODUCTS WILL BE UNINTERRUPTED OR ERROR FREE.

In the event that you and NI have a separate signed written agreement with warranty terms covering the products, then the warranty terms in the separate agreement shall control.


Copyright

Under the copyright laws, this publication may not be reproduced or transmitted in any form, electronic or mechanical, including photocopying, recording, storing in an information retrieval system, or translating, in whole or in part, without the prior written consent of National Instruments Corporation.

NI respects the intellectual property of others, and we ask our users to do the same. NI software is protected by copyright and other intellectual property laws. Where NI software may be used to reproduce software or other materials belonging to others, you may use NI software only to reproduce materials that you may reproduce in accordance with the terms of any applicable license or other legal restriction.

End-User License Agreements and Third-Party Legal Notices

You can find end-user license agreements (EULAs) and third-party legal notices in the following locations:

  • Notices are located in the <National Instruments>\_Legal Information and <National Instruments> directories.
  • EULAs are located in the <National Instruments>\Shared\MDF\Legal\license directory.
  • Review <National Instruments>\_Legal Information.txt for information on including legal information in installers built with NI products.

U.S. Government Restricted Rights

If you are an agency, department, or other entity of the United States Government ("Government"), the use, duplication, reproduction, release, modification, disclosure or transfer of the technical data included in this manual is governed by the Restricted Rights provisions under Federal Acquisition Regulation 52.227-14 for civilian agencies and Defense Federal Acquisition Regulation Supplement Section 252.227-7014 and 252.227-7015 for military agencies.

IVI Foundation Copyright Notice

Content from the IVI specifications reproduced with permission from the IVI Foundation.

The IVI Foundation and its member companies make no warranty of any kind with regard to this material, including, but not limited to, the implied warranties of merchantability and fitness for a particular purpose. The IVI Foundation and its member companies shall not be liable for errors contained herein or for incidental or consequential damages in connection with the furnishing, performance, or use of this material.


Trademarks

Refer to the NI Trademarks and Logo Guidelines at ni.com/trademarks for more information on NI trademarks.

ARM, Keil, and µVision are trademarks or registered of ARM Ltd or its subsidiaries.

LEGO, the LEGO logo, WEDO, and MINDSTORMS are trademarks of the LEGO Group.

TETRIX by Pitsco is a trademark of Pitsco, Inc.

FIELDBUS FOUNDATION™ and FOUNDATION™ are trademarks of the Fieldbus Foundation.

EtherCAT® is a registered trademark of and licensed by Beckhoff Automation GmbH.

CANopen® is a registered Community Trademark of CAN in Automation e.V.

DeviceNet™ and EtherNet/IP™ are trademarks of ODVA.

Go!, SensorDAQ, and Vernier are registered trademarks of Vernier Software & Technology. Vernier Software & Technology and vernier.com are trademarks or trade dress.

Xilinx is the registered trademark of Xilinx, Inc.

Taptite and Trilobular are registered trademarks of Research Engineering & Manufacturing Inc.

FireWire® is the registered trademark of Apple Inc.

Linux® is the registered trademark of Linus Torvalds in the U.S. and other countries.

Handle Graphics®, MATLAB®, Simulink®, Stateflow®, and xPC TargetBox® are registered trademarks, and Simulink Coder™, TargetBox™, and Target Language Compiler™ are trademarks of The MathWorks, Inc.

Tektronix®, Tek, and Tektronix, Enabling Technology are registered trademarks of Tektronix, Inc.

The Bluetooth® word mark is a registered trademark owned by the Bluetooth SIG, Inc.

The ExpressCard™ word mark and logos are owned by PCMCIA and any use of such marks by National Instruments is under license.

The mark LabWindows is used under a license from Microsoft Corporation. Windows is a registered trademark of Microsoft Corporation in the United States and other countries.

Other product and company names mentioned herein are trademarks or trade names of their respective companies.

An NI Partner is a business entity independent from NI and has no agency, partnership, or joint-venture relationship with NI.


Patents

For patents covering the NI products/technology, refer to the appropriate location: Help»Patents in your software, the patents.txt file on your media, or the Patent Notice at ni.com/patents.


Export Compliance Information

Refer to the Export Compliance Information at ni.com/legal for the NI global trade compliance policy and how to obtain relevant HTS codes, ECCNs, and other import/export data.


WARNING REGARDING USE OF NATIONAL INSTRUMENTS PRODUCTS

WARNING REGARDING USE OF NATIONAL INSTRUMENTS CORPORATION PRODUCTS

YOU ARE ULTIMATELY RESPONSIBLE FOR VERIFYING AND VALIDATING THE SUITABILITY AND RELIABILITY OF THE PRODUCTS WHENEVER THE PRODUCTS ARE INCORPORATED IN YOUR SYSTEM OR APPLICATION, INCLUDING THE APPROPRIATE DESIGN, PROCESS, AND SAFETY LEVEL OF SUCH SYSTEM OR APPLICATION.

PRODUCTS ARE NOT DESIGNED, MANUFACTURED, OR TESTED FOR USE IN LIFE OR SAFETY CRITICAL SYSTEMS, HAZARDOUS ENVIRONMENTS OR ANY OTHER ENVIRONMENTS REQUIRING FAIL-SAFE PERFORMANCE, INCLUDING IN THE OPERATION OF NUCLEAR FACILITIES; AIRCRAFT NAVIGATION; AIR TRAFFIC CONTROL SYSTEMS; LIFE SAVING OR LIFE SUSTAINING SYSTEMS OR SUCH OTHER MEDICAL DEVICES; OR ANY OTHER APPLICATION IN WHICH THE FAILURE OF THE PRODUCT OR SERVICE COULD LEAD TO DEATH, PERSONAL INJURY, SEVERE PROPERTY DAMAGE OR ENVIRONMENTAL HARM (COLLECTIVELY, "HIGH-RISK USES"). FURTHER, PRUDENT STEPS MUST BE TAKEN TO PROTECT AGAINST FAILURES, INCLUDING PROVIDING BACK-UP AND SHUT-DOWN MECHANISMS. NI EXPRESSLY DISCLAIMS ANY EXPRESS OR IMPLIED WARRANTY OF FITNESS OF THE PRODUCTS OR SERVICES FOR HIGH-RISK USES.


NI Services

The NI website is your complete resource for technical support. At ni.com/support, you have access to everything from troubleshooting and application development self-help resources to email and phone assistance from NI Technical Support Engineers.

Visit ni.com/services for information about the services NI offers.

Visit ni.com/register to register your NI product. Product registration facilitates technical support and ensures that you receive important information updates from NI.

NI corporate headquarters is located at 11500 North Mopac Expressway, Austin, Texas, 78759-3504, USA. For up-to-date contact information for your location, visit ni.com/contact.


Chassis General View (PXI-1 Variant)

What Are Chassis Status Messages?

Chassis status messages report the chassis operational status. If the chassis is experiencing reduced functionality or is inoperable, a status message explains the cause.

What Is the Chassis Number Used For?

The chassis number is a unique logical ID belonging to this chassis.

What Is Chassis Identification?

Chassis identification indicates the selected chassis model to the system. Without a valid identification, the system cannot properly determine the connected devices, trigger routing, and reservations, and additional functionality may not be available. Some chassis are unconfigured by default and must be identified, while other chassis may be identified automatically.

Refer to Getting Started for more information about chassis identification and numbering.


Chassis General View (PXI Express Variant)

What Are Chassis Status Messages?

Chassis status messages report the chassis operational status. If the chassis is experiencing reduced functionality or is inoperable, a status message explains the cause.

What Is the Chassis Number Used For?

The chassis number is a unique logical ID belonging to this chassis.


Chassis Trigger View (Single Bus)

Trigger Reservation

If multiple devices attempt to use the same trigger line simultaneously, hardware damage can occur. By reserving any predetermined trigger lines, NI software can use the remaining available trigger lines safely and automatically. Reserve trigger lines that are necessary for applications that use third-party devices, or in any case where the trigger lines are used without being programmatically reserved.

For more detailed information, refer to Trigger Routing and Reservation.


Chassis Trigger View (Three Bus)

Trigger Reservation

If multiple devices attempt to use the same trigger line simultaneously, hardware damage can occur. By reserving any predetermined trigger lines, NI software can use the remaining available trigger lines safely and automatically. Reserve trigger lines that are necessary for applications that use third-party devices, or in any case where the trigger lines are used without being programmatically reserved.

For more detailed information, refer to Trigger Routing and Reservation.

Trigger Routing

Without further configuration, chassis with multiple trigger buses function like three separate single-segment chassis. A device in a slot connected to one trigger bus cannot use the trigger lines to communicate to a device connected to another trigger bus. To see what slots are assigned to each trigger bus, refer to the Bus Mappings Legend area of the Trigger view for your chassis.

Trigger route types are dynamic (the default), Away from Bus 1, Away from Bus 2, and Away from Bus 3.

  • Dynamic: The routes are left unconfigured and available for other NI products to perform programmatic or automated routes to connect devices.
  • Away from Bus 1: The route carries the trigger signal sourced from the lowest-numbered bus toward the highest-numbered bus.
  • Away from Bus 2: The route carries a trigger signal sourced from the middle trigger bus to the higher- and lower-numbered buses.
  • Away from Bus 3: The route carries a trigger signal sourced from the highest-numbered bus toward the lowest-numbered bus.

For more detailed information, refer to Trigger Routing and Reservation.


PXI Chassis Object

How do I use my PXI chassis?

To enable the full functionality of your PXI system, each chassis must be properly identified. Once properly identified, each chassis is assigned a chassis number used to identify the chassis and the devices it contains.

What can I do with my PXI chassis?

You can identify your PXI chassis model, view modules within the chassis, renumber the chassis, delete the chassis (if applicable), and configure the trigger lines.


PXI Embedded Controller Object

PXI controllers provide connectivity to your PXI system, giving your modules integrated timing, synchronization, and triggering capabilities.

How do I use my PXI controller?

To enable the full functionality of your PXI system, the system controller must be identified as the correct model.

To identify a controller, right-click the controller object and select Identify As, then select your controller model from the list.

What can I do with my PXI controller?

You can identify your PXI controller model.


PXI Embedded with ExpressCard Slot Object

PXI controllers provide connectivity to your PXI system, giving your modules integrated timing, synchronization, and triggering capabilities.

This PXI controller also may provide a MXI link through the integrated ExpressCard slot using an ExpressCard MXI device. You can use this link to extend your PXI system to include additional chassis, expanding the number of modules available to the system. Chassis clocks and triggers are not shared across this link.

How do I use my PXI controller with ExpressCard MXI?

To enable the full functionality of your PXI system, the system controller must be identified as the correct model.

To identify a controller, right-click the controller object and select Identify As, then select the your controller model from the list.

What can I do with my PXI controller with ExpressCard MXI?

You can identify your PXI controller model and locate a connected chassis through a MXI link from an ExpressCard MXI in the integrated ExpressCard slot. To locate a connected chassis through an ExpressCard MXI link, double-click the embedded controller object.

Note Note Some MXI devices do not support locating connected chassis.


PXI Express Chassis Object

What can I do with my PXI Express chassis?

You can view modules within the chassis, renumber the chassis, and configure the trigger lines.


PXI Express Embedded Controller Object

PXI Express controllers provide connectivity to your PXI Express system, giving your modules integrated timing, synchronization, and triggering capabilities.


PXI Express Embedded with ExpressCard Slot Object

PXI Express controllers provide connectivity to your PXI Express system, giving your modules integrated timing, synchronization, and triggering capabilities.

This PXI Express controller also may provide a MXI link through the integrated ExpressCard slot using an ExpressCard MXI device. You can use this link to extend your PXI Express system to include an additional chassis, expanding the number of modules available to the system. Chassis clocks and triggers are not shared across this link.

What can I do with my PXI Express controller with ExpressCard MXI?

You can locate a connected chassis through a MXI link from an ExpressCard MXI in the integrated ExpressCard slot. To locate a connected chassis through an ExpressCard MXI link, double-click the embedded controller object.

Note Note Some MXI devices do not support locating connected chassis.


PXI Express Remote Controller Object

Remote controllers, when attached to an upstream MXI device, extend your PXI system to include the chassis containing your remote controller, as well as all modules connected to that chassis.

Chassis clocks and triggers are not shared across this link.

What can I do with my remote controller?

You can locate a connected chassis through a MXI link. To locate a connected chassis through a MXI link, refer to the Connection Information area of the remote controller's General pane, or double-click the remote controller object.

Some remote controller hardware provides MXI link statistics. If available, MXI link statistics are on the remote controller's General tab.

Note Note Some MXI devices do not support locating connected chassis.


PXI Remote Controller Object

Remote controllers, when attached to an upstream MXI device, extend your PXI system to include the chassis containing your remote controller, as well as all modules connected to that chassis.

Chassis clocks and triggers are not shared across this link.

How do I use my remote controller?

No configuration is necessary to begin using your remote controller.

Under some circumstances, an embedded controller may be incorrectly identified as a remote controller. If this is the case, to enable the full functionality of your PXI system, the remote controller must be reidentified as the correct model.

To identify a controller, right-click the controller object and select Identify As, then select your controller model from the list.

What can I do with my remote controller?

You can locate a connected chassis through a MXI link. To locate a connected chassis through a MXI link, refer to the Connection Information area of the remote controller's General pane, or double-click the remote controller object.

Some remote controller hardware provides MXI link statistics. If available, MXI link statistics are on the remote controller's General tab.

Note Note Some MXI devices do not support locating connected chassis.


PXI Upstream MXI Object

You can use upstream MXI devices to extend your PXI system to include an additional chassis, expanding the number of modules available to the system.

Chassis clocks and triggers are not shared across this link.

What can I do with my upstream MXI device?

You can locate a connected chassis through a MXI link. To locate a connected chassis through a MXI link, refer to the Connection Information area of the upstream MXI device's General pane, or double-click the upstream MXI object.

Note Note Some MXI devices do not support locating connected chassis.


Remote Controller General View

Remote controllers, when paired with an upstream MXI device in another chassis, allow modules in this child chassis to communicate with the parent chassis connected via an upstream MXI device. Use this mechanism to chain together multiple chassis, enabling communication with all connected modules.

The Connection Information area indicates the connected upstream MXI device's chassis and slot number.


Upstream MXI Device General View

Upstream MXI devices allow chassis expansion by linking to a remote controller in slot 1 of another chassis. This enables communication with modules in the remote chassis.

The Connection Information area indicates the chassis number of the remote controller to which this module links.