NI-VISA対応Measurement & Automation Explorerヘルプ

NI-VISA用Measurement & Automation Explorerヘルプ

2014年5月版、371395J-0112

このヘルプファイルでは、NI-VISAとNI-VXIの構成とプログラミングのためのMeasurement & Automation Explorer（MAX）の使用方法を説明します。

関連ドキュメント

このドキュメントについてのご意見は、ナショナルインスツルメンツのウェブサイトからお寄せください。

© 2005–2014 National Instruments Corporation. All rights reserved.


関連ドキュメント

以下のドキュメントには、このヘルプファイルを使用する際に役立つ情報が記載されています。

  • NI-VXI Help
  • NI-VXI API Help
  • NI-VISA Help
  • 1155-1992 Standard VMEbus Extensions for Instrumentation: VXIbus
  • GPIB-VXI/C User Manual


用語集

接頭辞

記号 | 接頭辞 | 値
p | ピコ | 10 -12
n | ナノ | 10 -9
μ | マイクロ | 10 -6
m | ミリ | 10 -3
k | キロ | 10 3
M | メガ | 10 6
G | ギガ | 10 9
T | テラ | 10 12

数字/記号

nV | ナノボルト | 10-9ボルト
μV | マイクロボルト | 10-6ボルト
μΩ | マイクロオーム | 10-6オーム
mΩ | ミリオーム | 10-3オーム
MΩ | メガオーム | 106オーム
pA | ピコアンペア | 10-12アンペア
nA | ナノアンペア | 10-9アンペア
μA | マイクロアンペア | 10-6アンペア
mA | ミリアンペア | 10-3アンペア

A

A16/A24/A32領域 VXIbusのアドレス領域。アドレス範囲は、2nのメモリ位置のセットであり、VXI/VMシステムの他のメモリ位置のセットとは、アドレス修正子として知られる6つの信号ラインによって区別されます。ただし、nは与えられた領域の固有のバイト位置を指定するのに必要なアドレスラインの番号です。nの有効番号は、16、24、および32です。

A16領域はVME 64 KBのショートアドレス範囲に相当します。VXIでは、上位16KBの領域をVXI構成領域といいます。

A24領域はVME 16 MBの標準アドレス範囲に相当します。

A32領域はVME 4 GBの拡張アドレス範囲に相当します。

D

DMA | ダイレクトメモリアクセス（DMA Direct Memory Access）とは、CPUの介入なしにデバイスと内部メモリの間でデータを転送する方法のことです。一般的に、DMAは最も速く最も効率の良いデータ転送方法です。
DRAM | DRAM(（Dynamic Random Access Memory）は、コンピュータが頻繁にリフレッシュするストレージです。

G

GPIB-VXI/Cデバッグボード | デバッグモードでGPIB-VXI code instrumentをロードします。GPIB-VXI/Cのデバッグについては、『GPIB-VXI/C User Manual』に詳細が説明してあります。通常、ナショナルインスツルメンツの技術サポートからの指示がない限り、GPIB-VXI/Cはデバッグモードにしないでください。
GPIB 汎用インタフェースバス（General Purpose Interface Bus）。これは、工業規格IEEE 488バスであり、コンピュータとテスト機器を接続するケーブルバスです。GPIBは、プログラマブル計測器（ヒューレットパッカードでは、GPIBのことをHP-IBと呼ぶ）のラインを接続して制御するために、1960年代にヒューレットパッカードによって最初に開発されました。

1975年、IEEE（電気電子技術者協会）は、ANSI/IEEE Standard 488、IEEE Standard Digital Interface for Programmable Instrumentation（IEEEプログラマブル計測器のための標準デジタルインタフェース）を発行しました。これには、インタフェースシステムの電気、機械、機能的仕様があります。このバスは現在世界中で使用されていて、以下の名前で知られています。

  • 汎用インタフェースバス（GPIB）
  • ヒューレットパッカードインタフェースバス（HP-IB）
  • IEEE 488バス

IEEE委員会によって、後に、IEEE 488.2、Codes, Formats, Protocoles, and Common Commands（コード、フォーマット、プロトコル、および一般コマンド）等の補助的な規格が追加され、IEEE 488の仕様が拡張されました。IEEE 488.2では、バス通信プロトコル、データコードおよびフォーマットの一般的セット、および一般的デバイスのコマンドの基本的なセットを定義しています。また、プログラマブル計測のための標準コマンド（SCPI:Standard Command for Programmable Instrumentation）で、標準計測器コマンドのセットも定義しています。

GPIBはテスト・計測システム用の工業規格となりました。VXIはこの業界で開発されたため、多くのVXIデバイスは、IEEE 488.2およびSCPIコマンドを使用します。

H

HP/Agilent VISA | ヒューレット・パッカード／アジレント社のVISAの仕様を参照してください。

L

LabVIEW | LabVIEWは、高度なユーザ定義の計測システムを簡単に構築するために設計されたグラフィカルプログラミングシステムです。LabVIEWには、アプリケーション開発に要する時間を大幅に削減するプログラミングメソッドに加え、VXIの高性能を利用するのに必要な柔軟性があります。LabVIEWは、VXIplug&playに完全準拠しており、VXIplug&playテクノロジーのメリットを最大限に活用することができます。
LabWindows/CVI | LabWindows/CVIは、高速開発、プロトタイプ、およびテスト計測やデータ集録アプリケーション用のオペレーションのための統合ソフトウェアシステムです。WindowsおよびSun Solarisプラットフォーム用のフル機能Cプログラミング環境を提供します。LabWindows/CVIのアプリケーションは、業界標準のプログラムコードで記述されているため、柔軟性に優れ、さらにモジュール方式、拡張可能、プラットフォーム間で移植可能という利点があります。ナショナルインスツルメンツでは、NI-VXIドライバソフトウェアをLabWindows/CVIにリンクするこれら2つのプラットフォーム用VXI/VME開発システムを提供します。これらのプラットフォームでは、組み込み式VXI/VMEコントローラまたはMXIインタフェースを搭載した外部コンピュータからVXI計測器を制御します。LabWindows/CVIは、VXIplug&playに完全準拠しており、VXIplug&playテクノロジーのメリットを最大限に活用することができます。

M

MXI/MXI-2 マルチシステム拡張インタフェースバス（MXIbus）は、デバイス間の高速通信用に設計されたマルチドロップパラレルバスアーキテクチャです。MXIbusは、PC、ワークステーション、VXIbusシャーシ、VMEbusベースのコンピュータ、スタンドアロン計測器、モジュール式計測器等、2つ以上のデバイス間の通信に使用できる汎用ゲートウェイです。

MXI-2は、ナショナルインスツルメンツのMXIbus製品ラインの第二世代製品です。MXI-2は、VXIトリガ、すべてのVXI割り込み、CLK10、SYSFAIL*、SYSRESET*、およびACFAIL*を含めることによって、標準MXIbusケーブルでの信号数を拡張することができます。

N

NI-VISA | NI-VISAは、VXI/VMEデバイスとの通信のためのネイティブAPIです。NI-VISAは、VISA I/O規格に準拠したナショナルインスツルメンツ製品です。これは、さまざまな計測器（VXI、GPIB、PXI、シリアル、TCP/IP等）に使用可能な共通インタフェースです。NI-VXIは、NI-VISAで使用するために最適化してあります。ナショナルインスツルメンツでは、新しいVXI/VMEアプリケーションをNI-VISAで開発することを推奨します。
NI-VXI API | NI-VXI APIは、開発環境のオプションで、NI-VXIのデフォルトインストレーションの一部ではありません。NI-VXI APIは、NI-VISAより先に開発されました。NI-VXIはNI-VXI APIをサポートしていますが、ナショナルインスツルメンツでは、新しいVXI/VMEアプリケーションには、NI-VISAをご使用になることをお勧めします。従来のNI-VXI APIでアプリケーションを開発しなければならない場合は、NI-VXIインストーラを実行し、カスタムインストールの画面で適切なオプションを選択してください。
NI-VXI | NI-VXIは、ナショナルインスツルメンツのVXIコントローラ同梱のソフトウェアパッケージです。NI-VXIには、Measurement & Automation Explorer（MAX）、NI-VISA、NI I/O Trace、リソースマネージャ（Resman）、VXIデバイスドライバ、およびVXIシステムを構成、制御するその他のユーティリティがあります。
NI I/O Trace | NI-VISA、NI-VXI API、およびNI-488.2に対するアプリケーションからの関数の呼び出しをトラッキングするナショナルインスツルメンツのユーティリティ。このロギングユーティリティを使用すると、アプリケーションが呼び出した関数のリストを入手して、正しく実行されなかった関数をすぐに見つけることができます。

P

peek | 特定のアドレスからの単一バイト、ワード、またはロングワードを読み取ること。ポインタの直接デリファレンスを通して、あるいはNI-VISA関数viPeekXまたはNI-VXI API関数VXIpeekを通して、アクセスすることができます。
poke | 特定のアドレスへ単一バイト、ワード、またはロングワードを書き込むこと。ポインタのデリファレンスを直接通して、あるいはNI-VISA関数viPokeXまたはNI-VXI API関数VXIpokeを通して、アクセスすることができます。

S

SYNCプロトコル 最も基本的なプロトコルで、トリガラインの最低持続時間のパルス。

アサートしない期間50 nsの前に、最低30 nsの間パルスをアサートできます。送信先からの肯定応答はありません。どのモジュールでもトリガパルスを発信することができますが、パルスが受信されたかどうかは確認できません。

V

VIC/VICtext VXI対話形式の制御プログラム（NI-VXI APIバスインタフェースソフトウェアの一部）。VXIデバイスのプログラミングや、VXIアプリケーションプログラムの開発およびデバッグに使用します。また、これは、NI-VXI APIを使用してVXIデバイスと対話する方法を理解するのにとても便利です。テキストベースのプラットフォームで使用する場合は、これをVICtextといいます。
メモ 　VICユーティリティは、NI-VXIの標準インストールではインストールされません。VICを使用する場合は、NI-VXIインストーラを実行し、「typical」でなく、「custom」インストールを選択してください。Select Featuresダイアログボックスで、NI-VXI API Developmentオプションを有効にし、画面の指示に従って続行します。再起動後、VICは使用可能となります。
VISA VISAとはマルチベンダのI/Oソフトウェア規格で、 VXIplug&play Systems Allianceによって承認されています。この規格は、計測器ドライバ、ソフトフロントパネル、およびアプリケーションソフトウェア等の、高レベルのマルチベンダシステムソフトウェアコンポーネントの開発、発送、相互接続性のための一般的な基礎を提供します。

NI-VISAは、ナショナルインスツルメンツのVISAソリューションです。

VISAIC | VISA対話形式制御（VISAIC）ユーティリティ。これは、NI-VISAインタフェースソフトウェアの一部です。NI-VISAでこのユーティリティを使用すると、デバイスと対話することができます。これは、VISAのアプリケーションプログラムを開発、デバッグするのにとても便利です。また、VISAを使用してデバイスと対話する方法を理解するのに役立ちます。
VME | Versa Module EurocardまたはIEEE 1014。
VME64プロトコル | VME64プロトコルをサポートするデバイスでは、64ビットの増分でデータを転送し、従来のVXIの処理能力を2倍の80 Mbytes/sにすることができます。
VXI | VMEbus Extensions for Instrumentation（計測のためのVMEbus機能拡張）。1987年のVXIbus Consortiumで導入されたVXIbus（IEEE 1155）規格は、GPIB計測器の最高の技術に現代のコンピュータバスアーキテクチャのVERSAbus Module Eurocard（VME）を組み合わせてあります。VXIでは、プラグインボード上のモジュール式計測器のシャーシを使用しています。MEbusのバックグラウンドにより、VXIには、性能がより高く、計測器間のタイミングおよび同期がより精巧であるといった特徴があります。また、これはGPIBラックアンドスタック型の計測器より小型です。ただし、VXIは標準通信プロトコルを特定のデバイスに対して定義するという点でVMEと異なります。このインタフェースを通して、一般的なASCIIコマンドを使用して計測器をGPIBの場合と同様に制御することができます。VXIbusの仕様は、VMEbus（IEEE 1014）の仕様が拡張されたものです。VMEbusを電気的、機械的に機能拡張したVXIbusでは、VMEと同じバックプレーンコネクタ、同じサイズのボード、VMEbusの仕様で定義されたのと同じ信号を使用します。VXIbusでは、ボードサイズを2つ追加し、モジュール幅を変更し、バックプレーンへの追加信号を定義します。
VXIplug&playソフトフロントパネル | VXIplug&play互換計測器には、プログラミング環境なしで実行できるソフトウェアがあり、ソフトフロントパネル（SFP）がそれに相当します。SFPは、計測器関数を対話形式で表示および制御するテストアプリケーションです。グラフィカルインタフェースおよびマウスポインティングデバイスを使用して、シミュレートされたノブ、ボタン、制御、表示を管理します。SFPを使用して計測器の動作を確認したり、構成やインストールを検証および修正したり、計測器と対話することができます。
VXI組み込み式コントローラ | VXIシャーシのバックプレーンに直接組み込まれたコンピュータ。この例としては、ナショナルインスツルメンツのVXIpcシリーズがあります。
VXI信号 | 信号レジスタへの書き込みで構成されるメッセージベースのデバイス間での通信。信号を送信するには、送信元のデバイスにVMEbusマスタ機能があることが必要です。
VXIトリガ | VXIトリガは、コントローラや計測器間で必要なタイミングおよび信号伝播を実現するため、VXIがVME規格に追加したバックプレーン機能です。P2コネクタを搭載した各VXIボードは、8つの10 MHzのTTLトリガラインにアクセスできます。P3コネクタの場合は、6つの100 MHz ECLトリガラインにアクセスできます。VXIbusの仕様では、ご使用のアプリケーションがデバイスの同期、テストステップの実行、またはコマンドパスのために使用できるさまざまなトリガプロトコルが定義されています。最も基本的なプロトコルは、SYNC、ASYNC、SEMI-SYNC、START/STOPおよびON/OFFです。

う

ウィンドウ | VXI/VMEbusアドレス範囲へのアクセスはすべて、VXI/VMEbusのアドレスに対応するローカルのCPUアドレス範囲にある特定のオフセットに対する読み取りと書き込みにより行われます（ハードウェアインタフェースを使用）。ウィンドウは、ローカルCPUのアドレス範囲がVXI/VMEbusにマッピングされる領域です。表示されるウィンドウのサイズと数は、ご使用のハードウェアによって異なります。

え

エクステンダ | 割り込みライン、トリガライン、または他の信号をシャーシの内外にマッピングできるVXI-MXI-2やVME-MXI-2等のデバイス。

か

外部コントローラ | MXIインタフェースボードを通してVXIシステムに接続したデスクトップコンピュータまたはワークステーション。例としては、PCI-MXI-2を取り付けた標準的なPCがあります。
監視アクセス | 定義済みのVMEbusデータ転送タイプの一種。特定のアドレス修正子コードによって示されます。

き

擬似論理アドレス | アドレスを意味する番号。VMEデバイスをVXIデバイスに統合するのに使用できます。リソースマネージャはVMEデバイスを構成しないため、デバイスは手動で追加する必要があります。256～511の範囲の番号を選択できます（255以下の番号はVXIデバイス用に確保されています）。他の適切な情報をエディタのさまざまなフィールドに入力すると、リソースマネージャを実行した場合、さまざまなデバイス依存のVMEアドレス範囲およびVME割り込みラインを正しく構成することができます。
共有メモリ | クライアントとサーバの両方にアクセス可能なメモリブロック。メモリブロックは、通信のためのメッセージバッファとして使用されます。

く

組み込み式コントローラ | PXIまたはVXIシャーシのバックプレーンに直接組み込まれたコンピュータ。ナショナルインスツルメンツのPXI-8170シリーズおよびVXIpcコントローラが組み込まれたコントローラの例です。

け

計測器ドライバ | 計測器ドライバは、計測器自体のプログラミングをせずにシステムを開発するためのツールです。計測器ドライバを使用すれば、計測器コマンドの文字列をフォーマットするためのルーチンを学ぶ必要がありません。計測器ドライバには、マルチメータ、スコープ、およびカウンタ等の特定の計測器用の上位関数があります。ドライバには、計測器用のプログラミングのコマンドおよびデータフォーマットルーチンがすべて備わっているため、計測器のプログラミングに時間を取られることなくシステムの開発に集中することができます。
権限のないアクセス | 定義済みのVMEbusデータ転送タイプの一種。特定のアドレス修正子コードによって示されます。定義済みの各VMEbusアドレス範囲には、定義済みの権限のないアクセスモードがあります。

こ

構成領域 VXIbus仕様では、自動システム構成および基本レベルの通信のためのVXI/VMEbusアドレス範囲のセクションを確保します。このセクションは、一般にA16アドレス範囲と呼ばれる上位16 KBです。これは、単一のVXIbusシャーシで64バイトの256ブロック（最大256個のVXIデバイス）に分割されます。したがって、このセクション（VXIbus構成領域）は、ベースアドレス0xC000から始まり、0xFFFFで終わります。8ビットの固有の論理アドレスが各デバイスを識別します。論理アドレスは、これらの256ブロックのうち、VXIデバイスが常駐/使用するブロックを決定します。各VXIデバイスには、そのシステムに固有の位置があります。

下記の公式を使用して、デバイスの64バイトのアドレスブロックのうちのオフセット（開始アドレス）を計算できます。

オフセット（16進）= C000 hex + （論理アドレス * 40 hex）

または、十進法で、

オフセット= 49152 + (論理アドレス * 64)

構成レジスタ | システムがモジュールデバイスタイプ、モデル、製造元、アドレス範囲、および必要なメモリを識別するために使用できる一連のレジスタ。自動システムおよびメモリ構成をサポートするために、VXIbusの仕様ではすべてのVXIbusデバイスにこのレジスタを持つことを必要としています。VMEデバイスには、構成デバイスがありません。
コマンダ/サーバント階層 VXIbus仕様にはコマンダ／サーバント通信プロトコルが定義されています。このプロトコルは、VXIデバイスの概念上の層で階層を作成するのに使用できます。結果として、ツリーのような構造が得られます。コマンダとは、階層において1つまたは複数の関連した下位レベルデバイス（サーバント）を持つメッセージベースのデバイスのことです。サーバントとは、コマンダのサブツリーにあるデバイスのことです。デバイスは、複数のレベルの階層で、コマンダ兼サーバントとなることができます。

コマンダは、そのすぐ下の階層にあるサーバントの（1つまたは複数の）通信および構成レジスタに対して、排他制御を行います。すべてのVXIモジュールには、唯一無二のコマンダがあります。コマンダは、ワードシリアルプロトコルを使用して、サーバントの通信レジスタでサーバントと通信します。サーバントは、そのコマンダからのワードシリアルコマンドやクエリに対して応答しながらコマンダと通信します。サーバントは、ハードウェアの割り込みを通して、あるいは特定のメッセージを直接そのコマンダの信号レジスタに書き込んで、コマンダに対して非同期状態のイベントの通信をすることもできます。

コマンダ | バスマスタでもあり、1つまたは複数のサーバントを制御できるメッセージベースのデバイス。コマンダは、コマンダ/サーバント階層内でそのコマンダより高いレベルにある別のコマンダに対して、サーバントになることができます。
コントローラ（システムコントローラ） コントローラとは、他のデバイスを制御できるデバイスのことです。MXIインタフェースボードを搭載したデスクトップコンピュータ、VXIシャーシの組み込みコンピュータ、VXI-MXI、およびVME-MXIはすべて、VXIシステムの構成によってはコントローラになり得ます。

VMEbusシステムコントローラは、VXIbusシャーシのスロット0への取り付けまたはVMEbusシャーシのスロット1への取り付けのために構成されたデバイスです。このデバイスは、クロックの提供およびバックプレーンを通してデータの転送処理などを含むVMEbusシステムコントローラ機能を実行するという点でVMEbusシステムでは特有なデバイスです。

MXIbusシステムコントローラは、アービタ、デイジーチェーンドライバ、MXIbusサイクルタイムアウト処理の機能を実行するモジュールです。このデバイスは、MXIbusのデイジーチェーン接続では常に最初のデバイスです。

さ

サーバント | コマンダ/サーバント階層でコマンダによって制御されるデバイス。サーバント自体が階層の下位にあるサーバントデバイスに対するコマンダとなる場合もあります。

し

システムレジストリ | システムレジストリは、オペレーティングシステムと多くのプログラムの両方が永続的な情報を保管するのに使用します。詳細については、オペレーティングシステムのドキュメントを参照してください。

す

ステータス/ID | IACKサイクルの間に返される値。VMEでは通常、8ビットの値となります。これは、プロセッサがソースを判断するのに使用するステータス/データの値またはベクトル/IDの値です。VXIでは、データとして使用される16ビットの値となります。下位8ビットは、割り込みデバイスのVXI論理アドレスとなり、上位8ビットは、割り込みの理由を指定します。
スロット0 VXIシャーシの最初のスロット。このスロットに取り付けられるように構成されたデバイスは、バックプレーンでデータ転送のための処理とクロック提供を含むVMEbusシステムコントローラ機能を実行するという点で、VXIシステムでは特有です。
注意 スロット0用に構成されたデバイスを0以外のスロットに取り付けると、デバイス、バックプレーン、または両方を破損するおそれがあります。

そ

ソフトフロントパネル(SFP) | VXIplug&playソフトフロントパネルを参照。

つ

通信レジスタ | メッセージベースのデバイスにおいて、デバイスのコマンダにアクセス可能でワードシリアルプロトコルの通信を行うのに使用される一連のレジスタ。VMEデバイスおよびVXIレジスタベースのデバイスには、通信レジスタがありません。

て

デバイスクラス VXIbusデバイスは、サポートするプロトコルにより以下の4つのクラスに分類されます。

メッセージベースのデバイスは、VXIbus構成および通信プロトコルの両方をサポートします。これらのデバイスには、コマンダやコマンドベースのサーバント機能があります。

レジスタベースのデバイスには、VXIbus構成レジスタがありますが、通信レジスタはありません。通常、これらのデバイスには、ローカル知能はほとんどないか、あるいはまったくなく、メッセージベースのデバイスによって制御可能です。

メモリデバイスにはVXIbus構成レジスタがあり、VMEbusのA24またはA32アドレス範囲にあるRAMまたはROMのブロックを恒久または一時データ保存に使用します。

拡張デバイスには、VXIbus構成レジスタとサブクラスレジスタがあります。これらは、標準および製造元によるサブクラスの両方を定義します。さらに、サブクラスは、シャーシエクステンダ等の拡張デバイスの機能も定義します。ナショナルインスツルメンツのVXI-MXIシャーシエクステンダは、拡張デバイスの一例です。

VXIbus構成レジスタを実装していないVMEデバイスにはVXIデバイスクラスがありません。

と

トリガ | モジュール間の通信で使用するTTLまたはECLライン。

の

ノンスロット0 VXIシャーシのスロットで、最初のスロット以外のスロット。
注意 スロット0以外のデバイスとして構成されたデバイスをスロット0に取り付けると、デバイスまたはVXIbusバックプレーン、あるいはその両方を損傷するおそれがあります。

は

バイト | コンピュータが一単位として操作する隣接した二進数字をグループ化したもの。1バイトは、8ビットで構成されています。
バイト順序 | バイトのワード内での並び方、またはワードのロングワード内での並び方。モトローラの順位付けでは、まず最上位のバイト（MSB）またはワードを、次に最下位のバイト（LSB）またはワードを格納します。インテルの順位付けでは、まずLSBまたはワードを、次にMSBまたはワードを格納します。
バスマスタ | コンピュータバス上でデバイスを読み取り、書き込む機能を持つプラグインボードまたはコントローラの一種。

ふ

フェアリクエスタ | MXIbusの解放後、バスリクエスト信号の無効を検出するまでは、MXIbusのための調整をしないMXIbusマスタ。これにより、要求側のすべてのデバイスが確実にバスを使用することができます。

へ

ベースアドレス | データ位置の絶対アドレスを決定するため、相対アドレス（またはオフセット）に連結される指定アドレス。どのVXIアドレスウィンドウにも、割り当てられたVXIアドレス範囲に関連したベースアドレスがあります。
ポインタ | アドレスまたは他のストレージ位置の表示を含むデータストラクチャ。

め

メッセージベースの通信 | メッセージベースのデバイスは、あらかじめ定義されたVXIbusレジスタおよび通信プロトコルを実装します。これらのデバイスは、通信レジスタを通して互いに通信する際、ワードシリアルプロトコルを使用します。このレジスタはオプションのレジスタで、レジスタベースのデバイスでは使用しません。メッセージベースのデバイスは、GPIBのようにASCII文字を使用して高レベルで通信します。メッセージベースのデバイスへ送信するASCII文字は、そのデバイスの特定の言語でなければなりません。ただし、モジュール指定のレジスタ（バイナリ読み取りおよび書き込み）を考慮する必要はありません。多くのVXIメッセージベースの計測器は、SCPI互換です。

ゆ

ユーザウィンドウ | 下位関数の呼び出しを通して使用するためのVXIpcシリーズ組み込み式コントローラまたは外部コントローラにより確保されたPCIアドレスの領域。MapVXIAddress()およびviMapAddress()関数は、このアドレス範囲を使用して、VXIpeek()/VXIpoke()関数およびviPeekXX()/viPokeXX()関数が使用する範囲を割り当てます。

り

リソースマネージャ(Resman) | 論理アドレス0に位置するメッセージベースのコマンダ。これは、アドレスマッピング構成、コマンダとサーバントの階層マッピング、自己テストおよび診断管理等の構成管理サービスを提供します。システムのスタートアップ時に、VXIシステムコントローラはリソースマネージャを実行してシステム全体を自動的に構成します。この自動スタートアップ構成により、システムの統合が容易になります。リソースマネージャの実行後、システムは準備が整います。システムリソースを再構成すれば常に、リソースマネージャを対話形式で実行することもできます。

れ

レジスタベースの通信 | レジスタベースのデバイスは、VXIbus構成レジスタをサポートするサーバントのみのデバイスです。これらのデバイスには、メッセージベースの通信に必要なオプションの通信レジスタが装備されていません。レジスタベースのデバイスは通常、デバイス依存レジスタの読み取りおよび書き込みを通してメッセージベースのデバイスにより制御されます。レジスタベースのデバイスは、文字通りハードウェアを直接操作する速度レベルで通信するため、通信速度が速いというメリットがあります。コマンド文字列の構文解析によるオーバヘッドはありません。デメリットは、各デバイスが異なり、レジスタの操作のカスタマイズが必要なことです。計測器のインタフェースには、計測器間での移植性はありません。

ろ

ロングワード | 32ビット整数のデータタイプ。標準ワードシリアルプロトコルにある16ビット転送ではなく、ロングワードシリアルプロトコルでは、コマンダおよびサーバントが32ビットデータ転送で通信します。
論理アドレス | システムにある各VXIbusデバイスの構成レジスタの位置を特定し、コマンダおよびサーバントの関係を示す8ビットの番号。デバイスのA16レジスタアドレスは、C000h + 論理アドレス * 40hです。
論理アドレス0 VXIbus仕様の定義では、外部コントローラ等のローカルデバイスが論理アドレス0に構成された場合、起動時に以下のVXIリソースマネージャオペレーションが行われます。
  • システムのVXIbusデバイスをすべて識別
  • システムの自己テストおよび診断シーケンスを管理
  • システムのA24およびA32アドレスマップを構成
  • システムのコマンダ／サーバント階層を構成
  • VMEbus IRQラインの割り当て
  • 通常のシステムオペレーションの開始

また、スタートアップリソースマネージャには、以下の機能があります。これは、VXIbus仕様の要求以上のものです。

  • 標準VXIbusシャーシエクステンダ（VXI-MXI-2等）を使用した複数のシャーシサポート
  • シャーシごとに動的に構成されたデバイスのサポート
  • MAXを使用した各シャーシのVXI以外（VMEおよび疑似VXI）のデバイスの統合

わ

ワード | プロセッサまたはメモリが一回に操作するビットの標準的なビット数。マイクロプロセッサには、通常、8、16、32ビットワードが使用されます。標準ワードシリアルプロトコルでは、ワードは16ビットと定義されています。
ワードシリアルプロトコル | VXIbusシステムにあるメッセージベースのデバイスでサポートされている、最も簡単な必須通信プロトコル。シンプルなポーリングハンドシェイクメソッドで、A16通信レジスタを使用して、16ビットのデータ転送を行います。メッセージベースのデバイスはすべて、このプロトコルをサポートする必要があります。ワードシリアルプロトコルは、デバイスからデータメッセージをシリアル転送します。転送速度は、一度にバイト（またはワード）で、そのデバイスの通信レジスタを通じて行われます。
割り込み | デバイスが他のデバイスにイベントの発生を通知する方法。この非同期のイベントは、通常の動作を中断し、一時的に割り込み処理関数の動作に切り替えます。
割り込みハンドラ | インタラプタが生成する割り込みリクエストを検出し、適切な動作を行うモジュール。


操作方法

一般的な項目

構成

プログラミングに関する一般的な問題


一般的な項目

VXIの問題をデバッグする

デバイスに計測器ドライバがあるかどうか確認する


VXIの問題をデバッグする

大きいVXIシステムは大変複雑な可能性があります。したがって、VXIに関する問題のデバッグの第一段階は、その問題の発生個所をできるだけ小さな要素に絞り込むことです。たとえば、マルチシャーシシステムの場合、単一のシャーシに分割して問題を再現します。問題のあるシステムを1つか2つの計測器に特定できるまで、計測器をシステムから切り離していかなければならない場合もあります。

VISAICおよびVICは、問題を切り分ける上で非常に役立つツールです。このユーティリティを使ってVXIの問題を再現すると、ご使用のアプリケーションを問題の発生元として除外することができます。こうした対話式ユーティリティを使用して、ドライバの最も基本的なインタフェースで計測器との基本的な通信を確認することができます。

メモ 　VICユーティリティは、NI-VXIの標準インストールではインストールされません。VICを使用する場合は、NI-VXIインストーラを実行し、「typical」でなく、「custom」インストールを選択してください。Select Featuresダイアログボックスで、NI-VXI API Developmentオプションを有効にし、画面の指示に従って続行します。再起動後、VICは使用可能となります。

VISAICまたはVICで問題を再現できない場合、NI I/O Traceを使用してください。NI I/O Traceはパワフルなユーティリティで、NI-VISA、NI-VXI、またはNI-488.2のすべての呼び出しをトラッキングできます。エラーや警告を返す呼び出しをハイライトして、ドライバに送信されたパラメータをすべて表示するため、パラメータの有効性を確認できます。NI I/O Traceを使用すれば、大きいアプリケーションでもすばやくバグを見つけることができます。

VXIの問題をデバッグするも参照してください。


デバイスに計測器ドライバがあるかどうかを確認する

デバイスに計測器ドライバがあるかどうか確認する

計測器ドライバが既にインストールされている場合には、ユーティリティのVISAICやMAXがそれらを検出することがあります。VISAICやMAXは、システム上の計測器ドライバを探して、ソフトフロントパネルを起動します。

計測器ドライバの多くは、ナショナルインスツルメンツのウェブサイトから入手できます。

ご使用のデバイス用の計測器ドライバがナショナルインスツルメンツにない場合、デバイスの製造元にご連絡ください。VXIplug&playシステムアライアンスメンバーの製造元は、自社製品用の計測器ドライバを多数作成しています。


構成

VISAデバイスにエイリアスを割り当てる

VISAデバイスを無効にする

システムが正常に動作しているかどうか確認する

VXIplug&playソフトウェアのインストール

HP/Agilent GPIB-VXIボードと動作するようにNI-VISAを構成する

ナショナルインスツルメンツのGPIB-VXI/Cと動作するようにNI-VISAを構成する

複数のGPIB-VXI/Cボードを表示できるようにNI-VISAを構成する

VISAIC/VICを使用する

インストールしたソフトウェアのバージョンを判断する


VISAデバイスにエイリアスを割り当てる

デバイスを右クリックしてポップアップメニューから名前を変更を選択すると、エイリアスをサポートするデバイスを指定できます。


VISAデバイスを無効にする

表示から一般タブにアクセスし、デバイスの有効化ボックスのチェックマークを外すと、VISAデバイスを無効にすることができます。


マイシステムが正常に動作しているかどうか確認する

システムが正常に動作しているかどうか確認する

デバイスがMAXのシステム表示に表示されないということは、NI-VISAによって検出されなかったことを意味します。以下の種類のデバイスは、デバイスの追加ウィザードを使用して手動でシステムに追加する必要があることに注意してください。

  • すべてのTCP/IPリソース
  • イーサネットベースのコンバータ（例: GPIB-ENETおよびSerial ENET）
  • すべてのVMEリソース
  • プライマリアドレス1、セカンダリアドレス0以外の場所のGPIB-VXIコントローラ

VXIシステムでは、自動的に実行するように構成していない場合、リソースマネージャを実行する必要がある場合があります。

NI-VISAまたはVXIリソースマネージャがエラーを検出すると、それに応じてデバイスのアイコンにマークが表示されます。エラーの原因を調べるには、これらのマークが付けられたデバイスにアクセスし、一般タブからトラブルシューティングを表示します。

MAXがデバイスをすべて検出したら、デバイスにアクセスできるかどうかをテストできます。VISAテストパネルを開くコマンドはVISA対話式制御でセッションを作成し、デバイスとの基本通信を確立できるようにします。デバイスとの通信をテストするには、さまざまな方法があります。コンタクトを確立するには、VXIまたはPXIデバイスのレジスタを読み取ることができます。GPIB、VXI、シリアルデバイスの多くは、viWrite()を使用してデバイスに送信することができる*IDN?文字列に応答します。この488.2のコマンドは、viRead()を通して返される、デバイスの識別文字列をクエリします。

また、GPIBデバイスを検出できない理由およびVXIデバイスを検出できない理由を参照してください。


VXIplugnplayソフトウェアをインストールする

VXIplug&playソフトウェアをインストールする

VXIplug&play計測器ドライバは、Windowsで標準のインストーラを使用します。

ファイルマネージャまたはWindowsエクスプローラを使用して計測器ドライバ用のsetup.exeインストールプログラムを探し、それをダブルクリックします。これにより、VXIplug&playインストールプログラムが実行され、ドライバのファイルは適切な場所にインストールされます。

通常、VXIplug&play計測器ドライバは、Cのソースコード、Windowsヘルプファイル、Win32 DLL、LabWindows/CVI関数パネル、技術データベース、および ソフトフロントパネルと呼ばれるスタンドアロン実行アプリケーションをインストールします。

ソースコード、ヘルプファイル、ソフトフロントパネルは、<ドライブ>¥VXIPNP¥<オペレーティングシステム>¥<計測器名>¥パス (C:¥VXIPNP¥WinNT¥HPE-1431¥など)にインストールされます。

DLLは<ドライブ>¥VXIPNP¥<オペレーティングシステム>¥bin¥にインストールされます。

ソフトフロントパネルを使用して、迅速にご使用の計測器を利用することができます。

LabWindows/CVI関数パネルファイルは、関数パネルツリーをLabWindows/CVIに作成します。この便利なストラクチャには、内蔵ヘルプのほか、DLLにある関数の論理ツリーがあります。

DLLには、最終的なアプリケーションに組み込む必要のある関数が多数あります。

技術データベースファイルは、計測器の仕様を記載したハードウェアのデータベースです。このデータベースファイルには、操作仕様および機能が記載されていることもあります。

また、計測器ドライバには、リソースファイルやBASICソースコードなど、ユーザが計測器をプログラムするときに役立つファイルが添付されていることもあります。

さらに、テキストベースの計測器ドライバをLabVIEWに簡単にポートすることができます。LabVIEWのファイルメニューのVXIplug&playドライバの更新オプションを使用してください。これにより、VXIPNPディレクトリにあるインストールされたVXIplug&play計測器ドライバが確認され、LabWindows/CVI関数パネルにリストされている関数すべてを含むLabVIEWライブラリに変換されます。関数パネルはLabVIEWフロントパネルに変換され、各VIにはDLLを呼び出すCall Library関数が含まれます。変換されたVIは<LabVIEWディレクトリ>\Instr.libディレクトリに置かれます。これらのVIは関数パレットから計測器ドライバのサブパレットに表示され、すぐに利用が可能です。ファイルメニューにあるCVI FPファイルを変換は、ユーザがDLLおよびFPファイルを明示的に検索しなければならない点を除き、同じ操作を行うことにご注意ください。


HP/Agilent GPIB-VXIボードと動作するようにNI-VISAを構成する

HP1406等、ナショナルインスツルメンツ製以外のGPIB-VXIボードと動作するようにNI-VISAを構成するには、MAXでこのデバイスをご使用のシステムに手動で追加してください。この操作を行うには、ツリー構図のデバイスとインタフェースを右クリックし、新規作成...を選択します。ウィザードでは、GPIBアドレス（プライマリおよびセカンダリ）、VXI論理アドレス、GPIBコントローラ番号（GPIB-VXI/Cを接続するGPIBプラグインボード）、およびGPIB-VXI番号の入力手順に従ってください。GPIB-VXIボード番号には、そのシステムで固有の番号を使用してください。

また、システムにVISAに対して適切なGPIB-VXIモジュールが取り付けられていることを確認してください。詳細については、GPIB-VXIコントローラの製造元までお問い合わせください。


ナショナルインスツルメンツのGPIB-VXI/Cと動作するようにNI-VISAを構成する

ナショナルインスツルメンツのGPIB-VXI/Cのデフォルト構成は、プライマリアドレス1、セカンダリアドレス0です。NI-VISAはこの位置でこれを自動的に検出します。GPIB-VXI/Cを別のGPIBアドレスで使用するには、MAXでこのデバイスをご使用のシステムに手動で追加する必要があります。この操作を行うには、ツリー構図のデバイスとインタフェースを右クリックして新規作成...を選択します。ウィザードでは、GPIBアドレス（プライマリおよびセカンダリ）、VXI論理アドレス、GPIBコントローラ番号（GPIB-VXI/Cを接続するGPIBプラグインボード）、およびGPIB-VXI番号の入力手順に従ってください。GPIB-VXIボード番号には、そのシステムで固有の番号を使用してください。

複数のGPIB-VXIコントローラがシステムにある場合、構成する必要があるのは、デフォルトでGPIBアドレスがプライマリアドレス1、セカンダリアドレス0ではないコントローラのみです。


複数のGPIB-VXI/Cボードを表示できるようにNI-VISAを構成する

ナショナルインスツルメンツのGPIB-VXI/Cのデフォルト構成は、プライマリアドレス1、セカンダリアドレス0です。NI-VISAはこの位置でこれを自動的に検出します。GPIB-VXI/Cを別のGPIBアドレスで使用するには、MAXでこのデバイスをご使用のシステムに手動で追加する必要があります。この操作を行うには、ツリー構図のデバイスとインタフェースを右クリックして新規作成...を選択します。ウィザードでは、GPIBアドレス（プライマリおよびセカンダリ）、VXI論理アドレス、GPIBコントローラ番号（GPIB-VXI/Cを接続するGPIBプラグインボード）、およびGPIB-VXI番号の入力手順に従ってください。GPIB-VXIボード番号には、そのシステムで固有の番号を使用してください。

複数のGPIB-VXIコントローラがシステムにある場合、構成する必要があるのは、デフォルトでGPIBアドレスがプライマリアドレス1、セカンダリアドレス0ではないコントローラのみです。


VISAIC/VICを使用する

VISAICは、スタート→プログラム→National Instruments→VISAメニューから起動できます。VICは、スタート→プログラム→National Instruments→VXI→NI-VXI APIメニューから起動できます。

メモ 　VICユーティリティは、NI-VXIの標準インストールではインストールされません。VICを使用する場合は、NI-VXIインストーラを実行し、「typical」ではなく「custom」インストールを選択してください。Select Featuresダイアログボックスで、NI-VXI API Developmentオプションを有効にし、画面の指示に従って続行します。再起動後、VICは使用可能となります。

2つのプログラムを使用して、ご使用のデバイスと対話形式で通信することができます。VISAICを使用して、VXI、GPIB、PXI、TCP/IP、またはシリアルデバイスへのセッションを開くことができます。デバイスへのセッションを開くと、メッセージの送受信やデバイスの属性の表示が可能となります。また、VXIデバイスの場合は、デバイスのメモリおよびレジスタへの直接アクセスが可能となります。

VICでは、NI-VXI API関数を使用してVXIにアクセスします。WSwrt関数やWSrd関数を使用してワードシリアルメッセージを送受信したり、VXIinRegおよび VXIoutRegを使用してデバイスのレジスタにアクセスできます。また、VXIinやVXIoutを使用してVXIメモリ領域に直接アクセスすることができます。

これらのプログラムは両方とも、デバイスとの初期の通信を確立するだけでなく、NI-VISAおよびNI-VXI APIライブラリが正しくインストールしてあるかどうか、および正しく動いているかどうかを確認するのに役立ちます。このようなユーティリティでデバイスにアクセスできない場合は、ご使用のアプリケーションからもアクセスできない可能性が高いと考えられます。VISAICまたはVICでデバイスにアクセスする方法を決めたら、プログラムでこれらの同じ関数を使用することができます。


インストールしたソフトウェアのバージョンを判断する

MAXのヘルプメニューから、システム情報を選択してください。システムタブをクリックすると、現在インストールしてあるNI-VISAのコンポーネント、NI-VXIのコンポーネント、およびT&Mユーティリティを含むナショナルインスツルメンツコンポーネントのバージョン情報が表示されます。

また、MAXでマイシステムの下にあるソフトウェアカテゴリを拡張して、コンポーネントを選択してMAXの右ペーンでバージョン情報を表示することもできます。

VISAICからHelpメニューで、About...を選択してください。使用しているNI-VISAのバージョン情報、適合するVISA仕様のバージョン情報が表示されます。

また、32ビットのドライバコンポーネントにはすべて、バージョンのリソースがあります。Windowsエクスプローラでは、コンポーネントをどれか右クリックすると、プロパティオプションを選択するこができます。これにより、バージョンタブのあるプロパティシートが表示されます。このタブにはソフトウェアおよび特定のコンポーネントのバージョン情報の記載があります。

NI-VXI APIユーティリティプログラムVICを実行して、プロンプトでverとタイプすることもできます。ユーティリティは、VICおよびNI-VXIのバージョン情報、このNI-VXIドライバがサポートする最新のボードのバージョン情報を表示します。


プログラミングに関する一般的な問題

NI-VISAまたはNI-VXI APIでVXI割り込み（信号、トリガ等）を処理する

NI-VISAまたはNI-VXI APIでレジスタベースデバイスと通信する

NI-VISAまたはNI-VXI APIでメッセージベースデバイスと通信する

GPIB-VXI/CプログラムをNI-488.2からNI-VISAに変換する

VISAでGPIB-VXI/Cをプログラミングする

NI-VISAまたはNI-VXI APIで大きいデータブロックを移動する

VME64を使用してデータを転送する

VXIのプログラムをデバッグする

C言語でVXIのプログラムを作成する

LabVIEW開発環境でVXIプログラムを作成する

Visual BasicでVXIプログラムを作成する


NI-VISAまたはNI-VXI APIでVXI割り込み（信号、トリガ等）を処理する

NI-VISA

NI-VISAには、キューとコールバックの2つのメカニズムがあり、柔軟なイベントの処理が可能です。イベント処理の最も一般的な方法は、イベントキューを使用することです。viOpen()でVISAセッションを開いた後、viEnableEvent()を呼び出してVI_QUEUEをメカニズムとして指定すると、キューを有効にすることができます。後に、viWaitOnEvent()を呼び出して待機し、そのセッションに関連付けられたデバイスからイベントを受け取ります。コールバックにする場合は、まず、viInstallHandler()でコールバックハンドラを指定し、VI_HNDLRをメカニズムとしてviEnableEvent()を呼び出します。コールバックハンドラは、指定されたイベントのタイプを受け取ると常に呼び出されます。

VXIインタフェースで使用可能なイベントの種類を下記に示します。

  • VI_EVENT_VXI_SIGP―VXIデバイスからの16ビット割り込みまたは信号
  • VI_EVENT_VXI_VME_INTR―VXIまたはVMEデバイスからの8ビット、16ビット、32ビットの割り込み
  • VI_EVENT_TRIG―VXIデバイスからのトリガ検出

たいていのVXIデバイスは16ビット割り込みを生成するため、VI_EVENT_VXI_SIGPまたはVI_EVENT_VXI_VME_INTRのどちらかを使用することができます。—これらは機能的に同等です。VXIデバイスはトリガを生成する場合、まず、viEnableEvent()を呼び出す前に、VI_ATTR_TRIG_IDに、検出するTTLまたはECLトリガラインを指定しなければなりません。

NI-VXI API

メモ 　ナショナルインスツルメンツでは、アプリケーションの開発に、NI-VXI APIではなくNI-VISAをご使用になることをお勧めします。

NI-VXI APIの非同期信号の処理で最も一般的な方法は、コールバック関数を使用することです。こうした関数は、非同期信号が受信されると常に呼び出されます。InitVXIlibrary()でライブラリを初期化後、以下の機能のうちの1つを使用してコールバック機能を設定することができます。

  • SetVXIintHandler()―VXIの割り込みを処理
  • SetSignalHandler()―VXI信号を処理
  • SetTrigHandler()―VXIトリガを処理

下記の関数を使用して、検出しようとしている信号を有効にしてください。

  • EnableVXIint()―VXI割り込みラインを有効にする
  • EnableSignalInt()―VXI信号を有効にする
  • EnableTrigSense()―トリガを有効にする

VXI割り込みおよび信号では、いくつかのルーチンを実行することが必要です。詳細は、RouteSignal()およびRouteVXIint()関数を参照してください。NIVXIディレクトリの割り込みの例を参照することもお勧めします。

VXIトリガをご使用の際は、National Instruments Technical Note 40の『Triggering with NI-VXI』を参照してください。


NI-VISAまたはNI-VXI APIでレジスタベースデバイスと通信する

レジスタベースのデバイスは、4つの基本的なVXIbus構成レジスタを含む必要があります。ただし、こうしたデバイスの大半は、計測器専用の追加レジスタを含みます。レジスタベースのデバイスを制御するための標準的な通信プロトコルはありません。

各デバイスの特定の関数を制御するレジスタのアクセスパターンは各製造元により指定されます。コントローラは、VMEbusデバイスと通信を行う方法と同様に、レジスタによる読み取りと書き込みによってレジスタベースのデバイスと通信します。

NI-VISAまたはNI-VXI APIでVXI/VMEアドレス範囲へ直接アクセスする方法を示すサンプルがあります。（ナショナルインスツルメンツでは、アプリケーションの開発にはNI-VXI APIよりNI-VISAをご使用になることをお勧めします。）VISAレジスタレベル通信サンプルのHighReg.cおよびLowReg.cは、vxipnp¥win32¥Nivisa¥examplesディレクトリにあります。NI-VXI APIのサンプルはVXIlow.c、VXIhigh.cといいます。これらのファイルはexampleフォルダのNIVXIディレクトリにあります。VXIlow.cは、MapVXIAddress()およびVXIpeek()/VXIpoke()の使用方法を示します。VXIhigh.cは、VXIinやVXIoutなどの、高レベルのコールを使用します。


NI-VISAまたはNI-VXI APIでメッセージベースデバイスと通信する

メッセージベースのデバイスには、VXIbus構成レジスタの他にレジスタセットがもうひとつあります。VXIbus通信レジスタと呼ばれるこれらのレジスタは、64バイトのデバイス構成領域内にあります。ワードシリアルプロトコル（メッセージベースのデバイス用の定義済み通信プロトコルで、IEEE 488プロトコルと似ています）は、これらのVXIbus通信レジスタをベースとしています。メッセージベースのデバイスとの通信には、通信用ワードシリアルプロトコルを使用する場合、製造元に関係なく同じ手順に従ってください。

VXIのメッセージベースのデバイスとの通信は、NI-VISAのviRead()およびviWrite()関数を使用して行うことができます。通信するメッセージベースのデバイスへのセッションを開くと、viWrite()でメッセージの文字列の書き込みや、viRead()でデバイスからのメッセージの読み取りを行うことができます。VISAサンプルのディレクトリには、RdWrt.cと呼ばれるメッセージベースの通信方法を示すサンプルがあります。

また、NI-VXI APIワードシリアル関数を使用することもできます。（ナショナルインスツルメンツでは、アプリケーションの開発にはNI-VXI APIよりNI-VISAをご使用になることをお勧めします。）Wswrt()は、メッセージの文字列を特定の論理アドレスのデバイスに送信するときに使用する関数です。Wsrd()は、デバイスからメッセージを受け取るときに使用する関数です。NI-VXI APIでのメッセージベースの通信方法を示すサンプルは、NI-VXIディレクトリのexamplesフォルダにあります。メモ帳でVXIws.cという名前のファイルを開きます。


GPIB-VXI/CプログラムをNI-488.2からNI-VISAに変換する

GPIB-VXIを介したメッセージベースVXIデバイスの制御において、NI-488を使用したプログラムとNI-VISAを使用したプログラムの最大の相違点は、最初と最後に行われた呼び出しの違いです。レジスタベースのデバイスでは、その違いがより顕著になります。ここでは、両タイプのデバイスに共通の基本的な変更点について検討します。次に、レジスタベースのプログラミングに必要な変更点について検討します。

メッセージベースのプログラミングでは、通常NI-488のプログラムは特定のデバイスに対するハンドルを取得するために、VXIデバイスのGPIBプライマリアドレスおよびセカンダリアドレスをパラメータとしたibdev()関数を呼び出します。NI-VISAでは、プログラムはVXIデバイスの論理アドレス（デバイスがVXIであるため、より自然なアドレス）をパラメータとしたviOpen()を呼び出し、それに対するハンドルを取得します。データブロックの読み取りや書き込みを行う呼び出しだけでなく、他のIEEE 488通信（ステータスバイトの読み取りやバッファのクリアなど）に対応する呼び出しが、NI-488とNI-VISAのそれぞれに存在します。ここで留意すべきことは、サービスリクエストを待機する際に、まずviEnableEvent()を使用して、VISAのアプリケーションをそのイベントに対して有効化しなければならない点です。アプリケーションの最後に、デバイスのハンドルを閉じるために、ibonlではなくviClose()を使用してください。

レジスタベースのプログラミングでは、直接的な関連関数は存在しません。GPIB-VXIを使用したレジスタのアクセスは、コントローラ自体へリクエストを送信するため（ローカルコマンドセットを使用）、NI-488のプログラムではGPIB-VXIコントローラのGPIBプライマリアドレスおよびセカンダリアドレスをパラメータとしたibdev()を使用します。NI-VISAでは、VXIデバイスの論理アドレスをパラメータとしてviOpen()（これはメッセージベースおよびレジスタベースデバイスのどちらの場合も同じで、より自然で直感的なAPIです）を呼び出します。コントローラへ送信する必要のあるメッセージは、VISAが処理します。デバイスのプログラミングについては、以下のNI-488メッセージおよびNI-VISAオペレーションはほぼ同等です。

NI-488 | NI-VISA
"Laddrs?"または"DLAD?" | viFindRsrc()
"RMentry?"または "DINF?" | viGetAttribute()
"Cmdr?" | VI_ATTR_CMDR_LAを使用したviGetAttribute()
"LaSaddr?" | VI_ATTR_GPIB_SECONDARY_ADDRを使用したviGetAttribute()
"Primary?" | VI_ATTR_GPIB_PRIMARY_ADDRを使用したviGetAttribute()
"WREG"または"A16" | VI_A16_SPACEを使用したviOut16()
"RREG?"または"A16?" | VI_A16_SPACEを使用したviIn16()
"A24" | VI_A24_SPACEを使用したviOut16()
"A24?" | VI_A24_SPACEを使用したviIn16()
"SrcTrig" | viAssertTrigger()

INSTRレジスタアクセス操作のviOut16()とviIn16()では、指定されたアドレス範囲のデバイス相対オフセットが渡されることに注目してください。これは絶対アドレスを受け付けるGPIB-VXIのローカルコマンドセットとは異なります。ご使用のアプリケーションが絶対アドレス指定を使用している場合、また、デバイス相対オフセットに変換したくない場合は、絶対アドレスを受け付けるMEMACCリソースの使用を検討してください。viOut8()およびviIn8()オペレーションを使用して、8ビットアクセス（ローカルコマンドセットではサポートされない機能）を行うことができます。VISAはA32領域への32ビットオペレーションおよびアクセスも定義しますが、これらのオペレーションはGPIB-VXIによって実装されないためエラーを返します。

code instrumentのDMAmoveを使用する代わりに、viMoveInxx()およびviMoveOutxx()オペレーションを使用できるようになりました。これらのオペレーションはGPIB-VXIのDMA機能を利用しますが、コマンドおよびデータブロックの送信、そしてオペレーションの完了を待機するためのポールに必要なのは1回のコールのみで、複数ののコールを呼び出す必要はありません。データブロックを移動するためにVISAを使用すれば、NI-VISAは別のcode instrumentを自動的にダウンロードしてこれらのオペレーションやその他のオペレーションを処理するので、code instrumentのDMAmoveをロードする必要がなくなります。

つまり、NI-VISAを使用してGPIB-VXIで制御するVXIデバイスのプログラミングを行う操作は、外部コントローラまたはVXIpcシリーズなどのネイティブのVXIコントローラで制御する場合の操作と同じことです。レジスタベースのプログラミングの場合、NI-488からNI-VISAにコードを移植する操作は容易でありませんが、より単純なAPIおよびネイティブのVXIコントローラとの互換性のメリットを考慮すると変更の価値があります。


NI-VXI APIプログラムをNI-VISAに変換する

VXIデバイスを制御する多くのアプリケーションの場合、NI-VXI APIを使用したプログラムとNI-VISAを使用したプログラムの最大の相違点は、最初と最後に行われた呼び出しの違いです。2つのAPIの最大の相違点は、VXIトリガ、割り込み、信号等のイベントを送信および処理するプロブラムに影響を及ぼします。このトピックでは、まずNI-VXI APIプログラムのすべてに共通の基本的な変更について説明します。次に、レジスタベースのプログラムとイベント処理プログラムの詳細について説明します。

NI-VXI APIプログラムをNI-VISAに変換する際に役立つリソースの１つに、NI-VXIヘルプがあります。ヘルプには、VXIオペレーションの各グループについてのセクションもあり、機能別に記載されています。（たとえば、上位レジスタベースのプログラミングについての説明があるセクションなど）各概要の初めには、NI-VXI APIとNI-VISAのそのグループのオペレーションと関連した関数をリストした表があります。この表を使用して、NI-VXI APIの関数とNI-VISAの対応する関数を参照することができます。

アプリケーションを開始する

通常、NI-VXI APIプログラムはInitVXIlibrary()を呼び出してプログラムを開始します。次に、FindDevLA()を呼び出して、特定のデバイスの論理アドレスを取得して通信を開始します。NI-VISAでは、プログラムはviOpenDefaultRM()を呼び出してNI-VISAを初期化し、viFindRsrc()を呼び出してデバイスを検出し、次にviOpen()を呼び出して、それに対するハンドルを取得します。

VXI I/Oを行う

メッセージベースのVXIデバイスの場合、他のメッセージベースの通信と同様に、データブロックの読み取りおよび書き込み用の呼び出しにはNI-VXIとNI-VISA間でそれぞれ対応した関数があります（WSwrt()はviWrite()、WSrd()はviRead()など）。ワードシリアルサーバントの機能は、NI-VISAのSERVANTリソースを使用します。

同様に、NI-VXI APIの対応関数によく似たNI-VISA関数を使用して、レジスタベースのI/Oが行われます。VXIin()の代わりにviInX()、VXImove()の代わりにviMoveX()が使用されます。通常、NI-VISAの属性により、NI-VXI APIからのアクセスパラメータが制御されます。指定されたデバイスに対するVISAセッションは、オフセットと境界の自動チェックを提供します。絶対アドレスが必要な場合、VISA MEMACCリソースのセッションを使用してください。MapVXIAddress()やVXIpeek()などの下位レジスタベースI/OオペレーションはVISAにもあり、viMapAddress()やviPeekX()など、対応する関数があります。NI-VISAでは、マッピングされる領域はセッションにつき1つに限定されているため、指定したデバイスに対して複数のセッションを開き、下位アクセスのために複数の領域をマッピングしてください。

イベントのアサートおよび処理

NI-VISAには、viAssertIntrSignal()、viAssertTrigger()などのオペレーションがあります。これは、NI-VXI APIにあるAssertVXIint()、SrcTrig()などと同じ機能をサポートします。これらの関数では、VISAの属性設定によって対応するNI-VXI APIのパラメータが提供する設定を行います。

NI-VISA APIとNI-VXI APIの違いは、VXIの割り込み、信号、トリガなどのイベントを処理するためのプログラミングをする際に最も顕著になります。イベントを有効にする関数と無効にする関数は、非常によく似ています。NI-VISAには、EnableSignalInt()など、NI-VXI API関数から派生した関数Enable...()/Disable()に対応する、viEnableEvent()およびviDisableEvent()があります。

両方のAPIを使用して、ハンドラ（別名コールバック）でイベントを非同期に受け取る、またイベントを待ち行列（キュー）に入れることができます。NI-VISAでは、viEnableEvent()のためのVI_HNDLRメカニズムおよびviInstallHandler()は、コールバックの使用を行い、VI_QUEUEではイベントの待ち行列を使用します。待ち行列を使用するNI-VXI APIの例として、SetVXIintHandler()などのSet...Handler()関数や、信号をキューに引き渡すRouteSignal()関数が挙げられます。イベントをキューから取り出す作業は、NI-VXIとNI-VISAではほぼ同様です。たとえば、WaitForSignal()や関連した関数の代わりにviWaitOnEvent()が使用されます。

VI_EVENT_VXI_SIGPイベントタイプ（割り込みと信号の両方）を提供するNI-VISAとRouteVXIint()オペレーションを提供するNI-VXIを使用して、両方のAPIでVXI割り込みおよび信号を合わせて処理することもできます。

アプリケーションを閉じる

アプリケーションの最後に、CloseVXIlibrary()の代わりにviClose()でデバイスのハンドルを閉じ、もう一度viClose()でデフォルトリソースマネージャセッションを閉じることによりNI-VISAをシャットダウンします。

ほとんどのアプリケーションでは、VXIデバイスの制御に、NI-VXI APIの代わりにNI-VISAを使用するほうが適切です。NI-VXIからNI-VISAへコードを移植する作業は容易でない場合もありますが、より使いやすく強力なAPIとインタフェース間の互換性を提供するVISAの特徴を考慮すると、変更する価値があります。

メモ 48ビット拡張ワードシリアルプロトコルコマンドやSEMI-SYNCトリガなどの機能の中には、NI-VXI APIでのみ使用可能なものもあります。この機能がVISAプログラムで必要な場合は、ナショナルインスツルメンツまでご連絡ください。アプリケーションについてのご意見をお待ちしております。また、VISA志向のソリューションについてのサポートも提供しております。


NI-VISAでGPIB-VXI/Cをプログラミングする

NI-VISAで計測器をプログラミングする場合に使用する関数は、GPIB-VXI/Cをプログラミングする際にそのまま使用できます。viWrite()およびviRead()を使用すると、メッセージベースの通信を行うことができます。viInX()関数、viOutX()関数、viMoveInX()関数、およびviMoveOutX()関数を使用して、レジスタベースの通信を行うことができます。また、NI-VISAまたはNI-VXI APIでメッセージベースデバイスと通信するおよびNI-VISAを使用するを参照してください。


NI-VISAまたはNI-VXI APIで大きいデータブロックを移動する

効率良くデータブロックを移動するには、NI-VISAのviMoveX()またはNI-VXI APIのVXImove()を使用する方法が最適です。（ナショナルインスツルメンツでは、アプリケーションの開発にはNI-VXI APIよりNI-VISAをご使用になることをお勧めします。）これらの関数の使用方法の例は、NI-VISAおよびNI-VXI APIのサンプルディレクトリにあります。NI-VISAのサンプルはvxipnp¥win32¥Nivisa¥examplesディレクトリにあり、HighReg.cと呼ばれます。NI-VXI APIのサンプルはnivxi¥win32¥examplesディレクトリにあり、VXIblock.cと呼ばれます。

多量なVXIバス転送を最適化する

パフォーマンスを最適化するには、viMove()またはVXImove()を使用する際に以下に注意してください。

  • バッファが32ビットで整列されていることを確認します。
  • 可能な限り、32ビットデータで送信します。
  • VXIブロックのアクセス権を使用することで、ブロック転送を受け入れることができるデバイスとのパフォーマンスが大幅に向上されます。同様に、VME64 64ビットデータ転送プロトコルを受け入れることができるデバイスには、D64アクセス権を使用します。
  • Windowsオペレーティングシステムなどの仮想メモリシステムで移動のパフォーマンスを最適化するには、メモリ内のユーザバッファを手動でロックして、移動操作がバッファのロックをする必要がないようにします。
  • Windowsオペレーティングシステムなどのページメモリシステムで移動のパフォーマンスを最適化するには、連続バッファを使用して、移動操作がユーザバッファのスキャッタ・ギャザーリストを作成する必要がないようにします。
メモ viMemAlloc()またはVXImemAlloc()は、移動操作で効率的な、32ビットで整列された、ページロックされている、連続バッファを返します。


VME64を使用してデータを転送する

NI-VISAでは、viSetAttribute()を使用して、適切な属性(VI_ATTR_SRC_ACCESS_PRIVまたはVI_ATTR_DEST_ACCESS_PRIV）の設定により、VME64をサポートします。これを設定すると、データを転送するviMoveX()を呼び出すことができます。

メモ 　ナショナルインスツルメンツでは、アプリケーションの開発に、NI-VXI APIではなくNI-VISAをご使用になることをお勧めします。

NI-VXI API関数のVXImove()を使用して、VME64ブロックを転送することができます。ビット2、4、110（権限のないアクセスの場合や、権限のあるアクセスでは、111を使用）を設定すると、VXImove()はVME64ブロックサイクルを指定アドレスに発行します。特定のデバイスのみがVME64転送を受け入れます。特定の計測器の仕様を調べて、VME64をサポートするかどうか確かめてください。

NI-VISAおよびNI-VXI APIの大きいデータブロックを移動するも参照してください。


VXIのプログラムをデバッグする

VXIプログラムをデバッグする最良の方法は、NI I/O Traceユーティリティを使用することです。NI I/O Traceを起動および構成して、関数の呼び出しを記録してください。プログラムを実行すると、NI I/O TraceはNI-VISA、NI-VXI API、またはNI-488.2への呼び出しをすべて記録します。NI Spyは、エラーを返す関数をすべてハイライトし、それらの関数に渡されるパラメータをチェックすることができます。

デバイスが正常に動作しない場合、VISAICまたはVICを使用すると多くの問題をデバッグすることができます。これらのユーティリティを使用すると、プログラムを作成しないでデバイスと対話することができます。そのため、アプリケーションが正しく作成されているかどうかを懸念せずに、デバイスとの通信方法が正常であることを確認できます。いったん通信が確立できたら、VISAICまたはVICで呼び出した関数と同じ関数をプログラムでそのまま使用できます。


C言語でプログラムを作成する

C言語でVXIのプログラムを作成する

計測器ドライバを使用する

NI-VISAを使用する


計測器ドライバを使用する（C言語）

サポートされているC言語のコンパイラ（LabWindows/CVI、Microsoft Visual C++、およびBorland C++）では、WindowsでVXIplug&play計測器ドライバを使用することができます。

WINフレームワーク計測器ドライバの配布ディスクには、C言語のソースコードファイル（.Cおよび.H）、その計測器ドライバに関連したグラフィックパネルを記述する関数パネルファイル（.FP）、そのドライバのコンパイルバージョンのDLLファイル（.DLL）、およびWindowsヘルプファイル（.HLP）があります。

計測器ドライバの関数を使用するには、Cコードに.Hファイルを含めてください。LabWindows/CVIをご使用でない場合は、コンパイラ別のインポートライブラリ（.LIB）ファイルをプロジェクトへリンクし、.DLLファイルをWindows/SystemまたはWinNT/Systemのディレクトリへコピーする必要があります。

プログラムの最初のタスクは、INITIALIZE関数を呼び出して計測器への接続を初期化することです。INITIALIZE関数の出力の1つに、計測器IDがあります。基本的には、これが計測器のハンドルです。計測器の接続を初期化したら、上位のAPPLICATION関数と下位のCOMPONENT関数のどちらかを使用できます。前者は、測定オペレーションを一通り行い、後者は計測器のオペレーションをより細かく制御できるのが特徴です。プログラムの最後でCLOSE関数を使用して、計測器への接続を解除します。

VXIplug&play計測器ドライバを使用する重要なメリットとして、ドライバにあるオンラインヘルプがあります。このヘルプでは、ドライバの各コンポーネントの説明とそのコンポーネントの階層的な概要があります。


NI-VISAを使用する（C言語）

NI-VISAでは、LabWindows/CVI、Microsoft Visual C++、およびBorland C++のCコンパイラをWindowsでサポートしています。各コンパイラのサンプルを参照してください。サンプルは、vxipnp\win95\NIvisa\examplesまたはvxipnp\winNT\NIvisa\examples\ディレクトリにあります。NI-VISAプログラムの基本的な流れは、どのコンパイラでも同じです。

最初に呼び出す関数は、viOpenDefaultRM()です。この関数によりNI-VISAが初期化され、VISAのリソースマネージャを操作できます。これは、後に呼び出す関数で必要となります。計測器にアクセスするには、viOpen()でその計測器のハンドルを取得します。次に、プログラムが非同期イベントの処理を行う場合、非同期イベントハンドラを設定します。その後、ご使用の計測器すべてにアクセスします。すべての通信処理が終了した後、viClose()を呼び出して各計測器ハンドルとリソースマネージャのハンドルを閉じます。NI-VISA関数がすべて宣言されるように、#includeでvisa.hを必ず含んでください。

LabWindows/CVIを使用しない場合は、コンパイラ別のインポートライブラリのvisa32.libにリンクすることが必要です。LabWindows/CVIはこのステップを自動的に処理します。

また、NI-VISAまたはNI-VXI APIでメッセージベースデバイスと通信するを参照してください。


LabVIEW開発環境でプログラムを作成する

LabVIEW開発環境でVXIプログラムを作成する

計測器ドライバを使用する

NI-VISAを使用する


計測器ドライバを使用する（LabVIEW開発環境）

LabVIEWでは、GWINフレームワーク計測器ドライバとWINフレームワーク計測器ドライバの両方を使用できます。計測器にGWINドライバがあれば、LabVIEW開発環境内からブロックダイアグラムのソースコードへアクセスできます。LabVIEWでWINドライバをご使用の場合、DLLインタフェースでドライバに接続できます。したがって、ブロックダイアグラムのソースコードはありません。ただし、ドライバ各関数のフロントパネル、アイコン、ヘルプ情報、およびブロックダイアグラム（DLL呼び出し用）を含むネイティブLabVIEW VIを利用することができます。

プログラムの最初のタスクは、INITIALIZE関数を呼び出して計測器への接続を初期化することです。INITIALIZE関数の出力の1つに、計測器IDがあります。基本的には、これが計測器のハンドルです。計測器の接続を初期化したら、上位のAPPLICATION関数と下位のCOMPONENT関数のどちらかを使用できます。前者は、計測オペレーションを一通り行い、後者は計測器のオペレーションをより細かく制御できるのが特徴です。プログラムの最後でCLOSE関数を使用して、計測器への接続を解除します。

GWIN計測器ドライバをLabVIEWで使用するには、以下のファイルとソフトウェアが必要です。

  • Windows対応LabVIEW 5.0以降
  • VISA32.DLL 2.01以降
  • instr_name.LLB
  • instr_name.HLP

計測器ドライバのVIは他のLabVIEW VIと同様に、ロードすることができます。

WIN計測器ドライバをLabVIEWで使用するには、以下のファイルとソフトウェアが必要です。

  • Windows対応LabVIEW 5.0以降
  • VISA32.DLL 2.01以降
  • instr_name.DLL
  • instr_name.H
  • instr_name.HLP
  • instr_name.LLB

WINドライバは、LabWindows/CVIを使用してC言語でコードされています。このため、WIN計測器ドライバをLabVIEWで使用する前に、LabVIEWを使ってドライバをLabVIEW VIに自動変換してください。LabVIEWを起動して、ファイル→CVI FPファイルを変換...（LabVIEW 5.x）を選択するか、ツール→計測器→CVI計測器ドライバをインポート（LabVIEW 6.x）を選択します。.FPファイルと.DLLファイルの両方を要求するプロンプトが表示されます。WIN計測器ドライバをLabVIEWライブラリ（.LLB ファイル）に変換したら、そのVIを他のLabVIEW VIと同様に使用することができます。

VXIplug&play計測器ドライバをご使用の際は、オンラインヘルプをご利用ください。このヘルプでは、ドライバの各コンポーネントの説明とそのコンポーネントの階層的な概要があります。計測器のWindowsヘルプファイルは、LabVIEWを使用中に標準Windowsヘルプシステムを使ってアクセスできます。


NI-VISAを使用する（LabVIEW開発環境）

NI-VISA(LabVIEW開発環境）

NI-VISAを使用してLabVIEWで書かれたVXIプログラムのサンプルは、examples¥instr¥visaディレクトリにあります。

プログラムで最初に呼び出すVIはVISA Openです。このVIは計測器との通信チャネルを開きます。この通信チャネルは、セッションとして知られていて、VISAプログラムの残りの部分全体で、通信とその計測器の属性の設定を固有のものにしておくために使用されます。各計測器と通信を開始するにはVISA Open VIを呼び出してください。セッションが開かれると、非同期のイベントハンドラを設定することができます。このハンドラは、プログラムが非同期イベント処理を行う場合に必要です。次に計測器にアクセスします。その後、各セッションおよびイベントオブジェクトを閉じるためにVISA Close VIを呼び出します。

Simple Error Handler VIを使用すると、エラー発生時にエラーのチェックや表示を行うことができます。


Visual Basicでプログラムを作成する

Visual BasicでVXIプログラムを作成する

NI-VISAを使用する


NI-VISAを使用する（Visual Basic）

NI-VISAを使用する (Visual Basic)

Microsoft Visual Basic （4.0以降）のアプリケーションファイルには、VISA32.BASモジュールを含める必要があります。このモジュールは、 vxipnp\win95\includeディレクトリまたは vxipnp\winNT\includeディレクトリにあり、ダイナミックリンクライブラリ VISA32.DLLとのインタフェースとなる NI-VISA関数のプロトタイプおよびVISA特有の定数定義が含まれています。

VISAを使用したVXI Visual Basicのサンプルは、ni-vxi¥win32¥vb¥examplesディレクトリにあります。これらのサンプルは、プログラムを開始するときに参考として使用することができます。

最初に呼び出す関数は、viOpenDefaultRM()です。この関数により、NI-VISAが初期化され、VISAのリソースマネージャのハンドラが得られます。これは、後に呼び出す関数で必要となります。VISAリソースマネージャへのセッションを開いた後、viFindRsrc() を呼び出すと、どの計測器でセッションを開くことができるかがわかります。計測器にアクセスするには、viOpen()でその計測器へのセッションを開きます。計測器のセッションが開かれると、非同期のイベントハンドラを設定できます。このハンドラは、プログラムが非同期イベント処理を行う場合に必要です。次に計測器すべてにアクセスします。その後、各計測器ハンドルとリソースマネージャのハンドルを閉じるためにviClose()を呼び出します。

計測器ドライバを作成する場合、モジュールVPPTYPE.BASもご使用のアプリケーションのプロジェクトファイルに含めるようにしてください。このファイルはVXIplug&play計測器ドライバのヘッダファイルです。これは、vxipnp¥win95¥includeディレクトリまたはvxipnp¥winNT¥includeディレクトリにあります。


問題の原因

構成に関する質問

プログラミングに関する質問

トラブルシューティング


構成に関する質問

GPIBデバイスを検出できない理由

シリアルデバイスを検出できない理由

VXIデバイスを検出できない理由

GPIB-VXI/VXIデバイスと通信できない理由

VMEデバイスをリソースマネージャで構成できない理由

A24範囲で8MBを超えるメモリを共有できない理由

HP-VISAとNI-VISAを同じシステムで使用できない理由


GPIBデバイスを検出できない理由

GPIBデバイスを検出できない理由はいくつかあります。まず、NI-488.2がシステムに正しくインストールされている必要があります。NI-VISAはシステムに付属のデバイスをすべて検出しようとします。中には、動的に検出されないデバイスもあります（特に、すべてのリスナを検出するというGPIBコマンドに対して応答しないデバイス）。


シリアルデバイスを検出できない理由

シリアルデバイスを検出できない理由はいくつかあります。まず、NI-VISA がシステムに正しくインストールされている必要があります。NI-VISAはシステムに付属のシリアルポートをすべて検出しようとします。ポートは、デバイスが付属されていない場合もリストされます。動的に検出されないポート（特に、パラレルポート）もあります。NI-VISAでこれらのデバイスを表示するには、構成にデバイスを手動で追加してください。また、LabVIEW RTシステム上のシリアルポートには、LabVIEW RT対応のNI-Serialがインストールされている必要があります。


VXIデバイスを検出できない理由

GPIB-VXIを使用してVXIシャーシにアクセスする場合は、GPIB-VXI/VXIデバイスと通信できない理由を参照してください。

外部または組み込み式VXIコントローラを使用してVXIバスにアクセスする場合は、NI-VXI をシステムに正しくインストールする必要があります。構成ユーティリティはNI-VXI Resmanユーティリティを使用して、VXIデバイスを検出および構成します。Resmanがエラーを報告した場合、システムが正しく構成されていない可能性があります。

検出されるはずのデバイスがある場合、シャーシに電源が入っているか、また、計測器が動作しているかどうかを確認してください。警告やエラーのメッセージについては、MAXの構成の表示を確認してください。デバイス間のリソースの競合により、Resmanの実行に失敗することがあります。MXI-2またはVXI-8340シリーズをご使用の場合、ケーブルがすべてしっかりと接続してあることを確認してください。また、MXI-2の場合、シャーシ側のケーブル端がシャーシに差し込まれていることを確認してください。MXI-2ケーブル上のラベルが、MXIバスシステムのコントローラ側に接続されたコネクタ付近にあることを確認してください。

また、Resmanは、VMEデバイスを検出できません。システムにVMEデバイスがある場合は、システムに手動で追加してください。


VMEデバイスをリソースマネージャで構成できない理由

リソースマネージャでは、VXIが定義する 構成レジスタを読み書きして、VXIの仕様で定義されたとおりにシステムを構成します。VMEデバイスには、これらの構成レジスタがないため、リソースマネージャによる構成が行えません。

VMEデバイスと正しく動作するようにシステムを構成するには、システムにデバイスを手動で追加してください。デバイスがNI-VISA、NI-VXI APIおよびユーティリティに表示されます。これにより、VXIデバイスとVMEデバイスの間でリソースの競合が防止され、競合が発生しそうな場合にユーティリティが通知できるようになります。その結果、VME-MXI-2エクステンダを正しく構成できるようになります。


GPIB-VXI/VXIデバイスと通信できない理由

GPIB-VXIを使用してVXIのシャーシにアクセスするには、NI-VISAがシステムに正しくインストールされている必要があります。NI-VISAは、GPIBのプライマリアドレス1およびセカンダリアドレス0に設定されていないGPIB-VXIボードを自動的に検出できません。GPIB設定が上記以外に設定されているGPIB-VXIボードの場合は、手動でシステムに追加してください。


A24範囲で8MBを超えるメモリを共有できない理由

VXI仕様では、どの特定のデバイスでもメモリが常駐しているアドレス範囲の半分しかリクエストできません。A24範囲は16MBしかないため、どのデバイスでもリソースマネージャからリクエストできるメモリの最大量は、8MBとなります。


HP-VISAとNI-VISAを同じシステムで使用できない理由

HP-VISAおよびNI-VISAは同じAPIを定義しますが、VISAの各関数の実装方法は異なります。HP-VISAとNI-VISAを同じシステムで実行すると、アプリケーションが混乱する恐れがあります。たとえば、LabVIEWからviOpenを呼び出す場合、LabVIEWは最初に検出した方のVISAドライバにアクセスします。


プログラミングに関する質問

MapVXIAddress()またはviMapAddress()を呼び出す

VXImemAlloc()またはviMemAlloc()を呼び出す


VXIMapAddress()またはviMapAddress()を呼び出す

MapVXIAddress()またはviMapAddress()を呼び出す

メモ 　ナショナルインスツルメンツでは、アプリケーションの開発に、NI-VXI APIではなくNI-VISAをご使用になることをお勧めします。

ユーザウィンドウのサイズがゼロに設定されている場合や、マッピングしようとしているウィンドウのサイズより小さい場合、MapVXIAddressまたはviMapAddressが正しく実行されない可能性があります。外部コントローラまたはVXIpc組み込み式コントローラを右クリックしてハードウェアの構成を選択し、ユーザウィンドウのサイズを確認してください。このウィンドウのサイズは、マッピングしようとしているウィンドウのサイズ合計より大きい必要があります。

MapVXIAddress()およびviMapAddress()の使用方法を示すサンプルコードを確認してください。NI-VISAのサンプルコードはvxipnp¥win32¥Nivisa¥examplesディレクトリにあり、LowReg.cといいます。NI-VXI APIコード、VXIlow.cは、nivxi¥win32¥msc(borlandc)¥examples¥ディレクトリにあります。


VXImemAlloc()またはviMemAlloc()を呼び出す

メモ 　ナショナルインスツルメンツでは、アプリケーションの開発に、NI-VXI APIではなくNI-VISAをご使用になることをお勧めします。

サイズパラメータで要求した物理メモリ量の割り当ておよび確保ができない場合、VXImemAllocまたはviMemAllocは正しく実行できません。共有メモリを使用する場合、外部コントローラまたはVXIpc組み込み式コントローラを右クリックし、ハードウェアの構成を選択すると、これらの設定を確認できます。メモリを共有しているシステムは、A16のみに設定しないでください。システムメモリは、A24領域またはA32領域でのみ共有できます。共有しようとしているメモリは、割り当てるメモリをすべて処理するのに充分な量に設定してください。

共有しているメモリは、VXImemAlloc()またはviMemAlloc()で割り当てようとしている量より多くなるように設定してください。共有メモリのページにある物理メモリを予約フィールドを設定し、割り当てようとしているメモリの量と同等以上のメモリの量を確保してください。

VXImemAllocおよびviMemAlloc()の使用方法を示したサンプルコードがあります。NI-VISAのサンプルコードはvxipnp¥win32¥Nivisa¥examplesディレクトリにあり、ShareSys.cといいます。NI-VXI APIコード、VXImem.cは、nivxi¥win32¥msc(borlandc)¥examples¥ディレクトリにあります。

メモ 　一部のコントローラは共有メモリをサポートしません。共有メモリのサポートの詳細については、コントローラのドキュメントを参照してください。


トラブルシューティング

デバイスビジー

デバイス無効

デバイス欠落機能

デバイスオフライン

デバイスOK

デバイス状態不明

デバイススタティック


デバイスビジー

このデバイスはビジー状態であるため、VISAはこのデバイスと通信できません。このデバイスがCOMMポートを使用している場合、モデムやマウスまたは他のデバイスで使用されている可能性があります。今後VISAがこのデバイスを開かないようにするために、このデバイスを無効にすることもできます。

このデバイスがビジー状態であるべきでないと考えられる場合は、アプリケーションをすべて閉じるか、Windowsを再起動してデバイスを使用しているタスクをすべて終了してください。


デバイス無効

デバイスが無効に設定されているため、MAXはこのデバイスの状態を判断できませんでした。VISAやご使用のアプリケーションにはデバイスが無効かどうかは表示されません。システムにあるデバイスを使用したい場合、プロパティダイアログのデバイスの有効化ボックスにチェックマークを付けると再び有効にすることができます。


デバイス欠落機能

このデバイスは機能が不足している可能性があります。使用できない機能がご使用のアプリケーションに必要ない場合、このデバイスを使用しても問題はありません。


デバイスオフライン

このデバイスはセルフテストに失敗し、強制的にオフラインとなりました。デバイスを再設定し、リソースマネージャを再実行してください。それでも問題が解決しない場合は、デバイスの製造元にお問い合わせください。


デバイスOK

このデバイスは正常に動作しています。このデバイスを使用して通信することができます。


デバイス状態不明

VISAがデバイスの状態を判断できないことがあります。動的に検出されないデバイスや状態を判断するプロトコルをサポートしないデバイスは、このカテゴリに入ります。


デバイススタティック

デバイスをシステムに手動で追加したため、MAXはこのデバイスの状態を判断できませんでした。VISAはスタティックデバイスを自動検出できないため、MAXはデバイスの状態をクエリできません。


手順を行う理由とタイミング

NI-VISAの使用とNI-VXI APIの使用

NI-VISAの使用とHP/Agilent VISAの使用

低レベルVXIアクセスコールを使用する（viMapAddress()を使用）

高レベルVXIアクセスコールを使用する

viMove()またはVXImove()を使用する

VISAのiblnを無効にする

VISAのGPIB-VXI/Cボードを自動検出しないように設定する

viClose()を呼び出す


NI-VISAの使用とNI-VXI APIの使用

ナショナルインスツルメンツでは、VXI/VMEアプリケーションの開発には、NI-VXI APよりもNI-VISAをご使用になることをお勧めします。これらのAPIは両方とも、VXI計測器でのメッセージベースの通信、VXIバックプレーン上での高レベルおよび低レベルの通信、ブロック転送、および非同期のイベントの処理を行うことができます。ただし、NI-VXI（ナショナルインスツルメンツのコントローラに同梱されるソフトウェアパッケージ。Measurement & Automation ExplorerおよびResmanなどのユーティリティも含まれます）は、NI-VISAを通して使用するために最適化されています。

GPIBまたはシリアル計測器を使用する場合、あるいはVXI計測器がGPIB-VXI/C経由で接続されている場合、APIがインタフェース依存でないため、NI-VISAを使用することが多くなります。メッセージをGPIB計測器に送信する呼び出しは、メッセージをVXI計測器に送信するのに使用する呼び出しと同じです。NI-VISAも非同期I/Oオペレーションをサポートしますが、NI-VXI APIはサポートしません。

NI-VXI APIは、NI-VISAがサポートしない特定のレガシー計測器および動作をサポートします。RORAインタラプタやバスエラーの非同期通知等がこの例になります（VISAは高レベルのバスアクセス関数からのバスのエラーをリポートすることに注意してください）。

同じプログラムで両方のインタフェースを使用することができますが、両方のAPIの機能が必要でない限りこの方法は推奨できません。両方の言語で非同期イベントを処理しないでください。VXIインタラプタまたはトリガ等の非同期イベントを処理する必要がある場合、APIを1つ選び、すべての非同期オペレーションに使用してください。


NI-VISAの使用とHP/Agilent VISAの使用

NI-VISAとHP/Agilent VISAのどちらを使用するかは、GPIBおよびVXIコントローラの製造元によって決まります。NI-VISAおよびHP/Agilent VISAの違いは、ハードウェアに対するインタフェースです。ナショナルインスツルメンツのVXIおよびGPIBコントローラを使用する場合は、NI-VISAをご使用ください。HP/Agilent VISAでは、たとえば外部コントローラ等のナショナルインスツルメンツのボードとの通信ができません。逆に、HP GPIBやVXIコントローラを使用する場合は、HP/Agilent VISAをご使用ください。GPIBコントローラボードと製造元が異なるVXIコントローラをVISAといっしょに使用することはできません。ただし、HP/Agilent VISAのAPIとNI-VISAのAPIは同一で、プログラミング時に書くコードも両者で相違はありません。

ナショナルインスツルメンツとヒューレット・パッカードのGPIB-VXIコントローラは、VISAのどちらのインプリメンテーションでも使用することができます。システムでGPIB-VXIを使用する場合、GPIBコントローラボードの製造元がどの会社かで、どちらのVISAを使用すべきかが決まります。


低レベルVXIアクセスコールを使用する（viMapAddress()を使用）

低レベルのVXIアクセス関数は、ハードウェアに対する最も低いレベルのインタフェースを提供し、結果として最高のPeek/Poke性能が得られます。ただし、これを使用するのは、高レベル関数を使用するほど簡単ではありません。viMapAddress()は、仮想アドレス範囲のウィンドウをVXIアドレス範囲の一部にマッピングします。これで、バックプレーンのメモリへ直接アクセスできます。ただし、そのウィンドウのコンテキストの管理、バスのエラーの確認、ウィンドウの境界を越えた読み取りないし書き込みをしないようにする必要があります。

低レベルコールを使用すべきでないときに使用するケースが頻繁にあります。VXIアドレス範囲の範囲が時間重視でない場合は、ウィンドウをその領域にマッピングしないでください。その代わり、高レベルコールでこれらのデバイスと通信してください。また、データブロックの転送のため、viPeekX()/viPokeX()の呼び出しをループに置くことがよくあります。これは、ブロック転送をするのに一番効率の良い方法ではありません。代わりに、ブロック転送関数viMoveX()を使用してこのタスクを行ってください。

低レベルアクセスコールをプログラムで使用する場合は、ナショナルインスツルメンツが提供するサンプルをご覧ください。


高レベルVXIアクセスコールを使用する

高レベルVXIコールは、VXIデバイスとのレジスタレベルの通信を確立する最も簡単な方法です。できるだけ高レベルコールを使用してください。初めてVXIでプログラミングをする場合は、まず高レベルコマンドを使用することを推奨します。アプリケーションが速度重視のPeekおよびPokeを行う場合、低レベルアクセスコールの使用を検討してください。


viMove()またはVXImove()を使用する

VXIバックプレーンに大きいデータブロックを転送する場合、viMoveX()（NI-VISA）またはVXImove()（NI-VXI API）を使用してください。（ナショナルインスツルメンツでは、アプリケーションの開発にはNI-VXI APIよりもNI-VISAの使用を推奨します。）viMoveX()およびVXImove()を使用する方法は、データブロックを転送する最も高速な方法です。これは、関数がドライバやハードウェアの多くの機能を効果的に利用するためです。これらの関数は両方とも、データを連続したメモリブロックおよびFIFOキューから転送することができます。

NI-VISAおよびNI-VXI APIの大きいデータブロックを移動するも参照してください。


VISAのiblnを無効にする

特定のNI-VISAコール（viClear()、viAssertTrigger()など）は、ibln()を使用した追加チェックを行い、デバイスの有無を確認します。アプリケーションの性能を最適化するには、MAXでこの機能を無効にします。

ツールメニューからNI-VISA→VISAオプションを選択し、NI-VISAで構成できるオプションを表示します。


VISAのGPIB-VXI/Cボードを自動検出しないように設定する

GPIB-VXIでなく*IDN?に応答しないデバイスがPA1 SA0にある場合、自動検出を無効にしてください。

ツールメニューからNI-VISA→VISAオプションを選択し、NI-VISAで構成できるオプションを表示します。


viClose()を呼び出す

これはNI-VISAの終了ルーチンで、すべてのアプリケーションの最後（または中断）に含まれている必要があります。計測器の使用が終了したら、開いた計測器ハンドルをviClose()の呼び出しにより閉じてください。リソースマネージャハンドルに対しviClose()を呼び出すと、割り込みが無効になり、内部リソースマネージャテーブルや他のストラクチャに割り当てられたダイナミックメモリが解放されます。ドライバでクリーンアップの操作を試みますが、アプリケーションの終了時にリソースマネージャハンドルに対してviClose()の呼び出しを行わないと、予期しない不具合が発生する恐れがあります。オペレーティングシステムの中断ルーチンによってアプリケーションが中断できるようになっている場合、開いているハンドルに対してviClose()を呼び出すアボート/クローズルーチンを必ず作成してください。


詳細ヘルプ

このウィンドウは、詳細ヘルプを表示します。詳細ヘルプの内容を表示するには、カーソルを制御器または表示器の上に移動します。


バージョン情報ダイアログボックス

ソフトウェアの情報ボタンは、ソフトウェアのコンポーネントすべてに関するバージョン情報を入手するときにクリックしてください。


エイリアス用デバイス追加ウィザードページ

このダイアログボックスは、デバイス名とリソース名を割り当てるときに使用します。


デバイスの追加ウィザードの完了ページ

このダイアログボックスは、このデバイスの追加ウィザードセッションを終了するときに使用します。完了ボタンをクリックし、新規デバイスをシステムに作成します。


GPIBデバイス用デバイスの追加ウィザード

このダイアログボックスは、プライマリアドレスおよびセカンダリアドレスを定義し、このGPIBデバイスを固有に識別するときに使用します。


GPIB-VXIデバイス用デバイスの追加ウィザード

このダイアログボックスは、デバイス番号およびVXI論理アドレスを定義し、このGPIB-VXIデバイスを固有に識別するときに使用します。


シリアルデバイス用デバイスの追加ウィザード

このダイアログボックスは、MAXがシステムに追加できるようにシリアルデバイスの属性を定義し、このシリアルデバイスを固有に識別するときに使用します。


デバイスの追加ウィザードのスタートページ

このダイアログボックスは、システムに追加するデバイスのタイプを選択するときに使用します。


VMEデバイス用デバイスの追加ウィザード

このダイアログボックスは、VMEデバイスにVXIの特性を割り当ててシステムに追加し、VXIデバイスとして動作させるときに使用します。


VXIデバイス用デバイスの追加ウィザード

このダイアログボックスは、製造元名およびモデル名を選択したデバイスに割り当てるときに使用します。


VXIリソース用デバイスの追加ウィザード

このダイアログボックスは、このVXIまたはVMEデバイスで使用するリソースを追加、編集、または削除するときに使用します。


エイリアスを追加ダイアログボックス

このダイアログボックスは、エイリアスをシステムにあるデバイスに割り当てるときに使用します。エイリアスを割り当てるには、リソース名とエイリアスをタイプしてOKをクリックします。


VISAエイリアスエディタダイアログボックス

このダイアログボックスは、システムにあるデバイスのVISAのエイリアスを作成、変更、削除するときに使用します。

新しいエイリアスをデバイスに割り当てるには、デバイス名を選択して、エイリアスを編集をクリックします。既存のエイリアスを変更するには、デバイス名を選択してエイリアスを追加をクリックし、エイリアスを追加ダイアログボックスを表示します。エイリアスをすべて削除するには、すべてのエイリアスを消去をクリックします。終了したら、OKをクリックして、変更を保存します。


シリアルデバイスのプロパティダイアログボックス

このダイアログボックスは、強調表示されたシリアルデバイスについてシリアルポートのバインド、ボーレート、データビット、パリティ、停止ビット、およびフローコントロール設定を表示または構成するときに使用します。


VXIデバイスの構成ダイアログボックス

このボックスは、使用可能なエディタでシステムにあるデバイスを構成するときに使用します。


割り込みハンドラダイアログボックス

このダイアログボックスは、デバイスへの割り込みラインを割り当てるときに使用します。


選択したエントリを変更できるポップアップボックス

エントリを編集する

選択したエントリを変更できるポップアップボックス


環境設定ダイアログボックスの全般環境設定ページ

このページは、スタートアップ時のチェックおよび表示を設定するときに使用します。


デバイスの一般プロパティダイアログボックス

このページは、デバイスの一般的な特徴の表示または変更および問題のトラブルシューティングを行うときに使用します。


GPIBデバイスのプロパティダイアログボックス

このページで、GPIBデバイスのプライマリアドレスおよびセカンダリアドレスを表示または編集し、GPIBバスのコントローラデバイスの位置を識別してください。


製造元名エディタダイアログボックス

このエディタは、製造元名とIDナンバーのリストをアップデートするときに使用します。


モデル名エディタダイアログボックス

このエディタは、関連製造元名とIDナンバーとともに、モデル名のリストをアップデートするときに使用してください。


デバイスの一般プロパティダイアログボックス

このページでは、ご使用のデバイスの一般的な特性を表示し、VISAエイリアスを割り当てます。


GPIBデバイスのプロパティダイアログボックス

このページで、GPIBデバイスのプライマリアドレスおよびセカンダリアドレスを表示し、GPIBバスのコントローラデバイスの位置を識別してください。


GPIBデバイスのプロパティダイアログボックス

このページで、GPIBデバイスのプライマリアドレスおよびセカンダリアドレスを編集し、GPIBバスのコントローラデバイスの位置を識別してください。


割り込みハンドラダイアログボックス

このダイアログボックスは、編集ボタンで構成できる割り込みハンドラのリストを表示するときに使用します。


VXIシステム割り込みレベルダイアログボックス

このダイアログボックスは、割り込み用にハンドラを割り当てるときや、割り込みをフレーム間で自動的にマッピングするときに使用します。


信号マッピングダイアログボックス

このページで、このデバイスのシグナルマッピングを構成します。


NI-VISAクライアント環境設定　全般ダイアログボックス

このダイアログボックスは、VISAリモートサーバにアクセスする環境設定を表示するときに使用します。


NI-VISAサーバプロパティ　全般ダイアログボックス

このダイアログボックスは、リモートサーバのNI-VISAのプロパティを表示するときに使用します。


VMEプロファイルのプロパティ　全般ダイアログボックス

このページは、デバイスの一般的な特徴の表示または変更および問題のトラブルシューティングを行うときに使用します。


VMEプロファイルのリソースプロパティダイアログボックス

このダイアログボックスは、強調表示されたデバイスのリソース設定を表示、追加、または修正するときに使用します。また、リソースの競合トラブルシューティングをするときに使用します。


VXIシステムの設定ダイアログボックス

このダイアログボックスは、このシステムのシステム番号やリソースマネージャの遅延を変更するとき、およびMXIバスを非表示にするときに使用します。


割り当てられていないVMEデバイスダイアログボックス

このダイアログボックスは、もう存在しないフレームにあるVMEデバイスを表示するときに使用します。トラブルシューティングボタンで、デバイスを有効なフレームに割り当ててください。


PXIデバイスのプロパティダイアログボックス

PXIデバイスの製造元名やモデル名を始め、バス、デバイス、ファンクション番号を表示するには、このページを使用してください。


パスポートレジストリエディタダイアログボックス

このダイアログボックスは、VISAライブラリパスポートの追加、削除、有効化、または無効化に使用します。リストにあるパスポートにチェックマークを付けるとパスポートが有効になり、外すと無効になります。


設定ダイアログボックスのリソースマネージャページ

このページは、リソースマネージャのスタートアップオプションを割り当てるときに使用します。


VISAセキュリティオプションダイアログボックス

このダイアログボックスは、VISAサーバへアクセスできるリモートクライアントのリストを表示するとき、または、どのクライアントにシステムのVISAリソースへアクセスを許可するかを指定するときに使用します。


環境設定ダイアログボックスのNI-VISAページ

このページは、NI-VISAを自動的に動作させるオプションを設定するときに使用します。


VMEプロファイルダイアログボックス

このダイアログボックスは、VMEプロファイルを編集するときに使用します。VMEプロファイルは、製造元名、モデル名、アドレスの範囲など、VXIシステムにあるVMEデバイスの一般的な特性やリソースの設定について記述します。


デバイスのプロパティ VMEダイアログボックス

VMEデバイスのプロパティダイアログボックス

このダイアログボックスは、VMEデバイスについての情報を入力するときに使用します。入力すると、リソースマネージャはデバイスをVXIシステムに統合することが可能になります。


VXIオプションダイアログボックス

このダイアログボックスは、VXIのリソースマネージャをスタートアップ時に実行する場合や、NI-VXI 2.0のエミュレーションレイヤを構成するときに使用します。


VXIデバイスのプロパティダイアログボックス

このダイアログボックスは、強調表示されたVXIデバイスの論理アドレス、製造元およびモデル名を表示、構成するときに使用します。


デバイスのリソースプロパティダイアログボックス

このダイアログボックスは、強調表示されたデバイスのリソース設定を表示、追加、または修正するときに使用します。また、リソースの競合トラブルシューティングをするときに使用します。


シリアルバインド

このデバイスのシリアルポート結合を識別します。


ASRL番号

シリアルデバイスを識別します。


デバイスタイプ

このリストから、システムに追加するデバイスのタイプを選択します。


デバイス名

製造元名およびモデル名を割り当てるデバイス名を表示します。


デバイス名

VISAシステムに追加するデバイス名を指定します。


フレーム

このVMEデバイスが位置するフレームを選択します。


GPIBコントローラ番号

このGPIBコントローラの識別番号を指定します。


GPIB-VXIコントローラ番号

このGPIB-VXIデバイスのボード番号を指定します。


論理アドレス

このGPIB-VXIデバイスの論理アドレスを指定します。


製造元名

このスクロールリストを使用して、VXIまたはVMEデバイスの製造元名を選択します。


モデル名

このスクロールリストを使用して、VXIまたはVMEデバイスの製造元のモデル名を選択します。


プライマリアドレス

このGPIBデバイスのプライマリアドレスを指定します。


擬似論理アドレス

擬似論理アドレスをこのVMEデバイスに割り当てます。許容範囲は、256～511です。


リソース名

リソースを説明する文字列で、どのリソースにアクセスするかを指定します。


セカンダリアドレス

このGPIBデバイスのセカンダリアドレスを指定します。


スロット

このVMEデバイスが位置するフレームのスロットを選択します。


エイリアス

デバイスに割り当てるエイリアスをタイプします。


リソース名

エイリアスを割り当てるデバイスのリソース名をタイプします。


エイリアスを追加

このボタンをクリックして、デバイスの新しいVISAエイリアスを作成します。


リソースとエイリアスのリスト

システムにあるすべてのデバイスのリソース名およびVISAエイリアスです。


すべてのエイリアスを消去

すべてのデバイスのVISAエイリアスが削除されます。エイリアスを再入力しない限り、アプリケーションで従来型のVISAリソース命を使用する必要があります（例: ASRL1::INSTR）。


エイリアス名を変更

デバイス名を選択してこのボタンをクリックして、そのデバイスの既存のVISAエイリアスを編集します。


認証

クリックして、指定した構成でNI-VISAがリソースにアクセスできるかどうかテストします。


論理アドレスに割り当てる

割り込みハンドラで特定の割り込みラインをこの論理アドレスのデバイスに割り当てるときに、このオプションにチェックマークを付けます。


ポートを変更...

リモートシステムを選択してこのボタンをクリックし、リモートシステムとの接続に使用するポート番号を変更します。この値はそのシステムのNI-VISAのサーバが通信に設定しているポート番号と同じでなければなりません。


エディタ

デバイスを構成するのに使用するエディタを選択します。


論理アドレス

デバイスの論理アドレスを選択します。


すべてのインタフェースタイプの設定を保存する

競合の有無に関係なくすべてのインタフェースタイプの選択されたVISAの情報を保存するには、このチェックボックスをオンにします。このチェックボックスをオフにすると、各インタフェースタイプの選択されたVISAに関する情報は、そのインタフェースタイプを扱うことができる複数のVISAが実装されている場合にのみ保存されます。このチェックボックスがオフの場合、これまで1つのVISAによってのみ開くことができた特定のインタフェースタイプのリソースを扱える新しいVISAがインストールされると、次回そのインタフェースタイプのリソースを開くときに、どちらか1つのVISAが選択されます。


すべてを推奨に設定

各インタフェースタイプのVISAとして、そのインタフェースタイプを扱うことができる推奨VISAを適用します。


すべての競合を削除

リストからすべての競合を削除します。


インタフェースタイプとVISAのリスト

競合マネージャが認識できるインタフェースのタイプと、各インタフェースタイプに対して現在選択されているVISAをここに示します。インタフェースタイプをクリックしてドロップダウンリストから異なるVISAを選択することもできます。各インタフェースタイプのリソースは、選択されているVISAによってのみ開かれます。


VISAを無効にする

リストで現在選択されているVISAを無効にします。推奨VISAを無効にすると、他のVISAが新たな推奨VISAとして選択されます。削除されたVISAを選択VISAとするインタフェースタイプは、他のVISAが選択されるか、競合マネージャ設定から削除されます。


VISAを有効にする

リストで現在選択されているVISAを有効にします。


推奨するVISA

システムに実装されている有効なVISAの1つを、推奨VISAとして設定できます。VISAが選択されていないリソースを開こうとした場合、推奨VISAがそれを開ければそのリソースのVISAとして選択されます。


競合を削除

選択された競合をリストから削除します。このボタンをクリックしても、システムからVISAが削除されたり、インタフェースが無効になることはありません。このボタンをクリックすると、特定のインタフェースと選択されたVISAの関連付けが解消されます。次回このインタフェースタイプのリソースを開くと、現在有効なVISAのリストから、新しいVISAが選択されます。推奨されるVISAがその特定のインタフェースタイプを扱える場合は、そのVISAが新しく選択されます。


インストールされたVISAの実装

システムで検出されたすべてのVISAが表示されます。


競合マネージャエラー

競合マネージャの設定はロードできませんでした。


新規システムを作成...

このボタンをクリックして、リストに表示されていないリモートVISAシステムを作成します。


デバイスのアイコン

デバイスのタイプを示すアイコンを表示します。


デバイス名

構成しているデバイス名を表示します。


エントリコード

現在選択されているエントリを表示します。あるいはこの時点で、新しい番号コードを追加できます。


エントリ名

現在選択されているエントリを表示します。あるいはこの時点で、新しい名前を追加できます。


NI I/O Traceで表示されるようにｐeek/pokeコールを強制する

NI I/O Traceで表示されるようにpeek/pokeコールを強制する

この機能を有効にすると、ポインタをデリファレンスする代わりにアプリケーションで下位のPeek/pokeレジスタベースの関数が使用されます。アプリケーションに関数の呼び出しを強制すると、NI I/O Traceはリスト内のコールをキャプチャできるようになります。この機能を有効にするとパフォーマンスが影響されるため、通常このオプションの選択は外してください。


デバイスの有効化

このボックスで、システムにあるデバイスを手動で有効または無効にします。


参照

このボタンをクリックすると、選択したデバイスドライバを検索/ダウンロードするためのアプリケーションが起動します。


計測器ドライバファインダ（IDFinder）

このセクションでは、デバイスの計測器ドライバを検索、ダウンロードできます。LabVIEWで計測器ドライバファインダ（IDFinder）で使用するか、計測器ドライバネットワーク（IDNet）を使用するかを選択します。


LabVIEWバージョン

このドロップダウンリストには、システムで検出されたIDFinderをサポートするLabVIEWのバージョンがすべて表示されます。ドライバのダウンロードに使用するLabVIEWのバージョンを選択します。ダウンロードされたドライバは、選択したLabVIEWバージョンの適切な場所に自動的にインストールされます。


次のメッセージ

>>ボタンをクリックすると、次のデバイス状態のメッセージが表示されます。現在表示されているメッセージが最後のメッセージの場合、このボタンは無効となります。


前のメッセージ

<<ボタンをクリックすると、前のデバイス状態のメッセージが表示されます。現在表示されているメッセージが最初のメッセージの場合、このボタンは無効となります。


IDFinder

LabVIEWでIDFinderを使用してドライバを検索、ダウンロードするには、このラジオボタンを選択します。このオプションを選択して参照ボタンをクリックすると、下にあるドロップダウンリストで選択したLabVIEWバージョン用のIDFinderが起動します。この方法では、デバイスのLabVIEWベースドライバだけをダウンロードできます。ダウンロードしたドライバは、ドロップダウンリストで選択したLabVIEWバージョンの適切な場所に自動的にインストールされます。


IDNet

計測器ドライバネットワーク（ni.com/idnet）のすべてのドライバを参照するには、このラジオボタンを選択します。このオプションを選択して参照ボタンをクリックすると、IDNetページが表示された状態でブラウザが開きます。この方法によって、LabVIEW、LabVIEW Real-Time、LabWindows/CVIなどの開発環境で使用するドライバを検索/ダウンロードできます。開発環境でドライバを使用するには、適切な場所に手動でインストールする必要があります。


ハードウェア構成

このボタンをクリックし、選択したデバイスのハードウェアの設定を修正します。


デバイスの状態

このボックスは、指定したデバイスの現在の状態を表示します。


トラブルシューティング

このボタンをクリックすると、デバイスの問題のトラブルシューティングに役立つヒントが得られます。


デバイスタイプ

このフィールドでは、メッセージベースのデバイスまたはレジスタベースのデバイス等、デバイスのタイプを表示します。


GPIBコントローラ番号

このデバイスまたはコントローラが配置されているGPIBシステムのインタフェース番号を指定します。


プライマリアドレス

GPIBデバイスのプライマリアドレスです。


セカンダリアドレス

GPIBデバイスのセカンダリアドレスです。


編集

編集ボタンをクリックして、このフレームの割り込みハンドラの割り当てを変更します。


LANデバイス名

デバイスのLANデバイス名を指定します。LANデバイス名は通常、「inst0」または「gpib0,1」です。


変更

変更ボタンをクリックして、製造元名のリストにある選択したエントリを変更します。


削除

削除ボタンをクリックして、製造元名のリストから選択したエントリを削除します。


製造元名

現在の製造元名のエントリをすべてリストします。


新規

新規ボタンをクリックして、エントリを製造元名のリストに追加します。


編集

このデバイスの信号マッピングを変更する場合、編集ボタンをクリックします。


信号のグループ

このデバイスのためにマッピングする単一のグループを選択します。


信号マッピング

このデバイスの現在の信号マッピングを表示します。


変更

変更ボタンをクリックして、モデル名のリストにある選択したエントリを変更します。


削除

削除ボタンをクリックして、モデル名のリストから選択したエントリを削除します。


モデル名

現在のモデル名のエントリをすべてリストします。


製造元名

デバイスの製造元名を指定します。


新規

新規ボタンをクリックして、エントリをモデル名のリストに追加します。


適用

VISAライブラリパスポートを追加、削除、有効化、または無効化した後、このボタンをクリックすると、変更がリストに適用されます。変更を適用後、<F5>キーを押すと、MAXが更新されます。


削除

VISAライブラリパスポートを選択してからこのボタンをクリックすると、選択したパスポートがリストから削除されます。


すべてのGPIB-VXIを自動検出

有効な場合、NI-VISAは各GPIBボードのデフォルトのGPIB-VXIアドレス（プライマリ1、セカンダリ0）で自動的にコントローラを検出します。無効な場合、NI-VISAは静的に追加されたGPIB-VXIコントローラのみを検出します。"*IDN?"をサポートしないアドレスを持つデバイスを使用する場合は、このオプションを無効にします。


自動ポーリング時間

このオプションを使用して、GPIBデバイスでSRQ自動ポーリングの間にVISAが待機する時間を設定します。許容値の範囲は、50～1000ミリ秒です。これは16ビットのGPIBドライバをNI-488.2互換ドライバとともに使用するときにのみ適用されます。ネイティブの32ビットGPIBドライバでは、この値は無視されます。


デバイス状態のテストにiblnを使用する

このオプションを使用して、ibln NI-488関数の呼び出しを有効または無効にします。iblnを呼び出して、非同期の読み取りおよび書き込みオペレーションとトリガ、ポーリング、およびオペレーションのクリアの実行中に、デバイスの状態をテストします。


失敗した場合、再試行

このオプションを使用して、GPIB-VXIコントローラが検出されない場合に自動リトライを有効または無効にします。


GPIB-VXIデバッグモードを有効化

このオプションは、デバッグモードでGPIB-VXI code instrumentをロードします。


最小非同期転送

許容範囲は16～65535です。パスポートがデフォルトで非同期転送をサポートする場合は、NI-VISAはこのオプションを無視します。他のパスポートでは、NI-VISAは転送カウントがこのしきい値を交差するとスレッドを作成します。


VISAがアクセス可能なPXI/PCIデバイスをすべて表示する

このオプションを使用して、VISAにアクセス可能なすべてのPXI/PCIデバイスを返すデバイスを検出します。デバイスのリストには、VISAがアクセスできるPXI/PCIデバイスに加えて、VISAに登録されているすべてのPXI/PCIデバイスが含まれます。


VISAで登録されたPXI/PCIデバイスのみを表示する

このオプションを使用して、VISA Driver Development Wizardで作成されたドライバ付きデバイスなど、VISAに登録されているPXI/PCIデバイスのみを返すデバイスを検索します。


PCIバス番号

PXI/PCIデバイスのバス番号を指定します。これは、デバイスが配置される物理PCIバスに対応しています。


PCIデバイス番号

物理PXI/PCIデバイス番号です。特定のシステム構成に基づいたオペレーティングシステムによって割り当てられた任意数です。


シャーシ

VXIデバイスが位置するシャーシを指定します。


PCIファンクション番号

論理デバイスの番号です。単一のPXI/PCIデバイスが複数の論理デバイスを持つ場合に使用されます。


ローカルバス(左)

このデバイスのローカルバスの左ラインに接続されたスロット番号または特殊機能です。


ローカルバス(右)

このデバイスのローカルバスの右ラインに接続されたスロット番号または特殊機能です。


製造元

PXI/PCI デバイスの製造元の名前とID番号番号です。


モデル

PXI/PCI デバイスのモデル名とデバイスID番号番号です。


スロット

PXIデバイスが挿入されたシャーシ内の物理的なスロット位置を表します。スロット番号が不明、またはPXIシャーシが識別されていない場合、この値は－1です。


スロットパス

このPXIデバイスのスロットパスを指定します。スロットパスは、PCIバス番号とは無関係に、PCIバスの階層を示します。PXIスロットパスは、PCIモジュールのファンクション番号とPCIデバイス番号、そしてモジュールからホストPCIブリッジ（バス0）へ経路指定する各親PCIブリッジを示す値のシーケンスです。


トリガバス

デバイスのトリガバス番号です。


リモートサーバホスト名

このフィールドには、アクセスしているVISAサーバでコンピュータのリモートアドレスが表示されます。


競合デバイスリスト

指定したデバイスとのリソースの競合についての情報を表示します。


リソース設定

デバイスのリソース設定を表示できるリソース設定ボックスです。


トラブルシューティング

トラブルシューティングボタンです。このボタンをクリックすると、デバイスとのリソースの競合についての情報が表示されます。


シャーシ

RIOデバイスが位置するシャーシを指定します。


製造元

RIOデバイスの製造元名と番号です。


モデル

RIOデバイスのモデル名と番号です。


PCIバス番号

RIOデバイスのPCIバス番号を指定します。


PCIデバイス番号

RIOデバイスのPCIデバイス番号を指定します。


PCIファンクション番号

RIOデバイスのPCIファンクション番号を示します。


シリアル番号

RIOデバイスのシリアル番号です。


スロット

RIOデバイスが挿入されたシャーシ内の物理的なスロット位置を表します。スロット番号が不明、またはシャーシが識別されていない場合、この値は－1です。


受信バッファ

受信FIFOバッファサイズを調整します。通常、サイズの大きなバッファは、多量のデータを受信するのに必要な割り込み数を減らすため、コンピュータのパフォーマンスを向上します。サイズの小さなバッファは、バッファのオーバーフローなどの問題を解決し、サイズの小さなデータを受信するためにシステムの待機時間を減らす上で役立ちます。


ボーレート

このポートを介して転送するデータのレートをビット/秒（bps）で設定します。通常、通信するコンピュータまたはデバイスによってサポートされている最大レートに設定されています。


データビット

転送および受信する各文字に使用するデータビット数を変更します。通信するコンピュータまたはデバイスには、ここで選択したものと同じ設定が含まれている必要があります。通常、文字は7または8データビット転送されます。


フロー制御

このポートのフローコントロールを指定します。指定する値についての判断が難しい場合は、ハードウェアのドキュメントを参照して、フロー制御をサポートするデバイスと使用する場合のみにフロー制御を有効にします。フロー制御を使用すると、バッファオーバーフローが減り、通信問題が減少します。


パリティ

選択したポートに使用するエラーチェックの種類を変更します。通信するコンピュータまたはデバイスには、ここで選択したものと同じ設定が含まれている必要があります。パリティを使用すると破損したデータを検出することができ、デバイスによってサポートされている場合は使用することが推奨されます。


ポートバインド

シリアル/パラレルデバイスのポートバインドを指定します。ドロップダウンリストを使用して、ASRLリソースにリンクする別のポートを選択してください。これによって、物理シリアルポートの論理ポート番号（COMx）は変更されません。このVISAリソースが結合されるCOMのみが変更されます。

メモ メモ 既存のNIポートに対するポートバインドの割り当てを変更するには、上級タブにあるCOMポート番号を使用します。NI製品以外のポートに対してこの変更を行うには、Windowsのデバイスマネージャを使用してください。


VISA

下の設定は現在VISAが使用しています。オプションを選んでこれらの設定を選択し、Windowsに適用します。


Windows

下の設定は現在Windowsが使用しています。オプションを選んでこれらの設定を選択し、VISAに適用します。


設定

このセクションでは、このポートの設定を制御します。


ストップビット

各文字の転送間隔を変更し、間隔はビット/秒で計測されます。


FIFOバッファを使用

ユニバーサル非同期レシーバ/トランスミッタ（UART）チップセットでは、デフォルトでFIFOバッファを使用します。取り込む情報をコンピュータへ転送するまで格納しておくバッファを含むシリアルポートでは、UARTは主要な構成要素です。これらのバッファでは、取り出す情報も計測器に転送されるまでは格納されています。通常、ポートやデバイスには、このチップセットが使用されています。

FIFOバッファは、シリアルポートのプロパティに16550UARTチップのサポートがあり、これによって高速モデムの性能が向上します。データ喪失、オーバランエラーなどの接続上の問題が発生した場合は、FIFOバッファの設定を小さくするか、そのオプションをクリアします。


トランシーバモード

RS-485ハードウェアは、ハードウェアトランシーバ制御の4つのモードをサポートします。ハードウェアトランシーバ制御を使用してトランスミッタおよびレシーバを有効または無効にすると、異なるバストポロジーで機能できるようになります。


実際のIPアドレス

デバイスの実際のIPアドレスを指定します。NI-VISAがデバイスと通信できない場合（たとえば、デバイスがオフライン、またはアドレスが正しく構成されていない場合）、このフィールドは不明です。


ローカルサブネットを参照

クリックしてローカルサブネット上のVXI-11リソース（TCP/IP LAN計測器）を検出します。


ファームウェアリビジョン

これは、指定したLANデバイスのファームウェアリビジョンです。


ホスト名またはIPアドレス

デバイスのホスト名またはIPアドレスを指定します。


LXIバージョン

指定したLANデバイスが準拠するLXI仕様のバージョンです。


製造元

これは、指定したLANデバイスの製造元です。


モデル名

これは、指定したLANデバイスのモデル名です。


ポート番号

デバイスのポート番号を指定します。


シリアル番号

これは、指定したLANデバイスのシリアル番号です。


認証

クリックしてNI-VISAがリソースにアクセスできるかどうかをテストします。デバイスの電源をオンにして、ネットワークへ接続する必要があります。


VXI-11リスト

ローカルサブネットで検出されたVXI-11リソースをリストに表示します。


リストを更新

クリックしてVXI-11リソースのリストを更新します。ローカルのサブネットを検索するには数秒かかります。


ステータス

この表示は、実行された最も最近の動作についてのステータス情報を示しています。


送信バッファ

送信FIFOバッファサイズを調整します。通常、サイズの大きなバッファは、多量のデータを送信するのに必要な割り込み数を減らすため、コンピュータのパフォーマンスを向上します。サイズの小さなバッファは、バッファのオーバーフローなどの問題を解決し、サイズの小さなデータを送信するためにシステムの待機時間を減らす上で役立ちます。


488.2との互換性

デバイスが488.2に完全準拠しているかを指定します。


インタフェース番号

特定のセッションで使用しているUSBインタフェース番号です。


製造元

USBデバイスの製造元名です。


モデル

USBデバイスのモデル名です。


シリアル番号

USBデバイスのシリアル番号です。


マイシステム上のVISAエイリアス

このデバイスまたはリソースにユーザ定義名を割り当てることを可能にします。ローカルシステムのアプリケーションでは、このエイリアスを使用することができます。エイリアスには、最大80文字まで含むことができ、英数字、'_'および'-'を使用することができます。


リモートシステム上のVISAエイリアス

リモートシステム上のこのデバイスまたはリソースにユーザ定義名を割り当てることを可能にします。リモートシステムをターゲットとしたアプリケーションでは、このエイリアスが使用できます。エイリアスには、最大80文字まで含むことができ、英数字、'_'および'-'を使用することができます。


VISAクライアント検出の有効化

ローカルリソースのみを指定しない検索文字列を使用する場合、これはviFindRsrcがこのリモートシステムでリソースを検索するかどうかを指定します。


VISAクライアントの接続ポート

VISAクライアントが接続するポート番号を指定します。この値は、サーバの監視設定の値と同じである必要があります。許容範囲は、0～65535です。


パスポートのリスト

システムのVISAライブラリパスポートのリストを表示します。パスポートにチェックマークを付けるとパスポートが有効になり、チェックマークを外すと無効になります。


アクセスのみ

この許可レベルを選択すると、VISAリソースに対するVISAセッションを開くためのアクセスがリモートクライアントに与えられます。ただし、クラインアントは、リソースのデフォルト設定を構成することはできません。


追加

このボタンをクリックして、新しいエントリをリモートアクセスリストに追加し、サーバ上でそのクライアントに許可を割り当てます。


全アクセス拒否

この許可レベルを選択すると、リモートクライアントによるVISAリソースへのアクセスが拒否されます。クライアントは、システムにあるリソースを検出したり、システムのリソースへのセッションを開くことができません。


VISAオプション→リモート

このボタンは、すべてのリモートシステムのローカルVISAオプションリストを表示します。次に、検索時にローカルVISAリモートクライアントが自動的にこのリモートシステムを検索するかどうかについて、有効または無効にすることができます。また、このシステムでサーバに接続しようとする場合、ローカルVISAリモートクライアントが使用するポートを変更することができます。


アクセスおよびリモート構成

この許可レベルを選択すると、リモートクライアントに対して、デフォルト設定を構成してリソースに対するVISAセッションを開く機能を含む、VISAリソースへのフルアクセスが与えられます。


アクセス権限

このボックスでは、選択したリモートアドレスの3つの許可レベルの中から1つを選びます。


リモートアドレス

このフィールドには、許可を編集しているリモートアドレスの現在選択されているものが表示されます。


リモートアクセスリスト

リモートアクセスリストは、このマシンでVISAリソースへアクセスするリモートマシンの許可レベルを示すリストを表示します。このリストに重複しているエントリがある場合、このリモートマシンは2番目のエントリの許可レベルになります。


削除

このボタンをクリックして、リモートアクセスリストから選択したリモートアドレスを削除します。リモートアドレスがリストの他の位置に表示された場合、リモートアドレスを削除してもクライアントのサーバへのアクセスを取り消すことができない場合があります。


名前を変更

このボタンをクリックして、エントリのリモートアドレスを変更します。


VISAサーバが監視するポート

NI-VISAサーバがリスンするポート番号を指定します。許容範囲は、1～65535です。


デフォルトを復元

NI-VISAサーバのポート番号がデフォルト値の3537に復帰します。


起動時にVISAサーバを起動

ログイン時に、NI-VISAサーバを自動的に実行できるようにします。ただし、OSサービスとしては実行できません。


今すぐサーバを起動

このボタンをクリックして、NI-VISAサーバを直ちに起動します。


今すぐサーバを停止

このボタンをクリックして、NI-VISAサーバを直ちに停止します。


リモートVISAシステム

使用可能なリモートシステムのリストを表示します。リモートシステムにチェックマークを付けると、VISAがリソース検索時にシステムを検索できるようになります。


製造元名

このVMEプロファイルに関連したデバイスの製造元名を表示します。


モデル名

このVMEプロファイルに関連したデバイスのモデル名を表示します。


名前

構成するVMEプロファイル名を表示します。


コピー

このボタンをクリックすると、VMEプロファイルダイアログボックスのコピーが表示されます。


削除

このボタンをクリックして、VMEプロファイルを削除します。


プロパティ

このボタンをクリックして、VMEプロファイルのプロパティダイアログボックスを表示します。


名前を変更

このボタンをクリックして、VMEプロファイルの名前を変更ダイアログボックスを表示します。これは、VMEのプロファイルの名前を変更するときに使用します。


追加

追加ボタンを使用して、新しいエントリまたは変更したエントリをリソースの設定ボックスでアルファベット順のエントリのリストに追加します。


削除

削除ボタンを使用して、指定したエントリをリソースの設定ボックスから削除します。


編集

編集ボタンを使用して、指定したエントリをリソースの設定ボックスで変更します。


シャーシ

指定したVMEデバイスのあるVXIまたはVMEシャーシの名前です。この情報は、親側エクステンダデバイス（外部CPUまたはマルチシャーシの場合）または組み込み式コントローラ（組み込みCPUの場合）のどちらかを含むフレームと同じである必要があります。


製造元

VMEデバイスの製造元名です。製造元名やモデル名は通常VXIデバイスのものに対応しませんが、NI-VXIソフトウェアでは、この情報で記号化された製造元名とモデル名をデバイスに関連付けます。


製造元名

このボタンをクリックすると、製造元の名前のリストが表示されます。指定したVMEデバイスの製造元名が見つからない場合、製造元ボックスに会社名を入力してください。


モデル

VMEデバイスの製造元のモデル名です。製造元名やモデル名は通常VXIデバイスのものに対応しませんが、NI-VXIソフトウェアでは、この情報で記号化された製造元名とモデル名をデバイスに関連付けます。


モデル名

このボタンをクリックすると、モデル名のリストが表示されます。指定したVMEデバイスのモデル名が見つからない場合、モデルボックスにモデル名を入力してください。


擬似論理アドレス

VMEデバイスの擬似論理アドレスです。ドロップダウンリストから、固有の論理アドレス（256～511）をVXIシステムに追加するVMEデバイスすべてに割り当てます。


スロット

指定したVMEデバイスのあるVXIまたはVMEシャーシのスロット番号です。


トラブルシューティング

このボタンをクリックすると、指定VMEデバイスのリソース競合についての情報が表示されます。


リソース設定

指定したVMEまたはVXIデバイス用リソースの設定リストです。


基本設定

VMEデバイスのハードウェアの設定を示すVMEプロファイルを識別します。


キャンセル

VXI-11リソースを選択せずにダイアログボックスを閉じます。


選択

ダイアログボックスを閉じてハイライトされたVXI-11リソースを選択します。


フレーム

VXIデバイスが位置するシャーシを指定します。


論理アドレス

VXIデバイスの論理アドレスです。システムにある各デバイスには、固有の論理アドレスが必要です。リソースマネージャのデバイスは、論理アドレス0である必要があります。


製造元

VXIデバイスの製造元名です。


モデル

VXIデバイスのモデル名です。


スロット

指定されたフレームでVXIデバイスが位置するスロット番号を指定します。


MXIバスを非表示にする

このシステムのMXIバスを非表示にします。


システム番号

VXIシステムのシステム番号を変更します。


リソースマネージャの遅延

リソースマネージャの遅延を変更します。


論理アドレス

優先順位の付いた信号論理アドレスを表示します。


論理アドレス

優先順位の付いた信号論理アドレスを設定します。


論理アドレス

このボタンをクリックすると、優先順位のついた信号論理アドレスを設定できます。


リソースの競合

指定したVXIデバイスとのリソースの競合についての情報を表示します。


リソース設定

VXIデバイスのリソース設定を表示、追加、または変更するリソースの設定ボックスです。


トラブルシューティング

このボタンをクリックすると、VXIデバイスのリソース競合についての情報が表示されます。


VMEデバイスのプロパティダイアログボックス

このダイアログボックスは、VMEデバイスについての情報を入力するときに使用します。入力すると、リソースマネージャはデバイスをVXIシステムに統合することが可能になります。


GPIB-VXIデバイスの基礎

使用方法

デバイスの名前を変更する

ツリー構図のGPIB-VXIデバイス名を右クリックし、名前を変更を選択します。

デバイスと通信する

ツリー構図のGPIB-VXデバイス名を右クリックし、VISAテストパネルを開くを選択します。これで、GPIB-VXIデバイスとの通信が可能です。

デバイスのプロパティを表示および編集する

タブをクリックしてプロパティを表示および編集します。

保留状態の変更を保存する

変更を保存するには、保存をクリックします。

保留状態の変更を破棄する

変更を破棄するには、復元をクリックします。復元はこの項目に対して少なくとも1つの変更が行われた場合に使用可能です。復元は変更を元に戻して、この項目を最後に保存した状態に復旧します。


GPIB-VXIフレームの基礎

使用方法

リソースと通信する

ツリー構図のGPIB-VXフレーム名を右クリックし、VISAテストパネルを開くを選択します。これで、GPIB-VXIフレームとの通信が可能です。


GPIB-VXIシステムの基礎

使用方法

GPIB-VXIコントローラを構成する

ツリー構図のGPIB-VXIシステムまたはGPIB-VXIコントローラを右クリックし、ハードウェアの構成を選択します。

保留状態の変更を保存する

このカテゴリですべての項目に対する変更を保存するには、Save All GPIB-VXIをクリックします。

GPIB-VXIデバイスのプロパティを表示および編集する

特定のデバイスのプロパティを表示および編集するには、中央ペーンのシステム表示で項目をダブルクリックするか、またはツリー構図で項目を選択します。


MXIバスの基礎

使用方法

リソースと通信する

ツリー構図のMXIバス名を右クリックし、VISAテストパネルを開くを選択します。これで、MXIバスとの通信が可能です。

MXIバスのプロパティを表示および編集する

リソース名をダブルクリックするか、またはリソース名を選択して、リソースに移動をクリックします。タブをクリックしてプロパティを表示および編集します。


PXIデバイスの基礎

使用方法

デバイスの名前を変更する

ツリー構図のPXIデバイス名を右クリックし、名前を変更を選択します。

デバイスと通信する

ツリー構図のPXIデバイス名を右クリックし、VISAテストパネルを開くを選択します。これで、PXIデバイスとの通信が可能です。

デバイスのプロパティを表示および編集する

タブをクリックしてプロパティを表示および編集します。

保留状態の変更を保存する

変更を保存するには、保存をクリックします。

保留状態の変更を破棄する

変更を破棄するには、復元をクリックします。復元はこの項目に対して少なくとも1つの変更が行われた場合に使用可能です。復元は変更を元に戻して、この項目を最後に保存した状態に復旧します。


PXIシステムとバスの基礎

使用方法

デバイスのプロパティを表示および編集する

特定のデバイスのプロパティを表示および編集するには、中央ペーンのシステム表示で項目をダブルクリックするか、またはツリー構図で項目を選択します。

保留状態の変更を保存する

このカテゴリですべての項目に対する変更を保存するには、PXIをすべて保存をクリックします。


リモートVISAシステムの基礎

使用方法

リモートVISAシステムを更新する

ツリー構図のリモートVISAシステム名を右クリックし、更新を選択します。リモートシステムを更新すると、リモートVISAシステムの使用可能なリソースがツリー構図のリモートシステムの下に表示されます。新しく検出されたリソースを表示するには、「+」をクリックしてリモートシステムを拡張してください。

メモ MAX新規作成Wizardを使用してリモートシステムを初めて検出した場合、MAXはリモートVISAシステムで使用可能なリモートリソースをすべて自動検出して表示します。更新を使用して、リモートシステムを初めて検出して以来リモートVISAシステムに追加した新しいVISAリソースをすべて検出してください。リモートVISAシステムをMAXで検出することの詳細については、以下の新しいリモートVISAシステムを作成するを参照してください。

ローカルエイリアスをリモートVISAシステムに割り当てる

ツリー構図のVISAリモートリソース名を右クリックし、名前を変更を選択します。

新しいリモートVISAシステムを作成する

ツリー構図のリモートシステムを右クリックし、新規作成を選択してください。リモートVISAシステムを選択し、ウィザードの手順に従って新しいリモートVISAシステムを追加します。

リモートVISAシステムを削除する

ツリー構図のリモートVISAシステム名を右クリックし、削除を選択します。リモートVISAシステムを削除しても、削除したシステムのリモートリソースに関連したローカルエイリアスは削除されません。ローカルエイリアスを削除するには、MAXのメニューからツール→NI-VISA→エイリアスエディタを選択します。削除するエイリアスを選択し、削除ボタンを押します。

リモートVISAシステムのプロパティを表示および編集する

特定のデバイスのプロパティを表示および編集するには、中央ペーンのシステム表示で項目をダブルクリックするか、またはツリー構図で項目を選択します。

保留状態の変更を保存する

このカテゴリですべての項目に対する変更を保存するには、リモートVISAをすべて保存をクリックします。


シリアルポートとパラレルポートの基礎

使用方法

デバイスの名前を変更する

ツリー構図のシリアルポート名またはパラレルポート名を右クリックして、名前を変更を選択します。

デバイスと通信する

ツリー構図のシリアルポート名またはパラレルポート名を右クリックして、VISAテストパネルを開くを選択します。

シリアルポートのプロパティやボーレートを表示および編集する

タブをクリックしてプロパティを表示および編集します。

シリアルリソースを削除する

ツリー構図のシリアルポート名を右クリックして、削除を選択します。シリアルリソースを静的に追加した場合のみ、それを削除できます。

保留状態の変更を保存する

変更を保存するには、保存をクリックします。

保留状態の変更を破棄する

変更を破棄するには、復元をクリックします。復元はこの項目に対して少なくとも1つの変更が行われた場合に使用可能です。復元は変更を元に戻して、この項目を最後に保存した状態に復旧します。


シリアルポートとパラレルポートの基礎

使用方法

シリアルポートのプロパティやボーレートを表示および編集する

システム表示（中央ペーン）でリソース名をダブルクリックするか、またはリソース名を選択して、リソースに移動をクリックします。あるいは、ツリー構図の項目を選択します。

保留状態の変更を保存する

このカテゴリですべての項目に対する変更を保存するには、シリアルをすべて保存をクリックします。

新規ポートを作成する

新規ポートを作成ボタンをクリックして、VISAが自動的に検出できなかったポートを追加します。

シリアルリソースを削除する

ツリー構図のシリアルポート名を右クリックして、削除を選択します。シリアルリソースを静的に追加した場合のみ、それを削除できます。


不明なVMEリソースの基礎

使用方法

VMEデバイスをシステムに追加する

ツリー構図の デバイスとインタフェースを右クリックして、 新規作成を選択してください。VME Deviceを選択してウィザードを完了します。


USBシステムの基礎

使用方法

デバイスのプロパティを表示および編集する

特定のデバイスのプロパティを表示および編集するには、中央ペーンのシステム表示で項目をダブルクリックするか、またはツリー構図で項目を選択します。

保留状態の変更を保存する

このカテゴリですべての項目に対する変更を保存するには、USBをすべて保存をクリックします。


VISAリソースの基礎

使用方法

リソース名を変更する

ツリー構図のVISAリソース名を右クリックし、名前の変更を選択します。

リソースと通信する

ツリー構図のVISAリソース名を右クリックし、VISAテストパネルを開くを選択します。これで、VISAリソースとの通信が可能です。

リソースのプロパティを表示および編集する

タブをクリックしてプロパティを表示および編集します。


VISA TCP/IPリソースの基礎

使用方法

デバイスの名前を変更する

ツリー構図のTCP/IPデバイス名を右クリックし、名前の変更を選択します。

デバイスと通信する

ツリー構図のTCP/IPデバイス名を右クリックし、VISAテストパネルを開くを選択します。これで、TCP/IPデバイスとの通信が可能です。

デバイスのプロパティを表示および編集する

タブをクリックしてプロパティを表示および編集します。

保留状態の変更を保存する

変更を保存するには、保存をクリックします。

保留状態の変更を破棄する

変更を破棄するには、復元をクリックします。

TCP/IPリソースを削除する

ツリー構図のリソース名を右クリックして、削除を選択します。


VISA TCP/IPリソースの基礎

使用方法

TCP/IPリソースのプロパティを表示および編集する

特定のデバイスのプロパティを表示および編集するには、中央ペーンのシステム表示で項目をダブルクリックするか、またはツリー構図で項目を選択します。

保留状態の変更を保存する

このカテゴリですべての項目に対する変更を保存するには、TCP/IPをすべて保存をクリックします。

新規リソースを作成する

新規TCP/IPリソースを作成ボタンをクリックしてリソースを追加すると、VISAでは既知デバイスのリストにそのリソースが含まれます。


VXIデバイスの基礎

使用方法

デバイスの名前を変更する

ツリー構図のVXIデバイス名を右クリックし、名前を変更を選択します。

デバイスと通信する

ツリー構図のVXIデバイス名を右クリックし、VISAテストパネルを開くを選択します。これで、VXIデバイスとの通信が可能です。

デバイスのプロパティを表示および編集する

リソース名をダブルクリックするか、またはリソース名を選択して、リソースに移動をクリックします。タブをクリックしてプロパティを表示および編集します。

保留状態の変更を保存する

変更を保存するには、保存をクリックします。

保留状態の変更を破棄する

変更を破棄するには、復元をクリックします。復元はこの項目に対して少なくとも1つの変更が行われた場合に使用可能です。復元は変更を元に戻して、この項目を最後に保存した状態に復旧します。


VXIフレームの基礎

使用方法

リソースと通信する

ツリー構図のVXIフレーム名を右クリックし、VISAテストパネルを開くを選択します。これで、VXIリソースとの通信が可能です。

VXIフレームのプロパティを表示および編集する

リソース名をダブルクリックするか、またはリソース名を選択して、リソースに移動をクリックします。タブをクリックしてプロパティを表示および編集します。


VXIシステムの基礎

使用方法

VMEデバイスをシステムに追加する

ツリー構図の デバイスとインタフェースを右クリックして、 新規作成を選択してください。VME Deviceを選択してウィザードを完了します。

リソースマネージャを実行する

VXI計測器を構成するときに、またはVXIシャーシをパワーサイクルするときに必ずResmanを実行するには、ツリー構図のVXI System <X>を右クリックし、VXIリソースマネージャを実行を選択します。

VXIコントローラを構成する

ツリー構図のVXIコントローラ名を右クリックし、ハードウェアを構成を選択します。

VMEリソースを削除する

ツリー構図のVMEデバイス名を右クリックして、削除を選択します。VMEデバイスを取り外したら、VXIリソースマネージャを実行をクリックし、Resmanを実行します。

VXIデバイスのプロパティを表示および編集する

特定のデバイスのプロパティを表示および編集するには、中央ペーンのシステム表示で項目をダブルクリックするか、またはツリー構図で項目を選択します。

保留状態の変更を保存する

このカテゴリですべての項目に対する変更を保存するには、VXIをすべて保存をクリックします。


エイリアス

このページは、システムにあるデバイスのVISAのエイリアスを作成、変更、削除するときに使用します。エイリアスには、デバイスおよびリソースのユーザ定義名で、最大80文字まで含むことができ、英数字、'_'および'-'を使用することができます。

新しいエイリアスをデバイスに割り当てるには、デバイス名を選択して、エイリアスを編集をクリックします。既存のエイリアスを変更するには、デバイス名を選択してエイリアスを追加をクリックし、エイリアスを追加ダイアログボックスを表示します。エイリアスをすべて削除するには、すべてのエイリアスを消去をクリックします。終了したら、保存をクリックして、変更を保存します。


競合マネージャ

これは高度な設定ページです。このページでの設定は、すべての64ビットVISAアプリケーションおよび32ビットVISA COMアプリケーションに対して使用されます。

競合マネージャでは、システムにインストールされているVISAの有効/無効の切り替え、有効VISAの推奨VISAとしての設定、特定のインタフェースタイプのリソースへの有効VISAの割り当てを行うことができます。

また、競合の有無に関係なく競合マネージャにインタフェースタイプの設定を常に保存するよう設定できます（推奨）。このように設定しない場合は、競合が発生した場合にのみインタフェースタイプの設定が保存されます。インタフェースタイプの競合は、そのタイプのリソースを開けるVISAが複数インストールされている場合に発生します。


パスポート

このページは、NI-VISAが使用するパスポートを構成するときに使います。

リストにあるパスポートにチェックマークを付けるとパスポートが有効に、外すと無効になります。

終了したら、保存をクリックして、変更を保存します。


リモート

このページは、リソースを検索する際にVISAが探すシステムを設定するときに使います。

検索のためにリモートシステムを有効にするには、リモートシステムのアドレスのそばのボックスにチェックマークを付けます。リモートシステムのVISAサーバが通信にカスタムポート番号を設定している場合、そのシステムを選択してポートの変更VIをクリックします。

リストにないリモートシステムを追加するには、リモートシステムを右クリックして新規作成...を選択します。ダイアログの指示に従って、新しいリモートVISAシステムを作成します。

終了したら、保存をクリックして、変更を保存します。


セキュリティ

このページは、このシステムでVISAリソースへのアクセス権があるクライアントを指定します。

有効なアドレス値

有効なネットワークアドレスには、文字（a-z、A-Z）、数字（0-9）、ハイフン（-）、下線（_）、ピリオド（.）が含まれていますが、スペースは含まれません。IPアドレス（xxx.xxx.xxx.xxx）またはそれらと同等のDNS名（machine.domain.com）も有効なリモートアドレスです。他の有効なエントリは、すべてのネットワークアドレスには*、サブネットにはxxx.xxx.xxx.*、xxx.xxx.*、ドメインには*.com、または*.somedomain.comが挙げられます。

リスト順

許可の順番について考慮してください。VISAサーバは許可を通じて、許可のリストの上から順に一致するものを探します。VISAサーバはリモートシステムがシステムのリソースへのアクセスを許可するかしないかを判断する際に、リモートアドレスと一致する、リモートアクセスリストにある最後のエントリを使用します。一致したものが見つからなかった場合は、デフォルトによりリモートアドレスはアクセスが拒否されます。

新しいリモート許可を追加するには、追加または<新しいリモート許可の追加はここをクリック>をクリックします。新しい許可を入力して、そのリモートアドレスからのアクセスを許可するかどうかをチェックします。許可を変更するには、リモートアドレスを選択して名前の変更をクリックします。許可を削除するには、リモートアドレスを選択して削除をクリックします。終了したら、保存をクリックして、変更を保存します。

サーバが実行中の場合、新しい許可はその変更を保存した直後に有効になります。


VISAサーバ

このページは、VISAサーバが通信に使用するポート番号や起動時にVISAサーバを実行するかどうかについて構成するのに使用します。

ポート番号を変更するには、VISAサーバが通信に使用するポート番号をタイプ入力します。デフォルトのポート番号を復元するには、デフォルトを復元クリックします。起動時にVISAサーバを実行するには、起動時にVISAサーバを実行にチェックマークをつけます。VISAサーバがインストールされているリモートシステムで起動時にVISAサーバが自動的に実行されます。保存をクリックして変更を保存します。サーバが実行中の場合は、ポート番号に加えた変更はすべて、VISAサーバの再起動が必要です。リモートマシンでVISAサーバを再起動するには、そのリモートマシンを再起動します。ローカルサーバを構成する際は、サーバを開始をクリックしてVISAサーバを起動することができます。


VISAの設定

このページは、NI-VISAを自動的に動作させるオプションを設定するときに使用します。各オプションを右クリックして、そのオプションについてのヘルプを表示します。保存をクリックして変更を保存します。