MAX-Hilfe zu Systemen im Netzwerk

Juli 2021, 370640V-0113

Hinweis Vor der Konfiguration von Geräten oder Systemen in Netzwerken müssen das LabVIEW Real-Time Module und der MAX auf dem Host-Computer installiert werden. Weitere Hinweise zur Installation des LabVIEW Real-Time Modules finden Sie im Kapitel 2, Installation, der LabVIEW Real-Time Module Release and Upgrade Notes.

Für Kommentare und Anregungen zu unserer Dokumentation besuchen Sie bitte unsere Website.

© 2003–2021 National Instruments Corporation. Alle Rechte vorbehalten.


Herstellen einer Verbindung zu LabVIEW-Real-Time-Systemen

Zum Herstellen einer Verbindung mit einem LabVIEW-Real-Time-System und zur Erkennung des Systems sind folgende Schritte erforderlich:

  1. Verbinden mit einem Host-Computer
    Das Real-Time-System muss sich im selben Subnetz wie der Host-Computer befinden, von dem aus das System konfiguriert wird. Wie eine Verbindung mit dem System hergestellt wird, ist im Abschnitt Herstellen von Netzwerk- und Peer-to-Peer-Verbindungen beschrieben.
  2. Erkennen des Netzwerksystems
    Damit Sie das Zielsystem konfigurieren können, muss es zuerst in MAX erkannt werden. Informationen zum Erkennen von Netzwerksystemen finden Sie unter Erkennen von Netzwerksystemen im MAX.


Erstellen eines Netzwerksystems

Sie müssen möglicherweise ein Netzwerksystem erstellen, wenn Sie auf ein System zugreifen möchten, das sich nicht in Ihrem lokalen Subnetz befindet oder wenn MAX durch eine Firewall daran gehindert wird, Software von NI zu erkennen.

Gehen Sie zum Erstellen eines neuen Netzwerksystems wie folgt vor:

  1. Klicken Sie mit der rechten Maustaste auf Netzwerkumgebung und wählen Sie im Kontextmenü die Option Neu aus.
  2. Wählen Sie im Dialogfeld Neu erstellen den Punkt System im Netzwerk aus und klicken Sie auf Weiter.
  3. Geben Sie die IP-Adresse des Systems in das Feld IP-Adresse ein und klicken Sie auf Beenden.

Das System wird dann im MAX unter "Netzwerkumgebung" angezeigt.


Erkennen von Netzwerksystemen im MAX

Erweitern Sie in der Übersicht des Measurement & Automation Explorers (MAX) die Kategorie Netzwerkumgebung. Bereits erkannte Systeme werden sofort unter der Kategorie "Netzwerkumgebung" aufgeführt. Darüber hinaus sucht MAX nach neuen Systemen im lokalen Subnetz. Diese werden nach einer kurzen Verzögerung in die Liste aufgenommen. Wenn Systeme erkannt wurden, werden diese unter Netzwerkumgebung aufgeführt. Es wird bei jedem Start des MAX und bei jedem Klick auf die Kategorie Netzwerkumgebung nach neuen Netzwerksystemen gesucht. Daneben kann auch über die Option Ansicht»Aktualisieren (F5) nach neu angeschlossenen Netzwerkgeräten gesucht werden.

Hinweis Als Standardbezeichnung des Systems wird die IP-Adresse verwendet. Wenn mehrere Systeme unter Netzwerkumgebung zur Auswahl stehen, klicken Sie die IP-Adresse des zu konfigurierenden Systems an. Auf der Registerkarte Systemeinstellungen können Sie Ihrem System – sofern möglich – einen Host-Namen zuweisen. Dieser wird dann in der Übersicht angezeigt. (Mit "Host-Name" ist nicht in jedem Fall der DNS-Host-Name gemeint. Lesen Sie hierzu auch den Abschnitt Konfigurieren der Systemeinstellungen). Der Systemstatus kann Nicht konfiguriert lauten, wenn Ihr System die automatische IP-Zuweisung nicht unterstützt und noch keine IP-Adresse vergeben wurde.

Weitere Hinweise dazu erhalten Sie im Abschnitt Konfigurieren der Netzwerkeinstellungen.


Konfigurieren von Real-Time-Systemen in einem Netzwerk

Nachfolgend wird die Konfiguration eines Echtzeitsystems (Real-Time-Systems) im Netzwerk für das LabVIEW Real-Time Module erläutert. Eine detailliertere Beschreibung dieser Schritte finden Sie in der Anleitung zur Konfiguration von Real-Time-Systemen in einem Netzwerk.

  1. Starten des Systems in LabVIEW Real-Time
    Vor Beginn der Konfiguration eines Netzwerksystems muss sichergestellt werden, dass dieses im LabVIEW-Echtzeitbetriebssystem läuft. Nähere Einzelheiten dazu erfahren Sie im Abschnitt Starten des Systems in LabVIEW Real-Time.
  2. Konfigurieren der Netzwerkeinstellungen
    Das System muss mit einer IP-Adresse versehen werden, bevor weitere Einstellungen vorgenommen werden können. Falls das Netzwerksystem nicht bereits zum automatischen Ermitteln einer IP-Adresse eingestellt ist, können Sie auf der Registerkarte "Netzwerkeinstellungen" eine IP-Adresse manuell eingeben oder automatisch ermitteln. Für weitere Hinweise zu Netzwerkeinstellungen lesen Sie bitte den Abschnitt Konfigurieren der Netzwerkeinstellungen.
    Hinweis Wie eine Verbindung zum Host-Computer hergestellt wird, erfahren Sie im Abschnitt Herstellen einer Verbindung zu LabVIEW-Real-Time-Systemen.

  3. Installieren der Software
    Installieren Sie nun auf Ihrer Zielumgebung alle notwendigen Programme oder nehmen Sie mit dem Software-Assistenten für LabVIEW Real-Time Programmaktualisierungen vor. Zum Starten des Software-Assistenten erweitern Sie das System unter Netzwerkumgebung. Klicken Sie dann auf die Unterkategorie Software und in der Symbolleiste auf das Symbol Software hinzufügen/entfernen. Weitere Informationen zum Installieren von Software auf einem Netzwerksystem erhalten Sie unter Umgang mit dem Software-Assistenten für LabVIEW Real-Time.
  4. Konfigurieren des Datenaustauschs
    Bevor I/O-Hardware von NI von einer LabVIEW-Real-Time-Anwendung aus aufgerufen werden kann, muss diese konfiguriert werden. Die genaue Vorgehensweise wird unter Konfigurieren der Geräte näher erläutert.
  5. Konfigurieren der Systemeinstellungen
    Wie der Name und die Sprache für das Real-Time-System festgelegt sowie Kommentare hinzugefügt werden, ist im Abschnitt Konfigurieren der Systemeinstellungen beschrieben.

  6. Konfigurieren der Zeiteinstellungen
    Wie die Zeitzone und Sommer-/Winterzeiteinstellungen für das Real-Time-System festgelegt werden, ist im Abschnitt Konfigurieren der Zeiteinstellungen beschrieben. Wenn das Gerät Zeitsynchronisation unterstützt, können Sie auf der Registerkarte "Zeiteinstellungen" Einstellungen zur Zeitsynchronisation festlegen.
  7. Dateitransfer
    Weitere Informationen zum Dateiaustausch mit Ihrem Netzwerksystem finden Sie unter Dateitransfer.

    (NI Linux Real-Time) Informationen zum Dateiaustausch mit Hilfe eines WebDAV-Servers finden Sie auf ni.com/info nach Eingabe des Infocodes RTFileTransfer.

Nach Ausführung dieser Schritte ist Ihr System für den Zugriff über das LabVIEW Real-Time Module bereit.


Starten des Systems LabVIEW Real-Time

Die Art des Systemstarts in LabVIEW Real-Time hängt vom Systemtyp und vom ausgewählten Startmodus ab.

Startmodi

Für den Systemstart in LabVIEW Real-Time stehen nachfolgende Modi zur Verfügung:

Startmodi | Beschreibung
Normales Hochfahren | Wenn das Real-Time-System in diesem Modus hochgefahren wird, ist es komplett einsatzbereit. Dies ist der voreingestellte Startmodus.
IP-Reset | Bei einem Systemstart in diesem Modus werden alle IP-Einstellungen und das Systempasswort gelöscht. Die Option dient dazu, das Passwort oder falsche manuell vorgenommene Einstellungen zurückzusetzen.
Deaktivieren der Startanwendung | Bei einem Systemstart in diesem Modus wird die automatische Ausführung von LabVIEW-Anwendungen direkt nach dem Hochfahren des Real-Time-Systems unterdrückt. Das kann von Nutzen sein, wenn eine nach dem Hochfahren startende Anwendung so viel CPU-Leistung beansprucht, dass keine Verbindung zum System mehr herstellbar ist.
Sicherer Modus | Beim Hochfahren in diesem Modus werden die normalen Startroutinen des Real-Time-Systems umgangen. Stattdessen werden nur die Dienste gestartet, die zum Bearbeiten der Systemeinstellungen und zur Installation von Software von Bedeutung sind. Der sichere Startmodus hat den Vorteil, dass fehlerhafte Software umgangen werden kann. Die Software kann anschließend mit Hilfe des MAX neu installiert werden.
Deinstallationsmodus | Bei einem Systemstart in diesem Modus werden alle zu LabVIEW Real-Time gehörigen Komponenten entfernt. Der Deinstallationsmodus dient dazu, fehlerhafte Software vom Real-Time-System zu entfernen. Die Software kann anschließend mit Hilfe des MAX neu installiert werden. Dieser Modus steht nur bei Real-Time-Systemen mit Diskettenlaufwerk zur Verfügung.

Systemtypen

Wie Ihr Real-Time-System in LabVIEW Real-Time gestartet wird, richtet sich nach der Art Ihres Real-Time-Systems.

Gängige Methoden für den Systemstart in LabVIEW Real-Time sind die Verwendung von Diskettenlaufwerken, USB-Laufwerken, DIP-Schaltern und das Festlegen des sicheren Modus als Startmodus im BIOS. Weitere Informationen zum Systemstart in LabVIEW Real-Time finden Sie in der Dokumentation zur Hardware. Im Abschnitt Desktop-PC-Utility für USB-Laufwerke finden Sie weitere Informationen zum Erstellen von USB-Laufwerken (sofern für Ihr System zutreffend).


Überwachen und Konfigurieren eines Geräts im Netzwerk mit Hilfe eines Webbrowsers

Mit dem Utility "NI-Webkonfiguration und Überwachung" können Sie Netzwerkgeräte konfigurieren und überwachen. Ermitteln Sie mit Hilfe des Software-Assistenten für LabVIEW Real-Time im NI Measurement & Automation Explorer (MAX), ob "NI-Webkonfiguration und Überwachung" auf dem Real-Time-System installiert ist. Wenn nicht, müssen Sie es mit dem Software-Assistenten für LabVIEW Real-Time installieren.

Zugriff auf die Konfigurationsseite

Auf folgende Weise können Sie ein Netzwerkgerät mittels eines Webbrowsers überwachen und konfigurieren:

  • Klicken Sie mit der rechten Maustaste im Projekt-Explorer in LabVIEW auf das Gerät und wählen Sie Utilities»View in Browser aus dem Kontextmenü.
  • Geben Sie die URL http://[IP-Adresse des Netzwerkgeräts] in einen Webbrowser ein.

Ausführen von gängigen Tasks auf einem Gerät im Netzwerk

In der folgenden Liste werden die Aufgaben beschrieben, die Sie mit NI-Webkonfiguration und Überwachung ausführen können.

  • Anzeigen von Systemeinstellungen
  • Anzeigen von Netzwerkeinstellungen
  • Anzeigen von SytstemLink-Einstellungen
  • Anzeigen und Konfigurieren von Sicherheitseinstellungen für Benutzer, Gruppen und Berechtigungen
  • Anzeigen und Konfigurieren von Webservereinstellungen
  • Anzeigen und Konfigurieren von Einstellungen und Aufträgen in LabVIEW FPGA Compile Farm


Systemzustände

Der Systemstatus von Netzwerksystemen kann folgendermaßen lauten:

Zustand | Beschreibung
Nicht konfiguriert | Die IP-Adresse lautet 0.0.0.0. Es muss eine gültige IP-Adresse ermittelt werden.
Nicht verbunden | MAX kann das System nicht im Netzwerk finden.
Nicht verbunden - Neu starten | Das System wird neu gestartet.
Initialisierung | Das System fährt gerade hoch.
Inkonsistente IP-Einstellungen | Das System ist verbunden, aber seine IP-Adresse gestattet möglicherweise keine vollständige Konfiguration. Korrigieren Sie die IP-Einstellungen.
Verbunden - In Betrieb | Das System wurde gestartet und es funktioniert ordnungsgemäß.
Verbunden - Installationsmodus | Das System ist im Installationsmodus verbunden. Installationsmodus bedeutet, dass sich das System in einem sicheren Modus befindet und installierte Software mit Hilfe des MAX geändert werden kann.
Verbunden - Sicherer Modus (keine Software installiert) | Das System ist im sicheren Modus verbunden, hat aber keine installierte Software. Wenn das System gestartet wird und die erforderlichen Systemdateien für LabVIEW Real-Time nicht findet, wird die Nachricht Keine installierte Software angezeigt.
Verbunden - Sicherer Modus (Benutzer) | Der Zustand "Verbunden - Sicherer Modus (Benutzer)" wird entweder über einen Schalter am Zielsystem, durch Starten mit Hilfe einer Diskette für den sicheren Modus oder Verwendung des sicheren Modus des Desktop-PC-Utilitys für USB-Laufwerke aktiviert.
Verbunden - Sicherer Modus (Software-Update erforderlich) | Das System unterstützt die installierte Version der Software nicht. Für diesen Modus ist eine neuere Version von LabVIEW Real-Time und/oder der dazugehörigen Komponenten erforderlich. Der Bildschirm des Zielsystems zeigt die älteste von der Hardware unterstützte Version von LabVIEW Real-Time an.
Verbunden - Sicherer Modus (Softwarefehler) | Dieser Modus wird nach dreimaligem unerwarteten Neustart des Ziel-Controllers, aufgrund von abstürzenden Startanwendungen, Treibern oder anderen Problemen, die einen unsicheren Neustart verursachen, aktiviert.
Verbunden - Sicherer Modus (unsachgemäße Installation) | Dieser Modus tritt auf, wenn der Controller des Systems beim Start bestimmte Fehler während des Ladens von Kerndateien des Betriebssystems verursacht. Der Modus ähnelt dem Modus "Keine installierte Software", allerdings existieren die Dateien und verursachen beim Laden schwerwiegende Fehler. Die Meldung kann auch angezeigt werden, wenn in der Datei ni-rt.ini wichtige Token fehlen, die auf Startinformationen und/oder Kerndateien des Betriebssystems verweisen.
Hinweis Hinweise Beim Hochfahren im sicheren Modus werden die normalen Startroutinen des Real-Time-Systems umgangen. Stattdessen werden nur die Dienste gestartet, die zum Ändern der Systemeinstellungen und zum Installieren Software von Bedeutung sind. Der sichere Startmodus hat den Vorteil, dass fehlerhafte Software umgangen werden kann. Die Software kann anschließend mit Hilfe des MAX neu installiert werden. Weitere Informationen zum Starten im sicheren Modus finden Sie unter Starten des Systems in LabVIEW Real-Time.


Dateitransfer

Um Dateien vom Netzwerk herunterzuladen oder auf dieses zu übertragen, sind folgende Schritte erforderlich:

  1. Klicken Sie unter "Netzwerkumgebung" mit der rechten Maustaste auf das gewünschte System.
  2. Wählen Sie die Option Dateitransfer zum Start des entsprechenden Utilitys.
  3. Geben Sie Ihren Administratornamen und Ihr Passwort unter Benutzername und Passwort ein oder aktivieren Sie Anonyme Anmeldung, wenn Ihr System nicht durch ein Passwort geschützt ist.
  4. Klicken Sie auf OK.
Hinweis Hinweis Diese Option steht nicht auf jedem System zur Verfügung.

(NI Linux Real-Time) Weitere Informationen zum Dateiaustausch mit Hilfe eines WebDAV-Servers finden Sie auf ni.com/info nach Eingabe des Infocodes RTFileTransfer.


Hinzufügen oder Entfernen von Software auf veralteten Systemen

Wenn Sie einem System im Netzwerk eine IP-Adresse zugewiesen haben, können Sie das LabVIEW Real-Time Module installieren.

Sollte LabVIEW Real-Time bereits vorhanden sein, müssen unter Umständen zusätzliche Treiber geladen werden. Auf der Registerkarte "Systemeinstellungen" sollte in diesem Fall für das Real-Time-System der Status Verbunden - In Betrieb angezeigt werden.

Wenn auf der Zielumgebung Windows installiert ist, müssen Sie das Betriebssystem auf LabVIEW Real-Time umstellen, bevor weitere Treibersoftware installiert werden kann. Zur Installation oder zum Upgrade von LabVIEW Real-Time oder von Treibern gibt es den Software-Assistenten für LabVIEW Real-Time.

Zum Starten des Software-Assistenten für LabVIEW Real-Time sind folgende Schritte erforderlich:

  1. Erweitern Sie die Kategorie "Netzwerkumgebung" und das RT-Zielsystem.
  2. Wählen Sie die Kategorie "Software" aus. Klicken Sie in der Symbolleiste auf das Symbol Software hinzufügen/entfernen. Wenn es diese Kategorie für das System nicht gibt, bedeutet das, dass Ihr System LabVIEW Real-Time nicht unterstützt.
  3. Der Software-Assistent für LabVIEW Real-Time dient zum Hinzufügen, Entfernen oder Aktualisieren von Software auf Real-Time-Systemen.


Formatieren eines Zielsystems im Netzwerk

Manche Festplatten auf Zielsystemen können über MAX formatiert werden. Wenn Ihr Zielsystem die Formatierung via MAX unterstützt, können Sie die Option Festplatte formatieren mit einem Klick der rechten Maustaste aus dem Kontextmenü auswählen. Wird diese Option nicht angezeigt, wird diese Funktion nicht vom Zielsystem unterstützt und Sie müssen ein USB-Laufwerk-Utility für Desktop-PCs verwenden.

Führen Sie zum Formatieren des Laufwerks folgende Schritte aus:

  1. Starten Sie das Zielsystem im sicheren Modus. Weitere Informationen zum Starten im sicheren Modus finden Sie in der Dokumentation Ihres Zielsystems.
  2. Klicken Sie mit der rechten Maustaste auf das Zielsystem und wählen Sie Laufwerk formatieren aus dem Kontextmenü aus.
  3. Wenn das Zielsystem mehrere Dateisysteme unterstützt, wählen Sie das gewünschte Dateisystem aus. "Reliance" ist das bevorzugte Dateisystem für Echtzeitsysteme, da es vor Datenverlust aufgrund von Beschädigung des Dateisystems schützt. (RT Linux) Auf Real-Time-Linux-Zielsystemen steht nur das Dateisystem UBIFS zur Verfügung.
    Hinweis Hinweis Wenn Sie das Zielsystem mit Hilfe des Dateisystems "Reliance" formatieren, kann von einer Partition des Laufwerks nur Windows oder LabVIEW Real-Time gestartet werden. Für jedes Betriebssystem muss eine eigene Partition erstellt werden.
  4. Bestätigen Sie die Formatierung des Zielsystems.
    Achtung Achtung Durch die Formatierung des Zielsystems werden alle Daten auf der LabVIEW-Real-Time-Partition des Laufwerks gelöscht. Bei Dual-Boot-Controllern wird nur die LabVIEW-Real-Time-Partition formatiert.

Nach dem Formatieren wird das Zielsystem neu gestartet.

Hinweis Hinweis Bei Problemen mit der Formatierung besuchen Sie unsere Website ni.com/info und geben Sie targetdiskformat ein.


Installieren einer benutzerdefinierten Auswahl von Softwarekomponenten

Zum Herunterladen von benutzerdefinierter Software mit Hilfe des Software-Assistenten für LabVIEW Real-Time gehen Sie wie folgt vor:

  1. Wählen Sie einen der folgenden Arbeitsschritte aus:
    • Anzeige der auf dem Zielsystem installierten Software
      Hinweis Programme, die von MAX 3.0.x oder Vorgängerversionen installiert wurden, werden nicht angezeigt, sind aber weiterhin funktionstüchtig. Damit die Software in dieser Kategorie angezeigt wird, muss sie neu installiert werden.
    • Anzeige der zur Installation auf dem Zielsystem verfügbaren Software
    • Aktualisierung des Real-Time-BIOS auf dem Zielsystem über BIOS aktualisieren, wenn eine neue Version verfügbar ist. Durch die Aktualisierung des Real-Time-BIOS wird die bereits vorhandene Software gelöscht.
    • Ändern der Software auf dem Zielsystem. Klicken Sie dazu auf das Symbol der Software und wählen Sie die gewünschte Option aus. Wenn ein Programm aus der Liste ausgewählt wird, ändert sich sein Symbol. Es kann zwischen folgenden Optionen ausgewählt werden:

      Installieren—Das ausgewählte Programm wird auf dem System installiert.

      Installiert lassen—Das ausgewählte Programm verbleibt auf dem System im Netzwerk.

      Neue Version vorhanden—Das ausgewählte Programm verbleibt auf dem System, aber es gibt eine neuere Version davon.

      Neu installieren—Das ausgewählte Programm wird auf dem System neu installiert. Diese Option gilt auch für den Fall, dass die installierte Version geändert werden soll.

      Deinstallieren—Das ausgewählte Programm wird vom System entfernt.

      Nicht installieren—Das ausgewählte Programm wird nicht auf dem System installiert.

      Alle Programme—Alle Programme werden zur Installation oder Deinstallation ausgewählt.

      Bei Auswahl einer bestimmten Komponente werden dazu auf der rechten Seite nähere Einzelheiten angezeigt, z. B.:

      • eine Beschreibung.
      • die auf dem Zielsystem installierte Version.
      • die auf dem lokalen Host vorhandenen Versionen. Es ist immer die neueste Version markiert. Über das Auswahlmenü können aber auch ältere Versionen installiert werden. Wenn das Programm zu einem anderen Programm gehört, wird die Version möglicherweise nicht in der Übersicht oder dem Versionsmenü angezeigt.
      • ein Symbol, das angibt, ob das Programm bereits installiert ist oder nicht, zur (Neu-)Installation oder Deinstallation ausgewählt wurde oder ob es auf dem Host eine neuere Version gibt.
      Hinweise
      • Wenn die ausgewählte Option zu einem Konflikt mit abhängigen Programmkomponenten führt, wird das Fenster Abhängige Komponenten anzeigen angezeigt, so dass Sie das Problem lösen können.
      • Auf manchen Systemen, z. B. dem Controller der Serie PXI-814X, muss LabVIEW Real-Time installiert sein, um andere Treiber installieren zu können.
  2. Klicken Sie auf Weiter und bestätigen Sie Ihre Auswahl im nächsten Dialogfeld. Es werden alle beabsichtigten Änderungen am Zielsystem aufgelistet.
  3. Wenn Sie mit den Änderungen einverstanden sind, klicken Sie auf Weiter. Das Zielsystem wird bei Bedarf im Installationsmodus neu gestartet und beginnt dann die Installation. In der Verlaufsanzeige wird angezeigt, welche Datei gerade entfernt oder installiert wird. Wenn der Vorgang beendet ist, startet das Installationsprogramm das System neu.
  4. Klicken Sie zum Schließen des Assistenten auf Beenden.

Die ausgewählte Software wird auf dem Zielsystem installiert und kann verwendet werden.


Installieren einer Startanwendung

Für Anwendungen, die mit Hilfe des LabVIEW Real-Time Modules erzeugt wurden, kann eine CDF-Datei (Component Definition File) erzeugt werden. In einer CDF-Datei werden abhängige Komponenten Ihrer Startanwendung aufgeführt. Zum Erstellen einer CDF-Datei aktivieren Sie auf der Seite Component Definition des Dialogfelds Real-Time Application Properties die Option Create a component definition file (.cdf) and specify dependencies. Weitere Informationen zum Erstellen einer CDF-Datei für Ihre Anwendung finden Sie in der LabVIEW-Hilfe.

Hinweis Hinweis In LabVIEW-Versionen ab 2011 können Sie mit Hilfe des VIs "Startanwendung installieren" programmatisch eine Startanwendung auf das Zielsystem übertragen.

Führen Sie zum Installieren einer Startanwendung auf einem Zielsystem mit Hilfe des Software-Assistenten für LabVIEW Real-Time folgende Schritte aus:

  1. Erweitern Sie die Kategorie Netzwerkumgebung und klicken Sie den Namen des Real-Time-Systems doppelt an.
  2. Wählen Sie Software. Klicken Sie in der Symbolleiste auf das Symbol Software hinzufügen/entfernen. Im Software-Assistenten für LabVIEW Real-Time wird die Seite Startup Application angezeigt. Zur Anzeige dieser Seite muss eine CDF-Datei erstellt werden. Informationen dazu finden Sie im Abschnitt Deploying from outside of the LabVIEW Development Environment des Themas Building and Deploying a Stand-Alone Real-Time Application der LabVIEW-Hilfe.
  3. Klicken Sie auf Install the following startup application und wählen Sie dann aus der Liste die Startanwendung aus, die Sie installieren möchten. In der Liste werden alle Startanwendungen angezeigt, die auf dem Host-Rechner zur Verfügung stehen.

    Wenn die gewünschte Startanwendung nicht aufgelistet wird, fehlt möglicherweise die CDF-Datei oder die Anwendung wurde für ein anderes Zielsystem erstellt.
  4. Wählen Sie unter Auf dem Host verfügbare Versionen die zu installierende Version aus.
  5. Klicken Sie auf Weiter.
  6. Überprüfen Sie die Auswahl auf der Bestätigungsseite. Es werden alle beabsichtigten Änderungen am Zielsystem aufgelistet.
    Hinweis Hinweis Wenn bereits eine Startanwendung auf dem Zielsystem installiert ist, wird diese automatisch von MAX deinstalliert.
  7. Klicken Sie zum Starten der Installation auf Weiter. In der Verlaufsanzeige wird angezeigt, welche Datei gerade entfernt oder installiert wird. Wenn der Vorgang beendet ist, startet das Installationsprogramm das System neu.
  8. Klicken Sie zum Schließen des Assistenten auf Beenden.

Alle auf dem Netzwerksystem installierten Softwareprodukte werden in der Übersicht unter Software angezeigt. Startanwendungen sind mit dem Symbol [image] gekennzeichnet.


Installieren von empfohlener Software

Zum Herunterladen von empfohlener Software mit Hilfe des Software-Assistenten für LabVIEW Real-Time gehen Sie wie folgt vor:

  1. Wählen Sie einen der folgenden Arbeitsschritte aus:
    • Wählen Sie die Komponenten aus, die installiert werden sollen. Bei Auswahl eines Softwarepakets wird auf der rechten Seite eine Liste mit der darin enthaltenen Software angezeigt, die von NI empfohlen wird.

      Wenn der Name der empfohlenen Software ausgegraut ist, kann sie aus einem der folgenden Gründe nicht installiert werden:
      • Softwareversionen, die für die empfohlene Software benötigt werden, sind auf dem Host-Rechner nicht vorhanden. Sie können Benutzerdefinierte Installation wählen, um eine andere Version zu installieren.
      • Auf dem Host-Rechner fehlt Software. Wählen Sie zur Installation anderer Software Benutzerdefinierte Installation oder verlassen Sie den MAX und installieren Sie die Treibersoftware erneut.
    • Wählen Sie - sofern verfügbar - Benutzerdefinierte Installation zur manuellen Auswahl der Komponenten, die auf dem Zielsystem installiert werden sollen.
      Hinweis Hinweis Wenn Sie Benutzerdefinierte Installation auswählen und auf Weiter klicken, wird die Seite Komponenten angezeigt. Wenn Sie Komponenten von dieser Seite installieren, ist nicht die empfohlene Software auf dem Zielsystem installiert. Weitere Informationen finden Sie unter Installieren einer benutzerdefinierten Auswahl von Softwarekomponenten.
    • Wählen Sie zum Entfernen aller Programme vom Zielsystem Gesamte Software deinstallieren.
  2. Klicken Sie auf Weiter.
  3. Wenn die ausgewählte Software Zusatzpakete enthält, wählen Sie die zu installierenden Zusatzpakete aus und klicken Sie auf Weiter.
  4. Überprüfen Sie die Auswahl auf der Bestätigungsseite. Es werden alle beabsichtigten Änderungen am Zielsystem aufgelistet.
  5. Wenn Sie mit den Änderungen einverstanden sind, klicken Sie auf Weiter. Das Zielsystem wird bei Bedarf im Installationsmodus neu gestartet und beginnt dann die Installation. In der Verlaufsanzeige wird angezeigt, welche Datei gerade entfernt oder installiert wird. Wenn der Vorgang beendet ist, startet das Installationsprogramm das System neu.
  6. Klicken Sie zum Schließen des Assistenten auf Beenden.

Die ausgewählte Software wird auf dem Zielsystem installiert und kann verwendet werden.

Aktualisieren der BIOS-Firmware

Klicken Sie zur Aktualisierung des Real-Time-BIOS auf dem Zielsystem im Netzwerk auf BIOS aktualisieren, wenn eine aktuelle Version verfügbar ist. Durch die Aktualisierung des Real-Time-BIOS wird die bereits vorhandene Software gelöscht.


Hinzufügen oder Entfernen von Software auf Linux-RT-Zielsystemen

Installieren Sie das LabVIEW Real-Time Module und andere Treibersoftware auf dem Zielsystem im Netzwerk.

  1. Erweitern Sie in der Konfigurationsbaumstruktur den Punkt "Netzwerkumgebung" und anschließend Ihr RT-Zielsystem.
  2. Wählen Sie Software.
  3. Klicken Sie in der Symbolleiste auf Software hinzufügen/entfernen. Daraufhin wird der Software-Assistenten für Real-Time gestartet.
  4. Mit Hilfe des Software-Assistenten für LabVIEW Real-Time können Sie folgende Aufgaben ausführen:
    1. Anwenden eines Basissystemabbilds auf Ihr Zielsystem.
    2. Auswählen einer Entwicklungsumgebung, die auf dem Zielsystem verwendet werden soll.
    3. Installieren von Softwarepaketen auf dem RT-Zielsystem.
Hinweis Hinweis Sollte LabVIEW Real-Time bereits vorhanden sein, müssen unter Umständen zusätzliche Treiber geladen werden. Auf der Registerkarte "Systemeinstellungen" sollte in diesem Fall für das Real-Time-System der Status Verbunden - In Betrieb angezeigt werden.


Anwenden von Basissystemabbildern

Anwenden von Basissystemabbildern auf das RT-Zielsystem

Wählen Sie im Software-Assistent für LabVIEW Real-Time ein Basissystemabbild aus, das auf das Zielsystem angewendet werden soll. Mit einem Basissystemabbild können Sie NI-Software über Feeds auf ni.com verwalten.

Hinweis Hinweis Wenn Sie ältere Software verwenden und mit der Installation von veralteter Software fortfahren möchten, lesen Sie Hinzufügen oder Entfernen von Software auf veralteten Systemen.
  1. Wählen Sie im Software-Assistent für LabVIEW Real-Time ein Basissystemabbild aus, das auf das Zielsystem angewendet werden soll, und klicken Sie auf OK.
  2. (Optional) Wenn Sie vom Software-Assistenten zum Formatieren des Zielsystems aufgefordert werden, um das Basissystemabbild anzuwenden, klicken Sie auf Formatieren.
Hinweis Hinweis Durch das Formatieren werden alle installierten Programme und Benutzerdaten vom Zielsystem gelöscht, die Netzwerkeinstellungen bleiben jedoch erhalten.

Nachdem Sie ein Basissystemabbild ausgewählt haben, wählen Sie eine Entwicklungsumgebung auf dem Zielsystem aus.


Auswählen einer Entwicklungsumgebung

Wählen Sie die Entwicklungsumgebung, die auf dem Zielsystem verwendet werden soll. Die von Ihnen gewählte Entwicklungsumgebung richtet sich danach, wo Ihre Anwendung entwickelt wurde und welche Runtime-Version Sie für das Zielsystem verwenden möchten.

Hinweis Hinweis Mit der von Ihnen ausgewählten Entwicklungsumgebung und Runtime-Version wird festgelegt, welche empfohlenen Pakete MAX für die Installation vorab auswählt.
  1. Wählen Sie im Software-Assistenten für LabVIEW Real-Time die Entwicklungsumgebung, aus, die Sie für das Zielsystem verwenden möchten.
  2. (Optional) Wenn Sie LabVIEW ausgewählt haben, wählen Sie eine Runtime-Version aus.
Hinweis Hinweis Verfügbare Entwicklungsumgebungen werden gefiltert und sind somit mit dem Real-Time-Zielsystem kompatibel. Wenn NXG nicht als Option zur Auswahl steht, besuchen Sie ni.com und geben Sie den Infocode nxgrtsupport ein.

Nachdem Sie Ihre Entwicklungsumgebung ausgewählt haben, wählen Sie die erforderlichen Softwarepakete aus und installieren Sie sie auf dem Zielsystem.


Installieren von Paketen auf dem Zielsystem

Sie können Pakete auf dem Zielsystem basierend auf der von Ihnen ausgewählten Entwicklungsumgebung installieren.

Die Pakete werden automatisch dem Zielsystem und der Entwicklungsumgebung entsprechend gefiltert.

Hinweis Hinweis Der Software-Assistent wählt empfohlene Pakete für Sie aus.

Mit Hilfe der folgenden Tabelle können Sie je nachdem, ob das Zielsystem oder der Host-Rechner über Internetzugang verfügt, die Art und Weise der Paketinstallation auf dem Zielsystem festlegen.

Anwendungsfall Vorgehensweise zur Paketinstallation
Das Zielsystem verfügt über Internetzugang.
  1. Wählen Sie die Pakete aus, die auf dem Zielsystem installiert werden sollen, und klicken Sie auf Änderungen überprüfen.
  2. Klicken Sie nach dem Überprüfen Ihrer Auswahl auf Fortsetzen, um den Installationsvorgang durchzuführen.
  3. Nachdem der Software-Assistent die Pakete erfolgreich installiert hat, können Sie das Dialogfeld schließen.
Das Zielsystem und der Host-Rechner verfügen beide über Internetzugang, und der Offline-Paketspeicherort ist auf dem Host-Rechner installiert.
  1. Folgen Sie den Anweisungen, um zwischen der Installation der Pakete von ni.com oder dem Abrufen von Paketen aus dem lokalen Paketspeicherort auf dem Host-Rechner zu wählen.
  2. Wählen Sie die Pakete aus, die auf dem Zielsystem installiert werden sollen, und klicken Sie auf Änderungen überprüfen.
  3. Klicken Sie nach dem Überprüfen Ihrer Auswahl auf Fortsetzen, um den Installationsvorgang durchzuführen.
  4. Nachdem der Software-Assistent die Pakete erfolgreich installiert hat, können Sie das Dialogfeld schließen.
Der Host-Rechner verfügt über Internetzugang, das Zielsystem jedoch nicht. Die Pakete sind auf dem Host verfügbar.
  1. Folgen Sie den Anweisungen, um dem Zielsystem entweder sicheren Zugriff auf ni.com durch den Host-Rechner zu gewähren oder Pakete vom lokalen Paketspeicherort auf dem Host-Rechner abzurufen.
  2. Wählen Sie die Pakete aus, die auf dem Zielsystem installiert werden sollen, und klicken Sie auf Änderungen überprüfen.
  3. Klicken Sie nach dem Überprüfen Ihrer Auswahl auf Fortsetzen, um den Installationsvorgang durchzuführen.
  4. Nachdem der Software-Assistent die Pakete erfolgreich installiert hat, können Sie das Dialogfeld schließen.
Der Host-Rechner verfügt über Internetzugang, das Zielsystem jedoch nicht. Die erforderlichen Pakete sind noch nicht auf dem Host installiert.
  1. Folgen Sie den Anweisungen, um dem Zielsystem sicheren Zugriff auf ni.com zu gewähren.
  2. Wählen Sie die Pakete aus, die auf dem Zielsystem installiert werden sollen, und klicken Sie auf Änderungen überprüfen.
  3. Klicken Sie nach dem Überprüfen Ihrer Auswahl auf Fortsetzen, um den Installationsvorgang durchzuführen.
  4. Nachdem der Software-Assistent die Pakete erfolgreich installiert hat, können Sie das Dialogfeld schließen.
Weder der Host noch das Zielsystem haben Internetzugang.
  1. Folgen Sie den Schritten zur Fehlerbehebung, die im Software-Assistenten angezeigt werden, um die erforderlichen Pakete zu installieren.
  2. Wählen Sie die Pakete aus, die auf dem Zielsystem installiert werden sollen, und klicken Sie auf Änderungen überprüfen.
  3. Klicken Sie nach dem Überprüfen Ihrer Auswahl auf Fortsetzen, um den Installationsvorgang durchzuführen.
  4. Nachdem der Software-Assistent die Pakete erfolgreich installiert hat, können Sie das Dialogfeld schließen.


Konfigurieren der Netzwerkeinstellungen

Mit der Ansicht Netzwerkeinstellungen lassen sich Netzwerkeinstellungen für ein Netzwerksystem anzeigen und festlegen. Auf dieser Registerkarte werden alle im System erkannten Ethernet-Geräte und drahtlosen Geräte aufgelistet. Das erste Gerät in der Liste ist der Standardadapter. Dies ist nicht immer der Primäradapter.

Ähnliche Themen

Konfigurieren mehrerer EtherCAT-Zielsysteme
Herstellen von Netzwerk- und Peer-to-Peer-Verbindungen
Verwalten von Zertifikaten

Konfiguration von IP-Adressen
Zuweisen einer IP-Adresse
Festlegen einer statischen IP-Adresse
Anhalten des Systems beim Nichtzustandekommen einer Internetverbindung
Ändern der IP-Adresse (offline)
Fehlersuche bei inkonsistenten IP-Einstellungen


IP-Konfiguration

Zuweisen einer IP-Adresse

Festlegen einer statischen IP-Adresse

Anhalten des Systems beim Nichtzustandekommen einer Internetverbindung

Ändern der IP-Adresse (offline)

Konfigurieren von Ethernet-over-USB-Geräten

Fehlersuche bei inkonsistenten IP-Einstellungen


Zuweisen einer IP-Adresse

Ein Netzwerksystem kann entweder an das LAN angeschlossen werden, in dem sich der Host-Computer befindet, oder über ein CAT-5-Crossover-Kabel direkt mit dem Host-Computer verbunden werden. In beiden Fällen muss das System mit einer IP-Adresse versehen werden. Dazu können Sie entweder automatisch oder manuell eine Adresse bestimmen.

Hinweis Hinweis Sie können eine IP-Adresse auf unterstützten Geräten mit Hilfe eines USB-Kabels ermitteln. Weitere Informationen finden Sie außerdem unter Konfigurieren von Ethernet mit Hilfe von USB-Geräten.

Manche Zielsysteme erfordern die Angabe einer statischen IP-Adresse, da sie die Zuweisung von automatischen IP-Adressen nicht unterstützen. Auch bei Verwendung einer Standleitung ist eine IP-Adresse erforderlich. Lesen Sie dazu bitte den Abschnitt Festlegen einer statischen IP-Adresse.

Wenn sich das Real-Time-System in einem Netzwerk mit DHCP-Server befindet, ist es unter Umständen möglich, automatisch eine IP-Adresse zuzuweisen. Der DHCP-Server weist dem System dann bei jedem Hochfahren des Systems eine IP-Adresse zu. Sie müssen in diesem Fall keine weiteren Informationen, z. B. eine Subnetzmaske, angeben. Ob Ihr Netzwerk einen DHCP-Server hat, erfahren Sie von Ihrem Netzwerkadministrator. Zum automatischen Ermitteln einer IP-Adresse wählen Sie die Option DHCP oder Link Local und klicken Sie anschließend auf Speichern. Damit die Einstellungen in Kraft treten, muss das System neu gestartet werden.

Nicht alle DHCP-Server arbeiten gleich. Daher kann es vorkommen, dass bestimmte Server mit dem LabVIEW Real-Time Module nicht kompatibel sind. Nach Auswahl von DHCP oder Link Local und Neustart des Real-Time-Systems fragt LabVIEW den DHCP-Server nach einer IP-Adresse. Wenn diese Operation fehlschlägt, startet LabVIEW das Real-Time-System automatisch neu und versucht, ihm eine Link-Local-Adresse (169.254.x.x) zuzuweisen, sofern diese Funktion unterstützt wird. Link-Local-Adressen sind Netzwerkadressen für lokale Netzwerke. Nach drei fehlgeschlagenen Versuchen nimmt das Programm mit der IP-Adresse 0.0.0.0 wieder die Ausgangskonfiguration an. In diesem Fall müssen alle Netzwerkparameter manuell eingegeben werden.

Bei Verwendung eines DHCP-Servers wird dem RT-Zielsystem bei jedem Hochfahren des Systems eine IP-Adresse zugewiesen. Die neue Adresse kann daher von der vorherigen abweichen. Wenn Sie dem Zielsystem mit Hilfe des DHCP-Servers eine IP-Adresse zuweisen, wird empfohlen, die Verbindung mit dem Real-Time-System mit Hilfe des Host-Namens und nicht über die IP-Adresse herzustellen. Zum Herstellen einer Verbindung mit dem Zielsystem mit Hilfe des Host-Namens geben Sie den Host-Namen in das Feld IP Address/DNS Name auf der Seite General im Dialogfeld RT Target Properties ein.


Festlegen einer statischen IP-Adresse

Wenn Sie eine IP-Adresse festlegen möchten, setzen Sie auf der Registerkarte "Netzwerkeinstellungen" die Option IPv4-Adresse konfigurieren auf Statisch, geben Sie für die untenstehenden Netzwerkparameter die korrekten Werte für Ihr Netzwerk ein und klicken Sie dann auf Speichern. Damit die Einstellungen in Kraft treten, muss das System neu gestartet werden.

  • IPv4-Adresse—Adresse zur eindeutigen Kennzeichnung eines Rechners im Netzwerk. Jede IP-Adresse besteht aus vier Zahlen, von denen jede eine bis drei Stellen haben kann. Alle Zahlen liegen zwischen 0 und 255 und sind durch Punkte voneinander getrennt. Das Anzeigeformat wird daher auch als Punktnotation bezeichnet. Eine IP-Adresse in Punktnotation kann beispielsweise 224.102.13.24 lauten.
  • Subnetzmaske—Code, mit dessen Hilfe ein Netzwerkrechner feststellt, ob sich ein anderes Gerät im selben oder in einem anderen Netz befindet. Die Subnetzmaske lautet in der Regel 255.255.255.0.
  • Gateway—IP-Adresse des Rechners, der als Übergang von einem Netzwerk zu einem anderen dient.
  • DNS-Server—IP-Adresse eines Netzwerkrechners, auf dem DNS-Host-Namen (Domain Name System) gespeichert und in IP-Adressen umgewandelt werden.

Setzen Sie sich vor Eingabe dieser Parameter mit Ihrem Netzwerkadministrator in Verbindung. Sollte das nicht möglich sein oder sollten Sie selbst das Netzwerk verwalten, lesen Sie bitte für weitere Hilfe den Abschnitt Konfigurieren der Netzwerkeinstellungen. Um Ihre Änderungen rückgängig zu machen, klicken Sie auf Wiederherstellen.


Anhalten des Systems beim Nichtzustandekommen einer Internetverbindung

Mit Hilfe der Option Bei IP-Fehler anhalten kann die Funktionsweise des LabVIEW Real-Time Modules und Controllers festgelegt werden, wenn beim Hochfahren des Controllers ein TCP/IP-Fehler auftritt.

Bei Deaktivierung dieser Option führt LabVIEW Real-Time beim Systemstart die von Ihnen festgelegten Startanwendungen aus, auch wenn die IP-Adresse nicht automatisch ermittelt werden kann oder beim Start andere TCP/IP-Fehler auftreten. Nach dem Herstellen einer Verbindung müssen Sie den Controller manuell neu starten, um eine Verbindung zum Netzwerk herzustellen.

Wenn die Option aktiviert ist und TCP/IP-Fehler auftreten, versucht LabVIEW Real-Time, eine automatische IP-Adresse über DHCP zu ermitteln. Kann keine Adresse ermittelt werden, wird versucht, eine Link-Lokal-Adresse (169.254.x.x) abzufragen, falls das Zielsystem diese Funktion unterstützt. Wenn auch dieser Vorgang fehlschlägt, startet LabVIEW Real-Time das System neu und versucht es erneut. Nach drei fehlgeschlagenen Versuchen setzt LabVIEW Real-Time den Controller auf die IP-Adresse 0.0.0.0 zurück.

Hinweis DHCP-Fehler werden als TCP/IP-Fehler betrachtet.


Ändern der IP-Adresse (offline)

Mit IP-Adresse ändern (offline) wird die IP-Adresse des Netzwerksystems geändert, nachdem ihm eine neue zugewiesen wurde.

Der MAX erkennt automatisch Änderungen der IP-Adresse für Ziele im lokalen Subnetz. Wenn sich die IP-Adresse eines Systems in einem fremden Subnetz ändert, kann der MAX mit Hilfe dieser Einstellung darüber informiert werden.

Um zu der Einstellung zu gelangen, erweitern Sie in der MAX-Übersicht die Kategorie Netzwerkumgebung. Klicken Sie mit der rechten Maustaste auf den Namen Ihres Systems und wählen Sie IP-Adresse ändern (offline).


Konfigurieren mehrerer EtherCAT-Zielsysteme

Wenn mehrere Zielsysteme mit demselben EtherCAT-Netzwerk verbunden sind, muss der Modus "Master-Redundanz" auf allen Zielsystemen aktiviert werden. Falls der primäre EtherCAT-Master nicht funktioniert, wird der zweite EtherCAT-Master zum primären EtherCAT-Master. Die Option Startmodus kann nicht bei mehreren Netzwerkadaptern auf demselben Zielsystem auf "Master-Redundanz" gesetzt werden.

Gehen Sie zum Aktivieren der Master-Redundanz für einen EtherCAT-Adapter folgendermaßen vor:

  1. Wählen Sie EtherCAT aus der Dropdown-Liste Adaptermodus.
  2. Geben Sie einen Wert für EtherCAT-Master-ID ein.
  3. Klicken Sie auf Mehr Einstellungen.
  4. Wählen Sie Master-Redundanz aus der Dropdown-Liste Startmodus aus. Diese Option muss für beide Adapter ausgewählt werden. Die EtherCAT-Master-ID legt fest, welcher Adapter der Master ist.
  5. Klicken Sie auf Speichern zum Übernehmen der Änderungen oder auf Wiederherstellen zum Abbrechen.
  6. Bei Aufforderung zum Neustart des Netzwerksystems klicken Sie auf Ja.


Erstellen eines drahtlosen Netzwerks

Sie können drahtlose Netzwerke im MAX mit Hilfe von unterstützten Geräten, wie z. B. myRIO-1900, erstellen. Gehen Sie zum Erstellen eines Zugangspunkts für ein drahtloses Netzwerk folgendermaßen vor:

  1. Öffnen Sie die Registerkarte Netzwerkeinstellungen im MAX.
  2. Wählen Sie im Abschnitt Drahtloser Adapter wlan0 aus dem Dropdown-Menü Drahtlose Verbindung den Punkt Drahtloses Netzwerk erstellen aus.
  3. Wählen Sie Ihren Standort aus dem Dropdown-Menü Land aus.
  4. Geben Sie in das Textfeld SSID den öffentlichen Namen für Ihr drahtloses Netzwerk ein.
  5. Wählen Sie aus dem Dropdown-Menü Kanal einen Kanal aus. Es wird empfohlen einen Kanal mit minimalen Störeinflüssen von benachbarten Kanälen auszuwählen.
  6. Wählen Sie Ihre Sicherheitseinstellungen aus dem Dropdown-Menü Sicherheit aus.
    • Zum Erstellen eines öffentlichen drahtlosen Netzwerks, das jeder Benutzer verwenden kann, wählen Sie Offen.
    • Zum Erstellen eines privaten drahtlosen Netzwerks, für das ein Passwort erforderlich ist, wählen Sie WPA2 Personal aus. Bei Auswahl der dieser Option wird im MAX das Textfeld WPA-Passphrase angezeigt, in dem Sie ein Netzwerkpasswort festlegen können.
  7. Zum Übernehmen der Änderungen klicken Sie in der MAX-Symbolleiste auf die Schaltfläche Speichern.

Vergewissern Sie sich nach dem Erstellen des Netzwerks, dass andere Clients eine Verbindung mit dem neuen Netzwerk herstellen können.


Konfigurieren von Ethernet-over-USB-Geräten

Sie können unterstützte Geräte mit Hilfe eines USB-Kabels an einen Host-Computer anschließen und eine IP-Adresse ermitteln. Diese Geräte, z. B. myRIO-1900, werden im Abschnitt Netzwerkumgebung in der Baumstruktur angezeigt.

Die IP-Adresse, die dem Gerät über USB zugewiesen wird, kann nur vom Host-Computer verwendet werden. Wenn Sie von einem anderen Computer im Subnetz aus eine Verbindung mit dem Gerät herstellen möchten, verwenden Sie eine der folgenden Optionen:

  • Stellen Sie eine Verbindung mit einem drahtlosen Netzwerk her. Sie können eine Verbindung mit einem drahtlosen Netzwerk herstellen, um eine IP-Adresse zu ermitteln, mit deren Hilfe eine Verbindung mit dem Gerät über das Netzwerk hergestellt werden kann. Beim Herstellen einer Verbindung mit einem drahtlosen Netzwerk können Sie auch mit Hilfe des Host-Namens des Zielsystems eine Verbindung über das Netzwerk herstellen. Auf der Registerkarte Netzwerkeinstellungen können Sie eine Verbindung mit einem drahtlosen Netzwerk herstellen.
  • Schließen Sie das Gerät über einen Ethernet-Adapter für die USB-Schnittstelle an den Host-Computer an.
  • Stellen Sie eine Netzwerkbrücke zwischen dem Netzwerkadapter des Geräts und einem Adapter mit Netzwerkverbindung her. Weitere Informationen zum Herstellen einer Brücke mit Netzwerkadaptern finden Sie im KnowledgeBase-Artikel 6CK9HDGW.

An unterstützten Geräten können Sie auch ein drahtloses Netzwerk erstellen.


Herstellen von Netzwerk- und Peer-to-Peer-Verbindungen

Ein Host-Computer kommuniziert mit einem System im Netzwerk über eine Ethernet-Verbindung. Wenn der Host-Computer bereits in einem Netzwerk konfiguriert wurde, muss das System im selben Netzwerk konfiguriert werden. Wenn keiner der Rechner an ein Netzwerk angeschlossen ist, müssen beide Computer über ein CAT.5-Crossover-Kabel oder einen Hub miteinander verbunden werden. So kann das Real-Time-System direkt vom Host-Computer aus konfiguriert werden.

Bei Systemen, die ihre IP-Adresse nicht automatisch über DHCP ermitteln, müssen sowohl Host-Computer als auch Netzwerksystem zum selben Subnetz gehören, um das System mit MAX zu konfigurieren.

Sollte das nicht der Fall sein, können Sie dennoch LabVIEW-Real-Time-Anwendungen erstellen und ausführen. Weisen Sie dazu dem Controller für das Subnetz, in dem sich das Real-Time-System befindet, eine statische IP-Adresse zu. Nähere Einzelheiten dazu finden Sie im Abschnitt Zuweisen einer IP-Adresse.


Verwalten von Zertifikaten

Über Zertifikate verwalten lassen sich Client-Zertifikate und vertrauenswürdige Stammzertifikate anzeigen, verwalten und auf drahtlose Geräte im Netzwerk hochladen.

Führen Sie zum Hochladen eines Zertifikates auf das Zielsystem folgende Schritte aus:

  1. Erweitern Sie in der MAX-Baumstruktur die Kategorie Geräte und Schnittstellen.
  2. Erweitern Sie die Kategorie Netzwerkgeräte und wählen Sie das gewünschte drahtlose Netzwerkgerät aus.
  3. Klicken Sie auf die Registerkarte Netzwerkeinstellungen.
  4. Melden Sie sich auf dem Zielsystem an und vergewissern Sie sich, dass Sie die nötigen Berechtigungen zum Bearbeiten der Netzwerkeinstellungen haben.
  5. Klicken Sie zum Verwalten der Zertifikate auf die Schaltfläche Zertifikate verwalten. MAX zeigt die derzeit auf dem Zielsystem verfügbaren Zertifikate an.
  6. Klicken Sie auf Neues Zertifikat hochladen.
  7. Zertifikatsdatei—Wählen Sie den Speicherort der Zertifikatsdatei aus.
  8. (Optional) Wenn das Client-Zertifikat, das hochgeladen werden soll, einen entsprechenden privaten Schlüssel erfordert, aktivieren Sie die Option Privaten Schlüssel für dieses Zertifikat hochladen. Wenn es sich um ein Client-Zertifikat für TLS handelt, ist ein privater Schlüssel erforderlich.
  9. (Optional) Datei für privaten Schlüssel—Wählen Sie den Speicherort für die Datei für den privaten Schlüssel aus, die zu dem Client-Zertifikat gehört.
    Hinweis Hinweis Für manche Dateien für private Schlüssel ist ein Passwort für den Lesezugriff erforderlich. Sie müssen möglicherweise ein Passwort in das Textfeld Passwort für Schlüssel (Optional) eingeben.
  10. Klicken Sie auf Hochladen.

Ein Zertifikat kann von einem Gerät entfernt werden. Klicken Sie dazu auf den Link Entfernen rechts neben dem Namen des Zielsystems.


Konfigurieren der Systemeinstellungen

Auf der Registerkarte Systemeinstellungen befinden sich alle Einstellungen zu Ihrem LabVIEW-Real-Time-Zielsystem (z. B. Host-Name und Kommentare).

Hinweis Auf Zielsystemen mit installierter Webkonfiguration kann die Systemkonfiguration durch einen Benutzernamen und ein Passwort geschützt werden. Jedes Netzwerkgerät hat per Voreinstellung einen Benutzer:

Benutzername—admin
Passwort—<leer>

Ähnliche Themen

Gerätekalibrierung
Überwachen von Systemressourcen
Aktualisieren des sicheren Modus auf dem Zielsystem
Festlegen des Zugriffs auf ein Zielsystem über das Netzwerk


Überwachen von Systemressourcen

Im Abschnitt Systemressourcen auf der Registerkarte Systemeinstellungen werden die folgenden Angaben für Systeme angezeigt. Diese Angaben können nicht bearbeitet werden:

  • Physikalischer Speicher (gesamt) zeigt an, wie viel physikalischer Speicher insgesamt auf dem System zur Verfügung steht.
  • Physikalischer Speicher (frei) zeigt an, wie viel freier physikalischer Speicher auf dem System zur Verfügung steht.
  • Virtueller Speicher (gesamt) zeigt an, wie viel virtueller Speicher insgesamt auf dem System zur Verfügung steht.
  • Virtueller Speicher (frei) zeigt an, wie viel freier virtueller Speicher auf dem System zur Verfügung steht.
  • Größter verfügbarer Speicherblock zeigt die Größe des größten verfügbaren Speicherblocks auf dem System an.
  • Speicherplatz der primären Festplatte ist der Speicherplatz der Primärfestplatte (z. B. C:) des Systems.
  • Freier Speicherplatz der primären Festplatte ist der freie Speicherplatz der Primärfestplatte (z. B. C:) des Systems.
  • CPU-Gesamtauslastung zeigt die Gesamtauslastung für jeden logischen Prozessor im System an. Diese Angabe erfolgt als Zahl zwischen 0 und 100.
  • CPU-Interrupt-Auslastung zeigt den prozentualen Anteil der Zeit an, die ein logischer Prozessor im System auf Kernel-Tasks (z. B. Bearbeiten von Interrupts) verwendet. Diese Angabe erfolgt als Zahl zwischen 0 und 100.


Aktualisieren des sicheren Modus auf dem Zielsystem

Sie können die Version des sicheren Modus auf dem Zielsystem durch Aktualisieren der Firmware aktualisieren. Führen Sie zum Aktualisieren der Firmware folgende Schritte aus:

Hinweis Hinweis Nicht alle Geräte unterstützen Firmware-Aktualisierungen.
  1. Öffnen Sie die Registerkarte Systemeinstellungen für Ihr Zielsystem.
  2. Klicken Sie auf die Schaltfläche Firmware aktualisieren.
  3. Wählen Sie aus der Dropdown-Liste das Firmware-Abbild aus, auf das aktualisiert werden soll. Zur Auswahl der Firmware-Datei vom Host können Sie auch auf die Schaltfläche Suchen klicken.
    Hinweis Hinweis Wenn auf Ihrem Gerät keine Firmware-Abbilder vorhanden sind, wird über die Schaltfläche Firmware aktualisieren ein Dialogfeld gestartet, mit dessen Hilfe ein Firmware-Abbild vom lokalen Host ausgewählt werden kann.
  4. Klicken Sie auf die Schaltfläche Aktualisierung starten.


Festlegen des Zugriffs auf ein Zielsystem über das Netzwerk

Mit Internetzugriff auf Systemkonfiguration können Sie festlegen, wie auf die Systemkonfigurationseinstellungen des Zielsystems zugegriffen werden soll.

  • Nur lokal—Ermöglicht das Konfigurieren von Einstellungen nur vom Zielsystem aus.
  • Lokal und über Netzwerk—Ermöglicht die Konfiguration sowohl lokal als auch über das Netzwerk.
  • (Windows Embedded Standard 7) Lokal und über Netzwerk—Aktiviert die Verteilung von Webdiensten über das Netzwerk von einem LabVIEW-Projekt aus.


Konfigurieren der Zeiteinstellungen

Mit Hilfe der Registerkarte Zeiteinstellungen können Sie Zeiteinstellungen (z. B. Datum, aktuelle Zeit, Zeitzone und Sommerzeit) auf Ihrem LabVIEW-Real-Time-System vornehmen. Hier können Sie auch Zeitsynchronisationsquellen für Ihr System auswählen.

Hinweis
  • Nicht alle LabVIEW-Real-Time-Zielsysteme unterstützen alle Zeiteinstellungen.

Ähnliche Themen

Festlegen von Datum und Zeit


Festlegen von Datum und Zeit

Mit Hilfe von Datum und Zeit können Sie Zeit und Datum Ihres LabVIEW-Real-Time-Zielsystems festlegen.

  • Datum—Wählen Sie aus dem Kalender ein Datum für Ihr Zielsystem aus.
  • Aktuelle Zeit—Wählen Sie mit Hilfe der Pfeilschaltflächen die Zeit für Ihr Zielsystem aus.
  • Zeitzone—Legen Sie die Zeitzone fest, in der sich das Zielsystem befindet. Diese Einstellung wird von den LabVIEW-VIs für Datum und Zeit benötigt, damit sie exakte Angaben liefern.
  • Automatisch auf Sommer-/Winterzeit umstellen—Aktivieren Sie diese Option zur automatischen Umstellung des Zielsystems auf Sommer-/Winterzeit (sofern Ihr Zielsystem dies unterstützt).
    Hinweis Hinweis Wenn das Zielsystem nicht die automatische Umstellung auf Sommer-/Winterzeit unterstützt, wählen Sie unter Zeitzone das GMT-Äquivalent für Ihren Standort statt der tatsächlichen Zeitzone. Andernfalls sind Zeitstempel möglicherweise nicht korrekt.


Gerätekonfiguration

Bevor eine LabVIEW-Real-Time-Anwendung mit einem Gerät arbeiten kann, das mit NI-Real-Time kompatibel ist, muss dieses konfiguriert werden. Wenn ein Gerät in einem Real-Time-System nicht im MAX angezeigt wird, vergewissern Sie sich, dass die richtige Treibersoftware auf dem Real-Time-System installiert ist.

Die Verwendung bestimmter NI-Produkte im MAX wird auch unter Hilfe»Hilfethemen erläutert. Sie können die Hilfe zu NI-Produkten auch von der MAX-Hilfe aus über den Menüpunkt Hilfe oder durch Drücken der Taste <F1> öffnen. Weitere Informationen finden Sie in der Dokumentation Ihres Geräts.


Sicherheit

Mit dem Passwort wird sichergestellt, dass ein Host-Computer über LabVIEW Real-Time kein System im Netzwerk steuert, das nicht unter RT Target: Access in LabVIEW aufgeführt ist. Zum Aufrufen dieser Liste von LabVIEW klicken Sie mit der rechten Maustaste auf ein Projektfenster und wählen Sie Properties.

Lesen Sie die folgenden Themen zur Konfiguration von Sicherheitseinstellungen für Ihr Netzwerkgerät.

  • Erstellen eines neuen Benutzerkontos
  • Schützen der Systemkonfiguration auf dem Zielsystem
  • Sichern eines Netzwerkgeräts


Erstellen eines neuen Benutzerkontos

Gehen Sie zum Erstellen eines neuen Benutzerkontos wie folgt vor:

  1. Zum Öffnen der Seite "Sicherheitskonfiguration" in einem Browser klicken Sie im MAX auf die Schaltfläche Berechtigungen festlegen in der Symbolleiste.
  2. Klicken Sie auf Anmelden und geben Sie admin in das Feld Benutzername ein.
  3. Lassen Sie das Feld Passwort leer, wenn Sie das Standardpasswort nicht geändert haben, oder geben Sie das aktuelle Passwort ein.
  4. Zum Erstellen eines neuen Benutzerkontos klicken Sie auf die Schaltfläche Neuer Benutzer.
  5. Ersetzen Sie den Standardbenutzernamen im Feld Benutzername durch Ihren Benutzernamen.
  6. Geben Sie im Feld Neues Passwort ein sicheres Passwort ein.
  7. Geben Sie das Passwort erneut in das Feld Passwort erneut eingeben ein.
  8. (Optional) Geben Sie im Feld Kommentare eine Beschreibung des neuen Benutzerkontos ein.
  9. Setzen Sie im Feld Gruppe(n) vor alle Kästchen für Gruppen ein Häkchen, denen das neue Benutzerkonto angehören soll.
  10. Setzen Sie im Feld Berechtigung(en) vor alle Kästchen für Berechtigungen ein Häkchen, die das neue Benutzerkonto erhalten soll.
  11. Klicken Sie auf die Schaltfläche Speichern.
  12. Klicken Sie zum Speichern der Änderungen am System auf die Schaltfläche Änderungen hochladen.
  13. Kehren Sie zum MAX zurück und melden Sie sich mit dem neuen Benutzernamen und Passwort an.
Tipp Tipp Aktivieren Sie zum Erstellen eines sicheren Kontos für einen Nicht-Administrator die Mindestberechtigungen, die zum Ausführen der Tasks des Benutzers notwendig sind. Zur Anzeige einer Beschreibung für jede Berechtigung klicken Sie auf die Schaltfläche Hilfe in der rechten oberen Ecke der Seite Sicherheitskonfiguration.

Für weitere Informationen zum Festlegen von Berechtigungen klicken Sie auf Hilfe auf der Seite "Sicherheitskonfiguration".


Schützen der Systemkonfiguration auf dem Zielsystem

Bei Zielsystemen mit installierter Webkonfiguration kann die Systemkonfiguration mit Hilfe von Benutzername und Passwort geschützt werden. Jedes Netzwerkgerät hat per Voreinstellung einen Nutzer mit folgendem Namen und Passwort:

  • Benutzername—admin
  • Passwort—<leer>

Zum Anmelden auf dem Zielsystem, um dort Änderungen vorzunehmen, führen Sie folgende Schritte aus:

  1. Klicken Sie im MAX auf die Schaltfläche Anmelden in der Symbolleiste.
  2. Geben Sie admin in das Feld Benutzername ein.
  3. Lassen Sie das Feld Passwort leer.
  4. Klicken Sie auf die Schaltfläche OK.


Sichern eines Netzwerkgeräts

Zum Sichern eines Netzwerkgeräts gehen Sie wie folgt vor:

  1. Zum Öffnen der Seite "Sicherheitskonfiguration" in einem Browser klicken Sie im MAX auf die Schaltfläche Berechtigungen festlegen in der Symbolleiste.
  2. Klicken Sie auf Anmelden und geben Sie admin in das Feld Benutzername ein.
  3. Lassen Sie das Feld Passwort leer, wenn Sie das Standardpasswort nicht geändert haben, oder geben Sie das aktuelle Passwort ein.
  4. Klicken Sie in der Liste der Benutzer auf der Registerkarte Benutzer doppelt auf admin.
  5. Geben Sie im Feld Neues Passwort ein sicheres Passwort ein.
  6. Geben Sie das Passwort erneut in das Feld Passwort erneut eingeben ein.
  7. Klicken Sie auf die Schaltfläche Speichern.
  8. Klicken Sie zum Speichern der Änderungen am System auf die Schaltfläche Änderungen hochladen.
  9. Kehren Sie zum MAX zurück und melden Sie sich mit dem neuen Passwort an.
Achtung Zum Schützen Ihres Netzwerkgeräts müssen Sie das Standardpasswort ändern. Des Weiteren müssen alle Berechtigungen von der Gruppe "everyone" entfernt werden.

Entfernen von Berechtigungen der Gruppe "Everyone"

Führen Sie zum Entziehen aller Berechtigungen der Gruppe "everyone" folgende Schritte aus:

  1. Klicken Sie auf die Registerkarte Gruppen.
  2. Klicken Sie doppelt auf die Gruppe "everyone".
  3. Deaktivieren Sie alle Optionen in der Spalte Berechtigung?.
  4. Klicken Sie auf die Schaltfläche Speichern.
  5. Klicken Sie zum Speichern der Änderungen am System auf die Schaltfläche Änderungen hochladen.


Literaturhinweise

Die meisten Handbücher von NI gibt es auch als PDF-Dateien. Zur Anzeige der Dokumente benötigen Sie mindestens Adobe Acrobat Reader 5.0.5 mit Suchfunktion. Den Adobe Reader können Sie auf der Adobe-Website herunterladen. Die aktuelle Version aller Handbücher finden Sie in der Produktbibliothek von NI.

Die nachfolgenden Materialien können sich bei der Lektüre dieser Hilfedatei als nützlich erweisen:

  • Getting Started with the LabVIEW Real-Time Module (Start»Alle Programme»National Instruments»LabVIEW»LabVIEW-Handbücher»RT_Getting_Started.pdf)
  • LabVIEW Real-Time Module Release and Upgrade Notes (Start»Alle Programme»National Instruments»LabVIEW»LabVIEW-Handbücher»RT_Release_Upgrade_Notes.pdf)
  • Using Desktop PCs as RT Targets with the LabVIEW Real-Time Module (Start»Alle Programme»National Instruments»LabVIEW»LabVIEW-Handbücher»RT_Using_PC_as_RT_Target.pdf)
  • Handbücher, Anleitungen, Beispiele und Diskussionsforen zum LabVIEW Real-Time Module unter ni.com/support/labview/real-time.
  • LabVIEW-Hilfe (wird in LabVIEW über Hilfe»LabVIEW-Hilfe geöffnet. Klicken Sie auf der Registerkarte "Inhalt" auf das Buch "Real-Time Module".)
  • NI-CAN User Manual

Häufige Fehlercodes

Wenn Sie unter ni.com einen bestimmten Fehlercode eingeben, erhalten Sie die neuesten Informationen dazu.


.topic 0x9f5b1f6e
Geben Sie ein Passwort ein, um den Zugriff auf das Netzwerksystem zu sperren.
.topic 0x9f5b1f6f
Wiederholen Sie das neue Password für Ihr Netzwerksystem.
.topic 0x9f5b234c
Geben Sie ein neues Passwort ein, um das Netzwerksystem zu sperren.
.topic 0x9f5b234d
Wiederholen Sie das neue Password für Ihr Netzwerksystem.
.topic 0x9f53235d
Bearbeiten Sie die IP-Adresse Ihres Netzwerksystems.
.topic 0x9f591f4f
Geben Sie ein Passwort ein, um Ihr Netzwerksystem freizugeben.
.topic 0x9f53235c
Geben Sie einen Host-Namen für Ihr Netzwerksystem ein.
.topic 0x9f532347
Diese Option sollte gewählt werden, wenn ein System im Netzwerk über den DNS-qualifizierten Host-Namen erkannt werden soll.
.topic 0x9f531f64
Bearbeiten Sie den Host-Namen für Ihr Netzwerksystem.
.topic 0x9f53234a
Geben Sie eine IP-Adresse für Ihr Netzwerksystem ein. Jede IP-Adresse besteht aus vier Zifferngruppen zwischen 0 und 255. Weitere Informationen zu IP-Adressen finden Sie in der Hilfe zu Systemen im Netzwerk, die über Hilfe>>Hilfethemen>>Netzwerkumgebung geöffnet wird.
.topic 0x9f651f7b
Wählen Sie die IP-Adresse der Netzwerkkarte, die mit dem Gerät im Netzwerk verbunden werden soll. Die Ihrer Netzwerkkarte zugewiesenen IP-Adressen können der Kategorie "Netzwerkverbindungen" unter "Systemsteuerung" entnommen werden.
.topic 0x9f651f83
Zeigt das erste Oktett (das erste 8-Bit-Segment) der IP-Adresse an. Das erste Oktett identifiziert die Klasse der IP-Adresse. Nähere Hinweise zu diesem Thema entnehmen Sie bitte der Hilfe zu Systemen im Netzwerk unter Hilfe>>Hilfethemen>>Netzwerkumgebung.
.topic 0x9f651f85
Zeigt das zweite Oktett (8-Bit-Segment) der IP-Adresse an. Nähere Hinweise zu diesem Thema entnehmen Sie bitte der Hilfe zu Systemen im Netzwerk unter Hilfe>>Hilfethemen>>Netzwerkumgebung.
.topic 0x9f651f84
Zeigt das dritte Oktett (8-Bit-Segment) der IP-Adresse an. Nähere Hinweise zu diesem Thema entnehmen Sie bitte der Hilfe zu Systemen im Netzwerk unter Hilfe>>Hilfethemen>>Netzwerkumgebung.
.topic 0x9f651f86
Zeigt das vierte und letzte Oktett (8-Bit-Segment) der IP-Adresse an. Nähere Hinweise zu diesem Thema entnehmen Sie bitte der Hilfe zu Systemen im Netzwerk unter Hilfe>>Hilfethemen>>Netzwerkumgebung.
.topic 0x9f532348
Diese Option sollte gewählt werden, wenn ein System im Netz über seine IP-Adresse automatisch erkannt werden soll. Geben Sie die IP-Adresse des gesuchten Systems ein. Wenn das System gefunden wird, erfolgt dessen Anzeige in der Baumstruktur unter Netzwerkumgebung. Als Standardname wird die IP-Adresse des Systems verwendet.


Netzwerkumgebung

In der Kategorie Netzwerkumgebung sind alle Systeme konfigurierbar, die über Ethernet mit Ihrem Rechner verbunden sind. Zur Anzeige aller Systeme in der Netzwerkumgebung klicken Sie auf das Erweiterungssymbol [image].

Mögliche Arbeitsschritte

Erstkonfiguration des Systems

Lesen Sie die Anleitung zur Konfiguration von Real-Time-Systemen in einem Netzwerk. Bei Geräten, die nicht für den Echtzeitbetrieb ausgelegt sind, lesen Sie bitte die dazugehörige Beschreibung.

Anzeigen aller Systeme und Geräte im Netzwerk

Wenn Sie den MAX starten und die Kategorie Netzwerkumgebung zum ersten Mal öffnen, dauert die Anzeige der Geräte im Netzwerk etwas länger. Um das Programm zu einem späteren Zeitpunkt nach neuen Systemen und Geräten suchen zu lassen, klicken Sie in der Menüleiste auf Ansicht»Aktualisieren (F5).

Was ist zu tun, wenn ein Gerät nicht angezeigt wird?

Wenn ein Netzwerksystem nach der beschriebenen Vorgehensweise nicht automatisch angezeigt wird, vergewissern Sie sich, dass das System tatsächlich mit dem lokalen Subnetz verbunden ist.

Wenn Ihr System nicht im lokalen Subnetz vorhanden ist, klicken Sie mit der rechten Maustaste auf Netzwerkumgebung und wählen Sie Neu. Folgen Sie dann den angezeigten Anweisungen, um das System hinzuzufügen.

Das Hinzufügen von Systemen zu einem lokalen Subnetz wird in der Hilfe zu Systemen im Netzwerk näher erläutert. Welche Schritte zum Anschluss eines Systems an ein Netzwerk erforderlich sind, erfahren Sie in der Dokumentation zum System.

Anzeigen und Konfigurieren der Systemeinstellungen von Netzwerksystemen

In der Kategorie Netzwerkumgebung können Sie Systemeinstellungen für Netzwerksysteme anzeigen und konfigurieren. Wählen Sie dazu ein System oder Gerät aus und klicken Sie auf die Registerkarte Systemeinstellungen. Sie können den Host-Namen des Systems ändern und Kommentare zum System hinzufügen. Sie können auch Netzwerkeinstellungen und Angaben zum Speicher und Speicherplatz anzeigen.

Konfigurieren der Netzwerkeinstellungen eines Systems

In der Kategorie Netzwerkumgebung ist es möglich, einem System eine IP-Adresse zuzuweisen und andere Netzwerkeinstellungen zum System vorzunehmen. Wählen Sie dazu ein System oder Gerät aus und klicken Sie auf die Registerkarte Netzwerkeinstellungen. Anschließend können Sie eine IP-Adresse automatisch erfassen oder manuell zuweisen.

Installieren von Software auf einem System im Netzwerk

Im MAX gibt es einen Software-Assistenten für LabVIEW Real-Time, der Sie schrittweise durch die Installation eines Programms auf ein System im Netzwerk führt. Um ihn zu öffnen, wählen Sie unter Netzwerkumgebung die Kategorie Software aus und klicken in der Symbolleiste auf Software hinzufügen/entfernen.

Netzwerksystem

Ein Netzwerksystem ist ein Echtzeitsystem, das über ein Netzwerk verwaltet oder konfiguriert werden kann. Ein Netzwerkgerät kann dagegen kein Echtzeitbetriebssystem ausführen. Netzwerksysteme unterscheiden sich von Netzwerkgeräten. Ein Netzwerkgerät ist ein Gerät, auf das über ein Ethernet oder eine drahtlose Verbindung zugegriffen werden kann. Der Zugriff auf solche Geräte kann von mehreren Rechnern erfolgen. Diese Geräte führen keine Echtzeitbetriebssysteme aus.

Hinweise zur Verwendung von Produkten von NI mit dem MAX erhalten Sie unter Hilfe»Hilfethemen und Auswahl einer der vorhandenen Optionen. Sie können die Hilfe zu NI-Produkten auch von der MAX-Hilfe aus über den Menüpunkt Hilfe oder durch Drücken der Taste <F1> öffnen.


Datenumgebung

In der Kategorie Datenumgebung sind alle Ein- und Ausgangskanäle des Systems in der Netzwerkumgebung aufgeführt. Hier werden auch virtuelle Kanäle und Tasks für NI-DAQmx angezeigt.

Mögliche Arbeitsschritte

Erstellen von Verknüpfungen

Zum Erstellen einer Verknüpfung klicken Sie mit der rechten Maustaste auf Datenumgebung und wählen Sie Neu. Die weiteren Optionen im Kontextmenü hängen von den installierten NI-Produkten ab.

Testen oder Entfernen einer Verknüpfung

Diese Option ist abhängig davon, welche Produkte installiert sind. In der Regel kann durch Rechtsklick auf eine Verknüpfung ein Kontextmenü geöffnet werden.

Anzeigen und Bearbeiten von Eigenschaften

Auch diese Option ist von der installierten Software abhängig. Normalerweise ist eine Verknüpfung mit der rechten Maustaste anzuklicken und die Option Eigenschaften auszuwählen. Bei manchen Objekten lassen sich die Eigenschaften in der Einzelansicht verändern.

Weitere Informationen zur Verwendung der Datenumgebung mit Produkten von NI erhalten Sie unter Hilfe»Hilfethemen. Sie können die Hilfe zu NI-Produkten auch von der MAX-Hilfe aus über den Menüpunkt Hilfe oder durch Drücken der Taste <F1> öffnen.


Geräte und Schnittstellen

In der Kategorie Geräte und Schnittstellen sind alle Geräte von NI aufgeführt, die an ein LabVIEW-Real-Time-System (Echtzeitsystem) im Netzwerk angeschlossen sind.

Wenn Ihr Gerät nicht angezeigt wird, ...

haben Sie die Anzeige eventuell nicht aktualisiert.

Drücken Sie <F5> oder wählen Sie Ansicht»Aktualisieren.

konnte MAX unter Umständen keine Verbindung zum Gerät herstellen.

Überprüfen Sie, ob das Netzwerk ordnungsgemäß konfiguriert und das Gerät online ist.

ist das Gerät möglicherweise nicht mit dem MAX konfigurierbar.

Manchen Geräte unterstützen die Konfiguration über das Netzwerk mit Hilfe von MAX nicht. Prüfen Sie anhand der Beschreibung, ob mit dem MAX Einstellungen über ein Netzwerk am Gerät vorgenommen werden können.

Mögliche Arbeitsschritte

Konfiguration eines vorhandenen Geräts

Klicken Sie dazu in der Übersicht den Kanalnamen mit der rechten Maustaste an und wählen Sie Eigenschaften. Bei manchen Komponenten können die Einstellungen nur in der Einzelansicht verändert werden. Wenn Sie mit dem traditionellen NI-DAQ-Treiber arbeiten, klicken Sie im Menü auf Werkzeuge»NI-DAQ-Konfiguration»Netzwerk-DAQ-Konfiguration.

Falls das Gerät immer noch nicht in der Liste erscheint, überprüfen Sie anhand der Installationsanleitung in der Gerätebeschreibung oder der produktspezifischen MAX-Hilfe (Hilfe»Hilfethemen), ob das Gerät ordnungsgemäß installiert ist. Wenn Sie sicher sind, dass die Hardware korrekt installiert ist, besuchen Sie die Support-Website unter ni.com/support.

Die Verwendung bestimmter NI-Produkte im MAX wird unter Hilfe»Hilfethemen erläutert. Sie können die Hilfe zu NI-Produkten auch von der MAX-Hilfe aus über den Menüpunkt Hilfe oder durch Drücken der Taste <F1> öffnen.


Skalierungen

In der Kategorie Skalierungen werden alle mathematischen Operationen aufgeführt, die für die Verarbeitung erfasster Daten konfiguriert wurden.

Mögliche Arbeitsschritte

Erstellen einer Skalierung

Klicken Sie zum Erstellen einer Skalierung mit der rechten Maustaste auf Skalierungen und wählen Sie Neu ...

Entfernen einer Skalierung

Zum Entfernen einer Skalierung klicken Sie diese in der Baumstruktur mit der rechten Maustaste an und wählen Sie Löschen.

Anzeigen und Bearbeiten von Skalierungen

Je nach installierter Software können Sie eine Skalierung mit der rechten Maustaste anklicken und die Option Eigenschaften auswählen oder die Eigenschaften in der Einzelansicht verändern.

Weitere Informationen zur Anzeige Ihrer Produkte von NI in der Kategorie Skalierungen erhalten Sie unter Hilfe»Hilfethemen und Auswahl einer der vorhandenen Optionen. Sie können die Hilfe zu NI-Produkten auch von der MAX-Hilfe aus über den Menüpunkt Hilfe oder durch Drücken der Taste <F1> öffnen.


Software

In der Kategorie Software werden alle Programme angezeigt, die auf einem LabVIEW-Real-Time-System installiert sind.

Mögliche Arbeitsschritte

Anzeigen der installierten Software

Zur Anzeige aller Einträge in der Kategorie Software klicken Sie auf das Symbol [image].

Software installieren

Klicken Sie dazu in der Symbolleiste auf die Schaltfläche Software hinzufügen/entfernen.

Spezifische Hinweise zu Hardware von NI erhalten Sie unter Hilfe»Hilfethemen und Auswahl einer der vorhandenen Optionen. Sie können die Hilfe zu NI-Produkten auch von der MAX-Hilfe aus über den Menüpunkt Hilfe oder durch Drücken der Taste <F1> öffnen.


Adaptermodus

Wenn es sich bei dem ausgewählten Gerät um das Hauptgerät handelt, ist Adaptermodus auf TCP/IP-Netzwerk gestellt. Für das Hauptgerät ist TCP/IP (DHCP oder statisch) der einzige zulässige Modus. Für andere Geräte gibt Adaptermodus den Verwendungszweck an. Weitere Hinweise dazu finden Sie unter Konfigurieren der Netzwerkeinstellungen.


Hintergrundsuche aktivieren

Aktiviert die Hintergrundsuche für das ausgewählte drahtlose Netzwerk. Aktivieren Sie diese Option, wenn der Adapter automatisch nach drahtlosen Netzwerken mit besserer Verbindungsqualität suchen und eine Verbindung herstellen soll.


Seriennummer

Zeigt die eindeutige Seriennummer des Zertifikats an.


Signaturalgorithmus

Zeigt den Algorithmus an, mit dessen Hilfe das Zertifikat verschlüsselt wird.


Version

Zeigt die Version des öffentlichen Schlüssels an, mit das Zertifikat signiert wurde.


Kanal

Zeigt eine Liste mit Kanälen an, die für das erstellte drahtlose Netzwerk ausgewählt werden können. Diese Liste kann je nach ausgewähltem Land unterschiedlich sein. Sie sollten einen Kanal mit minimalen Störeinflüssen von benachbarten drahtlosen Netzwerken auswählen.


Client-Zertifikat

Gibt das Zertifikat an, mit dem sich der Client im Netzwerk anmeldet. Informationen zum Hochladen eines Zertifikats auf das Zielsystem finden Sie unter Verwalten von Zertifikaten.


Kommentare

Hier haben Sie die Möglichkeit, ein System in der Netzwerkumgebung und seinen Verwendungszweck genauer zu beschreiben. Es können bis zu 64 Zeichen eingegeben werden.


Status

Zeigt den Verbindungsstatus des Netzwerks an, das unter Drahtloses Netzwerk ausgewählt wurde. Es werden die folgenden Angaben zur Verbindung mit dem Netzwerk angezeigt.

  • Verbunden—Der Adapter ist mit dem drahtlosen Netzwerk verbunden.
  • Nicht verbunden—Der Adapter ist nicht mit dem drahtlosen Netzwerk verbunden.
  • Ungültige Sicherheitseinstellungen—Der Adapter konnte aufgrund von ungültigen Sicherheitseinstellungen keine Verbindung mit dem drahtlosen Netzwerk herstellen.
  • Ungültige IP-Einstellungen—Der Adapter ist mit dem drahtlosen Netzwerk verbunden, kann aber keine IP-Adresse ermitteln.


Land

Legt den Standort des drahtlosen Adapters fest. Zum Herstellen einer Verbindung mit einem drahtlosen Netzwerk oder zum Erstellen eines drahtlosen Netzwerks muss ein Land ausgewählt werden.

Hinweis Hinweis Wenn das Gerät in den Vereinigten Staaten erworben wurde, wählt MAX das Land automatisch aus und speichert es.


Aktuelle Geschwindigkeit

Zeigt die aktuelle Verbindungsgeschwindigkeit des drahtlosen Adapters an.


Kontexthilfe

In diesem Fenster erhalten Sie situationsabhängige Hilfe. Zur Anzeige von Informationen zu einem Bedien- oder Anzeigeelement bewegen Sie den Cursor über das entsprechende Element.


IP-Adresse von einem DHCP-Server beziehen

DHCP oder Link Local

Bei Auswahl dieser Option wird dem System automatisch eine IP-Adresse zugewiesen. Wenn diese Funktion auf dem System unterstützt wird, ist DHCP die Standardeinstellung. Bei Ausfall von DHCP wird eine Link-Local-Adresse (169.254.x.x) gewählt. Link-Local-Adressen sind Netzwerkadressen für lokale Netzwerke.


Speicherplatz (frei)

Ist der freie Speicher des Hauptlaufwerks (z. B. C:) auf diesem System.


Speicherplatz (gesamt)

Ist die gesamte Speicherkapazität des Hauptlaufwerks (z. B. C:) auf diesem System.


DNS-Server

Wenn die IP-Einstellungen zum System im Netzwerk automatisch ermittelt werden, wird in diesem Feld der erkannte DNS-Server angezeigt. Ansonsten ist hier der DNS-Server einzugeben. Weitere Hinweise dazu finden Sie unter Konfigurieren der Netzwerkeinstellungen.


Sommerzeit

Stellt die Uhr auf dem System im Netzwerk automatisch auf Sommerzeit um (ist nicht bei allen Systemen möglich).

Hinweis Hinweis Wenn das Zielsystem nicht die automatische Umstellung für Sommer-/Winterzeit unterstützt, wählen Sie unter Zeitzone das GMT-Äquivalent für Ihren Standort statt der tatsächlichen Zeitzone. Andernfalls sind Zeitstempel möglicherweise nicht korrekt.


EAP-Typ

Gibt die Art des Protokolls an, mit dessen Hilfe der Authentifizierungsserver den Benutzernamen und das Passwort zum Erstellen einer Verbindung mit dem Netzwerk prüft. Folgende Protokolle stehen zur Auswahl:

  • EAP-TLS
  • EAP-TTLS
  • EAP-FAST
  • LEAP
  • PEAP


EtherCAT-Master-ID

Mit einem Wert von 0-255 werden EtherCAT-Master in Ihrem Real-Time-System gekennzeichnet. Sind mehrere EtherCAT-Master auf dem selben Real-Time-Zielsystem vorhanden, müssen diesen eindeutige Master-IDs zugewiesen werden.


Gültig bis

Zeigt an, bis wann das Zertifikat gültig ist.


Gateway

Wenn die IP-Einstellungen zum System im Netzwerk automatisch ermittelt werden, wird in diesem Feld der erkannte Gateway-Server angezeigt. Ansonsten ist hier der Gateway-Server einzugeben. Weitere Hinweise dazu finden Sie unter Konfigurieren der Netzwerkeinstellungen.


Bei IP-Fehler anhalten

Mit dieser Option kann das LabVIEW Real-Time Module bei Verbindungsproblemen, die das Erfassen einer dynamischen Adresse verhindern, nach dem Hochfahren des Netzwerksystems angehalten werden. Wenn das Feld Bei IP-Fehler anhalten deaktiviert wird, fährt LabVIEW Real-Time hoch und führt Startanwendungen aus, selbst wenn beim Starten des Systems keine dynamische Adresse ermittelt wurde.

Es wird empfohlen, diese Option zu deaktivieren und auf der Registerkarte Netzwerkeinstellungen die Option IPv4-Adresse konfigurieren auf DHCP oder Link Local zu setzen.

Hinweis Wenn Ihre Anwendung nicht ohne eine gültige DHCP-Adresse in einem Netzwerk ausgeführt werden soll, wählen Sie auf der Registerkarte Netzwerkeinstellungen die Option Nur DHCP aus und aktivieren Sie Bei IP-Fehler anhalten.


Name

Geben Sie hier einen Namen für das System im Netzwerk ein. Es können bis zu 31 Zeichen eingegeben werden. Namen dürfen nur alphanumerische Zeichen und Bindestriche enthalten. Der Name kann nicht mit einem Bindestrich beginnen oder enden. Wenn Sie das Feld leer lassen, wird das System unter seiner IP-Adresse aufgeführt.


IPv4-Adresse

Wenn die IP-Einstellungen zum System im Netzwerk automatisch ermittelt werden, wird in diesem Feld die zugewiesene IP-Adresse angezeigt. Ansonsten ist hier die IP-Adresse einzugeben. Weitere Informationen zu IP-Adressen finden Sie unter IP-Konfiguration.


Zusätzliche Einstellungen

Ermöglicht gerätespezifische Einstellungen. Für Informationen zu Ihrer Hardware lesen Sie die dazugehörige Hilfe unter Hilfe»Hilfethemen. Sie können aber auch über das Hilfe-Menü oder die Taste <F1> die MAX-Hilfe starten und die Hilfe zu Ihrem Produkt von da aus öffnen.


Ausgegeben von

Zeigt an, von wem das Zertifikat ausgestellt wurde.


Angaben zum Herausgeber

Zeigt an, von wem das Zertifikat ausgestellt wurde. Angaben zum Herausgeber enthält die folgenden Informationen zum Herausgeber des Zertifikats:

  • Allgemeiner Name
  • Stadt
  • Bundesland
  • Land
  • Organisation
  • Organisationseinheit


Ländereinstellung

Gibt den Zeichensatz für die Ausgabetexte des Netzwerksystems an (diese Option muss jedoch von der installierten Software unterstützt werden).


MAC-ID

Zeigt die Haupt-MAC-ID des Systems im Netzwerk an. Diese Adresse wird auch im MAX zur Identifizierung auch verwendet. Wenn das Zielsystem mehrere Netzwerkadapter hat, kann die MAC-ID von der MAC-ID des Hauptnetzwerkadapters abweichen. Durch MAC (Media Access Control) wird ausgeschlossen, dass zwei Geräte gleichzeitig mit der Datenübertragung beginnen.


Primäradapter

Wählt den markierten Ethernet-Adapter als Primäradapter aus.

Hinweis Hinweis Der erste Netzwerkadapter in der Liste kann nicht aktiviert werden, wenn er nicht der Primäradapter ist. Durch das Ändern des Primäradapters wird der ursprüngliche Primäradapter deaktiviert.


Physikalischer Speicher (frei)

Zeigt an, wie viel freier physikalischer Speicher auf diesem Zielsystem zur Verfügung steht.


Größter verfügbarer Speicherblock

Gibt die Größe des größten verfügbaren Speicherblocks des Systems an.


Physikalischer Speicher (gesamt)

Zeigt an, wie viel physikalischer Speicher insgesamt auf dem Zielsystem zur Verfügung steht.


Virtueller Speicher (gesamt)

Zeigt an, wie viel virtueller Speicher insgesamt auf dem System zur Verfügung steht.


Modell

Zeigt das Modell des im Netzwerk befindlichen Systems an.


Angaben zum Modul

Zeigt die Steckplatznummer, das Modell und die Seriennummer für die Module des Geräts an.


Netzwerktyp

Wählen Sie den Netzwerktyp für das drahtlose Netzwerk aus, mit dem eine Verbindung hergestellt oder das erstellt werden soll. Sie können Ad Hoc oder Zugangspunkt aus der Dropdown-Liste Netzwerktyp auswählen.


Gültig ab

Zeigt das Datum an, an welchem das Zertifikat ausgestellt wurde.


Passwort

Geben Sie das Passwort für das mit Hilfe von WPA/WPA2 Enterprise gesicherte Netzwerk ein, das unter Drahtloses Netzwerk ausgewählt wurde.


Geschützter Neustart

Wenn diese Option aktiviert ist, werden für einen Neustart des Systems im Netzwerk ein Benutzername und ein Passwort benötigt.


QoS-Priorität

Setzt die Priorität für die übertragenen Daten über den Adapter für das drahtlose Netzwerk, wenn das drahtlose Gerät den Kanal mit anderen Geräten teilt. Die Voreinstellung lautet Normal.

Es wird empfohlen, die QoS-Priorität auf Normal zu setzen, wenn Sie eine Verbindung mit einem vorhandenen drahtlosen Netzwerk herstellen. Bei einer QoS-Priorität von Kritisch wird möglicherweise die Ausführungsgeschwindigkeit von anderen Geräten in dem drahtlosen Netzwerk verlangsamt. Wenn Ihr Funkzugangspunkt (WAP) 802.11e QoS unterstützt, wird durch Festlegen einer höheren Priorität die Bandbreite Ihres Geräts im drahtlosen Netzwerk erhöht.

Wenn Ihr WAP 802.11e QoS nicht unterstützt, wird als QoS-Priorität die Option Deaktiviert empfohlen.

Hinweis Hinweis Drahtlose Ad-Hoc-Netzwerke unterstützen QoS nicht.
Option im MAX | QoS | 802.11e-Standard
Deaktiviert | Deaktiviert | -
Normal | Aktiviert | Best Effort
Hoch | Aktiviert | Video
Kritisch | Aktiviert | Voice


Sicherheit

Zeigt die Sicherheitseinstellungen für das ausgewählte Netzwerk an. Bei Auswahl von Mit anderem Netzwerk verbinden aus der Dropdown-Liste Drahtloses Netzwerk oder Drahtloses Netzwerk erstellen aus der Dropdown-Liste Drahtlose Verbindung werden unter Sicherheit die folgenden Optionen für die Sicherheitseinstellungen angezeigt:

  • Open
  • WPA Personal
  • WPA2 Personal
  • WPA-Enterprise
  • WPA2-Enterprise
  • WEP


Seriennummer

Zeigt die Seriennummer des im Netzwerk befindlichen Systems an.


SSID

Bei Auswahl von Mit anderem Netzwerk verbinden aus der Dropdown-Liste Drahtloses Netzwerk gibt SSID den öffentlichen Namen des drahtlosen Netzwerks an, mit eine Verbindung hergestellt werden soll.

Bei Auswahl von Drahtloses Netzwerk erstellen aus der Dropdown-Liste Drahtlose Verbindung legt SSID den öffentlichen Namen für das drahtlose Netzwerk fest.


Startmodus

Gibt an, ob Sie den Modus "Master-Redundanz" aktivieren möchten, oder ob während des Starts der normale Modus beibehalten werden soll. Wenn mehrere Zielsysteme mit demselben EtherCAT-Netzwerk verbunden sind, muss der Modus "Master-Redundanz" auf allen Zielsystemen aktiviert werden. Falls der primäre EtherCAT-Master nicht funktioniert, wird der zweite EtherCAT-Master zum primären EtherCAT-Master. Die Option Startmodus kann nicht bei mehreren Netzwerkadaptern auf demselben Zielsystem auf "Master-Redundanz" gesetzt werden.


Systemstatus

Zeigt den aktuellen Status des im Netzwerk befindlichen Systems an. Weitere Informationen entnehmen Sie bitte dem Abschnitt Systemstatus.


Angaben zum Zertifikat

Zeigt den Inhalt des Zertifikats an. Angaben zum Zertifikat enthält folgende Informationen:

  • Allgemeiner Name
  • Stadt
  • Bundesland
  • Land
  • Organisation
  • Organisationseinheit


Subnetzmaske

Wenn die IP-Einstellungen zum System im Netzwerk automatisch ermittelt werden, wird in diesem Feld die erkannte Subnetzmaske angezeigt. Ansonsten ist hier die Subnetzmaske einzugeben. Nähere Hinweise zu diesem Thema finden Sie in der Hilfe zu Systemen im Netzwerk unter Hilfe»Hilfethemen»Netzwerkumgebung.


Zugriff auf Systemkonfiguration

Gibt an, wie auf die Systemkonfigurationseinstellungen des Zielsystems zugegriffen werden kann. Mit Nur lokal können die Einstellungen nur vom Zielsystem aus konfiguriert werden. Lokal und über Netzwerk ermöglicht die Konfiguration sowohl lokal als auch über das Netzwerk.


Aktuelles Datum

Wählen Sie das aktuelle Datum im Kalender zum Festlegen des Datums auf dem Zielsystem.


Aktuelle Zeit

Wird jede Sekunde aktualisiert. Klicken Sie auf Zeit aktiv/inaktiv, um die Zeit anzuhalten. Klicken Sie auf eine Stelle neben dieser Option, um die Zeit weiterlaufen zu lassen.


IP-Adresse

Ein schreibgeschütztes Feld zur Anzeige der aktuellen IP-Adresse. Die IP-Adresse des Zielsystems kann auf der Registerkarte Netzwerkeinstellungen festgelegt werden.


Systembenutzerdaten

Ermöglicht gerätespezifische Einstellungen. Für Informationen zu Ihrer Hardware lesen Sie die dazugehörige Hilfe unter Hilfe»Hilfethemen. Sie können aber auch über das Hilfe-Menü oder die Taste <F1> die MAX-Hilfe starten und die Hilfe zu Ihrem Produkt von da aus öffnen.


Aktuelle Geschwindigkeit

Ein schreibgeschütztes Feld zur Anzeige der aktuellen Verbindungsgeschwindigkeit. Zum Festlegen der bevorzugten Verbindungsgeschwindigkeit lesen Sie den Abschnitt Konfigurieren der Netzwerkeinstellungen.


Paketerkennung

Dient zur Einstellung der Paketerkennung für das Zielsystem. Die möglichen Einstellungen lauten Leitungs-Interrupt, Message-Signaled Interrupts und Polling.

Leitungs-Interrupt | Bei dieser Methode der Signalübertragung wird mit Hilfe von Außenbandsignalen mitgeteilt, dass die Ethernet-Verbindung zum Datenaustausch bereit ist. Hierbei handelt es sich um die Standardmethode von Ethernet-Geräten, mit der die Bereitschaft zur Datenübertragung festgestellt wird.
Message Signaled Interrupts | An unterstützten Geräten kann die Bereitschaft zur Datenübertragung an einer Ethernet-Verbindung mit Hilfe von Message Signaled Interrupts (MSIs) als Methode für Innenbandsignale festgestellt werden. Diese Methode kann für das Betriebssystem effizienter sein als Außenbandsignale, da es die Ressourcen verringert, die zur Verarbeitung von Ethernet-Daten erforderlich sind.
Polling | Das Betriebssystem fragt die Ethernet-Verbindung periodisch nach dem Vorliegen neuer Daten ab. Bei Auswahl von Polling muss angegeben werden, in welchem Abstand sich die Abfrage wiederholen soll.


DNS-Name

Ein schreibgeschütztes Feld zur Anzeige des vollständigen qualifizierten DNS-Namens (FQDN) für das Zielsystem.


IPv4-Adresse konfigurieren

Gibt an, wie das Zielsystem eine IP-Adresse ermittelt. Die verfügbaren Optionen sind in Abhängigkeit Ihres Zielsystem und der installierten Software DHCP oder Link Local, Nur DHCP, Nur Link Local und Statisch.

DHCP oder Link Local | Gibt an, dass die IP-Adresse Ihres Netzwerksystems automatisch mit Hilfe von DHCP ermittelt wird. Wenn DHCP fehlschlägt, ermittelt das Zielsystem eine Link-Local-Adresse, die nur für die Verwendung im lokalen Netzwerk gedacht ist.
Nur DHCP | Gibt an, dass die IP-Adresse automatisch mit Hilfe von DHCP ermittelt wird. Zielsysteme, die mit Hilfe von USB mit dem Host verbunden sind, verwenden diese Option automatisch.
Nur Link Local | Gibt an, dass eine Link-Local-Adresse, die nur für die Verwendung im lokalen Netzwerk gedacht ist, automatisch ermittelt wird.
Statisch | Erlaubt es Ihnen, manuell eine IP-Adresse in das Feld IPv4-Adresse einzugeben.


Auto-MDIX

Legt fest, ob Auto-MDIX unterstützt wird. Auto-MDIX (Auto-Medium Dependent Interface Crossover; mediumabhängige Schnittstelle) erkennt automatisch die Art der Kabelverbindung (gekreuzt oder ungekreuzt) und konfiguriert die Verbindung entsprechend. Daher werden keine Crossover-Kabel mehr benötigt.


MTU

Dient zum Festlegen der MTU (Maximum Transmission Unit). Unter MTU versteht man die maximale Größe eines TCP/IP-Pakets. Durch Erhöhen der MTU lässt sich die Geschwindigkeit für Gigabit-Ethernet-Verbindungen erhöhen, da größere Pakete übertragen werden können.


Polling-Intervall

Gibt bei Geräten, bei denen ankommende Datenpakete durch periodische Abfrage der Verbindung erkannt werden, das Abfrageintervall an. Die Einstellung kann zwischen 1 und 10000 ms liegen. Wenn das Gerät mit Interrupts arbeitet, ist dieses Feld deaktiviert.

Hinweis Hinweis Je nach Art Ihres Netzwerks kann ein Polling-Intervall mit einem Wert von mehr als 1000 ms zu unerwünschtem Verhalten führen.


Bevorzugte Geschwindigkeit

Dient zum Festlegen der bevorzugten Verbindungsgeschwindigkeit. Folgende Optionen stehen zur Verfügung:

  • Autom. Festlegung
  • 10 Mbps/Halbduplex
  • 10 Mbps/Vollduplex
  • 100 Mbps/Halbduplex
  • 100 Mbps/Vollduplex
  • Gigabit/Halbduplex
  • Gigabit/Vollduplex
Weitere Hinweise dazu finden Sie unter Konfigurieren der Netzwerkeinstellungen.


Vorige IP-Adresse anfordern

Aktivieren Sie dieses Feld zum Anfordern der vorherigen IP-Adresse vom DNS-Server.


Zeitzone

Ist die Zeitzone des Systems im Netzwerk. Mit Hilfe dieses Werts wird die korrekte Systemzeit ausgegeben.

Hinweis Hinweis Wenn das Zielsystem nicht die automatische Umstellung auf Sommer-/Winterzeit unterstützt, wählen Sie unter Zeitzone das GMT-Äquivalent für Ihren Standort statt der tatsächlichen Zeitzone. Andernfalls sind Zeitstempel möglicherweise nicht korrekt.


Benutzername

Geben Sie den Benutzernamen für das mit Hilfe von WPA/WPA2 Enterprise gesicherte Netzwerk ein, das unter Drahtloses Netzwerk ausgewählt wurde.


WEP-Sicherheitsschlüssel

Bei Auswahl von Mit drahtlosem Netzwerk verbinden aus der Dropdown-Liste Drahtlose Verbindung oder Anderes Netzwerk aus der Dropdown-Liste Drahtloses Netzwerk ist der WEP-Sicherheitsschlüssel das erforderliche Passwort für das WEP-gesicherte Netzwerk, mit dem eine Verbindung hergestellt werden soll.

Bei Auswahl von Drahtloses Netzwerk erstellen aus der Dropdown-Liste Drahtlose Verbindung legt WEP-Sicherheitsschlüssel den erforderlichen Schlüssel für das WEP-gesicherte Netzwerk fest, das erstellt wird.


Drahtlose Verbindung

Drahtlose Verbindung ist Mit drahtlosem Netzwerk verbinden, wenn eine Verbindung mit einem vorhandenen drahtlosen Netzwerk erstellt werden soll. Wählen Sie Drahtloses Netzwerk erstellen zum Erstellen eines Ad-Hoc-Netzwerks für den ausgewählten Adapter. Weitere Hinweise dazu finden Sie unter Konfigurieren der Netzwerkeinstellungen.


Drahtloses Netzwerk

Zeigt eine Liste mit allen für das ausgewählte Gerät verfügbaren drahtlosen Netzwerke an. Sie können auch Anderes Netzwerk auswählen, um manuell eine Verbindung zu einem drahtlosen Netzwerk zu erstellen, das nicht in der Dropdown-Liste angezeigt wird.


WPA-Passphrase

Bei Auswahl von Mit drahtlosem Netzwerk verbinden aus der Dropdown-Liste Drahtlose Verbindung oder Anderes Netzwerk aus der Dropdown-Liste Drahtloses Netzwerk ist die WPA-Passphrase das erforderliche Passwort für das WPA-gesicherte Netzwerk, mit dem eine Verbindung hergestellt werden soll.

Bei Auswahl von Drahtloses Netzwerk erstellen aus der Dropdown-Liste Drahtlose Verbindung legt WPA-Passphrase das erforderliche Passwort für das WPA-gesicherte Netzwerk fest, das erstellt wird.


Abbrechen

Mit dieser Schaltfläche verlassen Sie das Dialogfeld, ohne dass die Einstellungen gespeichert werden.


OK

Beim Anklicken dieser Schaltfläche werden Ihre Änderungen gespeichert und das Dialogfeld wird geschlossen.


Anmelden auf dem System

Sie können verhindern, dass nicht autorisierte Benutzer Systemeinstellungen ändern, indem Sie ein Administratorpasswort und Berechtigungen festlegen. Nicht alle Geräte unterstützen die Möglichkeit der Anmeldung.

Hinweis Nur die Netzwerkeinstellungen, Systemeinstellungen, Zeiteinstellungen, der Software-Assistent für LabVIEW Real-Time und verschiedene VISA/PXI-Einstellungen werden durch das Anmelden vor unbefugtem Zugriff geschützt.

Schützen der Systemkonfiguration auf Zielsystemen mit LabVIEW Real-Time ab Version 2010

Bei Zielsystemen mit LabVIEW Real-Time ab Version 2010 wird die Systemkonfiguration durch einen Benutzernamen und ein Passwort geschützt. Jedes Netzwerkgerät hat per Voreinstellung einen Nutzer mit folgendem Namen und Passwort:

  • Benutzername—admin
  • Passwort—<leer>

Zum Anmelden auf dem Zielsystem, um dort Änderungen vorzunehmen, führen Sie folgende Schritte aus:

  1. Klicken Sie im MAX auf die Schaltfläche Anmelden in der Symbolleiste.
  2. Geben Sie admin in das Feld Benutzername ein.
  3. Lassen Sie das Feld Passwort leer.
  4. Klicken Sie auf die Schaltfläche OK.

Sichern eines Netzwerkgeräts

Zum Sichern eines Netzwerkgeräts gehen Sie wie folgt vor:

  1. Zum Öffnen der Seite "Sicherheitskonfiguration" in einem Browser klicken Sie im MAX auf die Schaltfläche Berechtigungen festlegen in der Symbolleiste.
  2. Klicken Sie auf Anmelden und geben Sie admin in das Feld Benutzername ein.
  3. Lassen Sie das Feld Passwort leer, wenn Sie das Standardpasswort nicht geändert haben, oder geben Sie das aktuelle Passwort ein.
  4. Klicken Sie in der Liste der Benutzer auf der Registerkarte Benutzer doppelt auf admin.
  5. Geben Sie im Feld Neues Passwort ein sicheres Passwort ein.
  6. Geben Sie das Passwort erneut in das Feld Passwort erneut eingeben ein.
  7. Klicken Sie auf die Schaltfläche Speichern.
  8. Klicken Sie zum Speichern der Änderungen am System auf die Schaltfläche Änderungen hochladen.
  9. Kehren Sie zum MAX zurück und melden Sie sich mit dem neuen Passwort an.
Achtung Zum Schützen Ihres Netzwerkgeräts müssen Sie das Standardpasswort ändern. Des Weiteren müssen alle Berechtigungen von der Gruppe "everyone" entfernt werden.

Entfernen von Berechtigungen der Gruppe "Everyone"

Führen Sie zum Entziehen aller Berechtigungen der Gruppe "everyone" folgende Schritte aus:

  1. Klicken Sie auf die Registerkarte Gruppen.
  2. Klicken Sie doppelt auf die Gruppe "everyone".
  3. Deaktivieren Sie alle Optionen in der Spalte Berechtigung?.
  4. Klicken Sie auf die Schaltfläche Speichern.
  5. Klicken Sie zum Speichern der Änderungen am System auf die Schaltfläche Änderungen hochladen.

Erstellen eines neuen Benutzerkontos

Gehen Sie zum Erstellen eines neuen Benutzerkontos wie folgt vor:

  1. Zum Öffnen der Seite "Sicherheitskonfiguration" in einem Browser klicken Sie im MAX auf die Schaltfläche Berechtigungen festlegen in der Symbolleiste.
  2. Klicken Sie auf Anmelden und geben Sie admin in das Feld Benutzername ein.
  3. Lassen Sie das Feld Passwort leer, wenn Sie das Standardpasswort nicht geändert haben, oder geben Sie das aktuelle Passwort ein.
  4. Zum Erstellen eines neuen Benutzerkontos klicken Sie auf die Schaltfläche Neuer Benutzer.
  5. Ersetzen Sie den Standardbenutzernamen im Feld Benutzername durch Ihren Benutzernamen.
  6. Geben Sie im Feld Neues Passwort ein sicheres Passwort ein.
  7. Geben Sie das Passwort erneut in das Feld Passwort erneut eingeben ein.
  8. (Optional) Geben Sie im Feld Kommentare eine Beschreibung des neuen Benutzerkontos ein.
  9. Setzen Sie im Feld Gruppe(n) vor alle Kästchen für Gruppen ein Häkchen, denen das neue Benutzerkonto angehören soll.
  10. Setzen Sie im Feld Berechtigung(en) vor alle Kästchen für Berechtigungen ein Häkchen, die das neue Benutzerkonto erhalten soll.
  11. Klicken Sie auf die Schaltfläche Speichern.
  12. Klicken Sie zum Speichern der Änderungen am System auf die Schaltfläche Änderungen hochladen.
  13. Kehren Sie zum MAX zurück und melden Sie sich mit dem neuen Benutzernamen und Passwort an.
Tipp Tipp Aktivieren Sie zum Erstellen eines sicheren Kontos für einen Nicht-Administrator die Mindestberechtigungen, die zum Ausführen der Tasks des Benutzers notwendig sind. Zur Anzeige einer Beschreibung für jede Berechtigung klicken Sie auf die Schaltfläche Hilfe in der rechten oberen Ecke der Seite Sicherheitskonfiguration.

Für weitere Informationen zum Festlegen von Berechtigungen klicken Sie auf Hilfe auf der Seite "Sicherheitskonfiguration".

Schützen der Systemkonfiguration auf Zielsystemen mit LabVIEW Real-Time bis Version 2009

Auf Zielsystemen mit LabVIEW Real-Time bis Version 2009 wird der Schutz über Sperren aktiviert. Die Systemkonfiguration wird folgendermaßen mit einem Passwort versehen:

  1. Wählen Sie in der Übersicht ein Netzwerksystem aus und klicken Sie in der Symbolleiste auf Berechtigungen festlegen.
  2. Geben Sie im angezeigten Dialogfeld ein Administratorpasswort ein und bestätigen Sie es.
  3. Klicken Sie anschließend auf OK.
  4. Klicken Sie zum Beenden auf Abmelden.
  5. Zum Vornehmen weiterer Änderungen am Zielsystem klicken Sie auf Anmelden und geben Sie das Administratorpasswort ein.

Aufheben der Sperre der Systemkonfiguration

Führen Sie zum Aufheben der Sperre der Systemkonfiguration folgende Schritte aus:

  1. Klicken Sie auf Berechtigungen festlegen und geben Sie das korrekte Administratorpasswort ein, wenn Sie dazu aufgefordert werden.
  2. Wählen Sie Sperre aufheben im angezeigten Dialogfeld aus.
  3. Klicken Sie auf OK.

Ändern des Administratorpassworts

Führen Sie zum Ändern des Administratorpasswort folgende Schritte aus:

  1. Klicken Sie auf Berechtigungen festlegen und geben Sie das korrekte Administratorpasswort ein, wenn Sie dazu aufgefordert werden.
  2. Wählen Sie Passwort ändern im angezeigten Dialogfeld aus.
  3. Geben Sie das neue Administratorpasswort ein und bestätigen Sie es.
  4. Klicken Sie auf OK.
Tipp Tipp Aktivieren Sie die Option Neustart nur mit Passwort, wenn Benutzer zum Neustart eines Netzwerksystems einen Benutzernamen und ein Passwort eingeben müssen.

Steuern von passwortgeschützten Real-Time-Systemen von LabVIEW aus

Mit dem Passwort wird sichergestellt, dass ein Host-Computer über LabVIEW Real-Time kein System im Netzwerk steuert, das nicht unter RT Target: Access in LabVIEW aufgeführt ist. Zum Aufrufen dieser Liste von LabVIEW klicken Sie mit der rechten Maustaste auf ein Projektfenster und wählen Sie Properties.


Umgang mit dem Software-Assistenten für LabVIEW Real-Time

Zum Herunterladen von Software mit Hilfe des Software-Assistenten für LabVIEW Real-Time gehen Sie wie folgt vor:

  1. Wenn Sie den Software-Assistenten für LabVIEW Real-Time noch nicht gestartet haben, gehen Sie wie folgt vor:
    1. Erweitern Sie die Kategorie "Netzwerkumgebung" und das RT-Zielsystem.
    2. Wählen Sie Software. Klicken Sie in der Symbolleiste auf das Symbol Software hinzufügen/entfernen. Wenn es für das System keine Software-Kategorie gibt, arbeitet Ihr System nicht mit LabVIEW Real-Time.
    Hinweis Hinweis Wenn ein Anmeldepasswort eingerichtet wurde, werden Sie zur Eingabe des Administratornamens und des Passworts für das Real-Time-System aufgefordert. Weitere Informationen entnehmen Sie bitte dem Abschnitt Anmelden auf dem System.
  2. Entscheiden Sie die weitere Vorgehensweise. Wenn auf Ihrem Real-Time-Zielsystem empfohlene Software verwendet wird, lesen Sie den Abschnitt Installieren von empfohlener Software. Wenn auf dem Real-Time-Zielsystem benutzerdefinierte Software verwendet wird, finden Sie Hinweise unter Installieren einer benutzerdefinierten Auswahl von Softwarekomponenten.


Anleitung zur Konfiguration von Real-Time-Systemen in einem Netzwerk

Nachfolgend wird die Konfiguration eines Echtzeitsystems (Real-Time-Systems) im Netzwerk für das LabVIEW Real-Time Module erläutert.

  1. Starten des Systems in LabVIEW Real-Time
    Das Netzwerksystem muss zunächst in LabVIEW Real-Time gestartet werden. Wenn auf dem System bei der Lieferung nur LabVIEW Real-Time installiert war, startet es automatisch in LabVIEW Real-Time. Wenn Ihr System kein Diskettenlaufwerk hat, dann hat es möglicherweise DIP-Schalter oder BIOS-Einstellungen für das Hochfahren in LabVIEW Real-Time. Weitere Informationen finden Sie unter Starten des Systems LabVIEW Real-Time.

    Sie können die Festplatte mit Hilfe der Desktop-PC-Utility für USB-Laufwerke permanent formatieren und so konfigurieren, dass direkt in Real-Time gebootet wird.
  2. Konfigurieren der Netzwerkeinstellungen
    Prüfen Sie, ob Ihr Real-Time-System erkannt wurde, indem Sie die Kategorie Netzwerkumgebung erweitern (klicken Sie dazu das [+]-Zeichen neben Netzwerkumgebung an). Wenn noch keine IP-Adresse für das System angegeben wurde, wird es unter der Adresse 0.0.0.0 geführt. Wenn das Gerät nicht angezeigt wird, drücken Sie <F5>, um die Ansicht zu aktualisieren. Geräte, die noch nicht mit einer IP-Adresse versehen wurden, müssen sich im selben Subnetz wie der Host befinden, damit eine IP-Adresse dafür eingerichtet werden kann. Wenn es für das Gerät bereits eine IP-Adresse gibt, es sich jedoch nicht im lokalen Subnetz befindet, fügen Sie es der Kategorie Netzwerkumgebung hinzu, indem Sie diese mit der rechten Maustaste anklicken und Neu auswählen. Folgen Sie dann den angezeigten Anweisungen, um das System hinzuzufügen.

    Hinweis Vergewissern Sie sich, dass alle Firewalls deaktiviert sind. Manche Firewalls blockieren die IP-Adresse 0.0.0.0 auch dann noch, wenn das Herstellen einer Verbindung in Ausnahmefällen zugelassen wird.

    Wenn Sie ein DHCP-Netzwerk verwenden, setzen Sie IPv4-Adresse konfigurieren auf DHCP oder Link Local. Nicht alle DHCP-Server arbeiten gleich. Daher kann es vorkommen, dass bestimmte Server mit dem LabVIEW Real-Time Module nicht kompatibel sind. Nach Auswahl von DHCP oder Link Local und Neustart des Controllers fragt LabVIEW Real-Time den DHCP-Server nach einer IP-Adresse. Wenn diese Operation fehlschlägt, wird der Controller erneut gestartet. Wenn das System die automatische IP-Zuweisung unterstützt, sucht es nach einer Link-Lokal-Adresse (169.254.x.x) und startet damit das restliche System. Nach drei fehlgeschlagenen Versuchen nimmt das Programm mit der IP-Adresse 0.0.0.0 wieder die Ausgangskonfiguration an. In diesem Fall müssen die Netzwerkparameter per Hand eingegeben werden.

    Wenn Sie manuelle eine IP-Adresse festlegen müssen, wählen Sie Statisch und geben Sie eine IP-Adresse ein. Wenn es im Netzwerk weder einen Gateway-Server noch ein DNS gibt, setzen Sie beide Werte auf 0.0.0.0.

    Für weitere Hinweise zur Netzwerkkonfiguration lesen Sie bitte den Abschnitt Konfigurieren der Netzwerkeinstellungen.

  3. Installieren der Software
    Wenn Sie einem System im Netzwerk eine IP-Adresse zugewiesen haben, können Sie auf dem System das LabVIEW Real-Time Module installieren.

    Sollte LabVIEW Real-Time bereits vorhanden sein, müssen unter Umständen zusätzliche Treiber geladen werden oder es sind Updates erforderlich.

    Zum Herunterladen von Software mit Hilfe des Software-Assistenten für LabVIEW Real-Time gehen Sie wie folgt vor:
    1. Erweitern Sie die Kategorie Netzwerkumgebung und klicken Sie den Namen des Real-Time-Systems doppelt an.
    2. Wählen Sie Software. Klicken Sie in der Symbolleiste auf das Symbol Software hinzufügen/entfernen, um den Software-Assistenten für LabVIEW Real-Time zu starten. Wenn es für das System keine Software-Kategorie gibt, arbeitet Ihr System nicht mit LabVIEW Real-Time. Entscheiden Sie die weitere Vorgehensweise. Wenn auf Ihrem Zielsystem empfohlene Software verwendet wird, lesen Sie den Abschnitt Installieren von empfohlener Software. Wenn auf dem System benutzerdefinierte Software verwendet wird, finden Sie Hinweise unter Installieren einer benutzerdefinierten Auswahl von Softwarekomponenten.
      Hinweis Wenn auf dem Host-Computer ein Treiber installiert ist, der nicht im Software-Assistenten für LabVIEW Real-Time angezeigt wird, ist möglicherweise die Real-Time-Komponente des Treibers nicht installiert. Dieses Problem tritt häufig auf, wenn Treiber vor dem LabVIEW Real-Time Module installiert wurden. Zum Beheben dieses Problems klicken Sie mit der rechten Maustaste auf Mein System»Software in der Baumstruktur im MAX und wählen Sie Software hinzufügen/ändern zur Modifizierung des installierten Treibers, um die LabVIEW-Real-Time-Komponenten hinzuzufügen.
    3. Konfigurieren der Systemeinstellungen
      Sie können mehrere Systemeinstellungen für Ihr LabVIEW-Real-Time-System vornehmen, und zwar "Name", "Sprache" und "Bei IP-Fehler anhalten". Außerdem können Sie Kommentare hinzufügen.

      Sie können auch einen aussagekräftigeren Namen für das System und Kommentare zum System und seinen Komponenten eingeben. Nach Beendigung klicken Sie auf die Schaltfläche Speichern am oberen Bildschirmrand, damit alle Änderungen gespeichert werden.

      Über die Spracheinstellung wird festgelegt, mit welchem Zeichensatz die Meldungen dargestellt werden sollen, die vom Real-Time-System empfangen werden. Wenn keines der auf Ihrem Real-Time-System vorhandenen Programme diese Einstellung unterstützt, ist die Option deaktiviert.

      Weitere Informationen zu diesen Einstellungen finden Sie im Abschnitt Konfigurieren der Systemeinstellungen.
    4. Konfigurieren der Zeiteinstellungen
      Auf der Registerkarte "Zeiteinstellungen" können Sie Einstellungen zur Zeitzone, in der sich das Zielsystem befindet, und zur Sommer-/Winterzeit vornehmen. Diese Einstellung dient beispielsweise den LabVIEW-VIs für Datum und Zeit zur korrekten Angabe der Zeit, insbesondere bei der Umstellung auf die Sommerzeit.

      Wenn auf Ihrem Zielsystem LabVIEW 2010 oder eine neuere LabVIEW-Version verwendet wird, können Sie Datum und Zeit sowie Angaben zur Synchronisation festlegen, sofern das Zielsystem dies unterstützt.

      Weitere Informationen zu Zeiteinstellungen finden Sie im Abschnitt Konfigurieren der Zeiteinstellungen.
    5. Konfigurieren des Datenaustauschs
      Bevor I/O-Hardware von NI von einer LabVIEW-Real-Time-Anwendung aus aufgerufen werden kann, muss sie konfiguriert werden. Die genaue Vorgehensweise dazu wird unter Konfigurieren der Geräte und in der Gerätebeschreibung erläutert.

Nach Ausführung dieser Schritte ist Ihr System für den Zugriff über das LabVIEW Real-Time Module bereit.