Licensing User's Guide: Licensing User's Guide

Keil, An ARM® Company Licensing User's Guide

All Keil Software products are licensed and grant one year of technical support and product maintenance.

  • License Agreements and Terminology provides copies of the license agreements for the Keil products and terminology terms.
  • License Management provides information about the licensing process within µVision and includes detailed descriptions for installing and using the various licensing methods.
  • Licensing Errors lists the errors that may occur when licensing the tools.

Revision History

  • December 2018: Updated License Agreement for MDK v5.27 (pre-release) and above.
  • February 2013: FlexNet Server Setup added.
  • March 2012: License Agreement for MDK-ARM has been adapted to reflect the new editor's authorization.
  • December 2011: Flex Licensing method added.
  • March 2011: Copy of License Agreement MDK-ARM added.
  • Sept 2009: Extended with latest products and pictures.
  • Jun 2006: Adjusted images to reduce the width of pages.
  • October 2005: Added detailed descriptions for licensing.
  • December 2004: Revisions for Single-User Licenses and Floating Licenses.
  • January 2004: Initial revision in CHM format.

Copyright © Keil, An ARM Company. All rights reserved.


Licensing User's Guide: License Agreement C51, C166, C251

License Agreement C51, C166, C251

11 June 2012 LEC-ELA-00203 SP-Version: 2.0

END USER LICENCE AGREEMENT FOR ARM KEIL SOFTWARE DEVELOPMENT TOOLS

THIS END USER LICENCE AGREEMENT (“LICENCE”) IS A LEGAL AGREEMENT BETWEEN YOU (EITHER A SINGLE INDIVIDUAL, OR SINGLE LEGAL ENTITY) AND ARM LIMITED ("ARM") FOR THE USE OF THE SOFTWARE ACCOMPANYING THIS LICENCE. ARM IS ONLY WILLING TO LICENSE THE SOFTWARE TO YOU ON CONDITION THAT YOU ACCEPT ALL OF THE TERMS IN THIS LICENCE. BY CLICKING “I AGREE” OR BY INSTALLING OR OTHERWISE USING OR COPYING THE SOFTWARE YOU INDICATE THAT YOU AGREE TO BE BOUND BY ALL THE TERMS OF THIS LICENCE. IF YOU DO NOT AGREE TO THE TERMS OF THIS LICENCE, ARM IS UNWILLING TO LICENSE THE SOFTWARE TO YOU AND YOU MAY NOT INSTALL, USE OR COPY THE SOFTWARE, AND YOU SHOULD PROMPTLY RETURN THE SOFTWARE TO YOUR SUPPLIER AND ASK FOR A REFUND OF ANY LICENCE FEE PAID.

“Licence Key” means an electronic numbered licence key issued to you by ARM to enable the use of the Software, or the built-in evaluation mode (“Evaluation Only”) that enables, the use of the Software.

“Seat” means a written or electronic authorization from ARM to use and run certain components or features of the Software, only in the quantities and for the time periods stated therein, and (if applicable) only with the target devices.

“Separate Files” means the separate files identified in Section 2 of the Schedule.

“Software” means any software, firmware and data accompanying this Licence, any printed, electronic or online documentation supplied with it, and any updates, upgrades, patches and modifications ARM may agree to make available to you under the terms of this Licence, for the ARM KEIL package of software development tools. The package includes; (i) ARM KEIL compilation tools targeting C166, C51, C251 and related microcontroller processor architectures, including compiler, assembler, linker, libraries and example code; (ii) KEIL uVision integrated development environment (IDE); (iii) simulation models targeting standard MCU devices; (iv) example application code identified in Section 1B of the Schedule (“Example Code ”); and (v) real time operating systems in source code form identified in Section 1C of the Schedule (individually or together “Tiny-RTOS”).

1. LICENCE GRANTS.
(i) SOFTWARE: ARM hereby grants to you, subject to the terms and conditions of this Licence, a non-exclusive, non-transferable licence, only for the Seats, to; (a) use the Software, solely for the purposes of developing, testing, debugging, analysing and optimising software applications (referred to in this Licence as “Software Applications”); and (b) use copy and modify any or all of the Example Code and Tiny-RTOS as specimen Software Applications. Except as may be permitted by clauses 1 (ii) – 1(iii) below, you shall not modify or redistribute any of the Software.

(ii) LIBRARIES: In respect of any language libraries and helper libraries identified in Section 1A of the Schedule (together “Target Libraries”), ARM hereby grants you, provided you comply with the terms of clause 1(iv), additional non-exclusive, non-transferable licences to; (a) incorporate and link the language libraries into or with Software Applications, provided that Software Applications contain substantial additional functionality; (b) incorporate and link the helper libraries into, or use them in, Software Applications; and (c) reproduce and distribute the Target Libraries, only in object code form, and only as part of Software Applications.

(iii) EXAMPLE CODE AND TINY-RTOS: In respect of any Example Code or Tiny-RTOS, ARM hereby grants you, provided you comply with the terms of clause 1(iv), additional non-exclusive, non-transferable licences to; (a) use copy and (if supplied in source code form) modify the Example Code or Tiny-RTOS, only for internal testing, evaluation, and development and testing of Software Applications; (b) incorporate, compile and link the Example Code and Tiny-RTOS, and any modifications, into Software Applications; (c) reproduce and distribute the Example Code and Tiny-RTOS, and any modifications, only in object code form, and only as part of Software Applications.

(iv) REDISTRIBUTION AND CONDITIONS ON REDISTRIBUTION: ARM herby grants to you, provided you comply with terms of this clause 1 (iv), additional non-exclusive, non-transferable licenses to permit either or both your customers and your authorised distributors to redistribute any or all of the Example Code and Tiny-RTOS, and any modifications you make thereto, only in object form and only as part of Software Applications developed by you or your pertmitted users (identified in clause 2 paragraph three “PERMITTED USERS” below).

If you are authorised and choose to redistribute the whole or any part of the Target Libraries, Example Code, or Tiny-RTOS, you agree; (a) to ensure that they are licensed for use (1) only as part of Software Applications developed by you or your permitted users, and (2) except where the Software Applications are developed using only those compilers and libraries in the Software which do not target the ARM microprocessor architecture, only on microprocessors manufactured or simulated under licence from ARM; (b) not to use ARM’s or any of its licensors names, logos or trademarks to market Software Applications; (c) to include valid copyright notices on Software Applications, and preserve any copyright notices which are included with, or in, the Target Libraries, Example Code, and Tiny-RTOS; and (d) to ensure that any further redistribution of the Target Libraries, Example Code, or Tiny-RTOS is limited to redistribution by either or both your customers and your authorised distributors solely as part of Software Applications developed by you and your permitted users and that your customers and your authorised distributors comply with the terms of this Clause 1(iv).

2. RESTRICTIONS ON USE OF THE SOFTWARE.
SEATS, INSTALLATION AND LICENCE KEYS: Your use of the Software is limited to the specific number of Seats issued to you by ARM. For each Seat, ARM will make a Licence Key available to you to enable use of the Software, or certain components or optional functionality in the Software, as applicable. You shall only install and use the Software and Licence Keys on computers, or virtual machines running on computers, which are owned by you (or which are in your exclusive possession under an equipment finance arrangement) and which are either; (i) located at your premises; or (ii) portable computers which shall remain in the possession and control of your employees when outside such premises. Each Seat and Licence Key shall be limited or locked to a single item of your computer hardware (also known as host ID) on which the Seat or Licence Key is initially installed, except where ARM may separately agree to authorise the transfer (also known as re-hosting) of such Seat or Licence Key to another host ID.

COPYING: You shall not use or copy the Software or Licence Keys except as expressly authorised in this Licence. You may make one additional copy of the delivered Software media or image for backup or archival purposes.

PERMITTED USERS: The Software and Licence Keys shall only be used by your employees, or by your bona fide sub-contractors for whose acts and omissions you hereby agree to be responsible to ARM to the same extent as those of your employees, and provided always that such sub-contractors; (i) work only onsite at your premises; (ii) comply with the terms of this Licence; (iii) are contractually obligated to use the Software and Licence Keys only for your benefit, and (iv) agree to assign all their work product and any rights they create therein in the supply of such work to you. Only the single individual, company or other legal entity to whom ARM is supplying this Licence may use the Software and Licence Keys. Except as provided in this clause, you shall not allow third parties (including but not limited to any subsidiary, parent or affiliated companies, or offsite contractors you may have) to use the Software or Licence Keys unless ARM specifically agrees otherwise with you on a case by case basis.

REMOTE USE: The Software and Licence Keys shall only be used onsite at your premises, except when used offsite by an employee (but not a sub-contractor) of yours, on a portable computer, in accordance with the “SEATS, INSTALLATION AND LICENCE KEYS” paragraph above, as part of his or her normal work activities, and only for your benefit.

MULTIPLE VERSIONS: The media on which the Software resides may contain more than one version of the Software, each of which is compatible with a different operating system (such as Microsoft Windows XP Professional and Red Hat Linux). Each version may only be installed and used by you to the extent that you have valid Seats and Licence Keys from ARM. To the extent that certain components of the Software are identified for use on a specific operating system, you are only licensed to use such components to develop Software Applications for use with the relevant operating system or future compatible versions of such operating system.

EVALUATION USE RESTRICTION: If your Licence Key is evaluation only, or the Software is identified as an evaluation version (collectively “Evaluation Software”), then notwithstanding anything else in this Licence, YOU AGREE THAT YOUR USE OF THE SOFTWARE IS TECHNICALLY LIMITED, INCLUDING BUT NOT LIMITED TO TECHNICAL RESTRICTIONS IN RESPECT OF THE CODE IN WHICH IT SUPPORTS, COMPILES AND DEBUGS, AS IDENTIFIED IN THE TECHNICAL LIMITATIONS DOCUMENT SET OUT AT http://www.keil.com/demo/limits.asp.

ACADEMIC OR EDUCATIONAL USE RESTRICTION: If you or your employer or institution paid academic or educational pricing for the Software, or the Software is identified as an academic or educational version (collectively “Academic Software”), then notwithstanding anything else in this Licence, YOU AGREE TO USE THE SOFTWARE ONLY FOR ACADEMIC, NON-COMMERCIAL PURPOSES, AND ARM DOES NOT GRANT YOU ANY RIGHTS TO DISTRIBUTE OR SUB-LICENCE SOFTWARE APPLICATIONS UNDER THIS LICENCE.

REVERSE ENGINEERING: Except to the extent that such activity is permitted by applicable law you shall not reverse engineer, decompile or disassemble any of the Software. If the Software was provided to you in Europe you shall not reverse engineer, decompile or disassemble any of the Software for the purposes of error correction.

BENCHMARKING: This licence does not prevent you from using the Software for internal benchmarking purposes. However, you shall treat any and all benchmarking data relating to the Software, and any other results of your use or testing of the Software which are indicative of its performance, efficacy, reliability or quality, as confidential information and you shall not disclose such information to any third party without the express written permission of ARM.

RESTRICTIONS ON TRANSFER OF LICENSED RIGHTS: The rights granted to you under this Licence may not be assigned, sublicensed or otherwise transferred by you to any third party without the prior written consent of ARM. An assignment shall be deemed to include, without limitation; (i) any transaction or series of transactions whereby a third party acquires, directly or indirectly, the power to control the management and policies of you, whether through the acquisition of voting securities, by contract or otherwise; or (ii) the sale of more than fifty percent (50%) of your assets whether in a single transaction or series of transactions. You shall not rent or lease the Software.You shall not share the Software with contractors (except as identified in the “PERMITTED USERS” paragraph above) or other third parties.

COPYRIGHT AND RESERVATION OF RIGHTS: The Software is owned by ARM or its licensors and is protected by copyright and other intellectual property laws and international treaties. The Software is licensed not sold. You acquire no rights to the Software other than as expressly provided by this Licence. You shall not remove from the Software any copyright notice or other notice and shall ensure that any such notice is reproduced in any copies of the whole or any part of the Software made by you.

3. SUPPORT AND MAINTENANCE.
If you purchased the Software directly from ARM, and you are not receiving it as either or both, as applicable, Evaluation Software (defined in Clause 2) and Academic Software (defined in Clause 2), you are entitled to reasonable support and maintenance for the Software, for the shorter period of; (i) the term of your licence to the Software (as specified by the Licence Key); and (ii) one (1) year, commencing on the date of purchase.

Support will be provided on any version of the Software components defined in your Seat which, at the date of your support request, is either (a) the current version made generally available by ARM, or (b) the previous version made generally available by ARM at some time during the previous ninety (90) days.

Support will be provided by telephone, email or other written format designated by ARM, prioritised at ARM’s discretion, and may not be used as a substitute for training or as additional resource for your programming projects. Maintenance will be provided in the form of updates, upgrades and patch releases to the Software as and when they are made generally available from ARM. Any updates and upgrades replace the earlier releases of the Software that you are updating and upgrading, and are not additional copies. When you update or upgrade the Software, as applicable, the Licence Key for such new release replaces your existing Licence Key. Therefore, if you are receiving the Software as an update or upgrade, you obtain no rights to and shall not install or use the update or upgrade, as applicable, unless you have ceased all use of, and deleted your Licence Key for the version of the Software that you are updating or upgrading, as applicable.

ARM’s obligation under this Clause 3 is limited to the provision of support and maintenance to you and ARM is under no obligation to provide any support and maintenance to any third parties under this Licence. If you purchase support and maintenance for additional years it will be provided pursuant to this Clause 3 and will be subject to the terms and conditions of this Licence.

If; (i) you obtained the Software from an ARM authorised reseller or other third party, or; (ii) the Software was provided free of charge or it is Evaluation Software; or (iii) the Software is Academic Software, you are not entitled to any support for the Software from ARM but ARM may, at its sole discretion provide limited support to you. The vendor of the Software may or may not offer support to you for the Software. Please refer to the Technical Support area of http://www.arm.com for contact details for ARM’s support service and (if applicable) other authorised support channels.

4. CONFIDENTIALITY.
You acknowledge that the Software, Licence Keys, any benchmarking data and related information mentioned in Clause 2 contain trade secrets and confidential material, and you agree to maintain all such information in confidence and apply security measures no less stringent than the measures which you apply to protect your own like information, but not less than a reasonable degree of care, to prevent their unauthorised disclosure and use. Subject to any restrictions imposed by applicable law, the period of confidentiality shall be indefinite. You agree that you shall not use any such information other than in normal use of the Software under the licences granted in this Licence.

5. LIMITED WARRANTIES.
For the period of ninety (90) days from the date of receipt by you of the Software, unless the Software is Evaluation Software, ARM warrants to you that (i) the media on which the Software is provided shall be free from defects in materials and workmanship under normal use; and (ii) the Software will perform substantially in accordance with its accompanying documentation (if any). ARM's total liability and your exclusive remedy for breach of these limited warranties shall be limited to ARM, at ARM's option; (a) refunding the price paid by you for the Software; or (b) replacing the defective Software; or (c) using reasonable efforts to correct material, documented, reproducible defects in the Software and delivering such corrected Software to you. Any replacement Software will be warranted for the remainder of the original warranty period or thirty (30) days, whichever is longer.

EXCEPT AS MAY BE PROVIDED ABOVE, YOU AGREE THAT THE SOFTWARE IS LICENSED “AS IS”, AND THAT ARM EXPRESSLY DISCLAIMS ALL REPRESENTATIONS, WARRANTIES, CONDITIONS OR OTHER TERMS, EXPRESS OR IMPLIED, INCLUDING WITHOUT LIMITATION THE IMPLIED WARRANTIES OF NON-INFRINGEMENT, SATISFACTORY QUALITY, AND FITNESS FOR A PARTICULAR PURPOSE.

YOU EXPRESSLY ASSUME ALL LIABILITIES AND RISKS, FOR USE OR OPERATION OF SOFTWARE APPLICATIONS, INCLUDING WITHOUT LIMITATION, APPLICATIONS DESIGNED OR INTENDED FOR MISSION CRITICAL APPLICATIONS, SUCH AS PACEMAKERS, WEAPONARY, AIRCRAFT NAVIGATION, FACTORY CONTROL SYSTEMS, ETC. SHOULD THE SOFTWARE PROVE DEFECTIVE, YOU ASSUME THE ENTIRE COST OF ALL NECESSARY SERVICING, REPAIR OR CORRECTION.

6. LIMITATION OF LIABILITY.
TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW, IN NO EVENT SHALL ARM BE LIABLE FOR ANY INDIRECT, SPECIAL, INCIDENTAL OR CONSEQUENTIAL DAMAGES (INCLUDING LOSS OF PROFITS) ARISING OUT OF THE USE OR INABILITY TO USE THE SOFTWARE WHETHER BASED ON A CLAIM UNDER CONTRACT, TORT OR OTHER LEGAL THEORY, EVEN IF ARM WAS ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.

ARM does not seek to limit or exclude liability for death or personal injury arising from ARM's negligence or ARM’s fraud and because some jurisdictions do not permit the exclusion or limitation of liability for consequential or incidental damages the above limitation relating to liability for consequential damages may not apply to you.

NOTWITHSTANDING ANYTHING TO THE CONTRARY CONTAINED IN THIS LICENCE, THE MAXIMUM LIABILITY OF ARM TO YOU IN AGGREGATE FOR ALL CLAIMS MADE AGAINST ARM IN CONTRACT TORT OR OTHERWISE UNDER OR IN CONNECTION WITH THE SUBJECT MATTER OF THIS LICENCE SHALL NOT EXCEED THE GREATER OF; (I) THE TOTAL OF SUMS PAID BY YOU TO ARM (IF ANY) FOR THIS LICENCE; AND US$10,00. THE EXISTENCE OF MORE THAN ONE CLAIM WILL NOT ENLARGE OR EXTEND THE LIMIT.

7. THIRD PARTY RIGHTS.
The Separate Files are delivered subject to and your use is governed by their own separate licence agreements. This Licence does not apply to such Separate Files and they are not included in the term “Software” under this Licence. You agree to comply with all terms and conditions imposed on you in respect of such Separate Files including those identified in the Schedule (“Third Party Terms”).

ARM HEREBY DISCLAIMS ANY AND ALL WARRANTIES EXPRESS OR IMPLIED FROM ANY THIRD PARTIES REGARDING ANY SEPARATE FILES, ANY THIRD PARTY MATERIALS INCLUDED IN THE SOFTWARE, ANY THIRD PARTY MATERIALS FROM WHICH THE SOFTWARE IS DERIVED (COLLECTIVELY “OTHER CODE”), AND THE USE OF ANY OR ALL THE OTHER CODE IN CONNECTION WITH THE SOFTWARE, INCLUDING (WITHOUT LIMITATION) ANY WARRANTIES OF SATISFACTORY QUALITY OR FITNESS FOR A PARTICULAR PURPOSE.

NO THIRD PARTY LICENSORS OF OTHER CODE SHALL HAVE ANY LIABILITY FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING WITHOUT LIMITATION LOST PROFITS), HOWEVER CAUSED AND WHETHER MADE UNDER CONTRACT, TORT OR OTHER LEGAL THEORY, ARISING IN ANY WAY OUT OF THE USE OR DISTRIBUTION OF THE OTHER CODE OR THE EXERCISE OF ANY RIGHTS GRANTED UNDER EITHER OR BOTH THIS LICENCE AND THE LEGAL TERMS APPLICABLE TO ANY SEPARATE FILES, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.

The Software includes materials supplied by third party device manufacturers for use with their relevant target devices. To the extent such materials are either (i) identified as such in the Software (for example in a “Help About” box or on-screen copyright message), or (ii) presented, in a standard installation, for selection by you at a path name or file name which contains the name of the relevant manufacturer or device, you agree to use such materials (if at all) only to develop applications for the relevant devices of that vendor.

To the extent that you purchase the Software with a dongle key from ARM or its authorised distributors, you are only permitted to use the Software in conjunction with such dongle key.

8. U.S. GOVERNMENT END USERS.
US Government Restrictions: Use, duplication, reproduction, release, modification, disclosure or transfer of this Software is restricted in accordance with the terms of this Licence.

9. TERM AND TERMINATION.
This Licence shall remain in force until terminated by you, by ARM or by expiry (in the case of a time limited licence). Without prejudice to any of its other rights if you are in breach of any of the terms and conditions of this Licence then ARM may terminate this Licence immediately upon giving written notice to you. You may terminate this Licence at any time. Upon termination or expiry of this Licence by you or by ARM; (i) you shall stop using the Software and destroy all copies of the Software in your possession together with all documentation and related materials; and (ii) ARM’s obligations to provide support and maintenance shall terminate immediately. Notwithstanding the foregoing, except where ARM has terminated this Licence for your breach, your rights to distribute either or both, as applicable, Target Libraries, Example Code, and Tiny-RTOS as part of Software Applications developed prior to termination or expiry shall survive termination or expiry of this Licence, subject to the terms and conditions of this Licence.

The provisions of clauses 4, 5, 6, 7, 8, 9 and 10 shall survive termination or expiry of this Licence.

10. GENERAL.
This Licence is governed by English Law. Except where ARM agrees otherwise in: (i) a written contract signed by you and ARM; or (ii) a written contract provided by ARM and accpeted by you, this is the only agreement between you and ARM relating to the Software and it may only be modified by written agreement between you and ARM. Except as expressly agreed in writing, this Licence may not be modified by purchase orders, advertising or other representation by any person. If any clause or sentence in this Licence is held by a court of law to be illegal or unenforceable the remaining provisions of this Licence shall not be affected thereby. The failure by ARM to enforce any of the provisions of this Licence, unless waived in writing, shall not constitute a waiver of ARM's rights to enforce such provision or any other provision of this Licence in the future.

At ARM’s request, you agree to check your computers for installations of the Software, copies of Licence Keys, contents of any licence server log files, individual or concurrent usage of Seats, and any other information requested by ARM relating to Software installation, usage and Licence Key management, and to provide this information to ARM. You agree that auditors nominated by ARM may also perform such checking and reporting on behalf of ARM by prior appointment during your normal business hours on seven (7) days’ notice. ARM shall bear the auditors’ costs for that audit unless it reveals unlicensed usage in which case you shall promptly reimburse ARM for all reasonable costs and expenses, including professional fees, relating to such audit. Any information which is disclosed to ARM or such auditors during checking or audit shall be treated as your confidential information and shall only be used by ARM for licence management, compliance and enforcement purposes.

The Software provided under this Licence is subject to U.S. export control laws, including the U.S. Export Administration Act and its associated regulations, and may be subject to export or import regulations in other countries. You agree to comply fully with all laws and regulations of the United States and other countries ("Export Laws") to assure that the Software, is not (1) exported, directly or indirectly, in violation of Export Laws, either to any countries that are subject to U.S.A. export restrictions or to any end user who has been prohibited from participating in the U.S.A. export transactions by any federal agency of the U.S.A. government; or (2) intended to be used for any purpose prohibited by Export Laws, including, without limitation, nuclear, chemical, or biological weapons proliferation.

THE SCHEDULE

SECTION 1

A. Target Libraries (object code):
Language Libraries and Helper Libraries found in your installation at (as applicable):
\KEIL\C166\LIB\*.LIB
\KEIL\C51\ LIB\*.LIB
\KEIL\C251\ LIB\*.LIB

B. Example Code:
\KEIL\......\EXAMPLES\*.*
\KEIL\......\BOARDS\*.*

C. Tiny-RTOS:
\KEIL\C51\RtxTiny2\*.*
\KEIL\C166\RtxTiny\*.*

SECTION 2 - SEPARATE FILES

A. XERCES XML parser (libxerces-c.so, xerces-c_3.0.0.dll): these files are licensed to you under the Apache Software License, Version 2.0.

B. Windows Driver Development Kit redistributables. See www.microsoft.com for more details.

C. Scintilla, an editor tool which enables the debugging and editing of source code is licensed to you under the Historical Permission Notice and Disclaimer, an open source license approved by the Open Source Initiative.

ARM contract references: LEC-ELA-00203 (SP version 2.0) KEIL 4.3


Licensing User's Guide: License Agreement Arm FuSa RTS Safety Package

License Agreement Arm FuSa RTS Safety Package

  • EULA
  • Supplementary terms
  • Redistributables
  • Third-party licenses

END USER LICENSE AGREEMENT FOR ARM SOFTWARE DEVELOPMENT TOOLS

This end user license agreement ("License") is a legal agreement between you (a single individual), or the company or organisation (a single legal entity) that you represent and have the legal authority to bind, and Arm relating to use of the Arm Tools. Arm is only willing to license the Arm Tools on condition that you accept all of the terms of this License. By clicking "I Agree" or by installing or otherwise using the Arm Tools and/or any Update thereto (as permitted by this License) you indicate that you agree to be bound by all of the terms and conditions of this License. If you do not agree to the terms of this License, Arm will NOT license the Arm Tools to you, you may not install or use the Arm Tools or any part thereof, and you shall promptly return the Arm Tools to Arm or to your supplier (if not Arm) and ask for a refund of the license fee paid (if any).

NOTE - YOUR ATTENTION IS DRAWN TO THE FOLLOWING:

(A) The terms and conditions set out in this License shall apply to the supply by Arm of Arm Tools for both commercial and non-commercial use. If you are in receipt of a Non-Commercial Use License for the Arm Tools (each capitalised term as defined below), or the Arm Tools or any component thereof are identified or classified as such, or you are receiving a license for the Arm Tools free of charge, then notwithstanding any of the other terms and conditions of this License, your use of the Arm Tools shall be limited by the restrictions of use set out in clause 2.2 of this License.

(B) PLEASE NOTE any terms and conditions of use set out in the order documentation provided to you by Arm and the Software Information File(s) (as defined below) applicable to the Arm Tools provided to you with (or included within) either (i) the Arm Tools, and/or (ii) any Updates to the Arm Tools, which limit, extend or otherwise vary the permitted uses and restrictions applicable to the Arm Tools ("Special Conditions"). The Special Conditions form part of and are incorporated into this License. In the event of any conflict or inconsistency between the provisions set out in the main body of this License and any of the Special Conditions, the provisions set out in the Special Conditions shall prevail (in the order in which they are listed in this paragraph).

(C) This License (and any documents incorporated by reference herein) is the sole and exclusive agreement between you and Arm for the Arm Tools, and (except as agreed in writing to the contrary) no other document, including (but not limited to) your purchase order or any other document supplied by you, will form part of this License.

DEFINITIONS

For the purposes of this License the following words and expressions shall have the following meanings:

"Arm" means Arm Limited whose registered office is situated at 110 Fulbourn Road, Cambridge CB1 9NJ, England and/or any member of Arm's group of companies.

"Arm Documentation" means any printed, electronic or online documentation relating to Arm Software licensed to you by Arm under this License.

"Arm Software" means any and all software, firmware and data licensed to you by Arm under this License.

"Arm Tools" means any and all Arm Software and/or Arm Documentation owned or licensed by Arm, and any Updates to the Arm Software and/or Arm Documentation.

"Arm Tools Performance Data" means any results, benchmarking data or other information relating to or connected with your use or testing of the Arm Tools which are indicative of their performance, efficacy, reliability or quality.

"Fees" means any fee(s) payable by you for the provision by Arm to you of the Arm Tools and associated support and maintenance services, and any other fees payable by you in accordance with this License that are agreed by the parties from time to time.

"License Key" means an electronic license key issued to you by Arm which enables you to use and run one or more Licensed Seat of an Arm Tool or a component thereof in accordance with the terms of this License.

"Licensed Seats" means any and all Seats of the Arm Tools (including, if applicable, Updates) that you are licensed to run and use concurrently under the terms of this License, in the types and quantities specified in the order documentation provided to you by Arm, as well as any additional or replacement Seats of the Arm Tools that Arm agrees to provide to you from time to time during the License Term.

"License Term" means the term set out in the order documentation provided to you by Arm during which you shall be entitled to access and use the Arm Tools.

"Non-Commercial Use License" means an evaluation, preview, beta, pre-release, pilot, academic, educational or community use only license.

"Permitted Users" means your employees, workers, consultants, professional advisors, bona fide sub-contractors and service providers that use the Arm Tools in connection with the provision of work carried out for your benefit, and/or, other members of your organisation or third party users who use the Arm Tools with your express written permission on computers (physical or virtual) owned or controlled by you.

"Redistributables" means the example code, library files, configuration files, header files, and any other Arm Tools or components thereof owned by Arm (or licensed by Arm and provided to you under Arm's terms and conditions) which you are permitted to include within Your Software and redistribute or sub-license within Your Software to third parties, the details of which (if applicable) are set out in a file or folder (the "Redistributables File") typically named 'redistributables' located within an Arm Tool (or components thereof).

"Seat" means a written or electronic authorisation to run a software component subject to the terms and restrictions specified in that authorisation.

"Software Information File(s)" means Third Party Licenses Files, Redistributables Files, and/or Supplementary Terms Files (as the context requires).

"Special Conditions" is as defined above in Recital (B) of this License.

"Specified Project" means a single design and development activity undertaken by you or your Permitted Users relating to Your Software or Your Hardware, the details of which will be set out in the order documentation provided to you by Arm.

"Supplementary Terms File" means a software file or folder typically named 'supplementary_terms' located within an Arm Tool (or components thereof) which (if applicable) details any component-specific extensions, limitations or other variations to the terms of this License.

"Territory" means, if applicable, the geographical area detailed in the order documentation provided to you by Arm to which your use of the Arm Tools or any part thereof is restricted.

"Third Party Licenses File" means a software file or folder typically named 'third_party_licenses' located within an Arm Tool (or components thereof) which (if applicable) details any third party material included in the relevant Arm Tool which is not licensed under the terms of this License, and a reference to the applicable third party license terms and conditions.

"Update" means an update, patch, hotfix, bug fix, support release, modification or limited functional enhancement (as applicable) to an Arm Tool or component thereof, including but not limited to error corrections to any program or associated documentation developed by or for Arm comprised in the Arm Tools, which (i) Arm makes generally available to the market, and (ii) does not, in Arm's opinion, constitute an Upgrade or a new product.

"Upgrade" means a new release of an existing Arm Tool which Arm makes generally available to the market and which usually contains major functional improvements.

"Your Hardware" means hardware manufactured or developed by you or on your behalf, or hardware owned or licensed by you, which is supported by the Arm Tools.

"Your Reports" means any written reports or other information relating to the behavior or performance of Your Software or Your Hardware, in html, binary, text or any other format (excluding for the avoidance of doubt, Arm Tools Performance Data), generated by you from or using the Arm Tools and any modifications thereto.

"Your Software" means any software owned or licensed by you (including, but not limited to, applications, libraries and Arm API compliant plug-ins, but excluding Arm Software) which is supported by (or developed by you using) the Arm Tools.

1. LICENSE GRANT

1.1 Subject to your compliance with the terms and conditions of this License, and payment by you of the Fees (if any), Arm hereby grants to you and your Permitted Users during the License Term a non-exclusive, non-transferable license to receive and use the Arm Tools, certain components thereof, or optional functionality, in the Territory only on the Licensed Seats or for a Specified Project (as applicable) for the permitted uses set out in this clause 1 and subject to the restrictions set out in clause 2 (as limited, extended or otherwise varied by any terms, including product-specific permitted uses and restrictions, set out in the Special Conditions). Except as expressly permitted by this License, you and your Permitted Users shall NOT copy, modify, sub-license, redistribute or otherwise use any component of the Arm Tools.

1.2 PERMITTED USE OF THE ARM TOOLS: Except as otherwise provided in this License, use of the Arm Tools (or components thereof) is permitted for the purpose of:

(a) building, developing, testing, debugging, analysing and optimising Your Software or Your Hardware;

(b) generation of Your Reports, and use of Your Reports to develop, test, debug, analyse and optimise Your Software or Your Hardware; and

(c) only as expressly provided in the relevant Redistributables File: (i) incorporating, compiling and/or linking the files listed in that Redistributables File into Your Software, provided that Your Software contains substantial additional functionality; and (ii) subject to clause 2.1 below, reproducing and redistributing the files (and permitting your customers and/or your authorised distributors to reproduce and redistribute the files), only in object code form (unless otherwise specified in the relevant Redistributables Files), and only as part of Your Software. You agree that, except as expressly provided to the contrary in the relevant Redistributables File, you may only copy the Arm Tools (or any component thereof) to the extent that such copying is incidental to the permitted uses set out in this clause 1.2, including installation, backup and execution.

2. YOUR OBLIGATIONS AND RESTRICTIONS ON USE

2.1 OBLIGATIONS RELATING TO REDISTRIBUTION: Any redistribution as permitted by this License is subject to any restrictions set out in the applicable Special Conditions, and your compliance with the following:

(a) in cases where you are expressly permitted under this License (including for the avoidance of doubt by inclusion of agreed wording in the order documentation provided to you by Arm) to sub-license or redistribute any component of the Arm Tools to your customers, authorised distributors or other third parties, you are responsible for ensuring that such customers, authorised distributors and third parties accept, and are contractually bound (by agreement with you or directly with Arm) to comply with, the terms and conditions of this License;

(b) Any use by you of Arm's or any of its licensors' names, logos or trademarks to publicise or market any of Your Software containing (or developed or generated using) Arm Tools is subject to you obtaining express written permission from Arm;

(c) You warrant that you shall not make any representations or warranties on behalf of Arm in respect of any of the Arm Tools or in respect of any other software, reports or documentation developed or generated by you in accordance with the license grants set out in this License;

(d) You must reproduce or preserve (as applicable) any copyright notices which are included in or with any Arm Tools or components thereof; and

(e) Except as otherwise agreed by Arm (including for the avoidance of doubt by inclusion of the relevant permission in a Supplementary Terms File), you may not disclose or otherwise distribute any Arm Tools Performance Data. For the avoidance of doubt, nothing in this sub-clause 2.1 (e) shall prevent you from disclosing or otherwise distributing Your Reports.

2.2 NON-COMMERCIAL USE AND FREE OF CHARGE LICENSES: If you are in receipt of a Non-Commercial Use License for the Arm Tools, or the Arm Tools or any component thereof are identified or classified as such, and/or you are receiving the Arm Tools free of charge, then notwithstanding any of the other terms and conditions of this License, your use (which includes use by your Permitted Users) of the Arm Tools is limited as follows:

(a) if you are receiving the Arm Tools free of charge:

  • (i) no support or maintenance shall be provided to you in respect of the Arm Tools;
  • (ii) the warranty set out in clause 7.1 of this License does not apply to you or your use of the Arm Tools, and Arm gives no other warranty whatsoever in relation to (and accepts no liability in connection with) the Arm Tools or your use (as permitted by this License) of them;
  • (iii) Arm may immediately terminate this License at any time for any reason by giving written notice to you;
  • (iv) except as otherwise expressly agreed in writing by Arm, you shall grant to Arm in full the license set out in clause 3.2 of this License; and/or
    • (b) if you are receiving a Non-Commercial Use License or version (as applicable) of the Arm Tools:
  • (i) you and your Permitted Users may use the Arm Tools for internal use only; and
  • (ii) you are not permitted to distribute or sub-license (A) any part of the Arm Tools, or (B) Your Software, Your Hardware, or Your Reports developed under this License using the Arm Tools. The Arm Tools shall be used only by you and your Permitted Users, and you shall not (except as otherwise authorised in writing by Arm) allow any other third party whatsoever to use the Arm Tools.

For the avoidance of doubt, if you are receiving a Non-Commercial Use License and the license is provided to you free of charge, the restrictions in both sub-clauses (a) and (b) above will apply to your use of the Arm Tools.

2.3 LICENSE TYPES: Depending on the type of license you have agreed to purchase from Arm under this License (the details of which are set out in the order documentation provided to you by Arm), your use of the Arm Tools shall be limited to:

(a) use of each Licensed Seat (i) by one individual named Permitted User only on a specified item of computer hardware ('named-user license'), OR (ii) by one individual Permitted User at a time only on a specified item of computer hardware ('node-locked license'), OR (iii) by one individual Permitted User at a time on specified items of computer hardware ('floating license'). In respect of 'node-locked licenses', each Licensed Seat may only be used for one 'process' at any one time. For the purpose of this sub-clause 2.3 (a), each 'process' is the execution of an instance of an Arm Tool; or

(b) use for a Specified Project.

2.4 PERMITTED USERS: You hereby agree to be responsible for the acts and omissions of any and all Permitted Users, and shall ensure that such Permitted Users (i) are contractually obliged to comply with the terms of this License, including those relating to confidentiality; and (ii) do not supply the Arm Tools or any components thereof to any third party whatsoever. Except as expressly provided in this License or as agreed in writing by Arm on a case by case basis, you shall not sub-license, redistribute, lease, rent or otherwise allow any third party to use the Arm Tools or License Keys.

2.5 REVERSE ENGINEERING: Your use of the Arm Tools shall specifically exclude the reverse engineering, decompiling, disassembly, translation, adaptation, arrangement or other alteration of any part of the Arm Tools (except to the extent that applicable law overrides this provision or any part hereof).

2.6 COPYRIGHT AND RESERVATION OF RIGHTS: The Arm Tools are owned by Arm and/or its licensors and are protected by copyright and other intellectual property rights, laws and international treaties. The Arm Tools are licensed not sold. Except as expressly provided by this License, you acquire no rights to the Arm Tools or any element thereof, or to any other Arm products or services. You shall not remove from the Arm Tools any copyright notice or other notice and shall ensure that any such notice is reproduced in any permitted reproduction of the whole or any part of the Arm Tools.

2.7 TECHNICAL RESTRICTIONS IN THE ARM TOOLS: You must comply with any technical restrictions in the Arm Tools and License Keys, including any restrictions that restrict use to certain components of the Arm Tools or use only for certain purposes. You shall not work around any such technical restrictions.

2.8 ARM DOCUMENTATION: You may use the Arm Documentation (if any) internally only in conjunction with your use of the Arm Software to which it relates.

3. LICENSE OF FEEDBACK TO ARM

3.1 You may at your discretion deliver any suggestions, comments, feedback, ideas, or know-how (whether in oral or written form) to Arm relating to or connected with your use of the Arm Tools ("Feedback"). Notwithstanding the foregoing, you shall not knowingly give to Arm any Feedback that you are aware (or should reasonably be aware) is subject to any patent, copyright or other intellectual property claim or right of any third party.

3.2 Except as expressly notified by you to Arm (in writing which may include email) to the contrary, you hereby grant to Arm under your and your affiliates (as applicable) intellectual property, a perpetual, irrevocable, royalty free, non-exclusive, worldwide license to: (i) use, copy, modify, and create derivative works of the Feedback; (ii) sell, supply or otherwise distribute the whole or any part of the Feedback (and derivative works thereof) as part of any Arm owned or licensed product(s) without obligation or restriction of any kind; and (iii) sub-license to third parties the foregoing rights, including the right to sub-license to further third parties. No right is granted by you to Arm to sub-license your and your affiliates (as applicable) intellectual property except to the extent that it is provided to Arm as Feedback and is embodied in any Arm owned or licensed product(s). For the avoidance of doubt, if, during the License Term, you provide notice to Arm revoking the license granted under this clause 3.2, you acknowledge and agree that such revocation shall not apply to Feedback delivered to Arm prior to the date of receipt of the revocation notice, and that (notwithstanding the foregoing) Arm shall continue to be permitted to use Feedback received after the date of receipt of the revocation notice for internal purposes.

3.3 Except as expressly licensed to Arm in clause 3.2, you retain all right, title and interest in and to the Feedback provided by you under this License.

4. DATA COLLECTION AND PRIVACY

4.1 The Arm Software may include features that enable it to transmit certain computer information over the internet to Arm's and/or its service providers' computer systems, for example your computer's internet protocol address, computer hardware and operating system details, or the serial numbers of the Arm Tools you have licensed. This information will not be shared with any third parties, and shall be used by Arm only for the purpose of Arm protecting its legitimate interests, which may include Arm verifying your right to use the Arm Tools and monitoring your compliance with the permitted uses and restrictions set out in this License.

4.2 Arm may also collect anonymous data, which, for the avoidance of doubt, cannot be used to identify individual users of the Arm Tools. This information may be used by Arm to help us understand and analyse what components or features in the Arm Tools our end users are using in order to (i) maintain and improve the quality of the Arm Tools and the end user experience, (ii) inform end users of relevant new and improved products and services, and (iii) assist end users to maximise the performance of, or solve user experience issues with, the Arm Tools.

4.3 Information collected by the Arm Software will only be used for the aforementioned purposes. Please refer to the Arm Privacy Policy https://www.arm.com/company/policies/privacy for further information on how Arm collects, uses and safeguards personal data (including but not limited to personal data collected for the protection of Arm's legitimate interests and your rights to object to its collection).

5. SUPPORT AND MAINTENANCE

5.1 Provision of reasonable support and maintenance is subject to payment by you of all applicable Fees.

5.2 Any support provided by Arm in accordance with the above clause 5.1 shall (i) be provided by telephone, email or such other format as is designated by Arm, (ii) be prioritised at Arm's discretion, and (iii) not be used as a substitute for training or as additional resource for your projects.

5.3 Maintenance will generally be provided in the form of Updates to the Arm Tools. Arm shall be under no obligation to provide such maintenance in respect of any modifications made by you (where permitted) to the Arm Tools. Updates do not constitute additional Licensed Seats and may only be used by you if you have an active Licensed Seat to run and use such Updates. Updates will generally be provided to you as soon as reasonably practicable following the date of general public release of the Update by Arm.

5.4 In cases where the Arm Tools were provided to you free of charge, you are not entitled to any support or maintenance for the Arm Tools from Arm, but Arm may, in its sole discretion, provide support to you. If you obtained the Arm Tools from an Arm authorised distributor, reseller or other third party, support and maintenance may be provided by either Arm or the third party as per the terms of your contract for supply. Arm shall not be responsible for any delay or failure in connection with any third party supplier providing support or maintenance that it is obligated to provide to you. Please refer to the 'Support' area of https://www.arm.com for details of Arm's support services, relevant contact details, and (if applicable) details of other authorised support channels.

5.5 Arm's obligations under this clause 5 are limited to the provision of support and maintenance to you, and Arm is under no obligation to provide any support and maintenance to any third parties. You agree to provide all front line support services to all third parties to whom you distribute any Arm Tools, Your Reports, Your Software or Your Hardware, pursuant to and in accordance with the terms of this License.

5.6 This License does not grant you any entitlement to receive (i) Upgrades, (ii) Arm products other than those specified in your product documentation, or (iii) any new products developed or introduced by Arm from time to time, nor to receive any support or maintenance in respect of the same.

6. CONFIDENTIALITY

6.1 You acknowledge that the Arm Tools, License Keys, Arm Tools Performance Data, and any and all other software, documentation or other information licensed to you by Arm, or provided to you during discussions about or in connection with the Arm Tools (including this License and information provided during the provision by Arm of any support), contain trade secrets and confidential information of Arm ("Confidential Information").

6.2 You agree to maintain all such Confidential Information in confidence and apply security measures (such measures to be no less stringent than the measures which you apply (or should reasonably apply) to protect your own like information, but not less than a reasonable degree of care) to prevent their unauthorised disclosure and use.

6.3 Subject to any restrictions imposed by applicable law, the period of confidentiality shall be five (5) years from the date of disclosure of the Confidential Information. You agree that you shall not use any such information other than in your normal use of the Arm Tools as permitted by this License.

7. LIMITED WARRANTIES

7.1 Subject to the restrictions in clause 2, for the period of ninety (90) days from the date of receipt by you of the Arm Tools, Arm warrants to you that (i) the media on which any Arm Software is provided shall be free from defects in materials and workmanship under normal use; and (ii) the Arm Software will perform substantially in accordance with the accompanying Arm Documentation (if any). Arm's total liability and your exclusive remedy for breach of these warranties shall be limited to Arm, at Arm's option (a) replacing the defective Arm Software; or (b) using reasonable efforts to correct material, documented, reproducible defects in the Arm Software and delivering such corrected Arm Software to you; or (c) if you licensed the Arm Software directly from Arm, refunding the price paid by you to Arm for that Arm Software. Any replacement Arm Software will be warranted for the remainder of the original warranty period or thirty (30) days from the date of replacement, whichever is longer.

7.2 The Arm Software described in any Arm Documentation is subject to continuous development and improvement. All particulars of the Arm Software and its use as described in the Arm Documentation are given by Arm in good faith. Consequently, the information contained in the Arm Documentation is subject to change without notice and is not warranted to be error free. If you discover any errors in the Arm Documentation please report them to Arm in writing. Any Arm Documentation provided to you that relates to specific industry quality and functional safety standard compliance may assist you in applying to a competent auditor for certification of Your Software or Your Hardware, but you acknowledge and agree that on its own such Arm Documentation may not provide sufficient evidence of, or be compatible with, the required safety compliance standards.

7.3 Except as provided in clause 7.1 above, you agree that the Arm Tools are licensed "as is", and that Arm expressly disclaims all representations, warranties, conditions or other terms, express or implied or statutory, including without limitation the implied warranties of non-infringement, satisfactory quality, and fitness for a particular purpose. You acknowledge that it is your responsibility to satisfy yourself that the Arm Tools are fit for the intended purpose and satisfy your requirements, including compatibility with Your Hardware, and you expressly assume all liabilities and risks relating to (i) any use of an Arm Tool which is inconsistent with its design or any guidance provided to you in the applicable Arm Documentation, and/or (ii) any use of an Arm Tool with Your Software or Your Hardware where such software or hardware (as applicable) is not supported by or compatible with the relevant Arm Tool.

7.4 You expressly assume all liabilities and risks relating to your use or operation of Your Software and Your Hardware designed or modified using the Arm Tools, including without limitation, Your software or Your Hardware designed or intended for safety-critical applications. Should Your Software or Your Hardware prove defective, you assume the entire cost of all necessary servicing, repair or correction.

8. LIMITATION OF LIABILITY

8.1 To the maximum extent permitted by applicable law, in no event shall Arm be liable for any indirect, special, incidental or consequential damages (including loss of profits) arising out of the use of, or inability to use, the Arm Tools, whether based on a claim under contract, tort or otherwise, even if Arm was advised of the possibility of such damages.

8.2 Arm does not seek to limit or exclude liability for death or personal injury arising from Arm's negligence or Arm's fraud. Arm acknowledges that certain jurisdictions do not permit the exclusion or limitation of liability for consequential or incidental damages, and in such cases the above limitation relating to liability for consequential damages may not apply to you.

8.3 Notwithstanding anything to the contrary contained in this License, the maximum liability of Arm to you in aggregate (in contract, tort or otherwise) in relation to or in connection with the subject matter of this License shall not exceed the greater of (i) the total sums paid by you to Arm (if any) for this License, and (ii) $10.00 USD. The existence of more than one claim will not enlarge or extend the limit.

9. THIRD PARTY MATERIAL

9.1 The Arm Tools may contain material owned or developed by third parties, including but not limited to open source software, freeware and commercial software ("Third Party Material"). Any Third Party Material is subject to the terms and conditions of the applicable Third Party Material license(s) and is not covered under the terms of this License. Details relating to such Third Party Material shall either be presented to you at the time of installation or shall be detailed in the Third Party Licenses File(s). Your use of such Third Party Material is subject to your compliance with the applicable Third Party Material license(s).

9.2 Arm hereby disclaims any and all warranties express or implied from any third parties regarding, or otherwise connected with, any Third Party Material included in the Arm Tools and any Third Party Material from which the Arm Tools are derived, and/or your use of any or all of the Third Party Material in connection with Your Software or Your Hardware, including (without limitation) any warranties of satisfactory quality or fitness for a particular purpose.

9.3 No Third Party Material licensors shall have any liability for any direct, indirect, incidental, special, exemplary, or consequential damages (including without limitation lost profits) howsoever caused and whether made under contract, tort or otherwise arising in any way out of your use or distribution of the Third Party Material or the exercise of any rights granted under either or both this License and the legal terms applicable to any Third Party Material, even if advised in advance of the possibility of such damages.

10. GOVERNMENT REQUIREMENTS

10.1 To the extent that you are an agency, contractor or instrumentality of the U.S. Government, you and we agree that:

(a) the Arm Tools are commercial computer software and commercial computer software documentation, and that your rights therein are as specified in this License, per FAR 12.212 and DFARS 227.7202-3, as applicable, or in the case of NASA, subject to NSF 1852.22786. Arm acknowledges that, whilst commercial computer software or commercial computer software documentation shall be acquired under licenses customarily provided to the public, such licenses must be consistent with U.S. Federal law and otherwise satisfy the U.S. Government's needs ("U.S. Government Requirements"); and

(b) you may assign your rights under this License to the relevant US Government Federal Department or the successor contractor designated by the US Government Federal Department upon termination of your related prime contract with that US Government Federal Department. If you exercise your rights under this clause 10.1(b), you acknowledge and agree that you shall remain liable to Arm in respect of all your obligations under this License.

10.2 If there is any material inconsistency between (i) either a U.S. Government Requirement or a requirement of another government with which Arm is mandated by statute to comply and (ii) any provision of this License, the terms of the relevant government requirement shall prevail and the provision in question shall be deemed varied or deleted (as applicable) as required by the terms of the relevant government requirement. For the avoidance of doubt, in such circumstances, all other terms, conditions and provisions of this License will continue to be valid to the fullest extent permitted by law in accordance with the below clause 12.3.

11. TERM AND TERMINATION

11.1 Subject to clauses 11.2 and 11.3 below, this License shall remain in force until terminated by you, by Arm or (in the case of a time limited license) by expiry.

11.2 In the event of a party breaching of any of the terms and conditions of this License, which if capable of remedy, has not been remedied by that party within thirty (30) days of the date of breach, without prejudice to any of its other rights under this License, the non-breaching party may terminate this License immediately upon giving written notice to the breaching party. Upon termination of this License by you or by Arm, or upon expiry, you shall (and shall ensure that your Permitted Users shall) immediately (i) stop using the Arm Tools (or any element thereof) and any Confidential Information and, (ii) destroy all copies of the same in your possession or control, together with all Arm Documentation and related materials.

11.3 Notwithstanding the foregoing, except where Arm has terminated this License for your breach, your rights (if applicable) to distribute any of Your Software or Your Hardware developed using the Arm Tools prior to termination or expiry of this License shall (subject to your continued compliance with the terms and conditions of this License) survive such termination or expiry.

12. GENERAL

12.1 This License is governed by English Law. Notwithstanding the foregoing, to the extent that you are an agency, contractor or instrumentality of the U.S. Government, disputes arising under or relating to this License shall be decided under the U.S. federal law of government contracting, including without limitation the Contract Disputes Act. Nothing in this License shall prevent you from enforcing your intellectual property rights or seeking injunctive or other equitable relief in any court of competent jurisdiction. The parties hereby disclaim application of the United Nations Convention on Contracts for the International Sale of Goods and the Uniform Computer Information Transactions Act.

12.2 Except where Arm agrees otherwise in (i) a written contract signed by you and Arm, or (ii) a written contract provided by Arm and accepted by you, this is the only agreement between you and Arm relating to the Arm Tools and it may only be modified by written agreement between you and Arm. No terms and conditions contained in any purchase order or other document issued by you, or any advertising or other representation by you or any third party shall add to, supersede or in any way vary the terms and conditions of this License. This License (and any documents expressly incorporated into it by reference herein) represents the entire agreement between you and Arm in relation to its subject matter.

12.3 If any clause or sentence in this License is held by a court of law to be illegal or unenforceable, the remaining provisions of this License shall not be affected. Any failure by Arm to enforce any of the provisions of this License, unless waived in writing, shall not constitute a waiver of Arm's rights to enforce such provision or any other provision of this License in the future.

12.4 Subject to clause 10.1(b), neither this License or any rights granted to you under it may be assigned, sub-licensed or otherwise transferred by you to any third party without the prior written consent of Arm. An assignment shall be deemed to include, without limitation (i) any transaction or series of transactions whereby a third party acquires, directly or indirectly, the power to control the management and policies of you, whether through the acquisition of voting securities, by contract or otherwise; and (ii) the sale of more than fifty percent (50%) of your assets whether in a single transaction or series of transactions. Notwithstanding the foregoing, Arm may, in its discretion acting reasonably, separately agree to authorise the re-host of a Licensed Seat (for which additional charges may apply).

12.5 Subject to any applicable legal restrictions, including but not limited to those relating to the security of classified information, at Arm's request, (i) you agree to check your computers for installations of the Arm Tools, copies of License Keys, contents of any license server log files, individual or concurrent usage of Seats, and any other information requested by Arm relating to Arm Tools installation, usage and License Key management, and, to provide this information to Arm; and (ii) you agree that Arm may instruct appropriately qualified independent auditors to perform such checks by prior appointment during your normal business hours on reasonable notice. In respect of any audit, Arm shall bear the auditors' costs for that audit unless it reveals unlicensed usage, in which case you shall promptly reimburse Arm for all reasonable costs and expenses, including professional fees, relating to such audit. Any information which is disclosed to Arm or such auditors during checking or audit shall be treated as your confidential information and shall only be used by Arm for compliance and enforcement purposes.

12.6 The Arm Tools provided under this License are subject to U.S. export control laws, including the U.S. Export Administration Act and its associated regulations, and may be subject to export or import regulations in other countries. You agree to comply fully with all laws and regulations of the United States and other countries ("Export Laws") to ensure that the Arm Tools are not (i) exported, directly or indirectly, in violation of Export Laws, either to any countries that are subject to U.S. export restrictions or to any end user who has been prohibited from participating in the U.S export transactions by any federal agency of the U.S. government; or (ii) intended to be used for any purpose prohibited by Export Laws, including, without limitation, nuclear, chemical, or biological weapons proliferation.

Arm Document Reference LES-PRE-21260, Version 12.2, Effective Date 12 February 2019


Licensing User's Guide: License Agreement Arm FuSa RTS v1.0.1

License Agreement Arm FuSa RTS v1.0.1

Below are the references to licensing terms of 'Arm Run-Time System for functional safety applications (Arm FuSa RTS)' v1.0.1 and its documentation set 'Arm FuSa RTS Safety Package".

  • EULA
  • Supplementary terms
  • Redistributables
  • Third-party licenses
  • License agreement Arm FuSa RTS Safety Package (Documentation Set)

END USER LICENSE AGREEMENT FOR ARM SOFTWARE DEVELOPMENT TOOLS

This end user license agreement ("License") is a legal agreement between you (a single individual), or the company or organisation (a single legal entity) that you represent and have the legal authority to bind, and Arm relating to use of the Arm Tools. Arm is only willing to license the Arm Tools on condition that you accept all of the terms of this License. By clicking "I Agree" or by installing or otherwise using the Arm Tools and/or any Update thereto (as permitted by this License) you indicate that you agree to be bound by all of the terms and conditions of this License. If you do not agree to the terms of this License, Arm will NOT license the Arm Tools to you, you may not install or use the Arm Tools or any part thereof, and you shall promptly return the Arm Tools to Arm or to your supplier (if not Arm) and ask for a refund of the license fee paid (if any).

NOTE - YOUR ATTENTION IS DRAWN TO THE FOLLOWING:

(A) The terms and conditions set out in this License shall apply to the supply by Arm of Arm Tools for both commercial and non-commercial use. If you are in receipt of a Non-Commercial Use License for the Arm Tools (each capitalised term as defined below), or the Arm Tools or any component thereof are identified or classified as such, or you are receiving a license for the Arm Tools free of charge, then notwithstanding any of the other terms and conditions of this License, your use of the Arm Tools shall be limited by the restrictions of use set out in clause 2.2 of this License.

(B) PLEASE NOTE any terms and conditions of use set out in the order documentation provided to you by Arm and the Software Information File(s) (as defined below) applicable to the Arm Tools provided to you with (or included within) either (i) the Arm Tools, and/or (ii) any Updates to the Arm Tools, which limit, extend or otherwise vary the permitted uses and restrictions applicable to the Arm Tools ("Special Conditions"). The Special Conditions form part of and are incorporated into this License. In the event of any conflict or inconsistency between the provisions set out in the main body of this License and any of the Special Conditions, the provisions set out in the Special Conditions shall prevail (in the order in which they are listed in this paragraph).

(C) This License (and any documents incorporated by reference herein) is the sole and exclusive agreement between you and Arm for the Arm Tools, and (except as agreed in writing to the contrary) no other document, including (but not limited to) your purchase order or any other document supplied by you, will form part of this License.

DEFINITIONS

For the purposes of this License the following words and expressions shall have the following meanings:

"Arm" means Arm Limited whose registered office is situated at 110 Fulbourn Road, Cambridge CB1 9NJ, England and/or any member of Arm's group of companies.

"Arm Documentation" means any printed, electronic or online documentation relating to Arm Software licensed to you by Arm under this License.

"Arm Software" means any and all software, firmware and data licensed to you by Arm under this License.

"Arm Tools" means any and all Arm Software and/or Arm Documentation owned or licensed by Arm, and any Updates to the Arm Software and/or Arm Documentation.

"Arm Tools Performance Data" means any results, benchmarking data or other information relating to or connected with your use or testing of the Arm Tools which are indicative of their performance, efficacy, reliability or quality.

"Fees" means any fee(s) payable by you for the provision by Arm to you of the Arm Tools and associated support and maintenance services, and any other fees payable by you in accordance with this License that are agreed by the parties from time to time.

"License Key" means an electronic license key issued to you by Arm which enables you to use and run one or more Licensed Seat of an Arm Tool or a component thereof in accordance with the terms of this License.

"Licensed Seats" means any and all Seats of the Arm Tools (including, if applicable, Updates) that you are licensed to run and use concurrently under the terms of this License, in the types and quantities specified in the order documentation provided to you by Arm, as well as any additional or replacement Seats of the Arm Tools that Arm agrees to provide to you from time to time during the License Term.

"License Term" means the term set out in the order documentation provided to you by Arm during which you shall be entitled to access and use the Arm Tools.

"Non-Commercial Use License" means an evaluation, preview, beta, pre-release, pilot, academic, educational or community use only license.

"Permitted Users" means your employees, workers, consultants, professional advisors, bona fide sub-contractors and service providers that use the Arm Tools in connection with the provision of work carried out for your benefit, and/or, other members of your organisation or third party users who use the Arm Tools with your express written permission on computers (physical or virtual) owned or controlled by you.

"Redistributables" means the example code, library files, configuration files, header files, and any other Arm Tools or components thereof owned by Arm (or licensed by Arm and provided to you under Arm's terms and conditions) which you are permitted to include within Your Software and redistribute or sub-license within Your Software to third parties, the details of which (if applicable) are set out in a file or folder (the "Redistributables File") typically named 'redistributables' located within an Arm Tool (or components thereof).

"Seat" means a written or electronic authorisation to run a software component subject to the terms and restrictions specified in that authorisation.

"Software Information File(s)" means Third Party Licenses Files, Redistributables Files, and/or Supplementary Terms Files (as the context requires).

"Special Conditions" is as defined above in Recital (B) of this License.

"Specified Project" means a single design and development activity undertaken by you or your Permitted Users relating to Your Software or Your Hardware, the details of which will be set out in the order documentation provided to you by Arm.

"Supplementary Terms File" means a software file or folder typically named 'supplementary_terms' located within an Arm Tool (or components thereof) which (if applicable) details any component-specific extensions, limitations or other variations to the terms of this License.

"Territory" means, if applicable, the geographical area detailed in the order documentation provided to you by Arm to which your use of the Arm Tools or any part thereof is restricted.

"Third Party Licenses File" means a software file or folder typically named 'third_party_licenses' located within an Arm Tool (or components thereof) which (if applicable) details any third party material included in the relevant Arm Tool which is not licensed under the terms of this License, and a reference to the applicable third party license terms and conditions.

"Update" means an update, patch, hotfix, bug fix, support release, modification or limited functional enhancement (as applicable) to an Arm Tool or component thereof, including but not limited to error corrections to any program or associated documentation developed by or for Arm comprised in the Arm Tools, which (i) Arm makes generally available to the market, and (ii) does not, in Arm's opinion, constitute an Upgrade or a new product.

"Upgrade" means a new release of an existing Arm Tool which Arm makes generally available to the market and which usually contains major functional improvements.

"Your Hardware" means hardware manufactured or developed by you or on your behalf, or hardware owned or licensed by you, which is supported by the Arm Tools.

"Your Reports" means any written reports or other information relating to the behavior or performance of Your Software or Your Hardware, in html, binary, text or any other format (excluding for the avoidance of doubt, Arm Tools Performance Data), generated by you from or using the Arm Tools and any modifications thereto.

"Your Software" means any software owned or licensed by you (including, but not limited to, applications, libraries and Arm API compliant plug-ins, but excluding Arm Software) which is supported by (or developed by you using) the Arm Tools.

1. LICENSE GRANT

1.1 Subject to your compliance with the terms and conditions of this License, and payment by you of the Fees (if any), Arm hereby grants to you and your Permitted Users during the License Term a non-exclusive, non-transferable license to receive and use the Arm Tools, certain components thereof, or optional functionality, in the Territory only on the Licensed Seats or for a Specified Project (as applicable) for the permitted uses set out in this clause 1 and subject to the restrictions set out in clause 2 (as limited, extended or otherwise varied by any terms, including product-specific permitted uses and restrictions, set out in the Special Conditions). Except as expressly permitted by this License, you and your Permitted Users shall NOT copy, modify, sub-license, redistribute or otherwise use any component of the Arm Tools.

1.2 PERMITTED USE OF THE ARM TOOLS: Except as otherwise provided in this License, use of the Arm Tools (or components thereof) is permitted for the purpose of:

(a) building, developing, testing, debugging, analysing and optimising Your Software or Your Hardware;

(b) generation of Your Reports, and use of Your Reports to develop, test, debug, analyse and optimise Your Software or Your Hardware; and

(c) only as expressly provided in the relevant Redistributables File: (i) incorporating, compiling and/or linking the files listed in that Redistributables File into Your Software, provided that Your Software contains substantial additional functionality; and (ii) subject to clause 2.1 below, reproducing and redistributing the files (and permitting your customers and/or your authorised distributors to reproduce and redistribute the files), only in object code form (unless otherwise specified in the relevant Redistributables Files), and only as part of Your Software. You agree that, except as expressly provided to the contrary in the relevant Redistributables File, you may only copy the Arm Tools (or any component thereof) to the extent that such copying is incidental to the permitted uses set out in this clause 1.2, including installation, backup and execution.

2. YOUR OBLIGATIONS AND RESTRICTIONS ON USE

2.1 OBLIGATIONS RELATING TO REDISTRIBUTION: Any redistribution as permitted by this License is subject to any restrictions set out in the applicable Special Conditions, and your compliance with the following:

(a) in cases where you are expressly permitted under this License (including for the avoidance of doubt by inclusion of agreed wording in the order documentation provided to you by Arm) to sub-license or redistribute any component of the Arm Tools to your customers, authorised distributors or other third parties, you are responsible for ensuring that such customers, authorised distributors and third parties accept, and are contractually bound (by agreement with you or directly with Arm) to comply with, the terms and conditions of this License;

(b) Any use by you of Arm's or any of its licensors' names, logos or trademarks to publicise or market any of Your Software containing (or developed or generated using) Arm Tools is subject to you obtaining express written permission from Arm;

(c) You warrant that you shall not make any representations or warranties on behalf of Arm in respect of any of the Arm Tools or in respect of any other software, reports or documentation developed or generated by you in accordance with the license grants set out in this License;

(d) You must reproduce or preserve (as applicable) any copyright notices which are included in or with any Arm Tools or components thereof; and

(e) Except as otherwise agreed by Arm (including for the avoidance of doubt by inclusion of the relevant permission in a Supplementary Terms File), you may not disclose or otherwise distribute any Arm Tools Performance Data. For the avoidance of doubt, nothing in this sub-clause 2.1 (e) shall prevent you from disclosing or otherwise distributing Your Reports.

2.2 NON-COMMERCIAL USE AND FREE OF CHARGE LICENSES: If you are in receipt of a Non-Commercial Use License for the Arm Tools, or the Arm Tools or any component thereof are identified or classified as such, and/or you are receiving the Arm Tools free of charge, then notwithstanding any of the other terms and conditions of this License, your use (which includes use by your Permitted Users) of the Arm Tools is limited as follows:

(a) if you are receiving the Arm Tools free of charge:

  • (i) no support or maintenance shall be provided to you in respect of the Arm Tools;
  • (ii) the warranty set out in clause 7.1 of this License does not apply to you or your use of the Arm Tools, and Arm gives no other warranty whatsoever in relation to (and accepts no liability in connection with) the Arm Tools or your use (as permitted by this License) of them;
  • (iii) Arm may immediately terminate this License at any time for any reason by giving written notice to you;
  • (iv) except as otherwise expressly agreed in writing by Arm, you shall grant to Arm in full the license set out in clause 3.2 of this License; and/or
    • (b) if you are receiving a Non-Commercial Use License or version (as applicable) of the Arm Tools:
  • (i) you and your Permitted Users may use the Arm Tools for internal use only; and
  • (ii) you are not permitted to distribute or sub-license (A) any part of the Arm Tools, or (B) Your Software, Your Hardware, or Your Reports developed under this License using the Arm Tools. The Arm Tools shall be used only by you and your Permitted Users, and you shall not (except as otherwise authorised in writing by Arm) allow any other third party whatsoever to use the Arm Tools.

For the avoidance of doubt, if you are receiving a Non-Commercial Use License and the license is provided to you free of charge, the restrictions in both sub-clauses (a) and (b) above will apply to your use of the Arm Tools.

2.3 LICENSE TYPES: Depending on the type of license you have agreed to purchase from Arm under this License (the details of which are set out in the order documentation provided to you by Arm), your use of the Arm Tools shall be limited to:

(a) use of each Licensed Seat (i) by one individual named Permitted User only on a specified item of computer hardware ('named-user license'), OR (ii) by one individual Permitted User at a time only on a specified item of computer hardware ('node-locked license'), OR (iii) by one individual Permitted User at a time on specified items of computer hardware ('floating license'). In respect of 'node-locked licenses', each Licensed Seat may only be used for one 'process' at any one time. For the purpose of this sub-clause 2.3 (a), each 'process' is the execution of an instance of an Arm Tool; or

(b) use for a Specified Project.

2.4 PERMITTED USERS: You hereby agree to be responsible for the acts and omissions of any and all Permitted Users, and shall ensure that such Permitted Users (i) are contractually obliged to comply with the terms of this License, including those relating to confidentiality; and (ii) do not supply the Arm Tools or any components thereof to any third party whatsoever. Except as expressly provided in this License or as agreed in writing by Arm on a case by case basis, you shall not sub-license, redistribute, lease, rent or otherwise allow any third party to use the Arm Tools or License Keys.

2.5 REVERSE ENGINEERING: Your use of the Arm Tools shall specifically exclude the reverse engineering, decompiling, disassembly, translation, adaptation, arrangement or other alteration of any part of the Arm Tools (except to the extent that applicable law overrides this provision or any part hereof).

2.6 COPYRIGHT AND RESERVATION OF RIGHTS: The Arm Tools are owned by Arm and/or its licensors and are protected by copyright and other intellectual property rights, laws and international treaties. The Arm Tools are licensed not sold. Except as expressly provided by this License, you acquire no rights to the Arm Tools or any element thereof, or to any other Arm products or services. You shall not remove from the Arm Tools any copyright notice or other notice and shall ensure that any such notice is reproduced in any permitted reproduction of the whole or any part of the Arm Tools.

2.7 TECHNICAL RESTRICTIONS IN THE ARM TOOLS: You must comply with any technical restrictions in the Arm Tools and License Keys, including any restrictions that restrict use to certain components of the Arm Tools or use only for certain purposes. You shall not work around any such technical restrictions.

2.8 ARM DOCUMENTATION: You may use the Arm Documentation (if any) internally only in conjunction with your use of the Arm Software to which it relates.

3. LICENSE OF FEEDBACK TO ARM

3.1 You may at your discretion deliver any suggestions, comments, feedback, ideas, or know-how (whether in oral or written form) to Arm relating to or connected with your use of the Arm Tools ("Feedback"). Notwithstanding the foregoing, you shall not knowingly give to Arm any Feedback that you are aware (or should reasonably be aware) is subject to any patent, copyright or other intellectual property claim or right of any third party.

3.2 Except as expressly notified by you to Arm (in writing which may include email) to the contrary, you hereby grant to Arm under your and your affiliates (as applicable) intellectual property, a perpetual, irrevocable, royalty free, non-exclusive, worldwide license to: (i) use, copy, modify, and create derivative works of the Feedback; (ii) sell, supply or otherwise distribute the whole or any part of the Feedback (and derivative works thereof) as part of any Arm owned or licensed product(s) without obligation or restriction of any kind; and (iii) sub-license to third parties the foregoing rights, including the right to sub-license to further third parties. No right is granted by you to Arm to sub-license your and your affiliates (as applicable) intellectual property except to the extent that it is provided to Arm as Feedback and is embodied in any Arm owned or licensed product(s). For the avoidance of doubt, if, during the License Term, you provide notice to Arm revoking the license granted under this clause 3.2, you acknowledge and agree that such revocation shall not apply to Feedback delivered to Arm prior to the date of receipt of the revocation notice, and that (notwithstanding the foregoing) Arm shall continue to be permitted to use Feedback received after the date of receipt of the revocation notice for internal purposes.

3.3 Except as expressly licensed to Arm in clause 3.2, you retain all right, title and interest in and to the Feedback provided by you under this License.

4. DATA COLLECTION AND PRIVACY

4.1 The Arm Software may include features that enable it to transmit certain computer information over the internet to Arm's and/or its service providers' computer systems, for example your computer's internet protocol address, computer hardware and operating system details, or the serial numbers of the Arm Tools you have licensed. This information will not be shared with any third parties, and shall be used by Arm only for the purpose of Arm protecting its legitimate interests, which may include Arm verifying your right to use the Arm Tools and monitoring your compliance with the permitted uses and restrictions set out in this License.

4.2 Arm may also collect anonymous data, which, for the avoidance of doubt, cannot be used to identify individual users of the Arm Tools. This information may be used by Arm to help us understand and analyse what components or features in the Arm Tools our end users are using in order to (i) maintain and improve the quality of the Arm Tools and the end user experience, (ii) inform end users of relevant new and improved products and services, and (iii) assist end users to maximise the performance of, or solve user experience issues with, the Arm Tools.

4.3 Information collected by the Arm Software will only be used for the aforementioned purposes. Please refer to the Arm Privacy Policy https://www.arm.com/company/policies/privacy for further information on how Arm collects, uses and safeguards personal data (including but not limited to personal data collected for the protection of Arm's legitimate interests and your rights to object to its collection).

5. SUPPORT AND MAINTENANCE

5.1 Provision of reasonable support and maintenance is subject to payment by you of all applicable Fees.

5.2 Any support provided by Arm in accordance with the above clause 5.1 shall (i) be provided by telephone, email or such other format as is designated by Arm, (ii) be prioritised at Arm's discretion, and (iii) not be used as a substitute for training or as additional resource for your projects.

5.3 Maintenance will generally be provided in the form of Updates to the Arm Tools. Arm shall be under no obligation to provide such maintenance in respect of any modifications made by you (where permitted) to the Arm Tools. Updates do not constitute additional Licensed Seats and may only be used by you if you have an active Licensed Seat to run and use such Updates. Updates will generally be provided to you as soon as reasonably practicable following the date of general public release of the Update by Arm.

5.4 In cases where the Arm Tools were provided to you free of charge, you are not entitled to any support or maintenance for the Arm Tools from Arm, but Arm may, in its sole discretion, provide support to you. If you obtained the Arm Tools from an Arm authorised distributor, reseller or other third party, support and maintenance may be provided by either Arm or the third party as per the terms of your contract for supply. Arm shall not be responsible for any delay or failure in connection with any third party supplier providing support or maintenance that it is obligated to provide to you. Please refer to the 'Support' area of https://www.arm.com for details of Arm's support services, relevant contact details, and (if applicable) details of other authorised support channels.

5.5 Arm's obligations under this clause 5 are limited to the provision of support and maintenance to you, and Arm is under no obligation to provide any support and maintenance to any third parties. You agree to provide all front line support services to all third parties to whom you distribute any Arm Tools, Your Reports, Your Software or Your Hardware, pursuant to and in accordance with the terms of this License.

5.6 This License does not grant you any entitlement to receive (i) Upgrades, (ii) Arm products other than those specified in your product documentation, or (iii) any new products developed or introduced by Arm from time to time, nor to receive any support or maintenance in respect of the same.

6. CONFIDENTIALITY

6.1 You acknowledge that the Arm Tools, License Keys, Arm Tools Performance Data, and any and all other software, documentation or other information licensed to you by Arm, or provided to you during discussions about or in connection with the Arm Tools (including this License and information provided during the provision by Arm of any support), contain trade secrets and confidential information of Arm ("Confidential Information").

6.2 You agree to maintain all such Confidential Information in confidence and apply security measures (such measures to be no less stringent than the measures which you apply (or should reasonably apply) to protect your own like information, but not less than a reasonable degree of care) to prevent their unauthorised disclosure and use.

6.3 Subject to any restrictions imposed by applicable law, the period of confidentiality shall be five (5) years from the date of disclosure of the Confidential Information. You agree that you shall not use any such information other than in your normal use of the Arm Tools as permitted by this License.

7. LIMITED WARRANTIES

7.1 Subject to the restrictions in clause 2, for the period of ninety (90) days from the date of receipt by you of the Arm Tools, Arm warrants to you that (i) the media on which any Arm Software is provided shall be free from defects in materials and workmanship under normal use; and (ii) the Arm Software will perform substantially in accordance with the accompanying Arm Documentation (if any). Arm's total liability and your exclusive remedy for breach of these warranties shall be limited to Arm, at Arm's option (a) replacing the defective Arm Software; or (b) using reasonable efforts to correct material, documented, reproducible defects in the Arm Software and delivering such corrected Arm Software to you; or (c) if you licensed the Arm Software directly from Arm, refunding the price paid by you to Arm for that Arm Software. Any replacement Arm Software will be warranted for the remainder of the original warranty period or thirty (30) days from the date of replacement, whichever is longer.

7.2 The Arm Software described in any Arm Documentation is subject to continuous development and improvement. All particulars of the Arm Software and its use as described in the Arm Documentation are given by Arm in good faith. Consequently, the information contained in the Arm Documentation is subject to change without notice and is not warranted to be error free. If you discover any errors in the Arm Documentation please report them to Arm in writing. Any Arm Documentation provided to you that relates to specific industry quality and functional safety standard compliance may assist you in applying to a competent auditor for certification of Your Software or Your Hardware, but you acknowledge and agree that on its own such Arm Documentation may not provide sufficient evidence of, or be compatible with, the required safety compliance standards.

7.3 Except as provided in clause 7.1 above, you agree that the Arm Tools are licensed "as is", and that Arm expressly disclaims all representations, warranties, conditions or other terms, express or implied or statutory, including without limitation the implied warranties of non-infringement, satisfactory quality, and fitness for a particular purpose. You acknowledge that it is your responsibility to satisfy yourself that the Arm Tools are fit for the intended purpose and satisfy your requirements, including compatibility with Your Hardware, and you expressly assume all liabilities and risks relating to (i) any use of an Arm Tool which is inconsistent with its design or any guidance provided to you in the applicable Arm Documentation, and/or (ii) any use of an Arm Tool with Your Software or Your Hardware where such software or hardware (as applicable) is not supported by or compatible with the relevant Arm Tool.

7.4 You expressly assume all liabilities and risks relating to your use or operation of Your Software and Your Hardware designed or modified using the Arm Tools, including without limitation, Your software or Your Hardware designed or intended for safety-critical applications. Should Your Software or Your Hardware prove defective, you assume the entire cost of all necessary servicing, repair or correction.

8. LIMITATION OF LIABILITY

8.1 To the maximum extent permitted by applicable law, in no event shall Arm be liable for any indirect, special, incidental or consequential damages (including loss of profits) arising out of the use of, or inability to use, the Arm Tools, whether based on a claim under contract, tort or otherwise, even if Arm was advised of the possibility of such damages.

8.2 Arm does not seek to limit or exclude liability for death or personal injury arising from Arm's negligence or Arm's fraud. Arm acknowledges that certain jurisdictions do not permit the exclusion or limitation of liability for consequential or incidental damages, and in such cases the above limitation relating to liability for consequential damages may not apply to you.

8.3 Notwithstanding anything to the contrary contained in this License, the maximum liability of Arm to you in aggregate (in contract, tort or otherwise) in relation to or in connection with the subject matter of this License shall not exceed the greater of (i) the total sums paid by you to Arm (if any) for this License, and (ii) $10.00 USD. The existence of more than one claim will not enlarge or extend the limit.

9. THIRD PARTY MATERIAL

9.1 The Arm Tools may contain material owned or developed by third parties, including but not limited to open source software, freeware and commercial software ("Third Party Material"). Any Third Party Material is subject to the terms and conditions of the applicable Third Party Material license(s) and is not covered under the terms of this License. Details relating to such Third Party Material shall either be presented to you at the time of installation or shall be detailed in the Third Party Licenses File(s). Your use of such Third Party Material is subject to your compliance with the applicable Third Party Material license(s).

9.2 Arm hereby disclaims any and all warranties express or implied from any third parties regarding, or otherwise connected with, any Third Party Material included in the Arm Tools and any Third Party Material from which the Arm Tools are derived, and/or your use of any or all of the Third Party Material in connection with Your Software or Your Hardware, including (without limitation) any warranties of satisfactory quality or fitness for a particular purpose.

9.3 No Third Party Material licensors shall have any liability for any direct, indirect, incidental, special, exemplary, or consequential damages (including without limitation lost profits) howsoever caused and whether made under contract, tort or otherwise arising in any way out of your use or distribution of the Third Party Material or the exercise of any rights granted under either or both this License and the legal terms applicable to any Third Party Material, even if advised in advance of the possibility of such damages.

10. GOVERNMENT REQUIREMENTS

10.1 To the extent that you are an agency, contractor or instrumentality of the U.S. Government, you and we agree that:

(a) the Arm Tools are commercial computer software and commercial computer software documentation, and that your rights therein are as specified in this License, per FAR 12.212 and DFARS 227.7202-3, as applicable, or in the case of NASA, subject to NSF 1852.22786. Arm acknowledges that, whilst commercial computer software or commercial computer software documentation shall be acquired under licenses customarily provided to the public, such licenses must be consistent with U.S. Federal law and otherwise satisfy the U.S. Government's needs ("U.S. Government Requirements"); and

(b) you may assign your rights under this License to the relevant US Government Federal Department or the successor contractor designated by the US Government Federal Department upon termination of your related prime contract with that US Government Federal Department. If you exercise your rights under this clause 10.1(b), you acknowledge and agree that you shall remain liable to Arm in respect of all your obligations under this License.

10.2 If there is any material inconsistency between (i) either a U.S. Government Requirement or a requirement of another government with which Arm is mandated by statute to comply and (ii) any provision of this License, the terms of the relevant government requirement shall prevail and the provision in question shall be deemed varied or deleted (as applicable) as required by the terms of the relevant government requirement. For the avoidance of doubt, in such circumstances, all other terms, conditions and provisions of this License will continue to be valid to the fullest extent permitted by law in accordance with the below clause 12.3.

11. TERM AND TERMINATION

11.1 Subject to clauses 11.2 and 11.3 below, this License shall remain in force until terminated by you, by Arm or (in the case of a time limited license) by expiry.

11.2 In the event of a party breaching of any of the terms and conditions of this License, which if capable of remedy, has not been remedied by that party within thirty (30) days of the date of breach, without prejudice to any of its other rights under this License, the non-breaching party may terminate this License immediately upon giving written notice to the breaching party. Upon termination of this License by you or by Arm, or upon expiry, you shall (and shall ensure that your Permitted Users shall) immediately (i) stop using the Arm Tools (or any element thereof) and any Confidential Information and, (ii) destroy all copies of the same in your possession or control, together with all Arm Documentation and related materials.

11.3 Notwithstanding the foregoing, except where Arm has terminated this License for your breach, your rights (if applicable) to distribute any of Your Software or Your Hardware developed using the Arm Tools prior to termination or expiry of this License shall (subject to your continued compliance with the terms and conditions of this License) survive such termination or expiry.

12. GENERAL

12.1 This License is governed by English Law. Notwithstanding the foregoing, to the extent that you are an agency, contractor or instrumentality of the U.S. Government, disputes arising under or relating to this License shall be decided under the U.S. federal law of government contracting, including without limitation the Contract Disputes Act. Nothing in this License shall prevent you from enforcing your intellectual property rights or seeking injunctive or other equitable relief in any court of competent jurisdiction. The parties hereby disclaim application of the United Nations Convention on Contracts for the International Sale of Goods and the Uniform Computer Information Transactions Act.

12.2 Except where Arm agrees otherwise in (i) a written contract signed by you and Arm, or (ii) a written contract provided by Arm and accepted by you, this is the only agreement between you and Arm relating to the Arm Tools and it may only be modified by written agreement between you and Arm. No terms and conditions contained in any purchase order or other document issued by you, or any advertising or other representation by you or any third party shall add to, supersede or in any way vary the terms and conditions of this License. This License (and any documents expressly incorporated into it by reference herein) represents the entire agreement between you and Arm in relation to its subject matter.

12.3 If any clause or sentence in this License is held by a court of law to be illegal or unenforceable, the remaining provisions of this License shall not be affected. Any failure by Arm to enforce any of the provisions of this License, unless waived in writing, shall not constitute a waiver of Arm's rights to enforce such provision or any other provision of this License in the future.

12.4 Subject to clause 10.1(b), neither this License or any rights granted to you under it may be assigned, sub-licensed or otherwise transferred by you to any third party without the prior written consent of Arm. An assignment shall be deemed to include, without limitation (i) any transaction or series of transactions whereby a third party acquires, directly or indirectly, the power to control the management and policies of you, whether through the acquisition of voting securities, by contract or otherwise; and (ii) the sale of more than fifty percent (50%) of your assets whether in a single transaction or series of transactions. Notwithstanding the foregoing, Arm may, in its discretion acting reasonably, separately agree to authorise the re-host of a Licensed Seat (for which additional charges may apply).

12.5 Subject to any applicable legal restrictions, including but not limited to those relating to the security of classified information, at Arm's request, (i) you agree to check your computers for installations of the Arm Tools, copies of License Keys, contents of any license server log files, individual or concurrent usage of Seats, and any other information requested by Arm relating to Arm Tools installation, usage and License Key management, and, to provide this information to Arm; and (ii) you agree that Arm may instruct appropriately qualified independent auditors to perform such checks by prior appointment during your normal business hours on reasonable notice. In respect of any audit, Arm shall bear the auditors' costs for that audit unless it reveals unlicensed usage, in which case you shall promptly reimburse Arm for all reasonable costs and expenses, including professional fees, relating to such audit. Any information which is disclosed to Arm or such auditors during checking or audit shall be treated as your confidential information and shall only be used by Arm for compliance and enforcement purposes.

12.6 The Arm Tools provided under this License are subject to U.S. export control laws, including the U.S. Export Administration Act and its associated regulations, and may be subject to export or import regulations in other countries. You agree to comply fully with all laws and regulations of the United States and other countries ("Export Laws") to ensure that the Arm Tools are not (i) exported, directly or indirectly, in violation of Export Laws, either to any countries that are subject to U.S. export restrictions or to any end user who has been prohibited from participating in the U.S export transactions by any federal agency of the U.S. government; or (ii) intended to be used for any purpose prohibited by Export Laws, including, without limitation, nuclear, chemical, or biological weapons proliferation.

Arm Document Reference LES-PRE-21260, Version 12.2, Effective Date 12 February 2019


Licensing User's Guide: License Agreement MDK v5.26 and below

License Agreement MDK v5.26 and below

The license agreement on this page is valid for MDK v5.26 and lower. Licensing Agreements page provides references to license agreements for other MDK versions.

6 Aug 2016 LEC-PRE-00559 SP-Version: 6.0

END USER LICENCE AGREEMENT FOR MDK-ARM

THIS END USER LICENCE AGREEMENT (ï¿½LICENCEï¿½) IS A LEGAL AGREEMENT BETWEEN YOU (EITHER A SINGLE INDIVIDUAL, OR SINGLE LEGAL ENTITY) AND ARM LIMITED ("ARM") FOR THE USE OF THE SOFTWARE ACCOMPANYING THIS LICENCE. ARM IS ONLY WILLING TO LICENSE THE SOFTWARE TO YOU ON CONDITION THAT YOU ACCEPT ALL OF THE TERMS IN THIS LICENCE. BY CLICKING ï¿½I AGREEï¿½ OR BY INSTALLING OR OTHERWISE USING OR COPYING THE SOFTWARE YOU INDICATE THAT YOU AGREE TO BE BOUND BY ALL OF THE TERMS OF THIS LICENCE. IF YOU DO NOT AGREE TO THE TERMS OF THIS LICENCE, ARM IS UNWILLING TO LICENSE THE SOFTWARE TO YOU AND YOU MAY NOT INSTALL, USE OR COPY THE SOFTWARE, AND YOU SHOULD PROMPTLY RETURN THE SOFTWARE TO YOUR SUPPLIER AND ASK FOR A REFUND OF ANY LICENCE FEE PAID (IF ANY).

ï¿½Clangï¿½ means a compiler front-end developed by http://clang.llvm.org

ï¿½Licence Keyï¿½ means an electronic numbered licence key issued to you by ARM to enable the use of the Software, or the built-in evaluation mode (ï¿½Evaluation Onlyï¿½) that enables, the use of the Software.

ï¿½LLVMï¿½ means a code generation and optimisation framework developed by http://llvm.org

ï¿½MDK-Plus Middlewareï¿½ means all of the following software components in object code form: (a) IPv4 networking suite; (b) USB device; (c) Flash (flash file system); (d) GUI emWin.

ï¿½MDK-Professional Middlewareï¿½ means all of the following software components in object code form: (a) IPv4 and IPv6 networking suite; (b) USB host and device; (c) Flash (flash file system); (d) GUI emWin; and (e) any other middleware software components delivered by ARM as part of the MDK Professional edition software package, and found in your installation at <install base>\ARM\PACK\Keil\MDK-Middleware.\ARM\PACK\Keil\MDK-Middleware.

ï¿½Middlewareï¿½ means either or both of the MDK-Plus Middleware and MDK-Professional Middleware, as applicable.

ï¿½Seatï¿½ means a written or electronic authorization from ARM to use and run certain components or features of the Software, only in the quantities and for the time periods stated therein, and (if applicable) only with the target devices.

ï¿½Separate Filesï¿½ means the separate files identified in Section 2 of the Schedule.

ï¿½Softwareï¿½ means any software, firmware and data accompanying this Licence, any printed, electronic or online documentation supplied with it, and any updates, upgrades, patches and modifications ARM may agree to make available to you subject to the terms and conditions of the applicable end user licence agreement. The package includes: (i) ARM Compilers targeting ARM microprocessors, including compiler, assembler, linker and libraries; (ii) KEIL uVision integrated development environment (IDE); (iii) simulation models targeting standard microcontroller devices; (iv) example application code identified in Section 1 of the Schedule (ï¿½Example Codeï¿½); (v) Middleware; (vi) device packs for third party microcontroller devices. If you have licensed MDK-Professional edition, the package will also include (a) fixed virtual platforms for certain ARM microprocessor cores; and (b) a single licence to ARMï¿½s software development tool known as ARM Development Studio for MDK (ï¿½DS-MDKï¿½).

1. LICENCE GRANTS.
(i) SOFTWARE: ARM hereby grants to you, subject to the terms and conditions of this Licence, a non-exclusive, non-transferable licence, only for the Seats, to: (a) use the Software excluding the Middleware solely for the purposes of developing, testing, debugging, analysing and optimising software applications (ï¿½Software Applicationsï¿½); and (b) use, copy and modify any or all of the Example Code as specimen Software Applications. Except as permitted by Clauses 1(ii) and 1(iv) below, you shall not modify any of the Software. Except as permitted by Clauses 1(ii) to 1(iv) below, you shall not redistribute any of the Software.

(ii) Middleware: YOU ACKNOWLEDGE AND AGREE THAT YOU SHALL NOT USE THE MDK-PLUS MIDDLEWARE OR MDK-PROFESSIONAL MIDDLEWARE (AS APPLICABLE) UNLESS YOU HAVE LICENSED EITHER MDK-ARM PLUS EDITION OR MDK-ARM PROFESSIONAL EDITION RESPECTIVELY. In respect of the Middleware, ARM hereby grants to you, provided you comply with the terms of clause 1(v), a non-exclusive, non-transferable licence, only for the Seats, to: (a) use, copy only for internal testing, evaluation, and development and testing of Software Applications; (b) incorporate, compile and link the Middleware and any modifications thereto into Software Applications; (c) reproduce and distribute the Middleware only in object code form, as part of Software Applications, and only to target microprocessors manufactured or simulated under licence from ARM; (d) permit either or both your customers and your authorised distributors to redistribute the Middleware, only in object code form and only as part of Software Applications developed by you or your pemitted users (identified in clause 2 paragraph three below).

(iii) LIBRARIES: In respect of any libraries and helper libraries identified in Section 1 of the Schedule (together ï¿½Target Librariesï¿½), ARM hereby grants to you, provided you comply with the terms of clause 1(vi), additional non-exclusive, non-transferable licences to: (a) incorporate and link the libraries into Software Applications, provided that Software Applications contain substantial additional functionality; (b) incorporate and link the helper libraries into, or use them in, Software Applications; (c) reproduce and distribute the Target Libraries, only in object code form, and only as part of Software Applications.

(iv) EXAMPLE CODE : In respect of any and all of the Example Code, ARM hereby grants to you, provided you comply with the terms of clause 1(v), additional non-exclusive, non-transferable licences to: (a) use, copy and if supplied in source form modify any and all of the Example Code, only for internal testing, evaluation, and development and testing of Software Applications; (b) incorporate, compile and link any and all of the Example Code any modifications thereto into Software Applications; (c) reproduce and distribute any or all of the Example Code, and any modifications thereto, only in object code form, and only as part of Software Applications.

(v) REDISTRIBUTION AND CONDITIONS ON REDISTRIBUTION: ARM hereby grants to you, provided you comply with terms of this clause 1 (v), additional non-exclusive, non-transferable licences to permit either or both your customers and your authorised distributors to redistribute any or all of the Example Code , and any modifications you make thereto, and Target Libraries, only in object form and only as part of Software Applications developed by you or your permitted users (identified in clause 2 paragraph three below).

If you are authorised and choose to redistribute the whole or any part of any or all of the Example Code, Target Libraries, and Middleware, you agree: (a) to ensure that they are licensed for use (1) only as part of Software Applications developed by you or your permitted users; and (2) target the ARM microprocessor architecture manufactured or simulated under licence from ARM; (b) not to use ARMï¿½s or any of its licensors names, logos or trademarks to market Software Applications; (c) to include valid copyright notices on Software Applications, and preserve any copyright notices which are included with, or in, any or all of the Example Code, Target Libraries and Middleware, as applicable; and (d) to ensure that any further redistribution of any or all of the Example Code, Target Libraries and Middleware, as applicable, is limited to redistribution by either or both your customers and your authorised distributors solely as part of Software Applications developed by you and your permitted users and that your customers and your authorised distributors comply with the terms of this Clause 1(v).

2. RESTRICTIONS ON USE OF THE SOFTWARE.

SEATS, INSTALLATION AND LICENCE KEYS: Your use of the Software is limited to the specific number of Seats issued to you by ARM. For each Seat, ARM will make a Licence Key available to you to enable use of the Software, or certain components or optional functionality in the Software, as applicable. You shall only install and use the Software and Licence Keys on computers, or virtual machines running on computers, which are owned by you (or which are in your exclusive possession under an equipment finance arrangement) and which are either: (i) located at your premises; or (ii) portable computers which shall remain in the possession and control of your employees when outside such premises. Each Seat and Licence Key shall be limited or locked to a single item of your computer hardware (also known as host ID) on which the Seat or Licence Key is initially installed, except where ARM may separately agree to authorise the transfer (also known as re-hosting) of such Seat or Licence Key to another host ID.

COPYING: You shall not use or copy the Software or Licence Keys except as expressly authorised in this Licence. You may make one additional copy of the delivered Software media or image for backup or archival purposes.

PERMITTED USERS: The Software and Licence Keys shall only be used by your employees, or by your bona fide sub-contractors for whose acts and omissions you hereby agree to be responsible for to the same extent as you are for any acts and omissions of your employees, and provided always that such sub-contractors: (i) work only onsite at your premises; (ii) comply with the terms of this Licence; (iii) are contractually obligated to use the Software and Licence Keys only for your benefit, and (iv) agree to assign all their work product and any rights they create therein in the supply of such work to you. Only the single individual, company or other legal entity to whom ARM is supplying this Licence may use the Software and Licence Keys. Except as provided in this clause, you shall not allow third parties (including but not limited to any subsidiary, parent or affiliated companies, or offsite contractors you may have) to use the Software or Licence Keys unless ARM specifically agrees otherwise with you on a case by case basis.

REMOTE USE: The Software and Licence Keys shall only be used onsite at your premises, except when used offsite by an employee (but not a sub-contractor) of yours, on a portable computer, in accordance with the ï¿½SEATS, INSTALLATION AND LICENCE KEYSï¿½ paragraph above, as part of his or her normal work activities, and only for your benefit.

MULTIPLE VERSIONS: The media on which the Software resides may contain more than one version of the Software, each of which is compatible with a different operating system (such as Microsoft Windows and Red Hat Linux). Each version may only be installed and used by you to the extent that you have valid Seats and Licence Keys from ARM. To the extent that certain components of the Software are identified for use on a specific operating system, you are only licensed to use such components to develop Software Applications for use with the relevant operating system or future compatible versions of such operating system.

EVALUATION USE RESTRICTION: If your Licence Key is Evaluation Only, or the Software is identified as MDK-Lite or as an evaluation version (collectively ï¿½Evaluation Softwareï¿½), then notwithstanding anything else in this Licence, YOU AGREE THAT YOUR USE OF THE SOFTWARE IS TECHNICALLY LIMITED, INCLUDING BUT NOT LIMITED TO TECHNICAL RESTRICTIONS IN RESPECT OF THE CODE IN WHICH IT SUPPORTS, COMPILES AND DEBUGS, AS IDENTIFIED IN THE TECHNICAL LIMITATIONS DOCUMENT SET OUT AT http://www.keil.com/demo/limits.asp.

ACADEMIC OR EDUCATIONAL USE RESTRICTION: If you or your employer or institution paid academic or educational pricing for the Software, or the Software is identified as an academic or educational version (collectively ï¿½Academic Softwareï¿½), then notwithstanding anything else in this Licence, YOU AGREE TO USE THE ACADEMIC SOFTWARE ONLY FOR ACADEMIC, NON-COMMERCIAL PURPOSES, AND ARM DOES NOT GRANT YOU ANY RIGHTS TO DISTRIBUTE OR SUB-LICENCE SOFTWARE APPLICATIONS UNDER THIS LICENCE.

REVERSE ENGINEERING: Except to the extent that such activity is permitted by applicable law you shall not reverse engineer, decompile or disassemble any of the Software. If the Software was provided to you in Europe you shall not reverse engineer, decompile or disassemble any of the Software for the purposes of error correction.

BENCHMARKING: This Licence does not prevent you from using the Software for internal benchmarking purposes. However, you shall treat any and all benchmarking data relating to the Software, and any other results of your use or testing of the Software which are indicative of its performance, efficacy, reliability or quality, as confidential information and you shall not disclose such information to any third party without the express written permission of ARM.

RESTRICTIONS ON TRANSFER OF LICENSED RIGHTS: Except to the extent permitted under European Law (where applicable) the rights granted to you under this Licence may not be assigned, sublicensed or otherwise transferred by you to any third party without the prior written consent of ARM. An assignment shall be deemed to include, without limitation: (i) any transaction or series of transactions whereby a third party acquires, directly or indirectly, the power to control the management and policies of you, whether through the acquisition of voting securities, by contract or otherwise; or (ii) the sale of more than fifty percent (50%) of your assets whether in a single transaction or series of transactions. You shall not rent or lease the Software.You shall not share the Software with contractors (except as identified in the ï¿½PERMITTED USERSï¿½ paragraph above in this Clause 2) or other third parties.

COPYRIGHT AND RESERVATION OF RIGHTS: The Software is owned by ARM or its licensors and is protected by copyright and other intellectual property laws and international treaties. The Software is licensed not sold. You acquire no rights to the Software other than as expressly provided by this Licence. You shall not remove from the Software any copyright notice or other notice and shall ensure that any such notice is reproduced in any copies of the whole or any part of the Software made by you or your permitted users.

3. SUPPORT AND MAINTENANCE.
If you purchased the Software directly from ARM, and you are not receiving it as either or both, as applicable, Evaluation Software (defined in Clause 2) and Academic Software (defined in Clause 2), you are entitled to reasonable support and maintenance for the Software, for the shorter period of: (i) the term of your licence to the Software (as specified by the Licence Key); and (ii) one (1) year, commencing on the date of purchase.

Support will be provided on any version of the Software components defined in your Seat which, at the date of your support request, is either: (a) the current version made generally available by ARM; or (b) the previous version made generally available by ARM at some time during the previous ninety (90) days.

Support will be provided by telephone, email or other written format designated by ARM, prioritised at ARMï¿½s discretion, and may not be used as a substitute for training or as additional resource for your programming projects. Maintenance will be provided in the form of updates, upgrades and patch releases to the Software as and when they are made generally available from ARM and it will only be provided on the most revsion of the Software. ARM shall be under no obligation to provide such maintenance in respect of any modifications (where permitted) to the Software.

Any updates and upgrades replace the earlier releases of the Software that you are updating and upgrading, and are not additional copies. When you update or upgrade the Software, as applicable, the Licence Key for such new release replaces your existing Licence Key. Therefore, if you are receiving the Software as an update or upgrade, you obtain no rights to and shall not install or use the update or upgrade, as applicable, unless: (i) you have ceased all use of, and deleted your Licence Key for the version of the Software that you are updating or upgrading, as applicable; and (ii) you agree to the terms and conditions of the end user licence agreement incorporated with any updates, upgrades and patch releases. You acknowledge and agree that ARM shall have no responsibility for testing that any upgrades, updates and patch releases of the Software are compatible with earlier releases of the Software.

ARMï¿½s obligation under this Clause 3 is limited to the provision of support and maintenance to you and ARM is under no obligation to provide any support and maintenance to any third parties under this Licence. If you purchase support and maintenance for additional years it will be provided pursuant to this Clause 3 and will be subject to the terms and conditions of the applicable end user licence agreement.

If: (i) you obtained the Software from an ARM authorised reseller or other third party; (ii) the Software was provided free of charge or it is Evaluation Software; or (iii) the Software is Academic Software, you are not entitled to any support for the Software from ARM directly, but ARM may, at its sole discretion provide limited support to you. Subject to the terms of your agreement with the vendor of the Software, the vendor of the Software may or may not offer support to you for the Software. Please refer to the Technical Support area of http://www.arm.com for contact details for ARMï¿½s support service and (if applicable) other authorised support channels.

4. CONFIDENTIALITY.
You acknowledge that the Software, Licence Keys, any benchmarking data and related information mentioned in Clause 2 may contain trade secrets and confidential material, and you agree to maintain all such information in confidence and apply security measures no less stringent than the measures which you apply to protect your own like information, but not less than a reasonable degree of care, to prevent their unauthorised disclosure and use. Subject to any restrictions imposed by applicable law, the period of confidentiality shall be indefinite. You agree that you shall not use any such information other than in normal use of the Software under the licences granted in this Licence.

5. LIMITED WARRANTIES.
For the period of ninety (90) days from the date of receipt by you of the Software, unless the Software is Evaluation Software, ARM warrants to you that: (i) the media on which the Software is provided shall be free from defects in materials and workmanship under normal use; and (ii) the Software will perform substantially in accordance with its accompanying documentation (if any). ARM's total liability and your exclusive remedy for breach of these limited warranties shall be limited to ARM, at ARM's option: (a) refunding the price paid by you for the Software; or (b) replacing the defective Software; or (c) using reasonable efforts to correct material, documented, reproducible defects in the Software and delivering such corrected Software to you. Any replacement Software will be warranted for the remainder of the original warranty period or thirty (30) days, whichever is longer.

EXCEPT AS MAY BE PROVIDED ABOVE, YOU AGREE THAT THE SOFTWARE IS LICENSED ï¿½AS ISï¿½, AND THAT ARM EXPRESSLY DISCLAIMS ALL REPRESENTATIONS, WARRANTIES, CONDITIONS OR OTHER TERMS, EXPRESS OR IMPLIED, OR STATUTORY, INCLUDING WITHOUT LIMITATION THE IMPLIED WARRANTIES OF NON-INFRINGEMENT, SATISFACTORY QUALITY, AND FITNESS FOR A PARTICULAR PURPOSE.

YOU EXPRESSLY ASSUME ALL LIABILITIES AND RISKS, FOR USE OR OPERATION OF SOFTWARE APPLICATIONS, INCLUDING WITHOUT LIMITATION, SOFTWARE APPLICATIONS DESIGNED OR INTENDED FOR MISSION CRITICAL APPLICATIONS, SUCH AS PACEMAKERS, WEAPONARY, AIRCRAFT NAVIGATION, FACTORY CONTROL SYSTEMS, ETC. SHOULD THE SOFTWARE PROVE DEFECTIVE, YOU ASSUME THE ENTIRE COST OF ALL NECESSARY SERVICING, REPAIR OR CORRECTION.

6. LIMITATION OF LIABILITY.
TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW, IN NO EVENT SHALL ARM BE LIABLE FOR ANY INDIRECT, SPECIAL, INCIDENTAL OR CONSEQUENTIAL DAMAGES (INCLUDING LOSS OF PROFITS) ARISING OUT OF THE USE OR INABILITY TO USE THE SOFTWARE WHETHER BASED ON A CLAIM UNDER CONTRACT, TORT OR OTHER LEGAL THEORY, EVEN IF ARM WAS ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.

ARM does not seek to limit or exclude liability for death or personal injury arising from ARM's negligence or ARMï¿½s fraud and because some jurisdictions do not permit the exclusion or limitation of liability for consequential or incidental damages the above limitation relating to liability for consequential damages may not apply to you.

NOTWITHSTANDING ANYTHING TO THE CONTRARY CONTAINED IN THIS LICENCE, THE MAXIMUM LIABILITY OF ARM TO YOU IN AGGREGATE FOR ALL CLAIMS MADE AGAINST ARM IN CONTRACT TORT OR OTHERWISE UNDER OR IN CONNECTION WITH THE SUBJECT MATTER OF THIS LICENCE SHALL NOT EXCEED THE GREATER OF: (I) THE TOTAL OF SUMS PAID BY YOU TO ARM (IF ANY) FOR THIS LICENCE; AND; (II) US$10.00. THE EXISTENCE OF MORE THAN ONE CLAIM WILL NOT ENLARGE OR EXTEND THE LIMIT.

7. THIRD PARTY RIGHTS.
The Separate Files are delivered subject to and your use is governed by their own separate licence agreements. This Licence does not apply to such Separate Files and they are not included in the term ï¿½Softwareï¿½ under this Licence. You agree to comply with all terms and conditions imposed on you in respect of such Separate Files including those identified in the Schedule (ï¿½Third Party Termsï¿½).

ARM HEREBY DISCLAIMS ANY AND ALL WARRANTIES EXPRESS OR IMPLIED FROM ANY THIRD PARTIES REGARDING ANY SEPARATE FILES, ANY THIRD PARTY MATERIALS INCLUDED IN THE SOFTWARE, ANY THIRD PARTY MATERIALS FROM WHICH THE SOFTWARE IS DERIVED (COLLECTIVELY ï¿½OTHER CODEï¿½), AND THE USE OF ANY OR ALL THE OTHER CODE IN CONNECTION WITH THE SOFTWARE, INCLUDING (WITHOUT LIMITATION) ANY WARRANTIES OF SATISFACTORY QUALITY OR FITNESS FOR A PARTICULAR PURPOSE.

NO THIRD PARTY LICENSORS OF OTHER CODE SHALL HAVE ANY LIABILITY FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING WITHOUT LIMITATION LOST PROFITS), HOWEVER CAUSED AND WHETHER MADE UNDER CONTRACT, TORT OR OTHER LEGAL THEORY, ARISING IN ANY WAY OUT OF THE USE OR DISTRIBUTION OF THE OTHER CODE OR THE EXERCISE OF ANY RIGHTS GRANTED UNDER EITHER OR BOTH THIS LICENCE AND THE LEGAL TERMS APPLICABLE TO ANY SEPARATE FILES, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.

The Software includes materials supplied by third party device manufacturers for use with their relevant target microcontroller devices. To the extent such materials are either: (i) identified as such in the Software (for example in a ï¿½Help Aboutï¿½ box or on-screen copyright message), or (ii) presented, in a standard installation, for selection by you at a path name or file name which contains the name of the relevant manufacturer or device, you agree to use such materials (if at all) only to develop applications for the relevant devices of that vendor.

The FlashFS libraries FS_ARM_L.lib, FS_ARM_B.lib, FS_CM1.lib, FS_CM3.lib, FS_LFN_CM0_B.lib, FS_LFN_CM0_L.lib, FS_LFN_CM3_B.lib and FS_LFN_CM3_L.lib include source code that is capable of supporting a file system with long filenames in Software Applications that you develop. You warrant to ARM that unless you have first obtained a licence from Microsoft for its FAT file system with long filename support then you will not develop or distribute Software Applications that include a file system with long filenames (see https://www.microsoft.com/en-us/legal/intellectualproperty/mtl/technologylicensing.aspx for more details). As an alternative, the libraries FSN_ARM_L.lib, FSN_ARM_B.lib, FSN_CM1.lib, FSN_CM3.lib, FS_SFN_CM0_B.lib, FS_SFN_CM0_L.lib, FS_SFN_CM3_B.lib and FS_SFN_CM3_L.lib are not capable of supporting a file system with long filenames and are licensed to you as part of the Software provided under this Licence.

Distribution of code from the Rogue Wave C++ libraries (located in your installation at <install base>\ARM\ARMCC\lib\cpplib) is permitted only if: (a) you are granted the right to redistribute those libraries under Clause 1 of this Licence; and (b) they do not constitute a major portion of the value of the Software Applications. No right is granted to use those libraries on any computers as are marketed or commonly considered to be mainframe computers in the computer industry. Notwithstanding any provisions in this Licence to the contrary, you shall not: (i) distribute in any manner any of the header files, object modules, template-based classes, or independent static libraries of the Rogue Wave C++libraries or documentation relating thereto; (ii) distribute any portion of the same in a software utility product or otherwise in competition with Rogue Wave Software Incï¿½s distribution thereof. ï¿½Rogue Waveï¿½ is a registered trademark of Rogue Wave Software, Inc.

To the extent that you purchase the Software with a dongle key from ARM or its authorised distributors, you are only permitted to use the Software in conjunction with such dongle key.

8. U.S. GOVERNMENT END USERS.
US Government Restrictions: Use, duplication, reproduction, release, modification, disclosure or transfer of this Software is restricted in accordance with the terms of this Licence.

9. TERM AND TERMINATION.
This Licence shall remain in force until terminated by you, by ARM or by expiry (in the case of a time limited licence). Without prejudice to any of its other rights if you are in breach of any of the terms and conditions of this Licence then ARM may terminate this Licence immediately upon giving written notice to you. You may terminate this Licence at any time. Upon termination of this Licence by you or by ARM or upon expiry: (i) you shall stop using the Software confidential information and destroy all copies of the Software and confidential information in your possession together with all documentation and related materials; and (ii) ARMï¿½s obligations to provide support and maintenance shall terminate immediately. Notwithstanding the foregoing, except where ARM has terminated this Licence for your breach, your rights to distribute any or all of, as applicable, the Example Code, Target Libraries and Middleware, as part of Software Applications developed prior to termination or expiry shall survive termination or expiry of this Licence, subject to the terms and conditions of this Licence.

The provisions of clauses 4, 5, 6, 7, 8, 9 and 10 shall survive termination or expiry of this Licence.

10. GENERAL.
This Licence is governed by English Law. Except where ARM agrees otherwise in: (i) a written contract signed by you and ARM; or (ii) a written contract provided by ARM and accepted by you, this is the only agreement between you and ARM relating to the Software and it may only be modified by written agreement between you and ARM. Except as expressly agreed in writing, this Licence may not be modified by purchase orders, advertising or other representation by any person. If any clause or sentence in this Licence is held by a court of law to be illegal or unenforceable the remaining provisions of this Licence shall not be affected thereby. The failure by ARM to enforce any of the provisions of this Licence, unless waived in writing, shall not constitute a waiver of ARM's rights to enforce such provision or any other provision of this Licence in the future.

At ARMï¿½s request, you agree to check your computers for installations of the Software, copies of Licence Keys, contents of any licence server log files, individual or concurrent usage of Seats, and any other information requested by ARM relating to Software installation, usage and Licence Key management, and to provide this information to ARM. You agree that auditors nominated by ARM may also perform such checking and reporting on behalf of ARM by prior appointment during your normal business hours on seven (7) daysï¿½ notice. ARM shall bear the auditorsï¿½ costs for that audit unless it reveals unlicensed usage in which case you shall promptly reimburse ARM for all reasonable costs and expenses, including professional fees, relating to such audit. Any information which is disclosed to ARM or such auditors during checking or audit shall be treated as your confidential information and shall only be used by ARM for licence management, compliance and enforcement purposes.

The Software provided under this Licence is subject to U.S. export control laws, including the U.S. Export Administration Act and its associated regulations, and may be subject to export or import regulations in other countries. You agree to comply fully with all laws and regulations of the United States and other countries ("Export Laws") to assure that the Software, is not (1) exported, directly or indirectly, in violation of Export Laws, either to any countries that are subject to U.S.A. export restrictions or to any end user who has been prohibited from participating in the U.S.A. export transactions by any federal agency of the U.S.A. government; or (2) intended to be used for any purpose prohibited by Export Laws, including, without limitation, nuclear, chemical, or biological weapons proliferation.

THE SCHEDULE

SECTION 1

  9. I. Target Libraries (object code): Libraries: C Libraries, ABI libraries, C++ runtime support library, RogueWave C++ Libraries, Software floating-point libraries, VFP support; and Helper Libraries: ARM Compiler libraries found in your installation at <install base>\ARM\<toolchain name>\lib
  10. J. Example code found in the software packs in the default directory <install base>\ARM\Pack\Keil or the pack directory selected during installation.

SECTION 2 ï¿½ SEPARATE FILES

  1. XERCES XML parser (libxerces-c.so, xerces-c_3.0.0.dll): these files are licensed to you under the Apache Software License, Version 2.0.
  2. Scintilla, an editor tool which enables the debugging and editing of source code is licensed to you under the Historical Permission Notice and Disclaimer, an open source license approved by the Open Source Initiative.
  3. The Cortex Microcontroller Software Interface Standard (ï¿½CMSISï¿½) deliverables, which includes the following components: (a) CMSIS-Core; (b) CMSIS-DAP; (c) CMSIS-RTOS API; and (d) CMSIS-SVD. The CMSIS deliverables are subject to their own separate terms and conditions which are either incorporated within or alongside the aforementioned components.
  4. LLVM is licensed to you under the University of Illinos/NCSA Open Source License.
  5. Clang is licensed to you under the University of Illinois/NCSA Open Source License.
  6. libstdc++ is licensed to you under the GNU General Public License version 3, plus runtime exception.
  7. libC++ and libC++ ABI (including ARMï¿½s modifications) are licensed to you under either the University of Illinois/NCSA Open Source License or the MIT license.

If you have licensed MDK-Professional edition, the package may also include:

  8. Libgcc is licensed to you under the GNU General Public License version 3, plus runtime exception.
  9. SDL v1.2.15 is licensed to you under the GNU Lesser General Public License, version 2.1*
  10. Zlib v1.2.8 is licensed to you under the Zlib license
  11. ARM Development Studio for MDK (ï¿½DS-MDKï¿½) is licensed under the DS-5 Development Studio for MDK end user licence agreement, which is incorporated into the component.
  12. The mbed TLS and mbed Client libraries, are licensed to you under the Apache Software License, version 2.0.

ARM contract references: LEC-PRE-00559-V6.0 MDK-ARM


Licensing User's Guide: License Agreement MDK v5.27 and above

License Agreement MDK v5.27 and above

END USER LICENSE AGREEMENT FOR ARM SOFTWARE DEVELOPMENT TOOLS

This end user license agreement ("License") is a legal agreement between you (a single individual), or the company or organisation (a single legal entity) that you represent and have the legal authority to bind, and Arm relating to use of the Arm Tools. Arm is only willing to license the Arm Tools on condition that you accept all of the terms of this License. By clicking "I Agree" or by installing or otherwise using the Arm Tools and/or any Update thereto (as permitted by this License) you indicate that you agree to be bound by all of the terms and conditions of this License. If you do not agree to the terms of this License, Arm will NOT license the Arm Tools to you, you may not install or use the Arm Tools or any part thereof, and you shall promptly return the Arm Tools to Arm or to your supplier (if not Arm) and ask for a refund of the license fee paid (if any).

NOTE - YOUR ATTENTION IS DRAWN TO THE FOLLOWING:

(A) The terms and conditions set out in this License shall apply to the supply by Arm of Arm Tools for both commercial and non-commercial use. If you are in receipt of a Non-Commercial Use License for the Arm Tools (each capitalised term as defined below), or the Arm Tools or any component thereof are identified or classified as such, or you are receiving a license for the Arm Tools free of charge, then notwithstanding any of the other terms and conditions of this License, your use of the Arm Tools shall be limited by the restrictions of use set out in clause 2.2 of this License.

(B) PLEASE NOTE any terms and conditions of use set out in the order documentation provided to you by Arm and the Software Information File(s) (as defined below) applicable to the Arm Tools provided to you with (or included within) either (i) the Arm Tools, and/or (ii) any Updates to the Arm Tools, which limit, extend or otherwise vary the permitted uses and restrictions applicable to the Arm Tools ("Special Conditions"). The Special Conditions form part of and are incorporated into this License. In the event of any conflict or inconsistency between the provisions set out in the main body of this License and any of the Special Conditions, the provisions set out in the Special Conditions shall prevail (in the order in which they are listed in this paragraph).

(C) This License (and any documents incorporated by reference herein) is the sole and exclusive agreement between you and Arm for the Arm Tools, and (except as agreed in writing to the contrary) no other document, including (but not limited to) your purchase order or any other document supplied by you, will form part of this License.

DEFINITIONS

For the purposes of this License the following words and expressions shall have the following meanings:

"Arm" means Arm Limited whose registered office is situated at 110 Fulbourn Road, Cambridge CB1 9NJ, England and/or any member of Arm's group of companies.

"Arm Documentation" means any printed, electronic or online documentation relating to Arm Software licensed to you by Arm under this License.

"Arm Software" means any and all software, firmware and data licensed to you by Arm under this License.

"Arm Tools" means any and all Arm Software and/or Arm Documentation owned or licensed by Arm, and any Updates to the Arm Software and/or Arm Documentation.

"Arm Tools Performance Data" means any results, benchmarking data or other information relating to or connected with your use or testing of the Arm Tools which are indicative of their performance, efficacy, reliability or quality.

"Fees" means any fee(s) payable by you for the provision by Arm to you of the Arm Tools and associated support and maintenance services, and any other fees payable by you in accordance with this License that are agreed by the parties from time to time.

"License Key" means an electronic license key issued to you by Arm which enables you to use and run one or more Licensed Seat of an Arm Tool or a component thereof in accordance with the terms of this License.

"Licensed Seats" means any and all Seats of the Arm Tools (including, if applicable, Updates) that you are licensed to run and use concurrently under the terms of this License, in the types and quantities specified in the order documentation provided to you by Arm, as well as any additional or replacement Seats of the Arm Tools that Arm agrees to provide to you from time to time during the License Term.

"License Term" means the term set out in the order documentation provided to you by Arm during which you shall be entitled to access and use the Arm Tools.

"Non-Commercial Use License" means an evaluation, preview, beta, pre-release, pilot, academic, educational or community use only license.

"Permitted Users" means your employees, workers, consultants, professional advisors, bona fide sub-contractors and service providers that use the Arm Tools in connection with the provision of work carried out for your benefit, and/or, other members of your organisation or third party users who use the Arm Tools with your express written permission on computers (physical or virtual) owned or controlled by you.

"Redistributables" means the example code, library files, configuration files, header files, and any other Arm Tools or components thereof owned by Arm (or licensed by Arm and provided to you under Arm's terms and conditions) which you are permitted to include within Your Software and redistribute or sub-license within Your Software to third parties, the details of which (if applicable) are set out in a file or folder (the "Redistributables File") typically named 'redistributables' located within an Arm Tool (or components thereof).

"Seat" means a written or electronic authorisation to run a software component subject to the terms and restrictions specified in that authorisation.

"Software Information File(s)" means Third Party Licenses Files, Redistributables Files, and/or Supplementary Terms Files (as the context requires).

"Special Conditions" is as defined above in Recital (B) of this License.

"Specified Project" means a single design and development activity undertaken by you or your Permitted Users relating to Your Software or Your Hardware, the details of which will be set out in the order documentation provided to you by Arm.

"Supplementary Terms File" means a software file or folder typically named 'supplementary_terms' located within an Arm Tool (or components thereof) which (if applicable) details any component-specific extensions, limitations or other variations to the terms of this License.

"Territory" means, if applicable, the geographical area detailed in the order documentation provided to you by Arm to which your use of the Arm Tools or any part thereof is restricted.

"Third Party Licenses File" means a software file or folder typically named 'third_party_licenses' located within an Arm Tool (or components thereof) which (if applicable) details any third party material included in the relevant Arm Tool which is not licensed under the terms of this License, and a reference to the applicable third party license terms and conditions.

"Update" means an update, patch, hotfix, bug fix, support release, modification or limited functional enhancement (as applicable) to an Arm Tool or component thereof, including but not limited to error corrections to any program or associated documentation developed by or for Arm comprised in the Arm Tools, which (i) Arm makes generally available to the market, and (ii) does not, in Arm's opinion, constitute an Upgrade or a new product.

"Upgrade" means a new release of an existing Arm Tool which Arm makes generally available to the market and which usually contains major functional improvements.

"Your Hardware" means hardware manufactured or developed by you or on your behalf, or hardware owned or licensed by you, which is supported by the Arm Tools.

"Your Reports" means any written reports or other information relating to the behavior or performance of Your Software or Your Hardware, in html, binary, text or any other format (excluding for the avoidance of doubt, Arm Tools Performance Data), generated by you from or using the Arm Tools and any modifications thereto.

"Your Software" means any software owned or licensed by you (including, but not limited to, applications, libraries and Arm API compliant plug-ins, but excluding Arm Software) which is supported by (or developed by you using) the Arm Tools.

1. LICENSE GRANT

1.1 Subject to your compliance with the terms and conditions of this License, and payment by you of the Fees (if any), Arm hereby grants to you and your Permitted Users during the License Term a non-exclusive, non-transferable license to receive and use the Arm Tools, certain components thereof, or optional functionality, in the Territory only on the Licensed Seats or for a Specified Project (as applicable) for the permitted uses set out in this clause 1 and subject to the restrictions set out in clause 2 (as limited, extended or otherwise varied by any terms, including product-specific permitted uses and restrictions, set out in the Special Conditions). Except as expressly permitted by this License, you and your Permitted Users shall NOT copy, modify, sub-license, redistribute or otherwise use any component of the Arm Tools.

1.2 PERMITTED USE OF THE ARM TOOLS: Except as otherwise provided in this License, use of the Arm Tools (or components thereof) is permitted for the purpose of:

(a) building, developing, testing, debugging, analysing and optimising Your Software or Your Hardware;

(b) generation of Your Reports, and use of Your Reports to develop, test, debug, analyse and optimise Your Software or Your Hardware; and

(c) only as expressly provided in the relevant Redistributables File: (i) incorporating, compiling and/or linking the files listed in that Redistributables File into Your Software, provided that Your Software contains substantial additional functionality; and (ii) subject to clause 2.1 below, reproducing and redistributing the files (and permitting your customers and/or your authorised distributors to reproduce and redistribute the files), only in object code form (unless otherwise specified in the relevant Redistributables Files), and only as part of Your Software. You agree that, except as expressly provided to the contrary in the relevant Redistributables File, you may only copy the Arm Tools (or any component thereof) to the extent that such copying is incidental to the permitted uses set out in this clause 1.2, including installation, backup and execution.

2. YOUR OBLIGATIONS AND RESTRICTIONS ON USE

2.1 OBLIGATIONS RELATING TO REDISTRIBUTION: Any redistribution as permitted by this License is subject to any restrictions set out in the applicable Special Conditions, and your compliance with the following:

(a) in cases where you are expressly permitted under this License (including for the avoidance of doubt by inclusion of agreed wording in the order documentation provided to you by Arm) to sub-license or redistribute any component of the Arm Tools to your customers, authorised distributors or other third parties, you are responsible for ensuring that such customers, authorised distributors and third parties accept, and are contractually bound (by agreement with you or directly with Arm) to comply with, the terms and conditions of this License;

(b) Any use by you of Arm's or any of its licensors' names, logos or trademarks to publicise or market any of Your Software containing (or developed or generated using) Arm Tools is subject to you obtaining express written permission from Arm;

(c) You warrant that you shall not make any representations or warranties on behalf of Arm in respect of any of the Arm Tools or in respect of any other software, reports or documentation developed or generated by you in accordance with the license grants set out in this License;

(d) You must reproduce or preserve (as applicable) any copyright notices which are included in or with any Arm Tools or components thereof; and

(e) Except as otherwise agreed by Arm (including for the avoidance of doubt by inclusion of the relevant permission in a Supplementary Terms File), you may not disclose or otherwise distribute any Arm Tools Performance Data. For the avoidance of doubt, nothing in this sub-clause 2.1 (e) shall prevent you from disclosing or otherwise distributing Your Reports.

2.2 NON-COMMERCIAL USE AND FREE OF CHARGE LICENSES: If you are in receipt of a Non-Commercial Use License for the Arm Tools, or the Arm Tools or any component thereof are identified or classified as such, and/or you are receiving the Arm Tools free of charge, then notwithstanding any of the other terms and conditions of this License, your use (which includes use by your Permitted Users) of the Arm Tools is limited as follows:

(a) if you are receiving the Arm Tools free of charge:

  • (i) no support or maintenance shall be provided to you in respect of the Arm Tools;
  • (ii) the warranty set out in clause 7.1 of this License does not apply to you or your use of the Arm Tools, and Arm gives no other warranty whatsoever in relation to (and accepts no liability in connection with) the Arm Tools or your use (as permitted by this License) of them;
  • (iii) Arm may immediately terminate this License at any time for any reason by giving written notice to you;
  • (iv) except as otherwise expressly agreed in writing by Arm, you shall grant to Arm in full the license set out in clause 3.2 of this License; and/or
    • (b) if you are receiving a Non-Commercial Use License or version (as applicable) of the Arm Tools:
  • (i) you and your Permitted Users may use the Arm Tools for internal use only; and
  • (ii) you are not permitted to distribute or sub-license (A) any part of the Arm Tools, or (B) Your Software, Your Hardware, or Your Reports developed under this License using the Arm Tools. The Arm Tools shall be used only by you and your Permitted Users, and you shall not (except as otherwise authorised in writing by Arm) allow any other third party whatsoever to use the Arm Tools.

For the avoidance of doubt, if you are receiving a Non-Commercial Use License and the license is provided to you free of charge, the restrictions in both sub-clauses (a) and (b) above will apply to your use of the Arm Tools.

2.3 LICENSE TYPES: Depending on the type of license you have agreed to purchase from Arm under this License (the details of which are set out in the order documentation provided to you by Arm), your use of the Arm Tools shall be limited to:

(a) use of each Licensed Seat (i) by one individual named Permitted User only on a specified item of computer hardware ('named-user license'), OR (ii) by one individual Permitted User at a time only on a specified item of computer hardware ('node-locked license'), OR (iii) by one individual Permitted User at a time on specified items of computer hardware ('floating license'). In respect of 'node-locked licenses', each Licensed Seat may only be used for one 'process' at any one time. For the purpose of this sub-clause 2.3 (a), each 'process' is the execution of an instance of an Arm Tool; or

(b) use for a Specified Project.

2.4 PERMITTED USERS: You hereby agree to be responsible for the acts and omissions of any and all Permitted Users, and shall ensure that such Permitted Users (i) are contractually obliged to comply with the terms of this License, including those relating to confidentiality; and (ii) do not supply the Arm Tools or any components thereof to any third party whatsoever. Except as expressly provided in this License or as agreed in writing by Arm on a case by case basis, you shall not sub-license, redistribute, lease, rent or otherwise allow any third party to use the Arm Tools or License Keys.

2.5 REVERSE ENGINEERING: Your use of the Arm Tools shall specifically exclude the reverse engineering, decompiling, disassembly, translation, adaptation, arrangement or other alteration of any part of the Arm Tools (except to the extent that applicable law overrides this provision or any part hereof).

2.6 COPYRIGHT AND RESERVATION OF RIGHTS: The Arm Tools are owned by Arm and/or its licensors and are protected by copyright and other intellectual property rights, laws and international treaties. The Arm Tools are licensed not sold. Except as expressly provided by this License, you acquire no rights to the Arm Tools or any element thereof, or to any other Arm products or services. You shall not remove from the Arm Tools any copyright notice or other notice and shall ensure that any such notice is reproduced in any permitted reproduction of the whole or any part of the Arm Tools.

2.7 TECHNICAL RESTRICTIONS IN THE ARM TOOLS: You must comply with any technical restrictions in the Arm Tools and License Keys, including any restrictions that restrict use to certain components of the Arm Tools or use only for certain purposes. You shall not work around any such technical restrictions.

2.8 ARM DOCUMENTATION: You may use the Arm Documentation (if any) internally only in conjunction with your use of the Arm Software to which it relates.

3. LICENSE OF FEEDBACK TO ARM

3.1 You may at your discretion deliver any suggestions, comments, feedback, ideas, or know-how (whether in oral or written form) to Arm relating to or connected with your use of the Arm Tools ("Feedback"). Notwithstanding the foregoing, you shall not knowingly give to Arm any Feedback that you are aware (or should reasonably be aware) is subject to any patent, copyright or other intellectual property claim or right of any third party.

3.2 Except as expressly notified by you to Arm (in writing which may include email) to the contrary, you hereby grant to Arm under your and your affiliates (as applicable) intellectual property, a perpetual, irrevocable, royalty free, non-exclusive, worldwide license to: (i) use, copy, modify, and create derivative works of the Feedback; (ii) sell, supply or otherwise distribute the whole or any part of the Feedback (and derivative works thereof) as part of any Arm owned or licensed product(s) without obligation or restriction of any kind; and (iii) sub-license to third parties the foregoing rights, including the right to sub-license to further third parties. No right is granted by you to Arm to sub-license your and your affiliates (as applicable) intellectual property except to the extent that it is provided to Arm as Feedback and is embodied in any Arm owned or licensed product(s). For the avoidance of doubt, if, during the License Term, you provide notice to Arm revoking the license granted under this clause 3.2, you acknowledge and agree that such revocation shall not apply to Feedback delivered to Arm prior to the date of receipt of the revocation notice, and that (notwithstanding the foregoing) Arm shall continue to be permitted to use Feedback received after the date of receipt of the revocation notice for internal purposes.

3.3 Except as expressly licensed to Arm in clause 3.2, you retain all right, title and interest in and to the Feedback provided by you under this License.

4. DATA COLLECTION AND PRIVACY

4.1 The Arm Software may include features that enable it to transmit certain computer information over the internet to Arm's and/or its service providers' computer systems, for example your computer's internet protocol address, computer hardware and operating system details, or the serial numbers of the Arm Tools you have licensed. This information will not be shared with any third parties, and shall be used by Arm only for the purpose of Arm protecting its legitimate interests, which may include Arm verifying your right to use the Arm Tools and monitoring your compliance with the permitted uses and restrictions set out in this License.

4.2 Arm may also collect anonymous data, which, for the avoidance of doubt, cannot be used to identify individual users of the Arm Tools. This information may be used by Arm to help us understand and analyse what components or features in the Arm Tools our end users are using in order to (i) maintain and improve the quality of the Arm Tools and the end user experience, (ii) inform end users of relevant new and improved products and services, and (iii) assist end users to maximise the performance of, or solve user experience issues with, the Arm Tools.

4.3 Information collected by the Arm Software will only be used for the aforementioned purposes. Please refer to the Arm Privacy Policy https://www.arm.com/company/policies/privacy for further information on how Arm collects, uses and safeguards personal data (including but not limited to personal data collected for the protection of Arm's legitimate interests and your rights to object to its collection).

5. SUPPORT AND MAINTENANCE

5.1 Provision of reasonable support and maintenance is subject to payment by you of all applicable Fees.

5.2 Any support provided by Arm in accordance with the above clause 5.1 shall (i) be provided by telephone, email or such other format as is designated by Arm, (ii) be prioritised at Arm's discretion, and (iii) not be used as a substitute for training or as additional resource for your projects.

5.3 Maintenance will generally be provided in the form of Updates to the Arm Tools. Arm shall be under no obligation to provide such maintenance in respect of any modifications made by you (where permitted) to the Arm Tools. Updates do not constitute additional Licensed Seats and may only be used by you if you have an active Licensed Seat to run and use such Updates. Updates will generally be provided to you as soon as reasonably practicable following the date of general public release of the Update by Arm.

5.4 In cases where the Arm Tools were provided to you free of charge, you are not entitled to any support or maintenance for the Arm Tools from Arm, but Arm may, in its sole discretion, provide support to you. If you obtained the Arm Tools from an Arm authorised distributor, reseller or other third party, support and maintenance may be provided by either Arm or the third party as per the terms of your contract for supply. Arm shall not be responsible for any delay or failure in connection with any third party supplier providing support or maintenance that it is obligated to provide to you. Please refer to the 'Support' area of https://www.arm.com for details of Arm's support services, relevant contact details, and (if applicable) details of other authorised support channels.

5.5 Arm's obligations under this clause 5 are limited to the provision of support and maintenance to you, and Arm is under no obligation to provide any support and maintenance to any third parties. You agree to provide all front line support services to all third parties to whom you distribute any Arm Tools, Your Reports, Your Software or Your Hardware, pursuant to and in accordance with the terms of this License.

5.6 This License does not grant you any entitlement to receive (i) Upgrades, (ii) Arm products other than those specified in your product documentation, or (iii) any new products developed or introduced by Arm from time to time, nor to receive any support or maintenance in respect of the same.

6. CONFIDENTIALITY

6.1 You acknowledge that the Arm Tools, License Keys, Arm Tools Performance Data, and any and all other software, documentation or other information licensed to you by Arm, or provided to you during discussions about or in connection with the Arm Tools (including this License and information provided during the provision by Arm of any support), contain trade secrets and confidential information of Arm ("Confidential Information").

6.2 You agree to maintain all such Confidential Information in confidence and apply security measures (such measures to be no less stringent than the measures which you apply (or should reasonably apply) to protect your own like information, but not less than a reasonable degree of care) to prevent their unauthorised disclosure and use.

6.3 Subject to any restrictions imposed by applicable law, the period of confidentiality shall be five (5) years from the date of disclosure of the Confidential Information. You agree that you shall not use any such information other than in your normal use of the Arm Tools as permitted by this License.

7. LIMITED WARRANTIES

7.1 Subject to the restrictions in clause 2, for the period of ninety (90) days from the date of receipt by you of the Arm Tools, Arm warrants to you that (i) the media on which any Arm Software is provided shall be free from defects in materials and workmanship under normal use; and (ii) the Arm Software will perform substantially in accordance with the accompanying Arm Documentation (if any). Arm's total liability and your exclusive remedy for breach of these warranties shall be limited to Arm, at Arm's option (a) replacing the defective Arm Software; or (b) using reasonable efforts to correct material, documented, reproducible defects in the Arm Software and delivering such corrected Arm Software to you; or (c) if you licensed the Arm Software directly from Arm, refunding the price paid by you to Arm for that Arm Software. Any replacement Arm Software will be warranted for the remainder of the original warranty period or thirty (30) days from the date of replacement, whichever is longer.

7.2 The Arm Software described in any Arm Documentation is subject to continuous development and improvement. All particulars of the Arm Software and its use as described in the Arm Documentation are given by Arm in good faith. Consequently, the information contained in the Arm Documentation is subject to change without notice and is not warranted to be error free. If you discover any errors in the Arm Documentation please report them to Arm in writing. Any Arm Documentation provided to you that relates to specific industry quality and functional safety standard compliance may assist you in applying to a competent auditor for certification of Your Software or Your Hardware, but you acknowledge and agree that on its own such Arm Documentation may not provide sufficient evidence of, or be compatible with, the required safety compliance standards.

7.3 Except as provided in clause 7.1 above, you agree that the Arm Tools are licensed "as is", and that Arm expressly disclaims all representations, warranties, conditions or other terms, express or implied or statutory, including without limitation the implied warranties of non-infringement, satisfactory quality, and fitness for a particular purpose. You acknowledge that it is your responsibility to satisfy yourself that the Arm Tools are fit for the intended purpose and satisfy your requirements, including compatibility with Your Hardware, and you expressly assume all liabilities and risks relating to (i) any use of an Arm Tool which is inconsistent with its design or any guidance provided to you in the applicable Arm Documentation, and/or (ii) any use of an Arm Tool with Your Software or Your Hardware where such software or hardware (as applicable) is not supported by or compatible with the relevant Arm Tool.

7.4 You expressly assume all liabilities and risks relating to your use or operation of Your Software and Your Hardware designed or modified using the Arm Tools, including without limitation, Your software or Your Hardware designed or intended for safety-critical applications. Should Your Software or Your Hardware prove defective, you assume the entire cost of all necessary servicing, repair or correction.

8. LIMITATION OF LIABILITY

8.1 To the maximum extent permitted by applicable law, in no event shall Arm be liable for any indirect, special, incidental or consequential damages (including loss of profits) arising out of the use of, or inability to use, the Arm Tools, whether based on a claim under contract, tort or otherwise, even if Arm was advised of the possibility of such damages.

8.2 Arm does not seek to limit or exclude liability for death or personal injury arising from Arm's negligence or Arm's fraud. Arm acknowledges that certain jurisdictions do not permit the exclusion or limitation of liability for consequential or incidental damages, and in such cases the above limitation relating to liability for consequential damages may not apply to you.

8.3 Notwithstanding anything to the contrary contained in this License, the maximum liability of Arm to you in aggregate (in contract, tort or otherwise) in relation to or in connection with the subject matter of this License shall not exceed the greater of (i) the total sums paid by you to Arm (if any) for this License, and (ii) $10.00 USD. The existence of more than one claim will not enlarge or extend the limit.

9. THIRD PARTY MATERIAL

9.1 The Arm Tools may contain material owned or developed by third parties, including but not limited to open source software, freeware and commercial software ("Third Party Material"). Any Third Party Material is subject to the terms and conditions of the applicable Third Party Material license(s) and is not covered under the terms of this License. Details relating to such Third Party Material shall either be presented to you at the time of installation or shall be detailed in the Third Party Licenses File(s). Your use of such Third Party Material is subject to your compliance with the applicable Third Party Material license(s).

9.2 Arm hereby disclaims any and all warranties express or implied from any third parties regarding, or otherwise connected with, any Third Party Material included in the Arm Tools and any Third Party Material from which the Arm Tools are derived, and/or your use of any or all of the Third Party Material in connection with Your Software or Your Hardware, including (without limitation) any warranties of satisfactory quality or fitness for a particular purpose.

9.3 No Third Party Material licensors shall have any liability for any direct, indirect, incidental, special, exemplary, or consequential damages (including without limitation lost profits) howsoever caused and whether made under contract, tort or otherwise arising in any way out of your use or distribution of the Third Party Material or the exercise of any rights granted under either or both this License and the legal terms applicable to any Third Party Material, even if advised in advance of the possibility of such damages.

10. GOVERNMENT REQUIREMENTS

10.1 To the extent that you are an agency, contractor or instrumentality of the U.S. Government, you and we agree that:

(a) the Arm Tools are commercial computer software and commercial computer software documentation, and that your rights therein are as specified in this License, per FAR 12.212 and DFARS 227.7202-3, as applicable, or in the case of NASA, subject to NSF 1852.22786. Arm acknowledges that, whilst commercial computer software or commercial computer software documentation shall be acquired under licenses customarily provided to the public, such licenses must be consistent with U.S. Federal law and otherwise satisfy the U.S. Government's needs ("U.S. Government Requirements"); and

(b) you may assign your rights under this License to the relevant US Government Federal Department or the successor contractor designated by the US Government Federal Department upon termination of your related prime contract with that US Government Federal Department. If you exercise your rights under this clause 10.1(b), you acknowledge and agree that you shall remain liable to Arm in respect of all your obligations under this License.

10.2 If there is any material inconsistency between (i) either a U.S. Government Requirement or a requirement of another government with which Arm is mandated by statute to comply and (ii) any provision of this License, the terms of the relevant government requirement shall prevail and the provision in question shall be deemed varied or deleted (as applicable) as required by the terms of the relevant government requirement. For the avoidance of doubt, in such circumstances, all other terms, conditions and provisions of this License will continue to be valid to the fullest extent permitted by law in accordance with the below clause 12.3.

11. TERM AND TERMINATION

11.1 Subject to clauses 11.2 and 11.3 below, this License shall remain in force until terminated by you, by Arm or (in the case of a time limited license) by expiry.

11.2 In the event of a party breaching of any of the terms and conditions of this License, which if capable of remedy, has not been remedied by that party within thirty (30) days of the date of breach, without prejudice to any of its other rights under this License, the non-breaching party may terminate this License immediately upon giving written notice to the breaching party. Upon termination of this License by you or by Arm, or upon expiry, you shall (and shall ensure that your Permitted Users shall) immediately (i) stop using the Arm Tools (or any element thereof) and any Confidential Information and, (ii) destroy all copies of the same in your possession or control, together with all Arm Documentation and related materials.

11.3 Notwithstanding the foregoing, except where Arm has terminated this License for your breach, your rights (if applicable) to distribute any of Your Software or Your Hardware developed using the Arm Tools prior to termination or expiry of this License shall (subject to your continued compliance with the terms and conditions of this License) survive such termination or expiry.

12. GENERAL

12.1 This License is governed by English Law. Notwithstanding the foregoing, to the extent that you are an agency, contractor or instrumentality of the U.S. Government, disputes arising under or relating to this License shall be decided under the U.S. federal law of government contracting, including without limitation the Contract Disputes Act. Nothing in this License shall prevent you from enforcing your intellectual property rights or seeking injunctive or other equitable relief in any court of competent jurisdiction. The parties hereby disclaim application of the United Nations Convention on Contracts for the International Sale of Goods and the Uniform Computer Information Transactions Act.

12.2 Except where Arm agrees otherwise in (i) a written contract signed by you and Arm, or (ii) a written contract provided by Arm and accepted by you, this is the only agreement between you and Arm relating to the Arm Tools and it may only be modified by written agreement between you and Arm. No terms and conditions contained in any purchase order or other document issued by you, or any advertising or other representation by you or any third party shall add to, supersede or in any way vary the terms and conditions of this License. This License (and any documents expressly incorporated into it by reference herein) represents the entire agreement between you and Arm in relation to its subject matter.

12.3 If any clause or sentence in this License is held by a court of law to be illegal or unenforceable, the remaining provisions of this License shall not be affected. Any failure by Arm to enforce any of the provisions of this License, unless waived in writing, shall not constitute a waiver of Arm's rights to enforce such provision or any other provision of this License in the future.

12.4 Subject to clause 10.1(b), neither this License or any rights granted to you under it may be assigned, sub-licensed or otherwise transferred by you to any third party without the prior written consent of Arm. An assignment shall be deemed to include, without limitation (i) any transaction or series of transactions whereby a third party acquires, directly or indirectly, the power to control the management and policies of you, whether through the acquisition of voting securities, by contract or otherwise; and (ii) the sale of more than fifty percent (50%) of your assets whether in a single transaction or series of transactions. Notwithstanding the foregoing, Arm may, in its discretion acting reasonably, separately agree to authorise the re-host of a Licensed Seat (for which additional charges may apply).

12.5 Subject to any applicable legal restrictions, including but not limited to those relating to the security of classified information, at Arm's request, (i) you agree to check your computers for installations of the Arm Tools, copies of License Keys, contents of any license server log files, individual or concurrent usage of Seats, and any other information requested by Arm relating to Arm Tools installation, usage and License Key management, and, to provide this information to Arm; and (ii) you agree that Arm may instruct appropriately qualified independent auditors to perform such checks by prior appointment during your normal business hours on reasonable notice. In respect of any audit, Arm shall bear the auditors' costs for that audit unless it reveals unlicensed usage, in which case you shall promptly reimburse Arm for all reasonable costs and expenses, including professional fees, relating to such audit. Any information which is disclosed to Arm or such auditors during checking or audit shall be treated as your confidential information and shall only be used by Arm for compliance and enforcement purposes.

12.6 The Arm Tools provided under this License are subject to U.S. export control laws, including the U.S. Export Administration Act and its associated regulations, and may be subject to export or import regulations in other countries. You agree to comply fully with all laws and regulations of the United States and other countries ("Export Laws") to ensure that the Arm Tools are not (i) exported, directly or indirectly, in violation of Export Laws, either to any countries that are subject to U.S. export restrictions or to any end user who has been prohibited from participating in the U.S export transactions by any federal agency of the U.S. government; or (ii) intended to be used for any purpose prohibited by Export Laws, including, without limitation, nuclear, chemical, or biological weapons proliferation.

Arm Document Reference LES-PRE-21260, Version 12.2, Effective Date 12 February 2019


Licensing User's Guide: License Agreement MDK v5.29

License Agreement MDK v5.29

END USER LICENSE AGREEMENT FOR ARM SOFTWARE DEVELOPMENT TOOLS

This end user license agreement ("License") is a legal agreement between you (a single individual), or the company or organisation (a single legal entity) that you represent and have the legal authority to bind, and Arm relating to use of the Arm Tools. Arm is only willing to license the Arm Tools on condition that you accept all of the terms of this License. By clicking "I Agree" or by installing or otherwise using the Arm Tools and/or any Update thereto (as permitted by this License) you indicate that you agree to be bound by all of the terms and conditions of this License. If you do not agree to the terms of this License, Arm will NOT license the Arm Tools to you, you may not install or use the Arm Tools or any part thereof, and you shall promptly return the Arm Tools to Arm or to your supplier (if not Arm) and ask for a refund of the license fee paid (if any).

NOTE - YOUR ATTENTION IS DRAWN TO THE FOLLOWING:

(A) The terms and conditions set out in this License shall apply to the supply by Arm of Arm Tools for both commercial and non-commercial use. If you are in receipt of a Non-Commercial Use License for the Arm Tools (each capitalised term as defined below), or the Arm Tools or any component thereof are identified or classified as such, or you are receiving a license for the Arm Tools free of charge, then notwithstanding any of the other terms and conditions of this License, your use of the Arm Tools shall be limited by the restrictions of use set out in clause 2.2 of this License.

(B) PLEASE NOTE any terms and conditions of use set out in the order documentation provided to you by Arm and the Software Information File(s) (as defined below) applicable to the Arm Tools provided to you with (or included within) either (i) the Arm Tools, and/or (ii) any Updates to the Arm Tools, which limit, extend or otherwise vary the permitted uses and restrictions applicable to the Arm Tools ("Special Conditions"). The Special Conditions form part of and are incorporated into this License. In the event of any conflict or inconsistency between the provisions set out in the main body of this License and any of the Special Conditions, the provisions set out in the Special Conditions shall prevail (in the order in which they are listed in this paragraph).

(C) This License (and any documents incorporated by reference herein) is the sole and exclusive agreement between you and Arm for the Arm Tools, and (except as agreed in writing to the contrary) no other document, including (but not limited to) your purchase order or any other document supplied by you, will form part of this License.

DEFINITIONS

For the purposes of this License the following words and expressions shall have the following meanings:

"Arm" means Arm Limited whose registered office is situated at 110 Fulbourn Road, Cambridge CB1 9NJ, England and/or any member of Arm's group of companies.

"Arm Documentation" means any printed, electronic or online documentation relating to Arm Software licensed to you by Arm under this License.

"Arm Software" means any and all software, firmware and data licensed to you by Arm under this License.

"Arm Tools" means any and all Arm Software and/or Arm Documentation owned or licensed by Arm, and any Updates to the Arm Software and/or Arm Documentation.

"Arm Tools Performance Data" means any results, benchmarking data or other information relating to or connected with your use or testing of the Arm Tools which are indicative of their performance, efficacy, reliability or quality.

"Fees" means any fee(s) payable by you for the provision by Arm to you of the Arm Tools and associated support and maintenance services, and any other fees payable by you in accordance with this License that are agreed by the parties from time to time.

"License Key" means an electronic license key issued to you by Arm which enables you to use and run one or more Licensed Seat of an Arm Tool or a component thereof in accordance with the terms of this License.

"Licensed Seats" means any and all Seats of the Arm Tools (including, if applicable, Updates) that you are licensed to run and use concurrently under the terms of this License, in the types and quantities specified in the order documentation provided to you by Arm, as well as any additional or replacement Seats of the Arm Tools that Arm agrees to provide to you from time to time during the License Term.

"License Term" means the term set out in the order documentation provided to you by Arm during which you shall be entitled to access and use the Arm Tools.

"Non-Commercial Use License" means an evaluation, preview, beta, pre-release, pilot, academic, educational or community use only license.

"Permitted Users" means your employees, workers, consultants, professional advisors, bona fide sub-contractors and service providers that use the Arm Tools in connection with the provision of work carried out for your benefit, and/or, other members of your organisation or third party users who use the Arm Tools with your express written permission on computers (physical or virtual) owned or controlled by you.

"Redistributables" means the example code, library files, configuration files, header files, and any other Arm Tools or components thereof owned by Arm (or licensed by Arm and provided to you under Arm's terms and conditions) which you are permitted to include within Your Software and redistribute or sub-license within Your Software to third parties, the details of which (if applicable) are set out in a file or folder (the "Redistributables File") typically named 'redistributables' located within an Arm Tool (or components thereof).

"Seat" means a written or electronic authorisation to run a software component subject to the terms and restrictions specified in that authorisation.

"Software Information File(s)" means Third Party Licenses Files, Redistributables Files, and/or Supplementary Terms Files (as the context requires).

"Special Conditions" is as defined above in Recital (B) of this License.

"Specified Project" means a single design and development activity undertaken by you or your Permitted Users relating to Your Software or Your Hardware, the details of which will be set out in the order documentation provided to you by Arm.

"Supplementary Terms File" means a software file or folder typically named 'supplementary_terms' located within an Arm Tool (or components thereof) which (if applicable) details any component-specific extensions, limitations or other variations to the terms of this License.

"Territory" means, if applicable, the geographical area detailed in the order documentation provided to you by Arm to which your use of the Arm Tools or any part thereof is restricted.

"Third Party Licenses File" means a software file or folder typically named 'third_party_licenses' located within an Arm Tool (or components thereof) which (if applicable) details any third party material included in the relevant Arm Tool which is not licensed under the terms of this License, and a reference to the applicable third party license terms and conditions.

"Update" means an update, patch, hotfix, bug fix, support release, modification or limited functional enhancement (as applicable) to an Arm Tool or component thereof, including but not limited to error corrections to any program or associated documentation developed by or for Arm comprised in the Arm Tools, which (i) Arm makes generally available to the market, and (ii) does not, in Arm's opinion, constitute an Upgrade or a new product.

"Upgrade" means a new release of an existing Arm Tool which Arm makes generally available to the market and which usually contains major functional improvements.

"Your Hardware" means hardware manufactured or developed by you or on your behalf, or hardware owned or licensed by you, which is supported by the Arm Tools.

"Your Reports" means any written reports or other information relating to the behavior or performance of Your Software or Your Hardware, in html, binary, text or any other format (excluding for the avoidance of doubt, Arm Tools Performance Data), generated by you from or using the Arm Tools and any modifications thereto.

"Your Software" means any software owned or licensed by you (including, but not limited to, applications, libraries and Arm API compliant plug-ins, but excluding Arm Software) which is supported by (or developed by you using) the Arm Tools.

1. LICENSE GRANT

1.1 Subject to your compliance with the terms and conditions of this License, and payment by you of the Fees (if any), Arm hereby grants to you and your Permitted Users during the License Term a non-exclusive, non-transferable license to receive and use the Arm Tools, certain components thereof, or optional functionality, in the Territory only on the Licensed Seats or for a Specified Project (as applicable) for the permitted uses set out in this clause 1 and subject to the restrictions set out in clause 2 (as limited, extended or otherwise varied by any terms, including product-specific permitted uses and restrictions, set out in the Special Conditions). Except as expressly permitted by this License, you and your Permitted Users shall NOT copy, modify, sub-license, redistribute or otherwise use any component of the Arm Tools.

1.2 PERMITTED USE OF THE ARM TOOLS: Except as otherwise provided in this License, use of the Arm Tools (or components thereof) is permitted for the purpose of:

(a) building, developing, testing, debugging, analysing and optimising Your Software or Your Hardware;

(b) generation of Your Reports, and use of Your Reports to develop, test, debug, analyse and optimise Your Software or Your Hardware; and

(c) only as expressly provided in the relevant Redistributables File: (i) incorporating, compiling and/or linking the files listed in that Redistributables File into Your Software, provided that Your Software contains substantial additional functionality; and (ii) subject to clause 2.1 below, reproducing and redistributing the files (and permitting your customers and/or your authorised distributors to reproduce and redistribute the files), only in object code form (unless otherwise specified in the relevant Redistributables Files), and only as part of Your Software. You agree that, except as expressly provided to the contrary in the relevant Redistributables File, you may only copy the Arm Tools (or any component thereof) to the extent that such copying is incidental to the permitted uses set out in this clause 1.2, including installation, backup and execution.

2. YOUR OBLIGATIONS AND RESTRICTIONS ON USE

2.1 OBLIGATIONS RELATING TO REDISTRIBUTION: Any redistribution as permitted by this License is subject to any restrictions set out in the applicable Special Conditions, and your compliance with the following:

(a) in cases where you are expressly permitted under this License (including for the avoidance of doubt by inclusion of agreed wording in the order documentation provided to you by Arm) to sub-license or redistribute any component of the Arm Tools to your customers, authorised distributors or other third parties, you are responsible for ensuring that such customers, authorised distributors and third parties accept, and are contractually bound (by agreement with you or directly with Arm) to comply with, the terms and conditions of this License;

(b) Any use by you of Arm's or any of its licensors' names, logos or trademarks to publicise or market any of Your Software containing (or developed or generated using) Arm Tools is subject to you obtaining express written permission from Arm;

(c) You warrant that you shall not make any representations or warranties on behalf of Arm in respect of any of the Arm Tools or in respect of any other software, reports or documentation developed or generated by you in accordance with the license grants set out in this License;

(d) You must reproduce or preserve (as applicable) any copyright notices which are included in or with any Arm Tools or components thereof; and

(e) Except as otherwise agreed by Arm (including for the avoidance of doubt by inclusion of the relevant permission in a Supplementary Terms File), you may not disclose or otherwise distribute any Arm Tools Performance Data. For the avoidance of doubt, nothing in this sub-clause 2.1 (e) shall prevent you from disclosing or otherwise distributing Your Reports.

2.2 NON-COMMERCIAL USE AND FREE OF CHARGE LICENSES: If you are in receipt of a Non-Commercial Use License for the Arm Tools, or the Arm Tools or any component thereof are identified or classified as such, and/or you are receiving the Arm Tools free of charge, then notwithstanding any of the other terms and conditions of this License, your use (which includes use by your Permitted Users) of the Arm Tools is limited as follows:

(a) if you are receiving the Arm Tools free of charge:

  • (i) no support or maintenance shall be provided to you in respect of the Arm Tools;
  • (ii) the warranty set out in clause 7.1 of this License does not apply to you or your use of the Arm Tools, and Arm gives no other warranty whatsoever in relation to (and accepts no liability in connection with) the Arm Tools or your use (as permitted by this License) of them;
  • (iii) Arm may immediately terminate this License at any time for any reason by giving written notice to you;
  • (iv) except as otherwise expressly agreed in writing by Arm, you shall grant to Arm in full the license set out in clause 3.2 of this License; and/or
    • (b) if you are receiving a Non-Commercial Use License or version (as applicable) of the Arm Tools:
  • (i) you and your Permitted Users may use the Arm Tools for internal use only; and
  • (ii) you are not permitted to distribute or sub-license (A) any part of the Arm Tools, or (B) Your Software, Your Hardware, or Your Reports developed under this License using the Arm Tools. The Arm Tools shall be used only by you and your Permitted Users, and you shall not (except as otherwise authorised in writing by Arm) allow any other third party whatsoever to use the Arm Tools.

For the avoidance of doubt, if you are receiving a Non-Commercial Use License and the license is provided to you free of charge, the restrictions in both sub-clauses (a) and (b) above will apply to your use of the Arm Tools.

2.3 LICENSE TYPES: Depending on the type of license you have agreed to purchase from Arm under this License (the details of which are set out in the order documentation provided to you by Arm), your use of the Arm Tools shall be limited to:

(a) use of each Licensed Seat (i) by one individual named Permitted User only on a specified item of computer hardware ('named-user license'), OR (ii) by one individual Permitted User at a time only on a specified item of computer hardware ('node-locked license'), OR (iii) by one individual Permitted User at a time on specified items of computer hardware ('floating license'). In respect of 'node-locked licenses', each Licensed Seat may only be used for one 'process' at any one time. For the purpose of this sub-clause 2.3 (a), each 'process' is the execution of an instance of an Arm Tool; or

(b) use for a Specified Project.

2.4 PERMITTED USERS: You hereby agree to be responsible for the acts and omissions of any and all Permitted Users, and shall ensure that such Permitted Users (i) are contractually obliged to comply with the terms of this License, including those relating to confidentiality; and (ii) do not supply the Arm Tools or any components thereof to any third party whatsoever. Except as expressly provided in this License or as agreed in writing by Arm on a case by case basis, you shall not sub-license, redistribute, lease, rent or otherwise allow any third party to use the Arm Tools or License Keys.

2.5 REVERSE ENGINEERING: Your use of the Arm Tools shall specifically exclude the reverse engineering, decompiling, disassembly, translation, adaptation, arrangement or other alteration of any part of the Arm Tools (except to the extent that applicable law overrides this provision or any part hereof).

2.6 COPYRIGHT AND RESERVATION OF RIGHTS: The Arm Tools are owned by Arm and/or its licensors and are protected by copyright and other intellectual property rights, laws and international treaties. The Arm Tools are licensed not sold. Except as expressly provided by this License, you acquire no rights to the Arm Tools or any element thereof, or to any other Arm products or services. You shall not remove from the Arm Tools any copyright notice or other notice and shall ensure that any such notice is reproduced in any permitted reproduction of the whole or any part of the Arm Tools.

2.7 TECHNICAL RESTRICTIONS IN THE ARM TOOLS: You must comply with any technical restrictions in the Arm Tools and License Keys, including any restrictions that restrict use to certain components of the Arm Tools or use only for certain purposes. You shall not work around any such technical restrictions.

2.8 ARM DOCUMENTATION: You may use the Arm Documentation (if any) internally only in conjunction with your use of the Arm Software to which it relates.

3. LICENSE OF FEEDBACK TO ARM

3.1 You may at your discretion deliver any suggestions, comments, feedback, ideas, or know-how (whether in oral or written form) to Arm relating to or connected with your use of the Arm Tools ("Feedback"). Notwithstanding the foregoing, you shall not knowingly give to Arm any Feedback that you are aware (or should reasonably be aware) is subject to any patent, copyright or other intellectual property claim or right of any third party.

3.2 Except as expressly notified by you to Arm (in writing which may include email) to the contrary, you hereby grant to Arm under your and your affiliates (as applicable) intellectual property, a perpetual, irrevocable, royalty free, non-exclusive, worldwide license to: (i) use, copy, modify, and create derivative works of the Feedback; (ii) sell, supply or otherwise distribute the whole or any part of the Feedback (and derivative works thereof) as part of any Arm owned or licensed product(s) without obligation or restriction of any kind; and (iii) sub-license to third parties the foregoing rights, including the right to sub-license to further third parties. No right is granted by you to Arm to sub-license your and your affiliates (as applicable) intellectual property except to the extent that it is provided to Arm as Feedback and is embodied in any Arm owned or licensed product(s). For the avoidance of doubt, if, during the License Term, you provide notice to Arm revoking the license granted under this clause 3.2, you acknowledge and agree that such revocation shall not apply to Feedback delivered to Arm prior to the date of receipt of the revocation notice, and that (notwithstanding the foregoing) Arm shall continue to be permitted to use Feedback received after the date of receipt of the revocation notice for internal purposes.

3.3 Except as expressly licensed to Arm in clause 3.2, you retain all right, title and interest in and to the Feedback provided by you under this License.

4. DATA COLLECTION AND PRIVACY

4.1 The Arm Software may include features that enable it to transmit certain computer information over the internet to Arm's and/or its service providers' computer systems, for example your computer's internet protocol address, computer hardware and operating system details, or the serial numbers of the Arm Tools you have licensed. This information will not be shared with any third parties, and shall be used by Arm only for the purpose of Arm protecting its legitimate interests, which may include Arm verifying your right to use the Arm Tools and monitoring your compliance with the permitted uses and restrictions set out in this License.

4.2 Arm may also collect anonymous data, which, for the avoidance of doubt, cannot be used to identify individual users of the Arm Tools. This information may be used by Arm to help us understand and analyse what components or features in the Arm Tools our end users are using in order to (i) maintain and improve the quality of the Arm Tools and the end user experience, (ii) inform end users of relevant new and improved products and services, and (iii) assist end users to maximise the performance of, or solve user experience issues with, the Arm Tools.

4.3 Information collected by the Arm Software will only be used for the aforementioned purposes. Please refer to the Arm Privacy Policy https://www.arm.com/company/policies/privacy for further information on how Arm collects, uses and safeguards personal data (including but not limited to personal data collected for the protection of Arm's legitimate interests and your rights to object to its collection).

5. SUPPORT AND MAINTENANCE

5.1 Provision of reasonable support and maintenance is subject to payment by you of all applicable Fees.

5.2 Any support provided by Arm in accordance with the above clause 5.1 shall (i) be provided by telephone, email or such other format as is designated by Arm, (ii) be prioritised at Arm's discretion, and (iii) not be used as a substitute for training or as additional resource for your projects.

5.3 Maintenance will generally be provided in the form of Updates to the Arm Tools. Arm shall be under no obligation to provide such maintenance in respect of any modifications made by you (where permitted) to the Arm Tools. Updates do not constitute additional Licensed Seats and may only be used by you if you have an active Licensed Seat to run and use such Updates. Updates will generally be provided to you as soon as reasonably practicable following the date of general public release of the Update by Arm.

5.4 In cases where the Arm Tools were provided to you free of charge, you are not entitled to any support or maintenance for the Arm Tools from Arm, but Arm may, in its sole discretion, provide support to you. If you obtained the Arm Tools from an Arm authorised distributor, reseller or other third party, support and maintenance may be provided by either Arm or the third party as per the terms of your contract for supply. Arm shall not be responsible for any delay or failure in connection with any third party supplier providing support or maintenance that it is obligated to provide to you. Please refer to the 'Support' area of https://www.arm.com for details of Arm's support services, relevant contact details, and (if applicable) details of other authorised support channels.

5.5 Arm's obligations under this clause 5 are limited to the provision of support and maintenance to you, and Arm is under no obligation to provide any support and maintenance to any third parties. You agree to provide all front line support services to all third parties to whom you distribute any Arm Tools, Your Reports, Your Software or Your Hardware, pursuant to and in accordance with the terms of this License.

5.6 This License does not grant you any entitlement to receive (i) Upgrades, (ii) Arm products other than those specified in your product documentation, or (iii) any new products developed or introduced by Arm from time to time, nor to receive any support or maintenance in respect of the same.

6. CONFIDENTIALITY

6.1 You acknowledge that the Arm Tools, License Keys, Arm Tools Performance Data, and any and all other software, documentation or other information licensed to you by Arm, or provided to you during discussions about or in connection with the Arm Tools (including this License and information provided during the provision by Arm of any support), contain trade secrets and confidential information of Arm ("Confidential Information").

6.2 You agree to maintain all such Confidential Information in confidence and apply security measures (such measures to be no less stringent than the measures which you apply (or should reasonably apply) to protect your own like information, but not less than a reasonable degree of care) to prevent their unauthorised disclosure and use.

6.3 Subject to any restrictions imposed by applicable law, the period of confidentiality shall be five (5) years from the date of disclosure of the Confidential Information. You agree that you shall not use any such information other than in your normal use of the Arm Tools as permitted by this License.

7. LIMITED WARRANTIES

7.1 Subject to the restrictions in clause 2, for the period of ninety (90) days from the date of receipt by you of the Arm Tools, Arm warrants to you that (i) the media on which any Arm Software is provided shall be free from defects in materials and workmanship under normal use; and (ii) the Arm Software will perform substantially in accordance with the accompanying Arm Documentation (if any). Arm's total liability and your exclusive remedy for breach of these warranties shall be limited to Arm, at Arm's option (a) replacing the defective Arm Software; or (b) using reasonable efforts to correct material, documented, reproducible defects in the Arm Software and delivering such corrected Arm Software to you; or (c) if you licensed the Arm Software directly from Arm, refunding the price paid by you to Arm for that Arm Software. Any replacement Arm Software will be warranted for the remainder of the original warranty period or thirty (30) days from the date of replacement, whichever is longer.

7.2 The Arm Software described in any Arm Documentation is subject to continuous development and improvement. All particulars of the Arm Software and its use as described in the Arm Documentation are given by Arm in good faith. Consequently, the information contained in the Arm Documentation is subject to change without notice and is not warranted to be error free. If you discover any errors in the Arm Documentation please report them to Arm in writing. Any Arm Documentation provided to you that relates to specific industry quality and functional safety standard compliance may assist you in applying to a competent auditor for certification of Your Software or Your Hardware, but you acknowledge and agree that on its own such Arm Documentation may not provide sufficient evidence of, or be compatible with, the required safety compliance standards.

7.3 Except as provided in clause 7.1 above, you agree that the Arm Tools are licensed "as is", and that Arm expressly disclaims all representations, warranties, conditions or other terms, express or implied or statutory, including without limitation the implied warranties of non-infringement, satisfactory quality, and fitness for a particular purpose. You acknowledge that it is your responsibility to satisfy yourself that the Arm Tools are fit for the intended purpose and satisfy your requirements, including compatibility with Your Hardware, and you expressly assume all liabilities and risks relating to (i) any use of an Arm Tool which is inconsistent with its design or any guidance provided to you in the applicable Arm Documentation, and/or (ii) any use of an Arm Tool with Your Software or Your Hardware where such software or hardware (as applicable) is not supported by or compatible with the relevant Arm Tool.

7.4 You expressly assume all liabilities and risks relating to your use or operation of Your Software and Your Hardware designed or modified using the Arm Tools, including without limitation, Your software or Your Hardware designed or intended for safety-critical applications. Should Your Software or Your Hardware prove defective, you assume the entire cost of all necessary servicing, repair or correction.

8. LIMITATION OF LIABILITY

8.1 To the maximum extent permitted by applicable law, in no event shall Arm be liable for any indirect, special, incidental or consequential damages (including loss of profits) arising out of the use of, or inability to use, the Arm Tools, whether based on a claim under contract, tort or otherwise, even if Arm was advised of the possibility of such damages.

8.2 Arm does not seek to limit or exclude liability for death or personal injury arising from Arm's negligence or Arm's fraud. Arm acknowledges that certain jurisdictions do not permit the exclusion or limitation of liability for consequential or incidental damages, and in such cases the above limitation relating to liability for consequential damages may not apply to you.

8.3 Notwithstanding anything to the contrary contained in this License, the maximum liability of Arm to you in aggregate (in contract, tort or otherwise) in relation to or in connection with the subject matter of this License shall not exceed the greater of (i) the total sums paid by you to Arm (if any) for this License, and (ii) $10.00 USD. The existence of more than one claim will not enlarge or extend the limit.

9. THIRD PARTY MATERIAL

9.1 The Arm Tools may contain material owned or developed by third parties, including but not limited to open source software, freeware and commercial software ("Third Party Material"). Any Third Party Material is subject to the terms and conditions of the applicable Third Party Material license(s) and is not covered under the terms of this License. Details relating to such Third Party Material shall either be presented to you at the time of installation or shall be detailed in the Third Party Licenses File(s). Your use of such Third Party Material is subject to your compliance with the applicable Third Party Material license(s).

9.2 Arm hereby disclaims any and all warranties express or implied from any third parties regarding, or otherwise connected with, any Third Party Material included in the Arm Tools and any Third Party Material from which the Arm Tools are derived, and/or your use of any or all of the Third Party Material in connection with Your Software or Your Hardware, including (without limitation) any warranties of satisfactory quality or fitness for a particular purpose.

9.3 No Third Party Material licensors shall have any liability for any direct, indirect, incidental, special, exemplary, or consequential damages (including without limitation lost profits) howsoever caused and whether made under contract, tort or otherwise arising in any way out of your use or distribution of the Third Party Material or the exercise of any rights granted under either or both this License and the legal terms applicable to any Third Party Material, even if advised in advance of the possibility of such damages.

10. GOVERNMENT REQUIREMENTS

10.1 To the extent that you are an agency, contractor or instrumentality of the U.S. Government, you and we agree that:

(a) the Arm Tools are commercial computer software and commercial computer software documentation, and that your rights therein are as specified in this License, per FAR 12.212 and DFARS 227.7202-3, as applicable, or in the case of NASA, subject to NSF 1852.22786. Arm acknowledges that, whilst commercial computer software or commercial computer software documentation shall be acquired under licenses customarily provided to the public, such licenses must be consistent with U.S. Federal law and otherwise satisfy the U.S. Government's needs ("U.S. Government Requirements"); and

(b) you may assign your rights under this License to the relevant US Government Federal Department or the successor contractor designated by the US Government Federal Department upon termination of your related prime contract with that US Government Federal Department. If you exercise your rights under this clause 10.1(b), you acknowledge and agree that you shall remain liable to Arm in respect of all your obligations under this License.

10.2 If there is any material inconsistency between (i) either a U.S. Government Requirement or a requirement of another government with which Arm is mandated by statute to comply and (ii) any provision of this License, the terms of the relevant government requirement shall prevail and the provision in question shall be deemed varied or deleted (as applicable) as required by the terms of the relevant government requirement. For the avoidance of doubt, in such circumstances, all other terms, conditions and provisions of this License will continue to be valid to the fullest extent permitted by law in accordance with the below clause 12.3.

11. TERM AND TERMINATION

11.1 Subject to clauses 11.2 and 11.3 below, this License shall remain in force until terminated by you, by Arm or (in the case of a time limited license) by expiry.

11.2 In the event of a party breaching of any of the terms and conditions of this License, which if capable of remedy, has not been remedied by that party within thirty (30) days of the date of breach, without prejudice to any of its other rights under this License, the non-breaching party may terminate this License immediately upon giving written notice to the breaching party. Upon termination of this License by you or by Arm, or upon expiry, you shall (and shall ensure that your Permitted Users shall) immediately (i) stop using the Arm Tools (or any element thereof) and any Confidential Information and, (ii) destroy all copies of the same in your possession or control, together with all Arm Documentation and related materials.

11.3 Notwithstanding the foregoing, except where Arm has terminated this License for your breach, your rights (if applicable) to distribute any of Your Software or Your Hardware developed using the Arm Tools prior to termination or expiry of this License shall (subject to your continued compliance with the terms and conditions of this License) survive such termination or expiry.

12. GENERAL

12.1 This License is governed by English Law. Notwithstanding the foregoing, to the extent that you are an agency, contractor or instrumentality of the U.S. Government, disputes arising under or relating to this License shall be decided under the U.S. federal law of government contracting, including without limitation the Contract Disputes Act. Nothing in this License shall prevent you from enforcing your intellectual property rights or seeking injunctive or other equitable relief in any court of competent jurisdiction. The parties hereby disclaim application of the United Nations Convention on Contracts for the International Sale of Goods and the Uniform Computer Information Transactions Act.

12.2 Except where Arm agrees otherwise in (i) a written contract signed by you and Arm, or (ii) a written contract provided by Arm and accepted by you, this is the only agreement between you and Arm relating to the Arm Tools and it may only be modified by written agreement between you and Arm. No terms and conditions contained in any purchase order or other document issued by you, or any advertising or other representation by you or any third party shall add to, supersede or in any way vary the terms and conditions of this License. This License (and any documents expressly incorporated into it by reference herein) represents the entire agreement between you and Arm in relation to its subject matter.

12.3 If any clause or sentence in this License is held by a court of law to be illegal or unenforceable, the remaining provisions of this License shall not be affected. Any failure by Arm to enforce any of the provisions of this License, unless waived in writing, shall not constitute a waiver of Arm's rights to enforce such provision or any other provision of this License in the future.

12.4 Subject to clause 10.1(b), neither this License or any rights granted to you under it may be assigned, sub-licensed or otherwise transferred by you to any third party without the prior written consent of Arm. An assignment shall be deemed to include, without limitation (i) any transaction or series of transactions whereby a third party acquires, directly or indirectly, the power to control the management and policies of you, whether through the acquisition of voting securities, by contract or otherwise; and (ii) the sale of more than fifty percent (50%) of your assets whether in a single transaction or series of transactions. Notwithstanding the foregoing, Arm may, in its discretion acting reasonably, separately agree to authorise the re-host of a Licensed Seat (for which additional charges may apply).

12.5 Subject to any applicable legal restrictions, including but not limited to those relating to the security of classified information, at Arm's request, (i) you agree to check your computers for installations of the Arm Tools, copies of License Keys, contents of any license server log files, individual or concurrent usage of Seats, and any other information requested by Arm relating to Arm Tools installation, usage and License Key management, and, to provide this information to Arm; and (ii) you agree that Arm may instruct appropriately qualified independent auditors to perform such checks by prior appointment during your normal business hours on reasonable notice. In respect of any audit, Arm shall bear the auditors' costs for that audit unless it reveals unlicensed usage, in which case you shall promptly reimburse Arm for all reasonable costs and expenses, including professional fees, relating to such audit. Any information which is disclosed to Arm or such auditors during checking or audit shall be treated as your confidential information and shall only be used by Arm for compliance and enforcement purposes.

12.6 The Arm Tools provided under this License are subject to U.S. export control laws, including the U.S. Export Administration Act and its associated regulations, and may be subject to export or import regulations in other countries. You agree to comply fully with all laws and regulations of the United States and other countries ("Export Laws") to ensure that the Arm Tools are not (i) exported, directly or indirectly, in violation of Export Laws, either to any countries that are subject to U.S. export restrictions or to any end user who has been prohibited from participating in the U.S export transactions by any federal agency of the U.S. government; or (ii) intended to be used for any purpose prohibited by Export Laws, including, without limitation, nuclear, chemical, or biological weapons proliferation.

Arm Document Reference LES-PRE-21260, Version 12.2, Effective Date 12 February 2019


Licensing User's Guide: License Agreement MDK v5.30 and above

License Agreement MDK v5.30 and above

END USER LICENSE AGREEMENT FOR ARM SOFTWARE DEVELOPMENT TOOLS

This end user license agreement ("License") is a legal agreement between you (a single individual), or the company or organisation (a single legal entity) that you represent and have the legal authority to bind, and Arm relating to use of the Arm Tools. Arm is only willing to license the Arm Tools on condition that you accept all of the terms of this License. By clicking "I Agree" or by installing or otherwise using the Arm Tools and/or any Update thereto (as permitted by this License) you indicate that you agree to be bound by all of the terms and conditions of this License. If you do not agree to the terms of this License, Arm will NOT license the Arm Tools to you, you may not install or use the Arm Tools or any part thereof, and you shall promptly return the Arm Tools to Arm or to your supplier (if not Arm) and ask for a refund of the license fee paid (if any).

NOTE - YOUR ATTENTION IS DRAWN TO THE FOLLOWING:

(A) The terms and conditions set out in this License shall apply to the supply by Arm of Arm Tools for both commercial and non-commercial use. If you are in receipt of a Non-Commercial Use License for the Arm Tools (each capitalised term as defined below), or the Arm Tools or any component thereof are identified or classified as such, or you are receiving a license for the Arm Tools free of charge, then notwithstanding any of the other terms and conditions of this License, your use of the Arm Tools shall be limited by the restrictions of use set out in clause 2.2 of this License.

(B) PLEASE NOTE any terms and conditions of use set out in the order documentation provided to you by Arm and the Software Information File(s) (as defined below) applicable to the Arm Tools provided to you with (or included within) either (i) the Arm Tools, and/or (ii) any Updates to the Arm Tools, which limit, extend or otherwise vary the permitted uses and restrictions applicable to the Arm Tools ("Special Conditions"). The Special Conditions form part of and are incorporated into this License. In the event of any conflict or inconsistency between the provisions set out in the main body of this License and any of the Special Conditions, the provisions set out in the Special Conditions shall prevail (in the order in which they are listed in this paragraph).

(C) This License (and any documents incorporated by reference herein) is the sole and exclusive agreement between you and Arm for the Arm Tools, and (except as agreed in writing to the contrary) no other document, including (but not limited to) your purchase order or any other document supplied by you, will form part of this License.

DEFINITIONS

For the purposes of this License the following words and expressions shall have the following meanings:

"Arm" means Arm Limited whose registered office is situated at 110 Fulbourn Road, Cambridge CB1 9NJ, England and/or any member of Arm's group of companies.

"Arm Documentation" means any printed, electronic or online documentation relating to Arm Software licensed to you by Arm under this License.

"Arm Software" means any and all software, firmware and data licensed to you by Arm under this License.

"Arm Tools" means any and all Arm Software and/or Arm Documentation owned or licensed by Arm, and any Updates to the Arm Software and/or Arm Documentation.

"Arm Tools Performance Data" means any results, benchmarking data or other information relating to or connected with your use or testing of the Arm Tools which are indicative of their performance, efficacy, reliability or quality.

"Fees" means any fee(s) payable by you for the provision by Arm to you of the Arm Tools and associated support and maintenance services, and any other fees payable by you in accordance with this License that are agreed by the parties from time to time.

"License Key" means an electronic license key issued to you by Arm which enables you to use and run one or more Licensed Seat of an Arm Tool or a component thereof in accordance with the terms of this License.

"Licensed Seats" means any and all Seats of the Arm Tools (including, if applicable, Updates) that you are licensed to run and use concurrently under the terms of this License, in the types and quantities specified in the order documentation provided to you by Arm, as well as any additional or replacement Seats of the Arm Tools that Arm agrees to provide to you from time to time during the License Term.

"License Term" means the term set out in the order documentation provided to you by Arm during which you shall be entitled to access and use the Arm Tools.

"Non-Commercial Use License" means an evaluation, preview, beta, pre-release, pilot, academic, educational or community use only license.

"Permitted Users" means your employees, workers, consultants, professional advisors, bona fide sub-contractors and service providers that use the Arm Tools in connection with the provision of work carried out for your benefit, and/or, other members of your organisation or third party users who use the Arm Tools with your express written permission on computers (physical or virtual) owned or controlled by you.

"Redistributables" means the example code, library files, configuration files, header files, and any other Arm Tools or components thereof owned by Arm (or licensed by Arm and provided to you under Arm's terms and conditions) which you are permitted to include within Your Software and redistribute or sub-license within Your Software to third parties, the details of which (if applicable) are set out in a file or folder (the "Redistributables File") typically named 'redistributables' located within an Arm Tool (or components thereof).

"Seat" means a written or electronic authorisation to run a software component subject to the terms and restrictions specified in that authorisation.

"Software Information File(s)" means Third Party Licenses Files, Redistributables Files, and/or Supplementary Terms Files (as the context requires).

"Special Conditions" is as defined above in Recital (B) of this License.

"Specified Project" means a single design and development activity undertaken by you or your Permitted Users relating to Your Software or Your Hardware, the details of which will be set out in the order documentation provided to you by Arm.

"Supplementary Terms File" means a software file or folder typically named 'supplementary_terms' located within an Arm Tool (or components thereof) which (if applicable) details any component-specific extensions, limitations or other variations to the terms of this License.

"Territory" means, if applicable, the geographical area detailed in the order documentation provided to you by Arm to which your use of the Arm Tools or any part thereof is restricted.

"Third Party Licenses File" means a software file or folder typically named 'third_party_licenses' located within an Arm Tool (or components thereof) which (if applicable) details any third party material included in the relevant Arm Tool which is not licensed under the terms of this License, and a reference to the applicable third party license terms and conditions.

"Update" means an update, patch, hotfix, bug fix, support release, modification or limited functional enhancement (as applicable) to an Arm Tool or component thereof, including but not limited to error corrections to any program or associated documentation developed by or for Arm comprised in the Arm Tools, which (i) Arm makes generally available to the market, and (ii) does not, in Arm's opinion, constitute an Upgrade or a new product.

"Upgrade" means a new release of an existing Arm Tool which Arm makes generally available to the market and which usually contains major functional improvements.

"Your Hardware" means hardware manufactured or developed by you or on your behalf, or hardware owned or licensed by you, which is supported by the Arm Tools.

"Your Reports" means any written reports or other information relating to the behavior or performance of Your Software or Your Hardware, in html, binary, text or any other format (excluding for the avoidance of doubt, Arm Tools Performance Data), generated by you from or using the Arm Tools and any modifications thereto.

"Your Software" means any software owned or licensed by you (including, but not limited to, applications, libraries and Arm API compliant plug-ins, but excluding Arm Software) which is supported by (or developed by you using) the Arm Tools.

1. LICENSE GRANT

1.1 Subject to your compliance with the terms and conditions of this License, and payment by you of the Fees (if any), Arm hereby grants to you and your Permitted Users during the License Term a non-exclusive, non-transferable license to receive and use the Arm Tools, certain components thereof, or optional functionality, in the Territory only on the Licensed Seats or for a Specified Project (as applicable) for the permitted uses set out in this clause 1 and subject to the restrictions set out in clause 2 (as limited, extended or otherwise varied by any terms, including product-specific permitted uses and restrictions, set out in the Special Conditions). Except as expressly permitted by this License, you and your Permitted Users shall NOT copy, modify, sub-license, redistribute or otherwise use any component of the Arm Tools.

1.2 PERMITTED USE OF THE ARM TOOLS: Except as otherwise provided in this License, use of the Arm Tools (or components thereof) is permitted for the purpose of:

(a) building, developing, testing, debugging, analysing and optimising Your Software or Your Hardware;

(b) generation of Your Reports, and use of Your Reports to develop, test, debug, analyse and optimise Your Software or Your Hardware; and

(c) only as expressly provided in the relevant Redistributables File: (i) incorporating, compiling and/or linking the files listed in that Redistributables File into Your Software, provided that Your Software contains substantial additional functionality; and (ii) subject to clause 2.1 below, reproducing and redistributing the files (and permitting your customers and/or your authorised distributors to reproduce and redistribute the files), only in object code form (unless otherwise specified in the relevant Redistributables Files), and only as part of Your Software. You agree that, except as expressly provided to the contrary in the relevant Redistributables File, you may only copy the Arm Tools (or any component thereof) to the extent that such copying is incidental to the permitted uses set out in this clause 1.2, including installation, backup and execution.

2. YOUR OBLIGATIONS AND RESTRICTIONS ON USE

2.1 OBLIGATIONS RELATING TO REDISTRIBUTION: Any redistribution as permitted by this License is subject to any restrictions set out in the applicable Special Conditions, and your compliance with the following:

(a) in cases where you are expressly permitted under this License (including for the avoidance of doubt by inclusion of agreed wording in the order documentation provided to you by Arm) to sub-license or redistribute any component of the Arm Tools to your customers, authorised distributors or other third parties, you are responsible for ensuring that such customers, authorised distributors and third parties accept, and are contractually bound (by agreement with you or directly with Arm) to comply with, the terms and conditions of this License;

(b) Any use by you of Arm's or any of its licensors' names, logos or trademarks to publicise or market any of Your Software containing (or developed or generated using) Arm Tools is subject to you obtaining express written permission from Arm;

(c) You warrant that you shall not make any representations or warranties on behalf of Arm in respect of any of the Arm Tools or in respect of any other software, reports or documentation developed or generated by you in accordance with the license grants set out in this License;

(d) You must reproduce or preserve (as applicable) any copyright notices which are included in or with any Arm Tools or components thereof; and

(e) Except as otherwise agreed by Arm (including for the avoidance of doubt by inclusion of the relevant permission in a Supplementary Terms File), you may not disclose or otherwise distribute any Arm Tools Performance Data. For the avoidance of doubt, nothing in this sub-clause 2.1 (e) shall prevent you from disclosing or otherwise distributing Your Reports.

2.2 NON-COMMERCIAL USE AND FREE OF CHARGE LICENSES: If you are in receipt of a Non-Commercial Use License for the Arm Tools, or the Arm Tools or any component thereof are identified or classified as such, and/or you are receiving the Arm Tools free of charge, then notwithstanding any of the other terms and conditions of this License, your use (which includes use by your Permitted Users) of the Arm Tools is limited as follows:

(a) if you are receiving the Arm Tools free of charge:

  • (i) no support or maintenance shall be provided to you in respect of the Arm Tools;
  • (ii) the warranty set out in clause 7.1 of this License does not apply to you or your use of the Arm Tools, and Arm gives no other warranty whatsoever in relation to (and accepts no liability in connection with) the Arm Tools or your use (as permitted by this License) of them;
  • (iii) Arm may immediately terminate this License at any time for any reason by giving written notice to you;
  • (iv) except as otherwise expressly agreed in writing by Arm, you shall grant to Arm in full the license set out in clause 3.2 of this License; and/or
    • (b) if you are receiving a Non-Commercial Use License or version (as applicable) of the Arm Tools:
  • (i) you and your Permitted Users may use the Arm Tools for internal use only; and
  • (ii) you are not permitted to distribute or sub-license (A) any part of the Arm Tools, or (B) Your Software, Your Hardware, or Your Reports developed under this License using the Arm Tools. The Arm Tools shall be used only by you and your Permitted Users, and you shall not (except as otherwise authorised in writing by Arm) allow any other third party whatsoever to use the Arm Tools.

For the avoidance of doubt, if you are receiving a Non-Commercial Use License and the license is provided to you free of charge, the restrictions in both sub-clauses (a) and (b) above will apply to your use of the Arm Tools.

2.3 LICENSE TYPES: Depending on the type of license you have agreed to purchase from Arm under this License (the details of which are set out in the order documentation provided to you by Arm), your use of the Arm Tools shall be limited to:

(a) use of each Licensed Seat (i) by one individual named Permitted User only on a specified item of computer hardware ('named-user license'), OR (ii) by one individual Permitted User at a time only on a specified item of computer hardware ('node-locked license'), OR (iii) by one individual Permitted User at a time on specified items of computer hardware ('floating license'). In respect of 'node-locked licenses', each Licensed Seat may only be used for one 'process' at any one time. For the purpose of this sub-clause 2.3 (a), each 'process' is the execution of an instance of an Arm Tool; or

(b) use for a Specified Project.

2.4 PERMITTED USERS: You hereby agree to be responsible for the acts and omissions of any and all Permitted Users, and shall ensure that such Permitted Users (i) are contractually obliged to comply with the terms of this License, including those relating to confidentiality; and (ii) do not supply the Arm Tools or any components thereof to any third party whatsoever. Except as expressly provided in this License or as agreed in writing by Arm on a case by case basis, you shall not sub-license, redistribute, lease, rent or otherwise allow any third party to use the Arm Tools or License Keys.

2.5 REVERSE ENGINEERING: Your use of the Arm Tools shall specifically exclude the reverse engineering, decompiling, disassembly, translation, adaptation, arrangement or other alteration of any part of the Arm Tools (except to the extent that applicable law overrides this provision or any part hereof).

2.6 COPYRIGHT AND RESERVATION OF RIGHTS: The Arm Tools are owned by Arm and/or its licensors and are protected by copyright and other intellectual property rights, laws and international treaties. The Arm Tools are licensed not sold. Except as expressly provided by this License, you acquire no rights to the Arm Tools or any element thereof, or to any other Arm products or services. You shall not remove from the Arm Tools any copyright notice or other notice and shall ensure that any such notice is reproduced in any permitted reproduction of the whole or any part of the Arm Tools.

2.7 TECHNICAL RESTRICTIONS IN THE ARM TOOLS: You must comply with any technical restrictions in the Arm Tools and License Keys, including any restrictions that restrict use to certain components of the Arm Tools or use only for certain purposes. You shall not work around any such technical restrictions.

2.8 ARM DOCUMENTATION: You may use the Arm Documentation (if any) internally only in conjunction with your use of the Arm Software to which it relates.

3. LICENSE OF FEEDBACK TO ARM

3.1 You may at your discretion deliver any suggestions, comments, feedback, ideas, or know-how (whether in oral or written form) to Arm relating to or connected with your use of the Arm Tools ("Feedback"). Notwithstanding the foregoing, you shall not knowingly give to Arm any Feedback that you are aware (or should reasonably be aware) is subject to any patent, copyright or other intellectual property claim or right of any third party.

3.2 Except as expressly notified by you to Arm (in writing which may include email) to the contrary, you hereby grant to Arm under your and your affiliates (as applicable) intellectual property, a perpetual, irrevocable, royalty free, non-exclusive, worldwide license to: (i) use, copy, modify, and create derivative works of the Feedback; (ii) sell, supply or otherwise distribute the whole or any part of the Feedback (and derivative works thereof) as part of any Arm owned or licensed product(s) without obligation or restriction of any kind; and (iii) sub-license to third parties the foregoing rights, including the right to sub-license to further third parties. No right is granted by you to Arm to sub-license your and your affiliates (as applicable) intellectual property except to the extent that it is provided to Arm as Feedback and is embodied in any Arm owned or licensed product(s). For the avoidance of doubt, if, during the License Term, you provide notice to Arm revoking the license granted under this clause 3.2, you acknowledge and agree that such revocation shall not apply to Feedback delivered to Arm prior to the date of receipt of the revocation notice, and that (notwithstanding the foregoing) Arm shall continue to be permitted to use Feedback received after the date of receipt of the revocation notice for internal purposes.

3.3 Except as expressly licensed to Arm in clause 3.2, you retain all right, title and interest in and to the Feedback provided by you under this License.

4. DATA COLLECTION AND PRIVACY

4.1 The Arm Software may include features that enable it to transmit certain computer information over the internet to Arm's and/or its service providers' computer systems, for example your computer's internet protocol address, computer hardware and operating system details, or the serial numbers of the Arm Tools you have licensed. This information will not be shared with any third parties, and shall be used by Arm only for the purpose of Arm protecting its legitimate interests, which may include Arm verifying your right to use the Arm Tools and monitoring your compliance with the permitted uses and restrictions set out in this License.

4.2 Arm may also collect anonymous data, which, for the avoidance of doubt, cannot be used to identify individual users of the Arm Tools. This information may be used by Arm to help us understand and analyse what components or features in the Arm Tools our end users are using in order to (i) maintain and improve the quality of the Arm Tools and the end user experience, (ii) inform end users of relevant new and improved products and services, and (iii) assist end users to maximise the performance of, or solve user experience issues with, the Arm Tools.

4.3 Information collected by the Arm Software will only be used for the aforementioned purposes. Please refer to the Arm Privacy Policy https://www.arm.com/company/policies/privacy for further information on how Arm collects, uses and safeguards personal data (including but not limited to personal data collected for the protection of Arm's legitimate interests and your rights to object to its collection).

5. SUPPORT AND MAINTENANCE

5.1 Provision of reasonable support and maintenance is subject to payment by you of all applicable Fees.

5.2 Any support provided by Arm in accordance with the above clause 5.1 shall (i) be provided by telephone, email or such other format as is designated by Arm, (ii) be prioritised at Arm's discretion, and (iii) not be used as a substitute for training or as additional resource for your projects.

5.3 Maintenance will generally be provided in the form of Updates to the Arm Tools. Arm shall be under no obligation to provide such maintenance in respect of any modifications made by you (where permitted) to the Arm Tools. Updates do not constitute additional Licensed Seats and may only be used by you if you have an active Licensed Seat to run and use such Updates. Updates will generally be provided to you as soon as reasonably practicable following the date of general public release of the Update by Arm.

5.4 In cases where the Arm Tools were provided to you free of charge, you are not entitled to any support or maintenance for the Arm Tools from Arm, but Arm may, in its sole discretion, provide support to you. If you obtained the Arm Tools from an Arm authorised distributor, reseller or other third party, support and maintenance may be provided by either Arm or the third party as per the terms of your contract for supply. Arm shall not be responsible for any delay or failure in connection with any third party supplier providing support or maintenance that it is obligated to provide to you. Please refer to the 'Support' area of https://www.arm.com for details of Arm's support services, relevant contact details, and (if applicable) details of other authorised support channels.

5.5 Arm's obligations under this clause 5 are limited to the provision of support and maintenance to you, and Arm is under no obligation to provide any support and maintenance to any third parties. You agree to provide all front line support services to all third parties to whom you distribute any Arm Tools, Your Reports, Your Software or Your Hardware, pursuant to and in accordance with the terms of this License.

5.6 This License does not grant you any entitlement to receive (i) Upgrades, (ii) Arm products other than those specified in your product documentation, or (iii) any new products developed or introduced by Arm from time to time, nor to receive any support or maintenance in respect of the same.

6. CONFIDENTIALITY

6.1 You acknowledge that the Arm Tools, License Keys, Arm Tools Performance Data, and any and all other software, documentation or other information licensed to you by Arm, or provided to you during discussions about or in connection with the Arm Tools (including this License and information provided during the provision by Arm of any support), contain trade secrets and confidential information of Arm ("Confidential Information").

6.2 You agree to maintain all such Confidential Information in confidence and apply security measures (such measures to be no less stringent than the measures which you apply (or should reasonably apply) to protect your own like information, but not less than a reasonable degree of care) to prevent their unauthorised disclosure and use.

6.3 Subject to any restrictions imposed by applicable law, the period of confidentiality shall be five (5) years from the date of disclosure of the Confidential Information. You agree that you shall not use any such information other than in your normal use of the Arm Tools as permitted by this License.

7. LIMITED WARRANTIES

7.1 Subject to the restrictions in clause 2, for the period of ninety (90) days from the date of receipt by you of the Arm Tools, Arm warrants to you that (i) the media on which any Arm Software is provided shall be free from defects in materials and workmanship under normal use; and (ii) the Arm Software will perform substantially in accordance with the accompanying Arm Documentation (if any). Arm's total liability and your exclusive remedy for breach of these warranties shall be limited to Arm, at Arm's option (a) replacing the defective Arm Software; or (b) using reasonable efforts to correct material, documented, reproducible defects in the Arm Software and delivering such corrected Arm Software to you; or (c) if you licensed the Arm Software directly from Arm, refunding the price paid by you to Arm for that Arm Software. Any replacement Arm Software will be warranted for the remainder of the original warranty period or thirty (30) days from the date of replacement, whichever is longer.

7.2 The Arm Software described in any Arm Documentation is subject to continuous development and improvement. All particulars of the Arm Software and its use as described in the Arm Documentation are given by Arm in good faith. Consequently, the information contained in the Arm Documentation is subject to change without notice and is not warranted to be error free. If you discover any errors in the Arm Documentation please report them to Arm in writing. Any Arm Documentation provided to you that relates to specific industry quality and functional safety standard compliance may assist you in applying to a competent auditor for certification of Your Software or Your Hardware, but you acknowledge and agree that on its own such Arm Documentation may not provide sufficient evidence of, or be compatible with, the required safety compliance standards.

7.3 Except as provided in clause 7.1 above, you agree that the Arm Tools are licensed "as is", and that Arm expressly disclaims all representations, warranties, conditions or other terms, express or implied or statutory, including without limitation the implied warranties of non-infringement, satisfactory quality, and fitness for a particular purpose. You acknowledge that it is your responsibility to satisfy yourself that the Arm Tools are fit for the intended purpose and satisfy your requirements, including compatibility with Your Hardware, and you expressly assume all liabilities and risks relating to (i) any use of an Arm Tool which is inconsistent with its design or any guidance provided to you in the applicable Arm Documentation, and/or (ii) any use of an Arm Tool with Your Software or Your Hardware where such software or hardware (as applicable) is not supported by or compatible with the relevant Arm Tool.

7.4 You expressly assume all liabilities and risks relating to your use or operation of Your Software and Your Hardware designed or modified using the Arm Tools, including without limitation, Your software or Your Hardware designed or intended for safety-critical applications. Should Your Software or Your Hardware prove defective, you assume the entire cost of all necessary servicing, repair or correction.

8. LIMITATION OF LIABILITY

8.1 To the maximum extent permitted by applicable law, in no event shall Arm be liable for any indirect, special, incidental or consequential damages (including loss of profits) arising out of the use of, or inability to use, the Arm Tools, whether based on a claim under contract, tort or otherwise, even if Arm was advised of the possibility of such damages.

8.2 Arm does not seek to limit or exclude liability for death or personal injury arising from Arm's negligence or Arm's fraud. Arm acknowledges that certain jurisdictions do not permit the exclusion or limitation of liability for consequential or incidental damages, and in such cases the above limitation relating to liability for consequential damages may not apply to you.

8.3 Notwithstanding anything to the contrary contained in this License, the maximum liability of Arm to you in aggregate (in contract, tort or otherwise) in relation to or in connection with the subject matter of this License shall not exceed the greater of (i) the total sums paid by you to Arm (if any) for this License, and (ii) $10.00 USD. The existence of more than one claim will not enlarge or extend the limit.

9. THIRD PARTY MATERIAL

9.1 The Arm Tools may contain material owned or developed by third parties, including but not limited to open source software, freeware and commercial software ("Third Party Material"). Any Third Party Material is subject to the terms and conditions of the applicable Third Party Material license(s) and is not covered under the terms of this License. Details relating to such Third Party Material shall either be presented to you at the time of installation or shall be detailed in the Third Party Licenses File(s). Your use of such Third Party Material is subject to your compliance with the applicable Third Party Material license(s).

9.2 Arm hereby disclaims any and all warranties express or implied from any third parties regarding, or otherwise connected with, any Third Party Material included in the Arm Tools and any Third Party Material from which the Arm Tools are derived, and/or your use of any or all of the Third Party Material in connection with Your Software or Your Hardware, including (without limitation) any warranties of satisfactory quality or fitness for a particular purpose.

9.3 No Third Party Material licensors shall have any liability for any direct, indirect, incidental, special, exemplary, or consequential damages (including without limitation lost profits) howsoever caused and whether made under contract, tort or otherwise arising in any way out of your use or distribution of the Third Party Material or the exercise of any rights granted under either or both this License and the legal terms applicable to any Third Party Material, even if advised in advance of the possibility of such damages.

10. GOVERNMENT REQUIREMENTS

10.1 To the extent that you are an agency, contractor or instrumentality of the U.S. Government, you and we agree that:

(a) the Arm Tools are commercial computer software and commercial computer software documentation, and that your rights therein are as specified in this License, per FAR 12.212 and DFARS 227.7202-3, as applicable, or in the case of NASA, subject to NSF 1852.22786. Arm acknowledges that, whilst commercial computer software or commercial computer software documentation shall be acquired under licenses customarily provided to the public, such licenses must be consistent with U.S. Federal law and otherwise satisfy the U.S. Government's needs ("U.S. Government Requirements"); and

(b) you may assign your rights under this License to the relevant US Government Federal Department or the successor contractor designated by the US Government Federal Department upon termination of your related prime contract with that US Government Federal Department. If you exercise your rights under this clause 10.1(b), you acknowledge and agree that you shall remain liable to Arm in respect of all your obligations under this License.

10.2 If there is any material inconsistency between (i) either a U.S. Government Requirement or a requirement of another government with which Arm is mandated by statute to comply and (ii) any provision of this License, the terms of the relevant government requirement shall prevail and the provision in question shall be deemed varied or deleted (as applicable) as required by the terms of the relevant government requirement. For the avoidance of doubt, in such circumstances, all other terms, conditions and provisions of this License will continue to be valid to the fullest extent permitted by law in accordance with the below clause 12.3.

11. TERM AND TERMINATION

11.1 Subject to clauses 11.2 and 11.3 below, this License shall remain in force until terminated by you, by Arm or (in the case of a time limited license) by expiry.

11.2 In the event of a party breaching of any of the terms and conditions of this License, which if capable of remedy, has not been remedied by that party within thirty (30) days of the date of breach, without prejudice to any of its other rights under this License, the non-breaching party may terminate this License immediately upon giving written notice to the breaching party. Upon termination of this License by you or by Arm, or upon expiry, you shall (and shall ensure that your Permitted Users shall) immediately (i) stop using the Arm Tools (or any element thereof) and any Confidential Information and, (ii) destroy all copies of the same in your possession or control, together with all Arm Documentation and related materials.

11.3 Notwithstanding the foregoing, except where Arm has terminated this License for your breach, your rights (if applicable) to distribute any of Your Software or Your Hardware developed using the Arm Tools prior to termination or expiry of this License shall (subject to your continued compliance with the terms and conditions of this License) survive such termination or expiry.

12. GENERAL

12.1 This License is governed by English Law. Notwithstanding the foregoing, to the extent that you are an agency, contractor or instrumentality of the U.S. Government, disputes arising under or relating to this License shall be decided under the U.S. federal law of government contracting, including without limitation the Contract Disputes Act. Nothing in this License shall prevent you from enforcing your intellectual property rights or seeking injunctive or other equitable relief in any court of competent jurisdiction. The parties hereby disclaim application of the United Nations Convention on Contracts for the International Sale of Goods and the Uniform Computer Information Transactions Act.

12.2 Except where Arm agrees otherwise in (i) a written contract signed by you and Arm, or (ii) a written contract provided by Arm and accepted by you, this is the only agreement between you and Arm relating to the Arm Tools and it may only be modified by written agreement between you and Arm. No terms and conditions contained in any purchase order or other document issued by you, or any advertising or other representation by you or any third party shall add to, supersede or in any way vary the terms and conditions of this License. This License (and any documents expressly incorporated into it by reference herein) represents the entire agreement between you and Arm in relation to its subject matter.

12.3 If any clause or sentence in this License is held by a court of law to be illegal or unenforceable, the remaining provisions of this License shall not be affected. Any failure by Arm to enforce any of the provisions of this License, unless waived in writing, shall not constitute a waiver of Arm's rights to enforce such provision or any other provision of this License in the future.

12.4 Subject to clause 10.1(b), neither this License or any rights granted to you under it may be assigned, sub-licensed or otherwise transferred by you to any third party without the prior written consent of Arm. An assignment shall be deemed to include, without limitation (i) any transaction or series of transactions whereby a third party acquires, directly or indirectly, the power to control the management and policies of you, whether through the acquisition of voting securities, by contract or otherwise; and (ii) the sale of more than fifty percent (50%) of your assets whether in a single transaction or series of transactions. Notwithstanding the foregoing, Arm may, in its discretion acting reasonably, separately agree to authorise the re-host of a Licensed Seat (for which additional charges may apply).

12.5 Subject to any applicable legal restrictions, including but not limited to those relating to the security of classified information, at Arm's request, (i) you agree to check your computers for installations of the Arm Tools, copies of License Keys, contents of any license server log files, individual or concurrent usage of Seats, and any other information requested by Arm relating to Arm Tools installation, usage and License Key management, and, to provide this information to Arm; and (ii) you agree that Arm may instruct appropriately qualified independent auditors to perform such checks by prior appointment during your normal business hours on reasonable notice. In respect of any audit, Arm shall bear the auditors' costs for that audit unless it reveals unlicensed usage, in which case you shall promptly reimburse Arm for all reasonable costs and expenses, including professional fees, relating to such audit. Any information which is disclosed to Arm or such auditors during checking or audit shall be treated as your confidential information and shall only be used by Arm for compliance and enforcement purposes.

12.6 The Arm Tools provided under this License are subject to U.S. export control laws, including the U.S. Export Administration Act and its associated regulations, and may be subject to export or import regulations in other countries. You agree to comply fully with all laws and regulations of the United States and other countries ("Export Laws") to ensure that the Arm Tools are not (i) exported, directly or indirectly, in violation of Export Laws, either to any countries that are subject to U.S. export restrictions or to any end user who has been prohibited from participating in the U.S export transactions by any federal agency of the U.S. government; or (ii) intended to be used for any purpose prohibited by Export Laws, including, without limitation, nuclear, chemical, or biological weapons proliferation.

Arm Document Reference LES-PRE-21260, Version 12.2, Effective Date 12 February 2019


Licensing User's Guide: License Agreement MDK v5.32 and above

License Agreement MDK v5.32 and above

END USER LICENSE AGREEMENT FOR ARM SOFTWARE DEVELOPMENT TOOLS

This end user license agreement ("License") is a legal agreement between you (a single individual), or the company or organisation (a single legal entity) that you represent and have the legal authority to bind, and Arm relating to use of the Arm Tools. Arm is only willing to license the Arm Tools on condition that you accept all of the terms of this License. By clicking "I Agree" or by installing or otherwise using the Arm Tools and/or any Update thereto (as permitted by this License) you indicate that you agree to be bound by all of the terms and conditions of this License. If you do not agree to the terms of this License, Arm will NOT license the Arm Tools to you, you may not install or use the Arm Tools or any part thereof, and you shall promptly return the Arm Tools to Arm or to your supplier (if not Arm) and ask for a refund of the license fee paid (if any).

NOTE - YOUR ATTENTION IS DRAWN TO THE FOLLOWING:

(A) The terms and conditions set out in this License shall apply to the supply by Arm of Arm Tools for both commercial and non-commercial use. If you are in receipt of a Non-Commercial Use License for the Arm Tools (each capitalised term as defined below), or the Arm Tools or any component thereof are identified or classified as such, or you are receiving a license for the Arm Tools free of charge, then notwithstanding any of the other terms and conditions of this License, your use of the Arm Tools shall be limited by the restrictions of use set out in clause 3.2 of this License.

(B) PLEASE NOTE any terms and conditions of use set out in the order documentation provided to you by Arm and the Software Information File(s) (as defined below) applicable to the Arm Tools provided to you with (or included within) either (i) the Arm Tools, and/or (ii) any Updates to the Arm Tools, which limit, extend or otherwise vary the permitted uses and restrictions applicable to the Arm Tools ("Special Conditions"). The Special Conditions form part of and are incorporated into this License. In the event of any conflict or inconsistency between the provisions set out in the main body of this License and any of the Special Conditions, the provisions set out in the Special Conditions shall prevail (in the order in which they are listed in this paragraph).

(C) This License (and any documents incorporated by reference herein) is the sole and exclusive agreement between you and Arm for the Arm Tools, and (except as agreed in writing to the contrary) no other document, including (but not limited to) your purchase order or any other document supplied by you, will form part of this License.

1. DEFINITIONS

For the purposes of this License the following words and expressions shall have the following meanings:

"Arm" means Arm Limited whose registered office is situated at 110 Fulbourn Road, Cambridge CB1 9NJ, England and/or any member of Arm's group of companies.

"Arm Documentation" means any printed, electronic or online documentation relating to Arm Software owned or licensed by Arm.

"Arm Software" means any and all software, firmware and data owned or licensed by Arm.

"Arm Tools" means any and all Arm Software and/or Arm Documentation (including any Updates to the Arm Software and/or Arm Documentation) licensed to you by Arm under this License.

"Arm Tools Performance Data" means any results, benchmarking data or other information relating to or connected with your use or testing of Arm Tools which is indicative of their performance, efficacy, reliability or quality.

"Fees" means any fee(s) payable by you for the provision by Arm to you of the Arm Tools and associated support and maintenance services, and any other fees payable by you in accordance with this License that are agreed by the parties from time to time.

"License Key" means an electronic license key issued to you by Arm which enables you to use and run one or more Licensed Seat of an Arm Tool or a component thereof in accordance with the terms of this License.

"Licensed Seats" means any and all Seats of the Arm Tools (including, if applicable, Updates) that you are licensed to run and use concurrently under the terms of this License, in the types and quantities specified (if applicable) in the order documentation provided to you by Arm, as well as any additional or replacement Seats of the Arm Tools that Arm provides to you from time to time during the License Term (For the purposes of this definition, "Seat" meaning a written or electronic authorisation to run a software component subject to the terms and restrictions specified in that authorisation).

"License Term" means the term set out in the order documentation provided to you by Arm during which you shall be entitled to access and use the Arm Tools.

"Non-Commercial Use License" means an evaluation, preview, beta, pre-release, pilot, academic, educational or community use only license.

"Permitted Users" means your employees, workers, consultants, professional advisors, bona fide sub-contractors and service providers that use the Arm Tools in connection with the provision of work carried out for your benefit, and/or, other members of your organisation or third party users who use the Arm Tools with your express written permission on computers (physical or virtual) owned or controlled by you.

"Redistributables" means the example code, library files, configuration files, header files, and any other Arm Tools or components thereof owned by Arm (or licensed by Arm and provided to you under Arm's terms and conditions) which you are permitted to include within Your Software and redistribute or sub-license within Your Software to third parties, the details of which (if applicable) are set out in a file or folder (the "Redistributables File") typically named 'redistributables' located within the 'license_terms' folder in an Arm Tool (or components thereof).

"Software Information File(s)" means Third Party Licenses Files, Redistributables Files, and/or Supplementary Terms Files (as the context requires).

"Special Conditions" is as defined above in Recital (B) of this License.

"Specified Project" means a single design and development activity undertaken by you or your Permitted Users relating to Your Software or Your Hardware, the details of which (if applicable) shall be set out in the order documentation provided to you by Arm.

"Supplementary Terms File" means a software file or folder typically named 'supplementary_terms' located within the 'license_terms' folder in an Arm Tool (or components thereof) which (if applicable) details any component-specific extensions, limitations or other variations to the terms of this License.

"Territory" means, if applicable, the geographical area detailed in the order documentation provided to you by Arm to which your use of the Arm Tools or any part thereof is restricted.

"Third Party Licenses File" means a software file or folder typically named 'third_party_licenses' located within the 'license_terms' folder in an Arm Tool (or components thereof) which (if applicable) details any third party material included in the relevant Arm Tool which is not licensed under the terms of this License, and a reference to the applicable third party license terms and conditions.

"Update" means an update, patch, hotfix, bug fix, support release, modification or limited functional enhancement (as applicable) to an Arm Tool or component thereof, including but not limited to error corrections to any program or associated documentation developed by or for Arm comprised in the Arm Tools, which (i) Arm makes generally available to the market, and (ii) does not, in Arm's opinion, constitute an Upgrade or a new product.

"Upgrade" means a new release of an existing Arm Tool which Arm makes generally available to the market and which usually contains major functional improvements.

"Your Hardware" means hardware manufactured or developed by you or on your behalf, or hardware owned or licensed by you, which is supported by Arm Tools.

"Your Reports" means any written reports or other information relating to the behavior or performance of Your Software or Your Hardware, in html, binary, text or any other format (excluding for the avoidance of doubt, Arm Tools Performance Data), generated by you from or using Arm Tools and any modifications thereto.

"Your Software" means any software owned or licensed by you (including, but not limited to, applications, libraries and Arm API compliant plug-ins, but excluding Arm Software) which is supported by (or developed by you using) Arm Tools.

2. LICENSE GRANT

2.1 Subject to your compliance with the terms and conditions of this License, and payment by you of the Fees (if any), Arm hereby grants to you and your Permitted Users during the License Term a non-exclusive, non-transferable license to receive and use the Arm Tools, certain components thereof, or optional functionality, in the Territory only on the Licensed Seats or for a Specified Project (as applicable) for the permitted uses set out in this clause 2 and subject to the restrictions set out in clause 3 (as limited, extended or otherwise varied by any terms, including product-specific permitted uses and restrictions, set out in the Special Conditions). Except as expressly permitted by this License, you and your Permitted Users shall NOT copy, modify, sub-license, redistribute or otherwise use any component of the Arm Tools.

2.2 PERMITTED USE OF THE ARM TOOLS: Except as otherwise provided in this License, use of the Arm Tools (or components thereof) is permitted for the purpose of:

(a) building, developing, testing, debugging, analysing and optimising Your Software or Your Hardware;

(b) generation of Your Reports, and use of Your Reports to develop, test, debug, analyse and optimise Your Software or Your Hardware; and

(c) only as expressly permitted in the relevant Redistributables File: (i) incorporating, compiling and/or linking the files listed in that Redistributables File into Your Software, provided that Your Software contains substantial additional functionality; and (ii) subject to clause 3.1 below, reproducing and redistributing the files (and permitting your customers and/or your authorised distributors to reproduce and redistribute the files), only in object code form (unless otherwise specified in the relevant Redistributables Files), and only as part of Your Software. You agree that, except as expressly provided to the contrary in the relevant Redistributables File, you may only copy the Arm Tools (or any component thereof) to the extent that such copying is incidental to the permitted uses set out in this clause 2.2, including installation, backup and execution.

3. YOUR OBLIGATIONS AND RESTRICTIONS ON USE

3.1 OBLIGATIONS RELATING TO REDISTRIBUTION: Any redistribution as permitted by this License is subject to any restrictions set out in the applicable Special Conditions, and your compliance with the following:

(a) in cases where you are expressly permitted under this License (including for the avoidance of doubt by inclusion of agreed wording in the order documentation provided to you by Arm) to sub-license or redistribute any Arm Tool or component thereof to your customers, authorised distributors or other third parties, you are responsible for ensuring that such customers, authorised distributors and third parties accept, and are contractually bound (by agreement with you or directly with Arm) to comply with, the terms and conditions of this License;

(b) any use by you of Arm's or any of its licensors' names, logos or trademarks to publicise or market any of Your Software containing (or developed or generated using) Arm Tools is subject to you obtaining express written permission from Arm;

(c) you warrant that you shall not make any representations or warranties on behalf of Arm in respect of any of the Arm Tools or in respect of any other software, reports or documentation developed or generated by you in accordance with the license grants set out in this License;

(d) you must reproduce or preserve (as applicable) any copyright notices which are included in or with any Arm Tools or components thereof; and

(e) except as otherwise agreed by Arm (including for the avoidance of doubt by inclusion of the relevant permission in a Supplementary Terms File), you may not disclose or otherwise distribute any Arm Tools Performance Data. For the avoidance of doubt, nothing in this sub-clause 3.1 (e) shall prevent you from disclosing or otherwise distributing Your Reports.

3.2 NON-COMMERCIAL USE AND FREE OF CHARGE LICENSES: If you are in receipt of a Non-Commercial Use License for the Arm Tools, or the Arm Tools or any component thereof are identified or classified as such, and/or you are receiving the Arm Tools free of charge, then notwithstanding any of the other terms and conditions of this License, your use (which includes use by your Permitted Users) of the Arm Tools is limited as follows:

(a) if you are receiving the Arm Tools free of charge:

  • (i) no support or maintenance shall be provided to you in respect of the Arm Tools;
  • (ii) the warranty set out in clause 8.1 of this License does not apply to you or your use of the Arm Tools, and Arm gives no other warranty whatsoever in relation to (and accepts no liability in connection with) the Arm Tools or your use (as permitted by this License) of them;
  • (iii) Arm may immediately terminate this License at any time for any reason by giving written notice to you;
  • (iv) except as otherwise expressly agreed in writing by Arm, you shall grant to Arm in full the license set out in clause 4.2 of this License; and/or
    • (b) if you are receiving a Non-Commercial Use License or version (as applicable) of the Arm Tools:
  • (i) you and your Permitted Users may use the Arm Tools for internal use only; and
  • (ii) you are not permitted to distribute or sub-license (A) any part of the Arm Tools, or (B) Your Software, Your Hardware, or Your Reports developed under this License using the Arm Tools. The Arm Tools shall be used only by you and your Permitted Users, and you shall not (except as otherwise authorised in writing by Arm) allow any other third party whatsoever to use the Arm Tools.

For the avoidance of doubt, if you are receiving a Non-Commercial Use License and the license is provided to you free of charge, the restrictions in both sub-clauses (a) and (b) above will apply to your use of the Arm Tools.

3.3 LICENSE TYPES: Depending on the type of license you have purchased from Arm under this License (the details of which shall be set out in the order documentation provided to you by Arm), your use of the Arm Tools shall be limited to:

(a) use of each Licensed Seat (i) by only one individual assigned Permitted User on unlimited items of computer hardware ('Authorised User License'), OR (ii) by one individual Permitted User at a time only on one specified item of computer hardware ('Node Locked License'), OR (iii) by one individual Permitted User at a time on specified items of computer hardware ('Floating License'). In respect of 'Node Locked Licenses', each Licensed Seat may only be used for one 'process' at any one time. For the purpose of this sub-clause 3.3 (a), each 'process' is the execution of an instance of an Arm Tool; or

(b) use for a Specified Project.

3.4 PERMITTED USERS: You hereby agree to be responsible for the acts and omissions of any and all Permitted Users, and shall ensure that such Permitted Users (i) are contractually obliged to comply with the terms of this License, including those relating to confidentiality; and (ii) do not supply Arm Tools or any components thereof to any third party whatsoever. Except as expressly provided in this License or as agreed in writing by Arm on a case by case basis, you shall not sub-license, redistribute, lease, rent or otherwise allow any third party to use the Arm Tools or License Keys.

3.5 REVERSE ENGINEERING: Your use of Arm Tools shall specifically exclude the reverse engineering, decompiling, disassembly, translation, adaptation, arrangement or other alteration of any part of the Arm Tools (except to the extent that applicable law overrides this provision or any part hereof).

3.6 COPYRIGHT AND RESERVATION OF RIGHTS: Arm Tools are owned by Arm and/or its licensors and are protected by copyright and other intellectual property rights, laws and international treaties. Arm Tools are licensed not sold. Except as expressly provided by this License, you acquire no rights to any Arm Tools or elements thereof, or to any other Arm products or services. You shall not remove from Arm Tools any copyright notice or other notice and shall ensure that any such notice is reproduced in any permitted reproduction of the whole or any part of the Arm Tools.

3.7 TECHNICAL RESTRICTIONS IN ARM TOOLS: You must comply with any technical restrictions in Arm Tools and License Keys, including any restrictions that restrict use to certain components of Arm Tools or use only for certain purposes. You shall not work around any such technical restrictions.

3.8 ARM DOCUMENTATION: Use of Arm Documentation (if any) is permitted internally only in conjunction with your use of the Arm Software to which it relates.

4. LICENSE OF FEEDBACK TO ARM

4.1 You may at your discretion deliver any suggestions, comments, feedback, ideas, or know-how (whether in oral or written form) to Arm relating to or connected with your use of Arm Tools ("Feedback"). Notwithstanding the foregoing, you shall not knowingly give to Arm any Feedback that you are aware (or should reasonably be aware) is subject to any patent, copyright or other intellectual property claim or right of any third party.

4.2 Except as expressly notified by you to Arm (in writing which may include email) to the contrary, you hereby grant to Arm under your and your affiliates (as applicable) intellectual property, a perpetual, irrevocable, royalty free, non-exclusive, worldwide license to: (i) use, copy, modify, and create derivative works of the Feedback; (ii) sell, supply or otherwise distribute the whole or any part of the Feedback (and derivative works thereof) as part of any Arm owned or licensed product(s) without obligation or restriction of any kind; and (iii) sub-license to third parties the foregoing rights, including the right to sub-license to further third parties. No right is granted by you to Arm to sub-license your and your affiliates (as applicable) intellectual property except to the extent that it is provided to Arm as Feedback and is embodied in any Arm owned or licensed product(s). For the avoidance of doubt, if, during the License Term, you provide notice to Arm revoking the license granted under this clause 4.2, you acknowledge and agree that such revocation shall not apply to Feedback delivered to Arm prior to the date of receipt of the revocation notice, and that (notwithstanding the foregoing) Arm shall continue to be permitted to use Feedback received after the date of receipt of the revocation notice for internal purposes.

4.3 Except as expressly licensed to Arm in clause 4.2, you retain all right, title and interest in and to the Feedback provided by you under this License.

5. DATA COLLECTION AND PRIVACY

5.1 Arm Software may include features that enable it to transmit certain computer information over the internet to Arm's and/or its service providers' computer systems, for example your computer's internet protocol address, computer hardware and operating system details, or the serial numbers of Arm Tools you have licensed. This information will not be shared with any third parties, and shall be used by Arm only for the purpose of Arm protecting its legitimate interests, which may include Arm verifying your right to use any Arm Tools and monitoring your compliance with the permitted uses and restrictions set out in this License.

5.2 Arm may also collect anonymous data, which, for the avoidance of doubt, cannot be used to identify individual users of Arm Tools. This information may be used by Arm to help us understand and analyse what components or features in Arm Tools our end users are using in order to (i) maintain and improve the quality of the Arm Tools and the end user experience, (ii) inform end users of relevant new and improved products and services, and (iii) assist end users to maximise the performance of, or solve user experience issues with, the Arm Tools.

5.3 Information collected by Arm Software will only be used for the aforementioned purposes. Please refer to the Arm Privacy Policy https://www.arm.com/company/policies /privacy for further information on how Arm collects, uses and safeguards personal data (including but not limited to personal data collected for the protection of Arm's legitimate interests and your rights to object to its collection).

6. SUPPORT AND MAINTENANCE

6.1 Provision of reasonable support and maintenance is subject to payment by you of all applicable Fees.

6.2 Any support provided by Arm in accordance with the above clause 6.1 shall (i) be provided by telephone, email or such other format as is designated by Arm, (ii) be prioritised at Arm's discretion, and (iii) not be used as a substitute for training or as additional resource for your projects.

6.3 Maintenance will generally be provided in the form of Updates to Arm Tools. Arm shall be under no obligation to provide such maintenance in respect of any modifications made by you (where permitted) to Arm Tools. Updates do not constitute additional Licensed Seats and may only be used by you if you have an active Licensed Seat to run and use such Updates. Updates will generally be provided to you as soon as reasonably practicable following the date of general public release of the Update by Arm.

6.4 In cases where the Arm Tools were provided to you free of charge, you are not entitled to any support or maintenance for the Arm Tools from Arm, but Arm may, in its sole discretion, provide support to you. If you obtained the Arm Tools from an Arm authorised distributor, reseller or other third party, support and maintenance may be provided by either Arm or the third party as per the terms of your contract for supply. Arm shall not be responsible for any delay or failure in connection with any third party supplier providing support or maintenance that it is obligated to provide to you. Please refer to the 'Support' area of https://www.arm.com for details of Arm's support services, relevant contact details, and (if applicable) details of other authorised support channels.

6.5 Any obligation Arm has under this clause 6 is limited to the provision of support and maintenance to you, and Arm is under no obligation to provide any support and maintenance to any third parties. You agree to provide all front line support services to all third parties to whom you distribute any Arm Tools, Your Reports, Your Software or Your Hardware, pursuant to and in accordance with the terms of this License.

6.6 This License does not grant you any entitlement to receive (i) Upgrades, (ii) Arm products other than those specified in your product documentation, or (iii) any new products developed or introduced by Arm from time to time, nor to receive any support or maintenance in respect of the same.

7. CONFIDENTIALITY

7.1 You acknowledge that the Arm Tools, License Keys, Arm Tools Performance Data, and any and all other software, documentation or other information licensed to you by Arm, or provided to you during discussions about or in connection with the Arm Tools (including this License and information provided during the provision by Arm of any support), contain trade secrets and confidential information of Arm ("Confidential Information").

7.2 You agree to maintain all such Confidential Information in confidence and apply security measures (such measures to be no less stringent than the measures which you apply (or should reasonably apply) to protect your own like information, but not less than a reasonable degree of care) to prevent their unauthorised disclosure and use.

7.3 Subject to any restrictions imposed by applicable law, the period of confidentiality shall be indefinite. You agree that you shall not use any such information other than in your normal use of the Arm Tools as permitted by this License.

8 LIMITED WARRANTIES

8.1 Subject to the restrictions in clause 3, for the period of ninety (90) days from the date of receipt by you of Arm Tools, Arm warrants to you that; (i) Arm Software will perform substantially in accordance with the accompanying Arm Documentation (if any); and (ii) Arm Software will be compatible with the hardware and software mentioned as such in the Arm Documentation. Arm's total liability and your exclusive remedy for breach of these warranties shall be limited to Arm, at Arm's option (a) replacing any defective Arm Software; or (b) using reasonable efforts to correct material, documented, reproducible defects in the Arm Software and delivering such corrected Arm Software to you; or (c) if you licensed the Arm Software directly from Arm, refunding the price paid by you to Arm for that Arm Software. Any replacement Arm Software will be warranted for the remainder of the original warranty period or thirty (30) days from the date of replacement, whichever is longer.

8.2 Arm Software described in any Arm Documentation is subject to continuous development and improvement. All particulars of Arm Software and its use as described in the applicable Arm Documentation are given by Arm in good faith. Consequently, the information contained in Arm Documentation is subject to change without notice and is not warranted to be error free. If you discover any errors in Arm Documentation please report them to Arm in writing. Any Arm Documentation provided to you that relates to specific industry quality and functional safety standard compliance may assist you in applying to a competent auditor for certification of Your Software or Your Hardware, but you acknowledge and agree that on its own such Arm Documentation may not provide sufficient evidence of, or be compatible with, the required safety compliance standards.

8.3 Except as provided in clause 8.1 above, you agree that Arm Tools are licensed "as is", and that Arm expressly disclaims all representations, warranties, conditions or other terms, express or implied or statutory, including without limitation the implied warranties of non-infringement, satisfactory quality, and fitness for a particular purpose. You acknowledge that it is your responsibility to satisfy yourself that any Arm Tools are fit for the intended purpose and satisfy your requirements, including compatibility with Your Hardware, and you expressly assume all liabilities and risks relating to (i) any use of an Arm Tool which is inconsistent with its design or any guidance provided to you in the applicable Arm Documentation, and/or (ii) any use of an Arm Tool with Your Software or Your Hardware where such software or hardware (as applicable) is not supported by or compatible with the relevant Arm Tool.

8.4 You expressly assume all liabilities and risks relating to your use or operation of Your Software and Your Hardware designed or modified using Arm Tools, including without limitation, Your software or Your Hardware designed or intended for safety-critical applications. Should Your Software or Your Hardware prove defective, you assume the entire cost of all necessary servicing, repair or correction.

9 LIMITATION OF LIABILITY

9.1 To the maximum extent permitted by applicable law, in no event shall Arm be liable for any indirect, special, incidental or consequential damages (including loss of profits) arising out of the use of, or inability to use, Arm Tools, whether based on a claim under contract, tort or otherwise, even if Arm was advised of the possibility of such damages.

9.2 Arm does not seek to limit or exclude liability for death or personal injury arising from Arm's negligence or Arm's fraud. Arm acknowledges that certain jurisdictions do not permit the exclusion or limitation of liability for consequential or incidental damages, and in such cases the above limitation relating to liability for consequential damages may not apply to you.

9.3 Notwithstanding anything to the contrary contained in this License, the maximum liability of Arm to you in aggregate (in contract, tort or otherwise) in relation to or in connection with the subject matter of this License shall not exceed the greater of (i) the total sums paid by you to Arm (if any) for this License, and (ii) $10.00 USD. The existence of more than one claim or suit will not enlarge or extend the limit. You release Arm from all obligations, liability, claims or demands in excess of this limitation.

10 THIRD PARTY MATERIAL

10.1 Arm Tools may contain material owned or developed by third parties, including but not limited to open source software, freeware and commercial software ("Third Party Material"). Details relating to such Third Party Material shall be detailed in the Third Party Licenses File(s). Your use of such Third Party Material is subject to your compliance with the applicable Third Party Material license(s).

10.2 Arm hereby disclaims any and all warranties express or implied from any third parties regarding, or otherwise connected with, any Third Party Material included in Arm Tools and any Third Party Material from which any Arm Tools are derived, and /or your use of any or all of the Third Party Material in connection with Your Software or Your Hardware, including (without limitation) any warranties of satisfactory quality or fitness for a particular purpose.

10.3 No Third Party Material licensors shall have any liability for any direct, indirect, incidental, special, exemplary, or consequential damages (including without limitation lost profits) howsoever caused and whether made under contract, tort or otherwise arising in any way out of your use or distribution of the Third Party Material or the exercise of any rights granted under this License, even if advised in advance of the possibility of such damages.

11. GOVERNMENT REQUIREMENTS

11.1 To the extent that you are an agency, contractor or instrumentality of the U.S. Government, you and we agree that:

(a) Arm Tools are commercial computer software and commercial computer software documentation, and that your rights therein are as specified in this License, per FAR 12.212 and DFARS 227.7202-3, as applicable, or in the case of NASA, subject to NSF 1852.22786. Arm acknowledges that, whilst commercial computer software or commercial computer software documentation shall be acquired under licenses customarily provided to the public, such licenses must be consistent with U.S. Federal law and otherwise satisfy the U.S. Government's needs ("U.S. Government Requirements"); and

(b) you may assign your rights under this License to the relevant US Government Federal Department or the successor contractor designated by the US Government Federal Department upon termination of your related prime contract with that US Government Federal Department. If you exercise your rights under this clause 11.1(b), you acknowledge and agree that you shall remain liable to Arm in respect of all your obligations under this License.

11.2 If there is any material inconsistency between (i) either a U.S. Government Requirement or a requirement of another government with which Arm is mandated by statute to comply and (ii) any provision of this License, the terms of the relevant government requirement shall prevail and the provision in question shall be deemed varied or deleted (as applicable) as required by the terms of the relevant government requirement. For the avoidance of doubt, in such circumstances, all other terms, conditions and provisions of this License will continue to be valid to the fullest extent permitted by law in accordance with the below clause 13.3.

12. TERM AND TERMINATION

12.1 Subject to clauses 12.2 and 12.3 below, this License shall remain in force until terminated by you, by Arm or (in the case of a time limited license) by expiry.

12.2 In the event of a party breaching of any of the terms and conditions of this License, which if capable of remedy, has not been remedied by that party within thirty (30) days of the date of breach, without prejudice to any of its other rights under this License, the non-breaching party may terminate this License immediately upon giving written notice to the breaching party. Upon termination of this License by you or by Arm, or upon expiry, you shall (and shall ensure that your Permitted Users shall) immediately (i) stop using the relevant Arm Tools (or any element thereof) and any Confidential Information and, (ii) destroy all copies of the same in your possession or control, together with all Arm Documentation and related materials.

12.3 Notwithstanding the foregoing, except where Arm has terminated this License for your breach, your rights (if applicable) to distribute any of Your Software or Your Hardware developed using the Arm Tools prior to termination or expiry of this License shall (subject to your continued compliance with the terms and conditions of this License) survive such termination or expiry.

12.4 Without limitation to the survival of other terms as expressly set out elsewhere in this License, upon termination or expiry of this License, the provisions of clauses 1, 3.1, 3.5, 4, 7, 8, 9, 10, 12 and 13 shall survive.

13. GENERAL

13.1 This License is governed by English Law. Notwithstanding the foregoing, to the extent that you are an agency, contractor or instrumentality of the U.S. Government, disputes arising under or relating to this License shall be decided under the U.S. federal law of government contracting, including without limitation the Contract Disputes Act. Nothing in this License shall prevent you from enforcing your intellectual property rights or seeking injunctive or other equitable relief in any court of competent jurisdiction. The parties hereby disclaim application of the United Nations Convention on Contracts for the International Sale of Goods and the Uniform Computer Information Transactions Act.

13.2 Except where Arm agrees otherwise in (i) a written contract signed by you and Arm, or (ii) a written contract provided by Arm and accepted by you, this License (including any documents expressly incorporated herein) is the only agreement between you and Arm relating to the Arm Tools and it may only be modified by written agreement between you and Arm. No terms and conditions contained in any purchase order or other document issued by you, or any advertising or other representation by you or any third party shall add to, supersede or in any way vary the terms and conditions of this License. This License (and any documents expressly incorporated into it by reference herein) represents the entire agreement between you and Arm in relation to its subject matter.

13.3 If any clause or sentence in this License is held by a court of law to be illegal or unenforceable, the remaining provisions of this License shall not be affected. Any failure by Arm to enforce any of the provisions of this License, unless waived in writing, shall not constitute a waiver of Arm's rights to enforce such provision or any other provision of this License in the future.

13.4 Subject to clause 11.1(b), neither this License or any rights granted to you under it may be assigned, sub-licensed or otherwise transferred by you to any third party without the prior written consent of Arm. An assignment shall be deemed to include, without limitation (i) any transaction or series of transactions whereby a third party acquires, directly or indirectly, the power to control the management and policies of you, whether through the acquisition of voting securities, by contract or otherwise; and (ii) the sale of more than fifty percent (50%) of your assets whether in a single transaction or series of transactions. Notwithstanding the foregoing, Arm may, in its discretion acting reasonably, separately agree to authorise the re-host of a Licensed Seat (for which additional charges may apply).

13.5 Subject to any applicable legal restrictions, including but not limited to those relating to the security of classified information, at Arm's reasonable request, (i) you agree to check your computers for installations of the Arm Tools, copies of License Keys, contents of any license server log files, individual or concurrent usage of Licensed Seats, and any other information requested by Arm relating to Arm Tools installation, usage and License Key management, and, to provide this information to Arm; and (ii) you agree that Arm may instruct appropriately qualified independent auditors to perform such checks by prior appointment during your normal business hours on reasonable notice. In respect of any audit, Arm shall bear the auditors' costs for that audit unless it reveals unlicensed usage, in which case you shall promptly reimburse Arm for all reasonable costs and expenses, including professional fees, relating to such audit. Any information which is disclosed to Arm or such auditors during checking or audit shall be treated as your confidential information and shall only be used by Arm for compliance and enforcement purposes.

13.6 Arm Tools provided under this License are subject to U.S. export control laws, including the U.S. Export Administration Act and its associated regulations, and may be subject to export or import regulations in other countries. You agree to comply fully with all laws and regulations of the United States and other countries ("Export Laws") to ensure that the applicable Arm Tools are not (i) exported, directly or indirectly, in violation of Export Laws, either to any countries that are subject to U.S. export restrictions or to any end user who has been prohibited from participating in the U.S export transactions by any federal agency of the U.S. government; or (ii) intended to be used for any purpose prohibited by Export Laws, including, without limitation, nuclear, chemical, or biological weapons proliferation.

Arm Document Reference LES-PRE-21260, Version 12.3, Effective Date 18 June 2020


Licensing User's Guide: License Agreements and Terminologies

License Agreements and Terminologies

The various toolchains offered by Keil have different license agreements. The same terminologies are used for all license agreements.

  • License agreement MDK v5.32 and above provides a copy of the license agreement for the Keil MDK editions starting with MDK v5.32.
  • License agreement MDK v5.30 and above provides a copy of the license agreement for the Keil MDK editions starting with MDK v5.30.
  • License agreement MDK v5.29 provides a copy of the license agreement for the Keil MDK v5.29 editions.
  • License agreement MDK v5.27 (pre-release) and v5.28 provides a copy of the license agreement for the Keil MDK editions starting with MDK v5.27 (pre-release) up until v5.28.
  • License agreement MDK v5.26 and below provides a copy of the license agreement for the Keil MDK editions up to (and including) MDK v5.26.
  • License agreement C51, C166, C251 provides a copy of the license agreement for the Keil C51, C166, C251 Development Tools.
  • License agreement FuSa RTS provides copies of the license agreements for the Arm Run-Time System for functional safety (FuSa RTS).
  • Terminology defines terms and acronyms associated with product licensing.


Licensing User's Guide: Licensing Errors

Licensing Errors

The following errors may occur during product licensing or product use. They appear:

  • In the License Management dialog,
  • In the Output Window when starting the Debugger,
  • or In the Output Window as a WARNING generated by the Compiler, Assembler, or Linker/Locater.

General Error Messages

  • R200: RENEW LICENSE ID CODE (LIC)
R201: INVALID LICENSE ID CODE (LIC)
    The CID of your computer has changed (typically this happens when you update the operating system). Uninstall your current LIC and (so that license is returned to the pool) and obtain a new LIC.
  • R202: LICENSE TIMEOUT
    The computer time is invalid. Check the time setting on your computer and make sure that the clock is working.
  • R203: EVALUATION PERIOD EXPIRED
    Your license has a time limit that is now expired. Please contact the Keil Software Sales Department or your local Keil Software Distributor.
  • R204: LICENSE ERROR
R205: PARAMETER ERROR
    Internal Error, contact http://www.keil.com/support/.
  • R206: NO REGISTRY ACCESS, ADMINISTRATION RIGHTS REQUIRED
    You have no access to the registry of your computer. Please log in with administration rights or change the rights of the current user to administration rights.
  • R207: REGISTRY READ ERROR
    Internal Error, contact http://www.keil.com/support/.
  • R208: RENEW LICENSE ID CODE (LIC)
    During software registration some computer parameters have changed. Make sure that you are using the same network configuration and do not change the network adapter (or reconfigure other hardware parameters) until you have added the LIC in the License Management dialog.

    This error can occur if:

    • Your LIC has been modified since it was generated. Did you incorrectly copy it?
    • Some of the computer parameters have changed since you generated your LIC.

    Solution:

    • Make sure you correctly copied your LIC, or
    • Uninstall this LIC and click the ‘Get LIC via Internet’ button to obtain a new LIC for this computer.

    Refer to Single-User License — Get LIC via Internet for more information.

  • R209: CANNOT CREATE FLOATING LICENSE FILE
R20A: FLF FILE WRITE ERROR
    The Floating License File (*.FLF) cannot be created. This typically indicates insufficient access rights on the network drive.
  • R20B: FLF FILENAME MUST BE A NETWORK FILE
    The Floating License File (*.FLF) must be created on a network drive using a Universal Naming Convention (UNC) path, such as \\server\share\license. File name paths on your local computer are not accepted.

    This error can occur if:

    • The administrator attempts to create the *.FLF file from the same computer acting as the file server.
  • R20C: READ ERROR ON FLF FILE
R20D: CONTENT ERROR IN FLF FILE
    Generated when there is a read error to the *.FLF file.

    This error can occur if:

    • LIC was created as a Single-User License via 'Get LIC via Internet' button, or
    • LIC does not belong to the FLF file referred to in the file TOOLS.ini, or
    • Because the FLF file was moved, or the network drive changed name.

    Solution:

    • Use your PSN to create an Floating License File (FLF), or if you already have an FLF
    • Obtain a new LIC by clicking the 'Add Product' button for your FLF file, or
    • Check that the FLF path in your TOOLS.ini file is the one you used to obtain your LIC, or
    • Check with your Floating License Administrator if the FLF file was moved, or if the network drive name changed.
  • R20E: LICENSE INVALID - TRANSFER FAILED
    The LIC that you are trying to install has been already uninstalled.

    This error can occur if:

    • You are trying to use an uninstalled LIC, or
    • A newer LIC has been installed on this machine, making this old LIC invalid.

    Solution:

    • Uninstall this LIC and click the ‘Get LIC via Internet’ button to obtain a new LIC for this computer.
    Refer to Uninstall for more information and obtain a new LIC for this computer.
  • R20F: INCOMPATIBLE LICENSE DLL
    The License DLL is incompatible with the software product. Please contact http://www.keil.com/support/.
  • R210: ACCESS ERROR - FLF FILE IN USE BY ANOTHER COMPUTER
    The Floating License File (*FLF) cannot be accessed since it is in use by another application. If this error occurs multiple times, contact http://www.keil.com/support/.
  • R211: READ ERROR ON FLF FILE
R212: WRITE ERROR ON FLF FILE
R213: INVALID FLF FILE
    The Floating License File (* FLF) has an illegal format. Please contact http://www.keil.com/support/.
  • R214: A FLOATING USER HAS INCORRECT COMPUTER TIME
    A computer that is using a Floating License has an invalid time. Check the clock setting of the current active users. The clock of the floating users must be within ± 10min. This error may cause that licenses are blocked for 3 hours.
  • R215: CURRENTLY NO LICENSE AVAILABLE
    You are trying to obtain a Floating-User License, but the maximum user limit is exceeded. Check the list of current active users.

    You may contact the Keil Software Sales Department or your local Keil Software Distributor to increase the number of users on your license.
  • R216: SERIAL NUMBER MISMATCH
    There is a consistency problem on your computer. Please contact http://www.keil.com/support/.
  • R217: NO FLF FILENAME IN TOOLS.INI
    In your system the path to the Floating License File (*.FLF) is missing. Typically, this happens when the \KEIL\TOOLS.INI file has been manually changed. This error can also happen if a user tries to obtain a Single-User LIC using a Floating-User PSN. Either way, reinstall the Floating-User License on this computer.
  • R218: CHECKOUT DATE CANNOT BE BEFORE TODAY
    The Check Out date must be within the next 60 days. You cannot check out a license before today or after 60 days.
  • R219: FLOATING LICENSE FILE (*.FLF) NOT FOUND
    The system cannot access the floating license file. This happens typically when the network connection is missing or the server cannot be accessed.
  • R220: INSUFFICIENT ACCESS RIGHTS TO FLOATING LICENSE FILE (*.FLF)
    You have insufficient access rights to the floating license file. Please contact the Floating-User Administrator and make sure that you have read/write access rights to the Floating License File.
  • R221:CHECKOUT CANNOT BE LONGER THAN 60 DAYS
    The Check Out date must be within the next 60 days. You cannot check out a license before today or after 60 days.
  • R222: CHECKIN REJECTED: TIMEOUT WIHTIN NEXT FEW HOURS
    The Check In is rejected since the license timeout is within the next 3 hours.
  • R223: CHECKIN REJECTED: LICENSE NOT IN USE
    The Check In is rejected since the license of this computer was not in use.
  • R224: FLOATING LICENSE FILE INCONSISTENT, LICENSE CURRENTLY BLOCKED
    The FLF File has a consistency problem. The license of this computer is blocked for 3 hours.

    This error can occur if:

    • Multiple user accounts are trying to share a floating LIC on the same machine.
    • A backup of an FLF file is restored.
    • Trying to run the µVision tool from the same PC licensed with a floating license file.

    Solution:

    • Create or use only a single user account for uVision on this machine, or
    • For MDK-ARM only: Ask the Keil Sales Team about switching to FlexNet floating licensing. Email sales.intl@keil.com for more information.
  • R225: TOOLS.INI NOT FOUND
    The file TOOLS.INI cannot be found. This file is located in the KEIL root folder. Refer to Folder Structure of the µVision User's Guide.
  • R226: PRODUCT IS NOT A FLOATING LICENSE
    The PSN does not belong to a Floating User License and therefore it is not possible to create a FLF file with this number.
  • R227: CURRENTLY NO LICENSE AVAILABLE
    The Floating User License has reached the maximum number of users.

    Solution:

    • Click the button Used by to view the list of users who have checked out a floating license.
  • R228: PATH TO FLF FILE MUST BE IDENTICAL ON ALL COMPUTERS
    The path name used to create the FLF file is different from the path name used to obtain a LIC. The path name to the FLF file must be identical on all computers.

    This error can occur if:

    • The path name used to create the FLF file is different from the path name used to obtain a LIC, or
    • The network drive where the FLF is stored changed name

    Solution:

    • When FLF file is created, make sure all users use the same exact path to access file, or
    • Make sure all users can access the FLF using the same network drive name that it was created on.
  • R229: FLF FILE ALREADY EXISTS
    The file containing the floating licenses exists and cannot be created in this path.

    This error can occur if:

    • Tried to create an *.FLF file in a folder where one already existed.

    Solution:

    • Select another folder to create the FLF in, or delete any unused FLF files found.

    ATTENTION:

    Please check with your administrator before deleting an FLF file. It may still be in use.
  • R230: CONNECT TO UVISION KERNEL FAILED

    This error can occur if:

    • LIC is generated for the China region and this OS does not use Chinese as the default language.

    Solution:

    • Update your OS to use Chinese as the default language, or
    • Request a new PSN from Keil Sales. Email sales.intl@keil.com for more information.
  • R240: FLEX ERROR

    These errors occur for various reasons as specified by the FlexNet Publisher licensing package. Please refer to the FlexNet Publisher End User guide for more information.

  • R241: A FLEX LICENSE SERVER IS NOT DEFINED

    This error can occur if:

    • No Flex license server is defined in the TOOLS.ini file (i.e. FLEX=port@host), but the Flex licensing flag is set (i.e. FLEX_USE=1).

    Solution:

    • If you intend to use Flex licensing, include the line FLEX=port@host in the TOOLS.ini file, where
      • port is the port number to contact the server on, and
      • host is the hostname of the machine where the server is running.
    • If you do not intend to use Flex licensing, specify FLEX_USE=0 in your TOOLS.ini file.
  • R242: FLEX_USE IS SET TO 1 BUT NO FLEX_VARIANT IS DEFINED

    This error can occur if:

    • No MDK product variant has been specified in the TOOLS.ini file (for example, FLEX_VARIANT=<some-variant>), but the Flex licensing flag is set (FLEX_USE=1)

    Solution:

    • If you intend to use Flex licensing, include the line FLEX_VARIANT=<some-variant> in the TOOLS.ini file, where
      • <some-variant> represents the MDK product that you have Flex licenses for. For example: mdk_pro, mdk_std, mdk_cm_std, etc.
    • If you do not intend to use Flex licensing, specify FLEX_USE=0 in your TOOLS.ini file.

    See the Licensing User Guide for more information.

Security Key Messages

  • R003: SECURITY KEY NOT FOUND
    Your license is protected by a security key, but the security key is not found on your computer. Refer to GENERAL: UPGRADED TO WINDOWS NT/2000 AND PROTECTION FAILS in the Support Knowledgebase for more information. It is recommended that you use the Dongle Testing Application that may be downloaded from this article.
  • R007: PORT IS BUSY
    The security key is connected to a LPT port, but the LPT port is not released by a printer driver. Typically this happens when you print documents using other software products.
  • R009: NO PORT FOUND
    Internal Error, which is indicates a wrong configuration of the security device driver. Refer to GENERAL: CONFIGURING THE USB SECURITY KEY DRIVER in the Support Knowledgebase for more information.
  • R012: DRIVER NOT INSTALLED
    The security device driver is not installed. Refer to GENERAL: WARNING 500 -MISSING DEVICE (DRIVER NOT INSTALLED) in the Support Knowledgebase for more information.

Other Hardware-Related Messages

  • R100: HARDWARE NOT FOUND
    EPM900 protected license, but EPM900 is not present.


Licensing User's Guide: MDK-Professional Evaluation

MDK-Professional Evaluation

The MDK-Lite Edition allows you to evaluate the full potential and features of the MDK-Professional Edition by installing an evaluation license. This removes the code size limits and you can explore and test the comprehensive middleware. The trial period is limited to 30 consecutive days.

Installation

  1. Open the dialog File - License Management with administration rights: Eval Licence

    Click Evaluate MDK Professional.

  2. This opens the dialog to install the evaluation license: Eval Licence

    Click OK.

  3. You will be redirected to a web page that contains the same details: Web form

    Click on Submit to send the form. The submission will be acknowledged: Form submitted

  4. After a while, you will receive an email with the license (LIC) for your computer. To install it on your machine, enter the LIC in the field New License ID Code (LIC) of the License Management dialog and click Add LIC.


Licensing User's Guide: Check Out & Check In

Check Out & Check In

If a license is needed away from the network (for example, business trips), you can reserve and Check Out a license for an extended period of time, also referred to as "borrow". The maximum number of days allowed for borrowing a license is 60 days. To check-out a licenses:

  1. Connect the PC to the network. Ensure you have access to the license server.
  2. Open the dialog License Management.
  3. Click the tab Floating License, or FlexNet License.
  4. Click Check Out... and specify for how long to check-out a license.

Checkout Floating-User License Dialog

A checked-out license is removed from the license server at all times during the checkout period and is not available to any other user and becomes node-locked to the PC.

A checked-out license can be returned to the license server at any time using Check In. You need to be connected to a network with access to the license server at this time. The license is freed immediately.

In addition, a FlexNet License has:

  • a linger time of 60 seconds while compiling.
  • full borrowing time while debugging.


Licensing User's Guide: Adapt the FlexNet License File

Adapt the FlexNet License File

Before you can use your license file, you must modify it as follows:

  1. Move the license file to a known location on the C: drive of your server. A suitable place for the license file is the same directory as your floating license server software.
    Note
    The license file must be installed on the C: drive.

  2. The suggested file name is license.dat, and this name is used throughout this document to refer to the license file.

  3. Open a text editor to modify your license.dat file.

    Note

    • Do NOT use Windows Notepad to modify this file because it will remove all carriage return characters (0x0D) from the file and make it unusable to the FlexNet tools. Use Windows Word or Wordpad or any other text editor instead.

  4. Replace this_host in line that starts with SERVER with the corresponding server name.
    Note
    If the host ID in the license file is incorrect or if the server host ID has changed, you must contact to ARM for a new license file. See Rehost a FlexNet License.

  5. Add the IP port number which should be used to communicate with clients after the host ID. We recommend to use the port number 8224.

    For example, if the web-generated license file contained the following line:
    SERVER this_host 001002A34BC5
    and you wanted to use port number 8224 on your floating license server called synchrotron, you must change the line to:
    SERVER synchrotron 001002A34BC5 8224

  6. The FlexNet license server consists of two services, the main service lmgrd.exe and the vendor daemon armlmd.exe. If your server runs a network firewall and you want to open dedicated IP ports for every service, you can define a fixed communication port between lmgrd.exe and armlmd.exe. You can specify this port in the VENDOR line.

    For example, if the web-generated license file contained the following line:
    VENDOR armlmd
    and you want lmgrd.exe and armlmd.exe to communicate over the fixed IP port number 8225, you must change the line to:
    VENDOR armlmd port=8225

  7. Save your edited license file as a plain text file. You can download the original license file from the ARM web licensing portal at any time.

  8. Continue with Start a License Server.


Licensing User's Guide: Install FlexNet Publisher Software

Install FlexNet Publisher Software

Install the FlexNet Publisher software on a machine that acts as a floating license server. Download FlexNet Publisher Software describes the download process.

The software contains:

  • armlmd - the ARM vendor daemon.
  • lmgrd - the FlexNet server daemon
  • lmutil - the FlexNet licensing utilities
  • lmtools.exe - the graphical user interface for FlexNet licensing utilities. This tool is only available on Windows.

Extract the binary files for your matching OS and copy them to a dedicated folder of your license server.

Note

  • In some cases, file servers run protection algorithms (such as Windows Data Execution Protection or DEP) which can prevent binary files from being executed. If your file server blocks unknown files, ensure that the binary files are included in the "allow to execute" list.

On Unix/Linux server, change to your license utilities directory, and type:
sh ./makelinks.sh

Continue with Adapt the FlexNet License File.

Note

  • If the machine is acting only as a license server, then the installation of MDK software is not required.


Licensing User's Guide: Installing a FlexNet License

Installing a FlexNet License

To Activate a FlexNet License:

  1. Install MDK-ARM on the workstation. Administration rights are required.
  2. Connect the workstation to the network in case of a floating license.
  3. For floating licenses you need to obtain the URL from the system administrator. The URL should have the form portNumber@hostServer.

    Ensure the firewall is not blocking the port or application.

  4. For node locked licenses you need to obtain a license file and store it on your machine.

For FlexNet License Setup in µVision

  1. From µVision, open the dialog File — License Management.
  2. Select the tab FlexNet License and click the button Edit to enter the URL (port@host) or select a license file using Select file ....

    License Management Dialog

  3. Click OK.
  4. Enable Use FlexNet. The dialog shows all available product licenses.
  5. Select a product row in the license table and click Set as Active Product to use the license.

  6. License Management Dialog

    • Green record identifies the FlexNet License currently active on your workstation. There can only be one active product at a time.
    • Red records identify FlexNet Licenses that cannot be used. The licenses are all in use by other parties or the FlexNet License Server cannot be accessed.
    • Black records identify available licenses to choose from. Any of these records can be made active (but only one at a time).
    • Gray records show the licenses installed locally.

Once the FlexNet License has been installed, you can Check out (borrow) the license for an extended period.

The button Used By shows a list of users that are working with the selected license.


Licensing User's Guide: Before You Start...

Before You Start...

Before you can use the FlexNet License, you must download, install, configure and start the FlexNet Publisher.

Ensure that you (or an administrator):

  • Verified that the file server has (or can be assigned) a fixed MAC address. FlexNet tools support locking floating licenses only to the network MAC address, and do not support any other hostid mechanisms. To operate a FlexNet Publisher, ensure that the machine has a stable MAC address permanently assigned to it, and that FlexNet utilities can detect the MAC address.
  • Can connect to the chosen file server via Remote Desktop Connection or equivalent program.
  • Have administration privileges to logon to the file server.

Verify this by running the Windows Remote Desktop Connection program (Start - Accessories - Remote Desktop Connection). Enter the name of the file server and your logon credentials. If your logon is not successful, then contact your IT department.

  • The chapters focus on Windows-based operating systems. For other operating system, please read the FNP_LicAdmin.pdf located in the folder root\UV4\FlexNet of your installation.


Licensing User's Guide: Rehost a FlexNet License

Rehost a FlexNet License

To move your license to another machine, you must apply for a Rehost through the Arm Software Licensing portal.

  1. Logon to Rehost Licenses Page. An account is required.

  2. Accept the Disclaimer and the terms of the Rehost Agreement.

  3. You will see a list of serial numbers which are registered to your account. If you own multiple licenses, you can also search for your licenses by entering the Serial Number (PSN) or Host Identifier (MAC address) at the top of the page.

  4. Select the license or licenses you wish to rehost by ticking in the box on the right of the license information. Then, click on the Rehost button. Select a reason for rehosting from the list and click on the Rehost button.

    The system informs you with a message that a new Rehost Request support case has been opened and entered in the License Support Queue. An ARM Support Operator will review your request and will respond with an email indicating your rehost has been successful and instructions on how to obtain your new license file


Licensing User's Guide: Renew a FlexNet License

Renew a FlexNet License

The FlexNet License renewal process is triggered by the sales representatives of the participating companies. As a consequence, you will receive a notification e-mail with a link to generate the new license file.

  1. Click on the link in the e-mail and follow the instructions on the screen.
  2. Click on Renew. This generates the license file. The field Server Host ID cannot be changed, because this is a renewal process.
  3. Click on View to verify the file content.
  4. Click on Save to download the file.
  5. Adapt the FlexNet License File. Verify
    • The host name (or IP address)
    • The Port (default: 8224)
  6. Restart the server.
    NOTE: Your updated license file is not recognized by the FlexNet Publisher until you shutdown and restart FlexNet Publisher.
    • Shut down FlexNet Publisher
    • Restart FlexNet Publisher


Licensing User's Guide: Retrieve a FlexNet License File

Retrieve a FlexNet License File

  1. Logon to Generate Licenses Page. An account is required.

  2. Enter the Personal Serial Number (PSN).

  3. Click Get License.

  4. Select ETHERNET as HostID Type 1 and enter the MAC address of the server which will run the FlexNet Publisher software into the HostID 1 text box. In case the license server has multiple network interfaces, enter only one MAC address. Three MAC addresses are used only when a three (redundant) server license has been purchased.

    The HostID 1 text box only accepts MAC addresses with 12 digits without any embedded dashes or spaces.

    If you are working on the license server or if you are connected to the license server via remote desktop, do the following to find the MAC address:

    In a Windows Command Prompt window, enter ipconfig -all to get the MAC addresses of all installed network interfaces on this server. The MAC address is listed under Physical Address for each network adapter. Be sure to remove the embedded dashes before you copy the MAC address into the HostID 1 text box.
    - or -
    If the FlexNet Publisher software is already installed on the server, run the lmutil lmhostid command to get the MAC address of the server. This command outputs the MAC address in the right format for the HostID 1 text box.

  5. Click Generate.

  6. Click Confirm.

  7. Click Download License to display the license file, then Download to save your license file.

  8. Continue with Download FlexNet Publisher Software.


Licensing User's Guide: Start FlexNet Publisher

Start FlexNet Publisher

The procedure to start a FlexNet Publisher depends on the platform you are using.

NOTE:

  • The lmtools.exe program must be run either directly on the file server desktop or from a client PC using an application such as Windows Remote Desktop. Administration access to the file server is usually required.

Starting a Windows server using lmtools.exe

  1. Start the lmtools.exe program.
  2. On the Server/License File tab, select the Configuration using Services option.

    Configuration using Services

  3. Click the Config Services tab to display the dialog. This example assumes the FlexNet tools were installed in the C:\Flexnet\ folder. Make sure the Path to the lmgrd.exe file is the same as the path where you installed the FlexNet tools. The paths to the license.dat file and the debug.log file do not have to be in the same folder, but you should include the file names and extensions (license.dat, debug.log) as shown in the example.

    Server setup dialog

  4. Enter the paths that specify the required files, or click the browse buttons to locate and select the files. You must specify paths for the:
    • executable file lmgrd.exe.
    • license file license.dat.
    • log file (must first be manually created by you), which is debug.log in this example.
  5. If you require the server software to start running automatically when the server computer is turned on:
    • Enable Use Services.
    • Enable Start Server at Power Up.
  6. Click Save Service.
  7. At the prompt, confirm saving the FlexNet License Manager service.
  8. Click the Start/Stop/Reread tab, and ensure that the FlexNet License Manager service is selected.
  9. Click Start Server to start running the floating license server software.
  10. Check whether the floating license server started successfully:
    • Click the Server Status tab
    • Click Perform Status Enquiry

      The status information shows that the floating license server and vendor daemon are both UP, followed by a licensed feature usage list. Any floating license server errors are shown in the status information.

After you have started the license server, you can use a text editor, such as Notepad, to inspect the server debug log file.

Starting a Windows server from the command line

To start the floating license server on Windows using the command line:

  1. Go to the directory where the floating license server software is installed.
  2. Type:

    lmgrd -c license_file_name -l logfile_name

    Where

    license_file_name | specifies the fully qualified path name of the license file
    logfile_name | specifies the fully qualified path name to a server debug log file. The server log file can become very large, so it might be necessary for you to control its size.

After you have started the floating license server, you can use a text editor, such as Notepad, to inspect the server debug log file.

Starting a Unix/Linux server

To start the floating license server software on a Unix/Linux server:

  1. Go to the directory containing the floating license server software.
  2. Type:

    nohup lmgrd -c license_file_name -l logfile_name

    Where

    license_file_name | Specifies the fully qualified path name of the license file.
    logfile_name | Specifies the fully qualified path name to a server debug log file. The debug log file must be on a local storage device to avoid network problems. The server log file can become very large, so it might be necessary for you to take action to control its size.

    • lmgrd does not require root privileges, ARM recommends that you start the server as a non-privileged user, instead of giving it root privileges.

After you have started the floating license server, you can type, for example:

tail -f logfile_name

to see the most recent output from the floating license server.

For more details on how to start and configure a floating license server on Unix/Linux, see the Flexera Software documentation.

Note

  • If you are adding a new license to a system with a running floating license server, you must
    1. Shut down the server.
    2. Point the server to the new license file.
    3. Restart the server.

    If this is not done, the new license information might not be recognized by the license daemons.

  • ARM does not recommend the use of the lmreread command.


Licensing User's Guide: Shut down a FlexNet Publisher

Shut down a FlexNet Publisher

The shutdown procedure of a FlexNet Publisher depends on the platform you are using.

  • Avoid using the Windows Task Manager, or kill -9 on Unix/Linux, to terminate the server daemons. Processes terminated this way might not end gracefully and can cause problems when restarting the server.
  • If you must forcibly shut down a server, always stop lmgrd before armlmd.

Stopping a Windows license server

Stop a Windows floating license server using the graphical user interface:

  1. Start the lmtools.exe program. Refer to Install FlexNet Publisher Software.
  2. Click the Start/Stop/Reread tab.
  3. Check the Force Server Shutdown checkbox.
  4. Click the Stop Server button to shut down the server.

Stopping a Windows or Unix/Linux license server from the command line

Go to the directory containing the floating license server software. At the command prompt, type:

lmutil lmdown -q -c license_file_name

Where

license_file_name specifies the license file name (with the fully qualified path) that starts the server.


Licensing User's Guide: Download FlexNet Publisher Software

Download FlexNet Publisher Software

  1. Download the FlexNet software licensing utilities that corresponds to your file server hardware and OS from ARM Developer - License Management.
  2. Click Save to store the file on the local machine. Follow instructions on the screen.
  3. Continue with Install FlexNet Publisher Software.


Licensing User's Guide: FlexNet Publisher Setup (Server)

FlexNet Publisher Setup (Server)

The FlexNet Publisher (server) controls the number of license copies of a software product. The FlexNet Publisher can be installed on Windows and Unix/Linux machines. Client machines must be able to access the server over the Local Area Network (LAN).

MDK supports single-server FLexNet floating license installations. You can only use the ARM License Manager to set up single-server floating licenses. A multiple-server floating license configuration must be set up manually.

Steps to set up the server:

  1. Before you start...
  2. Retrieve a FlexNet License File
  3. Download FlexNet Publisher Software
  4. Install FlexNet Publisher Software
  5. Adapt FlexNet License File
  6. Start FlexNet Publisher
  7. Shut down FlexNet Publisher
  8. Rehost FlexNet License
  9. Transfer FlexNet License

See also

  • Renew FlexNet License
  • Licensing Errors
  • Trouble shooting floating license issues
  • Licensing Management
  • FlexNet License Setup (Client)


Licensing User's Guide: Transfer FlexNet License

Transfer FlexNet License

To transfer a FlexNet License do the following:

  1. The new administrator for FlexNet licenses must create an account in developer.arm.com as described in http://www2.keil.com/support/silver.
  2. Send an e-mail to license.support@arm.com with the following information:
    • Serial Number (PSN)
    • Name and email address of current license administrator (if available)
    • Name and email address of the new license administrator
    • The reason for the transfer

    ARM will try to transfer the permission to the new license administrator. The transfer may take some time until finished. You will be informed by e-mail about the transfer.


Licensing User's Guide: Uninstalling a FlexNet License

Uninstalling a FlexNet License

To uninstall a FlexNet License:

  1. Open the dialog File — License Management.
  2. Select the tab FlexNet License.
  3. Disable Use FlexNet.


Licensing User's Guide: FlexNet License Setup (Client)

FlexNet License Setup (Client)

A FlexNet license grants access to software product for multiple users and multiple computers. FlexNet licenses are available for some Keil products.

A FlexNet license overrides all other licensing methods for a product group. For example, if you have installed a Single-User MDK-ARM Professional License and you install a FlexNet MDK-ARM Standard License, then the Single-User MDK-ARM Professional License is disabled and the FlexNet MDK-ARM Standard License enabled.

FlexNet licenses require a host server that provides the license credentials. Ask your system administrator for the FlexNet Server URL.

  • Installing a FlexNet License on the client machine.
  • Uninstalling a FlexNet License from a client machine.

Once the FlexNet license has been set up on the client machine, you can Check out (borrow) the license for an extended period.

  • You cannot directly access MDK product downloads with a FlexNet license. Refer to the knowledgebase article, How to download MDK-ARM with a FlexNet license, to learn how to upgrade.

See also:

  • Licensing Errors
  • Trouble shooting floating license issues
  • Licensing Management
  • FlexNet Publisher Setup (Server)


Licensing User's Guide: Floating License Administrator

Floating License Administrator

The Floating License Administrator is responsible for creating the Floating License File (*.FLF) on a network server. Each workstation that uses the FLF must have access to the server and must use the identical Universal Naming Convention (UNC) path (for example, \\server\share\folder). Each user must have read/write/modify access rights to the FLF file. The file server computer hosting the FLF may not be used as a client workstation.

To create a Floating License File...

  • In uVision, open the dialog File - License Management... and click the Floating License Administrator tab.
  • Enter the path where the Floating License File should be saved. This folder must be a network drive.
  • Enter the PSN of the Floating-User License.
  • Click the button Create FLF....

    License Management Dialog

For a new FLF that replaces the existing FLF...

  • Inform your users to install a new LIC based on the new FLF.
  • In case the new FLF does not overwrite the existing FLF, remove the old FLF after the last user switched to the new FLF.

  • It is impossible to change the path to the Floating License File after the first license has been obtained from the Keil web site.
  • Windows Roaming User Profiles, which include registry copy, are incompatible with Keil Floating Licensing.

Related Links:

  • Licensing Errors
  • Licensing Management


Licensing User's Guide: Floating-User License

Floating-User License

A Floating-User License allows users to use a Keil software product on multiple computers. Floating-User Licenses are available for most Keil products.

Floating-User Licenses require a file server that hosts a Floating-License-File (*.FLF). The system administrator has to create the file through the dialog Floating License Administrator prior to using the product. The file server computer hosting the FLF may not be used as a client workstation.

For PK51, PK166, and PK251 toolchains, licenses are lingered for one hour. For MDK Editions, the one hour linger time gets reset at the end of a build or debug session.

After the Keil software has been installed, license the product by registering your CID and Floating License Code on the Keil website.

  • Installing or Adding a LIC explains the licensing procedure.

Once you have installed a Floating-User License on a workstation you may:

  • Check out and check in licenses for an extended period.
  • Review the list of active license users.

  • Licensing Errors
  • Licensing Management


Licensing User's Guide: Check Out & Check In

Check Out & Check In

If a license is needed away from the network (for example, business trips), you can reserve and Check Out a license for an extended period of time, also referred to as "borrow". The maximum number of days allowed for borrowing a license is 60 days. To check-out a licenses:

  1. Connect the PC to the network. Ensure you have access to the license server.
  2. Open the dialog License Management.
  3. Click the tab Floating License, or FlexNet License.
  4. Click Check Out... and specify for how long to check-out a license.

Checkout Floating-User License Dialog

A checked-out license is removed from the license server at all times during the checkout period and is not available to any other user and becomes node-locked to the PC.

A checked-out license can be returned to the license server at any time using Check In. You need to be connected to a network with access to the license server at this time. The license is freed immediately.

In addition, FlexNet licenses have:

  • a linger time of 60 seconds while compiling.
  • full borrowing time while debugging.


Licensing User's Guide: Installing a LIC

Installing a LIC

To Activate a Floating-User License, You Must...

  1. Install the software product on the workstation. Administration rights are required.
  2. Obtain a LIC to activate the license.

For Computers Connected to the Internet...

  1. Login with an account that has administration rights.
  2. Right-click the µVision icon and select Run as Administrator... from the context menu.
  3. Open the dialog File — License Management and select the tab Floating-User License.
  4. Click Add Product... and enter the path to the Floating License File (*.FLF). This opens the License Management page on the Keil web site.
  5. Enter your contact information and click on the Submit button.
  6. Within a few minutes you will receive a License ID Code (LIC) via an automated e-mail process. Activate your software product, by entering the LIC in the field New License ID Code (LIC) and clicking Add LIC.

    License Management Dialog

For Computers Not Connected to the Internet...

For computers with no Internet connection, use another computer to visit the Keil web page http://www.keil.com/license/floating.htm. The Floating License ID (FLI) and Computer ID Number (CID) must be obtained from the computer that will run the license:

  1. Open the µVision dialog File - License Management - Floating License.
  2. Click Add Product. Find the floating-license file, select it, and click Open to obtain the FLI and CID information for that computer.
  3. Visit the webpage from the computer that is connected to the internet and enter the information.
  4. Within a few minutes you will receive a License ID Code (LIC) via an automated e-mail process. Activate the software product, by entering the LIC in the field New License ID Code (LIC) and clicking Add LIC.

Note

  • If you do not know the location of the Floating License File (*.FLF), contact your License Administrator.
  • Do not change any Network Connection on your computer during the registration process. The CID encodes various parameters including network adapter information. After product activation, the network adapter can change, as it is the case on portable Notebooks with various network connections.
  • The CID encodes several computer parameters including a time information. Therefore the CID changes daily. However, you may install a LIC at any time, provided the same Network Connection is active.


Licensing User's Guide: Current Users

Current Users

The Used By... button on the Floating-User License tab of the License Management dialog displays a list of users who have checked out a floating license.

Current License Users Dialog

User names printed in black have their Checked Out Until date set in the future and are currently consuming a license. User names printed in gray have their Checked Out Until date in the past and are not active.


Licensing User's Guide: License Agreement Arm FuSa RTS

License Agreement Arm FuSa RTS

This page provides references to Arm FuSa RTS license terms:

  • License Agreement for Arm FuSa RTS v1.0.1


Licensing User's Guide: License Management

License Management

The License Management dialog allows you to license Keil software products. After the installation, you must license that product by registering your CID and PSN on the Keil website. You will be notified via an automated e-mail containing a LIC. Enter the LIC into the License Management dialog (refer to Terminology for abbreviations).

The software can be licensed as:

  • Single-User License
    Register software products for a single user on one workstation.
  • Floating-User License
    Register software products for multiple users on multiple workstations.
  • Floating License Administrator
    Manage Floating-User Licenses.
  • FlexNet License Setup (Client)
    Install the FlexNet License on your machine.
  • FlexNet Publisher Setup (Server)
    Install the FlexNet licensing server.
  • MDK Professional Evaluation
    Evaluate the MDK Professional Edition for 30 days.

Open the License Management dialog via the µVision menu File - License Management.

Note

  • To install or remove a LIC on PCs running Windows Vista or Windows 7, you must start µVision with administration rights. Right-click the µVision icon and select Run as Administrator.


Licensing User's Guide: Redistributables

Redistributables

================================================================================
This file lists the portions of this release of 'Arm Run-Time System for
functional safety applications (Arm FuSa RTS)' that you are permitted to
redistribute and any terms and conditions applicable to such redistribution.
Refer to the End User License Agreement that accompanies this release of 'Arm
FuSa RTS' for terms and conditions relating to permitted redistribution and
'Redistributables'. Any modification or redistribution of files covered by
open-source licenses, whether listed here or not, is subject to the terms of
the applicable open-source license.
================================================================================

1) FuSa RTS Software components:
Redistribution permitted only in object code form and only as part of Software
Applications developed by you or your permitted users. If you choose to
redistribute the whole or any part of FuSa RTS Software component, you agree:
(a) to ensure that they are licensed for use only as part of Software
Applications and only for execution on microprocessors manufactured or
simulated under licence from Arm; (b) not to use Arm's or any of its licensors
names, logos or trademarks to market Software Applications; (c) to include
valid copyright notices on Software Applications, and preserve any copyright
notices which are included with, or in, the Example Code; and (d) to ensure
that any further redistribution is limited to redistribution by either or both
your customers and your authorised distributors as part of Software
Applications and that your customers and your authorised distributors comply
with these terms.

FuSa RTS Software components can be found in your FuSa RTS pack
installation/extraction location:

- FuSa CMSIS-Core:     <install_dir>\CMSIS\core
- FuSa RTX:            <install_dir>\CMSIS\RTOS2
- FuSa Event Recorder: <install_dir>\ArmCompiler
- FuSa C Libraries:    <install_dir>\FuSaCLibs

----------------------------------------------------------------------
2) Example Code: Redistribution permitted only in object code form and only as
part of Software Applications developed by you or your permitted users. If you
choose to redistribute the whole or any part of Example Code, you agree: (a)
to ensure that they are licensed for use only as part of Software Applications
and only for execution on microprocessors manufactured or simulated under
licence from Arm; (b) not to use Arm's or any of its licensors names, logos or
trademarks to market Software Applications; (c) to include valid copyright
notices on Software Applications, and preserve any copyright notices which are
included with, or in, the Example Code; and (d) to ensure that any further
redistribution is limited to redistribution by either or both your customers
and your authorised distributors as part of Software Applications and that
your customers and your authorised distributors comply with these terms.

Example code found in the software packs in the directory:
<install_dir>\Examples.

----------------------------------------------------------------------
END OF FILE: redistributables.txt


Licensing User's Guide: Redistributables

Redistributables

================================================================================
This file lists the portions of this release of 'Arm FuSa RTS Safety Package'
that you are permitted to redistribute and any terms and conditions applicable
to such redistribution. Refer to the End User License Agreement that
accompanies this release of 'Arm FuSa RTS Safety Package' for terms and
conditions relating to permitted redistribution and 'Redistributables'. Any
modification or redistribution of files covered by open-source licenses,
whether listed here or not, is subject to the terms of the applicable
open-source license.
================================================================================

Unless otherwise provided herein, all capitalised terms set out below shall
have the meaning given to them in the License Agreement.

Subject to the provisions of clause 7.2 of the License Agreement, you are
permitted to disclose the Arm Documentation in the 'Arm FuSa RTS Safety
Package' to a competent auditor of functional safety standard compliance only
in relation to certification of Your Software or Your Hardware in respect of
such compliance. Except as expressly set out herein, you are not permitted to
disclose or otherwise redistribute the whole or any part of the 'Arm FuSa
Safety Package'.

----------------------------------------------------------------------
END OF FILE: redistributables.txt


Licensing User's Guide: Redistributables

Redistributables

===============================================================================
This file lists the portions of this release of 'Keil MDK' that
you are permitted to redistribute and any terms and conditions applicable to
such redistribution. Refer to the End User License Agreement that accompanies
this release of 'Keil MDK' for terms and conditions relating to
permitted redistribution and 'Redistributables'. Any modification or
redistribution of files covered by open-source licenses, whether listed here
or not, is subject to the terms of the applicable open-source license.
===============================================================================

1) Target Libraries(libraries and helper libraries): Redistribution permitted
only in object code form, compiled and linked by Arm Compiler in to Software
Applications developed by you or your permitted users, provided that Software
Applications contain substantial additional functionality. If you choose to
redistribute the whole or any part of Target Libraries, you agree: (a) to
ensure that they are licensed for use only as part of Software Applications
and only for execution on microprocessors manufactured or simulated under
licence from Arm; (b) not to use Arm's or any of its licensors names, logos or
trademarks to market Software Applications; (c) to include valid copyright
notices on Software Applications, and preserve any copyright notices which are
included with, or in, the Target Libraries; and (d) to ensure that any further
redistribution is limited to redistribution by either or both your customers
and your authorised distributors as part of Software Applications and that
your customers and your authorised distributors comply with these terms.

Details of the Target Libraries and their location in your installation:
a) Libraries: C libraries; ABI libraries; Standard C++ libraries; C++ runtime
support libraries; Maths libraries; Software floating-point libraries; VFP
support found in your installation in armlib and libcxx subdirectories at
at <install_dir>\ARM\<Arm_Compiler_toolchain_name>\lib

b) Helper libraries: Arm Compiler helper libraries found in your installation
at <install_dir>\ARM\<Arm_Compiler_toolchain_name>\lib\armlib\h_*

---------------------------------------------------------------------
2) Example Code: Redistribution permitted only in object code form and only as
part of Software Applications developed by you or your permitted users.
If you choose to redistribute the whole or any part of Example Code, you agree: (a)
to ensure that they are licensed for use only as part of Software Applications
and only for execution on microprocessors manufactured or simulated under
licence from Arm; (b) not to use Arm's or any of its licensors names, logos or
trademarks to market Software Applications; (c) to include valid copyright
notices on Software Applications, and preserve any copyright notices which are
included with, or in, the Example Code; and (d) to ensure that any further
redistribution is limited to redistribution by either or both your customers
and your authorised distributors as part of Software Applications and that
your customers and your authorised distributors comply with these terms.

Example code found in the software packs in the default directory at
<install_dir>\ARM\Pack\Keil or the pack directory selected during installation.

-------------------------------------------------------------------------
3) Middleware: Redistribution permitted only in object code form and only as
part of Software Applications developed by you or your permitted users,
provided that Software Applications contain substantial additional functionality.
If you choose to redistribute the whole or any part of Middleware, you agree: (a)
to ensure that they are licensed for use only as part of Software Applications
and only for execution on microprocessors manufactured or simulated under
licence from Arm; (b) not to use Arm's or any of its licensors names, logos or
trademarks to market Software Applications; (c) to include valid copyright
notices on Software Applications, and preserve any copyright notices which are
included with, or in, the Middleware; and (d) to ensure that any further
redistribution is limited to redistribution by either or both your customers
and your authorised distributors as part of Software Applications and that
your customers and your authorised distributors comply with these terms.

---------------------------------------------------------------------
END OF FILE: redistributables.txt


Licensing User's Guide: Redistributables

Redistributables

===============================================================================
This file lists the portions of this release of 'Keil MDK' that
you are permitted to redistribute and any terms and conditions applicable to
such redistribution. Refer to the End User License Agreement that accompanies
this release of 'Keil MDK' for terms and conditions relating to
permitted redistribution and 'Redistributables'. Any modification or
redistribution of files covered by open-source licenses, whether listed here
or not, is subject to the terms of the applicable open-source license.
===============================================================================

1) Target Libraries(libraries and helper libraries): Redistribution permitted
only in object code form, compiled and linked by Arm Compiler in to Software
Applications developed by you or your permitted users, provided that Software
Applications contain substantial additional functionality. If you choose to
redistribute the whole or any part of Target Libraries, you agree: (a) to
ensure that they are licensed for use only as part of Software Applications
and only for execution on microprocessors manufactured or simulated under
licence from Arm; (b) not to use Arm's or any of its licensors names, logos or
trademarks to market Software Applications; (c) to include valid copyright
notices on Software Applications, and preserve any copyright notices which are
included with, or in, the Target Libraries; and (d) to ensure that any further
redistribution is limited to redistribution by either or both your customers
and your authorised distributors as part of Software Applications and that
your customers and your authorised distributors comply with these terms.

Details of the Target Libraries and their location in your installation:
a) Libraries: C libraries; ABI libraries; Standard C++ libraries; C++ runtime
support libraries; Maths libraries; Software floating-point libraries; VFP
support found in your installation in armlib and libcxx subdirectories at
at <install_dir>\ARM\<Arm_Compiler_toolchain_name>\lib

b) Helper libraries: Arm Compiler helper libraries found in your installation
at <install_dir>\ARM\<Arm_Compiler_toolchain_name>\lib\armlib\h_*

---------------------------------------------------------------------
2) Example Code: Redistribution permitted only in object code form and only as
part of Software Applications developed by you or your permitted users. If you
choose to redistribute the whole or any part of Example Code, you agree: (a)
to ensure that they are licensed for use only as part of Software Applications
and only for execution on microprocessors manufactured or simulated under
licence from Arm; (b) not to use Arm's or any of its licensors names, logos or
trademarks to market Software Applications; (c) to include valid copyright
notices on Software Applications, and preserve any copyright notices which are
included with, or in, the Example Code; and (d) to ensure that any further
redistribution is limited to redistribution by either or both your customers
and your authorised distributors as part of Software Applications and that
your customers and your authorised distributors comply with these terms.

Example code found in the software packs in the default directory at
<install_dir>\ARM\Pack\Keil or the pack directory selected during installation.

-------------------------------------------------------------------------
3) Middleware: Redistribution permitted only in object code form and only as
part of Software Applications developed by you or your permitted users,
provided that Software Applications contain substantial additional functionality.
If you choose to redistribute the whole or any part of Middleware, you agree: (a)
to ensure that they are licensed for use only as part of Software Applications
and only for execution on microprocessors manufactured or simulated under
licence from Arm; (b) not to use Arm's or any of its licensors names, logos or
trademarks to market Software Applications; (c) to include valid copyright
notices on Software Applications, and preserve any copyright notices which are
included with, or in, the Middleware; and (d) to ensure that any further
redistribution is limited to redistribution by either or both your customers
and your authorised distributors as part of Software Applications and that
your customers and your authorised distributors comply with these terms.
-------------------------------------------------------------------------

4) uVision IDE project file extensions *.uvprojx, *.uvoptx, and *.uvguix:
Redistribution permitted only as part of Software Applications developed by
you or your permitted users, provided that Software Applications contain
substantial additional functionality. If you choose to redistribute uVision
IDE project files, you agree: (a) to ensure that they are licensed for use
only as part of Software Applications and only for execution on
microprocessors manufactured or simulated under licence from Arm; (b) not to
use Arm's or any of its licensors names, logos or trademarks to market
Software Applications; (c) to include valid copyright notices on Software
Applications, and preserve any copyright notices which are included with, or
in, the Example Code; and (d) to ensure that any further redistribution is
limited to redistribution by either or both your customers and your authorised
distributors as part of Software Applications and that your customers and your
authorised distributors comply with these terms.
---------------------------------------------------------------------
END OF FILE: redistributables.txt


Licensing User's Guide: Single-User License

Single-User License

A Single-User License allows exactly one person to use a Keil product on a maximum of two computers. Single-User Licenses are available for all Keil Software products.

Two licensing operations may be performed with a Single-User License:

  • Installing or Adding a LIC
  • Uninstalling a LIC

  • Licensing Errors
  • Licensing Management


Licensing User's Guide: Installing a LIC

Installing a LIC

To Activate a Single-User License:

  1. Install the software product on the workstation. Administration rights are required.
  2. Obtain a LIC to activate the Single-User License.

Obtain a LIC for Computers Connected to the Internet...

  1. Login with an account that has administration rights.
  2. Right-click the µVision icon and select Run as Administrator... from the context menu.
  3. Open the dialog File — License Management... and select the Single-User License tab.
  4. Click the button Get LIC via Internet..., then click the button OK to register the product. This action opens the License Management page on the Keil web site.
  5. Enter the Product Serial Number (PSN) for the Single-User License along with your contact information and click the button Submit. An e-mail is sent back with the License ID Code (LIC) within a few minutes.
  6. To activate the Software Product, enter the LIC in the field New License ID Code (LIC) of the dialog License Management... and click Add LIC.

    License Management Dialog

Obtain a LIC for Computers Not Connected to the Internet...

On the Computer without internet:

  1. Login with an account that has administration rights.
  2. Right-click the µVision icon and select Run as Administrator... from the context menu.
  3. In the Keil µVision IDE go to File -> License Management - the License Management dialog opens. The CID is on the top right corner.

  4. Copy down the the Computer ID (CID) of the target computer where the license will be installed.
  5. On the Computer with internet: Open http://www.keil.com/license/install.htm
  6. Enter the Product Serial Number (PSN) for the Single-User License along with your contact information and click the button Submit. An e-mail is sent back with the License ID Code (LIC) within a few minutes.
  7. Copy down the LIC from the email. Add it to the target computer.

Note

  • Owners of a dongle-protected node-locked (Single-User) license must download and install the Sentinel Dongle Driver. Verify your dongle with the Dongle Testing Application. Additional information is available at LICENSE: Usage of a LPT-Dongle protected product.
  • Compatible product versions can be licensed with the same LIC on the same machine. The versions must be installed in different root folders. In this case, uninstall previous LICs and request a new LIC with the latest PSN and the latest software version. Then, the new LIC can be used to activate all versions that you want to use.
  • If the PSN is missing, contact the Keil Software Sales Department or the local Keil Software Distributor.
  • Do not change any Network Connection on the target computer during the registration process. The CID encodes various parameters including network adapter information. After product activation, the network adapter may change as it is the case on Notebooks with various network connections.
  • The CID encodes several computer parameters including a time stamp. This causes the CID to change daily. However, a LIC can be installed at any time, provided that the same Network Connection is active.


Licensing User's Guide: Uninstalling a LIC

Uninstalling a LIC

Administration rights are required to uninstall a Single-User License. Then, you may transfer the license to a different computer.

For Computers Connected to the Internet...

  1. In µVision, open the Single-User License page of the File — License Management... dialog.
  2. Select the product you want to uninstall from the list.
  3. Click on the Uninstall... button and select Yes to the prompt.

    License Management Dialog
  4. Your original license ID code (LIC) has been replaced by an Uninstall License ID Code starting with TRN. µVision opens a webpage on the Keil website and automatically enters this TRN number.
  5. You must click on the Submit button to finalize the uninstall process.

For Computers Not Connected to the Internet...

  1. In µVision, open the Single-User License page of the File — License Management... dialog.
  2. Select the product you want to uninstall from the list.
  3. Click on the Uninstall... button and select Yes to the prompt.
  4. Write down the Uninstall License ID Code starting with TRN from the License Management dialog as shown in the figure.

    License Management Dialog
  5. Visit the following web page (on a computer with internet access)
    http://www.keil.com/license/uninstall.htm
    and enter the Uninstall License ID Code that starts with TRN.
  6. You must click on the Submit button to finalize the uninstall process.

Note

  • After uninstalling a license, you may obtain a new LIC on a different computer for the software product.


Licensing User's Guide: Supplementary Terms

Supplementary Terms

================================================================================
This file contains details of any applicable specific extensions, limitations
or other variations to the terms of the End User License Agreement that
accompanies this release of 'Arm Run-Time System for functional
safety applications (Arm FuSa RTS)'.
================================================================================

1) Arm Compiler 6.6 C Library for Functional Safety is licensed for use only
with safety qualified releases of Arm Compiler 6.6.

2) Your use of Arm FuSa RTS may be restricted to use only in relation to a
Specified Project (as defined in the License Agreement) and/or use only on
or with specified items of Arm-based hardware. Any such restrictions will be
set out in the order documentation provided to you by Arm.

----------------------------------------------------------------------
END OF FILE: supplementary_terms.txt


Licensing User's Guide: Supplementary Terms

Supplementary Terms

================================================================================
This file contains details of any applicable specific extensions, limitations
or other variations to the terms of the End User License Agreement that
accompanies this release of 'Arm FuSa RTS Safety Package'.
================================================================================

1) 'Arm FuSa RTS Safety Package' is provided as part of 'Arm Run-Time System for
functional safety applications (Arm FuSa RTS)' product and can be used only for the same
Specified Project.

----------------------------------------------------------------------
END OF FILE: supplementary_terms.txt


Licensing User's Guide: Supplementary Terms

Supplementary Terms

===============================================================================
This file contains details of any applicable specific extensions, limitations
or other variations to the terms of the End User License Agreement that
accompanies this release of 'Keil MDK'.
===============================================================================
MDK-SPECIFIC DEFINITIONS:

“MDK-Plus Middleware” means all of the following software components in object
code form: (a) IPv4 networking suite; (b) USB device; (c) Flash (flash file system);
d) GUI emWin.

“MDK-Professional Middleware” means all of the following software components
in object code form: (a) IPv4 and IPv6 networking suite; (b) USB host and device;
(c) Flash (flash file system); (d) GUI emWin; and (e) any other middleware software
components delivered by ARM as part of the MDK Professional edition software package,
and found in your installation at <install base>\ARM\PACK\Keil\MDK-Middleware.

“Middleware” means either or both of the MDK-Plus Middleware and MDK-Professional
Middleware, as applicable.

---------------------------------------------------------------------
MIDDLEWARE:

Use of Middleware is granted per licensed Seat of MDK-Plus or MDK-Pro edition.

You acknowledge and agree that you shall not use the MDK-Plus Middleware or
MDK-Professional Middleware (as applicable) unless you have licensed either
MDK-Plus edition or MDK-Professional edition respectively.

The FlashFS libraries FS_ARM_L.lib, FS_ARM_B.lib, FS_CM1.lib, FS_CM3.lib,
FS_LFN_CM0_B.lib, FS_LFN_CM0_L.lib, FS_LFN_CM3_B.lib and FS_LFN_CM3_L.lib include
source code that is capable of supporting a file system with long filenames in
Software Applications that you develop. You warrant to ARM that unless you have
first obtained a licence from Microsoft for its FAT file system with long filename
support then you will not develop or distribute Software Applications that include
a file system with long filenames see
https://www.microsoft.com/en-us/legal/intellectualproperty/mtl/technologylicensing.aspx
for more details). As an alternative, the libraries FSN_ARM_L.lib, FSN_ARM_B.lib,
FSN_CM1.lib, FSN_CM3.lib, FS_SFN_CM0_B.lib, FS_SFN_CM0_L.lib, FS_SFN_CM3_B.lib
and FS_SFN_CM3_L.lib are not capable of supporting a file system with long filenames
and are licensed to you as part of the Arm Software provided under this Licence.

----------------------------------------------------------------------
END OF FILE: supplementary_terms.txt


Licensing User's Guide: Supplementary Terms

Supplementary Terms

===============================================================================
This file contains details of any applicable specific extensions, limitations
or other variations to the terms of the End User License Agreement that
accompanies this release of 'Keil MDK'.
===============================================================================
MDK-SPECIFIC DEFINITIONS:

“MDK-Plus Middleware” means all of the following software components in object
code form: (a) IPv4 networking suite; (b) USB device; (c) Flash (flash file
system); d) GUI emWin.

“MDK-Professional Middleware” means all of the following software components
in object code form: (a) IPv4 and IPv6 networking suite; (b) USB host and
device; (c) Flash (flash file system); (d) GUI emWin; and (e) any other
middleware software components delivered by ARM as part of the MDK Professional
edition software package, and found in your installation at
<install base>\ARM\PACK\Keil\MDK-Middleware.

“Middleware” means either or both of the MDK-Plus Middleware and
MDK-Professional Middleware, as applicable.

---------------------------------------------------------------------
MIDDLEWARE:

Use of Middleware is granted per licensed Seat of MDK-Plus or MDK-Pro edition.

You acknowledge and agree that you shall not use the MDK-Plus Middleware or
MDK-Professional Middleware (as applicable) unless you have licensed either
MDK-Plus edition or MDK-Professional edition respectively.
----------------------------------------------------------------------
END OF FILE: supplementary_terms.txt


Licensing User's Guide: Terminology

Terminology

You will encounter the following terms as you install and license Keil products:

For Keil Licenses

  • CID (Computer ID)
    A 10-character alphanumeric (XXXXX-XXXXX) ID that uniquely identifies a computer, and is automatically generated daily. Find the CID in the µVision IDE under File — License Management... dialog.
    Generating a LIC (for product activation) requires a valid PSN and CID.
  • PSN (Product Serial Number)
    A 15-character alphanumeric value (XXXXX-XXXXX-XXXXX) that contains the product information and support expiration date. A PSN is delivered at the time of purchase of a Keil product.
    Generating a LIC (for product activation) requires a valid PSN and CID.
  • LIC (License ID Code)
    A 30-character alphanumeric value used to activate a Keil product for one particular computer. Register online using a CID and valid PSN to obtain a LIC.

For Keil Floating Licenses

  • FLI (Floating License ID)
    Contains the product information embedded in the FLF. Submit the FLI to the licensing website to receive a LIC.
  • FLF (Floating License File)
    A user-generated file on a network server that contains the product information and maintains license usage. This file cannot be moved or recreated.
  • UNC (Universal Naming Convention)
    UNC is a machine-independent file naming convention. For example, the UNC path for a floating-license file named keilfloat.FLF on a shared folder named flic on a computer named serv1 is: \\serv1\flic\keilfloat.FLF.

For Flexara Flexnet Licenses

  • FlexNet
    Software licensing utilities provided by Arm are programs that allow you to install and manage Arm licenses.
  • license.dat
    The FlexNet License file. Generated from the Arm licensing website that contains the product information and HostID of the server.
  • FlexNet Publisher
    The tools to set up a licensing server.
  • lmtools.exe
    The graphical user interface for FlexNet licensing utilities (only available on Windows).
  • lmgrd.exe
    The FlexNet server daemon running on the license server.
  • armlmd.exe
    The Arm-specific vendor daemon on the license server
  • lmutil
    The FlexNet licensing utilities; used for troubleshooting and checking the status of the license server.
  • URL; Flex-URL (Uniform Resource Locator)
    The URL to the server that hosts the Flex License. This URL is required when using a Flexera Software licensing solution. The URL should have the form portNumber@serverName.


Licensing User's Guide: Third Party Licenses

Third Party Licenses

===============================================================================
This file lists the package level copyright and license information for third
party software included in this release of 'Arm Run-Time System for functional
safety applications (Arm FuSa RTS)'. Refer to the End User License Agreement
that accompanies this release of 'Arm FuSa RTS' for terms and conditions
relating to your use of such third party software.

The information is grouped into two sections. The first section lists out
details of third party software projects, including names of the applicable
licenses as per the SPDX format (http://spdx.org/licenses). The second section
includes the full license text of all applicable licenses referenced in the
first section.
===============================================================================

SECTION 1: THIRD PARTY SOFTWARE PROJECTS
===============================================================================

Project:      CMSIS-Core(Cortex-M) v5.2.1 (part of CMSIS v5.5.1)
Summary:      Cortex Microcontroller Software Interface Standard (CMSIS).
Home-page:    https://arm-software.github.io/CMSIS_5/Core/html/index.html
              https://github.com/ARM-software/CMSIS_5/tree/5.5.1/CMSIS/Core
License(s):   Apache License 2.0 (Apache-2.0). See later section for a copy of
              license text.
Copyright(s): Copyright (C) 1999-2019 Arm Limited. All rights reserved.
              Copyright (c) 2017-2018 IAR Systems.
---------------------------------------------------------------------

Project:      fdlibm
Summary:      Maths library.
Home-page:    http://www.netlib.org/fdlibm/
License(s):   MIT License (MIT). See later section for a copy of license text.
Copyright(s): Copyright (C) 1993 by Sun Microsystems, Inc. All rights reserved.

===============================================================================

SECTION 2: APPLICABLE LICENSES
===============================================================================

1) License text for 'CMSIS-Core(Cortex-M)' (Apache-2.0):

                                 Apache License
                           Version 2.0, January 2004
                        http://www.apache.org/licenses/

   TERMS AND CONDITIONS FOR USE, REPRODUCTION, AND DISTRIBUTION

   1. Definitions.

      "License" shall mean the terms and conditions for use, reproduction,
      and distribution as defined by Sections 1 through 9 of this document.

      "Licensor" shall mean the copyright owner or entity authorized by
      the copyright owner that is granting the License.

      "Legal Entity" shall mean the union of the acting entity and all
      other entities that control, are controlled by, or are under common
      control with that entity. For the purposes of this definition,
      "control" means (i) the power, direct or indirect, to cause the
      direction or management of such entity, whether by contract or
      otherwise, or (ii) ownership of fifty percent (50%) or more of the
      outstanding shares, or (iii) beneficial ownership of such entity.

      "You" (or "Your") shall mean an individual or Legal Entity
      exercising permissions granted by this License.

      "Source" form shall mean the preferred form for making modifications,
      including but not limited to software source code, documentation
      source, and configuration files.

      "Object" form shall mean any form resulting from mechanical
      transformation or translation of a Source form, including but
      not limited to compiled object code, generated documentation,
      and conversions to other media types.

      "Work" shall mean the work of authorship, whether in Source or
      Object form, made available under the License, as indicated by a
      copyright notice that is included in or attached to the work
      (an example is provided in the Appendix below).

      "Derivative Works" shall mean any work, whether in Source or Object
      form, that is based on (or derived from) the Work and for which the
      editorial revisions, annotations, elaborations, or other modifications
      represent, as a whole, an original work of authorship. For the purposes
      of this License, Derivative Works shall not include works that remain
      separable from, or merely link (or bind by name) to the interfaces of,
      the Work and Derivative Works thereof.

      "Contribution" shall mean any work of authorship, including
      the original version of the Work and any modifications or additions
      to that Work or Derivative Works thereof, that is intentionally
      submitted to Licensor for inclusion in the Work by the copyright owner
      or by an individual or Legal Entity authorized to submit on behalf of
      the copyright owner. For the purposes of this definition, "submitted"
      means any form of electronic, verbal, or written communication sent
      to the Licensor or its representatives, including but not limited to
      communication on electronic mailing lists, source code control systems,
      and issue tracking systems that are managed by, or on behalf of, the
      Licensor for the purpose of discussing and improving the Work, but
      excluding communication that is conspicuously marked or otherwise
      designated in writing by the copyright owner as "Not a Contribution."

      "Contributor" shall mean Licensor and any individual or Legal Entity
      on behalf of whom a Contribution has been received by Licensor and
      subsequently incorporated within the Work.

   2. Grant of Copyright License. Subject to the terms and conditions of
      this License, each Contributor hereby grants to You a perpetual,
      worldwide, non-exclusive, no-charge, royalty-free, irrevocable
      copyright license to reproduce, prepare Derivative Works of,
      publicly display, publicly perform, sublicense, and distribute the
      Work and such Derivative Works in Source or Object form.

   3. Grant of Patent License. Subject to the terms and conditions of
      this License, each Contributor hereby grants to You a perpetual,
      worldwide, non-exclusive, no-charge, royalty-free, irrevocable
      (except as stated in this section) patent license to make, have made,
      use, offer to sell, sell, import, and otherwise transfer the Work,
      where such license applies only to those patent claims licensable
      by such Contributor that are necessarily infringed by their
      Contribution(s) alone or by combination of their Contribution(s)
      with the Work to which such Contribution(s) was submitted. If You
      institute patent litigation against any entity (including a
      cross-claim or counterclaim in a lawsuit) alleging that the Work
      or a Contribution incorporated within the Work constitutes direct
      or contributory patent infringement, then any patent licenses
      granted to You under this License for that Work shall terminate
      as of the date such litigation is filed.

   4. Redistribution. You may reproduce and distribute copies of the
      Work or Derivative Works thereof in any medium, with or without
      modifications, and in Source or Object form, provided that You
      meet the following conditions:

      (a) You must give any other recipients of the Work or
          Derivative Works a copy of this License; and

      (b) You must cause any modified files to carry prominent notices
          stating that You changed the files; and

      (c) You must retain, in the Source form of any Derivative Works
          that You distribute, all copyright, patent, trademark, and
          attribution notices from the Source form of the Work,
          excluding those notices that do not pertain to any part of
          the Derivative Works; and

      (d) If the Work includes a "NOTICE" text file as part of its
          distribution, then any Derivative Works that You distribute must
          include a readable copy of the attribution notices contained
          within such NOTICE file, excluding those notices that do not
          pertain to any part of the Derivative Works, in at least one
          of the following places: within a NOTICE text file distributed
          as part of the Derivative Works; within the Source form or
          documentation, if provided along with the Derivative Works; or,
          within a display generated by the Derivative Works, if and
          wherever such third-party notices normally appear. The contents
          of the NOTICE file are for informational purposes only and
          do not modify the License. You may add Your own attribution
          notices within Derivative Works that You distribute, alongside
          or as an addendum to the NOTICE text from the Work, provided
          that such additional attribution notices cannot be construed
          as modifying the License.

      You may add Your own copyright statement to Your modifications and
      may provide additional or different license terms and conditions
      for use, reproduction, or distribution of Your modifications, or
      for any such Derivative Works as a whole, provided Your use,
      reproduction, and distribution of the Work otherwise complies with
      the conditions stated in this License.

   5. Submission of Contributions. Unless You explicitly state otherwise,
      any Contribution intentionally submitted for inclusion in the Work
      by You to the Licensor shall be under the terms and conditions of
      this License, without any additional terms or conditions.
      Notwithstanding the above, nothing herein shall supersede or modify
      the terms of any separate license agreement you may have executed
      with Licensor regarding such Contributions.

   6. Trademarks. This License does not grant permission to use the trade
      names, trademarks, service marks, or product names of the Licensor,
      except as required for reasonable and customary use in describing the
      origin of the Work and reproducing the content of the NOTICE file.

   7. Disclaimer of Warranty. Unless required by applicable law or
      agreed to in writing, Licensor provides the Work (and each
      Contributor provides its Contributions) on an "AS IS" BASIS,
      WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or
      implied, including, without limitation, any warranties or conditions
      of TITLE, NON-INFRINGEMENT, MERCHANTABILITY, or FITNESS FOR A
      PARTICULAR PURPOSE. You are solely responsible for determining the
      appropriateness of using or redistributing the Work and assume any
      risks associated with Your exercise of permissions under this License.

   8. Limitation of Liability. In no event and under no legal theory,
      whether in tort (including negligence), contract, or otherwise,
      unless required by applicable law (such as deliberate and grossly
      negligent acts) or agreed to in writing, shall any Contributor be
      liable to You for damages, including any direct, indirect, special,
      incidental, or consequential damages of any character arising as a
      result of this License or out of the use or inability to use the
      Work (including but not limited to damages for loss of goodwill,
      work stoppage, computer failure or malfunction, or any and all
      other commercial damages or losses), even if such Contributor
      has been advised of the possibility of such damages.

   9. Accepting Warranty or Additional Liability. While redistributing
      the Work or Derivative Works thereof, You may choose to offer,
      and charge a fee for, acceptance of support, warranty, indemnity,
      or other liability obligations and/or rights consistent with this
      License. However, in accepting such obligations, You may act only
      on Your own behalf and on Your sole responsibility, not on behalf
      of any other Contributor, and only if You agree to indemnify,
      defend, and hold each Contributor harmless for any liability
      incurred by, or claims asserted against, such Contributor by reason
      of your accepting any such warranty or additional liability.

   END OF TERMS AND CONDITIONS
===============================================================================

2) License text for 'fdlibm' (MIT):

Developed at SunSoft, a Sun Microsystems, Inc. business.
Permission to use, copy, modify, and distribute this software is freely granted,
provided that this notice is preserved.

================================================================================
END OF FILE: third_party_licenses.txt


Licensing User's Guide: Third Party Licenses

Third Party Licenses

===============================================================================
This file lists the package level copyright and license information for third
party software included in this release of 'Arm FuSa RTS Safety Package'.
Refer to the End User License Agreement that accompanies this release of
'Arm FuSa RTS Safety Package' for terms and conditions relating to your use
of such third party software.

The information is grouped into two sections. The first section lists out
details of third party software projects, including names of the applicable
licenses as per the SPDX format (http://spdx.org/licenses). The second section
includes the full license text of all applicable licenses referenced in the
first section.
===============================================================================

SECTION 1: THIRD PARTY SOFTWARE PROJECTS
===============================================================================

===============================================================================

SECTION 2: APPLICABLE LICENSES
===============================================================================

================================================================================
END OF FILE: third_party_licenses.txt


Licensing User's Guide: Third Party Licenses

Third Party Licenses

===============================================================================
This file lists the package level copyright and license information for third
party software included in this release of 'Keil MDK'. Refer to the
End User License Agreement that accompanies this release of 'Keil MDK'
for terms and conditions relating to your use of such third party software.

===============================================================================

1) ARMCC Compiler:
=================
The following location provides a summary of the third party software
components and their associated licenses used in 'ARMCC Compiler' of MDK.
- location: <install_root>\license_terms\third_party_licenses\ARMCompiler5.06u6

2) ARM CLANG Compiler:
=====================
The following location provides a summary of the third party software
components and their associated licenses used in 'ARM CLANG Compiler' of MDK.
- location: <install_root>\license_terms\third_party_licenses\ARMCompiler6.12

3) Fixed Virtual Platform models:
================================
The following location provides a summary of the third party software
components and their associated licenses used in MPS2_Cortex-M and MPS2_AEMv8M
Fixed Virtual Platform models of MDK.
- location: <install_root>\license_terms\third_party_licenses\FVP11.6

4) uVision IDE:
==============
a) file: UV4\UvEdit.dll
Project:  Scintilla source code editing component
License:  Historical Permission Notice and Disclaimer

Copyright 1998-2002 by Neil Hodgson <neilh@scintilla.org>
All Rights Reserved

Permission to use, copy, modify, and distribute this software and its
documentation for any purpose and without fee is hereby granted, provided that
the above copyright notice appear in all copies and that both that copyright
notice and this permission notice appear in supporting documentation.

NEIL HODGSON DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE, INCLUDING
ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO EVENT SHALL NEIL
HODGSON BE LIABLE FOR ANY SPECIAL, INDIRECT OR CONSEQUENTIAL DAMAGES OR ANY
DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN
ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF OR IN
CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
--------------------------------------------------------------------------------

b) file: UV4\UVCC.dll
Project:        LLVM Clang C/C++ compiler http://clang.llvm.org/
License:        The University of Illinois/NCSA Open Source License (NCSA)

Permission is hereby granted, free of charge, to any person obtaining a copy
of this software and associated documentation files (the "Software"), to deal
with the Software without restriction, including without limitation the rights
to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
copies of the Software, and to permit persons to whom the Software is
furnished to do so, subject to the following conditions:

  Redistributions of source code must retain the above copyright notice, this
  list of conditions and the following disclaimers.

  Redistributions in binary form must reproduce the above copyright notice, this
  list of conditions and the following disclaimers in the documentation and/or
  other materials provided with the distribution.

  Neither the names of <Name of Development Group, Name of Institution>, nor the
  names of its contributors may be used to endorse or promote products derived
  from this Software without specific prior written permission.
--------------------------------------------------------------------------------

c) file: UV4\xerces-c_3_0.dll:
Project:        http://xerces.apache.org/xerces-c/
License:        Apache License 2.0

Copyright © 1999-2015 The Apache Software Foundation

Apache License
Version 2.0, January 2004

http://www.apache.org/licenses/

TERMS AND CONDITIONS FOR USE, REPRODUCTION, AND DISTRIBUTION

1. Definitions.

"License" shall mean the terms and conditions for use, reproduction, and
distribution as defined by Sections 1 through 9 of this document.

"Licensor" shall mean the copyright owner or entity authorized by the
copyright owner that is granting the License.

"Legal Entity" shall mean the union of the acting entity and all other
entities that control, are controlled by, or are under common control with
that entity. For the purposes of this definition, "control" means (i) the
power, direct or indirect, to cause the direction or management of such entity,
 whether by contract or otherwise, or (ii) ownership of fifty percent (50%) or
more of the outstanding shares, or (iii) beneficial ownership of such entity.

"You" (or "Your") shall mean an individual or Legal Entity exercising
permissions granted by this License.

"Source" form shall mean the preferred form for making modifications,
including but not limited to software source code, documentation source, and
configuration files.

"Object" form shall mean any form resulting from mechanical transformation or
translation of a Source form, including but not limited to compiled object
code, generated documentation, and conversions to other media types.

"Work" shall mean the work of authorship, whether in Source or Object form,
made available under the License, as indicated by a copyright notice that is
included in or attached to the work (an example is provided in the Appendix
below).

"Derivative Works" shall mean any work, whether in Source or Object form, that
is based on (or derived from) the Work and for which the editorial revisions,
annotations, elaborations, or other modifications represent, as a whole, an
original work of authorship. For the purposes of this License, Derivative
Works shall not include works that remain separable from, or merely link (or
bind by name) to the interfaces of, the Work and Derivative Works thereof.

"Contribution" shall mean any work of authorship, including the original
version of the Work and any modifications or additions to that Work or
Derivative Works thereof, that is intentionally submitted to Licensor for
inclusion in the Work by the copyright owner or by an individual or Legal
Entity authorized to submit on behalf of the copyright owner. For the purposes
of this definition, "submitted" means any form of electronic, verbal, or
written communication sent to the Licensor or its representatives, including
but not limited to communication on electronic mailing lists, source code
control systems, and issue tracking systems that are managed by, or on behalf
of, the Licensor for the purpose of discussing and improving the Work, but
excluding communication that is conspicuously marked or otherwise designated
in writing by the copyright owner as "Not a Contribution."

"Contributor" shall mean Licensor and any individual or Legal Entity on behalf
of whom a Contribution has been received by Licensor and subsequently
incorporated within the Work.

2. Grant of Copyright License. Subject to the terms and conditions of this
License, each Contributor hereby grants to You a perpetual, worldwide,
non-exclusive, no-charge, royalty-free, irrevocable copyright license to
reproduce, prepare Derivative Works of, publicly display, publicly perform,
sublicense, and distribute the Work and such Derivative Works in Source or
Object form.

3. Grant of Patent License. Subject to the terms and conditions of this
License, each Contributor hereby grants to You a perpetual, worldwide,
non-exclusive, no-charge, royalty-free, irrevocable (except as stated in this
section) patent license to make, have made, use, offer to sell, sell, import,
and otherwise transfer the Work, where such license applies only to those
patent claims licensable by such Contributor that are necessarily infringed by
their Contribution(s) alone or by combination of their Contribution(s) with
the Work to which such Contribution(s) was submitted. If You institute patent
litigation against any entity (including a cross-claim or counterclaim in a
lawsuit) alleging that the Work or a Contribution incorporated within the Work
constitutes direct or contributory patent infringement, then any patent
licenses granted to You under this License for that Work shall terminate as of
the date such litigation is filed.

4. Redistribution. You may reproduce and distribute copies of the Work or
Derivative Works thereof in any medium, with or without modifications, and in
Source or Object form, provided that You meet the following conditions:

    You must give any other recipients of the Work or Derivative Works a copy of
    this License; and
    You must cause any modified files to carry prominent notices stating that
    You changed the files; and
    You must retain, in the Source form of any Derivative Works that You
    distribute, all copyright, patent, trademark, and attribution notices from
    the Source form of the Work, excluding those notices that do not pertain to
    any part of the Derivative Works; and

    If the Work includes a "NOTICE" text file as part of its distribution, then
    any Derivative Works that You distribute must include a readable copy of the
    attribution notices contained within such NOTICE file, excluding those
    notices that do not pertain to any part of the Derivative Works, in at least
    one of the following places: within a NOTICE text file distributed as part
    of the Derivative Works; within the Source form or documentation, if
    provided along with the Derivative Works; or, within a display generated by
    the Derivative Works, if and wherever such third-party notices normally
    appear. The contents of the NOTICE file are for informational purposes only
    and do not modify the License. You may add Your own attribution notices
    within Derivative Works that You distribute, alongside or as an addendum to
    the NOTICE text from the Work, provided that such additional attribution
    notices cannot be construed as modifying the License.

    You may add Your own copyright statement to Your modifications and may
    provide additional or different license terms and conditions for use,
    reproduction, or distribution of Your modifications, or for any such
    Derivative Works as a whole, provided Your use, reproduction, and
    distribution of the Work otherwise complies with the conditions stated in
    this License.

5. Submission of Contributions. Unless You explicitly state otherwise, any
Contribution intentionally submitted for inclusion in the Work by You to the
Licensor shall be under the terms and conditions of this License, without any
additional terms or conditions. Notwithstanding the above, nothing herein
shall supersede or modify the terms of any separate license agreement you may
have executed with Licensor regarding such Contributions.

6. Trademarks. This License does not grant permission to use the trade names,
trademarks, service marks, or product names of the Licensor, except as
required for reasonable and customary use in describing the origin of the Work
and reproducing the content of the NOTICE file.

7. Disclaimer of Warranty. Unless required by applicable law or agreed to in
writing, Licensor provides the Work (and each Contributor provides its
Contributions) on an "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
KIND, either express or implied, including, without limitation, any warranties
or conditions of TITLE, NON-INFRINGEMENT, MERCHANTABILITY, or FITNESS FOR A
PARTICULAR PURPOSE. You are solely responsible for determining the
appropriateness of using or redistributing the Work and assume any risks
associated with Your exercise of permissions under this License.

8. Limitation of Liability. In no event and under no legal theory, whether in
tort (including negligence), contract, or otherwise, unless required by
applicable law (such as deliberate and grossly negligent acts) or agreed to in
writing, shall any Contributor be liable to You for damages, including any
direct, indirect, special, incidental, or consequential damages of any
character arising as a result of this License or out of the use or inability
to use the Work (including but not limited to damages for loss of goodwill,
work stoppage, computer failure or malfunction, or any and all other
commercial damages or losses), even if such Contributor has been advised of
the possibility of such damages.

9. Accepting Warranty or Additional Liability. While redistributing the Work
or Derivative Works thereof, You may choose to offer, and charge a fee for,
acceptance of support, warranty, indemnity, or other liability obligations
and/or rights consistent with this License. However, in accepting such
obligations, You may act only on Your own behalf and on Your sole
responsibility, not on behalf of any other Contributor, and only if You agree
to indemnify, defend, and hold each Contributor harmless for any liability
incurred by, or claims asserted against, such Contributor by reason of your
accepting any such warranty or additional liability.
================================================================================
END OF FILE: third_party_licenses.txt


Licensing User's Guide: Third Party Licenses

Third Party Licenses

===============================================================================
This file lists the package level copyright and license information for third
party software included in this release of 'Keil MDK'. Refer to the License
Agreement (End User License Agreement (EULA)) that accompanies this release of
'Keil MDK' for terms and conditions relating to your use of such third party
software.

The information is grouped into two sections. The first section lists out
details of third party software projects, including names of the applicable
licenses as per the SPDX format (http://spdx.org/licenses). The second section
includes the full license text of all applicable licenses referenced in the
first section.
================================================================================

SECTION 1: THIRD PARTY SOFTWARE PROJECTS
================================================================================

Name:         Scintilla v3.7.5 [UV4\UvEdit.dll]
Summary:      Scintilla is a free source code editing component which includes
              useful features such as syntax styling, error indicators, folding,
              code completion and call tips. The project includes SciTE
              (SCIntilla based Text Editor).
Home-page:    http://www.scintilla.org/
License(s):   Historical Permission Notice and Disclaimer (HPND). See later
              section for a copy of license text.
Copyright(s): Copyright 1998-2002 by Neil Hodgson <neilh@scintilla.org>
Source(s):    https://www.scintilla.org/ScintillaHistory.html
----------------------------------------------------------------------

Name:         Clang v3.7.0 [UV4\UVCC.dll]
Summary:      C/C++ language frontend for LLVM.
Home-page:    https://clang.llvm.org/
License(s):   University of Illinois/NCSA Open Source License (NCSA). See later
              section for a copy of license text.
Copyright(s): Copyright (c) 2007-2015 University of Illinois at Urbana-Champaign
              All rights reserved.
              For full list, please refer to Source(s).
Source(s):    http://www.llvm.org/viewvc/llvm-project/cfe/branches/release_37/
----------------------------------------------------------------------

Name:         Xerces v3.0.0 [UV4\xerces-c_3_0.dll]
Summary:      An open-source C library for parsing XML files and data streams.
Home-page:    http://xerces.apache.org/
License(s):   Apache License 2.0 (Apache-2.0). See later section for a copy of
              license text.
Copyright(s): Copyright (c) 1999-2015 The Apache Software Foundation
              For full list, please refer to Source(s).
Source(s):    http://archive.apache.org/dist/xerces/c/3/sources/
----------------------------------------------------------------------

Name:         CMSIS_5 v5.6.0
Summary:      Cortex Microcontroller Software Interface Standard (CMSIS).
Home-page:    https://arm-software.github.io/CMSIS_5/General/html/index.html
License(s):   Apache License 2.0 (Apache-2.0). See later section for a copy of
              license text.
Copyright(s): Copyright (C) 2019 Arm Limited. All rights reserved.
              For full list, please refer to Source(s).
Source(s):    https://github.com/ARM-software/CMSIS_5/tree/5.6.0
----------------------------------------------------------------------

Name:         The FlashFS libraries (FS_ARM_L.lib, FS_ARM_B.lib, FS_CM1.lib,
              FS_CM3.lib, FS_LFN_CM0_B.lib, FS_LFN_CM0_L.lib, FS_LFN_CM3_B.lib
              and FS_LFN_CM3_L.lib)
Summary:      Above mentioned libraries include source code that is capable of
              supporting a file system with long filenames in Software
              Applications that you develop.
License(s):   You warrant to ARM that unless you have first obtained a licence
              from Microsoft for its FAT file system with long filename support
              then you will not develop or distribute Software Applications that
              include a file system with long filenames see
https://www.microsoft.com/en-us/legal/intellectualproperty/mtl/technologylicensing.aspx

Note:         As an alternative, the libraries FSN_ARM_L.lib, FSN_ARM_B.lib,
FSN_CM1.lib, FSN_CM3.lib, FS_SFN_CM0_B.lib, FS_SFN_CM0_L.lib, FS_SFN_CM3_B.lib
and FS_SFN_CM3_L.lib are not capable of supporting a file system with long
filenames and are licensed to you as part of the Arm Software provided under
this Licence.
================================================================================

SECTION 1A: THIRD PARTY SOFTWARE PROJECTS (IN COMPONENTS OF 'Keil MDK')
================================================================================

1) ARM Compiler 5:
-----------------
The co-located 'arm_compiler_5' folder contains a summary of the third party
software and their associated licenses used in 'ARM Compiler 5' (part of Keil
MDK)

2) ARM Compiler 6:
-----------------
The co-located 'arm_compiler_6' folder contains a summary of the third party
software and their associated licenses used in 'ARM Compiler 6' (part of Keil
MDK)

3) Simulation models:
--------------------
The co-located 'models' folder contains a summary of the third party software
and their associated licenses used in 'Fixed Virtual Platform Models (FVPs)'
(part of Keil MDK).
===============================================================================

SECTION 2: APPLICABLE LICENSES
===============================================================================

1) License text (HPND) for 'Scintilla'

Copyright 1998-2002 by Neil Hodgson <neilh@scintilla.org>
All Rights Reserved

Permission to use, copy, modify, and distribute this software and its
documentation for any purpose and without fee is hereby granted, provided that
the above copyright notice appear in all copies and that both that copyright
notice and this permission notice appear in supporting documentation.

NEIL HODGSON DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE, INCLUDING
ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO EVENT SHALL NEIL
HODGSON BE LIABLE FOR ANY SPECIAL, INDIRECT OR CONSEQUENTIAL DAMAGES OR ANY
DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN
ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF OR IN
CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
===============================================================================

2) License Text (NCSA) for 'Clang'

University of Illinois/NCSA
Open Source License

Copyright (c) 2007-2015 University of Illinois at Urbana-Champaign.
All rights reserved.

Developed by:

    LLVM Team

    University of Illinois at Urbana-Champaign

    http://llvm.org

Permission is hereby granted, free of charge, to any person obtaining a copy of
this software and associated documentation files (the "Software"), to deal with
the Software without restriction, including without limitation the rights to
use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies
of the Software, and to permit persons to whom the Software is furnished to do
so, subject to the following conditions:

    * Redistributions of source code must retain the above copyright notice,
      this list of conditions and the following disclaimers.

    * Redistributions in binary form must reproduce the above copyright notice,
      this list of conditions and the following disclaimers in the
      documentation and/or other materials provided with the distribution.

    * Neither the names of the LLVM Team, University of Illinois at
      Urbana-Champaign, nor the names of its contributors may be used to
      endorse or promote products derived from this Software without specific
      prior written permission.

THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS
FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT.  IN NO EVENT SHALL THE
CONTRIBUTORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS WITH THE
SOFTWARE.

******************************
The LLVM software contains code written by third parties.  Such software will
have its own individual LICENSE.TXT file in the directory in which it appears.
This file will describe the copyrights, license, and restrictions which apply
to that code.

The disclaimer of warranty in the University of Illinois Open Source License
applies to all code in the LLVM Distribution, and nothing in any of the
other licenses gives permission to use the names of the LLVM Team or the
University of Illinois to endorse or promote products derived from this
Software.

The following pieces of software have additional or alternate copyrights,
licenses, and/or restrictions:

Program             Directory
-------             ---------
<none yet>
===============================================================================

3) License Text (Apache-2.0) for 'Xerces' and 'CMSIS_5'

                                 Apache License
                           Version 2.0, January 2004
                        http://www.apache.org/licenses/

   TERMS AND CONDITIONS FOR USE, REPRODUCTION, AND DISTRIBUTION

   1. Definitions.

      "License" shall mean the terms and conditions for use, reproduction,
      and distribution as defined by Sections 1 through 9 of this document.

      "Licensor" shall mean the copyright owner or entity authorized by
      the copyright owner that is granting the License.

      "Legal Entity" shall mean the union of the acting entity and all
      other entities that control, are controlled by, or are under common
      control with that entity. For the purposes of this definition,
      "control" means (i) the power, direct or indirect, to cause the
      direction or management of such entity, whether by contract or
      otherwise, or (ii) ownership of fifty percent (50%) or more of the
      outstanding shares, or (iii) beneficial ownership of such entity.

      "You" (or "Your") shall mean an individual or Legal Entity
      exercising permissions granted by this License.

      "Source" form shall mean the preferred form for making modifications,
      including but not limited to software source code, documentation
      source, and configuration files.

      "Object" form shall mean any form resulting from mechanical
      transformation or translation of a Source form, including but
      not limited to compiled object code, generated documentation,
      and conversions to other media types.

      "Work" shall mean the work of authorship, whether in Source or
      Object form, made available under the License, as indicated by a
      copyright notice that is included in or attached to the work
      (an example is provided in the Appendix below).

      "Derivative Works" shall mean any work, whether in Source or Object
      form, that is based on (or derived from) the Work and for which the
      editorial revisions, annotations, elaborations, or other modifications
      represent, as a whole, an original work of authorship. For the purposes
      of this License, Derivative Works shall not include works that remain
      separable from, or merely link (or bind by name) to the interfaces of,
      the Work and Derivative Works thereof.

      "Contribution" shall mean any work of authorship, including
      the original version of the Work and any modifications or additions
      to that Work or Derivative Works thereof, that is intentionally
      submitted to Licensor for inclusion in the Work by the copyright owner
      or by an individual or Legal Entity authorized to submit on behalf of
      the copyright owner. For the purposes of this definition, "submitted"
      means any form of electronic, verbal, or written communication sent
      to the Licensor or its representatives, including but not limited to
      communication on electronic mailing lists, source code control systems,
      and issue tracking systems that are managed by, or on behalf of, the
      Licensor for the purpose of discussing and improving the Work, but
      excluding communication that is conspicuously marked or otherwise
      designated in writing by the copyright owner as "Not a Contribution."

      "Contributor" shall mean Licensor and any individual or Legal Entity
      on behalf of whom a Contribution has been received by Licensor and
      subsequently incorporated within the Work.

   2. Grant of Copyright License. Subject to the terms and conditions of
      this License, each Contributor hereby grants to You a perpetual,
      worldwide, non-exclusive, no-charge, royalty-free, irrevocable
      copyright license to reproduce, prepare Derivative Works of,
      publicly display, publicly perform, sublicense, and distribute the
      Work and such Derivative Works in Source or Object form.

   3. Grant of Patent License. Subject to the terms and conditions of
      this License, each Contributor hereby grants to You a perpetual,
      worldwide, non-exclusive, no-charge, royalty-free, irrevocable
      (except as stated in this section) patent license to make, have made,
      use, offer to sell, sell, import, and otherwise transfer the Work,
      where such license applies only to those patent claims licensable
      by such Contributor that are necessarily infringed by their
      Contribution(s) alone or by combination of their Contribution(s)
      with the Work to which such Contribution(s) was submitted. If You
      institute patent litigation against any entity (including a
      cross-claim or counterclaim in a lawsuit) alleging that the Work
      or a Contribution incorporated within the Work constitutes direct
      or contributory patent infringement, then any patent licenses
      granted to You under this License for that Work shall terminate
      as of the date such litigation is filed.

   4. Redistribution. You may reproduce and distribute copies of the
      Work or Derivative Works thereof in any medium, with or without
      modifications, and in Source or Object form, provided that You
      meet the following conditions:

      (a) You must give any other recipients of the Work or
          Derivative Works a copy of this License; and

      (b) You must cause any modified files to carry prominent notices
          stating that You changed the files; and

      (c) You must retain, in the Source form of any Derivative Works
          that You distribute, all copyright, patent, trademark, and
          attribution notices from the Source form of the Work,
          excluding those notices that do not pertain to any part of
          the Derivative Works; and

      (d) If the Work includes a "NOTICE" text file as part of its
          distribution, then any Derivative Works that You distribute must
          include a readable copy of the attribution notices contained
          within such NOTICE file, excluding those notices that do not
          pertain to any part of the Derivative Works, in at least one
          of the following places: within a NOTICE text file distributed
          as part of the Derivative Works; within the Source form or
          documentation, if provided along with the Derivative Works; or,
          within a display generated by the Derivative Works, if and
          wherever such third-party notices normally appear. The contents
          of the NOTICE file are for informational purposes only and
          do not modify the License. You may add Your own attribution
          notices within Derivative Works that You distribute, alongside
          or as an addendum to the NOTICE text from the Work, provided
          that such additional attribution notices cannot be construed
          as modifying the License.

      You may add Your own copyright statement to Your modifications and
      may provide additional or different license terms and conditions
      for use, reproduction, or distribution of Your modifications, or
      for any such Derivative Works as a whole, provided Your use,
      reproduction, and distribution of the Work otherwise complies with
      the conditions stated in this License.

   5. Submission of Contributions. Unless You explicitly state otherwise,
      any Contribution intentionally submitted for inclusion in the Work
      by You to the Licensor shall be under the terms and conditions of
      this License, without any additional terms or conditions.
      Notwithstanding the above, nothing herein shall supersede or modify
      the terms of any separate license agreement you may have executed
      with Licensor regarding such Contributions.

   6. Trademarks. This License does not grant permission to use the trade
      names, trademarks, service marks, or product names of the Licensor,
      except as required for reasonable and customary use in describing the
      origin of the Work and reproducing the content of the NOTICE file.

   7. Disclaimer of Warranty. Unless required by applicable law or
      agreed to in writing, Licensor provides the Work (and each
      Contributor provides its Contributions) on an "AS IS" BASIS,
      WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or
      implied, including, without limitation, any warranties or conditions
      of TITLE, NON-INFRINGEMENT, MERCHANTABILITY, or FITNESS FOR A
      PARTICULAR PURPOSE. You are solely responsible for determining the
      appropriateness of using or redistributing the Work and assume any
      risks associated with Your exercise of permissions under this License.

   8. Limitation of Liability. In no event and under no legal theory,
      whether in tort (including negligence), contract, or otherwise,
      unless required by applicable law (such as deliberate and grossly
      negligent acts) or agreed to in writing, shall any Contributor be
      liable to You for damages, including any direct, indirect, special,
      incidental, or consequential damages of any character arising as a
      result of this License or out of the use or inability to use the
      Work (including but not limited to damages for loss of goodwill,
      work stoppage, computer failure or malfunction, or any and all
      other commercial damages or losses), even if such Contributor
      has been advised of the possibility of such damages.

   9. Accepting Warranty or Additional Liability. While redistributing
      the Work or Derivative Works thereof, You may choose to offer,
      and charge a fee for, acceptance of support, warranty, indemnity,
      or other liability obligations and/or rights consistent with this
      License. However, in accepting such obligations, You may act only
      on Your own behalf and on Your sole responsibility, not on behalf
      of any other Contributor, and only if You agree to indemnify,
      defend, and hold each Contributor harmless for any liability
      incurred by, or claims asserted against, such Contributor by reason
      of your accepting any such warranty or additional liability.

   END OF TERMS AND CONDITIONS

   APPENDIX: How to apply the Apache License to your work.

      To apply the Apache License to your work, attach the following
      boilerplate notice, with the fields enclosed by brackets "[]"
      replaced with your own identifying information. (Don't include
      the brackets!)  The text should be enclosed in the appropriate
      comment syntax for the file format. We also recommend that a
      file or class name and description of purpose be included on the
      same "printed page" as the copyright notice for easier
      identification within third-party archives.

   Copyright [yyyy] [name of copyright owner]

   Licensed under the Apache License, Version 2.0 (the "License");
   you may not use this file except in compliance with the License.
   You may obtain a copy of the License at

       http://www.apache.org/licenses/LICENSE-2.0

   Unless required by applicable law or agreed to in writing, software
   distributed under the License is distributed on an "AS IS" BASIS,
   WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
   See the License for the specific language governing permissions and
   limitations under the License.
================================================================================
END OF FILE: third_party_licenses.txt


Licensing User's Guide: Third Party Licenses

Third Party Licenses

===============================================================================
This file lists the package level copyright and license information for third
party software included in this release of 'Keil MDK'. Refer to the License
Agreement (End User License Agreement (EULA)) that accompanies this release of
'Keil MDK' for terms and conditions relating to your use of such third party
software.

The information is grouped into two sections. The first section lists out
details of third party software projects, including names of the applicable
licenses as per the SPDX format (http://spdx.org/licenses). The second section
includes the full license text of all applicable licenses referenced in the
first section.
================================================================================

SECTION 1: THIRD PARTY SOFTWARE PROJECTS
================================================================================

Name:         Scintilla v3.7.5 [UV4\UvEdit.dll]
Summary:      Scintilla is a free source code editing component which includes
              useful features such as syntax styling, error indicators, folding,
              code completion and call tips. The project includes SciTE
              (SCIntilla based Text Editor).
Home-page:    http://www.scintilla.org/
License(s):   Historical Permission Notice and Disclaimer (HPND). See later
              section for a copy of license text.
Copyright(s): Copyright 1998-2002 by Neil Hodgson <neilh@scintilla.org>
Source(s):    https://www.scintilla.org/ScintillaHistory.html
----------------------------------------------------------------------

Name:         Clang v3.7.0 [UV4\UVCC.dll]
Summary:      C/C++ language frontend for LLVM.
Home-page:    https://clang.llvm.org/
License(s):   University of Illinois/NCSA Open Source License (NCSA). See later
              section for a copy of license text.
Copyright(s): Copyright (c) 2007-2015 University of Illinois at Urbana-Champaign
              All rights reserved.
              For full list, please refer to Source(s).
Source(s):    http://www.llvm.org/viewvc/llvm-project/cfe/branches/release_37/
----------------------------------------------------------------------

Name:         Xerces v3.0.0 [UV4\xerces-c_3_0.dll]
Summary:      An open-source C library for parsing XML files and data streams.
Home-page:    http://xerces.apache.org/
License(s):   Apache License 2.0 (Apache-2.0). See later section for a copy of
              license text.
Copyright(s): Copyright (c) 1999-2015 The Apache Software Foundation
              For full list, please refer to Source(s).
Source(s):    http://archive.apache.org/dist/xerces/c/3/sources/
----------------------------------------------------------------------

Name:         CMSIS_5 v5.7.0
Summary:      Cortex Microcontroller Software Interface Standard (CMSIS).
Home-page:    https://arm-software.github.io/CMSIS_5/General/html/index.html
License(s):   Apache License 2.0 (Apache-2.0). See later section for a copy of
              license text.
Copyright(s): Copyright (C) 2020 Arm Limited. All rights reserved.
              For full list, please refer to Source(s).
Source(s):    https://github.com/ARM-software/CMSIS_5/tree/5.7.0
----------------------------------------------------------------------

Name:         The FlashFS libraries (FS_ARM_L.lib, FS_ARM_B.lib, FS_CM1.lib,
              FS_CM3.lib, FS_LFN_CM0_B.lib, FS_LFN_CM0_L.lib, FS_LFN_CM3_B.lib
              and FS_LFN_CM3_L.lib)
Summary:      Above mentioned libraries include source code that is capable of
              supporting a file system with long filenames in Software
              Applications that you develop.
License(s):   You warrant to ARM that unless you have first obtained a licence
              from Microsoft for its FAT file system with long filename support
              then you will not develop or distribute Software Applications that
              include a file system with long filenames see
https://www.microsoft.com/en-us/legal/intellectualproperty/mtl/technologylicensing.aspx

Note:         As an alternative, the libraries FSN_ARM_L.lib, FSN_ARM_B.lib,
FSN_CM1.lib, FSN_CM3.lib, FS_SFN_CM0_B.lib, FS_SFN_CM0_L.lib, FS_SFN_CM3_B.lib
and FS_SFN_CM3_L.lib are not capable of supporting a file system with long
filenames and are licensed to you as part of the Arm Software provided under
this Licence.
================================================================================

SECTION 1A: THIRD PARTY SOFTWARE PROJECTS (IN COMPONENTS OF 'Keil MDK')
================================================================================

1) ARM Compiler 5:
-----------------
The co-located 'arm_compiler_5' folder contains a summary of the third party
software and their associated licenses used in 'ARM Compiler 5' (part of Keil
MDK)

2) ARM Compiler 6:
-----------------
The co-located 'arm_compiler_6' folder contains a summary of the third party
software and their associated licenses used in 'ARM Compiler 6' (part of Keil
MDK)

3) Simulation models:
--------------------
The co-located 'models' folder contains a summary of the third party software
and their associated licenses used in 'Fixed Virtual Platform Models (FVPs)'
(part of Keil MDK).
===============================================================================

SECTION 2: APPLICABLE LICENSES
===============================================================================

1) License text (HPND) for 'Scintilla'

Copyright 1998-2002 by Neil Hodgson <neilh@scintilla.org>
All Rights Reserved

Permission to use, copy, modify, and distribute this software and its
documentation for any purpose and without fee is hereby granted, provided that
the above copyright notice appear in all copies and that both that copyright
notice and this permission notice appear in supporting documentation.

NEIL HODGSON DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE, INCLUDING
ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO EVENT SHALL NEIL
HODGSON BE LIABLE FOR ANY SPECIAL, INDIRECT OR CONSEQUENTIAL DAMAGES OR ANY
DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN
ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF OR IN
CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
===============================================================================

2) License Text (NCSA) for 'Clang'

University of Illinois/NCSA
Open Source License

Copyright (c) 2007-2015 University of Illinois at Urbana-Champaign.
All rights reserved.

Developed by:

    LLVM Team

    University of Illinois at Urbana-Champaign

    http://llvm.org

Permission is hereby granted, free of charge, to any person obtaining a copy of
this software and associated documentation files (the "Software"), to deal with
the Software without restriction, including without limitation the rights to
use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies
of the Software, and to permit persons to whom the Software is furnished to do
so, subject to the following conditions:

    * Redistributions of source code must retain the above copyright notice,
      this list of conditions and the following disclaimers.

    * Redistributions in binary form must reproduce the above copyright notice,
      this list of conditions and the following disclaimers in the
      documentation and/or other materials provided with the distribution.

    * Neither the names of the LLVM Team, University of Illinois at
      Urbana-Champaign, nor the names of its contributors may be used to
      endorse or promote products derived from this Software without specific
      prior written permission.

THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS
FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT.  IN NO EVENT SHALL THE
CONTRIBUTORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS WITH THE
SOFTWARE.

******************************
The LLVM software contains code written by third parties.  Such software will
have its own individual LICENSE.TXT file in the directory in which it appears.
This file will describe the copyrights, license, and restrictions which apply
to that code.

The disclaimer of warranty in the University of Illinois Open Source License
applies to all code in the LLVM Distribution, and nothing in any of the
other licenses gives permission to use the names of the LLVM Team or the
University of Illinois to endorse or promote products derived from this
Software.

The following pieces of software have additional or alternate copyrights,
licenses, and/or restrictions:

Program             Directory
-------             ---------
<none yet>
===============================================================================

3) License Text (Apache-2.0) for 'Xerces' and 'CMSIS_5'

                                 Apache License
                           Version 2.0, January 2004
                        http://www.apache.org/licenses/

   TERMS AND CONDITIONS FOR USE, REPRODUCTION, AND DISTRIBUTION

   1. Definitions.

      "License" shall mean the terms and conditions for use, reproduction,
      and distribution as defined by Sections 1 through 9 of this document.

      "Licensor" shall mean the copyright owner or entity authorized by
      the copyright owner that is granting the License.

      "Legal Entity" shall mean the union of the acting entity and all
      other entities that control, are controlled by, or are under common
      control with that entity. For the purposes of this definition,
      "control" means (i) the power, direct or indirect, to cause the
      direction or management of such entity, whether by contract or
      otherwise, or (ii) ownership of fifty percent (50%) or more of the
      outstanding shares, or (iii) beneficial ownership of such entity.

      "You" (or "Your") shall mean an individual or Legal Entity
      exercising permissions granted by this License.

      "Source" form shall mean the preferred form for making modifications,
      including but not limited to software source code, documentation
      source, and configuration files.

      "Object" form shall mean any form resulting from mechanical
      transformation or translation of a Source form, including but
      not limited to compiled object code, generated documentation,
      and conversions to other media types.

      "Work" shall mean the work of authorship, whether in Source or
      Object form, made available under the License, as indicated by a
      copyright notice that is included in or attached to the work
      (an example is provided in the Appendix below).

      "Derivative Works" shall mean any work, whether in Source or Object
      form, that is based on (or derived from) the Work and for which the
      editorial revisions, annotations, elaborations, or other modifications
      represent, as a whole, an original work of authorship. For the purposes
      of this License, Derivative Works shall not include works that remain
      separable from, or merely link (or bind by name) to the interfaces of,
      the Work and Derivative Works thereof.

      "Contribution" shall mean any work of authorship, including
      the original version of the Work and any modifications or additions
      to that Work or Derivative Works thereof, that is intentionally
      submitted to Licensor for inclusion in the Work by the copyright owner
      or by an individual or Legal Entity authorized to submit on behalf of
      the copyright owner. For the purposes of this definition, "submitted"
      means any form of electronic, verbal, or written communication sent
      to the Licensor or its representatives, including but not limited to
      communication on electronic mailing lists, source code control systems,
      and issue tracking systems that are managed by, or on behalf of, the
      Licensor for the purpose of discussing and improving the Work, but
      excluding communication that is conspicuously marked or otherwise
      designated in writing by the copyright owner as "Not a Contribution."

      "Contributor" shall mean Licensor and any individual or Legal Entity
      on behalf of whom a Contribution has been received by Licensor and
      subsequently incorporated within the Work.

   2. Grant of Copyright License. Subject to the terms and conditions of
      this License, each Contributor hereby grants to You a perpetual,
      worldwide, non-exclusive, no-charge, royalty-free, irrevocable
      copyright license to reproduce, prepare Derivative Works of,
      publicly display, publicly perform, sublicense, and distribute the
      Work and such Derivative Works in Source or Object form.

   3. Grant of Patent License. Subject to the terms and conditions of
      this License, each Contributor hereby grants to You a perpetual,
      worldwide, non-exclusive, no-charge, royalty-free, irrevocable
      (except as stated in this section) patent license to make, have made,
      use, offer to sell, sell, import, and otherwise transfer the Work,
      where such license applies only to those patent claims licensable
      by such Contributor that are necessarily infringed by their
      Contribution(s) alone or by combination of their Contribution(s)
      with the Work to which such Contribution(s) was submitted. If You
      institute patent litigation against any entity (including a
      cross-claim or counterclaim in a lawsuit) alleging that the Work
      or a Contribution incorporated within the Work constitutes direct
      or contributory patent infringement, then any patent licenses
      granted to You under this License for that Work shall terminate
      as of the date such litigation is filed.

   4. Redistribution. You may reproduce and distribute copies of the
      Work or Derivative Works thereof in any medium, with or without
      modifications, and in Source or Object form, provided that You
      meet the following conditions:

      (a) You must give any other recipients of the Work or
          Derivative Works a copy of this License; and

      (b) You must cause any modified files to carry prominent notices
          stating that You changed the files; and

      (c) You must retain, in the Source form of any Derivative Works
          that You distribute, all copyright, patent, trademark, and
          attribution notices from the Source form of the Work,
          excluding those notices that do not pertain to any part of
          the Derivative Works; and

      (d) If the Work includes a "NOTICE" text file as part of its
          distribution, then any Derivative Works that You distribute must
          include a readable copy of the attribution notices contained
          within such NOTICE file, excluding those notices that do not
          pertain to any part of the Derivative Works, in at least one
          of the following places: within a NOTICE text file distributed
          as part of the Derivative Works; within the Source form or
          documentation, if provided along with the Derivative Works; or,
          within a display generated by the Derivative Works, if and
          wherever such third-party notices normally appear. The contents
          of the NOTICE file are for informational purposes only and
          do not modify the License. You may add Your own attribution
          notices within Derivative Works that You distribute, alongside
          or as an addendum to the NOTICE text from the Work, provided
          that such additional attribution notices cannot be construed
          as modifying the License.

      You may add Your own copyright statement to Your modifications and
      may provide additional or different license terms and conditions
      for use, reproduction, or distribution of Your modifications, or
      for any such Derivative Works as a whole, provided Your use,
      reproduction, and distribution of the Work otherwise complies with
      the conditions stated in this License.

   5. Submission of Contributions. Unless You explicitly state otherwise,
      any Contribution intentionally submitted for inclusion in the Work
      by You to the Licensor shall be under the terms and conditions of
      this License, without any additional terms or conditions.
      Notwithstanding the above, nothing herein shall supersede or modify
      the terms of any separate license agreement you may have executed
      with Licensor regarding such Contributions.

   6. Trademarks. This License does not grant permission to use the trade
      names, trademarks, service marks, or product names of the Licensor,
      except as required for reasonable and customary use in describing the
      origin of the Work and reproducing the content of the NOTICE file.

   7. Disclaimer of Warranty. Unless required by applicable law or
      agreed to in writing, Licensor provides the Work (and each
      Contributor provides its Contributions) on an "AS IS" BASIS,
      WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or
      implied, including, without limitation, any warranties or conditions
      of TITLE, NON-INFRINGEMENT, MERCHANTABILITY, or FITNESS FOR A
      PARTICULAR PURPOSE. You are solely responsible for determining the
      appropriateness of using or redistributing the Work and assume any
      risks associated with Your exercise of permissions under this License.

   8. Limitation of Liability. In no event and under no legal theory,
      whether in tort (including negligence), contract, or otherwise,
      unless required by applicable law (such as deliberate and grossly
      negligent acts) or agreed to in writing, shall any Contributor be
      liable to You for damages, including any direct, indirect, special,
      incidental, or consequential damages of any character arising as a
      result of this License or out of the use or inability to use the
      Work (including but not limited to damages for loss of goodwill,
      work stoppage, computer failure or malfunction, or any and all
      other commercial damages or losses), even if such Contributor
      has been advised of the possibility of such damages.

   9. Accepting Warranty or Additional Liability. While redistributing
      the Work or Derivative Works thereof, You may choose to offer,
      and charge a fee for, acceptance of support, warranty, indemnity,
      or other liability obligations and/or rights consistent with this
      License. However, in accepting such obligations, You may act only
      on Your own behalf and on Your sole responsibility, not on behalf
      of any other Contributor, and only if You agree to indemnify,
      defend, and hold each Contributor harmless for any liability
      incurred by, or claims asserted against, such Contributor by reason
      of your accepting any such warranty or additional liability.

   END OF TERMS AND CONDITIONS

   APPENDIX: How to apply the Apache License to your work.

      To apply the Apache License to your work, attach the following
      boilerplate notice, with the fields enclosed by brackets "[]"
      replaced with your own identifying information. (Don't include
      the brackets!)  The text should be enclosed in the appropriate
      comment syntax for the file format. We also recommend that a
      file or class name and description of purpose be included on the
      same "printed page" as the copyright notice for easier
      identification within third-party archives.

   Copyright [yyyy] [name of copyright owner]

   Licensed under the Apache License, Version 2.0 (the "License");
   you may not use this file except in compliance with the License.
   You may obtain a copy of the License at

       http://www.apache.org/licenses/LICENSE-2.0

   Unless required by applicable law or agreed to in writing, software
   distributed under the License is distributed on an "AS IS" BASIS,
   WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
   See the License for the specific language governing permissions and
   limitations under the License.
================================================================================
END OF FILE: third_party_licenses.txt