LEGAL NOTICES AND DISCLAIMERS

GREEN HILLS SOFTWARE MAKES NO REPRESENTATIONS OR WARRANTIES WITH RESPECT TO THE CONTENTS HEREOF AND SPECIFICALLY DISCLAIMS ANY IMPLIED WARRANTIES OF MERCHANTABILITY OR FITNESS FOR ANY PARTICULAR PURPOSE. Further, Green Hills Software reserves the right to revise this publication and to make changes from time to time in the content hereof without obligation of Green Hills Software to notify any person of such revision or changes.

Copyright (c) 1983-2023 by Green Hills Software. All rights reserved. No part of this publication may be reproduced, stored in a retrieval system, or transmitted, in any form or by any means, electronic, mechanical, photocopying, recording, or otherwise, without prior written permission from Green Hills Software.

Green Hills, the Green Hills logo, CodeBalance, GMART, GSTART, INTEGRITY, MULTI, and Slingshot are registered trademarks of Green Hills Software. AdaMULTI, Built with INTEGRITY, EventAnalyzer, G-Cover, GHnet, GHnetLite, Green Hills Probe, Integrate, ISIM, u-velOSity, PathAnalyzer, Quick Start, ResourceAnalyzer, Safety Critical Products, SuperTrace Probe, TimeMachine, TotalDeveloper, and DoubleCheck are trademarks of Green Hills Software.

All other company, product, or service names mentioned in this book may be trademarks or service marks of their respective owners.

For a listing of Green Hills Software's periodically updated patent marking information, please visit http://www.ghs.com/copyright_patent.html.

PubID: c_error_ref-744926

Branch: http://toolsvc/branches/release-branch-2023-5-comp

Date: September 1, 2023


C and C++ Compiler Diagnostics

This chapter lists diagnostic messages that you may encounter when compiling C or C++ code, listed by diagnostic number. For information about how to suppress these messages, see Set Message to Silent (--diag_suppress).


Compiler Diagnostic Message Codes

The following list contains all the C and C++ compiler diagnostic messages:


Diagnostics 1 to 99

1

last_line_incomplete

last line of file ends without a newline

2

last_line_backslash

last line of file ends with a backslash

3

include_recursion

#include file "xxxx" includes itself

For more information, see C++ Implementation Defined Features.

4

out_of_memory

out of memory

6

comment_unclosed_at_eof

comment unclosed at end of file

7

bad_token

unrecognized token

8

unclosed_string

missing closing quote

9

nested_comment

nested comment is not allowed

GHS Standard Mode enables this diagnostic.

You cannot nest comments inside one another. For example, the following line will cause the compiler to issue a warning:

/* this is /*a comment*/ not a comment */

Because the first instance of */ closes the comment, the compiler parses not a comment as C code.

10

bad_use_of_sharp

"#" not expected here

11

bad_pp_directive_keyword

unrecognized preprocessing directive

GHS Standard Mode enables this diagnostic.

The compiler issues this warning when it does not recognize a preprocessing directive. For example:

#foo

12

end_of_flush

parsing restarts here after previous syntax error

13

exp_file_name

expected a file name

14

extra_text_in_pp_directive

extra text after expected end of preprocessing directive

17

exp_rbracket

expected a "]"

18

exp_rparen

expected a ")"

19

extra_chars_on_number

extra text after expected end of number

20

undefined_identifier

identifier "xxxx" is undefined

21

useless_type_qualifiers

type qualifiers are meaningless in this declaration

22

bad_hex_digit

invalid hexadecimal number

23

integer_too_large

integer constant is too large

24

bad_octal_digit

invalid octal digit

25

zero_length_string

quoted string should contain at least one character

26

too_many_characters

too many characters in character constant

27

bad_character_value

character value is out of range

28

expr_not_constant

expression must have a constant value

29

exp_primary_expr

expected an expression

30

bad_float_value

floating constant is out of range

31

expr_not_integral

expression must have integral type

32

expr_not_arithmetic

expression must have arithmetic type

33

exp_line_number

expected a line number

34

bad_line_number

invalid line number

35

error_directive

#error directive: xxxx

36

missing_pp_if

the #if for this directive is missing

GHS Standard Mode enables this diagnostic.

37

missing_endif

the #endif for this directive is missing

GHS Standard Mode enables this diagnostic.

38

pp_else_already_appeared

directive is not allowed -- an #else has already appeared

39

divide_by_zero

division by zero

40

exp_identifier

expected an identifier

41

expr_not_scalar

expression must have arithmetic or pointer type

42

incompatible_operands

operand types are incompatible ("type" and "type")

44

expr_not_pointer

expression must have pointer type

45

cannot_undef_predef_macro

#undef may not be used on this predefined name "entity"

46

cannot_redef_predef_macro

"entity" is predefined; attempted redefinition ignored

47

bad_macro_redef

incompatible redefinition of macro "entity" (declared at line xxxx)

49

duplicate_macro_param_name

duplicate macro parameter name

50

paste_cannot_be_first

"##" may not be first in a macro definition

51

paste_cannot_be_last

"##" may not be last in a macro definition

52

exp_macro_param

expected a macro parameter name

53

exp_colon

expected a ":"

54

too_few_macro_args

too few arguments in invocation of entity-kind "entity"

GHS Standard Mode enables this diagnostic.

55

too_many_macro_args

too many arguments in invocation of entity-kind "entity"

56

sizeof_function

operand of sizeof may not be a function

57

bad_constant_operator

this operator is not allowed in a constant expression

58

bad_pp_operator

this operator is not allowed in a preprocessing expression

59

bad_constant_function_call

function call is not allowed in a constant expression

60

bad_integral_operator

this operator is not allowed in an integral constant expression

61

integer_overflow

integer operation result is out of range

62

negative_shift_count

shift count is negative

63

shift_count_too_large

shift count is too large

GHS Standard Mode enables this diagnostic.

64

useless_decl

declaration does not declare anything

65

exp_semicolon

expected a ";"

66

enum_value_out_of_int_range

enumeration value is out of "int" range

GHS Standard Mode enables this diagnostic.

67

exp_rbrace

expected a "}"

68

integer_sign_change

integer conversion resulted in a change of sign

69

integer_truncated

integer conversion resulted in truncation

GHS Standard Mode enables this diagnostic.

70

incomplete_type_not_allowed

incomplete type is not allowed

71

sizeof_bit_field

operand of sizeof may not be a bit field

75

bad_indirection_operand

operand of "*" must be a pointer but has type "type"

76

empty_macro_argument

argument to macro is empty

77

missing_decl_specifiers

this declaration has no storage class or type specifier

GHS Standard Mode enables this diagnostic.

78

initializer_in_param

a parameter declaration may not have an initializer

79

exp_type_specifier

expected a type specifier

80

storage_class_not_allowed

a storage class may not be specified here

81

mult_storage_classes

more than one storage class may not be specified

82

storage_class_not_first

storage class is not first

83

dupl_type_qualifier

type qualifier specified more than once

84

bad_combination_of_type_specifiers

invalid combination of type specifiers

85

bad_param_storage_class

invalid storage class for a parameter

86

bad_function_storage_class

invalid storage class for a function

87

type_specifier_not_allowed

a type specifier may not be used here

88

array_of_function

array of functions is not allowed

89

array_of_void

array of void is not allowed

90

function_returning_function

function returning function is not allowed

91

function_returning_array

function returning array is not allowed

92

param_id_list_needs_function_def

identifier-list parameters may only be used in a function definition

93

function_type_must_come_from_declarator

function type may not come from a typedef

94

array_size_must_be_positive

the size of an array must be greater than zero

95

array_size_too_large

array is too large

96

empty_translation_unit

a translation unit must contain at least one declaration

97

bad_function_return_type

a function may not return a value of this type

98

bad_array_element_type

an array may not have elements of this type

99

decl_should_be_of_param

a declaration here must declare a parameter


Diagnostics 100 to 199

100

dupl_param_name

duplicate parameter name

101

id_already_declared

"xxxx" has already been declared in the current scope

102

nonstd_forward_decl_enum

forward declaration of enum type is nonstandard

103

class_too_large

class is too large

104

struct_too_large

struct or union is too large

105

bad_bit_field_size

invalid size for bit field

106

bad_bit_field_type

invalid type for a bit field

107

zero_length_bit_field_must_be_unnamed

zero-length bit field must be unnamed

108

signed_one_bit_field

signed bit field of length 1

GHS Standard Mode enables this diagnostic.

109

expr_not_ptr_to_function

expression preceding parentheses of apparent call must have (pointer-to-) function type

110

exp_definition_of_tag

expected either a definition or a tag name

111

code_is_unreachable

statement is unreachable

This diagnostic may be silenced on a case-by-case basis by placing a special /*NOTREACHED*/ comment before the code that is unreachable.

Example:

if (1) {
  return 0;
}
/*NOTREACHED*/
impossible_condition();

When using this feature, note the following:

  • Comments with NOTREACHED must use the style in the example above ("/* ... */"). Other commenting styles (such as "//") will not work.

  • NOTREACHED may be optionally prefixed by a single whitespace. If any words follow NOTREACHED, they must be prefixed by at least one whitespace.

112

exp_while

expected "while"

114

never_defined

entity-kind "entity" was referenced but not defined

115

continue_must_be_in_loop

a continue statement may only be used within a loop

116

break_must_be_in_loop_or_switch

a break statement may only be used within a loop or switch

117

no_value_returned_in_non_void_function

non-void entity-kind "entity" should return a value

GHS Standard Mode enables this diagnostic.

118

value_returned_in_void_function

a void function may not return a value

119

cast_to_bad_type

cast to type "type" is not allowed

120

bad_return_value_type

return value type does not match the function type

121

case_label_must_be_in_switch

a case label may only be used within a switch

122

default_label_must_be_in_switch

a default label may only be used within a switch

124

default_label_appears_more_than_once

default label has already appeared in this switch at line xxxx

125

exp_lparen

expected a "("

126

expr_not_an_lvalue

expression must be an lvalue

127

exp_statement

expected a statement

128

loop_not_reachable

loop is not reachable

129

block_scope_function_must_be_extern

a block-scope function may only have extern storage class

130

exp_lbrace

expected a "{"

131

expr_not_ptr_to_class

expression must have pointer-to-class type but it has type "type"

132

expr_not_ptr_to_struct_or_union

expression must have pointer-to-struct-or-union type but it has type "type"

133

exp_member_name

expected a member name

134

exp_field_name

expected a field name

135

not_a_member

entity-kind "entity" has no member "xxxx"

136

not_a_field

entity-kind "entity" has no field "xxxx"

137

expr_not_a_modifiable_lvalue

expression must be a modifiable lvalue

138

address_of_register_variable

taking the address of a register variable is not allowed

139

address_of_bit_field

taking the address of a bit field is not allowed

140

too_many_arguments

too many arguments in function call

141

all_proto_params_must_be_named

unnamed prototyped parameters not allowed when body is present

142

expr_not_pointer_to_object

expression must have pointer-to-object type but it has type "type"

143

program_too_large

program too large or complicated to compile

144

bad_initializer_type

a value of type "type" cannot be used to initialize an entity of type "type"

145

cannot_initialize

entity-kind "entity" may not be initialized

146

too_many_initializer_values

too many initializer values

147

not_compatible_with_previous_decl

declaration is incompatible with entity-kind "entity" (declared at line xxxx)

148

already_initialized

entity-kind "entity" has already been initialized

149

bad_file_scope_storage_class

a global-scope declaration may not have this storage class

150

type_cannot_be_param_name

a type name may not be redeclared as a parameter

151

typedef_cannot_be_param_name

a typedef name may not be redeclared as a parameter

152

non_zero_int_conv_to_pointer

conversion of nonzero integer to pointer

153

expr_not_class

expression must have class type but it has type "type"

154

expr_not_struct_or_union

expression must have struct or union type but it has type "type"

155

old_fashioned_assignment_operator

old-fashioned assignment operator

156

old_fashioned_initializer

old-fashioned initializer

157

expr_not_integral_constant

expression must be an integral constant expression

158

expr_not_an_lvalue_or_function_designator

expression must be an lvalue or a function designator

159

decl_incompatible_with_previous_use

declaration is incompatible with previous "entity" (declared at line xxxx)

160

external_name_clash

external name conflicts with external name of entity-kind "entity" (declared at line xxxx)

161

unrecognized_pragma

unrecognized #pragma

163

cannot_open_temp_file_reason

could not open temporary file "xxxx": xxxx

164

temp_file_dir_name_too_long

name of directory for temporary files is too long ("xxxx")

165

too_few_arguments

too few arguments in function call

166

bad_float_constant

invalid floating constant

167

incompatible_param

argument of type "type" is incompatible with parameter of type "type"

168

function_type_not_allowed

a function type is not allowed here

169

exp_declaration

expected a declaration

170

pointer_outside_base_object

pointer points outside of underlying object

171

bad_cast

invalid type conversion

172

linkage_conflict

external/internal linkage conflict with previous declaration at line xxxx

GHS Standard Mode enables this diagnostic.

173

float_to_integer_conversion

floating-point value does not fit in required integral type

174

expr_has_no_effect

expression has no effect

GHS Standard Mode enables this diagnostic.

175

subscript_out_of_range

subscript out of range

177

declared_but_not_referenced

entity-kind "entity" was declared but never referenced

178

pcc_address_of_array

"&" applied to an array has no effect

179

mod_by_zero

right operand of "%" is zero

180

old_style_incompatible_param

argument is incompatible with formal parameter

181

printf_arg_mismatch

argument is incompatible with corresponding format string conversion (expected "type", given "type")

GHS Standard Mode enables this diagnostic.

182

empty_include_search_path

could not open source file "xxxx" (no directories in search list)

183

cast_not_integral

type of cast must be integral

184

cast_not_scalar

type of cast must be arithmetic or pointer

185

initialization_not_reachable

dynamic initialization in unreachable code

186

unsigned_compare_with_zero

pointless comparison of unsigned integer with zero

187

assign_where_compare_meant

use of "=" where "==" may have been intended

GHS Standard Mode enables this diagnostic.

188

mixed_enum_type

enumerated type mixed with another type

189

file_write_error

error while writing xxxx file

190

bad_il_file

invalid intermediate language file

191

cast_to_qualified_type

type qualifier is meaningless on cast type

192

unrecognized_char_escape

unrecognized character escape sequence

GHS Standard Mode enables this diagnostic.

193

undefined_preproc_id

zero used for undefined preprocessing identifier "xxxx"

194

exp_asm_string

expected an asm string

195

asm_func_must_be_prototyped

an asm function must be prototyped

196

bad_asm_func_ellipsis

an asm function may not have an ellipsis


Diagnostics 200 to 299

219 | file_delete_error_reason error while deleting file "xxxx": xxxx
220 | integer_to_float_conversion integral value does not fit in required floating-point type
221 | float_to_float_conversion floating-point value does not fit in required floating-point type
222 | bad_float_operation_result floating-point operation result is out of range
223 | implicit_func_decl function xxxx declared implicitly GHS Standard Mode enables this diagnostic.
224 | too_few_printf_args the format string requires additional arguments GHS Standard Mode enables this diagnostic.
225 | too_many_printf_args the format string ends before this argument GHS Standard Mode enables this diagnostic.
226 | bad_printf_format_string invalid format string conversion GHS Standard Mode enables this diagnostic.
227 | macro_recursion macro recursion
228 | nonstd_extra_comma trailing comma is nonstandard
229 | enum_bit_field_too_small bit field cannot contain all values of the enumerated type
230 | nonstd_bit_field_type nonstandard type for a bit field
231 | decl_in_prototype_scope declaration is not visible outside of function
232 | decl_of_void_ignored old-fashioned typedef of "void" ignored
233 | old_fashioned_field_selection left operand is not a struct or union containing this field
234 | old_fashioned_ptr_field_selection pointer does not point to struct or union containing this field
235 | var_retained_incomp_type variable "xxxx" was declared with a never-completed type
236 | boolean_controlling_expr_is_constant controlling expression is constant
237 | switch_selector_expr_is_constant selector expression is constant GHS Standard Mode enables this diagnostic.
238 | bad_param_specifier invalid specifier on a parameter
239 | bad_specifier_outside_class_decl invalid specifier outside a class declaration
240 | dupl_decl_specifier duplicate specifier in declaration
241 | base_class_not_allowed_for_union a union is not allowed to have a base class
242 | access_already_specified multiple access control specifiers are not allowed
243 | missing_class_definition class or struct definition is missing
244 | name_not_member_of_class_or_base_classes qualified name is not a member of class "type" or its base classes
245 | member_ref_requires_object a nonstatic member reference must be relative to a specific object
246 | nonstatic_member_def_not_allowed a nonstatic data member may not be defined outside its class
247 | already_defined entity-kind "entity" has already been defined
248 | pointer_to_reference pointer to reference is not allowed
249 | reference_to_reference reference to reference is not allowed
250 | reference_to_void reference to void is not allowed
251 | array_of_reference array of reference is not allowed
252 | missing_initializer_on_reference reference entity-kind "entity" requires an initializer
253 | exp_comma expected a ","
254 | type_identifier_not_allowed type name is not allowed
255 | type_definition_not_allowed type definition is not allowed
256 | bad_type_name_redeclaration invalid redeclaration of type name "entity" (declared at line xxxx)
257 | missing_initializer_on_const const entity-kind "entity" requires an initializer
258 | this_used_incorrectly "this" may only be used inside a nonstatic member function
259 | constant_value_not_known constant value is not known
260 | missing_type_specifier explicit type is missing ("int" assumed) GHS Standard Mode enables this diagnostic.
261 | missing_access_specifier access control not specified ("xxxx" by default)
262 | not_a_class_or_struct_name not a class or struct name
263 | dupl_base_class_name duplicate base class name
264 | bad_base_class invalid base class
265 | no_access_to_name entity-kind "entity" is inaccessible
266 | ambiguous_name "entity" is ambiguous
267 | old_style_parameter_list old-style parameter list (anachronism)
268 | declaration_after_statements declaration may not appear after executable statement in block
269 | inaccessible_base_class conversion to inaccessible base class "type" is not allowed
274 | improperly_terminated_macro_call improperly terminated macro invocation
276 | id_must_be_class_or_namespace_name name followed by "::" must be a class or namespace name
277 | bad_friend_decl invalid friend declaration
278 | value_returned_in_constructor a constructor or destructor may not return a value
279 | bad_destructor_decl invalid destructor declaration
280 | class_and_member_name_conflict declaration of a member with the same name as its class
281 | global_qualifier_not_allowed global-scope qualifier (leading "::") is not allowed
282 | name_not_found_in_file_scope the global scope has no "xxxx"
283 | qualified_name_not_allowed qualified name is not allowed
284 | null_reference NULL reference is not allowed
285 | brace_initialization_not_allowed initialization with "{…}" is not allowed for object of type "type"
286 | ambiguous_base_class base class "type" is ambiguous
287 | ambiguous_derived_class derived class "type" contains more than one instance of class "type"
288 | derived_class_from_virtual_base cannot convert pointer to base class "type" to pointer to derived class "type" -- base class is virtual
289 | no_matching_constructor no instance of constructor "entity" matches the argument list
290 | ambiguous_copy_constructor copy constructor for class "type" is ambiguous
291 | no_default_constructor no default constructor exists for class "type"
292 | not_a_field_or_base_class "xxxx" is not a nonstatic data member or base class of class "type"
293 | indirect_nonvirtual_base_class_not_allowed indirect nonvirtual base class is not allowed
294 | bad_union_field invalid union member -- class "type" has a disallowed member function
296 | bad_rvalue_array invalid use of non-lvalue array
297 | exp_operator expected an operator
298 | inherited_member_not_allowed inherited member is not allowed
299 | indeterminate_overloaded_function cannot determine which instance of entity-kind "entity" is intended


Diagnostics 300 to 399

300 | bound_function_must_be_called a pointer to a bound function may only be used to call the function
301 | duplicate_typedef typedef name has already been declared (with same type)
302 | function_redefinition entity-kind "entity" has already been defined
304 | no_matching_function no instance of entity-kind "entity" matches the argument list
305 | type_def_not_allowed_in_func_type_decl type definition is not allowed in function return type declaration
306 | default_arg_not_at_end default argument not at end of parameter list
307 | default_arg_already_defined redefinition of default argument
308 | ambiguous_overloaded_function more than one instance of entity-kind "entity" matches the argument list:
309 | ambiguous_constructor more than one instance of constructor "entity" matches the argument list:
310 | bad_default_arg_type default argument of type "type" is incompatible with parameter of type "type"
311 | return_type_cannot_distinguish_functions cannot overload functions distinguished by return type alone
312 | no_user_defined_conversion no suitable user-defined conversion from "type" to "type" exists
314 | virtual_static_not_allowed only nonstatic member functions may be virtual
315 | unqual_function_with_qual_object the object has type qualifiers that are not compatible with the member function
316 | too_many_virtual_functions program too large to compile (too many virtual functions)
317 | bad_return_type_on_virtual_function_override return type is not identical to nor covariant with return type "type" of overridden virtual function "entity"
318 | ambiguous_virtual_function_override override of virtual entity-kind "entity" is ambiguous
319 | pure_specifier_on_nonvirtual_function pure specifier ("= 0") allowed only on virtual functions
320 | bad_pure_specifier badly-formed pure specifier (only "= 0" is allowed)
321 | bad_data_member_initialization data member initializer is not allowed
322 | abstract_class_object_not_allowed object of abstract class type "type" is not allowed:
323 | function_returning_abstract_class function returning abstract class "type" is not allowed:
324 | duplicate_friend_decl duplicate friend declaration
325 | inline_and_nonfunction inline specifier allowed on function declarations only
326 | inline_not_allowed "inline" is not allowed
327 | bad_storage_class_with_inline invalid storage class for an inline function
328 | bad_member_storage_class invalid storage class for a class member
329 | local_class_function_def_missing local class member entity-kind "entity" requires a definition
330 | inaccessible_special_function entity-kind "entity" (declared at line xxxx) is inaccessible
332 | missing_const_copy_constructor class "type" has no copy constructor to copy a const object
333 | definition_of_implicitly_declared_function defining an implicitly declared member function is not allowed
334 | no_suitable_copy_constructor class "type" has no suitable copy constructor
335 | linkage_specifier_not_allowed linkage specification is not allowed
336 | bad_linkage_specifier unknown external linkage specification
337 | incompatible_linkage_specifier linkage specification is incompatible with previous "entity" (declared at line xxxx)
338 | overloaded_function_linkage more than one instance of overloaded function "entity" has "C" linkage
339 | ambiguous_default_constructor class "type" has more than one default constructor
340 | temp_used_for_ref_init value copied to temporary, reference to temporary used
341 | nonmember_operator_not_allowed "operatorxxxx" must be a member function
342 | static_member_operator_not_allowed operator may not be a static member function
343 | too_many_args_for_conversion no arguments allowed on user-defined conversion
344 | too_many_args_for_operator too many parameters for this operator function
345 | too_few_args_for_operator too few parameters for this operator function
346 | no_params_with_class_type nonmember operator requires a parameter with class type
347 | default_arg_expr_not_allowed default argument is not allowed
348 | ambiguous_user_defined_conversion more than one user-defined conversion from "type" to "type" applies:
349 | no_matching_operator_function no operator "xxxx" matches these operands
350 | ambiguous_operator_function more than one operator "xxxx" matches these operands:
351 | bad_arg_type_for_operator_new first parameter of allocation function must be of type "size_t"
352 | bad_return_type_for_op_new allocation function requires "void *" return type
353 | bad_return_type_for_op_delete deallocation function requires "void" return type
354 | bad_first_arg_type_for_operator_delete first parameter of deallocation function must be of type "void *"
356 | type_must_be_object_type type must be an object type
357 | base_class_already_initialized base class "type" has already been initialized
358 | base_class_init_anachronism base class name required -- "type" assumed (anachronism)
359 | member_already_initialized entity-kind "entity" has already been initialized
360 | missing_base_class_or_member_name name of member or base class is missing
361 | assignment_to_this assignment to "this" (anachronism)
362 | overload_anachronism "overload" keyword used (anachronism)
363 | anon_union_member_access invalid anonymous union -- nonpublic member is not allowed
364 | anon_union_member_function invalid anonymous union -- member function is not allowed
365 | anon_union_storage_class anonymous union at global or namespace scope must be declared static
366 | missing_initializer_on_fields entity-kind "entity" provides no initializer for:
367 | cannot_initialize_fields implicitly generated constructor for class "type" cannot initialize:
368 | no_ctor_but_const_or_ref_member entity-kind "entity" defines no constructor to initialize the following:
369 | var_with_uninitialized_member entity-kind "entity" has an uninitialized const or reference member
370 | var_with_uninitialized_field entity-kind "entity" has an uninitialized const field
371 | missing_const_assignment_operator class "type" has no assignment operator to copy a const object
372 | no_suitable_assignment_operator class "type" has no suitable assignment operator
373 | ambiguous_assignment_operator ambiguous assignment operator for class "type"
375 | missing_typedef_name declaration requires a typedef name
377 | virtual_not_allowed "virtual" is not allowed
378 | static_not_allowed "static" is not allowed
379 | bound_function_cast_anachronism cast of bound function to normal function pointer (anachronism)
380 | expr_not_ptr_to_member expression must have pointer-to-member type
381 | extra_semicolon extra ";" ignored
382 | nonstd_const_member in-class initializer for nonstatic member is nonstandard
384 | no_matching_new_function no instance of overloaded "entity" matches the argument list
386 | no_match_for_addr_of_overloaded_function no instance of entity-kind "entity" matches the required type
387 | delete_count_anachronism delete array size expression used (anachronism)
389 | cast_to_abstract_class a cast to abstract class "type" is not allowed:
390 | bad_use_of_main function "main" may not be called or have its address taken
391 | initializer_not_allowed_on_array_new a new-initializer may not be specified for an array
392 | member_function_redecl_outside_class member function "entity" may not be redeclared outside its class
393 | ptr_to_incomplete_class_type_not_allowed pointer to incomplete class type "type" is not allowed
394 | ref_to_nested_function_var reference to local variable of enclosing function is not allowed
395 | single_arg_postfix_incr_decr_anachronism single-argument function used for postfix "xxxx" (anachronism)
397 | bad_default_assignment implicitly generated assignment operator cannot copy:
398 | nonstd_array_cast cast to array type is nonstandard (treated as cast to "type")
399 | class_with_op_new_but_no_op_delete entity-kind "entity" has an operator new() but no default operator delete()


Diagnostics 400 to 499

400 | class_with_op_delete_but_no_op_new entity-kind "entity" has a default operator delete() but no operator new()
401 | base_class_with_nonvirtual_dtor destructor for base class "entity" (declared at line xxxx) is not virtual
403 | member_function_redeclaration entity-kind "entity" has already been declared
404 | inline_main function "main" may not be declared inline
405 | class_and_member_function_name_conflict member function with the same name as its class must be a constructor
406 | nested_class_anachronism using nested entity-kind "entity" (anachronism)
407 | too_many_params_for_destructor a destructor may not have parameters
408 | bad_constructor_param copy constructor for class "type" may not have a parameter of type "type"
409 | incomplete_function_return_type entity-kind "entity" returns incomplete type "type"
410 | protected_access_problem protected entity-kind "entity" (declared at line xxxx) is not accessible through a "type" pointer or object
411 | param_not_allowed a parameter is not allowed
412 | asm_decl_not_allowed an "asm" declaration is not allowed here
413 | no_conversion_function no suitable conversion function from "type" to "type" exists
414 | delete_of_incomplete_class delete of pointer to incomplete class
415 | no_constructor_for_conversion no suitable constructor exists to convert from "type" to "type"
416 | ambiguous_constructor_for_conversion more than one constructor applies to convert from "type" to "type":
417 | ambiguous_conversion_function more than one conversion function from "type" to "type" applies:
418 | ambiguous_conversion_to_builtin more than one conversion function from "type" to a built-in type applies:
424 | addr_of_constructor_or_destructor a constructor or destructor may not have its address taken
426 | nonconst_ref_init_anachronism temporary used for initial value of reference to non-const (anachronism)
427 | qualifier_in_member_declaration qualified name is not allowed in member declaration
428 | mixed_enum_type_anachronism enumerated type mixed with another type (anachronism)
429 | new_array_size_must_be_nonnegative the size of an array in "new" must be non-negative
430 | return_ref_init_requires_temp returning reference to local temporary
432 | enum_not_allowed "enum" declaration is not allowed
433 | qualifier_dropped_in_ref_init qualifiers dropped in binding reference of type "type" to initializer of type "type"
434 | bad_nonconst_ref_init a reference of type "type" (not const-qualified) cannot be initialized with a value of type "type"
435 | delete_of_function_pointer a pointer to function may not be deleted
436 | bad_conversion_function_decl conversion function must be a nonstatic member function
437 | bad_template_declaration_scope a template declaration is not allowed here
438 | exp_lt expected a "<"
439 | exp_gt expected a ">"
440 | missing_template_param template parameter declaration is missing
441 | missing_template_arg_list argument list for entity-kind "entity" is missing
442 | too_few_template_args too few arguments for entity-kind "entity"
443 | too_many_template_args too many arguments for entity-kind "entity"
445 | not_used_in_template_function_params entity-kind "entity" is not used in declaring the parameter types of entity-kind "entity"
446 | cfront_multiple_nested_types two nested types have the same name: "entity" and "entity" (declared at line xxxx) (cfront compatibility)
447 | cfront_global_defined_after_nested_type global "entity" was declared after nested "entity" (declared at line xxxx) (cfront compatibility)
449 | ambiguous_ptr_to_overloaded_function more than one instance of entity-kind "entity" matches the required type
450 | nonstd_long_long the type "long long" is nonstandard
451 | nonstd_friend_decl omission of "xxxx" is nonstandard
452 | return_type_on_conversion_function return type may not be specified on a conversion function
456 | runaway_recursive_instantiation excessive recursion at instantiation of entity-kind "entity" For more information, see C++ Implementation Defined Features.
457 | bad_template_declaration "xxxx" is not a function or static data member
458 | bad_nontype_template_arg argument of type "type" is incompatible with template parameter of type "type"
459 | init_needing_temp_not_allowed initialization requiring a temporary or conversion is not allowed
460 | decl_hides_function_parameter declaration of "xxxx" hides function parameter GHS Standard Mode enables this diagnostic.
461 | nonconst_ref_init_from_rvalue initial value of reference to non-const must be an lvalue
463 | template_not_allowed "template" is not allowed
464 | not_a_class_template "type" is not a class template
466 | function_template_named_main "main" is not a valid name for a function template
467 | union_nonunion_mismatch invalid reference to entity-kind "entity" (union/nonunion mismatch)
468 | local_type_in_template_arg a template argument may not reference a local type
469 | tag_kind_incompatible_with_declaration tag kind of xxxx is incompatible with declaration of entity-kind "entity" (declared at line xxxx)
470 | name_not_tag_in_file_scope the global scope has no tag named "xxxx"
471 | not_a_tag_member entity-kind "entity" has no tag member named "xxxx"
472 | ptr_to_member_typedef member function typedef (allowed for cfront compatibility)
473 | bad_use_of_member_function_typedef entity-kind "entity" may be used only in pointer-to-member declaration
475 | nonexternal_entity_in_template_arg a template argument may not reference a non-external entity
476 | id_must_be_class_or_type_name name followed by "::~" must be a class name or a type name
478 | destructor_type_mismatch type used as destructor name does not match type "type"
479 | called_function_redeclared_inline entity-kind "entity" redeclared "inline" after being called
481 | bad_storage_class_on_template_decl invalid storage class for a template declaration
482 | no_access_to_type_cfront_mode entity-kind "entity" (declared at line xxxx) is an inaccessible type (allowed for cfront compatibility)
484 | invalid_instantiation_argument invalid explicit instantiation declaration
485 | not_instantiatable_entity entity-kind "entity" is not an entity that can be instantiated
486 | compiler_generated_function_cannot_be_instantiated compiler generated entity-kind "entity" cannot be explicitly instantiated
487 | inline_function_cannot_be_instantiated inline entity-kind "entity" cannot be explicitly instantiated
489 | instantiation_requested_no_definition_supplied entity-kind "entity" cannot be instantiated -- no template definition was supplied
490 | instantiation_requested_and_specialized entity-kind "entity" cannot be instantiated -- it has been explicitly specialized
493 | no_match_for_type_of_overloaded_function no instance of entity-kind "entity" matches the specified type
494 | nonstd_void_param_list declaring a void parameter list with a typedef is nonstandard
495 | cfront_name_lookup_bug global entity-kind "entity" used instead of entity-kind "entity" (cfront compatibility)
496 | redeclaration_of_template_param_name template parameter "xxxx" may not be redeclared in this scope
497 | decl_hides_template_parameter declaration of "xxxx" hides template parameter
498 | must_be_prototype_instantiation template argument list must match the parameter list


Diagnostics 500 to 599

500 | bad_extra_arg_for_postfix_operator extra parameter of postfix "operator++" must be of type "int"
501 | function_type_required an operator name must be declared as a function
502 | operator_name_not_allowed operator name is not allowed
503 | bad_scope_for_specialization entity-kind "entity" cannot be specialized in the current scope
504 | nonstd_member_function_address nonstandard form for taking the address of a member function
505 | too_few_template_params too few template parameters -- does not match previous declaration (declared at line xxxx)
506 | too_many_template_params too many template parameters -- does not match previous declaration (declared at line xxxx)
507 | template_operator_delete function template for operator delete(void *) is not allowed
508 | class_template_same_name_as_templ_param class template and template parameter may not have the same name
510 | unnamed_type_in_template_arg a template argument may not reference an unnamed type
511 | enum_type_not_allowed this operation on an enumerated type requires an applicable user-defined operator function
512 | qualified_reference_type type qualifier on a reference type is not allowed
513 | incompatible_assignment_operands a value of type "type" cannot be assigned to an entity of type "type"
514 | unsigned_compare_with_negative pointless comparison of unsigned integer with a negative constant
515 | converting_to_incomplete_class cannot convert to incomplete class "type"
516 | missing_initializer_on_unnamed_const const object requires an initializer
517 | unnamed_object_with_uninitialized_field object has an uninitialized const or reference member
518 | nonstd_pp_directive nonstandard preprocessing directive
519 | unexpected_template_arg_list entity-kind "entity" may not have a template argument list
520 | missing_initializer_list initialization with "{…}" expected for aggregate object
521 | incompatible_ptr_to_member_selection_operands pointer-to-member selection class types are incompatible ("type" and "type")
522 | self_friendship pointless friend declaration
523 | period_used_as_qualifier "." used in place of "::" to form a qualified name
524 | const_function_anachronism non-const function called for const object (anachronism)
525 | dependent_stmt_is_declaration a dependent statement may not be a declaration
526 | void_param_not_allowed a parameter may not have void type
529 | bad_templ_arg_expr_operator this operator is not allowed in a template argument expression
530 | missing_handler try block requires at least one handler
531 | missing_exception_declaration handler requires an exception declaration
532 | masked_by_default_handler handler is masked by default handler
533 | masked_by_handler handler is potentially masked by previous handler for type "type"
534 | local_type_used_in_exception use of a local type to specify an exception
535 | redundant_exception_specification_type redundant type in exception specification
536 | incompatible_exception_specification exception specification is incompatible with that of previous entity-kind "entity" (declared at line xxxx)
540 | no_exception_support support for exception handling is disabled
541 | omitted_exception_specification allowing all exceptions is incompatible with previous entity-kind "entity" (declared at line xxxx)
542 | cannot_create_instantiation_request_file could not create instantiation request file "xxxx"
543 | non_arith_operation_in_templ_arg non-arithmetic operation not allowed in nontype template argument
544 | local_type_in_nonlocal_var use of a local type to declare a nonlocal variable
545 | local_type_in_function use of a local type to declare a function
546 | branch_past_initialization transfer of control bypasses initialization of:
548 | branch_into_handler transfer of control into an exception handler
549 | used_before_set entity-kind "entity" is used before its value is set GHS Standard Mode enables this diagnostic.
550 | set_but_not_used entity-kind "entity" was set but never used
551 | bad_scope_for_definition entity-kind "entity" cannot be defined in the current scope
552 | exception_specification_not_allowed exception specification is not allowed
553 | template_and_instance_linkage_conflict external/internal linkage conflict for entity-kind "entity" (declared at line xxxx)
554 | conversion_function_not_usable entity-kind "entity" will not be called for implicit or explicit conversions
555 | tag_kind_incompatible_with_template_parameter tag kind of xxxx is incompatible with template parameter of type "type"
556 | template_operator_new function template for operator new(size_t) is not allowed
558 | bad_member_type_in_ptr_to_member pointer to member of type "type" is not allowed
559 | ellipsis_on_operator_function ellipsis is not allowed in operator function parameter list
560 | unimplemented_keyword "entity" is reserved for future use as a keyword
561 | cl_invalid_macro_definition invalid macro definition: xxxx
562 | cl_invalid_macro_undefinition invalid macro undefinition: xxxx
565 | cl_il_file_must_be_specified IL file name must be specified if input is
570 | cl_error_in_debug_option_argument error in debug option argument
571 | cl_invalid_option invalid option: xxxx
572 | cl_back_end_requires_il_file back end requires name of IL file
573 | cl_could_not_open_il_file could not open IL file xxxx
574 | cl_invalid_number invalid number: xxxx
575 | cl_incorrect_host_id incorrect host CPU id
576 | cl_invalid_instantiation_mode invalid instantiation mode: xxxx
578 | cl_invalid_error_limit invalid error limit: xxxx
585 | cl_vtbl_option_only_in_cplusplus virtual function tables can only be suppressed when compiling C++
586 | cl_anachronism_option_only_in_cplusplus anachronism option can be used only when compiling C++
587 | cl_instantiation_option_only_in_cplusplus instantiation mode option can be used only when compiling C++
588 | cl_auto_instantiation_option_only_in_cplusplus automatic instantiation mode can be used only when compiling C++
589 | cl_implicit_inclusion_option_only_in_cplusplus implicit template inclusion mode can be used only when compiling C++
590 | cl_exceptions_option_only_in_cplusplus exception handling option can be used only when compiling C++
591 | cl_strict_mode_incompatible_with_pcc strict mode is incompatible with K&R mode
592 | cl_strict_mode_incompatible_with_cfront strict mode is incompatible with cfront mode
593 | cl_missing_source_file_name missing source file name
594 | cl_output_file_incompatible_with_multiple_inputs output files may not be specified when compiling several input files
595 | cl_too_many_arguments too many arguments on command line
596 | cl_no_output_file_needed an output file was specified, but none is needed
597 | cl_il_display_requires_il_file_name IL display requires name of IL file
598 | void_template_parameter a template parameter may not have void type
599 | too_many_unused_instantiations excessive recursive instantiation of entity-kind "entity" due to instantiate-all mode


Diagnostics 600 to 699

600 | cl_strict_mode_incompatible_with_anachronisms strict mode is incompatible with allowing anachronisms
601 | void_throw a throw expression may not have void type
602 | cl_tim_local_conflicts_with_auto_instantiation local instantiation mode is incompatible with automatic instantiation
603 | abstract_class_param_type parameter of abstract class type "type" is not allowed:
604 | array_of_abstract_class array of abstract class "type" is not allowed:
605 | float_template_parameter floating-point template parameter is nonstandard
606 | pragma_must_precede_declaration this pragma must immediately precede a declaration
607 | pragma_must_precede_statement this pragma must immediately precede a statement
608 | pragma_must_precede_decl_or_stmt this pragma must immediately precede a declaration or statement
609 | pragma_may_not_be_used_here this kind of pragma may not be used here
611 | partial_override overloaded virtual function "entity" is only partially overridden in entity-kind "entity"
612 | specialization_of_called_inline_template_function specific definition of inline template function must precede its first use
613 | cl_invalid_error_tag invalid error tag in diagnostic control option: xxxx
614 | cl_invalid_error_number invalid error number in diagnostic control option: xxxx
617 | ptr_to_member_cast_to_ptr_to_function pointer-to-member-function cast to pointer to function
618 | no_named_fields struct or union declares no named members
619 | nonstd_unnamed_field nonstandard unnamed field GHS Standard Mode enables this diagnostic.
620 | nonstd_unnamed_member nonstandard unnamed member GHS Standard Mode enables this diagnostic.
624 | not_a_type_name "xxxx" is not a type name
631 | unable_to_get_mapped_memory unable to obtain mapped memory
641 | cannot_chdir "xxxx" is not a valid directory
642 | cannot_build_temp_file_name cannot build temporary file name
643 | restrict_not_allowed "restrict" is not allowed
644 | restrict_pointer_to_function a pointer or reference to function type may not be qualified by "restrict"
646 | calling_convention_not_allowed a calling convention modifier may not be specified here
647 | conflicting_calling_conventions conflicting calling convention modifiers
648 | cl_strict_mode_incompatible_with_microsoft strict mode is incompatible with Microsoft mode
649 | cl_cfront_incompatible_with_microsoft cfront mode is incompatible with Microsoft mode
650 | calling_convention_ignored calling convention specified here is ignored
651 | calling_convention_may_not_precede_nested_declarator a calling convention may not be followed by a nested declarator
652 | calling_convention_ignored_for_type calling convention is ignored for this type
654 | decl_modifiers_incompatible_with_previous_decl declaration modifiers are incompatible with previous declaration
655 | decl_modifiers_invalid_for_this_decl the modifier "xxxx" is not allowed on this declaration
656 | branch_into_try_block transfer of control into a try block
657 | incompatible_inline_specifier_on_specific_decl inline specification is incompatible with previous "entity" (declared at line xxxx)
658 | template_missing_closing_brace closing brace of template definition not found
659 | cl_wchar_t_option_only_in_cplusplus wchar_t keyword option can be used only when compiling C++
660 | bad_pack_alignment invalid packing alignment value
661 | exp_int_constant expected an integer constant
662 | call_of_pure_virtual call of pure virtual function
663 | bad_ident_string invalid source file identifier string
664 | template_friend_definition_not_allowed a class template cannot be defined in a friend declaration
665 | asm_not_allowed "asm" is not allowed
666 | bad_asm_function_def "asm" must be used with a function definition
667 | nonstd_asm_function "asm" function is nonstandard
668 | nonstd_ellipsis_only_param ellipsis with no explicit parameters is nonstandard
669 | nonstd_address_of_ellipsis "&…" is nonstandard
670 | bad_address_of_ellipsis invalid use of "&…"
672 | const_volatile_ref_init_anachronism temporary used for initial value of reference to const volatile (anachronism)
673 | bad_const_volatile_ref_init a reference of type "type" cannot be initialized with a value of type "type"
674 | const_volatile_ref_init_from_rvalue initial value of reference to const volatile must be an lvalue
675 | cl_SVR4_C_option_only_in_ansi_C SVR4 C compatibility option can be used only when compiling ANSI C
676 | using_out_of_scope_declaration using out-of-scope declaration of entity-kind "entity" (declared at line xxxx)
677 | cl_strict_mode_incompatible_with_SVR4 strict mode is incompatible with SVR4 C mode
678 | cannot_inline_call call of entity-kind "entity" (declared at line xxxx) cannot be inlined
679 | cannot_inline entity-kind "entity" cannot be inlined
681 | exp_except_or_finally expected __except or __finally
682 | leave_must_be_in_try a __leave statement may only be used within a __try
688 | not_found_on_pack_alignment_stack "xxxx" not found on pack alignment stack
689 | empty_pack_alignment_stack empty pack alignment stack
690 | cl_rtti_option_only_in_cplusplus RTTI option can be used only when compiling C++
691 | inaccessible_elided_cctor entity-kind "entity" (declared at line xxxx), required for copy that was eliminated, is inaccessible
692 | uncallable_elided_cctor entity-kind "entity" (declared at line xxxx), required for copy that was eliminated, is not callable because reference parameter cannot be bound to rvalue
693 | typeid_needs_typeinfo <typeinfo> must be included before typeid is used
694 | cannot_cast_away_const xxxx cannot cast away const or other type qualifiers
695 | bad_dynamic_cast_type the type in a dynamic_cast must be a pointer or reference to a complete class type, or void *
696 | bad_ptr_dynamic_cast_operand the operand of a pointer dynamic_cast must be a pointer to a complete class type
697 | bad_ref_dynamic_cast_operand the operand of a reference dynamic_cast must be an lvalue of a complete class type
698 | dynamic_cast_operand_must_be_polymorphic the operand of a runtime dynamic_cast must have a polymorphic class type
699 | cl_bool_option_only_in_cplusplus bool option can be used only when compiling C++


Diagnostics 700 to 799

701

array_type_not_allowed

an array type is not allowed here

702

exp_assign

expected an "="

704

redeclaration_of_condition_decl_name

"xxxx", declared in condition, may not be redeclared in this scope

705

default_template_arg_not_allowed

default template arguments are not allowed for function templates

706

exp_comma_or_gt

expected a "," or ">"

707

missing_template_param_list

expected a template parameter list

708

incr_of_bool_deprecated

incrementing a bool value is deprecated

709

bool_type_not_allowed

bool type is not allowed

710

base_class_offset_too_large

offset of base class "entity" within class "entity" is too large

711

expr_not_bool

expression must have bool type (or be convertible to bool)

712

cl_array_new_and_delete_option_only_in_cplusplus

array new and delete option can be used only when compiling C++

713

based_requires_variable_name

entity-kind "entity" is not a variable name

714

based_not_allowed_here

__based modifier is not allowed here

715

based_not_followed_by_star

__based does not precede a pointer operator, __based ignored

716

based_var_must_be_ptr

variable in __based modifier must have pointer type

717

bad_const_cast_type

the type in a const_cast must be a pointer, reference, or pointer to member to an object type

718

bad_const_cast

a const_cast can only adjust type qualifiers; it cannot change the underlying type

719

mutable_not_allowed

mutable is not allowed

720

cannot_change_access

redeclaration of entity-kind "entity" is not allowed to alter its access

721

nonstd_printf_format_string

nonstandard format string conversion

722

probable_inadvertent_lbracket_digraph

use of alternative token "<:" appears to be unintended

723

probable_inadvertent_sharp_digraph

use of alternative token "%:" appears to be unintended

724

namespace_def_not_allowed

namespace definition is not allowed

725

missing_namespace_name

name must be a namespace name

726

namespace_alias_def_not_allowed

namespace alias definition is not allowed

727

namespace_qualified_name_required

namespace-qualified name is required

728

namespace_name_not_allowed

a namespace name is not allowed

729

bad_combination_of_dll_attributes

invalid combination of DLL attributes

730

sym_not_a_class_template

entity-kind "entity" is not a class template

731

array_of_incomplete_type

array with incomplete element type is nonstandard

732

allocation_operator_in_namespace

allocation operator may not be declared in a namespace

733

deallocation_operator_in_namespace

deallocation operator may not be declared in a namespace

734

conflicts_with_using_decl

entity-kind "entity" conflicts with using-declaration of entity-kind "entity"

735

using_decl_conflicts_with_prev_decl

using-declaration of entity-kind "entity" conflicts with entity-kind "entity" (declared at line xxxx)

736

cl_namespaces_option_only_in_cplusplus

namespaces option can be used only when compiling C++

737

useless_using_declaration

using-declaration ignored -- it refers to the current namespace

738

class_qualified_name_required

a class-qualified name is required

742

not_an_actual_member

entity-kind "entity" has no actual member "xxxx"

744

mem_attrib_incompatible

incompatible memory attributes specified

745

mem_attrib_ignored

memory attribute ignored

746

mem_attrib_may_not_precede_nested_declarator

memory attribute may not be followed by a nested declarator

747

dupl_mem_attrib

memory attribute specified more than once

748

dupl_calling_convention

calling convention specified more than once

749

type_qualifier_not_allowed

a type qualifier is not allowed

750

template_instance_already_used

entity-kind "entity" (declared at line xxxx) was used before its template was declared

751

static_nonstatic_with_same_param_types

static and nonstatic member functions with same parameter types cannot be overloaded

752

no_prior_declaration

no prior declaration of entity-kind "entity"

753

template_id_not_allowed

a template-id is not allowed

754

class_qualified_name_not_allowed

a class-qualified name is not allowed

755

bad_scope_for_redeclaration

entity-kind "entity" may not be redeclared in the current scope

756

qualifier_in_namespace_member_decl

qualified name is not allowed in namespace member declaration

757

sym_not_a_type_name

entity-kind "entity" is not a type name

758

explicit_instantiation_not_in_namespace_scope

explicit instantiation is not allowed in the current scope

759

bad_scope_for_explicit_instantiation

entity-kind "entity" cannot be explicitly instantiated in the current scope

760

multiple_explicit_instantiations

entity-kind "entity" explicitly instantiated more than once

761

typename_not_in_template

typename may only be used within a template

762

cl_special_subscript_cost_option_only_in_cplusplus

special_subscript_cost option can be used only when compiling C++

763

cl_typename_option_only_in_cplusplus

typename option can be used only when compiling C++

764

cl_implicit_typename_option_only_in_cplusplus

implicit typename option can be used only when compiling C++

765

nonstd_character_at_start_of_macro_def

nonstandard character at start of object-like macro definition

766

exception_spec_override_incompat

exception specification for virtual entity-kind "entity" is incompatible with that of overridden entity-kind "entity"

767

pointer_conversion_loses_bits

conversion from pointer to smaller integer

768

generated_exception_spec_override_incompat

exception specification for implicitly declared virtual entity-kind "entity" is incompatible with that of overridden entity-kind "entity"

769

implicit_call_of_ambiguous_name

"entity", implicitly called from entity-kind "entity", is ambiguous

770

cl_explicit_option_only_in_cplusplus

option "explicit" can be used only when compiling C++

771

explicit_not_allowed

"explicit" is not allowed

772

conflicts_with_predeclared_type_info

declaration conflicts with "xxxx" (reserved class name)

The compiler emits this non-discretionary diagnostic whenever it encounters a definition of class std::type_info outside the standard header <typeinfo>. Instances of this class are created and exposed to the programmer via the C++ language operator typeid; therefore, a program that defines its own, incompatible version of class std::type_info may exhibit undefined behavior.

To define your own version of class std::type_info, but suppress this diagnostic, precede the class definition with #pragma define_type_info.

A correct definition of this class must preserve the member and vtable layout assumed by the compiler's typeid machinery. The following example is an acceptable definition:

namespace std {
    #pragma define_type_info
    class type_info {
      virtual ~type_info();
    };
}

We recommend that you do not attempt to provide your own definition of this class. However, you might see this error if you are using standard C++ libraries other than the ones provided with your Green Hills compiler distribution.

773

array_member_initialization

only "()" is allowed as initializer for array entity-kind "entity"

774

virtual_function_template

"virtual" is not allowed in a function template declaration

775

anon_union_class_member_template

invalid anonymous union -- class member template is not allowed

776

template_depth_mismatch

template nesting depth does not match the previous declaration of entity-kind "entity"

777

multiple_template_decls_not_allowed

this declaration cannot have multiple "template <…>" clauses

778

cl_old_for_init_option_only_in_cplusplus

option to control the for-init scope can be used only when compiling C++

779

redeclaration_of_for_init_decl_name

"xxxx", declared in for-loop initialization, may not be redeclared in this scope

780

hidden_by_old_for_init

reference is to entity-kind "entity" (declared at line xxxx) -- under old for-init scoping rules it would have been entity-kind "entity" (declared at line xxxx)

781

cl_for_init_diff_warning_option_only_in_cplusplus

option to control warnings on for-init differences can be used only when compiling C++

782

unnamed_class_virtual_function_def_missing

definition of virtual entity-kind "entity" is required here

783

svr4_token_pasting_comment

empty comment interpreted as token-pasting operator "##"

784

storage_class_in_friend_decl

a storage class is not allowed in a friend declaration

785

templ_param_list_not_allowed

template parameter list for "entity" is not allowed in this declaration

786

bad_member_template_sym

entity-kind "entity" is not a valid class member template

787

bad_member_template_decl

not a valid member class or function template declaration

788

specialization_follows_param_list

a template declaration containing a template parameter list may not be followed by an explicit specialization declaration

789

specialization_of_referenced_template

explicit specialization of entity-kind "entity" must precede the first use of entity-kind "entity"

790

explicit_specialization_not_in_namespace_scope

explicit specialization is not allowed in the current scope

791

partial_specialization_not_allowed

partial specialization of entity-kind "entity" is not allowed

792

entity_cannot_be_specialized

entity-kind "entity" is not an entity that can be explicitly specialized

793

specialization_of_referenced_entity_pos

explicit specialization of entity-kind "entity" must precede its first use (at line xxxx)

794

template_param_in_elab_type

template parameter "xxxx" may not be used in an elaborated type specifier

795

old_specialization_not_allowed

specializing entity-kind "entity" requires "template<>" syntax

798

cl_old_specializations_option_only_in_cplusplus

option "old_specializations" can be used only when compiling C++

799

nonstd_old_specialization

specializing entity-kind "entity" without "template<>" syntax is nonstandard


Diagnostics 800 to 899

800 | bad_linkage_for_decl this declaration may not have extern "C" linkage
801 | not_a_template_name "xxxx" is not a class or function template name in the current scope
802 | nonstd_default_arg_on_function_template_redecl specifying a default argument when redeclaring an unreferenced function template is nonstandard
803 | default_arg_on_function_template_not_allowed specifying a default argument when redeclaring an already referenced function template is not allowed
804 | pm_derived_class_from_virtual_base cannot convert pointer to member of base class "type" to pointer to member of derived class "type" -- base class is virtual
805 | bad_exception_specification_for_specialization exception specification is incompatible with that of entity-kind "entity" (declared at line xxxx):
806 | omitted_exception_specification_on_specialization allowing all exceptions is incompatible with entity-kind "entity" (declared at line xxxx)
807 | unexpected_end_of_default_arg unexpected end of default argument expression
808 | default_init_of_reference default-initialization of reference is not allowed
809 | uninitialized_field_with_const_member uninitialized entity-kind "entity" has a const member
810 | uninitialized_base_class_with_const_member uninitialized base class "type" has a const member
811 | missing_default_constructor_on_const const entity-kind "entity" requires an initializer -- class "type" has no user-provided default constructor
812 | missing_default_constructor_on_unnamed_const const object requires an initializer -- class "type" has no user-provided default constructor
813 | cl_impl_extern_c_conv_option_only_in_cplusplus option "implicit_extern_c_type_conversion" can be used only when compiling C++
814 | cl_strict_mode_incompatible_with_long_preserving strict mode is incompatible with long preserving rules
815 | useless_type_qualifier_on_return_type type qualifier on return type is meaningless
816 | type_qualifier_on_void_return_type in a function definition a type qualifier on a "void" return type is not allowed
817 | static_data_member_not_allowed static data member declaration is not allowed in this class
818 | invalid_declaration template instantiation resulted in an invalid function declaration
819 | ellipsis_not_allowed "…" is not allowed
820 | cl_extern_inline_option_only_in_cplusplus option "extern_inline" can be used only when compiling C++
821 | extern_inline_never_defined extern inline entity-kind "entity" was referenced but not defined
822 | invalid_destructor_name invalid destructor name for type "type"
824 | ambiguous_destructor destructor reference is ambiguous -- both entity-kind "entity" and entity-kind "entity" could be used
825 | virtual_inline_never_defined virtual inline entity-kind "entity" was never defined
826 | unreferenced_function_param entity-kind "entity" was never referenced
827 | union_already_initialized only one member of a union may be specified in a constructor initializer list
828 | no_array_new_and_delete_support support for "new[]" and "delete[]" is disabled
829 | double_for_long_double "double" used for "long double" in generated C code
830 | no_corresponding_delete entity-kind "entity" has no corresponding operator delete (to be called if an exception is thrown during initialization of an allocated object)
831 | useless_placement_delete support for placement delete is disabled
832 | no_appropriate_delete no appropriate operator delete is visible
833 | ptr_or_ref_to_incomplete_type pointer or reference to incomplete type is not allowed
834 | bad_partial_specialization invalid partial specialization -- entity-kind "entity" is already fully specialized
835 | incompatible_exception_specs incompatible exception specifications
836 | returning_ref_to_local_variable returning reference to local variable
837 | nonstd_implicit_int omission of explicit type is nonstandard ("int" assumed) GHS Standard Mode enables this diagnostic.
838 | ambiguous_partial_spec more than one partial specialization matches the template argument list of entity-kind "entity"
840 | partial_spec_is_primary_template a template argument list is not allowed in a declaration of a primary template
841 | default_not_allowed_on_partial_spec partial specializations may not have default template arguments
842 | not_used_in_partial_spec_arg_list entity-kind "entity" is not used in or cannot be deduced from the template argument list of entity-kind "entity"
844 | partial_spec_arg_depends_on_templ_param the template argument list of the partial specialization includes a nontype argument whose type depends on a template parameter
845 | partial_spec_after_instantiation this partial specialization would have been used to instantiate entity-kind "entity"
846 | partial_spec_after_instantiation_ambiguous this partial specialization would have made the instantiation of entity-kind "entity" ambiguous
847 | expr_not_integral_or_enum expression must have integral or enum type
848 | expr_not_arithmetic_or_enum expression must have arithmetic or enum type
849 | expr_not_arithmetic_or_enum_or_pointer expression must have arithmetic, enum, or pointer type
850 | cast_not_integral_or_enum type of cast must be integral or enum
851 | cast_not_arithmetic_or_enum_or_pointer type of cast must be arithmetic, enum, or pointer
852 | expr_not_object_pointer expression must be a pointer to a complete object type
854 | partial_spec_nontype_expr a partial specialization nontype argument must be the name of a nontype parameter or a constant
855 | different_return_type_on_virtual_function_override return type is not identical to return type "type" of overridden virtual function "entity"
856 | cl_guiding_decls_option_only_in_cplusplus option "guiding_decls" can be used only when compiling C++
857 | member_partial_spec_not_in_namespace a partial specialization of a class template must be declared in the namespace of which it is a member
858 | pure_virtual_function entity-kind "entity" is a pure virtual function
859 | no_overrider_for_pure_virtual_function pure virtual entity-kind "entity" has no overrider
860 | decl_modifiers_ignored __declspec attributes ignored
861 | invalid_char invalid character in input line
862 | incomplete_return_type function returns incomplete type "type"
863 | local_pragma_pack effect of this "#pragma pack" directive is local to entity-kind "entity"
864 | not_a_template xxxx is not a template
865 | friend_partial_specialization a friend declaration may not declare a partial specialization
866 | exception_specification_ignored exception specification ignored
867 | unexpected_type_for_size_t declaration of "size_t" does not match the expected type "type"
868 | exp_gt_not_shift_right space required between adjacent ">" delimiters of nested template argument lists (">>" is the right shift operator)
869 | bad_multibyte_char_locale could not set locale "xxxx" to allow processing of multibyte characters
870 | bad_multibyte_char invalid multibyte character sequence
871 | bad_type_from_instantiation template instantiation resulted in unexpected function type of "type" (the meaning of a name may have changed since the template declaration -- the type of the template is "type")
872 | ambiguous_guiding_decl ambiguous guiding declaration -- more than one function template "entity" matches type "type"
873 | non_integral_operation_in_templ_arg non-integral operation not allowed in nontype template argument
874 | cl_embedded_cplusplus_option_only_in_cplusplus option "embedded_c++" can be used only when compiling C++
875 | templates_in_embedded_cplusplus Embedded C++ does not support templates
876 | exceptions_in_embedded_cplusplus Embedded C++ does not support exception handling
877 | namespaces_in_embedded_cplusplus Embedded C++ does not support namespaces
878 | rtti_in_embedded_cplusplus Embedded C++ does not support run-time type information
879 | new_cast_in_embedded_cplusplus Embedded C++ does not support the new cast syntax
880 | using_decl_in_embedded_cplusplus Embedded C++ does not support using-declarations
881 | mutable_in_embedded_cplusplus Embedded C++ does not support "mutable"
882 | multiple_inheritance_in_embedded_cplusplus Embedded C++ does not support multiple or virtual inheritance
883 | cl_invalid_microsoft_version invalid Microsoft version number: xxxx
884 | inheritance_kind_already_set pointer-to-member representation "xxxx" has already been set for entity-kind "entity"
885 | bad_constructor_type "type" cannot be used to designate constructor for "type"
886 | bad_suffix invalid suffix on integral constant
887 | uuidof_requires_uuid_class_type operand of __uuidof must have a class or enum type for which __declspec(uuid("…")) has been specified
888 | bad_uuid_string invalid GUID string in __declspec(uuid("…"))
889 | cl_vla_option_only_in_C option "vla" can be used only when compiling C
890 | vla_with_unspecified_bound_not_allowed variable length array with unspecified bound is not allowed
891 | explicit_template_args_not_allowed an explicit template argument list is not allowed on this declaration
892 | variably_modified_type_not_allowed an entity with linkage cannot have a type involving a variable length array
893 | vla_is_not_auto a variable length array cannot have static storage duration
894 | sym_not_a_template entity-kind "entity" is not a template
896 | expected_template_arg expected a template argument
898 | no_params_with_class_or_enum_type nonmember operator requires a parameter with class or enum type
899 | cl_enum_overloading_option_only_in_cplusplus option "enum_overloading" can be used only when compiling C++


Diagnostics 900 to 999

901 | destructor_qualifier_type_mismatch qualifier of destructor name "type" does not match type "type"
902 | type_qualifier_ignored type qualifier ignored
903 | cl_nonstandard_qualifier_deduction_option_only_in_cplusplus option "nonstd_qualifier_deduction" can be used only when compiling C++
904 | cannot_define_dllimport_function a function declared "dllimport" may not be defined
905 | bad_declspec_property incorrect property specification; correct form is __declspec(property(get=name1,put=name2))
906 | dupl_get_or_put property has already been specified
907 | declspec_property_not_allowed __declspec(property) is not allowed on this declaration
908 | no_get_property member is declared with __declspec(property), but no "get" function was specified
909 | get_property_function_missing the __declspec(property) "get" function "xxxx" is missing
910 | no_put_property member is declared with __declspec(property), but no "put" function was specified
911 | put_property_function_missing the __declspec(property) "put" function "xxxx" is missing
912 | dual_lookup_ambiguous_name ambiguous class member reference -- entity-kind "entity" (declared at line xxxx) used in preference to entity-kind "entity" (declared at line xxxx)
916 | pm_virtual_base_from_derived_class cannot convert pointer to member of derived class "type" to pointer to member of base class "type" -- base class is virtual
917 | cl_invalid_instantiation_directory invalid directory for instantiation files: xxxx
918 | cl_one_instantiation_per_object_option_only_in_cplusplus option "one_instantiation_per_object" can be used only when compiling C++
921 | cl_ii_file_name_incompatible_with_multiple_inputs an instantiation information file name may not be specified when compiling several input files
922 | cl_one_instantiation_per_object_incompatible_with_multiple_inputs option "one_instantiation_per_object" may not be used when compiling several input files
923 | cl_ambiguous_option more than one command line option matches the abbreviation "--xxxx":
925 | cv_qualified_function_type type qualifiers on function types are ignored
927 | cl_late_tiebreaker_option_only_in_cplusplus late/early tiebreaker option can be used only when compiling C++
928 | bad_va_start incorrect use of va_start
929 | bad_va_arg incorrect use of va_arg
930 | bad_va_end incorrect use of va_end
931 | cl_pending_instantiations_option_only_in_cplusplus pending instantiations option can be used only when compiling C++
932 | cl_invalid_import_directory invalid directory for #import files: xxxx
933 | cl_import_only_in_microsoft an import directory can be specified only in Microsoft mode
934 | ref_not_allowed_in_union a member with reference type is not allowed in a union
935 | typedef_not_allowed "typedef" may not be specified here
936 | redecl_changes_access redeclaration of entity-kind "entity" alters its access
937 | qualified_name_required a class or namespace qualified name is required
938 | implicit_int_on_main return type "int" omitted in declaration of function "main" GHS Standard Mode enables this diagnostic.
939 | invalid_inheritance_kind_for_class pointer-to-member representation "xxxx" is too restrictive for entity-kind "entity"
940 | implicit_return_from_non_void_function missing return statement at end of non-void entity-kind "entity" GHS Standard Mode enables this diagnostic.
941 | duplicate_using_decl duplicate using-declaration of "entity" ignored
942 | unsigned_enum_bit_field_with_signed_enumerator enum bit fields are always unsigned, but enum "type" includes negative enumerator
943 | cl_class_name_injection_option_only_in_cplusplus option "class_name_injection" can be used only when compiling C++
944 | cl_arg_dependent_lookup_option_only_in_cplusplus option "arg_dep_lookup" can be used only when compiling C++
945 | cl_friend_injection_option_only_in_cplusplus option "friend_injection" can be used only when compiling C++
946 | invalid_name_after_template name following "template" must be a template
948 | local_class_friend_requires_prior_decl nonstandard local-class friend declaration -- no prior declaration in the enclosing scope
949 | nonstd_default_arg specifying a default argument on this declaration is nonstandard
950 | cl_nonstd_using_decl_option_only_in_cplusplus option "nonstd_using_decl" can be used only when compiling C++
951 | bad_return_type_on_main return type of function "main" must be "int"
952 | template_parameter_has_class_type a nontype template parameter may not have class type
953 | default_arg_on_member_decl a default template argument cannot be specified on the declaration of a member of a class template outside of its class
954 | return_from_ctor_function_try_block_handler a return statement is not allowed in a handler of a function try block of a constructor
955 | no_ordinary_and_extended_designators ordinary and extended designators cannot be combined in an initializer designation
956 | no_negative_designator_range the second subscript must not be smaller than the first
958 | cl_extended_designators_option_only_in_C option "extended_designators" can be used only when compiling C
959 | extra_bits_ignored declared size for bit field is larger than the size of the bit field type; truncated to xxxx bits
960 | constructor_type_mismatch type used as constructor name does not match type "type"
961 | type_with_no_linkage_in_var_with_linkage use of a type with no linkage to declare a variable with linkage
962 | type_with_no_linkage_in_function use of a type with no linkage to declare a function
963 | return_type_on_constructor return type may not be specified on a constructor
964 | return_type_on_destructor return type may not be specified on a destructor
965 | malformed_universal_character incorrectly formed universal character name
966 | invalid_UCN universal character name specifies an invalid character
967 | UCN_names_basic_char a universal character name cannot designate a character in the basic character set
968 | invalid_identifier_UCN this universal character is not allowed in an identifier
969 | VA_ARGS_not_allowed the identifier __VA_ARGS__ can only appear in the replacement lists of variadic macros
970 | friend_qualification_ignored the qualifier on this friend declaration is ignored
971 | no_range_designator_with_dynamic_init array range designators cannot be applied to dynamic initializers
972 | property_name_not_allowed property name cannot appear here
973 | inline_qualifier_ignored "inline" used as a function qualifier is ignored
974 | cl_compound_literals_option_only_in_C option "compound_literals" can be used only when compiling C
975 | vla_not_allowed a variable-length array type is not allowed
976 | bad_integral_compound_literal a compound literal is not allowed in an integral constant expression
977 | bad_compound_literal_type a compound literal of type "type" is not allowed
978 | friend_template_in_local_class a template friend declaration cannot be declared in a local class
979 | ambiguous_question_operator ambiguous "?" operation: second operand of type "type" can be converted to third operand type "type", and vice versa
980 | bad_call_of_class_object call of an object of a class type without appropriate operator() or conversion functions to pointer-to-function type
982 | ambiguous_class_call there is more than one way an object of type "type" can be called for the argument list:
983 | similar_typedef typedef name has already been declared (with similar type)
984 | no_internal_linkage_for_new_or_delete operator new and operator delete cannot be given internal linkage
985 | no_mutable_allowed_on_anonymous_union storage class "mutable" is not allowed for anonymous unions
987 | abstract_class_catch_type abstract class type "type" is not allowed as catch type:
988 | bad_qualified_function_type a qualified function type cannot be used to declare a nonmember function or a static member function
989 | bad_qualified_function_type_parameter a qualified function type cannot be used to declare a parameter
990 | ptr_or_ref_to_qualified_function_type cannot create a pointer or reference to qualified function type
991 | nonstd_braces extra braces are nonstandard GHS Standard Mode enables this diagnostic.
992 | bad_cmd_line_macro invalid macro definition: xxxx
993 | nonstandard_ptr_minus_ptr subtraction of pointer types "type" and "type" is nonstandard
994 | empty_template_param_list an empty template parameter list is not allowed in a template template parameter declaration
995 | exp_class expected "class"
996 | struct_not_allowed the "struct" keyword may not be used when declaring a template template parameter
997 | virtual_function_decl_hidden entity-kind "entity" is hidden by "entity" -- virtual function override intended?
998 | no_qualified_friend_definition a qualified name is not allowed for a friend declaration that is a function definition
999 | not_compatible_with_templ_templ_param entity-kind "entity" is not compatible with entity-kind "entity"


Diagnostics 1000 to 1099

1000 | storage_class_requires_function_or_variable a storage class may not be specified here
1001 | member_using_must_be_visible_in_direct_base class member designated by a using-declaration must be visible in a direct base class
1003 | cl_sun_incompatible_with_cfront Sun mode is incompatible with cfront mode
1004 | cl_strict_mode_incompatible_with_sun strict mode is incompatible with Sun mode
1005 | cl_sun_mode_only_in_cplusplus Sun mode is only allowed when compiling C++
1006 | template_template_param_same_name_as_templ_param a template template parameter cannot have the same name as one of its template parameters
1007 | recursive_def_arg_instantiation recursive instantiation of default argument
1009 | bad_template_name entity-kind "entity" is not an entity that can be defined
1010 | destructor_name_must_be_qualified destructor name must be qualified
1011 | no_typename_in_friend_class_decl friend class name may not be introduced with "typename"
1012 | no_ctor_or_dtor_using_declaration a using-declaration may not name a constructor or destructor
1013 | friend_is_nonreal_template a qualified friend template declaration must refer to a specific previously declared template
1014 | bad_class_template_decl invalid specifier in class template declaration
1015 | simple_incompatible_param argument is incompatible with formal parameter
1016 | cl_dep_name_option_only_in_cplusplus option "dep_name" can be used only when compiling C++
1017 | op_arrow_loop loop in sequence of "operator->" functions starting at class "type"
1018 | not_a_member_class entity-kind "entity" has no member class "xxxx"
1019 | name_not_class_in_file_scope the global scope has no class named "xxxx"
1020 | recursive_inst_of_templ_default_arg recursive instantiation of template default argument
1021 | no_access_or_using_decl_in_union access declarations and using-declarations cannot appear in unions
1022 | not_class_member "entity" is not a class member
1023 | nonstd_const_member_decl_not_allowed nonstandard member constant declaration is not allowed
1024 | cl_ignore_std_option_only_in_cplusplus option "ignore_std" can be used only when compiling C++
1025 | cl_parse_nonclass_templates_option_only_in_cplusplus option "parse_templates" can be used only when compiling C++
1026 | cl_dep_name_requires_parse_nonclass_templates option "dep_name" cannot be used with "no_parse_templates"
1027 | cl_incompatible_language_modes language modes specified are incompatible
1028 | invalid_nested_class_redecl invalid redeclaration of nested class
1029 | flexible_array_member_not_allowed type containing an unknown-size array is not allowed
1030 | static_variable_in_inline_function a variable with static storage duration cannot be defined within an inline function
1031 | bad_linkage_of_ref_within_inline_function an entity with internal linkage cannot be referenced within an inline function with external linkage
1032 | type_generic_function_mismatch argument type "type" does not match this type-generic function macro
1034 | friend_cannot_add_default_arguments friend declaration cannot add default arguments to previous declaration
1035 | cannot_be_declared_in_scope entity-kind "entity" cannot be declared in this scope
1036 | id_can_only_appear_in_function the reserved identifier "xxxx" may only be used inside a function
1037 | invalid_identifier_start_UCN this universal character cannot begin an identifier
1038 | exp_string_literal expected a string literal
1039 | unrecognized_stdc_pragma unrecognized STDC pragma
1040 | bad_stdc_pragma_arg expected "ON", "OFF", or "DEFAULT"
1041 | stdc_pragma_not_allowed_here a STDC pragma may only appear between declarations in the global scope or before any statements or declarations in a block scope
1042 | bad_va_copy incorrect use of va_copy
1043 | only_applies_to_float_types xxxx can only be used with floating-point types
1044 | complex_type_not_allowed complex type is not allowed
1045 | invalid_designator_kind invalid designator kind
1046 | inexact_fp_conversion floating-point value cannot be represented exactly
1047 | bad_complex_operation_result complex floating-point operation result is out of range
1048 | real_imaginary_conversion conversion between real and imaginary yields zero
1049 | cannot_initialize_flexible_array_member an initializer cannot be specified for a flexible array member
1050 | imaginary_times_assign imaginary *= imaginary sets the left-hand operand to zero
1051 | undeclared_parameter standard requires that entity-kind "entity" be given a type by a subsequent declaration ("int" assumed)
1052 | inline_never_defined a definition is required for inline entity-kind "entity"
1053 | conversion_to_pointer_loses_bits conversion from integer to smaller pointer
1054 | missing_floating_point_type a floating-point type must be included in the type specifier for a _Complex or _Imaginary type
1055 | type_decl_in_anon_union types cannot be declared in anonymous unions
1056 | returning_ptr_to_local_variable returning pointer to local variable GHS Standard Mode enables this diagnostic.
1057 | returning_ptr_to_local_temp returning pointer to local temporary
1058 | cl_export_template_option_only_in_cplusplus option "export" can be used only when compiling C++
1059 | cl_export_template_requires_dep_name option "export" cannot be used with "no_dep_name"
1060 | cl_export_template_requires_no_implicit_include option "export" cannot be used with "implicit_include"
1061 | corresp_decl_incompatible declaration of entity-kind "entity" is incompatible with a declaration in another translation unit
1062 | corresp_decl_at the other declaration is at line xxxx
1065 | field_cannot_involve_vla_type a field declaration cannot have a type involving a variable length array
1066 | entity_differs_in_other_trans_unit declaration of entity-kind "entity" had a different meaning during compilation of "xxxx"
1067 | exp_template expected "template"
1068 | export_on_instantiation "export" cannot be used on an explicit instantiation
1069 | bad_decl_for_export "export" cannot be used on this declaration
1070 | exported_in_unnamed_namespace a member of an unnamed namespace cannot be declared "export"
1071 | export_after_definition a template cannot be declared "export" after it has been defined
1072 | labeled_declaration a declaration cannot have a label
1073 | no_export_support support for exported templates is disabled
1075 | entity_defined_in_other_trans_unit entity-kind "entity" already defined during compilation of "xxxx"
1076 | entity_defined_twice entity-kind "entity" already defined in another translation unit
1077 | based_var_cannot_be_local a nonstatic local variable may not be used in a __based specification
1078 | cl_list_make_dependencies_incompatible_with_multiple_trans_units the option to list makefile dependencies may not be specified when compiling more than one translation unit
1080 | cl_pp_output_incompatible_with_multiple_trans_units the option to generate preprocessed output may not be specified when compiling more than one translation unit
1081 | field_name_conflicts_with_class a field with the same name as its class cannot be declared in a class with a user-declared constructor
1082 | cl_implicit_include_incompatible_with_multiple_trans_units "implicit_include" cannot be used when compiling more than one translation unit
1083 | corrupted_export_template_file exported template file "xxxx" is corrupted
1084 | exported_instantiation_and_specialized entity-kind "entity" cannot be instantiated -- it has been explicitly specialized in the translation unit containing the exported definition
1086 | unqual_named_function_with_qual_object the object has type qualifiers that are not compatible with the member entity-kind "entity"
1087 | no_matching_function_due_to_selector no instance of entity-kind "entity" matches the argument list and object (the object has type qualifiers that prevent a match)
1088 | mode_incompatible_with_type an attribute specifies a mode incompatible with "type"
1089 | no_type_of_specified_width there is no type with the width specified
1090 | bad_attribute_alignment invalid alignment value specified by attribute
1091 | attribute_does_not_apply_to_type invalid attribute for "type"
1092 | attribute_does_not_apply invalid attribute for entity-kind "entity"
1094 | arguments_provided_for_attribute attribute "xxxx" does not take arguments
1096 | exp_attribute_name expected an attribute name
1097 | unrecognized_attribute unknown attribute "xxxx"
1098 | attribute_not_allowed attributes may not appear here
1099 | invalid_argument_to_attribute invalid argument to attribute "xxxx"


Diagnostics 1100 to 1199

1100 | packed_attribute_ignored_in_typedef the "packed" attribute is ignored in this context
1101 | assigned_goto_requires_void_ptr in "goto *expr", expr must have type "void *"
1102 | nonstd_assigned_goto "goto *expr" is nonstandard
1103 | nonstd_address_of_label taking the address of a label is nonstandard
1104 | cl_duplicate_file_name file name specified more than once: xxxx
1105 | warning_directive #warning directive: xxxx
1107 | transparent_type_is_not_union the "transparent_union" attribute only applies to unions, and "type" is not a union
1108 | transparent_attribute_ignored the "transparent_union" attribute is ignored on incomplete types
1109 | union_cannot_be_transparent_sym "type" cannot be transparent because entity-kind "entity" does not have the same size as the first field
1110 | union_cannot_be_transparent "type" cannot be transparent because it has a field of type "type" which is not the same size as the first field
1112 | attribute_does_not_apply_to_local_variable attribute "xxxx" does not apply to local variables
1113 | attributes_in_rout_defn attributes are not permitted in a function definition
1115 | invalid_case_range the second constant in a case range must be larger than the first
1116 | asm_name_in_rout_defn an asm name is not permitted in a function definition
1117 | asm_name_in_typedef an asm name is ignored in a typedef
1118 | bad_reg_name unknown register name "xxxx"
1120 | bad_asm_constraint_modifier unknown asm constraint modifier "xxxx"
1121 | bad_asm_constraint_letter unknown asm constraint letter "xxxx"
1122 | missing_constraint_letter asm operand has no constraint letter
1123 | asm_output_must_have_output_mod an asm output operand must have one of the '=' or '+' modifiers
1124 | asm_input_must_not_have_output_mod an asm input operand may not have the '=' or '+' modifiers
1127 | register_used_twice register "xxxx" used more than once
1128 | register_used_and_clobbered register "xxxx" is both used and clobbered
1129 | register_clobbered_twice register "xxxx" clobbered more than once
1130 | fixed_register_used register "xxxx" has a fixed purpose and may not be used in an asm statement
1131 | fixed_register_clobbered register "xxxx" has a fixed purpose and may not be clobbered in an asm statement
1132 | empty_clobbers_list an empty clobbers list must be omitted entirely
1133 | exp_asm_operand expected an asm operand
1134 | exp_asm_clobber expected a register to clobber
1135 | format_rout_not_varargs "format" attribute requires an ellipsis parameter
1136 | subst_arg_is_not_variable first substitution argument is not the first variable argument
1137 | fmt_arg_does_not_exist format argument index is greater than number of parameters
1138 | fmt_arg_is_not_string format argument does not have string type
1139 | template_not_in_template the "template" keyword used for syntactic disambiguation may only be used within a template
1142 | attr_requires_func_type attribute "xxxx" does not apply to non-function type "type"
1143 | nonobject_pointer_arithmetic arithmetic on pointer to void or function type
1144 | invalid_storage_class_in_for_init storage class must be auto or register
1145 | va_arg_would_have_been_promoted "type" would have been promoted to "type" when passed through the ellipsis parameter; use the latter type instead
1146 | not_a_base_class_member "xxxx" is not a base class member
1147 | super_after_scope __super cannot appear after "::"
1148 | super_not_in_class __super may only be used in a class scope
1149 | unqualified_super __super must be followed by "::"
1151 | mangled_name_too_long mangled name is too long
1152 | aliased_name_undeclared declaration aliased to undefined entity "xxxx"
1153 | aliased_name_bad_kind declaration does not match its alias entity-kind "entity"
1154 | alias_cannot_have_definition entity declared as alias cannot have definition
1155 | vla_size_ignored variable-length array field type will be treated as zero-length array field type
1156 | gcc_lvalue_cast_ignored nonstandard cast on lvalue ignored
1157 | cl_invalid_flag_name unrecognized flag name: xxxx
1158 | qualified_void_return_type void return type cannot be qualified
1159 | auto_ignored the auto specifier is ignored here (invalid in standard C/C++)
1160 | alignment_reduction_ignored a reduction in alignment without the "packed" attribute is ignored
1161 | corresp_member_template_is_different_kind a member template corresponding to "entity" is declared as a template of a different kind in another translation unit
1162 | excess_initializers_ignored excess initializers are ignored GHS Standard Mode enables this diagnostic.
1163 | va_start_requires_ellipsis_function va_start can appear only in a function with an ellipsis parameter
1164 | cl_short_enums_requires_gcc_mode the "short_enums" option is only valid in GNU C and GNU C++ modes
1165 | bad_export_info_file invalid export information file "xxxx" at line number xxxx
1166 | statement_expression_in_function_only statement expressions are only allowed in block scope
1168 | asm_name_on_auto_variable an asm name is ignored on a non-register automatic variable
1170 | unrecognized_upc_pragma unrecognized UPC pragma
1171 | mismatched_shared_block_size shared block size does not match one previously specified
1172 | ambiguous_block_size_spec bracketed expression is assumed to be a block size specification rather than an array dimension
1173 | shared_block_size_must_be_positive the block size of a shared array must be greater than zero
1174 | multiple_block_sizes multiple block sizes not allowed
1175 | nonshared_strict_relaxed strict or relaxed requires shared
1176 | threads_constant_not_allowed THREADS not allowed in this context
1177 | shared_block_size_too_large block size specified exceeds the maximum value of xxxx
1178 | function_returning_shared function returning shared is not allowed
1180 | shared_nonthreads_dim one dimension of an array of a shared type must be a multiple of THREADS when the number of threads is nonconstant
1181 | shared_inside_struct shared type inside a struct or union is not allowed
1182 | shared_parameter parameters may not have shared types
1183 | threads_dimension_requires_definite_block_size a dynamic THREADS dimension requires a definite block size
1184 | bad_shared_storage_class shared variables must be static or extern
1185 | nonshared_blocksizeof argument of upc_blocksizeof is a pointer to a shared type (not shared type itself)
1186 | nested_upc_forall affinity expression ignored in nested upc_forall
1187 | exit_forall branching into or out of a upc_forall loop is not allowed
1188 | bad_affinity affinity expression must have a shared type or point to a shared type
1189 | shared_affinity_type affinity has shared type (not pointer to shared)
1190 | upc_shared_void_comparison shared void* types can only be compared for equality
1191 | cl_upc_requires_ansi_c_dialect UPC mode is incompatible with C++ and K&R modes
1192 | null_char_ignored null (zero) character in input line ignored
1193 | null_char_in_string null (zero) character in string or character constant
1194 | null_char_in_header_name null (zero) character in header name
1195 | for_init_hides_declaration declaration in for-initializer hides a declaration in the surrounding scope
1196 | for_init_hidden_declaration the hidden declaration is at line xxxx
1197 | prototype_lost the prototype declaration of entity-kind "entity" (declared at line xxxx) is ignored after this unprototyped redeclaration
1199 | bad_linkage_for_redefine_extname entity-kind "entity" (declared at line xxxx) must have external C linkage


Diagnostics 1200 to 1299

1200

declaration_hides_for_init

variable declaration hides declaration in for-initializer

1201

typedef_in_elab_type

typedef "xxxx" may not be used in an elaborated type specifier

1202

call_of_zero

call of zero constant ignored

1203

handler_redeclares_parameter

parameter "xxxx" may not be redeclared in a catch clause of function try block

1204

specialization_out_of_namespace

the initial explicit specialization of entity-kind "entity" must be declared in the namespace containing the template

1205

cc_clobber_ignored

"cc" clobber ignored

1206

invalid_token_after_template

"template" must be followed by an identifier

1207

mythread_constant_not_allowed

MYTHREAD not allowed in this context

1208

bad_upc_shared_pointer_layout_qualifier

layout qualifier cannot qualify pointer to shared

1209

bad_upc_shared_array_layout_qualifier

layout qualifier cannot qualify an incomplete array

1210

decl_hides_catch_parameter

declaration of "xxxx" hides handler parameter

1211

nonstd_ignored_array_cast

nonstandard cast to array type ignored

1212

invalid_pragma_operator

this pragma cannot be used in a _Pragma operator (a #pragma directive must be used)

1213

field_uses_tail_padding

field uses tail padding of a base class

1214

gnu_may_use_bit_padding

GNU C++ compilers may use bit field padding

1215

deprecated_entity

entity-kind "entity" (declared at line xxxx) was declared deprecated

1216

field_with_asm_name_not_allowed

an asm name is not allowed on a nonstatic member declaration

1217

unrecognized_format_function_type

unrecognized format function type "xxxx" ignored

1218

base_uses_tail_padding

base class "entity" uses tail padding of base class "entity"

1219

bad_variable_for_init_priority

the "init_priority" attribute can only be used for definitions of static data members and namespace scope variables of class types

1220

init_priority_reserved

requested initialization priority is reserved for internal use

1221

hidden_anonymous_union_field

this anonymous union/struct field is hidden by entity-kind "entity" (declared at line xxxx)

1222

invalid_error_number

invalid error number

1223

invalid_error_tag

invalid error tag

1224

exp_error_argument

expected an error number or error tag

1225

size_affected_by_tail_padding

size of class is affected by tail padding

1226

nonlocal_label_reference

labels can be referenced only in function definitions

1227

branch_into_statement_expr

transfer of control into a statement expression is not allowed

1229

bad_statement_in_statement_expr

this statement is not allowed inside of a statement expression

1230

class_def_in_statement_expr

a class that is not trivially copyable cannot be defined inside a statement expression

1232

dyn_local_static_in_statement_expr

a dynamically-initialized local static variable is not allowed inside of a statement expression

1233

vla_in_statement_expr

a variable-length array is not allowed inside of a statement expression

1234

statement_expr_in_default_arg

a statement expression is not allowed inside of a default argument

1235

ptr_func_ptr_data_conv

nonstandard conversion between pointer to function and pointer to data

1236

interface_cannot_have_virtual_base

interface types cannot have virtual base classes

1237

interface_cannot_have_private_or_protected

interface types cannot specify "private" or "protected"

1238

interface_must_derive_from_interface

interface types can only derive from other interface types

1239

type_is_interface

"type" is an interface type

1240

interface_cannot_have_typedef

interface types cannot have typedef members

1241

interface_cannot_have_ctor_or_dtor

interface types cannot have user-declared constructors or destructors

1242

interface_cannot_have_operator

interface types cannot have user-declared member operators

1243

interface_cannot_be_local

interface types cannot be declared in functions

1245

interface_cannot_have_data_member

interface types cannot have data members

1246

interface_cannot_have_friend

interface types cannot contain friend declarations

1248

interface_cannot_be_nested_class

interface types cannot be nested class types

1249

interface_cannot_have_member_templates

interface types cannot have member templates

1250

interface_cannot_have_static_members

interface types cannot have static member functions

1251

invalid_microsoft_pragma_operator

this pragma cannot be used in a __pragma operator (a #pragma directive must be used)

1252

qualifier_must_be_base_class

qualifier must be base class of "type"

1253

invalid_selective_overrider_declaration

declaration must correspond to a pure virtual member function in the indicated base class

1254

integer_overflow_class_internal

integer overflow in internal computation due to size or complexity of "type"

The compiler displays this error if you are using multiple or virtual inheritance, and the offset from the beginning of the derived class type to a base class within type exceeds the 32 kilobytes. If you are using multiple inheritance, rearrange the inheritance order by putting smaller classes first. With the new ordering, the offset of larger classes is less likely to exceed this limit. If you are using virtual inheritance, make the derived class members smaller, because the compiler always places members of a derived class before virtual base classes.

If you do not need your code to be backwards-compatible with existing code, you can remove this limit by passing the --large_vtbl_offsets option. For more information, see “Virtual Function Table Offset Size”.

1255

integer_overflow_internal

integer overflow in internal computation

1256

invalid_type_for_w64

__w64 can only be specified on int, long, and pointer types

1257

ilp64_will_narrow

potentially narrowing conversion when compiled in an environment where int, long, or pointer types are 64 bits wide

1258

value_of_pragma_pack_show

current value of pragma pack is xxxx

1259

pragma_pack_show_args_ignored

arguments for pragma pack(show) are ignored

1262

multiple_declspec_align

earlier __declspec(align(…)) ignored

1263

exp_ms_attr_enum_value

expected an argument value for the "xxxx" attribute parameter

1264

invalid_ms_attr_enum_value

invalid argument value for the "xxxx" attribute parameter

1265

exp_ms_attr_bool_value

expected a boolean value for the "xxxx" attribute parameter

1266

positional_after_named

a positional argument cannot follow a named argument in an attribute

1267

invalid_ms_attr_name

attribute "xxxx" has no parameter named "xxxx"

1268

exp_ms_attr_arg_list

expected an argument list for the "xxxx" attribute

1269

exp_comma_or_rbracket

expected a "," or "]"

1270

duplicate_ms_attr_arg

attribute argument "xxxx" has already been given a value

1271

cannot_assign_to_ms_attr

a value cannot be assigned to the "xxxx" attribute

1272

ptr_incomplete_throw

a throw expression may not have pointer-to-incomplete type

1273

alignof_incomplete_type

alignment-of operator applied to incomplete type

1274

invalid_use_of_standalone_ms_attr

"xxxx" may only be used as a standalone attribute

1275

invalid_use_of_ms_attr

"xxxx" attribute cannot be used here

1277

ms_attr_not_allowed

attributes are not allowed here

1278

invalid_ms_attr_uuid_value

invalid argument value for the "xxxx" attribute parameter

1279

too_many_ms_attr_args

too many attribute arguments

1280

conv_from_inaccessible_base_class

conversion from inaccessible base class "type" is not allowed

1281

cl_export_template_requires_distinct_templ_sigs

option "export" requires distinct template signatures

1282

mixed_string_concatenation

string literals with different character kinds cannot be concatenated

1283

no_gnu_virtual_base_gap

GNU layout bug not emulated because it places virtual base "entity" outside "entity" object boundaries

1284

gnu_virtual_base_gap

virtual base "entity" placed outside "entity" object boundaries

1285

nonstd_qualifier_in_namespace_member_decl

nonstandard qualified name in namespace member declaration

1286

declspec_align_reduction_ignored

reduction in alignment ignored

1287

const_ignored

const qualifier ignored

1289

invalid_asm_qualifiers

invalid GNU asm qualifiers

1290

non_pod_passed_to_ellipsis

a class type that is not trivially copyable passed through ellipsis

The compiler issues this remark because it is expected that passing a struct to a variadic function is done by accident more often than it is done intentionally. For example, in many cases it is likely that passing either the address of the struct or one of its fields was intended instead. This remark may be issued on perfectly valid code.

1291

non_pod_va_arg

a class type that cannot be trivially copied cannot be fetched by va_arg

1292

nonstd_fixed_point_suffix

the 'u' or 'U' suffix must appear before the 'l' or 'L' suffix in a fixed-point literal

1293

cl_fixed_point_option_only_in_C

option "fixed_point" can be used only when compiling C

1294

integer_may_not_fit_in_fixed_point_result

integer operand may cause fixed-point overflow

1295

bad_fixed_point_value

fixed-point constant is out of range

1296

inexact_fxp_conversion

fixed-point value cannot be represented exactly

1297

c99_constant_in_unsigned_long_long_range

constant is too large for long long; given unsigned long long type (nonstandard)

1298

bad_upc_shared_void_pointer_layout_qualifier

layout qualifier cannot qualify pointer to shared void

1299

duplicate_threads_dim

duplicate THREADS in multidimensional array type


Diagnostics 1300 to 1399

1300 | bad_strong_using_scope a strong using-directive may only appear in a namespace scope
1301 | probable_guiding_friend entity-kind "entity" declares a non-template function -- add <> to refer to a template instance
1302 | operation_may_not_fit_in_fixed_point_result operation may cause fixed-point overflow
1303 | expr_not_integral_or_enum_or_fixed_point expression must have integral, enum, or fixed-point type
1304 | expr_not_integral_or_fixed_point expression must have integral or fixed-point type
1305 | noreturn_function_does_return function declared with "noreturn" does return
1306 | asm_name_conflict asm name ignored because it conflicts with a previous declaration
1307 | duplicate_typedef_in_class class member typedef may not be redeclared
1308 | taking_address_of_temporary taking the address of a temporary
1309 | attribute_ignored_on_incomplete_class_decl attributes are ignored on a class declaration that is not also a definition
1310 | implicit_fixed_point_to_floating_point_conversion fixed-point value implicitly converted to floating-point type
1311 | no_classification_for_fixed_point_type fixed-point types have no classification
1312 | fixed_template_parameter a template parameter may not have fixed-point type
1313 | hex_fp_constant hexadecimal floating-point constants are not allowed
1314 | cl_named_address_spaces_option_only_in_C option "named_address_spaces" can be used only when compiling C
1315 | float_to_fixed_conversion floating-point value does not fit in required fixed-point type
1316 | inexact_fixed_conversion value cannot be converted to fixed-point value exactly
1317 | fixed_sign_change fixed-point conversion resulted in a change of sign
1318 | integer_to_fixed_conversion integer value does not fit in required fixed-point type
1319 | bad_fixed_operation_result fixed-point operation result is out of range
1320 | multiple_named_address_spaces multiple named address spaces
1321 | bad_storage_class_for_named_address_space_variable variable with automatic storage duration cannot be stored in a named address space
1322 | type_with_named_address_space_not_allowed type cannot be qualified with named address space
1323 | named_address_space_on_function_type function type cannot be qualified with named address space
1324 | field_type_cannot_be_qualified_with_named_address_space field type cannot be qualified with named address space
1325 | fixed_to_float_conversion fixed-point value does not fit in required floating-point type
1326 | fixed_to_integer_conversion fixed-point value does not fit in required integer type
1327 | fixed_to_fixed_conversion value does not fit in required fixed-point type
1328 | cl_named_registers_option_only_in_C option "named_registers" can be used only when compiling C
1329 | named_register_not_allowed a named-register storage class is not allowed here
1330 | register_storage_class_conflict entity-kind "entity" (declared at line xxxx) redeclared with incompatible named-register storage class
1331 | aliased_variable_cannot_have_register_storage_class named-register storage class cannot be specified for aliased variable
1332 | register_in_use named-register storage specifier is already in use
1333 | embedded_c_option_incompatible_with_individual_feature_options option "embedded_c" cannot be combined with options to control individual Embedded C features
1334 | cl_invalid_edg_base_directory invalid EDG_BASE directory: xxxx
1336 | bad_predef_macro_line invalid predefined macro entry at line xxxx: xxxx
1337 | bad_macro_mode_name invalid macro mode name "xxxx"
1338 | bad_predef_macro_redef incompatible redefinition of predefined macro "xxxx"
1339 | missing_named_register_storage_class redeclaration of entity-kind "entity" (declared at line xxxx) is missing a named-register storage class
1340 | register_too_small named register is too small for the type of the variable
1341 | no_named_register_for_array arrays cannot be declared with named-register storage class
1342 | enum_const_cast const_cast to enum type is nonstandard
1343 | cl_embedded_c_option_only_in_C option "embedded_c" can be used only when compiling C
1344 | named_address_space_not_allowed a named address space qualifier is not allowed here
1345 | bad_initializer_for_array_with_unspecified_bound an empty initializer is invalid for an array with unspecified bound
1346 | incomplete_class_return_type function returns incomplete class type "type"
1347 | out_of_class_initializer_ignored entity-kind "entity" has already been initialized; the out-of-class initializer will be ignored
1348 | local_variable_hidden declaration hides entity-kind "entity" (declared at line xxxx)
1349 | named_address_space_for_parameter a parameter cannot be allocated in a named address space
1350 | bad_float_or_fixed_suffix invalid suffix on fixed-point or floating-point constant
1351 | register_in_address_space a register variable cannot be allocated in a named address space
1352 | bad_stdc_fx_overflow_pragma_arg expected "SAT" or "DEFAULT"
1353 | no_corresponding_member_delete entity-kind "entity" has no corresponding member operator delete (to be called if an exception is thrown during initialization of an allocated object)
1354 | dll_thread_conflict a thread-local variable cannot be declared with "dllimport" or "dllexport"
1355 | function_returning_named_address_space a function return type cannot be qualified with a named address space
1356 | cannot_initialize_destructible_flexible_array an initializer cannot be specified for a flexible array member whose elements have a nontrivial destructor
1357 | cannot_initialize_indirect_flexible_array an initializer cannot be specified for an indirect flexible array member
1358 | cl_invalid_gnu_version invalid GNU version number: xxxx
1359 | attribute_after_parenthesized_initializer variable attributes appearing after a parenthesized initializer are ignored
1360 | gcc_use_of_cast_as_lvalue the result of this cast cannot be used as an lvalue
1361 | unsigned_fixed_point_negation negation of an unsigned fixed-point value
1364 | register_name_on_nonregister register names can only be used for register variables
1365 | void_named_register named-register variables cannot have void type
1367 | parameter_with_link_scope_specifier parameters cannot have link scope specifiers
1368 | multiple_link_scope_specifiers multiple link scope specifiers
1369 | link_scope_requires_external_linkage link scope specifiers can only appear on functions and variables with external linkage
1370 | link_scope_relaxation a redeclaration cannot weaken a link scope
1371 | invalid_link_scope link scope specifier not allowed on this declaration
1372 | nonstd_qualifier_in_global_scope_decl nonstandard qualified name in global scope declaration
1373 | impl_narrowing_64_bit_int implicit conversion of a 64-bit integral type to a smaller integral type (potential portability problem)
1374 | expl_narrowing_64_bit_int explicit conversion of a 64-bit integral type to a smaller integral type (potential portability problem)
1375 | pointer_conversion_to_same_size_int conversion from pointer to same-sized integral type (potential portability problem)
1376 | alias_loop alias creates cycle of aliased entities
1377 | pcc_field_ambiguity field name resolves to more than one offset -- see "entity" (declared at line xxxx) and "entity" (declared at line xxxx)
1378 | not_a_field_name "xxxx" is not a field name
1379 | invalid_symbolic_asm_operand_name invalid symbolic operand name "xxxx"
1380 | match_limit_for_symbolic_asm_operand a symbolic match constraint must refer to one of the first ten operands
1381 | friend_specifier_ignored friend specifier is not allowed in a class definition; friend specifier is ignored
1382 | cannot_use_thread_local_storage only static and extern variables can use thread-local storage
1383 | multiple_thread_local_storage_specifiers multiple thread-local storage specifiers
1384 | virtual_function_never_defined virtual entity-kind "entity" was not defined (and cannot be defined elsewhere because it is a member of an unnamed namespace)
1385 | stray_carriage_return carriage return character in source line outside of comment or character/string literal
1386 | expr_not_fixed_point expression must have fixed-point type
1387 | invalid_access_specifier invalid use of access specifier is ignored
1388 | ptr_conv_to_bool pointer converted to bool
1389 | ptr_to_member_conv_to_bool pointer-to-member converted to bool
1390 | storage_specifier_ignored storage specifier ignored
1391 | dll_interface_ignored_on_class_template dllexport and dllimport are ignored on class templates
1392 | base_class_has_different_dll_interface base class dllexport/dllimport specification differs from that of the derived class
1393 | redeclaration_adds_dll_interface redeclaration cannot add dllexport/dllimport to "entity" (declared at line xxxx)
1394 | dll_interface_conflict_dllexport_assumed dllexport/dllimport conflict with "entity" (declared at line xxxx); dllexport assumed
1395 | dllimport_defined cannot define dllimport entity
1396 | dll_interface_requires_external_linkage dllexport/dllimport requires external linkage
1397 | class_and_member_have_dll_interface a member of a class declared with dllexport/dllimport cannot itself be declared with such a specifier
1398 | field_without_dll_interface field of class type without a DLL interface used in a class with a DLL interface
1399 | microsoft_parenthesized_member parenthesized member declaration is nonstandard


Diagnostics 1400 to 1499

1400

white_space_inside_splice

white space between backslash and newline ignored for GNU compatibility -- may cause unintentional line continuation

In most C dialects, the compiler does not parse backslash (\) as a line continuation character if it is followed by a whitespace. In the GNU C dialect, the compiler parses backslash as a line continuation character whether or not it is followed by a whitespace. In versions of the MULTI compiler earlier than 5.2, the GNU C and C++ dialects behaved the same way as other dialects.

This diagnostic indicates that your code has a line that contains a backslash followed by a whitespace, and therefore may contain an unintentional line continuation. The following example shows one of these cases (the space is indicated by an underscore, because it does not display in print):

#include <stdio.h>
int main(void) {
    int i = 42; // use space after backslash, as in C:\_
    i = 0; // ignored in GNU
    if (i != 0) {
        printf("i = %d, should be 0\n", i);
    }
}

1401

dll_interface_conflict_none_assumed

dllexport/dllimport conflict with "entity" (declared at line xxxx); dllimport/dllexport dropped

1402

bad_nonstd_anonymous_union_field

invalid member for anonymous member class -- class "type" has a disallowed member function

1403

nonstd_reinterpret_cast

nonstandard reinterpret_cast

1404

positional_format_specifier_zero

positional format specifier cannot be zero

1405

nonlocal_vla_not_allowed

a local class cannot reference a variable-length array type from an enclosing function

1406

class_and_inherited_member_instance_have_dll_interface

member entity-kind "entity" (declared at line xxxx) already has an explicit dllexport/dllimport specifier

1407

vla_in_return_type

a variable-length array is not allowed in a function return type

1408

ptr_to_member_of_vla_type

variable-length array type is not allowed in pointer to member of type "type"

1409

statement_expr_with_vla_type

the result of a statement expression cannot have a type involving a variable-length array

1410

trigraph_ignored

support for trigraphs is disabled

1411

attribute_requires_external_linkage

the "xxxx" attribute can only appear on functions and variables with external linkage

1412

cl_strict_mode_incompatible_with_ignore_std

strict mode is incompatible with treating namespace std as an alias for the global namespace

1413

if_exists_not_allowed

use of __if_exists is not supported in this context

1414

if_exists_not_closed

__if_exists block not closed in the same scope in which it was opened

1415

bad_init_for_thread_local

thread-local variable cannot be dynamically initialized

1416

unaligned_qualifier_dropped

conversion drops "__unaligned" qualifier

1417

insufficient_enum_range

some enumerator values cannot be represented by the integral type underlying the enum type

1418

friend_class_template_default_arg_not_allowed

default argument is not allowed on a friend class template declaration

1419

multi_char_literal

value of multicharacter character literal is implementation-defined

1420

exp_class_type

expected a class, struct, or union type

1421

offsetof_nonfield

second operand of offsetof must be a field

1422

offsetof_bit_field

second operand of offsetof may not be a bit field

1423

offsetof_virtual_base_member

cannot apply offsetof to a member of a virtual base

1424

offset_in_non_POD_nonstandard

offsetof applied to a type other than a standard-layout class

1425

default_arg_on_member_friend

default arguments are not allowed on a friend declaration of a member function

1426

default_arg_requires_friend_to_be_definition

default arguments are not allowed on friend declarations that are not definitions

1427

redeclaration_of_friend_with_default_args

redeclaration of entity-kind "entity" (declared at line xxxx) previously declared as a friend with default arguments is not allowed

1428

bad_qualifier_for_nested_class_decl

invalid qualifier for "type" (a derived class is not allowed here)

1429

bad_qualifier_for_delayed_class_definition

invalid qualifier for definition of class "type"

1430

no_prior_push_macro

no prior push_macro for "xxxx"

1431

wide_string_not_allowed

wide string literal not allowed

1433

feature_requires_c

"xxxx" is only allowed in C

1434

microsoft_ptr_width_must_follow_star

__ptr32 and __ptr64 must follow a "*"

1435

microsoft_ptr_width_conflict

__ptr32 and __ptr64 cannot both apply

1436

name_must_be_prototype_instantiation

template argument list of "xxxx" must match the parameter list

1437

incomplete_class_type

an incomplete class type is not allowed

1438

complex_integral_type

complex integral types are not supported

1439

real_and_imag_require_complex_argument

__real and __imag can only be applied to complex values

1440

real_and_imag_applied_to_real_value

__real/__imag applied to real value

1441

deprecated_entity_with_custom_message

entity-kind "entity" (declared at line xxxx) was declared deprecated ("xxxx")

1442

redefinition

invalid redefinition of entity-kind "entity" (declared at line xxxx)

1443

dll_interface_in_unnamed_namespace

dllimport/dllexport applied to a member of an unnamed namespace

1444

thiscall_requires_nonstatic_member

__thiscall can only appear on nonstatic member function declarations

1445

vararg_thiscall

__thiscall not allowed on function with ellipsis parameter

1446

specialization_of_referenced_entity

explicit specialization of entity-kind "entity" must precede its first use

1447

sealed_base_class

a sealed class type cannot be used as a base class

1448

duplicate_class_modifier

duplicate class modifier

1449

function_modifiers_abstract_and_sealed

a member function cannot have both the "abstract" and "sealed" modifiers

1450

pure_specifier_on_sealed_member

a sealed member cannot be pure virtual

1451

function_modifier_requires_virtual_function

nonvirtual function cannot be declared with "abstract" or "sealed" modifier

1452

override_member_does_not_override

member function declared with "override" does not override a base class member

1453

override_of_sealed_function

cannot override sealed entity-kind "entity" (declared at line xxxx)

1454

type_is_declared_abstract

entity-kind "entity" (declared at line xxxx) was declared with the class modifier "abstract"

1457

enum_base_type_must_be_integral

underlying type of enum type must be an integral type

1458

enum_base_type_too_limited

some enumerator constants cannot be represented by "type"

1459

feature_not_allowed_in_current_mode

"xxxx" not allowed in current mode

1460

cl_type_traits_helpers_option_only_in_cplusplus

type traits helpers option can be used only when compiling C++

1461

gnu_sentinel_attribute_requires_ellipsis

attribute "sentinel" requires an ellipsis parameter

1462

invalid_gnu_sentinel_argument

argument must be a constant null pointer value

1463

no_gnu_sentinel_argument

insufficient number of arguments for sentinel value

1464

gnu_sentinel_must_be_ellipsis_argument

sentinel argument must correspond to an ellipsis parameter

1465

implementation_key_outside_mapping_region

__declspec(implementation_key(…) can appear only between #pragma start_map_region and #pragma stop_map_region

1466

start_map_region_ignored

#pragma start_map_region already active: pragma ignored

1467

stop_map_region_ignored

no #pragma start_map_region is currently active: pragma ignored

1468

var_used_as_destructor

entity-kind "entity" cannot be used to name a destructor (a type name is required)

1469

empty_wide_character

nonstandard empty wide character literal treated as L'\0'

1470

invalid_typename_specifier

"typename" may not be specified here

1471

no_default_delete_in_virtual_dtor

a non-placement operator delete must be visible in a class with a virtual destructor

1472

name_linkage_mismatch_for_variable

name linkage conflicts with previous declaration of entity-kind "entity" (declared at line xxxx)

1474

register_mapped_variable_cannot_have_initializer

a variable with static storage duration allocated in a specific register cannot be declared with an initializer

1475

register_mapped_variable_must_be_POD

a variable allocated in a specific register must be trivially copyable

1476

predef_macro_redefined

predefined meaning of "entity" discarded

1478

designator_for_non_POD

class type not suitable for use with designators

1480

nonstandard_anonymous_union_qualifier

anonymous union qualifier is nonstandard

1481

anonymous_union_qualifier_ignored

anonymous union qualifier is ignored

1483

struct_declspec_ignored_in_C_mode

__declspec(xxxx) ignored (it has no meaning for a C struct)

1484

nonstandard_secondary_decl_specifiers

specifiers after comma between declarations are nonstandard

1485

secondary_specifier_ignored

nonstandard specifier ignored

1486

enum_attribute_ignored

attributes are ignored on an enum declaration that is not also a definition

1487

reference_declared_mutable

declaring a reference with "mutable" is nonstandard

1488

array_condition_always_true

a condition declaration for an array is always true

1489

static_assert

static assertion failed with "xxxx"

1490

gnu_visibility_conflict

visibility attribute ignored because it conflicts with a previous declaration

1491

member_cannot_have_internal_linkage

a member function cannot have internal linkage

1492

builtin_function_hidden

declaration hides built-in entity-kind "entity"

1493

builtin_function_overloaded

declaration overloads built-in entity-kind "entity"

1494

cl_list_macros_incompatible_with_multiple_trans_units

the option to list macro definitions may not be specified when compiling more than one translation unit

1495

lparen_after_function

unexpected parenthesis after declaration of entity-kind "entity" (malformed parameter list or invalid initializer?)

1496

nonstandard_parenthesized_string_initializer

parentheses around a string initializer are nonstandard

1497

auto_variable_in_own_initializer

a variable declared with an auto type specifier cannot appear in its own initializer

1498

cannot_deduce_auto_type

cannot deduce "auto" type

1499

auto_brace_initialization_not_allowed

initialization with "{…}" is not allowed for "auto" type


Diagnostics 1500 to 1599

1501

bad_align_alignment

invalid align value

1502

local_pragma_align

effect of this "#pragma align" directive is local to entity-kind "entity"

1503

nested_pragma_areas

pragmas which specify data areas cannot be nested

1504

misplaced_asm_pragma

"#pragma asm/endasm" cannot be placed xxxx

1505

ghs_interrupt_and_nonfunction

interrupt specifier allowed on function declarations only

1506

ghs_interrupt_and_nonvoid_return

interrupt function must return void

1507

ghs_interrupt_and_has_parameters

interrupt function may not have parameters

1508

ghs_interrupt_not_supported

interrupt functions not supported in this compiler

1509

incompatible_interrupt_specifier_on_specific_decl

__interrupt specification is incompatible with previous "entity" (declared at line xxxx)

1510

ghs_pragma_config_unimplement

This pragma is not implemented for this configuration

The compiler displays this error if you use a #pragma directive that is not implemented for your processor or target operating system, or if you set an option that disables the directive.

For more information, see the documentation for the #pragma directive reported in the error.

1511

bad_alignvar_alignment

invalid alignvar value

1512

bad_section_pragma

incorrect section #pragma: xxxx

1513

unknown_ghs_pragma

GHS #pragma with incorrect keyword "xxxx"

1514

invalid_ghs_pragma

incorrect GHS #pragma: xxxx

1515

unmatched_ghs_sda_pragma

the end data section pragma does not match the start data section pragma

1517

invalid_pp_directive_in_asm_block

this preprocessing directive is not permitted within a #pragma asm/endasm block

1518

ghs_safe_ansi_alias_pointer_function

a questionable cast from type "type" to type "type" causes ANSI aliasing rules to be turned off for this function

This warning indicates that the compiler has detected that two entities of incompatible type might alias each other at function scope, and therefore the compiler will not perform any optimizations whose correctness depends on aliasing information when compiling the current function. This warning is issued only when those optimizations have been enabled. When compiling without optimizations, remark 1798 is issued instead.

To disable ANSI aliasing rules and suppress this warning, pass the -no_ansi_alias option.

1519

ghs_safe_ansi_alias_pointer_file

a questionable cast from type "type" to type "type" -- please recompile with ANSI aliasing turned off

This error indicates that the compiler has detected that two entities of incompatible type might alias each other at file scope, and therefore the compiler cannot perform any optimizations whose correctness depends on aliasing information.

To disable ANSI aliasing rules and suppress this error, pass the -no_ansi_alias option.

1520

unimplemented_gnu_extension

unsupported GNU language extension: xxxx

1521

gnu_extension_recognized

use -gnu for full GNU support

1522

global_reg_and_initializer

global register variable cannot have an initializer

1523

asmsym_macro_commented_out

This macro definition will be commented-out in asmsym output files since it may have adverse effects

1524

asmsym_internal_macro_syntax_error

Incorrect usage of __ASMSYM_INTERNAL()

1527

no_match_for_intvect_pragma

The name specified in the 'intvect' must be a declared interrupt routine

1528

field_not_yet_laid_out

An asmsym region ended before the xxxx definition containing field "xxxx" was complete

1529

asm_not_allowed_with_bin_codegen

asm statement incompatible with binary code generation. Try command line option -noobj or builder menu File Options->Advanced->Compilation = Assembly

1530

addr_of_builtin

this builtin function may not have its address taken

1531

builtin_function_type

Builtin function xxxx is not xxxx

1532

decl_overloaded_builtin

overloaded builtin function may not be declared

1533

defining_builtin

defining builtin function; may be called only via pointer to function

1534

expr_not_constant_or_vector

expression must be a vector type or have a constant value

1535

implicit_builtin

builtin function may not be implicitly declared

1536

obsolete_feature

use of obsolete feature: xxxx

1537

too_few_initializer_values

too few initializer values

1538

type_must_be_compat_with_builtin

type must be compatible with builtin function

1539

vector_arg_without_prototype

vector argument requires a prototype

1540

vector_not_first

vector type specifier is not first

1541

ghs_vector_type_required

operand of vec_step must be a vector type

1542

no_floating_point_types

floating point types have been disabled

1543

no_floating_point_const

floating point constants have been disabled

1544

pragma_information_conflict

incompatibility associated with redeclaration of entity-kind "entity": xxxx

1545

address_of_packed_struct_member

address taken of a packed structure member with insufficient alignment

1546

asm_non_portable

asm constructs are non-portable

1547

call_to_nonprototyped_func

call is made to a non-prototyped function

GHS Standard Mode enables this diagnostic.

1550

auto_type_in_array_type

"auto" type cannot appear in top-level array type

1551

auto_type_in_function_type

"auto" type cannot appear in top-level function type

1552

invalid_member_constant_type

a member of type "type" cannot have an in-class initializer

1553

member_constant_not_const

a member with an in-class initializer must be const

1554

auto_type_requires_initializer

cannot deduce "auto" type (initializer required)

1555

inconsistent_deduction_of_auto

"auto" type is "type" for this entity, but was previously implied to be "type"

1556

bad_constructor_decl

invalid constructor declaration

1557

bad_type_qualifier

invalid use of a type qualifier

1558

abstract_or_sealed_on_union

a union cannot be abstract or sealed

1559

auto_not_allowed_here

"auto" is not allowed here

1560

unfinished_base_class

definition of base class type not completed yet

1561

static_extern_template

"extern template" cannot refer to a specialization of static entity-kind "entity" (declared at line xxxx)

1562

extern_template_follows_instantiation

"extern template" cannot follow explicit instantiation of entity-kind "entity"

1563

bad_declspec_restrict_return

__declspec(restrict) requires a function returning a pointer type

1564

cl_report_gnu_extensions_requires_gnu_mode

the "report_gnu_extensions" option is only valid in GNU C and GNU C++ modes

1565

vla_is_nonstandard

variable-length array types are nonstandard

1566

designator_is_nonstandard

designators are nonstandard

1567

extended_designator_is_gnu_extension

this designator syntax is a GNU extension

1568

compound_literal_is_nonstandard

compound literals are nonstandard

1569

statement_expression_is_gnu_extension

statement expressions are a GNU extension

1570

asm_name_after_definition

asm name ignored for previously defined entity

1571

attribute_is_gnu_extension

attributes are a GNU extension

1572

asm_operand_spec_is_gnu_extension

extended asm syntax is a GNU feature

1573

volatile_asm_is_gnu_extension

volatile asm declarations are a GNU extension

1574

asm_name_is_gnu_extension

asm name specifiers are a GNU extension

1575

gnu_restrict_is_nonstandard

the "__restrict" qualifier is nonstandard

1576

typeof_is_gnu_extension

"typeof" is a GNU extension

1577

typedef_modification_is_nonstandard

modifying the size or signedness of a typedef is nonstandard

1578

zero_length_array_is_gnu_extension

zero-length arrays are a GNU extension

1579

flexible_array_is_nonstandard

flexible array members are nonstandard

1580

nonnull_on_nonpointer

attribute "nonnull" references nonpointer parameter

1581

nonnull_parameter_number_too_large

argument for attribute "nonnull" is larger than number of parameters

1582

no_pointer_parameters

no parameter has pointer type

1583

null_argument_for_nonnull_parameter

null argument provided for parameter marked with attribute "nonnull"

This warning is issued in connection with the nonnull attribute.

1584

access_prevents_dtor_generation

the destructor for "type" has been suppressed because the destructor for "type" is inaccessible

1585

suppressed_dtor_needed

the suppressed destructor for "type" is needed

1586

inline_gnu_noinline_conflict

routine is both "inline" and "noinline"

1587

invalid_cleanup_routine

invalid cleanup routine

1588

attribute_cleanup_requires_automatic_storage

attribute "cleanup" requires automatic storage duration

1589

attribute_cleanup_for_parameter

attribute "cleanup" does not apply to parameters

1590

bad_type_for_cleanup_routine

cleanup routine has invalid type

1591

nonstandard_conversion_for_cleanup

call of cleanup routine requires suspect conversion

1592

microsoft_ptr_signedness_must_follow_star

__sptr and __uptr must follow a "*"

1593

microsoft_ptr_signedness_conflict

__sptr and __uptr cannot both be specified

1594

microsoft_ptr_sign_extension

widening pointer conversion from "type" to "type" extends sign bit

1595

microsoft_ptr_signedness_on_ptr_to_member

__sptr and __uptr don't apply to pointer-to-member types

1596

const_mbr_suppresses_copy_asgn_decl

the declaration of the copy assignment operator for "type" has been suppressed because entity-kind "entity" is const

1597

ref_mbr_suppresses_copy_asgn_decl

the declaration of the copy assignment operator for "type" has been suppressed because entity-kind "entity" has reference type

1598

subobj_copy_asgn_decl_suppressed

the declaration of the copy assignment operator for "type" has been suppressed because that of "type" was suppressed

1599

ambig_suppresses_copy_asgn_decl

the declaration of the copy assignment operator for "type" has been suppressed because that of "type" is ambiguous


Diagnostics 1600 to 1699

1600 | access_suppresses_copy_asgn_decl the declaration of the copy assignment operator for "type" has been suppressed because that of "type" is inaccessible
1601 | subobj_copy_ctor_decl_suppressed the declaration of the copy constructor for "type" has been suppressed because that of "type" was suppressed
1602 | ambig_suppresses_copy_ctor_decl the declaration of the copy constructor for "type" has been suppressed because that of "type" is ambiguous
1603 | access_suppresses_copy_ctor_decl the declaration of the copy constructor for "type" has been suppressed because that of "type" is inaccessible
1604 | inaccessible_dtor_not_invoked the destructor for "type" will not be called because it is inaccessible and the destructor for "type" was suppressed
1605 | file_ends_with_unterminated_type_definition definition at end of file not followed by a semicolon or a declarator
1606 | bad_type_for_gnu_sync_function first argument must be a pointer to integer or enumeration type
1607 | invalid_gnu_sync_size synchronized operations are valid only on objects of size 1, 2, 4, or 8
1608 | extra_arguments_ignored extra arguments ignored
1609 | equals_assumed_in_cmd_line_macro_def '=' assumed following macro name "xxxx" in command-line definition
1610 | white_space_required_after_macro_name white space is required between the macro name "xxxx" and its replacement text
1611 | call_result_should_be_used result of call is not used
1612 | warn_unused_result_with_void_return attribute "warn_unused_result" is ignored for void return type
1614 | dll_interface_ignored_on_qualified_declaration dllimport/dllexport is ignored on redeclaration using a qualified name
1615 | leading_character_ignored_in_char_literal too many characters in character literal -- extra leading characters ignored
1616 | first_inline_after_definition entity-kind "entity" cannot be declared inline after its definition at line xxxx
1619 | duplicate_function_modifier duplicate function modifier
1620 | no_char16_t_representation invalid character for char16_t literal
1622 | cl_unrecognized_calling_convention unrecognized calling convention xxxx, must be one of:
1623 | include_next_in_primary_source_file #include_next cannot be used in the primary source file
1624 | bad_template_member_definition "entity" cannot be specified in a template member definition -- "entity" assumed instead
1625 | local_function_attribute_ignored attribute "xxxx" is ignored on local function declaration
1626 | concat_yields_invalid_token concatenation with "xxxx" in entity-kind "entity" does not create a valid token
1627 | ambiguous_injected_template_name "entity" is ambiguous (entity-kind "entity" assumed)
1628 | function_qualifier_on_static_member a type qualifier is not allowed on a static member function
1629 | function_qualifier_on_ctor_or_dtor a type qualifier is not allowed on a constructor or destructor
1630 | function_qualifier_on_new_or_delete a type qualifier is not allowed on operator new or operator delete
1631 | function_qualifier_on_nonmember a type qualifier is not allowed on a nonmember function
1632 | assume_expression_discarded argument to xxxx has side-effects but is unevaluated
1633 | gnu_attributes_ignored attributes ignored here
1634 | useless_type_qualifiers_in_type_name type qualifiers are meaningless here
1642 | no_floating_point_double_type double precision floating point type has been disabled
1643 | no_floating_point_double_const double precision floating point constants have been disabled
1657 | ghs_unable_to_create_pch unable to create precompiled header file: xxxx
1658 | ghs_pch_source_dir_mismatch directory of source file not the same as when precompiled header file "xxxx" was created
1695 | ghs_trigraph_not_allowed trigraphs not allowed
1696 | ghs_register_not_allowed register storage class not allowed
1697 | ghs_va_list_not_allowed variable argument list not allowed
1698 | ghs_basic_type_not_allowed basic types may not be used -- use typedef
1699 | ghs_unspecified_char_not_allowed char without signed or unsigned specifier not allowed


Diagnostics 1700 to 1799

1700

ghs_inline_not_in_cpp

"xxxx" is not allowed in C++ -- use "inline"

1701

ghs_inline_not_allowed

"xxxx" is not allowed

1702

ghs_uminus_on_unsigned_expr_not_allowed

unary minus may not be applied to an unsigned expression

GHS Standard Mode enables this diagnostic.

1703

ghs_ptr_cast_not_allowed

cast from type "type" to type "type" not allowed

1704

ghs_exact_float_test_not_allowed

floating point variable may not be tested for exact equality or inequality

GHS Standard Mode enables this diagnostic.

This diagnostic is only issued when the compiler checks for conformance with an associated MISRA rule. As such, it will not be issued (at any severity) if the associated MISRA rule is not enabled.

1705

ghs_goto_not_allowed

the goto statement is not allowed

1706

ghs_continue_not_allowed

the continue statement is not allowed

1707

ghs_break_only_in_switch

the break statement may only be used to terminate the case of a switch statement

1708

ghs_label_not_allowed

label not allowed

This diagnostic is only issued when the compiler checks for conformance with an associated MISRA rule. As such, it will not be issued (at any severity) if the associated MISRA rule is not enabled.

1709

ghs_compound_statement_required

dependent statement in conditional or loop construct must be enclosed in braces

1710

ghs_else_required

final non-trivial else clause required for if, else if construct

1711

ghs_no_fall_thru_on_case

previous non-empty case clause must be terminated with a break statement

If fall through is intended, a special /*FALLTHROUGH*/ comment may be placed immediately before the following case label to suppress this diagnostic.

Example:

case 1:
   do_something();
   /*FALLTHROUGH*/
case 2:
   break;
...

When using this feature, note the following:

  • Comments with FALLTHROUGH must use the style in the example above ("/* ... */"). Other commenting styles (such as "//") will not work.

  • FALLTHROUGH may be optionally prefixed by a single whitespace. If any words follow FALLTHROUGH, they must be prefixed by at least one whitespace.

  • MISRA overrides the /*FALLTHROUGH*/ feature.

GHS Standard Mode enables this diagnostic.

This diagnostic is only issued when the compiler checks for conformance with an associated MISRA rule. As such, it will not be issued (at any severity) if the associated MISRA rule is not enabled.

1712

ghs_default_required_for_switch

switch statement must contain a non-trivial default case

GHS Standard Mode enables this diagnostic.

1713

ghs_case_required_for_switch

switch statement must contain at least one case

GHS Standard Mode enables this diagnostic.

1714

ghs_callmode_and_nonfunction

call mode specifier allowed on function declarations only

1715

ghs_undef_not_allowed

#undef may not be used

1716

ghs_multiple_hash_ops_not_allowed

only one # or ## operator per macro allowed

1717

ghs_bitfield_signedness_is_unspecified

bit-fields should be explicitly "signed" or "unsigned"

1718

ghs_octal_constant_not_allowed

octal constant (other than zero) not allowed

1719

ghs_comma_outside_for_not_allowed

comma operator only allowed in the control expression of a for loop

1720

ghs_wide_string_not_allowed

wide string literal not allowed

1721

ghs_id_shadow_not_allowed

identifier shadows entity-kind "entity" (declared at line xxxx)

GHS Standard Mode enables this diagnostic.

1722

ghs_typedef_reuse_not_allowed

identifier redefines typedef entity-kind "entity" (declared at line xxxx)

This diagnostic is only issued when the compiler checks for conformance with an associated MISRA rule. As such, it will not be issued (at any severity) if the associated MISRA rule is not enabled.

1723

ghs_separate_name_spaces_not_allowed

identifier conflicts with entity-kind "entity" (declared at line xxxx) in separate namespace

This diagnostic is only issued when the compiler checks for conformance with an associated MISRA rule. As such, it will not be issued (at any severity) if the associated MISRA rule is not enabled.

1724

ghs_short_circuit_side_effects_not_allowed

right hand operand of && or || operator may not contain side effects

1725

ghs_sizeof_side_effects_not_allowed

side effects not allowed in operand of sizeof operator

GHS Standard Mode enables this diagnostic.

1726

ghs_enumeration_init_first_or_all_only

only the first or all members of an enumeration may be explicitly initialized

GHS Standard Mode enables this diagnostic.

1727

ghs_bad_ids_for_func_params

identifiers must be given for all of the declared parameters

1728

ghs_empty_param_list_not_allowed

function with no parameters must be declared with parameter type void

GHS Standard Mode enables this diagnostic.

1729

ghs_primary_exprs_in_logical_ops_required

operands of logical && or || must be primary expressions

1730

ghs_bitwise_op_on_signed_ints_not_allowed

bitwise operation may not be performed on signed integer types

1731

ghs_block_scope_func_decls_not_allowed

function must be declared at file scope

GHS Standard Mode enables this diagnostic.

1732

ghs_define_or_undef_in_block_not_allowed

#define and #undef may not be used within a block

GHS Standard Mode enables this diagnostic.

1733

ghs_boolean_switch_not_allowed

switch expression may not represent a boolean value

GHS Standard Mode enables this diagnostic.

1734

ghs_multiple_function_exits_not_allowed

function must have a single exit point

1735

ghs_unsigned_const_wrap_around_not_allowed

constant unsigned integer expression may not wrap around

This diagnostic is only issued when the compiler checks for conformance with an associated MISRA rule. As such, it will not be issued (at any severity) if the associated MISRA rule is not enabled.

1736

ghs_initializer_braces_required

initializer must use braces to match structure of object

GHS Standard Mode enables this diagnostic.

1737

ghs_op_precedence_dependence_not_allowed

expression may not depend on operator precedence rules

This diagnostic is only issued when the compiler checks for conformance with an associated MISRA rule. As such, it will not be issued (at any severity) if the associated MISRA rule is not enabled.

1738

ghs_assign_op_in_boolean_expr_not_allowed

assignment operator not allowed in boolean operation

This diagnostic is only issued when the compiler checks for conformance with an associated MISRA rule. As such, it will not be issued (at any severity) if the associated MISRA rule is not enabled.

1739

ghs_lossy_implicit_conversion_not_allowed

implicit conversion may result in loss of information when converting from "type" to "type"

This diagnostic is only issued when the compiler checks for conformance with an associated MISRA rule. As such, it will not be issued (at any severity) if the associated MISRA rule is not enabled.

1740

ghs_redundant_explicit_cast_not_allowed

redundant explicit cast not allowed

1741

ghs_deep_pointer_indirection_not_allowed

no more than 2 levels of pointer indirection may be used

1742

ghs_anonymous_member_not_allowed

all members of structure or union must be named

1743

ghs_macro_parens_required

definition and each parameter of function-like macro must be enclosed in parentheses

1744

ghs_long_long

the type "long long" is not supported for this configuration

1745

ghs_identical_param_ids_required

parameter identifiers in declaration different from prototype entity-kind "entity" (declared at line xxxx)

1746

ghs_isolated_null_statements_required

null statement must occur on line by itself

1747

ghs_non_std_file_name_chars_not_allowed

non-standard character in header file name not allowed

GHS Standard Mode enables this diagnostic.

1748

ghs_include_after_non_pp_token_not_allowed

#include statements may only be preceded by preprocessor directives and comments

1749

ghs_dedicated_asm_procs_required

in-line assembly must be embedded in dedicated assembly procedures only

1750

ghs_float_loop_counter_not_allowed

floating point expression not allowed in condition expression of loop

GHS Standard Mode enables this diagnostic.

1751

ghs_mixed_precision_arithmetic_not_allowed

mixed precision arithmetic must use explicit cast

This diagnostic is only issued when the compiler checks for conformance with an associated MISRA rule. As such, it will not be issued (at any severity) if the associated MISRA rule is not enabled.

1752

ghs_ptr_arith_not_allowed

pointer arithmetic not allowed

1753

fixedpt_to_fixedpt_conversion

fixed-point value does not fit in required fixed-point type

1754

fixedpt_to_float_conversion

fixed-point value does not fit in required floating-point type

1755

fixedpt_to_integer_conversion

fixed-point value does not fit in required integer type

1756

float_to_fixedpt_conversion

floating-point value does not fit in required fixed-point type

1757

integer_to_fixedpt_conversion

integer value does not fit in required fixed-point type

1758

unsupported_fixedpt

fixed-point type not supported by this target

1759

bad_fixedpt_value

fixed-point value out of range

1760

sat_not_first

__sat type specifier is not first

1761

missing_vector_underlying_type

__vector requires an underlying element type

1762

bad_vector_underlying_type

vector of "type" not allowed

1763

bad_vector_dimension

explicit dimension of vector of "type" is too large

1764

vector_subscript_out_of_range

vector subscript out of range

1766

bad_pragma_placement

badly placed #pragma: xxxx

1767

ghs_call_result_cast_to_void

result of call is not used (cast to void)

1768

ghs_unattributed_call_result_should_still_be_used

result of call is not used

1770

incorrect_pragma

incorrect #pragma: xxxx

1771

ghs_code_commented_out

possible occurrence of 'commented out' code

1772

ghs_identifier_truncated

identifier too long - truncated to xxxx significant characters

This diagnostic is only issued when the compiler checks for conformance with an associated MISRA rule. As such, it will not be issued (at any severity) if the associated MISRA rule is not enabled.

1773

noinline_not_allowed

"__noinline" is not allowed

1774

function_call_needs_parens

function address expression - function call without arguments needs "()" as the parameter list

1775

numeric_constant_needs_suffix

numeric constant should be suffixed to indicate type

1776

macro_not_a_literal_specifier_or_function

macro definition can only be used for symbolic constants, function-like macros, or type and storage class qualifiersxxxx

This diagnostic is only issued when the compiler checks for conformance with an associated MISRA rule. As such, it will not be issued (at any severity) if the associated MISRA rule is not enabled.

1777

non_constant_pointer_to_function

detected usage of a non-constant pointer to function

1778

function_pointer_prototype_mismatch

function pointer prototypes must be identical

This diagnostic is only issued when the compiler checks for conformance with an associated MISRA rule. As such, it will not be issued (at any severity) if the associated MISRA rule is not enabled.

1779

be_addr_of_pid_is_init_val

address of a position independent object cannot be an initial value; detected inside the routine at the given position

1780

address_of_local_used_outside_scope

address of an automatic variable potentially used out of scope

GHS Standard Mode enables this diagnostic.

1781

cl_error_in_config

--config option error:

1782

be_safe_ansi_alias_pointer

a questionable cast has been found in a routine at the given position - the ANSI aliasing rules are turned off for that routine

1786

argument_not_u5bit_constant

argument must be an integer literal in range [0,31]

1787

argument_not_s5bit_constant

argument must be an integer literal in range [-16,15]

1788

intrinsic_call_no_decl

call to intrinsic function "xxxx" without a prior declaration

1789

bit_field_type_too_large

bit-field base type must not be larger than 32 bits

1790

be_loop_cannot_be_vectorized

failed to vectorize the loop: xxxx

1791

call_to_nonprototyped_vararg_func

call is made to a non-prototyped function, known to use variable arguments: xxxx

GHS Standard Mode enables this diagnostic.

1792

bad_fixedpt_operation_result

fixed-point result out of range

1793

bad_dsp_c_operator

operator not allowed on type "type"

1794

bad_target_for_extension

extension cannot be used with this target configuration

1795

double_under_in_name

the usage of "__" in this C++ identifier may introduce ambiguity into its mangled name and prevent debug utilities from being able to reconstruct the original C++ identifier. (Note: C++ identifiers with "__" in the name are reserved for the implementation)

1796

section_incompatible

use of section "xxxx" not compatible with its other uses -- explicit section assignment ignored

1797

ghs_single_extern_def

external identifier shall have exactly one definition

GHS Standard Mode enables this diagnostic.

1798

ghs_safe_ansi_alias_pointer_warn_but_dont_degrade_optimizations

a questionable cast from type "type" to type "type" may indicate illegal references.

See diagnostic 1518.

1799

noarg_c_function_needs_void

function declared without a prototype - consider `void' for the parameter list


Diagnostics 1800 to 1899

1800

nonprototype_function_defined

function defined without a prototype

1801

bad_weak_string

unexpected character in weak identifier sequence

1803

builtin_va_list_not_supported

builtin va_list operators not supported

1804

questionable_conversion

implicit conversion from type "type" to type "type"

1805

pack_and_pad_nondefault

cannot have `#pragma pack' and `#pragma pad' active at the same time

1806

pragma_align_lowers_alignment

`#pragma align' lowers the alignment below alignment specified by type

1807

address_of_register

taking the address of a register is not allowed

1808

calling_convention_attribute_not_allowed

calling convention specification not allowed here

1809

conflicting_calling_convention

conflicting calling convention attribute

1810

no_packed_floating_point_types

packed floating point types not allowed

1811

bytereversed_int_or_short_only

byte ordering qualifiers only apply to pointer and integral types larger than char, not "type"

1812

ghs_cast_away_string_literal_const

implicit const-cast of string literal

1813

argument_not_required_const_range

argument must be an integer literal in range xxxx

1814

argument_truncation_range

argument will be truncated to range xxxx

1816

ghs_extern_decl_not_in_header

external declaration should be in header file

1817

ghs_linkonce_and_nonfunction

linkonce specifier allowed on function declarations only

1818

ghs_fp_divide_by_zero

floating point division by zero

1819

ghs_bitfield_used_within_union

bit-fields within union probably used to access sub-parts of larger data type

1820

ghs_floating_used_within_union

floating point types within union depend on underlying bit representation

1821

ghs_unreachable_code_in_switch_not_allowed

unreachable code in switch statement

1822

ghs_multicharacter_literal_used

value of multicharacter literal is implementation-defined

1823

ghs_multibyte_char_used

multibyte character detected

1824

ghs_array_size_required

incomplete array type with external linkage not allowed for entity-kind "entity" (declared at line xxxx)

1825

ghs_comma_not_allowed

comma operator not allowed

1826

ghs_if_without_compound_statement

compound statement required for if construct

1827

ghs_union_not_allowed

union not allowed

1828

ghs_static_nonprototype_function_defined

static function defined without a prototype

This diagnostic is only issued when the compiler checks for conformance with an associated MISRA rule. As such, it will not be issued (at any severity) if the associated MISRA rule is not enabled.

1829

ghs_macro_parameter_parens_required

parameter of function-like macro must be enclosed in parentheses

1830

ghs_hash_ops_not_allowed

# or ## operator not allowed

1831

ghs_no_defined_during_preproc_expansion

token "defined" may not be generated during #if or #elif expansion

1832

ghs_func_ptr_cast_not_allowed

conversion from type "type" to type "type" not allowed

1833

ghs_obj_ptr_cast_not_allowed

conversion from type "type" to type "type" not allowed

1834

ghs_ptr_int_cast_not_allowed

cast from type "type" to type "type" not allowed

1835

ghs_ptr_ptr_cast_not_allowed

cast from type "type" to type "type" not allowed

1836

ghs_qual_removing_ptr_cast_not_allowed

cast from type "type" to type "type" that removes underlying qualifier is not allowed

1837

ghs_default_clause_must_be_final_clause

default clause must be final clause of switch statement

GHS Standard Mode enables this diagnostic.

1838

ghs_switch_label_must_be_at_top_level

case or default label not scoped in top level compound statement of switch statement

GHS Standard Mode enables this diagnostic.

1839

ghs_macro_mixes_asm_and_c

entity-kind "entity" (declared at line xxxx) mixes in-line assembly language and C/C++

1840

ghs_identifier_reuse_not_allowed

identifier reused from declaration of entity-kind "entity" (declared at line xxxx)

This diagnostic is only issued when the compiler checks for conformance with an associated MISRA rule. As such, it will not be issued (at any severity) if the associated MISRA rule is not enabled.

1841

ghs_typedef_must_be_unique

typedef name conflict between entity-kind "entity" (declared at line xxxx) and identifier

This diagnostic is only issued when the compiler checks for conformance with an associated MISRA rule. As such, it will not be issued (at any severity) if the associated MISRA rule is not enabled.

1842

ghs_tag_must_be_unique

tag name conflict between entity-kind "entity" (declared at line xxxx) and identifier

This diagnostic is only issued when the compiler checks for conformance with an associated MISRA rule. As such, it will not be issued (at any severity) if the associated MISRA rule is not enabled.

1843

ghs_static_storage_id_reuse_not_allowed

static storage name conflict between entity-kind "entity" (declared at line xxxx) and identifier

This diagnostic is only issued when the compiler checks for conformance with an associated MISRA rule. As such, it will not be issued (at any severity) if the associated MISRA rule is not enabled.

1844

ghs_identical_param_and_return_types_required

parameter or return type in declaration different from prototype entity-kind "entity" (declared at line xxxx)

GHS Standard Mode enables this diagnostic.

1845

ghs_too_many_break_statements

multiple break statements per iteration statement not allowed

1846

ghs_definition_in_header_file

object or function defined in header file

1847

ghs_complex_integer_cast_not_allowed

cast of complex integer expression with underlying type "type" to non-integer type "type" not allowed

1848

ghs_complex_float_cast_not_allowed

cast of complex floating point expression from type "type" to type "type" not allowed

1849

ghs_bitwise_expr_needs_cast

bitwise ~ or << expression must be immediately cast back to underlying type, "type"

1850

ghs_plain_char_for_char_values_only

plain char type can only be used for storage of character values

This diagnostic is only issued when the compiler checks for conformance with an associated MISRA rule. As such, it will not be issued (at any severity) if the associated MISRA rule is not enabled.

1851

ghs_non_plain_char_for_numeric_values_only

signed or unsigned char type can only be used for storage of numeric values

1852

ghs_plain_char_operand_not_allowed

only assignment and equality operators may be used on plain char operand

1853

ghs_boolean_expr_required

effectively boolean expression required

1854

ghs_boolean_expr_not_allowed

effectively boolean expression not allowed

This diagnostic is only issued when the compiler checks for conformance with an associated MISRA rule. As such, it will not be issued (at any severity) if the associated MISRA rule is not enabled.

1855

ghs_explicit_test_required

explicit test against zero required

1856

ghs_inc_or_dec_result_used

result of increment or decrement expression may not be used

1857

ghs_boolean_op_is_invariant

result of boolean operation is invariant

1858

ghs_subscript_on_array_type_only

subscript operator may only be applied to objects declared as an array type

1859

ghs_macro_misuse_not_allowed

macro definition can only be used for a braced initializer, constant, parenthesized expression, type qualifier, storage class specifier, or do-while-zero construct

This diagnostic is only issued when the compiler checks for conformance with an associated MISRA rule. As such, it will not be issued (at any severity) if the associated MISRA rule is not enabled.

1860

ghs_macros_must_balance_brackets

macro definition must balance all braces, parentheses, and brackets

This diagnostic is only issued when the compiler checks for conformance with an associated MISRA rule. As such, it will not be issued (at any severity) if the associated MISRA rule is not enabled.

1861

ghs_reserved_name_redef_or_undef

reserved identifier, macro, or function name "xxxx" cannot be defined, redefined, or undefined

1862

ghs_function_like_macro_not_allowed

function-like macro not allowed -- use function instead

1863

ghs_non_integer_implicit_conversion_not_allowed

implicit conversion from underlying type, "type", to non-integer underlying type, "type", not allowed

This diagnostic is only issued when the compiler checks for conformance with an associated MISRA rule. As such, it will not be issued (at any severity) if the associated MISRA rule is not enabled.

1864

ghs_narrowing_implicit_conversion_not_allowed

implicit conversion from underlying type, "type", to narrower underlying type, "type", not allowed

This diagnostic is only issued when the compiler checks for conformance with an associated MISRA rule. As such, it will not be issued (at any severity) if the associated MISRA rule is not enabled.

1865

ghs_same_width_implicit_conversion_not_allowed

implicit conversion from underlying type, "type", to same width underlying type, "type", not allowed

This diagnostic is only issued when the compiler checks for conformance with an associated MISRA rule. As such, it will not be issued (at any severity) if the associated MISRA rule is not enabled.

1866

ghs_signedness_changing_implicit_conversion_not_allowed

implicit conversion from underlying type, "type", to underlying type, "type", changes signedness

This diagnostic is only issued when the compiler checks for conformance with an associated MISRA rule. As such, it will not be issued (at any severity) if the associated MISRA rule is not enabled.

1867

ghs_complex_implicit_conversion_not_allowed

implicit conversion of complex expression from underlying type, "type", to underlying type, "type", not allowed

This diagnostic is only issued when the compiler checks for conformance with an associated MISRA rule. As such, it will not be issued (at any severity) if the associated MISRA rule is not enabled.

1868

ghs_arg_implicit_conversion_not_allowed

implicit conversion of non-constant function argument from underlying type, "type", to underlying type, "type", not allowed

This diagnostic is only issued when the compiler checks for conformance with an associated MISRA rule. As such, it will not be issued (at any severity) if the associated MISRA rule is not enabled.

1869

ghs_ret_implicit_conversion_not_allowed

implicit conversion of non-constant return expression from underlying type, "type", to underlying type, "type", not allowed

This diagnostic is only issued when the compiler checks for conformance with an associated MISRA rule. As such, it will not be issued (at any severity) if the associated MISRA rule is not enabled.

1870

ghs_boolean_implicit_conversion_not_allowed

implicit conversion of boolean expression from underlying type, "type", to underlying type, "type", not allowed

This diagnostic is only issued when the compiler checks for conformance with an associated MISRA rule. As such, it will not be issued (at any severity) if the associated MISRA rule is not enabled.

1871

ghs_non_float_implicit_float_conversion_not_allowed

implicit conversion from floating type, "type", to non-floating type, "type", not allowed

This diagnostic is only issued when the compiler checks for conformance with an associated MISRA rule. As such, it will not be issued (at any severity) if the associated MISRA rule is not enabled.

1872

ghs_narrowing_implicit_float_conversion_not_allowed

implicit conversion from floating type, "type", to narrower type, "type", not allowed

This diagnostic is only issued when the compiler checks for conformance with an associated MISRA rule. As such, it will not be issued (at any severity) if the associated MISRA rule is not enabled.

1873

ghs_complex_implicit_float_conversion_not_allowed

implicit conversion of complex floating point expression from type, "type", to type, "type", not allowed

This diagnostic is only issued when the compiler checks for conformance with an associated MISRA rule. As such, it will not be issued (at any severity) if the associated MISRA rule is not enabled.

1874

ghs_arg_implicit_float_conversion_not_allowed

implicit conversion of function argument from floating type, "type", to type, "type", not allowed

This diagnostic is only issued when the compiler checks for conformance with an associated MISRA rule. As such, it will not be issued (at any severity) if the associated MISRA rule is not enabled.

1875

ghs_ret_implicit_float_conversion_not_allowed

implicit conversion of return expression from floating type, "type", to type, "type", not allowed

This diagnostic is only issued when the compiler checks for conformance with an associated MISRA rule. As such, it will not be issued (at any severity) if the associated MISRA rule is not enabled.

1876

ghs_end_of_line_comment_not_allowed

// style comment not allowed

1877

ghs_null_ptr_cast_not_allowed

cast of 0 from type "type" to type "type" not allowed

1878

ghs_widening_complex_integer_cast_not_allowed

cast of complex integer expression with underlying type "type" to wider type "type" not allowed

1879

ghs_same_width_complex_integer_cast_not_allowed

cast of complex integer expression with underlying type "type" to same width type "type" not allowed

1880

ghs_signedness_changing_complex_integer_cast_not_allowed

cast of complex integer expression with underlying type "type" to type "type" changes signedness

1881

ghs_explicit_test_of_constant_required

explicit test of constant against zero required

1882

ghs_header_needs_include_guard

header file needs guard to prevent multiple inclusion

1883

ghs_call_of_virtual_in_ctor_or_dtor

call of virtual function inside constructor or destructor when extract vptrs is used

1884

ghs_break_required

previous non-empty case clause doesn't fall through but must be terminated with a break statement

This diagnostic is only issued when the compiler checks for conformance with an associated MISRA rule. As such, it will not be issued (at any severity) if the associated MISRA rule is not enabled.

1885

ghs_underscore_name_redef_or_undef

reserved identifier, macro, or function name "xxxx" beginning with an underscore cannot be defined, redefined, or undefined

1886

ghs_cmd_line_macro_misuse_not_allowed

command-line macro definition can only be used for a braced initializer, constant, parenthesized expression, type qualifier, storage class specifier, or do-while-zero constructxxxx

This diagnostic is only issued when the compiler checks for conformance with an associated MISRA rule. As such, it will not be issued (at any severity) if the associated MISRA rule is not enabled.

1887

ghs_tda_disabled

TDA is disabled for this configuration

1888

ghs_keyword_def_or_undef

#define or #undef of keyword "xxxx"

1889

ghs_bad_alignfunc_alignment

invalid alignfunc value

1890

ghs_init_but_not_modified

initialized non-const entity-kind "entity" was used but never modified

1891

ghs_invalid_section_renaming_option

invalid section renaming option: xxxx

1892

ghs_bitwise_with_comparison

comparison operator has higher precedence than bitwise operator; parentheses recommended

GHS Standard Mode enables this diagnostic.

1893

ghs_wrong_constructor_init_order

entity-kind "entity" will be initialized before the previous constructor initializer, entity-kind "entity"

1894

ghs_prototype_restrict_qualifiers_differ

"restrict" qualifier in declaration different from prototype entity-kind "entity" (declared at line xxxx)

1895

ghs_bool_to_pointer_conversion

implicit conversion from bool to pointer type

1896

ghs_reserved_tracereg_use

use of reserved trace register

1897

ghs_invalid_dc_pragma

incorrect #pragma double_check xxxx

1898

ghs_if_statement_no_effect

if statement does not affect control flow

1899

ghs_gets_unsafe

use of gets is unsafe; use fgets instead

GHS Standard Mode enables this diagnostic.


Diagnostics 1900 to 1999

1900

ghs_scanf_unsafe

use of %s in scanf is unsafe; specify a maximum field width

GHS Standard Mode enables this diagnostic.

1901

ghs_assign_const_addr_to_bool

assignment of constant address to bool

1902

ghs_defined_needs_identifier

defined must be followed by an identifier

1903

ghs_cannot_be_used_as_macro

"xxxx" cannot be used as a macro

1904

ghs_sizeof_array_parameter

sizeof pointer parameter yields size of pointer-to-type where size of array-of-type may have been intended

1905

ghs_bitwise_with_shift

shift operator has higher precedence than bitwise operator; parentheses suggested

1906

ghs_call_setjmp_or_longjmp

call to setjmp() and longjmp() is not allowed

GHS Standard Mode enables this diagnostic.

1907

ghs_call_atof_atoi_atol

call to atof(), atoi(), atol(), and atoll() is not allowed -- use strtof(), strtol(), or strtoll() instead

GHS Standard Mode enables this diagnostic.

1908

ghs_string_initializer_truncated

initialization of array of type "type" discards terminating null character

GHS Standard Mode enables this diagnostic.

1909

ghs_comma_only_in_1st_or_3rd_of_for_loop

comma operator only allowed in the first or third expression of a for loop

1910

ghs_part_of_expr_has_no_effect

part of expression has no effect

GHS Standard Mode enables this diagnostic.

1911

ghs_invalid_bit_field_initializer

this expression cannot be used as the initializer for a bit field

1912

ghs_global_reg_must_have_scalar_type

global register variable must have integral or pointer type

GHS Standard Mode enables this diagnostic.

1913

ghs_register_variable_too_wide

variable's type is too wide for a single machine register

GHS Standard Mode enables this diagnostic.

1914

ghs_bool_bitfield_remark

declared size for boolean bit-field is greater than 1

1915

ghs_cast_involves_incomplete_class_pointer

cast involving pointer to incomplete class type "type" will not adjust for inheritance

GHS Standard Mode enables this diagnostic.

1916

ghs_alignof_bitfield

__alignof__ operator cannot be applied to a bit-field

1917

ghs_zero_size_ptrdiff

subtraction of pointers to zero-sized type "type"

1918

ghs_too_many_variables

out of resources while compiling function "xxxx" (internal variable limit exceeded)

The compiler limits the number of variables you can have per function to 65536, which is what causes this error. This limit includes both explicitly declared variables and internal variables the compiler produces. There is no way to increase this limit. One common cause of this error is run-time error checking, which instruments the C code and creates many internal variables. You might want to work around the limitation by selectively disabling run-time error checks.

1922

ghs_string_literal_comparison

comparison with string literal has unspecified result

1923

ghs_unusual_pointer_literal_comparison

unusual comparison of non-integer literal to pointer

1924

ghs_unusual_pointer_literal_assignment

unusual assignment of non-integer literal to pointer

1925

ghs_ufd_type_requires_constructor

type "type" must define a default constructor to initialize its members lacking default constructors

1926

ghs_ufd_uninitialized_fields

entity-kind "entity" does not initialize the following fields:

1927

ghs_ufd_arg_is_not_modifiable_pointer

initialized argument must be a pointer or reference to non-const

GHS Standard Mode enables this diagnostic.

1928

ghs_ufd_arg_does_not_exist

argument index is greater than number of parameters

1929

ghs_plain_bitfield_may_overflow

bit-field of same width as underlying type should be explicitly "signed" or "unsigned"

1930

ghs_cannot_override_final_member_function

member entity-kind "entity" is marked "final" and cannot be overridden

1931

ghs_sizeof_complicated_expression

operand of sizeof is not a type, variable, or dereferenced pointer expression

GHS Standard Mode enables this diagnostic.

1932

ghs_variable_format_string

format string parameter is not a compile-time constant

This diagnostic is suppressed in cases where the diagnostic-triggering format string argument is both a parameter of the enclosing function and specified to be a format string. For example, when the enclosing function is annotated with _attribute_((format(printf,x,y))).

GHS Standard Mode enables this diagnostic.

1933

ghs_va_list_passed_to_ellipsis

"va_list" passed through ellipsis

1934

ghs_struct_passed_to_ellipsis

aggregate type passed through ellipsis

1935

ghs_constructor_should_be_explicit

one-argument constructor should be declared "explicit"

This remark is issued whenever you declare a one-argument constructor without the explicit keyword. A non-explicit constructor participates in implicit type conversions. For example:

struct Integer {
  int value;
  Integer(int v): value(v) {}
};
void foo(const Integer &i);
int main() { foo(0); } //Implicit conversion to Integer

This program compiles because 0 may be implicitly converted to Integer via the non-explicit constructor. By adding the explicit keyword, you prevent such conversions; to pass 0 to foo(), you would have to write:

struct Integer {
  int value;
  explicit Integer(int v): value(v) {}
};
void foo(const Integer &i);
int main() { foo(Integer(0)); }

1936

ghs_comparison_of_comparison

comparison of comparison where two comparison expressions may have been intended

1937

ghs_dubious_comparison_of_bool

possibly unintentional comparison of bool to non-bool

GHS Standard Mode enables this diagnostic.

1938

ghs_bytereversed_bitfield

byte ordering qualifiers do not apply to bit-fields

1939

ghs_bytereversed_parameter

byte ordering qualifiers do not apply to parameters

1940

ghs_bytereversed_initializer

byte-reversed objects cannot be statically initialized

1941

restrict_qualifier_ignored

restrict qualifier is ignored

1942

ghs_attribute_requires_typedef

attribute "xxxx" may only be applied to a typedef

1943

ghs_strong_typedef_forbids_implicit_conversion

strong typedef rules forbid implicit conversion from type "type" to type "type"

1944

ghs_two_cases_required_for_switch

switch statement must contain at least two cases

1945

ghs_attribute_ignored_in_this_context

the "xxxx" attribute is ignored in this context

1946

ghs_obsolete_attribute_syntax

type attributes should follow the class/struct/union/enum keyword, not the closing brace

1947

ghs_field_not_at_requested_offset

struct field is being placed at offset xxxx instead of requested offset

This error is issued in connection with the at attribute.

1948

ghs_address_of_member_function_with_calling_convention

a member function with a non-default calling convention may not have its address taken

1949

ghs_placement_array_new

placement new[] may invoke undefined behavior and should not be used

1950

ghs_multiple_definitions_of_symbol

multiple definitions of symbol "xxxx"

1951

ghs_virtual_function_without_virtual_keyword

virtual entity-kind "entity" should be declared "virtual"

1952

ghs_addition_inside_shift

+ or - operator has higher precedence than shift operator; parentheses recommended

1953

ghs_string_concatenation

adjacent string literals will be concatenated

1954

ghs_strncmp_argument_mismatch

third argument to strncmp does not match the length of the string literal argument

1955

ghs_memset_length_is_zero

third argument to memset is zero; second and third arguments may have been swapped accidentally

1956

ghs_length_is_not_multiple_of_target_size

sizeof argument xxxx to xxxx does not divide value of argument xxxx

1957

ghs_malloc_of_strlen

strlen used in memory allocation; strlen+1 was probably intended

1958

ghs_dubious_boolean_expression

implausible operator at top level of boolean expression

1959

ghs_uninitialized_local_variable

local entity-kind "entity" not initialized

1960

ghs_dubious_pair_of_comparisons

apparently redundant comparisons may indicate a mistake

1961

ghs_relational_comparison_to_null

pointer comparison to NULL depends on implementation-defined pointer signedness

1962

ghs_nonstd_case_range

case range syntax is non-standard

1963

ghs_right_brace_after_label

label not followed by statement is non-standard

GHS Standard Mode enables this diagnostic.

1964

ghs_cl_coding_standard_file_not_found

cannot open coding standard file xxxx

1965

ghs_cl_coding_standard_file_error

error in coding standard file: xxxx

1966

ghs_cl_tag_not_recognized

unused coding standard tag or malformed error number xxxx

1967

ghs_dangerous_trigraph

trigraph in source code has possibly unintended effect on semantics

GHS Standard Mode enables this diagnostic.

1968

ghs_uninitialized_local_struct_variable

local struct/union entity-kind "entity" not initialized

1969

ghs_lint_columns_dont_match

statement begins in column different from first statement in its block

1970

ghs_callt_not_supported

call tabled functions not supported in this compiler

1971

ghs_callt_interrupt_not_supported

call tabled interrupt functions are not supported

1972

ghs_multiple_noninterface_base_class

base specifier list contains more than one "non-interface" class

Java and some other object-oriented languages support multiple inheritance of “interfaces”, but only single inheritance of “implementation”. In C++ terms, an “interface” is a class that contains only pure virtual member functions and static member data (in other words, it does not contain code or non-static data members). This diagnostic is given whenever a class specifies two or more “non-interface” classes in its list of base classes.

1973

ghs_packed_qualifier_dropped

conversion drops "__packed" qualifier

1974

ghs_overloaded_and_or_comma

overloading the &&, ||, or comma operators is dangerous

1975

ghs_dyn_initializer

dynamic initialization causes code to be executed before main()

1976

ghs_long_constant_needs_suffix

"long" or "long long" constant should be suffixed to indicate type

1977

ghs_strong_fptr_forbids_explicit_conversion

strong fptr rules forbid explicit conversion from type "type" to type "type"

1978

ghs_strong_fptr_forbids_implicit_conversion

strong fptr rules forbid implicit conversion from type "type" to type "type"

1979

ghs_strong_fptr_forbids_union

strong fptr rules prohibit type "type" from being a member of a union

1980

ghs_not_enough_initializers

not enough initializers; trailing elements will be default-initialized

1981

ghs_empty_initializer_is_nonstandard

empty initializer is non-standard

1982

ghs_insufficient_stack_alignment

target stack alignment is insufficient to guarantee alignment of xxxx

1983

ghs_char_escape_backslash_e

character escape sequence "\e" is non-standard

1984

ghs_char_escape_octal

octal character escape sequences are not allowed

1985

ghs_char_escape_hexadecimal

hexadecimal character escape sequences are not allowed

1986

ghs_misra_shift_count_too_large

shift count is too large for underlying type "type"

1987

ghs_bad_ptr_ref_argument

argument of type "type" is incompatible with ptr_ref parameter

1988

ghs_fmt_arg_has_incorrect_type

format argument has incorrect type "type"

1989

ghs_mismatched_memcpy_sizes

arguments xxxx and xxxx to xxxx have pointer types whose targets differ in size

1990

ghs_memcpy_size_has_no_sizeof

argument xxxx to xxxx must be of the form n*sizeof(a)

1991

ghs_length_uses_wrong_sizeof

argument xxxx to xxxx has a type inconsistent with the sizeof-expression in argument xxxx

1996

ghs_linkonce_cannot_be_inline

a __linkonce function cannot be inline

1997

ghs_linkonce_cannot_be_static

a __linkonce function cannot be static

1999

ghs_misra_recursion

function "xxxx" contains possible recursion


Diagnostics 2000 to 2099

2000

ghs_attribute_not_implemented

attribute "xxxx" is not implemented and will be ignored

2001

ghs_function_like_macro_invocation_not_allowed

invocation of function-like macro not allowed

2002

ghs_character_greater_than_127

character greater than 127 not allowed

2003

ghs_pointer_to_larger_alignment

alignment of type pointed to by "type" is smaller than the one pointed to by "type", which may lead to a misaligned memory access

2004

ghs_signed_unsigned_promotion

operation promotes signed type "type" to unsigned type "type", which may lead to unintended results

2005

ghs_whitespace_after_backslash_not_recommended

"\" followed by white space is not a line splice

2006

ghs_sideeffect_missing_volatile

__[no]sideeffect must be preceded by volatile, otherwise it is ignored

2007

ghs_eagle_tag_bad_usage

'__ghs_eagle_tag' may only be used as a simple assignment inside of 'if' statement conditional; 'if' statement may not have 'else'

2008

ghs_no_var_init

potentially unintended initializer with no named variable

2009

ghs_sideeffect_nosideeffect_mix

mixing __sideeffect and __nosidefffect qualifiers not allowed

2010

ghs_strong_fptr_non_fptr_typedef

'strong_fptr' attribute invalid for non-function pointer typedef

2011

ghs_strong_fptr_unnamed_struct

'strong_fptr' attribute invalid for unnamed struct/class

2012

ghs_nonstd_static_assert

Use of static assertions is nonstandard

2013

ghs_future_library_name_redef_or_undef

identifier "xxxx" reserved for future library use cannot be defined, redefined, or undefined

2014

ghs_expression_in_dependent_typeof

an expression is not allowed in a template-dependent typeof specifier

2015

ghs_strong_fptr_with_struct_member_no_sfptr

type "type" has non-strong function pointers -- it cannot be a member or base class of strong_fptr type "type"

2016

ghs_sideeffect_qualifier_on_automatic_var

non-static local variable may not be qualified by, or contain field qualified by, '__sideeffect'

2017

ghs_unsequenced_assignments

detected potentially undefined behavior resulting from multiple unsequenced assignments to a stored value

2018

ghs_unsequenced_assignment_and_use

detected potentially undefined behavior resulting from an unsequenced read of, and assignment to, a stored value

2019

ghs_uninitialized_local_array_variable

local array entity-kind "entity" not initialized

2020

ghs_packing_of_non_POD

packing ignored on non-POD type "type"

2021

ghs_not_inlining_inline_func

not inlining call of inline function "xxxx" because xxxx

2022

ghs_not_inlining_always_inline_func

not inlining call of always_inline function "xxxx" because xxxx

2023

ghs_inlining_non_inline_func

inlining call of function "xxxx" even though it is not declared as inline

2024

ghs_optimization_attribute_conflict

conflicting optimization strategy attribute

2025

ghs_strong_fptr_converted_to_non_strong_type

strong fptr type "type" converted to non-strong fptr type "type"

2026

ghs_non_strong_type_converted_to_strong_fptr

non-strong fptr type "type" converted to strong fptr type "type"

2027

ghs_split_section_exists_as_user_section

section "xxxx" already exists as a user-defined section, not being used as individual section

2028

ghs_user_section_exists_as_split_section

user defined section "xxxx" was used as an individual section, potentially undefined behavior

2029

ghs_identifier_on_blacklist

identifier "xxxx" is on blacklist

2030

ghs_bool_expr_mcdc_ready

boolean expression is not MC/DC ready

2031

ghs_target_does_not_support_thread_local

thread local storage is not supported for this target

2032

ghs_array_element_alignment_exceeds_size

cannot honor element alignment: size of array element is less than alignment of array element

2033

ghs_unintentional_loss_of_precision

arithmetic operation loses precision -- consider adding an explicit cast to one of the operands

2034

ghs_invalid_register_number

register is not a globalreg-reserved register

The compiler only allows mapping a global variable to a specific register if it is one of the registers available with the use of the -globalreg option. For more information, see “GNU C/C++ Extensions”.

2035

ghs_cannot_allocate_specified_register

cannot allocate "xxxx" to specified register

The compiler rejects mapping variables to registers that are not general purpose or that are used in instruction sequences implemented using fixed registers. For more information, see “GNU C/C++ Extensions”.

2036

ghs_cannot_allocate_specified_caller_saved_register

cannot allocate "xxxx" to specified caller-saved register

The compiler rejects mapping variables to caller-saved registers. This is because such registers are potentially overwritten by function calls during the variables' lifetime. For more information, see “GNU C/C++ Extensions”.

2037

ghs_extern_declared_but_not_referenced

extern entity-kind "entity" declared but not referenced

2038

ghs_static_routine_may_not_be_weak

a function with internal linkage may not be weak

2039

ghs_default_arg_on_block_extern_decl

default argument in block scope extern declaration differs from default argument from declaration in enclosing scope; the default argument value from the block scope declaration will be used (even if the enclosing scope's declaration is referenced directly via a qualified name)

The compiler rejects valid code in this instance to work around a non-conformance issue in its implementation of C++. For more information, see “Block Scope Declarations Not Ignored by Qualified Lookup”.

2040

ghs_default_clause_must_be_first_or_final_clause

default clause must be first or final clause of switch statement

2041

ghs_void_ptr_arith_cast_not_allowed

cast from type "type" to type "type" not allowed

2042

ghs_header_not_allowed

use of header file "xxxx" not allowed

2043

ghs_misaligned_field_referenced_early

entity-kind "entity" is misaligned and its address was referenced before the class was complete; the resulting pointer will not be implicitly __packed

2044

ghs_pragma_weak_deprecated_with_cxx

Using "#pragma weak" with C++ symbols is deprecated and may not work correctly; please use __attribute__((weak)) instead

2045

ghs_incomplete_return_type_for_vtable_thunk

entity-kind "entity" requires a virtual table thunk but its return type, "type", is incomplete. Please ensure that "type" is defined/instantiated in this translation unit.

2046

ghs_cannot_parse_macro_invocation

cannot parse this macro invocation

2047

ghs_float_literal_too_long

floating constant is too long.

2048

ghs_loop_vectorized

succeeded in vectorizing the loopxxxx

2049

ghs_direct_call_to_constructor

calling a constructor directly is not allowed

2050

ghs_lambda_init_capture_default_arg

lambda init-capture not allowed in default argument

2051

ghs_auto_func_not_alone

function with deduced return type must be only declaration on declarator list

2052

ghs_lambda_init_capture_followed_by_ellipsis

A lambda init-capture must not be followed by an ellipsis

2053

ghs_pointer_comparison_linktime_entity_not_accepted

pointer comparison of link-time entity is not accepted

2054

ghs_limit_macro_parameter_pasting

token concatenation of stringized macro parameter not allowed

2055

ghs_misra_forbidden_macro_expansion

expansion of macro xxxx is not allowed

2056

ghs_misra_forbidden_function

call to xxxx() is not allowed

2057

ghs_bad_type_for_load_no_speculate_call

first argument must be a pointer to integer or a pointer to pointer

2058

ghs_invalid_load_no_speculate_size

read object must be of size 1, 2, 4, or 8 bytes

2059

ghs_nonstd_relational_pointer_comparison_to_null

relational pointer comparison against a null pointer constant is not allowed

2060

ghs_no_splicing_single_line_comments

splicing a single-line comment is forbidden

2061

ghs_no_id_macro_overlap

identifiers not distinct from macro names; previously used as entity-kind "entity" (declared at line xxxx)

2062

ghs_defaulted_special_member_cannot_be_constexpr

defaulted special member function cannot be constexpr because the corresponding implicitly declared special member function would not be constexpr

2063

ghs_lowercase_l_literal_suffix

Lowercase 'l' is not allowed in a literal suffix, use uppercase 'L' instead

2064

ghs_non_static_inline_function

inline functions must have static storage class

2065

ghs_if_directive_not_zero_or_one

the condition of an #if directive must evaluate to zero or one

2066

ghs_extern_func_defn_without_decl

definition of external function without a prior declaration

2067

ghs_extern_object_defn_without_decl

definition of external object without a prior declaration

2068

ghs_sym_not_allowed

xxxx is not allowed

2069

ghs_terminate_hex_and_octal_escapes

all octal or hex escape sequences may only be followed by an escape sequence

2070

ghs_static_in_array_declarator

static used in array declarator

2071

ghs_function_return_value_not_used

function return value not used

2072

ghs_implicit_enum_values_must_be_unique

an enumerator with an implicit value may not have the same value as another enumerator

2073

ghs_no_backwards_gotos

backwards gotos are not allowed

2074

ghs_designated_initializer_for_array_with_no_bound

designated initializers may not be used for an array without an explicit bound

2075

ghs_object_element_initialized_more_than_once

there is more than one initializer for this element

2076

ghs_result_value_of_assignment_is_used

the resulting value of this assignment is used

2077

ghs_conv_involving_ptr_to_incomplete_type

conversion to or from pointer to incomplete type is not allowed

2078

ghs_function_parameter_modified

function parameter modified

2079

ghs_function_parameter_nonconst_addr

non-constant pointer to function parameter

2080

ghs_incr_or_decr_with_other_side_effects

increment or decrement in full expression with other side effects

2081

ghs_no_strings_in_memcmp

string argument may not be passed to memcmp

2082

ghs_match_types_in_memcmp

both pointers passed to memcmp, memmove, or memcpy must have compatible types

2083

ghs_memcmp_restricted_type

memcmp argument is a forbidden type

2084

ghs_null_pointer_constant_must_be_explicit

null pointer constants must be of the form 'NULL' or '(void*)0'

2085

ghs_no_deref_of_stdio_file_type

pointers to the C library's FILE type should not be dereferenced

2086

ghs_restricted_cast

invalid cast from "type" to "type": essential types do not match

2087

ghs_no_side_effect_in_initializer_list

initializer lists shall not contain side effects

2088

ghs_goto_must_be_to_same_or_enclosing_block

goto must be to the same or an enclosing block

2089

ghs_array_must_be_fully_initialized

array must be fully initialized

2090

ghs_type_could_be_opaque

type definition unnecessary in this scope; consider an opaque type

2091

ghs_no_implicit_conversion_on_assignment

invalid implicit assignment of underlying type "type" to underlying type "type"

2092

ghs_no_implcit_assignment_widening

invalid assignment of underlying type "type" to wider underlying type "type"

2093

ghs_macro_arg_expanded_and_unexpanded

mixed usage of argument in macro: it is used in an expandable form and in a non-expandable form (i.e. as an operand of # or ##)

2094

ghs_array_param_not_enough_elements

argument passed to array parameter does not have enough elements

2095

ghs_static_array_param_not_enough_elements

argument passed to array parameter with static keyword does not have enough elements

2096

ghs_function_defined_with_old_style_params

function defined with old-style parameter list

2097

ghs_at_most_one_break_or_goto_out_of_iter_stmt

More than one break or goto out iteration statement at line xxxx

2098

ghs_inappropriate_essentially_char_add_sub

Inappropriate use of essential char type in additive operator

2099

ghs_inappropriate_essential_type_for_operand

Inappropriate essential type used in operand


Diagnostics 2100 to 2199

2100 | ghs_different_essential_type_category_for_usual_arithmetic_conversions Usual arithmetic conversions performed on operands with different essential type categories
2101 | ghs_language_extensions_not_allowed language extensions are not allowed
2102 | ghs_type_declared_in_file_but_not_referenced type "xxxx" was declared but never referenced
2103 | ghs_tag_declared_in_file_but_not_referenced tag "xxxx" was declared but never referenced
2104 | ghs_macro_declared_in_file_but_not_referenced macro "xxxx" was declared but never referenced
2105 | ghs_no_implicit_arithmetic_widening implicit cast of composite expression with essential type "type" to wider type "type" not allowed
2106 | ghs_too_many_volatile_reads expression has too many volatile reads
2107 | ghs_too_many_volatile_writes expression has too many volatile writes
2108 | ghs_no_composite_cast_widening invalid cast from "type" to "type": cannot cast to wider essential type
2109 | ghs_alignment_change_yields_non_portable_type xxxx is a struct with an explicit change in alignment -- this may cause the calling convention to be non-portable
2110 | ghs_newline_expected_after_pragma_asm newline expected after #pragma asm
2111 | ghs_max_template_depth_exceeded maximum template depth exceeded
2112 | ghs_max_operator_arrow_depth_exceeded maximum operator arrow depth exceeded
2114 | ghs_multiple_matches_in_c11_generic selector type matches multiple associations
2115 | ghs_const_inline_static_data_member_without_initializer a const inline static data member declaration requires an in-class initializer
2116 | ghs_alias_template_requires_template_arguments entity-kind "entity" (declared at line xxxx) used without template arguments
2117 | ghs_cannot_resolve_pack cannot resolve parameter pack
2118 | ghs_problematic_attr_alignment_reduction_on_typedef this attribute reduces the alignment of the typedef, and while that will be respected for struct/field layout, the compiler will not generate code to handle misaligned accesses for objects of this type
2119 | ghs_strong_fptr_cannot_distinguish_functions cannot overload functions distinguished by a difference in strong function pointer type alone
2120 | ghs_strong_fptr_redecl_mismatch this redeclaration has a different strong function pointer type than the original declaration
2121 | ghs_pct_n_with_printf_s %n specifier not allowed with printf_s
2122 | ghs_bitwise_copy_of_non_trivially_copyable_type this object is not trivially copyable; bitwise copies/writes may invoke undefined behavior
2123 | ghs_misaligned_ptr_cast_not_allowed CERT EXP36-C: conversion from type "type" (alignment: n) to type "type" (alignment: n) not allowed
2124 | ghs_cyclomatic_complexity_mismatch cyclomatic complexity mismatch: evaluated at n vs expected (limit) n
2125 | ghs_cyclomatic_complexity_construct_not_supported cyclomatic complexity checking does not currently support this construct
2126 | ghs_comparing_padding_not_allowed CERT EXP42-C: cannot pass type "type" to memcmp: points to a struct/union with n byte(s) + n bit(s) of padding after field "xxxx" (at offset n byte(s) + n bit(s))
2127 | ghs_unsafe_ato_conversion_not_allowed CERT ERR34-C: xxxx performs unsafe string-to-number conversion; use xxxx instead
2128 | ghs_unsafe_scanf_parse_not_allowed CERT ERR34-C: unsafe string-to-number conversion performed during scanf/fscanf/sscanf parsing; use fgets and a strto*() function instead
2129 | ghs_strto_with_null_not_allowed CERT ERR34-C: cannot call xxxx with null as the second argument; unsafe string-to-number conversion
2130 | ghs_struct_last_field_no_size_one_array CERT DCL38-C: possible improper declaration of flexible array member detected (last member of multi-element struct cannot be an array of size 1)
2131 | ghs_no_passing_padded_struct CERT DCL39-C: cannot pass a padded struct/union into a function: "type" contains n byte(s) + n bit(s) of padding after field "xxxx" (at offset n byte(s) + n bit(s))
2132 | ghs_no_calling_va_arg_with_impossible_type CERT EXP47-C: cannot call va_arg with type "type": will never match due to default argument promotion; use type "type" instead
2133 | ghs_no_scanf_string_specifier_without_width CERT STR31-C: scanning in an unbounded number of characters can cause a buffer overflow; add a width subspecifier
2134 | ghs_no_sprintf CERT STR31-C: using sprintf is risky and can cause a buffer overflow; use snprintf instead
2135 | ghs_must_allocate_flex_array_structs_dynamically CERT MEM33-C: Flex array structs must be allocated dynamically (otherwise no space reserved for the flex array)
2136 | ghs_no_dereference_flex_array_struct_ptr CERT MEM33-C: Cannot dereference pointer to flex array struct (can cause copy of incorrect size)
2137 | ghs_no_storing_or_modifying_temp_array CERT EXP35-C: Cannot modify a temporary array or access it after the end of the sequence point (undefined behavior)
2138 | ghs_fast_eof_msg fasteof: xxxx
2139 | ghs_fast_eof_msg2 fasteof: xxxx at line xxxx
2140 | ghs_stack_frame_may_overrun_guard_page Stack frame of function "xxxx" has size xxxx bytes, which is large enough to bypass stack overflow guard pages (typically 4095 bytes)
2141 | ghs_side_effect_in_unevaluated_alignof_operand unevaluated operand of alignof operator has side effects
2142 | ghs_side_effect_in_unevaluated_generic_operand unevaluated operand of _Generic operator has side effects
2143 | ghs_ropi_addr_in_static_init address of a position independent object cannot be used in static initialization
2144 | ghs_attr_on_unsupported_target this attribute is not supported on this target
2145 | ghs_constraint_rule identifier "xxxx" is xxxx in constraint rules: xxxx
2146 | ghs_constraint_rule_file_syntax_error syntax error in constraint rules file: xxxx
2147 | ghs_indirect_warn_unused_result this function directly returns the value of a call to a 'warn_unused_result' function, but is not itself annotated with 'warn_unused_result'
2148 | ghs_pointer_arithmetic_subverts_alignment pointer arithmetic on this type will result in misaligned pointers (type "type" has size n, which is not a multiple of its alignment (n))
2149 | ghs_section_placement_failure variable xxxx is required to be placed in a xxxx-like section but is placed in xxxx
2150 | ghs_attr_ignored_after_definition this attribute has no effect because the entity it pertains to has already been defined
2151 | ghs_no_enum_arithmetic arithmetic operation performed on enum type
2152 | ghs_disallowed_side_effect this expression has side effects, which are not allowed here
2153 | ghs_adl_in_std_library this call to "xxxx" may use argument-dependent lookup, which is usually not allowed in the standard libraries
2154 | ghs_strong_fptr_passed_to_ellipsis strong fptr rules prohibit passing type "type" for an ellipsis parameter
2155 | ghs_bad_multibyte_char_in_comment invalid multibyte character sequence in comment
2156 | ghs_invalid_builtin_array_dim_arg invalid argument for __builtin_array_dim: xxxx
2157 | ghs_side_effects_in_unevaluated_arg argument to xxxx has side-effects but is unevaluated
2158 | ghs_has_cpp_attr_missing_lparen expected "(" after __has_cpp_attribute
2159 | ghs_destructor_calls_operator_delete a call to this destructor implicitly calls operator delete
2162 | ghs_strong_fptr_in_template_arg strong function pointers are not allowed as template arguments


Diagnostics 2300 to 2399

2301 | type_with_no_linkage_in_template_arg a template argument may not reference a type with no name linkage
2302 | virtual_ignored "virtual" is ignored here
2303 | vla_type_in_template_arg a template argument may not reference a variable-length array type
2304 | UCN_names_surrogate_code_point a universal character name cannot designate a surrogate code point
2305 | case_label_conflict case label value has already appeared in this switch at line xxxx
2306 | cl_unrecognized_unicode_source_kind unrecognized Unicode source kind (must be one of UTF-8, UTF-16, UTF-16LE, UTF-16BE): xxxx
2307 | bad_unicode_char_in_pp_output Unicode character with hex value xxxx not representable in preprocessing output
2308 | ctor_dtor_priority_reserved requested constructor/destructor priority is reserved for internal use
2309 | unrecognized_gcc_pragma unrecognized GCC pragma
2310 | unrecognized_gcc_visibility_pragma unrecognized GCC visibility pragma directive
2311 | unrecognized_visibility unrecognized visibility kind
2312 | ELF_visibility_pop_mismatch visibility pragma was still active
2313 | ELF_visibility_stack_empty no matching visibility push
2314 | typeid_of_incomplete_type typeid of incomplete type
2316 | array_size_one_assumed array entity-kind "entity" assumed to have one element
2317 | vector_size_attribute_requires_integral_floating_or_enum_type vector_size attribute requires an arithmetic or enum type
2318 | vector_size_too_large vector size is too large
2319 | vector_size_must_be_power_of_two the number of elements in a vector must be a power of two
2320 | vector_size_must_be_multiple_of_element_size vector size must be a multiple of the element size
2321 | mixed_vector_scalar_operation mixed vector-scalar operation not allowed
2322 | vectors_must_have_same_size operation requires two vectors of the same size
2323 | dependent_vector_size template-dependent vector size is not allowed
2326 | vector_size_attribute_on_complex_type vector_size attribute is not allowed with a complex element type
2328 | vector_element_type_mismatch vector operation requires identical element types
2329 | vector_operation_requires_integer_vector vector operation does not apply to vector with non-integral type
2330 | cannot_open_file cannot open xxxx file "xxxx"
2331 | cannot_open_file_reason cannot open xxxx file "xxxx": xxxx
2337 | file_write_error_errno error while writing xxxx file: xxxx
2346 | il_output IL output
2347 | restrict_qualifier_dropped conversion drops "__restrict" qualifier
2348 | unable_to_get_mapped_memory_reason unable to obtain mapped memory for "xxxx": xxxx
2349 | nonstandard_array_with_flexible_array_element array of elements containing a flexible array member is nonstandard
2350 | vector_template_parameter a template parameter may not have a vector type
2351 | out_of_order_ctor_init the initialization of entity-kind "entity" will be done before that of entity-kind "entity"
2353 | inheritance_kind_ignored_on_enum inheritance kind is ignored on an enum specifier
2355 | extended_modifier_ignored_on_enum modifier is ignored on an enum specifier
2356 | non_unicode_char_in_ident identifier character cannot be represented in Unicode
2357 | non_unicode_char_in_header header name contains characters that cannot be represented in Unicode
2358 | invalid_locale "xxxx" is not a valid locale name
2359 | nonstd_template_void_param_list declaring a void parameter list with a template parameter is nonstandard
2360 | cl_lambdas_option_only_in_cplusplus lambdas option can be used only when compiling C++
2361 | capture_mode_matches_default explicit capture matches default
2362 | not_a_variable entity-kind "entity" is not a variable
2363 | capture_of_static_duration_variable a variable with static storage duration cannot be captured in a lambda
2364 | cannot_capture_this_by_reference "this" cannot be captured by reference
2365 | this_in_lambda "this" cannot be used inside the body of this lambda
2366 | anon_union_ref_in_lambda a member of an outer-scope anonymous union cannot be referenced inside the body of a lambda
2367 | not_captured_local_var_in_lambda an enclosing-function local variable cannot be referenced in a lambda body unless it is in the capture list
2368 | bad_local_var_in_lambda invalid reference to an outer-scope local variable in a lambda body
2369 | captured_local_var_not_in_innermost_function a local variable outside the current function scope cannot be captured
2370 | not_captured_this_in_lambda the enclosing-function "this" cannot be referenced in a lambda body unless it is in the capture list
2372 | captured_var_type_not_copyable lambda captured variable of type "type" cannot be copied to closure class field of type "type"
2373 | cl_invalid_template_directory invalid template directory: xxxx
2374 | enum_value_out_of_underlying_range enumeration value is outside the range of its underlying type ("type")
2375 | not_a_line_splice "\" followed by white space is not a line splice
2376 | dynamic_cast_without_rtti this dynamic_cast cannot be done without runtime type information, which is disabled
2377 | ambiguous_cast_selects_direct_base conversion to "type" is ambiguous; direct base selected
2378 | requested_size_too_large an internal buffer would be too large
2379 | exception_handler_used C++ exception handler used, but exception handling semantics have not been specified
2380 | type_qualifier_ignored_on_constructor type qualifier ignored on constructor
2381 | lambda_capture_involves_variable_length_array a variable captured by a lambda cannot have a type involving a variable-length array
2382 | incompatible_vectors_conversion conversion between incompatible vector types
2383 | missing_lambda_body expected a "{" introducing a lambda body
2384 | cl_rvalue_references_option_only_in_cplusplus rvalue references option can be used only when compiling C++
2385 | type_qualifier_on_lambda a type qualifier is not allowed on a lambda
2386 | more_than_one_capture a name cannot appear more than once in a capture-list
2387 | explicit_template_args_ignored explicit template arguments ignored
2388 | bad_constant_lambda a lambda is not allowed in a constant expression
2389 | class_type_required "type" is not a class type
2390 | delete_of_array_type "delete" applied to a pointer-to-array type treated as delete[]
2391 | delete_of_array_type_nonstandard "delete" applied to a pointer-to-array type is nonstandard; treated as delete[]
2392 | function_does_not_match_arguments entity-kind "entity" cannot be called with the given argument list
2393 | rvalue_reference_bound_to_lvalue an rvalue reference cannot be bound to an lvalue
2394 | rvalue_ref_template_parameter a nontype template parameter cannot have rvalue reference type
2395 | type_qualifiers_ignored_on_reference type qualifiers are ignored (underlying type is a reference)
2396 | decl_with_local_type_but_not_defined entity-kind "entity", declared using a local type, must be defined in this translation unit
2397 | decl_with_no_linkage_type_but_not_defined entity-kind "entity", declared using a type with no linkage, must be defined in this translation unit
2398 | bad_rvalue_ref_dynamic_cast_operand the operand of an rvalue reference dynamic_cast must have a complete class type
2399 | invalid_function_to_be_defaulted "= default" can only appear on default constructors, copy/move constructors, copy/move assignment operators, and destructors


Diagnostics 2400 to 2499

2400 | deleted_function_definition_must_be_first_declaration "= delete" can only appear on the first declaration of a function
2401 | deleted_function entity-kind "entity" (declared at line xxxx) cannot be referenced -- it is a deleted function
2402 | bad_unevaluated_lambda a lambda is not allowed in an unevaluated expression
2403 | bad_function_for_gnu_va_arg_pack __builtin_va_arg_pack/__builtin_va_arg_pack_len can appear only in an inline function with an ellipsis parameter
2404 | function_defaulted_in_friend_decl "= default" cannot be specified on a friend declaration
2405 | exp_cpp_keyword expected a C++ keyword
2407 | nonconstant_offsetof offset is not constant
2408 | unrecognized_microsoft_comment_pragma_type unrecognized #pragma comment type "xxxx"
2409 | cl_auto_type_option_only_in_cplusplus option to control whether "auto" is a type specifier can be used only when compiling C++
2410 | cl_auto_storage_option_only_in_cplusplus option to control whether "auto" is a storage class can be used only when compiling C++
2411 | cl_auto_cannot_be_disabled the type specifier and storage class specifier meanings of "auto" cannot both be disabled
2412 | bad_pragma_comment_string invalid string in #pragma comment
2413 | deleted_function_overrides_nondeleted_function deleted function overrides nondeleted entity-kind "entity"
2414 | nondeleted_function_overrides_deleted_function nondeleted function overrides deleted entity-kind "entity"
2415 | deleted_default_constructor the default constructor of "type" cannot be referenced -- it is a deleted function
2416 | rvalue_reference_catch_type an rvalue reference is not allowed as a catch type
2417 | default_args_incompatible default arguments of entity-kind "entity" is incompatible with a declaration in another translation unit
2418 | default_arg_differs_in_other_trans_unit default arguments of entity-kind "entity" were different during compilation of "xxxx"
2420 | initializers_incompatible initializer for entity-kind "entity" is different in another translation unit
2421 | initializer_differs_in_other_trans_unit initializer for entity-kind "entity" was different during compilation of "xxxx"
2422 | designator_for_template_dependent_type a designator into a template-dependent type is not allowed
2423 | invalid_pragma_conform_kind unrecognized conformance kind
2424 | exp_on_or_off expected "on" or "off"
2425 | forScope_stack_empty #pragma conform(forScope) stack is empty
2426 | no_matching_forScope_stack_entry no previous #pragma conform(forScope) entry matches "xxxx"
2427 | show_pragma_conform_forScope_is_nonstandard forScope behavior is nonstandard
2428 | show_pragma_conform_forScope_is_standard forScope behavior is standard
2429 | deleted_main function "main" cannot be deleted
2430 | invalid_assignment_operator_to_be_defaulted invalid type for defaulted assignment operator
2431 | function_template_cannot_be_defaulted function templates cannot be defaulted
2432 | invalid_constructor_to_be_defaulted invalid type for defaulted constructor
2433 | call_requires_one_argument function call requires one argument
2434 | call_requires_floating_point_argument function call requires a real floating-point argument
2435 | copy_ctor_with_default_arg_cannot_be_defaulted a copy constructor with a default argument cannot be defaulted
2436 | predeclared_function_cannot_be_deleted a predeclared function cannot be deleted
2437 | empty_then_statement empty dependent statement in if-statement
2438 | empty_else_statement empty dependent statement in "else" clause of if-statement
2439 | deleted_elided_cctor entity-kind "entity" (declared at line xxxx), required for copy that was eliminated, cannot be referenced -- it is a deleted function
2440 | main_first_param_not_int nonstandard first parameter "type" of "main", expected "int"
2441 | main_wrong_num_params nonstandard number of parameters for "main", expected zero or two parameters
2442 | main_second_param_wrong_type nonstandard second parameter "type" of "main", expected "char *[]" or "char **"
2443 | incl_dir_both_sys_and_nonsys "xxxx" was specified as both a system and non-system include directory -- the non-system entry will be ignored
2444 | cl_rvalue_ctor_is_copy_ctor_option_only_in_cplusplus option to control move constructors and move assignment operators can be used only when compiling C++
2447 | trailing_return_type_requires_auto a trailing return type requires the "auto" type specifier
2448 | trailing_return_type_in_nested_declarator a trailing return type cannot appear in a nested declarator
2449 | trailing_return_type_function_without_simple_auto a function declarator with a trailing return type must be preceded by a simple "auto" type specifier
2450 | missing_trailing_return_type "auto" function requires a trailing return type
2451 | pure_virtual_member_template a member template cannot have a pure specifier
2452 | excess_characters_in_literal_ignored string literal too long -- excess characters ignored
2453 | cl_nullptr_option_only_in_cplusplus option to control the nullptr keyword can be used only when compiling C++
2454 | nullptr_conv_to_bool std::nullptr_t converted to bool
2457 | invalid_empty_attribute_arg_list attribute "xxxx" does not allow an empty argument list
2458 | attr_twice_in_group attribute appears more than once
2459 | wrong_entity_for_attribute attribute "xxxx" does not apply here
2460 | attr_disallows_bit_field attribute "xxxx" does not apply to bit fields
2461 | attr_requires_bit_field attribute "xxxx" requires a bit field
2462 | attr_disallows_member_function attribute "xxxx" does not apply to member functions
2463 | attr_requires_member_function attribute "xxxx" requires a member function
2464 | attr_disallows_virtual_function attribute "xxxx" does not apply to virtual functions
2465 | attr_requires_virtual_function attribute "xxxx" requires a virtual function
2466 | attr_disallows_pure_virtual_function attribute "xxxx" does not apply to pure virtual functions
2467 | attr_requires_pure_virtual_function attribute "xxxx" requires a pure virtual function
2468 | attr_disallows_register_storage attribute "xxxx" does not apply to register variables
2469 | attr_requires_register_storage attribute "xxxx" requires a register variable
2470 | attr_must_also_appear_in_first_declaration attribute "xxxx" did not appear on original declaration
2471 | invalid_attribute_location attributes are not allowed here
2472 | attr_must_appear_in_class_definition attribute "xxxx" must appear in a class definition
2473 | pure_final_virtual "final" applied to a pure virtual function
2474 | override_of_final_function cannot override "final" entity-kind "entity" (declared at line xxxx)
2475 | undefined_static_function_treated_as_extern static entity-kind "entity" treated as extern because it was referenced but not defined
2476 | cl_gnu_c89_inlining_option_only_in_C option to enable GNU-C89-style inlining can be used only when compiling C
2477 | first_decl_not_gnu_inline function was previously declared without the "gnu_inline" attribute
2478 | gnu_inline_requires_inline the "gnu_inline" attribute is ignored on non-inline functions
2479 | carries_dependency_not_on_first_decl entity-kind "entity" previously declared without the carries_dependency attribute
2480 | bad_array_member_initialization invalid initializer for array entity-kind "entity"
2481 | cl_must_specify_cpp11_mode must specify C++11 or C++14 mode when building runtime library
2482 | attr_disallows_function_type attribute "xxxx" does not apply to function types
2483 | attr_requires_function_type attribute "xxxx" requires a function type
2484 | attribute_ignored_on_nonstatic_member_function attribute "xxxx" does not apply to nonstatic member functions
2485 | attr_disallows_automatic_storage attribute "xxxx" does not apply to automatic variables
2486 | attr_requires_automatic_storage attribute "xxxx" requires an automatic variable
2487 | attr_disallows_external_linkage attribute "xxxx" does not apply to a variable or function with external linkage
2488 | attr_requires_local_variable attribute "xxxx" requires a local variable
2489 | attributes_ignored attributes ignored here
2490 | unattached_attribute attribute does not apply to any entity
2491 | bad_attribute_template_substitution bad attribute argument substitution
2492 | bad_tls_model_attr_arg the argument of the "tls_model" attribute must be "global-dynamic", "local-dynamic", "initial-exec", or "local-exec"
2493 | inconsistent_tls_model_attr_arg the declaration at line xxxx specified a different "tls_model" argument
2494 | attr_disallows_inline attribute "xxxx" does not apply to inline functions
2495 | attr_requires_inline attribute "xxxx" requires a inline function
2496 | include_kind_mismatch both file names in an include_alias pragma must use the same delimiter characters
2497 | signed_unsigned_comparison comparison between signed and unsigned operands
2498 | attribute_ignored_on_unnamed_type attribute "xxxx" ignored on unnamed type
2499 | attribute_ignored_on_nondefinition attribute "xxxx" ignored because no definition follows


Diagnostics 2500 to 2599

2500 | incompatible_thread_locality thread locality is incompatible with a previous declaration of entity-kind "entity" (declared at line xxxx)
2501 | no_implicit_capture_on_enclosing_lambda this enclosing-function local variable cannot be referenced in this lambda body because an enclosing lambda does not allow implicit captures
2502 | unbalanced_attribute_argument this attribute argument contains unmatched parentheses, brackets, or braces
2503 | invalid_builtin_fpclassify_args a call to __builtin_fpclassify requires five integral arguments followed by one floating-point argument
2504 | bad_final_builtin_fpclassify_arg the last argument in a call to __builtin_fpclassify must have a real floating-point type
2505 | invalid_alignment_reducing_attr alignment cannot be set to less than the default alignment
2506 | attribute_on_explicit_instantiation attributes are not allowed on explicit instantiations
2507 | attr_disallows_definition attribute "xxxx" does not apply to a definition
2508 | attr_requires_definition attribute "xxxx" requires a definition
2509 | friend_attribute_requires_definition standard attributes cannot appear on friend declarations that are not definitions
2510 | inconsistent_alignment specified alignment (xxxx) is different from alignment (xxxx) specified on a previous declaration
2511 | variable_align_attr_not_on_definition alignment attribute must also appear on definition at line xxxx
2512 | alias_used_in_type entity-kind "entity" may not be used in the type-id of the alias-declaration
2514 | transparent_union_cannot_have_floating_first_field "type" cannot be transparent because its first field has a floating-point type
2515 | transparent_union_cannot_have_bit_field_first "type" cannot be transparent because its first field is a bit field
2516 | missing_override_attr_in_base_check_class virtual function of a "base_check" class overrides a base class member but lacks the "override" attribute
2517 | hiding_attr_on_nonhiding_member "hiding" attribute specified on a declaration that does not hide a base class declaration
2518 | hiding_attr_on_unhidden_member "hiding" attribute specified on a declaration referred to by the using-declaration at line xxxx
2519 | hiding_attr_required attribute "hiding" is required on a declaration (in a "base_check" class) that hides entity-kind "entity" (declared at line xxxx)
2520 | undefined_decl_using_local_type entity-kind "entity" is not defined in this translation unit but depends on a local type
2521 | undefined_decl_using_no_linkage_type entity-kind "entity" is not defined in this translation unit but depends on a type with no linkage
2522 | missing_attribute_in_other_translation_unit attribute "xxxx" is missing in another translation unit
2523 | conflicting_attribute_in_other_translation_unit attribute "xxxx" conflicts with another translation unit
2524 | cl_nonstd_gnu_keywords_requires_gnu_mode the "nonstd_gnu_keywords" option is only valid in GNU C and GNU C++ modes
2525 | const_var_in_C_const_expr use of a const variable in a constant expression is nonstandard in C
2526 | cannot_init_auto_flexible_array_member an initializer cannot be specified for a flexible array member with automatic storage duration
2528 | final_base_class a "final" class type cannot be used as a base class
2529 | export_removed exported templates are no longer in the standard C++ language
2530 | template_dependent_designator a template-dependent designator is not allowed
2531 | offsetof_ref_field second operand of offsetof may not be a field with reference type
2532 | cl_long_lifetime_temps_incompat_with_newer_features long lifetime temporaries are incompatible with other requested newer language features
2533 | wide_deprecation_string wide character string literal will not be quoted in diagnostics
2534 | missing_attribute_arguments missing arguments for attribute "xxxx"
2535 | sfinae_requires_newer_abi_version options "c++11" and "c++11_sfinae" require a different compiler configuration
2536 | template_param_pack_not_at_end template parameter pack not at end of parameter list
2537 | parameter_pack_decl_not_allowed a parameter pack declaration is not allowed here
2538 | param_pack_cannot_have_default a parameter pack cannot have a default
2539 | cl_cppcli_only_in_microsoft_cplusplus C++/CLI can be enabled only in Microsoft C++ mode
2540 | reserved_enumerator_name "value__" cannot be used as the name of an enumerator constant (it is a reserved name in this context)
2541 | cppcli_enumerator_requires_explicit_value an explicit enumerator value is required in an enumeration type with boolean underlying type
2543 | pack_not_expanded parameter pack "xxxx" was referenced but not expanded
2544 | expansion_contains_no_packs pack expansion does not make use of any argument packs
2545 | pack_length_mismatch pack "xxxx" does not have the same number of elements as "xxxx"
2547 | vector_size_attribute_on_enum_type vector_size attribute is not allowed with an enumeration type
2548 | virtual_static_property a property cannot be both static and virtual
2549 | trivial_indexed_property an indexed property cannot be trivial
2550 | invalid_property_accessor_decl this declaration cannot appear in a property definition
2551 | qualified_cli_accessor a qualified function type cannot be used to declare an accessor function
2552 | ellipsis_cli_accessor an accessor function cannot have an ellipsis parameter
2553 | property_get_already_declared a "get" accessor was already declared for this property at line xxxx
2554 | property_set_already_declared a "set" accessor was already declared for this property at line xxxx
2555 | property_get_cannot_have_parameter a "get" accessor cannot have a parameter
2556 | bad_property_get_return return type of "get" accessor does not match property type
2557 | bad_property_set_return return type of "set" accessor must be void
2558 | empty_property_indices a property cannot declare an empty list of indices
2559 | void_property_index_type a property index cannot have type void
2560 | property_set_index_type_mismatch index type does not match the corresponding parameter in the "set" accessor
2561 | property_get_index_type_mismatch index type does not match the corresponding parameter in the "get" accessor
2562 | property_set_index_type_missing index type is missing in the "set" accessor
2563 | property_get_index_type_missing index type is missing in the "get" accessor
2564 | property_set_missing_value_parameter "set" accessor is missing its value parameter
2565 | extra_property_accessor_parameters accessor function has too many parameters
2566 | property_set_value_parameter_mismatch the last parameter of the "set" accessor does not match the property type
2567 | cppcli_not_enabled "xxxx" requires C++/CLI mode
2568 | win32_api_error error in Win32 API "xxxx": xxxx
2569 | using_not_at_file_scope #using may only be used at global scope
2571 | member_name_reserved_by_property member name "xxxx" is reserved by entity-kind "entity" (declared at line xxxx)
2572 | exp_lbracket expected a "["
2573 | cl_microsoft_version_insufficient_for_cppcli C++/CLI mode requires microsoft_version >= 1600
2574 | static_default_indexed_property a default-indexed property cannot be static
2575 | virtual_static_property_accessor a property accessor cannot be both static and virtual
2576 | visibility_specifier_on_nested_type a top-level visibility specifier cannot appear on a nested type declaration
2577 | visibility_specifier_requires_definition a top-level visibility specifier requires a type definition
2578 | trivial_reference_property a trivial property cannot have a reference type
2579 | trivial_const_or_volatile_property a trivial property cannot have a const or volatile type
2580 | incompatible_enum_kinds entity-kind "entity" (declared at line xxxx) was previously declared as a different kind of enumeration type
2581 | lambda_captures_managed_class_type a variable captured by a lambda cannot have a managed class type
2582 | covariant_override_in_managed_class virtual function overriding with a covariant return type is not allowed in a managed class
2583 | array_of_handle array of handles is not allowed
2584 | handle_to_array handle to array is not allowed
2585 | handle_to_function handle to function is not allowed
2586 | handle_to_void handle to void is not allowed
2587 | handle_to_address_type handle to handle, pointer, or reference is not allowed
2588 | tracking_reference_to_function tracking reference to function is not allowed
2590 | field_cannot_be_tracking_reference a field cannot be a tracking reference
2591 | invalid_ref_tracking_ref_combination a tracking reference cannot be combined with an ordinary reference in this way
2592 | static_storage_variable_with_ref_class_type a variable with static storage duration cannot have a ref class type
2593 | unnamed_cli_managed_class_type a managed class cannot be unnamed
2594 | local_cli_managed_class_type a managed class cannot be local
2595 | conflicting_cli_class_type_kinds entity-kind "entity" (declared at line xxxx) was previously declared as a different kind of class
2596 | conflicting_cli_class_template_kinds entity-kind "entity" (declared at line xxxx) was previously declared as a different kind of class template
2597 | literal_requires_managed_class literal data members can only be members of managed classes
2598 | literal_without_initializer a literal data member must be initialized
2599 | invalid_literal_type a literal data member of type "type" is not allowed


Diagnostics 2600 to 2699

2600 | literal_const_has_no_effect const has no effect on a literal data member
2601 | initonly_requires_managed_class initonly data members can only be members of managed classes
2602 | initonly_const_has_no_effect const has no effect on an initonly data member
2603 | cli_get_accessor_missing entity-kind "entity" (declared at line xxxx) has no "get" accessor
2604 | cli_set_accessor_missing entity-kind "entity" (declared at line xxxx) has no "set" accessor
2605 | static_constructor_with_params a static constructor cannot have parameters
2606 | static_constructor_member_template a static constructor cannot be a member template
2607 | compound_lvalue_as_asm_operand a compound lvalue is not allowed as an asm output operand
2608 | property_requires_managed_class properties can only be members of managed classes
2609 | qualifier_not_allowed_on_managed_member_function a type qualifier is not allowed on a member function of a managed class
2610 | pointer_to_ref_or_interface_class an ordinary pointer to a C++/CLI ref class or interface class is not allowed
2611 | reference_to_ref_or_interface_class an ordinary reference to a C++/CLI ref class or interface class is not allowed
2612 | override_name_must_be_a_base_class_member_function override specifier does not name a base class member function
2613 | override_name_nonvirtual override specifier designates a nonvirtual member entity-kind "entity" (declared at line xxxx)
2614 | multiple_overrides member function overrides entity-kind "entity" (declared at line xxxx) which is already overridden by entity-kind "entity" (declared at line xxxx)
2615 | multiple_visibility_specifiers at most one visibility specifier is allowed
2616 | invalid_delegate_type type "type" used for delegate definition is not a function type
2617 | delegate_requires_managed_class delegate member types can only be members of managed classes
2618 | tracking_reference_to_delegate a tracking reference to a delegate type is not allowed
2619 | bad_use_of_delegate_type a delegate type is not allowed here
2620 | empty_pack_expansion this pack expansion produced an empty list of expressions, and an expression is needed here
2621 | virtual_static_event an event cannot be both static and virtual
2622 | event_requires_managed_class events can only be members of managed classes
2623 | invalid_event_accessor_decl this declaration cannot appear in an event definition
2624 | invalid_event_type event type must be a handle-to-delegate type
2625 | event_add_already_declared an "add" accessor was already declared for this event at line xxxx
2626 | event_remove_already_declared a "remove" accessor was already declared for this event at line xxxx
2627 | event_raise_already_declared a "raise" accessor was already declared for this event at line xxxx
2628 | virtual_static_event_accessor an event accessor cannot be both static and virtual
2629 | bad_event_add_or_remove_return return type of "add" and "remove" accessors must be void
2630 | event_accessor_missing_value_parameter event accessor is missing its value parameter
2631 | extra_event_accessor_parameters accessor function has too many parameters
2632 | event_accessor_value_parameter_mismatch the type "type" of the parameter of the event accessor does not match the event type ("type")
2633 | event_raise_type_mismatch the type of the "raise" accessor does not match the event's delegate invocation type
2634 | missing_add_or_remove_accessor an event definition must include both "add" and "remove" accessors
2635 | static_conversion_function_must_have_one_parameter a static conversion function must accept exactly one argument
2636 | bad_parameter_type_for_static_member_operator static operator must have a parameter type T, T&, T%, or T^ with T = "type"
2637 | sizeof_operand_not_parameter_pack the operand of sizeof… must be a parameter pack name
2638 | sizeof_pack_in_non_variadic_context the sizeof… operator can be used only in a variadic template
2639 | event_name_not_allowed event name cannot appear here
2640 | handle_to_standard_class_type a handle to a non-managed class is not allowed
2641 | handle_to_unscoped_enum_type a handle to an unscoped enum type is not allowed
2642 | property_attribute_in_managed_class "property" attribute not allowed in managed class
2643 | pure_virtual_definition a pure specifier ("= 0") followed by a definition is nonstandard
2644 | managed_nullptr_not_allowed the managed nullptr type cannot be used here
2645 | addr_of_ref_class the "&" operator cannot be used to take the address of an object with a ref class type
2646 | array_of_managed_class array of managed class is not allowed
2647 | static_storage_variable_with_handle_or_tracking_ref_type a variable with static storage duration cannot have a handle or tracking reference type
2648 | lambda_captures_handle_or_tracking_ref a variable captured by a lambda cannot be a handle or tracking reference
2649 | invalid_param_array_type a C++/CLI parameter array requires a handle to a one-dimensional cli::array type
2650 | cannot_import_metadata could not import metadata from file "xxxx"
2651 | namespace_cli_cannot_be_extended the cli namespace cannot be extended
2652 | cli_array_invalid_element_type the element type of a cli::array must be a handle or value type
2653 | cli_array_invalid_number_of_dimensions invalid number of dimensions for cli::array type
2654 | invalid_type_pointed_to_for_interior_ptr_or_pin_ptr a cli::interior_ptr/cli::pin_ptr must point to a standard class, a value class, an integer, a handle, or a standard pointer
2655 | type_cannot_be_class_member "type" cannot be a class member
2656 | pin_ptr_param_not_allowed a parameter of type cli::pin_ptr is not allowed
2657 | bad_finalizer_decl invalid finalizer declaration
2658 | too_many_params_for_finalizer a finalizer may not have parameters
2659 | function_qualifier_on_finalizer a type qualifier is not allowed on a finalizer
2660 | return_type_on_finalizer a return type may not be specified on a finalizer
2661 | no_finalizer_using_declaration a using-declaration may not name a finalizer
2662 | finalizer_name_must_be_qualified a finalizer name must be qualified
2663 | finalizer_qualifier_type_mismatch qualifier of finalizer name "type" does not match type "type"
2664 | var_used_as_finalizer entity-kind "entity" cannot be used to name a finalizer (a type name is required)
2665 | invalid_finalizer_name invalid finalizer name for type "type"
2666 | ambiguous_finalizer finalizer reference is ambiguous -- both entity-kind "entity" and entity-kind "entity" could be used
2667 | finalizer_requires_reference_type a finalizer can only be a member of a ref class
2669 | finalizer_type_mismatch type used as finalizer name does not match type "type"
2670 | finalizer_does_not_exist a finalizer does not exist for this type
2671 | handle_of_non_managed the "%" operator can be used only on an object with a managed class type
2672 | ptr_handle_or_ref_to_interior_ptr a pointer, handle, or reference to a cli::interior_ptr is not allowed
2673 | ptr_handle_or_ref_to_pin_ptr a pointer, handle, or reference to a cli::pin_ptr is not allowed
2674 | ptr_or_ref_to_cli_array a pointer or reference to a C++/CLI array is not allowed
2675 | bad_use_of_cli_array_type a C++/CLI array type is not allowed here
2676 | invalid_ref_class_base a C++/CLI ref class can only derive from another ref class or from interface classes
2677 | invalid_value_class_base a C++/CLI value class can only derive from interface classes
2678 | invalid_interface_class_base a C++/CLI interface class can only derive from interface classes
2679 | ref_class_has_multiple_ref_bases a ref class can have at most one direct ref base class ("type" is already such a base)
2680 | managed_base_for_standard_class a standard class cannot derive from a managed class
2681 | virtual_base_for_managed_class a managed class cannot have a virtual base
2682 | managed_class_type_cannot_have_private_or_protected_base a managed class cannot have a "private" or "protected" base
2683 | override_requires_virtual the "override" modifier requires a virtual function declaration with an explicit "virtual" keyword
2684 | abstract_requires_virtual the "abstract" modifier requires a virtual function declaration with an explicit "virtual" keyword
2685 | sealed_requires_virtual the "sealed" modifier requires a virtual function declaration with an explicit "virtual" keyword
2686 | named_override_requires_virtual a named override specifier requires a virtual function declaration with an explicit "virtual" keyword
2687 | pin_ptr_return_type_not_allowed a cli::pin_ptr return type is not allowed
2688 | cppcli_attribute_only attribute "xxxx" applies in C++/CLI mode only
2689 | normal_ref_bound_to_gc_lvalue a simple (non-tracking) reference cannot be bound to an entity on the managed heap
2691 | cli_entity_not_loaded "xxxx" not loaded from default assemblies
2692 | list_initializer_nonstandard_in_current_mode list initialization syntax is a C++11 feature
2693 | sizeof_ref_or_interface_class operand of sizeof may not be a ref class type or interface class type
2694 | cli_array_invalid_number_of_subscripts invalid number of subscripts for this cli::array type
2695 | ptr_to_member_of_managed_class a pointer-to-member is not valid for a managed class
2696 | private_virtual_member_function_not_sealed private virtual member function of managed class is not "sealed"
2697 | modifier_not_allowed_on_destructor modifier is not allowed on a destructor
2698 | modifier_not_allowed_on_finalizer modifier is not allowed on a finalizer
2699 | virtual_has_no_effect "virtual" has no effect on a destructor of a managed class


Diagnostics 2700 to 2799

2700 | new_or_override_required "new" or "override" is required because this declaration matches entity-kind "entity" (declared at line xxxx)
2701 | new_or_virtual_required "new" or "virtual" is required because this declaration matches entity-kind "entity" (declared at line xxxx)
2702 | override_for_interface_member "new" or "override" are not valid here because the matching entity-kind "entity" (declared at line xxxx) is a member of an interface
2703 | new_requires_matching_base_member "new" modifier without a matching base ref class member
2704 | overriding_reduces_accessibility_in_managed_type entity-kind "entity" (declared at line xxxx) overridden with reduced access
2705 | bad_tracking_ref_init a reference of type "type" cannot be initialized with a value of type "type"
2706 | copy_constructor_in_value_class_type a copy constructor cannot be declared in a value class
2707 | default_constructor_in_value_class_type a default constructor cannot be declared in a value class
2708 | destructor_in_value_class_type a destructor cannot be declared in a value class
2709 | assignment_in_value_class_type an assignment operator cannot be declared in a value class
2710 | nonvalue_class_type_cannot_be_value_class_member non-value class "type" cannot be the type of a member of a value class
2711 | cppcli_requires_newer_abi_version option "cppcli" requires a different compiler configuration
2712 | managed_member_exception_spec exception specifications are not allowed on member functions of managed classes
2713 | managed_class_cannot_have_friend a managed class cannot declare a friend
2716 | local_class_in_managed_member_function a local class definition is not allowed in a member function of a managed class
2717 | local_lambda_in_managed_member_function a local lambda is not allowed in a member function of a managed class
2718 | cli_interface_member_function_definition a member function of a C++/CLI interface class type cannot have a definition
2719 | missing_get_and_set_accessors a property definition must include at least one accessor ("get" or "set")
2720 | subscript_mechanism_conflict default-indexed property conflicts with entity-kind "entity" (declared at line xxxx)
2721 | unusable_pack entity-kind "entity" cannot be used because it follows a parameter pack and cannot be deduced from the parameters of entity-kind "entity"
2722 | excess_pack_expansion this pack expansion produced more than one expression, and a single expression is needed here
2723 | cli_enum_base_has_no_system_counterpart type must correspond to System::Boolean, System::Byte, System::SByte, System::Int16, System::UInt16, System::Int32, System::UInt32, System::Int64, or System::UInt64
2724 | bad_call_of_handle call of an object of a handle type without appropriate operator() or conversion functions to pointer-to-function type
2725 | abstract_declarator_pack_is_nested an unnamed parameter pack declaration cannot be parenthesized
2726 | cl_variadic_templates_only_in_cplusplus variadic templates can be enabled only when compiling C++
2727 | conflicting_properties property definition conflicts with entity-kind "entity" (declared at line xxxx)
2730 | generic_param_cannot_have_default a generic parameter cannot have a default
2731 | bad_param_kind_for_generic a generic can only have type parameters
2732 | for_each_missing_function to be used with "for each" statements, type "type" must provide nonstatic member function "xxxx"
2733 | for_each_static_function "for each" cannot use member entity-kind "entity" because it is static
2734 | for_each_no_matching_overload in this "for each" statement, no instance of "entity" is callable with an empty argument list
2735 | for_each_invalid_return_type_for_move_next "for each" cannot use member function "MoveNext" because the return type is invalid
2736 | for_each_incompatible_type a "for each" statement cannot operate on an expression of type "type"
2737 | for_each_missing_field to be used with "for each" statements, type "type" must provide a non-indexed property "xxxx"
2739 | for_each_getenumerator_return_type_invalid in this "for each" statement, "type" is not a valid enumerator (returned by "GetEnumerator" of "type")
2740 | exp_in expected "in"
2741 | no_suitable_synthesis_assignment_operator class "type" has no suitable assignment operator (after operator synthesis)
2742 | not_a_generic_param "xxxx" is not a generic parameter
2743 | not_generic_param_of_curr_decl "xxxx" is not a generic parameter of the innermost generic parameter list
2744 | invalid_constraint invalid generic constraint
2745 | invalid_event_use invalid use of event member (only subscription, unsubscription, and invocation are allowed)
2746 | event_without_raise_invoked invoking an event with no "raise" accessor is invalid
2747 | bad_event_compound_assignment only "+=" and "-=" are valid for events
2748 | typeid_of_managed_type typeid of a managed type is not allowed
2749 | cli_typeid_of_managed_pointer typeid of a managed pointer type is not allowed
2750 | name_before_typeid_not_type name followed by "::typeid" must be a type name
2751 | reserved_dispose a member "xxxx" of this type is reserved within a managed class -- destructor intended?
2752 | reserved_finalize a member "xxxx" of this type is reserved within a managed class -- finalizer intended?
2753 | invalid_idisposable_dispose System::IDisposable::Dispose is missing or invalid
2754 | invalid_object_finalize System::Object::Finalize is missing or invalid
2755 | finalize_does_not_override_object_finalize entity-kind "entity" does not override System::Object::Finalize
2756 | bad_handle_dynamic_cast_operand the operand of a handle dynamic_cast must be a handle to a complete class type
2757 | bad_tracking_ref_dynamic_cast_operand the operand of a tracking-reference dynamic_cast must be an lvalue of a complete class type
2758 | bad_cli_dynamic_cast_type the type in a dynamic_cast to a handle or tracking reference type must refer to a complete class
2759 | cast_interior_ptr_to_ptr an interior pointer cannot be cast to a native pointer
2760 | cppcli_explicit_conversion_only_in_ref_and_value_classes explicit conversion operators can only be declared in ref and value class types
2761 | cppcli_explicit_conversion_is_virtual explicit conversion operator cannot be virtual
2762 | expr_not_arithmetic_or_unscoped_enum expression must have arithmetic or unscoped enum type
2763 | expr_not_arithmetic_or_unscoped_enum_or_pointer expression must have arithmetic, unscoped enum, or pointer type
2764 | expr_not_integral_or_unscoped_enum expression must have integral or unscoped enum type
2765 | expr_not_integral_or_unscoped_enum_or_fixed_point expression must have integral, unscoped enum, or fixed-point type
2766 | scoped_enum_operation_type_mismatch a built-in binary operator applied to a scoped enumeration requires two operands of the same type
2767 | invalid_gcnew_type gcnew cannot allocate an entity of type "type"
2768 | gcnew_used_with_placement_syntax placement syntax cannot be used with gcnew
2769 | new_used_on_unsuitable_value_type new can only be used with simple value types
2770 | new_used_on_managed_class_type new cannot be used on a managed class (gcnew should be used instead)
2771 | new_used_on_handle_or_tracking_reference_type new cannot be used on a handle type
2772 | cli_array_must_have_new_or_array_init gcnew for a C++/CLI array must have a new initializer or an array initializer
2773 | gcnew_bad_type_used_with_array_init an array initializer can only be used to initialize a C++/CLI array type
2774 | gcnew_used_with_auto_syntax gcnew does not allow auto
2775 | too_many_array_bounds too many array bounds
2776 | too_few_array_bounds too few array bounds
2777 | too_few_generic_args too few arguments for entity-kind "entity"
2778 | too_many_generic_args too many arguments for entity-kind "entity"
2780 | no_matching_arity no declaration of entity-kind "entity" accepts the number of generic arguments supplied
2781 | bad_function_for_delegate invalid delegate initializer -- must be a function
2782 | ambiguous_function_for_delegate invalid delegate initializer -- more than one function matches the delegate type
2783 | mismatched_function_for_delegate invalid delegate initializer -- function does not match the delegate type
2784 | missing_delegate_object invalid delegate initializer -- an object is needed in addition to a function
2785 | nonmanaged_function_for_delegate invalid delegate initializer -- function is not a member of a managed class
2786 | superfluous_delegate_object invalid delegate initializer -- object is not needed for the specified function
2787 | incompatible_delegate_object invalid delegate initializer -- object has type "type" but type "type" is expected
2788 | address_of_managed_member_function taking the address of a member function of a managed class is not allowed
2789 | bad_delegate_init_list invalid delegate initializer -- expected either "(<function-address>)" or "(<object-handle>, <member-address>)"
2790 | interface_not_implemented class fails to implement interface member entity-kind "entity" (declared at line xxxx)
2791 | gcnew_of_native_array gcnew cannot be used to allocate a native array
2792 | cli_interface_cannot_have_assignment a C++/CLI interface class cannot declare an assignment operator
2793 | sealed_cli_interface a C++/CLI interface class cannot be sealed
2795 | destructor_or_finalizer_with_named_override a destructor or finalizer declaration cannot include a named override specifier
2796 | override_name_is_destructor_or_finalizer an override specifier cannot designate a destructor or finalizer
2797 | named_override_requires_managed_type a named override specifier is allowed only in a managed class
2798 | named_override_type_mismatch no member designated by the named override specifier matches the type of this member
2799 | static_constructor_with_named_override a static constructor declaration cannot include a named override specifier


Diagnostics 2800 to 2899

2800 | unnamed_scoped_enum a scoped enumeration type must have a name
2801 | branch_into_finally transfer of control into a finally block is not allowed
2802 | return_from_finally return statement inside a finally block is not allowed
2803 | missing_finally try block requires at least one handler or finally clause
2804 | managed_object_not_thrown_by_handle a managed object must be thrown by handle
2805 | managed_object_not_caught_by_handle a managed object must be caught by handle
2806 | break_cannot_be_in_finally_block a break statement cannot be used in a finally block
2807 | continue_cannot_be_in_finally_block a continue statement cannot be used in a finally block
2808 | no_overloaded_subscript_with_offsetof builtin offsetof cannot be used when subscripting is overloaded
2809 | duplicate_constraint duplicate constraint
2810 | multiple_class_constraints more than one class constraint: "type" and "type"
2811 | multiple_constraint_clauses more than one constraint clause for entity-kind "entity"
2812 | initonly_static_data_member_not_initialized initonly static data members must have an initializer or be initialized in a static constructor
2813 | gnu_attr_on_template_redecl GNU attributes on a template redeclaration have no effect
2814 | gnu_attr_on_template_redecl_but_original_kept GNU attributes on a template redeclaration have no effect (the attributes of the original declaration at line xxxx apply instead)
2815 | cli_param_array_must_be_last_parameter a C++/CLI parameter array must be the last parameter
2816 | default_arg_used_in_param_array_function a function with a C++/CLI parameter array cannot have default arguments
2817 | ellipsis_after_param_array a C++/CLI parameter array cannot be followed by an ellipsis parameter
2818 | parameter_array_on_operator_function a C++/CLI parameter array is not allowed in an operator function parameter list
2819 | microsoft_inline_not_allowed_here __inline and __forceinline are not allowed here
2820 | data_member_with_interface_type a data member cannot have a C++/CLI interface class type
2821 | variable_with_interface_type a variable cannot have a C++/CLI interface class type
2822 | parameter_with_interface_type a parameter cannot have a C++/CLI interface class type
2823 | return_type_is_interface a function return type cannot be a C++/CLI interface class type
2824 | array_of_generic_param an array of generic parameter type is not allowed
2825 | ptr_handle_or_ref_to_generic_param a pointer, handle, or reference to a generic parameter type is not allowed
2826 | ref_class_initonly_field an initonly field cannot have a ref class type
2827 | ref_bound_to_initonly_field a reference cannot be bound to an initonly field
2828 | address_of_initonly_field taking the address of an initonly field is not allowed
2829 | modification_of_initonly_field an initonly field can only be modified by the instance constructor of its containing class
2830 | modification_of_static_initonly_field a static initonly field can only be modified by the static constructor of its containing class
2831 | member_function_call_on_initonly_field member function will be invoked on a copy of the initonly field
2832 | expr_not_pointer_nor_handle expression must have pointer or handle type but it has type "type"
2833 | move_ctor_or_assign_copy_of_lvalue a move constructor or move assignment operator is used to copy an lvalue here, which may destroy the source object
2834 | generic_selection_with_points_to member selection on a C++/CLI generic entity must use the "->" syntax, not "."
2835 | invalid_specific_ref_class_base a ref class type cannot derive from "type"
2836 | generic_class_must_be_managed a generic class must be managed (i.e., a ref class, a value class, or an interface class)
2837 | sealed_constraint a sealed class cannot be used as a constraint
2838 | dynamic_cast_to_value_generic the type in a dynamic_cast cannot be a generic type that might be a value type
2839 | UCN_names_invalid_code_point a universal character name must designate a valid code point
2840 | override_with_constraint_mismatch generic constraints do not match those of entity-kind "entity" (declared at line xxxx)
2841 | bad_argument_for_underlying_type __underlying_type only applies to enumeration types
2842 | too_many_cast_operands expected only one operand expression for this cast
2843 | bad_unicode_char_in_string Unicode character with hex value xxxx not representable in the system default code page
2844 | conv_of_pm_to_func_ptr nonstandard conversion of bound pointer-to-member to a function pointer
2845 | deprecated_access_specifier access specifier xxxx is deprecated -- use xxxx instead
2846 | static_accessor_in_nonstatic_property_or_event a static accessor function is not permitted in a nonstatic property or event definition
2847 | both_ref_and_value_constraints "type" has both a value class and ref class constraint
2848 | circular_constraints "type" and "type" involve circular naked type constraints
2849 | invalid_type_constraint "type" is not a valid type constraint
2850 | pch_file_incomplete precompiled header file "xxxx" not used (because it is incomplete)
2851 | invalid_generic_arg "type" is not a valid generic argument
2852 | bad_assembly_info_attribute assembly_info attribute applied to an invalid type
2853 | ref_class_not_satisfied "type" does not satisfy the ref class constraint of generic parameter "type"
2854 | value_class_not_satisfied "type" does not satisfy the value class constraint of generic parameter "type"
2855 | gcnew_and_abstract "type" does not satisfy the gcnew constraint of generic parameter "type" because it is abstract
2856 | gcnew_and_no_ctor "type" does not satisfy the gcnew constraint of generic parameter "type" because it does not have a public default constructor
2857 | gcnew_and_no_gcnew generic parameter "type" does not satisfy the gcnew constraint of generic parameter "type" because it does not have the gcnew constraint
2858 | type_not_satisfied "type" does not satisfy the "type" type constraint of generic parameter "type"
2859 | constraint_mismatch constraint on generic parameter "type" differs from previous declaration (at line xxxx)
2860 | standard_array_member_in_managed_class a member of a managed class cannot be a standard array
2861 | handle_member_in_standard_class a member of a non-managed class cannot be a handle
2862 | tracking_reference_member_in_standard_class a member of a non-managed class cannot be a tracking reference
2863 | reinterpret_cast_of_handle unsafe reinterpret_cast of handle
2864 | generic_type_in_template_arg a template argument may not reference a generic type parameter
2865 | comma_operator_in_cli_subscript an expression list is not allowed in this subscript operation (use parentheses around a top-level comma operator)
2866 | expr_not_pointer_or_array_handle expression must have pointer-to-object or handle-to-C++/CLI-array type but it has type "type"
2867 | unrecognized_ms_attr unrecognized attribute
2868 | standard_class_member_in_managed_class a member of a managed class cannot be of a non-managed class type
2869 | ref_or_interface_class_member_in_standard_class a member of a non-managed class cannot have a ref class type or interface class type
2871 | template_delegate a delegate may not be declared as a template
2872 | invalid_generic_specialization a generic cannot be explicitly specialized
2873 | generic_in_template a generic cannot be declared in a class template
2874 | template_in_generic a template cannot be declared in a generic class
2875 | static_literal_field a literal field cannot be declared "static"
2876 | nonstandard_long_float "long float" is a nonstandard extension -- use "double" instead
2877 | standard_class_nested_in_managed_class a standard class cannot be nested in a managed class
2878 | clrcall_requires_cppcli __clrcall is valid only in C++/CLI mode
2879 | vararg_clrcall __clrcall not allowed on function with ellipsis parameter
2880 | bad_use_of_function_modifier "xxxx" is not allowed here
2881 | override_with_trivial_property_or_event a trivial property or event cannot be used to override entity-kind "entity" (declared at line xxxx)
2882 | exp_id_in_for_each_decl expected an iterator variable name
2883 | missing_notequal_on_for_each_type the iterator type in this "for each" statement is "type", which is not a pointer type or an iterator-like class type
2884 | missing_incr_on_for_each_type the iterator type in this "for each" statement is "type", which is not a pointer type or an iterator-like class type
2885 | missing_indirect_on_for_each_type the iterator type in this "for each" statement is "type", which is not a pointer type or an iterator-like class type
2886 | no_packing_of_non_POD_field packing attribute on the parent type is ignored for this field of class type "type" that is not standard-layout
2887 | nonpublic_implicit_interface_match entity-kind "entity" (declared at line xxxx) not implemented because this declaration is not public and has no named override specifier
2888 | missing_gnu_inline_attr_on_redeclaration this declaration is missing the gnu_inline attribute specified in the previous declaration at line xxxx
2889 | managed_member_function_cannot_have_ellipsis_parameter a member function of a managed class cannot have an ellipsis parameter
2890 | invalid_prev_decl_iterator previously-declared entity-kind "entity" invalid as iterator of "for each" statement
2891 | generic_parameter_requires_clrcall calling convention ignored because the function type involves a generic parameter; __clrcall used instead
2892 | generic_parameter_does_not_permit_varargs a function type involving a generic parameter cannot have an ellipsis parameter
2893 | virtual_required_for_base_override "virtual" is required to override the matching entity-kind "entity" (declared at line xxxx)
2894 | virtual_required_for_interface_implementation "virtual" is required to implement the matching entity-kind "entity" (declared at line xxxx)
2895 | initonly_volatile_not_allowed an initonly data member cannot be volatile
2896 | member_name_reserved_by_cli_operator a member "xxxx" of this type is reserved within a managed class -- C++/CLI operators must be declared using the keyword "operator"
2897 | tracking_ref_to_constant a tracking reference to non-const cannot be bound to a constant
2898 | attributes_with_no_decl attributes ignored here because they do not apply to a declared entity
2899 | tracking_reference_to_system_string a tracking reference to System::String is not allowed


Diagnostics 2900 to 2999

2900 | use_of_generic_class_with_pending_constraint invalid use of a generic class "type" with pending constraints (probably caused by an invalid metadata file)
2901 | invalid_entity_for_pending_constraint a pending constraint clause is only allowed for generic class declarations (but not generic class definitions)
2902 | invalid_empty_initializer_list empty initializer list not allowed here
2903 | template_in_managed_class a template cannot be declared in a managed class
2904 | bad_generic_declaration_scope a generic declaration is not allowed here
2905 | interface_cannot_have_member_generics interface types cannot have member generics
2906 | character_not_latin_1 Unicode character not Latin-1, truncated to low-order byte
2907 | range_based_for_missing_function to be used with range-based "for" statements, type "type" must provide function "xxxx"
2908 | missing_notequal_on_range_based_for_type the iterator type in this range-based "for" statement is "type", which is not a pointer type or an iterator-like class type
2909 | missing_incr_on_range_based_for_type the iterator type in this range-based "for" statement is "type", which is not a pointer type or an iterator-like class type
2910 | missing_indirect_on_range_based_for_type the iterator type in this range-based "for" statement is "type", which is not a pointer type or an iterator-like class type
2911 | range_based_for_incomplete_array_type a range-based "for" statement cannot operate on an array of unknown size or incomplete type "type"
2912 | begin_end_type_mismatch_in_range_based_for return types for "begin" and "end" functions used in a range-based "for" statement must be the same ("begin" return type is "type", "end" return type is "type")
2913 | inaccessible_elided_dtor entity-kind "entity" (declared at line xxxx), required to destroy temporary that was eliminated, is inaccessible
2914 | range_based_for_no_matching_overload in this range-based "for" statement, no instance of "entity" matches the argument list
2915 | range_based_for_undefined_identifier this range-based "for" statement requires a suitable "xxxx" function and none was found
2916 | for_each_undefined_identifier this "for each" statement requires a suitable "xxxx" function and none was found
2917 | class_metadata_not_representable "type" has a metadata representation not representable using C++/CLI
2918 | exp_ellipsis expected "…"
2919 | implements_requires_interface "type" in __implements list is not an interface
2920 | implements_must_precede_virtual_functions an __implements list must precede virtual function declarations
2921 | missing_implements_list "type" specified "__implements …" in its list of bases, but is missing a matching __implements list
2922 | unused_dereference_of_ref_class the result of dereferencing a handle to a ref or interface class type must be used
2924 | exp_rparen_and_pragma_ignored expected a ")"; pragma ignored
2925 | using_or_access_declaration_in_managed_class a using-declaration or access declaration cannot appear in a managed class
2926 | skipped_inaccessible_function Note: entity-kind "entity" (declared at line xxxx) could have been called but was not considered because it is inaccessible
2927 | cli_abstract_member_function_definition an abstract member function of a C++/CLI managed class cannot have a definition
2928 | nonstatic_addressof_operator_in_managed_class declaring this unary "operator*" can change the meaning of dereferencing a handle (use static member operators to explicitly indicate applicable types)
2943 | interface_nonstatic_data_member an interface class cannot contain a nonstatic data member
2944 | pragma_gcc_system_header_in_primary_file #pragma GCC system_header cannot be used in the primary source file
2945 | too_large_to_inline entity-kind "entity" is too large to be inlined
2947 | cl_gen_move_operations_option_only_in_cplusplus option to control move operations can be used only when compiling C++
2948 | cl_gen_move_operations_and_rvalue_ctor_is_copy_ctor move operations cannot be generated when rvalue constructors are copy constructors
2949 | cl_move_operations_require_rvalue_references option to control move operations cannot be used when rvalue references are disabled
2950 | final_managed_class "final" cannot be used for managed classes (use "sealed" instead)
2951 | cast_to_cli_interface_class a cast to CLI interface class "type" is not allowed -- cast to handle intended?
2952 | new_of_cli_interface_class cannot create an object of a CLI interface class
2953 | enum_type_replacement this declaration hides the nonstandard declaration of entity-kind "entity" (declared at line xxxx) because the underlying types are incompatible
2954 | known_comparison_with_null pointer comparison result is constant, because operand can never be null
2955 | value_init_of_incomplete an object of the incomplete type "type" cannot be value-initialized
2956 | value_init_of_reference a reference cannot be value-initialized
2957 | exp_lparen_or_brace expected a "(" or a "{"
2958 | explicit_ctor_in_copy_list_init copy-list-initialization cannot use a constructor marked "explicit"
2959 | ptr_to_member_of_type_void pointer to member of type void is not allowed
2960 | ptr_to_member_of_reference_type pointer to member of reference type is not allowed
2961 | ptr_to_member_of_handle_type pointer to member of handle type is not allowed
2962 | braced_init_list_not_allowed a brace-enclosed list is not allowed here
2963 | arrow_star_operator_in_managed_class an operator->* member is not allowed in a managed class
2964 | bad_assembly_index assembly metadata refers to non-existent assembly
2965 | attribute_conflict attribute "xxxx" conflicts with earlier attribute "xxxx"
2966 | incompatible_enum_base_types entity-kind "entity" (declared at line xxxx) was previously declared with a different base type
2967 | invalid_scoped_enum_elaboration "enum class" and "enum struct" cannot be used here (use plain "enum" instead)
2968 | extra_braces_on_simple_init only one level of braces is allowed on an initializer for an object of type "type"
2969 | not_an_enum_type_name entity-kind "entity" (declared at line xxxx) cannot be used as an enumeration type name
2971 | auto_new_with_braced_init a braced-initializer cannot be used with "new auto"
2972 | missing_initializer_list_ctor the definition of std::initializer_list does not contain the expected constructor
2973 | variable_hides_entity declaration hides entity-kind "entity" (declared at line xxxx)
2974 | invalid_std_initializer_list_parameter_list invalid template parameter list for std::initializer_list (it should be one ordinary type parameter with no default)
2975 | braced_list_passed_to_ellipsis a brace-enclosed list cannot be passed for an ellipsis parameter
2976 | initializer_list_not_included an #include <initializer_list> is needed prior to a use of std::initializer_list, including an implicit use
2977 | inline_on_alias the "inline" keyword cannot be used on a namespace alias declaration
2978 | prev_ns_not_inline the previous declaration of entity-kind "entity" was not declared inline
2979 | prev_ns_inline entity-kind "entity" was previously declared inline
2980 | first_arg_must_be_integer_constant the first argument must be an integer constant
2981 | designator_requires_aggregate_type a designator cannot be used with a non-aggregate type "type"
2982 | indirect_anon_union_designator a designator for an anonymous union member can only appear within braces corresponding to that anonymous union
2983 | cl_func_prototype_tags_option_only_in_C function prototype tags can only be enabled when compiling C
2984 | cannot_elide_braces braces cannot be omitted for this subobject initializer
2985 | narrowing_conversion invalid narrowing conversion from "type" to "type"
2986 | constant_narrowing_conversion invalid narrowing conversion from "type" to "type": constant value does not fit in destination type
2987 | cast_to_incomplete_array_type cast to incomplete array type "type" is not allowed
2988 | constant_narrowing_conversion_to_float invalid narrowing conversion from "type" to "type": constant value cannot be represented exactly in destination type
2989 | braced_init_in_paren_init a parenthesized initializer for a non-class entity must be an expression, not a brace-enclosed list
2990 | braced_list_for_implicit_lambda_type a brace-enclosed list does not provide a return type for this lambda
2991 | invalid_explicit_exception_specification the declared exception specification is incompatible with the generated one
2992 | scoped_enum_nonstandard_in_current_mode scoped enumeration types are a C++11 feature
2993 | value_init_of_function a function type cannot be value-initialized
2994 | list_init_of_incomplete list-initialization of an object type "type" is not allowed because the type is incomplete
2995 | std_initializer_list_has_dtor std::initializer_list has a destructor, and is not supposed to -- library is misconfigured
2996 | explicit_enum_base_nonstandard_in_current_mode explicit enum base types are a C++11 feature
2997 | unconvertible_con_expr this constant expression has type "type" instead of the required "type" type
2998 | new_of_initializer_list a "new" of an std::initializer_list object is unlikely to work as expected because the underlying array will be destroyed at the end of the full expression


Diagnostics 3000 to 3099

3001 | defined_always_false "defined" is always false in a macro expansion in Microsoft mode
3002 | init_list_element_type_not_complete_object "type" cannot be the element type of an initializer list because it is not a complete object type
3003 | invalid_default_arg mismatched delimiters in default argument expression
3004 | conv_of_unbound_pm_to_func_ptr nonstandard conversion of pointer-to-member to a function pointer
3005 | dynamic_exception_specifications_deprecated dynamic exception specifications are deprecated
3006 | bad_scope_for_partial_spec entity-kind "entity" cannot be partially specialized in the current scope
3007 | previous_constexpr_decl_conflict entity-kind "entity" (declared at line xxxx) was previously declared constexpr
3008 | previous_nonconstexpr_decl_conflict entity-kind "entity" (declared at line xxxx) was previously not declared constexpr
3009 | constexpr_variable_decl_must_be_definition missing initializer for constexpr variable
3010 | invalid_constexpr "constexpr" is not valid here
3011 | invalid_constexpr_body a constexpr function must contain exactly one return statement
3012 | invalid_statement_in_constexpr_function statement may not appear in a constexpr function
3013 | invalid_statement_in_constexpr_constructor statement may not appear in a constexpr constructor
3014 | constexpr_virtual_combination a function cannot be both constexpr and virtual in this mode
3015 | nonliteral_return_type_in_constexpr_function a constexpr function cannot have a nonliteral return type "type"
3016 | nonliteral_param_type_in_constexpr_function a constexpr function cannot have a parameter of nonliteral type "type"
3017 | unsequenced_use_of_variable unsequenced uses of entity-kind "entity" in expression may produce undefined results
3018 | 3rd_arg_of_assume_aligned_must_be_integral the optional third argument of a call to __builtin_assumed_aligned must have integral type
3019 | constexpr_destructor a destructor cannot be constexpr
3020 | invalid_mmap_address address supplied for mmap must be aligned on a page boundary: xxxx
3021 | constexpr_constructor_with_function_try_block the body of a constexpr constructor cannot be a function try block
3022 | missing_initializer_on_fields_with_constexpr_ctor constexpr entity-kind "entity" provides no initializer for:
3024 | default_ctor_call_not_constant calling the default constructor for "type" does not produce a constant value
3025 | default_ctor_not_constexpr the default constructor for "type" is not constexpr
3026 | constexpr_variable_must_have_literal_type a constexpr variable must have a literal type or a reference type
3027 | constexpr_ctor_with_virtual_base a constructor for a class with virtual bases cannot be constexpr
3028 | bad_cpp11_constant_function_call function call must have a constant value in a constant expression
3029 | constexpr_main function "main" may not be declared constexpr
3031 | tag_defined_in_constexpr_body a class or enumeration type definition cannot appear in a constexpr function or constructor body
3032 | only_gnu_attributes_here only GNU-style attributes are permitted here
3033 | auto_used_two_ways nonstandard use of "auto" to both deduce the type from an initializer and to announce a trailing return type
3034 | nonstd_qualified_void_param_list declaring a void parameter list with a qualified void type is nonstandard
3035 | qualifier_ignored_on_local_declaration the qualifier on this local declaration is ignored
3036 | bad_conv_constant_expr_type this constant expression has type "type" instead of the required xxxx type
3037 | bad_argument_for_bases an instantiation of __bases or __direct_bases requires a class type
3038 | bad_prototype_argument_for_bases the argument of __bases and __direct_bases must be a type template parameter
3039 | bases_not_in_template xxxx can only be used in template contexts
3040 | constexpr_return_not_constant constexpr function return is non-constant
3041 | nonconstexpr_call_in_mem_initializer constexpr constructor calls non-constexpr entity-kind "entity"
3042 | nonconstant_field_initializer_in_mem_initializer constructor cannot be constexpr because the initializer of entity-kind "entity" is not a constant expression
3043 | nonconstant_mem_init_for_constexpr_ctor non-constant initializer for constexpr constructor
3044 | generated_default_constructor_used_in_field_initializer the generated default constructor for "type" cannot be used in an initializer for its own data member
3045 | recursive_initializer_instantiation instantiation of initializer of entity-kind "entity" depends on its own value
3046 | defaulted_default_ctor_cannot_be_constexpr defaulted default constructor cannot be constexpr because the corresponding implicitly declared default constructor would not be constexpr
3048 | bad_binary_digit invalid binary number
3049 | multiple_union_field_initializers a union can have at most one field initializer -- entity-kind "entity" (declared at line xxxx) also has an initializer
3051 | union_constexpr_constructor_initializes_no_field constexpr constructor of a union must initialize one of its fields
3052 | constexpr_constructor_initializes_no_variant_field constexpr constructor fails to initialize an anonymous union (defined at line xxxx)
3053 | constexpr_static_data_member_without_initializer a constexpr static data member declaration requires an in-class initializer
3054 | cl_max_constexpr_option_only_in_cplusplus maximum constexpr depth/count options can be used only when compiling C++
3055 | excessive_constexpr_complexity expression not folded to a constant due to excessive constexpr function call complexity
3056 | cl_unrestricted_unions_option_only_in_cplusplus unrestricted union options can be used only when compiling C++
3057 | constexpr_ctor_does_not_initialize_base constexpr constructor must initialize direct base class "type"
3058 | field_initializer_list creation of an std::initializer_list object in a field initializer is unlikely to work as expected because the underlying array will be destroyed at the end of the full expression
3059 | this_not_constant "this" cannot be used in a constant expression
3061 | constexpr_explicit_instantiation "constexpr" is not allowed on an explicit instantiation directive
3062 | generated_default_ctor_exception_spec_circularity cannot determine the exception specification of the default constructor due to a circular dependency
3063 | anon_union_at_decl_position anonymous union defined at line xxxx
3064 | unbounded_constexpr_ctor_init_recursion this constructor uses the initializer of entity-kind "entity" (declared at line xxxx), which would result in unbounded recursion
3066 | block_extern_initializer_not_allowed an initializer is not allowed on a local declaration of an extern variable
3067 | local_named_register_initializer_not_allowed an initializer is not allowed on a local declaration of a named register variable
3069 | cl_unrestricted_unions_in_microsoft_mode unrestricted unions cannot be enabled in Microsoft mode
3070 | delegation_loop constructor delegates directly or indirectly to itself
3071 | delegation_init_and_mem_init a delegating constructor cannot have other mem-initializers
3072 | ref_qualifier_not_allowed a ref-qualifier is not allowed here
3073 | same_param_types_with_and_without_ref_qualifiers overloading two member functions with the same parameter types requires that they both have ref-qualifiers or both lack ref-qualifiers
3074 | bad_raw_string_delim_char invalid character in raw string delimiter
3075 | missing_raw_string_delim_lparen parenthesis terminating raw string delimiter not found within 16 characters -- raw string indicator ignored
3076 | missing_raw_string_delimiter ending delimiter for raw string not found
3077 | pack_not_last_arg a parameter pack must be the final template argument in a partial specialization
3078 | pm_call_obj_not_lvalue a pointer-to-member function with type "type" can only be used with an lvalue object
3079 | pm_call_obj_not_rvalue a pointer-to-member function with type "type" can only be used with an rvalue object
3080 | defaulted_copy_ctor_cannot_have_const_parameter the parameter of this defaulted copy-constructor cannot be const because a base or member copy constructor parameter is non-const
3081 | defaulted_assignment_cannot_have_const_parameter the parameter of this defaulted assignment operator cannot be const because a base or member copy assignment parameter is non-const
3082 | empty_anonymous_union an anonymous union must contain at least one nonstatic data member
3083 | delegating_constructor_requires_newer_abi_version option "delegating_constructors" requires a different compiler configuration
3084 | alignment_reduction_unconditionally_ignored a reduction in alignment is ignored
3085 | bad_rvalue_ref_const_cast_operand the operand of a const_cast to an rvalue reference type cannot be a non-class prvalue
3086 | expr_not_a_glvalue expression must be an lvalue or xvalue
3087 | lossy_conversion conversion may change the value
3088 | deprecated_string_conv conversion from a string literal to "char *" is deprecated
3089 | deprecated_string_conv_gen conversion from a string literal to pointer-to-character (non-const) is deprecated
3090 | override_and_final_is_cpp11 "override" and "final" are C++11 features
3091 | rvalue_reference_in_exception_specification rvalue references are not allowed as exception specification types
3092 | attr_disallows_handler_param attribute "xxxx" does not apply to handler parameters
3093 | attr_requires_handler_param attribute "xxxx" requires a handler parameter
3094 | wrong_entity_for_alignas alignas does not apply here
3095 | std_alignof_with_expr_arg the standard "alignof" operator does not accept an expression argument (use a type instead)
3096 | bad_qualifier_for_member_enum_decl invalid qualifier for "type" (a derived class is not allowed here)
3097 | always_inline_requires_inline the "always_inline" attribute is ignored on non-inline functions
3098 | inheriting_ctor_not_from_direct_base inheriting constructors must be inherited from a direct base class


Diagnostics 3100 to 3199

3100 | exp_asm_label expected a label
3101 | missing_label_operand_number expected an operand number after "%l"
3102 | label_operand_number_out_of_range operand number for "%l" doesn't refer to a valid label argument
3103 | wide_string_invalid_in_asm a wide string is invalid in an "asm" statement
3104 | attribute_is_nonstandard attribute is nonstandard
3105 | decltype_is_not_base_class not a base class of class "type"
3106 | bad_user_defined_suffix non-identifier character in user-defined literal suffix
3107 | multichar_ud_lit a multicharacter literal cannot be part of a user-defined literal
3108 | ud_string_suffix_mismatch user-defined literal suffix does not match the earlier "xxxx"
3109 | invalid_literal_operator_id invalid literal operator name
3110 | literal_operator_not_found user-defined literal operator not found
3111 | ambig_literal_operator ambiguous literal operators and/or literal operator template:
3112 | udl_cannot_be_class_member a literal operator cannot be a member of a class
3113 | extern_c_literal_operator a literal operator cannot have extern "C" name linkage
3114 | no_parameter_for_literal_operator at least one parameter expected for a literal operator
3115 | too_many_parameters_for_literal_operator too many parameters for this literal operator
3116 | invalid_parameter_type_for_literal_operator invalid parameter type "type" for literal operator
3117 | invalid_integer_parameter_for_literal_operator invalid integer parameter type ("type") for literal operator; expected a character type or unsigned long long
3118 | invalid_float_parameter_for_literal_operator invalid floating-point parameter type ("type") for literal operator; expected long double
3119 | pointer_to_nonconst_for_literal_operator invalid first parameter type ("type") for literal operator; pointer to non-const type is not allowed
3120 | invalid_second_parameter_type_for_literal_operator invalid second parameter type ("type") for literal operator; must be size_t
3121 | invalid_pointer_parameter_for_literal_operator invalid pointer parameter type ("type") for literal operator; expected a pointer to a character type
3122 | ellipsis_parameter_for_literal_operator a literal operator cannot have an ellipsis parameter
3123 | invalid_parameter_for_literal_operator_template a literal operator template cannot have any parameters
3124 | invalid_template_parameter_for_literal_operator_template a literal operator template must have a template parameter list equivalent to "<char …>"
3125 | thread_local_not_allowed thread-local storage class is not valid here
3126 | thread_local_follows_non_thread_local thread-local declaration follows non-thread-local declaration (declared at line xxxx)
3127 | non_thread_local_follows_thread_local non-thread-local declaration follows thread-local declaration (declared at line xxxx)
3128 | default_arg_for_literal_operator a literal operator cannot have default arguments
3129 | attribute_ignored_for_thread_local attribute is ignored for thread-local variables
3130 | lit_suffix_no_underscore a user-provided literal suffix must begin with "_"
3131 | rvalue_references_is_cpp11 rvalue references are a C++11 feature
3132 | lambdas_is_cpp11 lambda expressions are a C++11 feature
3133 | std_attributes_is_cpp11 standard attribute syntax is a C++11 feature
3134 | delegating_constructor_is_cpp11 delegating constructors are a C++11 feature
3135 | inheriting_constructor_is_cpp11 inheriting constructors are a C++11 feature
3136 | field_initializers_is_cpp11 field initializers are a C++11 feature
3137 | deleted_functions_is_cpp11 deleted functions are a C++11 feature
3138 | defaulted_functions_is_cpp11 defaulted functions are a C++11 feature
3139 | storage_class_not_allowed_in_specialization a storage class is not allowed in an explicit specialization
3141 | specialization_of_unscoped_enum an unscoped enumeration must be opaque in order to be specialized
3142 | nonmember_enum_template an enumeration template declaration must refer to a previously declared member of a class template
3143 | operand_must_be_vector expected a vector operand
3144 | incompatible_shuffle_source_operands shuffle source operands have incompatible types "type" and "type"
3145 | nonintegral_shuffle_mask shuffle mask (type "type") is not a vector of integers
3146 | incompatible_shuffle_mask shuffle mask (type "type") has a length different from the source operand (type "type")
3147 | bad_size_for_static_address_init static initialization with an address value requires a destination of the same size as the address
3148 | feature_test_macro_req_id the argument to a feature-test macro must be a simple identifier
3149 | has_include_next_in_primary_source_file __has_include_next cannot be used in the primary source file
3150 | absolute_file_name_in_has_include_next absolute file name used in __has_include_next
3151 | attr_not_applied_to_function_type attribute "xxxx" must be applied to a function type
3153 | bad_c11_noreturn _Noreturn is not allowed here
3154 | operand_must_be_real_floating_value expected an operand of real floating-point type (not "type")
3155 | incompatible_builtin_complex_types __builtin_complex requires operands of compatible types (unlike "type" and "type")
3156 | default_association_appears_more_than_once a default association already appeared in this _Generic selection
3157 | variably_modified_type_not_allowed_here a type involving a variable length array is not allowed here
3158 | duplicate_type_in_c11_generic duplicate association type ("type") in _Generic selection
3159 | no_match_in_c11_generic no association matches the selector type "type"
3160 | incompatible_ifunc_resolver_type the type of entity-kind "entity" ("type") is incompatible with an ifunc resolver type
3161 | ifunc_cant_be_alias a function cannot have both ifunc and alias attributes
3162 | ifunc_cant_be_weak a function cannot have both ifunc and weak attributes
3163 | call_requires_string_literal call requires a string literal operand
3164 | duplicate_inheriting_constructor duplicate inheriting constructor declaration (previous at line xxxx)
3165 | modified_decltype_auto_type "decltype(auto)" must be a placeholder for the complete type of the variable (not for a component of that type)
3166 | decltype_auto_not_allowed_here decltype(auto) is not allowed here
3167 | decltype_auto_type_requires_initializer cannot deduce "decltype(auto)" (initializer required)
3168 | cannot_deduce_decltype_auto_type cannot deduce "decltype(auto)" type
3169 | thread_local_must_include_static_or_extern a block-scope thread-local declaration must include static or extern
3170 | deduced_return_type_conflict deduced return type "type" conflicts with previously deduced type "type"
3171 | use_of_undefined_function_with_deduced_return_type cannot deduce the return type of entity-kind "entity" (declared at line xxxx); it has not been defined
3172 | virtual_function_cannot_have_deduced_return_type a virtual function cannot have a deduced return type
3173 | keyword_dropped entity-kind "entity" will be treated as a context-sensitive keyword from this point
3174 | global_ns_has_no_actual_member the global namespace has no actual member "xxxx"
3175 | different_enum_comparison comparison between two different enum types ("type" and "type")
3176 | unrecognized_target_attribute target attribute not recognized
3177 | gnu_mv_default_missing missing "default" target function
3178 | gnu_mv_only_one_arch only one arch= target may be specified
3179 | generic_class_cannot_be_custom_attribute a generic class cannot be a custom attribute
3180 | invalid_ms_attribute_target invalid attribute target "xxxx"
3181 | ambiguous_ms_attribute ambiguous attribute -- both "type" and "type" could be used
3182 | cli_attribute_inaccessible_field a named attribute argument can only reference a public nonstatic read/write field or scalar property
3183 | cli_attribute_invalid_field a named attribute argument can only reference a nonstatic field or scalar property of an attribute parameter type
3184 | cli_attribute_invalid_argument invalid attribute argument -- expression must be a constant of an attribute parameter type
3185 | cli_typeid_of_generic_param_in_attribute an attribute argument cannot use generic type parameters
3186 | invalid_use_of_standalone_custom_ms_attr "type" may only be used as a standalone attribute
3187 | field_target_on_nontrivial_property_or_event the 'field' attribute target cannot be used on a non-trivial property/event
3188 | invalid_attribute_target_for_standalone_ms_attr invalid attribute target for a standalone attribute
3189 | invalid_attribute_target_for_ms_attr invalid attribute target for this context
3190 | invalid_use_of_custom_ms_attr "type" attribute cannot be used here
3191 | cli_param_array_attribute_deprecated "type" is deprecated; use '…' to specify a parameter array
3192 | namespace_default_cannot_be_extended the default namespace cannot be extended
3193 | cppcx_box_invalid_type the boxed type must be a value class or enum
3194 | tracking_reference_to_value_class tracking reference to value class is not allowed
3195 | handle_to_value_class handle to value class is not allowed
3196 | tracking_reference_to_enum tracking reference to enum is not allowed
3197 | handle_to_enum handle to enum is not allowed
3198 | cppcx_public_native_type a public native type is not allowed
3199 | public_nested_type_in_cppcx_type a public nested type is not allowed


Diagnostics 3200 to 3299

3200 | cppcx_generic_type_not_allowed generic types are not permitted in C++/CX
3201 | cppcx_generic_method_not_allowed generic methods are not permitted in C++/CX
3202 | cppcx_generic_constraints_not_allowed generic constraints are not allowed
3203 | nonpublic_data_member_in_public_cppcx_value_type non-public data members are not allowed in public C++/CX value types
3204 | public_nondata_member_in_public_cppcx_value_type public non-data members are not allowed in public C++/CX value types
3205 | cppcx_public_value_class_constructor constructors are not allowed in public C++/CX value types
3206 | bad_cppcx_event_add_return the return type of the "add" accessor must be Windows::Foundation::EventRegistrationToken
3207 | bad_cppcx_event_remove_return the return type of the "remove" accessor must be void
3208 | bad_cppcx_event_remove_parameter the parameter type of the "remove" accessor must be Windows::Foundation::EventRegistrationToken
3209 | cppcx_handle_or_ref_to_generic_param a handle or reference to a generic parameter type is not allowed
3210 | public_data_member_in_public_non_value_type public data members are not allowed in non-value types
3211 | cl_cppcx_only_in_microsoft_cplusplus C++/CX can be enabled only in Microsoft C++ mode
3212 | cl_cppcx_and_cppcli C++/CLI and C++/CX modes cannot be combined
3213 | cppcx_not_enabled "xxxx" requires C++/CX mode
3214 | cl_microsoft_version_insufficient_for_cppcx C++/CX mode requires microsoft_version >= 1600
3215 | literal_fields_disallowed_in_cppcx_mode Literal fields are not allowed in C++/CX
3216 | normal_ref_bound_to_cppcx_lvalue a standard reference cannot be bound to a C++/CX type
3217 | cppcx_enum_base_has_no_platform_counterpart type must correspond to Platform::Boolean, default::uint8, default::int8, default::int16, default::uint16, default::int32, default::uint32, default::int64, or default::uint64
3218 | event_in_cppcx_value_type a C++/CX value type cannot have events
3219 | bad_cppcx_dynamic_cast_type a dynamic_cast to a handle type must refer to a complete class type
3220 | cppcx_array_only_one_dimension_allowed Platform::Array can only be one-dimensional
3221 | cppcx_tracking_reference_on_standard_class_type tracking reference to standard class type is not allowed
3222 | cppcx_value_type_deriving_from_interface a C++/CX value type cannot inherit from an interface
3223 | cppcx_value_type_contains_virtual_function a C++/CX value type cannot contain virtual functions
3224 | partial_class_incorrect_type_or_location "partial" can only be applied to "ref class" or "ref struct" at global scope or namespace scope
3225 | cppcx_invalid_array_property_set_value_parameter the parameter of the "set" accessor must be of type "const Platform::Array<T>^"
3226 | cppcx_public_global_type the definition of a public C++/CX type is not allowed at global scope
3227 | cppcx_public_indexed_property an indexed property with a public "get" or "set" accessor is not allowed
3228 | cppcx_public_nested_delegate a public nested delegate type is not allowed
3229 | cppcx_bad_delegate_init_list invalid delegate initializer -- expected either "(<function-address or functor-object> [, Platform::CallbackContext])" or "(<object handle>, <member-address> [, Platform::CallbackContext [, bool]])"
3230 | cppcx_invalid_delegate_object invalid delegate initializer -- object must be a handle to a managed class
3231 | cppcx_non_const_array_parameter C++/CX does not support 'in/out' arrays -- use "const Platform::Array<T>^" for 'in' and "Platform::WriteOnlyArray<T>^" or "Platform::Array<T>^*" for 'out' on public APIs
3232 | missing_target_attribute missing "target" attribute for entity-kind "entity" (declared at line xxxx)
3233 | no_matching_target_attribute no declared member function matches "target" attributes for entity-kind "entity"
3234 | invalid_base_for_ms_attributes Microsoft attributes in this location are only permitted for interface types
3235 | resolver_routine_required GNU function multiversion resolver routine required
3236 | enum_in_managed_class_missing_definition an enum type declared in a managed class must include a definition
3237 | decltype_qualified_declared_name a decltype-qualified name is nonstandard in this declaration context
3238 | final_modifier_requires_virtual_function nonvirtual function cannot be declared with "final" modifier
3239 | target_on_special_function "target" attribute on special function is not supported
3240 | target_string_must_be_narrow must be a narrow string literal
3241 | target_unmatched_parens unmatched parentheses
3242 | gcc_pragma_nothing_to_pop no corresponding "push_options"
3243 | pragma_inside_function this pragma is not allowed inside a function
3244 | inline_new_or_delete_operator declaring a new or delete operator "inline" is nonstandard
3245 | pack_expansion_for_field_mem_init a mem-initializer for a data member cannot be a pack expansion
3246 | generic_lambda_cannot_capture generic lambda expressions cannot have capture defaults in this mode
3247 | friend_with_def_arg_must_be_definition a default template argument in a friend declaration may only be specified in a definition
3248 | friend_with_def_arg_must_be_only_decl a friend template declaration with a default template argument must be the only declaration (first declared at line xxxx)
3249 | non_autonomous_opaque_enum_decl an opaque enum declaration cannot be part of another declaration
3250 | nonstd_opaque_enum_decl_in_type_id an opaque enum declaration is nonstandard in this context
3251 | extended_friends_is_cpp11 extended friend syntax is a C++11 feature
3252 | digit_separators_not_enabled digit separators not enabled, apostrophe begins a character literal
3253 | bad_digit_separator_pos digit separator cannot appear here
3254 | constexpr_ignored_on_microsoft_nonstatic_member "constexpr" is ignored here in Microsoft mode
3255 | bad_gnu_stmt_return invalid expression for statement expression result
3256 | macro_not_udl_suffix identifier is a macro and not a literal suffix
3257 | cannot_call_named_member_on_lvalue entity-kind "entity" (declared at line xxxx) cannot be called on an lvalue
3258 | cannot_call_named_member_on_rvalue entity-kind "entity" (declared at line xxxx) cannot be called on an rvalue
3259 | cannot_call_member_on_lvalue member function cannot be called on an lvalue
3260 | cannot_call_member_on_rvalue member function cannot be called on an rvalue
3261 | templ_param_list_too_long the template parameter list is too long
3262 | bad_alias_templ_redecl alias template type "type" is incompatible with the previous type of "type" in the redeclaration of entity-kind "entity" (declared at line xxxx)
3263 | field_initializer_is_not_constant the field initializer for entity-kind "entity" (declared at line xxxx) is not a constant expression
3264 | constraint_number_mismatch the number of operand constraints must be the same in each constraint string
3265 | too_many_constraints the constraint string contains too many alternative constraints; not all constraints were checked
3266 | call_through_incomplete_class_type call through incomplete class "type" will always produce an error when instantiated
3267 | decltype_auto_cannot_be_qualified decltype(auto) cannot have added type qualifiers
3268 | bad_init_capture_capture init-capture "entity" (declared at line xxxx) cannot be captured here
3269 | invalid_nontype_template_argument invalid nontype template argument of type "type"
3270 | abi_tag_ignored_in_C_mode the abi_tag attribute is ignored (it has no meaning in C mode)
3271 | abi_tag_redefinition redeclaration adds abi_tag attribute "xxxx"
3272 | abi_tag_ignored abi_tag attribute is ignored (superseded by later abi_tag attribute)
3273 | no_abi_tag_on_declaration previous declaration of entity-kind "entity" (declared at line xxxx) had no abi_tag attribute
3275 | abi_tag_ignored_on_specialization abi_tag attribute is ignored on specialization
3276 | decltype_auto_return_must_be_standalone decltype(auto) cannot appear under a pointer, reference, or pointer-to-member construct
3277 | exp_class_or_typename expected "class" or "typename"
3278 | placement_new_refers_to_non_placement_delete placement "new" expression refers to non-placement entity-kind "entity" (declared at line xxxx)
3279 | cl_must_specify_cpp14_mode must specify C++14 mode when building runtime library
3283 | constexpr_not_const constexpr non-static member function will not be implicitly 'const' in C++14
3284 | nonliteral_var_in_constexpr_function variable type "type" in constexpr function is not a literal type
3285 | nonautomatic_var_in_constexpr_function variable in constexpr function does not have automatic storage duration
3286 | uninitialized_var_in_constexpr_function variable in constexpr function is uninitialized
3287 | auto_direct_list_init_requires_singleton braced initialization of a variable declared with a placeholder type but without `=` requires exactly one element inside the braces
3288 | cl_invalid_target no "xxxx" --target configuration exists
3289 | attribute_not_supported_in_x86_64 attribute is not supported in 64-bit x86 configurations
3290 | cl_missing_argument "xxxx" requires an argument
3291 | special_member_coroutine a constructor or destructor cannot be a coroutine
3292 | main_coroutine entity-kind "entity" cannot be a coroutine
3293 | yield_in_catch co_yield expressions are not permitted in a catch clause
3298 | special_class_template_not_found class template "xxxx" not found
3299 | typename_needed use the "typename" keyword to treat entity-kind "entity" as a type in a dependent context


Diagnostics 3300 to 3399

3300 | shufflevector_index_out_of_range argument value must be less than the sum of the vector elements
3301 | not_a_type_member "type" has no member "xxxx"
3302 | braced_list_for_implicit_return_type a brace-enclosed list does not provide a return type
3303 | await_not_allowed_outside_function_scope a co_await expression must appear in a function scope
3304 | await_not_allowed_in_catch_clause a co_await expression is not allowed inside a catch clause
3305 | coroutine_with_ellipsis_parameter a coroutine cannot have an ellipsis parameter
3306 | cl_relaxed_constexpr_requires_bool enabling C++14-style constexpr requires support for "bool"
3307 | constexpr_function_undefined constexpr entity-kind "entity" (declared at line xxxx) is not defined
3308 | constexpr_call_not_interpretable this call cannot be evaluated because the target function entity-kind "entity" (declared at line xxxx) is not constexpr or not completely defined yet
3311 | anon_union_alias_member_template invalid anonymous union -- alias member template is not allowed
3312 | utf8_char_lit_too_long a UTF-8 character literal value cannot occupy more than one code unit
3313 | variable_not_constant_valued the value of entity-kind "entity" (declared at line xxxx) cannot be used as a constant
3314 | variable_not_constant_addressed a pointer or reference to entity-kind "entity" (declared at line xxxx) cannot be used as a constant
3315 | constexpr_non_array_subscript nonzero subscript for non-array object
3316 | constexpr_out_of_bounds_array_access cannot access position n in array of n elements
3317 | constexpr_called_from called from:
3318 | constexpr_union_field_inactive invalid access to inactive entity-kind "entity" of union (entity-kind "entity" is active)
3319 | constexpr_goto 'goto' cannot be executed in constexpr contexts
3320 | constexpr_missing_return_value missing return value
3321 | constexpr_null_callee callee is null
3322 | constexpr_null_dereference attempt to dereference a null pointer
3323 | constexpr_access_one_past_array_end attempt to access storage one position past the end of an array of n elements
3324 | constexpr_access_to_expired_storage attempt to access expired storage
3325 | constexpr_access_to_runtime_storage attempt to access run-time storage
3327 | constexpr_call_to_nonconstexpr_function cannot call non-constexpr entity-kind "entity" (declared at line xxxx)
3328 | constexpr_vla cannot use variable-length array during constexpr evaluation
3329 | constexpr_negative_shift cannot perform a negative shift
3330 | constexpr_shift_excess shift amount (n) too large
3331 | constexpr_integer_overflow value exceeds range of "type"
3332 | constexpr_fp_error floating-point error
3333 | constexpr_null_ptr_to_member_data attempt to dereference a null pointer-to-member (data member)
3334 | comparison_of_pointers_to_void_and_function comparing a pointer to void and a pointer to a function is nonstandard
3335 | ms_metadata_init_failed metadata initialization failed
3336 | constexpr_bad_derived_class_cast invalid base-to-derived cast (complete class type is "type")
3337 | constexpr_invalid_pm_access invalid access to entity-kind "entity" in object of complete type "type"
3338 | bad_gnu_auto_type "__auto_type" not allowed here
3339 | gnu_auto_type_with_secondary_declarator "__auto_type" does not permit multiple declarators
3340 | auto_type_brace_initialization_not_allowed initialization with "{…}" is not allowed for "__auto_type"
3341 | modified_auto_type "__auto_type" must be a placeholder for the complete type of the variable (not for a component of that type)
3342 | gnu_auto_type_without_initializer a variable declared with "__auto_type" requires an initializer
3343 | constant_must_be_positive integer constant must be greater than or equal to zero
3344 | type_must_be_integral type must be an integral type
3345 | constexpr_expression_cannot_be_interpreted expression cannot be interpreted
3346 | constexpr_statement_cannot_be_interpreted statement cannot be interpreted
3347 | constexpr_interpreter_address invalid use of address of interpreter storage
3348 | constexpr_invalid_constant_kind invalid constant kind for constant-expression
3349 | constexpr_type_too_large type "type" too large for constant-expression evaluation
3350 | constexpr_type_invalid invalid type "type" for constant-expression evaluation
3351 | constexpr_invalid_type_conversion conversion from "type" to "type" is invalid in constant-expression evaluation
3352 | constexpr_fp_conversion_failed floating-point conversion failed
3354 | deduced_return_types_is_cpp14 deduced return types are a C++14 feature
3355 | constexpr_ctor_with_dtor cannot evaluate a constructor with an associated destructor
3356 | constexpr_missing_initializer_for_field entity-kind "entity" not initialized during constexpr evaluation
3357 | constexpr_invalid_pdiff invalid pointer difference in constexpr evaluation
3358 | constexpr_non_array_pointer_arithmetic invalid arithmetic on non-array pointer
3359 | constexpr_pointer_ahead_of_array cannot set pointer before the first array element
3360 | coroutine_with_deduced_return_type a coroutine with a deduced return type is invalid
3361 | await_in_unevaluated_operand expression not allowed in unevaluated context
3364 | return_in_coroutine "return" is not permitted in a coroutine (use "co_return" instead)
3365 | invalid_co_return "co_return" is only allowed in coroutines
3366 | constexpr_fp_values_not_comparable floating-point values cannot be compared
3367 | constexpr_pointers_not_comparable pointer values cannot be compared because they do not point into the same complete object or they point to subobjects with different accessibility
3368 | ignoring_attribute_on_non_inline_namespace ignoring abi_tag attribute on non-inline namespace
3369 | ignoring_attribute_on_anonymous_namespace ignoring abi_tag attribute on anonymous namespace
3370 | complex_template_parameter complex or imaginary template parameter type is nonstandard
3371 | yield_outside_of_function co_yield expression is not permitted outside a function scope
3372 | thread_local_ignored ignoring thread-local indication on anonymous union
3375 | object_not_initialized access to uninitialized object
3376 | constexpr_volatile_fetch attempt to read from volatile storage
3377 | constexpr_no_active_union_field invalid access to inactive entity-kind "entity" of union (no field is active)
3378 | label_in_constexpr_function label definitions cannot appear in constexpr functions
3379 | constexpr_equality_past_the_end_address cannot compare a pointer past the end of an array with a pointer to another complete object
3380 | variable_templ_function_type function type "type" is an invalid type for a variable template instantiation
3381 | incomplete_var_type variable cannot have incomplete type "type"
3382 | field_subobject_not_initialized access to uninitialized subobject (entity-kind "entity")
3383 | base_subobject_not_initialized access to uninitialized subobject (base class "type")
3384 | constexpr_vacuous_dtor_call a pseudo-destructor call is not permitted in a constant-expression
3385 | constexpr_modifying_const_storage attempt to modify const storage
3388 | constexpr_access_past_object attempt to access storage one position past an object treated as an array of one element
3389 | constexpr_reinterpret_cast cannot use reinterpret_cast in constant-expression evaluation
3390 | constexpr_invalid_null_ptr_operation operation not allowed on null pointer
3391 | star_this_not_constant_valued the value of *this cannot be used as a constant
3392 | inline_on_nested_namespace the "inline" keyword cannot be used on a nested namespace declaration
3393 | carries_dependency_ignored the "carries_dependency" attribute is ignored
3394 | event_interface_cannot_have_definition an "__event __interface" cannot have a definition here
3395 | invalid_event_handler_type an event handler must have a void or integral return type
3396 | event_interface_must_be_previously_defined an "__event __interface" must have been previously defined
3397 | too_many_template_arguments too many template arguments for entity-kind "entity"
3398 | enumerator_already_declared enumerator already declared (see entity-kind "entity" (declared at line xxxx))
3399 | microsoft_version_doesnt_support_cpp14_mode the version of Microsoft being emulated must be at least 1903 to use "--ms_c++14"


Diagnostics 3400 to 3499

3400 | microsoft_version_doesnt_support_cpplatest_mode the version of Microsoft being emulated must be at least 1903 to use "--ms_c++latest"
3401 | c11_atomic_array_or_function_type type "type" cannot be _Atomic because it is an array or function type
3402 | c11_atomic_specifier_with_qualified_type the _Atomic(…) specifier cannot be applied to qualified type "type"
3403 | access_to_member_of_c11_atomic_object access to member of _Atomic object
3404 | c11_atomic_bit_field a bit field cannot have an _Atomic type
3405 | c11_atomic_class_types_disabled _Atomic class types are disabled
3406 | nonconstexpr_mem_init_ctor_for_constexpr_ctor constexpr constructor calls non-constexpr constructor for subobject initialization
3407 | terse_static_assert_not_enabled expected a comma (the one-argument version of static_assert is not enabled in this mode)
3408 | terse_static_assert static assertion failed
3409 | conflicting_nullability at most one of the qualifiers _Nullable, _Nonnull, and _Null_unspecified can modify a type
3410 | invalid_type_for_nullability nullability qualifiers are only permitted on pointer and pointer-to-member types
3411 | vector_length_too_large vector length is too large
3412 | invalid_vector_element_type vector element type must be integral, enum, or real floating-point type
3413 | builtin_needs_128_bit_integers builtin function is not available because 128-bit integers are not supported
3414 | builtin_needs_vector_types builtin function is not available because vector types are not supported
3415 | must_introduce_attribute two consecutive left square brackets always introduce an attribute list but an attribute list cannot appear here
3416 | invalid_target_attribute unrecognized "target" attribute disqualifies this routine from being used by resolver routine
3417 | vector_type_required "type" is not a vector type
3418 | vector_types_differ_in_length vector types "type" and "type" must have the same length
3419 | member_special_after_class_definition added default arguments cannot result in declaring a default or copy constructor
3420 | template_arg_cannot_point_to_subobject a nontype template argument of reference type must bind to a function or to a complete object
3421 | type_not_allowed_here "type" not allowed here
3422 | register_keyword_disallowed use of the "register" storage class specifier is not allowed
3423 | register_keyword_deprecated use of the "register" storage class specifier is deprecated
3424 | incr_of_bool_not_allowed incrementing a bool value is not allowed
3425 | redeclaration_of_range_iterator "xxxx", declared as iterator of range-based "for" statement, may not be redeclared in this scope
3426 | namespace_not_allowed an attribute namespace may not be used here (because a "using" prefix was specified)
3427 | attribute_namespace_unrecognized attribute namespace "xxxx" is unrecognized
3428 | default_member_init_for_value_class a default member initializer is not permitted in a value class
3429 | cl_implicit_noexcept_requires_noexcept_support "--implicit_noexcept" requires a mode that enables noexcept
3430 | constexpr_virtual_base cannot fold operation involving virtual base class ("type")
3431 | initializer_not_constant initialization is not constant
3432 | constexpr_incomplete_type cannot evaluate value of incomplete "type"
3433 | nodiscard_routine ignoring return value from routine declared with "nodiscard" attribute
3434 | nodiscard_return_type ignoring return value type with "nodiscard" attribute
3435 | nodiscard_doesnt_apply the "nodiscard" attribute doesn't apply to destructors or routines with void return type
3436 | fallthrough_applies_to_null_statement the "fallthrough" attribute only applies to null statements
3437 | fallthrough_not_in_switch the "fallthrough" attribute may only appear in an enclosing switch statement
3438 | fallthrough_must_precede_switch_case fallthrough statement must precede switch case label or default
3439 | constexpr_expiring_temporary reference or pointer to temporary with limited lifetime
3440 | address_of_nontrue_enable_if_function cannot take the address of a function with an "enable_if" attribute whose condition is not unconditionally true
3441 | nonconstant_enable_if_attr "enable_if" attributes with conditions that are not constant values are not currently supported
3442 | attribute_declared_here attribute was declared here
3443 | has_include_not_in_if __has_include cannot appear outside #if
3444 | coclass_base_requirements_not_met could not add CComCoClass base class
3445 | constexpr_string_not_null_terminated not a null-terminated string
3446 | non_scalar_vacuous_dtor_call non-scalar type "type" cannot be used in a pseudo-destructor call
3447 | constexpr_weak_address address of "weak" entity-kind "entity" is not constant
3448 | excessive_rescan_depth too many recursive substitutions of function template signatures
3449 | invalid_struct_binding_specifier invalid specifier for structured binding declaration
3450 | invalid_struct_binding_syntax invalid structured binding syntax
3451 | missing_initializer missing initializer
3452 | invalid_struct_binding_type type "type" has no components to bind to
3453 | too_many_struct_bindings too many identifiers
3454 | missing_bindings there are more elements than there are binding names
3455 | missing_std_tuple_element "std::tuple_element" not defined
3456 | missing_std_tuple_element_instance cannot instantiate "std::tuple_element" for <xxxx, "type">
3457 | failed_tuple_container_member_get cannot call member function "get<xxxx>()" for type "type"
3458 | tuple_get_no_matching_overload no instance of "entity" matches the argument list
3459 | struct_binding_undefined_identifier this structured binding requires a suitable "xxxx" function and none was found
3460 | struct_binding_inline a structured binding cannot be declared "inline"
3461 | struct_binding_constexpr a structured binding cannot be declared "constexpr"
3462 | struct_binding_storage_class a structured binding cannot declare an explicit storage class
3463 | invalid_tuple_size std::tuple_size<"type">::value is not a valid integral constant-expression
3464 | condition_does_not_declare_a_variable a condition declaration must declare a variable
3465 | condition_decl_must_have_initializer a condition declaration must include an initializer
3466 | parenthesized_init_not_allowed a parenthesized initializer is not permitted for a condition declaration
3467 | condition_with_multiple_declarators a condition declaration can only declare one variable
3468 | struct_binding_lambda structured binding cannot bind to closure type
3469 | struct_binding_private_member cannot bind to non-public entity-kind "entity"
3470 | struct_binding_incomplete_type cannot bind to incomplete type "type"
3471 | invalid_init_statement this declaration is not valid here
3472 | constexpr_function_with_function_try_block the body of a constexpr function cannot be a function try block
3473 | branch_into_constexpr_if transfer of control into a constexpr if block is not allowed
3474 | lambda_capture_structured_binding structured binding cannot be captured
3475 | microsoft_version_doesnt_support_cpp17_mode the version of Microsoft being emulated must be at least 1911 to use "--ms_c++17"
3476 | attempt_to_read_past_end_of_object attempt to read past the end of the object
3477 | constexpr_lambdas_not_enabled constexpr lambdas are not enabled in this mode
3478 | lambda_not_constant_expr a constant expression cannot contain a lambda expression
3479 | template_argument_index_out_of_bounds value exceeds number of template arguments
3480 | fold_expression_operator_mismatch second operator in binary fold expression does not match first
3481 | invalid_fold_expression_operator invalid fold expression operator
3482 | two_packs_in_fold_expression a binary fold expression cannot apply to two parameter packs
3483 | invalid_empty_fold_expression empty expansion not valid for this fold expression
3484 | inline_nonstatic_data_mem a nonstatic data member cannot be declared as inline
3485 | no_pack_in_fold_expression fold expression does not refer to a parameter pack
3486 | same_param_types_with_different_exception_specifications two functions with the same parameter types but different exception specifications cannot be overloaded
3487 | dynamic_exc_spec_not_permitted dynamic exception specifications are not permitted in this mode
3489 | invalid_noexcept_specifier_operand invalid operand for noexcept specifier
3490 | lambda_in_noexcept_specifier lambda expression cannot appear in noexcept specifier of a template
3491 | inaccessible_rvalue_dtor entity-kind "entity" (declared at line xxxx) is inaccessible
3492 | bad_enum_template_decl invalid specifier in enum template declaration
3493 | no_float80 80-bit floating-point types are not supported in this configuration
3494 | no_float128 128-bit floating-point types are not supported in this configuration
3495 | invalid_enumerator_value invalid enumerator value
3496 | must_be_atomic_qualified_type must be an _Atomic qualified type
3497 | element_type_incomplete type of array element must be complete
3498 | always_inline_suppressed the always_inline attribute has been suppressed for this function
3499 | negative_value a negative value is not permitted here


Diagnostics 3500 to 3599

3500 | integer_pack_element_for_type an integer pack element cannot match entity-kind "entity"
3501 | integer_pack_element_for_template an integer pack element cannot match entity-kind "entity"
3502 | unexpected_designator unexpected designator
3503 | cannot_evaluate_builtin_offsetof cannot evaluate __builtin_offsetof
3504 | deduction_guide_def deduction guide "type" cannot be defined
3505 | bad_deduction_guide_scope deduction guide must be declared in the same scope as entity-kind "entity"
3506 | invalid_specifier_for_deduction_guide invalid specifier for deduction guide declaration (only "explicit" is permitted)
3507 | constexpr_mutable_field_load mutable entity-kind "entity" of a constant cannot be accessed in a constant expression
3508 | member_function_modifier_on_static_member function modifier does not apply to static member declaration
3509 | overloadable_attribute_requires_prototype the "overloadable" attribute requires a prototyped function declaration
3510 | cannot_deduce_auto_templ_param cannot deduce "auto" template parameter type "type" from "type"
3511 | modified_class_template_placeholder class template name must be a placeholder for the complete type being initialized (not for a component of that type)
3512 | alias_declaration_is_cpp11 alias declarations are a C++11 feature
3513 | alias_template_is_cpp11 alias templates are a C++11 feature
3514 | bad_deduction_guide_return_type the return type must directly designate a specialization of the associated class template
3515 | explicit_deduction_guide_in_copy_list_init copy-list-initialization cannot use "explicit" entity-kind "entity"
3517 | invalid_udl_value Invalid value for user-defined literal operator
3518 | has_cpp_attrib_not_in_if __has_cpp_attribute cannot appear outside of #if or #elif
3519 | bad_deduction_guide_access deduction guide must be declared with the same accessibility as entity-kind "entity"
3520 | lambda_not_allowed_here a lambda is not permitted in this context
3521 | align_not_equivalent specified alignment is not equivalent to previous declaration
3522 | no_alignment_on_definition no alignment specified on definition; previous declaration had specified an alignment
3523 | builtin_needs_128_bit_floats builtin function is not available because 128-bit floating-point types are not supported
3524 | constexpr_shift_negative_value left-shifting a negative value has undefined behavior
3525 | no_array_designators_in_cpp_mode array designators are nonstandard in C++
3526 | no_chained_designators_in_cpp_mode chained designators are nonstandard in C++
3527 | no_mixed_init_in_cpp_mode mixing designated and non-designated initializers is nonstandard in C++
3528 | no_out_of_order_init_in_cpp_mode out-of-order initializers are nonstandard in C++
3529 | invalid_string_literal_operator_template a string literal operator template must have a template parameter list equivalent to "<typename T, T …>"
3530 | duplicate_designator duplicate designator is not allowed
3531 | likely_unlikely_conflict attribute conflicts with previous likely/unlikely attribute
3532 | implicit_copy_this_capture_deprecated the implicit by-copy capture of "this" is deprecated
3533 | empty_lambda_template_param_list an empty template parameter list is not allowed in a lambda expression
3534 | microsoft_version_doesnt_support_cpp20_mode the version of Microsoft being emulated must be at least 1920 to use "--ms_c++20"
3535 | bad_stdc_pragma_arg_for_mode STDC pragma argument not accepted in this mode
3536 | if_constexpr_is_cpp17 constexpr if statements are a C++17 feature
3537 | no_pack_expansion_in_designator pack expansion is not allowed in a designated initializer list
3538 | no_designator_value field designator has no value
3539 | multiple_union_field_initializers_empty a union can have at most one field initializer
3540 | bad_ordering_type no valid std::xxxx type found (<compare> must be included)
3541 | invalid_spaceship_types invalid types ("type" and "type") for built-in operator<=>
3542 | fold_expressions_nonstandard fold expressions are nonstandard in this mode
3543 | selection_initializer_nonstandard C++17-style initializer is nonstandard in this mode
3544 | star_this_capture_nonstandard capturing *this is nonstandard in this mode
3545 | using_attribute_nonstandard C++17-style "using" attribute prefix is nonstandard in this mode
3546 | nested_namespace_nonstandard C++17-style nested namespaces are nonstandard in this mode
3547 | constexpr_and_consteval_specifiers only one of "constexpr", "consteval", and "constinit" can appear on a declaration
3548 | consteval_virtual_combination a function cannot be both consteval and virtual in this mode
3549 | consteval_explicit_instantiation "consteval" is not allowed on an explicit instantiation directive
3550 | invalid_consteval "consteval" is not valid here
3551 | consteval_destructor a destructor cannot be consteval
3552 | consteval_ctor_with_virtual_base a constructor for a class with virtual bases cannot be consteval
3553 | consteval_variable "consteval" is not permitted on the declaration of a variable or static data member
3554 | previous_consteval_decl_conflict entity-kind "entity" (declared at line xxxx) was previously declared consteval
3555 | previous_nonconsteval_decl_conflict entity-kind "entity" (declared at line xxxx) was previously not declared consteval
3556 | consteval_main function "main" may not be declared consteval
3557 | consteval_call_nonconstant call to consteval entity-kind "entity" did not produce a valid constant expression
3558 | address_of_consteval_function address of consteval entity-kind "entity" in constant expression result
3559 | consteval_overrides_nonconsteval consteval member cannot override non-consteval entity-kind "entity"
3560 | nonconsteval_overrides_consteval non-consteval member cannot override consteval entity-kind "entity"
3562 | constexpr_invalid_dynamic_cast dynamic_cast to subobject of type "type" is invalid (most-derived type is "type")
3563 | VA_OPT_not_allowed the identifier __VA_OPT__ can only appear in the replacement lists of variadic macros
3564 | nested_VA_OPT __VA_OPT__ cannot appear in a __VA_OPT__ operand
3565 | unclosed_VA_OPT missing closing parenthesis for __VA_OPT__
3566 | missing_VA_OPT_paren __VA_OPT__ must be followed by "("
3567 | paste_cannot_be_first_in_VA_OPT "##" may not be first in a __VA_OPT__ operand
3568 | paste_cannot_be_last_in_VA_OPT "##" may not be last in a __VA_OPT__ operand
3569 | nested_inline_namespace_nonstandard C++20-style nested inline namespaces are nonstandard in this mode
3570 | derived_class_too_far cannot convert pointer to base class "type" to pointer to derived class "type" -- attempt to point beyond the most-derived object
3572 | invalid_variable_main "main" cannot be used as a global variable name or given C language linkage
3573 | linkage_main function "main" cannot be declared in a linkage-specification
3574 | struct_binding_in_condition structured binding is not allowed in a condition
3575 | missing_attr_namespace an attribute namespace identifier is required before "::"
3576 | multiple_attr_namespaces only one attribute namespace is allowed
3577 | bad_return "return" not allowed here
3578 | struct_binding_with_multiple_declarators a structured binding cannot be combined with other declarators
3579 | branch_out_of_constant cannot branch out of a constant-evaluation context
3580 | struct_binding_template structured binding templates are not permitted
3581 | braced_init_in_parens a parenthesized initializer must be an expression, not a brace-enclosed list
3582 | cannot_deduce_class_template_arguments cannot deduce class template arguments
3583 | consteval_new_or_delete_operator a new or delete operator cannot be declared "consteval"
3584 | address_of_consteval_function_leaked the address of a consteval function cannot be used here
3585 | alignof_function_type the alignment of a function type ("type") is nonstandard
3586 | alignof_incomplete_array the alignment of an array of unspecified bound is nonstandard in C
3587 | cannot_be_common_internal_linkage a variable cannot have both "common" and "internal_linkage" attributes
3588 | internal_linkage_not_on_prior_declaration the "internal_linkage" attribute did not appear on a prior declaration
3589 | no_class_template_guide no viable template argument deduction candidate found for entity-kind "entity"
3590 | fully_qualified_constructor_call a fully qualified constructor call is not allowed
3591 | bad_scope_for_defaulted_comparison a defaulted comparison operator must be a member or a friend of the class it applies to
3592 | bad_param_type_for_defaulted_comparison bad type "type" for parameter of defaulted comparison operator (must be "reference to const X" where X is the enclosing class type)
3593 | return_type_of_default_comparison_must_be_bool return type of defaulted comparison operator must be "bool"
3594 | nonconst_defaulted_member_comparison a defaulted member comparison operator must be "const"
3596 | no_return_value_and_return_void a coroutine's promise type "type" cannot have both "return_void" and "return_value" set
3597 | return_value_at "return_value" declared at line xxxx
3598 | return_void_at "return_void" declared at line xxxx
3599 | implicit_co_return_with_no_return_void missing co_return statement while "type" has no "return_void" at end of entity-kind "entity"


Diagnostics 3600 to 3699

3600 | no_nothrow_global_new_for_coroutine no nothrow variant of the global "operator new" found for coroutine state allocation
3601 | no_viable_delete_for_coroutine no viable "operator delete" found for coroutine state deallocation
3602 | no_constexpr_coroutine a constexpr function cannot be a coroutine
3603 | await_operand_not_a_class the operand to this xxxx expression resolves to non-class "type"
3604 | await_not_allowed_in_static_initializer a co_await expression is not allowed in a static initializer
3605 | final_suspend_cannot_throw the co_await expression calling entity-kind "entity" must be non-throwing
3606 | excessive_comparison_rewrites too many recursive comparison rewrite operations
3607 | invalid_placeholder_for_defaulted_spaceship_return a deducible return type for a default operator<=> must be "auto"
3608 | constexpr_implied_source_nonconstant implicit copy of non-constant source
3609 | struct_binding_restricted_storage_class a structured binding cannot declare an explicit storage class other than static or thread_local
3610 | defaulted_comparison_for_property defaulted comparison operators are not supported for nontrivial Microsoft property fields
3611 | invalid_std_comparison_type standard comparison type ("type") must be a class type with a single nonstatic data member of integral type
3612 | invalid_std_comparison_value no constexpr static data member "xxxx" found in "type"
3613 | constexpr_alloc_too_large number of elements (n) too large for dynamic allocation
3614 | constexpr_allocation_too_large constexpr dynamic allocation request too large
3615 | constexpr_bad_deallocation deallocation of storage that was not dynamically allocated
3616 | constexpr_bad_deallocation_size deallocation size (n) does not correspond to size allocated (n)
3617 | constexpr_allocation_pos allocation occurred here
3618 | constexpr_bad_deallocation_type deallocation type ("type") does not correspond to allocation type ("type")
3619 | constexpr_leftover_allocations some dynamic allocations (total number = n) were not deallocated
3620 | constexpr_invalid_intrinsic_signature intrinsic entity-kind "entity" declared with unexpected signature (type "type")
3621 | constexpr_begin_report >> output from std::__report_constexpr_value
3622 | constexpr_end_report >> end output from std::__report_constexpr_value
3623 | constexpr_dependent_array_size cannot use array with dependent array size in constexpr evaluation
3624 | nodiscard_routine_with_reason ignoring return value from routine declared with "nodiscard" attribute ("xxxx")
3625 | nodiscard_return_type_with_reason ignoring return value type with "nodiscard" attribute ("xxxx")
3626 | nodiscard_constructor constructor used to create discarded object has "nodiscard" attribute
3627 | nodiscard_constructor_with_reason constructor used to create discarded object has "nodiscard" attribute ("xxxx")
3628 | nodiscard_object_type type of discarded object has "nodiscard" attribute
3629 | nodiscard_object_type_with_reason type of discarded object has "nodiscard" attribute ("xxxx")
3630 | vacuous_destructor_not_called a pseudo-destructor reference can only be used for a pseudo-destructor call
3631 | constexpr_explicit_dtor_call an explicit destructor call is not permitted in a constant-expression
3632 | comma_operator_in_array_subscript_deprecated an unparenthesized comma operator in an array subscript expression is deprecated
3633 | constexpr_alloc_too_small number of dynamically-allocated elements (n) too small for initializer
3634 | volatile_inc_dec_deprecated a volatile operand to xxxx expression is deprecated
3635 | volatile_ass_deprecated use of the result of an assignment to a volatile scalar object is deprecated
3636 | volatile_op_ass_deprecated a volatile destination type for a compound assignment expression is deprecated
3637 | volatile_func_param_deprecated a volatile function parameter is deprecated
3638 | volatile_return_type_deprecated a volatile return type is deprecated
3639 | volatile_str_bind_deprecated use of a volatile qualifier on a structured binding is deprecated
3640 | ext_vector_type_invalid_size the "ext_vector_type" argument must be between 1 and 2047
3641 | ext_vector_type_not_in_typedef the "ext_vector_type" attribute may appear only in a typedef
3642 | ext_vector_type_requires_integral_floating_type the "ext_vector_type" attribute applies only to integer or floating-point types
3643 | feature_test_macro_ignored this feature-test macro is ignored (and returns 0) in the current compilation mode
3644 | constexpr_multiple_union_initializers cannot evaluate an aggregate initializer with multiple elements for a union
3645 | cmp_operator_does_not_return_bool entity-kind "entity" (declared at line xxxx) selected for operator rewrite does not return type bool
3646 | constexpr_class_specific_new a new-expression calling a class-specific allocation function cannot be constant-evaluated
3647 | constexpr_placement_new a placement new-expression cannot be constant-evaluated
3648 | constexpr_nonvirtual_subobject_delete deleting through a subobject pointer requires a virtual destructor
3650 | invalid_intaddr_address operand of __INTADDR__ must be offset from null pointer
3651 | ambiguous_c11_generic _Generic construct matches multiple types
3652 | ambiguous_c11_generic_previous_match the other match is "type"
3653 | availability_attribute_ignored the "availability" attribute used here is ignored
3654 | init_stmt_in_range_for_nonstandard C++20-style initializer statement in a range-based "for" statement is nonstandard in this mode
3655 | co_await_on_non_range_based_for co_await can only apply to a range-based for statement
3656 | cannot_deduce_type_in_range_based_for cannot deduce type of range in range-based "for" loop
3657 | inline_variables_nonstandard inline variables are a C++17 feature
3658 | destroying_delete_wrong_type destroying operator delete requires "type" as first parameter
3659 | destroying_delete_with_extra_params a destroying operator delete cannot have parameters other than std::size_t and std::align_val_t
3660 | cl_relaxed_abstract_checking_only_in_cplusplus relaxed abstract class options can be used only when compiling C++
3661 | invalid_start_of_requires_clause_expr invalid start of expression in requires clause
3662 | cast_in_requires_clause a cast expression in a requires-clause must be parenthesized
3663 | invalid_operator_in_requires_clause this operator cannot appear at the top level (without parentheses) in a requires-clause
3664 | nonbool_atomic_constraint atomic constraint must have type bool
3665 | atomic_constraint_substitution_failed atomic constraint failed substitution
3666 | atomic_constraint_evaluation_failed atomic constraint not constant
3667 | atomic_constraint_false atomic constraint evaluates to false
3668 | template_constraint_not_satisfied template constraint not satisfied
3669 | bad_scope_for_concept concept definition cannot appear in this scope
3670 | invalid_concept_redecl invalid redeclaration of entity-kind "entity" (declared at line xxxx)
3671 | concept_arg_list_substitution_failed substitution of arguments "<templ-args>" for concept-id failed
3672 | concept_failed concept is false for arguments "<templ-args>"
3673 | trailing_requires_clause_not_on_template a requires-clause is not allowed here (not a templated function)
3675 | requires_incompatible_with_previous_decl requires-clause incompatible with entity-kind "entity" (declared at line xxxx)
3676 | expected_an_attribute expected an attribute
3678 | exp_type_name expected a type name
3679 | requires_expr_ellipsis_param an ellipsis parameter is not permitted in a requires-expression
3680 | unnamed_require_expr_param unnamed parameter in requires-expression has no effect
3681 | exp_concept_name expected a concept name
3682 | is_constant_evaluated_in_constant_expression call to xxxx appearing in a constant expression always produces "true"
3683 | is_constant_evaluated_in_consteval_context call to xxxx appearing in a consteval context always produces "true"
3684 | is_constant_evaluated_in_nonconstexpr_context call to xxxx appearing in a non-constexpr function always produces "false"
3685 | type_constraint_failed type constraint failed for "type"
3686 | cl_export_template_option_incompatible_with_modules option "export" cannot be used in modes where C++ modules are enabled
3687 | glb_mod_fgmt_decl_must_come_first a global module fragment declaration must precede any other declaration
3688 | module_decl_only_after_glb_mod a module declaration can only be preceded by a global module fragment
3689 | pvt_mod_fgmt_only_after_module a private module fragment must be preceded by a module declaration
3690 | cannot_export_fgmt a xxxx module fragment cannot be exported
3691 | more_than_one_module_decl cannot declare more than one module
3692 | more_than_one_fgmt_decl cannot declare more than one xxxx module fragment
3693 | module_req_primary_name a module must be declared with a non-empty name
3694 | header_not_importable "xxxx" is not an importable header
3695 | cannot_import_module_with_no_name cannot import a module with no name
3696 | module_cannot_depend_on_itself a module cannot have an interface dependency on itself
3697 | module_already_imported module "xxxx" has already been imported
3699 | module_file_not_found could not find module file for module "xxxx"


Diagnostics 3700 to 3799

3700 | cannot_import_module could not import module file "xxxx"
3701 | mismatched_module_file_kind expected xxxx, found xxxx instead
3703 | unknown_ifc_partition unknown partition name "xxxx"
3709 | types_must_have_same_size the type of the second operand "type" must have the same size as "type"
3710 | type_must_be_trivially_copyable type must be trivially copyable
3711 | unsupported_type_for_bit_cast type "type" is currently not supported for constexpr evaluation of __builtin_bit_cast
3712 | bitfields_not_allowed class types with bitfields "type" are not currently supported for constexpr evaluation of __builtin_bit_cast
3713 | reference_type_not_allowed non-static data member of reference type "type" prevents constexpr evaluation of __builtin_bit_cast
3714 | volatile_type_not_allowed a volatile type "type" prevents constexpr evaluation of __builtin_bit_cast
3715 | invalid_bit_cast_type a union, pointer, or pointer-to-member type "type" prevents constexpr evaluation of __builtin_bit_cast
3717 | deleted_inh_def_constructor the sub-object construction of "type" for inheriting constructors cannot be performed -- the implicit default constructor is deleted
3718 | promise_type_returns_return_void entity-kind "entity" must return void
3719 | invalid_start_of_member_declaration invalid start of member declaration
3720 | exp_auto expected "auto"
3721 | operator_not_allowed_after_new this operator is not allowed at this point; parenthesize the preceding new-expression
3722 | invalid_use_of_concept invalid use of concept
3723 | rvalue_defaulted_member_comparison a defaulted member comparison operator cannot be "&&"-qualified
3724 | constexpr_comparison_calls_nonconstexpr_function default constexpr comparison function calls non-constexpr function entity-kind "entity" (declared at line xxxx)
3725 | invalid_constexpr_memcmp constexpr memory comparison is only supported for integer or array-of-integer objects
3726 | constraint_concept_template a concept template cannot have associated constraints
3727 | export_not_allowed "export" is not allowed
3728 | export_class_members exporting individual class members is not allowed
3729 | export_must_introduce_name an exported declaration must introduce a name
3730 | export_cannot_contain_export an export declaration cannot contain an export declaration (previous declaration at line xxxx)
3731 | export_cannot_contain_import an export declaration cannot contain a module import declaration
3732 | export_only_in_modules an export declaration can only appear in a module interface unit
3733 | export_internal_linkage an export declaration cannot export a name with internal linkage
3735 | builtin_needs_fp16 builtin function is not available because __fp16 floating-point types are not supported
3736 | empty_requires_expression a requires-expression must specify at least one requirement
3737 | invalid_constinit "constinit" is not valid here
3738 | constinit_variable_storage "constinit" is only valid for declarations of variables with static or thread storage duration
3739 | constinit_variable_has_dynamic_init constinit variable requires dynamic initialization
3740 | missing_constinit variable was previously declared with "constinit" at line xxxx
3741 | use_of_non_prototype_func_declarator use of non-prototype function declarator
3742 | cannot_be_const_qualified argument cannot have a const-qualified type
3743 | ptr_to_mem_of_incomplete_class a pointer-to-member of an incomplete type "type" is not allowed
3744 | pack_init_capture_not_enabled pack expansion in init-capture not enabled in this mode
3745 | pack_init_capture_is_cpp20 pack expansion in init-capture is a C++20 feature
3746 | comparison_defaulted_in_class_must_be_first_decl a comparison operator defaulted in a class definition must be the first declaration of that comparison operator (entity-kind "entity" (declared at line xxxx))
3747 | pack_init_capture_in_non_variadic_context a pack expansion in an init-capture can be used only in a variadic template
3748 | type_constraint_requires_type_concept type constraint uses entity-kind "entity" (declared at line xxxx) that is not a type concept (i.e., a concept template whose first parameter is a type parameter)
3749 | placeholder_type_failed_constraint the deduced placeholder type "type" failed the type constraint
3750 | ineligible_default_constructor default constructor for "type" is not eligible
3751 | ambiguous_destructor_constraints destructor for "type" is ambiguous because of unordered constraints
3752 | failed_destructor_constraints destructor for "type" is ineligible because of failed constraints
3753 | destructor_position ambiguous destructor candidate
3754 | trailing_requires_on_virtual_func a virtual function cannot have a trailing requires clause
3755 | function_ineligible entity-kind "entity" (declared at line xxxx) does not satisfy its constraints
3756 | bad_decltype_qualifier result of decltype qualifier "type" is not a class or enumeration
3757 | cpp20_reversed_comparison_ambiguity comparison is ambiguous in standard C++20 because the implied comparison operator with reversed parameters is an equally good match -- this is usually caused by a missing "const" qualifier on the comparison operator; see "entity" (declared at line xxxx)
3758 | invalid_concept_id invalid concept-id
3759 | requires_clause_arg_list_substitution_failed substitution of arguments "<templ-args>" for requires-clause failed
3760 | ineligible_member_function constraints for entity-kind "entity" (declared at line xxxx) are not satisfied
3761 | var_with_virtual_bases_in_constexpr_function variable type "type" in constexpr function has virtual base classes
3762 | constexpr_object_with_virtual_base a constant expression cannot allocate a virtual base subobject (for type "type")
3763 | template_parameter_has_nonstructural_class_type a template parameter of class type must be of structural class type
3764 | utf8_lit_no_ulit support for UTF-8 literals requires u-literal support.
3765 | duplicate_module_map module file mapping for "xxxx" specified more than once
3766 | duplicate_header_unit_map header unit mapping for "xxxx" specified more than once
3767 | missing_header_unit_map no mapping specified for "xxxx"
3768 | invalid_module_file_map module file mapping for "xxxx" is invalid
3769 | cannot_find_header_for_import cannot find header "xxxx" to import
3770 | multiple_module_matches more than one file in the module file list matches "xxxx"
3771 | module_file_mismatch module file found for "xxxx" is for a different module
3773 | module_read_error unable to read module file
3774 | builtin_needs_char8_t builtin function is not available because the char8_t type is not supported with the current options
3776 | nonstandard_use_of_explicit_default_constructor nonstandard use of explicit constructor "entity" (declared at line xxxx) for default aggregate element initialization
3777 | constexpr_memcpy_operand_not_object source or destination of memcpy-like intrinsic does not point to an object
3778 | constexpr_memcpy_distinct_types memcpy-like intrinsic attempts to copy representationally-distinct types "type" and "type"
3779 | constexpr_memcpy_nontrivial_type memcpy-like intrinsic attempts to copy nontrivially-copyable type "type"
3780 | constexpr_memcpy_partial_object memcpy-like intrinsic attempts to copy partial object
3781 | constexpr_memcpy_overflow memcpy-like intrinsic attempts to copy past array boundary
3782 | constexpr_memcpy_overlap memcpy-like intrinsic attempts to copy overlapping byte ranges (using corresponding memmove operation instead)
3783 | nondefining_friend_requires_clause a friend declaration with a trailing-requires-clause must be a definition
3784 | type_not_scalar expression must have arithmetic or pointer type but has type "type"
3785 | type_not_arithmetic_or_enum_or_pointer expression must have arithmetic, enum, or pointer type but has type "type"
3786 | type_not_arithmetic_or_unscoped_enum_or_pointer expression must have arithmetic, unscoped enum, or pointer type but has type "type"
3787 | type_not_pointer expression must have pointer type but it has type "type"
3788 | member_access_requires_pointer operator -> or ->* applied to "type" instead of to a pointer type
3789 | incomplete_type_expr_not_allowed incomplete class type "type" is not allowed
3790 | cannot_interpret_target_bits cannot interpret bit layout for this compilation target
3791 | ifc_no_corresponding_operator no corresponding operator for IFC operator "xxxx"
3792 | ifc_no_corresponding_calling_conv no corresponding calling convention for IFC calling convention "xxxx"
3793 | module_file_contains_unsupported_constructs module "xxxx" contains unsupported constructs
3794 | unhandled_ifc_construct unsupported IFC construct: "xxxx"
3795 | is_signed_no_longer_a_keyword __is_signed is no longer a keyword from this point
3796 | dim_not_const_unsigned_int an array dimension must have a constant unsigned integer value
3797 | unsupported_ifc_file_version IFC file "xxxx" has unsupported version n.n
3798 | modules_not_enabled modules are not enabled in this mode
3799 | import_name_not_allowed "import" is not allowed in a module name


Diagnostics 3800 to 3899

3800 | module_name_not_allowed "module" is not allowed in a module name
3803 | not_an_enum_type entity-kind "entity" is not an enumeration type
3804 | using_enum_conflicts enumerator "entity" conflicts with entity-kind "entity"
3805 | using_enum_redecl enumerator "entity" has already been declared in this scope at line xxxx
3806 | empty_throw_specification_not_cpp20 the "throw()" specification is not part of C++20 and later
3807 | multiple_header_map_matches more than entry in the header unit map matches "xxxx"
3808 | exp_push_pop #pragma diagnostic must have either 'push' or 'pop' argument
3809 | no_corresponding_push no '#pragma diagnostic push' was found to match this 'diagnostic pop'
3810 | macro_in_pp_directive "xxxx" cannot be a macro when used in an import or module directive
3811 | not_global_namespace this directive can only appear in the global namespace scope
3812 | export_not_at_namespace_scope an "export" declaration can appear only at global or namespace scope
3813 | identifier_not_keyword "xxxx" is parsed as an identifier rather than a keyword because the tokens that follow it do not match those of a preprocessor directive
3814 | apparent_module_pp_directive this appears to be the start of a preprocessor directive, but the lack of a ';' followed immediately by a newline prevents that
3815 | module_directive_in_macro this appears to be a modules preprocessing directive, but such directives cannot appear within a macro expansion
3816 | module_directive_in_if a "module" directive cannot appear within the scope of conditional inclusion (e.g., #if, #else, #elseif, etc.)
3817 | import_skipped the import of "xxxx" has been skipped
3818 | bad_gro_on_alloc_fail promise type "type" must declare get_return_object_on_allocation_failure as a static member function requiring no arguments
3819 | expl_spec_alias_template an alias template cannot be explicitly specialized
3820 | matching_lbrace to match this "{"
3821 | macro_invocation in this macro invocation
3822 | call_with_unusable_argument_conversion call requires an ambiguous argument conversion
3823 | named_module_source_conflict declaration owned by module xxxx conflicts with entity-kind "entity" (declared at line xxxx)
3824 | global_module_source_conflict declaration owned by global module conflicts with entity-kind "entity" (declared at line xxxx) owned by a named module
3825 | bad_malloc_attribute the first argument to a "malloc" attribute must be a function
3826 | cannot_capture_var cannot capture "entity" (declared at line xxxx)
3827 | cannot_capture_this cannot capture "this"
3828 | already_in_consteval_context already in consteval context
3829 | if_consteval_requires_braced_dependent_statement "if consteval" and "if not consteval" require braced dependent statements
3830 | if_consteval_in_nonconstexpr_function "if consteval" and "if not consteval" are meaningless in a non-constexpr function
3831 | branch_into_if_consteval transfer of control into an "if consteval" or "if not consteval" statement is not allowed
3832 | constexpr_local_static constant-evaluation cannot go through the declaration of a variable with static or thread storage duration
3833 | mutable_qualifier_on_explicit_this_lambda the mutable qualifier is not allowed on a lambda with an explicit "this" parameter
3834 | static_with_explicit_this a member function declared with "static" cannot have an explicit "this" parameter
3835 | explicit_this_param_must_be_first an explicit "this" parameter must be the first declared parameter
3836 | bad_this "this" is not allowed here
3837 | explicit_this_defaulted_comparison a comparison function with explicit "this" cannot be defaulted
3838 | explicit_this_needs_this an explicit "this" function requires a selector operand
3839 | if_consteval_nonstandard "if consteval" and "if not consteval" are not standard in this mode
3840 | lambda_without_parameters_nonstandard omitting "()" in a lambda declarator is nonstandard in this mode
3841 | lambda_without_parameters_requires_clause a trailing-requires-clause is not permitted when the lambda parameter list is omitted
3842 | invalid_ifc_partition module "xxxx" invalid partition requested
3843 | undefined_ifc_partition module "xxxx" undefined partition (believed to be "xxxx") requested
3844 | invalid_empty_ifc_position module "xxxx" file position n (relative position n) requested for partition "xxxx" - which is empty
3845 | invalid_preceding_ifc_position module "xxxx" file position n (relative position n) requested for partition "xxxx" - which preceeds the start of the partition
3846 | invalid_overflowing_ifc_position module "xxxx" file position n (relative position n) requested for partition "xxxx" - which overflows the end of its partition
3847 | invalid_misaligned_ifc_position module "xxxx" file position n (relative position n) requested for partition "xxxx" - which is misaligned with its partitions elements
3848 | invalid_ifc_position_backtrace_field from subfield "xxxx"
3849 | invalid_ifc_position_backtrace_pos from partition "xxxx" element n (file position n, relative position n)
3850 | nonstandard_lambda_attributes lambda attributes are nonstandard here
3851 | confusable_identifier identifier "xxxx" could be confused with a visually-similar one appearing at line xxxx
3852 | suspicious_comment_formatting this comment contains suspicious Unicode formatting control characters
3853 | suspicious_string_formatting this string contains Unicode formatting control characters that could result in unexpected runtime behavior
3854 | suppressed_module_warning_diag n suppressed warning was encountered while processing module "xxxx"
3855 | suppressed_module_warnings_diag n suppressed warnings were encountered while processing module "xxxx"
3856 | suppressed_module_error_diag n suppressed error was encountered while processing module "xxxx"
3857 | suppressed_module_errors_diag n suppressed errors were encountered while processing module "xxxx"
3860 | virtual_with_explicit_this a virtual member function cannot have an explicit "this" parameter
3861 | address_of_unqualified_explicit_this_function taking the address of an explicit "this" function requires a qualified name
3862 | implicit_address_of_explicit_this_function forming the address of an explicit "this" function requires the "&" operator
3863 | string_literal_cannot_initialize_flexible_array_member a string literal cannot be used to initialize a flexible array member
3864 | ifc_bad_function_definition The IFC representation of the definition of function "xxxx" is invalid
3865 | ifc_bad_function_param_implicit_this a correction has been made to drop an implicit "this" parameter
3866 | ifc_bad_function_param_wrong_chart a UniLevel IFC chart wasn't used to specify parameters
3867 | ifc_bad_function_param_counts_multi_multi n parameters were specified by the IFC parameter definition chart while n parameters were specified by the IFC declaration
3868 | ifc_bad_function_param_counts_single_multi n parameter was specified by the IFC parameter definition chart while n parameters were specified by the IFC declaration
3869 | ifc_bad_function_param_counts_multi_single n parameters were specified by the IFC parameter definition chart while n parameter was specified by the IFC declaration
3870 | ifc_missing_function_definition The IFC representation of the definition of function "xxxx" is missing
3871 | member_function_modifier_on_template function modifier does not apply to member template declaration
3872 | constexpr_too_many_nested_anonymous_types member selection involves too many nested anonymous types
3873 | no_common_type there is no common type between the operands
3874 | exp_pointer_to_member expected a pointer-to-member
3875 | lone_flexible_array_member a flexible array member cannot be declared in an otherwise-empty type
3876 | missing_gnu_srcloc_type expected "std::source_location::__impl" to be defined to a class with only the data members "_M_function_name", "_M_file_name", "_M_column", "_M_line"
3877 | srcloc_column_bounds during the initialization of "std::source_location::__impl", column number overflows member "_M_column" of type "type"
3878 | srcloc_line_bounds during the initialization of "std::source_location::__impl", line number overflows member "_M_line" of type "type"
3879 | utf16_char_lit_too_long a UTF-16 character constant cannot occupy more than one code unit; value truncated
3880 | both_arguments_must_have_same_type both arguments must have the same type
3881 | invalid_type_for_builtin type "type" is invalid as an argument for this builtin
3882 | constexpr_called_from_rout called from entity-kind "entity" (declared at line xxxx):
3883 | qualified_unnamed_bit_field_type a qualified type is nonstandard for anonymous bit fields
3884 | bad_vector_conditional_size the element type of the vector condition ("type") must have the same size as the element type of the result ("type")
3885 | bad_vector_float_operand_size the floating-point vector operand type ("type") has no matching integer vector type
3886 | mangling_for_requires mangling for "requires" expressions is not yet implemented
3887 | unavailable_attr because of an "unavailable" attribute
3888 | duplicate_asm_qualifier duplicate 'asm' qualifier
3889 | incomplete_enum_bit_field_or_bad_opaque_enum either a bit field with an incomplete enum type or an opaque enumeration with an invalid base type
3890 | ifc_partition_mismatch attempted to construct an element from IFC partition "xxxx" using an index into IFC partition "xxxx"
3891 | ifc_partition_bad_entry_size the partition "xxxx" specified its entry size as n when n was expected
3892 | ifc_requirement_failure an unexpected IFC requirement was encountered while processing module "xxxx"
3893 | ifc_requirement_failure_fill_in condition failed at line n in xxxx: "xxxx"
3894 | circular_constraint atomic constraint depends on itself
3895 | noreturn_with_return_type "noreturn" function has non-void return type
3896 | ifc_bad_function_param_name a correction has been made by dropping the parameter "xxxx" (at relative index n)
3897 | default_arg_on_member_template_def a default template argument cannot be specified on the definition of a member template outside its class
3898 | ifc_bad_identifier invalid IFC identifier name "xxxx" encountered during entity reconstruction
3899 | ifc_bad_identifier_skipped invalid IFC identifier named "xxxx" skipped during entity reconstruction


Diagnostics 3900 to 3999

3900 | invalid_ifc_sort_value module "xxxx" invalid sort value
3901 | ifc_function_template_parse_failure a function template loaded from an IFC module was incorrectly parsed as entity-kind "entity" (declared at line xxxx)
3902 | ifc_entity_ref_failure failed to load an IFC entity reference in module "xxxx"
3903 | ifc_entity_ref_failure_info IFC index sort = n, value = n
3904 | no_chained_designators_with_destructor chained designators are not permitted for a class type with a nontrivial destructor


Diagnostics 100000 to 100099

100001 | Fatal Error Illegal type for field
100002 | Fatal Error Character constant expression expected
100003 | Fatal Error Type expected
100004 | Fatal Error More than 7 dimensions not allowed
100005 | Fatal Error Length of INTEGER must be 1, 2, or 4 (or sometimes 8)
100006 | Fatal Error Type not defined
100007 | Fatal Error Scalar value expected
100008 | Fatal Error Incompatible scalar values
100009 | Fatal Error Cannot take the address of this object
100010 | Fatal Error Allocation failed
100011 | Fatal Error Array, variable or Common block name expected
100012 | Fatal Error Array size exceeds implementation limit
100013 | Fatal Error Incorrect label on END DO statement
100014 | Fatal Error Illegal Label
100015 | Fatal Error Illegal terminal statement of DO-loop
100016 | Fatal Error Empty Statement with Label is illegal
100017 | Fatal Error A null reference is prohibited
100018 | Fatal Error ENTRY Statement illegal in main program
100019 | Fatal Error ENTRY Statement illegal
100020 | Fatal Error Implicit statement illegal
100021 | Fatal Error Must be a record
100022 | Fatal Error Illegal END DO statement
100023 | Fatal Error Parameter name already defined:
100024 | Fatal Error Illegal to take the address of this object
100025 | Fatal Error Illegal use of typedef
100026 | Fatal Error Unrecognized Statement
100027 | Fatal Error This object has no defined size
100028 | Fatal Error Multiple definition of identifier:
100029 | Fatal Error Operand must be an lvalue
100030 | Fatal Error REAL operand not allowed here
100031 | Fatal Error Pointer to void not legal here
100032 | Fatal Error Indexing not allowed, this object must be an lvalue
100033 | Fatal Error Type mismatch
100034 | Fatal Error Machine code insertions are illegal with binary code generation; use -noobj
100035 | Fatal Error Can only index arrays
100036 | Fatal Error Multiple definition of statement label
100037 | Fatal Error Illegal operation
100038 | Fatal Error Duplicate specifier
100039 | Fatal Error Pointer to procedure not legal here
100040 | Fatal Error Illegal function
100041 | Fatal Error Character function length undefined
100042 | Fatal Error Illegal type for function
100043 | Fatal Error Illegal argument to xxxx
100044 | Fatal Error Integer expression required
100045 | Fatal Error INTEGER/REAL/DOUBLE PRECISION value required
100046 | Fatal Error Empty Statement illegal in Logical IF
100047 | Fatal Error Format statement must have a label
100048 | Fatal Error Illegal statement in logical IF
100049 | Fatal Error Illegal Format Statement
100050 | Fatal Error Statement function parameter must be constant size
100051 | Fatal Error Illegal digit in hex or octal constant
100052 | Fatal Error Arithmetic constant too large for type
100053 | Fatal Error Illegal specifier
100054 | Fatal Error Character expression expected
100055 | Fatal Error Logical*4 variable expected
100056 | Fatal Error Asm statement incompatible with binary code generation. Try command line option -noobj, or builder menu File Options->Advanced->Compilation = Assembly
100057 | Fatal Error Unit identifier expected
100058 | Fatal Error INQUIRE may not specify both UNIT and FILE
100059 | Fatal Error Constant expression expected
100060 | Fatal Error End of line found in hollerith data
100061 | Fatal Error Illegal Radix-50 character
100062 | Fatal Error Cannot have REC= in list directed I/O
100063 | Fatal Error Line longer than 132000 characters
100064 | Fatal Error Format identifier expected
100065 | Fatal Error Illegal use of a private or protected field:
100066 | Fatal Error END= not allowed in WRITE or REWRITE statement
100067 | Fatal Error Illegal character
100068 | Fatal Error End of line found in string
100069 | Fatal Error Direct or unformatted I/O illegal
100070 | Fatal Error Cannot recover from previous error
100071 | Fatal Error Cannot open file:
100072 | Fatal Error Redeclaration of array with different dimension:
100073 | Fatal Error Concatenate operand must be a character expression
100074 | Fatal Error File name too long
100076 | Fatal Error Do not know how to do list I/O on this type
100077 | Fatal Error Repetition count must be greater than zero
100078 | Fatal Error Use of a non-prototype function:
100080 | Fatal Error Constant expected
100081 | Fatal Error No overloaded function matches these arguments:
100082 | Fatal Error Illegal EQUIVALENCE item
100083 | Fatal Error Illegal data-implied-do-list
100084 | Fatal Error Integer constant expression expected
100085 | Fatal Error Low bound must be less than high bound
100086 | Fatal Error Not enough constants specified
100087 | Fatal Error Too many constants specified
100088 | Fatal Error Multiple initialization
100089 | Fatal Error Cannot use this type with xxxx
100090 | Fatal Error Illegal variable or expression
100091 | Fatal Error Must have logical unit number
100092 | Fatal Error Illegal DATA item
100093 | Fatal Error REAL or COMPLEX operand not allowed here
100094 | Fatal Error Scalar reference or array reference expected
100095 | Fatal Error Expression not legal in constant
100096 | Fatal Error Only one equivalence item specified
100097 | Fatal Error Too many arguments passed to function:
100098 | Fatal Error Illegal to equivalence two common entities
100099 | Fatal Error Too few arguments passed to function:


Diagnostics 100100 to 100199

100100 | Fatal Error Label used inconsistently
100101 | Fatal Error Illegal length specification
100102 | Fatal Error I/O error on read
100103 | Fatal Error Radix-50 constant too long (limited to 12 characters)
100104 | Fatal Error Only the last dimension can be an asterisk
100105 | Fatal Error End of line found in Radix-50 constant
100106 | Fatal Error Label expected
100107 | Fatal Error Too many subscripts for
100108 | Fatal Error END Statement expected
100109 | Fatal Error Identifier cannot contain a period
100110 | Fatal Error Asm statement illegal under current options
100111 | Fatal Error Cannot index string constants
100112 | Fatal Error Invalid type coercion
100113 | Fatal Error A constant may not be assigned a new value
100114 | Fatal Error END statement missing
100115 | Fatal Error No matching if statement above
100116 | Fatal Error Substring of parameter not allowed
100117 | Fatal Error Illegal substring of
100118 | Fatal Error Illegal substring operation
100119 | Fatal Error Type error in intrinsic
100120 | Fatal Error Illegal continuation card
100121 | Fatal Error Multiple definition of FORMAT statement
100122 | Fatal Error Illegal initialization
100123 | Fatal Error Type size exceeds implementation limit
100124 | Fatal Error USEROPEN value must be EXTERNAL SUBROUTINE
100125 | Fatal Error Type error in statement function
100126 | Fatal Error Statement function type must be constant size
100127 | Fatal Error It is illegal to jump to a FORMAT statement
100128 | Fatal Error Illegal concatenation of indeterminate length
100129 | Fatal Error Integer*4 variable expected
100130 | Fatal Error Internal Compiler Error
100131 | Fatal Error Redeclaration of array with different base type:
100132 | Fatal Error Array index out of bounds
100133 | Fatal Error Integer variable expected
100134 | Fatal Error Structure-name required at outermost level
100135 | Fatal Error No constructor matches this initialization
100136 | Fatal Error xxxx expected
100137 | Fatal Error NAMELIST group-name expected
100138 | Fatal Error Illegal type of object in NAMELIST
100139 | Fatal Error I/O list not permitted for NAMELIST I/O
100140 | Fatal Error Same control variable used for inner and outer DO loop
100141 | Fatal Error A function may not return an incomplete type
100142 | Fatal Error This use of an incomplete type is illegal
100143 | Fatal Error Unmatched left parenthesis
100144 | Fatal Error Illegal to use KEY on internal file
100145 | Fatal Error Illegal to mix direct I/O and indexed I/O
100146 | Fatal Error Error on line
100147 | Fatal Error Cannot assign to this object
100148 | Fatal Error Illegal type for key
100149 | Fatal Error Could not disambiguate overloaded procedure name:
100150 | Fatal Error due to alignment rules
100151 | Fatal Error No storage mode specification line matched
100152 | Fatal Error Internal Compiler Consistency Error
100154 | Fatal Error Initial value cannot be the address of a position independent object
100155 | Fatal Error Fatal error in reading library file:
100156 | Fatal Error Duplicate field:
100157 | Fatal Error Variable expected
100158 | Fatal Error Internal Program Error
100159 | Fatal Error Too many errors during compilation


Diagnostics 100200 to 100299

100201 | Fatal Error Label not defined
100202 | Fatal Error Type conflict for:
100203 | Fatal Error Not constant size:
100204 | Fatal Error No return type specified for FUNCTION:
100205 | Fatal Error Illegal type for:
100206 | Fatal Error No such intrinsic:
100207 | Fatal Error Period missing after
100208 | Fatal Error Illegal goto into loop to label:
100209 | Fatal Error Undefined STRUCTURE name:
100210 | Fatal Error No such field in STRUCTURE:
100211 | Fatal Error Undefined name:
100212 | Fatal Error NAMELIST name not a constant size:
100213 | Fatal Error Incompatible definition of function type:
100214 | Fatal Error Entry parameter declared after use:
100215 | Fatal Error No return type specified for ENTRY:
100230 | Fatal Error Old fashioned class member declaration
100235 | Fatal Error Division by 0
100246 | Fatal Error Global register cannot be initialized
100268 | Fatal Error old-fashioned assignment operator
100278 | Fatal Error The routine main() may not be declared static or inline.
100287 | Fatal Error Unnecessary comma in declaration
100290 | Fatal Error Size for field is larger than base type:
100292 | Fatal Error All linkage specifications for a name must agree:
100293 | Fatal Error Interrupt function may not have parameters:
100294 | Fatal Error Interrupt function may not return a value:
100297 | Fatal Error Global register must be struct, union or integer type
100299 | Fatal Error Typedef redeclared as a variable of same type:


Diagnostics 100300 to 100399

100302 | Fatal Error Ambiguous type conversions
100305 | Fatal Error Coercion of a const pointer to a pointer
100306 | Fatal Error Invalid pointer coercion
100310 | Fatal Error Parameter should not initialize a reference in a constructor:
100314 | Fatal Error No variables may be declared with an abstract type:
100316 | Fatal Error Redeclaration of:
100321 | Fatal Error Illegal use of non-static member (in static context):
100322 | Fatal Error Illegal context in which to use this variable:
100325 | Fatal Error Expression involves a reference to an ambiguous base class:
100330 | Fatal Error Ambiguous member reference
100331 | Fatal Error Should not cast a member pointer to a virtual base class
100332 | Fatal Error Braced expression must be inside a routine
100338 | Fatal Error Invalid coercion: the routine is not a (non-static) class member
100339 | Fatal Error Invalid coercion: the routine is a class member
100347 | Fatal Error This copy constructor cannot initialize from a constant object:
100349 | Fatal Error main() may not be called, nor may its address be taken
100356 | Fatal Error Zero length bit fields must be unnamed:
100364 | Fatal Error Virtual may only be used inside a class
100365 | Fatal Error Coercion of a volatile pointer to a pointer
100366 | Fatal Error Illegal combination of enum and integer
100367 | Fatal Error Integral type too small to hold pointer value
100374 | Fatal Error An array of voids is illegal
100375 | Fatal Error Negative or zero array size
100376 | Fatal Error An array of functions is illegal
100380 | Fatal Error An array of references is illegal
100385 | Fatal Error Cannot create a temporary, no copy constructor for constant objects of type
100389 | Fatal Error Illegal to create a temporary for a reference to a non-constant
100390 | Fatal Error A value must be returned by a non-void function:
100391 | Fatal Error A value is returned from a void function:
100393 | Fatal Error This block does not return a value
100394 | Fatal Error A block containing a label may not return a value
100395 | Fatal Error Missing comma in initializer
100396 | Fatal Error An array initializer must be enclosed in braces
100398 | Fatal Error Case or switch statement exceeds 16-bit limit. Try -bigswitch.
100399 | Fatal Error Scopes nested too deeply. Cannot recover.


Diagnostics 100400 to 100499

100400 | Fatal Error Implicit coercion from a void pointer is not legal
100402 | Fatal Error Cannot cast an object to a function type
100405 | Fatal Error Bad argument to reserved __builtin_va_arg_incr
100407 | Fatal Error This compilation does not support floating point
100424 | Fatal Error Interrupt functions may not be inlined
100425 | Fatal Error Inconsistent version in inliner intermediate code files (.inf files). Clean your project and rebuild.
100427 | Fatal Error This limited-functionality version of the software cannot compile code this large. Contact Green Hills Software, Inc. for a full-functionality version of the software.
100428 | Fatal Error Nameless parameter in function definition
100429 | Fatal Error Undefined static function used:
100434 | Fatal Error An integer value is required for
100448 | Fatal Error Illegal to call a member function of an undefined class:
100449 | Fatal Error Illegal use of void type
100450 | Fatal Error Neither const nor volatile may be used here
100453 | Fatal Error Nothing to initialize
100459 | Fatal Error Backslash x must be followed by a hex digit
100461 | Fatal Error No digits in hex number
100462 | Fatal Error No name given for typedef
100467 | Fatal Error No statics with file scope may be referenced within a template:
100468 | Fatal Error Array size cannot exceed 32767 in this mode
100470 | Fatal Error PIC/PID illegal in Ada compiler
100489 | Fatal Error This structure has no named fields
100490 | Fatal Error Definition of a non-prototype function:
100492 | Fatal Error Forward references to enums are not allowed
100493 | Fatal Error Indexing not allowed on objects with this type:
100494 | Fatal Error Cannot generate Altivec instructions with this combination of compiler and cpu setting


Diagnostics 100500 to 100599

100506 | Fatal Error No TDA accesses allowed:
100507 | Fatal Error Attempt to access variable in wrong TDA section:
100508 | Fatal Error Bad argument to reserved __mac3(), etc.
100509 | Fatal Error Bad argument to reserved __ghs_FR20_va_arg
100514 | Fatal Error Function prototypes may not have dummy variable names in this mode
100515 | Fatal Error Unrecognized va_argnum parameter
100516 | Fatal Error Function already defined - ignoring new prototype
100531 | Fatal Error Too many -YI options
100532 | Fatal Error Too many -I- options
100533 | Fatal Error Too many -I options
100534 | Fatal Error Cannot redirect stderr to
100535 | Fatal Error Illegal option:
100538 | Fatal Error Required switch:
100539 | Fatal Error Unsupported switch:
100566 | Fatal Error A questionable cast was encountered at the file scope level which may result in incorrect output when ANSI aliasing based optimizations are applied. Please recompile with ANSI aliasing switched off.
100568 | Fatal Error Bad entry for the ISR.
100570 | Fatal Error Taking the address of a packed structure member
100573 | Fatal Error Interrupt service routine not allowed in current processor mode.
100575 | Fatal Error Asm macro must be defined:
100580 | Fatal Error Option -ga is not allowed for interrupt service routines.


Diagnostics 100600 to 100699

100600 | Fatal Error Must be a structure
100601 | Fatal Error Illegal operation:
100602 | Fatal Error Braces nested too deeply. Cannot recover.
100603 | Fatal Error Length of LOGICAL must be 1, 2, or 4 (or sometimes 8)
100604 | Fatal Error Length of REAL must be 4 or 8
100605 | Fatal Error Length of COMPLEX must be 8 or 16
100606 | Fatal Error EQUIVALENCE entity extends before common block
100608 | Fatal Error Illegal to initialize a Non-constant address
100609 | Fatal Error Multiple definition of name:
100610 | Fatal Error Common block name expected
100611 | Fatal Error Redeclaration of character variable with different dimension:
100612 | Fatal Error Redeclaration of variable as an array:
100613 | Fatal Error Letter expected
100614 | Fatal Error Error in complex constant
100615 | Fatal Error Illegal built-in function name
100616 | Fatal Error Procedure name expected
100617 | Fatal Error Alternate return specifier only in CALL statement
100619 | Fatal Error A FUNCTION may not return a STRUCTURE
100620 | Fatal Error Illegal OPTIONS statement
100621 | Fatal Error Non-digit in statement number field
100622 | Fatal Error Attempt to read off end of line
100623 | Fatal Error UNIT must be specified
100624 | Fatal Error INTEGER*4 variable expected
100625 | Fatal Error Illegal specification in REWRITE statement
100626 | Fatal Error KEYID specified but no KEY value specified
100627 | Fatal Error Illegal statement number
100628 | Fatal Error Illegal statement in DO range
100629 | Fatal Error INTEGER/REAL/DOUBLE PRECISION variable expected
100630 | Fatal Error Alternate return not allowed from function
100631 | Fatal Error Only 5 digits allowed
100632 | Fatal Error Integer or string constant expected
100633 | Fatal Error Illegal placement of PROGRAM statement
100634 | Fatal Error Illegal placement of OPTIONS statement
100635 | Fatal Error Specification Statement Illegal
100636 | Fatal Error END Statement expected at end of file
100637 | Fatal Error Illegal type
100638 | Fatal Error A structure, union, or enum must have at least one member
100639 | Fatal Error A type or a storage class must be specified in a declaration
100640 | Fatal Error Storage class illegal here
100641 | Fatal Error Nothing declared in a declaration
100642 | Fatal Error Function illegal in structure or union
100643 | Fatal Error Illegal type for bit field
100644 | Fatal Error Illegal negative size for field:
100645 | Fatal Error Void type for
100646 | Fatal Error Illegal type for member
100647 | Fatal Error Semicolon missing in struct definition
100648 | Fatal Error Field larger than int not supported in this compiler:
100649 | Fatal Error This type has no constructor:
100650 | Fatal Error Declaration not legal here
100651 | Fatal Error Only one use of
100652 | Fatal Error Illegal use of
100653 | Fatal Error Incompatible type-specifiers
100654 | Fatal Error Semicolon omitted after declaration
100657 | Fatal Error Only non-static class members may be const or volatile:
100658 | Fatal Error Argument must have a default value (since a previous arg did):
100659 | Fatal Error Array size must be constant
100660 | Fatal Error Null dimension
100661 | Fatal Error No arguments may be specified after …
100662 | Fatal Error Reference to void illegal
100663 | Fatal Error A reference to a reference is illegal.
100664 | Fatal Error Pointers to references are illegal
100665 | Fatal Error Initialized extern variable within a function
100666 | Fatal Error This variable must be initialized
100667 | Fatal Error Globalvalue initializer must be constant
100668 | Fatal Error The size of this variable is not defined
100669 | Fatal Error Initializer too large
100670 | Fatal Error Illegal initial value
100671 | Fatal Error A braced initializer must contain a value
100674 | Fatal Error A prototype parameter list must be specified here
100676 | Fatal Error Inline may be applied only to a function
100677 | Fatal Error Static function declaration only allowed at file scope:
100679 | Fatal Error No name given in declaration
100680 | Fatal Error Illegal storage class
100681 | Fatal Error This class has no destructor:
100682 | Fatal Error Undefined member:
100683 | Fatal Error Illegal member use:
100684 | Fatal Error Undefined function:
100685 | Fatal Error Implicit function declaration:
100686 | Fatal Error Undefined symbol:
100687 | Fatal Error This is not an lvalue
100688 | Fatal Error Illegal member use
100689 | Fatal Error Bit field not legal as operand of sizeof
100690 | Fatal Error Must have at least one stack argument
100691 | Fatal Error Redeclaration of prototype parameters
100692 | Fatal Error Two declarations of:
100693 | Fatal Error Void type argument illegal
100694 | Fatal Error Unknown size for parameter
100695 | Fatal Error Not a parameter name:
100696 | Fatal Error A function must be declared by specifying parens
100697 | Fatal Error No name given for declaration
100698 | Fatal Error A file (translation unit) must contain at least one declaration/definition
100699 | Fatal Error passed to function


Diagnostics 100700 to 100799

100700 | Fatal Error Label not defined:
100701 | Fatal Error Illegal octal digit
100702 | Fatal Error Illegal symbol
100703 | Fatal Error Illegal floating constant
100704 | Fatal Error Empty character constant illegal
100705 | Fatal Error Character constant too long
100706 | Fatal Error Unexpected end of file
100707 | Fatal Error End of line found in character constant
100708 | Fatal Error Asm procedure incompatible with binary code generation. Try command line option -noobj, or builder menu File Options->Advanced->Compilation = Assembly
100709 | Fatal Error #pragma asm incompatible with binary code generation. Try command line option -noobj, or builder menu File Options->Advanced->Compilation = Assembly
100711 | Fatal Error This is a binary file
100712 | Fatal Error Duplicate case
100713 | Fatal Error Controlling expression of a switch statement must be integral
100714 | Fatal Error Case not in switch statement
100715 | Fatal Error Only one "default" case per switch statement allowed
100716 | Fatal Error Case expression not constant
100717 | Fatal Error Semicolon missing at end of switch statement
100718 | Fatal Error Break statement must appear inside of a loop or switch
100719 | Fatal Error Continue statement must appear inside of a loop
100721 | Fatal Error Used before defined in scope,
100722 | Fatal Error Semicolon omitted before case in variant record
100723 | Fatal Error Tag field must be a scalar type
100724 | Fatal Error Selector must be constant
100725 | Fatal Error Subrange not legal in record tag/case
100726 | Fatal Error Not all tag cases specified in variant record
100727 | Fatal Error Undefined type:
100728 | Fatal Error Ordinal type expected
100729 | Fatal Error Type name expected
100730 | Fatal Error File of file not allowed
100731 | Fatal Error Subrange type expected
100732 | Fatal Error Set too large for representation
100733 | Fatal Error Structured type expected
100734 | Fatal Error Labels must be in the range 0..9999
100735 | Fatal Error Nil may not be in constant
100736 | Fatal Error Type not declared
100737 | Fatal Error Cannot inline a procedure or function which has a nested procedure of function
100738 | Fatal Error Cannot dereference a function call
100739 | Fatal Error Type illegal in expression
100740 | Fatal Error Illegal use of a procedure as a function
100741 | Fatal Error Built in operation may not be an actual parameter
100742 | Fatal Error This is not a variable
100743 | Fatal Error No such field in this record:
100744 | Fatal Error Operand must be a variable
100745 | Fatal Error File comparison not legal
100746 | Fatal Error Illegal type for comparison
100747 | Fatal Error Only equality and inequality allowed on pointers
100748 | Fatal Error Procedure call illegal in expression
100749 | Fatal Error Set constructor elements must be ordinal values
100750 | Fatal Error File may not be assigned to
100751 | Fatal Error Extraneous semicolon
100752 | Fatal Error A procedure may not return a value
100753 | Fatal Error Function return must be scalar/pointer
100754 | Fatal Error Inconsistent redeclaration of routine
100755 | Fatal Error Nested routines may not be inlined
100756 | Fatal Error Multiple forward declarations
100757 | Fatal Error External declaration only allowed at top level
100758 | Fatal Error No assignment to return variable in function
100759 | Fatal Error Scalar value required
100760 | Fatal Error Argument to round or trunc must be real
100761 | Fatal Error Argv requires a string variable
100762 | Fatal Error Array size undefined
100763 | Fatal Error File expected
100764 | Fatal Error Text variable expected
100765 | Fatal Error Input or output not defined
100766 | Fatal Error Unpacked variable required for actual parameter
100767 | Fatal Error This must be a procedure or function
100768 | Fatal Error Actual corresponding to a value conformant array may not be a conformant array
100769 | Fatal Error Tag field used as var parameter
100770 | Fatal Error For index may not be var parameter
100771 | Fatal Error Packed variable may not be passed by reference
100772 | Fatal Error Actual array arguments have different types when conformant formals match:
100773 | Fatal Error Too many arguments given for
100774 | Fatal Error Not enough arguments given for
100775 | Fatal Error Parameter not declared:
100776 | Fatal Error Parameter is not a variable:
100777 | Fatal Error Program ends before end of file
100778 | Fatal Error New requires a pointer variable
100779 | Fatal Error Dispose requires a pointer value
100780 | Fatal Error May not dispose of a value parameter
100781 | Fatal Error Initial value for tag must be constant
100782 | Fatal Error Pointer type undefined
100783 | Fatal Error Goto out of scope
100784 | Fatal Error Forward procedure not defined:
100785 | Fatal Error Digit required after decimal point
100786 | Fatal Error A number may not be followed by a letter
100787 | Fatal Error Null string, '''', not legal
100789 | Fatal Error Label not declared
100790 | Fatal Error Label already defined
100791 | Fatal Error This variable is a constant
100792 | Fatal Error Assignment to for loop index inside loop
100793 | Fatal Error Local variable required
100794 | Fatal Error For loop variable assigned in procedure
100795 | Fatal Error Value out of bounds
100796 | Fatal Error Ordinal type required in case statement
100797 | Fatal Error Record variable expected
100798 | Fatal Error Second parameter required
100799 | Fatal Error Text file expected


Diagnostics 100800 to 100899

100800 | Fatal Error Cannot read into this type of variable
100801 | Fatal Error Cannot write this type of expression
100802 | Fatal Error Packed array variable expected
100803 | Fatal Error Unpacked array variable expected
100804 | Fatal Error Array component types incompatible
100805 | Fatal Error Statement expected: function call illegal
100806 | Fatal Error Statement expected
100807 | Fatal Error #pragma intvect incompatible with binary code generation. Try command line option -noobj, or builder menu File Options->Advanced->Compilation = Assembly
100808 | Fatal Error Illegal TDA call to function


Diagnostics 101000 to 101099

101000 | Fatal Error No source file specified
101001 | Fatal Error Ran out of string space
101002 | Fatal Error Too many parameters for a macro
101007 | Fatal Error NAMELIST name must be a variable name or array name
101008 | Fatal Error Include nested too deeply
101009 | Fatal Error Unknown .keyword.
101011 | Fatal Error A cast is illegal in the expression of a #if/#elif
101012 | Fatal Error ( expected after # identifier
101013 | Fatal Error End of file found in arguments to macro
101014 | Fatal Error Unmatched #endif
101015 | Fatal Error End of file found in #if, #ifdef, #ifndef or #elif
101016 | Fatal Error An #if(def) directive begins in a different include file than it ends in
101017 | Fatal Error Unmatched #else or #elif
101018 | Fatal Error End of file found in comment
101019 | Fatal Error Illegal preprocessor command
101020 | Fatal Error Preprocessor expression must be constant
101022 | Fatal Error Redefinition of this builtin macro not permitted:
101023 | Fatal Error Extraneous comma in macro
101024 | Fatal Error Missing comma in argument list for macro:
101025 | Fatal Error # operator must be followed by a macro parameter
101026 | Fatal Error ## operator may not begin or terminate a macro
101027 | Fatal Error Redefinition of macro:
101038 | Fatal Error All names listed inside an unknown_control_flow pragma must be routines:
101040 | Fatal Error Preprocessing directives found inside of macro argument
101042 | Fatal Error #defines nested too deeply or are recursive
101044 | Fatal Error Wrong number of parameters in macro call
101046 | Fatal Error Error directive encountered
101047 | Fatal Error redeclaration of:
101048 | Fatal Error End of file found in #if, #ifdef, #ifndef, or #elif
101050 | Fatal Error #defines nested too deeply
101052 | Fatal Error Intrinsic arguments have wrong type, please include spe.h
101053 | Fatal Error __ev64_*__ types not permitted in SDA or ZDA
101054 | Fatal Error Intrinsic requires compile time constant as argument:
101055 | Fatal Error Intrinsic requires compile time constant (-128..127) as argument:
101056 | Fatal Error Intrinsic requires compile time constant (-16..15) as argument:
101057 | Fatal Error Intrinsic requires coprocessor register (0..31) as argument:
101058 | Fatal Error Unknown identifier
101060 | Fatal Error #pragma must use a non-common symbol defined in this module, not:
101061 | Fatal Error Size overflow of section
101064 | Fatal Error alloca() is not supported for MIPS16
101066 | Fatal Error __bytereversed only applies to int or short
101067 | Fatal Error _packed floating point types not allowed
101068 | Fatal Error Intrinsic requires compile time constant (0..1023) as argument:
101069 | Fatal Error Intrinsic requires compile time constant (-512..511) as argument:
101070 | Fatal Error Intrinsic requires compile time constant (0..255) as argument:
101071 | Fatal Error Intrinsic requires compile time constant (-32..31) as argument:
101072 | Fatal Error Intrinsic requires compile time constant (0..31) as argument:
101073 | Fatal Error Intrinsic requires compile time constant (0..15) as argument:
101074 | Fatal Error Intrinsic requires compile time constant (0..7) as argument:
101075 | Fatal Error stack overflow or underflow
101076 | Fatal Error Unable to acquire license for product code:
101077 | Fatal Error Multiple aliases detected for symbol:
101079 | Fatal Error Read/Write past top of stack frame
101080 | Fatal Error Read/Write past bottom of stack frame
101082 | Fatal Error This target does not support linkonce functions:
101083 | Fatal Error Processor not supported in this release
101084 | Fatal Error Alias conflicts with existing definition of identifier:
101086 | Fatal Error Inconsistency in inliner intermediate code files (.inf files). Clean your project and rebuild.
101087 | Fatal Error GNU ASM operand constraints do not allow for allocation
101088 | Fatal Error Unable to find suitable register for GNU ASM statement
101089 | Fatal Error Reference to undefined GNU ASM operand
101090 | Fatal Error Intrinsic requires compile time constant (0..63) as argument:
101091 | Fatal Error Intrinsic requires compile time constant (1..32) as argument:
101092 | Fatal Error Intrinsic requires compile time constant (1..64) as argument:
101093 | Fatal Error Too many ELF sections
101094 | Fatal Error Cannot allocate function; please lessen GNU inline assembly restrictions
101095 | Fatal Error Unexpected declaration or definition of symbol:
101096 | Fatal Error LSP instrinsic immediate argument(s) must be literals
101097 | Fatal Error LSP intrinsic immediate(s) out of range
101098 | Fatal Error Overlapping volatile region detected; check for structure packing. Object is:
101099 | Fatal Error Too many volatile regions; only 65535 may be tracked.


Diagnostics 101100 to 101199

101100 | Fatal Error Intrinsic requires compile time constant (0..0x1ffffff) as argument:
101101 | Fatal Error Elf file overflow
101102 | Fatal Error Identifier too long
101103 | Fatal Error Function stack size too large for -gtws (each function's stack must be smaller than 512MB).
101104 | Fatal Error Code/object tree debugging output suppressed with binary codegen
101105 | Fatal Error A filename is required for
101106 | Fatal Error Illegal use of 'H' or 'L' GNU ASM modifier. Modifier may only be used on a 32-bit processor for 64-bit integer types.
101107 | Fatal Error Line count exceeds implementation limit
101108 | Fatal Error MMX and floating-point stack used in the same function
101109 | Fatal Error Local branch out of range. Function too large.
101110 | Fatal Error GNU ASM floating point constraint used with software floating point
101111 | Fatal Error Reference to unknown GNU ASM modifier:
101112 | Fatal Error Only basic asm expressions are allowed for functions with __attribute__((naked)):
101113 | Fatal Error Thumb-1 codegen is incompatible with hardware floating point, but both were requested for function
101114 | Fatal Error -Xx86_rdrand_rdseed_fixed_output_register is not compatible with 16-bit rdrand/rdseed
101115 | Fatal Error Bad argument to
101116 | Fatal Error alloca not supported in functions which use the PPC64 parameter save area


Linker Diagnostic Messages

This chapter lists diagnostic messages that you may encounter when linking code, listed by diagnostic number.


Linker Diagnostic Message Codes

The following list contains all the linker diagnostic messages:


Diagnostics 1 to 99

1

Fatal Error

expected -Cname=value

Option -Cname is not followed by expected syntax of equal sign and constant.

2

Fatal Error

expected '{' for memory map

MEMORY directive not followed by bracket. See syntax for MEMORY directive in “Defining a Memory Map with the MEMORY Directive”.

3

Fatal Error

expected ORIGIN in memory declaration for xxxx

In MEMORY directive, block declaration not followed by ORIGIN. See syntax for MEMORY directive in “Defining a Memory Map with the MEMORY Directive”.

4

Fatal Error

negative LENGTH in memory declaration

In MEMORY directive, block declared with LENGTH less than zero. Memory block length must be non-negative integer.

5

Fatal Error

expected LENGTH or MIRROR in memory declaration for xxxx

In MEMORY directive, block declaration not followed by LENGTH. See syntax for MEMORY directive in “Defining a Memory Map with the MEMORY Directive”.

6

Fatal Error

expected '{' for constant list

DEFAULTS or CONSTANTS directive not followed by open bracket. See syntax for DEFAULTS directive in “Setting Defaults with the DEFAULTS Directive”.

7

Fatal Error

don't know how to evaluate xxxx(…) as a constant

Expected expression that evaluates to a constant, either a number, a previously defined constant symbol, or some arithmetic combination of those.

8

Fatal Error

don't know how to evaluate xxxx as a constant

Expected expression that evaluates to a constant, either a number, a previously defined constant symbol, or some arithmetic combination of those.

Example:

DEFAULTS {
foo = 0x2000  // Correct
bar = foo + 0x2000  // Correct
baz = nonsense  // Error, don't know how to evaluate
                // nonsense as a constant
}

10

Fatal Error

expected -argcheck=none|normal|full

Option -argcheck given parameter other than none, normal, or full.

11

Fatal Error

section xxxx multiply defined in section map

Section declared more than once in SECTIONS directive.

Example:

SECTIONS {
     .mytext : > .
     .mytext :
}

12

Fatal Error

expected -ccvcheck=none|partial|full

Option -ccvcheck given parameter other than none, partial, or full.

13

Fatal Error

expected OPTION("-option")

OPTION directive did not contain string expression.

Example:

OPTION(-append)

Correct:

OPTION("-append")

14

Fatal Error

expected -Y U|L|UL,dir

Option -Y not followed by U, L, or UL.

15

Fatal Error

CROM sections are not supported with -a or -r

CROM section attribute used with relocatable object link.

Solution: Use CROM in final, absolute link stage or use uncompressed ROM.

16

Fatal Error

cannot find file xxxx

An option refers to a specific file which does not exist.

Example:

ccppc -exportall=dummy.o hello.c

Solution: Make sure the file exists or remove the option referring to it.

17

Fatal Error

No files to link. Use -help for help

Linker has been invoked without specifying any modules to link on the command line. Provide valid object files to link into an executable.

18

Fatal Error

Section xxxx cannot have additional contents because it is already ROMming section xxxx

A section with the ROM directive may not also be declared with other section contents.

Example:

SECTIONS {
     .text       : > .
     .ROM.text ROM(.text) : { *(.text2) } > .
}

Correct:

     .ROM.text ROM(.text) : > .

19

Fatal Error

In section map, expected: *(section) or file(section) or library(file)(section) or library(*)(section) instead of 'xxxx', or missing ';' after expression

Unrecognized section contents specified in SECTIONS directive.

Example:

SECTIONS { .text : { .text2 } > . }

Correct:

SECTIONS { .text : { *(.text2) } > . }

See section inclusion commands syntax in “Writing Section Inclusion Commands”.

20

Fatal Error

expected section name instead of 'xxxx'

SECTIONS directive contains entry that is not a valid section name.

Example:

SECTIONS { * : > . }

Correct:

SECTIONS { .text : > . }

See syntax for SECTIONS directive in “Defining a Section Map with the SECTIONS Directive”.

21

Fatal Error

cannot find library xxxx

Specified library does not exist in the library directories provided.

Example:

ccppc -ldummy hello.c

Solution: Make sure library exists, add the directory to find it with -L, or remove the library from build if unnecessary.

22

Fatal Error

-shared_lib and -use_shared_libs are mutually exclusive

The -shared_lib and -use_shared_libs options cannot both be used. Choose one or the other.

23

Fatal Error

Multiple ROM directives for section xxxx

More than one ROM directive specified for a single section.

Example:

SECTIONS { .ROM.text ROM(.text) ROM(.data) : > . }

Correct:

SECTIONS { .ROM.text ROM(.text) : > . }

24

Fatal Error

section xxxx already has a start directive

BIND directive encountered in SECTION map entry that already has a start_expression. This counts as a start_expression, and each section may only have one. See syntax for SECTIONS directive in “Defining a Section Map with the SECTIONS Directive”.

Example:

SECTIONS { .text BIND(0x1000) BIND(0x2000) : }

Correct:

SECTIONS { .text BIND(0x1000) : }

25

Fatal Error

expected -Dsymbol=value

Option -Dsymbol is not followed by expected syntax of equal sign and constant.

26

Fatal Error

expected -default_section leader=follower

Option -default_section is not provided an argument in the form of .section1=.section2.

Example:

ccppc hello.c -lnk="-default_section .text"

Correct:

ccppc hello.c -lnk="-default_section .text=.text2"

27

Fatal Error

expected -debug_section section=data

Incorrect syntax for option -debug_section, which requires argument in the form section=data.

28

Fatal Error

expected '}' for section map

Link map has a SECTIONS directive with an open bracket and no matching close bracket.

29

Non-Fatal Error

GNU linkmap output filename not specified.

-gnu_linkmap option used without specifying the name of the file to output.

Example:

ccppc hello.c -lnk=-gnu_linkmap

Correct:

ccppc hello.c -lnk=-gnu_linkmap=out.ld

30

Fatal Error

section xxxx references unknown memory block xxxx

In SECTIONS directive, a section is assigned to a block that has not been declared with a MEMORY directive.

Example:

SECTIONS { .text : > block_unknown }

Correct:

MEMORY { block_known : ORIGIN = 0x1000, LENGTH = 0x1000 }
SECTIONS { .text : > block_known }

31

Fatal Error

section declared more than once with -default_section

The same section is defined with two different -default_section options.

Example:

ccppc hello.c -lnk="-default_section .text=.text2" \
            -lnk="-default_section .rodata=.text2"

Correct:

ccppc hello.c -lnk="-default_section .text=.text2"

32

Fatal Error

expected -follow_section leader=follower

Option -follow_section is not provided a parameter in the form of .section1=.section2.

Example:

ccppc hello.c -lnk="-follow_section .text"

Correct:

ccppc hello.c -lnk="-follow_section .text=.text2"

33

Fatal Error

expected '{' for section map

SECTIONS directive is not immediately followed by an open bracket. See syntax for SECTIONS directive in “Defining a Section Map with the SECTIONS Directive”.

34

Fatal Error

unknown directive xxxx for section xxxx (perhaps a second <start> directive?)

In SECTIONS directive, a section is declared with an expression that is not recognized as a valid section attribute and cannot be the start_expression, since the section already has a start_expression. See syntax for SECTIONS directive in “Defining a Section Map with the SECTIONS Directive”.

Example:

SECTIONS { .text 0x1000 NONSENSE ALIGN(8) : }

Correct:

SECTIONS { .text 0x1000 ALIGN(8) : }

35

Fatal Error

expected ':' in the section map

In SECTIONS directive, a section name is not followed by a colon. See syntax for SECTIONS directive in “Defining a Section Map with the SECTIONS Directive”.

36

Fatal Error

already have a load address for xxxx

Multiple LOAD or AT directives declared for the same section.

Example:

SECTIONS { .text LOAD(0x1000) LOAD(0x2000) : }

Correct:

SECTIONS { .text LOAD(0x1000) : }

37

Fatal Error

argument too long

An option was provided an argument billions of characters long.

38

Fatal Error

syntax error on symbol override

Incorrect syntax for this option, which requires argument in the form symbol=symbol.

39

Fatal Error

expected -Qy or -Qn

Option -Q followed by something other than the character y or n.

40

Fatal Error

xxxx is an invalid diagnostic number

-elxr_diag_(suppress|error|warning) option provided with an argument that does not correspond to a valid diagnostic number.

Example:

ccppc hello.c -lnk="-elxr_diag_warning -1"

41

Fatal Error

diagnostic #xxxx cannot be suppressed

Attempt to use -elxr_diag_suppress on a fatal error number.

42

Fatal Error

diagnostic #xxxx cannot be demoted to a warning

Attempt to use -elxr_diag_warning on a fatal error number.

43

Fatal Error

could not access file: xxxx

A .raw file specified with -rawimport option cannot be opened for reading.

44

Fatal Error

While allocating commons: unknown common symbol xxxx from module xxxx for section ####

A variable using the --commons syntax could not be mapped to a suitable section.

45

Fatal Error

malformed .ghs.linkonce section name "xxxx"

A linkonce section name is not in the form: .ghs.linkonce.NUMBER.SECTION

Example invalid symbol name: .ghs.linkonce.text or .ghs.linkonce.1

Example correct symbol name: .ghs.linkonce.1.text

47

Fatal Error

module xxxx differs in machine type or endianness

Attempting to link together incompatible modules, compiled with different endianness modes or for completely different architectures.

48

Fatal Error

write failed

The linker was not allowed by the host operating system to finish writing data to an output file. Possibly the disk is full.

49

Fatal Error

unknown internal relocation: ####

A module contains an unrecognized relocation code in a special reserved range.

50

Fatal Error

Couldn't ROM xxxx to xxxx because section "xxxx" does not exist

The ROM directive is used to declare a section as the ROM copy of a section that does not exist.

Example:

SECTIONS { .ROM.text ROM(.unknown) : }

Correct:

SECTIONS { .ROM.text ROM(.text) : }

51

Fatal Error

[InMem TimeMachine] (error) Unable to locate a .inmemtm-like section during a kernel link.

The option -inmemtm is used to link the INTEGRITY kernel but the link map does not define any *.inmemtm sections.

52

Fatal Error

couldn't open file xxxx Maybe another process has xxxx this file?

An object file being linked could not be opened for reading by the host operating system.

53

Fatal Error

different machine flags in module xxxx: #### vs #### in other modules (machine = ####)

Two modules being linked together have different and incompatible ELF flags, suggesting they were not compiled for the same processor type.

54

Fatal Error

Couldn't CROM xxxx to xxxx because section "xxxx" does not exist

The CROM directive is used to declare a section as the compressed ROM copy of a section that does not exist.

Example:

SECTIONS { .ROM.text CROM(.unknown) : }

Correct:

SECTIONS { .ROM.text CROM(.text) : }

55

Fatal Error

can't have an 8-bit branch displacement of #### xxxx

57

Non-Fatal Error

module xxxx was compiled with -registermode=32 but previous modules were compiled with -registermode=22

RH850 specific. A module compiled with -registermode=22 is being linked with a module compiled with the incompatible -registermode=32 option.

59

Fatal Error

.ghstraceedge section must be in 16-bit address range for ZDA mode

PowerPC specific. *.ghstraceedge section is located too far from address 0.

60

Fatal Error

bad character in literal: 'xxxx' in 'xxxx'

An option was expecting an integer value and got something else.

Example:

ccppc hello.c -lnk=-Cdummy=notanumber

Correct:

ccppc hello.c -lnk=-Cdummy=152

63

Fatal Error

missing a vital dynamic section in xxxx

An INTEGRITY shared library object does not contain expected .dynamic or .dynsym sections.

64

Fatal Error

-map_file and -prof_file are required with -profile. Use -help for help.

The -cfprofile option is used but the corresponding -cfmap_file and -cfprof_file options have not been used to specify input files with profiling data.

65

Fatal Error

cannot merge symbol with incompatible special common types: xxxx

A COMMON symbol appears in two different modules with incompatible declarations such that they each belong in different section types.

66

Fatal Error

cannot open directive file 'xxxx' (xxxx)

An option file (specified with a '@', like elxr @commands.txt) cannot be opened for reading by the host operating system. Does the file exist?

67

Fatal Error

unable to obtain a suitable license

A license may not be available to use the toolchain for various reasons. There could be a configuration or network issue, the licenses could all be in use, etc. Read documentation on licensing to troubleshoot.

68

Fatal Error

Attempt to change the size of section "xxxx" which was already used in a relocation

70

Fatal Error

file read failed for xxxx: possible file corruption or disk error

Could not read from ELF module, or the values read are not properly formatted. This file may have been corrupted and should probably be removed and rebuilt.

71

Fatal Error

SHT_GROUP section xxxx has an invalid sh_info index ####

An SHT_GROUP section does not have the index of a corresponding symbol.

72

Fatal Error

Function xxxx in xxxx in .text must be a multiple of four-bytes in size.

PowerPC specific. A non-VLE function has a size that is not 4 byte aligned.

73

Fatal Error

.robase section does not exist

74

Fatal Error

Reference to non-exported symbol xxxx in module xxxx

The -exported_absolutes_only option is used and there is a relocation to an external absolute symbol that has not been explicitly exported by an entry in the .ghsexports section.

75

Fatal Error

More than one .ghstraceedge like section in linker directive file

The section map contains multiple sections matching: *.ghstraceedge

76

Fatal Error

different machine flags in module xxxx: #### vs #### in other modules

Two modules being linked together have different and incompatible ELF flags, suggesting they were not compiled for the same processor type.

77

Fatal Error

attempt to allocate non-empty section xxxx to zero-length memory region xxxx

A section has been assigned a block of memory of size zero.

Example:

MEMORY { block_zero : ORIGIN = 0x10000, LENGTH=0x0 }
SECTIONS { .text : > block_zero }

Correct:

MEMORY { block_nozero : ORIGIN = 0x10000, LENGTH=0x8000 }
SECTIONS { .text : > block_nonzero }

78

Fatal Error

Malformed object file: xxxx(xxxx) has bad symbols

The object file format is wrong and possibly corrupt. A symbol is listed at a location that exceeds the size of the section it is in.

79

Fatal Error

Unknown or malformed function description symbol xxxx in module xxxx

A Green Hills Compiler generated symbol name beginning with the prefix ..gh.f. has an unsupported format containing unexpected characters. The object file could be generated by a compiler of a newer version than the linker executable.

80

Fatal Error

Relocation to overridden local linkonce symbol xxxx(xxxx)

Something has gone wrong with template instantiation and there are references to a redundant instance that have not been redirected to the chosen instance. This might happen if one of the modules referencing the template was not recompiled after changing the template.

82

Fatal Error

Relocation stack underflow xxxx

Blackfin specific. A complex expression relocation expected to be preceded by another relocation on the stack but was not.

83

Fatal Error

section xxxx's start address differs from the absolute (.org) address in module xxxx

A section marked with an absolute fixed address is placed in an output section with a different, incompatible address.

84

Fatal Error

compressed section xxxx is invalid: rommed section xxxx has type SHT_NOBITS

A compressed ROM section is created for a section that is not initialized with data and therefore has nothing to compress.

Example:

SECTIONS { .ROM.bss CROM(.bss) : }

Correct:

SECTIONS { .ROM.data CROM(.data) : }

85

Fatal Error

xxxx is an empty file

Attempted to translate a COFF file that contained no data into an ELF file.

87

Fatal Error

Attempt to change the value of symbol "xxxx" which has already been relocated

88

Fatal Error

SHT_GROUP section xxxx has no flags word

A GROUP section exists but contains no data.

89

Fatal Error

archive xxxx is missing its symbol table, and errors occurred while recovering. Run 'ax -ts xxxx' to rebuild table manually.

A library archive was missing the appropriate index that would allow us to access it, and an attempt to automatically generate this information failed. You can try to reformat this archive yourself using ax-ts

90

Fatal Error

could not generate a -prog2 image. Program header summary: xxxx

The option -prog2 was used, unsuccessfully.

91

Fatal Error

AutoSDA is incompatible with TraceEdge

The linker -sdaize or -zdaize optimization options are not supported in conjunction with the -traceedge or -inmemtm trace instrumentation options.

92

Fatal Error

error reading library xxxx

A library file was either unavailable for reading by the host operating system or the header was not formatted like a proper archive file.

93

Fatal Error

file xxxx is not a library

The header of a library file is not marked like a proper ELF archive should be.

94

Fatal Error

literal 'xxxx' is out of range

An immediate value is specified that would be more than 64-bits.

Example:

MEMORY { block_big  : ORIGIN = 0, LENGTH=100000000000000M }

96

Fatal Error

unhandled symbol xxxx in section xxxx of module xxxx; this module might contain invalid inline assembly statements

Linker optimizations were unable to properly disassemble the contents of a function. This may be due to inline assembly that is not safe to optimize.

98

Fatal Error

.ghstraceedge section must have non-zero size

The -traceedge option is used, but a *.ghstraceedge section is totally empty.

99

Non-Fatal Error

module xxxx was compiled with -registermode=22 but previous modules were compiled with -registermode=32

RH850 specific. A module compiled with -registermode=22 is being linked with a module compiled with the incompatible -registermode=32 option.


Diagnostics 100 to 199

100

Fatal Error

badly formed argument checking symbol encountered

Link-time argument checking is used, but the argument checking symbol name does not conform to expected syntax. These labels are expected to be in the form: __calle[e|r].FunctionName.ReturnType.ArgumentList

103

Fatal Error

ZDA overflow: symbol 'xxxx' out of range

TriCore specific. R_TRICORE_18ABS relocation out of range.

104

Non-Fatal Error

Possible xxxx incompatibility between modules xxxx and xxxx

C++ ABI compilation options do not match for two of the modules being linked together. Make sure both are up to date and compiled with similar options.

105

Fatal Error

.sdabase section does not exist

The section map does not declare an .sdabase section. Add one to the link map, or recompile without -sda options.

106

Fatal Error

xxxx section does not exist

RH850 specific. A required SDA related section is missing from the link map.

107

Fatal Error

AutoSDA cannot operate on a section map containing .PPC.EMB.sbss0 but not .PPC.EMB.sdata0

PowerPC specific. The link time ZDA optimization is enabled, and the link map contains a .PPC.EMB.sbss0 section, but not a .PPC.EMB.sdata0 section. Add a .PPC.EMB.sdata0 section to the link map or disable the ZDA optimization.

108

Fatal Error

.sdabase section not defined

The section map does not declare an .sdabase section. Add one to the link map, or recompile without -sda options.

109

Fatal Error

corrupt dynamic string table reference in xxxx

An INTEGRITY shared library has an invalid entry in .dynamic section.

110

Fatal Error

unable to obtain license for product code ####

Linking a proprietary module that requires a separate license, but a license was unavailable. Read licensing documentation or contact support.

111

Fatal Error

module xxxx has incompatible FPU version xxxx, should be xxxx

RH850 specific. Two modules are compiled for different floating point versions. Make sure all modules are recompiled with compatible options.

112

Fatal Error

corrupt string table reference for symbol #### in xxxx

This ELF object file has invalid references from symbol table to string table. It is possible that it has been corrupted and needs to be rebuilt.

114

Fatal Error

section xxxx in module xxxx does not conform to the ABI, has item with unrecognized name xxxx

RH850 specific. The .note.renesas containing supplemental ABI information is not properly formatted. Expected to contain the string REL in note entry.

115

Fatal Error

sh_entsize is 0 in section #### of module xxxx

A table section is marked with an invalid entry size of zero.

116

Fatal Error

problem during translation to ELF for xxxx

Translating COFF object file to ELF was unsuccessful. Attempt to translate to ELF file manually using gcof2elf or recompile with ELF tools.

117

Fatal Error

not an ELF object file: xxxx

An object file header is not properly formatted according to the ELF standard. Make sure it is an ELF object file.

118

Non-Fatal Error

module xxxx was compiled with ep(r30) not reserved but previous modules may have been

RH850 specific. Not all object files were compiled in the same mode with regard to whether to reserve ep(r30). Compile all files with the same option.

119

Fatal Error

couldn't find section xxxx needed to initialize symbol xxxx

A required section was not defined in the link map, so add it there.

120

Fatal Error

couldn't redirect every reference from xxxx to xxxx

121

Fatal Error

module xxxx has incompatible data alignment xxxx, should be xxxx

RH850 specific. Not all object files were compiled according to the same ABI data alignment setting. Compile all files with the same option.

122

Fatal Error

bad magic number in archive xxxx at offset ####

Library header contains unexpected characters. Possibly corrupt file.

124

Fatal Error

module xxxx has incompatible double size xxxx, should be xxxx

RH850 specific. Not all object files were compiled according to the same ABI double size setting. Compile all files with the same option.

125

Fatal Error

unable to parse license identifier

A proprietary module has improperly formatted licensing information. Contact customer support for help resolving.

127

Fatal Error

file xxxx didn't have a symbol table

An ELF object file is expected to have a table of symbols, but this did not. This file is possibly corrupt or not a valid ELF file.

128

Fatal Error

_SMALL_DATA_A8_ symbol is not defined for a8-relative SDA.

TriCore specific. SDA is used, but no _SMALL_DATA_A8_ symbol is defined. Declare that symbol in the link map or disable SDA optimizations.

129

Fatal Error

unknown object file format in xxxx

Object file is in a format that is neither ELF nor a supported COFF format. This file may need to be recompiled with tools that use a supported format.

130

Non-Fatal Error

module xxxx was compiled with r2 reserved but previous modules may not have been

RH850 specific. Not all object files were compiled in the same mode with regard to whether to reserve r2. Compile all files with the same option.

131

Fatal Error

-rpxtntp requires .ghstraceedge section defined in section map

Option -rpxtntp is used, but .ghstraceedge section is not defined in link map. Define that section or eliminate the option.

132

Fatal Error

encountered PICBASE relocation in .rel section

RH850 specific. The PICBASE relocation is only supported in sections that use the .rela format, such as those generated by GHS Compilers.

134

Fatal Error

Could not compress xxxx to xxxx

A compressed ROM section is created for a section that is not initialized with data and therefore has nothing to compress.

135

Fatal Error

combining Elf64 relocatable file into Elf32 executable

A file using the 64-bit ELF format is being linked into a 32-bit program. If this is being done intentionally, you can work around it using the -allow_elf64_to_elf32 linker option, otherwise recompile in a 32-bit mode.

136

Fatal Error

V800: section xxxx in module xxxx is too large to insert a farcall patch for function xxxx

RH850 specific. Linker far call patching failed because this module is larger than the maximum range of a non-far call. Read documentation on far calls for possible alternatives to linker far call patching.

137

Non-Fatal Error

module xxxx was compiled with gp(r4) not reserved but previous modules may have been

RH850 specific. Not all object files were compiled in the same mode with regard to whether to reserve gp(r4). Compile all files with the same option.

138

Non-Fatal Error

module xxxx was compiled with r2 not reserved but previous modules may have been

RH850 specific. Not all object files were compiled in the same mode with regard to whether to reserve r2. Compile all files with the same option.

139

Fatal Error

_SMALL_DATA_ symbol is not defined

TriCore specific. SDA is used, but no _SMALL_DATA_ symbol is defined. Declare that symbol in the link map or disable SDA optimizations.

140

Non-Fatal Error

module xxxx was compiled with tp(r5) reserved but previous modules may not have been

RH850 specific. Not all object files were compiled in the same mode with regard to whether to reserve tp(r5). Compile all files with the same option.

141

Fatal Error

_SMALL_DATA_A9_ symbol is not defined for a9-relative SDA.

TriCore specific. SDA is used, but no _SMALL_DATA_A9_ symbol is defined. Declare that symbol in the link map or disable SDA optimizations.

142

Fatal Error

bad ELF object file (header): xxxx

An ELF header is not properly marked, indicating that the object file could be corrupt or in an unsupported format. Recompile with supported tools.

143

Fatal Error

Output section xxxx includes xxxx(xxxx) with type ####:xxxx, unlike xxxx(xxxx) with type ####:xxxx

Two sections given the same name are fundamentally different section types. Make sure that custom sections are defined with the same attributes wherever they are used, or give different uses a new section name to resolve conflicts.

The option -allow_different_section_types allows the linker to silently combine two sections if one has type SHT_PROGBITS and the other has type SHT_NOBITS.

144

Fatal Error

SDA/ZDA is not supported on the section used as the TraceEdge instrumentation section.

PowerPC specific. Some modules are attempting to use the same register for SDA/ZDA optimizations that others are using for TraceEdge instrumentation. Make sure all modules are compiled with consistent options, and either disable the conflicting SDA optimization or change the TraceEdge register.

145

Fatal Error

SHT_GROUP section xxxx contains invalid section index ####

A GROUP entry references a section that does not exist in that module. This ELF file may be corrupt or in an unsupported format.

146

Fatal Error

.pcpdata section must exist for -pcptrans

TriCore specific. The .pcpdata is not defined in link map. Either define that section or disable the -pcptrans option.

147

Fatal Error

Failure to initialize TraceEdge framework

The -inmemtm option is used, but the required record symbols are not present.

148

Fatal Error

couldn't ROM xxxx to xxxx

Failed to generate a ROM() section because either the ROM section already has contents of its own or the RAM version is a non-standard section type.

149

Fatal Error

section xxxx in module xxxx does not conform to the ABI

RH850 specific. The .note.renesas containing supplemental ABI information is not properly formatted.

150

Fatal Error

relocation section #### has invalid sh_info field #### (should be a section index)

An ELF relocation section refers to another section that does not exist. This could indicate a corrupt file or unsupported file format.

151

Non-Fatal Error

module xxxx was compiled with tp(r5) not reserved but previous modules may have been

RH850 specific. Not all object files were compiled in the same mode with regard to whether to reserve tp(r5). Compile all files with the same option.

153

Fatal Error

.ghstraceedge section size must be a non-zero power of 2

The -traceedge option is used, but a *.ghstraceedge section has an invalid size. This section should have a power of 2 size.

154

Fatal Error

AutoSDA cannot operate on a section map containing .sbss but not .sdata

PowerPC specific. The link time SDA optimization is enabled, and the link map contains an .sbss section, but not an .sdata section. Add an sdata section to the link map or disable the SDA optimization.

155

Non-Fatal Error

Possible xxxx incompatibility detected in module xxxx

157

Fatal Error

bad relocation sequence: expected HIGH to be followed by IPAIR, not nothing

RH850 specific. A HIGH relocation should be followed by an IPAIR relocation.

158

Non-Fatal Error

module xxxx was compiled with gp(r4) reserved but previous modules may not have been

RH850 specific. Not all object files were compiled in the same mode with regard to whether to reserve gp(r4). Compile all files with the same option.

160

Fatal Error

.pcptext section must exist for -pcptrans

TriCore specific. The .pcpdata is not defined in link map. Either define that section or disable the -pcptrans option.

161

Fatal Error

_LITERAL_DATA_ symbol is not defined

TriCore specific. SDA is used, but no _LITERAL_DATA_ symbol is defined. Declare that symbol in the link map or disable SDA optimizations.

163

Fatal Error

module xxxx has incompatible SIMD/FXU mode xxxx, should be xxxx

RH850 specific. Not all object files were compiled according to the same ABI SIMD mode setting. Compile all files with the same option.

165

Non-Fatal Error

module xxxx was compiled with ep(r30) reserved but previous modules may not have been

RH850 specific. Not all object files were compiled in the same mode with regard to whether to reserve ep(r30). Compile all files with the same option.

167

Fatal Error

bad relocation sequence: expected HIGH to be followed by IPAIR, not ####

RH850 specific. A HIGH relocation should be followed by an IPAIR relocation.

168

Fatal Error

link-time SDA cannot be performed: relocation in module xxxx at xxxx+#### to section xxxx+####

The link-time AutoSDA optimization cannot be performed because there are relocations relative to data sections rather than the symbols within those data sections. It is not safe to optimize section relative relocations because it is unknown what variables they might be referring to. If this type of relocation occurs in compiled code built for AutoSDA, it might indicate a compiler bug.

169

Fatal Error

Unexpected relocation kind (####) from a function descriptor xxxx [xxxx] + 8 for the TOC base

PowerPC64 specific. Unexpected PPC64 TOC base relocation type in .opd section.

170

Fatal Error

Internal error - expected a ppc64 farcall

171

Fatal Error

Section xxxx is larger than #### bytes

A section in a 32-bit ELF image exceeds 32-bits in size.

172

Fatal Error

Relocation of type R_MIPS_PICHIGHADJ encountered without a preceding R_MIPS_PICBASE

MIPS specific. An R_MIPS_PICHIGHADJ relocation must be paired with a R_MIPS_PICBASE relocation.

173

Fatal Error

section xxxx starting at #### didn't fit in configured memory

A section is declared with SECTIONS directive at a specific memory location that does not place it in any of the configured blocks of memory declared with the MEMORY directive. If the target has available memory there, then declare a MEMORY block to represent it, otherwise move the section's starting address to within a valid region of memory.

Example:

MEMORY { block_one : ORIGIN=0x1000, LENGTH=0x1000 }
SECTIONS { dummy 0x3000 : }

Correct:

MEMORY { block_one : ORIGIN=0x1000, LENGTH=0x1000 }
SECTIONS { dummy 0x1000 : }

174

Fatal Error

unknown ARM pool reference instruction: #### in module xxxx at xxxx+####

ARM specific. An ARM pool relocation is located at an instruction that does not disassemble as any known pool instruction.

175

Non-Fatal Error

Bad relocation sequence. REL R_MIPS_HI0 relocation is expected to be followed by REL R_MIPS_LO16, or R_IPAIR relocation

MIPS specific. An R_MIPS_HI0 relocation is expected to be paired with another relocation, but is not. This can possibly be worked around with -gnu_compat.

176

Fatal Error

module xxxx has Virtualization/Hardware Multiple Task Thread instructions but a previous module might have been a RH850G3K core

RH850 specific. Not all object files were compiled for compatible CPU types. Compile all files with the same CPU option.

177

Fatal Error

PPC: Illegal R_PPC_EMB_BIT_FLD addend form

PowerPC specific. An R_PPC_EMB_BIT_FLD relocation has an invalid addend value.

178

Fatal Error

Insufficient additional SDA registers provided.

PowerPC specific. There is too much data put in SDA sections to fit within their range limits. Either fewer variables need to be placed in SDA, or additional registers must be allocated to offset the expanded SDA area. You can use the -additional_sda_reg=N option to reserve more registers.

179

Fatal Error

Internal error: no function symbol to jump to after .opd adjustments

180

Non-Fatal Error

Bad relocation sequence. REL R_MIPS_HI16 relocation is expected to be followed by REL R_MIPS_LO16, or R_IPAIR relocation

MIPS specific. An R_MIPS_HI16 relocation is expected to be paired with another relocation, but is not. This can possibly be worked around with -gnu_compat.

181

Fatal Error

Intercall patching not supported for function entry/exit history

ARM specific. A __ghs_log_fee function is in a different execution mode than the caller on a target that cannot switch modes without an intercall veneer. This combination of options is not supported. Compile this FEE instrumented code in ARM mode.

182

Fatal Error

PPC: Unknown section for relocation to xxxx from xxxx + ####

183

Fatal Error

Cannot change ISA mode with j xxxx at xxxx+####

MIPS specific. There is a relocation from a function in non-MIPS16 mode to a function in MIPS16 mode for an instruction that is not capable of switching modes automatically.

184

Non-Fatal Error

Bad relocation sequence. REL R_MICROMIPS_HI0 relocation is expected to be followed by REL R_MICROMIPS_LO16, or R_IPAIR relocation

MIPS specific. An R_MICROMIPS_HI0 relocation is expected to be paired with another relocation, but is not. This can possibly be worked around with -gnu_compat.

186

Fatal Error

Not in the same region with bgezal xxxx at xxxx+####

MIPS specific. There is a relocation from a function in non-MIPS16 mode to a function in MIPS16 mode that cannot be fixed because it spans across different memory regions.

187

Fatal Error

module xxxx is a RH850G3K core but a previous module might have Virtualization/Hardware Multiple Task Thread instructions

RH850 specific. Not all object files were compiled for compatible CPU types. Compile all files with the same CPU option.

188

Fatal Error

Attempt to change the address of section "xxxx" which was already used in a relocation; maybe this section's address depends on the size of a CROM section

189

Fatal Error

Encountered unknown relocation type (####) in module xxxx.

MIPS specific. Unhandled relocation. This object file may be generated by a toolchain that is newer than or not supported by this linker version.

190

Fatal Error

Cannot switch ISA in PIC mode with branch to xxxx at xxxx+####

MIPS specific. There is a relocation from a function in non-MIPS16 mode to a function in MIPS16 mode that cannot be fixed when using the -pic option.

191

Fatal Error

.toc section does not exist

PowerPC64 specific. There are PPC64 TOC relocations present, but the section map does not contain a .toc section. Declare a .toc section in linker directive file.

192

Fatal Error

Cannot switch ISA with conditional branch to xxxx at xxxx+####

MIPS specific. There is a relocation from a function in non-MIPS16 mode to a function in MIPS16 mode for an instruction that is not capable of switching modes automatically.

193

Fatal Error

Expected 'nop' instruction after PC-relative relocation from xxxx [xxxx] to xxxx.

PowerPC64 specific. An out of range PPC64 TOC call does not have an expected NOP instruction to use during far call expansion.

194

Fatal Error

unknown THUMB2 pool reference instruction: #### in module xxxx at xxxx+####

ARM specific. An Thumb-2 pool relocation is located at an instruction that does not disassemble as any known pool instruction.

195

Fatal Error

failed to convert SDA23 to SDA16 at xxxx (####)

RH850 specific. There is a 23-bit SDA relocation associated with an unrecognized type of instruction. Workaround by disabling the -shorten_loads and -shorten_moves optimizations.

196

Fatal Error

Unexpected relocation kind (####) from a function descriptor xxxx [xxxx] to function xxxx

PowerPC64 specific. Unexpected PPC64 TOC function relocation type in .opd section.

197

Non-Fatal Error

Bad relocation sequence. REL R_MICROMIPS_HI16 relocation is expected to be followed by REL R_MICROMIPS_LO16, or R_IPAIR relocation

MIPS specific. An R_MICROMIPS_HI16 relocation is expected to be paired with another relocation, but is not. This can possibly be worked around with -gnu_compat.

198

Fatal Error

ARM: section xxxx in module xxxx is too large to insert a farcall patch for function xxxx xxxx

ARM specific. Linker far call patching failed because this module is larger than the maximum range of a non-far call. Read documentation on far calls for possible alternatives to linker far call patching.


Diagnostics 200 to 299

200 | Fatal Error __gp is not set MIPS specific. The .sdabase section is not defined. Declare it in your linker directive file.
201 | Fatal Error Relocation of type R_MIPS_PICLOW encountered without a preceding R_MIPS_PICBASE MIPS specific. An R_MIPS_PICLOW relocation must be paired with a R_MIPS_PICBASE relocation.
203 | Fatal Error don't know how to extract addend for relocation #### Unhandled relocation in a REL relocation section. This object may have been compiled by a non-GHS toolchain that is not supported by this linker.
204 | Fatal Error Saw unexpected xxxx in xxxx (####), relink with -no_remove_pid to avoid error RH850 specific. A PID relocation was associated with an unexpected instruction type. Pass -no_remove_pid as a workaround.
205 | Fatal Error can't extract relocation #### Unhandled relocation in a REL relocation section. This object may have been compiled by a non-GHS toolchain that is not supported by this linker.
206 | Warning The program contains no reference to _dtors. The following C++ dynamic destruction routines will probably not get called: xxxx
207 | Warning ignoring ..fend symbol before end of function xxxx
208 | Warning Symbol xxxx has size 0.
209 | Warning Error in parsing the MISRA option.
210 | Warning Coverage section deletion failed -- unequal number of entries in xxxx and xxxx sections.
212 | Warning Unable to instrument function xxxx
213 | Warning Unexpected instruction #### with xxxx relocation
214 | Warning Option -extractall=xxxx was ignored, since option xxxx was not given
215 | Warning function: xxxx called in xxxx doesn't have an argument type checking declaration
216 | Warning Absolute relocation xxxx to function: from 'xxxx [xxxx]' to 'xxxx [xxxx]'
217 | Warning the checksum word on section xxxx overlaps section xxxx; removing checksum on xxxx to avoid overlap
218 | Warning TraceEdge unable to find .sdata2/.sdabase section in SDA mode
219 | Warning shared library xxxx does not support TDEH exception handling. Refer to the MULTI release notes for instructions on how to build shared libraries with TDEH support.
220 | Warning BLOCK directive has no effect.
221 | Warning no section map present. Assuming .text/.data/.bss use -T[text|data|bss] to set segment starts and avoid this warning use a section map for advanced placement control
222 | Warning The program contains no reference to _ctors. The following C++ dynamic initialization routines will probably not get called: xxxx
223 | Warning not defining xxxx: xxxx already exists in xxxx
225 | Warning ARM mapping symbols not found in section xxxx, module xxxx.
226 | Warning SHT_GROUP section #### has relocations! ignoring…
227 | Warning translating COFF file xxxx
228 | Warning .sdata and .sbss are not contiguous in the section map; AutoSDA will not place anything into .sbss
230 | Warning Unknown Pool Load
231 | Warning symbol xxxx in section xxxx was referenced as SDA at xxxx+#### but is out of range of the SDA base pointer
232 | Warning Function deletion should not be performed on object files with position-independent code that were built with older versions of the compiler. Please rebuild with a newer compiler or disable function deletion
233 | Warning Weak xxxx xxxx in xxxx overrides an equally weak definition in xxxx
234 | Warning Section xxxx at #### extends past 0
235 | Warning ignored -T[text|data|bss] due to section map
236 | Warning INTEGRITY interrupt routine does not have requisite padding: xxxx
237 | Warning section xxxx(xxxx) is not being included; module xxxx is not part of this link
238 | Warning Writeable section xxxx at #### liesxxxx between __ghs_romstart and __ghs_romend
239 | Warning xxxx will not be satisfied for -dyload links
240 | Warning ignoring size-#### ..fend symbol inconsistent with end of function xxxx
241 | Warning Layout of section xxxx does not converge on fixed address.
243 | Warning Unable to find map file, disabling CodeFactor profile feedback
244 | Warning Use of the special symbol __ghssizexxxx in -pic or -pid mode may produce incorrect results. Consider using (__ghsendxxxx - __ghsbeginxxxx) instead.
245 | Warning section xxxx(xxxx) is not being included; did you mean xxxx(xxxx)?
246 | Warning Did not find .callt section in linkmap. Enabling -v800_old_callt compatibility mode. See documentation on this option for more details.
247 | Warning script file xxxx included multiple times
248 | Warning -no_shared_lib_symbols should not be used when linking with shared libraries
249 | Warning Function deletion should not be performed on object files with position-independent code that were built with older versions of the compiler. Please rebuild with a newer compiler or disable function deletion.
250 | Warning Unexpected instruction #### with R_MICROMIPS_26_S1 relocation
251 | Warning unknown attributes for MEMORY block xxxx: xxxx
252 | Warning ARM mapping symbols not found for function xxxx, in section xxxx, module xxxx.
253 | Warning section xxxx in module xxxx has unrecognized setting: name=xxxx, id=0x####, value=0x####
254 | Warning relocation section #### has relocations! ignoring…
255 | Warning Invalid setting for Program Counter valid bits with xxxx. Setting ignored.
256 | Warning in module xxxx, section symbol ##### for section xxxx has a non-zero value. Attempting to fix and continue.
257 | Warning symbol xxxx in section xxxx was referenced as ZDA at xxxx+#### but is out of range of the ZDA base pointer
258 | Warning Patched reference to subroutine xxxx
259 | Warning Error in parsing the MISRA option: Invalid range.
260 | Warning TraceEdge has failed to fully instrument xxxx. Trace from this interrupt will be slighly limited.
261 | Warning branch to self detected: module xxxx at xxxx+####
262 | Warning cannot redirect stderr to xxxx
263 | Warning SUBALIGN has no effect. ELF section header specifies alignment
264 | Warning symbol xxxx in section xxxx was referenced as SDA at xxxx+#### but is out of range of 9-bit displacement from the SDA base pointer
265 | Warning archive xxxx contains a bad string table reference (module name) at offset ####, recovering
266 | Warning Unable to ignore instrumentation for function xxxx when instrumenting the kernel
267 | Warning checksum generation suppressed with relocatable link
268 | Warning size of symbol xxxx is inconsistent with location of function xxxx
269 | Warning Invalid map file, disabling CodeFactor profile feedback
270 | Warning section xxxx(xxxx) is not being included; section xxxx appears to be empty
271 | Warning maplines must be at least 5; ignoring -maplines=####
272 | Warning ignoring malformed option xxxx; try xxxx instead
273 | Warning ARM: unknown postamble in xxxx: ####
274 | Warning symbol xxxx in section xxxx was referenced as ZDA at xxxx+#### but is out of range of 9-bit displacement from the ZDA base pointer
275 | Warning unrecognized option: xxxx
276 | Warning setting start address to zero
277 | Warning xxxx generation not supported with CROM(xxxx)
278 | Warning orphan area at xxxx(xxxx)+####, nearest was xxxx at offset ####
279 | Warning unknown machine type: ####
280 | Warning this target doesn't support farcall patching
281 | Warning module xxxx contains relocations versus SHT_NOBITS section xxxx
282 | Warning Unknown MISRA option.
283 | Warning section xxxx from xxxx isn't included by the section map; appending after last section. add to section map or use -append to append without warning
284 | Warning ignoring ..fbeg symbol after start of function xxxx
285 | Warning Truncating the value of xxxx to 32 bits
286 | Warning Section flags do not match known section name - assuming SDA type by name - for section xxxx xxxx
288 | Warning unable to determine if absolute symbol: xxxx will work as the target of an intercall
289 | Warning couldn't adjust REL-type relocation (rel#####)!
290 | Warning found relocation into middle of now-defunct function xxxx xxxx
291 | Warning Unable to open profile information, disabling CodeFactor profile feedback
293 | Warning symbol xxxx has different sizes in: xxxx xxxx
294 | Warning symbol xxxx has different types in: xxxx xxxx
295 | Warning [InMem TimeMachine] Unable to locate .inmemtm section Appending .inmemtm section with size ####KB
296 | Warning Option -extractonce=xxxx was ignored, since option xxxx was not given
297 | Warning module xxxx not compiled for use with -auto_sda
298 | Warning ABS32 relocation mapping not defined
299 | Warning Unrecognized relocation attached to symbol xxxx (xxxx) in func.


Diagnostics 300 to 399

300 | Warning using subroutine symbol xxxx to patch references to deleted function.
301 | Warning [codefactor]: skipping module xxxx. xxxx
302 | Warning No functions found.
303 | Warning non-debug symbol at end of section
304 | Warning couldn't trace through pool relocation.
305 | Warning Unrecognized relocation.
306 | Warning pool data is 0x0. is it really data?
307 | Warning Unrecognized relocation attached to symbol xxxx (xxxx) in block.
308 | Warning deleted symbol has relocation refs.
309 | Non-Fatal Error unknown relocation type (xxxx) in xxxx
310 | Fatal Error section xxxx (####-####) doesn't fit in memory block xxxx (####-####)xxxx
311 | Fatal Error corrupt string table reference for section #### in xxxx
312 | Warning archive xxxx contains a bad string table reference (module name) at offset ####, recovering
313 | Warning library xxxx has a bad header at position ####, entry: xxxx
314 | Warning Symbol xxxx in module xxxx has a .fixaddr entry, but points to symbol xxxx which has an absolute address. This value may not be loaded properly at run time. Pass -delete_absolute_fixaddrs to the linker to fix this issue.
316 | Warning section xxxx is at a high address (#### - ####) that is out of range of the ####-bit Program Counter
317 | Warning module xxxx was compiled with 8-byte stack alignment but previous modules may not have been
318 | Fatal Error The program cannot be instrumented because of a non-local branch with no relocation, in function xxxx The compiler or assembler that produced that object file may not be compatible with -inmemtm. Turn off -inmemtm and run the linker again.
319 | Fatal Error The offset is too large to insert a farcall patch from xxxx (####) to xxxx (####) in module xxxx
320 | Warning module xxxx may have been compiled with 4-byte stack alignment but previous modules were compiled with explicit 8-byte stack alignment
321 | Warning couldn't adjust REL-type relocation: Offset: #### Type: #### Adjust: #### Dest Sym: xxxx in module xxxx
322 | Warning patching out of range relocation from xxxx (####) to xxxx (####) in module xxxx
323 | Warning Will not adjust section-relative relocation in file xxxx at location xxxx+#### that references section xxxx+#### relocation type: xxxxxxxx
346 | Fatal Error PLT entry for xxxx does not have corresponding .dynsym entry
349 | Fatal Error invalid .ghsinfo jtable size
350 | Fatal Error relocation at xxxx:xxxx+#### is outside of that section
352 | Fatal Error Unknown vtbl parent: xxxx
353 | Fatal Error some modules compiled with options unsafe for use with elxr
354 | Fatal Error .ghsinfo jtable out of sync
355 | Fatal Error Symbol 'xxxx' in module 'xxxx' is not located within executable section 'xxxx'
357 | Fatal Error Unknown vtbl class: xxxx
368 | Fatal Error corrupt symbol table in xxxx
370 | Fatal Error too many sections defined. At most #### supported.
373 | Fatal Error Cortex-A8 branch errata patching failure
375 | Non-Fatal Error section mismatch patching far-call to function xxxx
378 | Fatal Error bad relocation in module xxxx, references non-existent symbol ####
379 | Fatal Error Section too large for Cortex-A8 branch errata patching
384 | Fatal Error Sister vtbl entry was found!
388 | Fatal Error File error while writing binary; out of disk space?
392 | Fatal Error Bad sentinel value in UVFD section: ####
394 | Fatal Error bad elf file (sections): xxxx
396 | Fatal Error Unknown vtbl sym in readRoutSection(): xxxx
397 | Fatal Error inconsistent .fixaddr/.fixtype sections in xxxx
399 | Fatal Error relocation at xxxx:xxxx+#### is outside of that section


Diagnostics 400 to 499

400 | Non-Fatal Error Adjustment for j/jal/jalx offset too large
401 | Non-Fatal Error Function entry/exit history farcall patching not supported in THUMB mode
402 | Non-Fatal Error Unknown opcode for TDA relocation: ####
403 | Non-Fatal Error Mapping symbol xxxx does not indicate Arm/Thumb region.
404 | Non-Fatal Error Loop detected attempting to patch call to VLE function xxxx
405 | Non-Fatal Error .ghpepatch[xxxx] (@ ####): type = ####
406 | Non-Fatal Error .ghpepatch[xxxx] (@ ####): size = ####
407 | Non-Fatal Error Call table module xxxx not found
408 | Non-Fatal Error Bad relocation sequence. REL R_MIPS_GHS_PIDHIGHADJ relocation is expected to be followed by REL R_MIPS_GHS_PIDLOW, or R_IPAIR relocation
409 | Non-Fatal Error Failed to relocate data in TDA segment: address #### is out of range. (symbol xxxx, offset ####, addend ####)
410 | Non-Fatal Error malformed xxxx section in module xxxx
411 | Non-Fatal Error File error opening map file xxxx; skipping map file
412 | Non-Fatal Error unresolved symbols: #### xxxx
413 | Non-Fatal Error -traceedge_size must be power of 2
414 | Non-Fatal Error usage: -traceedge_size=hexsize, 0 < hexsize <= 0x10000
415 | Non-Fatal Error Call table symbol xxxx not defined
416 | Non-Fatal Error Function xxxx called from a no-TDA function in xxxx
417 | Non-Fatal Error cannot determine type of undefined function xxxx
418 | Non-Fatal Error ARM mapping symbols do not cover the address range of the section xxxx in module xxxx.
419 | Non-Fatal Error Loop detected attempting to patch far-call to function xxxx
420 | Non-Fatal Error Attempting to extract .rel relocation addend from non .rel section
421 | Non-Fatal Error Attempt to link module (xxxx) compiled with -notda against a module (xxxx) that uses the TDA
422 | Non-Fatal Error Bad relocation sequence. REL R_MICROMIPS_GHS_PIDHIGHADJ relocation is expected to be followed by REL R_MICROMIPS_GHS_PIDLOW
423 | Non-Fatal Error no global symbol for xxxx(xxxx)+####, local sym was xxxx
425 | Non-Fatal Error File error opening whitelist file xxxx; skipping whitelist
426 | Non-Fatal Error Module xxxx was compiled with TDA disabled but we are linking in MTDA mode
427 | Non-Fatal Error Could not find .dynsym entry for xxxx
428 | Non-Fatal Error -no_data_in_text is not supported for -pic
429 | Non-Fatal Error section xxxx from xxxx isn't included by the section map! add to section map or remove option -no_append
430 | Non-Fatal Error section symbol xxxx has non-zero st_value
431 | Non-Fatal Error -no_data_in_text is only supported on Thumb2 capable targets
432 | Non-Fatal Error usage: -traceedge_reg=R, for some gprR
433 | Non-Fatal Error Invalid instruction for R_ARM_ALU_PCREL relocation
434 | Non-Fatal Error patching to undefined symbols only supported with --integrity_posix_dll
435 | Non-Fatal Error malformed SHT_NOTE section xxxx in module xxxx
436 | Non-Fatal Error can't intercall_patch undefined symbol: xxxx
437 | Non-Fatal Error MISRA xxxx recommends that objects be declared at function scope whenever possible.
438 | Non-Fatal Error bad thumb BLxxxx relocation in module xxxx: got #### ####
439 | Non-Fatal Error Section xxxx moved as a result of compression and is not a ROM copy
440 | Non-Fatal Error MISRA xxxx recommends that objects declared at file scope be static whenever possible.
441 | Non-Fatal Error usage: -traceedge_addr=hexaddr
442 | Non-Fatal Error R_V800_CFPICREL32 relocation without matching R_V800_PICBASE
443 | Non-Fatal Error alias symbols have differing subcpu types: xxxx, xxxx
444 | Non-Fatal Error Unmatched TDA call to function xxxx in xxxx
445 | Non-Fatal Error common xxxx in xxxx has unsupported alignment: ####
446 | Non-Fatal Error -no_data_in_text is not supported with INTEGRITY TimeMachine
447 | Non-Fatal Error Cross-TDA call to function xxxx from TDA xxxx in xxxx
448 | Non-Fatal Error TDEH section deletion failed.
449 | Non-Fatal Error ambiguous local symbol xxxx multiply defined in: xxxx xxxx
450 | Non-Fatal Error couldn't process option xxxx
451 | Non-Fatal Error File error opening graph file xxxx; skipping call graph
452 | Non-Fatal Error .ghpepatch[xxxx] (@ ####): flags = ####
453 | Non-Fatal Error -no_data_in_text is not supported in THUMB mode
454 | Non-Fatal Error Absolute or PC-relative relocation was expected to shared weak symbol xxxx
455 | Non-Fatal Error Module xxxx contains a virtual function call to offset #### in the vtable for class xxxx, but the vtable for xxxx (defined in xxxx) does not contain an entry at that offset. The UVFD optimization cannot be performed. Pass -no_uvfd to continue.
456 | Non-Fatal Error Unexpected R_ARM_REL32 relocation found in optimized module.
458 | Non-Fatal Error .ghpepatch[xxxx] (@ ####): PC == 0
460 | Fatal Error in expression syntax: "xxxx" expected #### arguments
461 | Fatal Error globalreg count too large
462 | Fatal Error store instrumentation expected
463 | Non-Fatal Error read-only small data overflow: #### (signed) didn't fit in 16 bits, and could not be patched because the instruction or base register was not recognizedxxxx
464 | Fatal Error error() xxxx
465 | Non-Fatal Error xxxx: ####xxxx didn't fit in #### bits
466 | Non-Fatal Error ROSDA relocation encountered when ROSDA has been disabled
467 | Non-Fatal Error zero data overflow: #### (signed) didn't fit in 16 bits, and could not be patched because the instruction or base register was not recognized
469 | Fatal Error ABSOLUTE used outside of a section
470 | Fatal Error expected an expression after 'xxxx'
471 | Non-Fatal Error Cannot jump/call next instruction
472 | Non-Fatal Error read-only small data overflow: #### (signed) didn't fit in 23 bits, and could not be patched because the instruction or base register was not recognized
473 | Fatal Error expected an expression
474 | Non-Fatal Error read-only small data overflow: #### (signed) didn't fit in 16 bits, and could not be patched because the instruction or base register was not recognized
475 | Fatal Error expected ')'
476 | Fatal Error unknown section xxxx used in SIZEOF
477 | Fatal Error unterminated comment
478 | Non-Fatal Error unaligned: #### wasn't ####-byte aligned xxxx
479 | Fatal Error the argument to PROVIDE should be an assignment operation
480 | Fatal Error during eval: symbol xxxx doesn't exist
481 | Non-Fatal Error Table call relocation (R_V800_CALLT) without a table entry. Missing ___ghs_call_table symbol?
482 | Non-Fatal Error small data overflow: #### (signed) didn't fit in 16 bits, and could not be patched because the instruction or base register was not recognized
483 | Fatal Error expected ')' for 'xxxx'
484 | Fatal Error unknown section xxxx used in ENDADDR
485 | Fatal Error PHY is not supported. Remove the directive to avoid this error
486 | Non-Fatal Error Out of range. Not suitable for call table
487 | Warning Alignment expression must be a power of two
488 | Fatal Error saw branch in between function entry and first start of basic block
489 | Non-Fatal Error read-only small data overflow: #### (signed) didn't fit in 23 bits, and could not be patched because the instruction or base register was not recognizedxxxx
490 | Non-Fatal Error Overflow. CALLT table is full
491 | Fatal Error expected an argument to 'xxxx'
492 | Non-Fatal Error small data overflow: #### (signed) didn't fit in 23 bits, and could not be patched because the instruction or base register was not recognizedxxxx
493 | Fatal Error cannot assign to constant 'xxxx'
494 | Fatal Error volatile load instrumentation with no load
495 | Fatal Error unbounded string 'xxxx'
496 | Fatal Error expected something after xxxx
497 | Warning Alignment expression must be a power of two; changing from #### to ####.xxxx
498 | Non-Fatal Error Relocation not safe to be performed in shared code as it depends on core-specific initialization
499 | Non-Fatal Error small data overflow: #### (signed) didn't fit in 23 bits, and could not be patched because the instruction or base register was not recognized


Diagnostics 500 to 599

500 | Fatal Error xxxx at #### size ####: xxxx
501 | Non-Fatal Error zero data overflow: #### (signed) didn't fit in 23 bits, and could not be patched because the instruction or base register was not recognized
502 | Fatal Error unknown section xxxx used in ADDR
503 | Fatal Error expected ':' after conditional expression
504 | Fatal Error unknown section xxxx used in ALIGNOF
505 | Fatal Error Expected same block after inst
506 | Warning expression ignored for GNU linkmap generation
507 | Fatal Error while processing xxxx, expected 'xxxx'
508 | Fatal Error PACK_OR_ALIGN used outside of a section
509 | Fatal Error start of function expected
510 | Fatal Error dot was decremented in xxxx, from #### to ####
511 | Warning construct xxxx ignored for GNU linkmap generation
512 | Fatal Error expected expression after '('
513 | Non-Fatal Error Table call destination precedes call table
514 | Warning Alignment expression must be a power of two.
515 | Fatal Error start of basic block expected
516 | Fatal Error end of function without stack exit
517 | Fatal Error No instruction after inst
518 | Fatal Error memory segment xxxx not defined.
519 | Fatal Error expected an identifier
520 | Non-Fatal Error small data overflow: #### (signed) didn't fit in 16 bits, and could not be patched because the instruction or base register was not recognizedxxxx
521 | Non-Fatal Error jump table entry overflow in function xxxx in module xxxx at offset #### Please try recompiling with -bigswitch.
522 | Warning multiply destination registers cannot be the same in function xxxx in module xxxx at offset #### => xxxx
523 | Fatal Error jump table entry invalid in function xxxx in module xxxx at offset ####
524 | Non-Fatal Error ####-bit branch is out of range in function xxxx in module xxxx at offset #### => xxxx
525 | Warning multiply high destination register cannot be r0 in function xxxx in module xxxx at offset #### => xxxx
526 | Warning A branch becomes out of range by -fix_load_errata and has been expanded in function xxxx in module xxxx at offset #### => xxxx
527 | Fatal Error callt call to absolute index number in function xxxx in module xxxx at offset #### => xxxx Re-link with -v800_old_callt to avoid this error. See documentation on this option for more details.
528 | Warning Axxxx branch is followed by a load in function xxxx in module xxxx at offset #### => xxxx / xxxxxxxx
529 | Warning callt call to absolute index number in function xxxx in module xxxx at offset #### => xxxx Enabling -v800_old_callt compatibility mode. See documentation on this option for more details.
530 | Non-Fatal Error Unknown relocation type xxxx
531 | Warning PowerPC hazard found in function xxxx in module xxxx at offset #### => xxxx xxxx
532 | Non-Fatal Error xxxx incompatible with -record_timemachine, rebuild with -gen_timemachine
533 | Non-Fatal Error intercall from xxxx in module xxxx to xxxx cannot be patched
534 | Non-Fatal Error tracereg not always reserved in instrumented object xxxx.
535 | Non-Fatal Error calling convention mismatch for function xxxx: declared as xxxx in xxxx, called as xxxx in xxxx
536 | Non-Fatal Error Section xxxx overlaps section xxxx
537 | Non-Fatal Error Memory region xxxx overlaps region xxxx
538 | Non-Fatal Error In-Memory TimeMachine Warning In function xxxx at offset #### Unable to create instrumentation instruction.
539 | Non-Fatal Error symbol xxxx multiply defined in: xxxx xxxx
540 | Non-Fatal Error found fastcc and cdecl definitions for xxxx in: xxxx xxxx
541 | Non-Fatal Error entry symbol xxxx is undefined
542 | Warning entry symbol xxxx is undefined (allowed)
543 | Non-Fatal Error symbol xxxx is defined in xxxx and provided in xxxx; pass -overridden_absolute_allow to silence this message
545 | Warning bad argument types for function: declared as xxxx in xxxx, called as xxxx in xxxx
546 | Warning In OR/LOAD/XOR sequence, only OR can be branch destination.
547 | Warning LWC1 cannot be used. Please expand it to LW/MTC1.
548 | Warning R1 is used illegally in this instruction.
549 | Warning The destination register of the next instruction is the same as the base register of this instruction.
550 | Warning In LOAD/GSTM sequence, LOAD destination must match GSTM source.
551 | Warning Branch/jump must be to labeled address.
552 | Warning Load should not be in delay slot.
553 | Warning Only JALR is allowed for calls through a register.
554 | Warning In LDC1/FSTM sequence, the instruction following FSTM must be aligned to 4 mod 8 by 'xor r0, r0, r0'.
555 | Warning The destination register of this load instruction is the same as the base register. Please expand it into LOAD/XOR.
556 | Warning Branch destination must be aligned to 8 bytes.
557 | Warning JAXA hazard found with section xxxx in module xxxx Executable section contains no functions. Please verify that this is correct.
558 | Warning In LOAD/GSTM sequence, only LOAD can be branch destination.
559 | Warning JAXA hazard found with section xxxx in module xxxx at offset ####, size #### => Untyped, non-padding data in assembly module. Please check that this is not supposed to be a function, and use both .type and .size directives.
560 | Warning An index load instruction must be followed by 'bne r0, r0, .+4'.
561 | Warning OR/LDR/XOR must be aligned to 8 bytes.
562 | Warning And-link instruction requires 'xori r31, r31, 4' in the delay slot.
563 | Warning JAXA hazard found with section xxxx in module xxxx Cannot verify alignments mod 8, because section alignment is ####
564 | Warning The next instruction is the destination of a branch.
565 | Warning The next instruction is not a Basic load nor LDC1 with #offset(Rbase) operand.
566 | Warning This instruction must be aligned to 4 mod 8 by 'xor r0, r0, r0'.
567 | Warning In LW/MTC1 sequence, MTC1 must be aligned to 4 mod 8 by 'xor r0, r0, r0'.
568 | Warning NOP must be in the delay slot.
569 | Warning The next instruction is a branch destination.
570 | Warning Load instruction may not appear at end of function.
571 | Warning This unaligned load instruction is in bad sequence. Please expand it into OR/LOAD/XOR.
572 | Warning This instruction is prohibited.
573 | Warning Only JR r31 is allowed for subroutine return.
574 | Warning In LDC1/FSTM sequence, only LDC1 can be branch destination.
575 | Warning The next instruction is not a load with #offset(Rbase) operand.
576 | Warning In LW/MTC1 sequence, only LW can be branch destination.
577 | Fatal Error wrong number of symbols read from section #### in xxxx
578 | Warning Delay slot expected for this instruction at end of function.
579 | Warning In LOAD/XOR sequence, only LOAD can be branch destination.
580 | Non-Fatal Error MISRA xxxx: Function xxxx:xxxx is recursive
581 | Non-Fatal Error MISRA xxxx Rule xxxx forbids the use of "xxxx"
582 | Warning MISRA xxxx: Global variable xxxx:xxxx is referenced only from function xxxx:xxxx
583 | Non-Fatal Error MISRA xxxx: The following global symbols share a 31-character prefix:
584 | Warning MISRA xxxx: Global xxxx xxxx:xxxx is referenced only from module xxxx
585 | Non-Fatal Error MISRA xxxx: Common symbol xxxx in xxxx is overridden by a definition in xxxx
586 | Non-Fatal Error MISRA Rule #### forbids the use of "xxxx"
587 | Warning bad type for variable: defined as 'xxxx' in xxxx, used as 'xxxx' in xxxx
588 | Non-Fatal Error Unexpected character 'xxxx' in variable type-checking symbol 'xxxx'
589 | Fatal Error expected -globalcheck=none|normal|full
590 | Warning variable: 'xxxx' used in xxxx doesn't have a type checking declaration
591 | Warning Bad relocation sequence. R_MIPS_32 or R_MIPS_16 expected after R_MIPS_GHS_SUBPAIR. Got xxxx instead
592 | Warning individual section xxxx from xxxx contains symbol xxxx which does not match the individual section's symbol name
593 | Fatal Error cannot openxxxx file 'xxxx' (xxxx)
594 | Non-Fatal Error Relocation suggests data located in .text section but data-in-text is disabled
595 | Warning Global register written in kernel function: xxxx + #### (xxxx)
596 | Non-Fatal Error Global register written in non-kernel function: xxxx + #### (xxxx)
597 | Non-Fatal Error File error opening blacklist file xxxx; skipping blacklist
598 | Non-Fatal Error Blacklisted symbol xxxx defined in module xxxx
599 | Non-Fatal Error Blacklisted symbol xxxx referenced by module xxxx


Diagnostics 600 to 699

600 | Non-Fatal Error INTEGRITY TimeMachine does not support Thumb function:
601 | Non-Fatal Error Thumb mode cannot be used in this context
602 | Warning The program contains no reference to _tls_ctors. The following C++ thread local storage dynamic initialization routines will probably not get called: xxxx
603 | Fatal Error module xxxx has incompatible SDA_EXTRA_REGS count ####, should be ####
604 | Warning thread local storage section xxxx not defined
605 | Warning #### bytes of nops due to unsafe assembly
606 | Fatal Error Instruction using multiple relocations not supported with advanced linker optimizations.
607 | Fatal Error Instruction not supported with INTEGRITY TimeMachine
608 | Fatal Error Big switch table with align directive is not aligned in object file.
609 | Warning Assembly instruction using multiple relocations not supported with advanced linker optimizations.
610 | Non-Fatal Error Unknown INTEGRITY TimeMachine version in module xxxx (version ####).
611 | Fatal Error Tricore: section xxxx in module xxxx is too large to insert a farcall patch for function xxxx
612 | Warning The INTEGRITY TimeMachine atomic MFTB opcode is not set. Pass -C__ghs_itm_atomic_mftb_opcode=<opcode> to set it.
613 | Warning Linkonce symbol xxxx (from xxxx) is overridden by non-linkonce version from xxxx, but xxxx is not overridden
614 | Non-Fatal Error module xxxx was generated by a compiler with a version number greater than the version number of this elxr
615 | Fatal Error output file xxxx also specified as input file
616 | Warning unable to find function xxxx for ..lin label
617 | Warning unable to deconstruct "xxxx"
618 | Warning individual section xxxx from xxxx contains multiple symbols named xxxx
619 | Non-Fatal Error thread local storage is disabled, but .tls* sections are not empty.
621 | Warning __c_tls_offset symbol is referenced, but thread local storage is disabled.
622 | Warning imported module xxxx uses TLS data sections.
623 | Non-Fatal Error Reference to discarded linkonce section
624 | Warning function: xxxx has an argument type checking declaration in xxxx, but is never defined
625 | Warning min_p_align is larger than max_p_align (#### > ####)
626 | Warning min_p_align must be a power of two integer, not ####
627 | Warning max_p_align must be a power of two integer, not ####
628 | Warning RAM initialization not supported with PIC or PID.
629 | Non-Fatal Error incompatible ABI versions: xxxx in module xxxx vs xxxx in module xxxx
630 | Non-Fatal Error unrecognized cpu type: xxxx
631 | Non-Fatal Error incompatible machine flags in module xxxx: ####
632 | Fatal Error failed to read line #### ofxxxx file 'xxxx' (xxxx)
633 | Warning section xxxx can't be randomized
634 | Warning section xxxx(xxxx) marked as both sorted and randomized
635 | Non-Fatal Error imported symbol xxxx from executable section in image xxxx
636 | Warning symbol xxxx is provided in both xxxx and xxxx with address ####
637 | Non-Fatal Error symbol xxxx is provided in xxxx with address #### and xxxx with address ####
638 | Non-Fatal Error Maximum number of symbols supported by ELF32 (2^24) exceeded in output symbol table.
639 | Non-Fatal Error Maximum number of symbols supported by ELF64 (2^32) exceeded in output symbol table.
640 | Fatal Error start_expression for monotonic section xxxx places it outside memory_block list
641 | Fatal Error start_expression for monotonic section xxxx places it in block xxxx, swapping it with section(s) assigned to xxxx
642 | Fatal Error start_expression for section xxxx assigns it to block xxxx, swapping it across monotonic section(s)
643 | Fatal Error section xxxx cannot be assigned to any block without swapping across monotonic section(s)
645 | Non-Fatal Error Not applying -replace_rdtsc_to_int= to module xxxx (xxxx).
646 | Non-Fatal Error Error in parsing xxxx: Invalid range.
647 | Non-Fatal Error A 'movhi' instruction was shortened to a 'mov', but after farcall patching it is out of range. You may need to disable farcall patching (with -nofarcallpatch) or move shortening (with -no_shorten_moves). Inconsistency found
648 | Fatal Error unrecognized -variant argument
649 | Warning Preprocessor directive #xxxx found in file which is not being preprocessed
650 | Non-Fatal Error Not checking for non-replayable instructions in module xxxx (xxxx).
651 | Non-Fatal Error Encountered non-replayable xxxx instruction in function xxxx
652 | Non-Fatal Error xxxx incompatible with -record_replay, rebuild with -gen_replay
653 | Non-Fatal Error Unexpected farcall patch from xxxx to xxxx.
654 | Fatal Error Intercall patching not supported for prologue/epilogue snippets
655 | Non-Fatal Error mismatched ISA specification for module xxxx. Cannot merge 'i' and 'e' extensions.
656 | Non-Fatal Error incompatible embedded ABI (RVE) for module xxxx: xxxx vs xxxx in other modules
657 | Non-Fatal Error privileged spec version for module xxxx: ####.####.#### vs ####.####.#### in other modules
658 | Non-Fatal Error Error parsing arch attribute (xxxx) for module xxxx: xxxx
659 | Non-Fatal Error invalid data in xxxx section in xxxx
660 | Non-Fatal Error Unexpected architecture type for module xxxx. Must be RV32 or RV64
661 | Non-Fatal Error architecture type for module xxxx: xxxx vs xxxx in other modules
662 | Non-Fatal Error stack alignment for module xxxx: #### vs #### in other modules
663 | Non-Fatal Error incompatible floating-point ABI for module xxxx: xxxx vs xxxx in other modules
664 | Non-Fatal Error mismatched ISA extension version for 'xxxx' in module xxxx: ####.#### vs ####.#### in other modules
665 | Warning Straightline vulnerable assembly detected
667 | Fatal Error xxxx is not defined
668 | Non-Fatal Error ghtable with non-function xxxx and function xxxx
669 | Non-Fatal Error Cannot locate IFCC pair corresponding to xxxx
670 | Non-Fatal Error jump table entry overflow: try recompiling with -bigswitch in table entry at xxxx+#### from function xxxx in module xxxx
671 | Warning section xxxx couldn't be split across multiple memory blocks due to: xxxx
672 | Non-Fatal Error data overflow: #### didn't fit in #### bits in expression in module xxxx at xxxx+#### involving symbolxxxx
673 | Non-Fatal Error Unexpected symbol 'xxxx' encountered by block optimization
674 | Non-Fatal Error fixupprecf: unreachable branch in function xxxx in module xxxx at offset #### of section xxxx
675 | Non-Fatal Error Exceeded maximum number of faraddrs for -no_data_in_text
676 | Non-Fatal Error Not applying -replace_64bit_rdrand_to_int= to module xxxx (xxxx).
677 | Non-Fatal Error Not applying -replace_64bit_rdseed_to_int= to module xxxx (xxxx).
678 | Warning skipping rdrand replacement since it's not rdrand xxxx.
679 | Warning skipping rdseed replacement since it's not rdseed xxxx.
680 | Non-Fatal Error Relocation from xxxx + #### to xxxx + #### overlaps deleted symbol xxxx
681 | Non-Fatal Error xxxx incompatible with -indirect_function_call_checks due to relocation to xxxx
682 | Non-Fatal Error xxxx incompatible with -indirect_function_call_checks, rebuild with option enabled
683 | Non-Fatal Error section #### has multiple relocation sections in xxxx
684 | Non-Fatal Error symbol xxxx is malformed
685 | Non-Fatal Error Unconditional match section map content rule *(*) not supported.
686 | Non-Fatal Error Section xxxx needs to be padded but is not 2-byte aligned
688 | Fatal Error Unrecognized MIRROR block in memory declaration for xxxx


Assembler Diagnostic Messages

This chapter lists diagnostic messages that you may encounter when assembling code, listed by diagnostic number. Diagnostic message numbers will only appear for Power Architecture, ARM, RH850, and TriCore targets.


Assembler Diagnostic Message Codes

The following list contains all the assembler diagnostic messages:


Diagnostics 1 to 99

1 | Fatal Error Unrecognized option 'xxxx'
2 | Fatal Error COFF not supported for this configuration.
3 | Fatal Error Option 'xxxx' requires an argument of the form oldsect=newsect
4 | Fatal Error Invalid argument xxxx
5 | Fatal Error A source file must be specified.
6 | Fatal Error The assembler -globalreg check is not compatible with -tracereg.
7 | Fatal Error Invalid syntax for option 'xxxx'
8 | Fatal Error Argument xxxx too large
9 | Fatal Error diagnostic xxxx cannot be demoted to a warning
10 | Fatal Error xxxx is an invalid diagnostic number
11 | Fatal Error diagnostic xxxx cannot be suppressed
12 | Fatal Error out of memory
13 | Fatal Error syntax error
14 | Fatal Error constant required
15 | Fatal Error instruction not 16-bit aligned
16 | Fatal Error instruction not 32-bit aligned
17 | Fatal Error expected register r0-r7 or r24-r31
18 | Fatal Error use of global register
19 | Fatal Error displacement not 16-bit aligned
20 | Fatal Error expected floating point register
21 | Fatal Error expected condition register
22 | Warning VLE instruction in section not declared with "v" flag.
23 | Fatal Error expected register
25 | Fatal Error expected constant
26 | Fatal Error constant cannot be expressed as simple bitfield
27 | Fatal Error expected ','
28 | Fatal Error expected special purpose register
29 | Fatal Error displacement not 32-bit aligned
30 | Fatal Error expected vector register
31 | Fatal Error expected register r8-r23
32 | Fatal Error displacement must be in [-256,255]
33 | Fatal Error constant must be in [0,31]
34 | Fatal Error displacement must be in [-32768,32767]
35 | Fatal Error expected displacement
36 | Fatal Error constant must be in [0,2]
37 | Fatal Error n must be in [0,63]
38 | Fatal Error b must be in [0,63]
39 | Fatal Error constant must be in [-16,15]
40 | Fatal Error cannot branch this far
41 | Fatal Error (b+n) must be in [0,64]
42 | Fatal Error offset must be multiple of 4
43 | Fatal Error constant must be in [0,63]
44 | Fatal Error Internal assembler error
45 | Non-Fatal Error value not properly sign extended
46 | Fatal Error offset must be multiple of 8
47 | Fatal Error offset must be in [0,15])
48 | Fatal Error offset not word aligned
49 | Fatal Error offset must be multiple of 2
50 | Fatal Error offset must be in [-8192,8191]
51 | Fatal Error offset must be multiple of 4 and in [0,124]
52 | Fatal Error illegal VLE relocation
53 | Fatal Error constant must be in [1,64]
54 | Fatal Error expected base register r0-r7 or r24-r31
55 | Fatal Error offset must be in [0,30]
56 | Fatal Error constant must be in [0,3]
57 | Fatal Error offset must be multiple of 2 and in [0,62]
58 | Fatal Error expected TB or TBU
59 | Fatal Error offset not double aligned
60 | Fatal Error (b-n) must be in [0,31]
61 | Fatal Error offset not half-word aligned
62 | Fatal Error expected condition register cr0-3 only
63 | Fatal Error b-n must be in [0,63]
64 | Fatal Error constant must be in [0,64]
65 | Fatal Error n must be in [0,32]
66 | Fatal Error n must be in [1,32]
67 | Fatal Error constant must be in [0,255]
68 | Fatal Error la without .using
69 | Fatal Error b+n must be in [0,63]
70 | Fatal Error illegal relocation
71 | Fatal Error n must be in [0,7]
72 | Fatal Error expected segment register
73 | Fatal Error n must be in [0,64]
74 | Fatal Error constant must be in [-32768,65535]
75 | Fatal Error constant must be in [0,4]
76 | Fatal Error expected address
77 | Fatal Error constant must be 0 or 1
78 | Fatal Error constant must be in [-32767,32768]
79 | Fatal Error constant must be in [0,7]
80 | Fatal Error offset must be in [-2048,2047]
81 | Fatal Error expected 0 or 1
82 | Fatal Error constant must be in [0,15]
83 | Fatal Error (b+n) must be in [0,31]
84 | Fatal Error offset must be in [-32768,32767]
85 | Fatal Error expected TB (268) or TBU (269)
86 | Fatal Error offset must be multiple of 8 and in [0,248]
87 | Fatal Error Illegal TH value
88 | Fatal Error offset must be in [0,60]
89 | Fatal Error b must be in [0,31]
90 | Fatal Error L=1 invalid for 32-bit implemenation
91 | Fatal Error offset must be in [-128,127]
92 | Fatal Error expected 16-bit signed immediate
93 | Fatal Error expected SCI8 formated immediate
94 | Non-Fatal Error use of reserved trace register
95 | Fatal Error expected 20-bit signed immediate
96 | Fatal Error constant must be in [-524288,524287]
97 | Fatal Error expected 16-bit unsigned immediate
98 | Warning constant encoding requires sign extension
99 | Fatal Error .novle is not compatible with -convert_to_vle


Diagnostics 100 to 199

100 | Fatal Error INTEGRITY TimeMachine instrumentation error
101 | Fatal Error undefined temp label
102 | Fatal Error bad 387 register number
103 | Fatal Error no such temporary label
104 | Non-Fatal Error label must be in range 0..65535
105 | Fatal Error Expected =label
106 | Fatal Error Expected const shift count
107 | Fatal Error Illegal Binary Coded Decimal value
108 | Fatal Error Expected shift amount 2
109 | Fatal Error .equ symbol may not be redefined
111 | Fatal Error register name may not be reused as a label
112 | Fatal Error register name or other keyword may not be reused as a label
113 | Fatal Error multiply defined
114 | Fatal Error reference not addressable
115 | Fatal Error expected identifier
116 | Fatal Error value changed after use
117 | Fatal Error illegal assignment type change
118 | Fatal Error expected comma
119 | Fatal Error Cannot weak this
120 | Warning Symbol table cannot express a global symbol set to an undefined symbol
121 | Non-Fatal Error Expect a push to MIPS .set stack first
122 | Fatal Error weak symbol cannot be set to undefined symbol
123 | Fatal Error dot cannot decrease
124 | Non-Fatal Error Exceed maximum MIPS .set stack level
125 | Fatal Error common symbol cannot be redeclared local; use .lcomm instead
126 | Non-Fatal Error Expected .mips16 or its variants
127 | Fatal Error Missing scope number
128 | Non-Fatal Error Expected .set mips16 or its variants
129 | Fatal Error .export symbol not defined
130 | Fatal Error expected model name
131 | Fatal Error Cannot nest
132 | Fatal Error register names cannot be made external
133 | Fatal Error Missing line number
134 | Fatal Error label starting with "_" within .beginscope cannot be exported
135 | Fatal Error expected symbol
137 | Fatal Error Unmatched
138 | Fatal Error .tracereg_endnowarn not matched with prior .tracereg_nowarn
139 | Warning Currently, only the FLAT model is supported
140 | Fatal Error .import symbol was defined
142 | Fatal Error expected comment delimiter
143 | Fatal Error Missing function name
144 | Fatal Error expected new line
145 | Warning unsupported directive
146 | Non-Fatal Error Cannot declare symbol weak after definition
147 | Non-Fatal Error No output file name assigned
148 | Fatal Error expected immediate or label
149 | Non-Fatal Error Unsupported operator
150 | Warning Relocatable sym1-sym2 value may be incorrect after link-time function deletion
152 | Fatal Error negative relocation not allowed
153 | Fatal Error expect comma
155 | Non-Fatal Error unterminated .if
156 | Fatal Error Expected register
158 | Non-Fatal Error Subtract of symbols in different sections
160 | Fatal Error Expected , or }
161 | Non-Fatal Error unterminated comment directive
162 | Warning Couldn't open DBO file for patching
163 | Fatal Error Expected `]'
164 | Non-Fatal Error unterminated macro or repeat
165 | Fatal Error illegal addressing mode
167 | Warning Couldn't write to DBO file
170 | Non-Fatal Error negative offset for static symbol - may cause problems with software update
171 | Warning Couldn't load DBO file for patching
172 | Non-Fatal Error Error writing to object file.
174 | Non-Fatal Error unexpected end of line
175 | Fatal Error Expected shift operand
176 | Fatal Error First operand must be register
177 | Fatal Error Expected ']'
178 | Warning Unknown issue processing DBO file
179 | Fatal Error cannot convert undefined expr to register
180 | Warning Couldn't open DBO file for writing
181 | Non-Fatal Error Relocatable sym1-sym2 must have sym2 in current section
182 | Non-Fatal Error 16-bit offset exceeds 32k, possibly due to big switch statement (try -bigswitch)
183 | Fatal Error expected register or displacement
184 | Fatal Error '-' illegal for System Registers
185 | Fatal Error overflow
186 | Fatal Error Expected `)'
187 | Non-Fatal Error Couldn't add labels to symbol table in DBO file
188 | Fatal Error Expected general register
189 | Fatal Error alignment must be a power of two
190 | Fatal Error "type" relocations only allowed in tv modules
191 | Fatal Error Expecting comma
192 | Fatal Error .align X mod Y not allowed in special sections
193 | Fatal Error mismatched [] in macro parameter list
194 | Fatal Error undefined symbol used
195 | Fatal Error Branch cannot be expanded.
196 | Fatal Error invalid redeclaration of linkonce type
197 | Fatal Error non-void .scall directive used after void .scall directive
198 | Warning ignoring -g as assembly file originates from source file compiled with -g and .dbo file already exists
199 | Fatal Error exponent out of range


Diagnostics 200 to 299

200 | Fatal Error too many parameters
201 | Fatal Error unmatched conditional assembly directive
202 | Warning inexact decimal conversion
203 | Fatal Error too many type specifiers
204 | Fatal Error mismatched <> in macro parameter list
205 | Fatal Error mismatched () or [] in macro parameter list
206 | Fatal Error section attribute must be x, d, r, or b
207 | Fatal Error too many digits in BCD constant
208 | Fatal Error too many nested .include files
209 | Fatal Error expected hex digit
210 | Fatal Error missing ')', ']' or '>'
211 | Fatal Error illegal alignment boundary
212 | Fatal Error local symbol cannot be redeclared common; use .lcomm instead
213 | Fatal Error multiple maxstack values
214 | Fatal Error can't fixup coff symbol scnum
215 | Fatal Error expected end of line or ">" for address
216 | Fatal Error relocation macro illegal here
217 | Warning expected filename
218 | Fatal Error expected ']'
219 | Fatal Error Unable to open include file. Exiting.
220 | Fatal Error .maxstack must be used within scope of current function
221 | Fatal Error expected .align X mod Y
222 | Fatal Error The difference of two labels with an offset is not allowed
223 | Fatal Error multiple maxinstances values
224 | Fatal Error .section requires a quoted name
225 | Fatal Error constant must be in [1,3]
226 | Fatal Error .offset directive cannot decrease current offset
227 | Fatal Error type clash
228 | Fatal Error mismatched () in macro parameter list
229 | Fatal Error multiple hi1, lo, sdaoff, etc. per line not allowed
230 | Fatal Error missing single quote
231 | Fatal Error hex digit in decimal literal
232 | Fatal Error Expecting right parenthesis
233 | Fatal Error expected ", entsize"
234 | Fatal Error missing character constant
235 | Fatal Error newlines in string constant
236 | Warning output file not specified; using default filename
237 | Fatal Error .endx must match .macro/.rept and begin the line
238 | Fatal Error .frameinfo must start with .name
239 | Fatal Error wrong number of hex digits
240 | Warning coff directive specified but assembler is outputing ELF.
241 | Fatal Error bcd constant too large
242 | Fatal Error expected [:|,]
243 | Fatal Error bcd constant is NAN
244 | Fatal Error Too many sections
245 | Fatal Error expected end of line
246 | Warning elf directive specified but assembler is outputing COFF.
247 | Fatal Error float not allowed here
248 | Warning too many digits in mantissa
249 | Fatal Error .radix operand must be B, Q, D or H
250 | Fatal Error unrecognized @type annotation
251 | Fatal Error relocation incompatible with -torn
252 | Fatal Error bad numeric literal
253 | Fatal Error expected positive integer
254 | Fatal Error Expected constant
255 | Fatal Error range error
256 | Fatal Error hi/lo illegal here
257 | Fatal Error void .scall directive used after non-void .scall directive
258 | Fatal Error .fsize must be used within scope of current function
259 | Fatal Error expected comma followed by group name
260 | Fatal Error symbol previously defined
261 | Fatal Error expected group name
262 | Fatal Error include name too long
263 | Fatal Error relocation type not allowed
264 | Warning ignoring -g as assembly file originates from source file compiled with -g
265 | Fatal Error multiple fsize values
266 | Fatal Error expected name or 0
267 | Fatal Error Unknown directive
268 | Fatal Error .scall must be used within scope of current function
269 | Fatal Error bad section directive
270 | Fatal Error size out of range
271 | Fatal Error global not found in c_symnum()
273 | Fatal Error value must be in range 0..255
274 | Warning multiple text sections in one file; dwarf 1.1 debug information eliminated for this file
275 | Fatal Error no coff symbol created
276 | Fatal Error can't set coff symbol scnum
277 | Fatal Error Expected right parenthesis
278 | Fatal Error non zero fill value in .bss-like section
279 | Fatal Error too many COFF relocation table entries
280 | Warning -s0 not allowed with debug info generation; using -s1 instead
281 | Fatal Error expected "bss" or "data"
282 | Fatal Error line too complex
283 | Fatal Error bad size specification for hex constant
284 | Warning illegal octal digit
285 | Fatal Error bad @<val> to .type
286 | Fatal Error expected name
287 | Fatal Error invalid redeclaration of associated linkonce section
288 | Fatal Error division by 0
289 | Fatal Error expected section attributes
290 | Fatal Error recursive macro/rept loop
291 | Fatal Error Expected id
292 | Warning dc doesn't align odd-addressed data & labels. Precede it with align 2
293 | Fatal Error undefined fill value
294 | Warning include directory not specified
295 | Warning multiple text sections in one file; debug information eliminated for this file
296 | Warning immediate encoding requires change of sign
297 | Fatal Error invalid expression
298 | Warning section does not have allocation bit set
299 | Fatal Error .section attribute must be .text, .data, or .bss


Diagnostics 300 to 399

300 | Fatal Error fill not allowed in special sections
301 | Fatal Error relocatable space < 32 bits
302 | Fatal Error fill value out of range
303 | Warning artificial macro has incomplete reference info
304 | Fatal Error .exitm must be invoked inside a macro
305 | Fatal Error Invalid .set syntax
306 | Fatal Error recursive macro/rept loop recurses too deeply
308 | Fatal Error Could not find associated linkonce section
309 | Fatal Error Illegal redefinition of macro
310 | Fatal Error Variable expression not allowed here
311 | Fatal Error relocations of size other than 32 are not supported with COFF output
312 | Fatal Error bss segment phase error type 1
313 | Warning .fsize directive causing info specified by .frameinfo to be discarded
314 | Fatal Error bcd constant too small
315 | Fatal Error relocatable or undefined expression size != 32
316 | Fatal Error fail encountered
317 | Fatal Error relocation sizes other than 32 and 64 bits are not supported
318 | Fatal Error can't combine these types for addressing
319 | Fatal Error undefined byte count
320 | Fatal Error statement too complicated
321 | Fatal Error Expected left parenthesis
322 | Fatal Error expected macro name
323 | Fatal Error Expecting identifier
324 | Fatal Error bcd constant is too large
326 | Fatal Error .radix operand must be 2, 8, 10 or 16
327 | Fatal Error unterminated < in macro argument
328 | Fatal Error Size of section exceeds host memory limit
329 | Fatal Error wrong type
330 | Fatal Error ? operators are: ?i ?r ?c
331 | Fatal Error attempt to dump pool in wrong section
332 | Fatal Error Expected string
333 | Fatal Error hex constant too long
334 | Fatal Error c_symnum: null exref in rel entry
335 | Fatal Error unsupported target
336 | Fatal Error unknown section attribute
337 | Fatal Error macro parameter mismatch
338 | Fatal Error expected section flags
339 | Fatal Error unknown linkonce type
340 | Fatal Error .maxinstances must be used within scope of current function
341 | Fatal Error illegal redefinition of section attributes
342 | Fatal Error cannot insert negative-sized space
343 | Fatal Error unexpected parameter
344 | Fatal Error infinite .include loop
345 | Warning syntax is obsolete
346 | Fatal Error illegal >< concatenation operand
347 | Fatal Error special section not closed
348 | Fatal Error expected string
350 | Warning INTEGRITY TimeMachine instrumentation warning: xxxx
351 | Fatal Error Can't create builder information file: xxxx
352 | Non-Fatal Error INTEGRITY TimeMachine instrumentation error: xxxx
353 | Fatal Error Inconsistent operand types: xxxx and xxxx
354 | Fatal Error assignments involving xxxx not allowed
355 | Fatal Error xxxx undefined
356 | Fatal Error constant must be in [0,####]
357 | Fatal Error range error: immediate value xxxx does not fit in #### bits
358 | Fatal Error constant must be in [xxxx,xxxx]
359 | Fatal Error illegal character (####) 'xxxx'
361 | Non-Fatal Error Section xxxx is larger than xxxx bytes
362 | Fatal Error Expected ',' or 'xxxx'
364 | Warning overflow warning
365 | Fatal Error .error
366 | Warning .warning
367 | Fatal Error Assertion failed
368 | Fatal Error type clash, operator='xxxx'
369 | Fatal Error directive not supported without -asm3g option
370 | Fatal Error unable to write to temp file "xxxx"
371 | Fatal Error could not close dependencies file
372 | Fatal Error directive not supported by the current target configuration
373 | Fatal Error unknown object "xxxx"
374 | Fatal Error object "xxxx" does not have struct/class/union type
375 | Fatal Error struct "xxxx" has no field "xxxx"
376 | Fatal Error field "xxxx" in struct "xxxx" does not have struct/class/union type
377 | Fatal Error unable to process import file "xxxx"
378 | Fatal Error Could not convert, no equivalent VLE instruction exists
379 | Fatal Error Could not convert, operands are not compatible with any equivalent VLE instructions
380 | Non-Fatal Error reference to blacklisted symbol
381 | Non-Fatal Error definition of blacklisted symbol
382 | Fatal Error Expected id defined in module
383 | Fatal Error Invalid common alignment


Diagnostics 1000 to 1099

1000 | Fatal Error .localentry size must be a power of two between 1 and 16
1001 | Fatal Error multiple .seh_setframe directives for same proc
1002 | Fatal Error .seh directive in different section than .seh_proc
1003 | Fatal Error unrecognized reg in .seh directive
1004 | Fatal Error .seh_endproc expected
1005 | Fatal Error multiple .seh_endprologue directives for same proc
1006 | Fatal Error too many .seh unwind codes
1007 | Fatal Error .seh directive out of prologue offset range
1008 | Fatal Error .seh_beginproc missing or in different section than .seh_endproc
1009 | Fatal Error .seh_endprologue in different section than .seh_proc
1010 | Fatal Error .seh directives used in non-text section
1011 | Fatal Error bad value in .seh_stackalloc directive
1012 | Fatal Error .seh directives in COMDAT section with bad name
1013 | Fatal Error bad offset in .seh_setframe directive


Diagnostics 2000 to 2099

2002 | Fatal Error expected '}', ',' or '-' while parsing reglist
2003 | Fatal Error immediate constant expected
2004 | Fatal Error not within valid xxxx range
2005 | Fatal Error parameter cannot be r0 on this architecture
2006 | Fatal Error expected '{' at start of reglist
2009 | Fatal Error out of range
2011 | Fatal Error expected register while parsing reglist
2012 | Fatal Error illegal register for this reglist
2013 | Fatal Error comma expected
2014 | Fatal Error expected a xxxx
2015 | Fatal Error internal ease error: reghi > reglo+32
2016 | Fatal Error expected a replicated immediate with #### identical ####-bit values
2018 | Fatal Error expected an immediate with prefix 'xxxx'
2019 | Fatal Error xxxx constant or relocatable expected
2021 | Fatal Error expected least-significant bit to be zero
2022 | Fatal Error Out of range sub-data specification '####'
2023 | Fatal Error not within valid xxxx set
2024 | Fatal Error expected #### least-significant bits to be zero
2025 | Fatal Error unmatched text
2026 | Fatal Error expected substring "xxxx"
2027 | Fatal Error unexpected text before substring "xxxx"
2028 | Fatal Error numeric label not found
2029 | Fatal Error end-of-line expected
2030 | Fatal Error xxxx is an invalid diagnostic number
2032 | Non-Fatal Error reg3 cannot be r0 or the same as reg2
2033 | Non-Fatal Error Only one rh850_flags directive allowed
2034 | Non-Fatal Error bit instruction found
2035 | Non-Fatal Error Bad rh850_flag, ep(r30) is previously set to fixed
2036 | Non-Fatal Error Bad rh850_flag, double-precision is previously set to 32 bits
2037 | Non-Fatal Error Bad rh850_flag, FPU version is previously set to FPU2.0
2038 | Non-Fatal Error Bad rh850_flag, FPU version is previously set to FPU3.0
2040 | Non-Fatal Error Bad rh850_flag, r2 is previously set to reserved
2042 | Non-Fatal Error Bad rh850_flag, data alignment is previously set to 4 bytes
2043 | Warning unrecognized cpu type: xxxx
2044 | Non-Fatal Error Unrecognized rh850_flag
2045 | Non-Fatal Error Bad rh850_flag, register mode is previously set to 32
2046 | Non-Fatal Error Bad rh850_flag, data alignment is previously set to 8 bytes
2047 | Non-Fatal Error Bad rh850_flag, gp(r4) is previously set to non-fixed
2048 | Non-Fatal Error Bad rh850_flag, FXU is disabled
2049 | Non-Fatal Error Bad rh850_flag, tp(r5) is previously set to fixed
2050 | Non-Fatal Error Bad rh850_flag, tp(r5) is previously set to non-fixed
2051 | Non-Fatal Error Bad rh850_flag, SIMD is disabled
2052 | Non-Fatal Error Bad rh850_flag, FPU is disabled
2053 | Non-Fatal Error Bad rh850_flag, ep(r30) is previously set to non-fixed
2054 | Non-Fatal Error Bad rh850_flag, gp(r4) is previously set to fixed
2055 | Non-Fatal Error Bad rh850_flag, r2 is previously set to non-reserved
2056 | Non-Fatal Error Bad rh850_flag, register mode is previously set to 22
2057 | Non-Fatal Error Bad rh850_flag, double-precision is disabled
2058 | Warning cpu already set, ignoring option: -cpu=xxxx
2059 | Non-Fatal Error Bad rh850_flag, double-precision is previously set to 64 bits
2060 | Fatal Error no files to assemble. Use -help for help
2061 | Non-Fatal Error Could not read comment file xxxx
2062 | Warning cannot redirect stderr to xxxx
2063 | Fatal Error expected a macro invocation
2064 | Warning Couldn't open DBO file for writing Unable to open a file containing Green Hills debugging information for writing in order to patch in additional information from the assembler.
2065 | Fatal Error instruction unsupported in this context
2066 | Warning Couldn't load DBO file for patching A problem occurred when loading a file containing Green Hills debugging information in order to patch in additional information from the assembler.
2067 | Fatal Error unknown instruction
2068 | Fatal Error no default value to macro parameter
2069 | Warning Couldn't open DBO file for patching Unable to open a file containing Green Hills debugging information for reading in order to patch in additional information from the assembler.
2070 | Warning Couldn't write to DBO file A problem occurred when writing a file containing Green Hills debugging information after patching in additional information from the assembler.
2071 | Fatal Error bad parameter
2072 | Fatal Error label multiply defined
2073 | Warning unknown option: xxxx
2074 | Warning Unknown issue processing DBO file An unknown problem occurred while processing a file containing Green Hills debugging information in order to patch in additional information from the assembler. This warning is not currently given.
2075 | Fatal Error can't concatenate here
2076 | Non-Fatal Error Couldn't add labels to symbol table in DBO file A problem occurred while patching addition information from the assembler into a file containing Green Hills debugging information.
2077 | Fatal Error diagnostic xxxx cannot be suppressed
2078 | Fatal Error diagnostic xxxx cannot be demoted to a warning
2079 | Fatal Error gen_fopen() error on file "xxxx" in INCBIN directive
2080 | Fatal Error fseek()/ftell() error on file "xxxx" in INCBIN directive
2081 | Fatal Error fread() error on file "xxxx" in INCBIN directive
2082 | Non-Fatal Error assertion failed at line ####
2083 | Fatal Error info: xxxx
2084 | Non-Fatal Error jtentry data does not fit in halfword
2085 | Fatal Error line ####: invalid newline within symbol
2086 | Fatal Error line ####: invalid semicolon within symbol
2087 | Fatal Error -PD must be preceded by -armuk The -armuk option must be specified on the command line before options that declare and set ARM UK Assembler Predefines. This error is specific to the ARM target architecture.
2088 | Fatal Error -PD: unable to find SET[A|S|L] directive in 'xxxx'
2089 | Non-Fatal Error Arm UK macro parameters must start with '$'
2093 | Fatal Error expected ')' in parameter list
2094 | Fatal Error EOF unexpected
2095 | Fatal Error cannot find file xxxx
2096 | Fatal Error Too many ELF sections
2097 | Non-Fatal Error illegal redefinition of non-label symbol xxxx
2098 | Fatal Error write to ELF file failed
2099 | Non-Fatal Error missing dependency information in do_dependency_file()


Diagnostics 2100 to 2199

2100

Non-Fatal Error

multiple fsize values for xxxx

2101

Non-Fatal Error

multiple maxstack values for xxxx

2102

Non-Fatal Error

multiple maxinstances values for xxxx

2103

Fatal Error

xxxx illegal here

2105

Fatal Error

invalid rotated immediate

2106

Fatal Error

Use of reserved trace register

2107

Fatal Error

destination registers are equal

2108

Fatal Error

Writeback not permitted for store multiple of user registers

2109

Fatal Error

Writeback not permitted for load multiple of user registers not including PC

2110

Fatal Error

expected a register

2111

Warning

INTEGRITY TimeMachine instrumentation warning (line ####): code outside function; instrumentation suppressed

2112

Warning

unrecognized fpu type: xxxx

2113

Warning

invalid eflags value: xxxx

2114

Warning

AREA both CODE and READWRITE: creating nonstandard .text section with WRITE flag

2115

Warning

OPT: unsupported option(s) set

2116

Fatal Error

Store multiple of base register with writeback may have unpredictable results

2117

Fatal Error

Load multiple of base register with writeback may have unpredictable results

2118

Fatal Error

Thumb2 load/store multiple with fewer than 2 registers in mask may have unpredictable results

2119

Warning

apcs options used only under -armuk flag

The -armuk option must be specified on the command line before -apcs= options that set the values of simulated ARM Ltd. internal variables. This error is specific to the ARM target architecture.

2120

Warning

-apcs parameter 'xxxx' unrecognized at position xxxx

2121

Warning

Arm UK macro parameters: one token only, read as string

Encountered more than one token for the value of an ARM UK macro parameter. This error is specific to the ARM target architecture.

2122

Warning

frame address <reg>,<offset>: not supported

2123

Warning

frame address <reg>: not supported

2124

Warning

frame pop <integer>: not supported

2125

Warning

frame pop {<registers>}: not supported

2126

Warning

frame push <integer>: not supported

2127

Warning

frame push {<registers>}: not supported

2128

Warning

frame register: not supported

2129

Warning

frame restore: not supported

2130

Warning

frame save: not supported

2131

Warning

frame state remember: not supported

2132

Warning

frame state restore: not supported

2133

Warning

require8: not supported

2134

Warning

preserve8: not supported

2135

Warning

entry: not supported

2136

Warning

section xxxx has been assigned multiple types (old:#### new:####)

2137

Warning

cannot create .inf file

2138

Warning

Instruction length exceeds maximum for source-line debug info

The number of bytes of machine code associated with a particular instruction exceeds the limit for what can be represented in the source line table of the debugging information.

2139

Warning

ignoring -g as assembly file originates from source file compiled with -g and .dbo file already exists

The assembler is not generating debugging information for a source file because it detected symbols in that file that indicate the compiler has already generated the information and the associated file containing the information is known to exist.

2140

Warning

ignoring -g as assembly file originates from source file compiled with -g

The assembler is not generating debugging information for a source file because it detected symbols in that file that indicate the compiler has already generated the information.

2141

Warning

.fsize directive causing info specified by .frameinfo to be discarded

2142

Warning

use of deprecated .hidemacro. This feature will be removed shortly!!!

2143

Warning

questionable assignment of pointer value to "xxxx" field

2144

Warning

questionable assignment of non-zero integer value to "xxxx" field

2145

Warning

Ignoring unknown section attribute

2146

Warning

Truncating to -1

2147

Non-Fatal Error

.thumb1 not supported with this configuration

2148

Non-Fatal Error

.thumb2 not supported with this configuration

2149

Non-Fatal Error

.nothumb not supported with this configuration

2150

Non-Fatal Error

invalid aligned-data directive

2151

Non-Fatal Error

AREA cannot be both READONLY and READWRITE

2152

Non-Fatal Error

AREA cannot be both CODE and DATA

2153

Non-Fatal Error

AREA both CODE and NOINIT not supported

2154

Non-Fatal Error

AREA both READONLY and NOINIT not supported

2155

Non-Fatal Error

expected string or constant expression

2156

Non-Fatal Error

bad expression

2157

Non-Fatal Error

expected [WEAK]

2158

Non-Fatal Error

invalid symbol

2159

Non-Fatal Error

Too late to ban floating point instructions

A directive was used to disable the use of floating-point instructions after at least one such instruction had already been seen.

2160

Non-Fatal Error

invalid parameter (0 <= OPT parameter < 65536)

2161

Non-Fatal Error

unmatched preprocessor directive

2162

Non-Fatal Error

invalid ARM renaming directive

2163

Non-Fatal Error

invalid register

2164

Non-Fatal Error

jtdispatch only supported in V4 and above

2165

Non-Fatal Error

register out of bounds

2166

Non-Fatal Error

no jtentry table after previous/only jtdispatch

2167

Non-Fatal Error

jtdispatch: invalid parameter(s)

2168

Non-Fatal Error

label has been previously defined

2169

Non-Fatal Error

symbol may not be equated to expression using dot operator

2170

Non-Fatal Error

attempt to redefine to a different value

2173

Non-Fatal Error

unsupported directive

2174

Non-Fatal Error

no corresponding jtentry lines with data

2175

Non-Fatal Error

bad/no corresponding jtdispatch

2176

Fatal Error

cannot find file "xxxx" referenced in INCBIN directive

2177

Non-Fatal Error

Overlapping IT instructions

2178

Non-Fatal Error

Invalid condition code

2179

Fatal Error

unexpected token type (xxxx) encountered; expected type (xxxx)

2180

Non-Fatal Error

undeclared substituted variable

2181

Non-Fatal Error

Invalid 0-length variable ($ at end of id/string)

2182

Non-Fatal Error

Invalid substituted variable (or $ in id/string)

2183

Non-Fatal Error

local label outside any routine or area scope

2184

Non-Fatal Error

local label routine-name mismatches current routine

2185

Non-Fatal Error

invalid local label (post-first-pass)

2186

Non-Fatal Error

local label must begin with a number (after '%' and flags)

2187

Non-Fatal Error

local label ref outside routine or area scope

2188

Non-Fatal Error

local label ref routine-name mismatches current routine

2189

Non-Fatal Error

local label not found

2190

Non-Fatal Error

Cannot mix Arm UK and GHS macro syntax in the same file.

2191

Non-Fatal Error

Arm UK-style label parameters to macros must start with $

2192

Non-Fatal Error

function/proc directive must be preceded by a label

2193

Non-Fatal Error

cannot nest function/proc directives

2194

Non-Fatal Error

no corresponding function/proc directive

2195

Non-Fatal Error

frame directive must be within proc/endp directives

2196

Non-Fatal Error

expected number or register list

2197

Non-Fatal Error

expected register list

2198

Non-Fatal Error

invalid frame state operation

2199

Non-Fatal Error

invalid frame operation


Diagnostics 2200 to 2299

2200 | Non-Fatal Error ROUT: may only be preceded by a label
2201 | Non-Fatal Error MAP directive expected absolute or section-relative parameter
2202 | Non-Fatal Error MAP directive expected register as second parameter
2203 | Non-Fatal Error MAP directive: register-base cannot have section-relative offset
2204 | Non-Fatal Error FIELD directive without MAP directive
2205 | Fatal Error cannot find file "xxxx" referenced in .inspect directive
2207 | Non-Fatal Error a variable and an EQU definition cannot share names
2208 | Non-Fatal Error undeclared variable
2209 | Non-Fatal Error type mismatch
2210 | Non-Fatal Error unterminated string constant
2211 | Non-Fatal Error non-void .scall directive used after void .scall directive Encountered a .scall directive indicating that a function makes a static call after an earlier directive indicated that the same function makes no calls.
2212 | Non-Fatal Error void .scall directive used after non-void .scall directive Encountered a .scall directive indicating that a function makes no static calls after an earlier directive indicated that the same function makes at least one call.
2213 | Non-Fatal Error section stack empty
2214 | Non-Fatal Error illegal macro redefinition
2215 | Non-Fatal Error label parameters to macros not supported
2216 | Non-Fatal Error default values for macro parameters not supported Default values for macro parameters are not supported when not in -armuk mode. This error is specific to the ARM target architecture.
2217 | Non-Fatal Error Only one use of .macronextline per macro allowed
2218 | Non-Fatal Error expected .assert constant_expr [, "message"]
2219 | Non-Fatal Error unexpected .else
2220 | Non-Fatal Error unexpected .elseif
2221 | Non-Fatal Error macro doesn't exist
2222 | Non-Fatal Error illegal redefinition
2223 | Non-Fatal Error .radix operand must be B, Q, D, or H
2224 | Non-Fatal Error expected filename in quotes
2225 | Non-Fatal Error expected comma or end-of-line
2226 | Non-Fatal Error expected struct type name followed by variable name
2227 | Non-Fatal Error Expected struct keyword
2228 | Non-Fatal Error Expected struct name in .extern struct
2229 | Non-Fatal Error Expected struct variable name in .extern struct
2230 | Non-Fatal Error bad directive This error is given in various cases where a supported assembler directive is used incorrectly. See the documentation for the offending directive for information about its proper usage and syntax.
2231 | Non-Fatal Error label undefined
2232 | Non-Fatal Error expected 'mod'
2233 | Non-Fatal Error expected 0..31
2234 | Non-Fatal Error unknown type
2235 | Non-Fatal Error do not allow nested .dsect blocks
2236 | Non-Fatal Error unexpected in .dsect block
2237 | Non-Fatal Error Cannot set global symbol to RHS not defined in this file
2238 | Non-Fatal Error RHS must be defined in this file
2239 | Non-Fatal Error Expected 32-bit value
2240 | Non-Fatal Error Failed to find function name for .fsize Unable to match a .fsize directive to a specific function. Only happens on targets where the function is not a required argument to the directive.
2241 | Non-Fatal Error Failed to find source function name for .scall Unable to match a .scall directive to a specific function. Only happens on targets where the caller is not a required argument to the directive.
2242 | Non-Fatal Error Cannot nest
2243 | Non-Fatal Error Not allowed inside of a macro
2244 | Non-Fatal Error Line number too large
2245 | Non-Fatal Error Scope number too large
2246 | Non-Fatal Error Unmatched directive
2247 | Non-Fatal Error Value too large
2248 | Non-Fatal Error unhandled directive
2249 | Non-Fatal Error syntax error in sizeof() expression
2250 | Non-Fatal Error syntax error in offsetof() expression
2251 | Fatal Error expected expression
2252 | Fatal Error expected absolute expression
2253 | Fatal Error expected constant expression
2254 | Fatal Error expected boolean expression
2255 | Fatal Error expected string expression
2256 | Fatal Error the predicate parser failed
2257 | Non-Fatal Error numeric/temporary labels are obsolete use .macrolocal instead or pass -temporary_labels for transition mode support
2258 | Non-Fatal Error initializer data overlaps
2259 | Non-Fatal Error A value of type "xxxx" cannot be used to initialize a field of type "xxxx"
2260 | Non-Fatal Error more initializers than array elements
2261 | Non-Fatal Error expected ',' or '}' in array initializer
2262 | Non-Fatal Error expected at least one initializer in array initializer
2263 | Non-Fatal Error struct/class/union "xxxx" has no field "xxxx"
2264 | Non-Fatal Error field name must be specified after nested field designator is used
2265 | Non-Fatal Error too many field initializer values
2266 | Non-Fatal Error bitfields cannot be initialized The assembler does not currently support initializing bitfields in .struct directives.
2267 | Non-Fatal Error expected ',' or '}' in struct initializer
2268 | Non-Fatal Error string literal cannot initialize a field of type "xxxx"
2269 | Non-Fatal Error aggregate initializer expected
2270 | Non-Fatal Error floating point fields cannot be initialized The assembler does not currently support initializing floating-point fields in .struct directives.
2271 | Non-Fatal Error cannot initialize field of "xxxx" type with pointer value
2272 | Non-Fatal Error cannot initialize field of "xxxx" type with value of "int" type
2273 | Non-Fatal Error unable to initialize field to that integer type Encountered an initializer in a .struct directive for an integer type whose size is not 1, 2, 4, or 8 bytes.
2274 | Non-Fatal Error syntax error in initializer
2275 | Non-Fatal Error expected array initializer
2276 | Non-Fatal Error redefinition of "xxxx" as "struct xxxx", previously "struct xxxx"
2277 | Non-Fatal Error unknown struct "xxxx"
2278 | Non-Fatal Error name "xxxx" refers to type "xxxx", not a struct/class/union type
2279 | Non-Fatal Error syntax error in field selection
2280 | Non-Fatal Error left hand side of field selection operator is a type, not a variable
2281 | Non-Fatal Error could not create label
2282 | Non-Fatal Error syntax error in array length expression
2283 | Non-Fatal Error expected struct initializer or ';'
2284 | Non-Fatal Error initializer required when unspecified-length array is declared
2285 | Non-Fatal Error relocatable expected
2286 | Fatal Error different numbers of macro parameter names and values
2287 | Fatal Error symbol table too large The symbol table contains too many entries to be written in the ELF file format.
2288 | Fatal Error Offset of section name in string table must fit in 32 bits
2289 | Fatal Error unknown construct encountered Encountered a construct that was not recognized as a legal directive, macro, label, or instruction.
2290 | Fatal Error unable to create dir "xxxx" for source listing
2291 | Fatal Error more tokens expected
2292 | Fatal Error can't parse pool expression
2293 | Fatal Error unexpected tokens after ldr <register>,=<expression> pseudoinstruction
2294 | Fatal Error can't evaluate pool expression
2295 | Non-Fatal Error directive not supported without -asm3g option
2296 | Non-Fatal Error directive not supported by the current target configuration
2297 | Non-Fatal Error unable to process import file "xxxx"
2298 | Non-Fatal Error unable to write to temp file "xxxx" A problem occurred while attempting to write to a temporary file as part of handling a .inspect directive.
2299 | Non-Fatal Error could not close dependencies file


Diagnostics 2300 to 2399

2300 | Non-Fatal Error unknown object "xxxx"
2301 | Non-Fatal Error struct "xxxx" has no field "xxxx"
2302 | Non-Fatal Error object "xxxx" does not have struct/class/union type
2303 | Non-Fatal Error field "xxxx" in struct "xxxx" does not have struct/class/union type
2304 | Fatal Error failed to open file: xxxx
2305 | Non-Fatal Error xxxx ####: memory address (0x####) exceeded the maximum available address (0x####)
2306 | Warning unrecognized output format: xxxx
2307 | Fatal Error relocation of address counter to (0x####) overwrites previously assembled results
2308 | Fatal Error address counter relocation (0x####) not multiples of 4
2309 | Warning include file not specified for .cinclude
2310 | Non-Fatal Error bad width, must be less than or equal to instruction width, which is 32
2311 | Fatal Error address counter relocation not multpiles of 4
2312 | Non-Fatal Error the expression value cannot be represented by 32 bits
2313 | Non-Fatal Error cannot overwrite a previously defined label or variable
2314 | Fatal Error relocation of address counter overwrites previously assembled results
2315 | Non-Fatal Error character not allowed in an option
2316 | Non-Fatal Error the .cmdline directive is only allowed as a first statement of the source file
2317 | Non-Fatal Error cannot overwrite a previously defined label
2318 | Non-Fatal Error the expression value cannot be represented within the specified width
2319 | Non-Fatal Error cannot overwrite a register symbol
2320 | Warning .warning
2321 | Non-Fatal Error .error
2322 | Non-Fatal Error File error opening blacklist file xxxx; skipping blacklist
2323 | Non-Fatal Error Blacklisted symbol xxxx is referenced
2324 | Non-Fatal Error Blacklisted symbol xxxx is declared
2325 | Non-Fatal Error INTEGRITY TimeMachine instrumentation: difference of two labels not allowed
2326 | Non-Fatal Error INTEGRITY TimeMachine instrumentation (line ####): unsupported instruction
2327 | Non-Fatal Error mismatched parentheses
2328 | Fatal Error couldn't open file xxxx
2329 | Fatal Error Unable to create dir "xxxx" for header file
2330 | Non-Fatal Error Explicit S-bit instruction used in IT block
2331 | Non-Fatal Error .ghsnote version must be at least 19 when setting the GP_FIX, GP_NONFIX, EP_FIX, EP_NONFIX, TP_FIX, TP_NONFIX, REG2_RESERVE, or REG2_NONRESERVE RH850 flags
2332 | Fatal Error matching register is undefined
2333 | Warning DWARF generation not supported for assembly files originating from source files compiled with -g
2334 | Non-Fatal Error .offset directive cannot decrease current offset
2335 | Fatal Error expected '-' while parsing entry ID range
2336 | Warning expected eID1 <= eID2
2337 | Fatal Error expected an entry ID in the format eN (0<=N<=31)
2338 | Non-Fatal Error macro recursion maximum depth exceeded
2339 | Non-Fatal Error replay not enabled
2340 | Non-Fatal Error .rplinst overflow
2341 | Non-Fatal Error .norplinst not matched with .rplinst
2342 | Non-Fatal Error option stack empty
2343 | Warning unknown option directive
2344 | Warning unrecognized abi type: xxxx
2345 | Fatal Error RISC-V architecture must be specified with -riscv_arch
2346 | Warning unknown attribute name
2347 | Non-Fatal Error expression is too complicated
2348 | Fatal Error 16-bit offset out of range, possible due to big switch statement (try -bigswitch)
2349 | Non-Fatal Error Bad argument to xxxx
2350 | Warning DWARFv1 generation not supported; doing DWARFv2 instead
2352 | Warning Deprecated syntax


MULTI: Toolchain Error Messages and Other Diagnostics

Green Hills Software

LEGAL NOTICES AND DISCLAIMERS