Vector.MenuPlugin Namespace

[image]

Vector.MenuPlugin API documentation
Vector.MenuPlugin Namespace

Interfaces

Interface | Description
IMenuItem | IMenuItem represents a menu item. A menu item might have further child menu items.
IMenuPlugin | IMenuPlugin is the initial interface that must be implemented. The implementing class must provide a default constructor. This constructor is called during CANalyzer/CANoe startup.


IMenuItem Interface

[image]

Vector.MenuPlugin API documentation
IMenuItem Interface
Members See Also
IMenuItem represents a menu item. A menu item might have further child menu items.

Namespace: Vector.MenuPlugin
Assembly: Vector.MenuPlugin (in Vector.MenuPlugin)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public interface IMenuItem
Visual Basic (Declaration)
Public Interface IMenuItem
Visual C++
public interface class IMenuItem

See Also

IMenuItem Members
Vector.MenuPlugin Namespace


IMenuItem Members

[image] [image]

Vector.MenuPlugin API documentation
IMenuItem Members
IMenuItem Interface Properties See Also

The IMenuItem type exposes the following members.

Properties

Name | Description
Checked | Indicates if the menu item is checked.
Enabled | Indicates if the menu item is enabled.
SubMenuItems | The collection of sub menu items of the current item.
Text | The text that is displayed for the menu item.

See Also

IMenuItem Interface


IMenuItem Properties

[image] [image]

Vector.MenuPlugin API documentation
IMenuItem Properties
IMenuItem Interface See Also

The IMenuItem type exposes the following properties.

Properties

Name | Description
Checked | Indicates if the menu item is checked.
Enabled | Indicates if the menu item is enabled.
SubMenuItems | The collection of sub menu items of the current item.
Text | The text that is displayed for the menu item.

See Also

IMenuItem Interface


Checked Property

[image]

Vector.MenuPlugin API documentation
IMenuItem..::.Checked Property
IMenuItem Interface See Also
Indicates if the menu item is checked.

Namespace: Vector.MenuPlugin
Assembly: Vector.MenuPlugin (in Vector.MenuPlugin)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
bool Checked { get; }
Visual Basic (Declaration)
ReadOnly Property Checked As Boolean
Visual C++
property bool Checked {
    bool get ();
}

See Also

IMenuItem Interface


Enabled Property

[image]

Vector.MenuPlugin API documentation
IMenuItem..::.Enabled Property
IMenuItem Interface See Also
Indicates if the menu item is enabled.

Namespace: Vector.MenuPlugin
Assembly: Vector.MenuPlugin (in Vector.MenuPlugin)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
bool Enabled { get; }
Visual Basic (Declaration)
ReadOnly Property Enabled As Boolean
Visual C++
property bool Enabled {
    bool get ();
}

See Also

IMenuItem Interface


SubMenuItems Property

[image]

Vector.MenuPlugin API documentation
IMenuItem..::.SubMenuItems Property
IMenuItem Interface See Also
The collection of sub menu items of the current item.

Namespace: Vector.MenuPlugin
Assembly: Vector.MenuPlugin (in Vector.MenuPlugin)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
IList<IMenuItem> SubMenuItems { get; }
Visual Basic (Declaration)
ReadOnly Property SubMenuItems As IList(Of IMenuItem)
Visual C++
property IList<IMenuItem^>^ SubMenuItems {
    IList<IMenuItem^>^ get ();
}

See Also

IMenuItem Interface


Text Property

[image]

Vector.MenuPlugin API documentation
IMenuItem..::.Text Property
IMenuItem Interface See Also
The text that is displayed for the menu item.

Namespace: Vector.MenuPlugin
Assembly: Vector.MenuPlugin (in Vector.MenuPlugin)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
string Text { get; }
Visual Basic (Declaration)
ReadOnly Property Text As String
Visual C++
property String^ Text {
    String^ get ();
}

See Also

IMenuItem Interface


IMenuPlugin Interface

[image]

Vector.MenuPlugin API documentation
IMenuPlugin Interface
Members See Also
IMenuPlugin is the initial interface that must be implemented. The implementing class must provide a default constructor. This constructor is called during CANalyzer/CANoe startup.

Namespace: Vector.MenuPlugin
Assembly: Vector.MenuPlugin (in Vector.MenuPlugin)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public interface IMenuPlugin
Visual Basic (Declaration)
Public Interface IMenuPlugin
Visual C++
public interface class IMenuPlugin

See Also

IMenuPlugin Members


IMenuPlugin Members

[image] [image]

Vector.MenuPlugin API documentation
IMenuPlugin Members
IMenuPlugin Interface Methods Properties See Also

The IMenuPlugin type exposes the following members.

Methods

Name | Description
ItemClicked | Notification when a menu item was clicked.

Properties

Name | Description
MenuItems | The collection of menu items that are displayed. Note: This collection is requested on every popup of the main menu item.
Text | The text that is displayed for the menu item in the main menu bar.

See Also

IMenuPlugin Interface


IMenuPlugin Methods

[image] [image]

Vector.MenuPlugin API documentation
IMenuPlugin Methods
IMenuPlugin Interface See Also

The IMenuPlugin type exposes the following methods.

Methods

Name | Description
ItemClicked | Notification when a menu item was clicked.

See Also

IMenuPlugin Interface


ItemClicked Method

[image]

Vector.MenuPlugin API documentation
IMenuPlugin..::.ItemClicked Method
IMenuPlugin Interface See Also
Notification when a menu item was clicked.

Namespace: Vector.MenuPlugin
Assembly: Vector.MenuPlugin (in Vector.MenuPlugin)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
void ItemClicked(
    IMenuItem clickedItem
)
Visual Basic (Declaration)
Sub ItemClicked ( _
    clickedItem As IMenuItem _
)
Visual C++
void ItemClicked(
    IMenuItem^ clickedItem
)

Parameters

clickedItem
Type: Vector.MenuPlugin..::.IMenuItem
The clicked menu item.

See Also

IMenuPlugin Interface


IMenuPlugin Properties

[image] [image]

Vector.MenuPlugin API documentation
IMenuPlugin Properties
IMenuPlugin Interface See Also

The IMenuPlugin type exposes the following properties.

Properties

Name | Description
MenuItems | The collection of menu items that are displayed. Note: This collection is requested on every popup of the main menu item.
Text | The text that is displayed for the menu item in the main menu bar.

See Also

IMenuPlugin Interface


MenuItems Property

[image]

Vector.MenuPlugin API documentation
IMenuPlugin..::.MenuItems Property
IMenuPlugin Interface See Also
The collection of menu items that are displayed. Note: This collection is requested on every popup of the main menu item.

Namespace: Vector.MenuPlugin
Assembly: Vector.MenuPlugin (in Vector.MenuPlugin)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
IList<IMenuItem> MenuItems { get; }
Visual Basic (Declaration)
ReadOnly Property MenuItems As IList(Of IMenuItem)
Visual C++
property IList<IMenuItem^>^ MenuItems {
    IList<IMenuItem^>^ get ();
}

See Also

IMenuPlugin Interface


Text Property

[image]

Vector.MenuPlugin API documentation
IMenuPlugin..::.Text Property
IMenuPlugin Interface See Also
The text that is displayed for the menu item in the main menu bar.

Namespace: Vector.MenuPlugin
Assembly: Vector.MenuPlugin (in Vector.MenuPlugin)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
string Text { get; }
Visual Basic (Declaration)
ReadOnly Property Text As String
Visual C++
property String^ Text {
    String^ get ();
}

See Also

IMenuPlugin Interface