Vector.Diagnostics Namespace

Vector Diagnostic Scripting Library
Vector.Diagnostics Namespace
Classes
 | Class | Description
Public class | Application | The Application is the starting point for each script. The Application class has access to the loaded ECUs of the scripting host via the application 'environment' (i.e. CANape, CANoe, etc.; e.g. Write window, CANape device or CANoe target, ...).
Public class | DiagnosticException | The exception that is thrown when the conversion of a parameter value fails.
 | Ecu | The ECU represents a diagnostics server. Each ECU references a diagnostics database that defines the diagnostics services. Within the application the communication channel is configured to allow access to the ECU via a network.
Public class | Parameter | Represents a parameter of a message (request/response).
Public class | ParameterCollection | Provide a strongly typed collection for Parameters
 | Request | Provides a diagnostic request message.
Public class | RequestCollection | Provide a strongly typed collection for Requests.
 | Response | Provides a diagnostic response message.
Public class | SendResult | The result of the service communication transaction. Contains the transaction status (e.g. error state) and the response object if available.
Public class | Value | To access a parameter's value.
Enumerations
 | Enumeration | Description
Public enumeration | ExceptionType | Defines constants that are used by the DiagnosticException class
Public enumeration | GenerateSecurityKeyResult | Result of the GenerateSecurityKey(Ecu, Byte, Byte, String, Byte) method that contains information whether the key could be generated using a seed and key dll.
Public enumeration | ResponseStatus | A response's detailed status.
Public enumeration | SecurityAccessResult | Contains the result of unlock an ECU using Unlock(Byte) and Unlock(Byte, String).
Public enumeration | SendStatus | The request transmission result states.
Public enumeration | VariantSelectionResult | The result of a call to SelectVariant(String).
Public enumeration | WaitResult | The result codes of a waiting operation.

(C) 2008-2013 Vector Informatik GmbH


Application Class

Application Class
The Application is the starting point for each script. The Application class has access to the loaded ECUs of the scripting host via the application 'environment' (i.e. CANape, CANoe, etc.; e.g. Write window, CANape device or CANoe target, ...).
Inheritance Hierarchy
SystemObject
Vector.DiagnosticsApplication

Namespace: Vector.Diagnostics
Assembly: Vector.Diagnostics (in Vector.Diagnostics.dll) Version: 5.4 Beta2
Syntax
C#
VB
Copy
public static class Application
Public NotInheritable Class Application

The Application type exposes the following members.

Methods
Name | Description
GenerateSecurityKey | Generates the security key.
GetEcu | Get access to the ECU that is provided (by the application) for the current execution context.
GetEcu(String) | Gets the ECU with the given qualifier.
GetEcuByLogicalLink | Get access to the ECU for the given logical link
Top
See Also

Reference

Vector.Diagnostics Namespace


Application Methods

Application Methods

The Application type exposes the following members.

Methods
Name | Description
GenerateSecurityKey | Generates the security key.
GetEcu | Get access to the ECU that is provided (by the application) for the current execution context.
GetEcu(String) | Gets the ECU with the given qualifier.
GetEcuByLogicalLink | Get access to the ECU for the given logical link
Top
See Also

Reference

Application Class


Application.GenerateSecurityKey Method

ApplicationGenerateSecurityKey Method
Generates the security key.

Namespace: Vector.Diagnostics
Assembly: Vector.Diagnostics (in Vector.Diagnostics.dll) Version: 5.4 Beta2
Syntax
C#
VB
Copy
public static GenerateSecurityKeyResult GenerateSecurityKey(
    Ecu ecu,
    byte[] seed,
    byte securityLevel,
    string option,
    out byte[] key
)
Public Shared Function GenerateSecurityKey (
    ecu As Ecu,
    seed As Byte(),
    securityLevel As Byte,
    option As String,
    <OutAttribute> ByRef key As Byte()
) As GenerateSecurityKeyResult

Parameters

ecu
Type: Vector.DiagnosticsEcu
The ECU where the seed and key dll is configured.
seed
Type: SystemByte
The seed from the ECU.
securityLevel
Type: SystemByte
The security level.
option
Type: SystemString
The option string. Set Empty if no option string is provided.
key
Type: SystemByte
The generated key as output parameter.

Return Value

Type: GenerateSecurityKeyResult
Success if the key was generated without an error.
Remarks
The ECU variant (Variant) is passed to the seed and key dll.
Examples
Unlocking an ECU using the GenerateSecurityKey(Ecu, Byte, Byte, String, Byte) method. If you do not have to provide additional parameters except the security level then use Unlock(Byte) or Unlock(Byte, String) which provides a more convenient API.
Copy
public void GeneratingKeyForEcuAndUnlockEcuInLevel1()
{
    // Get the first ECU
    Ecu ecu = Application.GetEcu();

    // Create request for requesting the seed in level 0x01
    Request requestSeedRequest = ecu.CreateRequest(new byte[] { 0x27, 0x01 });
    SendResult sendResult = requestSeedRequest.Send();
    if (sendResult.Status != SendStatus.Ok)
    {
        Output.WriteLine("Error sending request seed: " + sendResult.Status);
        return;
    }

    // Extract the seed from the response of $27 01
    byte[] requestSeedResponsePdu = sendResult.Response.Pdu;
    byte[] seed = new byte[requestSeedResponsePdu.Length - 2];
    Array.Copy(requestSeedResponsePdu, 2, seed, 0, seed.Length);

    // Generate the key on the current using the extracted seed in level 1 without option strings
    byte[] key;
    GenerateSecurityKeyResult generateSecurityKeyResult = Application.GenerateSecurityKey(ecu, seed, 1, string.Empty, out key);
    if (generateSecurityKeyResult != GenerateSecurityKeyResult.Success)
    {
        Output.WriteLine("Error generating key from seed (" + BitConverter.ToString(seed) + "): " + generateSecurityKeyResult);
        return;
    }

    // Create request for sending the key
    byte[] sendKeyPdu = new byte[key.Length + 2];
    sendKeyPdu[0] = 0x27;
    sendKeyPdu[1] = 0x02;
    Array.Copy(key, 0, sendKeyPdu, 2, key.Length);

    // Try to unlock the ECU by sending the key
    Request requestSendKey = ecu.CreateRequest(sendKeyPdu);
    SendResult sendKeySendResult = requestSendKey.Send();
    if (sendKeySendResult.Status != SendStatus.Ok)
    {
        Output.WriteLine("Error sending key (" + BitConverter.ToString(key) + "): " + sendKeySendResult.Status);
        return;
    }

    // Check for positive response (= successful) or negative response code
    if (!sendKeySendResult.Response.IsPositive)
    {
        Output.WriteLine("Unlocking ECU with key failed with an NRC. Response: " + BitConverter.ToString(sendKeySendResult.Response.Pdu));
        return;
    }

    // Enter stuff to be executed on an unlocked ECU.
}
See Also

Reference

Application Class
Vector.Diagnostics Namespace
EcuUnlock(Byte)
EcuUnlock(Byte, String)


Application.GetEcu Method

ApplicationGetEcu Method
Overload List
Name | Description
GetEcu | Get access to the ECU that is provided (by the application) for the current execution context.
GetEcu(String) | Gets the ECU with the given qualifier.
Top
See Also

Reference

Application Class


Application.GetEcu Method

ApplicationGetEcu Method
Get access to the ECU that is provided (by the application) for the current execution context.

Namespace: Vector.Diagnostics
Assembly: Vector.Diagnostics (in Vector.Diagnostics.dll) Version: 5.4 Beta2
Syntax
C#
VB
Copy
public static Ecu GetEcu()
Public Shared Function GetEcu As Ecu

Return Value

Type: Ecu
The Ecu object if there is one defined for the current execution context, null otherwise.
See Also

Reference

Application Class
GetEcu Overload


Application.GetEcu Method (String)

ApplicationGetEcu Method (String)
Gets the ECU with the given qualifier.

Namespace: Vector.Diagnostics
Assembly: Vector.Diagnostics (in Vector.Diagnostics.dll) Version: 5.4 Beta2
Syntax
C#
VB
Copy
public static Ecu GetEcu(
    string ecuQualifier
)
Public Shared Function GetEcu (
    ecuQualifier As String
) As Ecu

Parameters

ecuQualifier
Type: SystemString
The unique ECU identification string.

Return Value

Type: Ecu
The ECU object if it exists, null otherwise.
Remarks
NOTES: This method enables access to an already configured ECU of the host application. (The configuration includes the variant selection.) A qualifier can be assigned to an ECU in the application (e.g. in CANoe, CANape), therefore there is no guarantee that different applications know the ECU under the same qualifier.
Examples
This example shows how to get an ECU by an ecu identifier, create a request, and retrieve a parameter from that request.
Copy
public void ApplicationSample()
{
  // Using the ECU with the qualifier "MyECU"
  Ecu myEcu = Application.GetEcu("MyECU");

  // Creating a request using the service qualifier
  Request request1 = myEcu.CreateRequest("Software_Version_Read");

  // Alternative: create a request using a PDU specified as raw byte stream
  Request request2 = myEcu.CreateRequest(new byte[] { 0x10, 0x03 });

  // Get a parameter from the request
  Parameter parameter = request1.GetParameter("My_Param");
}
See Also

Reference

Application Class
GetEcu Overload


Application.GetEcuByLogicalLink Method

ApplicationGetEcuByLogicalLink Method
Get access to the ECU for the given logical link

Namespace: Vector.Diagnostics
Assembly: Vector.Diagnostics (in Vector.Diagnostics.dll) Version: 5.4 Beta2
Syntax
C#
VB
Copy
public static Ecu GetEcuByLogicalLink(
    string logicalLink
)
Public Shared Function GetEcuByLogicalLink (
    logicalLink As String
) As Ecu

Parameters

logicalLink
Type: SystemString
Logical link qualifier

Return Value

Type: Ecu
The ECU object if it exists, null otherwise.
See Also

Reference

Application Class


DiagnosticException Class

DiagnosticException Class
The exception that is thrown when the conversion of a parameter value fails.
Inheritance Hierarchy
SystemObject
SystemException
SystemApplicationException
Vector.DiagnosticsDiagnosticException

Namespace: Vector.Diagnostics
Assembly: Vector.Diagnostics (in Vector.Diagnostics.dll) Version: 5.4 Beta2
Syntax
C#
VB
Copy
[SerializableAttribute]
public class DiagnosticException : ApplicationException
<SerializableAttribute>
Public Class DiagnosticException
    Inherits ApplicationException

The DiagnosticException type exposes the following members.

Constructors
 | Name | Description
Public method | DiagnosticException | Initializes a new instance of the DiagnosticException class.
Public method | DiagnosticException(String) | Initializes a new instance of the DiagnosticException class.
Public method | DiagnosticException(ExceptionType) | Initializes a new instance of the DiagnosticException class with an ExceptionType.
Protected method | DiagnosticException(SerializationInfo, StreamingContext) | Initializes a new instance of the DiagnosticException class.
Public method | DiagnosticException(String, Exception) | Initializes a new instance of the DiagnosticException class.
Top
Methods
 | Name | Description
Public method | GetObjectData | Sets the SerializationInfo with information about the exception. (Overrides ExceptionGetObjectData(SerializationInfo, StreamingContext).)
Public method | ToString | Returns the string representation of the current instance. (Overrides ExceptionToString.)
Top
Properties
 | Name | Description
Public property | Type | Information about the DiagnosticException.
Top
See Also

Reference

Vector.Diagnostics Namespace

(C) 2008-2013 Vector Informatik GmbH


DiagnosticException Constructor

DiagnosticException Constructor
Overload List
 | Name | Description
Public method | DiagnosticException | Initializes a new instance of the DiagnosticException class.
Public method | DiagnosticException(String) | Initializes a new instance of the DiagnosticException class.
Public method | DiagnosticException(ExceptionType) | Initializes a new instance of the DiagnosticException class with an ExceptionType.
Protected method | DiagnosticException(SerializationInfo, StreamingContext) | Initializes a new instance of the DiagnosticException class.
Public method | DiagnosticException(String, Exception) | Initializes a new instance of the DiagnosticException class.
Top
See Also

Reference

DiagnosticException Class


DiagnosticException Constructor

DiagnosticException Constructor
Initializes a new instance of the DiagnosticException class.

Namespace: Vector.Diagnostics
Assembly: Vector.Diagnostics (in Vector.Diagnostics.dll) Version: 5.4 Beta2
Syntax
C#
VB
Copy
public DiagnosticException()
Public Sub New
See Also

Reference

DiagnosticException Class
DiagnosticException Overload


DiagnosticException Constructor (String)

DiagnosticException Constructor (String)
Initializes a new instance of the DiagnosticException class.

Namespace: Vector.Diagnostics
Assembly: Vector.Diagnostics (in Vector.Diagnostics.dll) Version: 5.4 Beta2
Syntax
C#
VB
Copy
public DiagnosticException(
    string message
)
Public Sub New (
    message As String
)

Parameters

message
Type: SystemString
The exception message.
See Also

Reference

DiagnosticException Class
DiagnosticException Overload


DiagnosticException Constructor (ExceptionType)

DiagnosticException Constructor (ExceptionType)
Initializes a new instance of the DiagnosticException class with an ExceptionType.

Namespace: Vector.Diagnostics
Assembly: Vector.Diagnostics (in Vector.Diagnostics.dll) Version: 5.4 Beta2
Syntax
C#
VB
Copy
public DiagnosticException(
    ExceptionType exceptionType
)
Public Sub New (
    exceptionType As ExceptionType
)

Parameters

exceptionType
Type: Vector.DiagnosticsExceptionType
Type of the exception (e.g. illegal value conversion)
See Also

Reference

DiagnosticException Class
DiagnosticException Overload


DiagnosticException Constructor (SerializationInfo, StreamingContext)

DiagnosticException Constructor (SerializationInfo, StreamingContext)
Initializes a new instance of the DiagnosticException class.

Namespace: Vector.Diagnostics
Assembly: Vector.Diagnostics (in Vector.Diagnostics.dll) Version: 5.4 Beta2
Syntax
C#
VB
Copy
protected DiagnosticException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The object that holds the serialized object data.
context
Type: System.Runtime.SerializationStreamingContext
The contextual information about the source or destination.
See Also

Reference

DiagnosticException Class
DiagnosticException Overload


DiagnosticException Constructor (String, Exception)

DiagnosticException Constructor (String, Exception)
Initializes a new instance of the DiagnosticException class.

Namespace: Vector.Diagnostics
Assembly: Vector.Diagnostics (in Vector.Diagnostics.dll) Version: 5.4 Beta2
Syntax
C#
VB
Copy
public DiagnosticException(
    string message,
    Exception innerException
)
Public Sub New (
    message As String,
    innerException As Exception
)

Parameters

message
Type: SystemString
The exception message.
innerException
Type: SystemException
The inner exception.
See Also

Reference

DiagnosticException Class
DiagnosticException Overload


DiagnosticException Methods

DiagnosticException Methods

The DiagnosticException type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Sets the SerializationInfo with information about the exception. (Overrides ExceptionGetObjectData(SerializationInfo, StreamingContext).)
Public method | ToString | Returns the string representation of the current instance. (Overrides ExceptionToString.)
Top
See Also

Reference

DiagnosticException Class


DiagnosticException.GetObjectData Method

DiagnosticExceptionGetObjectData Method
Sets the SerializationInfo with information about the exception.

Namespace: Vector.Diagnostics
Assembly: Vector.Diagnostics (in Vector.Diagnostics.dll) Version: 5.4 Beta2
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
Type: System.Runtime.SerializationStreamingContext
The StreamingContext that contains contextual information about the source or destination.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
_ExceptionGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
ArgumentNullException | info
See Also

Reference

DiagnosticException Class


DiagnosticException.ToString Method

DiagnosticExceptionToString Method
Returns the string representation of the current instance.

Namespace: Vector.Diagnostics
Assembly: Vector.Diagnostics (in Vector.Diagnostics.dll) Version: 5.4 Beta2
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
The string representation of the current instance.

Implements

_ExceptionToString
See Also

Reference

DiagnosticException Class


DiagnosticException Properties

DiagnosticException Properties

The DiagnosticException type exposes the following members.

Properties
 | Name | Description
Public property | Type | Information about the DiagnosticException.
Top
See Also

Reference

DiagnosticException Class


DiagnosticException.Type Property

DiagnosticExceptionType Property
Information about the DiagnosticException.

Namespace: Vector.Diagnostics
Assembly: Vector.Diagnostics (in Vector.Diagnostics.dll) Version: 5.4 Beta2
Syntax
C#
VB
Copy
public ExceptionType Type { get; }
Public ReadOnly Property Type As ExceptionType
    Get

Property Value

Type: ExceptionType
See Also

Reference

DiagnosticException Class


Ecu Class

Ecu Class
The ECU represents a diagnostics server. Each ECU references a diagnostics database that defines the diagnostics services. Within the application the communication channel is configured to allow access to the ECU via a network.
Inheritance Hierarchy
SystemObject
Vector.DiagnosticsEcu

Namespace: Vector.Diagnostics
Assembly: Vector.Diagnostics (in Vector.Diagnostics.dll) Version: 5.4 Beta2
Syntax
C#
VB
Copy
public sealed class Ecu : IDisposable
Public NotInheritable Class Ecu
    Implements IDisposable

The Ecu type exposes the following members.

Methods
 | Name | Description
 | ActivateTesterPresent | Activates (or deactivates) the periodic sending of the tester present request message by the application.
Public method | Close | Invalidate ECU and its hierarchy; free resources.
 | CreateRequest(Byte) | Create a request using raw bytes as PDU.
 | CreateRequest(String) | Create a request using the service qualifier.
 | CreateRequestsBySemantic | Creates requests using the supplied semantic.
Public method | Dispose | Free resources allocated for this message. Call this method when the message is no longer used.
Protected method | Finalize | Finalizes an instance of the Ecu class. (Overrides ObjectFinalize.)
Public method | IdentifyAndSelectVariant | Identify and select ECU variant and give the variant qualifier back.
Public method | IdentifyVariant | IdentifyVariant returns the qualifier of the identified ECU variant.
Public method | IsTesterPresentActive | Get the current tester present sending state.
Public method | SelectVariant | Selects the ECU variant by its qualifier. In case an empty string is passed to SelectVariant it shall return VariantSelectionResult.VariantDoesNotExist.
Public method | ToString | Get the ECU identification name. (Overrides ObjectToString.)
 | Unlock(Byte) | Unlocks the ECU in the specified level.
Public method | Unlock(Byte, String) | Unlocks the ECU in the specified level using an additional option string.
Top
Properties
 | Name | Description
Public property | IsDisposed | Gets a value indicating whether the current instance was disposed.
Public property | Name | Gets the name of the current ECU.
Public property | Qualifier | Gets the unique ECU identifier.
Public property | Variant | Gets the qualifier of the current ECU variant.
Top
Remarks
The ECU has to be configured in the host application.
Remarks
The resources that are held for messages (requests and responses) have to be cleared after the according objects will not be accessed any more. This has to be done by calling the Dispose() method of such objects or by using the the C# 'using' statement. To assure that all (of the possibly multiple) responses of a service communication transaction are cleared, call the Dispose() method of the SendResult object.
Examples
The following example shows how to get an ECU, change the session to extended session and activate sending TesterPresent messages to stay in the extended session.
Copy
public void EcuSampleScript()
{
  // Use the ECU currently selected by the Application
  Ecu myEcu = Application.GetEcu();

  // Create a request using a raw byte stream as PDU.
  using(Request request = myEcu.CreateRequest(new byte[] { 0x10, 0x03 }))
  {
    // With the C# 'using' keyword one can define a scope,
    // outside of which an object will automatically be disposed.

    // Send the request to the ECU and wait for a response
    using(SendResult result = request.Send())
    {
      // Check if the message transmission was successful
      if (result.Status == SendStatus.Ok)
      {
        // Get the response from the send result
        // Caution: the response might be null
        Response response = result.Response;

        // Check if the ECU sent a positive response
        if (response.IsPositive)
        {
            // Activate sending TesterPresent messages
            myEcu.ActivateTesterPresent(true);
        }
      }
    }
  }
}
See Also

Reference

Vector.Diagnostics Namespace

(C) 2008-2013 Vector Informatik GmbH


Ecu Methods

Ecu Methods

The Ecu type exposes the following members.

Methods
 | Name | Description
 | ActivateTesterPresent | Activates (or deactivates) the periodic sending of the tester present request message by the application.
Public method | Close | Invalidate ECU and its hierarchy; free resources.
 | CreateRequest(Byte) | Create a request using raw bytes as PDU.
 | CreateRequest(String) | Create a request using the service qualifier.
 | CreateRequestsBySemantic | Creates requests using the supplied semantic.
Public method | Dispose | Free resources allocated for this message. Call this method when the message is no longer used.
Protected method | Finalize | Finalizes an instance of the Ecu class. (Overrides ObjectFinalize.)
Public method | IdentifyAndSelectVariant | Identify and select ECU variant and give the variant qualifier back.
Public method | IdentifyVariant | IdentifyVariant returns the qualifier of the identified ECU variant.
Public method | IsTesterPresentActive | Get the current tester present sending state.
Public method | SelectVariant | Selects the ECU variant by its qualifier. In case an empty string is passed to SelectVariant it shall return VariantSelectionResult.VariantDoesNotExist.
Public method | ToString | Get the ECU identification name. (Overrides ObjectToString.)
 | Unlock(Byte) | Unlocks the ECU in the specified level.
Public method | Unlock(Byte, String) | Unlocks the ECU in the specified level using an additional option string.
Top
See Also

Reference

Ecu Class


Ecu.ActivateTesterPresent Method

EcuActivateTesterPresent Method
Activates (or deactivates) the periodic sending of the tester present request message by the application.

Namespace: Vector.Diagnostics
Assembly: Vector.Diagnostics (in Vector.Diagnostics.dll) Version: 5.4 Beta2
Syntax
C#
VB
Copy
public bool ActivateTesterPresent(
    bool activateTP
)
Public Function ActivateTesterPresent (
    activateTP As Boolean
) As Boolean

Parameters

activateTP
Type: SystemBoolean
true: activate tester present; false: deactivate tester present

Return Value

Type: Boolean
False if action failed.

Return Value

Type: Boolean
False if action failed.
Exceptions
Exception | Condition
ObjectDisposedException | Throws an ObjectDisposedException when the instance was disposed.
Examples
The following example shows how to get an ECU, change the session to extended session and activate sending TesterPresent messages to stay in the extended session.
Copy
public void EcuSampleScript()
{
  // Use the ECU currently selected by the Application
  Ecu myEcu = Application.GetEcu();

  // Create a request specifying the service qualifier
  Request request = myEcu.CreateRequest("Extended_Session_Start");

  // Send the request to the ECU and wait for a response
  SendResult result = request.Send();

  // Check if the request transmission was successful
  if (result.Status == SendStatus.Ok)
  {
    // Get the response from the send result
    // Caution: the response might be null
    Response response = result.Response;

    // Check if the ECU sent a positive response
    if (response.IsPositive)
    {
      // Activate sending TesterPresent messages
      myEcu.ActivateTesterPresent(true);
    }
  }

  // The resources that are held for messages (requests and responses) have to be cleared
  // when the according objects will not be accessed any more. This has to be done by calling
  // the Dispose() method of such objects or by the C# 'using' statement.
  request.Dispose();
  result.Dispose();
}
See Also

Reference

Ecu Class


Ecu.Close Method

EcuClose Method
Invalidate ECU and its hierarchy; free resources.

Namespace: Vector.Diagnostics
Assembly: Vector.Diagnostics (in Vector.Diagnostics.dll) Version: 5.4 Beta2
Syntax
C#
VB
Copy
public void Close()
Public Sub Close
Remarks
Called by Dispose. Request and Request instances assigned to this ECU are not valid anymore.
See Also

Reference

Ecu Class


Ecu.CreateRequest Method

EcuCreateRequest Method
Overload List
Name | Description
CreateRequest(Byte) | Create a request using raw bytes as PDU.
CreateRequest(String) | Create a request using the service qualifier.
Top
See Also

Reference

Ecu Class


Ecu.CreateRequest Method (Byte[])

EcuCreateRequest Method (Byte)
Create a request using raw bytes as PDU.

Namespace: Vector.Diagnostics
Assembly: Vector.Diagnostics (in Vector.Diagnostics.dll) Version: 5.4 Beta2
Syntax
C#
VB
Copy
public Request CreateRequest(
    byte[] bytes
)
Public Function CreateRequest (
    bytes As Byte()
) As Request

Parameters

bytes
Type: SystemByte
Byte array containing the PDU.

Return Value

Type: Request
The request object.
Exceptions
Exception | Condition
ObjectDisposedException | Throws an ObjectDisposedException when the instance was disposed.
Examples
This example shows how to create a new request based on a PDU.
Copy
// Use the ECU currently selected by the Application
Ecu myEcu = Application.GetEcu();

// Create a request using raw bytes as PDU
using(Request request = myEcu.CreateRequest(new byte[] { 0x10, 0x03 }))
{
  // ...
}
// The resources that are held for messages (requests and responses) have to be
// cleared after the according objects will not be accessed any more.
// This has to be done by calling the Dispose() method of such objects or by the C# 'using' statement.
See Also

Reference

Ecu Class
CreateRequest Overload


Ecu.CreateRequest Method (String)

EcuCreateRequest Method (String)
Create a request using the service qualifier.

Namespace: Vector.Diagnostics
Assembly: Vector.Diagnostics (in Vector.Diagnostics.dll) Version: 5.4 Beta2
Syntax
C#
VB
Copy
public Request CreateRequest(
    string serviceQualifier
)
Public Function CreateRequest (
    serviceQualifier As String
) As Request

Parameters

serviceQualifier
Type: SystemString
The qualifier of the service.

Return Value

Type: Request
The request object with the given qualifier. Returns null if no service with given qualifier is available.
Exceptions
Exception | Condition
ObjectDisposedException | Throws an ObjectDisposedException when the instance was disposed.
Examples
This example shows how to create a new request based on the service qualifier.
Copy
public void EcuSampleScript()
{
  // Use the ECU currently selected by the Application
  Ecu myEcu = Application.GetEcu();

  // Create a request using the service qualifier
  using(Request request = myEcu.CreateRequest("Software_Version_Read"))
  {
    // ...
  }
  // The resources that are held for messages (requests and responses) have to be
  // cleared after the according objects will not be accessed any more.
  // This has to be done by calling the Dispose() method of such objects or by the C# 'using' statement.
}
See Also

Reference

Ecu Class
CreateRequest Overload


Ecu.CreateRequestsBySemantic Method

EcuCreateRequestsBySemantic Method
Creates requests using the supplied semantic.

Namespace: Vector.Diagnostics
Assembly: Vector.Diagnostics (in Vector.Diagnostics.dll) Version: 5.4 Beta2
Syntax
C#
VB
Copy
public RequestCollection CreateRequestsBySemantic(
    string semantic
)
Public Function CreateRequestsBySemantic (
    semantic As String
) As RequestCollection

Parameters

semantic
Type: SystemString
The semantic of the service.

Return Value

Type: RequestCollection
A collection of requests with the supplied semantic. The collection is always initialized, but can be empty.
Exceptions
Exception | Condition
ObjectDisposedException | Throws an ObjectDisposedException when the instance was disposed.
Examples
This example shows how to create a request based on a given semantic.
Copy
public void EcuSampleScript()
{
  // Use the ECU currently selected by the Application
  Ecu myEcu = Application.GetEcu();

  // Create a request using a semantic
  using(RequestCollection requests = myEcu.CreateRequestsBySemantic("FAULTREAD"))
  {
    if(requests.Count > 0)
    {
      ...
    }
  }
}
See Also

Reference

Ecu Class


Ecu.Dispose Method

EcuDispose Method
Free resources allocated for this message. Call this method when the message is no longer used.

Namespace: Vector.Diagnostics
Assembly: Vector.Diagnostics (in Vector.Diagnostics.dll) Version: 5.4 Beta2
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
See Also

Reference

Ecu Class


Ecu.Finalize Method

EcuFinalize Method
Finalizes an instance of the Ecu class.

Namespace: Vector.Diagnostics
Assembly: Vector.Diagnostics (in Vector.Diagnostics.dll) Version: 5.4 Beta2
Syntax
C#
VB
Copy
protected override void Finalize()
Protected Overrides Sub Finalize
See Also

Reference

Ecu Class


Ecu.IdentifyAndSelectVariant Method

EcuIdentifyAndSelectVariant Method
Identify and select ECU variant and give the variant qualifier back.

Namespace: Vector.Diagnostics
Assembly: Vector.Diagnostics (in Vector.Diagnostics.dll) Version: 5.4 Beta2
Syntax
C#
VB
Copy
public string IdentifyAndSelectVariant()
Public Function IdentifyAndSelectVariant As String

Field Value

Type: String
The qualifier of the ECU variant.

Return Value

Type: String
If the selection of the variant was successfully the variant qualifier is returned.
Exceptions
Exception | Condition
ObjectDisposedException | Throws an ObjectDisposedException when the instance was disposed.
Remarks
Start the variant identification and selection.
See Also

Reference

Ecu Class


Ecu.IdentifyVariant Method

EcuIdentifyVariant Method
IdentifyVariant returns the qualifier of the identified ECU variant.

Namespace: Vector.Diagnostics
Assembly: Vector.Diagnostics (in Vector.Diagnostics.dll) Version: 5.4 Beta2
Syntax
C#
VB
Copy
public string IdentifyVariant()
Public Function IdentifyVariant As String

Return Value

Type: String
The qualifier of the identified variant if successful, otherwise an empty string.
Exceptions
Exception | Condition
ObjectDisposedException | Throws an ObjectDisposedException when the instance was disposed.
See Also

Reference

Ecu Class


Ecu.IsTesterPresentActive Method

EcuIsTesterPresentActive Method
Get the current tester present sending state.

Namespace: Vector.Diagnostics
Assembly: Vector.Diagnostics (in Vector.Diagnostics.dll) Version: 5.4 Beta2
Syntax
C#
VB
Copy
public bool IsTesterPresentActive()
Public Function IsTesterPresentActive As Boolean

Return Value

Type: Boolean
true: application sends tester present periodically; false: tester present off or the state couldn't be retrieved
Exceptions
Exception | Condition
ObjectDisposedException | Throws an ObjectDisposedException when the instance was disposed.
See Also

Reference

Ecu Class


Ecu.SelectVariant Method

EcuSelectVariant Method
Selects the ECU variant by its qualifier. In case an empty string is passed to SelectVariant it shall return VariantSelectionResult.VariantDoesNotExist.

Namespace: Vector.Diagnostics
Assembly: Vector.Diagnostics (in Vector.Diagnostics.dll) Version: 5.4 Beta2
Syntax
C#
VB
Copy
public VariantSelectionResult SelectVariant(
    string qualifier
)
Public Function SelectVariant (
    qualifier As String
) As VariantSelectionResult

Parameters

qualifier
Type: SystemString
The qualifier of the variant that is selected.

Return Value

Type: VariantSelectionResult
The appropriate VariantSelectionResult.
Exceptions
Exception | Condition
ObjectDisposedException | Throws an ObjectDisposedException when the instance was disposed.
See Also

Reference

Ecu Class


Ecu.ToString Method

EcuToString Method
Get the ECU identification name.

Namespace: Vector.Diagnostics
Assembly: Vector.Diagnostics (in Vector.Diagnostics.dll) Version: 5.4 Beta2
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
Identifier of the ECU
See Also

Reference

Ecu Class


Ecu.Unlock Method

EcuUnlock Method
Overload List
 | Name | Description
 | Unlock(Byte) | Unlocks the ECU in the specified level.
Public method | Unlock(Byte, String) | Unlocks the ECU in the specified level using an additional option string.
Top
See Also

Reference

Ecu Class


Ecu.Unlock Method (Byte)

EcuUnlock Method (Byte)
Unlocks the ECU in the specified level.

Namespace: Vector.Diagnostics
Assembly: Vector.Diagnostics (in Vector.Diagnostics.dll) Version: 5.4 Beta2
Syntax
C#
VB
Copy
public SecurityAccessResult Unlock(
    byte securityLevel
)
Public Function Unlock (
    securityLevel As Byte
) As SecurityAccessResult

Parameters

securityLevel
Type: SystemByte
The security level.

Return Value

Type: SecurityAccessResult
Success if ECU was unlocked successfully otherwise check value of SecurityAccessResult.
Exceptions
Exception | Condition
ObjectDisposedException | Throws an ObjectDisposedException when the instance was disposed.
Examples
Copy
public void UnlockEcuInLevel1()
{
    // Get the first ECU
    Ecu ecu = Application.GetEcu();

    // Unlock ECU in Level 1:
    // - Request seed with $27 01
    // - Calculate key using seed key dll and response of $27 01
    // - Send key using $27 02 and calculated key
    // - if ECU responds with positive response
    SecurityAccessResult securityAccessResult = ecu.Unlock(1);

    // Check result of unlocking the ECU
    if (securityAccessResult == SecurityAccessResult.Success)
    {
      Output.WriteLine("Unlocking ECU was successful.");
    }

    // Enter stuff to be executed on an unlocked ECU.
}
See Also

Reference

Ecu Class
Unlock Overload


Ecu.Unlock Method (Byte, String)

EcuUnlock Method (Byte, String)
Unlocks the ECU in the specified level using an additional option string.

Namespace: Vector.Diagnostics
Assembly: Vector.Diagnostics (in Vector.Diagnostics.dll) Version: 5.4 Beta2
Syntax
C#
VB
Copy
public SecurityAccessResult Unlock(
    byte securityLevel,
    string option
)
Public Function Unlock (
    securityLevel As Byte,
    option As String
) As SecurityAccessResult

Parameters

securityLevel
Type: SystemByte
The security level.
option
Type: SystemString
The option string to be passed to the seed and key DLL.

Return Value

Type: SecurityAccessResult
Success if ECU was unlocked successfully.
Exceptions
Exception | Condition
ObjectDisposedException | Throws an ObjectDisposedException when the instance was disposed.
See Also

Reference

Ecu Class
Unlock Overload


Ecu Properties

Ecu Properties

The Ecu type exposes the following members.

Properties
 | Name | Description
Public property | IsDisposed | Gets a value indicating whether the current instance was disposed.
Public property | Name | Gets the name of the current ECU.
Public property | Qualifier | Gets the unique ECU identifier.
Public property | Variant | Gets the qualifier of the current ECU variant.
Top
See Also

Reference

Ecu Class


Ecu.IsDisposed Property

EcuIsDisposed Property
Gets a value indicating whether the current instance was disposed.

Namespace: Vector.Diagnostics
Assembly: Vector.Diagnostics (in Vector.Diagnostics.dll) Version: 5.4 Beta2
Syntax
C#
VB
Copy
public bool IsDisposed { get; }
Public ReadOnly Property IsDisposed As Boolean
    Get

Property Value

Type: Boolean
true if the current instance was disposed; otherwise, false.
See Also

Reference

Ecu Class


Ecu.Name Property

EcuName Property
Gets the name of the current ECU.

Namespace: Vector.Diagnostics
Assembly: Vector.Diagnostics (in Vector.Diagnostics.dll) Version: 5.4 Beta2
Syntax
C#
VB
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get

Property Value

Type: String
See Also

Reference

Ecu Class


Ecu.Qualifier Property

EcuQualifier Property
Gets the unique ECU identifier.

Namespace: Vector.Diagnostics
Assembly: Vector.Diagnostics (in Vector.Diagnostics.dll) Version: 5.4 Beta2
Syntax
C#
VB
Copy
public string Qualifier { get; }
Public ReadOnly Property Qualifier As String
    Get

Property Value

Type: String
Exceptions
Exception | Condition
ObjectDisposedException | Throws an ObjectDisposedException when the instance was disposed.
Remarks
Some applications (CANape, CANoe, CANdito) allow changing the qualifier of an ECU in the configuration, i.e. the default qualifier defined in the diagnostics description may be overwritten by the user.
See Also

Reference

Ecu Class


Ecu.Variant Property

EcuVariant Property
Gets the qualifier of the current ECU variant.

Namespace: Vector.Diagnostics
Assembly: Vector.Diagnostics (in Vector.Diagnostics.dll) Version: 5.4 Beta2
Syntax
C#
VB
Copy
public string Variant { get; }
Public ReadOnly Property Variant As String
    Get

Property Value

Type: String
The qualifier of the ECU variant.
Exceptions
Exception | Condition
ObjectDisposedException | Throws an ObjectDisposedException when the instance was disposed.
Remarks
Caution: the variant qualifier may change if you use automatic variant detection.
See Also

Reference

Ecu Class


ExceptionType Enumeration

ExceptionType Enumeration
Defines constants that are used by the DiagnosticException class

Namespace: Vector.Diagnostics
Assembly: Vector.Diagnostics (in Vector.Diagnostics.dll) Version: 5.4 Beta2
Syntax
C#
VB
Copy
[SerializableAttribute]
public enum ExceptionType
<SerializableAttribute>
Public Enumeration ExceptionType
Members
Member name | Value | Description
Unspecified | 0 | An unspecified error occurred.
IllegalValueConversion | 1 | An error occurred during the conversion of a value.
See Also

Reference

Vector.Diagnostics Namespace

(C) 2008-2013 Vector Informatik GmbH


GenerateSecurityKeyResult Enumeration

GenerateSecurityKeyResult Enumeration
Result of the GenerateSecurityKey(Ecu, Byte, Byte, String, Byte) method that contains information whether the key could be generated using a seed and key dll.

Namespace: Vector.Diagnostics
Assembly: Vector.Diagnostics (in Vector.Diagnostics.dll) Version: 5.4 Beta2
Syntax
C#
VB
Copy
public enum GenerateSecurityKeyResult
Public Enumeration GenerateSecurityKeyResult
Members
Member name | Value | Description
NoResult | 0 | No result available (initial state).
Success | 1 | Generating the key was successful.
InvalidSeedKeyDll | 10 | The seed and key dll is not configured or not available in the application for the specified ECU.
InvalidVariant | 11 | The current ECU variant passed to the seed and key dll is invalid.
InvalidSecurityLevel | 12 | The specified security level is invalid.
Failure | 100 | An unknown error occurred trying to generate the key from the seed with the specified parameters.
See Also

Reference

Vector.Diagnostics Namespace

(C) 2008-2013 Vector Informatik GmbH


Parameter Class

Parameter Class
Represents a parameter of a message (request/response).
Inheritance Hierarchy
SystemObject
Vector.DiagnosticsParameter

Namespace: Vector.Diagnostics
Assembly: Vector.Diagnostics (in Vector.Diagnostics.dll) Version: 5.4 Beta2
Syntax
C#
VB
Copy
public sealed class Parameter : IParameter,
    IParameterParent, IDisposable
Public NotInheritable Class Parameter
    Implements IParameter, IParameterParent, IDisposable

The Parameter type exposes the following members.

Methods
 | Name | Description
Protected method | Finalize | Finalizes an instance of the Parameter class. (Overrides ObjectFinalize.)
 | GetParameter | Access to a sub parameter within a structured parameter.
 | SetIterationCount | Set the number of iterations.
Public method | ToString | Get a descriptive string for the parameter, including its value. (Overrides ObjectToString.)
Top
Properties
 | Name | Description
Public property | Description | Get the parameter description text.
Public property | Name | Get the parameter name.
 | Parameters | Get sub parameters of a structured parameter.
Public property | Qualifier | The parameter qualifier (unique name).
Public property | Semantic | The parameter's semantic.
Public property | Unit | Get the unit of the parameter.
Public property | Value | Access the parameter value object.
Top
See Also

Reference

Vector.Diagnostics Namespace

(C) 2008-2013 Vector Informatik GmbH


Parameter Methods

Parameter Methods

The Parameter type exposes the following members.

Methods
 | Name | Description
Protected method | Finalize | Finalizes an instance of the Parameter class. (Overrides ObjectFinalize.)
 | GetParameter | Access to a sub parameter within a structured parameter.
 | SetIterationCount | Set the number of iterations.
Public method | ToString | Get a descriptive string for the parameter, including its value. (Overrides ObjectToString.)
Top
See Also

Reference

Parameter Class


Parameter.Finalize Method

ParameterFinalize Method
Finalizes an instance of the Parameter class.

Namespace: Vector.Diagnostics
Assembly: Vector.Diagnostics (in Vector.Diagnostics.dll) Version: 5.4 Beta2
Syntax
C#
VB
Copy
protected override void Finalize()
Protected Overrides Sub Finalize
See Also

Reference

Parameter Class


Parameter.GetParameter Method

ParameterGetParameter Method
Access to a sub parameter within a structured parameter.

Namespace: Vector.Diagnostics
Assembly: Vector.Diagnostics (in Vector.Diagnostics.dll) Version: 5.4 Beta2
Syntax
C#
VB
Copy
public Parameter GetParameter(
    string subParameterQualifier
)
Public Function GetParameter (
    subParameterQualifier As String
) As Parameter

Parameters

subParameterQualifier
Type: SystemString
The qualifier of the sub parameter.

Return Value

Type: Parameter
The sub parameter if it exists, null otherwise.
Exceptions
Exception | Condition
ObjectDisposedException | Throws an ObjectDisposedException when the instance was disposed.
Examples
This example shows how to get sub parameters from a parameter.
Copy
// Retrieve the door ECU from the application
Ecu myEcu = Application.GetEcu("Door");

// Create a request using the service qualifier
Request request = myEcu.CreateRequest("Software_Version_Read");

// Get the parent parameter from the request
Parameter parameter = request.GetParameter("Software_Version");

// Reade the sub parameters for the software version from the parent parameter
Parameter paramMajor = parameter.GetParameter("Software_Version.Major");
Parameter paramMinor = parameter.GetParameter("Software_Version.Minor");
Parameter paramRevision = parameter.GetParameter("Software_Version.Revision");

// ...
See Also

Reference

Parameter Class


Parameter.SetIterationCount Method

ParameterSetIterationCount Method
Set the number of iterations.

Namespace: Vector.Diagnostics
Assembly: Vector.Diagnostics (in Vector.Diagnostics.dll) Version: 5.4 Beta2
Syntax
C#
VB
Copy
public bool SetIterationCount(
    uint count
)
Public Function SetIterationCount (
    count As UInteger
) As Boolean

Parameters

count
Type: SystemUInt32
The number of iterations this iterative parameter will contain afterwards.

Return Value

Type: Boolean
true if actions succeeds, false otherwise.
Exceptions
Exception | Condition
ObjectDisposedException | Throws an ObjectDisposedException when the instance was disposed.
Remarks
Sets the number of iterations in an iterative parameter. Do not use the Value property to add or remove iterations!
Examples
The following example shows how to set the number of iterations in an iterative parameter.
Copy
// Get the parameter from the request
Parameter parameter = request.GetParameter("My_Param");

// Set the number of iterations to 5
bool settingIterationsWithoutError = parameter.SetIterationCount(5);
See Also

Reference

Parameter Class


Parameter.ToString Method

ParameterToString Method
Get a descriptive string for the parameter, including its value.

Namespace: Vector.Diagnostics
Assembly: Vector.Diagnostics (in Vector.Diagnostics.dll) Version: 5.4 Beta2
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
The parameter representation string in the format "[parameter_name]: [value]".
See Also

Reference

Parameter Class


Parameter Properties

Parameter Properties

The Parameter type exposes the following members.

Properties
 | Name | Description
Public property | Description | Get the parameter description text.
Public property | Name | Get the parameter name.
 | Parameters | Get sub parameters of a structured parameter.
Public property | Qualifier | The parameter qualifier (unique name).
Public property | Semantic | The parameter's semantic.
Public property | Unit | Get the unit of the parameter.
Public property | Value | Access the parameter value object.
Top
See Also

Reference

Parameter Class


Parameter.Description Property

ParameterDescription Property
Get the parameter description text.

Namespace: Vector.Diagnostics
Assembly: Vector.Diagnostics (in Vector.Diagnostics.dll) Version: 5.4 Beta2
Syntax
C#
VB
Copy
public string Description { get; }
Public ReadOnly Property Description As String
    Get

Property Value

Type: String
Remarks
The description text of the parameter depends on the language settings of the diagnostic database in the host application.
See Also

Reference

Parameter Class


Parameter.Name Property

ParameterName Property
Get the parameter name.

Namespace: Vector.Diagnostics
Assembly: Vector.Diagnostics (in Vector.Diagnostics.dll) Version: 5.4 Beta2
Syntax
C#
VB
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get

Property Value

Type: String
Remarks
The name of the parameter depends on the language settings for the diagnostic database in the host application.
See Also

Reference

Parameter Class


Parameter.Parameters Property

ParameterParameters Property
Get sub parameters of a structured parameter.

Namespace: Vector.Diagnostics
Assembly: Vector.Diagnostics (in Vector.Diagnostics.dll) Version: 5.4 Beta2
Syntax
C#
VB
Copy
public ParameterCollection Parameters { get; }
Public ReadOnly Property Parameters As ParameterCollection
    Get

Property Value

Type: ParameterCollection
ParameterCollection with a list of sub parameters.
Examples
This example shows how to access the sub parameter collection to get a sub parameter.
Copy
// Use the ECU currently selected by the Application
Ecu myEcu = Application.GetEcu();

// Create a request using the service qualifier
Request request = myEcu.CreateRequest("Software_Version_Read");

// Send the request to the ECU and wait for a response
SendResult result = request.Send();

// Check if request has been sent successfully to the ECU
if (result.Status == SendStatus.Ok)
{
    // Get the response from the send result
    Response response = result.Response;

    // Read the parameter
    Parameter paramSoftwareVersion = response.GetParameter("Software_Version");

    // Read the sub parameters via indexer
    Parameter paramMajor = paramSoftwareVersion.Parameters["Software_Version.Major"];
    Parameter paramMinor = paramSoftwareVersion.Parameters["Software_Version.Minor"];
    Parameter paramRevision = paramSoftwareVersion.Parameters["Software_Version.Revision"];

    // Iterate over sub parameters with foreach-loop
    foreach (Parameter parameter in paramSoftwareVersion.Parameters)
    {
        string paramName = parameter.Name;
        string paramDescription = parameter.Description;
        // ...
    }

    // Iterate over sub parameters with for-loop
    for (int i = 0; i < paramSoftwareVersion.Parameters.Count; i++)
    {
        Parameter parameter = paramSoftwareVersion.Parameters[i];
        string paramName = parameter.Name;
        string paramDescription = parameter.Description;
        // ...
    }

    // ...
}
See Also

Reference

Parameter Class


Parameter.Qualifier Property

ParameterQualifier Property
The parameter qualifier (unique name).

Namespace: Vector.Diagnostics
Assembly: Vector.Diagnostics (in Vector.Diagnostics.dll) Version: 5.4 Beta2
Syntax
C#
VB
Copy
public string Qualifier { get; }
Public ReadOnly Property Qualifier As String
    Get

Property Value

Type: String
See Also

Reference

Parameter Class


Parameter.Semantic Property

ParameterSemantic Property
The parameter's semantic.

Namespace: Vector.Diagnostics
Assembly: Vector.Diagnostics (in Vector.Diagnostics.dll) Version: 5.4 Beta2
Syntax
C#
VB
Copy
public string Semantic { get; }
Public ReadOnly Property Semantic As String
    Get

Property Value

Type: String
See Also

Reference

Parameter Class


Parameter.Unit Property

ParameterUnit Property
Get the unit of the parameter.

Namespace: Vector.Diagnostics
Assembly: Vector.Diagnostics (in Vector.Diagnostics.dll) Version: 5.4 Beta2
Syntax
C#
VB
Copy
public string Unit { get; }
Public ReadOnly Property Unit As String
    Get

Property Value

Type: String
See Also

Reference

Parameter Class


Parameter.Value Property

ParameterValue Property
Access the parameter value object.

Namespace: Vector.Diagnostics
Assembly: Vector.Diagnostics (in Vector.Diagnostics.dll) Version: 5.4 Beta2
Syntax
C#
VB
Copy
public Value Value { get; }
Public ReadOnly Property Value As Value
    Get

Property Value

Type: Value
See Also

Reference

Parameter Class


ParameterCollection Class

ParameterCollection Class
Provide a strongly typed collection for Parameters
Inheritance Hierarchy
SystemObject
System.CollectionsReadOnlyCollectionBase
Vector.DiagnosticsParameterCollection

Namespace: Vector.Diagnostics
Assembly: Vector.Diagnostics (in Vector.Diagnostics.dll) Version: 5.4 Beta2
Syntax
C#
VB
Copy
public sealed class ParameterCollection : ReadOnlyCollectionBase,
    ICollection, IEnumerable, IParameterCollection, IParameterParent, IDisposable
Public NotInheritable Class ParameterCollection
    Inherits ReadOnlyCollectionBase
    Implements ICollection, IEnumerable, IParameterCollection, IParameterParent,
    IDisposable

The ParameterCollection type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Cleanup the parameters in the ParameterCollection. Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Protected method | Finalize | Finalizes an instance of the ParameterCollection class. (Overrides ObjectFinalize.)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection. (Overrides ReadOnlyCollectionBaseGetEnumerator.)
Public method | IndexOf | Index the of the specified Parameter.
Top
Properties
 | Name | Description
Public property | Count | Return the number of parameters in this collection (Overrides ReadOnlyCollectionBaseCount.)
Public property | ItemInt32 | Gets the Parameter at the specified index.
Public property | ItemString | Gets the Parameter with the specified qualifier.
Top
See Also

Reference

Vector.Diagnostics Namespace

(C) 2008-2013 Vector Informatik GmbH


ParameterCollection Methods

ParameterCollection Methods

The ParameterCollection type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Cleanup the parameters in the ParameterCollection. Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Protected method | Finalize | Finalizes an instance of the ParameterCollection class. (Overrides ObjectFinalize.)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection. (Overrides ReadOnlyCollectionBaseGetEnumerator.)
Public method | IndexOf | Index the of the specified Parameter.
Top
See Also

Reference

ParameterCollection Class


ParameterCollection.Dispose Method

ParameterCollectionDispose Method
Cleanup the parameters in the ParameterCollection. Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Vector.Diagnostics
Assembly: Vector.Diagnostics (in Vector.Diagnostics.dll) Version: 5.4 Beta2
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
See Also

Reference

ParameterCollection Class


ParameterCollection.Finalize Method

ParameterCollectionFinalize Method
Finalizes an instance of the ParameterCollection class.

Namespace: Vector.Diagnostics
Assembly: Vector.Diagnostics (in Vector.Diagnostics.dll) Version: 5.4 Beta2
Syntax
C#
VB
Copy
protected override void Finalize()
Protected Overrides Sub Finalize
See Also

Reference

ParameterCollection Class


ParameterCollection.GetEnumerator Method

ParameterCollectionGetEnumerator Method
Returns an enumerator that iterates through a collection.

Namespace: Vector.Diagnostics
Assembly: Vector.Diagnostics (in Vector.Diagnostics.dll) Version: 5.4 Beta2
Syntax
C#
VB
Copy
public override IEnumerator GetEnumerator()
Public Overrides Function GetEnumerator As IEnumerator

Return Value

Type: IEnumerator
An IEnumerator object that can be used to iterate through the collection.

Implements

IEnumerableGetEnumerator
IEnumerableGetEnumerator
See Also

Reference

ParameterCollection Class


ParameterCollection.IndexOf Method

ParameterCollectionIndexOf Method
Index the of the specified Parameter.

Namespace: Vector.Diagnostics
Assembly: Vector.Diagnostics (in Vector.Diagnostics.dll) Version: 5.4 Beta2
Syntax
C#
VB
Copy
public int IndexOf(
    Parameter parameter
)
Public Function IndexOf (
    parameter As Parameter
) As Integer

Parameters

parameter
Type: Vector.DiagnosticsParameter
The parameter to find.

Return Value

Type: Int32
The zero-based index of the first occurrence of the parameter within the entire collection, if found; otherwise, -1.
See Also

Reference

ParameterCollection Class


ParameterCollection Properties

ParameterCollection Properties

The ParameterCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Return the number of parameters in this collection (Overrides ReadOnlyCollectionBaseCount.)
Public property | ItemInt32 | Gets the Parameter at the specified index.
Public property | ItemString | Gets the Parameter with the specified qualifier.
Top
See Also

Reference

ParameterCollection Class


ParameterCollection.Count Property

ParameterCollectionCount Property
Return the number of parameters in this collection

Namespace: Vector.Diagnostics
Assembly: Vector.Diagnostics (in Vector.Diagnostics.dll) Version: 5.4 Beta2
Syntax
C#
VB
Copy
public override int Count { get; }
Public Overrides ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

Implements

ICollectionCount
ICollectionCount
See Also

Reference

ParameterCollection Class


ParameterCollection.Item Property

ParameterCollectionItem Property
Overload List
 | Name | Description
Public property | ItemInt32 | Gets the Parameter at the specified index.
Public property | ItemString | Gets the Parameter with the specified qualifier.
Top
See Also

Reference

ParameterCollection Class


ParameterCollection.Item Property (Int32)

ParameterCollectionItem Property (Int32)
Gets the Parameter at the specified index.

Namespace: Vector.Diagnostics
Assembly: Vector.Diagnostics (in Vector.Diagnostics.dll) Version: 5.4 Beta2
Syntax
C#
VB
Copy
public Parameter this[
    int index
] { get; }
Public ReadOnly Default Property Item (
    index As Integer
) As Parameter
    Get

Parameters

index
Type: SystemInt32

Property Value

Type: Parameter
The zero-based index value of the parameter in the collection.
Remarks
If the parameter with the specified index cannot be found, null is returned.
See Also

Reference

ParameterCollection Class
Item Overload


ParameterCollection.Item Property (String)

ParameterCollectionItem Property (String)
Gets the Parameter with the specified qualifier.

Namespace: Vector.Diagnostics
Assembly: Vector.Diagnostics (in Vector.Diagnostics.dll) Version: 5.4 Beta2
Syntax
C#
VB
Copy
public Parameter this[
    string qualifier
] { get; }
Public ReadOnly Default Property Item (
    qualifier As String
) As Parameter
    Get

Parameters

qualifier
Type: SystemString

Property Value

Type: Parameter
The qualifier of the Parameter.
Remarks
If the parameter with the specified qualifier cannot be found, null is returned.
See Also

Reference

ParameterCollection Class
Item Overload


Request Class

Request Class
Provides a diagnostic request message.
Inheritance Hierarchy
SystemObject
Vector.DiagnosticsRequest

Namespace: Vector.Diagnostics
Assembly: Vector.Diagnostics (in Vector.Diagnostics.dll) Version: 5.4 Beta2
Syntax
C#
VB
Copy
public sealed class Request : IMessage,
    IParameterParent, IDisposable
Public NotInheritable Class Request
    Implements IMessage, IParameterParent, IDisposable

The Request type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Free resources allocated for this message. Call this method when the message is no longer used.
Protected method | Finalize | Finalizes an instance of the Request class. (Overrides ObjectFinalize.)
Public method | GetParameter | Get a specific parameter from the request message.
Public method | Send | Sends the request message to the ECU.
 | SendAsynchronous | Sends the request message asynchronously to the ECU.
Public method | ToString | Returns the qualifier of the service of the request message. (Overrides ObjectToString.)
Top
Properties
 | Name | Description
Public property | Ecu | Gets the Ecu instance to that this instance belongs.
Public property | Parameters | Get the list of top level request parameters.
Public property | Pdu | Get the raw request PDU.
Public property | Qualifier | The service qualifier (unique name).
Public property | RequestQualifier | The request primitive's identifier string (unique name).
Public property | SuppressPositiveResponse | Access positive response suppression setting.
Top
Remarks
The resources that are held for messages (requests and responses) have to be cleared after the according objects will not be accessed any more. This has to be done by calling the Dispose() method of such objects. C# comes with an extra statement which is built in in the language: ‘using’. With this keyword one can define a scope, outside of which an object will automatically be disposed.
Examples
This example shows how to create a new request based on raw bytes as PDU.
Copy
// Use the ECU currently selected by the Application
Ecu myEcu = Application.GetEcu();

// Create a request using raw bytes as PDU
Request request = myEcu.CreateRequest(new byte[] { 0x10, 0x03 });
// ...

// When the request is not needed any more use Dispose() to free allocated resources
Examples
This example shows how to create a new request based on a service qualifier.
Copy
public void EcuSampleScript()
{
  // Use the ECU currently selected by the Application
  Ecu myEcu = Application.GetEcu();

  // Create a request using the service qualifier
  using(Request request = myEcu.CreateRequest("Software_Version_Read"))
  {
    // ...
  }
}
See Also

Reference

Vector.Diagnostics Namespace

(C) 2008-2013 Vector Informatik GmbH


Request Methods

Request Methods

The Request type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Free resources allocated for this message. Call this method when the message is no longer used.
Protected method | Finalize | Finalizes an instance of the Request class. (Overrides ObjectFinalize.)
Public method | GetParameter | Get a specific parameter from the request message.
Public method | Send | Sends the request message to the ECU.
 | SendAsynchronous | Sends the request message asynchronously to the ECU.
Public method | ToString | Returns the qualifier of the service of the request message. (Overrides ObjectToString.)
Top
See Also

Reference

Request Class


Request.Dispose Method

RequestDispose Method
Free resources allocated for this message. Call this method when the message is no longer used.

Namespace: Vector.Diagnostics
Assembly: Vector.Diagnostics (in Vector.Diagnostics.dll) Version: 5.4 Beta2
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
See Also

Reference

Request Class


Request.Finalize Method

RequestFinalize Method
Finalizes an instance of the Request class.

Namespace: Vector.Diagnostics
Assembly: Vector.Diagnostics (in Vector.Diagnostics.dll) Version: 5.4 Beta2
Syntax
C#
VB
Copy
protected override void Finalize()
Protected Overrides Sub Finalize
See Also

Reference

Request Class


Request.GetParameter Method

RequestGetParameter Method
Get a specific parameter from the request message.

Namespace: Vector.Diagnostics
Assembly: Vector.Diagnostics (in Vector.Diagnostics.dll) Version: 5.4 Beta2
Syntax
C#
VB
Copy
public Parameter GetParameter(
    string qualifier
)
Public Function GetParameter (
    qualifier As String
) As Parameter

Parameters

qualifier
Type: SystemString
The qualifier of the parameter.

Return Value

Type: Parameter
The parameter object if it exists, null otherwise.
Exceptions
Exception | Condition
ObjectDisposedException | Throws an ObjectDisposedException when the instance was disposed.
See Also

Reference

Request Class


Request.Send Method

RequestSend Method
Sends the request message to the ECU.

Namespace: Vector.Diagnostics
Assembly: Vector.Diagnostics (in Vector.Diagnostics.dll) Version: 5.4 Beta2
Syntax
C#
VB
Copy
public SendResult Send()
Public Function Send As SendResult

Return Value

Type: SendResult
The SendResult object, which contains the status and also the response.
Exceptions
Exception | Condition
ObjectDisposedException | Throws an ObjectDisposedException when the instance was disposed.
See Also

Reference

Request Class


Request.SendAsynchronous Method

RequestSendAsynchronous Method
Sends the request message asynchronously to the ECU.

Namespace: Vector.Diagnostics
Assembly: Vector.Diagnostics (in Vector.Diagnostics.dll) Version: 5.4 Beta2
Syntax
C#
VB
Copy
public SendResult SendAsynchronous()
Public Function SendAsynchronous As SendResult

Return Value

Type: SendResult
The SendResult object, which contains the status and also the response.
Exceptions
Exception | Condition
ObjectDisposedException | Throws an ObjectDisposedException when the instance was disposed.
Examples
This example shows how to create a new request, send it asynchronously and then wait for the result.
Copy
public void EcuSampleScript()
{
  // Use the ECU currently selected by the Application
  Ecu myEcu = Application.GetEcu();

  // Create a request using the service qualifier
  using(Request request = myEcu.CreateRequest("Software_Version_Read"))
  {
    // Send the request
    using(SendResult result = request.SendAsynchronous())
    {
      // Do something here...

      // Wait for the result
      WaitResult waitResult = SendResult.WaitAll(result);

      if(waitResult == WaitResult.Success)
      {
        // The response(s) are available now
        Response response = result.Response;
      }
      else
      {
        // error handling
      }
    }
  }
}
See Also

Reference

Request Class


Request.ToString Method

RequestToString Method
Returns the qualifier of the service of the request message.

Namespace: Vector.Diagnostics
Assembly: Vector.Diagnostics (in Vector.Diagnostics.dll) Version: 5.4 Beta2
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
Qualifier string of the request message.
Exceptions
Exception | Condition
ObjectDisposedException | Throws an ObjectDisposedException when the instance was disposed.
See Also

Reference

Request Class


Request Properties

Request Properties

The Request type exposes the following members.

Properties
 | Name | Description
Public property | Ecu | Gets the Ecu instance to that this instance belongs.
Public property | Parameters | Get the list of top level request parameters.
Public property | Pdu | Get the raw request PDU.
Public property | Qualifier | The service qualifier (unique name).
Public property | RequestQualifier | The request primitive's identifier string (unique name).
Public property | SuppressPositiveResponse | Access positive response suppression setting.
Top
See Also

Reference

Request Class


Request.Ecu Property

RequestEcu Property
Gets the Ecu instance to that this instance belongs.

Namespace: Vector.Diagnostics
Assembly: Vector.Diagnostics (in Vector.Diagnostics.dll) Version: 5.4 Beta2
Syntax
C#
VB
Copy
public Ecu Ecu { get; }
Public ReadOnly Property Ecu As Ecu
    Get

Property Value

Type: Ecu
Exceptions
Exception | Condition
ObjectDisposedException | Throws an ObjectDisposedException when the instance was disposed.
See Also

Reference

Request Class


Request.Parameters Property

RequestParameters Property
Get the list of top level request parameters.

Namespace: Vector.Diagnostics
Assembly: Vector.Diagnostics (in Vector.Diagnostics.dll) Version: 5.4 Beta2
Syntax
C#
VB
Copy
public ParameterCollection Parameters { get; }
Public ReadOnly Property Parameters As ParameterCollection
    Get

Property Value

Type: ParameterCollection
Exceptions
Exception | Condition
ObjectDisposedException | Throws an ObjectDisposedException when the instance was disposed.
See Also

Reference

Request Class


Request.Pdu Property

RequestPdu Property
Get the raw request PDU.

Namespace: Vector.Diagnostics
Assembly: Vector.Diagnostics (in Vector.Diagnostics.dll) Version: 5.4 Beta2
Syntax
C#
VB
Copy
public byte[] Pdu { get; }
Public ReadOnly Property Pdu As Byte()
    Get

Property Value

Type: Byte
Exceptions
Exception | Condition
ObjectDisposedException | Throws an ObjectDisposedException when the instance was disposed.
See Also

Reference

Request Class


Request.Qualifier Property

RequestQualifier Property
The service qualifier (unique name).

Namespace: Vector.Diagnostics
Assembly: Vector.Diagnostics (in Vector.Diagnostics.dll) Version: 5.4 Beta2
Syntax
C#
VB
Copy
public string Qualifier { get; }
Public ReadOnly Property Qualifier As String
    Get

Property Value

Type: String
Exceptions
Exception | Condition
ObjectDisposedException | Throws an ObjectDisposedException when the instance was disposed.
See Also

Reference

Request Class


Request.RequestQualifier Property

RequestRequestQualifier Property
The request primitive's identifier string (unique name).

Namespace: Vector.Diagnostics
Assembly: Vector.Diagnostics (in Vector.Diagnostics.dll) Version: 5.4 Beta2
Syntax
C#
VB
Copy
public string RequestQualifier { get; }
Public ReadOnly Property RequestQualifier As String
    Get

Property Value

Type: String
Exceptions
Exception | Condition
ObjectDisposedException | Throws an ObjectDisposedException when the instance was disposed.
See Also

Reference

Request Class


Request.SuppressPositiveResponse Property

RequestSuppressPositiveResponse Property
Access positive response suppression setting.

Namespace: Vector.Diagnostics
Assembly: Vector.Diagnostics (in Vector.Diagnostics.dll) Version: 5.4 Beta2
Syntax
C#
VB
Copy
public bool SuppressPositiveResponse { get; set; }
Public Property SuppressPositiveResponse As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

Request Class


RequestCollection Class

RequestCollection Class
Provide a strongly typed collection for Requests.
Inheritance Hierarchy
SystemObject
System.CollectionsReadOnlyCollectionBase
Vector.DiagnosticsRequestCollection

Namespace: Vector.Diagnostics
Assembly: Vector.Diagnostics (in Vector.Diagnostics.dll) Version: 5.4 Beta2
Syntax
C#
VB
Copy
public class RequestCollection : ReadOnlyCollectionBase,
    IDisposable
Public Class RequestCollection
    Inherits ReadOnlyCollectionBase
    Implements IDisposable

The RequestCollection type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Free resources.
Top
Properties
 | Name | Description
Public property | ItemInt32 | Gets the Request at the specified index.
Public property | ItemString | Gets the Request with the specified qualifier.
Top
See Also

Reference

Vector.Diagnostics Namespace

(C) 2008-2013 Vector Informatik GmbH


RequestCollection Methods

RequestCollection Methods

The RequestCollection type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Free resources.
Top
See Also

Reference

RequestCollection Class


RequestCollection.Dispose Method

RequestCollectionDispose Method
Free resources.

Namespace: Vector.Diagnostics
Assembly: Vector.Diagnostics (in Vector.Diagnostics.dll) Version: 5.4 Beta2
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
See Also

Reference

RequestCollection Class


RequestCollection Properties

RequestCollection Properties
Properties
 | Name | Description
Public property | ItemInt32 | Gets the Request at the specified index.
Public property | ItemString | Gets the Request with the specified qualifier.
Top
See Also

Reference

RequestCollection Class


RequestCollection.Item Property

RequestCollectionItem Property
Overload List
 | Name | Description
Public property | ItemInt32 | Gets the Request at the specified index.
Public property | ItemString | Gets the Request with the specified qualifier.
Top
See Also

Reference

RequestCollection Class


RequestCollection.Item Property (Int32)

RequestCollectionItem Property (Int32)
Gets the Request at the specified index.

Namespace: Vector.Diagnostics
Assembly: Vector.Diagnostics (in Vector.Diagnostics.dll) Version: 5.4 Beta2
Syntax
C#
VB
Copy
public Request this[
    int index
] { get; }
Public ReadOnly Default Property Item (
    index As Integer
) As Request
    Get

Parameters

index
Type: SystemInt32

Property Value

Type: Request
The zero-based index value of the request in the collection.
Remarks
If the request with the specified index cannot be found, null is returned.
See Also

Reference

RequestCollection Class
Item Overload


RequestCollection.Item Property (String)

RequestCollectionItem Property (String)
Gets the Request with the specified qualifier.

Namespace: Vector.Diagnostics
Assembly: Vector.Diagnostics (in Vector.Diagnostics.dll) Version: 5.4 Beta2
Syntax
C#
VB
Copy
public Request this[
    string qualifier
] { get; }
Public ReadOnly Default Property Item (
    qualifier As String
) As Request
    Get

Parameters

qualifier
Type: SystemString

Property Value

Type: Request
The qualifier of the Request.
Remarks
If the request with the specified qualifier cannot be found, null is returned.
See Also

Reference

RequestCollection Class
Item Overload


Response Class

Response Class
Provides a diagnostic response message.
Inheritance Hierarchy
SystemObject
Vector.DiagnosticsResponse

Namespace: Vector.Diagnostics
Assembly: Vector.Diagnostics (in Vector.Diagnostics.dll) Version: 5.4 Beta2
Syntax
C#
VB
Copy
public sealed class Response : IMessage,
    IParameterParent, IDisposable
Public NotInheritable Class Response
    Implements IMessage, IParameterParent, IDisposable

The Response type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Free resources allocated for this response. Call this method after the response has been handled and won't be accessed any more.
Protected method | Finalize | Finalizes an instance of the Response class. (Overrides ObjectFinalize.)
Public method | GetParameter | Get a specific parameter from the response message.
Top
Properties
 | Name | Description
Public property | Ecu | Gets the Ecu instance to that this instance belongs.
Public property | IsPositive | Indicates whether the response is a positive or negative response.
Public property | Parameters | Read access to the (top level) parameter collection of that message.
Public property | Pdu | The message PDU.
Public property | ResponseQualifier | The response primitive's identifier string (unique qualifier / shortname).
Public property | Status | Returns a response's detailed status.
Top
Remarks
The resources that are held for messages (requests and responses) have to be cleared after the corresponding objects will not be accessed any more. This has to be done by calling the Dispose() method of such objects. C# comes with an extra statement which is built in in the language: ‘using’. With this keyword one can define a scope, outside of which an object will automatically be disposed.
Examples
This example sends a request to the ECU and reads a parameter from the response
Copy
// Use the ECU currently selected by the Application
Ecu myEcu = Application.GetEcu();

// Create a request using raw bytes as PDU
using(Request request = myEcu.CreateRequest(new byte[] {0x10, 0x03}))
{
  // Send the request to the ECU and wait for a response
  using(SendResult result = request.Send())
  {
    // Retrieve the response from the send result
    // Caution: the response can be null, e.g. if sending failed
    Response response = result.Response;

    // Get a parameter from the response
    Parameter timingParameter = response.GetParameter("Timing_Res_1ms");

    // Write the parameter value to the output window, indicating the parameter's unit
    Output.WriteLine("Timing: " + timingParameter.Value.ToDouble() + timingParameter.Unit);
  }
}
See Also

Reference

Vector.Diagnostics Namespace

(C) 2008-2013 Vector Informatik GmbH


Response Methods

Response Methods

The Response type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Free resources allocated for this response. Call this method after the response has been handled and won't be accessed any more.
Protected method | Finalize | Finalizes an instance of the Response class. (Overrides ObjectFinalize.)
Public method | GetParameter | Get a specific parameter from the response message.
Top
See Also

Reference

Response Class


Response.Dispose Method

ResponseDispose Method
Free resources allocated for this response. Call this method after the response has been handled and won't be accessed any more.

Namespace: Vector.Diagnostics
Assembly: Vector.Diagnostics (in Vector.Diagnostics.dll) Version: 5.4 Beta2
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
See Also

Reference

Response Class


Response.Finalize Method

ResponseFinalize Method
Finalizes an instance of the Response class.

Namespace: Vector.Diagnostics
Assembly: Vector.Diagnostics (in Vector.Diagnostics.dll) Version: 5.4 Beta2
Syntax
C#
VB
Copy
protected override void Finalize()
Protected Overrides Sub Finalize
See Also

Reference

Response Class


Response.GetParameter Method

ResponseGetParameter Method
Get a specific parameter from the response message.

Namespace: Vector.Diagnostics
Assembly: Vector.Diagnostics (in Vector.Diagnostics.dll) Version: 5.4 Beta2
Syntax
C#
VB
Copy
public Parameter GetParameter(
    string qualifier
)
Public Function GetParameter (
    qualifier As String
) As Parameter

Parameters

qualifier
Type: SystemString
The qualifier of the parameter.

Return Value

Type: Parameter
The parameter object if it exists, null otherwise.
See Also

Reference

Response Class


Response Properties

Response Properties

The Response type exposes the following members.

Properties
 | Name | Description
Public property | Ecu | Gets the Ecu instance to that this instance belongs.
Public property | IsPositive | Indicates whether the response is a positive or negative response.
Public property | Parameters | Read access to the (top level) parameter collection of that message.
Public property | Pdu | The message PDU.
Public property | ResponseQualifier | The response primitive's identifier string (unique qualifier / shortname).
Public property | Status | Returns a response's detailed status.
Top
See Also

Reference

Response Class


Response.Ecu Property

ResponseEcu Property
Gets the Ecu instance to that this instance belongs.

Namespace: Vector.Diagnostics
Assembly: Vector.Diagnostics (in Vector.Diagnostics.dll) Version: 5.4 Beta2
Syntax
C#
VB
Copy
public Ecu Ecu { get; }
Public ReadOnly Property Ecu As Ecu
    Get

Property Value

Type: Ecu
See Also

Reference

Response Class


Response.IsPositive Property

ResponseIsPositive Property
Indicates whether the response is a positive or negative response.

Namespace: Vector.Diagnostics
Assembly: Vector.Diagnostics (in Vector.Diagnostics.dll) Version: 5.4 Beta2
Syntax
C#
VB
Copy
public bool IsPositive { get; }
Public ReadOnly Property IsPositive As Boolean
    Get

Property Value

Type: Boolean
True, if the response is a positive response. Otherwise, false.
See Also

Reference

Response Class


Response.Parameters Property

ResponseParameters Property
Read access to the (top level) parameter collection of that message.

Namespace: Vector.Diagnostics
Assembly: Vector.Diagnostics (in Vector.Diagnostics.dll) Version: 5.4 Beta2
Syntax
C#
VB
Copy
public ParameterCollection Parameters { get; }
Public ReadOnly Property Parameters As ParameterCollection
    Get

Property Value

Type: ParameterCollection
List of parameters of the response message.
See Also

Reference

Response Class


Response.Pdu Property

ResponsePdu Property
The message PDU.

Namespace: Vector.Diagnostics
Assembly: Vector.Diagnostics (in Vector.Diagnostics.dll) Version: 5.4 Beta2
Syntax
C#
VB
Copy
public byte[] Pdu { get; }
Public ReadOnly Property Pdu As Byte()
    Get

Property Value

Type: Byte
The PDU of the message as raw bytes.
See Also

Reference

Response Class


Response.ResponseQualifier Property

ResponseResponseQualifier Property
The response primitive's identifier string (unique qualifier / shortname).

Namespace: Vector.Diagnostics
Assembly: Vector.Diagnostics (in Vector.Diagnostics.dll) Version: 5.4 Beta2
Syntax
C#
VB
Copy
public string ResponseQualifier { get; }
Public ReadOnly Property ResponseQualifier As String
    Get

Property Value

Type: String
See Also

Reference

Response Class


Response.Status Property

ResponseStatus Property
Returns a response's detailed status.

Namespace: Vector.Diagnostics
Assembly: Vector.Diagnostics (in Vector.Diagnostics.dll) Version: 5.4 Beta2
Syntax
C#
VB
Copy
public ResponseStatus Status { get; }
Public ReadOnly Property Status As ResponseStatus
    Get

Property Value

Type: ResponseStatus
See Also

Reference

Response Class


ResponseStatus Enumeration

ResponseStatus Enumeration
A response's detailed status.

Namespace: Vector.Diagnostics
Assembly: Vector.Diagnostics (in Vector.Diagnostics.dll) Version: 5.4 Beta2
Syntax
C#
VB
Copy
public enum ResponseStatus
Public Enumeration ResponseStatus
Members
Member name | Value | Description
NotInitialized | 0 | Not yet initialized.
Negative | 1 | A negative response.
Positive | 2 | A positive response.
FailedResponseParse | 3 | The response's pdu could not be matched/parsed correctly. Pdu is always filled, Parameters are left empty (empty ParameterCollection).
See Also

Reference

Vector.Diagnostics Namespace

(C) 2008-2013 Vector Informatik GmbH


SecurityAccessResult Enumeration

SecurityAccessResult Enumeration
Contains the result of unlock an ECU using Unlock(Byte) and Unlock(Byte, String).

Namespace: Vector.Diagnostics
Assembly: Vector.Diagnostics (in Vector.Diagnostics.dll) Version: 5.4 Beta2
Syntax
C#
VB
Copy
[SerializableAttribute]
public enum SecurityAccessResult
<SerializableAttribute>
Public Enumeration SecurityAccessResult
Members
Member name | Value | Description
NoResult | 0 | The current state of unlock an ECU is unknown (initial state).
Success | 1 | Unlock an ECU in the specified level was successful.
InvalidSeedKeyDll | 10 | The seed and key DLL was not configured or could not be used.
CommunicationError | 11 | A communication error occurred when unlocking the ECU.
NegativeResponse | 12 | The ECU to be unlocked responds with a negative response code (NRC). Check trace window for further details.
Failure | 100 | Unlocking the ECU failed because of an unspecified error. See write window or log file for further details.
See Also

Reference

Vector.Diagnostics Namespace

(C) 2008-2013 Vector Informatik GmbH


SendResult Class

SendResult Class
The result of the service communication transaction. Contains the transaction status (e.g. error state) and the response object if available.
Inheritance Hierarchy
SystemObject
Vector.DiagnosticsSendResult

Namespace: Vector.Diagnostics
Assembly: Vector.Diagnostics (in Vector.Diagnostics.dll) Version: 5.4 Beta2
Syntax
C#
VB
Copy
public sealed class SendResult : ISendResult,
    IDisposable, IEnumerable<Response>, IEnumerable
Public NotInheritable Class SendResult
    Implements ISendResult, IDisposable, IEnumerable(Of Response),
    IEnumerable

The SendResult type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Free resources allocated for this send result. Disposes all 'send result' resources (i.e. single / multiple responses). Call this method after the send result, i.e. response(s), won't be used any more.
Protected method | Finalize | Finalizes an instance of the SendResult class. (Overrides ObjectFinalize.)
 | WaitAll(SendResult) | Waits for all results to complete.
 | WaitAll(Int32, SendResult) | Either waits for all results to complete or a timeout to occur.
 | WaitAny(Int32, SendResult) | Waits for one of the results to complete.
 | WaitAny(Int32, Int32, SendResult) | Either waits for one of the results to complete or a timeout to occur.
Top
Properties
 | Name | Description
Public property | Response | The response to the sent request message (if available; null otherwise). In case of multiple responses are to be expected or possible for a certain request (e.g. multiple responses or functional requests) then the Responses property will provide the list of responses (i.e. this Response property will return null).
Public property | Responses | Gets the list of response messages from the ECU.
Public property | Status | Gets the status of the request message transmission.
Top
Remarks
To assure that all (of the possibly multiple) responses of a service communication transaction are cleared, call the Dispose() method of the SendResult object when the responses will not be accessed any more.
See Also

Reference

Vector.Diagnostics Namespace

(C) 2008-2013 Vector Informatik GmbH


SendResult Methods

SendResult Methods

The SendResult type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Free resources allocated for this send result. Disposes all 'send result' resources (i.e. single / multiple responses). Call this method after the send result, i.e. response(s), won't be used any more.
Protected method | Finalize | Finalizes an instance of the SendResult class. (Overrides ObjectFinalize.)
 | WaitAll(SendResult) | Waits for all results to complete.
 | WaitAll(Int32, SendResult) | Either waits for all results to complete or a timeout to occur.
 | WaitAny(Int32, SendResult) | Waits for one of the results to complete.
 | WaitAny(Int32, Int32, SendResult) | Either waits for one of the results to complete or a timeout to occur.
Top
See Also

Reference

SendResult Class


SendResult.Dispose Method

SendResultDispose Method
Free resources allocated for this send result. Disposes all 'send result' resources (i.e. single / multiple responses). Call this method after the send result, i.e. response(s), won't be used any more.

Namespace: Vector.Diagnostics
Assembly: Vector.Diagnostics (in Vector.Diagnostics.dll) Version: 5.4 Beta2
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
See Also

Reference

SendResult Class


SendResult.Finalize Method

SendResultFinalize Method
Finalizes an instance of the SendResult class.

Namespace: Vector.Diagnostics
Assembly: Vector.Diagnostics (in Vector.Diagnostics.dll) Version: 5.4 Beta2
Syntax
C#
VB
Copy
protected override void Finalize()
Protected Overrides Sub Finalize
See Also

Reference

SendResult Class


SendResult.WaitAll Method

SendResultWaitAll Method
Overload List
Name | Description
WaitAll(SendResult) | Waits for all results to complete.
WaitAll(Int32, SendResult) | Either waits for all results to complete or a timeout to occur.
Top
See Also

Reference

SendResult Class


SendResult.WaitAll Method (SendResult[])

SendResultWaitAll Method (SendResult)
Waits for all results to complete.

Namespace: Vector.Diagnostics
Assembly: Vector.Diagnostics (in Vector.Diagnostics.dll) Version: 5.4 Beta2
Syntax
C#
VB
Copy
public static WaitResult WaitAll(
    params SendResult[] results
)
Public Shared Function WaitAll (
    ParamArray results As SendResult()
) As WaitResult

Parameters

results
Type: Vector.DiagnosticsSendResult
The results that must complete.

Return Value

Type: WaitResult
A WaitResult value indicating the exact outcome of the waiting operation.
See Also

Reference

SendResult Class
WaitAll Overload


SendResult.WaitAll Method (Int32, SendResult[])

SendResultWaitAll Method (Int32, SendResult)
Either waits for all results to complete or a timeout to occur.

Namespace: Vector.Diagnostics
Assembly: Vector.Diagnostics (in Vector.Diagnostics.dll) Version: 5.4 Beta2
Syntax
C#
VB
Copy
public static WaitResult WaitAll(
    int timeout,
    params SendResult[] results
)
Public Shared Function WaitAll (
    timeout As Integer,
    ParamArray results As SendResult()
) As WaitResult

Parameters

timeout
Type: SystemInt32
The timeout in milliseconds. In case timeout is < 0 no timeout shall occur. In case timeout == 0 the method shall return immediately, indicating either Success in case the result was already available when the method was called or Aborted/Timeout otherwise.
results
Type: Vector.DiagnosticsSendResult
The results that must complete.

Return Value

Type: WaitResult
A WaitResult value indicating the exact outcome of the waiting operation.
See Also

Reference

SendResult Class
WaitAll Overload


SendResult.WaitAny Method

SendResultWaitAny Method
Overload List
Name | Description
WaitAny(Int32, SendResult) | Waits for one of the results to complete.
WaitAny(Int32, Int32, SendResult) | Either waits for one of the results to complete or a timeout to occur.
Top
See Also

Reference

SendResult Class


SendResult.WaitAny Method (Int32, SendResult[])

SendResultWaitAny Method (Int32, SendResult)
Waits for one of the results to complete.

Namespace: Vector.Diagnostics
Assembly: Vector.Diagnostics (in Vector.Diagnostics.dll) Version: 5.4 Beta2
Syntax
C#
VB
Copy
public static WaitResult WaitAny(
    out int index,
    params SendResult[] results
)
Public Shared Function WaitAny (
    <OutAttribute> ByRef index As Integer,
    ParamArray results As SendResult()
) As WaitResult

Parameters

index
Type: SystemInt32
The index of the result that completed.
results
Type: Vector.DiagnosticsSendResult
The results that must complete.

Return Value

Type: WaitResult
A WaitResult value indicating the exact outcome of the waiting operation.
See Also

Reference

SendResult Class
WaitAny Overload


SendResult.WaitAny Method (Int32, Int32, SendResult[])

SendResultWaitAny Method (Int32, Int32, SendResult)
Either waits for one of the results to complete or a timeout to occur.

Namespace: Vector.Diagnostics
Assembly: Vector.Diagnostics (in Vector.Diagnostics.dll) Version: 5.4 Beta2
Syntax
C#
VB
Copy
public static WaitResult WaitAny(
    int timeout,
    out int index,
    params SendResult[] results
)
Public Shared Function WaitAny (
    timeout As Integer,
    <OutAttribute> ByRef index As Integer,
    ParamArray results As SendResult()
) As WaitResult

Parameters

timeout
Type: SystemInt32
The timeout in milliseconds. In case timeout is < 0 no timeout shall occur. In case timeout == 0 the method shall return immediately, indicating either Success in case the result was already available when the method was called or Aborted/Timeout otherwise.
index
Type: SystemInt32
The index of the result that completed.
results
Type: Vector.DiagnosticsSendResult
The results that must complete.

Return Value

Type: WaitResult
A WaitResult value indicating the exact outcome of the waiting operation.
See Also

Reference

SendResult Class
WaitAny Overload


SendResult Properties

SendResult Properties

The SendResult type exposes the following members.

Properties
 | Name | Description
Public property | Response | The response to the sent request message (if available; null otherwise). In case of multiple responses are to be expected or possible for a certain request (e.g. multiple responses or functional requests) then the Responses property will provide the list of responses (i.e. this Response property will return null).
Public property | Responses | Gets the list of response messages from the ECU.
Public property | Status | Gets the status of the request message transmission.
Top
See Also

Reference

SendResult Class


SendResult.Response Property

SendResultResponse Property
The response to the sent request message (if available; null otherwise). In case of multiple responses are to be expected or possible for a certain request (e.g. multiple responses or functional requests) then the Responses property will provide the list of responses (i.e. this Response property will return null).

Namespace: Vector.Diagnostics
Assembly: Vector.Diagnostics (in Vector.Diagnostics.dll) Version: 5.4 Beta2
Syntax
C#
VB
Copy
public Response Response { get; }
Public ReadOnly Property Response As Response
    Get

Property Value

Type: Response
Remarks
The response message might be null if an error occurred. Please check the Status-property for the SendStatus value "OK" before accessing the response message.
See Also

Reference

SendResult Class


SendResult.Responses Property

SendResultResponses Property
Gets the list of response messages from the ECU.

Namespace: Vector.Diagnostics
Assembly: Vector.Diagnostics (in Vector.Diagnostics.dll) Version: 5.4 Beta2
Syntax
C#
VB
Copy
public List<Response> Responses { get; }
Public ReadOnly Property Responses As List(Of Response)
    Get

Property Value

Type: ListResponse
Remarks
In the special case that several responses may be received for a single request sent (e.g. GM fault memory access with multiple responses or the responses belonging to a functional request) the response collection can be accessed using this 'Responses' container property. Notice that the 'Responses' property has always to be used for multiple response services, even if only one response is received; e.g. if there is only one DTC or if only one ECU did respond to a functional request.
See Also

Reference

SendResult Class


SendResult.Status Property

SendResultStatus Property
Gets the status of the request message transmission.

Namespace: Vector.Diagnostics
Assembly: Vector.Diagnostics (in Vector.Diagnostics.dll) Version: 5.4 Beta2
Syntax
C#
VB
Copy
public SendStatus Status { get; }
Public ReadOnly Property Status As SendStatus
    Get

Property Value

Type: SendStatus
See Also

Reference

SendResult Class


SendStatus Enumeration

SendStatus Enumeration
The request transmission result states.

Namespace: Vector.Diagnostics
Assembly: Vector.Diagnostics (in Vector.Diagnostics.dll) Version: 5.4 Beta2
Syntax
C#
VB
Copy
[SerializableAttribute]
public enum SendStatus
<SerializableAttribute>
Public Enumeration SendStatus
Members
Member name | Value | Description
Ok | 0 | Sending data to the ECU succeeded.
InvalidRequest | 1 | Invalid request specified.
CommunicationError | 2 | Communication error occurred (either sending the request or receiving the response).
FailedResponseParse | 3 | One (or more) responses received that do not match the database definitions.
UnexpectedResponse | 4 | One or more responses received while no or just a single response was expected.
AsynchronousTransactionPending | 5 | Needed for asynchronous communication: No response information available yet. I.e. (final) response not received and also no error detected by now.
See Also

Reference

Vector.Diagnostics Namespace

(C) 2008-2013 Vector Informatik GmbH


Value Class

Value Class
To access a parameter's value.
Inheritance Hierarchy
SystemObject
Vector.DiagnosticsValue

Namespace: Vector.Diagnostics
Assembly: Vector.Diagnostics (in Vector.Diagnostics.dll) Version: 5.4 Beta2
Syntax
C#
VB
Copy
public sealed class Value
Public NotInheritable Class Value

The Value type exposes the following members.

Methods
 | Name | Description
Public method | GetBytes | Gets the parameter value as byte[].
Public method | Set(Byte) | Set raw parameter value.
Public method | Set(Double) | Set Double parameter value.
Public method | Set(Int32) | Set Int32 parameter value.
Public method | Set(String) | Set String parameter value.
Public method | Set(UInt32) | Set UInt32 parameter value.
Public method | ToDouble | Gets the parameter value as double.
Public method | ToInt32 | Gets the parameter value as Int32.
Public method | ToString | Get the parameter value as string. (Overrides ObjectToString.)
Public method | ToUInt32 | Gets the parameter value as UInt32.
Top
See Also

Reference

Vector.Diagnostics Namespace

(C) 2008-2013 Vector Informatik GmbH


Value Methods

Value Methods

The Value type exposes the following members.

Methods
 | Name | Description
Public method | GetBytes | Gets the parameter value as byte[].
Public method | Set(Byte) | Set raw parameter value.
Public method | Set(Double) | Set Double parameter value.
Public method | Set(Int32) | Set Int32 parameter value.
Public method | Set(String) | Set String parameter value.
Public method | Set(UInt32) | Set UInt32 parameter value.
Public method | ToDouble | Gets the parameter value as double.
Public method | ToInt32 | Gets the parameter value as Int32.
Public method | ToString | Get the parameter value as string. (Overrides ObjectToString.)
Public method | ToUInt32 | Gets the parameter value as UInt32.
Top
See Also

Reference

Value Class


Value.GetBytes Method

ValueGetBytes Method
Gets the parameter value as byte[].

Namespace: Vector.Diagnostics
Assembly: Vector.Diagnostics (in Vector.Diagnostics.dll) Version: 5.4 Beta2
Syntax
C#
VB
Copy
public byte[] GetBytes()
Public Function GetBytes As Byte()

Return Value

Type: Byte
Parameter value as byte[].
Exceptions
Exception | Condition
DiagnosticException | DiagnosticException is thrown if the parameter data type is not a byte array.
See Also

Reference

Value Class


Value.Set Method

ValueSet Method
Overload List
 | Name | Description
Public method | Set(Byte) | Set raw parameter value.
Public method | Set(Double) | Set Double parameter value.
Public method | Set(Int32) | Set Int32 parameter value.
Public method | Set(String) | Set String parameter value.
Public method | Set(UInt32) | Set UInt32 parameter value.
Top
See Also

Reference

Value Class


Value.Set Method (Byte[])

ValueSet Method (Byte)
Set raw parameter value.

Namespace: Vector.Diagnostics
Assembly: Vector.Diagnostics (in Vector.Diagnostics.dll) Version: 5.4 Beta2
Syntax
C#
VB
Copy
public bool Set(
    byte[] valueBytes
)
Public Function Set (
    valueBytes As Byte()
) As Boolean

Parameters

valueBytes
Type: SystemByte
byte[] parameter value.

Return Value

Type: Boolean
True if value has been set, false otherwise.
Remarks
Ensure that the data type of the parameter is a byte array.
See Also

Reference

Value Class
Set Overload


Value.Set Method (Double)

ValueSet Method (Double)
Set Double parameter value.

Namespace: Vector.Diagnostics
Assembly: Vector.Diagnostics (in Vector.Diagnostics.dll) Version: 5.4 Beta2
Syntax
C#
VB
Copy
public bool Set(
    double doubleValue
)
Public Function Set (
    doubleValue As Double
) As Boolean

Parameters

doubleValue
Type: SystemDouble
Double parameter value.

Return Value

Type: Boolean
True if value has been set, false otherwise.
Remarks
Ensure that the data type of the parameter is 'double'.
See Also

Reference

Value Class
Set Overload


Value.Set Method (Int32)

ValueSet Method (Int32)
Set Int32 parameter value.

Namespace: Vector.Diagnostics
Assembly: Vector.Diagnostics (in Vector.Diagnostics.dll) Version: 5.4 Beta2
Syntax
C#
VB
Copy
public bool Set(
    int intValue
)
Public Function Set (
    intValue As Integer
) As Boolean

Parameters

intValue
Type: SystemInt32
Int32 parameter value.

Return Value

Type: Boolean
True if value has been set, false otherwise.
Remarks
Ensure that the data type of the parameter is 'integer'.
See Also

Reference

Value Class
Set Overload


Value.Set Method (String)

ValueSet Method (String)
Set String parameter value.

Namespace: Vector.Diagnostics
Assembly: Vector.Diagnostics (in Vector.Diagnostics.dll) Version: 5.4 Beta2
Syntax
C#
VB
Copy
public bool Set(
    string stringValue
)
Public Function Set (
    stringValue As String
) As Boolean

Parameters

stringValue
Type: SystemString
String parameter value.

Return Value

Type: Boolean
True if value has been set, false otherwise.
Remarks
Ensure that the data type of the parameter is a string.
See Also

Reference

Value Class
Set Overload


Value.Set Method (UInt32)

ValueSet Method (UInt32)
Set UInt32 parameter value.

Namespace: Vector.Diagnostics
Assembly: Vector.Diagnostics (in Vector.Diagnostics.dll) Version: 5.4 Beta2
Syntax
C#
VB
Copy
public bool Set(
    uint uintValue
)
Public Function Set (
    uintValue As UInteger
) As Boolean

Parameters

uintValue
Type: SystemUInt32
UInt32 parameter value.

Return Value

Type: Boolean
True if value has been set, false otherwise.
Remarks
Ensure that the data type of the parameter is 'unsigned integer'.
See Also

Reference

Value Class
Set Overload


Value.ToDouble Method

ValueToDouble Method
Gets the parameter value as double.

Namespace: Vector.Diagnostics
Assembly: Vector.Diagnostics (in Vector.Diagnostics.dll) Version: 5.4 Beta2
Syntax
C#
VB
Copy
public double ToDouble()
Public Function ToDouble As Double

Return Value

Type: Double
parameter value as double.
Exceptions
Exception | Condition
DiagnosticException | DiagnosticException is thrown if the parameter data type is not a double.
See Also

Reference

Value Class


Value.ToInt32 Method

ValueToInt32 Method
Gets the parameter value as Int32.

Namespace: Vector.Diagnostics
Assembly: Vector.Diagnostics (in Vector.Diagnostics.dll) Version: 5.4 Beta2
Syntax
C#
VB
Copy
public int ToInt32()
Public Function ToInt32 As Integer

Return Value

Type: Int32
Int32 parameter value.
Exceptions
Exception | Condition
DiagnosticException | DiagnosticException is thrown if the parameter data type is not an integer.
See Also

Reference

Value Class


Value.ToString Method

ValueToString Method
Get the parameter value as string.

Namespace: Vector.Diagnostics
Assembly: Vector.Diagnostics (in Vector.Diagnostics.dll) Version: 5.4 Beta2
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
parameter value as string.
Exceptions
Exception | Condition
DiagnosticException | DiagnosticException is thrown if the parameter data type is not a string.
See Also

Reference

Value Class


Value.ToUInt32 Method

ValueToUInt32 Method
Gets the parameter value as UInt32.

Namespace: Vector.Diagnostics
Assembly: Vector.Diagnostics (in Vector.Diagnostics.dll) Version: 5.4 Beta2
Syntax
C#
VB
Copy
public uint ToUInt32()
Public Function ToUInt32 As UInteger

Return Value

Type: UInt32
UInt32 parameter value.
Exceptions
Exception | Condition
DiagnosticException | DiagnosticException is thrown if the parameter data type is not an unsigned integer.
See Also

Reference

Value Class


VariantSelectionResult Enumeration

VariantSelectionResult Enumeration
The result of a call to SelectVariant(String).

Namespace: Vector.Diagnostics
Assembly: Vector.Diagnostics (in Vector.Diagnostics.dll) Version: 5.4 Beta2
Syntax
C#
VB
Copy
public enum VariantSelectionResult
Public Enumeration VariantSelectionResult
Members
Member name | Value | Description
NotInitialized | 0 | In case no result was assigned yet.
Success | 1 | The variant was selected successfully.
VariantDoesNotExist | 2 | The variant does not exist within the diagnostic description.
VariantSelectionNotPossible | 3 | E.g. CANoe restriction
See Also

Reference

Vector.Diagnostics Namespace

(C) 2008-2013 Vector Informatik GmbH


WaitResult Enumeration

WaitResult Enumeration
The result codes of a waiting operation.

Namespace: Vector.Diagnostics
Assembly: Vector.Diagnostics (in Vector.Diagnostics.dll) Version: 5.4 Beta2
Syntax
C#
VB
Copy
[SerializableAttribute]
public enum WaitResult
<SerializableAttribute>
Public Enumeration WaitResult
Members
Member name | Value | Description
Aborted | -1 | Waiting operation aborted, i.e. SendResult is not available.
Timeout | 0 | Timeout occurred during wait operation. In TimeOut case no responses were received, i.e. the transaction is not completed yet and therefore the SendResult object does not contain any responses.
Success | 1 | Wait operation was successful, i.e. the transaction is completed and the SendResult object contains the responses.
See Also

Reference

Vector.Diagnostics Namespace

(C) 2008-2013 Vector Informatik GmbH