NI 에러 리포트 도움말

2017년 1월판, 373371D-0129

NI 에러 리포트를 통해 NI로 충돌이나 내부 경고 리포트를 보낼 수 있습니다. NI는 소프트웨어 개선을 위해 이 리포트를 사용합니다. 충돌 또는 내부 경고 리포트에 관련 파일, 사용자 의견 및 이메일 주소를 첨부할 수 있습니다. NI는 충돌 또는 내부 경고 재현에 필요한 파일을 모두 첨부하도록 권장합니다.

노트 노트
  • NI 에러 리포트를 통해 NI로 리포트와 사용자 이메일 주소를 보내는 경우, 보내는 즉시 기술 지원을 받을 수 있는 것은 아닙니다. 충돌 또는 내부 경고 해결에 도움이 필요하면, NI 기술 지원부에 문의하십시오.
  • 보내기 버튼이 비활성화된 경우, 관리자에게 문의하십시오.

NI 에러 리포트 대화 상자에서 볼 수 있는 용어

NI 에러 리포트 대화 상자에서 볼 수 있는 용어는 다음과 같습니다.
  • 예외―OS가 감지한 내부 에러.
  • (LabVIEW) DAbort—LabVIEW 내부 에러. 내부 에러 (DAbort)가 발생하면 메모리의 VI가 손상될 위험이 있기 때문에 LabVIEW가 계속 실행될 수 없습니다. NI 에러 리포트 대화 상자에서, 내부 에러 (DAborts)는 에러 코드와 관련이 있습니다. 내부 에러 발생 원인에 대해 알아보려면 ni.com에서 이 에러 코드를 검색합니다.
  • (LabVIEW) DWarn—LabVIEW 내부 경고. 내부 경고 (DWarn) 발생 시 LabVIEW는 계속 실행되며, 다만 이 정보가 내부 경고 리포트에 기록됩니다.

리포트 이해하기

리포트를 NI로 보내기 전에 확인하려면, NI 에러 리포트 대화 상자에서 리포트 보기를 클릭합니다.

NI 에러 리포트는 컴퓨터에서 각 프로세스 또는 제품의 리포트 중 마지막 20개를 저장합니다. 충돌 또는 내부 경고 리포트는 다음 디렉토리에서 찾을 수 있습니다.

  • (LabVIEW) LabVIEW Data\LVInternalReports\LabVIEW\<버전>\<리포트 ID>
  • (MAX) C:\ProgramData\National Instruments\MAX\Logs\MAX\<리포트 ID>
  • (다른 모든 NI 제품) %LocalAppData%\National Instruments\<제품 이름>\ErrorReports\<버전>\<리포트 ID>

<버전> 및 <리포트 ID>는 NI 에러 리포트 대화 상자에서 찾을 수 있습니다.

충돌이나 내부 경고 리포트는 다음을 포함합니다.

  • 내부 경고, 에러, 예외의 최소 프로세스 덤프 파일. 에러 코드와 함께 충돌 또는 내부 경고와 관련된 기타 정보를 포함.
  • 충돌 또는 내부 경고에 대한 추가 세부사항이 포함된 텍스트 파일
  • NI 에러 리포트 대화 상자에 입력한 의견 및 E-메일 주소가 포함된 또 다른 텍스트 파일
  • (옵션) NI 에러 리포트 대화 상자에 첨부한 Zip 파일

리포트 전송 중 에러 발생의 이유

코드 | 설명
0x80002012 | National Instruments 서버에 연결하는 중 타임아웃이 발생하였습니다. 다시 시도를 클릭하여 리포트 보내기를 다시 시도합니다. 충돌 또는 내부 경고 리포트를 보내는 동안 계속 에러가 발생하면, National Instruments 기술 지원부에 문의하십시오.
0x80002011 | 리포트를 보내는데 5분 이상이 소요되어 타임아웃이 발생하였습니다. 리포트의 크기가 너무 크거나 네트워크 연결 속도가 느립니다. 다시 시도를 클릭하여 리포트 보내기를 다시 시도합니다.
0x80002001 | 방화벽 또는 다른 네트워크 셋팅으로 인해 리포트를 보낼 수 없습니다. 모든 소프트웨어 방화벽을 비활성화하거나 네트워크 관리자에게 연락하십시오.
0x8000200C | 이 리포트를 보내려면 프록시 인증이 필요합니다. 네트워크 관리자에게 문의하십시오.
0x80008002 | National Instruments 서버에 접속할 수 없습니다. 다시 시도를 클릭하여 리포트 보내기를 다시 시도합니다. 충돌 또는 내부 경고 리포트를 보내는 동안 계속 에러가 발생하면, National Instruments 기술 지원부에 문의하십시오.
0x80008001, 0x80008003, 0x80008004, 0x80008005, 0x80008006, 0x80008007, 0x8000200A | National Instruments 서버가 이 리포트를 받을 수 없습니다. 다시 시도를 클릭하여 리포트 보내기를 다시 시도합니다. 충돌 또는 내부 경고 리포트를 보내는 동안 계속 에러가 발생하면, National Instruments 기술 지원부에 문의하십시오.
노트 노트 모든 다른 에러 코드는 다음과 같은 설명을 반환합니다: 이 리포트를 보내는 중에 에러가 발생했습니다.다시 시도를 클릭하여 리포트 전송을 다시 시도합니다.에러 또는 경고 리포트를 보내는 동안 계속 에러가 발생하면, National Instruments 기술 지원부에 문의하십시오.

충돌 시 프로그램 다시 시작

<제품 이름> 다시 시작 확인란을 사용하면 충돌 알리기 대화 상자를 닫은 후에 제품이 다시 시작됩니다.

제품은 .EXE 파일을 더블 클릭하거나 명령 라인 인수를 전달하는 등 이전에 시작된 방식으로 다시 시작됩니다.

프로그램이 다시 시작하지 않는 이유

<제품 이름> 다시 시작 확인란이 비활성화되어 있거나 다음의 이유로 제품을 다시 시작할 수 없는 경우일 수 있습니다.

  • 이전에 프로그램을 시작할 때 사용한 전체 명령 라인 인수의 총 길이가 255자를 초과합니다.
  • (LabVIEW) LabVIEW 2011을 사용하고 있습니다.
  • (LabVIEW) LabVIEW 런타임 엔진을 사용하고 있습니다.

(LabVIEW) LabVIEW 런타임 엔진의 NI 에러 리포트

LabVIEW 런타임 엔진에서, NI 에러 리포트는 내부 에러 (DAbort) 또는 예외가 감지되는 경우 충돌 대화 상자를 디스플레이합니다. 그러나 NI에 리포트를 보내는 옵션은 없습니다. 충돌 대화 상자에는 LabVIEW와 같은 소프트웨어 어플리케이션의 이름 대신 프로세스 이름을 제품 이름으로 보여줍니다. NI 에러 리포트는 내부 경고 (DWarns)의 최소 프로세스 덤프 파일을 생성하지만, 어플리케이션을 닫을 때 내부 경고 알리기 대화 상자는 나타나지 않습니다.

© 2011-2017 National Instruments. 판권 소유.


NI 서비스

NI는 고객의 성공을 위해 전세계적인 서비스 및 지원을 제공합니다. 교육, 인증 프로그램 뿐 아니라 어플리케이션 계획, 개발부터 배포와 유지에 이르기까지 제품 주기의 각 단계마다 사용자의 요구를 충족시키기 위해 제공하는 다양한 제품 서비스를 활용하십시오.

먼저 ni.com/myproducts에서 계정을 생성하거나, 계정이 있는 경우 MyNI 사용자 프로파일에 로그인하여 제품을 등록합니다.

NI 제품을 등록한 사용자는 다음과 같은 혜택을 받을 수 있습니다.

  • 제품별로 제공되는 서비스 사용 가능.
  • 온라인 계정을 사용하여 손쉽게 제품 관리.
  • 중요한 부품 알림 사항, 소프트웨어 업데이트 및 서비스 만료 공지 수신.

서비스 및 리소스

  • 제품 유지 보수 및 하드웨어 서비스―NI는 사용자가 시스템이 요구하는 정확도와 신뢰성을 파악할 수 있도록 지원하고, 보증, 교정 서비스를 제공하여 시스템의 수명 동안 정확도를 유지하고 가동 중단 시간을 최소화하도록 합니다. 더 자세한 정보는 ni.com/services를 방문하여 참조하십시오.
    • 보증 및 수리—모든 NI 하드웨어는 기본으로 1년 간 보증되며, 보증 기간은 최대 5년까지 연장이 가능합니다. 또한 NI는 NI 서비스 센터를 통해 숙련된 전문 기술자가 정품만을 사용하여 빠른 시간 안에 수리를 완료하는 수리 서비스를 제공합니다.
    • 교정—정기적인 교정을 통해 인스트루먼트의 측정 성능을 수치화하고 개선할 수 있습니다. NI는 최신의 교정 서비스를 제공합니다. 사용하는 제품이 교정을 지원하는 경우, ni.com/calibration에서 제품에 대한 교정 확인증을 얻을 수 있습니다.
  • 시스템 통합—시간의 제약, 제한된 사내 기술 리소스 또는 다른 프로젝트상의 문제점이 있는 경우, National Instruments Alliance Partner 회원사가 도움을 드릴 수 있습니다. 더 자세한 정보는 가까운 NI 사무소에 연락하시거나 ni.com/alliance를 방문하십시오.
  • 교육 및 인증―NI 교육 및 인증 프로그램은 어플리케이션 개발 능력 및 생산성을 향상시킬 수 있는 가장 좋은 방법을 제공합니다. 더 자세한 정보는 ni.com/training를 방문하여 참조하십시오.
    • Skills Guide를 사용하여 현재 개발 중인 어플리케이션이 어느 수준의 실력을 필요로 하는지 파악하고, 개인의 스케쥴 및 예산, 선호하는 학습 방법에 따라 실력을 향상시킬 수 있는 여러 옵션을 선택할 수 있습니다. ni.com/skills-guide 페이지에서 이러한 옵션을 볼 수 있습니다.
    • NI의 교육 과정은 여러 언어로 실시되고 있으며, 전세계의 여러 기관에서 실시되는 강사가 직접 강의하는 실습 코스를 비롯하여, 방문 교육, 온라인 교육 과정등 개개인의 다양한 필요를 충족시킬 수 있는 여러가지 형태의 강의를 제공하고 있습니다.
  • 지원―ni.com/support의 기술 지원은 다음의 리소스를 포함합니다.
    • 셀프 도움말 리소스—ni.com/support에서 소프트웨어 드라이버와 업데이트, 검색 가능한 기술지원 데이터베이스, 제품 매뉴얼, 단계별 문제해결 마법사, 수많은 예제 프로그램, 길라잡이, 어플리케이션 노트, 인스트루먼트 드라이버를 검색하고 사용할 수 있습니다. 또한, 등록된 사용자는 ni.com/forums의 NI 토론방을 이용할 수 있습니다. NI 어플리케이션 엔지니어가 온라인상으로 제출된 모든 질문에 대해 답변을 제공합니다.
    • 소프트웨어 지원 서비스 멤버쉽―NI Developer Suite를 비롯하여 대부분의 NI 소프트웨어 제품은 1년 간의 스탠다드 서비스 프로그램(SSP) 회원권이 포함되며, 회원권은 갱신 가능합니다. 멤버쉽 회원은 NI 어플리케이션 엔지니어와 전화나 E-메일을 통해 일대일로 기술 지원을 받고, ni.com/self-paced-training에서 자가 온라인 학습을 이용할 수 있습니다. NI는 또한 계약 기간을 유연하게 연장할 수 있는 옵션을 제공하여 고객이 필요한 만큼 중단없이 SSP 혜택을 사용할 수 있도록 합니다. 더 자세한 정보는 ni.com/ssp를 방문하여 참조하십시오.
  • 적합성 선언 (DoC: Declaration of Conformity)—DoC는 제조업체의 적합성 선언을 사용하여 Councile of the European Communities에 따른다는 준수 선언입니다. 이 시스템은 전자파 적합성(EMC)과 제품 안전에 대한 사용자 보호를 제공합니다. ni.com/certification을 방문하여 제품에 대한 DoC를 얻을 수 있습니다.

각 지역의 기술 지원 옵션에 대한 추가적인 정보는 ni.com/services를 방문하거나 ni.com/contact에서 가까운 National Instruments 사무소에 연락하십시오.

또한 ni.com/niglobal의 Worldwide Offices 섹션을 방문하여 최신 연락 정보, 지원 전화번호, E-메일 주소 및 이벤트 정보를 제공하는 각 사무소의 웹사이트에 접속할 수 있습니다.