NI エラーレポートヘルプ

2017年1月、373371D-0112

NI エラーレポートを使用すると、NIにクラッシュレポートまたは内部警告レポートを送信できます。レポートは、今後のソフトウェアの改善に使用されます。クラッシュレポートまたは内部警告レポートには、関連するファイル、コメント、およびEメールアドレスを添付できます。NIでは、クラッシュや内部警告の再現に必要なすべてのファイルを添付することを推奨しています。

メモ メモ
  • NI エラーレポートを使用して、Eメールアドレスを添付してNIにレポートを送信しても、即時技術サポートを受けることはできません。クラッシュまたは内部警告の解決については、技術サポートまでご連絡ください。
  • 送信ボタンが無効になっている場合は、管理者に連絡してください。

NI エラーレポートダイアログボックスに表示される用語

NI エラーレポートダイアログボックスには、以下の用語が表示されることがあります。
  • Exception―オペレーティングシステムが検出する内部エラーです。
  • （LabVIEW） DAbort―LabVIEW内部エラーです。内部エラー(DAbort)が発生した場合は、メモリ内のVIが破損する恐れがあるためLabVIEWは実行を継続できません。NI エラーレポートダイアログボックスには、(DAborts)に関連するエラーコードが表示されます。そのエラーコードをni.comで検索すると、内部エラーの原因を特定できる可能性があります。
  • （LabVIEW） DWarn―LabVIEW内部警告です。内部警告(DWarn)が発生してもLabVIEWは実行を継続できますが、内部警告レポートに情報がログされます。

レポートを理解する

NIに送信する前にレポートを表示するには、NI エラーレポートダイアログボックスのレポートを表示をクリックします。

NI エラーレポートは、コンピュータ上のプロセスまたは製品ごとに最近の20個のレポートを保存します。クラッシュまたは内部警告のレポートは、以下のディレクトリにあります。

  • （LabVIEW） LabVIEW Data\LVInternalReports\LabVIEW\<バージョン>\<レポートID>
  • （MAX） C:\ProgramData\National Instruments\MAX\Logs\MAX\<レポートID>
  • （他のすべてのNI製品） %LocalAppData%\National Instruments\<製品名>\ErrorReports\<バージョン>\<レポートID>

<バージョン>および<レポートID>は、NI エラーレポートダイアログボックスにあります。

クラッシュおよび内部警告レポートには以下の情報が含まれます。

  • エラーコードやクラッシュ/内部警告に関するその他の情報が含まれている、内部警告、エラー、および例外の最小プロセスダンプファイル
  • クラッシュ/内部警告に関する詳細が記述されたテキストファイル
  • NI エラーレポートダイアログボックスに入力されたコメントやメールアドレスが記述された2つ目のテキストファイル
  • （オプション）NI エラーレポートダイアログボックスに添付するZipファイル

レポート送信エラーの原因として考えられる理由

コード | 説明
0x80002012 | ナショナルインスツルメンツのサーバへの接続時にタイムアウトになりました。再試行をクリックして、レポートを再度送信してください。クラッシュまたは内部警告レポートの送信でエラーが続く場合は、ナショナルインスツルメンツの技術サポートまでお問い合わせください。
0x80002011 | レポートの送信に5分以上かかったためにタイムアウトになりました。これは、レポートが大きすぎたり、ネットワーク接続が遅い場合に発生する場合があります。再試行をクリックして、レポートを再度送信してください。
0x80002001 | ファイアウォールまたはその他のネットワーク設定が原因でこのレポートは送信されませんでした。ソフトウェアファイアウォールをすべて無効にするか、ネットワーク管理者に連絡してください。
0x8000200C | このレポートを送信するには、プロキシ認証が必要です。ネットワーク管理者に連絡してください。
0x80008002 | ナショナルインスツルメンツのサーバが使用できません。再試行をクリックして、レポートを再度送信してください。クラッシュまたは内部警告レポートの送信でエラーが続く場合は、ナショナルインスツルメンツの技術サポートまでお問い合わせください。
0x80008001、0x80008003、0x80008004、0x80008005、0x80008006、0x80008007、および0x8000200A | ナショナルインスツルメンツのサーバはこのレポートを受け付けることができません。再試行をクリックして、レポートを再度送信してください。クラッシュまたは内部警告レポートの送信でエラーが続く場合は、ナショナルインスツルメンツの技術サポートまでお問い合わせください。
メモ メモ この他のすべてのエラーコードは以下の説明を返します。このレポートを送信中にエラーが発生しました。再試行をクリックし、レポートを再度送信してください。エラーまたは警告レポートの送信でエラーが続く場合は、ナショナルインスツルメンツの技術サポートまでお問い合わせください。

クラッシュ時に製品を再起動する

<製品名>を再起動チェックボックスをオンにすると、クラッシュレポートダイアログボックスを閉じた後に製品が再起動されます。

製品は、前回起動した方法（.EXEファイルまたはコマンドラインでの引数渡し）と同じ方法で起動されます。

製品が再起動できない理由

<製品名>を再起動チェックボックスが無効になっており、製品が再起動されない場合は、以下の理由が考えられます。

  • 前回製品を起動したときに使用したコマンドライン引数の長さが255文字を超えている。
  • （LabVIEW）LabVIEW 2011を使用している。
  • （LabVIEW）LabVIEWランタイムエンジンを使用している。

（LabVIEW）LabVIEWランタイムエンジンでのNI エラーレポート

LabVIEWランタイムエンジンでは、(DAbort)または例外が検出されると、NI エラーレポートはクラッシュダイアログボックスを表示します。ただし、NIにレポートを送信するオプションは表示されません。クラッシュダイアログボックスには、製品名としてLabVIEWなどのソフトウェアアプリケーションの名前ではなく、プロセス名が表示されます。NI エラーレポートは、内部警告(DWarns)に対して最小プロセスダンプファイルを作成しますが、アプリケーションを閉じた時に内部警告レポートダイアログボックスは表示されません。

© 2011–2017 National Instruments. All rights reserved.


NIサービス

NIは、お客さまを成功に導く手助けとしてグローバルサービスとサポートを提供しています。デプロイメントや継続的メンテナンスにおける計画から開発などの、アプリケーションライフサイクルの各段階で役立つトレーニングおよび認定プログラムに加え、製品サービスもご利用ください。

製品のサービスを利用するには、アカウントを作成するか、ni.com/myproductsで自分のMyNIユーザプロファイルにログインして、お客様の製品をご登録ください。

登録されているNI製品をご使用のユーザには次の特典があります。

  • 適用される製品のサービスへのアクセス。
  • オンラインアカウントによる簡単な製品管理。
  • 製品に関する重要な通知、ソフトウェア更新、サービス期限の通知を受信。

サービスとリソース

  • メンテナンスとハードウェアサービス―NIは、ご使用のシステムの確度および信頼性の要件を確認する手助けや、製品の寿命期間にわたって確度を維持し、ダウンタイムを最小限に抑えることができるように、保証や予備製品およびキャリブレーションサービスを提供しています。詳細については、ni.com/servicesをご覧ください。
    • 保証と修理―すべてのNIハードウェア製品には、5年まで延長可能な1年の標準保証が提供されています。NIの修理サービスは、高度な訓練を受けた技術者によりNIサービスセンターで迅速に行われ、修理に際しては純正部品のみを使用しています。
    • キャリブレーション―標準のキャリブレーションを通じて、計測器の測定性能を定量化および改善することができます。NIでは、最新式のキャリブレーションサービスを提供しています。ご使用の製品でキャリブレーションがサポートされている場合は、ni.com/calibrationからその製品のCalibration Certificateを入手できます。
  • システムインテグレーションー時間の制約がある場合や社内の技術リソースが不足している場合、またはプロジェクトに関連する問題がある場合、ナショナルインスツルメンツのアライアンスパートナーによるサービスをご利用いただけます。詳細はNIオフィスにお電話いただくか、ni.com/allianceをご覧ください。
  • トレーニングと認定―NIのトレーニングおよび認定プログラムは、アプリケーション開発の習熟度と生産性を高める最も効果的な方法です。詳細については、ni.com/trainingをご覧ください。
    • 「NI LabVIEWスキルガイド」は、現在のアプリケーションの習熟度要件の確認を手助けし、これらのスキルを習得するための時間や予算の制約と個人的な学習方法の好みに合ったオプションを提供しています。これらのカスタムパスを確認するには、ni.com/skills-guideを参照してください。
    • NIでは、お客様のニーズに応じて、講師による各国の施設でのクラスや、お客様の施設で行う出張コース、およびオンラインコースなど、複数の言語および形式のコースを提供しています。
  • サポート―技術サポート（ni.com/support）には以下のリソースがあります。
    • セルフヘルプリソース―質問に対する回答やソリューションが必要な場合は、ナショナルインスツルメンツのウェブサイト（ni.com/support）でソフトウェアドライバとアップデート、検索可能な技術サポートデータベース、製品マニュアル、トラブルシューティングウィザード、種類豊富なサンプルプログラム、チュートリアル、アプリケーションノート、計測器ドライバなどをご利用いただけます。ユーザ登録されたお客様は、NIディスカッションフォーラム（ni.com/jp/dforum）にアクセスすることもできます。NIのアプリケーションエンジニアは、お客様からのご質問すべてにお答えしています。
    • ソフトウェアサポートサービスメンバーシップ―標準サポート・保守プログラム（SSP）は、NI Developer Suiteを含む大部分のNIソフトウェア製品に含まれる、毎年更新が必要なプログラムです。このプログラムでは、NIのアプリケーションエンジニアによる電話またはEメールでの個別サポートが提供されます。また、SSPの特典を必要な限り中断なく利用できる柔軟な延長契約オプションもご利用いただけます。詳細については、ni.com/sspをご覧ください。
  • 適合宣言（DoC）―適合宣言とは、適合宣言書によるさまざまな欧州閣僚理事会指令への適合宣言です。この制度により、電磁両立性（EMC）に対するユーザ保護や製品の安全性に関する情報が提供されます。ご使用の製品の適合宣言は、ni.com/certificationから入手できます。

ご利用の地域のその他の技術サポートのオプションについては、ni.com/jp/servicesをご覧いただくか、またはni.com/contactから最寄の営業所までお問い合わせください。

また、弊社ウェブサイトのWorldwide Officesセクション（ni.com/niglobal（英語））から各支社のウェブサイトにアクセスすることもできます。各支社のサイトでは、お問い合わせ先、サポート電話番号、Eメールアドレス、現行のイベントなどに関する最新情報を提供しています。