NI错误报告帮助

2017年1月，373371D-0118

NI错误报告将程序崩溃或内部警告发送给NI。NI通过报告对软件进行改进。可将相关文件、注释以及您的电子邮件地址随错误报告一并发送。要重现程序崩溃和内部错误，应该附上所有的相关文件。

注 注
  • 通过NI错误报告发送错误和您的电子邮件地址，不表示可立即获得NI的技术支持。如需解决程序崩溃或内部错误，请联系NI技术支持。
  • 如发送按钮被禁用，请联系管理员。

NI错误报告对话框的术语

NI错误报告对话框中可能会出现下列术语：
  • 异常－操作系统检测到的内部错误。
  • (LabVIEW) DAbort－LabVIEW内部错误。发生内部错误(DAbort)时，LabVIEW无法继续运行，因为继续运行可能会损坏内存中的VI。在NI错误报告对话框中，内部错误(DAborts)有对应的错误代码。可在ni.com上搜索错误代码，查看可能导致内部错误的原因。
  • (LabVIEW) DWarn－LabVIEW内部警告。发生内部警告(DWarn)时，LabVIEW仍可继续运行，但会在内部警告报告中记录信息。

了解报告

向NI发送报告之前如需查看报告，可单击NI错误报告对话框中的查看报告。

NI错误报告会在计算机上存储每个进程或产品的最近20个错误报告。可在下列目录中找到程序崩溃或内部警告报告：

  • (LabVIEW) LabVIEW Data\LVInternalReports\LabVIEW\<版本>\<报告ID>
  • (MAX) C:\ProgramData\National Instruments\MAX\Logs\MAX\<报告ID>
  • （其他所有NI产品）%LocalAppData%\National Instruments\<产品名称>\ErrorReports\<版本>\<报告ID>

<版本>和<报告ID>可在NI错误报告对话框中找到。

程序崩溃和内部警告包括：

  • 内部警告、错误和异常的最小进程转储文件，其中包含错误代码及与程序崩溃或内部警告有关的其他信息
  • 包含程序崩溃或内部警告的其他细节信息的文本文件
  • NI错误报告对话框中输入的注释、电子邮箱地址的文本文件
  • （可选）随附于NI错误报告的压缩文件

发送报告时可能引起错误的原因

代码 | 说明
0x80002012 | 连接National Instruments服务器发生超时。单击重试，再次发送报告。如发送程序崩溃或内部警告时仍有错误发生，请联系NI技术支持获取帮助。
0x80002011 | 报告发送超过5分钟，发生超时。如报告过大或连接过慢，都会发生该错误。单击重试，再次发送报告。
0x80002001 | 防火墙或其他网络设置阻止发送报告。禁用防火墙软件或联系网管。
0x8000200C | 发送报告必须通过代理验证。请联系网管。
0x80008002 | National Instruments服务器暂时不可用。单击重试，再次发送报告。如发送程序崩溃或内部警告时仍有错误发生，请联系NI技术支持获取帮助。
0x80008001, 0x80008003, 0x80008004, 0x80008005, 0x80008006, 0x80008007, 0x8000200A | National Instruments服务器无法接收报告。单击重试，再次发送报告。如发送程序崩溃或内部警告时仍有错误发生，请联系NI技术支持获取帮助。
注 注：其他所有错误代码均返回下列说明信息：发送报告时产生错误。请单击重试，再次发送报告。如发送错误或警告报告时仍遇到错误，请联系NI技术支持获取帮助。

崩溃后重新启动产品

勾选重新启动<产品名称>复选框可在关闭崩溃报告器对话框后重新启动产品。

产品的重新启动方式与最近一次启动方式相同，例如，双击.EXE文件或传入命令行参数。

产品无法重新启动的原因

下列原因可能会导致重新启动<产品名称>复选框被禁用且产品无法重新启动：

  • 最近一次用于启动产品的命令行参数总字符数量超过255个。
  • (LabVIEW) 使用LabVIEW 2011。
  • (LabVIEW) 使用LabVIEW运行引擎。

(LabVIEW) LabVIEW运行引擎中的NI错误报告

在LabVIEW运行引擎中检测到内部错误(DAbort)或异常时，NI错误报告将打开崩溃对话框。但是，无法将该报告发送至NI。崩溃对话框中显示的产品名称为进程的名称，而不是LabVIEW等应用程序的名称。NI错误报告将为内部警告(DWarns)创建最小进程转储文件，但关闭应用程序时不会出现内部警告报告器对话框。

© 2011–2017 National Instruments. 版权所有


NI服务

NI提供全球服务和支持，致力于帮助客户成功。除培训和认证项目之外，用户还可根据自身需求，在应用程序生命周期的每个阶段利用NI的产品服务，包括筹备开发、部署及当前维护的相关服务。

用户首先需要访问ni.com/myproducts，创建一个账号或登录MyNI用户账号，并注册产品。

NI产品的注册用户享有以下权益：

  • 享受产品的相关服务。
  • 通过账户轻松管理所购买的产品。
  • 接收关键部件更新、软件更新和服务到期提醒。

服务和资源

  • 维护和硬件服务－在整个系统生命周期中，NI帮助用户确定系统的精度和可靠性要求，并提供保修、替换和校准服务，从而帮助用户维护精度并将系统故障降至最低。详细信息请访问ni.com/services。
    • 保修和维修－所有NI硬件的标准保修期均为一年，保修期最多可延长至五年。NI提供及时维修服务，维修由受过专业训练的工厂技术人员在NI服务中心全部使用原厂配件完成。
    • 校准－定期校准有助于量化并提高仪器的测量性能。NI提供最先进的校准服务。如产品支持校准服务，可访问ni.com/calibration获取校准证书。
  • 系统集成－NI联盟伙伴可帮助解决时间限制、内部技术资源短缺或其他项目问题。详情请致电当地NI办事处或登录网站ni.com/alliance。
  • 培训与认证－NI培训和认证项目是提高应用开发熟练度和效率的最佳方式。详细信息请访问ni.com/training。
    • 技能指南可帮助用户确定当前应用的熟练度要求，并根据时间、预算限制和个人学习兴趣提供学习这些技能的选项。详细信息请访问ni.com/skills-guide。
    • NI提供多种语言和形式的培训课程，包括世界各地NI分支机构举办的面授培训、上门培训以及在线课程，满足不同客户的需求。
  • 技术支持－技术支持ni.com/support包括以下资源：
    • 自助技术资源－请访问ni.com/support，查阅有关软件驱动和更新、可搜索的知识库、产品手册、疑难解答向导、数千个范例程序、产品教程、应用指南、仪器驱动等相关信息。注册用户还可访问NI论坛ni.com/forums。NI的应用工程师可确保您在线提交的所有问题得到解答。
    • 软件支持服务成员－标准服务项目(SSP)是可续订的一年制订阅服务，几乎每个NI软件产品均包含该服务，包括NI Developer Suite。标准服务项目成员可通过电话或email直接获取NI应用工程师的一对一技术支持，以及ni.com/self-paced-training提供的专享自选在线培训模块。NI还为您提供了各种续期服务，保证您在会员资格到期后能继续享受SSP的各种权益。详细信息请访问ni.com/ssp。
  • 合规声明(DoC)－DoC是NI对符合欧盟委员会要求所作的合规声明。该系统可确保电子产品的电磁兼容性(EMC)和安全性。请访问ni.com/certification获取产品的合规声明。

如需了解更多当地的技术支持服务，请访问ni.com/services或ni.com/contact与当地办事处联系。

您也可以访问ni.com/niglobal的全球办事处页面查找最新的办事处联系方式、技术支持电话、电子邮件地址及最新消息。