使用 WCF 测试客户端 (WcfTestClient.exe)

Windows Communication Foundation (WCF) 测试客户端 (WcfTestClient.exe) 是一个 GUI 工具，通过使用该工具，用户可以输入测试参数、将该输入提交给服务并查看服务发回的响应。 当与 WCF 服务主机结合时，它可以提供完美的服务测试体验。

使用测试客户端的方案

以下各节讨论了使用 WCF 测试客户端简化开发流程的最常见方案。

WCF 服务主机启动 WCF 测试客户端和一项服务

在创建新的 WCF 服务项目并按 F5 启动调试器后，WCF 服务主机将开始承载项目中的服务。 然后 WCF 测试客户端将会打开，并显示在配置文件中定义的服务终结点列表。 可以测试参数和调用服务，并可以重复此过程以继续测试和验证服务。

WCF 服务主机启动 WCF 测试客户端和多项服务

也可以使用 WCF 测试客户端来帮助调试包含多项服务的服务项目。 打开 WCF 测试客户端时，它将自动循环访问项目服务列表并打开这些服务进行测试。

WCF 测试客户端用户界面

可以将 WCF 测试客户端用于一项或多项服务。

服务操作

WCF 测试客户端主窗口的左窗格列出了所有可用的服务及其各自的终结点和操作。

如果双击某项操作，则可以在右窗格中查看其内容。 左窗格还列出了客户端配置文件。 双击任何项可以在新选项卡式窗口内的右窗格中显示文件的内容。

输入测试参数

若要查看测试参数，请双击某项操作以在右窗格中打开它，然后单击“已格式化”。 若要查看消息的 XML，请单击“XML”。 如果单击“已格式化”，则可以输入任意参数值以测试服务。 若要将它们发送给服务，请单击“调用”。

注意:
当操作处于调用进程中时，可以切换到另一个操作或终结点以查看参数。 但是，在当前操作完成之前，无法编辑或调用另一个操作。

服务响应将出现在测试参数下面。

注意:
如果预期的返回值是字符串，则结果将显示为带引号的字符串，即使提供的输入未包含在引号中，也是如此。

如果在创建服务约定时将特定操作指定为单向操作，则不会显示服务响应。 消息一旦处于排队等待发送状态，则会弹出一个对话框，通知您已成功发送消息。

查看客户端配置

WCF 测试客户端主窗口的左窗格列出了客户端配置文件。 单击任何项可以在右窗格中显示文件的内容。

WCF 测试客户端支持的功能

下面是 WCF 测试客户端支持的功能的列表：

  • 类型：Byte、SByte、Int16、Int32、Int64、UInt16、UInt32、UInt64、Single、Double、Boolean、Char、Decimal、Object、String、DateTime、DateTimeOffset、TimeSpan、Guid、Uri、XmlQualifiedName、Byte 对象的数组、Array、集合、枚举、复杂类型和子类型。

  • 服务调用：请求/响应和单向消息。

  • 绑定：Svcutil.exe 支持的所有绑定。

下面是 WCF 测试客户端不支持的功能的列表：

  • System.Nullable<T>

  • 具有的参数类型或返回类型为 Message 的操作协定。

  • 双工协定

  • 控制会话

  • 事务

  • 消息协定和 XML 序列化

  • 类型：Stream、Dataset 或相关的类型，以及 IDictionary 对象的集合。

  • 安全交互：Window CardSpace、证书和用户名/密码。

  • 绑定：WSFederationbinding、任何上下文绑定和 Https 绑定。

关闭 WCF 测试客户端

可以通过以下方式关闭 WCF 测试客户端：

  • 在“文件”菜单上单击“退出”。 或者，在 WCF 测试客户端主窗口中单击“关闭”。 这两种操作还将关闭 WCF 服务自动主机并停止 Visual Studio 调试进程。

  • 右击通知区域中的“WCF 服务主机”图标，然后单击“退出”。 这将关闭 WCF 服务自动主机和 WCF 测试客户端并停止 Visual Studio 调试进程。

版权所有 (C) 2007 Microsoft Corporation。保留所有权利。