关于 Access Web 数据表

Access Web 数据表提供了一个类似于 Excel 的环境，用于查看和编辑数据。它在由行和列构成的网格中显示列表或文档库的内容。列表中的项目和列在 Access Web 数据表中显示为行和列。可以添加和编辑行和列、应用筛选和执行排序、显示计算值和总计等等。

下图显示了 Access Web 数据表中的雇员列表：

标注 1 一行对应一个列表项目。

标注 2 一列对应一个列表域。

标注 3 列标题中的下拉箭头用于对数据进行筛选和排序。

标注 4 “汇总”行用于显示每一列的合计值。

返回页首

在 Access Web 数据表中查看列表

在 Access Web 数据表中可以查看大多数类型的列表。可使用两种方式查看：

  • 在“普通”视图中打开列表，然后在功能区的“列表”选项卡中单击“在数据表中编辑”切换到“数据表”视图。

    注意 如果“普通”视图不支持在“数据表”视图中执行编辑，“在数据表中编辑”命令就会处于不可用状态。例如，文档库的“资源管理器”视图不支持在“数据表”视图中执行编辑。

  • 通过创建“数据表”视图。请注意，可将“数据表”视图设置为列表的默认视图。

“数据表”视图独立于列表的其他所有视图。如果是从“普通”视图添加或删除列，所做更改不会影响“数据表”视图。

下面是一些不支持“数据表”视图的列表类型。

  • 讨论板
  • 调查
  • 图像库
  • Web 模板库
  • Web 部件目录
  • 数据源
  • 收件箱

返回页首

Access Web 数据表中的列表的组成部分

行 一个 Access Web 数据表包含一或多个行。每一行都存储着与列表中某个项目有关的信息。例如，雇员列表中的一个行存储着与某个雇员有关的信息。

可通过滚动到列表的底部并在星号 (*) 行输入数据来添加行。还可编辑或删除某一行。在您离开该行后，您的更改会被发送给服务器并异步提交。您可继续对不同的行做更改，而视图会在后台提交您的更改。如果更改导致冲突或错误，则会使用所需的信息来更新视图以解决冲突或错误。

可以基于一列或多列更改行高、排序行，及通过应用筛选隐藏行。

列 一个视图包含一列或多列。每一列存储视图中所有项目的某个特定类型的信息。例如，雇员列表中的“姓名”列存储雇员的姓名。

可在“数据表”视图或标准视图中将某一列添加到列表中。列必须具有名称，且必须是特定的数据类型。如果您不希望用户在输入数据时跳过某一列，则可以将该列标记为“必填”。还可指定其他列设置，如默认值和最大长度。有关如何将列添加到列表中的详细信息，请参阅 Microsoft SharePoint Foundation 2010 帮助。若要显示 Microsoft SharePoint Foundation 2010 帮助，请单击“帮助”( 帮助图标)。

可修改某个现有列或删除某一列。通过显示或隐藏列、重排列、调整宽度及根据列值筛选和排序行可自定义列的外观。还可将计算列添加到列表中。

“数据表”组 功能区中“列表”选项卡下的“数据表”组中显示用于在“数据表”视图中执行常见任务的命令，例如：显示任务窗格或添加新行。

状态栏 视图底部的状态栏显示一些有用信息。例如：

  • 错误消息或警告消息
  • 特定于当前选定内容的信息，例如“只读”。
  • 服务器通信状态

任务窗格 任务窗格使您无需离开“数据表”视图，就可方便、快捷的访问某些操作。

下面的图示显示一个示例列表的任务窗格：

标注 1 在该窗格的顶部是工具栏。它显示常用命令的按钮，例如“剪切”、“复制”、“粘贴”、“排序”和“帮助”。

标注 2 单击“网纹”条可隐藏或显示任务窗格。拖动该条可调整窗格的大小。

标注 3 悬停在滚动条上可在垂直方向滚动窗格。

标注 4 窗格的内部显示各种命令。

返回页首

使用 Access Web 数据表的软件要求

要在 Access Web 数据表中查看列表，计算机必须满足一系列的软件要求。

返回页首


Access Web Datasheet 的软件要求

要在 Access Web Datasheet 中打开列表，必须满足下列要求：

  • 在计算机上安装 32 位 Microsoft Office 2010 版本。
  • 在计算机上安装随 Office 2010 提供的 Microsoft Office Access Web Datasheet 组件。

    注意 默认情况下，该组件在安装 Office 2010 时安装。

  • 使用 Microsoft Internet Explorer 6.0 或更高版本打开列表。
  • 确保浏览器中的安全设置支持 Microsoft ActiveX 控件。

如果不符合上述一种或多种要求，将看到一条消息，该消息指出该列表将在“普通”视图中显示。为“数据表”视图指定的设置（如列顺序、排序和筛选以及“汇总”行设置）将在列表显示之前应用于“标准”视图。但是，诸如行高、列宽和隐藏列之类的设置将被忽略。

请注意，即使不符合上述所有要求，也可以对“数据表”视图进行更改。所做的更改将被保存，下次使用符合上述所有软件要求的计算机时，将会看到这些更改所产生的效果。


显示产品信息和计算机信息

可通过打开“关于”对话框来显示您的计算机上安装的 Microsoft Office Access Web Datasheet Component 的版本、产品 ID 号、系统信息和其他相关信息。

  • 右键单击列表的左上角，再单击“关于”。


在 Access Web Datasheet 中获取帮助

  • 要在 Access Web Datasheet 中获取帮助，请右键单击“数据表”视图内的任何单元格，然后单击“帮助”。

    要点 Access Web Datasheet 帮助主题仅包含“数据表”视图中可用的功能。若要获取 SharePoint 列表的一般帮助信息，请单击“帮助”( 帮助图标)。

  • 若要获取有关包含“数据表”视图的 SharePoint 页面的帮助，请单击“帮助”( 帮助图标)。
  • 要在“数据表”视图中显示“列表视图 Web 部件”时获取帮助，请单击“Web 部件”菜单，然后单击“帮助”。帮助主题包含 Web 部件页、Web 部件属性和 Web 部件连接。

注释

  • 一些对话框和状态栏消息包含指向上下文相关帮助信息的链接。还可单击任务窗格工具栏上的“帮助”( “帮助”图标)。
  • 如果“数据表”视图处于活动状态，按 F1 将显示有关“数据表”视图的帮助。否则，将显示 Internet Explorer 帮助。


Access Web Datasheet 疑难解答

我在 Access Web Datasheet 中打不开列表，或者列表在标准视图中打开

看不到视图中的任何数据，或者只看到视图中的部分数据

消息显示“列表/视图不存在”

消息显示“您没有权限”

消息显示“无法显示或添加附件”

消息显示“无法刷新列表”

消息显示“视图中缺少必需的域”

视图为只读视图，或者视图的某些部分是只读的

我在 Access Web Datasheet 中打不开列表，或者列表在标准视图中打开

这可能是由于下列原因之一引起的：

  • 您的计算机不满足显示 Access Web Datasheet 的所有软件要求。
    • 未安装与 SharePoint Foundation 2010 兼容的数据表组件。
    • 您的浏览器不支持 ActiveX 控件。
    • 安装的 64 位 Microsoft Office 不支持数据表视图。
    • 已禁用对 ActiveX 控件的支持。
  • 如果列表或当前视图不支持数据表视图，则功能区中的“数据表视图”选项将灰显。例如，不支持在数据表视图中查看幻灯片库。
  • 访问有关列表结构或视图定义的信息时发生错误。请尝试刷新视图。

返回页首

看不到视图中的任何数据，或者只看到视图中的部分数据

如果看不到视图中的任何数据，可能是因为服务器正忙或找不到服务器，或者发生了其他一些错误。请关闭列表，稍后再尝试查看该列表。

由于下列一种或多种原因而看不到视图中的某些行或列：

  • 应用了筛选，或者将筛选指定为视图定义的一部分。

    要检查视图中是否应用了筛选，请确保列标题中的下拉箭头显示正常。如果某一列已被筛选，则该列标题中的下拉箭头将显示为不同的颜色。在某些显示器上，可能很难看出颜色差异。

    若要检查是否已将筛选指定为视图定义的一部分，请在功能区中的“列表”选项卡下，单击“修改此视图”。在“编辑视图”页上的“筛选”部分，检查是否已应用筛选。

  • 列被隐藏，或者列未包含在视图定义中。

    要显示所有隐藏的列，请右键单击视图左上角的单元格，然后单击“取消隐藏”。

    若要检查视图中是否包括某一列，请在功能区中的“列表”选项卡下，单击“修改此视图”。在“编辑视图”页上的“列”部分，检查是否已选中“显示”复选框。若要在视图中包含此列，请选中该复选框。

  • 列表需要内容审批，某些项目或所有项目仍然待定或已被拒绝。

    要检查项目的审批状态，请在“视图”下拉列表中单击“我的提交”。查看“审批状态”和“备注”列。如果某个项目被拒绝，则对该项目进行编辑。该项目将被设置为“待定”并被发送以再次进行审批。

返回页首

消息显示“列表/视图不存在”

列表或“数据表”视图不存在。可能是因为已被其他用户删除。请验证列表和视图是否存在，然后重试。

返回页首

消息显示“您没有权限”

这可能是由于下列原因之一引起的：

  • 不具有进行更改所需的必要权限。
  • 将内容添加到网站时被阻止。
  • 已超出网站的存储限制。
要避免这些错误，请与您的系统管理员联系。

返回页首

消息显示“无法显示或添加附件”

这可能是因为服务器出现了错误。请稍后尝试添加或查看附件。

返回页首

消息显示“无法刷新列表”

由于服务器错误，视图不能得到刷新。请单击“是”以重试。如果错误再次出现，请单击“否”，稍后再试。

返回页首

消息显示“视图中缺少必需的域”

视图中未包含一个或多个标记为必需的列。行的必需列中必须有非空值，才能将该行提交到服务器。

因为视图中不包含一个或多个必需列，所以不能执行下列操作：

  • 添加新行。
  • 如果行的某个必需列中有空值，则请对该行进行编辑。

    注意 标记为必需的列不接受空值。但是，如果随后将未标记为必需的列修改为需要非空值，则该列可能包含空值。因此，将列的设置从“可选”更改为“必需”时，应编辑“数据表”视图中的列表，以确保每一行的列中都有非空值。

要避免出现此消息，请将必须填写的字段添加到视图中，或者与列表的作者联系。

返回页首

视图为只读视图，或者视图的某些部分是只读的

这可能是因为多种原因中的一种引起的。有关详细信息，请单击状态栏上的“只读”链接。

返回页首


将“数据表”视图设置为默认视图

首次创建列表时，默认情况下会为该列表定义一个新的标准视图。若要更改为“数据表”视图，可在功能区中的“列表工具”下，单击“列表”，然后单击“数据表视图”。但是，如果要使“数据表”视图成为列表的默认视图，必须先为该列表创建一个新“数据表”视图，然后将该视图设置为默认视图。

要为列表创建新“数据表”视图并将其设置为默认视图，请执行下列操作：
  1. 在功能区中，单击“列表”选项卡，然后单击“创建视图”。
  2. 在“创建视图”页上的“选择视图格式”下，单击“数据表视图”。
  3. 在“创建数据表视图”页上，键入该视图的名称。可能需要在视图名称中包括“数据表”一词，以帮助您记住该视图是“数据表”视图。
  4. 选中“将此项设为默认视图”复选框。
  5. 确保已选中“创建公共视图”选项，以便其他访问者可以看到该视图。
  6. 在页面底部，单击“确定”。
要将现有的“数据表”视图设置为默认视图，请执行下列操作：
  1. 在功能区中，单击“列表”选项卡，然后单击“列表设置”。
  2. 在“列表设置”页上的“视图”下，单击要设置为默认视图的视图的名称。
  3. 在“编辑视图”页上的“名称”部分，选中“将此项设为默认视图”复选框。

    注意 如果已将该视图设置为默认视图，或者已将其设置为个人视图，则看不到该复选框。


显示、隐藏任务窗格或调整任务窗格的大小

  • 若要显示或隐藏任务窗格，请在功能区上，单击“列表”选项卡，然后在“数据表”组中，单击“显示任务窗格”。
  • 要调整任务窗格的大小，请将光标定位在窗格左侧的“网纹”条上。当光标变为调整大小的光标时，单击并向左或向右拖动。


键盘快捷方式

使用快捷键可以快速访问经常使用的命令或操作。下列主题列出了 Access Web Datasheet 中可用的快捷键。也可以使用访问键而不是鼠标将焦点移动到视图的其他部分。

选择视图的各个部分

执行命令

编辑数据

设置支持 Rich HTML 文本的单元格的格式

排序和筛选数据

选择视图的各个部分

要执行此操作 | 请按
从左到右，然后向下移动所选区域。如果选中多个单元格，则将焦点移动到所选区域中的下一个单元格。 | Tab
从上到下，然后向右移动所选区域。如果选中多个单元格，则将焦点移动到所选区域中的下一个单元格。 | Enter
从右到左移动所选区域。如果当前的单元格在最左端，则按 Shift+Tab 将选中前一行的最后一个单元格。 | Shift+Tab
选择当前单元格上面的单元格。如果当前单元格在最顶端，则按 Shift+Enter 将选中前一列的最后一个单元格。 | Shift+Enter
沿箭头键的方向移动所选区域。 | 箭头键
按箭头键的方向扩展或缩小所选区域。 | Shift+箭头键
按箭头键的方向将所选区域移动到最后一个单元格。如果在该方向上存在空白单元格，则移动到在第一个空白单元格之前的最后一个单元格。 | Ctrl+箭头键
按箭头键的方向将所选区域扩展到最后一个单元格。如果在该方向上存在空白单元格，则将所选区域扩展到在第一个空白单元格之前的最后一个单元格。 | Ctrl+Shift+箭头键
选中当前行中的第一个单元格。 | Home
选中第一行中的第一个单元格。 | Ctrl+Home
选中最后一行中的最后一个单元格。 | Ctrl+End
将所选区域扩展到当前行的行首。 | Shift+Home
将所选区域扩展到当前行的行尾。 | Shift+End
将所选区域扩展到列表的起始位置。 | Ctrl+Shift+Home
将所选区域扩展到列表的末尾。 | Ctrl+Shift+End
将所选区域扩展到整列。 如果选中单元格中的文本，并且该列支持 Rich HTML 格式，则清除格式。 | Ctrl+空格键
将所选区域扩展到整行。 | Shift+空格键
选择整个列表。 | Ctrl+A
滚动到下一个列表页。 | Page Down
显示上一个列表页。 | Page Up
将所选区域向下扩展一页。 | Shift+Page Down
将所选区域向上扩展一页。 | Shift+Page Up
滚动以显示当前单元格。 | Ctrl+BackSpace

返回页首

执行命令

要执行此操作 | 请按
显示当前所选内容的快捷菜单。 | Shift+F10
执行包含带下划线字母的快捷菜单命令。 | 快捷菜单上带下划线的字母
撤消尚未提交的对行所做的更改。 如果显示快捷菜单，则关闭快捷菜单而不执行命令。 在编辑模式下，取消编辑模式，并放弃更改。 | Esc
如果“数据表”视图处于活动状态，并且未处于编辑模式下，则显示“数据表”视图帮助。否则显示 Internet Explorer 帮助。 | F1
进入编辑模式。 | F2
清除当前单元格。 | Delete
显示任务窗格。 | F8
隐藏任务窗格。 | Shift+F8
将所选内容复制到剪贴板中。 | Ctrl+C
粘贴剪贴板中的内容。 | Ctrl+V
将所选内容移动到剪贴板中。 | Ctrl+X
显示“解决冲突和错误”对话框。 | F7
关闭浏览器窗口。 | Alt+F4

返回页首

编辑数据

要执行此操作 | 请按
撤消对当前单元格所做的更改。 | Ctrl+Z
插入无间断连字符。 | Ctrl+Shift+-
在“汇总”行中，显示对当前单元格可用的聚合函数的列表。在单行文本类型的列中，显示列中现有值的列表。 | Alt+向下键

返回页首

设置支持 Rich HTML 文本的单元格的格式

要执行此操作 | 请按
将焦点移动到字体列表。 | Ctrl+Shift+F
将焦点移动到字号列表。 | Ctrl+Shift+P
对所选内容应用加粗样式。 | Ctrl+B
为所选内容添加下划线。 | Ctrl+U
将所选内容设置为倾斜。 | Ctrl+I
将所选内容调整为左对齐。 | Ctrl+L
将所选内容调整为居中。 | Ctrl+E
将所选内容调整为右对齐。 | Ctrl+R
为所选内容添加项目符号。 | Ctrl+Shift+L
增加缩进量。 | Ctrl+M
减少缩进量。 | Ctrl+Shift+M
清除当前单元格中的 Rich HTML 文本格式。 | Ctrl+空格键

返回页首

排序和筛选数据

要执行此操作 | 请按
为所选列显示筛选下拉列表。 | Alt+Shift+向下键
关闭筛选下拉列表。 | Alt+Shift+向上键
移动到筛选下拉列表中的上一个项目（显示该列表时）。 | 向上键
移动到筛选下拉列表中的下一个项目（显示该列表时）。 | 向下键
移动到筛选下拉列表中的第一个项目（显示该列表时）。 | Home
移动到筛选下拉列表中的最后一个项目（显示该列表时）。 | End
在筛选下拉列表中向上或向下移动一页（显示该列表时）。 | Page Up、Page Down
执行筛选下拉列表中的所选项目（显示该列表时）。 | Enter

返回页首


Access Web Datasheet 如何检索并更新数据？

在 Access Web Datasheet 中编辑数据要比在“普通”视图中编辑数据快得多。

在标准视图中，一次只能编辑一个项目。并且只有将已编辑的项目提交到服务器后，才能编辑下一个项目。

在 Access Web Datasheet 中可以对某一行进行更改，然后移到下一行开始编辑该行中的单元格。视图会将所做的更改发送到服务器并返回状态信息，不需要中断您的工作。

异步更新

异步数据检索

异步更新

当您添加或编辑某一行时，Access Web Datasheet 会将相应的更改发送到服务器，将该行标记为待定，并且在行标题中显示“待定”（ “待定”图标 ）图标。如果某一行含有待定更改，则在提交这些更改以前不能对该行进行编辑。但是，在将上一组更改发送到服务器的同时，您可以继续编辑其他各行。

当该视图从服务器获取响应时，它会相应地更新该行。如果编辑导致冲突或错误，则行标题会显示“冲突”( “冲突”图标) 图标或“错误”( “错误”图标) 图标。如果成功地提交编辑，则会删除“待定”图标，且可编辑该行。

也会非同步地将对视图定义的更改（如更改列的顺序或隐藏“汇总”行）发送到服务器。但是，当存在待定更改时，不能进行结构更改或编辑计算列。必须在更改结构或编辑某个计算列之前，等待所有更改都被提交并解决任何产生的冲突或错误。

如果存在待定更改时试图刷新视图或离开视图，则系统会提示您等待直到提交所有更改。根据服务器响应，随后将能够解决任何冲突或错误。

返回页首

异步数据检索

在 Access Web Datasheet 中打开某个列表时，它会检索前 100 行，并异步检索剩余的行。当视图仍在从服务器获取数据时，状态栏会显示“正在搜索数据”。如果试图对数据进行筛选或排序，则必须等到列表从服务器检索出所有必要的数据，才能查看筛选或排序的结果。

如果服务器忙，找不到，或者如果发生使视图不能检索所需的行的其他任何错误，则该视图会显示一个错误。

返回页首


选择单元格、行、列或列表

选择单个单元格

  • 单击该单元格，或按箭头键移动到该单元格。

    注意 如果单击包含超链接的单元格，则会导航到相应的 Web 地址。若要选择包含超链接的单元格，请使用键盘快捷方式之一。

选择单元格的内容

  • 选择该单元格，单击单元格内部，再选择该单元格中的文本。

选择单元格区域

  • 单击区域的第一个单元格，再拖动鼠标到最后一个单元格。或者，单击区域的第一个单元格，再按住 Shift 并单击区域中的最后一个单元格。

注意 可以先滚动到最后一个单元格所在的位置。

选择某一行或某一列

  • 单击行或列标题。

选择多行或多列

  • 单击第一行或第一列的标题，然后拖动鼠标至最后一行或最后一列。或者，先选择第一行或第一列，再按住 Shift 并选择最后一行或最后一列。


添加多值选项栏

您可以使用多值选项栏从选项列表中一次选择多个项目。例如，在任务跟踪列表中，您可以为每项任务分配多个人。将此栏添加到列表时输入可能的选项。

添加多值选项栏

  1. 右键单击此列表中的任意栏标题或任意单元格，然后单击“添加列”。
  2. 在“名称和类型”下，输入该栏的名称，然后单击“选项”。
  3. 在“其他栏设置”下，键入要显示在该栏中的选项，然后单击“复选框(允许多重选择)”。
  4. 设置所需的任何其他选项，然后单击“确定”。

要在查看数据表时使用多值选项栏，请单击单元格中的下拉箭头，然后选中或清除要在单元格中添加或删除的每个值旁边的复选框。

编辑多值选项栏中的选项列表

要在多值选项栏中添加、编辑或删除项目，请按照以下过程操作：

  1. 右键单击要编辑的栏中的栏标题或任意单元格，然后单击“编辑/删除列”。
  2. 在“其他栏设置”下，编辑选项列表。
  3. 设置所需的任何其他选项，然后单击“确定”。

使用多值选项栏

要使用多值选项栏，请按照以下过程操作：

  1. 单击要编辑的单元格中的下拉箭头。
  2. 选中或清除要在单元格中添加或删除的每个项目旁边的复选框。
  3. 单击“确定”。

选中的选项显示在单元格中，用分号 (;) 分隔。


添加多值查阅栏

您可以使用多值查阅栏从选项列表中一次选择多个项目。例如，在任务跟踪列表中，您可以为每项任务分配多个人。查阅栏中的值来自当前列表中的现有栏或者其他列表中的现有栏。

添加多值查阅栏

  1. 右键单击此列表中的任意栏标题或任意单元格，然后单击“添加列”。
  2. 在“名称和类型”下，输入该栏的名称，然后单击“查阅项(此网站已有的信息)”。
  3. 在“其他栏设置”下，从“信息来源”下拉列表中选择包含查阅栏中所需的值的列表。
  4. 从“此栏包含”下拉列表中选择包含这些值的栏。
  5. 选择“允许多个值”。
  6. 设置所需的任何其他选项，然后单击“确定”。

要在查看数据表时使用多值查阅栏，请单击单元格中的下拉箭头，然后选中或清除要在单元格中添加或删除的每个值旁边的复选框。

编辑多值查阅栏中的选项列表

由于多值查阅栏中的项目来自当前列表中的其他栏或其他列表中的某一栏，因此您必须编辑查阅栏所基于的列表。例如，如果查阅栏基于任务列表的标题栏，则必须编辑任务列表以更改查阅栏中的值。

使用多值查阅栏

要使用多值查阅栏，请按照以下过程操作：

  1. 单击要编辑的单元格中的下拉箭头。
  2. 选中或清除要在单元格中添加或删除的每个项目旁边的复选框。
  3. 单击“确定”。

选中的选项显示在单元格中，用分号 (;) 分隔。


添加行或列

添加行

默认情况下，在列表的最后一行之后显示星号 (*) 行，即行标题中用星号 (*) 标记的空白行。可以使用此行向列表中添加新项。

注意 不能在两个现有行之间插入一个空白行。如果视图为只读，则不会显示星号行。

若要添加行，请执行以下任一步骤：

  • 如果看不到空白行，请右键单击任意单元格，然后单击“添加行”，或者
  • 在功能区中，单击“列表”选项卡，然后在“数据表”组中，单击“新行”。

添加列

  1. 在列表中右键单击某个单元格。
  2. 单击“添加列”。
  3. 在“创建列”页中，指定该列的详细信息，然后单击“确定”。

    新列被添加到现有列的右边。要将该列移到新位置，只需将该列的列标题拖到所需位置即可。


更改列宽

  1. 右键单击列标题，再单击“列宽”。
  2. 在“列宽”对话框中，键入 1 到 255 之间的一个数字。

注释

  • 如果指定宽度为 0，则该列将会隐藏。
  • 还可在列标题的右侧拖动边框，直到列达到所需的宽度。若要调整列的大小使每个单元格的内容在单行中以最适合的列宽显示，请将光标移动至列标题的右边框。当调整大小的光标出现时，请双击边框线。


更改行高

  1. 右键单击某个行标题，再单击“行高”。
  2. 在“行高”对话框中，键入 1 到 409 之间的一个数字。

注释

  • 更改某一行的高度会更改列表中所有行的高度。
  • 还可以拖动行标题的顶端或底端边框，直到行达到所需的高度。若要调整行的大小以使内容完全可见，请将光标移动到行标题的底端边框。当调整大小的光标出现时，请双击边框线。


删除行或列

删除行

  1. 单击要删除的行的行标题。

    注意 若要删除多行，请单击第一行的标题，再拖动到最后一行。或者选中第一行，然后按住 Shift 并选择最后一行。

  2. 右键单击所选内容，再单击“删除行”。

可以将已删除的行放入网站回收站，也可以根据需要还原到列表中。有关如何使用回收站的详细信息，请单击“帮助”( 帮助图标) 以打开 Microsoft SharePoint Foundation 2010 中的“帮助”。

删除列

  1. 右键单击要删除的列的列标题，再单击“编辑/删除列”。
  2. 在“更改列”页上，单击“删除”。

注释

  • 被删除的列不会放入回收站中，它们将被永久删除。
  • 一次仅可删除一列。如果选中多个列中的单元格，则会将包含活动单元格的列作为选中的列。
  • 如果列为只读，则无法删除。也不能删除某个特定类型的列表中的列，因为这些列是列表正常工作所必需的。


对列进行修改

可以更改列的名称、说明和数据类型或与数据类型有关的设置。

  1. 右键单击要修改的列中的单元格，然后单击“编辑/删除列”。
  2. 在“更改栏”页面上，进行更改，然后单击“确定”。

注释

  • 一次只能修改一列。如果选中多个列中的单元格，则将把包含活动单元格的列作为所选列。
  • 如果列为只读，则无法修改列。


对列进行重排

“数据表”视图提供一种快速简便的方法以更改列的顺序。

  1. 若要移动某一列，请将鼠标指针放到要移动的列的标题上，直到看到移动指针 ( 移动指针)。

    要移动某个列区域，请单击第一列的标题，然后按住 Shift 键，同时单击该区域中的最后一列。将指针放到包含所选列的矩形的一侧以显示移动指针。

  2. 单击并将所选列拖动到新的位置。

移动列时，会自动更新视图定义。

注意 不能移动行。可以通过排序重新排列行。


显示或隐藏列

显示隐藏的列

列标题右边较粗的竖线表示隐藏了该列旁边的列。

  • 若要取消隐藏的列，请选择隐藏的列两边任意一个可见的列，并右键单击所选的列，然后单击“取消隐藏”。
  • 若要取消列表中隐藏的所有列，请右键单击列表的左上角，然后单击“取消隐藏”。

隐藏列

  • 若要隐藏列，请右键单击要隐藏的列的标题，然后单击“隐藏”。


查看多行文本栏中以前的条目

您可以配置“多行文本”栏以便当您编辑该栏中的数据时，以前的条目将保留而不是被覆盖。通过使用此功能，您可以保留该栏中以前条目的记录：更改时间和更改者。

创建新的仅限附加的栏

  1. 右键单击列表中的任意单元格并单击“添加栏”。
  2. 在“栏名”框中键入此栏的名称，然后单击“多行文本”。
  3. 在“其他栏设置”下的“追加对现有文本所做的更改”下，单击“是”。
  4. 进行所需的任何其他更改，然后单击“确定”。

    新栏将添加到现有栏的右侧。要将该栏移动到新的位置，请将其栏标题拖动到您想要的位置。

将现有栏修改为仅限附加

  1. 右键单击要修改的栏的栏标题，然后单击“编辑/删除栏”。
  2. 如果该栏还不是多行文本数据类型，请单击“多行文本”。如果此选项不可用，则不能修改该栏的数据类型，您必须新建一栏才能使用“追加更改”选项。
  3. 在“其他栏设置”下的“追加对现有文本所做的更改”下，单击“是”。
  4. 进行所需的任何其他更改，然后单击“确定”。

查看仅限附加的栏中以前的条目

Access Web 数据表单元格中只显示仅限附加的栏中最新的条目。要查看以前的条目，请执行下列操作：

  • 右键单击要查看其以前条目的单元格，然后单击“查看条目”。

    Microsoft SharePoint Foundation 2010 显示此项目的所有数据，包含仅限附加的栏中以前的条目。


关于数据类型

有关数据类型的帮助，请参阅 Microsoft SharePoint Foundation 2010 帮助。

若要显示 Microsoft SharePoint Foundation 2010 帮助，请单击 SharePoint 页上的“帮助”( 帮助图标)。


为列指定默认值

可以为单行、选项、数字、货币或日期和时间类型的列指定默认值。默认值会自动显示在所有新行的该列中。可以保留单元格中的默认值，或者在任何时候编辑它。

  1. 右键单击列，再单击“编辑/删除列”。
  2. 在“默认值”下，选择下列各项之一：
    • “文本” 如果列类型为“单行文本”，请指定某个字符串作为默认值。
    • “选项” 如果列类型为“选项”，请从上面指定的选项列表中指定其中一个选项。
    • “数字” 如果列类型为“数字”，请指定一个数值。
    • “货币” 如果列类型为“货币”，请指定一个货币值。
    • “当前日期” 如果列类型为“日期和时间”，且您希望默认值为当前日期，请选择此选项。
    • 任何日期 如果列类型为“日期和时间”，且您希望指定某个特定的日期，请选择最后一个选项按钮，然后按“年-月-日”格式输入日期。
    • “是”（在“默认值”框中）如果列类型为“是/否(复选框)”，且您希望默认情况下该复选框显示被选中，请选择“是”。
    • “计算值” 如果希望使用某个计算值作为默认值，请输入公式。注意公式不能引用列表中的其他列。


数据类型的疑难解答

有关与数据类型相关的疑难解答的帮助，请参阅 Microsoft SharePoint Foundation 2010 帮助。

若要显示 Microsoft SharePoint Foundation 2010 帮助，请单击“帮助”( 帮助图标)。


添加、编辑或删除单元格内容

一次只对一个单元格进行更改

可在编辑模式下添加、编辑或删除单元格内容。

  1. 如果还没有选中要编辑的单元格，请单击该单元格。

    注意 如果该单元格包含超链接，则会导航到相应的 Web 地址。

  2. 再次单击该单元格以进入编辑模式，然后对单元格进行更改。

    注意 也可按 F2 以进入编辑模式。

  3. 完成时请按 Tab 或 Enter。

注意 按 Ctrl+Z 可撤消上次对单元格所做的更改。按 Esc 可放弃对单元格所做的更改并退出编辑模式。

批量编辑单元格

可使用下列方法之一批量编辑单元格、行或列：

  • 通过复制和粘贴数据。
  • 通过拖动填充柄。


编辑超链接

此命令仅当所选单元格具有超链接时才可用。

  1. 右键单击具有超链接的单元格，指向“超链接”，再单击“编辑超链接”。
  2. 在“编辑超链接”对话框的“键入网站地址”文本框中键入有效的 URL。有效的 URL 必须以协议开头，如 http:// 或 ftp://，且不能超过 255 个字符。
  3. 在“键入说明”文本框中键入显示文本。


通过从值列表中选择值在单元格中输入数据

在一列单行文本单元格中输入数据时，可以通过两种方式为单元格选择值。

  • 单击要在其中输入数据的单元格。如果侧面出现下箭头，请单击该箭头，然后单击要为该单元格选择的值。

  • 开始在单元格中键入数据。将使用在该列中其他位置输入的数据与您已经键入的内容相匹配，然后在单元格中显示最接近的结果。当显示了正确值后，请按 Enter 以选择该值。


在列表内容被修改时得到通知

显示 当下列各项之一被更改时收到通知：行、文档或单元格

  1. 右键单击要启用通知的行标题或单元格，再单击“通知我”。
  2. 在“新建通知”页面上，指定要得到通知的方式和时间。

显示 在列表或文档库被更改时收到通知

  1. 右键单击列表或库的左上角，再单击“通知我”。
  2. 在“新建通知”页面上，指定要得到通知的方式和时间。


撤消更改

可以撤消尚未保存到列表的更改。当处于编辑模式时，可以撤消对当前单元格所做的更改。

  • 单击任务窗格工具栏上的“撤消”或按 CTRL+Z。

注释

  • 对于支持 Rich HTML 格式的单元格，每个格式设置命令都等同于编辑。
  • “撤消”命令与按下 Esc 退出编辑模式不同。
  • 将附件添加到记录或者从记录中删除附件之后，不能撤消对列表所做的更改。在保存行之后，不能撤消对该行所做的更改。


验证数据

有关验证数据的帮助，请参阅 Microsoft SharePoint Foundation 2010 帮助。

若要显示 SharePoint Foundation 2010 帮助，请单击“帮助”( 帮助图标)。


设置数据格式

如果列支持多行文本和 RTF 格式，则可设置该列内容的格式。

启用列对 RTF 格式的支持：

  1. 右键单击要为 RTF 格式启用的列，然后单击“编辑/删除列”。
  2. 在“名称和类型”下，选择“多行文本”（如果尚未选中）。
  3. 在“其他栏设置”下，选择“RTF (加粗、倾斜、文本对齐方式)”。
  4. 单击“确定”。

进行了这些设置后，便可对一个或多个单元格中的文本或只对一个单元格中的部分文本设置格式：

  1. 选择要设置格式的单元格或文本。
  2. 如果任务窗格未打开，请在功能区中单击“列表”选项卡，然后单击“显示任务窗格”。
  3. 应用所需的格式。可更改字体设置、文本和背景色以及缩进和对齐方式。还可将文本组织成带编号或项目符号的项目列表。

注释

  • 可通过选择文本，然后按 Ctrl+Space 来清除 RTF 格式。但是，Ctrl+Space 不能删除对齐方式设置。
  • 无法设置只读单元格或“汇总”行的格式。
  • 格式设置不会应用于通过筛选隐藏的行。


对列启用或禁用自动换行

对于某一列，如果启用自动换行，则以多行显示该列单元格中的内容。如果禁用自动换行，则仅以单行显示适合单元格大小的内容。默认情况下，对于所有列，自动换行都是启用的。

自动换行适用于下列数据类型：单行文本、多行文本、选项、个人或组、超链接或图片以及计算字段。

  • 右键单击要更改其设置的列标题，然后单击“禁用自动换行”或“启用自动换行”。


解决格式数据问题

在任务窗格中看不到格式按钮。

格式设置未应用于列中的所有行。

将文本复制到了多行文本列中，但格式设置无效。

得到一条有关单元格大小超出其最大值的消息。

在任务窗格中看不到格式按钮。

要启用文本的格式，该列必须支持多行文本和 RTF 格式。

启用列对 RTF 格式的支持：

  1. 右键单击要为 RTF 格式启用的列，然后单击“编辑/删除列”。
  2. 如果“多行文本”尚未指定为列类型，则在“更改列”页上的“名称和类型”部分，选择它。
  3. 在“其他栏设置”部分，选择“RTF (加粗、倾斜、文本对齐方式)”。
  4. 单击“确定”。

更改这些设置后，便可对一个或多个单元格中的文本或者只对一个单元格中的部分文本设置格式：

  1. 在功能区中，单击“列表”选项卡，然后在“数据表”组中，单击“显示任务窗格”。
  2. 选择要设置格式的单元格或文本。
  3. 在任务窗格中，使用 RTF 工具应用所需格式。可更改字体设置、文本和背景色以及缩进和对齐方式。还可将文本组织成带编号或项目符号的项目列表。

返回页首

格式设置未应用于列中的所有行。

当选择整列并应用格式时，“汇总”行和因筛选而隐藏的行将不能获得此格式设置。

返回页首

将文本复制到了多行文本列中，但格式设置无效。

这可能是因为源文本的格式未被列表完全识别。请确保源文本中不包括该列表不支持的格式。

若要查看哪些格式是受支持的，请在支持 RTF 格式的列中选择一个单元格，并浏览任务窗格中工具栏下的按钮。

返回页首

得到一条有关单元格大小超出其最大值的消息。

格式设置后的单元格包含有关格式设置的文本和信息。如果数据和格式设置的信息超出了单元格的最大大小值，您将会看到此消息。请尝试减少文本或应用到该文本的格式数量。

返回页首


关于筛选数据

筛选是提取并只显示符合特定条件的列表项的过程。通过对列表应用多个筛选器，您可以快速找到特定列表项。

例如，通过筛选“雇员”列表中“经理”列设置为“是”的雇员，可创建该列表的“经理”视图。可进一步筛选此列表，以查看“国家/地区”列设置为“美国”和“省/市/自治区”列设置为“加利福尼亚”的经理。下图显示在加利福尼亚工作的经理。

注意“省/市/自治区”和“国家/地区”列标题中下拉箭头的外观。

当切换视图或关闭“经理”视图时，将不会保存“国家/地区”和“省/市/自治区”筛选器。下次在“经理”视图中打开该列表时，该列表将显示所有经理。

可通过两种方式对列表应用筛选器：

  • 可以在“数据表”视图中对列表应用筛选器。当您导航到其他页面时该筛选器将重置，下次要查看相同结果时，必须重新应用该筛选器。
  • 指定筛选器作为视图定义的一部分时，将保存筛选条件，并且每次在指定的视图中打开列表时，都会应用这些筛选条件。

多行文本和超链接类型的列或图片不支持筛选。对于附件类型的列，可筛选“是”和“否”值。对于多选项类型的列，将包括包含所选值的单元格。


应用筛选

  1. 单击列标题中的下拉箭头。

    注意 如果某个列不支持筛选，则会对该列禁用筛选命令。

  2. 在列表中，请执行下列操作之一：
    • 单击某个单元格值以筛选具有匹配值的记录。对于多选项列，将会选中包含所选值的记录。
    • 单击“(空白)”以筛选没有值的记录。
    • 单击“(非空白)”以筛选有值的记录。
    • 单击“(自定义筛选...)”以自定义筛选条件。在“自定义筛选”对话框中，指定比较运算符和值。例如，若要搜索以“A”或“B”开头的名称，请在左上方列表中选择“始于”并在右上方列表中键入“A”。在左侧中部列表中选择“始于”并在右侧中部列表中键入“B”。选择顶端的“或”运算符以将这两个条件链接起来，然后单击“确定”。
  3. 单击“(全部显示)”可从该列中删除筛选器。

注意 可在视图中筛选和排序多个列。


取消筛选或排序顺序

若要查看列是否已筛选，请单击该列标题中的下拉箭头。如果列应用了筛选，则会在下拉列表中选中除“全部显示”之外的某个条目。

显示 从列中取消筛选

  1. 单击列标题中的下拉箭头。
  2. 单击列表中的“全部显示”。

显示 取消所有筛选和排序顺序

  • 在任务窗格的工具栏上，单击“取消筛选/排序”。


对行进行排序

排序用于按所需顺序排列列表中的项目。此操作在尝试查找特定条目或确定特定条目分组时很有用。

可通过两种方式对列表进行排序

  • 在“数据表”视图中时可以对列表进行排序。当您导航到其他页面时，排序将被重置，如果下次想要查看相同结果，则必须重新应用排序。
  • 指定排序作为视图定义的一部分时，将保存排序条件，并且每次在指定的视图中打开列表时，都会应用这些排序条件。

对单列进行排序

  1. 单击列标题中的下拉箭头。
  2. 单击“升序排序”或“降序排序”。
  3. 您可以对其他列重复此过程，以便更精确地组织列表。

一次对多列进行排序

对多列进行排序时，列的排序顺序决定数据的组织方式。通常，必须先对最重要的信息进行排序。例如，要按字母顺序列出每个部门的员工，必须按部门对每个人分组。因此，应首先对“部门”列进行排序，然后对“员工”列进行排序。

  1. 在功能区中，单击“列表”选项卡，然后在“数据表”组中，单击“显示任务窗格”。
  2. 在任务窗格中，单击“排序”。
  3. 在“自定义排序”对话框的“排序依据”下，选择最外层的排序列，然后单击“升序”或“降序”。
  4. 对另外两个列重复上述步骤，直到最不重要的排序条件。
  5. 单击“确定”。

注释

  • 可以在已排序的视图中应用一种或多种筛选。
  • 类型为多行文本、多值选择或多值查阅的列不支持排序。如果某一列不支持排序，则排序命令对该列无效。
  • 排序之后行的顺序取决于用于排序的列中数据的类型。

    不同数据类型的默认排序顺序

    在按升序排序时，“数据表”视图使用下列顺序。在按降序排序时，排序顺序与此相反；但空白单元格除外，它们始终排在最后。

    数据类型 | 排序顺序
    数字 | 从最小的负数到最大的正数进行排序
    字母数字 从左到右逐字符进行排序。例如，如果一个单元格包含文本“A100”，则这个单元格将排在包含条目“A1”的单元格的后面、包含条目“A11”的单元格前面。

    按下列顺序对文本和包含数字的文本进行排序：0 1 2 3 4 5 6 7 8 9（空格）! " # $ % & ( ) * , . / : ; ? @ [ \ ] ^ _ ` { | } ~ + < = > A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

    省略符号 (') 和连字符 (-) 通常被忽略，但有一个例外：如果两个文本字符串除连字符之外完全相同，则具有连字符的文本排在后面。
    逻辑值 | No 位于 Yes 前面。
    错误值 | 在排序时所有错误值都被当作等号对待。


解决排序和筛选问题

不能在视图中保存排序顺序或筛选条件

排序和筛选命令不可用

“自定义筛选器”对话框中缺少某些运算符

看不到希望在其中进行排序行或筛选数据的列

排序顺序与计算机中的设置不匹配

虽然应用了筛选或排序，但视图并未显示已筛选或已排序

不能在视图中保存排序顺序或筛选条件

在“数据表”视图中打开列表之后应用于列表的任何排序或筛选都不能保存。关闭“数据表”视图或切换到其他视图时，设置将丢失。若要保存排序顺序或筛选条件，请将其指定为视图定义的一部分。

返回页首

排序和筛选命令不可用

如果某一列不支持排序或筛选，则单击列标题时不会显示这些命令。

返回页首

“自定义筛选器”对话框中缺少某些运算符

显示在“自定义筛选”对话框中的运算符列表会因所选列的数据类型而异。例如，“始于”和“包含”不适用于数字列。

返回页首

看不到希望在其中进行排序行或筛选数据的列

确保在“数据表”视图中该列不是隐藏的。右键单击列表左上角的单元格，单击“取消隐藏”。如果“取消隐藏”命令不可用，请检查视图定义，以确保视图中包含该列。

返回页首

排序顺序与计算机中的设置不匹配

这可能是由于 SharePoint 服务器上的区域设置造成的。有关详细信息，请参阅 Microsoft SharePoint Foundation 2010 帮助。若要显示 Microsoft SharePoint Foundation 2010 帮助，请单击“帮助”( [image])。

返回页首

虽然应用了筛选或排序，但视图并未显示已筛选或已排序

在应用筛选或排序之后添加或编辑数据时，视图不会自动刷新数据。请尝试刷新视图，或重新应用筛选或排序顺序。

返回页首


关于移动、复制和粘贴单元格内容

可将列表的各个部分移动或复制到同一列表中的另一个位置，或者到另一个文档中。移动所选内容时，会从列表中删除所选内容并将其移动到剪贴板上。复制所选内容时，所选内容将保留在列表中，而将一个副本放置在剪贴板上。粘贴剪贴板的内容可将其传送到目标位置。

移动或复制列表的各个部分

将剪贴板的内容粘贴到列表中

移动或复制列表的各个部分

如果所选范围包含的单元格不能为空或为只读，则移动操作将失败。使用下列数据类型的列不能为空，因此不能使用移动操作将其清除：复选框和计算值。

下表列出了在移动或复制操作后相应的剪贴板内容。

移动或复制... | 剪贴板的内容
数据或者一个或多个单元格（所选内容不包含整行或某一列） | 单元格内容被清除或复制并放置到剪贴板中。
一行或多行 | 选中的行将被删除或复制并放置到剪贴板中。
一列（仅可进行复制，不可进行移动） | 所选内容将被放置到剪贴板中。
“汇总”行 | 如果进行移动，会将“汇总”行中的单元格的表达式设置为“无”。“汇总”行不会受到复制操作的影响。 将合计值放置到剪贴板中。
复选框单元格 | 在移动操作中不会被清除。 将 Yes 或 No 放置到剪贴板中。
计算列 | 在移动操作中不会被清除。 将计算值放置到剪贴板中。

返回页首

将剪贴板的内容粘贴到列表中

粘贴剪贴板中的内容时，会将新行添加到“数据表”视图的底端（如果需要）。但是，如果视图没有足够的列，则粘贴操作会失败。在下列情况下，粘贴操作也会失败：

  • 某些或全部目标单元格为只读
  • 将内容粘贴到所选单元格中会使内容不能通过验证规则
  • 试图粘贴与目标单元格的数据类型不匹配的数据
  • 试图将数据粘贴到计算列中

当试图将一种类型的数据粘贴到不同类型的列中时，列表将尝试转换源数据以便与目标列的类型匹配。例如，如果源数据为数字，而目标单元格支持文本，则会将源数据转换为文本，然后放置到目标单元格中。如果不能转换源数据使其与目标单元格类型匹配，则粘贴操作会失败。

下表列出了不同的粘贴操作的结果：

剪贴板的内容 | 试图将内容粘贴到... | 粘贴操作的结果
单个单元格 | 某一范围内的单元格 | 会将内容复制到所选范围内的每个单元格中。
某一范围内的单元格 | 单个单元格 | 目标范围扩展以适合剪贴板的整个内容，其中所选单元格成为目标范围的左上角单元格。
一行/列或多行/列 | 行或列的第一个单元格 | 目标范围扩展以适合剪贴板的整个内容，其中所选单元格成为目标范围的左上角单元格。
一行或多行 | 某一行除第一个单元格以外的单元格 | 粘贴操作失败。
一列或多列 | 某一列除第一个单元格以外的单元格 | 除非目标范围超出了视图的最后一行，并且视图包含所需的列之外，粘贴操作将成功。因为新行中所需的列将为空，所以不会添加新行，您会看到一条消息，指示跳过某些行。
某一范围内的单元格 | 某一范围内的单元格 | 如果尺寸匹配，则粘贴操作将成功，否则，粘贴操作将失败。
“汇总”行中的单元格 | “汇总”行 | 包含在源单元格中的表达式将被放置到目标单元格中。
“汇总”行中的单元格 | “汇总”行之外的任何位置 | 将合计值放置到目标单元格中。

返回页首


使用数据自动填充单元格

可使用某个特定值、某一范围的值或使用线性增加的值填充单元格区域。

将某单元格的内容复制到该列中的其他单元格中

将某区域内的值复制到该列中的其他单元格中

线性增加列中某一单元格区域的值

将某单元格的内容复制到该列中的其他单元格中

例如，行 1 中的“年份”列包含值 1980，您希望将其复制到第 2、3、4、5 行。

  1. 选择要复制其内容的单元格。
  2. 将鼠标指针定位在该单元格右下角的拖动填充柄上。

  3. 看到拖动指针 (+) 时，拖动该指针直到包含所有目标单元格。可以在所选单元格的上面或下面拖动。

  4. 释放鼠标按钮时，第一个单元格中的内容将被复制到目标单元格中。

返回页首

将某区域内的值复制到该列中的其他单元格中

例如，希望使用值 1、2、3、4、1、2、3、4 填充“季度”列中的单元格。

  1. 在第一行中键入 1，在第二行中键入 2，在第三行中键入 3，在第四行中键入 4。
  2. 选择全部四个单元格。
  3. 将鼠标指针定位在所选区域右下角的拖动填充柄上。
  4. 看到拖动光标 (+) 时，按下 Ctrl 并拖动该光标，直到包含所有的目标单元格为止。可以在所选单元格的上方或下方拖动。

返回页首

线性增加列中某一单元格区域的值

在某些文本和数字列中，可以使用一系列从源单元格中的值向上线性增加的值来填充单元格。下面的备注中列出了不支持此操作的列类型。

例如，希望使用值 1910、1920、1930 等填充“年份”列中的单元格。

  1. 在第一行中键入 1910，并在第二行中键入 1920。
  2. 选择第一行和第二行的“年份”单元格。
  3. 将鼠标指针定位在所选区域右下角的拖动填充柄上。
  4. 看到拖动光标 (+) 时，拖动该光标，直到包含所有的目标单元格为止。可以在所选单元格的上方或下方拖动。

注意 如果初始序列包含单个值，则必须拖动填充柄的同时按住 Ctrl 以生成序列。

线性增加值的示例

下表列出了一些可通过拖动填充柄生成的序列。

初始值 | 产生的序列
1, 2, 3 | 4, 5, 6...
Mon | Tue, Wed, Thu...
Monday | Tuesday, Wednesday, Thursday...
Jan | Feb, Mar, Apr...
Jan, Apr | Jul, Oct, Jan...
1/1/2005 | 1/2/2005, 1/3/2005...
01.15.05, 03.15.05 | 05.15.05, 07.15.05...
1999, 2000 | 2001, 2002, 2003...
Qtr3 | Qtr4, Qtr1, Qtr2...
Q3 | Q4, Q1, Q2...
text1, textA | text2, textA, text3, textA...
1st Period | 2nd Period, 3rd Period...
Product 1 | Product 2, Product 3...

注释

  • 可在单次操作中自动填充多个列。每一列中选中的单元格将用于填充目标单元格。
  • 具有下列数据类型的列不支持使用线性增加值进行填充：
    • 多行文本
    • 选择
    • 查找
    • 是/否（复选框）
    • 个人或组
    • 超链接或图片
    • 计算
  • 如果尝试填充只读单元格或用无效值填充单元格，则该单元格的填充操作将失败。

返回页首


在单元格中自动填充数据的疑难解答

消息显示“目标区域的单元格为只读单元格”

正在拖动填充柄以包括只读的单元格。

消息显示“因为新行的必需字段中包含无效的值而被跳过”

正在拖动填充柄以包括在标记为必需的一列或多列中无任何值的行。

消息显示“不能对计算列执行此操作”

不能在计算列中通过拖动填充柄填充值。计算列通过对公式进行计算来获得值。若要查看或编辑计算列中的公式，请单击该列中的某个单元格，然后再单击一次。

消息显示“试图使用无效值填充单元格或行”

正试图在单元格中填充可能会导致单元格或行的有效性验证规则失效的值。

消息显示“某些数据已被截断”

正试图在单元格中填充长度超出了目标单元格所允许的最大长度的值。


解决单元格内容的移动、复制和粘贴问题

无法在列中粘贴数据，或者消息显示“无法粘贴 N 个单元格”

消息显示“某些数据已被截断”

消息显示“区域中的单元格是必需的，不能被清除”

消息显示“区域中的单元格/行是只读的”

消息显示“因为粘贴区域不全在列表中，所以不能粘贴”

消息显示“不能粘贴信息，因为剪切或复制区域的大小与粘贴区域的大小不一样”

消息显示“某些行被跳过”

无法在列中粘贴数据，或者消息显示“无法粘贴 N 个单元格”

请执行下列一项或多项操作：

  • 确保该列不是计算列。
  • 确保您尝试粘贴的数据类型与目标单元格的类型匹配。
  • 确保粘贴操作不会违反为单元格或行设置的有效性规则。

返回页首

消息显示“某些数据已被截断”

正在试图在一个或多个目标单元格中粘贴超出了目标单元格所允许的最大长度的字符。例如，如果尝试在类型为单行文本的单元格中粘贴超过 255 个字符长度的文本，多余的字符将被截断。

返回页首

消息显示“区域中的单元格是必需的，不能被清除”

正在试图在标记为必需的列中移动一个或多个单元格。必需列不能保留为空；如果不愿尝试移动数据，请尝试将数据复制到目标单元格，然后删除不需要的行。

返回页首

消息显示“区域中的单元格/行是只读的”

正在试图从一个或多个只读的单元格或行中移动数据，或者在只读的单元格或行中粘贴数据。不能更改只读的单元格和行中的内容。

返回页首

消息显示“因为粘贴区域不全在列表中，所以不能粘贴”

这可能是由于下列原因之一引起的：

  • 您正尝试将一个或多个行粘贴到行中第一个单元格之外的一个单元格中。
  • 您正尝试将某个单元格区域粘贴到一个单元格中，但是视图在目标单元格的右下方没有所需的行数或列数。

返回页首

消息显示“不能粘贴信息，因为剪切或复制区域的大小与粘贴区域的大小不一样”

正在试图将单元格区域粘贴到目标区域中，但区域大小不匹配。确保在目标区域中选择的行数和列数与源区域中的行数和列数相同。

返回页首

消息显示“某些行被跳过”

这可能是由于下列原因之一引起的：

  • 您尝试将一个或多个列粘贴到目标列中除第一个单元格之外的一个单元格中。
  • 您尝试将数据粘贴到带有星号 (*) 的行中，但该操作不能将数据添加到视图中需要的所有列中。

任何需要添加新行但保留必需列为空的操作都会失败。粘贴操作只对现有行有效，而其余的行则被跳过。

返回页首


批准或拒绝待定项目

如果将列表设置为需要审批内容，那么具有适当列表管理权限的用户可以审核其他用户添加到该列表中的项目，并决定批准还是拒绝这些项目，然后再将信息显示给公众。只有获得批准的项目才会显示给网站用户。

  1. 在“数据表”视图中，检查“审批状态”列以查看是否有等待批准的项目。
  2. 转到“批准/拒绝项目”视图：
    1. 在功能区中，单击“列表”选项卡，然后在“当前视图”组中，单击“当前视图”下拉菜单中的“批准/拒绝项目”。
    2. 确保您仍位于“数据表”视图中。根据需要单击“数据表视图”。
  3. 可以选择筛选列表以便仅显示待定列表项。单击“审批状态”列的列标题中的下拉箭头，然后单击“待定”。
  4. 若要批准或拒绝某一行，请在“审批状态”列中单击相应项目的当前状态，再单击向下箭头，然后单击下拉菜单中的“已批准”或“已拒绝”。

    若要使用相同的状态或备注更新相邻的行，请在第一行中输入值，然后拖动填充柄以包含所需的行。还可在这些列中复制和粘贴值。

  5. 在“审批者注释”列中键入您的相关注释。

注意 还可将已批准或已拒绝项目的状态更改回待定状态。这将取消发布该项目，以便不再向访问该网站的用户显示该项目。


将数据更改提交给列表经理进行审批

如果要向需要进行内容审批的列表中添加数据或编辑其中的数据，则在具有适当内容审批权限的人员批准所做更改之前，其他用户将看不到您所做的更改。

注意 如果您具有列表的内容审批权限，将自动批准您对列表所做的更改。

新建列表项并提交进行审批

  1. 在功能区中，单击“项目”选项卡，然后在“新建”组中，单击“新建项目”。
  2. 在“新建项目”页上，输入有关新项目的信息，然后单击“确定”。

    在“数据表”视图中，该新项目以“待定”审批状态显示在列表中。具有内容审批权限的用户必须审核并批准该项目，它才会显示给访问网站的用户。

编辑已获得批准的项目

  1. 转到“我提交的项目”视图。
    1. 在功能区中，单击“列表”选项卡，然后在“自定义视图”组中，单击“当前视图”下拉菜单中的“我提交的项目”。
    2. 确保您仍位于“数据表”视图中。根据需要单击“数据表视图”。

    该视图显示已添加到列表中的所有项目，包括已拒绝的项目。除了显示列表中的其他所有列之外，该视图还显示“审批状态”和“注释”列。但是，“审批状态”、“注释”、“修改时间”和“修改者”列是只读列。在项目获得批准后，只有创建该项目的人员才能编辑它。

  2. 在要编辑的项目所在的行中，进行所需更改。

    在“数据表”视图中，您所编辑的项目的审批状态将自动更改为“待定”。在编辑行时，应像对待新项目一样对该行进行审批。


关于使用文档库

就像其对于列表一样，“数据表”视图对于文档库提供了相同级别的支持。可在“数据表”视图中打开文档库以查看库的内容，添加和删除文件夹及文档，以及编辑文档并更改其属性。

在“数据表”视图中使用文档

在“数据表”视图中管理文档和文件夹

在“数据表”视图中使用文档

在“数据表”视图中使用文档库的方法有两种。

  • 在功能区中的“库”选项卡下，单击“数据表视图”。
  • 基于“数据表”视图为库创建一个或多个自定义视图。下面是具体方法：
    1. 在功能区中的“库”选项卡下，单击“创建视图”。
    2. 在“创建视图”页上的“选择视图格式”部分，单击“数据表视图”。
    3. 在“视图名称”框中键入视图的名称。最好在视图名称中包括“数据表”一词，这样以后就可以确定该视图的种类。
    4. 为视图设置任何其他所需属性。
    5. 单击“确定”。
    6. 新视图将出现在“当前视图”下拉列表中。

      注意 如果将视图的文件夹设置设为“在文件夹内显示项目”，则打开库时仅会显示顶层的文档和文件夹。如果将视图的文件夹设置设为“显示所有项目，但不显示文件夹”，则打开库时，会将所有文档（包括那些位于不同的文件夹下的文档）作为行来显示。

若要更改现有“数据表”视图的设置，请执行下列操作：

  1. 在功能区中的“库”选项卡下，单击“修改此视图”。
  2. 在“编辑视图”页上，选择或更改此视图的属性。
  3. 单击“确定”。

返回页首

在“数据表”视图中管理文档和文件夹

  • 可使用在“所有文档”视图或其他任何“普通”视图中添加和上载文档相同的方法将文档添加和上载到库中。
  • 如果视图的文件夹设置被设置为“在文件夹内显示文档”，则可添加新文件夹并导航到库中的其他文件夹。
  • 可打开、编辑和签入或签出文档。
  • 可在“数据表”视图中删除文档和文件夹。删除文件夹时，会将文件夹（包括子文件夹）中的内容从库中删除。
  • 可添加列，或删除和修改您或其他用户添加到视图中的列。还可在包含文档的行中输入和编辑存储在这些列中的数据。不能编辑与文件夹相对应的行。请注意诸如“类型”和“修改者”之类的列是只读的，您无法对其进行修改或删除，也无法输入或编辑这些列的内容。
  • 可显示或隐藏“汇总”行。
  • 可以基于不同的列（包括“类型”列）对库进行排序和筛选。
  • “数据表”视图不会显示文档库的星号 (*) 行。
  • 无法使用拖动填充柄或从单元格的下拉列表中选择值在“名称”列中输入值。

返回页首


添加、查看或删除附加到行中的文档

在某些类型的列表中，可以将一个或多个文档附加到行中。附加文档在行的“附件”列中显示为曲别针图标。如果列表中的项目均不包含附件，则不会显示“附件”列。

向新项目中添加附件

  1. 在功能区中，单击“项目”选项卡，然后在“新建”组中，单击“新建项目”。
  2. 在“新建项目”页上，键入该项目的名称并指定其他项目属性。
  3. 单击“附加文件”。
  4. 选择要附加到新项目中的一个或多个文件，然后单击“打开”。
  5. 单击“确定”。
  6. 单击“确定”。

向现有项目中添加附件

  1. 在“数据表”视图中，右键单击某一行的“附件”列，然后单击“编辑附件”。

    注意 无法将附件添加到尚未提交的行中。

  2. 在“列表项目的附件”对话框中：
    • 若要添加附件，请单击“添加”。选择要附加到该行中的一个或多个文件，然后单击“打开”。

      若要在附加文件之前预览该文件，请在“列表项目的附件”对话框中双击该文件。

    • 若要删除附件，请选择该文件，然后单击“删除”
  3. 当“列表项目的附件”对话框中包含所需的全部附件时，请单击“确定”将其附加到行。“附件”列中将出现一个曲别针图标，以指示该行包含一个或多个附加文件。


签入或签出文档

签入已签出给您但当前尚未打开的文档

  1. 右键单击行标题或与要签入的文档相对应的行中的任何单元格，指向“文档”，再单击“签入文档”。
  2. 在“签入”页上，选择是要在将文档签入到服务器后保持签出给您的状态，还是发布该文档以供他人使用。
  3. 可以选择在“注释”框中描述对文档所做的更改。
  4. 单击“确定”。

签出文档

  • 右键单击行标题或与要签出的文档相对应的行中的任何单元格，指向“文档”，再单击“签出文档”。

注意 不能签出当前已被其他用户签出的文档。


删除文件夹或文档

删除文件夹将删除其所有内容，包括子文件夹。

  1. 右键单击与要删除的文件夹或文档相对应的行的行标题或行中的任何单元格，再单击“删除文件夹”或“删除文档”。
  2. 若要确认，请单击“是”。

注意 一次仅可删除一个文件夹。


对文档进行编辑

打开要编辑的文档时，Microsoft SharePoint Foundation 2010 会自动执行若干必需的任务，例如签出该文件、将其下载到您的计算机以及打开相关程序。

  • 右键单击行标题或与要编辑的文档相对应的行中的任何单元格，指向“文档”，再单击“编辑文档”。

    如果必须签出文档才能进行编辑，Microsoft SharePoint Foundation 2010 会通知您将要签出和编辑该文档。单击“确定”继续操作。

将使用相应的 Office 应用程序打开该文档。您可以编辑该文档并将其保存回库中或其他位置。在关闭已签出的文档时，可以选择是重新签入该文档还是在保持其签出状态的同时在服务器上对其进行更新。

注意 无法编辑其他用户签出的文档。在将该文档签入之前，也无法编辑与该文档相对应的行中的任何列。


建立项目级权限

您可以通过建立项目级权限来限制用户查看或编辑列表中的项目。例如，您可以为列表设置权限以便用户只能查看他们自己的项目，或者您可以设置权限以便用户能够查看所有项目，但只能编辑他们自己的项目。在创建新的列表时，设置的权限使所有用户可以查看和编辑所有项目，而不管是谁创建了这些项目。

限制用户读取其他用户的项目

按照以下过程设置读取访问权限：

  1. 在功能区中，单击“列表”选项卡，然后在“设置”组中，单击“列表设置”。
  2. 在“列表设置”页上，单击“高级设置”。
  3. 在“高级设置”页上的“项目级权限”下，单击下列“读取权限”选项之一：
    • 单击“读取所有项目”以允许所有用户读取列表中的所有项目。
    • 单击“读取由该用户创建的项目”只允许用户读取他们自己创建的项目。
  4. 单击“确定”。

限制用户编辑项目

按照以下过程设置编辑访问权限：

  1. 在功能区中，单击“列表”选项卡，然后在“设置”组中，单击“列表设置”。
  2. 在“列表设置”页上，单击“高级设置”。
  3. 在“高级设置”页上的“项目级权限”下，单击下列“编辑权限”选项之一：
    • 单击“创建和编辑所有项目”以允许所有用户编辑列表中的所有项目。
    • 单击“创建项目并编辑由该用户创建的项目”只允许用户编辑他们自己创建的项目。
    • 单击“无”以防止所有用户编辑所有项目。
  4. 单击“确定”。


使文档可用于讨论

  • 右键单击与您希望可用于讨论的文档相对应的行中的行标题或任何单元格，再单击“讨论”。

这将在 Internet Explorer 中打开文档。浏览器窗口将显示“讨论”工具栏。


打开文件夹或文档

  • 要导航到文件夹或者要打开文档，请单击文件夹或文件的“类型” 列中的图标。

    如果文档是使用 Microsoft Office 创建的，则使用相应的 Office 应用程序打开该文档。其他所有文档在 Internet Explorer 中打开。


跟踪并查看列表项的版本信息

您可以存储有关对列表中各个项目所做的更改的信息。这样，您不仅可以查看更改时间和更改者，还可以查看对每个项目所做的更改。

启用列表中项目的版本跟踪

  1. 在功能区中，单击“列表”选项卡，然后在“设置”组中，单击“列表设置”。
  2. 在“列表设置”页上，单击“版本控制设置”。
  3. 在“版本控制设置”页上的“项目版本历史记录”部分，单击“是”，以便在每次编辑项目时都创建一个版本。
  4. 要限制保留的版本数量，请选中“保留以下数量的版本”复选框，并输入要保留的版本的最大数量。
  5. 单击“确定”。

查看列表中项目的版本

  1. 右键单击与您要查看其版本信息的项目对应的行中的行标题或任意单元格。
  2. 指向“项目”，然后单击“版本”。

    将显示版本信息。


查看文档版本

如果文档库的文档版本设置被设置为存储文档版本，则可以查看库中每个文档的各种版本信息。

查看文档版本

  • 在与希望查看其版本的文档相对应的行中，右键单击行标题或行中的任何单元格，指向“文档”，再单击“文档版本”。

更改文档版本设置

  1. 在功能区中，单击“库”标记，然后在“设置”组中，单击“库设置”。
  2. 在“列表设置”页上的“常规设置”下，单击“版本控制设置”。
  3. 在“文档库版本控制设置”页上的“文档版本历史记录”下，选择所需的版本控制方案，然后单击“确定”。


关于解决冲突更改

当两个用户对列表的数据或结构的同一部分进行更改时，就会发生冲突。首先提交更改的用户将成功地提交自己的更改，而第二个用户则会得到冲突通知。

例如，用户 A 将第三行的 City 列从 Dallas 更改为 Seattle，而同时，您将该单元格由 Dallas 更改为 Houston。用户 A 的更改先提交给服务器，随后才提交您的更改。服务器会通知您发生冲突并让您解决冲突。

注意 即使用户编辑同一行中的不同单元格时也会发生冲突。

下面的图示显示在第三行的标题中有“冲突”图标的列表。

只有在解决冲突后，才能对存在冲突的行做更改。

单击“冲突”图标会显示“解决冲突”对话框。

注意 如果试图删除另一个用户已更新的某一行，则会发生冲突，但不会显示“冲突”图标，因为该行已被更新。在这种情况下，请单击状态栏中的“冲突解决”以打开“解决冲突”对话框。

详细信息网格显示当前视图中的所有列。对于受影响的行，它会显示您所做的更改和其他用户所做的更改。更改的列会突出显示。请注意，您不能编辑显示在详细信息网格中的值。在对话框的顶部，可看到做出更改的用户的名称，及进行更改的日期和时间。

当两个或更多用户进行一系列更改时，可能会发生多个冲突。在尝试解决某个现有冲突时，可能会发生新的冲突。如果存在一个以上的冲突，则“解决冲突”对话框将使您能够通过单击对话框右上角的“上一个”和“下一个”按钮来查看每个冲突的详细信息。冲突会按行号排序。换句话说，第三行中的冲突会显示在第四行中的冲突的前面。在浏览冲突时，数据表中受影响的行会获得焦点。还可通过单击受影响的行中的“冲突”图标查看某个特定冲突的详细信息。对话框会自动滚动到所选的冲突，但您可通过单击“上一个”或“下一个”查看其他冲突的详细信息。

注意 如果除了存在冲突之外，在视图中还存在一个或多个错误，则“解决冲突”对话框将包含错误的详细信息，使您能够解决错误。

根据详细信息网格中的信息，您可以忽略所做的更改或重试更改。如果更改是对某一行的不同列所做的，重试更改会将您的更改与用户 A 的更改合并。如果更改是对同一单元格所做的，则您的更改将覆盖用户 A 的更改。当存在多个冲突时，可对每个冲突采取个别操作，或对所有冲突采取单个操作。若要忽略或重试所有更改，请单击“放弃所有更改”或“重试所有更改”。

可以不采取任何操作而关闭该对话框，但只有解决冲突，您才可离开或刷新列表，或者对计算列进行更改。

显示 在“解决冲突”对话框中的特殊情况

此处是“解决冲突”对话框可能以不同方式提供信息的特殊情况。
  • 更新已被其他用户删除的行。在这种情况下，该对话框将不会显示该用户的名称和做出更改的日期和时间。在详细信息网格中，与其他用户相对应的行只是显示“已删除的行”。唯一可用的选项是放弃您的更改。您将无法重试更改。
  • 用户 A 更新未包含在您的当前视图中的某一列。在这种情况下，详细信息网格将不包含用户 A 所更改的列。重试更改将不会覆盖用户 A 对不包含在您的视图中的列所做的更改。
  • 用户 A 编辑某一列，然后再次编辑它以使单元格恢复到原来的值。在这种情况下，对话框将仅显示最新的更改。
  • 如果当前的筛选隐藏了某个存在冲突的行，则对话框将暂时删除筛选以在数据表中显示该行。关闭对话框之后，将会自动重新应用筛选。
  • 如果用户 A 使用浏览器添加或删除某个附件，而您更新某一行，则您会收到冲突通知。但是，只有当该用户添加第一个附件或删除最后一个附件时，才会在对话框中突出显示“其他用户的更改”行中的列。当存在一个或多个附件时，详细信息网格中的列会显示“是”，而当没有附件时，则会显示“否”。
  • 如果受影响的单元格是一个超链接，则详细信息网格将显示 URL（如果显示名称不可用）。对于图片，该网格将显示路径。如果受影响的列包含 RTF 格式，则该网格会显示文本但不包含格式。但是，如果格式被更改，则会突出显示该列。

返回页首

解决结构性冲突

当两个或多个用户编辑一个列表的不同部分时，还可能发生结构性冲突。当不可能解决更改时，就会发生结构性冲突。例如，用户 A 删除某一列，而用户 B 试图更新该列。或者用户 A 更改了列的数据类型，而用户 B 输入与新的数据类型不兼容的数据。在这种情况下，将会要求用户 B 刷新列表。刷新列表将检索列表的最新版本，但会放弃用户 B 的更改。

返回页首

解决冲突会导致新的冲突或错误

解决冲突会导致一个或多个新的冲突或错误。例如，在您解决由于用户 A 的更改所引起的冲突时，第三个用户（用户 C）进行了一系列冲突更改。如果尝试重新应用您的更改导致了新的冲突，则会将新冲突添加到现有冲突列表中，且会更新该对话框。

返回页首


关于改正错误

使用“数据表”视图进行操作时，可能会遇到一个或多个错误。有些错误可以通过简单地重复操作或刷新视图来改正，而其他一些错误则需要费点精力才能改正。根据错误的不同，视图将提供适当信息以帮助您改正错误。

可能会出现错误的情况

错误类型

改正错误

可能会出现错误的情况

当执行下列操作时可能会出现错误：
  • 打开“数据表”视图。例如，视图可能无法加载，或者无法显示任何数据。
  • 在视图中查看或编辑数据。例如，如果找不到服务器，提交数据更改可能会失败。
  • 查看或编辑列表结构。例如，删除列时可能会因缺少权限而产生错误。
  • 查看或编辑视图定义。例如，对列进行重新排序时可能会因服务器超时而失败。

返回页首

错误类型

有两种错误类型：通过重试更改可以改正的错误，以及通过放弃更改可以改正的错误。

通过重试更改可以改正的错误：

  • 服务器没有响应。这可能是因为超时。
  • 服务器正忙，或找不到服务器。
  • 无法解析服务器响应。
  • 其他任何意外错误。

通过放弃更改可以改正的错误：

  • 不具有进行更改所需的必要权限。
  • 将内容添加到网站时被阻止。
  • 已超出网站的存储限制。
要避免这些错误，请与您的系统管理员联系。

返回页首

改正错误

出现错误时，视图将在相应的行和状态栏中显示“错误”（ “错误”图标 ）图标。另外，还可在状态栏中看到“单击此处改正错误”文本。如果存在冲突和错误，将会看到“单击此处解决数据冲突和错误”文本。

下图所示为“改正错误”对话框。

详细信息网格显示当前视图中的所有列。对于受影响的行，显示所做的更改。请注意，您不能编辑显示在详细信息网格中的值。在对话框的顶部，可以看到有关的错误说明。

如果存在多个错误，通过单击对话框右上角的“上一个”和“下一个”按钮可查看每个错误的详细信息。

根据详细信息网格中的错误信息，可以忽略所做的更改，也可以重试更改。当出现多个错误时，可以对每个错误采取单独的操作，也可以对所有错误采取一种操作。若要忽略或重试所有错误，请单击“放弃所有更改”或“重试所有更改”。

请注意：为改正错误而采取的任何操作都有可能导致新的错误。在这种情况下，将更新对话框以包括新错误的详细信息。

可以不采取任何操作而直接关闭对话框，但在改正错误之前不能离开或刷新列表，也不能更改计算列。

返回页首


解决冲突更改和错误的问题

  1. 单击状态栏上的“冲突解决”以显示“解决冲突和错误”对话框。

  2. 请执行下列操作之一：

    • 若要通过忽略对行所做的更改来解决当前显示的冲突或错误，请单击“放弃我的更改”。所做的更改将丢失。
    • 若要通过忽略对列表所做的所有更改来解决所有待定的冲突和错误，请单击“放弃所有更改”。
    • 若要通过重新应用更改来解决当前显示的冲突或错误，请单击“重试我的更改”。在存在冲突的情况下，如果您和其他用户更改同一列，则您所做的更改将覆盖其他用户所做的更改。如果编辑其他列，则您所做的更改将与其他用户所做的更改合并。
    • 若要通过重新应用更改来解决所有待定的冲突和错误，请单击“重试所有更改”。
    • 若要查看下一个冲突或错误的详细信息，请单击对话框右上角的“下一个”。
    • 若要查看上一个冲突或错误的详细信息，请单击对话框右上角的“上一个”。
    • 若要稍后解决冲突和错误，请单击对话框标题栏上的“关闭”。

注释

  • 详细信息网格显示当前视图中的所有列。如果这些列不可见，请使用水平滚动条滚动，或拖动对话框的右边缘以增加详细信息网格的宽度。

    若要缩放列的内容，请在详细信息网格中单击该列。您所做的更改以及其他用户所做的更改将显示在“字段详细信息”对话框中。该对话框还适用于查看 RTF 格式的更改。

  • 如果您或其他用户删除了行，则详细信息网格将显示“已删除的行”，而不是显示数据行。如果其他用户删除了该行，对话框将不显示用户名或删除的日期和时间。此外，您将不能重试更改。


何时发生冲突？

当两个用户对列表的数据或结构的同一部分进行更改时，就会发生冲突。首先提交更改的用户将成功地提交自己的更改，而第二个用户则会得到冲突通知。

可对列表进行的更改类型

将导致冲突的情况

不会导致冲突的情况

将导致结构性冲突的情况

不会导致错误消息或冲突的情况

可对列表进行的更改类型

可对列表进行三种类型的更改。下表列出了每种类型及一些示例：

更改的类型 | 示例
更改列表的数据 | 添加、修改或删除行 粘贴剪贴板内容 通过拖动填充柄将数据添加到单元格 添加或删除附件 设置一个或多个单元格内容的格式
修改列表的结构 | 添加或删除列 更改列的设置 对计算列进行更改 更改列表设置
更改视图定义 | 应用筛选或排序顺序 更改列宽或行高 更改列顺序 显示或隐藏“汇总”行

返回页首

将导致冲突的情况

下表汇总了会发生冲突的情况：

用户 A | 用户 B
删除某一行 | 更新同一行
更新某一行 | 更新或删除同一行 注意 在文档库中，如果用户 A 更新了某一行或某个文档，且用户 B 删除了同一行或同一个文档，则会发生冲突。
使用浏览器添加或删除附件 | 更新或删除同一行
删除某个文档 | 更新同一行
编辑、重命名或保存某个文档 | 更新同一行
更新某一行而不编辑文档 | 更新同一行
更改 RTF 格式 | 更新或删除同一行

在文档库中，如果用户 A 打开某个文档，而用户 B 编辑该文档或更改其设置，则用户 B 将收到一个错误，指示文档已锁定。

返回页首

不会导致冲突的情况

下表汇总了不会发生冲突的情况：

用户 A | 用户 B | 示例
更改数据 | 更改视图定义 | 用户 A 添加了一行，而用户 B 对视图应用了一个排序顺序
更改结构 | 更改视图定义 | 用户 A 添加了一列，而用户 B 对视图应用了一个排序顺序
更改视图定义 | 更改数据 | 用户 A 应用了一个排序顺序，而用户 B 添加了一行
更改视图定义 | 更改结构 | 用户 A 应用了一个排序顺序，而用户 B 添加了一列
更改视图定义 | 更改视图定义 | 用户 A 应用了一个排序顺序，随后用户 B 应用了另一个排序顺序 注意 因为保留最后的更改，所以用户 B 的更改将覆盖用户 A 的更改

注意 在文档库中，如果用户 A 和用户 B 以只读方式打开某一文档，后来又决定通过替换现有版本编辑并保存该文档，则后面保存的用户将覆盖另一个用户所做的更改。

返回页首

将导致结构性冲突的情况

下表汇总了将显示错误消息的情况。用户 B 会得到刷新列表的提示，且会放弃他们的更改。

用户 A | 用户 B
删除某一列 | 更新同一列中的数据
更改列中的数据类型 | 添加或更新类型不匹配的数据
添加、重命名或删除某一列，更改某一列的数据类型或其他属性 | 编辑计算列
进行列表级更改，例如重命名列表、更改列表的说明或安全设置、对列进行重新排列、启用或禁用附件，或将列表添加到“快速启动”栏 | 编辑计算列
编辑计算列 | 添加、重命名或删除某一列，更改某一列的数据类型或其他属性。 注意 在用户 A 开始编辑计算列之前，用户 B 必须在“添加列”或“更改列”页上
编辑计算列 | 进行列表级更改，例如重命名列表、更改列表的说明或安全设置、对列进行重新排列、启用或禁用附件，或将列表添加到“快速启动”栏 注意 在用户 A 开始编辑计算列之前，用户 B 必须在“列表设置”页上。

返回页首

不会导致错误消息或冲突的情况

下表汇总了既不会发生错误也不会发生冲突的情况：

用户 A | 用户 B
删除某一列 | 删除同一列
删除某个附件 | 删除同一附件
删除某个文档 | 删除同一个文档或行
删除某一行 | 删除同一行

返回页首


关于导出“数据表”视图

您可以从 Microsoft SharePoint Foundation 2010 导出到 Microsoft Access 2010 或 Microsoft Excel 2010。对于 Access 2010，可以导出到新数据库或现有数据库中的静态表或链接表。对于 Excel 2010，则可以在新工作表、现有工作表或新工作簿中创建“数据表”视图查询。

导出到 Access

从 Microsoft SharePoint Foundation 2010 导出到 Access 2010 时，将使用“数据表”视图中的数据创建静态数据库表。在对 Microsoft SharePoint Foundation 2010 中的数据进行更改时，该静态数据库表不会链接到“数据表”视图，也不会更新。

在 Access 中跟踪列表

当您在任务窗格中选择“在 Access 中跟踪此列表”时，将在 Access 中创建一个动态链接到 Microsoft SharePoint Foundation 2010 的表。如果您更改“数据表”视图中的数据，所做更改将会在 Access 表中自动更新。同样，如果您更改 Access 表中的数据，所做更改也会自动反映在“数据表”视图中。

注意 某些类型的列表中的列在 Microsoft SharePoint Foundation 2010 的“数据表”视图中可以修改，但在链接的 Access 表中不能修改。

通过 Excel 查询列表

通过 Excel 查询“数据表”视图时，将在 Excel 中创建一个查询，用于检索“数据表”视图中的数据。将“数据表”视图导出到 Excel 2010 后，将在 Excel 工作表中自动更新对“数据表”视图中的数据所做的更改。但是，对 Excel 工作表所做的更改不会反映在 Microsoft SharePoint Foundation 2010 中。


用 Excel 查询列表

  1. 在功能区中，单击“列表”选项卡，然后在“数据表”组中，单击“显示任务窗格”。
  2. 在任务窗格中，单击“用 Excel 查询列表”。

Microsoft Excel 将“数据表”视图作为 Web 查询文件导出。

如果在单击“用 Excel 绘图”时 Excel 正在运行，则系统会让您选择将 Web 查询文件中的数据导入现有工作表、新工作表还是新工作簿。否则，Excel 将打开并将数据导入新工作簿。导入的数据在工作表中显示为列表，并且系统会将该数据与 Microsoft SharePoint Foundation 2010 中的信息链接起来。

用“数据表”视图中所做的更改对工作表进行更新

对 Microsoft SharePoint Foundation 2010 中的数据进行更改之后，可以使用刷新外部数据功能对 Excel 工作表进行更新。有关查询的详细信息，请参阅 Excel 帮助。


导出联系人或事件信息

导出联系人信息

在联系人列表的标准视图和“数据表”视图中，可以将整个联系人列表或联系人列表中的单个联系人导出到 Microsoft Outlook。

导出联系人列表

  1. 在功能区中，单击“列表”选项卡，然后在“连接和导出”组中，单击“连接到 Outlook”。
  2. Outlook 将提示您确认是否将联系人列表连接到 Outlook。单击“是”。

将联系人列表导出到 Outlook 之后，在 Microsoft SharePoint Foundation 2010 中对联系人列表所做的更改将自动被转发到 Outlook 的联系人列表中并进行更新。当您下次在 Outlook 中重新加载联系人列表时，将显示这些更改。

导出单个联系人

  1. 请执行下列操作之一：
    • 在标准视图中，对于您要导出的联系人，单击其“姓氏”单元格中的下拉箭头，然后单击“导出联系人”。
    • 在“数据表”视图中，右键单击您要导出的联系人。然后，单击“导出联系人”。
  2. 系统将提示您确认是否下载虚拟名片文件（文件扩展名为 vcf）。单击“打开”。

此操作会将该联系人导出到默认的 Outlook 联系人列表“联系人”中。然后，您可以决定是将该联系人保存到“联系人”中，还是将其保存到其他联系人列表中。

返回页首

导出事件信息

可以将整个事件列表或事件列表中的单个事件导出到 Outlook。若要以事件列表的形式查看日历，请在功能区中的“列表工具”下，单击“列表”，然后单击“当前视图”下拉列表中的“所有事件”。

导出事件列表

  1. 在功能区中，单击“列表”选项卡，然后在“连接和导出”组中，单击“连接到 Outlook”。
  2. Outlook 将提示您确认是否将 Microsoft SharePoint Foundation 2010 中的日历连接到 Outlook。单击“是”。

将事件列表导出到 Outlook 之后，在 Microsoft SharePoint Foundation 2010 中对事件列表所做的更改将自动被转发到 Outlook 日历中并进行更新。当您下次在 Outlook 中重新加载日历时，将显示这些更改。

导出单个事件

  1. 请执行下列操作之一：
    • 在“数据表”视图中，对于您要导出的事件，右键单击其所在行的任意位置，然后单击“导出事件”。
    • 在标准视图中，单击要导出的事件，然后在“自定义命令”选项卡上，单击“导出事件”。
  2. 系统将提示您确认是否下载 Internet 日历文件（文件扩展名为 ics）。单击“打开”。

此操作会将该事件导出到默认的 Outlook 日历“日历”中。然后，您可以决定是将该事件保存到“日历”中，还是将其保存到其他日历中。

返回页首


将“数据表”视图导出或链接到 Access

将“数据表”视图导出到 Access

  1. 在功能区中，单击“列表”选项卡，然后在“数据表”组中，单击“显示任务窗格”。
  2. 在任务窗格中，单击“导出到 Access”。
  3. 选择将“数据表”导出到某个现有数据库或一个新数据库中，然后单击“确定”。

Microsoft Access 会提示您指定数据库的位置并打开一个包含导出的数据的表。

在 Access 中跟踪列表

  1. 在功能区中，单击“列表”选项卡，然后在“数据表”组中，单击“显示任务窗格”。
  2. 在任务窗格中，单击“在 Access 中跟踪此列表”。
  3. 选择将“数据表”导出到某个现有数据库或新数据库中，然后单击“确定”。

Access 会提示您指定数据库的位置并创建一个链接到 Microsoft SharePoint Foundation 2010 中的数据的链接表。

用链接表中的更改对“数据表”视图进行更新

  1. 在 Access 中编辑链接表。
  2. 在“数据表”视图中，在功能区中单击“列表”选项卡，然后在“数据表”组中，单击“刷新数据”。

用 SharePoint 中的更改更新链接表

  • 若要在链接表中查看对 Microsoft SharePoint Foundation 2010 中的数据所做的更改，请使用 Access 中的“刷新”命令。


创建 Access 报表

使用“数据表”视图在 Microsoft Access 中创建报表时，会使用“数据表”视图中的数据创建一个链接表，并基于该数据生成一个报表。

  1. 在功能区中，单击“列表”选项卡，然后在“数据表”组中，单击“显示任务窗格”。
  2. 单击“创建 Access 报表”。
  3. 选择将“数据表”导出到某个现有数据库或一个新数据库中，然后单击“确定”。

Access 会提示您指定数据库的位置，并创建一个链接到 Microsoft SharePoint Foundation 2010 中的数据的链接表。然后，它将生成一个简单报表，用于显示该链接表中的所有字段和记录。有关 Access 报表的详细信息，请在 Access 帮助中搜索“创建报表”。


创建 Excel 图表

使用“数据表”视图创建 Microsoft Excel 图表时，Excel 会先在“数据表”视图中创建数据查询，然后根据查询得到的数据创建图表。

  1. 在功能区中，单击“列表”选项卡，然后在“数据表”组中，单击“显示任务窗格”。
  2. 在任务窗格中，单击“用 Excel 绘图”。

Excel 将“数据表”视图作为 Web 查询文件导出。

如果在单击“用 Excel 绘图”时 Excel 正在运行，则系统会让您选择将 Web 查询文件中的数据导入现有工作表、新工作表还是新工作簿。否则，Excel 将打开并将数据导入新工作簿。导入的数据在工作表中显示为列表，并且系统会将该数据与 Microsoft SharePoint Foundation 2010 中的信息链接起来，然后提示您使用“图表向导”创建图表。


创建 Excel 数据透视表

如果使用“数据表”视图创建 Microsoft Excel 数据透视表，Excel 会先在“数据表”视图中查询数据，然后根据查询返回的数据创建数据透视表。

  1. 在功能区中，单击“列表”选项卡，然后在“数据表”组中，单击“显示任务窗格”。
  2. 在任务窗格中，单击“创建 Excel 数据透视表”。

Excel 将“数据表”视图作为 Web 查询文件导出。

如果在单击“创建 Excel 数据透视表”时 Excel 正在运行，则系统会让您选择将 Web 查询文件中的数据导入现有工作表、新工作表还是新工作簿。否则，Excel 将打开并将数据表导入新工作簿。导入的数据在工作表中显示为列表，并且系统会将该数据与 Microsoft SharePoint Foundation 2010 中的信息链接起来。在 Excel 中，会显示数据透视表字段列表和数据透视表工具栏，并提示您创建数据透视表。


使用 Excel 打印“数据表”视图

如果您使用 Microsoft Excel 打印“数据表”视图，Excel 会先在“数据表”视图中创建一个数据查询，然后打印该查询返回的数据。

  1. 在功能区中，单击“列表”选项卡，然后在“数据表”组中，单击“显示任务窗格”。
  2. 在任务窗格中，单击“用 Excel 打印”。

Excel 将“数据表”视图作为 Web 查询文件导出。

如果在单击“用 Excel 打印”时 Excel 正在运行，则系统会让您选择将 Web 查询文件中的数据导入现有工作表、新工作表还是新工作簿。否则，Excel 将打开并将数据表导入新工作簿。导入的数据在工作表中显示为列表，并且系统会将该数据与 Microsoft SharePoint Foundation 2010 中的信息链接起来，并提示您打印 Excel 列表。


关于计算运算符

运算符指定要对公式的元素执行的计算的类型。列表支持三种不同类型的计算运算符：算术运算符、比较运算符和文本运算符。

运算符的类型

列表在公式中执行运算的顺序

要点 只能在数据类型为“计算”的列中使用公式。无法将列的数据类型更改为“计算”。

运算符的类型

算术运算符 若要执行基本的数学运算（例如加、减或乘）、合并数字、及产生数字结果，请使用下列算术运算符。

算术运算符 | 意义（示例）
+（加号） | 加 (3+3)
-（减号） | 减 (3–1) 求反 (–1)
*（星号） | 乘 (3*3)
/（正斜杠） | 除 (3/3)
%（百分号） | 百分比 (20%)
^（脱字号） | 幂 (3^2)

比较运算符 可使用下列运算符比较两个值。使用这些运算符比较两个值时，比较结果为逻辑值 Yes 或 No。

比较运算符 | 意义（示例）
=（等号） | 等于 (A=B)
>（大于号） | 大于 (A>B)
<（小于号） | 小于 (A<B)
>=（大于等于号） | 大于或等于 (A>=B)
<=（小于等于号） | 小于或等于 (A<=B)
<>（不等于号） | 不等于 (A<>B)

文本串联运算符 使用 & 符号可连接或串联一个或多个文本字符串以产生单个的一段文本。

文本运算符 | 意义（示例）
&（与号） | 连接或串联两个值以产生一个连续的文本值 ("North"&"wind")

返回页首

列表在公式中执行运算的顺序

公式按特定的顺序来计算值。列表公式可能以等号 (=) 开头。紧跟着等号的是要计算的元素（操作数），它们被计算运算符分隔。列表根据公式中每个运算符的特定顺序，从左到右计算公式。

运算符优先级

如果在一个公式中组合了几个运算符，则列表会按照下表中显示的顺序执行运算。如果公式中包含的运算符具有相同的优先级（例如，如果公式既包含乘法运算符又包含除法运算符），则列表会按运算符从左到右的顺序进行求值。

运算符 | 说明
– | 求反（如 -1）
% | 百分比
^ | 幂
* 和 / | 乘和除
+ 和 - | 加和减
& | 连接两个文本字符串（串联）
= < > <= >= <> | 比较

括号的使用

若要更改计算的顺序，请对要首先计算的公式部分外加括号。例如，下面的公式计算结果为 11，因为列表先计算乘后计算加。公式将 2 乘以 3，然后加 5 得到结果。

=5+2*3

而如果使用括号以更改表达式，则列表会先将 5 与 2 相加，然后将结果乘以 3，最后得到 21。

=(5+2)*3

在下面的示例中，括住公式第一部分的括号强制列表首先计算 [Cost]+25，然后将结果除以列 EC1 和 EC2 中的值的和。

=([Cost]+25)/SUM([EC1]+[EC2])

返回页首


关于公式中的列引用

引用可以标识数据表中当前行中的一个单元格，它告诉列表在哪里寻找要在公式中使用的值或数据。例如，[Cost] 引用当前行中 Cost 列中的值。如果当前行的 Cost 列中的值为 100，则 =[Cost]*3 将返回 300。

要点 只能在数据类型为“计算”的列中使用公式。无法将列的数据类型更改为“计算”。

使用引用，可在一个或多个公式中使用包含在列表的不同列中的数据。在公式中可引用下列数据类型的列：单行文本、数字、货币、日期和时间、选项、是/否和计算值。

在公式中可使用列的显示名称引用该列。如果该名称包含空格或特殊字符，则必须在名称外加方括号 ([ ])。引用并不区分大小写。例如，可在公式中以“[Unit Price]”或“[unit price]”引用 Unit Price 列。

注意 不能引用当前行以外的行中的值。也不能在公式中包含被指定作为列的默认值的列引用。


关于公式中的常量

常量是无需通过计算而得到的值。例如，日期 2008-10-9、数字 210 和文本“Quarterly Earnings”都是常量。常量可以使用下列数据类型：

  • 字符串型（示例：=[Last Name] = "Smith"）

    字符串常量外加双引号，且最多可达 255 个字符。

  • 数字型（示例：=[Cost] >= 29.99）

    数字常量可以包含小数位数，且可以是正数或负数。

  • 日期型（示例：=[Date] <> 2002-7-7）

    日期常量不需要分隔符。

  • 布尔型（示例：=IF([Cost]>[Revenue], "Loss", "No Loss"）

    Yes 和 No 是布尔常量，可在条件表达式中使用。在上面的示例中，如果 Cost 大于 Revenue，则 IF 函数返回 Yes，而公式返回字符串“Loss”。如果 Cost 等于或小于 Revenue，则函数返回 No，而公式返回字符串“No Loss”。


关于显示总计值和计算值

在 Access Web Datasheet 的列表中，可以执行各种类型的计算。可以显示列表中某一列的合计值，如总和与平均值。可以添加使用公式计算列表中每一行值的计算列。还可以在指定某一列的默认值时使用公式。

以下图示用 Access Web Datasheet 显示员工-工资表列表。该列表在其底部的“汇总”行和标题为“应发工资”的计算列中显示合计值。

“汇总”行显示“个人”列中的行数和“应发工资”列中值的和。“应发工资”列使用显示在屏幕提示中的公式计算每一行的值。

关于显示合计值

关于在列中显示计算值

关于使用公式计算某一列的默认值

关于显示合计值

在数据表视图中，通过单击功能区上“列表”选项卡上的“显示合计”可以显示和隐藏“汇总”行。最初“汇总”行显示列表中每个数字列的和。如果列表中没有任何数字列，则显示列表最后一列中的项目数。不能对显示在“汇总”行中的值进行编辑。

启用“汇总”行之后，可以显示或隐藏特定列的合计值。通过从“汇总”行的下拉列表中选择不同的函数，还可以更改某一列使用的聚合函数。将鼠标指针停放在合计值上时出现的屏幕提示会指定该列使用的聚合函数。

不能根据合计值筛选列表中的数据。但是，如果列表已被筛选，则仅根据返回集中包含的项目计算合计值。“汇总”行不会与列表中的其他行一起进行排序。

下表列出了列表中支持的聚合函数以及每个函数支持的数据类型。

函数名称 | 说明 | 函数支持的数据类型
Average | 返回进行合计计算的列中值的平均值。 | 数字型、货币型和日期时间型
Count | 计算值的个数。对于布尔型、附件和 DocIcon 列，仅 Yes 值计算在内。 | 数字型、货币型、日期时间型、布尔型、附件、DocIcon、短文本、多行文本、单选项、多选项、查阅项、超链接
Maximum | 返回进行合计计算的列中最大的值。 | 数字型、货币型和日期时间型
Minimum | 返回进行合计计算的列中最小的值。 | 数字型、货币型和日期时间型
Sum | 对某一列中的值求和。 | 数字型和货币型
Standard Deviation | 返回进行汇总计算的列中值的标准偏差，假设这些值是总体中的样本。 | 数字型和货币型
Variance | 返回进行汇总计算的列中值的方差，假设这些值是总体中的样本。 | 数字型和货币型

单击“汇总”行单元格中的下拉箭头时，将会看到显示在列表中的“无”以及其他聚合函数。对于不想进行合计计算的列，请选择“无”。

可以对计算列中的值进行合计计算。适用于该列的函数列表将根据计算出的值的数据类型来确定。

返回页首

关于在列中显示计算值

为了使用公式计算一些值，可以将计算列添加到列表中。公式只能引用同一行内其他列中的值。在公式中不能引用特定单元格或单元格区域。

计算值存储在列中，但您不能对这些值进行编辑。当公式引用的值发生更改时，列表会自动地重新计算计算列的值。

将鼠标指针停放在计算值上时出现的屏幕提示指出了该列使用的公式。通过选择使用公式的单元格并进入编辑模式可以对公式进行编辑。完成对公式的编辑之后，退出编辑模式，新值会自动得到计算并显示在列中。

可以对计算列中的值进行排序和筛选。

返回页首

关于使用公式计算某一列的默认值

将某一列添加到类型为单行、选项、数字、货币或日期和时间的列表中时，可以将公式（而不是常数）指定为默认值。添加新行时，该列表将计算公式，同时在列中将结果显示为默认值。

将公式指定为默认值时，可以调用任何一个支持的函数，但是公式不能引用其他列。因为计算公式在前，在其他列中输入数据在后，所以不允许列引用。

返回页首


关于公式

公式是对列表中的值执行计算的等式。公式以等号 (=) 开头。例如，下面的公式将 2 与 3 相乘，然后将得到的结果加上 5。

=5+2*3

可在计算列中使用公式并计算列的默认值。

要点 只能在数据类型为“计算”的列中使用公式。无法将列的数据类型更改为“计算”。

公式还可包含下列所有内容或其中之一：函数、列引用、运算符和常量。

公式的组成部分
=PI()*[Result]^2

函数 PI() 函数返回值 pi：3.142...

引用（或列名称） [Result] 代表当前行的 Result 列中的值。

常量 直接输入到公式中的数字或文本，例如 2。

运算符 ^（插字号）运算符将数字乘幂，*（星号）运算符表示相乘。

示例

公式可能使用上面的一个或多个元素。下面是公式的一些示例（按复杂程度排序）。

  • 简单公式（如 =128+345）

    下列公式包含字面值和运算符。

    示例 | 说明
    =128+345 | 128 加上 345
    =5^2 | 5 的平方
  • 包含列引用的公式（如 =[Revenue] – [Cost]）

    下列公式引用同一列表中的其他列。

    示例 | 说明
    =[Revenue] | 使用 Revenue 列中的值
    =[Revenue]*10/100 | Revenue 列中的值的 10%
    =[Revenue] > [Cost] | 如果 Revenue 列中的值大于 Cost 列中的值，则返回 Yes
  • 调用函数的公式（如 =AVG(1, 2, 3, 4, 5)）

    下列公式调用内置函数。

    示例 | 说明
    =MAX(Q1, Q2, Q3, Q4) | 返回一组值中最大的值
    =IF(Cost>Revenue, "Not OK", "OK") | 如果成本大于收入，返回 Not OK。否则，返回 OK。
    =DAY("2008-4-15") | 返回日期的日部分。此公式返回数字 15。
  • 使用嵌套函数的公式（如 =SUM(ROUND([Cost],2),[Profit]）

    下列公式将一个或多个函数指定为函数参数。

    示例 说明
    =SUM(IF(A>B, A-B, 10), C) IF 函数返回列 A 和列 B 中的值之间的差值或 10。

    SUM 函数将 IF 函数返回的值与列 C 中的值相加。

    =DEGREES(PI()) PI 函数返回数字 3.14159265358979。

    DEGREES 函数将以弧度指定的值转换为角度。此公式返回值 180。
    =ISNUMBER(FIND("BD",Column1)) FIND 函数在 Column1 中搜索字符串 BD 并返回该字符串的起始位置。如果找不到字符串，则返回一个错误值。

    如果 FIND 函数返回数字值，则 ISNUMBER 函数返回 Yes。否则，返回 No。


编辑公式

  1. 单击计算列中的任意单元格。
  2. 再次单击该单元格以显示当前公式。
  3. 编辑公式，然后按 Enter。

    注意 在计算列中键入等号 (=) 后，只需通过单击该列中属于当前行的单元格即可粘贴列引用。但是，如果列的数据类型不支持计算，或者试图选择另一行中的单元格或选择多个单元格，则列表将不会在公式中粘贴列引用。

  4. 单击“继续”以确认更改。
  5. 如果列表中存在任何冲突、错误或待定更改，则会提示您提交或放弃更改。更改公式会导致列表结构的更改，因此只有在所有更改都已提交给服务器或被放弃，且已从列表中消除了所有冲突和错误之后，新的公式才会生效。

    单击“确定”，以提交更改并解决冲突和错误。

  6. 列表将把待定更改发送到服务器。如果存在冲突和错误，则会出现“解决冲突和错误”对话框。可接受或放弃更改。

要点 只能在数据类型为“计算”的列中使用公式。无法将列的数据类型更改为“计算”。


常见公式示例

在计算列中可使用下列示例。不包含列引用的示例可用于指定列的默认值。

要点 只能在数据类型为“计算”的列中使用公式。无法将列的数据类型更改为“计算”。

条件公式

显示 检查数字是否大于或小于另一个数字

使用 IF 函数完成该任务。

Column1 | Column2 | 公式 | 说明
15000 | 9000 | =Column1>Column2 | Column1 是否大于 Column2？(Yes)
15000 | 9000 | =IF(Column1<=Column2, "OK", "Not OK") | Column1 是否小于或等于 Column2？(Not OK)

显示 在比较列内容之后返回一个逻辑值

对于逻辑值（Yes 或 No）结果，可使用 AND、OR 和 NOT 函数。
Column1 | Column2 | Column3 | 公式 | 说明
15 | 9 | 8 | =AND(Column1>Column2, Column1<Column3) | 15 是否大于 9 并小于 8？(No)
15 | 9 | 8 | =OR(Column1>Column2, Column1<Column3) | 15 是否大于 9 或小于 8？(Yes)
15 | 9 | 8 | =NOT(Column1+Column2=24) | 15 加 9 是否不等于 24？(No)

对于其他计算结果，或 Yes 或 No 之外的其他任何值，可使用 IF、AND 和 OR 函数。

Column1 | Column2 | Column3 | 公式 | 说明
15 | 9 | 8 | =IF(Column1=15, "OK", "Not OK") | 如果 Column1 中的值等于 15，则返回“OK”。(OK)
15 | 9 | 8 | =IF(AND(Column1>Column2, Column1<Column3), "OK", "Not OK") | 如果 15 大于 9 并小于 8，则返回“Not OK”。(Not OK)
15 | 9 | 8 | =IF(OR(Column1>Column2, Column1<Column3), "OK", "Not OK") | 如果 15 大于 9 或小于 8，则返回“OK”。(OK)

显示 将零显示为空白或短划线

使用 IF 函数完成该任务。
Column1 | Column2 | 公式 | 说明
10 | 10 | =Column1-Column2 | 第一个数字减去第二个数字 (0)
10 | 10 | =IF(Column1-Column2,"",Column1-Column2) | 当值为零时返回 Null（空白列）
15 | 9 | =IF(Column1-Column2,"-",Column1-Column2) | 当值为零时返回短划线 (-)

日期和时间公式

显示 增加日期

若要增加日期的天数，可使用加法 (+) 运算符。请注意：执行日期操作时，必须将计算列的返回类型设置为“日期和时间”。
Column1 | Column2 | 公式 | 说明
2007-6-9 | 3 | =Column1+Column2 | 为 2007-6-9 增加 3 天 (2007-6-9)
2008-12-10 | 54 | =Column1+Column2 | 为 2008-12-10 增加 54 天 (2009-2-2)

若要增加日期的月数，可使用 DATE、YEAR、MONTH 和 DAY 函数。

Column1 | Column2 | 公式 | 说明
2007-6-9 | 3 | =DATE(YEAR(Column1),MONTH(Column1)+Column2,DAY(Column1)) | 为 2007-6-9 增加 3 个月 (2007-9-9)
2008-12-10 | 25 | =DATE(YEAR(Column1),MONTH(Column1)+Column2,DAY(Column1)) | 为 2008-12-10 增加 25 个月 (2011-1-10)

若要增加日期的年数，可使用 DATE、YEAR、MONTH 和 DAY 函数。

Column1 | Column2 | 公式 | 说明
2007-6-9 | 3 | =DATE(YEAR(Column1)+Column2,MONTH(Column1),DAY(Column1)) | 为 2007-6-9 增加 3 年 (2010-6-9)
2008-12-10 | 25 | =DATE(YEAR(Column1)+Column2,MONTH(Column1),DAY(Column1)) | 为 2008-12-10 增加 25 年 (2033-12-10)

若要同时增加日期的天数、月数和年数，可使用 DATE、YEAR、MONTH 和 DAY 函数。

Column1 | 公式 | 说明
2007-6-9 | =DATE(YEAR(Column1)+3,MONTH(Column1)+1,DAY(Column1)+5) | 为 2007-6-9 增加 3 年、1 个月和 5 天 (2010-7-14)
2008-12-10 | =DATE(YEAR(Column1)+1,MONTH(Column1)+7,DAY(Column1)+5) | 为 2007-6-9 增加 1 年、7 个月和 5 天 (2009-1-14)

显示 计算两个日期之间的差异

使用 DATEDIF 函数完成该任务。
Column1 | Column2 | 公式 | 说明
1995-1-1 | 1999-6-15 | =DATEDIF(Column1, Column2,"d") | 返回两个日期之间的天数 (1626)
1995-1-1 | 1999-6-15 | =DATEDIF(Column1, Column2,"ym") | 返回日期之间的月数，忽略年部分 (5)
1995-1-1 | 1999-6-15 | =DATEDIF(Column1, Column2,"yd") | 返回日期之间的天数，忽略年部分 (165)

显示 计算两个时间之间的差异

若要以标准时间格式（小时:分:秒）表示结果，可使用减号运算符 (-) 和 TEXT 函数。

若要使用此方法，小时必须不超过 24，分和秒必须不超过 60。

Column1 | Column2 | 公式 | 说明
2007-6-9 10:35 AM | 2007-6-9 3:30 PM | =TEXT(Column2-Column1,"h") | 两个时间之间的小时数 (4)
2007-6-9 10:35 AM | 2007-6-9 3:30 PM | =TEXT(Column2-Column1,"h:mm") | 两个时间之间的小时数和分钟数 (4:55)
2007-6-9 10:35 AM | 2007-6-9 3:30 PM | =TEXT(Column2-Column1,"h:mm:ss") | 两个时间之间的小时数、分钟数和秒数 (4:55:00)

若要按一种时间单位表示总的结果，可使用 INT 函数，或使用 HOUR、MINUTE 和 SECOND 函数。

Column1 | Column2 | 公式 | 说明
2007-6-9 10:35 AM | 2007-6-10 3:30 PM | =INT((Column2-Column1)*24) | 两个时间之间的总小时数 (28)
2007-6-9 10:35 AM | 2007-6-10 3:30 PM | =INT((Column2-Column1)*1440) | 两个时间之间的总分钟数 (1735)
2007-6-9 10:35 AM | 2007-6-10 3:30 PM | =INT((Column2-Column1)*86400) | 两个时间之间的总秒数 (104100)
2007-6-9 10:35 AM | 2007-6-10 3:30 PM | =HOUR(Column2-Column1) | 两个时间之间的小时数，差值不超过 24。(4)
2007-6-9 10:35 AM | 2007-6-10 3:30 PM | =MINUTE(Column2-Column1) | 两个时间之间的分钟数，差值不超过 60。(55)
2007-6-9 10:35 AM | 2007-6-10 3:30 PM | =SECOND(Column2-Column1) | 两个时间之间的秒数，差值不超过 60。(0)

显示 转换时间

若要将小时数从标准时间格式转换为小数格式，可使用 INT 函数。
Column1 | 公式 | 说明
10:35 AM | =(Column1-INT(Column1))*24 | 12:00 AM 以后的小时数 (10.583333)
12:15 PM | =(Column1-INT(Column1))*24 | 12:00 AM 以后的小时数 (12.25)

若要将小时数从小数格式转换为标准时间格式（小时:分:秒），可使用除法运算符和 TEXT 函数。

Column1 | 公式 | 说明
10:5833 | =TEXT(Column1/24, "h:mm") | 12:00 AM 以后的小时数 (10:35:00)
12:25 | =TEXT(Column1/24, "h:mm") | 12:00 AM 以后的小时数 (12:15)

显示 插入 Julian 日期

“Julian 日期”一词有时用来指代一种日期格式，这种格式是当前年份和从该年份开始的天数的组合。例如，2007 年 1 月 1 日表示为 2007001，而 2007 年 12 月 31 日表示为 2007365。

在天文学中也经常使用一种 Julian 日期，这是一种序列日期系统，起始于 B.C.E. 4713 年 1 月 1 日。

注释 该格式并非基于 Julian 历。

若要将日期转换为 Julian 日期，可使用 TEXT 和 DATEVALUE 函数。

Column1 | 公式 | 说明
2007-6-23 | =TEXT(Column1,"yy")&TEXT((Column1-DATEVALUE("1/1/"& TEXT(Column1,"yy"))+1),"000") | 以 Julian 格式表示的日期，用两位数表示年份 (07174)
2007-6-23 | =TEXT(Column1,"yyyy")&TEXT((Column1-DATEVALUE("1/1/"&TEXT(Column1,"yy"))+1),"000") | 以 Julian 格式表示的日期，用四位数表示年份 (2007174)

若要将日期转换为天文学中使用的 Julian 日期，可使用常量 2415018.50。

该公式仅适用于 1901-3-1 之后的日期，且需要使用 1900 日期系统。

Column1 | 公式 | 说明
2007-6-23 | =Column1+2415018.50 | 以天文学中使用的“Julian”格式表示的日期 (2454274.50)

显示 以星期名称的形式显示日期

若要将日期转换为星期名称文本，可使用 TEXT 和 WEEKDAY 函数。
Column1 | 公式 | 说明
2007-2-19 | =TEXT(WEEKDAY(Column1), "dddd") | 计算该日期的星期名称，并返回该日的全称 (Monday)
2008-1-3 | =TEXT(WEEKDAY(Column1), "ddd") | 计算该日期的星期名称，并返回该日的缩写名称 (Thu)

数学公式

显示 数字求和

若要将一行中两列或多个列中的数字相加，可使用加法运算符或 SUM 函数。

Column1 | Column2 | Column3 | 公式 | 说明
6 | 5 | 4 | =Column1+Column2+Column3 | 将前三列中的值相加 (15)
6 | 5 | 4 | =SUM(Column1,Column2,Column3) | 将前三列中的值相加 (15)
6 | 5 | 4 | =SUM(IF(Column1>Column2, Column1-Column2, 10), Column3) | 如果 Column1 大于 Column2，则将其差值与 Column3 相加。否则，则将 10 与 Column3 相加。(5)

显示 数字相减

使用减法 (-) 运算符完成该任务。
Column1 | Column2 | Column3 | 公式 | 说明
15000 | 9000 | -8000 | =Column1-Column2 | 从 15000 减去 9000 (6000)
15000 | 9000 | -8000 | =SUM(Column1, Column2, Column3) | 将前三列中的数字相加，包括负值 (16000)

显示 计算两个数字之差（以百分比表示）

使用减法 (-) 和除法 (/) 运算符以及 ABS 函数。
Column1 | Column2 | 公式 | 说明
2342 | 2500 | =(Column2-Column1)/ABS(Column1) | 百分比差值（6.75% 或 0.06746）

显示 数字相乘

使用乘法 (*) 运算符或 PRODUCT 函数完成该任务。
Column1 | Column2 | 公式 | 说明
5 | 2 | =Column1*Column2 | 将前两列中的数字相乘 (10)
5 | 2 | =PRODUCT(Column1, Column2) | 将前两列中的数字相乘 (10)
5 | 2 | =PRODUCT(Column1,Column2,2) | 将前两列中的数字和数字 2 相乘 (20)

显示 数字相除

使用除法运算符 (/) 完成该任务。

Column1 | Column2 | 公式 | 说明
15000 | 12 | =Column1/Column2 | 15000 除以 12 (1250)
15000 | 12 | =(Column1+10000)/Column2 | 将 15000 和 9000 相加，再将总数除以 12 (2000)

显示 计算数字的平均值

平均值也称为平均数。若要计算一行中两列或多个列中数字的平均值，可使用 AVERAGE 函数。

Column1 | Column2 | Column3 | 公式 | 说明
6 | 5 | 4 | =AVERAGE(Column1, Column2,Column3) | 前三列中数字的平均值 (5)
6 | 5 | 4 | =AVERAGE(IF(Column1>Column2, Column1-Column2, 10), Column3) | 如果 Column1 大于 Column2，则计算其差值与 Column3 的平均值。否则，计算数值 10 与 Column3 的平均值。(2.5)

显示 计算数字的中值

中值是按顺序排列在一起的一组数字的中间值。可使用 MEDIAN 函数计算一组数字的中值。
A | B | C | D | E | F | 公式 | 说明
10 | 7 | 9 | 27 | 0 | 4 | =MEDIAN(A, B, C, D, E, F) | 前 6 列中数字的中值 (8)

显示 计算区域中的最小数字或最大数字

若要计算一行中两列或多个列中的最小数字或最大数字，可使用 MIN 和 MAX 函数
Column1 | Column2 | Column3 | 公式 | 说明
10 | 7 | 9 | =MIN(Column1, Column2, Column3) | 最小数字 (7)
10 | 7 | 9 | =MAX(Column1, Column2, Column3) | 最大数字 (10)

显示 数值计数

若要计算数字值的个数，可使用 COUNT 函数。
Column1 | Column2 | Column3 | 公式 | 说明
苹果 |  | 2007-12-12 | =COUNT(Column1, Column2, Column3) | 计算包含数字值的列的数量，包括日期和时间值。不包括文本和空值。(1)
￥12 | #DIV/0! | 1.01 | =COUNT(Column1, Column2, Column3) | 计算包含数字值的列的数量，但不包括错误和逻辑值 (2)

显示 按百分比增加或减小数字

使用百分比 (%) 运算符完成该任务。
Column1 | Column2 | 公式 | 说明
23 | 3% | =Column1*(1+5%) | 将 Column1 中的数字增加 5% (24.15)
23 | 3% | =Column1*(1+Column2) | 按 Column2 中的百分比值 (3%) 增加 Column1 中的数字 (23.69)
23 | 3% | =Column1*(1-Column2) | 按 Column2 中的百分比值 (3%) 减小 Column1 中的数字 (22.31)

显示 对数字进行幂运算

使用指数 (^) 运算符或 POWER 函数完成该任务。
Column1 | Column2 | 公式 | 说明
5 | 2 | =Column1^Column2 | 计算 5 的平方 (25)
5 | 3 | =POWER(Column1, Column2) | 计算 5 的立方 (125)

显示 对数字进行舍入运算

若要对数字进行舍入运算，可使用 ROUNDUP、ODD 和 EVEN 函数。

Column1 | 公式 | 说明
20.3 | =ROUNDUP(Column1,0) | 将 20.3 向上舍入到最接近的整数 (21)
-5.9 | =ROUNDUP(Column1,0) | 将 -5.9 向上舍入 (-6)
12.5493 | =ROUNDUP(Column1,2) | 将 12.5493 向上舍入到最接近的百分位，两位小数 (12.55)
20.3 | =EVEN(Column1) | 将 20.3 向上舍入到最接近的偶数 (22)
20.3 | =ODD(Column1) | 将 20.3 向上舍入到最接近的奇数 (21)

若要对数字进行向下舍入运算，可使用 ROUNDDOWN 函数。

Column1 | 公式 | 说明
20.3 | =ROUNDDOWN(Column1,0) | 将 20.3 向下舍入到最接近的整数 (20)
-5.9 | =ROUNDDOWN(Column1,0) | 将 -5.9 向下舍入 (-5)
12.5493 | =ROUNDDOWN(Column1,2) | 将 12.5493 向下舍入到最接近的百分位，两位小数 (12.54)

若要将数字舍入到最接近的数字或小数，可使用 ROUND 函数。

Column1 | 公式 | 说明
20.3 | =ROUND(Column1,0) | 将 20.3 向下舍入，因为小数部分小于 .5 (20)
5.9 | =ROUND(Column1,0) | 将 5.9 向上舍入，因为小数部分大于 .5 (6)
-5.9 | =ROUND(Column1,0) | 将 -5.9 向下舍入，因为小数部分小于 -.5 (-6)
1.25 | =ROUND(Column1, 1) | 将数字舍入到最接近的十分位（一个小数位）。因为要舍入的部分是 0.05 或更大，所以数字向上舍入（结果是 1.3）
30.452 | =ROUND(Column1, 2) | 将数字舍入到最接近的百分位（两个小数位）。因为要舍入的小数部分为 0.002，它小于 0.005，所以数字向下舍入（结果是 30.45）

若要将某个数字舍入到 0 以上的有效位，可使用 ROUND、ROUNDUP、ROUNDDOWN、INT 和 LEN 函数。

Column1 | 公式 | 说明
5492820 | =ROUND(Column1,3-LEN(INT(Column1))) | 将数字舍入到 3 个有效位 (5490000)
22230 | =ROUNDDOWN(Column1,3-LEN(INT(Column1))) | 将底部的数字向下舍入到 3 个有效位 (22200)
5492820 | =ROUNDUP(Column1, 5-LEN(INT(Column1))) | 将顶部的数字向上舍入到 5 个有效位 (5492900)

文本公式

显示 更改文字的大小写

使用 UPPER、LOWER 或 PROPER 函数完成该任务。
Column1 | 公式 | 说明
nancy Davolio | =UPPER(Column1) | 将文字更改为大写 (NANCY DAVOLIO)
nancy Davolio | =LOWER(Column1) | 将文字更改为小写 (nancy davolio)
nancy Davolio | =PROPER(Column1) | 将文字更改为标题样式 (Nancy Davolio)

显示 组合名字与姓氏

使用与 (&) 运算符或 CONCATENATE 函数完成该任务。
Column1 | Column2 | 公式 | 说明
Nancy | Fuller | =Column1&Column2 | 组合两个字符串 (NancyFuller)
Nancy | Fuller | =Column1&" "&Column2 | 组合两个字符串，以空格分隔 (Nancy Fuller)
Nancy | Fuller | =Column2&","&Column1 | 组合两个字符串，以逗号分隔 (Fuller, Nancy)
Nancy | Fuller | =CONCATENATE(Column2, ",", Column1) | 组合两个字符串，以逗号分隔 (Fuller,Nancy)

显示 合并来自不同列的文本和数字

使用 CONCATENATE 和 TEXT 函数以及与 (&) 运算符完成该任务。
Column1 | Column2 | 公式 | 说明
Buchanan | 28 | =Column1&" sold "&Column2&" units." | 将以上内容合并为一个短语 (Buchanan sold 28 units)
Dodsworth | 40% | =Column1&" sold "&TEXT(Column2,"0%")&" of the total sales." | 将以上内容合并为一个短语 (Dodsworth sold 40% of the total sales)。 注释 TEXT 函数追加 Column2 的格式化值而不是基础值 .4。
Buchanan | 28 | =CONCATENATE(Column1," sold ",Column2," units.") | 将以上内容合并为一个短语 (Buchanan sold 28 units)

显示 合并文本和日期（或时间）

使用 TEXT 函数以及与 (&) 运算符完成该任务。
Column1 | Column2 | 公式 | 说明
Billing Date | 2007-6-5 | ="Statement date: "&TEXT(Column2, "d-mmm-yyyy") | 合并文本和日期 (Statement date: 2007-6-5)
Billing Date | 2007-6-5 | =Column1&" "&TEXT(Column2, "mmm-dd-yyyy") | 将不同列中的文本和日期合并到一个列中 (Billing Date 2007-6-5)

显示 比较列内容

若要将某一列与另一列或一个值列表相比较，可使用 EXACT 和 OR 函数。
Column1 | Column2 | 公式 | 说明
BD122 | BD123 | =EXACT(Column1,Column2) | 比较前两列的内容 (No)
BD122 | BD123 | =EXACT(Column1, "BD122") | 比较 Column1 的内容和字符串“BD122”(Yes)
BD122 | BD123 | =OR(EXACT("BD121", Column1, Column2) | 比较字符串“BD121”和前两列的内容 (No)

显示 检查某一列的值或其中部分值是否与特定的文本相匹配

若要检查某一列的值或部分值是否与特定的文本相匹配，可使用 IF、FIND、SEARCH 和 ISNUMBer 函数。

Column1 | 公式 | 说明
Davolio | =IF(Column1="Davolio", "OK", "Not OK") | 检查 Column1 是否为 Davolio (OK)
Davolio | =IF(ISNUMBER(FIND("v",Column1)), "OK", "Not OK") | 检查 Column1 是否包含字母 v (OK)
BD123 | =ISNUMBER(FIND("BD",Column1)) | 检查 Column1 是否包含 BD (Yes)

显示 计算非空列的数量

使用 COUNTA 函数完成该任务。
Column1 | Column2 | Column3 | 公式 | 说明
Sales | 19 |  | =COUNTA(Column1, Column2) | 计算非空列的数量 (2)
Sales | 19 |  | =COUNTA(Column1, Column2, Column3) | 计算非空列的数量 (2)

显示 删除文本中的字符

使用 LEN、LEFT 和 RIGHT 函数完成该任务。
Column1 | 公式 | 说明
Vitamin A | =LEFT(Column1,LEN(Column1)-2) | 返回 7 (9-2) 个字符，从左边开始 (Vitamin)
Vitamin B1 | =RIGHT(Column1, LEN(Column1)-8) | 返回 2 (10-8) 个字符，从右边开始 (B1)

显示 删除列开头和结尾的空格

使用 TRIM 函数完成该任务。
Column1 | 公式 | 说明
Hello there! | =TRIM(Column1) | 删除开头和结尾的空格 (Hello there!)

显示 在列中重复某个字符

使用 REPT 函数完成该任务。
公式 | 说明
=REPT(".",3) | 重复句点 3 次 (...)
=REPT("-",10) | 重复短划线 10 次 (----------)

其他公式

显示 隐藏列中的错误值

若要在错误值的位置显示短划线、#N/A 或 NA，可使用 ISERROR 函数。
Column1 | Column2 | 公式 | 说明
10 | 0 | =Column1/Column2 | 导致错误 (#DIV/0)
10 | 0 | =IF(ISERROR(Column1/Column2),"NA",Column1/Column2) | 当值是错误值时，返回 NA
10 | 0 | =IF(ISERROR(Column1/Column2),"-",Column1/Column2) | 当值是错误值时，返回短划线


显示或隐藏汇总值

  • 若要显示或隐藏列表中所有列的汇总值，请单击功能区中的“列表”选项卡，然后在“数据表”组中，单击“显示合计”。

    “汇总”行显示在列表的底部。它显示数字列中数值的总和；如果列表中没有数字列，则在列表的最后一列中显示非空值行的行数。如果单击“显示合计”时汇总行可见，则将隐藏汇总行。

  • 若要显示或隐藏列表中一列或多列的汇总值，请执行下列操作：
    1. 单击“汇总”行中的一个单元格。
    2. 单击该单元格中出现的向下箭头。
    3. 从聚合函数下拉列表中，选择“无”可隐藏汇总值。选择除“无”之外的其他函数可显示汇总值。


解决汇总值和计算值的问题

得到一条消息，提示公式的计算结果将被发送到服务器

出现语法错误

单元格显示公式，而不是结果

在编辑计算列时得到一条有关待定更改的消息

出现超时或意外错误

出现错误，指示列表结构已经更改

出现错误，指示没有权限更改列表中的计算列

因一个或多个其他列需要值而不能编辑公式

出现错误，指示不允许一个或多个列引用

出现错误，指示某一列不存在

编辑计算列时，无法选择所需的列

计算列中的单元格显示 #NAME?

计算列中的单元格显示 #CIRC!

计算列中的单元格显示 #VALUE!

计算列中的单元格显示 #NUM!

计算列中的单元格显示 #DIV/0!

计算列中的单元格显示 #NULL!

计算列中的单元格显示 #N/A

得到一条消息，提示公式的计算结果将被发送到服务器

您对公式进行了编辑，列表正试图向服务器提交新结果。请执行下列操作之一：

  • 单击“继续”，以完成编辑操作。如果存在待定的更改、冲突或错误，列表将提示您采取相应的措施。
  • 单击“取消”，以返回到包含该公式的单元格。

返回页首

出现语法错误

这可能是因为下列一种或多种原因引起的：

  • 公式中使用的括号不匹配。确保每个左括号都有匹配的右括号。
  • 公式中包括除等号 (=) 和计算运算符之外的特殊字符。
  • 公式调用了一个或多个函数，但是为其中一个或多个函数指定的参数个数不正确。
  • 公式使用了列表不支持的函数。特别要注意，列表不支持 Rand 和 Now 函数。不能在计算列中使用 Today 和 Me 函数，但是可以使用这两个函数指定某一列的默认值。

返回页首

单元格显示公式，而不是结果

确保包含公式的单元格是计算列的一部分。如果在除计算列之外的某一列（如类型为单行文本的列）中输入公式，列表会将该公式视为文本字符串，显示该公式原有的形式。

返回页首

在编辑计算列时得到一条有关待定更改的消息

对计算列所做的任何更改都会导致列表结构的更改。仅当不存在待定更改、冲突和错误时，才可以对列表做结构上的更改。如果列表遇到列表中的这些情况之一，系统就会提示您等待，直到将所有更改提交给服务器，并解决任何冲突和错误之后，才可添加或编辑列。

返回页首

出现超时或意外错误。

刷新列表，然后对计算列重复所做的更改。

返回页首

出现错误，指示列表结构已经更改

编辑计算列会导致列表结构的更改。如果列表遇到以下问题：所做的两个更改之间有冲突，及其他用户所做的结构上的更改，则系统将提示您刷新列表。刷新列表会更新视图，但同时会放弃对计算列所做的更改。请尝试重复所做的更改。

返回页首

出现错误，指示没有权限更改列表中的计算列

编辑计算列会导致列表结构的更改。如果没有权限更改列表结构，则不能编辑列表中的计算列。

返回页首

因一个或多个其他列需要值而不能编辑公式

列表必须先提交您所做的所有更改，然后您才能够编辑公式。如果某一行的某一列被设置为必需列，则不能提交该行，但它保留为空白。在所有必需列中输入有效的值，然后尝试编辑公式。

返回页首

出现错误，指示不允许一个或多个列引用

公式中包括对某一列的引用，而该列的数据类型不支持计算。需要对公式进行编辑，以删除对不支持的列的引用。

返回页首

出现错误，指示某一列不存在

已经将字符串指定为操作数，但是列表找不到其名称与字符串相匹配的列。请执行下列一项或多项操作：

  • 确保公式中引用的列存在。
  • 如果列名称中包括空格或特殊字符，则请确保将列名称括在方括号 ([]) 中。
  • 验证列引用的拼写。

返回页首

编辑计算列时，无法选择所需的列

在计算列中键入等号 (=) 后，只需通过单击该列中属于当前行的单元格即可粘贴列引用。但是，如果该列具有不支持计算的数据类型，或者试图选择其他行中的单元格或选择多个单元格，则列表将不会在公式中粘贴列引用。

返回页首

计算列中的单元格显示 #NAME?

公式中引用的列已不存在。请在列表中添加该列，或对公式进行编辑以删除该引用。

返回页首

计算列中的单元格显示 #CIRC!

这种错误是由一个或多个循环引用引起的。在下列情况下会出现循环引用：

  • 列中使用的公式包含对其自身的引用。例如，用于计算“税收”列的值的公式引用了“税收”列。
  • 两个或更多的计算列相互引用。例如，Calc1 列使用公式 =[Calc2]+2，Calc2 列使用公式 =[Calc1]-1。
要删除循环引用，请执行下面的一项或多项操作：
  • 确保公式未引用包含该公式的列。
  • 如果公式引用了其他列，则应确保所引用的列中的公式未引用前者所在的列。
  • 验证列引用的拼写。

返回页首

计算列中的单元格显示 #VALUE!

处于以下两种情况之一时会出现这种错误：

  • 在公式中使用了错误类型的操作数。
  • 为公式中使用的函数指定了错误类型的参数。
验证操作数和参数的数据类型。

返回页首

计算列中的单元格显示 #NUM!

当公式中包含无效的数值时会出现这种错误，例如：

  • 公式返回的值太大，无法在列表中表示。
  • 公式遇到早于 1/1/1900 的日期值。
  • 公式中使用的函数需要一个数值参数，但您为其指定了一个非数值参数。为公式中使用的函数指定了错误类型的参数。

返回页首

计算列中的单元格显示 #DIV/0!

当一个数字被零 (0) 除时会出现这种错误，例如：

  • 明确指定被零 (0) 除，例如 =133/0。
  • 如果公式包含列引用，进行计算时所引用的列中的值则会导致被零 (0) 除。例如，[ECount1] 和 [ECount2] 列在某些行中具有相同的值，因此公式 =[Qty]/[ECount1]-[ECount2] 将因这些行导致出错。

返回页首

计算列中的单元格显示 #NULL!

当在公式中指定的参数或操作数具有空值时会出现这种错误。如果公式中的一个元素具有空值，则整个公式的计算结果将是空值。为避免这种错误，应确保将空值替换为零 (0)。可能还需要将引用列的设置更改为“必需”，以便所有行都具有非空值。

返回页首

计算列中的单元格显示 #N/A

当函数缺少值时会出现这种错误。应确保已经指定了函数中的所有必需参数。

返回页首


关于函数

函数是一些预定义的公式，通过使用一些称为参数的特定数值来按特定的顺序或结构执行计算。函数可用于执行简单或复杂的计算。例如，ROUND 函数可将 Cost 列中的数字四舍五入。

=ROUND(Cost, 2)

下面是使用函数时应该记住的主要问题：

  • 结构 函数的结构以等号 (=) 开始，后面紧跟函数名称和左括号，然后是以逗号分隔输入该函数的参数，最后是右括号。
  • 函数名称 列表所支持的函数的名称。每个函数都具有特定数量的参数，处理这些参数，并返回值。
  • 参数 参数可以是数字、文本、逻辑值（如 True 或 False）或列引用。指定的参数都必须生成一个有效的参数值。参数也可以是常量、公式或其他函数。
  • 参数工具提示 在键入函数时，会出现一个带有语法和参数的工具提示。例如，键入 =ROUND( 时，工具提示就会出现。工具提示只在使用内置函数时出现。

注意 列表不支持 RAND 和 NOW 函数。计算列中不支持 TODAY 和 ME 函数，但在列的默认值设置中支持这两个函数。

返回页首

嵌套函数

在某些情况下，可能需要将某函数作为另一函数的参数使用。例如，下面的公式使用嵌套的 AVERAGE 函数并将结果与两列数值之和进行比较。

=AVERAGE([Cost1], SUM([Cost2]+[Discount]))

有效返回值 将函数用作参数时，则函数必须返回与参数相同类型的值。例如，如果参数使用 Yes 或 No，则嵌套函数必须返回 Yes 或 No。如果它没有返回 Yes 或 No，则列表将显示错误值 #VALUE!。

嵌套层数限制 公式可包含多达八层的嵌套函数。当函数 B 用作函数 A 中的参数时，函数 B 则为第二层函数。例如，SUM 函数是第二层函数，因为它是 AVERAGE 函数的参数。在 SUM 函数中嵌套的函数则为第三层函数，以此类推。

返回页首


添加或编辑计算列

可添加一个列，它将根据同一行中的其他值计算每一行的值。

添加计算列

  1. 在功能区中，单击“列表”选项卡，然后在“设置”组中，单击“创建列”。
  2. 在“创建列”页上，为该列指定一个名称。
  3. 选择“计算值”作为将要存储在该列中的信息的类型。
  4. 在“公式”文本区中，键入一个新的公式。若要插入列引用，请在“插入列”列表中选择一列，再单击“添加到公式”。
  5. 指定将由公式返回的值的格式和其他相关设置。

编辑计算列

  1. 右键单击列，再单击“编辑/删除列”。
  2. 在“公式”文本区中，编辑现有公式。若要插入列引用，请在“插入列”列表中选择一列，再单击“添加到公式”。
  3. 指定将由公式返回的值的格式和其他相关设置。

注释

  • 添加或编辑列会导致列表结构的更改。仅当不存在待定更改、冲突和错误时，才可对列表做结构上的更改。如果列表遇到列表中的这些情况之一，系统就会提示您等待，直到将所有更改提交给服务器，并解决任何冲突和错误之后，才可添加或编辑列。
  • 不能将某个列的数据类型更改为“计算值”。若要在某个非计算列中使用公式，必须先删除该列，然后添加一个计算列。


更改显示在列中的总计值类型

  1. 单击要更改其总计值类型的列的“汇总”行。
  2. 单击下拉箭头，从列表中选择所需的函数。

注意 从列表中对某一列选择“无”将关闭该列的总计值。


DATE

返回代表某个特定日期的有序序列数。

语法

DATE(year,month,day)

Year year 参数可以是 1 到 4 位数。

  • 如果 year 在 0（零）到 1899（不包括）之间，则会将该值加上 1900 来计算年。例如，DATE(108,1,2) 返回 2008 年 1 月 2 日 (1900+108)。

  • 如果 year 在 1900 到 9999（不包括）之间，则会将该值用作年。例如，DATE(2008,1,2) 返回 2008 年 1 月 2 日。

Month 是代表年中月份的数字。如果 month 大于 12，则 month 会将该月份数与指定年中的第一个月相加。例如，DATE(2008,14,2) 返回代表 2009 年 2 月 2 日的序列数。

Day 是代表该月份中第几天的一个数字。如果 day 大于月中指定的天数，则 day 会将天数与该月中的第一天相加。例如，DATE(2008,1,35) 返回代表 2008 年 2 月 4 日的序列数。

说明

  • 日期是作为有序序列数进行存储的，因此可将其用于计算。默认情况下，1899 年 12 月 31 日的序列数为 1，而 2008 年 1 月 1 日的序列数为 39448，因为它是 1900 年 1 月 1 日之后的第 39,448 天。
  • 函数 DATE 在年、月和日为变量的公式中非常有用。

示例

Year | Month | Day | 公式 | 说明（结果）
2008 | 1 | 1 | =DATE([Year],[Month],[Day]) | 该日期的序列日期 (2008-1-1 或 39448)


DATEDIF

计算两个日期之间的天数、月数或年数。此函数是为与 Lotus 1-2-3 兼容而提供的。

语法

DATEDIF(start_date,end_date,unit)

Start_date 代表一段时期的第一个日期或起始日期的日期。日期可以放在引号内作为文本字符串输入（如 "2001-1-30"），也可以作为序列数（如 36921，如果使用的是 1900 日期系统，则它代表 2001 年 1 月 30 日）输入，或作为其他公式或函数的结果（如 DATEVALUE("2001-1-30")）输入。

End_date 代表一段时期的最后一个日期或结束日期的日期。

Unit 要返回的信息的类型：

Unit | 返回
"Y" | 一段时期内完整的年数。
"M" | 一段时期内完整的月数。
"D" | 一段时期内的天数。
"MD" | start_date 和 end_date 之间相差的天数。忽略日期的月数和年数。
"YM" | start_date 和 end_date 之间相差的月数。忽略日期的天数和年数。
"YD" | start_date 和 end_date 之间相差的天数。忽略日期的年数。

说明

  • 日期是作为有序序列数进行存储的，因此可将其用于计算。默认情况下，1899 年 12 月 31 日的序列数为 1，而 2008 年 1 月 1 日的序列数为 39448，因为它是 1900 年 1 月 1 日之后的第 39,448 天。
  • DATEDIF 函数在需要计算年龄的公式中很有用。

示例

Start_date | End_date | 公式 | 说明（结果）
2001-1-1 | 2003-1-1 | DATEDIF(Start_date,End_date,"Y") | 这段时期经历了两个完整年 (2)
2001-6-1 | 2002-8-15 | DATEDIF(Start_date,End_date,"D") | 2001 年 6 月 1 日和 2002 年 8 月 15 日之间有 440 天 (440)
2001-6-1 | 2002-8-15 | DATEDIF(Start_date,End_date,"YD") | 6 月 1 日和 8 月 15 日之间有 75 天，忽略日期的年数 (75)
2001-6-1 | 2002-8-15 | DATEDIF(Start_date,End_date,"MD") | 1 和 15（start_date 的天数和 end_date 的天数）之间相差的天数，忽略日期的月数和年数 (14)


DATETIME

DATETIME 函数是 DATE 和 TIME 函数的组合。

DATE 返回代表特定日期的序列号。

TIME 返回的小数值为 0（零）到 0.99999999 之间的数值，代表从 0:00:00 (12:00:00 AM) 到 23:59:59 (11:59:59 PM) 之间的时间。

语法

DATETIME(year,month,day,hour,minute,second)

Year Year 参数可以是一到四位数字。不能使用 1900 之前的年份。如果 year 参数在 0（零）到 1899 之间，则会将该值加上 1900 来计算年份。例如，DATETIME(108,1,2,n,n,n) 返回日期值 39.449，该值是代表 2008 (1900+108) 年 1 月 2 日的序列数。如果 year 参数在 1900 到 9999 之间，则会将该值用作年份值。例如，DATETIME(2008,1,2,n,n,n) 也返回日期值 39.449。

Month Month 是代表年中月份的数字。如果 month 大于 12，则 month 会将该月份数与指定年份中的第一个月相加。例如，DATETIME(2008,14,2,n,n,n) 返回代表 2009 年 2 月 2 日的序列数。

Day Day 是代表该月份中第几天的数字。如果 day 大于指定月份中的天数，则 day 会将天数与该月中的第一天相加。例如，DATETIME(2008,1,35,n,n,n) 返回代表 2008 年 2 月 4 日的序列数。

Hour Hour 为 0（零）到 32767 之间的数值，代表小时。任何大于 23 的数值都将除以 24，其余数将被视为小时值。例如，DATETIME(n,n,n ,27,0,0) 返回时间值 .125 或 3:00 AM。

Minute Minute 为 0 到 32767 之间的数值，代表分钟。任何大于 59 的数值都将被转换为小时和分钟。例如，DATETIME(n,n,n ,0,750,0) 返回时间值 .520833 或 12:30 PM。

Second Second 为 0 到 32767 之间的数值，代表秒。任何大于 59 的数值都将被转换为小时、分钟和秒。例如，DATETIME(n,n,n ,0,0,2000) 返回时间值 .023148 或 12:33:20 AM。

注解

日期是作为有序序列数进行存储的，因此可将其用于计算。默认情况下，1899 年 12 月 31 日的序列数为 1，而 2008 年 1 月 1 日的序列数为 39448，因为它是 1900 年 1 月 1 日之后的第 39,448 天。

示例

Year | Month | Day | Hour | Minute | Second | 公式 | 说明
2006 | 12 | 1 | 12 | 45 | 25 | =DATETIME([Year],[Month],[Day],[Hour],[Minute],[Second]) | 日期序列数和该日期中某一时间的小数表示形式 (39,052.5315393519)

返回页首


DATEVALUE

返回 date_text 所代表的日期的序列数。使用 DATEVALUE 可将由文本所代表的日期转换为序列数。

语法

DATEVALUE(date_text)

Date_text 是以日期格式表示的日期的文本。例如，"2008-1-30" 或 "30-Jan-2008" 是放在引号内的代表日期的文本字符串。

如果省略 date_text 中的年份部分，则 DATEVALUE 使用服务器内置时钟的当前年份。date_text 中的时间信息将被忽略。

说明

  • 日期是作为有序序列数进行存储的，因此可将其用于计算。默认情况下，1899 年 12 月 31 日的序列数为 1，而 2008 年 1 月 1 日的序列数为 39448，因为它是 1900 年 1 月 1 日之后的第 39,448 天。
  • 大部分函数都会自动将日期值转换为序列数。

示例

公式 | 说明（结果）
=DATEVALUE("2008-8-22") | 该文本日期的序列数 (39682)
=DATEVALUE("22-AUG-2008") | 该文本日期的序列数 (39682)
=DATEVALUE("2008-2-23") | 该文本日期的序列数 (39501)
=DATEVALUE("5-JUL") | 该文本日期的序列数，假定计算机的内置时钟设置为 2000 (37807)


DAY

返回由序列数所表示的某日期的天数。用 1 到 31 范围内的一个整数表示。

语法

DAY(serial_number)

Serial_number 是要查找的那一天的日期。

说明

  • 日期是作为有序序列数进行存储的，因此可将其用于计算。默认情况下，1899 年 12 月 31 日的序列数为 1，而 2008 年 1 月 1 日的序列数为 39448，因为它是 1900 年 1 月 1 日之后的第 39,448 天。
  • 不论所提供的日期值以何种格式显示，由 YEAR、MONTH 和 DAY 函数返回的值都是 Gregorian 值。例如，如果所提供的日期的显示格式为 Hijri，则 YEAR、MONTH 和 DAY 函数返回的值将是与等同的 Gregorian 日期相关联的值。

示例

公式 | 说明（结果）
=DAY("2008-4-15") | 该日期的天数 (15)


DAYS360

按一年 360 天的算法（一年 12 个月，每月 30 天）返回两个日期之间相差的天数，它用于某些会计计算中。如果您的财会系统是基于一年 12 个月，每月 30 天，可使用此函数帮助计算支付款项。

语法

DAYS360(start_date,end_date,method)

Start_date 和 end_date 是需要知道两个日期之间天数的起止日期。如果 start_date 发生在 end_date 之后，则 DAYS360 返回一个负数。

Method 是指定在计算中是使用美国方法还是欧洲方法的一个逻辑值。

Method | 定义
FALSE 或省略 | 美国 (NASD) 方法。如果起始日期是一个月的 31 号，则会等于同月的 30 号。如果终止日期是一个月的 31 号，且起始日期早于 30 号，则终止日期等于下一个月的 1 号，否则，终止日期等于同月的 30 号。
TRUE | 欧洲方法。发生在一个月的 31 号的起始日期和终止日期都将等于同月的 30 号。

说明

日期是作为有序序列数进行存储的，因此可将其用于计算。默认情况下，1899 年 12 月 31 日的序列数为 1，而 2008 年 1 月 1 日的序列数为 39448，因为它是 1900 年 1 月 1 日之后的第 39,448 天。

示例

Col1 | Col2 | 公式 | 说明（结果）
2008-1-30 | 2008-2-1 | =DAYS360([Col1],[Col2]) | 按照一年 360 天的算法，这两个日期之间的天数 (1)


HOUR

返回时间值的小时数。小时数以整数形式给出，范围从 0 (12:00 A.M.) 到 23 (11:00 P.M.)。

语法

HOUR(serial_number)

Serial_number 是包含要查找的小时数的时间。时间有多种输入方式：放在引号内作为文本字符串输入（例如 "6:45 PM"）、以十进制数输入（例如 0.78125，表示 6:45 PM）或者作为其他公式或函数的结果输入（例如 TIMEVALUE("6:45 PM")）。

说明

时间值是日期值的一部分，并用十进制数来表示（例如 12:00 PM 可以表示为 0.5，因为此时是一天的一半）。

示例

公式 | 说明（结果）
=HOUR("3:30:30 AM") | 时间的小时数 (3)
=HOUR("3:30:30 PM") | 时间的小时数 (15)
=HOUR("15:30") | 时间的小时数 (15)


MINUTE

返回时间值中的分钟。分钟是一个介于 0 到 59 之间的整数。

语法

MINUTE(serial_number)

Serial_number 表示一个时间值，其中包含要查找的分钟。时间有多种输入方式：放在引号内作为文本字符串输入（例如 "6:45 PM"）、以十进制数输入（例如 0.78125，表示 6:45 PM）或者作为其他公式或函数的结果输入（例如 TIMEVALUE("6:45 PM")）。

说明

时间值为日期值的一部分，并用十进制数表示（例如 12:00 PM 可表示为 0.5，因为此时是一天的一半）。

示例

公式 | 说明（结果）
=MINUTE("4:48:00 PM") | 该时间的分钟数 (48)


MONTH

返回以序列数表示的日期中的月份。月份是介于 1（一月）到 12（十二月）之间的整数。

语法

MONTH(serial_number)

Serial_number 表示一个日期值，其中包含要查找的月份。

说明

日期是作为有序序列数进行存储的，因此可将其用于计算。默认情况下，1899 年 12 月 31 日的序列数为 1，而 2008 年 1 月 1 日的序列数为 39448，因为它是 1900 年 1 月 1 日之后的第 39,448 天。

不论所提供的日期值以何种格式显示，由 YEAR、MONTH 和 DAY 函数返回的值都是 Gregorian 值。例如，如果所提供的日期的显示格式为 Hijri，则 YEAR、MONTH 和 DAY 函数返回的值将是与等同的 Gregorian 日期相关联的值。

示例

公式 | 说明（结果）
=MONTH("2008-4-15") | 该日期的月份 (4)


NOW.TIME

返回用小数表示的当前时间。NOW.TIME 返回的小数值为 0（零）到 0.99999999 之间的数值，代表从 0:00:00 (12:00:00 AM) 到 23:59:59 (11:59:59 PM) 之间的时间。

注意 NOW.TIME 只返回当前时间。若要使用某个函数获得特定的时间，请使用 TIME 函数。有关详细信息，请参阅主题 TIME 函数。

语法

NOW.TIME()

备注

NOW.TIME 函数语法没有参数。函数名后面必须包括一对空的圆括号。否则，Microsoft SharePoint Foundation 2010 不会将其识别为函数。


SECOND

返回时间值的秒数。返回的秒数为 0 到 59 之间的整数。

语法

SECOND(serial_number)

Serial_number 表示一个时间值，其中包含要查找的秒数。时间有多种输入方式：放在引号内作为文本字符串输入（例如 "6:45 PM"）、以十进制数输入（例如 0.78125，表示 6:45 PM）或者作为其他公式或函数的结果输入（例如 TIMEVALUE("6:45 PM")）。

说明

时间值是日期值的一部分，并用十进制数来表示（例如 12:00 PM 可以表示为 0.5，因为此时是一天的一半）。

示例

公式 | 说明
=SECOND("4:48:18 PM") | 时间的秒数 (18)
=SECOND("4:48 PM") | 时间的秒数 (0)


TIME

返回某一特定时间的小数值。TIME 返回的小数值为 0（零）到 0.99999999 之间的数值，代表从 0:00:00 (12:00:00 AM) 到 23:59:59 (11:59:59 PM) 之间的时间。

语法

TIME(hour,minute,second)

Hour 是 0（零）到 32767 之间的数字，代表小时。任何大于 23 的数值都将除以 24，其余数将视为小时。例如，TIME(27,0,0) = TIME(3,0,0) = .125 或 3:00 AM。

Minute 是 0 到 32767 之间的数字，表示分钟。任何大于 59 的值都将被转换为小时和分钟。例如，TIME(0,750,0) = TIME(12,30,0) = .520833 或 12:30 PM。

Second 是 0 到 32767 之间的数字，表示秒。任何大于 59 的值都将被转换为小时、分钟和秒。例如，TIME(0,0,2000) = TIME(0,33,22) = .023148 或 12:33:20 AM

说明

时间值是日期值的一部分，并用十进制数来表示（例如 12:00 PM 可以表示为 0.5，因为此时是一天的一半）。

示例

Hour | Minute | Second | 公式 | 说明（结果）
12 | 0 | 0 | =TIME([Hour],[Minute],[Second]) | 用小数表示一天的某一时间 (0.5)
16 | 48 | 10 | =TIME([Hour],[Minute],[Second]) | 用小数表示一天的某一时间 (0.700115741)


TIMEVALUE

返回由文本字符串所代表的时间的小数值。该小数值为 0（零）到 0.99999999 之间的数值，代表从 0:00:00 (12:00:00 AM) 到 23:59:59 (11:59:59 PM) 之间的时间。

语法

TIMEVALUE(time_text)

Time_text 文本字符串，以任何一种电子表格时间格式表示时间；例如，放在引号内表示时间的文本字符串 "6:45 PM" 和 "18:45"。

说明

  • time_text 中的日期信息将被忽略。

示例

公式 | 说明（结果）
=TIMEVALUE("2:24 AM") | 用小数表示一天的某一时间 (0.1)
=TIMEVALUE("22-Aug-2008 6:35 AM") | 用小数表示一天的某一时间 (0.274305556)


TODAY

返回当前日期的序列数。序列数是用于日期和时间计算的日期时间代码。

注意 只能将函数 TODAY 用作默认值；不能在计算列中使用它。

语法

TODAY

说明

日期是作为有序序列数进行存储的，因此可将其用于计算。默认情况下，1899 年 12 月 31 日的序列数为 1，而 2008 年 1 月 1 日的序列数为 39448，因为它是 1900 年 1 月 1 日之后的第 39,448 天。


WEEKDAY

返回与日期对应的一周中的某一天。默认情况下，其值为 1（星期日）到 7（星期六）之间的整数。

语法

WEEKDAY(serial_number,return_type)

Serial_number 是一个有序的数字，代表要查找的那一天的日期。

Return_type 是确定返回值类型的数字。

Return_type | 返回的数字
1 或省略 | 数字 1（星期日）到 7（星期六）。
2 | 数字 1（星期一）到 7（星期日）。
3 | 数字 0（星期一）到 6（星期日）。

说明

日期是作为有序序列数进行存储的，因此可将其用于计算。默认情况下，1899 年 12 月 31 日的序列数为 1，而 2008 年 1 月 1 日的序列数为 39448，因为它是 1900 年 1 月 1 日之后的第 39,448 天。

示例

公式 | 说明（结果）
=WEEKDAY("2008-2-14") | 一周中的某一天，使用数字 1（星期日）到 7（星期六）(5)
=WEEKDAY("2008-2-14",2) | 一周中的某一天，使用数字 1（星期一）到 7（星期日）(4)
=WEEKDAY("2008-2-14",3) | 一周中的某一天，使用数字 0（星期一）到 6（星期日）(3)

注意 2008-2-14 为星期四。


YEAR

返回与日期对应的年份。

语法

YEAR(serial_number)

Serial_number 要查找年份的日期。

说明

日期是作为有序序列数进行存储的，因此可将其用于计算。默认情况下，1899 年 12 月 31 日的序列数为 1，而 2008 年 1 月 1 日的序列数为 39448，因为它是 1900 年 1 月 1 日之后的第 39,448 天。

不论所提供的日期值以何种格式显示，由 YEAR、MONTH 和 DAY 函数返回的值都是 Gregorian 值。例如，如果所提供的日期的显示格式为 Hijri，则 YEAR、MONTH 和 DAY 函数返回的值将是与等同的 Gregorian 日期相关联的值。

示例

公式 | 说明（结果）
=YEAR("2008-7-5") | 第一个日期的年份 (2008)
=YEAR("10-7-5") | 第二个日期的年份 (2010)


DDB

使用双倍余额递减法或其他指定方法，计算一笔资产在给定期间内的折旧值。

语法

DDB(cost,salvage,life,period,factor)

Cost 是资产原值。

Salvage 是资产在折旧期末的价值（有时也称为资产残值）。

Life 是折旧期限（有时也称作资产的使用寿命）。

Period 是需要计算折旧值的期间。Period 必须使用与 life 相同的单位。

Factor 是余额递减速率。如果省略 factor，则假设其值为 2（双倍余额递减法）。

这五个参数都必须是正数。

说明

  • 双倍余额递减法以加速的速率计算折旧。折旧在第一阶段是最高的，在后继阶段中会减少。DDB 使用下面的公式计算一个阶段的折旧值：

    ((资产原值-资产残值) - 前面阶段的折旧总值) * (余额递减速率/生命周期)

  • 如果不希望使用双倍余额递减法，请更改余额递减速率。

示例

Cost | Salvage | Life | 公式 | 说明（结果）
2400 | 300 | 10 | =DDB([Cost],[Salvage],[Life]*365,1) | 第一天的折旧值。系统自动将 factor 设置为 2。(1.32)
2400 | 300 | 10 | =DDB([Cost],[Salvage],[Life]*12,1,2) | 第一个月的折旧值 (40.00)
2400 | 300 | 10 | =DDB([Cost],[Salvage],[Life],1,2) | 第一年的折旧值 (480.00)
2400 | 300 | 10 | =DDB([Cost],[Salvage],[Life],2,1.5) | 第二年的折旧值，使用了 1.5 的余额递减速率，而不用双倍余额递减法 (306.00)
2400 | 300 | 10 | =DDB([Cost],[Salvage],[Life],10) | 第十年的折旧值。系统自动将 factor 设置为 2 (22.12)

注意 结果将四舍五入到两位小数。


FV

基于固定利率和等额分期付款方式，返回某项投资的未来值。

语法

FV(rate,nper,pmt,pv,type)

有关 FV 中各参数的详细说明及年金函数的详细信息，请参阅函数 PV。

Rate 是各期利率。

Nper 为年金中的总支付期数。

Pmt 是各期所应支付的金额，其数值在整个年金期间保持不变。通常 pmt 包括本金和利息，但不包括其他费用或税款。如果省略 pmt，则必须包括 pv 参数。

Pv 是现值，或一系列未来付款的当前值的累积和。如果省略 pv，则假设其值为 0（零），并且必须包括 pmt 参数。

Type 数字 0 或 1，用以指定各期的付款时间是在期初还是期末。如果省略 type，则假设其值为零。

Type 值 | 支付时间
0 | 期末
1 | 期初

说明
  • 应确保指定 rate 和 nper 所用的单位保持一致。例如，同样是四年期年利率为 12% 的贷款，如果按月支付，rate 应为 12%/12，nper 应为 4*12；如果按年支付，rate 应为 12%，nper 为 4。
  • 在所有参数中，支出的款项，如银行存款，表示为负数；收入的款项，如股息收入，表示为正数。

示例 1

Rate | Nper | Pmt | PV | Type | 公式 | 说明（结果）
6% | 10 | -200 | -500 | 1 | =FV(Rate/12, Nper, Pmt, PV, Type) | 在指定的参数条件下投资的未来值 (2581.40)

注意 年利率应除以 12，因为它是按月计复利而得的。

示例 2

Rate | Nper | Pmt | 公式 | 说明（结果）
12% | 12 | -1000 | =FV([Rate]/12, [Nper], [Pmt]) | 在指定的参数条件下投资的未来值 (12,682.50)

注意 年利率应除以 12，因为它是按月计复利而得的。


IPMT

基于固定利率和等额分期付款方式，返回给定期数内对投资的利息偿还额。有关 IPMT 中参数的详细说明及年金函数的详细信息，请参阅 PV 函数。

语法

IPMT(rate,per,nper,pv,fv,type)

Rate 是各期利率。

Per 要计算其利息数额的期数，必须在 1 到 nper 范围内。

Nper 为年金中的总支付期数。

Pv 是现值，或一系列未来付款的当前值的累积和。

Fv 是未来值，或在最后一次付款后希望得到的现金余额。如果省略 fv，则假设其值为 0（例如，一笔贷款的未来值即为 0）。

Type 数字 0 或 1，用以指定各期的付款时间是在期初还是期末。如果省略 type，则假设其值为零。

Type 值 | 支付时间
0 | 期末
1 | 期初

说明
  • 应确保指定 rate 和 nper 所用的单位保持一致。例如，同样是四年期年利率为 12% 的贷款，如果按月支付，rate 应为 12%/12，nper 应为 4*12；如果按年支付，rate 应为 12%，nper 为 4。
  • 在所有参数中，支出的款项，如银行存款，表示为负数；收入的款项，如股息收入，表示为正数。

示例

Rate | Period | Nper | PV | 公式 | 说明（结果）
10% | 1 | 3 | 8000 | =IPMT([Rate]/12, [Period]*3, [Nper], [PV]) | 在指定的参数条件下贷款第一个月的利息 (-22.41)
10% | 1 | 3 | 8000 | =IPMT([Rate], 3, Nper, [PV]) | 在指定的参数条件下贷款最后一年的利息（按年支付）(-292.45)

注意 利率除以 12 将得到月利率。支付的年数乘以 12 将得到支付的次数。


ISPMT

计算在特定投资期内要支付的利息。

语法

ISPMT(rate,per,nper,pv)

Rate 投资的利率。

Per 要计算其利息的期数，必须在 1 到 nper 范围内。

Nper 为投资的总支付期数。

Pv 是投资的现值。对于贷款，pv 是贷款金额。

说明

  • 应确保指定 rate 和 nper 所用的单位保持一致。例如，同样是四年期年利率为 12% 的贷款，如果按月支付，rate 应为 12%/12，nper 应为 4*12；如果按年支付，rate 应为 12%，nper 为 4。
  • 在所有参数中，支出的款项，如银行存款，表示为负数；收入的款项，如股息收入，表示为正数。
  • 有关财务函数的其他信息，请参阅 PV 函数。

示例

Rate | Per | Nper | PV | 公式 | 说明（结果）
10% | 1 | 3 | 8000000 | =ISPMT([Rate]/12,[Per],[Nper]*12,[PV]) | 在指定的参数条件下对贷款第一个月支付的利息 (-64814.8)
10% | 1 | 3 | 8000000 | =ISPMT([Rate],1,[Nper],[PV]) | 在指定的参数条件下对贷款第一年支付的利息 (-533333)

注意 利率除以 12 将得到月利率。支付的年数乘以 12 将得到支付的次数。


NPER

基于固定利率及等额分期付款方式，返回某项投资的总期数。

语法

NPER(rate, pmt, pv, fv, type)

有关 NPER 中各参数的详细说明及有关年金函数的详细信息，请参阅 PV。

Rate 是各期利率。

Pmt 是各期所应支付的金额，其数值在整个年金期间保持不变。通常 pmt 包括本金和利息，但不包括其他费用或税款。

Pv 是现值，或一系列未来付款的当前值的累积和。

Fv 是未来值，或在最后一次付款后希望得到的现金余额。如果省略 fv，则假设其值为 0（例如，一笔贷款的未来值即为 0）。

Type 数字 0 或 1，用以指定各期的付款时间是在期初还是期末。

Type 值 | 支付时间
0 或省略 | 期末
1 | 期初

示例
Rate | Pmt | PV | FV | Type | 公式 | 说明（结果）
12% | -100 | -1000 | 10000 | 1 | =NPER([Rate]/12, [Pmt], [PV], [FV], 1) | 在指定的参数条件下投资的总期数 (60)
12% | -100 | -1000 | 10000 | 1 | =NPER([Rate]/12, [Pmt], [PV], [FV]) | 在指定的参数条件下投资的总期数，不包括在期初的支付 (60)
12% | -100 | -1000 | 10000 | 1 | =NPER([Rate]/12, [Pmt], [PV]) | 在指定的参数条件下投资的总期数，不包括未来值 (-9.578)


NPV

通过使用贴现率以及一系列未来支出（负值）和收入（正值），计算一项投资的净现值。

语法

NPV(rate,value1,value2, ...)

Rate 是某一期间的贴现率。

Value1, value2, ... 代表支出及收入的 1 到 29 个参数。

  • Value1, value2, ... 在时间上必须具有相等间隔，并且都发生在期末。
  • NPV 使用 value1, value2, ... 的顺序来解释现金流的顺序。所以务必保证支出和收入的数额按正确的顺序输入。
  • 如果参数为数字、空值、逻辑值或数字的文本表达式，则都会被计算在内；如果参数是错误值或不能转化为数字的文本，则将被忽略。

说明

  • 函数 NPV 假定投资开始于 value1 现金流所在日期的前一期，并结束于列表中最后一笔现金流的当期。函数 NPV 依据未来的现金流来进行计算。如果第一笔现金流发生在第一个周期的期初，则第一笔现金必须添加到函数 NPV 的结果中，而不应包含在 values 参数中。有关详细信息，请参阅下面的示例。
  • 如果 n 是值列表中的现金流的次数，则 NPV 的计算公式如下：

  • 函数 NPV 与函数 PV（现值）相似。PV 与 NPV 之间的主要差别在于：函数 PV 允许现金流在期初或期末开始。与可变的 NPV 的现金流数值不同，PV 的每一笔现金流在整个投资中必须是固定的。有关年金与财务函数的详细信息，请参阅函数 PV。
  • 函数 NPV 与函数 IRR（内部收益率）也有关，函数 IRR 是使 NPV 等于零的比率：NPV(IRR(...), ...) = 0。

示例 1

在下面的示例中：

  • Rate 是年贴现率。
  • Value1 一年前的初期投资。
  • Value2 第一年的收益。
  • Value3 第二年的收益。
  • Value4 第三年的收益。
Rate | Value1 | Value2 | Value3 | Value4 | 公式 | 说明（结果）
10% | -10000 | 3000 | 4200 | 6800 | =NPV([Rate], [Value1], [Value2], [Value3], [Value4]) | 此项投资的净现值 (1,188.44)

在上例中，将开始投资的 $10,000 作为数值参数中的一个。因为此项付款发生在第一期的期末。

示例 2

在下面的示例中：

  • Rate 年贴现率。可表示整个投资的通货膨胀率或利率。
  • Value1 一年前的初期投资。
  • Value2 第一年的收益。
  • Value3 第二年的收益。
  • Value4 第三年的收益。
  • Value5 第四年的收益。
  • Value6 第五年的收益。
Rate | Value1 | Value2 | Value3 | Value4 | Value5 | Value6 | 公式 | 说明（结果）
8% | 40000 | 8000 | 9200 | 10000 | 12000 | 14500 | =NPV(Rate, [Value2], [Value3], [Value4], [Value5], [Value6])+[Value1] | 此项投资的净现值 (1,922.06)
8% | 40000 | 8000 | 9200 | 10000 | 12000 | 14500 | =NPV(Rate, [Value2], [Value3], [Value4], [Value5], [Value6], -9000)+[Value1] | 此项投资的净现值，包括第六年中 9000 的赔付 (-3,749.47)

在上例中，一开始投资的 $40,000 并不包含在数值参数中，因为此项付款发生在第一期的期初。


PMT

基于固定利率及等额分期付款方式，计算贷款的每期付款额。

语法

PMT(rate,nper,pv,fv,type)

有关函数 PMT 中参数的详细说明，请参阅函数 PV。

Rate 贷款利率。

Nper 该项贷款的付款总次数。

Pv 是现值，或一系列未来付款的当前值的累积和，也称为本金。

Fv 是未来值，或在最后一次付款后希望得到的现金余额，如果省略 fv，则假设其值为 0（零），即一笔贷款的未来值为零。

Type 数字 0（零）或 1，用以指定各期的付款时间是在期初还是期末。

Type 值 | 支付时间
0 或省略 | 期末
1 | 期初

说明
  • PMT 返回的支付款项包括本金和利息，但不包括税款、保留支付或某些与贷款有关的费用。
  • 应确保所指定的 rate 和 nper 单位的一致性。例如，同样是四年期年利率为 12% 的贷款，如果按月支付，rate 应为 12%/12，nper 应为 4*12；如果按年支付，rate 应为 12%，nper 为 4。

显示 提示

若要计算贷款期间的支付总额，请用 PMT 返回值乘以 nper。

示例 1

在下面的示例中：

  • Rate 是年利率
  • Nper 是支付的月份数
  • PV 是贷款金额
Rate | Nper | PV | 公式 | 说明（结果）
8% | 10 | 10000 | =PMT([Rate]/12, [Nper], [PV]) | 在指定的参数条件下贷款的月支付额 (-1,037.03)
8% | 10 | 10000 | =PMT([Rate]/12, [Nper], [PV], 0, 1) | 在指定的参数条件下贷款的月支付额，不包括支付期限在期初的支付额 (-1,030.16)

示例 2

可以使用 PMT 来计算除贷款之外其他年金的支付额。

在下面的示例中：

  • Rate 年利率。
  • Nper 计划储蓄的年数。
  • PV 18 年内计划储蓄的数额。
Rate | Nper | PV | 公式 | 说明（结果）
6% | 18 | 50000 | =PMT([Rate]/12, [Nper]*12, 0, [PV]) | 为 18 年后最终得到 50,000，每个月应存的数额 (-129.08)

注意 利率除以 12 将得到月利率。支付的年数乘以 12 将得到支付的次数。


PPMT

基于固定利率及等额分期付款方式，返回投资在某一给定期间内的本金偿还额。

语法

PPMT(rate,per,nper,pv,fv,type)

有关函数 PPMT 中参数的详细信息，请参阅 PV。

Rate 是各期利率。

Per 用于计算其本金数额的期数，必须介于 1 到 nper 之间。

Nper 为年金中的总支付期数。

Pv 是现值，即一系列未来付款当前值的总和。

Fv 是未来值，或在最后一次付款后希望得到的现金余额，如果省略 fv，则假设其值为 0（零），即一笔贷款的未来值为零。

Type 数字 0 或 1，用以指定各期的付款时间是在期初还是期末。

Type 值 | 支付时间
0 或省略 | 期末
1 | 期初

说明

应确保所指定的 rate 和 nper 单位的一致性。例如，同样是四年期年利率为 12% 的贷款，如果按月支付，rate 应为 12%/12，nper 应为 4*12；如果按年支付，rate 应为 12%，nper 为 4。

示例 1

Rate | Nper | PV | 公式 | 说明（结果）
10% | 2 | 2000 | =PPMT([Rate]/12, 1, [Nper]*12, [PV]) | 贷款第一个月的本金支付 (-75.62)

注意 利率除以 12 将得到月利率。支付的年数乘以 12 将得到支付的次数。

示例 2

Rate | Per | PV | 公式 | 说明（结果）
8% | 10 | 200,000 | =PPMT([Rate], [Per], 10, [PV]) | 在指定的参数条件下，贷款最后一年的本金支付 (-27,598.05)


PV

返回投资的现值。现值为一系列未来付款的当前值的累积和。例如，借入方的借入款即为贷出方贷款的现值。

语法

PV(rate,nper,pmt,fv,type)

Rate 是各期利率。例如，如果按 10% 的年利率借入一笔贷款来购买汽车，并按月偿还贷款，则月利率为 10%/12（即 0.83%）。可以在公式中输入 10%/12、0.83% 或 0.0083 作为 rate 的值。

Nper 为年金中的总支付期数。例如，对于一笔 4 年期按月偿还的汽车贷款，共有 4*12（即 48）个偿款期数。可以在公式中输入 48 作为 nper 的值。

Pmt 是各期所应支付的金额，其数值在整个年金期间保持不变。通常 pmt 包括本金和利息，但不包括其他费用或税款。例如，$10,000 的年利率为 12% 的四年期汽车贷款的月偿还额为 $263.33。可以在公式中输入 -263.33 作为 pmt 的值。如果省略 pmt，则必须包含 fv 参数。

Fv 是未来值，或在最后一次支付后希望得到的现金余额，如果省略 fv，则假设其值为零（即一笔贷款的未来值为零）。例如，如果希望通过存款在 18 年后为某一特殊项目支付 $50,000，则 $50,000 就是未来值。可以根据保守估计的利率来决定每月的存款额。如果省略 fv，则必须包含 pmt 参数。

Type 数字 0 或 1，用以指定各期的付款时间是在期初还是期末。

Type 值 | 支付时间
0 或省略 | 期末
1 | 期初

说明
  • 应确保所指定的 rate 和 nper 单位的一致性。例如，同样是四年期年利率为 12% 的贷款，如果按月支付，rate 应为 12%/12，nper 应为 4*12；如果按年支付，rate 应为 12%，nper 为 4。
  • 以下函数适用于年金：
    • FV
    • IPMT
    • PMT
    • PPMT
    • PV
    • RATE
    年金是在一段连续期间内的一系列固定的现金付款。例如汽车贷款或抵押贷款就是年金。有关详细信息，请参阅各年金函数的详细说明。
  • 在年金函数中，支出的款项，如银行存款，表示为负数；收入的款项，如股息收入，表示为正数。例如，对于储户来说，$1000 银行存款可表示为参数 -1,000，而对于银行来说该参数为 1,000。
  • 财务参数相互之间有依赖关系。如果 rate 不为 0，则：

    如果 rate 为 0，则：

    (pmt * nper) + pv + fv = 0

示例

在下面的示例中：

  • Pmt 每月底一项保险年金的支出。
  • Rate 投资收益率。
  • Nper 付款的年限。
Pmt | Rate | Nper | 公式 | 说明（结果）
500 | 8% | 20 | =PV([Rate]/12, 12*[Nper], [Pmt], , 0) | 在指定的参数条件下年金的现值 (-59,777.15)。

结果为负值，因为这是一笔付款，亦即支出现金流。如果年金的购买成本是 (60,000)，则年金的现值 (59,777.15) 小于实际支付值。因此，这不是一项合算的投资。

注意 利率除以 12 将得到月利率。支付的年数乘以 12 将得到支付的次数。


RATE

返回年金的各期利率。函数 RATE 通过迭代法计算得出，并且可能无解或有多个解。如果在进行 20 次迭代计算后，函数 RATE 的相邻两次结果没有收敛于 0.0000001，则函数 RATE 将返回错误值 #NUM!。

语法

RATE(nper,pmt,pv,fv,type,guess)

有关参数 nper、pmt、pv、fv 和 type 的详细说明，请参阅 PV。

Nper 为年金中的总支付期数。

Pmt 是各期所应支付的金额，其数值在整个年金期间保持不变。通常 pmt 包括本金和利息，但不包括其他费用或税款。如果省略 pmt，则必须包含 fv 参数。

Pv 是现值，即一系列未来付款当前值的总和。

Fv 是未来值，或在最后一次付款后希望得到的现金余额。如果省略 fv，则假设其值为 0（例如，一笔贷款的未来值即为 0）。

Type 数字 0 或 1，用以指定各期的付款时间是在期初还是期末。

Type 值 | 支付时间
0 或省略 | 期末
1 | 期初

Guess 为预期利率。

  • 如果省略 guess，则假设其值为 10%。
  • 如果 RATE 不收敛，请改变 guess 的值。通常当 guess 介于 0 到 1 之间时，函数 RATE 是收敛的。

说明

应确保所指定的 guess 和 nper 单位的一致性。例如，同样是四年期年利率为 12% 的贷款，如果按月支付，guess 应为 12%/12，nper 应为 4*12；如果按年支付，guess 应为 12%，nper 应为 4。

示例

Nper | Pmt | PV | 公式 | 说明（结果）
4 | -200 | 8000 | =RATE([Nper]*12, [Pmt], [PV]) | 在指定的参数条件下贷款的月利率 (1%)
4 | -200 | 8000 | =RATE([Nper]*12, [Pmt], [PV])*12 | 在指定的参数条件下贷款的年利率（0.09241767 或 9.24%）

注意 贷款的年数乘以 12 为月数。


SLN

返回某项资产在一个期间中的线性折旧值。

语法

SLN(cost,salvage,life)

Cost 是资产原值。

Salvage 是资产在折旧期末的价值（有时也称为资产残值）。

Life 是折旧期限（有时也称作资产的使用寿命）。

示例

Cost | Salvage | Life | 公式 | 说明（结果）
30,000 | 7,500 | 10 | =SLN([Cost], [Salvage], [Life]) | 每年的折旧值 (2,250)


SYD

返回某项资产按年限总和折旧法计算的指定期间的折旧值。

语法

SYD(cost,salvage,life,per)

Cost 是资产原值。

Salvage 是资产在折旧期末的价值（有时也称为资产残值）。

Life 是折旧期限（有时也称作资产的使用寿命）。

Per 是期间，其单位与 life 相同。

说明

  • SYD 是按如下公式计算的：

示例

Cost | Salvage | Life | 公式 | 说明（结果）
30000 | 7500 | 10 | =SYD([Cost],[Salvage],[Life],1) | 第一年的年折旧值 (4,090.91)
30000 | 7500 | 10 | =SYD([Cost],[Salvage],[Life],10) | 第十年的年折旧值 (409.09)


IS

本节介绍了用来检验数值或列引用类型的九个函数。

这些函数，统称为 IS 函数，可以检验数值的类型并根据结果返回 TRUE 或 FALSE。例如，如果数值为空的列引用，则函数 ISBLANK 将返回逻辑值 TRUE，否则返回 FALSE。

语法

ISBLANK(value)
ISERR(value)
ISERROR(value)
ISLOGICAL(value)
ISNA(value)
ISNONTEXT(value)
ISNULL(value)
ISNUMBER(value)
ISTEXT(value)

Value 是需要进行检验的值。值可以为空值、错误值、逻辑值、文本、数字或列引用。

函数 | 如果为下面的内容，则返回 TRUE
ISBLANK | 值为空的列引用。
ISERR | 值为错误值（除去 #N/A）。
ISERROR | 值为任何错误值（#N/A、#VALUE!、#REF!、#DIV/0!、#NUM!、#NAME?, 或 #NULL!）。
ISLOGICAL | 值为逻辑值。
ISNA | 值为错误值 #N/A（值不可用）。
ISNONTEXT | 值为不是文本的任意项。（注意此函数在值为空的列引用时返回 TRUE。）
ISNULL | 值为 #NULL!。
ISNUMBER | 值为数字。
ISTEXT | 值为文本。

说明
  • IS 函数的参数 value 是不能进行转换的。例如，在其他需要数字的大多数函数中，文本值 "19" 会被转换成数字 19。然而在公式 ISNUMBER("19") 中，"19" 并未从文本值转换成数字，因此函数 ISNUMBER 返回 FALSE。
  • IS 函数在用公式检验计算结果时十分有用。当它与函数 IF 结合在一起使用时，可以提供一种方法用来在公式中查出错误（请参阅下面的示例）。

示例 1

公式 | 说明（结果）
=ISLOGICAL(TRUE) | 检查 TRUE 是否为逻辑值 (TRUE)
=ISLOGICAL("TRUE") | 检查 "TRUE" 是否为逻辑值 (FALSE)
=ISNUMBER(4) | 检查 4 是否为数字 (TRUE)

示例 2

Col1 | 公式 | 说明（结果）
Gold | =ISBLANK([Col1]) | 检查 Col1 中的值是否为空 (FALSE)
#REF! | =ISERROR([Col1]) | 检查 Col1 中的 #the 值是否为错误值 (TRUE)
#REF! | =ISNA([Col1]) | 检查 Col1 中的值是否为 #N/A 错误值 (FALSE)
#N/A | =ISNA([Col1]) | 检查 Col1 中的值是否为 #N/A 错误值 (TRUE)
#N/A | =ISERR([Col1]) | 检查 Col1 中的值是否为错误值 (FALSE)
#NULL! | =ISNULL([Col1]) | 检查 Col 1 中的值是否为 #NULL! (Yes)
330.92 | =ISNUMBER([Col1]) | 检查 Col1 中的值是否为数字 (TRUE)
Region1 | =ISTEXT([Col1]) | 检查 Col1 中的值是否为文本 (TRUE)


Me

返回当前用户名。

语法

Me

说明

  • Me 函数仅可以与默认值一起使用；不能在计算列中使用 Me 函数。


AND

所有参数的计算结果均为 TRUE 时，返回逻辑值 TRUE 或 Yes；如果有一个或多个参数的计算结果为 FALSE，则返回 FALSE 或 No。

语法

AND(logical1,logical2,...)

Logical1, logical2, ... 是 1 到 30 个待检测的条件，它们可以为 TRUE 或 FALSE。

说明

  • 这些参数的计算结果必须为逻辑值（如 TRUE 或 FALSE），或者这些参数必须是包含逻辑值的列引用。
  • 如果某个列引用参数包含文本，则 AND 返回错误值 #VALUE!；如果它为空，则它返回 FALSE。
  • 如果这些参数不包含任何逻辑值，则 AND 返回错误值 #VALUE!。
  • 如果有一个或多个参数包含 #NULL!，则 AND 返回 #NULL!。

示例 1

公式 | 说明（结果）
=AND(TRUE, TRUE) | 所有参数都为 TRUE (TRUE)
=AND(TRUE, FALSE) | 一个参数为 FALSE (FALSE)
=AND(2+2=4, 2+3=5) | 所有参数的计算结果都为 TRUE (TRUE)
=AND(TRUE, #NULL!) | 第一个参数的计算结果为 TRUE 并且有一个参数包含 #NULL! (#NULL!)

示例 2

Col1 | Col2 | 公式 | 说明（结果）
50 | 104 | =AND(1<[Col1], [Col1]<100) | 因为 50 介于 1 和 100 之间 (TRUE)
50 | 104 | =IF(AND(1<[Col2], [Col2]<100), [Col2], "数值超出范围。") | 如果第二个数字介于 1 和 100 之间，则显示该数字，否则显示消息（数值超出范围。）
50 | 104 | =IF(AND(1<[Col1], [Col1]<100), [Col1], "数值超出范围。") | 如果第一个数字介于 1 和 100 之间，则显示该数字，否则显示消息 (50)


CHOOSE

使用 index_num 返回数值参数列表中的数值。使用 CHOOSE 可以根据索引号从最多 29 个数值中选择一个。例如，如果 value1 到 value7 表示一周的 7 天，当将 1 到 7 之间的数字用作 index_num 时，则 CHOOSE 返回其中的某一天。

语法

CHOOSE(index_num,value1,value2,...)

Index_num 指定选择的数值参数。Index_num 必须是 1 到 29 之间的一个数字，或是包含 1 到 29 之间的数字的公式或列引用。

  • 如果 index_num 为 1，则 CHOOSE 返回 value1；如果它为 2，则 CHOOSE 返回 value2；以此类推。

  • 如果 index_num 是一个小于 1 或大于列表中最后一个值的数字，则 CHOOSE 返回错误值 #VALUE!。

  • 如果 index_num 是一个分数，则在使用前将被截尾取整。

Value1,value2,... 是 1 到 29 个数值参数，CHOOSE 会根据 index_num 从中选择一个数值或一个要执行的操作。参数可以是数字、列引用、公式、函数或文本。

说明

示例 1

Col1 | Col2 | Col3 | Col4 | 公式 | 说明（结果）
1st | 2nd | 3rd | Finished | =CHOOSE(2,[Col1],[Col2],[Col3],[Col4]) | 第二个参数 Col2 的值 (2nd)
Nails | Screws | Nuts | Bolts | =CHOOSE(4,[Col1],[Col2],[Col3],[Col4]) | 第四个参数 Col4 的值 (Bolts)

示例 2

Col1 | Col2 | Col3 | Col4 | 公式 | 说明（结果）
23 | 45 | 12 | 10 | =SUM([Col1], CHOOSE(2,[Col2],[Col3],[Col4])) | 参数 Col1 和 Choose 函数的结果的和 (35)


FALSE

返回逻辑值 FALSE。

语法

FALSE( )

说明

也可以直接在公式中键入文字 FALSE，它会被解释为逻辑值 FALSE。


IF

根据对指定的条件计算结果为 TRUE 或 FALSE，返回不同的结果。

可以使用 IF 对数值和公式执行条件检测。

语法

IF(logical_test,value_if_true,value_if_false)

Logical_test 是计算结果为 TRUE 或 FALSE 的任何值或表达式。例如，[Quarter1]=100 是一个逻辑表达式；如果该列某行中的值 [Quarter1] 等于 100，则表达式的计算结果为 TRUE。否则，表达式的计算结果为 FALSE。此参数可以使用任何比较计算运算符。

Value_if_true 是 logical_test 为 TRUE 时返回的值。例如，如果此参数是文本字符串“预算内”，而且 logical_test 参数的计算结果为 TRUE，则 IF 函数显示文本“预算内”。如果 logical_test 为 TRUE 而 value_if_true 为空，则此参数返回 0（零）。若要显示单词 TRUE，请为此参数使用逻辑值 TRUE。Value_if_true 也可以是其他公式。

Value_if_false 是 logical_test 为 FALSE 时返回的值。例如，如果此参数是文本字符串“超出预算”而 logical_test 参数的计算结果为 FALSE，则 IF 函数显示文本“超出预算”。如果 logical_test 为 FALSE 而 value_if_false 被省略（即 value_if_true 后没有逗号），则会返回逻辑值 FALSE。如果 logical_test 为 FALSE 且 value_if_false 为空（即 value_if_true 后有逗号并紧跟着右括号），则会返回数值 0（零）。Value_if_false 也可以是其他公式。

说明

  • IF 函数最多可以嵌套七层，用作 value_if_true 和 value_if_false 参数，以构造复杂的检测。请参阅下面最后一个示例。
  • 在计算参数 value_if_true 和 value_if_false 时，IF 会返回相应语句执行后的返回值。
  • 如果 IF 中的任何参数包含数组，则在执行 IF 语句时，数组中的每个元素都将得到计算。

示例 1

Col1 | Col2 | Col3 | Expense | 公式 | 说明（结果）
 |  |  | 50 | =IF([Expense]<=100,"Within budget","Over budget") | 如果数字小于或等于 100，则公式将显示“Within budget”。否则，函数显示“Over budget”。(Within budget)
23 | 45 | 89 | 50 | =IF([Expense]=100,SUM([Col1],[Col2],[Col3]),"") | 如果数字为 100，则将这三个值相加。否则，返回空文本 ("")。()

示例 2

ActualExpenses | PredictedExpenses | 公式 | 说明（结果）
1500 | 900 | =IF([ActualExpenses]>[PredictedExpenses],"Over Budget","OK") | 检查第一行是否超出预算 (Over Budget)
500 | 900 | =IF([ActualExpenses]>[PredictedExpenses],"Over Budget","OK") | 检查第二行是否超出预算 (OK)

示例 3

Score | 公式 | 说明（结果）
45 | =IF([Score]>89,"A",IF([Score]>79,"B", IF([Score]>69,"C",IF([Score]>59,"D","F")))) | 给第一个成绩指定一个字母等级 (F)
90 | =IF([Score]>89,"A",IF([Score]>79,"B", IF([Score]>69,"C",IF([Score]>59,"D","F")))) | 给第二个成绩指定一个字母等级 (A)
78 | =IF([Score]>89,"A",IF([Score]>79,"B", IF([Score]>69,"C",IF([Score]>59,"D","F")))) | 给第三个成绩指定一个字母等级 (C)

在上例中，第二个 IF 语句同时也是第一个 IF 语句的 value_if_false 参数。同样，第三个 IF 语句是第二个 IF 语句的 value_if_false 参数。例如，如果第一个 logical_test ([Score]>89) 为 TRUE，则返回“A”。如果第一个 logical_test 为 FALSE，则计算第二个 IF 语句，以此类推。

使用下列关键字指定数字的字母等级（假设仅使用整数）。

如果成绩是 | 则返回
大于 89 | A
80 到 89 | B
70 到 79 | C
60 到 69 | D
低于 60 | F


NOT

对其参数值求反。当要确保一个值不等于某一特定值时，可以使用 NOT 函数。

语法

NOT(logical)

Logical 为一个可以计算出 TRUE 或 FALSE 的值或表达式。

说明

如果 logical 为 FALSE，则 NOT 返回 TRUE；如果 logical 为 TRUE，则 NOT 返回 FALSE。

示例

公式 | 说明（结果）
=NOT(FALSE) | 对 FALSE 求反 (TRUE)
=NOT(1+1=2) | 对计算结果为 TRUE 的公式求反 (FALSE)


OR

在其参数组中，如果任一参数的逻辑值为 TRUE，即返回 TRUE；如果所有参数的逻辑值为 FALSE，即返回 FALSE。

语法

OR(logical1,logical2,...)

Logical1, logical2, ... 是 1 到 30 个待检测的条件，它们可以为 TRUE 或 FALSE。

说明

  • 参数必须能计算为逻辑值（如 TRUE 或 FALSE），或者为包含逻辑值的数组或引用。
  • 如果列引用参数中包含文本或为空，则这些值将被忽略。
  • 如果指定的区域中不包含任何逻辑值，则 OR 返回错误值 #VALUE!。
  • ? 如果有一个或多个参数包含 #NULL!，则 OR 返回 #NULL!。

示例

公式 | 说明（结果）
=OR(TRUE) | 一个参数为 TRUE (TRUE)
=OR(1+1=1,2+2=5) | 所有参数的计算结果都为 FALSE (FALSE)
=OR(TRUE,FALSE,TRUE) | 至少一个参数为 TRUE (TRUE)
=OR(#NULL!,#NULL!) | 两个参数均包含 #NULL! (#NULL!)
=OR(1+1=1,#NULL!) | 第一个参数的计算结果为 FALSE 并且另一个参数为 #NULL! (#NULL!)


TRUE

返回逻辑值 TRUE。

语法

TRUE( )

说明

可以不使用此函数而直接输入值 TRUE。TRUE 函数主要是用于与其他程序兼容。


ABS

返回数字的绝对值。一个数字的绝对值是该数字不带其符号的形式。

语法

ABS(number)

Number 是需要计算其绝对值的实数。

示例

Col1 | 公式 | 说明（结果）
-4 | =ABS([Col1]) | -4 的绝对值 (4)


ACOS

返回数字的反余弦值。反余弦值是角度，其余弦值是该函数的参数 number。返回的角度以弧度表示，范围从 0（零）到 pi。

语法

ACOS(number)

Number 是所需角度的余弦值，必须介于 -1 到 1 之间。

说明

如果要将结果从弧度转换为度，请将结果乘以 180/PI()，或使用 DEGREES 函数。

示例

公式 | 说明（结果）
=ACOS(-0.5) | -0.5 的反余弦值（以弧度表示），即 2*pi/3 (2.094395)
=ACOS(-0.5)*180/PI() | -0.5 的反余弦值（以度表示）(120)
=DEGREES(ACOS(-0.5)) | -0.5 的反余弦值（以度表示）(120)


ACOSH

返回数字的反双曲余弦值。Number 必须大于或等于 1。反双曲余弦值的双曲余弦为该函数的参数 number，因此 ACOSH(COSH(number)) 等于 number。

语法

ACOSH(number)

Number 是等于或大于 1 的任意实数。

示例

公式 | 说明（结果）
=ACOSH(1) | 1 的反双曲余弦值 (0)
=ACOSH(10) | 10 的反双曲余弦值 (2.993223)


ASIN

返回数字的反正弦值。反正弦值是角度，其正弦值是该函数的参数 number。返回的角度以弧度表示，范围从 -pi/2 到 pi/2。

语法

ASIN(number)

Number 是所需角度的正弦值，必须介于 -1 到 1 之间。

说明

若要以度表示反正弦值，请将结果乘以 180/PI()，或使用 DEGREES 函数。

公式 | 说明（结果）
=ASIN(-0.5) | -0.5 的反正弦值（以弧度表示），-pi/6 (-0.5236)
=ASIN(-0.5)*180/PI() | -0.5 的反正弦值（以度表示）(-30)
=DEGREES(ASIN(-0.5)) | -0.5 的反正弦值（以度表示）(-30)


ASINH

返回数字的反双曲正弦值。反双曲正弦值的双曲正弦值是该函数的参数 number，因此 ASINH(SINH(number)) 等于 number。

语法

ASINH(number)

Number 是任意实数。

示例

公式 | 说明（结果）
=ASINH(-2.5) | -2.5 的反双曲正弦值 (-1.64723)
=ASINH(10) | 10 的反双曲正弦值 (2.998223)


ATAN

返回数字的反正切值。反正切值是角度，其正切值是该函数的参数 number。返回的角度以弧度表示，范围从 -pi/2 到 pi/2。

语法

ATAN (number)

Number 是所需角度的正切值。

说明

若要以度表示反正切值，请将结果乘以 180/PI()，或使用 DEGREES 函数。

示例

公式 | 说明（结果）
=ATAN(1) | 1 的反正切值（以弧度表示），pi/4 (0.785398)
=ATAN(1)*180/PI() | 1 的反正切值（以度表示）(45)
=DEGREES(ATAN(1)) | 1 的反正切值（以度表示）(45)


ATAN2

返回指定的 x 和 y 坐标值的反正切值。反正切值是角度，是从 x 轴到通过原点 (0, 0) 和坐标点 (x_num, y_num) 的直线之间的夹角。该角度以弧度表示，介于 -pi 和 pi 之间（不包括 -pi）。

语法

ATAN2(x_num,y_num)

X_num 点的 x 坐标。

Y_num 点的 y 坐标。

说明

  • 结果为正表示从 x 轴逆时针旋转的角度，结果为负代表从 x 轴顺时针旋转的角度。
  • ATAN2(a,b) 等于 ATAN(b/a)，除了在 ATAN2 中 a 值为 0 以外。
  • 如果 x_num 和 y_num 都为 0，则 ATAN2 返回错误值 #DIV/0!。
  • 若要以度表示反正切值，请将结果乘以 180/PI( )，或使用 DEGREES 函数。

示例

公式 | 说明（结果）
=ATAN2(1, 1) | 点 (1, 1) 的反正切值（以弧度表示），pi/4 (0.785398)
=ATAN2(-1, -1) | 点 (1, 1) 的反正切值（以弧度表示），-3*pi/4 (-2.35619)
=ATAN2(-1, -1)*180/PI() | 点 (1, 1) 的反正切值（以度表示）(-135)
=DEGREES(ATAN2(-1, -1)) | 点 (1, 1) 的反正切值（以度表示）(-135)


ATANH

返回数字的反双曲正切值。Number 必须介于 -1 和 1 之间（不包括 -1 和 1）。反双曲正切值的双曲正切值为该函数的参数 number，因此 ATANH(TANH(number)) 等于 number。

语法

ATANH(number)

Number 是介于 1 和 -1 之间的任意实数。

示例

公式 | 说明（结果）
=ATANH(0.76159416) | 0.76159416 的反双曲正切值（约等于 1）
=ATANH(-0.1) | -0.1 的反双曲正切值 (-0.10034)


CEILING

返回向上舍入的数字，该数字将向上舍入（远离零）到最接近的指定基数的倍数。例如，如果您不希望在价格中使用分，而您的产品价格为 $4.42，则可使用公式 =CEILING(4.42,0.05) 将价格向上舍入到最接近的 5 美分。

语法

CEILING(number,significance)

Number 要舍入的数值。

Significance 是用以进行舍入计算的倍数。

说明

  • 如果任一参数为非数字型，则 CEILING 返回错误值 #VALUE!。
  • 不论数字的符号如何，数值都是向远离零的方向向上舍入。如果数字正好是指定基数的倍数，则无需进行任何舍入处理。
  • 如果 number 和 significance 具有不同的符号，则 CEILING 返回错误值 #NUM!。

示例

公式 | 说明（结果）
=CEILING(2.5, 1) | 将 2.5 向上舍入到最接近的 1 的倍数 (3)
=CEILING(-2.5, -2) | 将 -2.5 向上舍入到最接近的 -2 的倍数 (-4)
=CEILING(-2.5, 2) | 返回错误值，因为 -2.5 和 2 的符号不同 (#NUM!)
=CEILING(1.5, 0.1) | 将 1.5 向上舍入到最接近的 0.1 的倍数 (1.5)
=CEILING(0.234, 0.01) | 将 0.234 向上舍入到最接近的 0.01 的倍数 (0.24)


COS

返回给定角度的余弦值。

语法

COS(number)

Number 是需要计算其余弦的角度（以弧度表示）。

说明

如果角度是以度表示，则可将其乘以 PI()/180，或使用 RADIANS 函数将其转换为弧度。

示例

公式 | 说明（结果）
=COS(1.047) | 1.047 弧度的余弦值 (0.500171)
=COS(60*PI()/180) | 60 度的余弦值 (0.5)
=COS(RADIANS(60)) | 60 度的余弦值 (0.5)


COSH

返回数字的双曲余弦值。

语法

COSH(number)

Number 是需要计算其双曲余弦值的任意实数。

说明

双曲余弦的计算公式如下：

示例

公式 | 说明（结果）
=COSH(4) | 4 的双曲余弦值 (27.30823)
=COSH(EXP(1)) | 自然对数的底数的双曲余弦值 (7.610125)


DEGREES

将弧度转换为度。

语法

DEGREES(angle)

Angle 是要转换的以弧度表示的角度。

示例

公式 | 说明（结果）
=DEGREES(PI()) | pi 弧度的度数 (180)


EVEN

返回向上舍入到最接近的偶数的数字。可以使用此函数处理成对出现的项目。例如，一个包装箱一行可容纳一宗或两宗货物。只有当这些货物的数目向上舍入到最接近的偶数，与包装箱的容量相匹配时，包装箱才会装满。

语法

EVEN(number)

Number 是要四舍五入的数值。

说明

  • 如果 number 为非数字型，则 EVEN 返回错误值 #VALUE!。
  • 不论数字的符号如何，数值都是向远离零的方向向上舍入。如果 number 正好是偶数，则不会进行任何舍入处理。

示例

公式 | 说明（结果）
=EVEN(1.5) | 将 1.5 向上舍入到最接近的偶数 (2)
=EVEN(3) | 将 3 向上舍入到最接近的偶数 (4)
=EVEN(2) | 将 2 向上舍入到最接近的偶数 (2)
=EVEN(-1) | 将 -1 向上舍入到最接近的偶数 (-2)


EXP

返回 e 的 n 次幂。常数 e 等于 2.71828182845904，是自然对数的底数。

语法

EXP(number)

Number 是应用于底数 e 的指数。

说明

  • 若要计算其他底数的幂，请使用幂运算符 (^)。
  • EXP 函数是计算自然对数的 LN 函数的反函数。

示例

公式 | 说明（结果）
=EXP(1) | e 的近似值 (2.718282)
=EXP(2) | 自然对数的底数 e 的 2 次幂 (7.389056)


FACT

返回数的阶乘。一个数的阶乘等于 1*2*3*...* 该数。

语法

FACT(number)

Number 要计算其阶乘的非负数。如果 number 不是整数，则将被截尾取整。

示例

公式 | 说明（结果）
=FACT(5) | 5 的阶乘，即 1*2*3*4*5 (120)
=FACT(1.9) | 1.9 截尾取整后的阶乘 (1)
=FACT(0) | 0 的阶乘 (1)
=FACT(-1) | 负数导致错误值 (#NUM!)
=FACT(1) | 1 的阶乘 (1)


FLOOR

将数值向下舍入（向零的方向），使其等于最接近的给定基数的倍数。

语法

FLOOR(number,significance)

Number 要进行四舍五入的数值。

Significance 用以进行四舍五入计算的倍数。

说明

  • 如果任一参数为非数字型，则 FLOOR 返回错误值 #VALUE!。
  • 如果 number 和 significance 符号相反，则 FLOOR 返回错误值 #NUM!。
  • 不论数字的符号如何，舍入时数值的绝对值都将减小。如果数字正好是指定基数的倍数，则无需进行任何舍入处理。

示例

公式 | 说明（结果）
=FLOOR(2.5, 1) | 将 2.5 向下舍入到 1 的最接近的倍数 (2)
=FLOOR(-2.5, -2) | 将 -2.5 向下舍入到 -2 的最接近的倍数 (-2)
=FLOOR(-2.5, 2) | 返回错误值，因为 -2.5 和 2 的符号不同 (#NUM!)
=FLOOR(1.5, 0.1) | 将 1.5 向下舍入到 0.1 的最接近的倍数 (1.5)
=FLOOR(0.234, 0.01) | 将 0.234 向下舍入到 0.01 的最接近的倍数 (0.23)


INT

将数字向下舍入到最接近的整数。

语法

INT(number)

Number 是需要向下舍入为整数的实数。

示例 1

公式 | 说明（结果）
=INT(8.9) | 将 8.9 向下舍入 (8)
=INT(-8.9) | 将 -8.9 向下舍入 (-9)

示例 2

Col1 | 公式 | 说明（结果）
19.5 | =[Col1]-INT([Col1]) | 返回 Col1 中正实数的小数部分 (0.5)


LN

返回数字的自然对数。自然对数以常数项 e (2.71828182845904) 为底。

语法

LN(number)

Number 是要计算其自然对数的正实数。

说明

LN 函数是 EXP 函数的反函数。

示例

公式 | 说明（结果）
=LN(86) | 86 的自然对数 (4.454347)
=LN(2.7182818) | 常数项 e 的自然对数 (1)
=LN(EXP(3)) | e 的 3 次幂的自然对数 (3)


LOG

按所指定的底数，返回一个数的对数。

语法

LOG(number,base)

Number 是要计算其对数的正实数。

Base 是对数的底数。如果省略底数，则假设其值为 10。

示例

公式 | 说明（结果）
=LOG(10) | 10 的对数 (1)
=LOG(8, 2) | 以 2 为底时，8 的对数 (3)
=LOG(86, 2.7182818) | 以 e 为底时，86 的对数 (4.454347)


LOG10

返回数字以 10 为底的对数。

语法

LOG10(number)

Number 是要计算其以 10 为底的对数的正实数。

示例

公式 | 说明（结果）
=LOG10(86) | 以 10 为底时，86 的对数 (1.934498451)
=LOG10(10) | 以 10 为底时，10 的对数 (1)
=LOG10(1E5) | 以 10 为底时，1E5 的对数 (5)
=LOG10(10^5) | 以 10 为底时，10^5 的对数 (5)


MOD

返回两数相除的余数。结果的正负号与除数相同。

语法

MOD(number,divisor)

Number 是要计算其余数的数字（被除数）。

Divisor 是用以除 number 的数字（除数）。

说明

  • 如果 divisor 为 0，则 MOD 返回错误值 #DIV/0!。

  • MOD 函数可以借用 INT 函数来表示：

    MOD(n, d) = n - d*INT(n/d)

示例

公式 | 说明（结果）
=MOD(3, 2) | 3/2 的余数。(1)
=MOD(-3, 2) | -3/2 的余数。符号与除数相同。(1)
=MOD(3, -2) | 3/-2 的余数。符号与除数相同。(-1)
=MOD(-3, -2) | -3/-2 的余数。符号与除数相同。(-1)


ODD

返回数字向上舍入到的最接近的奇数。

语法

ODD(number)

Number 是要四舍五入的数值。

说明

  • 如果 number 为非数字型，则 ODD 返回错误值 #VALUE!。
  • 不论数字的符号如何，数值都是向远离零的方向向上舍入。如果 number 正好是奇数，则不进行任何舍入。

示例

公式 | 说明（结果）
=ODD(1.5) | 将 1.5 向上舍入到最接近的奇数 (3)
=ODD(3) | 将 3 向上舍入到最接近的奇数 (3)
=ODD(2) | 将 2 向上舍入到最接近的奇数 (3)
=ODD(-1) | 将 -1 向上舍入到最接近的奇数 (-1)
=ODD(-2) | 将 -2 向上舍入到最接近的奇数 (-3)


PI

返回数字 3.14159265358979，即数学常量 pi，精确到小数点后 14 位。

语法

PI( )

示例

公式 | 说明（结果）
=PI() | Pi (3.14159265358979)
=PI()/2 | Pi/2 (1.570796327)
=PI()*(3^2) | 半径为 3 的圆的面积 (28.27433388)


POWER

返回某数的乘幂结果。

语法

POWER(number,power)

Number 底数，可以为任意实数。

Power 指数，底数按该指数次幂乘方。

说明

可以用“^”运算符代替函数 POWER 来表示对底数乘方的幂次，例如 5^2。

示例

公式 | 说明（结果）
=POWER(5,2) | 5 的平方 (25)
=POWER(98.6,3.2) | 98.6 的 3.2 次方 (2401077)
=POWER(4,5/4) | 4 的 5/4 次方 (5.656854)


PRODUCT

将所有以参数形式给出的数字相乘，并返回乘积值。

语法

PRODUCT(number1,number2,...)

Number1, number2, ... 是要相乘的 1 到 30 个数字。

说明

  • 如果参数为数字、逻辑值或数字的文本表达式，则这些参数将计算在内；如果参数为错误值或无法转换为数字的文本，则将产生错误。
  • 如果参数为列引用，则只有其中的数字会被计算。空参数、逻辑值、文本或错误值都将被忽略。

示例

Col1 | Col2 | Col3 | 公式 | 说明（结果）
5 | 15 | 30 | =PRODUCT([Col1], [Col2], [Col3]) | 将这组数字相乘 (2250)
5 | 15 | 30 | =PRODUCT([Col1], [Col2], [Col3],2) | 将这组数字与 2 相乘 (4500)


RADIANS

将度转换为弧度。

语法

RADIANS(angle)

Angle 以度表示的需要转换成弧度的角度。

示例

公式 | 说明（结果）
=RADIANS(270) | 将角度 270 度转换成弧度（4.712389 或 3π/2 弧度）


ROMAN

将阿拉伯数字转换为文本形式的罗马数字。

语法

ROMAN(number,form)

Number 需要转换的阿拉伯数字。

Form 为一数字，指定所需的罗马数字类型。罗马数字的样式范围可以从古典型到简化，随着 form 值的增加将趋于更简明。请参阅下面的示例 ROMAN(499,0)。

Form | 类型
0 或省略 | 古典型。
1 | 更简明。请参阅下面的示例。
2 | 更简明。请参阅下面的示例。
3 | 更简明。请参阅下面的示例。
4 | 简化型。
TRUE | 古典型。
FALSE | 简化型。

说明

  • 如果 number 为负数，则返回错误值 #VALUE!。
  • 如果 number 大于 3999，则返回错误值 #VALUE!。

示例

公式 | 说明（结果）
=ROMAN(499,0) | 499 的古典型罗马数字样式 (CDXCIX)
=ROMAN(499,1) | 499 的更简明版 (LDVLIV)
=ROMAN(499,2) | 499 的更简明版 (XDIX)
=ROMAN(499,3) | 499 的更简明版 (VDIV)
=ROMAN(499,4) | 499 的更简明版 (ID)
=ROMAN(2013,0) | 2013 的古典型罗马数字样式 (MMXIII)


ROUND

本主题中的部分内容可能不适用于某些语言。

将数字四舍五入到指定位数。

语法

ROUND(number,num_digits)

Number 要进行四舍五入的数字。

Num_digits 指定要将数字四舍五入到的位数。

说明

  • 如果 num_digits 大于 0（零），则会将 number 四舍五入到指定的小数位数。
  • 如果 num_digits 为 0，则会将 number 四舍五入到最接近的整数。
  • 如果 num_digits 小于 0，则会将 number 从小数点向左进行四舍五入。

示例

公式 | 说明（结果）
=ROUND(2.15, 1) | 将 2.15 四舍五入到一位小数 (2.2)
=ROUND(2.149, 1) | 将 2.149 四舍五入到位小数 (2.1)
=ROUND(-1.475, 2) | 将 -1.475 四舍五入到两个小数位 (-1.48)
=ROUND(21.5, -1) | 将 21.5 四舍五入到小数点左侧一位 (20)


ROUNDDOWN

将数字向零的方向向下舍入。

语法

ROUNDDOWN(number,num_digits)

Number 是需要向下舍入的任何实数。

Num_digits 是要将数字舍入到的位数。

说明

  • ROUNDDOWN 与 ROUND 功能相似，不同之处在于 ROUNDDOWN 总是向下舍入数字。
  • 如果 num_digits 大于 0（零），则将 number 向下舍入到指定的小数位数。
  • 如果 num_digits 为 0，则将 number 向下舍入到最接近的整数。
  • 如果 num_digits 小于 0，则将 number 在小数点左侧向下进行舍入。

示例

公式 | 说明（结果）
=ROUNDDOWN(3.2, 0) | 将 3.2 向下舍入，小数位数为零 (3)
=ROUNDDOWN(76.9,0) | 将 76.9 向下舍入，小数位数为零 (76)
=ROUNDDOWN(3.14159, 3) | 将 3.14159 向下舍入，保留三位小数 (3.141)
=ROUNDDOWN(-3.14159, 1) | 将 -3.14159 向下舍入，保留一位小数 (-3.1)
=ROUNDDOWN(31415.92654, -2) | 将 31415.92654 向下舍入到小数点左侧两位 (31400)


ROUNDUP

将数字向远离 0（零）的方向向上舍入。

语法

ROUNDUP(number,num_digits)

Number 是需要向上舍入的任何实数。

Num_digits 是要将数字舍入到的位数。

说明

  • ROUNDUP 与 ROUND 功能相似，不同之处在于 ROUNDUP 总是向上舍入数字。

  • 如果 num_digits 大于 0（零），则将 number 向上舍入到指定的小数位数。

  • 如果 num_digits 为 0，则将 number 向上舍入到最接近的整数。

  • 如果 num_digits 小于 0，则将 number 在小数点的左侧向上进行舍入。

示例

公式 | 说明（结果）
=ROUNDUP(3.2,0) | 将 3.2 向上舍入，小数位数为零 (4)
=ROUNDUP(76.9,0) | 将 76.9 向上舍入，小数位数为零 (77)
=ROUNDUP(3.14159,3) | 将 3.14159 向上舍入，保留三位小数 (3.142)
=ROUNDUP(-3.14159,1) | 将 -3.14159 向上舍入，保留一位小数 (-3.2)
=ROUNDUP(31415.92654,-2) | 将 31415.92654 向上舍入到小数点左侧两位 (31500)


SIGN

确定一个数字的符号。当数字为正数时返回 1，为 0 时返回零 (0)，为负数时返回 -1。

语法

SIGN(number)

Number 是任意实数。

示例

公式 | 说明（结果）
=SIGN(10) | 正数的符号 (1)
=SIGN(4-4) | 零的符号 (0)
=SIGN(-0.00001) | 负数的符号 (-1)


SIN

返回给定角度的正弦值。

语法

SIN(number)

Number 是需要求正弦的角度，以弧度表示。

说明

如果参数以度表示，则将其乘以 PI()/180，或使用 RADIANS 函数将其转换为弧度。

示例

公式 | 说明（结果）
=SIN(PI()) | pi 弧度的正弦值（约等于 0）
=SIN(PI()/2) | pi/2 弧度的正弦值 (1)
=SIN(30*PI()/180) | 30 度的正弦值 (0.5)
=SIN(RADIANS(30)) | 30 度的正弦值 (0.5)


SINH

返回一个数字的双曲正弦值。

语法

SINH(number)

Number 是任意实数。

说明

双曲正弦的计算公式如下：

示例 1

公式 | 说明（结果）
=SINH(1) | 1 的双曲正弦值 (1.175201194)
=SINH(-1) | -1 的双曲正弦值 (-1.175201194)

示例 2

可以使用双曲正弦函数来估计累积概率分布。假设实验检测值在 0 到 10 秒之间变化。对于实验所搜集的历史数据的经验分析表明：结果 x 小于 t 秒的概率可用下面的等式进行估计：

P(x<t) = 2.868 * SINH(0.0342 * t)，其中 0<t<10

若要计算结果小于 1.03 秒的概率，请用 1.03 替换 t。

公式 | 说明（结果）
=2.868*SINH(0.0342*1.03) | 得到结果小于 1.03 秒的概率 (0.101049063)

即每 1000 次实验中，可以预期此结果发生大约 101 次。


SQRT

返回正平方根。

语法

SQRT(number)

Number 是要对其求平方根的数字。

说明

如果数字为负数，SQRT 将返回错误值 #NUM!。

示例

公式 | 说明（结果）
=SQRT(16) | 16 的平方根 (4)
=SQRT(-16) | -16 的平方根。由于数字为负数，所以返回错误值 (#NUM!)
=SQRT(ABS(-16)) | -16 的绝对值的平方根 (4)


SUM

将指定参数中的所有数字相加。

语法

SUM(number1,number2,...)

Number1, number2, ... 是要对其求和的 1 到 30 个参数。

说明

  • 直接键入到参数表中的数字、逻辑值及代表数字的文本将被计算，请参阅下面的示例一和示例二。
  • 如果参数是错误值或不能转换成数字的文本，则会导致错误。

示例

Col1 | Col2 | Col3 | Col4 | Col5 | 公式 | 说明（结果）
-5 | 15 | 30 |  | TRUE | =SUM(3, 2) | 将 3 和 2 相加 (5)
-5 | 15 | 30 |  | TRUE | =SUM("5", 15, TRUE) | 将 5、15 和 1 相加，因为文本值被转换成数字，逻辑值 TRUE 被转换成数字 1 (21)
-5 | 15 | 30 |  | TRUE | =SUM(Col1], [Col2], [Col3]) | 将前三列中的三个数字相加 (40)
-5 | 15 | 30 |  | TRUE | =SUM(Col1], [Col2], [Col3], 15) | 将前三列中的三个数字与 15 相加 (55)
-5 | 15 | 30 |  | TRUE | =SUM([Col4], [Col5], 2) | 将后两列中的值与 2 相加 (2)


SUMSQ

返回参数的平方和。

语法

SUMSQ(number1,number2,...)

Number1, number2, ... 是要对其求平方和的 1 到 30 个参数。

示例

公式 | 说明（结果）
=SUMSQ(3, 4) | 3 和 4 的平方和 (25)


TAN

返回给定角度的正切值。

语法

TAN(number)

Number 是要求其正切的角度，以弧度表示。

说明

如果参数以度表示，则将其乘以 PI()/180，或使用 RADIANS 函数将其转换为弧度。

示例

公式 | 说明（结果）
=TAN(0.785) | 0.785 弧度的正切值 (0.99920)
=TAN(45*PI()/180) | 45 度的正切值 (1)
=TAN(RADIANS(45)) | 45 度的正切值 (1)


TANH

返回某一数字的双曲正切值。

语法

TANH(number)

Number 是任意实数。

说明

双曲正切值的计算公式如下：

示例

公式 | 说明（结果）
=TANH(-2) | -2 的双曲正切值 (-0.96403)
=TANH(0) | 0 的双曲正切值 (0)
=TANH(0.5) | 0.5 的双曲正切值 (0.462117)


TRUNC

通过删除数字中的小数部分将数字截为整数。

语法

TRUNC(number,num_digits)

Number 需要截尾取整的数字。

Num_digits 用于指定取整精度的数字。Num_digits 的默认值为 0（零）。

说明

TRUNC 和 INT 类似，都返回整数。TRUNC 直接删除数字中的小数部分。而 INT 则是根据给定数字中小数部分的值，将其向下舍入到最接近的整数。INT 和 TRUNC 仅在使用负数时有所不同：TRUNC(-4.3) 返回 -4，但是 INT(-4.3) 返回 -5，因为 -5 比 -4 小。

示例

公式 | 说明（结果）
=TRUNC(8.9) | 8.9 的整数部分 (8)
=TRUNC(-8.9) | -8.9 的整数部分 (-8)
=TRUNC(PI()) | pi 的整数部分 (3)


AVEDEV

返回一组数据点与其平均数的绝对偏差的平均值。AVEDEV 是对数据集中可变性的度量。

语法

AVEDEV(number1,number2, ...)

Number1, number2, ... 是要计算其绝对偏差平均值的 1 到 30 个参数。

说明

  • 参数必须是数字，或是包含数字的列引用。
  • 如果某个列引用参数包含文本、逻辑值或为空，则这些值将被忽略，或返回错误值 #VALUE!；但包含零值的将计算在内。
  • 平均偏差的计算公式如下：

AVEDEV 的计算结果会受输入数据中的测量单位的影响。

示例

Col1 | Col2 | Col3 | Col4 | Col5 | Col6 | Col7 | 公式 | 说明（结果）
4 | 5 | 6 | 7 | 5 | 4 | 3 | =AVEDEV([Col1],[Col2],[Col3],[Col4],[Col5],[Col6],[Col7]) | 这组数据与其平均数的绝对偏差的平均值 (1.020408)


AVERAGE

返回参数的平均值（算术平均数）。

语法

AVERAGE(number1,number2, ...)

Number1, number2, ... 是要计算其平均值的 1 到 30 个数字参数。

说明

  • 参数必须是数字，或是包含数字的引用。
  • 如果某个数组或列引用参数包含文本、逻辑值或为空，则这些值将被忽略，或返回错误值 #VALUE!；但包含零值的参数将计算在内。

示例

Col1 | Col2 | Col3 | Col4 | Col5 | 公式 | 说明（结果）
10 | 7 | 9 | 27 | 2 | =AVERAGE([Col1], [Col2], [Col3], [Col4], [Col5]) | 列数字的平均值 (11)
10 | 7 | 9 | 27 | 2 | =AVERAGE([Col1], [Col2], [Col3], [Col4], [Col5], 5) | 列数字和 5 的平均值 (10)


AVERAGEA

计算参数列表中数值的平均值（算术平均值）。与 AVERAGE 函数不同，计算中包含文本和逻辑值（如 TRUE 和 FALSE）。

语法

AVERAGEA(value1,value2, ...)

Value1, value2,... 是要计算其平均值的 1 到 30 个参数。

说明

  • 包含文本的参数作为 0（零）进行计算。空文本 ("") 作为 0（零）进行计算。如果在平均值的计算中禁止包含文本值，请使用 AVERAGE 函数。
  • 包含 TRUE 的参数作为 1 进行计算；包含 FALSE 的参数作为 0（零）进行计算。

示例

Col1 | Col2 | Col3 | Col4 | Col5 | Col6 | 公式 | 说明（结果）
10 | 7 | 9 | 2 | 0 |  | =AVERAGEA([Col1],[Col2],[Col3],[Col4],[Col5]) | 这组数字的平均值 (5.6)
10 | 10 | 9 | 2 | 1 |  | =AVERAGEA([Col1],[Col2],[Col3],[Col4],[Col6]) | 数字和空参数的平均值 (7.75)


BETADIST

返回累积 beta 概率分布函数。累积 beta 概率分布函数通常用于研究样本中某些事物变化的百分比，例如人们一天中看电视的时间部分。

语法

BETADIST(x,alpha,beta,A,B)

X 介于 A 和 B 之间的值，用来进行函数计算。

Alpha 分布参数。

Beta 分布参数。

A 数值 x 所属区间的可选下界。

B 数值 x 所属区间的可选上界。

说明

  • 如果任一参数为非数字型，则 BETADIST 返回错误值 #VALUE!。
  • 如果 alpha ≤ 0 或 beta ≤ 0，则 BETADIST 返回错误值 #NUM!。
  • 如果 x < A，x > B 或 A = B，则 BETADIST 返回错误值 #NUM!。
  • 如果省略 A 和 B 的数值，则 BETADIST 使用标准累积 beta 分布，即 A = 0，B = 1。

示例

X | Alpha | Beta | A | B | 公式 | 说明（结果）
2 | 8 | 10 | 1 | 3 | =BETADIST([X],[Alpha],[Beta],[A],[B]) | 这些参数的累积 beta 概率密度函数的函数值 (0.685470581)


BETAINV

返回累积 beta 概率分布函数的反函数值。即，如果概率 = BETADIST(x,...)，则 BETAINV(probability,...) = x。累积 beta 分布函数可用于项目设计，在给定预期的完成时间和变化参数后，模拟可能的完成时间。

语法

BETAINV(probability,alpha,beta,A,B)

Probability 与 beta 分布相关联的概率值。

Alpha 分布参数。

Beta 分布参数。

A 数值 x 所属区间的可选下界。

B 数值 x 所属区间的可选上界。

说明

  • 如果任一参数为非数字型，则 BETAINV 返回错误值 #VALUE!。
  • 如果 alpha ≤ 0 或 beta ≤ 0，则 BETAINV 返回错误值 #NUM!。
  • 如果 probability ≤ 0 或 probability > 1，则 BETAINV 返回错误值 #NUM!。
  • 如果省略 A 和 B 值，则 BETAINV 使用标准累积 beta 分布，即 A = 0，B = 1。

BETAINV 使用迭代法来计算函数。如果给出一个概率值，则函数 BETAINV 开始进行迭代，直到计算结果的精度达到 ±3x10-7 内。如果经过 100 次迭代后，函数 BETAINV 仍未收敛，则函数返回错误值 #N/A。

示例

Probability | Alpha | Beta | A | B | 公式 | 说明（结果）
0.685470581 | 8 | 10 | 1 | 3 | =BETAINV([Probability],[Alpha],[Beta],[A],[B]) | 这些参数的累积 beta 概率密度函数的反函数值 (2)


BINOMDIST

返回一元二项式分布的概率值。函数 BINOMDIST 适用于固定次数的测试或试验，当任何试验的结果仅包含成功或失败两种情况，当试验是独立试验，且当在整个试验过程中成功的概率固定不变。例如，函数 BINOMDIST 可以计算三个婴儿中两个是男孩的概率。

语法

BINOMDIST(number_s,trials,probability_s,cumulative)

Number_s 是试验中成功的次数。

Trials 是独立试验的次数。

Probability_s 是每次试验中成功的概率。

Cumulative 是一逻辑值，用于确定函数的形式。如果 cumulative 为 TRUE，则函数 BINOMDIST 返回累积分布函数，即最多存在 number_s 次成功的概率；如果为 FALSE，则返回概率密度函数，即正好存在 number_s 次成功的概率。

说明

  • Number_s 和 trials 将被截尾取整。
  • 如果 number_s、trials 或 probability_s 为非数字型，则 BINOMDIST 返回错误值 #VALUE!。
  • 如果 number_s < 0 或 number_s > 试验次数，则 BINOMDIST 返回错误值 #NUM!。
  • 如果 probability_s < 0 或 probability_s > 1，则 BINOMDIST 返回错误值 #NUM!。
  • 二项式概率密度函数的计算公式如下：

    其中：

    等于 COMBIN(n,x)。

    注意 此处的 COMBIN 函数用于说明由 BINOMDIST 函数所用的数学公式。它并非可以在列表中使用的函数。

    累积二项式分布函数的计算公式如下：

示例

number_s | trials | probability_s | 公式 | 说明（结果）
6 | 10 | 0.5 | =BINOMDIST([number_s],[trials],[probability_s],FALSE) | 10 次试验正好成功 6 次的概率 (0.205078)


CHIDIST

返回 χ2 分布的收尾概率。γ2 分布与 γ2 检验相关联。使用 γ2 检验可比较观察值和理论值。例如，某项遗传学实验可能假设下一代植物将呈现出某一组颜色。通过使用该函数比较观察结果和理论值，可以确定初始假设是否有效。

语法

CHIDIST(x,degrees_freedom)

X 是用来计算分布的值。

Degrees_freedom 自由度。

说明

  • 如果任一参数为非数字型，则 CHIDIST 返回错误值 #VALUE!。
  • 如果 x 为负，则 CHIDIST 会返回错误值 #NUM!。
  • 如果 degrees_freedom 不是整数，将被截尾取整。
  • 如果 degrees_freedom < 1 或 degrees_freedom ≥ 10^10，则 CHIDIST 返回错误值 #NUM!。
  • CHIDIST 按 CHIDIST = P(X>x) 计算，式中 X 为 γ2 随机变量。

示例

X | DegreesFreedom | 公式 | 说明（结果）
18.307 | 10 | =CHIDIST([X],[DegreesFreedom]) | 在指定的参数条件下 χ2 分布的收尾概率 (0.050001)


CHIINV

返回 χ2 分布的收尾概率的反函数值。如果 probability = CHIDIST(x,...)，则 CHIINV(probability,...) = x。使用此函数可比较观察结果与理论值，以确定初始假设是否有效。

语法

CHIINV(probability,degrees_freedom)

Probability 与 χ2 分布相关联的概率。

Degrees_freedom 自由度。

说明

  • 如果任一参数为非数字型，则 CHIINV 返回错误值 #VALUE!。
  • 如果 probability < 0 或 probability > 1，则 CHIINV 返回错误值 #NUM!。
  • 如果 degrees_freedom 不是整数，将被截尾取整。
  • 如果 degrees_freedom < 1 或 degrees_freedom ≥ 10^10，则 CHIINV 返回错误值 #NUM!。

CHIINV 使用迭代法计算函数。如果给出一个概率值，则 CHIINV 开始进行迭代，直到计算结果的精度达到 ± 3x10^-7 内。如果经过 100 次迭代后，CHIINV 仍未收敛，则函数返回错误值 #N/A。

示例

Probability | DegreesFreedom | 公式 | 说明（结果）
0.05 | 10 | =CHIINV([Probability],[DegreesFreedom]) | χ2 分布的收尾概率的反函数值 (18.30703)


CONFIDENCE

使用标准分布返回总体平均值的置信区间。置信区间是样本平均值任何一侧的一个区域。例如，如果您通过邮购的方式订购产品，则依照某个特定置信度，可以确定最早及最晚到货的时间。

语法

CONFIDENCE(alpha,standard_dev,size)

Alpha 是用于计算置信度的显著水平参数。置信度等于 100*(1 - alpha)%，亦即，如果 alpha 为 0.05，则置信度为 95%。

Standard_dev 数据区域的总体标准偏差，假设为已知。

Size 样本容量。

说明

  • 如果任一参数为非数字型，则 CONFIDENCE 返回错误值 #VALUE!。
  • 如果 alpha ≤ 1 或 alpha ≥ 1，则 CONFIDENCE 返回错误值 #NUM!。
  • 如果 standard_dev ≤ 0，则 CONFIDENCE 返回错误值 #NUM!。
  • 如果 size 不是整数，将被截尾取整。
  • 如果 size < 1，则 CONFIDENCE 返回错误值 #NUM!。
  • 如果假设 alpha 等于 0.05，则需要计算等于 (1 - alpha) 或 95% 的标准正态分布曲线之下的面积。此面积值为 ± 1.96。因此置信区间为：

示例

假设样本取自 50 名乘车上班的乘客，他们花在上班路上的平均时间为 30 分钟，总体标准偏差为 2.5。总体平均值落入下列区间的置信度为 95%：

Alpha | StdDev | Size | 公式 | 说明（结果）
0.05 | .5 | 50 | =CONFIDENCE([Alpha],[StdDev],[Size]) | 总体平均值的置信区间。即花在上班路上的平均时间为 30 ± 0.692951 分钟，或 29.3 到 30.7 分钟。(0.692951)


COUNT

计算包含数字的参数的个数。

语法

COUNT(value1,value2, ...)

Value1, value2, ... 是可以包含或引用各种类型数据的 1 到 30 个参数，但只有数字类型的数据才计算在内。

说明

  • 数字、日期或文本代表的数字这类参数会被计算在内；但是错误值或无法转换为数字的文本这类参数将被忽略。
  • 如果需要统计逻辑值、文本或错误值，请使用 COUNTA 函数。

示例

Col1 | Col2 | Col3 | Col4 | Col5 | Col6 | Col7 | 公式 | 说明（结果）
Sales | 2008-12-8 |  | 19 | 22.24 | TRUE | #DIV/0! | =COUNT([Col1],[Col2],[Col3],[Col4],[Col5],[Col6],[Col7]) | 计算列表中包含数字的参数个数 (3)
 |  |  | 19 | 22.24 | TRUE | #DIV/0! | =COUNT([Col4],[Col5],[Col6],[Col7]) | 计算列表的最后 4 行中包含数字的参数的个数 (2)
Sales | 2008-2-8 |  | 19 | 22.24 | TRUE | #DIV/0! | COUNT([Col1],[Col2],[Col3],[Col4],[Col5],[Col6],[Col7],2) | 计算列表中包含数字，及数值 2 的参数个数 (4)


COUNTA

计算非空值的参数个数。

语法

COUNTA(value1,value2, ...)

Value1, value2, ... 代表要计数其值的 1 到 30 个参数。这种情况下，参数值可以是任何信息类型，包括空文本 ("")，但不包括空参数。如果不需要统计逻辑值、文本或错误值，请使用 COUNT 函数。

示例

Col1 | Col2 | Col3 | Col4 | Col5 | Col6 | Col7 | 公式 | 说明（结果）
Sales | 2008-12-8 |  | 19 | 22.24 | TRUE | #DIV/0! | =COUNTA([Col1],[Col2],[Col3],[Col4],[Col5],[Col6],[Col7]) | 计算列表中非空参数的个数 (6)
Sales | 2008-12-8 |  | 19 | 22.24 | TRUE | #DIV/0! | =COUNTA([Col4],[Col5],[Col6],[Col7])) | 计算列表的最后 4 行中非空参数的个数 (4)
Sales | 2008-12-8 |  | 19 | 22.24 | TRUE | #DIV/0! | =COUNTA([Col1],[Col2],[Col3],[Col4],[Col5],[Col6],[Col7],2) | 计算列表中的非空参数，及数值 2 的个数 (7)
Sales | 2008-12-8 |  | 19 | 22.24 | TRUE | #DIV/0! | =COUNTA([Col1],[Col2],[Col3],[Col4],[Col5],[Col6],[Col7], "Two") | 计算列表中的非空参数，及值“Two”的个数 (7)


CRITBINOM

返回使累积二项式分布大于或等于临界值的最小值。此函数可用于质量检验。例如，使用 CRITBINOM 来决定最多允许出现多少个有缺陷的部件，才可以保证当整批产品在离开装配线时检验合格。

语法

CRITBINOM(trials,probability_s,alpha)

Trials 贝努利试验次数。

Probability_s 每次试验中成功的概率。

Alpha 临界值。

说明

  • 如果任一参数为非数字型，则 CRITBINOM 返回错误值 #VALUE!。
  • 如果 trials 不是整数，将被截尾取整。
  • 如果 trials < 0，则 CRITBINOM 返回错误值 #NUM!。
  • 如果 probability_s < 0 或 probability_s > 1，则 CRITBINOM 返回错误值 #NUM!。
  • 如果 alpha < 0 或 alpha > 1，则 CRITBINOM 返回错误值 #NUM!。

示例

Trials | Probability_s | Alpha | 公式 | 说明（结果）
6 | 0.5 | 0.75 | =CRITBINOM([Trials],[Probability_s],[Alpha]) | 返回累积二项式分布大于等于临界值的最小值 (4)


DEVSQ

返回数据点与其样本平均值偏差的平方和。

语法

DEVSQ(number1,number2, ...)

Number1,number2, ... 是要计算其偏差平方和的 1 到 30 个参数。

说明

  • 参数必须是数字或包含数字的列引用。
  • 如果参数包含文本、逻辑值或为空，则这些值将被忽略，但包含零值的参数将计算在内。
  • 偏差平方和的计算公式如下：

示例

Col1 | Col2 | Col3 | Col4 | Col5 | Col6 | Col7 | 公式 | 说明（结果）
4 | 5 | 8 | 7 | 11 | 4 | 3 | =DEVSQ([Col1],[Col2],[Col3],[Col4],[Col5],[Col6],[Col7]) | 数据与其样本平均值之间偏差的平方和 (48)


EXPONDIST

返回指数分布。使用 EXPONDIST 可以建立事件之间的时间间隔模型，如银行自动提款机支付一次现金所花费的时间。例如，可以使用函数 EXPONDIST 来确定这一过程最长持续一分钟的发生概率。

语法

EXPONDIST(x,lambda,cumulative)

X 函数的数值。

Lambda 参数值。

Cumulative 是一逻辑值，指出提供的指数函数的形式。如果 cumulative 为 TRUE，则 EXPONDIST 返回累积分布函数；如果为 FALSE，则它返回概率密度函数。

说明

  • 如果 x 或 lambda 为非数字型，则 EXPONDIST 返回错误值 #VALUE!。
  • 如果 x < 0，则 EXPONDIST 返回错误值 #NUM!。
  • 如果 lambda ≤ 0，则 EXPONDIST 返回错误值 #NUM!。
  • 概率密度函数的计算公式如下：

  • 累积分布函数的计算公式如下：

示例 1

公式 | 说明（结果）
=EXPONDIST(0.2,10,FALSE) | 概率指数分布函数 (1.353353)

示例 2

X | Lambda | 公式 | 说明（结果）
0.2 | 10 | =EXPONDIST([X,][Lambda],TRUE) | 累积指数分布函数 (0.864665)


FDIST

返回 F 概率分布。可以使用此函数来确定两组数据是否存在变化程度上的不同。例如，分析进入高校的男生、女生的考试分数，确定女生分数的变化程度是否与男生不同。

语法

FDIST(x,degrees_freedom1,degrees_freedom2)

X 是用来计算函数的值。

Degrees_freedom1 分子的自由度。

Degrees_freedom2 分母的自由度。

说明

  • 如果任一参数为非数字型，则 FDIST 返回错误值 #VALUE!。
  • 如果 x 为负数，则 FDIST 返回错误值 #NUM!。
  • 如果 degrees_freedom1 或 degrees_freedom2 不是整数，将被截尾取整。
  • 如果 degrees_freedom1 < 1 或 degrees_freedom1 ≥ 10^10，则 FDIST 返回错误值 #NUM!。
  • 如果 degrees_freedom2 < 1 或 degrees_freedom2 ≥ 10^10，则 FDIST 返回错误值 #NUM!。
  • FDIST 的计算公式为 FDIST=P( F<x )，其中 F 为呈 F 分布的随机变量。

示例

X | Degrees1 | Degrees2 | 公式 | 说明（结果）
15.20675 | 6 | 4 | =FDIST([X],[Degrees1],[Degrees2]) | 在指定的参数条件下的 F 概率分布 (0.01)


FINV

返回 F 概率分布的反函数值。如果 p = FDIST(x,...)，则 FINV(p,...) = x。

在 F 检验中，可以使用 F 分布比较两组数据中的变化程度。例如，可以分析美国和加拿大的收入分布，判断两个国家/地区是否有相似的收入变化程度。

语法

FINV(probability,degrees_freedom1,degrees_freedom2)

Probability 与 F 累积分布相关联的概率值。

Degrees_freedom1 分子的自由度。

Degrees_freedom2 分母的自由度。

说明

  • 如果任一参数为非数字型，则 FINV 返回错误值 #VALUE!。
  • 如果 probability < 0 或 probability > 1，则 FINV 返回错误值 #NUM!。
  • 如果 degrees_freedom1 或 degrees_freedom2 不是整数，将被截尾取整。
  • 如果 degrees_freedom1 < 1 或 degrees_freedom1 ≥ 10^10，则 FINV 返回错误值 #NUM!。
  • 如果 degrees_freedom2 < 1 或 degrees_freedom2 ≥ 10^10，则 FINV 返回错误值 #NUM!。

FINV 可以用于返回 F 分布的临界值。例如，ANOVA 计算的结果通常包含 F 统计值、F 概率和显著水平参数为 0.05 的 F 临界值等数据。若要返回 F 的临界值，请将显著水平参数用作为 FINV 的 probability 参数。

FINV 使用迭代法来计算函数。如果给定一个概率值，则 FINV 开始迭代，直到计算结果的精度达到 ± 3x10^-7 内。如果经过 100 次迭代后，函数 FINV 仍未收敛，则此函数返回错误值 #N/A。

示例

Probability | Degrees1 | Degrees2 | 公式 | 说明（结果）
0.01 | 6 | 4 | =FINV([Probability],[Degrees1],[Degrees2]) | 在指定参数条件下 F 概率分布的反函数值 (15.20675)


FISHER

返回 x 的 Fisher 变换值。此变换生成一个近似正态分布而非偏斜的函数。使用此函数可以完成相关系数的假设检验。

语法

FISHER(x)

X 要对其进行变换的数值。

说明

  • 如果 x 为非数字型，则 FISHER 返回错误值 #VALUE!。
  • 如果 x ≤ -1 或 if x ≥ 1，则 FISHER 返回错误值 #NUM!。

  • Fisher 变换的公式如下：

示例

公式 | 说明（结果）
=FISHER(0.75) | 0.75 的 Fisher 变换值 (0.972955)


FISHERINV

返回 Fisher 变换的反函数值。使用此变换可以分析数据区域或数组之间的相关性。如果 y = FISHER(x)，则 FISHERINV(y) = x。

语法

FISHERINV(y)

Y 是要对其进行逆变换的数值。

说明

  • 如果 y 为非数字型，则 FISHERINV 返回错误值 #VALUE!。

  • Fisher 变换反函数的计算公式如下：

示例

公式 | 说明（结果）
=FISHERINV(0.972955) | 0.972955 的 Fisher 变换的反函数值 (0.75)


GAMMADIST

返回 γ 分布函数值。可以使用此函数来研究具有偏态分布的变量。γ 分布通常用于队列分析。

语法

GAMMADIST(x,alpha,beta,cumulative)

X 是用来计算分布的值。

Alpha 分布参数。

Beta 分布参数。如果 beta = 1，则 GAMMADIST 返回标准 γ 分布。

Cumulative 是一逻辑值，用于确定函数的形式。如果 cumulative 为 TRUE，则 GAMMADIST 返回累积分布函数；如果为 FALSE，则它返回概率密度函数。

说明

  • 如果 x、alpha 或 beta 为非数字型，则 GAMMADIST 返回错误值 #VALUE!。
  • 如果 x < 0，则 GAMMADIST 返回错误值 #NUM!。
  • 如果 alpha ≤ 0 或 beta ≤ 0，则 GAMMADIST 返回错误值 #NUM!。
  • γ 分布的计算公式如下：

    标准 γ 分布为：

  • 当 alpha = 1 时，则 GAMMADIST 使用下面的公式返回指数分布：

  • 对于正整数 n，当 alpha = n/2、beta = 2 且 cumulative = TRUE 时，GAMMADIST 返回 (1 - CHIDIST(x))（自由度为 n）。
  • 如果 alpha 为正整数，则 GAMMADIST 也称为 Erlang 分布。

示例

X | Alpha | Beta | 公式 | 说明（结果）
10 | 9 | 2 | =GAMMADIST([X],[Alpha],[Beta],FALSE) | 所给参数的概率 γ 分布 (0.032639)
10 | 9 | 2 | =GAMMADIST([X],[Alpha],[Beta],TRUE) | 所给参数的累积 γ 分布 (0.068094)


GAMMAINV

返回 γ 累积分布函数的反函数值。如果 p = GAMMADIST(x,...)，则 GAMMAINV(p,...) = x。

可以使用此函数研究可能出现偏态分布的变量。

语法

GAMMAINV(probability,alpha,beta)

Probability 与 γ 分布相关联的概率值。

Alpha 分布参数。

Beta 分布参数。如果 beta = 1，则 GAMMAINV 返回标准 γ 分布。

说明

  • 如果任一参数为非数字型，则 GAMMAINV 返回错误值 #VALUE!。
  • 如果 probability < 0 或 probability > 1，则 GAMMAINV 返回错误值 #NUM!。
  • 如果 alpha ≤ 0 或 beta ≤ 0，则 GAMMAINV 返回错误值 #NUM!。

GAMMAINV 使用迭代法来计算函数。如果给定一个概率数值，则 GAMMAINV 开始迭代，直到计算结果精度达到 ±3x10^-7 内。如果经过 100 次迭代后，GAMMAINV 仍未收敛，则函数返回错误值 #N/A。

示例

Probability | Alpha | Beta | 公式 | 说明（结果）
0.068094 | 9 | 2 | =GAMMAINV([Probability],[Alpha],[Beta]) | 所给参数的 γ 累积分布函数的反函数值 (10)


GAMMALN

返回 γ 函数的自然对数 Γ(x)。

语法

GAMMALN(x)

X 是要计算其 GAMMALN 值的数值。

说明

  • 如果 x 是非数字型，则 GAMMALN 返回错误值 #VALUE!。
  • 如果 x ≤ 0，则 GAMMALN 返回错误值 #NUM!。
  • 数字 e 的 GAMMALN(i) 次幂的返回值与 (i - 1)! 的结果相同（其中 i 为整数）。
  • GAMMALN 的计算公式如下：

    其中：

示例

公式 | 说明（结果）
=GAMMALN(4) | 4 的 γ 函数的自然对数 (1.791759)


GEOMEAN

返回正数数据的几何平均值。例如，可以使用 GEOMEAN 计算可变复利的平均增长率。

语法

GEOMEAN(number1,number2, ...)

Number1,number2, ... 要计算其平均值的 1 到 30 个参数。

说明

  • 参数必须是数字，或是包含数字的列引用。
  • 如果列引用参数包含文本、逻辑值或为空，则这些值将被忽略；但是，包含零值的参数将计算在内。
  • 如果任一数据点 ≤ 0，则 GEOMEAN 返回错误值 #NUM!。
  • 几何平均值的计算公式如下：

示例

Col1 | Col2 | Col3 | Col4 | Col5 | Col6 | Col7 | 公式 | 说明（结果）
4 | 5 | 8 | 7 | 11 | 4 | 3 | =GEOMEAN([Col1],[Col2],[Col3],[Col4],[Col5],[Col6],[Col7]) | 这些数据的几何平均值 (5.476987)


HARMEAN

返回一组数据的调和平均值。调和平均值与倒数的算术平均值互为倒数。

语法

HARMEAN(number1,number2, ...)

Number1,number2, ... 要计算其平均值的 1 到 30 个参数。

说明

  • 参数必须是数字，或是包含数字的列引用。
  • 如果列引用参数包含文本、逻辑值或为空，则这些值会被忽略；但是，包含零值的参数将计算在内。
  • 如果任何数据点 ≤ 0，则 HARMEAN 返回错误值 #NUM!。
  • 调和平均值总是小于几何平均值，而几何平均值总是小于算术平均值。
  • 调和平均值的计算公式如下：

示例

Col1 | Col2 | Col3 | Col4 | Col5 | Col6 | Col7 | 公式 | 说明（结果）
4 | 5 | 8 | 7 | 11 | 4 | 3 | =HARMEAN([Col1],[Col2],[Col3],[Col4],[Col5],[Col6],[Col7]) | 这组数据的调和平均值 (5.028376)


HYPGEOMDIST

返回超几何分布。在给定样本容量、样本总体成功次数和样本总体容量时，HYPGEOMDIST 返回样本取得给定成功次数的概率。使用 HYPGEOMDIST 可解决有限总体的问题，其中每个观察值或为成功或为失败，且其中给定样本容量的每一个子集有相等的发生概率。

语法

HYPGEOMDIST(sample_s,number_sample,population_s,number_population)

Sample_s 样本中成功的次数。

Number_sample 样本容量。

Population_s 样本总体中成功的次数。

Number_population 样本总体容量。

说明

  • 所有参数都将被截尾取整。
  • 如果任一参数为非数字型，则 HYPGEOMDIST 返回错误值 #VALUE!。
  • 如果 sample_s < 0 或 sample_s 大于 number_sample 或 population_s 中的较小值，则 HYPGEOMDIST 返回错误值 #NUM!。
  • 如果 sample_s 小于 0 或 (number_sample - number_population + population_s) 中的较大值，则 HYPGEOMDIST 返回错误值 #NUM!。
  • 如果 number_sample < 0 或 number_sample > number_population，则 HYPGEOMDIST 返回错误值 #NUM!。
  • 如果 population_s < 0 或 population_s > number_population，则 HYPGEOMDIST 返回错误值 #NUM!。
  • 如果 number_population < 0，则 HYPGEOMDIST 返回错误值 #NUM!。
  • 超几何分布的计算公式如下：

    其中：

    x = sample_s

    n = number_sample

    M = population_s

    N = number_population

    HYPGEOMDIST 用于在有限样本总体中进行不退回抽样的概率计算。

示例

抽样器里有 20 块巧克力。其中 8 块是焦糖的，其余 12 块是果仁的。如果随机选出 4 块，下面函数返回正好有一块是焦糖的概率。

Sample_s | Number_sample | Population_s | Number_Population | 公式 | 说明（结果）
1 | 4 | 8 | 20 | =HYPGEOMDIST([Sample_s],[Number_sample],[Population_s],[Number_Population]) | 样本和样本总体的超几何分布 (0.363261)


KURT

返回一组数据的峰值。峰值反映与正态分布相比某一分布的尖锐度或平坦度。正峰值表示相对尖锐的分布。负峰值表示相对平坦的分布。

语法

KURT(number1,number2, ...)

Number1,number2, ... 要计算其峰值的 1 到 30 个参数。

说明

  • 参数必须是数字，或是包含数字的列引用。
  • 如果列引用参数包含文本、逻辑值或为空，则这些值会被忽略；但是，包含零值的参数将计算在内。
  • 如果数据点少于四个，或样本标准偏差等于零，则 KURT 返回错误值 #DIV/0!。
  • 峰值的计算公式如下：

    其中：

    s 是样本标准偏差。

示例

Col1 | Col2 | Col3 | Col4 | Col5 | Col6 | Col7 | Col8 | Col9 | Col10 | 公式 | 说明（结果）
3 | 4 | 5 | 2 | 3 | 4 | 5 | 6 | 4 | 7 | =KURT([Col1], [Col2], [Col3], [Col4], [Col5], [Col6],[Col7],[Col8],[Col9],[Col10]) | 这组数据的峰值 (-0.1518)


LOGINV

返回 x 的对数累积分布函数的反函数，其中 ln(x) 是服从参数 mean 与 standard_dev 的正态分布。如果 p=LOGNORMDIST(x,...)，则 LOGINV（p,...）=x。

使用对数分布可分析经过对数变换的数据。

语法

LOGINV(probability,mean,standard_dev)

Probability 是与对数分布相关的概率。

Mean 是 ln(x) 的平均值。

Standard_dev 是 ln(x) 的标准偏差。

说明

  • 如果任一参数是非数字型，则 LOGINV 返回错误值 #VALUE!。
  • 如果 probability < 0 或 probability > 1，则 LOGINV 返回错误值 #NUM!。
  • 如果 standard_dev <= 0，则 LOGINV 返回错误值 #NUM!。

  • 对数分布函数的反函数为：

示例

Probablility | Mean | StdDev | 公式 | 说明（结果）
0.039084 | 3.5 | 1.2 | =LOGINV([Probablility], [Mean], [StdDev]) | 在指定的参数条件下对数累积分布函数的反函数值 (4.000028)


LOGNORMDIST

返回 x 的对数累积分布，其中 ln(x) 是服从参数 mean 和 standard_dev 的正态分布。使用此函数可以分析经过对数变换的数据。

语法

LOGNORMDIST(x,mean,standard_dev)

X 是用来计算函数的值。

Mean 是 ln(x) 的平均值。

Standard_dev 是 ln(x) 的标准偏差。

说明

  • 如果任一参数是非数字型，则 LOGNORMDIST 返回错误值 #VALUE!。
  • 如果 x ≤ 0 或 standard_dev ≤ 0，则 LOGNORMDIST 返回错误值 #NUM!。
  • 对数累积分布函数的计算公式如下：

示例

X | Mean | StdDev | 公式 | 说明（结果）
4 | 3.5 | 1.2 | =LOGNORMDIST([X],[Mean],[StdDev]) | 在指定的参数条件下 4 的对数累积分布函数值 (0.039084)


MAX

返回一组值中的最大值。

语法

MAX(number1,number2, ...)

Number1,number2, ... 是要从中查找最大值的 1 到 30 个数字。

说明

  • 可以将参数指定为数字、空参数、逻辑值或数字的文本表达式。如果参数为错误值或不能转换为数字的文本，则将产生错误。
  • 如果不能忽略逻辑值和文本，请使用 MAXA 来代替。
  • 如果参数不包含任何数字，则 MAX 返回 0（零）。

示例

Col1 | Col2 | Col3 | col4 | Col5 | 公式 | 说明（结果）
10 | 7 | 9 | 27 | 2 | =MAX([Col1],[Col2],[Col3],[Col4],[Col5]) | 这组数字中的最大值 (27)
10 | 7 | 9 | 27 | 2 | =MAX(Col1],[Col2],[Col3],[Col4],[Col5],30) | 这组数字和 30 中的最大值 (30)


MAXA

返回参数列表中最大值。文本和逻辑值（如 TRUE 和 FALSE）也可以和数字一样进行比较。

MAXA 与 MINA 相似。有关详细信息，请参阅 MINA 的示例。

语法

MAXA(value1,value2, ...)

Value1, Value2, ... 是要从中查找最大值的 1 到 30 个参数。

说明

  • 可以将参数指定为数字、空参数、逻辑值或数字的文本表达式。如果参数为错误值，将会产生错误。如果计算不能包含文本或逻辑值，请使用 MAX 来代替。
  • 包含 TRUE 的参数作为 1 计算；包含文本或 FALSE 的参数作为 0（零）计算。
  • 如果参数不包含任何值，则 MAXA 返回 0（零）。

示例

Col1 | Col2 | Col3 | Col4 | col5 | 公式 | 说明（结果）
0 | 0.2 | 0.5 | 0.4 | TRUE | =MAXA([Col1],[Col2],[Col3],[Col4],[Col5]) | 这组数据中的最大值。TRUE 值为 1 (1)


MEDIAN

返回给定数字集合的中值。中值是在一组数据中居于中间的数，即在这组数据中，有一半的数据比它大，有一半的数据比它小。

语法

MEDIAN(number1,number2, ...)

Number1, number2, ... 是要计算中值的 1 到 30 个数字。

说明

  • 参数应是数字，或是包含数字的列引用。
  • 如果列引用参数包含文本、逻辑值或为空，则这些值将被忽略；但是，包含零值的参数将计算在内。

  • 如果参数集合中包含偶数个数字，则 MEDIAN 返回位于中间的两个数字的平均值。请参阅示例中的第二个公式。

示例

Col1 | Col2 | Col3 | Col4 | Col5 | Col6 | 公式 | 说明（结果）
1 | 2 | 3 | 4 | 5 | 6 | =MEDIAN([Col1],[Col2],[Col3],[Col4],[Col5]) | 列表中前 5 个数字的中值 (3)
1 | 2 | 3 | 4 | 5 | 6 | =MEDIAN([Col1],[Col2],[Col3],[Col4],[Col5],[Col6]) | 所有数字的中值，即 3 和 4 的平均值 (3.5)


MIN

返回一组值中的最小值。

语法

MIN(number1,number2, ...)

Number1, number2, ... 是要从中查找最小值的 1 到 30 个数字。

说明

  • 可以将参数指定为数字、空参数、逻辑值或数字的文本表达式。如果参数为错误值或不能转换为数字的文本，则将产生错误。
  • 如果参数是列引用，则函数仅使用其中的数字。如果不能忽略逻辑值和文本，请使用 MINA 来代替。
  • 如果参数不包含任何数字，则 MIN 返回 0。

示例

Col1 | Col2 | Col3 | Col4 | Col5 | 公式 | 说明（结果）
10 | 7 | 9 | 27 | 2 | =MIN([Col1],[Col2],[Col3],[Col4],[Col5]) | 这组数据中的最小值 (2)
10 | 7 | 9 | 27 | 2 | =MIN([Col1],[Col2],[Col3],[Col4],[Col5],0) | 这组数据和 0 中的最小值 (0)


MINA

返回参数列表中的最小值。文本和逻辑值（如 TRUE 和 FALSE）也可以和数字一样进行比较。

语法

MINA(value1,value2,...)

Value1, Value2, ... 是要从中查找最小值的 1 到 30 个参数。

说明

  • 可以将参数指定为数字、空参数、逻辑值或数字的文本表达式。如果参数为错误值，将会产生错误。如果计算中不能包含文本或逻辑值，请使用 MIN 函数来代替。
  • 包含 TRUE 的参数作为 1 计算；包含文本或 FALSE 的参数作为 0（零）计算。
  • 如果参数不包含任何值，则 MINA 返回 0。

示例

Col1 | Col2 | Col3 | Col4 | Col5 | 公式 | 说明（结果）
FALSE | 0.2 | 0.5 | 0.4 | 0.8 | =MINA([Col1],[Col2],[Col3],[Col4],[Col5]) | 这组数据中的最小值。FALSE 的值为 0 (0)


MODE

返回在参数列表中出现频率最多的值。与 MEDIAN 一样，MODE 也是一个位置测量函数。

语法

MODE(number1,number2, ...)

Number1, number2, ... 是要计算众数的 1 到 30 个参数。

说明

  • 参数应是数字或包含数字的列引用。
  • 如果列引用参数包含文本、逻辑值或为空，则这些值将被忽略；但是，包含零值的参数将计算在内。
  • 如果数据集合中不包含重复的数据，则 MODE 返回错误值 #N/A。

在一组数值中，众数是出现频率最高的数值，而中数是位于中间的值，平均数是平均后的值，所有这些求中函数都不能单独地完全描绘所有数据。例如，假设数据分布在三个区域中，其中一半分布在一个较小数值区中，另外一半分布在两个较大数值区中。函数 AVERAGE 和函数 MEDIAN 可能会返回位于数据点稀疏处的中间值；而函数 MODE 则会返回位于数据点密集处的较小值。

示例

Col1 | Col2 | Col3 | Col4 | Col5 | Col6 | 公式 | 说明（结果）
5.6 | 4 | 4 | 3 | 2 | 4 | =MODE([Col1], [Col2], [Col3], [Col4], [Col5], [Col6]) | 这组数据中的众数，也即出现频率最多的数 (4)


NEGBINOMDIST

返回负二项式分布。当成功概率为常量 probability_s 时，NEGBINOMDIST 返回在达到 number_s 次成功之前，出现 number_f 次失败的概率。此函数与二项式分布相似，只是它的成功次数固定，试验总数为变量。与二项式分布类似的是，试验次数被假设为自变量。

例如，如果要找 10 个反应敏捷的人，且已知具有这种特征的候选人的概率为 0.3。函数 NEGBINOMDIST 将计算出在找到 10 个合格候选人之前，需要对给定数目的不合格候选人进行面试的概率。

语法

NEGBINOMDIST(number_f,number_s,probability_s)

Number_f 失败的次数。

Number_s 成功的极限次数。

Probability_s 成功的概率。

说明

  • Number_f 和 number_s 都应该 >= 0。
  • Number_f 和 number_s 都将被截尾取整。
  • 如果任一参数为非数字型，则 NEGBINOMDIST 返回错误值 #VALUE!。
  • 如果 probability_s < 0 或 probability > 1，则 NEGBINOMDIST 返回错误值 #NUM!。
  • 负二项式分布的计算公式如下：

    其中：

    x 是 number_f，r 是 number_s，而 p 是 probability_s。

示例

Number_f | Number_s | Probability_s | 公式 | 说明（结果）
10 | 5 | 0.25 | =NEGBINOMDIST([Number_f], [Number_s], [Probability_s]) | 在指定的参数条件下的负二项式分布值 (0.055049)


NORMDIST

返回指定平均值和标准偏差的正态分布。此函数在统计方面应用范围广泛（包括假设检验）。

语法

NORMDIST(x,mean,standard_dev,cumulative)

X 是需要计算其分布的数值。

Mean 是分布的算术平均值。

Standard_dev 是分布的标准偏差。

Cumulative 是一逻辑值，用于确定函数的形式。如果 cumulative 为 TRUE，则 NORMDIST 返回累积分布函数；如果为 FALSE，则返回概率密度函数。

说明

  • 如果 mean 或 standard_dev 为非数字型，则 NORMDIST 返回错误值 #VALUE!。
  • 如果 standard_dev ≤ 0，则 NORMDIST 返回错误值 #NUM!。
  • 如果 mean = 0，standard_dev = 1，且 cumulative = TRUE，则 NORMDIST 返回标准正态分布，即 NORMSDIST。
  • 正态分布密度函数 (cumulative = FALSE) 的计算公式如下：

  • 如果 cumulative = TRUE，则公式为从负无穷大到公式中给定的 X 的积分。

示例

X | Mean | StdDev | 公式 | 说明（结果）
42 | 40 | 1.5 | =NORMDIST([X],[Mean],[StdDev],TRUE) | 在指定的参数条件下的累积分布函数值 (0.908789)
42 | 40 | 1.5 | =NORMDIST([X],[Mean],[StdDev],FALSE) | 在指定的参数条件下的概率密度函数值 (0.10934005)


NORMINV

返回指定平均值和标准偏差的正态累积分布函数的反函数。

语法

NORMINV(probability,mean,standard_dev)

Probability 对应的正态分布的概率值。

Mean 是分布的算术平均值。

Standard_dev 是分布的标准偏差。

说明

  • 如果任一参数为非数字型，则 NORMINV 返回错误值 #VALUE!。
  • 如果 probability < 0 或 probability > 1，则 NORMINV 返回错误值 #NUM!。
  • 如果 standard_dev ≤ 0，则 NORMINV 返回错误值 #NUM!。

  • 如果 mean = 0 且 standard_dev = 1，则 NORMINV 使用标准正态分布（请参阅函数 NORMSINV）。

NORMINV 使用迭代法来计算函数。如果给定一个概率值，则 NORMINV 开始进行迭代，直到计算结果的精度达到 ± 3x10^-7 内。如果经过 100 次迭代后，NORMINV 仍未收敛，则函数返回错误值 #N/A。

示例

Probability | Mean | StdDev | 公式 | 说明（结果）
0.908789 | 40 | 1.5 | =NORMINV([Probability],[Mean],[StdDev]) | 在指定的参数条件下正态累积分布函数的反函数值 (42)


NORMSDIST

返回标准正态累积分布函数，该分布的平均值为 0（零），标准偏差为 1。可以使用此函数代替标准正态曲线面积表。

语法

NORMSDIST(z)

Z 是需要计算其分布的数值。

说明

  • 如果 z 为非数字型，则 NORMSDIST 返回错误值 #VALUE!。
  • 标准正态分布密度函数的计算公式如下：

示例

公式 | 说明（结果）
=NORMSDIST(1.333333) | 1.333333 的正态累积分布函数值 (0.908789)


NORMSINV

返回标准正态累积分布函数的反函数。该分布的平均值为 0，标准偏差为 1。

语法

NORMSINV(probability)

Probability 对应的正态分布的概率值。

说明

  • 如果 probability 为非数字型，则 NORMSINV 返回错误值 #VALUE!。
  • 如果 probability < 0 或 probability > 1，则 NORMSINV 返回错误值 #NUM!。

NORMSINV 使用迭代法来计算函数。如果给定一个概率值，则 NORMSINV 开始迭代，直到计算结果的精度达到 ± 3x10^-7 内。如果经过 100 次迭代后，NORMSINV 仍未收敛，则函数返回错误值 #N/A。

示例

公式 | 说明（结果）
=NORMSINV(0.908789) | 正态分布概率为 0.908789 时，标准正态累积分布函数的反函数值 (1.3333)


POISSON

返回泊松分布。泊松分布通常用于预测一段时间内事件发生的次数，例如一分钟内通过收费站的轿车的数量。

语法

POISSON(x,mean,cumulative)

X 事件数。

Mean 期望值。

Cumulative 为一逻辑值，确定所返回的概率分布形式。如果 cumulative 为 TRUE，则函数 POISSON 返回泊松累积分布概率，即，随机事件发生的次数在 0 到 x 之间（包含 0 和 x）；如果为 FALSE，则返回泊松概率密度函数，即，随机事件发生的次数正好为 x。

说明

  • 如果 x 不是整数，将被截尾取整。
  • 如果 x 或 mean 为非数字型，则 POISSON 返回错误值 #VALUE!。
  • 如果 x ≤ 0，则 POISSON 返回错误值 #NUM!。
  • 如果 mean ≤ 0，则 POISSON 返回错误值 #NUM!。
  • POISSON 的计算公式如下。

    如果 cumulative = FALSE：

    如果 cumulative = TRUE：

示例

X | Mean | 公式 | 说明（结果）
2 | 5 | =POISSON([X],[Mean],TRUE) | 在指定的参数条件下泊松累积分布概率 (0.124652)
2 | 5 | =POISSON([X],[Mean],FALSE) | 在指定的参数条件下泊松概率密度函数 (0.084224)


SKEW

返回分布的偏斜度。偏斜度反映以其平均值为中心的分布的不对称程度。正偏斜度表示不对称部分的分布更趋向正值。负偏斜度表示不对称部分的分布更趋向负值。

语法

SKEW(number1,number2, ...)

Number1,number2... 是需要计算偏斜度的 1 到 30 个参数。

说明

  • 参数必须是数字，或是包含数字的列引用。
  • 如果列引用参数包含文本、逻辑值或为空，则这些值将被忽略；但是，包含零值的参数将计算在内。
  • 如果数据点个数少于 3 个，或样本标准偏差为零，则 SKEW 返回错误值 #DIV/0!。
  • 偏斜度的计算公式定义如下：

示例

D1 | D2 | D3 | D4 | D5 | D6 | D7 | D8 | D9 | D10 | 公式 | 说明（结果）
3 | 4 | 5 | 2 | 3 | 4 | 5 | 6 | 4 | 7 | =SKEW([D1], [D2], [D3], [D4], [D5], [D6], [D7], [D8], [D9], [D10]) | 该数据集分布的偏斜度 (0.359543)


STANDARDIZE

返回以平均值和标准偏差表示的分布的正态化数值。

语法

STANDARDIZE(x,mean,standard_dev)

X 是要进行正态化的数值。

Mean 是分布的算术平均值。

Standard_dev 是分布的标准偏差。

说明

  • 如果 standard_dev ≤ 0，STANDARDIZE 将返回错误值 #NUM!。
  • 正态化数值的计算公式如下：

示例

X | Mean | StdDev | 公式 | 说明（结果）
42 | 40 | 1.5 | =STANDARDIZE([X],[Mean],[StdDev]) | 对于指定的参数，42 的正态化数值 (1.333333)


STDEV

基于样本估算标准偏差。标准偏差反映数值相对于平均值 (mean) 的离散程度。

语法

STDEV(number1,number2,...)

Number1,number2,... 是对应于总体中的样本的 1 到 30 个数字参数。

说明

  • 逻辑值（如 TRUE 和 FALSE）和文本将被忽略。如果不能忽略逻辑值和文本，请使用 STDEVA 函数。
  • STDEV 假设其参数是总体中的样本。如果数据代表整个样本总体，则应使用函数 STDEVP 来计算标准偏差。
  • 此处标准偏差的计算使用“无偏差”或“n-1”方法。
  • STDEV 的计算公式如下：

示例

假设有 10 件工具在制造过程中是由同一台机器制造出来的，并取样为随机样本进行断裂强度测量。

St1 | St2 | St3 | St4 | St5 | St6 | St7 | St8 | St9 | St10 | 公式 | 说明（结果）
1345 | 1301 | 1368 | 1322 | 1310 | 1370 | 1318 | 1350 | 1303 | 1299 | =STDEV([St1], [St2], [St3], [St4], [St5], [St6], [St7], [St8], [St9], [St10]) | 断裂强度的标准偏差 (27.46391572)


STDEVA

基于样本估算标准偏差。标准偏差反映数值相对于平均值 (mean) 的离散程度。文本值和逻辑值（如 TRUE 和 FALSE）也将计算在内。

语法

STDEVA(value1,value2, ...)

Value1,value2, ... 是对应于总体中的样本的 1 到 30 个值。

说明

  • STDEVA 假设其参数是总体中的样本。如果数据代表整个样本总体，则应使用函数 STDEVPA 计算标准偏差
  • 包含 TRUE 的参数作为 1 来计算；包含文本或 FALSE 的参数作为 0（零）来计算。如果在计算中不能包含文本或逻辑值，请使用 STDEV 电子表格函数来代替。
  • 此处标准偏差的计算使用“无偏差”或 n-1 方法。
  • STDEVA 的计算公式如下：

示例

假设有 10 件工具在制造过程中是由同一台机器制造出来的，并取样为随机样本进行断裂强度测量。

St1 | St2 | St3 | St4 | St5 | St6 | St7 | St8 | St9 | St10 | 公式 | 说明（结果）
1345 | 1301 | 1368 | 1322 | 1310 | 1370 | 1318 | 1350 | 1303 | 1299 | =STDEVA([St1], [St2], [St3], [St4], [St5], [St6], [St7], [St8], [St9], [St10]) | 全部工具断裂强度的标准偏差 (27.46391572)


STDEVP

基于以参数形式给出的整个样本总体计算标准偏差。标准偏差反映数值相对于平均值 (mean) 的离散程度。

语法

STDEVP(number1,number2, ...)

Number1,number2, ... 是对应于总体的 1 到 30 个数字参数。

说明

  • 逻辑值（如 TRUE 和 FALSE）和文本将被忽略。如果不能忽略逻辑值和文本，请使用 STDEVPA 电子表格函数。
  • STDEVP 假设其参数为整个样本总体。如果数据代表样本总体中的样本，应使用 STDEV 来计算标准偏差。
  • 对于大样本容量，STDEV 和 STDEVP 的计算结果大致相等。
  • 此处标准偏差的计算使用“有偏差”或 n 方法。
  • STDEVP 的计算公式如下：

示例

St1 | St2 | St3 | St4 | St5 | St6 | St7 | St8 | St9 | St10 | 公式 | 说明（结果）
1345 | 1301 | 1368 | 1322 | 1310 | 1370 | 1318 | 1350 | 1303 | 1299 | =STDEVP([St1], [St2], [St3], [St4], [St5], [St6], [St7], [St8], [St9], [St10]) | 假定只生产了 10 件工具，其断裂强度的标准偏差 (26.05455814)


STDEVPA

基于以参数形式给出的整个样本总体计算标准偏差，文本和逻辑值也计算在内。标准偏差反映数值相对于平均值 (mean) 的离散程度。

语法

STDEVPA(value1,value2, ...)

Value1,value2,... 对应于总体的 1 到 30 个值。

说明

  • STDEVPA 假设其参数即为整个样本总体。如果数据代表的是总体的一个样本，则必须使用 STDEVA 来计算标准偏差。
  • 包含 TRUE 的参数作为 1 计算；包含文本或 FALSE 的参数作为 0（零）计算。如果在计算中不能包含文本或逻辑值，请使用 STDEVP 电子表格函数来代替。
  • 对于大样本容量，STDEVA 和 STDEVPA 的返回值大致相等。
  • 此处标准偏差的计算使用“有偏差”或 n 方法。
  • STDEVPA 的计算公式如下：

示例

St1 | St2 | St3 | St4 | St5 | St6 | St7 | St8 | St9 | St10 | 公式 | 说明（结果）
1345 | 1301 | 1368 | 1322 | 1310 | 1370 | 1318 | 1350 | 1303 | 1299 | =STDEVPA([St1], [St2], [St3], [St4], [St5], [St6], [St7], [St8], [St9], [St10]) | 假定只生产了 10 件工具，其断裂强度的标准偏差 (26.05455814)


TDIST

返回学生 t 分布的百分点（概率），其中数值 (x) 是 t 的计算值（将计算其百分点）。t 分布用于小样本数据集合的假设检验。使用此函数可以代替 t 分布的临界值表。

语法

TDIST(x,degrees_freedom,tails)

X 是需要计算分布的数值。

Degrees_freedom 是一个表示自由度的整数。

Tails 指定返回的分布函数是单尾分布还是双尾分布。如果 tails = 1，则 TDIST 返回单尾分布。如果 tails = 2，则 TDIST 返回双尾分布。

说明

  • 如果任一参数为非数字型，则 TDIST 返回错误值 #VALUE!。
  • 如果 degrees_freedom < 1，则 TDIST 返回错误值 #NUM!。
  • 参数 degrees_freedom 和 tails 将被截尾取整。
  • 如果 tails 不为 1 或 2，则 TDIST 返回错误值 #NUM!。
  • TDIST 的计算公式为 TDIST = p( x<abs(X))，其中 X 为服从 t 分布的随机变量。

示例

X | Degrees | 公式 | 说明（结果）
1.96 | 60 | =TDIST([X],[Degrees],2) | 双尾分布（0.054644927 或 5.46％）
1.96 | 60 | =TDIST([X],[Degrees],1) | 单尾分布（0.027322463 或 2.73％）


TINV

返回作为概率和自由度函数的学生 t 分布的 t 值。

语法

TINV(probability,degrees_freedom)

Probability 是对应于双尾学生 t 分布的概率。

Degrees_freedom 是分布的自由度。

说明

  • 如果任一参数为非数字型，则 TINV 返回错误值 #VALUE!。
  • 如果 probability < 0 或 probability > 1，则 TINV 返回错误值 #NUM!。
  • 如果 degrees_freedom 不是整数，将被截尾取整。
  • 如果 degrees_freedom < 1，则 TINV 返回错误值 #NUM!。
  • TINV 的计算公式为 TINV = p( t<X )，其中 X 为服从 t 分布的随机变量。
  • 单尾 t 值可通过用两倍概率替换概率而求得。如果概率为 0.05 而自由度为 10，则双尾值由 TINV(0.05,10) 计算得到，它返回 2.28139。而同样概率和自由度的单尾值可由 TINV(2*0.05,10) 计算得到，它返回 1.812462。

    注意 在某些表中，概率被描述为 (1-p)。

TINV 使用迭代法来进行计算。如果给定一个概率值，TINV 就开始迭代，直到计算结果精度达到 ± 3x10^-7 内。如果经过 100 次迭代后，TINV 仍未收敛，则函数返回错误值 #N/A。

示例

Probability | Degrees | 公式 | 说明（结果）
0.054645 | 60 | =TINV([Probability],[Degrees]) | 在指定的参数条件下学生 t 分布的 t 值 (1.959997462)


VAR

计算基于样本的方差。

语法

VAR(number1,number2, ...)

Number1,number2, ... 是对应于总体中样本的 1 到 30 个数字参数。

说明

  • VAR 假设其参数是样本总体中的一个样本。如果数据代表整个样本总体，则应使用函数 VARP 来计算方差。
  • 逻辑值（如 TRUE 和 FALSE）和文本将被忽略。如果不能忽略逻辑值和文本，请使用 VARA 函数。
  • VAR 的计算公式如下：

示例

假设有 10 件工具在制造过程中是由同一台机器制造出来的，并取样为随机样本进行断裂强度测量。

St1 | St2 | St3 | St4 | St5 | St6 | St7 | St8 | St9 | St10 | 公式 | 说明（结果）
1345 | 1301 | 1368 | 1322 | 1310 | 1370 | 1318 | 1350 | 1303 | 1299 | =VAR([St1], [St2], [St3], [St4], [St5], [St6], [St7], [St8], [St9], [St10]) | 工具断裂强度的方差 (754.2666667)


VARA

计算基于样本的方差。不仅数字，文本和逻辑值（如 TRUE 和 FALSE）也将计算在内。

语法

VARA(value1,value2, ...)

Value1,value2, ... 是对应于总体中样本的 1 到 30 个参数。

说明

  • VARA 假设参数为总体的一个样本。如果数据代表的是整个样本总体，则必须使用函数 VARPA 来计算方差。
  • 包含 TRUE 的参数作为 1 计算；包含文本或 FALSE 的参数作为 0（零）计算。如果计算中不能包含文本或逻辑值，请使用 VAR 函数代替。
  • VARA 的计算公式如下：

示例

假设有 10 件工具在制造过程中是由同一台机器制造出来的，并取样为随机样本进行断裂强度测量。

St1 | St2 | St3 | St4 | St5 | St6 | St7 | St8 | St9 | St10 | 公式 | 说明（结果）
1345 | 1301 | 1368 | 1322 | 1310 | 1370 | 1318 | 1350 | 1303 | 1299 | =VARA([St1], [St2], [St3], [St4], [St5], [St6], [St7], [St8], [St9], [St10]) | 计算断裂强度的方差 (754.2666667)


VARP

计算基于整个样本总体的方差。

语法

VARP(number1,number2, ...)

Number1,number2, ... 是对应于总体的 1 到 30 个数字参数。

  • 逻辑值（如 TRUE 和 FALSE）和文本将被忽略。如果不能忽略逻辑值和文本，请使用 VARPA 函数。

说明

  • VARP 假设其参数为整个样本总体。如果数据只是代表样本总体中的一个样本，请使用函数 VAR 计算方差。
  • VARP 的计算公式如下：

示例

假设所有 10 件工具在制造过程中都是由同一台机器制造出来的，并取样进行断裂强度测量。

St1 | St2 | St3 | St4 | St5 | St6 | St7 | St8 | St9 | St10 | 公式 | 说明（结果）
1345 | 1301 | 1368 | 1322 | 1310 | 1370 | 1318 | 1350 | 1303 | 1299 | =VARP([St1], [St2], [St3], [St4], [St5], [St6], [St7], [St8], [St9], [St10]) | 全部工具断裂强度的方差（假定只生产了 10 件工具）(678.84)


VARPA

计算基于整个样本总体的方差。不仅数字，文本和逻辑值（如 TRUE 和 FALSE）也将计算在内。

语法

VARPA(value1,value2, ...)

Value1,value2,... 是对应于样本总体的 1 到 30 个参数。

说明

  • VARPA 假设其参数即为样本总体。如果数据代表的是总体的一个样本，则必须使用函数 VARA 计算方差。
  • 包含 TRUE 的参数作为 1 计算；包含文本或 FALSE 的参数作为 0（零）计算。如果计算中不能包含文本或逻辑值，请使用 VARP 代替。
  • VARPA 的计算公式如下：

示例

假设所有 10 件工具在制造过程中都是由同一台机器制造出来的，并取样进行断裂强度测量。

St1 | St2 | St3 | St4 | St5 | St6 | St7 | St8 | St9 | St10 | 公式 | 说明（结果）
1345 | 1301 | 1368 | 1322 | 1310 | 1370 | 1318 | 1350 | 1303 | 1299 | =VARPA([St1], [St2], [St3], [St4], [St5], [St6], [St7], [St8], [St9], [St10]) | 全部工具断裂强度的方差（假定只生产了 10 件工具）(678.84)


WEIBULL

返回韦伯分布。使用此分布可以进行可靠性分析，例如计算设备失效的平均时间。

语法

WEIBULL(x,alpha,beta,cumulative)

X 是用来计算函数的值。

Alpha 分布参数。

Beta 分布参数。

Cumulative 决定函数的形式。

说明

  • 如果 x、alpha 或 beta 为非数字型，则 WEIBULL 返回错误值 #VALUE!。
  • 如果 x < 0，则 WEIBULL 返回错误值 #NUM!。
  • 如果 alpha ≤ 0 或 beta ≤ 0，则 WEIBULL 返回错误值 #NUM!。
  • 韦伯累积分布函数的计算公式如下：

  • 韦伯概率密度函数的计算公式如下：

  • 当 alpha = 1 时，WEIBULL 返回指数分布：

示例

X | Alpha | Beta | 公式 | 说明（结果）
105 | 20 | 100 | =WEIBULL([X],[Alpha],[Beta],TRUE) | 在指定的参数条件下韦伯累积分布函数 (0.929581)
105 | 20 | 100 | =WEIBULL([X],[Alpha],[Beta],FALSE) | 在指定的参数条件下韦伯概率密度函数 (0.035589)


ASC

对于双字节字符集 (DBCS) 语言，将全角（双字节）字符更改为半角（单字节）字符。

语法

ASC(text)

Text 是文本或包含要更改的文本的列引用。如果文本不包含任何全角字母，则文本不会被更改。

示例

=ASC("EXCEL") 等于“EXCEL”

=ASC(" Excel Excel Excel Excel ") 等于“ Excel Excel Excel Excel ”


CHAR

返回由某个数字指定的字符。使用 CHAR 可将从其他类型计算机上的文件中获取的代码页数字转换为字符。

语法

CHAR(number)

Number 是指定所需字符的一个数字，介于 1 和 255 之间。字符是您的计算机使用的字符集中的字符。

示例

公式 | 说明（结果）
=CHAR(65) | 显示字符集中的第 65 个字符 (A)
=CHAR(33) | 显示字符集中的第 33 个字符 (!)


CLEAN

删除文本中所有不能打印的字符。对从其他应用程序导入的文本使用 CLEAN，将删除其中包含的您的操作系统无法打印的字符。例如，可以使用 CLEAN 删除一些通常出现在数据文件开头和结尾处、无法打印的低级计算机代码。

语法

CLEAN(text)

Text 是要从中删除不能打印的字符的任何信息。

示例

Col1 | 公式 | 说明（结果）
CHAR(7)&"text"&CHAR(7) | =CLEAN([Col1]) | 从字符串中删除不能打印的字符 CHAR(7) (text)。


CODE

返回文本字符串中第一个字符的数字代码。返回的代码与您的计算机所用的字符集相对应。

语法

CODE(text)

Text 是文本字符串中需要得到其第一个字符代码的文本。

示例

公式 | 说明（结果）
=CODE("A") | 显示 A 的数字代码 (65)
=CODE("!") | 显示 ! 的数字代码 (33)


CONCATENATE

将多个文本字符串合并为一个文本字符串。

语法

CONCATENATE (text1,text2,...)

Text1, text2, ... 是 1 到 30 个将要合并成单个文本项的文本项。这些文本项可以是文本字符串、数字或列引用。

说明

"&" 运算符可以用来代替 CONCATENATE 实现文本项的合并。

示例

Col1 | Col2 | Col3 | 公式 | 说明
brook trout | species | 32 | =CONCATENATE("Stream population for ",[Col1]," ",[Col2]," is ",[Col3],"/mile") | 将这些数据合并成一个句子 (Stream population for brook trout species is 32/mile)


DOLLAR

使用货币格式将数字转换为文本，并将小数四舍五入到指定的位数。使用的格式为 ($#,##0.00_);($#,##0.00)。

语法

DOLLAR(number,decimals)

Number 是数字、包含数字的列引用或计算结果为数字的公式。

Decimals 是小数点右边的位数。如果 decimals 为负数，则数字向小数点的左边四舍五入。如果省略 decimals，则将使用系统区域设置确定小数位数。

说明

Dollar 函数使用计算机的货币设置。如果希望总是显示美国货币，请使用 USDOLLAR 函数。

示例

Col1 | 公式 | 说明（结果）
1234.567 | =DOLLAR([Col1], 2) | 以货币格式及四舍五入到小数点右边 2 位数字的形式显示第一个数 ($1,234.57)
1234.567 | =DOLLAR([Col1], -2) | 以货币格式及四舍五入到小数点左边 2 位数字的形式显示第一个数 ($1,200)
-1234.567 | =DOLLAR([Col1], -2) | 以货币格式及四舍五入到小数点左边 2 位数字的形式显示第二个数 (($1,200))
-0.123 | =DOLLAR([Col1], 4) | 以货币格式及四舍五入到小数点右边 4 位数字的形式显示第三个数 (($0.1230))
99.888 | =DOLLAR([Col1]) | 以货币格式及四舍五入到小数点右边 2 位数字的形式显示第四个数 ($99.89)


EXACT

比较两个文本字符串，如果它们完全相同，则返回 TRUE，否则返回 FALSE。EXACT 是区分大小写的。EXACT 可用于测试输入到文档中的文本。

语法

EXACT(text1,text2)

Text1 待比较的第一个文本字符串。

Text2 待比较的第二个文本字符串。

示例

Col1 | Col2 | 公式 | 说明（结果）
word | word | =EXACT([Col1],[Col2]) | 检查字符串是否相同 (TRUE)
Word | word | =EXACT([Col1],[Col2] | 检查字符串是否相同 (FALSE)
w ord | word | =EXACT([Col1],[Col2]) | 检查字符串是否相同 (FALSE)


FIND

FIND 用于在一个文本字符串 (within_text) 内查找另一个文本字符串 (find_text)，并从 within_text 的首字符开始，返回 find_text 的起始位置的编号。也可使用 SEARCH 在一个文本字符串内查找另一个文本字符串，但是，FIND 和 SEARCH 不同，FIND 区分大小写并且不允许使用通配符。

语法

FIND(find_text,within_text,start_num)

Find_text 是要查找的文本。

Within_text 是包含要查找文本的文本。

Start_num 指定要从其开始搜索的字符。within_text 中的首字符是编号为 1 的字符。如果省略 start_num，则假设其值为 1。

显示 提示

使用 start_num 可跳过指定编号的字符。例如，假设要处理文本字符串“AYF0093.YoungMensApparel”。若要在文本字符串的说明部分中查找第一个“Y”的编号，请将 start_num 设置为 8，这样就不会搜索文本的序列号部分。函数 FIND 从第 8 个字符开始，在下一个字符处查找 find_text，并返回数字 9。FIND 总是返回从 within_text 的起始位置计算的字符的编号，如果 start_num 大于 1，则会计算跳过的字符。

说明

  • 如果 find_text 为空文本 ("")，则 FIND 会匹配搜索字符串中的首字符（即编号为 start_num 或 1 的字符）。
  • Find_text 不能包含任何通配符。
  • 如果 within_text 中没有 find_text，则 FIND 返回错误值 #VALUE!。
  • 如果 start_num 不大于零，则 FIND 返回错误值 #VALUE!。
  • 如果 start_num 大于 within_text 的长度，则 FIND 返回错误值 #VALUE!。

示例 1

公式 | 说明（结果）
=FIND("M","Miriam McGovern") | 字符串中第一个“M”的位置 (1)
=FIND("m","Miriam McGovern") | 字符串中第一个“m”的位置 (6)
=FIND("M","Miriam McGovern",3) | 从第三个字符开始查找的字符串中第一个“M”的位置 (8)

示例 2

Col1 | 公式 | 说明（结果）
Ceramic Insulators #124-TD45-87 | =MID([Col1],1,FIND(" #",[Col1],1)-1) | 提取字符串中从第一个位置到“#”的文本 (Ceramic Insulators)
Copper Coils #12-671-6772 | =MID([Col1],1,FIND(" #",[Col1],1)-1) | 提取字符串中从第一个位置到“#”的文本 (Copper Coils)
Variable Resistors #116010 | =MID([Col1],1,FIND(" #",[Col1],1)-1) | 提取字符串中从第一个位置到“#”的文本 (Variable Resistors)


FIXED

将数字舍入到指定的小数位数，使用句点和逗号，以十进制数格式对该数进行格式设置，并以文本形式返回结果。

语法

FIXED(number,decimals,no_commas)

Number 要进行舍入并转换为文本的数字。

Decimals 小数点右边的位数。

No_commas 是一个逻辑值，如果为 TRUE，则会禁止 FIXED 在返回的文本中包含逗号。

说明

  • 如果 decimals 为负数，则数字向小数点的左边四舍五入。
  • 如果省略 decimals，则将使用系统区域设置确定小数位数。
  • 如果 no_commas 为 FALSE 或省略，则返回的文本会像通常一样包含逗号。

示例

公式 | 说明（结果）
=FIXED(1234.567, 1) | 将第一个数字四舍五入到小数点右侧 1 位 (1,234.6)
=FIXED(1234.567, -1) | 将第一个数字四舍五入到小数点左侧 1 位 (1,230)
=FIXED(-1234.567, -1, TRUE) | 将第二个数字四舍五入到小数点左侧 1 位，不使用逗号 (-1230)
=FIXED(44.332) | 将第三个数字四舍五入到小数点右侧 2 位 (44.33)


LEFT

根据所指定的字符数，LEFT 返回文本字符串中第一个字符或前几个字符。

语法

LEFT(text,num_chars)

Text 是包含要提取字符的文本字符串。

Num_chars 指定要由 LEFT 提取的字符的数量。

  • Num_chars 必须大于或等于零。

  • 如果 num_chars 大于文本长度，则 LEFT 返回全部文本。

  • 如果省略 num_chars，则假设其值为 1。

示例

Col1 | 公式 | 说明（结果）
Sale Price | =LEFT([Col1],4) | 字符串中的前四个字符 (Sale)
Sweden | =LEFT([Col1]) | 字符串中的第一个字符 (S)


LEN

LEN 返回文本字符串中的字符数。

语法

LEN(text)

Text 是要查找其长度的文本。空格将作为字符进行计数。

示例

Col1 | 公式 | 说明（结果）
Phoenix, AZ | =LEN([Col1]) | 字符串的长度 (11)
 | =LEN([Col1]) | 字符串的长度 (0)
A One | =LEN([Col1]) | 字符串（包含 5 个空格）的长度 (5)


LOWER

将文本字符串中的所有大写字母转换为小写字母。

语法

LOWER(text)

Text 是要转换为小写字母的文本。LOWER 不会更改文本中的非字母字符。

示例

Col1 | 公式 | 说明（结果）
E. E. Cummings | =LOWER([Col1]) | 将字符串转换为小写 (e. e. cummings)
Apt. 2B | =LOWER([Col1]) | 将字符串转换为小写 (apt. 2b)


MID

MID 返回文本字符串中从指定位置开始的特定数目的字符，该数目由用户指定。

语法

MID(text,start_num,num_chars)

Text 是包含要提取字符的文本字符串。

Start_num 是要在文本中提取的第一个字符的位置。文本中第一个字符的 start_num 为 1，以此类推。

Num_chars 指定希望 MID 从文本中返回字符的个数。

说明

  • 如果 start_num 大于文本长度，则 MID 会返回空文本 ("")。
  • 如果 start_num 小于文本长度，但 start_num 加上 num_chars 超过了文本长度，则 MID 返回最多到文本结尾的字符。
  • 如果 start_num 小于 1，则 MID 返回错误值 #VALUE!。

  • 如果 num_chars 为负数，则 MID 返回错误值 #VALUE!。

示例

公式 | 说明（结果）
=MID("Fluid Flow",1,5) | 从第一个字符开始，返回字符串中五个字符 (Fluid)
=MID("Fluid Flow",7,20) | 从第七个字符开始，返回字符串中 20 个字符 (Flow)
=MID("Fluid Flow",20,5) | 因为要提取的第一个字符的位置大于字符串的长度，所以返回空文本 ()


NULL

返回值 #NULL!。使用 NULL 函数在计算列中指示空值。

使用 NULL，您可以避免无意中在计算中包括空值。当公式引用包含 #NULL! 的单元格时，该公式会返回 #NULL!。

语法

NULL()

备注

NULL 函数语法没有参数。函数名后面必须包括一对空的圆括号。否则，Microsoft SharePoint Foundation 2010 不会将其识别为函数。


NZ

检查值是否为 #NULL!。如果参数的计算结果为 TRUE，则此函数将返回替代值，否则将返回该值。

语法

NZ(value, alternate)

参数 | 说明
value | 可以是列引用。如果 value 为 #NULL!，则此函数将返回 alternate 中的值。否则，将返回 value。
alternate | 可以是数字、文本或列引用。如果 value 为 #NULL!，则返回 alternate 中的值。

示例

Col1 | Col2 | 公式 | 说明（结果）
#NULL! | 200 | =NZ([Col 1],[Col2]) | 检查 Col1 中的值是否为 #NULL! 错误值并返回替代值 (200)。
400 | 450 | =NZ([Col 1],[Col2]) | 检查 Col1 中的值是否为 #NULL! 错误值并返回替代值 (400)。


PROPER

将文本字符串的首字母及任何非字母字符之后的首字母转换成大写。将文本字符串中的其余字母转换成小写。

语法

PROPER(text)

Text 用引号括起来的文本、返回文本的公式或是对包含要进行部分大写转换的文本的列引用。

示例

公式 | 说明（结果）
=PROPER("this is a TITLE") | 字符串的转换 (This Is A Title)
=PROPER("2-cent's worth") | 字符串的转换 (2-Cent'S Worth)
=PROPER("76BudGet") | 字符串的转换 (76Budget)


REPLACE

REPLACE 使用其他文本字符串并根据所指定的字符数替换某文本字符串中的部分文本。

语法

REPLACE(old_text,start_num,num_chars,new_text)

Old_text 是要替换其部分字符的文本。

Start_num 是要用 new_text 替换的 old_text 中字符的位置。

Num_chars 是希望 REPLACE 使用 new_text 替换 old_text 中字符的个数。

New_text 是要用于替换 old_text 中字符的文本。

示例

公式 | 说明（结果）
=REPLACE("abcdefghijk",6,5,"*") | 从第六个字符开始替换五个字符 (abcde*k)
=REPLACE("2009",3,2,"10") | 用 10 替换 2009 的最后两位 (2010)
=REPLACE("123456",1,3,"@") | 用 @ 替换前三个字符 (@456)


REPT

按照给定的次数重复显示文本。可以使用函数 REPT 来不断地重复添加某一文本字符串。

语法

REPT(text,number_times)

Text 需要重复显示的文本。

Number_times 指定文本重复次数的一个正数。

说明

  • 如果 number_times 为 0（零），则 REPT 返回空文本 ("")。

  • 如果 number_times 不是整数，则将被截尾取整。

  • REPT 函数的结果不能大于 2000 个字符，否则 REPT 返回错误值 #VALUE!。

示例

公式 | 说明（结果）
=REPT("*-", 3) | 该字符串显示 3 次 (*-*-*-)
=REPT("-",10) | 短划线显示 10 次 (----------)


RIGHT

RIGHT 根据所指定的字符数返回文本字符串中最后一个或多个字符。

语法

RIGHT(text,num_chars)

Text 是包含要提取字符的文本字符串。

Num_chars 指定希望 RIGHT 提取的字符数。

说明

  • Num_chars 必须大于或等于零。
  • 如果 num_chars 大于文本长度，则 RIGHT 返回所有文本。
  • 如果省略 num_chars，则假设其值为 1。

示例

公式 | 说明（结果）
=RIGHT("Sale Price",5) | 字符串的最后 5 个字符 (Price)
=RIGHT("Stock Number") | 字符串的最后一个字符 (r)


SEARCH

SEARCH 返回从 start_num 开始首次找到特定字符或文本字符串的位置上的字符的编号。使用 SEARCH 可确定字符或文本字符串在其他文本字符串中的位置，这样就可使用 MID 或 REPLACE 函数更改文本。

语法

SEARCH(find_text,within_text,start_num)

Find_text 是要查找的文本。可以在 find_text 中使用通配符，包括问号 (?) 和星号 (*)。问号可匹配任意的单个字符，星号可匹配任意一串字符。如果要查找真正的问号或星号，请在该字符前键入一个波形符 (~)。

Within_text 是要在其中搜索 find_text 的文本。

Start_num 是 within_text 中从之开始搜索的字符编号。

显示 提示

使用 start_num 可跳过指定数目的字符。例如，假设使用文本字符串“AYF0093.YoungMensApparel”，若要查找文本字符串中说明部分的第一个 Y 的编号，则可将 start_num 设置为 8，这样就不会查找文本的序列号部分。SEARCH 将从第 8 个字符开始查找，而在下一个字符处即可找到 find_text，于是返回编号 9。SEARCH 总是从 within_text 的起始处返回字符编号，如果 start_num 大于 1，也会对跳过的字符进行计数。

说明

  • SEARCH 在搜索文本时不区分大小写。
  • SEARCH 与 FIND 类似，但 FIND 区分大小写。
  • 如果找不到 find_text，则返回错误值 #VALUE!。
  • 如果省略 start_num，则假设其值为 1。
  • 如果 start_num 不大于 0（零）或大于 within_text 的长度，则返回错误值 #VALUE!。

示例

Col1 | Col2 | Col3 | 公式 | 说明（结果）
Statements | Profit Margin | margin | =SEARCH("e",[Col1],6) | 从第六个位置开始，字符串中第一个“e”的位置 (7)
Statements | Profit Margin | margin | =SEARCH([Col2],[Col3]) | “margin”在“Profit Margin”中的位置 (8)
Statements | Profit Margin | margin | =REPLACE([Col3],SEARCH([Col3],[Col2]),6,"Amount") | 用“Amount”替换“Margin”(Profit Amount)


T

返回值引用的文本。

语法

T(value)

Value 是要进行检验的值。

说明

  • 如果值是文本或引用了文本，T 将返回值。如果值未引用文本，T 将返回空文本 ("")。

  • 通常在公式中不需要使用 T 函数，因为值会根据需要进行转换。

示例

公式 | 说明（结果）
=T("Rainfall") | 因为值是文本，所以返回文本 (Rainfall)
=T(19) | 因为值是数字，所以返回空文本 ()
=T(TRUE) | 因为值是逻辑值，所以返回空文本 ()


TEXT

将数值转换为按指定数字格式表示的文本。

语法

TEXT(value,format_text)

Value 数值、计算结果为数值的公式或包含数值的列引用。

Format_text 以文本格式表示的数字格式。

说明

  • 使用 TEXT 函数可以将数值转换为带格式的文本，而其结果将不再作为数字参与计算。

示例

Salesperson | Sales | 公式 | 说明（结果）
Buchanan | 2800 | =[Salesperson]&" sold "&TEXT([Sales], "$0.00;($0.00)")&" worth of units." | 将所示内容合并为一个短语 (Buchanan sold $2,800.00 worth of units)。
Dodsworth | .4 | =[Salesperson]&" sold "&TEXT([Sales],"0.00%")&" of the total sales." | 将所示内容合并为一个短语 (Dodsworth sold 40.00% of the total sales)。


TRIM

删除文本中的所有空格（除了单词之间的单个空格外）。对于从其他应用程序中获取带有不规则空格的文本，可以使用 TRIM。

语法

TRIM(text)

Text 是要从中删除空格的文本。

示例

公式 | 说明（结果）
=TRIM(" First Quarter Earnings ") | 删除公式中文本的前导空格和尾部空格 (First Quarter Earnings)


TRIMENDS

删除前导和尾部空格，如文本前后的空白和不间断空格。您可以对其他应用程序提供的文本字符串以及前后有额外空格的文本字符串使用 TRIMENDS。

注意 TRIMENDS 可保留文本字符串内的间距。若要更改文本字符串内的间距，请使用 TRIM 函数。有关详细信息，请参阅有关 TRIM 函数的帮助主题。

语法

TRIMENDS(text)

Text 要从中删除空格的字符串。

示例

公式 | 说明（结果）
=TRIMENDS (“ Record sales ”) | 删除公式中文本的前导和尾部空格 (Record sales)


UPPER

将文本转换成大写形式。

语法

UPPER(text)

Text 是需要转换为大写形式的文本。文本可以是列引用或文本字符串。

示例

公式 | 说明（结果）
=UPPER("total") | 字符串的大写形式 (TOTAL)
=UPPER("Yield") | 字符串的大写形式 (YIELD)


USDOLLAR

使用货币格式将数字转换为文本，并将小数四舍五入到指定的位数。使用的格式为 ($#,##0.00_);($#,##0.00)。

语法

USDOLLAR(number,decimals)

Number 可以是数字、包含数字的列引用或计算结果为数字的公式。

Decimals 是小数点右边的位数。如果 decimals 为负数，则数字向小数点的左边四舍五入。如果省略 decimals，则将使用系统区域设置确定小数位数。

说明

USDOLLAR 函数始终显示美国货币格式。如果希望显示您的计算机的货币设置，请使用 DOLLAR 函数代替。

示例

Col1 | 公式 | 说明（结果）
1234.567 | =USDOLLAR([Col1], 2) | 以货币格式及四舍五入到小数点右边 2 位数字的形式显示第一个数 ($1,234.57)
1234.567 | =USDOLLAR([Col1], -2) | 以货币格式及四舍五入到小数点左边 2 位数字的形式显示第一个数 ($1,200)
-1234.567 | =USDOLLAR([Col1], -2) | 以货币格式及四舍五入到小数点左边 2 位数字的形式显示第二个数 (($1,200))
-0.123 | =USDOLLAR([Col1], 4) | 以货币格式及四舍五入到小数点右边 4 位数字的形式显示第三个数 (($0.1230))
99.888 | =USDOLLAR([Col1]) | 以货币格式及四舍五入到小数点右边 2 位数字的形式显示第四个数 ($99.89)


VALUE

将代表数字的文本字符串转换为数字。

语法

VALUE(text)

Text 是用引号括起来的文本或包含需要进行文本转换的列引用。

说明

  • 文本可以是任何常数、日期或时间格式。如果文本不是这些格式，则 VALUE 返回错误值 #VALUE!。

示例

公式 | 说明（结果）
=VALUE("$1,000") | 字符串的等价数字 (1000)
=VALUE("16:48:00")-VALUE("12:00:00") | 与 4 小时 48 分钟（由 "16:48:00"-"12:00:00" 得到）等价的序列数（0.2 或 4:48）


关于改善 Access Web Datasheet 的性能

“数据表”视图的性能取决于许多因素，如列表的大小、服务器的性能和配置以及网络条件。本主题列出一些用于改善视图性能的指导原则。

完成下列操作可能会花费一些时间，因此请尽量减少下列操作：

  • 刷新包含大量数据的视图。
  • 移动或复制大批数据。
  • 通过拖动填充柄填充大量单元格。
  • 更改计算列中的公式。
  • 附加大文档。
  • 从 Microsoft Excel 2010 导出数据并链接到该程序。
  • 解决大量错误。

可执行下列操作以改善视图的性能：

  • 删除视图中不必要的列。在“编辑数据表视图”页面中，对于视图中不必要的列，清除“显示”复选框。但不要删除标记为“必需”的列。如果视图没有包含所有必需的列，将无法添加数据。
  • 应用一个或多个筛选以删除不必要的行。例如，可编辑 Managers 视图定义以包含一个筛选，该筛选可隐藏不是经理的雇员行。

    除了应用已保存的筛选之外，还可在会话期间应用筛选以进一步减少视图中的数据量。例如，如果当前要更新华盛顿州的经理行，则可隐藏其他州的经理行。

  • 配置 SharePoint 服务器以改善性能。有关改善服务器性能的详细信息，请参阅 Microsoft SharePoint Foundation 2010 帮助。若要显示 Microsoft SharePoint Foundation 2010 帮助，请单击“帮助”( 帮助图标)。


消息显示“列表结构已经更改”

当两个用户同时更改列表结构时，首先提交更改的用户可以成功提交其所做的更改，而第二个用户将收到一个有关列表结构已经更改的通知。

下表总结了在哪些情况下会收到有关列表结构已经更改的通知。

用户 A | 用户 B
删除某一列 | 更新同一列中的数据
更改列中的数据类型 | 添加或更新类型不匹配的数据
添加、重命名或删除某一列，更改某一列的数据类型或其他属性 | 编辑计算列
进行列表级更改，例如重命名列表、更改列表的说明或安全设置、对列进行重新排列、启用或禁用附件，或将列表添加到“快速启动”栏 | 编辑计算列
编辑计算列 | 添加、重命名或删除某一列，更改某一列的数据类型或其他属性 注意 在用户 A 开始编辑计算列之前，用户 B 必须位于“添加列”或“更改列”页中。
编辑计算列 | 进行列表级更改，例如重命名列表、更改列表的说明或安全设置、对列进行重新排列、启用或禁用附件，或将列表添加到“快速启动”栏 注意 在用户 A 开始编辑计算列之前，用户 B 必须在“列表设置”页上。

通过刷新列表可以解决结构性冲突。刷新列表时，将放弃所做的更改，同时使用最新版本的列表更新视图。刷新列表之后，只需重复所做的更改。


消息显示“停止提交更改”

您正试图在刷新、导航出列表或对计算列进行更改之前停止向服务器提交更改的过程。可执行下列操作之一：

  • 单击“是”，停止列表向服务器提交更改。这将丢失服务器尚未保存的更改，并且不能解决已经提交到服务器的更改所产生的冲突或错误。
  • 单击“否”，继续提交更改。您将能够解决所产生的冲突和错误，并可将所做的更改重新发送到服务器。


消息显示“提交待定的更改”

该列表试图在继续执行刷新、导航出列表或编辑计算列等请求之前将更改提交到服务器。可执行下列操作之一：

  • 等候，直至所有更改都已提交到服务器。这将允许您解决冲突和错误，并将更改重新发送到服务器（如果需要）。
  • 通过单击“取消”放弃所做的更改。如果单击“取消”，系统将请求您确认是否想要停止向服务器发送数据。如果单击“是”，将丢失服务器尚未保存的更改，并且不能解决已经提交到服务器的更改所产生的冲突或错误。


消息显示“目前存在待定的更改、或未解决的冲突和错误”。

您正试图刷新、离开列表，或对计算列进行更改。对列表所做的一些更改尚未提交到服务器。

可执行下列操作之一：

  • 单击“是”等待更改发送到服务器。如果任何冲突或错误是由于向服务器提交更改而产生的，则您将能够解决所产生的冲突和错误，然后再尝试将更改发送到服务器。
  • 单击“否”将立即继续进行上一个操作。这将丢失尚未提交到服务器的部分或全部更改，并且不能解决已经提交到服务器的更改所产生的冲突或错误。


状态栏显示“待定更改”

对列表中的内容进行编辑时，无需等候前面的更改提交到服务器即可进行其他更改。在更改数据的同时，该列表在后台继续向服务器提交所做的更改。如果批量编辑若干个单元格，例如通过拖动填充柄来填充一列的若干行，列表可能需要几秒钟时间将所有更改发送到服务器，此时它就会在状态栏中显示“待定更改”链接。

显示此链接并不是说需要在前面的更改提交之后再添加或编辑数据。但是，如果您试图编辑计算列中的公式、刷新或关闭视图，则会出现一条消息，要求您等候所做的更改提交到服务器之后再进行其他操作。


状态栏显示“只读”或“此视图为只读”

所选单元格、列、行或整个视图为只读状态。不能对标记为只读的单元格、列或行进行编辑。如果整个视图都为只读，则不能编辑视图的任何部分。

由于下列一种或多种原因，部分视图或整个视图可能为只读状态：

  • 有些列（如“创建者”和“修改时间”）始终为只读状态。这些列中的值是自动输入的。
  • 对所选的行或列所做的更改已经提交到服务器。如果没有任何冲突或错误，则可在保存更改之后对行或列进行编辑。
  • 如果所选行或列中存在未解决的冲突或错误，请在编辑所选行或列之前解决这些冲突或错误。
  • 需要内容审批的列表已设置完毕，您正在“所有项目”视图中查看该列表。
  • 在需要内容审批的列表的“我的提交”视图中，“审批状态”和“备注”列为只读状态。只有具有“审批者”权限的用户才可编辑这两个列。
  • 需要内容审批的列表中的附件为只读状态。在任何视图中也无法查看或编辑附件。
  • 当前行中的文档已被用户签出。在用户签入文档之前，不能编辑行中的列。
  • 您没有编辑列或行的权限。有关详细信息，请与该列表的作者联系。


状态栏显示“正在搜索数据”

列表以每次若干行分批检索数据。它正在试图获取下一批数据。如果服务器正忙，该操作可能需要花费一些时间。

如果服务器在检索数据时遇到问题，将出现一条消息。在这种情况下，请关闭列表，稍后再试。


关于国际语言支持

Microsoft SharePoint Foundation 2010 帮助中介绍了有关对列表的国际语言支持的详细信息。

若要显示 Microsoft SharePoint Foundation 2010 帮助，请单击“帮助”( 帮助图标)。


重组确定的字符串

注意 仅当在操作系统上或通过 Microsoft Office 语言设置启用支持日语、简体中文或繁体中文的输入法编辑器时，此命令才可用。

可以重组已经输入并转换过的字符串。

  1. 将插入点置于要重组的字符的开始或中间位置。
  2. 右键单击该单元格，再单击快捷菜单上的“汉字重组”。
  3. 单击所需的字符，再按两次 Enter。