Microsoft 条形码控件

条形码符号 属性 方法

Microsoft 条形码控件可插入至 Microsoft Office Access 窗体或报表以 Active-X 控件显示条形码符号。

档案名称

msbcode9.ocx

说明

条形码控件所支持的属性可控制一般常用的各种条形码符号的外观。设定后的数据与版本信息，亦可用所支持的方法来更新条形码符号。而且可以通过 Access 等具有数据链接功能的应用程序与数据来源自动链接而产生相对应的条形码符号。条形码控件与 OLE 服务器应用程序不同之处，在于无法只储存图片。


条形码控件的属性

条形码控件的属性举例如下。

属性 | 说明
Style | [Style] 指定条形码符号的样式。
SubStyle | [SubStyle] 指定更详细的样式。
Validation | [Validation] 指定是否要验证数据的有效性。
LineWeight | [LineWeight] 指定条形码符号的线条粗细。
Direction | [Direction] 指定条形码控件的显示方向。
ShowData | [ShowData] 指定是否要显示数据数值。
ForeColor | 指定条形码符号的前景颜色。
BackColor | 指定条形码符号的背景色。
Value | 指定所产生的条形码符号的值。

以上这些有关条形码控件属性的应用方式，请参阅各个属性的主题。


BackColor 属性

指定条形码控件的背景色。 BackColor 属性可以从自订属性表的（色彩）标签里选用颜色，或者从 Access 的属性表内输入代表 RGB 颜色的数值。

注意 如果与 ForeColor 属性指定的颜色所形成的对比度不够强烈的话，可能会有无法匹配条形码扫描仪规格的问题。


Direction 属性（方向列表框）

指定条形码符号的显示方向

Direction 属性设置

Direction（方向） | 说明
0 - 无 | 以标准方向(0 度)显示条形码符号。
1 - 90度 | 从标准方向旋转 90 度的位置显示条形码符号。
2 - 180度 | 从标准方向旋转 180 度的位置显示条形码符号。
3 - 270度 | 从标准方向旋转 270 度的位置显示条形码符号。


ForeColor 属性

指定条形码控件的前景颜色。 ForeColor 属性可以从自订属性表的（色彩）标签里选用颜色，或者从 Access 的属性表内输入代表 RGB 颜色的数值。

注意 如果与 BackColor 属性指定的颜色所形成的对比度不够强烈的话，可能会有无法匹配条形码扫描仪规格的问题。


LineWeight 属性（线条粗细列表框）

指定条形码符号的线条粗细。

印刷时的线条粗细会依所使用的印表机或纸张的种类不同而有所差异。如果印刷出来的条纹太粗的话，请选用较细的线条。反之，如果行印出来的条纹太细的话，请选用较粗的线条。

几乎所有的条形码都设有足够的误差容许值。请在确认实际用条形码扫描仪所印刷出来的条形码后，调节线条的粗细。

可调整的线条粗细范围是以 0.02 毫米为单位来调整。 但是，Post 条形码的话，除了条形码的特性，就是印表机的最小像素单位。 最小像素单位依打印机支持的 DPI 大小而有所不同。

LineWeight 属性设置

LineWeight（线条粗细） | 说明
0 - 特细线 | 以最细的线条产生条形码符号。
1 - 细线 |
2 - 中细线 |
3 - 标准 | 以标准粗细的线条产生条形码符号。
4 - 中粗线 |
5 - 粗线 |
6 - 特粗线 |
7 - 超特粗线 | 以最粗的线条产生条形码符号。


ShowData 属性 (显示数据复选框)

指定是否要与条形码符号一起显示数据数值。

若要显示数据数值，请选取复选框。


Style 属性

目前所使用的条形码有很多种，Microsoft 条形码控件可以产生一般较常用的 11 种条形码符号。

请依条形码的目的或所使用的条形码扫描仪来选择样式。

Style（样式） | 说明
0 - UPC-A | 广泛应用于标识货物的 POS 符号（美国与加拿大）。
1 - UPC-E | UPC 的简短版。使用于无法印刷标准版的小型货物。
2 - JAN-13 | 日本规格的 POS 符号与国际规格 EAN-13 POS 符号相同。可应用于包括书籍及杂志在内的所有货物。
3 - JAN-8 | JAN 或 EAN 的简短版。使用于无法印刷标准版的小型货物。
4 - Casecode | 制造商或批发商在将货物出货至零售店时，标识于包装箱外部的符号。
5 - NW-7 | 表示出英文数字和字母的条形码符号。标识于电脑机器等特殊货物的包装上。
6 - Code-39 | 表示出英文数字和字母的条形码符号。自 FA（Factory Automation ，工厂自动化）起，被广泛地应用在工业上。
7 - Code-128 | 将全部 ASCII 的 128 个字节编码的条形码控件。 也有简短版。
8 - US Postnet | 为了自动化处理而标识于邮件上的条形码符号（美国）。
9 - US Postal FIM | 为了自动化处理而标识于邮件上的特殊条形码符号（美国）。
10 - JP Post | 为了自动化处理而标识于邮件上的条形码符号（日本）。


Substyle 属性（子样式列表框）

选好条形码符号的样式之后，接着指定子样式。“子样式”列表框中所行出的子样式会依所使用的条形码样式而有所不同。也有些条形码样式没有子样式。

POS 条形码的子样式

Casecode 条形码的子样式

Postal 条形码的子样式


Validation 属性（校验列表框）

为了防止读取错误，有些条形码除了自我检查的功能之外，还设有校验位（将条形码符号的值加以统计所得的结果就是校验位）。

以条形码扫描仪读取条形码符号，将所读入的字节再次进行同样的统计。

如果读入正确的话，则新的计算结果与条形码所记录的校验位将会相等。

如果读入有误的话，则新的计算结果与条形码所记录的校验位将不一致。

Validation 属性在于指定是否要验证数据的有效性。 Validation 属性的设定值依条形码符号的样式而有所不同。

POS 条形码的 Validation 属性设定值

Validation（校验） | 说明
0 - 无校验 | 始终就对应数据产生条形码符号。 选用（无校验）的话，有可能会产生出扫描仪无法读入的条形码符号。 注意 如果数据内不含校验位的话，则正确值会被加入数据内。
1 - 调整，如果无效 | 计算符号的校验位，如果数据无效的话，则以正确值加以替换的内容。 注意 如果数据内不含校验位的话，则正确值会被加入数据内。
2 - 空格，如果无效 | 只有在数据的位数正确，而且校验位的值也相等的情况下才产生条形码符号。

NW-7 以及 Code-39 条形码的 Validation 属性设定值

Validation（校验） | 说明
0 - 无校验 | 仅对应数据产生条形码符号。
1 - 附加开始／结束位 | 如果没有开始／结束位的话，则 NW-7 条形码用“a”、Code-39 条形码用“*”各加在其前后。

US Postnet 条形码的 Validation 属性设定值

Validation（校验） | 说明
0 - 空格，如果无效 | 只有在数据有效的情况下才产生条形码符号。 注意 始终对数据进行校验，就不会产生无效的条形码符号。

Post 条形码的 Validation 属性设置

Validation（校验） | 说明
0 - 空格，如果无效 | 只有在数据有效的情况下才产生条形码符号。若有最初的 7 位数字，则判断数据为有效。 注意 始终对数据进行校验，就不会产生无效的条形码符号。


Value 属性

Value 属性是实际上用以指定产生条形码符号的值。此属性请在 Microsoft Office Access 的属性表里设置。随着 Style 属性所指定的条形码样式的不同，可设定的值也会有所不同。


条形码控件的方法

条形码控件的方法举例如下。

方法 | 说明
AboutBox | 显示版本与版权信息
Refresh | 更新条形码符号

以上有关条形码控件方法的应用方式，请参阅各个方法的主题。


AboutBox 方法

显示有记载版本和版权等与条形码控件相关信息的对话框。请在 Access 的属性表里单击“关于”属性方框，然后再单击方框右边的“生成器”按钮，就会显示出版本信息的对话框。


Refresh 方法

重画条形码控件。


UPC-A 条形码符号

在美国与加拿大主要用于标识货物的 POS 符号。

UPC-A 符号的规格，除了版面配置上多少有些不同以外，几乎和 JAN-13 的规格完全相同。

每组编码都是由 6 位数的货物制造厂商码、 5 位数的货物项目码，再加上校验位所构成的。

符号
标准
2 位 (ISSN)补充码
（用于杂志）
5 位 (ISBN) 补充码
（用于书籍）
POS Casecode 符号
（加上 Casecode 符号）


UPC-E 条形码符号

UPC POS 符号的简短版（用于美国与加拿大）。用于无法标识出标准版条形码符号的小型货物上。

每组编码都是由若干个系统位元（非 0 不可）、 3 位数的货物码、 3 位数的货物项目码，再加上校验位所构成的。

由于每项编码的的位数都不多，使用这种条形码符号则可分类的制造厂商与项目的数量就会有限。

符号
标准
2 位 (ISSN) 补充码
（用于杂志）
5 位 (ISBN) 补充码
（用于书籍）
POS Casecode 符号
（加上 Casecode 符号）


JAN-13 条形码符号

国际规格的 POS 符号。包括书籍和杂志在内，可以用于所有的货物。

JAN-13 条形码一般是由 2 位数的国码、 5 位数的货物码、 5 位数的货物项目码，再加上校验位所构成的。

符号
标准
2 位 (ISSN) 补充码
（用于杂志）
5 位 (ISBN) 补充码
（用于书籍）
POS Casecode
（加上 Casecode 符号）


JAN-8 条形码符号

国际规格 JAN POS 符号的简短版。用于无法标识出标准版条形码符号的小型货物上。

JAN-8 条形码通常是由 2 位数的国码、 4 位数的货物码、 1 位数的货物项目码，再加上校验位所构成的。

由于每项编码的的位数都不多，使用这种条形码符号则可分类的制造厂商与项目的数量就会有限。

符号
标准
2 位 (ISSN)补充码
（用于杂志）
5 位 (ISBN)补充码
（用于书籍）
POS Casecode
（加上 Casecode 符号）


Casecode 条形码符号

制造商或批发商在将货物出货至零售店时，印刷在包装箱外部的符号。

通常是使用 13 位数或者是 15 位数的符号。如果 13 位数的最初始值或 15 位数的第 2 位数值是“9”的话，表示是有加上有 6 位数的附加版。

注意 6 位数的附加符号并不会自动地被加上去。请使用者在必要的情况下自列构造。

符号
标准版
（13 位数 + 校验位）
扩充版
（15 位数 + 校验位）
附加版
（5 位数 + 校验位）

注意 请尽可能将 Casecode 符号印刷在包装箱的所有侧面的下方。

（框线的下缘与箱子底边的间距为 32 毫米 +/- 3 毫米 。并且，框线的左右边缘与箱角的距离为 19 毫米以上）。


NW-7 条形码符号

可以表示出英文数字和字母的条形码。通常用以标识在电脑机器等特殊制品的包装上。

由于 NW-7 条形码符号的长度可变，所以对数据的字节数并没有限制。

示例： 数据为“a123456789-1234a”时则如下。


Code-39 条形码符号

可以表示出英文数字和字母的条形码符号。从 FA（Factory Automation ，工厂自动化）开始，被广泛的应用在工业上。

由于 Code-39 条形码符号的长度可变，所以对数据的字节数并没有限制。

示例： 数据为“*123456 CODE-39*”时则如下。


Code-128 条形码符号

可以表示出英文数字和字母的条形码符号。可将包括数字、标点符号、英文字母（大写与小写）在内的所有 128 个 ASCII 字节加以编码。而且，在符号太长的时候还可以加以封装。

由于 Code-128 条形码符号的长度可变，所以对数据的字节数并没有限制。示例： 数据为“12-34 Code-128; V25b”时则如下。


US Postnet 条形码符号

在美国为了自动化处理邮件所使用的条形码符号。

为了配合邮件处理的自动化，目前所用的符号可以指定投递街道。

最新的条形码符号传递点是在 Zip + 4 编码上再加上 2 位数的数值来表示投递街道。

所有的 Postnet 条形码符号都附加有校验位，而这校验位是自动计算得来的。使用者请勿自己加上校验位。

符号
5-digit Zip code
Zip + 4 编码
传递点

注意 在 Value 属性里指定有街道的话，就会产生相对应的编码（ZIP + 4 与 传递点），但是也有可能会印刷出错误的条形码。

如果在街道的最后没有 ZIP + 4 编码的话，则将无法产生条形码符号。

如果没有传递点编码，又或者是传递点编码里含有混淆不清的字节的话，则会产生预设的传递点编码“ 99 ”。而附有此码的邮件将无法以机械进行分类。

示例 |
"23, Fifth Colm St., Boston, MA 12345-1234" | 可以产生出正确的传递点编码。
"23, 5th Colm St., Boston, MA 12345-1234" | 因为门牌号码混淆而无法产生传递点编码。


US Postal FIM 条形码符号

在美国为了自动化处理邮件所使用的特殊条形码符号。

符号
FIM A 符号

用于已经标明 Postnet 条形码的 Courtesy 邮件
FIM B 符号

用于未标明 Postnet 条形码符号的业务相关邮件、Penalty 邮件与免费投递邮件
FIM C 符号

用于已经标明 Postnet 条形码符号的业务相关邮件、Penalty 邮件与免费投递邮件

注意 请将 FIM 条形码标示于邮件上端（距离右缘起约 5 厘米 的位置）


JP Post 条形码符号

在日本为了自动化处理邮件所使用的条形码符号。

为了配合邮件处理的自动化，所用的符号可以指定投递街道。

是由 7 位邮政编码和住址所组成并加以条形码化。

可条形码化的数据是数字、英文大写字母和连结号。

有关 JP Post 条形码的详细规格，请联系最近的邮局(适用居住日本者)。

所有的 JP Post 条形码符号都附加有校验位，而这校验位是自动计算得来的。使用者请勿自己加上校验位。

示例： |
邮政编码： 街道： JP Post 条形码： | 151-0073 东京 1-50-1 15100731-50-1

符号
JP Post 条形码

注意 JP Post 条形码可显示的范围以邮政编码和住址组合成的 20 个文字为限。

若在 Value 属性设定超过范围的数值，则 20 个文字之后的数值将无法转换成条形码。


SubStyle 属性（Casecode 条形码的子样式，子样式列表框）

Casecode 条形码符号有 3 种子样式可供选用。

SubStyle（子样式） | 说明
0 - 标准版 | 以 14 位数的值来产生符号。 在出口至美国与加拿大时，除了申请 UPC 制造厂商码之外，还请附上 UPC 的 Casecode 。
1 - 扩充版 | 以 16 位数的值来产生符号。
2 - 附加版 | 以 6 位数的值来产生符号。 由于是在个别的包装上学习各货物的重量与价格的不同而附上的，所以是附加在标准（扩充）版的后面。


Substyle 属性（POS 条形码的子样式，子样式列表框）

选用 POS 条形码符号（UPC-A，UPC-E，JAN-13，JAN-8）时，会显示出下行的子样式。

请按需要选用任一子样式。

SubStyle（子样式） | 说明
0 - 标准 | 标准的条形码符号。几乎所有的货物都可以应用。
1 - 2 位 (ISSN) 补充码 | 主码的右边再附加上 2 位数的补充码。用以表示杂志的发行编号。
2 - 5 位 (ISSN) 补充码 | 在主码的右边再附加上 5 位数的补充码。 用以表示书籍的价格。
3 - POS Casecode | 产生比标准尺寸更大的 POS 条形码符号。而且，还会在符号周围标识粗轮廓。 当制造商或批发商在将货物出货至零售店时，印刷在包装箱外部。


SubStyle 属性（Postal 条形码的子样式，子样式列表框）

US Postnet 条形码的子样式

US Postnet 条形码为使用于美国的条形码，在台湾、日本不使用。有 3 种子样式可供选用。

SubStyle（子样式） | 说明
0 - 传递点 | 为使邮件处理自动化的 12 位数条形码。 邮件请尽量使用这种样式。
1 - ZIP + 4 code | 用以限定投递区域的 10 位数条形码。 虽然当前仍被使用，但使用率已经逐渐降低。
2 - 5-digit ZIP code | 用以限定投递区域的 5 位数条形码。 目前几乎已经完全不使用了。

US Postal FIM 条形码的子样式

US FIM 条形码为使用于美国的条形码，在台湾、日本不使用。有 3 种子样式可供选用。

SubStyle（子样式） | 说明
0 - FIM A | 使用于 Courtesy Reply 邮件。
1 - FIM B | 使用于未标明 Postnet 条形码符号的业务相关邮件、 Penalty 邮件与免费投递邮件。
2 - FIM C | 使用于已经标明 Postnet 条形码符号的业务相关邮件、 Penalty 邮件与免费投递邮件。