IviRFSigGen Reference

© 2003 IVI Foundation

Welcome to the IviRfSigGen Class-Compliant Interface Reference

This section contains the reference material for the IviRfSigGen class-compliant interface.

This help hierarchy matches the COM hierarchy defined in the IviRfSigGen class specification, available on the IVI Foundation Web Site. The COM hierarchy groups related capabilities into common interfaces. These interfaces often include both IviRfSigGen base and extension capabilities. To help users distinguish between base and extension capabilities, the Capability Group section of each method or property topic lists which of the IviRfSigGen Capability Groups the method or property belongs to.

Since IVI class-compliant specific drivers are not required to support all extension groups, users should refer to the compliance documentation for the particular driver being used to determine if an extension group is supported before using capabilities in that group.

IVI class-compliant specific drivers may have small differences in the way a particular extension group method or property is implemented. For instance, a driver might implement only one of several IVI-defined values for an extension group attribute. Refer to the help documentation provided with the IVI class-compliant specific driver for detailed information about implementation.


Inherent Interface

IviRFSigGen Capability Groups

Capability Group | Description
IviRFSigGenBase | Base Capabilities: For generators that at minimum support setting the output frequency and amplitude, enabling or disabling the ALC and the RF output.
IviRFSigGenModulateAM | Extension Group: For generators with the ability to apply amplitude modulation to an output signal.
IviRFSigGenModulateFM | Extension Group: For generators with the ability to apply frequency modulation to an output signal.
IviRFSigGenModulatePM | Extension Group: For generators with the ability to apply phase modulation to an output signal.
IviRFSigGenAnalogModulationSource | Extension Group: For generators with at least one modulation source.
IviRFSigGenModulatePulse | Extension Group: For generators with the ability to apply pulse modulation to an output signal.
IviRFSigGenLFGenerator | Extension Group: For generators with an internal LF generator.
IviRFSigGenLFGeneratorOutput | Extension Group: For generators with an internal LF generator and a configurable output.
IviRFSigGenPulseGenerator | Extension Group: For generators with an internal pulse generator.
IviRFSigGenPulseDoubleGenerator | Extension Group: For generators with an internal pulse generator and the ability to generate a double pulse.
IviRFSigGenPulseGeneratorOutput | Extension Group: For generators with an internal pulse generator and a configurable output.
IviRFSigGenSweep | Extension Group: For generators with the ability to sweep the output frequency and/or power by analog means, discrete steps, or a list of values.
IviRFSigGenFrequencySweep | Extension Group: For generators with the ability to sweep the output frequency.
IviRFSigGenPowerSweep | Extension Group: For generators with the ability to sweep the output power.
IviRFSigGenFrequencyStep | Extension Group: For generators with the ability to sweep the output frequency in discrete steps.
IviRFSigGenPowerStep | Extension Group: For generators with the ability to sweep the output power in discrete steps.
IviRFSigGenList | Extension Group: For generators with the ability to sweep the output frequency and/or power by alist of values.
IviRFSigGenALC | Extension Group: For generators with the ability to use an automatic level control.
IviRFSigGenReferenceOscillator | Extension Group: For generators with the ability to use an external reference frequency.
IviRFSigGenSoftwareTrigger | Extension Group: For generators with the ability to trigger signal generation.
IviRFSigGenModulateIQ | Extension Group: For generators with the ability to apply vector (IQ) modulation to an output signal.
IviRFSigGenIQImpairment | Extension Group: For generators with the ability to apply impairment to vector (IQ) modulation.
IviRFSigGenArbGenerator | Extension Group: For generators with an arbitrary waveform generator as source for vector (IQ) modulation.
IviRFSigGenDigitalModulationBase | Extension Group: For generators with the ability to apply basic Digital Modulation.
IviRFSigGenCDMABase | Extension Group: For generators with the ability to apply digital CDMA (Code Division Multiple Access) modulation.
IviRFSigGenTDMABase | Extension Group: For generators with the ability to apply digital TDMA (Time Division Multiple Access) modulation.


Inherent Interface

IviRFSigGen Instrument Class Interfaces

IIviRFSigGen | IVI RFSigGen class-compliant root interface
IIviRFSigGenALC | IVI RFSigGen class-compliant Automatic Level Control (ALC) interface
IIviRFSigGenAM | IVI RFSigGen class-compliant analog modulation interface
IIviRFSigGenAnalogModulation | IVI RFSigGen class-compliant analog modulation interface
IIviRFSigGenAnalogModulationSource | IVI RFSigGen class-compliant modulation source interface
IIviRFSigGenArb | IVI RFSigGen class-compliant ARB generator interface
IIviRFSigGenCDMA | IVI RFSigGen class-compliant CDMA base interface
IIviRFSigGenDigitalModulation | IVI RFSigGen class-compliant digital modulation interface
IIviRFSigGenDigitalModulationBase | IVI RFSigGen class-compliant digital modulation base interface
IIviRFSigGenFM | IVI RFSigGen class-compliant frequency modulation interface
IIviRFSigGenFrequencyStep | IVI RFSigGen class-compliant frequency step interface
IIviRFSigGenFrequencySweep | IVI RFSigGen class-compliant frequency sweep interface
IIviRFSigGenIQ | IVI RFSigGen class-compliant IQ modulation interface
IIviRFSigGenIQImpairment | IVI RFSigGen class-compliant IQ modulation impairment interface
IIviRFSigGenLFGenerator | IVI RFSigGen class-compliant LF generator interface
IIviRFSigGenLFGeneratorOutput | IVI RFSigGen class-compliant LF generator output interface
IIviRFSigGenList | IVI RFSigGen class-compliant sweep list interface
IIviRFSigGenPM | IVI RFSigGen class-compliant phase modulation interface
IIviRFSigGenPowerStep | IVI RFSigGen class-compliant power step interface
IIviRFSigGenPowerSweep | IVI RFSigGen class-compliant power sweep interface
IIviRFSigGenPulseGenerator | IVI RFSigGen class-compliant pulse generator interface
IIviRFSigGenPulseGeneratorDouble | IVI RFSigGen class-compliant pulse double generator interface
IIviRFSigGenPulseGeneratorOutput | IVI RFSigGen class-compliant pulse generator output interface
IIviRFSigGenPulseModulation | IVI RFSigGen class-compliant pulse modulation interface
IIviRFSigGenReferenceOscillator | IVI RFSigGen class-compliant reference oscillator interface
IIviRFSigGenRF | IVI RFSigGen class-compliant RF interface
IIviRFSigGenSweep | IVI RFSigGen class-compliant sweep interface
IIviRFSigGenTDMA | IVI RFSigGen class-compliant TDMA base interface


IIviRFSigGen Interface

IVI RFSigGen class-compliant root interface

Properties

DriverOperation | Pointer to the IIviDriverOperation interface
Identity | Pointer to the IIviDriverIdentity interface
Utility | Pointer to the IIviDriverUtility interface
Initialized | Initialized is True between a successful call to the Initialize method and a successful call to the Close method, and False at all other times.
RF | Pointer to the class-compliant IIviRFSigGenRF interface
ALC | Pointer to the class-compliant IIviRFSigGenALC interface
LFGenerator | Pointer to the class-compliant IIviRFSigGenLFGenerator interface
PulseGenerator | Pointer to the class-compliant IIviRFSigGenPulseGenerator interface
Sweep | Pointer to the class-compliant IIviRFSigGenSweep interface
ReferenceOscillator | Pointer to the class-compliant IIviRFSigGenReferenceOscillator interface
AnalogModulation | Pointer to the class-compliant IIviRFSigGenAnalogModulation interface
PulseModulation | Pointer to the class-compliant IIviRFSigGenPulseModulation interface
DigitalModulation | Pointer to the class-compliant IIviRFSigGenDigitalModulation interface
IQ | Pointer to the class-compliant IIviRFSigGenIQ interface

Methods

Initialize | Opens the I/O session to the instrument. Driver methods and properties that access the instrument are only accessible after Initialize is called. Initialize optionally performs a Reset and queries the instrument to validate the instrument model.
Close | Closes the I/O session to the instrument. Driver methods and properties that access the instrument are not accessible after Close is called.
SendSoftwareTrigger | Sends a software trigger, which will cause the signal generator to start signal generation.


DriverOperation Property

IIviRFSigGen.DriverOperation Property

Pointer to the IIviDriverOperation interface

[Visual Basic]
Property Get DriverOperation() As IIviDriverOperation*
[C++]
HRESULT get_DriverOperation(IIviDriverOperation** value);
[ANSI C]
HRESULT IIviRFSigGen_get_DriverOperation(IIviRFSigGen* This, IIviDriverOperation** value);
[C#]
public IIviDriverOperation* DriverOperation {get;}

Also In This Interface

DriverOperation | Identity | Utility | Initialized | RF | ALC | LFGenerator | PulseGenerator | Sweep | ReferenceOscillator | AnalogModulation | PulseModulation | DigitalModulation | IQ | Initialize | Close | SendSoftwareTrigger | IIviRFSigGen Overview


Identity Property

IIviRFSigGen.Identity Property

Pointer to the IIviDriverIdentity interface

[Visual Basic]
Property Get Identity() As IIviDriverIdentity*
[C++]
HRESULT get_Identity(IIviDriverIdentity** value);
[ANSI C]
HRESULT IIviRFSigGen_get_Identity(IIviRFSigGen* This, IIviDriverIdentity** value);
[C#]
public IIviDriverIdentity* Identity {get;}

Also In This Interface

DriverOperation | Identity | Utility | Initialized | RF | ALC | LFGenerator | PulseGenerator | Sweep | ReferenceOscillator | AnalogModulation | PulseModulation | DigitalModulation | IQ | Initialize | Close | SendSoftwareTrigger | IIviRFSigGen Overview


Utility Property

IIviRFSigGen.Utility Property

Pointer to the IIviDriverUtility interface

[Visual Basic]
Property Get Utility() As IIviDriverUtility*
[C++]
HRESULT get_Utility(IIviDriverUtility** value);
[ANSI C]
HRESULT IIviRFSigGen_get_Utility(IIviRFSigGen* This, IIviDriverUtility** value);
[C#]
public IIviDriverUtility* Utility {get;}

Also In This Interface

DriverOperation | Identity | Utility | Initialized | RF | ALC | LFGenerator | PulseGenerator | Sweep | ReferenceOscillator | AnalogModulation | PulseModulation | DigitalModulation | IQ | Initialize | Close | SendSoftwareTrigger | IIviRFSigGen Overview


Initialized Property

IIviRFSigGen.Initialized Property

Initialized is True between a successful call to the Initialize method and a successful call to the Close method, and False at all other times.

[Visual Basic]
Property Get Initialized() As Boolean
[C++]
HRESULT get_Initialized(VARIANT_BOOL* value);
[ANSI C]
HRESULT IIviRFSigGen_get_Initialized(IIviRFSigGen* This, VARIANT_BOOL* value);
[C#]
public bool Initialized {get;}

Also In This Interface

DriverOperation | Identity | Utility | Initialized | RF | ALC | LFGenerator | PulseGenerator | Sweep | ReferenceOscillator | AnalogModulation | PulseModulation | DigitalModulation | IQ | Initialize | Close | SendSoftwareTrigger | IIviRFSigGen Overview


RF Property

IIviRFSigGen.RF Property

Pointer to the class-compliant IIviRFSigGenRF interface

[Visual Basic]
Property Get RF() As IIviRFSigGenRF
[C++]
HRESULT get_RF(IIviRFSigGenRF** value);
[ANSI C]
HRESULT IIviRFSigGen_get_RF(IIviRFSigGen* This, IIviRFSigGenRF** value);
[C#]
public IIviRFSigGenRF RF {get;}

Capability Group

IviRFSigGenBase

Also In This Interface

DriverOperation | Identity | Utility | Initialized | RF | ALC | LFGenerator | PulseGenerator | Sweep | ReferenceOscillator | AnalogModulation | PulseModulation | DigitalModulation | IQ | Initialize | Close | SendSoftwareTrigger | IIviRFSigGen Overview


ALC Property

IIviRFSigGen.ALC Property

Pointer to the class-compliant IIviRFSigGenALC interface

[Visual Basic]
Property Get ALC() As IIviRFSigGenALC
[C++]
HRESULT get_ALC(IIviRFSigGenALC** value);
[ANSI C]
HRESULT IIviRFSigGen_get_ALC(IIviRFSigGen* This, IIviRFSigGenALC** value);
[C#]
public IIviRFSigGenALC ALC {get;}

Capability Group

IviRFSigGenALC

Also In This Interface

DriverOperation | Identity | Utility | Initialized | RF | ALC | LFGenerator | PulseGenerator | Sweep | ReferenceOscillator | AnalogModulation | PulseModulation | DigitalModulation | IQ | Initialize | Close | SendSoftwareTrigger | IIviRFSigGen Overview


LFGenerator Property

IIviRFSigGen.LFGenerator Property

Pointer to the class-compliant IIviRFSigGenLFGenerator interface

[Visual Basic]
Property Get LFGenerator() As IIviRFSigGenLFGenerator
[C++]
HRESULT get_LFGenerator(IIviRFSigGenLFGenerator** value);
[ANSI C]
HRESULT IIviRFSigGen_get_LFGenerator(IIviRFSigGen* This, IIviRFSigGenLFGenerator** value);
[C#]
public IIviRFSigGenLFGenerator LFGenerator {get;}

Capability Group

IviRFSigGenLFGenerator

Also In This Interface

DriverOperation | Identity | Utility | Initialized | RF | ALC | LFGenerator | PulseGenerator | Sweep | ReferenceOscillator | AnalogModulation | PulseModulation | DigitalModulation | IQ | Initialize | Close | SendSoftwareTrigger | IIviRFSigGen Overview


PulseGenerator Property

IIviRFSigGen.PulseGenerator Property

Pointer to the class-compliant IIviRFSigGenPulseGenerator interface

[Visual Basic]
Property Get PulseGenerator() As IIviRFSigGenPulseGenerator
[C++]
HRESULT get_PulseGenerator(IIviRFSigGenPulseGenerator** value);
[ANSI C]
HRESULT IIviRFSigGen_get_PulseGenerator(IIviRFSigGen* This, IIviRFSigGenPulseGenerator** value);
[C#]
public IIviRFSigGenPulseGenerator PulseGenerator {get;}

Capability Group

IviRFSigGenPulseGenerator

Also In This Interface

DriverOperation | Identity | Utility | Initialized | RF | ALC | LFGenerator | PulseGenerator | Sweep | ReferenceOscillator | AnalogModulation | PulseModulation | DigitalModulation | IQ | Initialize | Close | SendSoftwareTrigger | IIviRFSigGen Overview


Sweep Property

IIviRFSigGen.Sweep Property

Pointer to the class-compliant IIviRFSigGenSweep interface

[Visual Basic]
Property Get Sweep() As IIviRFSigGenSweep
[C++]
HRESULT get_Sweep(IIviRFSigGenSweep** value);
[ANSI C]
HRESULT IIviRFSigGen_get_Sweep(IIviRFSigGen* This, IIviRFSigGenSweep** value);
[C#]
public IIviRFSigGenSweep Sweep {get;}

Capability Group

IviRFSigGenSweep

Also In This Interface

DriverOperation | Identity | Utility | Initialized | RF | ALC | LFGenerator | PulseGenerator | Sweep | ReferenceOscillator | AnalogModulation | PulseModulation | DigitalModulation | IQ | Initialize | Close | SendSoftwareTrigger | IIviRFSigGen Overview


ReferenceOscillator Property

IIviRFSigGen.ReferenceOscillator Property

Pointer to the class-compliant IIviRFSigGenReferenceOscillator interface

[Visual Basic]
Property Get ReferenceOscillator() As IIviRFSigGenReferenceOscillator
[C++]
HRESULT get_ReferenceOscillator(IIviRFSigGenReferenceOscillator** value);
[ANSI C]
HRESULT IIviRFSigGen_get_ReferenceOscillator(IIviRFSigGen* This, IIviRFSigGenReferenceOscillator** value);
[C#]
public IIviRFSigGenReferenceOscillator ReferenceOscillator {get;}

Capability Group

IviRFSigGenReferenceOscillator

Also In This Interface

DriverOperation | Identity | Utility | Initialized | RF | ALC | LFGenerator | PulseGenerator | Sweep | ReferenceOscillator | AnalogModulation | PulseModulation | DigitalModulation | IQ | Initialize | Close | SendSoftwareTrigger | IIviRFSigGen Overview


AnalogModulation Property

IIviRFSigGen.AnalogModulation Property

Pointer to the class-compliant IIviRFSigGenAnalogModulation interface

[Visual Basic]
Property Get AnalogModulation() As IIviRFSigGenAnalogModulation
[C++]
HRESULT get_AnalogModulation(IIviRFSigGenAnalogModulation** value);
[ANSI C]
HRESULT IIviRFSigGen_get_AnalogModulation(IIviRFSigGen* This, IIviRFSigGenAnalogModulation** value);
[C#]
public IIviRFSigGenAnalogModulation AnalogModulation {get;}

Capability Group

IviRFSigGenBase

Also In This Interface

DriverOperation | Identity | Utility | Initialized | RF | ALC | LFGenerator | PulseGenerator | Sweep | ReferenceOscillator | AnalogModulation | PulseModulation | DigitalModulation | IQ | Initialize | Close | SendSoftwareTrigger | IIviRFSigGen Overview


PulseModulation Property

IIviRFSigGen.PulseModulation Property

Pointer to the class-compliant IIviRFSigGenPulseModulation interface

[Visual Basic]
Property Get PulseModulation() As IIviRFSigGenPulseModulation
[C++]
HRESULT get_PulseModulation(IIviRFSigGenPulseModulation** value);
[ANSI C]
HRESULT IIviRFSigGen_get_PulseModulation(IIviRFSigGen* This, IIviRFSigGenPulseModulation** value);
[C#]
public IIviRFSigGenPulseModulation PulseModulation {get;}

Capability Group

IviRFSigGenModulatePulse

Also In This Interface

DriverOperation | Identity | Utility | Initialized | RF | ALC | LFGenerator | PulseGenerator | Sweep | ReferenceOscillator | AnalogModulation | PulseModulation | DigitalModulation | IQ | Initialize | Close | SendSoftwareTrigger | IIviRFSigGen Overview


DigitalModulation Property

IIviRFSigGen.DigitalModulation Property

Pointer to the class-compliant IIviRFSigGenDigitalModulation interface

[Visual Basic]
Property Get DigitalModulation() As IIviRFSigGenDigitalModulation
[C++]
HRESULT get_DigitalModulation(IIviRFSigGenDigitalModulation** value);
[ANSI C]
HRESULT IIviRFSigGen_get_DigitalModulation(IIviRFSigGen* This, IIviRFSigGenDigitalModulation** value);
[C#]
public IIviRFSigGenDigitalModulation DigitalModulation {get;}

Capability Group

IviRFSigGenDigitalModulationBase

Also In This Interface

DriverOperation | Identity | Utility | Initialized | RF | ALC | LFGenerator | PulseGenerator | Sweep | ReferenceOscillator | AnalogModulation | PulseModulation | DigitalModulation | IQ | Initialize | Close | SendSoftwareTrigger | IIviRFSigGen Overview


IQ Property

IIviRFSigGen.IQ Property

Pointer to the class-compliant IIviRFSigGenIQ interface

[Visual Basic]
Property Get IQ() As IIviRFSigGenIQ
[C++]
HRESULT get_IQ(IIviRFSigGenIQ** value);
[ANSI C]
HRESULT IIviRFSigGen_get_IQ(IIviRFSigGen* This, IIviRFSigGenIQ** value);
[C#]
public IIviRFSigGenIQ IQ {get;}

Capability Group

IviRFSigGenModulateIQ

Also In This Interface

DriverOperation | Identity | Utility | Initialized | RF | ALC | LFGenerator | PulseGenerator | Sweep | ReferenceOscillator | AnalogModulation | PulseModulation | DigitalModulation | IQ | Initialize | Close | SendSoftwareTrigger | IIviRFSigGen Overview


Initialize Method

IIviRFSigGen.Initialize Method

Opens the I/O session to the instrument. Driver methods and properties that access the instrument are only accessible after Initialize is called. Initialize optionally performs a Reset and queries the instrument to validate the instrument model.

[Visual Basic]
Sub Initialize( _
   ResourceName As String, _
   IdQuery As Boolean, _
   Reset As Boolean, _
   OptionString As String _
)
[C++]
HRESULT Initialize(
   BSTR ResourceName,
   VARIANT_BOOL IdQuery,
   VARIANT_BOOL Reset,
   BSTR OptionString
);
[ANSI C]
HRESULT IIviRFSigGen_Initialize(
   IIviRFSigGen* This
   BSTR ResourceName,
   VARIANT_BOOL IdQuery,
   VARIANT_BOOL Reset,
   BSTR OptionString
);
[C#]
public void Initialize(
   string ResourceName,
   bool IdQuery,
   bool Reset,
   string OptionString
);

Parameters

ResourceName
An IVI logical name or an instrument specific string that identifies the address of the instrument, such as a VISA resource descriptor string.
IdQuery
Specifies whether to verify the ID of the instrument.
Reset
Specifies whether to reset the instrument.
OptionString
The user can use the OptionsString parameter to specify the initial values of certain IVI inherent attributes for the session.

Related Items

Close

Also In This Interface

DriverOperation | Identity | Utility | Initialized | RF | ALC | LFGenerator | PulseGenerator | Sweep | ReferenceOscillator | AnalogModulation | PulseModulation | DigitalModulation | IQ | Initialize | Close | SendSoftwareTrigger | IIviRFSigGen Overview


Close Method

IIviRFSigGen.Close Method

Closes the I/O session to the instrument. Driver methods and properties that access the instrument are not accessible after Close is called.

[Visual Basic]
Sub Close()
[C++]
HRESULT Close();
[ANSI C]
HRESULT IIviRFSigGen_Close(
   IIviRFSigGen* This);
[C#]
public void Close();

Related Items

Initialize

Also In This Interface

DriverOperation | Identity | Utility | Initialized | RF | ALC | LFGenerator | PulseGenerator | Sweep | ReferenceOscillator | AnalogModulation | PulseModulation | DigitalModulation | IQ | Initialize | Close | SendSoftwareTrigger | IIviRFSigGen Overview


SendSoftwareTrigger Method

IIviRFSigGen.SendSoftwareTrigger Method

Sends a software trigger, which will cause the signal generator to start signal generation.

[Visual Basic]
Sub SendSoftwareTrigger()
[C++]
HRESULT SendSoftwareTrigger();
[ANSI C]
HRESULT IIviRFSigGen_SendSoftwareTrigger(
   IIviRFSigGen* This);
[C#]
public void SendSoftwareTrigger();

Capability Group

IviRFSigGenSoftwareTrigger

Also In This Interface

DriverOperation | Identity | Utility | Initialized | RF | ALC | LFGenerator | PulseGenerator | Sweep | ReferenceOscillator | AnalogModulation | PulseModulation | DigitalModulation | IQ | Initialize | Close | SendSoftwareTrigger | IIviRFSigGen Overview


IIviRFSigGenALC Interface

IVI RFSigGen class-compliant Automatic Level Control (ALC) interface

Properties

Source | Specifies the ALC (Automatic Level Control) source.
Bandwidth | Specifies the ALC (Automatic Level Control) bandwidth.
Enabled | Enables or disables the Automatic Level Control (ALC).

Methods

Configure This function configures the ALC (Automatic Level Control) of the signal generator's RF output.


Source Property

IIviRFSigGenALC.Source Property

Specifies the ALC (Automatic Level Control) source.

[Visual Basic]
Property Get Source() As IviRFSigGenALCSourceEnum
Property Let Source(value As IviRFSigGenALCSourceEnum)
[C++]
HRESULT get_Source(IviRFSigGenALCSourceEnum* value);
HRESULT put_Source(IviRFSigGenALCSourceEnum value);
[ANSI C]
HRESULT IIviRFSigGenALC_get_Source(IIviRFSigGenALC* This, IviRFSigGenALCSourceEnum* value);
HRESULT IIviRFSigGenALC_put_Source(IIviRFSigGenALC* This, IviRFSigGenALCSourceEnum value);
[C#]
public IviRFSigGenALCSourceEnum Source {get; set;}

Capability Group

IviRFSigGenALC

Related Items

Configure

Also In This Interface

Source | Bandwidth | Enabled | Configure | IIviRFSigGenALC Overview


Bandwidth Property

IIviRFSigGenALC.Bandwidth Property

Specifies the ALC (Automatic Level Control) bandwidth.

[Visual Basic]
Property Get Bandwidth() As Double
Property Let Bandwidth(value As Double)
[C++]
HRESULT get_Bandwidth(double* value);
HRESULT put_Bandwidth(double value);
[ANSI C]
HRESULT IIviRFSigGenALC_get_Bandwidth(IIviRFSigGenALC* This, double* value);
HRESULT IIviRFSigGenALC_put_Bandwidth(IIviRFSigGenALC* This, double value);
[C#]
public double Bandwidth {get; set;}

Capability Group

IviRFSigGenALC

Related Items

Configure

Also In This Interface

Source | Bandwidth | Enabled | Configure | IIviRFSigGenALC Overview


Enabled Property

IIviRFSigGenALC.Enabled Property

Enables or disables the Automatic Level Control (ALC).

[Visual Basic]
Property Get Enabled() As Boolean
Property Let Enabled(value As Boolean)
[C++]
HRESULT get_Enabled(VARIANT_BOOL* value);
HRESULT put_Enabled(VARIANT_BOOL value);
[ANSI C]
HRESULT IIviRFSigGenALC_get_Enabled(IIviRFSigGenALC* This, VARIANT_BOOL* value);
HRESULT IIviRFSigGenALC_put_Enabled(IIviRFSigGenALC* This, VARIANT_BOOL value);
[C#]
public bool Enabled {get; set;}

Capability Group

IviRFSigGenBase

Related Items

Configure

Also In This Interface

Source | Bandwidth | Enabled | Configure | IIviRFSigGenALC Overview


Configure Method

IIviRFSigGenALC.Configure Method

This function configures the ALC (Automatic Level Control) of the signal generator's RF output.

[Visual Basic]
Sub Configure( _
   Source As IviRFSigGenALCSourceEnum, _
   Bandwidth As Double _
)
[C++]
HRESULT Configure(
   IviRFSigGenALCSourceEnum Source,
   double Bandwidth
);
[ANSI C]
HRESULT IIviRFSigGenALC_Configure(
   IIviRFSigGenALC* This
   IviRFSigGenALCSourceEnum Source,
   double Bandwidth
);
[C#]
public void Configure(
   IviRFSigGenALCSourceEnum Source,
   double Bandwidth
);

Parameters

Source
Specifies the ALC (Automatic Level Control) source.
Bandwidth
Specifies the ALC (Automatic Level Control) bandwidth.

Capability Group

IviRFSigGenALC

Related Items

Source | Bandwidth

Also In This Interface

Source | Bandwidth | Enabled | Configure | IIviRFSigGenALC Overview


IIviRFSigGenAM Interface

IVI RFSigGen class-compliant analog modulation interface

Properties

Source | Specifies the source of the signal that is used as the modulating signal.
Scaling | Specifies linear or logarithmic attenuation for amplitude modulation.
Depth | Specifies the extent of modulation the signal generator applies to the RF-signal.
NominalVoltage | Returns the voltage at which the instrument achieves the amount of modulation specified by the AM Depth attribute.
Enabled | Specifies whether the signal generator enables or disables amplitude modulation of the RF output signal.
ExternalCoupling | Specifies the coupling of the external source of the modulating signal.

Methods

Configure This function configures the attributes that control the signal generator's amplitude modulation.


Source Property

IIviRFSigGenAM.Source Property

Specifies the source of the signal that is used as the modulating signal.

[Visual Basic]
Property Get Source() As String
Property Let Source(value As String)
[C++]
HRESULT get_Source(BSTR* value);
HRESULT put_Source(BSTR value);
[ANSI C]
HRESULT IIviRFSigGenAM_get_Source(IIviRFSigGenAM* This, BSTR* value);
HRESULT IIviRFSigGenAM_put_Source(IIviRFSigGenAM* This, BSTR value);
[C#]
public string Source {get; set;}

Capability Group

IviRFSigGenModulateAM

Related Items

Configure

Also In This Interface

Source | Scaling | Depth | NominalVoltage | Enabled | ExternalCoupling | Configure | IIviRFSigGenAM Overview


Scaling Property

IIviRFSigGenAM.Scaling Property

Specifies linear or logarithmic attenuation for amplitude modulation.

[Visual Basic]
Property Get Scaling() As IviRFSigGenAMScalingEnum
Property Let Scaling(value As IviRFSigGenAMScalingEnum)
[C++]
HRESULT get_Scaling(IviRFSigGenAMScalingEnum* value);
HRESULT put_Scaling(IviRFSigGenAMScalingEnum value);
[ANSI C]
HRESULT IIviRFSigGenAM_get_Scaling(IIviRFSigGenAM* This, IviRFSigGenAMScalingEnum* value);
HRESULT IIviRFSigGenAM_put_Scaling(IIviRFSigGenAM* This, IviRFSigGenAMScalingEnum value);
[C#]
public IviRFSigGenAMScalingEnum Scaling {get; set;}

Capability Group

IviRFSigGenModulateAM

Related Items

Configure

Also In This Interface

Source | Scaling | Depth | NominalVoltage | Enabled | ExternalCoupling | Configure | IIviRFSigGenAM Overview


Depth Property

IIviRFSigGenAM.Depth Property

Specifies the extent of modulation the signal generator applies to the RF-signal.

[Visual Basic]
Property Get Depth() As Double
Property Let Depth(value As Double)
[C++]
HRESULT get_Depth(double* value);
HRESULT put_Depth(double value);
[ANSI C]
HRESULT IIviRFSigGenAM_get_Depth(IIviRFSigGenAM* This, double* value);
HRESULT IIviRFSigGenAM_put_Depth(IIviRFSigGenAM* This, double value);
[C#]
public double Depth {get; set;}

Capability Group

IviRFSigGenModulateAM

Related Items

Configure

Also In This Interface

Source | Scaling | Depth | NominalVoltage | Enabled | ExternalCoupling | Configure | IIviRFSigGenAM Overview


NominalVoltage Property

IIviRFSigGenAM.NominalVoltage Property

Returns the voltage at which the instrument achieves the amount of modulation specified by the AM Depth attribute.

[Visual Basic]
Property Get NominalVoltage() As Double
[C++]
HRESULT get_NominalVoltage(double* value);
[ANSI C]
HRESULT IIviRFSigGenAM_get_NominalVoltage(IIviRFSigGenAM* This, double* value);
[C#]
public double NominalVoltage {get;}

Capability Group

IviRFSigGenModulateAM

Also In This Interface

Source | Scaling | Depth | NominalVoltage | Enabled | ExternalCoupling | Configure | IIviRFSigGenAM Overview


Enabled Property

IIviRFSigGenAM.Enabled Property

Specifies whether the signal generator enables or disables amplitude modulation of the RF output signal.

[Visual Basic]
Property Get Enabled() As Boolean
Property Let Enabled(value As Boolean)
[C++]
HRESULT get_Enabled(VARIANT_BOOL* value);
HRESULT put_Enabled(VARIANT_BOOL value);
[ANSI C]
HRESULT IIviRFSigGenAM_get_Enabled(IIviRFSigGenAM* This, VARIANT_BOOL* value);
HRESULT IIviRFSigGenAM_put_Enabled(IIviRFSigGenAM* This, VARIANT_BOOL value);
[C#]
public bool Enabled {get; set;}

Capability Group

IviRFSigGenModulateAM

Also In This Interface

Source | Scaling | Depth | NominalVoltage | Enabled | ExternalCoupling | Configure | IIviRFSigGenAM Overview


ExternalCoupling Property

IIviRFSigGenAM.ExternalCoupling Property

Specifies the coupling of the external source of the modulating signal.

[Visual Basic]
Property Get ExternalCoupling() As IviRFSigGenAMExternalCouplingEnum
Property Let ExternalCoupling(value As IviRFSigGenAMExternalCouplingEnum)
[C++]
HRESULT get_ExternalCoupling(IviRFSigGenAMExternalCouplingEnum* value);
HRESULT put_ExternalCoupling(IviRFSigGenAMExternalCouplingEnum value);
[ANSI C]
HRESULT IIviRFSigGenAM_get_ExternalCoupling(IIviRFSigGenAM* This, IviRFSigGenAMExternalCouplingEnum* value);
HRESULT IIviRFSigGenAM_put_ExternalCoupling(IIviRFSigGenAM* This, IviRFSigGenAMExternalCouplingEnum value);
[C#]
public IviRFSigGenAMExternalCouplingEnum ExternalCoupling {get; set;}

Capability Group

IviRFSigGenModulateAM

Also In This Interface

Source | Scaling | Depth | NominalVoltage | Enabled | ExternalCoupling | Configure | IIviRFSigGenAM Overview


Configure Method

IIviRFSigGenAM.Configure Method

This function configures the attributes that control the signal generator's amplitude modulation.

[Visual Basic]
Sub Configure( _
   Source As String, _
   Scaling As IviRFSigGenAMScalingEnum, _
   Depth As Double _
)
[C++]
HRESULT Configure(
   BSTR Source,
   IviRFSigGenAMScalingEnum Scaling,
   double Depth
);
[ANSI C]
HRESULT IIviRFSigGenAM_Configure(
   IIviRFSigGenAM* This
   BSTR Source,
   IviRFSigGenAMScalingEnum Scaling,
   double Depth
);
[C#]
public void Configure(
   string Source,
   IviRFSigGenAMScalingEnum Scaling,
   double Depth
);

Parameters

Source
Specifies the source of the signal that the signal generator uses to modulate the output signal. The driver uses this value to set the AM Source attribute.
Scaling
Specifies the scaling of the modulation. The driver uses this value to set the AM Scaling attribute.
Depth
Specifies the extent of modulation. The driver uses this value to set the AM Depth attribute.

Capability Group

IviRFSigGenModulateAM

Related Items

Source | Scaling | Depth

Also In This Interface

Source | Scaling | Depth | NominalVoltage | Enabled | ExternalCoupling | Configure | IIviRFSigGenAM Overview


IIviRFSigGenAnalogModulation Interface

IVI RFSigGen class-compliant analog modulation interface

Properties

AM | Pointer to the class-compliant IIviRFSigGenAM interface
FM | Pointer to the class-compliant IIviRFSigGenFM interface
PM | Pointer to the class-compliant IIviRFSigGenPM interface
Source | Pointer to the class-compliant IIviRFSigGenAnalogModulationSource interface


AM Property

IIviRFSigGenAnalogModulation.AM Property

Pointer to the class-compliant IIviRFSigGenAM interface

[Visual Basic]
Property Get AM() As IIviRFSigGenAM
[C++]
HRESULT get_AM(IIviRFSigGenAM** value);
[ANSI C]
HRESULT IIviRFSigGenAnalogModulation_get_AM(IIviRFSigGenAnalogModulation* This, IIviRFSigGenAM** value);
[C#]
public IIviRFSigGenAM AM {get;}

Capability Group

IviRFSigGenModulateAM

Also In This Interface

AM | FM | PM | Source | IIviRFSigGenAnalogModulation Overview


FM Property

IIviRFSigGenAnalogModulation.FM Property

Pointer to the class-compliant IIviRFSigGenFM interface

[Visual Basic]
Property Get FM() As IIviRFSigGenFM
[C++]
HRESULT get_FM(IIviRFSigGenFM** value);
[ANSI C]
HRESULT IIviRFSigGenAnalogModulation_get_FM(IIviRFSigGenAnalogModulation* This, IIviRFSigGenFM** value);
[C#]
public IIviRFSigGenFM FM {get;}

Capability Group

IviRFSigGenModulateFM

Also In This Interface

AM | FM | PM | Source | IIviRFSigGenAnalogModulation Overview


PM Property

IIviRFSigGenAnalogModulation.PM Property

Pointer to the class-compliant IIviRFSigGenPM interface

[Visual Basic]
Property Get PM() As IIviRFSigGenPM
[C++]
HRESULT get_PM(IIviRFSigGenPM** value);
[ANSI C]
HRESULT IIviRFSigGenAnalogModulation_get_PM(IIviRFSigGenAnalogModulation* This, IIviRFSigGenPM** value);
[C#]
public IIviRFSigGenPM PM {get;}

Capability Group

IviRFSigGenModulatePM

Also In This Interface

AM | FM | PM | Source | IIviRFSigGenAnalogModulation Overview


Source Property

IIviRFSigGenAnalogModulation.Source Property

Pointer to the class-compliant IIviRFSigGenAnalogModulationSource interface

[Visual Basic]
Property Get Source() As IIviRFSigGenAnalogModulationSource
[C++]
HRESULT get_Source(IIviRFSigGenAnalogModulationSource** value);
[ANSI C]
HRESULT IIviRFSigGenAnalogModulation_get_Source(IIviRFSigGenAnalogModulation* This, IIviRFSigGenAnalogModulationSource** value);
[C#]
public IIviRFSigGenAnalogModulationSource Source {get;}

Capability Group

IviRFSigGenAnalogModulationSource

Also In This Interface

AM | FM | PM | Source | IIviRFSigGenAnalogModulation Overview


IIviRFSigGenAnalogModulationSource Interface

IVI RFSigGen class-compliant modulation source interface

Properties

Count | Specifies how many modulation sources are available.
Name | Returns the name of a particular modulation source.


Count Property

IIviRFSigGenAnalogModulationSource.Count Property

Specifies how many modulation sources are available.

[Visual Basic]
Property Get Count() As Long
[C++]
HRESULT get_Count(long* value);
[ANSI C]
HRESULT IIviRFSigGenAnalogModulationSource_get_Count(IIviRFSigGenAnalogModulationSource* This, long* value);
[C#]
public long Count {get;}

Capability Group

IviRFSigGenAnalogModulationSource

Also In This Interface

Count | Name | IIviRFSigGenAnalogModulationSource Overview


Name Property

IIviRFSigGenAnalogModulationSource.Name Property

Returns the name of a particular modulation source.

[Visual Basic]
Property Get Name(Index As Long) As String
[C++]
HRESULT get_Name(long Index, BSTR* value);
[ANSI C]
HRESULT IIviRFSigGenAnalogModulationSource_get_Name(IIviRFSigGenAnalogModulationSource* This, long Index, BSTR* value);
[C#]HRESULT get_Name(long Index, string value);

Parameters

Index
A one-based index that defines which name to return.

Capability Group

IviRFSigGenAnalogModulationSource

Also In This Interface

Count | Name | IIviRFSigGenAnalogModulationSource Overview


IIviRFSigGenArb Interface

IVI RFSigGen class-compliant ARB generator interface

Properties

SelectedWaveform | Specifies the selected waveform from the pool of available waveforms.
ClockFrequency | Specifies the sample frequency.
FilterFrequency | Specifies the cut off frequency of the low pass filter.
MaxNumberWaveforms | Specifies the maximum number of waveforms the instrument can hold in memory.
WaveformQuantum | The waveform length must be a multiple of this quantum.
WaveformSizeMin | The waveform length must be equal or greater than min size.
WaveformSizeMax | The waveform length must be equal or less than max size.
TriggerSource | Specifies the trigger source for the ARB waveform.
ExternalTriggerSlope | Specifies whether the trigger event occurs on the rising or falling edge of the input signal.

Methods

Configure | This function configures the ARB generator.
WriteWaveform | This function stores the waveform in the driver's or instrument's memory.
ClearAllWaveforms | This function deletes all waveforms from the pool of waveforms.
QueryWaveformCapabilities | This function returns the capabilities of the ARB generator.


SelectedWaveform Property

IIviRFSigGenArb.SelectedWaveform Property

Specifies the selected waveform from the pool of available waveforms.

[Visual Basic]
Property Get SelectedWaveform() As String
Property Let SelectedWaveform(value As String)
[C++]
HRESULT get_SelectedWaveform(BSTR* value);
HRESULT put_SelectedWaveform(BSTR value);
[ANSI C]
HRESULT IIviRFSigGenArb_get_SelectedWaveform(IIviRFSigGenArb* This, BSTR* value);
HRESULT IIviRFSigGenArb_put_SelectedWaveform(IIviRFSigGenArb* This, BSTR value);
[C#]
public string SelectedWaveform {get; set;}

Capability Group

IviRFSigGenArbGenerator

Also In This Interface

SelectedWaveform | ClockFrequency | FilterFrequency | MaxNumberWaveforms | WaveformQuantum | WaveformSizeMin | WaveformSizeMax | TriggerSource | ExternalTriggerSlope | Configure | WriteWaveform | ClearAllWaveforms | QueryWaveformCapabilities | IIviRFSigGenArb Overview


ClockFrequency Property

IIviRFSigGenArb.ClockFrequency Property

Specifies the sample frequency.

[Visual Basic]
Property Get ClockFrequency() As Double
Property Let ClockFrequency(value As Double)
[C++]
HRESULT get_ClockFrequency(double* value);
HRESULT put_ClockFrequency(double value);
[ANSI C]
HRESULT IIviRFSigGenArb_get_ClockFrequency(IIviRFSigGenArb* This, double* value);
HRESULT IIviRFSigGenArb_put_ClockFrequency(IIviRFSigGenArb* This, double value);
[C#]
public double ClockFrequency {get; set;}

Capability Group

IviRFSigGenArbGenerator

Related Items

Configure

Also In This Interface

SelectedWaveform | ClockFrequency | FilterFrequency | MaxNumberWaveforms | WaveformQuantum | WaveformSizeMin | WaveformSizeMax | TriggerSource | ExternalTriggerSlope | Configure | WriteWaveform | ClearAllWaveforms | QueryWaveformCapabilities | IIviRFSigGenArb Overview


FilterFrequency Property

IIviRFSigGenArb.FilterFrequency Property

Specifies the cut off frequency of the low pass filter.

[Visual Basic]
Property Get FilterFrequency() As Double
Property Let FilterFrequency(value As Double)
[C++]
HRESULT get_FilterFrequency(double* value);
HRESULT put_FilterFrequency(double value);
[ANSI C]
HRESULT IIviRFSigGenArb_get_FilterFrequency(IIviRFSigGenArb* This, double* value);
HRESULT IIviRFSigGenArb_put_FilterFrequency(IIviRFSigGenArb* This, double value);
[C#]
public double FilterFrequency {get; set;}

Capability Group

IviRFSigGenArbGenerator

Related Items

Configure

Also In This Interface

SelectedWaveform | ClockFrequency | FilterFrequency | MaxNumberWaveforms | WaveformQuantum | WaveformSizeMin | WaveformSizeMax | TriggerSource | ExternalTriggerSlope | Configure | WriteWaveform | ClearAllWaveforms | QueryWaveformCapabilities | IIviRFSigGenArb Overview


MaxNumberWaveforms Property

IIviRFSigGenArb.MaxNumberWaveforms Property

Specifies the maximum number of waveforms the instrument can hold in memory.

[Visual Basic]
Property Get MaxNumberWaveforms() As Long
[C++]
HRESULT get_MaxNumberWaveforms(long* value);
[ANSI C]
HRESULT IIviRFSigGenArb_get_MaxNumberWaveforms(IIviRFSigGenArb* This, long* value);
[C#]
public long MaxNumberWaveforms {get;}

Capability Group

IviRFSigGenArbGenerator

Related Items

QueryWaveformCapabilities

Also In This Interface

SelectedWaveform | ClockFrequency | FilterFrequency | MaxNumberWaveforms | WaveformQuantum | WaveformSizeMin | WaveformSizeMax | TriggerSource | ExternalTriggerSlope | Configure | WriteWaveform | ClearAllWaveforms | QueryWaveformCapabilities | IIviRFSigGenArb Overview


WaveformQuantum Property

IIviRFSigGenArb.WaveformQuantum Property

The waveform length must be a multiple of this quantum.

[Visual Basic]
Property Get WaveformQuantum() As Long
[C++]
HRESULT get_WaveformQuantum(long* value);
[ANSI C]
HRESULT IIviRFSigGenArb_get_WaveformQuantum(IIviRFSigGenArb* This, long* value);
[C#]
public long WaveformQuantum {get;}

Capability Group

IviRFSigGenArbGenerator

Related Items

QueryWaveformCapabilities

Also In This Interface

SelectedWaveform | ClockFrequency | FilterFrequency | MaxNumberWaveforms | WaveformQuantum | WaveformSizeMin | WaveformSizeMax | TriggerSource | ExternalTriggerSlope | Configure | WriteWaveform | ClearAllWaveforms | QueryWaveformCapabilities | IIviRFSigGenArb Overview


WaveformSizeMin Property

IIviRFSigGenArb.WaveformSizeMin Property

The waveform length must be equal or greater than min size.

[Visual Basic]
Property Get WaveformSizeMin() As Long
[C++]
HRESULT get_WaveformSizeMin(long* value);
[ANSI C]
HRESULT IIviRFSigGenArb_get_WaveformSizeMin(IIviRFSigGenArb* This, long* value);
[C#]
public long WaveformSizeMin {get;}

Capability Group

IviRFSigGenArbGenerator

Related Items

QueryWaveformCapabilities

Also In This Interface

SelectedWaveform | ClockFrequency | FilterFrequency | MaxNumberWaveforms | WaveformQuantum | WaveformSizeMin | WaveformSizeMax | TriggerSource | ExternalTriggerSlope | Configure | WriteWaveform | ClearAllWaveforms | QueryWaveformCapabilities | IIviRFSigGenArb Overview


WaveformSizeMax Property

IIviRFSigGenArb.WaveformSizeMax Property

The waveform length must be equal or less than max size.

[Visual Basic]
Property Get WaveformSizeMax() As Long
[C++]
HRESULT get_WaveformSizeMax(long* value);
[ANSI C]
HRESULT IIviRFSigGenArb_get_WaveformSizeMax(IIviRFSigGenArb* This, long* value);
[C#]
public long WaveformSizeMax {get;}

Capability Group

IviRFSigGenArbGenerator

Related Items

QueryWaveformCapabilities

Also In This Interface

SelectedWaveform | ClockFrequency | FilterFrequency | MaxNumberWaveforms | WaveformQuantum | WaveformSizeMin | WaveformSizeMax | TriggerSource | ExternalTriggerSlope | Configure | WriteWaveform | ClearAllWaveforms | QueryWaveformCapabilities | IIviRFSigGenArb Overview


TriggerSource Property

IIviRFSigGenArb.TriggerSource Property

Specifies the trigger source for the ARB waveform.

[Visual Basic]
Property Get TriggerSource() As IviRFSigGenArbTriggerSourceEnum
Property Let TriggerSource(value As IviRFSigGenArbTriggerSourceEnum)
[C++]
HRESULT get_TriggerSource(IviRFSigGenArbTriggerSourceEnum* value);
HRESULT put_TriggerSource(IviRFSigGenArbTriggerSourceEnum value);
[ANSI C]
HRESULT IIviRFSigGenArb_get_TriggerSource(IIviRFSigGenArb* This, IviRFSigGenArbTriggerSourceEnum* value);
HRESULT IIviRFSigGenArb_put_TriggerSource(IIviRFSigGenArb* This, IviRFSigGenArbTriggerSourceEnum value);
[C#]
public IviRFSigGenArbTriggerSourceEnum TriggerSource {get; set;}

Capability Group

IviRFSigGenArbGenerator

Also In This Interface

SelectedWaveform | ClockFrequency | FilterFrequency | MaxNumberWaveforms | WaveformQuantum | WaveformSizeMin | WaveformSizeMax | TriggerSource | ExternalTriggerSlope | Configure | WriteWaveform | ClearAllWaveforms | QueryWaveformCapabilities | IIviRFSigGenArb Overview


ExternalTriggerSlope Property

IIviRFSigGenArb.ExternalTriggerSlope Property

Specifies whether the trigger event occurs on the rising or falling edge of the input signal.

[Visual Basic]
Property Get ExternalTriggerSlope() As IviRFSigGenArbExternalTriggerSlopeEnum
Property Let ExternalTriggerSlope(value As IviRFSigGenArbExternalTriggerSlopeEnum)
[C++]
HRESULT get_ExternalTriggerSlope(IviRFSigGenArbExternalTriggerSlopeEnum* value);
HRESULT put_ExternalTriggerSlope(IviRFSigGenArbExternalTriggerSlopeEnum value);
[ANSI C]
HRESULT IIviRFSigGenArb_get_ExternalTriggerSlope(IIviRFSigGenArb* This, IviRFSigGenArbExternalTriggerSlopeEnum* value);
HRESULT IIviRFSigGenArb_put_ExternalTriggerSlope(IIviRFSigGenArb* This, IviRFSigGenArbExternalTriggerSlopeEnum value);
[C#]
public IviRFSigGenArbExternalTriggerSlopeEnum ExternalTriggerSlope {get; set;}

Capability Group

IviRFSigGenArbGenerator

Also In This Interface

SelectedWaveform | ClockFrequency | FilterFrequency | MaxNumberWaveforms | WaveformQuantum | WaveformSizeMin | WaveformSizeMax | TriggerSource | ExternalTriggerSlope | Configure | WriteWaveform | ClearAllWaveforms | QueryWaveformCapabilities | IIviRFSigGenArb Overview


Configure Method

IIviRFSigGenArb.Configure Method

This function configures the ARB generator.

[Visual Basic]
Sub Configure( _
   ClockFrequency As Double, _
   FilterFrequency As Double _
)
[C++]
HRESULT Configure(
   double ClockFrequency,
   double FilterFrequency
);
[ANSI C]
HRESULT IIviRFSigGenArb_Configure(
   IIviRFSigGenArb* This
   double ClockFrequency,
   double FilterFrequency
);
[C#]
public void Configure(
   double ClockFrequency,
   double FilterFrequency
);

Parameters

ClockFrequency
The driver uses this value to set the Arb Clock Frequency attribute.
FilterFrequency
The driver uses this value to set the Arb Filter Frequency attribute.

Capability Group

IviRFSigGenArbGenerator

Related Items

ClockFrequency | FilterFrequency

Also In This Interface

SelectedWaveform | ClockFrequency | FilterFrequency | MaxNumberWaveforms | WaveformQuantum | WaveformSizeMin | WaveformSizeMax | TriggerSource | ExternalTriggerSlope | Configure | WriteWaveform | ClearAllWaveforms | QueryWaveformCapabilities | IIviRFSigGenArb Overview


WriteWaveform Method

IIviRFSigGenArb.WriteWaveform Method

This function stores the waveform in the driver's or instrument's memory.

[Visual Basic]
Sub WriteWaveform( _
   Name As String, _
   IData As SAFEARRAY(double)*, _
   QData As SAFEARRAY(double)*, _
   MoreDataPending As Boolean _
)
[C++]
HRESULT WriteWaveform(
   BSTR Name,
   SAFEARRAY(double)* IData,
   SAFEARRAY(double)* QData,
   VARIANT_BOOL MoreDataPending
);
[ANSI C]
HRESULT IIviRFSigGenArb_WriteWaveform(
   IIviRFSigGenArb* This
   BSTR Name,
   SAFEARRAY(double)* IData,
   SAFEARRAY(double)* QData,
   VARIANT_BOOL MoreDataPending
);
[C#]
public void WriteWaveform(
   string Name,
   Array IData,
   Array QData,
   bool MoreDataPending
);

Parameters

Name
The driver uses this value to name the stored waveform.
IData
The driver uses the values of this array as I part of the waveform . The voltages are normalized to {-1, +1} to the full I range.
QData
The driver uses the values of this array as Q part of the waveform . The voltages are normalized to {-1, +1} to the full Q range.
MoreDataPending
The value is set to True if more data is coming. To complete the waveform, the next data shall have the same name. False means the waveform has no more data to come.

Capability Group

IviRFSigGenArbGenerator

Related Items

ClearAllWaveforms

Also In This Interface

SelectedWaveform | ClockFrequency | FilterFrequency | MaxNumberWaveforms | WaveformQuantum | WaveformSizeMin | WaveformSizeMax | TriggerSource | ExternalTriggerSlope | Configure | WriteWaveform | ClearAllWaveforms | QueryWaveformCapabilities | IIviRFSigGenArb Overview


ClearAllWaveforms Method

IIviRFSigGenArb.ClearAllWaveforms Method

This function deletes all waveforms from the pool of waveforms.

[Visual Basic]
Sub ClearAllWaveforms()
[C++]
HRESULT ClearAllWaveforms();
[ANSI C]
HRESULT IIviRFSigGenArb_ClearAllWaveforms(
   IIviRFSigGenArb* This);
[C#]
public void ClearAllWaveforms();

Capability Group

IviRFSigGenArbGenerator

Related Items

WriteWaveform

Also In This Interface

SelectedWaveform | ClockFrequency | FilterFrequency | MaxNumberWaveforms | WaveformQuantum | WaveformSizeMin | WaveformSizeMax | TriggerSource | ExternalTriggerSlope | Configure | WriteWaveform | ClearAllWaveforms | QueryWaveformCapabilities | IIviRFSigGenArb Overview


QueryWaveformCapabilities Method

IIviRFSigGenArb.QueryWaveformCapabilities Method

This function returns the capabilities of the ARB generator.

[Visual Basic]
Sub QueryWaveformCapabilities( _
   MaxNumberWaveforms As Long, _
   WaveformQuantum As Long, _
   MinWaveformSize As Long, _
   MaxWaveformSize As Long _
)
[C++]
HRESULT QueryWaveformCapabilities(
   long* MaxNumberWaveforms,
   long* WaveformQuantum,
   long* MinWaveformSize,
   long* MaxWaveformSize
);
[ANSI C]
HRESULT IIviRFSigGenArb_QueryWaveformCapabilities(
   IIviRFSigGenArb* This
   long* MaxNumberWaveforms,
   long* WaveformQuantum,
   long* MinWaveformSize,
   long* MaxWaveformSize
);
[C#]
public void QueryWaveformCapabilities(
   long MaxNumberWaveforms,
   long WaveformQuantum,
   long MinWaveformSize,
   long MaxWaveformSize
);

Parameters

MaxNumberWaveforms
Returns the Arb Max Number Waveforms attribute.
WaveformQuantum
Returns the Arb Waveform Quantum attribute.
MinWaveformSize
Returns the Arb Min Waveform Size attribute.
MaxWaveformSize
Returns the Arb Max Waveform Size attribute.

Capability Group

IviRFSigGenArbGenerator

Related Items

MaxNumberWaveforms | WaveformQuantum | WaveformSizeMin | WaveformSizeMax

Also In This Interface

SelectedWaveform | ClockFrequency | FilterFrequency | MaxNumberWaveforms | WaveformQuantum | WaveformSizeMin | WaveformSizeMax | TriggerSource | ExternalTriggerSlope | Configure | WriteWaveform | ClearAllWaveforms | QueryWaveformCapabilities | IIviRFSigGenArb Overview


IIviRFSigGenCDMA Interface

IVI RFSigGen class-compliant CDMA base interface

Properties

StandardName | Returns the standard name for the given index.
StandardCount | Returns the count of available standards for CDMA modulation.
SelectedStandard | Specifies the actual standard used by the instrument.
TestModelName | Returns the selected test model name.
TestModelCount | Returns the count of available test models.
SelectedTestModel | Specifies the actual test model used by the instrument.
TriggerSource | Specifies the trigger source for starting the signal generation.
ExternalTriggerSlope | Specifies whether the trigger event occurs on the rising or falling edge of the input signal.
ClockSource | Specifies the source of the clock signal used to generate the digital modulation.


StandardName Property

IIviRFSigGenCDMA.StandardName Property

Returns the standard name for the given index.

[Visual Basic]
Property Get StandardName(Index As Long) As String
[C++]
HRESULT get_StandardName(long Index, BSTR* value);
[ANSI C]
HRESULT IIviRFSigGenCDMA_get_StandardName(IIviRFSigGenCDMA* This, long Index, BSTR* value);
[C#]HRESULT get_StandardName(long Index, string value);

Parameters

Index
A one-based index that defines which name to return.

Capability Group

IviRFSigGenCDMABase

Also In This Interface

StandardName | StandardCount | SelectedStandard | TestModelName | TestModelCount | SelectedTestModel | TriggerSource | ExternalTriggerSlope | ClockSource | IIviRFSigGenCDMA Overview


StandardCount Property

IIviRFSigGenCDMA.StandardCount Property

Returns the count of available standards for CDMA modulation.

[Visual Basic]
Property Get StandardCount() As Long
[C++]
HRESULT get_StandardCount(long* value);
[ANSI C]
HRESULT IIviRFSigGenCDMA_get_StandardCount(IIviRFSigGenCDMA* This, long* value);
[C#]
public long StandardCount {get;}

Capability Group

IviRFSigGenCDMABase

Also In This Interface

StandardName | StandardCount | SelectedStandard | TestModelName | TestModelCount | SelectedTestModel | TriggerSource | ExternalTriggerSlope | ClockSource | IIviRFSigGenCDMA Overview


SelectedStandard Property

IIviRFSigGenCDMA.SelectedStandard Property

Specifies the actual standard used by the instrument.

[Visual Basic]
Property Get SelectedStandard() As String
Property Let SelectedStandard(value As String)
[C++]
HRESULT get_SelectedStandard(BSTR* value);
HRESULT put_SelectedStandard(BSTR value);
[ANSI C]
HRESULT IIviRFSigGenCDMA_get_SelectedStandard(IIviRFSigGenCDMA* This, BSTR* value);
HRESULT IIviRFSigGenCDMA_put_SelectedStandard(IIviRFSigGenCDMA* This, BSTR value);
[C#]
public string SelectedStandard {get; set;}

Capability Group

IviRFSigGenCDMABase

Also In This Interface

StandardName | StandardCount | SelectedStandard | TestModelName | TestModelCount | SelectedTestModel | TriggerSource | ExternalTriggerSlope | ClockSource | IIviRFSigGenCDMA Overview


TestModelName Property

IIviRFSigGenCDMA.TestModelName Property

Returns the selected test model name.

[Visual Basic]
Property Get TestModelName(Index As Long) As String
[C++]
HRESULT get_TestModelName(long Index, BSTR* value);
[ANSI C]
HRESULT IIviRFSigGenCDMA_get_TestModelName(IIviRFSigGenCDMA* This, long Index, BSTR* value);
[C#]HRESULT get_TestModelName(long Index, string value);

Parameters

Index
A one-based index that defines which name to return.

Capability Group

IviRFSigGenCDMABase

Also In This Interface

StandardName | StandardCount | SelectedStandard | TestModelName | TestModelCount | SelectedTestModel | TriggerSource | ExternalTriggerSlope | ClockSource | IIviRFSigGenCDMA Overview


TestModelCount Property

IIviRFSigGenCDMA.TestModelCount Property

Returns the count of available test models.

[Visual Basic]
Property Get TestModelCount() As Long
[C++]
HRESULT get_TestModelCount(long* value);
[ANSI C]
HRESULT IIviRFSigGenCDMA_get_TestModelCount(IIviRFSigGenCDMA* This, long* value);
[C#]
public long TestModelCount {get;}

Capability Group

IviRFSigGenCDMABase

Also In This Interface

StandardName | StandardCount | SelectedStandard | TestModelName | TestModelCount | SelectedTestModel | TriggerSource | ExternalTriggerSlope | ClockSource | IIviRFSigGenCDMA Overview


SelectedTestModel Property

IIviRFSigGenCDMA.SelectedTestModel Property

Specifies the actual test model used by the instrument.

[Visual Basic]
Property Get SelectedTestModel() As String
Property Let SelectedTestModel(value As String)
[C++]
HRESULT get_SelectedTestModel(BSTR* value);
HRESULT put_SelectedTestModel(BSTR value);
[ANSI C]
HRESULT IIviRFSigGenCDMA_get_SelectedTestModel(IIviRFSigGenCDMA* This, BSTR* value);
HRESULT IIviRFSigGenCDMA_put_SelectedTestModel(IIviRFSigGenCDMA* This, BSTR value);
[C#]
public string SelectedTestModel {get; set;}

Capability Group

IviRFSigGenCDMABase

Also In This Interface

StandardName | StandardCount | SelectedStandard | TestModelName | TestModelCount | SelectedTestModel | TriggerSource | ExternalTriggerSlope | ClockSource | IIviRFSigGenCDMA Overview


TriggerSource Property

IIviRFSigGenCDMA.TriggerSource Property

Specifies the trigger source for starting the signal generation.

[Visual Basic]
Property Get TriggerSource() As IviRFSigGenCDMATriggerSourceEnum
Property Let TriggerSource(value As IviRFSigGenCDMATriggerSourceEnum)
[C++]
HRESULT get_TriggerSource(IviRFSigGenCDMATriggerSourceEnum* value);
HRESULT put_TriggerSource(IviRFSigGenCDMATriggerSourceEnum value);
[ANSI C]
HRESULT IIviRFSigGenCDMA_get_TriggerSource(IIviRFSigGenCDMA* This, IviRFSigGenCDMATriggerSourceEnum* value);
HRESULT IIviRFSigGenCDMA_put_TriggerSource(IIviRFSigGenCDMA* This, IviRFSigGenCDMATriggerSourceEnum value);
[C#]
public IviRFSigGenCDMATriggerSourceEnum TriggerSource {get; set;}

Capability Group

IviRFSigGenCDMABase

Also In This Interface

StandardName | StandardCount | SelectedStandard | TestModelName | TestModelCount | SelectedTestModel | TriggerSource | ExternalTriggerSlope | ClockSource | IIviRFSigGenCDMA Overview


ExternalTriggerSlope Property

IIviRFSigGenCDMA.ExternalTriggerSlope Property

Specifies whether the trigger event occurs on the rising or falling edge of the input signal.

[Visual Basic]
Property Get ExternalTriggerSlope() As IviRFSigGenCDMAExternalTriggerSlopeEnum
Property Let ExternalTriggerSlope(value As IviRFSigGenCDMAExternalTriggerSlopeEnum)
[C++]
HRESULT get_ExternalTriggerSlope(IviRFSigGenCDMAExternalTriggerSlopeEnum* value);
HRESULT put_ExternalTriggerSlope(IviRFSigGenCDMAExternalTriggerSlopeEnum value);
[ANSI C]
HRESULT IIviRFSigGenCDMA_get_ExternalTriggerSlope(IIviRFSigGenCDMA* This, IviRFSigGenCDMAExternalTriggerSlopeEnum* value);
HRESULT IIviRFSigGenCDMA_put_ExternalTriggerSlope(IIviRFSigGenCDMA* This, IviRFSigGenCDMAExternalTriggerSlopeEnum value);
[C#]
public IviRFSigGenCDMAExternalTriggerSlopeEnum ExternalTriggerSlope {get; set;}

Capability Group

IviRFSigGenCDMABase

Also In This Interface

StandardName | StandardCount | SelectedStandard | TestModelName | TestModelCount | SelectedTestModel | TriggerSource | ExternalTriggerSlope | ClockSource | IIviRFSigGenCDMA Overview


ClockSource Property

IIviRFSigGenCDMA.ClockSource Property

Specifies the source of the clock signal used to generate the digital modulation.

[Visual Basic]
Property Get ClockSource() As IviRFSigGenCDMAClockSourceEnum
Property Let ClockSource(value As IviRFSigGenCDMAClockSourceEnum)
[C++]
HRESULT get_ClockSource(IviRFSigGenCDMAClockSourceEnum* value);
HRESULT put_ClockSource(IviRFSigGenCDMAClockSourceEnum value);
[ANSI C]
HRESULT IIviRFSigGenCDMA_get_ClockSource(IIviRFSigGenCDMA* This, IviRFSigGenCDMAClockSourceEnum* value);
HRESULT IIviRFSigGenCDMA_put_ClockSource(IIviRFSigGenCDMA* This, IviRFSigGenCDMAClockSourceEnum value);
[C#]
public IviRFSigGenCDMAClockSourceEnum ClockSource {get; set;}

Capability Group

IviRFSigGenCDMABase

Also In This Interface

StandardName | StandardCount | SelectedStandard | TestModelName | TestModelCount | SelectedTestModel | TriggerSource | ExternalTriggerSlope | ClockSource | IIviRFSigGenCDMA Overview


IIviRFSigGenDigitalModulation Interface

IVI RFSigGen class-compliant digital modulation interface

Properties

Arb | Pointer to the class-compliant IIviRFSigGenArb interface
Base | Pointer to the class-compliant IIviRFSigGenDigitalModulationBase interface
TDMA | Pointer to the class-compliant IIviRFSigGenTDMA interface
CDMA | Pointer to the class-compliant IIviRFSigGenCDMA interface


Arb Property

IIviRFSigGenDigitalModulation.Arb Property

Pointer to the class-compliant IIviRFSigGenArb interface

[Visual Basic]
Property Get Arb() As IIviRFSigGenArb
[C++]
HRESULT get_Arb(IIviRFSigGenArb** value);
[ANSI C]
HRESULT IIviRFSigGenDigitalModulation_get_Arb(IIviRFSigGenDigitalModulation* This, IIviRFSigGenArb** value);
[C#]
public IIviRFSigGenArb Arb {get;}

Capability Group

IviRFSigGenArbGenerator

Also In This Interface

Arb | Base | TDMA | CDMA | IIviRFSigGenDigitalModulation Overview


Base Property

IIviRFSigGenDigitalModulation.Base Property

Pointer to the class-compliant IIviRFSigGenDigitalModulationBase interface

[Visual Basic]
Property Get Base() As IIviRFSigGenDigitalModulationBase
[C++]
HRESULT get_Base(IIviRFSigGenDigitalModulationBase** value);
[ANSI C]
HRESULT IIviRFSigGenDigitalModulation_get_Base(IIviRFSigGenDigitalModulation* This, IIviRFSigGenDigitalModulationBase** value);
[C#]
public IIviRFSigGenDigitalModulationBase Base {get;}

Capability Group

IviRFSigGenDigitalModulationBase

Also In This Interface

Arb | Base | TDMA | CDMA | IIviRFSigGenDigitalModulation Overview


TDMA Property

IIviRFSigGenDigitalModulation.TDMA Property

Pointer to the class-compliant IIviRFSigGenTDMA interface

[Visual Basic]
Property Get TDMA() As IIviRFSigGenTDMA
[C++]
HRESULT get_TDMA(IIviRFSigGenTDMA** value);
[ANSI C]
HRESULT IIviRFSigGenDigitalModulation_get_TDMA(IIviRFSigGenDigitalModulation* This, IIviRFSigGenTDMA** value);
[C#]
public IIviRFSigGenTDMA TDMA {get;}

Capability Group

IviRFSigGenTDMABase

Also In This Interface

Arb | Base | TDMA | CDMA | IIviRFSigGenDigitalModulation Overview


CDMA Property

IIviRFSigGenDigitalModulation.CDMA Property

Pointer to the class-compliant IIviRFSigGenCDMA interface

[Visual Basic]
Property Get CDMA() As IIviRFSigGenCDMA
[C++]
HRESULT get_CDMA(IIviRFSigGenCDMA** value);
[ANSI C]
HRESULT IIviRFSigGenDigitalModulation_get_CDMA(IIviRFSigGenDigitalModulation* This, IIviRFSigGenCDMA** value);
[C#]
public IIviRFSigGenCDMA CDMA {get;}

Capability Group

IviRFSigGenCDMABase

Also In This Interface

Arb | Base | TDMA | CDMA | IIviRFSigGenDigitalModulation Overview


IIviRFSigGenDigitalModulationBase Interface

IVI RFSigGen class-compliant digital modulation base interface

Properties

StandardName | Returns the standard name for the given index. (]
StandardCount | Returns the count of available standards for digital base modulation.
SelectedStandard | Specifies the actual standard used by the instrument.
DataSource | Specifies the source of data for digital base modulation.
PRBSType | Specifies the type of PRBS for digital base modulation.
SelectedBitSequence | Specifies name of bit sequence used as data for digital modulation.
ClockSource | Specifies the source of the clock signal used to generate the digital modulation according to the selected standard.
ExternalClockType | Specifies the type of the external clock signal used to generate the digital modulation.

Methods

ConfigureClockSource | This function configures the clock source.
WriteBitSequence | This function writes the bit sequence used as data for the digital base modulation.
ClearAllBitSequences | This function deletes all named bit sequences.


StandardName Property

IIviRFSigGenDigitalModulationBase.StandardName Property

Returns the standard name for the given index. (]

[Visual Basic]
Property Get StandardName(Index As Long) As String
[C++]
HRESULT get_StandardName(long Index, BSTR* value);
[ANSI C]
HRESULT IIviRFSigGenDigitalModulationBase_get_StandardName(IIviRFSigGenDigitalModulationBase* This, long Index, BSTR* value);
[C#]HRESULT get_StandardName(long Index, string value);

Parameters

Index
A one-based index that defines which name to return.

Capability Group

IviRFSigGenDigitalModulationBase

Also In This Interface

StandardName | StandardCount | SelectedStandard | DataSource | PRBSType | SelectedBitSequence | ClockSource | ExternalClockType | ConfigureClockSource | WriteBitSequence | ClearAllBitSequences | IIviRFSigGenDigitalModulationBase Overview


StandardCount Property

IIviRFSigGenDigitalModulationBase.StandardCount Property

Returns the count of available standards for digital base modulation.

[Visual Basic]
Property Get StandardCount() As Long
[C++]
HRESULT get_StandardCount(long* value);
[ANSI C]
HRESULT IIviRFSigGenDigitalModulationBase_get_StandardCount(IIviRFSigGenDigitalModulationBase* This, long* value);
[C#]
public long StandardCount {get;}

Capability Group

IviRFSigGenDigitalModulationBase

Also In This Interface

StandardName | StandardCount | SelectedStandard | DataSource | PRBSType | SelectedBitSequence | ClockSource | ExternalClockType | ConfigureClockSource | WriteBitSequence | ClearAllBitSequences | IIviRFSigGenDigitalModulationBase Overview


SelectedStandard Property

IIviRFSigGenDigitalModulationBase.SelectedStandard Property

Specifies the actual standard used by the instrument.

[Visual Basic]
Property Get SelectedStandard() As String
Property Let SelectedStandard(value As String)
[C++]
HRESULT get_SelectedStandard(BSTR* value);
HRESULT put_SelectedStandard(BSTR value);
[ANSI C]
HRESULT IIviRFSigGenDigitalModulationBase_get_SelectedStandard(IIviRFSigGenDigitalModulationBase* This, BSTR* value);
HRESULT IIviRFSigGenDigitalModulationBase_put_SelectedStandard(IIviRFSigGenDigitalModulationBase* This, BSTR value);
[C#]
public string SelectedStandard {get; set;}

Capability Group

IviRFSigGenDigitalModulationBase

Also In This Interface

StandardName | StandardCount | SelectedStandard | DataSource | PRBSType | SelectedBitSequence | ClockSource | ExternalClockType | ConfigureClockSource | WriteBitSequence | ClearAllBitSequences | IIviRFSigGenDigitalModulationBase Overview


DataSource Property

IIviRFSigGenDigitalModulationBase.DataSource Property

Specifies the source of data for digital base modulation.

[Visual Basic]
Property Get DataSource() As IviRFSigGenDigitalModulationBaseDataSourceEnum
Property Let DataSource(value As IviRFSigGenDigitalModulationBaseDataSourceEnum)
[C++]
HRESULT get_DataSource(IviRFSigGenDigitalModulationBaseDataSourceEnum* value);
HRESULT put_DataSource(IviRFSigGenDigitalModulationBaseDataSourceEnum value);
[ANSI C]
HRESULT IIviRFSigGenDigitalModulationBase_get_DataSource(IIviRFSigGenDigitalModulationBase* This, IviRFSigGenDigitalModulationBaseDataSourceEnum* value);
HRESULT IIviRFSigGenDigitalModulationBase_put_DataSource(IIviRFSigGenDigitalModulationBase* This, IviRFSigGenDigitalModulationBaseDataSourceEnum value);
[C#]
public IviRFSigGenDigitalModulationBaseDataSourceEnum DataSource {get; set;}

Capability Group

IviRFSigGenDigitalModulationBase

Also In This Interface

StandardName | StandardCount | SelectedStandard | DataSource | PRBSType | SelectedBitSequence | ClockSource | ExternalClockType | ConfigureClockSource | WriteBitSequence | ClearAllBitSequences | IIviRFSigGenDigitalModulationBase Overview


PRBSType Property

IIviRFSigGenDigitalModulationBase.PRBSType Property

Specifies the type of PRBS for digital base modulation.

[Visual Basic]
Property Get PRBSType() As IviRFSigGenDigitalModulationBasePRBSTypeEnum
Property Let PRBSType(value As IviRFSigGenDigitalModulationBasePRBSTypeEnum)
[C++]
HRESULT get_PRBSType(IviRFSigGenDigitalModulationBasePRBSTypeEnum* value);
HRESULT put_PRBSType(IviRFSigGenDigitalModulationBasePRBSTypeEnum value);
[ANSI C]
HRESULT IIviRFSigGenDigitalModulationBase_get_PRBSType(IIviRFSigGenDigitalModulationBase* This, IviRFSigGenDigitalModulationBasePRBSTypeEnum* value);
HRESULT IIviRFSigGenDigitalModulationBase_put_PRBSType(IIviRFSigGenDigitalModulationBase* This, IviRFSigGenDigitalModulationBasePRBSTypeEnum value);
[C#]
public IviRFSigGenDigitalModulationBasePRBSTypeEnum PRBSType {get; set;}

Capability Group

IviRFSigGenDigitalModulationBase

Also In This Interface

StandardName | StandardCount | SelectedStandard | DataSource | PRBSType | SelectedBitSequence | ClockSource | ExternalClockType | ConfigureClockSource | WriteBitSequence | ClearAllBitSequences | IIviRFSigGenDigitalModulationBase Overview


SelectedBitSequence Property

IIviRFSigGenDigitalModulationBase.SelectedBitSequence Property

Specifies name of bit sequence used as data for digital modulation.

[Visual Basic]
Property Get SelectedBitSequence() As String
Property Let SelectedBitSequence(value As String)
[C++]
HRESULT get_SelectedBitSequence(BSTR* value);
HRESULT put_SelectedBitSequence(BSTR value);
[ANSI C]
HRESULT IIviRFSigGenDigitalModulationBase_get_SelectedBitSequence(IIviRFSigGenDigitalModulationBase* This, BSTR* value);
HRESULT IIviRFSigGenDigitalModulationBase_put_SelectedBitSequence(IIviRFSigGenDigitalModulationBase* This, BSTR value);
[C#]
public string SelectedBitSequence {get; set;}

Capability Group

IviRFSigGenDigitalModulationBase

Also In This Interface

StandardName | StandardCount | SelectedStandard | DataSource | PRBSType | SelectedBitSequence | ClockSource | ExternalClockType | ConfigureClockSource | WriteBitSequence | ClearAllBitSequences | IIviRFSigGenDigitalModulationBase Overview


ClockSource Property

IIviRFSigGenDigitalModulationBase.ClockSource Property

Specifies the source of the clock signal used to generate the digital modulation according to the selected standard.

[Visual Basic]
Property Get ClockSource() As IviRFSigGenDigitalModulationBaseClockSourceEnum
Property Let ClockSource(value As IviRFSigGenDigitalModulationBaseClockSourceEnum)
[C++]
HRESULT get_ClockSource(IviRFSigGenDigitalModulationBaseClockSourceEnum* value);
HRESULT put_ClockSource(IviRFSigGenDigitalModulationBaseClockSourceEnum value);
[ANSI C]
HRESULT IIviRFSigGenDigitalModulationBase_get_ClockSource(IIviRFSigGenDigitalModulationBase* This, IviRFSigGenDigitalModulationBaseClockSourceEnum* value);
HRESULT IIviRFSigGenDigitalModulationBase_put_ClockSource(IIviRFSigGenDigitalModulationBase* This, IviRFSigGenDigitalModulationBaseClockSourceEnum value);
[C#]
public IviRFSigGenDigitalModulationBaseClockSourceEnum ClockSource {get; set;}

Capability Group

IviRFSigGenDigitalModulationBase

Related Items

ConfigureClockSource

Also In This Interface

StandardName | StandardCount | SelectedStandard | DataSource | PRBSType | SelectedBitSequence | ClockSource | ExternalClockType | ConfigureClockSource | WriteBitSequence | ClearAllBitSequences | IIviRFSigGenDigitalModulationBase Overview


ExternalClockType Property

IIviRFSigGenDigitalModulationBase.ExternalClockType Property

Specifies the type of the external clock signal used to generate the digital modulation.

[Visual Basic]
Property Get ExternalClockType() As IviRFSigGenDigitalModulationBaseExternalClockTypeEnum
Property Let ExternalClockType(value As IviRFSigGenDigitalModulationBaseExternalClockTypeEnum)
[C++]
HRESULT get_ExternalClockType(IviRFSigGenDigitalModulationBaseExternalClockTypeEnum* value);
HRESULT put_ExternalClockType(IviRFSigGenDigitalModulationBaseExternalClockTypeEnum value);
[ANSI C]
HRESULT IIviRFSigGenDigitalModulationBase_get_ExternalClockType(IIviRFSigGenDigitalModulationBase* This, IviRFSigGenDigitalModulationBaseExternalClockTypeEnum* value);
HRESULT IIviRFSigGenDigitalModulationBase_put_ExternalClockType(IIviRFSigGenDigitalModulationBase* This, IviRFSigGenDigitalModulationBaseExternalClockTypeEnum value);
[C#]
public IviRFSigGenDigitalModulationBaseExternalClockTypeEnum ExternalClockType {get; set;}

Capability Group

IviRFSigGenDigitalModulationBase

Related Items

ConfigureClockSource

Also In This Interface

StandardName | StandardCount | SelectedStandard | DataSource | PRBSType | SelectedBitSequence | ClockSource | ExternalClockType | ConfigureClockSource | WriteBitSequence | ClearAllBitSequences | IIviRFSigGenDigitalModulationBase Overview


ConfigureClockSource Method

IIviRFSigGenDigitalModulationBase.ConfigureClockSource Method

This function configures the clock source.

[Visual Basic]
Sub ConfigureClockSource( _
   Source As IviRFSigGenDigitalModulationBaseClockSourceEnum, _
   Type As IviRFSigGenDigitalModulationBaseExternalClockTypeEnum _
)
[C++]
HRESULT ConfigureClockSource(
   IviRFSigGenDigitalModulationBaseClockSourceEnum Source,
   IviRFSigGenDigitalModulationBaseExternalClockTypeEnum Type
);
[ANSI C]
HRESULT IIviRFSigGenDigitalModulationBase_ConfigureClockSource(
   IIviRFSigGenDigitalModulationBase* This
   IviRFSigGenDigitalModulationBaseClockSourceEnum Source,
   IviRFSigGenDigitalModulationBaseExternalClockTypeEnum Type
);
[C#]
public void ConfigureClockSource(
   IviRFSigGenDigitalModulationBaseClockSourceEnum Source,
   IviRFSigGenDigitalModulationBaseExternalClockTypeEnum Type
);

Parameters

Source
The driver uses this value to set the DigitalModulationBase Clock Source attribute.
Type
Type is ignored if Source is set to Internal.The driver uses this value to set the DigitalModulationBase External Clock Type attribute.

Capability Group

IviRFSigGenDigitalModulationBase

Related Items

ClockSource | ExternalClockType

Also In This Interface

StandardName | StandardCount | SelectedStandard | DataSource | PRBSType | SelectedBitSequence | ClockSource | ExternalClockType | ConfigureClockSource | WriteBitSequence | ClearAllBitSequences | IIviRFSigGenDigitalModulationBase Overview


WriteBitSequence Method

IIviRFSigGenDigitalModulationBase.WriteBitSequence Method

This function writes the bit sequence used as data for the digital base modulation.

[Visual Basic]
Sub WriteBitSequence( _
   Name As String, _
   BitCount As Long, _
   Sequence As SAFEARRAY(BYTE)*, _
   MoreDataPending As Boolean _
)
[C++]
HRESULT WriteBitSequence(
   BSTR Name,
   long BitCount,
   SAFEARRAY(BYTE)* Sequence,
   VARIANT_BOOL MoreDataPending
);
[ANSI C]
HRESULT IIviRFSigGenDigitalModulationBase_WriteBitSequence(
   IIviRFSigGenDigitalModulationBase* This
   BSTR Name,
   long BitCount,
   SAFEARRAY(BYTE)* Sequence,
   VARIANT_BOOL MoreDataPending
);
[C#]
public void WriteBitSequence(
   string Name,
   long BitCount,
   Array Sequence,
   bool MoreDataPending
);

Parameters

Name
The driver uses this value to name the stored bit sequence.
BitCount
The number of bits in the sequence. One char/byte has 8 bits, but the stream of bits doesn't end necessarily on byte boundaries.
Sequence
The driver uses this array as stream of bits. The size of the array is bitCount.
MoreDataPending
The value is set to True if more data is comming. To complete the sequence, the next data shall have the same name. False means the waveform has no more data to come.

Capability Group

IviRFSigGenDigitalModulationBase

Also In This Interface

StandardName | StandardCount | SelectedStandard | DataSource | PRBSType | SelectedBitSequence | ClockSource | ExternalClockType | ConfigureClockSource | WriteBitSequence | ClearAllBitSequences | IIviRFSigGenDigitalModulationBase Overview


ClearAllBitSequences Method

IIviRFSigGenDigitalModulationBase.ClearAllBitSequences Method

This function deletes all named bit sequences.

[Visual Basic]
Sub ClearAllBitSequences()
[C++]
HRESULT ClearAllBitSequences();
[ANSI C]
HRESULT IIviRFSigGenDigitalModulationBase_ClearAllBitSequences(
   IIviRFSigGenDigitalModulationBase* This);
[C#]
public void ClearAllBitSequences();

Capability Group

IviRFSigGenDigitalModulationBase

Also In This Interface

StandardName | StandardCount | SelectedStandard | DataSource | PRBSType | SelectedBitSequence | ClockSource | ExternalClockType | ConfigureClockSource | WriteBitSequence | ClearAllBitSequences | IIviRFSigGenDigitalModulationBase Overview


IIviRFSigGenFM Interface

IVI RFSigGen class-compliant frequency modulation interface

Properties

Source | Specifies the source of the signal that is used as the modulating signal.
Deviation | Specifies the extent of modulation (peak frequency deviation) the signal generator applies to the RF-signal.
NominalVoltage | Returns the voltage at which the instrument achieves the amount of modulation specified by the FM Deviation attribute.
Enabled | Specifies whether the signal generator enables or disables frequency modulation of the RF output signal.
ExternalCoupling | Specifies the coupling of the external source of the modulating signal.

Methods

Configure This function configures the attributes that control the signal generator's frequency modulation.


Source Property

IIviRFSigGenFM.Source Property

Specifies the source of the signal that is used as the modulating signal.

[Visual Basic]
Property Get Source() As String
Property Let Source(value As String)
[C++]
HRESULT get_Source(BSTR* value);
HRESULT put_Source(BSTR value);
[ANSI C]
HRESULT IIviRFSigGenFM_get_Source(IIviRFSigGenFM* This, BSTR* value);
HRESULT IIviRFSigGenFM_put_Source(IIviRFSigGenFM* This, BSTR value);
[C#]
public string Source {get; set;}

Capability Group

IviRFSigGenModulateFM

Related Items

Configure

Also In This Interface

Source | Deviation | NominalVoltage | Enabled | ExternalCoupling | Configure | IIviRFSigGenFM Overview


Deviation Property

IIviRFSigGenFM.Deviation Property

Specifies the extent of modulation (peak frequency deviation) the signal generator applies to the RF-signal.

[Visual Basic]
Property Get Deviation() As Double
Property Let Deviation(value As Double)
[C++]
HRESULT get_Deviation(double* value);
HRESULT put_Deviation(double value);
[ANSI C]
HRESULT IIviRFSigGenFM_get_Deviation(IIviRFSigGenFM* This, double* value);
HRESULT IIviRFSigGenFM_put_Deviation(IIviRFSigGenFM* This, double value);
[C#]
public double Deviation {get; set;}

Capability Group

IviRFSigGenModulateFM

Related Items

Configure

Also In This Interface

Source | Deviation | NominalVoltage | Enabled | ExternalCoupling | Configure | IIviRFSigGenFM Overview


NominalVoltage Property

IIviRFSigGenFM.NominalVoltage Property

Returns the voltage at which the instrument achieves the amount of modulation specified by the FM Deviation attribute.

[Visual Basic]
Property Get NominalVoltage() As Double
[C++]
HRESULT get_NominalVoltage(double* value);
[ANSI C]
HRESULT IIviRFSigGenFM_get_NominalVoltage(IIviRFSigGenFM* This, double* value);
[C#]
public double NominalVoltage {get;}

Capability Group

IviRFSigGenModulateFM

Also In This Interface

Source | Deviation | NominalVoltage | Enabled | ExternalCoupling | Configure | IIviRFSigGenFM Overview


Enabled Property

IIviRFSigGenFM.Enabled Property

Specifies whether the signal generator enables or disables frequency modulation of the RF output signal.

[Visual Basic]
Property Get Enabled() As Boolean
Property Let Enabled(value As Boolean)
[C++]
HRESULT get_Enabled(VARIANT_BOOL* value);
HRESULT put_Enabled(VARIANT_BOOL value);
[ANSI C]
HRESULT IIviRFSigGenFM_get_Enabled(IIviRFSigGenFM* This, VARIANT_BOOL* value);
HRESULT IIviRFSigGenFM_put_Enabled(IIviRFSigGenFM* This, VARIANT_BOOL value);
[C#]
public bool Enabled {get; set;}

Capability Group

IviRFSigGenModulateFM

Also In This Interface

Source | Deviation | NominalVoltage | Enabled | ExternalCoupling | Configure | IIviRFSigGenFM Overview


ExternalCoupling Property

IIviRFSigGenFM.ExternalCoupling Property

Specifies the coupling of the external source of the modulating signal.

[Visual Basic]
Property Get ExternalCoupling() As IviRFSigGenFMExternalCouplingEnum
Property Let ExternalCoupling(value As IviRFSigGenFMExternalCouplingEnum)
[C++]
HRESULT get_ExternalCoupling(IviRFSigGenFMExternalCouplingEnum* value);
HRESULT put_ExternalCoupling(IviRFSigGenFMExternalCouplingEnum value);
[ANSI C]
HRESULT IIviRFSigGenFM_get_ExternalCoupling(IIviRFSigGenFM* This, IviRFSigGenFMExternalCouplingEnum* value);
HRESULT IIviRFSigGenFM_put_ExternalCoupling(IIviRFSigGenFM* This, IviRFSigGenFMExternalCouplingEnum value);
[C#]
public IviRFSigGenFMExternalCouplingEnum ExternalCoupling {get; set;}

Capability Group

IviRFSigGenModulateFM

Also In This Interface

Source | Deviation | NominalVoltage | Enabled | ExternalCoupling | Configure | IIviRFSigGenFM Overview


Configure Method

IIviRFSigGenFM.Configure Method

This function configures the attributes that control the signal generator's frequency modulation.

[Visual Basic]
Sub Configure( _
   Source As String, _
   Deviation As Double _
)
[C++]
HRESULT Configure(
   BSTR Source,
   double Deviation
);
[ANSI C]
HRESULT IIviRFSigGenFM_Configure(
   IIviRFSigGenFM* This
   BSTR Source,
   double Deviation
);
[C#]
public void Configure(
   string Source,
   double Deviation
);

Parameters

Source
Deviation

Capability Group

IviRFSigGenModulateFM

Related Items

Source | Deviation

Also In This Interface

Source | Deviation | NominalVoltage | Enabled | ExternalCoupling | Configure | IIviRFSigGenFM Overview


IIviRFSigGenFrequencyStep Interface

IVI RFSigGen class-compliant frequency step interface

Properties

Start | Specifies the start frequency of the stepped sweep.
Stop | Specifies the stop frequency of the stepped sweep.
Scaling | Specifies the spacing of the steps.
Size | Specifies the step size.
SingleStepEnabled | Turns single step on/off.
Dwell | Specifies the duration of one step.

Methods

ConfigureStartStop | This function configures the attributes that control the step frequencies of the generator's RF output signal.
ConfigureDwell | This function configures the attributes that control the stepping.
Reset | This function resets the stepping if single step is enabled.


Start Property

IIviRFSigGenFrequencyStep.Start Property

Specifies the start frequency of the stepped sweep.

[Visual Basic]
Property Get Start() As Double
Property Let Start(value As Double)
[C++]
HRESULT get_Start(double* value);
HRESULT put_Start(double value);
[ANSI C]
HRESULT IIviRFSigGenFrequencyStep_get_Start(IIviRFSigGenFrequencyStep* This, double* value);
HRESULT IIviRFSigGenFrequencyStep_put_Start(IIviRFSigGenFrequencyStep* This, double value);
[C#]
public double Start {get; set;}

Capability Group

IviRFSigGenFrequencyStep

Related Items

ConfigureStartStop

Also In This Interface

Start | Stop | Scaling | Size | SingleStepEnabled | Dwell | ConfigureStartStop | ConfigureDwell | Reset | IIviRFSigGenFrequencyStep Overview


Stop Property

IIviRFSigGenFrequencyStep.Stop Property

Specifies the stop frequency of the stepped sweep.

[Visual Basic]
Property Get Stop() As Double
Property Let Stop(value As Double)
[C++]
HRESULT get_Stop(double* value);
HRESULT put_Stop(double value);
[ANSI C]
HRESULT IIviRFSigGenFrequencyStep_get_Stop(IIviRFSigGenFrequencyStep* This, double* value);
HRESULT IIviRFSigGenFrequencyStep_put_Stop(IIviRFSigGenFrequencyStep* This, double value);
[C#]
public double Stop {get; set;}

Capability Group

IviRFSigGenFrequencyStep

Related Items

ConfigureStartStop

Also In This Interface

Start | Stop | Scaling | Size | SingleStepEnabled | Dwell | ConfigureStartStop | ConfigureDwell | Reset | IIviRFSigGenFrequencyStep Overview


Scaling Property

IIviRFSigGenFrequencyStep.Scaling Property

Specifies the spacing of the steps.

[Visual Basic]
Property Get Scaling() As IviRFSigGenFrequencyStepScalingEnum
Property Let Scaling(value As IviRFSigGenFrequencyStepScalingEnum)
[C++]
HRESULT get_Scaling(IviRFSigGenFrequencyStepScalingEnum* value);
HRESULT put_Scaling(IviRFSigGenFrequencyStepScalingEnum value);
[ANSI C]
HRESULT IIviRFSigGenFrequencyStep_get_Scaling(IIviRFSigGenFrequencyStep* This, IviRFSigGenFrequencyStepScalingEnum* value);
HRESULT IIviRFSigGenFrequencyStep_put_Scaling(IIviRFSigGenFrequencyStep* This, IviRFSigGenFrequencyStepScalingEnum value);
[C#]
public IviRFSigGenFrequencyStepScalingEnum Scaling {get; set;}

Capability Group

IviRFSigGenFrequencyStep

Related Items

ConfigureStartStop

Also In This Interface

Start | Stop | Scaling | Size | SingleStepEnabled | Dwell | ConfigureStartStop | ConfigureDwell | Reset | IIviRFSigGenFrequencyStep Overview


Size Property

IIviRFSigGenFrequencyStep.Size Property

Specifies the step size.

[Visual Basic]
Property Get Size() As Double
Property Let Size(value As Double)
[C++]
HRESULT get_Size(double* value);
HRESULT put_Size(double value);
[ANSI C]
HRESULT IIviRFSigGenFrequencyStep_get_Size(IIviRFSigGenFrequencyStep* This, double* value);
HRESULT IIviRFSigGenFrequencyStep_put_Size(IIviRFSigGenFrequencyStep* This, double value);
[C#]
public double Size {get; set;}

Capability Group

IviRFSigGenFrequencyStep

Related Items

ConfigureStartStop

Also In This Interface

Start | Stop | Scaling | Size | SingleStepEnabled | Dwell | ConfigureStartStop | ConfigureDwell | Reset | IIviRFSigGenFrequencyStep Overview


SingleStepEnabled Property

IIviRFSigGenFrequencyStep.SingleStepEnabled Property

Turns single step on/off.

[Visual Basic]
Property Get SingleStepEnabled() As Boolean
Property Let SingleStepEnabled(value As Boolean)
[C++]
HRESULT get_SingleStepEnabled(VARIANT_BOOL* value);
HRESULT put_SingleStepEnabled(VARIANT_BOOL value);
[ANSI C]
HRESULT IIviRFSigGenFrequencyStep_get_SingleStepEnabled(IIviRFSigGenFrequencyStep* This, VARIANT_BOOL* value);
HRESULT IIviRFSigGenFrequencyStep_put_SingleStepEnabled(IIviRFSigGenFrequencyStep* This, VARIANT_BOOL value);
[C#]
public bool SingleStepEnabled {get; set;}

Capability Group

IviRFSigGenFrequencyStep

Related Items

ConfigureDwell

Also In This Interface

Start | Stop | Scaling | Size | SingleStepEnabled | Dwell | ConfigureStartStop | ConfigureDwell | Reset | IIviRFSigGenFrequencyStep Overview


Dwell Property

IIviRFSigGenFrequencyStep.Dwell Property

Specifies the duration of one step.

[Visual Basic]
Property Get Dwell() As Double
Property Let Dwell(value As Double)
[C++]
HRESULT get_Dwell(double* value);
HRESULT put_Dwell(double value);
[ANSI C]
HRESULT IIviRFSigGenFrequencyStep_get_Dwell(IIviRFSigGenFrequencyStep* This, double* value);
HRESULT IIviRFSigGenFrequencyStep_put_Dwell(IIviRFSigGenFrequencyStep* This, double value);
[C#]
public double Dwell {get; set;}

Capability Group

IviRFSigGenFrequencyStep

Related Items

ConfigureDwell

Also In This Interface

Start | Stop | Scaling | Size | SingleStepEnabled | Dwell | ConfigureStartStop | ConfigureDwell | Reset | IIviRFSigGenFrequencyStep Overview


ConfigureStartStop Method

IIviRFSigGenFrequencyStep.ConfigureStartStop Method

This function configures the attributes that control the step frequencies of the generator's RF output signal.

[Visual Basic]
Sub ConfigureStartStop( _
   Start As Double, _
   Stop As Double, _
   Scaling As IviRFSigGenFrequencyStepScalingEnum, _
   StepSize As Double _
)
[C++]
HRESULT ConfigureStartStop(
   double Start,
   double Stop,
   IviRFSigGenFrequencyStepScalingEnum Scaling,
   double StepSize
);
[ANSI C]
HRESULT IIviRFSigGenFrequencyStep_ConfigureStartStop(
   IIviRFSigGenFrequencyStep* This
   double Start,
   double Stop,
   IviRFSigGenFrequencyStepScalingEnum Scaling,
   double StepSize
);
[C#]
public void ConfigureStartStop(
   double Start,
   double Stop,
   IviRFSigGenFrequencyStepScalingEnum Scaling,
   double StepSize
);

Parameters

Start
Specifies the start frequency of the step sweep. The driver uses this value to set the Frequency Step Start attribute.
Stop
Specifies the stop frequency of the step sweep. The driver uses this value to set the Frequency Step Stop attribute.
Scaling
Specifies the scaling of the step sweep. The driver uses this value to set the Frequency Step Scaling attribute.
StepSize
Specifies the size of one step. The driver uses this value to set the Frequency Step Size attribute.

Capability Group

IviRFSigGenFrequencyStep

Related Items

Start | Stop | Scaling | Size

Also In This Interface

Start | Stop | Scaling | Size | SingleStepEnabled | Dwell | ConfigureStartStop | ConfigureDwell | Reset | IIviRFSigGenFrequencyStep Overview


ConfigureDwell Method

IIviRFSigGenFrequencyStep.ConfigureDwell Method

This function configures the attributes that control the stepping.

[Visual Basic]
Sub ConfigureDwell( _
   SingleStepEnabled As Boolean, _
   Dwell As Double _
)
[C++]
HRESULT ConfigureDwell(
   VARIANT_BOOL SingleStepEnabled,
   double Dwell
);
[ANSI C]
HRESULT IIviRFSigGenFrequencyStep_ConfigureDwell(
   IIviRFSigGenFrequencyStep* This
   VARIANT_BOOL SingleStepEnabled,
   double Dwell
);
[C#]
public void ConfigureDwell(
   bool SingleStepEnabled,
   double Dwell
);

Parameters

SingleStepEnabled
Specifies whether the trigger initiates the next step. The driver uses this value to set the Frequency Step Single Step Enabled attribute.
Dwell
Specifies the duration of one frequency step. The driver uses this value to set the Frequency Step Dwell attribute.

Capability Group

IviRFSigGenFrequencyStep

Related Items

SingleStepEnabled | Dwell

Also In This Interface

Start | Stop | Scaling | Size | SingleStepEnabled | Dwell | ConfigureStartStop | ConfigureDwell | Reset | IIviRFSigGenFrequencyStep Overview


Reset Method

IIviRFSigGenFrequencyStep.Reset Method

This function resets the stepping if single step is enabled.

[Visual Basic]
Sub Reset()
[C++]
HRESULT Reset();
[ANSI C]
HRESULT IIviRFSigGenFrequencyStep_Reset(
   IIviRFSigGenFrequencyStep* This);
[C#]
public void Reset();

Capability Group

IviRFSigGenFrequencyStep

Also In This Interface

Start | Stop | Scaling | Size | SingleStepEnabled | Dwell | ConfigureStartStop | ConfigureDwell | Reset | IIviRFSigGenFrequencyStep Overview


IIviRFSigGenFrequencySweep Interface

IVI RFSigGen class-compliant frequency sweep interface

Properties

Start | Specifies the start frequency of the sweep.
Stop | Specifies the stop frequency of the sweep.
Time | Specifies the duration of one sweep from start to stop frequency.

Methods

ConfigureCenterSpan | This function configures the center frequency and the frequency span for the sweep.
ConfigureStartStop | This function configures the start and the stop frequency for the sweep.


Start Property

IIviRFSigGenFrequencySweep.Start Property

Specifies the start frequency of the sweep.

[Visual Basic]
Property Get Start() As Double
Property Let Start(value As Double)
[C++]
HRESULT get_Start(double* value);
HRESULT put_Start(double value);
[ANSI C]
HRESULT IIviRFSigGenFrequencySweep_get_Start(IIviRFSigGenFrequencySweep* This, double* value);
HRESULT IIviRFSigGenFrequencySweep_put_Start(IIviRFSigGenFrequencySweep* This, double value);
[C#]
public double Start {get; set;}

Capability Group

IviRFSigGenFrequencySweep

Related Items

ConfigureCenterSpan | ConfigureStartStop

Also In This Interface

Start | Stop | Time | ConfigureCenterSpan | ConfigureStartStop | IIviRFSigGenFrequencySweep Overview


Stop Property

IIviRFSigGenFrequencySweep.Stop Property

Specifies the stop frequency of the sweep.

[Visual Basic]
Property Get Stop() As Double
Property Let Stop(value As Double)
[C++]
HRESULT get_Stop(double* value);
HRESULT put_Stop(double value);
[ANSI C]
HRESULT IIviRFSigGenFrequencySweep_get_Stop(IIviRFSigGenFrequencySweep* This, double* value);
HRESULT IIviRFSigGenFrequencySweep_put_Stop(IIviRFSigGenFrequencySweep* This, double value);
[C#]
public double Stop {get; set;}

Capability Group

IviRFSigGenFrequencySweep

Related Items

ConfigureCenterSpan | ConfigureStartStop

Also In This Interface

Start | Stop | Time | ConfigureCenterSpan | ConfigureStartStop | IIviRFSigGenFrequencySweep Overview


Time Property

IIviRFSigGenFrequencySweep.Time Property

Specifies the duration of one sweep from start to stop frequency.

[Visual Basic]
Property Get Time() As Double
Property Let Time(value As Double)
[C++]
HRESULT get_Time(double* value);
HRESULT put_Time(double value);
[ANSI C]
HRESULT IIviRFSigGenFrequencySweep_get_Time(IIviRFSigGenFrequencySweep* This, double* value);
HRESULT IIviRFSigGenFrequencySweep_put_Time(IIviRFSigGenFrequencySweep* This, double value);
[C#]
public double Time {get; set;}

Capability Group

IviRFSigGenFrequencySweep

Also In This Interface

Start | Stop | Time | ConfigureCenterSpan | ConfigureStartStop | IIviRFSigGenFrequencySweep Overview


ConfigureCenterSpan Method

IIviRFSigGenFrequencySweep.ConfigureCenterSpan Method

This function configures the center frequency and the frequency span for the sweep.

[Visual Basic]
Sub ConfigureCenterSpan( _
   Center As Double, _
   Span As Double _
)
[C++]
HRESULT ConfigureCenterSpan(
   double Center,
   double Span
);
[ANSI C]
HRESULT IIviRFSigGenFrequencySweep_ConfigureCenterSpan(
   IIviRFSigGenFrequencySweep* This
   double Center,
   double Span
);
[C#]
public void ConfigureCenterSpan(
   double Center,
   double Span
);

Parameters

Center
Specifies the center frequency of the sweep. The driver uses this value to set the Frequency Sweep Start and Frequency Sweep Stop attribute.
Span
Specifies the frequency span of the sweep. The driver uses this value to set therequency Sweep Start and Frequency Sweep Stop attribute.

Capability Group

IviRFSigGenFrequencySweep

Related Items

Start | Stop

Also In This Interface

Start | Stop | Time | ConfigureCenterSpan | ConfigureStartStop | IIviRFSigGenFrequencySweep Overview


ConfigureStartStop Method

IIviRFSigGenFrequencySweep.ConfigureStartStop Method

This function configures the start and the stop frequency for the sweep.

[Visual Basic]
Sub ConfigureStartStop( _
   Start As Double, _
   Stop As Double _
)
[C++]
HRESULT ConfigureStartStop(
   double Start,
   double Stop
);
[ANSI C]
HRESULT IIviRFSigGenFrequencySweep_ConfigureStartStop(
   IIviRFSigGenFrequencySweep* This
   double Start,
   double Stop
);
[C#]
public void ConfigureStartStop(
   double Start,
   double Stop
);

Parameters

Start
Specifies the start frequency of the sweep. The driver uses this value to set the Frequency Sweep Start attribute.
Stop
Specifies the stop frequency of the sweep. The driver uses this value to set the Frequency Sweep Stop attribute

Capability Group

IviRFSigGenFrequencySweep

Related Items

Start | Stop

Also In This Interface

Start | Stop | Time | ConfigureCenterSpan | ConfigureStartStop | IIviRFSigGenFrequencySweep Overview


IIviRFSigGenIQ Interface

IVI RFSigGen class-compliant IQ modulation interface

Properties

Impairment | Pointer to the class-compliant IIviRFSigGenIQImpairment interface
Source | Specifies the source of the signal that the signal generator uses for IQ modulation.
SwapEnabled | Enables or disables the inverse phase rotation of the IQ signal by swapping the I and Q inputs.
NominalVoltage | Returns the voltage at which the instrument achieves full modulation.
Enabled | Enables or disables IQ (vector) modulation of the RF output signal.

Methods

Configure | This function configures the attributes that control the signal generator's IQ modulation.
Calibrate | This function performs a calibration of the IQ modulator.


Impairment Property

IIviRFSigGenIQ.Impairment Property

Pointer to the class-compliant IIviRFSigGenIQImpairment interface

[Visual Basic]
Property Get Impairment() As IIviRFSigGenIQImpairment
[C++]
HRESULT get_Impairment(IIviRFSigGenIQImpairment** value);
[ANSI C]
HRESULT IIviRFSigGenIQ_get_Impairment(IIviRFSigGenIQ* This, IIviRFSigGenIQImpairment** value);
[C#]
public IIviRFSigGenIQImpairment Impairment {get;}

Capability Group

IviRFSigGenIQImpairment

Also In This Interface

Impairment | Source | SwapEnabled | NominalVoltage | Enabled | Configure | Calibrate | IIviRFSigGenIQ Overview


Source Property

IIviRFSigGenIQ.Source Property

Specifies the source of the signal that the signal generator uses for IQ modulation.

[Visual Basic]
Property Get Source() As IviRFSigGenIQSourceEnum
Property Let Source(value As IviRFSigGenIQSourceEnum)
[C++]
HRESULT get_Source(IviRFSigGenIQSourceEnum* value);
HRESULT put_Source(IviRFSigGenIQSourceEnum value);
[ANSI C]
HRESULT IIviRFSigGenIQ_get_Source(IIviRFSigGenIQ* This, IviRFSigGenIQSourceEnum* value);
HRESULT IIviRFSigGenIQ_put_Source(IIviRFSigGenIQ* This, IviRFSigGenIQSourceEnum value);
[C#]
public IviRFSigGenIQSourceEnum Source {get; set;}

Capability Group

IviRFSigGenModulateIQ

Related Items

Configure

Also In This Interface

Impairment | Source | SwapEnabled | NominalVoltage | Enabled | Configure | Calibrate | IIviRFSigGenIQ Overview


SwapEnabled Property

IIviRFSigGenIQ.SwapEnabled Property

Enables or disables the inverse phase rotation of the IQ signal by swapping the I and Q inputs.

[Visual Basic]
Property Get SwapEnabled() As Boolean
Property Let SwapEnabled(value As Boolean)
[C++]
HRESULT get_SwapEnabled(VARIANT_BOOL* value);
HRESULT put_SwapEnabled(VARIANT_BOOL value);
[ANSI C]
HRESULT IIviRFSigGenIQ_get_SwapEnabled(IIviRFSigGenIQ* This, VARIANT_BOOL* value);
HRESULT IIviRFSigGenIQ_put_SwapEnabled(IIviRFSigGenIQ* This, VARIANT_BOOL value);
[C#]
public bool SwapEnabled {get; set;}

Capability Group

IviRFSigGenModulateIQ

Related Items

Configure

Also In This Interface

Impairment | Source | SwapEnabled | NominalVoltage | Enabled | Configure | Calibrate | IIviRFSigGenIQ Overview


NominalVoltage Property

IIviRFSigGenIQ.NominalVoltage Property

Returns the voltage at which the instrument achieves full modulation.

[Visual Basic]
Property Get NominalVoltage() As Double
[C++]
HRESULT get_NominalVoltage(double* value);
[ANSI C]
HRESULT IIviRFSigGenIQ_get_NominalVoltage(IIviRFSigGenIQ* This, double* value);
[C#]
public double NominalVoltage {get;}

Capability Group

IviRFSigGenModulateIQ

Also In This Interface

Impairment | Source | SwapEnabled | NominalVoltage | Enabled | Configure | Calibrate | IIviRFSigGenIQ Overview


Enabled Property

IIviRFSigGenIQ.Enabled Property

Enables or disables IQ (vector) modulation of the RF output signal.

[Visual Basic]
Property Get Enabled() As Boolean
Property Let Enabled(value As Boolean)
[C++]
HRESULT get_Enabled(VARIANT_BOOL* value);
HRESULT put_Enabled(VARIANT_BOOL value);
[ANSI C]
HRESULT IIviRFSigGenIQ_get_Enabled(IIviRFSigGenIQ* This, VARIANT_BOOL* value);
HRESULT IIviRFSigGenIQ_put_Enabled(IIviRFSigGenIQ* This, VARIANT_BOOL value);
[C#]
public bool Enabled {get; set;}

Capability Group

IviRFSigGenModulateIQ

Also In This Interface

Impairment | Source | SwapEnabled | NominalVoltage | Enabled | Configure | Calibrate | IIviRFSigGenIQ Overview


Configure Method

IIviRFSigGenIQ.Configure Method

This function configures the attributes that control the signal generator's IQ modulation.

[Visual Basic]
Sub Configure( _
   Source As IviRFSigGenIQSourceEnum, _
   SwapEnabled As Boolean _
)
[C++]
HRESULT Configure(
   IviRFSigGenIQSourceEnum Source,
   VARIANT_BOOL SwapEnabled
);
[ANSI C]
HRESULT IIviRFSigGenIQ_Configure(
   IIviRFSigGenIQ* This
   IviRFSigGenIQSourceEnum Source,
   VARIANT_BOOL SwapEnabled
);
[C#]
public void Configure(
   IviRFSigGenIQSourceEnum Source,
   bool SwapEnabled
);

Parameters

Source
Specifies the modulation source. The driver uses this value to set the Modulate IQ Source attribute.
SwapEnabled
Specifies the swap state. True swaps I and Q inputs, the result is an invers phase rotation. The driver uses this value to set the Modulate IQ Swap Enabled attribute.

Capability Group

IviRFSigGenModulateIQ

Related Items

Source | SwapEnabled

Also In This Interface

Impairment | Source | SwapEnabled | NominalVoltage | Enabled | Configure | Calibrate | IIviRFSigGenIQ Overview


Calibrate Method

IIviRFSigGenIQ.Calibrate Method

This function performs a calibration of the IQ modulator.

[Visual Basic]
Sub Calibrate()
[C++]
HRESULT Calibrate();
[ANSI C]
HRESULT IIviRFSigGenIQ_Calibrate(
   IIviRFSigGenIQ* This);
[C#]
public void Calibrate();

Capability Group

IviRFSigGenModulateIQ

Also In This Interface

Impairment | Source | SwapEnabled | NominalVoltage | Enabled | Configure | Calibrate | IIviRFSigGenIQ Overview


IIviRFSigGenIQImpairment Interface

IVI RFSigGen class-compliant IQ modulation impairment interface

Properties

Enabled | Enables or disables impairment attributes.
IOffset | Specifies an origin offset voltage to the I signal.
QOffset | Specifies an origin offset voltage to the Q signal.
Ratio | Specifies the gain imbalance between the I and Q channels.
Skew | Specifies the adjustment of the phase angle between the I and Q vectors.

Methods

Configure This function configures the attributes that simulate or correct impairment for the signal generator's IQ (vector) modulation.


Enabled Property

IIviRFSigGenIQImpairment.Enabled Property

Enables or disables impairment attributes.

[Visual Basic]
Property Get Enabled() As Boolean
Property Let Enabled(value As Boolean)
[C++]
HRESULT get_Enabled(VARIANT_BOOL* value);
HRESULT put_Enabled(VARIANT_BOOL value);
[ANSI C]
HRESULT IIviRFSigGenIQImpairment_get_Enabled(IIviRFSigGenIQImpairment* This, VARIANT_BOOL* value);
HRESULT IIviRFSigGenIQImpairment_put_Enabled(IIviRFSigGenIQImpairment* This, VARIANT_BOOL value);
[C#]
public bool Enabled {get; set;}

Capability Group

IviRFSigGenIQImpairment

Also In This Interface

Enabled | IOffset | QOffset | Ratio | Skew | Configure | IIviRFSigGenIQImpairment Overview


IOffset Property

IIviRFSigGenIQImpairment.IOffset Property

Specifies an origin offset voltage to the I signal.

[Visual Basic]
Property Get IOffset() As Double
Property Let IOffset(value As Double)
[C++]
HRESULT get_IOffset(double* value);
HRESULT put_IOffset(double value);
[ANSI C]
HRESULT IIviRFSigGenIQImpairment_get_IOffset(IIviRFSigGenIQImpairment* This, double* value);
HRESULT IIviRFSigGenIQImpairment_put_IOffset(IIviRFSigGenIQImpairment* This, double value);
[C#]
public double IOffset {get; set;}

Capability Group

IviRFSigGenIQImpairment

Related Items

Configure

Also In This Interface

Enabled | IOffset | QOffset | Ratio | Skew | Configure | IIviRFSigGenIQImpairment Overview


QOffset Property

IIviRFSigGenIQImpairment.QOffset Property

Specifies an origin offset voltage to the Q signal.

[Visual Basic]
Property Get QOffset() As Double
Property Let QOffset(value As Double)
[C++]
HRESULT get_QOffset(double* value);
HRESULT put_QOffset(double value);
[ANSI C]
HRESULT IIviRFSigGenIQImpairment_get_QOffset(IIviRFSigGenIQImpairment* This, double* value);
HRESULT IIviRFSigGenIQImpairment_put_QOffset(IIviRFSigGenIQImpairment* This, double value);
[C#]
public double QOffset {get; set;}

Capability Group

IviRFSigGenIQImpairment

Related Items

Configure

Also In This Interface

Enabled | IOffset | QOffset | Ratio | Skew | Configure | IIviRFSigGenIQImpairment Overview


Ratio Property

IIviRFSigGenIQImpairment.Ratio Property

Specifies the gain imbalance between the I and Q channels.

[Visual Basic]
Property Get Ratio() As Double
Property Let Ratio(value As Double)
[C++]
HRESULT get_Ratio(double* value);
HRESULT put_Ratio(double value);
[ANSI C]
HRESULT IIviRFSigGenIQImpairment_get_Ratio(IIviRFSigGenIQImpairment* This, double* value);
HRESULT IIviRFSigGenIQImpairment_put_Ratio(IIviRFSigGenIQImpairment* This, double value);
[C#]
public double Ratio {get; set;}

Capability Group

IviRFSigGenIQImpairment

Related Items

Configure

Also In This Interface

Enabled | IOffset | QOffset | Ratio | Skew | Configure | IIviRFSigGenIQImpairment Overview


Skew Property

IIviRFSigGenIQImpairment.Skew Property

Specifies the adjustment of the phase angle between the I and Q vectors.

[Visual Basic]
Property Get Skew() As Double
Property Let Skew(value As Double)
[C++]
HRESULT get_Skew(double* value);
HRESULT put_Skew(double value);
[ANSI C]
HRESULT IIviRFSigGenIQImpairment_get_Skew(IIviRFSigGenIQImpairment* This, double* value);
HRESULT IIviRFSigGenIQImpairment_put_Skew(IIviRFSigGenIQImpairment* This, double value);
[C#]
public double Skew {get; set;}

Capability Group

IviRFSigGenIQImpairment

Related Items

Configure

Also In This Interface

Enabled | IOffset | QOffset | Ratio | Skew | Configure | IIviRFSigGenIQImpairment Overview


Configure Method

IIviRFSigGenIQImpairment.Configure Method

This function configures the attributes that simulate or correct impairment for the signal generator's IQ (vector) modulation.

[Visual Basic]
Sub Configure( _
   IOffset As Double, _
   QOffset As Double, _
   Ratio As Double, _
   Skew As Double _
)
[C++]
HRESULT Configure(
   double IOffset,
   double QOffset,
   double Ratio,
   double Skew
);
[ANSI C]
HRESULT IIviRFSigGenIQImpairment_Configure(
   IIviRFSigGenIQImpairment* This
   double IOffset,
   double QOffset,
   double Ratio,
   double Skew
);
[C#]
public void Configure(
   double IOffset,
   double QOffset,
   double Ratio,
   double Skew
);

Parameters

IOffset
Specifies an offset to the I-path of IQ signals. The driver uses this value to set the IQ I Offset attribute.
QOffset
Specifies an offset to the Q-path of IQ signals. The driver uses this value to set the IQ Q Offset attribute.
Ratio
Specifies a gain imbalance to the IQ signals. The driver uses this value to set the IQ Ratio attribute.
Skew
Specifies an angle offset to the IQ signals. The driver uses this value to set the IQ Skew attribute.

Capability Group

IviRFSigGenIQImpairment

Related Items

IOffset | QOffset | Ratio | Skew

Also In This Interface

Enabled | IOffset | QOffset | Ratio | Skew | Configure | IIviRFSigGenIQImpairment Overview


IIviRFSigGenLFGenerator Interface

IVI RFSigGen class-compliant LF generator interface

Properties

Output | Pointer to the class-compliant IIviRFSigGenLFGeneratorOutput interface
Frequency | Specifies the frequency of the active LF generator.
Waveform | Specifies the waveform of the active LF generator.
ActiveLFGenerator | Selects the generator that is used as the modulating signal or for LF output.
Count | Returns the number of LF generators.
Name | Returns the LF generator name for a given index.

Methods

Configure This function configures the LF generator output frequency and waveform.


Output Property

IIviRFSigGenLFGenerator.Output Property

Pointer to the class-compliant IIviRFSigGenLFGeneratorOutput interface

[Visual Basic]
Property Get Output() As IIviRFSigGenLFGeneratorOutput
[C++]
HRESULT get_Output(IIviRFSigGenLFGeneratorOutput** value);
[ANSI C]
HRESULT IIviRFSigGenLFGenerator_get_Output(IIviRFSigGenLFGenerator* This, IIviRFSigGenLFGeneratorOutput** value);
[C#]
public IIviRFSigGenLFGeneratorOutput Output {get;}

Capability Group

IviRFSigGenLFGeneratorOutput

Also In This Interface

Output | Frequency | Waveform | ActiveLFGenerator | Count | Name | Configure | IIviRFSigGenLFGenerator Overview


Frequency Property

IIviRFSigGenLFGenerator.Frequency Property

Specifies the frequency of the active LF generator.

[Visual Basic]
Property Get Frequency() As Double
Property Let Frequency(value As Double)
[C++]
HRESULT get_Frequency(double* value);
HRESULT put_Frequency(double value);
[ANSI C]
HRESULT IIviRFSigGenLFGenerator_get_Frequency(IIviRFSigGenLFGenerator* This, double* value);
HRESULT IIviRFSigGenLFGenerator_put_Frequency(IIviRFSigGenLFGenerator* This, double value);
[C#]
public double Frequency {get; set;}

Capability Group

IviRFSigGenLFGenerator

Related Items

Configure

Also In This Interface

Output | Frequency | Waveform | ActiveLFGenerator | Count | Name | Configure | IIviRFSigGenLFGenerator Overview


Waveform Property

IIviRFSigGenLFGenerator.Waveform Property

Specifies the waveform of the active LF generator.

[Visual Basic]
Property Get Waveform() As IviRFSigGenLFGeneratorWaveformEnum
Property Let Waveform(value As IviRFSigGenLFGeneratorWaveformEnum)
[C++]
HRESULT get_Waveform(IviRFSigGenLFGeneratorWaveformEnum* value);
HRESULT put_Waveform(IviRFSigGenLFGeneratorWaveformEnum value);
[ANSI C]
HRESULT IIviRFSigGenLFGenerator_get_Waveform(IIviRFSigGenLFGenerator* This, IviRFSigGenLFGeneratorWaveformEnum* value);
HRESULT IIviRFSigGenLFGenerator_put_Waveform(IIviRFSigGenLFGenerator* This, IviRFSigGenLFGeneratorWaveformEnum value);
[C#]
public IviRFSigGenLFGeneratorWaveformEnum Waveform {get; set;}

Capability Group

IviRFSigGenLFGenerator

Related Items

Configure

Also In This Interface

Output | Frequency | Waveform | ActiveLFGenerator | Count | Name | Configure | IIviRFSigGenLFGenerator Overview


ActiveLFGenerator Property

IIviRFSigGenLFGenerator.ActiveLFGenerator Property

Selects the generator that is used as the modulating signal or for LF output.

[Visual Basic]
Property Get ActiveLFGenerator() As String
Property Let ActiveLFGenerator(value As String)
[C++]
HRESULT get_ActiveLFGenerator(BSTR* value);
HRESULT put_ActiveLFGenerator(BSTR value);
[ANSI C]
HRESULT IIviRFSigGenLFGenerator_get_ActiveLFGenerator(IIviRFSigGenLFGenerator* This, BSTR* value);
HRESULT IIviRFSigGenLFGenerator_put_ActiveLFGenerator(IIviRFSigGenLFGenerator* This, BSTR value);
[C#]
public string ActiveLFGenerator {get; set;}

Capability Group

IviRFSigGenLFGenerator

Also In This Interface

Output | Frequency | Waveform | ActiveLFGenerator | Count | Name | Configure | IIviRFSigGenLFGenerator Overview


Count Property

IIviRFSigGenLFGenerator.Count Property

Returns the number of LF generators.

[Visual Basic]
Property Get Count() As Long
[C++]
HRESULT get_Count(long* value);
[ANSI C]
HRESULT IIviRFSigGenLFGenerator_get_Count(IIviRFSigGenLFGenerator* This, long* value);
[C#]
public long Count {get;}

Capability Group

IviRFSigGenLFGenerator

Also In This Interface

Output | Frequency | Waveform | ActiveLFGenerator | Count | Name | Configure | IIviRFSigGenLFGenerator Overview


Name Property

IIviRFSigGenLFGenerator.Name Property

Returns the LF generator name for a given index.

[Visual Basic]
Property Get Name(Index As Long) As String
[C++]
HRESULT get_Name(long Index, BSTR* value);
[ANSI C]
HRESULT IIviRFSigGenLFGenerator_get_Name(IIviRFSigGenLFGenerator* This, long Index, BSTR* value);
[C#]HRESULT get_Name(long Index, string value);

Parameters

Index
A one-based index that defines which name to return.

Capability Group

IviRFSigGenLFGenerator

Also In This Interface

Output | Frequency | Waveform | ActiveLFGenerator | Count | Name | Configure | IIviRFSigGenLFGenerator Overview


Configure Method

IIviRFSigGenLFGenerator.Configure Method

This function configures the LF generator output frequency and waveform.

[Visual Basic]
Sub Configure( _
   Frequency As Double, _
   Waveform As IviRFSigGenLFGeneratorWaveformEnum _
)
[C++]
HRESULT Configure(
   double Frequency,
   IviRFSigGenLFGeneratorWaveformEnum Waveform
);
[ANSI C]
HRESULT IIviRFSigGenLFGenerator_Configure(
   IIviRFSigGenLFGenerator* This
   double Frequency,
   IviRFSigGenLFGeneratorWaveformEnum Waveform
);
[C#]
public void Configure(
   double Frequency,
   IviRFSigGenLFGeneratorWaveformEnum Waveform
);

Parameters

Frequency
Specifies the frequency of the active LF generator.
Waveform
Specifies the waveform of the active LF generator.

Capability Group

IviRFSigGenLFGenerator

Related Items

Frequency | Waveform

Also In This Interface

Output | Frequency | Waveform | ActiveLFGenerator | Count | Name | Configure | IIviRFSigGenLFGenerator Overview


IIviRFSigGenLFGeneratorOutput Interface

IVI RFSigGen class-compliant LF generator output interface

Properties

Enabled | Enables or disables the external LF generator output.
Amplitude | Specifies the output voltage of the LF generator.

Methods

Configure This function configures the attributes of the LF generator output (within the RF signal generator).


Enabled Property

IIviRFSigGenLFGeneratorOutput.Enabled Property

Enables or disables the external LF generator output.

[Visual Basic]
Property Get Enabled() As Boolean
Property Let Enabled(value As Boolean)
[C++]
HRESULT get_Enabled(VARIANT_BOOL* value);
HRESULT put_Enabled(VARIANT_BOOL value);
[ANSI C]
HRESULT IIviRFSigGenLFGeneratorOutput_get_Enabled(IIviRFSigGenLFGeneratorOutput* This, VARIANT_BOOL* value);
HRESULT IIviRFSigGenLFGeneratorOutput_put_Enabled(IIviRFSigGenLFGeneratorOutput* This, VARIANT_BOOL value);
[C#]
public bool Enabled {get; set;}

Capability Group

IviRFSigGenLFGeneratorOutput

Related Items

Configure

Also In This Interface

Enabled | Amplitude | Configure | IIviRFSigGenLFGeneratorOutput Overview


Amplitude Property

IIviRFSigGenLFGeneratorOutput.Amplitude Property

Specifies the output voltage of the LF generator.

[Visual Basic]
Property Get Amplitude() As Double
Property Let Amplitude(value As Double)
[C++]
HRESULT get_Amplitude(double* value);
HRESULT put_Amplitude(double value);
[ANSI C]
HRESULT IIviRFSigGenLFGeneratorOutput_get_Amplitude(IIviRFSigGenLFGeneratorOutput* This, double* value);
HRESULT IIviRFSigGenLFGeneratorOutput_put_Amplitude(IIviRFSigGenLFGeneratorOutput* This, double value);
[C#]
public double Amplitude {get; set;}

Capability Group

IviRFSigGenLFGeneratorOutput

Related Items

Configure

Also In This Interface

Enabled | Amplitude | Configure | IIviRFSigGenLFGeneratorOutput Overview


Configure Method

IIviRFSigGenLFGeneratorOutput.Configure Method

This function configures the attributes of the LF generator output (within the RF signal generator).

[Visual Basic]
Sub Configure( _
   Amplitude As Double, _
   Enabled As Boolean _
)
[C++]
HRESULT Configure(
   double Amplitude,
   VARIANT_BOOL Enabled
);
[ANSI C]
HRESULT IIviRFSigGenLFGeneratorOutput_Configure(
   IIviRFSigGenLFGeneratorOutput* This
   double Amplitude,
   VARIANT_BOOL Enabled
);
[C#]
public void Configure(
   double Amplitude,
   bool Enabled
);

Parameters

Amplitude
Specifies the output voltage of the LF generator.
Enabled
Enables or disables the external LF generator output.

Capability Group

IviRFSigGenLFGeneratorOutput

Related Items

Amplitude | Enabled

Also In This Interface

Enabled | Amplitude | Configure | IIviRFSigGenLFGeneratorOutput Overview


IIviRFSigGenList Interface

IVI RFSigGen class-compliant sweep list interface

Properties

SingleStepEnabled | Turns single step on/off.
Dwell | Specifies the duration of one step.
SelectedName | Specifies the name of the selected list to become active.

Methods

ConfigureDwell | This function configures the attributes that control the stepping.
ClearAll | This function deletes all lists from the pool of lists.
CreateFrequency | This function creates a named list of frequency values.
CreatePower | This function creates a named list of power values.
CreateFrequencyPower | This function creates a named list of frequency and power value pairs.
Reset | This function resets the stepping if single step is enabled.


SingleStepEnabled Property

IIviRFSigGenList.SingleStepEnabled Property

Turns single step on/off.

[Visual Basic]
Property Get SingleStepEnabled() As Boolean
Property Let SingleStepEnabled(value As Boolean)
[C++]
HRESULT get_SingleStepEnabled(VARIANT_BOOL* value);
HRESULT put_SingleStepEnabled(VARIANT_BOOL value);
[ANSI C]
HRESULT IIviRFSigGenList_get_SingleStepEnabled(IIviRFSigGenList* This, VARIANT_BOOL* value);
HRESULT IIviRFSigGenList_put_SingleStepEnabled(IIviRFSigGenList* This, VARIANT_BOOL value);
[C#]
public bool SingleStepEnabled {get; set;}

Capability Group

IviRFSigGenList

Related Items

ConfigureDwell

Also In This Interface

SingleStepEnabled | Dwell | SelectedName | ConfigureDwell | ClearAll | CreateFrequency | CreatePower | CreateFrequencyPower | Reset | IIviRFSigGenList Overview


Dwell Property

IIviRFSigGenList.Dwell Property

Specifies the duration of one step.

[Visual Basic]
Property Get Dwell() As Double
Property Let Dwell(value As Double)
[C++]
HRESULT get_Dwell(double* value);
HRESULT put_Dwell(double value);
[ANSI C]
HRESULT IIviRFSigGenList_get_Dwell(IIviRFSigGenList* This, double* value);
HRESULT IIviRFSigGenList_put_Dwell(IIviRFSigGenList* This, double value);
[C#]
public double Dwell {get; set;}

Capability Group

IviRFSigGenList

Related Items

ConfigureDwell

Also In This Interface

SingleStepEnabled | Dwell | SelectedName | ConfigureDwell | ClearAll | CreateFrequency | CreatePower | CreateFrequencyPower | Reset | IIviRFSigGenList Overview


SelectedName Property

IIviRFSigGenList.SelectedName Property

Specifies the name of the selected list to become active.

[Visual Basic]
Property Get SelectedName() As String
Property Let SelectedName(value As String)
[C++]
HRESULT get_SelectedName(BSTR* value);
HRESULT put_SelectedName(BSTR value);
[ANSI C]
HRESULT IIviRFSigGenList_get_SelectedName(IIviRFSigGenList* This, BSTR* value);
HRESULT IIviRFSigGenList_put_SelectedName(IIviRFSigGenList* This, BSTR value);
[C#]
public string SelectedName {get; set;}

Capability Group

IviRFSigGenList

Also In This Interface

SingleStepEnabled | Dwell | SelectedName | ConfigureDwell | ClearAll | CreateFrequency | CreatePower | CreateFrequencyPower | Reset | IIviRFSigGenList Overview


ConfigureDwell Method

IIviRFSigGenList.ConfigureDwell Method

This function configures the attributes that control the stepping.

[Visual Basic]
Sub ConfigureDwell( _
   SingleStepEnabled As Boolean, _
   Dwell As Double _
)
[C++]
HRESULT ConfigureDwell(
   VARIANT_BOOL SingleStepEnabled,
   double Dwell
);
[ANSI C]
HRESULT IIviRFSigGenList_ConfigureDwell(
   IIviRFSigGenList* This
   VARIANT_BOOL SingleStepEnabled,
   double Dwell
);
[C#]
public void ConfigureDwell(
   bool SingleStepEnabled,
   double Dwell
);

Parameters

SingleStepEnabled
Specifies whether the trigger initiates transitions to the next list step. The driver uses this value to set the List Single Step Enabled attribute.
Dwell
Specifies the duration of one list step. The driver uses this value to set the List Dwell attribute.

Capability Group

IviRFSigGenList

Related Items

SingleStepEnabled | Dwell

Also In This Interface

SingleStepEnabled | Dwell | SelectedName | ConfigureDwell | ClearAll | CreateFrequency | CreatePower | CreateFrequencyPower | Reset | IIviRFSigGenList Overview


ClearAll Method

IIviRFSigGenList.ClearAll Method

This function deletes all lists from the pool of lists.

[Visual Basic]
Sub ClearAll()
[C++]
HRESULT ClearAll();
[ANSI C]
HRESULT IIviRFSigGenList_ClearAll(
   IIviRFSigGenList* This);
[C#]
public void ClearAll();

Capability Group

IviRFSigGenList

Related Items

CreateFrequency | CreatePower | CreateFrequencyPower

Also In This Interface

SingleStepEnabled | Dwell | SelectedName | ConfigureDwell | ClearAll | CreateFrequency | CreatePower | CreateFrequencyPower | Reset | IIviRFSigGenList Overview


CreateFrequency Method

IIviRFSigGenList.CreateFrequency Method

This function creates a named list of frequency values.

[Visual Basic]
Sub CreateFrequency( _
   Name As String, _
   Frequency As SAFEARRAY(double)* _
)
[C++]
HRESULT CreateFrequency(
   BSTR Name,
   SAFEARRAY(double)* Frequency
);
[ANSI C]
HRESULT IIviRFSigGenList_CreateFrequency(
   IIviRFSigGenList* This
   BSTR Name,
   SAFEARRAY(double)* Frequency
);
[C#]
public void CreateFrequency(
   string Name,
   Array Frequency
);

Parameters

Name
Specifies the name of the list to be created.
Frequency
Specifies the array of frequency values to become elements of the list. The array must have at least as many elements as the value in the Length parameter. The units are Hertz.

Capability Group

IviRFSigGenList

Related Items

ClearAll | CreatePower | CreateFrequencyPower

Also In This Interface

SingleStepEnabled | Dwell | SelectedName | ConfigureDwell | ClearAll | CreateFrequency | CreatePower | CreateFrequencyPower | Reset | IIviRFSigGenList Overview


CreatePower Method

IIviRFSigGenList.CreatePower Method

This function creates a named list of power values.

[Visual Basic]
Sub CreatePower( _
   Name As String, _
   Power As SAFEARRAY(double)* _
)
[C++]
HRESULT CreatePower(
   BSTR Name,
   SAFEARRAY(double)* Power
);
[ANSI C]
HRESULT IIviRFSigGenList_CreatePower(
   IIviRFSigGenList* This
   BSTR Name,
   SAFEARRAY(double)* Power
);
[C#]
public void CreatePower(
   string Name,
   Array Power
);

Parameters

Name
Specifies the name of the list to be created.
Power
Specifies the array of power values to become elements of the list. The array must have at least as many elements as the value in the Length parameter. The units are dBm.

Capability Group

IviRFSigGenList

Related Items

ClearAll | CreateFrequency | CreateFrequencyPower

Also In This Interface

SingleStepEnabled | Dwell | SelectedName | ConfigureDwell | ClearAll | CreateFrequency | CreatePower | CreateFrequencyPower | Reset | IIviRFSigGenList Overview


CreateFrequencyPower Method

IIviRFSigGenList.CreateFrequencyPower Method

This function creates a named list of frequency and power value pairs.

[Visual Basic]
Sub CreateFrequencyPower( _
   Name As String, _
   Frequency As SAFEARRAY(double)*, _
   Power As SAFEARRAY(double)* _
)
[C++]
HRESULT CreateFrequencyPower(
   BSTR Name,
   SAFEARRAY(double)* Frequency,
   SAFEARRAY(double)* Power
);
[ANSI C]
HRESULT IIviRFSigGenList_CreateFrequencyPower(
   IIviRFSigGenList* This
   BSTR Name,
   SAFEARRAY(double)* Frequency,
   SAFEARRAY(double)* Power
);
[C#]
public void CreateFrequencyPower(
   string Name,
   Array Frequency,
   Array Power
);

Parameters

Name
Specifies the name of the list to be created.
Frequency
Specifies the array of frequency values to become elements of the list. The array must have at least as many elements as the value in the Length parameter. The units are Hertz.
Power
Specifies the array of power values to become elements of the list. The array must have at least as many elements as the value in the Length parameter. The units are dBm.

Capability Group

IviRFSigGenList

Related Items

ClearAll | CreateFrequency | CreatePower

Also In This Interface

SingleStepEnabled | Dwell | SelectedName | ConfigureDwell | ClearAll | CreateFrequency | CreatePower | CreateFrequencyPower | Reset | IIviRFSigGenList Overview


Reset Method

IIviRFSigGenList.Reset Method

This function resets the stepping if single step is enabled.

[Visual Basic]
Sub Reset()
[C++]
HRESULT Reset();
[ANSI C]
HRESULT IIviRFSigGenList_Reset(
   IIviRFSigGenList* This);
[C#]
public void Reset();

Capability Group

IviRFSigGenList

Also In This Interface

SingleStepEnabled | Dwell | SelectedName | ConfigureDwell | ClearAll | CreateFrequency | CreatePower | CreateFrequencyPower | Reset | IIviRFSigGenList Overview


IIviRFSigGenPM Interface

IVI RFSigGen class-compliant phase modulation interface

Properties

Source | Specifies the source of the signal that is used as the modulating signal.
Deviation | Specifies the extent of modulation (peak phase deviation) the signal generator applies to the RF-signal.
NominalVoltage | Returns the voltage at which the instrument achieves the amount of modulation specified by the PM Deviation attribute.
Enabled | Specifies whether the signal generator enables or disables phase modulation of the RF output signal.
ExternalCoupling | Specifies the coupling of the external source of the modulating signal.

Methods

Configure This function configures the attributes that control the signal generator's phase modulation.


Source Property

IIviRFSigGenPM.Source Property

Specifies the source of the signal that is used as the modulating signal.

[Visual Basic]
Property Get Source() As String
Property Let Source(value As String)
[C++]
HRESULT get_Source(BSTR* value);
HRESULT put_Source(BSTR value);
[ANSI C]
HRESULT IIviRFSigGenPM_get_Source(IIviRFSigGenPM* This, BSTR* value);
HRESULT IIviRFSigGenPM_put_Source(IIviRFSigGenPM* This, BSTR value);
[C#]
public string Source {get; set;}

Capability Group

IviRFSigGenModulatePM

Related Items

Configure

Also In This Interface

Source | Deviation | NominalVoltage | Enabled | ExternalCoupling | Configure | IIviRFSigGenPM Overview


Deviation Property

IIviRFSigGenPM.Deviation Property

Specifies the extent of modulation (peak phase deviation) the signal generator applies to the RF-signal.

[Visual Basic]
Property Get Deviation() As Double
Property Let Deviation(value As Double)
[C++]
HRESULT get_Deviation(double* value);
HRESULT put_Deviation(double value);
[ANSI C]
HRESULT IIviRFSigGenPM_get_Deviation(IIviRFSigGenPM* This, double* value);
HRESULT IIviRFSigGenPM_put_Deviation(IIviRFSigGenPM* This, double value);
[C#]
public double Deviation {get; set;}

Capability Group

IviRFSigGenModulatePM

Related Items

Configure

Also In This Interface

Source | Deviation | NominalVoltage | Enabled | ExternalCoupling | Configure | IIviRFSigGenPM Overview


NominalVoltage Property

IIviRFSigGenPM.NominalVoltage Property

Returns the voltage at which the instrument achieves the amount of modulation specified by the PM Deviation attribute.

[Visual Basic]
Property Get NominalVoltage() As Double
[C++]
HRESULT get_NominalVoltage(double* value);
[ANSI C]
HRESULT IIviRFSigGenPM_get_NominalVoltage(IIviRFSigGenPM* This, double* value);
[C#]
public double NominalVoltage {get;}

Capability Group

IviRFSigGenModulatePM

Also In This Interface

Source | Deviation | NominalVoltage | Enabled | ExternalCoupling | Configure | IIviRFSigGenPM Overview


Enabled Property

IIviRFSigGenPM.Enabled Property

Specifies whether the signal generator enables or disables phase modulation of the RF output signal.

[Visual Basic]
Property Get Enabled() As Boolean
Property Let Enabled(value As Boolean)
[C++]
HRESULT get_Enabled(VARIANT_BOOL* value);
HRESULT put_Enabled(VARIANT_BOOL value);
[ANSI C]
HRESULT IIviRFSigGenPM_get_Enabled(IIviRFSigGenPM* This, VARIANT_BOOL* value);
HRESULT IIviRFSigGenPM_put_Enabled(IIviRFSigGenPM* This, VARIANT_BOOL value);
[C#]
public bool Enabled {get; set;}

Capability Group

IviRFSigGenModulatePM

Also In This Interface

Source | Deviation | NominalVoltage | Enabled | ExternalCoupling | Configure | IIviRFSigGenPM Overview


ExternalCoupling Property

IIviRFSigGenPM.ExternalCoupling Property

Specifies the coupling of the external source of the modulating signal.

[Visual Basic]
Property Get ExternalCoupling() As IviRFSigGenPMExternalCouplingEnum
Property Let ExternalCoupling(value As IviRFSigGenPMExternalCouplingEnum)
[C++]
HRESULT get_ExternalCoupling(IviRFSigGenPMExternalCouplingEnum* value);
HRESULT put_ExternalCoupling(IviRFSigGenPMExternalCouplingEnum value);
[ANSI C]
HRESULT IIviRFSigGenPM_get_ExternalCoupling(IIviRFSigGenPM* This, IviRFSigGenPMExternalCouplingEnum* value);
HRESULT IIviRFSigGenPM_put_ExternalCoupling(IIviRFSigGenPM* This, IviRFSigGenPMExternalCouplingEnum value);
[C#]
public IviRFSigGenPMExternalCouplingEnum ExternalCoupling {get; set;}

Capability Group

IviRFSigGenModulatePM

Also In This Interface

Source | Deviation | NominalVoltage | Enabled | ExternalCoupling | Configure | IIviRFSigGenPM Overview


Configure Method

IIviRFSigGenPM.Configure Method

This function configures the attributes that control the signal generator's phase modulation.

[Visual Basic]
Sub Configure( _
   Source As String, _
   Deviation As Double _
)
[C++]
HRESULT Configure(
   BSTR Source,
   double Deviation
);
[ANSI C]
HRESULT IIviRFSigGenPM_Configure(
   IIviRFSigGenPM* This
   BSTR Source,
   double Deviation
);
[C#]
public void Configure(
   string Source,
   double Deviation
);

Parameters

Source
Specifies the source of the signal the signal generator uses to modulate the output signal. The driver uses this value to set the PM Source attribute.
Deviation
Specifies the extent of modulation. The driver uses this value to set the PM Deviation attribute.

Capability Group

IviRFSigGenModulatePM

Related Items

Source | Deviation

Also In This Interface

Source | Deviation | NominalVoltage | Enabled | ExternalCoupling | Configure | IIviRFSigGenPM Overview


IIviRFSigGenPowerStep Interface

IVI RFSigGen class-compliant power step interface

Properties

Start | Specifies the start power of the stepped sweep.
Stop | Specifies the stop power of the stepped sweep.
Size | Specifies the step size.
SingleStepEnabled | Turns single step on/off.
Dwell | Specifies the duration of one step.

Methods

ConfigureStartStop | This function configures the attributes that control the power steps of the generator's RF output signal.
ConfigureDwell | This function configures the attributes that control the stepping.
Reset | This function resets the stepping if single step is enabled.


Start Property

IIviRFSigGenPowerStep.Start Property

Specifies the start power of the stepped sweep.

[Visual Basic]
Property Get Start() As Double
Property Let Start(value As Double)
[C++]
HRESULT get_Start(double* value);
HRESULT put_Start(double value);
[ANSI C]
HRESULT IIviRFSigGenPowerStep_get_Start(IIviRFSigGenPowerStep* This, double* value);
HRESULT IIviRFSigGenPowerStep_put_Start(IIviRFSigGenPowerStep* This, double value);
[C#]
public double Start {get; set;}

Capability Group

IviRFSigGenPowerStep

Related Items

ConfigureStartStop

Also In This Interface

Start | Stop | Size | SingleStepEnabled | Dwell | ConfigureStartStop | ConfigureDwell | Reset | IIviRFSigGenPowerStep Overview


Stop Property

IIviRFSigGenPowerStep.Stop Property

Specifies the stop power of the stepped sweep.

[Visual Basic]
Property Get Stop() As Double
Property Let Stop(value As Double)
[C++]
HRESULT get_Stop(double* value);
HRESULT put_Stop(double value);
[ANSI C]
HRESULT IIviRFSigGenPowerStep_get_Stop(IIviRFSigGenPowerStep* This, double* value);
HRESULT IIviRFSigGenPowerStep_put_Stop(IIviRFSigGenPowerStep* This, double value);
[C#]
public double Stop {get; set;}

Capability Group

IviRFSigGenPowerStep

Related Items

ConfigureStartStop

Also In This Interface

Start | Stop | Size | SingleStepEnabled | Dwell | ConfigureStartStop | ConfigureDwell | Reset | IIviRFSigGenPowerStep Overview


Size Property

IIviRFSigGenPowerStep.Size Property

Specifies the step size.

[Visual Basic]
Property Get Size() As Double
Property Let Size(value As Double)
[C++]
HRESULT get_Size(double* value);
HRESULT put_Size(double value);
[ANSI C]
HRESULT IIviRFSigGenPowerStep_get_Size(IIviRFSigGenPowerStep* This, double* value);
HRESULT IIviRFSigGenPowerStep_put_Size(IIviRFSigGenPowerStep* This, double value);
[C#]
public double Size {get; set;}

Capability Group

IviRFSigGenPowerStep

Related Items

ConfigureStartStop

Also In This Interface

Start | Stop | Size | SingleStepEnabled | Dwell | ConfigureStartStop | ConfigureDwell | Reset | IIviRFSigGenPowerStep Overview


SingleStepEnabled Property

IIviRFSigGenPowerStep.SingleStepEnabled Property

Turns single step on/off.

[Visual Basic]
Property Get SingleStepEnabled() As Boolean
Property Let SingleStepEnabled(value As Boolean)
[C++]
HRESULT get_SingleStepEnabled(VARIANT_BOOL* value);
HRESULT put_SingleStepEnabled(VARIANT_BOOL value);
[ANSI C]
HRESULT IIviRFSigGenPowerStep_get_SingleStepEnabled(IIviRFSigGenPowerStep* This, VARIANT_BOOL* value);
HRESULT IIviRFSigGenPowerStep_put_SingleStepEnabled(IIviRFSigGenPowerStep* This, VARIANT_BOOL value);
[C#]
public bool SingleStepEnabled {get; set;}

Capability Group

IviRFSigGenPowerStep

Related Items

ConfigureDwell

Also In This Interface

Start | Stop | Size | SingleStepEnabled | Dwell | ConfigureStartStop | ConfigureDwell | Reset | IIviRFSigGenPowerStep Overview


Dwell Property

IIviRFSigGenPowerStep.Dwell Property

Specifies the duration of one step.

[Visual Basic]
Property Get Dwell() As Double
Property Let Dwell(value As Double)
[C++]
HRESULT get_Dwell(double* value);
HRESULT put_Dwell(double value);
[ANSI C]
HRESULT IIviRFSigGenPowerStep_get_Dwell(IIviRFSigGenPowerStep* This, double* value);
HRESULT IIviRFSigGenPowerStep_put_Dwell(IIviRFSigGenPowerStep* This, double value);
[C#]
public double Dwell {get; set;}

Capability Group

IviRFSigGenPowerStep

Related Items

ConfigureDwell

Also In This Interface

Start | Stop | Size | SingleStepEnabled | Dwell | ConfigureStartStop | ConfigureDwell | Reset | IIviRFSigGenPowerStep Overview


ConfigureStartStop Method

IIviRFSigGenPowerStep.ConfigureStartStop Method

This function configures the attributes that control the power steps of the generator's RF output signal.

[Visual Basic]
Sub ConfigureStartStop( _
   Start As Double, _
   Stop As Double, _
   StepSize As Double _
)
[C++]
HRESULT ConfigureStartStop(
   double Start,
   double Stop,
   double StepSize
);
[ANSI C]
HRESULT IIviRFSigGenPowerStep_ConfigureStartStop(
   IIviRFSigGenPowerStep* This
   double Start,
   double Stop,
   double StepSize
);
[C#]
public void ConfigureStartStop(
   double Start,
   double Stop,
   double StepSize
);

Parameters

Start
Specifies the start power of the stepping. The driver uses this value to set the Power Step Start attribute.
Stop
Specifies the stop power of the stepping. The driver uses this value to set the Power Step Stop attribute.
StepSize
Specifies the size of one step. The driver uses this value to set the Power Step Size attribute.

Capability Group

IviRFSigGenPowerStep

Related Items

Start | Stop | Size

Also In This Interface

Start | Stop | Size | SingleStepEnabled | Dwell | ConfigureStartStop | ConfigureDwell | Reset | IIviRFSigGenPowerStep Overview


ConfigureDwell Method

IIviRFSigGenPowerStep.ConfigureDwell Method

This function configures the attributes that control the stepping.

[Visual Basic]
Sub ConfigureDwell( _
   SingleStepEnabled As Boolean, _
   Dwell As Double _
)
[C++]
HRESULT ConfigureDwell(
   VARIANT_BOOL SingleStepEnabled,
   double Dwell
);
[ANSI C]
HRESULT IIviRFSigGenPowerStep_ConfigureDwell(
   IIviRFSigGenPowerStep* This
   VARIANT_BOOL SingleStepEnabled,
   double Dwell
);
[C#]
public void ConfigureDwell(
   bool SingleStepEnabled,
   double Dwell
);

Parameters

SingleStepEnabled
Specifies whether the trigger initiates the next step. The driver uses this value to set the Power Step Single Step Enabled attribute.
Dwell
Specifies the duration of one power step. The driver uses this value to set the Power Step Dwell attribute.

Capability Group

IviRFSigGenPowerStep

Related Items

SingleStepEnabled | Dwell

Also In This Interface

Start | Stop | Size | SingleStepEnabled | Dwell | ConfigureStartStop | ConfigureDwell | Reset | IIviRFSigGenPowerStep Overview


Reset Method

IIviRFSigGenPowerStep.Reset Method

This function resets the stepping if single step is enabled.

[Visual Basic]
Sub Reset()
[C++]
HRESULT Reset();
[ANSI C]
HRESULT IIviRFSigGenPowerStep_Reset(
   IIviRFSigGenPowerStep* This);
[C#]
public void Reset();

Capability Group

IviRFSigGenPowerStep

Also In This Interface

Start | Stop | Size | SingleStepEnabled | Dwell | ConfigureStartStop | ConfigureDwell | Reset | IIviRFSigGenPowerStep Overview


IIviRFSigGenPowerSweep Interface

IVI RFSigGen class-compliant power sweep interface

Properties

Start | Specifies the start power of the sweep.
Stop | Specifies the stop power of the sweep.
Time | Specifies the duration of one sweep from start to stop power.

Methods

ConfigureStartStop This function configures the start and the stop power for the sweep.


Start Property

IIviRFSigGenPowerSweep.Start Property

Specifies the start power of the sweep.

[Visual Basic]
Property Get Start() As Double
Property Let Start(value As Double)
[C++]
HRESULT get_Start(double* value);
HRESULT put_Start(double value);
[ANSI C]
HRESULT IIviRFSigGenPowerSweep_get_Start(IIviRFSigGenPowerSweep* This, double* value);
HRESULT IIviRFSigGenPowerSweep_put_Start(IIviRFSigGenPowerSweep* This, double value);
[C#]
public double Start {get; set;}

Capability Group

IviRFSigGenPowerSweep

Related Items

ConfigureStartStop

Also In This Interface

Start | Stop | Time | ConfigureStartStop | IIviRFSigGenPowerSweep Overview


Stop Property

IIviRFSigGenPowerSweep.Stop Property

Specifies the stop power of the sweep.

[Visual Basic]
Property Get Stop() As Double
Property Let Stop(value As Double)
[C++]
HRESULT get_Stop(double* value);
HRESULT put_Stop(double value);
[ANSI C]
HRESULT IIviRFSigGenPowerSweep_get_Stop(IIviRFSigGenPowerSweep* This, double* value);
HRESULT IIviRFSigGenPowerSweep_put_Stop(IIviRFSigGenPowerSweep* This, double value);
[C#]
public double Stop {get; set;}

Capability Group

IviRFSigGenPowerSweep

Related Items

ConfigureStartStop

Also In This Interface

Start | Stop | Time | ConfigureStartStop | IIviRFSigGenPowerSweep Overview


Time Property

IIviRFSigGenPowerSweep.Time Property

Specifies the duration of one sweep from start to stop power.

[Visual Basic]
Property Get Time() As Double
Property Let Time(value As Double)
[C++]
HRESULT get_Time(double* value);
HRESULT put_Time(double value);
[ANSI C]
HRESULT IIviRFSigGenPowerSweep_get_Time(IIviRFSigGenPowerSweep* This, double* value);
HRESULT IIviRFSigGenPowerSweep_put_Time(IIviRFSigGenPowerSweep* This, double value);
[C#]
public double Time {get; set;}

Capability Group

IviRFSigGenPowerSweep

Also In This Interface

Start | Stop | Time | ConfigureStartStop | IIviRFSigGenPowerSweep Overview


ConfigureStartStop Method

IIviRFSigGenPowerSweep.ConfigureStartStop Method

This function configures the start and the stop power for the sweep.

[Visual Basic]
Sub ConfigureStartStop( _
   Start As Double, _
   Stop As Double _
)
[C++]
HRESULT ConfigureStartStop(
   double Start,
   double Stop
);
[ANSI C]
HRESULT IIviRFSigGenPowerSweep_ConfigureStartStop(
   IIviRFSigGenPowerSweep* This
   double Start,
   double Stop
);
[C#]
public void ConfigureStartStop(
   double Start,
   double Stop
);

Parameters

Start
Specifies the start power of the sweep. The driver uses this value to set the Power Sweep Start attribute.
Stop
Specifies the stop power of the sweep. The driver uses this value to set the Power Sweep Stop attribute.

Capability Group

IviRFSigGenPowerSweep

Related Items

Start | Stop

Also In This Interface

Start | Stop | Time | ConfigureStartStop | IIviRFSigGenPowerSweep Overview


IIviRFSigGenPulseGenerator Interface

IVI RFSigGen class-compliant pulse generator interface

Properties

Double | Pointer to the class-compliant IIviRFSigGenPulseGeneratorDouble interface
Output | Pointer to the class-compliant IIviRFSigGenPulseGeneratorOutput interface
InternalTriggerPeriod | Specifies the period of the pulse generator's output signal.
Width | Specifies the width of the output pulse.
GatingEnabled | Enables or disables trigger gating.
TriggerSource | Specifies the source of the signal the pulse generator uses to generate one pulse.
ExternalTriggerSlope | Specifies whether the event occurs on the rising or falling edge of the trigger input signal.
ExternalTriggerDelay | Specifies the delay for starting the output signal with respect to the trigger input.

Methods

Configure | This function configures the pulse generator within the RF signal generator.
ConfigureExternalTrigger | This function configures the external trigger for the pulse generator.


Double Property

IIviRFSigGenPulseGenerator.Double Property

Pointer to the class-compliant IIviRFSigGenPulseGeneratorDouble interface

[Visual Basic]
Property Get Double() As IIviRFSigGenPulseGeneratorDouble
[C++]
HRESULT get_Double(IIviRFSigGenPulseGeneratorDouble** value);
[ANSI C]
HRESULT IIviRFSigGenPulseGenerator_get_Double(IIviRFSigGenPulseGenerator* This, IIviRFSigGenPulseGeneratorDouble** value);
[C#]
public IIviRFSigGenPulseGeneratorDouble Double {get;}

Capability Group

IviRFSigGenPulseDoubleGenerator

Also In This Interface

Double | Output | InternalTriggerPeriod | Width | GatingEnabled | TriggerSource | ExternalTriggerSlope | ExternalTriggerDelay | Configure | ConfigureExternalTrigger | IIviRFSigGenPulseGenerator Overview


Output Property

IIviRFSigGenPulseGenerator.Output Property

Pointer to the class-compliant IIviRFSigGenPulseGeneratorOutput interface

[Visual Basic]
Property Get Output() As IIviRFSigGenPulseGeneratorOutput
[C++]
HRESULT get_Output(IIviRFSigGenPulseGeneratorOutput** value);
[ANSI C]
HRESULT IIviRFSigGenPulseGenerator_get_Output(IIviRFSigGenPulseGenerator* This, IIviRFSigGenPulseGeneratorOutput** value);
[C#]
public IIviRFSigGenPulseGeneratorOutput Output {get;}

Capability Group

IviRFSigGenPulseGeneratorOutput

Also In This Interface

Double | Output | InternalTriggerPeriod | Width | GatingEnabled | TriggerSource | ExternalTriggerSlope | ExternalTriggerDelay | Configure | ConfigureExternalTrigger | IIviRFSigGenPulseGenerator Overview


InternalTriggerPeriod Property

IIviRFSigGenPulseGenerator.InternalTriggerPeriod Property

Specifies the period of the pulse generator's output signal.

[Visual Basic]
Property Get InternalTriggerPeriod() As Double
Property Let InternalTriggerPeriod(value As Double)
[C++]
HRESULT get_InternalTriggerPeriod(double* value);
HRESULT put_InternalTriggerPeriod(double value);
[ANSI C]
HRESULT IIviRFSigGenPulseGenerator_get_InternalTriggerPeriod(IIviRFSigGenPulseGenerator* This, double* value);
HRESULT IIviRFSigGenPulseGenerator_put_InternalTriggerPeriod(IIviRFSigGenPulseGenerator* This, double value);
[C#]
public double InternalTriggerPeriod {get; set;}

Capability Group

IviRFSigGenPulseGenerator

Also In This Interface

Double | Output | InternalTriggerPeriod | Width | GatingEnabled | TriggerSource | ExternalTriggerSlope | ExternalTriggerDelay | Configure | ConfigureExternalTrigger | IIviRFSigGenPulseGenerator Overview


Width Property

IIviRFSigGenPulseGenerator.Width Property

Specifies the width of the output pulse.

[Visual Basic]
Property Get Width() As Double
Property Let Width(value As Double)
[C++]
HRESULT get_Width(double* value);
HRESULT put_Width(double value);
[ANSI C]
HRESULT IIviRFSigGenPulseGenerator_get_Width(IIviRFSigGenPulseGenerator* This, double* value);
HRESULT IIviRFSigGenPulseGenerator_put_Width(IIviRFSigGenPulseGenerator* This, double value);
[C#]
public double Width {get; set;}

Capability Group

IviRFSigGenPulseGenerator

Related Items

Configure

Also In This Interface

Double | Output | InternalTriggerPeriod | Width | GatingEnabled | TriggerSource | ExternalTriggerSlope | ExternalTriggerDelay | Configure | ConfigureExternalTrigger | IIviRFSigGenPulseGenerator Overview


GatingEnabled Property

IIviRFSigGenPulseGenerator.GatingEnabled Property

Enables or disables trigger gating.

[Visual Basic]
Property Get GatingEnabled() As Boolean
Property Let GatingEnabled(value As Boolean)
[C++]
HRESULT get_GatingEnabled(VARIANT_BOOL* value);
HRESULT put_GatingEnabled(VARIANT_BOOL value);
[ANSI C]
HRESULT IIviRFSigGenPulseGenerator_get_GatingEnabled(IIviRFSigGenPulseGenerator* This, VARIANT_BOOL* value);
HRESULT IIviRFSigGenPulseGenerator_put_GatingEnabled(IIviRFSigGenPulseGenerator* This, VARIANT_BOOL value);
[C#]
public bool GatingEnabled {get; set;}

Capability Group

IviRFSigGenPulseGenerator

Related Items

Configure

Also In This Interface

Double | Output | InternalTriggerPeriod | Width | GatingEnabled | TriggerSource | ExternalTriggerSlope | ExternalTriggerDelay | Configure | ConfigureExternalTrigger | IIviRFSigGenPulseGenerator Overview


TriggerSource Property

IIviRFSigGenPulseGenerator.TriggerSource Property

Specifies the source of the signal the pulse generator uses to generate one pulse.

[Visual Basic]
Property Get TriggerSource() As IviRFSigGenPulseTriggerSourceEnum
Property Let TriggerSource(value As IviRFSigGenPulseTriggerSourceEnum)
[C++]
HRESULT get_TriggerSource(IviRFSigGenPulseTriggerSourceEnum* value);
HRESULT put_TriggerSource(IviRFSigGenPulseTriggerSourceEnum value);
[ANSI C]
HRESULT IIviRFSigGenPulseGenerator_get_TriggerSource(IIviRFSigGenPulseGenerator* This, IviRFSigGenPulseTriggerSourceEnum* value);
HRESULT IIviRFSigGenPulseGenerator_put_TriggerSource(IIviRFSigGenPulseGenerator* This, IviRFSigGenPulseTriggerSourceEnum value);
[C#]
public IviRFSigGenPulseTriggerSourceEnum TriggerSource {get; set;}

Capability Group

IviRFSigGenPulseGenerator

Related Items

Configure

Also In This Interface

Double | Output | InternalTriggerPeriod | Width | GatingEnabled | TriggerSource | ExternalTriggerSlope | ExternalTriggerDelay | Configure | ConfigureExternalTrigger | IIviRFSigGenPulseGenerator Overview


ExternalTriggerSlope Property

IIviRFSigGenPulseGenerator.ExternalTriggerSlope Property

Specifies whether the event occurs on the rising or falling edge of the trigger input signal.

[Visual Basic]
Property Get ExternalTriggerSlope() As IviRFSigGenPulseExternalTriggerSlopeEnum
Property Let ExternalTriggerSlope(value As IviRFSigGenPulseExternalTriggerSlopeEnum)
[C++]
HRESULT get_ExternalTriggerSlope(IviRFSigGenPulseExternalTriggerSlopeEnum* value);
HRESULT put_ExternalTriggerSlope(IviRFSigGenPulseExternalTriggerSlopeEnum value);
[ANSI C]
HRESULT IIviRFSigGenPulseGenerator_get_ExternalTriggerSlope(IIviRFSigGenPulseGenerator* This, IviRFSigGenPulseExternalTriggerSlopeEnum* value);
HRESULT IIviRFSigGenPulseGenerator_put_ExternalTriggerSlope(IIviRFSigGenPulseGenerator* This, IviRFSigGenPulseExternalTriggerSlopeEnum value);
[C#]
public IviRFSigGenPulseExternalTriggerSlopeEnum ExternalTriggerSlope {get; set;}

Capability Group

IviRFSigGenPulseGenerator

Related Items

ConfigureExternalTrigger

Also In This Interface

Double | Output | InternalTriggerPeriod | Width | GatingEnabled | TriggerSource | ExternalTriggerSlope | ExternalTriggerDelay | Configure | ConfigureExternalTrigger | IIviRFSigGenPulseGenerator Overview


ExternalTriggerDelay Property

IIviRFSigGenPulseGenerator.ExternalTriggerDelay Property

Specifies the delay for starting the output signal with respect to the trigger input.

[Visual Basic]
Property Get ExternalTriggerDelay() As Double
Property Let ExternalTriggerDelay(value As Double)
[C++]
HRESULT get_ExternalTriggerDelay(double* value);
HRESULT put_ExternalTriggerDelay(double value);
[ANSI C]
HRESULT IIviRFSigGenPulseGenerator_get_ExternalTriggerDelay(IIviRFSigGenPulseGenerator* This, double* value);
HRESULT IIviRFSigGenPulseGenerator_put_ExternalTriggerDelay(IIviRFSigGenPulseGenerator* This, double value);
[C#]
public double ExternalTriggerDelay {get; set;}

Capability Group

IviRFSigGenPulseGenerator

Related Items

ConfigureExternalTrigger

Also In This Interface

Double | Output | InternalTriggerPeriod | Width | GatingEnabled | TriggerSource | ExternalTriggerSlope | ExternalTriggerDelay | Configure | ConfigureExternalTrigger | IIviRFSigGenPulseGenerator Overview


Configure Method

IIviRFSigGenPulseGenerator.Configure Method

This function configures the pulse generator within the RF signal generator.

[Visual Basic]
Sub Configure( _
   PulseTriggerSource As IviRFSigGenPulseTriggerSourceEnum, _
   PulseWidth As Double, _
   GatingEnabled As Boolean _
)
[C++]
HRESULT Configure(
   IviRFSigGenPulseTriggerSourceEnum PulseTriggerSource,
   double PulseWidth,
   VARIANT_BOOL GatingEnabled
);
[ANSI C]
HRESULT IIviRFSigGenPulseGenerator_Configure(
   IIviRFSigGenPulseGenerator* This
   IviRFSigGenPulseTriggerSourceEnum PulseTriggerSource,
   double PulseWidth,
   VARIANT_BOOL GatingEnabled
);
[C#]
public void Configure(
   IviRFSigGenPulseTriggerSourceEnum PulseTriggerSource,
   double PulseWidth,
   bool GatingEnabled
);

Parameters

PulseTriggerSource
Specifies the source of the signal the pulse generator uses to generate one pulse.
PulseWidth
Specifies the width of the output pulse.
GatingEnabled
Enables or disables trigger gating.

Capability Group

IviRFSigGenPulseGenerator

Related Items

TriggerSource | Width | GatingEnabled

Also In This Interface

Double | Output | InternalTriggerPeriod | Width | GatingEnabled | TriggerSource | ExternalTriggerSlope | ExternalTriggerDelay | Configure | ConfigureExternalTrigger | IIviRFSigGenPulseGenerator Overview


ConfigureExternalTrigger Method

IIviRFSigGenPulseGenerator.ConfigureExternalTrigger Method

This function configures the external trigger for the pulse generator.

[Visual Basic]
Sub ConfigureExternalTrigger( _
   Slope As IviRFSigGenPulseExternalTriggerSlopeEnum, _
   Delay As Double _
)
[C++]
HRESULT ConfigureExternalTrigger(
   IviRFSigGenPulseExternalTriggerSlopeEnum Slope,
   double Delay
);
[ANSI C]
HRESULT IIviRFSigGenPulseGenerator_ConfigureExternalTrigger(
   IIviRFSigGenPulseGenerator* This
   IviRFSigGenPulseExternalTriggerSlopeEnum Slope,
   double Delay
);
[C#]
public void ConfigureExternalTrigger(
   IviRFSigGenPulseExternalTriggerSlopeEnum Slope,
   double Delay
);

Parameters

Slope
Specifies whether the event occurs on the rising or falling edge of the trigger input signal.
Delay
Specifies the delay for starting the output signal with respect to the trigger input.

Capability Group

IviRFSigGenPulseGenerator

Related Items

ExternalTriggerSlope | ExternalTriggerDelay

Also In This Interface

Double | Output | InternalTriggerPeriod | Width | GatingEnabled | TriggerSource | ExternalTriggerSlope | ExternalTriggerDelay | Configure | ConfigureExternalTrigger | IIviRFSigGenPulseGenerator Overview


IIviRFSigGenPulseGeneratorDouble Interface

IVI RFSigGen class-compliant pulse double generator interface

Properties

Enabled | Turns double pulse mode on/off.
Delay | Specifies the delay of the second pulse.

Methods

Configure This function configures the double pulse state and delay.


Enabled Property

IIviRFSigGenPulseGeneratorDouble.Enabled Property

Turns double pulse mode on/off.

[Visual Basic]
Property Get Enabled() As Boolean
Property Let Enabled(value As Boolean)
[C++]
HRESULT get_Enabled(VARIANT_BOOL* value);
HRESULT put_Enabled(VARIANT_BOOL value);
[ANSI C]
HRESULT IIviRFSigGenPulseGeneratorDouble_get_Enabled(IIviRFSigGenPulseGeneratorDouble* This, VARIANT_BOOL* value);
HRESULT IIviRFSigGenPulseGeneratorDouble_put_Enabled(IIviRFSigGenPulseGeneratorDouble* This, VARIANT_BOOL value);
[C#]
public bool Enabled {get; set;}

Capability Group

IviRFSigGenPulseDoubleGenerator

Related Items

Configure

Also In This Interface

Enabled | Delay | Configure | IIviRFSigGenPulseGeneratorDouble Overview


Delay Property

IIviRFSigGenPulseGeneratorDouble.Delay Property

Specifies the delay of the second pulse.

[Visual Basic]
Property Get Delay() As Double
Property Let Delay(value As Double)
[C++]
HRESULT get_Delay(double* value);
HRESULT put_Delay(double value);
[ANSI C]
HRESULT IIviRFSigGenPulseGeneratorDouble_get_Delay(IIviRFSigGenPulseGeneratorDouble* This, double* value);
HRESULT IIviRFSigGenPulseGeneratorDouble_put_Delay(IIviRFSigGenPulseGeneratorDouble* This, double value);
[C#]
public double Delay {get; set;}

Capability Group

IviRFSigGenPulseDoubleGenerator

Related Items

Configure

Also In This Interface

Enabled | Delay | Configure | IIviRFSigGenPulseGeneratorDouble Overview


Configure Method

IIviRFSigGenPulseGeneratorDouble.Configure Method

This function configures the double pulse state and delay.

[Visual Basic]
Sub Configure( _
   Enabled As Boolean, _
   Delay As Double _
)
[C++]
HRESULT Configure(
   VARIANT_BOOL Enabled,
   double Delay
);
[ANSI C]
HRESULT IIviRFSigGenPulseGeneratorDouble_Configure(
   IIviRFSigGenPulseGeneratorDouble* This
   VARIANT_BOOL Enabled,
   double Delay
);
[C#]
public void Configure(
   bool Enabled,
   double Delay
);

Parameters

Enabled
Turns double pulse mode on/off.
Delay
Specifies the delay of the second pulse.

Capability Group

IviRFSigGenPulseDoubleGenerator

Related Items

Enabled | Delay

Also In This Interface

Enabled | Delay | Configure | IIviRFSigGenPulseGeneratorDouble Overview


IIviRFSigGenPulseGeneratorOutput Interface

IVI RFSigGen class-compliant pulse generator output interface

Properties

Polarity | Specifies the polarity of the output signal.
Enabled | Enables or disables the pulse generator external output.

Methods

Configure This function configures the output and polarity of the pulse generator.


Polarity Property

IIviRFSigGenPulseGeneratorOutput.Polarity Property

Specifies the polarity of the output signal.

[Visual Basic]
Property Get Polarity() As IviRFSigGenPulseOutputPolarityEnum
Property Let Polarity(value As IviRFSigGenPulseOutputPolarityEnum)
[C++]
HRESULT get_Polarity(IviRFSigGenPulseOutputPolarityEnum* value);
HRESULT put_Polarity(IviRFSigGenPulseOutputPolarityEnum value);
[ANSI C]
HRESULT IIviRFSigGenPulseGeneratorOutput_get_Polarity(IIviRFSigGenPulseGeneratorOutput* This, IviRFSigGenPulseOutputPolarityEnum* value);
HRESULT IIviRFSigGenPulseGeneratorOutput_put_Polarity(IIviRFSigGenPulseGeneratorOutput* This, IviRFSigGenPulseOutputPolarityEnum value);
[C#]
public IviRFSigGenPulseOutputPolarityEnum Polarity {get; set;}

Capability Group

IviRFSigGenPulseGeneratorOutput

Related Items

Configure

Also In This Interface

Polarity | Enabled | Configure | IIviRFSigGenPulseGeneratorOutput Overview


Enabled Property

IIviRFSigGenPulseGeneratorOutput.Enabled Property

Enables or disables the pulse generator external output.

[Visual Basic]
Property Get Enabled() As Boolean
Property Let Enabled(value As Boolean)
[C++]
HRESULT get_Enabled(VARIANT_BOOL* value);
HRESULT put_Enabled(VARIANT_BOOL value);
[ANSI C]
HRESULT IIviRFSigGenPulseGeneratorOutput_get_Enabled(IIviRFSigGenPulseGeneratorOutput* This, VARIANT_BOOL* value);
HRESULT IIviRFSigGenPulseGeneratorOutput_put_Enabled(IIviRFSigGenPulseGeneratorOutput* This, VARIANT_BOOL value);
[C#]
public bool Enabled {get; set;}

Capability Group

IviRFSigGenPulseGeneratorOutput

Related Items

Configure

Also In This Interface

Polarity | Enabled | Configure | IIviRFSigGenPulseGeneratorOutput Overview


Configure Method

IIviRFSigGenPulseGeneratorOutput.Configure Method

This function configures the output and polarity of the pulse generator.

[Visual Basic]
Sub Configure( _
   Polarity As IviRFSigGenPulseOutputPolarityEnum, _
   Enabled As Boolean _
)
[C++]
HRESULT Configure(
   IviRFSigGenPulseOutputPolarityEnum Polarity,
   VARIANT_BOOL Enabled
);
[ANSI C]
HRESULT IIviRFSigGenPulseGeneratorOutput_Configure(
   IIviRFSigGenPulseGeneratorOutput* This
   IviRFSigGenPulseOutputPolarityEnum Polarity,
   VARIANT_BOOL Enabled
);
[C#]
public void Configure(
   IviRFSigGenPulseOutputPolarityEnum Polarity,
   bool Enabled
);

Parameters

Polarity
Specifies the polarity of the output signal.
Enabled
Enables or disables the pulse generator external output.

Capability Group

IviRFSigGenPulseGeneratorOutput

Related Items

Polarity | Enabled

Also In This Interface

Polarity | Enabled | Configure | IIviRFSigGenPulseGeneratorOutput Overview


IIviRFSigGenPulseModulation Interface

IVI RFSigGen class-compliant pulse modulation interface

Properties

Enabled | Enables or disables pulse modulation of the RF output signal.
Source | Specifies the source of the signal that is used as the modulating signal.
ExternalPolarity | Specifies the polarity of the external source signal.


Enabled Property

IIviRFSigGenPulseModulation.Enabled Property

Enables or disables pulse modulation of the RF output signal.

[Visual Basic]
Property Get Enabled() As Boolean
Property Let Enabled(value As Boolean)
[C++]
HRESULT get_Enabled(VARIANT_BOOL* value);
HRESULT put_Enabled(VARIANT_BOOL value);
[ANSI C]
HRESULT IIviRFSigGenPulseModulation_get_Enabled(IIviRFSigGenPulseModulation* This, VARIANT_BOOL* value);
HRESULT IIviRFSigGenPulseModulation_put_Enabled(IIviRFSigGenPulseModulation* This, VARIANT_BOOL value);
[C#]
public bool Enabled {get; set;}

Capability Group

IviRFSigGenModulatePulse

Also In This Interface

Enabled | Source | ExternalPolarity | IIviRFSigGenPulseModulation Overview


Source Property

IIviRFSigGenPulseModulation.Source Property

Specifies the source of the signal that is used as the modulating signal.

[Visual Basic]
Property Get Source() As IviRFSigGenPulseModulationSourceEnum
Property Let Source(value As IviRFSigGenPulseModulationSourceEnum)
[C++]
HRESULT get_Source(IviRFSigGenPulseModulationSourceEnum* value);
HRESULT put_Source(IviRFSigGenPulseModulationSourceEnum value);
[ANSI C]
HRESULT IIviRFSigGenPulseModulation_get_Source(IIviRFSigGenPulseModulation* This, IviRFSigGenPulseModulationSourceEnum* value);
HRESULT IIviRFSigGenPulseModulation_put_Source(IIviRFSigGenPulseModulation* This, IviRFSigGenPulseModulationSourceEnum value);
[C#]
public IviRFSigGenPulseModulationSourceEnum Source {get; set;}

Capability Group

IviRFSigGenModulatePulse

Also In This Interface

Enabled | Source | ExternalPolarity | IIviRFSigGenPulseModulation Overview


ExternalPolarity Property

IIviRFSigGenPulseModulation.ExternalPolarity Property

Specifies the polarity of the external source signal.

[Visual Basic]
Property Get ExternalPolarity() As IviRFSigGenPulseModulationExternalPolarityEnum
Property Let ExternalPolarity(value As IviRFSigGenPulseModulationExternalPolarityEnum)
[C++]
HRESULT get_ExternalPolarity(IviRFSigGenPulseModulationExternalPolarityEnum* value);
HRESULT put_ExternalPolarity(IviRFSigGenPulseModulationExternalPolarityEnum value);
[ANSI C]
HRESULT IIviRFSigGenPulseModulation_get_ExternalPolarity(IIviRFSigGenPulseModulation* This, IviRFSigGenPulseModulationExternalPolarityEnum* value);
HRESULT IIviRFSigGenPulseModulation_put_ExternalPolarity(IIviRFSigGenPulseModulation* This, IviRFSigGenPulseModulationExternalPolarityEnum value);
[C#]
public IviRFSigGenPulseModulationExternalPolarityEnum ExternalPolarity {get; set;}

Capability Group

IviRFSigGenModulatePulse

Also In This Interface

Enabled | Source | ExternalPolarity | IIviRFSigGenPulseModulation Overview


IIviRFSigGenReferenceOscillator Interface

IVI RFSigGen class-compliant reference oscillator interface

Properties

Source | Specifies the reference oscillator source.
ExternalFrequency | Specifies the frequency of the external signal, which is used as reference for internal RF frequency generation.

Methods

Configure This function configures the signal generator's reference oscillator.


Source Property

IIviRFSigGenReferenceOscillator.Source Property

Specifies the reference oscillator source.

[Visual Basic]
Property Get Source() As IviRFSigGenReferenceOscillatorSourceEnum
Property Let Source(value As IviRFSigGenReferenceOscillatorSourceEnum)
[C++]
HRESULT get_Source(IviRFSigGenReferenceOscillatorSourceEnum* value);
HRESULT put_Source(IviRFSigGenReferenceOscillatorSourceEnum value);
[ANSI C]
HRESULT IIviRFSigGenReferenceOscillator_get_Source(IIviRFSigGenReferenceOscillator* This, IviRFSigGenReferenceOscillatorSourceEnum* value);
HRESULT IIviRFSigGenReferenceOscillator_put_Source(IIviRFSigGenReferenceOscillator* This, IviRFSigGenReferenceOscillatorSourceEnum value);
[C#]
public IviRFSigGenReferenceOscillatorSourceEnum Source {get; set;}

Capability Group

IviRFSigGenReferenceOscillator

Related Items

Configure

Also In This Interface

Source | ExternalFrequency | Configure | IIviRFSigGenReferenceOscillator Overview


ExternalFrequency Property

IIviRFSigGenReferenceOscillator.ExternalFrequency Property

Specifies the frequency of the external signal, which is used as reference for internal RF frequency generation.

[Visual Basic]
Property Get ExternalFrequency() As Double
Property Let ExternalFrequency(value As Double)
[C++]
HRESULT get_ExternalFrequency(double* value);
HRESULT put_ExternalFrequency(double value);
[ANSI C]
HRESULT IIviRFSigGenReferenceOscillator_get_ExternalFrequency(IIviRFSigGenReferenceOscillator* This, double* value);
HRESULT IIviRFSigGenReferenceOscillator_put_ExternalFrequency(IIviRFSigGenReferenceOscillator* This, double value);
[C#]
public double ExternalFrequency {get; set;}

Capability Group

IviRFSigGenReferenceOscillator

Related Items

Configure

Also In This Interface

Source | ExternalFrequency | Configure | IIviRFSigGenReferenceOscillator Overview


Configure Method

IIviRFSigGenReferenceOscillator.Configure Method

This function configures the signal generator's reference oscillator.

[Visual Basic]
Sub Configure( _
   Source As IviRFSigGenReferenceOscillatorSourceEnum, _
   Frequency As Double _
)
[C++]
HRESULT Configure(
   IviRFSigGenReferenceOscillatorSourceEnum Source,
   double Frequency
);
[ANSI C]
HRESULT IIviRFSigGenReferenceOscillator_Configure(
   IIviRFSigGenReferenceOscillator* This
   IviRFSigGenReferenceOscillatorSourceEnum Source,
   double Frequency
);
[C#]
public void Configure(
   IviRFSigGenReferenceOscillatorSourceEnum Source,
   double Frequency
);

Parameters

Source
Specifies source of reference frequency signal. The driver uses this value to set the Reference Oscillator Source attribute.
Frequency
Specifies the frequency of the external reference oscillator. This parameter is only used if the Source is set to External. The driver uses this value to set the Reference Oscillator Frequency attribute.

Capability Group

IviRFSigGenReferenceOscillator

Related Items

Source | ExternalFrequency

Also In This Interface

Source | ExternalFrequency | Configure | IIviRFSigGenReferenceOscillator Overview


IIviRFSigGenRF Interface

IVI RFSigGen class-compliant RF interface

Properties

Frequency | Specifies the frequency of the generated RF output signal.
Level | Specifies the amplitude (power/level) of the RF output signal.
OutputEnabled | Enables or disables the RF output signal.

Methods

Configure | This function configures the frequency and the power level of the RF output signal.
IsSettled | This function queries the state of the RF output signal.
WaitUntilSettled | This function returns if the state of the RF output signal has settled.
DisableAllModulation | This function disables all currently enabled modulations.


Frequency Property

IIviRFSigGenRF.Frequency Property

Specifies the frequency of the generated RF output signal.

[Visual Basic]
Property Get Frequency() As Double
Property Let Frequency(value As Double)
[C++]
HRESULT get_Frequency(double* value);
HRESULT put_Frequency(double value);
[ANSI C]
HRESULT IIviRFSigGenRF_get_Frequency(IIviRFSigGenRF* This, double* value);
HRESULT IIviRFSigGenRF_put_Frequency(IIviRFSigGenRF* This, double value);
[C#]
public double Frequency {get; set;}

Capability Group

IviRFSigGenBase

Related Items

Configure

Also In This Interface

Frequency | Level | OutputEnabled | Configure | IsSettled | WaitUntilSettled | DisableAllModulation | IIviRFSigGenRF Overview


Level Property

IIviRFSigGenRF.Level Property

Specifies the amplitude (power/level) of the RF output signal.

[Visual Basic]
Property Get Level() As Double
Property Let Level(value As Double)
[C++]
HRESULT get_Level(double* value);
HRESULT put_Level(double value);
[ANSI C]
HRESULT IIviRFSigGenRF_get_Level(IIviRFSigGenRF* This, double* value);
HRESULT IIviRFSigGenRF_put_Level(IIviRFSigGenRF* This, double value);
[C#]
public double Level {get; set;}

Capability Group

IviRFSigGenBase

Related Items

Configure

Also In This Interface

Frequency | Level | OutputEnabled | Configure | IsSettled | WaitUntilSettled | DisableAllModulation | IIviRFSigGenRF Overview


OutputEnabled Property

IIviRFSigGenRF.OutputEnabled Property

Enables or disables the RF output signal.

[Visual Basic]
Property Get OutputEnabled() As Boolean
Property Let OutputEnabled(value As Boolean)
[C++]
HRESULT get_OutputEnabled(VARIANT_BOOL* value);
HRESULT put_OutputEnabled(VARIANT_BOOL value);
[ANSI C]
HRESULT IIviRFSigGenRF_get_OutputEnabled(IIviRFSigGenRF* This, VARIANT_BOOL* value);
HRESULT IIviRFSigGenRF_put_OutputEnabled(IIviRFSigGenRF* This, VARIANT_BOOL value);
[C#]
public bool OutputEnabled {get; set;}

Capability Group

IviRFSigGenBase

Also In This Interface

Frequency | Level | OutputEnabled | Configure | IsSettled | WaitUntilSettled | DisableAllModulation | IIviRFSigGenRF Overview


Configure Method

IIviRFSigGenRF.Configure Method

This function configures the frequency and the power level of the RF output signal.

[Visual Basic]
Sub Configure( _
   Frequency As Double, _
   PowerLevel As Double _
)
[C++]
HRESULT Configure(
   double Frequency,
   double PowerLevel
);
[ANSI C]
HRESULT IIviRFSigGenRF_Configure(
   IIviRFSigGenRF* This
   double Frequency,
   double PowerLevel
);
[C#]
public void Configure(
   double Frequency,
   double PowerLevel
);

Parameters

Frequency
Specifies the frequency of the generated RF output signal.
PowerLevel
Specifies the amplitude (power/level) of the RF output signal.

Capability Group

IviRFSigGenBase

Related Items

Frequency | Level

Also In This Interface

Frequency | Level | OutputEnabled | Configure | IsSettled | WaitUntilSettled | DisableAllModulation | IIviRFSigGenRF Overview


IsSettled Method

IIviRFSigGenRF.IsSettled Method

This function queries the state of the RF output signal.

[Visual Basic]
Function IsSettled() As Boolean
[C++]
HRESULT IsSettled(
   VARIANT_BOOL* Done
);
[ANSI C]
HRESULT IIviRFSigGenRF_IsSettled(
   IIviRFSigGenRF* This
   VARIANT_BOOL* Done
);
[C#]
public bool IsSettled();

Parameters

Done
Returns True if the output signal is in settled, False otherwise.

Capability Group

IviRFSigGenBase

Related Items

WaitUntilSettled

Also In This Interface

Frequency | Level | OutputEnabled | Configure | IsSettled | WaitUntilSettled | DisableAllModulation | IIviRFSigGenRF Overview


WaitUntilSettled Method

IIviRFSigGenRF.WaitUntilSettled Method

This function returns if the state of the RF output signal has settled.

[Visual Basic]
Sub WaitUntilSettled( _
   MaxTimeMilliseconds As Long _
)
[C++]
HRESULT WaitUntilSettled(
   long MaxTimeMilliseconds
);
[ANSI C]
HRESULT IIviRFSigGenRF_WaitUntilSettled(
   IIviRFSigGenRF* This
   long MaxTimeMilliseconds
);
[C#]
public void WaitUntilSettled(
   long MaxTimeMilliseconds
);

Parameters

MaxTimeMilliseconds
Defines the maximum time the function waits for the output to be settled. If the maximum time is exceeded, this function returns the Max Time Exceeded error. The units are milliseconds.

Capability Group

IviRFSigGenBase

Related Items

IsSettled

Also In This Interface

Frequency | Level | OutputEnabled | Configure | IsSettled | WaitUntilSettled | DisableAllModulation | IIviRFSigGenRF Overview


DisableAllModulation Method

IIviRFSigGenRF.DisableAllModulation Method

This function disables all currently enabled modulations.

[Visual Basic]
Sub DisableAllModulation()
[C++]
HRESULT DisableAllModulation();
[ANSI C]
HRESULT IIviRFSigGenRF_DisableAllModulation(
   IIviRFSigGenRF* This);
[C#]
public void DisableAllModulation();

Capability Group

IviRFSigGenBase

Also In This Interface

Frequency | Level | OutputEnabled | Configure | IsSettled | WaitUntilSettled | DisableAllModulation | IIviRFSigGenRF Overview


IIviRFSigGenSweep Interface

IVI RFSigGen class-compliant sweep interface

Properties

FrequencySweep | Pointer to the class-compliant IIviRFSigGenFrequencySweep interface
PowerSweep | Pointer to the class-compliant IIviRFSigGenPowerSweep interface
FrequencyStep | Pointer to the class-compliant IIviRFSigGenFrequencyStep interface
PowerStep | Pointer to the class-compliant IIviRFSigGenPowerStep interface
List | Pointer to the class-compliant IIviRFSigGenList interface
Mode | Specifies whether the RF output signal is a continuous wave or the frequency, the power level or both are swept or stepped.
TriggerSource | Specifies the way to start the sweep or run the sweep continuously.

Methods

Configure This function configures the signal generator whether the RF output signal is a continuous wave or the frequency, the power level or both are swept or stepped.


FrequencySweep Property

IIviRFSigGenSweep.FrequencySweep Property

Pointer to the class-compliant IIviRFSigGenFrequencySweep interface

[Visual Basic]
Property Get FrequencySweep() As IIviRFSigGenFrequencySweep
[C++]
HRESULT get_FrequencySweep(IIviRFSigGenFrequencySweep** value);
[ANSI C]
HRESULT IIviRFSigGenSweep_get_FrequencySweep(IIviRFSigGenSweep* This, IIviRFSigGenFrequencySweep** value);
[C#]
public IIviRFSigGenFrequencySweep FrequencySweep {get;}

Capability Group

IviRFSigGenFrequencySweep

Also In This Interface

FrequencySweep | PowerSweep | FrequencyStep | PowerStep | List | Mode | TriggerSource | Configure | IIviRFSigGenSweep Overview


PowerSweep Property

IIviRFSigGenSweep.PowerSweep Property

Pointer to the class-compliant IIviRFSigGenPowerSweep interface

[Visual Basic]
Property Get PowerSweep() As IIviRFSigGenPowerSweep
[C++]
HRESULT get_PowerSweep(IIviRFSigGenPowerSweep** value);
[ANSI C]
HRESULT IIviRFSigGenSweep_get_PowerSweep(IIviRFSigGenSweep* This, IIviRFSigGenPowerSweep** value);
[C#]
public IIviRFSigGenPowerSweep PowerSweep {get;}

Capability Group

IviRFSigGenPowerSweep

Also In This Interface

FrequencySweep | PowerSweep | FrequencyStep | PowerStep | List | Mode | TriggerSource | Configure | IIviRFSigGenSweep Overview


FrequencyStep Property

IIviRFSigGenSweep.FrequencyStep Property

Pointer to the class-compliant IIviRFSigGenFrequencyStep interface

[Visual Basic]
Property Get FrequencyStep() As IIviRFSigGenFrequencyStep
[C++]
HRESULT get_FrequencyStep(IIviRFSigGenFrequencyStep** value);
[ANSI C]
HRESULT IIviRFSigGenSweep_get_FrequencyStep(IIviRFSigGenSweep* This, IIviRFSigGenFrequencyStep** value);
[C#]
public IIviRFSigGenFrequencyStep FrequencyStep {get;}

Capability Group

IviRFSigGenFrequencyStep

Also In This Interface

FrequencySweep | PowerSweep | FrequencyStep | PowerStep | List | Mode | TriggerSource | Configure | IIviRFSigGenSweep Overview


PowerStep Property

IIviRFSigGenSweep.PowerStep Property

Pointer to the class-compliant IIviRFSigGenPowerStep interface

[Visual Basic]
Property Get PowerStep() As IIviRFSigGenPowerStep
[C++]
HRESULT get_PowerStep(IIviRFSigGenPowerStep** value);
[ANSI C]
HRESULT IIviRFSigGenSweep_get_PowerStep(IIviRFSigGenSweep* This, IIviRFSigGenPowerStep** value);
[C#]
public IIviRFSigGenPowerStep PowerStep {get;}

Capability Group

IviRFSigGenPowerStep

Also In This Interface

FrequencySweep | PowerSweep | FrequencyStep | PowerStep | List | Mode | TriggerSource | Configure | IIviRFSigGenSweep Overview


List Property

IIviRFSigGenSweep.List Property

Pointer to the class-compliant IIviRFSigGenList interface

[Visual Basic]
Property Get List() As IIviRFSigGenList
[C++]
HRESULT get_List(IIviRFSigGenList** value);
[ANSI C]
HRESULT IIviRFSigGenSweep_get_List(IIviRFSigGenSweep* This, IIviRFSigGenList** value);
[C#]
public IIviRFSigGenList List {get;}

Capability Group

IviRFSigGenList

Also In This Interface

FrequencySweep | PowerSweep | FrequencyStep | PowerStep | List | Mode | TriggerSource | Configure | IIviRFSigGenSweep Overview


Mode Property

IIviRFSigGenSweep.Mode Property

Specifies whether the RF output signal is a continuous wave or the frequency, the power level or both are swept or stepped.

[Visual Basic]
Property Get Mode() As IviRFSigGenSweepModeEnum
Property Let Mode(value As IviRFSigGenSweepModeEnum)
[C++]
HRESULT get_Mode(IviRFSigGenSweepModeEnum* value);
HRESULT put_Mode(IviRFSigGenSweepModeEnum value);
[ANSI C]
HRESULT IIviRFSigGenSweep_get_Mode(IIviRFSigGenSweep* This, IviRFSigGenSweepModeEnum* value);
HRESULT IIviRFSigGenSweep_put_Mode(IIviRFSigGenSweep* This, IviRFSigGenSweepModeEnum value);
[C#]
public IviRFSigGenSweepModeEnum Mode {get; set;}

Capability Group

IviRFSigGenSweep

Related Items

Configure

Also In This Interface

FrequencySweep | PowerSweep | FrequencyStep | PowerStep | List | Mode | TriggerSource | Configure | IIviRFSigGenSweep Overview


TriggerSource Property

IIviRFSigGenSweep.TriggerSource Property

Specifies the way to start the sweep or run the sweep continuously.

[Visual Basic]
Property Get TriggerSource() As IviRFSigGenSweepTriggerSourceEnum
Property Let TriggerSource(value As IviRFSigGenSweepTriggerSourceEnum)
[C++]
HRESULT get_TriggerSource(IviRFSigGenSweepTriggerSourceEnum* value);
HRESULT put_TriggerSource(IviRFSigGenSweepTriggerSourceEnum value);
[ANSI C]
HRESULT IIviRFSigGenSweep_get_TriggerSource(IIviRFSigGenSweep* This, IviRFSigGenSweepTriggerSourceEnum* value);
HRESULT IIviRFSigGenSweep_put_TriggerSource(IIviRFSigGenSweep* This, IviRFSigGenSweepTriggerSourceEnum value);
[C#]
public IviRFSigGenSweepTriggerSourceEnum TriggerSource {get; set;}

Capability Group

IviRFSigGenSweep

Related Items

Configure

Also In This Interface

FrequencySweep | PowerSweep | FrequencyStep | PowerStep | List | Mode | TriggerSource | Configure | IIviRFSigGenSweep Overview


Configure Method

IIviRFSigGenSweep.Configure Method

This function configures the signal generator whether the RF output signal is a continuous wave or the frequency, the power level or both are swept or stepped.

[Visual Basic]
Sub Configure( _
   Mode As IviRFSigGenSweepModeEnum, _
   TriggerSource As IviRFSigGenSweepTriggerSourceEnum _
)
[C++]
HRESULT Configure(
   IviRFSigGenSweepModeEnum Mode,
   IviRFSigGenSweepTriggerSourceEnum TriggerSource
);
[ANSI C]
HRESULT IIviRFSigGenSweep_Configure(
   IIviRFSigGenSweep* This
   IviRFSigGenSweepModeEnum Mode,
   IviRFSigGenSweepTriggerSourceEnum TriggerSource
);
[C#]
public void Configure(
   IviRFSigGenSweepModeEnum Mode,
   IviRFSigGenSweepTriggerSourceEnum TriggerSource
);

Parameters

Mode
Specifies whether the RF output signal is a continuous wave or the frequency, the power level or both are swept or stepped.
TriggerSource
Specifies the way to start the sweep or running it continuously. The driver uses this value to set the Sweep Trigger Source attribute.

Capability Group

IviRFSigGenSweep

Related Items

Mode | TriggerSource

Also In This Interface

FrequencySweep | PowerSweep | FrequencyStep | PowerStep | List | Mode | TriggerSource | Configure | IIviRFSigGenSweep Overview


IIviRFSigGenTDMA Interface

IVI RFSigGen class-compliant TDMA base interface

Properties

StandardName | Returns the standard name for the given index.
StandardCount | Returns the count of available standards for TDMA modulation.
SelectedStandard | Specifies the actual standard used by the instrument.
FrameName | Returns the frame name for the given index.
FrameCount | Returns the count of available frame names.
SelectedFrame | Specifies the actual frame/slot used by the instrument.
TriggerSource | Specifies the source of the trigger signal starting the generation of the frame/slot.
ExternalTriggerSlope | Specifies whether the trigger event occurs on the rising or falling edge of the input signal.
ClockSource | Specifies the source of the clock signal used to generate the digital modulation according to the selected standard.
ExternalClockType | Specifies the type of the external clock signal used to generate the digital modulation.

Methods

ConfigureClockSource This function configures the clock source.


StandardName Property

IIviRFSigGenTDMA.StandardName Property

Returns the standard name for the given index.

[Visual Basic]
Property Get StandardName(Index As Long) As String
[C++]
HRESULT get_StandardName(long Index, BSTR* value);
[ANSI C]
HRESULT IIviRFSigGenTDMA_get_StandardName(IIviRFSigGenTDMA* This, long Index, BSTR* value);
[C#]HRESULT get_StandardName(long Index, string value);

Parameters

Index
A one-based index that defines which name to return.

Capability Group

IviRFSigGenTDMABase

Also In This Interface

StandardName | StandardCount | SelectedStandard | FrameName | FrameCount | SelectedFrame | TriggerSource | ExternalTriggerSlope | ClockSource | ExternalClockType | ConfigureClockSource | IIviRFSigGenTDMA Overview


StandardCount Property

IIviRFSigGenTDMA.StandardCount Property

Returns the count of available standards for TDMA modulation.

[Visual Basic]
Property Get StandardCount() As Long
[C++]
HRESULT get_StandardCount(long* value);
[ANSI C]
HRESULT IIviRFSigGenTDMA_get_StandardCount(IIviRFSigGenTDMA* This, long* value);
[C#]
public long StandardCount {get;}

Capability Group

IviRFSigGenTDMABase

Also In This Interface

StandardName | StandardCount | SelectedStandard | FrameName | FrameCount | SelectedFrame | TriggerSource | ExternalTriggerSlope | ClockSource | ExternalClockType | ConfigureClockSource | IIviRFSigGenTDMA Overview


SelectedStandard Property

IIviRFSigGenTDMA.SelectedStandard Property

Specifies the actual standard used by the instrument.

[Visual Basic]
Property Get SelectedStandard() As String
Property Let SelectedStandard(value As String)
[C++]
HRESULT get_SelectedStandard(BSTR* value);
HRESULT put_SelectedStandard(BSTR value);
[ANSI C]
HRESULT IIviRFSigGenTDMA_get_SelectedStandard(IIviRFSigGenTDMA* This, BSTR* value);
HRESULT IIviRFSigGenTDMA_put_SelectedStandard(IIviRFSigGenTDMA* This, BSTR value);
[C#]
public string SelectedStandard {get; set;}

Capability Group

IviRFSigGenTDMABase

Also In This Interface

StandardName | StandardCount | SelectedStandard | FrameName | FrameCount | SelectedFrame | TriggerSource | ExternalTriggerSlope | ClockSource | ExternalClockType | ConfigureClockSource | IIviRFSigGenTDMA Overview


FrameName Property

IIviRFSigGenTDMA.FrameName Property

Returns the frame name for the given index.

[Visual Basic]
Property Get FrameName(Index As Long) As String
[C++]
HRESULT get_FrameName(long Index, BSTR* value);
[ANSI C]
HRESULT IIviRFSigGenTDMA_get_FrameName(IIviRFSigGenTDMA* This, long Index, BSTR* value);
[C#]HRESULT get_FrameName(long Index, string value);

Parameters

Index
A one-based index that defines which name to return.

Capability Group

IviRFSigGenTDMABase

Also In This Interface

StandardName | StandardCount | SelectedStandard | FrameName | FrameCount | SelectedFrame | TriggerSource | ExternalTriggerSlope | ClockSource | ExternalClockType | ConfigureClockSource | IIviRFSigGenTDMA Overview


FrameCount Property

IIviRFSigGenTDMA.FrameCount Property

Returns the count of available frame names.

[Visual Basic]
Property Get FrameCount() As Long
[C++]
HRESULT get_FrameCount(long* value);
[ANSI C]
HRESULT IIviRFSigGenTDMA_get_FrameCount(IIviRFSigGenTDMA* This, long* value);
[C#]
public long FrameCount {get;}

Capability Group

IviRFSigGenTDMABase

Also In This Interface

StandardName | StandardCount | SelectedStandard | FrameName | FrameCount | SelectedFrame | TriggerSource | ExternalTriggerSlope | ClockSource | ExternalClockType | ConfigureClockSource | IIviRFSigGenTDMA Overview


SelectedFrame Property

IIviRFSigGenTDMA.SelectedFrame Property

Specifies the actual frame/slot used by the instrument.

[Visual Basic]
Property Get SelectedFrame() As String
Property Let SelectedFrame(value As String)
[C++]
HRESULT get_SelectedFrame(BSTR* value);
HRESULT put_SelectedFrame(BSTR value);
[ANSI C]
HRESULT IIviRFSigGenTDMA_get_SelectedFrame(IIviRFSigGenTDMA* This, BSTR* value);
HRESULT IIviRFSigGenTDMA_put_SelectedFrame(IIviRFSigGenTDMA* This, BSTR value);
[C#]
public string SelectedFrame {get; set;}

Capability Group

IviRFSigGenTDMABase

Also In This Interface

StandardName | StandardCount | SelectedStandard | FrameName | FrameCount | SelectedFrame | TriggerSource | ExternalTriggerSlope | ClockSource | ExternalClockType | ConfigureClockSource | IIviRFSigGenTDMA Overview


TriggerSource Property

IIviRFSigGenTDMA.TriggerSource Property

Specifies the source of the trigger signal starting the generation of the frame/slot.

[Visual Basic]
Property Get TriggerSource() As IviRFSigGenTDMATriggerSourceEnum
Property Let TriggerSource(value As IviRFSigGenTDMATriggerSourceEnum)
[C++]
HRESULT get_TriggerSource(IviRFSigGenTDMATriggerSourceEnum* value);
HRESULT put_TriggerSource(IviRFSigGenTDMATriggerSourceEnum value);
[ANSI C]
HRESULT IIviRFSigGenTDMA_get_TriggerSource(IIviRFSigGenTDMA* This, IviRFSigGenTDMATriggerSourceEnum* value);
HRESULT IIviRFSigGenTDMA_put_TriggerSource(IIviRFSigGenTDMA* This, IviRFSigGenTDMATriggerSourceEnum value);
[C#]
public IviRFSigGenTDMATriggerSourceEnum TriggerSource {get; set;}

Capability Group

IviRFSigGenTDMABase

Also In This Interface

StandardName | StandardCount | SelectedStandard | FrameName | FrameCount | SelectedFrame | TriggerSource | ExternalTriggerSlope | ClockSource | ExternalClockType | ConfigureClockSource | IIviRFSigGenTDMA Overview


ExternalTriggerSlope Property

IIviRFSigGenTDMA.ExternalTriggerSlope Property

Specifies whether the trigger event occurs on the rising or falling edge of the input signal.

[Visual Basic]
Property Get ExternalTriggerSlope() As IviRFSigGenTDMAExternalTriggerSlopeEnum
Property Let ExternalTriggerSlope(value As IviRFSigGenTDMAExternalTriggerSlopeEnum)
[C++]
HRESULT get_ExternalTriggerSlope(IviRFSigGenTDMAExternalTriggerSlopeEnum* value);
HRESULT put_ExternalTriggerSlope(IviRFSigGenTDMAExternalTriggerSlopeEnum value);
[ANSI C]
HRESULT IIviRFSigGenTDMA_get_ExternalTriggerSlope(IIviRFSigGenTDMA* This, IviRFSigGenTDMAExternalTriggerSlopeEnum* value);
HRESULT IIviRFSigGenTDMA_put_ExternalTriggerSlope(IIviRFSigGenTDMA* This, IviRFSigGenTDMAExternalTriggerSlopeEnum value);
[C#]
public IviRFSigGenTDMAExternalTriggerSlopeEnum ExternalTriggerSlope {get; set;}

Capability Group

IviRFSigGenTDMABase

Also In This Interface

StandardName | StandardCount | SelectedStandard | FrameName | FrameCount | SelectedFrame | TriggerSource | ExternalTriggerSlope | ClockSource | ExternalClockType | ConfigureClockSource | IIviRFSigGenTDMA Overview


ClockSource Property

IIviRFSigGenTDMA.ClockSource Property

Specifies the source of the clock signal used to generate the digital modulation according to the selected standard.

[Visual Basic]
Property Get ClockSource() As IviRFSigGenTDMAClockSourceEnum
Property Let ClockSource(value As IviRFSigGenTDMAClockSourceEnum)
[C++]
HRESULT get_ClockSource(IviRFSigGenTDMAClockSourceEnum* value);
HRESULT put_ClockSource(IviRFSigGenTDMAClockSourceEnum value);
[ANSI C]
HRESULT IIviRFSigGenTDMA_get_ClockSource(IIviRFSigGenTDMA* This, IviRFSigGenTDMAClockSourceEnum* value);
HRESULT IIviRFSigGenTDMA_put_ClockSource(IIviRFSigGenTDMA* This, IviRFSigGenTDMAClockSourceEnum value);
[C#]
public IviRFSigGenTDMAClockSourceEnum ClockSource {get; set;}

Capability Group

IviRFSigGenTDMABase

Related Items

ConfigureClockSource

Also In This Interface

StandardName | StandardCount | SelectedStandard | FrameName | FrameCount | SelectedFrame | TriggerSource | ExternalTriggerSlope | ClockSource | ExternalClockType | ConfigureClockSource | IIviRFSigGenTDMA Overview


ExternalClockType Property

IIviRFSigGenTDMA.ExternalClockType Property

Specifies the type of the external clock signal used to generate the digital modulation.

[Visual Basic]
Property Get ExternalClockType() As IviRFSigGenTDMAExternalClockTypeEnum
Property Let ExternalClockType(value As IviRFSigGenTDMAExternalClockTypeEnum)
[C++]
HRESULT get_ExternalClockType(IviRFSigGenTDMAExternalClockTypeEnum* value);
HRESULT put_ExternalClockType(IviRFSigGenTDMAExternalClockTypeEnum value);
[ANSI C]
HRESULT IIviRFSigGenTDMA_get_ExternalClockType(IIviRFSigGenTDMA* This, IviRFSigGenTDMAExternalClockTypeEnum* value);
HRESULT IIviRFSigGenTDMA_put_ExternalClockType(IIviRFSigGenTDMA* This, IviRFSigGenTDMAExternalClockTypeEnum value);
[C#]
public IviRFSigGenTDMAExternalClockTypeEnum ExternalClockType {get; set;}

Capability Group

IviRFSigGenTDMABase

Related Items

ConfigureClockSource

Also In This Interface

StandardName | StandardCount | SelectedStandard | FrameName | FrameCount | SelectedFrame | TriggerSource | ExternalTriggerSlope | ClockSource | ExternalClockType | ConfigureClockSource | IIviRFSigGenTDMA Overview


ConfigureClockSource Method

IIviRFSigGenTDMA.ConfigureClockSource Method

This function configures the clock source.

[Visual Basic]
Sub ConfigureClockSource( _
   Source As IviRFSigGenTDMAClockSourceEnum, _
   Type As IviRFSigGenTDMAExternalClockTypeEnum _
)
[C++]
HRESULT ConfigureClockSource(
   IviRFSigGenTDMAClockSourceEnum Source,
   IviRFSigGenTDMAExternalClockTypeEnum Type
);
[ANSI C]
HRESULT IIviRFSigGenTDMA_ConfigureClockSource(
   IIviRFSigGenTDMA* This
   IviRFSigGenTDMAClockSourceEnum Source,
   IviRFSigGenTDMAExternalClockTypeEnum Type
);
[C#]
public void ConfigureClockSource(
   IviRFSigGenTDMAClockSourceEnum Source,
   IviRFSigGenTDMAExternalClockTypeEnum Type
);

Parameters

Source
The driver uses this value to set the TDMA Clock Source attribute.
Type
Type is ignored if Source is set to Internal.The driver uses this value to set the TDMA External Clock Type attribute.

Capability Group

IviRFSigGenTDMABase

Related Items

ClockSource | ExternalClockType

Also In This Interface

StandardName | StandardCount | SelectedStandard | FrameName | FrameCount | SelectedFrame | TriggerSource | ExternalTriggerSlope | ClockSource | ExternalClockType | ConfigureClockSource | IIviRFSigGenTDMA Overview


IviRFSigGenALCSourceEnum Enumeration

Values for the ALC source.

Members

Member Name | Description
IviRFSigGenALCSourceInternal | The ALC is controlled by an internal measurement source.
IviRFSigGenALCSourceExternal | The ALC is controlled by an external voltage.


IviRFSigGenAMExternalCouplingEnum Enumeration

Values for the AM external coupling.

Members

Member Name | Description
IviRFSigGenAMExternalCouplingAC | The external source is coupled for AC only.
IviRFSigGenAMExternalCouplingDC | The external source is coupled for both DC and AC.


IviRFSigGenAMScalingEnum Enumeration

Values for the AM scaling mode.

Members

Member Name | Description
IviRFSigGenAMScalingLinear | Enables linear attenuation for amplitude modulation.
IviRFSigGenAMScalingLogarithmic | Enables logarithmic attenuation for amplitude modulation.


IviRFSigGenArbExternalTriggerSlopeEnum Enumeration

Values for the Arb generator external trigger slope.

Members

Member Name | Description
IviRFSigGenArbExternalTriggerSlopePositive | Enables rising edge triggering.
IviRFSigGenArbExternalTriggerSlopeNegative | Enables falling edge triggering.


IviRFSigGenArbTriggerSourceEnum Enumeration

Values for the Arb generator trigger source.

Members

Member Name | Description
IviRFSigGenArbTriggerSourceImmediate | The Arb generator system does not wait for a trigger of any kind, so it is running continuously.
IviRFSigGenArbTriggerSourceExternal | The sweep is started with an external signal.
IviRFSigGenArbTriggerSourceSoftware | The sweep is started with a software programmable trigger.


IviRFSigGenCDMAClockSourceEnum Enumeration

Values for the CDMA clock source.

Members

Member Name | Description
IviRFSigGenCDMAClockSourceInternal | The internal clock generator is used.
IviRFSigGenCDMAClockSourceExternal | A connected external clock generator (bit or symbol clock frequency) is used.


IviRFSigGenCDMAExternalTriggerSlopeEnum Enumeration

Values for the CDMA external trigger slope.

Members

Member Name | Description
IviRFSigGenCDMAExternalTriggerSlopePositive | Enables rising edge triggering.
IviRFSigGenCDMAExternalTriggerSlopeNegative | Enables falling edge triggering.


IviRFSigGenCDMATriggerSourceEnum Enumeration

Values for the CDMA trigger source.

Members

Member Name | Description
IviRFSigGenCDMATriggerSourceImmediate | The CDMA generator system does not wait for a trigger of any kind, so it is running the channel codings continuously.
IviRFSigGenCDMATriggerSourceExternal | Each channel coding is started with an external signal.
IviRFSigGenCDMATriggerSourceSoftware | Each channel coding is started with a software programmable trigger.


IviRFSigGenDigitalModulationBaseClockSourceEnum Enumeration

Values for the digital modulation base clock source.

Members

Member Name | Description
IviRFSigGenDigitalModulationBaseClockSourceInternal | The internal clock generator is used.
IviRFSigGenDigitalModulationBaseClockSourceExternal | An connected external clock generator (bit or symbol clock frequency) is used.


IviRFSigGenDigitalModulationBaseDataSourceEnum Enumeration

Values for digital modulation base data source.

Members

Member Name | Description
IviRFSigGenDigitalModulationBaseDataSourceExternal | The data from an external device connected to the instrument is used.
IviRFSigGenDigitalModulationBaseDataSourcePRBS | The internal PRBS (Pseudo Random Binary Sequence) generator is used as data source.
IviRFSigGenDigitalModulationBaseDataSourceBitSequence | A constant bit sequence is used as data source and repeated continuously.


IviRFSigGenDigitalModulationBaseExternalClockTypeEnum Enumeration

Values for digital base modulation clock type.

Members

Member Name | Description
IviRFSigGenDigitalModulationBaseExternalClockTypeBit | The external clock frequency is equal to the bit clock frequency of the digital modulation.
IviRFSigGenDigitalModulationBaseExternalClockTypeSymbol | The external clock frequency is equal to the symbol clock frequency of the digital modulation.


IviRFSigGenDigitalModulationBasePRBSTypeEnum Enumeration

Values for digital base modulation PRBS type.

Members

Member Name | Description
IviRFSigGenDigitalModulationBasePRBSTypePRBS9 | Length of PRBS sequence is 2exp9-1.
IviRFSigGenDigitalModulationBasePRBSTypePRBS11 | Length of PRBS sequence is 2exp11-1.
IviRFSigGenDigitalModulationBasePRBSTypePRBS15 | Length of PRBS sequence is 2exp15-1.
IviRFSigGenDigitalModulationBasePRBSTypePRBS16 | Length of PRBS sequence is 2exp16-1.
IviRFSigGenDigitalModulationBasePRBSTypePRBS20 | Length of PRBS sequence is 2exp20-1.
IviRFSigGenDigitalModulationBasePRBSTypePRBS21 | Length of PRBS sequence is 2exp21-1.
IviRFSigGenDigitalModulationBasePRBSTypePRBS23 | Length of PRBS sequence is 2exp23-1.


IviRFSigGenErrorCodesEnum Enumeration

IVI RFSigGen class defined HRESULTS

Members

Member Name | Description
E_IVIRFSIGGEN_TRIGGER_NOT_SOFTWARE | The trigger source is not set to software trigger.
E_IVIRFSIGGEN_MAX_TIME_EXCEEDED | Maximum time exceeded before the operation completed.
E_IVIRFSIGGEN_LIST_UNKNOWN | The selected list is not defined.


IviRFSigGenFMExternalCouplingEnum Enumeration

Values for the FM external coupling.

Members

Member Name | Description
IviRFSigGenFMExternalCouplingAC | The external source is coupled for AC only.
IviRFSigGenFMExternalCouplingDC | The external source is coupled for both DC and AC.


IviRFSigGenFrequencyStepScalingEnum Enumeration

Values for the frequency step scaling mode.

Members

Member Name | Description
IviRFSigGenFrequencyStepScalingLinear | Enables linear scaling.
IviRFSigGenFrequencyStepScalingLogarithmic | Enables logarithmic scaling.


IviRFSigGenIQSourceEnum Enumeration

Values for the IQ modulation source.

Members

Member Name | Description
IviRFSigGenIQSourceDigitalModulationBase | The signal generator uses the internally generated digital modulation signal to apply IQ modulation to the output RF signal.
IviRFSigGenIQSourceCDMABase | The signal generator uses the internally generated CDMA signal to apply IQ modulation to the output RF signal.
IviRFSigGenIQSourceTDMABase | The signal generator uses the internally generated TDMA signal to apply IQ modulation to the output RF signal.
IviRFSigGenIQSourceArbGenerator | The signal generator uses the internally generated Arb signal to apply IQ modulation to the output RF signal.
IviRFSigGenIQSourceExternal | The signal generator uses data from an external source for IQ modulation.


IviRFSigGenLFGeneratorWaveformEnum Enumeration

Values for the LFGenerator waveform.

Members

Member Name | Description
IviRFSigGenLFGeneratorWaveformSine | Configures the LF generator to produce a sinusoidal waveform.
IviRFSigGenLFGeneratorWaveformSquare | Configures the LF generator to produce a square waveform.
IviRFSigGenLFGeneratorWaveformTriangle | Configures the LF generator to produce a triangle waveform.
IviRFSigGenLFGeneratorWaveformRampUp | Configures the LF generator to produce a rising ramp waveform.
IviRFSigGenLFGeneratorWaveformRampDown | Configures the LF generator to produce a falling ramp waveform.


IviRFSigGenMaxTimeMillisecondsEnum Enumeration

IVI RFSigGen class defined values for MaxTimeMilliseconds.

Members

Member Name | Description
IviRFSigGenMaxTimeMillisecondsInfinite | Sets timeout to infinite. The function waits indefinitely for the measurement to complete.
IviRFSigGenMaxTimeMillisecondsImmediate | Sets timeout to immediate. The function returns immediately. If no valid measurement value exists, the function returns the Max Time Exceeded error.


IviRFSigGenPMExternalCouplingEnum Enumeration

Values for the PM external coupling.

Members

Member Name | Description
IviRFSigGenPMExternalCouplingAC | The external source is coupled for AC only.
IviRFSigGenPMExternalCouplingDC | The external source is coupled for both DC and AC.


IviRFSigGenPulseExternalTriggerSlopeEnum Enumeration

Values for the pulse generator external trigger slope.

Members

Member Name | Description
IviRFSigGenPulseExternalTriggerSlopePositive | Enables rising edge triggering.
IviRFSigGenPulseExternalTriggerSlopeNegative | Enables falling edge triggering.


IviRFSigGenPulseModulationExternalPolarityEnum Enumeration

Values for the pulse modulation external polarity.

Members

Member Name | Description
IviRFSigGenPulseModulationExternalPolarityNormal | The signal generator modulates the carrier signal with normal pulse polarity. Increasing the positive pulse voltage level results in higher RF level.
IviRFSigGenPulseModulationExternalPolarityInverse | The signal generator modulates the carrier signal with inverted pulse polarity.


IviRFSigGenPulseModulationSourceEnum Enumeration

Values for the pulse modulation source.

Members

Member Name | Description
IviRFSigGenPulseModulationSourceInternal | The internal pulse generator (IviRFSigGenPulseGenerator Extension Group) is used for modulation.
IviRFSigGenPulseModulationSourceExternal | An external generator is used for modulation.


IviRFSigGenPulseOutputPolarityEnum Enumeration

Values for the pulse output polarity.

Members

Member Name | Description
IviRFSigGenPulseOutputPolarityNormal | Specifies normal polarity.
IviRFSigGenPulseOutputPolarityInverse | Specifies inverted polarity.


IviRFSigGenPulseTriggerSourceEnum Enumeration

Values for the pulse generator trigger source.

Members

Member Name | Description
IviRFSigGenPulseTriggerSourceInternal | No external trigger is used. The pulse period is specified with Pulse Internal Trigger Period.
IviRFSigGenPulseTriggerSourceExternal | The pulse is started with a trigger after the delay time specified with Pulse External Trigger Delay.


IviRFSigGenReferenceOscillatorSourceEnum Enumeration

Values for the reference oscillator source.

Members

Member Name | Description
IviRFSigGenReferenceOscillatorSourceInternal | The internal reference oscillator is used.
IviRFSigGenReferenceOscillatorSourceExternal | An external reference oscillator is used.


IviRFSigGenSweepModeEnum Enumeration

Values for the sweep mode.

Members

Member Name | Description
IviRFSigGenSweepModeNone | The RF output of the signal generator is a non-swept signal (Continuous Wave). Frequency and power level settings from the base capability group are used.
IviRFSigGenSweepModeFrequencySweep | The signal generator sweeps the RF output signal's frequency in an analog form (non-stepped). Refer to IviRFSigGenFrequencySweep extension group.
IviRFSigGenSweepModePowerSweep | The signal generator sweeps the RF output signal's power in an analog form (non-stepped). Refer to IviRFSigGenPowerSweep extension group.
IviRFSigGenSweepModeFrequencyStep | The signal generator sweeps the RF output signal's frequency in steps. Refer to IviRFSigGenFrequencyStep extension group.
IviRFSigGenSweepModePowerStep | The signal generator sweeps the RF output signal's power level in steps. Refer to IviRFSigGenPowerStep extension group.
IviRFSigGenSweepModeList | The signal generator uses two lists with frequency and power level values to sweep the RF output signal. Refer to IviRFSigGenList extension group.


IviRFSigGenSweepTriggerSourceEnum Enumeration

Values for the sweep trigger source.

Members

Member Name | Description
IviRFSigGenSweepTriggerSourceImmediate | The sweep system does not wait for a trigger of any kind, so it is running continuously.
IviRFSigGenSweepTriggerSourceExternal | The sweep is started with an external signal.
IviRFSigGenSweepTriggerSourceSoftware | The sweep is started with a software programmable trigger.


IviRFSigGenTDMAClockSourceEnum Enumeration

Values for the TDMA clock source.

Members

Member Name | Description
IviRFSigGenTDMAClockSourceInternal | The internal clock generator is used.
IviRFSigGenTDMAClockSourceExternal | A connected external clock generator (bit or symbol clock frequency) is used.


IviRFSigGenTDMAExternalClockTypeEnum Enumeration

Values for TDMA clock type.

Members

Member Name | Description
IviRFSigGenTDMAExternalClockTypeBit | The external clock frequency is equal to the bit clock frequency of the digital modulation.
IviRFSigGenTDMAExternalClockTypeSymbol | The external clock frequency is equal to the symbol clock frequency of the digital modulation.


IviRFSigGenTDMAExternalTriggerSlopeEnum Enumeration

Values for the TDMA external trigger slope.

Members

Member Name | Description
IviRFSigGenTDMAExternalTriggerSlopePositive | Enables rising edge triggering.
IviRFSigGenTDMAExternalTriggerSlopeNegative | Enables falling edge triggering.


IviRFSigGenTDMATriggerSourceEnum Enumeration

Values for the TDMA trigger source.

Members

Member Name | Description
IviRFSigGenTDMATriggerSourceImmediate | The TDMA generator system does not wait for a trigger of any kind, so it is running the frames continuously.
IviRFSigGenTDMATriggerSourceExternal | Each frame is started with an external signal.
IviRFSigGenTDMATriggerSourceSoftware | Each frame is started with a software programmable trigger.


Topic Not Found

No matching topic was found. The link may be out of date, incorrectly authored, or the topic may not be available in this release.

You may be able to find the topic by using the index or search tab instead.


Inherent Interface

IVI Inherent Interfaces

IIviDriver | IVI Driver root interface
IIviDriverIdentity | IVI Driver identity interface
IIviDriverOperation | IVI Driver operation interface
IIviDriverUtility | IVI Driver utility interface


IviDriver_ErrorCodes Enumeration

IVI Driver (inherent features) defined HRESULTS

Members

Member Name | Description
S_IVI_SUCCESS | Success
E_IVI_CANNOT_RECOVER | Unrecoverable failure
E_IVI_INSTRUMENT_STATUS | Instrument error detected
E_IVI_CANNOT_OPEN_FILE | File could not be opened
E_IVI_READING_FILE | File could not be read
E_IVI_WRITING_FILE | File could not be written
E_IVI_INVALID_PATHNAME | The path name is invalid
E_IVI_INVALID_VALUE | Invalid value for parameter or property
E_IVI_METHOD_NOT_SUPPORTED | Method not supported
E_IVI_PROPERTY_NOT_SUPPORTED | Property not supported
E_IVI_VALUE_NOT_SUPPORTED | The enumeration value for the parameter is not supported
E_IVI_NOT_INITIALIZED | A connection to the instrument has not been initialized
E_IVI_UNKNOWN_CHANNEL_NAME | Channel or repeated capability name specified is not valid for the instrument.
E_IVI_TOO_MANY_OPEN_FILES | Too many files opened
E_IVI_CHANNEL_NAME_REQUIRED | Channel or repeated capability name required
E_IVI_MISSING_OPTION_NAME | The option string contains an entry without a name.
E_IVI_MISSING_OPTION_VALUE | The option string contains an entry without a value.
E_IVI_BAD_OPTION_NAME | The option string contains an entry with an unknown option name.
E_IVI_BAD_OPTION_VALUE | The option string contains an entry with an unknown option value.
E_IVI_OUT_OF_MEMORY | The necessary memory could not be allocated
E_IVI_OPERATION_PENDING | Operation in progress
E_IVI_NULL_POINTER | Null pointer passed for parameter or property
E_IVI_UNEXPECTED_RESPONSE | Unexpected response from the instrument
E_IVI_FILE_NOT_FOUND | File not found
E_IVI_INVALID_FILE_FORMAT | The file format is invalid
E_IVI_STATUS_NOT_AVAILABLE | The instrument status is not available
E_IVI_ID_QUERY_FAILED | Instrument ID query failed
E_IVI_RESET_FAILED | Instrument reset failed
E_IVI_RESOURCE_UNKNOWN | Insufficient location information or resource not present in the system.
E_IVI_ALREADY_INITIALIZED | The driver is already initialized
E_IVI_CANNOT_CHANGE_SIMULATION_STATE | The simulation state cannot be changed.
S_IVI_NSUP_ID_QUERY | Identification query not supported
S_IVI_NSUP_RESET | Reset operation not supported
S_IVI_NSUP_SELF_TEST | Self test operation not supported
S_IVI_NSUP_ERROR_QUERY | Error query operation not supported
S_IVI_NSUP_REV_QUERY | Revision query not supported


IIviDriver Interface

IVI Driver root interface

Properties

DriverOperation | Pointer to the IIviDriverOperation interface
Identity | Pointer to the IIviDriverIdentity interface
Utility | Pointer to the IIviDriverUtility interface
Initialized | Initialized is True between a successful call to the Initialize method and a successful call to the Close method, and False at all other times.

Methods

Initialize | Opens the I/O session to the instrument. Driver methods and properties that access the instrument are only accessible after Initialize is called. Initialize optionally performs a Reset and queries the instrument to validate the instrument model.
Close | Closes the I/O session to the instrument. Driver methods and properties that access the instrument are not accessible after Close is called.


IIviDriverIdentity Interface

IVI Driver identity interface

Properties

Description | A brief description of the implementing component. Description is limted to 256 bytes.
Revision | The revision of the implementing component. Refer to IVI-3.2, Section 3.1.2.2, Additional Compliance Rules for Revision String Attributes, for a description of revision syntax and semantics. Revision is limited to 256 bytes.
Vendor | The name of the vendor that supplies the implementing component. Vendor is limited to 256 bytes.
InstrumentManufacturer | The name of the manufacturer reported by the physical instrument. If Simulation is enabled or the instrument is not capable of reporting the name of the manufacturer, a string is returned that explains the condition. Manufacturer is limited to 256 bytes
InstrumentModel | The model number or name reported by the physical instrument. If Simulation is enabled or the instrument is not capable of reporting the model number or name, a string is returned that explains the condition. Model is limited to 256 bytes
InstrumentFirmwareRevision | The firmware revision reported by the physical instrument. If Simulation is enabled or the instrument is not capable of reporting the firmware revision, a string is returned that explains the condition.
Identifier | The case-sensitive unique identifier of the implementing IVI-COM instrument driver.
SupportedInstrumentModels | A comma-separated list of instrument models that the IVI specific driver can control. The string does not include an abbreviation for the manufacturer if it is the same for all models.
SpecificationMajorVersion | For IVI class-compliant drivers, the major version number of the instrument class specification. If the driver is not class compliant, the value of this property is zero.
SpecificationMinorVersion | For IVI class-compliant drivers, the minor version number of the instrument class specification. If the driver is not class compliant, the value of this property is zero.
GroupCapabilities | A comma-separated list of the class capability groups implemented by the driver. Capability group names are documented in the IVI class specifications. If the driver is not class compliant, the driver returns an empty string.


IIviDriverOperation Interface

IVI Driver operation interface

Properties

LogicalName | Logical Name identifies a driver session in the Configuration Store. If Logical Name is not empty, the driver was initialized from information in the driver session. If it is empty, the driver was initialized without using the Configuration Store.
IoResourceDescriptor | The resource descriptor specifies the connection to a physical device. It is either specified in the Configuration Store or passed in the ResourceName parameter of the Initialize function. It is empty if the driver is not initialized.
Cache | Drivers may choose to always cache some instrument settings, never cache others, and optionally cache others, to avoid unecessary I/O to the instrument. If True, the driver caches optionally cached instrument settings.
InterchangeCheck | If True, the driver maintains a record of interchangeability warnings. If the driver does not support interchangeability checking, attempts to set InterchangeCheck to True return an error.
QueryInstrumentStatus | If True, the driver queries the instrument status at the end of each method or property that performs I/O to the instrument. If an error is reported, use ErrorQuery to retrieve error messages one at a time from the instrument.
RangeCheck | Drivers may choose to always validate some property/parameter values, never validate others, and optionally validate others, to avoid sending invalid commands to the instrument. If True, the driver performs optional validations.
RecordCoercions | If True, the driver keeps a list of the value coercions it makes for ViInt32 and ViReal64 attributes. If the driver does not support coercion recording, attempts to set RecordCoercions to True will return an error.
Simulate | If True, the driver does not perform I/O to the instrument, and returns simulated values for output parameters.
DriverSetup | The driver setup string. It is either specified in the Configuration Store or passed in the OptionString parameter of the Initialize function. Driver setup is empty if the driver is not initialized.

Methods

InvalidateAllAttributes | Invalidates all of the driver's cached values.
ClearInterchangeWarnings | Clears the list of interchangeability warnings that the IVI specific driver maintains.
GetNextInterchangeWarning | Returns the oldest warning from the interchange warning list. Records are only added to the list if InterchangeCheck is True.
ResetInterchangeCheck | Resets the interchangeability checking algorithms of the driver so that methods and properties that executed prior to calling this function have no affect on whether future calls to the driver generate interchangeability warnings.
GetNextCoercionRecord | Returns the oldest record from the coercion record list. Records are only added to the list if RecordCoercions is True.


IIviDriverUtility Interface

IVI Driver utility interface

Methods

Reset | Places the instrument in a known state and configures instrument options on which the IVI specific driver depends (for example, enabling/disabling headers). For an IEEE 488.2 instrument, Reset sends the command string *RST to the instrument.
ResetWithDefaults | Does the equivalent of Reset and then, (1) disables class extension capability groups, (2) sets attributes to initial values defined by class specs, and (3) configures the driver to option string settings used when Initialize was last executed.
Disable | Quickly places the instrument in a state where it has no, or minimal, effect on the external system to which it is connected. This state is not necessarily a known state.
SelfTest | Performs an instrument self test, waits for the instrument to complete the test, and queries the instrument for the results. If the instrument passes the test, TestResult is zero and TestMessage is 'Self test passed'.
ErrorQuery | Queries the instrument and returns instrument specific error information. This function can be used when QueryInstrumentStatus is True to retrieve error details when the driver detects an instrument error.
LockObject | Obtains a multithread lock on the driver after waiting until all other execution threads have released their locks on the instrument session.
UnlockObject | Releases a previously obtained mutlithread lock.


Close Method

IIviDriver.Close Method

Closes the I/O session to the instrument. Driver methods and properties that access the instrument are not accessible after Close is called.

[Visual Basic]
Sub Close()
[C++]
HRESULT Close();
[ANSI C]
HRESULT IIviDriver_Close(
   IIviDriver* This);
[C#]
public void Close();

Capability Group

IviRFSigGenBase

Related Items

Initialize

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Initialize | Close | IIviDriver Overview


DriverOperation Property

IIviDriver.DriverOperation Property

Pointer to the IIviDriverOperation interface

[Visual Basic]
Property Get DriverOperation() As IIviDriverOperation
[C++]
HRESULT get_DriverOperation(IIviDriverOperation** value);
[ANSI C]
HRESULT IIviDriver_get_DriverOperation(IIviDriver* This, IIviDriverOperation** value);
[C#]
public IIviDriverOperation DriverOperation {get;}

Capability Group

IviRFSigGenBase

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Initialize | Close | IIviDriver Overview


Identity Property

IIviDriver.Identity Property

Pointer to the IIviDriverIdentity interface

[Visual Basic]
Property Get Identity() As IIviDriverIdentity
[C++]
HRESULT get_Identity(IIviDriverIdentity** value);
[ANSI C]
HRESULT IIviDriver_get_Identity(IIviDriver* This, IIviDriverIdentity** value);
[C#]
public IIviDriverIdentity Identity {get;}

Capability Group

IviRFSigGenBase

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Initialize | Close | IIviDriver Overview


Initialize Method

IIviDriver.Initialize Method

Opens the I/O session to the instrument. Driver methods and properties that access the instrument are only accessible after Initialize is called. Initialize optionally performs a Reset and queries the instrument to validate the instrument model.

[Visual Basic]
Sub Initialize( _
   ResourceName As String, _
   IdQuery As Boolean, _
   Reset As Boolean, _
   OptionString As String _
)
[C++]
HRESULT Initialize(
   BSTR ResourceName,
   VARIANT_BOOL IdQuery,
   VARIANT_BOOL Reset,
   BSTR OptionString
);
[ANSI C]
HRESULT IIviDriver_Initialize(
   IIviDriver* This
   BSTR ResourceName,
   VARIANT_BOOL IdQuery,
   VARIANT_BOOL Reset,
   BSTR OptionString
);
[C#]
public void Initialize(
   string ResourceName,
   bool IdQuery,
   bool Reset,
   string OptionString
);

Parameters

ResourceName
An IVI logical name or an instrument specific string that identifies the address of the instrument, such as a VISA resource descriptor string.
IdQuery
Specifies whether to verify the ID of the instrument.
Reset
Specifies whether to reset the instrument.
OptionString
The user can use the OptionsString parameter to specify the initial values of certain IVI inherent attributes for the session.

Capability Group

IviRFSigGenBase

Related Items

Close

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Initialize | Close | IIviDriver Overview


Initialized Property

IIviDriver.Initialized Property

Initialized is True between a successful call to the Initialize method and a successful call to the Close method, and False at all other times.

[Visual Basic]
Property Get Initialized() As Boolean
[C++]
HRESULT get_Initialized(VARIANT_BOOL* value);
[ANSI C]
HRESULT IIviDriver_get_Initialized(IIviDriver* This, VARIANT_BOOL* value);
[C#]
public bool Initialized {get;}

Capability Group

IviRFSigGenBase

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Initialize | Close | IIviDriver Overview


Utility Property

IIviDriver.Utility Property

Pointer to the IIviDriverUtility interface

[Visual Basic]
Property Get Utility() As IIviDriverUtility
[C++]
HRESULT get_Utility(IIviDriverUtility** value);
[ANSI C]
HRESULT IIviDriver_get_Utility(IIviDriver* This, IIviDriverUtility** value);
[C#]
public IIviDriverUtility Utility {get;}

Capability Group

IviRFSigGenBase

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Initialize | Close | IIviDriver Overview


Description Property

IIviDriverIdentity.Description Property

A brief description of the implementing component. Description is limted to 256 bytes.

[Visual Basic]
Property Get Description() As String
[C++]
HRESULT get_Description(BSTR* value);
[ANSI C]
HRESULT IIviDriverIdentity_get_Description(IIviDriverIdentity* This, BSTR* value);
[C#]
public string Description {get;}

Capability Group

IviRFSigGenBase

Also In This Interface

Description | Revision | Vendor | InstrumentManufacturer | InstrumentModel | InstrumentFirmwareRevision | Identifier | SupportedInstrumentModels | SpecificationMajorVersion | SpecificationMinorVersion | GroupCapabilities | IIviDriverIdentity Overview


GroupCapabilities Property

IIviDriverIdentity.GroupCapabilities Property

A comma-separated list of the class capability groups implemented by the driver. Capability group names are documented in the IVI class specifications. If the driver is not class compliant, the driver returns an empty string.

[Visual Basic]
Property Get GroupCapabilities() As String
[C++]
HRESULT get_GroupCapabilities(BSTR* value);
[ANSI C]
HRESULT IIviDriverIdentity_get_GroupCapabilities(IIviDriverIdentity* This, BSTR* value);
[C#]
public string GroupCapabilities {get;}

Capability Group

IviRFSigGenBase

Also In This Interface

Description | Revision | Vendor | InstrumentManufacturer | InstrumentModel | InstrumentFirmwareRevision | Identifier | SupportedInstrumentModels | SpecificationMajorVersion | SpecificationMinorVersion | GroupCapabilities | IIviDriverIdentity Overview


Identifier Property

IIviDriverIdentity.Identifier Property

The case-sensitive unique identifier of the implementing IVI-COM instrument driver.

[Visual Basic]
Property Get Identifier() As String
[C++]
HRESULT get_Identifier(BSTR* value);
[ANSI C]
HRESULT IIviDriverIdentity_get_Identifier(IIviDriverIdentity* This, BSTR* value);
[C#]
public string Identifier {get;}

Capability Group

IviRFSigGenBase

Also In This Interface

Description | Revision | Vendor | InstrumentManufacturer | InstrumentModel | InstrumentFirmwareRevision | Identifier | SupportedInstrumentModels | SpecificationMajorVersion | SpecificationMinorVersion | GroupCapabilities | IIviDriverIdentity Overview


InstrumentFirmwareRevision Property

IIviDriverIdentity.InstrumentFirmwareRevision Property

The firmware revision reported by the physical instrument. If Simulation is enabled or the instrument is not capable of reporting the firmware revision, a string is returned that explains the condition.

[Visual Basic]
Property Get InstrumentFirmwareRevision() As String
[C++]
HRESULT get_InstrumentFirmwareRevision(BSTR* value);
[ANSI C]
HRESULT IIviDriverIdentity_get_InstrumentFirmwareRevision(IIviDriverIdentity* This, BSTR* value);
[C#]
public string InstrumentFirmwareRevision {get;}

Capability Group

IviRFSigGenBase

Also In This Interface

Description | Revision | Vendor | InstrumentManufacturer | InstrumentModel | InstrumentFirmwareRevision | Identifier | SupportedInstrumentModels | SpecificationMajorVersion | SpecificationMinorVersion | GroupCapabilities | IIviDriverIdentity Overview


InstrumentManufacturer Property

IIviDriverIdentity.InstrumentManufacturer Property

The name of the manufacturer reported by the physical instrument. If Simulation is enabled or the instrument is not capable of reporting the name of the manufacturer, a string is returned that explains the condition. Manufacturer is limited to 256 bytes

[Visual Basic]
Property Get InstrumentManufacturer() As String
[C++]
HRESULT get_InstrumentManufacturer(BSTR* value);
[ANSI C]
HRESULT IIviDriverIdentity_get_InstrumentManufacturer(IIviDriverIdentity* This, BSTR* value);
[C#]
public string InstrumentManufacturer {get;}

Capability Group

IviRFSigGenBase

Also In This Interface

Description | Revision | Vendor | InstrumentManufacturer | InstrumentModel | InstrumentFirmwareRevision | Identifier | SupportedInstrumentModels | SpecificationMajorVersion | SpecificationMinorVersion | GroupCapabilities | IIviDriverIdentity Overview


InstrumentModel Property

IIviDriverIdentity.InstrumentModel Property

The model number or name reported by the physical instrument. If Simulation is enabled or the instrument is not capable of reporting the model number or name, a string is returned that explains the condition. Model is limited to 256 bytes

[Visual Basic]
Property Get InstrumentModel() As String
[C++]
HRESULT get_InstrumentModel(BSTR* value);
[ANSI C]
HRESULT IIviDriverIdentity_get_InstrumentModel(IIviDriverIdentity* This, BSTR* value);
[C#]
public string InstrumentModel {get;}

Capability Group

IviRFSigGenBase

Also In This Interface

Description | Revision | Vendor | InstrumentManufacturer | InstrumentModel | InstrumentFirmwareRevision | Identifier | SupportedInstrumentModels | SpecificationMajorVersion | SpecificationMinorVersion | GroupCapabilities | IIviDriverIdentity Overview


Revision Property

IIviDriverIdentity.Revision Property

The revision of the implementing component. Refer to IVI-3.2, Section 3.1.2.2, Additional Compliance Rules for Revision String Attributes, for a description of revision syntax and semantics. Revision is limited to 256 bytes.

[Visual Basic]
Property Get Revision() As String
[C++]
HRESULT get_Revision(BSTR* value);
[ANSI C]
HRESULT IIviDriverIdentity_get_Revision(IIviDriverIdentity* This, BSTR* value);
[C#]
public string Revision {get;}

Capability Group

IviRFSigGenBase

Also In This Interface

Description | Revision | Vendor | InstrumentManufacturer | InstrumentModel | InstrumentFirmwareRevision | Identifier | SupportedInstrumentModels | SpecificationMajorVersion | SpecificationMinorVersion | GroupCapabilities | IIviDriverIdentity Overview


SpecificationMajorVersion Property

IIviDriverIdentity.SpecificationMajorVersion Property

For IVI class-compliant drivers, the major version number of the instrument class specification. If the driver is not class compliant, the value of this property is zero.

[Visual Basic]
Property Get SpecificationMajorVersion() As Long
[C++]
HRESULT get_SpecificationMajorVersion(long* value);
[ANSI C]
HRESULT IIviDriverIdentity_get_SpecificationMajorVersion(IIviDriverIdentity* This, long* value);
[C#]
public long SpecificationMajorVersion {get;}

Capability Group

IviRFSigGenBase

Also In This Interface

Description | Revision | Vendor | InstrumentManufacturer | InstrumentModel | InstrumentFirmwareRevision | Identifier | SupportedInstrumentModels | SpecificationMajorVersion | SpecificationMinorVersion | GroupCapabilities | IIviDriverIdentity Overview


SpecificationMinorVersion Property

IIviDriverIdentity.SpecificationMinorVersion Property

For IVI class-compliant drivers, the minor version number of the instrument class specification. If the driver is not class compliant, the value of this property is zero.

[Visual Basic]
Property Get SpecificationMinorVersion() As Long
[C++]
HRESULT get_SpecificationMinorVersion(long* value);
[ANSI C]
HRESULT IIviDriverIdentity_get_SpecificationMinorVersion(IIviDriverIdentity* This, long* value);
[C#]
public long SpecificationMinorVersion {get;}

Capability Group

IviRFSigGenBase

Also In This Interface

Description | Revision | Vendor | InstrumentManufacturer | InstrumentModel | InstrumentFirmwareRevision | Identifier | SupportedInstrumentModels | SpecificationMajorVersion | SpecificationMinorVersion | GroupCapabilities | IIviDriverIdentity Overview


SupportedInstrumentModels Property

IIviDriverIdentity.SupportedInstrumentModels Property

A comma-separated list of instrument models that the IVI specific driver can control. The string does not include an abbreviation for the manufacturer if it is the same for all models.

[Visual Basic]
Property Get SupportedInstrumentModels() As String
[C++]
HRESULT get_SupportedInstrumentModels(BSTR* value);
[ANSI C]
HRESULT IIviDriverIdentity_get_SupportedInstrumentModels(IIviDriverIdentity* This, BSTR* value);
[C#]
public string SupportedInstrumentModels {get;}

Capability Group

IviRFSigGenBase

Also In This Interface

Description | Revision | Vendor | InstrumentManufacturer | InstrumentModel | InstrumentFirmwareRevision | Identifier | SupportedInstrumentModels | SpecificationMajorVersion | SpecificationMinorVersion | GroupCapabilities | IIviDriverIdentity Overview


Vendor Property

IIviDriverIdentity.Vendor Property

The name of the vendor that supplies the implementing component. Vendor is limited to 256 bytes.

[Visual Basic]
Property Get Vendor() As String
[C++]
HRESULT get_Vendor(BSTR* value);
[ANSI C]
HRESULT IIviDriverIdentity_get_Vendor(IIviDriverIdentity* This, BSTR* value);
[C#]
public string Vendor {get;}

Capability Group

IviRFSigGenBase

Also In This Interface

Description | Revision | Vendor | InstrumentManufacturer | InstrumentModel | InstrumentFirmwareRevision | Identifier | SupportedInstrumentModels | SpecificationMajorVersion | SpecificationMinorVersion | GroupCapabilities | IIviDriverIdentity Overview


Cache Property

IIviDriverOperation.Cache Property

Drivers may choose to always cache some instrument settings, never cache others, and optionally cache others, to avoid unecessary I/O to the instrument. If True, the driver caches optionally cached instrument settings.

[Visual Basic]
Property Get Cache() As Boolean
Property Let Cache(value As Boolean)
[C++]
HRESULT get_Cache(VARIANT_BOOL* value);
HRESULT put_Cache(VARIANT_BOOL value);
[ANSI C]
HRESULT IIviDriverOperation_get_Cache(IIviDriverOperation* This, VARIANT_BOOL* value);
HRESULT IIviDriverOperation_put_Cache(IIviDriverOperation* This, VARIANT_BOOL value);
[C#]
public bool Cache {get; set;}

Capability Group

IviRFSigGenBase

Related Items

InvalidateAllAttributes

Also In This Interface

LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


ClearInterchangeWarnings Method

IIviDriverOperation.ClearInterchangeWarnings Method

Clears the list of interchangeability warnings that the IVI specific driver maintains.

[Visual Basic]
Sub ClearInterchangeWarnings()
[C++]
HRESULT ClearInterchangeWarnings();
[ANSI C]
HRESULT IIviDriverOperation_ClearInterchangeWarnings(
   IIviDriverOperation* This);
[C#]
public void ClearInterchangeWarnings();

Capability Group

IviRFSigGenBase

Related Items

GetNextInterchangeWarning | ResetInterchangeCheck | InterchangeCheck

Also In This Interface

LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


DriverSetup Property

IIviDriverOperation.DriverSetup Property

The driver setup string. It is either specified in the Configuration Store or passed in the OptionString parameter of the Initialize function. Driver setup is empty if the driver is not initialized.

[Visual Basic]
Property Get DriverSetup() As String
[C++]
HRESULT get_DriverSetup(BSTR* value);
[ANSI C]
HRESULT IIviDriverOperation_get_DriverSetup(IIviDriverOperation* This, BSTR* value);
[C#]
public string DriverSetup {get;}

Capability Group

IviRFSigGenBase

Also In This Interface

LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


GetNextCoercionRecord Method

IIviDriverOperation.GetNextCoercionRecord Method

Returns the oldest record from the coercion record list. Records are only added to the list if RecordCoercions is True.

[Visual Basic]
Function GetNextCoercionRecord() As String
[C++]
HRESULT GetNextCoercionRecord(
   BSTR* CoercionRecord
);
[ANSI C]
HRESULT IIviDriverOperation_GetNextCoercionRecord(
   IIviDriverOperation* This
   BSTR* CoercionRecord
);
[C#]
public string GetNextCoercionRecord();

Parameters

CoercionRecord
The coercion record string shall contain the following information:
  • The name of the attribute that was coerced. This can be the generic name, the COM property name, or the C defined constant.
  • If the attribute is channel-based, the name of the channel. The channel name can be the specific driver channel string or the virtual channel name that the user specified.
  • If the attribute applies to a repeated capability, the name of the repeated capability. The name can be the specific driver repeated capability token or the virtual repeated capability name that the user specified.
  • The value that the user specified for the attribute.
  • The value to which the attribute was coerced.

    • Capability Group

    IviRFSigGenBase

    Related Items

    RecordCoercions

    Also In This Interface

    LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


GetNextInterchangeWarning Method

IIviDriverOperation.GetNextInterchangeWarning Method

Returns the oldest warning from the interchange warning list. Records are only added to the list if InterchangeCheck is True.

[Visual Basic]
Function GetNextInterchangeWarning() As String
[C++]
HRESULT GetNextInterchangeWarning(
   BSTR* InterchangeWarning
);
[ANSI C]
HRESULT IIviDriverOperation_GetNextInterchangeWarning(
   IIviDriverOperation* This
   BSTR* InterchangeWarning
);
[C#]
public string GetNextInterchangeWarning();

Parameters

InterchangeWarning
A string describing the oldest interchangeability warning or empty string if no warrnings remain.

Capability Group

IviRFSigGenBase

Related Items

ClearInterchangeWarnings | ResetInterchangeCheck | InterchangeCheck

Also In This Interface

LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


InterchangeCheck Property

IIviDriverOperation.InterchangeCheck Property

If True, the driver maintains a record of interchangeability warnings. If the driver does not support interchangeability checking, attempts to set InterchangeCheck to True return an error.

[Visual Basic]
Property Get InterchangeCheck() As Boolean
Property Let InterchangeCheck(value As Boolean)
[C++]
HRESULT get_InterchangeCheck(VARIANT_BOOL* value);
HRESULT put_InterchangeCheck(VARIANT_BOOL value);
[ANSI C]
HRESULT IIviDriverOperation_get_InterchangeCheck(IIviDriverOperation* This, VARIANT_BOOL* value);
HRESULT IIviDriverOperation_put_InterchangeCheck(IIviDriverOperation* This, VARIANT_BOOL value);
[C#]
public bool InterchangeCheck {get; set;}

Capability Group

IviRFSigGenBase

Related Items

ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck

Also In This Interface

LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


InvalidateAllAttributes Method

IIviDriverOperation.InvalidateAllAttributes Method

Invalidates all of the driver's cached values.

[Visual Basic]
Sub InvalidateAllAttributes()
[C++]
HRESULT InvalidateAllAttributes();
[ANSI C]
HRESULT IIviDriverOperation_InvalidateAllAttributes(
   IIviDriverOperation* This);
[C#]
public void InvalidateAllAttributes();

Capability Group

IviRFSigGenBase

Related Items

Cache

Also In This Interface

LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


IoResourceDescriptor Property

IIviDriverOperation.IoResourceDescriptor Property

The resource descriptor specifies the connection to a physical device. It is either specified in the Configuration Store or passed in the ResourceName parameter of the Initialize function. It is empty if the driver is not initialized.

[Visual Basic]
Property Get IoResourceDescriptor() As String
[C++]
HRESULT get_IoResourceDescriptor(BSTR* value);
[ANSI C]
HRESULT IIviDriverOperation_get_IoResourceDescriptor(IIviDriverOperation* This, BSTR* value);
[C#]
public string IoResourceDescriptor {get;}

Capability Group

IviRFSigGenBase

Also In This Interface

LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


LogicalName Property

IIviDriverOperation.LogicalName Property

Logical Name identifies a driver session in the Configuration Store. If Logical Name is not empty, the driver was initialized from information in the driver session. If it is empty, the driver was initialized without using the Configuration Store.

[Visual Basic]
Property Get LogicalName() As String
[C++]
HRESULT get_LogicalName(BSTR* value);
[ANSI C]
HRESULT IIviDriverOperation_get_LogicalName(IIviDriverOperation* This, BSTR* value);
[C#]
public string LogicalName {get;}

Capability Group

IviRFSigGenBase

Also In This Interface

LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


QueryInstrumentStatus Property

IIviDriverOperation.QueryInstrumentStatus Property

If True, the driver queries the instrument status at the end of each method or property that performs I/O to the instrument. If an error is reported, use ErrorQuery to retrieve error messages one at a time from the instrument.

[Visual Basic]
Property Get QueryInstrumentStatus() As Boolean
Property Let QueryInstrumentStatus(value As Boolean)
[C++]
HRESULT get_QueryInstrumentStatus(VARIANT_BOOL* value);
HRESULT put_QueryInstrumentStatus(VARIANT_BOOL value);
[ANSI C]
HRESULT IIviDriverOperation_get_QueryInstrumentStatus(IIviDriverOperation* This, VARIANT_BOOL* value);
HRESULT IIviDriverOperation_put_QueryInstrumentStatus(IIviDriverOperation* This, VARIANT_BOOL value);
[C#]
public bool QueryInstrumentStatus {get; set;}

Capability Group

IviRFSigGenBase

Also In This Interface

LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


RangeCheck Property

IIviDriverOperation.RangeCheck Property

Drivers may choose to always validate some property/parameter values, never validate others, and optionally validate others, to avoid sending invalid commands to the instrument. If True, the driver performs optional validations.

[Visual Basic]
Property Get RangeCheck() As Boolean
Property Let RangeCheck(value As Boolean)
[C++]
HRESULT get_RangeCheck(VARIANT_BOOL* value);
HRESULT put_RangeCheck(VARIANT_BOOL value);
[ANSI C]
HRESULT IIviDriverOperation_get_RangeCheck(IIviDriverOperation* This, VARIANT_BOOL* value);
HRESULT IIviDriverOperation_put_RangeCheck(IIviDriverOperation* This, VARIANT_BOOL value);
[C#]
public bool RangeCheck {get; set;}

Capability Group

IviRFSigGenBase

Also In This Interface

LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


RecordCoercions Property

IIviDriverOperation.RecordCoercions Property

If True, the driver keeps a list of the value coercions it makes for ViInt32 and ViReal64 attributes. If the driver does not support coercion recording, attempts to set RecordCoercions to True will return an error.

[Visual Basic]
Property Get RecordCoercions() As Boolean
Property Let RecordCoercions(value As Boolean)
[C++]
HRESULT get_RecordCoercions(VARIANT_BOOL* value);
HRESULT put_RecordCoercions(VARIANT_BOOL value);
[ANSI C]
HRESULT IIviDriverOperation_get_RecordCoercions(IIviDriverOperation* This, VARIANT_BOOL* value);
HRESULT IIviDriverOperation_put_RecordCoercions(IIviDriverOperation* This, VARIANT_BOOL value);
[C#]
public bool RecordCoercions {get; set;}

Capability Group

IviRFSigGenBase

Related Items

GetNextCoercionRecord

Also In This Interface

LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


ResetInterchangeCheck Method

IIviDriverOperation.ResetInterchangeCheck Method

Resets the interchangeability checking algorithms of the driver so that methods and properties that executed prior to calling this function have no affect on whether future calls to the driver generate interchangeability warnings.

[Visual Basic]
Sub ResetInterchangeCheck()
[C++]
HRESULT ResetInterchangeCheck();
[ANSI C]
HRESULT IIviDriverOperation_ResetInterchangeCheck(
   IIviDriverOperation* This);
[C#]
public void ResetInterchangeCheck();

Capability Group

IviRFSigGenBase

Related Items

GetNextInterchangeWarning | ClearInterchangeWarnings | InterchangeCheck

Also In This Interface

LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


Simulate Property

IIviDriverOperation.Simulate Property

If True, the driver does not perform I/O to the instrument, and returns simulated values for output parameters.

[Visual Basic]
Property Get Simulate() As Boolean
Property Let Simulate(value As Boolean)
[C++]
HRESULT get_Simulate(VARIANT_BOOL* value);
HRESULT put_Simulate(VARIANT_BOOL value);
[ANSI C]
HRESULT IIviDriverOperation_get_Simulate(IIviDriverOperation* This, VARIANT_BOOL* value);
HRESULT IIviDriverOperation_put_Simulate(IIviDriverOperation* This, VARIANT_BOOL value);
[C#]
public bool Simulate {get; set;}

Capability Group

IviRFSigGenBase

Also In This Interface

LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


Disable Method

IIviDriverUtility.Disable Method

Quickly places the instrument in a state where it has no, or minimal, effect on the external system to which it is connected. This state is not necessarily a known state.

[Visual Basic]
Sub Disable()
[C++]
HRESULT Disable();
[ANSI C]
HRESULT IIviDriverUtility_Disable(
   IIviDriverUtility* This);
[C#]
public void Disable();

Capability Group

IviRFSigGenBase

Also In This Interface

Reset | ResetWithDefaults | Disable | SelfTest | ErrorQuery | LockObject | UnlockObject | IIviDriverUtility Overview


ErrorQuery Method

IIviDriverUtility.ErrorQuery Method

Queries the instrument and returns instrument specific error information. This function can be used when QueryInstrumentStatus is True to retrieve error details when the driver detects an instrument error.

[Visual Basic]
Sub ErrorQuery( _
   ErrorCode As Long, _
   ErrorMessage As String _
)
[C++]
HRESULT ErrorQuery(
   long* ErrorCode,
   BSTR* ErrorMessage
);
[ANSI C]
HRESULT IIviDriverUtility_ErrorQuery(
   IIviDriverUtility* This
   long* ErrorCode,
   BSTR* ErrorMessage
);
[C#]
public void ErrorQuery(
   long ErrorCode,
   string ErrorMessage
);

Parameters

ErrorCode
Instrument error code
ErrorMessage
Instrument error message

Capability Group

IviRFSigGenBase

Also In This Interface

Reset | ResetWithDefaults | Disable | SelfTest | ErrorQuery | LockObject | UnlockObject | IIviDriverUtility Overview


LockObject Method

IIviDriverUtility.LockObject Method

Obtains a multithread lock on the driver after waiting until all other execution threads have released their locks on the instrument session.

[Visual Basic]
Sub LockObject()
[C++]
HRESULT LockObject();
[ANSI C]
HRESULT IIviDriverUtility_LockObject(
   IIviDriverUtility* This);
[C#]
public void LockObject();

Capability Group

IviRFSigGenBase

Related Items

UnlockObject

Also In This Interface

Reset | ResetWithDefaults | Disable | SelfTest | ErrorQuery | LockObject | UnlockObject | IIviDriverUtility Overview


Reset Method

IIviDriverUtility.Reset Method

Places the instrument in a known state and configures instrument options on which the IVI specific driver depends (for example, enabling/disabling headers). For an IEEE 488.2 instrument, Reset sends the command string *RST to the instrument.

[Visual Basic]
Sub Reset()
[C++]
HRESULT Reset();
[ANSI C]
HRESULT IIviDriverUtility_Reset(
   IIviDriverUtility* This);
[C#]
public void Reset();

Capability Group

IviRFSigGenBase

Related Items

ResetWithDefaults

Also In This Interface

Reset | ResetWithDefaults | Disable | SelfTest | ErrorQuery | LockObject | UnlockObject | IIviDriverUtility Overview


ResetWithDefaults Method

IIviDriverUtility.ResetWithDefaults Method

Does the equivalent of Reset and then, (1) disables class extension capability groups, (2) sets attributes to initial values defined by class specs, and (3) configures the driver to option string settings used when Initialize was last executed.

[Visual Basic]
Sub ResetWithDefaults()
[C++]
HRESULT ResetWithDefaults();
[ANSI C]
HRESULT IIviDriverUtility_ResetWithDefaults(
   IIviDriverUtility* This);
[C#]
public void ResetWithDefaults();

Capability Group

IviRFSigGenBase

Also In This Interface

Reset | ResetWithDefaults | Disable | SelfTest | ErrorQuery | LockObject | UnlockObject | IIviDriverUtility Overview


SelfTest Method

IIviDriverUtility.SelfTest Method

Performs an instrument self test, waits for the instrument to complete the test, and queries the instrument for the results. If the instrument passes the test, TestResult is zero and TestMessage is 'Self test passed'.

[Visual Basic]
Sub SelfTest( _
   TestResult As Long, _
   TestMessage As String _
)
[C++]
HRESULT SelfTest(
   long* TestResult,
   BSTR* TestMessage
);
[ANSI C]
HRESULT IIviDriverUtility_SelfTest(
   IIviDriverUtility* This
   long* TestResult,
   BSTR* TestMessage
);
[C#]
public void SelfTest(
   long TestResult,
   string TestMessage
);

Parameters

TestResult
The numeric result from the self test operation. 0 = no error (test passed)
TestMessage
The self test status message

Capability Group

IviRFSigGenBase

Also In This Interface

Reset | ResetWithDefaults | Disable | SelfTest | ErrorQuery | LockObject | UnlockObject | IIviDriverUtility Overview


UnlockObject Method

IIviDriverUtility.UnlockObject Method

Releases a previously obtained mutlithread lock.

[Visual Basic]
Sub UnlockObject()
[C++]
HRESULT UnlockObject();
[ANSI C]
HRESULT IIviDriverUtility_UnlockObject(
   IIviDriverUtility* This);
[C#]
public void UnlockObject();

Capability Group

IviRFSigGenBase

Related Items

LockObject

Also In This Interface

Reset | ResetWithDefaults | Disable | SelfTest | ErrorQuery | LockObject | UnlockObject | IIviDriverUtility Overview