Lisez-moi "RunTime Kit"

Runtime Kit WibuKey

Ce fichier d'aide donne un aperçu du Runtime Kit WibuKey.
Installation des logiciels WibuKey
Désinstallation des logiciels WibuKey
Répertoire des fichiers fournis
Répertoires cibles pour les fichiers des pilotes
Comment se procurer les pilotes les plus récents ?


Installation des logiciels WibuKey

Ce logiciel d'installation permet d'installer automatiquement tous les pilotes nécessaires pour l'utilisation de WibuKey sous le système d'exploitation de l'ordinateur concerné. Pour installer les logiciels, vous devez tout d'abord fermer toutes les applications Windows ouvertes, en particulier celles qui sont protégées par WibuKey. Sinon, certains fichiers risquent de ne pas pouvoir être remplacés par la version la plus récente. Lancer le programme SETUP.EXE et suivre les instructions à l'écran. Le programme d'installation affiche le système d'exploitation détecté et indique la liste des fichiers nécessaires pour utiliser WibuKey sur ce système. Appuyer sur le bouton "Suivant" pour copier et éventuellement installer ces fichiers sur le disque dur. Une fois l'installation terminée, le panneau de configuration contient une nouvelle icône appelée WibuKey. Cliquer sur cette icône pour faire apparaître le contenu de la clé WibuBox raccordée. En cas d'erreur pendant l'installation ou au démarrage de l'icône, redémarrer le système et recommencer l'installation.
Important lors de l'installation de Windows 95:

Pour pouvoir utiliser correctement WibuKey, il faut réinstaller ou mettre à jour certaines DLL. Pour ce faire il faut utiliser le programm original d'installation de Microsoft msaardk.exe qui se trouve dans le répertoire \Tools\Microsoft sur le CD-ROM WibuKey version 3.30. L' installation de ces DLL est absolument nécessaire pour le kit de développement WibuKey DevKit. Elle n'est pas impérative mais néanmoins conseillée pour le Runtime Kit WibuKey.
Important lors de l'installation de Windows NT 4.0:

Sous Windows NT4, il faut installer la DLL système shlwapi.dll. Cette DLL est déjà installée si Internet Explorer version 4.0 ou supérieur est utilisé.


Désinstallation des logiciels WibuKey

Les pilotes WibuKey peuvent être désinstallés automatiquement de Windows /2000/XP/Vista/7/Serveur 2003, 2008 si ils ont été installés à partir de ce Runtime Kit WibuKey. Dans le Panneau de configuration, cliquer sur l'icône "Ajout/Suppression de programmes". Dans la liste des logiciels, sélectionner l'entrée "WibuKey Remove". Cliquer sur "Ajouter/Supprimer" ou "OK" pour lancer le programme de désinstallation et supprimer tous les fichiers de pilotes, l'icône WibuKey du Panneau de configuration ainsi que les entrées de la base de registre.


Répertoire des fichiers fournis

Fichiers de pilotes :
Nom du fichier
Répertoire cible
WKUSEUS.CHM | Version anglaise de l'aide
WKUSEDE.CHM | Version allemande de l'aide
WKUSEFR.CHM | Version française de l'aide
SETUP32.EXE | Programme d'installation pour Windows
SETUP.EXE | Programme d'installation pour Windows (16 bits)
SETUP32.LDE | Fichier de langue en allemand pour SETUP.EXE
SETUP32.LFR | Fichier de langue en français pour SETUP.EXE
SETUP32.LHU | Fichier de langue en hongrois pour SETUP.EXE
SETUP32.LES | Fichier de langue en espagnol pour SETUP.EXE
SETUP32.LJP | Fichier de langue en japonais pour SETUP.EXE
SETUP32.LBR | Fichier de langue en portugais pour SETUP.EXE
SETUP32.LIT | Fichier de langue en italien pour SETUP.EXE
SETUP32.LCN | Fichier de langue en chinois pour SETUP.EXE
SETUP.INI | Fichier de configuration pour Setup
WIBUKEY.INI | Fichier de configuration pour WIBU-KEY
WKEXT32.DLL | DLL de démarrage / pilote pour Windows
WKDOS.EXE | Pilote WkDOS pour Windows NT/2000/XP, Windows 95/98/ME, Win 3.x et DOS
WKWIN.DLL | DLL de démarrage / pilote pour Windows 16 bits
WKWIN16.LDE | Fichier de langue en allemand pour WKWIN16.DLL
WKWIN16.LFR | Fichier de langue en français pour WKWIN16.DLL
WKWIN16.LHU | Fichier de langue en hongrois pour WKWIN16.DLL
WKWIN16.LES | Fichier de langue en espagnol pour WKWIN16.DLL
WKWIN16.LJP | Fichier de langue en japonais pour WKWIN16.DLL
WKWIN16.LBR | Fichier de langue en portugais pour WKWIN16.DLL
WKWIN16.LIT | Fichier de langue en italien pour WKWIN16.DLL
WKWIN16.LCN | Fichier de langue en chinois pour WKWIN16.DLL
WIBUKJNI.DLL | DLL de Java Native Interface pour WIBU-KEY
WKWIN32.DLL | DLL de démarrage / pilote pour Win32
WKWIN32.LDE | Fichier de langue en allemand pour WKWIN32.DLL
WKWIN32.LFR | Fichier de langue en français pour WKWIN32.DLL
WKWIN32.LHU | Fichier de langue en hongrois pour WKWIN32.DLL
WKWIN32.LES | Fichier de langue en espagnol pour WKWIN32.DLL
WKWIN32.LJP | Fichier de langue en japonais pour WKWIN32.DLL
WKWIN32.LBR | Fichier de langue en portugais pour WKWIN32.DLL
WKWIN32.LIT | Fichier de langue en italien pour WKWIN32.DLL
WKWIN32.LCN | Fichier de langue en chinois pour WKWIN32.DLL
WIBUKEY.SYS | Pilote de noyau pour Windows NT/2000/XP
WIBUKEY2.SYS | Pilote de noyau pour Windows 98/ME/2000/XP pour USB
WIBUKEY.VXD | Pilote de noyau pour Windows 95/98/ME
WIBUKEY.DLL | Contrôle COM WIBU-KEY
WIBUSHELLEXT.DLL | Extension de shell WIBU-SYSTEMS
WIBUKE32.CPL | Extension du Panneau de configuration pour Windows
WIBUKE32.LDE | Fichier de langue en allemand pour WIBUKE32.CPL
WIBUKE32.LFR | Fichier de langue en français pour WIBUKE32.CPL
WIBUKE32.LHU | Fichier de langue en hongrois pour WIBUKE32.CPL
WIBUKE32.LES | Fichier de langue en espagnol pour WIBUKE32.CPL
WIBUKE32.LJP | Fichier de langue en japonais pour WIBUKE32.CPL
WIBUKE32.LBR | Fichier de langue en portugais pour WIBUKE32.CPL
WIBUKE32.LIT | Fichier de langue en italien pour WIBUKE32.CPL
WIBUKE32.LCN | Fichier de langue en chinois pour WIBUKE32.CPL
WIBUKEY.INF | Fichier d'installation PnP pour Windows 95/98/ME/2000/XP
Outils :

Nom du fichier
Répertoire cible
WKSVMON.EXE | Moniteur de serveur réseau WkNet/WkLAN pour Win32
WKSVNW.NLM | Processus de serveur WkNet sous forme de module NLM pour Novell Netware
WKSVW32.EXE | Processus de serveur réseau sous forme d'application 32 bits (WkLAN/WkNet)
WKU.EXE | Programme DOS pour l'utilisateur final WIBU-KEY
WKU32.EXE | Variante 32 bits de WKU.EXE
Certains outils possèdent des fichiers de langue supplémentaires. Ces fichiers possèdent le même nom que le fichier correspondant, avec l'extension Lxx, xx représentant le code de la langue utilisée. Certains fichiers ont été compressés à l'aide de l'outil Microsoft COMPRESS. Leur extension se termine toujours par le caractère souligné ("_").


Répertoires cibles pour les fichiers des pilotes

Nom de fichier
Répertoire cible
WkDOS.exe Répertoire racine de Windows ([Lect:]\..\%WINDOWS%) ou
([Lect:]\..\%WINDOWS%\SYSTEM32 uniquement sous Windows NT)
WkWin.dll | Répertoire système de Windows ([Lect:]\..\%WINDOWS%\SYSTEM)

WkExt32.dll

Répertoire racine de Windows ([Lect:]\..\%WINDOWS%) ou
([Lect:]\..\%WINDOWS%\SYSTEM32 uniquement sous Windows

WkWin32.dll | Répertoire système de Windows ([Lect:]\..\%WINDOWS%\SYSTEM ou [Lect:]\..\%WINDOWS%\SYSTEM32 uniquement sous Windows NT)

WibuKJni.dll

Répertoire système de Windows ([Lect:]\..\%WINDOWS%\SYSTEM ou [Lect:]\..\%WINDOWS%\SYSTEM32 uniquement sous Windows NT)

WIBUKEY.dll | Répertoire de programme WIBU-KEY ([Lect:]\..\ProgrammFiles\WIBU-KEY\BIN)
WibuShellExt.dll | Répertoire de programme WIBU-KEY ([Lect:]\..\ProgrammFiles\WIBU-SYSTEMS\System)
WibuKey.sys | Répertoire de pilotes de Windows NT ([Lect:]\..\%WINDOWS%\SYSTEM32\DRIVERS)
WibuKey2.sys | Répertoire de pilotes de Windows ([Lect:]\..\%WINDOWS%\SYSTEM32\DRIVERS)
WibuKey.vxd | Répertoire système de Windows ([Lect:]\..\%WINDOWS%\SYSTEM)
WibuKe32.cpl | Répertoire système de Windows ([Lect:]\..\%WINDOWS%\SYSTEM ou [Lect:]\..\%WINDOWS%\SYSTEM32)
Une application fonctionnera généralement sous W95/98/ME même si certains fichiers comme les DLL ou WKDOS.EXE ne se trouvent pas dans le répertoire système mais dans le répertoire d'application. Toutefois, WIBU-SYSTEMS recommande expressément d'installer les fichiers à l'aide du Runtime Kit WIBU-KEY pour garantir la fonctionnalité totale des applications. Sous Windows NT/2000/XP, l'installation avec le Runtime Kit WIBU-KEY est indispensable, car les composants sont alors enregistrés dans le système pour garantir le bon fonctionnement des applications. Si un fichier de langue correspondant à une DLL est installé, il est copié dans le même répertoire que la DLL. Les fichiers de langue sont nommés WkWin16.lxx pour WkWin.dll et WkWin32.lxx pour WkWin32.dll, xx correspondant à l'abréviation de la langue du fichier.


Comment se procurer les pilotes les plus récents ?

Les informations les plus récentes relatives à WibuKey se trouvent sur Internet. Visitez notre site web (version allemande ou version anglaise) :
http://www.wibu.de/
La dernière version du Runtime Kit WibuKey peut être téléchargée à partir de la page suivante :
http://wibu.de/download_user.php?lang=en


Les cles WibuBox

Les clés WibuBox

Qu'est-ce qu'une WibuBox ?
La clé WibuBox est un matériel d'encryptage de WIBU-SYSTEMS. Elle se présente sous la forme d'un petit connecteur de couleur pour PC ou Macintosh. La clé WibuBox peut avoir différentes couleurs, mais généralement elle est turquoise. Il existe différentes variantes de WibuBox pour les divers types de ports. Le comportement de toutes les WibuBox est le même. Les WibuBox respectent les normes nationales et internationales. Des déclarations de conformité détaillées sont disponibles sur demande.
WibuBox/P
WibuBox/U
WibuBox/SP
WibuBox/SX
WibuBox/ST
WibuBox/P36
WibuBox/CI
WibuBox/M
WibuBox/A
WibuBox/RP
WibuBox/RU
Conformité CE
Respect des dispositions FCC
Homologation VDE
Homologation UL
Homologation VCCI


WibuBox/P

Les clés WibuBox/P et WibuBox/P+ (avec 16kB de mémoire étendue) sont destinées au port parallèle d'imprimante des PC IBM ou compatibles. Elles supportent le port parallèle étendu (EPP) et son mode bidirectionnel compatible IEEE 1284. Tous les appareils utilisant cette norme fonctionnent avec la WibuBox/P(+). Pour la connecter, il suffit de la brancher dans le sens de la flèche sur le port d'imprimante 25 points du PC. Les vis servent à fixer la clé au boîtier du PC. La clé WibuBox peut être montée en cascade, c'est-à-dire qu'il est possible de connecter plusieurs WibuBox à la suite. Si la WibuBox/P est utilisée simultanément avec des clés d'autres fournisseurs, il est préférable de la connecter en premier au PC et de brancher les autres derrière la clé WibuBox. Généralement, il est également possible de raccorder une imprimante à la dernière WibuBox connectée. Voir le Problèmes d'imprimantes.


WibuBox/U

Les clés WibuBox/U et WibuBox/U+ (avec 16kB de mémoire étendue) sont conçues pour les ports USB (Universal Serial Bus) des PC et des Macintosh. Elles peuvent se connecter à tout port USB ou répartiteur (Hub). Le port USB remplacera certainement à l'avenir les ports traditionnels.
La clé WibuBox/U(+) ne peut pas se monter en cascade. Il ne peut exister de conflit entre la WibuBox/U(+) et les autres appareils, puisque le système d'exploitation contrôle et synchronise les accès à tous les périphériques USB raccordés. La WibuBox/U supporte MacOS à partir de la Version 8, Windows Windows 2000/XP/Serveur 2003, 2008/Vista et Windows 7.


WibuBox/SP

La clé WibuBox/SP est destinée au port série des PC IBM ou compatibles. Elle supporte différents modes de communication série. Le mode de fonctionnement standard de la WibuBox/SP est le mode Souris. Par ailleurs, la clé peut être reconfigurée en mode Terminal. Tous les périphériques utilisant l'un de ces modes pour la communication série peuvent être utilisés avec la WibuBox/SP. Pour la connecter, il suffit de la brancher dans le sens de la flèche sur le port série 25 points du PC. Les vis servent à fixer la clé au boîtier du PC. Il est également possible de connecter la clé WibuBox/SP aux ports AT 9 points. Pour cela, il faut utiliser un câble adaptateur entre la prise femelle 25 points de la WibuBox/SP et le petit connecteur 9 points. Il est ensuite possible de connecter une souris ou un périphérique avec connexion 3 fils (RS-232) à la WibuBox/SP. Toutefois, ces périphériques risquent de présenter quelques problèmes de fonctionnement lorsqu'ils sont raccordés derrière une WibuBox/SP. WIBU-SYSTEMS a testé des souris et identifié celles qui fonctionnent sans problème : les souris Microsoft, Logitech et Genius. Si les WibuBox/SP raccordées entre la souris et le port série font l'objet d'accès fréquents et longs, il se peut que les déplacements de la souris à l'écran soient légèrement ralentis. Cependant, cela ne doit en aucun cas provoquer de blocages, de positions hors de l'écran ou de clics intempestifs.


WibuBox/SX

La WIBU-BOX/SX est identique à la WIBU-BOX/SP, mais elle est conçue uniquement pour les PC NEC japonais avec port RS-232 standard.


WibuBox/ST

La clé WibuBox/ST est identique à la WibuBox/SP, mais elle est conçue pour les ports série asynchrones (RS-232) de tous les systèmes (ex. ordinateurs Unix, PC, Macintosh). La WibuBox/ST détecte automatiquement les vitesses de transmission de 4800 à 19200 bauds et s'y adapte.


WibuBox/P36

La clé WIBU-BOX/P36 est conçue pour l'interface Centronics 36 points et peut être utilisée aussi bien sur les systèmes NEC-PC98 japonais que sur des PC standard. Pour la connecter, il suffit de la brancher dans le sens de la flèche sur le port Centronics 36 points du PC. Les crochets servent à fixer le câble d'imprimante au PC.


WibuBox/CI

La clé WibuBox/CI est une carte pour les bus ISA des PC IBM ou compatibles. Pour l'installation, un emplacement 8 bits est nécessaire. Il est également possible d'utiliser un emplacement 16 bits ou une carte EISA. L'adresse d'interface peut être réglée entre 230H et 24FH ou entre 330H et 34FH à l'aide de cavaliers. L'adresse définie doit être entrée dans le panneau de configuration WibuKey, dans l'onglet Configuration. Le plus souvent, l'adresse de base de la WibuBox/CI est entrée comme adresse de LPT4.


WibuBox/M

La clé WIBU-BOX/M est une carte PCMCIA de type II. Elle fonctionne comme les autres variantes WIBU-BOX, elle est donc parfaitement compatible et aussi fiable. Les pilotes WIBU-KEY pour PCMCIA supportent les Card Services et l'accès direct aux Card-Controller PC compatibles Intel qui n'ont pas besoin de Card Services. Insérer la WIBU-BOX/M dans le sens de la flèche dans l'emplacement PC Card du PC ou du portable. Elle est détectée automatiquement comme matériel Plug and Play de Windows 98/ME et Windows 2000/XP. Sous DOS et Windows 3.x, il faut installer des Card Services et des Socket Services. L'utilisation sous Windows NT nécessite l'installation de l'Award Cardware pour NT 4.


WibuBox/A

La clé WibuBox/A a été développée spécialement pour l'interface ADB des ordinateurs Apple Macintosh. Elle repose sur le même ASIC que les autres variantes de clés WibuBox ; elle est donc parfaitement compatible et aussi fiable. Pour connecter la clé WibuBox/A, brancher le connecteur du câble (connecteur fin) sur le port ADB du Macintosh (par ex. sur le clavier, ou avant la souris). Le connecteur (ondulé) permet par exemple de brancher la souris à la suite.


WibuBox/RP

Les clés WibuBox/RP et WibuBox/RP+ (avec 16kB de mémoire étendue) sont destinées au port parallèle d'imprimante des PC IBM ou compatibles. Elles supportent le port parallèle étendu (EPP) et son mode bidirectionnel compatible IEEE 1284. Tous les appareils utilisant cette norme fonctionnent avec la WibuBox/RP(+). Pour la connecter, il suffit de la brancher dans le sens de la flèche sur le port d'imprimante 25 points du PC. Les vis servent à fixer la clé au boîtier du PC. La clé WibuBox peut être montée en cascade, c'est-à-dire qu'il est possible de connecter plusieurs WibuBox à la suite. Si la WibuBox/RP doit partager le port parallèle avec des clés d'autres fournisseurs, il est préférable de la raccorder en premier au PC et de brancher les autres clés derrière la clé WibuBox/RP. Il est en principe possible de brancher une imprimante dernière la WibuBox connectée au PC. Voir le chapitre Problèmes d'imprimantes.


WibuBox/RU

Les clés WibuBox/RU et WibuBox/RU+ (avec 16kB de mémoire étendue) sont conçues pour les ports USB (Universal Serial Bus) des PC et des Macintosh. Elles peuvent se connecter à tout port USB ou répartiteur (Hub).
Le port USB remplacera certainement à l'avenir les ports traditionnels. La clé WibuBox/RU(+) ne peut pas être montée en cascade. Il ne peut exister de conflit entre la WibuBox/RU(+) et les autres appareils, puisque le système d'exploitation contrôle et synchronise les accès à tous les périphériques USB raccordés. La WibuBox/RU supporte MacOS à partir de la Version 8, Windows Windows 2000/XP/Serveur 2003, 2008/ Vista /7.


Conformité CE

Toutes les clés WibuBox satisfont aux exigences de sécurité de la directive 89/336/CEE du Conseil de l'Union européenne. Elles portent le logo CE. Elles satisfont aux normes suivantes en vigueur pour la compatibilité électromagnétique, l'immunité et la sensibilité. Ces produits respectent les limites pour les appareils de classe B selon la norme EN55022. La résistance aux interférences est conforme aux normes EN 50082-1 et EN55024. Un certificat de conformité détaillé est disponible sur demande pour chaque variante de clé WibuBox.


Respect des dispositions FCC

Les clés WibuBox sont testées et homologuées pour le respect des valeurs limites applicables aux appareils numériques de classe B selon la partie 15 des dispositions FCC. Leur fonctionnement est soumis aux conditions suivantes :

1. L'appareil ne doit générer aucun rayonnement parasite nocif.

2. L'appareil doit pouvoir supporter les rayonnements parasites, y compris ceux qui peuvent entraîner un fonctionnement intempestif.

L'appareil génère et utilise une énergie à haute fréquence et peut générer des rayonnements parasites s'il n'est pas installé et utilisé conformément aux instructions. Toutefois, il n'existe pas de garantie qu'aucun rayonnement ne se produise dans une installation donnée. En cas de perturbations, consulter le manuel système, qui doit contenir des propositions susceptibles d'éliminer ces perturbations. Font partie des solutions généralement applicables : augmenter la distance entre l'ordinateur et les postes de télévision ou de radio, raccorder l'ordinateur à un autre circuit électrique ou sur une autre prise de courant. Toute modification ou altération du produit sans autorisation expresse de WIBU-SYSTEMS AG peut entraîner le non-respect des dispositions FCC. Dans ce cas, l'utilisateur perd le droit de faire usage de ce produit. Les clés WibuBox ont été, dans la mesure du possible, testées et homologuées avec un câble de liaison blindé. Il est donc nécessaire de disposer d'un câble blindé pour l'utilisation de ce produit. Une DoC (déclaration de conformité) FCC est disponible sur demande.


Homologation VDE

Les clés WibuBox satisfont aux exigences de sécurité des produits de la norme EN60950 (VDE 0805).


Homologation UL

Les clés WibuBox ont subi avec succès les tests UL94 d'inflammabilité des matières plastiques dans les pièces détachées et les appareils. Les WibuBox répondent aux exigences de la norme UL1950 (Safety of Information Technology Equipment - sécurité des équipements informatiques) et sont listés UL (Underwriters Laboratories).


Homologation VCCI

Les clés WibuBox satisfont aux exigences de sécurité des produits selon le VCCI au Japon (Voluntary Control Council for Interference by Information Technology Equipment).


WibuKey FAQ

FAQ WibuKey et solutions aux problèmes

Vous trouverez dans le lien ci-après les réponses aux questions les plus fréquemment posées par nos clients.
Pour simplifier la recherche, les réponses sont classées par domaine :
Page actuelle de la FAQ (connection Internet nécessaire)
Support

Une équipe professionnelle composée de collaborateurs de haut niveau assiste nos clients et clients finaux dès la première étape.
Le contact direct nous permet de réagir rapidement aux souhaits des utilisateurs.
En tant qu'utilisateur ou développeur vous bénéficierez d'une assistance compétente pour répondre à votre demande. En tant qu'utilisateur final nous vous aiderons volontier en cas de problème. Notre support est accessible de 8.00 à 12.00 et de 13.00 à 17.00 sous le numéro +49-721-93172-15 pour les clients finaux ou tout simplement par Email à l'adresse support@wibu.de.


L'applet du panneau de configuration

L'applet WibuKey du panneau de configuration

Contenu
L'applet WibuKey du panneau de configuration
Page Contenu
Page Test
Page Serveur

Page Accès Serveur

Page Serveur WkNet

Page Réseau
Page Contexte WIBU-BOX
Page Update WIBU-BOX
Page Configuration
Page Installation
Page Diagnostic
Page A propos


Icône WibuKey

L'applet WibuKey

L'outil de contrôle central pour l'accès à des clés WibuBox est l'applet WibuKey dans le panneau de configuration de Windows. Le symbole WibuKey est destiné à la fois au développer de logiciel et à l'utilisateur d'une application protégée par WibuKey. Le fichier de contrôle WIBUKE32.CPL est destiné aux systèmes d'exploitation 32 bits Windows 95/98/ME/NT/2000/XP/Serveur 2003. Suivant le système d'exploitation et les permissions accordées à l'utilisateur, le symbole WibuKey offre sur plusieurs pages les fonctions suivantes :

" Démarre avec 4 pages"

Contenu. Permet d'afficher les clés WibuBox connectées localement à l'ordinateur ou trouvées sur le réseau.

Réseau. Permet de configurer les paramètres réseau pour le client.

Installation. Permet d'afficher les pilotes installés, de les mettre à jour ou de les supprimer.

Informations. Permet d'afficher des informations sur cette version du symbole WibuKey.

" Choisir Mode avancé !"

"Toutes les pages sont affichées maintenant"

Contenu. Permet d'afficher les clés WibuBox connectées localement à l'ordinateur ou trouvées sur le réseau.

Test. Permet de tester le parfait fonctionnement des clés WibuBox.
Serveur. Permet de configurer le nom des clusters, les fichiers HLM et WkLAN.

Accès Serveur Cette page permet de configurer les droites d'a ccès de clients au serveur WkLAN.

Serveur WkNet. Permet de configurer les processus serveur de réseau WkNet.

Réseau. Permet de configurer les paramètres réseau pour le client.
Contexte WibuBox. Permet à l'utilisateur de sauvegarder le contenu d'une clé WibuBox dans un fichier (fichier contextuel de programmation à distance).
Mise à jour d'une clé WibuBox. Permet à l'utilisateur d'effectuer une mise à jour de sa clé WibuBox au travers d'un fichier de programmation à distance.
Paramétrage. Permet de configurer et de spécifier les interfaces à parcourir par les pilotes WibuKey pour rechercher les clés WibuBox.
Installation. Permet d'afficher les pilotes installés, de les mettre à jour ou de les supprimer.
Diagnostic. Permet d'afficher des messages de diagnostic des pilotes WibuKey.
Informations. Permet d'afficher des informations sur cette version du symbole WibuKey.


Icône WibuKey -Contenu-

Page Contenu

Pour la plupart des utilisateurs, cette page est la première et la plus importante du panneau de configuration. Elle liste toutes les clés WibuBox qui ont été trouvées localement ou sur le réseau.

La zone Liste des clés permet de sélectionner une clé WibuBox pour en afficher le contenu dans la partie droite de la fenêtre. Le bouton Edition… permet de modifier les données utilisateurs et les flags de configuration de la clé sélectionnée. Le bouton Lit les ports permet de parcourir les ports pour rechercher les clés qui viennent d'être connectées.
L'applet WibuKey ne permet pas de modifier les entrées protégées dans une clé WibuBox.


Icône WibuKey -TEST-

Page Test

Par défaut toutes les clés WibuBox qui ont été trouvées localement sont affichées à droite dans la liste des clés à tester. Le bouton &ndash;> permet d'ajouter une clé préalablement sélectionnée dans la zone Liste des clés à la liste des clés à tester. Le bouton <&ndash; permet de retirer une clé préalablement sélectionnée de la liste des clés à tester.

Le bouton Start permet de démarrer la procédure de test et le bouton Stop de l'arrêter.
Le bouton Reset permet de remettre le compteur d'erreur à zéro.

Le test de fonctionnement des clés sélectionnées se fait par encryptage et décryptage de chaînes de codes aléatoires. Le nombre d'erreurs rencontrées est affiché dans la dernière colonne de la liste des clés à tester. Le test se déroule en continu et s'arrête automatiquement lorsque la sélection des ports à tester est modifiée.

Le bouton Lit les ports permet de parcourir tous les ports pour rechercher les clés WibuBox qui viennent d'être connectées. Il remet aussi à zéro le compteur du nombre de tests effectués ainsi que le compteur d'erreurs.
Pendant l'exécution de tests sous Windows 95, la priorité haute du pilote WIBUKEY.VXD peut causer un léger ralentissement des mouvements de la souris.


Icône WibuKey -SERVEUR-

Page Serveur

Cette page permet de spécifier les noms des clusters, de fichiers HLM et de configurer WkLAN.
Nom de cluster
Fichiers HLM
Configuration de WkLAN


Icône WibuKey - Nom du cluster -

Nom du cluster
Le champ Nom du cluster définit un nom de cluster pour une paire Firm Code / User Code. Vous pouvez ajouter, modifier ou supprimer des noms. Pour chaque paire Firm Code / User Code, il n'est possible d'indiquer qu'un seul nom.


Icône WibuKey - Fichiers HLM

Fichiers HLM
Le champ Fichiers HLM permet de nommer des fichiers "Huge License Management". Vous pouvez indiquer un nom de fichier ou utiliser le bouton "..." pour rechercher les fichiers. Pour vérifier si le fichier indiqué est valable, cliquer sur le bouton "Test...".


Icône WibuKey -Paramétrage WkLAN-

Paramétrage WkLAN
La protection d'une application avec WkLAN nécessite la présence d'un serveur WkLAN sur le réseau. Ce serveur peut être identifié sur les postes de travail du réseau en indiquant un nom ou une adresse IP dans la liste de recherche des serveurs WkLAN. Si des noms sont utilisés pour identifier le serveur sur le réseau, un système DNS (Domain Name System) ou WINS (Windows Internet Naming Service) doit être installé. Ces systèmes effectuent la résolution nom/adresse IP.

Chaque spécification serveur peut contenir une information Broadcast ou Multicast. Si aucun nom ou adresse n'est indiqué dans la liste de recherche des serveurs WkLAN, l'adresse 255,255,255,255 (LAN Broadcast) sera utilisée par défaut. Ce broadcast ne s'applique qu'au réseau local et ne peut pas traverser un routeur.

Le bouton Ajouter permet d'ajouter à la liste de recherche des serveurs WkLAN le nom ou l'adresse d'un serveur WkLan indiqué dans la zone de texte. Le bouton Supprimer permet de supprimer le nom ou l'adresse sélectioné dans la liste et le bouton Modifier de les modifier.
Le bouton Rechercher... permet de parcourir le réseau pour rechercher les serveurs WkLAN disponibles.
Les boutons &rdquo;flêche vers le haut&rdquo; et &rdquo;flêche vers le bas&rdquo; permettent de modifier l'ordre de recherche des serveurs sur le réseau. Les pilotes WIBU-KEY effectuent la recherche en partant du haut vers le bas de la liste et utilisent le premier serveur WkLAN qui dispose des entrées appropriées.
200.200.200.13
200.200.200.147
255.255.255.255
Dans cet exemple, les pilotes WIBU-KEY rechercheront d'abord le serveur WkLAN avec l'adresse IP 200,200,200,13, puis le serveur WkLAN avec l'adresse IP 200,200,200,147 et pour finir effectuera une recherche sur tout le réseau local.

La page réseau permet aussi de modifier le numéro du port TCP utilisé pour la communication avec le serveur WkLAN. Par défaut, la gestion de serveur WkLAN utilise le port TCP numéro 22347. Si ce numéro est déjà utilisé par un autre serveur TCP sur le réseau, il faut indiquer un nouveau numéro dans cette page. Ce même numéro devra aussi être indiqué sur le serveur WkLAN, dans le cas contraire aucune communication ne pourrait avoir lieu entre l'application et le serveur.


Icône WibuKey -Accès Serveur

Page Accès Serveur

Cette page permet de configurer les droits d'accès des clients au serveur WkLAN. Vous pouvez indiquer ici divers droits d'accès individuels aux PC client via leur adresse IP ou leur nom :
  • Lecture : permet d'attribuer au client les droits de lecture sur le serveur WibuKey. Le serveur sera affiché avec l'outil WibuKey et le moniteur réseau .
  • Accès : permet d'attribuer une licence réseau à un PC client.
  • Suppression : permet de supprimer le client via le moniteur réseau WibuKey, sur le serveur WibuKey.
La configuration standard ou par défaut est paramétrée de telle sorte que tous les clients disposent de tous les droits sur le serveur WibuKey.
Administrer l'accès au serveur via le Registre


Icône WibuKey - Server WKNET -

Onglet Serveur WkNet

L'onglet Serveur WkNet permet de configurer le processus de serveur réseau WkNet.
Paramètres WkNet


Icône WibuKey -Configuration de WkNet-

Configuration de WkNet
La zone Configuration WkNet permet de configurer les paramètres du serveur WkNet :
  • Le champ Firm-/User-Code contient les paramètres d'encryptage pour le processus WkNet. Ces paramètres doivent être programmés dans une des clés WibuBox connectée à cette station.
  • Le fichier serveur est le fichier qui gère la communication entre le serveur WkNet et le poste de travail. Ce fichier WkNet ne doit pas nécessairement se trouver localement sur le serveur WkNet. Il peut se trouver sur n'importe quel ordinateur du réseau. Il est seulement nécessaire que le serveur WkNet et les postes de travail puissent lire et ecrire ce fichier.
  • Le bouton Rechercher... permet d'ouvrir une boîte de dialogue pour rechercher le fichier WkNet.
  • Le temps de rafraichissement (Refresh Time) spécifie la durée en secondes pour l'actualisation du fichier serveur WkNet. Les valeurs peuvent être comprises entre 10 secondes et 1 heure environ. La valeur par défaut est 10 secondes.
Si la durée du temps de rafraîchissement a été modifiée sur le serveur WkNet, il faut impérativement adapter les paramètres de rafraîchissement de l'application correspondante.
  • La valeur Timeout indique le temps en minutes au-delà duquel le serveur WkNet déconnecte les clients qui n'ont pas consulté le fichier serveur pendant ce temps. La valeur par défaut est de 30 minutes. Cette valeur dépend de la durée de rafraîchissement sélectionnée et doit se trouver entre trois fois et 249 fois la valeur de la durée de rafraîchissement.
    Si cette valeur n'est pas définie, aucune entrée dans le fichier serveur ne sera supprimée.
  • Le Selection Code est un paramètre additionnel nécessaire pour à l'encryptage. Cette valeur n'est pas enregistrée dans la clé WibuBox. Comme cette valeur est également utilisée dans l'application, elle est fixée par l'éditeur de logiciel. La valeur standard est 1234.
Un serveur WkNet peut contrôler simultanément plusieurs processus serveur. Le bouton Ajouter permet d'ajouter les valeurs indiquées dans les zones de texte, le bouton Modifier de les modifier et le bouton Supprimer de les supprimer.


Icône WibuKey -Réseau-

Page Réseau

La page réseau est utilisée pour configurer les paramètres réseau des postes de travail qui doivent communiquer avec des serveurs WkNet ou WkLAN.
La zone Fichiers serveurs WkNeT affiche les paramètres pour la recherche des serveurs WkNet.
La zone Liste de recherche des serveurs WkLAN affiche la liste de recherche pour les serveurs WkLAN.
La zone Sous-systèmes WibuKey permet de limiter la recherche sur certains sous-systèmes WibuKey et la zone Adresse de port WkLAN permet de modifier l'adresse du port utilisé.
Paramétrage WkNet
Paramétrage WkLAN
Paramétrages pour sous-systèmes


Icône WibuKey -Paramétrage WkNet-

Paramétrage WkNet
Pour qu'une application puisse accéder à une clé WibuBox d'un serveur WkNet, elle doit connaître le nom du fichier serveur utilisé pour la communication. L'application doit indiquer le nom de l'application aux pilotes WibuKey. La page réseau permet d'établir un lien entre le nom d'application et le fichier serveur correspondant WkNet. Le bouton Ajouter permet d'ajouter à la liste des Fichiers serveur WkNet le nom de l'application et son chemin d'accès indiqués dans les zones de texte. Le bouton Supprimer permet de supprimer le nom et le chemin d'un fichier et le bouton Modifier de les modifier. Le bouton Rechercher... permet d'ouvrir une boîte de dialogue pour rechercher le fichier serveur WkNet.
DrvTest H:\WIBUKEY\WKNET\WKNET.DAT
RunMe DOS:\TEST\WKNET.DAT
Dans le premier exemple, l'application DrvTest est attachée au fichier serveur WkNet H:\WIBUKEY\WKNET\WKNET.DAT. Dans le deuxième exemple, l'application RunMe est attachée au fichier DOS:\TEST\WKNET.DAT sur serveur Novell.


Icône WibuKey -Paramétrages pour sous-systèmes-

Paramétrages pour sous-systèmes
WibuKey utilise trois sous-systèmes différents :
  • Kernel, l'accès aux clés WibuBox locales,
  • WkLAN, l'accès aux clés WibuBox réseau via le protocole TCP/IP,
  • WkNet, l'accès aux clés WibuBox réseau via un fichier.
La page réseau permet de choisir les sous-systèmes à utiliser et dans quel ordre ces sous-systèmes doivent être recherchés. Pour activer la recherche dans un sous-système, cochez la case placée devant le sous-système choisi. L'ordre de rechercher des sous-systèmes peut être modifié à l'aide des boutons "flêche vers le haut" et "flêche vers le bas".


Icône WibuKey -Contexte-

Page Contexte WibuBox

La page contexte WibuBox permet de sauvegarder le contenu d'une ou de plusieurs clés WibuBox dans un fichier en vue d'une reprogrammation à distance. Le programme utilitaire WKU permet aussi de créer des fichiers de sauvegarde de clés WibuBox.
Par défaut toutes les clés WibuBox qui ont été trouvées localement sont listées à droite dans la zone Clés WibuBox sélectionnées.
Le bouton &ndash;> permet d'ajouter une clé sélectionnée à la liste Clés WibuBox sélectionnées.
Le bouton <&ndash; permet de retirer une clé sélectionnée de la liste Clés WibuBox sélectionnées.

La case Seulement entrées vides permet de ne sauvegarder que les entrées vides des clés sélectionnées. Cette option permet de réduite la taille du fichier.

La zone de texte Nom permet d'indiquer le nom du fichier de sauvegarde. Par défaut, ce fichier sera nommé wibukey.rtc. La case Ajouter au fichier existant permet d'ajouter le contexte des clés sélectionnées à un fichier existant. Le bouton Parcourir... permet de choisir l'emplacement pour enregistrer le fichier.

Le bouton Appliquer permet de démarrer la sauvegarde du contenu des clés sélectionnées. Le contenu des clés sélectionnées est enregistré sous forme cryptée et ne peut être exploité que par l'éditeur du logiciel.
L'applet WibuKey du panneau de configuration ne reconnait pas automatiquement si une ou plusieurs clés ont été déconnectées ou reconnectées. Dans ce cas, il est donc nécessaire d'actualiser la liste des clés WibuBox connectées avec le bouton Lit les ports.


Icône WibuKey -Update-

Page Update WibuBox

La page Update WibuBox permet de lire des fichiers update pour reprogrammer des clés WibuBox.
Par défaut toutes les clés WibuBox qui ont été trouvées localement sont listées à droite dans la zone Clés WibuBox sélectionnées.
Le bouton &ndash;> permet d'ajouter une clé sélectionnée à la liste Clés WibuBox sélectionnées.
Le bouton <&ndash; permet de retirer une clé sélectionnée de la liste Clés WibuBox sélectionnées.
La zone de texte Nom permet d'indiquer le nom du fichier de mise à jour. Le bouton Parcourir... permet de choisir l'emplacement du fichier de mise à jour.
Le bouton Appliquer permet de démarrer la lecture du fichier de mise à jour et la reprogrammation des clés correspondantes. Un message indiquant le nombre de clés mises à jour sera affiché à la fin de la reprogrammation.
Seules les clés WibuBox qui sont enregistrées dans le fichier de programmation à distance peuvent être reprogrammées. Aucune autre clé ne peut être reprogrammées avec ce fichier. Une clé WibuBox avec un fichier de reprogrammation à distance correspondant ne peut être reprogrammée qu'une seule fois avec ce fichier, la répétition de ce processus n'est pas possible.
L'option Supprimer après utilisation permet de supprimer le fichier de programmation à distance après la mise à jour réussie des clés WibuBox.


Icône WibuKey-Configuration-

Page Configuration

Cette page permet de paramétrer la recherche des clés WibuBox et de configurer individuellement la configuration les interfaces du PC. Si tous les pilotes WibuKey ont été installés correctement et que les pilotes ne peuvent accéder à aucune clé WibuBox, vérifiez en premier lieu le paramétrage des interfaces dans cette page.
Il existe six clés WibuBox différentes :
  • la clé WibuBox/P pour les ports parallèles,
  • la clé WibuBox/SP et /ST pour les ports série,
  • la clé WibuBox/U pour les ports USB,
  • la clé WibuBox/M pour les ports PCMCIA,
  • la clé WibuBox/CI pour connecteur PC accessible par l'intermédiaire du port parallèle.
Ce chapitre explique les attributs de configuration pour les différentes variantes de clés WibuBox.
Paramètres généraux
Paramétrages particuliers pour les clés WibuBox/P et /RP
Paramétrages particuliers pour les clés WibuBox/SP et /ST
Paramétrages particuliers pour les clés WibuBox/U et RU
Paramétrages particuliers pour les clés WibuBox/M
Paramétrages particuliers pour les clés WibuBox/CI


Icône WibuKey - Configuration -gen

Configuration
Le paramètre le plus important pour chaque variante de clé WibuBox est l'option Validé qui active l'accès au port correspondant.

Le paramètre Délai si le port est occupé indique la durée maximale en secondes (à la milliseconde) pendant laquelle le pilote WibuKey attend qu'un autre pilote libère le port concerné. Passé ce délai, le pilote met fin à l'accès et indique qu'il n'a pas trouvé de clé WibuBox raccordée.

Si le champ Facteur de délai est rempli, cela ralentit la communication entre les composants matériels. Cette valeur est très rarement nécessaire et ne doit être utilisée que par des utilisateurs confirmés ou après accord du support technique.

La seule autre option qui concerne tous les ports est l'option Temps d'attente WibuBox minimum. Cette option, qui n'apparaît que sous Windows 3.1, commande la vitesse d'accès aux ports de l'ordinateur. Normalement, cette option n'a pas à être utilisée. En cas de problème de communication sous Windows 3.1, il est possible de ralentir l'accès aux ports en indiquant une valeur comprise entre 100 et 30000.


Icône WibuKey -Paramétrages particuliers BOX/P et /RP-

Paramétrages particuliers pour les clés WibuBox/P et /RP
La zone emplacement de la page configuration permet de paramétrer l'adresse des ports d'entrée-sortie (adresse I/O) et sous Windows NT/2000/Serveur 2003, 2008/Vista/7, le type de bus et l'index. En cochant l'option système par défaut, les pilotes WibuKey utilisent les paramètres de configuration du port fourni par le système d'exploitation. Dans certains cas, il peut néanmoins arriver que le système d'exploitation n'arrive pas à reconnaître correctement les interfaces ou pour d'autres raisons retourne une adresse erronnée ou ne retourne aucune adresse. Dans ces cas, il faut indiquer manuellement l'adresse du port dans la zone emplacement. Les adresses typiques sont 0x378 pour LPT1, 0x278 pour LPT2 et 0x3BC pour LPT3. Attention, les adresses utilisées pour LPT1 et LPT2 sont très souvent inversées. La plupart des versions modernes de BIOS affichent les adresses des ports lors du démarrage de l'ordinateur et permettent aussi de les modifier.
Les pilotes WibuKey ne supportent actuellement que le mode parallèle standard et étendu EPP (Enhanced Printer Port). Le mode ECP (Enhanced Capability Port) n'est pas supporté.
La zone paramétrage du port permet, en plus de l'option Validé, de sélectionner les options suivantes :
  • L'option Partagé avec un accès imprimante concurrent permet de gèrer l'accès concurrent de plusieurs applications à un même port parallèle. Normalement, chaque application devrait demander l'autorisation au système d'exploitation pour accéder à un port. Si une autre application utilise déjà ce port, l'accès ne sera pas autorisé. Lorsque le port est déjà occupé par une autre application, le pilote WibuKey attendra que le délai indiqué dans la zone Délai si le port est occupé soit écoulé pour essayer d'accéder à nouveau à ce port. Si après ce délai, l'accès au port n'est toujours pas possible, un message d'erreur sera retourné à l'application. Si l'accès est possible, le pilote WibuKey accèdera au port pendant le temps nécessaire pour communiquer avec la clé WibuBox, puis le libèrera à nouveau après. Il existe malheureusement quelques programmes qui ne respectent pas ces conventions Microsoft. Ces programmes accèdent directement à un port sans plus jamais le libérer. Dans ce cas, pour pouvoir tout de même communiquer avec les clés WibuBox, cochez l'option Partagé avec un accès imprimante concurrent. Le pilote accèdera alors directement au port sans demander préalablement l'autorisation au système d'exploitation. Dans ce cas, des conflits d'accès et des erreurs de transfert sont possibles. Pour cette raison, cette option n'est pas validée par défaut.
  • L'option seulement UD-Mode permet de ne rechercher que les clés en mode uni-directionnel. Dans ce cas seules les clés WibuBox/P ou /RP dont l'attribut de configuration uni-directionnel est sélectionné seront trouvées, les clés configurées en mode bidirectionnel ne seront pas trouvées. Par défaut, cette option de même que l'option seulement BD-Mode n'est pas cochée de telle sorte que le pilote recherche les clés dans les deux modes.
  • L'option seulement BD-Mode permet de ne rechercher que les clés en mode bi-directionnel. Dans ce cas seules les clés WibuBox/P ou /RP dont l'attribut de configuration bi-directionnel est sélectionné seront trouvées, les clés configurées en mode unidirectionnel ne seront pas trouvées. Voir aussi les explications ci-dessus concernant le mode unidirectionnel (UD).


Icône WibuKey -Paramétrages particuliers BOX/SP et /ST-

Paramétrages particuliers pour les clés WibuBox/SP et /ST
La zone emplacement de la page configuration permet de paramétrer l'adresse des ports d'entrée-sortie (adresse I/O) et sous Windows NT/2000, le type de bus et l'index. En cochant l'option système par défaut, les pilotes WibuKey utilisent les paramètres de configuration du port fourni par le système d'exploitation. Dans certains cas, il peut néanmoins arriver que le système d'exploitation n'arrive pas à reconnaître correctement les interfaces ou pour d'autres raisons retourne une adresse erronnée ou ne retourne aucune adresse. Dans ces cas, il faut indiquer manuellement l'adresse du port dans la zone emplacement. Les adresses typiques sont 0x3F8 pour COM1, 0x2F8 pour COM2, 0xE8 pour COM3 et 0xE8 pour COM4. La plupart des versions modernes de BIOS affichent les adresses des ports lors du démarrage de l'ordinateur et permettent aussi de les modifier.

La zone paramétrage du port permet, en plus de l'option Validé, de sélectionner les options suivantes :
  • RTS toujours à l'état haut signifie que le pilote WibuKey fixe toujours la ligne RTS à l'état haut. Normalement, cette option n'est pas validée et elle ne devrait l'être que si le pilote ne trouve pas la clé WibuBox/SP ou /ST sur le port série. Une des raisons peut en être un niveau d'alimentation trop faible. En fixant cette ligne à l'état haut, la clé WibuBox/SP disposera d'une ligne d'alimentation supplémentaire ce qui permettra au pilote de pouvoir y accéder à nouveau.
  • DTR toujours à l'état haut signifie que le pilote WibuKey fixe toujours la ligne DTR à l'état haut. Cette option est identique à l'option précédente RTS toujours à l'état haut Normalement, cette option n'est pas validée.
  • Partagé avec un accès modem/souris concurrent permet de gérer l'accès concurrent de plusieurs applications à un même port série. Normalement, chaque application devrait demander l'autorisation au système d'exploitation pour accéder à un port. Si une autre application utilise déjà ce port, l'accès ne sera pas autorisé. Lorsque le port est déjà occupé par une autre application, le pilote WibuKey attendra que le délai indiqué dans la zone Délai si le port est occupé soit écoulé pour essayer d'accéder à nouveau à ce port. Si après ce délai, l'accès au port n'est toujours pas possible, un message d'erreur sera retourné à l'application. Si l'accès est possible, le pilote WibuKey accèdera au port pendant le temps nécessaire pour communiquer avec la clé WibuBox, puis le libèrera à nouveau après. Il existe malheureusement quelques programmes qui ne respectent pas ces conventions Microsoft. Ces programmes accèdent directement à un port sans plus jamais le libérer. Dans ce cas, pour pouvoir tout de même communiquer avec les clés WibuBox, cochez l'option Partagé avec un accès modem/souris concurrent. Le pilote accèdera alors directement au port sans demander préalablement l'autorisation au système d'exploitation. Dans ce cas, des conflits d'accès et des erreurs de transfert sont possibles. Pour cette raison, cette option n'est pas validée par défaut.
  • Seulement /SP signifie que le pilote ne recherche que les clés WibuBox/SP. Si cette option est validée, les clés WibuBox/ST ne seront pas trouvées. Cette option n'est pas validée par défaut.
  • Seulement /ST signifie que le pilote ne recherche que les clés WibuBox/ST. Si cette option est validée, les clés WibuBox/SP ne seront pas trouvées. Cette option n'est pas validée par défaut.


Icône WibuKey -Paramétrages particuliers BOX/U et /RU-

Paramétrages particuliers pour les clés WibuBox/U et /RU
L'accès à une clé WibuBox/U ou /RU peut être activé ou désactivé sous Windows 95/98/Me et Windows NT/2000/XP/Server 2003, 2008/Vista/7.
Il n'est pas possible d'utiliser une clé WibuBox/U ou /RU sous Windows 95 et Windows NT.


Icône WibuKey -Paramétrages particuliers BOX/M-

Paramétrages particuliers pour les clés WibuBox/M
L'accès à une clé WibuBox/M peut être activé ou désactivé sous Windows 95/98/Me et Windows NT/2000/XP/Serveur 2003.


Icône WibuKey -Paramétrages particuliers BOX/CI-

Paramétrages particuliers pour les clés WibuBox/CI
L'accès à une clé WibuBox/CI est similaire à celui d'une clé WibuBox/P pour PC. L'adresse du port de la carte doit néanmoins être spécifiée manuellement pour l'un des port parallèles, car la clé WibuBox/CI n'est pas reconnue comme une interface parallèle par le BIOS.
La carte supporte 16 adresses, de 0x230 à 0x33C, qui doivent être configurées à l'aide des cavaliers montés sur la carte. L'adresse standard est 0x330H.


Icône WibuKey -Installation-

Page Installation

Cette page permet d'installer, de désinstaller et de vérifier les pilotes WibuKey.

Une description des pilotes nécessaires pour un système d'exploitation donné peut être trouvée dans cette liste. A cet endroit seules les fonctionnalités de la page installation seront expliquées.

Cette liste affiche tous les composants WibuKey nécessaires pour le système d'exploitation utilisé. Lorsqu'un composant est correctement installé, sa case correspondante est cochée et sa version sera affichée. La zone Description, affiche une description succinte du composant sélectionné ainsi que la taille de son fichier. Cette fenêtre affiche aussi la taille mémoire nécessaire pour installer les composants ainsi que la place restante sur le disque. Une case non-cochée indique que le composant correspondant n'est pas installé correctement ou qu'il ne se trouve pas au bon emplacement.
Activer/Désactiver le pilote de noyau WibuKey
Bouton Plug&Play
Installation/Mise à jour des pilotes WibuKey
Suppression des pilotes WibuKey


Icône WibuKey - activer / désactiver le pilote de noyau (kernel driver) WIBU-KEY

Activer/Désactiver le pilote de noyau (kernel driver) WibuKey
Cette boîte de dialogue s'ouvre au moment d'activer le pilote de noyau WibuKey (WIBUKEY.VXD ou WIBUKEY.SYS) dans l'onglet Installation. Elle offre trois possibilités de lancer le pilote de noyau. Pour désactiver le pilote de noyau, la commande s'exécute directement.


Icône WibuKey -Bouton Plug&Play-

Bouton Plug&Play
Ce bouton, invisible sous WindowsNT 4.0, annule le paramétrage Plug&Play de votre clé WibuBox/U ou WibuBox/M. Avant de pouvoir annuler le paramétrage, vous devez déconnecter la clé WibuBox de l'interface. Lors de la prochaine connexion de la clé WibuBox, le mécanisme Plug&Play reconnaîtra automatiquement la clé et installera le pilote WibuBox correspondant.


Icône WibuKey -Installation / Mise à jour des pilotes WIBU-KEY-

Installation / Mise à jour des pilotes WibuKey
Pour installer de nouveaux pilotes ou faire une mise à jour avec les derniers pilotes, cochez les cases correspondantes à ces composants et indiquez le chemin d'accès aux fichiers. Les fichiers source peuvent être compressés avec le programme de compression Compress de Microsoft. Cliquez ensuite sur le bouton Appliquer pour démarrer l'installation. En cas d'erreur, une boîte de dialogue indique les problèmes rencontrés.


Icône WibuKey -Suppression des pilotes WIBU-KEY-

Suppression des pilotes WibuKey
Pour supprimer les pilotes WibuKey installés, décochez les cases correspondantes aux fichiers à supprimer puis cliquer sur le bouton Appliquer. Les fichiers pilote ne peuvent être supprimés que s'ils ne sont utilisés par aucune application (en plus du panneau de configuration).


Icône WibuKey -Diagnostic-

Page Diagnostic

Les pilotes WibuKey peuvent retourner des informations concernant des problèmes d'accès aux clés WibuBox. Ces informations ne sont pas des messages d'erreur courants mais représentent un rapport d'état concernant des processus liés aux pilotes. Normalement le mode diagnostic n'est pas activé et aucun message n'est émis. En cas de problème, vous pouvez activer le mode diagnostic pour consulter les résultats.

Pour activer le mode de diagnostic, cochez la case Actif qui se trouve en bas à gauche de la fenêtre, puis cliquez sur le bouton Nouveau. Toutes les opérations suivantes seront contrôlées et, le cas échéant, les messages d'erreur seront enregistrés. Pour consulter le diagnostic, cliquez sur le bouton Update. Pour sauvegarder les résultats du diagnostic dans un fichier texte, cliquez sur le bouton Sauvegarder... Ce fichier - accompagné d´un fichier de diagnostic MSD - peut ensuite être envoyé à l'éditeur du logiciel ou à WIBU-SYSTEMS.
Ce bouton rapport créé un fichier rapport contenant une information de base concernant les paramètres de configuration de WibuKey et votre environnement système.


Icône WibuKey -Info-

Page Info

Cette page affiche la version de l'applet WibuKey et le mode d'adressage des clés WibuBox. De plus cette page affiche le pilote (noyau) utilisé et éventuellement le COM-Control installé.


Version

L'aide utilisateur WibuKey Version: 6.0, Octobre 2009


WIBU-KEY Le serveur réseau Contenu

WkSv - Le serveur réseau WIBU-KEY

Contenu
Vue d'ensemble
WkSvW32 for Win32
WkSvNW pour Novell
Options de configuration
Comment faire ...
En cas de problème


WIBU-KEY Serveur réseau Vue d'ensemble

Vue d'ensemble

Le serveur réseau WIBU-KEY permet l'accès aux clés WIBU-BOX par le réseau. Ceci permet de protéger une application contre la copie mais aussi de limiter le nombre d'utilisateurs qui peuvent accéder simultanément à l'application. Le serveur réseau WIBU-KEY peut fonctionner sur n'importe quel ordinateur du réseau, il n'est pas nécessaire de le démarrer sur un serveur de réseau. Sous NetWare il est cependant nécessaire de démarrer le serveur réseau WIBU-KEY sur un serveur NetWare.

WIBU-KEY permet de protéger une application réseau suivant deux méthodes : WkNet et WkLAN.

La protection avec WkNet est basée sur des fichiers partagés et permet ainsi d'être utilisée sur pratiquement n'importe quel réseau existant (DOS, Windows, Novell, Macintosh, UNIX). Comme cette méthode ne dépend d'aucun protocole particulier elle peut être employée dans des réseaux hétérogènes composés de différentes plateformes matérielles.

La protection WkLAN est basée directement sur un protocole réseau, c.-à-d. les données sont transférées de façon synchrone sur le réseau entre les postes de travail et le serveur. WkLAN est basé sur TCP/IP. La version courante peut être utilisée sous MacOS et sous toutes les versions Windows supportant le protocole TCP/IP.
Versions de serveurs réseau WIBU-KEY actuellement disponibles :
  • Une application 32 bits pour Windows 95/98/Me et Windows NT/2000/XP, appelée WKSVW32.EXE. Cette application peut aussi s'exécuter comme service NT sous Windows NT/2000/XP
  • Un module pour serveurs NetWare Novell (version 3.11, 3.12 and 4.01), appelé WKSVNW.NLM.
  • Une application pour Mac OS 8/9, appelée WKSVMAC.
  • Une application pour Mac OS X, appelée WkSvMacX.
  • Une application pour Linux, appelée WkSvLin.


WIBU-KEY Serveur réseau WkSvW32 pour Win32

WkSvW32 pour Win32

WKSVW32.EXE, le processus serveur pour Win32, peut être démarré dans deux modes différents:
  • comme une application Windows normale.
  • comme un service Windows.
Sous Windows 95 seuls les deux premiers modes sont disponibles. En cliquant avec le bouton droit de la souris sur l'icône serveur WIBU-KEY apparaît un menu popup permettant de choisir entre le mode fenêtre normale et le mode barre des tâches. Lorsque le serveur WIBU-KEY traite la demande d'un client, celle-ci sera confirmée par un changement d'aspect de l'icône WIBU-KEY.

Après démarage du serveur WIBU-KEY apparaît l'icône du serveur réseau dans la barre des tâches.

Le Menu contextuel (touche droit de la souris) du serveur WIBU-KEY offre les options suivantes:

Quitter | Arrête l'application WIBU-KEY Server.
A propos | Affiche une fenêtre d'information avec la version du serveur WIBU-KEY.
Aide | Ouvre l'aide utilisateur de WIBU-KEY.
Relire la/les clés WIBU-BOX | Relit le contenu de toutes les clés WIBU-BOX connectées. Cette option devrait être exécutée après la mise à jour d'une clé WIBU-BOX ou pour lire une clé qui vient d'être connectée.
Logging | Active la fonction de Logging. Si celle-ci est activée, le statut du serveur WIBU-KEY sera enregistré dans le fichier "WkServer.log" sous [%Programme%\WibuKey\Server] .
Désinstaller le service | Désinstalle le service WIBU-KEY Serveur, si celui-ci est installé.
Arrêter le service | Arrête le service serveur WIBU-KEY, si celui-ci est démarré.
Démarrer comme service | Démarre le serveur WIBU-KEY comme service.
Etat | Ouvre une fenêtre indiquant l'état du serveur WIBU-KEY. Cette fenêtre affiche toutes les requêtes envoyées au serveur WIBU-KEY Serveur et éventuellement les problèmes rencontrés.

Le service Serveur WIBU-KEY peut aussi être contrôlé via la gestion des services du système d'exploitation ou au travers d'une ligne de commande :

La commande net start wksvw32 démarrera le service et

la commande net stop wksvw32 arrêtera le service.
La fenêtre d'état du serveur WIBU-KEY peut être affichée en cliquant avec le bouton droit de la souris sur l'icône du serveur WIBU-KEY. Cette fenêtre affiche toutes les informations importantes concernant l'état du serveur, les demandes client et les messages d'erreur.

Une description détaillée du paramétrage se trouve dans la section Options de configuration. La manière la plus simple pour changer les paramètres de configuration du processus serveur Windows est de passer par la page Serveur de l'applet WIBU-KEY du panneau de configuration.


WIBU-KEY Serveur réseau WkSvNW for Novell

WkSvNW for Novell

Le fichier WKSVNW.NLM doit être copié dans le répertoire SYSTEM du serveur et peut être démarré avec la ligne de commande suivante:

LOAD WKSVNW.NLM WibuKeyIniFile [/L:Logfile] [/V3]

Il utilise le fichier WIBUKEY.INI qui contient des paramètres de configuration additionnels. Ce fichier est un fichier texte et utilise la syntaxe des fichiers INI Windows. Une description détaillée des paramètres de configuration se trouve dans la section Options de configuration. Pour garantir que le module WKSVNW.NLM trouve le fichier WkNet, son chemin d'accès complet est spécifié dans le fichier WIBUKEY.INI. N'oubliez pas que NetWare n'utilise pas de lettres pour désigner les pilotes comme C: ou D: mais des noms de pilote comme SYS: ou DOS:. .
Le module WKSVNW.NLM utilise les paramètres de configuration de la section [DRIVER] du fichier WIBUKEY.INI, compatible avec la WKWIN.DLL.

L'option /V3 valide le mode 'commentaires supplémentaires' qui permet d'afficher des rapports plus détaillés. Utilisez cette option pour obtenir plus d'informations en cas de problèmes. Par défaut cette option n'est pas validée pour éviter l'affichage d'un trop grand nombre de messages sur la console NetWare.

L'option /L enregistre toutes les sorties console dans un fichier log. Ce fichier peut être visualisé sur n'importe quelle station du réseau.

Remarque: le module WKSVNW ne peut pas déterminer dynamiquement les adresses des ports pour accéder aux clés WIBU-KEY. Pour cela le pilote utilise des adresses fixes comme indiquées dans le tableau suivant :
Port: | Adresses par défaut:
LPT1 | 0x3BC
LPT2 | 0x378
LPT3 | 0x278
COM1 | 0x3F8
COM1 | 0x2F8
Les paramètres par défaut peuvent être écrasés par les paramètres de configuration du pilote indiqués dans le fichier WIBUKEY.INI.


WIBU-KEY Serveur réseau Options de configuration

Options de configuration

Les paramètres de configuration seront sauvegardés dans la base de registres. Les configurations importantes peuvent être faites à l'aide du panneau de configuration. Les options de configuration pour le serveur réseau WIBU-KEY peuvent être divisées en cinq sections:
Configuration WkNet
Configuration de la gestion de licences en masse
Configuration du pilote WkSvNW


WIBU-KEY Serveur réseau WkNet Configuration

Configuration de WkNet

Pour la protection WkNet, seules les sections avec un titre de la forme

[WkNet FirmCode:UserCode]

sont utilisées dans lesquelles FirmCode et UserCode indiquent des FirmCode et UserCode valides. L'exemple suivant pour NetWare montre les valeurs par défaut qui sont employées par les fichiers exemple WIBU-KEY :
[WkNet 10:13]
ServerFile=dos:\test\wknet.dat
RefreshTime=10
TimeOut=30
Selection=1234
Cette section contient les entrées suivantes qui sont enregistrées dans le répertoire [NetWork] dans la base de registres.
Mots clés Signification
ServerFile | Indique le chemin complet du fichier serveur WkNet, par exemple: ServerFile=dos:\test\wknet.dat
RefreshTime | Indique l'intervalle de temps (en sec.) entre chaque actualisation du fichier serveur WkNet. Si cette entrée n'est pas spécifiée, un intervalle de temps de 10 sec. est utilisé. Cette valeur dépend du logiciel protégé par WIBU-KEY WkNet.
TimeOut | Indique la valeur du timeout (en min.). Il libère automatiquement un slot alloué dans le fichier WkNet si le processus correspondant n'a pas accédé à ce slot dans le temps imparti. Si cette entrée n'est pas spécifiée, aucun slot ne sera libéré automatiquement.
Selection | Indique le Selection Code utilisé par le logiciel protégé par WIBU-KEY WkNet. Cette valeur doit être spécifiée par le développeur du logiciel. Si cette entrée n'est pas spécifiée, la valeur par défaut est 1234.


WIBU-KEY Serveur réseau Huge License Management Configuration

Configuration de la gestion de licences en masse (Huge License Management)

Un fichier de contrôle HLM est enregistré dans le répertoire [Server] de la base de registres. Pour ce faire on utlise la section [Server HLM files]. Chacune des variables de cette section est énumérée par " FileN ", l'argument est le chemin d'accès du fichier de contrôle HLM. La manière la plus simple pour changer les paramètres de configuration du processus serveur Windows est de passer par la page Serveur de l'applet WIBU-KEY du panneau de configuration.

Les paramètres de configuration HLM ne sont interprétés que si le serveur WIBU-KEY est démarré. Quand les paramètres sont modifiés, le serveur doit être arrêté puis redémarré pour une prise en compte des nouveaux paramètres.


WIBU-KEY Serveur réseau Configuration du pilote

Configuration du pilote

Les options de configuration du pilote ne sont utilisées que par le module WkSvNW, le serveur réseau WIBU-KEY pour NetWare Novell, car cette application utilise un pilote spécifique pour accéder aux clés matérielles WIBU-KEY.

Les valeurs suivantes peuvent être configurées dans la section [Driver] de la base de registres:
Mots clés Signification
WkCom | définit les adresses WIBU-KEY pour COM1 à COM4.
WkLpt | definit les adresses WIBU-KEY pour LPT1 à LPT4.
WkPort | indique le type d'interface WIBU-KEY.


WIBU-KEY Serveur réseau FAQ / Comment ...

Comment ...

1) ... démarrer WkSvW32 comme un service NT?
2) ... déconnecter un client réseau?
3) ... réparer un fichier corrompu WkNet?
4) ... démarrer WkSvNW pour NetWare de Novell?
5) ... configurer un client WkNet/WkLAN?
6) ... configurer un serveur WkNet/WkLAN?

Seitenanfang 1)
Démarrez WkSvW32.exe comme application. Cliquez maintenant avec le bouton droit de la souris sur l'icône dans le Systray et chosissez &ldquo;Démarrer comme Service&ldquo;.

Seitenanfang 2)
Un client WkNet/WkLAN peut être déconnecté avec WkSvMon en sélectionnant cet utilisateur puis en cliquant sur le bouton cancel user ou en cliquant sur l'icône correspondante dans la barre d'outils.

Un client WkNet peut aussi être déconnecté avec l'option /C de l'utilitaire WkNetLst.

Seitenanfang 3)
Il n'y a aucun moyen de réparer un fichier WkNet corrompu. Vous pouvez seulement arrêter le serveur puis recopier le fichier original WkNet sur le disque dur.

Seitenanfang 4)
WkSvNW doit être copié dans le répertoire SYS:\SYSTEM du serveur NetWare. Il peut ensuite être démarré via la console en tapant :

LOAD WKSVNW WibuKeyIniFileSpec

Pour plus d'informations, voir la section WkSvNW.

Seitenanfang 5)
WkNet client

Un client WkNet doit connaître l'emplacement du fichier WkNet. Cette information se trouve dans le fichier WIBUKEY.INI sur le système client dans la section [WkNet clients]. Normalement les paramètres devraient être préparés pendant l'installation de l'application protégée. Néanmoins les paramètres de configuration peuvent être changés dans la page &rdquo;réseau&rdquo; de l'Applet WIBU-KEY du panneau de configuration.
WkLAN client

Normalement les clients WkLAN n'ont pas besoin d'être configurés. Le pilote WIBU-KEY sur le poste client scrutera le réseau local et sélectionnera le premier serveur WkLAN disposant des paramètres appropriés. La page &rdquo;réseau&rdquo; de l'Applet WIBU-KEY permet d'indiquer où rechercher les serveurs WkLAN. Il est ainsi aussi possible de trouver les serveurs WkLAN qui ne résident pas sur le segment réseau local.

Seitenanfang 6)
WkNet server

Pour chaque processus WkNet serveur distinct une section [WkNet FC:UC] doit exister dans le fichier WIBUKEY.INI sur le serveur. La structure de la section et la signification des paramètres sont expliquées dans la section de configuration de WkNet.
WkLAN server

Un serveur WkLAN n'a pas besoin d'être configuré. Par défaut toutes les entrées des clés WIBU-BOX connectées sont disponibles sur le réseau. Les paramètres qui modifient le comportement par défaut du serveur sont listés dans la section configuration WkLAN. La plupart d'entre eux peuvent être modifiés dans la page &rdquo;serveur&rdquo; de l'Applet WIBU-KEY du panneau de configuration.


Serveur de réseau WIBU-KEY - FAQ / En cas de problème

En cas de problème

1) Le serveur WkNet/WkLAN signale une erreur
2) L'utilisateur WkNet ne trouve pas le serveur
3) L'utilisateur WkLAN ne trouve pas le serveur
4) WkSvNW ne fonctionne pas sous Novell SFT3
5) Le serveur WkNet/WkLAN indique : 0 utilisateur autorisé

Vous trouverez dans le lien ci-après les réponses aux questions les plus fréquemment posées par nos clients.
Pour simplifier la recherche, les réponses sont classées par domaine :

Page actuelle de la FAQ (connection Internet nécessaire)
Support

Une équipe professionnelle composée de collaborateurs de haut niveau assiste nos clients et clients finaux dès la première étape.
Le contact direct nous permet de réagir rapidement aux souhaits des utilisateurs.
En tant qu'utilisateur ou développeur vous bénéficierez d'une assistance compétente pour répondre à votre demande. En tant qu'utilisateur final nous vous aiderons volontier en cas de problème. Notre support est accessible de 8.00 à 12.00 et de 13.00 à 17.00 sous le numéro +49-721-93172-15 pour les clients finaux ou tout simplemnt par Email à l'adresse support@wibu.de.
Haut de page 1)
Remarque : Par défaut, WkSvNW n'affiche qu'un nombre réduit de messages. En cas de problème, il est conseillé d'indiquer l'option /V3 au démarrage du processus de serveur. Cette commande active le mode étendu qui affiche un plus grand nombre de messages d'état.
Messages d'erreur possibles
File [nom] not found.
Le fichier WkNet est introuvable.

No access to kernel driver.
Les fichiers de pilotes WIBU-KEY ne sont pas correctement installés.

No access to service manager.
L'accès au gestionnaire de services systèmes ne fonctionne pas. Vous n'avez peut-être pas les droits d'utilisateur nécessaires pour exécuter cette commande.

File encryption sequence cannot be created.
Il est impossible de créer la séquence d'encryptage de fichier nécessaire pour l'accès au fichier WkNet. Le processus de serveur est peut- être dans l'incapacité d'accéder à l'entrée WIBU-BOX nécessaire.

No access to WkLAN: WINSOCK.DLL not found.
Le protocole TCP/IP n'est pas correctement installé sous Windows 3.x.

No access to WkLAN: WSOCK32.DLL not found.
Le protocole TCP/IP n'est pas correctement installé sous Windows 95/Windows NT.

Error: WIBU-BOX entry [FC:UC] not found.
L'entrée WIBU-BOX nécessaire est introuvable. Vérifier que la WIBU-BOX correcte est raccordée à l'ordinateur.

Error: Data for encryption of user [utilisateur] cannot be read.
Il est impossible de lire les informations relatives à un utilisateur donné dans le fichier WkNet. Soit le fichier WkNet tout entier est endommagé, soit des informations inutilisables ont été écrites dans le fichier WkNet à cause d'un problème chez l'utilisateur.

Error: Encryption Firm Code of user [utilisateur] is 0.
L'application utilisateur a transmis un Firm Code invalide.

Error: Global Access to [FC:UC] failed with error [error code].
Le processus de serveur n'est pas en mesure d'accéder à l'entrée indiquée de la WIBU-BOX. Soit la clé WIBU-BOX a été débranchée, soit une autre application accède déjà à l'entrée choisie.

Error: File is no valid WkNet file.
Le fichier WkNet est inutilisable.

Haut de page 2)
Check-liste
  • Vérifiez que le fichier WkNet approprié est bien spécifié dans l'onglet &ldquo;Serveur WkNet&ldquo; de l'Applet WIBU-KEY du Panneau de configuration et que le Firm Code / User Code approprié est bien utilisé?
  • Le serveur WkNet signale-t-il des erreurs (utilisez-vous l'option /V3 sous Novell) ?
  • Le fichier WkNet est-il actualisé dans l'intervalle de temps (timeout) fixé ? Il est possible de le vérifier avec WkSvMon ou WkNetLst. Les deux programmes indiquent le dernier accès du serveur au fichier WkNet.
  • Tous les ordinateurs ont-ils des droits de lecture / écriture sur le fichier WkNet ?
  • Sous Novell : le nombre d'utilisateurs autorisés à accéder simultanément au fichier WkNet ou à l'emplacement du fichier est-il limité ?

Haut de page 3)
Check-liste
  • Le serveur WkLAN signale-t-il des erreurs ?
  • L'icône WIBU-KEY du Panneau de configuration sur l'ordinateur client trouve-t-elle le serveur WkLAN ?
  • Le protocole TCP/IP est-il correctement installé ?
  • La commande PING [adresse IP] fonctionne-t-elle entre l'utilisateur et le serveur (dans les deux sens) ?
  • La commande PING [nom] fonctionne-t-elle entre l'utilisateur et le serveur (dans les deux sens) ?
  • Le serveur WIBU-KEY fonctionne-t-il sur le port approprié ? Vérifiez l'indication dans la fenêtre d'état après le démarrage.
  • Le serveur WIBU-KEY utilise-t-il l'adresse IP appropriée ? Vérifiez l'indication dans la fenêtre d'état après le démarrage et spécifiez éventuellement une adresse IP dans &ldquo;BindAddress&ldquo;.

Haut de page 4)
Problème : si WkSvNW fonctionne lorsque le serveur miroir SFT3 est utilisé, aucun utilisateur WkNet ne peut accéder au fichier WkNet.
Raison : SFT3 reflète en permanence tous les fichiers du serveur. Le fichier WkNet est donc copié en permanence. Tant que le fichier WkNet est copié, aucune autre application ne peut y accéder, ni le serveur WkNet ni les utilisateurs WkNet.
Solution : tous les composants WIBU-KEY (WKSVNW.NLM, WIBUKEY.INI et le fichier WkNet) doivent se trouver dans le dossier SYS:\SYSTEM du serveur Novell. Comme l'accès en écriture est normalement interdit sur ce dossier, il faut changer ce paramètre pour que le fichier WkNet puisse être modifié.

Haut de page 5)
Check-liste
  • Le serveur donne-t-il la liste de toutes les WIBU-BOX raccordées à l'ordinateur ?
  • La section correspondante [WkNet FC:UC] existe-t-elle dans le WIBUKEY.INI du serveur ?
  • L'entrée indique-t-elle le bon fichier WkNet dans la section [WkNet FC:UC] du fichier WIBUKEY.INI serveur ?
  • Les droits de lecture / écriture sur le fichier WkNet sont-ils octroyés ?


- WkSvMon - Le moniteur réseau WibuKey -Contenu-

WkSvMon - Le moniteur réseau WibuKey

Contenu
Vue d'ensemble
Gestion WkLAN
Gestion WkNet
La barre de menu
La barre d'outils
Comment ...
En cas de problème


WkSvMon -Vue d'ensemble-

Vue d'ensemble

WkSvMon
WkSvMon est l'outil principal pour administrer WibuKey dans un environnement réseau. A partir de n'importe quel poste de travail du réseau vous pouvez vérifier le nombre d'utilisateurs accédant actuellement à un serveur WibuKey, à quel moment ils se sont connectés et à quel moment a eu le dernier accès. Vous pouvez déconnecter des utilisateurs et accéder à l'état du processus serveur de réseau et du pilote de noyau qui gère l'accès à la clé WibuBox.
Serveur réseau WibuKey
Le serveur réseau WibuKey permet l'accès aux clés WibuBox via le réseau. Il permet de protéger une application contre la copie mais aussi de limiter le nombre d'utilisateurs qui peuvent accéder simultanément à l'application. Le serveur réseau WibuKey peut fonctionner sur n'importe quel ordinateur du réseau, il n'est pas nécessaire de le démarrer sur un serveur du réseau. Sous NetWare Novell il est cependant nécessaire d'éxécuter le serveur réseau WibuKey sur un serveur NetWare.

WibuKey offre avec WkNet et WkLAN deux méthodes différentes pour protéger une application dans un réseau.

La protection WkNet est basée sur des fichiers partagés et permet ainsi d'être utilisée sur pratiquement n'importe quel réseau existant (DOS, Windows, Novell, Macintosh, UNIX). Comme cette méthode ne dépend d'aucun protocole particulier elle peut être utilisée dans des réseaux hétérogènes composés de différentes plateformes matérielles.

La protection WkLAN est basée directement sur un protocole de réseau, c.-à-d. les données sont transférées de façon synchrone sur le réseau entre les postes de travail et le serveur. WkLAN est basé sur le protocole TCP/IP. La version courante peut être utilisée sous Windows NT, Windows 95, MaOS et Windows pour Workgroups avec l'extension TCP/IP.

Actuellement les versions suivantes de serveurs réseau WibuKey sont disponibles:
  • WKSVW32.EXE, une application 32 bits pour Windows 95/98/Me et Windows NT/2000/XP. Cette application peut aussi être installée comme service sous Windows NT/2000/XP.
  • WKSVNW.NLM, un module pour serveurs NetWare Novell (version 3.11, 3.12 and 4.01).
  • WKSVMAC, une application pour MacOS.


Serveur de réseau WibuKey - la barre de menus

La barre de menus

Menu Fichier

Ouvrir fichier WkNet...

Ouvre une boîte de dialogue permettant de rechercher un fichier WkNet à afficher dans l'arborescence des serveurs.

Fermer fichier WkNet

Efface un fichier WkNet de l'arborescence des serveurs.

Quitter

Quitte WkSvMon.

Menu Vue

Serveur Etat

Affiche la fenêtre d'état du serveur WkLAN sélectionné. Cette option n'est active que si vous avez sélectionné un serveur dans l'arborescence

Statistique

Affiche une liste statistique des accès au serveur WkLAN sélectionné (option momentanément indisponible).

Serveur WkLAN

Active l'affichage des serveurs WkLAN.

Serveur WkNet

Active l'affichage des serveurs WkNet.

Vue serveur

L'arborescence WibuKey affiche : réseau - serveur - client

Vue cluster

L'arborescence WibuKey affiche : réseau - cluster - client - serveur

Vue utilisateur

L'arborescence WibuKey affiche : réseau - client - cluster - serveur

Actualiser

Met à jour l'arborescence des serveurs. Seules les informations relatives aux serveurs déjà enregistrés sont mises à jour. Le système ne recherche pas de nouveaux serveurs dans le réseau.

Parcourir le réseau

Parcourt le réseau local pour rechercher les serveurs WkLAN ou WkNet.

Menu Utilisateur

Supprimer un utilisateur

Supprime un utilisateur WkLAN ou WkNet. Cette option n'est active que si vous avez sélectionné un ou plusieurs utilisateurs dans l'arborescence ou dans la liste.

Supprimer tous les utilisateurs

Supprime tous les utilisateurs du serveur sélectionné / activé. Cette option n'est active que si vous avez sélectionné un serveur ou un cluster dans l'arborescence ou dans la liste.

Menu Options

Paramètres généraux...

Ouvre une fenêtre proposant diverses options de configuration. On peut choisir le mode de démarrage de WkSvMon, si l'actualisation doit être automatique...

Menu ?

Aide de WkSvMon

Ouvre le fichier d'aide en ligne.

A propos...

Affiche les informations de version.


Serveur de réseau WibuKey - la barre d'outils

La barre d'outils

"Actualiser" : met à jour l'arborescence des serveurs. Seules les informations relatives aux serveurs déjà enregistrés sont mises à jour. Le système ne recherche pas de nouveau serveur dans le réseau.
"Parcourir le réseau" : parcourt le réseau local pour rechercher de nouveaux serveurs WkLAN ou WkNet.
"WkLAN" : active l'affichage des serveurs WkLAN.
"WkNet" : active l'affichage des serveurs WkNet.
"Panneau de configuration" : ouvre l'extension WibuKey du panneau de configuration.
"Options" : Ouvre une fenêtre proposant diverses options de configuration. On peut choisir le mode de démarrage de WkSvMon, si l'actualisation doit être automatique...
"Effacer utilisateur" : supprime un utilisateur WkLAN ou WkNet. Ce bouton n'est actif que si vous avez sélectionné un ou plusieurs utilisateurs dans l'arborescence ou dans la liste.
"Effacer tous les utilisateurs" : supprime tous les utilisateurs du serveur sélectionné. Ce bouton n'est actif que si vous avez sélectionné un serveur ou un cluster dans l'arborescence ou dans la liste.
"Statistique" : affiche un résumé statistique de l'utilisation d'un serveur WkLAN sélectionné (option actuellement indisponible).
"Etat du serveur" : affiche la fenêtre d'état du serveur WkLAN sélectionné. Cette option n'est active que si vous avez sélectionné un serveur dans l'arborescence.
"Aide" : ouvre le fichier d'aide en ligne.
"Aide contextuelle" : active le mode d'aide contextuelle. Si vous activez l'aide contextuelle dans le menu de contrôle, une fenêtre d'aide spécifique s'ouvre (s'il existe une aide spécifique pour une option) (aide actuellement indisponible).


WkSvMon - Gérer WkLAN-

Gérer WkLAN

Recherche d'un serveur WkLAN
Afficher les informations concernant un serveur WkLAN
Afficher les informations concernant un cluster WkLAN
Afficher les informations concernant un client WkLAN
Afficher l'état d'un serveur WkLAN
Afficher le statut du pilote de noyau d'un serveur WkLAN
Déconnecter des utilisateur WkLAN


WkSvMon -Recherche d'un serveur WkLAN-

Recherche d'un serveur WkLAN

Pour rechercher un serveur WkLAN sur le réseau, cliquez soit sur le bouton &rdquo;Parcourir le réseau&rdquo; dans la barre d'outils soit sur la commande de menu Affichage/Parcourir le réseau. Le pilote WibuKey affiche ensuite une fenêtre pour confirmer la recherche des serveurs WibuKey disponibles sur le réseau. A la fin de la recherche tous les serveurs WkLAN trouvés sur le réseau sont affichés dans la fenêtre liste des serveurs WibuKey

Un serveur WkLAN par défaut peut être spécifié dans la boîte de dialogue &rdquo;paramètres généraux&rdquo; accessible via le menu &rdquo;Options&rdquo;.

Note: Le pilote WibuKey recherche les serveurs WkLAN en envoyant un broadcast sur le réseau via le protocole TCP/IP. Ce broadcast ne peut être reçu que par les ordinateurs qui se trouvent sur le même segment du réseau. Les ordinateurs qui se trouvent sur un segment différent doivent être spécifiés dans la page &rdquo;Réseau&rdquo; de l'applet WibuKey du panneau de configuration.


WkSvMon -Afficher les informations concernant un serveur WkLAN-

Afficher les informations concernant un serveur WkLAN

Après avoir recherché les serveurs WkLAN disponibles sur le réseau, cliquez dans la rubrique &rdquo;Liste des serveurs WibuKey sur celui dont vous souhaitez obtenir des informations. Dans la rubrique Informations sur le serveur WibuKey seront affichés le nom du serveur, son adresse IP (si disponible), les sous-ensembles actifs et la liste des clusters disponibles.

Un cluster est un segment d'information qui contient un Firm Code et un User Code, le nombre maximum d'utilisateurs qui peuvent accéder au programme via ces codes, le nombre de clients disponibles et le type de sous-ensemble auquel appartient ce cluster.


WkSvMon -Afficher les informations concernant un client WkLAN-

Afficher les informations concernant un client WkLAN

Le moniteur WkSvMon permet d'afficher les informations relatives à un client WkLAN donné. Pour afficher ces informations, cliquez sur la commande de menu Affichage/Affichage utilisateur puis sur la commande de menu Affichage/Parcourir le réseau (ou sur le bouton &rdquo;Parcourir le réseau&rdquo; de la barre d'outils). Dans la rubrique &ldquo;Liste des utilisateurs WIBU-KEY&ldquo; cliquez ensuite sur un utilisateur. Dans la rubrique à droite de la boîte de dialogue seront affichés l&lsquo;ID de l&lsquo;ordinateur client sélectionné, l&lsquo;ID de l&lsquo;application, l&lsquo;ID du cluster, le sous-système utilisé ainsi que la date du premier et du dernier accès au serveur WkLAN.

Note: Les utilisateurs WkLAN sont assignés du haut vers le bas. Si par exemple il y a 200 utilisateurs autorisés, le premier se verra attribuer l'ID 200, le deuxième l'ID 199 et ainsi de suite.


WkSvMon -Afficher l'état d'un serveur WkLAN-

Afficher l'état d'un serveur WkLAN

Le moniteur WkSvMon permet d'afficher l'état d'un serveur WkLAN donné. Pour afficher l'état d'un serveur WkLAN, cliquez sur la commande de menu Affichage/Affichage serveur puis sur la commande de menu Affichage/Parcourir le réseau (ou sur le bouton &ldquo;Parcourir le réseau&ldquo; de la barre d'outils). Dans la rubrique &ldquo;Liste des serveurs WIBU-KEY&ldquo; sélectionnez ensuite un serveur puis cliquez soit sur le bouton &rdquo;Etat&rdquo; situé en bas à droite dans la fenêtre du moniteur, soit sur le bouton &rdquo;Etat du serveur&rdquo; dans la barre d'outils, soit sur la commande de menu Affichage/Etat du serveur...


WkSvMon -Afficher l'état du pilote de noyau d'un serveur WkLAN-

Afficher l'état du pilote de noyau d'un serveur WkLAN

Le moniteur WkSvMon permet d'afficher l'état du pilote de noyau démarré sur un serveur WkLAN donné. Pour afficher l'état du pilote de noyau d'un serveur WkLAN, cliquez sur la commande de menu Affichage/Affichage serveur puis sur la commande de menu Affichage/Parcourir le réseau (ou sur le bouton &rdquo;Parcourir le réseau&rdquo; de la barre d'outils). Dans la rubrique &rdquo;Liste des serveurs WIBU-KEY&rdquo; sélectionnez ensuite un serveur puis cliquez soit sur le bouton &rdquo;Etat&rdquo; situé en bas à droite dans la fenêtre du moniteur, soit sur le bouton &rdquo;Etat du serveur&rdquo; dans la barre d'outils, soit sur la commande de menu AffichageEtat du serveur.... Pour finir cliquez sur l'option &rdquo;Etat du pilote de noyau&rdquo; située en bas à gauche de la boîte dialogue.


WkSvMon -Déconnecter des utilisateurs WkLAN-

Déconnecter des utilisateurs WkLAN

Le moniteur WkSvMon permet de déconnecter soit un utilisateur donné, soit tous les utilisateurs d'un serveur WkLAN donné. Pour déconnecter un utilisateur, cliquez sur la commande de menu Affichage/Affichage utilisateurs puis sur la commande de menu Affichage/Parcourir le réseau (ou sur le bouton &rdquo;Parcourir le réseau&rdquo; de la barre d'outils). Dans la rubrique &rdquo;Liste des utilisateurs WibuKey sélectionnez ensuite un utilisateur puis cliquez sur le bouton &rdquo;Supprimer l'utilisateur&rdquo; en bas de la boîte de dialogue.

Un utilisateur qui a été déconnecté sera supprimé des listes internes du serveur. Lorsque cet utilisateur tentera d'accéder au serveur, le message d'erreur &rdquo;utilisateur déconnecté&rdquo; lui sera retourné.


WkSvMon - Gestion de WkNet -

Gestion de WkNet

Rechercher un serveur WkNet
Informations sur un serveur WkNet
Informations sur un client WkNet
Supprimer des utilisateurs WkNet


WkSvMon - Rechercher un serveur WkNet -

Rechercher un serveur WkNet

Les serveurs WkNet ne sont pas détectés automatiquement par WkSvMon. Il s'agit de fichiers normaux qui doivent être ouverts à l'aide de l'option "Ouvrir fichier WkNet" du menu "Fichier".

Il est possible d'indiquer le nom d'un fichier WkNet à ouvrir par défaut dans la boîte de dialogue "Paramètres généraux".


WkSvMon - Informations sur un serveur WkNet -

Informations sur un serveur WkNet

Les informations affichées sur un serveur WkNet sont similaires aux informations WkLAN. Lorsqu'un utilisateur sélectionne l'icône de serveur, des informations relatives à ce serveur s'affichent à droite dans l'arborescence des serveurs WIBU-KEY. Le nom du serveur (ici le chemin d'accès complet au fichier WkNet), le sous-système actif (en principe WkNet) et l'heure du dernier accès au serveur pour ce fichier WkNet s'affichent.

La liste de contrôle dans la moitié inférieure de la fenêtre affiche une liste des clusters disponibles. Un cluster est un segment d'information qui contient un Firm Code ainsi qu'un User Code, le nombre maximum d'utilisateurs, l'accès possible à ces paramètres, le nombre actuel d'utilisateurs activés et le type de sous-système auquel appartient ce cluster.

Remarque : Actuellement, le fichier WkNet ne contient pas toutes les informations. Par exemple, il n'est pas possible d'afficher simultanément le Firm Code et le User Code qui commandent l'accès à ce fichier WkNet. Dans la liste de contrôle Firm Code et User Code, des valeurs nulles s'affichent.


WkSvMon - Informations sur un client WkNet -

Informations sur un client WkNet

Lorsqu'un utilisateur sélectionne l'icône Client de l'arborescence des serveurs WibuKey, les informations concernant cet utilisateur s'affichent dans la fenêtre de droite. Le nom de l'ordinateur client ainsi que le nom de l'application du client WkLAN (option actuellement indisponible), le type de sous-système et l'ID utilisateur s'affichent. La date de première ouverture de session (login) et la date du dernier accès au serveur WkNet sont également indiquées.

Remarque : Les clients WkLAN qui accèdent à des clusters existants également sous WkNet s'affichent aussi, puisqu'ils occupent un emplacement dans le fichier WkNet. Cependant, aucune information relative au client WkLAN n'est sauvegardée dans le fichier WkNet. Les données d'ID station, d'ID application et d'accès sont uniquement indiquées à titre d'exemple.


WkSvMon - Supprimer des utilisateurs WkNet -

Supprimer des utilisateurs WkNet

Pour supprimer des utilisateurs WkNet, procéder de la même manière que pour des utilisateurs WkLAN : Pour supprimer un seul utilisateur, cliquer sur le bouton "Effacer utilisateur" dans la barre d'outils, sélectionner l'option "Supprimer un utilisateur" dans le menu "Utilisateur" ou cliquer sur le bouton "Supprimer un utilisateur" dans l'onglet Client.

Pour supprimer tous les utilisateurs, cliquer sur le bouton correspondant dans la barre d'outils ou sur l'option adéquate du menu "Utilisateur".

Lorsqu'un utilisateur est supprimé, il est retiré des listes internes du serveur WkLAN. A la prochaine tentative d'accès au serveur par le client, celui-ci reçoit un message d'erreur ("Utilisateur supprimé"). La durée de ce processus (en secondes) est indiquée dans le paramètre Refreshtime. L'application client ne peut pas être informée immédiatement !


WkSvMon - FAQ du moniteur de réseau WibuKey / Comment...

Comment faire pour ...

Voici comment effectuer les tâches les plus fréquentes :
1) ...afficher des informations sur un serveur WkLAN donné ?
2) ...afficher des informations sur un serveur WkNet donné ?
3) ... vérifier qu'un fichier WkNet est correctement actualisé par le serveur WkNet ?
4) ...supprimer un utilisateur ?
5) ...afficher le message d'état d'un serveur WkLAN ?

Haut de page 1)
  • Cliquer sur le bouton "Parcourir le réseau" pour rechercher les serveurs WkLAN.
  • Dans l'arborescence, cliquer sur l'icône portant le nom du serveur WkLAN souhaité.

Haut de page 2)
  • Sélectionner l'option "Ouvrir fichier WkNet" du menu "Fichier" pour ouvrir le fichier WkNet souhaité. Le fichier WkNet s'affiche dans l'arborescence des serveurs WibuKey comme un serveur normal.
  • Cliquer sur l'icône du côté droit pour afficher les informations relatives au serveur.

Haut de page 3)
  • Sélectionner l'option "Ouvrir fichier WkNet" du menu "Fichier" pour ouvrir le fichier WkNet souhaité. Le fichier WkNet s'affiche dans l'arborescence des serveurs WibuKey comme un serveur normal.
  • Cliquer sur l'icône du côté droit pour afficher les informations relatives au serveur.
  • L'heure du dernier accès est actualisée à intervalles fixes. La durée d'un intervalle est définie par le paramètre Refreshtime. Appuyer sur la touche F5 ou cliquer sur le bouton "Actualiser" pour mettre l'affichage à jour si des éléments ont changé. Si rien ne change, soit le fichier WkNet affiché est erroné, soit le processus de serveur ne fonctionne plus correctement.

Haut de page 4)
Il est relativement simple de supprimer un utilisateur. Pour cela, consulter les pages Supprimer des utilisateurs WkLAN ou Supprimer des utilisateurs WkNet.

Haut de page 5)
  • Cliquer sur le bouton "Parcourir le réseau" pour rechercher les serveurs WkLAN.
  • Dans l'arborescence, cliquer sur l'icône portant le nom du serveur WkLAN souhaité.
  • Cliquer sur le bouton "Message d'état" en bas de la fenêtre.


WkSvMon - FAQ du moniteur de réseau WibuKey / En cas de problème

En cas de problème

1) WkSvMon ne détecte pas mon serveur WkLAN
2) WkSvMon ne détecte pas mon serveur WkNet

Vous trouverez dans le lien ci-après les réponses aux questions les plus fréquemment posées par nos clients.
Pour simplifier la recherche, les réponses sont classées par domaine :

Page actuelle de la FAQ (connection Internet nécessaire)
Support

Une équipe professionnelle composée de collaborateurs de haut niveau assiste nos clients et clients finaux dès la première étape.
Le contact direct nous permet de réagir rapidement aux souhaits des utilisateurs.
En tant qu'utilisateur ou développeur vous bénéficierez d'une assistance compétente pour répondre à votre demande. En tant qu'utilisateur final nous vous aiderons volontier en cas de problème. Notre support est accessible de 8.00 à 12.00 et de 13.00 à 17.00 sous le numéro +49-721-93172-15 pour les clients finaux et sous le numéro +49-721-93172-14 pour les autres clients ou tout simplemnt par Email à l'adresse support@wibu.de.
Haut de page 1)
Le pilote WibuKey parcourt le réseau au moyen d'un appel Broadcast TCP/IP. Cet appel n'atteint que les ordinateurs de la section courante de réseau. Les ordinateurs qui se trouvent sur une autre section de réseau (reliée par un routeur) doivent être entrés à l'aide du menu "Réseau" dans l'icône WibuKey du Panneau de configuration.

Haut de page 2)
Les serveurs WkNet ne sont pas détectés automatiquement par WkSvMon. Il s'agit de fichiers normaux qui doivent être ouverts à l'aide de l'option "Ouvrir fichier WkNet" du menu "Fichier".


.topic 0x20A58
Teste le fichier HLM choisi.

.topic 0x20A5E
Réinitialise les fonctions Plug&Play pour les clés WIBU-BOX/(R)U et WIBU-BOX/M sur cet ordinateur.

.topic 0x20A4A
Liste les noms de tous les Clusters disponibles.

.topic 0x20A4B
Cluster-Firm-/User-Code du Cluster sélectionné.

.topic 0x20A4C
Nom du Cluster sélectionné.

.topic 0x20A5C
Ajouter un nouveau Cluster.

.topic 0x20A5D
Supprime le Cluster sélectionné.

.topic 0x20A4E
Modifie des données du Cluster sélectionné.

.topic 0x20A51
Liste des fichiers HLM enregistrés.

.topic 0x20A52
Nom du fichier HLM sélectionné.

.topic 0x20A49
Désactive le serveur WKLAN.

.topic 0x20A48
Timeout du serveur WKLAN.

.topic 0x20A53
Ajouter un nouveau fichier HLM.

.topic 0x20A54
Efface l'entrée HLM sélectionnée.

.topic 0x20A55
Modifie l'entrée HLM sélectionnée.

.topic 0x20A56
Ouvre la boîte de dialog pour sélectionner des fichiers HLM.

.topic 0x207D0
Ceci est la représentation du contenu de la clé WIBU-BOX sélectionnée.
Une clé WIBU-BOX peut contenir jusqu'à 10 entrées. Les clés WIBU-BOX/RU und /RP
n'ont cependant qu'une seule entrée. Dans la partie inférieure de la
représentation est indiqué le numéro de série de la clé WIBU-BOX. A sa doite
se trouve l'affichage des attributs de configuration.

.topic 0x207D4
Ce bouton permet de sélectionner la première clé WIBU-BOX trouvée.

.topic 0x207D5
Ce bouton permet de sélectionner la prochaine clé WIBU-BOX.

.topic 0x207D6
Ce bouton permet de sélectionner la clé WIBU-BOX précédente.

.topic 0x207D7
Ce bouton permet de sélectionner la dernière clé WIBU-BOX trouvée.

.topic 0x207DC
Ce bouton permet d'ouvrir une boîte de dialogue pour rechercher
des fichiers pilote dans un répertoire source.

.topic 0x207DD
Ce bouton permet d'effacer l'entrée WkNet sélectionnée.

.topic 0x20834
Ce champ permet d'indiquer un dossier contenant des pilotes.

.topic 0x20835
Taille mémoire nécessaire pour tous les piloltes installés.

.topic 0x20836
Place mémoire disponible sur le disque dur.

.topic 0x20839
Cette liste indique les fichiers pilotes nécessaires au système d'exploitation
de cet ordinateur. Une case cochée indique que le composant est installé.

.topic 0x2083A
Ce compteur indique le nombre de tests effectués sans erreur.

.topic 0x2083B
Ce bouton permet de transférer la clé WIBU-BOX sélectionnée de la liste des WIBU-BOX dans
la liste des clés à tester.

.topic 0x2083C
Ce bouton permet de supprimer la clé WIBU-BOX de la liste des clés à tester.

.topic 0x208A6
Cet affichage indique la progression du test des clés WIBU-BOX.

.topic 0x208A7
Cette liste contient les clés WIBU-BOX sélectionnées pour cette procédure.

.topic 0x208A8
Ce bouton permet de démarrer le test des clés WIBU-BOX sélectionnées.

.topic 0x208A9
Ce bouton permet d'arrêter le test des clés WIBU-BOX sélectionnés.

.topic 0x208AA
Ce bouton permet de remettre le compteur d'erreur à zéro.

.topic 0x208AC
Lorsque cette option est activée, les dernières informations seront ajoutées dans
un fichier distant contextuel déjà existant.

.topic 0x208AD
Lorsque cette option est activée, seules les informations concernant les entrées vides
seront enregistrées dans le fichier contextuel.

.topic 0x208FD
Cette liste contient les protocols de diagnostic WIBU-KEY.

.topic 0x208FF
Ce bouton permet de lire la liste des WIBU-BOX connectées.

.topic 0x20904
Ce bouton permet d'activer l'enregistrement du diagnostic.

.topic 0x2092E
Ce bouton permet de redémarrer l'enregistrement du diagnostic.

.topic 0x2092F
Ce bouton permet d'enregistrer le protocol de diagnostic.

.topic 0x20930
Ce bouton permet de lire les informations de diagnostic de la mémoire interne du pilote.

.topic 0x20961
Symbole de l'entrée.

.topic 0x20962
Ceci est une paire de Firm-Code/User-Code pour le fichier WkNet correspondant.

.topic 0x20963
L'entrée est une entrée Maître.

.topic 0x20964
L'entrée contient des données utilisateur.

.topic 0x20965
L'entrée est vide.

.topic 0x2096A
Firmcode : chaque éditeur reçoit un Firmcode individuel. Le Firmcode 10 est un code public.

.topic 0x2096B
Usercode (24 bits) : librement définissable entre 0 - 16.777.215, 15.728.640 - 16.777.215 que pour HLM.

.topic 0x2096C
8 bits de poids fort de l'entrée : valeurs 0 - 239, le reste est réservé et ne doit pas être utilisé.

.topic 0x2096D
32 bits de poids faible de l'entrée : valeurs 0 - 1.073.741.823.

.topic 0x20992
Symbole de l'entrée additionnelle.

.topic 0x20994
Ajouter un compteur de limite à l'entré de base.

.topic 0x20995
Ajouter une date d'expiration à l'entrée de base.

.topic 0x20996
Ajouter des données à l'entrée de base.

.topic 0x20997
Pas d'entrée additionnelle à l'entrée de base.

.topic 0x2099C
8 bits de poids fort de l'entrée additionnelle; valeurs à - 239, le reste est réservé et ne doit ps être utilisé.

.topic 0x2099D
32 bits de poids faible de l'entrée additionnelle; valeurs 0 - 1.073.741.824.

.topic 0x2099E
La séquence de programmation pour reprogrammer la clé WIBU-BOX dépend du numéro de série de la clé.

.topic 0x2099F
La séquence de programmation pour reprogrammer la clé WIBU-BOX dépend du compteur de programmation interne de la clé.

.topic 0x209A0
La séquence de programmation pour reprogrammer la clé WIBU-BOX dépend du contenu actuel de la clé.

.topic 0x209A2
Indique combien de fois le compteur de limite peut encore être utilisé.

.topic 0x209A4
Indique le nombre de jours restant jusqu'à la date d'expiration.

.topic 0x209AB
Indique le jour de semaine de la date d'expiration.

.topic 0x209AC
Indique l'année de la date d'expiration.

.topic 0x209AD
Indique le mois de la date d'expiration.

.topic 0x209B0
Indique le jour de la date d'expiration.

.topic 0x209BA
Ce bouton permet d'annuler la dernière modification.

.topic 0x209BB
Ce bouton permet de passer à l'entrée suivante.

.topic 0x209BC
Ce bouton permet de revenir à l'entrée précédente.

.topic 0x209BD
Afficher tous les chiffres en notation hexadécimal.

.topic 0x209C9
Ce bouton permet d'ouvrir la boîte de dialogue des attributs de configuration de la clé WIBU-BOX séléctionnée.

.topic 0x20A2A
Cette liste affiche toutes les interfaces activées pour WIBU-KEY,
les serveurs réseau WIBU-KEY et les clés WIBU-BOX trouvées.

.topic 0x20A42
Ce bouton permet d'activer ou de désactiver le pilote de noyau pour Windows NT/2000/XP/Server 2003.

.topic 0x20802
Cette liste affiche les interfaces sur lesquelles le pilote WIBU-KEY peut rechercher des clés WIBU-BOX.

.topic 0x20804
Si cette option n'est pas cochée, le pilote WIBU-KEY ne recherchera pas de clé WIBU-BOX sur cette interface.

.topic 0x20805
Temps d'attente max. en secondes (résolution en ms) pour le pilote WIBU-KEY
jusqu'à ce qu'un autre pilote libère l'interface utilisée. Passé ce délai, le pilote
n'essayera plus d'accéder à cette interface et la clé WIBU-BOX ne pourra pas être trouvée.

.topic 0x20A64
Pour les ports parallèles (LPT), la recherche peut être limitée ici au mode
bidirectionnel (BD). Pour les ports série (COM), la recherche peut être limitée aux clés
WIBU-BOX/SP. Plus d'information dans l'aide sous paramétrage particulier des clés WIBU-BOX/P
respectivement WIBU-BOX/SP.

.topic 0x20A65
Pour les ports parallèles (LPT), la recherche peut être limitée ici au mode
unidirectionnel (UD). Pour les ports série (COM), la recherche peut être limitée aux clés
WIBU-BOX/ST. Plus d'information dans l'aide sous paramétrage particulier des clés WIBU-BOX/P
respectivement WIBU-BOX/ST.

.topic 0x20A66
Si cette option est cochée, le pilote accèdera à l'interface même si elle est déjà
utilisée par un autre équipement. Il peut en résulter des erreurs de fonctionnement
avec cet équipement de même qu'avec la clé WIBU-BOX. Cette option est cependant importante
et devrait être activée lorsque par ex. un pilote d'imprimante occupe de façon continu
une interface et que le pilote WIBU-KEY ne peut obtenir d'autorisation d'accès.

.topic 0x20A67
Si cette option est activée, la ligne RTS sera activée en permanence. Afin de disposer
d'une alimentation stable, il faudrait au moins que l'une des deux lignes RTS ou DTR soit
activée. Plus d'information dans l'aide sous paramétrage particulier de la clés WIBU-BOX/ST.

.topic 0x20A68
Si cette option est activée, la ligne DTR sera activée en permanence. Afin de disposer
d'une alimentation stable, il faudrait au moins que l'une des deux lignes RTS ou DTR soit
activée. Plus d'information dans l'aide sous paramétrage particulier de la clés WIBU-BOX/ST.

.topic 0x20A6B
Si cette option est activée, le pilote WIBU-KEY utilisera les paramètres du système
(BIOS, Système d'exploitation) pour ce port. Si cette option n'est pas activée, les paramètres
peuvent être indiqués manuellement et explicitement dans la partie inférieure de la boîte de dialogue.

.topic 0x20A6C
Vous pouvez indiquer ici l'adresse de l'interface en notation hexadécimale. Nous vous
recommandons néanmoins d'utiliser une des valeurs de la liste.

.topic 0x20A6D
Sous Windows NT/2000/XP/Server 2003 vous pouez indiquer ici le type de bus de l'interface.
Typiquement ce types sont ISA, EISA, PCI ou Internal.

.topic 0x20815
Ce bouton permet d'ouvrir une boîte de dialogue pour rechercher des fichiers WkNet.

.topic 0x20A6E
Sous Windows NT/2000/XP/Server 2003 vous pouvez indiquer ici le l'index du Bus de l'interface.
Comme le PC n'utilise pas plusieurs systèmes de bus d'un même type il faut indiquer ici la valeur 0.

.topic 0x20816
Ce bouton permet d'ouvrir une boîte de dialogue pour rechercher un fichier contextuel de
programmation à distance.

.topic 0x20817
Ce bouton permet d'ouvrir une boîte de dialogue pour rechercher un fichier de mise à jour de
programmation à distance.

.topic 0x20A74
Chemin vers un fichier de commande WkNet.

.topic 0x20A75
Chemin vers un fichier contextuel de programmation à distance.

.topic 0x20A76
Lorsque cette option est activée, vous pouvez accéder à la clé Firm-Security-Box (FSB)
connectée au serveur WkLAN.

.topic 0x20A77
Chemin vers un fichier de mise à jour pour la programmation à distance.

.topic 0x20A78
Lorsque cette option est activée, vous ne pourrez pas programmer de clés WIBU-BOX connectées
au serveur WkLAN via le réseau.

.topic 0x20A79
Lorsque cette option est activée, le fichier de mise à jour à distance sera automatiquement
supprimé après la mise à jour des clés WIBU-BOX.

.topic 0x20A7B
Cette zone contient les paramètres de configuration du sous-système WkNet.

.topic 0x20A7C
Cette zone contient les paramètres de configuration du sous-système WkLAN.

.topic 0x20A7F
Vous pouvez indiquer ici le temps de rafraichissement pour le fichier WkNet. Les valeurs
utilisables vont de 10 secondes jusqu'à plusieurs heures. Ce temps de fraichissement doit
correspondre à celui utilisé dans l'application ou éventuellement être plus petit.

.topic 0x20A80
Vous pouvez indiquer ici la valeur du Timeout de ce fichier WkNet. Les valeurs du Timeout
dépendent du temps de rafraischissemnt choisi. La valeur du Timeout doit être fixée au moins
au triple et au maximum à 249 fois la valeur du temps de rafraichissement.

.topic 0x20A81
Vous pouvez indiquer ici le Selection-Code pour ce fichier WkNet. Comme cette valeur est
également utilisée par l'application, elle est par conséquent fixée par l'éditeur du logiciel.

.topic 0x20A82
Cette zone contient l'adresse du port WkLAN.

.topic 0x20A86
Ce bouton permet de décaler l'entrée sélectionnée du serveur WkLAN d'une position vers le haut.

.topic 0x20A87
Ce bouton permet de décaler l'entrée sélectionnée du serveur WkLAN d'une position vers le bas.

.topic 0x20A88
Ce bouton permet d'ajouter une entrée de fichier WkNet.

.topic 0x20A89
Ce bouton permet de supprimer l'entrée sélectionnée du fichier WkNet.

.topic 0x20A8A
Ce bouton permet de modifier l'entrée sélectionnée du fichier WkNet.

.topic 0x20A8B
Ce bouton permet d'ouvrir une boîte de dialogue pour rechercher un fichier WkNet.

.topic 0x20A8C
Chemin au fichier WkNet de l'application sélectionnée.

.topic 0x20A8D
Nom de l'application sélectionnée.

.topic 0x20A8E
Cette liste sert à établir le lien entre une aplication et le fichier WkNet correspondant.

.topic 0x20A8F
Cette liste indique le nom ou l'adresse IP sous lequel/laquelle le pilote doit rechercher
des serveurs WkLAN. L'adresse 255.255.255.255 indique que tout le sous-système doit être parcouru
pour rechercher des serveurs WkLAN.

.topic 0x20A90
Dans ce champ sera indiqué le serveur WkLAN sélectionné.

.topic 0x20A91
Ce bouton permet d'ajouter une entrée serveur WKLAN.

.topic 0x20A92
Ce bouton permet d'effacer l'entrée serveur WkLAN sélectionnée.

.topic 0x20A93
Ce bouton permet de modifier l'entrée serveur WkLAN sélectionnée.

.topic 0x20A94
Ce bouton permet de rechercher des serveurs WkLAN.

.topic 0x20A95
Liste des sous-systèmes WIBU-KEY. Une coche indique que le sous-système est activé pour
le pilote. Les sous-systèmes sont parcourus de haut en bas dans l'ordre indiqué.

.topic 0x20A96
Ce bouton décale le sous-système sélectionné d'une position vers le haut.

.topic 0x20A97
Ce bouton décale le sous-système sélectionné d'une position vers le bas.

.topic 0x20A98
Ce bouton permet de fixer l'adresse standard pour le port WkLAN (22347).

.topic 0x20A99
Ce bouton permet de modifier l'entrée sélectionnée du fichier WkNet.

.topic 0x20A9A
Ce bouton permet d'ajouter une entrée de fichier WkNet.

.topic 0x20A9B
Choisi le serveur sélectionné et le transfère dans la liste de recherche.

.topic 0x20A9E
Cette liste indique les serveurs WkLAN trouvés sur le réseau.

.topic 0x20A57
Active le sous-système du serveur WIBU-KEY.

.topic 0x20AB2
Affichage du Delay Factor en cours d'utilisation.
L'affichage "--" spécifie que par défaut aucun Delay Factor n'est utilisé.
Le delay Factor doit être créé dans le Registre et ne devrait être utilisé que sur conseil du support technique.

.topic 0x20AAA
Ce bouton permet d'ouvrir une fenêtre pour générer un fichier de rapport WIBU-SYSTEMS.
Le rapport contient des informations sur les pilotes WIBU-KEY, le statut de l'utilisateur et des informations
sur le système d'exploitation utilisé.

.topic 0x20AC5
Ce champ vous permet de définir si la configuration WkLAN suivante est valable pour l'utilisateur
actuel ou pour tout le PC (cad pour tous les utilisateurs).

.topic 0x20820
Cette liste affiche tous les clients WIBU-KEY avec les autorisations
correspondantes. La configuration standard par défaut "Default" définit que
tous les clients WIBU-KEY du réseau dispose de tous les droits.

.topic 0x20821
Vous pouvez définir ici le nom du DNS ou l'adrese IP du PC client pour
lequel les autorisations spécifiques doivent s'appliquer.

.topic 0x20822
Cette option permet de définir si un client dispose des droits pour rechercher
un serveur WIBU-KEY et afficher les clés WIBU-BOX.

.topic 0x20824
Cette option permet de définir si un client dispose des droits pour utiliser une licence
sur le serveur WIBU-KEY.

.topic 0x20826
Cette option permet de définir si un client dispose des droits de gérer des utilisateurs
réseau sur le serveur WIBU-KEY.

.topic 0x20827
Ajouter une nouvelle autorisation.

.topic 0x20828
Supprimer l'autorisation sélectionnée.

.topic 0x20829
Modifie l'autorisation sélectionnée.


L'aide utilisateur WibuKey

Runtime Kit
WibuBoxes
L'applet WibuKey
Serveur (WkSv32)
Le moniteur réseau (WkSvMon)
FAQ
Version
Bienvenue a l'aide utisateur WibuKey


Imprimantes : paramètres et problèmes

Il faut toujours essayer de désactiver la communication bidirectionnelle entre l'imprimante et le pilote d'impression ainsi que tous les autres moniteurs d'impression, etc. Si cela est impossible, intégrer un nouveau port ou utiliser une autre clé WibuBox (BOX/SP ou BOX/U).
Imprimantes HP
Liste des imprimantes de marque HP testées par WIBU-SYSTEMS.
Imprimante | Système d'exploitation | Remarque
HP LaserJet 5L, 5P | Win95/Win98/WinNT4.0 | fonctionne
HP LaserJet 4L | quelconque | fonctionne uniquement en mode BD
HP LaserJet III D | quelconque | fonctionne uniquement en mode BD
HP LaserJet 1100 | Win95/Win98 | fonctionne
HP LaserJet 6P/MP | Win95/Win98 | fonctionne
HP OfficeJet 635 | quelconque | fonctionne avec des restrictions
HP DeskJet 540, 550C, 560D | quelconque | fonctionne uniquement en mode BD
HP DeskJet 600/660C | Win95 | fonctionne
HP DeskJet 820Cxi | WinNT4.0 SP5/Win98 | fonctionne avec des restrictions
HP DeskJet 880C | Win95 | ne fonctionne pas !
HP DeskJet 895Cxi | WinNT4.0 SP5/Win98 | fonctionne avec des restrictions
HP DeskJet 1200C | Win95 | fonctionne
HP LaserJet 1100 | WinNT4.0 SP5/Win98 | fonctionne

Imprimantes Canon
Liste des imprimantes de marque Canon testées par WIBU-SYSTEMS.
Imprimante | Système d'exploitation | Remarque
Canon LBP-730 | Win95 | problèmes
Canon LBP 4, 4Plus | quelconque | ne fonctionne pas !
HP LCanon BJC 610/620 | quelconque | ne fonctionne pas !

Imprimantes Epson
Liste des imprimantes de marque Epson testées par WIBU-SYSTEMS.
Imprimante | Système d'exploitation | Remarque
EPSON Stylus Pro Color | Novell | ne fonctionne pas !
EPSON EPL 5600 | Win95 | problèmes

Imprimantes Lexmark
Liste des imprimantes de marque Lexmark testées par WIBU-SYSTEMS.
Imprimante | Système d'exploitation | Remarque
Lexmark Optra N | Novell Netware | ne fonctionne pas !
Lexmark Optra SC1275 | Win95 | ne fonctionne pas !

Imprimantes Linotronic
Liste des imprimantes de marque Linotronic testées par WIBU-SYSTEMS.
Imprimante | Système d'exploitation | Remarque
Linotronic 260 | Novell Netware | ne fonctionne pas !

Imprimantes NEC
Liste des imprimantes de marque NEC testées par WIBU-SYSTEMS.
Imprimante | Système d'exploitation | Remarque
NEC Silentwriter S660 | quelconque | fonctionne uniquement en mode BD

Imprimantes Mannesmann
Liste des imprimantes de marque Mannesmann testées par WIBU-SYSTEMS.
Imprimante | Système d'exploitation | Remarque
Mannesmann Tally T9108 | quelconque | ne fonctionne pas !

Descriptions des imprimantes mentionnées ci-dessus, lorsqu'elles existent :
Haut de page HP LaserJet 5L/5P avec WibuBox/P sur port LPT, testée sous Windows 95/ 98/NT4.0
NOTE : L'imprimante HP LaserJet 5L/5P se comporte bien avec la clé WibuBox/P. Toutefois, lors de l'installation du pilote d'imprimante il est nécessaire d'installer le pilote PCL.

Haut de page HP LaserJet 6P/6MP

PROBLEME : Si on installe la boîte à outils (Toolbox) HP LaserJet, l'impression ne fonctionne pas avec la clé WibuBox/P et la WibuBox/P n'est détectée qu'en mode partagé (paramètre "partagé avec un accès imprimante concurrent" dans l'onglet Configuration de WIBUKEY). La boîte à outils LaserJet est une sorte de moniteur d'état qui n'a rien d'indispensable.
Le problème vient du fait que la boîte à outils LaserJet communique en permanence avec l'imprimante pour afficher une fenêtre à l'écran en cas de modification. Entre deux tâches d'impression, le port n'est donc jamais libéré.

SOLUTION sous Windows 95/98 : Il faut complètement désinstaller le pilote d'imprimante et le réinstaller en mode "installation personnalisée". Lors du choix des composants à installer, ne pas sélectionner la boîte à outils (HP LaserJet Toolbox). Rien d'autre ne doit être modifié. Tous les pilotes disponibles, "pilote amélioré", "pilote standard" et "pilote Postscript" fonctionnent sans problème avec la clé WibuBox/P en mode bidirectionnel. Il est alors possible d'imprimer tout en accédant à la WibuBox. La case "accès partagé" ou "shared mode" n'est pas cochée dans l'onglet Configuration/Setup du panneau de configuration WibuKey.
SOLUTION sous Windows NT4.0 : Il est impossible d'imprimer et d'accéder simultanément à la clé sous Windows NT.

Haut de page HP OfficeJet 635 avec WibuBox/P sur LPT, testée sous Windows 95/98
PROBLEME : en cas d'accès à la clé WibuBox, le moniteur d'état HP indique que la liaison avec l'imprimante HP OfficeJet 635 (appareil multifonctions : scanner, imprimante, fax) a été interrompue.
EXTENSION : le même problème s'applique également aux imprimantes HP OfficeJet 600, HP OfficeJet 1150C et HP 3100.
SOLUTION : utiliser un 2e port LPT ou une autre variante de clé WibuBox.
REMARQUE : les accès à la clé WibuBox sans impression simultanée se font sans problème. Au bout de quelques instants, un message d'erreur peut s'afficher dans le moniteur HP en indiquant que la liaison avec l'imprimante a été interrompue. Cliquer sur le bouton "Rétablir la liaison" pour résoudre le problème.
L'imprimante fonctionne (scanner, imprimer, faxer) sans problème avec une WibuBox/P intercalée lorsque celle-ci est en mode BD.
Il est impossible d'imprimer ou de scanner et d'accéder à la WibuBox simultanément. L'accès à la WibuBox fonctionne mais pas l'imprimante. Il faut alors éteindre puis rallumer l'imprimante et rétablir la liaison.

Haut de page HP DeskJet 600/660C avec WibuBox/P sur LPT, testée sous Windows 95
PROBLEME : le pilote d'imprimante fourni par HP surveille en permanence l'état de l'imprimante pendant l'impression. Toute tentative d'utilisation du port parallèle, même pour une courte durée, entraîne un message d'erreur.
SOLUTION : l'interrogation permanente de l'état de l'imprimante n'est pas indispensable. Elle est même impossible si le PC ne dispose pas d'un port parallèle bidirectionnel ou d'un câble correspondant exactement à ce standard. HP a donc installé dans le répertoire système de Windows 95 un programme nommé HPFCFG02.EXE, HPFCFG03.EXE, HPFCFG04.EXE ou HPRCFG01.EXE selon la version du pilote d'imprimante. En démarrant ce programme et en répondant à l'avertissement par "Continuer", on obtient une boîte de dialogue permettant de modifier diverses caractéristiques de l'imprimante. Dans cette boîte de dialogue, décocher la case "communication bidirectionnelle". L'accès à la clé WibuBox doit alors se faire sans problème ou message d'erreur même pendant les impressions.

Haut de page HP DeskJet 820Cxi avec WibuBox/P sur LPT, testée sous Windows 98/NT4.0
NOTE : L'imprimante HP DeskJet 820Cxi se comporte bien avec la clé WibuBox/P, à quelques petites limitations près. Sous Windows 98, il faut renoncer au test de communication de l'imprimante avec le PC, car ce test peut entraîner un conflit interne de sécurité nécessitant le redémarrage de l'ordinateur. Il peut se produire des erreurs en cas d'accès simultané à la clé WibuBox et à l'imprimante. Dans ce cas, cliquer sur le bouton "Ignorer" dans la boîte de dialogue du message d'erreur. L'impression fonctionne toujours correctement.
Sous Windows NT, la clé WibuBox/P fonctionne avec l'imprimante. Cependant, les accès à la WibuBox peuvent ralentir l'impression.
Sous ces deux systèmes d'exploitation, la case "Accès partagé..." du panneau de configuration WibuKey ne doit pas être cochée.

Haut de page HP DeskJet 895Cxi avec WibuBox/P sur LPT, testée sous Windows 98/NT4.0
NOTE : L'imprimante HP DeskJet 895Cxi (testée avec le pilote HP 11.1.4) s'harmonise bien avec la WibuBox/P. Sous Windows 98, il faut éviter l'installation Plug&Play du pilote de l'imprimante et préférer une installation traditionnelle. Il peut se produire des erreurs en cas d'accès simultané à la WibuBox et à l'imprimante ; dans ce cas, il suffit de cliquer sur le bouton "Ignorer" dans la boîte de dialogue du message d'erreur. L'impression fonctionne toujours correctement.
Sous Windows NT, la clé WibuBox/P fonctionne avec l'imprimante.
Sous ces deux systèmes d'exploitation, la case "Accès partagé..." du panneau de configuration WibuKey ne doit pas être cochée.

Haut de page HP LaserJet 1100 avec WibuBox/P sur LPT, testée sous Windows 95/ 98/NT4.0
NOTE : L'imprimante HP LaserJet 1100 se comporte bien avec la WibuBox/P. Sous Windows 98 et Windows NT4.0, la case "Accès partagé..." du panneau de configuration WibuKey doit cependant être cochée.

Haut de page Canon LBP-730 sous Windows 95
PROBLEME : sous Windows 95, l'imprimante Canon LBP-730 (A3, Postscript, 8 pages/min, 600ppp, uniquement commercialisée au Japon) n'est plus détectée si une WibuBox/P(4) se trouve intercalée. Toutefois, avec une WibuBox/P36 ou une ancienne WibuBox/P (numéro de série < 4-345137), ce problème ne doit pas se produire.
CAUSE : le pilote d'imprimante spécial de Canon sous Windows 95.
SOLUTION : utiliser un autre port ou installer un autre pilote d'imprimante.
REMARQUE : sous Windows NT, l'imprimante fonctionne sans problème même avec la WibuBox intercalée.

Haut de page Imprimante EPSON Stylus Pro Color
PROBLEME : Sous Novell Netware, cette imprimante ne fonctionne pas avec le module WkSvNw.NLM, version 2.50.
Ce problème est dû au fait que le pilote d'EPSON n'autorise aucune autre utilisation du port parallèle.
SOLUTION : utiliser une autre carte d'interface ou une autre variante de clé WibuBox.

Haut de page EPSON EPL 5600 sous Windows 95
PROBLEME : Il est impossible d'imprimer une page de test avec cette imprimante sous Windows 95 et les pilotes WibuKey (version testée : 2.40) sans apparition d'un message d'erreur. Il semble que la case "Accès partagé..." ne fasse aucune différence, qu'elle soit cochée ou non.
SOLUTION : utiliser une autre carte d'interface ou une autre variante de clé WibuBox.

Haut de page Imprimante Lexmark Optra N
PROBLEME : Sous Novell Netware, cette imprimante ne fonctionne pas avec le module WkSvNw.NLM, version 2.50.
Ce problème est dû au fait que le pilote Lexmark n'autorise aucune autre utilisation du port parallèle. Il s'agit d'une imprimante spéciale haute performance qui nécessite au minimum un port ECP.
SOLUTION : utiliser une autre carte d'interface ou une autre variante de clé WibuBox.

Haut de page Imprimante Lexmark Optra SC1275
PROBLEME : Sous Windows 95, lorsque cette imprimante est installée, il est impossible de détecter la WibuBox.
Ce problème est dû au fait que le pilote Lexmark n'autorise aucune autre utilisation du port parallèle. L'accès partagé ne change rien.
SOLUTION : utiliser une autre carte d'interface ou une autre variante de clé WibuBox.

Haut de page Imprimante Linotronic 260
PROBLEME : Sous Novell Netware, cette imprimante ne fonctionne pas avec le module WkSvNw.NLM, version 2.50.
Ce problème est dû au fait que le pilote de Linotronic n'autorise aucune autre utilisation du port parallèle.
SOLUTION : utiliser une autre carte d'interface ou une autre variante de clé WibuBox.


WibuKey Programmation à distance via le panneau de configuration WIBU-KEY

Programmation à distance via le panneau de configuration WibuKey

Comme auparavant, il est toujours possible de reprogrammer les clés WibuBox via le panneau de configuration WibuKey :
  • Création d'un fichier contextuel de programmation à distance.
  • Actualisation des clés WibuBox par un fichier update WibuKey.


WibuKey Programmation à distance à l'aide de l'explorateur Windows

Programmation à distance à l'aide de l'explorateur Windows

En cliquant sur le bouton droit de la souris, il est possible de créer un fichier update de programmation à distance dans l'Explorateur de Windows :
  • Pour cela, chercher dans l'explorateur le répertoire dans lequel le fichier à créer doit être sauvegardé, puis cliquer avec le bouton droit de la souris dans la fenêtre d'explorateur de ce répertoire.
  • Dans le menu contextuel qui s'affiche, choisir "Nouveau" puis "WIBU Control File".
  • Dans la boîte de dialogue, choisir "Fichier contextuel de programmation à distance WibuBox" et confirmer en cliquant sur "Créer".

Un fichier MyWibuBox.wbc est créé dans le répertoire ouvert.
Ce fichier doit être envoyé à l'éditeur de logiciels (développeur de logiciel), par exemple par e-mail, sur disquette, etc.
Grâce à ce fichier wbc, l'éditeur de logiciels peut générer un nouveau fichier qui permet de reprogrammer la clé WibuBox. Pour actualiser la WibuBox, il suffit de double-cliquer sur le fichier update de programmation à distance.


Readme_WKSVW

Le serveur de réseau WibuKey

Actuellement, les versions suivantes du serveur de réseau WibuKey sont disponibles :
  • Un module NLM appelé WKSVNW.NLM pour les serveurs des réseaux Novell version 3.11, 3.12 ou 4.01 (pour WkNet).
  • Une application Windows 32 bits appelée WKSVW32.EXE pour un serveur Windows 95 ou Windows NT (WkNet et WkLAN) pouvant également être lancée comme service sous Windows NT.
    WKSVW32.EXE     est disponible en sept langues. Les fichiers de langue possèdent le même nom que le fichier correspondant, avec l'extension Lxx, xx représentant le code de la langue utilisée.
Tous les serveurs lisent les données de configuration du contrôle de réseau dans le fichier WIBUKEY.INI. Ce fichier est enregistré au format texte et utilise la syntaxe des fichiers INI de Windows. Pour configurer les processus de serveur Windows, le plus simple est d'utiliser l'onglet Serveur de l'icône WibuKey. Il suffit d'ouvrir le Panneau de configuration et de double-cliquer sur l'icône WibuKey. Dans l'onglet Serveur, vous trouverez tous les paramètres nécessaires pour les processus de réseau.

Le fichier WIBUKEY.INI peut également être édité manuellement si l'accès est impossible via l'icône WibuKey, par exemple sous Novell. Pour WkLAN, aucun paramétrage supplémentaire n'est normalement nécesaire.


WKU.EXE / WKU32.EXE

WKU32 est l'application de console WibuKey universelle pour les utilisateurs de WibuKey. Le programme existe en deux versions : WKU32.EXE pour DOS et WKU32.EXE pour Win32 (t Windows 95/98/ME/NT/2000/XP/Serveur 2003).

WKU32.EXE peut également être utilisé sous Windows NT et Windows 95 conjointement avec le pilote DOS installé, WKDOS.EXE. C'est un programme idéal pour vérifier si l'accès WibuKey aux programmes DOS s'effectue sans problème. Par contre, WKU32.EXE s'adresse directement au pilote WKWIN32.DLL.

WKU32 englobe de nombreuses possibilités également offertes par l'icône WibuKey du Panneau de configuration. Pour cela, les arguments suivants sont utilisés :
  • Si le programme est lancé sans argument , il donne la liste de tous les ports détectés par WibuKey et le nombre de clés WibuBox raccordées.
  • La commande WKU32 LIST affiche le contenu d'une ou plusieurs clés WibuBox sur un ou plusieurs ports.
  • La commande WKU32 TEST permet d'effectuer un certain nombre de contrôles pour vérifier que la ou les clés WibuBox indiquées fonctionnent correctement (capacité de cryptage).
  • La commande WKU32 DATA permet d'afficher et de modifier les entrées de données User des utilisateurs d'une WibuBox.
  • La commande WKU32 CONFIG modifie les attributs de configuration d'une WibuBox.
  • La commande WKU32 REMOTE permet à l'utilisateur de créer un fichier contenant les informations relatives à une WibuBox pour la programmation à distance. En outre, il peut également reprogrammer les entrées d'une WibuBox à l'aide d'un fichier update de programmation à distance.
  • La commande WKU32 DIAGNOSE permet à l'utilisateur de lire les résultats de diagnostic du pilote DOS résident WKDOS.EXE et de les enregistrer dans un fichier.
  • WKU32 NETWORK sert à rechercher les serveurs WkLAN dans le réseau.
  • Avec WKU32 RESET, l'utilisateur peut réinitialiser le pilote ou libérer des clés WibuBox verrouillées durablement.
  • WKU32 PORTS permet de tester et de définir les adresses physiques données pour les ports LPT1 à LPT4 et COM1 à COM4.
  • WKU32 INSTALL sert à installer le pilote de noyau (kernel driver) WIBUKEY.SYS sous Windows NT.
  • WKU32 DEINSTALL désinstalle le pilote de noyau sous Windows NT.
  • WKU32 START démarre le pilote de noyau sous Windows NT.
  • WKU32 STOP arrête le pilote de noyau sous Windows NT.
  • WKU32 CHECK affiche le numéro de version du pilote de noyau de Windows à l'écran.
Pour plus de détails sur l'utilisation de WKU, consulter l'aide de l'application. Pour afficher des conseils d'ordre général, saisir :

WKU32 /?

Pour obtenir des détails sur les commandes de WKU32, taper l'option d'aide /? après la commande correspondante, par exemple :

WKU32 TEST /?

Les commandes spécifiques de WKU et les noms de ports peuvent être abrégés, à moins que cela rende la commande équivoque. Des abréviations valides sont par exemple :

WKU32 L L1 L2

à la place de

WKU32 LIST LPT1 LPT2

Par contre, un exemple d'abréviation équivoque serait :

WKU32 D

car "D" est l'initiale de DATA ainsi que de DIAGNOSE.
Utilisation de WKU pour la programmation à distance chez le client
WKU peut servir à créer un fichier contextuel de programmation à distance pour une ou plusieurs WibuBox raccordées, grâce à la commande REMOTE GET :
WKU32 REMOTE GET ALL TO X
copie le contenu de toutes les clés WibuBox raccordées dans le fichier X.RTC. Pour réduire la taille de ce fichier, l'utilisateur peut sélectionner les ports ou les clés dont il veut enregistrer le contenu. Pour sélectionner les ports et les clés WibuBox à enregistrer, utiliser les commandes WKU suivantes :
WKU32 REM l1:1 c1 GET ALL TO X.RTC
copie le contenu de la première WibuBox raccordée au port LPT1 et de toutes les WibuBox raccordées au port COM1 dans le fichier X.RTC

Pour réduire encore la taille du fichier contextuel de programmation à distance, indiquer le nombre d'entrées nécessaires. Pour cela, indiquer un ou plusieurs nombres de 1 à 10 à la place du mot clé ALL.
WKU32 REMOTE l1:2 GET 1,5 TO X.RTC
copie uniquement le contenu des entrées 1 et 5 de la deuxième WibuBox raccordée au port LPT1 dans le fichier contextuel de programmation à distance.

Pour ajouter une nouvelle entrée, le programmeur n'aura besoin que d'une liste des entrées vides de la WibuBox. Pour cela, indiquer le mot-clé EMPTY :
WKU32 REMOTE * GET EMPTY TO X.RTC
L'étoile (*) est un joker qui représente toutes les clés WibuBox détectées et possède la même fonction que l'espace entre REMOTE et GET.
Le fichier (par ex. X.RTC) peut désormais être envoyé à l'éditeur de logiciels sous une forme quelconque (disquette, e-mail, par courrier ou fax ou même par téléphone). Le développeur utilisera ce fichier pour effectuer des modifications dans la WibuBox.

Le fabricant de logiciels renvoie le fichier update de programmation à distance à l'utilisateur de la WibuBox. Ce nouveau fichier contient des commandes destinées à modifier le contenu spécifique de la WibuBox à l'aide du fichier contextuel. Pour exécuter les commandes de programmation de la WibuBox, on utilise WKU comme suit :
Pour transmettre un fichier update de programmation à distance à une WibuBox raccordée, utiliser la commande SET de WKU32 :
WKU32 REMOTE SET FROM X.RTU
Recherche sur tous les ports des clés WibuBox possédant le même numéro de série et la même valeur du compteur de programmation que dans le fichier update de programmation à distance. Une liste optionnelle de ports WibuKey ou de clés WibuBox particulières peut limiter le processus de mise à jour aux WibuBox raccordées.
Définition correcte des adresses de ports
La commande PORTS sert à détecter et définir correctement les adresses des ports auxquels plusieurs WibuBox ou autres modules de protection contre la copie d'autres fabricants sont raccordés, et qui ne peuvent pas être reconnues correctement par certaines (rares) variantes de BIOS. Dans ce cas, il est par exemple impossible d'imprimer à partir de ces ports.

La commande WKU PORTS sans argument permet d'indiquer les adresses des ports telles que le BIOS les a déterminées. Si les valeurs indiquées sont identiques après le démarrage (boot) du système avec ou sans WibuBox raccordée, le BIOS a correctement détecté les ports.

Sinon, utiliser la commande WKU PORTS pour détecter les ports ultérieurement et les intégrer dans la RAM BIOS. Ces ports seront ensuite normalement disponibles (par ex. pour imprimer) et peuvent être détectés par les pilotes WibuKey. Cela concerne principalement les ports parallèles (LPT). On peut insérer une telle commande WKU PORTS dans le fichier AUTOEXEC.BAT.

Pour définir des ports, on utilise la syntaxe suivante :

WKU32 PORTS ((LPT|COM) [=(AdresseHex|*|0)[,]...]) ...

Si on indique seulement LPT ou COM sans autre argument, WKU recherche des ports aux adresses qui suivent et, en cas de résultat positif, les insère dans la RAM BIOS :
Port : | Adresse standard :
LPT1 | 0x3BC
LPT2 | 0x378
LPT3 | 0x278
COM1 | 0x3F8
COM1 | 0x2F8
En cas d'utilisation d'un signe d'égalité, WKU PORTS recherche des ports aux adresses indiquées et les insère dans la RAM BIOS. Les adresses doivent être indiquées dans l'ordre LPT1 à LPT4 et COM1 à COM 4. Les adresses sont généralement indiquées en hexadécimal, mais en tant que nombres purs sans préfixe tel que "0X" ni "H" final (voir exemples). Indiquer l'adresse "0" pour désactiver le port correspondant. Si, au lieu d'une adresse, on indique un astérisque (*), l'adresse standard du tableau ci-dessus est utilisée.

L'option /? affiche à l'écran une courte description du programme ainsi que des exemples.

Remarque : WKU32 PORTS fonctionne uniquement sous DOS et dans le fichier AUTOEXEC.BAT de Windows 95. Pour Windows NT ou OS/2, la seule solution existant actuellement pour résoudre les erreurs de détection des ports par le BIOS consiste à raccorder les WibuBox à des ports auxquels aucun périphérique n'est raccordé. En outre, il faut indiquer les adresses des ces ports dans l'environnement.
Installation de pilotes de noyau (kernel driver)
WKU32 permet d'installer le pilote de noyau de Windows NT et de le démarrer ainsi que de le désinstaller. WKU32 est une application de console qui constitue une alternative à l'onglet Installation de l'icône WibuKey dans le panneau de configuration. WKU32 peut installer le pilote sous Windows NT sur d'autres ordinateurs de réseau.

L'installation ou la désinstallation du pilote de noyau pour Windows NT, WIBUKEY.SYS, est réservée aux utilisateurs possédant les droits administratifs nécessaires. Normalement, chaque administrateur ou administrateur de domaine NT possède ces droits. Le gestionnaire d'utilisateurs de NT permet également d'octroyer le droit d'installer et de désinstaller des pilotes de noyaux à des utilisateurs individuels. La description précise de ce droit d'utilisateur est Load and unload device drivers ou SeLoadDriverPrivilege.

Les commandes de pilote de noyau de WKU32 utilisent la syntaxe suivante :

WKU32 INSTALL KERNEL DRIVER [AUTOMATIC|MANUAL]

Cette commande (ré)installe le pilote WIBUKEY.SYS, qui doit se trouver dans le répertoire de pilotes de Windows NT. La commande MANUAL installe le pilote de manière à ce qu'il démarre (manuellement) dès qu'il est appelé par le logiciel WibuKey. Cette variante implique que l'utilisateur qui lance le logiciel WibuKey possède les droits d'utilisateur qui lui permettent d'installer et de démarrer un pilote de noyau Windows NT.

En l'absence de spécification ou avec l'indication AUTOMATIC, le pilote est installé de manière à démarrer (automatiquement) à chaque fois que Windows NT démarre. Cette variante allonge un peu la durée de la phase de démarrage de Windows, mais elle est adaptée aux utilisateurs qui ne possèdent pas le droit d'installer ou de démarrer un pilote de noyau Windows NT.

La commande d'installation peut également être utilisée pour installer WIBUKEY.VXD en tant que pilote VXD statique. Il démarre alors automatiquement à chaque démarrage de Windows 95/98. WKU32 insère WIBUKEY.VXD dans la liste des pilotes statiques enregistrés dans la base de registre.

Après un nouveau démarrage de Windows 95, la ligne "WIBUKEY.VXD statically started" est insérée dans le journal de diagnostic du pilote (si celui-ci est activé) pour indiquer que la méthode de démarrage statique a été choisie. La clé WibuBox/M doit ensuite être détectée immédiatement par toutes les applications.

WKU32 DEINSTALL KERNEL DRIVER

Cette commande est l'inverse de la commande INSTALL. Le pilote de noyau est arrêté et désinstallé. Le fichier WIBUKEY.SYS reste toutefois dans le répertoire de pilotes de NT.

WKU32 START KERNEL DRIVER

Cette commande démarre le pilote de noyau. Normalement, le pilote de noyau démarre automatiquement lors du démarrage du système d'exploitation. Cependant, dans certains cas il peut être intéressant de démarrer le pilote de noyau manuellement.

WKU32 STOP KERNEL DRIVER

Cette commande arrête le pilote de noyau. Si une autre application accède au pilote de noyau, celui-ci ne peut pas être arrêté et un message s'affiche.

WKU32 CHECK KERNEL DRIVER

Cette commande démarre le pilote de noyau, lit son numéro de version et l'affiche à l'écran. Cette commande fonctionne aussi bien pour le pilote de noyau sous Windows NT que sous Windows 95.

AT nom d'ordinateur

La commande AT permet d'appliquer toutes les commandes de pilote de noyau à un autre ordinateur, à l'exception de la commande CHECK. AT doit être indiqué soit avant la commande principale (ex. WKU32 AT nom d'ordinateur STOP KERNEL DRIVER), soit après (ex. WKU32 STOP AT nom d'ordinateur KERNEL DRIVER).

WKU32.EXE n'installe pas le fichier WKWIN32.DLL. Ce fichier doit être copié séparément, dans le répertoire SYSTEM32 sous Windows NT et dans le répertoire SYSTEM sous Windows 95.


Icône WibuKey-Configuration de WkLAN-

Configuration de WkLAN
La case à cocher WKLAN permet d'activer le process serveur WkLAN. Si la case n'est pas cochée, le serveur ne peut accéder au fichier via TCP/IP:
  • Accès à la clé FSB (Firm Security Boxes). En cochant cette case, l'accès aux Firm Codes compris entre 90 et 99 est possible via le réseau. Ces codes sont réservés aux clés FSB nécessaires à la programmation des clés WibuBox. Cette option doit être activée lorsqu'une clé FSB est connectée à sur un serveur WkLAN et que tous les l'utilisateurs du réseau doivent avoir accès à cette clé FSB pour programmer des clés WibuBox.
  • Pas de programmation de WibuBox. En cochant cette option, aucune programmation de clés WibuBox connectée au serveur WkLAN ne pourra être effectuée à partir d'une autre station.
  • La zone Timeout indique le délai maximum en minutes pour accéder à un slot. Tout slot qui n'a pas été accédé par le processus alloué sera retiré de la liste des clients WkLAN Si aucune valeur n'est définie, la valeur par défaut de 1440 (24 heures) est attribuée.
Ces options ne sont valables que pour les serveurs WkLAN.


Icône WibuKey- Bouton rapport -

Rapport
Cette boîte de dialogue permet de sélectionner l'information qui sera enregistrée dans le fichier rapport.


.topic 0x20A92
Ce bouton permet d'effacer l'entrée serveur WkLAN sélectionnée.

.topic 0x20804
Si cette option n'est pas cochée, le pilote WIBU-KEY ne recherchera pas de clé WIBU-BOX sur cette interface.

.topic 0x209C9
Ce bouton permet d'ouvrir la boîte de dialogue des attributs de configuration de la clé WIBU-BOX séléctionnée.

.topic 0x209AB
Indique le jour de semaine de la date d'expiration.

.topic 0x2092F
Ce bouton permet d'enregistrer le protocol de diagnostic.

.topic 0x20826
Cette option permet de définir si un client dispose des droits de gérer des utilisateursréseau sur le serveur WIBU-KEY.

.topic 0x20A9E
Cette liste indique les serveurs WkLAN trouvés sur le réseau.

.topic 0x20A74
Chemin vers un fichier de commande WkNet.

.topic 0x209AD
Indique le mois de la date d'expiration.

.topic 0x2096D
32 bits de poids faible de l'entrée : valeurs 0 - 1.073.741.823.

.topic 0x20965
L'entrée est vide.

.topic 0x2083A
Ce compteur indique le nombre de tests effectués sans erreur.

.topic 0x207D7
Ce bouton permet de sélectionner la dernière clé WIBU-BOX trouvée.

.topic 0x20A57
Active le sous-système du serveur WIBU-KEY.

.topic 0x2099D
32 bits de poids faible de l'entrée additionnelle; valeurs 0 - 1.073.741.824.

.topic 0x20997
Pas d'entrée additionnelle à l'entrée de base.

.topic 0x2096C
8 bits de poids fort de l'entrée : valeurs 0 - 239, le reste est réservé et ne doit pas être utilisé.

.topic 0x20963
L'entrée est une entrée Maître.

.topic 0x2092E
Ce bouton permet de redémarrer l'enregistrement du diagnostic.

.topic 0x207D4
Ce bouton permet de sélectionner la première clé WIBU-BOX trouvée.

.topic 0x20A5E
Réinitialise les fonctions Plug&Play pour les clés WIBU-BOX/(R)U et WIBU-BOX/M sur cet ordinateur.

.topic 0x2099C
8 bits de poids fort de l'entrée additionnelle; valeurs à - 239, le reste est réservé et ne doit ps être utilisé.

.topic 0x20995
Ajouter une date d'expiration à l'entrée de base.

.topic 0x208A9
Ce bouton permet d'arrêter le test des clés WIBU-BOX sélectionnés.

.topic 0x208A8
Ce bouton permet de démarrer le test des clés WIBU-BOX sélectionnées.

.topic 0x207D6
Ce bouton permet de sélectionner la clé WIBU-BOX précédente.

.topic 0x20A5C
Ajouter un nouveau Cluster.

.topic 0x20822
Cette option permet de définir si un client dispose des droits pour rechercherun serveur WIBU-KEY et afficher les clés WIBU-BOX.

.topic 0x20A97
Ce bouton décale le sous-système sélectionné d'une position vers le bas.

.topic 0x20A7C
Cette zone contient les paramètres de configuration du sous-système WkLAN.

.topic 0x20A52
Nom du fichier HLM sélectionné.

.topic 0x20AAA
Ce bouton permet d'ouvrir une fenêtre pour générer un fichier de rapport WIBU-SYSTEMS.Le rapport contient des informations sur les pilotes WIBU-KEY, le statut de l'utilisateur et des informationssur le système d'exploitation utilisé.

.topic 0x20A9A
Ce bouton permet d'ajouter une entrée de fichier WkNet.

.topic 0x20816
Ce bouton permet d'ouvrir une boîte de dialogue pour rechercher un fichier contextuel de programmation à distance.

.topic 0x20A64
Pour les ports parallèles (LPT), la recherche peut être limitée ici au modebidirectionnel (BD). Pour les ports série (COM), la recherche peut être limitée aux clésWIBU-BOX/SP. Plus d'information dans l'aide sous paramétrage particulier des clés WIBU-BOX/Prespectivement WIBU-BOX/SP.

.topic 0x209BB
Ce bouton permet de passer à l'entrée suivante.

.topic 0x209BA
Ce bouton permet d'annuler la dernière modification.

.topic 0x20961
Symbole de l'entrée.

.topic 0x2083C
Ce bouton permet de supprimer la clé WIBU-BOX de la liste des clés à tester.

.topic 0x207D5
Ce bouton permet de sélectionner la prochaine clé WIBU-BOX.

.topic 0x20A4A
Liste les noms de tous les Clusters disponibles.

.topic 0x20AC5
Ce champ vous permet de définir si la configuration WkLAN suivante est valable pour l'utilisateuractuel ou pour tout le PC (cad pour tous les utilisateurs).

.topic 0x20A96
Ce bouton décale le sous-système sélectionné d'une position vers le haut.

.topic 0x20A8F
Cette liste indique le nom ou l'adresse IP sous lequel/laquelle le pilote doit rechercher des serveurs WkLAN. L'adresse 255.255.255.255 indique que tout le sous-système doit être parcourupour rechercher des serveurs WkLAN.

.topic 0x20A78
Lorsque cette option est activée, vous ne pourrez pas programmer de clés WIBU-BOX connectéesau serveur WkLAN via le réseau.

.topic 0x20817
Ce bouton permet d'ouvrir une boîte de dialogue pour rechercher un fichier de mise à jour deprogrammation à distance.

.topic 0x20A65
Pour les ports parallèles (LPT), la recherche peut être limitée ici au modeunidirectionnel (UD). Pour les ports série (COM), la recherche peut être limitée aux clésWIBU-BOX/ST. Plus d'information dans l'aide sous paramétrage particulier des clés WIBU-BOX/Prespectivement WIBU-BOX/ST.

.topic 0x209A0
La séquence de programmation pour reprogrammer la clé WIBU-BOX dépend du contenu actuel de la clé.

.topic 0x20992
Symbole de l'entrée additionnelle.

.topic 0x20836
Place mémoire disponible sur le disque dur.

.topic 0x20834
Ce champ permet d'indiquer un dossier contenant des pilotes.

.topic 0x20A51
Liste des fichiers HLM enregistrés.

.topic 0x20820
Cette liste affiche tous les clients WIBU-KEY avec les autorisationscorrespondantes. La configuration standard par défaut "Default" définit quetous les clients WIBU-KEY du réseau dispose de tous les droits.

.topic 0x20A90
Dans ce champ sera indiqué le serveur WkLAN sélectionné.

.topic 0x20A7F
Vous pouvez indiquer ici le temps de rafraichissement pour le fichier WkNet. Les valeursutilisables vont de 10 secondes jusqu'à plusieurs heures. Ce temps de fraichissement doitcorrespondre à celui utilisé dans l'application ou éventuellement être plus petit.

.topic 0x20A75
Chemin vers un fichier contextuel de programmation à distance.

.topic 0x20A66
Si cette option est cochée, le pilote accèdera à l'interface même si elle est déjàutilisée par un autre équipement. Il peut en résulter des erreurs de fonctionnementavec cet équipement de même qu'avec la clé WIBU-BOX. Cette option est cependant importante    et devrait être activée lorsque par ex. un pilote d'imprimante occupe de façon continu une interface et que le pilote WIBU-KEY ne peut obtenir d'autorisation d'accès.

.topic 0x20802
Cette liste affiche les interfaces sur lesquelles le pilote WIBU-KEY peut rechercher des clés WIBU-BOX.

.topic 0x2099F
La séquence de programmation pour reprogrammer la clé WIBU-BOX dépend du compteur de programmation interne de la clé.

.topic 0x2099E
La séquence de programmation pour reprogrammer la clé WIBU-BOX dépend du numéro de série de la clé.

.topic 0x20A82
Cette zone contient l'adresse du port WkLAN.

.topic 0x20A81
Vous pouvez indiquer ici le Selection-Code pour ce fichier WkNet. Comme cette valeur estégalement utilisée par l'application, elle est par conséquent fixée par l'éditeur du logiciel.

.topic 0x20A7B
Cette zone contient les paramètres de configuration du sous-système WkNet.

.topic 0x20A77
Chemin vers un fichier de mise à jour pour la programmation à distance.

.topic 0x20A67
Si cette option est activée, la ligne RTS sera activée en permanence. Afin de disposerd'une alimentation stable, il faudrait au moins que l'une des deux lignes RTS ou DTR soitactivée. Plus d'information dans l'aide sous paramétrage particulier de la clés WIBU-BOX/ST.

.topic 0x209A4
Indique le nombre de jours restant jusqu'à la date d'expiration.

.topic 0x20904
Ce bouton permet d'activer l'enregistrement du diagnostic.

.topic 0x20821
Vous pouvez définir ici le nom du DNS ou l'adrese IP du PC client pour lequel les autorisations spécifiques doivent s'appliquer.

.topic 0x20A99
Ce bouton permet de modifier l'entrée sélectionnée du fichier WkNet.

.topic 0x20A6C
Vous pouvez indiquer ici l'adresse de l'interface en notation hexadécimale. Nous vousrecommandons néanmoins d'utiliser une des valeurs de la liste.

.topic 0x20A68
Si cette option est activée, la ligne DTR sera activée en permanence. Afin de disposerd'une alimentation stable, il faudrait au moins que l'une des deux lignes RTS ou DTR soitactivée. Plus d'information dans l'aide sous paramétrage particulier de la clés WIBU-BOX/ST.

.topic 0x208A7
Cette liste contient les clés WIBU-BOX sélectionnées pour cette procédure.

.topic 0x20A53
Ajouter un nouveau fichier HLM.

.topic 0x20A98
Ce bouton permet de fixer l'adresse standard pour le port WkLAN (22347).

.topic 0x20A6E
Sous Windows NT/2000/XP/Server 2003 vous pouvez indiquer ici le l'index du Bus de l'interface.Comme le PC n'utilise pas plusieurs systèmes de bus d'un même type il faut indiquer ici la valeur 0.

.topic 0x208AD
Lorsque cette option est activée, seules les informations concernant les entrées videsseront enregistrées dans le fichier contextuel.

.topic 0x2083B
Ce bouton permet de transférer la clé WIBU-BOX sélectionnée de la liste des WIBU-BOX dansla liste des clés à tester.

.topic 0x20835
Taille mémoire nécessaire pour tous les piloltes installés.

.topic 0x207DC
Ce bouton permet d'ouvrir une boîte de dialogue pour rechercher des fichiers pilote dans un répertoire source.

.topic 0x20A55
Modifie l'entrée HLM sélectionnée.

.topic 0x20AB2
Affichage du Delay Factor en cours d'utilisation.  L'affichage "--" spécifie que par défaut aucun Delay Factor n'est utilisé.Le delay Factor doit être créé dans le Registre et ne devrait être utilisé que sur conseil du support technique.

.topic 0x20A95
Liste des sous-systèmes WIBU-KEY. Une coche indique que le sous-système est activé pourle pilote. Les sous-systèmes sont parcourus de haut en bas dans l'ordre indiqué.

.topic 0x20A91
Ce bouton permet d'ajouter une entrée serveur WKLAN.

.topic 0x20A80
Vous pouvez indiquer ici la valeur du Timeout de ce fichier WkNet. Les valeurs du Timeoutdépendent du temps de rafraischissemnt choisi. La valeur du Timeout doit être fixée au moinsau triple et au maximum à 249 fois la valeur du temps de rafraichissement.

.topic 0x20A6D
Sous Windows NT/2000/XP/Server 2003 vous pouez indiquer ici le type de bus de l'interface.Typiquement ce types sont ISA, EISA, PCI ou Internal.

.topic 0x20805
Temps d'attente max. en secondes (résolution en ms) pour le pilote WIBU-KEYjusqu'à ce qu'un autre pilote libère l'interface utilisée. Passé ce délai, le pilote n'essayera plus d'accéder à cette interface et la clé WIBU-BOX ne pourra pas être trouvée.

.topic 0x209A2
Indique combien de fois le compteur de limite peut encore être utilisé.

.topic 0x20930
Ce bouton permet de lire les informations de diagnostic de la mémoire interne du pilote.

.topic 0x208AC
Lorsque cette option est activée, les dernières informations seront ajoutées dansun fichier distant contextuel déjà existant.

.topic 0x20A56
Ouvre la boîte de dialog pour sélectionner des fichiers HLM.

.topic 0x20A4E
Modifie des données du Cluster sélectionné.

.topic 0x20A58
Teste le fichier HLM choisi.

.topic 0x20829
Modifie l'autorisation sélectionnée.

.topic 0x20A8A
Ce bouton permet de modifier l'entrée sélectionnée du fichier WkNet.

.topic 0x20A87
Ce bouton permet de décaler l'entrée sélectionnée du serveur WkLAN d'une position vers le bas.

.topic 0x20A79
Lorsque cette option est activée, le fichier de mise à jour à distance sera automatiquementsupprimé après la mise à jour des clés WIBU-BOX.

.topic 0x2096A
Firmcode : chaque éditeur reçoit un Firmcode individuel. Le Firmcode 10 est un code public.

.topic 0x20A4C
Nom du Cluster sélectionné.

.topic 0x20827
Ajouter une nouvelle autorisation.

.topic 0x20A9B
Choisi le serveur sélectionné et le transfère dans la liste de recherche.

.topic 0x20A93
Ce bouton permet de modifier l'entrée serveur WkLAN sélectionnée.

.topic 0x20A8C
Chemin au fichier WkNet de l'application sélectionnée.

.topic 0x20A8B
Ce bouton permet d'ouvrir une boîte de dialogue pour rechercher un fichier WkNet.

.topic 0x20815
Ce bouton permet d'ouvrir une boîte de dialogue pour rechercher des fichiers WkNet.

.topic 0x209BD
Afficher tous les chiffres en notation hexadécimal.

.topic 0x209BC
Ce bouton permet de revenir à l'entrée précédente.

.topic 0x20996
Ajouter des données à l'entrée de base.

.topic 0x207DD
Ce bouton permet d'effacer l'entrée WkNet sélectionnée.

.topic 0x20A48
Timeout du serveur WKLAN.

.topic 0x20A94
Ce bouton permet de rechercher des serveurs WkLAN.

.topic 0x20A8D
Nom de l'application sélectionnée.

.topic 0x20A88
Ce bouton permet d'ajouter une entrée de fichier WkNet.

.topic 0x20A86
Ce bouton permet de décaler l'entrée sélectionnée du serveur WkLAN d'une position vers le haut.

.topic 0x20A42
Ce bouton permet d'activer ou de désactiver le pilote de noyau pour Windows NT/2000/XP/Server 2003.

.topic 0x2096B
Usercode (24 bits) : librement définissable entre 0 - 16.777.215, 15.728.640 - 16.777.215 que pour HLM.

.topic 0x20964
L'entrée contient des données utilisateur.

.topic 0x20962
Ceci est une paire de Firm-Code/User-Code pour le fichier WkNet correspondant.

.topic 0x208AA
Ce bouton permet de remettre le compteur d'erreur à zéro.

.topic 0x20839
Cette liste indique les fichiers pilotes nécessaires au système d'exploitationde cet ordinateur. Une case cochée indique que le composant est installé.

.topic 0x20A54
Efface l'entrée HLM sélectionnée.

.topic 0x20824
Cette option permet de définir si un client dispose des droits pour utiliser une licencesur le serveur WIBU-KEY.

.topic 0x20A8E
Cette liste sert à établir le lien entre une aplication et le fichier WkNet correspondant.

.topic 0x20A6B
Si cette option est activée, le pilote WIBU-KEY utilisera les paramètres du système(BIOS, Système d'exploitation) pour ce port. Si cette option n'est pas activée, les paramètrespeuvent être indiqués manuellement et explicitement dans la partie inférieure de la boîte de dialogue.

.topic 0x209B0
Indique le jour de la date d'expiration.

.topic 0x209AC
Indique l'année de la date d'expiration.

.topic 0x208FF
Ce bouton permet de lire la liste des WIBU-BOX connectées.

.topic 0x207D0
Ceci est la représentation du contenu de la clé WIBU-BOX sélectionnée.Une clé WIBU-BOX peut contenir jusqu'à 10 entrées. Les clés WIBU-BOX/RU und /RPn'ont cependant qu'une seule entrée. Dans la partie inférieure de lareprésentation est indiqué le numéro de série de la clé WIBU-BOX. A sa doitese trouve l'affichage des attributs de configuration.

.topic 0x20A49
Désactive le serveur WKLAN.

.topic 0x20A5D
Supprime le Cluster sélectionné.

.topic 0x20828
Supprimer l'autorisation sélectionnée.

.topic 0x20A89
Ce bouton permet de supprimer l'entrée sélectionnée du fichier WkNet.

.topic 0x20A76
Lorsque cette option est activée, vous pouvez accéder à la clé Firm-Security-Box (FSB)connectée au serveur WkLAN.

.topic 0x20A2A
Cette liste affiche toutes les interfaces activées pour WIBU-KEY, les serveurs réseau WIBU-KEY et les clés WIBU-BOX trouvées.

.topic 0x20994
Ajouter un compteur de limite à l'entré de base.

.topic 0x208FD
Cette liste contient les protocols de diagnostic WIBU-KEY.

.topic 0x208A6
Cet affichage indique la progression du test des clés WIBU-BOX.

.topic 0x20A4B
Cluster-Firm-/User-Code du Cluster sélectionné.


WkSvMon -Afficher les informations concernant un cluster WkLAN-

Afficher les informations concernant un cluster WkLAN

Le moniteur WkSvMon permet d'afficher les informations relatives à un cluster donné. Pour afficher ces informations, cliquez sur la commande de menu Affichage/Affichage cluster puis sur la commande de menu Affichage/Parcourir le réseau (ou sur le bouton &rdquo;Parcourir le réseau&rdquo; de la barre d'outils). Dans la rubrique &rdquo;Liste des clusters WibuKey&rdquo; cliquez ensuite sur un cluster. Dans la rubrique à droite de la boîte de dialogue seront affichés l'ID du cluster sélectionné, le Firm Code et le User Code, le sous-système utilisé ainsi que le nombre maximum d'utilisateurs et le nombre de slots disponibles.

Note: Un cluster peut être réparti sur plusieurs serveurs WkLAN. En cliquant sur l'icône &rdquo;Réseau&rdquo; dans la rubrique &rdquo;Liste des clusters WibuKey, tous les clusters de tout le réseau sont affichés en bas à droite dans la rubrique &rdquo;Informations réseau&rdquo;.


Moniteur de serveur WibuKey - version -

Version actuelle du moniteur de serveur WibuKey: 6.0


WIBU-KEY Serveur Accès distant

Accès distant

Les droits d'accès au serveur WIBU-KEY peuvent être définis dans le répertoire [RemoteAccess] de la Base de Registre. Les entrées sont "<adresse IP des clients >";=(DWORD)<Droits d'accès>, où <Droits d'accès> signifie:
Mots clés Signification
1 | Lire le contenu.
2 | Lire le contenu (détails) (pas encore implémenté).
4 | Utiliser une licence.
8 | Effacer un utilisateur.
16 | Effacer tous les utilisateurs (pas encore implémenté).
Des combinaisons sont possibles, par ex. 7 = autoriser la lecture du contenu et utiliser une licence, interdire la suppression d'un utilisateur. L'entrée "Default" =31 définie les droits des utilisateur qui ne sont pas définis explicitement. Ces droits peuvent aussi être limités. Toutes ces actions sont autorisées par défaut pour des raisons de compatibilité.


WIBU-KEY Serveur réseau Server Configuration

Configuration du serveur

Les paramètres de configuration de base des serveurs réseau WIBU-KEY sont stockés dans la section [Server] du fichier WIBUKEY.INI. Les valeurs suivantes peuvent être spécifiées :
Mots clés Signification
BindAddress | définit l'adresse IP à laquelle le serveur WIBU-KEY est attaché.
WkLAN | Autorise (1) ou interdit (0) la fonctionnalité WkLAN.
WkNet | Autorise (1) ou interdit (0) la fonctionnalité WkNet.
Logging | active (1) ou désactive (0) l'enregistrement de toutes les actions dans un fichier.
LoggingPath | définit le chemin du fichier LOG.


WIBU-KEY Serveur réseau WkLAN Configuration

Configuration de WkLAN

Les paramètres de configuration du serveur WkLAN sont enregistrés dans les répertoires [WkLAN] et [WkLAN Server] de la base de registres.

Les valeurs suivantes peuvent être spécifiées dans la section [WkLAN] :
Mots clés Signification
IpPort Specifie le numéro du port TCP à utiliser pour la communication WkLAN. La gestion WkLAN utilise par défaut le numéro de port 22347 pour accéder à un serveur WkLAN. Si ce numéro est déjà utilisé par un autre serveur TCP, il peut être changé ici. Ce changement doit aussi être effectué pour tous les clients sinon aucune communication entre application et serveur ne sera possible.
Les valeurs suivantes peuvent être spécifiées dans la section [WkLAN Server]:
Mots clés Signification
AccessFsb | Si cette option est validée (1), il est possible d'accéder via le réseau aux Firm Codes compris entre 90 et 99. Cette série de nombres est réservée pour les clés de programmation appelées Firm Security Boxes (FSB). Cette option doit être activée lorsqu'une clé de programmation Firm Security Box est connectée à un serveur WkLAN server et que tous les utilisateurs doivent avoir accès à cette clé de programmation via le réseau pour programmer des clés WIBU-BOX.
NoBoxPgm | doit être validé (1) pour empêcher la reprogrammation de clés WIBU-BOX connectées à un serveur WkLAN à partir d'autres stations de travail.
Timeout | spécifie la valeur du timeout en minutes. Il libère automatiquement un slot alloué dans la liste des clients WkLAN si le processus d'allocation n'a pas accéder à son slot dans le temps imparti. Si cette valeur n'est pas spécifiée, la valeur 1440 (24 heures) est utilisée par défaut.