Einführung

Einführung

PCAN Status Display ist eine Statusanzeige, mit deren Hilfe man statistische Informationen über momentan aktive Clients abfragen, sowie deren verwendete Netze und Hardware untersuchen kann.

Über die Registerkarten unterhalb der Symbolleiste kann der installierte Treiber bzw. Gerätetyp ausgewählt werden, dessen aktive Elemente untersucht werden sollen. Je nachdem, welche Treiber installiert worden sind, erscheinen die Registerkarten Virtuell, PCI, USB, PC Card, ISA, Dongle oder Peakcan.

Verwendung dieser Online-Hilfe

Ein Hilfe-Fenster wird anzeigt, wenn Sie die Schaltfläche Hilfe in einem Dialogfenster anklicken, und die kontextbezogene Hilfe erscheint für das jeweilige Dialogfenster. In jedem Fenster von PCAN Status Display können Sie auch F1 auf der Tastatur drücken, um ein Hilfethema für das Fenster oder die aktuelle Registerseite anzuzeigen.

Sie können auch die Registerseiten Inhalt und Suchen auf der linken Seite des Hilfe-Fensters verwenden, um ein spezielles Hilfethema zu finden. Wenn Sie eine Suche durchführen, werden die Ergebnisse nach dem Titel der Themen sortiert angezeigt.

Siehe auch

  • Referenz zur Benutzeroberfläche

  • PCAN-System Grundlagen

  • Kontakt-Information / Copyright

Feedback senden | Copyright © 2022 PEAK-System Technik GmbH. Alle Rechte vorbehalten.


PCAN-System Grundlagen

PCAN steht für PEAK CAN APPLICATIONS und ist ein flexibles System zur Planung, Entwicklung und Benutzung von CAN-Netzen. Es ist sowohl für den Entwickler als auch für den Endbenutzer ein hilfreiches und mächtiges Produkt.

Basis für die Kommunikation zwischen PCs und externer Hardware über CAN sind eine Reihe von Windows Kernel Mode Gerätetreiber, z.B. PCAN_USB.SYS, PCAN_PCI.SYS, PCAN_xxx.SYS. Diese Treiber bilden den Kern einer kompletten CAN-Umgebung auf einem PC mit Windows als Betriebssystem, und arbeiten als Schnittstellen zwischen CAN-Software und PC-basierter CAN-Hardware. Die Treiber verwalten den ganzen Datenverkehr jedes an den PC angeschlossenen CAN-Geräts.

Benutzern oder Administratoren einer CAN-Installation wird der Zugriff auf das Netzwerk mittels PCAN-Client-Programmen ermöglicht (kurz: Client). Mit ihrer Hilfe können Prozessgrößen visualisiert und beeinflusst werden. Die Treiber ermöglichen die Verbindung von mehreren Clients zur selben Zeit.

Weiterhin werden von einem PCAN-Treiber mehrere Hardware-Komponenten unterstützt, die auf dem CAN-Controller SJA1000 basieren. So genannte Netze stellen die logische Struktur für CAN-Busse zur Verfügung, die virtuell in den PC hinein verlängert sind. Auf der Hardware-Seite können ebenfalls mehrere Clients verbunden sein. Die folgende Grafik zeigt die verschiedenen Möglichkeiten von Netzkonfigurationen (die auch alle zur selben Zeit realisiert werde können):

Merkmale des PCAN-Systems:

  • Ein Client kann an mehrere Netze angeschlossen sein

  • Ein Netz versorgt mehrere Clients

  • Eine Hardware gehört zu maximal einem Netz

  • Einem Netz ist keine oder genau eine Hardware zugeordnet

  • Sendet ein Client, wird die Botschaft an alle anderen verbundenen Clients weitergegeben, und über eine verbundene CAN-Hardware auf den externen CAN-Bus

  • Wird eine Botschaft über die CAN-Hardware empfangen, wird sie an alle verbundenen Clients weitergegeben. Jeder Client empfängt aber nur die Botschaften, die seinen Akzeptanzfilter passieren.

  • Jeder Client hat eine Sende-Queue, in der zu sendende CAN-Botschaften bis zu ihrem Sendezeitpunkt warten. Beim Erreichen des Sendezeitpunktes werden sie in die Sende-Queue der PCAN-Hardware geschrieben.

  • Jeder Client hat eine Empfangs-Queue, die empfangene Botschaften puffert.

  • Jede Hardware hat eine Sende-Queue, um zu sendende CAN-Botschaften zu puffern.

Feedback senden | Copyright © 2022 PEAK-System Technik GmbH. Alle Rechte vorbehalten.


Kontakt-Information / Copyright

PCAN Status Display ist ein Produkt von:

PEAK-System Technik GmbH

Otto-Röhm-Strasse 69
64293 Darmstadt
Deutschland

Info: | info@peak-system.com
Support: | support@peak-system.com
Web: | www.peak-system.com

Copyright © 2022 PEAK-System Technik GmbH. Alle Rechte vorbehalten.

Windows® ist ein eingetragenes Warenzeichen von Microsoft in den Vereinigten Staten von Amerika und anderen Ländern. Alle in dieser Dokumentation erwähnten anderen Produktnamen können Warenzeichen oder registrierte Warenzeichen ihrer entsprechenden Hersteller sein. Weiterhin werden "™" und "®" nicht in jedem Fall in dieser Dokumentation angegeben.

Kein Teil dieses Hilfetextes darf in irgendeiner Form ohne schriftliche Genehmigung der Firma PEAK-System Technik GmbH unter Einsatz entsprechender Systeme reproduziert, verarbeitet, vervielfältigt oder verbreitet werden.

Letzte Aktualisierung: 08.02.2022

Feedback senden | Copyright © 2022 PEAK-System Technik GmbH. Alle Rechte vorbehalten.


Benutzeroberfläche

Benutzeroberfläche

Das Fenster von PCAN Status Display enthält die folgenden Bereiche, von oben nach unten:

  • Symbolleiste - Die Symbolleiste erlaubt einen schnellen Zugriff auf die am häufigsten verwendeten Befehle.

  • Registerkarten - Mit den Registerkarten können Sie den installierten Treiber bzw. Gerätetyp auswählen, dessen aktive Elemente Sie anzeigen möchten.

  • Verbindungsdiagramm - Zeigt eine grafische Darstellung der aktiven Elemente und deren Verknüpfungen an. In Abhängigkeit des gewählten Anzeigemodus werden in den grafischen Elementen entsprechende Informationen angezeigt.

Folgende Elemente können dargestellt werden:

Element | Symbol | Beschreibung
Client |  | Ein Client ist ein Programm, das sich beim PCAN-System registriert hat.
Netz |  | Ein Netz dient einem oder mehreren Clients zum Transport von CAN-Botschaften von und zur Hardware und auch von und zu anderen Clients.
Hardware |  | Eine Hardware ist mit einem Netz verbunden.

  • Statuszeile - Enthält eine Zusammenfassung aller sichtbaren Elemente.

Client

Ein Client-Block zeigt immer den Namen des Clients an, unter dem sich ein Programm beim PCAN-System registriert hat. Weiterhin wird in runden Klammern das interne Handle des Clients angezeigt, was für Software Entwickler von Bedeutung ist. Je nach Anzeigemodus wird zusätzlich folgende Information dargestellt:

RcvQueue

Zeigt den Füllstand der Empfangswarteschlange an, die vom PCAN-System für diesen Client verwaltet wird.

XmtQueue

Zeigt den Füllstand der Sendewarteschlange an, die vom PCAN-System für diesen Client verwaltet wird.

RcvMsg/s

Die aktuelle Anzahl der vom Client empfangenen Botschaften pro Sekunde.

XmtMsg/s

Die aktuelle Anzahl der vom Client gesendeten Botschaften pro Sekunde.

RcvBit/s

Die aktuelle Anzahl empfangener Bits pro Sekunde.

XmtBit/s

Die aktuelle Anzahl gesendeter Bits pro Sekunde.

AccCode, AccMask

Die Werte des Akzeptanzfilters, der für den Client vom PCAN-System simuliert wird.

Client-Handle

Der Wert des treiberinternen Handles des Clients (1-64).

Hinweis

Alle angezeigten Werte beziehen sich immer auf die Summe aller Netzverbindungen eines Clients. Ist ein Client mit mehreren Netzen gleichzeitig verbunden, enthält jeder dargestellte Client-Block dieses Clients identische Angaben zu den einzelnen Werten.

Netz

Ein Netz-Block zeigt immer den Namen des Netzes an. Dahinter erscheinen je nach Anzeigemodus weitere Werte.

Bitrate

Zeigt die für das Netz definierte Bitrate an. Diese stellt nicht unbedingt den aktuell verwendeten Wert dar, da diese nur von der Hardware abhängt. Vielmehr dient dieser Wert dazu, die Hardware zu initialisieren, wenn das Netz mit der Hardware verbunden wird.

Msg/s

Die aktuelle Anzahl der über dieses Netz empfangenen und gesendeten Botschaften pro Sekunde.

Bits/s

Die aktuelle Anzahl der über dieses Netz transportierten Bits pro Sekunde.

Netz-Handle

Der Wert des treiberinternen Handles des Netzes (1-64).

Hardware

Ein Hardware-Block zeigt immer den Namen der Hardware an, sowie weitere Parameter, welche die Hardware im PC identifizieren.

Abhängig vom Anzeigemodus können folgende Werte angezeigt werden:

Status

Anzeige von "OK", wenn kein Fehler vorliegt, andernfalls eine Fehlerbezeichnung wie z. B. "Error Passive".

Der zusätzliche Indikator "Warnung" wird angezeigt, wenn einer der Fehlerzähler des CAN-Controllers das Error Warning Limit erreicht hat (üblicherweise 96 Fehlerpunkte oder mehr).

Bitrate

Die aktuelle Übertragungsrate der Hardware.

XmtQueue

Zeigt den Füllstand der Sendewarteschlange an, die vom PCAN-System für diese Hardware verwaltet wird.

RcvMsg/s

Die aktuelle Anzahl der empfangenen Botschaften pro Sekunde.

XmtMsg/s

Die aktuelle Anzahl der gesendeten Botschaften pro Sekunde.

RcvBits/s

Die aktuelle Anzahl der empfangenen Bits pro Sekunde.

XmtBits/s

Die aktuelle Anzahl der gesendeten Bits pro Sekunde.

AccCode, AccMask

Die Werte des Akzeptanzfilters.

Error Frames

Zeigt an, ob eine Hardware für den Empfang von Error Frames konfiguriert ist.

Listen Only

Zeigt an, ob die Hardware im Listen Only-Modus arbeitet, wodurch sich der CAN Controller gegenüber Fehlern passiv verhält. Das Senden von Botschaften ist nicht möglich, auf empfangene Botschaften wird kein Acknowledge gegeben.

Hardw.Handle

Der Wert des treiberinternen Handles der Hardware (1-64).

Siehe auch

PCAN Status Display-Befehle

Feedback senden | Copyright © 2022 PEAK-System Technik GmbH. Alle Rechte vorbehalten.


PCAN Status Display-Befehle

Die folgenden Befehle sind auf der Symbolleiste von PCAN Status Display verfügbar:

Befehl | Symbol | Beschreibung
Beenden |  | Beendet das Programm.
Einstellungen |  | Öffnet ein Untermenü zur Konfiguration verschiedener Anwendungseinstellungen.
Status |  | Zeigt allgemeine Statusinformation über Hardware und Netze an. Keine Wirkung auf Clients.
Queues |  | Zeigt die aktuellen Füllstände von Sende- und Empfangswarteschlangen der Clients, und den Füllstand der Sendewarteschlange der Hardware an.
Botsch.Rate |  | Zeigt die Anzahl der Botschaften pro Sekunde an, die momentan von Clients oder Hardware empfangen und gesendet werden.
Bitrate |  | Zeigt die Anzahl der Bits pro Sekunde an, die momentan von Clients oder Hardware empfangen und gesendet werden.
Filter |  | Zeigt die Werte der Akzeptanzfilter an, mit denen die CAN-Hardware konfiguriert ist, sowie die Werte der Software-Filter von Clients.
Optionen |  | Zeigt die Einstellungen von Hardware-Optionen an, z. B. Empfang von Error Frames oder Listen Only-Modus.
Handles |  | Zeigt die Treiberinternen Handle-Werte für die verschiedenen Objekte an (Clients, Netze, Hardware).
Hilfe |  | Zeigt die Online-Hilfe zum PCAN Status Display an.
Über... |  | Zeigt Informationen über das Programm, Version und Copyright an.

Die folgenden Befehle können jeweils über das Kontextmenü einer Hardware, eines Netzes oder eines Clients ausgeführt werden. Das Kontextmenü wird durch Drücken der rechten Maustaste angezeigt.

Befehl | Symbol | Beschreibung
Alle Clients löschen |  | Entfernt alle Clients von einem Netz und schließt die zugehörigen Programme. Dieser Befehl ist für Netze verfügbar.
Bitrate |  | Wählt eine Bitrate für die Hardware aus. Dieser Befehl ist für eine Hardware verfügbar, wenn nicht der Anzeigemodus Optionen gewählt ist, und die Hardware nicht mit einer CAN-FD-Bitrate betrieben wird.
Error Frames |  | Aktiviert oder deaktiviert den Empfang von Error Frames für einen Client. Dieser Befehl ist nur im Anzeigemodus Optionen verfügbar und hat nur dann eine Wirkung, wenn der Client mit einer Hardware verbunden ist, die den Empfang von Error Frames unterstützt.
Identifizieren |  | Veranlasst eine Hardware, die LED des verwendeten CAN-Kanals für eine kurze Zeit blinken zu lassen. Dieser Befehl ist für eine Hardware verfügbar, wenn die Hardware diese Funktion unterstützt.
Listen-only |  | Aktiviert oder deaktiviert den Listen-only-Modus des CAN-Controllers einer Hardware. Dieser Befehl ist für eine Hardware verfügbar, wenn der Anzeigemodus Optionen gewählt ist und die Hardware diese Option unterstützt.
Löschen |  | Entfernt den betreffenden Client von einem Netz und schließt das zugehörige Programm.
Nach vorne bringen |  | Setzt das Programmfenster eines Clients in den Vordergrund.
Zurücksetzen |  | Führt einen Reset einer Hardware aus. Dieser Befehl ist für eine Hardware verfügbar, wenn nicht der Anzeigemodus Optionen gewählt ist.

Feedback senden | Copyright © 2022 PEAK-System Technik GmbH. Alle Rechte vorbehalten.