PCAN-Explorer 6-Dokumentation

Produktübersicht

Enthält Themen zur Einführung in PCAN-Explorer. Erklärt die PCAN-Grundlagen sowie das Einrichten und die Verwaltung des PCAN-Systems.

Erste Schritte

Enthält kurze Anleitungen für die ersten Schritte bei der Arbeit mit PCAN-Explorer.

Grundlagen der Benutzeroberfläche

Enthält Themen über die grundlegende Verwendung der Benutzeroberfläche mit Hilfe von Menüs, Symbolleisten, Fenstern, Tastenkombinationen und anderen Elementen.

Arbeiten mit Projekten

Enthält Themen über die Arbeit mit Projekten.

Arbeiten mit Symbolen

Enthält Themen über die Verwendung von Symbolen, mit deren Hilfe Nachrichtenobjekte eines CAN-Busses in symbolischer Form angezeigt werden können. Dies bringt die Botschaften in eine leichter zu verstehende Form.

Der integrierte Texteditor

Beschreibt die Verwendung des internen Texteditors.

PCAN-Explorer anpassen

Enthält Informationen über die verfügbaren Möglichkeiten, PCAN-Explorer nach eigenen Bedürfnissen anzupassen, um die Bedienung so komfortabel wie möglich zu gestalten.

Aufgaben in PCAN-Explorer automatisieren

Enthält Themen über die Möglichkeiten zur Automatisierung verschiedener Aufgaben in der PCAN-Explorer-Benutzeroberfläche.

Referenz

Enthält Information über Dialogfelder und Fenster, Tastenkombinationen sowie Kommandos und Fehlermeldungen in PCAN-Explorer.

PCAN-Werkzeuge

PCAN Nets Configuration

Einrichten und Verwalten von PCAN-Netzen für die Anbindung von Programmen an PCAN-Hardware.

PCAN Status Display

Statusanzeige für die Überwachung von PCAN-Programmen, -Netzen und Bus-Statistiken.

Letzte Aktualisierung: 21.04.2022

Feedback senden | Copyright © 2022 PEAK-System Technik GmbH. Alle Rechte vorbehalten.


Produktübersicht

Produktübersicht

PCAN-Explorer 6 ist ein universelles Werkzeug in einem CAN-Netzwerk (Controller Area Network), um CAN- oder SAE J1939-Datenverkehr zu überwachen oder zu visualisieren. Er basiert auf dem PCAN-System der Firma PEAK-System Technik GmbH, dessen Kern ein Satz von Windows Kernel-Mode-Treiber ist. Die Treiber sorgen für die Echtzeitanbindung von Windows-Anwendungen an alle CAN-Busse, die über PCAN-Schnittstellenhardware an den PC angeschlossen sind.

In diesem Abschnitt

PCAN-System Grundlagen

Einführung in das PCAN-System, das allen PCAN-Programmen zugrunde liegt.

Konfiguration von PCAN-Netzen

Beschreibt die Vorgehensweise beim Erstellen und Konfigurieren von PCAN-Netzen, die zur Anbindung von PCAN-Programmen an PCAN-Hardware dienen.

Kontakt-Information

Enthält Information über den Hersteller dieser Software.

Lizenzbestimmungen

Enthält die Lizenzbestimmungen bezüglich dieser Software.

Grundlegende Schritte zur Verwendung von PCAN-Explorer

Anlegen eines neuen Projekts

Öffnen eines bestehenden Projekts

Verbinden mit einem CAN-Bus

Empfangen von CAN-Botschaften

Senden einer neuen CAN-Botschaft

Weitere Abschnitte

Die PCAN-Explorer-Benutzeroberfläche

Enthält Themen über die Verwendung der PCAN-Explorer-Benutzeroberfläche.

PCAN Nets Configuration

Einrichten und Verwalten von PCAN-Netzen für die Anbindung von Programmen an PCAN-Hardware.

PCAN Status Display

Statusanzeige für die Überwachung von PCAN-Programmen, -Netzen und Bus-Statistiken.


PCAN-System Grundlagen

PCAN steht für PEAK CAN APPLICATIONS und ist ein flexibles System zur Planung, Entwicklung und Benutzung von CAN-Netzen. Es ist sowohl für den Entwickler als auch für den Endbenutzer ein hilfreiches und mächtiges Produkt.

Basis für die Kommunikation zwischen PCs und externer Hardware über CAN sind eine Reihe von Windows Kernel Mode Gerätetreiber, z.B. PCAN_USB.SYS, PCAN_PCI.SYS, PCAN_xxx.SYS. Diese Treiber bilden den Kern einer kompletten CAN-Umgebung auf einem PC mit Windows als Betriebssystem, und arbeiten als Schnittstellen zwischen CAN-Software und PC-basierter CAN-Hardware. Die Treiber verwalten den ganzen Datenverkehr jedes an den PC angeschlossenen CAN-Geräts.

Benutzern oder Administratoren einer CAN-Installation wird der Zugriff auf das Netzwerk mittels PCAN-Client-Programmen ermöglicht (kurz: Client). Mit ihrer Hilfe können Prozessgrößen visualisiert und beeinflusst werden. Die Treiber ermöglichen die Verbindung von mehreren Clients zur selben Zeit.

Weiterhin werden von einem PCAN-Treiber mehrere Hardware-Komponenten unterstützt, die auf dem CAN-Controller SJA1000 basieren. So genannte Netze stellen die logische Struktur für CAN-Busse zur Verfügung, die virtuell in den PC hinein verlängert sind. Auf der Hardware-Seite können ebenfalls mehrere Clients verbunden sein. Die folgende Grafik zeigt die verschiedenen Möglichkeiten von Netzkonfigurationen (die auch alle zur selben Zeit realisiert werde können):

Merkmale des PCAN-Systems

  • Ein Client kann an mehrere Netze angeschlossen sein

  • Ein Netz versorgt mehrere Clients

  • Eine Hardware gehört zu maximal einem Netz

  • Einem Netz ist keine oder genau eine Hardware zugeordnet

  • Sendet ein Client, wird die Botschaft an alle anderen verbundenen Clients weitergegeben, und über eine verbundene CAN-Hardware auf den externen CAN-Bus

  • Wird eine Botschaft über die CAN-Hardware empfangen, wird sie an alle verbundenen Clients weitergegeben. Jeder Client empfängt aber nur die Botschaften, die seinen Akzeptanzfilter passieren.

Siehe auch

Konfigurieren von PCAN-Netzen


Kontakt-Information

Diese Software ist ein Produkt von:

PEAK-System Technik GmbH

Otto-Röhm-Straße 69

D-64293 Darmstadt

E-Mail: | info@peak-system.com
Web: | www.peak-system.com

Technischer Support

Unser technischer Support steht Ihnen von Montag bis Freitag zwischen 8:30 und 16:30 Uhr MEZ unter der folgenden E-Mail-Adresse zur Verfügung:

E-Mail: support@peak-system.com

Preisanfragen / Bestellungen

Für Angebotserstellungen und Preisanfragen stehen wir Ihnen von Montag bis Freitag zwischen 8:00 und 16:00 Uhr MEZ zur Verfügung.

E-Mail: order@peak-system.com


Lizenzbestimmungen

Die im Handbuch verwendeten Bezeichnungen für Erzeugnisse, die zugleich ein eingetragenes Warenzeichen darstellen, wurden nicht gesondert gekennzeichnet. Das Fehlen der ® Markierung ist demzufolge nicht gleichbedeutend mit der Tatsache, dass die Bezeichnung als freier Warenname gilt. Ebenso wenig kann anhand der verwendeten Bezeichnung auf eventuell vorliegende Patente oder einen Gebrauchsmusterschutz geschlossen werden. Es sei ausdrücklich darauf verwiesen, dass die Firma PEAK-System Technik GmbH weder eine Garantie noch die juristische Verantwortung oder irgendeine Haftung für Folgeschäden übernimmt, die auf den Gebrauch der beiliegenden Software oder den Inhalt dieses Handbuches zurückzuführen sind. Die in diesem Handbuch enthaltenen Angaben können ohne vorherige Ankündigung geändert werden. Die Firma PEAK-System Technik GmbH geht damit keinerlei Verpflichtungen ein.

Copyright © 2000-2022 PEAK-System Technik GmbH

Alle Rechte vorbehalten.

Kein Teil dieses Hilfetextes darf in irgendeiner Form ohne schriftliche Genehmigung der Firma PEAK-System Technik GmbH unter Einsatz entsprechender Systeme reproduziert, verarbeitet, vervielfältigt oder verbreitet werden.

Siehe auch

Kontakt-Information


Erste Schritte mit PCAN-Explorer

Grundlegende Schritte zur Verwendung von PCAN-Explorer

Anlegen eines neuen Projekts

Öffnen eines bestehenden Projekts

Verbinden mit einem CAN-Bus

Empfangen von CAN-Botschaften

Senden einer neuen CAN-Botschaft


Anlegen eines neuen Projekts

Bevor Sie CAN-Botschaften empfangen oder senden können, muss ein Projekt geöffnet sein.

Um ein neues Projekt anzulegen:

  • Falls die Startseite geöffnet ist, klicken Sie auf Leeres Projekt unter der Überschrift Neues Projekt erstellen.

- oder -

  • Wählen Sie im Menü Datei im Untermenü Neu den Befehl Neues Projekt.

- oder -

  • Drücken Sie die Schaltfläche [image] in der Symbolleiste.

Hinweis

Nachdem ein neues Projekt angelegt wurde, zeigt der Projekt-Manager ein leeres Projekt mit dem Titel "Neues Projekt".

Der Projekt-Manager ist standardmäßig auf der rechten Seite der Benutzeroberfläche angeordnet. Er stellt ein nützliches Werkzeug dar, das eine organisierte Ansicht auf das aktuell geladene Projekt und die darin enthaltenen Dateien bietet. Außerdem ermöglicht er einen schnellen Zugriff auf Befehle, die das Projekt, seine Dateien, sowie weitere Projektelemente betreffen.

Siehe auch

Verbinden mit einem CAN-Bus

Produktübersicht


Öffnen eines bestehenden Projekts

Es gibt mehrere Wege, eine PCAN-Explorer Projektdatei (Datei mit Endung .peproj) zu öffnen.

Um ein Projekt nach dem Starten des Programms zu öffnen:

  • Wählen Sie im Menü Datei den Befehl Projekt öffnen.

- oder -

  • Falls die Startseite geöffnet ist, wählen Sie eines der Projekte aus der Liste Letzte Projekte öffnen, oder klicken Sie auf [image] Projekt öffnen.

- oder -

  • Drücken Sie die Schaltfläche [image] in der Symbolleiste und wählen Sie eine Projektdatei aus.

Hinweis

Verwenden Sie den Projekt-Manager, um den Inhalt des geladenen Projekts zu untersuchen. Der Projekt-Manager ist ein hilfreiches Werkzeug, das eine organisierte Ansicht des aktuell geladenen Projekts und die darin enthaltenen Dateien bietet. Außerdem ermöglicht er einen schnellen Zugriff auf Befehle, die das Projekt, seine Dateien, sowie weitere Projektelemente betreffen.

PCAN-Explorer kann auch so konfiguriert werden, dass er das zuletzt geöffnete Projekt automatisch lädt, wenn das Programm gestartet wird..

Um ein Projekt automatisch beim Programmstart zu laden:

  1. Im Menü Werkzeuge wählen Sie Optionen.

  2. Wählen Sie die Seite Umgebung in der Liste auf der linken Seite des Dialogfensters.

  3. In der Dropdownliste Beim Starten wählen Sie Lade zuletzt geladenes Projekt.

Falls ein Projekt geöffnet war als das Programm beendet wurde, wird beim nächsten Start von PCAN-Explorer dieses Projekt automatisch wieder geladen.

Siehe auch

Verbinden mit einem CAN-Bus

Produktübersicht


Verbinden mit einem CAN-Bus

Bevor Sie mit PCAN-Explorer CAN-Botschaften empfangen oder senden können, muss ein Projekt geöffnet sein, und das Projekt muss mindestens eine aktive Verbindung besitzen.

Um eine Verbindung mit einem CAN-Bus aufzubauen:

  1. Wählen Sie im Menü Verbindungen den Befehl Verbindung hinzufügen, oder klicken Sie auf die Schaltfläche [image] in der Symbolleiste. Das Dialogfenster Verbindung hinzufügen wird angezeigt.

  2. Wählen Sie eine der Gerätetyp-Registerkarten.

  3. Wählen Sie ein PCAN-Netz aus der Liste Verfügbare Netze, mit dem PCAN-Explorer verbunden werden soll.

Tipp

Falls in der Liste Verfügbare Netze keine PCAN-Netze angezeigt werden, wählen Sie die Schaltfläche Netze bearbeiten um das Netzkonfigurationswerkzeug zu starten. Befolgen Sie diese Schritte, um ein neues PCAN-Netz zu erzeugen. Wählen Sie anschließend die Schaltfläche [image], um die Liste der verfügbaren Netze zu aktualisieren, so dass neu angelegte Netze sichtbar werden.

  4. Geben Sie einen Namen für die Neue Verbindung im Feld Name ein.

Hinweis

Ein Projekt kann keine zwei Verbindungen mit dem selben Namen enthalten. Wenn der Name, den Sie in das Name-Feld eingeben, bereits von einer anderen Verbindung belegt ist, wird eine Zahl an den Namen angehängt, um einen eindeutigen Namen für die Verbindung zu erzeugen.

  5. Wählen Sie das Protokoll in der Dropdownliste Protokoll aus, das die neue Verbindung verwenden soll.

Hinweis

Falls das J1939 Add-in nicht geladen ist, ist nur das CAN-Protokoll in der Dropdownliste verfügbar.

  6. Aktivieren Sie die Option Verbindung aktivieren.

  7. Drücken Sie OK. Die Verbindung wird jetzt dem Projekt hinzugefügt.

Hinweis

Die hinzugefügte Verbindung wird jetzt im Verbindungen-Fenster und im Projekt-Manager angezeigt (dort auf der Registerkarte Projektelemente im Knoten Verbindungen). Das Symbol vor dem Namen der Verbindung zeigt den Status der Verbindung an:

Die Verbindung ist aktiv.

Die Verbindung hat ein Problem, prüfen Sie das Ausgabe-Fenster auf eine Fehlermeldung.

Die Verbindung ist deaktiviert.

Die Verbindung ist aktiv und hat einen aktivierten Botschaftsfilter.

Jetzt können Sie CAN-Botschaften auf dem verbundenen CAN-Bus empfangen und senden. Falls das Senden/Empfangen-Fenster noch nicht geöffnet ist, wählen Sie im Menü Ansicht den Befehl Senden/Empfangen, oder drücken Sie einfach [Strg+R] auf der Tastatur.

Siehe auch

Senden einer neuen CAN-Botschaft

Produktübersicht


Empfangen von CAN-Botschaften

Bevor Sie mit PCAN-Explorer CAN-Botschaften empfangen können, muss ein Projekt geöffnet sein, und das Projekt muss zumindest eine aktive Verbindung besitzen.

Um CAN-Botschaften zu empfangen:

  1. Befolgen Sie die Schritte Anlegen eines neuen Projekts oder Öffnen eines bestehenden Projekts.

  2. Befolgen Sie die Schritte Verbinden mit einem CAN-Bus.

Hinweis

Alle Verbindungen eines Projekts werden Verbindungen-Fenster und im Projekt-Manager angezeigt (dort auf der Registerkarte Projektelemente im Knoten Verbindungen). Das Symbol vor dem Namen der Verbindung zeigt den Status der Verbindung an:

Die Verbindung ist aktiv.

Die Verbindung hat ein Problem, prüfen Sie das Ausgabe-Fenster auf eine Fehlermeldung.

Die Verbindung ist deaktiviert.

Die Verbindung ist aktiv und hat einen aktivierten Botschaftsfilter.

  3. Wenn eine CAN-Verbindung hergestellt ist zeigt das Verbindungen-Fenster und der Projekt-Manager an, dass die Verbindung aktiv ist.

  4. Öffnen Sie das Senden/Empfangen-Fenster: Wählen Sie entweder den Befehl Senden/Empfangen im Menü Ansicht, führen Sie einen Doppelklick auf einer Verbindung im Projekt-Manager durch, oder drücken Sie [Strg+R].

Alle empfangenen CAN-Botschaften werden in der Empfangsliste angezeigt. Diese ist die obere Liste im Senden/Empfangen-Fenster. Eine Erläuterung der einzelnen Spalten der Liste finden Sie im Referenzthema Empfangsliste.

Siehe auch

Senden einer neuen CAN-Botschaft

Produktübersicht


Senden einer neuen CAN-Botschaft

Sie können eine CAN-Botschaft senden, indem Sie einen neuen Eintrag in einer Sendeliste erstellen. Verwenden Sie entweder die Sendeliste im Senden/Empfangen-Fenster, oder erzeugen Sie zuerst mit Hilfe des Menübefehls Datei | Neu | Neue Datei eine neue Sendeliste.

Um eine neue CAN-Botschaft zu senden:

  1. Befolgen Sie die Schritte Anlegen eines neuen Projekts oder Öffnen eines bestehenden Projekts.

  2. Befolgen Sie die Schritte Verbinden mit einem CAN-Bus.

  3. Öffnen Sie das Senden/Empfangen-Fenster: Wählen Sie entweder den Befehl Senden/Empfangen im Menü Ansicht, oder drücken Sie [Strg+R].

  4. Wählen Sie den Befehl Neue Botschaft im Menü Senden, oder drücken Sie die Taste [Einfg] während das Senden/Empfangen-Fenster aktiv ist.

  5. In der Dropdownliste Bus wählen Sie den Bus bzw. die Verbindung die Sie verwenden möchten.

  6. Geben Sie die CAN-ID der neuen Botschaft im Feld ID ein.

    Hinweis

    Wenn Sie mehr als 3 Zeichen eingeben, wird die Botschaft als erweiterte 29-Bit Botschaft behandelt, und die Option Extended Frame wird automatisch aktiviert. Der gültige CAN-ID-Bereich von 11-Bit Botschaften ist 0 bis 7FFh.

  7. Wählen Sie die Datenlänge der Botschaft im Feld Länge. Dies legt fest, wieviele Datenbytes die neue Botschaft haben wird. CAN-Botschaften können eine Datenlänge zwischen 0 und 8 Bytes haben, CAN-FD-Botschaften maximal 64.

  8. Geben Sie die Werte für die Datenbytes der Botschaft in den Feldern Daten in hexadezimaler Schreibweise ein.

  9. Drücken Sie OK. Die neue CAN-Botschaft wird der Sendeliste des Senden/Empfangen-Fensters hinzugefügt und automatisch ausgewählt.

  10. Um die Botschaft schließlich zu senden, wählen Sie entweder im Menü Senden den Befehl Senden oder drücken Sie die Leertaste.

Tipp

Falls Sie einen Kommentar für eine Sendebotschaft eintragen möchten, können Sie den Kommentartext im Eigenschaften-Fenster eingeben, wenn die Botschaft in der Sendeliste ausgewählt ist.

Siehe auch

Produktübersicht


Leitseite: PCAN-Explorer-Umgebung

Dieser Abschnitt enthält Information über die PCAN-Explorer-Umgebung.

In diesem Abschnitt

Grundlagen der Benutzeroberfläche

Beschreibt grundlegende Elemente der PCAN-Explorer-Benutzeroberfläche, wie z.B. Fenster, Symbolleisten und Tastenkombinationen.

Arbeiten mit Projekten

Enthält Themen über das Arbeiten mit Projekten.

Empfangen und Senden von CAN-Botschaften

Beschreibt den grundsätzlichen Empfangsbetrieb und erklärt die nötigen Schritte zum Senden von CAN-Botschaften.

Arbeiten mit dem Texteditor

Beschreibt die Verwendung des Texteditors, um z.B. Symboldateien oder VBS-Makros zu bearbeiten.

Arbeiten mit Symbolen

Enthält Themen über die Verwendung von Symbolen, mit deren Hilfe Botschaftsobjekte eines CAN-Busses in symbolischer Form angezeigt werden können. Dies bringt die Botschaften in eine leichter verständliche Form.

Aufzeichnen von CAN-Botschaften

Enthält Themen über die Verwendung des Tracers.

PCAN-Explorer anpassen

Enthält Informationen über die verfügbaren Möglichkeiten, PCAN-Explorer nach eigenen Bedürfnissen anzupassen, um die Bedienung so komfortabel wie möglich zu gestalten.

Weitere Abschnitte

Benutzeroberfläche

Enthält Referenz-Themen für die verschiedenen Dialogfelder und Fenster von PCAN-Explorer.


Grundlagen der Benutzeroberfläche

Grundlagen der Benutzeroberfläche

Leitseite (Umgebung)

Die PCAN-Explorer-Benutzeroberfläche besteht aus einer Reihe von integrierten Fenstern, Werkzeugen, Menüs, Symbolleisten, Listen und anderen Elementen.

Die Benutzeroberfläche verwendet die standardmäßige Windows-Interface-Funktionalität zusammen mit ein paar zusätzlichen Besonderheiten, um die Bedienung zu erleichtern.

Die Benutzeroberfläche ist ein Teil der PCAN-Explorer-Umgebung, in der man Information anzeigen und Aktionen festlegen kann. Diese Themen beschreiben den grundlegenden Betrieb der Benutzeroberfläche von PCAN-Explorer.

In diesem Abschnitt

Verwaltung von Fenstern

Beschreibung der verschiedenen Typen von Fenstern und Vorgehensweisen über das Anpassen des Layouts von Fenstern.

Symbolleisten und Menüleiste

Information über die Arbeit mit Symbolleisten und der Menüleiste.

Bibliothek

Beschreibt die PCAN-Explorer-Bibliothek und wie man die Bibliotheksverzeichnisse einrichtet.

Verwenden von Tastenkombinationen

Information über die Verwendung und das Anpassen von Tastenkombinationen, um die Arbeit mit der Benutzeroberfläche zu erleichtern.

Weitere Abschnitte

PCAN-Explorer anpassen

Beschreibung der Möglichkeiten und Verfahrensweisen, die Benutzeroberfläche nach eigenen Bedürfnissen anzupassen.


Verwaltung von Fenstern

Die PCAN-Explorer-Benutzeroberfläche enthält zwei grundlegende Fenstertypen: Tool-Fenster und Dokument-Fenster. Diese beiden Fenstertypen haben ein unterschiedliches Verhalten.

Tool-Fenster

Tool-Fenster sind im Menü Ansicht aufgeführt.

Die Fenster sind nicht auf den Arbeitsbereich der Anwendung beschränkt und können schwebend auf dem gesamten Desktop platziert werden. Weiterhin können sie an die Seiten des Hauptfensters angedockt werden.

Tool-Fenster sind erkennbar an der kleinen Titelleiste.

Dokument-Fenster

Dokument-Fenster werden dynamisch erzeugt, wenn eine Datei geöffnet wird. Die Liste der offenen Dokument Fenster erscheint im Menü Fenster in der aktuellen Z-Reihenfolge, wobei das oberste Fenster zuerst aufgeführt ist.

Die Dokument-Fenster können innerhalb des MDI-Arbeitsbereichs (MDI = Multiple Document Interface) platziert werden. Im Menü Fenster sind einige Befehle verfügbar, um die Fenster im Arbeitsbereich automatisch anzuordnen.

Hinweis

Das Senden/Empfangen-Fenster sowie die Startseite stellen Ausnahmen dar. Diese werden zwar wie Dokument-Fenster behandelt, beruhen aber nicht auf einer zu öffnenden Datei.

Fenster anordnen

Abhängig von der Anordnung der verschiedenen Fenster in der Benutzeroberfläche kann der verfügbare Raum für wichtige Fenster auf mehrere Arten erhöht werden:

  • Andocken von Tool-Fenstern an den Rand des Hauptfensters

  • Verschieben von Tool-Fenstern auf andere Monitore

  • Kachelförmige Anordnung der Dokument Fenster

  • Minimieren von Dokument-Fenstern.

Tool-Fenster andocken

Schwebende Tool-Fenster kann man an die Ränder des Hauptfensters andocken. Dazu zieht man die Fenster mit der Maus an deren Titelleiste über die Benutzeroberfläche, bis der halbtransparente Ziehrahmen die Form verändert und eine mögliche Andockposition anzeigt. Wird die Maustaste dann losgelassen, nimmt das Tool-Fenster den vorher angedeuteten Raum ein. Je nach angedockter Position erscheint eine Griffleiste am linken oder oberen Rand des Tool-Fensters und eine kleine Schaltfläche zum Schließen des Fensters.

Um den angedockten Zustand eines Tool-Fensters wieder aufzuheben, muss mit der Maus die Griffleiste des angedockten Fensters gezogen werden. Ein Ziehrahmen erscheint, der sich mit dem Mauszeiger bewegt. Wird die Maustaste dann losgelassen, wird aus dem Tool-Fenster wieder ein schwebendes Fenster.

Die Positionen der Tool-Fenster werden in der Layout-Datei (*.dsk) des jeweils geöffneten Projekts gespeichert und beim nächsten Laden des Projekts wiederhergestellt.


Symbolleisten

Symbolleisten bieten eine Möglichkeit, unter Benutzung der Maus auf die wichtigsten Kommandos schnell zugreifen zu können.

Man kann die verschiedenen verfügbaren Symbolleisten ein- oder ausblenden, und man kann ihre Position verändern.

Die Menüleiste ist eine spezielle Symbolleiste am oberen Fensterrand, die Menüeinträge wie beispielsweise Datei, Bearbeiten oder Ansicht enthält. Die Menüleiste erstreckt sich im Gegensatz zu einer normalen Symbolleiste immer bis zum rechten Rand des Anwendungsfensters und kann nicht ausgeblendet werden.

Um eine Symbolleiste ein- oder auszublenden:

  1. Im Menü Ansicht unter Symbolleisten die Symbolleiste auswählen, die ein- oder ausgeblendet werden soll. Ein Haken vor dem jeweiligen Befehl zeigt an, dass die entsprechende Symbolleiste angezeigt wird.

Siehe auch

Symbolleisten, Anpassen-Dialogfenster


Bibliothek

Bei der Arbeit mit PCAN-Explorer trifft man auf viele verschiedene Dateitypen, beispielsweise Symboldateien, Sendelisten und Makrodateien. Die PCAN-Explorer-Bibliothek erlaubt den schnellen Zugriff auf regelmäßig verwendete Dateien. Dateien, die in der Bibliothek gespeichert sind, können von verschiedenen Projekten verwendet werden, ohne dass sie in das jeweilige Projektverzeichnis kopiert werden müssen, und dadurch mehrere Kopien der gleichen Datei existieren.

Um ein Bibliotheksverzeichnis für einen Dateityp festzulegen:

  1. Im Menü Werkzeuge den Befehl Optionen und dann die Seite Bibliothek auswählen.

  2. In der Liste Bibliotheks-Verzeichnisse in die Spalte Pfad neben dem Dateityp klicken, für den ein Verzeichnis festgelegt werden soll.

  3. Den gewünschten Pfad eingeben oder die Schaltfläche [image] anklicken und ein Verzeichnis auswählen.

  4. OK drücken, um das Dialogfenster zu schließen.

Siehe auch

Bibliothek, Optionen-Dialogfenster


Verwenden von Tastenkombinationen

Tastenkombinationen bieten für Anwender, die die Benutzung der Tastatur der Maus vorziehen, eine alternative Methode zum Ausführen von Befehlen. Manche Tastenkombinationen in PCAN-Explorer sind standardmäßig zugewiesen. Andere Befehle haben keine Standard-Tastenkombinationen.

Man kann standardmäßig zugewiesene Tastenkombinationen ändern oder neue Tastenkombinationen für Befehle erzeugen, die standardmäßig keine haben.

Anzeigen einer Liste von aktuellen Tastenkombinationen

Man kann die aktuell zugewiesenen Tastenkombinationen anzeigen, einschließlich der selbst definierten Tastenkombinationen.

Um die Tastenkombinationen anzuzeigen:

  1. Im Menü Hilfe den Befehl Tastaturbelegung auswählen und eine oder mehrere der folgenden Aktionen ausführen:

  • Einen Eintrag aus der Dropdownliste wählen, um die Liste der Tastenkombinationen zu filtern (Alle Befehle, Befehle mit Tastenkombination, Befehle einer Kategorie).

  • In der Titelzeile der Liste auf Befehl, Alias, Taste oder Beschreibung klicken, um die Liste der Tastenkombinationen nach dem entsprechenden Kriterium alphabetisch zu sortieren.

  • Die Schaltfläche [image] anklicken, um die Einträge der Liste in die Zwischenablage von Windows zu kopieren (Weiterverarbeitung z.B. in einem Textverarbeitungssystem oder einem Texteditor).

Siehe auch

Anpassen von Tastenkombinationen


Arbeiten mit Projekten

Leitseite (Umgebung)

PCAN-Explorer-Projekte sind Container, die Ihnen dabei helfen, effizient die Elemente zu verwalten, die nötig sind um ein CAN- oder SAE J1939-Netzwerk zu überwachen und zu visualisieren. Dazu gehören z.B. Busverbindungen, Dateien, Ordner und Filter. Der Projekt-Manager, eine Schnittstelle für die Anzeige und Verwaltung von Projekten und ihrer verknüpften Elemente, ist Teil der PCAN-Explorer-Umgebung.

In diesem Abschnitt

Anlegen eines Projekts

Beschreibt die Vorgehensweise für das Anlegen eines neuen Projekts.

Öffnen eines bestehenden Projekts

Beschreibt die Vorgehensweise für das Öffnen eines bestehenden Projekts, und wie Projekte beim Start von PCAN-Explorer automatisch geladen werden können.

Hinzufügen einer Datei zu einem Projekt

Beschreibt die Vorgehensweise für das Hinzufügen von bestehenden oder neuen Dateien zu einem Projekt.

Umbenennen eines Projekts

Beschreibt die Möglichkeiten, wie ein Projekt umbenannt werden kann.


Anlegen eines Projekts

Bevor CAN-Botschaften empfangen oder gesendet werden können, muss ein Projekt geöffnet sein.

Um ein neues Projekt anzulegen:

  • Falls die Startseite geöffnet ist, klicken Sie auf Leeres Projekt unter der Überschrift Neues Projekt erstellen.

- oder -

  • Im Menü Datei wählen Sie im Untermenü Neu den Befehl Neues Projekt.

- oder -

  • Drücken Sie die Schaltfläche [image] in der Symbolleiste.

Hinweis

Nachdem ein neues Projekt angelegt wurde, zeigt der Projekt-Manager ein leeres Projekt mit dem Titel "Neues Projekt". Der Projekt-Manager ist standardmäßig auf der rechten Seite der Benutzeroberfläche angeordnet. Er stellt ein nützliches Werkzeug dar, das eine organisierte Ansicht auf das aktuell geladene Projekt und die darin enthaltenen Dateien bietet. Außerdem ermöglicht er einen schnellen Zugriff auf Befehle, die das Projekt, seine Dateien, sowie weitere Projektelemente betreffen.

Siehe auch

Hinzufügen einer Datei zu einem Projekt

Arbeiten mit Projekten


Öffnen eines bestehenden Projekts

Es gibt mehrere Wege, eine PCAN-Explorer Projektdatei (Datei mit Endung .peproj) zu öffnen.

Um ein Projekt nach dem Starten des Programms zu öffnen:

  • Wählen Sie im Menü Datei den Befehl Projekt öffnen.

- oder -

  • Falls die Startseite geöffnet ist, wählen Sie eines der Projekte aus der Liste Letzte Projekte öffnen, oder klicken Sie auf [image] Projekt öffnen.

- oder -

  • Drücken Sie die Schaltfläche [image] in der Symbolleiste und wählen Sie eine Projektdatei aus.

Hinweis

Verwenden Sie den Projekt-Manager, um den Inhalt des geladenen Projekts zu untersuchen. Der Projekt-Manager ist ein hilfreiches Werkzeug, das eine organisierte Ansicht des aktuell geladenen Projekts und die darin enthaltenen Dateien bietet. Außerdem ermöglicht er einen schnellen Zugriff auf Befehle, die das Projekt, seine Dateien, sowie weitere Projektelemente betreffen.

PCAN-Explorer kann auch so konfiguriert werden, dass er das zuletzt geöffnete Projekt automatisch lädt, wenn das Programm gestartet wird..

Um ein Projekt automatisch beim Programmstart zu laden:

  1. Im Menü Werkzeuge wählen Sie Optionen.

  2. Wählen Sie die Seite Umgebung in der Liste auf der linken Seite des Dialogfensters.

  3. In der Dropdownliste Beim Starten wählen Sie Lade zuletzt geladenes Projekt.

Falls ein Projekt geöffnet war als das Programm beendet wurde, wird beim nächsten Start von PCAN-Explorer dieses Projekt automatisch wieder geladen.

Siehe auch

Arbeiten mit Projekten


Hinzufügen einer Datei zu einem Projekt

Sie können entweder bereits existierende Dateien zu einem Projekt hinzufügen, oder in einem Schritt eine neue Datei erzeugen und hinzufügen.

Um eine neue Datei zu einem Projekt hinzuzufügen:

  1. Klicken Sie auf die Schaltfläche Neu in der Symbolleiste des Projekt-Managers

- oder -

Wählen Sie den Befehl Neues Element hinzufügen im Menü Projekt.

  2. Im Dialogfenster Neues Element hinzufügen wählen Sie in der Liste Dateitypen den Typ der Datei, die Sie erzeugen möchten.

  3. Geben Sie im Feld Name den Namen der neuen Datei ein.

  4. Geben Sie den Speicherort der Datei im Feld Ort ein, oder verwenden Sie die Schaltfläche dahinter um einen Ordner auszuwählen.

  5. Drücken Sie OK.

Die neue Datei wird jetzt geöffnet und erscheint im Projekt-Manager auf der Registerseite Projekt-Dateien.

Um eine bestehende Datei zu einem Projekt hinzuzufügen:

  1. Klicken Sie auf die Schaltfläche Hinzufügen in der Symbolleiste des Projekt-Managers

- oder -

Wählen Sie den Befehl Bestehendes Element hinzufügen im Menü Projekt.

  2. Im Öffnen-Dialogfenster wählen Sie die Datei aus, die Sie zum Projekt hinzufügen möchten.

  3. Drücken Sie Öffnen.

Die Datei erscheint jetzt im Projekt-Manager auf der Registerseite Projekt-Dateien.

Um eine bestehende Datei aus der Bibliothek zu einem Projekt hinzuzufügen:

  1. Öffnen Sie die Bibliothek, indem Sie den Befehl Bibliothek im Menü Ansicht auswählen.

  2. Wählen Sie die Datei aus, die Sie zum Projekt hinzufügen möchten.

  3. Öffnen Sie das Kontextmenü für die Datei (rechte Maustaste) und wählen Sie entweder den Befehl Zum Projekt hinzufügen oder Kopieren und zum Projekt hinzufügen.

Siehe auch

Arbeiten mit Projekten


Umbenennen eines Projekts

Es gibt verschiedene Wege, wie ein Projekt umbenannt werden kann.

Um ein Projekt umzubenennen:

  1. Öffnen Sie im Projekt-Manager das Kontextmenü auf dem Hauptknoten des Projekts.

  2. Wählen Sie den Befehl Umbenennen.

  3. Geben Sie den neuen Namen des Projekts ein und drücken Sie [Eingabe].

- oder -

  1. Wählen Sie den Hauptknoten des Projekts im Projekt-Manager aus.

  2. Klicken Sie erneut mit der Maus in das Beschriftungsfeld des Knotens (kein Doppelklick).

  3. Geben Sie den neuen Namen des Projekts ein und drücken Sie [Eingabe].

- oder -

  1. Wählen Sie den Befehl Projekt speichern unter im Menü Datei aus.

  2. Geben Sie Im Speichern-Dialogfenster einen neuen Namen für das Projekt ein.

  3. Drücken Sie Speichern.

Siehe auch

Arbeiten mit Projekten


Empfangen und Senden von CAN-Botschaften

Empfangen und Senden von CAN-Botschaften

Leitseite (Umgebung)

Bevor Sie mit PCAN-Explorer CAN-Botschaften empfangen oder senden können, müssen Sie eine Verbindung mit einem CAN-Bus herstellen.

Sobald mindestens eine aktive Verbindung vorhanden ist, werden alle CAN-Botschaften des verbundenen CAN-Busses in der Empfangsliste angezeigt. Die dort angezeigten Botschaften können entweder von CAN-Knoten am externen physikalischen CAN-Bus stammen, oder von anderen PCAN-Client-Programmen, die mit dem gleichen PCAN-Netz verbunden sind.

Wenn ein Botschaftsfilter für die Empfangsliste ausgewählt ist, müssen Sie diesen Filter so konfigurieren, dass die Botschaften durch den Filter gelassen werden. Andernfalls bleibt die Empfangsliste leer.

In diesem Abschnitt

Herstellen einer Verbindung mit einem CAN-Bus

Beschreibt die Vorgehensweise zum Hinzufügen einer Verbindung zu einem Projekt um eine Verbindung mit einem CAN-Bus herzustellen.

Senden von CAN-Botschaften

Beschreibt die Vorgehensweise zum Senden einer neuen CAN-Botschaft.

Arbeiten mit Sendelisten

Beschreibt die Anwendung von Sendelisten zur Verwendung von eigenen CAN-Botschaften in späteren Sitzungen.

Remote Transmission Request

Erläutert die Funktionsweise von Remote Transmission Requests und deren Verwendung in PCAN-Explorer.

Filtern von Botschaften

Beschreibt die Optionen, welche die Filterung von CAN-Botschaften steuern.

Anzeigen von Error Frames

Erläutert die Funktionsweise und die Anzeige von Error Frames in PCAN-Explorer.

Exportieren von Botschaften

Beschreibt die Vorgehensweise zum Exportieren von Botschaftslisten in Textdateien oder CSV-Dateien.


Herstellen einer Verbindung mit einem CAN-Bus

Bevor Sie mit PCAN-Explorer CAN-Botschaften empfangen oder senden können, muss ein Projekt geöffnet sein, und das Projekt muss mindestens eine aktive Verbindung besitzen.

Um ein neues Projekt anzulegen:

  • Wählen Sie im Menü Datei im Untermenü Neu den Befehl Neues Projekt.

- oder -

  • Falls die Startseite geöffnet ist, klicken Sie auf Leeres Projekt unter der Überschrift Neues Projekt erstellen.

- oder -

  • Drücken Sie die Schaltfläche [image] in der Symbolleiste.

Hinweis

Nachdem ein neues Projekt angelegt wurde, zeigt der Projekt-Manager ein leeres Projekt mit dem Titel "Neues Projekt".

Der Projekt-Manager ist standardmäßig auf der rechten Seite der Benutzeroberfläche angeordnet. Er stellt ein nützliches Werkzeug dar, das eine organisierte Ansicht auf das aktuell geladene Projekt und die darin enthaltenen Dateien bietet. Außerdem ermöglicht er einen schnellen Zugriff auf Befehle, die das Projekt, seine Dateien, sowie weitere Projektelemente betreffen.

Um eine Verbindung mit einem CAN-Bus aufzubauen:

  1. Wählen Sie im Menü Verbindungen den Befehl Verbindung hinzufügen, oder klicken Sie auf die Schaltfläche [image] in der Symbolleiste. Das Dialogfenster Verbindung hinzufügen wird angezeigt.

  2. Wählen Sie eine der Gerätetyp-Registerkarten.

  3. Wählen Sie ein PCAN-Netz aus der Liste Verfügbare Netze, mit dem PCAN-Explorer verbunden werden soll.

  4. Geben Sie einen Namen für die Neue Verbindung im Feld Name ein.

Hinweis

Ein Projekt kann keine zwei Verbindungen mit dem selben Namen enthalten. Wenn der Name, den Sie in das Name-Feld eingeben, bereits von einer anderen Verbindung belegt ist, wird eine Zahl an den Namen angehängt, um einen eindeutigen Namen für die Verbindung zu erzeugen.

  5. Wählen Sie das Protokoll in der Dropdownliste Protokoll aus, das die neue Verbindung verwenden soll.

Hinweis

Falls das J1939 Add-in nicht geladen ist, ist nur das CAN-Protokoll in der Dropdownliste verfügbar.

  6. Aktivieren Sie die Option Verbindung aktivieren.

  7. Drücken Sie OK. Die Verbindung wird jetzt dem Projekt hinzugefügt und wird im Verbindungen-Fenster sowie im Projekt-Manager angezeigt (dort auf der Registerkarte Projektelemente im Knoten Verbindungen).

Jetzt können Sie CAN-Botschaften auf dem verbundenen CAN-Bus empfangen und senden. Falls das Senden/Empfangen-Fenster noch nicht geöffnet ist, wählen Sie im Menü Ansicht den Befehl Senden/Empfangen, oder drücken Sie einfach [Strg+R] auf der Tastatur.

Siehe auch

Verbindung hinzufügen-Dialogfenster

Senden/Empfangen-Fenster

Projekt-Manager


Senden von CAN-Botschaften

Sie können eine CAN-Botschaft senden, indem Sie einen neuen Eintrag in einer Sendeliste erzeugen. Verwenden Sie entweder die Sendeliste des Senden/Empfangen-Fensters, oder erzeugen Sie zuerst mit Hilfe des Menübefehls Datei | Neu | Neue Datei eine neue Sendeliste.

Um eine neue CAN-Botschaft zu senden:

  1. Wählen Sie den Befehl Neue Botschaft im Menü Senden, oder drücken Sie die Taste [Einfg] während das Senden/Empfangen-Fenster oder die neue Sendeliste aktiv ist.

  2. In der Dropdownliste Bus wählen Sie den Bus bzw. die Verbindung die Sie verwenden möchten.

  3. Wählen Sie in der Liste Symbole den Eintrag <Benutzerdefinierte Botschaft> aus.

  4. Geben Sie die CAN-ID der neuen Botschaft im Feld ID in hexadezimaler Schreibweise ein.

  5. Wählen Sie im Feld Länge die Anzahl der Datenbytes der neuen Botschaft aus.

  6. Geben Sie in den Feldern Daten die Datenbytes der Botschaft in hexadezimaler Schreibweise ein.

  7. Drücken Sie OK. Die neue CAN-Botschaft wird in die von Ihnen gewählte Sendeliste eingetragen und automatisch selektiert.

  8. Um die Botschaft schließlich zu senden, wählen Sie entweder den Befehl Senden im Menü Senden, oder drücken Sie die Leertaste auf der Tastatur.

Sendebotschaften, die Sie in die Sendeliste des Senden/Empfangen-Fensters eintragen, werden in der Projektdatei gespeichert wenn Sie das Projekt speichern. Wenn Sie das Projekt dann später wieder laden, werden alle zuvor konfigurierten Sendebotschaften automatisch wiederhergestellt.

Falls Sie beabsichtigen, Sendelisten in anderen Projekten wiederzuverwenden, können Sie auch eine separate Sendelisten-Datei erstellen.

Um eine CAN-Botschaft in einer neuen Sendeliste anzulegen:

  1. Wählen Sie im Menü Datei im Untermenü Neu den Befehl Neue Datei.

  2. In der Liste Dateitypen wählen Sie den Typ Sendeliste und drücken Sie OK.

  3. Legen Sie die CAN-Botschaft wie oben beschrieben an..

Siehe auch

Arbeiten mit Sendelisten


Arbeiten mit Sendelisten

Sendelisten können einen Satz von CAN-Botschaften gruppieren, um sie z.B. in verschiedenen Projekten zu verwenden. Ein Projekt kann mehrere Sendelisten enthalten, die Anzahl der gleichzeitig geöffneten Sendelisten ist nicht beschränkt. Botschaften können auch über die Zwischenablage eingefügt werden, oder mittels Drag-and-Drop aus anderen Fenstern.

Information über Symbole wird nicht in Sendelisten gespeichert. Wird eine Sendeliste geöffnet, überprüft PCAN-Explorer welche Symbole zu den Botschaften in der Datei passen.

Um eine neue Sendeliste anzulegen:

  1. Wählen Sie im Menü Datei im Untermenü Neu den Befehl Neue Datei.

  2. In der Liste Dateitypen wählen Sie den Typ Sendeliste und drücken Sie OK.

  3. Fügen Sie CAN-Botschaften zur Sendeliste hinzu, indem Sie im Menü Senden den Befehl Neue Botschaft ausführen.

Um Botschaften in der Sendeliste des Senden/Empfangen-Fensters als Sendelistendatei zu speichern:

  1. Falls das Senden/Empfangen-Fenster nicht sichtbar ist, wählen Sie im Menü Ansicht den Befehl Senden/Empfangen.

  2. Aktivieren Sie das Senden/Empfangen-Fenster und setzen Sie den Eingabefokus in die Sendeliste.

  3. Wählen Sie im Menü Datei den Befehl Speichern.

  4. Wählen Sie den Pfad und den Dateinamen für die neue Sendeliste.

  5. Drücken Sie Speichern.

Um eine gespeicherte Sendeliste zu laden:

  1. Wählen Sie im Menü Datei den Befehl Öffnen.

  2. Wählen Sie die gewünschte Sendelistendatei aus und drücken Sie die Schaltfläche Öffnen.

Siehe auch

Senden von CAN-Botschaften

Standard-Sendeliste


Remote Transmission Request

Ein Remote Transmission Request (RTR) wird von einem CAN-Knoten zur Anforderung von bestimmten Daten in Form eines Remote Request Frames gesendet. Ein anderer CAN-Knoten, der für die Bereitstellung der entsprechenden Daten verantwortlich ist, sendet daraufhin einen Data Frame mit der gleichen CAN-ID als Anwort.

PCAN-Explorer kann automatisch Antworten auf empfangene Remote Request Frames senden.

Um die Verarbeitung von Remote Transmission Requests zu aktivieren:

  1. Wählen Sie im Menü Projekt den Befehl Einstellungen.

  2. Im angezeigten Dialogfenster wählen Sie die Seite CAN.

  3. Aktivieren Sie im Abschnitt Remote Transmission Requests die Option Remote Request Frames verarbeiten.

  4. Drücken Sie OK.

Beantworten von Remote Transmission Requests

Wird eine Remote Request Frame empfangen, überprüft PCAN-Explorer, ob sich entweder in der Sendeliste des Senden/Empfangen-Fensters oder in einer anderen geöffneten Sendeliste eine Botschaft mit der geforderten CAN-ID befindet, die als Antwort auf die Anforderung gesendet werden kann. Trifft dies zu, wird die entsprechende Botschaft gesendet und mit dem Sendegrund (Trigger) RTR markiert.

Diese Einstellung beeinflusst alle CAN-Verbindungen im Projekt.

Hinweis

RTR-Botschaften, die sich in der Sendeliste befinden, werden niemals als Antwort auf empfangene Remote Request Frames gesendet.
Berücksichtigen des Data Length Code

Soll der Data Length Code eines empfangenen Remote Request Frames berücksichtigt werden, deaktivieren Sie die Option Data Length Code ignorieren im Projekteinstellungen-Dialogfenster auf der Seite CAN. Hierdurch wird nach dem Eintreffen eines Remote Request Frames geprüft, ob sich in der Sendeliste Botschaften mit passender CAN-ID und mit der geforderten Anzahl von Datenbytes befinden. Trifft dies zu, wird die entsprechende Botschaft gesendet.

Die Option Data Length Code ignorieren beeinflusst alle CAN-Verbindungen im Projekt.

Siehe auch

CAN, Projekteinstellungen-Dialogfenster


Filtern von Botschaften

Filtern von Botschaften kann beim Aufzeichnen von Botschaften mit einem Tracer, oder zum Anpassen der Anzeige der Empfangsliste nützlich sein. Botschaften können gefiltert werden, indem ein Botschaftsfilter zum Projekt hinzugefügt wird, und dieser dann in der Symbolleiste eines Tracers oder des Senden/Empfangen-Fensters in der Filter-Dropdown-Liste ausgewählt wird.

Ein Botschaftsfilter besteht aus ein oder mehreren Filterelementen, von denen jedes in verschiedenen Betriebsmodi arbeiten kann. So ist es möglich, einen Botschaftsfilter zu konfigurieren, der auch spezielle Filteranforderungen erfüllt.

Um einen Botschaftsfilter zum aktuellen Projekt hinzuzufügen:

  1. Wählen Sie im Menü Verbindungen den Befehl Botschaftsfilter hinzufügen aus, oder drücken Sie die Schaltfläche [image] in der Symbolleiste eines Trace-Fensters oder des Senden/Empfangen-Fensters. Das Filter bearbeiten-Dialogfenster wird angezeigt.

  2. Fügen Sie ein Filterelement hinzu, indem Sie die Schaltfläche Element hinzufügen drücken.

  3. Um das Filterelement zu konfigurieren, wählen Sie den Bus, von dem das Filterelement Botschaften filtern soll, wählen Sie den Typ des Filterelements, und geben Sie optionale Parameter in die Felder im Bereich Details ein.

Hinweis

Wenn ein Filter überprüft, ob eine Botschaft den Filter passieren kann, verarbeitet der Filter die Filterelemente in der Liste von oben nach unten. Wenn ein Filterelement passt und die Bedingung wahr ist, wird die Verarbeitung weiterer Filterelemente abgebrochen. Deshalb beeinflusst die Position eines Filterelements in der Liste das Ergebnis der Filterung.
Hinweis

Enthält ein Filter nur Filterelemente, bei denen die Option Ausschließen aktiviert ist, werden alle anderen Botschaften, die nicht von diesen Filterelementen ausgeschlossen werden, automatisch vom Filter durchgelassen. Dies stellt eine Änderung zu früheren Versionen von PCAN-Explorer dar. Bis einschließlich PCAN-Explorer 5.3.1 musste zusätzlich zu den Ausschluss-Filterelementen mindestens noch ein einschließendes Filterelement definiert werden, damit überhaupt Botschaften den Filter passieren konnten.

Filterelement-Typen

Die einzelnen Elemente eines Botschaftsfilters können einen der folgenden Typen haben.

CAN-ID-Bereich

In diesem Modus fügt das Filterelement einen durchgängigen Bereich von CAN-IDs hinzu, die vom Filter hindurchgelassen werden sollen. Soll nur eine einzelne CAN-ID durchgelassen werden, muss dieselbe CAN-ID in die Felder Öffne Filter von und Bis eingegeben werden.

Wird Modus auf Standard gesetzt, verarbeitet das Filterelement nur 11-Bit-Botschaften. Falls Modus auf Erweitert gesetzt wird, verarbeitet das Filterelement nur 29-Bit-Botschaften.

Wird die Option RTR ausgewählt, verarbeitet das Filterelement nur Remote Transmission Requests.

Wird die Option Ausschließen aktiviert, blockiert das Filterelement den ausgewählten Bereich von CAN-IDs anstatt ihn hindurchzulassen.

SJA1000 Code/Maske

Dieser Modus emuliert den Low-Level Filtermechanismus des SJA1000 CAN-Controllers. Für eine Beschreibung des Arbeitsprinzips und der Bedeutung der Werte für Code und Maske, siehe NXP (vormals Philips) Application Note AN97076, "SJA1000 Stand-alone CAN controller", Abschnitt 4.1.2.

An Symbole anpassen

In diesem Modus können nur die Botschaften den Filter passieren, die eine entsprechende Symboldefinition in der Symboldatei haben, die der Verbindung zugewiesen ist.

An markierte Symbole anpassen

In diesem Modus können nur die Botschaften den Filter passieren, die eine entsprechende Symboldefinition in einer Symboldatei haben, und die explizit mit dem Trace-Schalter markiert sind (-t in einer Symboldatei).

Beispiel:

Symboldatei (FormatVersion 5.0)

[Demo]
ID=123h

DLC=3

Var=Test unsigned 0,8 -t

Falls ein Multiplexer für eine Botschaft definiert wurde, kann der Multiplexer selbst auch markiert werden:

Symboldatei (FormatVersion 5.0)

[Demo]
ID=123h

DLC=3

Mux=Mux1 0,8 1 -t

Var=Test unsigned 8,8

Sobald eine Variable oder ein Multiplexer auf diese Art markiert ist, wird die entsprechende CAN-Botschaft den Botschaftsfilter passieren.

Optionen

Erlaubt zusätzlichen Botschaftstypen, den Filter zu passieren.

Hinweis: Fehlerwarnungen werden niemals im Senden/Empfangen-Fenster angezeigt, auch wenn für ein Filterelement die entsprechende Option aktiviert wurde, und ein Filter der solch ein Element enthält dem Senden/Empfangen-Fenster zugewiesen wurde.

J1939

Diese Modus ist nur verfügbar, wenn das J1939 Add-in geladen ist.

In diesem Modus können Botschaften nach PGN, Priorität, Quelle, Ziel, und jeder Kombination dieser Werte gefiltert werden.

Wird die Option Ausschließen aktiviert, blockiert das Filterelement spezielle Botschaften, so dass diese nicht den Filter passieren können.

Siehe auch

Symboldateien

Signale

Variablen

Optionale Schalter für Signal- und Variablendefinitionen


Anzeigen von Error Frames

Wenn während der Übertragung von Daten-Frames oder Remote Request Frames ein Fehler auftritt, kann jeder Busteilnehmer, sowohl Sender als auch Empfänger, einen Fehler signalisieren. Der CAN-Knoten, der den Fehler signalisiert, zerstört die Botschaft, indem er einen Error Frame sendet. Dies führt dazu, dass der Sender die Botschaft erneut sendet. Bleibt der Busfehler bestehen, kann das ständige Neusenden der Botschaft beträchtlich zur Buslast beitragen.

Deshalb kann die Überwachung von Error Frames sehr nützlich sein, um die "Gesundheit" des Netzwerks zu beurteilen.

Um eine Verbindung für die Anzeige von Error Frames zu konfigurieren:

  1. Wählen Sie eine Verbindung im Verbindungen-Fenster oder im Projekt-Manager, auf der Registerseite Projekt-Elemente.

  2. Navigieren Sie im Eigenschaften-Fenster zu der Eigenschaft Error Frames.

  3. Stellen Sie die den Wert der Eigenschaft Error Frames auf Ja.

Im Verbindungen-Fenster wird jetzt für die gewählte Verbindung in der Spalte Optionen die Option EF angezeigt, und die Empfangsliste zeigt nun alle Error Frames an, die für diese Verbindung auftreten.

Siehe auch

Error Frames in der Empfangsliste


Exportieren von Botschaften

Die CAN-Botschaften in Empfangs- und Sendelisten können in Textdateien oder CSV-Dateien exportiert werden, um diese beispielsweise in Microsoft Excel zu importieren. Der Exportfilter kann flexibel konfiguriert werden, um nur die Daten zu exportieren, die für den Benutzer wichtig sind.

Um CAN-Botschaften zu exportieren:

  1. Bringen Sie das Senden/Empfangen-Fenster in den Vordergrund und selektieren Sie die Liste, die Sie exportieren möchten.

- oder -

Öffnen Sie eine Sendelisten-Datei oder bringen Sie ein Sendelisten-Fenster in den Vordergrund, dessen Daten Sie exportieren möchten.

  2. Wählen Sie im Menü Datei den Befehl Exportieren. Der Befehl ist nur verfügbar, wenn die ausgewählte Botschaftsliste Einträge enthält. Das Dialogfenster Daten exportieren wird angezeigt.

  3. Geben Sie in dem Feld Pfad den Pfad und den Namen der Datei ein, in welche die Daten gespeichert werden sollen.

  4. Wählen Sie aus, ob die Daten in eine Textdatei oder eine CSV-Datei exportiert werden sollen, indem Sie die entsprechende Registerseite anklicken.

  5. Wählen Sie zwischen den verschiedenen Optionen, um die Dateiausgabe an Ihre Bedürfnisse anzupassen.

  6. Drücken Sie OK.

Siehe auch

Daten exportieren-Dialogfenster


Arbeiten mit Symbolen

Arbeiten mit Symbolen

Leitseite (Umgebung)

Eine leistungsfähige Funktion von PCAN-Explorer ist die Möglichkeit, Botschaftsobjekte eines CAN-Busses in symbolischer Form anzuzeigen bzw. symbolische Eingabe von Daten zu erlauben, um die Botschaften in eine leicht verständliche Form zu bringen.

Üblicherweise werden die Werte von verschiedenen Anwendungsvariablen (z.B. Temperatur, Relaispositionen etc.) in einem bestimmten Format übermittelt. Jeder Wert belegt eine eigene Bitgruppe in den Datenbytes der Botschaft. Nur in seltenen Fällen kann der Wert einer Variable direkt aus der hexadezimalen Darstellung einer CAN-Botschaft abgelesen werden. PCAN-Explorer kann die übertragenen Werte aus den Datenbytes extrahieren und zeigt die Variablen mit ihrem Bezeichner und ihren enthaltenen Werten in einer für den Anwender sofort verständlichen Form an.

PCAN-Explorer entnimmt die Definitionen für die symbolische Interpretation der CAN-Botschaften aus Textdateien, sog. "Symboldateien". Diese können sowohl über einen integrierten Texteditor, als auch mit dem eigenständigen PCAN Symbol Editor erstellt und bearbeitet werden. Jeder CAN-Botschaft in dem getesteten Netzwerk kann ein Symbolname zugeordnet werden. Weiterhin können den verschiedenen Bitgruppen in den Datenbytes einer Botschaft Namen und Datenformate zugewiesen werden. Die Information, mit der die Symboldatei erstellt wird, entsteht üblicherweise bereits während der Planung eines CANs.

Symboldateien, die regelmäßig verwendet oder von verschiedenen Projekten verwendet werden, können in der PCAN-Explorer-Bibliothek gespeichert werden. Die Verzeichnisstruktur der Bibliothek kann im Optionen-Dialogfenster auf der Seite Bibliothek konfiguriert werden. Wird PCAN-Explorer das erste Mal gestartet, wird ein Bibliotheksverzeichnis für Symboldateien automatisch im Verzeichnis mit den Dokumenten des aktuellen Benutzers angelegt, und der Pfad auf dieses Verzeichnis wird als das Bibliotheksverzeichnis gespeichert. Außerdem wird eine Beispiel-Symboldatei in dieses Verzeichnis kopiert.

In diesem Abschnitt

Erstellen und Aktivieren von Symboldateien

Beschreibt die Vorgehensweise zum Erstellen einer neuen Symboldatei.

Zuweisen einer Symboldatei zu einer Verbindung

Beschreibt die Vorgehensweise zum Zuweisen einer Symboldatei zu einer Verbindung, so dass Botschaften der Verbindung symbolisch angezeigt werden können.

Öffnen einer Symboldatei aus der Bibliothek

Beschreibt die Vorgehensweise zum Öffnen einer vorhandenen Symboldatei aus der PCAN-Explorer-Bibliothek.

Signale

Beschreibt die Funktionsweise von Signalen und deren Verwendung in PCAN-Explorer.

Überwachen von Signalen

Beschreibt die Vorgehensweise zum Überwachen der Werte ausgewählter Signale.

Weitere Abschnitte

Symboldateien

Enthält die Referenz zu Symboldateien.

Fehlermeldungen von Symboldateien

Enthält alle Fehlermeldungen, die im Umgang mit Symboldateien auftreten können.


Erstellen und Aktivieren von Symboldateien

PCAN-Explorer entnimmt die Definitionen für die symbolische Interpretation der CAN-Botschaften aus den Symboldateien. Diese können entweder mit dem integrierten Texteditor oder mit dem eigenständigen PCAN Symbol Editor erstellt und bearbeitet werden. Die folgenden Prozeduren beschreiben, wie Symboldateien mit dem integrierten Texteditor erstellt, bearbeitet und aktiviert werden können.

Um einen neue Symboldatei zu erstellen und zu aktivieren:

  1. Stellen Sie sicher, dass Sie ein Projekt geöffnet haben und dass Ihr Projekt mindestens eine Verbindung enthält.

  2. Wählen Sie im Menü Datei im Untermenü Neu den Befehl Neue Datei.

  3. Wählen Sie in der Liste Dateitypen den Typ Symboldatei aus.

  4. Es wird eine neue Symboldatei angezeigt, die bereits ein Grundgerüst mit verschiedenen Abschnitten SEND, RECEIVE usw. enthält. Erweitern Sie die Datei mit Ihren Symboldefinitionen.

  5. Wählen Sie im Menü Datei den Befehl Anwenden. Der Anwenden-Befehl ist auch im Kontextmenü des Texteditors verfügbar. Falls die Definitionen der Symbole Fehler enthalten, werden diese im Ausgabe-Fenster und im Texteditor angezeigt. Die Position des Fehlers wird markiert oder die Einfügemarke wird an der entsprechenden Stelle positioniert.

  6. Falls die Symboldatei keine Fehler enthält, wird ein Dialogfenster angezeigt, das zur Auswahl eines Speicherorts für die Datei auffordert. Wählen Sie den Pfad und den Dateinamen, und drücken Sie OK.

  7. Bevor PCAN-Explorer die Symboldatei aktivieren kann, muss sie Teil Ihres Projekts werden. Falls Sie einen Speicherort für die Datei gewählt haben, der außerhalb des Projektverzeichnisses liegt, wird zuerst ein Dialogfenster angezeigt, in dem Sie die weitere Vorgehensweise auswählen können. Wählen Sie, ob Sie die Datei in Ihr Projektverzeichnis kopieren möchten, bevor sie zum Projekt hinzugefügt wird, oder fügen Sie sie direkt vom aktuellen Speicherort hinzu.

  8. Falls Ihr Projekt nur eine Verbindung enthält, wird die Symboldatei automatisch dieser Verbindung zugewiesen. Falls Ihr Projekt mehrere Verbindungen enthält, wird ein Dialogfenster angezeigt, das die Auswahl der Verbindungen ermöglicht, zu denen Sie die Symboldatei zuweisen möchten.

Um eine vorhandene Symboldatei zu ändern und zu aktivieren:

  1. Öffnen Sie die Symboldatei.

  2. Bearbeiten Sie die Datei.

  3. Wählen Sie im Menü Datei den Befehl Anwenden. Der Anwenden-Befehl ist auch im Kontextmenü des Texteditors verfügbar. Falls die Definitionen der Symbole Fehler enthalten, werden diese im Ausgabe-Fenster und im Texteditor angezeigt. Die Position des Fehlers wird markiert oder die Einfügemarke wird an der entsprechenden Stelle positioniert.

  4. Falls die Symboldatei keine Fehler enthält, wird ein Dialogfenster angezeigt, das zur Auswahl eines Speicherorts für die Datei auffordert. Wählen Sie den Pfad und den Dateinamen, und drücken Sie OK.

  5. Bevor PCAN-Explorer die Symboldatei aktivieren kann, muss sie Teil Ihres Projekts werden. Falls Sie einen Speicherort für die Datei gewählt haben, der außerhalb des Projektverzeichnisses liegt, wird zuerst ein Dialogfenster angezeigt, in dem Sie die weitere Vorgehensweise auswählen können. Wählen Sie, ob Sie die Datei in Ihr Projektverzeichnis kopieren möchten, bevor sie zum Projekt hinzugefügt wird, oder fügen Sie sie direkt vom aktuellen Speicherort hinzu.

  6. Falls die Symboldatei noch zu keiner Verbindung zugewiesen ist

  • Falls Ihr Projekt nur eine Verbindung enthält, wird die Symboldatei automatisch dieser Verbindung zugewiesen.

  • Falls Ihr Projekt mehrere Verbindungen enthält, wird ein Dialogfenster angezeigt, das die Auswahl der Verbindungen ermöglicht, zu denen Sie die Symboldatei zuweisen möchten.

Siehe auch

Öffnen einer Symboldatei aus der Bibliothek

Ausgabe-Fenster

Fehlermeldungen von Symboldateien


Zuweisen einer Symboldatei zu einer Verbindung

Bevor PCAN-Explorer CAN-Botschaften einer Verbindung symbolisch darstellen kann, muss eine Symboldatei zu der Verbindung zugewiesen werden.

Um eine Symboldatei einer Verbindung zuzuweisen:

  1. Stellen Sie sicher, dass die Symboldatei, die Sie einer Verbindung zuweisen möchten, bereits zum Projekt hinzugefügt wurde. Falls dies nicht der Fall ist, führen Sie diese Schritte aus, um die Symboldatei in das Projekt aufzunehmen.

  2. Wählen Sie die Verbindung, zu der Sie eine Symboldatei zuweisen möchten, entweder im Projekt-Manager oder im Verbindungen-Fenster aus.

  3. Suchen Sie im Eigenschaften-Fenster die Eigenschaft Symboldatei der Verbindung, und klicken Sie in dieser Zeile in die Werte-Spalte.

  4. Öffnen Sie die Dropdownliste der Werte-Zelle, und wählen Sie die Symboldatei aus, die Sie der Verbindung zuweisen möchten.

Hinweise

Die Dropdownliste der Eigenschaft Symboldatei im Eigenschaften-Fenster zeigt alle Symboldateien an, die das Projekt enthält.

Falls die Verbindung das J1939-Protokoll verwendet, ist die vordefinierte J1939-Symboldatei J1939Default.sym ebenfalls aufgeführt, egal ob diese in Ihrem Projekt enthalten ist oder nicht.

Falls das CANdb Add-in geladen ist und das Projekt auch CANdb Netzwerk Dateien enthält, stehen diese Dateien ebenfalls in der Dropdownliste zur Auswahl bereit.

Siehe auch

Arbeiten mit Symbolen


Öffnen einer Symboldatei aus der Bibliothek

Symboldateien, die regelmäßig verwendet werden, können im Bibliotheksverzeichnis für Symboldateien gespeichert werden. Das Fenster Bibliothek ermöglicht einen schnellen Zugriff auf diese Dateien.

Der Pfad auf das Symboldatei-Verzeichnis der Bibliothek kann im Optionen-Dialogfenster auf der Seite Bibliothek konfiguriert werden.

Um eine Symboldatei aus der Bibliothek zu öffnen:

  1. Wählen Sie im Menü Ansicht den Befehl Bibliothek.

  2. Navigieren Sie im Bibliotheks-Browser zum Knoten Symboldateien.

  3. Klappen Sie den Knoten Symboldateien auf und wählen Sie die Symboldatei aus, die Sie öffnen möchten.

  4. Zeigen Sie das Kontextmenü für die Datei an (erreichbar über die rechte Maustaste) und wählen Sie den Befehl Bearbeiten aus.

Siehe auch

Bibliotheks-Browser

Bibliothek, Optionen-Dialogfenster


Signale

Signale stellen eine einheitliche Schnittstelle für alle Module in PCAN-Explorer dar, um untereinander Werte auszutauschen. Signale können physikalische Größen sein, die über einen CAN-Bus empfangen wurden, sie können aber auch virtuelle Werte sein, ohne jeglichen Bezug zur Außenwelt.

Für einen Benutzer eines Signals darf es keinen Unterschied geben, auf welchem physikalischem Medium das Signal in Wirklichkeit transportiert wird. Ein Signal könnte beispielsweise von einem Add-in zur Verfügung gestellt werden, das seine Werte von einer seriellen Schnittstelle des PCs bezieht oder an sie ausgibt.

Die verfügbaren Signale können im Projekt-Manager auf der Seite Projekt-Elemente angezeigt werden. Das Überwachungen-Fenster kann dazu verwendet werden, um die Werte der Signale zu überwachen.

Variablen als Signale

Variablen, die in Symboldateien definiert sind, werden bei der Aktivierung der Symboldatei automatisch als Signale in der PCAN-Explorer-Umgebung verfügbar. Die Namen der Signale werden dabei aus den Namen der Symboldatei, des jeweiligen Symbols, Multiplexers und der Variablen zusammengesetzt (jeweils durch einen Punkt getrennt). Beispiel:

Symboldatei.RcvSymbol.Mux1.Speed

Dieser so genannte voll qualifizierte Name ist notwendig, da die Namen von Variablen nicht eindeutig sind. Mehrere Variablen von unterschiedlichen Symbolen können den gleichen Namen verwenden.

Die Anzeige der Signale kann jedoch entweder in der voll qualifizierten Form oder in der Kurzform geschehen, wobei im obigen Beispiel nur der Name Speed angezeigt wird. Wie die Signalnamen angezeigt werden sollen, kann im Optionen-Dialogfenster auf der Seite Allgemein eingestellt werden.

Siehe auch

Projekt-Manager

Überwachen von Signalen

Allgemein, Optionen-Dialogfenster


Überwachen von Signalen

Um die Werte von bestimmten Signalen zu überwachen, können Sie die Signale in das Überwachungen-Fenster aufnehmen.

Das Überwachungen-Fenster zeigt ständig die aktuellen Werte der ausgewählten Signale an.

Um ein Signal zu überwachen:

  1. Öffnen Sie das Überwachungen-Fenster, indem Sie im Menü Ansicht den Befehl Überwachungen auswählen.

  2. Wählen Sie im Überwachungen-Fenster eine der Registerkarten Watch aus, in die Sie das Signal aufnehmen möchten.

  3. Öffnen Sie den Projekt-Manager, indem Sie im Menü Ansicht den Befehl Projekt-Manager auswählen.

  4. Zeigen Sie im Projekt-Manager die Registerseite Projekt-Elemente an.

  5. Klappen Sie den Knoten Signale auf und wählen Sie dann das Signal aus, das Sie überwachen möchten.

  6. Öffnen Sie das Kontextmenü (rechte Maustaste) für das Signal und wählen Sie den Befehl Zu Überwachungen hinzufügen, oder ziehen Sie das Signal per Drag-and-Drop mit der Maus in das Überwachungen-Fenster.

- oder-

  1. Zeigen Sie das Überwachungen-Fenster an, indem Sie im Menü Ansicht den Befehl Überwachungen auswählen.

  2. Wählen Sie im Überwachungen-Fenster eine der Registerkarten Watch aus, in die Sie das Signal aufnehmen möchten.

  3. Öffnen Sie im Überwachungen-Fenster dessen Kontextmenü (rechte Maustaste) und wählen Sie den Befehl Signal hinzufügen.

  4. Wählen Sie das Signal aus, das Sie überwachen möchten.

  5. Drücken Sie OK.

- oder-

  1. In der Sende- oder Empfangsliste den Mauszeiger innerhalb der Datenspalte auf einem Variablennamen positionieren.

  2. Drücken Sie die rechte Maustaste und wählen Sie den Befehl Variablenname zu Überwachungen hinzufügen aus.

- oder-

  1. Öffnen Sie eines der Dialogfenster Variablen bearbeiten oder Variablen untersuchen.

  2. Wählen Sie in der Liste der Variablen die gewünschte Variable aus.

  3. Drücken Sie die rechte Maustaste und führen Sie den Befehl Zu Überwachungen hinzufügen aus.

Um Signale aus dem Überwachungen-Fenster zu entfernen:

  1. Wählen Sie im Überwachungen-Fenster die Zeilen mit den Signalen aus, die Sie entfernen möchten.

  2. Drücken Sie entweder die Taste [Entf] auf der Tastatur oder wählen Sie im Kontextmenü den Befehl Löschen.

Um die Reihenfolge der Signale im Überwachungen-Fenster zu verändern:

  1. Wählen Sie im Überwachungen-Fenster die Zeilen aus, die Sie an eine andere Position verschieben möchten.

  2. Drücken Sie eine der Tastenkombinationen [Strg+Pfeil-Rauf] oder [Strg+Pfeil-Runter], oder wählen Sie im Kontextmenü des Überwachungen-Fensters einen der Befehle Nach oben oder Nach unten.

Siehe auch

Überwachungen-Fenster


Arbeiten mit dem Texteditor

Arbeiten mit dem Texteditor

Leitseite (Umgebung)

Beim Arbeiten mit PCAN-Explorer trifft man auf verschiedene Arten von Textdateien, die mit Hilfe des integrierten Texteditors verwaltet, bearbeitet und ausgedruckt werden können.

Je nachdem, welche Art von Text bzw. welche Programmiersprache bearbeitet wird, unterstützt der Editor den Benutzer, indem er bekannte Schlüsselwörter und andere syntaktische Elemente mit verschiedenen Farben hervorhebt.

Es bestehen mehrere Möglichkeiten, den Texteditor anzuzeigen:

  • Im Projekt-Manager, indem eine Datei auf der Registerseite Projektdateien ausgewählt wird, und dann im Kontextmenü der Datei der Befehl Öffnen aufgerufen wird.

  • Im Fenster Bibliothek, indem z.B. eine Symboldatei ausgewählt wird und dann im Kontextmenü der Datei der Befehl Bearbeiten aufgerufen wird.

  • Im Menü Datei, indem einer der Befehle Neu | Neue Datei oder Öffnen ausgewählt wird.

In diesem Abschnitt

Merkmale des Texteditors

Beschreibt die Merkmale und Fähigkeiten des Texteditors.

Ändern und Auswählen von Text

Beschreibt das grundlegende Bearbeiten von Text.

Drag-and-Drop von Text

Beschreibt das Bewegen und Kopieren von Text mittels Drag-and-Drop.

Suchen von Text

Erklärt die Verwendung des Suchen-Dialogfensters zum Suchen von Text in Texteditor-Fenstern.

Anpassen des Texeditors und seiner Optionen

Beschreibt die verschiedenen Möglichkeiten, die Textanzeige und das Verhalten des Texteditors anzupassen.

Anpassen der Syntax-Hervorhebung

Beschreibt die Funktionsweise und Anpassung der Syntax-Hervorhebung in Texteditor-Fenstern.

Lesezeichen

Erläutert die Verwendung von Lesezeichen.


Merkmale des Texteditors

Der Texteditor hat folgende Merkmale und Fähigkeiten:

  • Anpassbare Syntax-Hervorhebung: Schlüsselwörter und andere syntaktische Elemente des Textes werden in Abhängigkeit der Programmiersprache eingefärbt. Die verwendeten Farben können für jedes Element beliebig geändert werden. Für weitere Informationen siehe Anpassen der Syntax-Hervorhebung.

  • Drag-and-Drop von Text: Markierte Textstellen können innerhalb des Editors einfach über Drag-and-Drop verschoben werden. Siehe auch Drag-and-Drop von Text.

  • Mehrfaches Zurücknehmen und Wiederherstellen von Eingaben: Bis zu 256 Eingaben können im Texteditor rückgängig gemacht und wiederhergestellt werden.

  • Zeilennummerierung: Für jede der unterstützten Programmiersprachen können unabhängig Zeilennummern eingeblendet werden. Siehe auch Texteditor, Optionen-Dialogfenster.

  • Lesezeichen: Bis zu 10 Lesezeichen können in einem Textfenster definiert werden, um die Navigation innerhalb längerer Texte zu vereinfachen. Siehe auch Lesezeichen.

  • Anpassbare Schriftarten und -größen: Die Schriftart, die im Editor verwendet wird, kann geändert werden, ebenso wie deren Größe. Sie auch Schriftarten und Farben, Optionen-Dialogfenster.

  • Automatisierung des Editors mittels VBS-Makros: Mit Hilfe von VBS-Makros kann die Funktionalität des Texteditors beliebig erweitert werden. Durch Zuweisen von Tastenkombinationen kann dann direkt auf die eigenen Funktionen zugegriffen werden. Für weitere Information siehe VBScript-Makros.


Ändern und Auswählen von Text

Das Editieren von Text funktioniert auf die gleiche Weise wie bei anderen Texteditoren oder Textverarbeitungsprogrammen in Microsoft Windows.

Um Text anzuhängen oder einzufügen:

  1. Klicken Sie entweder mit der Maus an die gewünschte Stelle im Dokument oder bewegen Sie die Einfügemarke mit der Tastatur an die Stelle.

  2. Geben Sie den Text ein.

Wenn sich die Einfügemarke zwischen existierenden Zeichen befindet, wird der Text zwischen diesen Zeichen eingefügt.

Um Zeichen in einer Zeile zu überschreiben, muss die Taste [Einfg] gedrückt werden, um den Editor in den Überschreiben-Modus zu bringen. Der Überschreiben-Modus ist aktiv, wenn die Einfügemarke ein blinkender Block ist und die Statuszeile des Textfensters den Indikator Überschreiben anzeigt. Ein erneutes Drücken der Taste [Einfg] wechselt zurück in den Einfügemodus.

Um Zeichen in einer Zeile zu löschen:

  1. Platzieren Sie die Einfügemarke unmittelbar vor dem Zeichen, das Sie löschen möchten.

  2. Drücken Sie die Taste [Entf] so oft, bis alle Zeichen gelöscht sind.

- oder -

Platzieren Sie die Einfügemarke hinter den zu löschenden Zeichen und drücken Sie die Rücktaste.

Hinweis

Um ein ganzes Wort zu löschen, können Sie dieses durch einen Doppelklick mit der Maus selektieren. Anschließend drücken Sie entweder die Taste [Entf] oder die Rücktaste.

- oder -

Platzieren Sie die Einfügemarke hinter dem zu löschenden Wort und halten Sie die Taste [Strg] gedrückt während Sie die Rücktaste betätigen.

Um Zeilen oder Absätze zu löschen:

  1. Selektieren Sie den zu löschenden Text, indem entweder die linke Maustaste gedrückt gehalten und die Maus über den Text bewegt wird, oder indem Sie die Umschalttaste zusammen mit einer der Pfeiltasten bzw. den Tasten [Pos1], [Ende], [Bild-rauf], [Bild-runter] drücken.

  2. Drücken Sie die Taste [Entf] oder die Rücktaste.

Sie können auch Text ausschneiden und kopieren, oder per Drag-and-Drop im Dokument verschieben oder kopieren. Für weitere Information siehe Drag-and-Drop von Text.

Auswählen von Text

Der Texteditor hat zwei Auswahlmodi:

  • Normaler Modus: Die Auswahl arbeitet wie im Editor von Windows. Die Selektion ist eine durchgängige Zeichenkette. Ganze Zeilen werden selektiert, wenn man sich zu einer nächsten oder vorherigen Zeile bewegt.

  • Blockmodus: Rechteckige Bereiche von Text können selektiert werden. Dies geschieht, wenn man beim ziehen des Mauszeigers über einen Bereich zusätzlich zur linken Maustaste die Taste [Alt] auf der Tastatur gedrückt hält.

Um Text im normalen Modus auszuwählen:

  • Klicken Sie mit der linken Maustaste in den Text, halten Sie die Maustaste gedrückt und bewegen sie über den Text.

- oder-

  • Verwenden Sie die Umschalttaste in Kombination mit den Pfeiltasten.

Um Text im Blockmodus auszuwählen:

  • Halten Sie die Taste [Alt] gedrückt, während Sie mit der linken Maustaste in den Text klicken. Halten Sie die Maustaste gedrückt und bewegen Sie die Maus über den Text.

- oder-

  • Verwenden Sie die Tasten [Umsch] und [Alt] in Kombination mit den Pfeiltasten.

Siehe auch

Arbeiten mit dem Texteditor

Drag-and-Drop von Text


Drag-and-Drop von Text

Sie können Text selektieren, um ihn dann mittels Drag-and-Drop an eine andere Stelle zu verschieben oder zu kopieren.

Um Text mittels Drag-and-Drop zu bewegen:

  1. Wählen Sie den zu bewegenden Text aus, wahlweise mit der Maus oder der Tastatur.

  2. Drücken und halten Sie die linke Maustaste auf dem ausgewählten Text.

  3. Bewegen Sie die Maus zu der Stelle, an welcher der Text eingefügt werden soll.

  4. Lassen Sie die Maustaste los.

Wenn der Text gezogen wird, wird er verschoben, d.h. er wird an der alten Stelle gelöscht und an der neuen Stelle eingefügt. Wird zusätzlich vor dem Loslassen der linken Maustaste die Taste [Strg] gedrückt gehalten, wird an der gewünschten Stelle eine Kopie des selektierten Textes eingefügt.

Siehe auch

Arbeiten mit dem Texteditor

Ändern und Auswählen von Text


Suchen von Text

Das Suchen-Dialogfenster kann zum Suchen von Text innerhalb eines Texteditor-Fensters verwendet werden.

Um nach Text zu suchen:

  1. Wählen Sie im Menü Bearbeiten den Befehl Suchen.

  2. Geben Sie in das Feld Text suchen den gesuchten Text ein.

  3. Aktivieren Sie die Option Groß-/Kleinschreibung beachten, wenn dies beim Suchen nach Text gewünscht ist.

  4. Aktivieren Sie die Option Ganze Wörter, wenn nur nach ganzen Worten und nicht nach Wortausschnitten gesucht werden soll.

  5. Legen Sie im Feld Richtung die Suchrichtung fest.

  6. Drücken Sie OK.

Die erste gefundene Textstelle wird im Texteditor markiert. Möchten Sie von dieser Position aus weitersuchen, wählen Sie den Befehl Weitersuchen im Menü Bearbeiten oder drücken Sie [F3]. Sie können so lange weitersuchen, bis entweder das Ende oder der Anfang der Datei erreicht wurde. Wenn nicht mehr weitergesucht werden kann, wird eine Meldung in der Statuszeile angezeigt. Drücken von [Umsch+F3] setzt die Suche auch fort, aber immer in Richtung Textanfang.

Siehe auch

Suchen-Dialogfenster

Arbeiten mit dem Texteditor


Anpassen des Texteditors und seiner Optionen

Um das Aussehen und Verhalten des Texteditors anzupassen, wählen Sie im Menü Werkzeuge den Befehl Optionen. Alle Optionen des Texteditors können Sie auf der Seite Texteditor konfigurieren.

Für | Siehe
Anpassen von Schriftart, Schriftgröße und Farben | Schriftarten und Farben, Optionen-Dialogfenster
Anpassen der Syntax-Hervorhebung | Anpassen der Syntax-Hervorhebung
Erzeugen von Tastenkombinationen für den Texteditor | Tastatur, Optionen-Dialogfenster
Anpassen anderer Texteditor-Optionen | Texteditor, Optionen-Dialogfenster

Siehe auch

Arbeiten mit dem Texteditor


Anpassen der Syntax-Hervorhebung

Die Syntax-Hervorhebung des Texteditors verwendet unterschiedliche Farben für verschiedene Elemente des Quellcodes, wie beispielsweise Schlüsselwörter und Kommentare. Diese Hervorhebung erleichtert die visuelle Übersicht über die Struktur und den Zustand des Quellcodes.

Die Syntax-Hervorhebung basiert auf der jeweiligen (Programmier-)Sprache des Quellcodes. Der Texteditor unterstützt die Syntax von folgenden Sprachen:

  • Symboldateien

  • Standardmakros

  • VBS-Makros

Der Texteditor erkennt die Sprache des Quellcodes anhand der Dateinamenerweiterung.

Um die Syntax-Hervorhebung anzupassen:

  1. Wählen Sie im Menü Werkzeuge den Befehl Optionen.

  2. Zeigen Sie die Seite Schriftarten und Farben an.

  3. Wählen Sie in der Dropdownliste Zeige Einstellungen für das Element Text-Editor.

  4. Wählen Sie in der Liste Anzeigeelement das Element das Sie ändern möchten.

  5. Wählen Sie in den Feldern Element-Vordergrundfarbe und Element-Hintergrundfarbe die Farben für das Element aus.

  6. Drücken Sie OK.

Hinweis

Das Verhalten der Einstellung Automatisch hängt von dem ausgewählten Element ab. Für Farben, die von Standard-Systemfarben bestimmt werden (wie z.B. Vordergrundfarbe, Hintergrundfarbe oder Textauswahlfarbe), bewirkt die Auswahl von Automatisch, dass das Element mit der entsprechende Systemfarbe angezeigt wird. Bei Elementen der Syntaxhervorhebung und anderer nicht vom System vorgegebenen Farben bewirkt die Auswahl von Automatisch, dass die Vordergrundfarbe oder Hintergrundfarbe vom Element Text bestimmt wird.

Siehe auch

Schriftarten und Farben, Optionen-Dialogfenster


Lesezeichen

Sie können Lesezeichen im Texteditor setzen, um regelmäßig verwendete Stellen im Quellcode zu markieren. Wenn ein Lesezeichen gesetzt ist, können Sie Menü- oder Tastaturkommandos verwenden, um zu diesem Lesezeichen zu springen. Wenn ein Lesezeichen nicht länger benötigt wird, kann es wieder entfernt werden.

Um ein Lesezeichen zu setzen:

  1. Die Einfügemarke in der Zeile positionieren, die mit einem Lesezeichen versehen werden soll.

  2. Im Kontextmenü im Eintrag Lesezeichen umschalten einen der Befehle Lesezeichen 0 bis Lesezeichen 9 auswählen.

- oder -

Eine der Tastenkombinationen [Umsch+Strg+0] bis [Umsch+Strg+9] drücken.

Das Lesezeichen wird in der ausgewählten Zeile gesetzt und im linken Rand des Textfensters angezeigt.

Um zu einem Lesezeichen zu springen:

  • Im Kontextmenü im Eintrag Gehe zu Lesezeichen einen der Befehle Lesezeichen 0 bis Lesezeichen 9 auswählen. Es haben nur diejenigen Lesezeichen eine Wirkung, die vorher gesetzt wurden. Dies wird mit einem Haken vor dem jeweiligen Lesezeichen angezeigt.

- oder -

Eine der Tastenkombinationen [Strg+0] bis [Strg+9] drücken.

Die Einfügemarke wird anschließend in der Zeile mit dem Lesezeichen positioniert. Wenn nötig, wird der sichtbare Ausschnitt des Quellcodes verschoben, um das Lesezeichen sichtbar zu machen.

Um ein Lesezeichen zu löschen:

  1. Im Kontextmenü im Eintrag Gehe zu Lesezeichen einen der Befehle Lesezeichen 0 bis Lesezeichen 9 auswählen, das gelöscht werden soll.

  2. Im Kontextmenü im Eintrag Lesezeichen umschalten einen der Befehle Lesezeichen 0 bis Lesezeichen 9 auswählen, das gelöscht werden soll.


Aufzeichnen von CAN-Botschaften

Aufzeichnen von CAN-Botschaften

Leitseite (Umgebung)

Um die Aktivitäten auf einem CAN-Bus aufzeichnen und später untersuchen zu können, ist in PCAN-Explorer ein vielseitiger Tracer (Datenlogger) integriert. Der Tracer zeichnet alle CAN-Botschaften, Remote Transmission Requests, Bus-Statusänderungen, Error Frames und auch Änderungen von Fehlerzählern der verbundenen CAN-Controller auf. Jedem Tracer kann ein Botschaftsfilter zugewiesen werden, der die aufgezeichneten Elemente bestimmt.

Der Datenpuffer des Tracers kann in verschiedenen Modi arbeiten. Die verfügbaren Puffertypen sind in folgender Tabelle aufgeführt.

Puffertyp | Beschreibung
Linear | Der Puffer hat eine feste Größe (einstellbar in Anzahl Einträge). Wenn der Puffer voll ist, wird die Aufzeichnung angehalten. Die aufgezeichneten Daten werden im Arbeitsspeicher abgelegt.
Ring | Der Puffer hat eine feste Größe (einstellbar in Anzahl Einträge). Wenn der Puffer voll ist, wird der älteste Eintrag überschrieben. Die aufgezeichneten Daten werden im Arbeitsspeicher abgelegt.
Dynamisch | Die Größe des Puffers wächst mit der Anzahl der aufgezeichneten Einträge. Die aufgezeichneten Daten werden im Arbeitsspeicher abgelegt.
Datei | Die aufgezeichneten Daten werden direkt in eine Datei geschrieben, deren Größe mit der Anzahl der Einträge wächst.

Bei Verwendung der Puffertypen Linear, Ring oder Dynamisch werden die Daten während der Aufzeichnung zunächst im Arbeitsspeicher des PCs abgelegt, und können dann in einer Datei gespeichert werden. Um die aufgezeichneten Daten später zu untersuchen, können gespeicherte Trace-Dateien wieder geladen werden. Weiterhin können die Daten in Textdateien oder CSV-Dateien exportiert werden.

In diesem Abschnitt

Starten einer Aufzeichnung

Beschreibt die Vorgehensweise zum Starten einer neuen Aufzeichnung.

Unterbrechen oder Stoppen einer Aufzeichnung

Beschreibt die verschiedenen Methoden, um ein Aufzeichnung zu unterbrechen.

Anzeigen von Variablen im Trace-Fenster

Beschreibt die Vorgehensweise zur symbolischen Anzeige der aufgezeichneten CAN-Botschaften.

Exportieren von aufgezeichneten Daten

Beschreibt die Vorgehensweise zum Exportieren von aufgezeichneten Daten in Textdateien oder CSV-Dateien.

Weitere Abschnitte

Tracer-Elemente

Enthält die Referenz zu Elementen der Benutzeroberfläche bezüglich des Tracers.


Starten einer Aufzeichnung

Da die Möglichkeit besteht, mehrere Trace-Fenster gleichzeitig in der Benutzeroberfläche zu öffnen, gibt es verschiedene Optionen, eine Aufzeichnung zu starten.

Zum Starten einer Aufzeichnung, wenn noch kein Trace-Fenster geöffnet ist:

  1. Wählen Sie Im Menü Trace den Befehl Neuen Tracer starten aus, oder drücken die Schaltfläche [image] in der Symbolleiste des PCAN-Explorer Hauptfensters.

- oder-

  1. Wählen Sie im Menü Datei den Befehl Neue Datei aus dem Untermenü Neu.

  2. Wählen Sie im Dialogfenster Neue Datei den Dateityp Trace-Datei aus und drücken Sie OK.

  3. Klicken Sie in der Symbolleiste des neuen Trace-Fensters auf die Schaltfläche [image].

Zum Starten einer Aufzeichnung in einem bereits geöffneten Trace-Fenster:

  • Klicken Sie in der Symbolleiste des Trace-Fensters auf die Schaltfläche [image].

Sie können auch alle geöffneten Tracer auf einmal starten, indem Sie im Menü Trace den Befehl Alle Tracer starten auswählen oder die Tastenkombination [Umsch+F9] drücken.

Wird die Aufzeichnung in einem Tracer gestartet, der bereits aufgezeichnete Daten in seinem Puffer enthält, und der sich im Zustand Gestoppt befindet, wird in Abhängigkeit des Puffertyps des Tracers eine der folgenden Aktionen ausgeführt:

  • Puffertyp Dynamisch, Linear oder Ring: Der alte Pufferinhalt wird gelöscht.

  • Puffertyp Datei: Die bisherige Trace-Datei wird am aktuellen Speicherort in den Unterordner "_backups" kopiert. Falls das Verzeichnis nicht existiert, wird es angelegt. Anschließend wird das Original überschrieben.

Siehe auch

Unterbrechen oder Stoppen einer Aufzeichnung

Trace-Fenster

Tracer, Optionen-Dialogfenster


Unterbrechen oder Stoppen einer Aufzeichnung

Eine Aufzeichnung kann entweder temporär unterbrochen oder vollständig angehalten werden. Eine unterbrochene Aufzeichnung kann später fortgesetzt werden, wobei der bisherige Pufferinhalt erhalten bleibt.

Um eine Aufzeichnung zu unterbrechen:

  • Klicken Sie in der Symbolleiste des Trace-Fensters auf die Schaltfläche [image].

Sie können auch alle geöffneten Tracer auf einmal unterbrechen, indem Sie im Menü Trace den Befehl Alle Tracer unterbrechen auswählen.

Um eine Aufzeichnung zu stoppen:

  • Klicken Sie in der Symbolleiste des Trace-Fensters auf die Schaltfläche [image].

Sie können auch alle geöffneten Tracer auf einmal anhalten, indem Sie im Menü Trace den Befehl Alle Tracer stoppen auswählen oder die Tastenkombination [Umsch+F6] drücken.

Siehe auch

Starten einer Aufzeichnung


Anzeigen von Variablen im Trace-Fenster

Während einer Aufzeichnung werden im Trace-Fenster nur die Datenbytes der CAN-Botschaften angezeigt, auch wenn für eine Botschaft eine Symboldefinition in einer aktiven Symboldatei vorhanden ist. Da für ein Symbol viele Variablen definiert werden können, ist eine symbolische Darstellung innerhalb des Trace-Fensters aus Platzgründen nahezu unmöglich.

Wurde für eine CAN-Botschaft ein passendes Symbol erkannt, wird der Name des Symbols in der Spalte ID angezeigt. In diesem Fall sind auch Variablen verfügbar. Die Werte der Variablen können dann angezeigt werden, wenn die Aufnahme zeitweilig unterbrochen oder ganz angehalten wird.

Um die Werte von Variablen einer symbolischen CAN-Botschaft anzuzeigen:

  1. Wählen Sie das Trace-Fenster aus, in dem Sie Variablen untersuchen wollen.

  2. Unterbrechen oder stoppen Sie die Aufzeichnung in dem ausgewählten Tracer.

  3. Bringen Sie die Botschaft, die Sie untersuchen wollen, in den sichtbaren Bereich, indem Sie die Bildlaufleiste des Trace-Fensters bewegen.

  4. Bewegen Sie den Mauszeiger in der Spalte Daten auf die Datenbytes der CAN-Botschaft, die Sie untersuchen wollen.

  5. Ein Hinweisfenster wird angezeigt, das alle Variablen und deren Werte enthält.

Falls Sie Botschaftsdaten untersuchen möchten, ohne die Aufzeichnung zu unterbrechen, verwenden Sie entweder das Überwachungen-Fenster oder die Empfangsliste.

Siehe auch

Trace-Fenster, Optionen-Dialogfenster

Übewachen von Signalen

Überwachungen-Fenster


Exportieren von aufgezeichneten Daten

Die vom Tracer aufgezeichneten Daten können in Textdateien oder CSV-Dateien exportiert werden, um diese beispielsweise in Microsoft Excel zu importieren. Der Exportfilter kann flexibel konfiguriert werden, um nur die Daten zu exportieren, die für den Benutzer wichtig sind.

Um aufgezeichnete Daten zu exportieren:

  1. Öffnen Sie eine Trace-Datei oder bringen Sie ein bereits geöffnetes Trace-Fenster in den Vordergrund, dessen Daten Sie exportieren möchten.

  2. Wählen Sie im Menü Datei den Befehl Exportieren. Der Befehl ist nur verfügbar, wenn das ausgewählte Trace-Fenster Daten enthält. Das Dialogfenster Daten exportieren wird angezeigt.

  3. Geben Sie in dem Feld Pfad den Pfad und den Namen der Datei ein, in welche die Daten gespeichert werden sollen.

  4. Wählen Sie aus, ob die Daten in eine Textdatei oder eine CSV-Datei exportiert werden sollen, indem Sie die entsprechende Registerseite anklicken.

  5. Wählen Sie zwischen den verschiedenen Optionen, um die Dateiausgabe an Ihre Bedürfnisse anzupassen.

  6. Drücken Sie OK.

Siehe auch

Daten exportieren-Dialogfenster

Aufzeichnen von CAN-Botschaften


PCAN-Explorer anpassen

PCAN-Explorer anpassen

Leitseite (Umgebung)

Sie können verschiedene Aspekte bezüglich des Layouts und der Bedienung von PCAN-Explorer anpassen.

In diesem Abschnitt

Anpassen von Schriftarten, -größen und -farben

Anweisungen, um die Schriftarten und Farben anzupassen, die in den verschiedenen Fenstern von PCAN-Explorer verwendet werden.

Anpassen des the Texteditors und seiner Optionen

Möglichkeiten, um das Erscheinungsbild des Texteditors und des von ihm angezeigten Texts zu ändern.

Anpassen von Tastenkombinationen

Anweisungen zum Erstellen von eigenen Tastenkombinationen für häufig verwendete Befehle.

Anpassen des Werkzeuge-Menüs

Details über das Hinzufügen, Ändern und Löschen von Werkzeugen im entsprechenden Menü.

Andere Anpassungsmöglichkeiten

Weitere Möglichkeiten, die Umgebung anzupassen, z.B. mit Add-in oder Makros.

Weitere Abschnitte

Verwaltung von Fenstern

Beschreibung der verschiedenen Fenstertypen und der Vorgehensweise zum Anpassen des Layouts von Fenstern.


Anpassen von Schriftarten, -größen und -farben

Sie können die Schriftarten, die Schriftgrößen und verwendete Farben für jedes PCAN-Explorer-Fenster anpassen.

Um eine Schriftart, Schriftgröße oder Farbe zu ändern:

  1. Wählen Sie im Menü Werkzeuge den Befehl Optionen.

  2. Zeigen Sie die Seite Schriftarten und Farben an.

  3. Wählen Sie in der Dropdownliste Zeige Einstellungen für das Element Text-Editor.

  4. Wählen Sie in der Liste Anzeigeelement das Element das Sie ändern möchten.

  5. Wählen Sie eine Schrift in der Dropdownliste Schriftart aus.

  6. Wählen Sie die Schriftgröße im Feld Größe.

  7. Wählen Sie in den Feldern Element-Vordergrundfarbe und Element-Hintergrundfarbe die Farben für das Element aus.

  8. Klicken Sie auf OK.

Hinweis

Das Verhalten der Einstellung Automatisch hängt von dem ausgewählten Element ab. Für Farben, die von Standard-Systemfarben bestimmt werden (wie z.B. Vordergrundfarbe, Hintergrundfarbe oder Textauswahlfarbe), bewirkt die Auswahl von Automatisch, dass das Element mit der entsprechende Systemfarbe angezeigt wird. Bei Elementen der Syntaxhervorhebung und anderer nicht vom System vorgegebenen Farben bewirkt die Auswahl von Automatisch, dass die Vordergrundfarbe oder Hintergrundfarbe vom Element Text bestimmt wird.

Die Einstellungen für Schriften und Farben beeinflussen alle in der PCAN-Explorer Benutzeroberfläche geöffneten Fenster. Für einige Fenster, wie z.B. das Trace-Fenster, werden bei der Auswahl der Schriftart nur die auf dem System installierten Schriftarten mit konstanter Zeichenbreite angeboten.

Siehe auch

PCAN-Explorer anpassen

Schriftarten und Farben, Optionen-Dialogfenster


Anpassen von Tastenkombinationen

Tastenkombinationen bieten Anwendern, welche die Benutzung der Tastatur der Maus vorziehen, eine alternative Methode, um Befehle auszuführen. In PCAN-Explorer kann man:

  • eine Liste aller aktuellen Tastenkombinationen anzeigen

  • zugewiesene Tastenkombinationen löschen

  • per Voreinstellung zugewiesene Tastenkombinationen ändern

  • Tastenkombinationen solchen Befehlen zuweisen, die standardmäßig keine entsprechende Zuweisung haben.

Durch neue Zuweisungen kann sich jeder Anwender seinen eigenen Satz von Tastenkombinationen erstellen, die seiner gewohnten Arbeitsweise entsprechen, oder die leichter im Gedächtnis behalten werden können.

Was möchten Sie tun?

  • Eine Tastenkombination zuweisen

  • Eine Tastenkombination löschen

  • Alle Tastenkombinationen auf ihre Standardwerte zurücksetzen

  • Eine Liste von aktuellen Tastenkombinationen anzeigen

Um eine Tastenkombination zuzuweisen:

  1. Wählen Sie im Menü Werkzeuge den Befehl Optionen und zeigen Sie dann die Seite Tastatur an.

  2. Wählen Sie in der Dropdownliste Kategorie die Kategorie aus, die den Befehl enthält, dem Sie eine Tastenkombination zuweisen wollen.

  3. Wählen Sie den Befehl in der Liste Befehle aus, dem Sie eine Tastenkombination zuweisen wollen.

  4. Klicken Sie in das Feld Drücke neue Tastenkombination.

  5. Drücken Sie die Taste oder Tastenkombination, die Sie möchten.

  6. Klicken Sie auf Zuweisen.

Wird eine ungültige Tastenkombination betätigt, wird keine Taste angezeigt. Sie können keine Tastenkombination mit [F1] wählen, oder Kombinationen wie [Strg+Alt+Entf], die bereits vom Betriebssystem verwendet werden.

Wenn Sie eine Taste oder Tastenkombination betätigen, die bereits zu einem anderen Befehl zugewiesen ist, erscheint dieser Befehl unter Momentan zugewiesen zu.

Um eine Tastenkombination zu löschen:

  1. Wählen Sie im Menü Werkzeuge den Befehl Optionen und zeigen Sie dann die Seite Tastatur an.

  2. Wählen Sie in der Dropdownliste Kategorie die Kategorie aus, die den Befehl enthält, dessen Tastenkombination Sie löschen wollen.

  3. Klicken Sie auf Entfernen.

Um alle Tastenkombinationen auf ihre Standardwerte zurückzusetzen:

  1. Wählen Sie im Menü Werkzeuge den Befehl Optionen und zeigen Sie dann die Seite Tastatur an.

  2. Klicken Sie auf Alle zurücksetzen.


Anpassen des Werkzeuge-Menüs

Sie können Einträge zum Menü Werkzeuge hinzufügen, um externe Werkzeuge aus PCAN-Explorer zu starten. Beispielsweise können Sie Einträge hinzufügen, um Hilfsprogramme wie das PCAN Status Display oder PCAN Nets Configuration zu starten.

Bis zu 16 Befehle können zum Menü Werkzeuge hinzugefügt werden. Für jeden hinzugefügten Befehl können Sie Aufrufparameter zuweisen.

Was möchten Sie tun?

  • Einen Befehl zum Menü Werkzeuge hinzufügen

  • Einen Befehl im Menü Werkzeuge bearbeiten

  • Einen Befehl aus dem Menü Werkzeuge entfernen

  • Variablen an ein Werkzeug übergeben

Um einen Befehl zum Menü Werkzeuge hinzuzufügen:

Als ein Beispiel wird in der folgenden Prozedur das Windows Zubehör "Editor" zum Menü Werkzeuge hinzugefügt.

  1. Wählen Sie im Menü Werkzeuge den Befehl Externe Werkzeuge.

  2. Klicken Sie auf die Schaltfläche Hinzufügen. Ein neuer Eintrag erscheint in der Liste Menü-Inhalt.

  3. Geben Sie im Feld Titel den Namen des Werkzeugs ein, wie es im Menü Werkzeuge erscheinen soll.

Möchten Sie beispielsweise einen Befehl für den Windows Editor hinzufügen, könnten Sie Editor eingeben. Die verbleibenden Schritte legen fest, welche Aktion ausgeführt wird, wenn der Befehl Editor ausgewählt wird.

Tipp

Geben Sie ein kaufmännisches Und-Zeichen (&) vor einem der Buchstaben im Werkzeugnamen ein, um ein Schnellzugriffstaste für den Befehl zu definieren. Wenn Sie zum Beispiel den Namen "Mein &Werkzeug" verwenden, wird der Buchstabe 'W' zur Schnellzugriffstaste.

  4. Geben Sie im Feld Befehl den Pfad und den Pfad und Dateinamen des Programms ein, beispielsweise C:\Windows\Notepad.exe.

  5. Geben Sie im Textfeld Argumente beliebige Argumente ein, die an das Programm übergeben werden sollen.

Sie können auch die Schaltfläche neben dem Textfeld Argumente verwenden, um ein Menü mit Argumenten anzuzeigen. Wählen Sie ein Argument aus der Liste, um ein Argument-Makro in das Textfeld Argumente einzufügen. Alle in PCAN-Explorer verfügbaren Argument-Makros sind in der Argument-Makros Tabelle aufgeführt.

  6. Geben Sie im Feld Arbeitsverzeichnis das Verzeichnis ein, das dem Programm als Arbeitsverzeichnis dienen soll.

Sie können auch die Schaltfläche neben dem Feld Arbeitsverzeichnis verwenden, um ein Menü mit Verzeichnissen anzuzeigen. Wählen Sie ein Verzeichnis aus der Liste, um ein Verzeichnis-Makro in das Feld Arbeitsverzeichnis einzufügen.

  7. Aktivieren Sie die Option Nach Argumenten fragen, falls Sie beim Ausführen des Befehls die Möglichkeit zum Bearbeiten der Aufrufargumente erhalten möchten.

  8. Drücken Sie OK.

Um einen Befehl aus dem Menü Werkzeuge zu bearbeiten:

  1. Wählen Sie im Menü Werkzeuge den Befehl Externe Werkzeuge.

  2. Wählen Sie in der Liste Menü-Inhalt den Befehl, den Sie bearbeiten möchten.

  3. Führen Sie eine oder mehrere der folgenden Aktionen:

  • Um den Befehl eine Position nach oben zu schieben, drücken Sie die Schaltfläche Nach oben.

  • Um den Befehl eine Position nach unten zu schieben, drücken Sie die Schaltfläche Nach unten.

  • Um den Menütext, die Kommandozeile (Pfad und Dateiname), Kommandozeilenargumente oder das Arbeitsverzeichnis zu ändern, geben Sie die neue Information in das entsprechende Textfeld ein.

  • Um einen Buchstaben im Menütext als Schnellzugriffstaste festzulegen, stellen Sie dem entsprechenden Buchstaben im Feld Titel ein Und-Zeichen (&) voran.

Um einen Befehl aus dem Menü Werkzeuge zu entfernen:

  1. Wählen Sie im Menü Werkzeuge den Befehl Externe Werkzeuge.

  2. Wählen Sie in der Liste Menü-Inhalt den Befehl, den Sie entfernen möchten und drücken Sie die Schaltfläche Löschen.

Siehe Auch

Externe Werkzeuge-Dialogfenster


Übergeben von Variablen an externe Werkzeuge

Man kann bestimmte Informationen an ein Werkzeug übergeben, wenn man das Werkzeug startet, z.B. Kommandozeilenschalter für Konsolenanwendungen. Es können auch Argumente an Werkzeuge übergeben werden. Argumente sind Variablen, die PCAN-Explorer automatisch mit Werten füllt, wenn das Werkzeug aus dem Werkzeuge-Menü startet.

Um Variablen an ein Werkzeug zu übergeben:

  1. Im Menü Werkzeuge den Befehl Externe Werkzeuge auswählen.

  2. In der Liste Menü-Inhalt das Werkzeug auswählen, an das eine Variable übergeben werden soll.

  3. Im Textfeld Argumente die Argumente eingeben, die an das Werkzeug übergeben werden sollen, oder neben dem Textfeld die Schaltfläche mit dem Pfeil anklicken, um ein vordefiniertes Argument auszuwählen.

Hinweis

Für weitere Informationen über die Verwendung von Argument-Syntax, siehe Argumente für externe Werkzeuge.

  4. Falls beim Starten des Werkzeugs die Argumente bearbeitet werden sollen, die an das Werkzeug übergeben werden, muss die Option Nach Argumenten fragen ausgewählt werden.

Wird das externe Werkzeug aus dem Werkzeuge-Menü gestartet, werden die ausgewählten Argumente automatisch an das Werkzeug übergeben. Wenn die Option Nach Argumenten fragen aktiviert wurde, wird das Dialogfenster Werkzeug-Argumente angezeigt.

Man kann auch ein Arbeitsverzeichnis für das Werkzeug oder den Befehl festlegen.

Um das Arbeitsverzeichnis für ein Werkzeug festzulegen:

  • Im Textfeld Arbeitsverzeichnis das Arbeitsverzeichnis für das Werkzeug eingeben, oder neben dem Textfeld die Schaltfläche mit dem Pfeil anklicken, um ein vordefiniertes Verzeichnis auszuwählen.

Siehe auch

Anpassen des Werkzeuge-Menüs

Externe Werkzeuge-Dialogfenster

Argumente für externe Werkzeuge

Argument-Makros


Andere Anpassungsmöglichkeiten

Zusätzlich zum Anpassen von Symbolleisten, Werkzeugen und Tastenkombinationen können Sie auch Makros, Add-ins und Callback-Bibliotheken verwenden, um Aufgaben zu automatisieren.

Worüber möchten Sie mehr wissen?

  • Anpassen des Fenster-Layouts

  • Verwenden von Add-ins

  • Verwenden von VBScript-Makros

  • Verwenden von Callback-Bibliotheken

Was möchten Sie tun?

  • Tastenkombinationen zu bestimmten VBScript-Makros zuweisen

  • Den Texteditor anpassen

  • Die Syntax-Hervorhebung in Texteditor-Fenstern anpassen


Übersicht: Automation

In der PCAN-Explorer-Umgebung werden viele Aufgaben manuell ausgeführt. Mit Automation können Aufgaben automatisiert werden, indem man VBScript-Makros oder PCAN-Explorer-Add-ins schreibt. VBScript-Makros sind Prozeduren, die in der VBScript-Sprache geschrieben werden. Add-ins sind In-Process COM-Komponenten (DLLs), die man mit beliebigen Entwicklungswerkzeugen erstellen kann.

Mit Makros und Add-ins kann man Aufgaben erledigen, indem man PCAN-Explorer und seine Komponenten als Objekte manipuliert. Beispielsweise kann ein Dokument geöffnet, editiert und geschlossen werden, indem man es als Objekt manipuliert. Entsprechend kann ein Fenster aktiviert oder dessen Größe geändert werden, indem man es als Objekt manipuliert.

Ein Objekt repräsentiert eine Komponente von PCAN-Explorer, oder es repräsentiert eine Kollektion von verwandten Komponenten. Zum Beispiel stellt ein Document-Objekt ein geöffnetes Dokument dar, das Documents -Objekt hingegen eine Kollektion aller geöffneten Dokumente. Ähnlich stellt ein Window-Objekt ein geöffnetes Fenster dar, und das Windows-Objekt alle offenen Fenster. Die Documents- und Windows-Objekte werden als Kollektionen bezeichnet, da sie eine Kollektion von verwandten Objekte enthalten.

Sie manipulieren Objekte, indem Sie die Methoden, Eigenschaften und Ereignisse verwenden, die mit den Objekten verbunden sind. Methoden repräsentieren Aktionen, die Sie auf Objekte anwenden können. Eigenschaften sind die Charakteristika der Objekte, wie z.B. ihr Typ oder ihre Größe. Ereignisse sind Bedingungen, unter denen Aktionen auf Objekte angewendet werden.

Angenommen, Sie möchten eine Symboldatei erzeugen, indem Sie einfach eine Tastenkombination drücken. Beginnen Sie, indem sie ein VBScript-Makro schreiben, das die Datei erzeugt. Das Makro sieht folgendermaßen aus:

VBS Macro

Sub CreateSymbolsFile

Set SymFile = Documents.Add(peDocumentKindText)

SymFile.Language = peSymbols

End Sub

Dieses Makro bewirkt folgendes:

  • Die Anweisung Sub beginnt das Makro, das den Namen CreateSymbolsFile hat. Der Name ist willkürlich, Sie können verwenden, was immer Sie möchten.

  • Die erste Zeile des Makros fügt ein neues Document-Objekt zur Kollektion der Document-Objekte hinzu, indem die Add-Methode der Documents-Kollektion verwendet wird.

  • Die zweite Zeile des Makros legt den Dateityp (Symbols) fest, indem die Language-Eigenschaft des Document-Objekts der Konstante peSymbols gleichgesetzt wird. Diese Konstante repräsentiert Symboldateien.

  • Die Anweisung End Sub beendet das Makro.

Nachdem Sie das Makro geschrieben haben, weisen Sie eine Tastenkombination zu. Dann drücken Sie einfach diese Tastenkombination, um das Makro auszuführen.

Für weitere Information über das Schreiben von VBScript-Makros siehe Übersicht: VBScript-Makros. Für Einzelheiten zu Objekten, die man zum Bewerkstelligen von Aufgaben in PCAN-Explorer verwenden kann, siehe Reference: PCAN-Explorer Objects (in Englisch). Und für Details über das Erzeugen von Add-ins siehe Übersicht: PCAN-Explorer Add-ins.

In diesem Abschnitt

PCAN-Explorer-Objekte

Enthält eine Übersicht und Referenz-Themen über das PCAN-Explorer-Objektmodell.

VBScript-Makros

Enthält Themen über die Erstellung und Verwendung von VBScript-Makros.

Add-ins

Enthält Themen über die Erstellung, Installation und Verwendung von Add-ins.

Callback-Bibliotheken

Enthält Themen über die Erstellung und Verwendung von Callback-Bibliotheken in Projekten.

Weitere Abschnitte

Standardmakros

Standardmakros ermöglichen einen gesteuerten Sende- und Empfangsbetrieb. Es steht ein einfacher Befehlssatz mit der am häufigsten benötigten Funktionalität zur Verfügung. Dieser Abschnitt enthält die Referenz zu Standardmakros.


Leitseite: PCAN-Explorer-Objekte

Sie können Aufgaben in PCAN-Explorer automatisieren, indem Sie VBScript-Makros und PCAN-Explorer-Add-ins entwerfen und verwenden.

Sie können Aufgaben automatisieren, indem Sie PCAN-Explorer und seine Objekte steuern. Zum Beispiel können Sie ein Dokument öffnen, bearbeiten und schließen, indem Sie es als Objekt manipulieren. Demgemäß können Sie ein Fenster aktivieren und in der Größe verändern, indem Sie es als Objekt manipulieren.

Sie manipulieren Objekte, indem Sie die Methoden, Eigenschaften und Ereignisse verwenden, die mit den Objekten und Kollektionen verbunden sind. Methoden repräsentieren Aktionen, die auf Objekte angewendet werden können. Eigenschaften sind die Charakteristika der Objekte, wie beispielsweise der Typ oder die Größe. Weiterhin sind Ereignisse Bedingungen, unter denen Aktionen auf Objekte angewendet werden.

Worüber möchten Sie mehr wissen?

  • Die Vorteile von Automation

  • Automation aus anderen Anwendungen heraus

  • Unterschiede zwischen VBScript-Makros und PCAN-Explorer-Add-ins

Folgende Themen sind nur in Englisch verfügbar:

  • Objekte

  • Kollektionen

  • Methoden

  • Eigenschaften

  • Ereignisse

  • Referenz

Weitere Abschnitte

  • VBScript-Makros

  • Add-ins für PCAN-Explorer

  • Callback-Bibliotheken

  • PCAN-Explorer anpassen


Aufgaben aus anderen Anwendungen heraus automatisieren

Leitseite (Objekte) | Referenz (in Englisch)

Mittels Automation können Sie die PCAN-Explorer Umgebung aus anderen Anwendungen wie z.B. Word, Excel oder Visual Basic steuern. Sie können PCAN-Explorer starten, Aufgaben automatisieren, und dann PCAN-Explorer beenden, wenn diese Aufgaben erledigt sind.

Starten von PCAN-Explorer

Um PCAN-Explorer aus einer anderen Anwendung zu starten, erzeugen Sie eine Instanz des PCAN-Explorer Application-Objekts. Um zum Beispiel PCAN-Explorer mit Visual Basic oder Visual Basic for Applications zu starten, können Sie folgenden Code verwenden:

Visual Basic

Dim app As PCANExplorer6.Application

Set app = CreateObject("PCANExplorer6.Application")

Damit Visual Basic die verwendeten PCAN-Explorer-Datentypen auflösen kann, müssen Sie dem Visual Basic Projekt die Referenz auf die COM-Komponente "PCAN-Explorer 6 Shared Objects" hinzufügen.

Wenn PCAN-Explorer startet, ist das Hauptfenster zunächst unsichtbar. Es muss sichtbar gemacht werden, indem Sie die IsVisible-Eigenschaft des entsprechenden Window-Objekts verwenden:

Visual Basic

Dim app As PCANExplorer6.Application

Set app = CreateObject("PCANExplorer6.Application")

app.MainWindow.IsVisible = True

Wenn PCAN-Explorer bereits läuft, können Sie diese Instanz verwenden, anstatt eine neue Instanz zu erzeugen. Um zum Beispiel die aktuelle Instanz von PCAN-Explorer aus Visual Basic oder Visual Basic for Applications zu verwenden, können Sie folgenden Code verwenden:

Visual Basic

Dim app As PCANExplorer6.Application

Set app = GetObject(, "PCANExplorer6.Application")

Aufgaben in PCAN-Explorer automatisieren

Nachdem PCAN-Explorer gestartet worden ist, können Sie Aufgaben automatisieren, indem Sie den entsprechenden Quellcode schreiben. Im folgenden Beispiel ist die Stelle markiert, an welcher der Code für die Automatisierung von Aufgaben eingefügt werden muss:

Visual Basic

Dim app As PCANExplorer6.Application

Set app = CreateObject("PCANExplorer6.Application")

app.MainWindow.IsVisible = True

' Code zum automatisieren von Aufgaben hier einfügen

PCAN-Explorer beenden

Nachdem alle Aufgaben erledigt sind, können Sie PCAN-Explorer stoppen, indem Sie die Anwendung beenden und alle Referenzen auf das Application-Objekt freigeben.

Hinweis: Falls Sie C#, Visual Basic oder Delphi zum Automatisieren von PCAN-Explorer verwenden, werden alle Referenzen auf das Application-Objekt automatisch freigegeben.

Um PCAN-Explorer zu beenden, können Sie den Befehl Beenden im Menü Datei verwenden, oder rufen Sie die Quit-Methode des Application-Objekts auf. Wenn Sie die Quit-Methode verwenden, müssen Sie dies jedoch tun, bevor Sie die Referenz auf das Application-Objekt freigeben.

Der folgende Quellcode zeigt, wie die Quit-Methode verwendet werden kann:

Visual Basic

Dim app As PCANExplorer6.Application

Set app = CreateObject("PCANExplorer6.Application")

app.MainWindow.IsVisible = True

' Code zum automatisieren von Aufgaben hier einfügen

app.Quit
Hinweis

Wenn der Benutzer versucht, PCAN-Explorer zu beenden, während ein anderes Programm es steuert, wird PCAN-Explorer im Speicher verbleiben, jedoch wird die Benutzeroberfläche unsichtbar gemacht. Wenn Sie danach versuchen, auf PCAN-Explorer-Objekte zuzugegreifen, können Fehler auftreten. In diesem Fall geben Sie alle Referenzen auf das Application-Objekt frei, so dass sich PCAN-Explorer selbst beenden kann.


Abfragen oder Setzen der Eigenschaften von PCAN-Explorer-Objekten

Leitseite (Objekte) | Referenz (in Englisch)

PCAN-Explorer-Objekte haben eine Vielzahl von Eigenschaften. Zum Beispiel haben ein TextWindow- oder ein Window-Objekt eine Caption-Eigenschaft, die den Titel eines Fensters angibt. Weiterhin haben ein TextWindow oder Window-Objekt eine Height-Eigenschaft, welche die Höhe eines Fensters angibt.

Einige Eigenschaften sind schreibgeschützt. Das bedeutet, dass Sie von diesen Eigenschaften den Wert nur lesen können. Bei anderen Eigenschaften können Sie die Werte lesen und schreiben.

Zum Beispiel können Sie den Wert der Caption-Eigenschaft nur lesen, wie im folgenden Beispiel gezeigt:

VBS Macro

Dim x

x = ActiveWindow.Caption

Alternativ dazu können Sie den Wert der Height-Eigenschaft lesen und schreiben. Zum Beispiel können Sie den Wert der Height-Eigenschaft auf 100 setzen:

VBS Macro

ActiveWindow.Height = 100

Für mehr Information über Eigenschaften, siehe Beschreibung der Eigenschaften.


Methoden auf PCAN-Explorer-Objekte anwenden

Leitseite (Objekte) | Referenz (in Englisch)

Die meisten PCAN-Explorer-Objekte haben Methoden. Diese stellen die Aktionen dar, die auf Objekte angewendet werden können.

Zum Beispiel ermöglicht Ihnen die Open-Methode des Documents-Objekts das Öffnen einer Datei. Angenommen, Sie erzeugen eine neue Symboldatei und speichern sie als MeineDatei.sym in ihrem lokalen Verzeichnis für Symboldateien. Um diese Datei dann zu öffnen, können Sie folgenden Quellcode verwenden:

VBS Macro

Documents.Open("C:\Users\<UserName>\Documents\PCAN-Explorer 6\Symbols\MeineDatei.sym")

In gleicher Weise können Sie dieses Dokument wieder schließen, indem Sie Close-Methode des TextDocument-Objekts aufrufen:

VBS Macro

ActiveDocument.Close

Für weitere Informationen über Methoden, siehe Beschreibungen der Methoden.


Ereignisse mit PCAN-Explorer-Objekten verwenden

Leitseite (Objekte) | Referenz (in Englisch)

Ein Ereignis ist eine Aktion oder ein Vorkommnis, das oft vom Benutzer hervorgerufen wird und auf das eine VBScript-Ereignisbehandlung, ein PCAN-Explorer-Add-in oder ein anderer Automation Controller reagieren können. Wenn der Benutzer zum Beispiel auf ein Fenster klickt, löst PCAN-Explorer ein OnWindowActivate-Ereignis des Application-Objekts aus.

In einer VBScript-Ereignisbehandlung können Sie auf Ereignisse reagieren, indem Sie eine Aktion ausführen. Zum Beispiel könnten Sie die Größe eines Fensters ändern, indem Sie die Height- und Width-Eigenschaften des Window-Objekts setzen.

Um auf ein Ereignis zu reagieren, fügen Sie die entsprechende Ereignisbehandlung zu einer geladenen VBScript-Makrodatei hinzu. Sie können diese Ereignisbehandlung zu mehreren VBScript-Makrodateien hinzufügen. Fügen Sie beispielsweise eine Ereignisbehandlug für das OnWindowActivate-Ereignis in zwei geladene VBScript-Makrodateien ein, werden beide Ereignisbehandlungen nacheinander ausgeführt, wenn der Benutzer ein Fenster aktiviert.

Zum Beispiel könnten Sie eine Aktion definieren, die direkt vor dem Beenden von PCAN-Explorer ausgeführt wird, indem Sie das OnApplicationShutDown-Ereignis verwenden. Um das Ereignis zu verwenden, kopieren Sie das Beispiel in der Beschreibung dieses Ereignisses:

VBS Macro

Sub Application_OnApplicationShutDown()

' Insert code to handle the event here

End Sub

Fügen Sie dann die Zeilen in Ihre Makrodatei ein, ergänzen den Code zur Behandlung des Ereignisses und laden die Makrodatei neu.

Tipp

Um eine Makrodatei neu zu laden, öffnen Sie die Datei im Texteditor, drücken Sie die rechte Maustaste um das Kontextmenü zu öffnen, und klicken Sie auf Makrodatei neu laden.


Reference: PCAN-Explorer Objects

Home Page (Objects)

The PCAN-Explorer object model enables you to automate tasks in the PCAN-Explorer environment. This object model consists of the hierarchy of PCAN-Explorer objects, and their associated properties, methods, and events.

This section describes each object and collection, along with its properties, methods, and events.

In This Section

Diagram of the Object Model

A graphical guide to all components of the PCAN-Explorer object model.

Objects

Contains all objects in the PCAN-Explorer object model.

Collections

Contains all collections in the PCAN-Explorer object model.

Properties

Contains all properties of the objects and collections in the PCAN-Explorer object model.

Methods

Contains all methods of the objects and collections in the PCAN-Explorer object model.

Events

Contains all events of the objects in the PCAN-Explorer object model.


Diagram of the Object Model

PCAN-Explorer: Automation

Objekte

PCAN-Explorer Object Model

See also

Reference: PCAN-Explorer Objects


Objects

Home Page (Objects) | Reference

You can control the PCAN-Explorer environment programmatically by manipulating it through Automation (former OLE Automation). For example, in a VBScript Macro, you can control an open document by manipulating its corresponding Document object.

Each PCAN-Explorer object implements a dual interface through which you can manipulate the object. Each object implements an IDispatch interface for Automation and a Component Object Model (COM) interface for direct access to object members (properties, methods, events).

Add-ins working with early binding can use the COM interface. Early binding makes all calls into interface members faster at runtime.

Overview of PCAN-Explorer Objects

Each PCAN-Explorer object is described below:

Object | Represents
AddIn | An Add-in listed in the Add-In Manager dialog box.
Application | The PCAN-Explorer application.
CallbackLibraryEvent | Encapsulates a Callback Library that is passed to callback functions that handle library-related events.
Connection | A connection between PCAN-Explorer and a CAN bus.
Document | An open document.
Enum | An enum that defines text representations for ordinal values.
J1939Filter | Used to filter the messages that are received by its parent J1939Node object.
J1939Msg | A J1939 message that can be sent by a J1939Node object.
J1939Node | A connection to a CAN bus using the J1939 protocol.
J1939RcvMsg | A J1939 message that was received by a J1939Node object.
MessageFilter | A message filter in the current project.
MessageFilterItem | A set of message filter settings.
Multiplexer | A multiplexer for a CAN symbol.
OutputWindow | The PCAN-Explorer Output window.
OutputWindowPane | Represents a tab in the Output window.
PCANBitrate | Represents a CAN or CAN FD bit rate.
PCANClient | The client object of the PCAN system. An object that is able to connect to one or more buses using the raw CAN protocol.
PCANClientConnection | A single connection of a PCANClient object to a CAN bus.
PCANMessage | A CAN message.
Project | A loaded PCAN-Explorer project.
ReceiveEvent | Encapsulates a received message that is passed to callback functions that handle receive-related events.
ReceiveMessage | A received CAN message.
ReceiveTransmitWindow | The central Receive/Transmit window.
Signal | A signal.
Symbol | A CAN symbol.
TextDocument | An open text file.
TextEditor | The text editor of PCAN-Explorer.
TextSelection | Selected text in an open text file.
TextWindow | A view of an open text document.
TraceMessage | A recorded CAN message.
Tracer | A tracer for recording CAN messages.
TraceWindow | A view of a tracer object.
TransmitEvent | Encapsulates a transmit message that is passed to callback functions that handle transmit-related events.
TransmitMessage | A CAN message to be sent.
TransmitWindow | A view of a Transmit List.
Variable | A CAN variable.
VBSMacroFile | A loaded VBS Macro file.
Window | A window of the PCAN-Explorer user interface.

See also

Collection Property | Parent Property


AddIn Object

The AddIn object represents an Add-in listed in the Add-In Manager dialog box and provides information about an Add-in to other Add-in objects.

Application

AddIns

AddIn

The AddIn object has the following properties:

Properties
Application | Guid
Collection | IsConnected
Description | Name
ExtensibilityObject | ProgID
FullName | Version
Remarks

The AddIn objects can be accessed by using the AddIns property of the Application object. This object has members (properties) that you can use to manipulate the Add-in.

An AddIn object provides information about an Add-in to other Add-ins. Only registered Add-ins are represented by an AddIn object.

Add-ins and other clients that can use early binding can access the members of the AddIn object by referencing the PCAN-Explorer Type Library, which resides in the program module PcanExpl.exe. The AddIn object implements the Dual Interface IPEAddIn (IID: C12B9635-194E-4617-B3F4-B5AED5C842C9).

See also

AddIns Collection


Application Object

The Application object represents PCAN-Explorer and is the top object in the PCAN-Explorer object model. From the Application object you can directly access other PCAN-Explorer objects, by using its properties and methods. On the other hand you can indirectly access other objects with the help of objects, which you get due to these properties and methods.

The Application object has the following properties, methods, and events:

Properties
ActiveDocument | MessageFilters
ActiveProject | Name
ActiveWindow | Path
AddIns | ReceiveMessages
Application | RegistryRoot
ApplicationDataDirectory | Signals
Connections | SymbolsManager
CurrentDirectory | TextEditor
CurrentTime | TimeFormat
Documents | TransmitMessages
FullName | VBSMacroFiles
Handle | Version
IsActive | Windows
MainWindow |
Methods
AddCommand | PrintToOutputWindow
AddCommandBarButton | Quit
AddKeybinding | SetAddInInfo
ExecuteCommand | TimeToString
NewProject | Wait
Events
OnApplicationShutDown | OnProjectClose
OnConnectionAdd | OnProjectOpen
OnConnectionConnect | OnSymbolsActivate
OnConnectionChanged | OnSymbolsDeactivate
OnConnectionDisconnect | OnSymbolsDeactivated
OnConnectionRemove | OnTracerActivate
OnDocumentClose | OnTracerDeactivate
OnDocumentOpen | OnTracerFull
OnDocumentSave | OnTracerPause
OnMessageFilterAdd | OnTracerStart
OnMessageFilterChanged | OnTracerStop
OnMessageFilterRemove | OnWindowActivate
OnNewDocument | OnWindowDeactivate
OnOptionsChanged |
Remarks

Since Application is the top object, its name is automatically included, when its properties or methods are accessed in a VBS Macro. Therefore you only need to indicate property's or method's name. If e.g. you want to access the Quit method, you only need to write Quit and not Application.Quit.

Add-ins and other clients that can use early binding can access the members of the Application object by referencing the PCAN-Explorer Type Library, which resides in the program module PcanExpl.exe. The Application object implements the Dual Interface IPEApplication (IID: A2388B6D-6AF5-419C-93A2-8EE2A8AF1C1A).


CallbackLibraryEvent Object

The CallbackLibraryEvent object encapsulates a Callback Library that is passed to callback functions that handle library-related events.

Application

CallbackLibraries (not accessible via Automation)

CallbackLibrary (not accessible via Automation)

CallbackLibraryEvent

The CallbackLibraryEvent object has the following properties:

Properties
Application | IsEnabled
FullName | Name
Remarks

Callback Libraries can access the CallbackLibraryEvent object in callback handler functions. It is provided as a function parameter for the events OnEnable and OnDisable.

Callback Libraries that can use early binding can access the members of the CallbackLibraryEvent object by referencing the PCAN-Explorer Callback Events Type Library PECallbackEvents.tlb, which is located in the PCAN-Explorer installation folder. The CallbackLibraryEvent object implements the interface IPECallbackLibraryEvent (IID: 2F9B6A72-2A97-4EC1-A884-590A21A35D12).


Connection Object

The Connection object represents a connection between PCAN-Explorer and a CAN bus.

Application

Connections

Connection

The Connection object has the following properties and methods:

Properties
Application | Filter
BitRate | IsEnabled
Bus | IsValid
CalculateBusLoad | Name
Collection | Protocol
CommunicationObject | Symbols
Connection | SymbolsFileName
Device |
Methods

BeginUpdate

EndUpdate
Remarks

The Connection object can be accessed by using the Connections property of the Application object. This object has members (properties and methods), that you can use to manipulate the connection.

Add-ins and other clients that can use early binding can access the members of the Connection object by referencing the PCAN-Explorer Type Library, which resides in the program module PcanExpl.exe. The Connection object implements the Dual Interface IPEConnection (IID: EE41C91A-25F7-4A55-9956-99D07CDAF7FD).


Document Object

The Document object represents an opened document.

Application

Documents

Document

The Document object has the following properties and methods:

Properties
ActiveWindow | IsSaved
Application | Kind
Collection | Name
FullName | Object
IsActive | Path
IsReadOnly | Type
Methods
Close | Save
PrintOut |
Remarks

The Document object can be accessed by using the Documents property of the Application object. This object has members (properties, methods, and events), that you can use to manipulate the document.

If the document is a text file, it also has a TextDocument object. This object has all the members of a Document object and also has members, that allow you to access text-specific attributes of the document.

Use a document's Type property to determine, which members you can access. If the type is "Generic", the document is not a text document and you can access only Document members. If the type is "Text", the document is a text document and you can access TextDocument members as well as Document members.

In VBScript Macros you can access TextDocument members by automatically using late binding. In Add-ins however you can also access these members by using early binding. Early binding offers better performance than late binding by making calls into the interface faster at run time.

The current document can be accessed by using the ActiveDocument property of the Application object.

All open documents belong to the Documents collection, which is represented by the Documents collection. A specific document can be found by iterating through this collection.

Add-ins and other clients that can use early binding can access the members of the Document object by referencing the PCAN-Explorer Type Library, which resides in the program module PcanExpl.exe. The Document object implements the Dual Interface IPEDocument (IID: C786025E-6A99-4F20-8282-46EE67607696).


Enum Object

The Enum object defines text representations for a set of ordinal values. Enums are used by Variables or Signals to provide more easily understandable values to the user, if the Signal's or Variable's value is equal to one of the values defined in an Enum.

Application

SymbolsManager

Symbols

Enums

Enum

The Enum object has the following properties and methods:

Properties
Application | Description
Collection | Name
Count |
Methods
Add | GetOrdinal
FindOrdinal | GetString
FindString |
Remarks

The Enum objects can be accessed by using the Enums property of a Symbols collection. This object has members (properties and methods) that you can use to manipulate the Enum.

Add-ins and other clients that can use early binding can access the members of the Enum object by referencing the PCAN-Explorer Type Library, which resides in the program module PcanExpl.exe. The Enum object implements the Dual Interface IPEEnum (IID: 3E0FE2F9-9B7F-410D-A093-11018A22E351).


J1939AddrName Object

Encapsulates the NAME value which uniquely identifies the primary function of an ECU and its instance on the network.

Application

Connections

Connection

J1939Node

J1939AddrName

The J1939AddrName object has the following properties:

Property | Description
ArbitraryAddressCapable | A Boolean value that specifies, whether the Controller Application is self-configurable and can use an arbitrary source address to resolve an address claim conflict. Note: The J1939 Add-in does not support self-configuration.
AsArray | A SafeArray that sets and returns the contents of the 64-bit NAME field.
AsNumber | An UInt64 value that sets and returns the contents of the 64-bit NAME field.
ECUInstance | Indicates, which one of a group of electronic control modules associated with a given function is being referenced.
Function | A capability of a vehicle system having one or more ECUs that are connected to a J1939 bus segment of a Vehicle System.
FunctionInstance | Identifies a particular occurrence of a function on the same Vehicle System on the network.
IdentityNumber | A unique value that is necessary to resolve any address contention. The manufacturer of an ECU must provide this uniqueness among products.
IndustryGroup | Identifies NAMEs associated with a particular industry that uses J1939. For example, on-highway or agricultural equipment.
ManufacturerCode | Indicates, which company was responsible for the production of the ECU for which this NAME is being referenced.
VehicleSystemInstance | Identifies a particular occurrence of a particular Vehicle System within a connected network.
VehicleSystem | A subcomponent of a vehicle that includes one or more J1939 segments.

For more information about the meaning of the NAME fields, see document SAE J1939-81, chapter 4.1.

Remarks

The J1939AddrName object can be accessed by using the AddressName property of the J1939Node object. This object has members (properties) that you can use to manipulate the J1939 NAME field.

Add-ins and other clients that can use early binding can access the members of the J1939AddrName object by referencing the J1939Pcan6 Type Library, which resides in the J1939 Add-in library module J1939Pcan.dll. The J1939AddrName object implements the Dual Interface IPCANJ1939AddrName (IID: 62985A49-78FE-48F7-8FBD-99887E2B1E4C).


J1939Filter Object

The J1939Filter object can be used to filter the messages that are received by its parent J1939Node object.

Application

Connections

Connection

J1939Node

J1939Filters

J1939Filter

The J1939Filter object has the following properties:

Properties
Collection | PGN
DestinationAddress | Priority
Flags | SourceAddress
Remarks

The J1939Filter object can be accessed by using the Filters property of the J1939Node object.

Add-ins and other clients that can use early binding can access the members of the J1939Filter object by referencing the J1939Pcan6 Type Library, which resides in the J1939 Add-in library module J1939Pcan.dll. The J1939Filter object implements the Dual Interface IPCANJ1939Filter (IID: 6A582964-B6AD-4F46-8350-B3DAFCA45CBF).


J1939Msg Object

The J1939Msg object represents a J1939 message that can be sent by a J1939Node object.

The J1939Msg object has the following properties:

Properties
ID | PacksCount
Data | PGN
DataArray | Priority
Length | Responder
Originator |
Remarks

Add-ins and other clients that can use early binding can access the members of the J1939Msg object by referencing the J1939Pcan6 Type Library, which resides in the J1939 Add-in library module J1939Pcan.dll. The J1939Msg object implements the Dual Interface IPCANJ1939Msg (IID: 2C6B24F6-CDF8-4A22-B456-236B56FD70E6).

Example

VBScript Macros can create the J1939Msg object by specifying its type name PCANJ1939Msg in the CreateObject function:

VBS Macro

Sub CreateJ1939MsgExample()

Dim msg

Set msg = CreateObject("J1939Pcan6.PCANJ1939Msg")

' Access the message object here

...

End Sub


J1939Node Object

The J1939Node object represents a virtual J1939 node, which is the interface between PCAN-Explorer and a CAN bus using the J1939 protocol. In J1939 terminology, a J1939 node object represents a single J1939 Controller Application (CA).

Application

Connections

Connection

J1939Node

The J1939Node object has the following properties and methods:

Properties
AddressClaimStatus | NotificationOnAddressLost
AddressName | NotificationOnMessageReceived
ClaimedAddress | NotificationOnPropertyChange
ClientName | PacksCountOnReadSessions
Connected | PacksCountOnWriteSessions
Device | PGNsToRejectOnRTS
Filters | PreferredAddress
HardwareHandle | RcvEventHandle
HardwareStatus | ReassembleIncomingPackets
HardwareType | Receiving
IncludeEchoes | ReCTSsCountOnReadSessions
IncludeTPMessages | ResetOnBusOff
LastCANError | RetriesCountOnWriteSessions
LastError | UseAddressingProtocol
Monitoring | WindowHandle
NetName | XmtQueueEmpty
NotificationOnAddressClaiming |
Methods
Connect | Read
ClaimAddress | ReleaseAddress
Disconnect | Reset
GetSystemTime | Write
Events
OnAddressClaiming | OnPropertyValueChanged
OnAddressLost |
Remarks

The J1939Node object can be accessed by using the CommunicationObject property of the Connection object. This object has members (properties, methods, and events), that you can use to manipulate the virtual J1939 node.

Add-ins and other clients that can use early binding can access the members of the J1939Node object by referencing the J1939Pcan6 Type Library, which resides in the J1939 Add-in library module J1939Pcan.dll. The J1939Node object implements the Dual Interface IPCANJ1939Node (IID: A8E0A47B-D339-4C4D-BC02-71D899C1E4A4).

Example

VBScript Macros can create the J1939Node object by specifying its type name PCANJ1939Node in the CreateObject function:

VBS Macro

Sub CreateJ1939NodeExample()

Dim node

Set node = CreateObject("J1939Pcan6.PCANJ1939Node")

' Access the node object here

...

End Sub


J1939RcvMsg Object

The J1939RcvMsg object represents a J1939 message that was received by a J1939Node object.

The J1939RcvMsg object has the following properties:

Properties
ID | Originator
Data | PacksCount
DataArray | PGN
IsEcho | Priority
Length | Responder
Timestamp |
Remarks

Add-ins and other clients that can use early binding can access the members of the J1939RcvMsg object by referencing the J1939Pcan6 Type Library, which resides in the J1939 Add-in library module J1939Pcan.dll. The J1939RcvMsg object implements the Dual Interface IPCANJ1939RcvMsg (IID: 471A7EAD-C9D8-4856-BB85-B1DFC2D02BAC).

Example

VBScript Macros can create the J1939RcvMsg object by specifying its type name PCANJ1939RcvMsg in the CreateObject function:

VBS Macro

Sub CreateJ1939RcvMsgExample()

Dim msg

Set msg = CreateObject("J1939Pcan6.PCANJ1939RcvMsg")

' Access the message object here

...

End Sub


MessageFilter Object

The MessageFilter object represents a message filter in a PCAN-Explorer project.

Application

MessageFilters

MessageFilter

The MessageFilter object has the following properties and methods:

Properties
Application | ItemCount
Collection | IsEnabled
Description | Name
Methods
AddItem | Item
BeginUpdate | RemoveItem
ClearItems | ShowFilterDialog
EndUpdate |
Remarks

The MessageFilter object can be accessed by using the MessageFilters property of the Application object. This object has members (properties and methods) that you can use to manipulate the filter.

Add-ins and other clients that can use early binding can access the members of the MessageFilter object by referencing the PCAN-Explorer Type Library, which resides in the program module PcanExpl.exe. The MessageFilter object implements the Dual Interface IPEMessageFilter (IID: 30037876-4BE6-4798-B989-A1FAEE3991BA).


MessageFilterItem Object

The MessageFilterItem object represents a single filter item of a message filter, which is a set of filter settings.

Application

MessageFilters

MessageFilter

MessageFilterItem

The MessageFilterItem object has the following properties and methods:

Properties
AccCode | IDto
AccMask | IsEnabled
Application | IsExtended
Bus | J1939FilterFlags
Collection | PGN
DestinationAddress | Priority
ErrorFramesEnabled | RTREnabled
ErrorWarningsEnabled | SourceAddress
ExcludeMode | Type
IDfrom |
Remarks

The MessageFilterItem object can be accessed by using the Item method of the MessageFilter object. This object has members (properties) that you can use to manipulate the filter item.

Add-ins and other clients that can use early binding can access the members of the MessageFilterItem object by referencing the PCAN-Explorer Type Library, which resides in the program module PcanExpl.exe. The MessageFilterItem object implements the Dual Interface IPEMessageFilterItem (IID: 42C1B6DE-FBC1-4864-BB32-B35A7316EDBD).


Multiplexer Object

The Multiplexer object is part of a Multiplexers collection.

Application

SymbolsManager

Symbols

Symbol

Multiplexers

Multiplexer

Multiplexers are an extension of a Symbol's CAN-ID and allow a different interpretation of a CAN message's data bytes depending on their contents.

The Multiplexer object has the following properties and methods:

Properties
Application | IsTraced
Collection | MuxData
Color | MuxLength
Comment | MuxStart
CycleTime | MuxValue
DataLength | Name
DefaultData | Parent
DisplayMode | Timeout
IsMotorola | Variables
IsPaused | VisibleVariablesCount
IsRTR |
Methods

Send

Remarks

The Multiplexer objects can be accessed by using the Multiplexers property of the Symbol object.

Add-ins and other clients that can use early binding can access the members of the Multiplexer object by referencing the PCAN-Explorer Type Library, which resides in the program module PcanExpl.exe. The Multiplexer object implements the Dual Interface IPEMultiplexer (IID: 14838ECF-EC72-427A-8D29-6ECC846A22CA).

See also

Symbol Object

Variable Object


OutputWindow Object

The OutputWindow object represents the Output window of the PCAN-Explorer user interface.

Application

Windows

Window

OutputWindow

The OutputWindow object has the following properties:

Properties
ActivePane | OutputWindowPanes
Application | Parent
Remarks

The OutputWindow object can be accessed by using the Windows property of the Application object.

Add-ins and other clients that can use early binding can access the members of the OutputWindow object by referencing the PCAN-Explorer Type Library, which resides in the program module PcanExpl.exe. The OutputWindow object implements the Dual Interface IPEOutputWindow (IID: 76E27435-3DCA-4AF8-AD80-932600F1AEC0).


OutputWindowPane Object

The OutputWindowPane object represents a tab in the Output window.

Application

Windows

Window

OutputWindow

OutputWindowPanes

OutputWindowPane

The OutputWindowPane object has the following properties and methods:

Properties
Application | Name
Collection |
Methods
Activate | OutputString
Clear |
Remarks

All tabs in the Output window are each represented by a OutputWindowPane object. This object has members (properties and methods) that you can use to manipulate the tab.

You can access the current (active) tab of the Output window by using the ActivePane property of the OutputWindow object.

Add-ins and other clients that can use early binding can access the members of the OutputWindowPane object by referencing the PCAN-Explorer Type Library, which resides in the program module PcanExpl.exe. The OutputWindowPane object implements the Dual Interface IPEOutputWindowPane (IID: 8FAB1FD1-F85A-4F15-8DB6-F2BC77C972EF).


PCANBitrate Object

The PCANBitrate object represents a CAN or CAN FD bit rate.

Application

Connections

Connection

PCANClientConnection

PCANBitrate

The PCANBitrate object has the following properties:

Properties
AsString | NominalBitrate
BTR0BTR1 | NominalPrescaler
Clock | NominalSampling
DataBitrate | NominalSyncJumpWidth
DataPrescaler | NominalTSeg1
DataSyncJumpWidth | NominalTSeg2
DataTSeg1 | ParameterString
DataTSeg2 | Parent
Remarks

The PCANBitrate object can be accessed by using the NetBitRate property or the HardwareBitRate property of the PCANClientConnection object.

Add-ins and other clients that can use early binding can access the members of the PCANBitrate object by referencing the PCAN4 Type Library, which resides in the library module Pcan4.dll. The PCANBitrate object implements the Dual Interface IPCANBitrate (IID: D42F37C2-5095-4570-B10D-5F3164F0FA0F).


PCANClient Object

The PCANClient object represents the interface between PCAN-Explorer and the CAN bus. As a client it sets down on the PCAN system lying below.

Application

Connections

Connection

PCANClient

The PCANClient object has the following properties, methods and events:

Properties
AutoConnect | Language
AutoRegister | LastError
Connections | LastErrorText
Device | Messages
DriverVersion | Name
ErrorFrames | RcvEventHandle
FilterCode | SelfReceive
FilterMask | Version
Handle | WindowHandle
IsConnected | XmtQueueEmpty
IsRegistered |
Methods
GetDriverParam | Remove
GetErrorText | Reset
GetHardwareParam | ResetFilters
GetLongErrorText | SetDriverParam
GetNetParam | SetHardwareParam
GetParam | SetNetParam
GetSystemTime | SetParam
Register |
Events
OnClientConnect | OnClientRemove
OnClientDisconnect | OnFilterChanged
OnClientRegister | OnHardwareReset
Remarks

The PCANClient object can be accessed by using the CommunicationObject property of the Connection object. This object has members (properties, methods, and events) that you can use to manipulate the PCAN client.

Add-ins and other clients that can use early binding can access the members of the PCANClient object by referencing the PCAN4 Type Library, which resides in the library module Pcan4.dll. The PCANClient object implements the Dual Interface IPCANClient (IID: 134E5DE2-BB99-4664-A4FE-DBBC31D94DF1).

VBScript Macros can create the PCANClient object by specifying its type name in the CreateObject function:

VBS Macro

Sub CreatePCANClientExample()

Dim client

Set client = CreateObject("PCAN4.PCANClient")

' Access the PCANClient object here

' ...

End Sub


PCANClientConnection Object

The PCANClientConnection object represents a connection between a PCANClient object and a CAN bus.

Application

Connections

Connection

PCANClient

PCANClientConnections

PCANClientConnection

The PCANClientConnection object has the following properties and methods:

Properties
Collection | IsConnected
HardwareBaudRate | ListenOnly
HardwareBitRate | NetBaudRate
HardwareBitRateText | NetBitRate
HardwareHandle | NetBitRateText
HardwareInterrupt | NetHandle
HardwareName | NetName
HardwarePort | Parent
HardwareStatus | XmtQueueEmpty
Methods
ConnectDialog | ResetHardware
RegisterMsg | SetFilter
Remarks

The PCANClientConnection objects can be accessed by using the Connections property of the PCANClient object. This object has members (properties and methods) that you can use to manipulate the connection.

Add-ins and other clients that can use early binding can access the members of the PCANClientConnection object by referencing the PCAN4 Type Library, which resides in the library module Pcan4.dll. The PCANClientConnection object implements the Dual Interface IPCANClientConnection (IID: 8926700A-4E0F-4C13-B3C3-0D5650A17BA2).


PCANMessage Object

The PCANMessage object represents a CAN message.

Application

Connections

Connection

PCANClient

PCANMessages

PCANMessage

The PCANMessage object has the following properties and methods:

Properties
Collection | LastErrorText
Data | MsgType
DLC | Parent
ID | RcvNet
LastError | Timestamp
Methods

Read

Write
Remarks

The PCANMessage object can be accessed by using the Messages property of the PCANClient object.

Add-ins and other clients that can use early binding can access the members of the PCANMessage object by referencing the PCAN4 Type Library, which resides in the library module Pcan4.dll. The PCANMessage object implements the Dual Interface IPCANMessage (IID: 4DA0F2CF-3594-4FE1-AFB6-2B56FAF28649).


Project Object

The Project object represents a PCAN-Explorer Project.

Application

Project

The Project object has the following properties:

Properties
Application | Parent
Connections (see Remarks) | Path
Description | PostLoadCommand
FullName | ProjectItems
IsSaved | ReceiveList (see Remarks)
Macros (see Remarks) | Signals (see Remarks)
MessageFilters (see Remarks) | Timings (see Remarks)
Name | TransmitList (see Remarks)
Methods
AddItem | RemoveItem
BeginUpdate | Save
EndUpdate | SaveAs
Remarks

The Project object can be accessed by using the ActiveProject property of the Application object.

Add-ins and other clients that can use early binding can access the members of the Project object by referencing the PCAN-Explorer Project System Type Library, which resides in the library module PrjSys.dll. The Project object implements the Dual Interface IPEProject (IID: A4B49DA6-0306-4C01-94B2-70D5532DB3F6).

The properties Connections, Macros, MessageFilters, Signals, and Timings each return a ProjectItems collection containing objects that represent these project items.

The properties ReceiveList and TransmitList each return a ProjectItem object. These objects are used internally to manage user settings associated with the message lists, and which are saved in the project file.


ProjectItem Object

The ProjectItem object represents an item in a PCAN-Explorer Project.

Application

Project

ProjectItems

ProjectItem

The ProjectItem object has the following properties:

Properties
Application | Object
Collection | Project
Kind | ProjectItems
Name |
Methods

BeginUpdate

EndUpdate
Remarks

The ProjectItem objects can be accessed by using the ProjectItems property of the Project object.

Add-ins and other clients that can use early binding can access the members of the ProjectItem object by referencing the PCAN-Explorer Project System Type Library, which resides in the library module PrjSys.dll. The ProjectItem object implements the Dual Interface IPEProjectItem (IID: 0B43E279-BD7C-440D-83EB-7586F92E643B).

See also

ProjectItems Collection


ReceiveEvent Object

The ReceiveEvent object encapsulates a received message that is passed to callback functions that handle receive-related events.

Application

ReceiveMessages

ReceiveMessage

ReceiveEvent

The ReceiveEvent object has the following properties and methods:

Properties
Bus | MsgType
Data | PGN
Data64 | Priority
DataArray | RcvNet
DataLength | SourceAddress
DataVariant | SymbolName
DestinationAddress | Timeout
DLC | Timestamp
EventCount | TimestampAbs
ID | TimestampAbsString
MaxCycleTime | TimingErrorCount
MinCycleTime | VariableStringValue
MinInterval | VariableValue
Methods

PrintToOutputWindow

Remarks

Callback Libraries can access the ReceiveEvent object in callback handler functions. It is provided as a function parameter for the events OnReceive and OnTimingError.

Callback Libraries that can use early binding can access the members of the ReceiveEvent object by referencing the PCAN-Explorer Callback Events Type Library PECallbackEvents.tlb, which is located in the PCAN-Explorer installation folder. The ReceiveEvent object implements the interface IPEReceiveEvent.


ReceiveMessage Object

The ReceiveMessage object represents a received CAN message.

Application

ReceiveMessages

ReceiveMessage

The ReceiveMessage object has the following properties:

Properties
Application | MsgType
Collection | Multiplexer
Connection | PGN
Data | Priority
Data64 | RcvNet
DataArray | SourceAddress
DataLength | Symbol
DataVariant | Timeout
DestinationAddress | Timestamp
DLC | TimestampAbs
EventCount | TimestampAbsString
ID | TimingErrorCount
MaxCycleTime | VariableStringValue
MinCycleTime | VariableValue
MinInterval |
Remarks

The ReceiveMessage object can be accessed by using the ReceiveMessages property of the Application object.

Add-ins and other clients that can use early binding can access the members of the ReceiveMessage object by referencing the PCAN-Explorer Type Library, which resides in the program module PcanExpl.exe. The ReceiveMessage object implements the Dual Interface IPEReceiveMessage (IID: 63D7F7C2-966C-49DD-AF85-D93EEA76C1FB).


ReceiveTransmitWindow Object

The ReceiveTransmitWindow object represents the view of the central Receive/Transmit window.

Application

Windows

Window

ReceiveTransmitWindow

The ReceiveTransmitWindow object has the following properties:

Properties
Application | SplitState
Parent | TransmitMessages
ReceiveMessages | Window
Remarks

The ReceiveTransmitWindow object is returned by the Object property of the Window object, if the window is the Receive/Transmit window.

Add-ins and other clients that can use early binding can access the members of the ReceiveTransmitWindow object by referencing the PCAN-Explorer Type Library, which resides in the program module PcanExpl.exe. The ReceiveTransmitWindow object implements the Dual Interface IPEReceiveTransmitWindow (IID: FE69211A-18A0-4C37-B057-582E611DB39B).

Example
VBS Macro

Sub ReceiveTransmitWindowExample()

Dim objRxTx

Set objRxTx = Windows(peWindowKindReceiveTransmit).Object

MsgBox objRxTx.Window.Caption

End Sub

See also

Window Object


Signal Object

The Signal object represents a logical or physical value. The Signal object itself is part of a Signals collection.

Application

Signals

Signal

The Signal object has the following properties and methods:

Properties
Application | RunningMaxTime
Collection | RunningMean
Comment | RunningMin
DataType | RunningMinTime
DecimalPlaces | ShortName
Enum | Source
EnumName | SourceKind
InitValue | SPN
LongName | StatisticsEnabled
Max | StringValue
Min | Unit
Name | Value
RunningMax | ValueChangeTime
Methods
BeginUpdate | RegisterCallback
CalculateStatisticsFromTracer | UnregisterCallback
EndUpdate |
Remarks

The Signal objects can be accessed by using the Signals property of the Application object.

Add-ins and other clients that can use early binding can access the members of the Signal object by referencing the PCAN-Explorer Type Library, which resides in the program module PcanExpl.exe. The Signal object implements the Dual Interface IPESignal (IID: 3C14E50F-47CC-407A-89EE-9F93E01C50A5).


Symbol Object

The Symbol object represents a CAN message that has been equipped with new properties to bring it in a clearly readable form for the user. The Symbol object itself is part of a Symbols collection.

Application

SymbolsManager

Symbols

Symbol

The Symbol object has the following properties:

Properties
Application | MuxLength
CanId | MuxStart
CanIdHi | Name
Collection | PGN
Comment | Priority
DefaultMultiplexer | SourceAddress
DestinationAddress | Type
IsExtended | XferDirection
Multiplexers |
Remarks

The Symbol objects can be accessed by using the Item method of a Symbols collection.

Add-ins and other clients that can use early binding can access the members of the Symbol object by referencing the PCAN-Explorer Type Library, which resides in the program module PcanExpl.exe. The Symbol object implements the Dual Interface IPESymbol (IID: EBBF2C1F-6E68-4619-BCCC-378321D876AA).

See also

Symbols Collection

Multiplexer Object

SymbolsManager Collection


TextDocument Object

The TextDocument object represents an opened text file.

Application

Documents

TextDocument

The TextDocument object has the following properties and methods:

Properties
ActiveWindow | Language
Application | Name
Collection | Object
FullName | Path
IsActive | Selection
IsReadOnly | TabSize
IsSaved | Type
Kind |
Methods
Close | Save
PrintOut |
Remarks

The TextDocument object can be accessed by using the Documents property of the Application object.

Add-ins and other clients that can use early binding can access the members of the TextDocument object by referencing the PCAN-Explorer Type Library, which resides in the program module PcanExpl.exe. The TextDocument object implements the Dual Interface IPETextDocument (IID: A57FAF44-FAF3-4B16-A395-07E12D1F54BC).

See also

Document Object

Documents Collection


TextEditor Object

The TextEditor object represents the PCAN-Explorer text editor.

Application

TextEditor

The TextEditor object has the following properties. These properties have influence on all text files, that are opened in the editor. For details about text documents, see TextDocument object.

Properties
Application | Overtype
Parent |
Remarks

The TextEditor object can be accessed by using the TextEditor property of the Application object.

Add-ins and other clients that can use early binding can access the members of the TextEditor object by referencing the PCAN-Explorer Type Library, which resides in the program module PcanExpl.exe. The TextEditor object implements the Dual Interface IPETextEditor (IID: 4A80C598-2CA6-4A57-AA22-08AA095D745E).


TextSelection Object

The TextSelection object represents a selection in a text editor window. A selection is a single point (the cursor position) or a continuous area of text.

Application

Documents

TextDocument

TextSelection

Using the TextSelection object, you can move the cursor position, check which text is selected and alter the contents of the selection.

The TextSelection object has the following properties and methods:

Properties
Application | Parent
CurrentColumn | Text
CurrentLine |
Methods
Backspace | GoToLine
Cancel | LineDown
CharLeft | LineUp
CharRight | MoveTo
Copy | PageDown
Cut | PageUp
Delete | Paste
EndOfLine | SelectAll
FindText | StartOfLine
Remarks

The TextSelection object can be accessed by using the Selection property of the TextDocument object.

Add-ins and other clients that can use early binding can access the members of the TextSelection object by referencing the PCAN-Explorer Type Library, which resides in the program module PcanExpl.exe. The TextSelection object implements the Dual Interface IPETextSelection (IID: 60C8731A-ACC8-41FF-8CFF-21470B8EDAD5).

See also

Document Object


TextWindow Object

The TextWindow object represents a window containing an opened text document.

Application

Windows

Window

TextWindow

The TextWindow object has the following properties:

Properties
Application | Selection
Parent | Window
Remarks

The TextWindow object is returned by the Object property of the Window object, if the window is a text window.

Add-ins and other clients that can use early binding can access the members of the TextWindow object by referencing the PCAN-Explorer Type Library, which resides in the program module PcanExpl.exe. The TextWindow object implements the Dual Interface IPETextWindow (IID: 06A18C9C-9E8D-4638-A0BB-1FE46BA569C2).

Example
VBS Macro

Sub TextWindowExample()

' Open a text window before execution

Dim objTW

Set objTW = ActiveWindow.Object

MsgBox objTW.Window.Caption

End Sub

See also

Window Object


TraceMessage Object

The TraceMessage object represents a recorded CAN message.

Application

Windows

Window

TraceWindow

Tracer

Messages

TraceMessage

The TraceMessage object has the following properties:

Properties
Application | IsTimeout
Collection | MsgType
Connection | Multiplexer
Data | PGN
Data64 | Priority
DataArray | SourceAddress
DataLength | Symbol
DataVariant | Timestamp
DestinationAddress | TimestampAbs
DLC | TimestampAbsString
EventCount | VariableStringValue
ID | VariableValue
IsReceived |
Remarks

The TraceMessage object can be accessed by using the Messages property of the Tracer object.

Add-ins and other clients that can use early binding can access the members of the TraceMessage object by referencing the PCAN-Explorer Type Library, which resides in the program module PcanExpl.exe. The TraceMessage object implements the Dual Interface IPETraceMessage (IID: 9875021A-820A-45C6-90FE-455749D84F66).


Tracer Object

The Tracer object represents a PCAN-Explorer Tracer for the logging of CAN messages.

Application

Windows

Window

TraceWindow

Tracer

The Tracer object has the following properties and methods:

Properties
Application | Messages
BufferType | Parent
BufferSize | PlaybackPosition
CanIdFormat | PlaybackRepeat
DataFormat | PlaybackRepeatCount
Description | PlaybackRepeatPause
Document | ShowAbsoluteTime
EntryCount | ShowDLC
FillingLevel | StartTime
Filter | TimestampFormat
FirstMessageSetsStartTime | TraceState
Methods
AbortOperation | Play
ApplyFilter | Start
Pause | Stop
Remarks

The Tracer object can be accessed by using the Tracer property of the TraceWindow object.

Add-ins and other clients that can use early binding can access the members of the Tracer object by referencing the PCAN-Explorer Type Library, which resides in the program module PcanExpl.exe. The Tracer object implements the Dual Interface IPETracer (IID: 43674C7C-22FB-4D2E-9438-11109E5CAA92).


TraceWindow Object

The TraceWindow object represents the view of a Tracer object.

Application

Windows

Window

TraceWindow

The TraceWindow object has the following properties:

Properties
Application | Tracer
Parent | Window
Remarks

The TraceWindow object is returned by the Object property of the Window object, if the window is a trace window.

Add-ins and other clients that can use early binding can access the members of the TraceWindow object by referencing the PCAN-Explorer Type Library, which resides in the program module PcanExpl.exe. The TraceWindow object implements the Dual Interface IPETraceWindow (IID: 8CF6A535-EC1C-4674-92F8-71F7B1E7FA59).

Example
VBS Macro

Sub TraceWindowExample()

' Open a trace window before execution

Dim objTW

Set objTW = ActiveWindow.Object

MsgBox objTW.Window.Caption

End Sub

See also

Window Object


TransmitEvent Object

The TransmitEvent object encapsulates a transmit message that is passed to callback functions that handle transmit-related events.

Application

TransmitMessages

TransmitMessage

TransmitEvent

The TransmitEvent object has the following properties and methods:

Properties
Bus | IsPaused
Comment | LastError
Creator | LastErrorType
CycleTime | MsgType
Data | PGN
Data64 | Priority
DataArray | SourceAddress
DataLength | SymbolName
DataVariant | Timestamp
DestinationAddress | TimestampAbs
DLC | TimestampAbsString
EventCount | VariableStringValue
ID | VariableValue
Methods

PrintToOutputWindow

Remarks

Add-ins and Callback Libraries can access the TransmitEvent object in callback handler functions. It is provided as a function parameter for the events OnBeforeTransmit, OnAfterTransmit, OnResume, OnPause, and OnReset.

Add-ins and Callback Libraries that can use early binding can access the members of the TransmitEvent object by referencing the PCAN-Explorer Callback Events Type Library PECallbackEvents.tlb, which is located in the PCAN-Explorer installation folder. The TransmitEvent object implements the interface IPETransmitEvent.


TransmitMessage Object

The TransmitMessage object represents a CAN message to be sent.

Application

TransmitMessages

TransmitMessage

The TransmitMessage object has the following properties and methods:

Properties
Application | IsPaused
Collection | LastError
Comment | LastErrorType
Connection | MsgType
Creator | Multiplexer
CycleTime | PGN
Data | Priority
Data64 | SourceAddress
DataArray | Symbol
DataLength | Timestamp
DataVariant | TimestampAbs
DestinationAddress | TimestampAbsString
DLC | VariableStringValue
EventCount | VariableValue
ID |
Methods
BeginUpdate | Write
EndUpdate |
Remarks

The TransmitMessage object can be accessed by using the TransmitMessages property of the Application object.

Add-ins and other clients that can use early binding can access the members of the TransmitMessage object by referencing the PCAN-Explorer Type Library, which resides in the program module PcanExpl.exe. The TransmitMessage object implements the Dual Interface IPETransmitMessage (IID: ED66C1FD-9678-46CE-90E2-C75055CCDD03).


TransmitWindow Object

The TransmitWindow object represents the view of a TransmitMessages collection.

Application

Windows

Window

TransmitWindow

The TransmitWindow object has the following properties:

Properties
Application | Parent
Messages | Window
Remarks

The TransmitWindow object is returned by the Object property of the Window object, if the window is a transmit window.

Add-ins and other clients that can use early binding can access the members of the TransmitWindow object by referencing the PCAN-Explorer Type Library, which resides in the program module PcanExpl.exe. The TransmitWindow object implements the Dual Interface IPETransmitWindow (IID: 8A7AB4F4-B5D5-457F-A3C9-932606DE950A).

Example
VBS Macro

Sub TransmitWindowExample()

' Open a Transmit List before execution

Dim objTW

Set objTW = ActiveWindow.Object

MsgBox objTW.Window.Caption

End Sub

See also

Window Object


Variable Object

The Variable object represents a logical or physical value, which corresponds to a defined part of data bytes (a bit string) of a CAN message. The Variable object itself is part of a Variables collection.

Application

SymbolsManager

Symbols

Symbol

Multiplexers

Multiplexer

Variables

Variable

The Variable object has the following properties:

Properties
Application | IsTraced
AutoTransmit | LongName
BitCount | Max
BitStart | Min
Collection | Name
Comment | Offset
DataType | OutputFormat
DecimalPlaces | Parent
DefaultValue | QualifiedName
DisplayMode | Signal
Enum | SPN
EnumName | Unit
Factor | Value
IsMotorola |
Methods

MessageToValue

Remarks

The Variable objects can be accessed by using the Variables property of the Multiplexer object.

Add-ins and other clients that can use early binding can access the members of the Variable object by referencing the PCAN-Explorer Type Library, which resides in the program module PcanExpl.exe. The Variable object implements the Dual Interface IPEVariable (IID: 2997DE92-E56F-4D2F-B670-64DFD4792C25).

See also

Multiplexer Object


VBSMacroFile Object

The VBSMacroFile object represents a loaded VBS Macro file.

Application

VBSMacroFiles

VBSMacroFile

The VBSMacroFile object has the following properties:

Properties
Application | DisplayName
Collection | FullName
Description | IsEnabled
Remarks

The VBSMacroFile objects can be accessed by using the VBSMacroFiles property of the Application object.

Add-ins and other clients that can use early binding can access the members of the VBSMacroFile object by referencing the PCAN-Explorer Type Library, which resides in the program module PcanExpl.exe. The VBSMacroFile object implements the Dual Interface IPEVBSMacroFile (IID: 919C4868-BB1C-4C8F-B7C2-31EF9D3EDF36).

See also

VBSMacroFiles Collection


Window Object

A Window object represents a window of the user interface.

Application

Windows

Window

The Window object has the following properties and methods:

Properties
Application | Next
Caption | Object
Collection | ObjectKind
Document | Previous
Height | Top
HWnd | Type
IsActive | Width
IsVisible | WindowState
Kind | WindowStyle
Left |
Methods

Close

Remarks

Each opened window is represented by a Window object. This object has members (properties and methods) that you can use to manipulate the window.

The current (active) window can be accessed by using the ActiveWindow property of the Application object.

Add-ins and other clients that can use early binding can access the members of the Window object by referencing the PCAN-Explorer Type Library, which resides in the program module PcanExpl.exe. The Window object implements the Dual Interface IPEWindow (IID: 806CA7BF-5B13-4398-ABCC-BE4ABD789C67).


Collections

The term describes a collection of objects that can be created and erased dynamically during runtime. For example, the Documents collection of the Application object contains all open documents in the user interface.

Following collections are available:

Collection | Description
AddIns | All Add-ins listed in the Add-In Manager dialog box. A collection of AddIn objects.
Connections | All connections in the current project. A collection of one or more Connection objects.
Documents | All open documents. A collection of one or more Document objects or TextDocument objects.
Enums | The Enums that are defined in a Symbols file. A collection of Enum objects.
J1939Filters | The filters of a J1939 node. A collection of J1939Filter objects.
MessageFilters | All message filters in the current project. A collection of MessageFilter objects.
Messages | A collection of Message objects, e.g. ReceiveMessage objects, TraceMessage objects, or TransmitMessage objects.
Multiplexers | All Multiplexers of a Symbol. A collection of Multiplexer objects.
OutputWindowPanes | The individual tabs of the output window. A collection of OutputWindowPane objects.
PCANClientConnections | A collection of PCANClientConnection objects.
PCANMessages | A collection of CAN messages.
ProjectItems | A collection of ProjectItem objects.
ReceiveMessages | Received CAN messages. A collection of ReceiveMessage objects.
Signals | A collection of Signal objects.
Symbols | A collection of Symbol objects.
SymbolsManager | A collection of Symbols collections.
TransmitMessages | CAN messages to be sent. A collection of TransmitMessage objects.
Variables | All variables of a Multiplexer. A collection of Variable objects.
VBSMacroFiles | All currently loaded VBS Macro files. A collection of VBSMacroFile objects.
Windows | All open windows. A collection of windows.


AddIns Collection

The AddIns collection represents all Add-ins listed in the Add-In Manager dialog box. The AddIns collection contains AddIn objects.

Application

AddIns

The AddIns collection has the following properties and methods:

Properties
Application | _NewEnum
Count | Parent
Methods

Item

Remarks

The AddIns collection contains all AddIn objects. To find a particular object, iterate through the collection by using the AddIns property of the Application object.

Add-ins and other clients that can use early binding can access the members of the AddIns collection by referencing the PCAN-Explorer Type Library, which resides in the program module PcanExpl.exe. The AddIns collection implements the Dual Interface IPEAddIns (IID: 738E5267-E324-47C3-9C7D-A5D2AD49E38A).

Example

Consider the following VBScript Macro:

VBS Macro

Sub AddInsExample()

Dim objAddIn

For Each objAddIn In AddIns

' Access objAddIn here.

' For example:

MsgBox objAddIn.Name

Next

End Sub

See also

AddIn Object


Connections Collection

The Connections collection represents all connections between PCAN-Explorer and CAN buses. The Connections collection contains one or more Connection objects.

Application

Connections

The Connections collection has the following properties and methods:

Properties
Application | Parent
Count | ReceiveMessages
_NewEnum | TransmitMessages
Methods
Add | Remove
Item |
Remarks

The Connections collection contains all Connection objects. To find a particular object, iterate through the collection by using the Connections property of the Application object.

Add-ins and other clients that can use early binding can access the members of the Connections collection by referencing the PCAN-Explorer Type Library, which resides in the program module PcanExpl.exe. The Connections collection implements the Dual Interface IPEConnections (IID: 3CD268E7-9A47-4B96-864C-F26BA502FF15).

Example

Consider the following VBScript Macro, which lists the names of all connections in a message box:

VBS Macro

Sub ConnectionsExample()

Dim objConnection, str

For Each objConnection In Connections

' Access objConnection here.

' For example:

str = str & objConnection.Name & vbCrLf

Next

MsgBox str

End Sub

See also

Connection Object


Documents Collection

The Documents collection represents all open documents. The Documents collection contains one or more Document or TextDocument objects.

Application

Documents

The Documents collection has the following properties and methods:

Properties
Application | _NewEnum
Count | Parent
Methods
Add | Open
AddDocumentType | SaveAll
CloseAll | TranslateFileName
Item |
Remarks

The Documents collection contains all Document objects. To find a particular object, iterate through the collection by using the Documents property of the Application object.

Add-ins and other clients that can use early binding can access the members of the Documents collection by referencing the PCAN-Explorer Type Library, which resides in the program module PcanExpl.exe. The Documents collection implements the Dual Interface IPEDocuments (IID: C1956813-808F-499A-B03F-B375FCD41AE5).

Example

Consider the following VBScript Macro, which lists all open documents in a message box:

VBS Macro

Sub DocumentsExample()

Dim objDocument, str

For Each objDocument In Documents

' Access objDocument here.

' For example:

str = str & objDocument.FullName & vbCrLf

Next

MsgBox str

End Sub

See also

Document Object

TextDocument Object


Enums Collection

The Enums collection represents all Enums that are defined in a Symbols file. The Enums collection contains Enum objects.

Application

SymbolsManager

Symbols

Enums

The Enums collection has the following properties and methods:

Properties
Application | _NewEnum
Count | Parent
Methods
Add | Remove
Item |
Remarks

The Enums collection contains all Enum objects. To find a particular object, iterate through the collection by using the Enums property of a Symbols collection.

Add-ins and other clients that can use early binding can access the members of the Enums collection by referencing the PCAN-Explorer Type Library, which resides in the program module PcanExpl.exe. The Enums collection implements the Dual Interface IPEEnums (IID: 606C76DF-981C-4622-996F-044B5D33ED6F).

Example

Consider the following VBScript macro, which lists all Enums defined in a specific Symbols file in the Output Window, on the Macros tab:

VBS Macro

Sub EnumsExample()

Dim objSymbols, objEnum

Set objSymbols = SymbolsManager("MySymbolsFile.sym")

For Each objEnum In objSymbols.Enums

' Access objEnum here.

' For example:

PrintToOutputWindow objEnum.Name

Next

End Sub

See also

Enum Object


J1939Filters Collection

The J1939Filters collection can be used to control the messages that are received from its parent J1939Node object.

Application

Connections

Connection

J1939Node

J1939Filters

The J1939Filters collection has the following properties and methods:

Properties
Count | _NewEnum
IsOpenThroughout | Parent
Item |
Methods
Add | OpenThroughout
Clear | Remove
Get |
Remarks

The J1939Filters collection contains J1939Filter objects. The J1939Filters collection can be accessed by using the Filters property of the J1939Node object. This object has members (properties and methods), that you can use to manipulate the J1939 filters.

Add-ins and other clients that can use early binding can access the members of the J1939Filters collection by referencing the J1939Pcan6 Type Library, which resides in the J1939 Add-in library module J1939Pcan.dll. The J1939Filters collection implements the Dual Interface IPCANJ1939Filters (IID: 3495C9B6-F81D-432B-A5F0-F7A5AB7FE417).


MessageFilters Collection

The MessageFilters collection represents all message filters in the current project. The MessageFilters collection contains one or more MessageFilter objects.

Application

MessageFilters

The MessageFilters collection has the following properties and methods:

Properties
Application | _NewEnum
Count | Parent
Methods
Add | Item
Duplicate | Remove
Remarks

The MessageFilters collection contains all MessageFilter objects of the currently loaded project. To find a particular object, iterate through the collection by using the MessageFilters property of the Application object.

Add-ins and other clients that can use early binding can access the members of the MessageFilters collection by referencing the PCAN-Explorer Type Library, which resides in the program module PcanExpl.exe. The MessageFilters collection implements the Dual Interface IPEMessageFilters (IID: 00C00AF7-76C4-436E-B41A-200188430390).

Example

Consider the following VBScript Macro, which lists all message filters in a message box:

VBS Macro

Sub MessageFiltersExample()

Dim objFilter, str

For Each objFilter In MessageFilters

' Access objFilter here.

' For example:

str = str & "Filter " & objFilter.Name & " has " & _

objFilter.ItemCount & " items" & vbCrLf

Next

MsgBox str

End Sub


Messages Collection

The Messages collection represents a collection of CAN messages. The Messages collection contains one or more message objects, e.g. ReceiveMessage objects, TraceMessage objects, or TransmitMessage objects.

The Messages collection has the following properties and methods:

Properties
Application | _NewEnum
Count | Parent
Methods
Add | FindSymbol
Clear | Item
FindID | Remove
FindMultiplexer |
Remarks

You can access the Messages collection for example by using the Messages property of the Tracer object.

Add-ins and other clients that can use early binding can access the members of the Messages collection by referencing the PCAN-Explorer Type Library, which resides in the program module PcanExpl.exe. The Messages collection implements the Dual Interface IPEMessages (IID: 2850BCEE-4BEC-4CEE-9C7F-C0D5371B4ADE).

See also

Connections Collection

Tracer Object


Multiplexers Collection

The Multiplexers collection represents all Multiplexers of a Symbol. The Multiplexers collection contains one or more Multiplexer objects.

Application

SymbolsManager

Symbols

Symbol

Multiplexers

The Multiplexers collection has the following properties and methods:

Properties
Application | _NewEnum
Count | Parent
Methods

Item

Remarks

The Multiplexers collection contains Multiplexer objects. To find a particular object, you can iterate through the collection by using the Multiplexers property of the respective Symbol object.

Add-ins and other clients that can use early binding can access the members of the Multiplexers collection by referencing the PCAN-Explorer Type Library, which resides in the program module PcanExpl.exe. The Multiplexers collection implements the Dual Interface IPEMultiplexers (IID: 6BF30FA9-2337-455B-98F9-9B6AD5570D4E).

Example

Consider the following VBScript Macro, which lists all Multiplexers of the first Symbol in the first Symbols file of the current project:

VBS Macro

Sub MultiplexersExample()

Dim objCollection, objSymbol, objMux

If SymbolsManager.Count > 0 Then

Set objCollection = SymbolsManager.Item(1)

If objCollection.Count > 0 Then

Set objSymbol = objCollection.Item(1)

For Each objMux In objSymbol.Multiplexers

' Access objMux here.

' For example:

PrintToOutputWindow objMux.Name

Next

End If

End If

End Sub

See also

Symbols Collection

Symbol Object

Multiplexer Object


OutputWindowPanes Collection

The OutputWindowPanes collection represents the tabs in the output window. The OutputWindowPanes collection contains one or more OutputWindowPane objects.

Application

Windows

Window

OutputWindow

OutputWindowPanes

The OutputWindowPanes collection has the following properties and methods:

Properties
Application | _NewEnum
Count | Parent
Methods

Add

Item
Remarks

The OutputWindowPanes collection contains all OutputWindowPane objects. To find a particular object, you can iterate through the collection by using the OutputWindowPanes property of the OutputWindow object.

Add-ins and other clients that can use early binding can access the members of the OutputWindowPanes collection by referencing the PCAN-Explorer Type Library, which resides in the program module PcanExpl.exe. The OutputWindowPanes collection implements the Dual Interface IPEOutputWindowPanes (IID: 6CA975C0-FD4D-4809-996B-1C99D5F0145E).

Example

Consider the following VBScript Macro, which adds a new pane to the output window:

VBS Macro

Sub PanesExample()

Dim win, OW, pane

Set win = Windows(peWindowKindOutput)

Set OW = win.Object

Set pane = OW.OutputWindowPanes("My pane")

If pane Is Nothing Then

' Add a new pane to the Output window

Set pane = OW.OutputWindowPanes.Add("My pane")

End If

' Access the new pane here.

' For example:

pane.OutputString("Test")

End Sub

See also

OutputWindow Object

OutputWindowPane Object


PCANClientConnections Collection

The PCANClientConnections collection represents all connections between a PCANClient object and CAN buses. The PCANClientConnections collection contains one or more PCANClientConnection objects.

PCANClient

PCANClientConnections

The PCANClientConnections collection has the following properties and methods:

Properties
Count | Parent
_NewEnum |
Methods
Add | Remove
Item |
Remarks

The PCANClientConnections collection contains PCANClientConnection objects. To find a particular object, iterate through the collection by using the Connections property of the PCANClient object.

Add-ins and other clients that can use early binding can access the members of the PCANClientConnections collection by referencing the PCAN4 Type Library, which resides in the library module Pcan4.dll. The PCANClientConnections collection implements the Dual Interface IPCANClientConnections (IID: 6E46257E-5C11-4CCC-B0C2-04BB02501B1F).

Example

Consider the following VBScript Macro, which connects a PCANClient object to the PCAN-net "TestNet":

VBS Macro

Sub NewClientConnectionSample()

Dim client, conn

Set client = CreateObject("PCAN4.PCANClient")

client.Name = "MyClient"

client.Device = "pcan_usb"

Set conn = client.Connections.Add("TestNet")

' Access the PCANClientConnection object here

End Sub

See also

PCANClient Object


PCANMessages Collection

The PCANMessages collection represents CAN messages. The PCANMessages collection contains one or more PCANMessage objects.

PCANClient

PCANMessages

The PCANMessages collection has the following properties and methods:

Properties
Count | Parent
_NewEnum |
Methods

Add

Item
Remarks

You can access the PCANMessages collection by using the Messages property of the PCANClient object.

Add-ins and other clients that can use early binding can access the members of the PCANMessages collection by referencing the PCAN4 Type Library, which resides in the library module Pcan4.dll. The PCANMessages collection implements the Dual Interface IPCANMessages (IID: 1866BFE9-D2EF-4A1E-8A20-0907EEA371EB).

Example

Consider the following VBS Macro, which connects a PCANClient object to a PCAN-net, and then transmits a CAN message:

VBS Macro

Sub PCANMessagesExample()

Dim client, conn, msg

Set client = CreateObject("PCAN4.PCANClient")

client.Device = "pcan_usb"

client.Name = "Macro"

Set conn = client.Connections.Add("TestNet")

Set msg = client.Messages.Add

' Access the PCANMessage object here.

' For example:

With msg

.Bus = 1

.ID = &H100

.DLC = 3

.Data(0) = &H11

.Data(1) = &H22

.Data(2) = &H33

.Write conn, 0

End With

End Sub

See also

PCANClient Object

PCANMessage Object


ProjectItems Collection

The ProjectItems collection represents a group of items in a project. The ProjectItems collection contains one or more ProjectItem objects.

Application

Project

ProjectItems

The ProjectItems collection has the following properties and methods:

Properties
Application | Parent
Count | Project
_NewEnum |
Methods
AddItem | RemoveItem
CanAddItem | RenameItem
Item |
Remarks

The ProjectItems collection contains ProjectItem objects. You can access the ProjectItems collection e.g. by using the ProjectItems property of the Project object.

Add-ins and other clients that can use early binding can access the members of the ProjectItems collection by referencing the PCAN-Explorer Project System Type Library, which resides in the library module PrjSys.dll. The ProjectItems collection implements the Dual Interface IPEProjectItems (IID: D511D272-625F-401F-B223-ECA77F395C7E).

Example

Consider the following VBS Macro, which lists all files of the current project in the output window, on the Macro tab:

VBS Macro

Sub ProjectItemsExample()

If Not ActiveProject Is Nothing Then _

OutputItems ActiveProject.ProjectItems

End Sub

Sub OutputItems(items)

Dim i, item

For i = 1 To items.Count

Set item = items(i)

If item.Kind = peProjectItemKindFile Then _

PrintToOutputWindow item.Object.RelativePath

If Not (item.ProjectItems Is Nothing) Then _

OutputItems item.ProjectItems

Next

End Sub

See also

ProjectItem Object


ReceiveMessages Collection

The ReceiveMessages collection represents received CAN messages. The ReceiveMessages collection contains one or more ReceiveMessage objects.

Application

ReceiveMessages

The ReceiveMessages collection has the following properties and methods:

Properties
Application | _NewEnum
Count | Parent
Filter |
Methods
Add | Item
Clear | RegisterCallback
FindID | Remove
FindMultiplexer | UnregisterCallback
FindSymbol |
Remarks

The ReceiveMessages collection contains all ReceiveMessage objects. You can access the ReceiveMessages collection by using the ReceiveMessages property of the Application object.

Add-ins and other clients that can use early binding can access the members of the ReceiveMessages collection by referencing the PCAN-Explorer Type Library, which resides in the program module PcanExpl.exe. The ReceiveMessages collection implements the Dual Interface IPEReceiveMessages (IID: 9C3F48A5-E9BA-4898-91C2-941612E9F343).

Example

Consider the following VBS Macro, which displays the number of entries in the Receive List:

VBS Macro

Sub ReceiveMessagesExample()

MsgBox "Number of entries: " & ReceiveMessages.Count

End Sub

See also

Messages Collection

TransmitMessages Collection


Signals Collection

The Signals collection represents all Signals of a Multiplexer. The Signals collection contains one or more Signal objects.

Application

Signals

The Signals collection has the following properties and methods:

Properties
Application | _NewEnum
Count | Parent
Methods
Add | SelectSignal
Item | SelectSignals
Remove |
Remarks

The Signals collection contains all Signal objects. To find a particular object, you can iterate through the collection by using the Signals property of the Application object.

Add-ins and other clients that can use early binding can access the members of the Signals collection by referencing the PCAN-Explorer Type Library, which resides in the program module PcanExpl.exe. The Signals collection implements the Dual Interface IPESignals (IID: 5895A0A5-4C9D-4C79-85DC-B84EAFE12676).

Example

Consider the following VBScript Macro, which prints the name of all Signals to the output window, on the Macros tab:

VBS Macro

Sub SignalsExample()

Dim objSignal

For Each objSignal In Signals

' Access objSignal here.

' For example:

PrintToOutputWindow objSignal.Name

Next

End Sub

See also

Signal Object


Symbols Collection

The Symbols collection contains all Symbols defined in a Symbols file. The Symbols collection contains one or more Symbol objects.

Application

SymbolsManager

Symbols

The Symbols collection has the following properties and methods:

Properties
Application | _NewEnum
Count | Parent
Document | Title
Enums |
Methods

Item

Remarks

The Symbols collection contains Symbol objects. To find a particular object, you can iterate through the collection by using the Symbols property of the Connection object, or by using the Item method of the SymbolsManager collection.

Add-ins and other clients that can use early binding can access the members of the Symbols collection by referencing the PCAN-Explorer Type Library, which resides in the program module PcanExpl.exe. The Symbols collection implements the Dual Interface IPESymbols (IID: 32530A86-13F0-4965-A614-A9E22DC75A08).

Example

Consider the following VBScript macro, which prints the names of all symbols in the first Symbols file to the Output Window, on the Macros tab:

VBS Macro

Sub SymbolsCollectionExample()

Dim objCollection, objSymbol

If SymbolsManager.Count > 0 Then

Set objCollection = SymbolsManager.Item(1)

For Each objSymbol In objCollection

' Access objSymbol here.

' For example:

PrintToOutputWindow objSymbol.Name

Next

End If

End Sub

See also

Symbol Object


SymbolsManager Collection

The SymbolsManager collection contains all Symbols collections that are assigned to the connections in the current project. The SymbolsManager collection contains one or more Symbols collections.

Application

SymbolsManager

The SymbolsManager collection has the following properties and methods:

Properties
Application | _NewEnum
Count | Parent
Enums |
Methods

Item

UpdateSymbols
Remarks

The SymbolsManager collection contains Symbols collections. To find a particular object, you can iterate through the collection by using the SymbolsManager property of the Application object.

Add-ins and other clients that can use early binding can access the members of the SymbolsManager collection by referencing the PCAN-Explorer Type Library, which resides in the program module PcanExpl.exe. The SymbolsManager collection implements the Dual Interface IPESymbolsManager (IID: 7E687603-B7D3-4EC6-AFBF-0DF94BF42290).

Example

Consider the following VBScript Macro, which shows all currently loaded Symbols files in a message box:

VBS Macro

Sub SymbolsManagerExample()

Dim objSymbols, str

For Each objSymbols In SymbolsManager

' Access objSymbols here.

' For example:

str = str & objSymbols.Document.FullName

Next

MsgBox str

End Sub

See also

Symbols Collection


TransmitMessages Collection

The TransmitMessages collection represents CAN messages to be sent. The TransmitMessages collection contains one or more TransmitMessage objects.

Application

TransmitMessages

The TransmitMessages collection has the following properties and methods:

Properties
Application | _NewEnum
Count | Parent
Methods
Add | PauseAll
Clear | RegisterCallback
FindID | Remove
FindMultiplexer | ResumeAll
FindSymbol | UnregisterCallback
Item |
Remarks

The TransmitMessages collection contains TransmitMessage objects. You can access the TransmitMessages collection by using the TransmitMessages property of the Application object, or by using the Messages property of the TransmitWindow object.

Add-ins and other clients that can use early binding can access the members of the TransmitMessages collection by referencing the PCAN-Explorer Type Library, which resides in the program module PcanExpl.exe. The TransmitMessages collection implements the Dual Interfaces IPETransmitMessages (IID: F59F8D70-86B1-46F0-8412-CB5964CEB694), and IPETransmitMessagesEx (IID: 9938AECE-5968-42AF-92B5-89EF73F90713), which is derived from IPETransmitMessages.

Example

Consider the following VBS Macro, which adds a new message to the Transmit List:

VBS Macro

Sub TransmitMessagesExample()

Dim msg

Set msg = TransmitMessages.Add

' Initialize the CAN message

With msg

If Connections.Count > 0 Then _

Set .Connection = Connections(1)

.ID = &H100

.DataLength = 3

.Data(0) = &H11

.Data(1) = &H22

.Data(2) = &H33

End With

End Sub

The same can be done in a C# application, for example in a Desktop Console App:

C#

static void Main(string[] args)

{

IPEApplication app = new PCANExplorer6.Application();

app.MainWindow.IsVisible = true;

// Open a project

app.Documents.Open("$(MyDocsDir)\\PCAN-Explorer 6\\Projects\\MyProject\\MyProject.peproj");

// Create and initialize a Transmit Message

IPETransmitMessage msg = app.TransmitMessages.Add() as IPETransmitMessage;

if (app.Connections.Count > 0)

msg.Connection = app.Connections.Item(1);

msg.ID = 0x100;

msg.DataLength = 3;

msg.Data[0] = 0x11;

msg.Data[1] = 0x22;

msg.Data[2] = 0x33;

}

See also

Messages Collection

ReceiveMessages Collection


Variables Collection

The Variables collection represents all variables of a Multiplexer, or the virtual variables in a Symbols collection. The Variables collection has one or more Variable objects.

Application

SymbolsManager

Symbols

Symbol

Multiplexers

Multiplexer

Variables

The Variables collection has the following properties and methods:

Properties
Application | _NewEnum
Count | Parent
Methods

Item

Remarks

The Variables collection contains Variable objects. To find a particular object, you can iterate through the collection by using the Variables property of the corresponding Multiplexer object.

Add-ins and other clients that can use early binding can access the members of the Variables collection by referencing the PCAN-Explorer Type Library, which resides in the program module PcanExpl.exe. The Variables collection implements the Dual Interface IPEVariables (IID: EA036A0A-92B3-4844-9730-F960B9FD4E7E).

Example

The following code snippet from a VBScript Macro lists all Variables of a Multiplexer object in the output window, on the Macros tab:

VBS Macro

Dim objVar

For Each objVar In objMux.Variables

' Access objVar here.

' For example:

PrintToOutputWindow objVar.Name

Next

See also

Multiplexer Object

Variable Object

Symbols Collection


VBSMacroFiles Collection

The VBSMacroFiles collection represents all loaded VBS Macro files. The VBSMacroFiles collection contains VBSMacroFile objects.

Application

VBSMacroFiles

The VBSMacroFiles collection has the following properties and methods:

Properties
Application | _NewEnum
Count | Parent
Methods

Item

Remarks

The VBSMacroFiles collection contains all VBSMacroFile objects. To find a particular object, iterate through the collection by using the VBSMacroFiles property of the Application object.

Add-ins and other clients that can use early binding can access the members of the VBSMacroFiles collection by referencing the PCAN-Explorer Type Library, which resides in the program module PcanExpl.exe. The VBSMacroFiles collection implements the Dual Interface IPEVBSMacroFiles (IID: 1687BACA-AA94-4F11-B3D2-DF01B7855BA4).

Example

Consider the following VBScript Macro, which shows all loaded VBS Macro files in a message box:

VBS Macro

Sub VBSMacroFilesExample()

Dim objFile, str

For Each objFile In VBSMacroFiles

' Access objFile here.

' For example:

str = str & objFile.FullName

Next

MsgBox str

End Sub

See also

VBSMacroFile Object


Windows Collection

The Windows collection represents all open windows in PCAN-Explorer.

Application

Windows

The Windows collection has the following properties and methods:

Properties
Application | _NewEnum
Count | Parent
Methods
Arrange | Item
CloseAll |
Remarks

The Windows collection contains all Window objects. To find a particular object, iterate through the collection by using For Each ... Next in a VBScript Macro.

Add-ins and other clients that can use early binding can access the members of the Windows collection by referencing the PCAN-Explorer Type Library, which resides in the program module PcanExpl.exe. The Windows collection implements the Dual Interface IPEWindows (IID: C4F64075-F612-4AC8-A082-92C76E0131EC).

Example

The following VBS Macro prints the captions of all windows to the output window, on the Macros tab:

VBS Macro

Sub WindowsExample()

Dim objWindow

For Each objWindow In Windows

' Access objWindow here.

' For example:

PrintToOutputWindow objWindow.Caption

Next

End Sub

See also

Window Object


Properties

Properties are the objects' characteristics. Window objects, for example, have Height and Width properties. These properties correspond to the height and the width of the windows.

For more information about properties, see Introduction to Properties.

  • Properties A-F

  • Properties G-K

  • Properties L-P

  • Properties Q-T

  • Properties U-Z


Properties A-F

The following table contains all properties beginning with letters A to F:

Property | Description
AccCode | Sets or returns the acceptance code value of a MessageFilterItem object.
AccMask | Sets or returns the acceptance mask value of a MessageFilterItem object.
ActiveDocument | Returns the Document or TextDocument object that is currently active.
ActivePane | Returns the active pane in the Output window.
ActiveProject | Returns the Project object that is currently loaded.
ActiveWindow | Returns a Window object that represents the active window (the window on top).
AddIns | Returns the AddIns collection that represents all the Add-ins listed in the Add-in Manager dialog box.
AddressClaimStatus | Returns the current address claiming status of a J1939 node.
AddressName | Sets or returns a J1939AddrName object.
Application | Returns the PCAN-Explorer Application object.
ApplicationDataDirectory | Returns the directory that PCAN-Explorer uses to store files containing settings and other data.
AsString | Returns a human-readable interpretation of a bit rate value.
AutoConnect | Sets or returns whether a PCANClient object automatically connects to a PCAN net.
AutoRegister | Sets or returns whether PCAN-Explorer registers itself automatically at the PCAN system at start-up.
AutoTransmit | Sets or returns whether the parent Multiplexer of a Variable is transmitted automatically, when the Variable's value is changed.
BitCount | Returns the number of bits that are used by a variable in the data bytes of the CAN message.
BitRate | Returns the bit rate of a connection.
BitStart | Returns a variable's first bit's index in the data bytes of the CAN message.
BTR0BTR1 | Returns the value of the bus timing registers BTR0 and BTR1 if the PCANBitrate object represents a bit rate for an SJA1000 CAN controller.
BufferSize | Sets or returns the buffer size of a tracer.
BufferType | Sets or returns the type of data buffer a tracer uses to store logged CAN messages.
Bus | Sets or returns the Bus number (1-16) that is assigned to the object.
CalculateBusLoad | Sets or returns whether the current bus load is calculated and the bus load indicator is shown for a connection.
CanId | Returns the CAN ID of a Symbol.
CanIdFormat | Sets or returns the format that is used to display CAN IDs in a trace window.
CanIdHi | Returns the upper CAN ID of a Symbol.
Caption | Returns a string containing the caption of a window.
ClaimedAddress | Returns the address that is currently claimed for a J1939 connection.
ClientName | Sets or returns the name of the PCAN client a J1939 node uses for low-level CAN communication.
Clock | Returns the clock frequency on which a CAN bit rate parameter set is based on.
Collection | Returns the collection containing the object supporting this property.
Color | Returns the color that has been defined to display a Multiplexer.
Comment | Returns the comment that has been defined for a Multiplexer, Symbol, Signal, or Variable object.
CommunicationObject | Returns an object that is responsible for the communication of messages through the connected bus.
Connected | Returns whether the J1939 node object is connected to a CAN bus.
Connection (Variation 1) | Sets or returns a string specifying the connection.
Connection (Variation 2) | Sets or returns a Connection object with which a message object is associated.
Connections (Variation 1) | Returns the Connections collection.
Connections (Variation 2) | Returns the PCANClientConnections collection.
Count | Returns the number of elements in a collection.
Creator | Sets or returns the text that is displayed in transmit lists in the "Creator" column for a message.
CurrentColumn | Returns the column of the caret in a Text window.
CurrentDirectory | Sets or returns the directory used by the Open command on the File menu.
CurrentLine | Returns the line number where the caret is located in a Text window.
CurrentTime | Returns the current PCAN-Explorer time that is used as a basis for generating timestamps.
CycleTime [Variation 1] | Sets or returns the transmit cycle time of a CAN message.
CycleTime [Variation 2] | Returns the transmit cycle time of a Multiplexer.
Data | Sets or returns the data bytes of a CAN message.
Data64 | Sets or returns the 8 data bytes of a CAN message in a single call.
DataArray | Sets or returns all data bytes of a CAN message in a SafeArray.
DataBitrate | Returns the data bit rate of a CAN FD bit rate.
DataFormat | Sets or returns the format that is used to display data bytes in a trace window.
DataLength | Returns the number of data bytes of a Multiplexer.
DataType | Returns the data type of a Signal or a Variable.
DataVariant | Sets or returns all data bytes of a CAN message in a Variant.
DecimalPlaces | Sets or returns the number of decimal places that are displayed for a Signal value or Variable value.
DefaultData | Returns the data bytes of a Multiplexer, which are filled with the default values of the Variables.
DefaultMultiplexer | Returns the Default Multiplexer of a Symbol.
DefaultValue | Returns a Variables's default value.
Description | Sets or returns a string containing the object's description.
DestinationAddress | Sets or returns a J1939 Destination Address.
Device [Variation 1] | Sets or returns the name of the device, which serves as basis of the PCAN system and manages the used CAN hardware.
Device [Variation 2] | Returns or sets the PCAN device that the object uses to access CAN hardware and to communicate with J1939 buses.
DisplayMode | Returns the display mode of a Multiplexer or a Variable.
DisplayName | Returns the name of a VBS Macro file as it is displayed in the various PCAN-Explorer windows.
DLC | Sets or returns the Data Length Code of a CAN message.
Document | Retrieves the Document object associated with the object.
Documents | Returns a Documents collection.
DriverVersion | Returns the version of the driver that is installed for managing the CAN hardware.
EntryCount | Returns the number of entries in a trace buffer or file.
Enum | Returns the Enum object that is associated with a Signal or Variable.
EnumName | Sets or returns the name of an Enum that is associated with a Signal or Variable.
Enums | Returns the Enums collection.
ErrorFrames | Sets or returns whether a PCAN client shall receive Error Frames.
ErrorFramesEnabled | Sets or returns whether Error Frames can pass through a MessageFilterItem object if the filter item operates in Options mode.
ErrorWarningsEnabled | Sets or returns whether Error Warnings can pass through a MessageFilterItem object if the filter item operates in Options mode.
EventCount | Returns a value indicating the number of times a CAN message has been received or transmitted.
ExcludeMode | Sets or returns whether a filter item operates in Exclude mode.
ExtensibilityObject | Allows access to the PEAddIn object implemented by an Add-in.
Factor | Returns the multiplier that was defined for the for the variable to transform its value from a raw value into a physical value.
FillingLevel | Returns the current filling level of a tracer.
Filter | Sets or returns a MessageFilter object that is used by the object to filter messages.
FilterCode | Sets or returns the acceptance code of the message filter for this PCAN client.
FilterMask | Sets or returns the acceptance mask of the message filter for this PCAN client.
Filters | Returns a J1939Filters collection that can be used to control the messages that are received from a J1939Node object.
FirstMessageSetsStartTime | Determines, whether the timestamp of the first message logged by a tracer is used as the reference time that marks the start of a tracer.
Flags | Returns the Flags attribute of a J1939Filter object.
FullName | Returns the full name of a file including the file path.

See also

Properties G-K

Properties L-P

Properties Q-T

Properties U-Z


AccCode Property

Applies to: MessageFilterItem object

Sets or returns the acceptance code value of a MessageFilterItem object that operates in Code/Mask mode.

Syntax

object.AccCode [=value]

Parameters

object

An expression that evaluates to a MessageFilterItem object.

value

A Long that specifies a new value for the property.

Property value

A Long value that specifies the acceptance code of a filter that operates in Code/Mask mode.

Remarks

Together with the AccMask property, the AccCode property specifies a filter according to the filter mechanism of a SJA1000 CAN controller.

The AccCode property only has an effect, if the Type property of the MessageFilterItem object is set to peFilterItemCodeMask.

See also

AccMask Property

Type Property


AccMask Property

Applies to: MessageFilterItem object

Sets or returns the acceptance mask value of a MessageFilterItem object that operates in Code/Mask mode.

Syntax

object.AccMask [=value]

Parameters

object

An expression that evaluates to a MessageFilterItem object.

value

A Long that specifies a new value for the property.

Property value

A Long value that specifies the acceptance mask of a filter that operates in Code/Mask mode.

Remarks

Together with the AccCode property, the AccMask property specifies a filter according to the filter mechanism of a SJA1000 CAN controller.

The AccMask property only has an effect, if the Type property of the MessageFilterItem object is set to peFilterItemCodeMask.

See also

AccCode Property

Type Property


ActiveDocument Property

Applies to: Application object

Returns the Document or TextDocument object that is currently active.

Syntax

object.ActiveDocument

Parameters

object

An expression that evaluates to an Application object.

Property value

The Document or a TextDocument object that is currently active.

Remarks

An active document is one that has the focus. To make another document active, set the focus on its window.

The document retrieved is a Document object or a TextDocument object. The type of the object depends on the type of the document.

If the window that is currently active in the PCAN-Explorer user interface does not have a document, for example the Receive/Transmit window, the ActiveDocument property returns the value Nothing in VBScript. In Visual C++ this corresponds to the value NULL, and C# to the value null.

Example
VBS Macro

Sub DocumentExample()

' A new document must be created before

' this code can be executed.

Dim doc, desc

Set doc = ActiveDocument

If Not doc Is Nothing Then

desc = "You are working on a "

If doc.ReadOnly Then

desc = desc & "write protected"

Else

desc = desc & "writable"

End If

desc = desc & " document named " & doc.Name

Else

desc = "No document is active"

End If

MsgBox desc

End Sub


ActivePane Property

Applies to: OutputWindow object

Gets the most recently active pane in the Output Window.

Syntax

object.ActivePane

Parameters

object

An expression that evaluates to an OutputWindow object.

Property value

An OutputWindowPane object.

Example
VBS Macro

Sub ActivePaneExample()

Dim win

Dim OW

Dim pane

Set win = Windows(peWindowKindOutput)

Set OW = win.Object

' Add a new pane to the Output window

Set pane = OW.OutputWindowPanes.Add("My Pane")

' Display a line of text

pane.OutputString("A Text")

MsgBox "Active page: " & OW.ActivePane.Name

End Sub


ActiveProject Property

Applies to: Application object

Returns the Project object that represents the currently loaded project.

Syntax

object.ActiveProject

Parameters

object

An expression that evaluates to an Application object.

Property value

A Project object.

Example

The following example displays the name of the currently loaded project:

VBS Macro

Sub ActiveProjectExample()

Dim prj

Set prj = ActiveProject

MsgBox "Loaded project: " & prj.Name

End Sub


ActiveWindow Property

Applies to: Application object, Document object

Returns a Window object that represents the active window (the window on top).

Syntax

object.ActiveWindow

Parameters

object

An expression that evaluates to an Application object or a Document object.

Property value

A Window object.

Remarks

If you access the ActiveWindow property of the Application object, you get the currently active window inside the PCAN-Explorer main window. If no window is currently active, the property returns the value Nothing in VBScript. In Visual C++ this corresponds to the value NULL, and C# to the value null.

Example
VBS Macro

Sub ActiveDocumentExample()

' A new document must be created before

' this code can be executed.

Dim objDoc

Set objDoc = ActiveDocument

MsgBox objDoc.ActiveWindow.Caption

End Sub


AddIns Property

Applies to: Application object

Returns the AddIns collection that represents all the Add-ins listed in the Add-in Manager dialog box.

Syntax

object.AddIns

Parameters

object

An expression that evaluates to an Application object.

Property value

An AddIns collection.

Remarks

The AddIns collection represents all the Add-ins listed in the Add-in Manager dialog box (Tools menu). Each Add-in in the collection is represented by an AddIn object.

Example

The following example accesses the AddIns collection:

VBS Macro

Sub AddInsExample()

MsgBox AddIns.Count,,"Number of Add-ins"

End Sub


AddressClaimStatus Property

Applies to: J1939Node object

Returns the current address claiming status of a J1939 node.

Syntax

object.AddressClaimStatus

Parameters

object

An expression that evaluates to a J1939Node object.

Property value

A TClaimedStatus enum value. The following values are possible:

  • tcsNone (0): No address has been claimed yet.

  • tcsNotClaim (1): The addressing protocol is disabled for the node. See UseAddressingProtocol property.

  • tcsClaiming (2): The node object is currently in the process of claiming an address.

  • tcsClaimed (3): An address has been claimed.

  • tcsCannotClaim (4): Claiming an address was not successful. Possible reason: An address conflict exists because another J1939 ECU on the bus has claimed the same address, and has a lower NAME value.

  • tcsReleased (5): A previously claimed address was released because the ReleaseAddress method was called.

Example

In the following example, a J1939 node claims an address and then displays the address claiming status:

VBS Macro

Sub J1939_AddressClaimStatusExample()

Dim node

Set node = CreateObject("J1939Pcan6.PCANJ1939Node")

node.Device = tcdUSB ' = 5

node.ClientName = "Macro"

node.NetName = "TestNet"

node.PreferredAddress = 10

If node.Connect Then

node.ClaimAddress

Select Case node.AddressClaimStatus

Case tcsCannotClaim:

MsgBox "Cannot claim address 10",,"Macro"

Case tcsClaimed:

MsgBox "Address 10 claimed",,"Macro"

End Select

End If

End Sub

See also

ClaimAddress Method

ClaimedAddress Property

PreferredAddress Property

ReleaseAddress Method

UseAddressingProtocol Property


AddressName Property

Applies to: J1939Node object

Sets or returns a J1939AddrName object, which encapsulates the NAME value that uniquely identifies an ECU on the network.

Syntax

object.AddressName [=NameObj]

Parameters

object

An expression that evaluates to a J1939Node object.

NameObj

An expression that evaluates to a J1939AddrName object.

Property value

A J1939AddrName object.

Example

The following example changes a property of the NAME value:

VBS Macro

Sub J1939_AddressNameExample()

' The first connection in the project

' must be a J1939 connection

If Connections(1).Protocol = peProtocolJ1939 Then

' Access the J1939Node object

Dim node

Set node = Connections(1).CommunicationObject

node.AddressName.FunctionInstance = 2

End If

End Sub


Application Property

Applies to: AddIn object, AddIns collection, Application object, CallbackLibraryEvent object, Connection object, Connections collection, Document object, Documents collection, Enum object, Enums collection, MessageFilter object, MessageFilters collection, Multiplexer object, Multiplexers collection, OutputWindow object, OutputWindowPane object, OutputWindowPanes collection, Project object, ProjectItem object, ReceiveMessage object, ReceiveMessages collection, ReceiveTransmitWindow object, Signal object, Signals collection, Symbol object, Symbols collection, TextDocument object, TextEditor object, TextSelection object, TextWindow object, TraceMessages collection, Tracer object, TransmitMessage object, TransmitMessages collection, TransmitWindow object, Variable object, Variables collection, VBSMacroFile object, VBSMacroFiles collection, Window object, Windows collection

Returns the PCAN-Explorer Application object.

Syntax

object.Application

Parameters

object

An expression that evaluates to one of the objects in the Applies To list above.

Property value

The Application object.

Remarks

The Application object represents the whole PCAN-Explorer application. It allows the access to other objects in the PCAN-Explorer object model and makes the access to methods and properties possible, which influence the whole application.

Example

The following example returns the PCAN-Explorer Application object, using the Document object:

VBScript

Dim app

Set app = myDocument.Application


ApplicationDataDirectory Property

Applies to: Application object

Returns the directory that PCAN-Explorer uses to store files containing settings and other data.

Syntax

object.ApplicationDataDirectory

Parameters

object

An expression that evaluates to an Application object. When you access the ApplicationDataDirectory property of the Application object, you can omit object because the name of the Application object is implied when you access its properties and methods.

Property value

A String containing the directory that PCAN-Explorer uses to store files containing settings and other data.

Example

The following example displays the directory, into which PCAN-Explorer stores data files:

VBScript

MsgBox ApplicationDataDirectory


AsString Property

Applies to: PCANBitrate object

Returns a human-readable interpretation of a bit rate value.

Syntax

object.AsString

Parameters

object

An expression that evaluates to a PCANBitrate object.

Property value

A String value that indicates the bit rate, e.g. "1 Mbit/s" for a CAN bit rate, or "Nominal 500 kbit/s, Data 2 Mbit/s" for a CAN FD bit rate.

Example

The following example displays the bit rate of the first connection in the project:

VBS Macro

Sub AsStringExample()

' The first connection in the project must

' be a CAN connection

If Connections(1).Protocol = peProtocolCAN Then

Dim ClientConn, bitrate

Set ClientConn = Connections(1).CommunicationObject

Set bitrate = ClientConn.HardwareBitRate

MsgBox "Bit rate of Hardware = " & bitrate.AsString

End If

End Sub


AutoConnect Property

Applies to: PCANClient object

Sets or returns whether a PCANClient object automatically connects to a PCAN net.

Syntax

object.AutoConnect [=boolean]

Parameters

object

An expression that evaluates to a PCANClient object.

boolean

A Boolean value that specifies the new value of the property.

Property value

A Boolean value that specifies whether the PCANClient object automatically connects to a PCAN net when a new connection is added using the Add method of the PCANClientConnections collection. If True, the object automatically connects to the PCAN net (the default). If False, the object does not automatically connect to a PCAN net. A connection to the net then must be established manually by setting the IsConnected property of the PCANClientConnection object.

Example

The following example manually connects a PCANClient object to the net "TestNet":

VBScript

Dim client, conn

Set client = CreateObject("PCAN4.PCANClient")

client.AutoConnect = False

Set conn = client.Connections.Add("TestNet")

conn.IsConnected = True

See also

PCANClientConnections Collection


AutoRegister Property

Applies to: PCANClient object

Sets or returns whether a PCANClient object registers itself automatically at the PCAN system when a client name is assigned.

Syntax

object.AutoConnect [=boolean]

Parameters

object

An expression that evaluates to a PCANClient object.

boolean

A Boolean that specifies the new value of the property.

Property value

A Boolean value that specifies whether the PCANClient object automatically registers itself at the PCAN system when a client name is assigned by setting the Name property. If True, the object automatically registers itself at the PCAN system (the default). If False, the object does not automatically register itself at the PCAN system. The object then must be registered manually by invoking the Register method of the PCANClient object.

Remarks

The AutoRegister property is mainly important at design time of programs that make use of the PCANClient COM component in order to use the PCAN system for communication with CAN busses. The PCANClient COM component can be linked into various development environments, e.g. like Visual Studio or Delphi. At design time, the values of the properties can be configured in a visual property editor. These values are then applied to the properties at the runtime of the created program.


AutoTransmit Property

Applies to: Variable object

Sets or returns whether the Multiplexer that contains the Variable is transmitted automatically when the Variable's value is set by using either its Value or StringValue property.

Syntax

object.AutoTransmit [=value]

Parameters

object

An expression that evaluates to a Variable object.

value

A Boolean that specifies the new value of the property.

Property value

A Boolean value that specifies whether the Multiplexer is transmitted automatically. If True, the Multiplexer is transmitted automatically (the default). If False, the Multiplexer is not transmitted automatically.

Remarks

In the object hierarchy, a Multiplexer object is always the immediate parent of a Variable object. A Multiplexer can be empty if there are no Multiplexers defined for the parent Symbol. In this case, it only serves as a container for the Symbol's Variables.

If the value of a Signal is set, which is based on a CAN variable, no CAN message will be sent if the Variable's AutoTransmit property is set to False.

If the AutoTransmit property is set to True, the Multiplexer is transmitted once each time the value of the Variable is set using the Value or StringValue properties. Even if the Variable's value hasn't changed.

Example

The following example changes the Variable SendSymbolMux.SendMux.HexValue2 from the sample file "Sample.sym", so that the parent Multiplexer is not transmitted automatically:

VBScript

Dim symbols, variable

Set symbols = SymbolsManager("Sample")

Set variable = symbols("SendSymbolMux").Multiplexers("SendMux").Variables("HexValue2")

variable.AutoTransmit = False

- or -

VBScript

Dim variable

Set variable = Signals("HexValue2").Source

variable.AutoTransmit = False

- or -

VBScript

Signals("HexValue2").Source.AutoTransmit = False

See also

StringValue Property

Value Property

Source Property


BitCount Property

Applies to: Variable object

Returns the number of bits that are used by a variable in the data bytes of the CAN message.

Syntax

object.BitCount

Parameters

object

An expression that evaluates to a Variable object.

Property value

A Long value that indicates the number of bits used by the variable.

Example

The following example retrieves the length of a variable:

VBScript

Dim l

l = myVar.BitCount

See also

BitStart Property


BitRate Property

Applies to: Connection object

Returns the bit rate of a connection.

Syntax

object.BitRate

Parameters

object

An expression that evaluates to a Connection object.

Property value

A String value that indicates the bit rate of the connection.

Examples: For standard CAN or J1939 connections, "500 kbit/s"; for CAN FD connections, "Nominal 500 kbit/s, Data 2 Mbit/s".

Remarks

The BitRate property of the Connection object is read-only.

Example

The following example displays the bit rate of the first connection in the project:

VBS Macro

Sub BitRateExample()

MsgBox Connections(1).BitRate

End Sub


BitStart Property

Applies to: Variable object

Returns a variable's first bit's index in the data bytes of the CAN message.

Syntax

object.BitStart

Parameters

object

An expression that evaluates to a Variable object.

Property value

A Long value that indicates the index of the first bit in the data bytes of the CAN message. The index value is 0-based. Index 0 is bit 0 of data byte 0, index 63 is bit 7 of data byte 7.

Example

The following example retrieves the start index of a variable:

VBScript

Dim i

i = myVar.BitStart

See also

BitCount Property


BTR0BTR1 Property

Applies to: PCANBitrate object

Returns the value of the bus timing registers BTR0 and BTR1 if the PCANBitrate object represents a bit rate for an SJA1000 CAN controller.

Syntax

object.BTR0BTR1

Parameters

object

An expression that evaluates to a PCANBitrate object.

Property value

A Long containing a 16-bit value, which is a combination of the two 8-bit values from the bus timing registers BTR0 and BTR1 of the SJA1000 CAN controller. To get a human-readable interpretation of the bit rate value, access the AsString property.

Remarks

If the PCANBitrate object represents a bit rate for an SJA1000 CAN controller, the Clock property has the value 8000000 (8 MHz).

Example

The following example queries the BTR0BTR1 property of a PCANBitrate object:

VBS Macro

Sub BTR0BTR1Example()

' The first connection in the project must

' be a CAN connection

If Connections(1).Protocol = peProtocolCAN Then

Dim ClientConn, bitrate

Set ClientConn = Connections(1).CommunicationObject

Set bitrate = ClientConn.HardwareBitRate

If bitrate.Clock = 8000000 Then

MsgBox "BTR0/BTR1 = " & Hex(bitrate.BTR0BTR1) & "h"

End If

End If

End Sub

See also

HardwareBaudRate Property

NetBaudRate Property


BufferSize Property

Applies to: Tracer object

Sets or returns the buffer size of a tracer.

Syntax

object.BufferSize [=value]

Parameter

object

An expression that evaluates to a Tracer object.

value

A Long specifying a new buffer size for the tracer.

Property value

A Long value that indicates the current size of the buffer.

Remarks

The BufferSize property only has a meaning if the BufferType property is either set to peTraceBufferTypeLinear or peTraceBufferRing.

Setting the BufferSize property of a tracer that is currently recording messages clears the buffer.

Example

The following example displays the buffer size of a tracer:

VBS Macro

Sub BufferSizeExample()

If ActiveWindow.Kind = peDocumentKindTrace Then

Dim tracer

Set tracer = ActiveWindow.Object.Tracer

MsgBox tracer.BufferSize

End If

End Sub

See also

BufferType Property


BufferType Property

Applies to: Tracer object

Sets or returns the type of data buffer a tracer uses to store logged CAN messages.

Syntax

object.BufferType [=type]

Parameter

object

An expression that evaluates to a Tracer object.

type

A PeTraceBufferType enum value that specifies a new type for the buffer.

Property value

A PeTraceBufferType enum value. Possible values are:

  • peTraceBufferTypeDynamic (0): A dynamic buffer that continuously expands while messages are logged.

  • peTraceBufferTypeLinear (1): A buffer with a fixed size. If the buffer is full, the tracer stops.

  • peTraceBufferTypeRing (2): A buffer with a fixed size. If the buffer is full, the oldest messages in the buffer will be overwritten.

  • peTraceBufferTypeFile (3): Trace data is not held in memory but is stored in a file that grows in size while messages are logged.

Example

The following example configures a tracer to use a ring buffer.

VBScript

myTracer.BufferType = peTraceBufferTypeRing

See also

FillingLevel Property


Bus Property

Applies to: Connection object, MessageFilterItem object, ReceiveEvent object, TransmitEvent object

Sets or returns the Bus number (1-16) that is assigned to the object.

Syntax

object.Bus [=value]

Parameter

object

An expression that evaluates to one of the objects in the Applies To list above.

value

A Long that sets the new value of the property.

Property value

A Long value that specifies a Bus number (1-16).

Remarks

The Bus property of the ReceiveEvent and TransmitEvent object is read-only.


CalculateBusLoad Property

Applies to: Connection object

Sets or returns whether the current bus load is calculated and the bus load indicator is shown for a connection.

Syntax

object.CalculateBusLoad [=boolean]

Parameters

object

An expression that evaluates to a Connection object.

boolean

A Boolean that specifies the new value of the property.

Property value

A Boolean value that specifies whether the bus load is calculated and the bus load indicator is shown for a connection:

  • False: The bus load calculation is disabled and the bus load indicator is hidden (the default)

  • True: The bus load calculation is enabled and the bus load indicator is shown.

Remarks

If the bus load calculation is enabled, the current bus load is shown in the Bus Load column in the Connections Window.

Example

The following example activates the bus load calculation for the first connection in the project:

VBS Macro

Sub CalculateBusLoadExample()

Connections(1).CalculateBusLoad = True

End Sub


CanId Property

Applies to: Symbol object

Returns the CAN ID of a Symbol.

Syntax

object.CanId

Parameters

object

An expression that evaluates to a Symbol object.

Property value

A Long value that represents the CAN ID that is assigned to the Symbol.

Example

The following example shows the CAN ID's of all symbols in a Symbols collection in a message box:

VBS Macro

Sub CanIdExample()

If SymbolsManager.Count = 0 Then Exit Sub

' Get the first Symbols collection

Dim symbols

Set symbols = SymbolsManager(1)

Dim mySymbol, strMsg

For Each mySymbol In symbols

strMsg = strMsg & Hex(mySymbol.CanId) & vbCrLf

Next

MsgBox strMsg,,"CAN ID's"

End Sub


CanIdFormat Property

Applies to: Tracer object

Sets or returns the format that is used to display CAN IDs in a trace window.

Syntax

object.CanIdFormat [=value]

Parameters

object

An expression that evaluates to a Tracer object.

boolean

A PeTraceCanIdFormat enum value that sets the new value of the property.

Property value

A PeTraceCanIdFormat enum value. Possible values are:

  • peTraceCanIdFormatHexadecimal (0): CAN IDs are displayed in hexadecimal notation.

  • peTraceCanIdFormatDecimal (1): CAN IDs are displayed in decimal notation.

Example

The following example toggles the value of the CanIdFormat property of the foreground tracer window:

VBS Macro

Sub CanIdFormatExample()

   If ActiveDocument.Kind = peDocumentKindTrace Then

      Dim tracer

      Set tracer = ActiveWindow.Object.Tracer

      If tracer.CanIdFormat = peTraceCanIdFormatHexadecimal Then

        tracer.CanIdFormat = peTraceCanIdFormatDecimal

      Else

        tracer.CanIdFormat = peTraceCanIdFormatHexadecimal

      End If

   End If

End Sub

See also

DataFormat Property

TimestampFormat Property


CanIdHi Property

Applies to: Symbol object

Returns the upper CAN ID of a Symbol.

Syntax

object.CanIdHi

Parameters

object

An expression that evaluates to a Symbol object.

Property value

A Long value that represents the upper CAN ID of a range of CAN ID's that is assigned to a symbol.

Remarks

Symbols that represent receive-only messages can interpret a range of CAN ID's. When a range of CAN ID's is assigned to a Symbol, the CanIdHi property contains the upper limit of the CAN ID's to be interpreted.

Example

The following example lists all CAN ID's of Symbols that interpret a range of CAN ID's, and shows them in a message box:

VBS Macro

Sub CanIdHiExample()

If SymbolsManager.Count = 0 Then Exit Sub

' Get the first Symbols collection

Dim symbols

Set symbols = SymbolsManager(1)

Dim mySymbol, strMsg

For Each mySymbol In symbols

If mySymbol.CanIdHi > mySymbol.CanId Then

strMsg = strMsg & Hex(mySymbol.CanId) & "-" & _

Hex(mySymbol.CanIdHi) & vbCrLf

End If

Next

MsgBox strMsg,,"CAN ID's"

End Sub


Caption Property

Applies to: Window object

Returns a string containing the caption of a window.

Syntax

object.Caption

Parameters

object

An expression that evaluates to a Window object.

Property value

A String value that represents the caption of the window.

Example

The following example returns the caption of the active window:

VBScript

Dim cap

cap = ActiveWindow.Caption


ClaimedAddress Property

Applies to: J1939Node object

Returns the address that is currently claimed for a J1939 connection.

Syntax

object.ClaimedAddress

Parameters

object

An expression that evaluates to a J1939Node object.

Property value

A Byte value that represents the currently claimed address. If no address is currently claimed, the property contains the Null Address (254).

Example

The following example shows the currently claimed address of the first J1939 connection in the project:

VBS Macro

Sub J1939_ClaimedAddressExample()

If Connections(1).Protocol = peProtocolJ1939 Then

Dim node

Set node = Connections(1).CommunicationObject

If Not node Is Nothing Then

' Connection is enabled

MsgBox node.ClaimedAddress,,"Claimed Address"

End If

End If

End Sub

See also

ClaimAddress Method

PreferredAddress Property

ReleaseAddress Method

UseAddressingProtocol Property


ClientName Property

Applies to: J1939Node object

Sets or returns the name of the PCAN client the J1939 node uses for low-level CAN communication.

Syntax

object.ClientName [=value]

Parameters

object

An expression that evaluates to a J1939Node object.

value

A String value that specifies the new value of the property.

Property value

A String value that specifies the name of the PCAN client that will be created when the connection is activated.

Remarks

Setting the ClientName property while the node is already connected raises an error. The LastError property then returns the value errAlreadyConnected (2).

Example

The following example creates a new node and sets its ClientName property:

VBS Macro

Sub J1939_ClientNameExample()

Dim node

Set node = CreateObject("J1939Pcan6.PCANJ1939Node")

node.Device = tcdUSB

' Set the client name for the node

node.ClientName = "Macro"

node.NetName = "TestNet"

If node.Connect Then

' ...

End If

End Sub


Clock Property

Applies to: PCANBitrate object

Returns the clock frequency on which a CAN bit rate parameter set is based on.

Syntax

object.Clock

Parameters

object

An expression that evaluates to a PCANBitrate object.

Property value

A Long value that indicates the clock frequency in Hz, e.g. 80,000,000.

Remarks

A clock frequency of 8,000,000 Hz (8 MHz) indicates that the bit rate is defined for the BTR0/BTR1 registers of an older SJA1000 CAN controller, which is used in CAN hardware like PCAN-USB adaptors or PCAN-PCI cards. Higher clock frequencies like 20, 24, 30, 40, 60, or 80 MHz indicate that the bit rate is defined for a CAN-FD-compatible CAN hardware, like PCAN-USB FD adaptors or PCAN-PCI Express FD cards.

Example

The following example displays the clock frequency of the hardware bit rate currently used by the first connection in the project:

VBS Macro

Sub ClockExample()

' The first connection in the project must

' be a CAN connection

If Connections(1).Protocol = peProtocolCAN Then

Dim ClientConn, bitrate

Set ClientConn = Connections(1).CommunicationObject

Set bitrate = ClientConn.HardwareBitRate

MsgBox "Clock frequency of bit rate = " & bitrate.Clock & " Hz"

End If

End Sub


Collection Property

Applies to: AddIn object, Connection object, Document object, Enum object, J1939Filter object, MessageFilter object, MessageFilterItem object, Multiplexer object, OutputWindowPane object, PCANClient object, PCANMessage object, ProjectItem object, ReceiveMessage object, Signal object, Symbol object, TextDocument object, TraceMessage object, TransmitMessage object, Variable object, VBSMacroFile object, Window object

Returns the collection containing the object supporting this property.

Syntax

object.Collection

Parameters

object

An expression that evaluates to one of the objects in the Applies To list above.

Property value

A collection relating to the object. In general, the collection name is a plural form of the object name.

Example

The following example accesses the Collection property:

VBS Macro

Sub CollectionExample()

Dim win, str

For Each win In ActiveWindow.Collection

str = str & win.Caption

Next

MsgBox str,,"All Windows"

End Sub


Color Property

Applies to: Multiplexer object

Returns the color that has been defined to display a Multiplexer.

Syntax

object.Color

Parameters

object

An expression that evaluates to a Multiplexer object.

Property value

A Long value that represents an RGB value.

Example

The following example extracts the base colors from a Multiplexer color:

VBScript

Dim Red, Green, Blue

Red = myMux.Color Mod &HFF

Green = (myMux.Color Mod &HFF00) \ 256

Blue = (myMux.Color Mod &HFF0000) \ 65536


Comment Property

Applies to: Multiplexer object, Signal object, Symbol object, TransmitEvent object, TransmitMessage object, Variable object

Sets or returns the comment text for an object.

Syntax

object.Comment

Parameters

object

An expression that evaluates to one of the objects in the Applies To list above.

Property value

A String value that represents the comment that has been defined for the object.

Remarks

The Comment properties of the Multiplexer, Symbol, and Variable objects are read-only.

Example

The following example displays the names and comments of the symbols in "Sample.sym" in a message box:

VBS Macro

Sub CommentExample()

Dim symbols, symbol, strMsg

Set symbols = SymbolsManager("Sample")

For Each symbol In symbols

strMsg = strMsg & symbol.Name & vbTab & symbol.Comment & vbCrLf

Next

MsgBox strMsg,,"Symbol Comments"

End Sub


CommunicationObject Property

Applies to: Connection object

Returns an object that is responsible for the communication of messages through the connected bus.

Syntax

object.CommunicationObject

Parameters

object

An expression that evaluates to a Connection object.

Property value

The type of the returned object depends on the protocol the connection uses:

Protocol | Value of Protocol Property | Returned Object
CAN | peProtocolCAN (0) | PCANClientConnection
J1939 | peProtocolJ1939 (1) | J1939Node
Example

The following example accesses the communication object of the first connection in the project:

VBS Macro

Sub CommunicationObjectExample()

Dim CommObj

Set CommObj = Connections(1).CommunicationObject

If Not CommObj Is Nothing Then

' The connection is enabled

Select Case Connections(1).Protocol

Case peProtocolCAN

' Access properties and methods of the

' PCANClientConnection object here

' ...

Case peProtocolJ1939

' Access properties and methods of the

' J1939Node object here

' ...

End Select

End If

End Sub

See also

Protocol Property


Connected Property

Applies to: J1939Node object

Returns whether the J1939 node object is connected to a CAN bus.

Syntax

object.Connected

Parameters

object

An expression that evaluates to a J1939Node object.

Property value

A Boolean value that specifies whether the object is connected to a CAN bus or not. If True, the object is connected to a CAN bus. If False, the object is not connected to a CAN bus.

Example

The following example creates a new node and connects it to a CAN bus:

VBS Macro

Sub J1939_ConnectedExample()

Dim node

Set node = CreateObject("J1939Pcan6.PCANJ1939Node")

node.Device = tcdUSB

node.ClientName = "Macro"

node.NetName = "TestNet"

node.Connect

If node.Connected Then

' Connection successful

' ...

End If

End Sub


Connection Property [Variation 1]

Applies to: Connection object

Sets or returns a string specifying the connection.

Syntax

object.Connection [=value]

Parameters

object

An expression that evaluates to a Connection object.

value

A String that specifies the value of the property.

Property value

A String in the form NetName@DeviceName that specifies with which PCAN net and PCAN device the Connection object is associated.

Example

The following examples access the Connection property:

VBS Macro

Sub ConnectionGetExample()

Dim conn, str

For Each conn In Connections

str = str & "Bus " & conn.Bus & " = " & conn.Connection & vbCrLf

Next

MsgBox str,,"Project Connections"

End Sub
VBS Macro

Sub ConnectionSetExample()

Connections("MyConnection").Connection = "TestNet@pcan_usb"

End Sub


Connection Property [Variation 2]

Applies to: ReceiveMessage object, TraceMessage object, TransmitMessage object

Sets or returns the Connection object with which the message object is associated.

Syntax

object.Connection [=value]

Parameters

object

An expression that evaluates to one of the objects in the Applies To list above.

value

A Connection object.

Property value

A Connection object with which the message object is associated.

Example

The following example displays the connection name of the first message in the Transmit List:

VBS Macro

Sub ConnectionExample2()

If TransmitMessages.Count > 0 Then

Dim msg

Set msg = TransmitMessages(1)

If Not msg.Connection Is Nothing Then

MsgBox str,,"Message Connection"

End If

End If

End Sub


Connections Property [Variation 1]

Applies to: Application object

Returns the Connections collection.

Syntax

object.Connections

Parameters

object

An expression that evaluates to an Application object.

Property value

A Connections collection.

Remarks

The Connections collection represents all connections of PCAN-Explorer to CAN buses. Each connection in the collection is represented by a Connection object.

Example

The following example accesses the Connections collection:

VBS Macro

Sub ConnectionsExample()

MsgBox "Count: " & Connections.Count,,"Project Connections"

End Sub


Connections Property [Variation 2]

Applies to: PCANClient object

Returns the PCANClientConnections collection.

Syntax

object.Connections

Parameters

object

An expression that evaluates to a PCANClient object.

Property value

A PCANClientConnections collection.

Remarks

The PCANClientConnections collection represents all connections of a PCANClient object to CAN buses. Each connection in the collection is represented by a PCANClientConnection object.

Example

The following example accesses the Connections collection:

VBS Macro

Sub ConnectionsExample2()

Dim client, conn

Set client = CreateObject("PCAN4.PCANClient")

client.Device = "pcan_usb"

client.Name = "MyClient"

Set conn = client.Connections.Add("TestNet")

' Access the PCANClientConnection object here

' ...

End Sub


Count Property

Applies to: AddIns collection, Connections collection, Documents collection, Enum object, Enums collection, J1939Filters collection, MessageFilters collection, Multiplexers collection, OutputWindowPanes collection, PCANClientConnections collection, PCANMessages collection, ReceiveMessages collection, Signals collection, Symbols collection, TraceMessages collection, TransmitMessages collection, VBSMacroFiles collection, Windows collection

Returns the number of elements in a collection.

Syntax

object.Count

Parameters

object

An expression that evaluates to one of the objects in the Applies To list above.

Property value

A Long value that specifies the number of elements in the collection.

Example

The following example prints all documents in the Documents collection:

VBS Macro

Sub CountExample()

Dim i

For i = 1 To Documents.Count

Documents.Item(i).PrintOut

Next

End Sub


Creator Property

Applies to: TransmitEvent object, TransmitMessage object

Sets or returns the text that is displayed in transmit lists in the "Creator" column for the message.

Syntax

object.Creator [=value]

Parameters

object

An expression that evaluates to a TransmitEvent or TransmitMessage object.

value

A String value that specifies the new value of the property.

Property value

A String value that specifies the text that is displayed in transmit lists in the "Creator" column for the message.

Remarks

The Creator property of the TransmitEvent object is read-only.

Example

The following example creates a new message in the transmit list and sets its properties:

VBS Macro

Sub CreatorExample()

Dim msg

Set msg = TransmitMessages.Add

Set msg.Connection = Connections(1)

msg.ID = &H100

msg.Creator = "Me"

End Sub


CurrentColumn Property

Applies to: TextSelection object

Returns the column of the caret in a Text window.

Syntax

object.CurrentColumn

Parameters

object

An expression that evaluates to a TextSelection object.

Property value

A Long value that indicates the horizontal position of the caret.

Remarks

A selection is a single point (the caret) or a range of text. If the TextSelection object represents a range of selected text, the CurrentColumn and CurrentLine properties indicate the active end of the selection. This is the point where the user has stopped dragging the mouse.

The status bar of a Text window also shows the location of the caret.

Example

The following example retrieves the column of the caret:

VBScript

Dim ColNum

ColNum = ActiveDocument.Selection.CurrentColumn


CurrentDirectory Property

Applies to: Application object

Sets or returns the directory used by the Open command on the File menu.

Syntax

object.CurrentDirectory [=string]

Parameters

object

An expression that evaluates to an Application object.

string

A String value that specifies the new value of the property.

Property value

A String value that indicates the current directory of the PCAN-Explorer 6 process. The returned directory name does not have a trailing backslash ("\").

Example

The following example sets the current directory to C:\Program Files (x86)\PCAN-Explorer 6:

VBScript

CurrentDirectory = "C:\Program Files (x86)\PCAN-Explorer 6"


CurrentLine Property

Applies to: TextSelection object

Returns the line number where the caret is located in a Text window.

Syntax

object.CurrentColumn

Parameters

object

An expression that evaluates to a TextSelection object.

Property value

A Long value that indicates the line number where the caret is located.

Remarks

A selection is a single point (the caret) or a range of text. If the TextSelection object represents a range of text, the CurrentColumn and CurrentLine properties indicate the active end of the selection. That is the point where the user has stopped dragging the mouse.

Example

The following example gets the line number of the caret:

VBScript

Dim LineNum

LineNum = ActiveDocument.Selection.CurrentLine


CurrentTime Property

Applies to: Application object

Returns the current PCAN-Explorer time that is used as a basis for generating timestamps.

Syntax

object.CurrentTime

Parameters

object

An expression that evaluates to an Application object.

Property value

A DATE value.

Example

The following example displays the current PCAN-Explorer time:

VBScript

MsgBox CurrentTime


CycleTime Property [Variation 1]

Applies to: TransmitEvent object, TransmitMessage object

Sets or returns the transmit cycle time of a CAN message.

Syntax

object.CycleTime [=value]

Parameters

object

An expression that evaluates to a TransmitEvent or TransmitMessage object.

value

A Long value that specifies the value of the property.

Property value

A Long value that specifies the transmit cycle time in milliseconds.

Example

The following example creates a new message in the transmit list and sends it with a cycle time of 500 ms:

VBS Macro

Sub CycleTimeExample()

Dim msg

Set msg = TransmitMessages.Add

Set msg.Connection = Connections(1)

msg.ID = &H100

msg.CycleTime = 500

End Sub


CycleTime Property [Variation 2]

Applies to: Multiplexer object

Returns the transmit cycle time of a Multiplexer.

Syntax

object.CycleTime

Parameters

object

An expression that evaluates to a Multiplexer object.

Property value

A Long value that indicates the transmit cycle time in Milliseconds.

Example

The following example lists all Multiplexers of a Symbol with their default transmit cycle time and displays them in a message box:

VBScript

Dim mux, strMsg

For Each mux In mySymbol

strMsg = strMsg & mux.Name & vbTab & mux.CycleTime & vbCrLf

Next

MsgBox strMsg,,"Multiplexers CycleTime"


Data Property

Applies to: PCANMessage object, ReceiveEvent object, ReceiveMessage object, TraceMessage object, TransmitEvent object, TransmitMessage object, J1939Msg object, J1939RcvMsg object

Sets or returns the data bytes of a CAN message.

Syntax

object.Data ( index ) [=value]

Parameters

object

An expression that evaluates to one of the objects in the Applies To list above.

index

A Long value that specifies the index of the accessed data byte (0-7 for PCANMessage object, 0-1785 for all other objects).

value

A Long value that sets the new value of the data byte.

Property value

An indexed Long value that specifies one data byte of a CAN message (0-255).

Remarks

The Data property of the J1939RcvMsg object is read-only.

Example

The following example shows the contents of the data bytes of a received CAN message:

VBS Macro

Sub DataExample()

If ReceiveMessages.Count = 0 Then Exit Sub

Dim msg, str, i

' Get the first message from the Receive list

Set msg = ReceiveMessages.Item(1)

str = "ID=" & Hex(msg.ID) & " Data="

For i = 0 To msg.DataLength-1

str = str & Hex(msg.Data(i)) & " "

Next

MsgBox str,,"Message Data"

End Sub


DataArray Property

Applies to: ReceiveEvent object, ReceiveMessage object, TraceMessage object, TransmitEvent object, TransmitMessage object, J1939Msg object, J1939RcvMsg object

Sets or returns all data bytes of a CAN message in a SafeArray.

Syntax

object.DataArray [=array]

Parameters

object

An expression that evaluates to one of the objects in the Applies To list above.

array

A SafeArray that contains the new data bytes for the message. The following conditions must be true for the array:

  • the array must consist of VT_UI1 elements

  • the lower bound must be 0 or 1

  • the number of elements in the array must not exceed 8 for CAN messages, 64 for CAN FD messages, or 1785 for J1939 messages.

The number of elements in the array determine the new Data Length Code of the message.

Property value

A SafeArray containing the data bytes of the message in VT_UI1 elements. The lower bound of the array is 0 and the upper bound the size of the message -1.

Remarks

Before assigning a SafeArray that contains more than 8 data bytes, either configure the message as CAN FD message, or assign a connection to the message that uses the J1939 protocol by setting the Connection property. Otherwise an error is raised.

The DataArray property cannot be used with VBScript macros. Use the DataVariant property instead.

The DataArray property of the J1939RcvMsg object is read-only.


DataBitrate Property

Applies to: PCANBitrate object

Returns the data bit rate of a CAN FD bit rate.

Syntax

object.DataBitrate

Parameters

object

An expression that evaluates to a PCANBitrate object.

Property value

A Double value that indicates the data bit rate in bits per second. If the parent PCANBitrate object does not represent a CAN FD bit rate, the property returns the value 0.

Example

The following example displays the bit rate of the hardware currently used by the first connection in the project:

VBS Macro

Sub DataBitrateExample()

' The first connection in the project must

' be a CAN connection

If Connections(1).Protocol = peProtocolCAN Then

Dim ClientConn, bitrate

Set ClientConn = Connections(1).CommunicationObject

Set bitrate = ClientConn.HardwareBitRate

MsgBox "Bit rate: Nominal=" & bitrate.NominalBitrate & _

", Data=" & bitrate.DataBitrate

End If

End Sub

See also

NominalBitrate Property


DataFormat Property

Applies to: Tracer object

Sets or returns the format that is used to display data bytes in a trace window.

Syntax

object.DataFormat [=value]

Parameters

object

An expression that evaluates to a Tracer object.

boolean

A PeTraceDataFormat enum value that sets the new value of the property.

Property value

A PeTraceDataFormat enum value. Possible values are:

  • peTraceDataFormatHexadecimal (0): Data bytes are displayed in hexadecimal notation.

  • peTraceDataFormatDecimal (1): Data bytes are displayed in decimal notation.

Example

The following example changes the value of the DataFormat property of the foreground tracer window:

VBS Macro

Sub DataFormatExample()

   If ActiveDocument.Kind = peDocumentKindTrace Then

      Dim tracer

      Set tracer = ActiveWindow.Object.Tracer

      tracer.DataFormat = peTraceDataFormatDecimal

   End If

End Sub

See also

CanIdFormat

TimestampFormat Property


DataLength Property

Applies to: Multiplexer object, ReceiveEvent object, ReceiveMessage object, TransmitEvent object, TraceMessage object, TransmitMessage object

Returns the number of data bytes assigned to the object.

Syntax

object.DataLength [=value]

Parameters

object

An expression that evaluates to one of the objects in the Applies To list above.

value

A Long value that specifies the new value of the property.

Property value

A Long value that indicates the number of data bytes.

Remarks

The DataLength properties of the Multiplexer, ReceiveEvent, and TransmitEvent objects are read-only.

Example

The following example displays all the Multiplexers of a Symbol with the number of the data bytes:

VBScript

Dim mux, strMsg

For Each mux In mySymbol

strMsg = strMsg & mux.Name & vbTab & CStr(mux.DataLength) & vbCrLf

Next

MsgBox strMsg,,"Multiplexers"


DataType Property

Applies to: Signal object, Variable object

Sets or returns the data type of a Signal or Variable.

Syntax

object.DataType [=value]

Parameters

object

An expression that evaluates to a Signal object or a Variable object.

value

A PeDataType enum value that specifies the new value of the property.

Property value

A PeDataType enum value. Possible values are:

  • peDataTypeBit (1): a single bit

  • peDataTypeChar (2): an ASCII character (8-bit)

  • peDataTypeString (3): an ASCII-String

  • peDataTypeSigned (4): a signed value (2-64 bit)

  • peDataTypeUnsigned (5): an unsigned value (1-64 bit)

  • peDataTypeFloat (6): a floating-point value according to IEEE754 (32-bit)

  • peDataTypeEnum (7): an enumeration

  • peDataTypeDouble (8): a double-precision floating-point value (64-bit).

  • peDataTypeRaw (9): The Signal or Variable contains raw data that is not associated with a specific data type.

Remarks

The DataType property of the Variable object is read-only.

Example

The following example returns the type of a Signal:

VBScript

Dim theType

theType = mySignal.DataType


DataVariant Property

Applies to: ReceiveEvent object, ReceiveMessage object, TraceMessage object, TransmitEvent object, TransmitMessage object

Sets or returns all data bytes of a CAN message in a Variant.

Syntax

object.DataVariant [=variant]

Parameters

object

An expression that evaluates to one of the objects in the Applies To list above.

variant

A Variant that contains the new data bytes for the message.

If variant contains an array, the number of elements in the array must not exceed 8 for CAN messages, 64 for CAN FD messages, or 1785 for J1939 messages. The number of elements in the array determine the new Data Length Code of the message.

Property value

A Variant containing an array with the data bytes of the message.

Remarks

Before assigning a Variant that contains an array with more than 8 data bytes, either configure the message as CAN FD message, or assign a connection to the message that uses the J1939 protocol by setting the Connection property. Otherwise an error is raised.

Example

The following example adds a new transmit message and initializes its data bytes:

VBS Macro

Sub DataVariantExample()

Dim msg

Set msg = TransmitMessages.Add

msg.ID = &H100

msg.DataVariant = Array(1,2,3,4)

End Sub


DecimalPlaces Property

Applies to: Signal object, Variable object

Sets or returns the number of decimal places that are displayed for a Signal value or Variable value.

Syntax

object.DecimalPlaces [=value]

Parameters

object

An expression that evaluates to a Signal object or Variable object.

value

A Long value that specifies the new value of the property.

Property value

A Long value that specifies the number of decimal places defined for the Signal or Variable. The value -1 indicates that the number of displayed decimal places is determined by the global decimal places setting in PCAN-Explorer.

Remarks

The DecimalPlaces property of the Variable object is read-only.

Example

The following example creates a new virtual Signal and its value is displayed with 2 decimal places:

VBS Macro

Sub DecimalPlacesExample()

Dim sig

Set sig = Signals("MySignal")

If sig Is Nothing Then

Set sig = Signals.Add("MySignal")

End If

sig.DataType = peDataTypeFloat

sig.DecimalPlaces = 2

End Sub


DefaultMultiplexer Property

Applies to: Symbol object

Returns the Default Multiplexer of a Symbol.

Syntax

object.DefaultMultiplexer

Parameters

object

An expression that evaluates to a Symbol object.

Property value

A Multiplexer object.

Remarks

The default Multiplexer is an empty Multiplexer that is automatically created for Symbols for which no other Multiplexers are defined explicitly.

Example

The following example displays the name of the Default Multiplexer of the Symbol "RcvSymbol" (defined in the symbol file "Sample.sym"):

VBS Macro

Sub DefaultMultiplexerExample()

Dim symbols, mux

Set symbols = SymbolsManager("Sample")

Set mux = symbols("RcvSymbol").DefaultMultiplexer

PrintToOutputWindow mux.Name

End Sub


DefaultData Property

Applies to: Multiplexer object

Returns the data bytes of a Multiplexer, which are filled with the default values of the Variables.

Syntax

object.DefaultData ( index )

Parameters

object

An expression that evaluates to a Multiplexer object.

index

A Long value indicating the index (0-7) of the data byte to be retrieved.

Property value

An indexed Long value that represents the value of a single data byte (0-255).

The data bytes that can be retrieved through the DefaultData property do not contain any data of the Multiplexer itself. The Multiplexer data can be retrieved by using its MuxData property.

Example

The following example shows the contents of the data bytes of a Multiplexer in a message box:

VBScript

Dim strMsg, i

For i = 0 To 7

strMsg = strMsg & Hex(myMux.DefaultData(i)) & " "

Next

MsgBox strMsg,,"Default Data"


DefaultValue Property

Applies to: Variable object

Returns a Variables's default value.

Syntax

object.DefaultValue

Parameters

object

An expression that evaluates to a Variable object.

Property value

A Variant value that represents the Variable's default value.

Example

The following example displays the default value of the Variable "MyVar" in a message box:

VBS Macro

Sub DefaultValueExample()

Dim symbols, v

Set symbols = SymbolsManager("MySymbols")

Set v = symbols("MySymbol").DefaultMultiplexer.Variables("MyVar")

MsgBox v.DefaultValue

End Sub


Description Property

Applies to: AddIn object, Enum object, MessageFilter object, Project object, Tracer object, VBSMacroFile object

Sets or returns a string containing the object's description.

Syntax

object.Description [=value]

Parameters

object

An expression that evaluates to one of the objects in the Applies To list above.

value

A String value that specifies the new value of the property.

Property value

A String that represents the description of the object.

Remarks

The Description properties of the Add-in object and Enum object are read-only.

Example

The following example lists all registered Add-ins along with their descriptions:

VBS Macro

Sub DescriptionExample()

Dim objAddIn, strMsg

For Each objAddIn In AddIns

strMsg = strMsg & objAddIn.Name & ": " & _

objAddIn.Description & vbCrLf

Next

MsgBox strMsg,,"Add-ins"

End Sub


DestinationAddress Property

Applies to: J1939Filter object, MessageFilterItem object, ReceiveEvent object, ReceiveMessage object, Symbol object, TraceMessage object, TransmitEvent object, TransmitMessage object

Sets or returns a J1939 Destination Address.

Syntax

object.DestinationAddress [=address]

Parameters

object

An expression that evaluates to one of the objects in the Applies To list above.

address

A Byte value that sets the new value of the property.

Property value

A Byte value that specifies a Destination Address (0-255).

Remarks

The DestinationAddress properties of the J1939Filter, ReceiveEvent, Symbol, and TransmitEvent objects are read-only.

For the J1939Filter object, the DestinationAddress property returns the Destination Address attribute of the filter. If the Flags property includes the tfmDestination flag, all J1939 messages sent to the specified Destination Address can pass the filter.

For the MessageFilterItem object, the DestinationAddress property only has an effect if the Type property is set to peFilterItemJ1939 and the J1939FilterFlags property includes the peJ1939DestinationAddress flag.

The DestinationAddress property of message objects is only relevant for PDU1 messages, or for PDU2 messages that have more than 8 data bytes, which are transmitted using the transport protocol.


Device Property [Variation 1]

Applies to: Connection object, PCANClient object

Returns or sets the name of the PCAN device that the object uses to access CAN hardware and to communicate with CAN buses.

Syntax

object.Device [=value]

Parameters

object

An expression that evaluates to a Connection object or a PCANClient object.

value

A String value that specifies the new name of the device to be used. Allowed device names are: "peakcan", "pcan_virtual", "pcan_isa", "pcan_dng", "pcan_pci", "pcan_usb", "pcan_pccard", and "pcan_lan".

Property value

A String value that specifies the name of the PCAN device used.

Remarks

The Device property of the Connection object is read-only.

Example

The following example configures a new client so that it uses the device "pcan_pci":

VBS Macro

Sub DeviceExample()

Dim client, conn

Set client = CreateObject("PCAN4.PCANClient")

' Set the device for the client

client.Device = "pcan_pci"

client.Name = "Macro"

Set conn = client.Connections.Add("TestNet")

If conn.IsConnected Then _

MsgBox "Client is connected. See PCAN Status Display."

End Sub


Device Property [Variation 2]

Applies to: J1939Node object

Returns or sets the PCAN device that the object uses to access CAN hardware and to communicate with J1939 buses.

Syntax

object.Device [=value]

Parameters

object

An expression that evaluates to a J1939Node object.

value

A TCANDevices enum value that specifies the new device to be used.

Property value

A TCANDevices enum value:

  • tcdPeakcan (1): The "peakcan" device is used.

  • tcdISA (2): The "pcan_isa" device is used.

  • tcdDNG (3): The "pcan_dng" device is used.

  • tcdPCI (4): The "pcan_pci" device is used.

  • tcdUSB (5): The "pcan_usb" device is used.

  • tcdPCCard (6): The "pcan_pccard" device" is used.

  • tcdVirtual (7): The "pcan_virtual" device is used.

  • tcdLAN (8): The "pcan_lan" device is used.

Example

The following example configures a new J1939 node object so that it uses the device "pcan_pci":

VBS Macro

Sub J1939_DeviceExample()

Dim node

Set node = CreateObject("J1939Pcan6.PCANJ1939Node")

' Set the device for the node

node.Device = tcdPCI

node.ClientName = "Macro"

node.NetName = "TestNet"

If node.Connect Then _

MsgBox "Node is connected. See PCAN Status Display."

End Sub


DisplayMode Property

Applies to: Multiplexer object, Variable object

Returns the display mode of a Multiplexer or a Variable.

Syntax

object.DisplayMode

Parameters

object

An expression that evaluates to a Multiplexer object or a Variable object.

Property value

A PeDisplayMode enum value:

  • peDisplayOff (0): Multiplexer or Variable is not displayed.

  • peDisplayValue (1): Only the value of a Multiplexer or Variable is displayed.

  • peDisplayAll (2): Name and value of a Multiplexer or Variable is displayed in the form Name=Value.

Example

The following example returns the display mode of a Multiplexer:

VBS Macro

Sub DisplayModeExample()

Dim sym, mux, mode

Set sym = SymbolsManager("MySymbols").Item("MySymbol")

Set mux = sym.Multiplexers("Mux1")

mode = mux.DisplayMode

' ...

End Sub


DisplayName Property

Applies to: VBSMacroFile object

Returns the name of a VBS Macro file as it is displayed in the various PCAN-Explorer windows.

Syntax

object.DisplayName

Parameters

object

An expression that evaluates to a VBSMacroFile object.

Property value

A String value that indicates the name of the VBS Macro file.

Example

The following example shows the display names of all loaded VBS Macro files in the Output window, on the Macro tab:

VBS Macro

Sub DisplayNameExample()

Dim file

For Each file In VBSMacroFiles

PrintToOutputWindow file.DisplayName

   Next

End Sub

See also

FullName Property


DLC Property

Applies to: PCANMessage object, ReceiveEvent object, ReceiveMessage object, TraceMessage object, TransmitEvent object, TransmitMessage object

Returns or sets the Data Length Code of a CAN message.

Syntax

object.DLC [=value]

Parameters

object

An expression that evaluates to one of the objects in the Applies To list above.

value

A Long that specifies the new value of the property.

Property value

A Long value that specifies the Data Length Code of the CAN message (0-8 for PCANMessage object, 0-1785 for all other objects).

Remarks

The DLC properties of the ReceiveEvent and TransmitEvent objects are read-only.

Example

The following example sets the DLC property of a PCANMessage object:

VBS Macro

Sub PCANMessagesExample()

Dim client, conn, msg

Set client = CreateObject("PCAN4.PCANClient")

client.Device = "pcan_usb"

client.Name = "Macro"

Set conn = client.Connections.Add("TestNet")

Set msg = client.Messages.Add

' Access the PCANMessage object here.

With msg

.Bus = 1

.ID = &H100

.DLC = 3

.Data(0) = &H11

.Data(1) = &H22

.Data(2) = &H33

.Write conn, 0

End With

End Sub

See also

ID Property

Data Property


Document Property

Applies to: Symbols object, Tracer object, Window object

Returns the Document object associated with the object.

Syntax

object.Document

Parameters

object

An expression that evaluates to a Symbols object, a Tracer object, or a Window object.

Property value

The Document object associated with the object.

Example

The following example displays the full path name of the document that is associated with the active window:

VBS Macro

Sub DocumentExample()

If Not ActiveWindow.Document Is Nothing Then _

MsgBox ActiveWindow.Document.FullName

End Sub


Documents Property

Applies to: Application object

Returns a Documents collection.

Syntax

object.Documents

Parameters

object

An expression that evaluates to an Application object.

Property value

A Documents collection that represents the collection of all opened documents. Each document in the collection is represented by a Document object.

Example

The following example accesses the Documents collection:

VBS Macro

Sub DocumentsExample()

MsgBox "Number of open documents = " & Documents.Count

End Sub


DriverVersion Property

Applies to: PCANClient object

Returns the version of the driver that is installed for managing the CAN hardware.

Syntax

object.DriverVersion

Parameters

object

An expression that evaluates to a PCANClient object.

Property value

A String value that contains information about the driver version, usually including a copyright note, and the information about the platform the driver is intended for.

Remarks

The driver's version can also be retrieved in the Windows Control Panel in the "CAN-Hardware" module.

Example

The following example retrieves the version of the currently used PCAN device driver and displays it in a message box:

VBS Macro

Sub DriverVersionExample()

If Connections.Count = 0 Then Exit Sub

Dim conn

Set conn = Connections(1)

If conn.Protocol = peProtocolCAN Then

' Access the PCANClient object

Dim client

Set client = conn.CommunicationObject.Parent

MsgBox client.DriverVersion,,"Driver Version"

End If

End Sub


EntryCount Property

Applies to: Tracer object

Returns the number of entries in a trace buffer or file.

Syntax

object.EntryCount

Parameter

object

An expression that evaluates to a Tracer object.

Property value

A Long value indicating the current number of entries.

Example

The following example displays the number of entries in the active tracer:

VBS Macro

Sub EntryCountExample()

Dim tracer, count

If ActiveWindow.Kind = peDocumentKindTrace Then

Set tracer = ActiveWindow.Object.Tracer

count = tracer.EntryCount

MsgBox count

End If

End Sub

See also

FillingLevel Property


EnumName Property

Applies to: Signal object, Variable object

Sets or returns the name of an Enum that is associated with a Signal or Variable.

Syntax

object.EnumName [=value]

Parameters

object

An expression that evaluates to a Signal object or a Variable object.

value

A String that specifies the new value of the property.

Property value

A String value that specifies the name of the Enum object that is associated with the Signal or Variable.

Remarks

The EnumName property of the Variable object is read-only.

Example

The following example displays the name of the associated Enum object for each Signal that has the peDataTypeEnum data type:

VBS Macro

Sub EnumNameExample()

Dim sig, strMsg

For Each sig In Signals

If sig.DataType = peDataTypeEnum Then _

strMsg = strMsg & sig.Name & vbTab & sig.EnumName & vbCrLf

Next

MsgBox strMsg

End Sub

See also

EnumName Property

Feedback senden | Copyright © 2022 PEAK-System Technik GmbH. Alle Rechte vorbehalten.


Enums Property

Applies to: Symbols collection, SymbolsManager collection

Returns an Enums collection.

Syntax

object.Enums

Parameters

object

An expression that evaluates to a Symbols collection or a SymbolsManager collection.

Property value

An Enums collection. Each Enum in the collection is represented by an Enum object.

The Enums property of a Symbols collection represents all Enums that are defined in the Symbols file that the Symbols collection represents.

The Enums collection returned by the SymbolsManager.Enums property is usually empty in PCAN-Explorer 6.

Attention

In PCAN-Explorer 5, the Enums of all loaded Symbols files were merged into the single SymbolsManager.Enums collection.

In PCAN-Explorer 6, the Enums defined in a specific Symbols file can be accessed via the Enums property of the respective Symbols collection. The SymbolsManager.Enums collection is still available, mostly for backward compatibility, but is usually empty unless Enums were added to the collection by a VBS macro or an Add-in.
Example

The following example accesses the Enums that were defined in a specific Symbols file:

VBS Macro

Sub EnumsExample()

MsgBox "Number of Enums = " & SymbolsManager("MySymbolsFile.sym").Enums.Count

End Sub


ErrorFrames Property

Applies to: PCANClient object

Sets or returns whether a PCAN client shall receive Error Frames.

Syntax

object.ErrorFrames [=value]

Parameters

object

An expression that evaluates to a PCANClient object.

value

A Boolean that specifies the new value of the property.

Property value

A Boolean value that specifies whether the PCAN client receives Error Frames. If True, the client receives Error Frames. If False, The client ignores Error Frames (the default).

Example
VBS Macro

Sub ErrorFramesExample()

Dim client

Set client = CreateObject("PCAN4.PCANClient")

client.Device = "pcan_usb"

client.Name = "Macro"

If client.IsRegistered Then

' Configure the client to receive Error Frames

client.ErrorFrames = True

' ...

Else

MsgBox "Error while registering client!"

End If

End Sub


ErrorFramesEnabled Property

Applies to: MessageFilterItem object

Sets or returns whether Error Frames can pass through the MessageFilterItem object if the filter item operates in Options mode.

Syntax

object.ErrorFramesEnabled [=value]

Parameters

object

An expression that evaluates to a MessageFilterItem object.

value

A Boolean value that specifies the new value of the property.

Property value

A Boolean value that specifies whether Error Frames can pass through the filter item or not. If True, Error Frames can pass through the filter item. If False, Error Frames are blocked by the filter item (the default).

Remarks

The ErrorFramesEnabled property only has an effect, if the Type property of the MessageFilterItem object is set to peFilterItemOptions.

See also

ErrorWarningsEnabled Property

RTREnabled Property

Type Property


ErrorWarningsEnabled Property

Applies to: MessageFilterItem object

Sets or returns whether Error Warnings can pass through the MessageFilterItem object if the filter item operates in Options mode.

Syntax

object.ErrorWarningsEnabled [=value]

Parameters

object

An expression that evaluates to a MessageFilterItem object.

value

A Boolean value that specifies the new value of the property.

Property value

A Boolean value that specifies whether Error Warnings can pass through the filter item. If True, Error Warnings can pass through the filter item. If False, Error Warnings are blocked by the filter item (the default).

Remarks

The ErrorWarningsEnabled property only has an effect, if the Type property of the MessageFilterItem object is set to peFilterItemOptions.

See also

ErrorFramesEnabled Property

RTREnabled Property

Type Property


EventCount Property

Applies to: ReceiveEvent object, ReceiveMessage object, TraceMessage object, TransmitEvent object, TransmitMessage object

Returns a value indicating the number of times a CAN message has been received or transmitted.

Syntax

object.EventCount

Parameters

object

An expression that evaluates to one of the objects in the Applies To list above.

Property value

A Long value representing the number of times the CAN message has been received or transmitted.

Example

The following example retrieves the event count of a message:

VBS Macro

Sub EventCountExample()

If ReceiveMessages.Count = 0 Then Exit Sub

' Access the first message in the Receive list

Dim msg, count

Set msg = ReceiveMessages(1)

count = msg.EventCount

' ...

End Sub


ExcludeMode Property

Applies to: MessageFilterItem object

Sets or returns whether the filter item operates in Exclude mode.

Syntax

object.ExcludeMode [=value]

Parameters

object

An expression that evaluates to a MessageFilterItem object.

value

A Boolean value that specifies the new value of the property.

Property value

A Boolean value that specifies whether the filter item operates in Exclude mode.

Remarks

The ExcludeMode property only has an effect, if the Type property of the MessageFilterItem object is set to either peFilterItemIDRange, peFilterItemCodeMask, or peFilterItemJ1939.

See also

Type Property


ExtensibilityObject Property

Applies to: AddIn object

Allows access to the PEAddIn object implemented by an Add-in.

Syntax

object.ExtensibilityObject

Parameters

object

An expression that evaluates to an AddIn object.

Property value

An IPEExtensibility interface.


Factor Property

Applies to: Variable object

Returns the multiplier that was defined for the for the variable to transform its value from a raw value into a physical value.

Syntax

object.Factor

Parameters

object

An expression that evaluates to a Variable object.

Property value

A Double value representing the multiplier that was defined for the variable to transform its value from a raw value into a physical value.

Example

The following example gets the factor of a variable:

VBScript

Dim fac

fac = myVar.Factor

See also

Offset Property


FillingLevel Property

Applies to: Tracer object

Returns the current filling level of a tracer.

Syntax

object.FillingLevel

Parameter

object

An expression that evaluates to a Tracer object.

Property value

A Long value indicating the current filling level in Percent (0-100).

Remarks

The filling level of a Tracer that has its BufferType property set to peTraceBufferTypeDynamic or peTraceBufferTypeFile is always 100%.

Example

The following example displays the filling level of the active tracer:

VBS Macro

Sub FillingLevelExample()

Dim tracer, fill

If ActiveWindow.Kind = peDocumentKindTrace Then

Set tracer = ActiveWindow.Object.Tracer

fill = tracer.FillingLevel

MsgBox fill & "%"

End If

End Sub

See also

EntryCount Property


Filter Property

Applies to: Connection object, ReceiveMessages collection, Tracer object

Sets or returns a MessageFilter object that is used by the object to filter messages.

Syntax

object.Filter [=value]

Parameter

object

An expression that evaluates to a ReceiveMessages collection or a Tracer object.

value

A reference to a MessageFilter object.

Property value

A MessageFilter object.

Example

The following example creates a new filter and configures a tracer to record only the single CAN-ID 100h:

VBS Macro

Sub FilterExample()

Dim myFilter

Set myFilter = MessageFilters("MyFilter")

If myFilter Is Nothing Then

' MyFilter does not yet exist in the current project

Set myFilter = MessageFilters.Add("MyFilter")

' Add a new filter item

Dim myItem

Set myItem = myFilter.AddItem

myItem.Type = peFilterItemIDRange

myItem.IDfrom = &H100

myItem.IDto = &H100

End If

' Now assign the filter to a tracer

Dim doc

Set doc = Documents("Trace1")

If doc Is Nothing Then

Dim tracer

Set tracer = doc.ActiveWindow.Object.Tracer

tracer.Filter = myFilter

' Finally, start the tracer

tracer.Start

End If

End Sub

See also

MessageFilter Object


FilterCode Property

Applies to: PCANClient object

Sets or returns the acceptance code of the message filter for this PCAN client.

Syntax

object.DLC [=value]

Parameters

object

An expression that evaluates to a PCANClient object.

value

A Long that sets the acceptance code.

Property value

A Long value representing the acceptance code of the PCAN client's message filter.

Remarks

Together with the FilterMask property, the FilterCode property configures which of the received CAN messages are passed on from the connected PCAN net to PCAN-Explorer.

Example

The following example gets the acceptance code of the first CAN connection:

VBS Macro

Sub FilterExample()

' The first connection in the project must

' be a CAN connection

If Connections(1).Protocol = peProtocolCAN Then

Dim client

Set client = Connections(1).CommunicationObject.Parent

MsgBox "Code = " & Hex(client.FilterCode) & vbCrLf & _

"Mask = " & Hex(client.FilterMask),,"Filter"

End If

End Sub

See also

FilterMask Property


FilterMask Property

Applies to: PCANClient object

Sets or returns the acceptance mask of the message filter for this PCAN client.

Syntax

object.DLC [=value]

Parameters

object

An expression that evaluates to a PCANClient object.

value

A Long that sets the acceptance mask.

Property value

A Long value representing the acceptance mask of the PCAN client's message filter.

Remarks

Together with the FilterCode property, the FilterMask property configures which of the received CAN messages are passed on from the connected PCAN net to PCAN-Explorer.

Example

The following example gets the acceptance mask of the first CAN connection:

VBS Macro

Sub FilterExample()

' The first connection in the project must

' be a CAN connection

If Connections(1).Protocol = peProtocolCAN Then

Dim client

Set client = Connections(1).CommunicationObject.Parent

MsgBox "Code = " & Hex(client.FilterCode) & vbCrLf & _

"Mask = " & Hex(client.FilterMask),,"Filter"

End If

End Sub

See also

FilterCode Property


Filters Property

Applies to: J1939Node object

Returns a J1939Filters collection that can be used to control the messages that are received from the J1939Node object.

Syntax

object.Filters

Parameter

object

An expression that evaluates to a JJ1939Node object.

Property value

A J1939Filters collection.

Example

The following example configures the filter of a J1939Node object so that only a single PGN is received:

VBS Macro

Sub J1939_FiltersExample()

Dim node

Set node = CreateObject("J1939Pcan6.PCANJ1939Node")

node.Device = tcdPCI

node.ClientName = "Macro"

node.NetName = "TestNet"

If node.Connect Then

' Add a filter for PGN 65132 (Tachograph)

node.Filters.Add tfmPGN, 65132, 0, 0, 0

Dim msg

Set msg = CreateObject("J1939Pcan6.PCANJ1939RcvMsg")

While Not node.Read(msg)

Wait 100

Wend

' A message with PGN 65132 has been received

' ...

End If

End Sub

See also

J1939Node object

J1939Filter object


FirstMessageSetsStartTime Property

Applies to: Tracer object

Determines whether the timestamp of the first message logged by a tracer is used as the reference time that marks the start of the tracer.

Syntax

object.FirstMessageSetsStartTime [=value]

Parameters

object

An expression that evaluates to a Tracer object.

value

A Boolean that sets the new value of the property.

Property value

A Boolean value that determines whether the timestamp of the first logged message is used as the reference time that marks the start of the tracer.


Flags Property

Applies to: J1939Filter object

Returns the Flags attribute of the filter.

Syntax

object.Flags

Parameters

object

An expression that evaluates to a J1939Filter object.

Property value

A combination of TFilterMask values that specify which fields of a J1939 message are taken into account by this filter. Can be one or a combination of the following values: tfmPGN (1), tfmPriority (2), tfmSource (4), or tfmDestination (8).


FullName Property

Applies to: AddIn object, Application object, CallbackLibraryEvent object, Document object, Project object, TextDocument object, VBSMacroFile object

Returns the full name of a file including the file path.

Syntax

object.FullName

Parameters

object

An expression that evaluates to one of the objects in the Applies To list above.

Property value

A String value representing the full name of the file.

The following table summarizes the results of using the FullName property with the objects in the Applies To list:

Object | Result
AddIn | Returns the full path of the Add-in DLL, e.g. "C:\Program Files (x86)\PCAN-Explorer 6\AddIns\LineWriter.dll"
Application | Returns the full path of the PCAN-Explorer application, e.g. "C:\Program Files (x86)\PCAN-Explorer 6\PcanExpl.exe".
Project | Returns the full path of the currently loaded PCAN-Explorer project, e.g. "C:\Users\User Name\Documents\PCAN-Explorer 6\Projects\My Project.peproj"
Document TextDocument | Returns the full path of the file, that contains the document, e.g. "C:\Users\User Name\Documents\PCAN-Explorer 6\Symbols\Sample.sym"
VBSMacroFile | Returns the full path of the VBS Macro file, e.g. "C:\Users\User Name\Documents\PCAN-Explorer 6\Macros\Sample.pem"
CallbackLibraryEvent | Returns the full path of the Callback Library, e.g. "C:\Users\User Name\Documents\MyProject\MyCallbackLibrary.dll"
Example

The following example displays the full path to every document in the Documents collection:

VBS Macro

Sub FullNameExample()

Dim i

For i = 1 To Documents.Count

PrintToOutputWindow Documents.Item(i).FullName

   Next

End Sub

See also

Name Property

Path Property


Properties G-K

The following table contains all properties beginning with letters G to K:

Property | Description
Guid | Returns an Add-in's CLSID as obtained from the Add-in's registry entry.
Handle | Returns a handle value of the object.
HardwareBaudRate | Sets or returns the value of the bus timing registers in the SJA1000 CAN controller of the connected CAN hardware.
HardwareBitRate | Returns a PCANBitrate object that describes the current bit rate of a CAN hardware.
HardwareBitRateText | Returns the bit rate of a connected CAN hardware, as a text.
HardwareHandle | Returns the handle of a connected CAN hardware.
HardwareInterrupt | Returns the interrupt that is used by the connected CAN hardware.
HardwareName | Returns the name of a connected CAN hardware.
HardwarePort | Returns the I/O address that is used by the connected CAN hardware.
HardwareStatus [Variation 1] | Returns the current status of a connected CAN hardware.
HardwareStatus [Variation 2] | Returns the current status of a connected CAN hardware.
HardwareType | Returns the type of a connected CAN hardware.
Height | Sets or returns the height of a window.
HWnd | Returns the window handle of a window.
ID | Sets or returns the CAN ID of a CAN message.
IDfrom | Sets or returns the lower CAN ID of a MessageFilterItem object.
IDto | Sets or returns the upper CAN ID of a MessageFilterItem object.
IncludeEchoes | Sets or returns whether successfully transmitted messages are being echoed back in the receive queue of a J1939Node object.
InitValue | Returns a Signal's initial value.
IsActive | Sets or returns whether a document, a window, or a tracer is active.
IsConnected [Variation 1] | Sets or returns whether PCAN-Explorer is connected to a PCAN net.
IsConnected [Variation 2] | Returns a value indicating whether an Add-in is loaded and connected.
IsEcho | Returns whether the message an echo of a transmitted J1939 message.
IsEnabled | Sets or returns whether the object is enabled or not.
IsExtended | Returns whether a Symbol represents a CAN message with a standard 11-bit ID or an extended 29-bit ID.
IsMotorola | Returns whether the individual bytes of a Multiplexer or Variable are arranged in the Motorola order.
IsOpenThroughout | Sets or returns whether the reception filter of a J1939Node object is completely open.
IsPaused | Sets or returns whether a CAN message is transmitted periodically, or whether a Multiplexer is transmitted periodically by default.
IsReadOnly | Sets or returns whether a document is write protected in PCAN-Explorer.
IsReceived | Returns whether a recorded CAN message has been received or transmitted.
IsRegistered | Sets or returns whether PCAN-Explorer is registered at a PCAN device.
IsRTR | Returns whether a Multiplexer represents a Remote Transmission Request (RTR) message.
IsSaved | Returns a document's saved status, indicating whether a document has changed since it was last saved.
IsTimeout | Returns whether a time-out event was recorded for a CAN message.
IsTraced | Returns whether a Multiplexer or a Variable object will be recorded by the tracer.
IsValid | Returns whether a connection is valid or not.
IsVisible | Sets or returns the visibility of a window.
Item | Retrieves a specific object from a collection.
ItemCount | Returns the number of filter items in a filter.
J1939FilterFlags | Sets or returns a value that determines which J1939 attributes are taken into account to filter J1939 messages.
Kind | Returns a GUID string indicating the kind or type of the object.

See also

Properties A-F

Properties L-P

Properties Q-T

Properties U-Z


Guid Property

Applies to: AddIn object

Returns the Add-in's CLSID as obtained from the Add-in's registry entry.

Syntax

object.Guid

Parameters

object

An expression that evaluates to an AddIn object.

Property value

A String value representing the Add-in's CLSID as obtained from the Add-in's registry entry.

Example

The following example lists all registered Add-ins and their GUIDs:

VBS Macro

Sub GuidExample()

Dim objAddIn, strMsg

For Each objAddIn In AddIns

strMsg = strMsg & objAddIn.Name & " " & _

objAddIn.Guid & vbCrLf

Next

MsgBox strMsg,,"Add-in GUIDs"

End Sub


Handle Property

Applies to: Application object, PCANClient object

Returns a handle value of the object.

Syntax

object.Handle

Parameters

object

An expression that evaluates to a Application object or a PCANClient object.

Property value

A Long value representing the handle of the object.

The following table summarizes the results of using the Handle property with the objects in the Applies To list:

Object | Result
Application | The Windows Application handle.
PCANClient | The client handle that has been assigned to the PCANClient object when registering at the PCAN system. If the PCANClient object is not registered at the PCAN system, the result is 0.
Example

The following example gets the client handle of the first CAN connection and displays it in a message box:

VBS Macro

Sub HandleExample()

' The first connection in the project must

' be a CAN connection

If Connections(1).Protocol = peProtocolCAN Then

Dim client

Set client = Connections(1).CommunicationObject.Parent

MsgBox "Client Handle = " client.Handle,,"Macro"

End If

End Sub


HardwareBaudRate Property

Applies to: PCANClientConnection object

Sets or returns the value of the bus timing registers in the SJA1000 CAN controller of the connected CAN hardware. In non-CAN-FD hardware the bus timing registers BTR0/BTR1 control the baud rate that is used for communication.

To access the bit rate parameters of a CAN hardware that operates in CAN FD mode, use the HardwareBitRate property.

Syntax

object.HardwareBaudRate [=value]

Parameters

object

An expression that evaluates to a PCANClientConnection object.

value

A Long value that specifies the new value of the bus timing register.

Property value

A Long containing a 16-bit value, which is a combination of the two 8-bit values from the bus timing registers BTR0 and BTR1 of the SJA1000 CAN controller. To get a human-readable interpretation of the bit rate value, access the HardwareBitRateText property.

Remarks

The bit rate of a hardware can only be set and retrieved if the PCANClientConnection object is connected to a PCAN net, which in turn is connected to a CAN hardware. If the object is connected to a virtual net that has no hardware connection, then the HardwareHandle property returns the value 0.

Example

The following example sets the baud rate of a CAN controller (type SJA1000) to 1 Mbit/s:

VBS Macro

Sub HardwareBaudRateExample()

' The first connection in the project must

' be a CAN connection

If Connections(1).Protocol = peProtocolCAN Then

Dim ClientConn

Set ClientConn = Connections(1).CommunicationObject

ClientConn.HardwareBaudRate = &H0014

End If

End Sub

See also

HardwareBitRateText Property

HardwareHandle Property

NetBaudRate Property


HardwareBitRate Property

Applies to: PCANClientConnection object

Returns a PCANBitrate object that describes the current bit rate of a CAN hardware.

Syntax

object.HardwareBitRate

Parameters

object

An expression that evaluates to a PCANClientConnection object.

Property value

A PCANBitrate object.

Remarks

The bit rate of a hardware can only be retrieved if the PCANClientConnection object is connected to a PCAN net, which in turn is connected to a CAN hardware. If the object is connected to a virtual net that has no hardware connection, then the HardwareHandle property returns the value 0.

Example

The following example gets the bit rate of a CAN controller:

VBS Macro

Sub HardwareBitRateExample()

' The first connection in the project must

' be a CAN connection

If Connections(1).Protocol = peProtocolCAN Then

Dim ClientConn, bitrate

Set ClientConn = Connections(1).CommunicationObject

Set bitrate = ClientConn.HardwareBitRate

' Access the PCANBitrate object here

MsgBox "Bit rate of Hardware = " & bitrate.AsString

End If

End Sub

See also

HardwareBitRateText Property

HardwareBaudRate Property

NetBitRate Property


HardwareBitRateText Property

Applies to: PCANClientConnection object

Returns the bit rate of the connected CAN hardware, as a text.

Syntax

object.HardwareBitRateText

Parameters

object

An expression that evaluates to a PCANClientConnection object.

Property value

A String representing the bit rate of the connected CAN hardware. The bit rate of a hardware can only be retrieved if the PCANClientConnection object is connected to a PCAN net, which in turn is connected to a CAN hardware. If the object is only connected to a virtual net that has no hardware connection, then the returned string is empty.

The HardwareBitRateText property returns the same string as the HardwareBitRate.AsString property.

Example

The following example displays the bit rate of the hardware that is associated with the first Connection in the project:

VBS Macro

Sub HardwareBitRateTextExample()

' The first connection in the project must

' be a CAN connection

If Connections(1).Protocol = peProtocolCAN Then

Dim ClientConn

Set ClientConn = Connections(1).CommunicationObject

MsgBox "Bit rate of Hardware = " & ClientConn.HardwareBitRateText

End If

End Sub

See also

HardwareBitRate Property

NetBitRateText Property


HardwareHandle Property

Applies to: J1939Node object, PCANClientConnection object

Returns the handle of a connected CAN hardware.

Syntax

object.HardwareHandle

Parameters

object

An expression that evaluates to a J1939Node object or a PCANClientConnection object.

Property value

A Long value representing a CAN hardware handle.

If the J1939Node object or PCANClientConnection object is not connected to any PCAN net, or the connected PCAN net is not connected to a CAN hardware, then the HardwareHandle property returns the value 0.

Example

The following example gets the handle of the hardware:

VBS Macro

Sub HardwareHandleExample()

If Connections.Count = 0 Then Exit Sub

Dim conn, handle

Set conn = Connections(1)

Select Case conn.Protocol

Case peProtocolCAN

' Access the PCANClientConnection object

Dim ClientConn

Set ClientConn = conn.CommunicationObject

handle = ClientConn.HardwareHandle

Case peProtocolJ1939

' Access the J1939Node object

Dim node

Set node = conn.CommunicationObject

handle = node.HardwareHandle

End Select

MsgBox "Hardware Handle = " & handle,,"Macro"

End Sub


HardwareInterrupt Property

Applies to: PCANClientConnection object

Returns the interrupt that is used by the connected CAN hardware.

Syntax

object.HardwareInterrupt

Parameters

object

An expression that evaluates to a PCANClientConnection object.

Property value

A Long value that represents the interrupt which is used by a connected CAN hardware.

If the PCANClientConnection object is not connected to any PCAN net, or the connected PCAN net is not connected to a CAN hardware, then the HardwareInterrupt property returns the value -1.

Example

The following example gets the interrupt that is used by the connected hardware.

VBS Macro

Sub HardwareInterruptExample()

' The first connection in the project must

' be a CAN connection

Dim client

If Connections(1).Protocol = peProtocolCAN Then

Set client = Connections(1).CommunicationObject

MsgBox "Interrupt = " & client.Connections(1).HardwareInterrupt

End If

End Sub

See also

HardwarePort Property


HardwareName Property

Applies to: PCANClientConnection object

Returns the name of a connected CAN hardware.

Syntax

object.HardwareName

Parameters

object

An expression that evaluates to a PCANClientConnection object.

Property value

A String value that represents the name of a connected CAN hardware.

If the PCANClientConnection object is not connected to any PCAN net, or the connected PCAN net in turn is not connected to a CAN hardware, then the HardwareName property returns an empty string.

Example

The following example gets the name of a connected CAN hardware:

VBS Macro

Sub HardwareNameExample()

' The first connection in the project must

' be a CAN connection

Dim client

If Connections(1).Protocol = peProtocolCAN Then

Set client = Connections(1).CommunicationObject

MsgBox "Name of hardware = " & client.Connections(1).HardwareName

End If

End Sub


HardwarePort Property

Applies to: PCANClientConnection object

Returns the I/O address that is used by the connected CAN hardware.

Syntax

object.HardwarePort

Parameters

object

An expression that evaluates to a PCANClientConnection object.

Property value

A Long value that represents the I/O address that is used by a connected CAN hardware.

If the PCANClientConnection object is not connected to any PCAN net, or the connected PCAN net in turn is not connected to a CAN hardware, then the HardwarePort property returns the value 0.

Example

The following example gets the I/O address of the hardware:

VBS Macro

Sub HardwarePortExample()

' The first connection in the project must

' be a CAN connection

Dim client

If Connections(1).Protocol = peProtocolCAN Then

Set client = Connections(1).CommunicationObject

MsgBox "I/O address = " & client.Connections(1).HardwarePort

End If

End Sub

See also

HardwareInterrupt Property


HardwareStatus Property [Variation 1]

Applies to: PCANClientConnection object

Returns the current status of a connected CAN hardware.

Syntax

object.HardwareStatus

Parameters

object

An expression that evaluates to a PCANClientConnection object.

Property value

A PCANError enum value that describes the status of the hardware: Possible values are:

  • pcanErrorNoVxd (512): No device driver is loaded.

  • pcanErrorBusOff (16): The connected CAN bus is in BUSOFF state.

  • pcanErrorBusHeavy (8): The connected CAN bus is in BUSHEAVY state.

  • pcanErrorOverrun (2): The reception register of the hardware couldn't be read before a new message was received.

Example

The following example retrieves the hardware status of the first connection in the project:

VBS Macro

Sub HardwareStatusExample()

If Connections.Count = 0 Then Exit Sub

Dim conn, ClientConn, status

Set conn = Connections(1)

If conn.Protocol = peProtocolCAN Then

' Access the PCANClientConnection object

Set ClientConn = conn.CommunicationObject

status = ClientConn.HardwareStatus

MsgBox "Hardware Status: " & ClientConn.Parent.GetErrorText(status)

End If

End Sub

See also

GetErrorText Method


HardwareStatus Property [Variation 2]

Applies to: J1939Node object

Returns the current status of a connected CAN hardware.

Parameters

object

An expression that evaluates to a J1939Node object.

Property values

A Long value that represents a status code. The status codes are identical to the ones returned by the HardwareStatus property of the PCANClient object. Possible values are:

  • 512 (pcanErrorNoDriver): No device driver is loaded.

  • 16 (pcanErrorBusOff): The connected CAN bus is in Bus-off state.

  • 8 (pcanErrorBusHeavy): The connected CAN bus is in BUSHEAVY state.

  • 2 (pcanErrorOverrun): The reception register of the hardware couldn't be read before a new message was received.


HardwareType Property

Applies to: J1939Node object

Returns the type of a connected CAN hardware.

Syntax

object.HardwareType

Parameters

object

An expression that evaluates to a J1939Node object.

Property value

A TCANHardware enum value that indicates the type of the connected CAN hardware. Possible values are:

  • tchNone (0): No hardware is connected.

  • tchDongle (1): The connected CAN hardware is a parallel port dongle.

  • tchPluginCard (2): The connected CAN hardware is either a plug-in card for the ISA bus, PCI bus, or PCI Express bus.

  • tchUSB (3): The CAN hardware is connected via a USB port.

  • tchPCCard (4): The connected CAN hardware is a PC Card (PCMCIA).


Height Property

Applies to: Window object

Sets or returns the height of a window.

Syntax

object.Height [=value]

Parameters

object

An expression that evaluates to a Window object.

value

A Long value that specifies the new value of the property.

Property value

A Long value that represents the height of the window in pixels.

Example

The following example sets the height of the active window to 150 pixels:

VBScript

ActiveWindow.Height = 150

See also

Left Property

Top Property

Width Property


HWnd Property

Applies to: Window object

Returns the window handle of the window.

Syntax

object.HWnd

Parameters

object

An expression that evaluates to a Window object.

Property value

A Long value that represents the Window Handle of the associated window.

Example

The following example gets the window handle of the active window and displays it in a message box:

VBS Macro

Sub HWndExample()

Dim h

h = ActiveWindow.HWnd

MsgBox "Window Handle = " & CStr(h)

End Sub


ID Property

Applies to: PCANMessage object, ReceiveEvent object, ReceiveMessage object, TraceMessage object, TransmitEvent object, TransmitMessage object, J1939Msg object, J1939RcvMsg object

Sets or returns the CAN ID of a CAN message.

Syntax

object.ID [=value]

Parameters

object

An expression that evaluates to one of the objects in the Applies To list above.

value

A Long value that specifies the new CAN identifier of the CAN message (0-1FFFFFFFh).

Property value

A Long value that represents the CAN identifier of the CAN message.

Remarks

The ID properties of the ReceiveEvent and TransmitEvent objects are read-only.

Example

The following example gets the CAN ID's of received messages and shows them in the output window:

VBS Macro

Sub IDExample()

Dim myClient, myConn, myMessage

' Create a new PCAN client, connect it, and

' open its filter

Set myClient = CreateObject("PCAN4.PCANClient")

myClient.Name = "Macro"

Set myConn = myClient.Connections.Add("TestNet")

myConn.RegisterMsg 0, &H7FF, False, False

Wait 1000

' Display all messages that have been received

' within the last Second

Set myMessage = myClient.Messages.Add

While myMessage.Read

PrintToOutputWindow Hex(myMessage.ID)

Wend

End Sub

The following example uses the Callback Library On Before Transmit event to modify data of a message with CAN ID 123h:

C++ Callback DLL

HRESULT __stdcall IDExample(PCANExplorer6::IPETransmitEvent *pEvent)

{

long id;

if (SUCCEEDED(pEvent->get_ID(&id)) && (id == 0x123))

{

// modify data byte 0

pEvent->put_Data(0, ...);

}

return S_OK;

}


IDfrom Property

Applies to: MessageFilterItem object

Sets or returns the lower CAN ID of a MessageFilterItem object that operates in ID Range mode.

Syntax

object.IDfrom [=value]

Parameters

object

An expression that evaluates to a MessageFilterItem object.

value

A Long value that specifies the new value of the property.

Property value

A Long value that represents the lower CAN ID of a range of CAN IDs.

Remarks

The IDfrom property only has an effect, if the Type property of the MessageFilterItem object is set to peFilterItemIDRange.

See also

IDto Property

Type Property


IDto Property

Applies to: MessageFilterItem object

Sets or returns the upper CAN ID of a MessageFilterItem object that operates in ID Range mode.

Syntax

object.IDto [=value]

Parameters

object

An expression that evaluates to a MessageFilterItem object.

value

A Long value that specifies the new value of the property.

Property value

A Long value that represents the upper CAN ID of a range of CAN IDs.

Remarks

The IDto property only has an effect, if the Type property of the MessageFilterItem object is set to peFilterItemIDRange.

See also

IDfrom Property

Type Property


IncludeEchoes Property

Applies to: J1939Node object

Sets or returns whether successfully transmitted messages are being echoed back in the receive queue.

Syntax

object.IncludeEchoes [=boolean]

Parameters

object

An expression that evaluates to a J1939Node object.

boolean

A Boolean value that specifies the new value of property.

Property value

A Boolean value that specifies whether messages that were transmitted successfully are being echoed back in the receive queue. If True, echoes are generated for transmitted messages. If False, no echoes are generated for transmitted messages.


IncludeTPMessages Property

Applies to: J1939Node object

Sets or returns whether Transport Protocol messages TPCM and TPDT are included in the messages receive queue.

Syntax

object.IncludeTPMessages [=boolean]

Parameters

object

An expression that evaluates to a J1939Node object.

boolean

A Boolean value that specifies the new value of property.

Property value

A Boolean value that specifies whether Transport Protocol messages TPCM and TPDT are included in the messages receive queue. True by default.


InitValue Property

Applies to: Signal object

Returns a Signal's initial value.

Syntax

object.InitValue

Parameters

object

An expression that evaluates to a Signal object.

Property value

A Double that specifies the Signal's initial value.

Remarks

You cannot use the InitValue property of Signals whose DataType property contains the value peDataTypeString.

Example

The following example displays the initial value of the signal "Speed" in a message box:

VBS Macro

Sub InitValueExample()

Dim sig, init

Set sig = Signals("Speed")

init = sig.InitValue

MsgBox init

End Sub


IsActive Property

Applies to: Application object, Document object, TextDocument object, Tracer object, Window object

Sets or returns whether a document, a window, or a tracer is active.

Syntax

object.IsActive [=boolean]

Parameters

object

An expression that evaluates to one of the objects in the Applies To list above.

boolean

A Boolean value that sets the new value of the property.

Property value

A Boolean value that specifies the state of the object. If True, the object is active. If False, the object is not active.

Example

The following example browses all open documents for the file "Sample.sym". If the file is found, it becomes the active document:

VBS Macro

Sub IsActiveExample()

Dim myDocument

For Each myDocument In Documents

If myDocument.Name = "Sample.sym" Then _

myDocument.IsActive = True

Next

End Sub


IsConnected Property [Variation 1]

Applies to: PCANClientConnection object

Sets or returns whether the PCANClientConnection object is connected to a PCAN net.

Syntax

object.IsConnected [=boolean]

Parameters

object

An expression that evaluates to a PCANClientConnection object.

boolean

A Boolean value that sets the new value of the property. If True, connects the object to the PCAN net that is specified in the NetName property. If False, disconnects the object from the previously connected PCAN net.

Property value

A Boolean value that specifies whether the object is connected or not. If True, the object is connected to a PCAN net. If False, the object is not connected to a PCAN net.

Example

The following example adds a new PCANClientConnection to a PCANClient object and connects it with the net "TestNet":

VBS Macro

Sub IsConnectedExample1()

Dim client, conn

Set client = CreateObject("PCAN4.PCANClient")

client.AutoConnect = False

client.Device = "pcan_usb"

client.Name = "Macro"

Set conn = client.Connections.Add("TestNet")

' The following line establishes the connection

conn.IsConnected = True

' Access the connection here

' ...

MsgBox "Press OK to remove client"

End Sub

See also

AutoConnect Property

Device Property


IsConnected Property [Variation 2]

Applies to: AddIn object

Returns a value indicating whether an Add-in is loaded and connected.

Syntax

object.IsConnected

Parameters

object

An expression that evaluates to an AddIn object.

Property value

A Boolean value that specifies whether the Add-in is loaded and connected. If True, the Add-in is loaded and connected. If False, the Add-in is not loaded or connected.

Example

The following example lists all Add-ins that are loaded and connected:

VBS Macro

Sub IsConnectedExample2()

Dim objAddIn, strMsg

For Each objAddIn In AddIns

If objAddIn.IsConnected Then _

strMsg = strMsg & objAddIn.Name & vbCrLf

Next

MsgBox strMsg,,"Connected Add-ins"

End Sub


IsEcho Property

Applies to: J1939RcvMsg object

Returns whether the message an echo of a transmitted J1939 message.

Syntax

object.IsEcho

Parameters

object

An expression that evaluates to a J1939RcvMsg object.

Property value

A Boolean value that specifies wether the message is an echo or not. If True, the message is an echo. If False, the message is a normal receive message. Echoes will be received by the J1939 node if the IncludeEchoes property is set to True.

See also

J1939Node Object

IncludeEchoes Property


IsEnabled Property

Applies to: CallbackLibraryEvent object, Connection object, MessageFilter object, MessageFilterItem object, VBSMacroFile object

Sets or returns whether the object is enabled or not.

Syntax

object.IsEnabled [=value]

Parameters

object

An expression that evaluates to one of the objects in the Applies To list above.

value

A Boolean value that specifies the new value of the property.

Property value

A Boolean value that specifies whether the object is enabled or not. If True, the object is enabled. If False, the object is not enabled.

Remarks

The IsEnabled property of the CallbackLibraryEvent object indicates, whether event handling is enabled for a Callback Library. The IsEnabled property of the CallbackLibraryEvent is read-only.

The IsEnabled property of the Connection object determines, whether the object has an active connection to a CAN bus or not.

The IsEnabled property of the MessageFilter object determines, whether the filter uses its filter items to filter messages. If the property is set to False, all messages can pass through the filter.

The IsEnabled property of the MessageFilterItem object determines, whether the parent filter uses the filter item to filter messages. Setting the property to False is, from the parent filter's view, the same as if the filter item is not present.

The IsEnabled property of the VBSMacroFile object determines, whether the macro file is loaded. If the macro file is loaded, all of its macros are available via the Macro drop-down list on the toolbar.


IsExtended Property

Applies to: MessageFilterItem object, Symbol object

Returns whether the object belongs to a CAN message that has a 29-bit identifier (Extended ID) or an 11-bit identifier (Standard ID).

Syntax

object.IsExtended [=value]

Parameters

object

An expression that evaluates to a MessageFilterItem object or Symbol object.

value

A Boolean value that specifies the new value of the property.

Property value

A Boolean value.

The IsExtended property of the Symbol object indicates, whether the Symbol represents a 29-bit CAN message. The IsExtended property of the Symbol object is read-only.

The IsExtended property of the MessageFilterItem object determines, whether the filter item is responsible for filtering 29-bit or 11-bit CAN messages.

Example

The following example displays a list of all Symbols along with their IsExtended property value in a message box:

VBS Macro

Sub IsExtendedExample()

If SymbolsManager.Count = 0 Then Exit Sub

' Get the first Symbols collection

Dim symbols

Set symbols = SymbolsManager(1)

' Iterate all symbols

Dim symbol, strMsg

For Each symbol In symbols

strMsg = strMsg & symbol.Name

If symbol.IsExtended Then

strMsg = strMsg & " - Extended" & vbCrLf

Else

strMsg = strMsg & " - Standard" & vbCrLf

End If

Next

MsgBox strMsg,,"Symbols"

End Sub


IsMotorola Property

Applies to: Multiplexer object, Variable object

Returns whether the individual bytes of a Multiplexer or Variable are arranged in the Motorola byte order.

Syntax

object.IsMotorola

Parameters

object

An expression that evaluates to a Multiplexer or Variable object.

Property value

A Boolean value that specifies whether the bytes are arranged in Motorola format or not. If True, the bytes are arranged in Motorola format (also called Big-Endian). If False, the bytes are arranged in Intel format (also called Little-Endian).


IsOpenThroughout Property

Applies to: J1939Filters collection

Returns whether the reception filter of a J1939Node object is completely open.

Syntax

object.IsOpenThroughout

Parameters

object

An expression that evaluates to a J1939Filters collection.

Property value

A Boolean value that specifies whether the reception filter is completely open. If True, all J1939Filter objects in the collection are ignored so that all J1939 messages can pass the filter. If False, the attributes of the J1939Filter objects in the collection determine whether a J1939 message can pass the filter or not.

See also

J1939Filter Object

OpenThroughout Method


IsPaused Property

Applies to: Multiplexer object, TransmitEvent object, TransmitMessage object

Sets or returns whether a CAN message is transmitted periodically, or whether a Multiplexer is transmitted periodically by default.

Syntax

object.IsPaused [=boolean]

Parameters

object

An expression that evaluates to one of the objects in the Applies To list above.

boolean

A Boolean that sets the new value of the property.

Property value

A Boolean value that specifies whether the CAN message is transmitted periodically or not. If True, the CAN message is transmitted periodically. If False, the CAN message is not transmitted periodically.

Remarks

The IsPaused property of the Multiplexer object is read-only. It returns the value of the "Paused" parameter that was defined for the Multiplexer in the Symbols file.

A CAN message can only be transmitted periodically if its CycleTime property contains a value greater than 0.

Example

The following example pauses all periodic messages in the transmit list:

VBS Macro

Sub IsPausedExample()

Dim msg

For Each msg In TransmitMessages

msg.IsPaused = True

Next

End Sub

See also

CycleTime Property


IsReadOnly Property

Applies to: Document object, TextDocument object

Sets or returns whether a document is write protected in PCAN-Explorer.

Syntax

object.IsReadOnly [=boolean]

Parameters

object

An expression that evaluates to a Document object or a TextDocument object.

boolean

A Boolean value that sets the new value of the property. If True, makes the document write protected in PCAN-Explorer. If False, makes the document read/write in PCAN-Explorer, but does not change its status on disk. For example, if the document is read-only on disk, it remains read-only.

Property value

A Boolean value that specifies whether the document is write protected in the PCAN-Explorer environment. If True, the document is write protected. If False, the document is read/write.

Example

The following example makes the active document read-only:

VBScript

ActiveDocument.IsReadOnly = True


IsReceived Property

Applies to: TraceMessage object

Returns whether a recorded CAN message was received or transmitted.

Syntax

object.IsReceived

Parameters

object

An expression that evaluates to a TraceMessage object.

Property value

A Boolean value that indicates wether the CAN message was received or transmitted. If True, the CAN message was received. If False, the CAN message was transmitted.


IsRegistered Property

Applies to: PCANClient object

Sets or returns whether a PCAN client is registered at a PCAN device.

Syntax

object.IsRegistered [=value]

Parameters

object

An expression that evaluates to a PCANClient object.

value

A Boolean value that sets the new value of the property. If True, registers the client at the PCAN device. Alternatively, the Register method of the PCANClient object can be called. If False, removes the client from the PCAN system. Alternatively, the Remove method can be called.

Property value

A Boolean value that specifies whether the client is registered at the PCAN device or not. If True, the client is registered. If False, the the client is not registered.

Remarks

Before a PCANClient object can be registered at a PCAN device, the Device property must contain the name of a PCAN device that is installed and loaded. Furthermore, a client name must be assigned to its Name property.

Example

The following example creates a new PCAN client and registers it:

VBS Macro

Sub IsRegisteredExample()

Dim client

Set client = CreateObject("PCAN4.PCANClient")

client.Device = "pcan_usb"

client.Name = "Macro"

If client.IsRegistered Then

' ...

Else

MsgBox "Error while registering client!"

End If

End Sub


IsRTR Property

Applies to: Multiplexer object

Returns whether a Multiplexer represents a Remote Transmission Request (RTR) message.

Syntax

object.IsRTR

Parameters

object

An expression that evaluates to a Multiplexer object.

Property value

A Boolean value that indicates whether a Multiplexer represents an RTR message. If True, the Multiplexer represents an RTR message. If False, the Multiplexer does not represent an RTR message.

Example

The following example lists all Multiplexers of a Symbol with their IsRTR property and displays them in a message box:

VBScript

Dim mux, strMsg

For Each mux In mySymbol

strMsg = strMsg & mux.Name & vbTab & mux.IsRTR & vbCrLf

Next

MsgBox strMsg


IsSaved Property

Applies to: Document object, TextDocument object, Project object

Returns a document's saved status, indicating whether a document has changed since it was last saved.

Syntax

object.IsSaved

Parameters

object

An expression that evaluates to a Document object, a TextDocument object, or a Project object.

Property value

A Boolean value that indicates the document's saved status:

  • True: Indicates that the document has not been changed since it was created or last saved.

  • False: Indicates that the document has been changed since it was last saved.

Example

The following example shows the saved status of the active document:

VBS Macro

Sub IsSavedExample()

Dim status

status = ActiveDocument.IsSaved

If status Then

MsgBox "Document is saved!"

Else

MsgBox "Document is modified!"

End If

End Sub


IsTimeout Property

Applies to: TraceMessage object

Returns whether a time-out event was recorded for a CAN message.

Syntax

object.IsTimeout

Parameters

object

An expression that evaluates to a TraceMessage object.

Property value

A Boolean value that indicates whether a time-out event occurred when this message was sent or received. If True, a time-out occurred for this message. If False, no time-out occurred for this message.


IsTraced Property

Applies to: Multiplexer object, Variable object

Returns whether the object will be recorded by the tracer.

Syntax

object.IsTraced

Parameters

object

An expression that evaluates to a Multiplexer object or a Variable object.

Property value

A Boolean value that indicates whether the object will be recorded by a tracer. If True, the object will be traced. If False, the object will be ignored.

Remarks

The IsTraced property only has an effect if a message filter has been assigned to a tracer that has a filter element of type "Ajust to marked symbols".


IsValid Property

Applies to: Connection object

Returns whether a connection is valid or not.

Syntax

object.IsValid

Parameters

object

An expression that evaluates to a Connection object.

Property value

A Boolean value that indicates whether the connection is valid or not. If True, the connection is valid. If False, the connection is invalid.

Remarks

Whether a connection is valid or not depends on the value of the Connection property. If the property value references a device and a PCAN net which actually exist on the current computer, then the connection is valid.


IsVisible Property

Applies to: Window object

Sets or returns the visibility of a window.

Syntax

object.IsVisible [=boolean]

Parameters

object

An expression that evaluates to a Window object.

boolean

A Boolean value that sets the visibility of the window. True makes the window visible. False makes the window invisible.

Note

Tabbed Document windows cannot be made invisible. If the IsVisible property of an Tabbed Document window is set to False, the window is only minimized in the working space.
Property value

A Boolean value that specifies the visibility of the window. If True, the window is visible. If False, the window is invisible.

Example

The following example makes the main window of PCAN-Explorer visible:

VBS Macro

MainWindow.IsVisible = True


Item Property

Applies to: J1939Filters collection

Retrieves a specific object from a collection.

Syntax

object.Item ( index )

or

object ( index )

Parameters

object

An expression that evaluates to a J1939Filters collection.

index

A Long that specifies the 1-based index of the object in the collection.

Property value

A J1939Filter object.

Example

The following example accesses all filters in the collection:

VBS Macro

Dim filter, i

For i = 1 To myNode.Filters.Count

Set filter = myNode.Filters(i)

...

Next


ItemCount Property

Applies to: MessageFilter object

Returns the number of filter items in the filter.

Syntax

object.ItemCount

Parameters

object

An expression that evaluates to a MessageFilter object.

Property value

A Long value that indicates the number of filter items in the filter.


J1939FilterFlags Property

Applies to: MessageFilterItem object

Sets or returns a value that determines which J1939 attributes are taken into account to filter J1939 messages.

Syntax

object.J1939FilterFlags [=flags]

Parameters

object

An expression that evaluates to a MessageFilterItem object.

flags

A combination of PeJ1939FilterFlags enum values that sets the new value of the property.

Property value

A combination of PeJ1939FilterFlags enum values. Possible values are:

  • peJ1939PGN (1): The PGN property is taken into account.

  • peJ1939Priority (2): The Priority property is taken into account.

  • peJ1939SourceAddress (3): The SourceAddress property is taken into account.

  • peJ1939DestinationAddress (4): The DestinationAddress property is taken into account.

Remarks

The J1939FilterFlags property only has an effect if the Type property of the MessageFilterItem object is set to peFilterItemJ1939.

See also

Type Property


Kind Property

Applies to: Document object, ProjectItem object, Window object

Returns a GUID string indicating the kind or type of the object.

Syntax

object.Kind

Parameters

object

An expression that evaluates to one of the objects in the Applies To list above.

Property value

A String value that indicates the kind or type of the object.

The Kind property of the Document object can return one of the following values:

Kind | Meaning | Alias
{80FDDCF6-A897-4A13-8893-1450FCB1754F} | Text document | peDocumentKindText
{ABF79C99-1166-4A10-90D3-5058EB7E94C5} | Trace document | peDocumentKindTrace
{9B06D6BC-2C36-41CC-8633-E7CFDE493D4F} | Transmit List document | peDocumentKindTransmit
{E76D8F30-5131-43C7-91E8-41CAC563CD90} | HTML document | peDocumentKindHtml
{31191CEB-5D42-4D0B-944D-5DC876238C35} | Plotter document | peDocumentKindPlotter
{DFAFFAC0-2F50-428E-824C-B97089CD5F3F} | Instruments Panel document | peDocumentKindInstrumentsPanel
{932ED998-1332-415b-A667-F5690CE3A42D} | Line Writer document | peDocumentKindLineWriter

The Kind property of the Window object can return one of the following values:

Kind | Meaning | Alias
{80FDDCF6-A897-4A13-8893-1450FCB1754F} | Text document | peDocumentKindText
{ABF79C99-1166-4A10-90D3-5058EB7E94C5} | Trace document | peDocumentKindTrace
{9B06D6BC-2C36-41CC-8633-E7CFDE493D4F} | Transmit List document | peDocumentKindTransmit
{E76D8F30-5131-43C7-91E8-41CAC563CD90} | HTML document | peDocumentKindHtml
{31191CEB-5D42-4D0B-944D-5DC876238C35} | Plotter document | peDocumentKindPlotter
{DFAFFAC0-2F50-428E-824C-B97089CD5F3F} | Instruments Panel document | peDocumentKindInstrumentsPanel
{932ED998-1332-415b-A667-F5690CE3A42D} | Line Writer document | peDocumentKindLineWriter
{7BF0CC9B-1632-4935-AD9A-ACE17D48E2C9} | Main window | peWindowKindMainWindow
{3F159EA3-60F6-46C7-9062-93F1E6750139} | Receive/Transmit window | peWindowKindReceiveTransmit
{48F7B7FB-3CE6-4A06-9310-444871C3B477} | Project Manager window | peWindowKindProjectManager
{FB44BF1E-7C70-4F04-A5B5-A476C4006598} | Connections window | peWindowKindConnections
{7A8A32C4-B718-40D6-9B8B-688F6DEF3068} | Properties window | peWindowKindProperties
{4842AE28-C870-4465-8195-8E0BC9B5DC5A} | Output window | peWindowKindOutput
{EA49F784-6A32-4CFE-A009-A286A8DED2FD} | Watch window | peWindowKindWatch
{27B1E93E-3A39-46E0-9BA8-4B40071A7BF5} | Timing Errors window | peWindowKindTiming
{9D2F99BB-7967-4361-8FA6-7ACD02D41EE3} | Macro Status window | peWindowKindMacroStatus
{0EFDD5ED-3FFB-4fec-AA56-927B865C3B3A} | Library window | peWindowKindLibrary
{D71CB064-8749-45C1-B82B-047AAFC33690} | Start Page | peWindowKindStartPage
{FF2113AB-74F9-412A-8D05-56BB972DB9C0} | News window | peWindowKindNews
{4B0CCB52-16CF-4F69-91FD-6339284F9FBD} | About window | peWindowKindAbout

The Kind property of the ProjectItem object can return one of the following values:

Kind | Meaning | Alias
{BD403830-4B7E-450f-95F5-29DBCEFC83A0} | File | peProjectItemKindFile
{BD403832-4B7E-450f-95F5-29DBCEFC83A0} | Virtual Folder | peProjectItemKindVirtualFolder
{BD403833-4B7E-450f-95F5-29DBCEFC83A0} | Connection | peProjectItemKindConnection
{BD403834-4B7E-450f-95F5-29DBCEFC83A0} | Connections | peProjectItemKindConnections
{BD403835-4B7E-450f-95F5-29DBCEFC83A0} | Message Filter | peProjectItemKindMessageFilter
{BD403836-4B7E-450f-95F5-29DBCEFC83A0} | Message Filters | peProjectItemKindMessageFilters
{BD403837-4B7E-450f-95F5-29DBCEFC83A0} | Message Filter Item | peProjectItemKindMessageFilterItem
{BD403838-4B7E-450f-95F5-29DBCEFC83A0} | Receive List | peProjectItemKindReceiveList
{BD403839-4B7E-450f-95F5-29DBCEFC83A0} | Transmit List | peProjectItemKindTransmitList
{BD40383A-4B7E-450f-95F5-29DBCEFC83A0} | Transmit List Item | peProjectItemKindTransmitListItem
{BD40383B-4B7E-450f-95F5-29DBCEFC83A0} | File Configuration | peProjectItemKindFileConfiguration
{BD40383C-4B7E-450f-95F5-29DBCEFC83A0} | Macros | peProjectItemKindMacros
{BD40383D-4B7E-450f-95F5-29DBCEFC83A0} | Macro | peProjectItemKindMacro
{BD40383E-4B7E-450f-95F5-29DBCEFC83A0} | Signals | peProjectItemKindSignals
{BD40383F-4B7E-450f-95F5-29DBCEFC83A0} | Signal | peProjectItemKindSignal
{BD403840-4B7E-450f-95F5-29DBCEFC83A0} | Timings | peProjectItemKindTimings
Example

The following example shows the kind of the active document:

VBS Macro

Sub KindExample()

' Open a text document before executing this example

Dim objDoc

Set objDoc = ActiveDocument

MsgBox "Kind of the active document: " & objDoc.Kind

End Sub


Properties L-P

The following table contains all properties beginning with letters L to P:

Property | Description
Language [Variation 1] | Sets or returns the (programming) language of a text document, which is used to set the correct syntax highlighting in the text editor.
Language [Variation 2] | Sets or returns the primary language ID of the language that is used for error messages.
LastCANError | Returns the code of the object's last CAN error.
LastError [Variation 1] | Returns the error code of an object's error that has occurred last.
LastError [Variation 2] | Returns the code of the last error that occurred for a J1939 node.
LastError [Variation 3] | Returns the code of the last error that occurred while sending the message.
LastErrorText | Returns the last error that has occurred for the object, as text.
LastErrorType | Returns what kind of error is specified in the LastError property of the TransmitMessage object.
Left | Sets or returns the x-coordinate of a window's left edge.
Length | Sets or returns the length of a J1939 message.
ListenOnly | Sets or returns whether the Listen Only mode is activated for the PCANClientConnection object.
LongName | Sets or returns the long name of an object.
MainWindow | Returns a Window object that represents the main window of PCAN-Explorer.
Max | Sets or returns the upper limit of a Signal's or Variable's range of values.
MaxCycleTime | Returns the measured maximum time interval between two successive reception events.
MessageFilters | Returns a MessageFilters collection.
Messages | Returns a collection of CAN messages.
Min | Sets or returns the lower limit of a Signal's or Variable's range of values.
MinCycleTime | Returns the measured minimum time interval between two successive reception events.
MinInterval | Returns the minimum allowed interval time value that was defined for a Multiplexer.
Monitoring | Sets or returns whether a J1939Node object works as a J1939 network monitor.
MsgType | Sets or returns the type of a CAN message.
Multiplexer | Returns the Multiplexer object that is associated with a CAN message.
Multiplexers | Returns a Multiplexers collection.
MuxData | Returns the data bytes of a Multiplexer, which are filled with the value of the Multiplexer.
MuxLength | Returns the number of bits that a Multiplexer occupies in the data bytes of the CAN message.
MuxStart | Returns a Multiplexer's first bit's index in the data bytes of a CAN message.
MuxValue | Returns the value of a Multiplexer.
Name | Sets or returns the name of an object.
NetBaudRate | Returns the baud rate code that was defined for a connected PCAN net that uses an SJA1000-compatible (non-CAN-FD) baud rate.
NetBitRate | Returns a PCANBitrate object that describes the bit rate that was defined for a connected PCAN net.
NetBitRateText | Returns the bit rate that was defined for the connected PCAN net as text, as a text.
NetHandle | Returns the handle of the connected PCAN net.
NetName | Returns the name of the connected PCAN net.
_NewEnum | References objects in a collection.
Next | Returns the next window in the tab sequence.
NominalBitrate | Returns the nominal (arbitration) bit rate of a CAN or CAN FD bit rate.
NotificationOnAddressClaiming | Sets or returns whether a J1939Node object triggers OnAddressClaiming events during an address claiming process.
NotificationOnAddressLost | Sets or returns whether the J1939Node object triggers OnAddressLost events.
NotificationOnMessageReceived | Sets or returns whether the J1939Node object triggers OnMessageReceived events.
NotificationOnPropertyChange | Sets or returns whether the J1939Node object triggers OnPropertyValueChanged events.
Object | Returns an interface or object that can be accessed by name at run time.
ObjectKind | Returns the type of the Window.Object object, which is a GUID string representing the tool contained in the window.
Offset | Returns the offset that was defined for the for the variable to transform its value from a raw value into a physical value.
Originator | Sets or returns the source address of the originator of a J1939 message.
OutputFormat | Returns the output format of a Variable.
OutputWindowPanes | Returns the OutputWindowPanes collection for the object.
Overtype | Sets or returns whether the editor is in overtype mode.
PacksCount | Returns the number of packages in which the data of this message is distributed.
PacksCountOnReadSessions | Sets or returns the maximum number of large message data packets cleared to send in a TPCM.CTS message.
PacksCountOnWriteSessions | Sets or returns a value that limits the number of requested packets that can be sent by the originator in response to one CTS.
ParameterString | Returns a string with the individual parameters of the bit rate.
Parent | Returns the immediate parent object of a given object.
Path | Returns the path to an object.
PGN | Sets or returns a J1939 Parameter Group Number.
PGNsToRejectOnRTS | Sets or returns a set of PGNs that are rejected by sending TPCM.ConnAbort when a TPCM.RTS message is received for one of them.
PlaybackPosition | Returns the current playback position of a tracer.
PlaybackRepeat | Determines whether trace playback restarts from the beginning when the end of the trace buffer or file is reached.
PlaybackRepeatCount | During playback of a trace buffer or file, determines the number of playback cycles before playback is stopped.
PlaybackRepeatPause | Determines the time delay before playback of a trace buffer or file is repeated.
PostLoadCommand | Sets or returns the name of a command that is executed after a project is loaded.
PreferredAddress | Sets or returns the address that the J1939Node object tries to claim when the ClaimAddress method is called.
Previous | Returns the previous window in the tab sequence.
Priority | Sets or returns a J1939 Priority.
ProgID | Returns a ProgID based on an Add-in's registry entry.
Project | Returns the Project object in which a ProjectItem object or ProjectItems collection is included.
ProjectItems | Returns a ProjectItems collection for the object.
Protocol | Sets or returns the protocol that a connection uses.

See also

Properties A-F

Properties G-K

Properties Q-T

Properties U-Z


Language Property [Variation 1]

Applies to: TextDocument object

Sets or returns the (programming) language of a text document, which is used to set the correct syntax highlighting in the text editor.

Syntax

object.Language [=string]

Parameters

object

An expression that evaluates to a TextDocument object.

string

A string constant of type PeLanguageSettings that specifies the type of the language. Possible values are:

  • peSymbols: Represents "CAN Symbols".

  • peMacro: Represents "Macro".

  • peVBSMacro: Represents "VBS Macro".

Remarks

The Language property has the String type.

Example

The following example sets the language of the active document to "CAN Symbols":

VBS Macro

Sub LanguageExample()

If ActiveDocument.Kind = peDocumentKindText Then _

ActiveDocument.Language = peSymbols

End Sub


Language Property [Variation 2]

Applies to: PCANClient object

Sets or returns the primary language ID of the language that is used for the error messages returned by the GetLongErrorText method.

Syntax

object.Language [=value]

Parameters

object

An expression that evaluates to a PCANClient object.

value

A Long value that specifies the new value of the property.

Property value

A Long value that specifies the primary language ID. Possible language IDs are 9 (English, the default) and 7 (German).


LastCANError Property

Applies to: J1939Node object

Returns the code of the object's last CAN error.

Syntax

object.LastCANError

Parameters

object

An expression that evaluates to a J1939Node object.

Property value

A Long value that represents a combination of error codes. The individual error codes are identical to the ones returned by the LastError property of the PCANClient object:

  • 0 (pcanErrorOk): No error occurred.

  • 1 (pcanErrorXmtFull): The transmission buffer in the CAN controller is full.

  • 2 (pcanErrorOverrun): The CAN controller hasn't been read out before the reception of a new message.

  • 4 (pcanErrorBusLight): An error counter has reached the BUSLIGHT limit.

  • 8 (pcanErrorBusHeavy): An error counter has reached the BUSHEAVY limit.

  • 8 (pcanErrorBusWarning): An error counter reached the 'warning' limit.

  • 10h (pcanErrorBusOff): The CAN controller is in bus-off state.

  • 20h (pcanErrorQRcvEmpty): The receive queue is empty.

  • 40h (pcanErrorQOverrun): The reception queue has overflowed.

  • 80h (pcanErrorQXmtFull): The transmission queue is full.

  • 100h (pcanErrorRegTest): The register test of the SJA1000 has failed.

  • 200h (pcanErrorNoDriver): No device driver is loaded.

  • 400h (pcanErrorHwInUse): The hardware is occupied by another net.

  • 800h (pcanErrorNetInUse): A client is connected to the net.

  • 1400h (pcanErrorIllHw): The hardware handle is not valid.

  • 1800h (pcanErrorIllNet): The net handle is not valid.

  • 1C00h (pcanErrorIllClient): The client handle is not valid.

  • 1C00h (pcanErrorMaskIllHandle): Mask for all handle errors.

  • 2000h (pcanErrorResource): A resource (buffer, client, timeout) couldn't be created.

  • 4000h (pcanErrorParamType): The parameter is not permitted/applicable.

  • 8000h (pcanErrorParamVal): Der parameter value is not valid.

  • 10000h (pcanErrorUnknown): Unknown error.

  • 20000h (pcanErrorIllFunction): Function not supported.

  • 40000h (pcanErrorBusPassive): The CAN controller is in error passive state.

  • 1000000h (pcanErrorIllDevice): The indicated device name is not allowed.

See also

LastError Property [Variation 1]

LastError Property [Variation 2]


LastError Property [Variation 1]

Applies to: PCANClient object, PCANMessage object

Returns the error code of an object's error that has occurred last.

Syntax

object.LastError

Parameters

object

An expression that evaluates to one of the objects in the Applies To list above.

Property value

A combination of PCANError enum values:

  • pcanErrorOk(0): No error occurred.

  • pcanErrorXmtFull (1): The transmission buffer in the CAN controller is full.

  • pcanErrorOverrun (2): The CAN controller hasn't been read out before the reception of a new message.

  • pcanErrorBusLight (4): An error counter has reached the BUSLIGHT limit.

  • pcanErrorBusHeavy (8): An error counter has reached the BUSHEAVY limit.

  • pcanErrorBusWarning (8): An error counter reached the 'warning' limit.

  • pcanErrorBusOff (10h): The CAN controller is in bus-off state.

  • pcanErrorQRcvEmpty (20h): The receive queue is empty.

  • pcanErrorQOverrun (40h): The reception queue has overflowed.

  • pcanErrorQXmtFull (80h): The transmission queue is full.

  • pcanErrorRegTest (100h): The register test of the SJA1000 has failed.

  • pcanErrorDriver (200h): No device driver is loaded.

  • pcanErrorHwInUse (400h): The hardware is occupied by another net.

  • pcanErrorNetInUse (800h): A client is connected to the net.

  • pcanErrorIllHw (1400h): The hardware handle is not valid.

  • pcanErrorIllNet (1800h): The net handle is not valid.

  • pcanErrorIllClient (1C00h): The client handle is not valid.

  • pcanErrorMaskIllHandle (1C00h): Mask for all handle errors.

  • pcanErrorResource (2000h): A resource (buffer, client, timeout) couldn't be created.

  • pcanErrorParamType (4000h): The parameter is not permitted/applicable.

  • pcanErrorParamVal (8000h): Der parameter value is not valid.

  • pcanErrorUnknown (10000h): Unknown error.

  • pcanErrorIllFunction (20000h): Function not supported.

  • pcanErrorBusPassive (40000h): The CAN controller is in error passive state.

  • pcanErrorIllDevice (1000000h): The indicated device name is not allowed.

Example

The following example retrieves the last error of a PCANClient object:

VBS Macro

Sub LastErrorExample()

Dim client

Set client = CreateObject("PCAN4.PCANClient")

client.Device = "pcan_usb"

client.Name = "Macro" ' This registers the client automatically

If Not client.IsRegistered Then

' Error while registering client

MsgBox "Error code: " & client.LastError

End If

End Sub

See also

LastErrorText Property

GetErrorText Method


LastError Property [Variation 2]

PCAN-Explorer: Automation

Objekte

LastError Property [Variation 3]

Home Page (Objects) | Reference

Applies to: J1939Node object

Returns the code of the last error that occurred for the J1939 node.

Syntax

object.LastError

Parameters

object

An expression that evaluates to a J1939Node object.

Property value

A TJ1939Error enum value. The following values are possible:

  • errOK (0): No error occurred.

  • errNotConnected (1): The J1939 node is not connected to any PCAN net.

  • errAlreadyConnected (2): The J1939 node is already connected to a PCAN net.

  • errAlreadySending (3): The transmission of a large message to the specified address is already in progress.

  • errWrongParamValue (4): A specified parameter was invalid.

  • errAddressBeingClaimed (5): Claiming an address is already in progress.

  • errAddressLost (6): The previously claimed address was lost.

  • errAddrNotClaimed (7): An address must be claimed first.

  • errAddrClaimFailed (8): Claiming an address has failed.

  • errQueueEmpty (9): There are no messages in the receive queue.

  • errCANObject (10; 0Ah): A CAN error occurred. See LastCANError property for more information.

  • errResource (11; 0Bh): Ab error occurred while allocating or freeing a resource.

  • errAborted (12; 0Ch): An operation was aborted because the connection was lost.

  • errUnknownError (65536; 10000h): An unknown error occurred.

See also

LastCANError Property


LastError Property [Variation 3]

Applies to: TransmitEvent object, TransmitMessage object

Returns the code of the last error that occurred while sending the message.

Syntax

object.LastError

Parameters

object

An expression that evaluates to a TransmitEvent or TransmitMessage object.

Property value

A Long value that represents an error code. The meaning of the error code depends on the contents of the LastErrorType property.

LastErrorType | Description
peErrorTypeCAN (0) | The individual error codes are identical to the ones returned by the LastError property of the PCANClient object.
peErrorTypeJ1939 (1) | The individual error codes are identical to the ones returned by the LastError property of the J1939Node object
peErrorTypeOther (2) Possible errors:
  • 10: No connection is assigned to the transmit message.
  • 11: The assigned connection is not enabled.

See also

LastErrorType Property


LastErrorText Property

Applies to: PCANClient object, PCANMessage object

Returns the last error that has occurred for the object, as text.

Syntax

object.GetLastErrorText

Parameters

object

An expression that evaluates to a PCANClient object or a PCANMessage object.

Return value

The LastErrorText property returns a String containing the error that has occurred last, in text format. Errors can be generated by calling methods or by setting properties of the objects. The last occurred error is saved in the LastError property of the PCANClient object or PCANMessage object.

If the value of the LastError property is 0, The LastErrorText property returns an empty string.

Remarks

The LastErrorText property has the String type.

Example

The following example shows the error occurred last as text:

VBS Macro

Sub LastErrorTextExample()

Dim client

Set client = CreateObject("PCAN4.PCANClient")

client.Name = "Macro"

If Not client.IsRegistered Then

' Error while registering client at PCAN device

MsgBox "Error: " & client.LastErrorText

End If

End Sub

See also

LastError Property

GetErrorText Method


LastErrorType Property

Applies to: TransmitEvent object, TransmitMessage object

Returns what kind of error is specified in the LastError property of the object.

Syntax

object.LastErrorType

Parameters

object

An expression that evaluates to a TransmitEvent or TransmitMessage object.

Property value

A PeErrorType enum value that indicates what kind of error is specified in the LastError property.

  • peErrorTypeCAN (0): The message is a CAN message, see the LastError property of the PCANClient object for a description of the possible error codes.

  • peErrorTypeJ1939 (1): The message is a J1939 message, see LastError property of the J1939Node object for a description of the possible error codes.

  • peErrorTypeOther (2): This kind of error can occur if the transmit message is not assigned to any bus/connection, or if the assigned connection is not enabled.


Left Property

Applies to: Window object

Sets or returns the x-coordinate of a window's left edge.

Syntax

object.Left [=value]

Parameters

object

An expression that evaluates to a Window object.

value

A Long value that specifies the new value of the property.

Property value

A Long value that represents the x-coordinate of the window's left edge in pixels.

Remarks
Note

Tabbed Document window coordinates are relative to the child window client area. (This area is inside the frame but does not include the docking sites.)
Example

The following example sets the x-coordinate of the active window to 25:

VBScript

ActiveWindow.Left = 25

See also

Height Property

Top Property

Width Property


Length Property

Applies to: J1939Msg object, J1939RcvMsg object

Sets or returns the length of the message.

Syntax

object.Length [=value]

Parameters

object

An expression that evaluates to a J1939Msg object or a J1939RcvMsg object.

value

A value that sets the new value of the data byte.

Property value

A Long value that specifies the length of the J1939 message (0-1785).

Remarks

The Length property of the J1939RcvMsg object is read-only.


ListenOnly Property

Applies to: PCANClientConnection object

Sets or returns whether the Listen Only mode is activated for the PCANClientConnection object.

Syntax

object.ListenOnly [=boolean]

Parameters

object

An expression that evaluates to a PCANClientConnection object.

boolean

A Boolean value that sets the new value of the property.

Property value

A Boolean value that specifies whether the Listen Only mode is activated for the object. If True, the Listen Only mode is activated. If False, the Listen Only mode is deactivated.

Remarks

The ListenOnly property only has an effect if the PCANClientConnection object is connected to a CAN hardware.

In Listen Only mode, the CAN controller gives no acknowledge to the CAN bus, even if a message is received successfully. The CAN controller is forced to be error passive. Message transmission is not possible. The Listen Only mode can be used e.g. for monitoring purposes or software driven bit rate detection.


LongName Property

Applies to: Signal object, Variable object

Sets or returns the long name of an object.

Syntax

object.LongName [=value]

Parameters

object

An expression that evaluates to a Signal object or a Variable object.

value

A String value that specifies the new value of the property.

Property value

A String value that specifies the long name of the object.

Remarks

The LongName property of the Variable object is read-only.

See also

Name Property


MainWindow Property

Applies to: Application object

Returns a Window object that represents the main window of PCAN-Explorer.

Syntax

object.MainWindow

Parameters

object

An expression that evaluates to an Application object. When you access the MainWindow property of the Application object, you can omit object because the name of the Application object is implied when you access its properties and methods.

Property value

A Window object.

Example

The following example gets the caption of the main window and displays it in a message box:

VBS Macro

Sub MainWindowExample()

MsgBox MainWindow.Caption

End Sub


Max Property

Applies to: Signal object, Variable object

Sets or returns the upper limit of a Signal's or Variable's range of values.

Syntax

object.Max [=value]

Parameters

object

An expression that evaluates to a Signal object or a Variable object.

value

A Long value that sets the new value of the property.

Property value

A Double value that specifies the upper limit of the object's range of values.

The Max property of signals that have the data type peDataTypeString always returns 0.

Remarks

The Max property of the Variable object is read-only.

Example

The following example displays the range of values of the signal "Speed":

VBS Macro

Sub ValueExample()

Dim sig

Set sig = Signals("RcvSymbol.Mux1.Speed")

MsgBox "Value range: " & sig.Min & "..." & sig.Max

End Sub

See also

Min Property


MessageFilters Property

Applies to: Application object

Returns the MessageFilters collection.

Syntax

object.MessageFilters

Parameters

object

An expression that evaluates to an Application object.

Property value

A MessageFilters collection.

Example

The following example accesses the MessageFilters collection:

VBS Macro

Sub MessageFiltersExample()

Dim filter, strMsg

For Each filter In MessageFilters

strMsg = strMsg & filter.Name & vbCrLf

Next

MsgBox strMsg,,"Filters"

End Sub


Messages Property

Applies to: PCANClient object, Tracer object, TransmitWindow object

Returns a collection of CAN messages.

Syntax

object.Messages

Parameters

object

An expression that evaluates to a PCANClient object, a Tracer object, or a TransmitWindow object.

Property value

  • For the PCANClient object a PCANMessages collection is returned.

  • For the Tracer object a TraceMessages collection is returned.

  • For the TransmitWindow object a TransmitMessages collection is returned.

Remarks

The PCANMessages collection represents a collection of CAN messages. Each CAN message in the collection is represented by a PCANMessage object.

The TraceMessages collection represents a collection of CAN messages. Each CAN message in the collection is represented by a TraceMessage object.

The TransmitMessages collection represents a collection of CAN messages. Each CAN message in the collection is represented by a TransmitMessage object.

When you query the Messages property of the Tracer object, the tracer must be either in paused or stopped mode (see TraceState property), otherwise an empty TraceMessages collection is returned.

Example

The following example accesses the Messages property of a Transmit list window:

VBS Macro

Sub MessagesExample()

If ActiveWindow.Kind = peDocumentKindTransmit Then _

MsgBox ActiveWindow.Object.Messages.Count

End Sub


Min Property

Applies to: Signal object, Variable object

Sets or returns the lower limit of a Signal's or Variable's range of values.

Syntax

object.Min [=value]

Parameters

object

An expression that evaluates to a Signal object or a Variable object.

value

A Long value that sets the new value of the property.

Property value

A Double value that specifies the lower limit of the object's range of values.

The Min property of signals that have the data type peDataTypeString always returns 0.

Remarks

The Min property of the Variable object is read-only.

Example

The following example displays the range of values of the signal "Speed":

VBS Macro

Sub ValueExample()

Dim sig

Set sig = Signals("RcvSymbol.Mux1.Speed")

MsgBox "Value range: " & sig.Min & "..." & sig.Max

End Sub

See also

Max Property


MinInterval Property

Applies to: Multiplexer object, ReceiveEvent object, ReceiveMessage object

Returns the minimum allowed interval time value that was defined for a Multiplexer.

Syntax

object.MinInterval

Parameters

object

An expression that evaluates to one of the objects in the Applies To list above.

Property value

A Long value that specifies the minimum interval time of the object in Milliseconds.

The value 0 indicates that no minimum interval was defined for the object.

Example

The following example gets the minimum interval time of a Multiplexer:

VBScript

Dim minInt

minInt = myMux.MinInterval

See also

Timeout Property


Monitoring Property

Applies to: J1939Node object

Sets or returns whether a J1939Node object works as a J1939 network monitor.

Syntax

object.Monitoring [=value]

Parameters

object

An expression that evaluates to a J1939Node object.

value

A Boolean that specifies the new value of the property.

Property value

A Boolean value that specifies whether the J1939 node object works as a J1939 network monitor. If True, Monitoring mode is activated. If False, Monitoring mode is deactivated.

In Monitoring mode, the J1939 node processes all of the Transport Protocol messages on the bus, even those that are not explicitly directed to the node because of its claimed address. The node processes the Transport Protocol messages and builds the large messages, which are then placed in the node's receive queue when completely transmitted.


MsgType Property

Applies to: PCANMessage object, ReceiveEvent object, ReceiveMessage object, TraceMessage object, TransmitEvent object, TransmitMessage object

Sets or returns the type of a CAN message.

Syntax

object.MsgType [=type]

Parameters

object

An expression that evaluates to one of the objects in the Applies To list above.

type

A combination of PCANMsgType enum values that specify the new value of the property.

Property value

A combination of PCANMsgType enum values that specify the type of the CAN message:

  • pcanMsgTypeStandard (0): A standard frame (11-bit CAN ID).

  • pcanMsgTypeRTR (1): A Remote Request frame.

  • pcanMsgTypeExtended (2): An extended frame (29-bit CAN ID).

  • pcanMsgTypeSingleShot (8): The message uses the Single Shot CAN controller option.

  • pcanMsgTypeErrorFrame (64): An Error Frame.

  • pcanMsgTypeStatus (128): A status message.

  • pcanMsgTypeErrorCounter (256): The message informs about error counter value changes.

  • pcanMsgTypeBusload (512): The message contains busload information.

  • pcanMsgTypeFD (1024): A CAN FD frame. CAN FD frames can have up to 64 data bytes.

  • pcanMsgTypeBRS (2048): A CAN FD frame with active Bit Rate Switch. The data fields in a CAN FD frame are transferred with a higher bit rate if the Bit Rate Switch flag is set.

  • pcanMsgTypeESI (4096): A CAN FD frame with Error State Indicator flag set. The Error State Indicator provides information, whether the sender of the message is in Error Active or Error Passive state.

Remarks

The MsgType properties of the ReceiveEvent and TransmitEvent objects are read-only.

Example

The following example sends a Remote Transmission Request message with an extended CAN ID:

VBS Macro

Sub MsgTypeExample()

Dim client, conn

Set client = CreateObject("PCAN4.PCANClient")

client.Name = "Macro"

' Connect client to net TestNet

Set conn = client.Connections.Add("TestNet")

If conn.IsConnected Then

Dim msg

Set msg = client.Messages.Add

With msg

.ID = &H100

.DLC = 2

.MsgType = pcanMsgTypeRTR + pcanMsgTypeExtended

.Write conn, 0

End With

End If

End Sub


Multiplexer Property

Applies to: ReceiveMessage object, TraceMessage object, TransmitMessage object

Returns the Multiplexer object that is associated with the CAN message.

Syntax

object.Multiplexer

Parameters

object

An expression that evaluates to one of the objects in the Applies To list above.

Property value

A Multiplexer object.

Example

The following example displays the Multiplexer name of every symbolic CAN message that the Receive list contains:

VBS Macro

Sub MultiplexerExample()

Dim msg

For Each msg In ReceiveMessages

If Not msg.Multiplexer Is Nothing Then _

PrintToOutputWindow msg.Multiplexer.Name

Next

End Sub

See also

Symbol Property


Multiplexers Property

Applies to: Symbol object

Returns a Multiplexers collection.

Syntax

object.Multiplexers

Parameters

object

An expression that evaluates to a Symbol object.

Property value

A Multiplexers collection.

Remarks

The Multiplexers collection contains all Multiplexers that were defined for a Symbol. Each Multiplexer in the collection is represented by a Multiplexer object.

Example

The following example accesses the Multiplexers collection of a Symbol:

VBScript

Dim muxs

Set muxs = mySymbol.Multiplexers


MuxData Property

Applies to: Multiplexer object

Returns the data bytes of a Multiplexer, which are filled with the value of the Multiplexer.

Syntax

object.MuxData ( index )

Parameters

object

An expression that evaluates to a Multiplexer object.

index

A Long value that specifies the index (0-7) of the accessed data byte.

Property value

An indexed Long value that specifies one data byte of a CAN message (0-255).

Remarks

The data bytes that can be retrieved with the MuxData property do not contain the default data of the signal. The default data can be retrieved with the DefaultData property.

Example

The following example shows how the value of a Multiplexer is embedded in the data bytes of a CAN message:

VBScript

Dim strMsg

For i = 0 To myMux.DataLength-1

strMsg = strMsg & Hex(myMux.MuxData(i)) & " "

Next

MsgBox strMsg

See also

MuxStart Property

MuxLength Property


MuxLength Property

Applies to: Multiplexer object, Symbol object

Returns the number of bits that the Multiplexer occupies in the data bytes of the CAN message.

Syntax

object.MuxLength

Parameters

object

An expression that evaluates to a Multiplexer object or a Symbol object.

Property value

A Long value that specifies the length of the Multiplexer in bits.

Remarks

All Multiplexers contained in a Symbol object have the same number of bits.

See also

MuxStart Property


MuxStart Property

Applies to: Multiplexer object, Symbol object

Returns the Multiplexer's first bit's index in the data bytes of a CAN message.

Syntax

object.MuxStart

Parameters

object

An expression that evaluates to a Multiplexer object or a Symbol object.

Property value

A Long value that specifies the 0-based index of the Multiplexer's fist bit.

Remarks

All Multiplexers contained in a Symbol object have the same start index.

See also

MuxLength Property


MuxValue Property

Applies to: Multiplexer object

Returns the value of the Multiplexer.

Syntax

object.MuxValue

Parameters

object

An expression that evaluates to a Multiplexer object.

Property value

A Long value that specifies the value of the Multiplexer.

Example

The following example retrieves the value of a Multiplexer:

VBScript

Dim v

v = myMultiplexer.MuxValue


Name Property

Applies to: AddIn object, Application object, CallbackLibraryEvent object, Connection object, Document object, Enum object, MessageFilter object, OutputWindowPane object, PCANClient object, Project object, ProjectItem object, Multiplexer object, Signal object, Symbol object, TextDocument object, Variable object

Sets or returns the name of an object.

Syntax

object.Name [=value]

Parameters

object

An expression that evaluates to one of the objects in the Applies To list above.

value

A String value that sets the name of the object.

Property value

A String value that specifies the name of the object.

The following table summarizes the results of using the Name property with the objects in the Applies To list:

Object | Result
AddIn | The name of the Add-in.
Application | The name of the application.
CallbackLibraryEvent | The file name of the Callback Library.
Connection | The name of the connection.
Document | The file name of the current document.
Enum | The name of the enum.
MessageFilter | The name of the message filter.
Multiplexer | The name of the multiplexer.
OutputWindowPane | The label name of the tab.
PCANClient | The name, under which the PCANClient object is registered at a PCAN device.
Project | The name of the project.
ProjectItem | The name of the project item.
Signal | The name of the signal.
Symbol | The name of the symbol.
TextDocument | The file name of the text document, for example "Sample.sym"
Variable | Tthe name of the variable.
Remarks

On file names, the Name property does not return the drive and the folder of the file. To get the drive and directory, use the Path or FullName property.

Only the Name properties of the Connection object, MessageFilter object, PCANClient object, Project object, and Signal object are writable. The Name properties of all other objects are read-only.

Example

The following example retrieves the name of the active document:

VBS Macro

MsgBox ActiveDocument.Name

See also

FullName Property


NetBitRate Property

Applies to: PCANClientConnection object

Returns a PCANBitrate object that describes the bit rate that was defined for a connected PCAN net.

Syntax

object.NetBitRate

Parameters

object

An expression that evaluates to a PCANClientConnection object.

Property value

A PCANBitrate object.

Example

The following example retrieves the bit rate of a connected net:

VBS Macro

Sub NetBitRateExample()

' The first connection in the project must

' be a CAN connection

If Connections(1).Protocol = peProtocolCAN Then

Dim ClientConn, bitrate

Set ClientConn = Connections(1).CommunicationObject

Set bitrate = ClientConn.NetBitRate

' Access the PCANBitrate object here

MsgBox "Bit rate of Net = " & bitrate.AsString

End If

End Sub

See also

NetBitRateText Property

NetBaudRate Property

HardwareBitRate Property


NetBitRateText Property

Applies to: PCANClientConnection object

Returns the bit rate that was defined for the connected PCAN net, as a text.

Syntax

object.NetBitRateText

Parameters

object

An expression that evaluates to a PCANClientConnection object.

Property value

A String that indicates the bit rate that is defined for the connected PCAN net.

You can only retrieve a net's bit rate if the PCANClientConnection object is connected to a PCAN net.

The NetBitRateText property returns the same string as the NetBitRate.AsString property.

Example

The following example retrieves the bit rate of a connected net:

VBS Macro

Sub NetBitRateTextExample()

' The first connection in the project must

' be a CAN connection

If Connections(1).Protocol = peProtocolCAN Then

Dim ClientConn

Set ClientConn = Connections(1).CommunicationObject

MsgBox "Bit rate of Net = " & ClientConn.NetBitRateText

End If

End Sub

See also

NetBitRate Property

HardwareBitRateText Property


NetHandle Property

Applies to: PCANClientConnection object

Returns the handle of the connected PCAN net.

Syntax

object.NetHandle

Parameters

object

An expression that evaluates to a PCANClientConnection object.

Property value

A Long value that specifies the handle of the connected PCAN net.

If the PCANClientConnection object is not connected to a PCAN net, the NetHandle property returns the value 0.

Example

The following example retrieves the handle of a net:

VBS Macro

Sub NetHandleExample()

' The first connection in the project must

' be a CAN connection

If Connections(1).Protocol = peProtocolCAN Then

Dim ClientConn

Set ClientConn = Connections(1).CommunicationObject

MsgBox "Net handle = " & ClientConn.NetHandle

End If

End Sub


NetName Property

Applies to: J1939Node object, PCANClient object

Sets or returns the name of the PCAN net, with which a PCAN client or J1939 node is connected.

Syntax

object.NetName [=value]

Parameters

object

An expression that evaluates to a J1939Node object or a PCANClient object.

value

A String that specifies the new value of the property.

Property value

A String value that specifies the name of a PCAN net.

Example

The following example retrieves the net name of the first connection in the project:

VBS Macro

Sub NetNameExample()

If Connections.Count = 0 Then Exit Sub

Dim conn

Set conn = Connections(1)

Select Case conn.Protocol

Case peProtocolCAN

' Access the PCANClientConnection object

Dim ClientConn

Set ClientConn = conn.CommunicationObject

MsgBox "Net Name: " & ClientConn.NetName

Case peProtocolJ1939

' Access the J1939Node object

Dim node

Set node = conn.CommunicationObject

MsgBox "Net Name: " & node.NetName

End Select

End Sub


_NewEnum Property

Applies to: AddIns collection, Connections collection, Documents collection, Enums collection, J1939Filter object, MessageFilters collection,Multiplexers collection, PCANClientConnections collection, PCANMessages collection, Signals collection, Symbols collection, ReceiveMessages collection, TraceMessages collection, Tracer collection, TransmitMessages collection, VBSMacroFiles collection, Windows collection

References objects in a collection.

Syntax

object._NewEnum

Parameters

object

An expression that evaluates to one of the objects in the Applies To list above.

Remarks

With Visual C++ or Delphi, you can browse a collection to find a particular item by using the _NewEnum property or the Item method. In Visual Basic, you do not need to use the _NewEnum property, because it is automatically used in the implementation of For Each ... Next.

Example

The following example is a Visual C++ code snippet you can insert into an Add-in's command handler method using the ActiveX Template Library. This example uses the _NewEnum property to iterate through all open windows and display their captions in a message box.

Tip: You can iterate through these windows more efficiently by using the Item method of the Windows object.

Visual C++

CComPtr<IDispatch> pDisp;

CComQIPtr<IPEWindows, &IID_IPEWindows> pWindows;

m_pApplication->Get_Windows(&pDisp);

pWindows = pDisp;

pDisp = NULL;

CComPtr<IUnknown> pUnk;

CComQIPtr<IEnumVARIANT, &IID_IEnumVARIANT> pNewEnum;

if (SUCCEEDED(pWindows->Get__NewEnum(&pUnk)) && pUnk != NULL)

{

pNewEnum = pUnk;

VARIANT varWindow;

CString strCaptions;

CComQIPtr<IPEWindow, &IID_IPEWindow> pWindow;

while (pNewEnum->Next(1, &varWindow, NULL) == S_OK)

{

ASSERT (varWindow.vt == VT_DISPATCH);

pWindow = varWindow.pdispVal;

VariantClear(&varWindow);

CComBSTR bstrCaption;

pWindow->Get_Caption(&bstrCaption);

strCaptions += bstrCaption.m_str;

strCaptions += "\n";

}

MessageBox(NULL, (LPSTR)(LPCTSTR) strCaptions,

"Open Windows", MB_OK | MB_ICONINFORMATION | MB_TOPMOST);

}


Next Property

Applies to: Window object

Returns the next window in the tab sequence.

Syntax

object.Next

Parameters

object

An expression that evaluates to a Window object.

Property value

A Window object.

See also

Previous Property


NominalBitrate Property

Applies to: PCANBitrate object

Returns the nominal (arbitration) bit rate of a CAN or CAN FD bit rate.

Syntax

object.NominalBitrate

Parameters

object

An expression that evaluates to a PCANBitrate object.

Property value

A Double value that indicates the nominal bit rate in bits per second.

Example

The following example displays the bit rate of the hardware currently used by the first connection in the project:

VBS Macro

Sub NominalBitrateExample()

' The first connection in the project must

' be a CAN connection

If Connections(1).Protocol = peProtocolCAN Then

Dim ClientConn, bitrate

Set ClientConn = Connections(1).CommunicationObject

Set bitrate = ClientConn.HardwareBitRate

MsgBox "Bit rate: Nominal=" & bitrate.NominalBitrate & _

", Data=" & bitrate.DataBitrate

End If

End Sub

See also

DataBitrate Property


NotificationOnAddressClaiming Property

Applies to: J1939Node object

Sets or returns whether the J1939Node object triggers OnAddressClaiming events during an address claiming process.

Syntax

object.NotificationOnAddressClaiming [=value]

Parameters

object

An expression that evaluates to a J1939Node object.

value

A Boolean that specifies the new value of the property.

Property value

A Boolean value that specifies whether the J1939Node object triggers OnAddressClaiming events during an address claiming process or not. If True, events are triggered. If False (the default), events are not triggered.

Remarks

If activated, OnAddressClaiming events are triggered when the value of the AddressClaimStatus property has changed.


NotificationOnAddressLost Property

Applies to: J1939Node object

Sets or returns whether the J1939Node object triggers OnAddressLost events.

Syntax

object.NotificationOnAddressLost [=value]

Parameters

object

An expression that evaluates to a J1939Node object.

value

A Boolean that specifies the new value of the property.

Property value

A Boolean value that specifies whether the J1939Node object triggers OnAddressLost events. If True, events are triggered. If False (the default), events are not triggered.

Remarks

If activated, an OnAddressLost event is triggered when J1939 node lost its claimed address because another J1939 ECU on the bus with a lower NAME value claimed the same address.


NotificationOnMessageReceived Property

Applies to: J1939Node object

Sets or returns whether the J1939Node object triggers OnMessageReceived events.

Syntax

object.NotificationOnMessageReceived [=value]

Parameters

object

An expression that evaluates to a J1939Node object.

value

A Boolean that specifies the new value of the property.

Property value

A Boolean value that specifies whether the J1939Node object triggers OnMessageReceived. If True, events are triggered. If False (the default), events are not triggered.

Remarks

If activated, OnMessageReceived events are triggered when a message has been put into the receive queue of the J1939Node object.


NotificationOnPropertyChange Property

Applies to: J1939Node object

Sets or returns whether the J1939Node object triggers OnPropertyValueChanged events.

Syntax

object.NotificationOnPropertyChange [=value]

Parameters

object

An expression that evaluates to a J1939Node object.

value

A Boolean that specifies the new value of the property.

Property value

A Boolean value that specifies whether the J1939Node object triggers OnPropertyValueChanged events. If True, events are triggered. If False (the default), events are not triggered.

Remarks

If activated, OnPropertyValueChanged events are triggered whenever any property of a J1939Node object has changed.


Object Property

Applies to: Document object, TextDocument object, Window object

Returns an interface or object that can be accessed by name at run time.

Syntax

object.Object

Parameters

object

An expression that evaluates to one of the objects in the Applies To list above.

Property value

An extensibility tool object represented by the window or document.

Example

The following example shows the number of panes in the output window:

VBS Macro

Sub ObjectExample()

Dim win

Set win = Windows(peWindowKindOutput)

Dim OW

Set OW = win.Object

MsgBox "Number of panes: " & OW.OutputWindowPanes.Count

End Sub

See also

ObjectKind Property


ObjectKind Property

Applies to: Window object

Returns the type of the Window.Object object, which is a GUID string representing the tool contained in the window.

Syntax

object.ObjectKind

Parameters

object

An expression that evaluates to a Window object.

Property value

A String value that represents the type of the Window.Object object.

The GUID can be used as index of the Item method of the Window object.

Example

The following example displays the caption and the ObjectKind for every window in the Windows collection:

VBS Macro

Sub ObjectKindExample()

Dim win

Dim str

For Each win In Windows

str = str & win.Caption

str = str & " ObjectKind: " & win.ObjectKind & vbCrLf

MsgBox str

End Sub


Offset Property

Applies to: Variable object

Returns the offset that was defined for the for the variable to transform its value from a raw value into a physical value.

Syntax

object.Offset

Parameters

object

An expression that evaluates to a Variable object.

Property value

A Double value representing the offset that was defined for the variable to transform its value from a raw value into a physical value.

Example

The following example retrieves the offset value of a variable:

VBScript

Dim offset

offset = myVar.Offset

See also

Factor Property


Originator Property

Applies to: J1939Msg object, J1939RcvMsg object

Sets or returns the source address of the originator of the message.

Syntax

object.Originator [=value]

Parameters

object

An expression that evaluates to a J1939Msg object or a J1939RcvMsg object.

value

A Byte that sets the new value of the property.

Property value

A Byte value that specifies the source address of the originator of the message.

Remarks

The Originator property of the J1939RcvMsg object is read-only.


OutputFormat Property

Applies to: Variable object

Returns the output format of a Variable.

Syntax

object.OutputFormat

Parameters

object

An expression that evaluates to a Variable object.

Property value

A PeOutputFormat enum value. The following values are possible:

  • peOutputDec: The value is displayed decimally.

  • peOutputHex: The value is displayed hexadecimally.

  • peOutputBin: The value is displayed binary.

Example

The following example displays the output format of the Variable "Speed":

VBS Macro

Sub OutputFormatExample()

' Open and apply the Symbols file "Sample.sym"

' before running this macro

Dim symbols, v

Set symbols = SymbolsManager("Sample")

Set v = symbols("RcvSymbol").DefaultMultiplexer.Variables("Speed")

Select Case v.OutputFormat

Case peOutputDec

MsgBox "Decimal display"

Case peOutputHex

MsgBox "Hexadecimal display"

Case peOutputBin

MsgBox "Binary display"

End Select

End Sub


OutputWindowPanes Property

Applies to: OutputWindow object

Returns the OutputWindowPanes collection for the object.

Syntax

object.OutputWindowPanes

Parameters

object

An expression that evaluates to an OutputWindow object.

Property value

An OutputWindowPanes collection.

Example

The following example adds a new pane to the Output window and displays a line of text:

VBS Macro

Sub OutputWindowPanesExample()

' Fetch a handle for the output window tool

Dim win

Set win = Windows(peWindowKindOutput)

' Handles for the output window itself and its tabs

Dim OW

Set OW = win.Object

' Create a new tab

Dim OWp

Set OWp = OW.OutputWindowPanes.Add("New page")

' Add a line of text to the new page

OWp.OutputString("Some text")

End Sub


Overtype Property

Applies to: TextEditor object

Sets or returns whether the editor is in Overtype mode.

Syntax

object.Overtype [=boolean]

Parameters

object

An expression that evaluates to a TextEditor object.

boolean

A Boolean that specifies the new value of the property.

Property value

A Boolean value that specifies whether the editor is in Overtype mode. If True, the editor is in Overtype mode. If False, the editor is in Insert mode.

Remarks

By default, the editor is in Insert mode.

Example

The following example changes the editor mode from Insert to Overtype:

VBScript

TextEditor.Overtype = True


PacksCount Property

Applies to: J1939Msg object, J1939RcvMsg object

Returns the number of packages in which the data of this message is distributed.

Syntax

object.PacksCount

Parameters

object

An expression that evaluates to a J1939Msg object or a J1939RcvMsg object.

Property value

A Long value that indicates the number of packages in which the data of this message is distributed.

See also

PacksCountOnReadSessions Property

PacksCountOnWriteSessions Property


PacksCountOnReadSessions Property

Applies to: J1939Node object

Sets or returns the maximum number of large message data packets cleared to send in a TPCM.CTS message.

Syntax

object.PacksCountOnReadSessions [=value]

Parameters

object

An expression that evaluates to a J1939Node object.

value

A Byte that specifies the new value of the property.

Property value

A Byte value that specifies the maximum number of large message data packets cleared to send.

Remarks

The actual number of packets cleared to send in a TPCM.CTS message will never be larger than the requested number or packets from a received TPCM.RTS message.

See also

ReCTSsCountOnReadSessions Property


PacksCountOnWriteSessions Property

Applies to: J1939Node object

Sets or returns a value that limits the number of requested packets that can be sent by the originator in response to one CTS.

Syntax

object.PacksCountOnWriteSessions [=value]

Parameters

object

An expression that evaluates to a J1939Node object.

value

A Byte that specifies the new value of the property.

Property value

A Byte value that limits the number of requested packets that can be sent by the originator in response to one CTS.

Remarks

If the responder complies with the limit, the responder ensures that the originator can re-transmit packets that the responder has not received correctly for whatever reason.

See also

RetriesCountOnWriteSessions Property


ParameterString Property

Applies to: PCANBitrate object

Returns a string with the individual parameters of the bit rate.

Syntax

object.ParameterString

Parameters

object

An expression that evaluates to a PCANBitrate object.

Property value

A String value with the comma-separated individual bit rate parameters in the form parameter1=value, parameter2=value, ...

For example: "f_clock=80000000, nom_brp=10, nom_tseg1=5, nom_tseg2=2, nom_sjw=2, data_brp=4, data_tseg1=7, data_tseg2=2, data_sjw=1".

Remarks

Depending on whether the bit rate represents a CAN or a CAN FD bit rate, the returned string only contains the parameters that are necessary to represent the individual bit rate.

Example

The following example displays the parameter string of the hardware bit rate currently used by the first connection in the project:

VBS Macro

Sub ClockExample()

' The first connection in the project must

' be a CAN connection

If Connections(1).Protocol = peProtocolCAN Then

Dim ClientConn, bitrate

Set ClientConn = Connections(1).CommunicationObject

Set bitrate = ClientConn.HardwareBitRate

MsgBox "Parameters of bit rate = " & bitrate.ParameterString

End If

End Sub


Parent Property

Applies to: AddIns collection, Connections collection, Documents collection, Enums collection, J1939Filters collection, MessageFilters collection,Multiplexer object, Multiplexers collection, OutputWindow object, OutputWindowPanes collection, PCANBitrate object, PCANClientConnections collection, PCANMessages collection, Project object, ReceiveMessages collection, ReceiveTransmitWindow object, Signals collection, Symbols collection, TextEditor object, TextSelection object, TextWindow object, TraceMessages collection, Tracer object, TraceWindow object, TransmitMessages collection, TransmitWindow object, Variable object, Variables collection, VBSMacroFiles collection, Windows collection

Returns the immediate parent object of a given object.

Syntax

object.Parent

Parameters

object

An expression that evaluates to one of the objects in the Applies To list above.

Property value

Returns the immediate parent to the object or collection. If you want to get the containing collection, then use the Collection property.

The Parent property's type depends on the object you access the property from (see the table below). For example, the Parent property of the TextSelection object has the TextDocument type.

The following table shows the parent of each object:

Object | Parent Object
AddIns | Application
Connections | Application
Documents | Application
Enums | SymbolsManager
J1939Filters | J1939Node
MessageFilters | Application
Multiplexer | Symbol
Multiplexers | Symbol
OutputWindow | Application
OutputWindowPanes | OutputWindow
PCANBitrate | PCANClientConnection
PCANClientConnection | PCANClient
PCANMessages | PCANClient
Project | Application
ReceiveMessages | Connection
ReceiveTransmitWindow | Application
Signals | Application
Symbols | SymbolsManager
SymbolsManager | Application
TextEditor | Application
TextSelection | TextDocument
TextWindow | TextDocument
Tracer | Application
TraceMessages | Application
TraceWindow | Document
TransmitMessages | Connection or Document
Variable | Multiplexer
Variables | Multiplexer
VBSMacroFiles | Application
Windows | Application
Example
VBScript

Sub ParentExample()

Dim WWin

Set WWin = Windows(peWindowKindWatch)

Dim watch

Set watch = WWin.Object

Dim win

Set win = watch.Parent

MsgBox "ObjectKind of the window: " & win.ObjectKind

End Sub


Path Property

Applies to: Application object, Document object, Project object, TextDocument object

Returns the path to an object.

Syntax

object.Path

Parameters

object

An expression that evaluates to one of the objects in the Applies To list above.

Property value

A String value that indicates the path to an object. The path never ends with a backslash ("\") unless the path has the format "C:\".

The Path property does not return the file name and the file name extension of an object. To get the file name and extension, use the Name property or FullName property.

The following table summarizes the results that are obtained when using the Path property of the objects mentioned above:

Object | Results
Application | Returns the path of the PCAN-Explorer program, e.g. "C:\Program Files\PCAN-Explorer 5".
Document TextDocument | Returns the path of the file, that contains the document, e.g. "C:\Users\<User Name>\Documents\PCAN-Explorer\Symbols".
Project | The path of the current project, e.g. "C:\Users\<User Name>\Documents\PCAN-Explorer\Projects\My Project".
Example

The following example retrieves the path of the active document:

VBScript

Sub PathExample()

Dim PathString

PathString = ActiveDocument.Path

' Access PathString here

End Sub


PGN Property

Applies to: J1939Filter object, J1939Msg object, J1939RcvMsg object, MessageFilterItem object, ReceiveEvent object, ReceiveMessage object, Symbol object, TraceMessage object, TransmitEvent object, TransmitMessage object

Sets or returns a J1939 Parameter Group Number.

Syntax

object.PGN [=value]

Parameters

object

An expression that evaluates to one of the objects in the Applies To list above.

value

A Long that specifies the new value of the property.

Property value

A Long value that specifies a Parameter Group Number.

Remarks

The PGN properties of the J1939Filter, J1939RcvMsg, ReceiveEvent, Symbol, and TransmitEvent objects are read-only.

For the J1939Filter object, the PGN property returns the PGN attribute of the filter. If the Flags property includes the tfmPGN flag, all J1939 messages having the specified PGN can pass the filter.

For the MessageFilterItem object, the J1939PGN property only has an effect if the Type property is set to peFilterItemJ1939 and the J1939FilterFlags property includes the peJ1939PGN flag.


PGNsToRejectOnRTS Property

Applies to: J1939Node object

Sets or returns a set of PGNs that are rejected by sending TPCM.ConnAbort when a TPCM.RTS message is received for one of them.

Syntax

object.PGNsToRejectOnRTS [=value]

Parameters

object

An expression that evaluates to a J1939Node object.

value

A String that specifies the new comma-separated set of PGNs to be rejected.

Property value

A String that specifies the comma-separated set of PGNs. For example: "64489, 0xFD78, 7000h, 30000-31000, 0x2000-0x2100".


PlaybackPosition Property

Applies to: Tracer object

Returns the current playback position of a tracer.

Syntax

object.PlaybackPosition

Parameters

object

An expression that evaluates to a Tracer object.

Property value

A Long value that indicates the current playback position, which is an index in the range 0 to EntryCount-1.

See also

EntryCount Property


PlaybackRepeat Property

Applies to: Tracer object

Determines whether trace playback restarts from the beginning when the end of the trace buffer or file is reached.

Syntax

object.PlaybackRepeat [=value]

Parameters

object

An expression that evaluates to a Tracer object.

value

A Boolean that sets the new value of the property.

Property value

A Boolean value that determines whether trace playback restarts from the beginning when the end of the trace buffer or file is reached.

Example

The following example configures the active tracer for repeated playback.

VBS Macro

Sub PlaybackRepeatExample()

Dim tracer

If ActiveWindow.Kind = peDocumentKindTrace Then

Set tracer = ActiveWindow.Object.Tracer

tracer.PlaybackRepeat = True

tracer.Play

End If

End Sub

See also

PlaybackRepeatCount Property

PlaybackRepeatPause Property


PlaybackRepeatCount Property

Applies to: Tracer object

During playback, determines the number of playback cycles before playback is stopped.

Syntax

object.PlaybackRepeatCount [=value]

Parameters

object

An expression that evaluates to a Tracer object.

value

A Long that sets the new value of the property.

Property value

A Long value that determines the number of playback cycles before playback is stopped. The value 0 means playback is repeated endlessly, as long as the PlaybackRepeat property has the value True.

See also

PlaybackRepeat Property

PlaybackRepeatPause Property


PlaybackRepeatPause Property

Applies to: Tracer object

Determines the time delay before playback of a trace buffer or file is repeated.

Syntax

object.PlaybackRepeatPause [=value]

Parameters

object

An expression that evaluates to a Tracer object.

value

A Long that sets the new value of the property.

Property value

A Long value that determines the time delay before playback is repeated when the end of the trace buffer or file is reached during playback. The time delay is specified in milliseconds.

See also

PlaybackRepeat Property

PlaybackRepeatCount Property


PostLoadCommand Property

Applies to: Project object

Sets or returns the name of a command that is executed after a project is loaded.

Syntax

object.PostLoadCommand [=command]

Parameters

object

An expression that evaluates to one a Project object.

command

A String that sets the new value of the property.

Property value

A String value that specifies the name of a PCAN-Explorer command that is executed after a project is loaded.


PreferredAddress Property

Applies to: J1939Node object

Sets or returns the address that the J1939Node object tries to claim when the ClaimAddress method is called.

Syntax

object.PreferredAddress [=value]

Parameters

object

An expression that evaluates to a J1939Node object.

value

A Byte that specifies the new value of the property.

Property value

A Byte value that represents the address (0-253) that the node tries to claim when the ClaimAddress method is called. Null address and Global address cannot be claimed by devices.

See also

ClaimAddress Method

ClaimedAddress Property

ReleaseAddress Method

UseAddressingProtocol Property


Previous Property

Applies to: Window object

Returns the previous window in the tab sequence.

Syntax

object.Previous

Parameters

object

An expression that evaluates to a Window object.

Property value

A Window object.

See also

Next Property


Priority Property

Applies to: J1939Filter object, J1939Msg object, J1939RcvMsg object, MessageFilterItem object, ReceiveEvent object, ReceiveMessage object, Symbol object, TraceMessage object, TransmitEvent object, TransmitMessage object

Sets or returns a J1939 Priority.

Syntax

object.Priority [=value]

Parameters

object

An expression that evaluates to one of the objects in the Applies To list above.

value

A Byte that specifies the new value of the property.

Property value

A Byte value that specifies a Priority (0-7).

Remarks

The Priority properties of the J1939Filter, J1939RcvMsg, ReceiveEvent, Symbol, and TransmitEvent objects are read-only.

For the J1939Filter object, the Priority property returns the Priority attribute of the filter. If the Flags property includes the tfmPriority flag, all J1939 messages having the specified Priority can pass the filter.

For the MessageFilterItem object, the J1939Priority property only has an effect if the Type property is set to peFilterItemJ1939 and the J1939FilterFlags property includes the peJ1939Priority flag.


ProgID Property

Applies to: AddIn object

Returns the ProgID based on the Add-in's registry entry.

Syntax

object.ProgID

Parameters

object

An expression that evaluates to a AddIn object.

Return value

The ProgID property returns a String representing the ProgID of the Add-in.

Example

The following example lists all registered Add-ins and their ProgIDs:

VBS Macro

Sub IsSavedExample()

Dim objAddIn, strMsg

For Each objAddIn In AddIns

strMsg = strMsg & objAddIn.Name & " " & _

objAdd.ProgID & vbCrLf

Next

MsgBox strMsg

End Sub


Project Property

Applies to: ProjectItem object, ProjectItems collection

Returns the Project object in which the object or collection is included.

Syntax

object.Project

Parameters

object

An expression that evaluates to a ProjectItem object or a ProjectItems collection.

Property value

A Project object.


ProjectItems Property

Applies to: Project object, ProjectItem object

Returns a ProjectItems collection for the object.

Syntax

object.ProjectItems

Parameters

object

An expression that evaluates to a ProjectItem object.

Property value

A ProjectItems collection containing project items that may be hierarchically below the project or project item.

Example

The following example lists all files of the current project in the Output window, on the Macro tab:

VBS Macro

Sub ProjectItemsExample()

OutputItems ActiveProject.ProjectItems, ""

End Sub

Sub OutputItems(items, indent)

Dim i, item

For i = 1 To items.Count

Set item = items(i)

If item.Kind = peProjectItemKindFile Then _

PrintToOutputWindow indent & item.Object.RelativePath

If Not (item.ProjectItems Is Nothing) Then

' This item contains child items

OutputItems item.ProjectItems, indent & " "

End If

Next

End Sub


Protocol Property

Applies to: Connection object

Sets or returns the protocol that the connection uses.

Syntax

object.Protocol [=value]

Parameters

object

An expression that evaluates to a Connection object.

value

A PeProtocol enum value that sets the new value of the property.

Property value

A PeProtocol enum value that specifies the protocol that the connection uses to communicate on the CAN bus.

  • peProtocolCAN (0): Raw CAN, no higher protocol is used.

  • peProtocolJ1939 (1): The J1939 protocol.


Properties Q-T

The following table contains all properties beginning with letters Q to T:

Property | Description
QualifiedName | Returns a variable's qualified name.
RcvEventHandle | Sets or returns an event handle that the object uses to notify waiting threads on a received message.
RcvNet | Returns the handle of the PCAN net from which the CAN message has been received.
ReassembleIncomingPackets | Sets or returns whether incoming large message packets are assembled to complete messages.
ReceiveMessages | Returns a ReceiveMessages collection.
Receiving | Sets or returns whether a J1939Node object receives messages.
ReCTSsCountOnReadSessions | Sets or returns the maximum number of Re-CTS during a read session.
RegistryRoot | Returns a string with the path to the root of the PCAN-Explorer registry settings.
ResetOnBusOff | Sets or returns whether the object automatically resets the CAN controller when a bus-off state is detected.
Responder | Sets or returns the destination address of the message.
RetriesCountOnWriteSessions | Sets or returns the maximum number of RTS-retries during a write session.
RTREnabled | Sets or returns whether RTR Frames can pass through a MessageFilterItem object if the filter item operates in Options mode.
RunningMax | Returns the highest value a Signal has reached.
RunningMaxTime | Returns the time at which a Signal reached its highest value.
RunningMean | Returns the arithmetic mean of a Signal's value.
RunningMin | Returns the lowest value a Signal has reached.
RunningMinTime | Returns the time at which a Signal reached its lowest value.
Selection | Returns the TextSelection object, which represents the selected text.
SelfReceive | Sets or returns whether PCAN-Explorer receives CAN messages transmitted by itself.
ShortName | Returns the short name of a signal, in contrast to the fully qualified name.
ShowAbsoluteTime | Sets or returns whether a tracer shows absolute or relative timestamps.
ShowDLC | Determines whether the data length in a trace window is displayed as a Data Length Code or as the number of data bytes.
Signal | Returns the Signal object that is associated with a variable.
Signals | Returns the Signals collection.
Source | Returns the object that servers as data source of a Signal object.
SourceAddress | Sets or returns a J1939 Source Address.
SourceKind | Returns the type of the Signal.Source object, which is a GUID string representing the object.
SplitState | Sets or returns the visual splitting of the Receive/Transmit window.
SPN | Returns a J1939 Suspect Parameter Number.
StartTime | Returns the start time of a tracer.
StatisticsEnabled | Activates or deactivates the calculation of statistical data for a Signal.
StringValue | Sets or returns a signal's value as string.
Symbol | Returns the Symbol object that is associated with a CAN message.
SymbolName | Returns the name of the symbol associated with the CAN message for which a Callback Library event was triggered.
Symbols | Returns the Symbols object.
SymbolsFileName | Sets or returns the name of a Symbols file that is associated with the connection.
SymbolsManager | Returns the SymbolsManager collection.
TabSize | Sets or returns the number of columns in a tab character.
Text | Sets or returns the text in a selection.
TextEditor | Returns the TextEditor object.
TimeFormat | Sets or returns a string that defines how absolute timestamps are displayed in the various windows of PCAN-Explorer.
Timeout | Returns the timeout time value that was defined for a Multiplexer.
Timestamp | Returns the timestamp of a message.
TimestampAbs | Returns the absolute timestamp of a CAN message.
TimestampAbsString | Returns the absolute timestamp of a CAN message as text.
TimestampFormat | Sets or returns the format that is used to display timestamps in a trace window.
TimingErrorCount | Returns the number of timing errors that have occurred for a received CAN message.
Title | Returns the title that was defined for a Symbols file with a global Title parameter.
Top | Sets or returns the y-coordinate of a window's upper edge.
Tracer | Returns the Tracer object contained in a trace window.
TraceState | Returns the current operating state of the tracer.
TransmitMessages | Returns a TransmitMessages collection.
Type [Variation 1] | Returns a string describing the type of the document or window.
Type [Variation 2] | Returns the type of a symbol.
Type [Variation 3] | Returns the type of a Message Filter item.

See also

Properties A-F

Properties G-K

Properties L-P

Properties U-Z


QualifiedName Property

Applies to: Variable object

Returns a variable's qualified name.

Syntax

object.QualifiedName

Parameters

object

An expression that evaluates to a Variable object.

Property value

A String value that represents a fully qualified variable name in the form SymbolName.MultiplexerName.VariableName.

If no multiplexer is defined for the parent symbol, the qualified name is returned in the form SymbolName.VariableName.

Example

The following example retrieves the qualified name of a variable:

VBS Macro

Sub QualifiedNameExample()

Dim sig, v

Set sig = Signals("Speed")

' The source of this signal is a variable

Set v = sig.Source

MsgBox v.QualifiedName,,"Qualified Name"

End Sub

See also

Multiplexer Object

Variable Object


RcvEventHandle Property

Applies to: J1939Node object, PCANClient object

Sets or returns an event handle that the object uses to notify waiting threads on a received message.

Syntax

object.RcvEventHandle [=value]

Parameters

object

An expression that evaluates to one of the objects in the Applies To list above.

value

A Long that specifies the new value of the property.

Property value

A Long value that specifies the event handle that the object uses to notify waiting threads on a received message.


RcvNet Property

Applies to: PCANMessage object, ReceiveEvent object, ReceiveMessage object

Returns the handle of the PCAN net from which the CAN message has been received.

Syntax

object.RcvNet

Parameters

object

An expression that evaluates to one of the objects in the Applies To list above.

Property value

A Long value that represents the handle of a PCAN net.

Example

The following example accesses the RcvNet property of a PCANMessage object:

VBScript

If myMessage.Read Then

h = myMessage.RcvNet

...

End If


ReassembleIncomingPackets Property

Applies to: J1939Node object

Sets or returns whether incoming large message packets are assembled to complete messages.

Syntax

object.ReassembleIncomingPackets [=value]

Parameters

object

An expression that evaluates to a J1939Node object.

value

A Boolean that specifies the new value of the property.

Property value

A Boolean value that specifies whether the J1939 node object performs the task of assembling complete messages from received packets.


ReceiveMessages Property

Applies to: Application object, Connections collection, ReceiveTransmitWindow object

Returns a ReceiveMessages collection.

Syntax

object.ReceiveMessages

Parameters

object

An expression that evaluates to the Application object, a Connections collection, or a ReceiveTransmitWindow object.

Property value

A ReceiveMessages collection, which represents a collection of CAN messages. Each CAN message in the collection is represented by a ReceiveMessage object.

Example

The following example accesses the ReceiveMessages collection and counts all received messages:

VBS Macro

Sub ReceiveMessagesExample()

Dim msg, cnt

cnt = 0

For Each msg In ReceiveMessages

cnt = cnt + msg.EventCount

Next

MsgBox "Number of received messages: " & cnt

End Sub


Receiving Property

Applies to: J1939Node object

Sets or returns whether the J1939Node object receives messages.

Syntax

object.Receiving [=value]

Parameters

object

An expression that evaluates to a J1939Node object.

value

A Boolean that specifies the new value of the property.

Property value

A Boolean value that specifies whether the object receives messages or not. If True (the default), the object receives messages. If False, the object does not receive messages.

Remarks

The Receiving property can be used to disable receiving of messages temporarily without changing the filter settings.


ReCTSsCountOnReadSessions Property

Applies to: J1939Node object

Sets or returns the maximum number of Re-CTS during a read session.

Syntax

object.ReCTSsCountOnReadSessions [=value]

Parameters

object

An expression that evaluates to a J1939Node object.

value

A Byte that specifies the new value of the property.

Property value

A Byte value that specifies the maximum number of Re-CTS during a read session.

Remarks

After the responder has transmitted a CTS, and no data packet (TPDT) is received from the originator within a timeout of 1250 ms, the responder sends again a CTS. When the number of these re-sent CTS reaches the number of specified Re-CTS, the responder aborts the session when the next timeout occurs by sending a TPCM.ConnAbort.

See also

PacksCountOnReadSessions Property


RegistryRoot Property

Applies to: Application object

Returns a string with the path to the root of the PCAN-Explorer registry settings.

Syntax

object.RegistryRoot

Parameters

object

An expression that evaluates to an Application object.

Property value

A String value representing a registry path.

Typically, the registry root of PCAN-Explorer 5 is HKCU\Software\PEAK-System\PCAN-Explorer\5.0\

Example

The following example displays the registry path for the PCAN-Explorer in a message box:

VBS Macro

MsgBox RegistryRoot


ResetOnBusOff Property

Applies to: J1939Node object

Sets or returns whether the object automatically resets the CAN controller when a bus-off state is detected.

Syntax

object.ResetOnBusOff [=value]

Parameters

object

An expression that evaluates to a J1939Node object.

value

A Boolean that specifies the new value of the property.

Property value

A Boolean value that specifies whether the object automatically resets the CAN controller when a bus-off state is detected. If True, the object automatically resets the CAN controller. If False (the default), the object does not automatically reset the CAN controller.

Remarks

Since no communication is possible in a bus-off state, it is useful to let the node catch this event automatically and reset the CAN controller, to avoid extra handling of this problem by a macro or application.


Responder Property

Applies to: J1939Msg object, J1939RcvMsg object

Sets or returns the destination address of the message.

Syntax

object.Responder [=value]

Parameters

object

An expression that evaluates to a J1939Msg object or a J1939RcvMsg object.

value

A Byte that sets the new value of the property.

Property value

A Byte value that specifies the destination address of the message.

Remarks

The Responder property of the J1939RcvMsg object is read-only.

The Responder property ins only relevant for PDU1 messages, or for PDU2 messages that have more than 8 data bytes, which are transmitted using the transport protocol.


RetriesCountOnWriteSessions Property

Applies to: J1939Node object

Sets or returns the maximum number of RTS-retries during a write session.

Syntax

object.RetriesCountOnWriteSessions [=value]

Parameters

object

An expression that evaluates to a J1939Node object.

value

A Byte that specifies the new value of the property.

Property value

A Byte value that specifies the maximum number of RTS-retries during a write session.

Remarks

After the originator has transmitted the number of data packets that were cleared to send by the last received CTS, the originator sends again an RTS to request the next data transfer. If the responder does not answer with a CTS within a timeout of 1250 ms, the originator issues again an RTS. When the number of these re-sent RTR reaches the number of specified Retries, the originator aborts the session when the next timeout occurs by sending a TPCM.ConnAbort.

See also

PacksCountOnWriteSessions Property


RTREnabled Property

Applies to: MessageFilterItem object

Sets or returns whether RTR Frames can pass through the MessageFilterItem object if the filter item operates in Options mode.

Syntax

object.RTREnabled [=value]

Parameters

object

An expression that evaluates to a MessageFilterItem object.

value

A Boolean value that specifies the new value of the property.

Property value

A Boolean value that specifies whether RTR Frames (Remote Transmission Requests) can pass through the filter item. If True, RTR Frames can pass through the filter item. If False, RTR Frames are blocked by the filter item (the default).

Remarks

The RTREnabled property only has an effect, if the Type property of the MessageFilterItem object is set to peFilterItemOptions.

See also

ErrorFramesEnabled Property

ErrorWarningsEnabled Property

Type Property


RunningMax Property

Applies to: Signal object

Returns the highest value the Signal has reached.

Syntax

object.RunningMax

Parameters

object

An expression that evaluates to a Signal object.

Property value

A Double value that indicates the highest value the Signal has reached.

The RunningMax property of a Signal that has the data type peDataTypeString always returns 0.

Remarks

A Signal stores its maximum value only if the StatisticsEnabled property is set to True.

Example

The following example displays the highest value of the signal "Speed":

VBS Macro

Sub RunningMaxExample()

Dim sig

Set sig = Signals("RcvSymbol.Mux1.Speed")

MsgBox "Speed.RunningMax = " & sig.RunningMax

End Sub

See also

RunningMaxTime Property

RunningMean Property

RunningMin Property

RunningMinTime Property

StatisticsEnabled Property


RunningMaxTime Property

Applies to: Signal object

Returns the time at which the Signal reached its highest value.

Syntax

object.RunningMaxTime

Parameters

object

An expression that evaluates to a Signal object.

Property value

A DATE value that indicates the time at which the Signal reached its highest value, which is stored in the RunningMax property.

The RunningMaxTime property of a Signal that has the data type peDataTypeString always returns 0.

Remarks

A Signal stores the time of its highest value only if the StatisticsEnabled property is set to True.

Example

The following example displays the time at which the signal "Speed" reached its highest value:

VBS Macro

Sub RunningMaxTimeExample()

Dim sig

Set sig = Signals("RcvSymbol.Mux1.Speed")

MsgBox "Speed.RunningMaxTime = " & sig.RunningMaxTime

End Sub

See also

RunningMax Property

RunningMean Property

RunningMin Property

RunningMinTime Property

StatisticsEnabled Property


RunningMean Property

Applies to: Signal object

Returns the arithmetic mean of the Signal's value.

Syntax

object.RunningMean

Parameters

object

An expression that evaluates to a Signal object.

Property value

A Double value that indicates the arithmetic mean of the Signal's value.

The RunningMean property of a Signal that has the data type peDataTypeString always returns 0.

Remarks

A Signal calculates its arithmetic mean only if the StatisticsEnabled property is set to True.

Example

The following example displays the arithmetic mean of the signal "Speed":

VBS Macro

Sub RunningMeanExample()

Dim sig

Set sig = Signals("RcvSymbol.Mux1.Speed")

MsgBox "Speed.RunningMean = " & sig.RunningMean

End Sub

See also

RunningMax Property

RunningMaxTime Property

RunningMin Property

RunningMinTime Property

StatisticsEnabled Property


RunningMin Property

Applies to: Signal object

Returns the lowest value the Signal has reached.

Syntax

object.RunningMin

Parameters

object

An expression that evaluates to a Signal object.

Property value

A Double value that indicates the lowest value the Signal has reached.

The RunningMin property of a Signal that has the data type peDataTypeString always returns 0.

Remarks

A Signal stores its lowest value only if the StatisticsEnabled property is set to True.

Example

The following example displays the lowest value of the signal "Speed":

VBS Macro

Sub RunningMinExample()

Dim sig

Set sig = Signals("RcvSymbol.Mux1.Speed")

MsgBox "Speed.RunningMin = " & sig.RunningMin

End Sub

See also

RunningMax Property

RunningMaxTime Property

RunningMean Property

RunningMinTime Property

StatisticsEnabled Property


RunningMinTime Property

Applies to: Signal object

Returns the time at which the Signal reached its lowest value.

Syntax

object.RunningMinTime

Parameters

object

An expression that evaluates to a Signal object.

Property value

A DATE value that indicates the time at which the Signal reached its lowest value, which is stored in the RunningMin property.

The RunningMinTime property of a Signals that has the data type peDataTypeString always returns 0.

Remarks

A Signal stores the time of its lowest value only if the StatisticsEnabled property is set to True.

Example

The following example displays the time at which the signal "Speed" reached its lowest value:

VBS Macro

Sub RunningMinTimeExample()

Dim sig

Set sig = Signals("RcvSymbol.Mux1.Speed")

MsgBox "Speed.RunningMinTime = " & sig.RunningMinTime

End Sub

See also

RunningMax Property

RunningMaxTime Property

RunningMean Property

RunningMin Property

StatisticsEnabled Property


Selection Property

Applies to: TextDocument object, TextWindow object

Returns the TextSelection object, which represents the selected text.

Syntax

object.Selection

Parameters

object

An expression that evaluates to a TextDocument object or a TextWindow object.

Property value

A TextSelection object.

For the TextDocument object, the Selection property gets the object representing the text selected in a document's active window.

For the TextWindow object, the Selection property gets the object representing the text selected in the text window.

Example

The following example deletes the selected text in a text document:

VBS Macro

Sub SelectionExample()

   If ActiveDocument.Kind = peDocumentKindText Then

      ActiveDocument.Selection.Delete

   End If

End Sub


SelfReceive Property

Applies to: PCANClient object

Sets or returns whether a PCAN client receives CAN messages transmitted by itself.

Syntax

object.SelfReceive [=boolean]

Parameters

object

An expression that evaluates to a PCANClient object.

boolean

A Boolean that sets the new value of the property.

Property value

A Boolean value that specifies whether the PCAN client receives CAN messages transmitted by itself. If True, the PCAN client receives messages transmitted by itself. If False (the default), the PCAN client does not receive messages transmitted by itself.

Example

The following example activates the reception of self-transmitted messages for a PCAN client:

VBS Macro

Sub SelfReceiveExample()

Dim client, conn

Set client = CreateObject("PCAN4.PCANClient")

client.Device = "pcan_usb"

client.Name = "Macro"

client.SelfReceive = True

Set conn = client.Connections.Add("TestNet")

If conn.IsConnected Then

' Open the filter so that the self-received

' message won't be blocked

conn.RegisterMsg &H100, &H100, False, False

Dim msg

Set msg = client.Messages.Add

msg.ID = &H100

msg.DLC = 2

msg.Data(0)= 1

msg.Data(1)= 2

msg.Write conn, 0

If msg.Read Then _

MsgBox "Self-receive Message: " & Hex(msg.ID)

End If

End Sub


ShortName Property

Applies to: Signal object

Returns the short name of a signal, in contrast to the fully qualified name.

Syntax

object.ShortName

Parameters

object

An expression that evaluates to a Signal object.

Property value

A String value that indicates the short name of the signal. If the fully qualified name of a signal is, for example, "Symbol.Multiplexer.Name", then the short name of the signal is only "Name".

Example

The following example displays the fully qualified name and the short name of the signal "Speed":

VBS Macro

Sub ShortNameExample()

Dim sig

Set sig = Signals("Speed")

MsgBox sig.Name & vbCrLf & sig.ShortName

End Sub

See also

Name Property


ShowAbsoluteTime Property

Applies to: Tracer object

Sets or returns whether a tracer shows absolute or relative timestamps.

Syntax

object.ShowAbsoluteTime [=boolean]

Parameters

object

An expression that evaluates to a Tracer object.

boolean

A Boolean that sets the new value of the property.

Property value

A Boolean value that specifies whether the tracer shows absolute or relative timestamps. If True, the tracer shows absolute timestamps. If False, the tracer shows relative timestamps.

Remarks

This property is deprecated. Use the TimestampFormat property instead.

Example

The following example toggles the value of the ShowAbsoluteTime property of the tracer in the foreground:

VBS Macro

Sub ShowAbsoluteTimeExample()

   If ActiveDocument.Kind = peDocumentKindTrace Then

      Dim tracer

      Set tracer = ActiveWindow.Object.Tracer

      tracer.ShowAbsoluteTime = Not tracer.ShowAbsoluteTime

   End If

End Sub

See also

TimestampFormat Property


ShowDLC Property

Applies to: Tracer object

Determines whether the data length in a trace window is displayed as a Data Length Code or as the number of data bytes.

Syntax

object.ShowDLC [=value]

Parameters

object

An expression that evaluates to a Tracer object.

value

A Boolean that sets the new value of the property.

Property value

A Boolean the data length in a trace window is displayed as a Data Length Code or as the number of data bytes. If True, the tracer shows Data Length Codes. If False, the tracer shows the number of data bytes.


Signal Property

Applies to: Variable object

Returns the Signal object that is associated with the variable.

Syntax

object.Signal

Parameters

object

An expression that evaluates to a Variable object.

Property value

A Signal object.

Example

The following example retrieves the Signal object of a Variable and displays its name:

VBS Macro

Sub SignalExample()

' Open and apply the Symbols file "Sample.sym" before

' running this macro

Dim symbols, v

Set symbols = SymbolsManager("Sample")

Set v = symbols("RcvSymbol").DefaultMultiplexer.Variables("Speed")

Dim sig

Set sig = v.Signal

MsgBox sig.Name

End Sub


Signals Property

Applies to: Application object

Returns the Signals collection.

Syntax

object.Signals

Parameters

object

An expression that evaluates to an Application object.

Property value

A Signals collection that represents the collection of all signals in PCAN-Explorer. Each signal in the collection is represented by a Signal object.

Example

The following example accesses the Signals collection:

VBScript

MsgBox Signals.Count


Source Property

Applies to: Signal object

Returns the object that servers as the Signal's data source.

Syntax

object.Source

Parameters

object

An expression that evaluates to a Signal object.

Property value

An object that serves as the Signal's data source, e.g. a Variable object. If the Signal is a virtual Signal, the Source property returns the value Nothing (C/C++: NULL).

Example

The following example shows the qualified name of the Variable that serves as the Signal's data source:

VBS Macro

Sub SourceExample()

Dim src

Set src = Signals("Speed").Source

If Not src Is Nothing Then _

MsgBox src.QualifiedName,,"Macro"

End Sub

See also

Variable Object

SourceKind Property


SourceAddress Property

Applies to: J1939Filter object, MessageFilterItem object, ReceiveEvent object, ReceiveMessage object, Symbol object, TraceMessage object, TransmitEvent object, TransmitMessage object

Sets or returns a J1939 Source Address.

Syntax

object.SourceAddress [=address]

Parameters

object

An expression that evaluates to one of the objects in the Applies To list above.

value

A Byte that specifies the new value of the property.

Property value

A Byte value that specifies a Source Address (0-254).

Remarks

The SourceAddress properties of the J1939Filter, ReceiveEvent, Symbol, and TransmitEvent objects are read-only.

For the J1939Filter object, the SourceAddress property returns the Source Address attribute of the filter. If the Flags property includes the tfmSource flag, all J1939 messages sent from the specified Source Address can pass the filter.

For the MessageFilterItem object, the SourceAddress property only has an effect if the Type property is set to peFilterItemJ1939 and the J1939FilterFlags property includes the peJ1939SourceAddress flag.


SourceKind Property

Applies to: Signal object

Returns the type of the Signal.Source object, which is a GUID string representing the object.

Syntax

object.SourceKind

Parameters

object

An expression that evaluates to a Signal object.

Property value

A String value that represents the kind or type of the Signal.Source object.

The SourceKind property of a virtual signal returns an empty string.

Example

The following example displays the qualified name of the Variable that serves as data source for the Signal "Speed":

VBS Macro

Sub SourceKindExample()

Dim sig

Set sig = Signals("Speed")

If sig.SourceKind = peSourceKindVariable Then _

MsgBox sig.Source.QualifiedName

End Sub

See also

Source Property


SplitState Property

Applies to: ReceiveTransmitWindow object

Sets or returns the visual splitting of the Receive/Transmit window.

Syntax

object.SplitState [=state]

Parameters

object

An expression that evaluates to a ReceiveTransmitWindow object.

state

A PeSplitState enum value that sets the new value of the property.

Property value

A PeSplitState enum value that specifies the state of the window. Possible values are:

  • peSplitStateBothVisible (1): Both the Receive and Transmit lists are visible.

  • peSplitStateRcvMaximized (2): Only the Receive list is visible.

  • peSplitStateXmtMaximized (3): Only the Transmit list is visible.

Example

The following example maximizes the Receive list in the Receive/Transmit window:

VBS Macro

Sub SplitStateExample()

Dim wnd

Set wnd = Windows(peWindowKindReceiveTransmit)

wnd.Object.SplitState = peSplitStateRcvMaximized

End Sub


StartTime Property

Applies to: Tracer object

Returns the start time of a tracer.

Syntax

object.StartTime

Parameter

object

An expression that evaluates to a Tracer object.

Property value

A DATE value that represents the start time of the tracer.

Example

The following example displays the start time of the active tracer:

VBS Macro

Sub StartTimeExample()

Dim doc, tracer

doc = Documents.Add(peDocumentKindTrace)

Set tracer = doc.ActiveWindow.Object.Tracer

MsgBox tracer.StartTime,,"Start Time"

End Sub


StatisticsEnabled Property

Applies to: Signal object

Activates or deactivates the calculation of statistical data for a Signal.

Syntax

object.StatisticsEnabled [=value]

Parameters

object

An expression that evaluates to a Signal object.

value

A Boolean that sets the new value of the property.

Property value

A Boolean value that specifies whether the calculation of statistical data is activated for a Signal. If True, statistical data is calculated for the Signal. If False (the default), no statistical data is calculated for the Signal.

Remarks

If calculation of statistical data is activated for a Signal, the properties RunningMin, RunningMinTime, RunningMax, RunningMaxTime, and RunningMean are updated every time the Signal's value is set. If the StatisticsEnabled property is set to False, all values of these properties are reset to 0.

Example

The following example activates the calculation of statistical data for all signals:

VBS Macro

Sub StatisticsEnabledExample()

Dim sig

For Each sig In Signals

sig.StatisticsEnabled = True

Next

End Sub

See also

RunningMax Property

RunningMaxTime Property

RunningMean Property

RunningMin Property

RunningMinTime Property

StatisticsEnabled Property

Feedback senden | Copyright © 2022 PEAK-System Technik GmbH. Alle Rechte vorbehalten.


StringValue Property

Applies to: Signal object

Sets or returns a signal's value as string.

Syntax

object.StringValue [=value]

Parameters

object

An expression that evaluates to a Signal object.

value

A String setting the signal's value.

Property value

A String value that represents the current value of a signal or variable, as a string.

Use the StringValue property to get or set the value of a signal that has either the peDataTypeString or the peDataTypeEnum data type (see DataType property).

Example

The following example displays the value of the signal "Speed":

VBS Macro

Sub StringValueExample()

Dim sig

Dim value

Set sig = Signals("StringVar")

value = sig.StringValue

MsgBox "StringValue = " & value,,"StringVar"

End Sub

See also

DataType Property

Value Property


Symbol Property

Applies to: ReceiveMessage object, TraceMessage object, TransmitMessage object

Returns the Symbol object that is associated with the CAN message.

Syntax

object.Symbol

Parameters

object

An expression that evaluates to one of the objects in the Applies To list above.

Property value

A Symbol object.

Example

The following example displays the CAN-ID of every symbolic CAN message in the Receive list:

VBS Macro

Sub SymbolExample()

Dim msg

For Each msg In ReceiveMessages

If Not msg.Symbol Is Nothing Then

PrintToOutputWindow msg.Symbol & " -> " & Hex(msg.ID) & "h"

End If

Next

End Sub

See also

Multiplexer Property


SymbolName Property

Applies to: ReceiveEvent object, TransmitEvent object

Returns the name of the symbol associated with the CAN message for which a Callback Library event was triggered.

Syntax

object.SymbolName

Parameters

object

An expression that evaluates to one of the objects in the Applies To list above.

Property value

A String value that specifies the name of a symbol.


Symbols Property

Applies to: Connection object

Returns the Symbols collection.

Syntax

object.Symbols

Parameters

object

An expression that evaluates to a Connection object.

Property value

A Symbols collection, which represents a collection of Symbol objects.

Example

The following example accesses the Symbols collection of the first connection in the project:

VBS Macro

Sub SymbolsExample()

Dim objConnection

If Connections.Count = 0 Then _

Exit Sub

Set objConnection = Connections(1)

' Access the Symbols property here

' For example:

If objConnection.Symbols Is Nothing Then

PrintToOutputWindow "No Symbols assigned"

Else

PrintToOutputWindow "Connection has " & objConnection.Symbols.Count _

& " Symbols"

End If

End Sub


SymbolsFileName Property

Applies to: Connection object

Sets or returns the name of a Symbols file that is associated with the connection.

Syntax

object.SymbolsFileName [=value]

Parameters

object

An expression that evaluates to a Connection object.

value

A String that specifies the name and path of a Symbols file. If the Symbols file is located in the same directory as the project file, the file path can be omitted. If the CANdb Add-in is loaded, the file could also be a CANdb database file (*.dbc).

Property value

A String value that specifies the file name of the assigned Symbols file. The returned file name does not include the file path.

Example

The following example accesses the SymbolsFileName property of the first connection in the project:

VBS Macro

Sub SymbolsFileNameExample()

Dim objConnection

If Connections.Count = 0 Then _

Exit Sub

Set objConnection = Connections(1)

' Access the SymbolsFileName property here

' For example:

PrintToOutputWindow objConnection.SymbolsFileName

End Sub


SymbolsManager Property

Applies to: Application object

Returns the SymbolsManager collection.

Syntax

object.SymbolsManager

Parameters

object

An expression that evaluates to an Application object.

Property value

A SymbolsManager collection, which contains the Symbols collections of all the connections in the project.


TabSize Property

Applies to: TextDocument object

Sets or returns the number of columns in a tab character.

Syntax

object.TabSize [=value]

Parameters

object

An expression that evaluates to a TextDocument object.

value

A Long that specifies the new value of the property.

Property value

A Long value that specifies .the number of columns in a tab character.

Remarks

When you press the TAB key, you create an indent equal to the size specified by the TabSize property.

Example

The following example sets the number of columns in a tab character to 5 in the active document:

VBScript

ActiveDocument.TabSize = 5


Text Property

Applies to: TextSelection object

Sets or returns the text in a selection.

Syntax

object.Text [=text]

Parameters

object

An expression that evaluates to a TextSelection object.

text

A String that sets the text in the selection.

Property value

A String value that contains the text in the selection. This string can include one or both of the following values:

  • vbCrLf: represents "\r\n" or #13#10

  • vbTab: represents "\t" or #9

Remarks

The Text property is the default property of the TextSelection object. Accordingly, you can reference the TextSelection object without explicitly specifying ".Text" when getting the value of the Text property.

Note

You cannot use the Text property on a text in a column selection.
Example

The following example inserts a tab character by using vbTab with the Text property:

VBS Macro

Dim Sel

Set Sel = ActiveDocument.Selection

Sel.Text = vbTab


TextEditor Property

Applies to: Application object

Returns the TextEditor object.

Syntax

object.TextEditor

Parameters

object

An expression that evaluates to an Application object.

Property value

A the TextEditor object.

Example

The following example changes the editor mode from Insert to Overwrite:

VBScript

Dim EditorObj

Set EditorObj = TextEditor

EditorObj.OverType = True


TimeFormat Property

Applies to: Application object

Sets or returns a string that defines how absolute timestamps are displayed in the various windows of PCAN-Explorer.

Syntax

object.TimeFormat [=value]

Parameters

object

An expression that evaluates to an Application object.

value

A String that specifies the new value of the property.

Property value

A String value that specifies how absolute timestamps are displayed in the various windows of PCAN-Explorer.

The following table shows the format specifiers that can be used to format the output of timestamps:

Specifier | Displays
am/pm | am and pm indication, hour output in 12-hour format.
d | Day as number (1-31), shortest possible form.
dd | 2-digit day (01-31).
ddd | Day name, abbreviated to 2 characters (system locale dependent).
dddd | Day name, not abbreviated (system locale dependent).
h | Hour, shortest possible form. If am/pm is also indicated in the format string, hour is in 12-hour format.
hh | 2-digit hour. If am/pm is also indicated in the format string, hour is in 12-hour format.
m | Month as a number (1-12), shortest possible form.
mm | 2-digit Month (01-12).
mmm | Month name, abbreviated to 3 characters (system locale dependent).
mmmm | Month name, not abbreviated (system locale dependent).
n | Minute, shortest possible form (0-59).
nn | 2-digit Minute (00-59).
s | Second, shortest possible form (0-59).
ss | 2-digit Second (00-59).
x | Microseconds, up to 3 digits (x, xx, xxx).
yy | 2-digit Year.
yyyy | 4-digit Year.
z | Milliseconds, up to 3 digits (z, zz, zzz).
Example

The following example accesses the TimeFormat property:

VBScript

TimeFormat = "hh:nn:ss.zzz.xxx"


Timeout Property

Applies to: Multiplexer object, ReceiveEvent object, ReceiveMessage object

Returns the timeout time value that was defined for a Multiplexer.

Syntax

object.Timeout

Parameters

object

An expression that evaluates to one of the objects in the Applies To list above.

Property value

A Long value that specifies the timeout time of the object in Milliseconds.

The value 0 indicates that no timeout was defined for the object.

Example

The following example gets the time-out time of a Multiplexer:

VBScript

Dim timeout

timeout = myMux.Timeout

See also

MinInterval Property


Timestamp Property

Applies to: J1939RcvMsg object, PCANMessage object, ReceiveEvent object, ReceiveMessage object, TraceMessage object, TransmitEvent object, TransmitMessage object

Returns the timestamp of a message.

Syntax

object.Timestamp

Parameters

object

An expression that evaluates to one of the objects in the Applies To list above.

Property value

A Long value that specifies the number of Milliseconds that have elapsed since the start of Windows.

See also

TimestampAbs Property

TimestampAbsString Property


TimestampAbs Property

Applies to: ReceiveEvent object, ReceiveMessage object, TraceMessage object, TransmitEvent object, TransmitMessage object

Returns the absolute timestamp of a CAN message.

Syntax

object.TimestampAbs

Parameters

object

An expression that evaluates to one of the objects in the Applies To list above.

Property value

A DATE value that represents the absolute time stamp of the CAN message.

Example

The following example lists the absolute time stamps of all CAN messages that are currently contained in the Receive list:

VBS Macro

Sub TimestampAbsExample()

Dim msg

For Each msg In ReceiveMessages

PrintToOutputWindow Hex(msg.ID) & "h -> " & msg.TimestampAbs

Next

End Sub

See also

Timestamp Property

TimestampAbsString Property


TimestampAbsString Property

Applies to: ReceiveEvent object, ReceiveMessage object, TraceMessage object, TransmitEvent object, TransmitMessage object

Returns the absolute timestamp of a CAN message as text.

Syntax

object.TimestampAbsString

Parameters

object

An expression that evaluates to one of the objects in the Applies To list above.

Property value

A String value that represents the absolute time stamp of a CAN message.

The returned string is formatted according to the format specified in the TimeFormat property.

Example

The following example lists absolute time stamps of all CAN messages that are currently contained in the Receive list:

VBS Macro

Sub TimestampAbsStringExample()

Dim msg

For Each msg In ReceiveMessages

PrintToOutputWindow Hex(msg.ID) & "h -> " & msg.TimestampAbsString

Next

End Sub

See also

Timestamp Property

TimestampAbs Property


TimestampFormat Property

Applies to: Tracer object

Sets or returns the format that is used to display timestamps in a trace window.

Syntax

object.TimestampFormat [=value]

Parameters

object

An expression that evaluates to a Tracer object.

value

A PeTraceTimestampFormat enum value that sets the new value of the property.

Property value

A PeTraceTimestampFormat enum value. Possible values are:

  • peTraceTimestampFormatRelative (0): The timestamp indicates the time offset since start of the recording.

  • peTraceTimestampFormatAbsolute (1): The timestamp is shown as an absolute time.

  • peTraceTimestampFormatDifferential (2): The timestamp indicates the time period between the message and the previous recorded message.

Example

The following example changes the value of the TimestampFormat property of the foreground tracer window:

VBS Macro

Sub TimestampFormatExample()

   If ActiveDocument.Kind = peDocumentKindTrace Then

      Dim tracer

      Set tracer = ActiveWindow.Object.Tracer

      tracer.TimestampFormat = peTraceTimestampFormatAbsolute

   End If

End Sub

See also

CanIdFormat Property

DataFormat Property


TimingErrorCount Property

Applies to: ReceiveEvent object, ReceiveMessage object

Returns the number of timing errors that have occurred for a received CAN message.

Syntax

object.TimingErrorCount

Parameters

object

An expression that evaluates to a ReceiveEvent object or ReceiveMessage object.

Property value

A Long value that specifies the number of timing errors that have occurred for a received CAN message.

Example

The following example gets the number of timing errors of a CAN message:

VBS Macro

Sub TimingErrorCountExample()

Dim rcvmsg

For Each rcvmsg In ReceiveMessages

If rcvmsg.TimingErrorCount > 0 Then

PrintToOutputWindow rcvmsg.TimingErrorCount & _

" timing errors for message " & Hex(rcvmsg.ID) & "h"

End If

Next

End Sub

The following example uses the Callback Library On Timing Error event to print a message to the Output Window when a timing error occurs for a received message:

C++ Callback DLL

HRESULT __stdcall TimingErrorCountExample(PCANExplorer6::IPEReceiveEvent *pEvent)

{

long id, count;

if (SUCCEEDED(pEvent->get_ID(&id)) &&

(SUCCEEDED(pEvent->get_TimingErrorCount(&count)))

{

char buff[100];

sprintf_s(buff, "%d timing errors for message %Xh", count, id);

pEvent->PrintToOutputWindow(CComBSTR::CComBSTR(buff));

}

return S_OK;

}


Title Property

Applies to: Symbols collection

Returns the title that was defined for a Symbols file with a global Title parameter.

Syntax

object.Title

Parameters

object

An expression that evaluates to one of the objects in the Applies To list above.

Property value

A String value that specifies the title that was defined for a Symbols file with a global Title parameter.

If no Title parameter was specified in a Symbols file, the title is the name of the file without the name extension and file path.


Top Property

Applies to: Window object

Sets or returns the y-coordinate of a window's upper edge.

Syntax

object.Top [=value]

Parameters

object

An expression that evaluates to a Window object.

value

A Long value that specifies the new value of the property.

Property value

A Long value that represents the y-coordinate of the window's upper edge in pixels.

Remarks
Note

Multiple Document Interface (MDI) child window coordinates are relative to the child window client area. (This area is inside the frame but does not include the docking sites.)
Example

The following example sets the y-coordinate of the active window to 50:

VBScript

ActiveWindow.Top = 50

See also

Height Property

Left Property

Width Property


Tracer Property

Applies to: TraceWindow object

Returns the Tracer object contained in a trace window.

Syntax

object.Tracer

Parameters

object

An expression that evaluates to a TraceWindow object.

Property value

A Tracer object.

Example

The following example retrieves the number of recorded messages from the active tracer:

VBS Macro

Sub TracerExample()

' Open a trace window before running this macro

Dim TraceWin

Set TraceWin = ActiveWindow.Object

Dim TR

Set TR = TraceWin.Tracer

MsgBox "Number of recorded messages: " & TR.Messages.Count

End Sub


TraceState Property

Applies to: Tracer object

Returns the current operating state of the tracer.

Syntax

object.TraceState

Parameters

object

An expression that evaluates to a Tracer object.

Property value

A PeTraceState enum value. The following values are possible:

  • peTraceStopped: The tracer is stopped.

  • peTracePaused: The tracer is stopped temporarily.

  • peTraceStarted: The tracer is recording CAN messages.

  • peTraceLoading: The tracer is loading data from a file.

  • peTraceSaving: The tracer is saving data to a file.

Example

The following example gets the operating state of the active tracer:

VBS Macro

Sub TraceStateExample()

' Open a trace window before running this macro

Dim TraceWin

Set TraceWin = ActiveWindow.Object

Dim state, strMsg

state = TraceWin.Tracer.TraceState

Select Case state

Case peTraceStopped

strMsg = "Tracer is stopped"

Case peTracePaused

strMsg = "Tracer is paused"

Case peTraceStarted

strMsg = "Tracer is recording"

Case peTraceLoading

strMsg = "Tracer is loading"

Case peTraceSaving

strMsg = "Tracer is saving"

End Select

MsgBox strMsg,,ActiveWindow.Caption

End Sub


TransmitMessages Property

Applies to: Application object, Connections collection, ReceiveTransmitWindow object

Returns a TransmitMessages collection.

Syntax

object.TransmitMessages

Parameters

object

An expression that evaluates to the Application object, a Connections collection, or a ReceiveTransmitWindow object.

Property value

A TransmitMessages collection, which represents a collection of CAN messages. Each CAN message in the collection is represented by a TransmitMessage object.

Example

The following example accesses the TransmitMessages collection and counts the number of transmitted messages:

VBS Macro

Sub TransmitMessagesExample()

Dim msg, cnt

cnt = 0

For Each msg In TransmitMessages

cnt = cnt + msg.EventCount

Next

MsgBox "Number of transmitted messages: " & cnt

End Sub


Type Property [Variation 1]

Applies to: Document object, TextDocument object, Window object

Returns a string describing the type of the document or window.

Syntax

object.Type

Parameters

object

An expression that evaluates to one of the objects in the Applies To list above.

Property value

A String value that specifies the type of the document or window.

The following table describes what the Type property returns for each object in the Applies To list:

Object | Returned Type | Description
Document | Generic | Contains a file not corresponding to any other type.
 | Tool | Contains a document defined by an Add-in.
 | Trace | Contains a trace file.
 | XmtList | Contains a transmission list.
TextDocument | Text | Contains a text file.
Window | Document | Shows the data of a document.
 | Tool | Contains a tool window. This includes the Start Page and the Receive/Transmit window.
Example

The following example gets the type of the active document:

VBS Macro

Sub DocumentTypeExample()

Dim doctype

doctype = ActiveDocument.Type

MsgBox "Document Type = " & doctype

End Sub


Type Property [Variation 2]

Applies to: Symbol object

Returns the type of a symbol.

Syntax

object.Type

Parameters

object

An expression that evaluates to a Symbol object.

Property value

A PeSymbolType enum value. The following values are possible:

  • peSymbolTypeStandard (0): The symbol represents a standard CAN message that has an 11-bit identifier.

  • peSymbolTypeExtended (1): The symbol represents an extended CAN message that has a 29-bit identifier.

  • peSymbolTypeJ1939PG (2): The symbol represents a J1939 parameter group.

Example

The following example accesses the Type property:

VBS Macro

Sub SymbolTypeExample()

Dim symbol, symtype

Set symbol = SymbolsManager("MySymbols").Item("MySymbol")

symtype = symbol.Type

' ...

End Sub


Type Property [Variation 3]

PCAN-Explorer: Automation

Objekte

Type Property

Home Page (Objects) | Reference

Applies to: MessageFilterItem object

Returns the type of a Message Filter item.

Syntax

object.Type

Parameters

object

An expression that represents a MessageFilterItem object.

Property value

A PeMessageFilterItemType enum value. The following values are possible:

  • peFilterItemIDRange (0): The item filters CAN IDs.

  • peFilterItemCodeMask (1): The item filters by Acceptance Code and Mask.

  • peFilterItemAllSymbols (2): The item filters out all messages that do not have a matching symbol.

  • peFilterItemMarkedSymbols (3): Only those symbols pass the filter item that are marked with the Trace flag (-t switch in a Symbols file).

  • peFilterItemJ1939 (4): The item filters by J1939 PGN, Priority, Source Address, Destination Address.

  • peFilterItemOptions (5): The item filters by message type, e.g. RTR, Error Warning, Error Frame.

Example

The following example adds a new message filter to the project and configures a new filter item. The filter is then assigned to a tracer:

VBS Macro

Sub FilterExample()

Dim myFilter

Set myFilter = MessageFilters("MyFilter")

If myFilter Is Nothing Then

' MyFilter does not yet exist in the current project

Set myFilter = MessageFilters.Add("MyFilter")

' Add a new filter item

Dim myItem

Set myItem = myFilter.AddItem

myItem.Type = peFilterItemIDRange

myItem.IDfrom = &H100

myItem.IDto = &H100

End If

' Now assign the filter to a tracer

Dim doc

Set doc = Documents("Trace1.trc")

If Not doc Is Nothing Then

Dim tracer

Set tracer = doc.ActiveWindow.Object.Tracer

tracer.Filter = myFilter

' Finally, start the tracer

tracer.Start

End If

End Sub


Properties U-Z

The following table contains all properties beginning with letters U to Z:

Property | Description
Unit | Returns the physical unit of a signal or a variable.
UseAddressingProtocol | Sets or returns whether the addressing protocol, which is a part of the J1939 network management, is enabled for the J1939 node.
Value | Sets or returns a Signal's or Variable's value.
ValueChangeTime | Returns the time and date, at which the Signal value was set last
Variables | Returns a Variables collection.
VariableStringValue | Accesses a variable value stored in the data bytes of a CAN message.
VariableValue | Accesses a variable value stored in the data bytes of a CAN message.
VBSMacroFiles | Returns the VBSMacroFiles collection.
Version | Returns the version number of PCAN-Explorer or an Add-in.
VisibleVariablesCount | Returns the number of visible Variables of a Multiplexer.
Width | Sets or returns the width of a window.
Window | Returns the Window object that contains this object.
WindowHandle | Sets or returns the handle of a window that is associated with the object.
Windows | Returns the Windows collection.
WindowState | Sets or returns the state of a window.
WindowStyle | Sets or returns the style of a window.
XferDirection | Returns the transfer direction of a Symbol.
XmtQueueEmpty | Returns whether a PCAN client's transmit queue is empty.

See also

Properties A-F

Properties G-K

Properties L-P

Properties Q-T


Unit Property

Applies to: Signal object, Variable object

Returns the physical unit of a signal or a variable.

Syntax

object.Unit

Parameters

object

An expression that evaluates to a Signal object or a Variable object.

Property value

A String that specifies the physical unit of the signal or variable.

Example

The following example displays the unit of the signal "Speed" in a message box:

VBS Macro

Sub UnitExample()

Dim sig

Set sig = Signals("Speed")

MsgBox "Unit = " & sig.Unit,,"Speed"

End Sub


UseAddressingProtocol Property

Applies to: J1939Node object

Sets or returns whether the addressing protocol, which is a part of the J1939 network management, is enabled for the J1939 node.

Syntax

object.UseAddressingProtocol [=value]

Parameters

object

An expression that evaluates to a J1939Node object.

value

A Boolean that specifies the new value of the property.

Property value

A Boolean value that specifies whether the addressing protocol, which is a part of the J1939 network management, is enabled for the J1939 node (see J1939/81 document). If True (the default), the addressing protocol is enabled. If False, the addressing protocol is disabled and no addresses can be claimed on the bus.


Value Property

Applies to: Signal object, Variable object

Sets or returns a signal's or variable's value.

Syntax

object.Value [=value]

Parameters

object

An expression that evaluates to a Signal object or a Variable object.

value

A Double that sets the new value of the signal or variable.

Property value

A Double that represents the current value of the signal or variable.

Remarks

You cannot use the Value property of Signals whose DataType property contains the value peDataTypeString.

Example

The following example displays the value of the signal "Speed" in a message box:

VBS Macro

Sub ValueExample()

Dim sig, value

Set sig = Signals("Speed")

value = sig.Value

MsgBox "Value = " & sig.Value,,"Speed"

End Sub

See also

StringValue Property


ValueChangeTime Property

Applies to: Signal object

Returns the time and date at which the Signal value was set the last time, e.g. when a CAN message was received that contained data for the Signal.

Syntax

object.ValueChangeTime

Parameters

object

An expression that evaluates to a Signal object.

Property value

A DATE value that specifies the time and date at which the Signal value was set the last time.

Example

The following example displays the last value time of the Signal "Speed":

VBS Macro

Sub ValueChangeTimeExample()

Dim sig

Set sig = Signals("Speed")

MsgBox "ValueChangeTime = " & sig.ValueChangeTime,,"Speed"

End Sub


Variables Property

Applies to: Multiplexer object

Returns a Variables collection.

Syntax

object.Variables

Parameters

object

An expression that evaluates to a Multiplexer object.

Property value

A Variables collection, which represents the collection of all variables of a multiplexer. Each variable in the collection is represented by a Variable object.

Example

The following example accesses the Variables collection:

VBScript

Dim vars

Set vars = myMultiplexer.Variables


VariableStringValue Property

Applies to: ReceiveEvent object, ReceiveMessage object, TransmitEvent object, TransmitMessage object, TraceMessage object

Accesses a variable value stored in the data bytes of a CAN message.

Syntax

object.VariableStringValue ( name ) [=value]

Parameters

object

An expression that evaluates to one of the objects in the Applies To list above.

name

A String that specifies the name of the variable to be accessed.

value

A String that sets the new value of the variable.

Property value

A String representing the current value of the variable.

Remarks

The VariableStringValue properties of the ReceiveEvent, ReceiveMessage, and TraceMessage objects are read-only.

If the specified variable name is not found in the message when setting the value of a variable, nothing happens.

If the specified variable name is not found in the message when getting a variable value, then the value 0 is returned.

The string returned from the VariableStringValue property is formatted according to the variable's format specifiers, e.g. the OutputFormat property.

Examples

The following example prints all variable values of a received message to the Output window:

VBS Macro

Sub GetVariableValueExample()

Dim msg, mux, var

Set msg = ReceiveMessages(1)

If Not msg.Multiplexer Is Nothing Then

For Each var In msg.Multiplexer

PrintToOutputWindow var.Name & " = " & msg.VariableStringValue(var.Name)

Next

End If

End Sub

The following example changes a variable value in a transmit message:

VBS Macro

Sub SetVariableValueExample()

TransmitMessages(1).VariableStringValue("MyVariable") = "123"

End Sub

See also

VariableValue Property


VariableValue Property

Applies to: ReceiveEvent object, ReceiveMessage object, TransmitEvent object, TransmitMessage object, TraceMessage object

Accesses a variable value stored in the data bytes of a CAN message.

Syntax

object.VariableValue ( name ) [=value]

Parameters

object

An expression that evaluates to one of the objects in the Applies To list above.

name

A String that specifies the name of the variable to be accessed.

value

A Double that sets the new value of the variable.

Property value

A Double that represents the current value of the variable.

Remarks

The VariableValue properties of the ReceiveMessage and the TraceMessage objects are read-only.

If the specified variable name is not found in the message when setting the value of a variable, nothing happens.

If the specified variable name is not found in the message when getting a variable value, then the value 0 is returned.

Examples

The following example prints all variable values of a received message to the Output window:

VBS Macro

Sub GetVariableValueExample()

Dim msg, mux, var

Set msg = ReceiveMessages(1)

If Not msg.Multiplexer Is Nothing Then

For Each var In msg.Multiplexer

PrintToOutputWindow msg.VariableValue(var.Name)

Next

End If

End Sub

The following example changes a variable value in a transmit message:

VBS Macro

Sub SetVariableValueExample()

TransmitMessages(1).VariableValue("MyVariable") = 123

End Sub

The following example uses the Callback Library On Before Transmit event to increase a rolling counter variable before the message with CAN ID 123h is transmitted:

C++ Callback DLL

HRESULT __stdcall ID123_RollingCounter(PCANExplorer6::IPETransmitEvent *pEvent)

{

static int counter;

long id;

if (SUCCEEDED(pEvent->get_ID(&id)) && (id == 0x123))

{

if (++counter > 255)

counter = 0;

pEvent->put_VariableValue(CComBSTR::CComBSTR("MyCounter"), (double)counter);

}

return S_OK;

}

See also

VariableStringValue Property


VBSMacroFiles Property

Applies to: Application object

Returns the VBSMacroFiles collection.

Syntax

object.VBSMacroFiles

Parameters

object

An expression that evaluates to an Application object.

Property value

A VBSMacroFiles collection, which represents the collection of all VBS Macro Files listed in the VBS Macro Manager dialog box. Each file in the collection is represented by a VBSMacroFile object.

Example

The following example accesses the VBSMacroFiles collection:

VBS Macro

Sub VBSMacroFilesExample()

MsgBox VBSMacroFiles.Count,,"Number of VBS Macro Files"

End Sub


Version Property

Applies to: AddIn object, Application object, PCANClient object

Returns the version number of PCAN-Explorer or an Add-in.

Syntax

object.Version

Parameters

object

An expression that evaluates to one of the objects in the Applies To list above.

Property value

A String value that represents a version number.

The returned version number is formatted as MajorVersion.MinorVersion.Revision, for example "5.1.0".

Example

The following example displays the version number of PCAN-Explorer:

VBS Macro

Sub VersionExample()

MsgBox Version,,"Version"

End Sub


VisibleVariablesCount Property

Applies to: Multiplexer object

Returns the number of visible variables of a multiplexer.

Syntax

object.VisibleVariablesCount

Parameters

object

An expression that evaluates to a Multiplexer object.

Property value

A Long value that specifies the number of visible variables.

The value of the VisibleVariablesCount property arises from the display formats of the Variable, which are defined by their DisplayMode property. All those variables are counted, which have its DisplayMode property set either to peDisplayAll or peDisplayValue.

See also

DisplayMode Property


Width Property

Applies to: Window object

Sets or returns the width of a window.

Syntax

object.Width [=value]

Parameters

object

An expression that evaluates to a Window object.

value

A Long value that specifies the new value of the property.

Property value

A Long value that represents the width of the window in pixels.

Example

The following example gets the width of the active window:

VBScript

Dim width

width = ActiveWindow.Width

See also

Height Property

Left Property

Top Property


Window Property

Applies to: ReceiveTransmitWindow object, TextWindow object, TraceWindow object, TransmitWindow object

Returns the Window object that contains this object.

Syntax

object.Window

Parameters

object

An expression that evaluates to one of the objects in the Applies To list above.

Property value

A Window object.

Example

The following example closes the active window:

VBS Macro

Sub WindowExample()

' Open a window before running this macro

Dim obj

Set obj = ActiveWindow.Object

obj.Window.Close

End Sub


WindowHandle Property

Applies to: J1939Node object, PCANClient object

Sets or returns the handle of a window that is associated with the object.

Syntax

object.WindowHandle [=value]

Parameters

object

An expression that evaluates to a J1939Node object or a PCANClient object.

value

A Long that specifies the new value of the property.

Property value

A Long value representing the window handle that is associated with the object.


Windows Property

Applies to: Application object

Returns the Windows collection.

Syntax

object.Windows

Parameters

object

An expression that evaluates to an Application object. When you access the Windows property of the Application object, you can omit object because the name of the Application object is implied when you access its properties and methods.

Property value

A Windows collection, which represents a collection of all open windows. Each window in the collection is represented by a Window object.

Example

The following example accesses the collection of open windows:

VBS Macro

Sub WindowsExample()

MsgBox "Number of windows: " & Windows.Count,,"Macro"

End Sub


WindowState Property

Applies to: Window object

Sets or returns the state of a window.

Syntax

object.WindowState [=state]

Parameters

object

An expression that evaluates to a Window object.

state

A PeWindowState enum value that specifies the new value of the property.

Property value

A PeWindowState enum value. Possible values are:

  • peWindowStateMaximized: Maximizes the window.

  • peWindowStateMinimized: Minimizes the window.

  • peWindowStateNormal: Restores the normal state of the window.

Example

The following example minimizes the active window:

VBS Macro

Sub WindowStateExample()

ActiveWindow.WindowState = peWindowStateMinimized

End Sub


WindowStyle Property

Applies to: Window object

Sets or returns the style of a window.

Syntax

object.WindowStyle [=value]

Parameters

object

An expression that evaluates to a Window object.

value

A PeWindowStyle enum value that sets the new value of the property.

Property value

A PeWindowStyle enum value that specifies the style of the window. Possible values are:

  • peWindowStyleFloating (1): The window is a floating window.

  • peWindowStyleDockable (2): The window is a dockable window that can be docked to the dock zones of the main window.

  • peWindowStyleTabbed (3): The window is an MDI child window and has an associated tab in the tabs area of the main window.


XferDirection Property

Applies to: Symbol object

Returns the transfer direction of the CAN message that is represented by the symbol.

Syntax

object.XferDirection

Parameters

object

An expression that evaluates to a Symbol object.

Property value

A PeXferDirection enum value. The following values are possible:

  • peXferSend (1): The symbol is transmitted.

  • peXferReceive (2): The symbol is received.

  • peXferBidirectional (3): The symbol is both transmitted and received.

Example

The following example gets the transfer direction of the Symbol "MySymbol":

VBS Macro

Sub XferDirectionExample()

Dim symbol, direction

Set symbol = SymbolsManager("MySymbols").Item("MySymbol")

direction = symbol.XferDirection

' ...

End Sub


XmtQueueEmpty Property

Applies to: J1939Node object, PCANClient object, PCANClientConnection object

Returns whether the transmit queue of the communication object is empty.

Syntax

object.XmtQueueEmpty

Parameters

object

An expression that evaluates to a J1939Node object, a PCANClient object, or a PCANClientConnection object.

Property value

A Boolean value that indicates whether the transmit queue is empty. If True, the transmit queue is empty. If False, the transmit queue still contains unsent messages.

Examples

The following example waits until the transmit queue of the first connection in the project is empty:

VBS Macro

Sub XmtQueueEmptyExample1()

Dim obj

Set obj = Connections(1).CommunicationObject

While Not obj.XmtQueueEmpty

Wait 100

Wend

MsgBox "Queue is empty"

End Sub

The following example transmits some messages and waits until all messages are transmitted before exiting.

VBS Macro

Sub XmtQueueEmptyExample2()

' Create a new PCAN client

Dim client, conn

Set client = CreateObject("PCAN4.PCANClient")

client.Device = "pcan_usb"

client.Name = "Macro"

Set conn = client.Connections.Add("TestNet")

' Create a new transmit message

Dim msg

Set msg = client.Messages.Add

msg.ID = &H100

msg.DLC = 1

' Now write some messages to the transmit queue

Dim timestamp, i

timestamp = client.GetSystemTime + 100

For i = 1 To 20

msg.Data(0) = i

msg.Write conn, timestamp

timestamp = timestamp + 100

Next

' Finally, wait until all messages have been sent.

' If this is not done, the macro procedure will exit

' immediately so that the client will be deleted, and

' any unsent messages are lost.

While Not client.XmtQueueEmpty

Wait 500

Wend

End Sub


Methods

Methods are actions you take against objects. For example, to add a document to the collection of open documents, you use the Add method of the Documents collection.

For more information about methods, see Applying Methods to PCAN-Explorer Objects.

The following methods are available:

Method | Description
AbortOperation | Aborts any prolonged operation of a tracer, like loading, saving, and filtering.
Activate | Moves the focus to a specific item.
Add (Variation 1) | Creates a new object in a collection.
Add (Variation 2) | Creates a new object in a collection.
Add (Variation 3) | Creates a new document.
Add (Variation 4) | Adds a new Enum value.
Add (Variation 5) | Creates a new filter object in the collection.
AddCommand | Adds a command to PCAN-Explorer that is implemented by an Add-in.
AddCommandBarButton | Creates a toolbar and toolbar buttons for an Add-in.
AddDocumentType | Adds a new document type for an ActiveX control, which is implemented by an Add-in.
AddItem | Adds a sub-item to an object or collection.
AddKeybinding | Assigns a key combination to an Add-in command.
ApplyFilter | Filters the buffer contents of a Tracer. Creates a new Tracer containing the filtered buffer.
Arrange | Maximizes, minimizes or arranges all open windows separated horizontally or vertically
Backspace | Executes the function of the backspace key.
BeginUpdate | Acquires a lock on a object.
CalculateStatisticsFromTracer | Calculates statistical values for a signal from the recorded messages of a tracer.
CanAddItem | Checks, whether an item of a specific kind can be added to a ProjectItems collection.
Cancel | Removes a selection without deleting the selected text.
CharLeft | Moves the cursor position one character to the left.
CharRight | Moves the cursor position one character to the right.
ClaimAddress | Claims a J1939 address.
Clear | Removes all elements from the collection.
ClearItems | Clears the filter items collection.
Close | Closes a document and optionally saves it, or closes and destroys a window.
CloseAll | Closes all open windows or documents.
Connect | Establishes a CAN connection for a J1939 node object.
ConnectDialog | Shows a dialog box for establishing a connection to a PCAN net.
Copy | Copies the selected text into the clipboard.
Cut | Deletes the selected text and puts it into the clipboard.
Delete | Executes the function of the key DEL.
Disconnect | Closes the CAN connection of a J1939 node object.
Duplicate | Duplicates a message filter.
EndOfLine | Moves the cursor position to the end of the last row of a selection.
EndUpdate | Releases a lock and updates the object.
ExecuteCommand | Executes a PCAN-Explorer command.
FindID | Returns a collection of the same type, which contains CAN messages with the CAN ID searched for.
FindMultiplexer | Returns a collection of the same type, which contains CAN messages with the Multiplexer searched for.
FindOrdinal | Searches for an ordinal in an Enum.
FindString | Searches for a text in an Enum by its associated ordinal.
FindSymbol | Returns a collection of the same type, which contains CAN messages matching to the specified Symbol.
FindText | Starting with the end of the current selection FindText searches through the rest of the document for specific strings. If the string has been found, FindText moves the selection to this place.
GetErrorText | Evaluates the errors from an error code and returns them as text.
GetHardwareParam | Returns different parameters, which can be retrieved by the PCAN system for every managed CAN hardware.
GetLongErrorText | Returns a description of an error code.
GetNetParam | Returns different parameters, which can be retrieved by the PCAN system for all defined PCAN nets.
GetOrdinal | Retrieves an ordinal from an Enum by its index.
GetParam | Returns different parameters, which can be retrieved by the PCAN system for the client.
GetString | Retrieves a text from an Enum by its index.
GetSystemTime | Returns the number of milliseconds, that have passed since the start of Windows.
GoToLine | Moves the cursor position to a specific line in a document.
Item | Retreives a specific CAN message, a document, a window, a signal, a Symbol or a Multiplexer from a collection.
LineDown | Moves the cursor position one line downward.
LineUp | Moves the cursor position one line upward.
MessageToValue | Calculates a Variable's value from the data of a CAN message.
MoveTo | Moves the cursor position to the given line and column.
NewProject | Creates a new project.
Open | Opens a document having the indicated file name.
OutputString | Displays a text in the output window.
PageDown | Moves the cursor position one page downward.
PageUp | Moves the cursor position one page upward.
Paste | Replaces the selection with the clipboard's contents.
Pause | Pauses the recording of CAN messages.
PauseAll | Stops the periodic sending of all corresponding CAN messages of a Transmit List.
Play | Starts playback of CAN messages from a trace buffer or file.
PrintOut | Sends a document to the current printer.
PrintToOutputWindow | Routs the text output of a Macro to the Macro tab of the output window.
Quit | Quits PCAN-Explorer.
Read (Variation 1) | Reads a CAN message from the receive queue of the parent PCANClient object.
Read (Variation 2) | Reads a J1939 message from the receive queue of a J1939Node object.
Register | Registers a PCAN client at a PCAN device.
RegisterCallback (Variation 1) | Adds a callback handler for the signal value change event.
RegisterCallback (Variation 2) | Adds a callback handler for the message reception event.
RegisterCallback (Variation 3) | Adds a callback handler for message transmission events.
RegisterMsg | Opens the reception filter of the PCAN client for the reception of a range of CAN messages.
ReleaseAddress | Releases a previously claimed J1939 address.
Remove (Variation 1) | Removes an object from its parent collection.
Remove (Variation 2) | Removes PCAN client from a PCAN device.
RemoveItem | Removes a project item from an object or collection.
RenameItem | Renames a project item.
Reset (Variation 1) | Deletes the contents of a PCAN client's receive queue.
Reset (Variation 2) | Resets a J1939Node object. Resets the configured filter, deletes the contents of the Receive Queue, and resets the connected CAN Hardware.
ResetFilters | Closes the reception filter of the PCAN client so that no more CAN messages can pass the filter.
ResetHardware | Carries out a reset of a connected CAN hardware.
ResumeAll | Resumes the periodic sending of all messages in a Transmit List.
Save | Saves a document or project in a file.
SaveAll | Saves all open documents in the collection.
SaveAs | Saves a project under a new name.
SelectAll | Extends the selection so that the whole document is included.
SelectSignal | Shows a dialog box for selecting of a signal.
SelectSignals | Shows a dialog box for selecting one or multiple signals.
Send | Sends a CAN message on the selected bus/connection.
SetAddInInfo | Transfers information about an Add-in to PCAN-Explorer when the Add-in is loaded.
SetDriverParam | Sets a PCAN driver parameter.
SetFilter | Configures the receive filter of a connection.
SetHardwareParam | Configures different parameters of a CAN hardware.
SetNetParam | Configures different parameters of PCAN nets.
SetParam | Configures different parameters of the PCAN client.
ShowFilterDialog | Shows the Edit Filter dialog box for a message filter.
Start | Starts the recording of CAN messages.
StartOfLine | Moves the cursor position to the beginning of a line.
Stop | Ends the recording of CAN messages.
TimeToString | Formats a Date/Time value.
TranslateFileName | Translates a file name, which contains Argument Macros, into an actual file name.
UnregisterCallback (Variation 1) | Removes a callback handler for the signal value change event.
UnregisterCallback (Variation 2) | Removes a callback handler for the message reception event.
UnregisterCallback (Variation 3) | Removes a callback handler for message transmission events.
UpdateSymbols | Updates symbols definitions that are stored in a specific document.
Wait | Waits for the given number of milliseconds.
Write (Variation 1) | Sends a CAN message.
Write (Variation 2) | Writes a CAN message into the transmit message queue of a PCAN client.
Write (Variation 3) | Sends a J1939 message.


AbortOperation Method

Applies to: Tracer object

Aborts any prolonged operation of a tracer, like loading, saving, and filtering.

Syntax

object.AbortOperation

Parameters

object

An expression that evaluates to a Tracer object.


Activate Method

Applies to: OutputWindowPane object

Moves the focus to the current item.

Syntax

object.Activate

Parameters

object

An expression that evaluates to an OutputWindowPane object.

Example

The following activates the "Macro" pane in the Output window:

VBS Macro

Sub ActivateExample()

Dim win

Dim OutputWin

Dim pane

Set win = Windows(peWindowKindOutput)

win.IsVisible = True

Set OutputWin = win.Object

Set pane = OutputWin.OutputWindowPanes("Macro")

pane.Activate

End Sub

See also

OutputWindow Object


Add Method [Variation 1]

Applies to: Connections collection, Enums collection, MessageFilters collection, OutputWindowPanes collection, PCANClientConnections collection, Signals collection

Creates a new object in the collection.

Syntax

object.Add ( name )

or

object.Add ( NetName )

or

object.Add ( ConnectionString )

Parameters

object

An expression that evaluates to one of the objects in the Applies To list above.

name

A String representing the name of the new Signal object, Enum object, OutputWindowPane object, or MessageFilter object.

The name parameter is optional when calling the Add method of the Signals collection, Enums collection, or MessageFilters collection.

NetName

(PCANClientsConnections collection) A String representing the name of the PCAN-net, with which a connection is to be established.

ConnectionString

(Connections collection) A String in the form NetName@DeviceName, which represents the connection to be established.

Return values

The Add method returns the newly created Connection object, Enum object, MessageFilter object, OutputWindowPane object, or Signal object.

Example

The following example adds a new connection to the current project:

VBS Macro

Sub AddConnectionExample()

Dim conn

Set conn = Connections.Add("TestNet@pcan_usb")

conn.IsEnabled = True

End Sub


Add Method [Variation 2]

Applies to: Messages collection, PCANMessages collection, ReceiveMessages collection, TransmitMessages collection

Creates a new object in the collection.

Syntax

object.Add

Parameters

object

An expression that evaluates to one of the objects in the Applies To list above.

Return values

The Add method returns the newly created PCANMessage object, ReceiveMessage object, TraceMessage object, or TransmitMessage object.

Example

The following example adds a new message to the Transmit List:

VBS Macro

Sub AddMessageExample()

Dim msg

Set msg = TransmitMessages.Add

' Initialize the CAN message

With msg

.BeginUpdate

.ID = &H100

.DLC = 3

.Data(0) = &H11

.Data(1) = &H22

.Data(2) = &H33

If Connections.Count > 0 Then _

Set .Connection = Connections(1)

.EndUpdate

End With

End Sub


Add Method [Variation 3]

Applies to: Documents collection

Creates a new document.

Syntax

object.Add ( DocKind )

Parameters

object

An expression that evaluates to a Documents collection.

DocKind

(Optional) A String that defines the kind of the document to be created. The kind of the document is a GUID string, as it is returned by the Kind property.

Return values

The Add method returns the newly created Document object.

Example

The following example creates a new Symbols file and shows it in the editor:

VBS Macro

Sub AddDocumentExample()

Dim doc

Set doc = Documents.Add(peDocumentKindText)

doc.Language = peSymbols

End Sub


Add Method [Variation 4]

Applies to: Enum object

Adds a new Enum value.

Syntax

object.Add ( ordinal, value )

Parameters

object

An expression that evaluates to an Enum object.

ordinal

A Long representing the ordinal value to be added to an Enum. Each ordinal is associated with a string that represents the ordinal.

value

A String that is associated with the ordinal value.

Example

The following example adds a new value to the Enum "MyEnum":

VBS Macro

Sub AddEnumValueExample()

Dim objEnum

Set objEnum = SymbolsManager.Enums("MyEnum")

objEnum.Add 10, "MyValue"

End Sub


Add Method [Variation 5]

Applies to: J1939Filters collection

Creates a new filter object in the collection.

Syntax

object.Add ( FilterMask, PGN, Priority, Source, Destination )

Parameters

object

An expression that evaluates to a J1939Filters collection.

FilterMask

A combination of TFilterMask values that specify which fields of a J1939 message are taken into account by this filter. Can be one or a combination of the following values: tfmPGN (1), tfmPriority (2), tfmSource (4), or tfmDestination (8).

PGN

A Long representing the PGN.

Priority

A Byte representing the Priority (0-7).

Source

A Byte representing the Source Address (0-255).

Destination

A Byte representing the Destination Address (0-255).

Return values

The Add method returns the newly created J1939Filter object.


AddCommand Method

Applies to: Application object

Adds a command to PCAN-Explorer that is implemented by an Add-in.

Syntax
C++

HRESULT _stdcall AddCommand(

BSTR szCommandString,

BSTR szMethodName,

long nGraphicsOffset,

long dwCookie,

/* [out, retval] */ VARIANT_BOOL *res

);
C#

bool AddCommand(

string szCommandString,

string szMethodName,

int nGraphicsOffset,

int dwCookie

);
Delphi

function AddCommand(

szCommandString: WideString;

szMethodName: WideString;

nGraphicsOffset: Integer;

dwCookie: Integer;

out res: WordBool

): HResult; stdcall;
Parameters

szCommandString

A string containing further strings, separated by the pipe '|' character. The following strings are contained:

  • Name of the command

This is the command, which shall be added. If the command matches with an existing command, PCAN-Explorer returns False, keeps the already existing command and does not add the new one. To avoid conflicts with existing commands the Add-in should put its name at the beginning of the command name.

  • Text, which is displayed on the toolbar button for this command

If a toolbar button is created for executing this command, this text is displayed on the button.

  • Tooltip text

This is the text which is displayed as Tooltip, when the user places the mouse pointer over the toolbar button, which is assigned to the command.

  • Status bar text

This is the text, that is shown in the status bar or in the Customize dialog, when the user selects the command.

szMethodName

Represents the name of the method, which is published by the Add-in to execute the command.

nGraphicsOffset

The 0-based index for the image of this command in the commands bitmap. E.g.

dwCookie

Represents the unique ID of the Add-in. PCAN-Explorer submitted this value to the Add-in by the Add-in's OnConnection method.

Return values

The AddCommand method returns one of the following values:

  • True: The command has been added.

  • False: The command hasn't been added, because its name is in the conflict with an already existing command.

Remarks

Only Add-ins can invoke the AddCommand method. VBScript Macros are not capable of this.

Examples

The following code adds a command to PCAN-Explorer:

Visual C++

STDMETHODIMP CPEAddIn::OnConnection(IDispatch* pApp, VARIANT_BOOL bFirstTime,

long dwCookie, VARIANT_BOOL * res)

{

...

CComBSTR szCommandString("SampleCommand1|&Sample Command|Sample Command|This is a Sample Command");

CComBSTR szMethodName("SampleCommand1");

if (FAILED(pApplication->AddCommand(szCommandString, szMethodName, 1, dwCookie)))

{

// Handle the error, e.g.

*res = VARIANT_FALSE;

return S_OK;

}
C#

public bool OnConnection(object app, bool firstTime, int cookie)

{

...

string commandString = "SampleCommand1|&Sample Command|Sample Command|This is a Sample Command";

string methodName = "SampleCommand1";

try

{

if (!this.app.AddCommand(commandString, methodName, 1, cookie))

return false;

}

catch

{

// Handle the error, e.g.

return false;

}
Delphi

function TPEAddIn.OnConnection(const pApp: IPEApplication; bFirstTime: WordBool;

dwCookie: Integer; out res: WordBool): HResult;

var

commandString, methodName: String;

_res: WordBool;

begin

...

commandString := 'SampleCommand1|&Sample Command|Sample Command|This is a Sample Command';

methodName := 'SampleCommand1';

if Failed(pApplication.AddCommand(strCmdName, strMethodName, 1, dwCookie, _res))

or not _res then

begin

// Handle the error, e.g.

res := False;

Result := S_OK;

Exit;

end;


AddCommandBarButton Method

Applies to: Application object

Creates a toolbar and a toolbar button for an Add-in.

Syntax
C++

HRESULT _stdcall AddCommandBarButton(

BSTR szCmdName,

long dwCookie

);
C#

void AddCommandBarButton(

string szCmdName,

int dwCookie

);
Delphi

function AddCommandBarButton(

szCmdName: WideString;

dwCookie: Integer

): HResult; stdcall;
Parameters

szCmdName

A string containing the name of the command that you want to assign to the button. This name must match a command that has already been added by calling the AddCommand method.

dwCookie

Represents the unique ID of the Add-in. PCAN-Explorer submitted this value to the Add-in by the Add-in's OnConnection method.

Remarks

Only Add-ins can invoke the AddCommandBarButton method. VBScript Macros are not capable of this.

The AddCommandBarButton method is usually called in the implementation of the IPEExtensibility.OnConnection method.

Example
Visual C++

if (FAILED(pApp->AddCommandBarButton(szCommandName, m_dwCookie)))

{

// Handle the error, e.g.

*res = VARIANT_FALSE;

return S_OK;

}

C#

try

{

app.AddCommandBarButton(commandName, cookie);

}

catch

{

// Handle the error, e.g.

return false;

}

Delphi

if Failed(pApp.AddCommandBarButton(commandName, FCookie)) then

begin

// Handle the error, e.g.

res := VARIANT_FALSE;

Exit;

end;

See also

AddCommand Method

Adding Commands to PCAN-Explorer

AddKeybinding Method

SetAddInInfo Method


AddDocumentType Method

Applies to: Documents collection

Adds a new document type, which is implemented by an Add-in, to PCAN-Explorer. This document type serves for saving and loading data of an ActiveX control. The available document types appear in the dialog "New File".

Syntax

object.AddDocumentType ( DocString, DocumentCLSID, WindowCLSID, Binary )

Parameters

object

An expression that evaluates to a Documents collection.

DocString

A String containing further substrings, separated by LF characters (Line Feed, ASCII-Code 10). The following strings are contained:

  • ClassID of the object

This string must contain the ClassID of the ActiveX control, which is created for the display of the document and shown in the corresponding window.

  • Default name of the document

The default name of the document (e.g. "Sheet"). This name with a consecutive number as supplement is used as name for a new document, when the user selects the menu command File | New | New File (e.g. "Sheet1" or "Sheet2"). If this name is not indicated, "Untitled" is used as default name.

  • Name of the document type

This name appears in the New File dialog box for the new document type (e.g. "Worksheet"). If this name is not indicated, the new document type is not visible in the New File dialog box.

  • Name of Open filter

Description of the document type and the file filter for opening this document type. This string is shown in the drop-down list "Files of type" of the "Open" dialog box (e.g. "Worksheets (*.xls)"). If the filter is not indicated, the document type is not visible in the File New dialog box. The Open filter can contain more than one file types, which then must be separated by Pipe characters "|", e.g. "Excel files (*.xls)|XML files (*.xml)".

  • File name extensions for Opening

File name extensions for opening files of this type (e.g. ".xls"). If not indicated, the new document type is not visible in the New File dialog box. If more than one extension is indicated, they must be separated by Pipe characters "|", e.g. ".xls|.xml".

  • Name of Save filter

Description of the document type and the file filter for saving this document type. This string is shown in the drop-down list "Save as type" of the "Save as" dialog box (e.g. "Worksheets (*.xls)"). If the filter is not indicated, the file cannot be saved. More than one filter can be indicated, which then must be separated by Pipe characters "|", e.g. "Text file (*.txt)|Log file (*.log)".

  • File name extension for Saving

File name extension for saving files of this type (e.g. ".xls"). For every name of the Save filter the corresponding file name extension must be indicated here. If more than one extensions are indicated, they must be separated by Pipe characters "|", e.g. ".txt|.log".

  • Description for creating this document type

E.g. "Creates a text file." This description is shown in the New File dialog box if the document type is selected in the "Templates" field.

  • Identification of the document type in the registry

This string is for saving of the document type in the registry, which is managed by Windows (e.g. "ExcelWorksheet"). It is used for internal purposes only. If this string is not indicated, the document type cannot be registered at the Windows file manager.

  • Name of the document type in the registry

This string can be shown in dialog boxes of applications, which accesses the registry (e.g. "Microsoft Excel Worksheet").

  • Resource ID of the icon

The icon's resource ID in the module, that contains the implementation of the Add-in. This icon is used for representation of the document type in the File New dialog box.

  • Reserved

This string is reserved for internal purposes and must be empty.

DocumentCLSID

A String containing a ClassID of a COM object or ActiveX control that represents the document. This string must not be empty.

WindowCLSID

A String containing a ClassID of an Active X control, which will be created for the visual representation of the document. If this string is empty, the ClassID specified in the DocumentCLSID parameter is used to represent this document and the visual representation of the document. If both DocumentCLSID and WindowCLSID are specified and are different, individual COM/ActiveX objects are used for the document and its visual representation.

Binary

A Boolean value that indicates whether the document is saved binary or as ASCII text.

Remarks

Only Add-ins can invoke the AddDocumentType method. VBScript Macros are not capable of this.


AddItem Method

Applies to: MessageFilter object, Project object, ProjectItems collection

Adds a sub-item to an object or collection.

Syntax

object.AddItem

or

object.AddItem ( Name, Kind )

Parameters

object

An expression that evaluates to one of the objects in the Applies To list above.

Name

A String representing the name of the new project item object.

Kind

A String that defines the kind of the project item to be created. The kind of the project item is a GUID string, as it is returned by the Kind property.

Return values

The AddItem method returns the newly created MessageFilterItem object or ProjectItem object.

Example

The following example adds a new message filter to the current project:

VBS Macro

Sub AddItemExample()

Dim item

Set item = ActiveProject.AddItem("MyFilter", _

peProjectItemKindMessageFilter);

End Sub


AddKeybinding Method

Applies to: Application object

Assigns a key combination to a command.

Syntax
C++

HRESULT _stdcall AddKeybinding(

BSTR szKey,

BSTR szCommandName

);
C#

void AddKeybinding(

string szKey,

string szCommandName

);
Delphi

function AddKeybinding(

szKey: WideString,

szCommandName: WideString

): HResult; stdcall;
Parameters

szKey

A String that specifies the key combination which is needed for executing the command. The string has the format "CTRL+ALT+SHIFT+A", where CTRL, ALT, and SHIFT must always be indicated in this order.

szCommandName

A String that defines the command, which is executed by the key combination.

Remarks

If the user removes (uninstalls) an Add-in, PCAN-Explorer does not automatically remove the key combination that was added when installing the Add-in, since the user could have changed the key combination in the meantime.

Attention: If key combinations are not absolutely necessary, they shouldn't be added since they can get into conflict with existing key combinations, what can have unforeseeable consequences for the user.

The AddKeyBinding method is usually called in the implementation of the IPEExtensibility.OnConnection method.

Examples

The following code binds a key combination to an Add-in command:

Visual C++

if (bFirstTime == VARIANT_TRUE)

{

CComBSTR bszKeystroke("CTRL+4");

if (FAILED(pApplication->AddKeybinding(bszKeystroke, bszCmdName)))

{

// Handle the error, e.g.

*res = VARIANT_FALSE;

return S_OK;

}

}
C#

if (bFirstTime)

{

try

{

this.app.AddKeybinding("CTRL+4", cmdName);

}

catch

{

// Handle the error, e.g.

return false;

}

}
Delphi

if bFirstTime then

begin

if Failed(pApplication.AddKeybinding('CTRL+4', cmdName)) then

begin

// Handle the error, e.g.

res := False;

Result := S_OK;

Exit;

end;

end;

See also

AddCommand Method | Adding Commands to PCAN-Explorer | AddCommandBarButton Method | SetAddInInfo Method


ApplyFilter Method

Applies to: Tracer object

Filters the buffer contents of a Tracer. Creates a new Tracer containing the filtered buffer.

Syntax

object.ApplyFilter ( )

Parameters

object

An expression that evaluates to a Tracer object.

Return value

If successful, the ApplyFilter method returns the newly created Tracer object.

Example

The following example filters the buffer contents of a Tracer:

VBS Macro

Sub ApplyFilterExample()

Dim tracer, FilteredTracer

' Get the tracer

Set tracer = Windows("MyTracer.trc").Object.Tracer

' Select a filter to be applied

Set tracer.Filter = MessageFilters("MyFilter")

' Now filter the buffer and show the resulting

' number of messages

Set FilteredTracer = tracer.ApplyFilter

If Not FilteredTracer Is Nothing Then _

MsgBox FilteredTracer.Messages.Count

End Sub

See also

Filter Property

MessageFilters Property


Arrange Method

Applies to: Windows collection

Arranges, maximises, or minimizes all open windows.

Syntax

object.Arrange state

Parameters

object

An expression that evaluates to a Windows collection.

state

An enum of the type PeArrangeStyle, which sets the state of the windows. In the following the possible values, which are of the type Long:

  • peCascade: Cascades windows.

  • peMinimize: Minimizes windows.

  • peTileHorizontal: Arranges the windows separated horizontally.

  • peTileVertical: Arranges the windows separated vertically.

Example

The following example arranges all open windows separated horizontally:

VBScript

Windows.Arrange peTileHorizontal


Backspace Method

Applies to: TextSelection object

Executes the function of the backspace key.

Syntax

object.Backspace [count]

Parameters

object

An expression that evaluates to a TextSelection object.

count

(Optional) A Long value indicating the number of repetitions, how many times the action shall be executed. The standard value is 1.

Remarks

If no selection exists, the Backspace method deletes the character on the left of the cursor position.

Example

The following example moves the cursor two columns to the left and deletes the characters in these columns:

VBScript

If ActiveDocument.Type = "Text" Then

ActiveDocument.Selection.Backspace 2

End If

See also

Cut Method


BeginUpdate Method

Applies to: Connection object, Project object, ProjectItem object, Signal object, TransmitMessage object

Acquires a lock on the object.

Syntax

object.BeginUpdate

Parameters

object

An expression that evaluates to one of the objects in the Applies To list above.

See also

EndUpdate Method


CalculateStatisticsFromTracer Method

Applies to: Signal object

Calculates the statistical values accessible through the properties RunningMin, RunningMinTime, RunningMax, RunningMaxTime, and RunningMean from the recorded messages of a tracer.

Syntax

object.CalculateStatisticsFromTracer tracer

Parameters

object

An expression that evaluates to a Signal object.

tracer

An expression that evaluates to a Tracer object.

Remarks

Calling this method sets the StatisticsEnabled property to False, so that the statistical values are not altered by other currently received or transmitted messages.

Example

The following example calculates the statistical values of messages recorded by a tracer:

VB Script

Sub CalculateStatisticsFromTracerExample()

Dim doc, tracer, sig

' Open a Trace file

Set doc = Documents.Open("MyTrace.trc")

Set tracer = doc.ActiveWindow.Object.Tracer

Do While tracer.TraceState = peTraceLoading

Wait 10

Loop

' Calculate statistics and print the results

Set sig = Signals("Speed")

sig.CalculateStatisticsFromTracer(tracer)

PrintToOutputWindow "Min=" & sig.RunningMin

PrintToOutputWindow "Max=" & sig.RunningMax

PrintToOutputWindow "Mean value=" & sig.RunningMean

End Sub

See also

StatisticsEnabled Property

RunningMin Property

RunningMinTime Property

RunningMax Property

RunningMaxTime Property

RunningMean Property


CanAddItem Method

Applies to: ProjectItems collection

Checks, whether an item of a specific kind can be added to a ProjectItems collection.

Syntax

object.CanAddItem ( Name, Kind )

Parameters

object

An expression that evaluates to a ProjectItems collection.

Name

A String representing the name of the item to be added to the collection.

Kind

A String that defines the kind of the item to be added. The kind of the project item is a GUID string, as it is returned by the Kind property.

Return values

The CanAddItem method returns a Boolean value:

  • True: The specified item can be added to the collection.

  • False: The specified item cannot be added to the collection.


Cancel Method

Applies to: TextSelection object

Removes a selection without deleting the selected text.

Syntax

object.Cancel

Parameters

object

An expression that evaluates to a TextSelection object.

Example

The following example removes the current selection:

VBScript

If ActiveDocument.Type = "Text" Then

ActiveDocument.Selection.Cancel

End If


CharLeft Method

Applies to: TextSelection object

Moves the cursor position one character to the left.

Syntax

object.CharLeft [extend] [, count]

Parameters

object

An expression that evaluates to a TextSelection object.

extend

(Optional) An enum of the type PeMovementOptions, which determines what to be done with the selection. Possible values are:

  • peExtend: Extends the selection (this corresponds to the key combination SHIFT+LEFT ARROW).

  • peMove: The selection is not extended (default value).

count

(Optional) A Long value indicating the number of repetitions, how many times the action shall be executed. The standard value is 1.

Remarks

The CharLeft method has the same effect as pressing the key LEFT ARROW.

Example

The following example extends the selection 2 characters to the left:

VBS Macro

If ActiveDocument.Type = "Text" Then

ActiveDocument.Selection.CharLeft peExtend, 2

End If


CharRight Method

Applies to: TextSelection object

Moves the cursor position one character to the right.

Syntax

object.CharRight [extend] [, count]

Parameters

object

An expression that evaluates to a TextSelection object.

extend

(Optional) An enum of the type PeMovementOptions, which determines what to be done with the selection. Possible values are:

  • peExtend: Extends the selection (this corresponds to the key combination SHIFT+RIGHT ARROW).

  • peMove: Does not extend the selection (default value).

count

(Optional) A Long value indicating the number of repetitions, how many times the action shall be executed. The standard value is 1.

Remarks

The CharRight method has the same effect as pressing the key RIGHT ARROW.

Example

The following example extends the selection 2 characters to the right:

VBS Macro

If ActiveDocument.Type = "Text" Then

ActiveDocument.Selection.CharRight peExtend, 2

End If


ClaimAddress Method

Applies to: J1939Node object

Claims a J1939 address.

Syntax

object.ClaimAddress

Parameters

object

An expression that evaluates to a J1939Node object.

Return values

The ClaimAddress method returns one of the following values:

  • True: Claiming the address was successful.

  • False: An error occurred while claiming the address. The LastError property of the J1939Node object provides information about the cause of the error.

Remarks

The ClaimAddress method tries to claim the address that was specified in the PreferredAddress property. After an address has been successfully claimed, the actual claimed address can be obtained from the ClaimedAddress property.

See also

ReleaseAddress Method


Clear Method

Applies to: J1939Filters collection, Messages collection, OutputWindowPane object, ReceiveMessages collection, Tracer object, TransmitMessages collection

Removes all elements from the collection or object.

Syntax

object.Clear

Parameters

object

An expression that evaluates to one of the objects in the Applies To list above.

Example

The following example deletes all CAN messages from the Receive List:

VBS Macro

Sub ClearExample()

ReceiveMessages.Clear

End Sub


ClearItems Method

Applies to: MessageFilter object

Clears the filter items collection.

Syntax

object.ClearItems

Parameters

object

An expression that evaluates to a MessageFilter object.


Close Method

Applies to: Document object, TextDocument object, Window object

Closes a document and optionally saves it, or closes and destroys a window.

Syntax

object.Close ( [SaveChanges] )

Parameters

object

An expression that evaluates to one of the objects in the Applies To list above.

SaveChanges

(Optional) An enum of type PeSaveChanges that specifies the save action for the document or window. Can be one of the following values, which are of the Long type:

  • peSaveChangesYes (1): Saves pending changes without prompting the user (default).

  • peSaveChangesNo (2): Does not save pending changes.

  • peSaveChangesPrompt (3): Prompts the user to save pending changes.

Return value

The Close method returns a PeSaveStatus enum value having one of the following values:

  • peSaveCanceled: The user has canceled the save operation.

  • peSaveSucceeded: The user has saved the pending changes of the document.

Remarks

The following table summarizes the results of the use of Close on the objects mentioned above:

Object | Results
Document TextDocument | Closes all windows that are related to the document. These windows are removed from the Windows collection, which can be accessed by using the Windows property of the Application object. Closes the document and removes it from the Documents collection.
Window | Closes the window and removes it from the Windows collection, which can be accessed by using the Windows property of the Application object. If the window is the only one displaying an open document, this document is also closed and removed from the Documents collection.
Example

The following example saves all changes of the active document and closes the associated window:

VBScript

ActiveDocument.Close


CloseAll Method

Applies to: Documents object, Windows object

Closes all windows or documents.

Syntax

object.CloseAll ( [SaveChanges] )

Parameters

object

An expression that evaluates to a Documents or a Windows collection.

SaveChanges

(Optional) An enum of the type PeSaveChanges, which determines, if the changes of one or several documents shall be saved before the document is closed. In the following the possible values (type Long):

  • peSaveChangesYes: Saves all changes (default).

  • peSaveChangesNo: Does not save changes; no confirmation from the user.

  • peSaveChangesPrompt: Prompts the user to confirm the saving. If the user choses not to save the changes, CloseAll returns the enum peSaveStatus with the value peSaveCanceled. Otherwise CloseAll returns peSaveSucceeded.

Return value

The method CloseAll returns an enum PeSaveStatus having one of the following values:

  • peSaveCanceled: Indicates, that the user has chosen not to save the changes of the document.

  • peSaveSucceeded: Indicates, that the user has saved the changes of the document.

Example

The following example saves the changes of all open documents and then closes them:

VBScript

Documents.CloseAll

See also

Open Method


Connect Method

Applies to: J1939Node object

Establishes a CAN connection for the object.

Syntax

object.Connect

Parameters

object

An expression that evaluates to a J1939Node object.

Return values

The Connect method returns a Boolean value:

  • True: Establishing the CAN connection was successful.

  • False: An error occurred while establishing the connection. The LastError property of the J1939Node object provides information about the cause of the error.

Remarks

The Connect method uses the Device, ClientName, and NetName properties initialize the connection.

See also

Disconnect Method


ConnectDialog Method

Applies to: PCANClientConnection object

Shows a dialog box for establishing a connection to a PCAN net.

Syntax

object.ConnectDialog

Parameters

object

An expression that evaluates to a PCANClientConnection object.

Return values

The ConnectDialog method returns one of the following values:

  • True: A connection to the selected net has been established.

  • False: The user has closed the dialog box without selecting a net, or a connection to the net couldn't be established due to an error. In case of an error, the LastError property of the parent PCANClient object provides information about the cause of the error.

Example

The following example shows the dialog box for establishing a PCAN net connection:

VBS Macro

Sub ConnectDialogExample()

Dim client, conn

Set client = CreateObject("PCAN4.PCANClient")

client.Device = "pcan_usb"

client.Name = "Macro"

Set conn = client.Connections.Add("")

If conn.ConnectDialog Then

' Connection successful

MsgBox "Connected to " & conn.NetName & "@" & client.Device

End If

End Sub


Copy Method

Applies to: TextSelection object

Copies the selected text into the clipboard.

Syntax

object.Copy

Parameters

object

An expression that evaluates to a TextSelection object.

Example

The following example copies the selected text into the clipboard:

VBS Macro

Sub CopyExample()

If ActiveDocument.Type = "Text" Then _

ActiveDocument.Selection.Copy

End Sub

See also

Cut Method

Paste Method


Cut Method

Applies to: TextSelection object

Deletes the selected text and puts it into the clipboard.

Syntax

object.Cut

Parameters

object

An expression that evaluates to a TextSelection object.

Example

The following example deletes the selected text and puts it into the clipboard:

VBS Macro

Sub CutExample()

If ActiveDocument.Type = "Text" Then _

ActiveDocument.Selection.Cut

End Sub

See also

Copy Method

Paste Method


Delete Method

Applies to: TextSelection object

Executes the function of the key DEL.

Syntax

object.Delete [count]

Parameters

object

An expression that evaluates to a TextSelection object.

count

(Optional) A Long value indicating the number of repetitions, how many times the action shall be executed. The standard value is 1.

Remarks

If no selection exists, the Delete method deletes the character on the right of the cursor position.

Example

The following example deletes the selected text:

VBScript

If ActiveDocument.Type = "Text" Then

ActiveDocument.Selection.Delete

End If

See also

Cut Method


Disconnect Method

Applies to: J1939Node object

Closes the CAN connection of the object.

Syntax

object.Disconnect

Parameters

object

An expression that evaluates to a J1939Node object.

See also

Connect Method


Duplicate Method

Applies to: MessageFilters collection

Duplicates a message filter.

Syntax

object.Duplicate ( Value )

Parameters

object

An expression that evaluates to a MessageFilters collection.

Value

The message filter that is to be duplicated.

Return values

The Duplicate method returns the newly created MessageFilter object.

Example

The following example creates a copy of a message filter:

VBS Macro

Sub DuplicateExample()

Dim filter, filterCopy

Set filter = MessageFilters.Item("MyFilter")

Set filterCopy = MessageFilters.Duplicate(filter)

End Sub


EndOfLine Method

Applies to: TextSelection object

Moves the cursor position to the end of the last row of a selection.

Syntax

object.EndOfLine [extend]

Parameters

object

An expression that evaluates to a TextSelection object.

extend

(Optional) A value of the PeMovementOptions enum that determines what to be done with the selection. Possible values are:

  • peExtend: Extends the selection (this corresponds to the key combination SHIFT+END).

  • peMove: Does not extend the selection (default value).

Remarks

The EndOfLine method has the same effect as pressing the key END.

Example

The following example moves the cursor position to the end of the line:

VBS Macro

Sub EndOfLineExample()

If ActiveDocument.Kind = peDocumentKindText Then _

ActiveDocument.Selection.EndOfLine

End Sub


EndUpdate Method

Applies to: Connection object, Project object, ProjectItem object, Signal object, TransmitMessage object

Releases a lock and updates the object.

Syntax

object.EndUpdate

Parameters

object

An expression that evaluates to one of the objects in the Applies To list above.

See also

BeginUpdate Method


ExecuteCommand Method

Applies to: Application object

Executes a specified command.

Syntax

object.ExecuteCommand command

Parameters

object

An expression that evaluates to an Application object.

command

A String that represents the command that shall be executed.

Remarks

Commands can also be executed by specifying command names in the command line, or by using toolbar buttons or key combinations that are linked to the commands.

Attention

Do not execute the ApplicationExit command from a VBS macro. Use the Application.Quit method instead.
Example

The following example starts a new tracer:

VBScript

ExecuteCommand "TraceStartNew"

See also

PCAN-Explorer Commands


FindID Method

Applies to: Messages collection, ReceiveMessages collection, TransmitMessages collection

Returns a Messages collection, which contains only CAN messages with the requested CAN ID.

Syntax

object.FindID ( id )

Parameters

object

An expression that evaluates to one of the objects in the Applies To list above.

id

A Long value indicating the requested CAN ID.

Return values

The FindID method returns a Messages collection.

Example

The following example searches through the reception list for CAN messages with the ID 200h:

VBS Macro

Sub FindIDExample()

Dim msgs

Set msgs = ReceiveMessages.FindID(&H200)

MsgBox msgs.Count & " message(s) found."

End Sub


FindMultiplexer Method

Applies to: Messages collection, ReceiveMessages collection, TransmitMessages collection

Returns a Messages collection, which contains only CAN messages that are compatible with the specified Multiplexer.

Syntax

object.FindMultiplexer ( mux )

Parameters

object

An expression that evaluates to one of the objects in the Applies To list above.

mux

The requested Multiplexer.

Return values

The FindMultiplexer method returns a Messages collection.

Example

The following example searches through the reception list for CAN messages that are compatible with the Multiplexer "RcvSymbol.Mux1":

VBS Macro

Sub FindMultiplexerExample()

Dim mux

Set mux = SymbolsManager("Sample").Item("RcvSymbol").Multiplexers("Mux1")

Dim msgs

Set msgs = ReceiveMessages.FindMultiplexer(mux)

MsgBox msgs.Count & " message(s) found."

End Sub


FindOrdinal Method

Applies to: Enum object

Searches for an ordinal in the Enum.

Syntax

object.FindOrdinal ( String )

Parameters

object

An expression that evaluates to an Enum object.

String

A String containing the text, for which an associated ordinal is searched.

Return values

The FindOrdinal method returns the one-based index of the found ordinal in the list. If no ordinal is associated with the specified text, the FindOrdinal method returns the value 0.

Example

The following example searches for an ordinal in the Enum "MyEnum" and displays it in a message box:

VBS Macro

Sub FindOrdinalExample()

Dim myEnum, index, ord

Set myEnum = SymbolsManager.Enums("MyEnum")

index = myEnum.FindOrdinal("Value1")

If index > 0 Then

ord = myEnum.GetOrdinal(index)

MsgBox ord

End If

End Sub

See also

FindString Method

GetOrdinal Method

GetString Method


FindString Method

Applies to: Enum object

Searches for a text in the Enum by its associated ordinal.

Syntax

object.FindString ( ordinal )

Parameters

object

An expression that evaluates to an Enum object.

ordinal

A Long representing the ordinal, for which an associated text is searched.

Return values

The FindString method returns a string that is associated with the specified ordinal. If no text is associated with the ordinal, the FindString method returns an empty string.

Example

The following example searches an ordinal in the Enum "MyEnum" and displays its associated text in a message box:

VBS Macro

Sub FindStringExample()

Dim myEnum, str

Set myEnum = SymbolsManager.Enums("MyEnum")

str = myEnum.FindString(43)

MsgBox str

End Sub

See also

FindOrdinal Method

GetOrdinal Method

GetString Method


FindSymbol Method

Applies to: Messages collection, ReceiveMessages collection, TransmitMessages collection

Returns a Messages collection, which contains only CAN messages that are compatible with the specified Symbol.

Syntax

object.FindSymbol ( sym )

Parameters

object

An expression that evaluates to one of the objects in the Applies To list above.

sym

The requested Symbol.

Return values

The FindSymbol method returns a Messages collection.

Example

The following example searches through the reception list for CAN messages that are compatible with the Symbol RcvSymbol:

VBS Macro

Sub FindSymbolExample()

Dim sym

Set sym = SymbolsManager("Sample").Item("RcvSymbol")

Dim msgs

Set msgs = ReceiveMessages.FindSymbol(sym)

MsgBox msgs.Count & " message(s) found."

End Sub


FindText Method

Applies to: TextSelection object

Starting with the end of the current selection FindText searches through the rest of the document for specific strings. If the string has been found, FindText moves the selection to this place.

Syntax

object.FindText ( string [,flags] )

Parameters

object

An expression that evaluates to a TextSelection object.

string

A String, which shall be searched for.

flags

(Optional) An enum of the type PeTextSearchOptions, which determines how the search shall be carried out. For complex search operations the values can be combined. The values, that can be combined, are:

  • peMatchForward: Searches forwards in the document. This is the standard value.

  • peMatchBackward: Searches backwards in the document.

  • peMatchFromStart: Searches from the beginning or from the end of the document. If a forward search is started (peMatchForward), it begins at the beginning of the document. If a backward search is started (peMatchBackward), it begins at the end of the document.

  • peMatchWord: Searches for whole words.

  • peMatchCase: The case sensitivity of the string searched for is considered.

Return values

The FindText method returns one of the following values:

  • True: The search has been successful.

  • False: The search hasn't been successful.

Remarks

The values of the flags parameter can be combined by using the or operator or the concatenation operator +. If, for example, a search shall be carried out, in which the case sensitivity is considered, specify either peMatchForward or peMatchCase or peMatchForward + peMatchCase.

Example

The following example carries out a search for the word "Receive":

VBS Macro

Sub FindTextExample()

ActiveDocument.Selection.FindText "receive", peMatchWord

End Sub


Get Method

Applies to: J1939Filters collection

Retrieves all parameters of a filter by its index.

Syntax

C++

HRESULT _stdcall Get(

int Index,

TFilterMask *Flags,

unsigned int *PGN,

unsigned char *Priority,

unsigned char *Source,

unsigned char *Destination,

/* [out, retval] */ VARIANT_BOOL *res

);

C#

bool Get(

int Index,

ref J1939Pcan.TFilterMask Flags,

ref uint PGN,

ref byte Priority,

ref byte Source,

ref byte Destination

);

Delphi

function Get(

Index: Integer;

out Flags: TFilterMask;

out PGN: LongWord;

out Priority: Byte;

out Source: Byte;

out Destination: Byte

): WordBool; stdcall;
Parameters

Index

The 1-based index of the filter in the collection.

Flags

Returns the contents of the Flags property of the object.

PGN

Returns the contents of the PGN property of the object.

Priority

Returns the contents of the Priority property of the object.

Source

Returns the contents of the SourceAddress property of the object.

Destination

Returns the contents of the DestinationAddress property of the object.

Return values

The Get method returns a Boolean value:

  • True: The parameters were retrieved successfully.

  • False: The specified index did not correspond to any item in the collection.

Remarks

Only Add-ins can invoke the Get method. VBScript Macros are not capable of this.


GetDriverParam Method

Applies to: PCANClient object

Retrieves the value of a PCAN driver parameter.

Syntax

object.GetDriverParam ( Param, pValue )

Parameters

object

An expression that evaluates to a PCANClient object.

Param

An enum of the type PCANParameter, which contains the type of the parameter to be retrieved. The GetDriverParam method supports the following parameters:

Parameter | Description
pcanParamDriverType | Returns the type of the device driver: 0 = Unknown, 1= Win9x, 2 = WinNT, 3 = WDM, 4 = WDF
pcanParamRcvQueueSize | Returns the size of Receive Queues (default = 32768)
pcanParamXmtQueueSize | Returns the size of Transmit Queues (default = 32768)
pcanParamAutoBusOn | This parameter indicates whether a CAN hardware is automatically set into a passive BUS-ON mode after its CAN controller reached the BUS-OFF state. 0 = Auto-BUS-ON disabled, 1 = Auto-BUS-ON enabled (default)

pValue

A pointer or reference to a Variant, which receives the parameter's value.

Return values

The GetDriverParam method returns one of the following values:

  • True: Getting the specified parameter was successful.

  • False: An error occurred while getting the specified parameter. The LastError property of the PCANClient object provides information about the cause of the error.

Example

The following example queries the size of Receive Queues for the pcan_usb device:

VBS Macro

Sub GetDriverParamExample()

Dim client, value

Set client = CreateObject("PCAN4.PCANClient")

client.Device = "pcan_usb"

If client.GetDriverParam(pcanParamRcvQueueSize, value) Then _

MsgBox "Receive Queue Size = " & value

End Sub

See also

SetDriverParam Method


GetErrorText Method

Applies to: PCANClient object

Transforms error codes to text.

Syntax

object.GetErrorText ( Error )

Parameters

object

An expression that evaluates to a PCANClient object.

Error

An enum of the type PCANError, which contains the error code to be analyzed and evaluated.

Return value

The GetErrorText method returns a String containing the error of the given error code, in text format. An error code is an enum of the type PCANError, which also can contain a combination of multiple errors.

Remarks

Error codes are returned directly by some methods of the PCANClient object. However, other methods return a Boolean value. If such a return value is False, this indicates an error and the cause of the error can be retrieved by the LastError property of the PCANClient object. Setting properties of the PCANClient object can also produce error codes.

Example

The following example analyses and evaluates an error code and displays the corresponding text:

VBS Macro

Sub GetErrorTextExample()

Dim client

Set client = CreateObject("PCAN4.PCANClient")

client.Device = "pcan_usb"

client.Name = "Macro"

If Not client.IsRegistered Then

' Error while registering client at PCAN system

MsgBox "Error: " & client.GetErrorText(client.LastError)

End If

End Sub

See also

GetLongErrorText Method

LastError Property

LastErrorText Property


GetHardwareParam Method

Applies to: PCANClient object

Retrieves the value of a CAN hardware parameter.

Syntax

object.GetHardwareParam ( HardwareHandle, Param, pValue )

Parameters

object

An expression that evaluates to a PCANClient object.

HardwareHandle

A Long value, which indicates the handle of the hardware, for which a parameter shall be retrieved.

Param

An enum of the type PCANParameter, which contains the type of the parameter to be retrieved. In the following the possible values and the meaning of the respective parameter:

Parameter | Description
pcanParamAccCode | The acceptance code of the message filter (Long value).
pcanParamAccMask | The acceptance mask of the message filter (Long value).
pcanParamActive | A Long value indicating if the CAN controller is in reset state or if it is actively working at the CAN bus.
pcanParamBitrate | The current bit rate of the CAN controller (Long value). The bit rate is a 16-bit value, which is a combination of the two 8-bit bus timing registers BTR0 and BTR1 of the SJA1000 CAN controller (only for non-FD bit rates).
pcanParamBitCnt | The total number of transmitted and received bits (Long value).
pcanParamHwDriverNo | A Long value indicating the kind of driver that manages the hardware (USB, PCI,...).
pcanParamHwInt | The interrupt used by the hardware (Long value).
pcanParamHwNet | A Long value, which indicates the handle of the net, the hardware is part of.
pcanParamHwPort | The I/O address used by the hardware (Long value).
pcanParamListenOnly | A Long value indicating whether the ListenOnly mode of the attached CAN hardware is enabled. 0 = disabled (default), 1 = enabled
pcanParamMsgCnt | The total number of transmitted and received messages (Long value).
pcanParamName | A String containing the name of the hardware.
pcanParamRcvBitCnt | The total number of received bits (Long value).
pcanParamRcvErrFrames | A Long value indicating whether the CAN hardware is configured for the reception of Error Frames. The value 1 indicates that Error Frames are received.
pcanParamRcvMsgCnt | The number of messages received in all (Long value).
pcanParamXmtBitCnt | The total number of transmitted bits (Long value).
pcanParamXmtMsgCnt | The total number of transmitted messages (Long value).
pcanParamXmtQueueFill | The number of messages in the transmit queue not being sent (Long value).

pValue

A pointer or reference to a Variant, which receives the parameter's value.

Return values

The GetHardwareParam method returns one of the following values:

  • True: Getting the specified parameter was successful.

  • False: An error occurred while getting the specified parameter. The LastError property of the PCANClient object provides information about the cause of the error.

Example

The following example creates a new PCAN client, connects it to the PCAN net "TestNet" on the PCAN-USB device, and retrieves the value of the bus timing register of the CAN controller, if the net is connected to a PCAN-USB adaptor:

VBS Macro

Sub GetHardwareParamExample()

Dim client, conn, btr0btr1

Set client = CreateObject("PCAN4.PCANClient")

client.Device = "pcan_usb"

client.Name = "Macro"

Set conn = client.Connections.Add("TestNet")

If conn.HardwareHandle > 0 Then

client.GetHardwareParam conn.HardwareHandle, pcanParamBitrate, btr0btr1

MsgBox "Bus Timing Register = " & Hex(btr0btr1)

End If

End Sub

Note that the value of the bus timing register of the connected Hardware can also be retrieved by using the HardwareBitRate property of the PCANClientConnection object.

See also

SetHardwareParam Method


GetLongErrorText Method

Applies to: PCANClient object

Returns a description of an error code.

Syntax

object.GetLongErrorText ( Error )

Parameters

object

An expression that evaluates to a PCANClient object.

Error

An enum of the type PCANError, which contains the error code to be analyzed and evaluated.

Return value

The GetLongErrorText method returns a String containing the description of the error of the given error code. An error code is an enum of the type PCANError, which also can contain a combination of multiple errors. If the error code consists of multiple errors, the individual descriptions are separated by commas.

Remarks

Error codes are returned directly by some methods of the PCANClient object. However, other methods return a Boolean value. If such a return value is False, this indicates an error and the cause of the error can be retrieved by the LastError property of the PCANClient object. Setting properties of the PCANClient object can also produce error codes.

Example

The following example analyses and evaluates an error code and displays the corresponding text:

VBS Macro

Sub GetLongErrorTextExample()

Dim client

Set client = CreateObject("PCAN4.PCANClient")

client.Device = "pcan_usb"

client.Name = "Macro"

If Not client.IsRegistered Then

' Error while registering client at PCAN system

MsgBox "Error: " & client.GetLongErrorText(client.LastError)

End If

End Sub

See also

GetErrorText Method

LastError Property

LastErrorText Property


GetNetParam Method

Applies to: PCANClient object

Retrieves the value of a PCAN net parameter.

Syntax

object.GetNetParam ( NetHandle, Param, pValue )

Parameters

object

An expression that evaluates to a PCANClient object.

NetHandle

A Long value that specifies the handle of the net, for which a parameter shall be retrieved.

Param

A value of the PCANParameter enum that determines the type of the parameter to be retrieved. The following table shows all allowed parameters:

Parameter | Description
pcanParamName | A String containing the name of the net.
pcanParamBitrate | The nominal bit rate that was defined for this net (Long value). The bit rate is a 16-bit value that is used to configure the bus timing registers BTR0 and BTR1 of the SJA1000 CAN controller (only for non-FD nets).
pcanParamMsgCnt | The total number of messages that were received and sent on the net (Long value).
pcanParamBitCnt | The total number of bits that were received and sent on the net (Long value).
pcanParamNetHw | The hardware handle of the net (Long value). If the net is not connected to a hardware, the value 0 is returned.
pcanParamNetClients | A String, containing the character code 1 for any possible client handle if this is connected to the net (otherwise 0). The index of the characters in the string corresponds to the client handles.
pcanParamRcvErrFrames | A Long value that indicates whether the connected CAN hardware is configured for the reception of Error Frames. The value 1 indicates that Error Frames are received.

pValue

A pointer or reference to a Variant, which receives the parameter's value.

Return values

The GetNetParam method returns one of the following values:

  • True: Getting the specified parameter was successful.

  • False: An error occurred while getting the specified parameter. The LastError property provides information about the cause of the error.

Example

The following example retrieves the total number of messages that were received and sent on the currently connected net:

VBS Macro

Sub GetNetParamExample()

Dim client, conn, count

Set client = CreateObject("PCAN4.PCANClient")

client.Device = "pcan_usb"

client.Name = "Macro"

Set conn = client.Connections.Add("TestNet")

If conn.HardwareHandle > 0 Then

client.GetNetParam conn.NetHandle, pcanParamMsgCnt, count

MsgBox "Number of messages = " & count

End If

End Sub


GetOrdinal Method

Applies to: Enum object

Retrieves an ordinal from the Enum by its index.

Syntax

object.GetOrdinal ( index )

Parameters

object

An expression that evaluates to an Enum object.

index

A Long, that is the one-based index of the ordinal in the Enum.

Return values

The GetOrdinal method returns an ordinal from the Enum via its 1-based index.

Example

The following example retrieves all ordinals that are defined in the Enum "MyEnum" and shows them in the Output window:

VBS Macro

Sub GetOrdinalExample()

Dim myEnum, ord, i

Set myEnum = Enums("MyEnum")

For i = 1 To myEnum.Count

ord = myEnum.GetOrdinal(i)

PrintToOutputWindow ord

Next

End Sub

See also

FindOrdinal Method

FindString Method

GetString Method


GetParam Method

Applies to: PCANClient object

Retrieves the value of a PCAN client parameter.

Syntax

object.GetParam ( Param, pValue )

Parameters

object

An expression that evaluates to a PCANClient object.

Param

An enum of the type PCANParameter, which contains the type of the parameter to be retrieved. In the following the possible values and the meaning of the respective parameter:

Parameter | Description
pcanParamName | A String containing the name of the client.
pcanParamAccCode | The acceptance code of the message filter (Long value).
pcanParamAccMask | The acceptance mask of the message filter (Long value).
pcanParamXmtQueueFill | The number of unsent messages in the transmit queue (Long value).
pcanParamRcvQueueFill | The number of unprocessed messages in the receive queue (Long value).
pcanParamRcvMsgCnt | The total number of received messages (Long value).
pcanParamRcvBitCnt | The total number of received bits (Long value).
pcanParamXmtMsgCnt | The total number of sent messages (Long value).
pcanParamXmtBitCnt | The total number of transmitted bits (Long value).
pcanParamMsgCnt | The total number of sent and received messages (Long value).
pcanParamBitCnt | The total number of sent and received bits (Long value).
pcanParamHwnd | The window handle of the application that owns this client (Long value).
pcanParamClNets | A String, containing the character code 1 for any possible net handle if the net is connected to the client (otherwise 0). The index of the characters in the string correspond to the net handles.
pcanParamOnRcvEventHandle | Handle of the Receive event, which is triggered when a message is received (Long value).
pcanParamOnRcvEventPulse | A Long value that indicates whether the Receive event is operated in Set mode (0) or Pulse mode (1).
pcanParamSelfReceive | A Long value that indicates whether the client receives messages sent by itself.
pcanParamRcvErrFrames | A Long value that indicates whether the client is configured for the reception of Error Frames. The value 1 means that Error Frames are received.

pValue

A pointer or reference to a Variant, which receives the parameter's value.

Return values

The GetParam method returns a Boolean value:

  • True: Getting the specified parameter was successful.

  • False: An error occurred while getting the specified parameter. The LastError property of the PCANClient object provides information about the cause of the error.

Example

The following example retrieves the number of messages received by the client that belongs to the first CAN connection in the project:

VBS Macro

Sub GetParamExample()

If Connections.Count > 0 Then

Dim conn, client, count

Set conn = Connections(1)

If conn.Protocol = peProtocolCAN Then

' Access the PCANClient object

Set client = conn.CommunicationObject.Parent

If client.GetParam(pcanParamRcvMsgCnt, count) Then _

MsgBox "Number of messages = " & count

End If

End If

End Sub


GetString Method

Applies to: Enum object

Retrieves a text from the Enum by its index.

Syntax

object.GetString ( index )

Parameters

object

An expression that evaluates to an Enum object.

index

A Long, that is the one-based index of the string in the Enum.

Return values

The GetString method returns a string from the Enum by its one-based index.

Example

The following example retrieves all strings that are defined in the Enum "MyEnum" and shows them in the Output window:

VBS Macro

Sub GetStringExample()

Dim myEnum, str, i

Set myEnum = Enums("MyEnum")

For i = 1 To myEnum.Count

str = myEnum.GetString(i)

PrintToOutputWindow str

Next

End Sub

See also

FindOrdinal Method

FindString Method

GetOrdinal Method


GetSystemTime Method

Applies to: J1939Node object, PCANClient object

Returns the number of Milliseconds that have elapsed since the start of Windows.

Syntax

object.GetSystemTime

Parameters

object

An expression that evaluates to a J1939Node object or a PCANClient object.

Remarks

The GetSystemTime method returns a Long value, containing the number of Milliseconds, that have passed since the start of Windows.

The value of this timer serves the PCAN system as basis for the calculation of the point of time, at which messages are sent. PCAN-Explorer provides received messages with a time stamp, which is retrieved from this timer.

Example

The following example retrieves the number of milliseconds since the start of Windows:

VBS Macro

Sub GetSystemTimeExample()

' Please make sure that the active project has at least one

' connection and that the first connection is enabled

If Connections.Count = 0 Then _

Exit Sub

Dim conn, millis

Set conn = Connections(1)

If Not conn.IsEnabled Then _

Exit Sub

If conn.Protocol = peProtocolCAN Then

' Access the PCANClient object

Dim client

Set client = conn.CommunicationObject.Parent

millis = client.GetSystemTime

ElseIf conn.Protocol = peProtocolJ1939 Then

' Access the J1939Node object

Dim node

Set node = conn.CommunicationObject

millis = node.GetSystemTime

End If

MsgBox "Elapsed time = " & millis & " ms"

End Sub


GoToLine Method

Applies to: TextSelection object

Moves the cursor position to a specific line in a document.

Syntax

object.GoToLine line [,select]

Parameters

object

An expression that evaluates to a TextSelection object.

line

A Long value, indicating the line number, to which the cursor position shall be moved. If the value peLastLine is indicated or if line is beyond the last line of the document, the last line of the document is selected.

select

(Optional) An enum of the type PeGoToLineOptions, which determines what to be done with the selection. Possible values are:

  • peSelect: Selects the whole line.

  • peMove: Moves the cursor position to the beginning of the line, but does not select any part of the line (default).

Example

The following example moves the cursor to the third line of a document and selects the whole line:

VBS Macro

Sub GoToLineExample()

' Put a text window in the foreground

' before running this macro

ActiveDocument.Selection.GoToLine 3, peSelect

End Sub


Item Method

Applies to: AddIns collection, Connections collection, Documents collection, Enums collection, OutputWindowPanes collection, MessageFilter object, MessageFilters collection, Multiplexers collection, PCANClientConnections collection, PCANMessages collection, ReceiveMessages collection, Signals collection, Symbols collection, SymbolsManager collection, TraceMessages collection, TransmitMessages collection, Variables collection, VBSMacroFiles collection, Windows collection

Retrieves a specific CAN message, connection, document, Enum, window, Signal, Symbol, Symbols collection, message filter, Multiplexer, Add-in, or VBS Macro file from a collection.

Syntax

object.Item ( index )

or

object ( index )

Parameters

object

An expression that evaluates to one of the objects in the Applies To list above.

index

A Variant that is a Long or String representing the appropriate object.

  • If you specify a Long, the Item method fetches the object by its 1-based index in the collection.

  • If you specify a String, it must be one of the strings described in the following table:

Returned Object String

AddIn

The Add-in's name (as defined in the Name property).

Connection

The connection' name (as defined in the Name property).

Document

The document's file name.

The file name can be given with its full path. If only the file name is indicated, PCAN-Explorer tries to find an open document with this name. If however more than one document with the same name are open, the Item method returns the document found first.

Enum

The Enum's name (as defined in the Name property).

MessageFilter

The message filter's name (as defined in the Name property).

Multiplexer

The Multiplexer's name (as defined in the Name property).

OutputWindowPane

The tab's name (as defined in the Name property).

PCANClientConnection

The name of the PCAN net, with which the object is connected (as defined in the NetName property).

Signal

The Signal's name (as defined in the Name property).

Symbol

The Symbol's name (as defined in the Name property).

Symbols

  • The Symbols file's title (as defined in the Title property).

  • The full file name of the Symbols file.

Variable

The Variable's name (as defined in the Name property).

VBSMacroFile

The VBS Macro file's display name (as defined in the DisplayName property) or the VBS Macro file's full file name (as defined in the FullName property)

Window

  • The window's title (as defined in the Caption property).

  • A GUID string, which defines the kind of the window, that shall be accessed (as defined in its property ObjectKind).
Remarks

If you specify numbers for index, do not store these for later use because the indices might change as objects are added or removed.

The Item method is the default method of a collection. Accordingly, you don't have to reference Item explicitly, as shown in the following example.

If the Item method of one of the collections PCANMessages, ReceiveMessages, TraceMessages, TransmitMessages, or of the MessageFilter object is used, the value of index must be specified as a number.

Examples

The following example prints all open documents:

VBS Macro

For num = 1 To Documents.Count

Documents(num).PrintOut

Next

The following example prints the document with the name "MyDocument":

VBS Macro

Documents("MyDocument").PrintOut

The following example sends the Multiplexer "Mux1" of the Symbol "MySymbol":

VBS Macro

Dim symbols

Set symbols = SymbolsManager("My Symbols")

symbols.Item("MySymbol").Multiplexers("Mux1").Send peSendOnce


LineDown Method

Applies to: TextSelection object

Moves the cursor position one line downward.

Syntax

object.LineDown [extend] [, count]

Parameters

object

An expression that evaluates to a TextSelection object.

extend

(Optional) An enum of the type PeMovementOptions, which determines what to be done with the selection. Possible values are:

  • peExtend: Extends the selection (this corresponds to the key combination SHIFT+DOWN ARROW).

  • peMove: Does not extend the selection (default value).

count

(Optional) A Long value indicating the number of repetitions, how many times the action shall be executed. The standard value is 1.

Remarks

The LineDown method has the same effect as pressing the key DOWN ARROW.

Example

The following example extends the selection one line downward:

VBS Macro

If ActiveDocument.Type = "Text" Then

ActiveDocument.Selection.LineDown peExtend

End If

See also

LineUp Method


LineUp Method

Applies to: TextSelection object

Moves the cursor position one line upward.

Syntax

object.LineUp [extend] [, count]

Parameters

object

An expression that evaluates to a TextSelection object.

extend

(Optional) An enum of the type PeMovementOptions, which determines what to be done with the selection. Possible values are:

  • peExtend: Extends the selection (this corresponds to the key combination SHIFT+UP ARROW).

  • peMove: Does not extend the selection (default value).

count

(Optional) A Long value indicating the number of repetitions, how many times the action shall be executed. The standard value is 1.

Remarks

The LineDown method has the same effect as pressing the key UP ARROW.

Example

The following example extends the selection one line upward:

VBS Macro

If ActiveDocument.Type = "Text" Then

ActiveDocument.Selection.LineUp peExtend

End If

See also

LineDown Method


MessageToValue Method

Applies to: Variable object

Calculates the variable's value from the data of a given CAN message.

Syntax

object.MessageToValue message

Parameters

object

An expression that evaluates to a Variable object.

message

A ReceiveMessage object, TransmitMessage object, or TraceMessage object. The object's data is used to calculate the variable value.

Return values

The MessageToValue method returns the calculated Double value.

Example

The following example shows the names and values of all Variables of the first message in the Receive List:

VBS Macro

Sub MessageToValueExample()

Dim msg, v, strMsg, val

Set msg = ReceiveMessages(1)

For Each v In msg.Multiplexer.Variables

val = v.MessageToValue(msg)

strMsg = strMsg & v.Name & " = " & val & " " & v.Unit & vbCrLf

Next

MsgBox strMsg,,msg.Symbol.Name

End Sub


MoveTo Method

Applies to: TextSelection object

Moves the cursor position to the given line and column.

Syntax

object.MoveTo line, column [,extend]

Parameters

object

An expression that evaluates to a TextSelection object.

line

A Long value, which defines the new line. Some possible values are:

  • 0: Does not move the cursor position. It stays on the current line.

  • 1: Moves the cursor position to the first line.

  • peLastLine: Moves the cursor position to the last line of the file.

column

A Long value, which defines the new column. Some possible values are:

  • 0: Does not move the cursor position. It stays on the current column.

  • 1: Moves the cursor position to the first column.

  • peEndOfLine: Moves the cursor position to the end of the line.

extend

(Optional) An enum of the type PeMovementOptions, which determines what to be done with the selection. Possible values are:

  • peExtend: Extends the selection.

  • peMove: Does not extend the selection (default value).

Example

The following example moves the cursor to the third column of the second line:

VBS Macro

If ActiveDocument.Type = "Text" Then

ActiveDocument.Selection.MoveTo 2, 3

End If


NewProject Method

Applies to: Application object

Creates a new project.

Syntax

object.NewProject Name, Path

Parameters

object

An expression that evaluates to an Application object.

Name

A String representing the name of the new project. If the string is left blank, PCAN-Explorer automatically creates a name for the project.

Path

A String representing a path where the project shall be saved. If the specified path does not exist, the project will not be saved. The string can also be left blank if the project initially is not to be saved.

Remarks

If a project is already open, it is closed automatically. If the open project contains any unsaved elements, the project and all its elements are automatically saved before it is closed.

Example

The following creates a new project:

VBS Macro

Sub CreateProjectExample()

NewProject "MyProject", ""

End Sub


Open Method

Applies to: Documents collection

Opens a document having the indicated file name.

Syntax

object.Open ( PathName[, OpenAs] [,ReadOnly] )

Parameters

object

An expression that evaluates to a Documents collection.

PathName

A String containing the document's full file name.

The file name can contain Argument Macros.

OpenAs

(Optional) A Variant containing a String, which defines the document's type, when the document is opened. Possible values are:

  • "Text": Opens the document as text file.

  • "Auto": Opens the document in the appropriate editor (default).

ReadOnly

(Optional) A Variant containing a Boolean value, which defines, if the document shall be opened write-protected. Possible values are:

  • True: Opens the document write-protected.

  • False: Opens the document with read/write rights (default).

Return values

The method Open returns the opened Document object at successful execution.

Example

The following example opens the file C:\Users\<User Name>\Documents\PCAN-Explorer 6\Symbols\Sample.sym write-protected:

VBS Macro

Sub OpenExample()

Dim doc

Set doc = Documents.Open("$(MyDocsDir)\PCAN-Explorer 6\Symbols\Sample.sym",,True)

' Access the document here

' ...

End Sub

See also

Close Method

CloseAll Method


OpenThroughout Method

Applies to: J1939Filters collection

Opens the reception filter of a J1939Node object completely.

Syntax

object.OpenThroughout

Parameters

object

An expression that evaluates to a J1939Filters collection.

Example

The following example opens the filter of a J1939Node object so that all PGNs are received:

VBS Macro

Sub J1939_OpenThroughoutExample()

Dim node

Set node = CreateObject("J1939Pcan6.PCANJ1939Node")

node.Device = tcdPCI

node.ClientName = "Macro"

node.NetName = "TestNet"

If node.Connect Then

' Open the filter

node.Filters.OpenThroughout

Dim msg

Set msg = CreateObject("J1939Pcan6.PCANJ1939RcvMsg")

While Not node.Read(msg)

Wait 100

Wend

' A message has been received

' ...

End If

End Sub

See also

IsOpenThroughout Property


OutputString Method

Applies to: OutputWindowPane object

Displays a text in the output window.

Syntax

object.OutputString Text

Parameters

object

An expression that evaluates to an OutputWindowPane object.

Text

A String containing the text to be displayed.

Example

The following example displays a text on a new pane in the output window:

VBS Macro

Sub OutputStringExample()

' Fetch a handle to the Output window tool

Dim win

Set win = Windows(peWindowKindOutput)

' Create handles to the Output window and its panes

Dim OW

Set OW = win.Object

' Add a new pane to the Output window

Dim OWp

Set OWp = OW.OutputWindowPanes.Add("A New Pane")

' Add a line of text to the new pane

OWp.OutputString("Some Text")

End Sub

See also

OutputWindowPane Object


PageDown Method

Applies to: TextSelection object

Moves the cursor position one page downward.

Syntax

object.PageDown [extend] [, count]

Parameters

object

An expression that evaluates to a TextSelection object.

extend

(Optional) An enum of the type PeMovementOptions, which determines what to be done with the selection. Possible values are:

  • peExtend: Extends the selection (this corresponds to the key combination SHIFT+PGDN).

  • peMove: Does not extend the selection (default value).

count

(Optional) A Long value indicating the number of repetitions, how many times the action shall be executed. The standard value is 1.

Remarks

The PageDown method has the same effect as pressing the key PGDN.

Example

The following example extends the selection one page downward:

VBS Macro

Sub PageDownExample()

If ActiveDocument.Type = "Text" Then _

ActiveDocument.Selection.PageDown peExtend

End Sub

See also

PageUp Method


PageUp Method

Applies to: TextSelection object

Moves the cursor position one page upward.

Syntax

object.PageUp [extend] [, count]

Parameters

object

An expression that evaluates to a TextSelection object.

extend

(Optional) An enum of the type PeMovementOptions, which determines what to be done with the selection. Possible values are:

  • peExtend: Extends the selection (this corresponds to the key combination SHIFT+PGUP).

  • peMove: Does not extend the selection (default value).

count

(Optional) A Long value indicating the number of repetitions, how many times the action shall be executed. The standard value is 1.

Remarks

The PageUp method has the same effect as pressing the key PGUP.

Example

The following example extends the selection one page upward:

VBS Macro

Sub PageUpExample()

If ActiveDocument.Type = "Text" Then _

ActiveDocument.Selection.PageUp peExtend

End Sub

See also

PageDown Method


Paste Method

Applies to: TextSelection object

Replaces the selection with the clipboard's contents.

Syntax

object.Paste

Parameters

object

An expression that evaluates to a TextSelection object.

Example

The following example replaces the selection with the clipboard's contents:

VBS Macro

Sub PasteExample()

If ActiveDocument.Type = "Text" Then _

ActiveDocument.Selection.Paste

End Sub

See also

Copy Method

Cut Method


Pause Method

Applies to: Tracer object

Pauses the recording of CAN messages.

Syntax

object.Pause

Parameters

object

An expression that evaluates to a Tracer object.

Remarks

The Pause method has only an effect if the tracer was previously started.

Example

The following example pauses the recording of CAN messages:

VBS Macro

Sub PauseExample()

If ActiveWindow.Kind = peDocumentKindTrace Then _

ActiveWindow.Object.Tracer.Pause

End Sub

See also

Start Method

Stop Method


PauseAll Method

Applies to: TransmitMessages collection

Stops the periodic sending of all corresponding CAN messages of a Transmit List.

Syntax

object.PauseAll

Parameters

object

An expression that evaluates to a TransmitMessages collection.

Example

The following example stops the periodic sending of CAN messages in the default transmit window:

VBS Macro

Sub PauseAllExample()

TransmitMessages.PauseAll

End Sub

See also

ResumeAll Method


Play Method

Applies to: Tracer object

Starts playback of CAN messages from a trace buffer or file.

Syntax

object.Start

Parameters

object

An expression that evaluates to a Tracer object.

Example

The following example loads a trace file and then starts playback of CAN messages:

VBS Macro

Sub PlayExample()

Dim doc, tracer

Set doc = Documents.Open("MyTrace.trc")

Set tracer = doc.ActiveWindow.Object.Tracer

While tracer.TraceState = peTraceLoading

Wait 50

Wend

tracer.Play

End Sub

See also

Pause Method

Stop Method


PrintOut Method

Applies to: Document object, TextDocument object

Sends a document to the current printer.

Syntax

object.PrintOut

Parameters

object

An expression that evaluates to a Document object or a TextDocument object.

Remarks

The PrintOut method does not work with documents, which are of the type Generic.

Example

The following example sends a document to the current printer:

VBS Macro

Sub PrintOutExample()

ActiveDocument.PrintOut

End Sub


PrintToOutputWindow Method

Applies to: Application object, ReceiveEvent object, TransmitEvent object

Prints text on the Macro tab of the output window.

Syntax

object.PrintToOutputWindow string

Parameters

object

An expression that evaluates to an Application object.

string

A String containing the text that shall appear on the Macro tab on the output window.

Remarks

The text processed by PrintToOutputWindow can be any text generated by the Macro. The output text typically contains data that is not shown in a message box, like debug output or information about received CAN messages.

Example

The following example iterates through the active Symbols and shows some of their details:

VBS Macro

Sub PrintToOutputWindowExample()

Dim symbols, objSymbol

Set symbols = SymbolsManager("Sample")

For Each objSymbol In symbols

PrintToOutputWindow(objSymbol.Name)

PrintToOutputWindow(objSymbol.CanId)

PrintToOutputWindow(objSymbol.Comment)

Next

End Sub


Quit Method

Applies to: Application object

Quits PCAN-Explorer.

Syntax

object.Quit

Parameters

object

An expression that evaluates to an Application object. When you use the Quit method of the Application object, you can omit object because the name of the Application object is implied when you access its properties and methods.

Remarks

The Quit method asks the user, if changes on opened documents shall be saved before PCAN-Explorer is quit.

Example

The following example causes PCAN-Explorer to quit:

VBS Macro

Quit


Read Method [Variation 1]

Applies to: PCANMessage object

Reads a CAN message from the receive queue of the parent PCANClient object.

Syntax

object.Read ( )

Parameters

object

An expression that evaluates to a PCANMessage object.

Return values

The Read method returns a Boolean value:

  • True: A CAN message was read from the receive queue.

  • False: No CAN message was read from the receive queue, because either the queue was empty or an error occurred. The LastError property provides information about the cause of error.

Example

The following example reads a CAN message from the receive queue:

VBS Macro

Sub ReadExample()

Dim client, conn

Set client = CreateObject("PCAN4.PCANClient")

client.Device = "pcan_usb"

client.Name = "Macro"

' Connect client to net TestNet

Set conn = client.Connections.Add("TestNet")

' Open the filter for message 100h

conn.RegisterMsg &H100, &H100, False, False

Dim msg

Set msg = client.Messages.Add

While msg.Read

' Insert code to evaluate the CAN messages here

Wend

End Sub

See also

Write Method


Read Method [Variation 2]

Applies to: J1939Node object

Reads a J1939 message from the receive queue of a J1939Node object.

Syntax

object.Read ( Msg )

Parameters

object

An expression that evaluates to a J1939Node object.

Msg

A J1939RcvMsg object in which the data of the received J1939 message will be stored.

Return values

The Read method returns a Boolean value:

  • True: A message was read from the receive queue.

  • False: No message was read from the receive queue, because either the queue was empty or an error occurred. The LastError property provides information about the cause of error.

Example

The following example reads a J1939 message:

VBS Macro

Sub ReadExample2()

Dim node

Set node = CreateObject("J1939Pcan6.PCANJ1939Node")

node.Device = tcdPCI

node.ClientName = "Macro"

' Connect node to net TestNet

node.NetName = "TestNet"

If node.Connect Then

node.Filters.OpenThroughout

Dim msg

Set msg = CreateObject("J1939Pcan6.PCANJ1939RcvMsg")

While node.Read(msg)

' Insert code to evaluate the J1939 messages here

Wend

End If

End Sub


RegisterCallback Method [Variation 1]

Applies to: Signal object

Registers a SignalCallback object at a Signal object, which is then notified when the value of the Signal has changed. The Add-in registers a SignalCallback object by passing a pointer to its implemented COM interface IPESignalCallback to the RegisterCallback method.

If the Value property of the Signal object has changed, e.g. because a CAN message has been received, PCAN-Explorer invokes the OnChangeValue method of all the SignalCallback objects that were previously registered at the Signal object.

Syntax
C++

HRESULT _stdcall RegisterCallback(

IPESignalCallback *pCallback

);
C#

void RegisterCallback(

IPESignalCallback pCallback

);
Delphi

procedure RegisterCallback(

const pCallback: IPESignalCallback

); safecall;
Parameters

object

An expression that evaluates to a Signal object.

pCalback

A pointer to a IPESignalCallback interface whose methods are invoked to notify the SignalCallback object when conditions of the associated signal are being changed.

Remarks

The RegisterCallback method can only be invoked by Add-ins. VBScript Macros are not capable of this.

Example

The following example registers a callback interface of the signal "Speed":

Visual C++

COleVariant vSignal("RcvSymbol.Mux1.Speed");

IPESignal *pSignal = NULL;

if (SUCCEEDED(pSignals->Item(vSignal, &pSignal)))

{

pSignal->RegisterCallback(pMyCallback);

...

}

See also

Getting notified when a Signal value has changed

UnregisterCallback Method


RegisterCallback Method [Variation 2]

Applies to: ReceiveMessages collection

Registers a ReceiveCallback object at a ReceiveMessages collection, which is then notified when a CAN message is received. The Add-in registers a ReceiveCallback object by passing a pointer to the COM interface IPEReceiveCallback, which the ReceiveCallback object must implement.

When a CAN message has been received, PCAN-Explorer then invokes the OnReceive method of all ReceiveCallback objects that have been previously registered at the ReceiveMessages collection.

Syntax
C++

HRESULT _stdcall RegisterCallback(

IPEReceiveCallback *pCallback

);
C#

void RegisterCallback(

IPEReceiveCallback pCallback

);
Delphi

procedure RegisterCallback(

const pCallback: IPEReceiveCallback

); safecall;
Parameters

object

An expression that evaluates to a ReceiveMessages collection.

pCallback

A pointer to a IPEReceiveCallback interface whose OnReceive method is invoked when a CAN message has been received.

Remarks

The RegisterCallback method can only be invoked by Add-ins. VBScript Macros are not capable of this. RegisterCallback is a method of the IPEReceiveMessages interface.

Example

The following example registers a callback interface at the ReceiveMessages collection:

Visual C++

IPEConnections *pConns;

if (SUCCEEDED(m_pApp->get_Connections(&pConns)))

{

IPEReceiveMessages *pRcvMsgs;

if (SUCCEEDED(pConns->get_ReceiveMessages(&pRcvMsgs)))

{

pRcvMsgs->RegisterCallback(pMyCallback);

...

}

}

See also

UnregisterCallback Method


RegisterCallback Method [Variation 3]

Applies to: TransmitMessages collection

Registers a TransmitCallback object at a TransmitMessages collection, which is then notified when a CAN message are transmitted. The Add-in registers a TransmitCallback object by passing a pointer to the COM interface IPETransmitCallback, which the TransmitCallback object must implement.

When a CAN message is transmitted, PCAN-Explorer invokes the methods OnBeforeTransmit and OnAfterTransmit of all TransmitCallback objects that have been previously registered at the TransmitMessages collection.

Syntax
C++

HRESULT _stdcall RegisterCallback(

IPETransmitCallback *pCallback,

PeTransmitCallbackMask mask

);
C#

void RegisterCallback(

IPETransmitCallback pCallback,

PeTransmitCallbackMask mask

);
Delphi

procedure RegisterCallback(

const pCallback: IPETransmitCallback;

mask: PeTransmitCallbackMask

); safecall;
Parameters

object

An expression that evaluates to a ReceiveMessages collection.

pCallback

A pointer to a IPETransmitCallback interface, the methods of which are invoked when conditions of the associated CAN message are being changed.

mask

A combination of values from the PETransmitCallbackMask enum. The specified values determine which methods of the IPETransmitCallback interface are invoked when the corresponding event occurs. An Add-in typically does not need to handle all available events, and will configure the mask to only get those methods called that it requires to perform its special tasks.

The PETransmitCallbackMask enum has the following values:

  • peOnBeforeTransmit (1): The OnBeforeTransmit method is called before a message is transmitted.

  • peOnAfterTransmit (2): The OnAfterTransmit method is called after a message has been transmitted.

  • peOnResume (4): The OnResume method is called when a periodic transmit message is being resumed.

  • peOnPause (8): The OnPause method is called when a periodic transmit message is halted.

  • peOnReset (16): The OnReset method is called when the Reset command has been executed for a connection. The OnReset method is then called for all transmit messages associated with the connection for which the Reset command has been executed.

Remarks

The RegisterCallback method can only be invoked by Add-ins. VBScript Macros are not capable of this. RegisterCallback is a method of the IPETransmitMessagesEx interface.

Example

The following example registers a callback interface at the TransmitMessages collection and configures calling of the methods OnBeforeTransmit and OnReset.

Visual C++

IPETransmitMessages *pXmtMsgs;

if (SUCCEEDED(m_pApp->get_TransmitMessages(&pXmtMsgs)))

{

IPETransmitMessagesEx *pXmtMsgsEx;

if (SUCCEEDED(pXmtMsgs->QueryInterface(IID_IPETransmitMessagesEx, (void**) &pXmtMsgsEx)))

{

pXmtMsgsEx->RegisterCallback(

pMyCallback,

(PeTransmitCallbackMask)(peOnBeforeTransmit | peOnReset));

...

}

}
C#

public class TransmitCallbacks : IPETransmitCallback

{

...

public void Register(IPEApplication app)

{

(app.TransmitMessages as IPETransmitMessagesEx).RegisterCallback(

this as IPETransmitCallback,

PeTransmitCallbackMask.peOnBeforeTransmit | PeTransmitCallbackMask.peOnReset);

...

}

}

See also

UnregisterCallback Method


Register Method

Applies to: PCANClient object

Registers a PCAN client at a PCAN device.

Syntax

object.Register

Parameters

object

An expression that evaluates to a PCANClient object.

Return values

The Register method returns one of the following values:

  • True: The client has been successfully registered at the device.

  • False: The client couldn't be registered at the device. The LastError property of the PCANClient object provides information about the cause of the error.

Remarks

Before a PCANClient object can be registered at a PCAN device, the Device property must contain the name of a PCAN device that is installed and loaded. Furthermore, a client name must be assigned to its Name property.

Example

The following example creates a new PCAN client and registers it at the pcan_usb device:

VBS Macro

Sub RegisterExample()

Dim client

Set client = CreateObject("PCAN4.PCANClient")

client.AutoRegister = False

client.Device = "pcan_usb"

client.Name = "Macro"

' Auto-register is diabled, the following line

' registers the client manually

If client.Register Then

' ...

MsgBox "Press OK to remove client"

End If

End Sub

See also

Remove Method


RegisterMsg Method

Applies to: PCANClientConnection object

Opens the reception filter of a PCAN client object and of a connected CAN hardware so far as the specified range of CAN messages can pass the filter.

Syntax

object.RegisterMsg ( ID1, ID2, Ext1, Ext2 )

Parameters

object

An expression that evaluates to a PCANClientConnection object.

ID2

A Long value indicating the lower CAN ID of the range.

ID2

A Long value indicating the upper CAN ID of the range.

Ext1

A Boolean value that determines if the lower CAN ID represents a 29-bit CAN ID.

Ext2

A Boolean value that determines if the upper CAN ID represents a 29-bit CAN ID.

Return values

The RegisterMsg method returns a Boolean value:

  • True: The reception filter has been successfully configured.

  • False: The reception filter could not be configured. The LastError property of the parent PCANClient object provides information about the cause of error.

Example

The following example configures the reception filter of a custom PCAN client to receive all messages in the range of 100h to 200h:

VBS Macro

Sub RegisterMsgExample()

Dim client, conn

Set client = CreateObject("PCAN4.PCANClient")

client.Device = "pcan_usb"

client.Name = "Macro"

Set conn = client.Connections.Add("TestNet")

conn.RegisterMsg &H100, &H200, False, False

' ...

End Sub

See also

ResetFilters Method


ReleaseAddress Method

Applies to: J1939Node object

Releases a previously claimed J1939 address.

Syntax

object.ReleaseAddress

Parameters

object

An expression that evaluates to a J1939Node object.

Return values

The ReleaseAddress method returns one of the following values:

  • True: Releasing the address was successful.

  • False: An error occurred while releasing the address. The LastError property of the J1939Node object provides information about the cause of the error.

See also

ClaimAddress Method


Remove Method [Variation 1]

Applies to: Connections collection, J1939Filters collection, PCANClientConnections collection, Enums collection, MessageFilters collection, Messages collection, ReceiveMessages collection, Signals collection, TransmitMessages collection

Removes an object from its parent collection.

Syntax

object.Remove ( Value )

Parameters

object

An expression that evaluates to one of the objects in the Applies To list above.

Value

The object that shall be removed from the collection.

Example

The following example adds a new Signal object to the Signals collection and removes it again later:

VBS Macro

Dim mySignal

Set mySignal = Signals.Add("MySignal")

...

Signals.Remove mySignal


Remove Method [Variation 2]

Applies to: PCANClient object

Removes a PCAN client from a PCAN device.

Syntax

object.Remove

Parameters

object

An expression that evaluates to a PCANClient object.

Return values

The Remove method returns one of the following values:

  • True: The client has been removed from the PCAN device.

  • False: The client couldn't be removed from the PCAN device. The LastError property of the PCANClient object provides information about the cause of the error.

Example

The following example creates a new PCAN client and disconnects it from the PCAN device after a short pause:

VBS Macro

Sub RemoveExample()

Dim client

Set client = CreateObject("PCAN4.PCANClient")

client.Device = "pcan_usb"

' Auto-register is enabled, the following line

' registers the client

client.Name = "Macro"

If client.IsRegistered Then

MsgBox "Press OK to remove client"

If client.Remove Then

MsgBox "Client removed"

' ...

End If

End If

End Sub

See also

Register Method


RemoveItem Method

Applies to: MessageFilter object, Project object, ProjectItems collection

Removes a project item from an object or collection.

Syntax

object.RemoveItem ( item )

Parameters

object

An expression that evaluates to one of the objects in the Applies To list above.

item

The ProjectItem object to be removed.

Example

The following example adds and removes a message filter to and from the current project:

VBS Macro

Sub RemoveItemExample()

Dim item

Set item = ActiveProject.AddItem("MyFilter", _

peProjectItemKindMessageFilter);

MsgBox "Item added",,"Macro"

ActiveProject.RemoveItem(item);

MsgBox "Item removed",,"Macro"

End Sub


RenameItem Method

Applies to: ProjectItems collection

Renames a project item.

Syntax

object.RenameItem ( OldName, MewName )

Parameters

object

An expression that evaluates to a ProjectItems collection.

OldName

The old name of the project item to be renamed.

NewName

The new name for the project item.

Remarks

Renaming the item will fail if a project item with the same name already exists in the collection.

Example

The following example adds a message filter and then renames it:

VBS Macro

Sub RenameItemExample()

Dim item

Set item = ActiveProject.AddItem("Test", _

peProjectItemKindMessageFilter);

MsgBox "Item added",,"Macro"

ActiveProject.RenameItem("Test", "MyFilter");

MsgBox "Item renamed",,"Macro"

End Sub


Reset Method [Variation 1]

Applies to: PCANClient object

Deletes the contents of a PCAN client's receive queue.

Syntax

object.Reset

Parameters

object

An expression that evaluates to a PCANClient object.

Example

The following example clears the receive queue of a PCAN client:

VBS Macro

Sub ResetExample()

Dim client, conn

Set client = CreateObject("PCAN4.PCANClient")

client.Name = "Macro"

Set conn = client.Connections.Add("TestNet")

' Open the filter

conn.RegisterMsg 0, &H7FF, False, False

' Messages are being received

' ...

client.Reset ' Receive queue is now empty

' ...

End Sub

See also

ResetFilters Method

ResetHardware Method


Reset Method [Variation 2]

Applies to: J1939Node object

Resets the object. Resets the configured filter, deletes the contents of the Receive Queue, and resets the connected CAN Hardware.

Syntax

object.Reset

Parameters

object

An expression that evaluates to a J1939Node object.

Example

The following example resets a J1939 node:

VBS Macro

Sub ResetExample2()

Dim node

Set node = CreateObject("J1939Pcan6.PCANJ1939Node")

node.Device = tcdPCI

node.ClientName = "Macro"

node.NetName = "TestNet"

If node.Connect Then

' Open the filter

node.Filters.OpenThroughout

' Messages are being received

' ...

node.Reset ' Filter is now closed, Receive queue is empty

' ...

End If

End Sub


ResetFilters Method

Applies to: PCANClient object

Closes the reception filter of the PCAN client so that no more CAN messages can pass the filter.

Syntax

object.ResetFilters

Parameters

object

An expression that evaluates to a PCANClient object.

Example

The following example closes the reception filter of a custom PCAN client:

VBS Macro

Sub ResetFiltersExample()

Dim client, conn

Set client = CreateObject("PCAN4.PCANClient")

client.Device = "pcan_usb"

client.Name = "Macro"

Set conn = client.Connections.Add("TestNet")

conn.RegisterMsg &H100, &H200, False, False

' Now messages from 100h to 200h are received

' ...

client.ResetFilters

' Now no more messages are received

' ...

End Sub

See also

RegisterMsg Method


ResetHardware Method

Applies to: PCANClientConnection object

Carries out a reset of a connected CAN hardware.

Syntax

object.ResetHardware

Parameters

object

An expression that evaluates to a PCANClientConnection object.

Example

The following example resets a CAN hardware:

VBS Macro

Sub ResetHardwareExample()

Dim client, conn

Set client = CreateObject("PCAN4.PCANClient")

client.Device = "pcan_usb"

client.Name = "Macro"

Set conn = client.Connections.Add("TestNet")

' Use the connection here, e.g. send messages

' ...

conn.ResetHardware

' ...

End Sub


ResumeAll Method

Applies to: TransmitMessages collection

Resumes the periodic sending of all messages in a Transmit List.

Syntax

object.ResumeAll

Parameters

object

An expression that evaluates to a TransmitMessages collection.

Example

The following example resumes the periodic sending of CAN messages in the default transmit window:

VBS Macro

Sub ResumeAllExample()

TransmitMessages.ResumeAll

End Sub

See also

PauseAll Method


Save Method

Applies to: Document object, Project object, TextDocument object

Saves a document or project in a file.

Syntax

object.Save ( [FullName] [, PromptUser] )

Parameters

object

An expression that evaluates to a Document object, a Project object, or a TextDocument object.

FullName

(Optional) A Variant containing a String that specifies the file name including the path in which the document shall be saved. If the name is omitted, the name stored in the FullName property is used.

PromptUser

(Optional) A Variant containing a Boolean that specifies whether the user is prompted to save pending changes. Possible values are:

  • True: Prompts the user to save pending changes.

  • False: Does not prompt the user to save pending changes (default).

Return values

The Save method of the Document object or the TextDocument object returns a PeSaveStatus enum value having one of the following values:

  • peSaveSucceeded (1): The user has saved the pending changes of the document or has chosen to discard the changes.

  • peSaveCanceled (2): The user has canceled the save operation.

The Save method of the Project object returns a Boolean value:

  • True: The project has been saved successfully.

  • False: The user has canceled the save operation.

Example

The following example saves a document to "C:\Documents\MyDoc.txt":

VBScript

Dim result

result = ActiveDocument.Save("C:\Documents\MyDoc.txt")


SaveAll Method

Applies to: Documents collection

Saves all open documents.

Syntax

object.SaveAll ( [PromptUser] )

Parameters

object

An expression that evaluates to a Documents collection.

PromptUser

(Optional) A Variant containing a Boolean that specifies whether the user is prompted to save pending changes. Possible values are:

  • True: Prompts the user to save pending changes.

  • False: Does not prompt the user to save pending changes (default).

Return values

The method SaveAll returns a PeSaveStatus enum value having one of the following values:

  • peSaveSucceeded (1): The user has saved the pending changes on all open documents or has chosen to discard the changes.

  • peSaveCanceled (2): The user has canceled the save operation.

Example

The following example prompts the user, to confirm the saving of changes on all open documents:

VBScript

Documents.SaveAll (True)


SaveAs Method

Applies to: Project object

Saves a project under a new name.

Syntax

object.SaveAs ( FullName )

Parameters

object

An expression that evaluates to a Project object.

FullName

A String that specifies the file name including the path in which the project shall be saved.

Return values

The SaveAs method returns a Boolean value:

  • True: The project has been saved successfully.

  • False: The user has canceled the save operation.

Example

The following example saves a document to "C:\Documents\MyDoc.txt":

VBScript

Dim result

result = ActiveProject.SaveAs("C:\Projects\MyProject.peproj")


SelectAll Method

Applies to: TextSelection object

Extends the selection so that the whole document is included.

Syntax

object.SelectAll

Parameters

object

An expression that evaluates to a TextSelection object.

Example

The following example extends the selection to the whole document:

VBScript

If ActiveDocument.Type = "Text" Then

ActiveDocument.Selection.SelectAll

End If


SelectSignal Method

Applies to: Signals collection

Shows a dialog box for selecting of a signal.

Syntax

object.SelectSignal ( Signal )

Parameters

object

An expression that evaluates to a Signals collection.

Signal

(Optional) A Signal object, that is marked as selected in the selection dialog box, to indicate that it has been selected before.

Return values

The SelectSignal method returns a Signal object, if the user has selected a signal. If the user closes the dialog box without selecting a signal, in VBScript the SelectSignal method returns the value Nothing. In Visual C++ this corresponds to the value NULL, and in C# to the value null.

Example

The following example gives the user the possibility to select a signal from the existing ones:

VBS Macro

Sub SelectSignalExample()

Dim mySignal

Set mySignal = Signals.SelectSignal()

If Not mySignal Is Nothing Then

' Code to evaluate the signal

MsgBox mySignal.Name,,"Selected Signal"

End If

End Sub


SelectSignals Method

Applies to: Signals collection

Shows a dialog box for selecting one or multiple signals.

Syntax

object.SelectSignals

Parameters

object

An expression that evaluates to a Signals collection.

Return values

The SelectSignals method returns a Variant that contains an array of Signal objects.

Example

The following example gives the user the possibility to select some signals from the existing ones. The names of the selected signals are shown in the Output window.

VBS Macro

Sub SelectSignalsExample()

Dim result, signal

result = Signals.SelectSignals

For Each signal In result

PrintToOutputWindow signal.Name

Next

End Sub


Send Method

Applies to: Multiplexer object

Sends a CAN message on the selected bus/connection.

Syntax

object.Send ( bus, [options] [, CycleTime] )

Parameters

object

An expression that evaluates to a Multiplexer object.

bus

The number of the bus (1-16) in the project, on which the message shall be sent.

If bus is set to 0, the message is sent on all the buses, which include the multiplexer.

If a bus is specified that does not include the multiplexer, no message is sent.

options

(Optional) A PeSendOptions constant indicating how the message shall be sent. Possible values are:

  • peSendOnce (0): Sends the message only once (default).

  • peSendPeriodic (1): Sends the message periodically.

  • peSendWait (2): Only creates an entry in the Transmit List, but does not actually send the message.

CycleTime

(Optional) A Long that defines the sending period of the message. If this parameter is omitted and the options parameter is set to peSendPeriodic, the value of the CycleTime property of the Multiplexer object is used as sending period.

Return value

If successful, the Send method returns a TransmitMessage object.

Examples

The following example creates a transmit message for the Symbol "MySymbol" in the Transmit List, sets some variable values, and sends the message once:

VBS Macro

Sub SendSymbolExample()

Dim sym, msg

Set sym = SymbolsManager("MySymbols").Item("MySymbol")

Set msg = sym.DefaultMultiplexer.Send(1, peSendWait)

msg.VariableValue("MyVariable") = 123

msg.VariableValue("MyOtherVar") = 4.56

msg.Write 0

End Sub

The following example sends the multiplexer "Mux1" of the symbol "MySymbol" periodically every 100 ms on bus 1:

VBS Macro

Sub SendMultiplexerExample()

Dim sym

Set sym = SymbolsManager("MySymbols").Item("MySymbol")

sym.Multiplexers("Mux1").Send 1, peSendPeriodic, 100

End Sub

The following example sends the multiplexer "Mux1" of the symbol "MySymbol" periodically as Remote Transmission Request on bus 1:

VBS Macro

Sub SendRTRExample()

Dim sym, msg

Set sym = SymbolsManager("MySymbols").Item("MySymbol")

Set msg = sym.Multiplexers("Mux1").Send(1, peSendWait)

msg.MsgType = msg.MsgType Or pcanMsgTypeRTR

msg.CycleTime = 100

msg.IsPaused = False

End Sub

See also

Write Method


SetAddInInfo Method

Applies to: Application object

Transfers information about an Add-in to PCAN-Explorer when the Add-in is loaded. The Add-in calls SetAddInInfo.

Syntax
C++

HRESULT _stdcall SetAddInInfo(

long nInstanceHandle,

IDispatch *bCmdDispatch,

long nGraphicsResourceID,

long nGraphicsOffset,

long dwCookie

);
C#

void SetAddInInfo(

int nInstanceHandle,

object pCmdDispatch,

int nGraphicsResourceID,

int nGraphicsOffset,

int dwCookie

);
Delphi

procedure SetAddInInfo(

nInstanceHandle: Integer;

const pCmdDispatch: IDispatch;

nGraphicsResourceID: Integer;

nGraphicsOffset: Integer;

dwCookie: Integer

); stdcall;
Parameters

nInstanceHandle

The HINSTANCE handle of the Add-in DLL.

pCmdDispatch

The pointer to the dispatch interface (dispinterface), which is implemented by the Commands object of the Add-in. If the user selects one of the Add-in commands, PCAN-Explorer executes the command by using this pointer for communication with the Add-in.

nGraphicsResourceID

The bitmap resource ID containing all bitmaps of the toolbar buttons and menu commands, which are added by the Add-in. If the Add-in does not provide toolbar and command images, -1 must be submitted.

nGraphicsOffset

The offset or index of the image in the bitmap resource that represents the Add-in itself. If an Add-in adds more than one command, PCAN-Explorer creates a submenu in the Tools menu that groups the commands. The image that is displayed for the submenu item is determined by this value.

cookie

A value that specifies the Add-in's unique ID. PCAN-Explorer submits this value to the Add-in by the OnConnection method of the Add-in.

Remarks

Only Add-ins can invoke the method SetAddInInfo, VBScript Macros are not able to do this.

Examples

The following code examples invoke the SetAddInInfo method:

Visual C++

STDMETHODIMP CPEAddIn::OnConnection(IDispatch* pApp, VARIANT_BOOL bFirstTime,

long dwCookie, VARIANT_BOOL * res)

{

...

if (FAILED(pApplication->SetAddInInfo(

(long) AfxGetInstanceHandle(),

(LPDISPATCH) m_pCommands,

IDB_TOOLBAR,

0,

dwCookie))

{

*OnConnection = VARIANT_FALSE;

return;

}

...

}
C#

public bool OnConnection(object app, bool firstTime, int cookie)

{

...

try

{

IntPtr instanceHandle = Marshal.GetHINSTANCE(this.GetType().Module);

this.app.SetAddInInfo(

instanceHandle.ToInt32(),

commandsObject,

toolbarBitmapID,

0,

cookie);

}

catch

{

return false;

}

...

}
Delphi

function TPEAddIn.OnConnection(const pApp: IDispatch; bFirstTime: WordBool;

dwCookie: Integer; out res: WordBool): HResult;

begin

...

if Failed(pApp.SetAddInInfo(

HInstance,

FCommands,

IDB_TOOLBAR,

0,

dwCookie) Then

begin

res := False;

Result := S_OK;

end;

...

end;

See also

OnConnection Method


SetDriverParam Method

Applies to: PCANClient object

Sets a PCAN driver parameter.

Syntax

object.SetDriverParam ( Param, Value )

Parameters

object

An expression that evaluates to a PCANClient object.

Param

An enum of the type PCANParameter, which contains the type of the parameter to be set. The SetDriverParam method supports the following parameters:

Parameter | Description
pcanParamRcvQueueSize | Specifies the size of Receive Queues (default = 32768)
pcanParamXmtQueueSize | Specifies the size of Transmit Queues (default = 32768)
pcanParamAutoBusOn | Sets whether a CAN hardware is automatically set into a passive BUS-ON mode after its CAN controller reached the BUS-OFF state. 0 = Auto-BUS-ON disabled, 1 = Auto-BUS-ON enabled (default)

Value

A Long value that contains the parameter value.

Return values

The SetDriverParam method returns one of the following values:

  • True: Setting the specified parameter was successful.

  • False: An error occurred while setting the specified parameter. The LastError property of the PCANClient object provides information about the cause of the error.

Example

The following example disables the Auto-BUS-ON feature of the pcan_usb device:

VBS Macro

Sub SetDriverParamExample()

Dim client, value

Set client = CreateObject("PCAN4.PCANClient")

client.Device = "pcan_usb"

client.SetDriverParam pcanParamAutoBusOn, 0

End Sub

See also

GetDriverParam Method


SetFilter Method

Applies to: PCANClientConnection object

Configures the receive filter of the connection.

Syntax

object.SetFilter ( Extended, AccCode, AccMask )

Parameters

object

An expression that evaluates to a PCANClientConnection object.

Extended

Specifies whether the AccCode/AccMask values have a size of 11-bit (Extended = 0), or 29-bits (Extended = 1).

AccCode

The acceptance code is part of the acceptance filter of the SJA1000. See also Philips Data Sheet "SJA1000 Stand-alone CAN controller".

AccMask

The acceptance mask is part of the acceptance filter of the SJA1000. See also Philips Data Sheet "SJA1000 Stand-alone CAN controller".

Return values

The SetFilter method returns a Boolean value:

  • True: The filter has been successfully configured.

  • False: An error occurred while configuring the filter. The LastError property of the parent PCANClient object provides information about the cause of the error.

Remarks

The SetFilter method is particularly adapted to the SJA1000 CAN controller. The reception filter can also be configured with the RegisterMsg method.

See also

RegisterMsg Method


SetHardwareParam Method

Applies to: PCANClient object

Configures different parameters of a CAN hardware.

Syntax

object.SetHardwareParam ( HardwareHandle, Param, Value )

Parameters

object

An expression that evaluates to a PCANClient object.

HardwareHandle

A Long value that indicates the handle of the hardware, for which a parameter shall be configured.

Param

An enum of the type PCANParameter, which contains the type of the parameter to be configured. The following parameters are allowed:

Parameter | Description
pcanParamBitrate | A Long value, which sets the bit rate of the CAN controller. The bit rate is a 16-bit value that is used to configure the bus timing registers BTR0 and BTR1 of an SJA1000 CAN controller (only for non-FD bit rates).
pcanParamListenOnly | A Long value, which enables or disables the Listen-only mode of an attached CAN hardware. 1 = Listen-only enabled, 0 = Listen-only disabled.

Value

A Long value that contains the parameter value.

Return values

The SetHardwareParam method returns one of the following values:

  • True: The specified parameter has been successfully configured.

  • False: The specified parameter could not be configured. The LastError property of the PCANClient object provides information about the cause of the error.

Example

The following example creates a new PCAN client, connects it to the PCAN net "TestNet" on the PCAN-USB device, and sets the bit rate of the attached CAN hardware to 500 kbit/s:

VBS Macro

Sub SetHardwareParamExample()

Dim client, conn

Set client = CreateObject("PCAN4.PCANClient")

client.Device = "pcan_usb"

client.Name = "Macro"

Set conn = client.Connections.Add("TestNet")

If conn.HardwareHandle > 0 Then _

client.SetHardwareParam conn.HardwareHandle, pcanParamBitrate, &H001C

' ...

End Sub

See also

GetHardwareParam Method


SetNetParam Method

Applies to: PCANClient object

Configures different parameters of PCAN nets.

Syntax

object.SetNetParam ( NetHandle, Param, Value )

Parameters

object

An expression that evaluates to a PCANClient object.

NetHandle

A Long value that specifies the handle of the net, for which a parameter shall be configured.

Param

A value of the PCANParameter enum that determines the type of the parameter to be set. In the following the possible values and the meaning of the respective parameter:

Parameter | Description
pcanParamBitrate | A Long value, which sets the bit rate for this net (Long value). The bit rate is a 16-bit value that is used to configure the bus timing registers BTR0 and BTR1 of an SJA1000 CAN controller (only for non-FD nets).
pcanParamDelayedMessageDistribution | A Long value, which determines whether a transmitted CAN message is sent to other clients on the same net only when the message has actually been sent by the CAN controller on the physical CAN bus.

Value

A Long value, which holds the parameter's value.

Return values

The SetNetParam method returns a Boolean value:

  • True: The specified parameter has been set successfully.

  • False: The specified parameter could not be set. The LastError property provides information about the cause of error.

Example

The following example configures a parameter of the net "TestNet":

VBS Macro

Sub SetNetParamExample()

Dim client, conn

Set client = CreateObject("PCAN4.PCANClient")

client.Device = "pcan_usb"

client.Name = "Macro"

Set conn = client.Connections.Add("TestNet")

If conn.HardwareHandle > 0 Then

client.SetNetParam conn.NetHandle, _

pcanParamDelayedMessageDistribution, 1

End If

End Sub


SetParam Method

Applies to: PCANClient object

Configures different parameters of the PCAN client.

Syntax

object.SetParam ( Param, Value )

Parameters

object

An expression that evaluates to a PCANClient object.

Param

A value of the PCANParameter enum that determines type of the parameter to be set. The following table shows all allowed parameters:

Parameter | Description
pcanParamOnRcvEventHandle | A Long value that specifies the handle of an event synchronization object. The event is set to signalled when a message is received.
pcanParamOnRcvEventPulse | A Long value that specifies the trigger mode of the reception event. 0 = Set, 1 = Pulse.
pcanParamSelfReceive | A Long value that specifies whether the client receives CAN messages it has sent itself. 0 = The client does not receive messages it has sent itself 1 = The client receives messages it has sent itself
pcanParamRcvErrFrames | A Long value that specifies whether the reception of Error Frames is activated. 0 = Error Frames deactivated 1 = Error Frames activated

Value

A Variant, which holds the parameter's value.

Return values

The SetParam method returns a Boolean value:

  • True: The specified parameter has been set successfully.

  • False: The specified parameter could not be set. The LastError property provides information about the cause of error.

Example

The following example configures the client to receive messages it has sent itself:

VBS Macro

Sub SetParamExample()

Dim client

Set client = CreateObject("PCAN4.PCANClient")

client.Device = "pcan_usb"

client.Name = "Macro"

client.SetParam pcanParamSelfReceive, 1

' ...

End Sub


ShowFilterDialog Method

Applies to: MessageFilter object

Shows the Edit Filter dialog box for a message filter.

Syntax

object.ShowFilterDialog

Parameters

object

An expression that evaluates to a MessageFilter object.

Return values

The ShowFilterDialog method returns a Boolean value:

  • True: The dialog box has been closed with OK.

  • False: The user has canceled the dialog box, no filter settings have been changed.

Example

The following example shows the filter settings of the first message filter in the project:

VBS Macro

Sub ShowFilterDialogExample()

Dim result

result = MessageFilters.ShowFilterDialog

If result Then

MsgBox "User pressed OK",,"Macro"

Else

MsgBox "User pressed Cancel",,"Macro"

End If

End Sub


Start Method

Applies to: Tracer object

Starts the recording of CAN messages.

Syntax

object.Start

Parameters

object

An expression that evaluates to a Tracer object.

Example

The following example starts the recording of CAN messages:

VBS Macro

Sub StartExample()

If ActiveWindow.Kind = peDocumentKindTrace Then _

ActiveWindow.Object.Tracer.Start

End Sub

See also

Pause Method

Stop Method


StartOfLine Method

Applies to: TextSelection object

Moves the cursor position to the beginning of a line.

Syntax

object.StartOfLine [moveto][,extend]

Parameters

object

An expression that evaluates to a TextSelection object.

moveto

(Optional) A value of the PeStartOfLineOptions enum that determines what to be done with the selection. Possible values are:

  • peFirstColumn: Moves the cursor to the first column of the line (default).

  • peFirstText: Moves the cursor to the first character in the line.

extend

(Optional) A value of the PeMovementOptions enum that determines what to be done with the selection. Possible values are:

  • peExtend: Extends the selection (this corresponds to the key combination SHIFT+HOME).

  • peMove: Does not extend the selection (default value).

Example

The following example moves the cursor position to the beginning of the line and extends the selection:

VBS Macro

Sub StartOfLineExample()

If ActiveDocument.Kind = peDocumentKindText Then _

ActiveDocument.Selection.StartOfLine ,peExtend

End Sub


Stop Method

Applies to: Tracer object

Ends the recording of CAN messages.

Syntax

object.Stop

Parameters

object

An expression that evaluates to a Tracer object.

Remarks

The Stop method has only an effect if the tracer was previously started.

Example

The following example ends the recording of CAN messages:

VBS Macro

Sub StoptExample()

If ActiveWindow.Kind = peDocumentKindTrace Then _

ActiveWindow.Object.Tracer.Stop

End Sub

See also

Start Method

Pause Method


TimeToString Method

Applies to: Application object

Formats a Date/Time value.

Syntax

object.TimeToString( DateTime, Format )

Parameters

object

An expression that evaluates to an Application object. When you access the TimeToString method of the Application object, you can omit object because the name of the Application object is implied when you access its properties and methods.

DateTime

A DATE value containing a valid Date/Time.

Format

(Optional) A Variant containing a String that determines the format of the returned Date/Time.

If this parameter is omitted, the format of the returned Date/Time string is determined by the TimeFormat property.

For a list of possible format specifiers, see TimeFormat property.

Return value

A String containing the formatted Date/Time value.

Example

The following example displays the current PCAN-Explorer time:

VBScript

MsgBox TimeToString(CurrentTime, "ddd dd, hh:nn:ss am/pm"),,"Current Time"


TranslateFileName Method

Applies to: Documents collection

Translates a file name, which contains Argument Macros, into an actual file name.

Syntax

object.TranslateFileName ( FileName )

Parameters

object

An expression that evaluates to a Documents collection.

FileName

A String containing the file name that shall be translated.

Return values

The method TranslateFileName returns a String with a file name, in which all known Argument Macros were translated against actual directory names.

Example

The following example displays the actual file name of the example Symbol file "Sample.sym", which is located in a subdirectory of the "Documents" directory of the current user:

VBS Macro

Sub TranslateFileNameExample()

Dim path

path = Documents.TranslateFileName("$(MyDocsDir)\PCAN-Explorer 6\Symbols\Sample.sym")

MsgBox path

End Sub


UnregisterCallback Method [Variation 1]

Applies to: Signal object

Removes the registration of a SignalCallback object from a Signal object. After the registration has been removed, the SignalCallback object is no longer notified when the value of the signal changes.

Syntax
C++

HRESULT _stdcall UnregisterCallback(

IPESignalCallback *pCallback

);
C#

void UnregisterCallback(

IPESignalCallback pCallback

);
Delphi

procedure UnregisterCallback(

const pCallback: IPESignalCallback

); safecall;
Parameters

object

An expression that evaluates to a Signal object.

pCallback

The same pointer to a IPESignalCallback interface that was previously provided when calling the RegisterCallback method.

Remarks

The Add-in must undo the registration of the SignalCallback object in any case by invoking the UnregisterCallback method, at latest when the Add-in is disconnected from PCAN-Explorer or if the Symbols are closed that were responsible for creating the Signal.

The method UnregisterCallback can only be invoked by Add-ins. VBScript Macros are not capable of this.

Example

The following example removes the registration of the callback interface from the signal "Speed":

Visual C++

COleVariant vSignal("RcvSymbol.Mux1.Speed");

IPESignal *pSignal = NULL;

if (SUCCEEDED(pSignals->Item(vSignal, &pSignal)))

{

pSignal->UnrgisterCallback(m_pCallback);

...

}

See also

Removing a Notification about a Signal value change

RegisterCallback Method


UnregisterCallback Method [Variation 2]

Applies to: ReceiveMessages collection

Removes the registration of a ReceiveCallback object from a ReceiveMessages collection. After the registration has been removed, the ReceiveCallback object is no longer notified when a CAN message is received.

Syntax
C++

HRESULT _stdcall UnregisterCallback(

IPEReceiveCallback *pCallback

);
C#

void UnregisterCallback(

IPEReceiveCallback pCallback

);
Delphi

procedure UnregisterCallback(

const pCallback: IPEReceiveCallback

); safecall;
Parameters

object

An expression that evaluates to a ReceiveMessages collection.

pCallback

The same pointer to a IPEReceiveCallback interface that was previously provided when calling the RegisterCallback method.

Remarks

The Add-in must undo the registration of the ReceiveCallback object in any case by invoking the UnregisterCallback method, at latest when the Add-in is disconnected from PCAN-Explorer.

The UnregisterCallback method can only be invoked by Add-ins. VBScript Macros are not capable of this.

Example

The following example removes the registration of the callback interface from the ReceiveMessages collection:

Visual C++

IPEConnections *pConns;

if (SUCCEEDED(m_pApp->get_Connections(&Conns)))

{

IPEReceiveMessages *pRcvMsgs;

if (SUCCEEDED(pConns->get_ReceiveMessages(&pRcvMsgs)))

{

pRcvMsgs->UnregisterCallback(m_pCallback);

...

}

}

See also

RegisterCallback Method


UnregisterCallback Method [Variation 3]

Applies to: TransmitMessages collection

Removes the registration of a TransmitCallback object from a TransmitMessages collection. After the registration has been removed, the TransmitCallback object is no longer notified when a CAN messages are transmitted.

Syntax
C++

HRESULT _stdcall UnregisterCallback(

IPETransmitCallback *pCallback

);
C#

void UnregisterCallback(

IPETransmitCallback pCallback

);
Delphi

procedure UnregisterCallback(

const pCallback: IPETransmitCallback

); safecall;
Parameters

object

An expression that evaluates to a ReceiveMessages collection.

pCallback

The same pointer to a IPETransmitCallback interface that was previously provided when calling the RegisterCallback method.

Remarks

The Add-in must undo the registration of the TransmitCallback object in any case by invoking the UnregisterCallback method, at latest when the Add-in is disconnected from PCAN-Explorer.

The UnregisterCallback method can only be invoked by Add-ins. VBScript Macros are not capable of this. UnregisterCallback is a method of the IPETransmitMessagesEx interface.

Example

The following example removes the registration of the callback interface from the TransmitMessages collection:

Visual C++

IPETransmitMessages *pXmtMsgs;

if (SUCCEEDED(m_pApp->get_TransmitMessages(&pXmtMsgs)))

{

IPETransmitMessagesEx *pXmtMsgsEx;

if (SUCCEEDED(pXmtMsgs->QueryInterface(IID_IPETransmitMessagesEx, (void**) &pXmtMsgsEx)))

{

pXmtMsgsEx->UnregisterCallback(m_pCallback);

...

}

}

See also

RegisterCallback Method


UpdateSymbols Method

Applies to: SymbolsManager collection

Updates symbols definitions that are stored in a specific document.

Syntax

object.UpdateSymbols ( doc )

Parameters

object

An expression that evaluates to a SymbolsManager collection.

doc

A Document object that contains new symbols definitions.

Remarks

Usually, the document is a text document that has the ".sym" file extension.

PCAN-Explorer uses this method internally to update the symbols definitions when you execute the Apply command for a symbols file.


Wait Method

Applies to: Application object

Waits for the given number of milliseconds.

Syntax

object.Wait ( Time )

Parameters

object

An expression that evaluates to an Application object. When you use the Wait method of the Application object, you can omit object because the name of the Application object is implied when you access its properties and methods.

Time

A Long value, indicating the number of milliseconds, which to wait for.

Remarks

The Wait method serves VBScript Macros for waiting a defined time. VBScript does not have a predefined function for this task.

Example

The following example waits until the transmit message queue of a PCAN client is empty.

VBS Macro

While Not myClient.XmtQueueEmpty

Wait 500

Wend


Write Method [Variation 1]

Applies to: TransmitMessage object

Sends a message.

Syntax

object.Write ( Time )

Parameters

object

An expression that evaluates to a TransmitMessage object.

Time

The point of time at which the message shall be sent. For CAN messages, the current time can be retrieved with the method GetSystemTime of the PCANClient object.

If Time is smaller than or equal to the current time, the message is sent immediately.

If Time is higher than the current time, the message will be put into the transmit message queue.

Attention: This parameter has no effect if the message is a J1939 message. J1939 messages are always sent immediately.

Return values

The Write method returns a Boolean value:

  • True: The message was written into the transmit message queue, or sent immediately.

  • False: An error occurred while sending the message. The properties LastError and LastErrorType provide information about the cause of the error.

Example

The following example creates a new CAN message 100h in the transmit list and sends it:

VBS Macro

Sub WriteExample()

Dim msg

Set msg = TransmitMessages.Add

With msg

.BeginUpdate

Set .Connection = Connections(1)

.ID = &H100

.DLC = 3

.Data(0) = &H11

.Data(1) = &H22

.Data(2) = &H33

.EndUpdate

.Write 0

End With

End Sub


Write Method [Variation 2]

Applies to: PCANMessage object

Writes a CAN message into the transmit message queue of a PCAN client.

Syntax

object.Write ( Connection, Time )

Parameters

object

An expression that evaluates to a PCANMessage object.

Connection

A PCANClientConnection object that determines the CAN bus to which the message is written.

Time

The point of time at which the message shall be sent. The current time can be retrieved with the GetSystemTime method of the PCANClient object.

If Time is smaller than or equal to the current time, the message is sent immediately.

If Time is higher than the current time, the message will be put into the transmit message queue.

Return values

The Write method returns a Boolean value:

  • True: The CAN message was put into the transmit message queue or sent immediately.

  • False: An error occurred while sending the CAN message. The LastError property provides information about the cause of the error.

Example

The following example sends a CAN message with a CAN ID of 100h and two data bytes:

VBS Macro

Sub WriteExample2()

Dim client, conn

Set client = CreateObject("PCAN4.PCANClient")

client.Device = "pcan_usb"

client.Name = "Macro"

' Connect client to net TestNet

Set conn = client.Connections.Add("TestNet")

If conn.IsConnected Then

Dim msg

Set msg = client.Messages.Add

With msg

.ID = &H100

.DLC = 2

.Data(0) = &H11

.Data(1) = &H22

.Write conn, 0

End With

End If

End Sub

See also

Read Method


Write Method [Variation 3]

Applies to: J1939Node object

Sends a J1939 message.

Syntax

object.Write ( Message )

Parameters

object

An expression that evaluates to a J1939Node object.

Message

A J1939Msg object that contains the data to be sent.

Return values

The Write method returns a Boolean value:

  • True: The J1939 message has been successfully written into the transmit message queue.

  • False: An error occurred while sending the J1939 message. The LastError property of the J1939Node object provides information about the cause of the error.

Example

The following example sends a J1939 message:

VBS Macro

Sub J1939_WriteExample()

Dim node

Set node = CreateObject("J1939Pcan6.PCANJ1939Node")

node.Device = tcdUSB ' = 5

node.ClientName = "Macro"

node.NetName = "TestNet"

If node.Connect Then

Dim msg

Set msg = CreateObject("J1939Pcan6.PCANJ1939Msg")

With msg

.PGN = 65132 ' TCO1, Tachograph

.Priority = 3

.Length = 8

.Originator = 1

End With

node.Write msg

End If

End Sub


Events

An event is an action or occurrence, often generated by the user, to which a VBScript event handler, PCAN-Explorer Add-in, or other Automation controller can respond. For example, if a user clicks on a window, PCAN-Explorer fires the OnWindowActivate event of the Application object.

The following events are available:

Event | Description
OnAddressClaiming | Occurs during the address claiming process of J1939Node objects.
OnAddressLost | Occurs after a J1939Node object lost its claimed address.
OnApplicationShutDown | Occurs before PCAN-Explorer shuts down.
OnClientConnect | Occurs after a PCANClient object has been connected to a PCAN net.
OnClientDisconnect | Occurs after a PCANClient object has been disconnected from a PCAN net.
OnClientRegister | Occurs after a PCANClient object has been registered at a PCAN device.
OnClientRemove | Occurs before a PCANClient object is removed from PCAN device.
OnConnectionAdd | Occurs when a connection is added to the project.
OnConnectionChanged | Occurs after properties of a connection have been changed.
OnConnectionConnect | Occurs after a connection has been enabled.
OnConnectionDisconnect | Occurs after a connection has been disabled.
OnConnectionRemove | Occurs before a connection is removed from the project.
OnDocumentClose | Occurs before a document is closed.
OnDocumentOpen | Occurs after a document has been opened.
OnDocumentSave | Occurs after a document has been saved.
OnFilterChanged | Occurs after the reception filter of PCANClient object has been changed.
OnHardwareReset | Occurs after a hardware reset has been performed for a CAN hardware.
OnMessageFilterAdd | Occurs when a message filter is added to the project.
OnMessageFilterChanged | Occurs after properties of a message filter have been changed.
OnMessageFilterRemove | Occurs before a message filter is removed from the project.
OnNewDocument | Occurs after a new document has been created.
OnOptionsChanged | Occurs after PCAN-Explorer options have been changed.
OnProjectClose | Occurs before a project is closed.
OnProjectOpen | Occurs after a project has been opened.
OnPropertyValueChanged | Occurs after a property of a J1939Node object has changed.
OnSymbolsActivate | Occurs after a symbols collection has been activated.
OnSymbolsDeactivate | Occurs before a symbols collection is deactivated.
OnSymbolsDeactivated | Occurs after a symbols collection has been deactivated.
OnTracerActivate | Occurs after a tracer has been activated.
OnTracerDeactivate | Occurs after a tracer has been deactivated.
OnTracerFull | Occurs after the filling level of a specified tracer has reached 100%.
OnTracerPause | Occurs after a specified tracer has been paused.
OnTracerStart | Occurs after a specified tracer has been started.
OnTracerStop | Occurs after a specified tracer has been stopped.
OnWindowActivate | Occurs after a window has been activated.
OnWindowDeactivate | Occurs after a window has been deactivated.

In a VBScript event handler you can respond to an event by taking some action. For instance, you could change the size of a window by setting the Height and Width properties of the Window object.

To respond to an event, add the appropriate event handler to any loaded VBScript Macro file. You can add this event handler to multiple VBScript Macro files. For example, if you add an event handler for the OnWindowActivate event to two loaded VBScript Macro files, when the user activates a window, both of these event handlers will be called - one at a time.

To add the event handler, find the appropriate event by using the previous table, copy the sample event handler from the example, paste the handler into your Macro file, insert the appropriate code into the handler, and then reload the Macro file.

For example, you could take some action just before PCAN-Explorer quits by using the OnApplicationShutDown event. To use this event, go to the description of the event and copy the sample event handler:

VBS Macro

Sub Application_OnApplicationShutDown()

' Insert code to handle the event here

End Sub

Then, paste this code into your Macro file, insert the code for handling the event, and then reload the Macro file.

Tip: To reload the Macro file, open the file in the text editor, click the right mouse button, and then click Reload Macro File.


OnAddressClaiming Event

Applies to: J1939Node object

Occurs during the address claiming process.

Syntax

object_OnAddressClaiming ( node, status )

Parameters

object

An expression that evaluates to a J1939Node object.

node

The J1939Node object that triggers this event.

status

A TClaimedStatus enum value that specifies the current address claiming status.

Remarks

The OnAddressClaiming event is triggered only if the NotificationOnAddressClaiming property is set to True. For the J1939Node objects that PCAN-Explorer creates for its J1939 CommunicationObject objects, this property is automatically set to True.

For an overview about using event code, see the introduction to events.

Example

Following is a sample event handler for the OnAddressClaiming event. Copy this into your Macro file, and then insert the appropriate code:

VBS Macro

Sub J1939Node_OnAddressClaiming(node, status)

Dim str

Select Case status

Case tcsClaiming:

str = "Claiming address..."

Case tcsClaimed:

str = "Address claimed"

Case tcsCannotClaim:

str = "Cannot claim address"

Case tcsReleased:

str = "Address released"

End Select

PrintToOutputWindow "OnAddressClaiming, Status=" & str

End Sub

See also

AddressClaimStatus Property


OnAddressLost Event

Applies to: J1939Node object

Occurs after a J1939 node lost its claimed address.

Syntax

object_OnAddressLost ( node, address )

Parameters

object

An expression that evaluates to a J1939Node object.

node

The J1939Node object that triggers this event.

address

A Byte representing the address that was lost.

Remarks

For an overview about using event code, see the introduction to events.

Example

Following is a sample event handler for the OnAddressLost event. Copy this into your Macro file, and then insert the appropriate code:

VBS Macro

Sub J1939Node_OnAddressLost(node, address)

' Insert code to handle the event here

End Sub


OnApplicationShutDown Event

Applies to: Application object

Occurs before PCAN-Explorer shuts down.

Syntax

object_OnApplicationShutDown

Parameters

object

An expression that evaluates to an Application object.

Remarks

PCAN-Explorer fires this event before PCAN-Explorer ends.

For an overview about using event code, see the introduction to events.

Example

Following is a sample event handler for the OnApplicationShutDown event. Copy this into your Macro file, and then insert the appropriate code:

VBS Macro

Sub Application_OnApplicationShutDown()

' Insert code to handle the event here

End Sub


OnClientConnect Event

Applies to: PCANClient object

Occurs after a PCANClient object has been connected to a PCAN net.

Syntax

object_OnClientConnect ( connection )

Parameters

object

An expression that evaluates to a PCANClient object.

connection

The PCANClientConnection object that triggers this event.

Remarks

For an overview about using event code, see the introduction to events.

Example

Following is a sample event handler for the OnClientConnect event. Copy this into your Macro file and insert the appropriate code:

VBS Macro

Sub PCANClient_OnClientConnect(connection)

' Insert code to handle the event here

End Sub

See also

OnClientDisconnect Event


OnClientDisconnect Event

Applies to: PCANClient object

Occurs after a PCANClient object has been disconnected from PCAN net.

Syntax

object_OnClientDisconnect ( connection )

Parameters

object

An expression that evaluates to a PCANClient object.

connection

The PCANClientConnection object that triggers this event.

Remarks

For an overview about using event code, see the introduction to events.

Example

Following is a sample event handler for the OnClientDisconnect event. Copy this into your Macro file and insert the appropriate code:

VBS Macro

Sub PCANClient_OnClientDisconnect(connection)

' Insert code to handle the event here

End Sub

See also

OnClientConnect Event


OnClientRegister Event

Applies to: PCANClient object

Occurs after a PCANClient object has been registered at a PCAN device.

Syntax

object_OnClientRegister ( client )

Parameters

object

An expression that evaluates to a PCANClient object.

client

The PCANClient object that triggers this event.

Remarks

For an overview about using event code, see the introduction to events.

Example

Following is a sample event handler for the OnClientRegister event. Copy this into your Macro file and insert the appropriate code:

VBS Macro

Sub PCANClient_OnClientRegister(client)

' Insert code to handle the event here

End Sub

See also

Register Method

OnClientRemove Event


OnClientRemove Event

Applies to: PCANClient object

Occurs before a PCANClient object is removed from PCAN device.

Syntax

object_OnClientRemove ( client )

Parameters

object

An expression that evaluates to a PCANClient object.

client

The PCANClient object that triggers this event.

Remarks

For an overview about using event code, see the introduction to events.

Example

Following is a sample event handler for the OnClientRemove event. Copy this into your Macro file and insert the appropriate code:

VBS Macro

Sub PCANClient_OnClientRemove(client)

' Insert code to handle the event here

End Sub

See also

Remove Method [Variation 2]

OnClientRegister Event


OnConnectionAdd Event

Applies to: Application object

Occurs when a connection is added to the project.

Syntax

object_OnConnectionAdd ( connection )

Parameters

object

An expression that evaluates to an Application object.

connection

The Connection object that triggers this event.

Remarks

PCAN-Explorer fires this event before the connection is added to the project.

For an overview about using event code, see the introduction to events.

Example

Following is a sample event handler for the OnConnectionAdd event. Copy this into your Macro file and insert the appropriate code:

VBS Macro

Sub Application_OnConnectionAdd(theConnection)

' Insert code to handle the event here

End Sub

See also

OnConnectionRemove Event


OnConnectionChanged Event

Applies to: Application object

Occurs after properties of a connection have been changed.

Syntax

object_OnConnectionChanged ( connection )

Parameters

object

An expression that evaluates to an Application object.

connection

The Connection object that triggers this event.

Remarks

PCAN-Explorer fires this event after properties of a connection have been changed.

For an overview about using event code, see the introduction to events.

Example

Following is a sample event handler for the OnConnectionChanged event. Copy this into your Macro file and insert the appropriate code:

VBS Macro

Sub Application_OnConnectionChanged(theConnection)

' Insert code to handle the event here

End Sub


OnConnectionConnect Event

Applies to: Application object

Occurs after a connection has been enabled.

Syntax

object_OnConnectionConnect ( connection )

Parameters

object

An expression that evaluates to an Application object.

connection

The Connection object that triggers this event.

Remarks

PCAN-Explorer fires this event after the connection has been successfully enabled.

For an overview about using event code, see the introduction to events.

Example

Following is a sample event handler for the OnConnectionConnect event. Copy this into your Macro file and insert the appropriate code:

VBS Macro

Sub Application_OnConnectionConnect(theConnection)

' Insert code to handle the event here

End Sub

See also

OnConnectionDisconnect Event


OnConnectionDisconnect Event

Applies to: Application object

Occurs after a connection has been disabled.

Syntax

object_OnConnectionDisconnect ( connection )

Parameters

object

An expression that evaluates to an Application object.

connection

The Connection object that triggers this event.

Remarks

PCAN-Explorer fires this event after the connection has been disabled.

For an overview about using event code, see the introduction to events.

Example

Following is a sample event handler for the OnConnectionDisconnect event. Copy this into your Macro file and insert the appropriate code:

VBS Macro

Sub Application_OnConnectionDisconnect(theConnection)

' Insert code to handle the event here

End Sub

See also

OnConnectionConnect Event


OnConnectionRemove Event

Applies to: Application object

Occurs before a connection is removed from the project.

Syntax

object_OnConnectionRemove ( connection )

Parameters

object

An expression that evaluates to an Application object.

connection

The Connection object that triggers this event.

Remarks

PCAN-Explorer fires this event before the connection is removed from the project.

For an overview about using event code, see the introduction to events.

Example

Following is a sample event handler for the OnConnectionRemove event. Copy this into your Macro file and insert the appropriate code:

VBS Macro

Sub Application_OnConnectionRemove(theConnection)

' Insert code to handle the event here

End Sub

See also

OnConnectionAdd Event


OnDocumentClose Event

Applies to: Application object

Occurs before a document is closed.

Syntax

object_OnDocumentClose ( document )

Parameters

object

An expression that evaluates to an Application object.

document

The Document object that triggers this event.

Remarks

PCAN-Explorer fires this event before the document closes.

For an overview about using event code, see the introduction to events.

Example

Following is a sample event handler for the OnDocumentClose event. Copy this into your Macro file and insert the appropriate code:

VBS Macro

Sub Application_OnDocumentClose(theDocument)

' Insert code to handle the event here

End Sub

See also

OnDocumentOpen Event

OnDocumentSave Event


OnDocumentOpen Event

Applies to: Application object

Occurs after a document has been opened.

Syntax

object_OnDocumentOpen ( document )

Parameters

object

An expression that evaluates to an Application object.

document

The Document object that triggers this event.

Remarks

PCAN-Explorer fires this event after the document has been opened.

For an overview about using event code, see the introduction to events.

Example

Following is a sample event handler for the OnDocumentOpen event. Copy this into your Macro file and insert the appropriate code:

VBS Macro

Sub Application_OnDocumentOpen(theDocument)

' Insert code to handle the event here

End Sub

See also

OnDocumentClose Event

OnDocumentSave Event


OnDocumentSave Event

Applies to: Application object

Occurs after a specified document is saved.

Syntax

object_OnDocumentSave ( document )

Parameters

object

An expression that evaluates to an Application object.

document

The Document object that triggers this event.

Remarks

PCAN-Explorer fires this event after the document is saved.

For an overview about using event code, see the introduction to events.

Example

Following is a sample event handler for the OnDocumentSave event. Copy this into your Macro file and insert the appropriate code:

VBS Macro

Sub Application_OnDocumentSave(theDocument)

' Insert code to handle the event here

End Sub

See also

OnDocumentOpen Event

OnDocumentClose Event


OnFilterChanged Event

Applies to: PCANClient object

Occurs after the reception filter of PCANClient object has been changed.

Syntax

object_OnFilterChanged ( client )

Parameters

object

An expression that evaluates to a PCANClient object.

client

The PCANClient object that triggers this event.

Remarks

For an overview about using event code, see the introduction to events.

Example

Following is a sample event handler for the OnFilterChanged event. Copy this into your Macro file and insert the appropriate code:

VBS Macro

Sub PCANClient_OnFilterChanged(client)

' Insert code to handle the event here

End Sub

See also

RegisterMsg Method

ResetFilters Method

SetFilter Method


OnHardwareReset Event

Applies to: PCANClient object

Occurs after a hardware reset has been performed for a connected CAN hardware.

Syntax

object_OnHardwareReset ( connection )

Parameters

object

An expression that evaluates to a PCANClient object.

connection

The PCANClientConnection object that triggers this event.

Remarks

For an overview about using event code, see the introduction to events.

Example

Following is a sample event handler for the OnHardwareReset event. Copy this into your Macro file and insert the appropriate code:

VBS Macro

Sub PCANClient_OnHardwareReset(connection)

' Insert code to handle the event here

End Sub

See also

ResetHardware Method


OnMessageFilterAdd Event

Applies to: Application object

Occurs when a message filter is added to the project.

Syntax

object_OnMessageFilterAdd ( filter )

Parameters

object

An expression that evaluates to an Application object.

filter

The MessageFilter object that triggers this event.

Remarks

PCAN-Explorer fires this event before the message filter is added to the project.

For an overview about using event code, see the introduction to events.

Example

Following is a sample event handler for the OnMessageFilterAdd event. Copy this into your Macro file and insert the appropriate code:

VBS Macro

Sub Application_OnMessageFilterAdd(theFilter)

' Insert code to handle the event here

End Sub

See also

OnMessageFilterRemove Event


OnMessageFilterChanged Event

Applies to: Application object

Occurs after properties of a message filter have been changed.

Syntax

object_OnMessageFilterChanged ( filter )

Parameters

object

An expression that evaluates to an Application object.

filter

The MessageFilter object that triggers this event.

Remarks

PCAN-Explorer fires this event after properties of a message filter have been changed.

For an overview about using event code, see the introduction to events.

Example

Following is a sample event handler for the OnMessageFilterChanged event. Copy this into your Macro file and insert the appropriate code:

VBS Macro

Sub Application_OnMessageFilterChanged(theFilter)

' Insert code to handle the event here

End Sub


OnMessageFilterRemove Event

Applies to: Application object

Occurs before a message filter is removed from the project.

Syntax

object_OnMessageFilterRemove ( filter )

Parameters

object

An expression that evaluates to an Application object.

filter

The MessageFilter object that triggers this event.

Remarks

PCAN-Explorer fires this event before the message filter is removed from the project.

For an overview about using event code, see the introduction to events.

Example

Following is a sample event handler for the OnMessageFilterRemove event. Copy this into your Macro file and insert the appropriate code:

VBS Macro

Sub Application_OnMessageFilterRemove(theFilter)

' Insert code to handle the event here

End Sub

See also

OnMessageFilterAdd Event


OnNewDocument Event

Applies to: Application object

Occurs after a specified document is created.

Syntax

object_OnNewDocument ( document )

Parameters

object

An expression that evaluates to an Application object.

document

The Document object that triggers this event.

Remarks

PCAN-Explorer fires this event after the document is created.

For an overview about using event code, see the introduction to events.

Example

Following is a sample event handler for the OnNewDocument event. Copy this into your Macro file and insert the appropriate code:

VBS Macro

Sub Application_OnNewDocument(theDocument)

' Insert code to handle the event here

End Sub


OnOptionsChanged Event

Applies to: Application object

Occurs after PCAN-Explorer options have been changed.

Syntax

object_OnOptionsChanged

Parameters

object

An expression that evaluates to an Application object.

Remarks

PCAN-Explorer fires this event after the Options Dialog box was closed by pressing the OK button.

For an overview about using event code, see the introduction to events.

Example

Following is a sample event handler for the OnOptionsChanged event. Copy this into your Macro file, and then insert the appropriate code:

VBS Macro

Sub Application_OnOptionsChanged()

' Insert code to handle the event here

End Sub


OnProjectClose Event

Applies to: Application object

Occurs before a project is closed.

Syntax

object_OnProjectClose ( project )

Parameters

object

An expression that evaluates to an Application object.

document

The Project object that triggers this event.

Remarks

PCAN-Explorer fires this event before a project is closed.

For an overview about using event code, see the introduction to events.

Example

Following is a sample event handler for the OnProjectClose event. Copy this into your Macro file and insert the appropriate code:

VBS Macro

Sub Application_OnProjectClose(theProject)

' Insert code to handle the event here

End Sub

See also

OnProjectOpen Event


OnProjectOpen Event

Applies to: Application object

Occurs after a project has been opened.

Syntax

object_OnProjectOpen ( project )

Parameters

object

An expression that evaluates to an Application object.

document

The Project object that triggers this event.

Remarks

PCAN-Explorer fires this event after a project has been opened.

For an overview about using event code, see the introduction to events.

Example

Following is a sample event handler for the OnProjectOpen event. Copy this into your Macro file and insert the appropriate code:

VBS Macro

Sub Application_OnProjectOpen(theProject)

' Insert code to handle the event here

End Sub

See also

OnProjectClose Event


OnPropertyValueChanged Event

Applies to: J1939Node object

Occurs after a property of the object has changed.

Syntax

object_OnPropertyValueChanged ( node, property )

Parameters

object

An expression that evaluates to a J1939Node object.

node

The J1939Node object that triggers this event.

property

A TJ1939Property enum value that specifies which property has changed.

The following enum values are possible:

  • propClaimStatus (1): The AddressClaimStatus property has changed.

  • propClientName (2): The ClientName property has changed.

  • propWindowHandle (3): The WindowHandle property has changed.

  • propDevice (4): The Device property has changed.

  • propNetName (5): The NetName property has changed.

  • propResetOnBusOff (6): The ResetOnBusOff property has changed.

  • propIncludeEchoes (7): The IncludeEchoes property has changed.

  • propReceiving (8): The Receiving property has changed.

  • propAddressName (9): A value of the object under the AddressName property has changed.

  • propPreferredAddress (10): The PreferredAddress property has changed.

  • propUseAddressingProtocol (11): The UseAddressingProtocol property has changed.

  • propMonitoring (12): The Monitoring property has changed.

  • propConnected (13): The Connected property has changed.

  • propClaimedAddress (14): The ClaimedAddress property has changed.

  • propFilter (15): A value of one of the filter objects under the Filters property has changed.

  • propNotifyPropertyChanges (16): The NotificationOnPropertyChange property has changed.

  • propNotifyAddressClaiming (17): The NotificationOnAddressClaiming property has changed.

  • propNotifyAddressLost (18): The NotificationOnAddressLost property has changed.

  • propNotifyMessageReceived (20): The NotificationOnMessageReceived property has changed.

  • propPacksCountOnReadSessions (21): The PacksCountOnReadSessions property has changed.

  • propPacksCountOnWriteSessions (22): The PacksCountOnWriteSessions property has changed.

  • propRetriesCountOnWriteSessions (23): The RetriesCountOnWriteSessions property has changed.

  • propReCTSCountOnReadSessions (24): The ReCTSsCountOnReadSessions property has changed.

  • propRcvEventHandle (25): The RcvEventHandle property has changed.

Remarks

The OnPropertyValueChanged event is triggered only if the NotificationOnPropertyChange property is set to True. For the J1939Node objects that PCAN-Explorer creates for its J1939 CommunicationObject objects, this property is automatically set to True.

For an overview about using event code, see the introduction to events.

Example

Following is a sample event handler for the OnPropertyValueChanged event. Copy this into your Macro file, and then insert the appropriate code:

VBS Macro

Sub J1939Node_OnPropertyValueChanged(node, property)

' Insert code to handle the event here

End Sub


OnSymbolsActivate Event

Applies to: Application object

Occurs after a new collection Symbols has been activated.

Syntax

object_OnSymbolsActivate ( Symbols )

Parameters

object

An expression that evaluates to an Application object.

Symbols

The Symbols object that triggers this event.

Remarks

PCAN-Explorer fires this event after the Symbols collection has been activated.

For an overview about using event code, see the introduction to events.

Example

Following is a sample event handler for the OnSymbolsActivate event. Copy this into your Macro file and insert the appropriate code:

VBS Macro

Sub Application_OnSymbolsActivate(theSymbols)

' Insert code to handle the event here

End Sub

See also

OnSymbolsDeactivate Event


OnSymbolsDeactivate Event

Applies to: Application object

Occurs before a symbols collection is deactivated.

Syntax

object_OnSymbolsDeactivate ( Symbols )

Parameters

object

An expression that evaluates to an Application object.

Symbols

The Symbols object that triggers this event.

Remarks

PCAN-Explorer fires this event before a symbols collection is deactivated.

For an overview about using event code, see the introduction to events.

Example

Following is a sample event handler for the OnSymbolsDeactivate event. Copy this into your Macro file and insert the appropriate code:

VBS Macro

Sub Application_OnSymbolsDeactivate(theSymbols)

' Insert code to handle the event here

End Sub

See also

OnSymbolsDeactivated Event

OnSymbolsActivate Event


OnSymbolsDeactivated Event

Applies to: Application object

Occurs after a symbols collection has been deactivated.

Syntax

object_OnSymbolsDeactivated ( Symbols )

Parameters

object

An expression that evaluates to an Application object.

Symbols

The Symbols object that triggers this event.

Remarks

PCAN-Explorer fires this event after a symbols collection has been deactivated.

For an overview about using event code, see the introduction to events.

Example

Following is a sample event handler for the OnSymbolsDeactivated event. Copy this into your Macro file and insert the appropriate code:

VBS Macro

Sub Application_OnSymbolsDeactivated(theSymbols)

' Insert code to handle the event here

End Sub

See also

OnSymbolsDeactivate Event

OnSymbolsActivate Event


OnTracerActivate Event

Applies to: Application object

Occurs after a specified tracer becomes active.

Syntax

object_OnTracerActivate ( tracer )

Parameters

object

An expression that evaluates to an Application object.

tracer

The Tracer object that triggers this event.

Remarks

PCAN-Explorer fires this event after the tracer becomes active.

For an overview about using event code, see the introduction to events.

Example

Following is a sample event handler for the OnTracerActivate event. Copy this into your Macro file and insert the appropriate code:

VBS Macro

Sub Application_OnTracerActivate(theTracer)

' Insert code to handle the event here

End Sub

See also

OnTracerDeactivate Event


OnTracerDeactivate Event

Applies to: Application object

Occurs after a specified tracer becomes inactive.

Syntax

object_OnTracerDeactivate ( tracer )

Parameters

object

An expression that evaluates to an Application object.

tracer

The Tracer object that triggers this event.

Remarks

PCAN-Explorer fires this event after the tracer becomes inactive.

For an overview about using event code, see the introduction to events.

Example

Following is a sample event handler for the OnTracerDeactivate event. Copy this into your Macro file and insert the appropriate code:

VBS Macro

Sub Application_OnTracerDeactivate(theTracer)

' Insert code to handle the event here

End Sub

See also

OnTracerActivate Event


OnTracerFull Event

Applies to: Application object

Occurs after the filling level of a specified tracer has reached 100%.

Syntax

object_OnTracerFull ( tracer )

Parameters

object

An expression that evaluates to an Application object.

tracer

The Tracer object that triggers this event.

Remarks

PCAN-Explorer fires this event after the filling level of a tracer has reached 100%. This event is fired only for tracers that use a linear buffer. The event is fired after the OnTracerStop event has been fired.

For an overview about using event code, see the introduction to events.

Example

Following is a sample event handler for the OnTracerFull event. Copy this into your Macro file and insert the appropriate code:

VBS Macro

Sub Application_OnTracerFull(theTracer)

' Insert code to handle the event here

End Sub

See also

OnTracerStop Event


OnTracerPause Event

Applies to: Application object

Occurs after a specified tracer is paused.

Syntax

object_OnTracerPause ( tracer )

Parameters

object

An expression that evaluates to an Application object.

tracer

The Tracer object that triggers this event.

Remarks

PCAN-Explorer fires this event after the tracer is paused.

For an overview about using event code, see the introduction to events.

Example

Following is a sample event handler for the OnTracerPause event. Copy this into your Macro file and insert the appropriate code:

VBS Macro

Sub Application_OnTracerPause(theTracer)

' Insert code to handle the event here

End Sub

See also

OnTracerStart Event

OnTracerStop Event


OnTracerStart Event

Applies to: Application object

Occurs after a specified tracer is started.

Syntax

object_OnTracerStart ( tracer )

Parameters

object

An expression that evaluates to an Application object.

tracer

The Tracer object that triggers this event.

Remarks

PCAN-Explorer fires this event after the tracer is started.

For an overview about using event code, see the introduction to events.

Example

Following is a sample event handler for the OnTracerStart event. Copy this into your Macro file and insert the appropriate code:

VBS Macro

Sub Application_OnTracerStart(theTracer)

' Insert code to handle the event here

End Sub

See also

OnTracerPause Event

OnTracerStop Event


OnTracerStop Event

Applies to: Application object

Occurs after a specified tracer is stopped.

Syntax

object_OnTracerStop ( tracer )

Parameters

object

An expression that evaluates to an Application object.

tracer

The Tracer object that triggers this event.

Remarks

PCAN-Explorer fires this event after the tracer is stopped.

For an overview about using event code, see the introduction to events.

Example

Following is a sample event handler for the OnTracerStop event. Copy this into your Macro file and insert the appropriate code:

VBS Macro

Sub Application_OnTracerStop(theTracer)

' Insert code to handle the event here

End Sub

See also

OnTracerStart Event

OnTracerPause Event


OnWindowActivate Event

Applies to: Application object

Occurs after a specified window becomes active.

Syntax

object_OnWindowActivate ( window )

Parameters

object

An expression that evaluates to an Application object.

window

The Window object that triggers this event.

Remarks

PCAN-Explorer fires this event after the window becomes active.

For an overview about using event code, see the introduction to events.

Example

Following is a sample event handler for the OnWindowActivate event. Copy this into your Macro file and insert the appropriate code:

VBS Macro

Sub Application_OnWindowActivate(theWindow)

' Insert code to handle the event here

End Sub

See also

OnWindowDeactivate Event


OnWindowDeactivate Event

Applies to: Application object

Occurs after a specified window becomes inactive.

Syntax

object_OnWindowDeactivate ( window )

Parameters

object

An expression that evaluates to an Application object.

window

The Window object that triggers this event.

Remarks

PCAN-Explorer fires this event after a window has been deactivated.

For an overview about using event code, see the introduction to events.

Example

Following is a sample event handler for the OnWindowDeactivate event. Copy this into your Macro file and insert the appropriate code:

VBS Macro

Sub Application_OnWindowDeactivate(theTracer)

' Insert code to handle the event here

End Sub

See also

OnWindowActivate Event


Leitseite: VBScript-Makros

Sie können VBScript-Makros verwenden, um die Arbeit mit PCAN-Explorer zu vereinfachen.

In diesem Abschnitt

Übersicht

Enthält allgemeine Information zu VBScript-Makros.

"Wie kann man ...?"-Themen

Beschreibt die Vorgehensweisen beim Arbeiten mit VBScript-Makros.

Referenz

Enthält die Referenz zu VBScript-Makros.

Weitere Abschnitte

PCAN-Explorer-Objekte

Dokumentation des PCAN-Explorer-Objektmodells.

Add-ins für PCAN-Explorer

Enthält Themen zur Erstellung von PCAN-Explorer Add-ins.

PCAN-Explorer anpassen

Information über Möglichkeiten, PCAN-Explorer an eigene Bedürfnisse anzupassen.


Übersicht: VBScript-Makros

Leitseite (VBScript-Makros) | Wie kann man ...? | Referenz

Mit VBScript-Makros oder PCAN-Explorer-Add-ins können Sie Routineaufgaben automatisieren.

Ein VBScript-Makro ist eine Prozedur, die VBScript-Befehle enthält und keine Parameter benötigt. Ein VBScript-Makro beginnt mit einer Sub-Anweisung, fährt mit VBScript-Befehlen fortt welche die Aufgaben repräsentieren, die Sie durchführen möchten, und endet mit einer End Sub-Anweisung. VBScript-Makros werden in Textdateien gespeichert, die Makrodateien genannt werden.

Um ein VBScript-Makro zu verwenden, führen Sie es aus. Falls Sie es regelmäßig ausgeführen wollen, weisen Sie ihm eine Tastenkombination zu. Dann können Sie das Makro starten, indem Sie einfach die entsprechenden Tasten drücken.

Worüber möchten Sie mehr wissen?

  • Unterschiede zwischen VBScript-Makros und PCAN-Explorer-Add-ins

  • Makrodateien

  • VBScript-Sprache

  • Automation

  • PCAN-Explorer-Objekte

Was möchten Sie tun?

  • Ein Makro schreiben

  • Ein Makro bearbeiten

  • Ein Makro installieren

  • Eine Tastenkombination einem Makro zuweisen

  • Ein Makro ausführen

  • Ein Makro debuggen

  • Ein Makro löschen

  • Ein Makro umbenennen


Unterschiede zwischen VBScript-Makros und PCAN-Explorer-Add-ins

Leitseite (VBScript-Makros) | Übersicht | Wie kann man ...? | Referenz

VBScript-Makros unterscheiden sich von PCAN-Explorer-Add-ins. Der primäre Unterschied liegt darin, dass Makros Prozeduren sind, die in der Programmiersprache Visual Basic Scripting Edition (VBScript) geschrieben sind. Add-ins hingegen sind In-Process COM-Komponenten (DLLs), die in einer beliebigen Programmiersprache wie z.B. Microsoft Visual C++, C#, Embarcadero Delphi oder C++ Builder geschrieben sind.

Man kann VBScript-Makros schneller und leichter erstellen als ein Add-in. Um ein Makro zu erzeugen, muss man nur wenig Quellcode innerhalb der PCAN-Explorer-Oberfläche schreiben und kann das Makro dann direkt starten. Um ein Add-in zu erzeugen, muss man es in einer Programmiersprache wie z.B. Visual C++ schreiben, es zu einer DLL kompilieren, es mit PCAN-Explorer verbinden und dann die Kommandos des Add-ins ausführen.

VBScript-Makros sind nicht so vielseitig wie Add-ins. Makros können nur die VBScript-Sprache verwenden und können nur auf das PCAN-Explorer-Objektmodell zugreifen. Add-ins dagegen können auf alle Ressourcen des PCs zurückgreifen.

Die folgende Tabelle fasst die Unterschiede zwischen Makros und Add-ins zusammen.

VBScript-Makros | PCAN-Explorer Add-ins
Werden interpretiert | Werden kompiliert
Sind einfach zu erzeugen | Sind schwieriger zu erzeugen
Können nur in VBScript geschrieben werden | Können in verschiedenen Programmiersprachen geschrieben werden, z.B. Microsoft Visual C++, C#, Visual Basic, Embarcadero Delphi, C++ Builder
Können nur auf das PCAN-Explorer-Objektmodell zugreifen | Können auf lokale Computer-Ressourcen als auch auf das PCAN-Explorer-Objektmodell zugreifen
Können nur Dialogfenster verwenden, die von den VBScript-Funktionen InputBox und MsgBox erzeugt werden | Können eigene Dialogfenster verwenden
Können nicht die Win32-API verwenden | Können die Win32-API verwenden
Können nicht "Frühe Bindung" verwenden | Können "Frühe Bindung" verwenden, was eine schnellere Ausführung zur Laufzeit bewirkt


Makrodateien

Leitseite (VBScript-Makros) | Übersicht | Wie kann man ...? | Referenz

PCAN-Explorer speichert Makros in Textdateien, die Makrodateien genannt werden. Eine Makrodatei hat die Dateinamenerweiterung .pem und kann einen oder mehrere Makros enthalten. Die Anzahl der Makros ist beliebig.

Sie installieren Makrodateien mit Hilfe des VBS-Makro Manager-Dialogfensters (Menü Werkzeuge, Befehl VBS-Makro Manager) installiert. Einmal installiert, werden sie beim Start von PCAN-Explorer automatisch geladen.

Am Anfang einer Makrodatei befindet sich eine Beschreibung der Datei. Diese Beschreibung wird beim Erzeugen der Datei angegeben. Im Anschluss folgen die Definitionen der Makros.

Bevor der Quellcode für das Makro geschrieben werden kann, hängt PCAN-Explorer einen Makro-Abschnitt an die Datei an. Dieser Abschnitt beginnt mit einer Sub-Anweisung, die den Namen des Makros enthält, gefolgt von einer Beschreibung, die beim Erstellen des Makros angeben werden kann. Abschließend folgt eine End Sub-Anweisung.

Die VBScript-Befehle eines Makros müssen zwischen den Anweisungen Sub und End Sub eingefügt werden.

VBS Macro

Sub MacroName()

'DESCRIPTION: The Macro description goes here

'TODO: The VBScript commands go here

End Sub


"Wie kann man ...?"-Themen: VBScript-Makros

Leitseite (VBScript-Makros) | Übersicht | Referenz

Sie können die Arbeit mit PCAN-Explorer automatisieren, indem Sie VBScript-Makros erstellen, die Routineaufgaben ausführen.

Was möchten Sie tun?

  • Ein Makro schreiben

  • Ein Makro bearbeiten

  • Ein Makro installieren

  • Eine Tastenkombination einem Makro zuweisen

  • Ein Makro ausführen

  • Ein laufendes Makro beenden

  • Ein Makro debuggen

  • Ein Makro löschen

  • Ein Makro umbenennen


Schreiben von VBScript-Makros

Leitseite (VBScript-Makros) | Übersicht | Wie kann man ...? | Referenz

Sie können ein VBScript-Makro schreiben, indem Sie den Code des Makros zu einer neuen oder bereits existierenden Makrodatei hinzufügen.

Um ein Makro zu schreiben:

  1. Wählen Sie im Menü Makro den Befehl Makro.

  2. Um das Makro in eine neue Makrodatei einzufügen, drücken Sie die Schaltfläche Neue Datei und geben dann den Namen und die Beschreibung der Datei ein.

- oder -

Um ein Makro einer existierenden Makrodatei hinzuzufügen, wählen Sie den Dateinamen in der Dropdownliste Datei. Falls die Datei nicht in der Liste enthalten ist, installieren Sie die Datei zuerst.

  3. Geben Sie den Namen des Makros in der Liste Name ein.

  4. Drücken Sie die Schaltfläche Bearbeiten.

  5. Geben Sie im Dialogfenster Neue VBS-Makrodatei eine Beschreibung des Makros ein und klicken Sie auf OK.

PCAN-Explorer öffnet die Makrodatei und erzeugt einen Sub-Block für das neue Makro am Ende der Datei. Wenn zum Beispiel der Makroname MeinMakro lautete, würde der Sub-Block so aussehen:

VBScript-Makro

Sub MeinMakro()
'DESCRIPTION: Hier ist die Makrobeschreibung

'TODO: Hier Makro-Code einfügen
End Sub
Tipp

Es ist eine gute Praxis, Variablen zu deklarieren, die im Makro verwendet werden. Man deklariert Variablen, indem man die VBScript-Anweisung Dim verwendet. Wenn man sicher sein will, dass Variablen deklariert werden, bevor man sie verwendet, kann man die Zeile "Option Explicit" am Anfang der Makrodatei einfügen.


Bearbeiten von VBScript-Makros

Leitseite (VBScript-Makros) | Übersicht | Wie kann man ...? | Referenz

Mit dem Makroeditor können Sie ein existierendes Makro bearbeiten oder ein neues Makro hinzufügen.

Um ein Makro zu bearbeiten:

  1. Wählen Sie im Menü Makro den Befehl Makro.

  2. Wählen Sie in der Dropdownliste Datei die Makrodatei aus, die das Makro enthält, das Sie bearbeiten möchten. Falls die Datei nicht in der Liste enthalten ist, installieren Sie die Datei zuerst, und wählen sie sie dann in der Dropdownliste Datei aus.

  3. Wählen Sie in der Liste Name das Makro aus, das Sie bearbeiten möchten.

  4. Klicken Sie auf die Schaltfläche Bearbeiten.

  5. Führen Sie die Änderungen durch.

  6. Speichern sie das Makro.

Siehe auch

Makro-Dialogfenster

Feedback senden | Copyright © 2011 PEAK-System Technik GmbH. Alle Rechte vorbehalten.


Installieren von VBScript-Makros

Leitseite (VBScript-Makros) | Übersicht | Wie kann man ...? | Referenz

Eine Makrodatei enthält ein oder mehrere Makros. Um diese Makros in PCAN-Explorer verfügbar zu machen, müssen Sie die Makrodatei installieren.

Um eine Makrodatei zu installieren:

  1. Wählen Sie im Menü Makro den Befehl VBS-Makro Manager.

  2. Der Name der Makrodatei sollte in der Liste Makrodateien erscheinen.

  3. Falls der Name der Makrodatei nicht in der Liste erscheint, klicken Sie auf die Schaltfläche Hinzufügen und wählen Sie die Datei aus.

Tipp: Um die Suche nach der Datei zu vermeiden, sollte die Makrodatei im Verzeichnis Dokumente\PCAN-Explorer 6\Macros gespeichert werden. PCAN-Explorer sucht zuerst in diesem Verzeichnis nach Makrodateien.

  4. Laden Sie die entsprechende Makrodatei, indem Sie in das Kontrollkästchen vor dem Namen in der Liste klicken.

PCAN-Explorer setzt einen Haken in das Auswahlfeld, um anzuzeigen, dass die Makrodatei geladen ist. Dieser Haken weist PCAN-Explorer auch an, beim nächsten Start die Makrodatei automatisch zu laden.

Hinweis

Wenn Sie den Haken von der Makrodatei löschen, wird die Datei geschlossen. Wenn Sie die Makrodatei schließen, verlieren alle Makros in der Datei ihre zugewiesenen Tastenkombinationen. Außerdem lädt PCAN-Explorer die Makrodatei beim nächsten Start nicht mehr automatisch.


Zuweisen von Tastenkombinationen zu VBScript-Makros

Leitseite (VBScript-Makros) | Übersicht | Wie kann man ...? | Referenz

Wenn Sie einem Makro eine Tastenkombination zuweisen, können Sie das Makro durch Drücken der zugewiesenen Tasten ausführen.

Um eine Tastenkombination einem Makro zuzuweisen:

  1. Wählen Sie im Menü Werkzeuge den Befehl Optionen.

  2. Wählen Sie die Seite Tastatur.

  3. Wählen Sie den Eintrag Makro in der Dropdownliste Kategorie.

  4. Wählen Sie in der Liste Befehle das Makro aus, zu dem Sie eine Tastenkombination zuweisen möchten.

  5. Klicken Sie in das Feld Drücke neue Tastenkombination.

  6. Drücken Sie die Tastenkombination, die Sie für das gewählte Makro verwenden möchten.

PCAN-Explorer zeigt unterhalb des Feldes die aktuelle Belegung der Tastenkombination an. Falls die gewünschte Tastenkombination noch nicht verwendet wird, erscheint der Text "[nicht zugewiesen]".

  7. Klicken Sie auf die Schaltfläche Zuweisen.

PCAN-Explorer weist die Tastenkombination dem Makro zu.

Hinweis

Dieselbe Tastenkombination kann theoretisch mehreren Befehlen gleichzeitig zugeordnet sein. Dies ist jedoch nicht empfehlenswert, da im Endeffekt nur die zuerst definierte Zuweisung ausgeführt wird.


Ausführen von VBScript-Makros

Leitseite (VBScript-Makros) | Übersicht | Wie kann man ...? | Referenz

Nachdem Sie eine Makrodatei installiert haben, können Sie die darin enthaltenen Makros ausführen. Der einfachste Weg ist die Verwendung von Tastenkombinationen, die Sie den Makros zuvor zugewiesen haben.

Sie können Makros auch aus dem Makro-Dialogfenster ausführen (Menü Makro, Befehl Makro), oder von der Kommandozeile aus.

Um ein Makro aus dem Makro-Dialogfenster auszuführen:

  1. Wählen Sie im Menü Makro den Befehl Makro.

  2. Wählen Sie in der Dropdownliste Datei die Makrodatei aus, die das Makro enthält, das Sie ausführen möchten. Falls die Datei nicht in der Liste enthalten ist, installieren Sie die Datei zuerst, und wählen sie sie dann in der Dropdownliste Datei aus.

  3. Doppelklicken Sie in der Liste Name auf den Namen des Makros, das Sie ausführen möchten.

- oder -

Wählen Sie das Makro in der Liste Name aus und klicken auf die Schaltfläche Ausführen.

Um ein Makro von der Kommandozeile auszuführen:

  • Geben Sie ein: pcanexpl -ex Befehl

wobei Befehl der Name des Makros ist. Diese Syntax startet PCAN-Explorer. Nachdem das PCAN-Explorer-Hauptfenster erschienen ist, wird das Makro ausgeführt.

Nachdem das Makro vollständig ausgeführt wurde, läuft PCAN-Explorer weiter. Wenn PCAN-Explorer automatisch beendet werden soll, muss das Makro die Quit-Methode des Application-Objekts aufrufen.

Siehe auch

Macro-Dialogfenster


Beenden von VBScript-Makros

Leitseite (VBScript-Makros) | Übersicht | Wie kann man ...? | Referenz

Während ein VBScript-Makro ausgeführt wird, erscheint ein entsprechendes Symbol in der Windows-Taskleiste. Wenn das Makro schnell ausgeführt wird, erscheint das Symbol nur kurz. Benötigt das Makro für die Ausführung eine längere Zeit, bleibt das Symbol so lange sichtbar, bis das Makro beendet ist.

Sie können ein laufendes Makro beenden, bevor es vollständig ausgeführt ist.

Um ein Makro zu beenden:

  • Führen Sie ein Doppelklick auf das Makro-Symbol [image] in der Windows-Taskleiste aus.

Achtung

Wenn das Makro aus irgendeinem Grund nicht beendet wird, kann dies zur Folge haben, dass PCAN-Explorer nicht mehr reagiert. Wenn das geschieht, drücken Sie bitte [Strg+Alt+Entf] und beenden den PCAN-Explorer-Task.


Debuggen von VBScript-Makros

Leitseite (VBScript-Makros) | Übersicht | Wie kann man ...? | Referenz

PCAN-Explorer enthält Möglichkeiten, die beim Debuggen von VBScript-Makros helfen können.

Um ein Makro zu debuggen:

  • Verwenden Sie die PrintToOutputWindow-Methode, um Diagnosenachrichten oder Werte von Variablen an verschiedenen Stellen im Makro im Ausgabe-Fenster anzuzeigen.

  • Verwenden Sie die VBScript MsgBox-Funktion, um das Makro anzuhalten, so dass Sie die Nachrichten untersuchen können, die mit PrintToOutputWindow oder MsgBox ausgegeben wurden. Wenn Sie bereit sind, das Makro fortzuführen, schließen Sie das Dialogfenster.


Löschen von VBScript-Makros

Leitseite (VBScript-Makros) | Übersicht | Wie kann man ...? | Referenz

Wenn Sie ein Makro nicht länger benötigen, können Sie es löschen.

Um ein Makro zu löschen:

  1. Wählen Sie im Menü Makro den Befehl Makro.

  2. Wählen Sie in der Dropdownliste Datei die Makrodatei aus, die das Makro enthält, das Sie löschen möchten.

  3. Wählen Sie in der Liste Name das Makro aus, das Sie löschen möchten.

  4. Klicken Sie auf die Schaltfläche Bearbeiten.

  5. Löschen Sie den Sub-Block, der den Makro-Code enthält.

  6. Speichern Sie das Makro.


Umbenennen von VBScript-Makros

Leitseite (VBScript-Makros) | Übersicht | Wie kann man ...? | Referenz

Falls nötig, können Sie ein Makro durch entsprechende Änderung im Quellcode umbenennen.

Um ein Makro umzubenennen:

  1. Wählen Sie im Menü Makro den Befehl Makro.

  2. Wählen Sie in der Dropdownliste Datei die Makrodatei aus, die das Makro enthält, das Sie löschen möchten. Falls die Datei nicht in der Liste enthalten ist, installieren Sie die Datei zuerst, und wählen sie sie dann in der Dropdownliste Datei aus.

  3. Wählen Sie in der Liste Name das Makro aus, das Sie umbenennen möchten.

  4. Klicken Sie auf die Schaltfläche Bearbeiten.

  5. Gehen Sie zu dem Sub-Block, der den Makro-Quellcode enthält.

  6. In der Zeile, die den Namen des Makros enthält, ändern Sie den Makronamen.

  7. Speichern Sie das Makro.

Siehe auch

Makro-Dialogfenster


Referenz: VBScript-Makros

Leitseite (VBScript-Makros) | Übersicht | Wie kann man ...?

In der PCAN-Explorer-Oberfläche kann man Makros in der Programmiersprache Visual Basic Scripting Edition (VBScript) schreiben, speichern und editieren.

Siehe auch

VBScript-Benutzerhandbuch

VBScript-Sprachverzeichnis


Leitseite: Add-ins für PCAN-Explorer

PCAN-Explorer-Add-ins sind In-process COM-Komponenten (DLLs), die z.B. mit Microsoft Visual C++, C#, Visual Basic, Embarcadero Delphi oder C++ Builder geschrieben werden können. Mit Add-ins können Sie in PCAN-Explorer Aufgaben automatisieren, indem Sie

  • Befehle hinzufügen die diese Aufgaben erledigen

  • Schaltflächen zur Symbolleiste hinzufügen, die diese Befehle ausführen

  • Auf PCAN-Explorer-Ereignisse reagieren.

In diesem Abschnitt

Übersicht

Information zur Funktionsweise von Add-ins und zur Kommunikation von PCAN-Explorer mit Add-ins.

Wie kann man ...?

Vorgehensweisen beim Erstellen von Add-ins.

Referenz

Enthält die Referenz zu allen Objekten, Methoden und Interfaces, die beim Erstellen und der Verwendung von Add-ins benötigt werden.

Weitere Abschnitte

VBScript-Makros

Dokumentation über VBScript-Makros sowie deren Erstellung und Verwendung.

Callback-Bibliotheken

Enthält Themen über die Erstellung und Verwendung von Callback-Bibliotheken in Projekten.

PCAN-Explorer-Objekte

Dokumentation des PCAN-Explorer-Objektmodells.

PCAN-Explorer anpassen

Information über Möglichkeiten, PCAN-Explorer an eigene Bedürfnisse anzupassen.


Übersicht: Add-ins für PCAN-Explorer

Leitseite (Add-ins) | Wie kann man ...? | Referenz

Mit Add-ins oder VBScript-Makros können Sie Aufgaben in PCAN-Explorer automatisieren. Zum Beispiel könnten Sie automatisch bestimmte Dateien (Symbole, Makros, Sendelisten) öffnen und dann ein bestimmtes PCAN-Explorer-Makro starten.

Sie können Aufgaben automatisieren, indem Sie Automation (früher OLE Automation) benutzen. Mit Automation werden die PCAN-Explorer-Oberfläche und seine Komponenten zu Objekten, die Sie per Programm steuern können. Zum Beispiel werden Fenster zu Objekten, die Sie aktivieren und in der Größe verändern können. Ähnlich werden Dokumente zu Objekten, die Sie öffnen, editieren und schließen können.

Mit Add-ins können Sie Aufgaben automatisieren, indem Sie Befehle zur PCAN-Explorer-Oberfläche hinzufügen. Jedes Add-in kann ein oder mehrere Befehle hinzufügen, und jeder Befehl kann ein oder mehrere Aufgaben ausführen. Die Anzahl der Befehle und Aufgaben ist frei programmierbar.

Optional können Add-ins Symbolleistenschaltflächen oder Tastenkombinationen bereitstellen, mit denen ihre Befehle ausgeführt werden können. Ohne die Schaltflächen und Tastenkombination müssen die Befehle von der Kommandozeile ausgeführt werden.

Ein Add-in zu erzeugen ist ein Prozess, der aus drei Schritten besteht: Erstens müssen Sie den Code für das Add-in schreiben. Zweitens, schreiben Sie den Code zum Hinzufügen der Befehle, Symbolleistenschaltflächen und Tastenkombinationen. Und drittens kompilieren und testen Sie die DLL für das Add-in.

Nachdem Sie das Add-in erzeugt haben, verbinden Sie es mit der PCAN-Explorer-Umgebung. Wenn es sich verbindet, fügt es die Befehle, Symbolleistenschaltflächen und Tastenkombinationen zur Oberfläche hinzu. Später, wenn das Add-in nicht benötigt wird, können Sie alle Elemente wieder entfernen, indem Sie das Add-in von PCAN-Explorer trennen.

Weitere Themen

  • Unterschiede zwischen Add-ins und VBScript-Makros

  • Entwerfen von Add-ins

  • Der Prozess zum Erzeugen von Add-ins

  • Wie sich Add-ins verbinden und trennen

  • Wie Add-ins Befehle, Symbolleistenschaltflächen und Tastenkombinationen hinzufügen

  • Wie Add-in-Befehle ausgeführt werden

  • Steuern von PCAN-Explorer-Objekten durch Dual Interfaces

  • Definieren neuer Dokumenttypen mit Add-ins

  • Wie ActiveX-Steuerelemente verbunden und getrennt werden

  • Wie Add-in-Dokumentdaten geladen uns gespeichert werden

  • Wie Add-ins bei Änderung eines Signalwertes benachrichtigt werden

  • Wie Add-ins beim Empfang einer Botschaft benachrichtigt werden

  • Wie Add-ins beim Senden von Botschaften benachrichtigt werden


Entwerfen von Add-ins

Leitseite (Add-ins) | Übersicht | Wie kann man ...? | Referenz

Bevor Sie Add-ins erstellen, sollten Sie folgende Überlegungen zum Entwurf anstellen:

  • Welche Aufgaben soll das Add-in ausführen?

  • Könnten Sie ein VBScript-Makro verwenden, um die Aufgabe auszuführen?

Sie können ein VBScript-Makro schneller erstellen als ein Add-in. Bevor Sie beginnen, sollten Sie die Unterschiede zwischen Makros und Add-ins sorgfältig betrachten.

  • Welche Befehle soll das Add-in benutzen um die Aufgaben durchzuführen?

  • Welche PCAN-Explorer-Objekte werden in den Befehlen des Add-ins referenziert?

  • Welche PCAN-Explorer-Methoden und Eigenschaften werden in den Befehlen des Add-ins benutzt?

  • Wie viele Add-ins werden Sie benötigen?

Wenn Sie mehrere benötigen, können Sie sie in der selben DLL kombinieren.

  • Wird das Add-in ein ActiveX-Steuerelement anzeigen?

Ein Add-in kann neue Dokumenttypen zu PCAN-Explorer hinzufügen, die zur visuellen Darstellung ein ActiveX-Steuerelement in einem Fenster anzeigen.

  • Wird das Add-in Ereignisse behandeln?

Ein Add-in kann Ereignisse behandeln, die von PCAN-Explorer ausgelöst werden. Zeigt das Add-in in einem Fenster ein ActiveX-Steuerelement an, kann dieses wiederum Ereignisse auslösen, die dann vom Add-in behandelt werden.

  • Wird das Add-in eine andere Applikation steuern?

Ein Add-in kann eine anderes Programm (.exe) steuern, indem es als Out-Of-Process-Controller für die andere Applikation dient.

  • Wird das Add-in mehr als einen Thread haben?

Wenn Sie ein multithreaded Add-in entwerfen, sind die Effekte unvorhersehbar. Ein Add-in kann mehrere Threads haben, wenn keiner davon eine Message-Pumpe haben wird, und nur einer auf das PCAN-Explorer-Objektmodell zugreift.

  • Wird das Add-in Befehle eines anderen Add-ins ausführen?

  • Wird das Add-in eine Hilfedatei haben?

Falls das Add-in ein Fenster anzeigt, das ein ActiveX-Steuerelement enthält, fragt PCAN-Explorer das ActiveX-Steuerelement nach einer Hilfedatei und einem Hilfethema ab, so dass das Hilfesystem über die Taste [F1] angezeigt werden kann. Andernfalls muss das Add-in selbst einen Befehl zur Anzeige der Hilfedatei bereitstellen.


Der Prozess zum Erzeugen von Add-ins

Leitseite (Add-ins) | Übersicht | Wie kann man ...? | Referenz

Nachfolgend ist eine Zusammenfassung über den Entwurfsprozess eines Add-ins aufgeführt. Für Schritt-für-Schritt-Anweisungen siehe "Wie kann man ...?"-Themen: Add-ins für PCAN-Explorer.

  1. Entscheiden Sie, welche Programmiersprache Sie verwenden möchten.

  2. Erzeugen Sie ein Projekt für das Add-in mit einer 32-Bit Build-Konfiguration.

  3. Schreiben Sie den Code für das Add-in.

  4. Erzeugen Sie die DLL aus den Quellcode-Dateien.

Bedenken Sie, dass Sie mehrere Add-ins in einer DLL kombinieren können.

  5. Verbinden Sie das Add-in mit der PCAN-Explorer-Umgebung.

Wenn Sie das Add-in verbinden, fügt es seine Befehle der PCAN-Explorer-Umgebung hinzu. Für Details siehe Verbinden von Add-ins mit PCAN-Explorer.

  6. Führen Sie die Befehle aus, die zu PCAN-Explorer hinzugefügt wurden.

Sie können diese Befehle von der Kommandozeile ausführen, oder Sie können die Symbolleistenschaltfläche oder Tastenkombination verwenden, die mit diesen Befehlen verbunden sind. Für Details, siehe Ausführen von Add-in-Befehlen.


Wie sich Add-ins verbinden und trennen

Leitseite (Add-ins) | Übersicht | Wie kann man ...? | Referenz

Beim Start von PCAN-Explorer werden automatisch alle Add-ins geladen, die im Add-in Manager-Dialogfenster mit einem Haken versehen sind (Menü Werkzeuge, Befehl Add-in Manager). Dies geschieht, indem PCAN-Explorer für jedes Add-in die OnConnection-Methode ausführt, die von dem PEAddIn-Objekt des jeweiligen Add-ins veröffentlicht wird. Diese Methode macht außerdem die vom Add-in bereitgestellten Befehle für den Benutzer zugänglich. Weiterhin verbindet sie das Add-in mit PCAN-Explorer-Ereignissen, falls das Add-in Methoden für die Ereignisbehandlung enthält.

Beim Beenden gibt PCAN-Explorer jedes Add-in frei, indem die jeweilige OnDisconnection-Methode aufgerufen wird. Diese wird vom PEAddIn-Objekt des Add-ins veröffentlicht.

PEAddIn-Objekt

Jedes Add-in veröffentlicht ein PEAddIn-Objekt und ein Commands-Objekt. PCAN-Explorer verwendet das PEAddIn-Objekt, um sich mit dem Add-in zu verbinden oder sich von ihm zu trennen. Außerdem wird die Verfügbarkeit von Befehle festgestellt. PCAN-Explorer verwendet das Commands-Objekt zum Ausführen der Befehle, die mittels der AddCommand-Methode hinzugefügt wurden.

Ein Add-in veröffentlicht das PEAddIn-Objekt, indem es das COM-Interface IPEExtensibility implementiert.

Commands-Objekt

Jedes Add-in veröffentlicht ein PEAddIn-Objekt und ein Commands-Objekt. PCAN-Explorer verwendet das PEAddIn-Objekt, um sich mit dem Add-in zu verbinden oder sich von ihm zu trennen. PCAN-Explorer verwendet das Commands-Objekt zum Ausführen der Befehle, die mittels der AddCommand-Methode hinzugefügt wurden.

Das Commands-Objekt veröffentlicht eine Methode für jeden Befehl, den es mit AddCommand hinzufügt. Die Implementierung dieser Methode legt schließlich fest, was der Befehl bewirkt.

Siehe auch

IPEExtensibility-Interface


Wie Add-ins Befehle, Symbolleistenschaltflächen und Tastenkombinationen hinzufügen

Leitseite (Add-ins) | Übersicht | Wie kann man ...? | Referenz

Während sich ein Add-in mit der PCAN-Explorer-Umgebung verbindet, fügt es seine Befehle zur Umgebung hinzu. Optional kann das Add-in auch Symbolleistenschaltflächen und Tastenkombinationen zum Ausführen dieser Befehle hinzufügen.

Die folgende Tabelle fasst zusammen, wie ein Add-in Befehle, Symbolleistenschaltflächen und Tastenkombinationen hinzufügt.

Hinzufügen von | Ein Add-in ruft auf
Ein Befehl | Die Methode AddCommand
Eine Symbolleistenschaltfläche | Die Methode AddCommandBarButton
Eine Tastenkombination | Die Methode AddKeybinding

Achtung: Wenn Tastenkombinationen nicht unbedingt nötig sind, fügen Sie keine per Code hinzu, da sie bestehende Tastenkombinationen ersetzen könnten. Ist zum Beispiel eine Tastenkombination zu einem Befehl zugewiesen und Sie fügen dieselbe Tastenkombination zu einem anderen Befehl hinzu, ersetzen Sie damit das Original. Für das beste Ergebnis lassen Sie den Benutzer Tastenkombinationen den Befehlen des Add-ins zuweisen.


Wie Add-in-Befehle ausgeführt werden

Leitseite (Add-ins) | Übersicht | Wie kann man ...? | Referenz

Wenn ein Benutzer ein Befehl ausführt, das von einem Add-in bereitgestellt wird, ruft PCAN-Explorer eine Methode auf, die mit dem Befehl assoziiert ist. Diese Methode spezifiziert, was der Befehl tun soll. Sie wird von dem Commmands-Objekt veröffentlicht, das mit dem Befehl verbunden ist.

PCAN-Explorer findet den Namen der Methode, wenn das Add-in die Methode AddCommand aufgerufen hat. Dadurch wird ein Befehl zu PCAN-Explorer hinzugefügt. Dann ruft PCAN-Explorer diese Methode auf, indem er mit dem Add-in über das Dispatch-Interface kommuniziert. Letzteres wird von dem Commands-Objekt implementiert.

Siehe auch

Ausführen von Add-in-Befehlen


Steuern von PCAN-Explorer-Objekten durch Dual Interfaces

Leitseite (Add-ins) | Übersicht | Wie kann man ...? | Referenz

Jedes PCAN-Explorer-Objekt implementiert ein Dual Interface, durch das Sie das Objekt steuern können. Jedes Objekt implementiert ein IDispatch-Interface für Automation, und ein COM-Interface für direkten Zugriff auf Objektglieder (Eigenschaften, Methoden und Ereignisse).

Die folgende Tabelle zeigt das von jedem PCAN-Explorer-Objekt verwendete Dual Interface.

Objekt | Dual Interface
AddIn | IPEAddIn
AddIns | IPEAddIns
Application | IPEApplication
Connection | IPEConnection
Connections | IPEConnections
Document | IPEDocument
Documents | IPEDocuments
Enum | IPEEnum
Enums | IPEEnums
MessageFilter | IPEMessageFilter
MessageFilterItem | IPEMessageFilterItem
MessageFilters | IPEMessageFilters
Messages | IPEMessages
Multiplexer | IPEMultiplexer
Multiplexers | IPEMultiplexers
OutputWindow | IPEOutputWindow
OutputWindowPane | IPEOutputWindowPane
OutputWindowPanes | IPEOutputWindowPanes
PCANClient | IPCANClient
PCANClientConnection | IPCANClientConnection
PCANClientConnections | IPCANClientConnections
PCANMessage | IPCANMessage
PCANMessages | IPCANMessages
ReceiveMessage | IPEReceiveMessage
ReceiveMessages | IPEReceiveMessages
ReceiveTransmitWindow | IPEReceiveTransmitWindow
Signal | IPESignal
Signals | IPESignals
Symbol | IPESymbol
Symbols | IPESymbols
SymbolsManager | IPESymbolsManager
TextDocument | IPETextDocument
TextEditor | IPETextEditor
TextSelection | IPETextSelection
TextWindow | IPETextWindow
Tracer | IPETracer
TraceMessage | IPETraceMessage
TraceWindow | IPETraceWindow
TransmitMessage | IPETransmitMessage
TransmitMessages | IPETransmitMessages
TransmitWindow | IPETransmitWindow
Variable | IPEVariable
Variables | IPEVariables
VBSMacroFile | IPEVBSMacroFile
VBSMacroFiles | IPEVBSMacroFiles
Window | IPEWindow
Windows | IPEWindows

Die meisten Compiler können sich die frühe Bindung zunutze machen. Die frühe Bindung macht Aufrufe der Interface-Glieder zur Laufzeit schneller.

Wechseln zwischen Dual Interfaces

Sie können von einem Dual Interface zu einem anderen wechseln, indem Sie QueryInterface aufrufen. Um beispielsweise vom COM-Interface IPEDocument eines TextDocument-Objekts zum COM-Interface IPETextDocument zu wechseln, verwenden Sie folgenden Code:

Visual C++

IPEDocument* pDoc;

pApplication->Get_ActiveDocument(&pDoc);

BSTR bstrType;

pDoc->Get_Type(&bstrType)

if (!wcscmp(bstrType, L"Text"))

{

// Es ist ein Textdokument,

// ..deshalb QI für das richtige Interface

IPETextDocument* pTextDoc;

pDoc->QueryInterface(IID_IPETextDocument, &pTextDoc)

// Jetzt können wir textspezifische Glieder

// von pTextDoc aufrufen

pTextDoc->Release();

}

SysFreeString(bstrType)

pDoc->Release();
Delphi

var

pDoc: IPEDocument;

pTextDoc: IPETextDocument;

strType: WideString;

begin

pDoc := pApplication.ActiveDocument;

if AnsiCompareText(pDoc.Type_, "Text") = 0 then

begin

// Es ist ein Textdokument,

// Interface umwandeln

pTextDoc := pDoc as IPETextDocument;

// Jetzt können wir textspezifische Glieder

// von pTextDoc aufrufen

end;

end;

Verwenden von Rückgabewerten von Dual Interfaces in C++

Wenn eine Eigenschaft oder Methode eines PCAN-Explorer-Objekts einen Rückgabewert vom Typ T hat, dann gibt die entsprechende Dual Interface-Methode einen HRESULT-Wert zurück, aber akzeptiert einen weiteren Parameter vom Typ "Zeiger auf T" (oder T*). Dieses Argument ist am Ende der Argumentliste. Beispiel: Ist eine Eigenschaft vom Typ Long, dann akzeptiert die entsprechende Dual Interface Methode ein zusätzliches Argument vom Typ "Zeiger auf Long" (oder Long*).

Wenn die Methode ausgeführt ist, speichert PCAN-Explorer den Rückgabewert dort, wohin der letzte Parameter zeigt. Beispiel: Die Close-Methode des IPETextWindow-Interfaces gibt einen PeSaveStatus-Wert zurück. Die Dual Interface-Version dieser Methode ist deklariert als

HRESULT Close (VARIANT vSaveChanges, PeSaveStatus* pSaved)

Der letzte Parameter, welcher als PeSaveStatus* deklariert ist, ist der Speicherort des Rückgabewertes.

Der Visual C++ Code hierfür sieht folgendermaßen aus:

Visual C++

PeSaveStatus saveStatus;

if (myTxtWindow->Close(VARIANT_TRUE, &saveStatus) == S_OK)

{

// Der Code hier könnte den saveStatus Wert testen,

// der von Close zurückgegeben wurde

}

Wenn die Funktion zurückkehrt, wird der von der Dual Interface-Methode zurückgegebene HRESULT einen Erfolgscode wie S_OK sein. Wenn die Funktion fehlschlägt, gibt sie einen Fehlercode zurück. Dieser Fehlercode hat den gleichen Wert wie der einer Dispatch Exception, wenn man die Methode über das Dispatch Interface aufruft.

Manipulieren der Eigenschaften von Objekten durch Dual Interfaces in C++

Um eine Eigenschaft eines Objekts zu erhalten, stellen Sie dem Eigenschaftsnamen "get_" voran. Alternativ, um eine Eigenschaft zu setzen, stellen Sie dem Eigenschaftsnamen "put_" voran.

Um beispielsweise die Höhe eines Fensters zu erhalten, stellen Sie der Height-Eigenschaft eines Window-Objekts ein "get_" voran, wie in folgendem Beispiel gezeigt:

C++

long nHeight;

if (pWnd->get_Height(&nHeight) == S_OK)

{

// Code zum Auswerten der Height-Eigenschaft

// durch nHeight

}

Alternativ dazu der Code zum Setzen der Height-Eigenschaft auf den Wert 150:

C++

pWnd->put_Height(150);

Aufrugen von Methoden von Dual Interfaces

Einige Dual Interface-Methoden haben Parameter namens "Reserved" des Typs VARIANT, und andere Methoden verwenden Parameter, die optional sind. In VBScript-Makros oder Add-ins, die mit Visual Basic geschrieben sind, kann man solche Parameter weglassen. Andererseits muss man bei Add-ins, die z.B. mit Visual C++ geschrieben werden, diese Parameter angeben. Man muss dann einen VT_ERROR VARIANT für jeden Parameter angeben, und man muss den "scode" des VARIANT als DISP_E_PARAMNOTFOUND spezifizieren.

Beispielsweise können Sie mit MFC die Close-Methode des Window-Objekts aufrufen, indem Sie folgenden Code verwenden:

Visual C++

COleVariant var(0L, VT_ERROR);

var.scode = DISP_E_PARAMNOTFOUND;

pWindow->Close(var);

In Embarcadero Delphi sieht das so aus:

Delphi

pWindow.Close(EmptyParam);


Definieren neuer Dokumenttypen mit Add-ins

Leitseite (Add-ins) | Übersicht | Wie kann man ...? | Referenz

Add-ins können nicht nur neue Befehle zu PCAN-Explorer hinzufügen, sondern auch vollkommen neue Dokumenttypen implementieren, die sich genauso verhalten, wie die vorhandenen Dokumenttypen. Solche neuen Dokumenttypen verwenden für ihre Visualisierung ActiveX-Steuerelemente.

Ein neuer Dokumenttyp kann hinzugefügt werden, indem die AddDocumentType-Methode aufgerufen wird.

Siehe auch

Wie ActiveX-Steuerelemente verbunden und getrennt werden

Wie Add-in-Dokumentdaten geladen uns gespeichert werden


Wie ActiveX-Steuerelemente verbunden und getrennt werden

Leitseite (Add-ins) | Übersicht | Wie kann man ...? | Referenz

Damit PCAN-Explorer das ActiveX-Steuerelement verwalten kann, das zur Darstellung der Dokumentdaten dient, muss dieses das COM-Interface IPEToolWindow implementieren. Dieses Interface definiert die Methoden OnWindowCreate und OnWindowDestroy.

Wenn PCAN-Explorer ein Dokument erzeugt, dessen Typ von einem Add-in hinzugefügt wurde, wird ebenfalls eine neue Ansicht auf das Dokument erzeugt. Diese verwendet dann das ActiveX-Steuerelement. PCAN-Explorer initialisiert das ActiveX-Steuerelement, indem er die OnWindowCreate-Methode ausführt, die von dem ActiveX-Steuerelement implementiert werden muss.

Beim Schließen des Dokuments oder des Fensters gibt PCAN-Explorer das enthaltene ActiveX-Steuerelement frei. Dazu wird die OnWindowDestroy-Methode des ActiveX-Steuerelements ausgeführt.

Siehe auch

IPEToolWindow-Interface


Wie Add-in-Dokumentdaten geladen und gespeichert werden

Leitseite (Add-ins) | Übersicht | Wie kann man ...? | Referenz

PCAN-Explorer kann das ActiveX-Steuerelement, das zur visuellen Darstellung der Dokumentdaten dient, über das Laden und Speichern der Daten eines Dokuments benachrichtigen. Dazu muss das ActiveX-Steuerelement das COM-Interface IPEToolDocument implementieren, in dem die Methoden OnLoad und OnSave definiert sind.

Zum Laden eines Dokuments aus einer Datei, dessen Typ von einem Add-in hinzugefügt wurde, führt PCAN-Explorer die OnLoad-Methode aus, die von dem ActiveX-Steuerelement implementiert wird.

Beim Speichern des Dokuments wird entsprechend die OnSave-Methode ausgeführt.

Siehe auch

IPEToolDocument-Interface


Wie Add-ins bei Änderung eines Signalwertes benachrichtigt werden

Leitseite (Add-ins) | Übersicht | Wie kann man ...? | Referenz

Soll ein Add-in bei Änderung eines Signalwertes benachrichtigt werden, muss es ein SignalCallback-Objekt veröffentlichen und einen Zeiger auf dessen COM-Interface bei einem Signal-Objekt registrieren.

SignalCallback-Objekt

Ein Add-in muss ein oder mehrere SignalCallback-Objekte veröffentlichen, wenn es bei Veränderung von einem oder mehreren verschiedenen Signalwerten benachrichtigt werden möchte. PCAN-Explorer verwendet ein SignalCallback-Objekt, um das Add-in bei Änderung eines Signalwerts zu benachrichtigen, indem die OnChangeValue-Methode des entsprechenden SignalCallback-Objekts aufgerufen wird.

Ein Add-in veröffentlicht ein SignalCallback-Objekt, indem es das COM-Interface IPESignalCallback implementiert.


Wie Add-ins bei Empfang einer Botschaft benachrichtigt werden

Leitseite (Add-ins) | Übersicht | Wie kann man ...? | Referenz

Soll ein Add-in beim Empfang einer Botschaft benachrichtigt werden, muss es ein ReceiveCallback-Objekt veröffentlichen und einen Zeiger auf dessen COM-Interface bei der ReceiveMessages-Kollektion registrieren.

ReceiveCallback-Objekt

Ein Add-in muss ein ReceiveCallback-Objekt veröffentlichen, wenn es beim Empfang einer Botschaft informiert werden soll. PCAN-Explorer verwendet das ReceiveCallback-Objekt, um das Add-in beim Empfang einer Botschaft zu informieren, indem die OnReceive-Methode aufgerufen wird.

Ein Add-in veröffentlicht ein ReceiveCallback-Objekt, indem es das COM-Interface IPEReceiveCallback implementiert, und das Objekt dann durch Aufruf der Methode RegisterCallback für die entsprechenden Benachrichtigungen registriert.


Wie Add-ins beim Senden von Botschaften benachrichtigt werden

Leitseite (Add-ins) | Übersicht | Wie kann man ...? | Referenz

Soll ein Add-in beim Senden von Botschaften benachrichtigt werden, muss es ein TransmitCallback-Objekt veröffentlichen und einen Zeiger auf dessen COM-Interface bei der TransmitMessages-Kollektion registrieren.

TransmitCallback-Objekt

Ein Add-in muss ein TransmitCallback-Objekt veröffentlichen, wenn es über das Senden von Botschaften informiert werden soll. PCAN-Explorer verwendet das TransmitCallback-Objekt, um das Add-in vor und nach dem Senden von Botschaften zu informieren, indem die Methoden OnBeforeTransmit und/oder OnAfterTransmit aufgerufen werden.

Ein Add-in veröffentlicht ein TransmitCallback-Objekt, indem es das COM-Interface IPETransmitCallback implementiert, und das Objekt durch Aufruf der Methode RegisterCallback für die entsprechenden Benachrichtigungen registriert.


"Wie kann man ...?"-Themen: Add-ins für PCAN-Explorer

Leitseite (Add-ins) | Übersicht | Referenz

Mit Add-ins können Sie Aufgaben automatisieren, indem Sie Befehle hinzufügen, die diese Aufgaben erledigen. Weiterhin können Sie Symbolleistenschaltflächen oder Tastenkombinationen hinzufügen, die diese Befehle ausführen - genauso einfach wie man alle anderen Befehle von PCAN-Explorer verwenden kann.

Worüber möchten Sie mehr wissen?

  • Entwerfen von Add-ins

  • Der Entwurfsprozess für Add-ins

Was möchten Sie tun?

  • Verbinden eines Add-ins mit PCAN-Explorer

  • Ausführen von Add-in-Befehlen

  • Zuweisen von Tastenkombinationen zu Add-in-Befehlen

  • Trennen eines Add-ins von PCAN-Explorer

  • Hinzufügen einer Benachrichtigung bei Änderung eines Signalwertes

  • Entfernen einer Benachrichtigung bei Änderung eines Signalwertes


Hinzufügen von Befehlen zu PCAN-Explorer

Leitseite (Add-ins) | Übersicht | Wie kann man ...? | Referenz

Um ein Befehl hinzuzufügen:

  1. Fügen Sie zum ICommands-Interface eine Methodendeklaration hinzu, die den Befehl ausführen soll.

  2. Schreiben Sie die Implementierung der Methode.

  3. Fügen Sie in der Implementierung der OnConnection-Methode des Add-ins einen Aufruf von AddCommand hinzu und geben Sie die Parameter an.

  4. Erzeugen Sie wahlweise eine Symbolleistenschaltfläche, mit deren Hilfe Benutzer den Befehl ausführen können. Siehe Hinzufügen von Symbolleistenschaltflächen für Add-in-Befehle.

  5. Fügen Sie dem Befehl wahlweise eine Tastenkombination hinzu. Siehe Zuweisen von Tastenkombinationen zu Add-in-Befehlen.


Hinzufügen von Symbolleistenschaltflächen für Add-in-Befehle

Leitseite (Add-ins) | Übersicht | Wie kann man ...? | Referenz

Der Benutzer kann Add-in-Befehle ausführen, indem er die Symbolleistenschaltfläche anklickt, die dem Befehl zugewiesen ist.

Um eine Symbolleistenschaltfläche für einen Befehl hinzuzufügen:

  1. Gehen Sie zur Implementierung der OnConnection-Methode im Code.

  2. Suchen Sie nach dem Code, der einen Befehl hinzufüge. Dieser Befehl ruft die AddCommand-Methode auf.

  3. Fügen Sie nach dem AddCommand-Aufruf einen Aufruf von AddCommandBarButton hinzu.

  4. Prüfen Sie in der Methode OnEnableCommand des PEAddIn-Objekts die Verfügbarkeit des Befehls und geben Sie den entsprechenden Wert an PCAN-Explorer zurück.

Wenn der Benutzer das Add-in von PCAN-Explorer trennt, muss das Add-in die von ihm hinzugefügten Schaltflächen nicht entfernen, dies geschieht automatisch.


Zuweisen von Tastenkombinationen zu Add-in-Befehlen per Programm

Leitseite (Add-ins) | Übersicht | Wie kann man ...? | Referenz

Sie können einen Add-in-Befehl ausführen, indem Sie eine Tastenkombination verwenden, die dem Befehl zugewiesen ist. Eine Tastenkombination kann mittels der Benutzeroberfläche oder per Programm hinzufügt werden.

Um eine Tastenkombination per Programm hinzuzufügen:

  1. Gehen Sie zur Implementierung der OnConnection-Methode im Add-in-Projekt.

  2. Suchen Sie nach dem Code, der einen Befehl hinzufügen. Dieser Befehl ruft die AddCommand-Methode auf.

  3. Fügen Sie nach dem AddCommand-Aufruf einen Aufruf von AddKeybinding hinzu.

Achtung: Wenn Tastenkombinationen nicht unbedingt notwendig sind, sollten sie nicht hinzugefügt werden. Neue Tastenkombinationen könnten mit bestehenden in Konflikt geraten, was unvorhersehbare Ergebnisse für den Benutzer hat.


Verbinden von Add-ins mit PCAN-Explorer

Leitseite (Add-ins) | Übersicht | Wie kann man ...? | Referenz

Um Befehle eines Add-ins auszuführen, muss das Add-in zuerst mit PCAN-Explorer verbunden werden.

Um ein Add-in der PCAN-Explorer-Umgebung zu verbinden:

  1. Wählen Sie im Menü Werkzeuge den Befehl Add-in Manager aus.

  2. Drücken Sie die Schaltfläche Hinzufügen, und wählen Sie den Speicherort der Add-in-DLL aus.

  3. Das Hilfsprogramm RegAddIn.exe wird ausgeführt, das die nötigen Schritte durchführt, um das Add-in im System zu registrieren. Bitte beachten Sie, dass das Registrieren eines Add-ins Administratorrechte benötigt, deshalb wird höchstwahrscheinlich ein Bestätigungsdialog für die Benutzerkontensteuerung angezeigt, bevor das Hilfsprogramm ausgeführt werden kann (je nach Sicherheitseinstellungen Ihres Systems).

  4. Laden Sie das entsprechende Add-in, indem Sie das Kontrollkästchen neben dem Namen des Add-ins setzen.
    Ein Haken kennzeichnet, dass ein Add-in geladen ist. Dieser Haken weist PCAN-Explorer auch an, das Add-in beim nächsten Programmstart automatisch zu laden.

  5. Drücken Sie OK oder Übernehmen.

Siehe auch

Trennen von Add-ins von PCAN-Explorer

Wie sich Add-ins verbinden und trennen


Trennen von Add-ins von PCAN-Explorer

Leitseite (Add-ins) | Übersicht | Wie kann man ...? | Referenz

Wenn ein Add-in nicht länger benötigt wird, können Sie es von PCAN-Explorer trennen.

Um ein Add-in von PCAN-Explorer zu trennen:

  1. Wählen Sie im Menü Werkzeuge den Befehl Add-in Manager aus.

  2. Deaktivieren Sie die Kontrollkästchen neben den Add-ins, die getrennt werden sollen.

  3. Drücken Sie OK oder Übernehmen.

Die ausgewählten Add-ins sind ab sofort nicht mehr verfügbar und werden beim nächsten Start von PCAN-Explorer nicht mehr automatisch geladen.

Siehe auch

Verbinden von Add-ins mit PCAN-Explorer

Wie sich Add-ins Verbinden und Trennen


Ausführen von Add-in-Befehlen

Leitseite (Add-ins) | Übersicht | Wie kann man ...? | Referenz

Nachdem ein Add-in mit PCAN-Explorer verbunden worden ist, können die Befehle des Add-ins ausgeführt werden, indem die entsprechenden Symbolleistenschaltflächen oder Tastenkombinationen betätigt werden.

Außerdem können Befehle von der Kommandozeile ausgeführt werden.

Um einen Befehl von der Kommandozeile auszuführen:

  • Geben Sie ein: pcanexpl -ex Befehl

    wobei Befehl der Name des Add-in-Befehls ist. Diese Syntax startet PCAN-Explorer. Nachdem das PCAN-Explorer-Hauptfenster erschienen ist, wird mit der Ausführung des Befehls begonnen.

Nachdem der Befehl vollständig ausgeführt wurde, läuft PCAN-Explorer weiter. Wenn PCAN-Explorer nach der Ausführung des Befehls beendet werden soll, muss die Implementierung des Add-in-Befehls am Ende die Quit-Methode des Application-Objekts aufrufen.

Siehe auch

Wie Add-in-Befehle ausgeführt werden


Hinzufügen einer Benachrichtigung bei Änderung eines Signalwertes

Leitseite (Add-ins) | Übersicht | Wie kann man ...? | Referenz

Zum Hinzufügen einer Benachrichtigung bei Änderung eines Signalwertes muss das Add-in ein SignalCallback-Objekt beim Signal-Objekt registrieren. Das Add-in unternimmt die folgenden Schritte, um ein SignalCallback-Objekt zu registrieren:

  1. Speichern Sie in der Implementierung der OnConnection-Methode einen Application*-Zeiger für eine spätere Verwendung.

  2. Erzeugen Sie eine Ereignisbehandlung für das OnSymbolsActivate-Ereignis.

  3. Verwenden Sie in der Implementierung der OnSymbolsActivate-Ereignisbehandlung den Application*-Zeiger, um auf die Signals-Kollektion zuzugreifen, um das Signal-Objekt zu finden, für das Sie eine Callback-Behandlung registrieren möchten.

  4. Rufen Sie die RegisterCallback-Methode des Signal-Objekts auf, um ein SignalCallback-Objekt zu registrieren.

  5. Fügen Sie in der Implementierung der OnRemove-Methode des SignalCallback-Objekts einen Aufruf der UnregisterCallback-Methode hinzu, um Ihr Callback-Objekt zu entfernen. Alternativ können Sie auch eine Ereignisbehandlung für das OnSymbolsDeactivate-Ereignis erzeugen, in der Sie alle Ihre Callback-Objekte in einem Schritt entfernen können.

Achtung: Die Callback-Objekte müssen auch entfernt werden, wenn das Add-in von PCAN-Explorer getrennt wird. Siehe OnDisconnection-Methode.

Siehe auch

Entfernen einer Benachrichtigung bei Änderung eines Signalwertes


Entfernen einer Benachrichtigung bei Änderung eines Signalwertes

Leitseite (Add-ins) | Übersicht | Wie kann man ...? | Referenz

Wenn die Benachrichtigung nicht länger benötigt wird, oder wenn die aktiven Symbole deaktiviert werden und deshalb das verwendete Signal-Objekt nicht mehr gültig ist, muss das Add-in sein SignalCallback-Objekt vom entsprechenden Signal-Objekt entfernen.

Zum Entfernen der Benachrichtigung muss das Add-in die UnregisterCallback-Methode des Signal-Objekts aufrufen.

Siehe auch

Hinzufügen einer Benachrichtigung bei Änderung eines Signalwertes


Referenz: Add-ins für PCAN-Explorer

Leitseite (Add-ins) | Übersicht | Wie kann man ...?

Mit Add-ins kann man Aufgaben in PCAN-Explorer automatisieren oder Befehle hinzufügen, die diese Aufgaben erledigen.

Methoden

Nachfolgend sind alle Methoden aufgeführt, die PCAN-Explorer im Umgang mit Add-ins aufruft. Dazu muss das Add-in das entsprechende Interface implementieren, in dem die jeweilige Methode definiert ist.

Methode | Beschreibung
OnAfterTransmit | Wird aufgerufen, nachdem eine Botschaft gesendet wurde (CAN, CAN FD, J1939).
OnBeforeTransmit | Wird aufgerufen, bevor eine Botschaft gesendet wird (CAN, CAN FD, J1939)..
OnChange | Wird aufgerufen, wenn sich ein Eigenschaftswert eines Signals ändert.
OnChangeValue | Wird aufgerufen, wenn sich der Wert eines Signals ändert.
OnConnection | Wird aufgerufen, wenn ein Add-in verbunden wird.
OnDisconnection | Wird aufgerufen, wenn ein Add-in getrennt wird.
OnDocumentCreate | Wird aufgerufen, wenn ein Dokument, das von einem Add-in verwaltet wird, erzeugt wird.
OnDocumentDestroy | Wird aufgerufen, wenn ein Dokument, das von einem Add-in verwaltet wird, geschlossen wird.
OnLoad | Wird aufgerufen, wenn ein Dokument, das von einem Add-in verwaltet wird, aus einer Datei geladen wird.
OnPause | Wird aufgerufen, wenn das periodische Senden einer Botschaft angehalten wurde.
OnReceive | Wird aufgerufen, wenn eine Botschaft empfangen wird (CAN, CAN FD, J1939).
OnRemove | Wird aufgerufen, wenn ein Signal entfernt worden ist.
OnReset | Wird für Sendebotschaften aufgerufen, wenn der Zurücksetzen-Befehl für eine Verbindung ausgeführt wurde.
OnResume | Wird aufgerufen, wenn das periodische Senden einer Botschaft fortgesetzt wurde.
OnSave | Wird aufgerufen, wenn ein Dokument, das von einem Add-in verwaltet wird, gespeichert wird.
OnWindowCreate | Wird aufgerufen, wenn ein ActiveX-Steuerelement zur Visualisierung eines Add-in-Dokumenttyps erzeugt wird.
OnWindowDestroy | Wird aufgerufen, wenn ein ActiveX-Steuerelement geschlossen wird, das zur Visualisierung eines Add-in-Dokumenttyps gedient hat.
QueryCommandStatus | Wird aufgerufen, wenn PCAN-Explorer die Verfügbarkeit eines Add-in-Kommandos feststellen will.
QueryHelpContext | Wird aufgerufen, wenn PCAN-Explorer Information über die Online-Hilfe feststellen will, die für das Fenster angezeigt werden kann.
QueryHelpFile | Wird aufgerufen, wenn PCAN-Explorer Information über die Online-Hilfe feststellen will, die für das Fenster angezeigt werden kann.
Interfaces

Nachfolgend sind alle Interfaces aufgeführt, die von Add-ins implementiert werden können, um die gewünschte Funktionalität bereitzustellen.

Interface | Beschreibung
IPEExtensibility | Jedes PCAN-Explorer-Add-in muss dieses Interface implementieren.
IPEReceiveCallback | Muss implementiert werden, wenn ein Add-in beim Empfang einer CAN-Botschaft benachrichtigt werden soll.
IPESignalCallback | Muss implementiert werden, wenn ein Add-in bei Veränderung eines Signalwertes benachrichtigt werden soll.
IPEToolDocument | Muss implementiert werden, wenn ein Add-in Daten verwaltet, die in Dateien gespeichert werden.
IPEToolWindow | Muss implementiert werden, wenn ein Add-in ein ActiveX-Steuerelement zur Visualisierung eines eigenen Dokumenttyps bereitstellt.
IPETransmitCallback | Muss implementiert werden, wenn ein Add-in beim Senden von CAN-Botschaften benachrichtigt werden soll.

Siehe auch

Reference: PCAN-Explorer Objects (in Englisch)


IPEExtensibility-Interface

Leitseite (Add-ins) | Übersicht | Wie kann man ...? | Referenz

Dieses Interface muss implementiert werden, um ein Add-in zu erzeugen. Es stellt die nötigen Ereignisse bereit, die ein Programm zur Verfügung stellen muss, um ein Add-in zu sein.

Das IPEExtensibility-Interface definiert die folgenden Methoden:

Methode | Beschreibung
OnConnection | Wird aufgerufen, wenn ein Add-in verbunden wird.
OnDisconnection | Wird aufgerufen, wenn ein Add-in getrennt wird.
QueryCommandStatus | Wird aufgerufen, wenn PCAN-Explorer die Verfügbarkeit eines Add-in-Befehls feststellen will.
Hinweis

Das IPEExtensibility-Interface ist kein Dual Interface, da es nicht von IDispatch abgeleitet ist. Es ist von IUnknown abgeleitet.

Um ein Add-in zu laden, ruft PCAN-Explorer die OnConnection-Methode des Add-ins auf. Wenn PCAN-Explorer beendet wird, entlädt er jedes Add-in durch Aufruf der OnDisconnection-Methode. Wenn PCAN-Explorer feststellen will, ob ein vom Add-in hinzugefügtes Kommando für den Benutzer verfügbar sein soll, ruft er die Methode QueryCommandStatus auf.

Um das COM-Interface zu implementieren, muss ein Add-in die folgende vordefinierte Interface-ID (IID) verwenden: E6885F19-17F6-45D0-950B-16E75BEFEC2B.

Siehe auch

Wie sich Add-ins verbinden und trennen


IPEReceiveCallback-Interface

Leitseite (Add-ins) | Übersicht | Wie kann man ...? | Referenz

Dieses Interface muss von einem Objekt eines Add-ins implementiert werden, wenn das Add-in benachrichtigt werden möchte, wenn PCAN-Explorer eine CAN-Botschaft empfangen hat.

Das IPEReceiveCallback-Interface definiert die folgenden Methoden:

Methode | Beschreibung
OnReceive | Wird aufgerufen, wenn eine Botschaft empfangen wurde (CAN, CAN FD, J1939).
Hinweis

Das IPEReceiveCallback-Interface ist kein Dual Interface, da es nicht von IDispatch abgeleitet ist. Es ist von IUnknown abgeleitet.

Um das COM-Interface zu implementieren, muss ein Objekt die folgende vordefinierte Interface-ID (IID) verwenden: 9C3F48A5-E9BA-4898-91C2-941612E9F343.

Siehe auch

Wie Add-ins bei Empfang einer Botschaft benachrichtigt werden


IPESignalCallback-Interface

Leitseite (Add-ins) | Übersicht | Wie kann man ...? | Referenz

Dieses Interface muss von einem Objekt eines Add-ins implementiert werden, wenn das Add-in zur Benachrichtigung über einen geänderten Signalwert bei PCAN-Explorer registriert werden soll.

Das IPESignalCallback-Interface definiert die folgenden Methoden:

Methode | Beschreibung
OnChange | Wird aufgerufen, wenn sich die Signaldefinition geändert hat.
OnChangeValue | Wird aufgerufen, wenn sich der Signalwert geändert hat.
OnRemove | Wird aufgerufen, wenn das Signal entfernt wurde.
Hinweis

Das IPESignalCallback-Interface ist kein Dual Interface, da es nicht von IDispatch abgeleitet ist. Es ist von IUnknown abgeleitet.

Um das COM-Interface zu implementieren, muss ein Add-in die folgende vordefinierte Interface-ID (IID) verwenden: 3C14E50F-47CC-407A-89EE-9F93E01C50A5.

Siehe auch

Wie Add-ins bei Änderung eines Signalwertes benachrichtigt werden


IPEStream-Interface

Leitseite (Add-ins) | Übersicht | Wie kann man ...? | Referenz

Dieses Interface muss verwendet werden, um Daten aus einem Dokument zu lesen oder Daten in ein Dokument zu speichern. Ein Zeiger auf dieses Interface wird von PCAN-Explorer übergeben, wenn er die Methoden OnLoad oder OnSave beim Laden oder Speichern eines Dokuments aufruft.

Das IPEStream-Interface definiert einige Methoden und Eigenschaften, von denen nur die folgenden 2 Methoden verwendet werden dürfen:

Methode | Beschreibung
Read | Liest Daten aus dem Stream.
Write | Speichert Daten in den Stream.
Hinweis

Das IPEStream-Interface ist kein Dual Interface, da es nicht von IDispatch abgeleitet ist. Es ist von IUnknown abgeleitet.

Das IPEStream-Interface hat die folgende vordefinierte Interface-ID (IID): 7038EC3B-848A-4882-A5D2-A371CEEB3FBE.

Siehe auch

Wie Add-in-Dokumentdaten geladen und gespeichert werden


IPEToolDocument-Interface

Leitseite (Add-ins) | Übersicht | Wie kann man ...? | Referenz

Dieses Interface muss von einem ActiveX-Steuerelement implementiert werden, wenn das ActiveX-Steuerelement Daten verwaltet, die über die PCAN-Explorer-Dateibefehle geladen und gespeichert werden sollen.

Das IPEToolDocument-Interface definiert die folgenden Methoden:

Methode | Beschreibung
OnDocumentCreate | Wird aufgerufen, wenn ein Dokument, das von einem Active-X-Steuerelement verwaltet wird, erzeugt wird.
OnDocumentDestroy | Wird aufgerufen, wenn ein Dokument, das von einem Active-X-Steuerelement verwaltet wird, geschlossen wird.
OnLoad | Wird aufgerufen, wenn ein Dokument, das von einem ActiveX-Steuerelement verwaltet wird, aus einer Datei geladen wird.
OnSave | Wird aufgerufen, wenn ein Dokument, das von einem ActiveX-Steuerelement verwaltet wird, gespeichert wird.
Hinweis

Das IPEToolDocument-Interface ist kein Dual Interface, da es nicht von IDispatch abgeleitet ist. Es ist von IUnknown abgeleitet.

Um das COM-Interface zu implementieren, muss ein Add-in die folgende vordefinierte Interface-ID (IID) verwenden: CB1C0AF0-8877-4CC1-AAD3-D912CC869A8A.

Siehe auch

Wie Add-in-Dokumentdaten geladen und gespeichert werden


IPEToolWindow-Interface

Leitseite (Add-ins) | Übersicht | Wie kann man ...? | Referenz

Dieses Interface muss von einem ActiveX-Steuerelement implementiert werden, das zur visuellen Darstellung eines von einem Add-in definierten Dokument verwendet werden soll.

Das IPEToolWindow-Interface definiert die folgenden Methoden:

Methode | Beschreibung
OnWindowCreate | Wird aufgerufen, wenn ein ActiveX-Steuerelement zur Visualisierung eines Add-in-Dokumenttyps erzeugt wird.
OnWindowDestroy | Wird aufgerufen, wenn ein ActiveX-Steuerelement geschlossen wird, das zur Visualisierung eines Add-in-Dokumenttyps gedient hat.
QueryHelpFile | Wird aufgerufen, wenn PCAN-Explorer den Dateinamen der Online-Hilfe feststellen will, die für das Fenster angezeigt werden kann.
QueryHelpContext | Wird aufgerufen, wenn PCAN-Explorer die Kontext-Nummer des Hilfethemas feststellen will, das für das Fenster angezeigt werden kann.
Hinweis

Dieses IPEToolWindow-Interface ist kein Dual Interface, da es nicht von IDispatch abgeleitet ist. Es ist von IUnknown abgeleitet.

Um das COM-Interface zu implementieren, muss ein ActiveX-Steuerelement die folgende vordefinierte Interface-ID (IID) verwenden: 37D11F8F-1798-4BA5-8228-CFA2092E844D.

Siehe auch

Wie ActiveX-Steuerelemente verbunden und getrennt werden


IPETransmitCallback-Interface

Leitseite (Add-ins) | Übersicht | Wie kann man ...? | Referenz

Dieses Interface muss von einem Objekt eines Add-ins implementiert werden, wenn das Add-in benachrichtigt werden möchte, wenn PCAN-Explorer Botschaften sendet.

Das IPETransmitCallback-Interface definiert die folgenden Methoden:

Methode | Beschreibung
OnBeforeTransmit | Wird aufgerufen, bevor eine Botschaft gesendet wird (CAN, CAN FD, J1939).
OnAfterTransmit | Wird aufgerufen, nachdem eine Botschaft gesendet wurde (CAN, CAN FD, J1939).
OnResume | Wird aufgerufen, wenn das periodische Senden einer Botschaft fortgesetzt wurde.
OnPause | Wird aufgerufen, wenn das periodische Senden einer Botschaft angehalten wurde.
OnReset | Wird aufgerufen, wenn der Zurücksetzen-Befehl für eine Verbindung ausgeführt wurde. Die OnReset-Methode wird dann für alle Sendebotschaften aufgerufen, die zu der Verbindung gehören, für die der Zurücksetzen-Befehl ausgeführt wurde.
Hinweis

Das IPETransmitCallback-Interface ist kein Dual Interface, da es nicht von IDispatch abgeleitet ist. Es ist von IUnknown abgeleitet.

Um das COM-Interface zu implementieren, muss ein Objekt die folgende vordefinierte Interface-ID (IID) verwenden: CAFCC024-B365-4083-BE61-D95597FFF33F.

Siehe auch

Wie Add-ins beim Senden von Botschaften benachrichtigt werden


OnAfterTransmit-Methode

Leitseite (Add-ins) | Übersicht | Wie kann man ...? | Referenz

Nachdem PCAN-Explorer eine Botschaft gesendet hat, ruft er die OnAfterTransmit-Methoden aller bei der TransmitMessages-Kollektion registrierten TransmitCallback-Objekte auf.

Die OnAfterTransmit-Methode ist im COM-Interface IPETransmitCallback definiert.

Syntax
C++

HRESULT _stdcall OnAfterTransmit(

IPETransmitEvent *pEvent

);
C#

void OnAfterTransmit(

IPETransmitEvent pEvent

);
Delphi

function OnAfterTransmit(

const pEvent: IPETransmitEvent

): HResult; stdcall;
Parameter

pEvent

Ein Zeiger (IPETransmitEvent*) auf das COM-Interface des TransmitEvent-Objekts, das die gesendete Botschaft repräsentiert.

Siehe auch

OnBeforeTransmit-Methode


OnBeforeTransmit-Methode

Leitseite (Add-ins) | Übersicht | Wie kann man ...? | Referenz

Bevor PCAN-Explorer eine Botschaft sendet, ruft er die OnBeforeTransmit-Methoden aller bei der TransmitMessages-Kollektion registrierten TransmitCallback-Objekte auf.

Die OnBeforeTransmit-Methode ist im COM-Interface IPETransmitCallback definiert.

Syntax
C++

HRESULT _stdcall OnBeforeTransmit(

IPETransmitEvent *pEvent

);
C#

void OnBeforeTransmit(

IPETransmitEvent pEvent

);
Delphi

function OnBeforeTransmit(

const pEvent: IPETransmitEvent

): HResult; stdcall;
Parameter

pEvent

Ein Zeiger (IPETransmitEvent*) auf das COM-Interface des TransmitEvent-Objekts, das die zu sendende Botschaft repräsentiert.

Beispiel

Das folgende Beispiel erzeugt einen rollenden Zähler in Datenbyte 0 einer CAN-Botschaft mit ID 100h und Datenlänge 8, der vor jedem Senden der Botschaft um eins erhöht wird:

C#

private byte counter = 0;

public void OnBeoreTransmit(IPETransmitEvent event)

{

if (event.ID == 0x100 && event.DataLength == 8)

{

event.Data[0] = counter++;

}

}

Siehe auch

OnAfterTransmit-Methode


OnChange-Methode

Leitseite (Add-ins) | Übersicht | Wie kann man ...? | Referenz

Wenn sich der Wert einer Eigenschaft eines Signals ändert, beispielsweise der Name oder der Datentyp, ruft PCAN-Explorer die OnChange Methoden aller beim Signal registrierten SignalCallback-Objekte auf.

Die OnChange-Methode ist im COM-Interface IPESignalCallback definiert.

Syntax
C++

HRESULT _stdcall OnChange(

IPESignal * pSignal

);
C#

void OnChange(

IPESignal pSignal

);
Delphi

function OnChange(

const pSignal: IPESignal

): HResult; stdcall;
Parameter

pSignal

Ein Zeiger (IPESignal*) auf das Dual Interface des Signal-Objekts, dessen Definition verändert wurde.


OnChangeValue-Methode

Leitseite (Add-ins) | Übersicht | Wie kann man ...? | Referenz

Wenn sich der Wert eines Signals ändert, weil z.B. eine CAN-Botschaft mit neuen Daten empfangen worden ist, ruft PCAN-Explorer die OnChangeValue-Methoden aller beim Signal registrierten SignalCallback-Objekte auf.

Die OnChangeValue-Methode ist im COM-Interface IPESignalCallback definiert.

Syntax
C++

HRESULT _stdcall OnChangeValue(

IPESignal *pSignal

);
C#

void OnChangeValue(

IPESignal pSignal

);
Delphi

function OnChangeValue(

const pSignal: IPESignal

): HResult; stdcall;
Parameter

pSignal

Ein Zeiger (IPESignal*) auf das Dual Interface des Signal-Objekts, dessen Wert sich geändert hat.

Siehe auch

Hinzufügen einer Benachrichtigung bei Änderung eines Signalwertes


OnConnection Method

Home Page (Add-ins) | Overview | How do I ...? | Reference

To load an Add-in, PCAN-Explorer calles the OnConnection method of the Add-in.

The OnConnection method is defined in the COM interface IPEExtensibility.

Syntax
C++

HRESULT _stdcall OnConnection(

IDispatch *pApp,

VARIANT_BOOL bFirstTime,

long dwCookie,

/* [out, retval] */ VARIANT_BOOL * res

);
C#

bool OnConnection(

object pApp,

bool bFirstTime,

int dwCookie

);
Delphi

function OnConnection(

const pApp: IDispatch;

bFirstTime: WordBool;

dwCookie: Integer;

out res: WordBool

): HResult; stdcall;
Parameters

pApp

A pointer (IDispatch*) to the Dual Interface of the PCAN-Explorer Application object. This pointer to can be transformed into an IPEApplication interface pointer with a QueryInterface call.

bFirstTime

Indicates, if this is the first time that the Add-in has been loaded into the environment. Possible values are:

  • VARIANT_TRUE (C++), true (C#, Delphi),
    It is the first time, that the Add-in has been loaded, or the Add-in has been disconnected and reloaded again by the user.

  • VARIANT_FALSE (C++), false (C#, Delphi),
    The Add-in has been loaded in another session before.

dwCookie

The Add-in must use this value to identify itself in subsequent calls to PCAN-Explorer. For example, the Add-in uses this cookie to call the AddCommand method.

res

Returns the result.

Possible values are:

  • VARIANT_FALSE / false: The Add-in is not loaded.

  • VARIANT_TRUE / true: The Add-in is loaded successfully.

Return values

(C#)

  • false: The Add-in is not loaded.

  • true: The Add-in is loaded successfully.

Usage

To connect, the Add-in takes the following steps:

  1. Uses the pApp parameter to ensure that required objects in the PCAN-Explorer object model are installed. If required objects are not available, the Add-in returns VARIANT_FALSE (C++) or false (C#, Delphi) or indicating that it should not be loaded.

  2. Uses the bFirstTime parameter to determine if this is the first time the Add-in has been loaded into the environment. If it is the first time, bFirstTime is VARIANT_TRUE (C++) or true (C#, Delphi) or and the Add-in can carry out initializations that are necessary only the first time.

Tip: You only need to add key bindings the first time an Add-in is loaded because the environment keeps track of them in subsequent loads.

  3. Provides information about itself by calling the SetAddInInfo method. If the Add-in fails to provide the required information, the environment unloads the Add-in by calling the Add-in's OnDisconnection method. Then, the environment displays a message box describing what the Add-in failed to do.

  4. Connects to events. The Add-in locates the appropriate PCAN-Explorer objects and then connects to their events.

  5. Adds commands by calling the AddCommand method.

  6. Stores the cookie and the pointer (Application*) to the Application object for future use. If the used compiler does not support automatic referencing for interface pointers, the Add-in must explicitly call the interface's AddRef function. Storing the pointer is recommended because PCAN-Explorer will not pass the pointer to the Add-in again.

  7. Returns VARIANT_TRUE (C++) or true (C#, Delphi) indicating that the Add-in loaded successfully.

See also

OnDisconnection Method


OnDisconnection Method

Home Page (Add-ins) | Overview | How do I ...? | Reference

When PCAN-Explorer shuts down, the environment unloads each Add-in by calling the OnDisconnection method.

The OnDisconnection method is defined in the COM interface IPEExtensibility.

Syntax
C++

HRESULT _stdcall OnDisconnection(

VARIANT_BOOL bLastTime

);
C#

void OnDisconnection(

bool bLastTime

);
Delphi

function OnDisconnection(

bLastTime: WordBool

): HResult; stdcall;
Parameters

bLastTime

Indicates, why the Add-in is unloaded. Possible values are:

  • VARIANT_TRUE (C++), true (C#, Delphi)
    The user removes (uninstalls) the Add-in.

  • VARIANT_FALSE (C++), false (C#, Delphi)
    PCAN-Explorer is exiting.

Usage

To disconnect, the Add-in takes the following steps:

  1. Examines the bLastTime parameter to determine why it is unloading.

  2. Disconnects from events.

  3. Releases the pointer to the Dual Interface on the PCAN-Explorer Application object - if it stored the pointer while connecting to the environment.

  4. Performs cleanup tasks such as deallocating memory, freeing resources, and so on.

See also

OnConnection Method


OnDocumentCreate-Methode

Leitseite (Add-ins) | Übersicht | Wie kann man ...? | Referenz

Wenn ein Dokument erzeugt wird, dessen Typ von einem Add-in definiert wird, ruft PCAN-Explorer die OnDocumentCreate-Methode des ActiveX-Steuerelements auf.

Die OnDocumentCreate-Methode ist im COM-Interface IPEToolDocument definiert.

Syntax
C++

HRESULT _stdcall OnDocumentCreate(

IPEDocument *pDoc

);
C#

void OnDocumentCreate(

IPEDocument pDoc

);
Delphi

function OnDocumentCreate(

const pDoc: IPEDocument

): HResult; stdcall;
Parameter

pDoc

Ein Zeiger (IPEDocument*) auf das Dual Interface des neu erzeugten Document-Objekts.

Siehe auch

OnDocumentDestroy-Methode


OnDocumentDestroy-Methode

Leitseite (Add-ins) | Übersicht | Wie kann man ...? | Referenz

Wenn ein Dokument geschlossen wird, dessen Typ von einem Add-in definiert wird, ruft PCAN-Explorer die OnDocumentDestroy-Methode des ActiveX-Steuerelements auf.

Die OnDocumentDestroy-Methode ist im COM-Interface IPEToolDocument definiert.

Syntax
C++

HRESULT _stdcall OnDocumentDestroy( void );
C#

void OnDocumentDestroy( void );
Delphi

function OnDocumentDestroy: HResult; stdcall;

Siehe auch

OnDocumentCreate-Methode


OnLoad-Methode

Leitseite (Add-ins) | Übersicht | Wie kann man ...? | Referenz

Wenn ein Dokument aus einer Datei geladen wird, dessen Typ von einem Add-in definiert wird, ruft PCAN-Explorer die OnLoad-Methode des ActiveX-Steuerelements auf, um diesem die Möglichkeit zu bieten, seine Daten aus der Datei zu lesen.

Die OnLoad-Methode ist im COM-Interface IPEToolDocument definiert.

Syntax
C++

HRESULT _stdcall OnLoad(

IPEStream *pStream,

/* [out, retval] */ VARIANT_BOOL * res

);
C#

bool OnLoad(

IPEStream pStream

);
Delphi

function OnLoad(

const pStream: IPEStream;

out res: WordBool

): HResult; stdcall;
Parameter

pStream

Ein Zeiger (IPEStream*) auf das Stream-Objekt, über das die Daten eingelesen werden können.

res

Gibt das Ergebnis zurück.

Mögliche Werte sind:

  • VARIANT_FALSE (C++), False (Delphi): Beim Lesen der Daten trat ein Fehler auf.

  • VARIANT_TRUE: (C++), True (Delphi): Die Daten konnten ohne Fehler gelesen werden.

Rückgabewerte

(C#)

  • false: Beim Lesen der Daten trat ein Fehler auf.

  • true: Die Daten konnten ohne Fehler gelesen werden.

Siehe auch

OnSave-Methode


OnPause-Methode

Leitseite (Add-ins) | Übersicht | Wie kann man ...? | Referenz

Wenn das periodische Senden einer CAN-Botschaft angehalten wurde, ruft PCAN-Explorer die OnPause-Methoden aller bei der TransmitMessages-Kollektion registrierten TransmitCallback-Objekte auf.

Die OnPause-Methode ist im COM-Interface IPETransmitCallback definiert.

Syntax
C++

HRESULT _stdcall OnPause(

IPETransmitEvent *pEvent

);
C#

void OnPause(

IPETransmitEvent pEvent

);
Delphi

function OnPause(

const pEvent: IPETransmitEvent

): HResult; stdcall;
Parameter

pEvent

Ein Zeiger (IPETransmitEvent*) auf das COM-Interface des TransmitEvent-Objekts, das die Sendebotschaft repräsentiert, für die das periodische Senden angehalten wurde.

Siehe auch

OnResume-Methode


OnReceive-Methode

Leitseite (Add-ins) | Übersicht | Wie kann man ...? | Referenz

Wenn eine CAN-Botschaft empfangen worden ist, ruft PCAN-Explorer die OnReceive-Methoden aller bei der ReceiveMessages-Kollektion registrierten ReceiveCallback-Objekte auf.

Die OnReceive-Methode ist im COM-Interface IPEReceiveCallback definiert.

Syntax
C++

HRESULT _stdcall OnReceive(

IPEReceiveMessage *pMessage

);
C#

void OnReceive(

IPEReceiveMessage pMessage

);
Delphi

function OnReceive(

const pMessage: IPEReceiveMessage

): HResult; stdcall;
Parameter

pMessage

Ein Zeiger (IPEReceiveMessage*) auf das Dual Interface des ReceiveMessage-Objekts, das die empfangene Botschaft repräsentiert.


OnRemove-Methode

Leitseite (Add-ins) | Übersicht | Wie kann man ...? | Referenz

Wenn ein Signal aus der Signals-Kollektion des Application-Objekts entfernt worden ist, weil z.B. die Symboldatei, die das Signal in die Signals-Kollektion eingeblendet hatte, vom Benutzer aus dem Projekt entfernt wurde, ruft PCAN-Explorer die OnRemove-Methoden aller beim Signal registrierten SignalCallback-Objekte auf.

Die OnRemove-Methode ist im COM-Interface IPESignalCallback definiert.

Syntax
C++

HRESULT _stdcall OnRemove(

IPESignal *pSignal

);
C#

void OnRemove(

IPESignal pSignal

);
Delphi

function OnRemove(

const pSignal: IPESignal

): HResult; stdcall;
Parameter

pSignal

Ein Zeiger (IPESignal*) auf das Dual Interface des Signal-Objekts, das entfernt worden ist.

Bemerkungen

Ein Signal wird deaktiviert, wenn entweder die Symboldatei, die das Signal in die Signals-Kollektion eingefügt hatte, aus dem Projekt entfernt wurde, oder wenn ein VBScript-Makro oder ein Add-in das Signal manuell aus der Signals-Kollektion durch Aufrufen dessen Remove-Methode entfernt.

PCAN-Explorer übergibt einen Zeiger (IPESignal*) auf das Dual Interface des Signal-Objekts, das entfernt worden ist.


OnReset-Methode

Leitseite (Add-ins) | Übersicht | Wie kann man ...? | Referenz

Wenn der Zurücksetzen-Befehl für eine Verbindung ausgeführt wurde, ruft PCAN-Explorer die OnReset-Methoden aller bei der TransmitMessages-Kollektion registrierten TransmitCallback-Objekte auf. Der Aufruf erfolgt nacheinander für alle Sendebotschaften in der Kollektion, die zu der Verbindung gehören, für die der Zurücksetzen-Befehl ausgeführt wurde.

Die OnReset-Methode ist im COM-Interface IPETransmitCallback definiert.

Syntax
C++

HRESULT _stdcall OnReset(

IPETransmitEvent *pEvent

);
C#

void OnReset(

IPETransmitEvent pEvent

);
Delphi

function OnReset(

const pEvent: IPETransmitEvent

): HResult; stdcall;
Parameter

pEvent

Ein Zeiger (IPETransmitEvent*) auf das COM-Interface des TransmitEvent-Objekts, das die Sendebotschaft repräsentiert, die von dem Zurücksetzen-Befehl betroffen ist.


OnResume-Methode

Leitseite (Add-ins) | Übersicht | Wie kann man ...? | Referenz

Wenn das periodische Senden einer CAN-Botschaft fortgesetzt wurde, ruft PCAN-Explorer die OnResume-Methoden aller bei der TransmitMessages-Kollektion registrierten TransmitCallback-Objekte auf.

Die OnResume-Methode ist im COM-Interface IPETransmitCallback definiert.

Syntax
C++

HRESULT _stdcall OnResume(

IPETransmitEvent *pEvent

);
C#

void OnResume(

IPETransmitEvent pEvent

);
Delphi

function OnResume(

const pEvent: IPETransmitEvent

): HResult; stdcall;
Parameter

pEvent

Ein Zeiger (IPETransmitEvent*) auf das COM-Interface des TransmitEvent-Objekts, das die Sendebotschaft repräsentiert, für die das periodische Senden fortgesetzt wurde.

Siehe auch

OnPause-Methode


OnSave-Methode

Leitseite (Add-ins) | Übersicht | Wie kann man ...? | Referenz

Wenn ein Dokument in eine Datei gespeichert wird, dessen Typ von einem Add-in definiert wird, ruft PCAN-Explorer die OnSave-Methode des ActiveX-Steuerelements auf, um diesem die Möglichkeit zu bieten, seine Daten in die Datei zu speichern.

Die OnSave-Methode ist im COM-Interface IPEToolDocument definiert.

Syntax
C++

HRESULT _stdcall OnSave(

IPEStream *pStream

);
C#

bool OnSave(

IPEStream pStream

);
Delphi

function OnSave(

const pStream: IPEStream

): HResult; stdcall;
Parameter

pStream

Ein Zeiger (IPEStream*) auf das Stream-Objekt, das zum Speichern der Daten verwendet werden kann.

Siehe auch

OnLoad-Methode


OnWindowCreate-Methode

Leitseite (Add-ins) | Übersicht | Wie kann man ...? | Referenz

Wenn ein Dokument erzeugt wird, dessen Typ von einem Add-in definiert wird, wird ebenfalls ein neues Fenster erzeugt, das ein ActiveX-Steuerelement zur Darstellung des Dokuments enthält. PCAN-Explorer ruft die OnWindowCreate-Methode des ActiveX-Steuerelements auf, um dieses von der Erzeugung des Fensters zu benachrichtigen.

Die OnWindowCreate-Methode ist im COM-Interface IPEToolWindow definiert.

Syntax
C++

HRESULT _stdcall OnWindowCreate(

IPEWindow *pWnd,

/* [out, retval] */ VARIANT_BOOL *res

);
C#

bool OnWindowCreate(

IPEWindow pWnd

);
Delphi

function OnWindowCreate(

const pWnd: IPEWindow;

out res: WordBool

): HResult; stdcall;
Parameter

pWnd

Ein Zeiger (IPEWindow*) auf das Dual Interface des Window-Objekts, in dem das ActiveX-Steuerelement enthalten ist.

res

Gibt das Ergebnis zurück.

Mögliche Werte sind:

  • VARIANT_FALSE (C++), False (Delphi): Das Fenster, welches das ActiveX-Steuerelement enthält, wird nicht angezeigt.

  • VARIANT_TRUE (C++), True (Delphi): Das Fenster, welches das ActiveX-Steuerelement enthält, wird angezeigt.

Return values

(C#)

  • false: Das Fenster, welches das ActiveX-Steuerelement enthält, wird nicht angezeigt.

  • true: Das Fenster, welches das ActiveX-Steuerelement enthält, wird angezeigt.

Verwendung

PCAN-Explorer übergibt einen Zeiger (IPEWindow*) auf das Dual Interface des PCAN-Explorer-Objekts Window.

Das ActiveX-Steuerelement unternimmt die folgenden Schritte, um sich zu verbinden:

  1. Verwendet die Application-Eigenschaft des pWnd-Zeigers, um einen Zeiger auf das Application-Objekt von PCAN-Explorer zu erhalten.

  2. Verwendet das Application-Objekt um sicherzustellen, dass benötigte Objekte im PCAN-Explorer-Objektmodell installiert sind. Wenn benötigte Objekte nicht verfügbar sind, gibt das ActiveX-Steuerelement VARIANT_FALSE (C++), False (Delphi), false (C#) zurück, wodurch das Fenster nicht angezeigt wird.

  3. Verbindet sich mit Ereignissen. Das ActiveX-Steuerelement lokalisiert die benötigten Objekte im PCAN-Explorer-Objektmodell und verbindet sich dann mit deren Ereignissen.

  4. Speichert den Zeiger (IPEWindow*) auf das Window-Objekt für zukünftige Verwendung. Wenn der verwendete Compiler nicht das automatische Referenzieren von Interface-Zeigern unterstützt, muss das Add-in explizit die AddRef-Funktion des Interfaces aufrufen. Das Speichern des Zeigers ist empfohlen, da PCAN-Explorer den Zeiger nicht erneut an das ActiveX-Steuerelement übergibt.

Siehe auch

OnWindowDestroy-Methode


OnWindowDestroy-Methode

Leitseite (Add-ins) | Übersicht | Wie kann man ...? | Referenz

Wenn ein Dokument geschlossen wird, dessen Typ von einem Add-in definiert wird, wird ebenfalls das Fenster geschlossen, welches das ActiveX-Steuerelement zur Darstellung des Dokuments enthält. PCAN-Explorer ruft dann die OnWindowDestroy-Methode des ActiveX-Steuerelements auf.

Die OnWindowDestroy-Methode ist im COM-Interface IPEToolWindow definiert.

Syntax
C++

HRESULT _stdcall OnWindowDestroy( void );
C#

void OnWindowDestroy( void );
Delphi

function OnWindowDestroy: HResult; stdcall;
Verwendung

Das ActiveX-Steuerelement unternimmt die folgenden Schritte, um sich zu trennen:

  1. Trennt sich von Ereignissen.

  2. Gibt den Zeiger (IPEWindow*) auf das Dual Interface des Window-Objekts frei, wenn es den Zeiger während des Verbindens gespeichert hatte.

  3. Führt Aufräumungsarbeiten durch, wie z.B. zugewiesenen Speicher freigeben, Ressourcen freigeben etc.

Siehe auch

OnWindowCreate-Methode


QueryCommandStatus-Methode

Leitseite (Add-ins) | Übersicht | Wie kann man ...? | Referenz

PCAN-Explorer muss regelmäßig feststellen, in welchem Zustand sich die Kommandos eines Add-ins befinden. Ein Add-in kann dies kontrollieren, indem es beim Aufruf der Methode QueryCommandStatus einen entsprechenden Wert zurückgibt.

Die QueryCommandStatus-Methode ist im COM-Interface IPEExtensibility definiert.

Syntax
C++

HRESULT __stdcall QueryCommandStatus(

int nBitmapOffset,

PeCommandStatus *Status

);
C#

void QueryCommandStatus(

int nBitmapOffset,

ref PeCommandStatus Status

);
Delphi

function QueryCommandStatus(

nBitmapOffset: Integer;

var Status: PeCommandStatus

): HResult; stdcall;
Parameter

nBitmapOffset

Gibt den Befehl an, für das der Status abgefragt wird. Der Parameter entspricht dem gleichen Wert nBitmapOffset, der PCAN-Explorer während des Aufrufs der Methode AddCommand übergeben wurde, um den Befehl hinzuzufügen.

Status

Ein Wert des Typs PeCommandStatus, der den gewünschten Status des Befehls festlegt.

  • peCommandStatusDisabled: Der Befehl ist für den Benutzer nicht verfügbar.

  • peCommandStatusEnabled: Der Befehl ist für den Benutzer verfügbar.

  • peCommandStatusLatched: Die Schaltfläche des Befehls wird im eingerasteten Zustand gezeigt. Der Menüeintrag des Befehls im Menü Werkzeuge wird mit einem Haken versehen. Dieser Wert kann mit dem Wert peCommandStatusEnabled kombiniert werden.

Verwendung

Das Add-in unternimmt die folgenden Schritte, um den Status eines Befehls festzulegen:

  1. Anhand des Parameters nBitmapOffset prüft es, für welchen Befehl der Status abgefragt wird.

  2. Gibt den gewünschten Status im Parameter Status zurück.


QueryHelpContext-Methode

Leitseite (Add-ins) | Übersicht | Wie kann man ...? | Referenz

Wenn ein Fenster geöffnet wird, das ein ActiveX-Steuerelement zur Visualisierung enthält, fragt PCAN-Explorer Information über dessen Online-Hilfe ab. Falls das ActiveX-Steuerelement das IPEToolWindow-Interface implementiert, ruft PCAN-Explorer die QueryHelpContext-Methode und die QueryHelpFile-Methode auf. Das ActiveX-Steuerelement kann PCAN-Explorer damit über den Hilfekontext und die Hilfedatei informieren. Wenn der Benutzer die Taste [F1] drückt, während das ActiveX-Steuerelement den Eingabefokus hat, zeigt PCAN-Explorer dann diesen Hilfekontext aus der Hilfedatei an.

Die QueryHelpContext-Methode ist im COM-Interface IPEToolWindow definiert.

Syntax
C++

HRESULT _stdcall QueryHelpContext(

/* [out, retval] */ int *nContext

);
C#

int QueryHelpContext( void );
Delphi

function QueryHelpContext(

out nContext: Integer

): HResult; stdcall;
Parameter

nContext

(out) Hier muss die Nummer des Hilfekontexts zurückgegeben werden, der angezeigt werden soll. Falls der Wert 0 zurückgegeben wird, zeigt PCAN-Explorer keine Hilfe für dieses Fenster an.

Rückgabewert

(C#) Die Nummer des Hilfekontexts, der angezeigt werden soll. Falls der Wert 0 zurückgegeben wird, zeigt PCAN-Explorer keine Hilfe für dieses Fenster an.

Bemerkungen

Die QueryHelpContext-Methode wird einmalig beim Erzeugen des ActiveX-Steuerelements aufgerufen, und zwar direkt nachdem zuvor die Methoden OnWindowCreate und QueryHelpFile aufgerufen wurden.

Siehe auch

QueryHelpFile-Methode

Wie ActiveX-Steuerelemente verbunden und getrennt werden


QueryHelpFile-Methode

Leitseite (Add-ins) | Übersicht | Wie kann man ...? | Referenz

Wenn ein Fenster geöffnet wird, das ein ActiveX-Steuerelement zur Visualisierung enthält, fragt PCAN-Explorer Information über dessen Online-Hilfe ab. Falls das ActiveX-Steuerelement das IPEToolWindow-Interface implementiert, ruft PCAN-Explorer die QueryHelpFile-Methode und die QueryHelpContext-Methode auf. Das ActiveX-Steuerelement kann PCAN-Explorer damit über den Hilfekontext und die Hilfedatei informieren. Wenn der Benutzer die Taste [F1] drückt, während das ActiveX-Steuerelement den Eingabefokus hat, zeigt PCAN-Explorer dann diesen Hilfekontext aus der Hilfedatei an.

Die QueryHelpFile-Methode ist im COM-Interface IPEToolWindow definiert.

Syntax
C++

HRESULT _stdcall QueryHelpFile(

/* [out, retval] */ BSTR *szHelpFile

);
C#

string QueryHelpFile( void );
Delphi

function QueryHelpFile(

out szHelpFile: WideString

): HResult; stdcall;
Parameter

szHelpFile

(out) Hier muss der Name Hilfedatei zurückgegeben werden, die angezeigt werden soll. Wird ein leerer String zurückgegeben, zeigt PCAN-Explorer keine Hilfe für dieses Fenster an.

Rückgabewert

(C#) Der Name der Hilfedatei, die angezeigt werden soll. Wird ein leerer String zurückgegeben, zeigt PCAN-Explorer keine Hilfe für dieses Fenster an.

Bemerkungen

Die QueryHelpFile-Methode wird einmalig beim Erzeugen des ActiveX-Steuerelements aufgerufen, und zwar direkt nach dem Aufruf der OnWindowCreate-Methode.

Siehe auch

QueryHelpContext-Methode

Wie ActiveX-Steuerelemente verbunden und getrennt werden


Read-Methode

Leitseite (Add-ins) | Übersicht | Wie kann man ...? | Referenz

Diese Methode kann von einem ActiveX-Steuerelement aufgerufen werden, um Daten aus einem Dokument zu lesen, wenn PCAN-Explorer das Dokument öffnet.

Die Read-Methode ist im COM-Interface IPEStream definiert.

Syntax
C++

HRESULT _stdcall Read(

unsigned char *pByte,

int cb,

/* [out, retval] */ int *pcbRead

);
C#

int Read(

ref byte pByte,

int cb

);
Delphi

function Read(

var pByte: Byte;

cb: Integer;

out pcbRead: Integer

): HResult; stdcall;
Parameter

pByte

Ein Zeiger auf den Puffer, in den die gelesenen Stream-Daten gespeichert werden.

cb

Die Anzahl der Bytes, die aus dem Stream gelesen werden sollen.

pcbRead

Ein Zeiger auf eine Long-Variable, welche die Anzahl der tatsächlich aus dem Stream gelesenen Bytes aufnimmt.

Rückgabewert

(C++, Delphi) Ist die Methode erfolgreich, wird S_OK zurückgegeben.

(C#) Die Anzahl der tatsächlich aus dem Stream gelesenen Bytes.

Siehe auch

Write-Methode


Write-Methode

Leitseite (Add-ins) | Übersicht | Wie kann man ...? | Referenz

Diese Methode kann von einem ActiveX-Steuerelement aufgerufen werden, um Daten in ein Dokument zu schreiben, wenn PCAN-Explorer das Dokument speichert.

Die Write-Methode ist im COM-Interface IPEStream definiert.

Syntax
C++

HRESULT _stdcall Write(

unsigned char *pByte,

int cb,

/* [out, retval] */ int *pcbWritten

);
C#

int Write(

ref byte pByte,

int cb

);
Delphi

function Write(

var pByte: Byte;

cb: Integer;

out pcbWritten: Integer

): HResult; stdcall;
Parameter

pByte

Ein Zeiger auf den Puffer, der die zu schreibenden Daten enthält.

cb

Die Anzahl der Bytes, die in den Stream geschrieben werden sollen.

pcbWritten

Ein Zeiger auf eine Long-Variable, welche die Anzahl der tatsächlich in den Stream geschriebenen Bytes aufnimmt.

Return value

(C++, Delphi) Ist die Methode erfolgreich, wird S_OK zurückgegeben.

(C#) Die Anzahl der tatsächlich in den Stream geschriebenen Bytes.

Siehe auch

Read-Methode


Leitseite: Callback-Bibliotheken

Callback-Bibliotheken sind Dynamic Link Libraries (DLLs), die Sie beispielsweise mit Microsoft Visual C++ schreiben, und in ein PCAN-Explorer-Projekt aufnehmen. Mit Callback-Bibliotheken können Sie folgendes tun:

  • Daten von CAN-Botschaften auswerten, verarbeiten oder modifizieren, bevor oder nachdem sie gesendet wurden

  • Daten von empfangenen CAN-Botschaften auswerten, verarbeiten oder modifizieren, bevor sie von PCAN-Explorer verarbeitet wurden

  • Ausführen anderer Botschafts-bezogener Aufgaben beim Senden und Empfangen.

In diesem Abschnitt

Übersicht

Information zur Funktionsweise von Callback-Bibliotheken und zur Kommunikation von PCAN-Explorer mit Callback-Bibliotheken.

Referenz

Enthält die Referenz zu allen Objekten, Methoden und Interfaces, die beim Erstellen und der Verwendung von Callback-Bibliotheken benötigt werden.

Weitere Abschnitte

Add-ins

Enthält Themen über die Erstellung, Installation und Verwendung von Add-ins.

VBScript-Makros

Dokumentation über VBScript-Makros sowie deren Erstellung und Verwendung.

PCAN-Explorer-Objekte

Dokumentation des PCAN-Explorer-Objektmodells.

PCAN-Explorer anpassen

Information über Möglichkeiten, PCAN-Explorer an eigene Bedürfnisse anzupassen.


Übersicht: Callback-Bibliotheken

Leitseite (Callback-Bibliotheken) | Referenz

Mit Callback-Bibliotheken können Sie Daten von empfangenen oder gesendeten CAN-Botschaften auf eigene Art und Weise auswerten, verarbeiten oder modifizieren.

Callback-Bibliotheken sind Dynamic Link Libraries (DLLs), die Sie mit geeigneten Compilern selbst erstellen und ganz nach Ihren Bedürfnissen programmieren. Eine erzeugte Callback-Bibliothek nehmen Sie in ein PCAN-Explorer-Projekt auf, so dass Sie die programmierten Funktionen zu den verschiedenen Ereignisse zuordnen können, die PCAN-Explorer beim Empfangen und Senden von CAN-Botschaften auslöst, und in dabei dann die DLL-Funktionen aufruft, die diesen Ereignissen zugewiesen sind.

PCAN-Explorer übergibt spezielle Objekte an die DLL-Funktionen als Funktionsparameter, die der jeweiligen Funktion Zugriff auf die Daten der empfangenen oder gesendeten Botschaft ermöglicht. Die Funktion der Callback-Bibliothek kann die verschiedenen Eigenschaften und Methoden dieser Objekte verwenden, um die Datenbytes der Botschaft wie gewünscht zu verarbeiten oder zu modifizieren, oder um sonstige Aufgaben auszuführen. Beispielsweise kann eine Funktion vor jedem Senden einer Botschaft laufende Zähler oder eine Checksumme für die Botschaft berechnen und in die Datenbytes an den korrekten Stellen einfügen, so dass die Integrität der Botschaft sichergestellt ist, und vom Empfänger als gültig verifiziert werden kann.

Weitere Themen

  • Der Prozess zum Erzeugen von Callback-Bibliotheken

  • Wie Funktionen von Callback-Bibliotheken ausgeführt werden


Der Prozess zum Erzeugen von Callback-Bibliotheken

Leitseite (Callback-Bibliotheken) | Übersicht | Referenz

Nachfolgend ist eine Zusammenfassung über den Entwurfsprozess einer Callback-Bibliothek aufgeführt.

  1. Entscheiden Sie, welche Programmiersprache Sie verwenden möchten.

  2. Erzeugen Sie ein Projekt für eine Callback-Bibliothek (Windows Desktop Dynamic Link Library) mit einer 32-Bit Build-Konfiguration.

  3. Schreiben Sie die Funktionen, die Sie von der DLL exportieren möchten.

  4. Erzeugen Sie die DLL aus den Quellcode-Dateien.

  5. Nehmen Sie die DLL in ein PCAN-Explorer-Projekt auf.

  6. Öffnen Sie die DLL aus dem Projekt-Manager heraus um das Callback-Bibliothek-Fenster anzuzeigen, und weisen Sie dort Ihre exportierten DLL-Funktionen den verfügbaren Ereignissen zu.


Wie Funktionen von Callback-Bibliotheken ausgeführt werden

Leitseite (Callback-Bibliotheken) | Übersicht | Referenz

Immer wenn ein Ereignis auftritt, zu welchem eine exportierte DLL-Funktion zugewiesen wurde, ruft PCAN-Explorer die Funktion auf und wartet auf die Rückkehr aus der Funktion, bevor er seine Operationen fortführt. In Abhängigkeit der Art des Ereignisses übergibt er an die DLL-Funktion unterschiedliche Parameter, womit der Funktion ermöglicht wird, auf das Objekt zuzugreifen, für welches das Ereignis ausgelöst wurde.

In Abhängigkeit des Ereignisses gibt es derzeit drei verschiedene Parametertypen:

Ereignis | Parametertyp | Beschreibung
OnDisable OnEnable | IPECallbackLibraryEvent * | Zeiger auf ein IPECallbackLibraryEvent-Interface, das den Zugriff auf ein CallbackLibraryEvent-Objekt ermöglicht.
OnReceive OnTimingError | IPEReceiveEvent * | Zeiger auf ein IPEReceiveEvent-Interface, das den Zugriff auf ein ReceiveEvent-Objekt ermöglicht.
OnAfterTransmit OnBeforeTransmit OnPause OnReset OnResume | IPETransmitEvent * | Zeiger auf ein IPETransmitEvent-Interface, das den Zugriff auf ein TransmitEvent-Objekt ermöglicht.

Die Objekte ReceiveEvent und TransmitEvent, auf welche Sie über die übergebenen Interfaces zugreifen können, haben gegenüber ihren voll ausgestatteten Gegenstücken ReceiveMessage und TransmitMessage einen leicht reduzierten Satz von Eigenschaften und Methoden, und erlauben nur Schreibzugriff auf solche Attribute der Botschaftsobjekte, die manipuliert werden können, wenn die Ereignisse ausgelöst werden. Beispielsweise erlaubt die Eigenschaft ID des Objekts TransmitMessage Lese- und Schreibzugriff, die Eigenschaft ID des Objekts TransmitEvent kann jedoch nur gelesen werden.

Achtung

Callback-Bibliothek-Funktionen werden im Haupt-Thread von PCAN-Explorer ausgeführt. Aus diesem Grund sollten Sie keine länglichen Operationen in Ihren DLL-Funktionen durchführen, da dies alle Aufgaben unterbricht, die PCAN-Explorer bearbeitet. Auch Worker-Threads, die im Hintergrund arbeiten, werden oft mit dem Haupt-Thread synchronisiert, deshalb kann der Verbrauch von zu viel Zeit in einer DLL-Funktion dazu führen, dass Fenster nicht mehr korrekt gezeichnet werden, die Benutzeroberfläche nicht mehr auf Eingaben reagiert, oder im schlimmsten Fall CAN-Botschaften verloren gehen.

Wenn Sie Callback-Funktionen schreiben, die empfangene oder gesendeten Botschaften behandeln, wird strengstens empfohlen, nur auf die Methoden und Eigenschaften der übergebenen Interfaces zuzugreifen, um die unmittelbaren Objekte ReceiveEvent und TransmitEvent zu untersuchen oder zu manipulieren, und nicht auf andere Objekte des PCAN-Explorer Objektmodells zuzugreifen. Letzteres ist theoretisch möglich indem z.B. bei der Behandlung des OnEnable-Ereignisses Referenzen das IPECallbackLibraryEvent-Interface und dessen Application-Eigenschaft dazu verwendet werden, um auf andere Objekte im Objektmodell zuzugreifen. Es wird nicht empfohlen, an dieser Stelle Referenzen auf Objekte zu speichern, um sie später in anderen Callback-Funktionen zu verwenden. Es ist nicht garantiert, dass der Zugriff auf Eigenschaften und Methoden von anderen Objekten in zukünftigen Versionen von PCAN-Explorer erfolgreich verläuft, wenn eine Sende-/Empfangsbezogene Callback-Funktion aufgerufen wird.

Sie können die Ausführung von Callback-Bibliotheks-Funktionen für eine ausgewählte DLL deaktivieren, indem Sie die Option Aktiviere Callback-Funktionen im Konfigurationsfenster der entsprechenden DLL deaktivieren.

Wird ein Fehler in einer der aufgerufenen DLL-Funktionen festgestellt, deaktiviert PCAN-Explorer die weitere Ausführung von Funktionen der DLL, indem er automatisch die Option Aktiviere Callback-Funktionen für die DLL abschaltet, wobei noch das OnDisable-Ereignis ausgelöst wird.


Referenz: Callback-Bibliotheken

Leitseite (Callback-Bibliotheken) | Übersicht

Mit Callback-Bibliotheken können Sie Daten von empfangenen oder gesendeten CAN-Botschaften auf eigene Art und Weise auswerten, verarbeiten oder modifizieren.

Ereignisse

Nachfolgend sind alle Ereignisse aufgeführt, die von Callback-Bibliotheken verarbeitet werden können. Dazu muss die Callback-Bibliothek Funktionen exportieren, die diesen Ereignissen dann im geladenen PCAN-Explorer-Projekt zugewiesen werden.

Ereignis | Beschreibung
OnAfterTransmit | Tritt auf, nachdem eine Botschaft gesendet wurde.
OnBeforeTransmit | Tritt auf, bevor eine Botschaft gesendet wird.
OnDisable | Tritt auf, wenn eine Callback-Bibliothek deaktiviert wird.
OnEnable | Tritt auf, wenn eine Callback-Bibliothek aktiviert wird.
OnPause | Tritt auf, wenn das periodische Senden einer Botschaft angehalten wurde.
OnReceive | Tritt auf, nachdem eine Botschaft empfangen wurde.
OnReset | Tritt auf, wenn der Zurücksetzen-Befehl für eine Verbindung ausgeführt wurde.
OnResume | Tritt auf, wenn das periodische Senden eine Botschaft fortgesetzt wurde.
OnTimingError | Tritt auf, wenn ein Timing-Fehler für eine empfangene Botschaft festgestellt wurde.
Interfaces

Nachfolgend sind alle Interfaces aufgeführt, die PCAN-Explorer beim Aufrufen von Funktionen aus Callback-Bibliotheken verwendet.

Interface | Beschreibung
IPECallbackLibraryEvent | Ein Zeiger auf dieses Interface wird an eine Callback-Funktion übergeben, die ein Ereignis für die Callback-Bibliothek selbst behandelt, z.B. bei Aktivierung/Deaktivierung der Bibliothek.
IPEReceiveEvent | Ein Zeiger auf dieses Interface wird an eine Callback-Funktion übergeben, die ein Ereignis für eine Empfangsbotschaft behandelt.
IPETransmitEvent | Ein Zeiger auf dieses Interface wird an eine Callback-Funktion übergeben, die ein Ereignis für eine Sendebotschaft behandelt.

Siehe auch

Reference: PCAN-Explorer Objects (in Englisch)


IPECallbackLibraryEvent-Interface

Leitseite (Callback-Bibliotheken) | Übersicht | Referenz

Dieses Interface kann verwendet werden, um Informationen über eine Callback-Bibliothek zu erhalten, die aktiviert oder deaktiviert wird. Ein Zeiger auf dieses Interface wird von PCAN-Explorer an die aufgerufenen Callback-Funktionen übergeben, wenn eines der Ereignisse OnEnable oder OnDisable auftritt.

Eine Liste aller Eigenschaften des IPECallbackLibraryEvent-Interfaces finden Sie in der Referenz des Objekts CallbackLibraryEvent.

Hinweis

Das IPECallbackLibraryEvent-Interface ist kein Dual Interface, da es nicht von IDispatch abgeleitet ist. Es ist von IUnknown abgeleitet.

Das IPECallbackLibraryEvent COM-Interface hat die folgende vordefinierte Interface-ID (IID): 2F9B6A72-2A97-4EC1-A884-590A21A35D12. Das Interface ist in der PCAN-Explorer Callback Events Typbibliothek PECallbackEvents.tlb definiert, die im PCAN-Explorer Installationsverzeichnis zu finden ist.


IPEReceiveEvent-Interface

Leitseite (Callback-Bibliotheken) | Übersicht | Referenz

Dieses Interface muss verwendet werden, um Daten aus einer Botschaft zu lesen, die von PCAN-Explorer empfangen wurde. Ein Zeiger auf dieses Interface wird von PCAN-Explorer an die aufgerufenen Callback-Funktionen übergeben, wenn eines der Ereignisse OnReceive oder OnTimingError auftritt.

Eine Liste aller Eigenschaften und Methoden des IPEReceiveEvent-Interfaces finden Sie in der Referenz des Objekts ReceiveEvent.

Hinweis

Das IPEReceiveEvent-Interface ist kein Dual Interface, da es nicht von IDispatch abgeleitet ist. Es ist von IUnknown abgeleitet.

Das IPEReceiveEvent COM-Interface hat die folgende vordefinierte Interface-ID (IID): 0CB3A137-E323-4C8F-B4A1-7EBBD075DCF3. Das Interface ist in der PCAN-Explorer Callback Events Typbibliothek PECallbackEvents.tlb definiert, die im PCAN-Explorer Installationsverzeichnis zu finden ist.


IPETransmitEvent-Interface

Leitseite (Callback-Bibliotheken) | Übersicht | Referenz

Dieses Interface muss verwendet werden, um Daten aus einer Botschaft zu lesen oder zu modifizieren, die von PCAN-Explorer gesendet werden. Ein Zeiger auf dieses Interface wird von PCAN-Explorer an die aufgerufenen Callback-Funktionen übergeben, wenn eines der Ereignisse OnBeforeTransmit, OnAfterTransmit, OnResume, OnPause oder OnReset auftritt.

Eine Liste aller Eigenschaften und Methoden des IPETransmitEvent-Interfaces finden Sie in der Referenz des Objekts TransmitEvent.

Hinweis

Das IPETransmitEvent-Interface ist kein Dual Interface, da es nicht von IDispatch abgeleitet ist. Es ist von IUnknown abgeleitet.

Das IPETransmitEvent COM-Interface hat die folgende vordefinierte Interface-ID (IID): 226B0C97-D642-43D3-A5CA-E24A89055879. Das Interface ist in der PCAN-Explorer Callback Events Typbibliothek PECallbackEvents.tlb definiert, die im PCAN-Explorer Installationsverzeichnis zu finden ist.


OnAfterTransmit-Ereignis

Leitseite (Callback-Bibliotheken) | Übersicht | Referenz

Tritt auf, nachdem eine Botschaft gesendet wurde (CAN, CAN FD, J1939).

Syntax
C++

HRESULT __stdcall FunktionsName(

IPETransmitEvent *pEvent

);
Pascal

function FunktionsName(

const pEvent: IPETransmitEvent

);
Parameter

pEvent

Ein Zeiger (IPETransmitEvent*) auf das COM-Interface des PCAN-Explorer TransmitEvent-Objekts, das die gesendete Botschaft repräsentiert.


OnBeforeTransmit-Ereignis

Leitseite (Callback-Bibliotheken) | Übersicht | Referenz

Tritt auf, bevor eine Botschaft gesendet wird (CAN, CAN FD, J1939).

Syntax
C++

HRESULT __stdcall FunktionsName(

IPETransmitEvent *pEvent

);
Pascal

function FunktionsName(

const pEvent: IPETransmitEvent

);
Parameter

pEvent

Ein Zeiger (IPETransmitEvent*) auf das COM-Interface des PCAN-Explorer TransmitEvent-Objekts, das die zu sendende Botschaft repräsentiert.

Beispiel

Das folgende Beispiel erzeugt einen rollenden Zähler in Datenbyte 0 einer CAN-Botschaft mit ID 100h, der vor jedem Senden der Botschaft um eins erhöht wird:

Visual C++

using namespace PCANExplorer6;

int counter = 0;

HRESULT __stdcall HandleBeforeTransmit(IPETransmitEvent *pEvent)

{

long id;

if (SUCCEEDED(pEvent->get_ID(&id)) && (id == 0x100))

{

counter++;

if (counter > 255)

counter = 0;

pEvent->put_Data(0, counter);

}

return S_OK;

}
Delphi / Lazarus

uses PCANExplorer6_2_0_TLB;

var counter: Integer = 0;

function HandleBeforeTransmit(const pEvent: IPETransmitEvent): HRESULT; stdcall;

begin

if (event.ID = $100) then

begin

Inc(counter);

if (counter > 255) then

counter := 0;

event.Data[0] := counter;

end;

Result := S_OK;

end;


OnDisable-Ereignis

Leitseite (Callback-Bibliotheken) | Übersicht | Referenz

Tritt auf, wenn eine Callback-Bibliothek deaktiviert wird.

Syntax
C++

HRESULT __stdcall FunktionsName(

IPECallbackLibraryEvent *pEvent

);
Pascal

function FunktionsName(

const pEvent: IPECallbackLibraryEvent

);
Parameter

pEvent

Ein Zeiger (IPECallbackLibraryEvent*) auf das COM-Interface des PCAN-Explorer CallbackLibraryEvent-Objekts, das die Callback-Bibliothek repräsentiert, die deaktiviert wird.


OnEnable-Ereignis

Leitseite (Callback-Bibliotheken) | Übersicht | Referenz

Tritt auf, wenn eine Callback-Bibliothek aktiviert wird.

Syntax
C++

HRESULT __stdcall FunktionsName(

IPECallbackLibraryEvent *pEvent

);
Pascal

function FunktionsName(

const pEvent: IPECallbackLibraryEvent

);
Parameter

pEvent

Ein Zeiger (IPECallbackLibraryEvent*) auf das COM-Interface des PCAN-Explorer CallbackLibraryEvent-Objekts, das die Callback-Bibliothek repräsentiert, die aktiviert wird.


OnPause-Ereignis

Leitseite (Callback-Bibliotheken) | Übersicht | Referenz

Tritt auf, wenn das periodische Senden einer Botschaft angehalten wurde.

Syntax
C++

HRESULT __stdcall FunktionsName(

IPETransmitEvent *pEvent

);
Pascal

function FunktionsName(

const pEvent: IPETransmitEvent

);
Parameter

pEvent

Ein Zeiger (IPETransmitEvent*) auf das COM-Interface des PCAN-Explorer TransmitEvent-Objekts, das die Sendebotschaft repräsentiert, deren periodisches Senden angehalten wurde.


OnReceive-Ereignis

Leitseite (Callback-Bibliotheken) | Übersicht | Referenz

Tritt auf, nachdem eine Botschaft empfangen wurde (CAN, CAN FD, J1939).

Syntax
C++

HRESULT __stdcall FunktionsName(

IPEReceiveEvent *pEvent

);
Pascal

function FunktionsName(

const pEvent: IPEReceiveEvent

);
Parameter

pEvent

Ein Zeiger (IPEReceiveEvent*) auf das COM-Interface des PCAN-Explorer ReceiveEvent-Objekts, das die empfangene Botschaft repräsentiert.


OnReset-Ereignis

Leitseite (Callback-Bibliotheken) | Übersicht | Referenz

Tritt auf, wenn der Zurücksetzen-Befehl für eine Verbindung ausgeführt wurde. Das Ereignis wird dann für alle Sendebotschaften ausgelöst, die zu der Verbindung gehören, für die der Zurücksetzen-Befehl ausgeführt wurde.

Syntax
C++

HRESULT __stdcall FunktionsName(

IPETransmitEvent *pEvent

);
Pascal

function FunktionsName(

const pEvent: IPETransmitEvent

);
Parameter

pEvent

Ein Zeiger (IPETransmitEvent*) auf das COM-Interface des PCAN-Explorer TransmitEvent-Objekts, das die Sendebotschaft repräsentiert, für die das OnReset-Ereignis ausgelöst wurde.


OnResume-Ereignis

Leitseite (Callback-Bibliotheken) | Übersicht | Referenz

Tritt auf, wenn das periodische Senden einer Botschaft fortgesetzt wurde.

Syntax
C++

HRESULT __stdcall FunktionsName(

IPETransmitEvent *pEvent

);
Pascal

function FunktionsName(

const pEvent: IPETransmitEvent

);
Parameter

pEvent

Ein Zeiger (IPETransmitEvent*) auf das COM-Interface des PCAN-Explorer TransmitEvent-Objekts, das die Sendebotschaft repräsentiert, deren periodisches Senden fortgesetzt wurde.


OnTimingError-Ereignis

Leitseite (Callback-Bibliotheken) | Übersicht | Referenz

Tritt auf, wenn ein Timing-Fehler für eine empfangene Botschaft festgestellt wurde.

Syntax
C++

HRESULT __stdcall FunktionsName(

IPEReceiveEvent *pEvent

);
Pascal

function FunktionsName(

const pEvent: IPEReceiveEvent

);
Parameter

pEvent

Ein Zeiger (IPEReceiveEvent*) auf das COM-Interface des PCAN-Explorer ReceiveEvent-Objekts, das die empfangene Botschaft repräsentiert, für die ein Timing-Fehler festgestellt wurde.

Bemerkungen

Das Detektieren von Timing-Fehlern hängt von den Werten der Parameter Timeout und MinInterval von Symbol- oder Multiplexer-Definitionen ab, siehe Timing. Außerdem muss die Aufzeichnung von Timing-Fehlern für das aktuell geladene Projekt aktiviert sein, entweder im Projekteinstellungen-Dialogfenster oder über die Schaltfläche [image] in der Symbolleiste.


Leitseite: Referenz

Dieser Abschnitt enthält Informationen über Dialogfenster und anderer Fenster, Tastenkombinationen, PCAN-Explorer-Befehle, Makros und Fehlermeldungen.

In diesem Abschnitt

Benutzeroberfläche

Enthält Referenz-Themen für die verschiedenen Dialogfenster und anderer Fenster von PCAN-Explorer.

PCAN-Explorer-Befehle

Enthält die Referenz zu allen vordefinierten PCAN-Explorer-Befehlen.

Symboldateien

Enthält die Referenz zu Symboldateien.

Standardmakros

Enthält die Referenz zu Standardmakros.

Fehlermeldungen

Führt alle Fehlermeldungen auf, die beim Arbeiten mit Symboldateien und Standardmakros, sowie im Sende- und Empfangsbetrieb auftreten können.

Weitere Abschnitte

VBScript-Sprachverzeichnis

Enthält Themen zur VBScript-Programmiersprache bezüglich Eigenschaften, Methoden, Objekte, Funktionen und Anderem.


Benutzeroberfläche

Benutzeroberfläche

Leitseite: Referenz

Die Themen der Referenz zur Benutzeroberfläche erklären die Elemente der Benutzeroberfläche, die in den verschiedenen Dialogfenster, Fenstern und anderen Teilen der Benutzeroberfläche erscheinen. Diese Themen werden üblicherweise angezeigt, wenn Sie die Taste [F1] in einem Dialogfenster oder anderem Fenster drücken, oder wenn Sie die Schaltfläche Hilfe in einem Dialogfenster anklicken.

In diesem Abschnitt

Allgemeine Elemente der Benutzeroberfläche

Beschreibt das Eigenschaften-Fenster, das Ausgabe-Fenster, den Texteditor, den Bibliotheks-Browser, das Info-Dialogfenster, das Add-in Manager-Dialogfenster und das Externe Werkzeuge-Dialogfenster.

Projekt-spezifische Elemente der Benutzeroberfläche

Beschreibt die Elemente der Benutzeroberfläche die im Umgang mit Projekten verwendet werden, z.B. den Projekt-Manager.

CAN-spezifische Elemente der Benutzeroberfläche

Beschreibt Elemente der Benutzeroberfläche bezüglich CAN, beispielsweise das Verbindung hinzufügen-Dialogfenster und das Botschaft bearbeiten-Dialogfenster.

Dateibezogene Elemente

Beschreibt Elemente der Benutzeroberfläche, die im Umgang mit Dateien verwendet werden.

Makro-Elemente

Beschreibt Elemente der Benutzeroberfläche bezüglich VBScript-Makros und Standardmakros.

Optionen-Dialogfenster

Ermöglicht die Konfiguration verschiedener Optionen zur Beeinflussung der PCAN-Explorer-Umgebung.

Senden/Empfangen-Fenster

Zeigt empfangene CAN- oder J1939-Botschaften an und erlaubt das manuelle Senden eigener Botschaften.

Signal- und Symbol-Elemente

Beschreibt Elemente der Benutzeroberfläche bezüglich Signale und Symbole, beispielsweise das Signalauswahl-Dialogfenster und das Überwachungen-Fenster.

Tastenkombinationen

Beschreibt die vordefinierten Tastenkombinationen und weitere Elemente der Benutzeroberfläche im Bezug auf Tastenkombinationen.

Tracer-Elemente

Enthält die Referenz zu Elementen der Benutzeroberfläche bezüglich des Botschafts-Tracers.

Andere Elemente der Benutzeroberfläche

Beschreibt Elemente der Benutzeroberfläche, die zu keinen der anderen Kategorien zugeordnet werden können, z.B. das Callback-Bibliothek-Fenster.

Weitere Abschnitte

PCAN-Explorer-Befehle

Enthält die Referenz zu den vordefinierten PCAN-Explorer-Befehlen.

Fehlermeldungen

Dieser Abschnitt führt alle Fehlermeldungen auf, die beim Arbeiten mit Symboldateien und Standardmakros sowie im Sende- und Empfangsbetrieb auftreten können.


Allgemeine Elemente der Benutzeroberfläche

Nachfolgend sind allgemeinen Elemente aufgeführt, die in der Benutzeroberfläche von PCAN-Explorer verfügbar sind, wie beispielsweise der das Eigenschaften-Fenster, das Verbindungen-Fenster und das Ausgabe-Fenster.

In diesem Abschnitt

Eigenschaften-Fenster

Zeigt die Eigenschaften von verschiedenen Objekten an, wenn diese in der Benutzeroberfläche ausgewählt sind.

Ausgabe-Fenster

Zeigt Statusmeldungen für verschiedene Elemente der PCAN-Explorer-Benutzeroberfläche an.

Verbindungen-Fenster

Enthält eine detaillierte Übersicht aller Verbindungen des aktuellen Projekts.

Add-in Manager Dialogfenster

Ermöglicht das Installieren von Add-ins in der PCAN-Explorer-Benutzeroberfläche.

VBS-Makro Manager-Dialogfenster

Verwaltet VBS-Makros.

Externe Werkzeuge-Dialogfenster

Ermöglicht das Hinzufügen von Einträgen zum Menü Werkzeuge, um eigene externe Hilfsprogramme aus PCAN-Explorer heraus zu starten.

Bibliotheks-Browser

Ein Werkzeug zum Durchsuchen der PCAN-Explorer-Bibliothek.

Texteditor

Ermöglicht das Editieren von Symboldateien, Standardmakros und VBScript-Makros.

Info-Dialogfenster

Zeigt Informationen über PCAN-Explorer an.

Weitere Abschnitte

Benutzeroberfläche

Enthält Referenz-Themen für die verschiedenen Dialogfenster und anderer Fenster von PCAN-Explorer


Eigenschaften-Fenster

Das Eigenschaften-Fenster kann verwendet werden, um Eigenschaften von allen möglichen Objekten anzuzeigen und zu ändern, die in der Benutzeroberfläche von PCAN-Explorer ausgewählt werden können.

Um das Eigenschaften-Fenster anzuzeigen, wählen Sie den Befehl Eigenschaften im Menü Ansicht.

Siehe auch

Benutzeroberfläche


Ausgabe-Fenster

Das Ausgabe-Fenster zeigt Status- und Ereignismeldungen für verschiedene Elemente der PCAN-Explorer-Benutzeroberfläche an.

Um das Ausgabe-Fenster anzuzeigen, muss im Menü Ansicht der Befehl Ausgabe ausgewählt werden.

Das Ausgabe-Fenster zeigt Meldungen auf verschiedenen Registerkarten an:

Meldungen

Auf dieser Seite werden allgemeine Meldungen angezeigt, die von verschiedenen Elementen der Benutzeroberfläche generiert werden..

Editor

Auf dieser Seite werden Meldungen des Texteditors angezeigt, beispielsweise Fehlermeldungen, die beim Aktivieren von Symboldateien oder Kompilieren von Standardmakros auftreten können.

Makro

Diese Seite zeigt Meldungen, die mittels der PrintToOutputWindow-Methode von VBScript-Makros oder der PrintToOutputWindow-Anweisung von Standardmakros ausgegeben werden.

Ereignisse

Diese Seite zeigt Meldungen für die folgenden Ereignisse an:

  • Busfehler

  • Ein- und Ausstecken von CAN-Hardware

  • Meldungen und Fehler des J1939-Adressierungsprotokolls.

Zusätzlich können weitere Registerkarten erzeugt werden, indem z.B. von einem VBScript-Makro auf die Kollektion OutputWindowPanes zugegriffen wird.

Siehe auch

Benutzeroberfläche


Verbindungen-Fenster

Das Verbindungen-Fenster gibt einen schnellen Überblick über alle Verbindungen des aktuellen Projekts. Im Gegensatz zum Projekt-Manager, der im Knoten Verbindungen nur über die Namen und den Status von Verbindungen informiert, zeigt das Verbindungen-Fenster detaillierte Informationen zu jede Verbindung an. Zusätzlich kann im Fenster ausgewählt werden, welche Informationen angezeigt werden sollen.

Um das Verbindungen-Fenster anzuzeigen, muss im Menü Ansicht der Befehl Verbindungen ausgewählt werden.

Symbolleiste

Schaltfläche | Befehl | Beschreibung
 | Verbindung hinzufügen | Fügt dem aktuellen Projekt eine neue Verbindung hinzu.
 | Verbindung zurücksetzen | Setzt die in der Liste ausgewählte Verbindung zurück. Je nachdem, welche Aktionen für den Zurücksetzen-Befehl im Optionen-Dialog auf der Registerseite Senden/Empfangen konfiguriert sind, können optional die Botschaften der Verbindung aus der Empfangsliste gelöscht, Zähler und Zeitangaben in Empfangs- und Sendelisten zurückgesetzt, sowie die periodischen Sendebotschaften der Verbindung neu gestartet werden.
 | Adresse anfordern | Verwendet die ausgewählte Verbindung das J1939-Protokoll, können Sie mit dieser Schaltfläche eine Adresse für die Verbindung anfordern. Die Verbindung wird versuchen, die Adresse anzufordern, die in den Verbindungseigenschaften unter Bevorzugte Adresse eingetragen ist (siehe auch Spezifikation SAE J1939-81, Network Management).
 | Adresse freigeben | Verwendet die ausgewählte Verbindung das J1939-Protokoll, und wurde für die Verbindung bereits eine Adresse angefordert, können Sie mit dieser Schaltfläche die angeforderte Adresse wieder freigeben (siehe auch Spezifikation SAE J1939-81, Network Management).

Spalten im Verbindungen-Fenster

Die folgenden Spalten sind im Verbindungen-Fenster verfügbar:

(Aktiviert)

Diese Spalte hat keine Überschrift. Klicken Sie in das Markierungsfeld, um eine Verbindung zu aktivieren oder zu deaktivieren.

Bus

Zeigt die Bus-Nummer der Verbindung (1-16).

Name

Der Name der Verbindung, wie er auch im Projekt-Manager angezeigt wird.

Netzverbindung

Der Netzverbindung in der Form Netzname@GeräteName.

Netzname

Der Name des PCAN-Netzes, das die Verbindung verwendet.

Gerät

Der Name des PCAN-Geräts, das die Verbindung verwendet.

Hardware

Der Name der verwendeten PCAN-Hardware.

Bitrate

Die Übertragungsrate auf dem CAN-Bus.

Status

Der aktuelle Busstatus der Verbindung. Die folgenden Statustexte können hier angezeigt werden:
OK, Error Passive, Warnung, Bus-Off, BUSLIGHT, BUSHEAVY, OVERRUN, QOVERRUN. Siehe auch Hardware-Status.

Overruns

Die Anzahl der aufgetretenen "Overruns" für die Verbindung. Overruns treten auf, wenn der CAN-Controller so viele Botschaften empfängt, dass die Verarbeitung der ausgelösten Hardware-Interrupts nicht schnell genug durchgeführt werden kann.

QXmtFulls

Die Anzahl der aufgetretenen "Transmit Queue Full"-Ereignisse für die Verbindung. Dies ist die Anzahl von Versuchen, eine Botschaft zu senden, obwohl der Sendepuffer der Hardware im Treiber voll ist. Der Füllstand des Sendepuffers nimmt zu, falls Botschaften nicht auf dem Bus gesendet werden können, weil ein Problem auf dem Bus besteht. Der Sendepuffer einer CAN-Hardware hat gewöhnlich eine Größe von 32767 Botschaften.

Optionen

CAN-Controller Optionen.

Option

Beschreibung

EF

Error Frames. Diese Option aktiviert den Empfang von Error Frames.

Diese Option ist nur verfügbar, falls die Verbindung mit einer CAN-Hardware verknüpft ist, die den Empfang von Error Frames unterstützt.

LO

Listen-Only. Diese Option aktiviert den Listen-Only-Modus des CAN-Controllers. Im Listen-Only-Modus ist PCAN-Explorer kein aktiver Busteilnehmer. Dies bedeutet, dass der verbundene CAN-Controller kein Acknowledge auf eine empfangene CAN-Botschaft sendet. Botschaften können nur empfangen werden, Senden von Botschaften ist dann nicht möglich.

Diese Option ist nur verfügbar, falls die Verbindung mit einer CAN-Hardware verknüpft ist, die den Listen-Only-Modus unterstützt.

ST

Zeitstempel bei Start-of-Frame. Wenn aktiviert, wird der Zeitstempel einer CAN-Nachricht bei Start-of-Frame bestimmt anstatt bei End-of-Frame.

Benötigt mindestens PCAN-Treiber Version 4.3.0, und das verwendete CAN-Interface bzw. dessen Firmware-Version muss das Feature unterstützen.

SA

Tx Self-Acknowledge. Wenn aktiviert, sendet der CAN-Controller auch als Sender einen Acknowledge Slot (ACK) auf den Bus, sodass keine anderen CAN-Knoten am Bus vorhanden sein müssen, um den Frame zu quittieren.

Benötigt mindestens PCAN-Treiber Version 4.3.0, und das verwendete CAN-Interface bzw. dessen Firmware-Version muss das Feature unterstützen.

IB

Ignoriere BRS (Bit Rate Switch). Wenn aktiviert, ignoriert der CAN-Controller empfangene CAN-FD-Frames, bei denen das BRS-Bit gesetzt ist.

Benötigt mindestens PCAN-Treiber Version 4.3.0, und das verwendete CAN-Interface bzw. dessen Firmware-Version muss das Feature unterstützen.

Buslast

Die aktuelle Buslast der Verbindung. Zur Anzeige der Buslast einer Verbindung muss die Buslastberechnung zunächst in den Eigenschaften der Verbindung aktiviert werden (siehe Eigenschaft Zeige Buslast).

Tipp

Ein Doppelklick in dieser Spalte setzt den Indikator für die maximale Buslast zurück.

Buslast Spitze

Der Spitzenwert der Buslast, sowie die Zeit, wann der Spitzenwert erreicht wurde.

Protokoll

Das Protokoll, das die Verbindung verwendet, z.B. CAN, J1939.

Typ

Der Typ der Verbindung. Momentan wird nur der Typ "PCAN" unterstützt.

Symboldatei

Die Symboldatei, die zu der Verbindung zugewiesen ist.

Filter

Der Botschaftsfilter, den die Verbindung verwendet.

J1939 Adresse

Verwendet die Verbindung das J1939-Protokoll, dann zeigt diese Spalte die aktuell angeforderte Adresse der Verbindung an.

Anpassen der angezeigten Spalten

Es können sowohl die Spalten, die angezeigt werden sollen, als auch die Reihenfolge der angezeigten Spalten angepasst werden.

Um die angezeigten Spalten auszuwählen:

  1. Öffnen Sie das Kontextmenü auf einer der Spaltenüberschriften.

  2. Wählen Sie die Spalten, die Sie anzeigen möchten.

Um die Reihenfolge der Spalten zu ändern:

  1. Drücken Sie die linke Maustaste auf einer Spaltenüberschrift und halten Sie sie gedrückt.

  2. Ziehen Sie die Spalte an die neue Position.

  3. Lassen Sie die Maustaste los.

Siehe auch

Benutzeroberfläche


Add-in Manager-Dialogfenster

Das Add-in Manager-Dialogfenster ermöglicht die Installation von Add-ins in der PCAN-Explorer-Benutzeroberfläche. Um das Add-in Manager-Dialogfenster anzuzeigen, wählen Sie den Befehl Add-in Manager im Menü Werkzeuge.

Für Informationen über Add-ins und wie man Add-ins erstellt und verwendet, siehe Add-ins für PCAN-Explorer.

Verfügbare Add-ins

Eine Liste aller Add-in-Komponenten, die in PCAN-Explorer registriert sind. Durch Anklicken des Auswahlfeldes vor dem Namen des Add-ins können Sie das jeweilige Add-in aktivieren oder deaktivieren.

Version

Zeigt die Versionsnummer des Add-ins an.

Status

Zeigt an, ob die Add-in-Komponente geladen ist. Wird der Status Nicht entsperrt angezeigt, erlaubt die momentan installierte PCAN-Explorer-Lizenzdatei nicht die Verwendung des Add-ins.

Beschreibung

Eine kurze Beschreibung des Add-ins, die von dessen Autor erstellt worden ist. Diese kann z.B. Tipps zur Verwendung sowie Support-, Versions- und Lizenzinformationen enthalten.

Hinzufügen

Verwenden Sie diese Schaltfläche, um eine Add-in-Komponente auszuwählen, die in PCAN-Explorer geladen werden soll. Administratorrechte sind erforderlich, um diese Operation durchzuführen.

Wenn Sie diese Schaltfläche drücken, wählen Sie zuerst eine Add-in Komponente aus (*.dll), die Sie hinzufügen möchten. Je nachdem, ob Sie Administrator oder ein Standardbenutzer sind, zeigt Windows dann entweder die Benutzerkontensteuerung (UAC) an, oder es erscheint eine Anmeldeaufforderung, wo Sie Anmeldeinformationen für ein Administrator-Konto eingeben können. Nach einer erfolgreichen Authentifizierung wird das Add-in im System registriert und in der Liste der verfügbaren Add-ins angezeigt.

Entfernen

Verwenden Sie diese Schaltfläche, um eine Add-in-Komponente von PCAN-Explorer zu entfernen. Administratorrechte sind erforderlich, um diese Operation durchzuführen.

Wenn Sie diese Schaltfläche drücken, zeigt Windows je nachdem, ob Sie Administrator oder ein Standardbenutzer sind, entweder die Benutzerkontensteuerung (UAC) an, oder es erscheint eine Anmeldeaufforderung, wo Sie Anmeldeinformationen für ein Administrator-Konto eingeben können. Nach einer erfolgreichen Authentifizierung deregistriert PCAN-Explorer das Add-in und entfernt es aus der Liste der verfügbaren Add-ins.

Siehe auch

Verbinden von Add-ins mit PCAN-Explorer


VBS-Makro Manager-Dialogfenster

Im VBS-Makro Manager Dialogfenster sind alle VBScript-Makrodateien aufgeführt, die in PCAN-Explorer installiert sind. Mit Hilfe dieses Dialogfensters können Sie Makrodateien installieren, entfernen, aktivieren oder deaktivieren. Nur Makroprozeduren von aktivierten Makrodateien können in der PCAN-Explorer-Umgebung ausgeführt werden.

Um dieses Dialogfenster anzuzeigen, wählen Sie den Befehl VBS-Makro Manager im Menü Makro.

Für Informationen über VBS-Makros siehe VBScript-Makros.

Makrodateien

Eine Liste aller VBScript-Makrodateien, die in PCAN-Explorer installiert sind. Sie können eine bestimmte Makrodatei aktivieren oder deaktivieren, indem Sie in das Markierungfeld vor dem Namen der Datei klicken.

Beschreibung

Eine kurze Beschreibung der Makrodatei, die von dessen Autor erstellt wurde.

Ort

Zeigt den Installationsort der ausgewählten Makrodatei an.

Hinzufügen

Klicken Sie auf die Schaltfläche, um eine Makrodatei auszuwählen, die Sie in PCAN-Explorer installieren möchten.

Entfernen

Entfernt eine installierte Makrodatei. Diese Funktion ist nur für Makrodateien verfügbar, die nicht im eingestellten Bibliotheksverzeichnis für VBScript-Makrodateien installiert wurden.

Siehe auch

Installieren von VBScript-Makros


Externe Werkzeuge-Dialogfenster

Verwenden Sie dieses Dialogfenster, um externe Werkzeuge wie z.B. PCAN Status Display oder PCAN Nets Configuration zum Menü Werkzeuge hinzuzufügen. Dies ermöglicht das Ausführen von anderen Anwendungen, ohne die PCAN-Explorer-Benutzeroberfläche verlassen zu müssen. Sie können Start-Argumente und ein Arbeitsverzeichnis für das jeweilige Werkzeug festlegen. Um dieses Dialogfenster anzuzeigen, wählen Sie den Befehl Externe Werkzeuge im Menü Werkzeuge.

Für weitere Informationen darüber, wie man externe Werkzeuge zum Menü Werkzeuge hinzufügt, siehe Anpassen des Werkzeuge-Menüs.

Menü-Inhalt

Eine Liste aller Namen von externen Werkeugen, die aktuell zum Menü Werkzeuge hinzugefügt sind.

Hinzufügen

Fügt der Liste einen neuen Eintrag hinzu.

Löschen

Entfernt das ausgewählte Werkzeug oder den Befehl sowohl aus der Liste Menü-Inhalt als auch vom Menü Werkzeuge.

Nach oben

Bewegt das ausgewählte Werkzeug in der Liste der Werkzeuge, die im Menü Werkzeuge erscheinen, nach oben.

Nach unten

Bewegt das ausgewählte Werkzeug in der Liste der Werkzeuge, die im Menü Werkzeuge erscheinen, nach unten.

Titel

Der Name der Menüoption.

Tipp

Geben Sie ein kaufmännisches Und-Zeichen (&) vor einem der Buchstaben im Werkzeugnamen ein, um eine Schnellzugriffstaste für den Befehl im Menü Werkzeuge zu definieren. Wenn Sie zum Beispiel den Namen "Mein &Werkzeug" verwenden, wird der Buchstabe 'W' zur Schnellzugriffstaste.

Befehl

Gibt den Pfad der .exe, .com, .bat, .cmd oder einer anderen Datei an, die gestartet werden soll.

Argumente

Gibt die Variablen an, die an das Programm übergeben werden, wenn es aus dem Menü Werkzeuge aufgerufen wird. Argumente können Werte festlegen, die an das Werkzeug übergeben werden, wenn es gestartet wird. Beispielsweise kann ein Wert einen Dateinamen oder ein Verzeichnis enthalten. Verwenden Sie die Schaltfläche mit dem Pfeil, um eine Liste von vordefinierten Argumenten anzuzeigen. Sie können ein einzelnes oder mehrere Argumente hinzufügen. Für eine vollständige Liste aller vordefinierten Argumente siehe Tabelle Argument-Makros. Sie können auch eigene Argumente eingeben, wie z.B. Kommandozeilenschalter, abhängig vom verwendeten Werkzeug.

Arbeitsverzeichnis

Legt das Arbeitsverzeichnis des Werkzeugs fest. Verwenden Sie die Schaltfläche mit dem Pfeil, um Verzeichnisse auszuwählen. Sie können mehr als ein Verzeichnis auswählen.

Nach Argumenten fragen

Zeigt bei jedem Start des externen Werkzeugs das Argumente-Dialogfenster an, das eine Eingabe oder die Änderung von Aufrufargumenten ermöglicht.

Mehrere Instanzen erlauben

Ist diese Option aktiviert, erzeugt jedes Ausführen des Werkzeugs eine neue Instanz des Werkzeugs (es sei denn, das Werkzeug verhindert dies von sich aus).

Wenn Sie die Option abschalten und das Werkzeug bereits einmal ausgeführt haben, sucht PCAN-Explorer beim nächsten Ausführen zunächst nach der zuvor gestarteten Instanz. Ist diese noch aktiv, wird das Fenster dieser Instanz in den Vordergrund gebracht, anstatt eine neue Instanz des Werkzeugs zu starten.

Hinweis

Wenn Sie die Option abschalten und im Feld Argumente Startparameter angeben, wirken sich diese unter Umständen nur beim ersten Ausführen des Werkzeugs aus. Falls beim Ausführen des Werkzeugs eine zuvor gestartete Instanz gefunden und wiederverwendet wird, haben Startargumente keine Wirkung und es erfolgt auch keine Anzeige des Argumente-Dialogfensters, falls die Option Nach Argumenten fragen aktiviert ist.

Siehe auch

Anpassen des Werkzeuge-Menüs

Argumente für externe Werkzeuge

Argument-Makros


Argumente für externe Werkzeuge

Beim Aufruf von externen Werkzeugen aus dem Menü Werkzeuge können vordefinierte Argumente mit Hilfe von Argument-Makros an das Programm übergeben wereden. Argumente sind Variablen, die PCAN-Explorer automatisch mit Werten füllt, wenn ein externes Werkzeug aus dem Menü Werkzeuge gestartet wird.

Um ein Argument-Makro zu verwenden, muss es im Textfeld Argumente eingegeben werden. Makros, die ein Verzeichnis ergeben, können auch im Textfeld Arbeitsverzeichnis eingegeben werden.

Um ein Argument-Makro zu einem installierten Werkzeug hinzuzufügen und dann zu starten:

Als Beispiel demonstriert die folgende Prozedur, wie man das Argument $(FilePath) zum Windows-Zubehör "Editor" hinzufügt.

  1. Im Menü Werkzeuge den Befehl Externe Werkzeuge auswählen.

  2. In der Liste Menü-Inhalt den Befehl auswählen, der bearbeitet werden soll. In diesem Fall den Editor auswählen, der bereits vorher installiert wurde.

  3. Im Textfeld Argumente den Text $(FilePath) eingeben, oder die Schalfläche mit dem Pfeil rechts neben dem Textfeld betätigen, um eine Liste von verfügbaren Argumenten anzuzeigen, z.B. Dateipfad.

  4. Auf OK klicken.

  5. Um die Änderungen zu sehen, im Menü Werkzeuge auf Editor klicken. Der Windows-Editor wird mit dem aktiven Dokument als Textdatei geöffnet.

Siehe auch

Anpassen des Werkzeuge-Menüs

Argument-Makros


Bibliotheks-Browser

Der Bibliotheks-Browser ist ein Werkzeug zum Durchsuchen einer Verzeichnisstruktur, die oft verwendete Dateien wie z.B. Symboldateien, Makros, Sendelisten etc. enthält.

Um den Bibliotheks-Browser anzuzeigen, wählen Sie im Menü Ansicht den Befehl Bibliothek.

Durch Verwendung des Bibliotheks-Browsers können Sie schnell und einfach oft verwendete Dateien zum aktuellen Projekt hinzufügen. Öffnen Sie dazu das Kontextmenü (rechte Maustaste) und wählen entweder den Befehl Zum Projekt hinzufügen oder den Befehl Kopieren und zum Projekt hinzufügen.

Symboldateien

Dieser Knoten führt alle Symboldateien auf, die sich in dem eingestellten Bibliotheksverzeichnis für Symboldateien befinden. Die Dateinamen werden ohne die Dateiendung .sym angezeigt.

Mit Hilfe des Kontextmenüs können Sie Symboldateien zum aktuellen Projekt hinzufügen, und Sie können Symboldateien bearbeiten oder löschen.

Ist eine Symboldatei nicht leer, können Sie deren Inhalt anzeigen, indem Sie den Knoten aufklappen. Es werden dann alle enthaltenen Symbole dargestellt. Diese können wiederum Multiplexer und Variablen enthalten.

VBS-Makrodateien

Dieser Knoten enthält alle VBScript-Makrodateien, die sich in dem eingestellten Bibliotheksverzeichnis für VBScript-Makrodateien befinden. Durch Aufklappen der Dateiknoten können Sie die in ihnen enthaltenen Makroprozeduren anzeigen.

Sie können VBS-Makroprozeduren ausführen, indem Sie ein Doppelklick auf einer Prozedur ausführen.

Sie können VBS-Makroprozeduren über das Kontextmenü bearbeiten oder ausführen.

Standardmakros

Dieser Knoten führt alle Standardmakros auf, die sich in dem eingestellten Bibliotheksverzeichnis für Standardmakros befinden. Jedes Standardmakro benötigt im Gegensatz zu VBScript-Makroprozeduren eine eigene Datei.

Sie können Standardmakros bearbeiten, indem Sie ein Doppelklick auf einem Makro ausführen, oder indem Sie den Befehl Bearbeiten aus dem Kontextmenü auswählen.

Standardmakros können im Bibliotheks-Browser nicht ausgeführt werden. Um ein Standardmakro zu starten, fügen Sie es zuerst dem aktuellen Projekt hinzu, und führen es dann aus dem Projekt-Manager oder der Makro-Dropdownliste in der Makro-Symbolleiste aus.

Sendelisten

Dieser Knoten enthält alle Sendelisten, die sich im Bibliotheksverzeichnis für Sendelisten befinden.

Mit Hilfe des Kontextmenüs können Sie Sendelisten zum aktuellen Projekt hinzufügen, und Sie können Sendelisten öffnen oder löschen.

Trace-Dateien

Dieser Knoten enthält alle Trace-Dateien, die sich im Bibliotheksverzeichnis für Trace-Dateien befinden.

Mit Hilfe des Kontextmenüs können Sie Trace-Dateien zum aktuellen Projekt hinzufügen, und Sie können Trace-Dateien öffnen oder löschen.

Callback-Bibliotheken

Dieser Knoten enthält alle Callback-Bibliotheken, die sich im Bibliotheksverzeichnis für Callback-Bibliotheken befinden.

Mit Hilfe des Kontextmenüs können Sie Callback-Bibliotheken zum aktuellen Projekt hinzufügen, und Sie können Callback-Bibliotheken öffnen oder löschen.

CANdb-Dateien

Falls das CANdb Add-in installiert und geladen ist, führt dieser Knoten alle CANdb-Netzwerk Dateien auf, die sich im Bibliotheksverzeichnis für CANdb-Dateien befinden.

Mit Hilfe des Kontextmenüs können Sie CANdb-Dateien zum aktuellen Projekt hinzufügen, und Sie können CANdb-Dateien öffnen oder löschen.

Plotter-Dateien

Falls das Plotter Add-in installiert und geladen ist, führt dieser Knoten alle Plotter-Dateien auf, die sich im Bibliotheksverzeichnis für Plotter-Dateien befinden.

Mit Hilfe des Kontextmenüs können Sie Plotter-Dateien zum aktuellen Projekt hinzufügen, und Sie können Plotter-Dateien öffnen oder löschen.

Instruments Panel-Dateien

Falls das Instruments Panel Add-in installiert und geladen ist, führt dieser Knoten alle Instruments Panel-Dateien auf, die sich im Bibliotheksverzeichnis für Instruments Panel-Dateien befinden.

Mit Hilfe des Kontextmenüs können Sie Instruments Panel-Dateien zum aktuellen Projekt hinzufügen, und Sie können Instruments Panel-Dateien öffnen oder löschen.

Siehe auch

Benutzeroberfläche

Bibliothek, Optionen-Dialogfenster


Texteditor

Der Texteditor ist ein Werkzeug zur Textverarbeitung, mit dem man Code und Text eingeben, anzeigen und editieren kann.

Es können mehrere Texteditorfenster gleichzeitig offen sein, um das Arbeiten mit den verschiedenen Arten von Textdateien zu erleichtern. Der Texteditor unterstützt verschiedene Programmiersprachen. Er erkennt die Syntax und Schlüsselworte der Dialekte und färbt diese zur leichteren Lesbarkeit ein.

Texteditorfenster können auf folgende Arten geöffnet werden:

  • Im Projekt-Manager, indem eine Datei auf der Registerseite Projekt-Dateien ausgewählt wird, und dann der Befehl Öffnen aus dem Kontextmenü der Datei ausgewählt wird.

  • Im Bibliotheks-Fenster, indem eine Datei ausgewählt wird, und dann einer der Befehle Öffnen oder Bearbeiten aus dem Kontextmenü der Datei ausgewählt wird.

  • Im Menü Datei, indem einer der Befehle Neu oder Öffnen ausgewählt wird.

Textfeld

Der Bereich, in dem der Text eingegeben wird. Es können diverse Einstellungen verändert werden, die das Erscheinungsbild des Textes und das Verhalten der Texteingabe beeinflussen. Siehe auch Schriftarten und Farben, Optionen-Dialogfenster.

Anzeigerand

Der Bereich links vom Texteditor. Hier können Zeilennummern oder Lesezeichen angezeigt werden. Wenn Sie mit der Maus in diesen Bereich klicken, wird die Einfügemarke an den Anfang der entsprechenden Zeile positioniert.

Selektionsrand

Ein schmaler leerer Bereich zwischen dem Anzeigerand und den ersten Zeichen im Textfeld. Wenn Sie mit der Maus in diesen Rand klicken, wird die ganze Zeile neben dem Mauszeiger ausgewählt. Befindet sich der Mauszeiger im Selektionsrand, ändert er seine Form.

Horizontale und vertikale Bildlaufleisten

Die Bildlaufleisten ermöglichen das Rollen des Textfelds in horizontaler und vertikaler Richtung, um den Text sichtbar zu machen, der sich außerhalb des sichtbaren Bereichs befindet.

Statuszeile

Die Statuszeile zeigt die Zeile und Spalte, an der sich die Einfügemarke momentan befindet. Außerdem zeigt sie an, ob sich der Texteditor aktuell im Einfüge- oder Überschreiben-Modus befindet. Daneben befinden sich noch Anzeigen für die Feststelltaste und den Num-Lock-Modus.

Siehe auch

Arbeiten mit dem Texteditor

Benutzeroberfläche


Info-Dialogfenster

Das Info-Dialogfenster zeigt Informationen über Versionsnummer, Copyright und über den Registrierungszustand von PCAN-Explorer an. Um dieses Dialogfenster anzuzeigen, wählen Sie den Befehl Über PCAN-Explorer im Menü Hilfe.

Version

Dies ist die Versionsnummer des ausführbaren Hauptprogramms von PCAN-Explorer, PcanExpl.exe.

Produkt-Lizenzstatus

Zeigt den aktuellen Registrierungsstatus an. Mögliche Werte sind beispielsweise: Aktiviert, Registriert, Testversion, Abgelaufen, oder eine Fehlermeldung.

Lizenzinformation

Zeigt ein Dialogfenster mit Details an, die in der aktuell geladenen Lizenzdatei gespeichert sind.


Projekt-spezifische Elemente

Diese Elemente der Benutzeroberfläche werden im Umgang mit Projekten benötigt.

In diesem Abschnitt

Projekt-Manager

Bietet eine organisierte Ansicht des aktuell geladenen Projekts.

Projekteinstellungen-Dialogfenster

Ermöglicht die Konfiguration verschiedener Projekteinstellungen.

Neues Element hinzufügen-Dialogfenster

Ermöglicht das Hinzufügen von neuen Dateien zum Projekt.

Weitere Abschnitte

Benutzeroberfläche

Enthält Referenz-Themen für die verschiedenen Dialogfenster und anderer Fenster von PCAN-Explorer.


Projekt-Manager

Der Projekt-Manager bietet eine organisierte Ansicht des aktuell geladenen Projekts und seiner Dateien, sowie einen schnellen Zugriff auf die Befehle, die auf sie angewendet werden können. Eine Symbolleiste am oberen Rand des Fenster stellt häufig verwendete Befehle bereit.

Um den Projekt-Manager anzuzeigen, wählen Sie Projekt-Manager im Menü Ansicht.

Baumansicht

Diese standardmäßige Projekt-Manager-Ansicht repräsentiert das aktive Projekt als logischer Container für die Dateien und Elemente, die mit einem Projekt verknüpft sind. Sie können Projekt-Elemente zur Bearbeitung öffnen und andere Verwaltungsaufgaben direkt aus dieser Ansicht durchführen.

Registerseite Projekt-Dateien

Auf dieser Registerseite zeigt die Baumansicht alle Dateien, die das aktive Projekt enthält. Sie können virtuelle Ordner erzeugen, um die Dateien besser zu organisieren. Sie können Dateierweiterungen für einen virtuellen Ordner definieren, so dass neu erzeugte oder hinzugefügte Dateien automatisch in einen kompatiblen Ordner einsortiert werden. Physikalische Ordner können nicht zu einem Projekt hinzugefügt werden.

Registerseite Projekt-Elemente

Auf der Registerseite Projekt-Elemente zeigt die Baumansicht alle Elemente, die direkt in der Projektdatei gespeichert sind (z.B. Verbindungen), und andere Elemente, die durch Hinzufügen von Dateien zum Projekt entstanden sind (z.B. Symbole und Signale).

Symbole

Die nachfolgende Liste beschreibt die Symbole, die im Projekt-Manager angezeigt werden:

Symbol | Beschreibung
 | Der Hauptknoten des Projekts.
 | Der Verbindungen-Knoten.
 | Eine aktivierte Verbindung.
 | Eine deaktivierte Verbindung.
 | Eine ungültige Verbindung.
 | Eine aktivierte Verbindung, der ein aktivierter Botschaftsfilter zugewiesen ist.
 | Der Botschaftsfilter-Knoten.
 | Ein aktivierter Botschaftsfilter.
 | Ein deaktivierter Botschaftsfilter.
 | Der Makros-Knoten, eine VBS-Makroprozedur.
 | Eine VBS-Makrodatei
 | Ein Standardmakro.
 | Der Aktive Symbole-Knoten, ein Symbol.
 | Eine Symboldatei.
 | Eine Symboldatei, die von mindestens einer Verbindung verwendet wird.
 | Eine Symboldatei, die einen Fehler enthält.
 | Eine CANdb Netzwerk Datei.
 | Eine CANdb Netzwerk Datei, die von mindestens einer Verbindung verwendet wird.
 | Eine Instruments Panel-Datei.
 | Eine Plotter-Datei.
 | Ein Multiplexer.
 | Eine Variable.
 | Der Signale-Knoten, ein Signal.
 | Ein virtuelles Signal.

Befehle

Sie können Dateien öffnen, Elemente hinzufügen und entfernen, und andere Verwaltungsaufgaben durchführen. Durch die Verwendung des Kontextmenüs für eine Datei oder einem Projekt-Element können Sie verschiedene Befehle für die Dateien ausführen, abhängig vom Typ der Datei oder des Elements. Ein Doppelklick auf einer Datei öffnet die Datei zur Bearbeitung.

Die Aktion, die bei einem Doppelklick auf ein Element auf der Registerseite Projekt-Elemente ausgeführt wird, hängt vom Typ des Elements ab:

Element | Aktion
Verbindungen-Knoten | Klappt den Verbindungen-Knoten auf.
Verbindung | Zeigt das Verbindung ändern-Dialogfenster an.
Botschaftsfilter-Knoten | Klappt den Botschaftsfilter-Knoten auf.
Botschaftsfilter | Öffnet das Filter bearbeiten-Dialogfenster.
Makros-Knoten | Klappt den Makros-Knoten auf.
Standardmakro | Führt das Standardmakro aus.
VBS-Makrodatei | Klappt den VBS-Makrodatei-Knoten auf.
VBS-Makroprozedur | Führt die Makroprozedur aus.
Aktive Symbole | Klappt den Knoten "Aktive Symbole" auf.
Symboldatei, Symbol, Multiplexer | Klappt den Knoten auf.
Variable | Keine.
Signale-Knoten | Klappt den Signale-Knoten auf.
Signal | Keine.

Siehe auch

Benutzeroberfläche


Neues Element hinzufügen-Dialogfenster

Verwenden Sie dieses Dialogfenster, um in einem Schritt eine neue Datei zu erzeugen und diese dem Projekt hinzuzufügen.

Um den Projekt-Manager anzuzeigen, wählen Sie Projekt-Manager im Menü Ansicht.

Um das Neues Element hinzufügen-Dialogfenster anzuzeigen, wählen den Befehl Neues Element hinzufügen im Menü Projekt, oder klicken Sie auf die Schaltfläche Neu in der Symbolleiste des Projekt-Managers.

Das Neues Element hinzufügen-Dialogfenster hat die folgenden Felder:

Dateitypen

Enthält alle Dateitypen, die von PCAN-Explorer unterstützt werden, und die mit Hilfe dieses Dialogfensters erzeugt werden können.

Das eingerahmte Feld unter der Dateitypen-Liste zeigt eine kurze Beschreibung eines Dateityps an, wenn ein Dateityp in der Liste ausgewählt ist.

Name

Legt den Namen der neuen Datei fest.

Ort

Gibt den Ort an, an dem die Datei erzeugt wird. Standardmäßig wird der Pfad des aktuellen Projekts angezeigt. Mit Hilfe der Schaltfläche rechts neben dem Eingabefeld können Sie ein Dialogfenster öffnen, um einen Pfad auszuwählen.

Wird die Schaltfläche OK angeklickt, wird die neue Datei an dem gewählten Ort erzeugt. War das Erzeugen der Datei erfolgreich, wird der Projekt-Manager aktualisiert, um die neue Datei auf der Registerseite Projekt-Dateien anzuzeigen.

Siehe auch

Projekt-Manager

Benutzeroberfläche


Projekteinstellungen-Dialogfenster

Verwenden Sie dieses Dialogfenster, um Projekteinstellungen anzupassen.

Um dieses Dialogfenster zu öffnen, wählen Sie den Befehl Einstellungen im Menü Projekt oder im Kontextmenü des Projekts im Projekt-Manager.

Das Projekteinstellungen-Dialogfenster ist in zwei Bereiche aufgeteilt: eine Kategorienliste auf der linken Seite und ein Bereich zur Anzeige verschiedener Seiten auf der rechten Seite. Auf den einzelnen Seiten sind die Optionen nach ihrer Funktionalität gruppiert. Wenn in der Kategorienliste eine Seite angeklickt wird, erscheint deren Inhalt im Seitenanzeigebereich.

Um die Hilfe für eine bestimmte Seite anzuzeigen, zeigen Sie die entsprechende Seite an und drücken entweder die Taste [F1], oder klicken Sie auf die Schaltfläche Hilfe.

Das Projekteinstellungen-Dialogfenster kann die folgenden Seiten anzeigen:

Seite | Beschreibung
Allgemein | Allgemeine Projekteinstellungen.
CAN | Einstellungen bezüglich des CAN-Protokolls, z.B. Remote Transmission Requests.
J1939 | Einstellungen bezüglich des J1939-Protokolls.
J1939 Auto-Werte | Einstellungen bezüglich automatischer Signalwertberechnung für J1939-Sendebotschaften.
Verbindungen | Enthält keine Optionen, dient als Container für die Verbindungen des Projekts.
Verbindung | Einstellungen bezüglich der Verbindungen des Projekts.
Tracer | Enthält keine Optionen, dient als Container für die Tracer des Projekts.
Tracer | Einstellungen bezüglich der Tracer im Projekt.
Timing | Einstellungen bezüglich der Aufzeichnung von Timing-Fehlern.

Siehe auch

Benutzeroberfläche


Allgemein, Projekteinstellungen-Dialogfenster

Verwenden Sie die Seite Allgemein des Projekteinstellungen-Dialogfensters, um allgemeine Projekteinstellungen anzupassen.

Um dieses Dialogfenster anzuzeigen, wählen Sie im Menü Projekt den Befehl Einstellungen und dann die Seite Allgemein.

Name

Benennt das Projekt.

Beschreibungen

Verwenden Sie dieses Feld, um eine kurze Beschreibung zum Projekt einzugeben.

Nach dem Laden des Projekts folgenden Befehl ausführen

Dieser Befehl wird ausgeführt, nachdem das Projekt geladen wurde.

Beispiel

Wenn Sie ein Fenster Ihres Projekt-Desktops im Vollbild-Modus anzeigen möchten, nachdem das Projekt geöffnet wurde, geben Sie den Befehl ToggleFullScreen in das Feld ein. Nachdem Sie das Dialogfenster geschlossen haben, bringen Sie das Fenster in den Vordergrund, das Sie im Vollbild-Modus anzeigen möchten. Dann speichern und schließen Sie das Projekt, oder Beenden Sie PCAN-Explorer. Wenn Sie das nächste Mal das Projekt öffnen, wird das zuvor ausgewählte Fenster im Vollbild-Modus angezeigt. Sie können den Vollbild-Modus beenden, indem Sie die Taste [F11] drücken.

Siehe auch

Projekteinstellungen-Dialogfenster


CAN, Projekteinstellungen-Dialogfenster

Verwenden Sie die Seite CAN im Projekteinstellungen-Dialogfenster, um allgemeine Einstellungen von Verbindungen des Projekts anzupassen, die das CAN-Protokoll verwenden. Um dieses Dialogfenster anzuzeigen, wählen Sie im Menü Projekt den Befehl Einstellungen und dann die Seite CAN.

Remote Transmission Requests

Remote Transmission Requests (RTR) werden von CAN-Knoten zur Anforderung von bestimmten Daten gesendet, die üblicherweise ein anderer Busteilnehmer zur Verfügung stellt.

Remote Request Frames verarbeiten

Ist diese Option aktiviert, verarbeitet PCAN-Explorer eintreffende Remote Request Frames, und sendet gegebenenfalls eine oder mehrere Botschaften als Antwort, falls die Sendeliste im Senden/Empfangen-Fenster passende Botschaften enthält.

Data Length Code ignorieren

Ist diese Option aktiviert, wird der Data Length Code des empfangenen Remote Request Frames nicht berücksichtigt, während in der Standard-Sendeliste nach passenden Botschaften gesucht wird, die als Antwort auf den RTR gesendet werden können. Somit werden alle CAN-Botschaften als Antwort gesendet, deren CAN-ID mit der des Remote Request Frames übereinstimmen.

Ist die Option deaktiviert, werden nur die Botschaften der Standard-Sendeliste als Antwort gesendet, welche die gleiche CAN-ID und den gleichen Data Length Code haben wie der empfangene Remote Request Frame.

Fehlerwarnungen

Fehlerwarnungen entstehen, wenn infolge von mehrfachen Busfehlern ein Fehlerzähler des CAN-Controllers bestimmte Werte überschreitet.

Bei Bus-Off automatisch Reset durchführen

Falls nach dem Eintreten eines Bus-Off-Fehlerzustandes Probleme bestehen, dass die Sende- und/oder Empfangstätigkeit nicht wieder aufgenommen wird, kann durch Aktivieren dieser Option automatisch dar Befehl Reset ausgeführt werden, wodurch ein Hardware-Reset des CAN-Controllers ausgelöst wird. Dies kann helfen, das Problem zu beseitigen, jedoch können CAN-Botschaften verlorengehen, während sich der CAN-Controller im Reset-Zustand befindet.

Siehe auch

Reset-Befehl

Remote Transmission Request

Anzeigen von Error Frames

Hardware-Status

Projekteinstellungen-Dialogfenster

Standard-Sendeliste


J1939, Projekteinstellungen-Dialogfenster

Verwenden Sie die Seite J1939 des Projekteinstellungen-Dialogfensters, um Einstellungen für Verbindungen anzupassen, die das J1939-Protokoll verwenden. Die Einstellungen auf dieser Seite gelten für alle J1939-Verbindungen des Projekts.

Um dieses Dialogfenster anzuzeigen, wählen Sie im Menü Projekt den Befehl Einstellungen und dann die Seite J1939. Die Seite ist nur verfügbar, wenn das J1939 Add-in geladen ist und das Projekt mindestens eine J1939-Verbindung enthält.

Einstellungen

Anforderungen bearbeiten (RQST)

Ist diese Option aktiviert, versucht PCAN-Explorer empfangene RQST-Botschaften (PGN 59904) zu beantworten. Dabei werden passende Nachrichten sowohl in der Sendeliste des Senden/Empfangen-Fensters als auch in anderen geöffneten Sendelisten gesucht.

Transportprotokoll Lese-Sessions

Diese Einstellungen haben eine Wirkung, falls eine J1939-Verbindung während einer Datenübertragung als Beantworter (Responder) fungiert.

CTS: Anzahl der akzeptierten Pakete

Dies ist die maximale Anzahl Datenpakete für große Botschaften, die zum Senden freigegeben werden. Die tatsächliche Anzahl von zum Senden freigegebener Pakete in einer TPCM.CTS Botschaft wird niemals größer als die angeforderte Anzahl von Paketen von einer empfangenen TPCM.RTS Botschaft.

Anzahl Re-CTS

Setzt die maximale Anzahl Re-CTS während einer Lese-Session.

Nachdem der Beantworter ein CTS gesendet hat, und innerhalb des Timeouts von 1250 ms keine Datenpakete (TPDT) vom Absender empfangen werden, sendet der Beantworter erneut ein CTS. Wenn die Anzahl dieser neu gesendeten CTS die hier definierte maximale Anzahl Re-CTS erreicht, wird der Beantworter beim nächsten Timeout die Session abbrechen, indem er ein TPCM.ConnAbort sendet.

Transportprotokoll Schreib-Sessions

Diese Einstellungen haben eine Wirkung, falls eine J1939-Verbindung während einer Datenübertragung als Absender (Originator) fungiert.

RTS: Maximale Anzahl Pakete

Begrenzt die Anzahl der angeforderten Pakete, die vom Absender als Antwort auf ein empfangenes CTS gesendet werden können. Falls der Beantworter diese Grenze akzeptiert, stellt er dadurch sicher, dass der Absender die Pakete neu senden kann, die der Beantworter aus irgendwelchen Gründen nicht korrekt empfangen hat.

Anzahl Neuversuche

Setzt die maximale Anzahl RTS-Neuversuche während einer Schreib-Session.

Nachdem der Absender die Anzahl Datenpakte gesendet hat, die vom letzten empfangenen CTS zum Senden freigegeben waren, sendet der Absender erneut ein RTS, um die nächste Datenübertragung anzufordern. Wenn der Beantworter nicht innerhalb einer Zeit von 1250 ms mit einem CTS antwortet, sendet der Absender erneut ein RTS. Wenn die Anzahl dieser neu gesendeten RTS die hier definierte Anzahl Neuversuche erreicht, wird der Absender beim nächsten Timeout die Session abbrechen, indem er ein TPCM.ConnAbort sendet.

Siehe auch

Projekteinstellungen-Dialogfenster

J1939 Auto-Werte, Projekteinstellungen-Dialogfenster

J1939, Optionen-Dialogfenster


J1939 Auto-Werte, Projekteinstellungen-Dialogfenster

Verwenden Sie die Seite J1939 Auto-Werte des Projekteinstellungen-Dialogfensters, um Einstellungen für Sendebotschaften anzupassen, die das J1939-Protokoll verwenden. Die Einstellungen auf dieser Seite gelten für alle J1939-Sendebotschaften des Projekts.

Um dieses Dialogfenster anzuzeigen, wählen Sie im Menü Projekt den Befehl Einstellungen und dann die Seite J1939 Auto-Werte unterhalb des Knotens J1939. Die Seite ist nur verfügbar, wenn das J1939 Add-in geladen ist und das Projekt mindestens eine J1939-Verbindung enthält.

Beim Senden die Werte dieser J1939-Signale automatisch berechnen

Hier können Sie für verschiedene J1939-Signale (SPNs) auswählen, ob deren Werte beim Senden einer J1939-Botschaft, welche die Signale enthalten, automatisch berechnet werden.

Empfänger von bestimmten J1939-Botschaften wie z.B. TSC1 (Torque/Speed Control 1, PGN 0) können die Datenintegrität der Botschaft überprüfen, indem sie den rollenden Zähler sowie die Prüfsumme der Botschaft auswerten.

Die automatische Signalwertberechnung ist mit den SPNs verknüpft und findet nur dann statt, wenn einer Sendebotschaft ein Symbol vom Typ J1939PG zugewiesen ist, welches Signale mit den passenden SPNs enthält.

Ein Klick auf die Schaltfläche [image] rechts oberhalb der Liste öffnet ein Menü, mit dessen Hilfe Sie verschiedene Optionen für die Liste anpassen können, z.B. die Sortierung der Liste.

Siehe auch

Projekteinstellungen-Dialogfenster

J1939, Projekteinstellungen-Dialogfenster

J1939 Auto-Werte, Optionen-Dialogfenster


Verbindung, Projekteinstellungen-Dialogfenster

Verwenden Sie die Seite Verbindung im Projekteinstellungen-Dialogfenster, um allgemeine Einstellungen für jede Verbindung im Projekt anzupassen.

Sie können dieses Dialogfenster anzuzeigen, indem Sie im Menü Projekt den Befehl Einstellungen wählen, und dann die entsprechende Verbindung unterhalb des Knotens Verbindungen auswählen.

Einstellungen

Aktiviert

Diese Option aktiviert die Verbindung.

Name

Benennt die Verbindung.

Protokoll

Wählt das Protokoll aus, das von der Verbindung verwendet wird.

CAN

Diese Einstellungen sind verfügbar, wenn in der Dropdownliste Protokoll das CAN-Protokoll ausgewählt wurde.

Listen-Only-Modus

Diese Option aktiviert den Listen-Only-Modus des CAN-Controllers. Im Listen-Only-Modus gibt der CAN-Controller kein Acknowledge auf dem CAN-Bus, auch wenn eine CAN-Botschaft erfolgreich empfangen wurde. Der CAN-Controller wird gezwungen, "Error Passive" zu bleiben. Senden von Botschaften ist nicht möglich. Der Listen-Only-Modus kann z.B. für Überwachungsaufgaben verwendet werden, oder um eine softwaregesteuerte Bitratenerkennung durchzuführen.

Diese Option ist nur verfügbar, wenn die Verbindung mit einer CAN-Hardware verknüpft ist, die den Listen-Only-Modus unterstützt.

Error Frames

Diese Option aktiviert den Empfang von Error Frames für die Verbindung.

Bestimme Zeitstempel bei Start-of-Frame

Wenn aktiviert, wird der Zeitstempel einer CAN-Nachricht bei Start-of-Frame bestimmt anstatt bei End-of-Frame.

Benötigt mindestens PCAN-Treiber Version 4.3.0, und das verwendete CAN-Interface bzw. dessen Firmware-Version muss die Funktion unterstützen.

Tx Self-Acknowledge

Wenn aktiviert, sendet der CAN-Controller auch als Sender einen Acknowledge Slot (ACK) auf den Bus, sodass keine anderen CAN-Knoten am Bus vorhanden sein müssen, um den Frame zu quittieren.

Benötigt mindestens PCAN-Treiber Version 4.3.0, und das verwendete CAN-Interface bzw. dessen Firmware-Version muss die Funktion unterstützen.

Ignoriere BRS

Wenn aktiviert, ignoriert der CAN-Controller empfangene CAN-FD-Frames, bei denen das BRS-Bit gesetzt ist (Bit Rate Switch).

Benötigt mindestens PCAN-Treiber Version 4.3.0, und das verwendete CAN-Interface bzw. dessen Firmware-Version muss die Funktion unterstützen.

Siehe auch

Projekteinstellungen-Dialogfenster


Tracer, Projekteinstellungen-Dialogfenster

Sie können dieses Dialogfenster anzuzeigen, indem Sie im Menü Projekt den Befehl Einstellungen wählen, und dann den entsprechenden Tracer unterhalb des Knotens Tracer auswählen.

Filter

Wählt den Botschaftsfilter für den Tracer aus.

Puffertyp

Bestimmt, wie der Puffer mit Daten gefüllt wird.

  • Datei: Die Daten werden während der Aufzeichnung direkt in eine Trace-Datei geschrieben.

  • Dynamisch: Die Größe des Puffers wächst ständig, während Botschaften aufgezeichnet werden.

  • Linear: Der Puffer hat eine feste Größe. Wenn der Puffer komplett gefüllt ist, wird die Aufzeichnung angehalten und im Ausgabe-Fenster wird eine Meldung angezeigt.

  • Ring: Der Puffer hat eine feste Größe. Wenn der Puffer komplett gefüllt ist, wird die älteste Botschaft im Puffer überschrieben wenn eine neue Botschaft aufgezeichnet wird.

Puffergröße

Setzt die feste Größe des Datenpuffers (Anzahl von CAN-Botschaften) für die Puffertypen Linear und Ring. Die maximale Größe beträgt 999.999.999 Botschaften. Während Sie einen Wert in das Feld eingeben, wird der benötigte Arbeitsspeicher berechnet und neben dem Eingabefeld angezeigt.

Zeitstempel

Bestimmt das Format der im Trace-Fenster angezeigten Zeitstempel.

  • Relativ: Der angezeigte Wert gibt die Zeitdauer seit Aufzeichnungsbeginn in Sekunden an.

  • Absolut: Der Zeitstempel wird als absolute Uhrzeit angezeigt.

  • Differenziell: Der angezeigte Wert gibt die Zeitdauer seit Aufzeichnung der letzten Botschaft in Sekunden an.

Erster Eintrag setzt Startzeit

Ist die Option aktiviert, bestimmt der Zeitstempel der ersten aufgezeichneten Botschaft die Startzeit des Tracers. Der Zeit-Offset des ersten Eintrags wird hierbei zu 0.

Ist die Option nicht aktiviert, ist die Startzeit des Tracers der Zeitpunkt, zu dem der Tracer wirklich gestartet wurde, z.B. wenn die Schaltfläche Start im Trace-Fenster betätigt wurde.

Wiedergabe wiederholen

Ist die Option aktiviert, beginnt das Abspielen der Trace-Datei am Ende wieder von vorne.

Anzahl Wiederholungen

Ist die Option aktiviert, kann die Anzahl der Wiederholungen vorgegeben werden. Nach der letzten Wiederholung stoppt die Wiedergabe.

Pause vor Wiederholung

Ist die Option aktiviert, wartet der Tracer nach der Wiedergabe der letzten Botschaft im Puffer die angegebene Wartezeit, bevor die Wiedergabe erneut von vorne beginnt.

Siehe auch

Projekteinstellungen-Dialogfenster


Timing, Projekteinstellungen-Dialogfenster

Verwenden Sie die Seite Timing des Projekteinstellungen-Dialogfensters, um Einstellungen bezüglich der Aufzeichnung von Timeing-Fehlern anzupassen. Um dieses Dialogfenster anzuzeigen, wählen Sie im Menü Projekt den Befehl Einstellungen und dann die Seite Timing.

Timing-Fehler aufzeichnen

Ist diese Option aktiviert, prüft PCAN-Explorer beim Empfang einer symbolischen Botschaft auf einen möglichen Timing-Fehler. Damit Timing-Fehler erkannt werden können, müssen für Symbole bzw. Multiplexer Timeouts und/oder Minimum-Intervalle definiert werden.

Timing-Fehler in Datei aufzeichnen

Wenn diese Option aktiviert ist, speichert PCAN-Explorer die aufgetretenen Timing-Fehler in der angegebenen Logdatei. Um eine Datei auszuwählen, können Sie über die Schaltfläche neben dem Eingabefeld ein Dialogfenster zur Auswahl einer Datei anzeigen.

Permanent auf Timeouts überprüfen

Wenn diese Option aktiviert ist, prüft PCAN-Explorer nicht nur beim Empfang einer symbolischen Botschaft auf einen möglichen Timeout für dieses Symbol, sondern überprüft ständig alle Symbole und Multiplexer in der Empfangsliste auf Timeouts.

Siehe auch

Timing

Projekteinstellungen-Dialogfenster


CAN-spezifische Elemente

Dieser Abschnitt enthält Informationen über alle Dialogfenster und sonstige Elemente, die direkt mit dem Thema CAN und CAN-Botschaften in Verbindung stehen.

In diesem Abschnitt

Verbindung hinzufügen-Dialogfenster

Stellt eine Verbindung mit einem PCAN-Netz her, das zur Kommunikation mit einem externen CAN-Bus dient.

Verbindung ändern-Dialogfenster

Wählt für eine bestehende Verbindung ein anderes PCAN-Netz aus.

Botschaft bearbeiten-Dialogfenster

Ermöglicht das Eingeben und Bearbeiten der Parameter einer CAN- oder J1939-Botschaft, die manuell auf einem CAN-Bus gesendet werden soll.

Daten bearbeiten-Dialogfenster

Ermöglicht das Verändern von Datenbytes einer Botschaft mit Hilfe eines Hex-Editors.

Filter bearbeiten-Dialogfenster

Ermöglicht die Definition von Filterelementen für Botschaftsfilter. Botschaftsfilter können verwendet werden, um die CAN-Botschaften zu filtern, die in der Empfangsliste angezeigt oder von Tracer-Modulen aufgezeichnet werden sollen.

Sendelisten-Fenster

Enthält eine Reihe von CAN-Botschaften, die von PCAN-Explorer gesendet werden.

Timing-Fehler-Fenster

Ermöglicht die Überwachung des zyklischen Empfangs von CAN-Botschaften innerhalb vorgegebener Zeitspannen.

Daten exportieren-Dialogfenster

Ermöglicht das Exportieren von CAN-Botschaften in verschiedene Dateiformate.

Weitere Abschnitte

Benutzeroberfläche

Enthält Referenzthemen für die verschiedenen Dialogfenster und weiterer Fenster von PCAN-Explorer.


Verbindung hinzufügen-Dialogfenster

Verwenden Sie das Verbindung hinzufügen-Dialogfenster um eine neue Verbindung zum aktuellen Projekt hinzuzufügen.

Um das Dialogfenster anzuzeigen, wählen Sie im Menü Verbindungen den Befehl Verbindung hinzufügen.

Über die Registerkarten am oberen Rand des Dialogfensters können Sie den Gerätetyp auswählen, für den Sie eine Verbindung hinzufügen möchten. Abhängig von den installierten PCAN-Gerätetreibern können die Registerkarten Peakcan, Virtuell, ISA, Dongle, PCI, USB, PC Card oder LAN angezeigt werden.

Peakcan (nur verfügbar auf 32-Bit Betriebssystemen)

Dieser Gerätetyp kann ausgewählt werden, wenn eine Verbindung mit einer Non-Plug-and-Play Hardware, beispielsweise einer PCAN-ISA-Karte oder einem PCAN-Dongle (für den Parallel-Port) hergestellt werden soll.

Virtuell

Dieser Gerätetyp unterstützt keine Hardware, nur interne Netze.

ISA

Falls vorhanden, kann dieser Gerätetyp ausgewählt werden, wenn eine Verbindung mit einer PCAN-ISA-Karte hergestellt werden soll.

Dongle

Falls vorhanden, kann dieser Gerätetyp ausgewählt werden, wenn eine Verbindung mit einem PCAN-Dongle (für den Parallel-Port) hergestellt werden soll.

PCI

Wenn eine PCI- oder PCI-Express-Karte verwendet werden soll, muss dieser Gerätetyp ausgewählt werden.

USB

Wenn ein PCAN-Adapter mit USB-Anschluss verwendet werden soll, muss dieser Gerätetyp ausgewählt werden.

PC Card

Wenn ein PCAN-PC Card-Adapter verwendet werden soll, muss dieser Gerätetyp ausgewählt werden.

LAN

Wenn ein PCAN-Gateway über eine Netzwerkverbindung (Ethernet, WLAN) verwendet werden soll, muss dieser Gerätetyp ausgewählt werden.

Verfügbare Netze

Hier werden alle PCAN-Netze angezeigt, die für den ausgewählten Gerätetyp konfiguriert worden sind. Sollte die Liste leer sein, muss erst mit Hilfe der Schaltfläche Netze bearbeiten ein Netz eingerichtet werden.

Name

Geben Sie den Namen der neuen Verbindung in diesem Feld ein.

Hinweis

Ein Projekt kann keine zwei Verbindungen mit dem selben Namen enthalten. Wenn der Name, den Sie in das Name-Feld eingeben, bereits von einer anderen Verbindung belegt ist, wird eine Zahl an den Namen angehängt, um einen eindeutigen Namen für die Verbindung zu erzeugen.

Protokoll

Wählt das Protokoll aus, das von der neuen Verbindung verwendet werden soll.

Hinweis

Falls das J1939 Add-in nicht installiert ist, ist nur das CAN-Protokoll in der Dropdownliste verfügbar.

Verbindung Aktivieren

Wird diese Option ausgewählt, wird die neue Verbindung direkt nach dem Schließen des Dialogfensters aktiviert.

Bevorzugte Adresse

Gibt die bevorzugte J1939-Adresse der neuen Verbindung an. Nur verfügbar, falls im Feld Protokoll das J1939 ausgewählt ist. Der Wert der J1939-Adresse muss im Bereich 0 bis 253 liegen.

Netze bearbeiten

Startet das Hilfsprogramm PCAN Nets Configuration, mit dem PCAN-Netze für die installierten PCAN-Geräte erstellt und bearbeitet werden können.

Aktualisiert die Liste der verfügbaren Netze.

Siehe auch

Konfiguration von PCAN-Netzen

Verbindung ändern-Dialogfenster

Referenz Benutzeroberfläche


Verbindung ändern-Dialogfenster

Verwenden Sie das Verbindung ändern-Dialogfenster, um für eine bestehende Verbindung ein anderes PCAN-Netz auszuwählen.

Um das Dialogfenster anzuzeigen, selektieren Sie im Verbindungen-Fenster eine Verbindung, und wählen Sie im Kontextmenü der Verbindung (rechte Mauste) den Befehl Ändern.

Über die Registerkarten am oberen Rand des Dialogfensters können Sie den Gerätetyp auswählen, von dem Sie ein PCAN-Netz auswählen möchten. Abhängig von den installierten PCAN-Gerätetreibern können die Registerkarten Peakcan, Virtuell, ISA, Dongle, PCI, USB, PC Card oder LAN angezeigt werden.

Peakcan (nur verfügbar auf 32-Bit Betriebssystemen)

Dieser Gerätetyp kann ausgewählt werden, wenn eine Verbindung mit einer Non-Plug-and-Play Hardware, beispielsweise einer PCAN-ISA-Karte oder einem PCAN-Dongle (für den Parallel-Port) hergestellt werden soll.

Virtuell

Dieser Gerätetyp unterstützt keine Hardware, nur interne Netze.

ISA (nur verfügbar auf 32-Bit Betriebssystemen)

Falls vorhanden, kann dieser Gerätetyp ausgewählt werden, wenn eine Verbindung mit einer PCAN-ISA-Karte hergestellt werden soll.

Dongle (nur verfügbar auf 32-Bit Betriebssystemen)

Falls vorhanden, kann dieser Gerätetyp ausgewählt werden, wenn eine Verbindung mit einem PCAN-Dongle (für den Parallel-Port) hergestellt werden soll.

PCI

Wenn eine PCI- oder PCI-Express-Karte verwendet werden soll, muss dieser Gerätetyp ausgewählt werden.

USB

Wenn ein PCAN-Adapter mit USB-Anschluss verwendet werden soll, muss dieser Gerätetyp ausgewählt werden.

PC Card

Wenn ein PCAN-PC Card-Adapter verwendet werden soll, muss dieser Gerätetyp ausgewählt werden.

LAN

Wenn ein PCAN-Gateway über eine Netzwerkverbindung (Ethernet, WLAN) verwendet werden soll, muss dieser Gerätetyp ausgewählt werden.

Verfügbare Netze

Hier werden alle PCAN-Netze angezeigt, die für den ausgewählten Gerätetyp konfiguriert worden sind. Sollte die Liste leer sein, muss erst mit Hilfe der Schaltfläche Netze bearbeiten ein Netz eingerichtet werden.

Netze bearbeiten

Startet das Hilfsprogramm PCAN Nets Configuration, mit dem PCAN-Netze für die installierten PCAN-Geräte erstellt und bearbeitet werden können.

Aktualisiert die Liste der verfügbaren Netze.

Siehe auch

Konfiguration von PCAN-Netzen

Verbindung hinzufügen-Dialogfenster

Referenz Benutzeroberfläche


Botschaft bearbeiten-Dialogfenster

Das Botschaft bearbeiten-Dialogfenster ermöglicht das Eingeben und Bearbeiten der Parameter einer CAN- oder J1939-Botschaft.

Um das Dialogfenster anzuzeigen, muss im Menü Senden der Befehl Neue Botschaft oder Botschaft bearbeiten ausgewählt werden.

Das Dialogfenster enthält folgende Felder:

Bus

Legt den Bus bzw. die Verbindung fest, auf welcher die Botschaft gesendet wird. Die Dropdownliste enthält alle Verbindungen des aktuellen Projekts.

Öffnet das Dialogfenster Verbindung hinzufügen, um direkt eine neue Verbindung hinzuzufügen, ohne dieses Dialogfenster zu verlassen.

Strg+F

Sucht in der Liste der Symbole.

Symbole

Diese Liste zeigt alle Symbole, die für den ausgewählten Bus gerade geladen sind, und die zum Senden ausgewählt werden können. Symbole, die als reine Empfangssymbole definiert wurden, werden hier nicht aufgeführt. Wenn der Eintrag <Benutzerdefinierte Botschaft> ausgewählt wird, kann jede beliebige CAN-Botschaft erzeugt werden. Der Eintrag <Benutzerdefnierte Botschaft> ist nicht verfügbar, wenn eine symbolische Botschaft bearbeitet wird.

Ein Klick auf die Schaltfläche [image] öffnet ein Menü, mit dessen Hilfe Sie weitere Anzeigeoptionen für die Symbolliste anpassen können. Durch Auswahl der Option Sortiert kann die Symbolliste alphabetisch sortiert werden. Andernfalls erscheinen die Symbole in der Liste in der Reihenfolge, in der sie in der Symboldatei definiert wurden.

Für J1939-Verbindungen kann die Symbolliste auch so konfiguriert werden, dass sie Akronyme, lange Namen, dezimale PGNs oder hexadezimale PGNs anzeigt.

Multiplexer

Diese Liste zeigt alle Multiplexer, die für das ausgewählte Symbol definiert wurden. Falls ein Symbol keine Multiplexer enthält, wird der Eintrag <Empty> angezeigt. Wenn ein Multiplexer ausgewählt wird, werden seine Daten automatisch in die Felder Daten eingetragen. Diese Felder werden dann für das Bearbeiten gesperrt. Sollen andere Werte in den Feldern Daten gesendet werden, die der Multiplexer belegt, ist der Eintrag <Andere> zu wählen.

Diese Liste ist nur aktiviert, wenn eine Symboldatei für den ausgewählten Bus geladen ist.

ID

Die CAN-ID der Botschaft (hexadezimal). Falls ein Symbol in der Liste Symbole ausgewählt ist, kann dieses Feld nicht editiert werden, da die CAN-ID dann vom ausgewählten Symbol bestimmt wird.

Länge

Die Anzahl der Datenbytes der Botschaft. Falls die Botschaft ein Daten-Frame ist, bestimmt dieser Wert die Anzahl der Datenbytes (0-8 für CAN-Botschaften, 0-64 für CAN-FD-Botschaften, 0-1785 für J1939-Botschaften). Ist die Botschaft ein Remote Request Frame, dann entspricht dieser Wert der Länge des anzufordernden Daten-Frames. Wurde in der Liste Multiplexer ein Multiplexer ausgewählt, kann dieses Feld eventuell nicht editiert werden, wenn die Länge von der Definition des ausgewählten Multiplexers bestimmt wird.

Daten

Die Datenbytes der Botschaft in hexadezimaler Form. Wurde in der Liste Multiplexer ein Multiplexer ausgewählt, erscheint hier in den entsprechenden Positionen der für ihn definierte Wert. Belegt ein Multiplexer alle Bits eines Datenbytes, ist dieses Feld für die Bearbeitung gesperrt. Belegt ein Multiplexer nur einen Teil eines Datebytes, kann das Feld editiert werden, beim Verlassen des Feldes werden jedoch die vom Multiplexer belegten Bits mit den Daten des Multiplexers überschrieben.

Wird die Schaltfläche ... hinter den Datenbyte-Feldern gedrückt, wird das Dialogfenster Daten bearbeiten angezeigt, in dem man die Datenbytes der Botschaft mit Hilfe eines Hex-Editors bearbeiten kann. Dies ist speziell dann nützlich, wenn man mit großen J1939-Botschaften arbeitet, die bis zu 1785 Datenbytes besitzen können.

Zykluszeit

Das Zeitintervall in Millisekunden, in dem die Botschaft gesendet werden soll. Soll die Botschaft nicht periodisch gesendet werden, muss der Wert 0 eingegeben werden.

Angehalten

Ist diese Option aktiviert, wird eine periodisch zu sendende Botschaft angehalten. Das Senden kann später fortgesetzt werden.

Hinweis

Dieses Feld kann nicht verändert werden, falls der Listen-Only-Modus des CAN-Controllers aktiviert ist. Der Angehalten-Zustand ist dann immer gesetzt.

Kommentar

Kommentiert die Sendebotschaft. Um Kommentare in der Sendeliste anzuzeigen, blenden Sie die entsprechende Spalte mit Hilfe des Dialogfensters Spalten auswählen ein.

Spezielle Felder für CAN-Botschaften

Botschafts-Typ

Extended Frame

Ist dieses Markierungsfeld aktiviert, wird die Botschaft als Extended Frame nach der CAN-Spezifikation 2.0B gesendet. Das Feld ist nur verfügbar, falls die angeschlossene Hardware das CAN 2.0B Protokoll unterstützt.

Remote Request

Soll ein Remote Request Frame gesendet werden, dann ist dieses Markierungsfeld zu aktivieren. In diesem Fall werden die Eingabefelder für die Datenbytes entfernt.

Single Shot

Erzeugt eine CAN-Botschaft, die mit der Option Single Shot Transmission gesendet wird. Siehe NXP Application Note AN97076 "SJA1000 Stand-alone CAN controller", Abschnitt 5.4.

CAN FD

Definiert die Botschaft als CAN-FD-Botschaft. Eine CAN-FD-Botschaft kann bis zu 64 Datenbytes übertragen.

Bit Rate Switch

Setzt für eine CAN-FD-Botschaft das Flag Bit Rate Switch. Die Datenfelder eines CAN-FD-Frames werden mit einer höheren Bitrate übertragen, wenn Bit Rate Switch aktiviert ist.

Error State Indicator

Setzt für eine CAN-FD-Botschaft das Flag Error State Indicator. Der Error State Indicator gibt an, ob sich der Absender der Botschaft im Zustand Error Active oder Error Passive befindet.

Spezielle Felder für J1939-Botschaften

PGN

Legt die Parameter Group Number der J1939-Botschaft fest. Der PGN-Wert kann nur verändert werden, wenn man eine neue J1939-Botschaft anlegt und in der Liste Symbole der Eintrag <Benutzerdefinierte Botschaft> ausgewählt ist.

Falls ein hier eingegebener PGN-Wert rot erscheint, ist der Wert keine gültige PGN. Beachten Sie, dass für Botschaften im PDU1-Format das untere Byte der PGN den Wert 0 haben muss, da in dem Fall dieses Byte keinen Speicherplatz innerhalb der CAN-ID besitzt. Dort ist dieses Byte dann mit der Zieladresse belegt. Weitere Informationen finden Sie der J1939-Spezifikation im Basisdokument, Kapitel 4.1.2 Message Format and Usage.

Priorität

Legt die Priorität (0-7) der J1939-Botschaft fest. 0 ist die höchste Priorität, 7 die Niedrigste. Die Priorität ist ein 3-Bit Feld, das Teil der CAN-ID ist (Bits 26-28).

Quelle

Setzt die Quelladresse der J1939-Botschaft.

Falls die Botschaft maximal 8 Datenbytes hat, ist jeder Wert zwischen 0 und 253 erlaubt, oder die Null-Adresse (254).

Falls die Botschaft eine große Botschaft mit mehr als 8 Datenbytes ist, muss die Quelladresse identisch mit der Adresse sein, die für die zugehörige Verbindung angefordert wurde. Der Versuch, eine große Botschaft zu senden, die eine von der angeforderten Adresse abweichende Quelladresse besitzt, wird einen Fehler "Falscher Parameterwert" verursachen. Der Versuch, eine große Botschaft zu senden, wenn für die zugehörige Verbindung noch keine Adresse angefordert wurde, wird einen Fehler "Adresse nicht angefordert" verursachen. Weiterhin ist die Null-Adresse als Quelladresse für große Botschaften nicht zulässig.

Die Quelladresse ist Teil der CAN-ID (Bits 0-7).

Ziel

Setzt die Zieladresse der J1939-Botschaft.

Besitzt die ausgewählte PGN das PDU1-Format, ist jeder Wert zwischen 0 und 253 erlaubt, oder die Globale Adresse (255). Die Zieladresse muss sich von der Quelladresse unterscheiden.

Besitzt die ausgewählte PGN das PDU2-Format, und hat die Botschaft maximal 8 Datenbytes, kann keine Zieladresse eingegeben werden. Diese Botschaften werden immer als Broadcast gesendet. Falls die PDU2 PGN aber über das Transport-Protokoll gesendet werden darf, und die Datenlänge auf einen Wert größer als 8 eingestellt wird, kann eine Zieladresse ausgewählt werden. Gültige Zieladressen sind 0 bis 253, oder die Globale Adresse (255).

Bei Botschaften im PDU1-Format ist die Zieladresse Teil der CAN-ID (Bits 8-15).

Hexadezimale Werte

Ist diese Option aktiviert, werden Werte in den Feldern PGN, Quelle und Ziel im hexadezimalen Format angezeigt.

Siehe auch

Arbeiten mit Sendelisten

Senden von CAN-Botschaften

Daten bearbeiten-Dialogfenster


Daten bearbeiten-Dialogfenster

Verwenden Sie das Daten bearbeiten-Dialogfenster, um die Rohdaten einer Botschaft zu verändern.

Um das Daten bearbeiten-Dialogfenster anzuzeigen, klicken Sie auf die Schaltfläche ... hinter den Datenbyte-Eingabefeldern im Botschaft bearbeiten-Dialogfenster.

Lädt Daten aus einer Datei.

Speichert die Daten in eine Datei.

Setzt alle Datenbytes zu Null.

(Hex-Editor)

Im Hex-Editor können Sie die Datenbytes einer Botschaft verändern indem Sie Hex-Werte oder Zeichen eingeben. Durch Drücken von [Tab] auf der Tastatur können Sie die Einfügemarke zwischen dem Bereich für die Hex-Daten links und der ASCII-Interpretation der Daten auf der rechten Seite bewegen. Dort können Sie Zeichen anstatt von Hex-Codes eingeben. Wenn der Hex-Editor den Eingabefokus besitzt, können Sie [Strg+Tab] oder [Umsch+Strg+Tab] drücken, um den Eingabefokus zu einem anderen Steuerelement des Dialogfensters zu bewegen.

Der Hex-Editor kann mit Hilfe seines Kontextmenüs angepasst werden. Sie können sowohl die Anzahl der angezeigten Datenbytes pro Zeile auswählen (8, 10 oder 16) als auch die Anzahl der Datenbytes pro Spalte (1, 2 oder 4).

Siehe auch

Botschaft bearbeiten-Dialogfenster


Filter bearbeiten-Dialogfenster

Mit dem Filter bearbeiten-Dialogfenster können Filterelemente für einen Botschaftsfilter definiert werden. Botschaftsfilter können verwendet werden, um die CAN-Botschaften herauszufiltern, die in der Empfangsliste angezeigt oder von Tracern aufgezeichnet werden sollen.

Ein Filter besteht aus ein oder mehreren Filterelementen, die wiederum verschiedene Betriebsmodi und Parameter haben können. Jedes Filterelement kann so konfiguriert werden, dass es Botschaften eines einzelnen Busses oder von allen aktiven Bussen des Projekts filtert.

Filter aktivieren

Aktiviert oder deaktiviert den Botschaftsfilter. Wenn ein Filter aktiviert ist, bestimmen die Elemente in der Liste Filterelemente, ob eine Botschaft den Filter passieren kann. Wenn ein Filter deaktiviert ist, werden alle Botschaften vom Filter durchgelassen.

Beschreibung

Ermöglicht es, den Filter zu beschreiben.

Filterelemente

Diese Liste zeigt alle Elemente, die für den Filter definiert sind.

Bus Diese Spalte zeigt den Bus an, für den ein Filterelement Botschaften filtert. Der Zustand des Kontrollkästchens am linken Rand legt fest, ob das Filterelement aktiv ist oder nicht. Wird das Kontrollkästchen gelöscht, ist das aus der Sicht des Botschaftsfilters so, als ob das Filterelement nicht vorhanden ist.

Typ Diese Spalte zeigt den Typ bzw. Betriebsmodus der Filterelemente an.

Details Diese Spalte zeigt die Parameter der Filterelemente an.

Element hinzufügen

Fügt der Liste ein neues Filterelement hinzu.

Element löschen

Löscht das ausgewählte Filterelement aus der Liste.

Nach oben / Nach unten

Ändert die Position des ausgewählten Filterelements in der Liste.

Wenn ein Filter prüft, ob eine bestimmte Botschaft passieren kann, arbeitet der Filter die Filterelemente in der Liste von oben nach unten ab. Wenn ein Filterelement passt und die Bedingung wahr ist, wird die Verarbeitung weiterer Filterelemente abgebrochen. Deshalb beeinflusst die Position eines Elements in der Liste das Ergebnis des Filtervorgangs.

Einstellungen

Bus

Wenn ein bestimmter Bus in dieser Dropdownliste ausgewählt wird, werden nur Botschaften dieses Busses von dem Filterelement verarbeitet. Botschaften anderer Busse werden von dem Filterelement nicht durchgelassen.

Typ

Legt den Typ bzw. Betriebsmodus des ausgewählten Filterelements fest.

Typ/Modus Beschreibung

CAN-ID Bereich

Diese Modus fügt dem Element einen durchgängigen Bereich von CAN-IDs hinzu, die durch den Filter hindurchgelassen werden sollen.

Wenn Modus auf Standard gesetzt wird, verarbeitet das Filterelement nur 11-Bit-Botschaften. Bei Erweitert werden nur 29-Bit-Botschaften verarbeitet.

Wenn die Option RTR ausgewählt wird, verarbeitet das Filterelement nur Remote Transmission Requests.

Wenn die Option Ausschließen ausgewählt wird, verhindert das Filterelement, dass die spezifizierten Botschaften vom Filter durchgelassen werden.

SJA1000 Code/Maske

Dieser Modus simuliert den Low-Level Filtermechanismus des SJA1000 CAN-Controllers. Eine Beschreibung des Arbeitsprinzips und der Bedeutung der Werte Akzeptanzcode und Akzeptanzmaske siehe NXP (vormals Philips) Application Note AN97076, "SJA1000 Stand-alone CAN controller", Abschnitt 4.1.2.

Wird die Option Ausschließen ausgewählt, arbeitet der Filter invers, d.h. das Filterelement verhindert, dass die spezifizierten Botschaften vom Filter durchgelassen werden.

An Symbole anpassen

In diesem Modus werden nur diejenigen Botschaften vom Filter durchgelassen, für die ein entsprechendes Symbol in einer aktiven Symboldatei definiert wurde.

An markierte Symbole anpassen

Dieser Modus erlaubt nur denjenigen Symbolen, Multiplexern oder Variablen den Filter zu passieren, die in einer aktiven Symboldatei mit dem Trace-Schalter (-t) markiert wurden. Siehe auch Filtern von Botschaften.

Optionen

Erlaubt zusätzlichen Botschafts-Typen, den Filter zu passieren.

Hinweis: Fehlerwarnungen werden niemals im Senden/Empfangen-Fenster angezeigt, auch wenn für ein Filterelement die entsprechende Option aktiviert wurde, und der Filter, der solch ein Element enthält, dem Senden/Empfangen-Fenster zugewiesen wurde.

J1939

Dieser Modus ist nur verfügbar, wenn das J1939 Add-in geladen ist.

In diesem Modus können Botschaften über PGN, Priorität, Quelle, Ziel, und über jede Kombination dieser Werte gefiltert werden.

Wenn die Option Ausschließen ausgewählt wird, verhindert das Filterelement, dass die spezifizierten Botschaften vom Filter durchgelassen werden.

Siehe auch

Benutzeroberfläche

Filtern von Botschaften


Sendelisten-Fenster

Sendelisten-Fenster sind Ansichten von geöffneten Sendelisten-Dateien. Diese definieren eine Reihe von CAN-Botschaften, die von PCAN-Explorer gesendet werden sollen.

Die folgenden Spalten können für Sendeliste angezeigt werden:

Bus

Die Bus-Nummer der Verbindung, zu der die Botschaft gehört (1-16).

Wenn die verknüpfte Verbindung deaktiviert ist, wird das Symbol [image] vor der Busnummer angezeigt.

Verbindung

Der Name der Verbindung, zu der die Botschaft gehört.

CAN-ID (hexadezimal)

Der CAN-Identifier der Botschaft in hexadezimaler Darstellung. 11-Bit CAN-Botschaften werden mit einer 3-stelligen CAN-ID dargestellt (0-7FFh), 29-Bit CAN-Botschaften gemäß CAN-Protokoll 2.0B werden mit einer 8-stelligen CAN-ID dargestellt (0 - 1FFFFFFFh).

CAN-ID (dezimal)

Der CAN-Identifier der Botschaft in dezimaler Darstellung. 29-Bit CAN-Botschaften gemäß CAN-Protokoll 2.0B haben das Postfix 'x'.

Typ

Der Typ der Botschaft. Die verschiedenen Typen werden durch farbige Indikatoren kenntlich gemacht.

Die folgenden Indikatoren können angezeigt werden:

Indikator | Beschreibung
Keine Anzeige | 11- oder 29-Bit Datenbotschaft
 | Remote Request Frame
 | CAN-FD-Botschaft
 | CAN-FD-Botschaft mit aktiviertem Bit Rate Switch
 | Error State Indicator
 | Die Botschaft wird mit der Option Single Shot Transmission gesendet. Siehe NXP Application Note AN97076 "SJA1000 Stand-alone CAN controller", Abschnitt 5.4.
 | J1939-Botschaft
 | J1939-Botschaft, die zur Übertragung das Transport-Protokoll benötigt

DLC

Der Datenlängencode der Botschaft. Für CAN-Botschaften kann der Wert im Bereich 0-8 liegen, bei CAN-FD-Botschaften im Bereich 0-15, und bei J1939-Botschaften im Bereich 0-1785.

Länge

Die Anzahl der Datenbytes der Botschaft. Herkömmliche CAN-Botschaften können eine Länge zwischen 0 und 8 Datenbytes haben. Die maximale Länge von J1939 Botschaften ist 1785.

Bei CAN FD beträgt die maximale Länge 64 Datenbytes, wobei der folgende Zusammenhang zwischen DLC und Länge gilt:

DLC | Länge
<= 8 | DLC
9 | 12
10 | 16
11 | 20
12 | 24
13 | 32
14 | 48
15 | 64

Symbol

Diese Spalte zeigt den Namen eines Symbols an, das mit der Botschaft kompatibel ist.

Daten

Die Werte der Datenbytes der Botschaft.

Timeouts

Diese Spalte hat keine Bedeutung bei Sendelisten.

Zykluszeit

Das Zeitintervall, in dem eine Botschaft periodisch gesendet wird. Wurde die Botschaft mit einer Zykluszeit von 0 ms erzeugt, wird der Text Warte angezeigt, d.h. die Botschaft wird nicht periodisch gesendet.

Anzahl

Die Anzahl der gesendeten Botschaften seit dem letzten Ausführen des Reset-Befehls.

Trigger

Der Grund für das letzte Senden einer Botschaft. Folgende Gründe für das Senden einer Botschaft können angezeigt werden:

  • Manuell: Die Botschaft wurde manuell vom Benutzer gesendet.

  • Zeit: Die Botschaft wurde aufgrund der festgelegten Zykluszeit gesendet.

  • RTR: Die Botschaft wurde als Antwort auf einen empfangenen Remote Request Frame gesendet.

  • Makro: Die Botschaft wurde von einem Standardmakro gesendet.

  • Automation: Die Botschaft wurde von einem VBScript-Makro oder von einem externen Programm gesendet, das PCAN-Explorer als Automation Server betreibt.

  • RQST: Die Botschaft wurde als Antwort auf einen J1939-Request (PGN 59904) gesendet.

Zeit

Der Zeitpunkt, an dem die Botschaft zuletzt gesendet wurde.

Ersteller

Diese Spalte identifiziert den Erzeuger einer CAN-Botschaft.

Kommentar

Der Kommentar, der für die Botschaft vorgegeben wurde. Der Kommentartext kann im Eigenschaften-Fenster eingegeben werden, wenn die Botschaft in der Sendeliste ausgewählt ist.

Zusätzliche Spalten für das J1939-Protokoll

PGN

Gibt die Parameter Group Number der Botschaft an.

Prioriät

Die Priorität (0-7) der Botschaft.

Quelle

Die Quelladresse der Botschaft. Wird Null angezeigt, besitzt die Botschaft die Null-Adresse (254).

Es können separate Spalten angezeigt werden, um die Quelladresse in dezimaler und/oder hexadezimaler Schreibweise anzuzeigen.

Ziel

Die Zieladresse der Botschaft. Wird Alle angezeigt, wird die Botschaft unter Verwendung der Globalen Adresse 255 gesendet, was bedeutet, dass die Botschaft als Broadcast gesendet wird. Wird Null angezeigt, besitzt die Botschaft die Null-Adresse (254).

Es können separate Spalten angezeigt werden, um die Zieladresse in dezimaler und/oder hexadezimaler Schreibweise anzuzeigen.

Siehe auch

Arbeiten mit Sendelisten

Symbole in Sendelisten

Standard-Sendeliste


Timing-Fehler-Fenster

Das Timing-Fehler-Fenster ermöglicht die Überwachung von Timing-Fehlern, die beim periodischen Empfang von CAN-Botschaften auftreten können. Um das Timing-Fehler-Fenster anzuzeigen, wählen Sie den Befehl Timing-Fehler aus dem Menü Ansicht.

Filter

Wählt ein bestimmtes Symbol, dessen Timing-Fehler in der Liste angezeigt werden sollen.

Alles löschen

Löscht alle aufgezeichneten Timing-Fehler.

Kopieren

Kopiert die Liste mit den Timing-Fehler als Text in die Zwischenablage.

Zeit

Zeigt den Zeitstempel eines Timing-Fehlers an.

Bus

Zeigt die Bus-Nummer der Verbindung an, für die ein Timing-Fehler auftrat.

ID

Zeigt die CAN-ID der Botschaft an, die für den Timing-Fehler verantwortlich war.

Symbol

Zeigt den Namen des Symbols an, für das ein Timing-Fehler auftrat.

Min. Intervall

Zeit das kleinste erlaubte Empfangsintervall an, das für das Symbol definiert wurde (in Millisekunden).

Timeout

Zeigt die Timeout-Zeit an, die für das Symbol definiert wurde (in Millisekunden).

Dauer

Zeigt die Zeitdauer zwischen den letzten beiden Empfangszeitpunkten des Symbols an, die den Timing-Fehler verursacht hat. Wenn die Option Permanent auf Timeouts prüfen aktiviert ist (siehe Timing, Projekteinstellungen-Dialogfenster, kann ein Timeout-Zustand bereits vor dem Eintreffen der nächsten passenden CAN-Botschaft angezeigt werden. Die Zeitspanne kann aber erst ermittelt werden, wenn eine passende CAN-Botschaft empfangen wurde. Bis dahin wird ein Fragezeichen für die Dauer angezeigt.

Siehe auch

Timeouts

Timing, Projekteinstellungen-Dialogfenster

Benutzeroberfläche


Daten exportieren-Dialogfenster

Sie können das Daten exportieren-Dialogfenster verwenden, um Daten von aufgezeichneten CAN-Botschaften oder von Empfangs- und Sendelisten in Textdateien oder CSV-Dateien zu exportieren. Um das Daten exportieren-Dialogfenster anzuzeigen, aktivieren Sie ein Trace-Fenster oder eine Empfangs- bzw. Sendeliste und wählen dann im Menü Datei den Befehl Exportieren.

Je nach verfügbaren Export-Möglichkeiten werden bis zu drei verschiedene Registerseiten angezeigt:

  • Botschaften - Text

  • Botschaften - CSV

  • Signale - CSV

Die ausgewählte Registerseite bestimmt, welche Art von Export nach dem Drücken von OK durchgeführt wird.

Pfad

Legt den Pfad und den Namen der Datei fest, in welche die Daten exportiert werden. Die Dropdownliste enthält Pfadnamen der zuletzt verwendeten Dateien. Verwenden Sie die Schaltfläche ... neben der Dropdownliste um ein Dialogfenster zur Auswahl eines Pfades anzuzeigen.

Zeitstempel

Wählt das Format der Zeitstempel aus. Mögliche Optionen sind:

Option Beschreibung

Relativ in Millisekunden

Speichert die Zeitstempel von aufgezeichneten CAN-Botschaften als Offsets relativ zum Anfang der Aufzeichnung, in Millisekunden.
Nur verfügbar beim Exportieren von Daten aus einem Tracer.

Relativ in Sekunden

Speichert die Zeitstempel von aufgezeichneten CAN-Botschaften als Offsets relativ zum Anfang der Aufzeichnung, in Sekunden.
Nur verfügbar beim Exportieren von Daten aus einem Tracer.

Absolut - formatiert

Speichert die Zeitstempel als absolute Uhrzeiten. Die Zeitwerte werden gemäß der Einstellung Format der absoluten Zeitstempel im Optionen-Dialogfenster formatiert.

Absolut - Rohwerte

Speichert die Zeitstempel als Gleitkommawerte. Der ganzzahlige Anteil eines solchen Wertes stellt die Anzahl der seit dem 30. Dezember 1899 vergangenen Tage dar. Die Nachkommastellen sind der Bruchteil des vergangenen 24-Stunden-Tages.

Microsoft Excel kann nativ diese Werte interpretieren, indem eine Zelle mit einem solchen Wert als Datum oder Zeit oder als Kombination von beiden formatiert wird.

Differenziell in Millisekunden

Speichert den Zeitstempel einer aufgezeichneten CAN-Botschaft als Zeitdifferenz zu der unmittelbar zuvor aufgezeichneten CAN-Botschaft, in Millisekunden.
Nur verfügbar beim Exportieren von Daten aus einem Tracer.

Differenziell in Sekunden

Speichert den Zeitstempel einer aufgezeichneten CAN-Botschaft als Zeitdifferenz zu der unmittelbar zuvor aufgezeichneten CAN-Botschaft, in Sekunden.
Nur verfügbar beim Exportieren von Daten aus einem Tracer.

Dezimaltrennzeichen

Legt das Dezimaltrennzeichen fest, das zur Ausgabe der Werte in die Datei verwendet wird. Wenn der Wert Automatisch ausgewählt ist, wird das Dezimaltrennzeichen von der Regions- und Zahlenformateinstellung in der Windows-Systemsteuerung bestimmt.

Registerseite 'Botschaften - Text'

Wenn Sie diese Registerseite auswählen, werden die Daten als Textdatei exportiert, wobei die verschiedenen Informationen in Spalten angeordnet werden. Verwenden Sie die Optionen auf dieser Seite, um die Textausgabe an Ihre eigenen Anforderungen anzupassen.

Ausgabe

Bestimmt, welche Elemente in die Datei ausgegeben werden.

Option | Beschreibung
Daten-Frames | Gibt Daten-Frames in die Datei aus. Dazu gehören CAN, CAN FD, sowie J1939 Daten-Frames.
RTR-Frames | Gibt RTR-Frames in die Datei aus.
Error Frames | Gibt Error Frames in die Datei aus. Nur verfügbar beim Exportieren aus einer Trace-Aufzeichnung oder der Empfangsliste.
Fehlerzähler-Änderungen | Gibt Änderungen an Fehlerzählern im CAN-Controller in die Datei aus. Nur verfügbar beim Exportieren aus einer Trace-Aufzeichnung oder der Empfangsliste.
Statusänderungen | Gibt Änderungen am Hardware-Status in die Datei aus. Nur verfügbar beim Exportieren aus einer Trace-Aufzeichnung.
Ereignisse | Gibt Ereignisse, wie z.B. Plug-in/out von CAN-Hardware, in die Datei aus. Nur verfügbar beim Exportieren aus einer Trace-Aufzeichnung.

Spalten

Hier sind die einzelnen Spalten aufgeführt, die momentan für den Export-Vorgang konfiguriert sind.

Über die Schaltfläche Auswählen können Sie die Spalten sowie deren Reihenfolge anpassen.

Optionen

Option Beschreibung

Kopfzeilen ausgeben

Fügt einen Dateikopf mit Angaben über Speicherort, aktive Busse und Spaltenüberschriften am Anfang der Datei ein.

Variablenwerte ausgeben

Falls symbolische Informationen für eine CAN-Botschaft verfügbar sind, werden die enthaltenen Variablen sowie deren Werte in die Datei ausgegeben.

Über die Dropdownliste Anordnung können Sie steuern, an welcher Position die Variablen in der Datei erscheinen, bezogen auf die Zeile mit den Rohdaten.

Nur markierte Variablen

Speichert nur die Variablen in die Datei, deren Trace-Schalter aktiviert ist. Nur verfügbar, wenn die Option Variablenwerte ausgeben aktiviert ist

Qualifizierte Namen

Gibt Namen von Symbolen und Variablen in ihrer voll qualifizierten Form aus. Dies bedeutet, der Name wird aus den Namen von Symboldatei, Symbol, Multiplexer (falls verfügbar) und Variable zusammengesetzt, getrennt durch Punkte. Beispiele:

Symboldatei.Symbolname
Symboldatei.Symbolname.Multiplexername
Symboldatei.Symbolname.Variablenname
Symboldatei.Symbolname.Multiplexername.Variablenname

Registerseite 'Botschaften - CSV'

Wenn Sie diese Registerseite auswählen, werden die Daten als CSV-Datei (Comma-separated values) exportiert. Verwenden Sie die Optionen auf dieser Seite, um die Ausgabe an Ihre eigenen Anforderungen anzupassen.

Spaltentrennzeichen

Legt fest, welches Zeichen verwendet wird, um die einzelnen Spalten in der Datei voneinander zu trennen.

Wenn der Wert Automatisch ausgewählt ist, hängt das Spaltentrennzeichen vom Dezimaltrennzeichen ab:

  • Ist das Dezimaltrennzeichen ein Komma, wird das Spaltentrennzeichen ein Semikolon.

  • Ist das Dezimaltrennzeichen ein Punkt, wird das Spaltentrennzeichen ein Komma.

Ausgabe

Bestimmt, welche Elemente in die Datei ausgegeben werden.

Siehe Ausgabe bei Registerseite Botschaften - Text.

Spalten

Hier sind die einzelnen Spalten aufgeführt, die momentan für den Export-Vorgang konfiguriert sind.

Über die Schaltfläche Auswählen können Sie die Spalten sowie deren Reihenfolge anpassen.

Optionen

Option Beschreibung

Spaltenüberschriften

Falls aktiviert, erhält die erste Zeile in der Datei die Überschriften für alle Spalten.

Nur markierte Variablen

Speichert nur die Variablen in die Datei, deren Trace-Schalter aktiviert ist.

Qualifizierte Namen

Gibt Namen von Symbolen und Variablen in ihrer voll qualifizierten Form aus. Dies bedeutet, der Name wird aus den Namen von Symboldatei, Symbol, Multiplexer (falls verfügbar) und Variable zusammengesetzt, getrennt durch Punkte. Beispiele:

Symboldatei.Symbolname
Symboldatei.Symbolname.Multiplexername
Symboldatei.Symbolname.Variablenname
Symboldatei.Symbolname.Multiplexername.Variablenname

Registerseite 'Signale - CSV'

Mit Hilfe dieser Registerseite können Sie Signalwerte aus einer Trace-Aufzeichnung in eine CSV-Datei exportieren. Wenn Sie OK drücken, während diese Registerseite aktiv ist, sucht PCAN-Explorer zuerst in der aktiven Trace-Datei nach Signalinformationen, und öffnet dann ein Dialogfenster, in dem Sie die Signale auswählen können, die Sie exportieren möchten.

Diese Registerseite ist nur beim Exportieren aus einer Trace-Aufzeichnung verfügbar.

Spaltentrennzeichen

Legt fest, welches Zeichen verwendet wird, um die einzelnen Spalten in der Datei voneinander zu trennen.

Wenn der Wert Automatisch ausgewählt ist, hängt das Spaltentrennzeichen vom Dezimaltrennzeichen ab:

  • Ist das Dezimaltrennzeichen ein Komma, wird das Spaltentrennzeichen ein Semikolon.

  • Ist das Dezimaltrennzeichen ein Punkt, wird das Spaltentrennzeichen ein Komma.

Zeit-Spalte

Bestimmt, wie die Zeitstempel der Signale ausgegeben werden.

Option | Beschreibung
Separate Spalten für jedes Signal | Für jedes Signal werden jeweils zwei Spalten in die Datei geschrieben, welche die Wertepaare aus Zeitstempel und Signalwert enthalten.
Gemeinsame Spalte für alle Signale | Als erste Spalte wird eine gemeinsame Zeitspalte in die Datei geschrieben. Die weiteren Spalten enthalten nur noch die Werte der Signale zu dem jeweiligen Zeitpunkt.

Optionen

Option | Beschreibung
Spaltenüberschriften | Falls aktiviert, enthält die erste ausgegebene Zeile die Überschriften für alle Spalten.
Qualifizierte Signalnamen | Gibt Namen von Signalen in ihrer qualifizierten Form aus. Falls ein Signal auf einem CAN-Symbol basiert, wird der Name aus den Namen von Symboldatei, Symbol, Multiplexer (falls verfügbar) und Variable zusammengesetzt, getrennt durch Punkte. Beispiele: Symboldatei.Symbolname.Variablenname Symboldatei.Symbolname.Multiplexername.Variablenname Falls ein Signal nicht auf einem CAN-Symbol basiert: Symboldatei.Signalname

Siehe auch

Exportieren von aufgezeichneten Daten

Exportieren von Botschaften


Dateibezogene Elemente

Diese Elemente der Benutzeroberfläche werden im Umgang mit Dateien benötigt.

In diesem Abschnitt

Neue Datei-Dialogfenster

Erzeugt eine neue Datei eines auszuwählenden Typs.

Auswahl Drucken-Dialogfenster

Kontrolliert den Ausdruck von Textdateien.

Suchen-Dialogfenster

Sucht in Texteditorfenstern nach Text.

Weitere Abschnitte

Benutzeroberfläche

Enthält Referenzthemen für die verschiedenen Dialogfenster und weiterer Fenster von PCAN-Explorer.


Suchen-Dialogfenster

Das Suchen-Dialogfenster ermöglicht das Suchen nach Text in dem aktiven Texteditorfenster. Um das Dialogfenster anzuzeigen, muss im Menü Bearbeiten der Befehl Suchen ausgewählt werden.

Das Suchen-Dialogfenster durchsucht eine Textdatei ab der Position der Einfügemarke entweder nach unten oder nach oben, abhängig von der ausgewählten Suchrichtung. Die erste gefundene Stelle mit dem gesuchten Text wird markiert. Soll ab dieser Position mit den gleichen Einstellungen weitergesucht werden, muss im Menü Bearbeiten der Befehl Weitersuchen ausgewählt werden. Die Suche kann solange fortgesetzt werden, bis entweder das Ende oder der Anfang der Datei erreicht worden ist. Beim Erreichen des Endes oder des Anfangs der Datei wird in der Statuszeile des Texteditorfensters eine Meldung angezeigt.

Das Suchen-Dialogfenster hat folgende Felder:

Text suchen

Der Text, nach dem gesucht werden soll.

Groß-/Kleinschreibung beachten

Ist diese Option aktiviert, wird bei der Suche auf Übereinstimmung der Groß- und Kleinschreibung geachtet.

Ganze Wörter

Sucht nur nach ganzen Wörtern, anstatt nach Text zu suchen, der sich auch innerhalb von Wörtern befinden kann.

Richtung

Aufwärts

Sucht beginnend ab der Einfügemarke nach oben.

Abwärts

Sucht beginnend ab der Einfügemarke nach unten.

Siehe auch

Suchen von Text

Benutzeroberfläche


Neue Datei-Dialogfenster

Verwenden Sie dieses Dialogfenster, um neue Dateien zu erzeugen.

Dateitypen

Enthält alle Dateitypen, die von PCAN-Explorer unterstützt werden, und die mit Hilfe dieses Dialogfensters erzeugt werden können.

Zeigt die Dateitypen mit großen Symbolen an.

Zeigt die Dateitypen mit kleinen Symbolen an.

Siehe auch

Benutzeroberfläche


Auswahl Drucken-Dialogfenster

Verwenden Sie das Auswahl Drucken-Dialogfenster, um Optionen zu konfigurieren, die das Erscheinungsbild des Ausdrucks von Textdateien verändern. Das Auswahl Drucken-Dialogfenster wird angezeigt, wenn der Befehl Drucken im Menü Datei ausgewählt wird.

Zu druckende Datei

Zeigt den Namen der Datei an, die gedruckt werden soll.

Drucke ausgewählten Block

Ist im Texteditorfenster ein Textblock markiert, dann wird nur dieser Text gedruckt, wenn die Option aktiviert ist. Ist die Option nicht aktiviert, wird die gesamte Datei ausgedruckt.

Drucker einrichten

Zeigt das Dialogfenster zur Druckereinrichtung an.

Optionen

Kopfzeile/Seitenzahl

Ist diese Option aktiviert, werden auf jeder Seite eine Kopfzeile und die Seitenzahl ausgedruckt. Die Kopfzeile enthält den Dateinamen; die Seitenzahl erscheint mittig am unteren Blattrand.

Zeilen umbrechen

Bewirkt, dass Zeilen, welche die Breite der gedruckten Seite überschreiten, auf der nächsten Zeile fortgesetzt werden.

Linker Rand

Bestimmt die Breite des linken Rands für die gedruckten Seiten.

Siehe auch

Benutzeroberfläche


Makro-Elemente

Dieser Abschnitt enthält Informationen über alle Dialogfenster und sonstige Elemente, die sich auf VBScript-Makros und Standardmakros beziehen.

In diesem Abschnitt

Makro-Dialogfenster

Dient der Verwaltung von VBScript-Makros.

Makrostatus-Fenster

Zeigt Informationen über den Programmablauf von Standardmakros an.

Makro-Dropdownliste

Dient zur schnellen Auswahl eines Standardmakros oder VBScript-Makros, um es zu starten oder zu editieren.

Weitere Abschnitte

VBScript-Makros

Enthält Themen über Anwendung von und Referenz zu VBScript-Makros.

Standardmakros

Enthält die Referenz zu Standardmakros.

Benutzeroberfläche

Enthält Referenz-Themen für die verschiedenen Dialogfenster und anderer Fenster von PCAN-Explorer.


Makro-Dialogfenster

Das Makro-Dialogfenster dient der Verwaltung von VBScript-Makros. Es können Makros gestartet, editiert oder erzeugt werden. Um das Makro-Dialogfenster anzuzeigen, wählen Sie im Menü Makro den Befehl Makro.

Name

Diese Liste zeigt die Namen aller VBScript-Makros an, die in der ausgewählten Makrodatei (Dropdownliste Datei) enthalten sind. In dem Feld über der Liste kann der Name eines Makros eingegeben werden. Die Liste springt automatisch zu den Einträgen, die mit den eingegebenen Anfangsbuchstaben übereinstimmen.

Gibt man einen Namen ein, der nicht in der Liste vorhanden ist, kann man durch Drücken der Schaltfläche Bearbeiten ein neues Makro in die ausgewählte Makrodatei aufnehmen.

Datei

Wählt eine der installierten VBScript-Makrodateien aus, deren Makros in der Liste Name angezeigt werden sollen.

Beschreibung

Zeigt die Beschreibung des im Feld Name ausgewählten Makros an.

Ausführen

Startet das ausgewählte Makro.

Bearbeiten

Öffnet die Makrodatei des ausgewählten Makros im Texteditor.

Neue Datei

Erzeugt eine neue Makrodatei.

Schließen

Schließt das Makro-Dialogfenster.

Hilfe

Zeigt die Hilfe zum Makro-Dialogfenster an.

Siehe auch

VBScript-Makros

Benutzeroberfläche


Makrostatus-Fenster

Das Makrostatus-Fenster zeigt Informationen über den Programmablauf von Standardmakros an. Außerdem werden Debug-Ausgaben oder andere Meldungen des Standardmakros angezeigt, die von der Print-Makroanweisung erzeugt werden.

Das Makrostatus-Fenster wird beim Starten eines Standardmakros automatisch angezeigt. Dieses Verhalten kann im Optionen-Dialogfenster auf der Seite Makros eingestellt werden.

Beim Schließen des Fensters wird das Makro nicht beendet, sondern im Hintergrund weiterhin ausgeführt. Um das Fenster dann wieder anzuzeigen, wählen Sie im Menü Ansicht den Befehl Makro-Status.

Siehe auch

Standardmakros

Print-Anweisung

Makros, Optionen-Dialogfenster

Benutzeroberfläche


Makro-Dropdownliste

Beim Start von PCAN-Explorer werden alle Makros eingelesen und übersetzt, die sich in den eingestellten Bibliotheks-Verzeichnissen für Standardmakros und VBScript-Makros befinden. Alle gefundenen Makros werden in die Makro-Dropdownliste der Standard-Symbolleiste aufgenommen. Vor jedem Makro erscheint ein Symbol, das über Art und Zustand des jeweiligen Makros informiert:

Symbol | Beschreibung
 | Das Makro ist ein Standardmakro, das ordnungsgemäß übersetzt werden konnte und keine Fehler enthält.
 | Das Makro ist ein Standardmakro, das Fehler enthält.
 | Das Makro ist ein VBScript-Makro.

Die Bibliotheks-Verzeichnisse für Standardmakros und VBScript-Makros können im Optionen-Dialogfenster auf der Seite Bibliothek konfiguriert werden. Beim ersten Start von PCAN-Explorer sind entsprechende Verzeichnisse erstellt worden und deren Pfade dort bereits eingetragen.

Siehe auch

Bibliothek, Optionen-Dialogfenster

Standardmakros

VBScript-Makros


Optionen-Dialogfenster

Im Optionen-Dialogfenster kann man viele der Optionen verändern, die zur Beeinflussung der PCAN-Explorer-Umgebung dienen. Beispielsweise kann man die Verzeichnisse festlegen, die standardmäßig zum Speichern von Dateien der verschiedenen Dateitypen verwendet werden sollen. Um das Optionen-Dialogfenster anzuzeigen, wählen Sie im Menü Werkzeuge den Befehl Optionen.

Das Optionen-Dialogfenster ist in zwei Bereiche aufgeteilt: eine Kategorienliste auf der linken Seite und ein Bereich zur Anzeige verschiedener Seiten auf der rechten Seite. Auf den einzelnen Seiten sind die Optionen nach ihrer Funktionalität gruppiert. Wenn in der Kategorienliste eine Seite angeklickt wird, erscheint deren Inhalt im Seitenanzeigebereich.

Um die Hilfe für eine bestimmte Seite anzuzeigen, zeigen Sie die entsprechende Seite an und drücken entweder die Taste [F1], oder klicken Sie auf die Schaltfläche Hilfe.

Das Optionen-Dialogfenster kann folgende Seiten anzeigen:

Seite | Beschreibung
Allgemein | Allgemeine Einstellungen bezüglich Signale, Symboldateien, und dam Format von Gleitkommazahlen.
Umgebung | Allgemeine Einstellungen bezüglich der Benutzeroberfläche.
Fenster | Allgemeine Einstellungen bezüglich der Fenster in der Benutzeroberfläche.
Dokumente | Einstellungen bezüglich des Umgangs mit extern veränderten Dateien.
Texteditor | Einstellungen zum Verhalten des Texteditors, Anzeige von Zeilennummern.
Schriftarten und Farben | Einstellung von Schriftart und Farben für verschiedene Fenster bzw. Elemente der Benutzeroberfläche.
Tastatur | Verwenden Sie diese Seite um Tastenkombinationen anzupassen.
Senden/Empfangen | Steuert die Anzeige von Daten im Senden/Empfangen-Fenster.
Zurücksetzen-Aktionen | Legt die Aktionen fest, die beim Ausführen des Zurücksetzen-Befehls durchgeführt werden
Tracer | Voreinstellungen für Tracer.
Trace-Fenster | Anzeigeoptionen der Trace-Fenster.
Makros | Einstellungen bezüglich des Umgangs mit Makros.
Bibliothek | Konfiguriert den Ort und die Verzeichnisse des PCAN-Explorer-Bibliothek.
Internet | Einstellungen bezüglich der Internetverbindung.
Verbindungen | Allgemeine Einstellungen bezüglich Verbindungen.
J1939 | Voreinstellungen bezüglich des J1939-Protokolls.
J1939 Auto-Werte | Voreinstellungen bezüglich automatischer Signalwertberechung für J1939-Sendebotschaften.

Siehe auch

Benutzeroberfläche


Allgemein, Optionen-Dialogfenster

Verwenden Sie die Seite Allgemein des Optionen-Dialogfensters, un allgemeine Einstellungen bezüglich der Benutzeroberfläche, Symboldateien und des Formats von Gleitkommazahlen anzupassen. Um dieses Dialogfenster anzuzeigen, wählen Sie im Menü Werkzeuge den Befehl Optionen und dann die Seite Allgemein.

Gleitkommawerte

Format

Dieser Wert bestimmt das Ausgabeformat von Gleitkommazahlen, wenn diese in den verschiedenen Fenstern von PCAN-Explorer angezeigt werden.

Einstellung | Bedeutung
Fest | Gleitkommazahlen werden als Festkommawerte im Format -xxx,xxx angezeigt.
Wissenschaftlich | Gleitkommazahlen werden im wissenschaftlichen Format angezeigt: -x,xxx...E+xxx.
Kürzest möglich | Gleitkommazahlen werden im kürzesten möglichen Format angezeigt, wobei entweder die Formate Fest oder Wissenschaftlich verwendet wird.

Dezimalstellen

Dieser Wert bestimmt die Anzahl der Nachkommastellen für Gleitkommawerte.

Standard Dezimaltrennzeichen

Bestimmt das Dezimaltrennzeichen, das die Grenze zwischen dem ganzzahligen Teil und dem gebrochenen Teil einer Zahl bildet. Mögliche Werte sind:

Einstellung | Bedeutung
Auto | Das Trennzeichen wird von dem in Windows eingestellten Zahlenformat bestimmt. Eine Änderung des Trennzeichens kann in den entsprechenden Dialogfenstern zu regionalen Einstellungen der Systemsteuerung vorgenommen werden.
Punkt | Das Trennzeichen ist ein Punkt.
Komma | Das Trennzeichen ist ein Komma.

Symboldateien

Symbole nur für aktivierte Verbindungen laden

Ist diese Option aktiviert, lädt PCAN-Explorer Symbole nur für die Verbindungen des Projekts, die momentan aktiviert sind.

Signale

Anzeigemodus für Signalnamen

Steuert, wie Namen von Signalen in den verschiedenen Fenstern der Benutzeroberfläche angezeigt werden: Mögliche Werte sind:

Einstellung | Bedeutung
Kurze Namen | Zeit Signale mit ihren Kurznamen an, ohne Qualifizierung.
Qualifizierte Kurze Namen | Zeit Signale mit ihren voll qualifizierten Namen an. Falls ein Signal auf einem CAN-Symbol basiert, wird der angezeigte Name aus den Namen von Symboldatei, Symbol, Multiplexer (falls verfügbar) und Variable zusammengesetzt, getrennt durch Punkte. Beispiele: Symboldatei.Symbolname.Variablenname Symboldatei.Symbolname.Multiplexername.Variablenname Falls ein Signal nicht auf einem CAN-Symbol basiert: Symboldatei.Signalname
Lange Namen | Zeigt Signale mit ihren langen Namen an. Wenn für ein Signal kein langer Name definiert ist, wird der Kurzname angezeigt.

Signalwerte zurücksetzen, wenn Verbindungen zurückgesetzt werden

Ist diese Option ausgewählt, werden beim Ausführen des Befehls Zurücksetzen ebenfalls alle Signalwerte auf ihre Default-Werte zurückgesetzt.

Zeitstempel

Format der absoluten Zeitstempel

Steuert das Anzeigeformat von absoluten Zeitstempeln in den verschiedenen Fenstern der Benutzeroberfläche.

Die Dropdownliste enthält einige vordefinierte Formate, aber jedes Format kann eingegeben werden. Die folgenden Format-Platzhalter können verwendet werden, um die Ausgabe von Datum und Zeit zu formatieren:

Platzhalter | Zeigt an
am/pm | Anzeige von am und pm, Stunden im 12-Stunden-Format.
d | Tag als Zahl (1-31), kürzest mögliche Form.
dd | 2-stelliger Tag (01-31).
ddd | Name des Tages, abgekürzt auf 2 Zeichen (abhängig von der Sprache des Betriebssystems).
dddd | Name des Tages, nicht abgekürzt (abhängig von der Sprache des Betriebssystems).
h | Stunde, kürzest mögliche Form. Wenn am/pm auch im Format angegeben ist, wird die Stunde im 12-Stunden-Format angezeigt.
hh | 2-stellige Stunde. Wenn am/pm auch im Format angegeben ist, wird die Stunde im 12-Stunden-Format angezeigt.
m | Monat als Zahl (1-12), kürzest mögliche Form.
mm | 2-stelliger Monat (01-12).
mmm | Name des Monats, abgekürzt auf 3 Zeichen (abhängig von der Sprache des Betriebssystems).
mmmm | Name des Monats, nicht abgekürzt (abhängig von der Sprache des Betriebssystems).
n | Minute, kürzest mögliche Form (0-59).
nn | 2-stellige Minute (00-59).
s | Sekunde, kürzest mögliche Form (0-59).
ss | 2-stellige Sekunde (00-59).
x | Mikrosekunden, bis zu 3 Stellen (x, xx, xxx).
yy | 2-stelliges Jahr.
yyyy | 4-stelliges Jahr.
z | Millisekunden, bis zu 3 Stellen (z, zz, zzz).

Siehe auch

Optionen-Dialogfenster

Anwenden-Befehl


Umgebung, Optionen-Dialogfenster

Verwenden Sie die Seite Umgebung des Optionen-Dialogfensters, um allgemeine Einstellungen bezüglich der PCAN-Explorer-Benutzeroberfläche und anderer Umgebungseinstellungen anzupassen. Sie können dieses Dialogfenster anzeigen, indem Sie im Menü Werkzeuge den Befehl Optionen und dann die Seite Umgebung auswählen.

Einstellungen

Statuszeile anzeigen

Zeigt die Statuszeile an. Die Statuszeile ist am unteren Rand des PCAN-Explorer-Hauptfensters angeordnet und zeigt kurze Beschreibungen zu den Menüeinträgen und Symbolleisten-Schaltflächen an, über die Sie die Maus bewegen.

Projekt-Desktop automatisch speichern

Wenn diese Option aktiviert ist, speichert PCAN-Explorer die Anordnung Ihres Arbeitsbereichs wenn Sie ein Projekt schließen oder das Programm beenden. Wenn Sie später das Projekt wieder öffnen, werden alle Dateien, die zu dem Zeitpunkt geöffnet waren, als das Projekt geschlossen wurde, wieder geöffnet, unabhängig davon, ob sie vom Projekt verwendet werden.

Tipp

Drücken der Taste [Umsch] während ein Projekt geschlossen oder das Programm beendet wird deaktiviert vorübergehend das automatische Speichern des Projekt-Desktops.

Begrüßungsbildschirm beim Programmstart anzeigen

Wenn diese Option aktiviert ist, zeigt PCAN-Explorer während des Programmstarts ein kleines Fenster mit dem PCAN-Explorer-Symbol und -Titel an.

Beim Starten

Hier können Sie festlegen, was Sie sehen möchten, wenn Sie PCAN-Explorer starten.

Sprache

Wählt die Sprache der Benutzeroberfläche aus.

Stil

Bestimmt den Stil und die Farben der Benutzeroberfläche.

Ausgabe-Fenster

Sound wiedergeben bei einem Ereignis wenn die Registerkarte Ereignisse nicht sichtbar ist

Ist das Ausgabe-Fenster ausgeblendet oder ist die Registerkarte Ereignisse im sichtbaren Ausgabe-Fenster nicht aktiv, wird ein Sound wiedergegeben, wenn diese Option aktiviert ist und ein neues Ereignis im Ausgabe-Fenster eingetragen wird.

Andere

Debug-Logdatei aktivieren

Aktiviert die Erstellung einer Debug-Logdatei zu Diagnosezwecken. Ist die Option aktiviert, werden Debug-Ausgaben in dieser Datei protokolliert:

C:\Users\UserName\AppData\Roaming\PEAK-System\PCAN-Explorer\6.0\Debug.log

Der exakte Dateipfad wird im Fenster "Über PCAN-Explorer" unter Debug-Logdatei angegeben. Das Fenster können Sie über den Befehl Über PCAN-Explorer im Menü Hilfe anzeigen.

Siehe auch

Optionen-Dialogfenster


Fenster, Optionen-Dialogfenster

Verwenden Sie die Seite Fenster des Optionen-Dialogfensters, um allgemeine Einstellungen bezüglich der Fenster in der Benutzeroberfläche anzupassen. Sie können dieses Dialogfenster anzeigen, indem Sie im Menü Werkzeuge den Befehl Optionen und dann die Seite Fenster auswählen.

Einstellungen

An Fensterkanten einrasten

Ist die Option aktiviert, werden beim Verschieben oder beim Ändern der Größe eines Fensters im Arbeitsbereich die Kanten des Fensters an den Kanten anderer Fenster oder dem Rand des Arbeitsbereichs eingerastet. Dies erlaubt eine leichte gegenseitige Ausrichtung verschiedener Fenster und ist hilfreich bei der bestmöglichen Ausnutzung des zur Verfügung stehenden Arbeitsbereichs.

Hinweis

Diese Option hat nur Auswirkungen auf Fenster vom Typ Fenster mit Registerkarte.

Einrastbereich

Bestimmt den maximalen Abstand in Pixeln zwischen der Kante eines Fensters und einer anderen Fensterkante oder dem Rand des Arbeitsbereichs, bevor das Fenster an der Kante einrastet.

Werkzeug-Fenster

Layout zurücksetzen

Setzt die Anordnung des Arbeitsbereichs auf das voreingestellte Layout zurück, das beim ersten Start des Programms aktiv war.

Siehe auch

Optionen-Dialogfenster


Dokumente, Optionen-Dialogfenster

Verwenden Sie diese Seite des Optionen-Dialogfensters um zu steuern, wie Dokumente in der PCAN-Explorer-Umgebung angezeigt werden, und zur Verwaltung von externen Änderungen an Dokumenten und Dateien. Um dieses Dialogfenster anzuzeigen, wählen Sie im Menü Werkzeuge den Befehl Optionen und dann die Seite Dokumente.

Feststellen, ob die Datei außerhalb des Programms verändert wurde

Wenn ausgewählt, werden Sie mit Hilfe eines Meldungsfensters benachrichtigt, wenn Änderungen an einer geöffneten Datei durch einen Editor außerhalb von PCAN-Explorer durchgeführt wurden. Die Meldung erlaubt Ihnen, die Datei neu zu laden.

Änderungen automatisch laden (falls Datei nicht innerhalb des Programms verändert wurde)

Wenn die Option Feststellen, ob die Datei außerhalb des Programms verändert wurde aktiviert ist, und eine in PCAN-Explorer geöffnete Datei von extern geändert wurde, wird standardmäßig eine Warnmeldung angezeigt. Ist diese Option aktiviert, wird keine Warnmeldung anzeigt und das Dokument wird neu geladen um die externen Änderungen zu übernehmen.

Neu geladene Dateien automatisch "Anwenden"

Ist diese Option aktiviert, wird der Befehl Anwenden automatisch für Dateien ausgeführt, die wegen externer Änderungen automatisch neu geladen wurden. Diese Einstellung hat nur auf manche Dateitypen eine Auswirkung, wie beispielsweise Symboldateien und Makrodateien.

Automatisch speichern beim Ausführen des Befehls "Anwenden"

Ist diese Option aktiviert, wird eine Datei automatisch gespeichert, wenn der Befehl Anwenden für eine Datei ausgeführt wird.

Zuletzt geöffnete Dateien

Wählt die Dateitypen aus, die im Menü Letzte Dateien angezeigt werden nachdem sie geöffnet wurden.

Siehe auch

Optionen-Dialogfenster

Anwenden-Befehl


Texteditor, Optionen-Dialogfenster

Verwenden Sie die Seite Texteditor des Optionen-Dialogfensters, um Einstellungen anzupassen, die das Verhalten des Texteditors verändern. Um dieses Dialogfenster anzuzeigen, wählen Sie im Menü Werkzeuge den Befehl Optionen und dann die Seite Texteditor.

Automatisch einrücken

Positioniert die Einfügemarke unterhalb des ersten nichtleeren Zeichens (kein Leer- oder Tabulatorzeichen) der Zeile, wenn Sie die Eingabetaste drücken.

Rücktaste löscht Einzug

Falls aktiviert, bewirkt das Drücken der Rücktaste, während sich die Einfügemarke am ersten nichtleeren Zeichen einer Zeile befindet, dass der Einzug der Zeile an den Einzug der vorherigen Zeile ausgerichtet wird.

Tab-Zeichen verwenden

Fügt Tab-Zeichen für die Einrückung von Zeilen ein.

Text am Cursor suchen

Setzt den Text an der Einfügemarke in das Text suchen-Eingabefeld des Suchen-Dialogfensters, wenn Sie den Befehl Suchen im Menü Bearbeiten auswählen.

Zeilennummern

Zeigt Zeilennummern am linken Fensterrand an. Diese Option ist getrennt aktivierbar für die verschiedenen, auf Texteingabe basierenden Dateitypen.

Tab-Stopps

Die Anzahl von Zeichenspalten, die sich der Cursor nach rechts bewegt, wenn Sie die Tabulatortaste drücken.

Siehe auch

Arbeiten mit dem Texteditor

Anpassen von Schriftarten, -größen und -farben

Anpassen der Syntax-Hervorhebung

Option en-Dialogfenster


Schriftarten und Farben, Optionen-Dialogfenster

Die Seite Schriftarten und Farben des Optionen-Dialogfensters ermöglicht die Einstellung der Schriftart und des Farbschemas für verschiedene Elemente der Benutzeroberfläche. Sie können dieses Dialogfenster anzeigen, indem Sie im Menü Werkzeuge den Befehl Optionen und dann die Seite Schriftarten und Farben auswählen.

Einstellungen zeigen für

Enthält alle Elemente der Benutzeroberfläche, welche die Einstellung von Schriftart und Farbschema erlauben. Nachdem ein Element ausgewählt worden ist, können die Einstellungen für das Objekt verändert werden, das in der Liste Anzeigeelemente ausgewählt ist.

  • Ausgabe-Fenster
    Änderungen von Schriftart, Schriftgröße und von Farbeinstellungen beeinflussen das Erscheinungsbild von Text auf den verschiedenen Registerkarten des Ausgabe-Fensters.

  • Makrostatus-Fenster
    Änderungen von Schriftart, Schriftgröße und Farbeinstellungen beeinflussen das Erscheinungsbild von Text im Makrostatus-Fenster.

  • Senden/Empfangen-Fenster
    Änderungen von Schriftart, Schriftgröße und von Farbeinstellungen beeinflussen das Erscheinungsbild von Text in der Empfangsliste, der Standard-Sendeliste sowie in weiteren Sendelisten-Fenstern.

  • Text-Editor
    Änderungen von Schriftart, Schriftgröße und von Farbeinstellungen beeinflussen das Erscheinungsbild von Text in den verschiedenen Texteditor-Fenstern.

  • Trace-Fenster
    Änderungen von Schriftart, Schriftgröße und von Farbeinstellungen beeinflussen das Erscheinungsbild von Text in Trace-Fenstern.

  • Trace-Hinweisfenster
    Änderungen von Schriftart, Schriftgröße und von Farbeinstellungen beeinflussen das Erscheinungsbild von Text in dem Hinweisfenster, das die Variablenwerte von Trace-Botschaften anzeigt.

  • Überwachungen-Fenster
    Änderungen von Schriftart, Schriftgröße und von Farbeinstellungen beeinflussen das Erscheinungsbild von Text auf den verschiedenen Registerkarten des Überwachungen-Fensters.

  • Verbindungen-Fenster
    Setzt Schriftart, Schriftgröße und Farben für das Verbindungen-Fenster.

Voreinstellungen

Setzt alle Einstellungen auf Standardwerte zurück.

Schriftart

Enthält alle für die Anzeige des Elements passenden Schriftarten. Je nach ausgewähltem Element werden in der Liste beispielsweise nur Schriftarten angezeigt, die eine konstante Buchstabenbreite haben. Eine Änderung der Schriftart beeinflusst alle in Anzeigeelemente aufgeführten Objekte des in Einstellungen zeigen für ausgewählten Elements.

Größe

Enthält eine Auswahl an Größen für die ausgewählte Schriftart. Bei TrueType-Schriftarten können in dem Eingabefeld auch Werte eingegeben werden, die nicht in der Liste vorgegeben sind. Eine Änderung der Schriftgröße beeinflusst alle in Anzeigeelemente aufgeführten Objekte des in Einstellungen zeigen für ausgewählten Elements.

Anzeigeelemente

Enthält alle Objekte, für welche die Vorder- und Hintergrundfarbe verändert werden kann.

Hinweis

Text ist das Standard-Anzeigeobjekt. Die für das Objekt Text vorgenommenen Einstellungen werden von den Einstellungen anderer Objekte überschrieben. Weisen Sie beispielsweise dem Objekt Text die Farbe Blau zu und dem Objekt Schlüsselwort die Farbe Grün, erscheinen alle Schlüsselwörter grün. In diesem Beispiel überschreiben Schlüsselwort-Einstellungen Text-Einstellungen.

Element-Vordergrundfarbe

Führt alle verfügbaren Farben auf, die Sie für das in Anzeigeelemente ausgewählte Element wählen können.

Element-Hintergrundfarbe

Stellt eine Farbpalette zur Verfügung, aus der Sie eine Hintergrundfarbe für das in der Liste Anzeigeelemente ausgewählte Objekt festlegen können.

Textattribute

Wählen Sie diese Optionen, um den Text von ausgewählten Anzeigeelementen fett, kursiv oder als unterstrichenen Text anzuzeigen.

Beispiel

Zeigt ein Beispiel der ausgewählten Schriftart, der Schriftgröße und des Farbschemas für das Objekt an, das über Einstellungen zeigen für und Anzeigeelemente ausgewählt ist. Sie können dieses Feld als Vorschau verwenden, während Sie mit den verschiedenen Formatierungsoptionen experimentieren.

Siehe auch

Optionen-Dialogfenster


Tastatur, Optionen-Dialogfenster

Die Seite Tastatur ermöglicht es Ihnen, die Tastenkombinationen in PCAN-Explorer anzupassen. Es können neue Tastenkombinationen für häufig verwendete Befehle erstellt werden. Sie können dieses Dialogfenster anzeigen, indem Sie im Menü Werkzeuge den Befehl Optionen und dann die Seite Tastatur auswählen.

Hinweis

Geben Sie eine Tastenkombination im Textfeld Drücke neue Tastenkombination ein, um zu prüfen, ob diese Tastenkombination bereits einem anderen Befehl zugewiesen ist. Zum Beispiel wird FileSave im Feld Momentan zugewiesen zu angezeigt, wenn Sie [Strg+S] im Feld Drücke neue Tastenkombination eingeben.

Kategorie

Erlaubt die Auswahl einer Kategorie von Befehlen.

Befehle

Führt alle verfügbaren Befehle der ausgewählten Kategorie auf.

Tastenkombination für ausgewählten Befehl

Wenn ein Befehl in der Liste Befehle ausgewählt ist, zeigt dieses Feld die Tastenkombination an, die dem Befehl zugewiesen ist.

Drücke neue Tastenkombination

Ermöglicht Ihnen, eine Tastenkombination einzugeben, die für den momentan ausgewählten Befehl verwendet werden soll. Dazu müssen Sie eine oder mehrere der Umschalttasten wie [Strg], [Alt] oder [Umsch] drücken. Drücken Sie beispielsweise die Tasten [Strg] und [Umsch], und dann [F2] wird die Tastenkombination [Umsch+Strg+F2] erzeugt. Verwenden Sie die Rücktaste um eine Tastenkombination wieder aus dem Feld zu löschen.

Beschreibung

Eine kurze Beschreibung des Befehls.

Zuweisen

Weist die neue Tastenkombination dem ausgewählten Befehl zu. Diese Schaltfläche ist nur verfügbar, nachdem Sie eine Tastenkombination in das Feld Drücke eine neue Tastenkombination eingegeben haben.

Entfernen

Entfernt die zugewiesene Tastenkombination von dem ausgewählten Befehl.

Alle zurücksetzen

Setzt alle Tastenkombinationen auf ihre Standardwerte zurück.

Siehe auch

Optionen-Dialogfenster

Anpassen von Tastenkombinationen

Tabelle der Tastenkombinationen

PCAN-Explorer-Befehle


Senden/Empfangen, Optionen-Dialogfenster

Verwenden Sie die Seite Senden/Empfangen des Optionen-Dialogfensters, um die Anzeige von Daten in der Empfangsliste und in Sendelisten zu steuern. Um dieses Dialogfenster anzuzeigen, wählen Sie im Menü Werkzeuge den Befehl Optionen und dann die Seite Senden/Empfangen.

Empfangsliste

Zeige Symbol-Kommentare und Lange Namen als Kurztipps

Ist diese Option aktiviert, werden am Mauszeiger Kurztipps (ToolTips) angezeigt, wenn die Maus auf einem Symbol oder einer Variablen in der Empfangsliste in einer der Spalten Symbol oder Daten positioniert wird. Die Anzeige von Kurztipps kann das Verständnis der angezeigten Daten erleichtern.

Der Kurztipp für ein Symbol enthält den Kommentar, der für das entsprechende Element in der Symboldatei definiert wurde. Falls der Eintrag in der Empfangsliste auch mit einem Multiplexer verknüpft ist, wird in der nächsten Zeile auch der Kommentar angezeigt, der für den Multiplexer definiert ist.

Der Kurztipp für eine Variable zeigt den Langen Namen, der für die Variable in der Symboldatei definiert wurde, und in der nächsten Zeile den Kommentar.

Symbole automatisch aufklappen

Falls diese Option aktiviert ist, werden Symbole beim erstmaligen Empfang automatisch aufgeklappt dargestellt, andernfalls zugeklappt. Im aufgeklappten Zustand sind die im Symbol enthaltenen Variablen und ihre Werte sichtbar.

Zeige hexadezimale Daten für symbolische Botschaften

Ist diese Option aktiviert, werden bei symbolisch angezeigten CAN-Botschaften in der Datenspalte zusätzlich die Datenbytes hexadezimal angezeigt, oberhalb der Variablen.

Sendeliste

Zeige Symbol-Kommentare und Lange Namen als Kurztipps

Ist diese Option aktiviert, werden am Mauszeiger Kurztipps (ToolTips) angezeigt, wenn die Maus auf einem Symbol oder einer Variablen in einer Sendeliste in einer der Spalten Symbol oder Daten positioniert wird. Die Anzeige von Kurztipps kann das Verständnis der angezeigten Daten erleichtern.

Der Kurztipp für ein Symbol enthält den Kommentar, der für das entsprechende Element in der Symboldatei definiert wurde. Falls der Eintrag in der Sendeliste auch mit einem Multiplexer verknüpft ist, wird in der nächsten Zeile auch der Kommentar angezeigt, der für den Multiplexer definiert ist.

Der Kurztipp für eine Variable zeigt den Langen Namen, der für die Variable in der Symboldatei definiert wurde, und in der nächsten Zeile den Kommentar.

Zeige hexadezimale Daten für symbolische Botschaften

Ist diese Option aktiviert, werden bei symbolisch angezeigten CAN-Botschaften in der Datenspalte zusätzlich die Datenbytes hexadezimal angezeigt, oberhalb der Variablen.

Gemeinsame Einstellungen

Die folgenden Einstellungen wirken sich sowohl auf die Empfangsliste als auch auf Sendelisten aus.

Zeige lange Variablennamen

Ist diese Option aktiviert, werden die langen Namen von Variablen, falls verfügbar, in der Datenspalte von Empfangs- und Sendelisten angezeigt anstatt der Kurznamen, die auf eine Länge von 32 Zeichen begrenzt sind. Für alle Variablen, die keinen langen Namen besitzen, werden weiterhin die Kurznamen angezeigt.

Lange Namen werden über einen zusätzlichen Parameter in der Variablendefinition festgelegt. Siehe auch Optionale Parameter für Signal- und Variablendefinitionen.

Variablenwerte im sichtbaren Bereich halten

Ist diese Option aktiviert, werden die Variablenwerte in der Datenspalte nicht sofort rechts abgeschnitten, falls die Breite der Spalte nicht ausreicht, um alle Informationen anzuzeigen. Stattdessen werden zunächst die Variablennamen in der Länge gekürzt, um genügend Platz für die Variablenwerte zu schaffen.

Ausrichtung von Variablennamen

Bestimmt die Ausrichtung der Variablennamen in der Datenspalte.

Siehe auch

Zurücksetzen-Aktionen, Optionen-Dialogfenster

Optionen-Dialogfenster


Zurücksetzen-Aktionen, Optionen-Dialogfenster

Verwenden Sie die Seite Zurücksetzen-Aktionen des Optionen-Dialogfensters, um die Aktionen festzulegen, die beim Ausführen des Zurücksetzen-Befehls durchgeführt werden.

Aktionen für den Zurücksetzen-Befehl

Die folgenden Aktionen sind verfügbar:

Empfangsliste löschen

Ist diese Option aktiviert, wird die Empfangsliste gelöscht. Das Setzen dieser Option schließt auch immer die Optionen Zähler in Empfangsliste löschen und Zeitangaben in Empfangsliste löschen mit ein.

Zähler in Empfangsliste löschen

Ist diese Option aktiviert, werden die Zähler aller Einträge in der Empfangsliste auf 0 gesetzt.

Zeitangaben in Empfangsliste löschen

Ist diese Option aktiviert, werden die letzten Empfangszeitpunkte sowie gemessene Zykluszeiten jeder Botschaft gelöscht.

Zähler in Sendeliste löschen

Ist diese Option aktiviert, werden die Zähler aller Einträge in der Sendeliste auf 0 gesetzt.

Zeitangaben in Sendeliste löschen

Ist diese Option aktiviert, werden die letzten Sendezeitpunkte und die Werte in der Trigger-Spalte jeder Botschaft gelöscht.

Periodische Sendebotschaften neu planen

Ist diese Option aktiviert, werden die Sendezeitpunkte aller periodischen Sendebotschaften neu berechnet, so als ob das Senden der Botschaften angehalten und neu gestartet wurde. Sind mehrere aktive periodische Sendebotschaften vorhanden, kann das reine Zurücksetzen der Zählerstände gerade bei langsamen Sendeintervallen zu unklaren Beziehungen der Zählerstände untereinander sorgen.

Siehe auch

Senden/Empfangen, Optionen-Dialogfenster

Optionen-Dialogfenster


Tracer, Optionen-Dialogfenster

Verwenden Sie die Seite Tracer des Optionen-Dialogfensters, um Einstellungen für Tracer anzupassen. Um dieses Dialogfenster anzuzeigen, wählen Sie im Menü Werkzeuge den Befehl Optionen und dann die Seite Tracer.

Einstellungen

Verzeichnis für temporäre Trace-Dateien

Wenn ein neuer Tracer mit dem Befehl Neuen Tracer starten [image] geöffnet wird, und der Standard-Puffertyp für Tracer ist auf Datei eingestellt (s.u.), legt PCAN-Explorer die Trace-Datei in dem hier ausgewählten Verzeichnis an.

Das hier ausgewählte Verzeichnis wird nicht berücksichtigt, wenn das aktuell geöffnete Projekt noch keinen Speicherort besitzt. Wurde ein neues Projekt erzeugt das bisher nicht gespeichert wurde, werden neue Trace-Dateien automatisch im Temp-Verzeichnis des lokalen Benutzerkontos angelegt, üblicherweise in C:\Users\UserName\AppData\Local\Temp.

Lösche temporäre Trace-Datei nach Speichern unter

Ist die Option aktiviert, wird eine temporäre Trace-Datei gelöscht, nachdem sie mit dem Befehl Datei | Speichern unter erfolgreich unter einem anderem Dateinamen gespeichert wurde.

Dateiname und -pfad in Dateikopf von Trace-Datei eintragen

Ist die Option aktiviert, wird beim Speichern einer Trace-Datei im Dateikopf der Dateiname mit Pfad als Kommentar eingetragen.

Hinweis

Wird eine Trace-Datei, die mit dem Puffertyp Datei geöffnet ist, unter einem anderen Namen gespeichert, wird der im Dateikopf eingetragene Dateiname und -pfad nicht angepasst. In diesem Fall wird die Originaldatei lediglich an die neue Stelle kopiert und nicht neu erzeugt.

Filtername an Name von gefilterten Trace anhängen

Der beim Filtern einer Trace-Datei neu erstellte Trace erhält üblicherweise den Namen Dateiname_gefiltert. Ist diese Option aktiviert, wird zusätzlich der Name des angewendeten Filters angehängt, beispielsweise erhält der neu erstellte Trace dann den Namen Dateiname_gefiltert_MeinFilter. Alle Zeichen in Filternamen, die zu ungültigen Dateinamen führen könnten, werden dabei automatisch entfernt. Leerzeichen werden ebenfalls entfernt.

Tracer-Voreinstellungen

Diese Einstellungen dienen als Voreinstellung für neu erzeugte Tracer.

Puffertyp

Bestimmt, wie der Puffer mit Daten gefüllt wird.

  • Datei: Die Daten werden während der Aufzeichnung direkt in eine Trace-Datei geschrieben.

  • Dynamisch: Die Größe des Puffers wächst ständig, während Botschaften aufgezeichnet werden.

  • Linear: Der Puffer hat eine feste Größe. Wenn der Puffer komplett gefüllt ist, wird die Aufzeichnung angehalten und im Ausgabe-Fenster wird eine Meldung angezeigt.

  • Ring: Der Puffer hat eine feste Größe. Wenn der Puffer komplett gefüllt ist, wird die älteste Botschaft im Puffer überschrieben wenn eine neue Botschaft aufgezeichnet wird.

Puffergröße

Setzt die feste Größe des Datenpuffers (Anzahl von CAN-Botschaften) für die Puffertypen Linear und Ring. Die maximale Größe beträgt 999.999.999 Botschaften. Während Sie einen Wert in das Feld eingeben, wird der benötigte Arbeitsspeicher berechnet und neben dem Eingabefeld angezeigt.

Erster Eintrag setzt Startzeit

Ist die Option aktiviert, wird der Zeitstempel der ersten aufgezeichneten Botschaft als Startzeit des Tracers behandelt. Der Zeit-Offset des ersten Eintrags wird hierbei zu 0.

Ist die Option nicht aktiviert, ist die Startzeit des Tracers der Zeitpunkt, zu dem der Tracer wirklich gestartet wurde, z.B. wenn die Schaltfläche Start [image] im Trace-Fenster betätigt wurde.

Dateiformat

Bestimmt, welche Version des Trace-Dateiformats standardmäßig verwendet wird.

  • Automatisch: PCAN-Explorer bestimmt anhand der verwendeten PCAN-Hardware automatisch die Version. Hier gilt: werden in einem Projekt nur PCAN-USB Adapter (IPEH-002021/002022), PCAN-USB Pro (IPEH-002061) oder auch PCAN-USB Hub (IPEH-002004) verwendet, speichert PCAN-Explorer Trace-Dateien unter Verwendung von Version 1.3, in allen anderen Fällen unter Verwendung von Version 2.1.

  • Version 2.1: Bestimmt, dass beim Speichern von Trace-Dateien immer die aktuell neueste Version 2.1 verwendet werden soll.

Weitere Informationen zu den verschiedenen Versionen des Trace-Dateiformats finden Sie in der PEAK-System Dateiformat-Spezifikation für CAN-Trace-Dateien, die Sie auf unserer Webseite unter Support / Downloads / Dokumentation herunterladen können.

Siehe auch

Trace-Fenster, Optionen-Dialogfenster

Optionen-Dialogfenster

Projekteinstellungen-Dialogfenster


Trace-Fenster, Optionen-Dialogfenster

Verwenden Sie die Seite Trace-Fenster des Optionen-Dialogfensters, um Voreinstellungen für Trace-Fenster anzupassen. Um dieses Dialogfenster anzuzeigen, wählen Sie im Menü Werkzeuge den Befehl Optionen und dann die Seite Trace-Fenster unterhalb von Tracer.

Trace-Fenster

Spaltenüberschriften anzeigen

Legt fest, ob in Trace-Fenstern standardmäßig Spaltenüberschriften angezeigt werden.

Statuszeile anzeigen

Bestimmt, ob Trace-Fenster standardmäßig eine Statuszeile anzeigen.

Zeige Hex-Daten in Pause- und Stopp-Modus

Falls aktiviert, wird im Trace-Fenster die Hex-Ansicht unterhalb der Trace-Liste eingeblendet, während sich der Tracer im Pause- oder Stopp-Modus befindet. Selektiert man eine Botschaft in der Trace-Liste, wird die Botschaft im Detail in der Hex-Ansicht dargestellt.

Zeige Hinweisfenster mit Variablenwerten bei inaktivem Fenster

Falls eine Botschaft im Trace-Fenster symbolische Informationen besitzt, wird ein Hinweisfenster mit den Variablenwerten angezeigt, wenn man den Mauszeiger auf den Datenbytes der Botschaft positioniert. Dazu muss der Tracer pausiert oder gestoppt sein, und sowohl das Trace-Fenster als auch PCAN-Explorer selbst müssen aktiv sein.

Ist diese Option aktiviert, wird das Hinweisfenster mit den Variablenwerten auch dann angezeigt, wenn das Trace-Fenster nicht das aktive Fenster in der Benutzeroberfläche von PCAN-Explorer ist, oder wenn die Anwendung momentan nicht aktiv ist.

Siehe auch Anzeigen von Variablen im Trace-Fenster.

Zeige lange Namen von Variablen in Hinweisfenster

Ist diese Option aktiviert, werden die langen Namen von Variablen, falls verfügbar, im Hinweisfenster mit den Variablenwerten angezeigt anstatt der Kurznamen, die auf eine Länge von 32 Zeichen begrenzt sind. Für alle Variablen, die keinen langen Namen besitzen, werden weiterhin die Kurznamen angezeigt.

Lange Namen werden über einen zusätzlichen Parameter in der Variablendefinition festgelegt. Siehe auch Optionale Parameter für Signal- und Variablendefinitionen.

Zeige Überschreiben-Warnung für Tracer mit Puffertyp Datei

Ist diese Option aktiviert, wird in einem Trace-Fenster eine Warnmeldung angezeigt, falls der Tracer den Puffertyp Datei verwendet und bereits aufgezeichnete Daten enthält. Das Ausführen des Befehls Start würde neue Daten sofort in die momentan geöffnete Trace-Datei schreiben und eine vorherige Aufzeichnung überschreiben, im Gegensatz zu den Puffertypen Dynamisch, Linear und Ring, die zuerst in den Arbeitsspeicher aufzeichnen.

Zeitstempel

Bestimmt das Standardformat der in Trace-Fenstern angezeigten Zeitstempel.

  • Relativ: Der angezeigte Wert gibt die Zeitdauer seit Aufzeichnungsbeginn in Sekunden an.

  • Absolut: Der Zeitstempel wird als absolute Uhrzeit angezeigt.

  • Differenziell: Der angezeigte Wert gibt die Zeitdauer seit Aufzeichnung der letzten Botschaft in Sekunden an.

Relative und differenzielle Zeitstempel in Mikrosekunden-Auflösung:

Erhöht die Auflösung der in Trace-Fenstern angezeigten Zeitstempel auf 1 Mikrosekunde. Als Voreinstellung werden relative und differenzielle Zeitstempel mit einer Auflösung von 1/10 Millisekunden angezeigt.

Die höhere Auflösung kann nur für Trace-Dateien angezeigt werden, die Format-Version 1.3 oder neuer verwenden. Ältere Formate speichern die Zeitstempel nicht in der benötigten Anzahl Nachkommastellen. Alle Trace-Dateien, die mit PCAN-Explorer 6 aufgezeichnet werden, ermöglichen die Darstellung der Zeitstempel mit der höheren Auflösung.

Format der CAN-IDs:

Wählt das Standard-Anzeigeformat für CAN-IDs in Trace-Fenstern aus. Wählbar sind dezimale oder hexadezimale Darstellung.

Anzeige der Datenlänge:

Wählt aus, ob die Länge von CAN-Botschaften standardmäßig als Datenlängencode oder als Anzahl Datenbytes in Trace-Fenstern angezeigt wird.

Datenbytes-Format:

Wählt das Standard-Anzeigeformat für Datenbytes in Trace-Fenstern aus. Wählbar sind dezimale, hexadezimale oder ASCII-Darstellung.

J1939

Dieser Abschnitt ist nur verfügbar, wenn das J1939 Add-in geladen ist.

Anzeigeformat von PGNs

Bestimmt, ob Parametergruppennummern standardmäßig in dezimaler oder hexadezimaler Schreibweise angezeigt werden.

Anzeigeformat von Adressen

Bestimmt, ob Quell- oder Zieladressen in Trace-Fenstern standardmäßig in dezimaler oder hexadezimaler Schreibweise angezeigt werden.

Siehe auch

Tracer, Optionen-Dialogfenster

Trace-Fenster

Optionen-Dialogfenster

Projekteinstellungen-Dialogfenster


Makros, Optionen-Dialogfenster

Verwenden Sie die Seite Makros des Optionen-Dialogfensters, um festzulegen, wie PCAN-Explorer mit veränderten Makrodateien verfahren soll, bevor ein Makro gestartet wird. Dies betrifft sowohl Standardmakros als auch VBScript-Makros. Um dieses Dialogfenster anzuzeigen, wählen Sie im Menü Werkzeuge den Befehl Optionen und dann die Seite Makros.

Einstellungen

Datei immer neu laden

Ist diese Option ausgewählt, lädt PCAN-Explorer eine Makrodatei jedes Mal, wenn die Datei, die das Makro enthält, verändert worden ist.

Datei niemals neu laden

Ist diese Option ausgewählt, lädt PCAN-Explorer eine Makrodatei nie, nachdem die Datei verändert worden ist. Trotzdem kann man die Makrodatei manuell neu laden, nachdem man eine Änderung vorgenommen hat, indem man im Makroeditor die rechte Maustaste drückt und den Befehl Makrodatei neu laden auswählt.

Fragen, ob die Datei neu geladen werden soll

Ist diese Option ausgewählt, zeigt PCAN-Explorer ein Meldungsfenster an, um vom Benutzer abzufragen, ob eine veränderte Makrodatei neu geladen werden soll.

Standardmakros

Die Einstellungen in diesem Abschnitt betreffen nur Standardmakros.

Makrostatus-Fenster automatisch anzeigen...

Ist diese Option aktiviert, wird das Makrostatus-Fenster beim Starten eines Standardmakros automatisch angezeigt.

Zeitstempel im Makrostatus-Fenster anzeigen

Ist diese Option aktiviert, werden Zeitstempel im Makrostatus-Fenster am Anfang jeder Zeile angezeigt. Die Zeitstempel geben die Anzahl vergangener Sekunden seit dem Start des Makros an.

Prüfe maximale Anzahl erlaubter Argumente

Ist diese Option aktiviert, prüft PCAN-Explorer beim Übersetzen eines Standardmakros, ob die zulässige Anzahl von Argumenten für die einzelnen Makroanweisungen überschritten wurde. Eine Überschreitung der zulässigen Anzahl von Argumenten erzeugt die Fehlermeldung Fehler 208: Zu viele Argumente für Makroanweisung.

Siehe auch

Optionen-Dialogfenster

Fehlermeldungen von Standardmakros


Bibliothek, Optionen-Dialogfenster

Auf der Seite Bibliothek des Optionen-Dialogfensters können die Bibliotheksverzeichnisse für die verschiedenen Dateitypen von PCAN-Explorer vorgegeben werden. Dateien, die in diese Verzeichnisse gespeichert werden, werden im Bibliotheks-Browser unter der entsprechenden Kategorie aufgeführt, um einen schnellen Zugriff auf diese Dateien zu ermöglichen.

Um dieses Dialogfenster anzuzeigen, wählen Sie im Menü Werkzeuge den Befehl Optionen und dann die Seite Bibliothek.

Hauptverzeichnis der Bibliothek

Setzt das Hauptverzeichnis für die PCAN-Explorer-Bibliothek. Das Verzeichnis in diesem Feld wird auch verwendet, wenn das Verzeichnismakro $(LibDir) ausgeführt wird.

Um ein Verzeichnis auszuwählen, können Sie auch ein Dialogfenster Ordner suchen anzeigen, indem Sie die Schaltfläche neben dem Feld verwenden, oder wählen Sie ein Verzeichnismakro. aus.

Bibliotheksverzeichnisse

Diese Liste enthält alle Verzeichnisse für die entsprechenden Dateitypen.

Spalte | Bedeutung
Dateityp | Zeigt den Namen des Dateityps sowie dessen Dateinamenerweiterung an.
Pfad | Enthält das eingestellte Verzeichnis für den Dateityp. Die Pfadangabe kann auch Verzeichnismakros enthalten.

Siehe auch

Bibliothek

Optionen-Dialogfenster

Bibliotheks-Browser

Verzeichnismakros


Internet, Optionen-Dialogfenster

Verwenden Sie die Registerseite Internet im Optionen-Dialogfenster, um Einstellungen bezüglich Ihrer Internet-Verbindung zu ändern. PCAN-Explorer verwendet die Internet-Verbindung, um die News-Liste zu aktualisieren, die sich auf der Startseite befindet.

Sie können das Optionen-Dialogfenster anzeigen, indem Sie den Befehl Optionen im Menü Werkzeuge auswählen und dann die Seite Internet wählen.

Aktualisierungen

Auf neue Version prüfen alle ... Tage

Legt fest, ob und in welchem Zeitintervall PCAN-Explorer über das Internet auf verfügbare Produktaktualisierungen prüft.

News

Auf neue News Prüfen alle ... Tage

Legt fest, ob und in welchem Zeitintervall PCAN-Explorer das News-Fenster über das Internet aktualisiert.

Proxy mit Anmeldung

Ich nutze einen Proxy mit Anmeldung (HTTP)

Ist diese Option aktiviert, sendet die Anwendung eine Anmeldebotschaft an den Proxy-Server, wenn sie sich mit dem Internet verbindet. Aktivieren Sie diese Option nur, wenn Ihr Proxy-Server eine Anmeldung erfordert, und füllen Sie dann die Felder Benutzername und Kennwort aus.

Benutzername

Gibt den Anmeldenamen für den Proxy-Server an.

Kennwort

Gibt das Kennwort für die Anmeldung am Proxy-Server an.

Siehe auch

Optionen-Dialogfenster


Verbindungen, Optionen-Dialogfenster

Verwenden Sie die Registerseite Verbindungen im Optionen-Dialogfenster, um allgemeine Einstellungen bezüglich Verbindungen zu ändern.

Sie können diese Seite des Optionen-Dialogfensters anzeigen, indem Sie den Befehl Optionen im Menü Werkzeuge auswählen und dann die Seite Verbindungen wählen.

Einstellungen

Erzwinge die im Projekt konfigurierten Hardware-Optionen

Ist die Option aktiviert, werden beim Aufbau einer Verbindung die verschiedenen Hardware-Optionen des verwendeten CAN-Interfaces mit den im Projekt gespeicherten Einstellungen überschrieben, auch wenn das CAN-Interface bereits durch andere Software belegt und konfiguriert ist.

Dies betrifft die folgenden Einstellungen:

  • Listen-Only-Modus

  • Bestimme Zeitstempel bei Start-of-Frame

  • Tx Self-Acknowledge

  • Ignoriere BRS

Siehe auch

Verbindung, Projekteinstellungen-Dialogfenster

Optionen-Dialogfenster


J1939, Optionen-Dialogfenster

Verwenden Sie die Seite J1939 des Optionen-Dialogfensters, um Voreinstellungen für Verbindungen anzupassen, die das J1939-Protokoll verwenden.

Um dieses Dialogfenster anzuzeigen, wählen Sie im Menü Werkzeuge den Befehl Optionen und dann die Seite J1939. Die Seite ist nur verfügbar, wenn das J1939 Add-in geladen ist.

J1939 Voreinstellungen

Anforderungen bearbeiten (RQST)

Ist diese Option aktiviert, werden neue Projekte so konfiguriert, dass PCAN-Explorer versucht, empfangene RQST-Botschaften (PGN 59904) zu beantworten.

Transportprotokoll Lese-Sessions

Diese Einstellungen haben eine Wirkung, falls eine J1939-Verbindung während einer Datenübertragung als Beantworter (Responder) fungiert.

CTS: Anzahl der akzeptierten Pakete

Dies ist die Voreinstellung der maximalen Anzahl von Datenpaketen für große Botschaften, die zum Senden freigegeben werden. Die tatsächliche Anzahl von zum Senden freigegebener Pakete in einer TPCM.CTS Botschaft wird niemals größer als die angeforderte Anzahl von Paketen von einer empfangenen TPCM.RTS Botschaft.

Anzahl Re-CTS

Setzt die Voreinstellung für die maximale Anzahl Re-CTS während einer Lese-Session.

Nachdem der Beantworter ein CTS gesendet hat, und innerhalb des Timeouts von 1250 ms keine Datenpakete (TPDT) vom Absender empfangen werden, sendet der Beantworter erneut ein CTS. Wenn die Anzahl dieser neu gesendeten CTS die hier definierte maximale Anzahl Re-CTS erreicht, wird der Beantworter beim nächsten Timeout die Session abbrechen, indem er ein TPCM.ConnAbort sendet.

Transportprotokoll Schreib-Sessions

Diese Einstellungen haben eine Wirkung, falls eine J1939-Verbindung während einer Datenübertragung als Absender (Originator) fungiert.

RTS: Maximale Anzahl Pakete

Dies ist die Voreinstellung für die maximale Anzahl von angeforderten Paketen, die vom Absender als Antwort auf ein empfangenes CTS gesendet werden können. Falls der Beantworter diese Grenze akzeptiert, stellt er dadurch sicher, dass der Absender die Pakete neu senden kann, die der Beantworter aus irgendwelchen Gründen nicht korrekt empfangen hat.

Anzahl Neuversuche

Setzt die Voreinstellung für die maximale Anzahl RTS-Neuversuche während einer Schreib-Session.

Nachdem der Absender die Anzahl Datenpakte gesendet hat, die vom letzten empfangenen CTS zum Senden freigegeben waren, sendet der Absender erneut ein RTS, um die nächste Datenübertragung anzufordern. Wenn der Beantworter nicht innerhalb einer Zeit von 1250 ms mit einem CTS antwortet, sendet der Absender erneut ein RTS. Wenn die Anzahl dieser neu gesendeten RTS die hier definierte Anzahl Neuversuche erreicht, wird der Absender beim nächsten Timeout die Session abbrechen, indem er ein TPCM.ConnAbort sendet.

Siehe auch

Optionen-Dialogfenster

J1939 Auto-Werte, Optionen-Dialogfenster

J1939, Projekteinstellungen-Dialogfenster


J1939 Auto-Werte, Optionen-Dialogfenster

Verwenden Sie die Seite J1939 Auto-Werte des Optionen-Dialogfensters, um Voreinstellungen für Sendebotschaften anzupassen, die das J1939-Protokoll verwenden.

Um dieses Dialogfenster anzuzeigen, wählen Sie im Menü Werkzeuge den Befehl Optionen und dann die Seite J1939 Auto-Werte unterhalb des Knotens J1939. Die Seite ist nur verfügbar, wenn das J1939 Add-in geladen ist.

Beim Senden die Werte dieser J1939-Signale automatisch berechnen

Hier können Sie für verschiedene J1939-Signale (SPNs) auswählen, ob deren Werte beim Senden einer J1939-Botschaft, welche die Signale enthalten, automatisch berechnet werden.

Empfänger von bestimmten J1939-Botschaften wie z.B. TSC1 (Torque/Speed Control 1, PGN 0) können die Datenintegrität der Botschaft überprüfen, indem sie den rollenden Zähler sowie die Prüfsumme der Botschaft auswerten.

Die automatische Signalwertberechnung ist mit den SPNs verknüpft und findet nur dann statt, wenn einer Sendebotschaft ein Symbol vom Typ J1939PG zugewiesen ist, welches Signale mit den passenden SPNs enthält.

Ein Klick auf die Schaltfläche [image] rechts oberhalb der Liste öffnet ein Menü, mit dessen Hilfe Sie verschiedene Optionen für die Liste anpassen können, z.B. die Sortierung der Liste.

Hinweis

Die Einstellungen auf dieser Seite dienen nur als Voreinstellungen beim Anlegen neuer Projekte. Um die J1939 Auto-Wert-Berechnung Ihres aktuellen Projekts zu konfigurieren, verwenden Sie bitte die Seite J1939 Auto-Werte im Projekteinstellungen-Dialogfenster.

Siehe auch

Optionen-Dialogfenster

J1939, Optionen-Dialogfenster

J1939 Auto-Werte, Projekteinstellungen-Dialogfenster


Senden/Empfangen-Fenster

Das Senden/Empfangen-Fenster ist eines der zentralen Elemente der PCAN-Explorer Benutzeroberfläche. Es enthält die Empfangsliste und die Standard-Sendeliste.

Beide Listen sind am linken Rand des Fensters senkrecht beschriftet (Empfangen und Senden). Die Empfangsliste zeigt alle CAN-Botschaften, die von PCAN-Explorer empfangen werden. Die Sendeliste enthält CAN-Botschaften, die von PCAN-Explorer gesendet werden. Sendebotschaften können entweder vom Benutzer manuell erstellt werden, oder werden automatisch angelegt durch ein sendendes Standardmakro, VBScript-Makro oder Instruments Panel.

Die Höhen der Listen innerhalb des Senden/Empfangen-Fensters können mit Hilfe des horizontalen Trennbalkens zwischen den beiden Listen angepasst werden, indem dessen Position mit der Maus verändert wird.

Jeweils eine der beiden Listen kann auch so vergrößert werden, dass sie die ganze Fläche des Senden/Empfangen-Fensters belegt:

Schaltfläche | Beschreibung
 | Maximiert die entsprechende Liste. Alternativ kann die Taste [+] gedrückt werden, während die Liste den Eingabefokus hat.
 | Stellt die ursprüngliche Aufteilung der Empfangs- und Sendeliste wieder her. Alternativ kann die Taste [-] gedrückt werden.

Der Eingabefokus kann zwischen den beiden Listen gewechselt werden, indem die Taste [Tab] gedrückt wird.

Symbolleiste

Das Senden/Empfangen-Fenster besitzt eine separate Symbolleiste, die den schnellen Zugriff auf die wichtigsten Funktionen zum Bearbeiten der Sendeliste zur Verfügung stellt.

Schaltfläche | Befehl | Beschreibung | Alternativ
 | Neue Botschaft | Erzeugt eine neue Sendebotschaft, zeigt das Botschaft bearbeiten-Dialogfenster an. | [Einfg] Senden | Neue Botschaft
 | Botschaft bearbeiten | Zeigt das Botschaft bearbeiten-Dialogfenster an, um eine einzelne Sendebotschaft zu editieren. | [Eingabe] / [Umsch+Eingabe] Senden | Botschaft bearbeiten
 | Variablen bearbeiten | Zeigt das Variablen bearbeiten-Dialogfenster an, um die Variablenwerte einer einzelnen Sendebotschaft zu editieren. | [Eingabe] Senden | Variablen bearbeiten
 | Anhalten / Fortsetzen | Hält das zyklische Senden der ausgewählten Sendebotschaften an oder setzt es fort. | [Pause] Senden | Anhalten / Fortsetzen

Filter

Die Filter-Dropdownliste ermöglicht die Auswahl eines Botschaftsfilters für die Empfangsliste. Wenn Sie einen Filter ausgewählt haben, werden nur die Botschaften in der Empfangsliste angezeigt, die den Filter passieren können. Die Dropdownliste enthält alle Botschaftsfilter des aktuellen Projekts (siehe Projekt-Manager, Botschaftsfilter-Knoten auf der Registerseite Projekt-Elemente). Falls der ausgewählte Filter deaktiviert ist, können alle empfangenen Botschaften den Filter passieren.

Symbol | Beschreibung
 | Kein Filter ausgewählt.
 | Ein aktivierter Filter.
 | Ein deaktivierter Filter.

Die Schaltflächen neben der Dropdownliste haben die folgende Bedeutung:

Schaltfläche | Beschreibung
 | Bearbeitet den ausgewählten Filter, öffnet das Filter bearbeiten-Dialogfenster.
 | Fügt einen neuen Botschaftsfilter zum aktuellen Projekt hinzu und zeigt das Filter bearbeiten-Dialogfenster an.

Siehe auch

Empfangsliste

Standard-Sendeliste

Empfangen und Senden von CAN-Botschaften

Senden/Empfangen, Optionen-Dialogfenster


Empfangsliste

Die Empfangsliste befindet sich im Empfangen/Senden-Fenster und zeigt CAN-Botschaften, die von PCAN-Explorer empfangen werden.

Sie können die Spalten auswählen, die in der Empfangsliste angezeigt werden, indem Sie das Spalten auswählen-Dialogfenster verwenden. Die Reihenfolge der Spalten können Sie leicht ändern, indem Sie die Spaltenüberschriften mit der Maus an eine neue Position ziehen.

Die folgenden Spalten sind für die Empfangsliste verfügbar:

Bus

Die Bus-Nummer der Verbindung, von der eine Botschaft empfangen wurde (1-16).

Verbindung

Der Name der Verbindung, zu der die Botschaft gehört.

CAN-ID (hexadezimal)

Der CAN-Identifier der Botschaft in hexadezimaler Darstellung. 11-Bit Botschaften werden mit einer 3-stelligen CAN-ID angezeigt (0-7FFh), 29-Bit Botschaften gemäß CAN-Protokoll 2.0B werden mit einer 8-stelligen CAN-ID angezeigt (0-1FFFFFFFh).

CAN-ID (dezimal)

Der CAN-Identifier der Botschaft in dezimaler Darstellung. 29-bit Botschaften gemäß CAN-Protokoll 2.0B werden mit dem Postfix 'x' gekennzeichnet.

Typ

Der Typ der Botschaft. Die verschiedenen Typen werden durch Texte und farbige Indikatoren kenntlich gemacht.

Die folgenden Indikatoren können angezeigt werden:

Text/Indikator | Beschreibung
Keine Anzeige | 11- oder 29-Bit Datenbotschaft
 | Remote Request Frame
 | CAN-FD-Botschaft
 | CAN-FD-Botschaft mit aktiviertem Bit Rate Switch
 | Error State Indicator
 | J1939-Botschaft
 | J1939-Botschaft, die zur Übertragung das Transport-Protokoll verwendet hat
 | Error Frame
 | Fehlerzähler-Änderung

DLC

Der Datenlängencode der Botschaft. Für CAN-Botschaften und CAN-FD-Botschaften kann der Wert im Bereich 0-15 liegen, und bei J1939-Botschaften 0-1785.

Ist der DLC einer CAN-Botschaft größer als 8, wird der Wert rot dargestellt. Da das DLC-Feld in einem CAN Frame aus 4 Bits besteht, können Werte zwischen 0 und 15 enthalten sein. Die Datenlänge kann jedoch nie größer als 8 sein. DLC-Werte größer als 8 haben nur bei CAN FD eine Bedeutung.

Länge

Die Anzahl der Datenbytes der Botschaft. Herkömmliche CAN-Botschaften können eine Länge zwischen 0 und 8 Datenbytes haben. Die maximale Länge von J1939 Botschaften ist 1785.

Bei CAN FD beträgt die maximale Länge 64 Datenbytes, wobei der folgende Zusammenhang zwischen DLC und Länge gilt:

DLC | Länge
<= 8 | DLC
9 | 12
10 | 16
11 | 20
12 | 24
13 | 32
14 | 48
15 | 64

Symbol

Der Name des Symbols, das zu der Botschaft kompatibel ist.

Daten

Die Werte der Datenbytes der Botschaft. CAN-Botschaften können bis zu 8 Datenbytes haben, J1939-Botschaften können maximal 1785 Datenbytes haben.

Falls die Botschaft ein Error Frame ist, werden in der Spalte Informationen zu dem Error Frame angezeigt.

Timeouts

Die Anzahl der aufgetretenen Timeouts, falls ein Timeout für ein Symbol oder Multiplexer definiert wurde.

Zykluszeit

Das Zeitintervall zwischen den letzten beiden Empfangszeitpunkten der Botschaft, in Millisekunden.

Max. Zykluszeit

Die maximal gemessene Zykluszeit seit dem letzten Ausführen des Befehls Reset.

Wiederholungrate

Die Anzahl empfangener Botschaften pro Sekunde.

Anzahl

Die Anzahl der empfangenen Botschaften seit dem letzten Ausführen des Befehls Reset.

Zeit

Der Zeitpunkt, an dem die Botschaft zuletzt empfangen wurde.

Zusätzliche Spalten für das J1939-Protokoll

Diese Spalten werden nur dann angezeigt bzw. stehen nur dann zur Auswahl bereit, wenn das aktuelle Projekt mindestens eine Verbindung enthält, die das J1939-Protokoll verwendet.

PGN

Identifiziert die Parameter Group Number der Botschaft.

Getrennte Spalten können angezeigt werden, um die PGN in dezimaler und/oder hexadezimaler Schreibweise anzuzeigen.

Priorität

Die Priorität (0-7) der Botschaft.

Quelle

Die Quelladresse der Botschaft. Wird Null angezeigt, hat die Botschaft die Null-Adresse (254). Das bedeutet, der Absender der Botschaft hat keine Adresse angefordert.

Getrennte Spalten können angezeigt werden, um die Quelladresse in dezimaler und/oder hexadezimaler Schreibweise anzuzeigen.

Ziel

Die Zieladresse der Botschaft. Wird Alle angezeigt, wurde die Botschaft unter Verwendung der globalen Adresse 255 gesendet. Das bedeutet, die Botschaft wurde als Broadcast an alle Empfänger gesendet.

Getrennte Spalten können angezeigt werden, um die Zieladresse in dezimaler und/oder hexadezimaler Schreibweise anzuzeigen.

Siehe auch

Senden/Empfangen-Fenster

Symbole in der Empfangsliste

Standard-Sendeliste

Error Frames in der Empfangsliste

Spalten auswählen-Dialogfenster


Standard-Sendeliste

Die Sendeliste im Senden/Empfangen-Fenster wird auch Standard-Sendeliste genannt. Sendebotschaften können in diese Liste entweder manuell vom Benutzer eingetragen werden, oder sie werden automatisch durch ein sendendes Standardmakro, VBScript-Makro oder Instruments Panel eingetragen.

Alle Botschaften in dieser Liste werden automatisch in der Projektdatei gespeichert.

Sie können die Spalten auswählen, die in Sendelisten angezeigt werden, indem Sie das Spalten auswählen-Dialogfenster verwenden. Die Reihenfolge der Spalten können Sie leicht ändern, indem Sie die Spaltenüberschriften mit der Maus an eine neue Position ziehen.

Die folgenden Spalten sind für Sendelisten verfügbar:

Bus

Die Bus-Nummer der Verbindung, zu der die Botschaft gehört (1-16).

Wenn die verknüpfte Verbindung deaktiviert ist, wird das Symbol [image] vor der Busnummer angezeigt.

Verbindung

Der Name der Verbindung, zu der die Botschaft gehört.

CAN-ID (hexadezimial)

Der CAN-Identifier der Botschaft in hexadezimaler Darstellung. 11-Bit CAN-Botschaften werden mit einer 3-stelligen CAN-ID dargestellt (0-7FFh), 29-Bit CAN-Botschaften gemäß CAN-Protokoll 2.0B werden mit einer 8-stelligen CAN-ID dargestellt (0 - 1FFFFFFFh).

CAN-ID (dezimal)

Der CAN-Identifier der Botschaft in dezimaler Darstellung. 29-bit Botschaften gemäß CAN-Protokoll 2.0B werden mit dem Postfix 'x' gekennzeichnet.

Typ

Der Typ der Botschaft. Die verschiedenen Typen werden durch farbige Indikatoren kenntlich gemacht.

Die folgenden Indikatoren können angezeigt werden:

Indikator | Beschreibung
Keine Anzeige | 11- oder 29-Bit Datenbotschaft
 | Remote Request Frame
 | CAN-FD-Botschaft
 | CAN-FD-Botschaft mit aktiviertem Bit Rate Switch
 | Error State Indicator
 | Die Botschaft wird mit der Option Single Shot Transmission gesendet. Siehe NXP Application Note AN97076 "SJA1000 Stand-alone CAN controller", Abschnitt 5.4.
 | J1939-Botschaft
 | J1939-Botschaft, die zur Übertragung das Transport-Protokoll benötigt

DLC

Der Datenlängencode der Botschaft. Für CAN-Botschaften kann der Wert im Bereich 0-8 liegen, bei CAN-FD-Botschaften im Bereich 0-15, und bei J1939-Botschaften im Bereich 0-1785.

Länge

Die Anzahl der Datenbytes der Botschaft. Herkömmliche CAN-Botschaften können eine Länge zwischen 0 und 8 Datenbytes haben. Die maximale Länge von J1939 Botschaften ist 1785.

Bei CAN FD beträgt die maximale Länge 64 Datenbytes, wobei der folgende Zusammenhang zwischen DLC und Länge gilt:

DLC | Länge
<= 8 | DLC
9 | 12
10 | 16
11 | 20
12 | 24
13 | 32
14 | 48
15 | 64

Symbol

Diese Spalte zeigt den Namen eines Symbols an, das mit der Botschaft kompatibel ist.

Daten

Die Werte der Datenbytes der Botschaft.

Timeouts

Diese Spalte hat keine Bedeutung bei Sendelisten.

Zykluszeit

Das Zeitintervall, in dem eine Botschaft periodisch gesendet wird. Wurde die Botschaft mit einer Zykluszeit von 0 ms erzeugt, wird der Text Warte angezeigt, d.h. die Botschaft wird nicht periodisch gesendet.

Anzahl

Die Anzahl der gesendeten Botschaften seit dem letzten Ausführen des Reset-Befehls.

Trigger

Der Grund für das letzte Senden einer Botschaft. Folgende Gründe für das Senden einer Botschaft können angezeigt werden:

  • Manuell: Die Botschaft wurde manuell vom Benutzer gesendet.

  • Zeit: Die Botschaft wurde aufgrund der festgelegten Zykluszeit gesendet.

  • RTR: Die Botschaft wurde als Antwort auf einen empfangenen Remote Request Frame gesendet.

  • Makro: Die Botschaft wurde von einem Standardmakro gesendet.

  • Automation: Die Botschaft wurde von einem VBScript-Makro oder von einem externen Programm gesendet, das PCAN-Explorer als Automation Server betreibt.

  • RQST: Die Botschaft wurde als Antwort auf einen J1939-Request (PGN 59904) gesendet.

Zeit

Der Zeitpunkt, an dem die Botschaft zuletzt gesendet wurde.

Ersteller

Diese Spalte identifiziert den Erzeuger einer CAN-Botschaft.

Kommentar

Der Kommentar, der für die Botschaft vorgegeben wurde. Der Kommentartext kann im Eigenschaften-Fenster eingegeben werden, wenn die Botschaft in der Sendeliste ausgewählt ist.

Zusätzliche Spalten für das J1939-Protokoll

Diese Spalten werden nur dann angezeigt bzw. stehen nur dann zur Auswahl bereit, wenn das aktuelle Projekt mindestens eine Verbindung enthält, die das J1939-Protokoll verwendet.

PGN

Identifiziert die Parameter Group Number der Botschaft.

Getrennte Spalten können angezeigt werden, um die PGN in dezimaler und/oder hexadezimaler Schreibweise anzuzeigen.

Priorität

Die Priorität (0-7) der Botschaft.

Quelle

Die Quelladresse der Botschaft. Wird Null angezeigt, hat die Botschaft die Null-Adresse (254).

Getrennte Spalten können angezeigt werden, um die Quelladresse in dezimaler und/oder hexadezimaler Schreibweise anzuzeigen.

Ziel

Die Zieladresse der Botschaft. Wird Alle angezeigt, wird die Botschaft unter Verwendung der globalen Adresse 255 gesendet. Das bedeutet, die Botschaft wird als Broadcast an alle Empfänger gesendet. Wird Null angezeigt, hat die Botschaft die Null-Adresse (254).

Getrennte Spalten können angezeigt werden, um die Zieladresse in dezimaler und/oder hexadezimaler Schreibweise anzuzeigen.

Siehe auch

Symbole in Sendelisten

Arbeiten mit Sendelisten

Spalten auswählen-Dialogfenster


Error Frames in der Empfangsliste

Um Error Frames in der Empfangsliste anzuzeigen, aktivieren Sie die Eigenschaft Error Frames einer Verbindung im Eigenschaften-Fenster. Im Verbindungen-Fenster in der Spalte Optionen wird dann die Option EF für die Verbindung angezeigt.

Die Empfangsliste markiert einen erkannten Error Frame, indem sie die Art des Fehlers in der Spalte ID anzeigt:

  • Bit Error

  • Form Error

  • Stuff Error

  • Other Error

Für eine Beschreibung der verschiedenen Busfehler siehe NXP (vormals Philips) Application Note AN97076, "SJA1000 Stand-alone CAN controller", Abschnitt 5.2.3.

Wird der Text "Fehlerzähler" in der Spalte ID angezeigt, hat sich einer der Fehlerzähler RXERR oder TXERR im CAN-Controller verringert. Dies ist kein Error Frame, sondern informiert lediglich über geänderte Registerwerte.

Die Spalte Daten zeigt entweder den Text Fehler, oder weitere Informationen über den Error Frame. Ist die Option Zeige Detail-Informationen zu Error Frames im Optionen-Dialogfenster auf der Seite Senden/Empfangen aktiviert, zeigt diese Spalte zusätzliche Imformationen an, getrennt durch Kommas:

  • Tx oder Rx, falls der Fehler beim Senden oder beim Empfangen auftrat

  • Eine Beschreibung der Position des Fehlers auf dem Bus

  • Die Werte der Fehlerzählerregister RXERR und TXERR des CAN-Controllers.

Siehe auch

Anzeigen von Error Frames

Verbindungen-Fenster

Optionen-Dialogfenster

Empfangsliste


Spalten auswählen-Dialogfenster

Verwenden Sie dieses Dialogfenster, um die Spalten zu ändern, die in der Empfangs- oder Sendeliste angezeigt werden, und zur Auswahl der Spalten wenn Sie Daten aus den Empfangs-/Sendelisten oder einem Tracer exportieren.

Um das Dialogfenster anzuzeigen, klicken Sie beispielsweise mit der rechten Maustaste auf eine der Spaltenüberschriften der Empfangsliste, und wählen im Kontextmenü den Befehl Spalten anpassen.

Spalten

Führt alle verfügbaren Spaltentypen auf. Setzen Sie einen Haken in das Markierungsfeld vor dem Spaltennamen, um die Spalte auszuwählen.

Beschreibung

Zeigt eine kurze Beschreibung zu der ausgewählten Spalte an.

Nach oben

Bewegt die ausgewählte Spalte in der Liste Spalten aufwärts. Dadurch wird die Spalte in der Botschaftsliste oder beim Export nach links geschoben.

Nach unten

Bewegt die ausgewählte Botschaft in der Liste Spalten abwärts. Dadurch wird die Spalte in der Botschaftsliste oder beim Export nach rechts geschoben.

Um die Reihenfolge der Spalten zu ändern, können Sie eine Spalte auch mit der Maus anklicken und an eine andere Position in der Liste ziehen.

Siehe auch

Empfangsliste

Standard-Sendeliste


Signal- und Symbol-Elemente

Dieser Abschnitt enthält Informationen über alle Dialogfenster und sonstigen Elemente, die sich auf Signale und Symbole beziehen.

In diesem Abschnitt

Signal auswählen-Dialogfenster

Dient zur Auswahl eines Signals.

Überwachungen-Fenster

Ermöglicht das Überwachen von Signalwerten.

Variablen bearbeiten-Dialogfenster

Dient zum Verändern von Variablenwerten von CAN-Botschaften in Sendelisten.

Variablen untersuchen-Dialogfenster

Dient zum Untersuchen von Variablenwerten von CAN-Botschaften in der Empfangsliste.

Weitere Abschnitte

Signale

Beschreibt die Funktionsweise von Signalen und deren Verwendung in PCAN-Explorer.

Benutzeroberfläche

Enthält Referenzthemen für die verschiedenen Dialogfenster und weiterer Fenster von PCAN-Explorer.


Signal auswählen-Dialogfenster

Das Signal auswählen-Dialogfenster dient in verschiedenen Stellen in PCAN-Explorer zur Auswahl eines der verfügbaren Signale. Signale werden beispielsweise durch das Laden und Aktivieren einer Symboldatei erzeugt, oder von VBS-Makros.

Filter

Filtert die angezeigten Signale nach verschiedenen Kategorien:

  • Alle Signale: Alle verfügbaren Signale werden alphabetisch sortiert angezeigt.

  • CAN-Symbole: Führt alle Signale auf, die durch Aktivierung einer Symboldatei und der darin enthaltenen CAN-Variablen- bzw. Signaldefinitionen erzeugt wurden.

  • Virtuell: Führt nur virtuelle Signale bzw. Variablen auf, die keinem CAN-Symbol zugewiesen sind.

  • Bus n: Zeigt Signale, die zu einem bestimmten Bus mit der Bus-Nummer n gehören.

Anzeigen

Bestimmt, wie die Namen von Signalen in diesem Fenster angezeigt werden. Ist die Option Voreinstellung ausgewählt, wird das Anzeigeformat von der Voreinstellung im Optionen-Dialog bestimmt. Siehe auch Allgemein, Optionen-Dialogfenster, Anzeigemodus für Signalnamen.

Zum schnelleren Auffinden eines bestimmten Signals in der Liste drücken Sie die Tastenkombination [Strg+F], um nach bestimmten Signalnamen zu suchen. Während der Eingabe wird die Liste sofort gefiltert, Übereinstimmungen werden in den Signalnamen in der Liste markiert.

Siehe auch

Signale


Überwachungen-Fenster

Mit Hilfe des Überwachungen-Fensters können Sie die Werte einer Auswahl von Signalen überwachen. Um das Überwachungen-Fenster anzuzeigen, wählen Sie den Befehl Überwachungen aus dem Menü Ansicht. Das Überwachungen-Fenster enthält vier Registerkarten Watch 1, Watch 2, Watch 3 und Watch 4. Diese können Sie zum Gruppieren von überwachten Signalen verwenden.

Die folgenden Spalten können im Überwachungen-Fenster angezeigt werden:

Name

Enthält die Namen der überwachten Signale.

Wert

Zeigt die aktuellen Signalwerte an.

Zeit

Zeigt die Zeitpunkte an, zu der sich die Signalwerte zuletzt geändert haben. Ist keine Zeitangabe vorhanden, wurde der Signalwert entweder noch nicht manuell verändert, oder es wurde noch keine CAN-Botschaft empfangen oder gesendet, welche das Signal enthielt.

Balken

Zeigt grafische Darstellungen der Signalwerte als Balken an. Der Wertebereich der jeweiligen Balkenanzeige ergibt sich aus dem Datentyp und den definierten Minimum- und Maximum-Werten des entsprechenden Signals.

Typ

Zeigt die Datentypen der überwachten Signale an.

Kommentar

Enthält Kommentartexte, die den Signalen zugewiesen wurden.

Sie können Spalten ein- oder ausblenden, indem Sie das Kontextmenü des Überwachungen-Fensters verwenden (rechte Maustaste).

Um die Anordnung der Spalten zu verändern, ziehen Sie die Spaltenüberschriften mit der Maus an andere Positionen.

Um die vertikale Reihenfolge der Signale zu verändern, wählen Sie die Zeilen aus und drücken Sie entweder [Strg+Pfeil-Rauf] oder [Strg+Pfeil-Runter] auf der Tastatur, oder wählen Sie im Kontextmenü einen der Befehle Nach oben oder Nach unten.

Siehe auch

Überwachen von Signalen

Benutzeroberfläche


Variablen bearbeiten-Dialogfenster

Mit Hilfe des Variablen bearbeiten-Dialogfensters können Sie Variablenwerte von CAN-Botschaften ändern, die in Sendelisten aufgenommen wurden. Um dieses Dialogfenster anzuzeigen, wählen Sie den Befehl Variablen bearbeiten im Menü Ansicht oder dem Kontextmenü der Sendeliste.

Registerseite Variablen

Name

Diese Spalte zeigt die Namen der Variablen, die für diese CAN-Botschaft definiert wurden.

SPN

Falls die Botschaft eine J1939-Botschaft ist, zeigt diese Spalte die Suspect Parameter Numbers an, die den jeweiligen Variablen zugeordnet sind.

Wert

Diese Spalte zeigt die Werte der einzelnen Variablen an. Die Werte werden entsprechend der für sie definierten Anzeigeformate dargestellt.

Einheit

Zeigt die physikalische Einheit der Variablen.

Typ

Enthält die Datentypen der Variablen.

Wertebereich

Zeigt den Wertebereich der Variablen an. Falls ein eingegebener Variablenwert außerhalb des gültigen Bereichs liegt, wird eine Fehlermeldung angezeigt.

Um einen Variablenwert zu ändern, können Sie entweder mit der Maus in das Feld mit dem Wert doppelklicken, oder drücken Sie [F2] während die Liste den Eingabefokus besitzt und ein Wertefeld ausgewählt ist. Ein neuer Variablenwert kann in verschiedenen Formaten bzw. Zahlensystemen erfolgen, siehe Eingabesyntax verschiedener Werteformate.

Registerseite Rohdaten

Diese Registerseite ist nur sichtbar, wenn die Botschaft Variablen mit dem Datentyp "Raw" enthält. Solche Variablen können eine dynamische Datenlänge von bis zu 1785 Bytes haben. Auf dieser Registerseite können Sie die Datenbytes dieser Variablen mit Hilfe eines Hex-Editors verändern.

Variable

Wählt die Variable aus, die bearbeitet werden soll. Die Dropdownliste enthält alle Variablen der Botschaft, die den Datentyp "Raw" haben.

(Hex-Editor)

Im Hex-Editor können Sie die Datenbytes der ausgewählten Variable bearbeiten, indem Sie Hex-Werte oder Zeichen eingeben. Durch Drücken von [Tab] können Sie die Einfügemarke zwischen dem Hex-Bereich auf der linken, und der ASCII-Darstellung der Daten auf der rechten Seite hin- und herbewegen, wo Sie Zeichen anstatt von Hex-Codes eingeben können. Falls der Hex-Editor den Eingabefokus besitzt, können Sie ihn durch Drücken von [Strg+Tab] oder [Umsch+Strg+Tab] auf der Tastatur verlassen.

Die Hex-Editor-Anzeige kann mit Hilfe des Kontextmenüs angepasst werden. Sie können die Anzahl der Datenbytes auswählen, die in jeder Zeile (8, 10 oder 16) und in jeder Spalte (1, 2 oder 4) angezeigt werden.

Lädt die Daten aus einer Datei.

Speichert die Daten ein eine Datei.

Setzt alle Datenbytes zu Null.

Siehe auch

Symbole in Sendelisten

Eingabesyntax verschiedener Werteformate

Datentypen

Botschaft bearbeiten-Dialogfenster


Variablen untersuchen-Dialogfenster

Mit Hilfe des Variablen untersuchen-Dialogfensters können Sie Variablenwerte von CAN-Botschaften in der Empfangsliste untersuchen. Um dieses Dialogfenster anzuzeigen, wählen Sie den Befehl Variablen untersuchen im Menü Ansicht oder dem Kontextmenü der Empfangsliste.

Registerseite Variablen

Name

Diese Spalte zeigt die Namen der Variablen, die für diese CAN-Botschaft definiert wurden.

SPN

Falls die Botschaft eine J1939-Botschaft ist, zeigt diese Spalte die Suspect Parameter Numbers an, die den jeweiligen Variablen zugeordnet sind.

Wert

Diese Spalte zeigt die Werte der einzelnen Variablen an. Die Werte werden entsprechend der für sie definierten Anzeigeformate dargestellt.

Einheit

Zeigt die physikalische Einheit der Variablen.

Typ

Enthält die Datentypen der Variablen.

Wertebereich

Zeigt den Wertebereich der Variablen an.

Registerseite Rohdaten

Diese Registerseite ist nur sichtbar, wenn die Botschaft Variablen mit dem Datentyp "Raw" enthält. Solche Variablen können eine dynamische Datenlänge von bis zu 1785 Bytes haben. Auf dieser Registerseite können Sie die Datenbytes dieser Variablen mit Hilfe einer Anzeige in Form eines Hex-Editors untersuchen.

Variable

Wählt die anzuzeigende Variable aus. Die Dropdownliste enthält alle Variablen der Botschaft, die den Datentyp "Raw" haben.

(Hex-Editor)

Im Hex-Editor können Sie die Datenbytes der ausgewählten Variable untersuchen. Der Hex-Editor befindet sich im Schreibschutz-Modus, so dass Sie keine Datenbytes verändern können. Falls der Hex-Editor den Eingabefokus besitzt, können Sie ihn durch Drücken von [Strg+Tab] oder [Umsch+Strg+Tab] auf der Tastatur verlassen.

Die Hex-Editor-Anzeige kann mit Hilfe des Kontextmenüs angepasst werden. Sie können die Anzahl der Datenbytes auswählen, die in jeder Zeile (8, 10 oder 16) und in jeder Spalte (1, 2 oder 4) angezeigt werden.

Speichert die Daten in eine Datei.

Siehe auch

Symbole in der Empfangsliste

Datentypen


Tabelle der Tastenkombinationen

Die folgende Tabelle führt die Tastenkombinationen auf, die in der PCAN-Explorer Benutzeroberfläche vordefiniert sind:

Befehl-Alias | Tastenkombination | Beschreibung
ActivateConnectionsWindow | [Alt+5] | Aktiviert das Verbindungen-Fenster.
ActivateLibraryBrowser | [Alt+2] | Aktiviert das Fenster Bibliothek.
ActivateMacroStatusWindow | [Alt+7] | Aktiviert das Standardmakro-Statusfenster.
ActivateOutputWindow | [Alt+3] | Aktiviert das Ausgabe-Fenster.
ActivateProjectManager | [Alt+1] | Aktiviert den Projekt-Manager.
ActivateTimeoutsWindow | [Alt+6] | Aktiviert das Timeouts-Fenster.
ActivateToolsWindow | [Alt+8] | Aktiviert das Werkzeuge-Fenster.
ActivateWatchWindow | [Alt+4] | Aktiviert das Überwachungen-Fenster.
AddExistingItem | [Umsch+Alt+A] | Fügt dem Projekt ein bestehendes Element hinzu.
AddNewItem | [Umsch+Strg+A] | Fügt dem Projekt ein neues Element hinzu.
ClearAll | [Umsch+Esc] | Löscht den Inhalt eines Fensters.
Copy | [Strg+C] | Kopiert die Auswahl in die Zwischenablage.
Cut | [Strg+X] | Schneidet die Auswahl aus und kopiert deren Inhalt in die Zwischenablage.
Delete | [Entf] | Entfernt die Auswahl.
FileExport | [Strg+E] | Exportiert die momentan aktive Datei.
FileImport | [Strg+I] | Importiert Daten in das aktive Fenster oder Dokument.
FileNew | [Strg+N] | Erzeugt eine neue Datei.
FileOpen | [Strg+O] | Öffnet eine Datei.
FilePrint | [Strg+P] | Druckt die Datei.
FileSave | [Strg+S] | Speichert die momentan aktive Datei.
FileSaveAll | [Umsch+Strg+S] | Speichert alle offenen Dateien.
Find | [Strg+F] | Sucht einen angegebenen Text.
FindNext | [F3] | Sucht das nächste Vorkommen des gesuchten Texts.
FindPrevious | [Umsch+F3] | Sucht das vorherige Vorkommen des gesuchten Texts.
LogTimeouts | [Strg+L] | Aktiviert/deaktiviert die Aufzeichnung von Timeouts.
MacroRun | [Strg+M] | Started das in der Makro-Dropdownliste ausgewählte Makro.
MacroStop | [Umsch+Strg+M] | Stoppt ein laufendes Makro.
NewMessage | [Einfg] | Erzeugt eine neue Sendebotschaft.
Paste | [Strg+V] | Fügt den Inhalt der Zwischenablage an der Einfügemarke ein.
ProjectNew | [Umsch+Strg+N] | Erzeugt ein neues Projekt.
ProjectSettings | [Alt+F7] | Bearbeitet die Einstellungen des aktuellen Projekts.
Redo | [Strg+Y] | Wiederholt die zuvor zurückgenommene Aktion.
ResetHardware | [ZIRKUMFLEX] bzw. [^] | Setzt die angeschlossene CAN-Hardware zurück, löscht die Empfangsliste und setzt die Botschafts-Zähler in Sendelisten zurück.
SelectAll | [Strg+A] | Markiert das ganze Dokument.
Send | [Leertaste] | Sendet die ausgewählten Sendebotschaften.
ShowProperties | [Alt+Eingabe] | Bearbeitet die Eigenschaften der aktuellen Auswahl.
ShowReceiveTransmit | [Strg+R] | Zeigt das Senden/Empfangen-Fenster an.
ToggleFullScreen | [F11] | Zeigt das aktive Fenster im Vollbild-Modus an oder setzt die Fensteransicht zurück.
ToggleMessagePaused | [Pause] | Hält alle ausgewählten periodischen Sendebotschaften an oder setzt das Senden fort.
TracePlay | [F5] | Startet die Wiedergabe von CAN-Botschaften im aktiven Tracer.
TracePlayAll | [Umsch+F5] | Startet die Wiedergabe von CAN-Botschaften in allen Tracern.
TraceStart | [F9] | Startet die Aufzeichnung von CAN-Botschaften im aktiven Tracer.
TraceStartAll | [Umsch+F9] | Startet die Aufzeichnung von CAN-Botschaften in allen offenen Tracern.
TraceStartNew | [Strg+T] | Erzeugt einen neuen Tracer und startet die Aufzeichnung von CAN-Botschaften.
TraceStop | [F6] | Stoppt die Aufzeichnung von CAN-Botschaften im aktiven Tracer.
TraceStopAll | [Umsch+F6] | Stoppt die Aufzeichnung von CAN-Botschaften in allen offenen Tracern.
Undo | [Strg+Z] | Macht die letzte Aktion rückgängig.
XmtLoadSendSymbols | [Strg+Einfg] | Lädt alle Sendesymbole in die aktive Sendeliste.

Siehe auch

Anpassen von Tastenkombinationen

Verwenden von Tastenkombinationen

Tastatur, Optionen-Dialogfenster

PCAN-Explorer-Befehle


Tastaturbelegung-Fenster

Das Tastaturbelegung-Fenster stellt eine Liste aller Befehle dar, die in PCAN-Explorer verfügbar sind, und zeigt die Tastenkombinationen an, die den einzelnen Befehlen zugewiesen sind. Um das Tastaturbelegung-Fenster anzuzeigen, muss im Menü Hilfe der Befehl Tastaturbelegung ausgewählt werden.

Mit Hilfe der Dropdownliste oben im Fenster kann eine Kategorie ausgewählt werden, deren zugehörige Befehle angezeigt werden sollen.

Befehle mit Tastenkombination

Zeigt nur die Befehle an, denen eine Tastenkombination zugewiesen ist.

Alle Befehle

Zeit alle in PCAN-Explorer verfügbaren Befehle an.

Makros

Zeigt Befehle an, die von geladenen VBScript-Makros definiert wurden.

Add-ins

Zeigt Befehle an, die von geladenen Add-ins implementiert wurden.

Kopiert die Daten der ausgewählten Befehle als Text in die Zwischenablage. Soll der ganze Inhalt der Liste kopiert werden, können über die Tastenkombination [Strg+A] alle Befehle selektiert werden.

Zeigt die Hilfe zum Tastaturbelegung-Fenster an.

Befehlsliste

Die Befehlsliste zeigt alle Befehle der ausgewählten Kategorie an. Sie kann auf verschiedenste Weise sortiert werden, indem man die jeweiligen Spaltenüberschriften anklickt. Es kann jeweils zwischen aufsteigender und absteigender Sortierung gewechselt werden.

Befehl

Der angezeigte Name des Befehls, abhängig von der eingestellten Sprache der Benutzeroberfläche.

Alias

Der interne Name des Befehls, der unabhängig von der eingestellten Sprache der Benutzeroberfläche ist.

Taste

Die momentan zugewiesene Tastenkombination.

Beschreibung

Die Beschreibung des Befehls.

Siehe auch

Verwenden von Tastenkombinationen

Anpassen von Tastenkombinationen

Benutzeroberfläche


Tracer-Elemente

Dieser Abschnitt enthält Informationen über alle Dialogfenster und sonstiger Elemente, die sich auf Tracer beziehen.

In diesem Abschnitt

Trace-Fenster

Zeigt aufgezeichnete CAN-Botschaften tabellarisch an.

Weitere Abschnitte

Aufzeichnen von CAN-Botschaften

Enthält Themen über die Verwendung des Tracers.

Benutzeroberfläche

Enthält Referenzthemen für die verschiedenen Dialogfenster und weiterer Fenster von PCAN-Explorer.


Trace-Fenster

Das Trace-Fenster stellt ein Sichtfenster auf einen Datenpuffer mit aufgezeichneten CAN-Botschaften dar. Es können mehrere Trace-Fenster gleichzeitig geöffnet und verwendet werden, die mit Hilfe von Filtern verschiedene Botschaften aufzeichnen können.

Symbolleiste

Das Trace-Fenster enthält eine Symbolleiste am oberen Rand, mit der Sie den Tracer steuern können.

Schaltfläche | Befehl | Beschreibung
 | Trace Start | Startet die Aufzeichnung von CAN-Botschaften in diesem Tracer.
 | Trace Pause | Unterbricht die Aufzeichnung von CAN-Botschaften in diesem Tracer.
 | Trace Stopp | Stoppt die Aufzeichnung von CAN-Botschaften in diesem Tracer.
 | Trace Wiedergabe | Startet die Wiedergabe von CAN-Botschaften in diesem Tracer.
 | Trace Wiederholung | Falls aktiviert, beginnt das Abspielen der Trace-Datei am Ende wieder von vorne.

Filter

Die Filter-Dropdownliste ermöglicht die Auswahl eines Botschaftsfilters für den Tracer. Wenn Sie einen Filter ausgewählt haben, werden nur die Botschaften vom Tracer aufgezeichnet, die den Filter passieren können. Die Dropdownliste enthält alle Botschaftsfilter des aktuellen Projekts (siehe Projekt-Manager, Botschaftsfilter-Knoten auf der Registerseite Projekt-Elemente). Falls der ausgewählte Filter deaktiviert ist, können alle empfangenen Botschaften den Filter passieren.

Symbol | Beschreibung
 | Kein Filter ausgewählt.
 | Ein aktivierter Filter.
 | Ein deaktivierter Filter.

Die Schaltflächen neben der Dropdownliste haben die folgende Bedeutung:

Schaltfläche

Beschreibung

Bearbeitet den ausgewählten Filter, öffnet das Filter bearbeiten-Dialogfenster.

Fügt einen neuen Botschaftsfilter zum aktuellen Projekt hinzu und zeigt das Filter bearbeiten-Dialogfenster an.

Wendet entweder den ausgewählten Filter auf den Trace an, oder öffnet eine Auswahlliste mit verschiedenen vordefinierten Filterfunktionen, um den Inhalt nachträglich zu filtern. Das Ergebnis wird in einem neuen Trace-Fenster angezeigt. Diese Aktion ist nur möglich, wenn die Aufzeichnung unterbrochen oder angehalten wurde.

Das Anwenden eines Filters erzeugt immer ein neuen Trace im Arbeitsspeicher, deshalb sollte beim Filtern von großen Trace-Dateien mit Bedacht vorgegangen werden. Eventuell sollten Sie die zu filternde Trace-Datei vorher in mehrere kleinere Dateien aufspalten. Ein Werkzeug zum Aufspalten von Trace-Dateien können Sie über unsere Webseite unter Support/Downloads herunterladen: PEAK-Trace Splitter

Spalten in der Trace-Ansicht

Zeit

Diese Spalte zeigt die Zeitstempel der CAN-Botschaften an. Je nach gewähltem Zeitstempel-Format werden die Zeitstempel entweder relativ, absolut oder differenziell angezeigt. Zur Umschaltung drücken Sie in der Spaltenüberschrift die zweite Maustaste und wählen Sie die entsprechende Option. Siehe auch Tracer, Projekteinstellungen-Dialogfenster, Einstellung Zeitstempel.

Bus

Zeigt die Bus-Nummer der Verbindung an, zu der jede Botschaft gehört.

ID / Symbol

Diese Spalte zeigt die CAN-IDs der Botschaften an. Falls eine Symboldatei für eine Verbindung geladen wurde, werden hier auch die Namen von Symbolen angezeigt, falls für CAN-Botschaften passende Symbole definiert worden sind. CAN-IDs können in hexadezimaler oder dezimaler Form angezeigt werden. Zur Umschaltung drücken Sie in der Spaltenüberschrift die zweite Maustaste und wählen Sie die entsprechende Option.

Rx/Tx

Diese Spalte gibt die Übertragungsrichtung an:

  • Rx: Die CAN-Botschaft wurde empfangen.

  • Tx: Die CAN-Botschaft wurde gesendet.

Typ

Diese Spalte zeigt die Typen der aufgezeichneten Botschaften an:

  • Daten: Daten-Frame.

  • FD: CAN-FD Daten-Frame (0-64 Datenbytes).

  • FD,BRS: CAN-FD Daten-Frame mit gesetztem Bit Rate Switch (Übertragung der Datenbytes mit höherer Bitrate).

  • FD,ESI: CAN-FD Daten-Frame mit gesetztem Error State Indicator.

  • FD,BRS,ESI: CAN-FD Daten-Frame mit Bit Rate Switch (Übertragung der Datenbytes mit höherer Bitrate) und gesetztem Error State Indicator.

  • RTR: Remote Transmission Request.

  • Status: Ein Hardware-Status.

  • Fehler: Ein Error Frame wurde auf dem Bus erkannt.

  • Fehlerz.: Zeigt Änderungen der Werte von Empfangs- und Sendefehlerzählern im CAN-Controller an.

DLC / Länge

Diese Spalte zeigt entweder die Data Length Codes oder die Anzahl der Datenbytes der aufgezeichneten Botschaften. Die Darstellung kann zwischen DLC und Datenlänge umgeschaltet werden, indem man in der Spaltenüberschrift die zweite Maustaste drückt und die entsprechende Option auswählt.

Daten

Zeigt die Datenbytes der aufgezeichneten Botschaften an. Die Darstellung kann zwischen hexadezimal, dezimal oder ASCII umgeschaltet werden, indem man in der Spaltenüberschrift die zweite Maustaste drückt und die entsprechende Option auswählt.

Stellt die Botschaft ein Error Frame dar, enthält diese Spalte zusätzliche Informationen über den Error Frame. RxErr und TxErr-Werte zeigen die Inhalte der Empfangs- und Sende-Fehlerzähler des CAN-Controllers.

J1939-spezifische Spalten

J1939-spezifische Spalten werden angezeigt, falls das aktive Projekt Verbindungen enthält, die das J1939-Protokoll verwenden. Ist ein Filter für den Tracer ausgewählt, der so konfiguriert ist, dass er Botschaften von J1939-Verbindungen blockiert, werden die J1939-spezifischen Spalten nicht angezeigt.

Prio

Zeigt die Priorität der J1939-Botschaft.

PGN

Die Parameter Group Number der Botschaft. Die Darstellung kann zwischen hexadezimal und dezimal umgeschaltet werden, indem man in der Spaltenüberschrift die zweite Maustaste drückt und die entsprechende Option auswählt.

SA

Die Quelladresse, die vom Absender der Botschaft angegeben wurde. Die Darstellung kann zwischen hexadezimal und dezimal umgeschaltet werden, indem man in der Spaltenüberschrift die zweite Maustaste drückt und die entsprechende Option auswählt.

DA

Die Zieladresse, die vom Absender der Botschaft festgelegt wurde. Die Darstellung kann zwischen hexadezimal und dezimal umgeschaltet werden, indem man in der Spaltenüberschrift die zweite Maustaste drückt und die entsprechende Option auswählt.

Wird beim Starten einer Aufzeichnung ein neues Trace-Fenster geöffnet, wird im Hintergrund gemäß den Einstellungen im Optionen-Dialogfenster ein Datenpuffer angelegt. Je nach Größe des Puffers kann dies einen Moment in Anspruch nehmen. Nachdem der Puffer angelegt worden ist, beginnt umgehend die Aufzeichnung von CAN-Botschaften.

Ein Trace-Fenster kann auch Timing-Fehler anzeigen, falls eine Symboldatei für eine Verbindung geladen wurde. Eine Botschaft, für die ein Timing-Fehler festgestellt wurde, wird per Voreinstellung mit roter Schrift angezeigt. Die Schrift- und Hintergrundfarben, die für die Anzeige von Timing-Fehler verwendet werden, können im Optionen-Dialogfenster eingestellt werden.

Statuszeile

Die Statuszeile des Trace-Fensters zeigt folgende Informationen an, von links nach rechts:

Startzustand

Gibt Auskunft, ob der Tracer angehalten, gestartet, unterbrochen etc. ist.

Typ des Puffers

Zeigt an, ob der Datenpuffer linear, ringförmig, dynamisch oder als Datei konfiguriert wurde. Siehe Tracer, Projekteinstellungen-Dialogfenster, Einstellung Puffertyp.

Aufnahmezeit

Zeitdauer zwischen dem Start der Aufzeichnung und dem Zeitpunkt der letzten aufgezeichneten Botschaft.

Füllstand

Der aktuelle Füllstand des Puffers in Prozent (nur bei den Puffertypen Linear und Ring).

Rx

Die Anzahl der empfangenen Botschaften.

Tx

Die Anzahl der gesendeten Botschaften.

Status

Die Anzahl der Änderungen des Hardware-Status.

Fehler

Die Anzahl der Error Frames.

Datei-Überschreibungswarnung

Ist ein Tracer mit Puffertyp Datei geöffnet, der bereits aufgezeichnete Daten enthält, kann unterhalb der Symbolleiste eine Warnung angezeigt werden, die vor dem unbeabsichtigten Überschreiben der Datei warnt. Das Ausführen des Befehls Start für den Tracer würde neue Daten sofort in die momentan geöffnete Trace-Datei schreiben, im Gegensatz zu den Puffertypen Dynamisch, Linear und Ring, die zuerst in den Arbeitsspeicher aufzeichnen.

Sie können die angezeigte Warnmeldung durch Anklicken von [image] für die Laufzeit des Programms ausblenden. Um die Meldung dauerhaft auszublenden, drücken Sie auf der Warnung entweder die rechte Maustaste und wählen Sie den Befehl Warnung dauerhaft deaktivieren, oder deaktivieren Sie die Option Zeige Überschreiben-Warnung für Tracer mit Puffertyp Datei im Optionen-Dialogfenster, siehe Trace-Fenster, Optionen-Dialogfenster.

Siehe auch

Aufzeichnen von CAN-Botschaften

Tracer, Projekteinstellungen-Dialogfenster

Tracer, Optionen-Dialogfenster

Trace-Fenster, Optionen-Dialogfenster

Schriftarten und Farben, Optionen-Dialogfenster


Andere Elemente der Benutzeroberfläche

Dieser Abschnitt der Online-Hilfe behandelt Elemente der Benutzeroberfläche, die zu keinen der anderen Kategorien zugeordnet werden können.

In diesem Abschnitt

Callback-Bibliothek-Fenster

Konfiguriert die Ausführung von Funktionen aus externen Funktionsbibliotheken für verschiedene Ereignisse.

Linienschreiber

Beschreibt den PCAN-Explorer-Linienschreiber, einen einfachen 4-Kanal Datenschreiber.

Weitere Abschnitte

Benutzeroberfläche

Enthält Referenz-Themen für die verschiedenen Dialogfenster und anderer Fenster von PCAN-Explorer.


Callback-Bibliothek-Fenster

Mit Hilfe des Callback-Bibliothek-Fensters können Sie Funktionen aus externen Funktionsbibliotheken (DLLs) zu verschiedenen Ereignisse zuweisen, so dass diese dann beim Eintreten der Ereignisse aufgerufen werden. Auf diese Weise können z.B. Daten von CAN-Botschaften ausgewertet oder auch verändert werden.

Um das Callback-Bibliothek-Fenster anzuzeigen, markieren Sie eine Callback-Bibliothek Ihres Projekts im Projekt-Manager auf der Registerseite Projektdateien, und führen Sie dann den Befehl Öffnen aus dem Kontextmenu aus.

Folgende Informationen werden im Callback-Bibliothek-Fenster angezeigt:

DLL-Information

Zeigt verschiedene Informationen über die DLL an, wie die Dateiversion und andere Werte aus der Versionsinformations-Ressource der Datei, Zeit und Datum der letzten Änderung, Dateigröße, und Anzahl der exportierten DLL-Funktionen.

Aktiviere Callback-Funktionen

Nur wenn diese Option aktiviert ist, werden beim Eintreten der verschiedenen Ereignisses die zugeordneten Callback-Funktionen aufgerufen.

Registerkarte Allgemein

Hier sind alle Ereignisse aufgeführt, die im Zusammenhang mit der Callback-Bibliothek selbst stehen. In der Spalte DLL-Funktion können Sie durch Aufklappen der Dropdownliste jedem Ereignis eine DLL-Funktion zuordnen. Die Dropdownliste bietet alle Funktionen zur Auswahl, die von der DLL exportiert werden.

On Enable

Tritt auf, wenn die Callback-Bibliothek aktiviert wird.

On Disable

Tritt auf, wenn die Callback-Bibliothek deaktiviert wird.

Registerkarten Senden

Hier sind alle Ereignisse aufgeführt, die im Zusammenhang mit Sendebotschaften ausgelöst werden. In der Spalte DLL-Funktion können Sie durch Aufklappen der Dropdownliste jedem Ereignis eine DLL-Funktion zuordnen. Die Dropdownliste bietet alle Funktionen zur Auswahl an, die von der DLL exportiert werden.

On Before Transmit

Tritt auf, bevor eine Sendebotschaft gesendet wird.

On After Transmit

Tritt auf, nachdem eine Sendebotschaft gesendet wurde.

On Resume

Tritt auf, wenn das zyklische Senden einer Sendebotschaft fortgesetzt wird.

On Pause

Tritt auf, wenn das zyklische Senden einer Sendebotschaft unterbrochen wird.

On Reset

Tritt für jede Sendebotschaft auf, wenn der Befehl Zurücksetzen ausgeführt wurde.

Registerkarten Empfangen

Hier sind alle Ereignisse aufgeführt, die im Zusammenhang mit Empfangsbotschaften ausgelöst werden. In der Spalte DLL-Funktion können Sie durch Aufklappen der Dropdownliste jedem Ereignis eine DLL-Funktion zuordnen. Die Dropdownliste bietet alle Funktionen zur Auswahl, die von der DLL exportiert werden.

On Receive

Wird für eine empfangene Botschaft aufgerufen.

On Timing Error

Wird für eine empfangene Botschaft aufgerufen, wenn ein Timing-Fehler erkannt wurde, also entweder ein Timeout überschritten oder eine Minimum-Intervall unterschritten wurde.

Achtung

Die Dropdownlisten bieten alle exportierten DLL-Funktionen zu Auswahl an, unabhängig davon, ob die jeweilige Funktion das passende Format besitzt. Achten Sie bei der Auswahl einer Funktion darauf, dass diese sowohl die richtige Aufrufkonvention verwendet, als auch den korrekten Aufrufparameter besitzt und den passenden Rückgabewert liefert. Der Aufruf von unpassenden DLL-Funktionen kann zu unvorhersehbaren Programmfehlern führen, im schlimmsten Fall zum Absturz von PCAN-Explorer.

Siehe auch

Benutzeroberfläche


Linienschreiber

Der Linienschreiber erlaubt die visuelle Darstellung des zeitlichen Verlaufs von bis zu 4 Signalen. Das Linienschreiber Add-in ist ein standardmäßig beigefügtes Add-in, das nicht einzeln käuflich zu erwerben ist.

Um ein neues Linienschreiber-Fenster anzuzeigen, wählen Sie im Menü Werkzeuge das Untermenü Line Writer und dann den Befehl Anzeigen.

Symbolleiste

Kanalauswahl

Wählt den Kanal, der in der Skala auf der linken Seite angezeigt wird.

Löschen

Löscht die Zuordnung des Signals zu dem ausgewählten Kanal.

Signal auswählen

Zeigt eine Liste von Signalen an, die dem Kanal zugeordnet werden können.

Eigenschaften

Zeigt das Eigenschaften-Dialogfenster des Linienschreibers an.

Start

Startet eine Aufzeichnung.

Stopp

Stoppt eine Aufzeichnung.

(Zoom-Stufe)

Zeigt die momentan gewählte Zoom-Stufe der Y-Achse an.

Zeichenbereich

Kanal aktivieren/deaktivieren

Aktiviert oder deaktiviert die einzelnen Kanäle.

Y-Achse nach oben

Verschiebt den sichtbaren Bereich der Y-Achse nach oben.

Y-Zoom-Stufe erhöhen

Erhöht die Zoom-Stufe der Y-Achse.

Y-Achse zurücksetzen

Setzt die Zoom-Stufe und die Verschiebung der Y-Achse zurück.

Y-Zoom-Sstufe verkleinern

Verkleinert die Zoom-Stufe der Y-Achse.

Y-Achse nach unten

Verschiebt den sichtbaren Bereich der Y-Achse nach unten.


PCAN-Explorer-Referenz

Befehle

PCAN-Explorer-Befehle

Leitseite (Referenz)

PCAN-Explorer-Befehle erlauben eine direkte Interaktion mit der Benutzerobefläche, beispielsweise über Tastenkombinationen oder VBScript-Makros.

Eine Liste aller verfügbaren Befehle und ihrer momentan zugewiesenen Tastenkombinationen befindet sich im Fenster Tastaturbelegung.

Befehl-Alias

Jeder Befehl hat einen Namen, der auch in den verschiedenen Menüs der Benutzeroberfläche angezeigt wird. Der Alias eines Befehls ist der interne Name des Befehls, der auch unabhängig von der eingestellten Sprache der Benutzeroberfläche ist.

Befehle

Die folgende Liste führt alle Befehle auf, die in PCAN-Explorer vordefiniert sind, sortiert nach dem Alias.

Name des Befehls | Alias | Beschreibung
Verbindungen | ActivateConnectionsWindow | Aktiviert das Verbindungen-Fenster.
Bibliothek | ActivateLibraryBrowser | Aktiviert das Bibliotheks-Fenster.
Makro-Status | ActivateMacroStatus | Aktiviert das Standardmakro-Statusfenster.
Ausgabe | ActivateOutputWindow | Aktiviert das Augabe-Fenster.
Projekt-Manager | ActivateProjectManager | Aktiviert den Projekt-Manager.
Werkzeuge | ActivateToolsWindow | Aktiviert das Werkzeuge-Fenster.
Timing-Fehler | ActivateTimingWindow | Aktiviert das Timing-Fehler-Fenster.
Überwachungen | ActivateWatchWindow | Aktiviert das Überwachungen-Fenster.
Verbindung hinzufügen | AddConnection | Fügt dem Projekt eine neue Verbindung hinzu.
Bestehendes Element hinzufügen | AddExistingItem | Fügt dem Projekt ein bestehendes Element hinzu.
Add-in Manager | AddInManager | Zeigt das Add-in Manager-Dialogfenster an.
Botschaftsfilter hinzufügen | AddMessageFilter | Fügt dem Projekt einen neuen Botschaftsfilter hinzu.
Neues Element hinzufügen | AddNewItem | Fügt dem Element ein neues Element hinzu.
Beenden | ApplicationExit | Beendet das Programm.
Vollbildmodus beenden | CancelFullScreen | Beendet den Vollbildmodus.
Adresse anfordern | ClaimAddress | Fordert eine J1939-Adresse an.
Alles löschen | ClearAll | Löscht den Inhalt eines Fensters.
Auskommentieren | Comment | Stellt einem selektierten Text Kommentarzeichen voran.
Kopieren | Copy | Kopiert die ausgewählten Elemente in die Zwischenablage.
Ausschneiden | Cut | Schneidet die ausgewählten Elemente aus und kopiert sie in die Zwischenablage.
Löschen | Delete | Löscht die ausgewählten Elemente.
Botschaft bearbeiten | EditMessage | Zeigt das Botschaft bearbeiten-Dialogfenster an.
Variablen bearbeiten | EditVariables | Zeigt das Variablen bearbeiten-Dialogfenster an.
Mit dem Symbol Editor bearbeiten | EditWithSymbolEditor | Öffnet die Symboldatei im aktiven Textfenster mit dem PCAN Symbol Editor.
Externe Werkzeuge | ExternalTools | Passt das Werkzeuge-Menü an, zeigt das Externe Werkzeuge-Dialogfenster an.
Anwenden | FileApply | Prüft den Quellcode im aktiven Textfenster auf Fehler und übernimmt die Änderungen.
Schließen | FileClose | Schließt das aktive Fenster bzw. Dokument.
Alle schließen außer diesem | FileCloseAllButThis | Schließt alle Fenster außer dem aktiven Fenster.
Exportieren | FileExport | Exportiert das aktive Dokument in ein anderes Dateiformat.
Importieren | FileImport | Importiert Daten in das aktive Fenster oder Dokument.
Neu | FileNew | Erzeugt ein neues Dokument.
Öffnen | FileOpen | Öffnet eine Datei.
Drucken | FilePrint | Druckt ein Dokument.
Speichern | FileSave | Speichert das aktive Dokument.
Alle speichern | FileSaveAll | Speichert alle offenen Dateien.
Speichern als | FileSaveAs | Speichert das aktive Dokument unter einem anderen Namen.
Suchen | Find | Sucht nach Text.
Weitersuchen | FindNext | Zeigt die nächste Übereinstimmung mit dem gesuchten Text an.
Rückwärts suchen | FindPrevious | Zeigt die vorherige Übereinstimmung mit dem gesuchten Text an, in Richtung Textanfang.
Über | HelpAbout | Zeigt das Über PCAN-Explorer-Dialogfenster an.
Hilfe Inhalt | HelpContents | Zeigt das Inhaltsverzeichnis der PCAN-Explorer-Dokumentation an.
Hilfe Index | HelpIndex | Zeigt den Index der PCAN-Explorer-Dokumentation an.
Tastaturbelegung | HelpKeyboard | Zeigt eine Tabelle aller PCAN-Explorer-Befehle an sowie die jeweils zugewiesenen Tastenkombinationen.
Hilfe Suchen | HelpSearch | Erlaubt eine Suche in der PCAN-Explorer-Dokumentation.
Zum Anfang | Home | Bewegt die Einfügemarke entweder an den Anfang der Zeile oder an den Anfang von Text in der Zeile.
Bis zum Anfang markieren | HomeExtend | Erweitert die Auswahl entweder bis zum Anfang der Zeile oder bis zum Anfang von Text in der Zeile.
Sendeliste importieren | ImportTransmitList | Importiert eine Sendelistendatei in die Sendeliste im Senden/Empfangen-Fenster.
Zeileneinzug vergrößern | Indent | Vergrößert den Zeileneinzug des ausgewählten Textes.
Variablen untersuchen | InspectVariables | Öffnet ein Dialogfenster zum Untersuchen der Variablen.
Lizenzinformation | LicenseInfo | Zeigt ein Dialogfenster an, das detaillierte Lizenzinformationen enthält.
Timing-Fehler aufzeichnen | LogTimingErrors | Aktiviert oder deaktiviert die Aufzeichnung von Timing-Fehlern.
Makro | Macro | Zeigt das Makro-Dialogfenster an.
Makro hinzufügen | MacroAdd | Fügt ein neues Makro hinzu.
Makro bearbeiten | MacroEdit | Bearbeitet das ausgewählte Makro.
Makrodatei neu laden | MacroReloadFile | Lädt die Makrodatei neu, die gerade im Texteditor geföffnet ist.
Makro starten | MacroRun | Started das in der Makro-Dropdownliste ausgewählte Makro.
Makro stoppen | MacroStop | Stoppt ein laufendes Makro.
In Kleinbuchstaben umwandeln | MakeLowercase | Wandelt den ausgewählten Text in Kleinbuchstaben um.
In Großbuchstaben umwandeln | MakeUppercase | Wandelt den ausgewählten Text in Großbuchstaben um.
Empfangsliste maximieren | MaximizeReceiveList | Maximiert die Empfangsliste im Senden/Empfangen-Fenster.
Sendeliste maximieren | MaximizeTransmitList | Maximiert die Sendeliste im Senden/Empfangen-Fenster.
Neue Botschaft | NewMessage | Erzeugt eine neue Sendebotschaft, zeigt das Botschaft bearbeiten-Dialogfenster an.
Einfügen | Paste | Fügt den Inhalt der Zwischenablage an der Einfügemarke ein.
Alle anhalten | PauseAllMessages | Hält alle periodischen Sendebotschaften in der aktiven Sendeliste an.
Projekt schließen | ProjectClose | Schließt das aktuelle Projekt.
Neues Projekt | ProjectNew | Erzeugt ein neues Projekt.
Projekt öffnen | ProjectOpen | Öffnet ein bestehendes Projekt.
Projekt speichern | ProjectSave | Speichert das aktuelle Projekt.
Projekt speichern unter | ProjectSaveAs | Speichert das aktuelle Projekt unter einem anderen Namen.
Einstellungen | ProjectSettings | Bearbeitet die Einstellungen des aktuellen Projekts, zeigt das Projekteinstellungen-Dialogfenster an.
Wiederholen | Redo | Wiederholt eine zuvor zurückgenommene Aktion.
Adresse freigeben | ReleaseAddress | Gibt eine zuvor angeforderte J1939-Adresse frei.
Alle Zähler zurücksetzen | ResetAllCounters | Setzt die Zähler aller Sendebotschaften zurück.
Zähler zurücksetzen | ResetCounter | Setzt die Zähler der ausgewählten Sendebotschaften zurück.
Zurücksetzen | ResetHardware | Setzt die angeschlossene CAN-Hardware zurück, löscht die Empfangsliste und setzt die Botschafts-Zähler in Sendelisten zurück.
Botschafts-Listen wiederherstellen | RestoreMessageLists | Stellt sicher, dass sowohl Empfangsliste als auch Sendeliste im Senden/Empfangen-Fenster sichtbar sind.
Alle fortsetzen | ResumeAllMessages | Setzt das periodische Senden aller Sendebotschaften in der aktiven Sendeliste fort.
Alles markieren | SelectAll | Wählt den Inhalt des ganzen Dokuments aus.
Senden | Send | Sendet die ausgewählten Sendebotschaften.
Eigenschaften | ShowProperties | Zeigt das Eigenschaften-Fenster an.
Senden/Empfangen | ShowReceiveTransmit | Zeigt das Senden/Empfangen-Fenster an.
Startseite | ShowStartPage | Zeigt die Startseite an.
Verbindungen | ToggleConnectionsWindow | Zeigt das Verbindungen-Fenster an oder blendet es aus.
Vollbild | ToggleFullScreen | Zeigt das aktive Fenster im Vollbildmodus an oder setzt die Fensteransicht zurück.
Bibliothek An/Aus | ToggleLibraryTrowser | Zeigt den Bibliotheks-Browser an oder blendet ihn aus.
Makrostatus An/Aus | ToggleMacroStatusWindow | Zeigt das Makrostatus-Fenster an oder blendet es aus.
Anhalten / Fortsetzen | ToggleMessagePaused | Hält alle ausgewählten periodischen Sendebotschaften an oder setzt das Senden fort.
Ausgabe An/Aus | ToggleOutputWindow | Zeigt das Ausgabe-Fenster an oder blendet es aus.
Projekt-Manager An/Aus | ToggleProjectManager | Zeigt den Projekt-Manager an oder blendet ihn aus.
Timing-Fehler An/Aus | ToggleTimingWindow | Zeigt das Timing-Fehler-Fenster an oder blendet es aus.
Überwachungen An/Aus | ToggleWatchWindow | Zeigt das Überwachungen-Fenster an oder blendet es aus.
Anpassen | ToolsCustomize | Passt Einstellungen der Toolbars an, zeigt das Anpassen-Dialogfenster.
Optionen | ToolsOptions | Zeigt das Optionen-Dialogfenster an.
Alle Tracer unterbrechen | TracePauseAll | Unterbricht die Aufzeichnung von CAN-Botschaften in allen offenen Tracern.
Alle Tracer starten | TraceStartAll | Startet die Aufzeichnung von CAN-Botschaften in allen offenen Tracern.
Neuen Tracer starten | TraceStartNew | Erzeugt einen neuen Tracer und startet die Aufzeichnung von CAN-Botschaften.
Alle Tracer stoppen | TraceStopAll | Stoppt die Aufzeichnung von CAN-Botschaften in allen offenen Tracern.
Entkommentieren | Uncomment | Entfernt führende Kommentarzeichen aus der aktuellen Textauswahl.
Rückgängig | Undo | Macht die letzte Aktion rückgängig.
Zeileneinzug verkleinern | Unindent | Verkleinert den Zeileneinzug des ausgewählten Textes.
 | UserTool1..16 | Aktiviert ein benutzerdefiniertes Werkzeug.
VBS-Makro Manager | VBSMacroManager | Öffnet das VBS-Makro Manager Dialogfenster.
Überlappend | WindowCascade | Ordnet die Fenster überlappend an.
Schließen | WindowClose | Schließt ein Fenster.
Alle Dokumente schließen | WindowCloseAllDocuments | Schließt alle geöffneten Dokumente.
Andockbar | WindowDockable | Macht das Fenster zu einem andockbaren Werkzeug-Fenster.
Schwebend | WindowFloating | Macht das Fenster zu einem schwebenden Werkzeug-Fenster, das nicht angedockt werden kann.
Ausblenden | WindowHide | Blendet ein Werkzeug-Fenster aus.
Maximieren | WindowMaximize | Maximiert ein Fenster.
Nächstes | WindowNext | Aktiviert das nächste Dokument-Fenster der Registerkartenleiste.
Vorheriges | WindowPrevious | Aktiviert das vorherige Dokument-Fenster der Registerkartenleiste.
Wiederherstellen | WindowRestore | Stellt den nichtmaximierten Zustand eines Fensters wieder her.
Fenster mit Registerkarte | WindowTabbed | Macht ein Fenster zu einem Fenster mit Registerkarte.
Übereinander | WindowTileHorizontal | Ordnet die Fenster nicht überlappend übereinander an.
Nebeneinander | WindowTileVertical | Ordnet die Fenster nicht überlappend nebeneinander an.
Lade Sendesymbole | XmtLoadSendSymbols | Lädt alle Sendesymbole in die aktive Sendeliste.


Anwenden-Befehl

Testet den aktiven Quellcode auf Fehler und übernimmt Änderungen.

Symbol

Menü

Datei | Anwenden

Tastenkombination

Keine.

Bemerkungen

Der Anwenden-Befehl kann in Verbindung mit den folgenden Dateitypen verwendet werden:

  • Symboldateien

Wird der Befehl Anwenden auf Symboldateien angewendet, wird die Symboldatei übersetzt und auf Fehler geprüft. Falls die Datei keine Fehler enthält, wird sie aktiviert, indem sie einer oder mehreren Verbindungen des Projekts zugewiesen wird. Eine Symboldatei muss Teil des aktuellen Projekts sein, bevor sie aktiviert werden kann. Falls die Datei noch nicht in das aktuelle Projekt aufgenommen wurde, wird ein Dialogfenster angezeigt.

Falls die Datei Fehler enthält, wird eine entsprechende Fehlermeldung im Ausgabe-Fenster angezeigt und die entsprechende Stelle im Quellcode markiert.

  • Standardmakros

Wird der Befehl Anwenden auf Standardmakros angewendet, wird der Quellcode übersetzt und auf Fehler überprüft. Falls die Übersetzung erfolgreich ist, wird das Makro in die Makro-Dropdownliste in der Symbolleiste aufgenommen, und kann nun gestartet werden.

Falls die Datei Fehler enthält, wird eine entsprechende Fehlermeldung im Ausgabe-Fenster angezeigt und die entsprechende Stelle im Quellcode markiert.

  • VBScript-Makros

Wird der Befehl Anwenden auf VBScript-Makros angewendet, wird der Quellcode übersetzt und auf Fehler überprüft. Falls die Datei keine Fehler enthält, werden alle Makroprozeduren in der Datei in die Makro-Dropdownliste in der Symbolleiste aufgenommen.

Tritt während der Überprüfung ein Fehler auf, wird eine entsprechende Fehlermeldung angezeigt.

Hinweis

Wird der Befehl Anwenden auf eine Datei angewendet, wird die Datei per Voreinstellung automatisch gespeichert. Diese automatische Speicherfunktion kann im Optionen-Dialogfenster auf der Seite Dokumente konfiguriert werden.

Siehe auch

Erstellen und Aktivieren von Symboldateien

PCAN-Explorer-Befehle


Zurücksetzen-Befehl

Der Zurücksetzen-Befehl führt folgende Aufgaben aus:

  • Setzt ein- oder mehrere verbundene CAN-Hardware zurück.

  • Löscht die Empfangsliste, falls die entsprechende Option im Optionen-Dialogfenster auf der Seite Senden/Empfangen aktiviert ist.

  • Setzt die Zähler und Zeitangaben in Empfangs- und Sendelisten zurück, falls die entsprechende Optionen im Optionen-Dialogfenster auf der Seite Senden/Empfangen aktiviert sind.

  • Setzt die Signalwerte auf ihre Default-Werte zurück, falls die entsprechende Option im Optionen-Dialogfenster auf der Seite Allgemein aktiviert ist.

Symbol

Menü

Verbindungen | Zurücksetzen

Tastenkombination

Die Tastenkombination für diesen Befehl hängt von der verwendeten Tastatursprache ab. Auf einer englischen Tastatur ist die Taste [\] dem Befehl zugewiesen. Auf einer deutschen Tastatur ist die Taste [ZIRKUMFLEX] dem Befehl zugewiesen, die der Taste [^] entspricht. Bei anderen Tastatursprachen öffnen Sie das Menü Verbindungen und lesen Sie die zugewiesene Taste aus dem Menüeintrag des Zurücksetzen-Befehls ab.

Bemerkungen

Beim Ausführen des Zurücksetzen-Befehls werden nur die Verbindungen zurückgesetzt, deren Eigenschaft In Zurücksetzen einbinden aktiviert ist. Über das Dropdown-Menü der Zurücksetzen-Schaltfläche in der Symbolleiste können Sie ebenfalls auswählen, welche Verbindungen in den Zurücksetzen-Befehl eingebunden werden sollen.

Siehe auch

PCAN-Explorer-Befehle

Optionen-Dialogfenster


Symboldateien

Symboldateien

Leitseite (Referenz)

In Symboldateien werden Definitionen getroffen, wie die Daten von CAN-Botschaften zu interpretieren sind und welche symbolischen Bezeichner an ihrer Stelle in den verschiedenen Fenstern von PCAN-Explorer angezeigt werden sollen.

In diesem Abschnitt

Format und Syntax von Symboldateien

Beschreibt die allgemeinen Regeln, die beim Erstellen von Symboldateien in Bezug auf Format und Syntax zu beachten sind.

Abschnitte von Symboldateien

Beschreibt die verschiedenen Abschnitte, die eine Symboldatei enthalten kann, und welche Daten in diesen Abschnitten definiert werden müssen.

Globale Parameter

Beschreibt die Parameter, die sich auf eine komplette Symboldatei auswirken.

FormatVersion-Parameter

Beschreibt die Bedeutung des FormatVersion-Parameters, der im Kopf von Symboldateien angegeben ist.

Symbole

Beschreibt die Definition von Symbolen und ihrer Parameter.

Parameter für Symboldefinitionen

Beschreibt die verschiedenen Parameter, die in Symboldefinitionen möglich sind.

Symboltypen

Beschreibt die verschiedenen Typen von Symbolen.

Signale

Eine Anleitung zum Definieren von Signalen.

Variablen

Eine Anleitung zum Definieren von Variablen.

Datentypen

Beschreibt die verfügbaren Datentypen für Signale und Variablen.

Datentypen Float und Double

Eine Beschreibung der Datentypen 'Float' und 'Double' und deren Verwendung.

Optionale Schalter für Signal- und Variablendefinitionen

Beschreibt die optionalen Schalter, mit denen in Signal- und Variablendefinitionen z.B. das Anzeigeformat von Signal- und Variablenwerten gesteuert werden kann..

Optionale Parameter für Signal- und Variablendefinitionen

Eine Beschreibung der optionalen Parameter, die bei der Definition von Signalen und Variablen angegeben werden können, z.B. Faktor, Offset, Einheit.

Enums

Beschreibt die Verwendung von Aufzählungen (Werte-Listen) über die Definition von Enums.

Multiplexer

Eine Beschreibung der Funktionsweise von Multiplexern und deren Verwendung.

Timing

Beschreibt optionale Parameter, die zum Überwachen des Timings von Symbolen und Multiplexern angegeben werden können.

Picture-Parameter: Bit-Sequenz in Variablen

Beschreibt, was bei der Reihenfolge von Variablen-Bits in den Datenbytes einer CAN-Botschaft zu beachten ist, und erklärt das Intel- und Motorola-Format von Variablen.

Picture-Parameter: Bit-Sequenz in Multiplexern

Beschreibt, was bei der Reihenfolge von Multiplexer-Bits in den Datenbytes einer CAN-Botschaft zu beachten ist, und erklärt das Intel- und Motorola-Format von Variablen.

Zuweisen von CAN-Botschaften oder Makros zu Funktionstasten (veraltet)

Erläutert, wie mit Hilfe von Symboldateien Funktionstasten verwendet werden können, um einzelne CAN-Botschaften zu senden oder Makros zu starten.

Weitere Themen

Arbeiten mit Symbolen

Beschreibt die Verwendung von Symbolen in der PCAN-Explorer-Benutzeroberfläche.

Arbeiten mit dem Texteditor

Beschreibt die Verwendung des Texteditors, um z.B. Symboldateien oder VBScript-Makros zu bearbeiten.

Fehlermeldungen von Symboldateien

Enthält eine Beschreibung aller Fehlermeldungen, die im Umgang mit Symboldateien auftreten können.


Format und Syntax von Symboldateien

Symboldateien haben die Dateinamenserweiterung .sym. Es gelten folgende allgemeine Regeln bei der Erstellung von Symboldateien:

  • Alle Zeichen zwischen einem Semikolon ';' oder einem Doppel-Schrägstrich '//' und dem Ende einer Zeile werden als Kommentar betrachtet und ignoriert.

  • Leerzeilen sind erlaubt und werden ignoriert.

  • Alle Parameter werden im Format 'Parameter=Wert1 Wert2 Wert3' angegeben. Die Anzahl der anzugebenden Werte ist variabel, die Trennung von Werten kann durch Leerzeichen oder Tabulator-Zeichen erfolgen.

  • Alle Signale, die in den verschiedenen CAN-Botschaften enthalten sind, werden oberhalb der Symboldefinitionen in einem Abschnitt {SIGNALS} definiert, jeweils mit einer Zeile
    Sig=Signalname Datentyp AnzahlBits Optionen

  • Alle Symbole, die Botschaften repräsentieren sollen, werden in Abschnitten definiert, die mit einer Zeile
    [Symbolname]
    beginnen (Botschaftskopf).

  • Nach dem Botschaftskopf folgt eine Parameterzeile der Form
    ID=CAN-ID
    welche die symbolische Botschaft [Symbolname] mit einer CAN-ID verknüpft.

  • Die Länge der Botschaft (die Anzahl der Datenbytes) wird mit einer Parameterzeile der Form
    Len=Länge
    angegeben. Wird dieser Parameter weggelassen, wird ein Symbol definiert, das für alle Datenlängen gültig ist.

  • Falls das Symbol einen Multiplexer enthalten soll, muss eine Zeile mit einer Multiplexerdefinition in der Form
    Mux=Multiplexername Startbit,AnzahlBits Optionen
    folgen.

  • Für jedes Signal, welches das Symbol enthalten soll, muss eine Zeile in der Form
    Sig=Signalname Startbit Optionen
    folgen. SignalName referenziert eines der Signale aus dem Abschnitt {Signals}.

  • Namen von Symbolen, Multiplexern und Variablen können aus bis zu 32 Zeichen bestehen. Wenn ein Name Leerzeichen enthalten soll, muss er in Anführungszeichen gesetzt werden. Namen können keine Punkte enthalten.

Die folgenden Regeln betreffen Symboldateien, welche die älteren Format-Versionen 5.0 verwenden (PCAN-Explorer 5):

  • Die Länge der Botschaft (die Anzahl der Datenbytes) wird mit einer Parameterzeile der Form
    DLC=Länge
    angegeben. Wird dieser Parameter weggelassen, wird ein Symbol definiert, das für alle Datenlängen gültig ist.

  • Für jede Variable, die das Symbol enthalten soll, muss eine Zeile in der Form
    Var=Variablenname Datentyp Startbit,AnzahlBits Optionen
    folgen.

Die folgenden Regeln betreffen Symboldateien, welche die älteren Format-Versionen 3.1 und 3.0 verwenden (PCAN-Explorer 4 und älter):

  • Enthält die CAN-Botschaft Datenbytes, muss eine Parameterzeile der Form
    Picture=Bitmuster
    folgen. Wird dieser Parameter weggelassen, wird ein Symbol definiert, das für alle Datenlängen gültig ist. Es sind dann keine weiteren Angaben in der Symboldefinition nötig.

  • Für jede Bitgruppe, die im Parameter Picture in Bitmuster definiert wurde, muss eine Zeile
    Marker=Variablenname Datentyp Optionen
    folgen. Der Marker muss eines der Zeichen a bis z, A bis Z, 0 bis 9, % oder & sein.

  • Namen von Symbolen, Multiplexern und Variablen können aus bis zu 30 Zeichen bestehen.

Für Beispiele von Symboldateien siehe

Symboldatei-Beispiel (FormatVersion 6.0)

oder

Symboldatei-Beispiel (FormatVersion 5.0)

oder

Symboldatei-Beispiel (FormatVersion 3.1)

Siehe auch

FormatVersion-Parameter

Definition von Signalen

Definition von Variablen

Datentypen

Optionale Schalter für Variablendefinitionen

Optionen-Dialogfenster


Abschnitte in Symboldateien

Eine Symboldatei ist in verschiedene Abschnitte aufgeteilt:

ENUMS

Hier werden Aufzählungen (Werte-Listen) definiert, die in den nachfolgenden Abschnitten bei Signal- und Variablendefinitionen verwendet werden können.

SIGNALS (FormatVersion 6.0)

Definiert alle Signale, die in Symboldefinitionen in den folgenden Abschnitten {SEND}, {RECEIVE} und {SENDRECEIVE} referenziert werden.

SEND

Definiert Symbole für CAN-Botschaften, die gesendet werden. Diese Symbole werden niemals in der Empfangsliste erscheinen.

RECEIVE

Definiert Symbole für CAN-Botschaften, die nur empfangen werden. Bei der Erstellung von neuen Sendebotschaften stehen diese Symbole nicht als Vorlage für die Sendebotschaft zur Auswahl.

SENDRECEIVE

Definiert Symbole für CAN-Botschaften, die sowohl gesendet als auch empfangen werden (bidirektionale Symbole).

VIRTUALVARS (FormatVersion 5.0)

Definiert virtuelle Variablen, die nicht im Zusammenhang mit CAN-Botschaften stehen.

Ältere Formate (3.0, 3.1, siehe FormatVersion-Parameter) von Symboldateien erlauben zusätzlich noch folgende weitere Abschnitte:

MESSAGEKEYS

Weist Sendebotschaften zu Funktionstasten zu.

MACROKEYS

Weist Makros zu Funktionstasten zu.

Um den Beginn eines Abschnittes zu kennzeichnen, muss eine Zeile der folgenden Form in die Symboldatei eingefügt werden:

{Abschnittsbezeichner}

Ein Abschnitt reicht bis zu der Stelle, an der ein neuer Abschnitt definiert wird. Symbole, die vor dem ersten Abschnittsbezeichner definiert werden, werden als bidirektionale Symbole behandelt.

Siehe auch

FormatVersion-Parameter

Symbole

Enums

Zuweisen von CAN-Botschaften oder Makros zu Funktionstasten


Globale Parameter

Globale Parameter werden ganz am Anfang einer Symboldatei eingetragen.

Die folgenden globalen Parameter werden unterstützt:

  • DecimalSeparator

  • FloatDecimalPlaces

  • FormatVersion

  • IDMask

  • MuxChar

  • Title

  • UniqueVariables

DecimalSeparator

Bestimmt das Dezimaltrennzeichen, das bei der Angabe von Gleitkommawerten in der Symboldatei erwartet wird.

Erlaubte Dezimaltrennzeichen sind Komma oder Punkt.

Wird dieser Parameter weggelassen, wird das zu verwendende Dezimaltrennzeichen von den Zahlenformat-Einstellungen in der Windows Systemsteuerung bestimmt.

Dieser Parameter wird nur von Symboldateien unterstützt, die FormatVersion 3.1 oder älter verwenden.

Beispiel

FormatVersion=3.1

DecimalSeparator=,

[MeinSymbol]

ID=100h

DLC=3

Picture=aaaaaaaa --------

a=MeineVariable signed /f:0,5

FloatDecimalPlaces

Dieser Parameter steuert die Anzahl der Nachkommastellen, die für alle Variablen der Symboldatei angezeigt werden. Dieser Parameter überschreibt die Einstellung Dezimalstellen im Optionen-Dialogfenster.

Analog dazu kann für jede Variable einzeln die Anzahl der angezeigten Nachkommastellen gesteuert werden. Siehe Optionale Parameter für Variablendefinitionen, Parameter /p.

Beispiel

FormatVersion=6.0

FloatDecimalPlaces=3

{SIGNALS}

Sig=SignalA float

Sig=SignalB float /p:1

{SENDRECEIVE}

[MeinSymbol]

ID=100h

Len=8

Sig=SignalA 0

Sig=SignalB 32

SignalA des Beispiels wird mit 3 Nachkommastellen angezeigt, und SignalB mit einer Nachkommastelle.

FormatVersion

Siehe Kapitel FormatVersion-Parameter.

IDMask

Gibt eine Maske für alle CAN-IDs in der Symboldatei vor. Eine Maske qualifiziert, welche der entsprechenden Bits einer CAN-ID "relevant" oder "don't care" sind. Wenn PCAN-Explorer das Symbol ermittelt, das zu einer bestimmten Botschaft passt, werden nur die Bits der CAN-ID berücksichtigt, bei denen in der Maske an der entsprechenden Position eine 1 gesetzt ist.

Beispiel

FormatVersion=6.0

IDMask=FF00h

{SIGNALS}

Sig=MeinSignal unsigned 16

{SENDRECEIVE}

[MeinSymbol]

ID=1234h

Len=2

Sig=MeineSignal 0

In diesem Beispiel sind nur die Bits 8-15 der CAN-ID zur Bestimmung eines passenden Symbols relevant. Das Ergebnis ist, dass alle Botschaften mit CAN-IDs zwischen 1200h und 12FFh als "MeinSymbol" dekodiert werden.

MuxChar

Dieser Parameter legt fest, welches Platzhalter-Zeichen im Picture-Parameter Multiplexer-Bits kennzeichnet. Eines der folgenden Zeichen ist als Multiplexerzeichen erlaubt:

# % & ( ) * + ? @, a-z, A-Z.

Wird dieser Parameter weggelassen, ist das Platzhalter-Zeichen für den Multiplexer ein Stern (*).

Der MuxChar-Parameter wird nur von Symboldateien unterstützt, die FormatVersion 3.1 oder älter verwenden.

Beispiel

FormatVersion=3.1

MuxChar=X

[MeinSymbol]

ID=100h

Picture=XXXXXXXX aaaaaaaa bbbbbbbb

X=MeinMultiplexer 1

a=VariableA unsigned

b=VariableB unsigned

Title

Legt einen Titel für die Symboldatei fest. Wird die Symboldatei von einer Verbindung verwendet, wird deren Titel im Projekt-Manager unter dem Knoten Aktive Symbole angezeigt. Wird der Parameter nicht angegeben, ist der Titel der Symboldatei standardmäßig der Name der Datei ohne die Dateiendung.

Dieser Parameter wird nur von Symboldateien unterstützt, die mindestens FormatVersion 5.0 verwenden.

UniqueVariables

Bestimmt, ob Variablennamen innerhalb einer Symboldatei mehrfach verwendet werden können.

Variablennamen dürfen innerhalb einer Symboldefinition immer nur einmal vergeben werden. In verschiedenen Symboldefinitionen darf der gleiche Variablenname jedoch mehrmals verwendet werden. Wird der Parameter UniqueVariables in die Symboldatei mit dem Wert True eingetragen, darf jeder Variablenname in der gesamten Symboldatei nur einmal vorkommen.

Die Standardeinstellung des Parameters ist False.

Beispiel

FormatVersion=5.0

UniqueVariables=True

[Symbol1]

ID=100h

DLC=2

Var=MeineVariable unsigned 0,16

[Symbol2]

ID=200h

DLC=2

Var=MeineVariable signed 8,8

Dieses Beispiel erzeugt für die Definition von "MeineVariable" in Symbol2 den Fehlercode 62: "Variablenname wird bereits verwendet".

Siehe auch

FormatVersion-Parameter


FormatVersion-Parameter

Der FormatVersion-Parameter im Kopf einer Symboldatei legt die Version des Dateiformats fest. Diese Version bestimmt die einzuhaltende Syntax und die erlaubten bzw. unterstützten Schlüsselwörter. Wird kein FormatVersion-Parameter angegeben, gilt automatisch das aktuelle Format 6.0. Es wird empfohlen, auf jeden Fall eine Formatversion im Dateikopf anzugeben.

FormatVersion 3.0 und älter

Bis einschließlich PCAN-Explorer 3.0.2 galten die folgenden Einschränkungen in Symboldateien:

  • Alle Multiplexer- und Variablen-Bitgruppen, die das Motorola-Format verwenden, mussten an die Grenzen der Datenbytes ausgerichtet werden.

  • Die Formatangabe -m in einer Multiplexerdefinition legte fest, ob die jeweils angegebenen Multiplexerwerte im Intel- oder Motorola-Format zu interpretieren waren. Sie konnte in diesem Fall bei mehreren Multiplexern eines Symbols unterschiedlich angegeben werden.

FormatVersion 3.1

Ab PCAN-Explorer Version 3.0.3 bis Version 4.0 ist die Version des Dateiformats 3.1. Gegenüber Formatversion 3.0 sind ab dieser Version folgende Änderungen gültig:

  • Multiplexer und Variablen, die nicht an die Grenzen von Datenbytes ausgerichtet sind, können auch das Motorola-Format verwenden.

  • Die Formatangabe -m in der Multiplexerdefinition legt die Byte-Reihenfolge des Multiplexers in den Datenbytes fest. Jeder Multiplexer eines Symbols muss mit der gleichen Formatangabe -m definiert werden.

FormatVersion 5.0

PCAN-Explorer 5 führte Dateiformat 5.0 ein. Die folgenden Änderungen gelten bei dieser Version:

  • Der Picture-Parameter ist nicht länger erlaubt.

  • Neue Schlüsselwörter "Type", "DLC", "Mux", "Var".

  • Neuer Abschnitt {VIRTUALVARS}, um virtuelle Variablen zu definieren.

  • Abschnitte {MESSAGEKEYS} und {MACROKEYS} nicht länger erlaubt.

  • Das Schlüsselwort "Period" wurde ersetzt gegen "CycleTime", aber das alte Schlüsselwort wird immer noch erkannt und kann verwendet werden.

  • Globaler Parameter "MuxChar" wird nicht länger benötigt.

  • Globaler Parameter "DecimalSeparator" ist nicht länger erlaubt, als Dezimaltrennzeichen muss immer ein Punkt verwendet werden.

FormatVersion 6.0

PCAN-Explorer 6 führt das Dateiformat 6.0 ein. Die folgenden Änderungen gelten bei dieser Version:

  • Neuer Abschnitt {SIGNALS}, um alle Signale vorab zu definieren, die in späteren Symboldefinitionen verwendet werden.

  • Abschnitt {VIRTUALVARS} nicht länger erlaubt. Signale, die im Abschnitt {SIGNALS} definiert aber in keiner Symboldefinition verwendet werden, sind automatisch "virtuelle" Signale.

  • Neuer Parameter "Len" als Ersatz für "DLC", aber der alte Parameter wird immer noch erkannt und kann verwendet werden.

  • Neue Symboltypen "FDStandard" und "FDExtended".

  • Als Gegenstück zu Timeouts können kleinste erlaubte Zeitintervalle für Symbole und Multiplexer mittels eines Parameters "MinInterval" definiert werden..

Kompatibilität mit Symboldateien von PCAN-Explorer 3 oder älter

Um ältere Symboldateien zu verwenden, die noch keine Angabe der Formatversion enthielten, kann die Versionsnummer manuell auf "3.1" oder "3.0" gesetzt werden, indem ein FormatVersion-Parameter in die Datei aufgenommen wird. Das Setzen der Version auf "3.0" bewirkt die Kompatibilität mit dem alten Syntax, so dass alle Multiplexer- und Variablen-Bitgruppen, die das Motorola-Format verwenden, an die Grenzen der Datenbytes ausgerichtet werden müssen. Das Setzen der Version auf "3.1" erlaubt gegenüber Version 5.0 oder neuer die Verwendung des Picture-Parameters und die Verwendung der Abschnitte {MESSAGEKEYS} und {MACROKEYS}.

Siehe auch

Picture-Parameter: Bit-Sequenz in Multiplexern

Symboldatei-Beispiel (FormatVersion 6.0)

Symboldatei-Beispiel (FormatVersion 5.0)

Symboldatei-Beispiel (FormatVersion 3.1)


Symbole

Symbole sind die oberste Ebene der zu treffenden Definitionen. Sie weisen einer oder mehreren CAN-IDs einen symbolischen Bezeichner zu, der dann anstelle der CAN-ID in den verschiedenen Fenstern von PCAN-Explorer angezeigt wird.

Eine Symboldefinition besteht aus mindestens 2 Zeilen, z.B.:

Symboldatei

[MeinSymbol]

ID=100h

Hier wird der CAN-ID 100h das Symbol MeinSymbol zugewiesen. Werden keine weiteren Angaben zum Symbol gemacht, gilt diese Definition nur für eine CAN-Botschaft mit CAN-ID 100h, wobei der Data Length Code keine Rolle spielt.

Befindet sich die Symboldefinition im Abschnitt {RECEIVE}, dann kann auch ein Bereich von CAN-IDs spezifiziert werden:

Symboldatei

{RECEIVE}

[MeinSymbol]

ID=100h-1FFh

Diese Definition bewirkt die Anzeige des Symbols MeinSymbol beim Empfang einer CAN-Botschaft, deren CAN-ID im Bereich 100h bis einschließlich 1FFh liegt. Für Symbole im Abschnitt {SEND} oder {SENDRECEIVE} kann kein Bereich von CAN-IDs angegeben werden.

Nach der Angabe der CAN-ID können verschiedene weitere Parameter folgen. Siehe Parameter für Symboldefinitionen.

Siehe auch

Parameter für Symboldefinitionen

Symboltypen

Timing

Variablen

Multiplexer


Parameter für Symboldefinitionen

Die folgende Tabelle enthält alle Parameter, die für Symbol- bzw. Multiplexerdefinitionen angegeben werden können:

Parameter Beschreibung Beispiel

Color

Erlaubt die Zuweisung eines RGB-Farbwertes zu einem Symbol.

Wenn Sie einem Symbol eine Farbe zuweisen, wird der Name des Symbols in Empfangs- und Sendelisten in der Spalte "Symbol" in dieser Schriftfarbe dargestellt. In einem Trace-Fenster wird die ganze Zeile der Botschaft in der entsprechenden Schriftfarbe dargestellt.

Der Farbwert ist ein 24-Bit Wert, wobei LSB = Rot und MSB = Blau (BBGGRRh).

Color=FF0000h

(entspricht der Farbe Blau)

CycleTime

Ab FormatVersion 5.0.

Legt für das Symbol eine Standard-Sendeperiode fest, in Millisekunden. Wenn Sie eine neue Sendebotschaft in die Sendeliste eintragen, und ein Symbol mit vordefinierter Sendeperiode auswählen, wird als Sendeperiode der neuen Sendebotschaft dieser Wert verwendet.

Wird zusätzlich der Pause-Schalter -p nach der Sendeperiode angegeben, ist das zyklische Senden der Botschaft anfangs angehalten wenn dieses Symbol in eine Sendeliste aufgenommen wird.

CycleTime=250

CycleTime=250 -p

DLC

Gibt eine Datenlängencode für das Symbol an (0-8 für CAN-Symbole, 0-1785 für J1939-Symbole).

Wird ein Wert größer als 8 angegeben, muss der Symboltyp auf J1939PG gesetzt werden.

Wird für ein Symbol keine Datenlänge definiert, gilt die Symboldefinition für alle Datenlängen.

DLC=6

ID

Weist dem Symbol eine CAN-ID zu (0-1FFFFFFFh).

Ist der angegebene Wert größer als 7FFh, oder hat der angegebene Wert mehr als 3 Stellen, wird der Symboltyp automatisch auf Extended gesetzt.

Befindet sich die Symboldefinition im Abschnitt RECEIVE, dann kann auch ein Bereich von CAN-IDs spezifiziert werden.

ID=100h

ID=18EFFFF9h

ID=100h-1FFh

IgnoreSource

Nur erlaubt für Symboltyp J1939PG, ab FormatVersion 5.0.

Ist diese Option aktiviert (Standardwert), wird die in der CAN-ID enthaltene Quell-Adresse (Bits 0..7) nicht bei der Identifizierung des Symbols berücksichtigt. In diesem Fall ist bei einem J1939-Symbol nur der PGN-Anteil der CAN-ID (Bits 8..25) relevant. Wird eine PGN von verschiedenen ECUs am Bus mit verschiedenen Quell-Adressen aus empfangen, werden die darin enthaltenen Signale jeweils von den anderen ECUs überschrieben, da Signale immer nur einmal vorhanden sind und nicht zwischen Quell-Adressen unterscheiden können.

Ist die Option nicht aktiviert, werden die Bits 0..25 der CAN-ID zur Identifizierung des Symbols verwendet, so dass die Definition nur noch für eine ECU gilt. Andere ECUs mit anderen Quell-Adressen benötigen eine separate Symboldefinition, so dass die Signale von verschiedenen ECUs eindeutig voneinander getrennt sind.

Die J1939-Priorität in der CAN-ID (Bits 26..28) wird niemals zur Identifizierung von J1939-Symbolen verwendet.

IgnoreSource=False

Len

Gibt eine Datenlänge für das Symbol an (0-8 für CAN-Symbole; 0-8, 12, 16, 20, 24, 32, 48, 64 für CAN-FD-Symbole; 0-1785 für J1939-Symbole). Ab FormatVersion 6.0.

Wird für ein Symbol keine Datenlänge definiert, gilt die Symboldefinition für alle Datenlängen.

Len=8

MinInterval

Definiert ein kleinstes erlaubtes Zeitintervall, in dem ein Symbol oder Multiplexer empfangen werden muss, in Millisekunden. Ab FormatVersion 6.0

Siehe auch Parameter Timeout.

MinInterval=50

Multipacket

Nur erlaubt für Symboltyp J1939PG, ab FormatVersion 5.0.

Legt fest, ob die J1939-Parametergruppe das J1939-Transportprotokoll verwendet, um Botschaften mit mehr als 8 Datenbytes zu übertragen.

Falls Sie ein J1939-Symbol mit einem DLC größer als 8 definieren, ist Multipacket automatisch auf True gesetzt.

Multipacket=True

Mux

Definiert einen Multiplexer für das Symbol. Siehe Multiplexer. Erlaubt ab FormatVersion 5.0.

Mux=MeinMux 0,8 5

Period

Gibt eine Sendeperiode für das Symbol vor, in Millisekunden. Dieser Parameter wurde ab FormatVersion 5.0 durch Parameter CycleTime ersetzt.

Period=250

Period=250 -p

Picture

Legt die Anordnung von Variablen und Multiplexer innerhalb der Datenbytes eines Symbols fest. Nur FormatVersion 3.1 oder älter.

Siehe Picture-Parameter: Bit-Sequenz in Variablen und Picture-Parameter: Bit-Sequenz in Multiplexern für weitere Informationen.

Picture=aaaaaaaa bbbbbbbb

Sig

Definiert ein Signal. Siehe Signale. Erlaubt ab FormatVersion 6.0.

Sig=MeinSignal unsigned 16

Timeout

Legt eine Timeout-Zeit für ein Symbol oder Multiplexer fest, in Millisekunden.

Überschreitet das Zeitintervall zwischen den letzten beiden Empfangszeitpunkten des Symbols/Multiplexers einen so definierten Timeout, wird dies in der Empfangsliste angezeigt. Optional können die Zeitmarken der Timeouts auch aufgezeichnet werden (siehe Seite Timing im Projekteinstellungen-Dialogfenster).

Für weitere Informationen siehe Timing.

Timeout=500

Type

Legt den Typ des Symbols fest. Siehe Symboltypen.

Type=Extended

Var

Definiert eine Variable für das Symbol. Siehe Variablen. Erlaubt ab FormatVersion 5.0.

Var=MeineVar unsigned 8,16

Siehe auch

FormatVersion-Parameter


Symboltypen

Beginnend mit FormatVersion 5.0 unterstützen Symboldateien das neue Schlüsselwort "Type", um den Typ eines Symbols festzulegen.

Die folgenden Symboltypen sind verfügbar:

Typ | Beschreibung
Standard | Standard 11-Bit CAN-Botschaft (die Standardeinstellung).
Extended | Erweiterte 29-Bit CAN-Botschaft gemäß CAN-Protokoll 2.0B.
J1939PG | J1939 Parametergruppe.
FDStandard | 11-Bit CAN-FD-Botschaft (ab FormatVersion 6.0)
FDExtended | 29-Bit CAN-FD-Botschaft (ab FormatVersion 6.0)

Standard

Das folgende Beispiel definiert ein Symbol mit einer 11-Bit CAN-ID:

Symboldatei

[Demo]
ID=123h

Type=Standard

Extended

Das folgende Beispiel definiert ein Symbol mit einer 29-Bit CAN-ID:

Symboldatei

[Demo]
ID=123h

Type=Extended

was gleichbedeutend ist mit

Symboldatei

[Demo]
ID=00000123h

J1939PG

Das folgende Beispiel definiert ein Symbol, das eine J1939 Parametergruppe darstellt:

Symboldatei

[Demo]
ID=123h

Type=J1939PG

Symbole, die J1939 Parametergruppen sind, haben immer 29-Bit CAN-IDs, und sie können eine maximale Datenlänge von 1785 Bytes haben. Zum Beispiel könnte ein Symbol definiert werden, das 20 Datenbytes hat:

Symboldatei (FormatVersion 6.0)

[Demo]
ID=123h

Type=J1939PG

Len=20

Solch eine Botschaft wird immer unter Verwendung des J1939-Transportprotokolls auf dem CAN-Bus übertragen.

Falls die Parametergruppe eine dynamische Länge mit einer Standardlänge von 8 Datenbytes besitzt, aber eine Paketierung unter Verwendung des J1939-Transportprotokolls unterstützt, kann das neue Schlüsselwort "Multipacket" verwendet werden, welches explizit die Übermittlung von großen Botschaften erlaubt:

Symboldatei (FormatVersion 6.0)

[Demo]
ID=123h

Type=J1939PG

Multipacket=True

LenC=8

Wird solch eine Botschaft in eine Sendeliste eingetragen, kann im Botschaft bearbeiten-Dialogfenster die Datenlänge auf das Maximum von 1785 Bytes eingestellt werden. Falls die Botschaft mehr als 8 Datenbytes besitzt, wird sie unter Verwendung des Transportprotokolls übertragen, andernfalls wird eine einzelne Botschaft gesendet. Wenn das Schlüsselwort "Multipacket" weggelassen oder der Parameter explizit auf False gesetzt wird, ist im Botschaft bearbeiten-Dialogfenster die maximal erlaubte Datenlänge für diese Botschaft 8 Bytes.

CAN FD

Das folgende Beispiel definiert ein Symbol für eine 11-Bit CAN-FD-Botschaft mit 12 Datenbytes:

Symboldatei (FormatVersion 6.0)

[Demo]
ID=123h

Type=FDStandard

Len=12

Wird für dieses Symbol eine neue Sendebotschaft in einer Sendeliste angelegt, wird automatisch der Bit Rate Switch für die CAN-FD-Botschaft aktiviert. Um BRS für das Symbol per Voreinstellung abzuschalten, kann die Definition folgendermaßen erweitert werden:

Symboldatei (FormatVersion 6.0)

[Demo]
ID=123h

Type=FDStandard

BRS=0

Len=12


Timing

Um zu überwachen, ob beim zyklischen Empfang von Symbolen bzw. Multiplexern minimale oder maximale Zeitintervalle eingehalten werden, können entsprechende Timing-Parameter in die Symboldefinition aufgenommen werden. Überschreitet das Zeitintervall einen festgelegten maximalen Wert oder unterschreitet das Zeitintervall einen minimalen Wert, wird ein Timing-Fehler-Ereignis ausgelöst.

Tritt ein Timing-Fehler auf, wird in der Empfangsliste in der Spalte Timing-Fehler die Anzahl der bisher aufgetretenen Timing-Fehler erhöht und die tatsächliche Periodendauer in rot angezeigt. Ist die Aufzeichnung von Timing-Fehlern aktiviert, wird das Zeichen [image] in der Spalte Timing-Fehler sichtbar. Wenn Sie mit der Maus dieses Zeichen klicken, wird das Timing-Fehler-Fenster angezeigt und die Liste automatisch für das entsprechende Symbol bzw. Multiplexer gefiltert.

Um zu kontrollieren, ob ein maximales Zeitintervall eingehalten wird, geben Sie einen Parameter Timeout für das Symbol/den Multiplexer an. Um zu kontrollieren, ob ein minimales Zeitintervall eingehalten wird, geben Sie einen Parameter MinInterval an. MinInterval-Parameter werden ab FormatVersion 6.0 unterstützt. Sie können auch beide Parameter kombinieren. Alle Parameterwerte werden in Millisekunden angegeben.

Timeout- und MinInterval-Parameter können für Symbole und Multiplexer definiert werden, die in den Abschnitten {RECEIVE} und {SENDRECEIVE} definiert sind.

Syntax

Um einen Timeout zu definieren, fügen Sie einen Timeout-Parameter in die jeweilige Symbol- bzw. Multiplexerdefinition ein:

Symboldatei (FormatVersion 6.0)

[GeneralVehicleInfo]
ID=032h

Timeout=500
Mux=DataSet1 0,8 0Ah
Sig=MotorTemperature 8

Um ein minimal erlaubtes Zeitintervall zu definieren, fügen Sie einen MinInterval-Parameter in die jeweilige Symbol- bzw. Multiplexerdefinition ein:

Symboldatei (FormatVersion 6.0)

[GeneralVehicleInfo]
ID=032h

MinInterval=100
Mux=DataSet1 0,8 0Ah
Sig=MotorTemperature 8

Siehe auch

Timing-Fehler-Fenster

Timing, Projekteinstellungen-Dialogfenster


Signale

Signale sind ähnlich wie Variablen die kleinste Informationseinheit in Symboldateien. Sie beschreiben physikalische Werte zunächst unabhängig von einzelnen Bits oder Bitgruppen in CAN-Botschaften.

Die Definition von Signalen ist ab FormatVersion 6.0 möglich. Eine Signaldefinition umfasst gegenüber Variablen zunächst keine Definition, an welcher Position sich eine Information innerhalb der Datenbytes von CAN-Botschaften befindet. Signale sind zunächst unabhängig von CAN-Botschaften zu sehen.

Signale werden in einer Symboldatei in einem eigenen Abschnitt {SIGNALS} definiert, der sich vor den späteren Symboldefinitionen befinden muss. Erst in den Symboldefinitionen werden Signale zu bestimmten CAN-Botschaften zugeordnet, und erst dort wird die Festlegung getroffen, an welcher Bitposition sich die Information befindet.

Signale, die in der ganzen Symboldatei keinem Symbol zugeordnet werden, funktionieren mit FormatVersion 6.0 so wie virtuelle Variablen in Symboldateien mit FormatVersion 5.0.

Eine Signaldefinition besteht mindestens aus den folgenden Parametern:

  • Name

  • Datentyp

Optional können auch noch folgende Parameter angegeben werden:

  • Länge (Anzahl Bits)

  • Optionale Schalter, z.B. Anzeigeformat

  • Faktor, Offset

  • Physikalische Einheit

  • Anfangswert

  • Minimum, Maximum

  • Kommentar

  • Enum (Werte-Liste)

Signaldefinition in einer Symboldatei

Wie das Symboldatei-Beispiel zeigt, hat jede Signaldefinition in einer Symboldatei die folgende Form:

Symboldatei (FormatVersion 6.0)

{SIGNALS}

Sig=Signalname Typ [AnzahlBits] [ Schalter ] [ OptionaleParameter ] [//Kommentar]

Falls der Signalname Leerzeichen enthalten soll, muss der Name in Anführungszeichen gesetzt werden.

Wird der Parameter AnzahlBits weggelassen, gilt für das Signal eine voreingestellte Länge in Abhängigkeit des angegebenen Datentyps:

Datentyp | Anzahl Bits
Bit | 1
Float | 32
Double | 64
Alle anderen | 8

Signaledefinitionen enthalten im Gegensatz zu Variablendefinitionen keine Definition des Startbits. Das Startbit eines Signals wird erst in der Symboldefinition festgelegt, wenn ein Signal einem Symbol zugewiesen wird. In einer Symboldefinition wird ein Signal in folgender Form referenziert:

Symboldatei (FormatVersion 6.0)

{SENDRECEIVE}

[SymbolName]

...

Sig=Signalname StartBit [ OptionaleParameter ] [//Kommentar]

StartBit wird gezählt beginnend mit Datenbyte 0, Bit 0. Das höchste Bit in einer 8-Byte CAN-Botschaft ist Bit 63, welches dem Bit 7 von Datenbyte 7 entspricht. In J1939 Multipacket-Botschaften ist das höchste Bit 14279, welches dem Bit 7 von Datenbyte 1784 entspricht.

Mit OptionaleParameter können von der ursprünglichen Signaldefinition abweichende Parameter vorgegeben werden, z.B. kann ein anderer Anfangswert festgelegt werden.

Beispiel
Symboldatei (FormatVersion 6.0)

{SIGNALS}

Sig=Flag1 bit

Sig=Flag2 bit

Sig=Bits unsigned 3 -b

Sig=Value1 unsigned 8 -h

Sig=Value2 signed 16 -m

{SENDRECEIVE}

[MySymbol]

ID=100h

Len=4

Sig=Flag1 0

Sig=Flag2 1

Sig=Bits 5

Sig=Value1 8

Sig=Value2 16

Siehe auch

Datentypen

Optionale Schalter für Signal- und Variablendefinitionen

Optionale Parameter für Signal- und Variablendefinitionen


Variablen

Variablen sind die kleinste Informationseinheit in einer CAN-Botschaft. Variablen beschreiben den Informationsgehalt von einzelnen Bits oder Bitgruppen in den Datenbytes der CAN-Botschaft, und bringen diesen in eine für den Benutzer leicht verständliche Form.

Eine Variablendefinition besteht mindestens aus den folgenden Parametern:

  • Name

  • Datentyp

  • Startbit und Länge

Optional können auch noch folgende Parameter angegeben werden:

  • Optionale Schalter, z.B. Anzeigeformat

  • Faktor, Offset

  • Physikalische Einheit

  • Anfangswert

  • Minimum, Maximum

  • Kommentar

  • Enum (Werte-Liste)

Ab FormatVersion 6.0 können anstatt von Variablen Signale definiert werden, die gegenüber Variablen Vorteile besitzen. So brauchen Signale nur einmal definiert werden, können aber mehrfach zu verschiedenen Symbolen zugewiesen werden.

Variablendefinition in einer Symboldatei

Wie das Symboldatei-Beispiel zeigt, hat jede Varriablendefinition in einer Symboldatei die folgende Form:

Symboldatei (FormatVersion 5.0)

Var=Variablenname Typ StartBit,AnzahlBits [ Schalter ] [ Optionale Parameter ] [//Kommentar]

Falls der Variablenname Leerzeichen enthalten soll, muss der Name in Anführungszeichen gesetzt werden.

StartBit wird gezählt beginnend mit Datenbyte 0, Bit 0. Das höchste Bit in einer 8-Byte CAN-Botschaft ist Bit 63, welches dem Bit 7 von Datenbyte 7 entspricht. In J1939 Multipacket-Botschaften ist das höchste Bit 14279, welches dem Bit 7 von Datenbyte 1784 entspricht.

Variablendefinition in einer Symboldatei mit FormatVersion 3.1 und älter

Wie das Symboldatei-Beispiel zeigt, enthält jede Zeile "Picture= ..." ein Abbild der Datenbytes der Botschaft, wobei jedem Datenbyte 8 Zeichen zugeordnet sind. Die ersten 8 Zeichen entsprechen Datenbyte 0, die nächsten 8 Zeichen Datenbyte 1, usw.

Dies ist ein Beispiel für eine Botschaft mit 5 Datenbytes:

Symboldatei (FormatVersion 3.1)

Picture=ccc---ba ffff--ed -----ggg -------- hhhh----

Jeder Block aus 8 Zeichen repräsentiert die 8 Bits eines Datenbytes. Das erste Zeichen stellt das msb (most significant bit = Bit 7, Maske 80h) dar, das zweite Zeichen Bit 6 (Maske 40h), usw.

In die Datenbytes einer Botschaft sind verschiedene Anwendungsvariablen hineincodiert. Jede Variable belegt eine Reihe von zusammenhängender Bits, sog. Bitgruppen. Alle Bits, die zu einer bestimmten Bitgruppe gehören, sind im Parameter Picture mit dem "Marker"-Zeichen der Bitgruppe markiert. Bitgruppen dürfen sich auch über die Byte-Grenzen hinweg erstrecken. Unbenutzte Bits müssen mit '-' gekennzeichnet werden. Die Gesamtanzahl der angegebenen Bits bestimmt die Anzahl der Datenbytes der CAN-Botschaft, für die das Symbol definiert wird. Es müssen immer ganze Byte-Blöcke mit Zeichen gefüllt sein. Gültige "Marker"-Zeichen sind a bis z, A bis Z, 0 bis 9, %, &, so dass maximal 64 Variablen in einem Picture möglich sind.

In den nachfolgenden Zeilen werden den so markierten Bitgruppen Variablenname und Variablentyp zugeordnet. Der Typ der Variablen bestimmt die Interpretation und die Darstellung der Bitgruppe durch PCAN-Explorer.

Eine solche Variablendefinition muss immer in der folgenden Form erfolgen:

Symboldatei (FormatVersion 3.1)

Marker=Variablenname Typ [ Schalter ] [ Optionale Parameter ] [//Kommentar]
Hinweis

Wird ein leerer Picture-Parameter ohne weitere Bitgruppendefinitionen angegeben ("Picture="), gilt die Symboldefinition für eine CAN-Botschaft mit dem Datenlängencode 0.
Beispiele
Symboldatei (FormatVersion 5.0)

DLC=4

Var=Flag1 bit 0,1

Var=Flag2 bit 1,1

Var=Bits unsigned 5,3 -b

Var=Value1 unsigned 8,8 -h

Var=Value2 signed 16,16 -m
Symboldatei (FormatVersion 3.1)

Picture=ccc---ba dddddddd eeeeeeee eeeeeeee

a=Flag1 bit

b=Flag2 bit

c=Bits unsigned -b

d=Value1 unsigned -h

e=Value2 signed -m

Siehe auch

Datentypen

Optionale Schalter für Signal- und Variablendefinitionen

Optionale Parameter für Signal- und Variablendefinitionen

Picture-Parameter: Bit-Sequenz in Variablen


Datentypen

Die folgenden Datentypen werden von Variablen unterstützt:

Typ | Beschreibung | Beispiel
 |  | Bits | Anzeige
Bit | Binäre Darstellung einzelner Bits | 1 | 1
Char | Ein Byte als ASCII-Zeichen | 00001101 | #13
 |  | 01000011 | 'C'
String | ASCII-Zeichenkette | 01000001 01000010 01000011 | "ABC"
 |  | 01000001 00011111 01000011 | "A.C" Bytes, die keinem sichtbaren ASCII-Zeichen entsprechen, werden als Punkte dargestellt.
Signed | 2er-Komplement (2-32 Bit) | 11110010 | -14
Unsigned | Integer ohne Vorzeichen (1-32 Bit) | 11110010 | 242
Float | Gleitkomma gemäß IEEE754 (32 Bit) |  | 1.23
Double | Gleitkommazahlen mit bis zu 16 signifikanten Stellen (64 Bit) |  | 1.23
Enum | Aufzählung (Enumerator, Werte-Liste). Zuweisung von Zeichenfolgen zu einer oder mehreren Signed- oder Unsigned-Konstanten. |  | "Value1"
Raw | Rohdaten. Dieser Typ kann für längere Daten verwendet werden, die mit keinem anderen Datentyp interpretiert werden können. Ausgegeben wird ein String mit hexadezimalen Zeichen. | 01110001 00110101 10001100 | 71358C

Siehe auch

Datentypen Float und Double

Optionale Schalter für Signal- und Variablendefinitionen

Optionale Parameter für Signal- und Variablendefinitionen

Enums


Datentypen Float und Double

Der Typ Float ist zur Darstellung von 32-Bit Gleitkommazahlen im IEEE754-Format einsetzbar. Die 32-Bits einer Variablen dieses Typs müssen immer an den Grenzen von Datenbytes ausgerichtet werden.

Der Typ Double ist zur Darstellung von 64-Bit Gleitkommazahlen einsetzbar. Eine Variable dieses Typs nimmt alle 8 Datenbytes einer CAN-Botschaft ein.

Die Darstellung von Gleitkommawerten in der Empfangs- und Sendeliste kann im Optionen-Dialogfenster auf der Seite Allgemein im Abschnitt Gleitkommawerte festgelegt werden:

Format

Dieser Wert bestimmt das Format des ausgegebenen Wertes. Es kann zwischen Festkomma, wissenschaftlichem oder dem kürzest möglichem Format gewählt werden. Als Standard wird das Festkommaformat verwendet.

Dezimalstellen

Dieser Wert bestimmt die Anzahl der dargestellten Nachkommastellen. Der Standardwert ist 1.

Standard-Dezimaltrennzeichen

Bestimmt das Dezimaltrennzeichen. Folgende Einstellungen sind möglich:

Auto: Das Trennzeichen wird von dem in Windows eingestellten Zahlenformat bestimmt. Eine Änderung des Trennzeichens kann in den entsprechenden Dialogfenstern zu regionalen Einstellungen der Systemsteuerung vorgenommen werden.

Punkt: Das Dezimaltrennzeichen ist ein Punkt.

Komma: Das Dezimaltrennzeichen ist ein Komma.

Das ausgewählte Dezimaltrennzeichen ist ebenfalls bei der Angabe von Gleitkommazahlen in Symboldateien zu berücksichtigen. Es kann aber auch ein lokal gültiges, festes Dezimaltrennzeichen in der Symboldatei spezifiziert werden. Siehe Direkte Werteangaben in Symboldateien.

Siehe auch

Datentypen

Allgemein, Optionen-Dialogfenster


Optionale Schalter für Signal- und Variablendefinitionen

Optional können in der Signal- und Variablendefinition verschiedene Schalter angegeben werden, die beispielsweise das Anzeigeformat steuern. Das Anzeigeformat bestimmt, wie die Signal (-werte) einer symbolischen Botschaft in der Empfangs- und Sendeliste erscheinen. Es können mehrere der Schalter kombiniert werden.

Schalter | Bedeutung
-a | (Alles) Eine Variable wird in der Form Name=Wert angezeigt (Standardeinstellung, nur für Variablendefinitionen).
-b | (binär) Der Signalwert wird in binärer Form ausgegeben.
-d | (dezimal) Der Signalwert wird in dezimaler Form ausgegeben (Standardeinstellung).
-i | (Intel) Die Datenbytes des Signals werden im Intel-Format interpretiert (Standardeinstellung).
-h | (hexadezimal) Der Signalwert wird in hexadezimaler Form ausgegeben.
-m | (Motorola) Die Datenbytes des Signals werden im Motorola-Format interpretiert.
-o | (Off/Aus) Eine Variable wird nicht angezeigt (nur für Variablendefinitionen).
-s | (Standard) Das Signal/die Variable wird in der Spalte Daten angezeigt, auch wenn die Datenansicht zugeklappt ist (falls das Symbol/der Multiplexer mehr als ein Signal enthält).
-t | (Trace) Wird dieser Schalter für ein Signal angegeben, kann ein Botschaftsfilter verwendet werden, um nur die Botschaften durchzulassen, die mindestens ein so "markiertes" Signal enthalten. Dieser Schalter kann auch auf Symbole/Multiplexer angewendet werden. Siehe auch den An markierte Symbole anpassen Filterelementtyp in den Botschaftsfilter-Einstellungen.
-v | (Value/Wert) Nur der Wert der Variablen wird ausgegeben. Ab PCAN-Explorer 5 beeinflusst dieser Schalter nicht mehr die Art und Weise, wie eine Variable in Sende- und Empfangsliste angezeigt wird. Nur noch die Anzeige in Trace-Fenstern und die Ausgabe in von Tracern exportierten Textdateien wird beeinflusst (nur für Variablendefinitionen).
-x | Siehe -h

Die Standardeinstellung der Schalter eines Signals entspricht -i -d (Intel-Format, dezimale Anzeige des Wertes).

Die Standardeinstellung der Schalter einer Variablen entspricht -i -a -d (Intel-Format, Anzeige von Variablenname=Wert, dezimale Anzeige des Wertes).

Siehe auch

Optionale Parameter für Signal- und Variablendefinitionen


Optionale Parameter für Signal- und Variablendefinitionen

Signale und Variablen können zusätzlich mit Anfangswert, Enum, Faktor, Offset, physikalischer Einheit, und anderen Parametern versehen werden. Die folgende Tabelle zeigt alle möglichen optionalen Parameter:

Parameter Beschreibung Beispiel

/d

(Default value) Anfangswert für eine Variable, wenn eine neue Sendebotschaft angelegt wird. Der Anfangswert wird als physikalischer Wert angegeben (siehe Hinweise unten).

/d:123

/e

(Enum) Werte-Liste. Weist der Variablen einen Enum zu, um bei bestimmten Variablenwerten symbolische Namen anzuzeigen.

/e:MyEnum

/f

Faktor/Multiplikator zur Umrechnung des Variablenwerts (siehe Hinweise unten).

Beim Empfang: Der Variablenwert wird mit dem angegebenen Faktor multipliziert.

Beim Senden: Der eingegebene Variablenwert wird durch den Faktor dividiert.

/f:1.5

/ln

Langer Name. Ab FormatVersion 5.0.

Legt einen langen Namen für die Variable fest, der nicht auf eine Länge von 32 Zeichen begrenzt ist wie der normale Name. Lange Namen können eine maximale Länge von 128 Zeichen haben.

/ln:"Mein langer Name"

/m

(Multiplikator) Siehe /f

/m:1.5

/min

(Minimum) Der kleinste physikalische Wert, der für die Variable zugelassen ist.

/min:1

/max

(Maximum) Der größte physikalische Wert, der für die Variable zugelassen ist.

/max:100

/o

Offset zur Umrechnung des Variablenwerts (siehe Hinweise unten).

Beim Empfang: Der angegebene Offset wird zum Variablenwert addiert.

Beim Senden: Der Offset wird vom eingegebenen Variablenwert subtrahiert.

/o:2.2

/p

Anzahl der angezeigten Nachkommastellen für den Variablenwert. Hat nur eine Wirkung, wenn die Variable nicht nur ganzzahlige Werte anzeigt (z.B. bei Verwendung der Datentypen Float und Double, oder durch Angabe von Faktor/Offset).

Die Angabe dieses Parameters überschreibt alle anderen Vorgaben für Nachkommastellen, z.B. den globalen Parameter FloatDecimalPlaces.

/p:4

/spn

J1939: Suspect Parameter Number. Ab FormatVersion 5.0.

/spn:2557

/u

(Unit) Physikalische Einheit der Variablen.

FormatVersion 3.1: Bis zu 10 Zeichen

FormatVersion 5.0 und neuer: Bis zu 16 Zeichen.

/u:km/h

/u:"rpm * 100"

Hinweise:

  • Faktor und Offset können für ein Signal definiert werden, um einen "Rohwert" in einen physikalischen Wert umzurechnen. Ein Rohwert ist der Wert des Signals, wie er über den CAN-Bus übertragen wird. Der physikalische Wert ist dann der Wert der physikalischen Größe (z.B. Luftdruck, Geschwindigkeit), der dann von dem Signal dargestellt wird.

  • Beim Empfang wird erst der Rohwert mit dem Faktor multipliziert und dann der Offset addiert:
    Physikalischer Wert = (Rohwert * Faktor) + Offset

  • Beim Senden wird erst der Offset vom eingegebenen physikalischen Signalwert subtrahiert und dann durch den Faktor dividiert:
    Rohwert = (Physikalischer Wert - Offset) / Faktor

  • Die physikalischen Signalwerte werden in den verschiedenen Fenstern von PCAN-Explorer gemäß dem Ausgabeformat für Gleitkommazahlen formatiert, das im Optionen-Dialogfenster eingestellt werden kann.

  • Die folgenden optionalen Parameter können für Signale und Variablen vom Typ "String" nicht definiert werden:
    Faktor, Offset, Minimum, Maximum, Enum.

Siehe auch

Enums

Picture-Parameter: Bit-Sequenz in Variablen

Optionen-Dialogfenster

FormatVersion-Parameter


Picture-Parameter: Bit-Sequenz in Variablen

Hinweis

Der Picture-Parameter wird nur von Symboldateien unterstützt, die FormatVersion 3.1 oder älter verwenden.

Erstrecken sich Variablen über mehrere Datenbytes, ist es wichtig, die Zusammensetzung der ganzen Variablen nachvollziehen zu können.

Die Bytes der Variablen können entweder im Intel- oder im Motorola-Format angeordnet werden. Die Byte-Reihenfolge bzw. das Datenformat wird für jede Variable getrennt vorgenommen. Als Voreinstellung wird das Intel-Datenformat gewählt. Soll eine Variable im Motorola-Format dargestellt werden, so muss dies durch die Formatierungsanweisung -m in der Zeile mit der Variablendefinition gekennzeichnet werden.

Intel-Format

Beispiel: In einem einfachen Fall besteht eine Variable vom Typ "Signed" aus 16 Bits, die an den Datenbytegrenzen ausgerichtet sind:

Symboldatei

// Byte 0 Byte 1

// 76543210 76543210

Picture=aaaaaaaa aaaaaaaa
a=Variable signed

Im Intel-Format gelten die Bits in Datenbyte 0 als LSB (Least Significant Byte) und die Bits in Datenbyte 1 als MSB (Most Significant Byte).

Nicht so einfach ist es, wenn die Variable um einige Bits verschoben wird:

Symboldatei

// Byte 0 Byte 1 Byte 2

// 76543210 76543210 76543210

Picture=aaa----- aaaaaaaa ---aaaaa
a=Variable signed

In diesem Fall beginnt die Variable im Datenbyte 0 ab Bit 5, welches das lsb (Least Significant Bit) der ganzen Variable ist. Nach Bit 7 folgt Bit 0 in Datenbyte 1. Das msb (Most Significant Bit) der ganzen Variable ist Bit 4 in Datenbyte 2.

Motorola-Format

Im Motorola-Format wird die Byte-Reihenfolge umgekehrt, d.h. die Daten im niedrigsten Datenbyte der Bitgruppe gelten nach der Kodierung als MSB der ganzen Variable.

Symboldatei

// Byte 0 Byte 1

// 76543210 76543210

Picture=aaaaaaaa aaaaaaaa
a=Variable signed -m

Wird als Beispiel eine Variable vom Typ Signed mit 16 Bit Länge definiert, die in den Datenbytes 0 und 1 liegt, sind im Motorola-Format die Bits im Datenbyte 0 das MSB der Variablen und die Bits im Datenbyte 1 das LSB. Das msb befindet sich hierbei im Bit 7 von Datenbyte 0 und das lsb in Bit 0 von Datenbyte 1.

Wird die Bitgruppe um einige Bits verschoben, ist die Anordnung der Bits im Picture-Parameter im Gegensatz zur Anordnung im Intel-Format sequentiell:

Symboldatei

// Byte 0 Byte 1 Byte 2

// 76543210 76543210 76543210

Picture=-----aaa aaaaaaaa aaaaa---
a=Variable signed -m

Die Wertigkeiten der Bits sind hierbei: msb ist Bit 2 von Datenbyte 0, lsb ist Bit 3 von Datenbyte 2, also durchgängig absteigend von links nach rechts.

Siehe auch

Variablen

Optionale Schalter für Variablendefinitionen


Multiplexer

Um verschiedene Datensätze in den Datenbytes einer symbolischen Botschaft bei gleichbleibender CAN-ID zu ermöglichen, können sog. Multiplexer definiert werden. Multiplexer sind besonders behandelte Bits in den Datenbytes, deren Inhalt die Bedeutung der restlichen Datenbytes identifiziert.

Multiplexer können eine Länge von 1 bis 64 Bits annehmen und beliebig innerhalb der Datenbytes positioniert werden, wobei die einzelnen Bits zusammenhängend sein müssen.

Syntax

Multiplexer können über das Schlüsselwort Mux definiert werden (ab FormatVersion 5.0). Die Parameter eine Multiplexerdefinition sind: Name, Position und Länge (durch Komma getrennt), und der Multiplexerwert.

Symboldatei (FormatVersion 6.0)

Mux=Multiplexername Startbit,AnzahlBits MuxWert [Schalter] [//Kommentar]

Als Beispiel wird eine Botschaft mit 5 Datenbytes definiert, wobei sich der Multiplexer in Datenbyte 0 befindet und mit dem Wert 0Ah definiert ist:

Symboldatei (FormatVersion 6.0)

[GeneralVehicleInfo]
ID=032h

Len=5
Mux=DataSet1 0,8 0Ah
Sig=MotorTemperature 8

Wird das ältere Symboldatei-Format 3.1 verwendet, können Multiplexer definiert werden, indem im Picture-Parameter der Symboldefinition die Position des Multiplexers mit dem Multiplexerzeichen gekennzeichnet wird (standardmäßig '*'):

Symboldatei (FormatVersion 3.1)

[GeneralVehicleInfo]
ID=032h
Picture=******** aaaaaaaa aaaaaaaa aaaaaaaa aaaaaaaa
*=DataSet1 0Ah
a=MotorTemperature float

In diesem Format müssen ebenso wie bei Variablen anschließend weitere Angaben zu dieser Bitgruppe gemacht werden. Die Parameterzeile '*= ...' legt den Namen ("DataSet1") und den Wert (0Ah) des Multiplexers fest.

Wenn eine Botschaft empfangen wird, welche die CAN-ID 32h hat, eine Länge von 5 Bytes, und das Datenbyte 0 den Wert 0Ah enthält, dann wird die Botschaft gemäß der Definition dieses Multiplexers angezeigt. Die Datenbytes 1 bis 4 werden als Gleitkommawert interpretiert.

Um einen weiteren Datensatz für diese Botschaft zu erzeugen, muss eine weitere Botschaftsdefinition in die Symboldatei aufgenommen werden. Der Name und der Wert dieses neuen Multiplexers muss sich dabei von dem Vorherigen unterscheiden:

Symboldatei (FormatVersion 6.0)

[GeneralVehicleInfo]

Len=6
Mux=DataSet2 0,8 0Bh

Sig=MotorRPM 8
Sig=CurrentSpeed 32
Symboldatei (FormatVersion 3.1)

[GeneralVehicleInfo]
Picture=******** aaaaaaaa aaaaaaaa -------- bbbbbbbb bbbbbbbb
*=DataSet2 0Bh
a=MotorRPM unsigned
b=CurrentSpeed signed

Die Zeile "ID= ..." kann hierbei weggelassen werden, da die CAN-ID immer von der ersten Definition eines Symbols bestimmt wird. Zu beachten ist auch, dass die Position und Länge der Multiplexer-Bitgruppe immer identisch zu der ersten Multiplexerdefinition sein muss. Die gesamte Anzahl der Datenbytes kann jedoch für jede Multiplexerdefinition unterschiedlich sein.

Einstellen des Multiplexerzeichens (nur FormatVersion 3.1)

Das Zeichen, das im Parameter Picture als Platzhalter für den Multiplexer dient, ist standardmäßig ein Stern (*). Um einer Symboldatei ein bestimmtes Multiplexerzeichen zuzuordnen, kann der globale Parameter MuxChar in die Symboldatei aufgenommen werden:

Symboldatei (FormatVersion 3.1)

MuxChar=Zeichen

Eines der folgenden Zeichen ist als Multiplexerzeichen erlaubt:

# % & ( ) * + ? @, a-z, A-Z.

Optionale Schalter für Multiplexer

Optional können in der Zeile mit der Multiplexerdefinition verschiedene Schalter angegeben werden, die beispielsweise das Anzeigeformat steuern.

Schalter | Beschreibung
-a | (Alles) Der Name des Multiplexers wird angezeigt (Standardeinstellung).
-m | (Motorola) Die einzelnen Bytes des Multiplexers werden im Motorola-Format interpretiert.
-o | (Off/Aus) Der Multiplexer wird nicht angezeigt.
-t | (Trace) Wird dieser Schalter für einen Multiplexer angegeben, kann ein Botschaftsfilter verwendet werden, um nur die Botschaften durchzulassen, die eine entsprechende Multiplexerdefinition besitzen und bei denen dieser Schalter gesetzt ist. Der Schalter -t kann auch auf Variablen bzw. Signale angewendet werden. Siehe auch den An markierte Symbole anpassen Filterelementtyp in den Botschaftsfilter-Einstellungen.
-v | (Value/Wert) Nur der Wert des Multiplexers wird angezeigt.

Zu beachten ist hier, dass bei Verwendung des Schalters -o weder Wert und Name noch die für ihn definierten Variablen in der Empfangs- und Sendeliste erscheinen. Mit diesem Schalter kann somit die Definition eines Multiplexers unwirksam gemacht werden.

Wird kein Schalter angegeben, entspricht dies automatisch dem Schalter -a.

Siehe auch

Globale Parameter

Picture-Parameter: Bit-Sequenz in Multiplexern


Picture-Parameter: Bit-Sequenz in Multiplexern

Hinweis

Der Picture-Parameter wird nur von Symboldateien unterstützt, die FormatVersion 3.1 oder älter verwenden.

Erstrecken sich Multiplexer über mehrere Datenbytes, ist es wichtig, die Zusammensetzung des Multiplexers festlegen zu können.

Die einzelnen Bytes des Multiplexers können entweder im Intel- oder im Motorola-Format angeordnet werden. Die Byte-Reihenfolge wird für jeden Multiplexer getrennt vorgenommen. Als Standardeinstellung ist das Intel-Format gewählt. Soll ein Multiplexer im Motorola-Format definiert werden, so muss dies durch die Formatierungsanweisung -m in der Zeile mit der Multiplexerdefinition gekennzeichnet werden.

Intel-Format

Beispiel: In einem einfachen Fall besteht ein Multiplexer aus 16 Bits, die an den Datenbytegrenzen ausgerichtet sind:

Symboldatei

// Byte 0 Byte 1 Byte 2

// 76543210 76543210 76543210

Picture=******** ******** aaaaaaaa
*=IntelMux 0102h

a=Variable signed

Im Intel-Format gelten die Bits in Datenbyte 0 als LSB (Least Significant Byte) und die Bits in Datenbyte 1 als MSB (Most Significant Byte). Enthält eine empfangene CAN-Botschaft om Datenbyte 0 den Wert 02h und in Datenbyte 1 den Wert 01h, erkennt PCAN-Explorer diesen Multiplexer.

Nicht so einfach ist es, wenn der Multiplexer um einige Bits verschoben wird:

Symboldatei

// Byte 0 Byte 1 Byte 2 Byte 3

// 76543210 76543210 76543210 76543210

Picture=***----- ******** ---***** aaaaaaaa
*=IntelMux 0102h

a=Variable signed

In diesem Fall beginnt der Multiplexer im Datenbyte 0 ab Bit 5, welches das lsb (Least Significant Bit) des ganzen Multiplexers ist. Nach Bit 7 folgt Bit 0 in Datenbyte 1. Das msb (Most Significant Bit) des ganzen Multiplexers ist Bit 4 in Datenbyte 2. Damit dieser Multiplexer von PCAN-Explorer erkannt wird, muss beispielsweise Datenbyte 0 den Wert 40h enthalten, Datenbyte 1 den Wert 20h und Datenbyte 2 den Wert 0.

Motorola-Format

Im Motorola-Format wird die Byte-Reihenfolge umgekehrt, d.h. die Daten im niedrigsten Datenbyte der Bitgruppe gelten nach der Kodierung als MSB des ganzen Multiplexers.

Als Beispiel wird ein Multiplexer mit 16 Bit Länge in den Datenbytes 0 und 1 definiert:

Symboldatei

// Byte 0 Byte 1 Byte 2

// 76543210 76543210 76543210

Picture=******** ******** aaaaaaaa
*=MotorolaMux 0102h -m

a=Variable signed

Hier gelten im Motorola-Format die Bits im Datenbyte 0 als MSB des Multiplexers und die Bits im Datenbyte 1 als LSB. Das msb befindet sich hierbei im Bit 7 von Datenbyte 0, und das lsb in Bit 0 von Datenbyte 1. Damit dieser Multiplexer von PCAN-Explorer erkannt wird, muss Datenbyte 0 den Wert 01h enthalten und Datenbyte 1 den Wert 02h.

Wird die Bitgruppe um einige Bits verschoben, ist die Anordnung der Bits im Picture-Parameter im Gegensatz zur Anordnung im Intel-Format sequentiell:

Symboldatei

// Byte 0 Byte 1 Byte 2 Byte 3

// 76543210 76543210 76543210 76543210

Picture=-----*** ******** *****--- aaaaaaaa
*=MotorolaMux 0102h -m

a=Variable signed

Die Wertigkeiten der Bits sind hierbei: msb ist Bit 2 von Datenbyte 0, lsb ist Bit 3 von Datenbyte 2, also durchgängig absteigend von links nach rechts. Damit dieser Multiplexer von PCAN-Explorer erkannt wird, muss beispielsweise Datenbyte 0 den Wert 0 enthalten, Datenbyte 1 den Wert 08h und Datenbyte 2 den Wert 10h.

Achtung: Vor PCAN-Explorer Version 3.0.3 definierte die Formatangabe -m in der Multiplexerdefinition nicht direkt die Byte-Reihenfolge des Multiplexers in den Datenbytes, sondern legte nur fest, wie die jeweils angegebenen Multiplexerwerte zu interpretieren waren. Diese Formatangabe konnte bei mehreren Multiplexern eines Symbols unterschiedlich angegeben werden. Ab Version 3.0.3 muss jeder Multiplexer eines Symbols mit der gleichen Formatangabe -m definiert werden. Um alte Symboldateien ohne komplette Überarbeitung weiter verwenden zu können, kann am Anfang der alten Symboldatei ein Parameter

FormatVersion=3.0

eingefügt werden, wodurch eine Kompatibilität mit der alten Syntax erzwungen wird. In diesem Fall müssen alle Multiplexer-Bitgruppen an die Grenzen der Datenbytes ausgerichtet sein, wie es in den älteren PCAN-Explorer-Versionen gefordert ist.

Siehe auch

Variablen

Optionale Schalter für Variablendefinitionen

FormatVersion-Parameter


Enums

Ein Enum (Enumerator, Werte-Liste) ist eine Aufzählungsdefinition. Enums können Signalen zugewiesen werden, um bestimmte Werte nicht numerisch, sondern alphanumerisch darzustellen. Dazu werden Texte für bestimmte Zahlenwerte definiert. Stimmt zur Laufzeit der Rohwert eines Signals dann mit einem der definierten Werte überein, wird der Text anstatt des Zahlenwertes angezeigt.

Enumeratoren müssen im Abschnitt {ENUMS} definiert werden.

Syntax
Symboldatei

{ENUMS}

Enum=EnumName(Value_1="Text 1",

Value_2="Text 2",

Value_3..Value_4="Text 3",

...,

Value_N="Text N") [-b]
Bemerkungen

Die angegebenen Werte Value_... können positiv oder negativ sein, und müssen innerhalb des erlaubten Bereichs -2147483648 bis 2147483647 liegen (32-Bit Signed Integer). Wenn hexadezimale Werte angegeben werden, müssen diese im Bereich 0h bis FFFFFFFFh liegen (32-Bit).

Enums werden Signalen oder Variablen mittels des optionalen Parameters /e zugewiesen (siehe Beispiel). Zur Laufzeit dient der Rohwert einer Variablen dazu, einen passenden Enum-Eintrag zu finden. Der Rohwert ist der Wert, wie er über den CAN-Bus übertragen wird, also vor der Umrechnung in einen physikalischen Wert mittels Faktor und Offset. Wird kein passender Enum-Eintrag gefunden, wird der physikalische Wert angezeigt.

Seit PCAN-Explorer 6.1 können bei Verwendung von FormatVersion 6.0 auch Wertebereiche in der Form Value1..Value2="Text" angegeben werden.

Seit PCAN-Explorer 6.4 kann bei Verwendung von FormatVersion 6.0 ein Enum mit Hilfe des optionalen Schalters -b als Bitmaske definiert werden. Bei Bitmasken-Enums werden nur die in den einzelnen Werten auf 1 gesetzten Bits berücksichtigt. Alle anderen Bits sind automatisch Don't-care. Bei der Dekodierung eines Signalwerts können je nach den im Wert gesetzten Bits mehrere Enum-Werte als passend erkannt werden. Die zugeordneten Zeichenketten werden dann mit dem Pipe-Zeichen '|' miteinander verkettet dargestellt.

Beispiele

Im folgenden Beispiel werden für einen neuen Enum-Typ "Color" verschiedene Werte und entsprechende Texte definiert. Entspricht der Wert des Signals "ColorSig" einem der Werte 1 bis 10, wird der entsprechende Text anstatt des Zahlenwerts angezeigt.

Symboldatei (FormatVersion 6.0)

{ENUMS}

Enum=Color(1="Rot", 2="Grün", 3="Blau", 4..10="Bunt")

{SIGNALS}

Sig=ColorSig unsigned 3 /e:Color

{RECEIVE}

[TestSymbol]
ID=123h

Len=1
Sig=ColorSig 0

Ein ähnliches Beispiel für FormatVersion 5.0: Entspricht der Wert der Variablen "ColorVar" einem der Werte 1, 2 oder 3, wird der entsprechende Text anstatt des Zahlenwerts angezeigt. Die Angabe von Wertebereichen ist hier nicht möglich.

Symboldatei (FormatVersion 5.0)

{ENUMS}

enum Color(1="Rot", 2="Grün", 3="Blau")

{RECEIVE}

[TestSymbol]
ID=123h
DLC=1

Var=ColorVar unsigned 0,3 /e:Color

Das folgende Beispiel demonstriert einen Bitmasken-Enum, der Definitionen für vier verschiedene Bits enthält.

Symboldatei (FormatVersion 6.0)

{ENUMS}

Enum=BitMask(1="Bit 0", 2="Bit 1", 4="Bit 2", 8="Bit 3") -b

{SIGNALS}

Sig=BitMaskSig unsigned 4 /e:BitMask

{RECEIVE}

[TestSymbol]
ID=123h
Len=1

Sig=BitMaskSig 0

Siehe auch

Datentypen

Optionale Parameter für Signal- und Variablendefinitionen


Direkte Werteangaben in Symboldateien

Allgemein können Werte in Symboldateien un Makros dezimal, hexadezimal, binär, oder als ASCII-Zeichen angegeben werden (siehe Eingabesyntax verschiedener Werteformate).

Dezimale Werte unterliegen der Beschränkung, dass ihre binäre Repräsentation nicht länger als 32 Bit werden darf. Da Multiplexer bis zu 8 Bytes einnehmen können, müssen solche Werte dann in hexadezimaler Form angegeben werden.

Gleitkommazahlen

Bei Verwendung der Symboldatei-FormatVersion 3.1 oder älter müssen Gleitkommazahlen normalerweise mit dem Dezimaltrennzeichen in die Symboldatei eingetragen werden, das im Optionen-Dialogfenster eingestellt ist. Um eine Symboldatei jedoch unabhängig von lokalen Programmeinstellungen zu machen, kann auch ein festes Dezimaltrennzeichen für eine Symboldatei definiert werden. Um ein Dezimaltrennzeichen festzulegen, muss der Parameter DecimalSeparator im Kopf der Datei eingefügt werden:

Symboldatei

FormatVersion=3.1

DecimalSeparator=Dezimaltrennzeichen

Zulässige Dezimaltrennzeichen sind Punkt '.' oder Komma ','.

In Symboldateien, welche die FormatVersion 5.0 verwenden, muss als Dezimaltrennzeichen immer ein Punkt eingegeben werden.

Siehe auch

Eingabesyntax verschiedener Werteformate


Eingabesyntax verschiedener Werteformate

Die folgende Tabelle zeigt die Möglichkeiten, wie in den verschiedenen Eingabefenstern von PCAN-Explorer Werte eingegeben werden können:

Format | Kennzeichnung, Syntax | Beispiel
 |  | Bits | Wert
Dezimal | Kein Prefix oder Postfix | 00110010 | 50
Hexadezimal | Prefix $ oder Postfix h | 00110010 | 32h or $32
Binär | Postfix b | 00110010 | 110010b
Gleitkomma | Kein Prefix oder Postfix. Das Eingabeformat von Gleitkommazahlen hängt auch von dem im Optionen-Dialogfenster eingestellten Dezimaltrennzeichen ab. Siehe Datentypen Float und Double. |  | 1.47E-3 bzw. 1,47E-3
Einzelne ASCII-Zeichen | Prefix # + ASCII-Code oder Zeichen in Hochkommas | 01000011 | #67 oder 'C'
Zeichenkette/String | Zeichenkette in Anführungszeichen |  | "Abc"
Rohwert | Hexadezimale Zeichen. Ohne Prefix, Postfix oder Anführungszeichen. | 11000100 | C8


Zuweisen von CAN-Botschaften oder Makros zu Funktionstasten

Hinweis

CAN-Botschaften oder Makros auf Funktionstasten zu legen ist nur in Symboldateien erlaubt, die entweder die Format-Versionen 3.0 oder 3.1 verwenden (siehe FormatVersion-Parameter).

Wenn Sie eine dieser älteren Format-Versionen verwenden, dann können Sie CAN-Botschaften auf die Funktionstasten [F2] bis [F12] legen, um eine bestimmte Botschaft mit einem einzigen Tastendruck zu senden. Die Zuweisung muss im Abschnitt {MESSAGEKEYS} einer Symboldatei erfolgen, wobei für jede zuzuweisende Funktionstaste eine Zeile der Form

Symboldatei

{MESSAGEKEYS}

Fn=CAN-ID Länge Datenbytes

oder

Symboldatei

{MESSAGEKEYS}

Fn=Symbol Multiplexer [Var1=Wert [Var2=Wert...VarN=Wert]]

eingefügt werden muss.

Möchten Sie einen Remote Request Frame versenden, müssen Sie das Schlüsselwort RTR anstatt der Datenbytes angeben. Zum Beispiel:

Symboldatei

{MESSAGEKEYS}

Fn=CAN-ID Länge RTR

Starten von Makros

Wenn Sie eine der älteren Format-Versionen verwenden, können Sie auch Makros auf Funktionstasten legen, z.B. um mit einem einzigen Tastendruck eine Sequenz von CAN-Botschaften zu senden. Diese Zuweisungen müssen im Abschnitt {MACROKEYS} einer Symboldatei erfolgen, wobei für jede zuzuweisende Funktionstaste eine Zeile mit folgendem Syntax eingefügt werden muss:

Symboldatei

{MACROKEYS}

Fn=Makroname

Der Parameter Makroname kann hierbei der Name eines Standardmakros oder der Prozedurname eines VBScript-Makros sein.


Symboldatei-Beispiel (FormatVersion 6.0)

Symboldatei

// Dateikopf mit globalen Parametern

FormatVersion=6.0

Title="Sample"

{ENUMS}

// Dieser Abschnitt definiert Wertelisten, die zur Übersetzung von

// bestimmten Werten in lesbare Texte verwendet werden können

Enum MyEnum(1="Links", 2="Rechts", 4="Mitte")

{SIGNALS}

// Dieser Abschnitt definiert alle Signale, die in späteren

// Symboldefinitionen verwendet werden

Sig=CharValue char
Sig=BitValue bit
Sig=HexValue unsigned 4 -h

Sig=BitfieldValue unsigned 16 -b
Sig=MotorolaValue signed 16 -m

Sig=EnumValue unsigned /e:MyEnum

Sig=FloatValue float

Sig=LongValue signed 32 -h -m

Sig=ByteValue unsigned -h /d:123
Sig=IntValue signed 16 /f:1.5 /o:2.2

Sig=UnsignedValue unsigned 32

Sig=RawValue raw 64

{SEND}

// Dieser Abschnitt definiert Symbole für Botschaften, die nur gesendet

// werden

// Das folgende Symbol sendet eine Botschaft mit CAN-ID 222h und Länge 2

// mit einer Zykluszeit von 100 ms

[SendSymbol]
ID=222h

Len=2

CycleTime=100
Sig=CharValue 0
Sig=BitValue 8
Sig=HexValue 10

{RECEIVE}

// Dieser Abschnitt definiert Symbole für Botschaften, die nur empfangen

// werden

// Das folgende Symbol passt zu allen empfangenen Botschaften mit

// CAN-IDs im Bereich 300h bis 400h und Länge 5

[RcvSymbol]
ID=300h-400h

Len=5

Sig=BitfieldValue 0
Sig=MotorolaValue 16

Sig=EnumValue 32

// Die ersten beiden Datenbytes des folgende Symbols enthalten einen

// Multiplexer. Das Symbol passt zu allen empfangenen Botschaften mit

// CAN-ID 111h und Länge 6, das in Datenbyte 0 den Wert 2 und in

// Datenbyte 1 den Wert 1 enthält (Multiplexerwert 0102h im Intel-Format)

[MuxSymbol]
ID=111h
Len=6

Mux=Mux1 0,16 0102h
Sig=FloatValue 16

// Das folgende Symbol erweitert das vorherige Symbol um eine weitere

// Multiplexerdefinition. Die Definition passt zu allen empfangenen

// Botschaften mit CAN-ID 111h und Länge 6, das in Datenbyte 0 den

// Wert 3 und in Datenbyte 1 den Wert 1 enthält

[MuxSymbol]
Len=6

Mux=Mux2 0,16 0103h
Sig=LongValue 16

{SENDRECEIVE}

// Dieser Abschnitt definiert Symbole für Botschaften, die gesendet und

// empfangen werden

// Das folgende Symbol passt zu allen gesendeten und empfangenen

// Botschaften mit CAN-ID 100h und Länge 7

[BiDirSymbol]
ID=100h
Len=7

Sig=ByteValue 0
Sig=IntValue 8
Sig=LongValue 24

// Das folgende Symbol passt zu allen gesendeten und empfangenen

// CAN-FD-Botschaften mit CAN-ID 500h und Länge 12

[FDSymbol]
ID=500h

Type=FDStandard
Len=12

Sig=UnsignedValue 0

Sig=RawValue 32 /d:r445566778899AABB

Siehe auch

Symboldatei-Beispiel (FormatVersion 3.1)

Symboldatei-Beispiel (FormatVersion 5.0)


Symboldatei-Beispiel (FormatVersion 5.0)

Symboldatei

// Dateikopf mit globalen Parametern

FormatVersion=5.0

Title="Sample"

{ENUMS}

// Dieser Abschnitt definiert Wertelisten, die zur Übersetzung von

// bestimmten Werten in lesbare Texte verwendet werden können

Enum MyEnum(1="Links", 2="Rechts", 4="Mitte")

{SEND}

// Dieser Abschnitt definiert Symbole für Botschaften, die nur gesendet

// werden

// Das folgende Symbol sendet eine Botschaft mit CAN-ID 222h und Länge 2

// mit einer Zykluszeit von 100 ms

[SendSymbol]
ID=222h

DLC=2

CycleTime=100
Var=CharVar char 0,8
Var=BitVar bit 8,1
Var=HexVar unsigned 10,4 -h

{RECEIVE}

// Dieser Abschnitt definiert Symbole für Botschaften, die nur empfangen

// werden

// Das folgende Symbol passt zu allen empfangenen Botschaften mit

// CAN-IDs im Bereich 300h bis 400h und Länge 5

[RcvSymbol]
ID=300h-400h

DLC=5

Var=BitfieldVar unsigned 0,16 -b
Var=MotorolaVar signed 16,16 -m

Var=EnumVar unsigned 32,8 /e:MyEnum

// Die ersten beiden Datenbytes des folgende Symbols enthalten einen

// Multiplexer. Das Symbol passt zu allen empfangenen Botschaften mit

// CAN-ID 111h und Länge 6, das in Datenbyte 0 den Wert 2 und in

// Datenbyte 1 den Wert 1 enthält (Multiplexerwert 0102h im Intel-Format)

[MuxSymbol]
ID=111h
DLC=6

Mux=Mux1 0,16 0102h
Var=FloatVar float 16,32

// Das folgende Symbol erweitert das vorherige Symbol um eine weitere

// Multiplexerdefinition. Die Definition passt zu allen empfangenen

// Botschaften mit CAN-ID 111h und Länge 6, das in Datenbyte 0 den

// Wert 3 und in Datenbyte 1 den Wert 1 enthält

[MuxSymbol]
DLC=6

Mux=Mux2 0,16 0103h
Var=LongVar signed 16,32 -h -m

{SENDRECEIVE}

// Dieser Abschnitt definiert Symbole für Botschaften, die gesendet und

// empfangen werden

// Das folgende Symbol passt zu allen gesendeten und empfangenen

// Botschaften mit CAN-ID 100h und Länge 7

[BiDirSymbol]
ID=100h
DLC=7

Var=ByteVar unsigned 0,8 -h /d:123
Var=IntVar signed 8,16 /f:1.5 /o:2.2
Var=LongVar2 signed 24,32 -t

{VIRTUALVARS}

// Dieser Abschnitt definiert virtuelle Variablen, die nicht über

// CAN-Botschaften übertragen werden

Var=VirtualVar unsigned 16

Siehe auch

Symboldatei-Beispiel (FormatVersion 3.1)

Symboldatei-Beispiel (FormatVersion 6.0)


Symboldatei-Beispiel (FormatVersion 3.1)

Symboldatei

// Dateikopf mit globalen Parametern

FormatVersion=3.1

MuxChar=*

DecimalSeparator=.

{ENUMS}

// Dieser Abschnitt definiert Wertelisten, die zur Übersetzung von

// bestimmten Werten in lesbare Texte verwendet werden können

Enum MyEnum(1="Links", 2="Rechts", 4="Mitte")

{SEND}

// Dieser Abschnitt definiert Symbole für Botschaften, die nur gesendet

// werden

// Das folgende Symbol sendet eine Botschaft mit CAN-ID 222h und Länge 2

// mit einer Zykluszeit von 100 ms

[SendSymbol]
ID=222h
Period=100
// Byte 0 Byte 1 Byte 2 Byte 3 Byte 4 Byte 5 Byte 6

// 76543210 76543210 76543210 76543210 76543210 76543210 76543210
Picture=aaaaaaaa --cccc-b
a=CharVar char
b=BitVar bit
c=HexVar unsigned -h

{RECEIVE}

// Dieser Abschnitt definiert Symbole für Botschaften, die nur empfangen

// werden

// Das folgende Symbol passt zu allen empfangenen Botschaften mit

// CAN-IDs im Bereich 300h bis 400h und Länge 5

[RcvSymbol]
ID=300h-400h
Picture=aaaaaaaa aaaaaaaa bbbbbbbb bbbbbbbb cccccccc
a=BitfieldVar unsigned -b
b=MotorolaVar signed -m

c=EnumVar MyEnum

// Die ersten beiden Datenbytes des folgende Symbols enthalten einen

// Multiplexer. Das Symbol passt zu allen empfangenen Botschaften mit

// CAN-ID 111h und Länge 6, das in Datenbyte 0 den Wert 2 und in

// Datenbyte 1 den Wert 1 enthält (Multiplexerwert 0102h im Intel-Format)

[MuxSymbol]
ID=111h
Picture=******** ******** aaaaaaaa aaaaaaaa aaaaaaaa aaaaaaaa
*=Mux1 0102h
a=FloatVar float

// Das folgende Symbol erweitert das vorherige Symbol um eine weitere

// Multiplexerdefinition. Die Definition passt zu allen empfangenen

// Botschaften mit CAN-ID 111h und Länge 6, das in Datenbyte 0 den

// Wert 3 und in Datenbyte 1 den Wert 1 enthält

[MuxSymbol]
Picture=******** ******** aaaaaaaa aaaaaaaa aaaaaaaa aaaaaaaa
*=Mux2 0103h -m
a=LongVar signed -h -m

{SENDRECEIVE}

// Dieser Abschnitt definiert Symbole für Botschaften, die gesendet und

// empfangen werden

// Das folgende Symbol passt zu allen gesendeten und empfangenen

// Botschaften mit CAN-ID 100h und Länge 7

[BiDirSymbol]
ID=100h
Picture=aaaaaaaa bbbbbbbb bbbbbbbb cccccccc cccccccc cccccccc cccccccc
a=ByteVar unsigned -h /d:123
b=IntVar signed /f:1.5 /o:2.2
c=LongVar2 signed -t

{MESSAGEKEYS}

// Dieser Abschnitt legt Funktionstasten fest, die bei Betätigung

// bestimmte Botschaften senden

F3=101h 3 A1h 02h 03h

{MACROKEYS}

// Dieser Abschnitt legt Funktionstasten fest, die bei Betätigung

// bestimmte Makros starten

F4=MeinMakro

Siehe auch

Symboldatei-Beispiel (FormatVersion 5.0)

Symboldatei-Beispiel (FormatVersion 6.0)


Standardmakros

Standardmakros

Leitseite: Referenz

Standardmakros ermöglichen einen gesteuerten Sende- und Empfangsbetrieb. Es wird von PCAN-Explorer ein einfacher Befehlssatz mit den am häufigsten benötigten Funktionen zur Verfügung gestellt.

Standardmakros können beispielsweise für folgende Aufgaben verwendet werden:

  • Senden mehrerer Botschaften mit einem Tastendruck, um z.B. Konfigurationsdaten zu einem CAN-Knoten zu übertragen

  • Verschiedene Botschaften in einem bestimmten Zeitraster senden

  • Eine Antwort auf den Empfang einer bestimmten Botschaft senden

  • Bestimmte Antworten beim Empfang unterschiedlicher Daten senden, um CAN-Knoten zu simulieren, etc.

Aufgrund des einfach gehaltenen Befehlssatzes und einer eingeschränkten Funktionalität können Standardmakros nur begrenzt eingesetzt werden. Für komplexere Aufgaben sollten VBScript-Makros verwendet werden.

In diesem Abschnitt

Format und Syntax von Standardmakros

Beschreibt die allgemeinen Regeln, die beim Erstellen von Standardmakros in Bezug auf Format und Syntax zu beachten sind.

Standardmakro-Schlüsselwörter

Enthält eine Liste aller verfügbaren Schlüsselwörter, die in Standardmakros verwendet werden können.

Standardmakro-Anweisungen

Enthält eine Liste aller verfügbaren Anweisungen, die in Standardmakros eingesetzt werden können.

Verwenden von Sprungmarken

Erklärt die Definition und Verwendung von Sprungmarken, um den Programmablauf zu bestimmten Einsprungspunkten zu verzweigen

Weitere Abschnitte

Fehlermeldungen von Standardmakros

Enthält alle Fehlermeldungen, die im Umgang mit Standardmakros auftreten können.

VBScript-Makros

Enthält Themen über Anwendung von und Referenz zu VBScript-Makros.


Format und Syntax von Standardmakros

Standardmakros müssen die Dateinamenerweiterung .mcr haben. Es gelten folgende allgemeine Regeln bei der Erstellung von Standardmakros:

  • Alle Zeichen zwischen einem Semikolon ';' oder einem Doppelschrägstrich '//' und dem Ende einer Zeile werden als Kommentar angesehen und ignoriert.

  • Leerzeilen werden ignoriert.

  • Jede Makroanweisung muss in einer eigenen Zeile stehen.

  • Groß-/Kleinschreibung wird bei Makroanweisungen nicht beachtet, jedoch bei Bezug auf definierte Sprungmarken.

Namen von Makros

Die Namen der Makros, wie sie auch in der Dropdownliste der Makros-Symbolleiste und im Projekt-Manager erscheinen, werden durch ihren Dateinamen bestimmt, ohne die Dateinamenerweierung .mcr.

Siehe auch

Standardmakro-Anweisungen

Verwenden von Sprungmarken


Datenbytes als Parameter

Datenbytes als Parameter von Standardmakro-Anweisungen können dezimal, hexadezimal, binär, als ASCII-Zeichen oder als Zeichenkette angegeben werden. Siehe Eingabesyntax verschiedener Werteformate.

Werden Werte angegeben, die länger als 1 Byte sind, besteht für Standardmakros ebenso wie für Symboldateien die Möglichkeit, die Werte im Intel- oder Motorola-Format anzugeben. Siehe dazu Direkte Werteangaben in Symboldateien. Voreingestellt ist das Intel-Format.

Angabe von Datenbytes mittels Rohdaten-Zeichenketten

Um für CAN-FD-Botschaften mehr als 8 Datenbytes in einem Wert angeben zu können, führt PCAN-Explorer 6 sog. Rohdaten-Zeichenketten für Standardmakros ein. Diese beginnen mit einem kleinen 'r' als Prefix, und enthalten nachfolgend eine Zeichenkette aus hexadezimalen Zeichen (0-9, A-F, a-f). Auf diese Weise ist es möglich, bis zu 64 Bytes auf einmal anzugeben:

Standardmakro

FormatVersion=6.0

Send 1 110h FD 16 r00112233445566778899AABBCCDEEFF

Send 1 111h 8 r001122

Hierbei werden die einzelnen Bytes von links nach rechts aufsteigend in die Datenbytes der CAN-Botschaft eingesetzt, d.h. Datenbyte 0 erhält den Wert 0, Datenbyte 1 den Wert 11h, usw.

Ist die Zeichenkette nicht lang genug, um alle Datenbytes der Botschaft zu füllen, wird der Rest mit 0 gefüllt. Es wird aber immer bei Datenbyte 0 begonnen, die Daten einzusetzen, d.h. die folgenden Anweisungen sind gleichbedeutend:

Standardmakro

FormatVersion=6.0

Send 1 111h 8 r1122330000000000

Send 1 111h 8 r112233

Angabe von Datenbytes mittels ASCII-Zeichenketten

Datenbytes können auch als Zeichenketten angegeben werden. Die Anzahl der ASCII-Zeichen in der Zeichenkette muss der Anzahl der Datenbytes der Nachricht entsprechen, z.B.:

Standardmakro

Send 1 110h 6 "Text 1"

Auch Zeichenketten können im Intel- oder Motorola-Format in die Datenbytes der Nachricht eingesetzt werden. Um beispielsweise den ASCII-Code des Zeichens 'T' im obigen Beispiel dem Datenbyte 0 der Nachricht zuzuweisen, muss die Zeichenkette als Motorola-Wert konfiguriert werden:

Standardmakro

Send 1 110h 6 "Text 1" -m


Verwenden von Sprungmarken

Sprungmarken dienen zur Verzweigung des Programmablaufs zu bestimmten Einsprungspunkten.

Sprungmarken können definiert werden, indem ein Bezeichner gefolgt von einem Doppelpunkt an den Anfang einer Zeile gesetzt wird.

Syntax

Sprungmarke: [Anweisung Parameter]

Bemerkungen

Sprungmarken können entweder einzeln in einer Zeile stehen oder vor Anweisungen. Beim Bezug auf Sprungmarken durch Verwendung der Anweisungen Goto oder Call darf als Parameter nur der Bezeichner der Sprungmarke ohne den Doppelpunkt angegeben werden.

Beispiel
Standardmakro

FormatVersion=6.0

WaitKey

Call Sub

Repeat

Sub: Send 1 100h 2 12h 34h

Return

Siehe auch

Call-Anweisung

Goto-Anweisung

Return-Anweisung


Standardmakro-Schlüsselwörter

Die folgende Tabelle enthält alle Schlüsselwörter, die in Standardmakros verwendet werden können:

Schlüsselwort | Beschreibung
Bus | Gibt die globale Bus-Nummer für eine Makrodatei an.
FormatVersion | Bestimmt das Format der Standardmakro-Datei.

Siehe auch

Standardmakro-Anweisungen


Bus-Schlüsselwort

Gibt eine globale Bus-Nummer für die Makrodatei an.

Das Bus-Schlüsselwort stellt einen einfachen Weg dar, ältere Standardmakrodateien mit PCAN-Explorer kompatibel zu machen.

Ab PCAN-Explorer 5 steuert das FormatVersion-Schlüsselwort, wie die einzelnen Anweisungen in der Datei interpretiert werden. Einige Änderungen am Makrodatei-Format waren nötig, da PCAN-Explorer 5 Verbindungen mit mehreren CAN-Bussen gleichzeitig erlaubt. Die Standardmakro-Anweisungen wurden ursprünglich aber so entworfen, dass sie nur mit einem einzigen CAN-Bus arbeiten können. Deshalb wurde für manche Anweisungen ein zusätzlicher Bus-Parameter eingeführt, um zu steuern, mit welchem Bus diese Anweisungen arbeiten sollen.

Wenn kein FormatVersion-Parameter am Anfang einer Standardmakrodatei angegeben ist, nimmt PCAN-Explorer an, dass die Makrodatei im dem Format geschrieben ist, die von älteren PCAN-Explorer-Versionen verwendet wurde. In diesem Fall muss zuminest ein globaler Bus-Parameter am Anfang der Makrodatei eingefügt werden, um festzulegen, mit welchem Bus die Makro-Anweisungen zusammenarbeiten, die inzwischen normalerweise einen zusätzlichen Bus-Parameter benötigen. So kann man vermeiden, die Makrodatei komplett zu überarbeiten zu müssen.

Syntax

Bus=BusNummer

Parameter

BusNummer

Die Bus-Nummer (1-16).

Beispiel

Das folgende Beispiel verwendet den globalen Bus-Parameter, um festzulegen, mit welcher Verbindung die Makroanweisungen arbeiten:

Standardmakro

Bus=1

Send 100h 1 AAh

WaitId 0 101h

Loop: Send 102h 2 12h 34h

Wait 200

Goto Loop

Siehe auch

FormatVersion-Schlüsselwort


FormatVersion-Schlüsselwort

Bestimmt das Format der Standardmakrodatei.

Seit PCAN-Explorer 5 steuert das FormatVersion-Schlüsselwort, wie die einzelnen Anweisungen in der Datei interpretiert werden. Einige Änderungen am Makrodatei-Format waren nötig, da PCAN-Explorer 5 Verbindungen mit mehreren CAN-Bussen gleichzeitig erlaubt. Die Standardmakro-Anweisungen wurden ursprünglich aber so entworfen, dass sie nur mit einem einzigen CAN-Bus arbeiten können. Deshalb wurde für manche Anweisungen ein zusätzlicher Bus-Parameter eingeführt, um zu steuern, mit welchem Bus diese Anweisungen arbeiten sollen.

Wenn ein Parameter FormatVersion=5.0 oder größer am Anfang einer Standardmakrodatei angegeben ist, benötigen die folgenden Anweisungen einen zusätzlichen Bus-Parameter:

Send, WaitData, WaitId, WaitMsg und WaitRTR.

Wenn kein FormatVersion-Parameter angegeben ist und das Makro zum ersten Mal gestartet wird, wird ein Dialogfenster angezeigt, das dazu verwendet werden kann, um die Makrodatei einem einzelnen Bus zuzuweisen. In diesem Fall wird ein globaler Bus-Parameter am Anfang der Datei eingefügt.

PCAN-Explorer 6 unstützt Makrodatei-Formate bis Version 6.0.

Syntax

FormatVersion=5.0

oder

FormatVersion=6.0

Beispiel

Das folgende Beispiel verwendet FormatVersion 5.0. Die Anweisungen Send und Wait... benötigen einen zusätzlichen Bus-Parameter:

Standardmakro

FormatVersion=5.0

Send 1 100h 1 AAh

WaitId 0 1 101h

Loop: Send 1 102h 2 12h 34h

Wait 200

Goto Loop

Das folgende Beispiel zeigt dasselbe Makro unter Verwendung des alten Syntax. Der globale Bus-Parameter steuert, mit welcher Verbindung die Anweisungen arbeiten:

Standardmakro

Bus=1

Send 100h 1 AAh

WaitId 0 101h

Loop: Send 102h 2 12h 34h

Wait 200

Goto Loop

Siehe auch

Bus-Schlüsselwort


Standardmakro-Anweisungen

Die folgende Tabelle enthält alle Anweisungen, die in Standardmakros eingesetzt werden können:

Anweisung | Beschreibung
Call | Ruft ein Unterprogramm an der angegebenen Sprungmarke auf.
CheckData | Vergleicht nach einer erfolgreichen WaitMsg, WaitId oder WaitData-Anweisung die Daten der empfangenen Botschaft mit bestimmten Werten.
CheckId | Prüft die CAN-ID der letzten empfangenen Botschaft.
CheckMsgType | Prüft den Typ der letzten empfangenen Botschaft.
CheckSignal | Vergleicht einen Signalwert mit einer bestimmten Zahl oder Zeichenkette.
ClearOutput | Löscht den Inhalt des Makrostatus-Fensters.
ClearQueue | Löscht den Empfangspuffer des Makros.
DecSignal | Verkleinert einen Signalwert.
End | Beendet die Ausführung des Makros.
ExecuteCommand | Führt einen PCAN-Explorer-Befehl aus.
Goto | Setzt die Ausführung des Makros an der angegegebenen Sprungmarke fort.
If | Fragt das Ergebnis-Flag ab und ruft in Abhängigkeit davon eine angegebene Anweisung auf.
IncSignal | Erhöht einen Signalwert.
PauseTrace | Unterbricht die Aufzeichnung von CAN-Botschaften in dem aktiven Tracer.
Print | Gibt Text in das Makrostatus-Fenster aus.
PrintSignal | Gibt einen Signalwert in das Makrostatus-Fenster aus.
PrintToOutputWindow | Gibt Text in das Ausgabe-Fenster aus.
Repeat | Setzt die Ausführung am Anfang des Makros fort.
Return | Beendet ein Unterprogramm.
Send | Sendet eine CAN-Botschaft.
SetSignal | Setzt den Wert eines Signals.
StartTrace | Startet die Aufzeichnung von CAN-Botschaften.
StatusOutput | Steuert, ob Statusmeldungen in das Makrostatus-Fenster ausgegeben werden.
Stop | Beendet die Ausführung des Makros.
StopTrace | Beendet die Aufzeichnung von CAN-Botschaften.
Wait | Wartet die angegebene Zeitdauer.
WaitData | Wartet auf den Empfang einer bestimmten CAN-Botschaft.
WaitId | Wartet auf den Empfang einer CAN-Botschaft mit der angegebenen CAN-ID.
WaitKey | Wartet bis eine beliebige Taste gedrückt wurde.
WaitMsg | Wartet auf den Empfang einer Botschaft.
WaitRTR | Wartet auf den Empfang eines Remote Request Frames.
WaitSignal | Wartet darauf, dass ein Signal gesetzt wird.

Siehe auch

Standardmakro-Schlüsselwörter


Call-Anweisung

Ruft ein Unterprogramm an der angegebenen Sprungmarke auf.

Syntax

Call Label

Parameter

Label

Gibt den Namen der Sprungmarke an, an der die Ausführung fortgesetzt werden soll. Bei der Angabe des Namens der Sprungmarke muss die korrekte Groß-/Kleinschreibung beachtet werden.

Bemerkungen

Zum Verlassen des aufgerufenen Unterprogramms muss die Return-Anweisung ausgeführt werden. Die Ausführung wird dann mit der Anweisung fortgesetzt, die sich direkt nach der Call-Anweisung befindet.

Bei der Ausführung dieser Anweisung wird die aktuelle Ausführungsposition auf einen Stapel, dem sog. Stack, abgelegt. Der Stack kann maximal 100 Positionen aufnehmen. Ist de Stack voll, wird zur Ausführungszeit des Makros eine entsprechende Fehlermeldung ausgegeben und das Makro angehalten.

Beispiel

Das folgende Beispiel wartet darauf, dass eine Taste gedrückt wird, und ruft dann das Unterprogramm "Sub" auf:

Standardmakro

FormatVersion=6.0

WaitKey

Call Sub

Repeat

Sub: Send 1 100h 2 12h 34h

Return

Siehe auch

Return-Anweisung

Verwenden von Sprungmarken


CheckData-Anweisung

Vergleicht nach einer erfolgreichen WaitMsg, WaitId oder WaitData-Anweisung die Daten der empfangenen Botschaft mit bestimmten Werten.

Syntax

CheckData Länge Datenbytes

Parameter

Länge

Die Anzahl der Datenbytes, auf die geprüft werden soll. 0-8 Bytes bei CAN-Botschaften, maximal 64 Bytes bei CAN-FD-Botschaften (0-8, 12, 16, 20, 24, 32, 48, 64).

Datenbytes

Die Datenbytes, mit denen die Empfangsdaten verglichen werden sollen. Mit Hilfe des Zeichens '*' können Sie nicht relevante Daten als "Don't Care" markieren. Siehe auch das Beispiel unten.

Bemerkungen

Stimmen die angegebenen Daten mit den Daten der Botschaft überein, auf die zuletzt gewartet wurde, so wird das Ergebnis-Flag auf True gesetzt, andernfalls auf False.

Beispiele

Im folgenden Beispiel wird auf eine bestimmte CAN-Botschaft gewartet, und vergleicht dann deren Daten. Wenn im Datenbyte 0 der Wert A0h enthalten ist, wird eine Botschaft 101h als Antwort gesendet:

Standardmakro

FormatVersion=6.0

WaitId 0 1 100h

// Länge Daten

CheckData 3 A0h * *

If True

Send 101h 2 12h 34h

Repeat

Siehe auch

Datenbytes als Parameter

WaitId-Anweisung


CheckId-Anweisung

Prüft die CAN-ID der letzten empfangenen Botschaft.

Syntax

CheckId CAN-ID

oder

CheckId Bus Symbol

Parameter

CAN-ID

Gibt die ID der CAN-Botschaft an, auf die geprüft werden soll. Eine 3-stellige hexadezimale CAN-ID bis max. 7FFh legt einen Standard-Frame (11-Bit-ID) fest, eine hexadezimale CAN-ID mit mehr als 3 Stellen legt einen Extended Frame (29-Bit-ID) fest. Wenn Sie die CAN-ID dezimal angeben, ist ein Extended Frame erst ab CAN-ID 2048 möglich.

Bus

Die Bus-Nummer (1-16) einer Verbindung, deren Symbole zur Dekodierung des nachfolgenden Parameters Symbol verwendet werden sollen.

Symbol

Der Name des Symbols, dessen CAN-ID geprüft werden soll.

Bemerkungen

Stimmt die CAN-ID der zuletzt empfangenen Botschaft mit dem angegebenen Wert überein, wird das Ergebnis-Flag auf True gesetzt, andernfalls auf False.

Beispiel

Das folgende Beispiel wartet auf den Empfang einer CAN-Botschaft und prüft dann mit Hilfe mehrerer CheckId-Anweisungen, welche ID empfangen wurde:

Standardmakro

FormatVersion=6.0

WaitMsg Infinite 1

CheckId 100h

If True

Call ID100

CheckId 200h

If True

Call ID200

Repeat

ID100:

// Verarbeite CAN-ID 100h

...

Return

ID200:

// Verarbeite CAN-ID 200h

...

Return

Siehe auch

WaitMsg-Anweisung

CheckMsgType-Anweisung


CheckMsgType-Anweisung

Prüft den Typ der letzten empfangenen Botschaft.

Syntax

CheckMsgType Typ

Parameter

Typ

Ein oder mehrere Botschaftstypen, auf die geprüft werden soll. Werden mehrere Typen angegeben, sind die einzelnen Typen durch Kommas zu trennen.

Folgende Typ-Angaben sind möglich:

Typ | Beschreibung
STD | Standard 11-Bit Botschaft
EXT | Extended 29-Bit Botschaft
RTR | Remote Transmission Request
FD | CAN-FD-Botschaft
BRS | CAN-FD-Botschaft mit aktiviertem Bit Rate Switch
ESI | CAN-FD-Botschaft mit gesetztem Error State Indicator Bit

Bei der Auswertung der angegebenen Typen wird nicht zwischen Groß- und Kleinschreibung unterschieden.

Bemerkungen

Sind in der geprüften CAN-Botschaft alle angegebenen Botschaftstypen vorhanden, wird das Ergebnis-Flag auf True gesetzt, andernfalls auf False.

Beispiel

Das folgende Beispiel wartet auf den Empfang einer CAN-Botschaft und untersucht dann dessen Typ:

Standardmakro

FormatVersion=6.0

WaitMsg Infinite 1

CheckMsgType EXT,FD

If True

Print "Extended 29-Bit und CAN FD"

CheckMsgType STD

If True

Print "Standard 11-Bit"

...

Siehe auch

WaitMsg-Anweisung


CheckSignal-Anweisung

Vergleicht einen Signalwert mit einer bestimmten Zahl oder Zeichenkette.

Syntax

CheckSignal SignalName Operator Wert

Parameter

SignalName

Der Name des Signals. Sie können entweder den voll qualifizierten Signalnamen angeben, oder den Kurznamen des Signals.

Operator

Bestimmt den Vergleich, der durchgeführt wird.

Die folgenden Operatoren werden unterstützt:

Operator | Beschreibung
= | Prüft, ob der Signalwert identisch mit dem angegebenen Wert ist. Wenn Wert eine Zeichenkette und keine Zahl ist, wird der Vergleich unabhängig von der Groß-/Kleinschreibung durchgeführt.
== | Ist Wert eine Zeichenkette, wird der Vergleich unter Beachtung der Groß-/Kleinschreibung durchgeführt. Nicht anwendbar wenn Wert eine Zahl ist.
> | Prüft, ob der Signalwert größer als der angegebene Wert ist.
>= | Prüft, ob der Signalwert größer oder gleich dem angegebenen Wert ist.
< | Prüft, ob der Signalwert kleiner als der angegebene Wert ist.
<= | Prüft, ob der Signalwert kleiner oder gleich dem angegebenen Wert ist.

Wert

Der Operand mit dem der Vergleich durchgeführt wird. Kann eine Zahl oder eine Zeichenkette sein.

Bemerkungen

Das Ergebnis des Vergleichs wird im Ergebnis-Flag gespeichert.

Beispiel

Das folgende Beispiel wartet darauf, dass das Signal "MeinSignal" gesetzt wird, und prüft dann dessen Wert:

Standardmakro

FormatVersion=6.0

WaitSignal Infinite MeinSignal

CheckSignal MeinSignal > 123.45

If True

Print "MeinSignal ist größer als 123,45"

CheckSignal MeinSignal <= 10

If True

Print "MeinSignal ist <= 10"

Das folgende Beispiel setzt das Signal "MeinStringSignal" auf den Wert "STEFAn" und führt einige Vergleiche durch:

Standardmakro

FormatVersion=6.0

SetSignal MeinStringSignal "STEFAn"

CheckSignal MeinStringSignal > "STEFAN"

If True

Print "STEFAn ist größer als STEFAN"

// Beachten Sie, dass das Ergebnis des Vergleichs True ist

// weil der Wert von 'n' großer ist als der Wert von 'N'

CheckSignal MeinStringSignal = "STEFAN"

If True

Print "True: STEFAn = STEFAN"

CheckSignal MeinStringSignal == "STEFAN"

If False

Print "False: STEFAn == STEFAN"

Siehe auch

If-Anweisung

SetSignal-Anweisung

WaitSignal-Anweisung


ClearOutput-Anweisung

Löscht den Inhalt des Makrostatus-Fensters.

Syntax

ClearOutput

Beispiel

Das folgende Beispiel löscht den Inhalt des Makrostatus-Fensters, nachdem eine CAN-Botschaft von Bus 1 empfangen wurde:

Standardmakro

FormatVersion=6.0

WaitMsg 0 1

ClearOutput

Print "Botschaft empfangen"

...

Siehe auch

Makrostatus-Fenster


ClearQueue-Anweisung

Löscht den Empfangspuffer des Makros.

Syntax

ClearQueue

Bemerkungen

Wird im Makro eine der Anweisungen WaitData, WaitID, WaitKey, WaitMsg oder WaitRTR verwendet, wird der Empfangsfilter des Standardmakros automatisch so konfiguriert, dass er alle benötigten CAN-Botschaften im Empfangspuffer zwischengespeichert. Wenn eine der genannten Wait-Anweisungen ausgeführt wird, werden die Botschaften im Empfangspuffer ausgelesen, angefangen bei der ältesten Botschaft, um festzustellen, ob eine passende Botschaft empfangen wurde. Sobald eine passende Botschaft gefunden wird, wird das Auslesen des Puffers abgebrochen.

Der Empfangspuffer eines Standardmakros kann maximal 512 CAN-Botschaften speichern. Oft ist es nötig, den Empfangspuffer zu löschen, bevor eine der Wait-Anweisungen ausgeführt wird, da sich im Empfangspuffer irrelevante oder veraltete Botschaften angesammelt haben könnten.

Beispiel

Das folgende Beispiel löscht den Empfangspuffer, bevor es beginnt, auf eine angeforderte CAN-Botschaft zu warten:

Standardmakro

FormatVersion=6.0

ClearQueue

Send 1 100h 2 AAh 01h

WaitId 1 1000 101h

...

Siehe auch

WaitData-Anweisung

WaitId-Anweisung

WaitMsg-Anweisung

WaitRTR-Anweisung


DecSignal-Anweisung

Verkleinert einen Signalwert.

Syntax

DecSignal SignalName [Wert]

Parameter

SignalName

Der Name des Signals. Sie können entweder den voll qualifizierten Signalnamen angeben, oder den Kurznamen des Signals.

Wert

(Optional) Der Betrag, um den der Signalwert verkleinert werden soll. Nur ganzzahlige Werte sind erlaubt. Wird diese Angabe weggelassen, wird der Signalwert um 1 verkleinert.

Beispiele

Das folgende Beispiel verkleinert einen Signalwert:

Standardmakro

FormatVersion=6.0

SetSignal MeinSignal 100

DecSignal MeinSignal

DecSignal MeinSignal 10

DecSignal Symboldatei1.MeinSymbol.MeinSignal 4

Der Wert von MeinSignal ist 85 wenn das Makro ausgeführt wurde.

Siehe auch

IncSignal-Anweisung

SetSignal-Anweisung


End-Anweisung

Beendet die Ausführung des Makros.

Syntax

End

Beispiel

Das folgende Beispiel beendet nach dem Aufruf des Unterprogramms "Sub" die Ausführung des Makros:

Standardmakro

FormatVersion=6.0

WaitKey

Call Sub

End

Sub: Send 1 100h 2 12h 34h

Send 1 101h 1 AAh

Return

Siehe auch

Stop-Anweisung


ExecuteCommand-Anweisung

Führt einen PCAN-Explorer-Befehl aus.

Syntax

ExecuteCommand Befehl

Parameter

Befehl

Der Name des Befehls, der ausgeführt werden soll.

Beispiel

Das folgende Beispiel beendet PCAN-Explorer, wenn eine Botschaft 100h empfangen wird:

Standardmakro

FormatVersion=6.0

WaitId 0 1 100h

ExecuteCommand ApplicationExit

Siehe auch

PCAN-Explorer-Befehle


Goto-Anweisung

Setzt die Ausführung des Makros an der angegebenen Sprungmarke fort.

Syntax

Goto Label

Parameter

Label

Gibt den Namen der Sprungmarke an, an der die Ausführung fortgesetzt werden soll. Bei der Angabe des Namens der Sprungmarke muss die korrekte Groß-/Kleinschreibung beachtet werden.

Beispiel

Im folgenden Beispiel wird bei Erreichen der Goto-Anweisung ein Teil des Makros endlos ausgeführt:

Standardmakro

FormatVersion=6.0

Send 1 100h 1 AAh

WaitId 0 1 101h

Loop: Send 1 102h 2 12h 34h

Wait 200

Goto Loop

Siehe auch

Verwenden von Sprungmarken


If-Anweisung

Fragt das Ergebnis-Flag ab und ruft in Abhängigkeit dessen Wertes eine angegebene Anweisung auf.

Syntax

If Flag

Anweisung

Parameter

Flag

Der Wert des Ergebnis-Flags, auf den getestet werden soll. Mögliche Werte sind:

  • True: Das Ergebnis der Abfrage ist wahr, wenn das Ergebnis-Flag den Wert "True" enthält.

  • False: Das Ergebnis der Abfrage ist wahr, wenn das Ergebnis-Flag den Wert "False" enthält.

Anweisung

Diese Anweisung wird ausgeführt, wenn das Ergebnis der Abfrage wahr ist. Ist das Ergebnis falsch, wird die Anweisung übersprungen.

Bemerkungen

Das Ergebnis-Flag wird durch die Anweisungen CheckData, CheckId, CheckMsgType, CheckSignal, WaitData, WaitId, WaitKey, WaitMsg, WaitRTR und WaitSignal beeinflusst.

Achtung: Die Anweisung, die bei einem wahren Ergebnis ausgeführt werden soll, muss in der Zeile stehen, die der If-Anweisung folgt.

Beispiel

Das folgende Beispiel wartet auf den Empfang verschiedener CAN-Botschaften und reagiert darauf:

Standardmakro

FormatVersion=6.0

Send 1 100h 1 AAh

WaitId 1000 1 101h

If False

Stop

Send 1 102h 2 12h 34h

WaitId 1000 1 103h

If True

Send 1 104h 2 12h 34h

Repeat

Siehe auch

WaitData-Anweisung

WaitId-Anweisung

WaitMsg-Anweisung

WaitRTR-Anweisung

WaitSignal-Anweisung


IncSignal-Anweisung

Erhöht einen Signalwert.

Syntax

IncSignal SignalName [Wert]

Parameter

SignalName

Der Name des Signals. Sie können entweder den voll qualifizierten Signalnamen angeben, oder den Kurznamen des Signals.

Wert

(Optional) Der Betrag, um den der Signalwert erhöht werden soll. Nur ganzzahlige Werte sind erlaubt. Wird diese Angabe weggelassen, wird der Signalwert um 1 erhöht.

Beispiele

Das folgende Beispiel erhöht einen Signalwert:

Standardmakro

FormatVersion=6.0

SetSignal MeinSignal 100

IncSignal MeinSignal

IncSignal MeinSignal 10

IncSignal Symboldatei1.MeinSymbol.MeinSignal 4

Der Wert von MeinSignal ist 115 wenn das Makro ausgeführt wurde.

Siehe auch

DecSignal-Anweisung

SetSignal-Anweisung


PauseTrace-Anweisung

Unterbricht die Aufzeichnung von CAN-Botschaften.

Syntax

PauseTrace

Bemerkungen

Diese Anweisung hat nur eine Wirkung, falls zuvor ein Tracer mit Hilfe der Anweisung StartTrace gestartet wurde.

Beispiel

Im folgenden Beispiel wird der Tracer angehalten, wenn eine Botschaft mit der ID 201h empfangen wurde:

Standardmakro

FormatVersion=6.0

StartTrace

Loop: Send 1 101h 3 01h 12h 34h

Wait 100

Send 1 101h 3 02h 56h 78h

Wait 100

Send 1 200h 1 AAh

WaitId 500 1 201h

If False

Goto Loop

PauseTrace

Siehe auch

StartTrace-Anweisung

StopTrace-Anweisung


Print-Anweisung

Gibt Text in das Makrostatus-Fenster aus.

Syntax

Print Text

Parameter

Text

Der auszugebende Text. Enthält der Text Leerzeichen, muss er in Anführungszeichen gesetzt werden. Die maximale Länge des Textes darf 30 Zeichen (inklusive Anführungszeichen) nicht überschreiten.

Bemerkungen

Der ausgegebene Text erscheint per Voreinstellung in grüner Farbe im Makrostatus-Fenster. Sie können die Farbe im Optionen-Dialogfenster auf der Seite Schriftarten und Farben anpassen.

Beispiel

Das folgende Beispiel gibt verschiedene Texte aus:

Standardmakro

FormatVersion=6.0

Send 1 100h 1 AAh

WaitId 1000 1 101h

If False

Stop

Print "Datenübertragung..."

Send 1 102h 2 12h 34h

Wait 200

Send 1 103h 2 56h 78h

Wait 200

Send 1 104h 2 90h ABh

Wait 200

Send 1 105h 2 CDh EFh

Print "Fertig"

Siehe auch

Makrostatus-Fenster

PrintToOutputWindow-Anweisung

ClearOutput-Anweisung


PrintSignal-Anweisung

Gibt einen Signalwert in das Makrostatus-Fenster aus.

Syntax

PrintSignal SignalName

Parameter

SignalName

Der Name des Signals. Sie können entweder den voll qualifizierten Signalnamen angeben, oder den Kurznamen des Signals.

Bemerkungen

Der ausgegebene Signalwert erscheint per Voreinstellung in blauer Farbe im Makrostatus-Fenster. Sie können die Farbe im Optionen-Dialogfenster auf der Seite Schriftarten und Farben anpassen.

Beispiel

Das folgende Beispiel wartet darauf, dass das Signal "MeinSignal" gesetzt wird, und gibt dann dessen aktuellen Wert aus:

Standardmakro

FormatVersion=6.0

StatusOutput False

WaitSignal Infinite MeinSignal

ClearOutput

PrintSignal MeinSignal

Repeat

Siehe auch

Makrostatus-Fenster

StatusOutput-Anweisung

WaitSignal-Anweisung

ClearOutput-Anweisung


PrintToOutputWindow-Anweisung

Gibt Text in das Ausgabe-Fenster aus.

Syntax

PrintToOutputWindow Text

Parameter

Text

Der auszugebene Text. Der Text muss in Anführungszeichen gesetzt werden. Die maximale Länge des Textes darf 30 Zeichen (inklusive Anführungszeichen) nicht überschreiten.

Bemerkungen

Der Text erscheint im Ausgabe-Fenster auf der Registerseite Makro.

Beispiel

Das folgende Beispiel gibt verschiedene Texte in das Ausgabe-Fenster aus:

Standardmakro

FormatVersion=6.0

Send 1 100h 1 AAh

WaitId 1000 1 101h

If False

Stop

PrintToOutputWindow "Datenübertragung..."

Send 1 102h 2 12h 34h

Wait 200

Send 1 103h 2 56h 78h

Wait 200

Send 1 104h 2 90h ABh

Wait 200

Send 1 105h 2 CDh EFh

PrintToOutputWindow "Fertig"

Siehe auch

Ausgabe-Fenster

Print-Anweisung


Repeat-Anweisung

Setzt die Ausführung am Anfang des Makros fort.

Syntax

Repeat

Beispiel

Im folgenden Beispiel wird ein Makro durch die Repeat-Anweisung endlos ausgeführt:

Standardmakro

FormatVersion=6.0

Send 1 100h 2 12h 34h

Wait 500

Repeat


Return-Anweisung

Beendet ein mittels der Call-Anweisung aufgerufenes Unterprogramm.

Syntax

Return

Bemerkungen

Durch Ausführung der Return-Anweisung wird der oberste Wert vom Stapel (Stack) geholt und als neue Ausführungsposition betrachtet. Ist der Stack leer, und kann keine neue Ausführungsposition bestimmt werden, wird zur Ausführungszeit des Makros eine entsprechende Fehlermeldung ausgegeben und das Makro angehalten.

Beispiel

Das folgende Beispiel demonstriert den Aufruf eines Unterprogramms:

Standardmakro

FormatVersion=6.0

WaitId 0 1 100h

Call Sub

Repeat

Sub: Send 1 101h 2 12h 34h

Return

Siehe auch

Call-Anweisung


Send-Anweisung

Sendet eine CAN-Botschaft.

Syntax

Send Bus CAN-ID [Typ] Länge Datenbytes

oder

Send Bus Symbol Multiplexer Datenbytes

Parameter

Bus

Die Bus-Nummer (1-16) identifiziert die Verbindung, über welche die Botschaft gesendet wird. Ist das Schlüsselwort AnyBus angegeben, wird die Botschaft auf allen aktivierten CAN-Verbindungen gesendet.

CAN-ID

Gibt die ID der CAN-Botschaft an, die gesendet werden soll. Eine 3-stellige CAN-ID bis max. 7FFh sendet einen Standard-Frame (11-Bit-ID), eine CAN-ID mit mehr als 3 Stellen sendet einen Extended Frame (29-Bit-ID).

Typ

(Optional, ab FormatVersion 6) Gibt einen zusätzlichen Typ für die CAN-Botschaft an. Der Typ kann aus einem oder mehreren Einzelwerten bestehen, durch Kommas voneinander getrennt. Mögliche Typangaben sind:

  • FD Sendet die Botschaft als CAN-FD-Botschaft.

  • BRS Sendet die Botschaft als CAN-FD-Botschaft mit gesetztem Bit Rate Switch. Die Datenfelder eines CAN-FD-Frames werden mit einer höheren Bitrate übertragen, wenn Bit Rate Switch aktiviert ist.

  • ESI Sendet die Botschaft als CAN-FD-Botschaft mit gesetztem Error State Indicator. Der Error State Indicator gibt an, ob sich der Absender der Botschaft im Zustand Error Active oder Error Passive befindet.

  • RTR Sendet einen Remote Request Frame.

  • SS Sendet die Botschaft mit der Option Single Shot Transmission. Siehe NXP Application Note AN97076 "SJA1000 Stand-alone CAN controller", Abschnitt 5.4.

Länge

Bestimmt die Anzahl der Datenbytes. 0-8 Bytes für CAN-Botschaft, maximal 64 Bytes für CAN-FD-Botschaften (0-8, 12, 16, 20, 24, 32, 48, 64).

Datenbytes

Die Datenbytes der Botschaft. Soll ein Remote Request Frame gesendet werden, und wurde RTR nicht mittels Typ-Parameter festgelegt, muss hier das Schlüsselwort RTR angegeben werden.

Symbol

Der Name eines Symbols, das gesendet werden soll. Damit ein Makro ausgeführt werden kann, das Namen von Symbolen und Multiplexern enthält, muss für den angegebenen Bus eine Symboldatei aktiviert sein, die diese Symbole und Multiplexer definiert.

Multiplexer

Der Name eines Multiplexers, der für das Symbol definiert ist. Soll ein Symbol gesendet werden, für das kein Multiplexer definiert ist, muss als Multiplexer der Wert "<Empty>" angegeben werden.

Beispiel

Das folgende Beispiel zeigt die verschiedenen Möglichkeiten, CAN-Botschaften zu senden:

Standardmakro

FormatVersion=6.0

// Standard Frame

Send 1 100h 1 AAh

// Extended Frame

Send 1 1234h 3 11h 22h 33h

// CAN-FD-Frame

Send 1 100h FD,BRS 12 r0011223344556677889900AABB

// Sende mit Symbolangaben

Send 1 DataService Init A1h

// Sende Datensätze

Send 1 DataService Data 01h 12h 34h

Send 1 DataService Data 02h 56h 78h

Send 1 DataService Data 03h 90h 00h

Send 1 DataService Complete A1h

// Symbol2 hat keinen Multiplexer

Send 1 Symbol2 <Empty> AAh BBh

// RTR-Botschaft

Send 1 200h RTR 3

// Sende auf allen Bussen

Send AnyBus 300h 2 12h 34h

Siehe auch

FormatVersion-Schlüsselwort

Datenbytes als Parameter


SetSignal-Anweisung

Setzt den Wert eines Signals.

Syntax

SetSignal SignalName Wert

Parameter

SignalName

Der Name des Signals. Sie können entweder den voll qualifizierten Signalnamen angeben, oder den Kurznamen des Signals.

Wert

Der neue Wert des Signals. Um Fließkommawerte anzugeben, verwenden Sie einen Punkt als Dezimaltrennzeichen. Um eine Zeichenkette anzugeben, die Leerzeichen enthält, setzen Sie die Zeichenkette in Anführungszeichen.

Beispiele

Das folgende Beispiel setzt verschiedene Signalwerte:

Standardmakro

FormatVersion=6.0

SetSignal MeinSignal 123

SetSignal MeinSignal 1.23

SetSignal StringSignal Hallo

SetSignal StringSignal "Test 1"

SetSignal Symboldatei1.MeinSymbol.UniverselleAntwort 42

Siehe auch

DecSignal-Anweisung

IncSignal-Anweisung


StartTrace-Anweisung

Startet die Aufzeichnung von CAN-Botschaften.

Syntax

StartTrace [Dateiname]

Parameter

Dateiname

(Optional) Der Name einer bereits geöffneten Trace-Datei, die für die Aufzeichnung verwendet werden soll. Falls kein Dateiname angegeben ist, oder falls keine Trace-Datei mit dem angegebenen Namen bereits geöffnet ist, wird ein neuer Tracer gestartet.

Beispiel

Im folgenden Beispiel wird ein Tracer gestartet, wenn eine CAN-Botschaft mit der ID 101h empfangen wird:

Standardmakro

FormatVersion=6.0

Send 1 100h 1 AAh

WaitId 1000 1 101h

If False

Stop

StartTrace

Send 1 101h 3 01h 12h 34h

Wait 100

Send 1 101h 3 02h 56h 78h

Wait 100

StopTrace

Siehe auch

StopTrace-Anweisung


StatusOutput-Anweisung

Steuert, ob Statusmeldungen in das Makrostatus-Fenster ausgegeben werden.

Syntax

StatusOutput Wert

Parameter

Wert

  • True: Es werden Statusmeldungen in das Makrostatus-Fenster ausgegeben.

  • False: Es werden keine Statusmeldungen in das Makrostatus-Fenster ausgegeben.

Bemerkungen

Die StatusOutput-Anweisung beeinflusst nicht die Statusmeldungen der WaitKey-Anweisung, Ausgaben der Print-Anweisung, sowie die Ausgabe von Fehlermeldungen.

Beispiel

Das folgende Beispiel schaltet die Statusmeldungen im Makrostatus-Fenster zunächst ab, so dass die erste Anweisung WaitMsg keinen Eintrag "Warte auf nächste Botschaft auf Bus 1..." erzeugt, und anschließend wieder ein:

Standardmakro

FormatVersion=6.0

StatusOutput False

WaitMsg 0 1

Print "Botschaft empfangen"

StatusOutput True

WaitMsg 0 1

Print "Noch eine Botschaft empfangen"

...

Siehe auch

Makrostatus-Fenster


Stop-Anweisung

Beendet die Ausführung des Makros.

Syntax

Stop

Beispiel

Das folgende Beispiel beendet nach dem Aufruf des Unterprogramms "Sub" die Ausführung des Makros:

Standardmakro

FormatVersion=6.0

WaitKey

Call Sub

Stop

Sub: Send 1 100h 2 12h 34h

Send 1 101h 1 AAh

Return

Siehe auch

End-Anweisung


StopTrace-Anweisung

Beendet die Aufzeichnung von CAN-Botschaften.

Syntax

StopTrace

Bemerkungen

Diese Anweisung hat nur eine Wirkung, wenn zuvor ein Tracer mit Hilfe der StartTrace-Anweisung gestartet wurde.

Beispiel

Im folgenden Beispiel wird der Tracer beendet, wenn eine CAN-Botschaft mit der ID 201h auf Bus 1 empfangen wird:

Standardmakro

FormatVersion=6.0

StartTrace

Loop: Send 1 101h 3 01h 12h 34h

Wait 100

Send 1 101h 3 02h 56h 78h

Wait 100

Send 1 200h 1 AAh

WaitId 500 1 201h

If False

Goto Loop

StopTrace

Siehe auch

StartTrace-Anweisung

PauseTrace-Anweisung


Wait-Anweisung

Wartet die angegebene Zeitdauer.

Syntax

Wait Zeit

Parameter

Zeit

Die Zeitdauer, die gewartet werden soll, in Millisekunden.

Beispiel

Im folgenden Beispiel wird eine CAN-Botschaft kontinuierlich im Abstand von 500 ms gesendet:

Standardmakro

FormatVersion=6.0

Send 1 100h 2 12h 34h

Wait 500

Repeat


WaitData-Anweisung

Wartet auf den Empfang einer bestimmten CAN-Botschaft.

Syntax

WaitData Zeit Bus CAN-ID [Typ] Länge Datenbytes

oder

WaitData Zeit Bus Symbol Multiplexer Datenbytes

Parameter

Zeit

Die Zeitdauer, die gewartet werden soll, in Millisekunden. Der Wert 0 oder die Angabe des Schlüsselwortes Infinite bewirkt endloses Warten.

Bus

Die Bus-Nummer (1-16) identifiziert die Verbindung, auf der die Botschaft erwartet wird. Wenn Sie das Schlüsselwort AnyBus angeben, können Botschaften von allen aktivierten Verbindungen einen WaitData-Erfolg auslösen. Die Angabe von AnyBus ist jedoch nur erlaubt, wenn auf eine bestimmte CAN-ID gewartet wird, und nicht auf eine Symbol/Multiplexer-Kombination.

CAN-ID

Gibt die ID der CAN-Botschaft an, auf die Sie warten möchten. Eine 3-stellige CAN-ID bis max. 7FFh legt einen Standard-Frame (11-Bit-ID) fest, eine CAN-ID mit mehr als 3 Stellen legt einen Extended Frame (29-Bit-ID) fest.

Typ

(Optional, ab FormatVersion 6) Gibt einen zusätzlichen Typ von Daten an. Mögliche Typen sind:

  • FD Wartet auf eine CAN-FD-Botschaft.

Länge

Die Anzahl der Datenbytes, auf die gewartet werden soll. 0-8 Bytes für CAN-Botschaften, maximal 64 Bytes für CAN-FD-Botschaften (0-8, 12, 16, 20, 24, 32, 48, 64).

Datenbytes

Die Daten der Botschaft. Mit Hilfe des Zeichens '*' können Sie nicht relevante Daten als "Don't Care" markieren. Siehe Beispiele unten für weitere Informationen.

Symbol

Der Name eines Symbols, auf das Sie warten möchten. Damit ein Makro ausgeführt werden kann, das Namen von Symbolen und Multiplexern enthält, müssen Sie der Verbindung, mit der Sie in dem Makro arbeiten, eine Symboldatei zuweisen.

Multiplexer

Der Name eines Multiplexers, der für das angegebene Symbol definiert ist. Möchten Sie auf ein Symbol warten, für das kein Multiplexer definiert ist, geben Sie den Wert "<Empty>" an.

Bemerkungen

Wurde innerhalb der Wartezeit eine passende Botschaft empfangen, so wird das Ergebnis-Flag auf True gesetzt, andernfalls auf False.

Oft wird es nötig sein, den Empfangspuffer des Makros zu löschen, bevor auf eine Botschaft gewartet wird. Befinden sich noch irrelevante Botschaften im Empfangspuffer, kann dies zu unvorhergesehenen Ergebnissen führen. Siehe dazu ClearQueue-Anweisung.

Beispiele

Im folgenden Beispiel wird auf eine bestimmte CAN-Botschaft gewartet, bevor Daten gesendet werden:

Standardmakro

FormatVersion=6.0

Send 1 100h 1 AAh

// Zeit Bus ID Länge Daten

WaitData 1000 1 101h 3 BBh CCh DDh

If False

Stop

// Beginne Datenübertragung

Send 1 DataService Data 12h 34h

WaitData 1000 1 DataService DataControl FFh

If True

Send 104h 2 56h 78h

Im folgenden Beispiel wird auf eine CAN-FD-Botschaft gewartet:

Standardmakro

FormatVersion=6.0

// Zeit Bus ID Typ Länge Daten

WaitData 1000 1 101h FD 12 r00112233445566778899AABB

Das folgende Beispiel verwendet Don't Care-Markierungen um festzulegen, dass nur Datenbyte 1 relevant ist:

Standardmakro

FormatVersion=6.0

// Zeit Bus ID Länge Daten

WaitData 0 AnyBus 101h 3 * CCh *

Don't Care-Markierungen können auch in hexadezimalen oder binären Werten verwendet werden:

Standardmakro

FormatVersion=6.0

// Zeit Bus ID Länge Daten

WaitData 0 1 101h 1 C*h

WaitData 0 1 102h 1 0*011**0b

WaitData 0 1 103h 3 *Fh 0*011**0b *

WaitData 0 1 104h 8 r00**223344556677

Siehe auch

Datenbytes als Parameter

WaitMsg-Anweisung

WaitId-Anweisung

WaitRTR-Anweisung

ClearQueue-Anweisung

CheckData-Anweisung


WaitId-Anweisung

Wartet auf den Empfang einer CAN-Botschaft mit einer bestimmten CAN-ID.

Syntax

WaitId Zeit Bus CAN-ID

oder

WaitId Zeit Bus Symbol

Parameter

Zeit

Die Zeitdauer, die gewartet werden soll, in Millisekunden. Der Wert 0 oder die Angabe des Schlüsselwortes Infinite bewirkt endloses Warten.

Bus

Die Bus-Nummer (1-16) identifiziert die Verbindung, auf der die Botschaft erwartet wird. Wenn Sie das Schlüsselwort AnyBus angeben, können Botschaften von allen aktivierten Verbindungen einen WaitId-Erfolg auslösen.

CAN-ID

Gibt die ID der CAN-Botschaft an, auf die Sie warten möchten. Eine 3-stellige hexadezimale CAN-ID bis max. 7FFh legt einen Standard-Frame (11-Bit-ID) fest, eine hexadezimale CAN-ID mit mehr als 3 Stellen legt einen Extended Frame (29-Bit-ID) fest. Wenn Sie die CAN-ID dezimal angeben, ist ein Extended Frame erst ab CAN-ID 2048 möglich.

Symbol

Der Name eines Symbols, auf das Sie warten möchten. Damit ein Makro ausgeführt werden kann, das Namen von Symbolen und Multiplexern enthält, müssen Sie der Verbindung, mit der Sie in dem Makro arbeiten, eine Symboldatei zuweisen.

Bemerkungen

Wurde innerhalb der Wartezeit eine passende Botschaft empfangen, so wird das Ergebnis-Flag auf True gesetzt, andernfalls auf False.

Oft wird es nötig sein, den Empfangspuffer des Makros zu löschen, bevor auf eine Botschaft gewartet wird. Befinden sich noch irrelevante Botschaften im Empfangspuffer, kann dies zu unvorhergesehenen Ergebnissen führen. Siehe dazu ClearQueue-Anweisung.

Beispiel

Das folgende Beispiel wartet auf eine CAN-Botschaft mit einer bestimmten CAN-ID, bevor Daten gesendet werden:

Standardmakro

FormatVersion=6.0

Send 1 100h 2 AAh 01h

WaitId 1000 1 101h

If False

Stop

// Beginne Datenübertragung

Send 1 DataService Data 12h 34h

Send 1 DataService Data 56h 78h

...

Siehe auch

WaitMsg-Anweisung

WaitData-Anweisung

WaitRTR-Anweisung

ClearQueue-Anweisung


WaitKey-Anweisung

Wartet auf das Drücken einer beliebigen Taste.

Syntax

WaitKey [Zeit]

Parameters

Zeit

(Optional) Die Zeitdauer, die gewartet werden soll, in Millisekunden. Der Wert 0 oder die Angabe des Schlüsselwortes Infinite bewirkt endloses Warten.

Bemerkungen

Wurde eine Wartezeit angegeben, und innerhalb der Wartezeit eine Taste gedrückt, so wird das Ergebnis-Flag auf True gesetzt, andernfalls auf False.

Beispiel

Das folgende Beispiel sendet nach jedem Tastendruck eine CAN-Botschaft:

Standardmakro

FormatVersion=6.0

WaitKey

Send 1 100h 2 12h 34h

Repeat

Siehe auch

Send-Anweisung

Repeat-Anweisung


WaitMsg-Anweisung

Wartet auf den Empfang einer Botschaft.

Syntax

WaitMsg Zeit Bus

Parameters

Zeit

Die Zeitdauer, die gewartet werden soll, in Millisekunden. Der Wert 0 oder die Angabe des Schlüsselwortes Infinite bewirkt endloses Warten.

Bus

Die Bus-Nummer (1-16) identifiziert die Verbindung, auf der die Botschaft erwartet wird. Wenn Sie das Schlüsselwort AnyBus angeben, können Botschaften von allen aktivierten Verbindungen einen WaitMsg-Erfolg auslösen.

Bemerkungen

Wurde innerhalb der Wartezeit eine Botschaft empfangen, so wird das Ergebnis-Flag auf True gesetzt, andernfalls auf False.

Oft wird es nötig sein, den Empfangspuffer des Makros zu löschen, bevor auf eine Botschaft gewartet wird. Befinden sich noch irrelevante Botschaften im Empfangspuffer, kann dies zu unvorhergesehenen Ergebnissen führen. Siehe dazu ClearQueue-Anweisung.

Beispiel

Das folgende Beispiel wartet mehrfach auf eine CAN-Botschaft:

Standardmakro

FormatVersion=6.0

Send 1 100h 2 01h AAh

WaitMsg 1000 1

If False

Stop

Send 1 100h 2 02h ABh

WaitMsg 1000

If False

Stop

Send 1 100h 2 03h ACh

...

Siehe auch

WaitId-Anweisung

WaitData -Anweisung

WaitRTR-Anweisung

ClearQueue-Anweisung


WaitRTR-Anweisung

Wartet auf den Empfang eines Remote Request Frames.

Syntax

WaitRTR Zeit Bus CAN-ID [Länge]

oder

WaitRTR Zeit Bus Symbol [Länge]

Parameter

Zeit

Die Zeitdauer, die gewartet werden soll, in Millisekunden. Der Wert 0 oder die Angabe des Schlüsselwortes Infinite bewirkt endloses Warten.

Bus

Die Bus-Nummer (1-16) identifiziert die Verbindung, auf der die Botschaft erwartet wird. Wenn Sie das Schlüsselwort AnyBus angeben, können Botschaften von allen aktivierten Verbindungen einen WaitRTR-Erfolg auslösen.

CAN-ID

Gibt die ID der CAN-Botschaft an, auf die Sie warten möchten. Eine 3-stellige CAN-ID bis max. 7FFh legt einen Standard-Frame (11-Bit-ID) fest, eine CAN-ID mit mehr als 3 Stellen legt einen Extended Frame (29-Bit-ID) fest.

Symbol

Der Name eines Symbols, auf das Sie warten möchten. Damit ein Makro ausgeführt werden kann, das Namen von Symbolen und Multiplexern enthält, müssen Sie der Verbindung, mit der Sie in dem Makro arbeiten, eine Symboldatei zuweisen.

Länge

(Optional) Die Anzahl der Datenbytes (0-8) der CAN-Botschaft, auf die Sie warten möchten.

Wird der Parameter weggelassen, führt jede mögliche Datenlänge (0-8) zu einem Erfolg beim Warten.

Wird der Parameter angegeben, bestimmt die Projektoption Data Length Code ignorieren im Projekteinstellungen-Dialogfenster auf der Seite CAN, ob auf einen Remote Request Frame gewartet wird, dessen Data Length Code mit dem Parameter Länge übereinstimmt.

Bemerkungen

Wurde innerhalb der Wartezeit eine passende Botschaft empfangen, so wird das Ergebnis-Flag auf True gesetzt, andernfalls auf False.

Oft wird es nötig sein, den Empfangspuffer des Makros zu löschen, bevor auf eine Botschaft gewartet wird. Befinden sich noch irrelevante Botschaften im Empfangspuffer, kann dies zu unvorhergesehenen Ergebnissen führen. Siehe dazu ClearQueue-Anweisung.

Beispiel

Das folgende Beispiel wartet mehrfach auf den Empfang eines Remote Request Frames:

Standardmakro

FormatVersion=6.0

Send 1 100h 2 AAh 01h

WaitRTR 1000 1 101h 3

If True

Send 1 101h 3 11h 22h 33h

WaitRTR 500 1 DataService Data

If True

Send 1 DataService 3 01h 02h 03h

Siehe auch

WaitMsg-Anweisung

WaitId-Anweisung

WaitData-Anweisung

ClearQueue-Anweisung


WaitSignal-Anweisung

Wartet darauf, dass ein Signal gesetzt wird.

Syntax

WaitSignal Zeit SignalName

Parameter

Zeit

Die Zeitdauer, die gewartet werden soll, in Millisekunden. Der Wert 0 oder die Angabe des Schlüsselwortes Infinite bewirkt endloses Warten.

SignalName

Der Name des Signals. Sie können entweder den voll qualifizierten Signalnamen angeben, oder den Kurznamen des Signals.

Bemerkungen

Wurde das Signal innerhalb der Wartezeit gesetzt, wird das Ergebnis-Flag auf True gesetzt, andernfalls auf False.

Beispiel

Das folgende Beispiel wartet darauf, dass das Signal "MeinSignal" gesetzt wird, und prüft dann dessen Wert:

Standardmakro

FormatVersion=6.0

WaitSignal Infinite MeinSignal

CheckSignal MeinSignal > 12.5

If True

// Etwas tun

Siehe auch

CheckSignal-Anweisung


Fehlermeldungen

Fehlermeldungen

Leitseite: Referenz

Dieser Abschnitt führt alle Fehlermeldungen auf, die beim Arbeiten mit Symboldateien und Standardmakros sowie im Sende- und Empfangsbetrieb auftreten können.

In diesem Abschnitt

Fehlermeldungen von Symboldateien

Enthält alle Fehlermeldungen, die im Umgang mit Symboldateien auftreten können.

Fehlermeldungen von Standardmakros

Enthält alle Fehlermeldungen, die im Umgang mit Standardmakros auftreten können.

Hardware-Status

Beschreibt die Statusmeldungen von PCAN-Hardware, die beim Senden und Empfangen von CAN-Botschaften auftreten können.

Weitere Abschnitte

VBScript-Fehler

Enthält alle Fehlermeldungen, die während der Ausführung eines VBScript-Makros oder während der Kompilierungsphase auftreten können.

Benutzeroberfläche

Enthält Referenz-Themen für die verschiedenen Dialogfelder und Fenster von PCAN-Explorer.

PCAN-Explorer-Befehle

Enthält eine Beschreibung der vordefinierten PCAN-Explorer-Befehle.


Fehlermeldungen von Symboldateien

Fehlermeldungen von Symboldateien werden im Ausgabe-Fenster auf der Registerkarte Meldungen angezeigt. Wenn ein Fehler auftritt wird das Ausgabe-Fenster automatisch eingeblendet, wenn es noch nicht sichtbar gewesen ist. Es wird immer eine Fehlernummer und Kurzbeschreibung angegeben.

Folgende Fehler können angezeigt werden

Nr. Angezeigter Text Beschreibung

1

Syntax-Fehler

An der Cursor-Position liegt ein Fehler im Syntax der Symboldatei vor.

2

Schlüsselwort erwartet

An der angegebenen Position wird ein Schlüsselwort erwartet.

3

Unbekanntes Schlüsselwort

Das markierte Schlüsselwort existiert nicht.

4

Schlüsselwort an dieser Stelle nicht erlaubt

Das verwendete Schlüsselwort ist an der angegebenen Position nicht erlaubt.

5

'=' erwartet

An der angegebenen Position wird das Zeichen '=' erwartet.

6

':' erwartet

An der angegebenen Position wird ein Doppelpunkt erwartet.

7

Integer-Wert erwartet

An der angegebenen Position wird ein Integer-Wert erwartet.

8

Zeichenkette erwartet

An der angegebenen Position wird eine Zeichenkette erwartet.

9

CAN-ID erwartet

An der angegebenen Position wird ein CAN-ID erwartet.

10

Bezeichner zu lang

Der markierte Bezeichner hat mehr als 30 Zeichen.

11

Bezeichner erwartet

An der angegebenen Position wird ein Name für das zu definierende Objekt (Symbol, Multiplexer, Variable, Signal) erwartet.

12

Schlüsselwort an diesem Punkt nicht erlaubt

Das markierte Schlüsselwort darf nicht als Name eines Symbols, Multiplexers oder einer Variablen eingesetzt werden.

13

Symboldatei-Format nicht unterstützt

Es ist versucht worden, eine Symboldatei einzulesen, deren Format von der verwendeten Version von PCAN-Explorer noch nicht unterstützt wird.

15

Fehlender Wert von Parameter...

An der Cursor-Position fehlt der Wert des angegebenen Parameters.

16

Ungültiger Wert

Die markierte Textstelle ergibt keinen gültigen Wert.

20

CAN-ID bereits in Verwendung durch...

Die im Parameter ID angegebene CAN-ID wird bereits in einer anderen Definition eines Empfangssymbols oder bidirektionalen Symbols verwendet.

Eine CAN-ID, die in den Abschnitten {RECEIVE} oder {SENDRECEIVE} einem Symbol zugewiesen wurde, darf immer nur einmal vergeben werden, da es für PCAN-Explorer beim Empfang einer solchen CAN-ID ansonsten unmöglich wäre, das richtige Symbol zuzuordnen und anzuzeigen. Im Abschnitt {SEND} ist es dagegen möglich, mehreren Symbolen die gleiche CAN-ID zuzuordnen.

21

CAN-ID-Bereiche nur erlaubt für Nur-Empfangen-Symbole

Die Angabe eines Bereichs von CAN-IDs im Parameter ID der Symboldefinition ist nur für Symbole erlaubt, die im Abschnitt {RECEIVE} definiert sind.

22

Timeouts nicht erlaubt für Sendesymbole

Die Angabe eines Parameters Timeout ist nur für Symbole erlaubt, die nicht im Abschnitt {RECEIVE} definiert sind.

23

CAN-ID nicht angegeben

In der Symboldefinition wurde keine CAN-ID angegeben.

24

Die CAN-ID des Symbols wurde bereits zu ... in einer früheren Symbol-/Multiplexerdefinition festgelegt

In einer Multiplexerdefinition wurde eine andere CAN-ID angegeben, als in einer vorherigen. Nur in der ersten Definition des Symbols wird die Angabe der CAN-ID benötigt.

25

Typ passt nicht zur angegebenen Extended CAN-ID

Im Parameter ID wurde eine Extended 29-Bit CAN-ID angegeben, aber mit Hilfe des Parameters Typ wird versucht, die ID als Standard 11-Bit CAN-ID zu definieren.

32

Bits nicht innerhalb der Byte-Grenzen

Die markierte Bitgruppe des Parameters Picture enthält nicht genau 8 Bits.

33

Ungültiges Marker-Zeichen

Es wurde ein nicht erlaubter Platzhalter für eine Variable verwendet. Erlaubte Platzhalter sind die Zeichen 'a'..'z', 'A'..'Z', '0'..'9', '%' und '&'.

34

Bitgruppe ... nicht in Picture definiert

Die Bitgruppe mit dem angegebenen Platzhalter ist nicht im Parameter Picture definiert worden.

35

Fehler in Bitgruppe ... Prüfen Sie auf Motorola/Intel-Format

Die Anordnung der Bits im Parameter Picture passt nicht zur Definition der Variablen. Eventuell ist bei der Definition der Bitgruppe das Motorola- oder Intel-Format nicht eingehalten worden. Siehe auch Bit-Sequenz in Variablen.

40

Wert zu groß für 8 Bits

Der angegebene Wert ist zu groß, um in 8 Bits bzw. ein einzelnes Byte zu passen.

41

Wertebereich überschritten. Der erlaubte Wertebereich ist ... bis ...

Es wurde versucht, einer Variablen einen Wert zuzuweisen, dessen binäre Darstellung mehr Bits enthält, als die Variable aufnehmen kann.

42

Anzahl Zeichen im String ist nicht korrekt

Der String-Parameter enthält nicht die geforderte Anzahl von ASCII-Zeichen. Bei der Angabe einer Zeichenkette für die Datenbytes einer CAN-Botschaft z.B. im Abschnitt {MESSAGEKEYS} darf die Länge der Zeichenkette nicht die Anzahl der Datenbytes der Nachricht überschreiten.

43

Rohdaten-Zeichenkette zu lang für ... Bits

Die Rohdaten-Zeichenkette ergibt zu viele Bytes und kann nicht der Variable/dem Signal zugewiesen werden.

50

Unbekannter Datentyp

Der in der Variablendefinition angegebene Datentyp ist unbekannt.

51

Variable hat zu viele Bits

Die Länge der Variable passt nicht zum angegebenen Datentyp.

52

Nicht genügend Bits für Datentyp 'Signed'

Es wurde versucht, einem einzelnen Bit den Datentyp Signed zuzuweisen. Vorzeichenbehaftete Variablen müssen mindestens eine Länge von 2 Bits haben.

53

Zu viele Bits für Datentyp 'Bit'

Der Datentyp Bit wurde einer Bitgruppe mit mehr als einem Bit zugewiesen.

54

Falsche Anzahl Bits für Datentyp 'Char'

Der Datentyp Char wurde einer Bitgruppe zugewiesen, die nicht genau aus 8 Bits besteht.

55

Falsche Anzahl Bits für Datentyp 'String'

Der Datentyp String wurde einer Bitgruppe zugewiesen, deren Länge nicht einem vielfachen von 8 Bits entspricht.

56

Falsche Anzahl Bits für Datentyp 'Float'

Der Datentyp Float wurde einer Bitgruppe zugewiesen, die nicht aus genau 32 Bits besteht. Siehe auch Datentypen Float und Double.

57

Falsche Anzahl Bits für Datentyp 'Double

Der Datentyp Double wurde einer Bitgruppe zugewiesen, die nicht aus genau 64 Bits besteht. Siehe auch Datentypen Float und Double.

58

Faktor 0 wird eine Division durch Null bewirken. Prüfen Sie das eingestellte Dezimaltrennzeichen

Es wurde ein Faktorwert von 0 angegeben. Dies ist nicht zulässig, da dann bei der Umrechnung eine Division durch 0 auftreten würde. Dieser Fehler kann auch durch die Verwendung eines falschen Dezimaltrennzeichens verursacht werden, wenn der ganzzahlige Anteil 0 ist.

59

Variable nicht an Byte-Grenzen ausgerichtet

Variablen, die einen der Typen Double, String oder Raw haben, müssen immer an die Grenzen der Datenbytes ausgerichtet werden.

60

Ungültiges Anzeigeformat

Einem Multiplexer oder einer Variablen ist ein ungültiges Anzeigeformat zugewiesen worden.

Gültige Werte für das Multiplexer-Anzeigeformat sind:

-o (keine Anzeige),

-v (Anzeige des Wertes),

-a (Anzeige des Namens).

Gültige Werte für das Variablen-Anzeigeformat sind:

-o (keine Anzeige),

-v (Anzeige des Wertes),

-a (Bezeichner und Wert).

61

Neudefinition des Marker-Zeichens für die Variable

Der Variablen-Platzhalter an der Cursor-Position ist innerhalb des Parameters Picture bereits an anderer Stelle verwendet worden.

62

Variablenname wird bereits verwendet

Der markierte Variablenname wird bereits in einer anderen Variablendefinition verwendet.

64

Einheit zu lang (Max. ... Zeichen)

Die angegebene Variableneinheit ist länger als 10 Zeichen (FormatVersion 3.1) oder 16 Zeichen (FormatVersion 5.0 oder neuer).

65

Langer Name zu lang (Max. 128 Zeichen)

Der angegebene lange Name hat mehr als 128 Zeichen.

66

Variablen können nicht kürzer als 1 Bit sein

Variablen müssen eine Mindestlänge von 1 Bit haben.

67

Enum-Zuweisung nicht erlaubt

Enums können nur Variablen des Typs Bit, Signed und Unsigned zugewiesen werden.

68

Variablendefinition 'Var=...' erwartet

Im Abschnitt {VIRTUALVARS} dürfen nur Variablendefinitionen in der Form "Var=..." vorgenommen werden.

70

Multiplexername wird bereits verwendet

Für dieses Symbol wurde bereits ein anderer Multiplexer mit dem angegebenen Namen definiert.

71

Multiplexerwert wird bereits verwendet

Für dieses Symbol wurde bereits ein anderer Multiplexer mit dem gleichen Wert definiert.

72

Neudefinition der Multiplexerlänge für Symbol ...

Die Bitgruppe des Multiplexers wurde für dieses Symbol bereits mit einer anderen Länge definiert. Alle Multiplexer eines Symbols müssen die gleiche Länge haben.

73

Neudefinition des Multiplexerstarts für Symbol ...

Die Position der Bitgruppe des Multiplexers wurde für dieses Symbol bereits anders definiert. Alle Multiplexer eines Symbols müssen sich an der gleichen Position befinden.

74

Symbol wurde zuerst in Abschnitt {...} definiert

Es wurdet versucht, einen neuen Multiplexer für ein Symbol zu definieren, das ursprünglich in einer anderen Sektion definiert wurde. Sämtliche Multiplexer eines Symbols müssen in der gleichen Sektion definiert werden.

75

Neudefinition der Multiplexer-Bytereihenfolge für Symbol ...

Die Byte-Reihenfolge des Multiplexers wurde für das angegebenen Symbol zuvor schon anders definiert (Intel/Motorola). Siehe auch Bit-Sequenz in Multiplexern.

76

Die minimale Datenlänge für dieses Symbol beträgt ... Bytes

Für das Symbol wurde bereits mindestens ein Multiplexer definiert. Die Anzahl der Datenbytes darf deshalb den angegebenen Wert nicht unterschreiten, da ansonsten die Multiplexer-Bitgruppe teilweise oder ganz außerhalb der gültigen Datenbytes liegen würde.

77

Multiplexer-Bitgruppe nicht in Picture-Parameter angegeben, oder Multiplexerdefinition fehlt

Für das Symbol wurde bereits mindestens ein Multiplexer definiert. Jedoch wurde in der Definition eines weiteren Multiplexers entweder dessen Bitgruppe nicht erneut im Parameter Picture eingetragen, oder die Zuweisung eines Namens und Wertes fehlt (z.B. "*=Name Wert").

78

Multiplexer-Bitgruppe nicht in Picture-Parameter angegeben

Für das Symbol wurde bereits mindestens ein Multiplexer definiert, Jedoch wurde in der Definition eines weiteren Multiplexers dessen Bitgruppe nicht erneut im Parameter Picture eingetragen.

79

Ein Symbol mit dem selben Datenlängencode wurde bereits definiert

Für ein Symbol ohne Multiplexer-Bitgruppe können nur mehrere Definitionen getroffen werden, wenn sich bei jeder Definition zumindest der Datenlängencode unterscheidet.

80

Schlüsselwort 'Enum' erwartet

An der angegebenen Position wird das Schlüsselwort Enum erwartet.

81

Enum-Name erwartet

An der angegebenen Position wird der Name der zu definierenden Aufzählung erwartet.

82

Enum-Neudefinition

Die markierte Aufzählung existiert bereits.

83

'(' erwartet

An der angegeben Position wird das Zeichen '(' erwartet.

84

Komma oder ')' erwartet

An der angegeben Position wird entweder ein Komma oder das Zeichen ')' erwartet.

90

Ungültiger Datenlängencode

Der angegebene Datenlängencode einer CAN-Botschaft liegt nicht im Bereich von 0-8.

91

Funktionstaste bereits belegt

Die angegebene Funktionstaste ist bereits belegt.

92

Unbekanntes Symbol

Das markierte Symbol ist nirgends definiert worden.

93

Symbol ... ist ein Nur-Empfangen-Symbol

Das angegebene Symbol wurde nur für den Empfang definiert.

94

Multiplexername erwartet

An der angegebenen Position wird der Name eines Multiplexers erwartet.

95

Multiplexer ist nicht in diesem Symbol enthalten

Der markierte Multiplexer wurde nicht für das davor angegebene Symbol definiert.

96

Variable ist nicht in diesem Multiplexer enthalten

Die markierte Variable wurde nicht für den davor angegebenen Multiplexer definiert.

97

Makro nicht gefunden

Das markierte Makro existiert nicht in der Liste der geladenen Makros.

110

Variablen-Markerzeichen erwartet

An der angegebenen Position wird ein Variablen-Platzhalter erwartet.

111

Variablenname erwartet

An der angegebenen Position wird der Name einer Variablen erwartet.

112

Datentyp erwartet

An der angegebenen Position wird die Angabe eines Datentyps erwartet.

113

Optionsschalter erwartet

An der angegebenen Position wird ein optionaler Schalter erwartet.

114

Parameter-Zeichen erwartet

An der angegebenen Position wird ein Zeichen erwartet, das einen optionalen Parameter darstellt. Gültige optionale Parameter sind z.B. /d /f /m /o und /u.

120

'}' erwartet

An der angegeben Position wird das Zeichen '}' erwartet.

121

Ungültiger Abschnittsbezeichner

Ein ungültiger Sektionsbezeichner wurde angegeben.

122

']' erwartet

An der angegebenen Position wird das Zeichen ']' erwartet.

131

Komma erwartet

An der angegebenen Position wird ein Komma erwartet.

132

Datentyp nicht länger unterstützt wenn FormatVersion 5 oder neuer verwendet wird

Der angegebene Datentyp wird nicht länger unterstützt.

133

Nur einzelne CAN-IDs können einer J1939-Parametergruppe zugewiesen werden

CAN-ID-Bereiche sind für Symbole des Typs J1939PG nicht erlaubt.

134

Übergeordnetes Symbol ist keine J1939-Parametergruppe

SPNs können nur für Variablen in Symbolen des Typs J1939PG definiert werden.

135

Falsche Anzahl Bits für Datentyp 'Raw'

Die Länge von Variablen, die den Datentyp 'Raw' haben, muss ein vielfaches von 8 Bits sein.

136

Multiplexerdefinition 'Mux=...' fehlt

Für das Symbol wurde bereits mindestens ein Multiplexer definiert. Jedoch wurde in der Definition eines weiteren Multiplexers die Zeile Mux=... nicht angegeben.

140

Bitstart der Variable kann nicht größer als 63 sein

Alle Variablen eines Symbols, das vom Typ Standard oder Extended ist, müssen sich innerhalb der ersten 64 Datenbits befinden.

141

Variable nicht innerhalb der 64-Bit Grenzen

Alle Variablen eines Symbols, das vom Typ Standard oder Extended ist, müssen sich innerhalb der ersten 64 Datenbits befinden.

145

Dieser Parameter erfordert ein ANSI-Zeichen, Multi-Byte Zeichen sind nicht erlaubt

Der Zeichencode des angegebenen Zeichens darf nur ein Byte benötigen.

146

Ungültige Datenlänge

Die angegebene Datenlänge ist nicht möglich.

147

Ungültige CAN-FD-Datenlänge

Die angegebene CAN-FD-Datenlänge ist nicht möglich. Mögliche Datenlängen für CAN-FD sind 0-8, 12, 16, 20, 24, 32, 48 und 64 Bytes.

148

Ein Symbol mit der selben Datenlänge wurde bereits definiert

Für ein Symbol ohne Multiplexer-Bitgruppe können nur mehrere Definitionen getroffen werden, wenn sich bei jeder Definition zumindest die Datenlänge unterscheidet.

150

Schlüsselwort 'Sig' erwartet

Jede Signaldefinition im Abschnitt {SIGNALS} muss in der Form "Sig=..." erfolgen.

151

Signalname erwartet

An der angegebenen Position wird der Name eines Signals erwartet.

152

Signalname wird bereits verwendet

Der markierte Signalname wird bereits in einer anderen Signaldefinition verwendet.

153

Signale können nicht kürzer als 1 Bit sein

Signale müssen eine Mindestlänge von 1 Bit haben.

154

Signal hat zu viele Bits

Die Länge des Signals passt nicht zum angegebenen Datentyp.

160

Integer-Wert liegt nicht innerhalb des erlaubten Bereichs

Der Integer-Wert liegt nicht innerhalb des erlaubten Bereichs von -2147483648 bis 2147483647 (32-Bit Signed Integer).

161

Hexadezimaler Wert liegt nicht innerhalb des erlaubten Bereichs

Der hexadezimale Wert liegt nicht innerhalb des erlaubten Bereichs von 0 bis FFFFFFFFh (32-Bit).

Siehe auch

Fehlermeldungen von Standardmakros


Fehlermeldungen von Standardmakros

Fehlermeldungen in Standardmakros werden im Ausgabe-Fenster auf der Registerkarte Meldungen angezeigt. Wenn ein Fehler auftritt wird das Ausgabe-Fenster automatisch eingeblendet, wenn es noch nicht sichtbar gewesen ist. Es wird immer eine Fehlernummer und Kurzbeschreibung angegeben.

Folgende Fehler können angezeigt werden:

Nr. | Angezeigter Text | Beschreibung
201 | Fehlender Wert | An der angegebenen Position wird ein Wert erwartet.
202 | Unbekanntes Schlüsselwort | Der markierte Bezeichner stellt keine gültiges Schlüsselwort oder Makro-Anweisung dar.
203 | Keine Symbols verfügbar | Es ist ein Symbolbezeichner verwendet worden, obwohl zum gegenwärtigen Zeitpunkt keine Symboldatei geladen ist.
204 | Argument muss 'True' oder 'False' sein | Das Argument einer IF-Anweisung darf nur 'True' oder 'False' sein.
205 | Kein 'IF' nach 'IF' erlaubt | Direkt nach einer IF-Anweisung darf keine weitere IF-Anweisung stehen.
206 | Unbekannte Sprungmarke | Die angegebene Sprungmarke ist nirgends definiert worden.
207 | Makrodatei-Format nicht unterstützt | PCAN-Explorer 6 unterstützt nur Makrodateien bis zum Format 6.0.
208 | Zu viele Argumente für Makroanweisung | Die maximal zulässige Anzahl von Argumenten für die angegebene Makroanweisung wurde überschritten.
210 | Ungültiger Wert | Die markierte Textstelle ergibt keinen gültigen Wert.
211 | Wert ist zu lang | Der markierte Wert überschreitet die maximale Länge von 30 Zeichen.
212 | Zeichenkette nicht abgeschlossen | Die Zeichenkette an der angegebenen Cursor-Position hat kein abschließendes Anführungszeichen.
220 | Wert ist zu groß für 8 Bit | Der angegebene Wert ist zu groß, um in 8 Bits bzw. ein einzelnes Byte zu passen.
221 | Falsche Anzahl Zeichen in Zeichenkette | Der String-Parameter enthält nicht die geforderte Anzahl von ASCII-Zeichen. Bei der Angabe von Datenbytes einer Send-Anweisung als Zeichenkette muss die Anzahl der Zeichen in der Zeichenkette mit der Anzahl der Datenbytes übereinstimmen.
222 | Wert ist zu groß | Der markierte Hex-Wert enthält zu viele Bits.
223 | Dezimale Werte nicht erlaubt für Parameter die größer als 4 Bytes sind | Es ist versucht worden, einem Parameter einen dezimalen Wert zuzuweisen, obwohl dieser einen Wert größer als 4 Bytes erwartet. Dies ist nicht zulässig. Solche Werte müssen in hexadezimaler Form angegeben werden.
224 | Ungültiger Binärwert | Binärwerte können nur aus Nullen und Einsen bestehen.
225 | Ungültiges Zeichen in Rohdaten | Rohdaten-Zeichenketten dürfen nur aus hexadezimalen Werten bestehen: 0..9, A..F, a..f.
230 | DLC zu groß | Der angegebene DLC-Wert ist zu groß. Der höchste erlaubte DLC-Wert ist 8.
231 | Ungültige Datenlänge | Die angegebene Datenlänge ist zu groß. Die größte mögliche Datenlänge für CAN-Botschaften ist 8.
232 | Ungültige CAN-FD-Datenlänge | Die angegebene Datenlänge kann nicht für eine CAN-FD-Botschaft verwendet werden. Gültige Datenlängen für CAN FD sind: 0..8, 12, 16, 20, 24, 32, 48, 64.
235 | Ungültiger Operator | Der markierte Text konnte nicht als gültiger Operator für die CheckSignal-Anweisung erkannt werden.
240 | Unbekanntes Symbol | Das markierte Symbol ist nirgends definiert worden.
241 | Multiplexer ist kein Mitglied dieses Symbols | Der markierte Multiplexer ist nicht für das davor angegebene Symbol definiert worden.
242 | Unbekanntes Signal | Es existiert kein Signal mit dem angegebenen Namen.
250 | Ungültige Busnummer | Die angegebene Busnummer ist zu groß. Die höchste erlaubte Busnummer ist 16.
251 | Ungültige Verbindung | Es existiert keine Verbindung mit dem angegebenen Namen.
252 | Die Angabe von 'AnyBus' hier nicht erlaubt | Geben Sie eine Busnummer zwischen 1 und 16 für symbolische Botschaften an.
253 | Keine Standard-Busnummer festgelegt | Für Makrodatei-Formate älter als Version 5.0 muss eine Standard-Busnummer durch Einfügen eines Bus=... Parameters festgelegt werden. Siehe auch Bus-Schlüsselwort.

Siehe auch

Fehlermeldungen von Symboldateien


Hardware-Status

Der Status einer PCAN-Hardware wird einerseits im Verbindungen-Fenster oder in Trace-Fenstern angezeigt.

Die folgenden Tabellen beschreiben die Statusanzeigen, die in Abhängigkeit der verwendeten CAN-Hardware und der jeweils installierten PCAN-Treiber auftreten können.

Die folgenden Statusanzeigen können auftreten, wenn für die verwendete CAN-Hardware ein PCAN-Treiber mit einer Versionsnummer von 4 oder neuer installiert ist, und eine Verbindung zu einer anderen CAN-Hardware als zu einem PCAN-USB, PCAN-USB Pro oder PCAN-USB Hub besteht:

Status Beschreibung

OK

Der CAN-Controller befindet sich im Zustand "Error Active", d.h. alle Fehlerzähler befinden sich unterhalb des Schwellwerts 128.

Error Passive

Der CAN-Controller befindet sich im Zustand "Error Passive", d.h. mindestens ein Fehlerzähler erreichte den Schwellwert 128.

Mögliche Ursachen: eine Hardware ist nicht korrekt mit dem CAN-Bus verbunden, oder es wurde eine falsche Bitrate gewählt.

Warnung

Einer der Fehlerzähler erreichte den Schwellwert für "Error Warning Limit", der per Voreinstellung bei 96 liegt.

Bus-Off

Der CAN-Controller ist im Zustand "Bus-Off", weil ein fortwährender Fehler auf dem Bus existiert (255 Fehlerpunkte wurden überschritten).

Ein möglicher Fehler kann ein Kurzschluss der Busleitungen sein.

OVERRUN

Der CAN-Controller empfängt so viele Botschaften, dass nicht mehr alle ausgelösten Hardware-Interrupts verarbeitet werden können.

QOVERRUN

Die Empfangs-Queue ist voll.

Die interne Verarbeitungsgeschwindigkeit der Anwendung reicht nicht aus, um alle Botschaften zu verarbeiten, die vom Gerätetreiber in die Empfangs-Queue der Anwendung geschrieben wurden.

QXMTFULL

Die Sende-Queue ist voll.

Der Gerätetreiber ist nicht in der Lage, alle Botschaften an den CAN-Controller zu übergeben, die in seine Sende-Queue geschrieben wurden. Mögliche Fehlerursachen: niedrige Bitrate, hohe Buslast, oder ein Fehler auf dem Bus. Dieser Fehler tritt mit einer Verzögerung auf, da erst die Sende-Queue komplett gefüllt sein muss, die eine Größe von 32767 Botschaften hat.

Die folgenden Statusanzeigen können auftreten, wenn für die verwendete CAN-Hardware ein PCAN-Treiber mit einer Versionsnummer kleiner als 4 installiert ist, oder wenn eine Verbindung zu einem PCAN-USB, PCAN-USB Pro oder PCAN-USB Hub besteht:

Status Beschreibung

BUSLIGHT

Busfehler: einer der Fehlerzähler des CAN-Controllers erreichte den Schwellwert "Light" (mehr als 0 Fehlerpunkte).

BUSHEAVY

Busfehler: einer der Fehlerzähler des CAN-Controllers erreichte den Schwellwert "Heavy" (mindestens 96 Fehlerpunkte).

Mögliche Ursachen: eine Hardware ist nicht korrekt mit dem CAN-Bus verbunden, oder es wurde eine falsche Bitrate gewählt.

Bus-Off

Der CAN-Controller ist im Zustand "Bus-Off", weil ein fortwährender Fehler auf dem Bus existiert (255 Fehlerpunkte wurden überschritten).

Ein möglicher Fehler kann ein Kurzschluss der Busleitungen sein.

OVERRUN

Der CAN-Controller empfängt so viele Botschaften, dass nicht mehr alle ausgelösten Hardware-Interrupts verarbeitet werden können.

QOVERRUN

Die Empfangs-Queue ist voll.

Die interne Verarbeitungsgeschwindigkeit der Anwendung reicht nicht aus, um alle Botschaften zu verarbeiten, die vom Gerätetreiber in die Empfangs-Queue der Anwendung geschrieben wurden.

QXMTFULL

Die Sende-Queue ist voll.

Der Gerätetreiber ist nicht in der Lage, alle Botschaften an den CAN-Controller zu übergeben, die in seine Sende-Queue geschrieben wurden. Mögliche Fehlerursachen: niedrige Bitrate, hohe Buslast, oder ein Fehler auf dem Bus. Dieser Fehler tritt mit einer Verzögerung auf, da erst die Sende-Queue komplett gefüllt sein muss, die eine Größe von 32767 Botschaften hat.

Siehe auch

Empfangen und Senden von CAN-Botschaften


Argument-Makros

Argument-Makros sind Variablen, die PCAN-Explorer automatisch mit Werten füllt, wenn

  • ein externes Werkzeug aus dem Menü Werkzeuge aufgerufen wird

  • eine Datei von einem Add-in oder einem VBScript-Makro mit Hilfe der Open-Methode geöffnet wird

  • eine Datei von einem Add-in oder einem VBScript-Makro mit Hilfe der Save-Methode gespeichert wird.

Argument-Makros, deren Ergebnis ein Verzeichnis ist, werden in dieser Dokumentation auch als Verzeichnis-Makros bezeichnet.

PCAN-Explorer stellt die folgenden Argument-Makros zur Verfügung:

Name | Argument | Wird zu einem Text mit diesem Inhalt erweitert
Aktuelles Verzeichnis | $(CurDir) | Das aktuelle Arbeitsverzeichnis (definiert als Laufwerk+Pfad).
Dateiverzeichnis | $(FileDir) | Das Verzeichnis des aktiven Dokuments (definiert als Laufwerk+Pfad); leer, wenn kein Dokument aktiv ist.
Dateierweiterung | $(FileExt) | Die Dateinamenerweiterung des aktiven Dokuments; leer, wenn kein Dokument aktiv ist.
Dateiname | $(FileName) | Der Dateiname des aktiven Dokuments (definiert als Dateiname); leer, wenn kein Dokument aktiv ist.
Dateipfad | $(FilePath) | Der komplette Dateiname des aktiven Dokuments (definiert als Laufwerk+Pfad+Dateiname); leer, wenn kein Dokument aktiv ist.
Projektdatei | $(PrjFile) | Der Name der aktiven Projektdatei (definiert als Dateiname); leer, wenn aktuell kein Projekt geöffnet ist.
Projektverzeichnis | $(PrjDir) | Das Verzeichnis der aktiven Projektdatei (definiert als Laufwerk+Pfad); leer, wenn aktuell kein Projekt geöffnet ist.
Projektpfad | $(PrjPath) | Der komplette Dateiname der aktiven Projektdatei (definiert als Laufwerk+Pfad+Dateiname); leer, wenn aktuell kein Projekt geöffnet ist.
Standardverzeichnis für Projekte | $(DefPrjDir) | Das Verzeichnis, das als Root-Verzeichnis für PCAN-Explorer-Projekte definiert ist (siehe Bibliothek, Optionen-Dialogfester).
Bibliotheks-Verzeichnis | $(LibDir) | Das Root-Verzeichnis der PCAN-Explorer-Bibliothek (siehe Bibliothek, Optionen-Dialogfenster).
Symboldateien-Bibliotheksverzeichnis | $(LibSymDir) | Das Bibliotheksverzeichnis für Symboldateien (siehe Bibliothek, Optionen-Dialogfenster).
Makros-Bibliotheksverzeichnis | $(LibMacroDir) | Das Bibliotheksverzeichnis für Standardmakros (siehe Bibliothek, Optionen-Dialogfenster).
VBS-Macros-Bibliotheksverzeichnis | $(LibVBSMacroDir) | Das Bibliotheksverzeichnis für VBS-Makrodateien (siehe Bibliothek, Optionen-Dialogfenster).
Sendelisten-Bibliotheksverzeichnis | $(LibXmtDir) | Das Bibliotheksverzeichnis für Sendelisten (siehe Bibliothek, Optionen-Dialogfenster).
Trace-Dateien-Bibliotheksverzeichnis | $(LibTraceDir) | Das Bibliotheksverzeichnis für Trace-Dateien (siehe Bibliothek, Optionen-Dialogfenster).
Desktop-Verzeichnis | $(Desktop) | Das Desktop-Verzeichnis des aktuellen Benutzers.
Eigene Dateien-Verzeichnis | $(MyDocsDir) | Das "Eigene Dateien"-Verzeichnis des aktuellen Benutzers.
Gemeinsame Dokumente-Verzeichnis | $(CommonDocsDir) | Das Verzeichnis, in dem alle Benutzer Dokumente ablegen können, üblicherweise: \Dokumente und Einstellungen\All Users\Dokumente\ für Windows XP, \Users\Public\Documents\ für Windows Vista und neuer.
Anwendungsverzeichnis | $(AppDir) | Das Verzeichnis, in dem PCAN-Explorer installiert ist.
Hinweis

Die Erkennung von Makros ist unabhängig von Groß-/Kleinschreibung. Die Verzeichnis-Makros enden nicht in einem Backslash (\).

Siehe auch

Argumente für externe Werkzeuge


OnMessageReceived Event

Applies to: J1939Node object

Occurs after a J1939 message has been received.

Attention

Do not use this event in VBS macros. It has turned out that it does not work reliably in this context and no solution can be provided.
Syntax

object_OnMessageReceived ( node, count )

Parameters

object

An expression that evaluates to a J1939Node object.

node

The J1939Node object that triggers this event.

count

A Long that specifies the number of messages that are currently in the node's receive queue.


Data64 Property

Applies to: ReceiveEvent object, ReceiveMessage object, TraceMessage object, TransmitEvent object, TransmitMessage object

Sets or returns the 8 data bytes of a CAN message in a single call.

Syntax

object.Data64 [=value]

Parameters

object

An expression that evaluates to one of the objects in the Applies To list above.

value

An Int64 value that sets the new value of the data bytes.

Property value

An Int64 value that specifies the data bytes of a CAN message (Intel format, LSB is in data byte 0, MSB is in data byte 7).

Remarks

Only Add-ins and Callback DLLs can set or query the Data64 property, VBScript macros are not capable of this.

Example

The following example can be used as a handler for the Callback Library On Before Transmit event to increase a 64-bit counter value before the message with CAN ID 123h is transmitted:

C++ Callback DLL

HRESULT __stdcall ID123_Data64Example(PCANExplorer6::IPETransmitEvent *pEvent)

{

static long long counter;

long id;

if (SUCCEEDED(pEvent->get_ID(&id)) && (id == 0x123))

pEvent->put_Data64(++counter);

return S_OK;

}


Enum Property

Applies to: Signal object, Variable object

Returns the Enum object that is associated with a Signal or Variable.

Syntax

object.Enum

Parameters

object

An expression that evaluates to a Signal object or a Variable object.

Property value

An Enum object.

Example

The following example displays the name of the associated Enum object for each Signal:

VBS Macro

Sub EnumExample()

Dim sig, strMsg

For Each sig In Signals

If Not sig.Enum Is Nothing Then _

strMsg = strMsg & sig.Name & " has Enum " & sig.Enum.Name & vbCrLf

Next

MsgBox strMsg

End Sub

See also

EnumName Property


MaxCycleTime Property

Applies to: ReceiveEvent object, ReceiveMessage object

Returns the measured maximum time interval between two successive reception events.

Syntax

object.MaxCycleTime

Parameters

object

An expression that evaluates to a ReceiveEvent or ReceiveMessage object.

Property value

A Long value that specifies the measured maximum time interval between two successive reception events in milliseconds.

Example

The following example prints the maximum cycle times of each message in the Receive List to the Output window:

VBS Macro

Sub MaxCycleTimeExample()

Dim msg

For Each msg In ReceiveMessages

PrintToOutputWindow "ID=" & Hex(msg.ID) & ", MaxCycleTime=" & _

msg.MaxCycleTime & " ms"

Next

End Sub

See also

MinCycleTime Property


MinCycleTime Property

Applies to: ReceiveEvent object, ReceiveMessage object

Returns the measured minimum time interval between two successive reception events.

Syntax

object.MinCycleTime

Parameters

object

An expression that evaluates to a ReceiveEvent or ReceiveMessage object.

Property value

A Long value that specifies the measured minimum time interval between two successive reception events in milliseconds.

Example

The following example prints the minimum cycle times of each message in the Receive List to the Output window:

VBS Macro

Sub MaxCycleTimeExample()

Dim msg

For Each msg In ReceiveMessages

PrintToOutputWindow "ID=" & Hex(msg.ID) & ", MaxCycleTime=" & _

msg.MinCycleTime & " ms"

Next

End Sub

See also

MaxCycleTime Property


NetBaudRate Property

Applies to: PCANClientConnection object

Returns the baud rate code that was defined for a connected PCAN net that uses an SJA1000-compatible (non-CAN-FD) baud rate.

To access the bit rate parameters of a PCAN net that represents a CAN FD connection, use the NetBitRate property.

Syntax

object.NetBaudRate

Parameters

object

An expression that evaluates to a PCANClientConnection object.

Property value

A Long containing a 16-bit value, which is a combination of the two 8-bit values used to initialize the bus timing registers BTR0 and BTR1 of the SJA1000 CAN controller, when the first client connects to that net. To get a human-readable interpretation of the baud rate value, access the NetBitRateText property.

You can only retrieve the net's bit rate if the PCANClientConnection object is connected to a PCAN net.

Example

The following example retrieves the bit rate of a connected net:

VBS Macro

Sub NetBaudRateExample()

' The first connection in the project must

' be a CAN connection

If Connections(1).Protocol = peProtocolCAN Then

Dim ClientConn, baud

Set ClientConn = Connections(1).CommunicationObject

baud = ClientConn.NetBaudRate

' Access the baud rate here

' ...

End If

End Sub

See also

NetBitRate Property

HardwareBaudRate Property

HardwareBitRate Property


NotificationOnSessionEvents Property

Applies to: J1939Node object

Sets or returns whether the J1939Node object triggers session events.

Syntax

object.NotificationOnSessionEvents [=value]

Parameters

object

An expression that evaluates to a J1939Node object.

value

A Boolean that specifies the new value of the property.

Property value

A Boolean value that specifies whether the J1939Node object triggers session events. If True, events are triggered. If False (the default), events are not triggered.

Remarks

If activated, the J1939Node object triggers OnReadSessionBegin, OnWriteSessionEnd, and OnSessionAbort events.


SPN Property

Applies to: Signal object, Variable object

Returns a J1939 Suspect Parameter Number.

Syntax

object.SPN

Parameters

object

An expression that evaluates to a Signal object or a Variable object.

Property value

A Long value that specifies a Suspect Parameter Number.

Remarks

Suspect Parameter Numbers are assigned to signals or variables in Symbols files by using the optional parameter /spn.


Symbole in der Empfangsliste

Sobald eine Symboldatei einer Verbindung zugewiesen wird, kann die Spalte Symbol in der Empfangsliste die Namen der Symbole anzeigen, die mit den Botschaften in der Liste kompatibel sind.

Die folgenden Spalten werden standardmäßig angezeigt:

Bus

Die Bus-Nummer der Verbindung, von der eine Botschaft empfangen wurde (1-16).

CAN-ID

Die CAN-ID der Botschaft in hexadezimaler Darstellung. 11-Bit Botschaften werden mit einer 3-stelligen CAN-ID angezeigt (0-7FFh), 29-Bit Botschaften gemäß CAN-Protokoll 2.0B werden mit einer 8-stelligen CAN-ID angezeigt (0-1FFFFFFFh).

Länge

Die Anzahl der Datenbytes der Botschaft.

Symbol

Der Name des Symbols, das zu der Botschaft kompatibel ist.

Wurde auch ein Multiplexer für das Symbol definiert, und passt der Inhalt der Datenbytes der Botschaft zu einem der Multiplexer, wird der Symbolname in der Form Symbol.Multiplexer angezeigt.

Daten

Die Namen der Variablen und deren momentane Werte.

Ist mehr als eine Variable für dieses Symbol bzw. diesen Multiplexer definiert, wird das Plus-Zeichen [image] angezeigt. Sie können die Zeile kann aufgeklappen, indem Sie entweder mit der Maus auf das Plus-Zeichen klicken, oder die Zeile selektieren und die Taste [Pfeil-Rechts] drücken. Das Zuklappen geschieht entsprechend durch Anklicken des Minus-Zeichens oder Drücken der Taste [Pfeil-Links]. Sie können auch alle Symbole auf einmal auf- und zugeklappen, indem Sie die Tastenkombination [Umsch+Pfeil-Rechts] oder [Umsch+Pfeil-Links] drücken.

Timeouts

Die Anzahl der für das Symbol/den Multiplexer aufgetretenen Timeouts seit dem letzten Ausführen des Befehls Zurücksetzen.

Zykluszeit

Das Zeitintervall zwischen den letzten beiden Empfangszeitpunkten der Botschaft, in Millisekunden.

Anzahl

Die Anzahl der empfangenen Botschaften seit dem letzten Ausführen des Befehls Zurücksetzen.

Siehe auch

Empfangsliste

Symbole in Sendelisten


Symbole in Sendelisten

Ebenso wie in der Empfangsliste kann die Spalte Symbol in Sendelisten die Namen von den Symbolen anzeigen, die kompatibel mit den Botschaften in der Liste sind, falls eine Symboldatei einer Verbindung zugewiesen ist.

Die folgenden Spalten werden standardmäßig angezeigt:

Bus

Die Bus-Nummer der Verbindung, auf dem eine Botschaft gesendet wird (1-16).

CAN-ID

Die CAN-ID der Botschaft in hexadezimaler Darstellung. 11-Bit Botschaften werden mit einer 3-stelligen CAN-ID angezeigt (0-7FFh), 29-Bit Botschaften gemäß CAN-Protokoll 2.0B werden mit einer 8-stelligen CAN-ID angezeigt (0-1FFFFFFFh).

Länge

Die Anzahl der Datenbytes der Botschaft.

Symbol

Der Name des Symbols, das zu der Botschaft kompatibel ist.

Wurde auch ein Multiplexer für das Symbol definiert, und passt der Inhalt der Datenbytes der Botschaft zu einem der Multiplexer, wird der Symbolname in der Form Symbol.Multiplexer angezeigt.

Daten

Die Namen der Variablen und deren momentane Werte.

Ist mehr als eine Variable für dieses Symbol bzw. diesen Multiplexer definiert, wird das Plus-Zeichen [image] angezeigt. Sie können die Zeile kann aufgeklappen, indem Sie entweder mit der Maus auf das Plus-Zeichen klicken, oder die Zeile selektieren und die Taste [Pfeil-Rechts] drücken. Das Zuklappen geschieht entsprechend durch Anklicken des Minus-Zeichens oder Drücken der Taste [Pfeil-Links]. Sie können auch alle Symbole auf einmal auf- und zugeklappen, indem Sie die Tastenkombination [Umsch+Pfeil-Rechts] oder [Umsch+Pfeil-Links] drücken.

Zykluszeit

Das Zeitintervall, in dem eine Botschaft zyklisch gesendet wird. Wurde bei der Erstellung der Nachricht 0 ms als Sendeperiode angegeben, wird der Text Warte angezeigt, d.h. die Botschaft wird nur manuell gesendet.

Anzahl

Die Anzahl der gesendeten Nachrichten seit dem letzten Ausführen des Befehls Reset.

Trigger

Der Grund für die letzte Sendung der Botschaft. Die folgenden Gründe für das Senden einer Botschaft können angezeigt werden:

  • Manuell Die Botschaft wurde manuell vom Benutzer gesendet.

  • Zeit Die Botschaft wurde aufgrund der festgelegten Zykluszeit gesendet.

  • RTR Die Botschaft wurde als Antwort auf einen empfangenen Remote Request Frame gesendet.

  • Makro Die Botschaft wurde von einem Standardmakro gesendet.

  • Automation Die Botschaft wurde von einem VBS-Makro oder von einem externen Programm gesendet, das PCAN-Explorer als Automation Server betreibt.

  • RQST: Die Botschaft wurde als Antwort auf einen J1939-Request (PGN 59904) gesendet.

Erzeuger

Diese Spalte identifiziert den Erzeuger einer Botschaft.

Siehe auch

Standard-Sendeliste

Arbeiten mit Sendelisten

Symbole in der Empfangsliste


PCAN-Explorer registrieren

Leitseite: Referenz

Falls Sie eine Testversion von PCAN-Explorer installiert haben, wird das Programm aufhören zu Arbeiten, wenn die Testperiode abgelaufen ist. Wenn Sie danach versuchen, das Programm zu starten, wird nur ein Dialogfenster mit einer entsprechenden Meldung angezeigt.

Um PCAN-Explorer wieder funktionsfähig zu machen, ziehen Sie in Betracht, die Software käuflich zu erwerben. Um die Software zu kaufen, kontaktieren Sie entweder PEAK-System Technik GmbH oder Ihren lokalen Distributor.

Wenn Sie Ihre käuflich erworbene Kopie der Software erhalten haben, ist die empfohlene Vorgehensweise, zuerst die Testversion zu deinstallieren, und anschließend die Software zu installieren, die Sie auf CD oder über einen Download erhalten haben.

In Ausnahmefällen ist es auch möglich, die Testperiode zu verlängern, was über die Schaltfläche Lizenz aktualisieren durchgeführt wird.

Siehe auch

Lizenz-Aktualisierung-Dialogfenster


Anpassen-Dialogfenster

Das Anpassen-Dialogfenster ermöglicht die Anpassung der Symbolleisten von PCAN-Explorer. Das Anpassen-Dialogfenster kann angezeigt werden, indem im Menü Werkzeuge der Befehl Anpassen ausgewählt wird.

Die folgenden Themen bieten detaillierte Informationen darüber, wie verschiedene Aufgaben im Anpassen-Dialogfenster ausgeführt werden können.

Für | Siehe
Symbolleisten ein-/ausblenden | Symbolleisten, Anpassen-Dialogfenster
Eine neue Symbolleiste erzeugen | Symbolleisten, Anpassen-Dialogfenster
Die Befehle ändern, die auf einer Symbolleiste angezeigt werden | Befehle, Anpassen-Dialogfenster
Eine Symbolleiste auf ihre Standardkonfiguration zurücksetzen | Symbolleisten, Anpassen-Dialogfenster
Große Symbole auf Symbolleisten anzeigen | Optionen, Anpassen-Dialogfenster
Menü-Animationen ändern | Optionen, Anpassen-Dialogfenster

Siehe auch

Benutzeroberfläche


Befehle, Anpassen-Dialogfenster

Die Registerseite Befehle zeigt die Menübefehle an, die auf eine Symbolleiste oder in ein Menü gezogen und abgelegt werden können.

Kategorien

Eine Liste mit allen Kategorien der Befehle, z.B. Datei und Bearbeiten.

Befehle

Enthält alle verfügbaren Befehle der Kategorie, die in der Liste Kategorien ausgewählt ist. Das Symbol links von dem Befehlsnamen ist die Schaltfläche, die in der Symbolleiste oder in einem Menüeintrag erscheint.

Beschreibung

Zeigt eine kurze Beschreibung für den ausgewählten Befehl an.

Siehe auch

Anpassen-Dialogfenster


Optionen, Anpassen-Dialogfenster

Die Registerkarte Optionen ermöglicht die Anpassung verschiedener Optionen von Menüs und Symbolleisten.

Große Symbole

Vergößert die Symbole auf Symbolleisten, so dass sie leichter zu erkennen sind.

Zeige ToolTips auf Toolbars

Zeigt Tooltips für Symbolleisten-Schalteflächen an, wenn man die Maus über eine Schaltfläche bewegt.

Zeige Tastenkombinationen in ToolTips

Zeigt die Tastenkombination im Tooltip-Text an, über welche die Funktion einer Symbolleisten-Schaltfläche ebenfalls ausgeführt werden kann.

Menu-Animationen

Wählt einen Animationseffekt, der zum Anzeigen von Menüs verwendet werden soll.

Siehe auch

Anpassen-Dialogfenster


Symbolleisten, Anpassen-Dialogfenster

Die Registerseite Symbolleisten führt alle Symbolleisten auf, die angezeigt, ausgeblendet oder zurückgesetzt werden können. Diese Registerkarte kann angezeigt werden, indem im Menü Werkzeuge der Befehl Anpassen und dann die Registerkarte Symbolleisten ausgewählt wird.

Symbolleisten

Zeigt alle verfügbaren standardmäßig vorhandenen Symbolleisten, sowie alle Symbolleisten von Add-ins. Wenn eine Symbolleiste aktuell angezeigt wird, erscheint ein Haken neben dem Namen.

Neu

Erstellt eine neue benutzerdefinierte Symbolleiste.

Umbenennen

Benennt die ausgewählte Symbolleiste um.

Zurücksetzen

Setzt die ausgewählte Symbolleiste auf ihre Standardkonfiguration zurück.

Siehe auch

Anpassen-Dialogfenster


Lizenz-Aktualisierung-Dialogfenster

Falls Sie eine käuflich erworbene Version von PCAN-Explorer verwenden, können Sie dieses Dialogfenster zum Verändern Ihrer PCAN-Explorer-Lizenz verwenden, falls keine Internetverbindung verfügbar ist, oder wenn Sie eine portable Lizenz mit Kopierschutz-Dongle verwenden.

Falls Sie eine Testversion verwenden, können Sie dieses Dialogfenster zum Verändern Ihrer PCAN-Explorer-Lizenz verwenden, ohne dass Sie eine neue Lizenzdatei installieren müssen.

Verändern der PCAN-Explorer-Lizenz erfordert die Kontaktaufnahme mit dem PEAK-Kundensupport.

Benutzer-Code 1/2

Wenn die Aktualisierung der Lizenz von unserem Kundensupport akzeptiert wurde, müssen Sie diese Codes an den Kundensupport übermitteln, zusammen mit Ihrer Lizenz-ID. Das Kundensupport-Team liefert dann zwei Registrierungs-Codes zurück, die Sie dann in die nachfolgenden Felder Registrierungs-Code eingeben müssen.

Nachdem Sie die Benutzer-Codes übermittelt haben, können Sie das Dialogfenster schließen oder sogar die Anwendung beenden, während Sie auf die Anwort vom Kundensupport warten. Das nächste Mal, wenn Sie das Dialogfenster öffnen, werden die selben Codes angezeigt. Die Benutzer-Codes ändern sich nicht, so lange bis der Aktualisierungsvorgang abgeschlossen ist.

Registrierungs-Code 1/2

Sie erhalten diese Codes vom PEAK-Kundensupport, wenn die Änderung der Lizenz akzeptiert und verarbeitet wurde. Geben Sie die Codes in die entsprechenden Felder ein und klicken Sie auf OK.

Achtung

Wenn Sie mehr als 3 Mal falsche Registrierungs-Codes eingeben, werden die angezeigten Benutzer-Codes ungültig. Wenn Sie das nächste Mal das Dialogfenster öffnen, werden neue Benutzer-Codes angezeigt, die Sie dann erneut an den Kundensupport übermitteln müssen, um den Vorgang zu wiederholen.


Trace-Daten exportieren-Dialogfenster

Sie können das Trace-Daten exportieren-Dialogfenster verwenden, um Daten von aufgezeichneten CAN-Botschaften in Textdateien oder CSV-Dateien zu exportieren. Um das Trace-Daten exportieren-Dialogfenster anzuzeigen, aktivieren Sie ein Trace-Fenster und wählen dann im Menü Datei den Befehl Exportieren.

Pfad

Legt den Pfad und den Namen der Datei fest, in welche die Daten exportiert werden. Die Dropdownliste enthält Pfadnamen der zuletzt verwendeten Dateien. Verwenden Sie die Schaltfläche ... neben der Dropdownliste um ein Dialogfenster zur Auswahl eines Pfades anzuzeigen.

Zeitstempel

Wählt das Format der Zeitstempel aus. Mögliche Optionen sind:

Option Beschreibung

Relativ in Millisekunden

Speichert die Zeitstempel der aufgezeichneten CAN-Botschaften als Offsets relativ zum Anfang der Aufzeichnung, in Millisekunden.

Relativ in Sekunden

Speichert die Zeitstempel der aufgezeichneten CAN-Botschaften als Offsets relativ zum Anfang der Aufzeichnung, in Sekunden.

Absolut - formatiert

Speichert die Zeitstempel der aufgezeichneten CAN-Botschaften als absolute Uhrzeiten. Die Zeitwerte werden gemäß der Einstellung Format der absoluten Zeitstempel im Optionen-Dialogfenster formatiert.

Absolut - Rohwerte

Speichert die Zeitstempel als Gleitkommawerte. Der ganzzahlige Anteil eines solchen Wertes stellt die Anzahl der seit dem 30. Dezember 1899 vergangenen Tage dar. Die Nachkommastellen sind der Bruchteil des vergangenen 24-Stunden-Tages.

Microsoft Excel kann nativ diese Werte interpretieren, indem eine Zelle mit einem solchen Wert als Datum oder Zeit oder als Kombination von beiden formatiert wird.

Registerseite 'Text'

Wenn Sie diese Registerseite auswählen, werden die Trace-Daten als Textdatei exportiert. Verwenden Sie die Optionen auf dieser Seite an, um die Textausgabe an Ihre eigenen Anforderungen anzupassen.

Speichern als

Option | Beschreibung
Hex | Speichert alle aufgezeichneten Botschaften in die Datei. CAN-IDs und Datenbytes werden als hexadezimale Werte gespeichert.
Symbolisch | Speichert nur die Botschaften, für die durch eine aktivierte Symboldatei eine symbolische Darstellung verfügbar ist.
Hex + symbolisch | Speichert alle Botschaften in die Datei. Falls eine symbolische Darstellung durch eine aktivierte Symboldatei verfügbar ist, wird die symbolische Ausgabe verwendet. Andernfalls werden Botschaften hexadezimal ausgegeben.

Optionen

Option | Beschreibung
Kopfzeilen ausgeben | Fügt einen Dateikopf mit Angaben über Erstellungsdatum, aktive Busse, Speicherort und Spaltenbeschreibungen am Anfang der Logdatei ein.
Alle Variablen in gleicher Zeile | Ordnet alle Variablen eines Symbols nebeneinander ohne Zeilenumbrüche in einer Zeile an.
Zeilenumbruch nach Multiplexer | Gibt einen Zeilenumbruch nach dem Multiplexer-Namen aus, so dass die Variablen mit ihren Werten in einer neuen Zeile erscheinen. Die erste Variable ist hierbei linksbündig zum Multiplexer-Namen ausgerichtet.
Alle Variablen in gleicher Spalte | Ordnet alle Variablen eines Symbols untereinander in einer Spalte an.
Nur markierte Variablen | Speichert nur die Variablen in die Logdatei, deren Trace-Schalter aktiviert ist.

Spalten

Diese Optionen bestimmen die Spalten, die in die Datei ausgegeben werden. Je nachdem, ob eine Symboldatei aktiv ist oder nicht, sind verschiedene Spalten verfügbar:

Spalte | Beschreibung
Fortlaufende Nummer | Enthält eine fortlaufende Nummerierung der Botschaften.
Zeit / Zeitoffset | Die Zeitstempel der Botschaften (siehe Einstellung Zeitstempel oben).
Art des Ereignisses | Die Typen der Botschaften, beispielsweise Rx, Tx, Warning, Error.
CAN-ID | Die CAN-IDs der Botschaften.
Data Length Code | Die Data Length Codes der Botschaften.
Daten | Die Datenbytes der Botschaften, als hexadezimale Werte.
Symbol / ID | Falls die Daten symbolisch exportiert werden, enthält diese Spalte entweder die CAN-IDs der Botschaften oder die Namen der Symbole.
Multiplexer / DLC | Falls die Daten symbolisch exportiert werden, enthält diese Spalte entweder die Data Length Codes der Botschaften oder die Namen von Multiplexern, die zu den Botschaften passen.
Variablen / Daten | Wenn die Daten symbolisch exportiert werden, enthält diese Spalte entweder die Datenbytes der Botschaften oder die für sie definierten Variablen und deren aktuellen Werte.

Registerseite 'CSV'

Wenn Sie diese Registerseite auswählen, werden die Trace-Daten in eine CSV-Datei exportiert. Wenn Sie OK drücken, während diese Registerseite aktiv ist, sucht PCAN-Explorer zuerst in der aktiven Trace-Datei nach Signalinformationen, und öffnet dann ein Dialogfenster, in dem Sie die Signale auswählen können, die Sie exportieren möchten.

Dezimaltrennzeichen

Legt das Dezimaltrennzeichen fest, das zur Ausgabe der Werte in die Datei verwendet wird. Wenn der Wert Automatisch ausgewählt ist, wird das Dezimaltrennzeichen von der Regions- und Zahlenformateinstellung in der Windows-Systemsteuerung bestimmt.

Spaltentrennzeichen

Legt fest, welches Zeichen verwendet wird, um die einzelnen Spalten in der Datei voneinander zu trennen.

Wenn der Wert Automatisch ausgewählt ist, hängt das Spaltentrennzeichen vom Dezimaltrennzeichen ab:

  • Ist das Dezimaltrennzeichen ein Komma, wird das Spaltentrennzeichen ein Semikolon.

  • Ist das Dezimaltrennzeichen ein Punkt, wird das Spaltentrennzeichen ein Komma.

Zeit-Spalte

Bestimmt, wie die Zeitstempel der Signale ausgegeben werden:

  • Separate Spalten für jedes Signal: Für jedes Signal werden jeweils zwei Spalten in die Datei geschrieben, welche die Wertepaare aus Zeitstempel und Signalwert enthalten.

  • Gemeinsame Spalte für alle Signale: Als erste Spalte wird eine gemeinsame Zeitspalte in die Datei geschrieben. Die weiteren Spalten enthalten nur noch die Werte der Signale zu dem jeweiligen Zeitpunkt.

Siehe auch

Exportieren von aufgezeichneten Daten