J1939 DTC-Monitor Fenster

Der J1939 DTC-Monitor kann dazu verwendet werden, J1939 Diagnostic Trouble Codes (DTCs) und andere Diagnose-Nachrichten anzuzeigen und anzufordern. Er ist Teil des J1939 Add-ins von PCAN-Explorer 6 auf Windows 10.

Um den J1939 DTC-Monitor zu öffnen, klicken Sie entweder in der PCAN-Explorer-Symbolleiste auf das Symbol [image], oder wählen Sie im Menü Werkzeuge den Befehl J1939 DTC-Monitor.

Symbolleiste

Die Symbolleiste am oberen Rand des Anwendungsfensters enthält folgende Elemente (von Links nach Rechts):

MIL

Malfunction Indicator Lamp.

RSL

Red Stop Lamp.

AWL

Amber Warning Lamp.

Protect

Protect Lamp.

Hinweis

Die Lampen MIL, RSL , AWL und Protect zeigen den jeweils höchsten empfangenen Status aller eingegangenen DM01-Nachrichten. Die Priorität liegt hierbei bei Fast Flash > Slow Flash > Lamp On > Lamp Off.

DM01 anfordern

Sendet Requests (RQST) für DM01. Dies kann nützlich sein, falls ein Steuergerät die DM01-Nachricht nicht selbstständig zyklisch sendet. Anforderung von DM01 können entweder an eine bestimmte Quelle oder an die Globale Adresse auf allen aktiven Verbindungen gesendet werden.

Damit eine zielgerichtete Anforderung von DM01 gesendet werden kann, muss in der Knotenliste (siehe unten) ein Eintrag ausgewählt sein. Globale Anforderungen können immer gesendet werden, wenn mindestens eine aktive Verbindung vorhanden ist.

Achtung: Damit ein Steuergerät eine Multipacket-Antwort mittels RTS/CTS übertragen kann, muss PCAN-Explorer eine Adresse auf der jeweiligen Verbindung angefordert haben.

Hilfe

Öffnet diese Hilfedatei.

Über

Zeigt Informationen zur Programmversion, den Hersteller und Copyright-Informationen an.

Knotenliste

Unterhalb der Symbolleiste befindet sich die Knotenliste. Hier werden alle Knoten angezeigt, von denen eine DM Nachricht empfangen wurde. Wenn von einem Knoten 2 Sekunden keine weitere DM empfangen wird, wird dieser Knoten eingegraut.

Spalte | Beschreibung
Bus | Der CAN-Bus auf dem die Nachricht des Knotens empfangen wurde.
Quelle | Die J1939-Adresse des Knotens.
DTC-Anzahl | Die Summe aller empfangenen DTCs des Knotens.
MIL | Malfunction Indicator Lamp.
RSL | Red Stop Lamp.
AWL | Amber Warning Lamp.
Protect | Protect Lamp.

Registerseiten

Unterhalb der Knotenliste befinden sich folgende Registerseiten:

Registerseite |  | Beschreibung
 | Aktive DTCs | Zeigt alle momentan aktiven DTCs an.
 | DTC-Historie | Enthält eine Liste aller vormals aktiven DTCs.
 | DTCs | Zeigt alle empfangenen DTCs, welche nicht von einer DM01-Nachricht stammen.
 | Verbindungen | Zeigt alle aktiven PCAN-Explorer-Verbindungen, die das J1939-Protokoll verwenden.

Feedback senden | Copyright © 2020 PEAK-System Technik GmbH. Alle Rechte vorbehalten.


Aktive DTCs

Auf dieser Registerseite werden alle empfangenen aktiven Diagnostic Trouble Codes (DTC) angezeigt.

Spalten

Name | Beschreibung
Bus | Der Bus auf dem der DTC empfangen wurde.
Quelle | Die Quelladresse, von der aus die Nachricht gesendet wurde, die den DTC enthält.
SPN | Suspect Parameter Number.
FMI | Failure Mode Indicator.
OC | Occurrence Count.

Befehle

Befehl |  | Beschreibung
 | Clear/Reset | Sendet Requests (RQST) für DM11 (Clear/Reset Previously Active DTCs) an alle Quellen, die in der Liste vorhanden sind.
 | Clear/Reset (global) | Sendet globale Requests (RQST) für DM11 (Clear/Reset Previously Active DTCs) auf allen Bussen, die in der Liste vorhanden sind.
 | Individual Clear/Reset | Sendet eine DM22-Nachricht (Individual Clear/Reset DTC) an die Quelle des ausgewählten DTCs, welche das Steuergerät auffordert, diesen DTC zu löschen.

Siehe auch

DTC-Historie

Feedback senden | Copyright © 2020 PEAK-System Technik GmbH. Alle Rechte vorbehalten.


DTC-Historie

Auf der Registerseite DTC-Historie werden alle empfangenen DM01 DTCs angezeigt. Wenn ein bereits empfangener DM01 DTC eines Steuergeräts nicht mehr in der nächsten DM01-Nachricht des Steuergeräts empfangen wird, wird der Historie eine ausgegraute Kopie des DTCs hinzugefügt. Diese Kopie spiegelt den inaktiven Status des DTCs wider.

Spalten

Name | Beschreibung
Zeit | Der Zeitpunkt an dem der DTC empfangen wurde. Das Zeitformat ist identisch zum aktuell genutzten Zeitformat des PCAN-Explorer 6.
Bus | Der Bus auf dem der DTC empfangen wurde.
Quelle | Die Quelladresse von der aus der DTC gesendet wurde.
SPN | Suspect Parameter Number.
FMI | Failure Mode Indicator.
OC | Occurrence Count.

Befehle

Befehl |  | Beschreibung
 | Historie Löschen | Löscht alle Einträge aus der Historie.

Siehe auch

Aktive DTCs

Feedback senden | Copyright © 2020 PEAK-System Technik GmbH. Alle Rechte vorbehalten.


DTCs

Diese Registerseite zeigt alle empfangenen DTCs, welche nicht von einer DM01-Nachricht stammen.

Spalten

Name | Beschreibung
Bus | Der Bus auf dem die Nachricht empfangen wurde, die den DTC enthielt.
Quelle | Die Quelladresse von der aus die Nachricht gesendet wurde.
SPN | Suspect Parameter Number.
FMI | Failure Mode Indicator.
OC | Occurrence Count.
DM02 | Zeigt, ob der DTC von einer DM02-Nachricht stammt.
DM06 | Zeigt, ob der DTC von einer DM06-Nachricht stammt.
DM12 | Zeigt, ob der DTC von einer DM12-Nachricht stammt.
DM23 | Zeigt, ob der DTC von einer DM23-Nachricht stammt.
DM27 | Zeigt, ob der DTC von einer DM27-Nachricht stammt.
DM28 | Zeigt, ob der DTC von einer DM28-Nachricht stammt.
DM35 | Zeigt, ob der DTC von einer DM35-Nachricht stammt.

Befehle

Befehl |  | Beschreibung
 | Clear/Reset | Sendet Requests (RQST) für DM03 (Clear/Reset Previously Active DTCs) an alle Quellen, die in der Liste enthalten sind.
 | DMs anfordern | Sendet Requests (RQST) für alle DMs, deren Spalten eingeblendet sind, an alle Quellen, die in der Liste vorhanden sind. Achtung: Damit ein Steuergerät eine Multipacket-Antwort mittels RTS/CTS übertragen kann, muss PCAN-Explorer eine Adresse auf der jeweiliger Verbindung angefordert haben.
 | DMs anfordern (global) | Sendet globale Requests (RQST) für alle DMs, deren Spalten eingeblendet sind, auf allen Bussen, die in der Liste vorhanden sind.
 | Individual Clear/Reset | Sendet eine DM22-Nachricht (Individual Clear/Reset DTC) an die Quelle des ausgewählten DTCs, welche das Steuergerät auffordert, diesen DTC zu löschen.
 | Spalten | Blendet einzelne Spalten ein oder aus.

Feedback senden | Copyright © 2020 PEAK-System Technik GmbH. Alle Rechte vorbehalten.


Verbindungen

Auf dieser Registerseite werden alle Verbindungen aufgelistet, mit denen der J1939 DTC-Monitor verbunden ist. Die Verbindungen richten sich nach dem aktiven PCAN-Explorer 6 Projekt. Hierbei verbindet sich der J1939 DTC-Monitor automatisch mit allen aktiven J1939-Verbindungen des Projekts.

Spalten

Name | Beschreibung
Bus | Der Bus auf dem sich die Verbindung befindet.
Name | Der Name der Verbindung.
Netzverbindung | Das PCAN-Netz der Verbindung.
Bitrate | Die Bitrate der Verbindung.
Angeforderte Adresse | Zeigt die angeforderte Adresse für diese Verbindung. Falls keine Adresse angefordert wurde, wird "Null" angezeigt.

Feedback senden | Copyright © 2020 PEAK-System Technik GmbH. Alle Rechte vorbehalten.