NI-VISA .NET Class Library

[image]
NI-VISA .NET Class Library Help
NI-VISA .NET Class Library

February 2016, 375853A-01

The NationalInstruments.Visa .NET class library contains classes that provide a .NET interface to the NI-VISA driver. This library is compliant with the VISA Implementation Specification for .NET (VPP-4.3.6) authored by the IVI Foundation. This library supersedes the National Instruments VisaNS library, which was implemented before the IVI Foundation standardized the .NET API to VISA.

This help file contains information about using NI-VISA to program your National Instruments device. NI-VISA is the software you use for configuring, programming, and troubleshooting instrumentation systems comprising GPIB, VXI, PXI, serial (RS232/RS485), Ethernet/LXI, and/or USB interfaces.

For more information about this help file, refer to the following topics:

Key NI-VISA .NET Library Features

NationalInstruments.Visa

© 2016 National Instruments. All rights reserved.