Glossary, Legal, and Resources

[image]
NI Measurement Studio .NET Class Library
Glossary, Legal, and Resources

In This Section

Glossary
Lists key terms used with Measurement Studio.
Important Information
Describes legal information regarding the use of National Instruments products.
NI Services
Describes where to go for more National Instruments product support and professional services.

© 2003-2015 National Instruments. All rights reserved.

Send Feedback on this topic to National Instruments.


Measurement Studio Glossary

[image]
NI Measurement Studio .NET Class Library
Measurement Studio Glossary

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

A

ActiveX
Set of Microsoft technologies for reusable software components. Formerly called OLE.
ActiveX control
Reusable software component that adds functionality to any ActiveX control container through exposed properties, methods, and events. The Measurement Studio data acquisition, user interface, and analysis controls are examples of ActiveX controls.
ActiveX control container
Development environment that fully supports ActiveX controls and integrates them into its own environment using COM. An ActiveX control container enables you to specify how ActiveX controls interact with the environment through environment properties. Visual Basic is an example of an ActiveX control container.
analog I/O
Reading or writing data in continuously variable physical quantities, such as voltage or current.
annotate
Adding text, arrows, or shapes to describe or highlight a point or region on a graph.
ANSI C
C programming language defined by the American National Standards Institute.
API
Application Programming Interface. A specification of software functions and their input and return parameters.
array control
An array of Measurement Studio user interface controls that behave as a single unit.
assembly
A collection of one or more files that are versioned and deployed as a unit. An assembly is the primary building block of a .NET Framework application. All managed types and resources are contained within an assembly and are marked either as accessible only within the assembly or as accessible from code in other assemblies.
asynchronous
Function that begins an operation and returns control to the program prior to the completion or termination of the operation.

Back to top

B

button
A control used to input or display Boolean information or to initiate an action in a program.

Back to top

C

channel
  1. Physical—a terminal or pin at which you can measure or generate an analog or digital signal. A single physical channel can include more than one terminal, as in the case of a differential analog input channel or a digital port of eight lines. The name used for a counter physical channel is an exception because that physical channel name is not the name of the terminal where the counter measures or generates the digital signal.
  2. Virtual—a collection of property settings that can include a name, a physical channel, input terminal connections, the type of measurement or generation, and scaling information. You can define NI-DAQmx virtual channels outside a task (global) or inside a task (local). Configuring virtual channels is optional in Traditional NI-DAQ and earlier versions, but is integral to every measurement you take in NI-DAQmx. In Traditional NI-DAQ, you configure virtual channels in MAX. In NI-DAQmx, you can configure virtual channels in either MAX or in a program, and you can configure channels as part of a task or separately.
  3. Switch—a switch channel represents any connection point on a switch. It may be made up of one or more signal wires (commonly one, two, or four), depending on the switch topology. A virtual channel cannot be created with a switch channel. Switch channels may be used only in the NI-DAQmx Switch functions and VIs.
chart
To append new data points to the end of an existing plot over time.
CodeBuilder
LabWindows/CVI feature that creates code based on a .uir file to connect your GUI to the rest of your program. This code can be compiled and run as soon as it is created.
coercion
Automatic conversion that Measurement Studio controls perform to change the numeric representation of a data element.
COM
Component Object Model. Microsoft specification for architecting and developing reusable software components.
complex graph
A control that displays a ComplexDouble data type; the ComplexDouble data type represents a complex number of type Double that is composed of a real part and an imaginary part.
context-sensitive help
Help for dialog boxes, the controls in dialog boxes, and keywords in source code that you can access with the key or a Help button, or by clicking the link that appears in the Dynamic Help window in Visual Studio.
control
  1. ActiveX control. See ActiveX control.
  2. Object for entering, displaying, or manipulating data on a user interface.
counter/timer I/O
Reading or writing data based on high-precision timing through a counter or timer. By combining a counter with a highly accurate clock, you can create a wide variety of timing and counting applications, such as monitoring and analyzing digital waveforms and generating complex square waves.
cursor
Flashing rectangle that shows where you may enter text on the screen. If you have a mouse installed, there is a rectangular mouse cursor, or pointer.
cursor label
Text object used to display X and Y coordinates that a cursor crosshair points to on a graph.

Back to top

D

DAQ
Data acquisition. Process of acquiring data, typically from A/D or digital input plug-in boards.
DAQ Assistant
A graphical interface for configuring measurement tasks, channels, and scales.
DAQ device
A device that acquires or generates data and can contain multiple channels and conversion devices. DAQ devices include plug-in devices, PCMCIA cards, and DAQPad devices, which connect to a computer USB or 1394 (FireWire) port. SCXI modules are considered DAQ devices.
DataSocket
Technology that simplifies live data exchange between applications and HTTP, FTP, OPC, logos (Lookout objects) and file servers over the Internet. It provides one common API to a number of different communication protocols.
device
An instrument or controller you can access as a single entity that controls or monitors real-world I/O points. A device is often connected to a host computer through some type of communication network. See also Daq device and measurement device.
digital I/O
Reading or writing digital representations of data in discrete units (the binary digits 1 and 0). Digital information is either on or off.
digital waveform graph
A control that displays DigitalWaveform data on a Windows Forms or Web Forms user interface; the DigitalWaveform data type represents a set of digital states that are grouped by samples or signals.
distribution
Ability to install programs you develop with Measurement Studio to others working on different computers.
DLL
Dynamic Link Library. A library of functions that link to a program and load at run time rather than being compiled into the program. Loading libraries only when they are needed saves memory in software applications.
DMM
Digital Multimeter. A common measurement instrument that measures resistance, current, and voltage in a wide variety of applications.
driver
Software that controls a specific hardware device, such as a data acquisition board or GPIB interface board. See also instrument driver.
DSTP
DataSocket Transfer Protocol. Protocol based on TCP/IP to exchange data directly between two applications using DataSocket clients. Data is passed through a DataSocket Server between the applications.

Back to top

E

Ethernet
Standard connection type for networks, where computers are connected by coaxial or twisted-pair cable.
event
Object-generated response to some action or change in state, such as a mouse click or a completed acquisition. The event calls an event procedure that processes the event.
executable
Program file with a .exe extension that you can run independently of the development environment in which it was created.

Back to top

F

form
Window or area on the screen on which you place controls and indicators to create the user interface for your program.
front panel
Interactive user interface of a virtual instrument. Modeled after the front panel of physical instruments, it is composed of switches, slides, meters, graphs, charts, gauges, LEDs, and other controls and indicators.
FTP
File Transfer Protocol. Protocol based on TCP/IP to exchange files between computers.

Back to top

G

gauge
A control used to input or display numerical data.
GPIB
General Purpose Interface Bus. The standard bus used for controlling electronic instruments with a computer. Also called IEEE 488 bus because it is defined by ANSI/IEEE Standards 488-1978, 488.1-1987, and 488.2-1987.
graph
A 2D or 3D display of one or more plots.

Back to top

H

HTTP
HyperText Transfer Protocol. Protocol based on TCP/IP, which is used to download Web pages from an HTTP server to a Web browser.

Back to top

I

IEEE 488
Shortened notation for ANSI/IEEE Standards 488-1978, 488.1-1987, and 488.2-1987. See also GPIB.
IMAQ Vision
National Instruments image acquisition and analysis software that you can use to acquire images from National Instruments image acquisition (IMAQ) boards, display them in your program, perform interactive viewer operations, and analyze the images to extract information.
indicator
A control in read-only mode.
installer
Software program that copies program, system, and other necessary files to computers.
instrument driver
Library of functions to control and use one specific physical instrument. Also a set of functions that adds specific functionality to an application.
Instrument I/O Assistant
Assists in writing code to communicate with devices such as serial, Ethernet, or GPIB instruments. The Instrument I/O Assistant provides a user interface within the Visual Studio environment. You use the Instrument I/O Assistant to interactively write commands to a device, read data that the device returns, and specify how to parse the response.
interface
Connection between one or more of the following: hardware, software, and the user. For example, hardware interfaces connect two other pieces of hardware.
IVI
Interchangeable Virtual Instruments. A technology involving standard programming interfaces for classes of instruments, such as oscilloscopes, DMMs, and function generators, that results in hardware-independent instrument drivers. The IVI standard programming interfaces have been defined by the IVI Foundation, an industry consortium. Refer to the IVI Foundation at www.ivifoundation.org for more information.

Back to top

K

knob
A control used to input or display numerical data.

Back to top

L

LabVIEW
Laboratory Virtual Instrument Engineering Workbench. Graphical development environment used for developing test and measurement applications.
LabWindows/CVI
ANSI C development environment for building test and measurement applications.
LED
Light-Emitting Diode. An indicator that emits a light when current passes through it. For example, an LED shows if your computer or printer is turned on.
legend
A control that displays symbols and descriptions for a specific set of elements of another object, such as the plots or cursors of a graph.

Back to top

M

matrix
A rectangular array of numbers or mathematical elements that represent the coefficients in a system of linear equations.
MB
Megabytes of memory.
Measurement & Automation Explorer (MAX)
National Instruments tool for configuring your National Instruments hardware and driver software; executing system diagnostics; adding new devices, interfaces, and virtual channels; and viewing devices and instruments connected to your system.
measurement device
DAQ devices such as the E Series multifunction I/O (MIO) devices, SCXI signal conditioning modules, and switch modules.
Measurement Studio
National Instruments software that includes an integrated suite of tools and class libraries that are designed for developers using Microsoft Visual Basic .NET, Visual C# and ASP.NET to develop measurement and automation applications.
meter
A control used to input or display numerical data.
method
Function that performs a specific action on or with an object. The operation of the method often depends on the values of the object properties.
MFC
Microsoft Foundation Class. A framework for programming in Microsoft Windows, MFC provides code for managing windows, menus, and dialog boxes; performing basic input/output; storing collections of data objects; and more.

Back to top

N

NI-488.2
Driver-level software to control and communicate with National Instruments GPIB hardware.
NI-DAQ
Driver-level software to control and communicate with DAQ hardware. NI-DAQ is an extensive library of VIs and functions you can call from an application development environment (ADE) to program all the features of an NI measurement device, such as configuring, acquiring and generating data from, and sending data to the device.
NI-DAQmx
The latest NI-DAQ driver with new VIs, functions, and development tools for controlling measurement devices. The advantages of NI-DAQmx over earlier versions of NI-DAQ include the DAQ Assistant for configuring channels and measurement tasks for your device for use in LabVIEW, LabWindows/CVI, and Measurement Studio; increased performance such as faster single-point analog I/O; and a simpler API for creating DAQ applications using fewer functions and VIs than earlier versions of NI-DAQ.
NI-IMAQ
Driver-level software to control and communicate with National Instruments image acquisition hardware.
numeric edit
A control used to display and edit numeric values.

Back to top

O

OCX
OLE Control eXtension. Another name for ActiveX controls, reflected by the .ocx file extension of ActiveX control files.
OLE
Object Linking and Embedding. See ActiveX.
OPC
OLE for Process Control. An industry standard based on ActiveX and COM technologies that enables you to create a single client application that can communicate with disparate devices. Refer to the OPC Foundation at www.opcfoundation.org for more information.
oscilloscope
Measurement instrument widely used in high-speed testing applications, such as telecommunication physical layer testing, video testing, and high-speed digital design verification.

Back to top

P

PCI
Peripheral Component Interconnect. High-performance expansion bus architecture commonly found in PCs.
PID
Proportional-Integral-Derivative. A three-term control mechanism combining proportional, integral, and derivative control. You might use a PID algorithm to control processes such as heating and cooling systems, fluid level monitoring, flow control, and pressure control.
plot
  1. Trace (data line) on a graph representing the data in one row or column of an array.
  2. To display a new set of data while deleting any previous data on the graph.
point
Structure that contains two 16-bit integers that represent horizontal and vertical coordinates.
property
Attribute that defines the appearance or state of an object. The property can be a specific value or another object with its own properties and methods. For example, a value property is the color (property) of a plot (object), while an object property is a specific Y axis (property) on a graph (object). The Y axis itself is another object with properties, such as minimum and maximum values.
property editor
A control used to configure properties for Windows Forms controls at run time.
property pages
Window or dialog box that displays current configuration information and allows users to modify the configuration.
PXI
PCI eXtensions for Instrumentation. Rugged, open platform for modular instrumentation with specialized mechanical, electrical, and software features. Refer to PXI Systems Alliance at www.pxisa.org for more information.

Back to top

R

range
Region between the limits within which a quantity is measured, received, or transmitted. The range is expressed by stating the lower and upper range values.

Back to top

S

scalar
Number that a point on a scale can represent. The number is a single value as opposed to an array.
scale
Part of graph, chart, and some numeric controls and indicators that contains a series of marks or points at known intervals to denote units of measure.
scatter graph
A control that displays two-dimensional data on a Windows Forms or Web Forms user interface; displays a graph of X and Y data pairs.
scope
See oscilloscope.
serial
Standard serial bus on a computer used to communicate with instruments. Also known as RS-232.
slide
A control used to input or display numerical data.
slider
Moveable part of a slide control.
switch
A control used to receive and control Boolean input in an application user interface.
synchronous
Property or operation that begins and returns control to the program only when the operation is complete.

Back to top

T

tank
A control used to input or display numerical data.
task
NI-DAQmx—a set of channels and the channel configurations, timing, and triggering, and other details that define a measurement or generation you want to perform.
TCP/IP
Transmission Control Protocol/Internet Protocol. A standard format for transferring data in packets from one computer to another. The two parts of TCP/IP are TCP, which deals with the construction of data pockets, and IP, which routes them from computer to computer.
TestStand
Ready-to-run test executive from National Instruments for organizing, controlling, and executing your automated prototype, validation, or manufacturing test systems.
thermometer
A control used to input or display numerical data.

Back to top

U

UI
User Interface.

Back to top

V

vector
1D array.
VISA
Driver-software architecture developed by National Instruments to unify instrumentation software for serial, GPIB, and VXI instruments or controllers. It has been accepted as a standard for VXI by the VXIplug&play Systems Alliance.
VXI
VME eXtension for Instrumentation. Instrumentation architecture and bus based on the VME standard. Used in high-end test applications.

Back to top

W

waveform graph
A control that displays two-dimensional data on a Windows Forms or Web Forms user interface; displays data that is uniformly spaced in one dimension.
Windows Forms user interface thread
Any thread that creates a user interface object pumps windows messages.

Back to top

© 2003-2015 National Instruments. All rights reserved.

Send Feedback on this topic to National Instruments.


Important Information

[image]
NI Measurement Studio .NET Class Library
Important Information

This section provides legal information about Measurement Studio.

In This Section

Limited Warranty
Copyright
Trademarks
Patents
WARNING REGARDING USE OF NATIONAL INSTRUMENTS PRODUCTS


Limited Warranty

[image]
NI Measurement Studio .NET Class Library
Limited Warranty

This document is provided "as is" and is subject to being changed, without notice, in future editions. For the latest version, refer to ni.com/manuals. NI reviews this document carefully for technical accuracy; however, NI MAKES NO EXPRESS OR IMPLIED WARRANTIES AS TO THE ACCURACY OF THE INFORMATION CONTAINED HEREIN AND SHALL NOT BE LIABLE FOR ANY ERRORS.

NI warrants that its hardware products will be free of defects in materials and workmanship that cause the product to fail to substantially conform to the applicable NI published specifications for one (1) year from the date of invoice.

For a period of ninety (90) days from the date of invoice, NI warrants that (i) its software products will perform substantially in accordance with the applicable documentation provided with the software, and (ii) the software media will be free from defects in materials and workmanship.

If NI receives notice of a defect or non-conformance during the applicable warranty period, NI will, in its discretion: (i) repair or replace the affected product, or (ii) refund the fees paid for the affected product. Repaired or replaced hardware will be warranted for the remainder of the original warranty period or ninety (90) days, whichever is longer. If NI elects to repair or replace the product, NI may use new or refurbished parts or products that are equivalent to new in performance and reliability and are at least functionally equivalent to the original part or product.

You must obtain an RMA number from NI before returning any product to NI. NI reserves the right to charge a fee for examining and testing hardware not covered by the Limited Warranty.

This Limited Warranty does not apply if the defect of the product resulted from improper or inadequate maintenance, installation, repair, or calibration (performed by a party other than NI); unauthorized modification; improper environment; use of an improper hardware or software key; improper use or operation outside of the specification for the product; improper voltages; accident, abuse, or neglect; or a hazard such as lightning, flood, or other act of nature.

THE REMEDIES SET FORTH ABOVE ARE EXCLUSIVE AND THE CUSTOMER’S SOLE REMEDIES, AND SHALL APPLY EVEN IF SUCH REMEDIES FAIL OF THEIR ESSENTIAL PURPOSE.

EXCEPT AS EXPRESSLY SET FORTH HEREIN, PRODUCTS ARE PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND AND NI DISCLAIMS ALL WARRANTIES, EXPRESSED OR IMPLIED, WITH RESPECT TO THE PRODUCTS, INCLUDING ANY IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, TITLE OR NON-INFRINGEMENT, AND ANY WARRANTIES THAT MAY ARISE FROM USAGE OF TRADE OR COURSE OF DEALING. NI DOES NOT WARRANT, GUARANTEE, OR MAKE ANY REPRESENTATIONS REGARDING THE USE OF OR THE RESULTS OF THE USE OF THE PRODUCTS IN TERMS OF CORRECTNESS, ACCURACY, RELIABILITY, OR OTHERWISE. NI DOES NOT WARRANT THAT THE OPERATION OF THE PRODUCTS WILL BE UNINTERRUPTED OR ERROR FREE.

In the event that you and NI have a separate signed written agreement with warranty terms covering the products, then the warranty terms in the separate agreement shall control.


Copyright

[image]
NI Measurement Studio .NET Class Library
Copyright

Under the copyright laws, this publication may not be reproduced or transmitted in any form, electronic or mechanical, including photocopying, recording, storing in an information retrieval system, or translating, in whole or in part, without the prior written consent of National Instruments Corporation.

National Instruments respects the intellectual property of others, and we ask our users to do the same. NI software is protected by copyright and other intellectual property laws. Where NI software may be used to reproduce software or other materials belonging to others, you may use NI software only to reproduce materials that you may reproduce in accordance with the terms of any applicable license or other legal restriction.

End-User License Agreements and Third-Party Legal Notices

You can find end-user license agreements (EULAs) and third-party legal notices in the following locations:

  • Notices are located in the <National Instruments>\_Legal Information and <National Instruments> directories.
  • EULAs are located in the <National Instruments>\Shared\MDF\Legal\license directory.
  • Review <National Instruments>\_Legal Information.txt for information on including legal information in installers built with NI products.

U.S. Government Restricted Rights

If you are an agency, department, or other entity of the United States Government ("Government"), the use, duplication, reproduction, release, modification, disclosure or transfer of the technical data included in this manual is governed by the Restricted Rights provisions under Federal Acquisition Regulation 52.227-14 for civilian agencies and Defense Federal Acquisition Regulation Supplement Section 252.227-7014 and 252.227-7015 for military agencies.

IVI Foundation Copyright Notice

Content from the IVI specifications reproduced with permission from the IVI Foundation.

The IVI Foundation and its member companies make no warranty of any kind with regard to this material, including, but not limited to, the implied warranties of merchantability and fitness for a particular purpose. The IVI Foundation and its member companies shall not be liable for errors contained herein or for incidental or consequential damages in connection with the furnishing, performance, or use of this material.


Trademarks

[image]
NI Measurement Studio .NET Class Library
Trademarks

Refer to the NI Trademarks and Logo Guidelines at ni.com/trademarks for information on NI trademarks.

ARM, Keil, and μVision are trademarks or registered of ARM Ltd or its subsidiaries.

LEGO, the LEGO logo, WEDO, and MINDSTORMS are trademarks of the LEGO Group.

TETRIX by Pitsco is a trademark of Pitsco, Inc.

FIELDBUS FOUNDATION™ and FOUNDATION™ are trademarks of the Fieldbus Foundation.

EtherCAT® is a registered trademark of and licensed by Beckhoff Automation GmbH.

CANopen® is a registered Community Trademark of CAN in Automation e.V.

DeviceNet™ and EtherNet/IP™ are trademarks of ODVA.

Go!, SensorDAQ, and Vernier are registered trademarks of Vernier Software & Technology. Vernier Software & Technology and vernier.com are trademarks or trade dress.

Xilinx is the registered trademark of Xilinx, Inc.

Taptite and Trilobular are registered trademarks of Research Engineering & Manufacturing Inc.

FireWire® is the registered trademark of Apple Inc.

Linux® is the registered trademark of Linus Torvalds in the U.S. and other countries.

Handle Graphics®, MATLAB®, Real-Time Workshop®, Simulink®, Stateflow®, and xPC TargetBox® are registered trademarks, and TargetBox™ and Target Language Compiler™ are trademarks of The MathWorks, Inc.

Tektronix®, Tek, and Tektronix, Enabling Technology are registered trademarks of Tektronix, Inc.

The Bluetooth® word mark is a registered trademark owned by the Bluetooth SIG, Inc.

The ExpressCard™ word mark and logos are owned by PCMCIA and any use of such marks by National Instruments is under license.

The mark LabWindows is used under a license from Microsoft Corporation. Windows is a registered trademark of Microsoft Corporation in the United States and other countries.

Other product and company names mentioned herein are trademarks or trade names of their respective companies.

Members of the National Instruments Alliance Partner Program are business entities independent from National Instruments and have no agency, partnership, or joint-venture relationship with National Instruments.


Patents

[image]
NI Measurement Studio .NET Class Library
Patents

For patents covering the National Instruments products/technology, refer to the appropriate location: Help»Patents on your software, the patents.txt file on your media, or the National Instruments Patent Notice at ni.com/patents.


WARNING REGARDING USE OF NATIONAL INSTRUMENTS PRODUCTS

[image]
NI Measurement Studio .NET Class Library
WARNING REGARDING USE OF NATIONAL INSTRUMENTS PRODUCTS

YOU ARE ULTIMATELY RESPONSIBLE FOR VERIFYING AND VALIDATING THE SUITABILITY AND RELIABILITY OF THE PRODUCTS WHENEVER THE PRODUCTS ARE INCORPORATED IN YOUR SYSTEM OR APPLICATION, INCLUDING THE APPROPRIATE DESIGN, PROCESS, AND SAFETY LEVEL OF SUCH SYSTEM OR APPLICATION.

PRODUCTS ARE NOT DESIGNED, MANUFACTURED, OR TESTED FOR USE IN LIFE OR SAFETY CRITICAL SYSTEMS, HAZARDOUS ENVIRONMENTS OR ANY OTHER ENVIRONMENTS REQUIRING FAIL-SAFE PERFORMANCE, INCLUDING IN THE OPERATION OF NUCLEAR FACILITIES; AIRCRAFT NAVIGATION; AIR TRAFFIC CONTROL SYSTEMS; LIFE SAVING OR LIFE SUSTAINING SYSTEMS OR SUCH OTHER MEDICAL DEVICES; OR ANY OTHER APPLICATION IN WHICH THE FAILURE OF THE PRODUCT OR SERVICE COULD LEAD TO DEATH, PERSONAL INJURY, SEVERE PROPERTY DAMAGE OR ENVIRONMENTAL HARM (COLLECTIVELY, "HIGH-RISK USES"). FURTHER, PRUDENT STEPS MUST BE TAKEN TO PROTECT AGAINST FAILURES, INCLUDING PROVIDING BACK-UP AND SHUT-DOWN MECHANISMS. NI EXPRESSLY DISCLAIMS ANY EXPRESS OR IMPLIED WARRANTY OF FITNESS OF THE PRODUCTS OR SERVICES FOR HIGH-RISK USES.


NI Services

[image]
NI Measurement Studio .NET Class Library
NI Services

National Instruments provides global services and support as part of our commitment to your success. Take advantage of product services in addition to training and certification programs that meet your needs during each phase of the application life cycle; from planning and development through deployment and ongoing maintenance.

To get started, create an account or log in to your National Instruments User Profile at ni.com/myproducts and register your product.

As a registered NI product user, you are entitled to the following benefits:

  • Access to applicable product services.
  • Easier product management with an online account.
  • Receive critical part notifications, software updates, and service expirations.

Services and Resources

  • Maintenance and Hardware Services—NI helps you identify your systems' accuracy and reliability requirements and provides warranty, sparing, and calibration services to help you maintain accuracy and minimize downtime over the life of your system. Visit ni.com/services for more information.
    • Warranty and Repair—All NI hardware features a one-year standard warranty that is extendable up to five years. NI offers repair services performed in a timely manner by highly trained factory technicians using only original parts at a National Instruments service center.
    • Calibration—Through regular calibration, you can quantify and improve the measurement performance of an instrument. NI provides state-of-the-art calibration services. If your product supports calibration, you can obtain the calibration certificate for your product at ni.com/calibration.
  • System Integration—If you have time constraints, limited in-house technical resources, or other project challenges, National Instruments Alliance Partner members can help. To learn more, call your local NI office or visit ni.com/alliance.
  • Training and Certification—The NI training and certification program is the most effective way to increase application development proficiency and productivity. Visit ni.com/training for more information.
    • The Skills Guide assists you in identifying the proficiency requirements of your current application and gives you options for obtaining those skills consistent with your time and budget constraints and personal learning preferences. Visit ni.com/skills-guide to see these custom paths.
    • NI offers courses in several languages and formats including instructor-led classes at facilities worldwide, courses on-site at your facility, and online courses to serve your individual needs.
  • Technical Support—Support at ni.com/support includes the following resources:
    • Self-Help Technical Resources—Visit ni.com/support for software drivers and updates, a searchable KnowledgeBase, product manuals, step-by-step troubleshooting wizards, thousands of example programs, tutorials, application notes, instrument drivers, and so on. Registered users also receive access to the NI Discussion Forums at ni.com/forums. NI Applications Engineers make sure every question submitted online receives an answer.
    • Software Support Service Membership—The Standard Service Program (SSP) is a renewable one-year subscription included with almost every NI software product, including NI Developer Suite. This program entitles members to direct access to NI Applications Engineers through phone and email for one-to-one technical support, as well as exclusive access to online training modules at ni.com/self-paced-training. NI also offers flexible extended contract options that guarantee your SSP benefits are available without interruption for as long as you need them. Visit ni.com/ssp for more information.
  • Declaration of Conformity (DoC)—A DoC is our claim of compliance with the Council of the European Communities using the manufacturer's declaration of conformity. This system affords the user protection for electromagnetic compatibility (EMC) and product safety. You can obtain the DoC for your product by visiting ni.com/certification.

For information about other technical support options in your area, visit ni.com/services or contact your local office at ni.com/contact.

You can also visit the Worldwide Offices section of ni.com/niglobal to access the branch office websites, which provide up-to-date contact information, support phone numbers, email addresses, and current events.


a
about
above
across
after
afterwards
again
against
all
almost
alone
along
already
also
although
always
am
among
amongst
amount
an
and
another
any
anyone
anything
anyway
anywhere
are
around
as
at
back
be
became
because
become
becomes
becoming
been
before
beforehand
behind
being
below
beside
besides
between
beyond
both
bottom
but
by
can
cannot
come
con
could
dec
did
do
does
doing
done
down
due
during
each
early
either
else
elsewhere
enough
etc
etcetera
even
ever
every
everyone
everything
everywhere
except
far
few
fill
find
fire
for
former
formerly
found
from
front
full
further
get
give
had
has
have
he
hence
her
here
hereafter
hereby
herein
hereupon
hers
herself
him
himself
his
how
however
i
if
in
inc
indeed
interest
into
is
it
its
itself
keep
last
late
later
latter
latterly
least
less
made
many
may
me
meanwhile
med
might
mine
more
moreover
most
mostly
move
much
must
myself
name
namely
near
neither
never
nevertheless
next
no
nobody
non
none
noone
nor
not
note
nothing
now
nowhere
of
off
often
on
once
only
onto
or
other
others
otherwise
our
ours
ourselves
out
over
own
per
perhaps
please
pre
pro
put
raise
rather
run
same
saw
see
seem
seemed
seeming
seems
seen
several
she
should
show
side
since
sincere
so
some
somehow
someone
something
sometime
sometimes
somewhere
still
such
take
tha
than
that
the
their
them
themselves
then
thence
there
thereafter
thereby
therefore
therein
thereupon
these
they
thick
thin
this
tho
those
though
through
throughout
thru
thus
thy
tip
to
together
too
toward
towards
under
until
up
upon
us
use
very
via
was
we
well
were
what
whatever
when
whence
whenever
where
whereafter
whereas
whereby
wherein
whereupon
wherever
whether
which
while
whither
who
whoever
whole
whom
whose
why
will
with
within
without
would
yet
you
your
yours
yourself
yourselves