IviSwtch Reference

© 2003 IVI Foundation

Welcome to the IviSwtch Class-Compliant Interface Reference

This section contains the reference material for the IviSwtch class-compliant interface.

This help hierarchy matches the COM hierarchy defined in the IviSwtch class specification, available on the IVI Foundation Web Site. The COM hierarchy groups related capabilities into common interfaces. These interfaces often include both IviSwtch base and extension capabilities. To help users distinguish between base and extension capabilities, the Capability Group section of each method or property topic lists which of the IviSwtch Capability Groups the method or property belongs to.

Since IVI class-compliant specific drivers are not required to support all extension groups, users should refer to the compliance documentation for the particular driver being used to determine if an extension group is supported before using capabilities in that group.

IVI class-compliant specific drivers may have small differences in the way a particular extension group method or property is implemented. For instance, a driver might implement only one of several IVI-defined values for an extension group attribute. Refer to the help documentation provided with the IVI class-compliant specific driver for detailed information about implementation.


Inherent Interface

IviDCPwr Reference

IviDCPwr Capability Groups

Capability Group | Description
IviSwtchBase | Base capabilities of the IviSwtch specification. This group supports the ability to connect and disconnect paths on the instrument, determine the connectivity of two switches, and query the state of the switch module.
IviSwtchScanner | This group supports the IviSwtchBase capabilities and has the ability to scan channels.
IviSwtchSoftwareTrigger | This group supports the IviSwtchBase capabilities and has the ability to receive software triggers.


Inherent Interface

IviSwtch Instrument Class Interfaces

IIviSwtch | IVI Swtch class-compliant root level interface
IIviSwtchChannel | IVI Swtch class-compliant channel interface
IIviSwtchChannels | IVI Swtch class-compliant channel collection interface
IIviSwtchCharacteristics | IVI Swtch class-compliant channel characteristics interface
IIviSwtchPath | IVI Swtch class-compliant path interface
IIviSwtchScan | IVI Swtch class-compliant scan interface


IIviSwtch Interface

IVI Swtch class-compliant root level interface

Methods

Initialize | Opens the I/O session to the instrument. Driver methods and properties that access the instrument are only accessible after Initialize is called. Initialize optionally performs a Reset and queries the instrument to validate the instrument model.
Close | Closes the I/O session to the instrument. Driver methods and properties that access the instrument are not accessible after Close is called.

Properties

DriverOperation | Pointer to the IIviDriverOperation interface
Identity | Pointer to the IIviDriverIdentity interface
Utility | Pointer to the IIviDriverUtility interface
Initialized | Initialized is True between a successful call to the Initialize method and a successful call to the Close method, and False at all other times.
Channels | Pointer to the class-compliant IIviSwtchChannels interface
Path | Pointer to the class-compliant IIviSwtchPath interface
Scan | Pointer to the class-compliant IIviSwtchScan interface


DriverOperation Property

IIviSwtch.DriverOperation Property

Pointer to the IIviDriverOperation interface

[Visual Basic]
Property Get DriverOperation() As IIviDriverOperation
[C++]
HRESULT get_DriverOperation(IIviDriverOperation** value);
[ANSI C]
HRESULT IIviSwtch_get_DriverOperation(IIviSwtch* This, IIviDriverOperation** value);
[C#]
public IIviDriverOperation DriverOperation {get;}

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Channels | Path | Scan | Initialize | Close | IIviSwtch Overview


Identity Property

IIviSwtch.Identity Property

Pointer to the IIviDriverIdentity interface

[Visual Basic]
Property Get Identity() As IIviDriverIdentity
[C++]
HRESULT get_Identity(IIviDriverIdentity** value);
[ANSI C]
HRESULT IIviSwtch_get_Identity(IIviSwtch* This, IIviDriverIdentity** value);
[C#]
public IIviDriverIdentity Identity {get;}

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Channels | Path | Scan | Initialize | Close | IIviSwtch Overview


Utility Property

IIviSwtch.Utility Property

Pointer to the IIviDriverUtility interface

[Visual Basic]
Property Get Utility() As IIviDriverUtility
[C++]
HRESULT get_Utility(IIviDriverUtility** value);
[ANSI C]
HRESULT IIviSwtch_get_Utility(IIviSwtch* This, IIviDriverUtility** value);
[C#]
public IIviDriverUtility Utility {get;}

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Channels | Path | Scan | Initialize | Close | IIviSwtch Overview


Initialized Property

IIviSwtch.Initialized Property

Initialized is True between a successful call to the Initialize method and a successful call to the Close method, and False at all other times.

[Visual Basic]
Property Get Initialized() As Boolean
[C++]
HRESULT get_Initialized(VARIANT_BOOL* value);
[ANSI C]
HRESULT IIviSwtch_get_Initialized(IIviSwtch* This, VARIANT_BOOL* value);
[C#]
public bool Initialized {get;}

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Channels | Path | Scan | Initialize | Close | IIviSwtch Overview


Channels Property

IIviSwtch.Channels Property

Pointer to the class-compliant IIviSwtchChannels interface

[Visual Basic]
Property Get Channels() As IIviSwtchChannels
[C++]
HRESULT get_Channels(IIviSwtchChannels** value);
[ANSI C]
HRESULT IIviSwtch_get_Channels(IIviSwtch* This, IIviSwtchChannels** value);
[C#]
public IIviSwtchChannels Channels {get;}

Capability Group

IviSwtchBase

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Channels | Path | Scan | Initialize | Close | IIviSwtch Overview


Path Property

IIviSwtch.Path Property

Pointer to the class-compliant IIviSwtchPath interface

[Visual Basic]
Property Get Path() As IIviSwtchPath
[C++]
HRESULT get_Path(IIviSwtchPath** value);
[ANSI C]
HRESULT IIviSwtch_get_Path(IIviSwtch* This, IIviSwtchPath** value);
[C#]
public IIviSwtchPath Path {get;}

Capability Group

IviSwtchBase

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Channels | Path | Scan | Initialize | Close | IIviSwtch Overview


Scan Property

IIviSwtch.Scan Property

Pointer to the class-compliant IIviSwtchScan interface

[Visual Basic]
Property Get Scan() As IIviSwtchScan
[C++]
HRESULT get_Scan(IIviSwtchScan** value);
[ANSI C]
HRESULT IIviSwtch_get_Scan(IIviSwtch* This, IIviSwtchScan** value);
[C#]
public IIviSwtchScan Scan {get;}

Capability Group

IviSwtchScanner, IviSwtchSoftwareTrigger

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Channels | Path | Scan | Initialize | Close | IIviSwtch Overview


Initialize Method

IIviSwtch.Initialize Method

Opens the I/O session to the instrument. Driver methods and properties that access the instrument are only accessible after Initialize is called. Initialize optionally performs a Reset and queries the instrument to validate the instrument model.

[Visual Basic]
Sub Initialize( _
   ResourceName As String, _
   IdQuery As Boolean, _
   Reset As Boolean, _
   OptionString As String _
)
[C++]
HRESULT Initialize(
   BSTR ResourceName,
   VARIANT_BOOL IdQuery,
   VARIANT_BOOL Reset,
   BSTR OptionString
);
[ANSI C]
HRESULT IIviSwtch_Initialize(
   IIviSwtch* This
   BSTR ResourceName,
   VARIANT_BOOL IdQuery,
   VARIANT_BOOL Reset,
   BSTR OptionString
);
[C#]
public void Initialize(
   string ResourceName,
   bool IdQuery,
   bool Reset,
   string OptionString
);

Parameters

ResourceName
An IVI logical name or an instrument specific string that identifies the address of the instrument, such as a VISA resource descriptor string.
IdQuery
Specifies whether to verify the ID of the instrument.
Reset
Specifies whether to reset the instrument.
OptionString
The user can use the OptionsString parameter to specify the initial values of certain IVI inherent attributes for the session.

Related Items

Close

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Channels | Path | Scan | Initialize | Close | IIviSwtch Overview


Close Method

IIviSwtch.Close Method

Closes the I/O session to the instrument. Driver methods and properties that access the instrument are not accessible after Close is called.

[Visual Basic]
Sub Close()
[C++]
HRESULT Close();
[ANSI C]
HRESULT IIviSwtch_Close(
   IIviSwtch* This);
[C#]
public void Close();

Related Items

Initialize

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Channels | Path | Scan | Initialize | Close | IIviSwtch Overview


IIviSwtchChannel Interface

IVI Swtch class-compliant channel interface

Properties

IsConfigurationChannel | If True, the specific driver can use the channel for internal path creation. The only operations that may be performed on configuration channels are reading and writing the IsConfigurationChannel property.
IsSourceChannel | If True, the channel is a source channel. Two channels that are either sources or have their own connections to sources, may not be connected. This prevents connections that might cause damage to channels, devices, or system.
Characteristics | Pointer to the class-compliant IIviSwtchCharacteristics interface


IsConfigurationChannel Property

IIviSwtchChannel.IsConfigurationChannel Property

If True, the specific driver can use the channel for internal path creation. The only operations that may be performed on configuration channels are reading and writing the IsConfigurationChannel property.

[Visual Basic]
Property Get IsConfigurationChannel() As Boolean
Property Let IsConfigurationChannel(value As Boolean)
[C++]
HRESULT get_IsConfigurationChannel(VARIANT_BOOL* value);
HRESULT put_IsConfigurationChannel(VARIANT_BOOL value);
[ANSI C]
HRESULT IIviSwtchChannel_get_IsConfigurationChannel(IIviSwtchChannel* This, VARIANT_BOOL* value);
HRESULT IIviSwtchChannel_put_IsConfigurationChannel(IIviSwtchChannel* This, VARIANT_BOOL value);
[C#]
public bool IsConfigurationChannel {get; set;}

Capability Group

IviSwtchBase

Also In This Interface

IsConfigurationChannel | IsSourceChannel | Characteristics | IIviSwtchChannel Overview


IsSourceChannel Property

IIviSwtchChannel.IsSourceChannel Property

If True, the channel is a source channel. Two channels that are either sources or have their own connections to sources, may not be connected. This prevents connections that might cause damage to channels, devices, or system.

[Visual Basic]
Property Get IsSourceChannel() As Boolean
Property Let IsSourceChannel(value As Boolean)
[C++]
HRESULT get_IsSourceChannel(VARIANT_BOOL* value);
HRESULT put_IsSourceChannel(VARIANT_BOOL value);
[ANSI C]
HRESULT IIviSwtchChannel_get_IsSourceChannel(IIviSwtchChannel* This, VARIANT_BOOL* value);
HRESULT IIviSwtchChannel_put_IsSourceChannel(IIviSwtchChannel* This, VARIANT_BOOL value);
[C#]
public bool IsSourceChannel {get; set;}

Capability Group

IviSwtchBase

Also In This Interface

IsConfigurationChannel | IsSourceChannel | Characteristics | IIviSwtchChannel Overview


Characteristics Property

IIviSwtchChannel.Characteristics Property

Pointer to the class-compliant IIviSwtchCharacteristics interface

[Visual Basic]
Property Get Characteristics() As IIviSwtchCharacteristics
[C++]
HRESULT get_Characteristics(IIviSwtchCharacteristics** value);
[ANSI C]
HRESULT IIviSwtchChannel_get_Characteristics(IIviSwtchChannel* This, IIviSwtchCharacteristics** value);
[C#]
public IIviSwtchCharacteristics Characteristics {get;}

Capability Group

IviSwtchBase

Also In This Interface

IsConfigurationChannel | IsSourceChannel | Characteristics | IIviSwtchChannel Overview


IIviSwtchChannels Interface

IVI Swtch class-compliant channel collection interface

Properties

Item | An interface reference pointer to one of the IVI Swtch Channel interfaces which is selected by the channel name.
Count | The number of channels.
Name | The channel name for a given index.


Item Property

IIviSwtchChannels.Item Property

An interface reference pointer to one of the IVI Swtch Channel interfaces which is selected by the channel name.

[Visual Basic]
Property Get Item(Name As String) As IIviSwtchChannel
[C++]
HRESULT get_Item(BSTR Name, IIviSwtchChannel** value);
[ANSI C]
HRESULT IIviSwtchChannels_get_Item(IIviSwtchChannels* This, BSTR Name, IIviSwtchChannel** value);
[C#]HRESULT get_Item(string Name, IIviSwtchChannel value);

Parameters

Name
The Name parameter may be a string defined by the driver or supplied as a virtual name in the configuration store.

Capability Group

IviSwtchBase

Also In This Interface

Item | Count | Name | IIviSwtchChannels Overview


Count Property

IIviSwtchChannels.Count Property

The number of channels.

[Visual Basic]
Property Get Count() As Long
[C++]
HRESULT get_Count(long* value);
[ANSI C]
HRESULT IIviSwtchChannels_get_Count(IIviSwtchChannels* This, long* value);
[C#]
public long Count {get;}

Capability Group

IviSwtchBase

Also In This Interface

Item | Count | Name | IIviSwtchChannels Overview


Name Property

IIviSwtchChannels.Name Property

The channel name for a given index.

[Visual Basic]
Property Get Name(Index As Long) As String
[C++]
HRESULT get_Name(long Index, BSTR* value);
[ANSI C]
HRESULT IIviSwtchChannels_get_Name(IIviSwtchChannels* This, long Index, BSTR* value);
[C#]HRESULT get_Name(long Index, string value);

Parameters

Index
The one-based index into the Channels collection. Its value must range from one to Channels.Count.

Capability Group

IviSwtchBase

Also In This Interface

Item | Count | Name | IIviSwtchChannels Overview


IIviSwtchCharacteristics Interface

IVI Swtch class-compliant channel characteristics interface

Properties

ACCurrentCarryMax | The maximum AC current the channel can carry, in amperes.
ACCurrentSwitchingMax | The maximum AC current the channel can switch, in amperes.
ACPowerCarryMax | The maximum AC power the channel can handle, in volt-amperes.
ACPowerSwitchingMax | The maximum AC power the channel can switch, in volt-amperes.
ACVoltageMax | The maximum AC voltage the channel can handle, in volts RMS.
Bandwidth | The bandwidth, in Hertz, for the channel.
DCCurrentCarryMax | The maximum DC current the channel can carry, in amperes.
DCCurrentSwitchingMax | The maximum DC current the channel can switch, in amperes.
DCPowerCarryMax | The maximum DC power the channel can handle, in watts.
DCPowerSwitchingMax | The maximum DC power the channel can switch, in watts.
DCVoltageMax | The maximum DC voltage the channel can handle, in volts.
Impedance | The characteristic impedance of the channel, in ohms.
SettlingTime | The maximum total settling time, in seconds, for the channel before the signal going through it is considered stable. This includes both the activation time for the channel as well as any debounce time.
WireMode | The number of conductors in the current channel.


ACCurrentCarryMax Property

IIviSwtchCharacteristics.ACCurrentCarryMax Property

The maximum AC current the channel can carry, in amperes.

[Visual Basic]
Property Get ACCurrentCarryMax() As Double
[C++]
HRESULT get_ACCurrentCarryMax(double* value);
[ANSI C]
HRESULT IIviSwtchCharacteristics_get_ACCurrentCarryMax(IIviSwtchCharacteristics* This, double* value);
[C#]
public double ACCurrentCarryMax {get;}

Capability Group

IviSwtchBase

Also In This Interface

ACCurrentCarryMax | ACCurrentSwitchingMax | ACPowerCarryMax | ACPowerSwitchingMax | ACVoltageMax | Bandwidth | DCCurrentCarryMax | DCCurrentSwitchingMax | DCPowerCarryMax | DCPowerSwitchingMax | DCVoltageMax | Impedance | SettlingTime | WireMode | IIviSwtchCharacteristics Overview


ACCurrentSwitchingMax Property

IIviSwtchCharacteristics.ACCurrentSwitchingMax Property

The maximum AC current the channel can switch, in amperes.

[Visual Basic]
Property Get ACCurrentSwitchingMax() As Double
[C++]
HRESULT get_ACCurrentSwitchingMax(double* value);
[ANSI C]
HRESULT IIviSwtchCharacteristics_get_ACCurrentSwitchingMax(IIviSwtchCharacteristics* This, double* value);
[C#]
public double ACCurrentSwitchingMax {get;}

Capability Group

IviSwtchBase

Also In This Interface

ACCurrentCarryMax | ACCurrentSwitchingMax | ACPowerCarryMax | ACPowerSwitchingMax | ACVoltageMax | Bandwidth | DCCurrentCarryMax | DCCurrentSwitchingMax | DCPowerCarryMax | DCPowerSwitchingMax | DCVoltageMax | Impedance | SettlingTime | WireMode | IIviSwtchCharacteristics Overview


ACPowerCarryMax Property

IIviSwtchCharacteristics.ACPowerCarryMax Property

The maximum AC power the channel can handle, in volt-amperes.

[Visual Basic]
Property Get ACPowerCarryMax() As Double
[C++]
HRESULT get_ACPowerCarryMax(double* value);
[ANSI C]
HRESULT IIviSwtchCharacteristics_get_ACPowerCarryMax(IIviSwtchCharacteristics* This, double* value);
[C#]
public double ACPowerCarryMax {get;}

Capability Group

IviSwtchBase

Also In This Interface

ACCurrentCarryMax | ACCurrentSwitchingMax | ACPowerCarryMax | ACPowerSwitchingMax | ACVoltageMax | Bandwidth | DCCurrentCarryMax | DCCurrentSwitchingMax | DCPowerCarryMax | DCPowerSwitchingMax | DCVoltageMax | Impedance | SettlingTime | WireMode | IIviSwtchCharacteristics Overview


ACPowerSwitchingMax Property

IIviSwtchCharacteristics.ACPowerSwitchingMax Property

The maximum AC power the channel can switch, in volt-amperes.

[Visual Basic]
Property Get ACPowerSwitchingMax() As Double
[C++]
HRESULT get_ACPowerSwitchingMax(double* value);
[ANSI C]
HRESULT IIviSwtchCharacteristics_get_ACPowerSwitchingMax(IIviSwtchCharacteristics* This, double* value);
[C#]
public double ACPowerSwitchingMax {get;}

Capability Group

IviSwtchBase

Also In This Interface

ACCurrentCarryMax | ACCurrentSwitchingMax | ACPowerCarryMax | ACPowerSwitchingMax | ACVoltageMax | Bandwidth | DCCurrentCarryMax | DCCurrentSwitchingMax | DCPowerCarryMax | DCPowerSwitchingMax | DCVoltageMax | Impedance | SettlingTime | WireMode | IIviSwtchCharacteristics Overview


ACVoltageMax Property

IIviSwtchCharacteristics.ACVoltageMax Property

The maximum AC voltage the channel can handle, in volts RMS.

[Visual Basic]
Property Get ACVoltageMax() As Double
[C++]
HRESULT get_ACVoltageMax(double* value);
[ANSI C]
HRESULT IIviSwtchCharacteristics_get_ACVoltageMax(IIviSwtchCharacteristics* This, double* value);
[C#]
public double ACVoltageMax {get;}

Capability Group

IviSwtchBase

Also In This Interface

ACCurrentCarryMax | ACCurrentSwitchingMax | ACPowerCarryMax | ACPowerSwitchingMax | ACVoltageMax | Bandwidth | DCCurrentCarryMax | DCCurrentSwitchingMax | DCPowerCarryMax | DCPowerSwitchingMax | DCVoltageMax | Impedance | SettlingTime | WireMode | IIviSwtchCharacteristics Overview


Bandwidth Property

IIviSwtchCharacteristics.Bandwidth Property

The bandwidth, in Hertz, for the channel.

[Visual Basic]
Property Get Bandwidth() As Double
[C++]
HRESULT get_Bandwidth(double* value);
[ANSI C]
HRESULT IIviSwtchCharacteristics_get_Bandwidth(IIviSwtchCharacteristics* This, double* value);
[C#]
public double Bandwidth {get;}

Capability Group

IviSwtchBase

Also In This Interface

ACCurrentCarryMax | ACCurrentSwitchingMax | ACPowerCarryMax | ACPowerSwitchingMax | ACVoltageMax | Bandwidth | DCCurrentCarryMax | DCCurrentSwitchingMax | DCPowerCarryMax | DCPowerSwitchingMax | DCVoltageMax | Impedance | SettlingTime | WireMode | IIviSwtchCharacteristics Overview


DCCurrentCarryMax Property

IIviSwtchCharacteristics.DCCurrentCarryMax Property

The maximum DC current the channel can carry, in amperes.

[Visual Basic]
Property Get DCCurrentCarryMax() As Double
[C++]
HRESULT get_DCCurrentCarryMax(double* value);
[ANSI C]
HRESULT IIviSwtchCharacteristics_get_DCCurrentCarryMax(IIviSwtchCharacteristics* This, double* value);
[C#]
public double DCCurrentCarryMax {get;}

Capability Group

IviSwtchBase

Also In This Interface

ACCurrentCarryMax | ACCurrentSwitchingMax | ACPowerCarryMax | ACPowerSwitchingMax | ACVoltageMax | Bandwidth | DCCurrentCarryMax | DCCurrentSwitchingMax | DCPowerCarryMax | DCPowerSwitchingMax | DCVoltageMax | Impedance | SettlingTime | WireMode | IIviSwtchCharacteristics Overview


DCCurrentSwitchingMax Property

IIviSwtchCharacteristics.DCCurrentSwitchingMax Property

The maximum DC current the channel can switch, in amperes.

[Visual Basic]
Property Get DCCurrentSwitchingMax() As Double
[C++]
HRESULT get_DCCurrentSwitchingMax(double* value);
[ANSI C]
HRESULT IIviSwtchCharacteristics_get_DCCurrentSwitchingMax(IIviSwtchCharacteristics* This, double* value);
[C#]
public double DCCurrentSwitchingMax {get;}

Capability Group

IviSwtchBase

Also In This Interface

ACCurrentCarryMax | ACCurrentSwitchingMax | ACPowerCarryMax | ACPowerSwitchingMax | ACVoltageMax | Bandwidth | DCCurrentCarryMax | DCCurrentSwitchingMax | DCPowerCarryMax | DCPowerSwitchingMax | DCVoltageMax | Impedance | SettlingTime | WireMode | IIviSwtchCharacteristics Overview


DCPowerCarryMax Property

IIviSwtchCharacteristics.DCPowerCarryMax Property

The maximum DC power the channel can handle, in watts.

[Visual Basic]
Property Get DCPowerCarryMax() As Double
[C++]
HRESULT get_DCPowerCarryMax(double* value);
[ANSI C]
HRESULT IIviSwtchCharacteristics_get_DCPowerCarryMax(IIviSwtchCharacteristics* This, double* value);
[C#]
public double DCPowerCarryMax {get;}

Capability Group

IviSwtchBase

Also In This Interface

ACCurrentCarryMax | ACCurrentSwitchingMax | ACPowerCarryMax | ACPowerSwitchingMax | ACVoltageMax | Bandwidth | DCCurrentCarryMax | DCCurrentSwitchingMax | DCPowerCarryMax | DCPowerSwitchingMax | DCVoltageMax | Impedance | SettlingTime | WireMode | IIviSwtchCharacteristics Overview


DCPowerSwitchingMax Property

IIviSwtchCharacteristics.DCPowerSwitchingMax Property

The maximum DC power the channel can switch, in watts.

[Visual Basic]
Property Get DCPowerSwitchingMax() As Double
[C++]
HRESULT get_DCPowerSwitchingMax(double* value);
[ANSI C]
HRESULT IIviSwtchCharacteristics_get_DCPowerSwitchingMax(IIviSwtchCharacteristics* This, double* value);
[C#]
public double DCPowerSwitchingMax {get;}

Capability Group

IviSwtchBase

Also In This Interface

ACCurrentCarryMax | ACCurrentSwitchingMax | ACPowerCarryMax | ACPowerSwitchingMax | ACVoltageMax | Bandwidth | DCCurrentCarryMax | DCCurrentSwitchingMax | DCPowerCarryMax | DCPowerSwitchingMax | DCVoltageMax | Impedance | SettlingTime | WireMode | IIviSwtchCharacteristics Overview


DCVoltageMax Property

IIviSwtchCharacteristics.DCVoltageMax Property

The maximum DC voltage the channel can handle, in volts.

[Visual Basic]
Property Get DCVoltageMax() As Double
[C++]
HRESULT get_DCVoltageMax(double* value);
[ANSI C]
HRESULT IIviSwtchCharacteristics_get_DCVoltageMax(IIviSwtchCharacteristics* This, double* value);
[C#]
public double DCVoltageMax {get;}

Capability Group

IviSwtchBase

Also In This Interface

ACCurrentCarryMax | ACCurrentSwitchingMax | ACPowerCarryMax | ACPowerSwitchingMax | ACVoltageMax | Bandwidth | DCCurrentCarryMax | DCCurrentSwitchingMax | DCPowerCarryMax | DCPowerSwitchingMax | DCVoltageMax | Impedance | SettlingTime | WireMode | IIviSwtchCharacteristics Overview


Impedance Property

IIviSwtchCharacteristics.Impedance Property

The characteristic impedance of the channel, in ohms.

[Visual Basic]
Property Get Impedance() As Double
[C++]
HRESULT get_Impedance(double* value);
[ANSI C]
HRESULT IIviSwtchCharacteristics_get_Impedance(IIviSwtchCharacteristics* This, double* value);
[C#]
public double Impedance {get;}

Capability Group

IviSwtchBase

Also In This Interface

ACCurrentCarryMax | ACCurrentSwitchingMax | ACPowerCarryMax | ACPowerSwitchingMax | ACVoltageMax | Bandwidth | DCCurrentCarryMax | DCCurrentSwitchingMax | DCPowerCarryMax | DCPowerSwitchingMax | DCVoltageMax | Impedance | SettlingTime | WireMode | IIviSwtchCharacteristics Overview


SettlingTime Property

IIviSwtchCharacteristics.SettlingTime Property

The maximum total settling time, in seconds, for the channel before the signal going through it is considered stable. This includes both the activation time for the channel as well as any debounce time.

[Visual Basic]
Property Get SettlingTime() As Double
[C++]
HRESULT get_SettlingTime(double* value);
[ANSI C]
HRESULT IIviSwtchCharacteristics_get_SettlingTime(IIviSwtchCharacteristics* This, double* value);
[C#]
public double SettlingTime {get;}

Capability Group

IviSwtchBase

Also In This Interface

ACCurrentCarryMax | ACCurrentSwitchingMax | ACPowerCarryMax | ACPowerSwitchingMax | ACVoltageMax | Bandwidth | DCCurrentCarryMax | DCCurrentSwitchingMax | DCPowerCarryMax | DCPowerSwitchingMax | DCVoltageMax | Impedance | SettlingTime | WireMode | IIviSwtchCharacteristics Overview


WireMode Property

IIviSwtchCharacteristics.WireMode Property

The number of conductors in the current channel.

[Visual Basic]
Property Get WireMode() As Long
[C++]
HRESULT get_WireMode(long* value);
[ANSI C]
HRESULT IIviSwtchCharacteristics_get_WireMode(IIviSwtchCharacteristics* This, long* value);
[C#]
public long WireMode {get;}

Capability Group

IviSwtchBase

Also In This Interface

ACCurrentCarryMax | ACCurrentSwitchingMax | ACPowerCarryMax | ACPowerSwitchingMax | ACVoltageMax | Bandwidth | DCCurrentCarryMax | DCCurrentSwitchingMax | DCPowerCarryMax | DCPowerSwitchingMax | DCVoltageMax | Impedance | SettlingTime | WireMode | IIviSwtchCharacteristics Overview


IIviSwtchPath Interface

IVI Swtch class-compliant path interface

Methods

CanConnect | Without actually creating the path, reports whether the switch module can create a given path. This method takes existing paths into account.
Connect | Creates a path between the two channels. If the path already exists, the operation does not count the number of calls. All paths are assumed to be bi-directional.
Disconnect | Destroys the path between the two channels. The order of the two channels need not be the same as the connect operation.
DisconnectAll | Disconnect all paths created since Initialize or Reset have been called. If any paths remain, this method returns a Path Remains warning.
GetPath | Returns the list of comma separated channel pairs that have been connected in order to create the path between the specified channels. The only valid paths that can be returned are ones that have been explicitly set via Connect and SetPath methods.
SetPath | Creates a path given a PathList of comma separated channel pairs. The end channels are the first and last entries in the PathList. For intermediate channels, the second channel of one pair must be the same as the first channel of the following pair.
WaitForDebounce | Wait until all the signals flowing through the switch have settled. If the signals do not settle within MaxTime, the method returns a Max Time Exceeded error.

Properties

IsDebounced If True, the switch module has settled from previous switching commands and completed debounce. This indicates that the signal going through the switch module is valid, assuming that the switches in the path have the correct characteristics.


IsDebounced Property

IIviSwtchPath.IsDebounced Property

If True, the switch module has settled from previous switching commands and completed debounce. This indicates that the signal going through the switch module is valid, assuming that the switches in the path have the correct characteristics.

[Visual Basic]
Property Get IsDebounced() As Boolean
[C++]
HRESULT get_IsDebounced(VARIANT_BOOL* value);
[ANSI C]
HRESULT IIviSwtchPath_get_IsDebounced(IIviSwtchPath* This, VARIANT_BOOL* value);
[C#]
public bool IsDebounced {get;}

Capability Group

IviSwtchBase

Related Items

WaitForDebounce

Also In This Interface

IsDebounced | CanConnect | Connect | Disconnect | DisconnectAll | GetPath | SetPath | WaitForDebounce | IIviSwtchPath Overview


CanConnect Method

IIviSwtchPath.CanConnect Method

Without actually creating the path, reports whether the switch module can create a given path. This method takes existing paths into account.

[Visual Basic]
Function CanConnect( _
   Channel1 As String, _
   Channel2 As String _
) As IviSwtchPathCapabilityEnum
[C++]
HRESULT CanConnect(
   BSTR Channel1,
   BSTR Channel2,
   IviSwtchPathCapabilityEnum* PathCapability
);
[ANSI C]
HRESULT IIviSwtchPath_CanConnect(
   IIviSwtchPath* This
   BSTR Channel1,
   BSTR Channel2,
   IviSwtchPathCapabilityEnum* PathCapability
);
[C#]
public IviSwtchPathCapabilityEnum CanConnect(
   string Channel1,
   string Channel2
);

Parameters

Channel1
A string indicating one of the channels of the path.
Channel2
A string indicating one of the channels of the path.
PathCapability
Indicates whether a path is valid and/or possible. See below for definitions.

Capability Group

IviSwtchBase

Also In This Interface

IsDebounced | CanConnect | Connect | Disconnect | DisconnectAll | GetPath | SetPath | WaitForDebounce | IIviSwtchPath Overview


Connect Method

IIviSwtchPath.Connect Method

Creates a path between the two channels. If the path already exists, the operation does not count the number of calls. All paths are assumed to be bi-directional.

[Visual Basic]
Sub Connect( _
   Channel1 As String, _
   Channel2 As String _
)
[C++]
HRESULT Connect(
   BSTR Channel1,
   BSTR Channel2
);
[ANSI C]
HRESULT IIviSwtchPath_Connect(
   IIviSwtchPath* This
   BSTR Channel1,
   BSTR Channel2
);
[C#]
public void Connect(
   string Channel1,
   string Channel2
);

Parameters

Channel1
A string indicating one of the channels of the path.
Channel2
A string indicating one of the channels of the path.

Capability Group

IviSwtchBase

Also In This Interface

IsDebounced | CanConnect | Connect | Disconnect | DisconnectAll | GetPath | SetPath | WaitForDebounce | IIviSwtchPath Overview


Disconnect Method

IIviSwtchPath.Disconnect Method

Destroys the path between the two channels. The order of the two channels need not be the same as the connect operation.

[Visual Basic]
Sub Disconnect( _
   Channel1 As String, _
   Channel2 As String _
)
[C++]
HRESULT Disconnect(
   BSTR Channel1,
   BSTR Channel2
);
[ANSI C]
HRESULT IIviSwtchPath_Disconnect(
   IIviSwtchPath* This
   BSTR Channel1,
   BSTR Channel2
);
[C#]
public void Disconnect(
   string Channel1,
   string Channel2
);

Parameters

Channel1
A string indicating one of the channels of the path.
Channel2
A string indicating one of the channels of the path.

Capability Group

IviSwtchBase

Also In This Interface

IsDebounced | CanConnect | Connect | Disconnect | DisconnectAll | GetPath | SetPath | WaitForDebounce | IIviSwtchPath Overview


DisconnectAll Method

IIviSwtchPath.DisconnectAll Method

Disconnect all paths created since Initialize or Reset have been called. If any paths remain, this method returns a Path Remains warning.

[Visual Basic]
Sub DisconnectAll()
[C++]
HRESULT DisconnectAll();
[ANSI C]
HRESULT IIviSwtchPath_DisconnectAll(
   IIviSwtchPath* This);
[C#]
public void DisconnectAll();

Capability Group

IviSwtchBase

Also In This Interface

IsDebounced | CanConnect | Connect | Disconnect | DisconnectAll | GetPath | SetPath | WaitForDebounce | IIviSwtchPath Overview


GetPath Method

IIviSwtchPath.GetPath Method

Returns the list of comma separated channel pairs that have been connected in order to create the path between the specified channels. The only valid paths that can be returned are ones that have been explicitly set via Connect and SetPath methods.

[Visual Basic]
Function GetPath( _
   Channel1 As String, _
   Channel2 As String _
) As String
[C++]
HRESULT GetPath(
   BSTR Channel1,
   BSTR Channel2,
   BSTR* PathList
);
[ANSI C]
HRESULT IIviSwtchPath_GetPath(
   IIviSwtchPath* This
   BSTR Channel1,
   BSTR Channel2,
   BSTR* PathList
);
[C#]
public string GetPath(
   string Channel1,
   string Channel2
);

Parameters

Channel1
A string indicating one of the channels of the path.
Channel2
A string indicating one of the channels of the path.
PathList
A user-allocated (for IVI-C) or driver-allocated (for IVI-COM) buffer into which the driver stores the list of configuration channels used to create a path between the two channels.

The caller may pass VI_NULL for this parameter if the PathListBufferSize parameter is 0.

Capability Group

IviSwtchBase

Also In This Interface

IsDebounced | CanConnect | Connect | Disconnect | DisconnectAll | GetPath | SetPath | WaitForDebounce | IIviSwtchPath Overview


SetPath Method

IIviSwtchPath.SetPath Method

Creates a path given a PathList of comma separated channel pairs. The end channels are the first and last entries in the PathList. For intermediate channels, the second channel of one pair must be the same as the first channel of the following pair.

[Visual Basic]
Sub SetPath( _
   PathList As String _
)
[C++]
HRESULT SetPath(
   BSTR PathList
);
[ANSI C]
HRESULT IIviSwtchPath_SetPath(
   IIviSwtchPath* This
   BSTR PathList
);
[C#]
public void SetPath(
   string PathList
);

Parameters

PathList
List of comma separated channel pairs indicating the path.

Capability Group

IviSwtchBase

Also In This Interface

IsDebounced | CanConnect | Connect | Disconnect | DisconnectAll | GetPath | SetPath | WaitForDebounce | IIviSwtchPath Overview


WaitForDebounce Method

IIviSwtchPath.WaitForDebounce Method

Wait until all the signals flowing through the switch have settled. If the signals do not settle within MaxTime, the method returns a Max Time Exceeded error.

[Visual Basic]
Sub WaitForDebounce( _
   MaxTimeMilliseconds As Long _
)
[C++]
HRESULT WaitForDebounce(
   long MaxTimeMilliseconds
);
[ANSI C]
HRESULT IIviSwtchPath_WaitForDebounce(
   IIviSwtchPath* This
   long MaxTimeMilliseconds
);
[C#]
public void WaitForDebounce(
   long MaxTimeMilliseconds
);

Parameters

MaxTimeMilliseconds
Maximum time (in milliseconds).

Capability Group

IviSwtchBase

Related Items

IsDebounced

Also In This Interface

IsDebounced | CanConnect | Connect | Disconnect | DisconnectAll | GetPath | SetPath | WaitForDebounce | IIviSwtchPath Overview


IIviSwtchScan Interface

IVI Swtch class-compliant scan interface

Methods

ConfigureList | Configures the scan List and Mode properties.
ConfigureTrigger | Configures the scan Delay, Input trigger, and AdvancedOutput trigger properties, in order to set the trigger behavior for the scan list established with the ConfigureList method.
Initiate | Initiates the scan based on the current List property, and returns once the scan has begun. To stop scanning, call Abort. When the switch is scanning, operations other than reading properties, SendSoftwareTrigger and Abort are invalid.
Abort | Stops the scan begun with Initiate method and returns the switch to the Idle state. This operation does not reset or initialize the state of the switch. To determine the status of the scan, call the IsScanning method.
SendSoftwareTrigger | Sends a software trigger, which causes the switch to advance to the next entry in the scan List.
WaitForScanComplete | Waits, up to MaxTime milliseconds, for the instrument to stop scanning through the scan List.

Properties

IsScanning | If True, the switch module is currently scanning through the scan list.
Continuous | If True, the switch module should scan continuously through the scan list, otherwise it should only scan once through the scan list.
NumberOfColumns | The maximum number of channels on the column of a matrix or scanner. If the switch module is a scanner, this value is the number of input channels. The number returned is dependent on the WireMode property.
NumberOfRows | The maximum number of channels on the row of a matrix or scanner. If the switch module is a scanner, this value is the number of output channels (commons). The number returned is dependent on the WireMode property.
AdvancedOutput | The destination of the scan's advanced output trigger. This trigger is asserted each time a path is created.
Delay | The minimum length of time, in milliseconds, from creating the path to asserting the scan's advanced output trigger. The actual time may be longer.
Input | The source of the trigger input. Input triggers tell the switch module to advance to the next entry in the scan list and close the specified channel.
List | A list of the channels to scan, and the order to scan them in. The format of this string is described in the IviSwtch specification.
Mode | The connection breaking behavior of the switch during a scan. Previous paths may be broken before making new ones, after making new ones, or not broken at all.


IsScanning Property

IIviSwtchScan.IsScanning Property

If True, the switch module is currently scanning through the scan list.

[Visual Basic]
Property Get IsScanning() As Boolean
[C++]
HRESULT get_IsScanning(VARIANT_BOOL* value);
[ANSI C]
HRESULT IIviSwtchScan_get_IsScanning(IIviSwtchScan* This, VARIANT_BOOL* value);
[C#]
public bool IsScanning {get;}

Capability Group

IviSwtchScanner

Also In This Interface

IsScanning | Continuous | NumberOfColumns | NumberOfRows | AdvancedOutput | Delay | Input | List | Mode | ConfigureList | ConfigureTrigger | Initiate | Abort | SendSoftwareTrigger | WaitForScanComplete | IIviSwtchScan Overview


Continuous Property

IIviSwtchScan.Continuous Property

If True, the switch module should scan continuously through the scan list, otherwise it should only scan once through the scan list.

[Visual Basic]
Property Get Continuous() As Boolean
Property Let Continuous(value As Boolean)
[C++]
HRESULT get_Continuous(VARIANT_BOOL* value);
HRESULT put_Continuous(VARIANT_BOOL value);
[ANSI C]
HRESULT IIviSwtchScan_get_Continuous(IIviSwtchScan* This, VARIANT_BOOL* value);
HRESULT IIviSwtchScan_put_Continuous(IIviSwtchScan* This, VARIANT_BOOL value);
[C#]
public bool Continuous {get; set;}

Capability Group

IviSwtchScanner

Also In This Interface

IsScanning | Continuous | NumberOfColumns | NumberOfRows | AdvancedOutput | Delay | Input | List | Mode | ConfigureList | ConfigureTrigger | Initiate | Abort | SendSoftwareTrigger | WaitForScanComplete | IIviSwtchScan Overview


NumberOfColumns Property

IIviSwtchScan.NumberOfColumns Property

The maximum number of channels on the column of a matrix or scanner. If the switch module is a scanner, this value is the number of input channels. The number returned is dependent on the WireMode property.

[Visual Basic]
Property Get NumberOfColumns() As Long
[C++]
HRESULT get_NumberOfColumns(long* value);
[ANSI C]
HRESULT IIviSwtchScan_get_NumberOfColumns(IIviSwtchScan* This, long* value);
[C#]
public long NumberOfColumns {get;}

Capability Group

IviSwtchScanner

Also In This Interface

IsScanning | Continuous | NumberOfColumns | NumberOfRows | AdvancedOutput | Delay | Input | List | Mode | ConfigureList | ConfigureTrigger | Initiate | Abort | SendSoftwareTrigger | WaitForScanComplete | IIviSwtchScan Overview


NumberOfRows Property

IIviSwtchScan.NumberOfRows Property

The maximum number of channels on the row of a matrix or scanner. If the switch module is a scanner, this value is the number of output channels (commons). The number returned is dependent on the WireMode property.

[Visual Basic]
Property Get NumberOfRows() As Long
[C++]
HRESULT get_NumberOfRows(long* value);
[ANSI C]
HRESULT IIviSwtchScan_get_NumberOfRows(IIviSwtchScan* This, long* value);
[C#]
public long NumberOfRows {get;}

Capability Group

IviSwtchScanner

Also In This Interface

IsScanning | Continuous | NumberOfColumns | NumberOfRows | AdvancedOutput | Delay | Input | List | Mode | ConfigureList | ConfigureTrigger | Initiate | Abort | SendSoftwareTrigger | WaitForScanComplete | IIviSwtchScan Overview


AdvancedOutput Property

IIviSwtchScan.AdvancedOutput Property

The destination of the scan's advanced output trigger. This trigger is asserted each time a path is created.

[Visual Basic]
Property Get AdvancedOutput() As IviSwtchAdvancedOutputEnum
Property Let AdvancedOutput(value As IviSwtchAdvancedOutputEnum)
[C++]
HRESULT get_AdvancedOutput(IviSwtchAdvancedOutputEnum* value);
HRESULT put_AdvancedOutput(IviSwtchAdvancedOutputEnum value);
[ANSI C]
HRESULT IIviSwtchScan_get_AdvancedOutput(IIviSwtchScan* This, IviSwtchAdvancedOutputEnum* value);
HRESULT IIviSwtchScan_put_AdvancedOutput(IIviSwtchScan* This, IviSwtchAdvancedOutputEnum value);
[C#]
public IviSwtchAdvancedOutputEnum AdvancedOutput {get; set;}

Capability Group

IviSwtchScanner

Also In This Interface

IsScanning | Continuous | NumberOfColumns | NumberOfRows | AdvancedOutput | Delay | Input | List | Mode | ConfigureList | ConfigureTrigger | Initiate | Abort | SendSoftwareTrigger | WaitForScanComplete | IIviSwtchScan Overview


Delay Property

IIviSwtchScan.Delay Property

The minimum length of time, in milliseconds, from creating the path to asserting the scan's advanced output trigger. The actual time may be longer.

[Visual Basic]
Property Get Delay() As Double
Property Let Delay(value As Double)
[C++]
HRESULT get_Delay(double* value);
HRESULT put_Delay(double value);
[ANSI C]
HRESULT IIviSwtchScan_get_Delay(IIviSwtchScan* This, double* value);
HRESULT IIviSwtchScan_put_Delay(IIviSwtchScan* This, double value);
[C#]
public double Delay {get; set;}

Capability Group

IviSwtchScanner

Also In This Interface

IsScanning | Continuous | NumberOfColumns | NumberOfRows | AdvancedOutput | Delay | Input | List | Mode | ConfigureList | ConfigureTrigger | Initiate | Abort | SendSoftwareTrigger | WaitForScanComplete | IIviSwtchScan Overview


Input Property

IIviSwtchScan.Input Property

The source of the trigger input. Input triggers tell the switch module to advance to the next entry in the scan list and close the specified channel.

[Visual Basic]
Property Get Input() As IviSwtchTriggerInputEnum
Property Let Input(value As IviSwtchTriggerInputEnum)
[C++]
HRESULT get_Input(IviSwtchTriggerInputEnum* value);
HRESULT put_Input(IviSwtchTriggerInputEnum value);
[ANSI C]
HRESULT IIviSwtchScan_get_Input(IIviSwtchScan* This, IviSwtchTriggerInputEnum* value);
HRESULT IIviSwtchScan_put_Input(IIviSwtchScan* This, IviSwtchTriggerInputEnum value);
[C#]
public IviSwtchTriggerInputEnum Input {get; set;}

Capability Group

IviSwtchScanner

Also In This Interface

IsScanning | Continuous | NumberOfColumns | NumberOfRows | AdvancedOutput | Delay | Input | List | Mode | ConfigureList | ConfigureTrigger | Initiate | Abort | SendSoftwareTrigger | WaitForScanComplete | IIviSwtchScan Overview


List Property

IIviSwtchScan.List Property

A list of the channels to scan, and the order to scan them in. The format of this string is described in the IviSwtch specification.

[Visual Basic]
Property Get List() As String
Property Let List(value As String)
[C++]
HRESULT get_List(BSTR* value);
HRESULT put_List(BSTR value);
[ANSI C]
HRESULT IIviSwtchScan_get_List(IIviSwtchScan* This, BSTR* value);
HRESULT IIviSwtchScan_put_List(IIviSwtchScan* This, BSTR value);
[C#]
public string List {get; set;}

Capability Group

IviSwtchScanner

Also In This Interface

IsScanning | Continuous | NumberOfColumns | NumberOfRows | AdvancedOutput | Delay | Input | List | Mode | ConfigureList | ConfigureTrigger | Initiate | Abort | SendSoftwareTrigger | WaitForScanComplete | IIviSwtchScan Overview


Mode Property

IIviSwtchScan.Mode Property

The connection breaking behavior of the switch during a scan. Previous paths may be broken before making new ones, after making new ones, or not broken at all.

[Visual Basic]
Property Get Mode() As IviSwtchScanModeEnum
Property Let Mode(value As IviSwtchScanModeEnum)
[C++]
HRESULT get_Mode(IviSwtchScanModeEnum* value);
HRESULT put_Mode(IviSwtchScanModeEnum value);
[ANSI C]
HRESULT IIviSwtchScan_get_Mode(IIviSwtchScan* This, IviSwtchScanModeEnum* value);
HRESULT IIviSwtchScan_put_Mode(IIviSwtchScan* This, IviSwtchScanModeEnum value);
[C#]
public IviSwtchScanModeEnum Mode {get; set;}

Capability Group

IviSwtchScanner

Also In This Interface

IsScanning | Continuous | NumberOfColumns | NumberOfRows | AdvancedOutput | Delay | Input | List | Mode | ConfigureList | ConfigureTrigger | Initiate | Abort | SendSoftwareTrigger | WaitForScanComplete | IIviSwtchScan Overview


ConfigureList Method

IIviSwtchScan.ConfigureList Method

Configures the scan List and Mode properties.

[Visual Basic]
Sub ConfigureList( _
   List As String, _
   Mode As IviSwtchScanModeEnum _
)
[C++]
HRESULT ConfigureList(
   BSTR List,
   IviSwtchScanModeEnum Mode
);
[ANSI C]
HRESULT IIviSwtchScan_ConfigureList(
   IIviSwtchScan* This
   BSTR List,
   IviSwtchScanModeEnum Mode
);
[C#]
public void ConfigureList(
   string List,
   IviSwtchScanModeEnum Mode
);

Parameters

List
Scan list string. The driver uses this value to set the Scan List attribute. See the attribute description for more details.
Mode
Scanning mode. The driver uses this value to set the Scan Mode attribute. See the attribute description for more details.

Capability Group

IviSwtchScanner

Also In This Interface

IsScanning | Continuous | NumberOfColumns | NumberOfRows | AdvancedOutput | Delay | Input | List | Mode | ConfigureList | ConfigureTrigger | Initiate | Abort | SendSoftwareTrigger | WaitForScanComplete | IIviSwtchScan Overview


ConfigureTrigger Method

IIviSwtchScan.ConfigureTrigger Method

Configures the scan Delay, Input trigger, and AdvancedOutput trigger properties, in order to set the trigger behavior for the scan list established with the ConfigureList method.

[Visual Basic]
Sub ConfigureTrigger( _
   ScanDelay As Double, _
   TriggerInput As IviSwtchTriggerInputEnum, _
   AdvancedOutput As IviSwtchAdvancedOutputEnum _
)
[C++]
HRESULT ConfigureTrigger(
   double ScanDelay,
   IviSwtchTriggerInputEnum TriggerInput,
   IviSwtchAdvancedOutputEnum AdvancedOutput
);
[ANSI C]
HRESULT IIviSwtchScan_ConfigureTrigger(
   IIviSwtchScan* This
   double ScanDelay,
   IviSwtchTriggerInputEnum TriggerInput,
   IviSwtchAdvancedOutputEnum AdvancedOutput
);
[C#]
public void ConfigureTrigger(
   double ScanDelay,
   IviSwtchTriggerInputEnum TriggerInput,
   IviSwtchAdvancedOutputEnum AdvancedOutput
);

Parameters

ScanDelay
The minimum length of time you want the instrument to wait from the time the instrument creates a path until it asserts a trigger on the Scan Advanced output line (in seconds). The driver uses this value to set the Scan Delay attribute. See the attribute description for more details.
TriggerInput
Trigger input. The driver uses this value to set the Trigger Input attribute. See the attribute description for more details.
AdvancedOutput
Scan advanced output. The driver uses this value to set the Scan Advanced Output attribute. See the attribute description for more details.

Capability Group

IviSwtchScanner

Also In This Interface

IsScanning | Continuous | NumberOfColumns | NumberOfRows | AdvancedOutput | Delay | Input | List | Mode | ConfigureList | ConfigureTrigger | Initiate | Abort | SendSoftwareTrigger | WaitForScanComplete | IIviSwtchScan Overview


Initiate Method

IIviSwtchScan.Initiate Method

Initiates the scan based on the current List property, and returns once the scan has begun. To stop scanning, call Abort. When the switch is scanning, operations other than reading properties, SendSoftwareTrigger and Abort are invalid.

[Visual Basic]
Sub Initiate()
[C++]
HRESULT Initiate();
[ANSI C]
HRESULT IIviSwtchScan_Initiate(
   IIviSwtchScan* This);
[C#]
public void Initiate();

Capability Group

IviSwtchScanner

Also In This Interface

IsScanning | Continuous | NumberOfColumns | NumberOfRows | AdvancedOutput | Delay | Input | List | Mode | ConfigureList | ConfigureTrigger | Initiate | Abort | SendSoftwareTrigger | WaitForScanComplete | IIviSwtchScan Overview


Abort Method

IIviSwtchScan.Abort Method

Stops the scan begun with Initiate method and returns the switch to the Idle state. This operation does not reset or initialize the state of the switch. To determine the status of the scan, call the IsScanning method.

[Visual Basic]
Sub Abort()
[C++]
HRESULT Abort();
[ANSI C]
HRESULT IIviSwtchScan_Abort(
   IIviSwtchScan* This);
[C#]
public void Abort();

Capability Group

IviSwtchScanner

Also In This Interface

IsScanning | Continuous | NumberOfColumns | NumberOfRows | AdvancedOutput | Delay | Input | List | Mode | ConfigureList | ConfigureTrigger | Initiate | Abort | SendSoftwareTrigger | WaitForScanComplete | IIviSwtchScan Overview


SendSoftwareTrigger Method

IIviSwtchScan.SendSoftwareTrigger Method

Sends a software trigger, which causes the switch to advance to the next entry in the scan List.

[Visual Basic]
Sub SendSoftwareTrigger()
[C++]
HRESULT SendSoftwareTrigger();
[ANSI C]
HRESULT IIviSwtchScan_SendSoftwareTrigger(
   IIviSwtchScan* This);
[C#]
public void SendSoftwareTrigger();

Capability Group

IviSwtchSoftwareTrigger

Also In This Interface

IsScanning | Continuous | NumberOfColumns | NumberOfRows | AdvancedOutput | Delay | Input | List | Mode | ConfigureList | ConfigureTrigger | Initiate | Abort | SendSoftwareTrigger | WaitForScanComplete | IIviSwtchScan Overview


WaitForScanComplete Method

IIviSwtchScan.WaitForScanComplete Method

Waits, up to MaxTime milliseconds, for the instrument to stop scanning through the scan List.

[Visual Basic]
Sub WaitForScanComplete( _
   MaxTimeMilliseconds As Long _
)
[C++]
HRESULT WaitForScanComplete(
   long MaxTimeMilliseconds
);
[ANSI C]
HRESULT IIviSwtchScan_WaitForScanComplete(
   IIviSwtchScan* This
   long MaxTimeMilliseconds
);
[C#]
public void WaitForScanComplete(
   long MaxTimeMilliseconds
);

Parameters

MaxTimeMilliseconds
Maximum time (milliseconds)

Capability Group

IviSwtchScanner

Also In This Interface

IsScanning | Continuous | NumberOfColumns | NumberOfRows | AdvancedOutput | Delay | Input | List | Mode | ConfigureList | ConfigureTrigger | Initiate | Abort | SendSoftwareTrigger | WaitForScanComplete | IIviSwtchScan Overview


IviSwtchAdvancedOutputEnum Enumeration

IVI Swtch class-compliant values for scan Advanced Output

Members

Member Name | Description
IviSwtchAdvancedOutputNone | No scan advanced output trigger is sent out of the switch module.
IviSwtchAdvancedOutputExternal | Means the trigger is going out to an external device through a trigger output connection.
IviSwtchAdvancedOutputGPIBSRQ | The scan advanced output trigger is represented as a GPIB SRQ event.
IviSwtchAdvancedOutputTTL0 | The switch asserts TTL0 each time a path is created.
IviSwtchAdvancedOutputTTL1 | The switch asserts TTL1 each time a path is created.
IviSwtchAdvancedOutputTTL2 | The switch asserts TTL2 each time a path is created.
IviSwtchAdvancedOutputTTL3 | The switch asserts TTL3 each time a path is created.
IviSwtchAdvancedOutputTTL4 | The switch asserts TTL4 each time a path is created.
IviSwtchAdvancedOutputTTL5 | The switch asserts TTL5 each time a path is created.
IviSwtchAdvancedOutputTTL6 | The switch asserts TTL6 each time a path is created.
IviSwtchAdvancedOutputTTL7 | The switch asserts TTL7 each time a path is created.
IviSwtchAdvancedOutputECL0 | The switch asserts ECL0 each time a path is created.
IviSwtchAdvancedOutputECL1 | The switch asserts ECL1 each time a path is created.
IviSwtchAdvancedOutputPXIStar | The switch asserts PXI Star each time a path is created.
IviSwtchAdvancedOutputRTSI0 | The switch asserts RTSI0 each time a path is created.
IviSwtchAdvancedOutputRTSI1 | The switch asserts RTSI1 each time a path is created.
IviSwtchAdvancedOutputRTSI2 | The switch asserts RTSI2 each time a path is created.
IviSwtchAdvancedOutputRTSI3 | The switch asserts RTSI3 each time a path is created.
IviSwtchAdvancedOutputRTSI4 | The switch asserts RTSI4 each time a path is created.
IviSwtchAdvancedOutputRTSI5 | The switch asserts RTSI5 each time a path is created.
IviSwtchAdvancedOutputRTSI6 | The switch asserts RTSI6 each time a path is created.


IviSwtchErrorCodesEnum Enumeration

IVI Swtch class defined HRESULTS

Members

Member Name | Description
E_IVISWTCH_TRIGGER_NOT_SOFTWARE | The trigger source is not set to software trigger.
E_IVISWTCH_INVALID_SWITCH_PATH | Invalid path list string.
E_IVISWTCH_INVALID_SCAN_LIST | The given scan list string does not have the correct syntax.
E_IVISWTCH_RSRC_IN_USE | One of the channels in the path is a configuration channel that is in use.
E_IVISWTCH_EMPTY_SCAN_LIST | No scan list specified.
E_IVISWTCH_EMPTY_SWITCH_PATH | The specified path list string is empty.
E_IVISWTCH_SCAN_IN_PROGRESS | The switch module is currently scanning through the scan list.
E_IVISWTCH_NO_SCAN_IN_PROGRESS | The switch module is not currently scanning through the scan list.
E_IVISWTCH_NO_SUCH_PATH | No explicit path exists between the channels.
E_IVISWTCH_IS_CONFIGURATION_CHANNEL | An explicit connection to a configuration channel is not allowed.
E_IVISWTCH_NOT_A_CONFIGURATION_CHANNEL | One of the non-terminal channels in the path is not a configuration channel.
E_IVISWTCH_ATTEMPT_TO_CONNECT_SOURCES | A connection between two different sources is not allowed.
E_IVISWTCH_EXPLICIT_CONNECTION_EXISTS | An explicit connection between the channels already exists.
E_IVISWTCH_LEG_MISSING_FIRST_CHANNEL | A leg in the path does not begin with a channel name.
E_IVISWTCH_LEG_MISSING_SECOND_CHANNEL | A leg in the path is missing the second channel.
E_IVISWTCH_CHANNEL_DUPLICATED_IN_LEG | The first and the second channels in the leg are the same.
E_IVISWTCH_CHANNEL_DUPLICATED_IN_PATH | A channel name is duplicated in the path string.
E_IVISWTCH_PATH_NOT_FOUND | No path was found between the two channels.
E_IVISWTCH_DISCONTINUOUS_PATH | The first channel of a leg in the path is not the same as the second channel in the previous leg.
E_IVISWTCH_CANNOT_CONNECT_DIRECTLY | The path contains a leg with two channels that cannot be directly connected.
E_IVISWTCH_CHANNELS_ALREADY_CONNECTED | A leg in the path contains two channels that are already directly connected.
E_IVISWTCH_CANNOT_CONNECT_TO_ITSELF | A channel cannot be connected to itself.
E_IVISWTCH_MAX_TIME_EXCEEDED | Maximum time exceeded before the operation completed.
S_IVISWTCH_PATH_REMAINS | Some connections remain after disconnecting.
S_IVISWTCH_IMPLICIT_CONNECTION_EXISTS | The implicit connection exists between the channels.


IviSwtchPathCapabilityEnum Enumeration

IVI Swtch class-compliant values for PathCapability

Members

Member Name | Description
IviSwtchPathAvailable | The driver can create a path at this time.
IviSwtchPathExists | The explicit path between the channels already exists.
IviSwtchPathUnsupported | The instrument is not capable of creating a path between the two channels.The instrument is not capable of creating a path between the two channels.Although the path is valid, the driver cannot create the path at this moment because the switch module is currently using one or more of the required channels to create another path. You must destroy the other path before creating this one.
IviSwtchPathRsrcInUse | Although the path is valid, the driver cannot create the path at this moment because the switch module is currently using one or more of the required channels to create another path. You must destroy the other path before creating this one.
IviSwtchPathSourceConflict | The instrument cannot create a path between the two channels because both are connected to a different source channel.
IviSwtchPathChannelNotAvailable | The driver cannot create a path between the two channels because one of the channels is a configuration channel and thus unavailable for external connections.


IviSwtchScanModeEnum Enumeration

IVI Swtch class-compliant values for Scan Mode

Members

Member Name | Description
IviSwtchScanModeNone | Indicates that no action should be taken on the previous paths.
IviSwtchScanModeBreakBeforeMake | Tells the card to break the previous paths before making the new paths.
IviSwtchScanModeBreakAfterMake | Tells the driver to make new paths before breaking the previous paths.


IviSwtchTriggerInputEnum Enumeration

IVI Swtch class-compliant values for Trigger Input

Members

Member Name | Description
IviSwtchTriggerInputImmediate | Indicates that the switch module does not wait for a trigger before starting the next entry in the scan list. This is typically done for switch modules that support the Scan Delay attribute and can therefore have the switch module pace itself.
IviSwtchTriggerInputExternal | Means the trigger is coming from an external source through a trigger input connection.
IviSwtchTriggerInputSwTrigFunc | The switch exits the Wait-For-Trigger state when the Send Software Trigger function executes. Refer to the Standardized Cross Class Capabilities specification for a complete description of this value and the Send Software Trigger function
IviSwtchTriggerInputTTL0 | The switch exits the Wait-For-Trigger state when it receives a trigger on TTL0.
IviSwtchTriggerInputTTL1 | The switch exits the Wait-For-Trigger state when it receives a trigger on TTL1.
IviSwtchTriggerInputTTL2 | The switch exits the Wait-For-Trigger state when it receives a trigger on TTL2.
IviSwtchTriggerInputTTL3 | The switch exits the Wait-For-Trigger state when it receives a trigger on TTL3.
IviSwtchTriggerInputTTL4 | The switch exits the Wait-For-Trigger state when it receives a trigger on TTL4.
IviSwtchTriggerInputTTL5 | The switch exits the Wait-For-Trigger state when it receives a trigger on TTL5.
IviSwtchTriggerInputTTL6 | The switch exits the Wait-For-Trigger state when it receives a trigger on TTL6.
IviSwtchTriggerInputTTL7 | The switch exits the Wait-For-Trigger state when it receives a trigger on TTL7.
IviSwtchTriggerInputECL0 | The switch exits the Wait-For-Trigger state when it receives a trigger on ECL0.
IviSwtchTriggerInputECL1 | The switch exits the Wait-For-Trigger state when it receives a trigger on ECL1.
IviSwtchTriggerInputPXIStar | The switch exits the Wait-For-Trigger state when it receives a trigger on PXI Star trigger bus.
IviSwtchTriggerInputRTSI0 | The switch exits the Wait-For-Trigger state when it receives a trigger on RTSI0.
IviSwtchTriggerInputRTSI1 | The switch exits the Wait-For-Trigger state when it receives a trigger on RTSI1.
IviSwtchTriggerInputRTSI2 | The switch exits the Wait-For-Trigger state when it receives a trigger on RTSI2.
IviSwtchTriggerInputRTSI3 | The switch exits the Wait-For-Trigger state when it receives a trigger on RTSI3.
IviSwtchTriggerInputRTSI4 | The switch exits the Wait-For-Trigger state when it receives a trigger on RTSI4.
IviSwtchTriggerInputRTSI5 | The switch exits the Wait-For-Trigger state when it receives a trigger on RTSI5.
IviSwtchTriggerInputRTSI6 | The switch exits the Wait-For-Trigger state when it receives a trigger on RTSI6.


Topic Not Found

No matching topic was found. The link may be out of date, incorrectly authored, or the topic may not be available in this release.

You may be able to find the topic by using the index or search tab instead.


Inherent Interface

IVI Inherent Interfaces

IIviDriver | IVI Driver root interface
IIviDriverIdentity | IVI Driver identity interface
IIviDriverOperation | IVI Driver operation interface
IIviDriverUtility | IVI Driver utility interface


Instrument Specific Interfaces


IviDriver_ErrorCodes Enumeration

IVI Driver (inherent features) defined HRESULTS

Members

Member Name | Description
S_IVI_SUCCESS | Success
E_IVI_CANNOT_RECOVER | Unrecoverable failure
E_IVI_INSTRUMENT_STATUS | Instrument error detected
E_IVI_CANNOT_OPEN_FILE | File could not be opened
E_IVI_READING_FILE | File could not be read
E_IVI_WRITING_FILE | File could not be written
E_IVI_INVALID_PATHNAME | The path name is invalid
E_IVI_INVALID_VALUE | Invalid value for parameter or property
E_IVI_METHOD_NOT_SUPPORTED | Method not supported
E_IVI_PROPERTY_NOT_SUPPORTED | Property not supported
E_IVI_VALUE_NOT_SUPPORTED | The enumeration value for the parameter is not supported
E_IVI_NOT_INITIALIZED | A connection to the instrument has not been initialized
E_IVI_UNKNOWN_CHANNEL_NAME | Channel or repeated capability name specified is not valid for the instrument.
E_IVI_TOO_MANY_OPEN_FILES | Too many files opened
E_IVI_CHANNEL_NAME_REQUIRED | Channel or repeated capability name required
E_IVI_MISSING_OPTION_NAME | The option string contains an entry without a name.
E_IVI_MISSING_OPTION_VALUE | The option string contains an entry without a value.
E_IVI_BAD_OPTION_NAME | The option string contains an entry with an unknown option name.
E_IVI_BAD_OPTION_VALUE | The option string contains an entry with an unknown option value.
E_IVI_OUT_OF_MEMORY | The necessary memory could not be allocated
E_IVI_OPERATION_PENDING | Operation in progress
E_IVI_NULL_POINTER | Null pointer passed for parameter or property
E_IVI_UNEXPECTED_RESPONSE | Unexpected response from the instrument
E_IVI_FILE_NOT_FOUND | File not found
E_IVI_INVALID_FILE_FORMAT | The file format is invalid
E_IVI_STATUS_NOT_AVAILABLE | The instrument status is not available
E_IVI_ID_QUERY_FAILED | Instrument ID query failed
E_IVI_RESET_FAILED | Instrument reset failed
E_IVI_RESOURCE_UNKNOWN | Insufficient location information or resource not present in the system.
E_IVI_ALREADY_INITIALIZED | The driver is already initialized
E_IVI_CANNOT_CHANGE_SIMULATION_STATE | The simulation state cannot be changed.
S_IVI_NSUP_ID_QUERY | Identification query not supported
S_IVI_NSUP_RESET | Reset operation not supported
S_IVI_NSUP_SELF_TEST | Self test operation not supported
S_IVI_NSUP_ERROR_QUERY | Error query operation not supported
S_IVI_NSUP_REV_QUERY | Revision query not supported


IIviDriver Interface

IVI Driver root interface

Methods

Initialize | Opens the I/O session to the instrument. Driver methods and properties that access the instrument are only accessible after Initialize is called. Initialize optionally performs a Reset and queries the instrument to validate the instrument model.
Close | Closes the I/O session to the instrument. Driver methods and properties that access the instrument are not accessible after Close is called.

Properties

DriverOperation | Pointer to the IIviDriverOperation interface
Identity | Pointer to the IIviDriverIdentity interface
Utility | Pointer to the IIviDriverUtility interface
Initialized | Initialized is True between a successful call to the Initialize method and a successful call to the Close method, and False at all other times.


IIviDriverIdentity Interface

IVI Driver identity interface

Properties

Description | A brief description of the implementing component. Description is limted to 256 bytes.
Revision | The revision of the implementing component. Refer to IVI 3.1, Section 3.1.2.2, for a description of revision syntax and semantics. Revision is limited to 256 bytes.
Vendor | The name of the vendor that supplies the implementing component. Vendor is limited to 256 bytes.
InstrumentManufacturer | The name of the manufacturer reported by the physical instrument. If Simulation is enabled or the instrument is not capable of reporting the name of the manufacturer, a string is returned that explains the condition. Manufacturer is limited to 256 bytes
InstrumentModel | The model number or name reported by the physical instrument. If Simulation is enabled or the instrument is not capable of reporting the model number or name, a string is returned that explains the condition. Model is limited to 256 bytes
InstrumentFirmwareRevision | The firmware revision reported by the physical instrument. If Simulation is enabled or the instrument is not capable of reporting the firmware revision, a string is returned that explains the condition.
Identifier | The case-sensitive unique identifier of the implementing IVI-COM instrument driver.
SupportedInstrumentModels | A comma-separated list of instrument models that the IVI specific driver can control. The string does not include an abbreviation for the manufacturer if it is the same for all models.
SpecificationMajorVersion | For IVI class-compliant drivers, the major version number of the instrument class specification. If the driver is not class compliant, the driver returns zero.
SpecificationMinorVersion | For IVI class-compliant drivers, the minor version number of the instrument class specification. If the driver is not class compliant, the driver returns zero.
GroupCapabilities | A comma-separated list of the class capability groups implemented by the driver. Capability group names are documented in the IVI class specifications. If the driver is not class compliant, the driver returns an empty string.


IIviDriverOperation Interface

IVI Driver operation interface

Methods

InvalidateAllAttributes | Invalidates all of the driver's cached values.
ClearInterchangeWarnings | Clears the list of interchangeability warnings that the IVI specific driver maintains.
GetNextInterchangeWarning | Returns the oldest warning from the interchange warning list. Records are only added to the list if InterchangeCheck is True.
ResetInterchangeCheck | Resets the interchangeability checking algorithms of the driver so that methods and properties that executed prior to calling this function have no affect on whether future calls to the driver generate interchangeability warnings.
GetNextCoercionRecord | Returns the oldest record from the coercion record list. Records are only added to the list if RecordCoercions is True.

Properties

LogicalName | Logical Name identifies a driver session in the Configuration Store. If Logical Name is not empty, the driver was initialized from information in the driver session. If it is empty, the driver was initialized without using the Configuration Store.
IoResourceDescriptor | The resource descriptor specifies the connection to a physical device. It is either specified in the Configuration Store or passed in the ResourceName parameter of the Initialize function. It is empty if the driver is not initialized.
Cache | Drivers may choose to always cache some instrument settings, never cache others, and optionally cache others, to avoid unecessary I/O to the instrument. If True, the driver caches optionally cached instrument settings.
InterchangeCheck | If True, the driver maintains a record of interchangeability warnings. If the driver does not support interchangeability checking, attempts to set InterchangeCheck to True return an error.
QueryInstrumentStatus | If True, the driver queries the instrument status at the end of each method or property that performs I/O to the instrument. If an error is reported, use ErrorQuery to retrieve error messages one at a time from the instrument.
RangeCheck | Drivers may choose to always validate some property/parameter values, never validate others, and optionally validate others, to avoid sending invalid commands to the instrument. If True, the driver performs optional validations.
RecordCoercions | If True, the driver keeps a list of the value coercions it makes for ViInt32 and ViReal64 attributes. If the driver does not support coercion recording, attempts to set RecordCoercions to True will return an error.
Simulate | If True, the driver does not perform I/O to the instrument, and returns simulated values for output parameters.
DriverSetup | The driver setup string. It is either specified in the Configuration Store or passed in the OptionString parameter of the Initialize function. Driver setup is empty if the driver is not initialized.


IIviDriverUtility Interface

IVI Driver utility interface

Methods

Reset | Places the instrument in a known state and configures instrument options on which the IVI specific driver depends (for example, enabling/disabling headers). For an IEEE 488.2 instrument, Reset sends the command string *RST to the instrument.
ResetWithDefaults | Does the equivalent of Reset and then, (1) disables class extension capability groups, (2) sets attributes to initial values defined by class specs, and (3) configures the driver to option string settings used when Initialize was last executed.
Disable | Quickly places the instrument in a state where it has no, or minimal, effect on the external system to which it is connected. This state is not necessarily a known state.
SelfTest | Performs an instrument self test, waits for the instrument to complete the test, and queries the instrument for the results. If the instrument passes the test, TestResult is zero and TestMessage is 'Self test passed'.
ErrorQuery | Queries the instrument and returns instrument specific error information. This function can be used when QueryInstrumentStatus is True to retrieve error details when the driver detects an instrument error.
LockObject | Obtains a multithread lock on the driver after waiting until all other execution threads have released their locks on the instrument session.
UnlockObject | Releases a previously obtained mutlithread lock.


Close Method

IIviDriver.Close Method

Closes the I/O session to the instrument. Driver methods and properties that access the instrument are not accessible after Close is called.

[Visual Basic]
Sub Close()
[C++]
HRESULT Close();
[ANSI C]
HRESULT IIviDriver_Close(
   IIviDriver* This);
[C#]
public void Close();

Related Items

Initialize

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Initialize | Close | IIviDriver Overview


DriverOperation Property

IIviDriver.DriverOperation Property

Pointer to the IIviDriverOperation interface

[Visual Basic]
Property Get DriverOperation() As IIviDriverOperation
[C++]
HRESULT get_DriverOperation(IIviDriverOperation** value);
[ANSI C]
HRESULT IIviDriver_get_DriverOperation(IIviDriver* This, IIviDriverOperation** value);
[C#]
public IIviDriverOperation DriverOperation {get;}

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Initialize | Close | IIviDriver Overview


Identity Property

IIviDriver.Identity Property

Pointer to the IIviDriverIdentity interface

[Visual Basic]
Property Get Identity() As IIviDriverIdentity
[C++]
HRESULT get_Identity(IIviDriverIdentity** value);
[ANSI C]
HRESULT IIviDriver_get_Identity(IIviDriver* This, IIviDriverIdentity** value);
[C#]
public IIviDriverIdentity Identity {get;}

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Initialize | Close | IIviDriver Overview


Initialize Method

IIviDriver.Initialize Method

Opens the I/O session to the instrument. Driver methods and properties that access the instrument are only accessible after Initialize is called. Initialize optionally performs a Reset and queries the instrument to validate the instrument model.

[Visual Basic]
Sub Initialize( _
   ResourceName As String, _
   IdQuery As Boolean, _
   Reset As Boolean, _
   OptionString As String _
)
[C++]
HRESULT Initialize(
   BSTR ResourceName,
   VARIANT_BOOL IdQuery,
   VARIANT_BOOL Reset,
   BSTR OptionString
);
[ANSI C]
HRESULT IIviDriver_Initialize(
   IIviDriver* This
   BSTR ResourceName,
   VARIANT_BOOL IdQuery,
   VARIANT_BOOL Reset,
   BSTR OptionString
);
[C#]
public void Initialize(
   string ResourceName,
   bool IdQuery,
   bool Reset,
   string OptionString
);

Parameters

ResourceName
An IVI logical name or an instrument specific string that identifies the address of the instrument, such as a VISA resource descriptor string.
IdQuery
Specifies whether to verify the ID of the instrument.
Reset
Specifies whether to reset the instrument.
OptionString
The user can use the OptionsString parameter to specify the initial values of certain IVI inherent attributes for the session.

Related Items

Close

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Initialize | Close | IIviDriver Overview


Initialized Property

IIviDriver.Initialized Property

Initialized is True between a successful call to the Initialize method and a successful call to the Close method, and False at all other times.

[Visual Basic]
Property Get Initialized() As Boolean
[C++]
HRESULT get_Initialized(VARIANT_BOOL* value);
[ANSI C]
HRESULT IIviDriver_get_Initialized(IIviDriver* This, VARIANT_BOOL* value);
[C#]
public bool Initialized {get;}

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Initialize | Close | IIviDriver Overview


Utility Property

IIviDriver.Utility Property

Pointer to the IIviDriverUtility interface

[Visual Basic]
Property Get Utility() As IIviDriverUtility
[C++]
HRESULT get_Utility(IIviDriverUtility** value);
[ANSI C]
HRESULT IIviDriver_get_Utility(IIviDriver* This, IIviDriverUtility** value);
[C#]
public IIviDriverUtility Utility {get;}

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Initialize | Close | IIviDriver Overview


Description Property

IIviDriverIdentity.Description Property

A brief description of the implementing component. Description is limted to 256 bytes.

[Visual Basic]
Property Get Description() As String
[C++]
HRESULT get_Description(BSTR* value);
[ANSI C]
HRESULT IIviDriverIdentity_get_Description(IIviDriverIdentity* This, BSTR* value);
[C#]
public string Description {get;}

Also In This Interface

Description | Revision | Vendor | InstrumentManufacturer | InstrumentModel | InstrumentFirmwareRevision | Identifier | SupportedInstrumentModels | SpecificationMajorVersion | SpecificationMinorVersion | GroupCapabilities | IIviDriverIdentity Overview


GroupCapabilities Property

IIviDriverIdentity.GroupCapabilities Property

A comma-separated list of the class capability groups implemented by the driver. Capability group names are documented in the IVI class specifications. If the driver is not class compliant, the driver returns an empty string.

[Visual Basic]
Property Get GroupCapabilities() As String
[C++]
HRESULT get_GroupCapabilities(BSTR* value);
[ANSI C]
HRESULT IIviDriverIdentity_get_GroupCapabilities(IIviDriverIdentity* This, BSTR* value);
[C#]
public string GroupCapabilities {get;}

Also In This Interface

Description | Revision | Vendor | InstrumentManufacturer | InstrumentModel | InstrumentFirmwareRevision | Identifier | SupportedInstrumentModels | SpecificationMajorVersion | SpecificationMinorVersion | GroupCapabilities | IIviDriverIdentity Overview


Identifier Property

IIviDriverIdentity.Identifier Property

The case-sensitive unique identifier of the implementing IVI-COM instrument driver.

[Visual Basic]
Property Get Identifier() As String
[C++]
HRESULT get_Identifier(BSTR* value);
[ANSI C]
HRESULT IIviDriverIdentity_get_Identifier(IIviDriverIdentity* This, BSTR* value);
[C#]
public string Identifier {get;}

Also In This Interface

Description | Revision | Vendor | InstrumentManufacturer | InstrumentModel | InstrumentFirmwareRevision | Identifier | SupportedInstrumentModels | SpecificationMajorVersion | SpecificationMinorVersion | GroupCapabilities | IIviDriverIdentity Overview


InstrumentFirmwareRevision Property

IIviDriverIdentity.InstrumentFirmwareRevision Property

The firmware revision reported by the physical instrument. If Simulation is enabled or the instrument is not capable of reporting the firmware revision, a string is returned that explains the condition.

[Visual Basic]
Property Get InstrumentFirmwareRevision() As String
[C++]
HRESULT get_InstrumentFirmwareRevision(BSTR* value);
[ANSI C]
HRESULT IIviDriverIdentity_get_InstrumentFirmwareRevision(IIviDriverIdentity* This, BSTR* value);
[C#]
public string InstrumentFirmwareRevision {get;}

Also In This Interface

Description | Revision | Vendor | InstrumentManufacturer | InstrumentModel | InstrumentFirmwareRevision | Identifier | SupportedInstrumentModels | SpecificationMajorVersion | SpecificationMinorVersion | GroupCapabilities | IIviDriverIdentity Overview


InstrumentManufacturer Property

IIviDriverIdentity.InstrumentManufacturer Property

The name of the manufacturer reported by the physical instrument. If Simulation is enabled or the instrument is not capable of reporting the name of the manufacturer, a string is returned that explains the condition. Manufacturer is limited to 256 bytes

[Visual Basic]
Property Get InstrumentManufacturer() As String
[C++]
HRESULT get_InstrumentManufacturer(BSTR* value);
[ANSI C]
HRESULT IIviDriverIdentity_get_InstrumentManufacturer(IIviDriverIdentity* This, BSTR* value);
[C#]
public string InstrumentManufacturer {get;}

Also In This Interface

Description | Revision | Vendor | InstrumentManufacturer | InstrumentModel | InstrumentFirmwareRevision | Identifier | SupportedInstrumentModels | SpecificationMajorVersion | SpecificationMinorVersion | GroupCapabilities | IIviDriverIdentity Overview


InstrumentModel Property

IIviDriverIdentity.InstrumentModel Property

The model number or name reported by the physical instrument. If Simulation is enabled or the instrument is not capable of reporting the model number or name, a string is returned that explains the condition. Model is limited to 256 bytes

[Visual Basic]
Property Get InstrumentModel() As String
[C++]
HRESULT get_InstrumentModel(BSTR* value);
[ANSI C]
HRESULT IIviDriverIdentity_get_InstrumentModel(IIviDriverIdentity* This, BSTR* value);
[C#]
public string InstrumentModel {get;}

Also In This Interface

Description | Revision | Vendor | InstrumentManufacturer | InstrumentModel | InstrumentFirmwareRevision | Identifier | SupportedInstrumentModels | SpecificationMajorVersion | SpecificationMinorVersion | GroupCapabilities | IIviDriverIdentity Overview


Revision Property

IIviDriverIdentity.Revision Property

The revision of the implementing component. Refer to IVI 3.1, Section 3.1.2.2, for a description of revision syntax and semantics. Revision is limited to 256 bytes.

[Visual Basic]
Property Get Revision() As String
[C++]
HRESULT get_Revision(BSTR* value);
[ANSI C]
HRESULT IIviDriverIdentity_get_Revision(IIviDriverIdentity* This, BSTR* value);
[C#]
public string Revision {get;}

Also In This Interface

Description | Revision | Vendor | InstrumentManufacturer | InstrumentModel | InstrumentFirmwareRevision | Identifier | SupportedInstrumentModels | SpecificationMajorVersion | SpecificationMinorVersion | GroupCapabilities | IIviDriverIdentity Overview


SpecificationMajorVersion Property

IIviDriverIdentity.SpecificationMajorVersion Property

For IVI class-compliant drivers, the major version number of the instrument class specification. If the driver is not class compliant, the driver returns zero.

[Visual Basic]
Property Get SpecificationMajorVersion() As Long
[C++]
HRESULT get_SpecificationMajorVersion(long* value);
[ANSI C]
HRESULT IIviDriverIdentity_get_SpecificationMajorVersion(IIviDriverIdentity* This, long* value);
[C#]
public long SpecificationMajorVersion {get;}

Also In This Interface

Description | Revision | Vendor | InstrumentManufacturer | InstrumentModel | InstrumentFirmwareRevision | Identifier | SupportedInstrumentModels | SpecificationMajorVersion | SpecificationMinorVersion | GroupCapabilities | IIviDriverIdentity Overview


SpecificationMinorVersion Property

IIviDriverIdentity.SpecificationMinorVersion Property

For IVI class-compliant drivers, the minor version number of the instrument class specification. If the driver is not class compliant, the driver returns zero.

[Visual Basic]
Property Get SpecificationMinorVersion() As Long
[C++]
HRESULT get_SpecificationMinorVersion(long* value);
[ANSI C]
HRESULT IIviDriverIdentity_get_SpecificationMinorVersion(IIviDriverIdentity* This, long* value);
[C#]
public long SpecificationMinorVersion {get;}

Also In This Interface

Description | Revision | Vendor | InstrumentManufacturer | InstrumentModel | InstrumentFirmwareRevision | Identifier | SupportedInstrumentModels | SpecificationMajorVersion | SpecificationMinorVersion | GroupCapabilities | IIviDriverIdentity Overview


SupportedInstrumentModels Property

IIviDriverIdentity.SupportedInstrumentModels Property

A comma-separated list of instrument models that the IVI specific driver can control. The string does not include an abbreviation for the manufacturer if it is the same for all models.

[Visual Basic]
Property Get SupportedInstrumentModels() As String
[C++]
HRESULT get_SupportedInstrumentModels(BSTR* value);
[ANSI C]
HRESULT IIviDriverIdentity_get_SupportedInstrumentModels(IIviDriverIdentity* This, BSTR* value);
[C#]
public string SupportedInstrumentModels {get;}

Also In This Interface

Description | Revision | Vendor | InstrumentManufacturer | InstrumentModel | InstrumentFirmwareRevision | Identifier | SupportedInstrumentModels | SpecificationMajorVersion | SpecificationMinorVersion | GroupCapabilities | IIviDriverIdentity Overview


Vendor Property

IIviDriverIdentity.Vendor Property

The name of the vendor that supplies the implementing component. Vendor is limited to 256 bytes.

[Visual Basic]
Property Get Vendor() As String
[C++]
HRESULT get_Vendor(BSTR* value);
[ANSI C]
HRESULT IIviDriverIdentity_get_Vendor(IIviDriverIdentity* This, BSTR* value);
[C#]
public string Vendor {get;}

Also In This Interface

Description | Revision | Vendor | InstrumentManufacturer | InstrumentModel | InstrumentFirmwareRevision | Identifier | SupportedInstrumentModels | SpecificationMajorVersion | SpecificationMinorVersion | GroupCapabilities | IIviDriverIdentity Overview


Cache Property

IIviDriverOperation.Cache Property

Drivers may choose to always cache some instrument settings, never cache others, and optionally cache others, to avoid unecessary I/O to the instrument. If True, the driver caches optionally cached instrument settings.

[Visual Basic]
Property Get Cache() As Boolean
Property Let Cache(value As Boolean)
[C++]
HRESULT get_Cache(VARIANT_BOOL* value);
HRESULT put_Cache(VARIANT_BOOL value);
[ANSI C]
HRESULT IIviDriverOperation_get_Cache(IIviDriverOperation* This, VARIANT_BOOL* value);
HRESULT IIviDriverOperation_put_Cache(IIviDriverOperation* This, VARIANT_BOOL value);
[C#]
public bool Cache {get; set;}

Related Items

InvalidateAllAttributes

Also In This Interface

LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


ClearInterchangeWarnings Method

IIviDriverOperation.ClearInterchangeWarnings Method

Clears the list of interchangeability warnings that the IVI specific driver maintains.

[Visual Basic]
Sub ClearInterchangeWarnings()
[C++]
HRESULT ClearInterchangeWarnings();
[ANSI C]
HRESULT IIviDriverOperation_ClearInterchangeWarnings(
   IIviDriverOperation* This);
[C#]
public void ClearInterchangeWarnings();

Related Items

GetNextInterchangeWarning | ResetInterchangeCheck | InterchangeCheck

Also In This Interface

LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


DriverSetup Property

IIviDriverOperation.DriverSetup Property

The driver setup string. It is either specified in the Configuration Store or passed in the OptionString parameter of the Initialize function. Driver setup is empty if the driver is not initialized.

[Visual Basic]
Property Get DriverSetup() As String
[C++]
HRESULT get_DriverSetup(BSTR* value);
[ANSI C]
HRESULT IIviDriverOperation_get_DriverSetup(IIviDriverOperation* This, BSTR* value);
[C#]
public string DriverSetup {get;}

Also In This Interface

LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


GetNextCoercionRecord Method

IIviDriverOperation.GetNextCoercionRecord Method

Returns the oldest record from the coercion record list. Records are only added to the list if RecordCoercions is True.

[Visual Basic]
Function GetNextCoercionRecord() As String
[C++]
HRESULT GetNextCoercionRecord(
   BSTR* CoercionRecord
);
[ANSI C]
HRESULT IIviDriverOperation_GetNextCoercionRecord(
   IIviDriverOperation* This
   BSTR* CoercionRecord
);
[C#]
public string GetNextCoercionRecord();

Parameters

CoercionRecord
The coercion record string shall contain the following information:
  • The name of the attribute that was coerced. This can be the generic name, the COM property name, or the C defined constant.
  • If the attribute is channel-based, the name of the channel. The channel name can be the specific driver channel string or the virtual channel name that the user specified.
  • If the attribute applies to a repeated capability, the name of the repeated capability. The name can be the specific driver repeated capability token or the virtual repeated capability name that the user specified.
  • The value that the user specified for the attribute.
  • The value to which the attribute was coerced.

    • Related Items

    RecordCoercions

    Also In This Interface

    LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


GetNextInterchangeWarning Method

IIviDriverOperation.GetNextInterchangeWarning Method

Returns the oldest warning from the interchange warning list. Records are only added to the list if InterchangeCheck is True.

[Visual Basic]
Function GetNextInterchangeWarning() As String
[C++]
HRESULT GetNextInterchangeWarning(
   BSTR* InterchangeWarning
);
[ANSI C]
HRESULT IIviDriverOperation_GetNextInterchangeWarning(
   IIviDriverOperation* This
   BSTR* InterchangeWarning
);
[C#]
public string GetNextInterchangeWarning();

Parameters

InterchangeWarning
A string describing the oldest interchangeability warning or empty string if no warrnings remain.

Related Items

ClearInterchangeWarnings | ResetInterchangeCheck | InterchangeCheck

Also In This Interface

LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


InterchangeCheck Property

IIviDriverOperation.InterchangeCheck Property

If True, the driver maintains a record of interchangeability warnings. If the driver does not support interchangeability checking, attempts to set InterchangeCheck to True return an error.

[Visual Basic]
Property Get InterchangeCheck() As Boolean
Property Let InterchangeCheck(value As Boolean)
[C++]
HRESULT get_InterchangeCheck(VARIANT_BOOL* value);
HRESULT put_InterchangeCheck(VARIANT_BOOL value);
[ANSI C]
HRESULT IIviDriverOperation_get_InterchangeCheck(IIviDriverOperation* This, VARIANT_BOOL* value);
HRESULT IIviDriverOperation_put_InterchangeCheck(IIviDriverOperation* This, VARIANT_BOOL value);
[C#]
public bool InterchangeCheck {get; set;}

Related Items

ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck

Also In This Interface

LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


InvalidateAllAttributes Method

IIviDriverOperation.InvalidateAllAttributes Method

Invalidates all of the driver's cached values.

[Visual Basic]
Sub InvalidateAllAttributes()
[C++]
HRESULT InvalidateAllAttributes();
[ANSI C]
HRESULT IIviDriverOperation_InvalidateAllAttributes(
   IIviDriverOperation* This);
[C#]
public void InvalidateAllAttributes();

Related Items

Cache

Also In This Interface

LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


IoResourceDescriptor Property

IIviDriverOperation.IoResourceDescriptor Property

The resource descriptor specifies the connection to a physical device. It is either specified in the Configuration Store or passed in the ResourceName parameter of the Initialize function. It is empty if the driver is not initialized.

[Visual Basic]
Property Get IoResourceDescriptor() As String
[C++]
HRESULT get_IoResourceDescriptor(BSTR* value);
[ANSI C]
HRESULT IIviDriverOperation_get_IoResourceDescriptor(IIviDriverOperation* This, BSTR* value);
[C#]
public string IoResourceDescriptor {get;}

Also In This Interface

LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


LogicalName Property

IIviDriverOperation.LogicalName Property

Logical Name identifies a driver session in the Configuration Store. If Logical Name is not empty, the driver was initialized from information in the driver session. If it is empty, the driver was initialized without using the Configuration Store.

[Visual Basic]
Property Get LogicalName() As String
[C++]
HRESULT get_LogicalName(BSTR* value);
[ANSI C]
HRESULT IIviDriverOperation_get_LogicalName(IIviDriverOperation* This, BSTR* value);
[C#]
public string LogicalName {get;}

Also In This Interface

LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


QueryInstrumentStatus Property

IIviDriverOperation.QueryInstrumentStatus Property

If True, the driver queries the instrument status at the end of each method or property that performs I/O to the instrument. If an error is reported, use ErrorQuery to retrieve error messages one at a time from the instrument.

[Visual Basic]
Property Get QueryInstrumentStatus() As Boolean
Property Let QueryInstrumentStatus(value As Boolean)
[C++]
HRESULT get_QueryInstrumentStatus(VARIANT_BOOL* value);
HRESULT put_QueryInstrumentStatus(VARIANT_BOOL value);
[ANSI C]
HRESULT IIviDriverOperation_get_QueryInstrumentStatus(IIviDriverOperation* This, VARIANT_BOOL* value);
HRESULT IIviDriverOperation_put_QueryInstrumentStatus(IIviDriverOperation* This, VARIANT_BOOL value);
[C#]
public bool QueryInstrumentStatus {get; set;}

Also In This Interface

LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


RangeCheck Property

IIviDriverOperation.RangeCheck Property

Drivers may choose to always validate some property/parameter values, never validate others, and optionally validate others, to avoid sending invalid commands to the instrument. If True, the driver performs optional validations.

[Visual Basic]
Property Get RangeCheck() As Boolean
Property Let RangeCheck(value As Boolean)
[C++]
HRESULT get_RangeCheck(VARIANT_BOOL* value);
HRESULT put_RangeCheck(VARIANT_BOOL value);
[ANSI C]
HRESULT IIviDriverOperation_get_RangeCheck(IIviDriverOperation* This, VARIANT_BOOL* value);
HRESULT IIviDriverOperation_put_RangeCheck(IIviDriverOperation* This, VARIANT_BOOL value);
[C#]
public bool RangeCheck {get; set;}

Also In This Interface

LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


RecordCoercions Property

IIviDriverOperation.RecordCoercions Property

If True, the driver keeps a list of the value coercions it makes for ViInt32 and ViReal64 attributes. If the driver does not support coercion recording, attempts to set RecordCoercions to True will return an error.

[Visual Basic]
Property Get RecordCoercions() As Boolean
Property Let RecordCoercions(value As Boolean)
[C++]
HRESULT get_RecordCoercions(VARIANT_BOOL* value);
HRESULT put_RecordCoercions(VARIANT_BOOL value);
[ANSI C]
HRESULT IIviDriverOperation_get_RecordCoercions(IIviDriverOperation* This, VARIANT_BOOL* value);
HRESULT IIviDriverOperation_put_RecordCoercions(IIviDriverOperation* This, VARIANT_BOOL value);
[C#]
public bool RecordCoercions {get; set;}

Related Items

GetNextCoercionRecord

Also In This Interface

LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


ResetInterchangeCheck Method

IIviDriverOperation.ResetInterchangeCheck Method

Resets the interchangeability checking algorithms of the driver so that methods and properties that executed prior to calling this function have no affect on whether future calls to the driver generate interchangeability warnings.

[Visual Basic]
Sub ResetInterchangeCheck()
[C++]
HRESULT ResetInterchangeCheck();
[ANSI C]
HRESULT IIviDriverOperation_ResetInterchangeCheck(
   IIviDriverOperation* This);
[C#]
public void ResetInterchangeCheck();

Related Items

GetNextInterchangeWarning | ClearInterchangeWarnings | InterchangeCheck

Also In This Interface

LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


Simulate Property

IIviDriverOperation.Simulate Property

If True, the driver does not perform I/O to the instrument, and returns simulated values for output parameters.

[Visual Basic]
Property Get Simulate() As Boolean
Property Let Simulate(value As Boolean)
[C++]
HRESULT get_Simulate(VARIANT_BOOL* value);
HRESULT put_Simulate(VARIANT_BOOL value);
[ANSI C]
HRESULT IIviDriverOperation_get_Simulate(IIviDriverOperation* This, VARIANT_BOOL* value);
HRESULT IIviDriverOperation_put_Simulate(IIviDriverOperation* This, VARIANT_BOOL value);
[C#]
public bool Simulate {get; set;}

Also In This Interface

LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


Disable Method

IIviDriverUtility.Disable Method

Quickly places the instrument in a state where it has no, or minimal, effect on the external system to which it is connected. This state is not necessarily a known state.

[Visual Basic]
Sub Disable()
[C++]
HRESULT Disable();
[ANSI C]
HRESULT IIviDriverUtility_Disable(
   IIviDriverUtility* This);
[C#]
public void Disable();

Also In This Interface

Reset | ResetWithDefaults | Disable | SelfTest | ErrorQuery | LockObject | UnlockObject | IIviDriverUtility Overview


ErrorQuery Method

IIviDriverUtility.ErrorQuery Method

Queries the instrument and returns instrument specific error information. This function can be used when QueryInstrumentStatus is True to retrieve error details when the driver detects an instrument error.

[Visual Basic]
Sub ErrorQuery( _
   ErrorCode As Long, _
   ErrorMessage As String _
)
[C++]
HRESULT ErrorQuery(
   long* ErrorCode,
   BSTR* ErrorMessage
);
[ANSI C]
HRESULT IIviDriverUtility_ErrorQuery(
   IIviDriverUtility* This
   long* ErrorCode,
   BSTR* ErrorMessage
);
[C#]
public void ErrorQuery(
   long ErrorCode,
   string ErrorMessage
);

Parameters

ErrorCode
Instrument error code
ErrorMessage
Instrument error message

Also In This Interface

Reset | ResetWithDefaults | Disable | SelfTest | ErrorQuery | LockObject | UnlockObject | IIviDriverUtility Overview


LockObject Method

IIviDriverUtility.LockObject Method

Obtains a multithread lock on the driver after waiting until all other execution threads have released their locks on the instrument session.

[Visual Basic]
Sub LockObject()
[C++]
HRESULT LockObject();
[ANSI C]
HRESULT IIviDriverUtility_LockObject(
   IIviDriverUtility* This);
[C#]
public void LockObject();

Related Items

UnlockObject

Also In This Interface

Reset | ResetWithDefaults | Disable | SelfTest | ErrorQuery | LockObject | UnlockObject | IIviDriverUtility Overview


Reset Method

IIviDriverUtility.Reset Method

Places the instrument in a known state and configures instrument options on which the IVI specific driver depends (for example, enabling/disabling headers). For an IEEE 488.2 instrument, Reset sends the command string *RST to the instrument.

[Visual Basic]
Sub Reset()
[C++]
HRESULT Reset();
[ANSI C]
HRESULT IIviDriverUtility_Reset(
   IIviDriverUtility* This);
[C#]
public void Reset();

Related Items

ResetWithDefaults

Also In This Interface

Reset | ResetWithDefaults | Disable | SelfTest | ErrorQuery | LockObject | UnlockObject | IIviDriverUtility Overview


ResetWithDefaults Method

IIviDriverUtility.ResetWithDefaults Method

Does the equivalent of Reset and then, (1) disables class extension capability groups, (2) sets attributes to initial values defined by class specs, and (3) configures the driver to option string settings used when Initialize was last executed.

[Visual Basic]
Sub ResetWithDefaults()
[C++]
HRESULT ResetWithDefaults();
[ANSI C]
HRESULT IIviDriverUtility_ResetWithDefaults(
   IIviDriverUtility* This);
[C#]
public void ResetWithDefaults();

Also In This Interface

Reset | ResetWithDefaults | Disable | SelfTest | ErrorQuery | LockObject | UnlockObject | IIviDriverUtility Overview


SelfTest Method

IIviDriverUtility.SelfTest Method

Performs an instrument self test, waits for the instrument to complete the test, and queries the instrument for the results. If the instrument passes the test, TestResult is zero and TestMessage is 'Self test passed'.

[Visual Basic]
Sub SelfTest( _
   TestResult As Long, _
   TestMessage As String _
)
[C++]
HRESULT SelfTest(
   long* TestResult,
   BSTR* TestMessage
);
[ANSI C]
HRESULT IIviDriverUtility_SelfTest(
   IIviDriverUtility* This
   long* TestResult,
   BSTR* TestMessage
);
[C#]
public void SelfTest(
   long TestResult,
   string TestMessage
);

Parameters

TestResult
The numeric result from the self test operation. 0 = no error (test passed)
TestMessage
The self test status message

Also In This Interface

Reset | ResetWithDefaults | Disable | SelfTest | ErrorQuery | LockObject | UnlockObject | IIviDriverUtility Overview


UnlockObject Method

IIviDriverUtility.UnlockObject Method

Releases a previously obtained mutlithread lock.

[Visual Basic]
Sub UnlockObject()
[C++]
HRESULT UnlockObject();
[ANSI C]
HRESULT IIviDriverUtility_UnlockObject(
   IIviDriverUtility* This);
[C#]
public void UnlockObject();

Related Items

LockObject

Also In This Interface

Reset | ResetWithDefaults | Disable | SelfTest | ErrorQuery | LockObject | UnlockObject | IIviDriverUtility Overview