IviSpecAn Reference

© 2003 IVI Foundation

Welcome to the IviSpecAn Class-Compliant Interface Reference

This section contains the reference material for the IviSpecAn class-compliant interface.

This help hierarchy matches the COM hierarchy defined in the IviSpecAn class specification, available on the IVI Foundation Web Site. The COM hierarchy groups related capabilities into common interfaces. These interfaces often include both IviSpecAn base and extension capabilities. To help users distinguish between base and extension capabilities, the Capability Group section of each method or property topic lists which of the IviSpecAn Capability Groups the method or property belongs to.

Since IVI class-compliant specific drivers are not required to support all extension groups, users should refer to the compliance documentation for the particular driver being used to determine if an extension group is supported before using capabilities in that group.

IVI class-compliant specific drivers may have small differences in the way a particular extension group method or property is implemented. For instance, a driver might implement only one of several IVI-defined values for an extension group attribute. Refer to the help documentation provided with the IVI class-compliant specific driver for detailed information about implementation.


Inherent Interface

IviSpecAn Capability Groups

Capability Group | Description
IviSpecAnBase | Base: Complies with the IviSpecAn base capabilities.
IviSpecAnMultitrace | Extension: IviSpecAn with the ability to do simple mathematical operations on multiple traces.
IviSpecAnDisplay | Extension: IviSpecAn with the ability to configure basic display characteristics.
IviSpecAnMarker | Extension: IviSpecAn with the ability to utilize internal markers to perform various measurements.
IviSpecAnMarkerType | Extension: IviSpecAn with the ability to specify different marker types.
IviSpecAnDeltaMarker | Extension: IviSpecAn with the ability to utilize delta markers to perform various relative measurements.
IviSpecAnTrigger | Extension: IviSpecAn with the ability to utilize different trigger sources.
IviSpecAnExternalTrigger | Extension: IviSpecAn with the ability to utilize external trigger level and slope.
IviSpecAnSendSoftwareTrigger | Extension: IviSpecAn with the ability to receive software triggers.
IviSpecAnVideoTrigger | Extension: IviSpecAn with the ability to utilize video trigger level and slope.
IviSpecAnExternalMixer | Extension: IviSpecAn with the ability to expand the frequency range.
IviSpecAnPreselector | Extension: IviSpecAn with the ability to utilize peak preselector function to reduce noise and increase dynamic range.


Inherent Interface

IviSpecAn Instrument Class Interfaces

IIviSpecAn | IVI SpecAn class-compliant root interface
IIviSpecAnAcquisition | IVI SpecAn class-compliant acquisition interface
IIviSpecAnDisplay | IVI SpecAn class-compliant display interface
IIviSpecAnExternalMixer | IVI SpecAn class-compliant external mixer interface
IIviSpecAnExternalMixerBias | IVI SpecAn class-compliant external mixer bias interface
IIviSpecAnExternalMixerConversionLossTable | IVI SpecAn class-compliant external mixer conversion loss table interface
IIviSpecAnFrequency | IVI SpecAn class-compliant frequency interface
IIviSpecAnLevel | IVI SpecAn class-compliant level interface
IIviSpecAnMarker | IVI SpecAn class-compliant marker interface
IIviSpecAnMarkerFrequencyCounter | IVI SpecAn class-compliant marker frequency counter interface
IIviSpecAnPreselector | IVI SpecAn class-compliant preselector interface
IIviSpecAnSweepCoupling | IVI SpecAn class-compliant sweep coupling interface
IIviSpecAnTrace | IVI SpecAn class-compliant trace interface
IIviSpecAnTraces | IVI SpecAn class-compliant trace collection interface
IIviSpecAnTracesMath | IVI SpecAn class-compliant traces math interface
IIviSpecAnTrigger | IVI SpecAn class-compliant trigger interface
IIviSpecAnTriggerExternal | IVI SpecAn class-compliant trigger external interface
IIviSpecAnTriggerVideo | IVI SpecAn class-compliant trigger video interface


IIviSpecAn Interface

IVI SpecAn class-compliant root interface

Properties

DriverOperation | Pointer to the IIviDriverOperation interface
Identity | Pointer to the IIviDriverIdentity interface
Utility | Pointer to the IIviDriverUtility interface
Initialized | Initialized is True between a successful call to the Initialize method and a successful call to the Close method, and False at all other times.
Frequency | Pointer to the class-compliant IIviSpecAnFrequency interface
SweepCoupling | Pointer to the class-compliant IIviSpecAnSweepCoupling interface
Level | Pointer to the class-compliant IIviSpecAnLevel interface
Acquisition | Pointer to the class-compliant IIviSpecAnAcquisition interface
Display | Pointer to the class-compliant IIviSpecAnDisplay interface
ExternalMixer | Pointer to the class-compliant IIviSpecAnExternalMixer interface
Trigger | Pointer to the class-compliant IIviSpecAnTrigger interface
Traces | Pointer to the class-compliant IIviSpecAnTraces interface
Marker | Pointer to the class-compliant IIviSpecAnMarker interface
Preselector | Pointer to the class-compliant IIviSpecAnPreselector interface

Methods

Initialize | Opens the I/O session to the instrument. Driver methods and properties that access the instrument are only accessible after Initialize is called. Initialize optionally performs a Reset and queries the instrument to validate the instrument model.
Close | Closes the I/O session to the instrument. Driver methods and properties that access the instrument are not accessible after Close is called.


DriverOperation Property

IIviSpecAn.DriverOperation Property

Pointer to the IIviDriverOperation interface

[Visual Basic]
Property Get DriverOperation() As IIviDriverOperation*
[C++]
HRESULT get_DriverOperation(IIviDriverOperation** value);
[ANSI C]
HRESULT IIviSpecAn_get_DriverOperation(IIviSpecAn* This, IIviDriverOperation** value);
[C#]
public IIviDriverOperation* DriverOperation {get;}

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Frequency | SweepCoupling | Level | Acquisition | Display | ExternalMixer | Trigger | Traces | Marker | Preselector | Initialize | Close | IIviSpecAn Overview


Identity Property

IIviSpecAn.Identity Property

Pointer to the IIviDriverIdentity interface

[Visual Basic]
Property Get Identity() As IIviDriverIdentity*
[C++]
HRESULT get_Identity(IIviDriverIdentity** value);
[ANSI C]
HRESULT IIviSpecAn_get_Identity(IIviSpecAn* This, IIviDriverIdentity** value);
[C#]
public IIviDriverIdentity* Identity {get;}

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Frequency | SweepCoupling | Level | Acquisition | Display | ExternalMixer | Trigger | Traces | Marker | Preselector | Initialize | Close | IIviSpecAn Overview


Utility Property

IIviSpecAn.Utility Property

Pointer to the IIviDriverUtility interface

[Visual Basic]
Property Get Utility() As IIviDriverUtility*
[C++]
HRESULT get_Utility(IIviDriverUtility** value);
[ANSI C]
HRESULT IIviSpecAn_get_Utility(IIviSpecAn* This, IIviDriverUtility** value);
[C#]
public IIviDriverUtility* Utility {get;}

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Frequency | SweepCoupling | Level | Acquisition | Display | ExternalMixer | Trigger | Traces | Marker | Preselector | Initialize | Close | IIviSpecAn Overview


Initialized Property

IIviSpecAn.Initialized Property

Initialized is True between a successful call to the Initialize method and a successful call to the Close method, and False at all other times.

[Visual Basic]
Property Get Initialized() As Boolean
[C++]
HRESULT get_Initialized(VARIANT_BOOL* value);
[ANSI C]
HRESULT IIviSpecAn_get_Initialized(IIviSpecAn* This, VARIANT_BOOL* value);
[C#]
public bool Initialized {get;}

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Frequency | SweepCoupling | Level | Acquisition | Display | ExternalMixer | Trigger | Traces | Marker | Preselector | Initialize | Close | IIviSpecAn Overview


Frequency Property

IIviSpecAn.Frequency Property

Pointer to the class-compliant IIviSpecAnFrequency interface

[Visual Basic]
Property Get Frequency() As IIviSpecAnFrequency
[C++]
HRESULT get_Frequency(IIviSpecAnFrequency** value);
[ANSI C]
HRESULT IIviSpecAn_get_Frequency(IIviSpecAn* This, IIviSpecAnFrequency** value);
[C#]
public IIviSpecAnFrequency Frequency {get;}

Capability Group

IviSpecAnBase

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Frequency | SweepCoupling | Level | Acquisition | Display | ExternalMixer | Trigger | Traces | Marker | Preselector | Initialize | Close | IIviSpecAn Overview


SweepCoupling Property

IIviSpecAn.SweepCoupling Property

Pointer to the class-compliant IIviSpecAnSweepCoupling interface

[Visual Basic]
Property Get SweepCoupling() As IIviSpecAnSweepCoupling
[C++]
HRESULT get_SweepCoupling(IIviSpecAnSweepCoupling** value);
[ANSI C]
HRESULT IIviSpecAn_get_SweepCoupling(IIviSpecAn* This, IIviSpecAnSweepCoupling** value);
[C#]
public IIviSpecAnSweepCoupling SweepCoupling {get;}

Capability Group

IviSpecAnBase

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Frequency | SweepCoupling | Level | Acquisition | Display | ExternalMixer | Trigger | Traces | Marker | Preselector | Initialize | Close | IIviSpecAn Overview


Level Property

IIviSpecAn.Level Property

Pointer to the class-compliant IIviSpecAnLevel interface

[Visual Basic]
Property Get Level() As IIviSpecAnLevel
[C++]
HRESULT get_Level(IIviSpecAnLevel** value);
[ANSI C]
HRESULT IIviSpecAn_get_Level(IIviSpecAn* This, IIviSpecAnLevel** value);
[C#]
public IIviSpecAnLevel Level {get;}

Capability Group

IviSpecAnBase

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Frequency | SweepCoupling | Level | Acquisition | Display | ExternalMixer | Trigger | Traces | Marker | Preselector | Initialize | Close | IIviSpecAn Overview


Acquisition Property

IIviSpecAn.Acquisition Property

Pointer to the class-compliant IIviSpecAnAcquisition interface

[Visual Basic]
Property Get Acquisition() As IIviSpecAnAcquisition
[C++]
HRESULT get_Acquisition(IIviSpecAnAcquisition** value);
[ANSI C]
HRESULT IIviSpecAn_get_Acquisition(IIviSpecAn* This, IIviSpecAnAcquisition** value);
[C#]
public IIviSpecAnAcquisition Acquisition {get;}

Capability Group

IviSpecAnBase

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Frequency | SweepCoupling | Level | Acquisition | Display | ExternalMixer | Trigger | Traces | Marker | Preselector | Initialize | Close | IIviSpecAn Overview


Display Property

IIviSpecAn.Display Property

Pointer to the class-compliant IIviSpecAnDisplay interface

[Visual Basic]
Property Get Display() As IIviSpecAnDisplay
[C++]
HRESULT get_Display(IIviSpecAnDisplay** value);
[ANSI C]
HRESULT IIviSpecAn_get_Display(IIviSpecAn* This, IIviSpecAnDisplay** value);
[C#]
public IIviSpecAnDisplay Display {get;}

Capability Group

IviSpecAnDisplay

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Frequency | SweepCoupling | Level | Acquisition | Display | ExternalMixer | Trigger | Traces | Marker | Preselector | Initialize | Close | IIviSpecAn Overview


ExternalMixer Property

IIviSpecAn.ExternalMixer Property

Pointer to the class-compliant IIviSpecAnExternalMixer interface

[Visual Basic]
Property Get ExternalMixer() As IIviSpecAnExternalMixer
[C++]
HRESULT get_ExternalMixer(IIviSpecAnExternalMixer** value);
[ANSI C]
HRESULT IIviSpecAn_get_ExternalMixer(IIviSpecAn* This, IIviSpecAnExternalMixer** value);
[C#]
public IIviSpecAnExternalMixer ExternalMixer {get;}

Capability Group

IviSpecAnExternalMixer

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Frequency | SweepCoupling | Level | Acquisition | Display | ExternalMixer | Trigger | Traces | Marker | Preselector | Initialize | Close | IIviSpecAn Overview


Trigger Property

IIviSpecAn.Trigger Property

Pointer to the class-compliant IIviSpecAnTrigger interface

[Visual Basic]
Property Get Trigger() As IIviSpecAnTrigger
[C++]
HRESULT get_Trigger(IIviSpecAnTrigger** value);
[ANSI C]
HRESULT IIviSpecAn_get_Trigger(IIviSpecAn* This, IIviSpecAnTrigger** value);
[C#]
public IIviSpecAnTrigger Trigger {get;}

Capability Group

IviSpecAnTrigger

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Frequency | SweepCoupling | Level | Acquisition | Display | ExternalMixer | Trigger | Traces | Marker | Preselector | Initialize | Close | IIviSpecAn Overview


Traces Property

IIviSpecAn.Traces Property

Pointer to the class-compliant IIviSpecAnTraces interface

[Visual Basic]
Property Get Traces() As IIviSpecAnTraces
[C++]
HRESULT get_Traces(IIviSpecAnTraces** value);
[ANSI C]
HRESULT IIviSpecAn_get_Traces(IIviSpecAn* This, IIviSpecAnTraces** value);
[C#]
public IIviSpecAnTraces Traces {get;}

Capability Group

IviSpecAnBase

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Frequency | SweepCoupling | Level | Acquisition | Display | ExternalMixer | Trigger | Traces | Marker | Preselector | Initialize | Close | IIviSpecAn Overview


Marker Property

IIviSpecAn.Marker Property

Pointer to the class-compliant IIviSpecAnMarker interface

[Visual Basic]
Property Get Marker() As IIviSpecAnMarker
[C++]
HRESULT get_Marker(IIviSpecAnMarker** value);
[ANSI C]
HRESULT IIviSpecAn_get_Marker(IIviSpecAn* This, IIviSpecAnMarker** value);
[C#]
public IIviSpecAnMarker Marker {get;}

Capability Group

IviSpecAnMarker

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Frequency | SweepCoupling | Level | Acquisition | Display | ExternalMixer | Trigger | Traces | Marker | Preselector | Initialize | Close | IIviSpecAn Overview


Preselector Property

IIviSpecAn.Preselector Property

Pointer to the class-compliant IIviSpecAnPreselector interface

[Visual Basic]
Property Get Preselector() As IIviSpecAnPreselector
[C++]
HRESULT get_Preselector(IIviSpecAnPreselector** value);
[ANSI C]
HRESULT IIviSpecAn_get_Preselector(IIviSpecAn* This, IIviSpecAnPreselector** value);
[C#]
public IIviSpecAnPreselector Preselector {get;}

Capability Group

IviSpecAnPreselector

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Frequency | SweepCoupling | Level | Acquisition | Display | ExternalMixer | Trigger | Traces | Marker | Preselector | Initialize | Close | IIviSpecAn Overview


Initialize Method

IIviSpecAn.Initialize Method

Opens the I/O session to the instrument. Driver methods and properties that access the instrument are only accessible after Initialize is called. Initialize optionally performs a Reset and queries the instrument to validate the instrument model.

[Visual Basic]
Sub Initialize( _
   ResourceName As String, _
   IdQuery As Boolean, _
   Reset As Boolean, _
   OptionString As String _
)
[C++]
HRESULT Initialize(
   BSTR ResourceName,
   VARIANT_BOOL IdQuery,
   VARIANT_BOOL Reset,
   BSTR OptionString
);
[ANSI C]
HRESULT IIviSpecAn_Initialize(
   IIviSpecAn* This
   BSTR ResourceName,
   VARIANT_BOOL IdQuery,
   VARIANT_BOOL Reset,
   BSTR OptionString
);
[C#]
public void Initialize(
   string ResourceName,
   bool IdQuery,
   bool Reset,
   string OptionString
);

Parameters

ResourceName
An IVI logical name or an instrument specific string that identifies the address of the instrument, such as a VISA resource descriptor string.
IdQuery
Specifies whether to verify the ID of the instrument.
Reset
Specifies whether to reset the instrument.
OptionString
The user can use the OptionsString parameter to specify the initial values of certain IVI inherent attributes for the session.

Related Items

Close

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Frequency | SweepCoupling | Level | Acquisition | Display | ExternalMixer | Trigger | Traces | Marker | Preselector | Initialize | Close | IIviSpecAn Overview


Close Method

IIviSpecAn.Close Method

Closes the I/O session to the instrument. Driver methods and properties that access the instrument are not accessible after Close is called.

[Visual Basic]
Sub Close()
[C++]
HRESULT Close();
[ANSI C]
HRESULT IIviSpecAn_Close(
   IIviSpecAn* This);
[C#]
public void Close();

Related Items

Initialize

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Frequency | SweepCoupling | Level | Acquisition | Display | ExternalMixer | Trigger | Traces | Marker | Preselector | Initialize | Close | IIviSpecAn Overview


IIviSpecAnAcquisition Interface

IVI SpecAn class-compliant acquisition interface

Properties

SweepModeContinuous | Turns continuous sweep on/off.
NumberOfSweeps | Specifies the number of sweeps.
DetectorTypeAuto | Turns automatic selection of detector type on/off.
DetectorType | Specifies the detector type used to capture and process the signal.
VerticalScale | Specifies the vertical scale of the measurement hardware (use of log amplifiers vs. linear amplifiers).

Methods

Configure This function configures the acquisition attributes of the IviSpecAn.


SweepModeContinuous Property

IIviSpecAnAcquisition.SweepModeContinuous Property

Turns continuous sweep on/off.

[Visual Basic]
Property Get SweepModeContinuous() As Boolean
Property Let SweepModeContinuous(value As Boolean)
[C++]
HRESULT get_SweepModeContinuous(VARIANT_BOOL* value);
HRESULT put_SweepModeContinuous(VARIANT_BOOL value);
[ANSI C]
HRESULT IIviSpecAnAcquisition_get_SweepModeContinuous(IIviSpecAnAcquisition* This, VARIANT_BOOL* value);
HRESULT IIviSpecAnAcquisition_put_SweepModeContinuous(IIviSpecAnAcquisition* This, VARIANT_BOOL value);
[C#]
public bool SweepModeContinuous {get; set;}

Capability Group

IviSpecAnBase

Related Items

Configure

Also In This Interface

SweepModeContinuous | NumberOfSweeps | DetectorTypeAuto | DetectorType | VerticalScale | Configure | IIviSpecAnAcquisition Overview


NumberOfSweeps Property

IIviSpecAnAcquisition.NumberOfSweeps Property

Specifies the number of sweeps.

[Visual Basic]
Property Get NumberOfSweeps() As Long
Property Let NumberOfSweeps(value As Long)
[C++]
HRESULT get_NumberOfSweeps(long* value);
HRESULT put_NumberOfSweeps(long value);
[ANSI C]
HRESULT IIviSpecAnAcquisition_get_NumberOfSweeps(IIviSpecAnAcquisition* This, long* value);
HRESULT IIviSpecAnAcquisition_put_NumberOfSweeps(IIviSpecAnAcquisition* This, long value);
[C#]
public long NumberOfSweeps {get; set;}

Capability Group

IviSpecAnBase

Related Items

Configure

Also In This Interface

SweepModeContinuous | NumberOfSweeps | DetectorTypeAuto | DetectorType | VerticalScale | Configure | IIviSpecAnAcquisition Overview


DetectorTypeAuto Property

IIviSpecAnAcquisition.DetectorTypeAuto Property

Turns automatic selection of detector type on/off.

[Visual Basic]
Property Get DetectorTypeAuto() As Boolean
Property Let DetectorTypeAuto(value As Boolean)
[C++]
HRESULT get_DetectorTypeAuto(VARIANT_BOOL* value);
HRESULT put_DetectorTypeAuto(VARIANT_BOOL value);
[ANSI C]
HRESULT IIviSpecAnAcquisition_get_DetectorTypeAuto(IIviSpecAnAcquisition* This, VARIANT_BOOL* value);
HRESULT IIviSpecAnAcquisition_put_DetectorTypeAuto(IIviSpecAnAcquisition* This, VARIANT_BOOL value);
[C#]
public bool DetectorTypeAuto {get; set;}

Capability Group

IviSpecAnBase

Related Items

Configure

Also In This Interface

SweepModeContinuous | NumberOfSweeps | DetectorTypeAuto | DetectorType | VerticalScale | Configure | IIviSpecAnAcquisition Overview


DetectorType Property

IIviSpecAnAcquisition.DetectorType Property

Specifies the detector type used to capture and process the signal.

[Visual Basic]
Property Get DetectorType() As IviSpecAnDetectorTypeEnum
Property Let DetectorType(value As IviSpecAnDetectorTypeEnum)
[C++]
HRESULT get_DetectorType(IviSpecAnDetectorTypeEnum* value);
HRESULT put_DetectorType(IviSpecAnDetectorTypeEnum value);
[ANSI C]
HRESULT IIviSpecAnAcquisition_get_DetectorType(IIviSpecAnAcquisition* This, IviSpecAnDetectorTypeEnum* value);
HRESULT IIviSpecAnAcquisition_put_DetectorType(IIviSpecAnAcquisition* This, IviSpecAnDetectorTypeEnum value);
[C#]
public IviSpecAnDetectorTypeEnum DetectorType {get; set;}

Capability Group

IviSpecAnBase

Related Items

Configure

Also In This Interface

SweepModeContinuous | NumberOfSweeps | DetectorTypeAuto | DetectorType | VerticalScale | Configure | IIviSpecAnAcquisition Overview


VerticalScale Property

IIviSpecAnAcquisition.VerticalScale Property

Specifies the vertical scale of the measurement hardware (use of log amplifiers vs. linear amplifiers).

[Visual Basic]
Property Get VerticalScale() As IviSpecAnVerticalScaleEnum
Property Let VerticalScale(value As IviSpecAnVerticalScaleEnum)
[C++]
HRESULT get_VerticalScale(IviSpecAnVerticalScaleEnum* value);
HRESULT put_VerticalScale(IviSpecAnVerticalScaleEnum value);
[ANSI C]
HRESULT IIviSpecAnAcquisition_get_VerticalScale(IIviSpecAnAcquisition* This, IviSpecAnVerticalScaleEnum* value);
HRESULT IIviSpecAnAcquisition_put_VerticalScale(IIviSpecAnAcquisition* This, IviSpecAnVerticalScaleEnum value);
[C#]
public IviSpecAnVerticalScaleEnum VerticalScale {get; set;}

Capability Group

IviSpecAnBase

Related Items

Configure

Also In This Interface

SweepModeContinuous | NumberOfSweeps | DetectorTypeAuto | DetectorType | VerticalScale | Configure | IIviSpecAnAcquisition Overview


Configure Method

IIviSpecAnAcquisition.Configure Method

This function configures the acquisition attributes of the IviSpecAn.

[Visual Basic]
Sub Configure( _
   SweepModeContinuous As Boolean, _
   NumberOfSweeps As Long, _
   DetectorTypeAuto As Boolean, _
   DetectorType As IviSpecAnDetectorTypeEnum, _
   VerticalScale As IviSpecAnVerticalScaleEnum _
)
[C++]
HRESULT Configure(
   VARIANT_BOOL SweepModeContinuous,
   long NumberOfSweeps,
   VARIANT_BOOL DetectorTypeAuto,
   IviSpecAnDetectorTypeEnum DetectorType,
   IviSpecAnVerticalScaleEnum VerticalScale
);
[ANSI C]
HRESULT IIviSpecAnAcquisition_Configure(
   IIviSpecAnAcquisition* This
   VARIANT_BOOL SweepModeContinuous,
   long NumberOfSweeps,
   VARIANT_BOOL DetectorTypeAuto,
   IviSpecAnDetectorTypeEnum DetectorType,
   IviSpecAnVerticalScaleEnum VerticalScale
);
[C#]
public void Configure(
   bool SweepModeContinuous,
   long NumberOfSweeps,
   bool DetectorTypeAuto,
   IviSpecAnDetectorTypeEnum DetectorType,
   IviSpecAnVerticalScaleEnum VerticalScale
);

Parameters

SweepModeContinuous
Enables or disables continuous sweeping. The driver uses this value to set the Sweep Mode Continuous attribute.
NumberOfSweeps
Specifies the number of sweeps to take. The driver uses this value to set the Number Of Sweeps attribute.
DetectorTypeAuto
Enables or Disables the auto detector. The driver uses this value to set the Detector Type Auto attribute.
DetectorType
Specifies the method of capturing and processing signal data. The driver uses this value to set the Detector Type attribute.
VerticalScale
Specifies the vertical scale. The driver uses this value to set the Vertical Scale attribute.

Capability Group

IviSpecAnBase

Related Items

SweepModeContinuous | NumberOfSweeps | DetectorTypeAuto | DetectorType | VerticalScale

Also In This Interface

SweepModeContinuous | NumberOfSweeps | DetectorTypeAuto | DetectorType | VerticalScale | Configure | IIviSpecAnAcquisition Overview


IIviSpecAnDisplay Interface

IVI SpecAn class-compliant display interface

Properties

UnitsPerDivision | Specifies the number of vertical units in one screen division.
NumberOfDivisions | Specifies the number of vertical screen divisions.


UnitsPerDivision Property

IIviSpecAnDisplay.UnitsPerDivision Property

Specifies the number of vertical units in one screen division.

[Visual Basic]
Property Get UnitsPerDivision() As Double
Property Let UnitsPerDivision(value As Double)
[C++]
HRESULT get_UnitsPerDivision(double* value);
HRESULT put_UnitsPerDivision(double value);
[ANSI C]
HRESULT IIviSpecAnDisplay_get_UnitsPerDivision(IIviSpecAnDisplay* This, double* value);
HRESULT IIviSpecAnDisplay_put_UnitsPerDivision(IIviSpecAnDisplay* This, double value);
[C#]
public double UnitsPerDivision {get; set;}

Capability Group

IviSpecAnDisplay

Also In This Interface

UnitsPerDivision | NumberOfDivisions | IIviSpecAnDisplay Overview


NumberOfDivisions Property

IIviSpecAnDisplay.NumberOfDivisions Property

Specifies the number of vertical screen divisions.

[Visual Basic]
Property Get NumberOfDivisions() As Long
[C++]
HRESULT get_NumberOfDivisions(long* value);
[ANSI C]
HRESULT IIviSpecAnDisplay_get_NumberOfDivisions(IIviSpecAnDisplay* This, long* value);
[C#]
public long NumberOfDivisions {get;}

Capability Group

IviSpecAnDisplay

Also In This Interface

UnitsPerDivision | NumberOfDivisions | IIviSpecAnDisplay Overview


IIviSpecAnExternalMixer Interface

IVI SpecAn class-compliant external mixer interface

Properties

Bias | Pointer to the class-compliant IIviSpecAnExternalMixerBias interface
ConversionLossTable | Pointer to the class-compliant IIviSpecAnExternalMixerConversionLossTable interface
Harmonic | Specifies the harmonic number.
AverageConversionLoss | Specifies the average conversion loss.
Enabled | Specifies whether the external mixer is enabled.
NumberOfPorts | Specifies a two-port mixer or a three-port mixer.

Methods

Configure This function specifies the mixer harmonic number and average conversion loss.


Bias Property

IIviSpecAnExternalMixer.Bias Property

Pointer to the class-compliant IIviSpecAnExternalMixerBias interface

[Visual Basic]
Property Get Bias() As IIviSpecAnExternalMixerBias
[C++]
HRESULT get_Bias(IIviSpecAnExternalMixerBias** value);
[ANSI C]
HRESULT IIviSpecAnExternalMixer_get_Bias(IIviSpecAnExternalMixer* This, IIviSpecAnExternalMixerBias** value);
[C#]
public IIviSpecAnExternalMixerBias Bias {get;}

Capability Group

IviSpecAnExternalMixer

Also In This Interface

Bias | ConversionLossTable | Harmonic | AverageConversionLoss | Enabled | NumberOfPorts | Configure | IIviSpecAnExternalMixer Overview


ConversionLossTable Property

IIviSpecAnExternalMixer.ConversionLossTable Property

Pointer to the class-compliant IIviSpecAnExternalMixerConversionLossTable interface

[Visual Basic]
Property Get ConversionLossTable() As IIviSpecAnExternalMixerConversionLossTable
[C++]
HRESULT get_ConversionLossTable(IIviSpecAnExternalMixerConversionLossTable** value);
[ANSI C]
HRESULT IIviSpecAnExternalMixer_get_ConversionLossTable(IIviSpecAnExternalMixer* This, IIviSpecAnExternalMixerConversionLossTable** value);
[C#]
public IIviSpecAnExternalMixerConversionLossTable ConversionLossTable {get;}

Capability Group

IviSpecAnExternalMixer

Also In This Interface

Bias | ConversionLossTable | Harmonic | AverageConversionLoss | Enabled | NumberOfPorts | Configure | IIviSpecAnExternalMixer Overview


Harmonic Property

IIviSpecAnExternalMixer.Harmonic Property

Specifies the harmonic number.

[Visual Basic]
Property Get Harmonic() As Long
Property Let Harmonic(value As Long)
[C++]
HRESULT get_Harmonic(long* value);
HRESULT put_Harmonic(long value);
[ANSI C]
HRESULT IIviSpecAnExternalMixer_get_Harmonic(IIviSpecAnExternalMixer* This, long* value);
HRESULT IIviSpecAnExternalMixer_put_Harmonic(IIviSpecAnExternalMixer* This, long value);
[C#]
public long Harmonic {get; set;}

Capability Group

IviSpecAnExternalMixer

Related Items

Configure

Also In This Interface

Bias | ConversionLossTable | Harmonic | AverageConversionLoss | Enabled | NumberOfPorts | Configure | IIviSpecAnExternalMixer Overview


AverageConversionLoss Property

IIviSpecAnExternalMixer.AverageConversionLoss Property

Specifies the average conversion loss.

[Visual Basic]
Property Get AverageConversionLoss() As Double
Property Let AverageConversionLoss(value As Double)
[C++]
HRESULT get_AverageConversionLoss(double* value);
HRESULT put_AverageConversionLoss(double value);
[ANSI C]
HRESULT IIviSpecAnExternalMixer_get_AverageConversionLoss(IIviSpecAnExternalMixer* This, double* value);
HRESULT IIviSpecAnExternalMixer_put_AverageConversionLoss(IIviSpecAnExternalMixer* This, double value);
[C#]
public double AverageConversionLoss {get; set;}

Capability Group

IviSpecAnExternalMixer

Related Items

Configure

Also In This Interface

Bias | ConversionLossTable | Harmonic | AverageConversionLoss | Enabled | NumberOfPorts | Configure | IIviSpecAnExternalMixer Overview


Enabled Property

IIviSpecAnExternalMixer.Enabled Property

Specifies whether the external mixer is enabled.

[Visual Basic]
Property Get Enabled() As Boolean
Property Let Enabled(value As Boolean)
[C++]
HRESULT get_Enabled(VARIANT_BOOL* value);
HRESULT put_Enabled(VARIANT_BOOL value);
[ANSI C]
HRESULT IIviSpecAnExternalMixer_get_Enabled(IIviSpecAnExternalMixer* This, VARIANT_BOOL* value);
HRESULT IIviSpecAnExternalMixer_put_Enabled(IIviSpecAnExternalMixer* This, VARIANT_BOOL value);
[C#]
public bool Enabled {get; set;}

Capability Group

IviSpecAnExternalMixer

Also In This Interface

Bias | ConversionLossTable | Harmonic | AverageConversionLoss | Enabled | NumberOfPorts | Configure | IIviSpecAnExternalMixer Overview


NumberOfPorts Property

IIviSpecAnExternalMixer.NumberOfPorts Property

Specifies a two-port mixer or a three-port mixer.

[Visual Basic]
Property Get NumberOfPorts() As Long
Property Let NumberOfPorts(value As Long)
[C++]
HRESULT get_NumberOfPorts(long* value);
HRESULT put_NumberOfPorts(long value);
[ANSI C]
HRESULT IIviSpecAnExternalMixer_get_NumberOfPorts(IIviSpecAnExternalMixer* This, long* value);
HRESULT IIviSpecAnExternalMixer_put_NumberOfPorts(IIviSpecAnExternalMixer* This, long value);
[C#]
public long NumberOfPorts {get; set;}

Capability Group

IviSpecAnExternalMixer

Also In This Interface

Bias | ConversionLossTable | Harmonic | AverageConversionLoss | Enabled | NumberOfPorts | Configure | IIviSpecAnExternalMixer Overview


Configure Method

IIviSpecAnExternalMixer.Configure Method

This function specifies the mixer harmonic number and average conversion loss.

[Visual Basic]
Sub Configure( _
   Harmonic As Long, _
   AverageConversionLoss As Double _
)
[C++]
HRESULT Configure(
   long Harmonic,
   double AverageConversionLoss
);
[ANSI C]
HRESULT IIviSpecAnExternalMixer_Configure(
   IIviSpecAnExternalMixer* This
   long Harmonic,
   double AverageConversionLoss
);
[C#]
public void Configure(
   long Harmonic,
   double AverageConversionLoss
);

Parameters

Harmonic
Specifies the harmonic number. The driver uses this value to set the External Mixer Harmonic attribute.
AverageConversionLoss
Specifies the average conversion loss. The driver uses this value to set the External Mixer Average Conversion Loss attribute.

Capability Group

IviSpecAnExternalMixer

Related Items

Harmonic | AverageConversionLoss

Also In This Interface

Bias | ConversionLossTable | Harmonic | AverageConversionLoss | Enabled | NumberOfPorts | Configure | IIviSpecAnExternalMixer Overview


IIviSpecAnExternalMixerBias Interface

IVI SpecAn class-compliant external mixer bias interface

Properties

Level | Specifies the bias current in amps.
Limit | Specifies the bias current limit.
Enabled | Turns bias on/off.

Methods

Configure This function configures the external mixer bias and the external mixer bias limit.


Level Property

IIviSpecAnExternalMixerBias.Level Property

Specifies the bias current in amps.

[Visual Basic]
Property Get Level() As Double
Property Let Level(value As Double)
[C++]
HRESULT get_Level(double* value);
HRESULT put_Level(double value);
[ANSI C]
HRESULT IIviSpecAnExternalMixerBias_get_Level(IIviSpecAnExternalMixerBias* This, double* value);
HRESULT IIviSpecAnExternalMixerBias_put_Level(IIviSpecAnExternalMixerBias* This, double value);
[C#]
public double Level {get; set;}

Capability Group

IviSpecAnExternalMixer

Related Items

Configure

Also In This Interface

Level | Limit | Enabled | Configure | IIviSpecAnExternalMixerBias Overview


Limit Property

IIviSpecAnExternalMixerBias.Limit Property

Specifies the bias current limit.

[Visual Basic]
Property Get Limit() As Double
Property Let Limit(value As Double)
[C++]
HRESULT get_Limit(double* value);
HRESULT put_Limit(double value);
[ANSI C]
HRESULT IIviSpecAnExternalMixerBias_get_Limit(IIviSpecAnExternalMixerBias* This, double* value);
HRESULT IIviSpecAnExternalMixerBias_put_Limit(IIviSpecAnExternalMixerBias* This, double value);
[C#]
public double Limit {get; set;}

Capability Group

IviSpecAnExternalMixer

Related Items

Configure

Also In This Interface

Level | Limit | Enabled | Configure | IIviSpecAnExternalMixerBias Overview


Enabled Property

IIviSpecAnExternalMixerBias.Enabled Property

Turns bias on/off.

[Visual Basic]
Property Get Enabled() As Boolean
Property Let Enabled(value As Boolean)
[C++]
HRESULT get_Enabled(VARIANT_BOOL* value);
HRESULT put_Enabled(VARIANT_BOOL value);
[ANSI C]
HRESULT IIviSpecAnExternalMixerBias_get_Enabled(IIviSpecAnExternalMixerBias* This, VARIANT_BOOL* value);
HRESULT IIviSpecAnExternalMixerBias_put_Enabled(IIviSpecAnExternalMixerBias* This, VARIANT_BOOL value);
[C#]
public bool Enabled {get; set;}

Capability Group

IviSpecAnExternalMixer

Also In This Interface

Level | Limit | Enabled | Configure | IIviSpecAnExternalMixerBias Overview


Configure Method

IIviSpecAnExternalMixerBias.Configure Method

This function configures the external mixer bias and the external mixer bias limit.

[Visual Basic]
Sub Configure( _
   Bias As Double, _
   BiasLimit As Double _
)
[C++]
HRESULT Configure(
   double Bias,
   double BiasLimit
);
[ANSI C]
HRESULT IIviSpecAnExternalMixerBias_Configure(
   IIviSpecAnExternalMixerBias* This
   double Bias,
   double BiasLimit
);
[C#]
public void Configure(
   double Bias,
   double BiasLimit
);

Parameters

Bias
Specifies the bias current. The driver uses this value to set the External Mixer Bias attribute.
BiasLimit
Specifies the bias current limit. The driver uses this value to set the External Mixer Bias Limit attribute.

Capability Group

IviSpecAnExternalMixer

Related Items

Level | Limit

Also In This Interface

Level | Limit | Enabled | Configure | IIviSpecAnExternalMixerBias Overview


IIviSpecAnExternalMixerConversionLossTable Interface

IVI SpecAn class-compliant external mixer conversion loss table interface

Properties

Enabled Turns the external mixer conversion loss table on/off.

Methods

Configure This function configures the conversion loss table by specifying a frequency and a power loss pair.


Enabled Property

IIviSpecAnExternalMixerConversionLossTable.Enabled Property

Turns the external mixer conversion loss table on/off.

[Visual Basic]
Property Get Enabled() As Boolean
Property Let Enabled(value As Boolean)
[C++]
HRESULT get_Enabled(VARIANT_BOOL* value);
HRESULT put_Enabled(VARIANT_BOOL value);
[ANSI C]
HRESULT IIviSpecAnExternalMixerConversionLossTable_get_Enabled(IIviSpecAnExternalMixerConversionLossTable* This, VARIANT_BOOL* value);
HRESULT IIviSpecAnExternalMixerConversionLossTable_put_Enabled(IIviSpecAnExternalMixerConversionLossTable* This, VARIANT_BOOL value);
[C#]
public bool Enabled {get; set;}

Capability Group

IviSpecAnExternalMixer

Also In This Interface

Enabled | Configure | IIviSpecAnExternalMixerConversionLossTable Overview


Configure Method

IIviSpecAnExternalMixerConversionLossTable.Configure Method

This function configures the conversion loss table by specifying a frequency and a power loss pair.

[Visual Basic]
Sub Configure( _
   Frequency As SAFEARRAY(double)*, _
   ConversionLoss As SAFEARRAY(double)* _
)
[C++]
HRESULT Configure(
   SAFEARRAY(double)* Frequency,
   SAFEARRAY(double)* ConversionLoss
);
[ANSI C]
HRESULT IIviSpecAnExternalMixerConversionLossTable_Configure(
   IIviSpecAnExternalMixerConversionLossTable* This
   SAFEARRAY(double)* Frequency,
   SAFEARRAY(double)* ConversionLoss
);
[C#]
public void Configure(
   Array Frequency,
   Array ConversionLoss
);

Parameters

Frequency
Specifies the frequency values for the pairs.
ConversionLoss
Specifies the conversion loss values for the pairs.

Capability Group

IviSpecAnExternalMixer

Also In This Interface

Enabled | Configure | IIviSpecAnExternalMixerConversionLossTable Overview


IIviSpecAnFrequency Interface

IVI SpecAn class-compliant frequency interface

Properties

Start | Specifies the left edge of frequency domain in Hertz.
Stop | Specifies the right edge of frequency domain in Hertz.
Offset | Specifies an offset that is added to the frequency readout to account for external frequency conversion.

Methods

ConfigureCenterSpan | This function configures the frequency range defining the center frequency and the frequency span. If the span corresponds to zero Hertz, then the spectrum analyzer operates in time-domain mode. Otherwise, the spectrum analyzer operates in frequency-domain mode. Frequency Start = CenterFrequency - Span / 2 Frequency Stop = CenterFrequency + Span / 2
ConfigureStartStop | This function configures the frequency range defining its start frequency and its stop frequency. If the start frequency is equal to the stop frequency, then the spectrum analyzer operates in time-domain mode. Otherwise, the spectrum analyzer operates in frequency-domain mode.


Start Property

IIviSpecAnFrequency.Start Property

Specifies the left edge of frequency domain in Hertz.

[Visual Basic]
Property Get Start() As Double
Property Let Start(value As Double)
[C++]
HRESULT get_Start(double* value);
HRESULT put_Start(double value);
[ANSI C]
HRESULT IIviSpecAnFrequency_get_Start(IIviSpecAnFrequency* This, double* value);
HRESULT IIviSpecAnFrequency_put_Start(IIviSpecAnFrequency* This, double value);
[C#]
public double Start {get; set;}

Capability Group

IviSpecAnBase

Related Items

ConfigureStartStop | ConfigureCenterSpan

Also In This Interface

Start | Stop | Offset | ConfigureCenterSpan | ConfigureStartStop | IIviSpecAnFrequency Overview


Stop Property

IIviSpecAnFrequency.Stop Property

Specifies the right edge of frequency domain in Hertz.

[Visual Basic]
Property Get Stop() As Double
Property Let Stop(value As Double)
[C++]
HRESULT get_Stop(double* value);
HRESULT put_Stop(double value);
[ANSI C]
HRESULT IIviSpecAnFrequency_get_Stop(IIviSpecAnFrequency* This, double* value);
HRESULT IIviSpecAnFrequency_put_Stop(IIviSpecAnFrequency* This, double value);
[C#]
public double Stop {get; set;}

Capability Group

IviSpecAnBase

Related Items

ConfigureStartStop | ConfigureCenterSpan

Also In This Interface

Start | Stop | Offset | ConfigureCenterSpan | ConfigureStartStop | IIviSpecAnFrequency Overview


Offset Property

IIviSpecAnFrequency.Offset Property

Specifies an offset that is added to the frequency readout to account for external frequency conversion.

[Visual Basic]
Property Get Offset() As Double
Property Let Offset(value As Double)
[C++]
HRESULT get_Offset(double* value);
HRESULT put_Offset(double value);
[ANSI C]
HRESULT IIviSpecAnFrequency_get_Offset(IIviSpecAnFrequency* This, double* value);
HRESULT IIviSpecAnFrequency_put_Offset(IIviSpecAnFrequency* This, double value);
[C#]
public double Offset {get; set;}

Capability Group

IviSpecAnBase

Also In This Interface

Start | Stop | Offset | ConfigureCenterSpan | ConfigureStartStop | IIviSpecAnFrequency Overview


ConfigureCenterSpan Method

IIviSpecAnFrequency.ConfigureCenterSpan Method

This function configures the frequency range defining the center frequency and the frequency span. If the span corresponds to zero Hertz, then the spectrum analyzer operates in time-domain mode. Otherwise, the spectrum analyzer operates in frequency-domain mode.

Frequency Start = CenterFrequency - Span / 2

Frequency Stop = CenterFrequency + Span / 2

[Visual Basic]
Sub ConfigureCenterSpan( _
   CenterFrequency As Double, _
   Span As Double _
)
[C++]
HRESULT ConfigureCenterSpan(
   double CenterFrequency,
   double Span
);
[ANSI C]
HRESULT IIviSpecAnFrequency_ConfigureCenterSpan(
   IIviSpecAnFrequency* This
   double CenterFrequency,
   double Span
);
[C#]
public void ConfigureCenterSpan(
   double CenterFrequency,
   double Span
);

Parameters

CenterFrequency
Specifies the center frequency of the frequency sweep. The units are Hertz.
Span
Specifies the frequency span of the frequency sweep. The units are Hertz.

Capability Group

IviSpecAnBase

Related Items

Start | Stop | ConfigureStartStop

Also In This Interface

Start | Stop | Offset | ConfigureCenterSpan | ConfigureStartStop | IIviSpecAnFrequency Overview


ConfigureStartStop Method

IIviSpecAnFrequency.ConfigureStartStop Method

This function configures the frequency range defining its start frequency and its stop frequency. If the start frequency is equal to the stop frequency, then the spectrum analyzer operates in time-domain mode. Otherwise, the spectrum analyzer operates in frequency-domain mode.

[Visual Basic]
Sub ConfigureStartStop( _
   StartFrequency As Double, _
   StopFrequency As Double _
)
[C++]
HRESULT ConfigureStartStop(
   double StartFrequency,
   double StopFrequency
);
[ANSI C]
HRESULT IIviSpecAnFrequency_ConfigureStartStop(
   IIviSpecAnFrequency* This
   double StartFrequency,
   double StopFrequency
);
[C#]
public void ConfigureStartStop(
   double StartFrequency,
   double StopFrequency
);

Parameters

StartFrequency
Specifies the left edge of frequency domain in Hertz.
StopFrequency
Specifies the right edge of frequency domain in Hertz.

Capability Group

IviSpecAnBase

Related Items

Start | Stop | ConfigureCenterSpan

Also In This Interface

Start | Stop | Offset | ConfigureCenterSpan | ConfigureStartStop | IIviSpecAnFrequency Overview


IIviSpecAnLevel Interface

IVI SpecAn class-compliant level interface

Properties

AmplitudeUnits | Specifies the amplitude units for input, output and display amplitude.
InputImpedance | Specifies the value of input impedance expected at the active input port.
Reference | Specifies the reference level.
ReferenceOffset | Adds an offset to the displayed reference level.
AttenuationAuto | Turns attenuation aut on/off.
Attenuation | Specifies the input attenuation (in positive dB).

Methods

Configure This function configures the vertical attributes of the IviSpecAn.


AmplitudeUnits Property

IIviSpecAnLevel.AmplitudeUnits Property

Specifies the amplitude units for input, output and display amplitude.

[Visual Basic]
Property Get AmplitudeUnits() As IviSpecAnAmplitudeUnitsEnum
Property Let AmplitudeUnits(value As IviSpecAnAmplitudeUnitsEnum)
[C++]
HRESULT get_AmplitudeUnits(IviSpecAnAmplitudeUnitsEnum* value);
HRESULT put_AmplitudeUnits(IviSpecAnAmplitudeUnitsEnum value);
[ANSI C]
HRESULT IIviSpecAnLevel_get_AmplitudeUnits(IIviSpecAnLevel* This, IviSpecAnAmplitudeUnitsEnum* value);
HRESULT IIviSpecAnLevel_put_AmplitudeUnits(IIviSpecAnLevel* This, IviSpecAnAmplitudeUnitsEnum value);
[C#]
public IviSpecAnAmplitudeUnitsEnum AmplitudeUnits {get; set;}

Capability Group

IviSpecAnBase

Related Items

Configure

Also In This Interface

AmplitudeUnits | InputImpedance | Reference | ReferenceOffset | AttenuationAuto | Attenuation | Configure | IIviSpecAnLevel Overview


InputImpedance Property

IIviSpecAnLevel.InputImpedance Property

Specifies the value of input impedance expected at the active input port.

[Visual Basic]
Property Get InputImpedance() As Double
Property Let InputImpedance(value As Double)
[C++]
HRESULT get_InputImpedance(double* value);
HRESULT put_InputImpedance(double value);
[ANSI C]
HRESULT IIviSpecAnLevel_get_InputImpedance(IIviSpecAnLevel* This, double* value);
HRESULT IIviSpecAnLevel_put_InputImpedance(IIviSpecAnLevel* This, double value);
[C#]
public double InputImpedance {get; set;}

Capability Group

IviSpecAnBase

Related Items

Configure

Also In This Interface

AmplitudeUnits | InputImpedance | Reference | ReferenceOffset | AttenuationAuto | Attenuation | Configure | IIviSpecAnLevel Overview


Reference Property

IIviSpecAnLevel.Reference Property

Specifies the reference level.

[Visual Basic]
Property Get Reference() As Double
Property Let Reference(value As Double)
[C++]
HRESULT get_Reference(double* value);
HRESULT put_Reference(double value);
[ANSI C]
HRESULT IIviSpecAnLevel_get_Reference(IIviSpecAnLevel* This, double* value);
HRESULT IIviSpecAnLevel_put_Reference(IIviSpecAnLevel* This, double value);
[C#]
public double Reference {get; set;}

Capability Group

IviSpecAnBase

Related Items

Configure

Also In This Interface

AmplitudeUnits | InputImpedance | Reference | ReferenceOffset | AttenuationAuto | Attenuation | Configure | IIviSpecAnLevel Overview


ReferenceOffset Property

IIviSpecAnLevel.ReferenceOffset Property

Adds an offset to the displayed reference level.

[Visual Basic]
Property Get ReferenceOffset() As Double
Property Let ReferenceOffset(value As Double)
[C++]
HRESULT get_ReferenceOffset(double* value);
HRESULT put_ReferenceOffset(double value);
[ANSI C]
HRESULT IIviSpecAnLevel_get_ReferenceOffset(IIviSpecAnLevel* This, double* value);
HRESULT IIviSpecAnLevel_put_ReferenceOffset(IIviSpecAnLevel* This, double value);
[C#]
public double ReferenceOffset {get; set;}

Capability Group

IviSpecAnBase

Related Items

Configure

Also In This Interface

AmplitudeUnits | InputImpedance | Reference | ReferenceOffset | AttenuationAuto | Attenuation | Configure | IIviSpecAnLevel Overview


AttenuationAuto Property

IIviSpecAnLevel.AttenuationAuto Property

Turns attenuation aut on/off.

[Visual Basic]
Property Get AttenuationAuto() As Boolean
Property Let AttenuationAuto(value As Boolean)
[C++]
HRESULT get_AttenuationAuto(VARIANT_BOOL* value);
HRESULT put_AttenuationAuto(VARIANT_BOOL value);
[ANSI C]
HRESULT IIviSpecAnLevel_get_AttenuationAuto(IIviSpecAnLevel* This, VARIANT_BOOL* value);
HRESULT IIviSpecAnLevel_put_AttenuationAuto(IIviSpecAnLevel* This, VARIANT_BOOL value);
[C#]
public bool AttenuationAuto {get; set;}

Capability Group

IviSpecAnBase

Related Items

Configure

Also In This Interface

AmplitudeUnits | InputImpedance | Reference | ReferenceOffset | AttenuationAuto | Attenuation | Configure | IIviSpecAnLevel Overview


Attenuation Property

IIviSpecAnLevel.Attenuation Property

Specifies the input attenuation (in positive dB).

[Visual Basic]
Property Get Attenuation() As Double
Property Let Attenuation(value As Double)
[C++]
HRESULT get_Attenuation(double* value);
HRESULT put_Attenuation(double value);
[ANSI C]
HRESULT IIviSpecAnLevel_get_Attenuation(IIviSpecAnLevel* This, double* value);
HRESULT IIviSpecAnLevel_put_Attenuation(IIviSpecAnLevel* This, double value);
[C#]
public double Attenuation {get; set;}

Capability Group

IviSpecAnBase

Related Items

Configure

Also In This Interface

AmplitudeUnits | InputImpedance | Reference | ReferenceOffset | AttenuationAuto | Attenuation | Configure | IIviSpecAnLevel Overview


Configure Method

IIviSpecAnLevel.Configure Method

This function configures the vertical attributes of the IviSpecAn.

[Visual Basic]
Sub Configure( _
   AmplitudeUnits As IviSpecAnAmplitudeUnitsEnum, _
   InputImpedance As Double, _
   ReferenceLevel As Double, _
   ReferenceLevelOffset As Double, _
   AttenuationAuto As Boolean, _
   Attenuation As Double _
)
[C++]
HRESULT Configure(
   IviSpecAnAmplitudeUnitsEnum AmplitudeUnits,
   double InputImpedance,
   double ReferenceLevel,
   double ReferenceLevelOffset,
   VARIANT_BOOL AttenuationAuto,
   double Attenuation
);
[ANSI C]
HRESULT IIviSpecAnLevel_Configure(
   IIviSpecAnLevel* This
   IviSpecAnAmplitudeUnitsEnum AmplitudeUnits,
   double InputImpedance,
   double ReferenceLevel,
   double ReferenceLevelOffset,
   VARIANT_BOOL AttenuationAuto,
   double Attenuation
);
[C#]
public void Configure(
   IviSpecAnAmplitudeUnitsEnum AmplitudeUnits,
   double InputImpedance,
   double ReferenceLevel,
   double ReferenceLevelOffset,
   bool AttenuationAuto,
   double Attenuation
);

Parameters

AmplitudeUnits
Specifies the amplitude units for input, output and display amplitude.
InputImpedance
Specifies the value of input impedance expected at the active input port.
ReferenceLevel
Specifies the reference level.
ReferenceLevelOffset
Adds an offset to the displayed reference level.
AttenuationAuto
Turns attenuation aut on/off.
Attenuation
Specifies the input attenuation (in positive dB).

Capability Group

IviSpecAnBase

Related Items

AmplitudeUnits | InputImpedance | AttenuationAuto | Attenuation

Also In This Interface

AmplitudeUnits | InputImpedance | Reference | ReferenceOffset | AttenuationAuto | Attenuation | Configure | IIviSpecAnLevel Overview


IIviSpecAnMarker Interface

IVI SpecAn class-compliant marker interface

Properties

FrequencyCounter | Pointer to the class-compliant IIviSpecAnMarkerFrequencyCounter interface
ActiveMarker | Establishes the active marker.
Amplitude | Returns the amplitude of the active marker.
Enabled | Enables/disables the active marker.
Type | Specifies the marker type of the active marker.
Count | Specifies the number of markers available for a particular instrument.
Name | Returns the marker name for a given index.
PeakExcursion | Specifies the minimum amplitude variation of the signal in dB that the marker can identify as a peak.
Position | Specifies the frequency or time position of the active marker.
ReferencePosition | Returns the reference marker position when the active marker is a delta marker.
ReferenceAmplitude | Returns the reference marker amplitude when the active marker is a delta marker.
SignalTrackEnabled | Enables/disables signal tracking.
Threshold | Specifies the lower limit for the marker search functions.
Trace | Specifies the trace for the active marker.

Methods

ConfigureEnabled | This function enables/disables the active marker on the specified trace.
ConfigureSearch | This function configures the marker peak excursion and marker threshold attribute values.
DisableAll | This function turns off all the markers.
MakeDelta | This function specifies whether the active marker is a delta marker.
Search | This function specifies the type of marker search and performs the search.
Query | This function returns the horizontal position and the marker amplitude level of the Active Marker.
QueryReference | This function returns the horizontal position and the marker amplitude level of the reference marker when the active marker is a delta marker.
SetInstrumentFromMarker | This function makes the Active Marker frequency to be the start, stop, or center frequency. It can also make the active marker amplitude to be the reference level.


FrequencyCounter Property

IIviSpecAnMarker.FrequencyCounter Property

Pointer to the class-compliant IIviSpecAnMarkerFrequencyCounter interface

[Visual Basic]
Property Get FrequencyCounter() As IIviSpecAnMarkerFrequencyCounter
[C++]
HRESULT get_FrequencyCounter(IIviSpecAnMarkerFrequencyCounter** value);
[ANSI C]
HRESULT IIviSpecAnMarker_get_FrequencyCounter(IIviSpecAnMarker* This, IIviSpecAnMarkerFrequencyCounter** value);
[C#]
public IIviSpecAnMarkerFrequencyCounter FrequencyCounter {get;}

Capability Group

IviSpecAnMarker

Also In This Interface

FrequencyCounter | ActiveMarker | Amplitude | Enabled | Type | Count | Name | PeakExcursion | Position | ReferencePosition | ReferenceAmplitude | SignalTrackEnabled | Threshold | Trace | ConfigureEnabled | ConfigureSearch | DisableAll | MakeDelta | Search | Query | QueryReference | SetInstrumentFromMarker | IIviSpecAnMarker Overview


ActiveMarker Property

IIviSpecAnMarker.ActiveMarker Property

Establishes the active marker.

[Visual Basic]
Property Get ActiveMarker() As String
Property Let ActiveMarker(value As String)
[C++]
HRESULT get_ActiveMarker(BSTR* value);
HRESULT put_ActiveMarker(BSTR value);
[ANSI C]
HRESULT IIviSpecAnMarker_get_ActiveMarker(IIviSpecAnMarker* This, BSTR* value);
HRESULT IIviSpecAnMarker_put_ActiveMarker(IIviSpecAnMarker* This, BSTR value);
[C#]
public string ActiveMarker {get; set;}

Capability Group

IviSpecAnMarker

Also In This Interface

FrequencyCounter | ActiveMarker | Amplitude | Enabled | Type | Count | Name | PeakExcursion | Position | ReferencePosition | ReferenceAmplitude | SignalTrackEnabled | Threshold | Trace | ConfigureEnabled | ConfigureSearch | DisableAll | MakeDelta | Search | Query | QueryReference | SetInstrumentFromMarker | IIviSpecAnMarker Overview


Amplitude Property

IIviSpecAnMarker.Amplitude Property

Returns the amplitude of the active marker.

[Visual Basic]
Property Get Amplitude() As Double
[C++]
HRESULT get_Amplitude(double* value);
[ANSI C]
HRESULT IIviSpecAnMarker_get_Amplitude(IIviSpecAnMarker* This, double* value);
[C#]
public double Amplitude {get;}

Capability Group

IviSpecAnMarker

Related Items

Query

Also In This Interface

FrequencyCounter | ActiveMarker | Amplitude | Enabled | Type | Count | Name | PeakExcursion | Position | ReferencePosition | ReferenceAmplitude | SignalTrackEnabled | Threshold | Trace | ConfigureEnabled | ConfigureSearch | DisableAll | MakeDelta | Search | Query | QueryReference | SetInstrumentFromMarker | IIviSpecAnMarker Overview


Enabled Property

IIviSpecAnMarker.Enabled Property

Enables/disables the active marker.

[Visual Basic]
Property Get Enabled() As Boolean
Property Let Enabled(value As Boolean)
[C++]
HRESULT get_Enabled(VARIANT_BOOL* value);
HRESULT put_Enabled(VARIANT_BOOL value);
[ANSI C]
HRESULT IIviSpecAnMarker_get_Enabled(IIviSpecAnMarker* This, VARIANT_BOOL* value);
HRESULT IIviSpecAnMarker_put_Enabled(IIviSpecAnMarker* This, VARIANT_BOOL value);
[C#]
public bool Enabled {get; set;}

Capability Group

IviSpecAnMarker

Related Items

ConfigureEnabled

Also In This Interface

FrequencyCounter | ActiveMarker | Amplitude | Enabled | Type | Count | Name | PeakExcursion | Position | ReferencePosition | ReferenceAmplitude | SignalTrackEnabled | Threshold | Trace | ConfigureEnabled | ConfigureSearch | DisableAll | MakeDelta | Search | Query | QueryReference | SetInstrumentFromMarker | IIviSpecAnMarker Overview


Type Property

IIviSpecAnMarker.Type Property

Specifies the marker type of the active marker.

[Visual Basic]
Property Get Type() As IviSpecAnMarkerTypeEnum
[C++]
HRESULT get_Type(IviSpecAnMarkerTypeEnum* value);
[ANSI C]
HRESULT IIviSpecAnMarker_get_Type(IIviSpecAnMarker* This, IviSpecAnMarkerTypeEnum* value);
[C#]
public IviSpecAnMarkerTypeEnum Type {get;}

Capability Group

IviSpecAnDeltaMarker

Related Items

MakeDelta

Also In This Interface

FrequencyCounter | ActiveMarker | Amplitude | Enabled | Type | Count | Name | PeakExcursion | Position | ReferencePosition | ReferenceAmplitude | SignalTrackEnabled | Threshold | Trace | ConfigureEnabled | ConfigureSearch | DisableAll | MakeDelta | Search | Query | QueryReference | SetInstrumentFromMarker | IIviSpecAnMarker Overview


Count Property

IIviSpecAnMarker.Count Property

Specifies the number of markers available for a particular instrument.

[Visual Basic]
Property Get Count() As Long
[C++]
HRESULT get_Count(long* value);
[ANSI C]
HRESULT IIviSpecAnMarker_get_Count(IIviSpecAnMarker* This, long* value);
[C#]
public long Count {get;}

Capability Group

IviSpecAnMarker

Also In This Interface

FrequencyCounter | ActiveMarker | Amplitude | Enabled | Type | Count | Name | PeakExcursion | Position | ReferencePosition | ReferenceAmplitude | SignalTrackEnabled | Threshold | Trace | ConfigureEnabled | ConfigureSearch | DisableAll | MakeDelta | Search | Query | QueryReference | SetInstrumentFromMarker | IIviSpecAnMarker Overview


Name Property

IIviSpecAnMarker.Name Property

Returns the marker name for a given index.

[Visual Basic]
Property Get Name(Index As Long) As String
[C++]
HRESULT get_Name(long Index, BSTR* value);
[ANSI C]
HRESULT IIviSpecAnMarker_get_Name(IIviSpecAnMarker* This, long Index, BSTR* value);
[C#]HRESULT get_Name(long Index, string value);

Parameters

Index
A one-based index that defines which name to return.

Capability Group

IviSpecAnMarker

Also In This Interface

FrequencyCounter | ActiveMarker | Amplitude | Enabled | Type | Count | Name | PeakExcursion | Position | ReferencePosition | ReferenceAmplitude | SignalTrackEnabled | Threshold | Trace | ConfigureEnabled | ConfigureSearch | DisableAll | MakeDelta | Search | Query | QueryReference | SetInstrumentFromMarker | IIviSpecAnMarker Overview


PeakExcursion Property

IIviSpecAnMarker.PeakExcursion Property

Specifies the minimum amplitude variation of the signal in dB that the marker can identify as a peak.

[Visual Basic]
Property Get PeakExcursion() As Double
Property Let PeakExcursion(value As Double)
[C++]
HRESULT get_PeakExcursion(double* value);
HRESULT put_PeakExcursion(double value);
[ANSI C]
HRESULT IIviSpecAnMarker_get_PeakExcursion(IIviSpecAnMarker* This, double* value);
HRESULT IIviSpecAnMarker_put_PeakExcursion(IIviSpecAnMarker* This, double value);
[C#]
public double PeakExcursion {get; set;}

Capability Group

IviSpecAnMarker

Related Items

ConfigureSearch

Also In This Interface

FrequencyCounter | ActiveMarker | Amplitude | Enabled | Type | Count | Name | PeakExcursion | Position | ReferencePosition | ReferenceAmplitude | SignalTrackEnabled | Threshold | Trace | ConfigureEnabled | ConfigureSearch | DisableAll | MakeDelta | Search | Query | QueryReference | SetInstrumentFromMarker | IIviSpecAnMarker Overview


Position Property

IIviSpecAnMarker.Position Property

Specifies the frequency or time position of the active marker.

[Visual Basic]
Property Get Position() As Double
Property Let Position(value As Double)
[C++]
HRESULT get_Position(double* value);
HRESULT put_Position(double value);
[ANSI C]
HRESULT IIviSpecAnMarker_get_Position(IIviSpecAnMarker* This, double* value);
HRESULT IIviSpecAnMarker_put_Position(IIviSpecAnMarker* This, double value);
[C#]
public double Position {get; set;}

Capability Group

IviSpecAnMarker

Related Items

Query

Also In This Interface

FrequencyCounter | ActiveMarker | Amplitude | Enabled | Type | Count | Name | PeakExcursion | Position | ReferencePosition | ReferenceAmplitude | SignalTrackEnabled | Threshold | Trace | ConfigureEnabled | ConfigureSearch | DisableAll | MakeDelta | Search | Query | QueryReference | SetInstrumentFromMarker | IIviSpecAnMarker Overview


ReferencePosition Property

IIviSpecAnMarker.ReferencePosition Property

Returns the reference marker position when the active marker is a delta marker.

[Visual Basic]
Property Get ReferencePosition() As Double
[C++]
HRESULT get_ReferencePosition(double* value);
[ANSI C]
HRESULT IIviSpecAnMarker_get_ReferencePosition(IIviSpecAnMarker* This, double* value);
[C#]
public double ReferencePosition {get;}

Capability Group

IviSpecAnDeltaMarker

Also In This Interface

FrequencyCounter | ActiveMarker | Amplitude | Enabled | Type | Count | Name | PeakExcursion | Position | ReferencePosition | ReferenceAmplitude | SignalTrackEnabled | Threshold | Trace | ConfigureEnabled | ConfigureSearch | DisableAll | MakeDelta | Search | Query | QueryReference | SetInstrumentFromMarker | IIviSpecAnMarker Overview


ReferenceAmplitude Property

IIviSpecAnMarker.ReferenceAmplitude Property

Returns the reference marker amplitude when the active marker is a delta marker.

[Visual Basic]
Property Get ReferenceAmplitude() As Double
[C++]
HRESULT get_ReferenceAmplitude(double* value);
[ANSI C]
HRESULT IIviSpecAnMarker_get_ReferenceAmplitude(IIviSpecAnMarker* This, double* value);
[C#]
public double ReferenceAmplitude {get;}

Capability Group

IviSpecAnDeltaMarker

Also In This Interface

FrequencyCounter | ActiveMarker | Amplitude | Enabled | Type | Count | Name | PeakExcursion | Position | ReferencePosition | ReferenceAmplitude | SignalTrackEnabled | Threshold | Trace | ConfigureEnabled | ConfigureSearch | DisableAll | MakeDelta | Search | Query | QueryReference | SetInstrumentFromMarker | IIviSpecAnMarker Overview


SignalTrackEnabled Property

IIviSpecAnMarker.SignalTrackEnabled Property

Enables/disables signal tracking.

[Visual Basic]
Property Get SignalTrackEnabled() As Boolean
Property Let SignalTrackEnabled(value As Boolean)
[C++]
HRESULT get_SignalTrackEnabled(VARIANT_BOOL* value);
HRESULT put_SignalTrackEnabled(VARIANT_BOOL value);
[ANSI C]
HRESULT IIviSpecAnMarker_get_SignalTrackEnabled(IIviSpecAnMarker* This, VARIANT_BOOL* value);
HRESULT IIviSpecAnMarker_put_SignalTrackEnabled(IIviSpecAnMarker* This, VARIANT_BOOL value);
[C#]
public bool SignalTrackEnabled {get; set;}

Capability Group

IviSpecAnMarker

Also In This Interface

FrequencyCounter | ActiveMarker | Amplitude | Enabled | Type | Count | Name | PeakExcursion | Position | ReferencePosition | ReferenceAmplitude | SignalTrackEnabled | Threshold | Trace | ConfigureEnabled | ConfigureSearch | DisableAll | MakeDelta | Search | Query | QueryReference | SetInstrumentFromMarker | IIviSpecAnMarker Overview


Threshold Property

IIviSpecAnMarker.Threshold Property

Specifies the lower limit for the marker search functions.

[Visual Basic]
Property Get Threshold() As Double
Property Let Threshold(value As Double)
[C++]
HRESULT get_Threshold(double* value);
HRESULT put_Threshold(double value);
[ANSI C]
HRESULT IIviSpecAnMarker_get_Threshold(IIviSpecAnMarker* This, double* value);
HRESULT IIviSpecAnMarker_put_Threshold(IIviSpecAnMarker* This, double value);
[C#]
public double Threshold {get; set;}

Capability Group

IviSpecAnMarker

Related Items

ConfigureSearch

Also In This Interface

FrequencyCounter | ActiveMarker | Amplitude | Enabled | Type | Count | Name | PeakExcursion | Position | ReferencePosition | ReferenceAmplitude | SignalTrackEnabled | Threshold | Trace | ConfigureEnabled | ConfigureSearch | DisableAll | MakeDelta | Search | Query | QueryReference | SetInstrumentFromMarker | IIviSpecAnMarker Overview


Trace Property

IIviSpecAnMarker.Trace Property

Specifies the trace for the active marker.

[Visual Basic]
Property Get Trace() As String
Property Let Trace(value As String)
[C++]
HRESULT get_Trace(BSTR* value);
HRESULT put_Trace(BSTR value);
[ANSI C]
HRESULT IIviSpecAnMarker_get_Trace(IIviSpecAnMarker* This, BSTR* value);
HRESULT IIviSpecAnMarker_put_Trace(IIviSpecAnMarker* This, BSTR value);
[C#]
public string Trace {get; set;}

Capability Group

IviSpecAnMarker

Related Items

ConfigureEnabled

Also In This Interface

FrequencyCounter | ActiveMarker | Amplitude | Enabled | Type | Count | Name | PeakExcursion | Position | ReferencePosition | ReferenceAmplitude | SignalTrackEnabled | Threshold | Trace | ConfigureEnabled | ConfigureSearch | DisableAll | MakeDelta | Search | Query | QueryReference | SetInstrumentFromMarker | IIviSpecAnMarker Overview


ConfigureEnabled Method

IIviSpecAnMarker.ConfigureEnabled Method

This function enables/disables the active marker on the specified trace.

[Visual Basic]
Sub ConfigureEnabled( _
   Enabled As Boolean, _
   MarkerTraceName As String _
)
[C++]
HRESULT ConfigureEnabled(
   VARIANT_BOOL Enabled,
   BSTR MarkerTraceName
);
[ANSI C]
HRESULT IIviSpecAnMarker_ConfigureEnabled(
   IIviSpecAnMarker* This
   VARIANT_BOOL Enabled,
   BSTR MarkerTraceName
);
[C#]
public void ConfigureEnabled(
   bool Enabled,
   string MarkerTraceName
);

Parameters

Enabled
Enables or disables the active marker. The driver uses this value to set the Marker Enabled attribute.
MarkerTraceName
Specifies the trace name. The driver uses this value to set the Marker Trace attribute.

Capability Group

IviSpecAnMarker

Related Items

Enabled | Trace

Also In This Interface

FrequencyCounter | ActiveMarker | Amplitude | Enabled | Type | Count | Name | PeakExcursion | Position | ReferencePosition | ReferenceAmplitude | SignalTrackEnabled | Threshold | Trace | ConfigureEnabled | ConfigureSearch | DisableAll | MakeDelta | Search | Query | QueryReference | SetInstrumentFromMarker | IIviSpecAnMarker Overview


ConfigureSearch Method

IIviSpecAnMarker.ConfigureSearch Method

This function configures the marker peak excursion and marker threshold attribute values.

[Visual Basic]
Sub ConfigureSearch( _
   PeakExcursion As Double, _
   MarkerThreshold As Double _
)
[C++]
HRESULT ConfigureSearch(
   double PeakExcursion,
   double MarkerThreshold
);
[ANSI C]
HRESULT IIviSpecAnMarker_ConfigureSearch(
   IIviSpecAnMarker* This
   double PeakExcursion,
   double MarkerThreshold
);
[C#]
public void ConfigureSearch(
   double PeakExcursion,
   double MarkerThreshold
);

Parameters

PeakExcursion
Minimum amplitude variation of the signal that the marker can recognize as a peak in dB. The driver uses this value to set the Peak Excursion attribute.
MarkerThreshold
Minimum amplitude below which a peak will not be detected. The driver uses this value to set the Marker Threshold attribute.

Capability Group

IviSpecAnMarker

Related Items

PeakExcursion | Threshold | Search

Also In This Interface

FrequencyCounter | ActiveMarker | Amplitude | Enabled | Type | Count | Name | PeakExcursion | Position | ReferencePosition | ReferenceAmplitude | SignalTrackEnabled | Threshold | Trace | ConfigureEnabled | ConfigureSearch | DisableAll | MakeDelta | Search | Query | QueryReference | SetInstrumentFromMarker | IIviSpecAnMarker Overview


DisableAll Method

IIviSpecAnMarker.DisableAll Method

This function turns off all the markers.

[Visual Basic]
Sub DisableAll()
[C++]
HRESULT DisableAll();
[ANSI C]
HRESULT IIviSpecAnMarker_DisableAll(
   IIviSpecAnMarker* This);
[C#]
public void DisableAll();

Capability Group

IviSpecAnMarker

Also In This Interface

FrequencyCounter | ActiveMarker | Amplitude | Enabled | Type | Count | Name | PeakExcursion | Position | ReferencePosition | ReferenceAmplitude | SignalTrackEnabled | Threshold | Trace | ConfigureEnabled | ConfigureSearch | DisableAll | MakeDelta | Search | Query | QueryReference | SetInstrumentFromMarker | IIviSpecAnMarker Overview


MakeDelta Method

IIviSpecAnMarker.MakeDelta Method

This function specifies whether the active marker is a delta marker.

[Visual Basic]
Sub MakeDelta( _
   DeltaMarker As Boolean _
)
[C++]
HRESULT MakeDelta(
   VARIANT_BOOL DeltaMarker
);
[ANSI C]
HRESULT IIviSpecAnMarker_MakeDelta(
   IIviSpecAnMarker* This
   VARIANT_BOOL DeltaMarker
);
[C#]
public void MakeDelta(
   bool DeltaMarker
);

Parameters

DeltaMarker
Enables or disables delta marker mode. The driver uses this value to set the Marker Type attribute.

Capability Group

IviSpecAnDeltaMarker

Related Items

Type

Also In This Interface

FrequencyCounter | ActiveMarker | Amplitude | Enabled | Type | Count | Name | PeakExcursion | Position | ReferencePosition | ReferenceAmplitude | SignalTrackEnabled | Threshold | Trace | ConfigureEnabled | ConfigureSearch | DisableAll | MakeDelta | Search | Query | QueryReference | SetInstrumentFromMarker | IIviSpecAnMarker Overview


Search Method

IIviSpecAnMarker.Search Method

This function specifies the type of marker search and performs the search.

[Visual Basic]
Sub Search( _
   SearchType As IviSpecAnMarkerSearchEnum _
)
[C++]
HRESULT Search(
   IviSpecAnMarkerSearchEnum SearchType
);
[ANSI C]
HRESULT IIviSpecAnMarker_Search(
   IIviSpecAnMarker* This
   IviSpecAnMarkerSearchEnum SearchType
);
[C#]
public void Search(
   IviSpecAnMarkerSearchEnum SearchType
);

Parameters

SearchType
Specifies the type of marker search.

Capability Group

IviSpecAnMarker

Related Items

ConfigureSearch

Also In This Interface

FrequencyCounter | ActiveMarker | Amplitude | Enabled | Type | Count | Name | PeakExcursion | Position | ReferencePosition | ReferenceAmplitude | SignalTrackEnabled | Threshold | Trace | ConfigureEnabled | ConfigureSearch | DisableAll | MakeDelta | Search | Query | QueryReference | SetInstrumentFromMarker | IIviSpecAnMarker Overview


Query Method

IIviSpecAnMarker.Query Method

This function returns the horizontal position and the marker amplitude level of the Active Marker.

[Visual Basic]
Sub Query( _
   MarkerPosition As Double, _
   MarkerAmplitude As Double _
)
[C++]
HRESULT Query(
   double* MarkerPosition,
   double* MarkerAmplitude
);
[ANSI C]
HRESULT IIviSpecAnMarker_Query(
   IIviSpecAnMarker* This
   double* MarkerPosition,
   double* MarkerAmplitude
);
[C#]
public void Query(
   double MarkerPosition,
   double MarkerAmplitude
);

Parameters

MarkerPosition
Returns the Marker Position attribute.
MarkerAmplitude
Returns the Marker Amplitude attribute.

Capability Group

IviSpecAnMarker

Related Items

Amplitude | Position

Also In This Interface

FrequencyCounter | ActiveMarker | Amplitude | Enabled | Type | Count | Name | PeakExcursion | Position | ReferencePosition | ReferenceAmplitude | SignalTrackEnabled | Threshold | Trace | ConfigureEnabled | ConfigureSearch | DisableAll | MakeDelta | Search | Query | QueryReference | SetInstrumentFromMarker | IIviSpecAnMarker Overview


QueryReference Method

IIviSpecAnMarker.QueryReference Method

This function returns the horizontal position and the marker amplitude level of the reference marker when the active marker is a delta marker.

[Visual Basic]
Sub QueryReference( _
   ReferencePosition As Double, _
   ReferenceAmplitude As Double _
)
[C++]
HRESULT QueryReference(
   double* ReferencePosition,
   double* ReferenceAmplitude
);
[ANSI C]
HRESULT IIviSpecAnMarker_QueryReference(
   IIviSpecAnMarker* This
   double* ReferencePosition,
   double* ReferenceAmplitude
);
[C#]
public void QueryReference(
   double ReferencePosition,
   double ReferenceAmplitude
);

Parameters

ReferencePosition
Returns the Reference Marker Amplitude attribute value.
ReferenceAmplitude
Returns the Reference Marker Position attribute value.

Capability Group

IviSpecAnDeltaMarker

Related Items

Amplitude | Position

Also In This Interface

FrequencyCounter | ActiveMarker | Amplitude | Enabled | Type | Count | Name | PeakExcursion | Position | ReferencePosition | ReferenceAmplitude | SignalTrackEnabled | Threshold | Trace | ConfigureEnabled | ConfigureSearch | DisableAll | MakeDelta | Search | Query | QueryReference | SetInstrumentFromMarker | IIviSpecAnMarker Overview


SetInstrumentFromMarker Method

IIviSpecAnMarker.SetInstrumentFromMarker Method

This function makes the Active Marker frequency to be the start, stop, or center frequency. It can also make the active marker amplitude to be the reference level.

[Visual Basic]
Sub SetInstrumentFromMarker( _
   InstrumentSetting As IviSpecAnInstrumentSettingEnum _
)
[C++]
HRESULT SetInstrumentFromMarker(
   IviSpecAnInstrumentSettingEnum InstrumentSetting
);
[ANSI C]
HRESULT IIviSpecAnMarker_SetInstrumentFromMarker(
   IIviSpecAnMarker* This
   IviSpecAnInstrumentSettingEnum InstrumentSetting
);
[C#]
public void SetInstrumentFromMarker(
   IviSpecAnInstrumentSettingEnum InstrumentSetting
);

Parameters

InstrumentSetting
Specifies the instrument setting to be set from the marker position.

Capability Group

IviSpecAnMarker

Also In This Interface

FrequencyCounter | ActiveMarker | Amplitude | Enabled | Type | Count | Name | PeakExcursion | Position | ReferencePosition | ReferenceAmplitude | SignalTrackEnabled | Threshold | Trace | ConfigureEnabled | ConfigureSearch | DisableAll | MakeDelta | Search | Query | QueryReference | SetInstrumentFromMarker | IIviSpecAnMarker Overview


IIviSpecAnMarkerFrequencyCounter Interface

IVI SpecAn class-compliant marker frequency counter interface

Properties

Enabled | This function activates/deactivates the marker counter.
Resolution | Specifies the resolution of the frequency counter in Hertz.

Methods

Configure This function sets the marker frequency counter resolution and turns the marker frequency counter on/off.


Enabled Property

IIviSpecAnMarkerFrequencyCounter.Enabled Property

This function activates/deactivates the marker counter.

[Visual Basic]
Property Get Enabled() As Boolean
Property Let Enabled(value As Boolean)
[C++]
HRESULT get_Enabled(VARIANT_BOOL* value);
HRESULT put_Enabled(VARIANT_BOOL value);
[ANSI C]
HRESULT IIviSpecAnMarkerFrequencyCounter_get_Enabled(IIviSpecAnMarkerFrequencyCounter* This, VARIANT_BOOL* value);
HRESULT IIviSpecAnMarkerFrequencyCounter_put_Enabled(IIviSpecAnMarkerFrequencyCounter* This, VARIANT_BOOL value);
[C#]
public bool Enabled {get; set;}

Capability Group

IviSpecAnMarker

Related Items

Configure

Also In This Interface

Enabled | Resolution | Configure | IIviSpecAnMarkerFrequencyCounter Overview


Resolution Property

IIviSpecAnMarkerFrequencyCounter.Resolution Property

Specifies the resolution of the frequency counter in Hertz.

[Visual Basic]
Property Get Resolution() As Double
Property Let Resolution(value As Double)
[C++]
HRESULT get_Resolution(double* value);
HRESULT put_Resolution(double value);
[ANSI C]
HRESULT IIviSpecAnMarkerFrequencyCounter_get_Resolution(IIviSpecAnMarkerFrequencyCounter* This, double* value);
HRESULT IIviSpecAnMarkerFrequencyCounter_put_Resolution(IIviSpecAnMarkerFrequencyCounter* This, double value);
[C#]
public double Resolution {get; set;}

Capability Group

IviSpecAnMarker

Related Items

Configure

Also In This Interface

Enabled | Resolution | Configure | IIviSpecAnMarkerFrequencyCounter Overview


Configure Method

IIviSpecAnMarkerFrequencyCounter.Configure Method

This function sets the marker frequency counter resolution and turns the marker frequency counter on/off.

[Visual Basic]
Sub Configure( _
   Enabled As Boolean, _
   Resolution As Double _
)
[C++]
HRESULT Configure(
   VARIANT_BOOL Enabled,
   double Resolution
);
[ANSI C]
HRESULT IIviSpecAnMarkerFrequencyCounter_Configure(
   IIviSpecAnMarkerFrequencyCounter* This
   VARIANT_BOOL Enabled,
   double Resolution
);
[C#]
public void Configure(
   bool Enabled,
   double Resolution
);

Parameters

Enabled
Enables or disables the marker frequency counter. The driver uses this value to set the Marker Frequency Counter Enabled attribute.
Resolution
Specifies the frequency counter resolution in Hertz. This value is ignored when Enabled is False. The driver uses this value to set the Marker Frequency Counter Resolution attribute.

Capability Group

IviSpecAnMarker

Related Items

Enabled | Resolution

Also In This Interface

Enabled | Resolution | Configure | IIviSpecAnMarkerFrequencyCounter Overview


IIviSpecAnPreselector Interface

IVI SpecAn class-compliant preselector interface

Methods

Peak This function adjusts the preselector to obtain the maximum readings for the current start and stop frequency.


Peak Method

IIviSpecAnPreselector.Peak Method

This function adjusts the preselector to obtain the maximum readings for the current start and stop frequency.

[Visual Basic]
Sub Peak()
[C++]
HRESULT Peak();
[ANSI C]
HRESULT IIviSpecAnPreselector_Peak(
   IIviSpecAnPreselector* This);
[C#]
public void Peak();

Capability Group

IviSpecAnPreselector

Also In This Interface

Peak | IIviSpecAnPreselector Overview


IIviSpecAnSweepCoupling Interface

IVI SpecAn class-compliant sweep coupling interface

Properties

ResolutionBandwidthAuto | Turns resolution bandwith auto coupling on/off.
ResolutionBandwidth | Specifies the width of the IF filter in Hertz.
VideoBandwidthAuto | Turns video bandwith auto coupling on/off.
VideoBandwidth | Specifies the video bandwidth of the post-detection filter in Hertz.
SweepTimeAuto | Turns sweep time auto coupling on/off.
SweepTime | Specifies the length of time (in seconds) to sweep from the beginning to the end of the current domain.

Methods

Configure This function configures the coupling and sweeping attributes of the IviSpecAn.


ResolutionBandwidthAuto Property

IIviSpecAnSweepCoupling.ResolutionBandwidthAuto Property

Turns resolution bandwith auto coupling on/off.

[Visual Basic]
Property Get ResolutionBandwidthAuto() As Boolean
Property Let ResolutionBandwidthAuto(value As Boolean)
[C++]
HRESULT get_ResolutionBandwidthAuto(VARIANT_BOOL* value);
HRESULT put_ResolutionBandwidthAuto(VARIANT_BOOL value);
[ANSI C]
HRESULT IIviSpecAnSweepCoupling_get_ResolutionBandwidthAuto(IIviSpecAnSweepCoupling* This, VARIANT_BOOL* value);
HRESULT IIviSpecAnSweepCoupling_put_ResolutionBandwidthAuto(IIviSpecAnSweepCoupling* This, VARIANT_BOOL value);
[C#]
public bool ResolutionBandwidthAuto {get; set;}

Capability Group

IviSpecAnBase

Related Items

Configure

Also In This Interface

ResolutionBandwidthAuto | ResolutionBandwidth | VideoBandwidthAuto | VideoBandwidth | SweepTimeAuto | SweepTime | Configure | IIviSpecAnSweepCoupling Overview


ResolutionBandwidth Property

IIviSpecAnSweepCoupling.ResolutionBandwidth Property

Specifies the width of the IF filter in Hertz.

[Visual Basic]
Property Get ResolutionBandwidth() As Double
Property Let ResolutionBandwidth(value As Double)
[C++]
HRESULT get_ResolutionBandwidth(double* value);
HRESULT put_ResolutionBandwidth(double value);
[ANSI C]
HRESULT IIviSpecAnSweepCoupling_get_ResolutionBandwidth(IIviSpecAnSweepCoupling* This, double* value);
HRESULT IIviSpecAnSweepCoupling_put_ResolutionBandwidth(IIviSpecAnSweepCoupling* This, double value);
[C#]
public double ResolutionBandwidth {get; set;}

Capability Group

IviSpecAnBase

Related Items

Configure

Also In This Interface

ResolutionBandwidthAuto | ResolutionBandwidth | VideoBandwidthAuto | VideoBandwidth | SweepTimeAuto | SweepTime | Configure | IIviSpecAnSweepCoupling Overview


VideoBandwidthAuto Property

IIviSpecAnSweepCoupling.VideoBandwidthAuto Property

Turns video bandwith auto coupling on/off.

[Visual Basic]
Property Get VideoBandwidthAuto() As Boolean
Property Let VideoBandwidthAuto(value As Boolean)
[C++]
HRESULT get_VideoBandwidthAuto(VARIANT_BOOL* value);
HRESULT put_VideoBandwidthAuto(VARIANT_BOOL value);
[ANSI C]
HRESULT IIviSpecAnSweepCoupling_get_VideoBandwidthAuto(IIviSpecAnSweepCoupling* This, VARIANT_BOOL* value);
HRESULT IIviSpecAnSweepCoupling_put_VideoBandwidthAuto(IIviSpecAnSweepCoupling* This, VARIANT_BOOL value);
[C#]
public bool VideoBandwidthAuto {get; set;}

Capability Group

IviSpecAnBase

Related Items

Configure

Also In This Interface

ResolutionBandwidthAuto | ResolutionBandwidth | VideoBandwidthAuto | VideoBandwidth | SweepTimeAuto | SweepTime | Configure | IIviSpecAnSweepCoupling Overview


VideoBandwidth Property

IIviSpecAnSweepCoupling.VideoBandwidth Property

Specifies the video bandwidth of the post-detection filter in Hertz.

[Visual Basic]
Property Get VideoBandwidth() As Double
Property Let VideoBandwidth(value As Double)
[C++]
HRESULT get_VideoBandwidth(double* value);
HRESULT put_VideoBandwidth(double value);
[ANSI C]
HRESULT IIviSpecAnSweepCoupling_get_VideoBandwidth(IIviSpecAnSweepCoupling* This, double* value);
HRESULT IIviSpecAnSweepCoupling_put_VideoBandwidth(IIviSpecAnSweepCoupling* This, double value);
[C#]
public double VideoBandwidth {get; set;}

Capability Group

IviSpecAnBase

Related Items

Configure

Also In This Interface

ResolutionBandwidthAuto | ResolutionBandwidth | VideoBandwidthAuto | VideoBandwidth | SweepTimeAuto | SweepTime | Configure | IIviSpecAnSweepCoupling Overview


SweepTimeAuto Property

IIviSpecAnSweepCoupling.SweepTimeAuto Property

Turns sweep time auto coupling on/off.

[Visual Basic]
Property Get SweepTimeAuto() As Boolean
Property Let SweepTimeAuto(value As Boolean)
[C++]
HRESULT get_SweepTimeAuto(VARIANT_BOOL* value);
HRESULT put_SweepTimeAuto(VARIANT_BOOL value);
[ANSI C]
HRESULT IIviSpecAnSweepCoupling_get_SweepTimeAuto(IIviSpecAnSweepCoupling* This, VARIANT_BOOL* value);
HRESULT IIviSpecAnSweepCoupling_put_SweepTimeAuto(IIviSpecAnSweepCoupling* This, VARIANT_BOOL value);
[C#]
public bool SweepTimeAuto {get; set;}

Capability Group

IviSpecAnBase

Related Items

Configure

Also In This Interface

ResolutionBandwidthAuto | ResolutionBandwidth | VideoBandwidthAuto | VideoBandwidth | SweepTimeAuto | SweepTime | Configure | IIviSpecAnSweepCoupling Overview


SweepTime Property

IIviSpecAnSweepCoupling.SweepTime Property

Specifies the length of time (in seconds) to sweep from the beginning to the end of the current domain.

[Visual Basic]
Property Get SweepTime() As Double
Property Let SweepTime(value As Double)
[C++]
HRESULT get_SweepTime(double* value);
HRESULT put_SweepTime(double value);
[ANSI C]
HRESULT IIviSpecAnSweepCoupling_get_SweepTime(IIviSpecAnSweepCoupling* This, double* value);
HRESULT IIviSpecAnSweepCoupling_put_SweepTime(IIviSpecAnSweepCoupling* This, double value);
[C#]
public double SweepTime {get; set;}

Capability Group

IviSpecAnBase

Related Items

Configure

Also In This Interface

ResolutionBandwidthAuto | ResolutionBandwidth | VideoBandwidthAuto | VideoBandwidth | SweepTimeAuto | SweepTime | Configure | IIviSpecAnSweepCoupling Overview


Configure Method

IIviSpecAnSweepCoupling.Configure Method

This function configures the coupling and sweeping attributes of the IviSpecAn.

[Visual Basic]
Sub Configure( _
   ResolutionBandwidthAuto As Boolean, _
   ResolutionBandwidth As Double, _
   VideoBandwidthAuto As Boolean, _
   VideoBandwidth As Double, _
   SweepTimeAuto As Boolean, _
   SweepTime As Double _
)
[C++]
HRESULT Configure(
   VARIANT_BOOL ResolutionBandwidthAuto,
   double ResolutionBandwidth,
   VARIANT_BOOL VideoBandwidthAuto,
   double VideoBandwidth,
   VARIANT_BOOL SweepTimeAuto,
   double SweepTime
);
[ANSI C]
HRESULT IIviSpecAnSweepCoupling_Configure(
   IIviSpecAnSweepCoupling* This
   VARIANT_BOOL ResolutionBandwidthAuto,
   double ResolutionBandwidth,
   VARIANT_BOOL VideoBandwidthAuto,
   double VideoBandwidth,
   VARIANT_BOOL SweepTimeAuto,
   double SweepTime
);
[C#]
public void Configure(
   bool ResolutionBandwidthAuto,
   double ResolutionBandwidth,
   bool VideoBandwidthAuto,
   double VideoBandwidth,
   bool SweepTimeAuto,
   double SweepTime
);

Parameters

ResolutionBandwidthAuto
Turns resolution bandwith auto coupling on/off.
ResolutionBandwidth
Specifies the width of the IF filter in Hertz.
VideoBandwidthAuto
Turns video bandwith auto coupling on/off.
VideoBandwidth
Specifies the video bandwidth of the post-detection filter in Hertz.
SweepTimeAuto
Turns sweep time auto coupling on/off.
SweepTime
Specifies the length of time (in seconds) to sweep from the beginning to the end of the current domain.

Capability Group

IviSpecAnBase

Related Items

ResolutionBandwidthAuto | ResolutionBandwidth | VideoBandwidthAuto | VideoBandwidth | SweepTimeAuto | SweepTime

Also In This Interface

ResolutionBandwidthAuto | ResolutionBandwidth | VideoBandwidthAuto | VideoBandwidth | SweepTimeAuto | SweepTime | Configure | IIviSpecAnSweepCoupling Overview


IIviSpecAnTrace Interface

IVI SpecAn class-compliant trace interface

Properties

Size | Returns the number of points in the trace array.
Type | Specifies the representation of the aquired data.

Methods

FetchY | This function returns the trace the spectrum analyzer aquires.
ReadY | This function initiates a signal acquisition, waits for the completion, and returns the trace as amplitude array.


Size Property

IIviSpecAnTrace.Size Property

Returns the number of points in the trace array.

[Visual Basic]
Property Get Size() As Long
[C++]
HRESULT get_Size(long* value);
[ANSI C]
HRESULT IIviSpecAnTrace_get_Size(IIviSpecAnTrace* This, long* value);
[C#]
public long Size {get;}

Capability Group

IviSpecAnBase

Also In This Interface

Size | Type | FetchY | ReadY | IIviSpecAnTrace Overview


Type Property

IIviSpecAnTrace.Type Property

Specifies the representation of the aquired data.

[Visual Basic]
Property Get Type() As IviSpecAnTraceTypeEnum
Property Let Type(value As IviSpecAnTraceTypeEnum)
[C++]
HRESULT get_Type(IviSpecAnTraceTypeEnum* value);
HRESULT put_Type(IviSpecAnTraceTypeEnum value);
[ANSI C]
HRESULT IIviSpecAnTrace_get_Type(IIviSpecAnTrace* This, IviSpecAnTraceTypeEnum* value);
HRESULT IIviSpecAnTrace_put_Type(IIviSpecAnTrace* This, IviSpecAnTraceTypeEnum value);
[C#]
public IviSpecAnTraceTypeEnum Type {get; set;}

Capability Group

IviSpecAnBase

Also In This Interface

Size | Type | FetchY | ReadY | IIviSpecAnTrace Overview


FetchY Method

IIviSpecAnTrace.FetchY Method

This function returns the trace the spectrum analyzer aquires.

[Visual Basic]
Sub FetchY( _
   Amplitude As SAFEARRAY(double) _
)
[C++]
HRESULT FetchY(
   SAFEARRAY(double)* Amplitude
);
[ANSI C]
HRESULT IIviSpecAnTrace_FetchY(
   IIviSpecAnTrace* This
   SAFEARRAY(double)* Amplitude
);
[C#]
public void FetchY(
   Array Amplitude
);

Parameters

Amplitude
Specifies a driver-allocated buffer into which the trace amplitudes are stored.

Capability Group

IviSpecAnBase

Also In This Interface

Size | Type | FetchY | ReadY | IIviSpecAnTrace Overview


ReadY Method

IIviSpecAnTrace.ReadY Method

This function initiates a signal acquisition, waits for the completion, and returns the trace as amplitude array.

[Visual Basic]
Sub ReadY( _
   MaxTimeMilliseconds As Long, _
   Amplitude As SAFEARRAY(double) _
)
[C++]
HRESULT ReadY(
   long MaxTimeMilliseconds,
   SAFEARRAY(double)* Amplitude
);
[ANSI C]
HRESULT IIviSpecAnTrace_ReadY(
   IIviSpecAnTrace* This
   long MaxTimeMilliseconds,
   SAFEARRAY(double)* Amplitude
);
[C#]
public void ReadY(
   long MaxTimeMilliseconds,
   Array Amplitude
);

Parameters

MaxTimeMilliseconds
Specifies the maximum length of time allowed for the function to complete in milliseconds.
Amplitude
Specifies a driver-allocated buffer into which the trace amplitudes are stored.

Capability Group

IviSpecAnBase

Also In This Interface

Size | Type | FetchY | ReadY | IIviSpecAnTrace Overview


IIviSpecAnTraces Interface

IVI SpecAn class-compliant trace collection interface

Properties

Math | Pointer to the class-compliant IIviSpecAnTracesMath interface
Item | Returns an interface reference pointer to an IIviSpecAnTrace interface.
Count | Returns the number of traces.
Name | Returns the trace name for a given index.

Methods

Abort | This function aborts a previously initiated measurement.
Initiate | This function initiates an acquisition.
AcquisitionStatus | This function determines if an acquisition is in progress or complete.
SendSoftwareTrigger | This function generates a software trigger.


Math Property

IIviSpecAnTraces.Math Property

Pointer to the class-compliant IIviSpecAnTracesMath interface

[Visual Basic]
Property Get Math() As IIviSpecAnTracesMath
[C++]
HRESULT get_Math(IIviSpecAnTracesMath** value);
[ANSI C]
HRESULT IIviSpecAnTraces_get_Math(IIviSpecAnTraces* This, IIviSpecAnTracesMath** value);
[C#]
public IIviSpecAnTracesMath Math {get;}

Capability Group

IviSpecAnBase

Also In This Interface

Math | Item | Count | Name | Abort | Initiate | AcquisitionStatus | SendSoftwareTrigger | IIviSpecAnTraces Overview


Item Property

IIviSpecAnTraces.Item Property

Returns an interface reference pointer to an IIviSpecAnTrace interface.

[Visual Basic]
Property Get Item(Name As String) As IIviSpecAnTrace
[C++]
HRESULT get_Item(BSTR Name, IIviSpecAnTrace** value);
[ANSI C]
HRESULT IIviSpecAnTraces_get_Item(IIviSpecAnTraces* This, BSTR Name, IIviSpecAnTrace** value);
[C#]HRESULT get_Item(string Name, IIviSpecAnTrace value);

Parameters

Name
Specifies the name of the trace whos interface pointer is to be returned.

Capability Group

IviSpecAnBase

Also In This Interface

Math | Item | Count | Name | Abort | Initiate | AcquisitionStatus | SendSoftwareTrigger | IIviSpecAnTraces Overview


Count Property

IIviSpecAnTraces.Count Property

Returns the number of traces.

[Visual Basic]
Property Get Count() As Long
[C++]
HRESULT get_Count(long* value);
[ANSI C]
HRESULT IIviSpecAnTraces_get_Count(IIviSpecAnTraces* This, long* value);
[C#]
public long Count {get;}

Capability Group

IviSpecAnBase

Also In This Interface

Math | Item | Count | Name | Abort | Initiate | AcquisitionStatus | SendSoftwareTrigger | IIviSpecAnTraces Overview


Name Property

IIviSpecAnTraces.Name Property

Returns the trace name for a given index.

[Visual Basic]
Property Get Name(Index As Long) As String
[C++]
HRESULT get_Name(long Index, BSTR* value);
[ANSI C]
HRESULT IIviSpecAnTraces_get_Name(IIviSpecAnTraces* This, long Index, BSTR* value);
[C#]HRESULT get_Name(long Index, string value);

Parameters

Index
A one-based index that defines which name to return.

Capability Group

IviSpecAnBase

Also In This Interface

Math | Item | Count | Name | Abort | Initiate | AcquisitionStatus | SendSoftwareTrigger | IIviSpecAnTraces Overview


Abort Method

IIviSpecAnTraces.Abort Method

This function aborts a previously initiated measurement.

[Visual Basic]
Sub Abort()
[C++]
HRESULT Abort();
[ANSI C]
HRESULT IIviSpecAnTraces_Abort(
   IIviSpecAnTraces* This);
[C#]
public void Abort();

Capability Group

IviSpecAnBase

Also In This Interface

Math | Item | Count | Name | Abort | Initiate | AcquisitionStatus | SendSoftwareTrigger | IIviSpecAnTraces Overview


Initiate Method

IIviSpecAnTraces.Initiate Method

This function initiates an acquisition.

[Visual Basic]
Sub Initiate()
[C++]
HRESULT Initiate();
[ANSI C]
HRESULT IIviSpecAnTraces_Initiate(
   IIviSpecAnTraces* This);
[C#]
public void Initiate();

Capability Group

IviSpecAnBase

Also In This Interface

Math | Item | Count | Name | Abort | Initiate | AcquisitionStatus | SendSoftwareTrigger | IIviSpecAnTraces Overview


AcquisitionStatus Method

IIviSpecAnTraces.AcquisitionStatus Method

This function determines if an acquisition is in progress or complete.

[Visual Basic]
Function AcquisitionStatus() As IviSpecAnAcquisitionStatusEnum
[C++]
HRESULT AcquisitionStatus(
   IviSpecAnAcquisitionStatusEnum* pVal
);
[ANSI C]
HRESULT IIviSpecAnTraces_AcquisitionStatus(
   IIviSpecAnTraces* This
   IviSpecAnAcquisitionStatusEnum* pVal
);
[C#]
public IviSpecAnAcquisitionStatusEnum AcquisitionStatus();

Parameters

pVal
Returns the acquisition status.

Capability Group

IviSpecAnBase

Also In This Interface

Math | Item | Count | Name | Abort | Initiate | AcquisitionStatus | SendSoftwareTrigger | IIviSpecAnTraces Overview


SendSoftwareTrigger Method

IIviSpecAnTraces.SendSoftwareTrigger Method

This function generates a software trigger.

[Visual Basic]
Sub SendSoftwareTrigger()
[C++]
HRESULT SendSoftwareTrigger();
[ANSI C]
HRESULT IIviSpecAnTraces_SendSoftwareTrigger(
   IIviSpecAnTraces* This);
[C#]
public void SendSoftwareTrigger();

Capability Group

IviSpecAnSendSoftwareTrigger

Also In This Interface

Math | Item | Count | Name | Abort | Initiate | AcquisitionStatus | SendSoftwareTrigger | IIviSpecAnTraces Overview


IIviSpecAnTracesMath Interface

IVI SpecAn class-compliant traces math interface

Methods

Add | This function adds Trace 1 and Trace 2 and stores the result in the Destination Trace.
Copy | This function copies one trace array to another trace array.
Exchange | This function exchanges the data arrays of two traces.
Subtract | This function subtracts the array elements of Trace 2 from Trace 1 and stores the result in the Destination Trace.


Add Method

IIviSpecAnTracesMath.Add Method

This function adds Trace 1 and Trace 2 and stores the result in the Destination Trace.

[Visual Basic]
Sub Add( _
   DestinationTrace As String, _
   Trace1 As String, _
   Trace2 As String _
)
[C++]
HRESULT Add(
   BSTR DestinationTrace,
   BSTR Trace1,
   BSTR Trace2
);
[ANSI C]
HRESULT IIviSpecAnTracesMath_Add(
   IIviSpecAnTracesMath* This
   BSTR DestinationTrace,
   BSTR Trace1,
   BSTR Trace2
);
[C#]
public void Add(
   string DestinationTrace,
   string Trace1,
   string Trace2
);

Parameters

DestinationTrace
Specifies the name of the result.
Trace1
Specifies the name of first trace operand.
Trace2
Specifies the name of the second trace operand.

Capability Group

IviSpecAnMultitrace

Also In This Interface

Add | Copy | Exchange | Subtract | IIviSpecAnTracesMath Overview


Copy Method

IIviSpecAnTracesMath.Copy Method

This function copies one trace array to another trace array.

[Visual Basic]
Sub Copy( _
   DestinationTrace As String, _
   SourceTrace As String _
)
[C++]
HRESULT Copy(
   BSTR DestinationTrace,
   BSTR SourceTrace
);
[ANSI C]
HRESULT IIviSpecAnTracesMath_Copy(
   IIviSpecAnTracesMath* This
   BSTR DestinationTrace,
   BSTR SourceTrace
);
[C#]
public void Copy(
   string DestinationTrace,
   string SourceTrace
);

Parameters

DestinationTrace
Specifies the name of the trace into which the array is copied.
SourceTrace
Specifies the name of the trace to be copied.

Capability Group

IviSpecAnMultitrace

Also In This Interface

Add | Copy | Exchange | Subtract | IIviSpecAnTracesMath Overview


Exchange Method

IIviSpecAnTracesMath.Exchange Method

This function exchanges the data arrays of two traces.

[Visual Basic]
Sub Exchange( _
   Trace1 As String, _
   Trace2 As String _
)
[C++]
HRESULT Exchange(
   BSTR Trace1,
   BSTR Trace2
);
[ANSI C]
HRESULT IIviSpecAnTracesMath_Exchange(
   IIviSpecAnTracesMath* This
   BSTR Trace1,
   BSTR Trace2
);
[C#]
public void Exchange(
   string Trace1,
   string Trace2
);

Parameters

Trace1
Specifies the name of the first trace to be exchanged.
Trace2
Specifies the name of the second trace to be exchanged.

Capability Group

IviSpecAnMultitrace

Also In This Interface

Add | Copy | Exchange | Subtract | IIviSpecAnTracesMath Overview


Subtract Method

IIviSpecAnTracesMath.Subtract Method

This function subtracts the array elements of Trace 2 from Trace 1 and stores the result in the Destination Trace.

[Visual Basic]
Sub Subtract( _
   DestinationTrace As String, _
   Trace1 As String, _
   Trace2 As String _
)
[C++]
HRESULT Subtract(
   BSTR DestinationTrace,
   BSTR Trace1,
   BSTR Trace2
);
[ANSI C]
HRESULT IIviSpecAnTracesMath_Subtract(
   IIviSpecAnTracesMath* This
   BSTR DestinationTrace,
   BSTR Trace1,
   BSTR Trace2
);
[C#]
public void Subtract(
   string DestinationTrace,
   string Trace1,
   string Trace2
);

Parameters

DestinationTrace
Specifies the name of the result trace.
Trace1
Specifies the name of the first trace operand.
Trace2
Specified the name of the second trace operand.

Capability Group

IviSpecAnMultitrace

Also In This Interface

Add | Copy | Exchange | Subtract | IIviSpecAnTracesMath Overview


IIviSpecAnTrigger Interface

IVI SpecAn class-compliant trigger interface

Properties

Source | Specifies the source for the trigger signal that causes the analyzer to leave the Wait-For-Trigger state.
External | Pointer to the class-compliant IIviSpecAnTriggerExternal interface
Video | Pointer to the class-compliant IIviSpecAnTriggerVideo interface


Source Property

IIviSpecAnTrigger.Source Property

Specifies the source for the trigger signal that causes the analyzer to leave the Wait-For-Trigger state.

[Visual Basic]
Property Get Source() As IviSpecAnTriggerSourceEnum
Property Let Source(value As IviSpecAnTriggerSourceEnum)
[C++]
HRESULT get_Source(IviSpecAnTriggerSourceEnum* value);
HRESULT put_Source(IviSpecAnTriggerSourceEnum value);
[ANSI C]
HRESULT IIviSpecAnTrigger_get_Source(IIviSpecAnTrigger* This, IviSpecAnTriggerSourceEnum* value);
HRESULT IIviSpecAnTrigger_put_Source(IIviSpecAnTrigger* This, IviSpecAnTriggerSourceEnum value);
[C#]
public IviSpecAnTriggerSourceEnum Source {get; set;}

Capability Group

IviSpecAnTrigger

Also In This Interface

Source | External | Video | IIviSpecAnTrigger Overview


External Property

IIviSpecAnTrigger.External Property

Pointer to the class-compliant IIviSpecAnTriggerExternal interface

[Visual Basic]
Property Get External() As IIviSpecAnTriggerExternal
[C++]
HRESULT get_External(IIviSpecAnTriggerExternal** value);
[ANSI C]
HRESULT IIviSpecAnTrigger_get_External(IIviSpecAnTrigger* This, IIviSpecAnTriggerExternal** value);
[C#]
public IIviSpecAnTriggerExternal External {get;}

Capability Group

IviSpecAnExternalTrigger

Also In This Interface

Source | External | Video | IIviSpecAnTrigger Overview


Video Property

IIviSpecAnTrigger.Video Property

Pointer to the class-compliant IIviSpecAnTriggerVideo interface

[Visual Basic]
Property Get Video() As IIviSpecAnTriggerVideo
[C++]
HRESULT get_Video(IIviSpecAnTriggerVideo** value);
[ANSI C]
HRESULT IIviSpecAnTrigger_get_Video(IIviSpecAnTrigger* This, IIviSpecAnTriggerVideo** value);
[C#]
public IIviSpecAnTriggerVideo Video {get;}

Capability Group

IviSpecAnVideoTrigger

Also In This Interface

Source | External | Video | IIviSpecAnTrigger Overview


IIviSpecAnTriggerExternal Interface

IVI SpecAn class-compliant trigger external interface

Properties

Level | Specifies the external level for triggering in volts.
Slope | Specifies the external trigger slope.

Methods

Configure This function specifies the external level and slope for triggering.


Level Property

IIviSpecAnTriggerExternal.Level Property

Specifies the external level for triggering in volts.

[Visual Basic]
Property Get Level() As Double
Property Let Level(value As Double)
[C++]
HRESULT get_Level(double* value);
HRESULT put_Level(double value);
[ANSI C]
HRESULT IIviSpecAnTriggerExternal_get_Level(IIviSpecAnTriggerExternal* This, double* value);
HRESULT IIviSpecAnTriggerExternal_put_Level(IIviSpecAnTriggerExternal* This, double value);
[C#]
public double Level {get; set;}

Capability Group

IviSpecAnExternalTrigger

Related Items

Configure

Also In This Interface

Level | Slope | Configure | IIviSpecAnTriggerExternal Overview


Slope Property

IIviSpecAnTriggerExternal.Slope Property

Specifies the external trigger slope.

[Visual Basic]
Property Get Slope() As IviSpecAnExternalTriggerSlopeEnum
Property Let Slope(value As IviSpecAnExternalTriggerSlopeEnum)
[C++]
HRESULT get_Slope(IviSpecAnExternalTriggerSlopeEnum* value);
HRESULT put_Slope(IviSpecAnExternalTriggerSlopeEnum value);
[ANSI C]
HRESULT IIviSpecAnTriggerExternal_get_Slope(IIviSpecAnTriggerExternal* This, IviSpecAnExternalTriggerSlopeEnum* value);
HRESULT IIviSpecAnTriggerExternal_put_Slope(IIviSpecAnTriggerExternal* This, IviSpecAnExternalTriggerSlopeEnum value);
[C#]
public IviSpecAnExternalTriggerSlopeEnum Slope {get; set;}

Capability Group

IviSpecAnExternalTrigger

Related Items

Configure

Also In This Interface

Level | Slope | Configure | IIviSpecAnTriggerExternal Overview


Configure Method

IIviSpecAnTriggerExternal.Configure Method

This function specifies the external level and slope for triggering.

[Visual Basic]
Sub Configure( _
   ExternalTriggerLevel As Double, _
   ExternalTriggerSlope As IviSpecAnExternalTriggerSlopeEnum _
)
[C++]
HRESULT Configure(
   double ExternalTriggerLevel,
   IviSpecAnExternalTriggerSlopeEnum ExternalTriggerSlope
);
[ANSI C]
HRESULT IIviSpecAnTriggerExternal_Configure(
   IIviSpecAnTriggerExternal* This
   double ExternalTriggerLevel,
   IviSpecAnExternalTriggerSlopeEnum ExternalTriggerSlope
);
[C#]
public void Configure(
   double ExternalTriggerLevel,
   IviSpecAnExternalTriggerSlopeEnum ExternalTriggerSlope
);

Parameters

ExternalTriggerLevel
Specifies the level, in volts, that the external trigger signal shall reach to trigger the acquisition. The driver uses this value to set the External Trigger Level attribute.
ExternalTriggerSlope
Specifies which slope of the external trigger signal triggers the acquisition. The driver uses this value to set the External Trigger Slope attribute.

Capability Group

IviSpecAnExternalTrigger

Related Items

Level | Slope

Also In This Interface

Level | Slope | Configure | IIviSpecAnTriggerExternal Overview


IIviSpecAnTriggerVideo Interface

IVI SpecAn class-compliant trigger video interface

Properties

Level | Specifies the video level for triggering in the units specified by the Amplitude Units attribute.
Slope | Specifies the video trigger slope.

Methods

Configure This function specifies the video level and slope for triggering.


Level Property

IIviSpecAnTriggerVideo.Level Property

Specifies the video level for triggering in the units specified by the Amplitude Units attribute.

[Visual Basic]
Property Get Level() As Double
Property Let Level(value As Double)
[C++]
HRESULT get_Level(double* value);
HRESULT put_Level(double value);
[ANSI C]
HRESULT IIviSpecAnTriggerVideo_get_Level(IIviSpecAnTriggerVideo* This, double* value);
HRESULT IIviSpecAnTriggerVideo_put_Level(IIviSpecAnTriggerVideo* This, double value);
[C#]
public double Level {get; set;}

Capability Group

IviSpecAnVideoTrigger

Related Items

Configure

Also In This Interface

Level | Slope | Configure | IIviSpecAnTriggerVideo Overview


Slope Property

IIviSpecAnTriggerVideo.Slope Property

Specifies the video trigger slope.

[Visual Basic]
Property Get Slope() As IviSpecAnVideoTriggerSlopeEnum
Property Let Slope(value As IviSpecAnVideoTriggerSlopeEnum)
[C++]
HRESULT get_Slope(IviSpecAnVideoTriggerSlopeEnum* value);
HRESULT put_Slope(IviSpecAnVideoTriggerSlopeEnum value);
[ANSI C]
HRESULT IIviSpecAnTriggerVideo_get_Slope(IIviSpecAnTriggerVideo* This, IviSpecAnVideoTriggerSlopeEnum* value);
HRESULT IIviSpecAnTriggerVideo_put_Slope(IIviSpecAnTriggerVideo* This, IviSpecAnVideoTriggerSlopeEnum value);
[C#]
public IviSpecAnVideoTriggerSlopeEnum Slope {get; set;}

Capability Group

IviSpecAnVideoTrigger

Related Items

Configure

Also In This Interface

Level | Slope | Configure | IIviSpecAnTriggerVideo Overview


Configure Method

IIviSpecAnTriggerVideo.Configure Method

This function specifies the video level and slope for triggering.

[Visual Basic]
Sub Configure( _
   VideoTriggerLevel As Double, _
   VideoTriggerSlope As IviSpecAnVideoTriggerSlopeEnum _
)
[C++]
HRESULT Configure(
   double VideoTriggerLevel,
   IviSpecAnVideoTriggerSlopeEnum VideoTriggerSlope
);
[ANSI C]
HRESULT IIviSpecAnTriggerVideo_Configure(
   IIviSpecAnTriggerVideo* This
   double VideoTriggerLevel,
   IviSpecAnVideoTriggerSlopeEnum VideoTriggerSlope
);
[C#]
public void Configure(
   double VideoTriggerLevel,
   IviSpecAnVideoTriggerSlopeEnum VideoTriggerSlope
);

Parameters

VideoTriggerLevel
Specifies the level that the video signal shall reach to trigger the acquisition. The driver uses this value to set the Video Trigger Level attribute.
VideoTriggerSlope
Specifies which slope of the video signal triggers the acquisition. The driver uses this value to set the Video Trigger Slope attribute.

Capability Group

IviSpecAnVideoTrigger

Related Items

Level | Slope

Also In This Interface

Level | Slope | Configure | IIviSpecAnTriggerVideo Overview


IviSpecAnAcquisitionStatusEnum Enumeration

IVI SpecAn class-compliant values for acquisition status

Members

Member Name | Description
IviSpecAnAcquisitionStatusComplete | The spectrum analyzer has completed the acquisition.
IviSpecAnAcquisitionStatusInProgress | The spectrum analyzer is still acquiring data.
IviSpecAnAcquisitionStatusUnknown | The spectrum analyzer cannot determine the status of the acquisition.


IviSpecAnAmplitudeUnitsEnum Enumeration

IVI SpecAn class-compliant values for Amplitude Units

Members

Member Name | Description
IviSpecAnAmplitudeUnitsDBM | Sets the spectrum analyzer to measure in decibels relative to 1 milliwatt.
IviSpecAnAmplitudeUnitsDBMV | Sets the spectrum analyzer to measure in decibels relative to 1 millivolt.
IviSpecAnAmplitudeUnitsDBUV | Sets the spectrum analyzer to measure in decibels relative to 1 microvolt.
IviSpecAnAmplitudeUnitsVolt | Sets the spectrum analyzer to measure in volts.
IviSpecAnAmplitudeUnitsWatt | Sets the spectrum analyzer to measure in watts.


IviSpecAnDetectorTypeEnum Enumeration

IVI SpecAn class-compliant values for Detector Type

Members

Member Name | Description
IviSpecAnDetectorTypeAutoPeak | Allows the detector to capture better readings by using both positive and negative peak values when noise is present.
IviSpecAnDetectorTypeAverage | Average value of samples taken within the bin for a dedicated point on the display.
IviSpecAnDetectorTypeMaxPeak | Obtains the maximum video signal between the last display point and the present display point.
IviSpecAnDetectorTypeMinPeak | Obtains the minimum video signal between the last display point and the present display point.
IviSpecAnDetectorTypeSample | Pick one point within a bin.
IviSpecAnDetectorTypeRMS | RMS value of samples taken within the bin for a dedicated point on the display.


IviSpecAnErrorCodesEnum Enumeration

IVI SpecAn class defined HRESULTS

Members

Member Name | Description
S_IVISPECAN_MEASURE_UNCALIBRATED | This warning indicates that the data was captured while the spectrum analyzer was in an uncalibrated state.
S_IVISPECAN_OVER_RANGE | This warning indicates that the signal exceeded the input range.
E_IVISPECAN_TRIGGER_NOT_SOFTWARE | The trigger source is not set to software trigger.
E_IVISPECAN_MARKER_NOT_ENABLED | The Active Marker is not enabled.
E_IVISPECAN_NOT_DELTA_MARKER | The Active Marker is not a delta marker.
E_IVISPECAN_MAX_TIME_EXCEEDED | This error indicates that the maximum time was exceeded before the operation completed.


IviSpecAnExternalTriggerSlopeEnum Enumeration

IVI SpecAn class-compliant values for External Trigger Slope

Members

Member Name | Description
IviSpecAnExternalTriggerSlopePositive | Specifies positive slope.
IviSpecAnExternalTriggerSlopeNegative | Specifies negative slope.


IviSpecAnInstrumentSettingEnum Enumeration

IVI SpecAn class-compliant values for Set Value from Marker

Members

Member Name | Description
IviSpecAnInstrumentSettingFrequencyCenter | Sets the center frequency with the Marker Position attribute.
IviSpecAnInstrumentSettingFrequencySpan | Sets the frequency span with the Marker Position attribute. This operation is only valid if the Marker Type attribute is set to Delta.
IviSpecAnInstrumentSettingFrequencyStart | Sets the Frequency Start attribute with the Marker Position attribute.
IviSpecAnInstrumentSettingFrequencyStop | Sets the Frequency Stop attribute with the Marker Position attribute.
IviSpecAnInstrumentSettingReferenceLevel | Sets the Reference Level attribute with the Marker Amplitude attribute.


IviSpecAnMarkerSearchEnum Enumeration

IVI SpecAn class-compliant values for Marker Search

Members

Member Name | Description
IviSpecAnMarkerSearchHighest | Sets marker search for the highest amplitude.
IviSpecAnMarkerSearchMinimum | Sets marker search for the minimum amplitude.
IviSpecAnMarkerSearchNextPeak | Sets marker search for the next highest peak.
IviSpecAnMarkerSearchNextPeakLeft | Sets marker search for the next peak left of the marker position.
IviSpecAnMarkerSearchNextPeakRight | Sets marker search for the next peak right of the marker position.


IviSpecAnMarkerTypeEnum Enumeration

IVI SpecAn class-compliant values for Marker Type

Members

Member Name | Description
IviSpecAnMarkerTypeNormal | Regular marker used to make absolute measurements.
IviSpecAnMarkerTypeDelta | Marker used in conjunction with the reference marker to make relative measurements.


IviSpecAnMaxTimeEnum Enumeration

IVI SpecAn class-compliant values for MaxTime

Members

Member Name | Description
IviSpecAnMaxTimeImmediate | Sets timeout to immediate. The function returns immediately. If no valid measurement value exists, the function returns the Max Time Exceeded error.
IviSpecAnMaxTimeInfinite | Sets timeout to infinite. The function waits indefinitely for the measurement to complete.


IviSpecAnTraceTypeEnum Enumeration

IVI SpecAn class-compliant values for Trace Type

Members

Member Name | Description
IviSpecAnTraceTypeClearWrite | Sets the spectrum analyzer to clear previous sweep data off the display before performing a sweep. Subsequent sweeps may or may not clear the display first, but the data array at the end of the sweep is entirely new.
IviSpecAnTraceTypeMaxHold | Sets the spectrum analyzer to keep the data from either the previous data or the new sweep data, which ever is higher.
IviSpecAnTraceTypeMinHold | Sets the spectrum analyzer to keep the data from either the previous data or the new sweep data, which ever is lower.
IviSpecAnTraceTypeVideoAverage | Sets the spectrum analyzer to maintain a running average of the swept data.
IviSpecAnTraceTypeView | Disables acquisition into this trace but displays the existing trace data.
IviSpecAnTraceTypeStore | Disables acquisition and disables the display of the existing trace data.


IviSpecAnTriggerSourceEnum Enumeration

IVI SpecAn class-compliant values for Trigger Source

Members

Member Name | Description
IviSpecAnTriggerSourceExternal | The spectrum analyzer waits until it receives a trigger on the external trigger connector.
IviSpecAnTriggerSourceImmediate | The spectrum analyzer does not wait for a trigger of any kind.
IviSpecAnTriggerSourceSoftware | The spectrum analyzer waits until the Send Software Trigger function executes.
IviSpecAnTriggerSourceACLine | The spectrum analyzer waits until it receives a trigger on the AC line.
IviSpecAnTriggerSourceVideo | The spectrum analyzer waits until it receives a video level.


IviSpecAnVerticalScaleEnum Enumeration

IVI SpecAn class-compliant values for Vertical Scale

Members

Member Name | Description
IviSpecAnVerticalScaleLinear | Specifies the vertical scale in linear units.
IviSpecAnVerticalScaleLogarithmic | Specifies the vertical scale in logarithmic units.


IviSpecAnVideoTriggerSlopeEnum Enumeration

IVI SpecAn class-compliant values for Video Trigger Slope

Members

Member Name | Description
IviSpecAnVideoTriggerSlopePositive | Specifies positive slope.
IviSpecAnVideoTriggerSlopeNegative | Specifies negative slope.


Topic Not Found

No matching topic was found. The link may be out of date, incorrectly authored, or the topic may not be available in this release.

You may be able to find the topic by using the index or search tab instead.


Inherent Interface

IVI Inherent Interfaces

IIviDriver | IVI Driver root interface
IIviDriverIdentity | IVI Driver identity interface
IIviDriverOperation | IVI Driver operation interface
IIviDriverUtility | IVI Driver utility interface


IviDriver_ErrorCodes Enumeration

IVI Driver (inherent features) defined HRESULTS

Members

Member Name | Description
S_IVI_SUCCESS | Success
E_IVI_CANNOT_RECOVER | Unrecoverable failure
E_IVI_INSTRUMENT_STATUS | Instrument error detected
E_IVI_CANNOT_OPEN_FILE | File could not be opened
E_IVI_READING_FILE | File could not be read
E_IVI_WRITING_FILE | File could not be written
E_IVI_INVALID_PATHNAME | The path name is invalid
E_IVI_INVALID_VALUE | Invalid value for parameter or property
E_IVI_METHOD_NOT_SUPPORTED | Method not supported
E_IVI_PROPERTY_NOT_SUPPORTED | Property not supported
E_IVI_VALUE_NOT_SUPPORTED | The enumeration value for the parameter is not supported
E_IVI_NOT_INITIALIZED | A connection to the instrument has not been initialized
E_IVI_UNKNOWN_CHANNEL_NAME | Channel or repeated capability name specified is not valid for the instrument.
E_IVI_TOO_MANY_OPEN_FILES | Too many files opened
E_IVI_CHANNEL_NAME_REQUIRED | Channel or repeated capability name required
E_IVI_MISSING_OPTION_NAME | The option string contains an entry without a name.
E_IVI_MISSING_OPTION_VALUE | The option string contains an entry without a value.
E_IVI_BAD_OPTION_NAME | The option string contains an entry with an unknown option name.
E_IVI_BAD_OPTION_VALUE | The option string contains an entry with an unknown option value.
E_IVI_OUT_OF_MEMORY | The necessary memory could not be allocated
E_IVI_OPERATION_PENDING | Operation in progress
E_IVI_NULL_POINTER | Null pointer passed for parameter or property
E_IVI_UNEXPECTED_RESPONSE | Unexpected response from the instrument
E_IVI_FILE_NOT_FOUND | File not found
E_IVI_INVALID_FILE_FORMAT | The file format is invalid
E_IVI_STATUS_NOT_AVAILABLE | The instrument status is not available
E_IVI_ID_QUERY_FAILED | Instrument ID query failed
E_IVI_RESET_FAILED | Instrument reset failed
E_IVI_RESOURCE_UNKNOWN | Insufficient location information or resource not present in the system.
E_IVI_ALREADY_INITIALIZED | The driver is already initialized
E_IVI_CANNOT_CHANGE_SIMULATION_STATE | The simulation state cannot be changed.
S_IVI_NSUP_ID_QUERY | Identification query not supported
S_IVI_NSUP_RESET | Reset operation not supported
S_IVI_NSUP_SELF_TEST | Self test operation not supported
S_IVI_NSUP_ERROR_QUERY | Error query operation not supported
S_IVI_NSUP_REV_QUERY | Revision query not supported


IIviDriver Interface

IVI Driver root interface

Properties

DriverOperation | Pointer to the IIviDriverOperation interface
Identity | Pointer to the IIviDriverIdentity interface
Utility | Pointer to the IIviDriverUtility interface
Initialized | Initialized is True between a successful call to the Initialize method and a successful call to the Close method, and False at all other times.

Methods

Initialize | Opens the I/O session to the instrument. Driver methods and properties that access the instrument are only accessible after Initialize is called. Initialize optionally performs a Reset and queries the instrument to validate the instrument model.
Close | Closes the I/O session to the instrument. Driver methods and properties that access the instrument are not accessible after Close is called.


IIviDriverIdentity Interface

IVI Driver identity interface

Properties

Description | A brief description of the implementing component. Description is limted to 256 bytes.
Revision | The revision of the implementing component. Refer to IVI-3.2, Section 3.1.2.2, Additional Compliance Rules for Revision String Attributes, for a description of revision syntax and semantics. Revision is limited to 256 bytes.
Vendor | The name of the vendor that supplies the implementing component. Vendor is limited to 256 bytes.
InstrumentManufacturer | The name of the manufacturer reported by the physical instrument. If Simulation is enabled or the instrument is not capable of reporting the name of the manufacturer, a string is returned that explains the condition. Manufacturer is limited to 256 bytes
InstrumentModel | The model number or name reported by the physical instrument. If Simulation is enabled or the instrument is not capable of reporting the model number or name, a string is returned that explains the condition. Model is limited to 256 bytes
InstrumentFirmwareRevision | The firmware revision reported by the physical instrument. If Simulation is enabled or the instrument is not capable of reporting the firmware revision, a string is returned that explains the condition.
Identifier | The case-sensitive unique identifier of the implementing IVI-COM instrument driver.
SupportedInstrumentModels | A comma-separated list of instrument models that the IVI specific driver can control. The string does not include an abbreviation for the manufacturer if it is the same for all models.
SpecificationMajorVersion | For IVI class-compliant drivers, the major version number of the instrument class specification. If the driver is not class compliant, the value of this property is zero.
SpecificationMinorVersion | For IVI class-compliant drivers, the minor version number of the instrument class specification. If the driver is not class compliant, the value of this property is zero.
GroupCapabilities | A comma-separated list of the class capability groups implemented by the driver. Capability group names are documented in the IVI class specifications. If the driver is not class compliant, the driver returns an empty string.


IIviDriverOperation Interface

IVI Driver operation interface

Properties

LogicalName | Logical Name identifies a driver session in the Configuration Store. If Logical Name is not empty, the driver was initialized from information in the driver session. If it is empty, the driver was initialized without using the Configuration Store.
IoResourceDescriptor | The resource descriptor specifies the connection to a physical device. It is either specified in the Configuration Store or passed in the ResourceName parameter of the Initialize function. It is empty if the driver is not initialized.
Cache | Drivers may choose to always cache some instrument settings, never cache others, and optionally cache others, to avoid unecessary I/O to the instrument. If True, the driver caches optionally cached instrument settings.
InterchangeCheck | If True, the driver maintains a record of interchangeability warnings. If the driver does not support interchangeability checking, attempts to set InterchangeCheck to True return an error.
QueryInstrumentStatus | If True, the driver queries the instrument status at the end of each method or property that performs I/O to the instrument. If an error is reported, use ErrorQuery to retrieve error messages one at a time from the instrument.
RangeCheck | Drivers may choose to always validate some property/parameter values, never validate others, and optionally validate others, to avoid sending invalid commands to the instrument. If True, the driver performs optional validations.
RecordCoercions | If True, the driver keeps a list of the value coercions it makes for ViInt32 and ViReal64 attributes. If the driver does not support coercion recording, attempts to set RecordCoercions to True will return an error.
Simulate | If True, the driver does not perform I/O to the instrument, and returns simulated values for output parameters.
DriverSetup | The driver setup string. It is either specified in the Configuration Store or passed in the OptionString parameter of the Initialize function. Driver setup is empty if the driver is not initialized.

Methods

InvalidateAllAttributes | Invalidates all of the driver's cached values.
ClearInterchangeWarnings | Clears the list of interchangeability warnings that the IVI specific driver maintains.
GetNextInterchangeWarning | Returns the oldest warning from the interchange warning list. Records are only added to the list if InterchangeCheck is True.
ResetInterchangeCheck | Resets the interchangeability checking algorithms of the driver so that methods and properties that executed prior to calling this function have no affect on whether future calls to the driver generate interchangeability warnings.
GetNextCoercionRecord | Returns the oldest record from the coercion record list. Records are only added to the list if RecordCoercions is True.


IIviDriverUtility Interface

IVI Driver utility interface

Methods

Reset | Places the instrument in a known state and configures instrument options on which the IVI specific driver depends (for example, enabling/disabling headers). For an IEEE 488.2 instrument, Reset sends the command string *RST to the instrument.
ResetWithDefaults | Does the equivalent of Reset and then, (1) disables class extension capability groups, (2) sets attributes to initial values defined by class specs, and (3) configures the driver to option string settings used when Initialize was last executed.
Disable | Quickly places the instrument in a state where it has no, or minimal, effect on the external system to which it is connected. This state is not necessarily a known state.
SelfTest | Performs an instrument self test, waits for the instrument to complete the test, and queries the instrument for the results. If the instrument passes the test, TestResult is zero and TestMessage is 'Self test passed'.
ErrorQuery | Queries the instrument and returns instrument specific error information. This function can be used when QueryInstrumentStatus is True to retrieve error details when the driver detects an instrument error.
LockObject | Obtains a multithread lock on the driver after waiting until all other execution threads have released their locks on the instrument session.
UnlockObject | Releases a previously obtained mutlithread lock.


Close Method

IIviDriver.Close Method

Closes the I/O session to the instrument. Driver methods and properties that access the instrument are not accessible after Close is called.

[Visual Basic]
Sub Close()
[C++]
HRESULT Close();
[ANSI C]
HRESULT IIviDriver_Close(
   IIviDriver* This);
[C#]
public void Close();

Capability Group

IviSpecAnBase

Related Items

Initialize

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Initialize | Close | IIviDriver Overview


DriverOperation Property

IIviDriver.DriverOperation Property

Pointer to the IIviDriverOperation interface

[Visual Basic]
Property Get DriverOperation() As IIviDriverOperation
[C++]
HRESULT get_DriverOperation(IIviDriverOperation** value);
[ANSI C]
HRESULT IIviDriver_get_DriverOperation(IIviDriver* This, IIviDriverOperation** value);
[C#]
public IIviDriverOperation DriverOperation {get;}

Capability Group

IviSpecAnBase

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Initialize | Close | IIviDriver Overview


Identity Property

IIviDriver.Identity Property

Pointer to the IIviDriverIdentity interface

[Visual Basic]
Property Get Identity() As IIviDriverIdentity
[C++]
HRESULT get_Identity(IIviDriverIdentity** value);
[ANSI C]
HRESULT IIviDriver_get_Identity(IIviDriver* This, IIviDriverIdentity** value);
[C#]
public IIviDriverIdentity Identity {get;}

Capability Group

IviSpecAnBase

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Initialize | Close | IIviDriver Overview


Initialize Method

IIviDriver.Initialize Method

Opens the I/O session to the instrument. Driver methods and properties that access the instrument are only accessible after Initialize is called. Initialize optionally performs a Reset and queries the instrument to validate the instrument model.

[Visual Basic]
Sub Initialize( _
   ResourceName As String, _
   IdQuery As Boolean, _
   Reset As Boolean, _
   OptionString As String _
)
[C++]
HRESULT Initialize(
   BSTR ResourceName,
   VARIANT_BOOL IdQuery,
   VARIANT_BOOL Reset,
   BSTR OptionString
);
[ANSI C]
HRESULT IIviDriver_Initialize(
   IIviDriver* This
   BSTR ResourceName,
   VARIANT_BOOL IdQuery,
   VARIANT_BOOL Reset,
   BSTR OptionString
);
[C#]
public void Initialize(
   string ResourceName,
   bool IdQuery,
   bool Reset,
   string OptionString
);

Parameters

ResourceName
An IVI logical name or an instrument specific string that identifies the address of the instrument, such as a VISA resource descriptor string.
IdQuery
Specifies whether to verify the ID of the instrument.
Reset
Specifies whether to reset the instrument.
OptionString
The user can use the OptionsString parameter to specify the initial values of certain IVI inherent attributes for the session.

Capability Group

IviSpecAnBase

Related Items

Close

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Initialize | Close | IIviDriver Overview


Initialized Property

IIviDriver.Initialized Property

Initialized is True between a successful call to the Initialize method and a successful call to the Close method, and False at all other times.

[Visual Basic]
Property Get Initialized() As Boolean
[C++]
HRESULT get_Initialized(VARIANT_BOOL* value);
[ANSI C]
HRESULT IIviDriver_get_Initialized(IIviDriver* This, VARIANT_BOOL* value);
[C#]
public bool Initialized {get;}

Capability Group

IviSpecAnBase

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Initialize | Close | IIviDriver Overview


Utility Property

IIviDriver.Utility Property

Pointer to the IIviDriverUtility interface

[Visual Basic]
Property Get Utility() As IIviDriverUtility
[C++]
HRESULT get_Utility(IIviDriverUtility** value);
[ANSI C]
HRESULT IIviDriver_get_Utility(IIviDriver* This, IIviDriverUtility** value);
[C#]
public IIviDriverUtility Utility {get;}

Capability Group

IviSpecAnBase

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Initialize | Close | IIviDriver Overview


Description Property

IIviDriverIdentity.Description Property

A brief description of the implementing component. Description is limted to 256 bytes.

[Visual Basic]
Property Get Description() As String
[C++]
HRESULT get_Description(BSTR* value);
[ANSI C]
HRESULT IIviDriverIdentity_get_Description(IIviDriverIdentity* This, BSTR* value);
[C#]
public string Description {get;}

Capability Group

IviSpecAnBase

Also In This Interface

Description | Revision | Vendor | InstrumentManufacturer | InstrumentModel | InstrumentFirmwareRevision | Identifier | SupportedInstrumentModels | SpecificationMajorVersion | SpecificationMinorVersion | GroupCapabilities | IIviDriverIdentity Overview


GroupCapabilities Property

IIviDriverIdentity.GroupCapabilities Property

A comma-separated list of the class capability groups implemented by the driver. Capability group names are documented in the IVI class specifications. If the driver is not class compliant, the driver returns an empty string.

[Visual Basic]
Property Get GroupCapabilities() As String
[C++]
HRESULT get_GroupCapabilities(BSTR* value);
[ANSI C]
HRESULT IIviDriverIdentity_get_GroupCapabilities(IIviDriverIdentity* This, BSTR* value);
[C#]
public string GroupCapabilities {get;}

Capability Group

IviSpecAnBase

Also In This Interface

Description | Revision | Vendor | InstrumentManufacturer | InstrumentModel | InstrumentFirmwareRevision | Identifier | SupportedInstrumentModels | SpecificationMajorVersion | SpecificationMinorVersion | GroupCapabilities | IIviDriverIdentity Overview


Identifier Property

IIviDriverIdentity.Identifier Property

The case-sensitive unique identifier of the implementing IVI-COM instrument driver.

[Visual Basic]
Property Get Identifier() As String
[C++]
HRESULT get_Identifier(BSTR* value);
[ANSI C]
HRESULT IIviDriverIdentity_get_Identifier(IIviDriverIdentity* This, BSTR* value);
[C#]
public string Identifier {get;}

Capability Group

IviSpecAnBase

Also In This Interface

Description | Revision | Vendor | InstrumentManufacturer | InstrumentModel | InstrumentFirmwareRevision | Identifier | SupportedInstrumentModels | SpecificationMajorVersion | SpecificationMinorVersion | GroupCapabilities | IIviDriverIdentity Overview


InstrumentFirmwareRevision Property

IIviDriverIdentity.InstrumentFirmwareRevision Property

The firmware revision reported by the physical instrument. If Simulation is enabled or the instrument is not capable of reporting the firmware revision, a string is returned that explains the condition.

[Visual Basic]
Property Get InstrumentFirmwareRevision() As String
[C++]
HRESULT get_InstrumentFirmwareRevision(BSTR* value);
[ANSI C]
HRESULT IIviDriverIdentity_get_InstrumentFirmwareRevision(IIviDriverIdentity* This, BSTR* value);
[C#]
public string InstrumentFirmwareRevision {get;}

Capability Group

IviSpecAnBase

Also In This Interface

Description | Revision | Vendor | InstrumentManufacturer | InstrumentModel | InstrumentFirmwareRevision | Identifier | SupportedInstrumentModels | SpecificationMajorVersion | SpecificationMinorVersion | GroupCapabilities | IIviDriverIdentity Overview


InstrumentManufacturer Property

IIviDriverIdentity.InstrumentManufacturer Property

The name of the manufacturer reported by the physical instrument. If Simulation is enabled or the instrument is not capable of reporting the name of the manufacturer, a string is returned that explains the condition. Manufacturer is limited to 256 bytes

[Visual Basic]
Property Get InstrumentManufacturer() As String
[C++]
HRESULT get_InstrumentManufacturer(BSTR* value);
[ANSI C]
HRESULT IIviDriverIdentity_get_InstrumentManufacturer(IIviDriverIdentity* This, BSTR* value);
[C#]
public string InstrumentManufacturer {get;}

Capability Group

IviSpecAnBase

Also In This Interface

Description | Revision | Vendor | InstrumentManufacturer | InstrumentModel | InstrumentFirmwareRevision | Identifier | SupportedInstrumentModels | SpecificationMajorVersion | SpecificationMinorVersion | GroupCapabilities | IIviDriverIdentity Overview


InstrumentModel Property

IIviDriverIdentity.InstrumentModel Property

The model number or name reported by the physical instrument. If Simulation is enabled or the instrument is not capable of reporting the model number or name, a string is returned that explains the condition. Model is limited to 256 bytes

[Visual Basic]
Property Get InstrumentModel() As String
[C++]
HRESULT get_InstrumentModel(BSTR* value);
[ANSI C]
HRESULT IIviDriverIdentity_get_InstrumentModel(IIviDriverIdentity* This, BSTR* value);
[C#]
public string InstrumentModel {get;}

Capability Group

IviSpecAnBase

Also In This Interface

Description | Revision | Vendor | InstrumentManufacturer | InstrumentModel | InstrumentFirmwareRevision | Identifier | SupportedInstrumentModels | SpecificationMajorVersion | SpecificationMinorVersion | GroupCapabilities | IIviDriverIdentity Overview


Revision Property

IIviDriverIdentity.Revision Property

The revision of the implementing component. Refer to IVI-3.2, Section 3.1.2.2, Additional Compliance Rules for Revision String Attributes, for a description of revision syntax and semantics. Revision is limited to 256 bytes.

[Visual Basic]
Property Get Revision() As String
[C++]
HRESULT get_Revision(BSTR* value);
[ANSI C]
HRESULT IIviDriverIdentity_get_Revision(IIviDriverIdentity* This, BSTR* value);
[C#]
public string Revision {get;}

Capability Group

IviSpecAnBase

Also In This Interface

Description | Revision | Vendor | InstrumentManufacturer | InstrumentModel | InstrumentFirmwareRevision | Identifier | SupportedInstrumentModels | SpecificationMajorVersion | SpecificationMinorVersion | GroupCapabilities | IIviDriverIdentity Overview


SpecificationMajorVersion Property

IIviDriverIdentity.SpecificationMajorVersion Property

For IVI class-compliant drivers, the major version number of the instrument class specification. If the driver is not class compliant, the value of this property is zero.

[Visual Basic]
Property Get SpecificationMajorVersion() As Long
[C++]
HRESULT get_SpecificationMajorVersion(long* value);
[ANSI C]
HRESULT IIviDriverIdentity_get_SpecificationMajorVersion(IIviDriverIdentity* This, long* value);
[C#]
public long SpecificationMajorVersion {get;}

Capability Group

IviSpecAnBase

Also In This Interface

Description | Revision | Vendor | InstrumentManufacturer | InstrumentModel | InstrumentFirmwareRevision | Identifier | SupportedInstrumentModels | SpecificationMajorVersion | SpecificationMinorVersion | GroupCapabilities | IIviDriverIdentity Overview


SpecificationMinorVersion Property

IIviDriverIdentity.SpecificationMinorVersion Property

For IVI class-compliant drivers, the minor version number of the instrument class specification. If the driver is not class compliant, the value of this property is zero.

[Visual Basic]
Property Get SpecificationMinorVersion() As Long
[C++]
HRESULT get_SpecificationMinorVersion(long* value);
[ANSI C]
HRESULT IIviDriverIdentity_get_SpecificationMinorVersion(IIviDriverIdentity* This, long* value);
[C#]
public long SpecificationMinorVersion {get;}

Capability Group

IviSpecAnBase

Also In This Interface

Description | Revision | Vendor | InstrumentManufacturer | InstrumentModel | InstrumentFirmwareRevision | Identifier | SupportedInstrumentModels | SpecificationMajorVersion | SpecificationMinorVersion | GroupCapabilities | IIviDriverIdentity Overview


SupportedInstrumentModels Property

IIviDriverIdentity.SupportedInstrumentModels Property

A comma-separated list of instrument models that the IVI specific driver can control. The string does not include an abbreviation for the manufacturer if it is the same for all models.

[Visual Basic]
Property Get SupportedInstrumentModels() As String
[C++]
HRESULT get_SupportedInstrumentModels(BSTR* value);
[ANSI C]
HRESULT IIviDriverIdentity_get_SupportedInstrumentModels(IIviDriverIdentity* This, BSTR* value);
[C#]
public string SupportedInstrumentModels {get;}

Capability Group

IviSpecAnBase

Also In This Interface

Description | Revision | Vendor | InstrumentManufacturer | InstrumentModel | InstrumentFirmwareRevision | Identifier | SupportedInstrumentModels | SpecificationMajorVersion | SpecificationMinorVersion | GroupCapabilities | IIviDriverIdentity Overview


Vendor Property

IIviDriverIdentity.Vendor Property

The name of the vendor that supplies the implementing component. Vendor is limited to 256 bytes.

[Visual Basic]
Property Get Vendor() As String
[C++]
HRESULT get_Vendor(BSTR* value);
[ANSI C]
HRESULT IIviDriverIdentity_get_Vendor(IIviDriverIdentity* This, BSTR* value);
[C#]
public string Vendor {get;}

Capability Group

IviSpecAnBase

Also In This Interface

Description | Revision | Vendor | InstrumentManufacturer | InstrumentModel | InstrumentFirmwareRevision | Identifier | SupportedInstrumentModels | SpecificationMajorVersion | SpecificationMinorVersion | GroupCapabilities | IIviDriverIdentity Overview


Cache Property

IIviDriverOperation.Cache Property

Drivers may choose to always cache some instrument settings, never cache others, and optionally cache others, to avoid unecessary I/O to the instrument. If True, the driver caches optionally cached instrument settings.

[Visual Basic]
Property Get Cache() As Boolean
Property Let Cache(value As Boolean)
[C++]
HRESULT get_Cache(VARIANT_BOOL* value);
HRESULT put_Cache(VARIANT_BOOL value);
[ANSI C]
HRESULT IIviDriverOperation_get_Cache(IIviDriverOperation* This, VARIANT_BOOL* value);
HRESULT IIviDriverOperation_put_Cache(IIviDriverOperation* This, VARIANT_BOOL value);
[C#]
public bool Cache {get; set;}

Capability Group

IviSpecAnBase

Related Items

InvalidateAllAttributes

Also In This Interface

LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


ClearInterchangeWarnings Method

IIviDriverOperation.ClearInterchangeWarnings Method

Clears the list of interchangeability warnings that the IVI specific driver maintains.

[Visual Basic]
Sub ClearInterchangeWarnings()
[C++]
HRESULT ClearInterchangeWarnings();
[ANSI C]
HRESULT IIviDriverOperation_ClearInterchangeWarnings(
   IIviDriverOperation* This);
[C#]
public void ClearInterchangeWarnings();

Capability Group

IviSpecAnBase

Related Items

GetNextInterchangeWarning | ResetInterchangeCheck | InterchangeCheck

Also In This Interface

LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


DriverSetup Property

IIviDriverOperation.DriverSetup Property

The driver setup string. It is either specified in the Configuration Store or passed in the OptionString parameter of the Initialize function. Driver setup is empty if the driver is not initialized.

[Visual Basic]
Property Get DriverSetup() As String
[C++]
HRESULT get_DriverSetup(BSTR* value);
[ANSI C]
HRESULT IIviDriverOperation_get_DriverSetup(IIviDriverOperation* This, BSTR* value);
[C#]
public string DriverSetup {get;}

Capability Group

IviSpecAnBase

Also In This Interface

LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


GetNextCoercionRecord Method

IIviDriverOperation.GetNextCoercionRecord Method

Returns the oldest record from the coercion record list. Records are only added to the list if RecordCoercions is True.

[Visual Basic]
Function GetNextCoercionRecord() As String
[C++]
HRESULT GetNextCoercionRecord(
   BSTR* CoercionRecord
);
[ANSI C]
HRESULT IIviDriverOperation_GetNextCoercionRecord(
   IIviDriverOperation* This
   BSTR* CoercionRecord
);
[C#]
public string GetNextCoercionRecord();

Parameters

CoercionRecord
The coercion record string shall contain the following information:
  • The name of the attribute that was coerced. This can be the generic name, the COM property name, or the C defined constant.
  • If the attribute is channel-based, the name of the channel. The channel name can be the specific driver channel string or the virtual channel name that the user specified.
  • If the attribute applies to a repeated capability, the name of the repeated capability. The name can be the specific driver repeated capability token or the virtual repeated capability name that the user specified.
  • The value that the user specified for the attribute.
  • The value to which the attribute was coerced.

    • Capability Group

    IviSpecAnBase

    Related Items

    RecordCoercions

    Also In This Interface

    LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


GetNextInterchangeWarning Method

IIviDriverOperation.GetNextInterchangeWarning Method

Returns the oldest warning from the interchange warning list. Records are only added to the list if InterchangeCheck is True.

[Visual Basic]
Function GetNextInterchangeWarning() As String
[C++]
HRESULT GetNextInterchangeWarning(
   BSTR* InterchangeWarning
);
[ANSI C]
HRESULT IIviDriverOperation_GetNextInterchangeWarning(
   IIviDriverOperation* This
   BSTR* InterchangeWarning
);
[C#]
public string GetNextInterchangeWarning();

Parameters

InterchangeWarning
A string describing the oldest interchangeability warning or empty string if no warrnings remain.

Capability Group

IviSpecAnBase

Related Items

ClearInterchangeWarnings | ResetInterchangeCheck | InterchangeCheck

Also In This Interface

LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


InterchangeCheck Property

IIviDriverOperation.InterchangeCheck Property

If True, the driver maintains a record of interchangeability warnings. If the driver does not support interchangeability checking, attempts to set InterchangeCheck to True return an error.

[Visual Basic]
Property Get InterchangeCheck() As Boolean
Property Let InterchangeCheck(value As Boolean)
[C++]
HRESULT get_InterchangeCheck(VARIANT_BOOL* value);
HRESULT put_InterchangeCheck(VARIANT_BOOL value);
[ANSI C]
HRESULT IIviDriverOperation_get_InterchangeCheck(IIviDriverOperation* This, VARIANT_BOOL* value);
HRESULT IIviDriverOperation_put_InterchangeCheck(IIviDriverOperation* This, VARIANT_BOOL value);
[C#]
public bool InterchangeCheck {get; set;}

Capability Group

IviSpecAnBase

Related Items

ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck

Also In This Interface

LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


InvalidateAllAttributes Method

IIviDriverOperation.InvalidateAllAttributes Method

Invalidates all of the driver's cached values.

[Visual Basic]
Sub InvalidateAllAttributes()
[C++]
HRESULT InvalidateAllAttributes();
[ANSI C]
HRESULT IIviDriverOperation_InvalidateAllAttributes(
   IIviDriverOperation* This);
[C#]
public void InvalidateAllAttributes();

Capability Group

IviSpecAnBase

Related Items

Cache

Also In This Interface

LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


IoResourceDescriptor Property

IIviDriverOperation.IoResourceDescriptor Property

The resource descriptor specifies the connection to a physical device. It is either specified in the Configuration Store or passed in the ResourceName parameter of the Initialize function. It is empty if the driver is not initialized.

[Visual Basic]
Property Get IoResourceDescriptor() As String
[C++]
HRESULT get_IoResourceDescriptor(BSTR* value);
[ANSI C]
HRESULT IIviDriverOperation_get_IoResourceDescriptor(IIviDriverOperation* This, BSTR* value);
[C#]
public string IoResourceDescriptor {get;}

Capability Group

IviSpecAnBase

Also In This Interface

LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


LogicalName Property

IIviDriverOperation.LogicalName Property

Logical Name identifies a driver session in the Configuration Store. If Logical Name is not empty, the driver was initialized from information in the driver session. If it is empty, the driver was initialized without using the Configuration Store.

[Visual Basic]
Property Get LogicalName() As String
[C++]
HRESULT get_LogicalName(BSTR* value);
[ANSI C]
HRESULT IIviDriverOperation_get_LogicalName(IIviDriverOperation* This, BSTR* value);
[C#]
public string LogicalName {get;}

Capability Group

IviSpecAnBase

Also In This Interface

LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


QueryInstrumentStatus Property

IIviDriverOperation.QueryInstrumentStatus Property

If True, the driver queries the instrument status at the end of each method or property that performs I/O to the instrument. If an error is reported, use ErrorQuery to retrieve error messages one at a time from the instrument.

[Visual Basic]
Property Get QueryInstrumentStatus() As Boolean
Property Let QueryInstrumentStatus(value As Boolean)
[C++]
HRESULT get_QueryInstrumentStatus(VARIANT_BOOL* value);
HRESULT put_QueryInstrumentStatus(VARIANT_BOOL value);
[ANSI C]
HRESULT IIviDriverOperation_get_QueryInstrumentStatus(IIviDriverOperation* This, VARIANT_BOOL* value);
HRESULT IIviDriverOperation_put_QueryInstrumentStatus(IIviDriverOperation* This, VARIANT_BOOL value);
[C#]
public bool QueryInstrumentStatus {get; set;}

Capability Group

IviSpecAnBase

Also In This Interface

LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


RangeCheck Property

IIviDriverOperation.RangeCheck Property

Drivers may choose to always validate some property/parameter values, never validate others, and optionally validate others, to avoid sending invalid commands to the instrument. If True, the driver performs optional validations.

[Visual Basic]
Property Get RangeCheck() As Boolean
Property Let RangeCheck(value As Boolean)
[C++]
HRESULT get_RangeCheck(VARIANT_BOOL* value);
HRESULT put_RangeCheck(VARIANT_BOOL value);
[ANSI C]
HRESULT IIviDriverOperation_get_RangeCheck(IIviDriverOperation* This, VARIANT_BOOL* value);
HRESULT IIviDriverOperation_put_RangeCheck(IIviDriverOperation* This, VARIANT_BOOL value);
[C#]
public bool RangeCheck {get; set;}

Capability Group

IviSpecAnBase

Also In This Interface

LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


RecordCoercions Property

IIviDriverOperation.RecordCoercions Property

If True, the driver keeps a list of the value coercions it makes for ViInt32 and ViReal64 attributes. If the driver does not support coercion recording, attempts to set RecordCoercions to True will return an error.

[Visual Basic]
Property Get RecordCoercions() As Boolean
Property Let RecordCoercions(value As Boolean)
[C++]
HRESULT get_RecordCoercions(VARIANT_BOOL* value);
HRESULT put_RecordCoercions(VARIANT_BOOL value);
[ANSI C]
HRESULT IIviDriverOperation_get_RecordCoercions(IIviDriverOperation* This, VARIANT_BOOL* value);
HRESULT IIviDriverOperation_put_RecordCoercions(IIviDriverOperation* This, VARIANT_BOOL value);
[C#]
public bool RecordCoercions {get; set;}

Capability Group

IviSpecAnBase

Related Items

GetNextCoercionRecord

Also In This Interface

LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


ResetInterchangeCheck Method

IIviDriverOperation.ResetInterchangeCheck Method

Resets the interchangeability checking algorithms of the driver so that methods and properties that executed prior to calling this function have no affect on whether future calls to the driver generate interchangeability warnings.

[Visual Basic]
Sub ResetInterchangeCheck()
[C++]
HRESULT ResetInterchangeCheck();
[ANSI C]
HRESULT IIviDriverOperation_ResetInterchangeCheck(
   IIviDriverOperation* This);
[C#]
public void ResetInterchangeCheck();

Capability Group

IviSpecAnBase

Related Items

GetNextInterchangeWarning | ClearInterchangeWarnings | InterchangeCheck

Also In This Interface

LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


Simulate Property

IIviDriverOperation.Simulate Property

If True, the driver does not perform I/O to the instrument, and returns simulated values for output parameters.

[Visual Basic]
Property Get Simulate() As Boolean
Property Let Simulate(value As Boolean)
[C++]
HRESULT get_Simulate(VARIANT_BOOL* value);
HRESULT put_Simulate(VARIANT_BOOL value);
[ANSI C]
HRESULT IIviDriverOperation_get_Simulate(IIviDriverOperation* This, VARIANT_BOOL* value);
HRESULT IIviDriverOperation_put_Simulate(IIviDriverOperation* This, VARIANT_BOOL value);
[C#]
public bool Simulate {get; set;}

Capability Group

IviSpecAnBase

Also In This Interface

LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


Disable Method

IIviDriverUtility.Disable Method

Quickly places the instrument in a state where it has no, or minimal, effect on the external system to which it is connected. This state is not necessarily a known state.

[Visual Basic]
Sub Disable()
[C++]
HRESULT Disable();
[ANSI C]
HRESULT IIviDriverUtility_Disable(
   IIviDriverUtility* This);
[C#]
public void Disable();

Capability Group

IviSpecAnBase

Also In This Interface

Reset | ResetWithDefaults | Disable | SelfTest | ErrorQuery | LockObject | UnlockObject | IIviDriverUtility Overview


ErrorQuery Method

IIviDriverUtility.ErrorQuery Method

Queries the instrument and returns instrument specific error information. This function can be used when QueryInstrumentStatus is True to retrieve error details when the driver detects an instrument error.

[Visual Basic]
Sub ErrorQuery( _
   ErrorCode As Long, _
   ErrorMessage As String _
)
[C++]
HRESULT ErrorQuery(
   long* ErrorCode,
   BSTR* ErrorMessage
);
[ANSI C]
HRESULT IIviDriverUtility_ErrorQuery(
   IIviDriverUtility* This
   long* ErrorCode,
   BSTR* ErrorMessage
);
[C#]
public void ErrorQuery(
   long ErrorCode,
   string ErrorMessage
);

Parameters

ErrorCode
Instrument error code
ErrorMessage
Instrument error message

Capability Group

IviSpecAnBase

Also In This Interface

Reset | ResetWithDefaults | Disable | SelfTest | ErrorQuery | LockObject | UnlockObject | IIviDriverUtility Overview


LockObject Method

IIviDriverUtility.LockObject Method

Obtains a multithread lock on the driver after waiting until all other execution threads have released their locks on the instrument session.

[Visual Basic]
Sub LockObject()
[C++]
HRESULT LockObject();
[ANSI C]
HRESULT IIviDriverUtility_LockObject(
   IIviDriverUtility* This);
[C#]
public void LockObject();

Capability Group

IviSpecAnBase

Related Items

UnlockObject

Also In This Interface

Reset | ResetWithDefaults | Disable | SelfTest | ErrorQuery | LockObject | UnlockObject | IIviDriverUtility Overview


Reset Method

IIviDriverUtility.Reset Method

Places the instrument in a known state and configures instrument options on which the IVI specific driver depends (for example, enabling/disabling headers). For an IEEE 488.2 instrument, Reset sends the command string *RST to the instrument.

[Visual Basic]
Sub Reset()
[C++]
HRESULT Reset();
[ANSI C]
HRESULT IIviDriverUtility_Reset(
   IIviDriverUtility* This);
[C#]
public void Reset();

Capability Group

IviSpecAnBase

Related Items

ResetWithDefaults

Also In This Interface

Reset | ResetWithDefaults | Disable | SelfTest | ErrorQuery | LockObject | UnlockObject | IIviDriverUtility Overview


ResetWithDefaults Method

IIviDriverUtility.ResetWithDefaults Method

Does the equivalent of Reset and then, (1) disables class extension capability groups, (2) sets attributes to initial values defined by class specs, and (3) configures the driver to option string settings used when Initialize was last executed.

[Visual Basic]
Sub ResetWithDefaults()
[C++]
HRESULT ResetWithDefaults();
[ANSI C]
HRESULT IIviDriverUtility_ResetWithDefaults(
   IIviDriverUtility* This);
[C#]
public void ResetWithDefaults();

Capability Group

IviSpecAnBase

Also In This Interface

Reset | ResetWithDefaults | Disable | SelfTest | ErrorQuery | LockObject | UnlockObject | IIviDriverUtility Overview


SelfTest Method

IIviDriverUtility.SelfTest Method

Performs an instrument self test, waits for the instrument to complete the test, and queries the instrument for the results. If the instrument passes the test, TestResult is zero and TestMessage is 'Self test passed'.

[Visual Basic]
Sub SelfTest( _
   TestResult As Long, _
   TestMessage As String _
)
[C++]
HRESULT SelfTest(
   long* TestResult,
   BSTR* TestMessage
);
[ANSI C]
HRESULT IIviDriverUtility_SelfTest(
   IIviDriverUtility* This
   long* TestResult,
   BSTR* TestMessage
);
[C#]
public void SelfTest(
   long TestResult,
   string TestMessage
);

Parameters

TestResult
The numeric result from the self test operation. 0 = no error (test passed)
TestMessage
The self test status message

Capability Group

IviSpecAnBase

Also In This Interface

Reset | ResetWithDefaults | Disable | SelfTest | ErrorQuery | LockObject | UnlockObject | IIviDriverUtility Overview


UnlockObject Method

IIviDriverUtility.UnlockObject Method

Releases a previously obtained mutlithread lock.

[Visual Basic]
Sub UnlockObject()
[C++]
HRESULT UnlockObject();
[ANSI C]
HRESULT IIviDriverUtility_UnlockObject(
   IIviDriverUtility* This);
[C#]
public void UnlockObject();

Capability Group

IviSpecAnBase

Related Items

LockObject

Also In This Interface

Reset | ResetWithDefaults | Disable | SelfTest | ErrorQuery | LockObject | UnlockObject | IIviDriverUtility Overview