IviScope Reference

© 2003 IVI Foundation

Welcome to the IviScope Class-Compliant Interface Reference

This section contains the reference material for the IviScope class-compliant interface.

This help hierarchy matches the COM hierarchy defined in the IviScope class specification, available on the IVI Foundation Web Site. The COM hierarchy groups related capabilities into common interfaces. These interfaces often include both IviScope base and extension capabilities. To help users distinguish between base and extension capabilities, the Capability Group section of each method or property topic lists which of the IviScope Capability Groups the method or property belongs to.

Since IVI class-compliant specific drivers are not required to support all extension groups, users should refer to the compliance documentation for the particular driver being used to determine if an extension group is supported before using capabilities in that group.

IVI class-compliant specific drivers may have small differences in the way a particular extension group method or property is implemented. For instance, a driver might implement only one of several IVI-defined values for an extension group attribute. Refer to the help documentation provided with the IVI class-compliant specific driver for detailed information about implementation.


Inherent Interface

IviScope Capability Groups

Capability Group | Description
IviScopeBase | Base Capabilities of the IviScope specification. This group includes the capability to acquire waveforms using edge triggering.
IviScopeInterpolation | Extension: IviScope with the ability to configure the oscilloscope to interpolate missing points in a waveform.
IviScopeTVTrigger | Extension: IviScope with the ability to trigger on standard television signals.
IviScopeRuntTrigger | Extension: IviScope with the ability to trigger on runts.
IviScopeGlitchTrigger | Extension: IviScope with the ability to trigger on glitches.
IviScopeWidthTrigger | Extension: IviScope with the ability to trigger on a variety of conditions regarding pulse widths.
IviScopeAcLineTrigger | Extension: IviScope with the ability to trigger on zero crossings of a network supply voltage.
IviScopeWaveformMeas | Extension: IviScope with the ability to calculate waveform measurements, such as rise time or frequency.
IviScopeMinMaxWaveform | Extension: IviScope with the ability to acquire a minimum and maximum waveforms that correspond to the same time range.
IviScopeProbeAutoSense | Extension: IviScope with the ability to automatically sense the probe attenuation of an attached probe.
IviScopeContinuousAcquisition | Extension: IviScope with the ability to continuously acquire data from the input and display it on the screen.
IviScopeAverageAcquisition | Extension: IviScope with the ability to create a waveform that is the average of multiple waveform acquisitions.
IviScopeSampleMode | Extension: IviScope with the ability to return the actual sample mode.
IviScopeTriggerModifier | Extension: IviScope with the ability to modify the behavior of the triggering subsystem in the absence of a expected trigger.
IviScopeAutoSetup | Extension: IviScope with the automatic configuration ability.


Inherent Interface

IviScope Instrument Class Interfaces

IIviScope | IVI Scope class-compliant root interface
IIviScopeAcquisition | IVI Scope class-compliant acquisition interface
IIviScopeChannel | IVI Scope class-compliant channel interface
IIviScopeChannels | IVI Scope class-compliant channel collection interface
IIviScopeMeasurement | IVI Scope class-compliant measurement interface
IIviScopeMeasurements | IVI Scope class-compliant measurement collection interface
IIviScopeReferenceLevel | IVI Scope class-compliant reference level interface
IIviScopeTrigger | IVI Scope class-compliant trigger interface
IIviScopeTriggerAcLine | IVI Scope class-compliant AC line trigger interface
IIviScopeTriggerEdge | IVI Scope class-compliant edge trigger interface
IIviScopeTriggerGlitch | IVI Scope class-compliant glitch trigger interface
IIviScopeTriggerRunt | IVI Scope class-compliant runt trigger interface
IIviScopeTriggerTv | IVI Scope class-compliant TV trigger interface
IIviScopeTriggerWidth | IVI Scope class-compliant width trigger interface


IIviScope Interface

IVI Scope class-compliant root interface

Methods

Initialize | Opens the I/O session to the instrument. Driver methods and properties that access the instrument are only accessible after Initialize is called. Initialize optionally performs a Reset and queries the instrument to validate the instrument model.
Close | Closes the I/O session to the instrument. Driver methods and properties that access the instrument are not accessible after Close is called.

Properties

DriverOperation | Pointer to the IIviDriverOperation interface
Identity | Pointer to the IIviDriverIdentity interface
Utility | Pointer to the IIviDriverUtility interface
Initialized | Initialized is True between a successful call to the Initialize method and a successful call to the Close method, and False at all other times.
Acquisition | Pointer to the class-compliant IIviScopeAcquisition interface
Channels | Pointer to the class-compliant IIviScopeChannels interface
Measurements | Pointer to the class-compliant IIviScopeMeasurements interface
ReferenceLevel | Pointer to the class-compliant IIviScopeReferenceLevel interface
Trigger | Pointer to the class-compliant IIviScopeTrigger interface


DriverOperation Property

IIviScope.DriverOperation Property

Pointer to the IIviDriverOperation interface

[Visual Basic]
Property Get DriverOperation() As IIviDriverOperation
[C++]
HRESULT get_DriverOperation(IIviDriverOperation** value);
[ANSI C]
HRESULT IIviScope_get_DriverOperation(IIviScope* This, IIviDriverOperation** value);
[C#]
public IIviDriverOperation DriverOperation {get;}

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Acquisition | Channels | Measurements | ReferenceLevel | Trigger | Initialize | Close | IIviScope Overview


Identity Property

IIviScope.Identity Property

Pointer to the IIviDriverIdentity interface

[Visual Basic]
Property Get Identity() As IIviDriverIdentity
[C++]
HRESULT get_Identity(IIviDriverIdentity** value);
[ANSI C]
HRESULT IIviScope_get_Identity(IIviScope* This, IIviDriverIdentity** value);
[C#]
public IIviDriverIdentity Identity {get;}

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Acquisition | Channels | Measurements | ReferenceLevel | Trigger | Initialize | Close | IIviScope Overview


Utility Property

IIviScope.Utility Property

Pointer to the IIviDriverUtility interface

[Visual Basic]
Property Get Utility() As IIviDriverUtility
[C++]
HRESULT get_Utility(IIviDriverUtility** value);
[ANSI C]
HRESULT IIviScope_get_Utility(IIviScope* This, IIviDriverUtility** value);
[C#]
public IIviDriverUtility Utility {get;}

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Acquisition | Channels | Measurements | ReferenceLevel | Trigger | Initialize | Close | IIviScope Overview


Initialized Property

IIviScope.Initialized Property

Initialized is True between a successful call to the Initialize method and a successful call to the Close method, and False at all other times.

[Visual Basic]
Property Get Initialized() As Boolean
[C++]
HRESULT get_Initialized(VARIANT_BOOL* value);
[ANSI C]
HRESULT IIviScope_get_Initialized(IIviScope* This, VARIANT_BOOL* value);
[C#]
public bool Initialized {get;}

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Acquisition | Channels | Measurements | ReferenceLevel | Trigger | Initialize | Close | IIviScope Overview


Acquisition Property

IIviScope.Acquisition Property

Pointer to the class-compliant IIviScopeAcquisition interface

[Visual Basic]
Property Get Acquisition() As IIviScopeAcquisition
[C++]
HRESULT get_Acquisition(IIviScopeAcquisition** value);
[ANSI C]
HRESULT IIviScope_get_Acquisition(IIviScope* This, IIviScopeAcquisition** value);
[C#]
public IIviScopeAcquisition Acquisition {get;}

Capability Group

IviScopeBase

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Acquisition | Channels | Measurements | ReferenceLevel | Trigger | Initialize | Close | IIviScope Overview


Channels Property

IIviScope.Channels Property

Pointer to the class-compliant IIviScopeChannels interface

[Visual Basic]
Property Get Channels() As IIviScopeChannels
[C++]
HRESULT get_Channels(IIviScopeChannels** value);
[ANSI C]
HRESULT IIviScope_get_Channels(IIviScope* This, IIviScopeChannels** value);
[C#]
public IIviScopeChannels Channels {get;}

Capability Group

IviScopeBase

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Acquisition | Channels | Measurements | ReferenceLevel | Trigger | Initialize | Close | IIviScope Overview


Measurements Property

IIviScope.Measurements Property

Pointer to the class-compliant IIviScopeMeasurements interface

[Visual Basic]
Property Get Measurements() As IIviScopeMeasurements
[C++]
HRESULT get_Measurements(IIviScopeMeasurements** value);
[ANSI C]
HRESULT IIviScope_get_Measurements(IIviScope* This, IIviScopeMeasurements** value);
[C#]
public IIviScopeMeasurements Measurements {get;}

Capability Group

IviScopeBase

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Acquisition | Channels | Measurements | ReferenceLevel | Trigger | Initialize | Close | IIviScope Overview


ReferenceLevel Property

IIviScope.ReferenceLevel Property

Pointer to the class-compliant IIviScopeReferenceLevel interface

[Visual Basic]
Property Get ReferenceLevel() As IIviScopeReferenceLevel
[C++]
HRESULT get_ReferenceLevel(IIviScopeReferenceLevel** value);
[ANSI C]
HRESULT IIviScope_get_ReferenceLevel(IIviScope* This, IIviScopeReferenceLevel** value);
[C#]
public IIviScopeReferenceLevel ReferenceLevel {get;}

Capability Group

IviScopeBase

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Acquisition | Channels | Measurements | ReferenceLevel | Trigger | Initialize | Close | IIviScope Overview


Trigger Property

IIviScope.Trigger Property

Pointer to the class-compliant IIviScopeTrigger interface

[Visual Basic]
Property Get Trigger() As IIviScopeTrigger
[C++]
HRESULT get_Trigger(IIviScopeTrigger** value);
[ANSI C]
HRESULT IIviScope_get_Trigger(IIviScope* This, IIviScopeTrigger** value);
[C#]
public IIviScopeTrigger Trigger {get;}

Capability Group

IviScopeBase

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Acquisition | Channels | Measurements | ReferenceLevel | Trigger | Initialize | Close | IIviScope Overview


Initialize Method

IIviScope.Initialize Method

Opens the I/O session to the instrument. Driver methods and properties that access the instrument are only accessible after Initialize is called. Initialize optionally performs a Reset and queries the instrument to validate the instrument model.

[Visual Basic]
Sub Initialize( _
   ResourceName As String, _
   IdQuery As Boolean, _
   Reset As Boolean, _
   OptionString As String _
)
[C++]
HRESULT Initialize(
   BSTR ResourceName,
   VARIANT_BOOL IdQuery,
   VARIANT_BOOL Reset,
   BSTR OptionString
);
[ANSI C]
HRESULT IIviScope_Initialize(
   IIviScope* This
   BSTR ResourceName,
   VARIANT_BOOL IdQuery,
   VARIANT_BOOL Reset,
   BSTR OptionString
);
[C#]
public void Initialize(
   string ResourceName,
   bool IdQuery,
   bool Reset,
   string OptionString
);

Parameters

ResourceName
An IVI logical name or an instrument specific string that identifies the address of the instrument, such as a VISA resource descriptor string.
IdQuery
Specifies whether to verify the ID of the instrument.
Reset
Specifies whether to reset the instrument.
OptionString
The user can use the OptionsString parameter to specify the initial values of certain IVI inherent attributes for the session.

Related Items

Close

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Acquisition | Channels | Measurements | ReferenceLevel | Trigger | Initialize | Close | IIviScope Overview


Close Method

IIviScope.Close Method

Closes the I/O session to the instrument. Driver methods and properties that access the instrument are not accessible after Close is called.

[Visual Basic]
Sub Close()
[C++]
HRESULT Close();
[ANSI C]
HRESULT IIviScope_Close(
   IIviScope* This);
[C#]
public void Close();

Related Items

Initialize

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Acquisition | Channels | Measurements | ReferenceLevel | Trigger | Initialize | Close | IIviScope Overview


IIviScopeAcquisition Interface

IVI Scope class-compliant acquisition interface

Methods

ConfigureRecord Configures the most commonly used properties of the oscilloscope’s acquisition subsystem: time per record, minimum record length, and the acquisition start time.

Properties

NumberOfAverages | The number of waveforms the oscilloscope acquires and averages before returning to the idle state.
NumberOfEnvelopes | The number of waveforms the oscilloscope acquires and analyzes to create the minimum and maximum waveforms, before returning to the idle state. Applies only when acquisition Type is Envelope
Interpolation | The interpolation method the oscilloscope uses when it cannot sample a voltage for every point in the waveform record.
RecordLength | The actual number of points the oscilloscope acquires for each channel. It is equal to or greater than the minimum number of points specified with the Horizontal Minimun Number of Points property.
SampleMode | The sample mode the oscilloscope is currently using.
SampleRate | The effective digitizing rate using the current configuration. The units are samples per second.
Type | How the oscilloscope acquires data and fills the waveform record. When set to Envelope or Peak Detect, the oscilloscope acquires minimum and maximum waveforms.
NumberOfPointsMin | The minimum number of points which can be in a waveform record for each channel. It configures the record length that the oscilloscope uses for waveform acquisition. The Record Length property returns the actual record length.
StartTime | The length of time from the trigger event to the first point in the waveform record. The units are seconds. If positive, the first point in the waveform occurs after the trigger. If negative, the first point in the waveform occurs before the trigger.
TimePerRecord | The time in seconds that corresponds to the record length.


NumberOfAverages Property

IIviScopeAcquisition.NumberOfAverages Property

The number of waveforms the oscilloscope acquires and averages before returning to the idle state.

[Visual Basic]
Property Get NumberOfAverages() As Long
Property Let NumberOfAverages(value As Long)
[C++]
HRESULT get_NumberOfAverages(long* value);
HRESULT put_NumberOfAverages(long value);
[ANSI C]
HRESULT IIviScopeAcquisition_get_NumberOfAverages(IIviScopeAcquisition* This, long* value);
HRESULT IIviScopeAcquisition_put_NumberOfAverages(IIviScopeAcquisition* This, long value);
[C#]
public long NumberOfAverages {get; set;}

Capability Group

IviScopeAverageAcquisition

Also In This Interface

NumberOfAverages | NumberOfEnvelopes | Interpolation | RecordLength | SampleMode | SampleRate | Type | NumberOfPointsMin | StartTime | TimePerRecord | ConfigureRecord | IIviScopeAcquisition Overview


NumberOfEnvelopes Property

IIviScopeAcquisition.NumberOfEnvelopes Property

The number of waveforms the oscilloscope acquires and analyzes to create the minimum and maximum waveforms, before returning to the idle state. Applies only when acquisition Type is Envelope

[Visual Basic]
Property Get NumberOfEnvelopes() As Long
Property Let NumberOfEnvelopes(value As Long)
[C++]
HRESULT get_NumberOfEnvelopes(long* value);
HRESULT put_NumberOfEnvelopes(long value);
[ANSI C]
HRESULT IIviScopeAcquisition_get_NumberOfEnvelopes(IIviScopeAcquisition* This, long* value);
HRESULT IIviScopeAcquisition_put_NumberOfEnvelopes(IIviScopeAcquisition* This, long value);
[C#]
public long NumberOfEnvelopes {get; set;}

Capability Group

IviScopeMinMaxWaveform

Also In This Interface

NumberOfAverages | NumberOfEnvelopes | Interpolation | RecordLength | SampleMode | SampleRate | Type | NumberOfPointsMin | StartTime | TimePerRecord | ConfigureRecord | IIviScopeAcquisition Overview


Interpolation Property

IIviScopeAcquisition.Interpolation Property

The interpolation method the oscilloscope uses when it cannot sample a voltage for every point in the waveform record.

[Visual Basic]
Property Get Interpolation() As IviScopeInterpolationEnum
Property Let Interpolation(value As IviScopeInterpolationEnum)
[C++]
HRESULT get_Interpolation(IviScopeInterpolationEnum* value);
HRESULT put_Interpolation(IviScopeInterpolationEnum value);
[ANSI C]
HRESULT IIviScopeAcquisition_get_Interpolation(IIviScopeAcquisition* This, IviScopeInterpolationEnum* value);
HRESULT IIviScopeAcquisition_put_Interpolation(IIviScopeAcquisition* This, IviScopeInterpolationEnum value);
[C#]
public IviScopeInterpolationEnum Interpolation {get; set;}

Capability Group

IviScopeInterpolation

Also In This Interface

NumberOfAverages | NumberOfEnvelopes | Interpolation | RecordLength | SampleMode | SampleRate | Type | NumberOfPointsMin | StartTime | TimePerRecord | ConfigureRecord | IIviScopeAcquisition Overview


RecordLength Property

IIviScopeAcquisition.RecordLength Property

The actual number of points the oscilloscope acquires for each channel. It is equal to or greater than the minimum number of points specified with the Horizontal Minimun Number of Points property.

[Visual Basic]
Property Get RecordLength() As Long
[C++]
HRESULT get_RecordLength(long* value);
[ANSI C]
HRESULT IIviScopeAcquisition_get_RecordLength(IIviScopeAcquisition* This, long* value);
[C#]
public long RecordLength {get;}

Capability Group

IviScopeBase

Also In This Interface

NumberOfAverages | NumberOfEnvelopes | Interpolation | RecordLength | SampleMode | SampleRate | Type | NumberOfPointsMin | StartTime | TimePerRecord | ConfigureRecord | IIviScopeAcquisition Overview


SampleMode Property

IIviScopeAcquisition.SampleMode Property

The sample mode the oscilloscope is currently using.

[Visual Basic]
Property Get SampleMode() As IviScopeSampleModeEnum
[C++]
HRESULT get_SampleMode(IviScopeSampleModeEnum* value);
[ANSI C]
HRESULT IIviScopeAcquisition_get_SampleMode(IIviScopeAcquisition* This, IviScopeSampleModeEnum* value);
[C#]
public IviScopeSampleModeEnum SampleMode {get;}

Capability Group

IviScopeSampleMode

Also In This Interface

NumberOfAverages | NumberOfEnvelopes | Interpolation | RecordLength | SampleMode | SampleRate | Type | NumberOfPointsMin | StartTime | TimePerRecord | ConfigureRecord | IIviScopeAcquisition Overview


SampleRate Property

IIviScopeAcquisition.SampleRate Property

The effective digitizing rate using the current configuration. The units are samples per second.

[Visual Basic]
Property Get SampleRate() As Double
[C++]
HRESULT get_SampleRate(double* value);
[ANSI C]
HRESULT IIviScopeAcquisition_get_SampleRate(IIviScopeAcquisition* This, double* value);
[C#]
public double SampleRate {get;}

Capability Group

IviScopeBase

Also In This Interface

NumberOfAverages | NumberOfEnvelopes | Interpolation | RecordLength | SampleMode | SampleRate | Type | NumberOfPointsMin | StartTime | TimePerRecord | ConfigureRecord | IIviScopeAcquisition Overview


Type Property

IIviScopeAcquisition.Type Property

How the oscilloscope acquires data and fills the waveform record. When set to Envelope or Peak Detect, the oscilloscope acquires minimum and maximum waveforms.

[Visual Basic]
Property Get Type() As IviScopeAcquisitionTypeEnum
Property Let Type(value As IviScopeAcquisitionTypeEnum)
[C++]
HRESULT get_Type(IviScopeAcquisitionTypeEnum* value);
HRESULT put_Type(IviScopeAcquisitionTypeEnum value);
[ANSI C]
HRESULT IIviScopeAcquisition_get_Type(IIviScopeAcquisition* This, IviScopeAcquisitionTypeEnum* value);
HRESULT IIviScopeAcquisition_put_Type(IIviScopeAcquisition* This, IviScopeAcquisitionTypeEnum value);
[C#]
public IviScopeAcquisitionTypeEnum Type {get; set;}

Capability Group

IviScopeBase

Also In This Interface

NumberOfAverages | NumberOfEnvelopes | Interpolation | RecordLength | SampleMode | SampleRate | Type | NumberOfPointsMin | StartTime | TimePerRecord | ConfigureRecord | IIviScopeAcquisition Overview


NumberOfPointsMin Property

IIviScopeAcquisition.NumberOfPointsMin Property

The minimum number of points which can be in a waveform record for each channel. It configures the record length that the oscilloscope uses for waveform acquisition. The Record Length property returns the actual record length.

[Visual Basic]
Property Get NumberOfPointsMin() As Long
Property Let NumberOfPointsMin(value As Long)
[C++]
HRESULT get_NumberOfPointsMin(long* value);
HRESULT put_NumberOfPointsMin(long value);
[ANSI C]
HRESULT IIviScopeAcquisition_get_NumberOfPointsMin(IIviScopeAcquisition* This, long* value);
HRESULT IIviScopeAcquisition_put_NumberOfPointsMin(IIviScopeAcquisition* This, long value);
[C#]
public long NumberOfPointsMin {get; set;}

Capability Group

IviScopeBase

Also In This Interface

NumberOfAverages | NumberOfEnvelopes | Interpolation | RecordLength | SampleMode | SampleRate | Type | NumberOfPointsMin | StartTime | TimePerRecord | ConfigureRecord | IIviScopeAcquisition Overview


StartTime Property

IIviScopeAcquisition.StartTime Property

The length of time from the trigger event to the first point in the waveform record. The units are seconds. If positive, the first point in the waveform occurs after the trigger. If negative, the first point in the waveform occurs before the trigger.

[Visual Basic]
Property Get StartTime() As Double
Property Let StartTime(value As Double)
[C++]
HRESULT get_StartTime(double* value);
HRESULT put_StartTime(double value);
[ANSI C]
HRESULT IIviScopeAcquisition_get_StartTime(IIviScopeAcquisition* This, double* value);
HRESULT IIviScopeAcquisition_put_StartTime(IIviScopeAcquisition* This, double value);
[C#]
public double StartTime {get; set;}

Capability Group

IviScopeBase

Also In This Interface

NumberOfAverages | NumberOfEnvelopes | Interpolation | RecordLength | SampleMode | SampleRate | Type | NumberOfPointsMin | StartTime | TimePerRecord | ConfigureRecord | IIviScopeAcquisition Overview


TimePerRecord Property

IIviScopeAcquisition.TimePerRecord Property

The time in seconds that corresponds to the record length.

[Visual Basic]
Property Get TimePerRecord() As Double
Property Let TimePerRecord(value As Double)
[C++]
HRESULT get_TimePerRecord(double* value);
HRESULT put_TimePerRecord(double value);
[ANSI C]
HRESULT IIviScopeAcquisition_get_TimePerRecord(IIviScopeAcquisition* This, double* value);
HRESULT IIviScopeAcquisition_put_TimePerRecord(IIviScopeAcquisition* This, double value);
[C#]
public double TimePerRecord {get; set;}

Capability Group

IviScopeBase

Also In This Interface

NumberOfAverages | NumberOfEnvelopes | Interpolation | RecordLength | SampleMode | SampleRate | Type | NumberOfPointsMin | StartTime | TimePerRecord | ConfigureRecord | IIviScopeAcquisition Overview


ConfigureRecord Method

IIviScopeAcquisition.ConfigureRecord Method

Configures the most commonly used properties of the oscilloscope’s acquisition subsystem: time per record, minimum record length, and the acquisition start time.

[Visual Basic]
Sub ConfigureRecord( _
   TimePerRecord As Double, _
   MinNumPts As Long, _
   AcquisitionStartTime As Double _
)
[C++]
HRESULT ConfigureRecord(
   double TimePerRecord,
   long MinNumPts,
   double AcquisitionStartTime
);
[ANSI C]
HRESULT IIviScopeAcquisition_ConfigureRecord(
   IIviScopeAcquisition* This
   double TimePerRecord,
   long MinNumPts,
   double AcquisitionStartTime
);
[C#]
public void ConfigureRecord(
   double TimePerRecord,
   long MinNumPts,
   double AcquisitionStartTime
);

Parameters

TimePerRecord
Specifies the time per record. This value sets the Horizontal Time Per Record property.
MinNumPts
Specifies the minimum number of points the end-user allows in the waveform recorded. This value sets the Horizontal Minimum Number of Points property.
AcquisitionStartTime
Specifies the position of the first point in the waveform record relative to the trigger event. This value sets the Acquisition Start Time property.

Capability Group

IviScopeBase

Related Items

TimePerRecord | NumberOfPointsMin | StartTime

Also In This Interface

NumberOfAverages | NumberOfEnvelopes | Interpolation | RecordLength | SampleMode | SampleRate | Type | NumberOfPointsMin | StartTime | TimePerRecord | ConfigureRecord | IIviScopeAcquisition Overview


IIviScopeChannel Interface

IVI Scope class-compliant channel interface

Methods

Configure | Configures the most commonly used properties of the oscilloscope channel sub-system. They are the range, offset, coupling, probe attenuation, and whether the channel is enabled.
ConfigureCharacteristics | Configures the properties that control the electrical characteristics of the channel. They are the input impedance and the maximum frequency of the input signal.

Properties

ProbeSense | The probe attenuation value the oscilloscope automatically senses. If the automatic probe sense is disabled, its value is the manual probe attenuation setting.
Coupling | How the oscilloscope couples the input signal.
Enabled | If True, the oscilloscope acquires a waveform for this channel when the Initiate Acquisition, Read Waveform, Read Min Max Waveform, or Read Waveform Measurement methods are called.
InputFrequencyMax | The maximum input frequency of this channel. It the frequency at which the input circuitry attenuates the input signal by 3 dB. The units are hertz.
InputImpedance | The input impedance of this channel. The units are ohms.
Offset | The location of the center of the range that you specify with the Range property. The units are volts, with respect to ground. For example, to acquire a sine wave spanning 0.0 to 10.0 volts, set Offset to 5.0 volts.
ProbeAttenuation | The scaling factor by which the probe attenuates the input signal. For example, with a 10:1 probe, the value is 10.0.
Range | The absolute value of the input range the oscilloscope can acquire for the channel. The units are volts. For example, to acquire a sine wave spanning -5.0 to 5.0 volts, set Range to 10.0 volts.


ProbeSense Property

IIviScopeChannel.ProbeSense Property

The probe attenuation value the oscilloscope automatically senses. If the automatic probe sense is disabled, its value is the manual probe attenuation setting.

[Visual Basic]
Property Get ProbeSense() As Double
[C++]
HRESULT get_ProbeSense(double* value);
[ANSI C]
HRESULT IIviScopeChannel_get_ProbeSense(IIviScopeChannel* This, double* value);
[C#]
public double ProbeSense {get;}

Capability Group

IviScopeProbeAutoSense

Also In This Interface

ProbeSense | Coupling | Enabled | InputFrequencyMax | InputImpedance | Offset | ProbeAttenuation | Range | Configure | ConfigureCharacteristics | IIviScopeChannel Overview


Coupling Property

IIviScopeChannel.Coupling Property

How the oscilloscope couples the input signal.

[Visual Basic]
Property Get Coupling() As IviScopeVerticalCouplingEnum
Property Let Coupling(value As IviScopeVerticalCouplingEnum)
[C++]
HRESULT get_Coupling(IviScopeVerticalCouplingEnum* value);
HRESULT put_Coupling(IviScopeVerticalCouplingEnum value);
[ANSI C]
HRESULT IIviScopeChannel_get_Coupling(IIviScopeChannel* This, IviScopeVerticalCouplingEnum* value);
HRESULT IIviScopeChannel_put_Coupling(IIviScopeChannel* This, IviScopeVerticalCouplingEnum value);
[C#]
public IviScopeVerticalCouplingEnum Coupling {get; set;}

Capability Group

IviScopeBase

Related Items

Configure

Also In This Interface

ProbeSense | Coupling | Enabled | InputFrequencyMax | InputImpedance | Offset | ProbeAttenuation | Range | Configure | ConfigureCharacteristics | IIviScopeChannel Overview


Enabled Property

IIviScopeChannel.Enabled Property

If True, the oscilloscope acquires a waveform for this channel when the Initiate Acquisition, Read Waveform, Read Min Max Waveform, or Read Waveform Measurement methods are called.

[Visual Basic]
Property Get Enabled() As Boolean
Property Let Enabled(value As Boolean)
[C++]
HRESULT get_Enabled(VARIANT_BOOL* value);
HRESULT put_Enabled(VARIANT_BOOL value);
[ANSI C]
HRESULT IIviScopeChannel_get_Enabled(IIviScopeChannel* This, VARIANT_BOOL* value);
HRESULT IIviScopeChannel_put_Enabled(IIviScopeChannel* This, VARIANT_BOOL value);
[C#]
public bool Enabled {get; set;}

Capability Group

IviScopeBase

Related Items

Configure

Also In This Interface

ProbeSense | Coupling | Enabled | InputFrequencyMax | InputImpedance | Offset | ProbeAttenuation | Range | Configure | ConfigureCharacteristics | IIviScopeChannel Overview


InputFrequencyMax Property

IIviScopeChannel.InputFrequencyMax Property

The maximum input frequency of this channel. It the frequency at which the input circuitry attenuates the input signal by 3 dB. The units are hertz.

[Visual Basic]
Property Get InputFrequencyMax() As Double
Property Let InputFrequencyMax(value As Double)
[C++]
HRESULT get_InputFrequencyMax(double* value);
HRESULT put_InputFrequencyMax(double value);
[ANSI C]
HRESULT IIviScopeChannel_get_InputFrequencyMax(IIviScopeChannel* This, double* value);
HRESULT IIviScopeChannel_put_InputFrequencyMax(IIviScopeChannel* This, double value);
[C#]
public double InputFrequencyMax {get; set;}

Capability Group

IviScopeBase

Related Items

ConfigureCharacteristics

Also In This Interface

ProbeSense | Coupling | Enabled | InputFrequencyMax | InputImpedance | Offset | ProbeAttenuation | Range | Configure | ConfigureCharacteristics | IIviScopeChannel Overview


InputImpedance Property

IIviScopeChannel.InputImpedance Property

The input impedance of this channel. The units are ohms.

[Visual Basic]
Property Get InputImpedance() As Double
Property Let InputImpedance(value As Double)
[C++]
HRESULT get_InputImpedance(double* value);
HRESULT put_InputImpedance(double value);
[ANSI C]
HRESULT IIviScopeChannel_get_InputImpedance(IIviScopeChannel* This, double* value);
HRESULT IIviScopeChannel_put_InputImpedance(IIviScopeChannel* This, double value);
[C#]
public double InputImpedance {get; set;}

Capability Group

IviScopeBase

Related Items

ConfigureCharacteristics

Also In This Interface

ProbeSense | Coupling | Enabled | InputFrequencyMax | InputImpedance | Offset | ProbeAttenuation | Range | Configure | ConfigureCharacteristics | IIviScopeChannel Overview


Offset Property

IIviScopeChannel.Offset Property

The location of the center of the range that you specify with the Range property. The units are volts, with respect to ground. For example, to acquire a sine wave spanning 0.0 to 10.0 volts, set Offset to 5.0 volts.

[Visual Basic]
Property Get Offset() As Double
Property Let Offset(value As Double)
[C++]
HRESULT get_Offset(double* value);
HRESULT put_Offset(double value);
[ANSI C]
HRESULT IIviScopeChannel_get_Offset(IIviScopeChannel* This, double* value);
HRESULT IIviScopeChannel_put_Offset(IIviScopeChannel* This, double value);
[C#]
public double Offset {get; set;}

Capability Group

IviScopeBase

Related Items

Configure

Also In This Interface

ProbeSense | Coupling | Enabled | InputFrequencyMax | InputImpedance | Offset | ProbeAttenuation | Range | Configure | ConfigureCharacteristics | IIviScopeChannel Overview


ProbeAttenuation Property

IIviScopeChannel.ProbeAttenuation Property

The scaling factor by which the probe attenuates the input signal. For example, with a 10:1 probe, the value is 10.0.

[Visual Basic]
Property Get ProbeAttenuation() As Double
Property Let ProbeAttenuation(value As Double)
[C++]
HRESULT get_ProbeAttenuation(double* value);
HRESULT put_ProbeAttenuation(double value);
[ANSI C]
HRESULT IIviScopeChannel_get_ProbeAttenuation(IIviScopeChannel* This, double* value);
HRESULT IIviScopeChannel_put_ProbeAttenuation(IIviScopeChannel* This, double value);
[C#]
public double ProbeAttenuation {get; set;}

Capability Group

IviScopeBase

Related Items

Configure

Also In This Interface

ProbeSense | Coupling | Enabled | InputFrequencyMax | InputImpedance | Offset | ProbeAttenuation | Range | Configure | ConfigureCharacteristics | IIviScopeChannel Overview


Range Property

IIviScopeChannel.Range Property

The absolute value of the input range the oscilloscope can acquire for the channel. The units are volts. For example, to acquire a sine wave spanning -5.0 to 5.0 volts, set Range to 10.0 volts.

[Visual Basic]
Property Get Range() As Double
Property Let Range(value As Double)
[C++]
HRESULT get_Range(double* value);
HRESULT put_Range(double value);
[ANSI C]
HRESULT IIviScopeChannel_get_Range(IIviScopeChannel* This, double* value);
HRESULT IIviScopeChannel_put_Range(IIviScopeChannel* This, double value);
[C#]
public double Range {get; set;}

Capability Group

IviScopeBase

Related Items

Configure

Also In This Interface

ProbeSense | Coupling | Enabled | InputFrequencyMax | InputImpedance | Offset | ProbeAttenuation | Range | Configure | ConfigureCharacteristics | IIviScopeChannel Overview


Configure Method

IIviScopeChannel.Configure Method

Configures the most commonly used properties of the oscilloscope channel sub-system. They are the range, offset, coupling, probe attenuation, and whether the channel is enabled.

[Visual Basic]
Sub Configure( _
   Range As Double, _
   Offset As Double, _
   Coupling As IviScopeVerticalCouplingEnum, _
   ProbeAttenuation As Double, _
   Enabled As Boolean _
)
[C++]
HRESULT Configure(
   double Range,
   double Offset,
   IviScopeVerticalCouplingEnum Coupling,
   double ProbeAttenuation,
   VARIANT_BOOL Enabled
);
[ANSI C]
HRESULT IIviScopeChannel_Configure(
   IIviScopeChannel* This
   double Range,
   double Offset,
   IviScopeVerticalCouplingEnum Coupling,
   double ProbeAttenuation,
   VARIANT_BOOL Enabled
);
[C#]
public void Configure(
   double Range,
   double Offset,
   IviScopeVerticalCouplingEnum Coupling,
   double ProbeAttenuation,
   bool Enabled
);

Parameters

Range
Specifies the vertical range. This value sets the Vertical Range property.
Offset
Specifies the vertical offset. This value sets the Vertical Offset property.
Coupling
Specifies how to couple the input signal. This value sets the Vertical
ProbeAttenuation
Specifies the probe attenuation. This value sets the Probe Attenuation property.
Enabled
Specifies if the channel is enabled for acquisition. This value sets the Channel Enabled property.

Capability Group

IviScopeBase

Related Items

Range | Offset | Coupling | ProbeAttenuation | Enabled

Also In This Interface

ProbeSense | Coupling | Enabled | InputFrequencyMax | InputImpedance | Offset | ProbeAttenuation | Range | Configure | ConfigureCharacteristics | IIviScopeChannel Overview


ConfigureCharacteristics Method

IIviScopeChannel.ConfigureCharacteristics Method

Configures the properties that control the electrical characteristics of the channel. They are the input impedance and the maximum frequency of the input signal.

[Visual Basic]
Sub ConfigureCharacteristics( _
   InputImpedance As Double, _
   InputFrequencyMax As Double _
)
[C++]
HRESULT ConfigureCharacteristics(
   double InputImpedance,
   double InputFrequencyMax
);
[ANSI C]
HRESULT IIviScopeChannel_ConfigureCharacteristics(
   IIviScopeChannel* This
   double InputImpedance,
   double InputFrequencyMax
);
[C#]
public void ConfigureCharacteristics(
   double InputImpedance,
   double InputFrequencyMax
);

Parameters

InputImpedance
The input impedance for the channel. The driver sets the Input Impedance to this value.
InputFrequencyMax
The maximum input frequency for the channel. The driver sets the Max Input Frequency to this value.

Capability Group

IviScopeBase

Related Items

InputImpedance | InputFrequencyMax

Also In This Interface

ProbeSense | Coupling | Enabled | InputFrequencyMax | InputImpedance | Offset | ProbeAttenuation | Range | Configure | ConfigureCharacteristics | IIviScopeChannel Overview


IIviScopeChannels Interface

IVI Scope class-compliant channel collection interface

Properties

Item | An interface reference pointer to one of the IviScopeChannel interfaces which is selected by the channel name.
Count | The number of channels.
Name | The channel name for a given index.


Item Property

IIviScopeChannels.Item Property

An interface reference pointer to one of the IviScopeChannel interfaces which is selected by the channel name.

[Visual Basic]
Property Get Item(Name As String) As IIviScopeChannel
[C++]
HRESULT get_Item(BSTR Name, IIviScopeChannel** value);
[ANSI C]
HRESULT IIviScopeChannels_get_Item(IIviScopeChannels* This, BSTR Name, IIviScopeChannel** value);
[C#]HRESULT get_Item(string Name, IIviScopeChannel value);

Parameters

Name
The name of a channel. It may be either a string known to the driver or a string defined as a virtual name in the configuration store.

Capability Group

IviScopeBase

Also In This Interface

Item | Count | Name | IIviScopeChannels Overview


Count Property

IIviScopeChannels.Count Property

The number of channels.

[Visual Basic]
Property Get Count() As Long
[C++]
HRESULT get_Count(long* value);
[ANSI C]
HRESULT IIviScopeChannels_get_Count(IIviScopeChannels* This, long* value);
[C#]
public long Count {get;}

Capability Group

IviScopeBase

Also In This Interface

Item | Count | Name | IIviScopeChannels Overview


Name Property

IIviScopeChannels.Name Property

The channel name for a given index.

[Visual Basic]
Property Get Name(Index As Long) As String
[C++]
HRESULT get_Name(long Index, BSTR* value);
[ANSI C]
HRESULT IIviScopeChannels_get_Name(IIviScopeChannels* This, long Index, BSTR* value);
[C#]HRESULT get_Name(long Index, string value);

Parameters

Index
Valid values are between one and the value of the Channel Count property. If the user passes an invalid value for the Index parameter, the value of this property is an empty string

Capability Group

IviScopeBase

Also In This Interface

Item | Count | Name | IIviScopeChannels Overview


IIviScopeMeasurement Interface

IVI Scope class-compliant measurement interface

Methods

FetchWaveform | Returns a previously acquired waveform for this channel. The acquisition must be made prior to calling this method. Call this method separately for each channel.
FetchWaveformMeasurement | Returns a previously acquired waveform measurement for this channel. The acquisition must be made prior to calling this method. Call this method separately for each measurement.
FetchWaveformMinMax | Returns the previously acquired minimum and maximum waveforms for this specified channel. The acquisition must be made prior to calling this method. Call this method separately for each channel.
ReadWaveform | Initiates an acquisition on all enabled channels, waits (up to MaxTime) for the acquisition to complete, and returns the waveform for this channel. Call FetchWaveform to obtain the waveforms for other channels.
ReadWaveformMeasurement | Initiates an acquisition on all enabled channels, waits (up to MaxTime) for the acquisition to complete, and returns the measurement for this channel. Call FetchWaveformMeasurement to obtain other measurements for this or other channels.
ReadWaveformMinMax | Initiates an acquisition on all enabled channels, waits (up to MaxTime) for the acquisition to complete, and returns the min/max waveforms for this channel. Call FetchMinMaxWaveform to obtain the min/max waveforms for other channels.


FetchWaveform Method

IIviScopeMeasurement.FetchWaveform Method

Returns a previously acquired waveform for this channel. The acquisition must be made prior to calling this method. Call this method separately for each channel.

[Visual Basic]
Sub FetchWaveform( _
   WaveformArray As SAFEARRAY(double), _
   InitialX As Double, _
   XIncrement As Double _
)
[C++]
HRESULT FetchWaveform(
   SAFEARRAY(double)* WaveformArray,
   double* InitialX,
   double* XIncrement
);
[ANSI C]
HRESULT IIviScopeMeasurement_FetchWaveform(
   IIviScopeMeasurement* This
   SAFEARRAY(double)* WaveformArray,
   double* InitialX,
   double* XIncrement
);
[C#]
public void FetchWaveform(
   Array WaveformArray,
   double InitialX,
   double XIncrement
);

Parameters

WaveformArray
The array contains the acquired waveform.. Units for the individual array elements are in volts.
InitialX
The time in relation to the Trigger Event of the first point in the waveform in seconds. Negative values mean that the first point in the waveform array was acquired before the trigger event.
XIncrement
The effective time between points in the acquired waveform in seconds.

Capability Group

IviScopeBase

Potential Error Sources

Invalid Waveform Element, Invalid Acquisition Type, Channel Not Enabled

Also In This Interface

FetchWaveform | FetchWaveformMeasurement | FetchWaveformMinMax | ReadWaveform | ReadWaveformMeasurement | ReadWaveformMinMax | IIviScopeMeasurement Overview


FetchWaveformMeasurement Method

IIviScopeMeasurement.FetchWaveformMeasurement Method

Returns a previously acquired waveform measurement for this channel. The acquisition must be made prior to calling this method. Call this method separately for each measurement.

[Visual Basic]
Sub FetchWaveformMeasurement( _
   MeasFunction As IviScopeMeasurementEnum, _
   Measurement As Double _
)
[C++]
HRESULT FetchWaveformMeasurement(
   IviScopeMeasurementEnum MeasFunction,
   double* Measurement
);
[ANSI C]
HRESULT IIviScopeMeasurement_FetchWaveformMeasurement(
   IIviScopeMeasurement* This
   IviScopeMeasurementEnum MeasFunction,
   double* Measurement
);
[C#]
public void FetchWaveformMeasurement(
   IviScopeMeasurementEnum MeasFunction,
   double Measurement
);

Parameters

MeasFunction
Characteristic of the acquired waveform to be measured.
Measurement
The measured value. The units depend on the measurement that the user specifies with the measFunction parameter.

Capability Group

IviScopeWaveformMeas

Potential Error Sources

Unable To Perform Measurement, Channel Not Enabled

Also In This Interface

FetchWaveform | FetchWaveformMeasurement | FetchWaveformMinMax | ReadWaveform | ReadWaveformMeasurement | ReadWaveformMinMax | IIviScopeMeasurement Overview


FetchWaveformMinMax Method

IIviScopeMeasurement.FetchWaveformMinMax Method

Returns the previously acquired minimum and maximum waveforms for this specified channel. The acquisition must be made prior to calling this method. Call this method separately for each channel.

[Visual Basic]
Sub FetchWaveformMinMax( _
   MinWaveform As SAFEARRAY(double), _
   MaxWaveform As SAFEARRAY(double), _
   InitialX As Double, _
   XIncrement As Double _
)
[C++]
HRESULT FetchWaveformMinMax(
   SAFEARRAY(double)* MinWaveform,
   SAFEARRAY(double)* MaxWaveform,
   double* InitialX,
   double* XIncrement
);
[ANSI C]
HRESULT IIviScopeMeasurement_FetchWaveformMinMax(
   IIviScopeMeasurement* This
   SAFEARRAY(double)* MinWaveform,
   SAFEARRAY(double)* MaxWaveform,
   double* InitialX,
   double* XIncrement
);
[C#]
public void FetchWaveformMinMax(
   Array MinWaveform,
   Array MaxWaveform,
   double InitialX,
   double XIncrement
);

Parameters

MinWaveform
This array contains the min waveform.
MaxWaveform
This array contains the max waveform.
InitialX
The time in relation to the Trigger Event of the first point in the waveform in seconds.
XIncrement
The time between points in the acquired waveform in seconds.

Capability Group

IviScopeMinMaxWaveform

Potential Error Sources

Invalid Waveform Element, Channel Not Enabled, Invalid Acquisition Type

Also In This Interface

FetchWaveform | FetchWaveformMeasurement | FetchWaveformMinMax | ReadWaveform | ReadWaveformMeasurement | ReadWaveformMinMax | IIviScopeMeasurement Overview


ReadWaveform Method

IIviScopeMeasurement.ReadWaveform Method

Initiates an acquisition on all enabled channels, waits (up to MaxTime) for the acquisition to complete, and returns the waveform for this channel. Call FetchWaveform to obtain the waveforms for other channels.

[Visual Basic]
Sub ReadWaveform( _
   MaxTimeMilliseconds As Long, _
   WaveformArray As SAFEARRAY(double), _
   InitialX As Double, _
   XIncrement As Double _
)
[C++]
HRESULT ReadWaveform(
   long MaxTimeMilliseconds,
   SAFEARRAY(double)* WaveformArray,
   double* InitialX,
   double* XIncrement
);
[ANSI C]
HRESULT IIviScopeMeasurement_ReadWaveform(
   IIviScopeMeasurement* This
   long MaxTimeMilliseconds,
   SAFEARRAY(double)* WaveformArray,
   double* InitialX,
   double* XIncrement
);
[C#]
public void ReadWaveform(
   long MaxTimeMilliseconds,
   Array WaveformArray,
   double InitialX,
   double XIncrement
);

Parameters

MaxTimeMilliseconds
Specifies the maximum time the end-user allows for this method to complete in milliseconds. The values defined in IviScopeTimeOutEnum are also allowed.
WaveformArray
The array contains the acquired waveform.. Units for the individual array elements are in volts.
InitialX
The time in relation to the Trigger Event of the first point in the waveform in seconds. Negative values mean that the first point in the waveform array was acquired before the trigger event.
XIncrement
The effective time between points in the acquired waveform in seconds.

Capability Group

IviScopeBase

Potential Error Sources

Invalid Waveform Element, Invalid Acquisition Type, Channel Not Enabled, Max Time Exceeded

Also In This Interface

FetchWaveform | FetchWaveformMeasurement | FetchWaveformMinMax | ReadWaveform | ReadWaveformMeasurement | ReadWaveformMinMax | IIviScopeMeasurement Overview


ReadWaveformMeasurement Method

IIviScopeMeasurement.ReadWaveformMeasurement Method

Initiates an acquisition on all enabled channels, waits (up to MaxTime) for the acquisition to complete, and returns the measurement for this channel. Call FetchWaveformMeasurement to obtain other measurements for this or other channels.

[Visual Basic]
Sub ReadWaveformMeasurement( _
   MeasFunction As IviScopeMeasurementEnum, _
   MaxTimeMilliseconds As Long, _
   Measurement As Double _
)
[C++]
HRESULT ReadWaveformMeasurement(
   IviScopeMeasurementEnum MeasFunction,
   long MaxTimeMilliseconds,
   double* Measurement
);
[ANSI C]
HRESULT IIviScopeMeasurement_ReadWaveformMeasurement(
   IIviScopeMeasurement* This
   IviScopeMeasurementEnum MeasFunction,
   long MaxTimeMilliseconds,
   double* Measurement
);
[C#]
public void ReadWaveformMeasurement(
   IviScopeMeasurementEnum MeasFunction,
   long MaxTimeMilliseconds,
   double Measurement
);

Parameters

MeasFunction
Characteristic of the acquired waveform to be measured.
MaxTimeMilliseconds
Specifies the maximum time the end-user allows for this method to complete in milliseconds. The values defined in IviScopeTimeOutEnum are also allowed.
Measurement
The measured value. The units depend on the measurement that the user specifies with the measFunction parameter.

Capability Group

IviScopeWaveformMeas

Potential Error Sources

Channel Not Enabled, Max Time Exceeded, Unable To Perform Measurement

Also In This Interface

FetchWaveform | FetchWaveformMeasurement | FetchWaveformMinMax | ReadWaveform | ReadWaveformMeasurement | ReadWaveformMinMax | IIviScopeMeasurement Overview


ReadWaveformMinMax Method

IIviScopeMeasurement.ReadWaveformMinMax Method

Initiates an acquisition on all enabled channels, waits (up to MaxTime) for the acquisition to complete, and returns the min/max waveforms for this channel. Call FetchMinMaxWaveform to obtain the min/max waveforms for other channels.

[Visual Basic]
Sub ReadWaveformMinMax( _
   MaxTimeMilliseconds As Long, _
   MinWaveform As SAFEARRAY(double), _
   MaxWaveform As SAFEARRAY(double), _
   InitialX As Double, _
   XIncrement As Double _
)
[C++]
HRESULT ReadWaveformMinMax(
   long MaxTimeMilliseconds,
   SAFEARRAY(double)* MinWaveform,
   SAFEARRAY(double)* MaxWaveform,
   double* InitialX,
   double* XIncrement
);
[ANSI C]
HRESULT IIviScopeMeasurement_ReadWaveformMinMax(
   IIviScopeMeasurement* This
   long MaxTimeMilliseconds,
   SAFEARRAY(double)* MinWaveform,
   SAFEARRAY(double)* MaxWaveform,
   double* InitialX,
   double* XIncrement
);
[C#]
public void ReadWaveformMinMax(
   long MaxTimeMilliseconds,
   Array MinWaveform,
   Array MaxWaveform,
   double InitialX,
   double XIncrement
);

Parameters

MaxTimeMilliseconds
Specifies the maximum time the end-user allows for this method to complete in milliseconds. The values defined in IviScopeTimeOutEnum are also allowed.
MinWaveform
This array contains the min waveform.
MaxWaveform
This array contains the max waveform.
InitialX
The time in relation to the Trigger Event of the first point in the waveform in seconds.
XIncrement
The time between points in the acquired waveform in seconds.

Capability Group

IviScopeMinMaxWaveform

Potential Error Sources

Invalid Waveform Element, Channel Not Enabled, Invalid Acquisition Type, Max Time Exceeded

Also In This Interface

FetchWaveform | FetchWaveformMeasurement | FetchWaveformMinMax | ReadWaveform | ReadWaveformMeasurement | ReadWaveformMinMax | IIviScopeMeasurement Overview


IIviScopeMeasurements Interface

IVI Scope class-compliant measurement collection interface

Methods

Initiate | Initiates a waveform acquisition. The oscilloscope leaves the Idle state and waits for a trigger. The oscilloscope acquires a waveform for each enabled channel.
Abort | Aborts an acquisition and returns the oscilloscope to the Idle state.
AutoSetup | Automatically configures all the oscilloscopes settings based on the input signals.
Status | Returns whether an acquisition is in progress, complete, or if the status is unknown.
IsWaveformElementInvalid | Returns False if an element in a waveform array returned by the driver contains a valid voltage. Returns True if an element in a waveform array returned by the driver contains a value indicating that the oscilloscope could not sample a voltage.

Properties

Item | An interface reference pointer to one of the IviScopeMeasurement interfaces which is selected by the channel name.
Count | The number of measurements.
Name | The channel name for given index.


Item Property

IIviScopeMeasurements.Item Property

An interface reference pointer to one of the IviScopeMeasurement interfaces which is selected by the channel name.

[Visual Basic]
Property Get Item(Name As String) As IIviScopeMeasurement
[C++]
HRESULT get_Item(BSTR Name, IIviScopeMeasurement** value);
[ANSI C]
HRESULT IIviScopeMeasurements_get_Item(IIviScopeMeasurements* This, BSTR Name, IIviScopeMeasurement** value);
[C#]HRESULT get_Item(string Name, IIviScopeMeasurement value);

Parameters

Name
The name of a channel. It may be either a string known to the driver or a string defined as a virtual name in the configuration store.

Capability Group

IviScopeBase

Also In This Interface

Item | Count | Name | Initiate | Abort | AutoSetup | Status | IsWaveformElementInvalid | IIviScopeMeasurements Overview


Count Property

IIviScopeMeasurements.Count Property

The number of measurements.

[Visual Basic]
Property Get Count() As Long
[C++]
HRESULT get_Count(long* value);
[ANSI C]
HRESULT IIviScopeMeasurements_get_Count(IIviScopeMeasurements* This, long* value);
[C#]
public long Count {get;}

Capability Group

IviScopeBase

Also In This Interface

Item | Count | Name | Initiate | Abort | AutoSetup | Status | IsWaveformElementInvalid | IIviScopeMeasurements Overview


Name Property

IIviScopeMeasurements.Name Property

The channel name for given index.

[Visual Basic]
Property Get Name(Index As Long) As String
[C++]
HRESULT get_Name(long Index, BSTR* value);
[ANSI C]
HRESULT IIviScopeMeasurements_get_Name(IIviScopeMeasurements* This, long Index, BSTR* value);
[C#]HRESULT get_Name(long Index, string value);

Parameters

Index
Valid values are between one and the value of the Measuremen Count property. If the user passes an invalid value for the Index parameter, the value of this property is an empty string

Capability Group

IviScopeBase

Also In This Interface

Item | Count | Name | Initiate | Abort | AutoSetup | Status | IsWaveformElementInvalid | IIviScopeMeasurements Overview


Initiate Method

IIviScopeMeasurements.Initiate Method

Initiates a waveform acquisition. The oscilloscope leaves the Idle state and waits for a trigger. The oscilloscope acquires a waveform for each enabled channel.

[Visual Basic]
Sub Initiate()
[C++]
HRESULT Initiate();
[ANSI C]
HRESULT IIviScopeMeasurements_Initiate(
   IIviScopeMeasurements* This);
[C#]
public void Initiate();

Capability Group

IviScopeBase

Also In This Interface

Item | Count | Name | Initiate | Abort | AutoSetup | Status | IsWaveformElementInvalid | IIviScopeMeasurements Overview


Abort Method

IIviScopeMeasurements.Abort Method

Aborts an acquisition and returns the oscilloscope to the Idle state.

[Visual Basic]
Sub Abort()
[C++]
HRESULT Abort();
[ANSI C]
HRESULT IIviScopeMeasurements_Abort(
   IIviScopeMeasurements* This);
[C#]
public void Abort();

Capability Group

IviScopeBase

Also In This Interface

Item | Count | Name | Initiate | Abort | AutoSetup | Status | IsWaveformElementInvalid | IIviScopeMeasurements Overview


AutoSetup Method

IIviScopeMeasurements.AutoSetup Method

Automatically configures all the oscilloscopes settings based on the input signals.

[Visual Basic]
Sub AutoSetup()
[C++]
HRESULT AutoSetup();
[ANSI C]
HRESULT IIviScopeMeasurements_AutoSetup(
   IIviScopeMeasurements* This);
[C#]
public void AutoSetup();

Capability Group

IviScopeAutoSetup

Also In This Interface

Item | Count | Name | Initiate | Abort | AutoSetup | Status | IsWaveformElementInvalid | IIviScopeMeasurements Overview


Status Method

IIviScopeMeasurements.Status Method

Returns whether an acquisition is in progress, complete, or if the status is unknown.

[Visual Basic]
Function Status() As IviScopeAcquisitionStatusEnum
[C++]
HRESULT Status(
   IviScopeAcquisitionStatusEnum* Status
);
[ANSI C]
HRESULT IIviScopeMeasurements_Status(
   IIviScopeMeasurements* This
   IviScopeAcquisitionStatusEnum* Status
);
[C#]
public IviScopeAcquisitionStatusEnum Status();

Parameters

Status
Acquisition Status. May be one of the values define by IviScopeAcquisitionStatusEnum.

Capability Group

IviScopeBase

Also In This Interface

Item | Count | Name | Initiate | Abort | AutoSetup | Status | IsWaveformElementInvalid | IIviScopeMeasurements Overview


IsWaveformElementInvalid Method

IIviScopeMeasurements.IsWaveformElementInvalid Method

Returns False if an element in a waveform array returned by the driver contains a valid voltage. Returns True if an element in a waveform array returned by the driver contains a value indicating that the oscilloscope could not sample a voltage.

[Visual Basic]
Function IsWaveformElementInvalid( _
   Element As Double _
) As Boolean
[C++]
HRESULT IsWaveformElementInvalid(
   double Element,
   VARIANT_BOOL* IsInvalid
);
[ANSI C]
HRESULT IIviScopeMeasurements_IsWaveformElementInvalid(
   IIviScopeMeasurements* This
   double Element,
   VARIANT_BOOL* IsInvalid
);
[C#]
public bool IsWaveformElementInvalid(
   double Element
);

Parameters

Element
Pass one of the values from the waveform array returned by the read and fetch waveform methods.
IsInvalid
Returns whether the elementValue is a valid voltage or a value indicating that the oscilloscope could not sample a voltage. Valid return values:
True
The elementValue indicates that the oscilloscope could not sample the voltage.
False
The elementValue is a valid voltage.

Capability Group

IviScopeBase

Also In This Interface

Item | Count | Name | Initiate | Abort | AutoSetup | Status | IsWaveformElementInvalid | IIviScopeMeasurements Overview


IIviScopeReferenceLevel Interface

IVI Scope class-compliant reference level interface

Methods

Configure Configures the reference levels for waveform measurements, low, mid, and high.

Properties

High | The high reference for waveform measurements. It is a percentage of the difference between the Voltage High and Voltage Low. Voltage High and Voltage Low may be calculated using either the min/max or histogram methods.
Low | The low reference for waveform measurements. It is a percentage of the difference between the Voltage High and Voltage Low. Voltage High and Voltage Low may be calculated using either the min/max or histogram methods.
Mid | The mid reference for waveform measurements. It is a percentage of the difference between the Voltage High and Voltage Low. Voltage High and Voltage Low may be calculated using either the min/max or histogram methods.


High Property

IIviScopeReferenceLevel.High Property

The high reference for waveform measurements. It is a percentage of the difference between the Voltage High and Voltage Low. Voltage High and Voltage Low may be calculated using either the min/max or histogram methods.

[Visual Basic]
Property Get High() As Double
Property Let High(value As Double)
[C++]
HRESULT get_High(double* value);
HRESULT put_High(double value);
[ANSI C]
HRESULT IIviScopeReferenceLevel_get_High(IIviScopeReferenceLevel* This, double* value);
HRESULT IIviScopeReferenceLevel_put_High(IIviScopeReferenceLevel* This, double value);
[C#]
public double High {get; set;}

Capability Group

IviScopeWaveformMeas

Related Items

Configure

Also In This Interface

High | Low | Mid | Configure | IIviScopeReferenceLevel Overview


Low Property

IIviScopeReferenceLevel.Low Property

The low reference for waveform measurements. It is a percentage of the difference between the Voltage High and Voltage Low. Voltage High and Voltage Low may be calculated using either the min/max or histogram methods.

[Visual Basic]
Property Get Low() As Double
Property Let Low(value As Double)
[C++]
HRESULT get_Low(double* value);
HRESULT put_Low(double value);
[ANSI C]
HRESULT IIviScopeReferenceLevel_get_Low(IIviScopeReferenceLevel* This, double* value);
HRESULT IIviScopeReferenceLevel_put_Low(IIviScopeReferenceLevel* This, double value);
[C#]
public double Low {get; set;}

Capability Group

IviScopeWaveformMeas

Related Items

Configure

Also In This Interface

High | Low | Mid | Configure | IIviScopeReferenceLevel Overview


Mid Property

IIviScopeReferenceLevel.Mid Property

The mid reference for waveform measurements. It is a percentage of the difference between the Voltage High and Voltage Low. Voltage High and Voltage Low may be calculated using either the min/max or histogram methods.

[Visual Basic]
Property Get Mid() As Double
Property Let Mid(value As Double)
[C++]
HRESULT get_Mid(double* value);
HRESULT put_Mid(double value);
[ANSI C]
HRESULT IIviScopeReferenceLevel_get_Mid(IIviScopeReferenceLevel* This, double* value);
HRESULT IIviScopeReferenceLevel_put_Mid(IIviScopeReferenceLevel* This, double value);
[C#]
public double Mid {get; set;}

Capability Group

IviScopeWaveformMeas

Related Items

Configure

Also In This Interface

High | Low | Mid | Configure | IIviScopeReferenceLevel Overview


Configure Method

IIviScopeReferenceLevel.Configure Method

Configures the reference levels for waveform measurements, low, mid, and high.

[Visual Basic]
Sub Configure( _
   Low As Double, _
   Mid As Double, _
   High As Double _
)
[C++]
HRESULT Configure(
   double Low,
   double Mid,
   double High
);
[ANSI C]
HRESULT IIviScopeReferenceLevel_Configure(
   IIviScopeReferenceLevel* This
   double Low,
   double Mid,
   double High
);
[C#]
public void Configure(
   double Low,
   double Mid,
   double High
);

Parameters

Low
Measurement low reference. This value sets the Meas Low Ref property
Mid
Measurement mid reference. This value sets the Meas Mid Ref property.
High
Measurement high reference. This value sets the Meas High Ref property.

Capability Group

IviScopeWaveformMeas

Related Items

Low | Mid | High

Also In This Interface

High | Low | Mid | Configure | IIviScopeReferenceLevel Overview


IIviScopeTrigger Interface

IVI Scope class-compliant trigger interface

Methods

Configure Configures trigger Type and Holdoff. Holdoff units are seconds.

Properties

Continuous | If True, the oscilloscope waits trigger holdoff seconds after a waveform acquisition is complete and then immediatley enters the wait for trigger state without passing through the idle state.
Coupling | How the oscilloscope couples the trigger source.
Level | The voltage threshold for the trigger subsystem. The units are volts.
Modifier | The trigger modifier determines the oscilloscope's behavior in the absence of a trigger.
Source | The signal the oscilloscope monitors for a trigger. It can be channel or one of many other values.
Holdoff | The length of time the oscilloscope waits after it fills the acquisition buffer until the oscilloscope enables the trigger subsystem to detect another trigger. The units are seconds.
Type | The kind of event that triggers the osciolloscope.
AcLine | Pointer to the class-compliant IIviScopeTriggerAcLine interface
Edge | Pointer to the class-compliant IIviScopeTriggerEdge interface
Glitch | Pointer to the class-compliant IIviScopeTriggerGlitch interface
Runt | Pointer to the class-compliant IIviScopeTriggerRunt interface
TV | Pointer to the class-compliant IIviScopeTriggerTv interface
Width | Pointer to the class-compliant IIviScopeTriggerWidth interface


Continuous Property

IIviScopeTrigger.Continuous Property

If True, the oscilloscope waits trigger holdoff seconds after a waveform acquisition is complete and then immediatley enters the wait for trigger state without passing through the idle state.

[Visual Basic]
Property Get Continuous() As Boolean
Property Let Continuous(value As Boolean)
[C++]
HRESULT get_Continuous(VARIANT_BOOL* value);
HRESULT put_Continuous(VARIANT_BOOL value);
[ANSI C]
HRESULT IIviScopeTrigger_get_Continuous(IIviScopeTrigger* This, VARIANT_BOOL* value);
HRESULT IIviScopeTrigger_put_Continuous(IIviScopeTrigger* This, VARIANT_BOOL value);
[C#]
public bool Continuous {get; set;}

Capability Group

IviScopeContinuousAcquisition

Also In This Interface

Continuous | Coupling | Level | Modifier | Source | Holdoff | Type | AcLine | Edge | Glitch | Runt | TV | Width | Configure | IIviScopeTrigger Overview


Coupling Property

IIviScopeTrigger.Coupling Property

How the oscilloscope couples the trigger source.

[Visual Basic]
Property Get Coupling() As IviScopeTriggerCouplingEnum
Property Let Coupling(value As IviScopeTriggerCouplingEnum)
[C++]
HRESULT get_Coupling(IviScopeTriggerCouplingEnum* value);
HRESULT put_Coupling(IviScopeTriggerCouplingEnum value);
[ANSI C]
HRESULT IIviScopeTrigger_get_Coupling(IIviScopeTrigger* This, IviScopeTriggerCouplingEnum* value);
HRESULT IIviScopeTrigger_put_Coupling(IIviScopeTrigger* This, IviScopeTriggerCouplingEnum value);
[C#]
public IviScopeTriggerCouplingEnum Coupling {get; set;}

Capability Group

IviScopeBase

Also In This Interface

Continuous | Coupling | Level | Modifier | Source | Holdoff | Type | AcLine | Edge | Glitch | Runt | TV | Width | Configure | IIviScopeTrigger Overview


Level Property

IIviScopeTrigger.Level Property

The voltage threshold for the trigger subsystem. The units are volts.

[Visual Basic]
Property Get Level() As Double
Property Let Level(value As Double)
[C++]
HRESULT get_Level(double* value);
HRESULT put_Level(double value);
[ANSI C]
HRESULT IIviScopeTrigger_get_Level(IIviScopeTrigger* This, double* value);
HRESULT IIviScopeTrigger_put_Level(IIviScopeTrigger* This, double value);
[C#]
public double Level {get; set;}

Capability Group

IviScopeBase

Related Items

IIviScopeTriggerEdge.Configure | IIviScopeTriggerGlitch.Configure | IIviScopeTriggerWidth.Configure

Also In This Interface

Continuous | Coupling | Level | Modifier | Source | Holdoff | Type | AcLine | Edge | Glitch | Runt | TV | Width | Configure | IIviScopeTrigger Overview


Modifier Property

IIviScopeTrigger.Modifier Property

The trigger modifier determines the oscilloscope's behavior in the absence of a trigger.

[Visual Basic]
Property Get Modifier() As IviScopeTriggerModifierEnum
Property Let Modifier(value As IviScopeTriggerModifierEnum)
[C++]
HRESULT get_Modifier(IviScopeTriggerModifierEnum* value);
HRESULT put_Modifier(IviScopeTriggerModifierEnum value);
[ANSI C]
HRESULT IIviScopeTrigger_get_Modifier(IIviScopeTrigger* This, IviScopeTriggerModifierEnum* value);
HRESULT IIviScopeTrigger_put_Modifier(IIviScopeTrigger* This, IviScopeTriggerModifierEnum value);
[C#]
public IviScopeTriggerModifierEnum Modifier {get; set;}

Capability Group

IviScopeTriggerModifier

Also In This Interface

Continuous | Coupling | Level | Modifier | Source | Holdoff | Type | AcLine | Edge | Glitch | Runt | TV | Width | Configure | IIviScopeTrigger Overview


Source Property

IIviScopeTrigger.Source Property

The signal the oscilloscope monitors for a trigger. It can be channel or one of many other values.

[Visual Basic]
Property Get Source() As String
Property Let Source(value As String)
[C++]
HRESULT get_Source(BSTR* value);
HRESULT put_Source(BSTR value);
[ANSI C]
HRESULT IIviScopeTrigger_get_Source(IIviScopeTrigger* This, BSTR* value);
HRESULT IIviScopeTrigger_put_Source(IIviScopeTrigger* This, BSTR value);
[C#]
public string Source {get; set;}

Capability Group

IviScopeBase

Related Items

IIviScopeTriggerEdge.Configure | IIviScopeTriggerGlitch.Configure | IIviScopeTriggerWidth.Configure | IIviScopeTriggerRunt.Configure | IIviScopeTriggerTv.Configure

Also In This Interface

Continuous | Coupling | Level | Modifier | Source | Holdoff | Type | AcLine | Edge | Glitch | Runt | TV | Width | Configure | IIviScopeTrigger Overview


Holdoff Property

IIviScopeTrigger.Holdoff Property

The length of time the oscilloscope waits after it fills the acquisition buffer until the oscilloscope enables the trigger subsystem to detect another trigger. The units are seconds.

[Visual Basic]
Property Get Holdoff() As Double
Property Let Holdoff(value As Double)
[C++]
HRESULT get_Holdoff(double* value);
HRESULT put_Holdoff(double value);
[ANSI C]
HRESULT IIviScopeTrigger_get_Holdoff(IIviScopeTrigger* This, double* value);
HRESULT IIviScopeTrigger_put_Holdoff(IIviScopeTrigger* This, double value);
[C#]
public double Holdoff {get; set;}

Capability Group

IviScopeBase

Related Items

Configure

Also In This Interface

Continuous | Coupling | Level | Modifier | Source | Holdoff | Type | AcLine | Edge | Glitch | Runt | TV | Width | Configure | IIviScopeTrigger Overview


Type Property

IIviScopeTrigger.Type Property

The kind of event that triggers the osciolloscope.

[Visual Basic]
Property Get Type() As IviScopeTriggerTypeEnum
Property Let Type(value As IviScopeTriggerTypeEnum)
[C++]
HRESULT get_Type(IviScopeTriggerTypeEnum* value);
HRESULT put_Type(IviScopeTriggerTypeEnum value);
[ANSI C]
HRESULT IIviScopeTrigger_get_Type(IIviScopeTrigger* This, IviScopeTriggerTypeEnum* value);
HRESULT IIviScopeTrigger_put_Type(IIviScopeTrigger* This, IviScopeTriggerTypeEnum value);
[C#]
public IviScopeTriggerTypeEnum Type {get; set;}

Capability Group

IviScopeBase

Related Items

Configure

Also In This Interface

Continuous | Coupling | Level | Modifier | Source | Holdoff | Type | AcLine | Edge | Glitch | Runt | TV | Width | Configure | IIviScopeTrigger Overview


AcLine Property

IIviScopeTrigger.AcLine Property

Pointer to the class-compliant IIviScopeTriggerAcLine interface

[Visual Basic]
Property Get AcLine() As IIviScopeTriggerAcLine
[C++]
HRESULT get_AcLine(IIviScopeTriggerAcLine** value);
[ANSI C]
HRESULT IIviScopeTrigger_get_AcLine(IIviScopeTrigger* This, IIviScopeTriggerAcLine** value);
[C#]
public IIviScopeTriggerAcLine AcLine {get;}

Capability Group

IviScopeAcLineTrigger

Also In This Interface

Continuous | Coupling | Level | Modifier | Source | Holdoff | Type | AcLine | Edge | Glitch | Runt | TV | Width | Configure | IIviScopeTrigger Overview


Edge Property

IIviScopeTrigger.Edge Property

Pointer to the class-compliant IIviScopeTriggerEdge interface

[Visual Basic]
Property Get Edge() As IIviScopeTriggerEdge
[C++]
HRESULT get_Edge(IIviScopeTriggerEdge** value);
[ANSI C]
HRESULT IIviScopeTrigger_get_Edge(IIviScopeTrigger* This, IIviScopeTriggerEdge** value);
[C#]
public IIviScopeTriggerEdge Edge {get;}

Capability Group

IviScopeBase

Also In This Interface

Continuous | Coupling | Level | Modifier | Source | Holdoff | Type | AcLine | Edge | Glitch | Runt | TV | Width | Configure | IIviScopeTrigger Overview


Glitch Property

IIviScopeTrigger.Glitch Property

Pointer to the class-compliant IIviScopeTriggerGlitch interface

[Visual Basic]
Property Get Glitch() As IIviScopeTriggerGlitch
[C++]
HRESULT get_Glitch(IIviScopeTriggerGlitch** value);
[ANSI C]
HRESULT IIviScopeTrigger_get_Glitch(IIviScopeTrigger* This, IIviScopeTriggerGlitch** value);
[C#]
public IIviScopeTriggerGlitch Glitch {get;}

Capability Group

IviScopeGlitchTrigger

Also In This Interface

Continuous | Coupling | Level | Modifier | Source | Holdoff | Type | AcLine | Edge | Glitch | Runt | TV | Width | Configure | IIviScopeTrigger Overview


Runt Property

IIviScopeTrigger.Runt Property

Pointer to the class-compliant IIviScopeTriggerRunt interface

[Visual Basic]
Property Get Runt() As IIviScopeTriggerRunt
[C++]
HRESULT get_Runt(IIviScopeTriggerRunt** value);
[ANSI C]
HRESULT IIviScopeTrigger_get_Runt(IIviScopeTrigger* This, IIviScopeTriggerRunt** value);
[C#]
public IIviScopeTriggerRunt Runt {get;}

Capability Group

IviScopeRuntTrigger

Also In This Interface

Continuous | Coupling | Level | Modifier | Source | Holdoff | Type | AcLine | Edge | Glitch | Runt | TV | Width | Configure | IIviScopeTrigger Overview


TV Property

IIviScopeTrigger.TV Property

Pointer to the class-compliant IIviScopeTriggerTv interface

[Visual Basic]
Property Get TV() As IIviScopeTriggerTv
[C++]
HRESULT get_TV(IIviScopeTriggerTv** value);
[ANSI C]
HRESULT IIviScopeTrigger_get_TV(IIviScopeTrigger* This, IIviScopeTriggerTv** value);
[C#]
public IIviScopeTriggerTv TV {get;}

Capability Group

IviScopeTVTrigger

Also In This Interface

Continuous | Coupling | Level | Modifier | Source | Holdoff | Type | AcLine | Edge | Glitch | Runt | TV | Width | Configure | IIviScopeTrigger Overview


Width Property

IIviScopeTrigger.Width Property

Pointer to the class-compliant IIviScopeTriggerWidth interface

[Visual Basic]
Property Get Width() As IIviScopeTriggerWidth
[C++]
HRESULT get_Width(IIviScopeTriggerWidth** value);
[ANSI C]
HRESULT IIviScopeTrigger_get_Width(IIviScopeTrigger* This, IIviScopeTriggerWidth** value);
[C#]
public IIviScopeTriggerWidth Width {get;}

Capability Group

IviScopeWidthTrigger

Also In This Interface

Continuous | Coupling | Level | Modifier | Source | Holdoff | Type | AcLine | Edge | Glitch | Runt | TV | Width | Configure | IIviScopeTrigger Overview


Configure Method

IIviScopeTrigger.Configure Method

Configures trigger Type and Holdoff. Holdoff units are seconds.

[Visual Basic]
Sub Configure( _
   Type As IviScopeTriggerTypeEnum, _
   Holdoff As Double _
)
[C++]
HRESULT Configure(
   IviScopeTriggerTypeEnum Type,
   double Holdoff
);
[ANSI C]
HRESULT IIviScopeTrigger_Configure(
   IIviScopeTrigger* This
   IviScopeTriggerTypeEnum Type,
   double Holdoff
);
[C#]
public void Configure(
   IviScopeTriggerTypeEnum Type,
   double Holdoff
);

Parameters

Type
Specifies the trigger type. This value sets the Trigger Type property.
Holdoff
Specifies the trigger hold-off. This value sets the Trigger Holdoff property.

Capability Group

IviScopeBase

Related Items

Type | Holdoff

Also In This Interface

Continuous | Coupling | Level | Modifier | Source | Holdoff | Type | AcLine | Edge | Glitch | Runt | TV | Width | Configure | IIviScopeTrigger Overview


IIviScopeTriggerAcLine Interface

IVI Scope class-compliant AC line trigger interface

Properties

Slope The slope of the zero crossing upon which the scope triggers.


Slope Property

IIviScopeTriggerAcLine.Slope Property

The slope of the zero crossing upon which the scope triggers.

[Visual Basic]
Property Get Slope() As IviScopeACLineSlopeEnum
Property Let Slope(value As IviScopeACLineSlopeEnum)
[C++]
HRESULT get_Slope(IviScopeACLineSlopeEnum* value);
HRESULT put_Slope(IviScopeACLineSlopeEnum value);
[ANSI C]
HRESULT IIviScopeTriggerAcLine_get_Slope(IIviScopeTriggerAcLine* This, IviScopeACLineSlopeEnum* value);
HRESULT IIviScopeTriggerAcLine_put_Slope(IIviScopeTriggerAcLine* This, IviScopeACLineSlopeEnum value);
[C#]
public IviScopeACLineSlopeEnum Slope {get; set;}

Capability Group

IviScopeAcLineTrigger

Also In This Interface

Slope | IIviScopeTriggerAcLine Overview


IIviScopeTriggerEdge Interface

IVI Scope class-compliant edge trigger interface

Methods

Configure Configures the conidtions for edge trigger. An edge trigger occurs when the trigger source signal passes through the trigger level with the specified slope.

Properties

Slope The slope, a rising or a falling edge, that triggers the oscilloscope.


Slope Property

IIviScopeTriggerEdge.Slope Property

The slope, a rising or a falling edge, that triggers the oscilloscope.

[Visual Basic]
Property Get Slope() As IviScopeTriggerSlopeEnum
Property Let Slope(value As IviScopeTriggerSlopeEnum)
[C++]
HRESULT get_Slope(IviScopeTriggerSlopeEnum* value);
HRESULT put_Slope(IviScopeTriggerSlopeEnum value);
[ANSI C]
HRESULT IIviScopeTriggerEdge_get_Slope(IIviScopeTriggerEdge* This, IviScopeTriggerSlopeEnum* value);
HRESULT IIviScopeTriggerEdge_put_Slope(IIviScopeTriggerEdge* This, IviScopeTriggerSlopeEnum value);
[C#]
public IviScopeTriggerSlopeEnum Slope {get; set;}

Capability Group

IviScopeBase

Related Items

Configure

Also In This Interface

Slope | Configure | IIviScopeTriggerEdge Overview


Configure Method

IIviScopeTriggerEdge.Configure Method

Configures the conidtions for edge trigger. An edge trigger occurs when the trigger source signal passes through the trigger level with the specified slope.

[Visual Basic]
Sub Configure( _
   Source As String, _
   Level As Double, _
   Slope As IviScopeTriggerSlopeEnum _
)
[C++]
HRESULT Configure(
   BSTR Source,
   double Level,
   IviScopeTriggerSlopeEnum Slope
);
[ANSI C]
HRESULT IIviScopeTriggerEdge_Configure(
   IIviScopeTriggerEdge* This
   BSTR Source,
   double Level,
   IviScopeTriggerSlopeEnum Slope
);
[C#]
public void Configure(
   string Source,
   double Level,
   IviScopeTriggerSlopeEnum Slope
);

Parameters

Source
Specifies the trigger source. This value sets the Trigger Source property.
Level
Specifies the trigger level. This value sets the Trigger Level property.
Slope
Specifies the trigger slope. This value sets the Trigger Slope property.

Capability Group

IviScopeBase

Related Items

IIviScopeTrigger.Level | IIviScopeTrigger.Source | Slope

Also In This Interface

Slope | Configure | IIviScopeTriggerEdge Overview


IIviScopeTriggerGlitch Interface

IVI Scope class-compliant glitch trigger interface

Methods

Configure Configure the glitch trigger Source, Level, Width, Polarity, and Condition. A glitch trigger occurs when the edge of a pulse that matches the Width and Polarity crosses the specified Level (in Volts).

Properties

condition | The glitch condition detemermines whether the oscilloscope triggers on a a pulse with a width less than or greater than the glitch width value.
polarity | The polarity of the glitch that triggers the oscilloscope.
Width | The glitch width. The units are seconds.


condition Property

IIviScopeTriggerGlitch.condition Property

The glitch condition detemermines whether the oscilloscope triggers on a a pulse with a width less than or greater than the glitch width value.

[Visual Basic]
Property Get condition() As IviScopeGlitchConditionEnum
Property Let condition(value As IviScopeGlitchConditionEnum)
[C++]
HRESULT get_condition(IviScopeGlitchConditionEnum* value);
HRESULT put_condition(IviScopeGlitchConditionEnum value);
[ANSI C]
HRESULT IIviScopeTriggerGlitch_get_condition(IIviScopeTriggerGlitch* This, IviScopeGlitchConditionEnum* value);
HRESULT IIviScopeTriggerGlitch_put_condition(IIviScopeTriggerGlitch* This, IviScopeGlitchConditionEnum value);
[C#]
public IviScopeGlitchConditionEnum condition {get; set;}

Capability Group

IviScopeGlitchTrigger

Related Items

Configure

Also In This Interface

condition | polarity | Width | Configure | IIviScopeTriggerGlitch Overview


polarity Property

IIviScopeTriggerGlitch.polarity Property

The polarity of the glitch that triggers the oscilloscope.

[Visual Basic]
Property Get polarity() As IviScopeGlitchPolarityEnum
Property Let polarity(value As IviScopeGlitchPolarityEnum)
[C++]
HRESULT get_polarity(IviScopeGlitchPolarityEnum* value);
HRESULT put_polarity(IviScopeGlitchPolarityEnum value);
[ANSI C]
HRESULT IIviScopeTriggerGlitch_get_polarity(IIviScopeTriggerGlitch* This, IviScopeGlitchPolarityEnum* value);
HRESULT IIviScopeTriggerGlitch_put_polarity(IIviScopeTriggerGlitch* This, IviScopeGlitchPolarityEnum value);
[C#]
public IviScopeGlitchPolarityEnum polarity {get; set;}

Capability Group

IviScopeGlitchTrigger

Related Items

Configure

Also In This Interface

condition | polarity | Width | Configure | IIviScopeTriggerGlitch Overview


Width Property

IIviScopeTriggerGlitch.Width Property

The glitch width. The units are seconds.

[Visual Basic]
Property Get Width() As Double
Property Let Width(value As Double)
[C++]
HRESULT get_Width(double* value);
HRESULT put_Width(double value);
[ANSI C]
HRESULT IIviScopeTriggerGlitch_get_Width(IIviScopeTriggerGlitch* This, double* value);
HRESULT IIviScopeTriggerGlitch_put_Width(IIviScopeTriggerGlitch* This, double value);
[C#]
public double Width {get; set;}

Capability Group

IviScopeGlitchTrigger

Related Items

Configure | Configure

Also In This Interface

condition | polarity | Width | Configure | IIviScopeTriggerGlitch Overview


Configure Method

IIviScopeTriggerGlitch.Configure Method

Configure the glitch trigger Source, Level, Width, Polarity, and Condition. A glitch trigger occurs when the edge of a pulse that matches the Width and Polarity crosses the specified Level (in Volts).

[Visual Basic]
Sub Configure( _
   Source As String, _
   Level As Double, _
   Width As Double, _
   polarity As IviScopeGlitchPolarityEnum, _
   condition As IviScopeGlitchConditionEnum _
)
[C++]
HRESULT Configure(
   BSTR Source,
   double Level,
   double Width,
   IviScopeGlitchPolarityEnum polarity,
   IviScopeGlitchConditionEnum condition
);
[ANSI C]
HRESULT IIviScopeTriggerGlitch_Configure(
   IIviScopeTriggerGlitch* This
   BSTR Source,
   double Level,
   double Width,
   IviScopeGlitchPolarityEnum polarity,
   IviScopeGlitchConditionEnum condition
);
[C#]
public void Configure(
   string Source,
   double Level,
   double Width,
   IviScopeGlitchPolarityEnum polarity,
   IviScopeGlitchConditionEnum condition
);

Parameters

Source
Specifies the trigger source. This value sets the Trigger Source property.
Level
Specifies the trigger level. This value sets the Trigger Level property.
Width
Specifies the glitch triggering glitch width in seconds. This value sets the Glitch Width property.
polarity
Specifies the glitch polarity. This value sets the Glitch Polarity property.
condition
Specifies the glitch condition. This value sets the Glitch Condition property.

Capability Group

IviScopeGlitchTrigger

Related Items

IIviScopeTrigger.Level | IIviScopeTrigger.Source | Width | polarity | condition

Also In This Interface

condition | polarity | Width | Configure | IIviScopeTriggerGlitch Overview


IIviScopeTriggerRunt Interface

IVI Scope class-compliant runt trigger interface

Methods

Configure Configures the runt trigger Source, ThresholdLow, ThresholdHigh, and Polarity. A runt trigger occurs when the trigger signal crosses one of the runt thresholds twice without crossing the other runt threshold.

Properties

polarity | The polarity of the runt that triggers the oscilloscope.
ThresholdHigh | The high threshold the oscilloscope uses for runt triggering. The units are volts.
ThresholdLow | The low threshold the oscilloscope uses for runt triggering. The units are volts.


polarity Property

IIviScopeTriggerRunt.polarity Property

The polarity of the runt that triggers the oscilloscope.

[Visual Basic]
Property Get polarity() As IviScopeRuntPolarityEnum
Property Let polarity(value As IviScopeRuntPolarityEnum)
[C++]
HRESULT get_polarity(IviScopeRuntPolarityEnum* value);
HRESULT put_polarity(IviScopeRuntPolarityEnum value);
[ANSI C]
HRESULT IIviScopeTriggerRunt_get_polarity(IIviScopeTriggerRunt* This, IviScopeRuntPolarityEnum* value);
HRESULT IIviScopeTriggerRunt_put_polarity(IIviScopeTriggerRunt* This, IviScopeRuntPolarityEnum value);
[C#]
public IviScopeRuntPolarityEnum polarity {get; set;}

Capability Group

IviScopeRuntTrigger

Related Items

Configure

Also In This Interface

polarity | ThresholdHigh | ThresholdLow | Configure | IIviScopeTriggerRunt Overview


ThresholdHigh Property

IIviScopeTriggerRunt.ThresholdHigh Property

The high threshold the oscilloscope uses for runt triggering. The units are volts.

[Visual Basic]
Property Get ThresholdHigh() As Double
Property Let ThresholdHigh(value As Double)
[C++]
HRESULT get_ThresholdHigh(double* value);
HRESULT put_ThresholdHigh(double value);
[ANSI C]
HRESULT IIviScopeTriggerRunt_get_ThresholdHigh(IIviScopeTriggerRunt* This, double* value);
HRESULT IIviScopeTriggerRunt_put_ThresholdHigh(IIviScopeTriggerRunt* This, double value);
[C#]
public double ThresholdHigh {get; set;}

Capability Group

IviScopeRuntTrigger

Related Items

Configure

Also In This Interface

polarity | ThresholdHigh | ThresholdLow | Configure | IIviScopeTriggerRunt Overview


ThresholdLow Property

IIviScopeTriggerRunt.ThresholdLow Property

The low threshold the oscilloscope uses for runt triggering. The units are volts.

[Visual Basic]
Property Get ThresholdLow() As Double
Property Let ThresholdLow(value As Double)
[C++]
HRESULT get_ThresholdLow(double* value);
HRESULT put_ThresholdLow(double value);
[ANSI C]
HRESULT IIviScopeTriggerRunt_get_ThresholdLow(IIviScopeTriggerRunt* This, double* value);
HRESULT IIviScopeTriggerRunt_put_ThresholdLow(IIviScopeTriggerRunt* This, double value);
[C#]
public double ThresholdLow {get; set;}

Capability Group

IviScopeRuntTrigger

Also In This Interface

polarity | ThresholdHigh | ThresholdLow | Configure | IIviScopeTriggerRunt Overview


Configure Method

IIviScopeTriggerRunt.Configure Method

Configures the runt trigger Source, ThresholdLow, ThresholdHigh, and Polarity. A runt trigger occurs when the trigger signal crosses one of the runt thresholds twice without crossing the other runt threshold.

[Visual Basic]
Sub Configure( _
   Source As String, _
   ThresholdLow As Double, _
   ThresholdHigh As Double, _
   polarity As IviScopeRuntPolarityEnum _
)
[C++]
HRESULT Configure(
   BSTR Source,
   double ThresholdLow,
   double ThresholdHigh,
   IviScopeRuntPolarityEnum polarity
);
[ANSI C]
HRESULT IIviScopeTriggerRunt_Configure(
   IIviScopeTriggerRunt* This
   BSTR Source,
   double ThresholdLow,
   double ThresholdHigh,
   IviScopeRuntPolarityEnum polarity
);
[C#]
public void Configure(
   string Source,
   double ThresholdLow,
   double ThresholdHigh,
   IviScopeRuntPolarityEnum polarity
);

Parameters

Source
Specifies the trigger source. This value sets the Trigger Source property.
ThresholdLow
Sets the runt triggering low threshold in volts.
ThresholdHigh
Sets the runt triggering high threshold in volts.
polarity
Sets the runt polarity.

Capability Group

IviScopeRuntTrigger

Related Items

IIviScopeTrigger.Source | ThresholdLow | ThresholdHigh | polarity

Also In This Interface

polarity | ThresholdHigh | ThresholdLow | Configure | IIviScopeTriggerRunt Overview


IIviScopeTriggerTv Interface

IVI Scope class-compliant TV trigger interface

Methods

Configure Configures the TV trigger source, signal format, event and polarity.

Properties

LineNumber | The line on which the oscilloscope triggers. The line number is absolute and not relative to the field of the TV signal.
Event | The event on which the oscilloscope triggers.
polarity | The polarity of the TV signal.
SignalFormat | The format of the TV signal on which the oscilloscope triggers.


LineNumber Property

IIviScopeTriggerTv.LineNumber Property

The line on which the oscilloscope triggers. The line number is absolute and not relative to the field of the TV signal.

[Visual Basic]
Property Get LineNumber() As Long
Property Let LineNumber(value As Long)
[C++]
HRESULT get_LineNumber(long* value);
HRESULT put_LineNumber(long value);
[ANSI C]
HRESULT IIviScopeTriggerTv_get_LineNumber(IIviScopeTriggerTv* This, long* value);
HRESULT IIviScopeTriggerTv_put_LineNumber(IIviScopeTriggerTv* This, long value);
[C#]
public long LineNumber {get; set;}

Capability Group

IviScopeTVTrigger

Also In This Interface

LineNumber | Event | polarity | SignalFormat | Configure | IIviScopeTriggerTv Overview


Event Property

IIviScopeTriggerTv.Event Property

The event on which the oscilloscope triggers.

[Visual Basic]
Property Get Event() As IviScopeTVTriggerEventEnum
Property Let Event(value As IviScopeTVTriggerEventEnum)
[C++]
HRESULT get_Event(IviScopeTVTriggerEventEnum* value);
HRESULT put_Event(IviScopeTVTriggerEventEnum value);
[ANSI C]
HRESULT IIviScopeTriggerTv_get_Event(IIviScopeTriggerTv* This, IviScopeTVTriggerEventEnum* value);
HRESULT IIviScopeTriggerTv_put_Event(IIviScopeTriggerTv* This, IviScopeTVTriggerEventEnum value);
[C#]
public IviScopeTVTriggerEventEnum Event {get; set;}

Capability Group

IviScopeTVTrigger

Related Items

Configure

Also In This Interface

LineNumber | Event | polarity | SignalFormat | Configure | IIviScopeTriggerTv Overview


polarity Property

IIviScopeTriggerTv.polarity Property

The polarity of the TV signal.

[Visual Basic]
Property Get polarity() As IviScopeTVTriggerPolarityEnum
Property Let polarity(value As IviScopeTVTriggerPolarityEnum)
[C++]
HRESULT get_polarity(IviScopeTVTriggerPolarityEnum* value);
HRESULT put_polarity(IviScopeTVTriggerPolarityEnum value);
[ANSI C]
HRESULT IIviScopeTriggerTv_get_polarity(IIviScopeTriggerTv* This, IviScopeTVTriggerPolarityEnum* value);
HRESULT IIviScopeTriggerTv_put_polarity(IIviScopeTriggerTv* This, IviScopeTVTriggerPolarityEnum value);
[C#]
public IviScopeTVTriggerPolarityEnum polarity {get; set;}

Capability Group

IviScopeTVTrigger

Related Items

Configure

Also In This Interface

LineNumber | Event | polarity | SignalFormat | Configure | IIviScopeTriggerTv Overview


SignalFormat Property

IIviScopeTriggerTv.SignalFormat Property

The format of the TV signal on which the oscilloscope triggers.

[Visual Basic]
Property Get SignalFormat() As IviScopeTVSignalFormatEnum
Property Let SignalFormat(value As IviScopeTVSignalFormatEnum)
[C++]
HRESULT get_SignalFormat(IviScopeTVSignalFormatEnum* value);
HRESULT put_SignalFormat(IviScopeTVSignalFormatEnum value);
[ANSI C]
HRESULT IIviScopeTriggerTv_get_SignalFormat(IIviScopeTriggerTv* This, IviScopeTVSignalFormatEnum* value);
HRESULT IIviScopeTriggerTv_put_SignalFormat(IIviScopeTriggerTv* This, IviScopeTVSignalFormatEnum value);
[C#]
public IviScopeTVSignalFormatEnum SignalFormat {get; set;}

Capability Group

IviScopeTVTrigger

Related Items

Configure

Also In This Interface

LineNumber | Event | polarity | SignalFormat | Configure | IIviScopeTriggerTv Overview


Configure Method

IIviScopeTriggerTv.Configure Method

Configures the TV trigger source, signal format, event and polarity.

[Visual Basic]
Sub Configure( _
   Source As String, _
   SignalFormat As IviScopeTVSignalFormatEnum, _
   Event As IviScopeTVTriggerEventEnum, _
   polarity As IviScopeTVTriggerPolarityEnum _
)
[C++]
HRESULT Configure(
   BSTR Source,
   IviScopeTVSignalFormatEnum SignalFormat,
   IviScopeTVTriggerEventEnum Event,
   IviScopeTVTriggerPolarityEnum polarity
);
[ANSI C]
HRESULT IIviScopeTriggerTv_Configure(
   IIviScopeTriggerTv* This
   BSTR Source,
   IviScopeTVSignalFormatEnum SignalFormat,
   IviScopeTVTriggerEventEnum Event,
   IviScopeTVTriggerPolarityEnum polarity
);
[C#]
public void Configure(
   string Source,
   IviScopeTVSignalFormatEnum SignalFormat,
   IviScopeTVTriggerEventEnum Event,
   IviScopeTVTriggerPolarityEnum polarity
);

Parameters

Source
Specifies the trigger source. This value sets the Trigger Source property.
SignalFormat
Specifies the TV trigger signal format. This value sets the TV Trigger Signal Format property.
Event
Specifies the TV trigger event. This value sets the TV Trigger Event property.
polarity
Specifies the polarity of the TV trigger. This value sets the TV Trigger Polarity property.

Capability Group

IviScopeTVTrigger

Related Items

IIviScopeTrigger.Source | SignalFormat | Event | polarity

Also In This Interface

LineNumber | Event | polarity | SignalFormat | Configure | IIviScopeTriggerTv Overview


IIviScopeTriggerWidth Interface

IVI Scope class-compliant width trigger interface

Methods

Configure Configures the width trigger Source, Level, ThresholdLow, ThresholdHigh, Polarity, and Condition. A width trigger occurs when a pulse, that passes through Level, with a width between or outside, the width thresholds is detected.

Properties

condition | The condition of a pulse that triggers the oscilloscope. The condition is either inside or outside of the high and low thresholds.
polarity | The polarity of the pulse that triggers the oscilloscope.
ThresholdLow | The low width threshold time. The units are seconds.
ThresholdHigh | The high width threshold time. The units are seconds.


condition Property

IIviScopeTriggerWidth.condition Property

The condition of a pulse that triggers the oscilloscope. The condition is either inside or outside of the high and low thresholds.

[Visual Basic]
Property Get condition() As IviScopeWidthConditionEnum
Property Let condition(value As IviScopeWidthConditionEnum)
[C++]
HRESULT get_condition(IviScopeWidthConditionEnum* value);
HRESULT put_condition(IviScopeWidthConditionEnum value);
[ANSI C]
HRESULT IIviScopeTriggerWidth_get_condition(IIviScopeTriggerWidth* This, IviScopeWidthConditionEnum* value);
HRESULT IIviScopeTriggerWidth_put_condition(IIviScopeTriggerWidth* This, IviScopeWidthConditionEnum value);
[C#]
public IviScopeWidthConditionEnum condition {get; set;}

Capability Group

IviScopeWidthTrigger

Related Items

Configure

Also In This Interface

condition | polarity | ThresholdLow | ThresholdHigh | Configure | IIviScopeTriggerWidth Overview


polarity Property

IIviScopeTriggerWidth.polarity Property

The polarity of the pulse that triggers the oscilloscope.

[Visual Basic]
Property Get polarity() As IviScopeWidthPolarityEnum
Property Let polarity(value As IviScopeWidthPolarityEnum)
[C++]
HRESULT get_polarity(IviScopeWidthPolarityEnum* value);
HRESULT put_polarity(IviScopeWidthPolarityEnum value);
[ANSI C]
HRESULT IIviScopeTriggerWidth_get_polarity(IIviScopeTriggerWidth* This, IviScopeWidthPolarityEnum* value);
HRESULT IIviScopeTriggerWidth_put_polarity(IIviScopeTriggerWidth* This, IviScopeWidthPolarityEnum value);
[C#]
public IviScopeWidthPolarityEnum polarity {get; set;}

Capability Group

IviScopeWidthTrigger

Related Items

Configure

Also In This Interface

condition | polarity | ThresholdLow | ThresholdHigh | Configure | IIviScopeTriggerWidth Overview


ThresholdLow Property

IIviScopeTriggerWidth.ThresholdLow Property

The low width threshold time. The units are seconds.

[Visual Basic]
Property Get ThresholdLow() As Double
Property Let ThresholdLow(value As Double)
[C++]
HRESULT get_ThresholdLow(double* value);
HRESULT put_ThresholdLow(double value);
[ANSI C]
HRESULT IIviScopeTriggerWidth_get_ThresholdLow(IIviScopeTriggerWidth* This, double* value);
HRESULT IIviScopeTriggerWidth_put_ThresholdLow(IIviScopeTriggerWidth* This, double value);
[C#]
public double ThresholdLow {get; set;}

Capability Group

IviScopeWidthTrigger

Related Items

Configure

Also In This Interface

condition | polarity | ThresholdLow | ThresholdHigh | Configure | IIviScopeTriggerWidth Overview


ThresholdHigh Property

IIviScopeTriggerWidth.ThresholdHigh Property

The high width threshold time. The units are seconds.

[Visual Basic]
Property Get ThresholdHigh() As Double
Property Let ThresholdHigh(value As Double)
[C++]
HRESULT get_ThresholdHigh(double* value);
HRESULT put_ThresholdHigh(double value);
[ANSI C]
HRESULT IIviScopeTriggerWidth_get_ThresholdHigh(IIviScopeTriggerWidth* This, double* value);
HRESULT IIviScopeTriggerWidth_put_ThresholdHigh(IIviScopeTriggerWidth* This, double value);
[C#]
public double ThresholdHigh {get; set;}

Capability Group

IviScopeWidthTrigger

Related Items

Configure

Also In This Interface

condition | polarity | ThresholdLow | ThresholdHigh | Configure | IIviScopeTriggerWidth Overview


Configure Method

IIviScopeTriggerWidth.Configure Method

Configures the width trigger Source, Level, ThresholdLow, ThresholdHigh, Polarity, and Condition. A width trigger occurs when a pulse, that passes through Level, with a width between or outside, the width thresholds is detected.

[Visual Basic]
Sub Configure( _
   Source As String, _
   Level As Double, _
   ThresholdLow As Double, _
   ThresholdHigh As Double, _
   polarity As IviScopeWidthPolarityEnum, _
   condition As IviScopeWidthConditionEnum _
)
[C++]
HRESULT Configure(
   BSTR Source,
   double Level,
   double ThresholdLow,
   double ThresholdHigh,
   IviScopeWidthPolarityEnum polarity,
   IviScopeWidthConditionEnum condition
);
[ANSI C]
HRESULT IIviScopeTriggerWidth_Configure(
   IIviScopeTriggerWidth* This
   BSTR Source,
   double Level,
   double ThresholdLow,
   double ThresholdHigh,
   IviScopeWidthPolarityEnum polarity,
   IviScopeWidthConditionEnum condition
);
[C#]
public void Configure(
   string Source,
   double Level,
   double ThresholdLow,
   double ThresholdHigh,
   IviScopeWidthPolarityEnum polarity,
   IviScopeWidthConditionEnum condition
);

Parameters

Source
Level
Trigger Level. This value sets the Trigger Level property.
ThresholdLow
Sets the width triggering low threshold in seconds. This value sets the Width Low Threshold property.
ThresholdHigh
Sets the width triggering high threshold in seconds. This value sets the Width High Threshold property.
polarity
Sets the width polarity. This value sets the Width Polarity property.
condition
Specifies whether a pulse that is within or outside the user-specified thresholds trigger waveform acquisition. This value sets the Width Condition property.

Capability Group

IviScopeWidthTrigger

Related Items

IIviScopeTrigger.Source | IIviScopeTrigger.Level | ThresholdLow | polarity | condition

Also In This Interface

condition | polarity | ThresholdLow | ThresholdHigh | Configure | IIviScopeTriggerWidth Overview


IviScopeACLineSlopeEnum Enumeration

IVI Scope class-compliant values for AC line trigger Slope

Members

Member Name | Description
IviScopeACLinePositive | Configures the oscilloscope to trigger on positive slope zero crossings of the network supply voltage.
IviScopeACLineNegative | Configures the oscilloscope to trigger on negative slope zero crossings of the network supply voltage.
IviScopeACLineEither | Configures the oscilloscope to trigger on either positive or negative slope zero crossings of the network supply voltage.


IviScopeAcquisitionStatusEnum Enumeration

IVI Scope class-compliant values for the status parameter of the acquisition Status method

Members

Member Name | Description
IviScopeAcqComplete | The oscilloscope has completed the acquisition.
IviScopeAcqInProgress | The oscilloscope is still acquiring data.
IviScopeAcqStatusUnknown | The oscilloscope cannot determine the status of the acquisition.


IviScopeAcquisitionTypeEnum Enumeration

IVI Scope class-compliant values for Acquisition Type

Members

Member Name | Description
IviScopeAcquisitionTypeNormal | Configures the oscilloscope to acquire one sample for each point in the waveform record. The oscilloscope uses real-time or equivalent time sampling.
IviScopeAcquisitionTypePeakDetect | Sets the oscilloscope to the peak-detect acquisition mode. The oscilloscope oversamples the input signal and keeps the minimum and maximum values that correspond to each position in the waveform record. The oscilloscope uses only real-time sampling.
IviScopeAcquisitionTypeHiRes | Configures the oscilloscope to oversample the input signal. The oscilloscope calculates the average value that corresponds to each position in the waveform record. The oscilloscope uses only real-time sampling.
IviScopeAcquisitionTypeEnvelope | Sets the oscilloscope to the envelope acquisition mode. The oscilloscope acquires multiple waveforms and keeps the minimum and maximum voltages it acquires for each point in the waveform record. The end-user specifies the number of waveforms the oscilloscope acquires with the Number of Envelopes property. The oscilloscope can use real-time or equivalent-time sampling.
IviScopeAcquisitionTypeAverage | Configures the oscilloscope to acquire multiple waveforms and calculate the average value for each point in the waveform record. The end-user specifies the number of waveforms to acquire with the Number of Averages property. The oscilloscope uses real-time or equivalent time sampling.


IviScopeErrorCodesEnum Enumeration

IVI Scope class defined HRESULTS

Members

Member Name | Description
E_IVISCOPE_CHANNEL_NOT_ENABLED | Specified channel is not enabled.
E_IVISCOPE_UNABLE_TO_PERFORM_MEASUREMENT | Unable to perform desired measurement operation.
E_IVISCOPE_MAX_TIME_EXCEEDED | Maximum time exceeded before the operation completed.
E_IVISCOPE_INVALID_ACQ_TYPE | Invalid acquisition type.
S_IVISCOPE_INVALID_WFM_ELEMENT | One of the elements in the waveform array is invalid.


IviScopeGlitchConditionEnum Enumeration

IVI Scope class-compliant values for glitch trigger Condition

Members

Member Name | Description
IviScopeGlitchConditionLessThan | The oscilloscope triggers when the pulse width is less than the value you specify with the Glitch Width property.
IviScopeGlitchConditionGreaterThan | The oscilloscope triggers when the pulse width is greater than the value you specify with the Glitch Width property.


IviScopeGlitchPolarityEnum Enumeration

IVI Scope class-compliant values for glitch trigger Polarity

Members

Member Name | Description
IviScopeGlitchPolarityPositive | The oscilloscope triggers on a positive glitch.
IviScopeGlitchPolarityNegative | The oscilloscope triggers on a negative glitch.
IviScopeGlitchPolarityEither | The oscilloscope triggers on either a positive or negative glitch.


IviScopeInterpolationEnum Enumeration

IVI Scope class-compliant values for acquisition Interpolation

Members

Member Name | Description
IviScopeInterpolationNone | The oscilloscope does not interpolate points in the waveform. Instead, the driver sets every element in the waveform record for which the oscilloscope cannot receive a value to an IEEE-defined NaN (Not-a-Number) value. Use the Is Waveform Element Invalid method to determine if the waveform record element is invalid.
IviScopeInterpolationSineX | The oscilloscope uses a sin(x)/x calculation to interpolate a value when it cannot resolve a voltage in the waveform record.
IviScopeInterpolationLinear | The oscilloscope uses a linear approximation to interpolate a value when it cannot resolve a voltage in the waveform record.


IviScopeMeasurementEnum Enumeration

IVI Scope class-compliant values for the MeasFunction parameter of the measurement Read and Fetch methods

Members

Member Name | Description
IviScopeMeasurementRiseTime | The length of time for a rising edge of the signal to rise from the low reference level to the high reference level. The units are seconds.
IviScopeMeasurementFallTime | The length of time for a falling edge of the signal to fall from the high reference level to the low reference level. The units are seconds.
IviScopeMeasurementFrequency | The frequency of one complete cycle in the waveform. The units are Hertz.
IviScopeMeasurementPeriod | The length of time of one complete cycle in the waveform. The units are seconds.
IviScopeMeasurementVoltageRMS | The true Root Mean Square voltage of the entire waveform. The units are Volts.
IviScopeMeasurementVoltagePeakToPeak | The absolute difference between the Voltage Max and the Voltage Min. The units are Volts.
IviScopeMeasurementVoltageMax | The maximum amplitude found in the entire waveform. The units are Volts.
IviScopeMeasurementVoltageMin | The minimum amplitude found in the entire waveform. The units are Volts.
IviScopeMeasurementVoltageHigh | The voltage that corresponds to 100% when using the reference levels. The oscilloscope calculates this value using either the min/max or histogram methods. The min/max method uses the maximum value found. The histogram method uses a common value found above the middle of the waveform. The units are Volts.
IviScopeMeasurementVoltageLow | The voltage that corresponds to 0% when using the reference levels. The oscilloscope calculates this value using either the min/max or histogram methods. The min/max method uses the minimum value found. The histogram method uses a common value found below the middle of the waveform. The units are Volts.
IviScopeMeasurementVoltageAverage | The arithmetic average in volts measured over the entire waveform. The units are Volts.
IviScopeMeasurementWidthNeg | The length of time between the mid reference level points of a negative pulse in the waveform. The units are seconds.
IviScopeMeasurementWidthPos | The length of time between the mid reference level points of a positive pulse in the waveform. The units are seconds.
IviScopeMeasurementDutyCycleNeg The ratio of the Width Neg to the Period of an integer number of cycles in the waveform expressed as a percentage.
                 Width Neg
Duty Cycle Neg = ---------- X 100%
                   Period
IviScopeMeasurementDutyCyclePos The ratio of the Width Pos width to the Period of an integer number of cycles in the waveform expressed as a percentage.
                 Width Pos
Duty Cycle Pos = ---------- X 100%
                   Period
IviScopeMeasurementAmplitude The Voltage High less the Voltage Low in Volts over the entire waveform.
Amplitude = Voltage High - Voltage Low
IviScopeMeasurementVoltageCycleRMS | The true Root Mean Square voltage over an integer number of cycles in the waveform. The units are Volts.
IviScopeMeasurementVoltageCycleAverage | The arithmetic average in Volts over an integer number of cycles in the waveform. The units are Volts.
IviScopeMeasurementOverShoot The relative waveform distortion that follows an edge transition. It is calculated using the following formula:-for the rising edge
             local maximum - Voltage High
Overshoot = ------------------------------ X 100%
                      Amplitude
where the local maximum is the maximum voltage of the signal in the first half of the time period that commences when the rising edge crosses the high reference level and concludes when the subsequent falling edge crosses the high reference level.-for the falling edge:
             Voltage Low - local maximum
Overshoot = ------------------------------ X 100%
                      Amplitude
where the local minimum is the minimum value of the signal measured in the first half of the time period that commences when the falling edge crosses the low reference level and concludes when the subsequent rising edge crosses the low reference level.The instrument makes the measurement on the edge closest to the beginning of the waveform record. The units are the percentage of the signal amplitude.
IviScopeMeasurementPreshoot The relative waveform distortion that precedes an edge transition. It is calculated using the following formula:-for the rising edge
            Voltage Low - local maximum
Preshoot = ----------------------------- X 100%
                      Amplitude
where the local minimum is the minimum value of the signal measured in the second half of the time period that commences when the preceding falling edge crosses the low reference level and concludes when the rising edge crosses the low reference level.-for the falling edge:
             local maximum - Voltage High
Overshoot = ------------------------------ X 100%
                      Amplitude
where the local maximum is the maximum voltage of the signal in the second half of the time period that commences when the preceding rising edge crosses the high reference level and concludes when the falling edge crosses the high reference level.The instrument makes the measurement on the edge closest to the beginning of the waveform record. The units are the percentage of the signal amplitude.


IviScopeRuntPolarityEnum Enumeration

IVI Scope class-compliant values for runt trigger Polarity

Members

Member Name | Description
IviScopeRuntPolarityPositive | The oscilloscope triggers on a positive runt. A positive runt occurs when a rising edge crosses the low runt threshold and does not cross the high runt threshold before re-crossing the low runt threshold.
IviScopeRuntPolarityNegative | The oscilloscope triggers on a negative runt. A negative runt occurs when a falling edge crosses the high runt threshold and does not cross the low runt threshold before re-crossing the high runt threshold.
IviScopeRuntPolarityEither | The oscilloscope triggers on either a positive or negative runt.


IviScopeSampleModeEnum Enumeration

IVI Scope class-compliant values for acquisition SampleMode

Members

Member Name | Description
IviScopeSampleModeRealTime | Indicates that the oscilloscope is using real-time sampling.
IviScopeSampleModeEquivalentTime | Indicates that the oscilloscope is using equivalent time sampling.


IviScopeTimeOutEnum Enumeration

IVI Scope class-compliant values for maxTime parameter of the measurement Read and Fetch methods.

Members

Member Name | Description
IviScopeTimeOutInfinite | The method waits indefinitely for the measurement to complete.
IviScopeTimeOutImmediate | The method returns immediately. If no valid measurement value exists, the method returns an error.


IviScopeTriggerCouplingEnum Enumeration

IVI Scope class-compliant values for trigger Coupling

Members

Member Name | Description
IviScopeTriggerCouplingAC | The oscilloscope AC couples the trigger signal.
IviScopeTriggerCouplingDC | The oscilloscope DC couples the trigger signal.
IviScopeTriggerCouplingHFReject | The oscilloscope filters out the high frequencies from the trigger signal.
IviScopeTriggerCouplingLFReject | The oscilloscope filters out the low frequencies from the trigger signal.
IviScopeTriggerCouplingNoiseReject | The oscilloscope filters out the noise from the trigger signal.


IviScopeTriggerModifierEnum Enumeration

IVI Scope class-compliant values for trigger Modifier

Members

Member Name | Description
IviScopeTriggerModifierNone | The oscilloscope waits until the trigger the end-user specifies occurs.
IviScopeTriggerModifierAuto | The oscilloscope automatically triggers if the configured trigger does not occur within the oscilloscope's timeout period.
IviScopeTriggerModifierAutoLevel | The oscilloscope adjusts the trigger level if the trigger the end-user specifies does not occur.


IviScopeTriggerSlopeEnum Enumeration

IVI Scope class-compliant values for edge trigger Slope

Members

Member Name | Description
IviScopeTriggerSlopePositive | A positive (rising) edge passing through the trigger level triggers the oscilloscope.
IviScopeTriggerSlopeNegative | A negative (falling) edge passing through the trigger level triggers the oscilloscope.


IviScopeTriggerTypeEnum Enumeration

IVI Scope class-compliant values for trigger Type

Members

Member Name | Description
IviScopeTriggerEdge | Configures the oscilloscope for edge triggering. An edge trigger occurs when the trigger signal specified with the Trigger Source property passes the voltage threshold specified with the Trigger Level property and has the slope specified with the Trigger Slope property.
IviScopeTriggerWidth | Configures the oscilloscope for width triggering. Use the IviScopeWidthTrigger extension properties and methods to configure the trigger.
IviScopeTriggerRunt | Configures the oscilloscope for runt triggering. Use the IviScopeRuntTrigger extension properties and methods to configure the trigger.
IviScopeTriggerGlitch | Configures the oscilloscope for glitch triggering. Use the IviScopeGlitchTrigger extension properties and methods to configure the trigger.
IviScopeTriggerTV | Configures the oscilloscope for triggering on TV signals. Use the IviScopeTVTrigger extension properties and methods to configure the trigger.
IviScopeTriggerImmediate | Configures the oscilloscope for immediate triggering. The oscilloscope does not wait for trigger of any kind upon initialization.
IviScopeTriggerACLine | Configures the oscilloscope for AC Line triggering. Use the IviScopeACLineTrigger extension properties and methods to configure the trigger.


IviScopeTVSignalFormatEnum Enumeration

IVI Scope class-compliant values for TV trigger SignalFormat

Members

Member Name | Description
IviScopeTVSignalFormatNTSC | Configures the oscilloscope to trigger on the NTSC signal format.
IviScopeTVSignalFormatPAL | Configures the oscilloscope to trigger on the PAL signal format
IviScopeTVSignalFormatSECAM | Configures the oscilloscope to trigger on the SECAM signal format


IviScopeTVTriggerEventEnum Enumeration

IVI Scope class-compliant values for TV trigger Event

Members

Member Name | Description
IviScopeTVTriggerEventField1 | Sets the oscilloscope to trigger on field 1 of the video signal.
IviScopeTVTriggerEventField2 | Sets the oscilloscope to trigger on field 2 of the video signal.
IviScopeTVTriggerEventAnyField | Sets the oscilloscope to trigger on any field.
IviScopeTVTriggerEventAnyLine | Sets the oscilloscope to trigger on any line.
IviScopeTVTriggerEventLineNumber | Sets the oscilloscope to trigger on a specific line number you specify with the TV Trigger Line Number property.


IviScopeTVTriggerPolarityEnum Enumeration

IVI Scope class-compliant values for TV trigger Polarity

Members

Member Name | Description
IviScopeTVTriggerPolarityPositive | Configures the oscilloscope to trigger on a positive video sync pulse.
IviScopeTVTriggerPolarityNegative | Configures the oscilloscope to trigger on a negative video sync pulse.


IviScopeVerticalCouplingEnum Enumeration

IVI Scope class-compliant values for channel Coupling

Members

Member Name | Description
IviScopeVerticalCouplingAC | The oscilloscope AC couples the input signal.
IviScopeVerticalCouplingDC | The oscilloscope DC couples the input signal.
IviScopeVerticalCouplingGnd | The oscilloscope couples the channel to the ground.


IviScopeWidthConditionEnum Enumeration

IVI Scope class-compliant values for width trigger Condition

Members

Member Name | Description
IviScopeWidthConditionWithin | Configures the oscilloscope to trigger on pulses that have a width that is less than the high threshold and greater than the low threshold. The end-user specifies the high and low thresholds with the Width High Threshold and Width Low Threshold properties.
IviScopeWidthConditionOutside | Configures the oscilloscope to trigger on pulses that have a width that is either greater than the high threshold or less than a low threshold. The end-user specifies the high and low thresholds with the Width High Threshold and Width Low Threshold properties.


IviScopeWidthPolarityEnum Enumeration

IVI Scope class-compliant values for width trigger Polarity

Members

Member Name | Description
IviScopeWidthPolarityPositive | Configures the oscilloscope to trigger on positive pulses that have a width that meets the condition the user specifies with the Width Condition property.
IviScopeWidthPolarityNegative | Configures the oscilloscope to trigger on negative pulses that have a width that meets the condition the user specifies with the Width Condition property.
IviScopeWidthPolarityEither | Configures the oscilloscope to trigger on either positive or negative pulses that have a width that meets the condition the user specifies with the Width Condition property.


Topic Not Found

No matching topic was found. The link may be out of date, incorrectly authored, or the topic may not be available in this release.

You may be able to find the topic by using the index or search tab instead.


Inherent Interface

IVI Inherent Interfaces

IIviDriver | IVI Driver root interface
IIviDriverIdentity | IVI Driver identity interface
IIviDriverOperation | IVI Driver operation interface
IIviDriverUtility | IVI Driver utility interface


Instrument Specific Interfaces


IviDriver_ErrorCodes Enumeration

IVI Driver (inherent features) defined HRESULTS

Members

Member Name | Description
S_IVI_SUCCESS | Success
E_IVI_CANNOT_RECOVER | Unrecoverable failure
E_IVI_INSTRUMENT_STATUS | Instrument error detected
E_IVI_CANNOT_OPEN_FILE | File could not be opened
E_IVI_READING_FILE | File could not be read
E_IVI_WRITING_FILE | File could not be written
E_IVI_INVALID_PATHNAME | The path name is invalid
E_IVI_INVALID_VALUE | Invalid value for parameter or property
E_IVI_METHOD_NOT_SUPPORTED | Method not supported
E_IVI_PROPERTY_NOT_SUPPORTED | Property not supported
E_IVI_VALUE_NOT_SUPPORTED | The enumeration value for the parameter is not supported
E_IVI_NOT_INITIALIZED | A connection to the instrument has not been initialized
E_IVI_UNKNOWN_CHANNEL_NAME | Channel or repeated capability name specified is not valid for the instrument.
E_IVI_TOO_MANY_OPEN_FILES | Too many files opened
E_IVI_CHANNEL_NAME_REQUIRED | Channel or repeated capability name required
E_IVI_MISSING_OPTION_NAME | The option string contains an entry without a name.
E_IVI_MISSING_OPTION_VALUE | The option string contains an entry without a value.
E_IVI_BAD_OPTION_NAME | The option string contains an entry with an unknown option name.
E_IVI_BAD_OPTION_VALUE | The option string contains an entry with an unknown option value.
E_IVI_OUT_OF_MEMORY | The necessary memory could not be allocated
E_IVI_OPERATION_PENDING | Operation in progress
E_IVI_NULL_POINTER | Null pointer passed for parameter or property
E_IVI_UNEXPECTED_RESPONSE | Unexpected response from the instrument
E_IVI_FILE_NOT_FOUND | File not found
E_IVI_INVALID_FILE_FORMAT | The file format is invalid
E_IVI_STATUS_NOT_AVAILABLE | The instrument status is not available
E_IVI_ID_QUERY_FAILED | Instrument ID query failed
E_IVI_RESET_FAILED | Instrument reset failed
E_IVI_RESOURCE_UNKNOWN | Insufficient location information or resource not present in the system.
E_IVI_ALREADY_INITIALIZED | The driver is already initialized
E_IVI_CANNOT_CHANGE_SIMULATION_STATE | The simulation state cannot be changed.
S_IVI_NSUP_ID_QUERY | Identification query not supported
S_IVI_NSUP_RESET | Reset operation not supported
S_IVI_NSUP_SELF_TEST | Self test operation not supported
S_IVI_NSUP_ERROR_QUERY | Error query operation not supported
S_IVI_NSUP_REV_QUERY | Revision query not supported


IIviDriver Interface

IVI Driver root interface

Methods

Initialize | Opens the I/O session to the instrument. Driver methods and properties that access the instrument are only accessible after Initialize is called. Initialize optionally performs a Reset and queries the instrument to validate the instrument model.
Close | Closes the I/O session to the instrument. Driver methods and properties that access the instrument are not accessible after Close is called.

Properties

DriverOperation | Pointer to the IIviDriverOperation interface
Identity | Pointer to the IIviDriverIdentity interface
Utility | Pointer to the IIviDriverUtility interface
Initialized | Initialized is True between a successful call to the Initialize method and a successful call to the Close method, and False at all other times.


IIviDriverIdentity Interface

IVI Driver identity interface

Properties

Description | A brief description of the implementing component. Description is limted to 256 bytes.
Revision | The revision of the implementing component. Refer to IVI 3.1, Section 3.1.2.2, for a description of revision syntax and semantics. Revision is limited to 256 bytes.
Vendor | The name of the vendor that supplies the implementing component. Vendor is limited to 256 bytes.
InstrumentManufacturer | The name of the manufacturer reported by the physical instrument. If Simulation is enabled or the instrument is not capable of reporting the name of the manufacturer, a string is returned that explains the condition. Manufacturer is limited to 256 bytes
InstrumentModel | The model number or name reported by the physical instrument. If Simulation is enabled or the instrument is not capable of reporting the model number or name, a string is returned that explains the condition. Model is limited to 256 bytes
InstrumentFirmwareRevision | The firmware revision reported by the physical instrument. If Simulation is enabled or the instrument is not capable of reporting the firmware revision, a string is returned that explains the condition.
Identifier | The case-sensitive unique identifier of the implementing IVI-COM instrument driver.
SupportedInstrumentModels | A comma-separated list of instrument models that the IVI specific driver can control. The string does not include an abbreviation for the manufacturer if it is the same for all models.
SpecificationMajorVersion | For IVI class-compliant drivers, the major version number of the instrument class specification. If the driver is not class compliant, the driver returns zero.
SpecificationMinorVersion | For IVI class-compliant drivers, the minor version number of the instrument class specification. If the driver is not class compliant, the driver returns zero.
GroupCapabilities | A comma-separated list of the class capability groups implemented by the driver. Capability group names are documented in the IVI class specifications. If the driver is not class compliant, the driver returns an empty string.


IIviDriverOperation Interface

IVI Driver operation interface

Methods

InvalidateAllAttributes | Invalidates all of the driver's cached values.
ClearInterchangeWarnings | Clears the list of interchangeability warnings that the IVI specific driver maintains.
GetNextInterchangeWarning | Returns the oldest warning from the interchange warning list. Records are only added to the list if InterchangeCheck is True.
ResetInterchangeCheck | Resets the interchangeability checking algorithms of the driver so that methods and properties that executed prior to calling this function have no affect on whether future calls to the driver generate interchangeability warnings.
GetNextCoercionRecord | Returns the oldest record from the coercion record list. Records are only added to the list if RecordCoercions is True.

Properties

LogicalName | Logical Name identifies a driver session in the Configuration Store. If Logical Name is not empty, the driver was initialized from information in the driver session. If it is empty, the driver was initialized without using the Configuration Store.
IoResourceDescriptor | The resource descriptor specifies the connection to a physical device. It is either specified in the Configuration Store or passed in the ResourceName parameter of the Initialize function. It is empty if the driver is not initialized.
Cache | Drivers may choose to always cache some instrument settings, never cache others, and optionally cache others, to avoid unecessary I/O to the instrument. If True, the driver caches optionally cached instrument settings.
InterchangeCheck | If True, the driver maintains a record of interchangeability warnings. If the driver does not support interchangeability checking, attempts to set InterchangeCheck to True return an error.
QueryInstrumentStatus | If True, the driver queries the instrument status at the end of each method or property that performs I/O to the instrument. If an error is reported, use ErrorQuery to retrieve error messages one at a time from the instrument.
RangeCheck | Drivers may choose to always validate some property/parameter values, never validate others, and optionally validate others, to avoid sending invalid commands to the instrument. If True, the driver performs optional validations.
RecordCoercions | If True, the driver keeps a list of the value coercions it makes for ViInt32 and ViReal64 attributes. If the driver does not support coercion recording, attempts to set RecordCoercions to True will return an error.
Simulate | If True, the driver does not perform I/O to the instrument, and returns simulated values for output parameters.
DriverSetup | The driver setup string. It is either specified in the Configuration Store or passed in the OptionString parameter of the Initialize function. Driver setup is empty if the driver is not initialized.


IIviDriverUtility Interface

IVI Driver utility interface

Methods

Reset | Places the instrument in a known state and configures instrument options on which the IVI specific driver depends (for example, enabling/disabling headers). For an IEEE 488.2 instrument, Reset sends the command string *RST to the instrument.
ResetWithDefaults | Does the equivalent of Reset and then, (1) disables class extension capability groups, (2) sets attributes to initial values defined by class specs, and (3) configures the driver to option string settings used when Initialize was last executed.
Disable | Quickly places the instrument in a state where it has no, or minimal, effect on the external system to which it is connected. This state is not necessarily a known state.
SelfTest | Performs an instrument self test, waits for the instrument to complete the test, and queries the instrument for the results. If the instrument passes the test, TestResult is zero and TestMessage is 'Self test passed'.
ErrorQuery | Queries the instrument and returns instrument specific error information. This function can be used when QueryInstrumentStatus is True to retrieve error details when the driver detects an instrument error.
LockObject | Obtains a multithread lock on the driver after waiting until all other execution threads have released their locks on the instrument session.
UnlockObject | Releases a previously obtained mutlithread lock.


Close Method

IIviDriver.Close Method

Closes the I/O session to the instrument. Driver methods and properties that access the instrument are not accessible after Close is called.

[Visual Basic]
Sub Close()
[C++]
HRESULT Close();
[ANSI C]
HRESULT IIviDriver_Close(
   IIviDriver* This);
[C#]
public void Close();

Capability Group

IviScopeBase

Related Items

Initialize

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Initialize | Close | IIviDriver Overview


DriverOperation Property

IIviDriver.DriverOperation Property

Pointer to the IIviDriverOperation interface

[Visual Basic]
Property Get DriverOperation() As IIviDriverOperation
[C++]
HRESULT get_DriverOperation(IIviDriverOperation** value);
[ANSI C]
HRESULT IIviDriver_get_DriverOperation(IIviDriver* This, IIviDriverOperation** value);
[C#]
public IIviDriverOperation DriverOperation {get;}

Capability Group

IviScopeBase

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Initialize | Close | IIviDriver Overview


Identity Property

IIviDriver.Identity Property

Pointer to the IIviDriverIdentity interface

[Visual Basic]
Property Get Identity() As IIviDriverIdentity
[C++]
HRESULT get_Identity(IIviDriverIdentity** value);
[ANSI C]
HRESULT IIviDriver_get_Identity(IIviDriver* This, IIviDriverIdentity** value);
[C#]
public IIviDriverIdentity Identity {get;}

Capability Group

IviScopeBase

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Initialize | Close | IIviDriver Overview


Initialize Method

IIviDriver.Initialize Method

Opens the I/O session to the instrument. Driver methods and properties that access the instrument are only accessible after Initialize is called. Initialize optionally performs a Reset and queries the instrument to validate the instrument model.

[Visual Basic]
Sub Initialize( _
   ResourceName As String, _
   IdQuery As Boolean, _
   Reset As Boolean, _
   OptionString As String _
)
[C++]
HRESULT Initialize(
   BSTR ResourceName,
   VARIANT_BOOL IdQuery,
   VARIANT_BOOL Reset,
   BSTR OptionString
);
[ANSI C]
HRESULT IIviDriver_Initialize(
   IIviDriver* This
   BSTR ResourceName,
   VARIANT_BOOL IdQuery,
   VARIANT_BOOL Reset,
   BSTR OptionString
);
[C#]
public void Initialize(
   string ResourceName,
   bool IdQuery,
   bool Reset,
   string OptionString
);

Parameters

ResourceName
An IVI logical name or an instrument specific string that identifies the address of the instrument, such as a VISA resource descriptor string.
IdQuery
Specifies whether to verify the ID of the instrument.
Reset
Specifies whether to reset the instrument.
OptionString
The user can use the OptionsString parameter to specify the initial values of certain IVI inherent attributes for the session.

Capability Group

IviScopeBase

Related Items

Close

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Initialize | Close | IIviDriver Overview


Initialized Property

IIviDriver.Initialized Property

Initialized is True between a successful call to the Initialize method and a successful call to the Close method, and False at all other times.

[Visual Basic]
Property Get Initialized() As Boolean
[C++]
HRESULT get_Initialized(VARIANT_BOOL* value);
[ANSI C]
HRESULT IIviDriver_get_Initialized(IIviDriver* This, VARIANT_BOOL* value);
[C#]
public bool Initialized {get;}

Capability Group

IviScopeBase

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Initialize | Close | IIviDriver Overview


Utility Property

IIviDriver.Utility Property

Pointer to the IIviDriverUtility interface

[Visual Basic]
Property Get Utility() As IIviDriverUtility
[C++]
HRESULT get_Utility(IIviDriverUtility** value);
[ANSI C]
HRESULT IIviDriver_get_Utility(IIviDriver* This, IIviDriverUtility** value);
[C#]
public IIviDriverUtility Utility {get;}

Capability Group

IviScopeBase

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Initialize | Close | IIviDriver Overview


Description Property

IIviDriverIdentity.Description Property

A brief description of the implementing component. Description is limted to 256 bytes.

[Visual Basic]
Property Get Description() As String
[C++]
HRESULT get_Description(BSTR* value);
[ANSI C]
HRESULT IIviDriverIdentity_get_Description(IIviDriverIdentity* This, BSTR* value);
[C#]
public string Description {get;}

Capability Group

IviScopeBase

Also In This Interface

Description | Revision | Vendor | InstrumentManufacturer | InstrumentModel | InstrumentFirmwareRevision | Identifier | SupportedInstrumentModels | SpecificationMajorVersion | SpecificationMinorVersion | GroupCapabilities | IIviDriverIdentity Overview


GroupCapabilities Property

IIviDriverIdentity.GroupCapabilities Property

A comma-separated list of the class capability groups implemented by the driver. Capability group names are documented in the IVI class specifications. If the driver is not class compliant, the driver returns an empty string.

[Visual Basic]
Property Get GroupCapabilities() As String
[C++]
HRESULT get_GroupCapabilities(BSTR* value);
[ANSI C]
HRESULT IIviDriverIdentity_get_GroupCapabilities(IIviDriverIdentity* This, BSTR* value);
[C#]
public string GroupCapabilities {get;}

Capability Group

IviScopeBase

Also In This Interface

Description | Revision | Vendor | InstrumentManufacturer | InstrumentModel | InstrumentFirmwareRevision | Identifier | SupportedInstrumentModels | SpecificationMajorVersion | SpecificationMinorVersion | GroupCapabilities | IIviDriverIdentity Overview


Identifier Property

IIviDriverIdentity.Identifier Property

The case-sensitive unique identifier of the implementing IVI-COM instrument driver.

[Visual Basic]
Property Get Identifier() As String
[C++]
HRESULT get_Identifier(BSTR* value);
[ANSI C]
HRESULT IIviDriverIdentity_get_Identifier(IIviDriverIdentity* This, BSTR* value);
[C#]
public string Identifier {get;}

Capability Group

IviScopeBase

Also In This Interface

Description | Revision | Vendor | InstrumentManufacturer | InstrumentModel | InstrumentFirmwareRevision | Identifier | SupportedInstrumentModels | SpecificationMajorVersion | SpecificationMinorVersion | GroupCapabilities | IIviDriverIdentity Overview


InstrumentFirmwareRevision Property

IIviDriverIdentity.InstrumentFirmwareRevision Property

The firmware revision reported by the physical instrument. If Simulation is enabled or the instrument is not capable of reporting the firmware revision, a string is returned that explains the condition.

[Visual Basic]
Property Get InstrumentFirmwareRevision() As String
[C++]
HRESULT get_InstrumentFirmwareRevision(BSTR* value);
[ANSI C]
HRESULT IIviDriverIdentity_get_InstrumentFirmwareRevision(IIviDriverIdentity* This, BSTR* value);
[C#]
public string InstrumentFirmwareRevision {get;}

Capability Group

IviScopeBase

Also In This Interface

Description | Revision | Vendor | InstrumentManufacturer | InstrumentModel | InstrumentFirmwareRevision | Identifier | SupportedInstrumentModels | SpecificationMajorVersion | SpecificationMinorVersion | GroupCapabilities | IIviDriverIdentity Overview


InstrumentManufacturer Property

IIviDriverIdentity.InstrumentManufacturer Property

The name of the manufacturer reported by the physical instrument. If Simulation is enabled or the instrument is not capable of reporting the name of the manufacturer, a string is returned that explains the condition. Manufacturer is limited to 256 bytes

[Visual Basic]
Property Get InstrumentManufacturer() As String
[C++]
HRESULT get_InstrumentManufacturer(BSTR* value);
[ANSI C]
HRESULT IIviDriverIdentity_get_InstrumentManufacturer(IIviDriverIdentity* This, BSTR* value);
[C#]
public string InstrumentManufacturer {get;}

Capability Group

IviScopeBase

Also In This Interface

Description | Revision | Vendor | InstrumentManufacturer | InstrumentModel | InstrumentFirmwareRevision | Identifier | SupportedInstrumentModels | SpecificationMajorVersion | SpecificationMinorVersion | GroupCapabilities | IIviDriverIdentity Overview


InstrumentModel Property

IIviDriverIdentity.InstrumentModel Property

The model number or name reported by the physical instrument. If Simulation is enabled or the instrument is not capable of reporting the model number or name, a string is returned that explains the condition. Model is limited to 256 bytes

[Visual Basic]
Property Get InstrumentModel() As String
[C++]
HRESULT get_InstrumentModel(BSTR* value);
[ANSI C]
HRESULT IIviDriverIdentity_get_InstrumentModel(IIviDriverIdentity* This, BSTR* value);
[C#]
public string InstrumentModel {get;}

Capability Group

IviScopeBase

Also In This Interface

Description | Revision | Vendor | InstrumentManufacturer | InstrumentModel | InstrumentFirmwareRevision | Identifier | SupportedInstrumentModels | SpecificationMajorVersion | SpecificationMinorVersion | GroupCapabilities | IIviDriverIdentity Overview


Revision Property

IIviDriverIdentity.Revision Property

The revision of the implementing component. Refer to IVI 3.1, Section 3.1.2.2, for a description of revision syntax and semantics. Revision is limited to 256 bytes.

[Visual Basic]
Property Get Revision() As String
[C++]
HRESULT get_Revision(BSTR* value);
[ANSI C]
HRESULT IIviDriverIdentity_get_Revision(IIviDriverIdentity* This, BSTR* value);
[C#]
public string Revision {get;}

Capability Group

IviScopeBase

Also In This Interface

Description | Revision | Vendor | InstrumentManufacturer | InstrumentModel | InstrumentFirmwareRevision | Identifier | SupportedInstrumentModels | SpecificationMajorVersion | SpecificationMinorVersion | GroupCapabilities | IIviDriverIdentity Overview


SpecificationMajorVersion Property

IIviDriverIdentity.SpecificationMajorVersion Property

For IVI class-compliant drivers, the major version number of the instrument class specification. If the driver is not class compliant, the driver returns zero.

[Visual Basic]
Property Get SpecificationMajorVersion() As Long
[C++]
HRESULT get_SpecificationMajorVersion(long* value);
[ANSI C]
HRESULT IIviDriverIdentity_get_SpecificationMajorVersion(IIviDriverIdentity* This, long* value);
[C#]
public long SpecificationMajorVersion {get;}

Capability Group

IviScopeBase

Also In This Interface

Description | Revision | Vendor | InstrumentManufacturer | InstrumentModel | InstrumentFirmwareRevision | Identifier | SupportedInstrumentModels | SpecificationMajorVersion | SpecificationMinorVersion | GroupCapabilities | IIviDriverIdentity Overview


SpecificationMinorVersion Property

IIviDriverIdentity.SpecificationMinorVersion Property

For IVI class-compliant drivers, the minor version number of the instrument class specification. If the driver is not class compliant, the driver returns zero.

[Visual Basic]
Property Get SpecificationMinorVersion() As Long
[C++]
HRESULT get_SpecificationMinorVersion(long* value);
[ANSI C]
HRESULT IIviDriverIdentity_get_SpecificationMinorVersion(IIviDriverIdentity* This, long* value);
[C#]
public long SpecificationMinorVersion {get;}

Capability Group

IviScopeBase

Also In This Interface

Description | Revision | Vendor | InstrumentManufacturer | InstrumentModel | InstrumentFirmwareRevision | Identifier | SupportedInstrumentModels | SpecificationMajorVersion | SpecificationMinorVersion | GroupCapabilities | IIviDriverIdentity Overview


SupportedInstrumentModels Property

IIviDriverIdentity.SupportedInstrumentModels Property

A comma-separated list of instrument models that the IVI specific driver can control. The string does not include an abbreviation for the manufacturer if it is the same for all models.

[Visual Basic]
Property Get SupportedInstrumentModels() As String
[C++]
HRESULT get_SupportedInstrumentModels(BSTR* value);
[ANSI C]
HRESULT IIviDriverIdentity_get_SupportedInstrumentModels(IIviDriverIdentity* This, BSTR* value);
[C#]
public string SupportedInstrumentModels {get;}

Capability Group

IviScopeBase

Also In This Interface

Description | Revision | Vendor | InstrumentManufacturer | InstrumentModel | InstrumentFirmwareRevision | Identifier | SupportedInstrumentModels | SpecificationMajorVersion | SpecificationMinorVersion | GroupCapabilities | IIviDriverIdentity Overview


Vendor Property

IIviDriverIdentity.Vendor Property

The name of the vendor that supplies the implementing component. Vendor is limited to 256 bytes.

[Visual Basic]
Property Get Vendor() As String
[C++]
HRESULT get_Vendor(BSTR* value);
[ANSI C]
HRESULT IIviDriverIdentity_get_Vendor(IIviDriverIdentity* This, BSTR* value);
[C#]
public string Vendor {get;}

Capability Group

IviScopeBase

Also In This Interface

Description | Revision | Vendor | InstrumentManufacturer | InstrumentModel | InstrumentFirmwareRevision | Identifier | SupportedInstrumentModels | SpecificationMajorVersion | SpecificationMinorVersion | GroupCapabilities | IIviDriverIdentity Overview


Cache Property

IIviDriverOperation.Cache Property

Drivers may choose to always cache some instrument settings, never cache others, and optionally cache others, to avoid unecessary I/O to the instrument. If True, the driver caches optionally cached instrument settings.

[Visual Basic]
Property Get Cache() As Boolean
Property Let Cache(value As Boolean)
[C++]
HRESULT get_Cache(VARIANT_BOOL* value);
HRESULT put_Cache(VARIANT_BOOL value);
[ANSI C]
HRESULT IIviDriverOperation_get_Cache(IIviDriverOperation* This, VARIANT_BOOL* value);
HRESULT IIviDriverOperation_put_Cache(IIviDriverOperation* This, VARIANT_BOOL value);
[C#]
public bool Cache {get; set;}

Capability Group

IviScopeBase

Related Items

InvalidateAllAttributes

Also In This Interface

LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


ClearInterchangeWarnings Method

IIviDriverOperation.ClearInterchangeWarnings Method

Clears the list of interchangeability warnings that the IVI specific driver maintains.

[Visual Basic]
Sub ClearInterchangeWarnings()
[C++]
HRESULT ClearInterchangeWarnings();
[ANSI C]
HRESULT IIviDriverOperation_ClearInterchangeWarnings(
   IIviDriverOperation* This);
[C#]
public void ClearInterchangeWarnings();

Capability Group

IviScopeBase

Related Items

GetNextInterchangeWarning | ResetInterchangeCheck | InterchangeCheck

Also In This Interface

LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


DriverSetup Property

IIviDriverOperation.DriverSetup Property

The driver setup string. It is either specified in the Configuration Store or passed in the OptionString parameter of the Initialize function. Driver setup is empty if the driver is not initialized.

[Visual Basic]
Property Get DriverSetup() As String
[C++]
HRESULT get_DriverSetup(BSTR* value);
[ANSI C]
HRESULT IIviDriverOperation_get_DriverSetup(IIviDriverOperation* This, BSTR* value);
[C#]
public string DriverSetup {get;}

Capability Group

IviScopeBase

Also In This Interface

LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


GetNextCoercionRecord Method

IIviDriverOperation.GetNextCoercionRecord Method

Returns the oldest record from the coercion record list. Records are only added to the list if RecordCoercions is True.

[Visual Basic]
Function GetNextCoercionRecord() As String
[C++]
HRESULT GetNextCoercionRecord(
   BSTR* CoercionRecord
);
[ANSI C]
HRESULT IIviDriverOperation_GetNextCoercionRecord(
   IIviDriverOperation* This
   BSTR* CoercionRecord
);
[C#]
public string GetNextCoercionRecord();

Parameters

CoercionRecord
The coercion record string shall contain the following information:
  • The name of the attribute that was coerced. This can be the generic name, the COM property name, or the C defined constant.
  • If the attribute is channel-based, the name of the channel. The channel name can be the specific driver channel string or the virtual channel name that the user specified.
  • If the attribute applies to a repeated capability, the name of the repeated capability. The name can be the specific driver repeated capability token or the virtual repeated capability name that the user specified.
  • The value that the user specified for the attribute.
  • The value to which the attribute was coerced.

    • Capability Group

    IviScopeBase

    Related Items

    RecordCoercions

    Also In This Interface

    LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


GetNextInterchangeWarning Method

IIviDriverOperation.GetNextInterchangeWarning Method

Returns the oldest warning from the interchange warning list. Records are only added to the list if InterchangeCheck is True.

[Visual Basic]
Function GetNextInterchangeWarning() As String
[C++]
HRESULT GetNextInterchangeWarning(
   BSTR* InterchangeWarning
);
[ANSI C]
HRESULT IIviDriverOperation_GetNextInterchangeWarning(
   IIviDriverOperation* This
   BSTR* InterchangeWarning
);
[C#]
public string GetNextInterchangeWarning();

Parameters

InterchangeWarning
A string describing the oldest interchangeability warning or empty string if no warrnings remain.

Capability Group

IviScopeBase

Related Items

ClearInterchangeWarnings | ResetInterchangeCheck | InterchangeCheck

Also In This Interface

LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


InterchangeCheck Property

IIviDriverOperation.InterchangeCheck Property

If True, the driver maintains a record of interchangeability warnings. If the driver does not support interchangeability checking, attempts to set InterchangeCheck to True return an error.

[Visual Basic]
Property Get InterchangeCheck() As Boolean
Property Let InterchangeCheck(value As Boolean)
[C++]
HRESULT get_InterchangeCheck(VARIANT_BOOL* value);
HRESULT put_InterchangeCheck(VARIANT_BOOL value);
[ANSI C]
HRESULT IIviDriverOperation_get_InterchangeCheck(IIviDriverOperation* This, VARIANT_BOOL* value);
HRESULT IIviDriverOperation_put_InterchangeCheck(IIviDriverOperation* This, VARIANT_BOOL value);
[C#]
public bool InterchangeCheck {get; set;}

Capability Group

IviScopeBase

Related Items

ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck

Also In This Interface

LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


InvalidateAllAttributes Method

IIviDriverOperation.InvalidateAllAttributes Method

Invalidates all of the driver's cached values.

[Visual Basic]
Sub InvalidateAllAttributes()
[C++]
HRESULT InvalidateAllAttributes();
[ANSI C]
HRESULT IIviDriverOperation_InvalidateAllAttributes(
   IIviDriverOperation* This);
[C#]
public void InvalidateAllAttributes();

Capability Group

IviScopeBase

Related Items

Cache

Also In This Interface

LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


IoResourceDescriptor Property

IIviDriverOperation.IoResourceDescriptor Property

The resource descriptor specifies the connection to a physical device. It is either specified in the Configuration Store or passed in the ResourceName parameter of the Initialize function. It is empty if the driver is not initialized.

[Visual Basic]
Property Get IoResourceDescriptor() As String
[C++]
HRESULT get_IoResourceDescriptor(BSTR* value);
[ANSI C]
HRESULT IIviDriverOperation_get_IoResourceDescriptor(IIviDriverOperation* This, BSTR* value);
[C#]
public string IoResourceDescriptor {get;}

Capability Group

IviScopeBase

Also In This Interface

LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


LogicalName Property

IIviDriverOperation.LogicalName Property

Logical Name identifies a driver session in the Configuration Store. If Logical Name is not empty, the driver was initialized from information in the driver session. If it is empty, the driver was initialized without using the Configuration Store.

[Visual Basic]
Property Get LogicalName() As String
[C++]
HRESULT get_LogicalName(BSTR* value);
[ANSI C]
HRESULT IIviDriverOperation_get_LogicalName(IIviDriverOperation* This, BSTR* value);
[C#]
public string LogicalName {get;}

Capability Group

IviScopeBase

Also In This Interface

LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


QueryInstrumentStatus Property

IIviDriverOperation.QueryInstrumentStatus Property

If True, the driver queries the instrument status at the end of each method or property that performs I/O to the instrument. If an error is reported, use ErrorQuery to retrieve error messages one at a time from the instrument.

[Visual Basic]
Property Get QueryInstrumentStatus() As Boolean
Property Let QueryInstrumentStatus(value As Boolean)
[C++]
HRESULT get_QueryInstrumentStatus(VARIANT_BOOL* value);
HRESULT put_QueryInstrumentStatus(VARIANT_BOOL value);
[ANSI C]
HRESULT IIviDriverOperation_get_QueryInstrumentStatus(IIviDriverOperation* This, VARIANT_BOOL* value);
HRESULT IIviDriverOperation_put_QueryInstrumentStatus(IIviDriverOperation* This, VARIANT_BOOL value);
[C#]
public bool QueryInstrumentStatus {get; set;}

Capability Group

IviScopeBase

Also In This Interface

LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


RangeCheck Property

IIviDriverOperation.RangeCheck Property

Drivers may choose to always validate some property/parameter values, never validate others, and optionally validate others, to avoid sending invalid commands to the instrument. If True, the driver performs optional validations.

[Visual Basic]
Property Get RangeCheck() As Boolean
Property Let RangeCheck(value As Boolean)
[C++]
HRESULT get_RangeCheck(VARIANT_BOOL* value);
HRESULT put_RangeCheck(VARIANT_BOOL value);
[ANSI C]
HRESULT IIviDriverOperation_get_RangeCheck(IIviDriverOperation* This, VARIANT_BOOL* value);
HRESULT IIviDriverOperation_put_RangeCheck(IIviDriverOperation* This, VARIANT_BOOL value);
[C#]
public bool RangeCheck {get; set;}

Capability Group

IviScopeBase

Also In This Interface

LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


RecordCoercions Property

IIviDriverOperation.RecordCoercions Property

If True, the driver keeps a list of the value coercions it makes for ViInt32 and ViReal64 attributes. If the driver does not support coercion recording, attempts to set RecordCoercions to True will return an error.

[Visual Basic]
Property Get RecordCoercions() As Boolean
Property Let RecordCoercions(value As Boolean)
[C++]
HRESULT get_RecordCoercions(VARIANT_BOOL* value);
HRESULT put_RecordCoercions(VARIANT_BOOL value);
[ANSI C]
HRESULT IIviDriverOperation_get_RecordCoercions(IIviDriverOperation* This, VARIANT_BOOL* value);
HRESULT IIviDriverOperation_put_RecordCoercions(IIviDriverOperation* This, VARIANT_BOOL value);
[C#]
public bool RecordCoercions {get; set;}

Capability Group

IviScopeBase

Related Items

GetNextCoercionRecord

Also In This Interface

LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


ResetInterchangeCheck Method

IIviDriverOperation.ResetInterchangeCheck Method

Resets the interchangeability checking algorithms of the driver so that methods and properties that executed prior to calling this function have no affect on whether future calls to the driver generate interchangeability warnings.

[Visual Basic]
Sub ResetInterchangeCheck()
[C++]
HRESULT ResetInterchangeCheck();
[ANSI C]
HRESULT IIviDriverOperation_ResetInterchangeCheck(
   IIviDriverOperation* This);
[C#]
public void ResetInterchangeCheck();

Capability Group

IviScopeBase

Related Items

GetNextInterchangeWarning | ClearInterchangeWarnings | InterchangeCheck

Also In This Interface

LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


Simulate Property

IIviDriverOperation.Simulate Property

If True, the driver does not perform I/O to the instrument, and returns simulated values for output parameters.

[Visual Basic]
Property Get Simulate() As Boolean
Property Let Simulate(value As Boolean)
[C++]
HRESULT get_Simulate(VARIANT_BOOL* value);
HRESULT put_Simulate(VARIANT_BOOL value);
[ANSI C]
HRESULT IIviDriverOperation_get_Simulate(IIviDriverOperation* This, VARIANT_BOOL* value);
HRESULT IIviDriverOperation_put_Simulate(IIviDriverOperation* This, VARIANT_BOOL value);
[C#]
public bool Simulate {get; set;}

Capability Group

IviScopeBase

Also In This Interface

LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


Disable Method

IIviDriverUtility.Disable Method

Quickly places the instrument in a state where it has no, or minimal, effect on the external system to which it is connected. This state is not necessarily a known state.

[Visual Basic]
Sub Disable()
[C++]
HRESULT Disable();
[ANSI C]
HRESULT IIviDriverUtility_Disable(
   IIviDriverUtility* This);
[C#]
public void Disable();

Capability Group

IviScopeBase

Also In This Interface

Reset | ResetWithDefaults | Disable | SelfTest | ErrorQuery | LockObject | UnlockObject | IIviDriverUtility Overview


ErrorQuery Method

IIviDriverUtility.ErrorQuery Method

Queries the instrument and returns instrument specific error information. This function can be used when QueryInstrumentStatus is True to retrieve error details when the driver detects an instrument error.

[Visual Basic]
Sub ErrorQuery( _
   ErrorCode As Long, _
   ErrorMessage As String _
)
[C++]
HRESULT ErrorQuery(
   long* ErrorCode,
   BSTR* ErrorMessage
);
[ANSI C]
HRESULT IIviDriverUtility_ErrorQuery(
   IIviDriverUtility* This
   long* ErrorCode,
   BSTR* ErrorMessage
);
[C#]
public void ErrorQuery(
   long ErrorCode,
   string ErrorMessage
);

Parameters

ErrorCode
Instrument error code
ErrorMessage
Instrument error message

Capability Group

IviScopeBase

Also In This Interface

Reset | ResetWithDefaults | Disable | SelfTest | ErrorQuery | LockObject | UnlockObject | IIviDriverUtility Overview


LockObject Method

IIviDriverUtility.LockObject Method

Obtains a multithread lock on the driver after waiting until all other execution threads have released their locks on the instrument session.

[Visual Basic]
Sub LockObject()
[C++]
HRESULT LockObject();
[ANSI C]
HRESULT IIviDriverUtility_LockObject(
   IIviDriverUtility* This);
[C#]
public void LockObject();

Capability Group

IviScopeBase

Related Items

UnlockObject

Also In This Interface

Reset | ResetWithDefaults | Disable | SelfTest | ErrorQuery | LockObject | UnlockObject | IIviDriverUtility Overview


Reset Method

IIviDriverUtility.Reset Method

Places the instrument in a known state and configures instrument options on which the IVI specific driver depends (for example, enabling/disabling headers). For an IEEE 488.2 instrument, Reset sends the command string *RST to the instrument.

[Visual Basic]
Sub Reset()
[C++]
HRESULT Reset();
[ANSI C]
HRESULT IIviDriverUtility_Reset(
   IIviDriverUtility* This);
[C#]
public void Reset();

Capability Group

IviScopeBase

Related Items

ResetWithDefaults

Also In This Interface

Reset | ResetWithDefaults | Disable | SelfTest | ErrorQuery | LockObject | UnlockObject | IIviDriverUtility Overview


ResetWithDefaults Method

IIviDriverUtility.ResetWithDefaults Method

Does the equivalent of Reset and then, (1) disables class extension capability groups, (2) sets attributes to initial values defined by class specs, and (3) configures the driver to option string settings used when Initialize was last executed.

[Visual Basic]
Sub ResetWithDefaults()
[C++]
HRESULT ResetWithDefaults();
[ANSI C]
HRESULT IIviDriverUtility_ResetWithDefaults(
   IIviDriverUtility* This);
[C#]
public void ResetWithDefaults();

Capability Group

IviScopeBase

Also In This Interface

Reset | ResetWithDefaults | Disable | SelfTest | ErrorQuery | LockObject | UnlockObject | IIviDriverUtility Overview


SelfTest Method

IIviDriverUtility.SelfTest Method

Performs an instrument self test, waits for the instrument to complete the test, and queries the instrument for the results. If the instrument passes the test, TestResult is zero and TestMessage is 'Self test passed'.

[Visual Basic]
Sub SelfTest( _
   TestResult As Long, _
   TestMessage As String _
)
[C++]
HRESULT SelfTest(
   long* TestResult,
   BSTR* TestMessage
);
[ANSI C]
HRESULT IIviDriverUtility_SelfTest(
   IIviDriverUtility* This
   long* TestResult,
   BSTR* TestMessage
);
[C#]
public void SelfTest(
   long TestResult,
   string TestMessage
);

Parameters

TestResult
The numeric result from the self test operation. 0 = no error (test passed)
TestMessage
The self test status message

Capability Group

IviScopeBase

Also In This Interface

Reset | ResetWithDefaults | Disable | SelfTest | ErrorQuery | LockObject | UnlockObject | IIviDriverUtility Overview


UnlockObject Method

IIviDriverUtility.UnlockObject Method

Releases a previously obtained mutlithread lock.

[Visual Basic]
Sub UnlockObject()
[C++]
HRESULT UnlockObject();
[ANSI C]
HRESULT IIviDriverUtility_UnlockObject(
   IIviDriverUtility* This);
[C#]
public void UnlockObject();

Capability Group

IviScopeBase

Related Items

LockObject

Also In This Interface

Reset | ResetWithDefaults | Disable | SelfTest | ErrorQuery | LockObject | UnlockObject | IIviDriverUtility Overview