IviPwrMeter Reference

© 2003 IVI Foundation

Welcome to the IviPwrMeter Class-Compliant Interface Reference

This section contains the reference material for the IviPwrMeter class-compliant interface.

This help hierarchy matches the COM hierarchy defined in the IviPwrMeter class specification, available on the IVI Foundation Web Site. The COM hierarchy groups related capabilities into common interfaces. These interfaces often include both IviPwrMeter base and extension capabilities. To help users distinguish between base and extension capabilities, the Capability Group section of each method or property topic lists which of the IviPwrMeter Capability Groups the method or property belongs to.

Since IVI class-compliant specific drivers are not required to support all extension groups, users should refer to the compliance documentation for the particular driver being used to determine if an extension group is supported before using capabilities in that group.

IVI class-compliant specific drivers may have small differences in the way a particular extension group method or property is implemented. For instance, a driver might implement only one of several IVI-defined values for an extension group attribute. Refer to the help documentation provided with the IVI class-compliant specific driver for detailed information about implementation.


Inherent Interface

IviDCPwr Reference

IviDCPwr Capability Groups

Capability Group | Description
IviPwrMeterBase | Power Meter that complies with the IviPwrMeterBase capability group.
IviPwrMeterChannelAcquisition | Power Meter that can acquire a measurement from a specified channel.
IviPwrMeterManualRange | Power Meter that can manually set the measurement range.
IviPwrMeterTriggerSource | Power Meter that is able to specify a trigger source.
IviPwrMeterInternalTrigger | Power Meter that can trigger internally on the measurement signal.
IviPwrMeterSoftwareTrigger | Power Meter that can trigger on a software trigger signal.
IviPwrMeterAveragingCount | Power Meter that can specify an averaging count in manual averaging mode.
IviPwrMeterZeroCorrection | Power Meter that can perform zero correction on an input channel for a given power sensor.
IviPwrMeterDutyCycleCorrection | Power Meter that can perform a duty cycle correction.
IviPwrMeterCalibration | Power Meter that can perform calibration for a given power sensor.
IviPwrMeterReferenceOscillator | Power Meter that can enable and configure an internal reference oscillator.


Inherent Interface

IviPwrMeter Instrument Class Interfaces

IIviPwrMeter | IVI PwrMeter class-compliant root interface
IIviPwrMeterAveraging | Class-compliant IIviPwrMeter interface containing methods and properties concerning averaging
IIviPwrMeterChannel | Class-compliant IIviPwrMeter interface containing methods and properties that apply to a particular channel
IIviPwrMeterChannels | Class-compliant IIviPwrMeter interface containing methods and properties that apply to all channels in the instrument. A particular channel can be referenced using the Item property
IIviPwrMeterDutyCycleCorrection | Class-compliant IIviPwrMeter interface containing methods and properties concerning duty cycle correction
IIviPwrMeterInternalTrigger | Class-compliant IIviPwrMeter interface containing methods and properties concerning the internal triggering capabilties of the instrument
IIviPwrMeterMeasurement | Class-compliant IIviPwrMeter interface containing methods and properties for initiating and retrieving measurements
IIviPwrMeterRange | Class-compliant IIviPwrMeter interface containing methods and properties concerning the meter and sensor range selection.
IIviPwrMeterReferenceOscillator | Class-compliant IIviPwrMeter interface containing methods and properties concerning the Reference Oscillator
IIviPwrMeterTrigger | Class-compliant IIviPwrMeter interface containing methods and properties concerning the triggering capabilities of the instrument


IIviPwrMeter Interface

IVI PwrMeter class-compliant root interface

Methods

Initialize | Opens the I/O session to the instrument. Driver methods and properties that access the instrument are only accessible after Initialize is called. Initialize optionally performs a Reset and queries the instrument to validate the instrument model.
Close | Closes the I/O session to the instrument. Driver methods and properties that access the instrument are not accessible after Close is called.

Properties

DriverOperation | Pointer to the IIviDriverOperation interface
Identity | Pointer to the IIviDriverIdentity interface
Utility | Pointer to the IIviDriverUtility interface
Initialized | Initialized is True between a successful call to the Initialize method and a successful call to the Close method, and False at all other times.
Channels | Reference to the class-compliant IIviPwrMeterChannels interface
Measurement | Reference to the class-compliant IIviPwrMeterMeasurement interface
ReferenceOscillator | Reference to the class-compliant IIviPwrReferenceOscillator interface
Trigger | Reference to the class-compliant IIviPwrMeterTrigger interface


DriverOperation Property

IIviPwrMeter.DriverOperation Property

Pointer to the IIviDriverOperation interface

[Visual Basic]
Property Get DriverOperation() As IIviDriverOperation
[C++]
HRESULT get_DriverOperation(IIviDriverOperation** value);
[ANSI C]
HRESULT IIviPwrMeter_get_DriverOperation(IIviPwrMeter* This, IIviDriverOperation** value);
[C#]
public IIviDriverOperation DriverOperation {get;}

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Channels | Measurement | ReferenceOscillator | Trigger | Initialize | Close | IIviPwrMeter Overview


Identity Property

IIviPwrMeter.Identity Property

Pointer to the IIviDriverIdentity interface

[Visual Basic]
Property Get Identity() As IIviDriverIdentity
[C++]
HRESULT get_Identity(IIviDriverIdentity** value);
[ANSI C]
HRESULT IIviPwrMeter_get_Identity(IIviPwrMeter* This, IIviDriverIdentity** value);
[C#]
public IIviDriverIdentity Identity {get;}

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Channels | Measurement | ReferenceOscillator | Trigger | Initialize | Close | IIviPwrMeter Overview


Utility Property

IIviPwrMeter.Utility Property

Pointer to the IIviDriverUtility interface

[Visual Basic]
Property Get Utility() As IIviDriverUtility
[C++]
HRESULT get_Utility(IIviDriverUtility** value);
[ANSI C]
HRESULT IIviPwrMeter_get_Utility(IIviPwrMeter* This, IIviDriverUtility** value);
[C#]
public IIviDriverUtility Utility {get;}

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Channels | Measurement | ReferenceOscillator | Trigger | Initialize | Close | IIviPwrMeter Overview


Initialized Property

IIviPwrMeter.Initialized Property

Initialized is True between a successful call to the Initialize method and a successful call to the Close method, and False at all other times.

[Visual Basic]
Property Get Initialized() As Boolean
[C++]
HRESULT get_Initialized(VARIANT_BOOL* value);
[ANSI C]
HRESULT IIviPwrMeter_get_Initialized(IIviPwrMeter* This, VARIANT_BOOL* value);
[C#]
public bool Initialized {get;}

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Channels | Measurement | ReferenceOscillator | Trigger | Initialize | Close | IIviPwrMeter Overview


Channels Property

IIviPwrMeter.Channels Property

Reference to the class-compliant IIviPwrMeterChannels interface

[Visual Basic]
Property Get Channels() As IIviPwrMeterChannels
[C++]
HRESULT get_Channels(IIviPwrMeterChannels** value);
[ANSI C]
HRESULT IIviPwrMeter_get_Channels(IIviPwrMeter* This, IIviPwrMeterChannels** value);
[C#]
public IIviPwrMeterChannels Channels {get;}

Capability Group

IviPwrMeterBase, IviPwrMeterZeroCorrection, IviPwrMeterCalibration

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Channels | Measurement | ReferenceOscillator | Trigger | Initialize | Close | IIviPwrMeter Overview


Measurement Property

IIviPwrMeter.Measurement Property

Reference to the class-compliant IIviPwrMeterMeasurement interface

[Visual Basic]
Property Get Measurement() As IIviPwrMeterMeasurement
[C++]
HRESULT get_Measurement(IIviPwrMeterMeasurement** value);
[ANSI C]
HRESULT IIviPwrMeter_get_Measurement(IIviPwrMeter* This, IIviPwrMeterMeasurement** value);
[C#]
public IIviPwrMeterMeasurement Measurement {get;}

Capability Group

IviPwrMeterBase, IviPwrMeterSoftwareTrigger, IviPwrMeterChannelAcquisition

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Channels | Measurement | ReferenceOscillator | Trigger | Initialize | Close | IIviPwrMeter Overview


ReferenceOscillator Property

IIviPwrMeter.ReferenceOscillator Property

Reference to the class-compliant IIviPwrReferenceOscillator interface

[Visual Basic]
Property Get ReferenceOscillator() As IIviPwrMeterReferenceOscillator
[C++]
HRESULT get_ReferenceOscillator(IIviPwrMeterReferenceOscillator** value);
[ANSI C]
HRESULT IIviPwrMeter_get_ReferenceOscillator(IIviPwrMeter* This, IIviPwrMeterReferenceOscillator** value);
[C#]
public IIviPwrMeterReferenceOscillator ReferenceOscillator {get;}

Capability Group

IviPwrMeterReferenceOscillator

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Channels | Measurement | ReferenceOscillator | Trigger | Initialize | Close | IIviPwrMeter Overview


Trigger Property

IIviPwrMeter.Trigger Property

Reference to the class-compliant IIviPwrMeterTrigger interface

[Visual Basic]
Property Get Trigger() As IIviPwrMeterTrigger
[C++]
HRESULT get_Trigger(IIviPwrMeterTrigger** value);
[ANSI C]
HRESULT IIviPwrMeter_get_Trigger(IIviPwrMeter* This, IIviPwrMeterTrigger** value);
[C#]
public IIviPwrMeterTrigger Trigger {get;}

Capability Group

IviPwrMeterTriggerSource

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Channels | Measurement | ReferenceOscillator | Trigger | Initialize | Close | IIviPwrMeter Overview


Initialize Method

IIviPwrMeter.Initialize Method

Opens the I/O session to the instrument. Driver methods and properties that access the instrument are only accessible after Initialize is called. Initialize optionally performs a Reset and queries the instrument to validate the instrument model.

[Visual Basic]
Sub Initialize( _
   ResourceName As String, _
   IdQuery As Boolean, _
   Reset As Boolean, _
   OptionString As String _
)
[C++]
HRESULT Initialize(
   BSTR ResourceName,
   VARIANT_BOOL IdQuery,
   VARIANT_BOOL Reset,
   BSTR OptionString
);
[ANSI C]
HRESULT IIviPwrMeter_Initialize(
   IIviPwrMeter* This
   BSTR ResourceName,
   VARIANT_BOOL IdQuery,
   VARIANT_BOOL Reset,
   BSTR OptionString
);
[C#]
public void Initialize(
   string ResourceName,
   bool IdQuery,
   bool Reset,
   string OptionString
);

Parameters

ResourceName
An IVI logical name or an instrument specific string that identifies the address of the instrument, such as a VISA resource descriptor string.
IdQuery
Specifies whether to verify the ID of the instrument.
Reset
Specifies whether to reset the instrument.
OptionString
The user can use the OptionsString parameter to specify the initial values of certain IVI inherent attributes for the session.

Related Items

Close

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Channels | Measurement | ReferenceOscillator | Trigger | Initialize | Close | IIviPwrMeter Overview


Close Method

IIviPwrMeter.Close Method

Closes the I/O session to the instrument. Driver methods and properties that access the instrument are not accessible after Close is called.

[Visual Basic]
Sub Close()
[C++]
HRESULT Close();
[ANSI C]
HRESULT IIviPwrMeter_Close(
   IIviPwrMeter* This);
[C#]
public void Close();

Related Items

Initialize

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Channels | Measurement | ReferenceOscillator | Trigger | Initialize | Close | IIviPwrMeter Overview


IIviPwrMeterAveraging Interface

Class-compliant IIviPwrMeter interface containing methods and properties concerning averaging

Properties

AutoEnabled | Class-compliant IIviPwrMeter property specifying whether auto-averaging is enabled or disabled for a particular input channel
Count | Class-compliant IIviPwrMeter property specifying the averaging count. When the Auto Averaging Enabled attribute is set to False, the driver filters the input signal by averaging it the number of times specified by this property


AutoEnabled Property

IIviPwrMeterAveraging.AutoEnabled Property

Class-compliant IIviPwrMeter property specifying whether auto-averaging is enabled or disabled for a particular input channel

[Visual Basic]
Property Get AutoEnabled() As Boolean
Property Let AutoEnabled(value As Boolean)
[C++]
HRESULT get_AutoEnabled(VARIANT_BOOL* value);
HRESULT put_AutoEnabled(VARIANT_BOOL value);
[ANSI C]
HRESULT IIviPwrMeterAveraging_get_AutoEnabled(IIviPwrMeterAveraging* This, VARIANT_BOOL* value);
HRESULT IIviPwrMeterAveraging_put_AutoEnabled(IIviPwrMeterAveraging* This, VARIANT_BOOL value);
[C#]
public bool AutoEnabled {get; set;}

Capability Group

IviPwrMeterBase

Also In This Interface

AutoEnabled | Count | IIviPwrMeterAveraging Overview


Count Property

IIviPwrMeterAveraging.Count Property

Class-compliant IIviPwrMeter property specifying the averaging count. When the Auto Averaging Enabled attribute is set to False, the driver filters the input signal by averaging it the number of times specified by this property

[Visual Basic]
Property Get Count() As Long
Property Let Count(value As Long)
[C++]
HRESULT get_Count(long* value);
HRESULT put_Count(long value);
[ANSI C]
HRESULT IIviPwrMeterAveraging_get_Count(IIviPwrMeterAveraging* This, long* value);
HRESULT IIviPwrMeterAveraging_put_Count(IIviPwrMeterAveraging* This, long value);
[C#]
public long Count {get; set;}

Capability Group

IviPwrMeterAveragingCount

Also In This Interface

AutoEnabled | Count | IIviPwrMeterAveraging Overview


IIviPwrMeterChannel Interface

Class-compliant IIviPwrMeter interface containing methods and properties that apply to a particular channel

Methods

Calibrate | Class-compliant IIviPwrMeter method that performs a calibration on a particular channel and sensor. This method returns only after calibration is complete
Zero | Class-compliant IIviPwrMeter method that performs a zero operation on a particular channel

Properties

Averaging | Reference to the class-compliant IIviPwrMeterAveraging interface
CorrectionFrequency | Class-compliant IIviPwrMeter property specifying the frequency of the input signal in Hertz. The instrument uses this value to determine the appropriate correction factor for the sensor
DutyCycle | Reference to the class-compliant IIviPwrMeterDutyCycleCorrection interface
Enabled | Class-compliant IIviPwrMeter property specifying whether the power meter should take a measurement on a particular input channel. The power meter will take a measurement on a channel only if that channel is enabled
Offset | Class-compliant IIviPwrMeter property specifying an offset to be added to the measured value in units of dB. This property can be used to compensate for system losses or gains between the unit under test and the power sensor
Range | Reference to the class-compliant IIviPwrMeterRange interface


Averaging Property

IIviPwrMeterChannel.Averaging Property

Reference to the class-compliant IIviPwrMeterAveraging interface

[Visual Basic]
Property Get Averaging() As IIviPwrMeterAveraging
[C++]
HRESULT get_Averaging(IIviPwrMeterAveraging** value);
[ANSI C]
HRESULT IIviPwrMeterChannel_get_Averaging(IIviPwrMeterChannel* This, IIviPwrMeterAveraging** value);
[C#]
public IIviPwrMeterAveraging Averaging {get;}

Capability Group

IviPwrMeterBase, IviPwrMeterAveragingCount

Also In This Interface

Averaging | CorrectionFrequency | DutyCycle | Enabled | Offset | Range | Calibrate | Zero | IIviPwrMeterChannel Overview


CorrectionFrequency Property

IIviPwrMeterChannel.CorrectionFrequency Property

Class-compliant IIviPwrMeter property specifying the frequency of the input signal in Hertz. The instrument uses this value to determine the appropriate correction factor for the sensor

[Visual Basic]
Property Get CorrectionFrequency() As Double
Property Let CorrectionFrequency(value As Double)
[C++]
HRESULT get_CorrectionFrequency(double* value);
HRESULT put_CorrectionFrequency(double value);
[ANSI C]
HRESULT IIviPwrMeterChannel_get_CorrectionFrequency(IIviPwrMeterChannel* This, double* value);
HRESULT IIviPwrMeterChannel_put_CorrectionFrequency(IIviPwrMeterChannel* This, double value);
[C#]
public double CorrectionFrequency {get; set;}

Capability Group

IviPwrMeterBase

Also In This Interface

Averaging | CorrectionFrequency | DutyCycle | Enabled | Offset | Range | Calibrate | Zero | IIviPwrMeterChannel Overview


DutyCycle Property

IIviPwrMeterChannel.DutyCycle Property

Reference to the class-compliant IIviPwrMeterDutyCycleCorrection interface

[Visual Basic]
Property Get DutyCycle() As IIviPwrMeterDutyCycleCorrection
[C++]
HRESULT get_DutyCycle(IIviPwrMeterDutyCycleCorrection** value);
[ANSI C]
HRESULT IIviPwrMeterChannel_get_DutyCycle(IIviPwrMeterChannel* This, IIviPwrMeterDutyCycleCorrection** value);
[C#]
public IIviPwrMeterDutyCycleCorrection DutyCycle {get;}

Capability Group

IviPwrMeterDutyCycleCorrection

Also In This Interface

Averaging | CorrectionFrequency | DutyCycle | Enabled | Offset | Range | Calibrate | Zero | IIviPwrMeterChannel Overview


Enabled Property

IIviPwrMeterChannel.Enabled Property

Class-compliant IIviPwrMeter property specifying whether the power meter should take a measurement on a particular input channel. The power meter will take a measurement on a channel only if that channel is enabled

[Visual Basic]
Property Get Enabled() As Boolean
Property Let Enabled(value As Boolean)
[C++]
HRESULT get_Enabled(VARIANT_BOOL* value);
HRESULT put_Enabled(VARIANT_BOOL value);
[ANSI C]
HRESULT IIviPwrMeterChannel_get_Enabled(IIviPwrMeterChannel* This, VARIANT_BOOL* value);
HRESULT IIviPwrMeterChannel_put_Enabled(IIviPwrMeterChannel* This, VARIANT_BOOL value);
[C#]
public bool Enabled {get; set;}

Capability Group

IviPwrMeterChannelAcquisition

Also In This Interface

Averaging | CorrectionFrequency | DutyCycle | Enabled | Offset | Range | Calibrate | Zero | IIviPwrMeterChannel Overview


Offset Property

IIviPwrMeterChannel.Offset Property

Class-compliant IIviPwrMeter property specifying an offset to be added to the measured value in units of dB. This property can be used to compensate for system losses or gains between the unit under test and the power sensor

[Visual Basic]
Property Get Offset() As Double
Property Let Offset(value As Double)
[C++]
HRESULT get_Offset(double* value);
HRESULT put_Offset(double value);
[ANSI C]
HRESULT IIviPwrMeterChannel_get_Offset(IIviPwrMeterChannel* This, double* value);
HRESULT IIviPwrMeterChannel_put_Offset(IIviPwrMeterChannel* This, double value);
[C#]
public double Offset {get; set;}

Capability Group

IviPwrMeterBase

Also In This Interface

Averaging | CorrectionFrequency | DutyCycle | Enabled | Offset | Range | Calibrate | Zero | IIviPwrMeterChannel Overview


Range Property

IIviPwrMeterChannel.Range Property

Reference to the class-compliant IIviPwrMeterRange interface

[Visual Basic]
Property Get Range() As IIviPwrMeterRange
[C++]
HRESULT get_Range(IIviPwrMeterRange** value);
[ANSI C]
HRESULT IIviPwrMeterChannel_get_Range(IIviPwrMeterChannel* This, IIviPwrMeterRange** value);
[C#]
public IIviPwrMeterRange Range {get;}

Capability Group

IviPwrMeterBase, IviPwrMeterManualRange

Also In This Interface

Averaging | CorrectionFrequency | DutyCycle | Enabled | Offset | Range | Calibrate | Zero | IIviPwrMeterChannel Overview


Calibrate Method

IIviPwrMeterChannel.Calibrate Method

Class-compliant IIviPwrMeter method that performs a calibration on a particular channel and sensor. This method returns only after calibration is complete

[Visual Basic]
Sub Calibrate()
[C++]
HRESULT Calibrate();
[ANSI C]
HRESULT IIviPwrMeterChannel_Calibrate(
   IIviPwrMeterChannel* This);
[C#]
public void Calibrate();

Capability Group

IviPwrMeterCalibration

Related Items

IIviPwrMeterChannels.IsCalibrationComplete

Also In This Interface

Averaging | CorrectionFrequency | DutyCycle | Enabled | Offset | Range | Calibrate | Zero | IIviPwrMeterChannel Overview


Zero Method

IIviPwrMeterChannel.Zero Method

Class-compliant IIviPwrMeter method that performs a zero operation on a particular channel

[Visual Basic]
Sub Zero()
[C++]
HRESULT Zero();
[ANSI C]
HRESULT IIviPwrMeterChannel_Zero(
   IIviPwrMeterChannel* This);
[C#]
public void Zero();

Capability Group

IviPwrMeterZeroCorrection

Related Items

IIviPwrMeterChannels.Zero

Also In This Interface

Averaging | CorrectionFrequency | DutyCycle | Enabled | Offset | Range | Calibrate | Zero | IIviPwrMeterChannel Overview


IIviPwrMeterChannels Interface

Class-compliant IIviPwrMeter interface containing methods and properties that apply to all channels in the instrument. A particular channel can be referenced using the Item property

Methods

IsCalibrationComplete | Class-compliant IIviPwrMeter method that queries the instrument to determine the status of all calibration operations
IsZeroComplete | Class-compliant IIviPwrMeter method that queries the instrument to determine the status of all zero operations
Zero | Class-compliant IIviPwrMeter method that performs a zero operation on all enabled channels

Properties

Count | Class-compliant IIviPwrMeter property that indicates the number of channels available on the instrument
Item | Class-compliant IIviPwrMeter property that is used to reference a Channel interface for a given channel. The Name property can be used to determine the name of a particular channel
Name | Class-compliant IIviPwrMeter property that returns the name of a particular channel
Units | Class-compliant IIviPwrMeter property specifying the unit to which the RF power is converted after measurement


Count Property

IIviPwrMeterChannels.Count Property

Class-compliant IIviPwrMeter property that indicates the number of channels available on the instrument

[Visual Basic]
Property Get Count() As Long
[C++]
HRESULT get_Count(long* value);
[ANSI C]
HRESULT IIviPwrMeterChannels_get_Count(IIviPwrMeterChannels* This, long* value);
[C#]
public long Count {get;}

Capability Group

IviPwrMeterBase

Also In This Interface

Count | Item | Name | Units | IsCalibrationComplete | IsZeroComplete | Zero | IIviPwrMeterChannels Overview


Item Property

IIviPwrMeterChannels.Item Property

Class-compliant IIviPwrMeter property that is used to reference a Channel interface for a given channel. The Name property can be used to determine the name of a particular channel

[Visual Basic]
Property Get Item(ChannelName As String) As IIviPwrMeterChannel
[C++]
HRESULT get_Item(BSTR ChannelName, IIviPwrMeterChannel** value);
[ANSI C]
HRESULT IIviPwrMeterChannels_get_Item(IIviPwrMeterChannels* This, BSTR ChannelName, IIviPwrMeterChannel** value);
[C#]HRESULT get_Item(string ChannelName, IIviPwrMeterChannel value);

Parameters

ChannelName
The ChannelName parameter may be a string defined by the driver or supplied as a virtual name in the configuration store.

Capability Group

IviPwrMeterBase

Also In This Interface

Count | Item | Name | Units | IsCalibrationComplete | IsZeroComplete | Zero | IIviPwrMeterChannels Overview


Name Property

IIviPwrMeterChannels.Name Property

Class-compliant IIviPwrMeter property that returns the name of a particular channel

[Visual Basic]
Property Get Name(Index As Long) As String
[C++]
HRESULT get_Name(long Index, BSTR* value);
[ANSI C]
HRESULT IIviPwrMeterChannels_get_Name(IIviPwrMeterChannels* This, long Index, BSTR* value);
[C#]HRESULT get_Name(long Index, string value);

Parameters

Index
The one-based index into the Channels collection. Its value must range from one to Channels.Count.

Capability Group

IviPwrMeterBase

Also In This Interface

Count | Item | Name | Units | IsCalibrationComplete | IsZeroComplete | Zero | IIviPwrMeterChannels Overview


Units Property

IIviPwrMeterChannels.Units Property

Class-compliant IIviPwrMeter property specifying the unit to which the RF power is converted after measurement

[Visual Basic]
Property Get Units() As IviPwrMeterUnitsEnum
Property Let Units(value As IviPwrMeterUnitsEnum)
[C++]
HRESULT get_Units(IviPwrMeterUnitsEnum* value);
HRESULT put_Units(IviPwrMeterUnitsEnum value);
[ANSI C]
HRESULT IIviPwrMeterChannels_get_Units(IIviPwrMeterChannels* This, IviPwrMeterUnitsEnum* value);
HRESULT IIviPwrMeterChannels_put_Units(IIviPwrMeterChannels* This, IviPwrMeterUnitsEnum value);
[C#]
public IviPwrMeterUnitsEnum Units {get; set;}

Capability Group

IviPwrMeterBase

Also In This Interface

Count | Item | Name | Units | IsCalibrationComplete | IsZeroComplete | Zero | IIviPwrMeterChannels Overview


IsCalibrationComplete Method

IIviPwrMeterChannels.IsCalibrationComplete Method

Class-compliant IIviPwrMeter method that queries the instrument to determine the status of all calibration operations

[Visual Basic]
Function IsCalibrationComplete() As IviPwrMeterCalibrationStatusEnum
[C++]
HRESULT IsCalibrationComplete(
   IviPwrMeterCalibrationStatusEnum* Status
);
[ANSI C]
HRESULT IIviPwrMeterChannels_IsCalibrationComplete(
   IIviPwrMeterChannels* This
   IviPwrMeterCalibrationStatusEnum* Status
);
[C#]
public IviPwrMeterCalibrationStatusEnum IsCalibrationComplete();

Parameters

Status
Returns the status of the calibration.

Capability Group

IviPwrMeterCalibration

Also In This Interface

Count | Item | Name | Units | IsCalibrationComplete | IsZeroComplete | Zero | IIviPwrMeterChannels Overview


IsZeroComplete Method

IIviPwrMeterChannels.IsZeroComplete Method

Class-compliant IIviPwrMeter method that queries the instrument to determine the status of all zero operations

[Visual Basic]
Function IsZeroComplete() As IviPwrMeterZeroStatusEnum
[C++]
HRESULT IsZeroComplete(
   IviPwrMeterZeroStatusEnum* Status
);
[ANSI C]
HRESULT IIviPwrMeterChannels_IsZeroComplete(
   IIviPwrMeterChannels* This
   IviPwrMeterZeroStatusEnum* Status
);
[C#]
public IviPwrMeterZeroStatusEnum IsZeroComplete();

Parameters

Status
Returns the status of the zeroing.

Capability Group

IviPwrMeterZeroCorrection

Related Items

Zero

Also In This Interface

Count | Item | Name | Units | IsCalibrationComplete | IsZeroComplete | Zero | IIviPwrMeterChannels Overview


Zero Method

IIviPwrMeterChannels.Zero Method

Class-compliant IIviPwrMeter method that performs a zero operation on all enabled channels

[Visual Basic]
Sub Zero()
[C++]
HRESULT Zero();
[ANSI C]
HRESULT IIviPwrMeterChannels_Zero(
   IIviPwrMeterChannels* This);
[C#]
public void Zero();

Capability Group

IviPwrMeterZeroCorrection

Related Items

IsZeroComplete

Also In This Interface

Count | Item | Name | Units | IsCalibrationComplete | IsZeroComplete | Zero | IIviPwrMeterChannels Overview


IIviPwrMeterDutyCycleCorrection Interface

Class-compliant IIviPwrMeter interface containing methods and properties concerning duty cycle correction

Methods

Configure Class-compliant IIviPwrMeter method that enables or disables duty cycle correction and sets the duty cycle for pulse power measurements

Properties

Enabled | Class-compliant IIviPwrMeter property specifying whether duty cycle correction is enabled on a particular channel
Value | Class-compliant IIviPwrMeter property specifying the duty cycle correction the power meter uses to calculate the pulse power of a pulse-modulated signal. The value of this attribute is specified as a percentage


Enabled Property

IIviPwrMeterDutyCycleCorrection.Enabled Property

Class-compliant IIviPwrMeter property specifying whether duty cycle correction is enabled on a particular channel

[Visual Basic]
Property Get Enabled() As Boolean
Property Let Enabled(value As Boolean)
[C++]
HRESULT get_Enabled(VARIANT_BOOL* value);
HRESULT put_Enabled(VARIANT_BOOL value);
[ANSI C]
HRESULT IIviPwrMeterDutyCycleCorrection_get_Enabled(IIviPwrMeterDutyCycleCorrection* This, VARIANT_BOOL* value);
HRESULT IIviPwrMeterDutyCycleCorrection_put_Enabled(IIviPwrMeterDutyCycleCorrection* This, VARIANT_BOOL value);
[C#]
public bool Enabled {get; set;}

Capability Group

IviPwrMeterDutyCycleCorrection

Related Items

Configure

Also In This Interface

Enabled | Value | Configure | IIviPwrMeterDutyCycleCorrection Overview


Value Property

IIviPwrMeterDutyCycleCorrection.Value Property

Class-compliant IIviPwrMeter property specifying the duty cycle correction the power meter uses to calculate the pulse power of a pulse-modulated signal. The value of this attribute is specified as a percentage

[Visual Basic]
Property Get Value() As Double
Property Let Value(value As Double)
[C++]
HRESULT get_Value(double* value);
HRESULT put_Value(double value);
[ANSI C]
HRESULT IIviPwrMeterDutyCycleCorrection_get_Value(IIviPwrMeterDutyCycleCorrection* This, double* value);
HRESULT IIviPwrMeterDutyCycleCorrection_put_Value(IIviPwrMeterDutyCycleCorrection* This, double value);
[C#]
public double Value {get; set;}

Capability Group

IviPwrMeterDutyCycleCorrection

Related Items

Configure

Also In This Interface

Enabled | Value | Configure | IIviPwrMeterDutyCycleCorrection Overview


Configure Method

IIviPwrMeterDutyCycleCorrection.Configure Method

Class-compliant IIviPwrMeter method that enables or disables duty cycle correction and sets the duty cycle for pulse power measurements

[Visual Basic]
Sub Configure( _
   Enabled As Boolean, _
   Value As Double _
)
[C++]
HRESULT Configure(
   VARIANT_BOOL Enabled,
   double Value
);
[ANSI C]
HRESULT IIviPwrMeterDutyCycleCorrection_Configure(
   IIviPwrMeterDutyCycleCorrection* This
   VARIANT_BOOL Enabled,
   double Value
);
[C#]
public void Configure(
   bool Enabled,
   double Value
);

Parameters

Enabled
Enables or disables the duty cycle correction. This parameter sets the Duty Cycle Correction Enabled property.
Value
Specifies the expected value of the duty cycle correction. This parameter sets the Duty Cycle Correction property.

Capability Group

IviPwrMeterDutyCycleCorrection

Related Items

Enabled | Value

Also In This Interface

Enabled | Value | Configure | IIviPwrMeterDutyCycleCorrection Overview


IIviPwrMeterInternalTrigger Interface

Class-compliant IIviPwrMeter interface containing methods and properties concerning the internal triggering capabilties of the instrument

Methods

Configure Class-compliant IIviPwrMeter method that configures the internal trigger event source, slope and level

Properties

EventSource | Class-compliant IIviPwrMeter property specifying the channel that the power meter uses to monitor the internal trigger event
Level | Class-compliant IIviPwrMeter property specifying the trigger level for the measurement signal. The value of this property is specified in the same unit as the value of the Channels.Units property
Slope | Class-compliant IIviPwrMeter property specifying whether the power meter should trigger on the rising or falling edge of the measurement signal


EventSource Property

IIviPwrMeterInternalTrigger.EventSource Property

Class-compliant IIviPwrMeter property specifying the channel that the power meter uses to monitor the internal trigger event

[Visual Basic]
Property Get EventSource() As String
Property Let EventSource(value As String)
[C++]
HRESULT get_EventSource(BSTR* value);
HRESULT put_EventSource(BSTR value);
[ANSI C]
HRESULT IIviPwrMeterInternalTrigger_get_EventSource(IIviPwrMeterInternalTrigger* This, BSTR* value);
HRESULT IIviPwrMeterInternalTrigger_put_EventSource(IIviPwrMeterInternalTrigger* This, BSTR value);
[C#]
public string EventSource {get; set;}

Capability Group

IviPwrMeterInternalTrigger

Related Items

Configure

Also In This Interface

EventSource | Level | Slope | Configure | IIviPwrMeterInternalTrigger Overview


Level Property

IIviPwrMeterInternalTrigger.Level Property

Class-compliant IIviPwrMeter property specifying the trigger level for the measurement signal. The value of this property is specified in the same unit as the value of the Channels.Units property

[Visual Basic]
Property Get Level() As Double
Property Let Level(value As Double)
[C++]
HRESULT get_Level(double* value);
HRESULT put_Level(double value);
[ANSI C]
HRESULT IIviPwrMeterInternalTrigger_get_Level(IIviPwrMeterInternalTrigger* This, double* value);
HRESULT IIviPwrMeterInternalTrigger_put_Level(IIviPwrMeterInternalTrigger* This, double value);
[C#]
public double Level {get; set;}

Capability Group

IviPwrMeterInternalTrigger

Also In This Interface

EventSource | Level | Slope | Configure | IIviPwrMeterInternalTrigger Overview


Slope Property

IIviPwrMeterInternalTrigger.Slope Property

Class-compliant IIviPwrMeter property specifying whether the power meter should trigger on the rising or falling edge of the measurement signal

[Visual Basic]
Property Get Slope() As IviPwrMeterInternalTriggerSlopeEnum
Property Let Slope(value As IviPwrMeterInternalTriggerSlopeEnum)
[C++]
HRESULT get_Slope(IviPwrMeterInternalTriggerSlopeEnum* value);
HRESULT put_Slope(IviPwrMeterInternalTriggerSlopeEnum value);
[ANSI C]
HRESULT IIviPwrMeterInternalTrigger_get_Slope(IIviPwrMeterInternalTrigger* This, IviPwrMeterInternalTriggerSlopeEnum* value);
HRESULT IIviPwrMeterInternalTrigger_put_Slope(IIviPwrMeterInternalTrigger* This, IviPwrMeterInternalTriggerSlopeEnum value);
[C#]
public IviPwrMeterInternalTriggerSlopeEnum Slope {get; set;}

Capability Group

IviPwrMeterInternalTrigger

Related Items

Configure

Also In This Interface

EventSource | Level | Slope | Configure | IIviPwrMeterInternalTrigger Overview


Configure Method

IIviPwrMeterInternalTrigger.Configure Method

Class-compliant IIviPwrMeter method that configures the internal trigger event source, slope and level

[Visual Basic]
Sub Configure( _
   EventSource As String, _
   Slope As IviPwrMeterInternalTriggerSlopeEnum _
)
[C++]
HRESULT Configure(
   BSTR EventSource,
   IviPwrMeterInternalTriggerSlopeEnum Slope
);
[ANSI C]
HRESULT IIviPwrMeterInternalTrigger_Configure(
   IIviPwrMeterInternalTrigger* This
   BSTR EventSource,
   IviPwrMeterInternalTriggerSlopeEnum Slope
);
[C#]
public void Configure(
   string EventSource,
   IviPwrMeterInternalTriggerSlopeEnum Slope
);

Parameters

EventSource
The name of the channel to use as the internal trigger event source. The driver uses this value to set the Internal Trigger Event Source attribute. See the attribute description for more information.
Slope
The internal trigger slope. This value sets the Internal Trigger Slope property.

Capability Group

IviPwrMeterInternalTrigger

Related Items

EventSource | Slope

Also In This Interface

EventSource | Level | Slope | Configure | IIviPwrMeterInternalTrigger Overview


IIviPwrMeterMeasurement Interface

Class-compliant IIviPwrMeter interface containing methods and properties for initiating and retrieving measurements

Methods

Abort | Class-compliant IIviPwrMeter method that aborts all previously initiated measurements and returns the power meter to the Idle state.
Configure | Class-compliant IIviPwrMeter method that configures the instrument to take single or dual channel measurements
Fetch | Class-compliant IIviPwrMeter method that returns the result of a previously configured and initiated 1 or 2 channel measurement. Measurement.Configure can be used to set up the measurement. Measurement.Initiate initiates that measurement
FetchChannel | Class-compliant IIviPwrMeter method that returns the result from a previously initiated measurement on a specified channel. Initiate initiates that measurement. The meaurement result will be returned in the units specified by the Unit property
Initiate | Class-compliant IIviPwrMeter method that initiates a measurement on all enabled channels. When this method executes, the power meter leaves the Idle state
IsMeasurementComplete | Class-compliant IIviPwrMeter method that queries the instrument to determine the status of the measurement initiated by the Initiate method. This method returns a status of Measurement only when measurements are complete on all enabled channels.
QueryResultRangeType | Class-compliant IIviPwrMeter method that takes a measurement value returned from Fetch, Fetch Channel, Read, or Read Channel and determines if the value is a valid measurement value or a value indicating that an out-of-range condition occurred.
Read | Class-compliant IIviPwrMeter method that initiates a previously configured measurement, waits until the power meter has returned to the Idle state, then returns the result of that measurement. Measurement.Configure can be used to set up the measurement
ReadChannel | Class-compliant IIviPwrMeter method that initiates a measurement, waits until the power meter has returned to the Idle state, then returns the result of the measurement on the specified channel
SendSoftwareTrigger | Class-compliant IIviPwrMeter method that sends a software trigger to the instrument


Abort Method

IIviPwrMeterMeasurement.Abort Method

Class-compliant IIviPwrMeter method that aborts all previously initiated measurements and returns the power meter to the Idle state.

[Visual Basic]
Sub Abort()
[C++]
HRESULT Abort();
[ANSI C]
HRESULT IIviPwrMeterMeasurement_Abort(
   IIviPwrMeterMeasurement* This);
[C#]
public void Abort();

Capability Group

IviPwrMeterBase

Also In This Interface

Abort | Configure | Fetch | FetchChannel | Initiate | IsMeasurementComplete | QueryResultRangeType | Read | ReadChannel | SendSoftwareTrigger | IIviPwrMeterMeasurement Overview


Configure Method

IIviPwrMeterMeasurement.Configure Method

Class-compliant IIviPwrMeter method that configures the instrument to take single or dual channel measurements

[Visual Basic]
Sub Configure( _
   Operator As IviPwrMeterMeasurementOperatorEnum, _
   Operand1 As String, _
   Operand2 As String _
)
[C++]
HRESULT Configure(
   IviPwrMeterMeasurementOperatorEnum Operator,
   BSTR Operand1,
   BSTR Operand2
);
[ANSI C]
HRESULT IIviPwrMeterMeasurement_Configure(
   IIviPwrMeterMeasurement* This
   IviPwrMeterMeasurementOperatorEnum Operator,
   BSTR Operand1,
   BSTR Operand2
);
[C#]
public void Configure(
   IviPwrMeterMeasurementOperatorEnum Operator,
   string Operand1,
   string Operand2
);

Parameters

Operator
The math function applied to the operands.
Operand1
The name of the channel from which the value for the first operand of the math function is measured.
Operand2
The name of the channel from which the value for the second operand of the math function is measured.

Capability Group

IviPwrMeterBase

Also In This Interface

Abort | Configure | Fetch | FetchChannel | Initiate | IsMeasurementComplete | QueryResultRangeType | Read | ReadChannel | SendSoftwareTrigger | IIviPwrMeterMeasurement Overview


Fetch Method

IIviPwrMeterMeasurement.Fetch Method

Class-compliant IIviPwrMeter method that returns the result of a previously configured and initiated 1 or 2 channel measurement. Measurement.Configure can be used to set up the measurement. Measurement.Initiate initiates that measurement

[Visual Basic]
Function Fetch() As Double
[C++]
HRESULT Fetch(
   double* Result
);
[ANSI C]
HRESULT IIviPwrMeterMeasurement_Fetch(
   IIviPwrMeterMeasurement* This
   double* Result
);
[C#]
public double Fetch();

Parameters

Result
Measured value

Capability Group

IviPwrMeterBase

Related Items

FetchChannel

Also In This Interface

Abort | Configure | Fetch | FetchChannel | Initiate | IsMeasurementComplete | QueryResultRangeType | Read | ReadChannel | SendSoftwareTrigger | IIviPwrMeterMeasurement Overview


FetchChannel Method

IIviPwrMeterMeasurement.FetchChannel Method

Class-compliant IIviPwrMeter method that returns the result from a previously initiated measurement on a specified channel. Initiate initiates that measurement. The meaurement result will be returned in the units specified by the Unit property

[Visual Basic]
Function FetchChannel( _
   ChannelName As String _
) As Double
[C++]
HRESULT FetchChannel(
   BSTR ChannelName,
   double* Result
);
[ANSI C]
HRESULT IIviPwrMeterMeasurement_FetchChannel(
   IIviPwrMeterMeasurement* This
   BSTR ChannelName,
   double* Result
);
[C#]
public double FetchChannel(
   string ChannelName
);

Parameters

ChannelName
The name of the channel from which to fetch the measurement.
Result
Measured value

Capability Group

IviPwrMeterChannelAcquisition

Related Items

Fetch

Also In This Interface

Abort | Configure | Fetch | FetchChannel | Initiate | IsMeasurementComplete | QueryResultRangeType | Read | ReadChannel | SendSoftwareTrigger | IIviPwrMeterMeasurement Overview


Initiate Method

IIviPwrMeterMeasurement.Initiate Method

Class-compliant IIviPwrMeter method that initiates a measurement on all enabled channels. When this method executes, the power meter leaves the Idle state

[Visual Basic]
Sub Initiate()
[C++]
HRESULT Initiate();
[ANSI C]
HRESULT IIviPwrMeterMeasurement_Initiate(
   IIviPwrMeterMeasurement* This);
[C#]
public void Initiate();

Capability Group

IviPwrMeterBase

Also In This Interface

Abort | Configure | Fetch | FetchChannel | Initiate | IsMeasurementComplete | QueryResultRangeType | Read | ReadChannel | SendSoftwareTrigger | IIviPwrMeterMeasurement Overview


IsMeasurementComplete Method

IIviPwrMeterMeasurement.IsMeasurementComplete Method

Class-compliant IIviPwrMeter method that queries the instrument to determine the status of the measurement initiated by the Initiate method. This method returns a status of Measurement only when measurements are complete on all enabled channels.

[Visual Basic]
Function IsMeasurementComplete() As IviPwrMeterMeasurementStatusEnum
[C++]
HRESULT IsMeasurementComplete(
   IviPwrMeterMeasurementStatusEnum* Status
);
[ANSI C]
HRESULT IIviPwrMeterMeasurement_IsMeasurementComplete(
   IIviPwrMeterMeasurement* This
   IviPwrMeterMeasurementStatusEnum* Status
);
[C#]
public IviPwrMeterMeasurementStatusEnum IsMeasurementComplete();

Parameters

Status
Returns the status of the measurement.

Capability Group

IviPwrMeterBase

Also In This Interface

Abort | Configure | Fetch | FetchChannel | Initiate | IsMeasurementComplete | QueryResultRangeType | Read | ReadChannel | SendSoftwareTrigger | IIviPwrMeterMeasurement Overview


QueryResultRangeType Method

IIviPwrMeterMeasurement.QueryResultRangeType Method

Class-compliant IIviPwrMeter method that takes a measurement value returned from Fetch, Fetch Channel, Read, or Read Channel and determines if the value is a valid measurement value or a value indicating that an out-of-range condition occurred.

[Visual Basic]
Function QueryResultRangeType( _
   MeasurementValue As Double _
) As IviPwrMeterResultRangeEnum
[C++]
HRESULT QueryResultRangeType(
   double MeasurementValue,
   IviPwrMeterResultRangeEnum* RangeType
);
[ANSI C]
HRESULT IIviPwrMeterMeasurement_QueryResultRangeType(
   IIviPwrMeterMeasurement* This
   double MeasurementValue,
   IviPwrMeterResultRangeEnum* RangeType
);
[C#]
public IviPwrMeterResultRangeEnum QueryResultRangeType(
   double MeasurementValue
);

Parameters

MeasurementValue
The measurement value returned by one of the Fetch or Read functions.
RangeType
Returns whether the MeasurementValue is a valid measurement or a value indicating that the power meter encountered an out-of-range condition.

Capability Group

IviPwrMeterBase

Also In This Interface

Abort | Configure | Fetch | FetchChannel | Initiate | IsMeasurementComplete | QueryResultRangeType | Read | ReadChannel | SendSoftwareTrigger | IIviPwrMeterMeasurement Overview


Read Method

IIviPwrMeterMeasurement.Read Method

Class-compliant IIviPwrMeter method that initiates a previously configured measurement, waits until the power meter has returned to the Idle state, then returns the result of that measurement. Measurement.Configure can be used to set up the measurement

[Visual Basic]
Function Read( _
   MaxTimeMilliseconds As Long _
) As Double
[C++]
HRESULT Read(
   long MaxTimeMilliseconds,
   double* Result
);
[ANSI C]
HRESULT IIviPwrMeterMeasurement_Read(
   IIviPwrMeterMeasurement* This
   long MaxTimeMilliseconds,
   double* Result
);
[C#]
public double Read(
   long MaxTimeMilliseconds
);

Parameters

MaxTimeMilliseconds
Specifies the maximum time in milliseconds to wait for a return value. It may also be one of the values in IviPwrMeterTimeOutEnum.
Result
Measured value.

Capability Group

IviPwrMeterBase

Related Items

ReadChannel

Also In This Interface

Abort | Configure | Fetch | FetchChannel | Initiate | IsMeasurementComplete | QueryResultRangeType | Read | ReadChannel | SendSoftwareTrigger | IIviPwrMeterMeasurement Overview


ReadChannel Method

IIviPwrMeterMeasurement.ReadChannel Method

Class-compliant IIviPwrMeter method that initiates a measurement, waits until the power meter has returned to the Idle state, then returns the result of the measurement on the specified channel

[Visual Basic]
Function ReadChannel( _
   ChannelName As String, _
   MaxTimeMilliseconds As Long _
) As Double
[C++]
HRESULT ReadChannel(
   BSTR ChannelName,
   long MaxTimeMilliseconds,
   double* Result
);
[ANSI C]
HRESULT IIviPwrMeterMeasurement_ReadChannel(
   IIviPwrMeterMeasurement* This
   BSTR ChannelName,
   long MaxTimeMilliseconds,
   double* Result
);
[C#]
public double ReadChannel(
   string ChannelName,
   long MaxTimeMilliseconds
);

Parameters

ChannelName
The name of the channel from which to take the measurement.
MaxTimeMilliseconds
Specifies the maximum time in seconds to wait for a return value. It may also be one of the values in IviPwrMeterTimeOutEnum.
Result
Measured value.

Capability Group

IviPwrMeterChannelAcquisition

Related Items

Read

Also In This Interface

Abort | Configure | Fetch | FetchChannel | Initiate | IsMeasurementComplete | QueryResultRangeType | Read | ReadChannel | SendSoftwareTrigger | IIviPwrMeterMeasurement Overview


SendSoftwareTrigger Method

IIviPwrMeterMeasurement.SendSoftwareTrigger Method

Class-compliant IIviPwrMeter method that sends a software trigger to the instrument

[Visual Basic]
Sub SendSoftwareTrigger()
[C++]
HRESULT SendSoftwareTrigger();
[ANSI C]
HRESULT IIviPwrMeterMeasurement_SendSoftwareTrigger(
   IIviPwrMeterMeasurement* This);
[C#]
public void SendSoftwareTrigger();

Capability Group

IviPwrMeterSoftwareTrigger

Also In This Interface

Abort | Configure | Fetch | FetchChannel | Initiate | IsMeasurementComplete | QueryResultRangeType | Read | ReadChannel | SendSoftwareTrigger | IIviPwrMeterMeasurement Overview


IIviPwrMeterRange Interface

Class-compliant IIviPwrMeter interface containing methods and properties concerning the meter and sensor range selection.

Methods

Configure Class-compliant IIviPwrMeter method that configures the lower and upper range values for a particular channel

Properties

AutoEnabled | Class-compliant IIviPwrMeter property specifying if the power meter should set the best range for the measurement. If True, the instrument automatically sets the best range. If False, set the range using the Range.Upper and Range.Lower properties
Lower | Class-compliant IIviPwrMeter property specifying the lower limit (minimum) of the expected value of the measurement. The value of this property is specified in the same units as the value of the Channels.Units property
Upper | Class-compliant IIviPwrMeter property specifying the upper limit (maximum) of the expected value of the measurement. The value of this property is specified in the same units as the value of the Channels.Units property


AutoEnabled Property

IIviPwrMeterRange.AutoEnabled Property

Class-compliant IIviPwrMeter property specifying if the power meter should set the best range for the measurement. If True, the instrument automatically sets the best range. If False, set the range using the Range.Upper and Range.Lower properties

[Visual Basic]
Property Get AutoEnabled() As Boolean
Property Let AutoEnabled(value As Boolean)
[C++]
HRESULT get_AutoEnabled(VARIANT_BOOL* value);
HRESULT put_AutoEnabled(VARIANT_BOOL value);
[ANSI C]
HRESULT IIviPwrMeterRange_get_AutoEnabled(IIviPwrMeterRange* This, VARIANT_BOOL* value);
HRESULT IIviPwrMeterRange_put_AutoEnabled(IIviPwrMeterRange* This, VARIANT_BOOL value);
[C#]
public bool AutoEnabled {get; set;}

Capability Group

IviPwrMeterBase

Also In This Interface

AutoEnabled | Lower | Upper | Configure | IIviPwrMeterRange Overview


Lower Property

IIviPwrMeterRange.Lower Property

Class-compliant IIviPwrMeter property specifying the lower limit (minimum) of the expected value of the measurement. The value of this property is specified in the same units as the value of the Channels.Units property

[Visual Basic]
Property Get Lower() As Double
Property Let Lower(value As Double)
[C++]
HRESULT get_Lower(double* value);
HRESULT put_Lower(double value);
[ANSI C]
HRESULT IIviPwrMeterRange_get_Lower(IIviPwrMeterRange* This, double* value);
HRESULT IIviPwrMeterRange_put_Lower(IIviPwrMeterRange* This, double value);
[C#]
public double Lower {get; set;}

Capability Group

IviPwrMeterManualRange

Related Items

Upper | Configure

Also In This Interface

AutoEnabled | Lower | Upper | Configure | IIviPwrMeterRange Overview


Upper Property

IIviPwrMeterRange.Upper Property

Class-compliant IIviPwrMeter property specifying the upper limit (maximum) of the expected value of the measurement. The value of this property is specified in the same units as the value of the Channels.Units property

[Visual Basic]
Property Get Upper() As Double
Property Let Upper(value As Double)
[C++]
HRESULT get_Upper(double* value);
HRESULT put_Upper(double value);
[ANSI C]
HRESULT IIviPwrMeterRange_get_Upper(IIviPwrMeterRange* This, double* value);
HRESULT IIviPwrMeterRange_put_Upper(IIviPwrMeterRange* This, double value);
[C#]
public double Upper {get; set;}

Capability Group

IviPwrMeterManualRange

Related Items

Lower | Configure

Also In This Interface

AutoEnabled | Lower | Upper | Configure | IIviPwrMeterRange Overview


Configure Method

IIviPwrMeterRange.Configure Method

Class-compliant IIviPwrMeter method that configures the lower and upper range values for a particular channel

[Visual Basic]
Sub Configure( _
   Lower As Double, _
   Upper As Double _
)
[C++]
HRESULT Configure(
   double Lower,
   double Upper
);
[ANSI C]
HRESULT IIviPwrMeterRange_Configure(
   IIviPwrMeterRange* This
   double Lower,
   double Upper
);
[C#]
public void Configure(
   double Lower,
   double Upper
);

Parameters

Lower
The lower limit of the expected value of the measurement. This parameter is sets the Range.Lower property.
Upper
The upper limit of the expected value of the measurement. This parameter sets the Range.Upper property.

Capability Group

IviPwrMeterManualRange

Related Items

Lower | Upper

Also In This Interface

AutoEnabled | Lower | Upper | Configure | IIviPwrMeterRange Overview


IIviPwrMeterReferenceOscillator Interface

Class-compliant IIviPwrMeter interface containing methods and properties concerning the Reference Oscillator

Methods

Configure Class-compliant IIviPwrMeter method that sets the frequency and power level of the signal generated by the reference oscillator

Properties

Enabled | Class-compliant IIviPwrMeter property specifying if the internal reference oscillator is enabled
Frequency | Class-compliant IIviPwrMeter property specifying the frequency of the signal generated by the reference oscillator in Hertz
Level | Class-compliant IIviPwrMeter property specifying the power level of the signal generated by the reference oscillator in dBm


Enabled Property

IIviPwrMeterReferenceOscillator.Enabled Property

Class-compliant IIviPwrMeter property specifying if the internal reference oscillator is enabled

[Visual Basic]
Property Get Enabled() As Boolean
Property Let Enabled(value As Boolean)
[C++]
HRESULT get_Enabled(VARIANT_BOOL* value);
HRESULT put_Enabled(VARIANT_BOOL value);
[ANSI C]
HRESULT IIviPwrMeterReferenceOscillator_get_Enabled(IIviPwrMeterReferenceOscillator* This, VARIANT_BOOL* value);
HRESULT IIviPwrMeterReferenceOscillator_put_Enabled(IIviPwrMeterReferenceOscillator* This, VARIANT_BOOL value);
[C#]
public bool Enabled {get; set;}

Capability Group

IviPwrMeterReferenceOscillator

Also In This Interface

Enabled | Frequency | Level | Configure | IIviPwrMeterReferenceOscillator Overview


Frequency Property

IIviPwrMeterReferenceOscillator.Frequency Property

Class-compliant IIviPwrMeter property specifying the frequency of the signal generated by the reference oscillator in Hertz

[Visual Basic]
Property Get Frequency() As Double
Property Let Frequency(value As Double)
[C++]
HRESULT get_Frequency(double* value);
HRESULT put_Frequency(double value);
[ANSI C]
HRESULT IIviPwrMeterReferenceOscillator_get_Frequency(IIviPwrMeterReferenceOscillator* This, double* value);
HRESULT IIviPwrMeterReferenceOscillator_put_Frequency(IIviPwrMeterReferenceOscillator* This, double value);
[C#]
public double Frequency {get; set;}

Capability Group

IviPwrMeterReferenceOscillator

Related Items

Configure

Also In This Interface

Enabled | Frequency | Level | Configure | IIviPwrMeterReferenceOscillator Overview


Level Property

IIviPwrMeterReferenceOscillator.Level Property

Class-compliant IIviPwrMeter property specifying the power level of the signal generated by the reference oscillator in dBm

[Visual Basic]
Property Get Level() As Double
Property Let Level(value As Double)
[C++]
HRESULT get_Level(double* value);
HRESULT put_Level(double value);
[ANSI C]
HRESULT IIviPwrMeterReferenceOscillator_get_Level(IIviPwrMeterReferenceOscillator* This, double* value);
HRESULT IIviPwrMeterReferenceOscillator_put_Level(IIviPwrMeterReferenceOscillator* This, double value);
[C#]
public double Level {get; set;}

Capability Group

IviPwrMeterReferenceOscillator

Related Items

Configure

Also In This Interface

Enabled | Frequency | Level | Configure | IIviPwrMeterReferenceOscillator Overview


Configure Method

IIviPwrMeterReferenceOscillator.Configure Method

Class-compliant IIviPwrMeter method that sets the frequency and power level of the signal generated by the reference oscillator

[Visual Basic]
Sub Configure( _
   Frequency As Double, _
   Level As Double _
)
[C++]
HRESULT Configure(
   double Frequency,
   double Level
);
[ANSI C]
HRESULT IIviPwrMeterReferenceOscillator_Configure(
   IIviPwrMeterReferenceOscillator* This
   double Frequency,
   double Level
);
[C#]
public void Configure(
   double Frequency,
   double Level
);

Parameters

Frequency
The frequency of the reference oscillator. This parameter sets the Reference Oscillator Frequency property.
Level
The power level of the reference oscillator. This parameter sets the Reference Oscillator Level property

Capability Group

IviPwrMeterReferenceOscillator

Related Items

Frequency | Level

Also In This Interface

Enabled | Frequency | Level | Configure | IIviPwrMeterReferenceOscillator Overview


IIviPwrMeterTrigger Interface

Class-compliant IIviPwrMeter interface containing methods and properties concerning the triggering capabilities of the instrument

Properties

Source | Class-compliant IIviPwrMeter property specifying the trigger source that the power meter monitors for a trigger event
Internal | Reference to the class-compliant IIviPwrMeterInternalTrigger interface


Source Property

IIviPwrMeterTrigger.Source Property

Class-compliant IIviPwrMeter property specifying the trigger source that the power meter monitors for a trigger event

[Visual Basic]
Property Get Source() As IviPwrMeterTriggerSourceEnum
Property Let Source(value As IviPwrMeterTriggerSourceEnum)
[C++]
HRESULT get_Source(IviPwrMeterTriggerSourceEnum* value);
HRESULT put_Source(IviPwrMeterTriggerSourceEnum value);
[ANSI C]
HRESULT IIviPwrMeterTrigger_get_Source(IIviPwrMeterTrigger* This, IviPwrMeterTriggerSourceEnum* value);
HRESULT IIviPwrMeterTrigger_put_Source(IIviPwrMeterTrigger* This, IviPwrMeterTriggerSourceEnum value);
[C#]
public IviPwrMeterTriggerSourceEnum Source {get; set;}

Capability Group

IviPwrMeterTriggerSource

Also In This Interface

Source | Internal | IIviPwrMeterTrigger Overview


Internal Property

IIviPwrMeterTrigger.Internal Property

Reference to the class-compliant IIviPwrMeterInternalTrigger interface

[Visual Basic]
Property Get Internal() As IIviPwrMeterInternalTrigger
[C++]
HRESULT get_Internal(IIviPwrMeterInternalTrigger** value);
[ANSI C]
HRESULT IIviPwrMeterTrigger_get_Internal(IIviPwrMeterTrigger* This, IIviPwrMeterInternalTrigger** value);
[C#]
public IIviPwrMeterInternalTrigger Internal {get;}

Capability Group

IviPwrMeterInternalTrigger

Also In This Interface

Source | Internal | IIviPwrMeterTrigger Overview


IviPwrMeterCalibrationStatusEnum Enumeration

IVI PwrMeter class-compliant values for Calibration Status

Members

Member Name | Description
IviPwrMeterCalibrationStatusComplete | The power meter has completed the calibration.
IviPwrMeterCalibrationStatusInProgress | The power meter is still performing calibration.
IviPwrMeterCalibrationStatusUnknown | The power meter cannot determine the status of the calibration.


IviPwrMeterErrorCodesEnum Enumeration

IVI PwrMeter class-compliant Errors

Members

Member Name | Description
S_IVIPWRMETER_WARN_UNDER_RANGE | Measurement is under range.
S_IVIPWRMETER_WARN_OVER_RANGE | Measurement is over range.
E_IVIPWRMETER_CHANNEL_NOT_ENABLED | The specified channel is not enabled for measurement.
E_IVIPWRMETER_MAX_TIME_EXCEEDED | Maximum timeout exceeded before operation could complete.
E_IVIPWRMETER_TRIGGER_NOT_SOFTWARE | The trigger source is not set to software trigger.


IviPwrMeterInternalTriggerSlopeEnum Enumeration

IVI PwrMeter class-compliant values for Internal Trigger Slope

Members

Member Name | Description
IviPwrMeterInternalTriggerSlopeNegative | Sets the trigger event to occur on the falling edge of the trigger pulse.
IviPwrMeterInternalTriggerSlopePositive | Sets the trigger event to occur on the rising edge of the trigger pulse.


IviPwrMeterMeasurementOperatorEnum Enumeration

IVI PwrMeter class-compliant values for Measurement Operator

Members

Member Name | Description
IviPwrMeterMeasurementOperatorNone | Operand1
IviPwrMeterMeasurementOperatorDifference | Operand1 - Operand2
IviPwrMeterMeasurementOperatorSum | Operand1 + Operand2
IviPwrMeterMeasurementOperatorQuotient | Operand1 / Operand2


IviPwrMeterMeasurementStatusEnum Enumeration

IVI PwrMeter class-compliant values for Measurement Status

Members

Member Name | Description
IviPwrMeterMeasurementStatusComplete | The power meter has completed the measurement on all enabled channels.
IviPwrMeterMeasurementStatusInProgress | The power meter is still taking a measurement on one or more enabled channels.
IviPwrMeterMeasurementStatusUnknown | The power meter cannot determine the status of the measurement.


IviPwrMeterResultRangeEnum Enumeration

IVI PwrMeter class-compliant values for Result Range

Members

Member Name | Description
IviPwrMeterResultRangeInRange | The measurement is within the current range limits.
IviPwrMeterResultRangeUnderRange | The measurement is below the current lower range limit.
IviPwrMeterResultRangeOverRange | The measurement is above the current upper range limit.


IviPwrMeterTimeOutEnum Enumeration

IVI PwrMeter class-compliant values for Time Out

Members

Member Name | Description
IviPwrMeterTimeOutInfinite | The function waits indefinitely for the measurement to complete.
IviPwrMeterTimeOutImmediate | The function returns immediately. If no valid measurement value exists, the function returns an error.


IviPwrMeterTriggerSourceEnum Enumeration

IVI PwrMeter class-compliant values for Trigger Source

Members

Member Name | Description
IviPwrMeterTriggerSourceImmediate | The power meter exits the Wait-For-Trigger state immediately after entering. It does not wait for a trigger of any kind.
IviPwrMeterTriggerSourceExternal | The power meter exits the Wait-For-Trigger state when a trigger occurs on the external trigger input.
IviPwrMeterTriggerSourceInternal | The power meter exits the Wait-For-Trigger state when an internal trigger event occurs on the measurement signal.
IviPwrMeterTriggerSourceSoftware | The power meter exits the Wait-For-Trigger state when it receives a software trigger.
IviPwrMeterTriggerSourceTTL0 | The power meter exits the Wait-For-Trigger state when it receives a trigger on TTL0.
IviPwrMeterTriggerSourceTTL1 | The power meter exits the Wait-For-Trigger state when it receives a trigger on TTL1.
IviPwrMeterTriggerSourceTTL2 | The power meter exits the Wait-For-Trigger state when it receives a trigger on TTL2.
IviPwrMeterTriggerSourceTTL3 | The power meter exits the Wait-For-Trigger state when it receives a trigger on TTL3.
IviPwrMeterTriggerSourceTTL4 | The power meter exits the Wait-For-Trigger state when it receives a trigger on TTL4.
IviPwrMeterTriggerSourceTTL5 | The power meter exits the Wait-For-Trigger state when it receives a trigger on TTL6.
IviPwrMeterTriggerSourceTTL6 | The power meter exits the Wait-For-Trigger state when it receives a trigger on TTL6.
IviPwrMeterTriggerSourceTTL7 | The power meter exits the Wait-For-Trigger state when it receives a trigger on TTL7.
IviPwrMeterTriggerSourceECL0 | The power meter exits the Wait-For-Trigger state when it receives a trigger on ECL0.
IviPwrMeterTriggerSourceECL1 | The power meter exits the Wait-For-Trigger state when it receives a trigger on ECL1.
IviPwrMeterTriggerSourcePXIStar | The power meter exits the Wait-For-Trigger state when it receives a trigger on PXI Star trigger bus.
IviPwrMeterTriggerSourceRTSI0 | The power meter exits the Wait-For-Trigger state when it receives a trigger on the RTSI0 line.
IviPwrMeterTriggerSourceRTSI1 | The power meter exits the Wait-For-Trigger state when it receives a trigger on the RTSI1 line.
IviPwrMeterTriggerSourceRTSI2 | The power meter exits the Wait-For-Trigger state when it receives a trigger on the RTSI2 line.
IviPwrMeterTriggerSourceRTSI3 | The power meter exits the Wait-For-Trigger state when it receives a trigger on the RTSI3 line.
IviPwrMeterTriggerSourceRTSI4 | The power meter exits the Wait-For-Trigger state when it receives a trigger on the RTSI4 line.
IviPwrMeterTriggerSourceRTSI5 | The power meter exits the Wait-For-Trigger state when it receives a trigger on the RTS5 line.
IviPwrMeterTriggerSourceRTSI6 | The power meter exits the Wait-For-Trigger state when it receives a trigger on the RTSI6 line.


IviPwrMeterUnitsEnum Enumeration

IVI PwrMeter class-compliant values for Units

Members

Member Name | Description
IviPwrMeterUnitsdBm | Sets the units to dBm.
IviPwrMeterUnitsdBmV | Sets the units to dB millivolts.
IviPwrMeterUnitsdBuV | Sets the units to dB microvolts.
IviPwrMeterUnitsWatts | Sets the units to Watts.


IviPwrMeterZeroStatusEnum Enumeration

IVI PwrMeter class-compliant values for Zero Status

Members

Member Name | Description
IviPwrMeterZeroStatusComplete | The power meter has completed all zero correction operations.
IviPwrMeterZeroStatusInProgress | The power meter is still performing zero correction on one or more channels.
IviPwrMeterZeroStatusUnknown | The power meter cannot determine the status of zero correction operations.


Topic Not Found

No matching topic was found. The link may be out of date, incorrectly authored, or the topic may not be available in this release.

You may be able to find the topic by using the index or search tab instead.


Inherent Interface

IVI Inherent Interfaces

IIviDriver | IVI Driver root interface
IIviDriverIdentity | IVI Driver identity interface
IIviDriverOperation | IVI Driver operation interface
IIviDriverUtility | IVI Driver utility interface


Instrument Specific Interfaces


IviDriver_ErrorCodes Enumeration

IVI Driver (inherent features) defined HRESULTS

Members

Member Name | Description
S_IVI_SUCCESS | Success
E_IVI_CANNOT_RECOVER | Unrecoverable failure
E_IVI_INSTRUMENT_STATUS | Instrument error detected
E_IVI_CANNOT_OPEN_FILE | File could not be opened
E_IVI_READING_FILE | File could not be read
E_IVI_WRITING_FILE | File could not be written
E_IVI_INVALID_PATHNAME | The path name is invalid
E_IVI_INVALID_VALUE | Invalid value for parameter or property
E_IVI_METHOD_NOT_SUPPORTED | Method not supported
E_IVI_PROPERTY_NOT_SUPPORTED | Property not supported
E_IVI_VALUE_NOT_SUPPORTED | The enumeration value for the parameter is not supported
E_IVI_NOT_INITIALIZED | A connection to the instrument has not been initialized
E_IVI_UNKNOWN_CHANNEL_NAME | Channel or repeated capability name specified is not valid for the instrument.
E_IVI_TOO_MANY_OPEN_FILES | Too many files opened
E_IVI_CHANNEL_NAME_REQUIRED | Channel or repeated capability name required
E_IVI_MISSING_OPTION_NAME | The option string contains an entry without a name.
E_IVI_MISSING_OPTION_VALUE | The option string contains an entry without a value.
E_IVI_BAD_OPTION_NAME | The option string contains an entry with an unknown option name.
E_IVI_BAD_OPTION_VALUE | The option string contains an entry with an unknown option value.
E_IVI_OUT_OF_MEMORY | The necessary memory could not be allocated
E_IVI_OPERATION_PENDING | Operation in progress
E_IVI_NULL_POINTER | Null pointer passed for parameter or property
E_IVI_UNEXPECTED_RESPONSE | Unexpected response from the instrument
E_IVI_FILE_NOT_FOUND | File not found
E_IVI_INVALID_FILE_FORMAT | The file format is invalid
E_IVI_STATUS_NOT_AVAILABLE | The instrument status is not available
E_IVI_ID_QUERY_FAILED | Instrument ID query failed
E_IVI_RESET_FAILED | Instrument reset failed
E_IVI_RESOURCE_UNKNOWN | Insufficient location information or resource not present in the system.
E_IVI_ALREADY_INITIALIZED | The driver is already initialized
E_IVI_CANNOT_CHANGE_SIMULATION_STATE | The simulation state cannot be changed.
S_IVI_NSUP_ID_QUERY | Identification query not supported
S_IVI_NSUP_RESET | Reset operation not supported
S_IVI_NSUP_SELF_TEST | Self test operation not supported
S_IVI_NSUP_ERROR_QUERY | Error query operation not supported
S_IVI_NSUP_REV_QUERY | Revision query not supported


IIviDriver Interface

IVI Driver root interface

Methods

Initialize | Opens the I/O session to the instrument. Driver methods and properties that access the instrument are only accessible after Initialize is called. Initialize optionally performs a Reset and queries the instrument to validate the instrument model.
Close | Closes the I/O session to the instrument. Driver methods and properties that access the instrument are not accessible after Close is called.

Properties

DriverOperation | Pointer to the IIviDriverOperation interface
Identity | Pointer to the IIviDriverIdentity interface
Utility | Pointer to the IIviDriverUtility interface
Initialized | Initialized is True between a successful call to the Initialize method and a successful call to the Close method, and False at all other times.


IIviDriverIdentity Interface

IVI Driver identity interface

Properties

Description | A brief description of the implementing component. Description is limted to 256 bytes.
Revision | The revision of the implementing component. Refer to IVI 3.1, Section 3.1.2.2, for a description of revision syntax and semantics. Revision is limited to 256 bytes.
Vendor | The name of the vendor that supplies the implementing component. Vendor is limited to 256 bytes.
InstrumentManufacturer | The name of the manufacturer reported by the physical instrument. If Simulation is enabled or the instrument is not capable of reporting the name of the manufacturer, a string is returned that explains the condition. Manufacturer is limited to 256 bytes
InstrumentModel | The model number or name reported by the physical instrument. If Simulation is enabled or the instrument is not capable of reporting the model number or name, a string is returned that explains the condition. Model is limited to 256 bytes
InstrumentFirmwareRevision | The firmware revision reported by the physical instrument. If Simulation is enabled or the instrument is not capable of reporting the firmware revision, a string is returned that explains the condition.
Identifier | The case-sensitive unique identifier of the implementing IVI-COM instrument driver.
SupportedInstrumentModels | A comma-separated list of instrument models that the IVI specific driver can control. The string does not include an abbreviation for the manufacturer if it is the same for all models.
SpecificationMajorVersion | For IVI class-compliant drivers, the major version number of the instrument class specification. If the driver is not class compliant, the driver returns zero.
SpecificationMinorVersion | For IVI class-compliant drivers, the minor version number of the instrument class specification. If the driver is not class compliant, the driver returns zero.
GroupCapabilities | A comma-separated list of the class capability groups implemented by the driver. Capability group names are documented in the IVI class specifications. If the driver is not class compliant, the driver returns an empty string.


IIviDriverOperation Interface

IVI Driver operation interface

Methods

InvalidateAllAttributes | Invalidates all of the driver's cached values.
ClearInterchangeWarnings | Clears the list of interchangeability warnings that the IVI specific driver maintains.
GetNextInterchangeWarning | Returns the oldest warning from the interchange warning list. Records are only added to the list if InterchangeCheck is True.
ResetInterchangeCheck | Resets the interchangeability checking algorithms of the driver so that methods and properties that executed prior to calling this function have no affect on whether future calls to the driver generate interchangeability warnings.
GetNextCoercionRecord | Returns the oldest record from the coercion record list. Records are only added to the list if RecordCoercions is True.

Properties

LogicalName | Logical Name identifies a driver session in the Configuration Store. If Logical Name is not empty, the driver was initialized from information in the driver session. If it is empty, the driver was initialized without using the Configuration Store.
IoResourceDescriptor | The resource descriptor specifies the connection to a physical device. It is either specified in the Configuration Store or passed in the ResourceName parameter of the Initialize function. It is empty if the driver is not initialized.
Cache | Drivers may choose to always cache some instrument settings, never cache others, and optionally cache others, to avoid unecessary I/O to the instrument. If True, the driver caches optionally cached instrument settings.
InterchangeCheck | If True, the driver maintains a record of interchangeability warnings. If the driver does not support interchangeability checking, attempts to set InterchangeCheck to True return an error.
QueryInstrumentStatus | If True, the driver queries the instrument status at the end of each method or property that performs I/O to the instrument. If an error is reported, use ErrorQuery to retrieve error messages one at a time from the instrument.
RangeCheck | Drivers may choose to always validate some property/parameter values, never validate others, and optionally validate others, to avoid sending invalid commands to the instrument. If True, the driver performs optional validations.
RecordCoercions | If True, the driver keeps a list of the value coercions it makes for ViInt32 and ViReal64 attributes. If the driver does not support coercion recording, attempts to set RecordCoercions to True will return an error.
Simulate | If True, the driver does not perform I/O to the instrument, and returns simulated values for output parameters.
DriverSetup | The driver setup string. It is either specified in the Configuration Store or passed in the OptionString parameter of the Initialize function. Driver setup is empty if the driver is not initialized.


IIviDriverUtility Interface

IVI Driver utility interface

Methods

Reset | Places the instrument in a known state and configures instrument options on which the IVI specific driver depends (for example, enabling/disabling headers). For an IEEE 488.2 instrument, Reset sends the command string *RST to the instrument.
ResetWithDefaults | Does the equivalent of Reset and then, (1) disables class extension capability groups, (2) sets attributes to initial values defined by class specs, and (3) configures the driver to option string settings used when Initialize was last executed.
Disable | Quickly places the instrument in a state where it has no, or minimal, effect on the external system to which it is connected. This state is not necessarily a known state.
SelfTest | Performs an instrument self test, waits for the instrument to complete the test, and queries the instrument for the results. If the instrument passes the test, TestResult is zero and TestMessage is 'Self test passed'.
ErrorQuery | Queries the instrument and returns instrument specific error information. This function can be used when QueryInstrumentStatus is True to retrieve error details when the driver detects an instrument error.
LockObject | Obtains a multithread lock on the driver after waiting until all other execution threads have released their locks on the instrument session.
UnlockObject | Releases a previously obtained mutlithread lock.


Close Method

IIviDriver.Close Method

Closes the I/O session to the instrument. Driver methods and properties that access the instrument are not accessible after Close is called.

[Visual Basic]
Sub Close()
[C++]
HRESULT Close();
[ANSI C]
HRESULT IIviDriver_Close(
   IIviDriver* This);
[C#]
public void Close();

Related Items

Initialize

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Initialize | Close | IIviDriver Overview


DriverOperation Property

IIviDriver.DriverOperation Property

Pointer to the IIviDriverOperation interface

[Visual Basic]
Property Get DriverOperation() As IIviDriverOperation
[C++]
HRESULT get_DriverOperation(IIviDriverOperation** value);
[ANSI C]
HRESULT IIviDriver_get_DriverOperation(IIviDriver* This, IIviDriverOperation** value);
[C#]
public IIviDriverOperation DriverOperation {get;}

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Initialize | Close | IIviDriver Overview


Identity Property

IIviDriver.Identity Property

Pointer to the IIviDriverIdentity interface

[Visual Basic]
Property Get Identity() As IIviDriverIdentity
[C++]
HRESULT get_Identity(IIviDriverIdentity** value);
[ANSI C]
HRESULT IIviDriver_get_Identity(IIviDriver* This, IIviDriverIdentity** value);
[C#]
public IIviDriverIdentity Identity {get;}

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Initialize | Close | IIviDriver Overview


Initialize Method

IIviDriver.Initialize Method

Opens the I/O session to the instrument. Driver methods and properties that access the instrument are only accessible after Initialize is called. Initialize optionally performs a Reset and queries the instrument to validate the instrument model.

[Visual Basic]
Sub Initialize( _
   ResourceName As String, _
   IdQuery As Boolean, _
   Reset As Boolean, _
   OptionString As String _
)
[C++]
HRESULT Initialize(
   BSTR ResourceName,
   VARIANT_BOOL IdQuery,
   VARIANT_BOOL Reset,
   BSTR OptionString
);
[ANSI C]
HRESULT IIviDriver_Initialize(
   IIviDriver* This
   BSTR ResourceName,
   VARIANT_BOOL IdQuery,
   VARIANT_BOOL Reset,
   BSTR OptionString
);
[C#]
public void Initialize(
   string ResourceName,
   bool IdQuery,
   bool Reset,
   string OptionString
);

Parameters

ResourceName
An IVI logical name or an instrument specific string that identifies the address of the instrument, such as a VISA resource descriptor string.
IdQuery
Specifies whether to verify the ID of the instrument.
Reset
Specifies whether to reset the instrument.
OptionString
The user can use the OptionsString parameter to specify the initial values of certain IVI inherent attributes for the session.

Related Items

Close

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Initialize | Close | IIviDriver Overview


Initialized Property

IIviDriver.Initialized Property

Initialized is True between a successful call to the Initialize method and a successful call to the Close method, and False at all other times.

[Visual Basic]
Property Get Initialized() As Boolean
[C++]
HRESULT get_Initialized(VARIANT_BOOL* value);
[ANSI C]
HRESULT IIviDriver_get_Initialized(IIviDriver* This, VARIANT_BOOL* value);
[C#]
public bool Initialized {get;}

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Initialize | Close | IIviDriver Overview


Utility Property

IIviDriver.Utility Property

Pointer to the IIviDriverUtility interface

[Visual Basic]
Property Get Utility() As IIviDriverUtility
[C++]
HRESULT get_Utility(IIviDriverUtility** value);
[ANSI C]
HRESULT IIviDriver_get_Utility(IIviDriver* This, IIviDriverUtility** value);
[C#]
public IIviDriverUtility Utility {get;}

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Initialize | Close | IIviDriver Overview


Description Property

IIviDriverIdentity.Description Property

A brief description of the implementing component. Description is limted to 256 bytes.

[Visual Basic]
Property Get Description() As String
[C++]
HRESULT get_Description(BSTR* value);
[ANSI C]
HRESULT IIviDriverIdentity_get_Description(IIviDriverIdentity* This, BSTR* value);
[C#]
public string Description {get;}

Also In This Interface

Description | Revision | Vendor | InstrumentManufacturer | InstrumentModel | InstrumentFirmwareRevision | Identifier | SupportedInstrumentModels | SpecificationMajorVersion | SpecificationMinorVersion | GroupCapabilities | IIviDriverIdentity Overview


GroupCapabilities Property

IIviDriverIdentity.GroupCapabilities Property

A comma-separated list of the class capability groups implemented by the driver. Capability group names are documented in the IVI class specifications. If the driver is not class compliant, the driver returns an empty string.

[Visual Basic]
Property Get GroupCapabilities() As String
[C++]
HRESULT get_GroupCapabilities(BSTR* value);
[ANSI C]
HRESULT IIviDriverIdentity_get_GroupCapabilities(IIviDriverIdentity* This, BSTR* value);
[C#]
public string GroupCapabilities {get;}

Also In This Interface

Description | Revision | Vendor | InstrumentManufacturer | InstrumentModel | InstrumentFirmwareRevision | Identifier | SupportedInstrumentModels | SpecificationMajorVersion | SpecificationMinorVersion | GroupCapabilities | IIviDriverIdentity Overview


Identifier Property

IIviDriverIdentity.Identifier Property

The case-sensitive unique identifier of the implementing IVI-COM instrument driver.

[Visual Basic]
Property Get Identifier() As String
[C++]
HRESULT get_Identifier(BSTR* value);
[ANSI C]
HRESULT IIviDriverIdentity_get_Identifier(IIviDriverIdentity* This, BSTR* value);
[C#]
public string Identifier {get;}

Also In This Interface

Description | Revision | Vendor | InstrumentManufacturer | InstrumentModel | InstrumentFirmwareRevision | Identifier | SupportedInstrumentModels | SpecificationMajorVersion | SpecificationMinorVersion | GroupCapabilities | IIviDriverIdentity Overview


InstrumentFirmwareRevision Property

IIviDriverIdentity.InstrumentFirmwareRevision Property

The firmware revision reported by the physical instrument. If Simulation is enabled or the instrument is not capable of reporting the firmware revision, a string is returned that explains the condition.

[Visual Basic]
Property Get InstrumentFirmwareRevision() As String
[C++]
HRESULT get_InstrumentFirmwareRevision(BSTR* value);
[ANSI C]
HRESULT IIviDriverIdentity_get_InstrumentFirmwareRevision(IIviDriverIdentity* This, BSTR* value);
[C#]
public string InstrumentFirmwareRevision {get;}

Also In This Interface

Description | Revision | Vendor | InstrumentManufacturer | InstrumentModel | InstrumentFirmwareRevision | Identifier | SupportedInstrumentModels | SpecificationMajorVersion | SpecificationMinorVersion | GroupCapabilities | IIviDriverIdentity Overview


InstrumentManufacturer Property

IIviDriverIdentity.InstrumentManufacturer Property

The name of the manufacturer reported by the physical instrument. If Simulation is enabled or the instrument is not capable of reporting the name of the manufacturer, a string is returned that explains the condition. Manufacturer is limited to 256 bytes

[Visual Basic]
Property Get InstrumentManufacturer() As String
[C++]
HRESULT get_InstrumentManufacturer(BSTR* value);
[ANSI C]
HRESULT IIviDriverIdentity_get_InstrumentManufacturer(IIviDriverIdentity* This, BSTR* value);
[C#]
public string InstrumentManufacturer {get;}

Also In This Interface

Description | Revision | Vendor | InstrumentManufacturer | InstrumentModel | InstrumentFirmwareRevision | Identifier | SupportedInstrumentModels | SpecificationMajorVersion | SpecificationMinorVersion | GroupCapabilities | IIviDriverIdentity Overview


InstrumentModel Property

IIviDriverIdentity.InstrumentModel Property

The model number or name reported by the physical instrument. If Simulation is enabled or the instrument is not capable of reporting the model number or name, a string is returned that explains the condition. Model is limited to 256 bytes

[Visual Basic]
Property Get InstrumentModel() As String
[C++]
HRESULT get_InstrumentModel(BSTR* value);
[ANSI C]
HRESULT IIviDriverIdentity_get_InstrumentModel(IIviDriverIdentity* This, BSTR* value);
[C#]
public string InstrumentModel {get;}

Also In This Interface

Description | Revision | Vendor | InstrumentManufacturer | InstrumentModel | InstrumentFirmwareRevision | Identifier | SupportedInstrumentModels | SpecificationMajorVersion | SpecificationMinorVersion | GroupCapabilities | IIviDriverIdentity Overview


Revision Property

IIviDriverIdentity.Revision Property

The revision of the implementing component. Refer to IVI 3.1, Section 3.1.2.2, for a description of revision syntax and semantics. Revision is limited to 256 bytes.

[Visual Basic]
Property Get Revision() As String
[C++]
HRESULT get_Revision(BSTR* value);
[ANSI C]
HRESULT IIviDriverIdentity_get_Revision(IIviDriverIdentity* This, BSTR* value);
[C#]
public string Revision {get;}

Also In This Interface

Description | Revision | Vendor | InstrumentManufacturer | InstrumentModel | InstrumentFirmwareRevision | Identifier | SupportedInstrumentModels | SpecificationMajorVersion | SpecificationMinorVersion | GroupCapabilities | IIviDriverIdentity Overview


SpecificationMajorVersion Property

IIviDriverIdentity.SpecificationMajorVersion Property

For IVI class-compliant drivers, the major version number of the instrument class specification. If the driver is not class compliant, the driver returns zero.

[Visual Basic]
Property Get SpecificationMajorVersion() As Long
[C++]
HRESULT get_SpecificationMajorVersion(long* value);
[ANSI C]
HRESULT IIviDriverIdentity_get_SpecificationMajorVersion(IIviDriverIdentity* This, long* value);
[C#]
public long SpecificationMajorVersion {get;}

Also In This Interface

Description | Revision | Vendor | InstrumentManufacturer | InstrumentModel | InstrumentFirmwareRevision | Identifier | SupportedInstrumentModels | SpecificationMajorVersion | SpecificationMinorVersion | GroupCapabilities | IIviDriverIdentity Overview


SpecificationMinorVersion Property

IIviDriverIdentity.SpecificationMinorVersion Property

For IVI class-compliant drivers, the minor version number of the instrument class specification. If the driver is not class compliant, the driver returns zero.

[Visual Basic]
Property Get SpecificationMinorVersion() As Long
[C++]
HRESULT get_SpecificationMinorVersion(long* value);
[ANSI C]
HRESULT IIviDriverIdentity_get_SpecificationMinorVersion(IIviDriverIdentity* This, long* value);
[C#]
public long SpecificationMinorVersion {get;}

Also In This Interface

Description | Revision | Vendor | InstrumentManufacturer | InstrumentModel | InstrumentFirmwareRevision | Identifier | SupportedInstrumentModels | SpecificationMajorVersion | SpecificationMinorVersion | GroupCapabilities | IIviDriverIdentity Overview


SupportedInstrumentModels Property

IIviDriverIdentity.SupportedInstrumentModels Property

A comma-separated list of instrument models that the IVI specific driver can control. The string does not include an abbreviation for the manufacturer if it is the same for all models.

[Visual Basic]
Property Get SupportedInstrumentModels() As String
[C++]
HRESULT get_SupportedInstrumentModels(BSTR* value);
[ANSI C]
HRESULT IIviDriverIdentity_get_SupportedInstrumentModels(IIviDriverIdentity* This, BSTR* value);
[C#]
public string SupportedInstrumentModels {get;}

Also In This Interface

Description | Revision | Vendor | InstrumentManufacturer | InstrumentModel | InstrumentFirmwareRevision | Identifier | SupportedInstrumentModels | SpecificationMajorVersion | SpecificationMinorVersion | GroupCapabilities | IIviDriverIdentity Overview


Vendor Property

IIviDriverIdentity.Vendor Property

The name of the vendor that supplies the implementing component. Vendor is limited to 256 bytes.

[Visual Basic]
Property Get Vendor() As String
[C++]
HRESULT get_Vendor(BSTR* value);
[ANSI C]
HRESULT IIviDriverIdentity_get_Vendor(IIviDriverIdentity* This, BSTR* value);
[C#]
public string Vendor {get;}

Also In This Interface

Description | Revision | Vendor | InstrumentManufacturer | InstrumentModel | InstrumentFirmwareRevision | Identifier | SupportedInstrumentModels | SpecificationMajorVersion | SpecificationMinorVersion | GroupCapabilities | IIviDriverIdentity Overview


Cache Property

IIviDriverOperation.Cache Property

Drivers may choose to always cache some instrument settings, never cache others, and optionally cache others, to avoid unecessary I/O to the instrument. If True, the driver caches optionally cached instrument settings.

[Visual Basic]
Property Get Cache() As Boolean
Property Let Cache(value As Boolean)
[C++]
HRESULT get_Cache(VARIANT_BOOL* value);
HRESULT put_Cache(VARIANT_BOOL value);
[ANSI C]
HRESULT IIviDriverOperation_get_Cache(IIviDriverOperation* This, VARIANT_BOOL* value);
HRESULT IIviDriverOperation_put_Cache(IIviDriverOperation* This, VARIANT_BOOL value);
[C#]
public bool Cache {get; set;}

Related Items

InvalidateAllAttributes

Also In This Interface

LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


ClearInterchangeWarnings Method

IIviDriverOperation.ClearInterchangeWarnings Method

Clears the list of interchangeability warnings that the IVI specific driver maintains.

[Visual Basic]
Sub ClearInterchangeWarnings()
[C++]
HRESULT ClearInterchangeWarnings();
[ANSI C]
HRESULT IIviDriverOperation_ClearInterchangeWarnings(
   IIviDriverOperation* This);
[C#]
public void ClearInterchangeWarnings();

Related Items

GetNextInterchangeWarning | ResetInterchangeCheck | InterchangeCheck

Also In This Interface

LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


DriverSetup Property

IIviDriverOperation.DriverSetup Property

The driver setup string. It is either specified in the Configuration Store or passed in the OptionString parameter of the Initialize function. Driver setup is empty if the driver is not initialized.

[Visual Basic]
Property Get DriverSetup() As String
[C++]
HRESULT get_DriverSetup(BSTR* value);
[ANSI C]
HRESULT IIviDriverOperation_get_DriverSetup(IIviDriverOperation* This, BSTR* value);
[C#]
public string DriverSetup {get;}

Also In This Interface

LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


GetNextCoercionRecord Method

IIviDriverOperation.GetNextCoercionRecord Method

Returns the oldest record from the coercion record list. Records are only added to the list if RecordCoercions is True.

[Visual Basic]
Function GetNextCoercionRecord() As String
[C++]
HRESULT GetNextCoercionRecord(
   BSTR* CoercionRecord
);
[ANSI C]
HRESULT IIviDriverOperation_GetNextCoercionRecord(
   IIviDriverOperation* This
   BSTR* CoercionRecord
);
[C#]
public string GetNextCoercionRecord();

Parameters

CoercionRecord
The coercion record string shall contain the following information:
  • The name of the attribute that was coerced. This can be the generic name, the COM property name, or the C defined constant.
  • If the attribute is channel-based, the name of the channel. The channel name can be the specific driver channel string or the virtual channel name that the user specified.
  • If the attribute applies to a repeated capability, the name of the repeated capability. The name can be the specific driver repeated capability token or the virtual repeated capability name that the user specified.
  • The value that the user specified for the attribute.
  • The value to which the attribute was coerced.

    • Related Items

    RecordCoercions

    Also In This Interface

    LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


GetNextInterchangeWarning Method

IIviDriverOperation.GetNextInterchangeWarning Method

Returns the oldest warning from the interchange warning list. Records are only added to the list if InterchangeCheck is True.

[Visual Basic]
Function GetNextInterchangeWarning() As String
[C++]
HRESULT GetNextInterchangeWarning(
   BSTR* InterchangeWarning
);
[ANSI C]
HRESULT IIviDriverOperation_GetNextInterchangeWarning(
   IIviDriverOperation* This
   BSTR* InterchangeWarning
);
[C#]
public string GetNextInterchangeWarning();

Parameters

InterchangeWarning
A string describing the oldest interchangeability warning or empty string if no warrnings remain.

Related Items

ClearInterchangeWarnings | ResetInterchangeCheck | InterchangeCheck

Also In This Interface

LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


InterchangeCheck Property

IIviDriverOperation.InterchangeCheck Property

If True, the driver maintains a record of interchangeability warnings. If the driver does not support interchangeability checking, attempts to set InterchangeCheck to True return an error.

[Visual Basic]
Property Get InterchangeCheck() As Boolean
Property Let InterchangeCheck(value As Boolean)
[C++]
HRESULT get_InterchangeCheck(VARIANT_BOOL* value);
HRESULT put_InterchangeCheck(VARIANT_BOOL value);
[ANSI C]
HRESULT IIviDriverOperation_get_InterchangeCheck(IIviDriverOperation* This, VARIANT_BOOL* value);
HRESULT IIviDriverOperation_put_InterchangeCheck(IIviDriverOperation* This, VARIANT_BOOL value);
[C#]
public bool InterchangeCheck {get; set;}

Related Items

ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck

Also In This Interface

LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


InvalidateAllAttributes Method

IIviDriverOperation.InvalidateAllAttributes Method

Invalidates all of the driver's cached values.

[Visual Basic]
Sub InvalidateAllAttributes()
[C++]
HRESULT InvalidateAllAttributes();
[ANSI C]
HRESULT IIviDriverOperation_InvalidateAllAttributes(
   IIviDriverOperation* This);
[C#]
public void InvalidateAllAttributes();

Related Items

Cache

Also In This Interface

LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


IoResourceDescriptor Property

IIviDriverOperation.IoResourceDescriptor Property

The resource descriptor specifies the connection to a physical device. It is either specified in the Configuration Store or passed in the ResourceName parameter of the Initialize function. It is empty if the driver is not initialized.

[Visual Basic]
Property Get IoResourceDescriptor() As String
[C++]
HRESULT get_IoResourceDescriptor(BSTR* value);
[ANSI C]
HRESULT IIviDriverOperation_get_IoResourceDescriptor(IIviDriverOperation* This, BSTR* value);
[C#]
public string IoResourceDescriptor {get;}

Also In This Interface

LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


LogicalName Property

IIviDriverOperation.LogicalName Property

Logical Name identifies a driver session in the Configuration Store. If Logical Name is not empty, the driver was initialized from information in the driver session. If it is empty, the driver was initialized without using the Configuration Store.

[Visual Basic]
Property Get LogicalName() As String
[C++]
HRESULT get_LogicalName(BSTR* value);
[ANSI C]
HRESULT IIviDriverOperation_get_LogicalName(IIviDriverOperation* This, BSTR* value);
[C#]
public string LogicalName {get;}

Also In This Interface

LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


QueryInstrumentStatus Property

IIviDriverOperation.QueryInstrumentStatus Property

If True, the driver queries the instrument status at the end of each method or property that performs I/O to the instrument. If an error is reported, use ErrorQuery to retrieve error messages one at a time from the instrument.

[Visual Basic]
Property Get QueryInstrumentStatus() As Boolean
Property Let QueryInstrumentStatus(value As Boolean)
[C++]
HRESULT get_QueryInstrumentStatus(VARIANT_BOOL* value);
HRESULT put_QueryInstrumentStatus(VARIANT_BOOL value);
[ANSI C]
HRESULT IIviDriverOperation_get_QueryInstrumentStatus(IIviDriverOperation* This, VARIANT_BOOL* value);
HRESULT IIviDriverOperation_put_QueryInstrumentStatus(IIviDriverOperation* This, VARIANT_BOOL value);
[C#]
public bool QueryInstrumentStatus {get; set;}

Also In This Interface

LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


RangeCheck Property

IIviDriverOperation.RangeCheck Property

Drivers may choose to always validate some property/parameter values, never validate others, and optionally validate others, to avoid sending invalid commands to the instrument. If True, the driver performs optional validations.

[Visual Basic]
Property Get RangeCheck() As Boolean
Property Let RangeCheck(value As Boolean)
[C++]
HRESULT get_RangeCheck(VARIANT_BOOL* value);
HRESULT put_RangeCheck(VARIANT_BOOL value);
[ANSI C]
HRESULT IIviDriverOperation_get_RangeCheck(IIviDriverOperation* This, VARIANT_BOOL* value);
HRESULT IIviDriverOperation_put_RangeCheck(IIviDriverOperation* This, VARIANT_BOOL value);
[C#]
public bool RangeCheck {get; set;}

Also In This Interface

LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


RecordCoercions Property

IIviDriverOperation.RecordCoercions Property

If True, the driver keeps a list of the value coercions it makes for ViInt32 and ViReal64 attributes. If the driver does not support coercion recording, attempts to set RecordCoercions to True will return an error.

[Visual Basic]
Property Get RecordCoercions() As Boolean
Property Let RecordCoercions(value As Boolean)
[C++]
HRESULT get_RecordCoercions(VARIANT_BOOL* value);
HRESULT put_RecordCoercions(VARIANT_BOOL value);
[ANSI C]
HRESULT IIviDriverOperation_get_RecordCoercions(IIviDriverOperation* This, VARIANT_BOOL* value);
HRESULT IIviDriverOperation_put_RecordCoercions(IIviDriverOperation* This, VARIANT_BOOL value);
[C#]
public bool RecordCoercions {get; set;}

Related Items

GetNextCoercionRecord

Also In This Interface

LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


ResetInterchangeCheck Method

IIviDriverOperation.ResetInterchangeCheck Method

Resets the interchangeability checking algorithms of the driver so that methods and properties that executed prior to calling this function have no affect on whether future calls to the driver generate interchangeability warnings.

[Visual Basic]
Sub ResetInterchangeCheck()
[C++]
HRESULT ResetInterchangeCheck();
[ANSI C]
HRESULT IIviDriverOperation_ResetInterchangeCheck(
   IIviDriverOperation* This);
[C#]
public void ResetInterchangeCheck();

Related Items

GetNextInterchangeWarning | ClearInterchangeWarnings | InterchangeCheck

Also In This Interface

LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


Simulate Property

IIviDriverOperation.Simulate Property

If True, the driver does not perform I/O to the instrument, and returns simulated values for output parameters.

[Visual Basic]
Property Get Simulate() As Boolean
Property Let Simulate(value As Boolean)
[C++]
HRESULT get_Simulate(VARIANT_BOOL* value);
HRESULT put_Simulate(VARIANT_BOOL value);
[ANSI C]
HRESULT IIviDriverOperation_get_Simulate(IIviDriverOperation* This, VARIANT_BOOL* value);
HRESULT IIviDriverOperation_put_Simulate(IIviDriverOperation* This, VARIANT_BOOL value);
[C#]
public bool Simulate {get; set;}

Also In This Interface

LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


Disable Method

IIviDriverUtility.Disable Method

Quickly places the instrument in a state where it has no, or minimal, effect on the external system to which it is connected. This state is not necessarily a known state.

[Visual Basic]
Sub Disable()
[C++]
HRESULT Disable();
[ANSI C]
HRESULT IIviDriverUtility_Disable(
   IIviDriverUtility* This);
[C#]
public void Disable();

Also In This Interface

Reset | ResetWithDefaults | Disable | SelfTest | ErrorQuery | LockObject | UnlockObject | IIviDriverUtility Overview


ErrorQuery Method

IIviDriverUtility.ErrorQuery Method

Queries the instrument and returns instrument specific error information. This function can be used when QueryInstrumentStatus is True to retrieve error details when the driver detects an instrument error.

[Visual Basic]
Sub ErrorQuery( _
   ErrorCode As Long, _
   ErrorMessage As String _
)
[C++]
HRESULT ErrorQuery(
   long* ErrorCode,
   BSTR* ErrorMessage
);
[ANSI C]
HRESULT IIviDriverUtility_ErrorQuery(
   IIviDriverUtility* This
   long* ErrorCode,
   BSTR* ErrorMessage
);
[C#]
public void ErrorQuery(
   long ErrorCode,
   string ErrorMessage
);

Parameters

ErrorCode
Instrument error code
ErrorMessage
Instrument error message

Also In This Interface

Reset | ResetWithDefaults | Disable | SelfTest | ErrorQuery | LockObject | UnlockObject | IIviDriverUtility Overview


LockObject Method

IIviDriverUtility.LockObject Method

Obtains a multithread lock on the driver after waiting until all other execution threads have released their locks on the instrument session.

[Visual Basic]
Sub LockObject()
[C++]
HRESULT LockObject();
[ANSI C]
HRESULT IIviDriverUtility_LockObject(
   IIviDriverUtility* This);
[C#]
public void LockObject();

Related Items

UnlockObject

Also In This Interface

Reset | ResetWithDefaults | Disable | SelfTest | ErrorQuery | LockObject | UnlockObject | IIviDriverUtility Overview


Reset Method

IIviDriverUtility.Reset Method

Places the instrument in a known state and configures instrument options on which the IVI specific driver depends (for example, enabling/disabling headers). For an IEEE 488.2 instrument, Reset sends the command string *RST to the instrument.

[Visual Basic]
Sub Reset()
[C++]
HRESULT Reset();
[ANSI C]
HRESULT IIviDriverUtility_Reset(
   IIviDriverUtility* This);
[C#]
public void Reset();

Related Items

ResetWithDefaults

Also In This Interface

Reset | ResetWithDefaults | Disable | SelfTest | ErrorQuery | LockObject | UnlockObject | IIviDriverUtility Overview


ResetWithDefaults Method

IIviDriverUtility.ResetWithDefaults Method

Does the equivalent of Reset and then, (1) disables class extension capability groups, (2) sets attributes to initial values defined by class specs, and (3) configures the driver to option string settings used when Initialize was last executed.

[Visual Basic]
Sub ResetWithDefaults()
[C++]
HRESULT ResetWithDefaults();
[ANSI C]
HRESULT IIviDriverUtility_ResetWithDefaults(
   IIviDriverUtility* This);
[C#]
public void ResetWithDefaults();

Also In This Interface

Reset | ResetWithDefaults | Disable | SelfTest | ErrorQuery | LockObject | UnlockObject | IIviDriverUtility Overview


SelfTest Method

IIviDriverUtility.SelfTest Method

Performs an instrument self test, waits for the instrument to complete the test, and queries the instrument for the results. If the instrument passes the test, TestResult is zero and TestMessage is 'Self test passed'.

[Visual Basic]
Sub SelfTest( _
   TestResult As Long, _
   TestMessage As String _
)
[C++]
HRESULT SelfTest(
   long* TestResult,
   BSTR* TestMessage
);
[ANSI C]
HRESULT IIviDriverUtility_SelfTest(
   IIviDriverUtility* This
   long* TestResult,
   BSTR* TestMessage
);
[C#]
public void SelfTest(
   long TestResult,
   string TestMessage
);

Parameters

TestResult
The numeric result from the self test operation. 0 = no error (test passed)
TestMessage
The self test status message

Also In This Interface

Reset | ResetWithDefaults | Disable | SelfTest | ErrorQuery | LockObject | UnlockObject | IIviDriverUtility Overview


UnlockObject Method

IIviDriverUtility.UnlockObject Method

Releases a previously obtained mutlithread lock.

[Visual Basic]
Sub UnlockObject()
[C++]
HRESULT UnlockObject();
[ANSI C]
HRESULT IIviDriverUtility_UnlockObject(
   IIviDriverUtility* This);
[C#]
public void UnlockObject();

Related Items

LockObject

Also In This Interface

Reset | ResetWithDefaults | Disable | SelfTest | ErrorQuery | LockObject | UnlockObject | IIviDriverUtility Overview