IviFgen Reference

© 2003 IVI Foundation

Welcome to the IviFgen Class-Compliant Interface Reference

This section contains the reference material for the IviFgen class-compliant interface.

This help hierarchy matches the COM hierarchy defined in the IviFgen class specification, available on the IVI Foundation Web Site. The COM hierarchy groups related capabilities into common interfaces. These interfaces often include both IviFgen base and extension capabilities. To help users distinguish between base and extension capabilities, the Capability Group section of each method or property topic lists which of the IviFgen Capability Groups the method or property belongs to.

Since IVI class-compliant specific drivers are not required to support all extension groups, users should refer to the compliance documentation for the particular driver being used to determine if an extension group is supported before using capabilities in that group.

IVI class-compliant specific drivers may have small differences in the way a particular extension group method or property is implemented. For instance, a driver might implement only one of several IVI-defined values for an extension group attribute. Refer to the help documentation provided with the IVI class-compliant specific driver for detailed information about implementation.


Inherent Interface

IviFgen Capability Groups

Capability Group | Description
IviFgenBase | Base capabilities of the IviFgen specification. This group supports the ability to configure basic signal generation properties like output impedance and the reference clock source.
IviFgenStdFunc | Supports IviFgenBase capabilities and has the ability to generate standard periodic waveforms
IviFgenArbWfm | Supports IviFgenBase capabilities and has the ability to create and generate user-defined arbitrary waveforms.
IviFgenArbFrequency | Supports the IviFgenArbWfm extension and has the ability to specify the rate at which the function generator produces one cycle of an arbitrary waveform on a channel.
IviFgenArbSeq | Supports the IviFgenArbWfm extension and has the ability to create and generate sequences of user-defined arbitrary waveforms.
IviFgenTrigger | Supports IviFgenBase capabilities and has the ability to specify the source of trigger signals.
IviFgenInternalTrigger | Supports the IviFgenTrigger capabilities and has the ability to generate triggers internally.
IviFgenSoftwareTrigger | Supports the IviFgenTrigger capabilities and has the ability to receive software triggers.
IviFgenBurst | Supports IviFgenBase capabilities and has the ability to generate discrete numbers of waveform cycles based on a trigger event.
IviFgenModulateAM | Supports IviFgenBase capabilities and has the ability to apply amplitude modulation to an output signal.
IviFgenModulateFM | Supports IviFgenBase capabilities and has the ability to apply frequency modulation to an output signal.


Inherent Interface

IviFgen Instrument Class Interfaces

IIviFgen | IVI FGen class-compliant root interface
IIviFgenAM | IVI FGen class-compliant AM interface
IIviFgenArbitrary | IVI FGen class-compliant arbitrary sequence and waveform common interface
IIviFgenArbitrarySequence | IVI FGen class-compliant arbitrary sequence interface
IIviFgenArbitraryWaveform | IVI FGen class-compliant arbitrary waveform interface
IIviFgenFM | IVI FGen class-compliant FM interface
IIviFgenOutput | IVI FGen class-compliant output interface
IIviFgenStandardWaveform | IVI FGen class-compliant standard waveform interface
IIviFgenTrigger | IVI FGen class-compliant trigger interface


IIviFgen Interface

IVI FGen class-compliant root interface

Methods

Initialize | Opens the I/O session to the instrument. Driver methods and properties that access the instrument are only accessible after Initialize is called. Initialize optionally performs a Reset and queries the instrument to validate the instrument model.
Close | Closes the I/O session to the instrument. Driver methods and properties that access the instrument are not accessible after Close is called.
InitiateGeneration | If the function generator is in the Configuration State, this function moves the function generator to the Output Generation State. If the function generator is already in the Output Generation State, this function does nothing and returns Success.
AbortGeneration | If the function generator is in the Output Generation State, this function moves the function generator to the Configuration State. If the function generator is already in the Configuration State, the function does nothing and returns Success.

Properties

DriverOperation | Pointer to the IIviDriverOperation interface
Identity | Pointer to the IIviDriverIdentity interface
Utility | Pointer to the IIviDriverUtility interface
Initialized | Initialized is True between a successful call to the Initialize method and a successful call to the Close method, and False at all other times.
Output | Reference to the class-compliant IIviFGenOutput interface
Trigger | Reference to the class-compliant IIviFGenTrigger interface
StandardWaveform | Reference to the class-compliant IIviFGenStandardWaveform interface
Arbitrary | Reference to the class-compliant IIviFGenArbitrary interface
AM | Reference to the class-compliant IIviFGenAM interface
FM | Reference to the class-compliant IIviFGenFM interface


DriverOperation Property

IIviFgen.DriverOperation Property

Pointer to the IIviDriverOperation interface

[Visual Basic]
Property Get DriverOperation() As IIviDriverOperation
[C++]
HRESULT get_DriverOperation(IIviDriverOperation** value);
[ANSI C]
HRESULT IIviFgen_get_DriverOperation(IIviFgen* This, IIviDriverOperation** value);
[C#]
public IIviDriverOperation DriverOperation {get;}

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Output | Trigger | StandardWaveform | Arbitrary | AM | FM | Initialize | Close | InitiateGeneration | AbortGeneration | IIviFgen Overview


Identity Property

IIviFgen.Identity Property

Pointer to the IIviDriverIdentity interface

[Visual Basic]
Property Get Identity() As IIviDriverIdentity
[C++]
HRESULT get_Identity(IIviDriverIdentity** value);
[ANSI C]
HRESULT IIviFgen_get_Identity(IIviFgen* This, IIviDriverIdentity** value);
[C#]
public IIviDriverIdentity Identity {get;}

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Output | Trigger | StandardWaveform | Arbitrary | AM | FM | Initialize | Close | InitiateGeneration | AbortGeneration | IIviFgen Overview


Utility Property

IIviFgen.Utility Property

Pointer to the IIviDriverUtility interface

[Visual Basic]
Property Get Utility() As IIviDriverUtility
[C++]
HRESULT get_Utility(IIviDriverUtility** value);
[ANSI C]
HRESULT IIviFgen_get_Utility(IIviFgen* This, IIviDriverUtility** value);
[C#]
public IIviDriverUtility Utility {get;}

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Output | Trigger | StandardWaveform | Arbitrary | AM | FM | Initialize | Close | InitiateGeneration | AbortGeneration | IIviFgen Overview


Initialized Property

IIviFgen.Initialized Property

Initialized is True between a successful call to the Initialize method and a successful call to the Close method, and False at all other times.

[Visual Basic]
Property Get Initialized() As Boolean
[C++]
HRESULT get_Initialized(VARIANT_BOOL* value);
[ANSI C]
HRESULT IIviFgen_get_Initialized(IIviFgen* This, VARIANT_BOOL* value);
[C#]
public bool Initialized {get;}

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Output | Trigger | StandardWaveform | Arbitrary | AM | FM | Initialize | Close | InitiateGeneration | AbortGeneration | IIviFgen Overview


Output Property

IIviFgen.Output Property

Reference to the class-compliant IIviFGenOutput interface

[Visual Basic]
Property Get Output() As IIviFgenOutput
[C++]
HRESULT get_Output(IIviFgenOutput** value);
[ANSI C]
HRESULT IIviFgen_get_Output(IIviFgen* This, IIviFgenOutput** value);
[C#]
public IIviFgenOutput Output {get;}

Capability Group

IviFgenBase

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Output | Trigger | StandardWaveform | Arbitrary | AM | FM | Initialize | Close | InitiateGeneration | AbortGeneration | IIviFgen Overview


Trigger Property

IIviFgen.Trigger Property

Reference to the class-compliant IIviFGenTrigger interface

[Visual Basic]
Property Get Trigger() As IIviFgenTrigger
[C++]
HRESULT get_Trigger(IIviFgenTrigger** value);
[ANSI C]
HRESULT IIviFgen_get_Trigger(IIviFgen* This, IIviFgenTrigger** value);
[C#]
public IIviFgenTrigger Trigger {get;}

Capability Group

IviFgenTrigger, IviFgenInternalTrigger, IviFgenSoftwareTrigger, IviFgenBurst

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Output | Trigger | StandardWaveform | Arbitrary | AM | FM | Initialize | Close | InitiateGeneration | AbortGeneration | IIviFgen Overview


StandardWaveform Property

IIviFgen.StandardWaveform Property

Reference to the class-compliant IIviFGenStandardWaveform interface

[Visual Basic]
Property Get StandardWaveform() As IIviFgenStandardWaveform
[C++]
HRESULT get_StandardWaveform(IIviFgenStandardWaveform** value);
[ANSI C]
HRESULT IIviFgen_get_StandardWaveform(IIviFgen* This, IIviFgenStandardWaveform** value);
[C#]
public IIviFgenStandardWaveform StandardWaveform {get;}

Capability Group

IviFgenStdFunc

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Output | Trigger | StandardWaveform | Arbitrary | AM | FM | Initialize | Close | InitiateGeneration | AbortGeneration | IIviFgen Overview


Arbitrary Property

IIviFgen.Arbitrary Property

Reference to the class-compliant IIviFGenArbitrary interface

[Visual Basic]
Property Get Arbitrary() As IIviFgenArbitrary
[C++]
HRESULT get_Arbitrary(IIviFgenArbitrary** value);
[ANSI C]
HRESULT IIviFgen_get_Arbitrary(IIviFgen* This, IIviFgenArbitrary** value);
[C#]
public IIviFgenArbitrary Arbitrary {get;}

Capability Group

IviFgenArbSeq, IviFgenArbWfm, IviFgenArbFrequency

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Output | Trigger | StandardWaveform | Arbitrary | AM | FM | Initialize | Close | InitiateGeneration | AbortGeneration | IIviFgen Overview


AM Property

IIviFgen.AM Property

Reference to the class-compliant IIviFGenAM interface

[Visual Basic]
Property Get AM() As IIviFgenAM
[C++]
HRESULT get_AM(IIviFgenAM** value);
[ANSI C]
HRESULT IIviFgen_get_AM(IIviFgen* This, IIviFgenAM** value);
[C#]
public IIviFgenAM AM {get;}

Capability Group

IviFgenModulateAM

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Output | Trigger | StandardWaveform | Arbitrary | AM | FM | Initialize | Close | InitiateGeneration | AbortGeneration | IIviFgen Overview


FM Property

IIviFgen.FM Property

Reference to the class-compliant IIviFGenFM interface

[Visual Basic]
Property Get FM() As IIviFgenFM
[C++]
HRESULT get_FM(IIviFgenFM** value);
[ANSI C]
HRESULT IIviFgen_get_FM(IIviFgen* This, IIviFgenFM** value);
[C#]
public IIviFgenFM FM {get;}

Capability Group

IviFgenModulateFM

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Output | Trigger | StandardWaveform | Arbitrary | AM | FM | Initialize | Close | InitiateGeneration | AbortGeneration | IIviFgen Overview


Initialize Method

IIviFgen.Initialize Method

Opens the I/O session to the instrument. Driver methods and properties that access the instrument are only accessible after Initialize is called. Initialize optionally performs a Reset and queries the instrument to validate the instrument model.

[Visual Basic]
Sub Initialize( _
   ResourceName As String, _
   IdQuery As Boolean, _
   Reset As Boolean, _
   OptionString As String _
)
[C++]
HRESULT Initialize(
   BSTR ResourceName,
   VARIANT_BOOL IdQuery,
   VARIANT_BOOL Reset,
   BSTR OptionString
);
[ANSI C]
HRESULT IIviFgen_Initialize(
   IIviFgen* This
   BSTR ResourceName,
   VARIANT_BOOL IdQuery,
   VARIANT_BOOL Reset,
   BSTR OptionString
);
[C#]
public void Initialize(
   string ResourceName,
   bool IdQuery,
   bool Reset,
   string OptionString
);

Parameters

ResourceName
An IVI logical name or an instrument specific string that identifies the address of the instrument, such as a VISA resource descriptor string.
IdQuery
Specifies whether to verify the ID of the instrument.
Reset
Specifies whether to reset the instrument.
OptionString
The user can use the OptionsString parameter to specify the initial values of certain IVI inherent attributes for the session.

Related Items

Close

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Output | Trigger | StandardWaveform | Arbitrary | AM | FM | Initialize | Close | InitiateGeneration | AbortGeneration | IIviFgen Overview


Close Method

IIviFgen.Close Method

Closes the I/O session to the instrument. Driver methods and properties that access the instrument are not accessible after Close is called.

[Visual Basic]
Sub Close()
[C++]
HRESULT Close();
[ANSI C]
HRESULT IIviFgen_Close(
   IIviFgen* This);
[C#]
public void Close();

Related Items

Initialize

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Output | Trigger | StandardWaveform | Arbitrary | AM | FM | Initialize | Close | InitiateGeneration | AbortGeneration | IIviFgen Overview


InitiateGeneration Method

IIviFgen.InitiateGeneration Method

If the function generator is in the Configuration State, this function moves the function generator to the Output Generation State. If the function generator is already in the Output Generation State, this function does nothing and returns Success.

[Visual Basic]
Sub InitiateGeneration()
[C++]
HRESULT InitiateGeneration();
[ANSI C]
HRESULT IIviFgen_InitiateGeneration(
   IIviFgen* This);
[C#]
public void InitiateGeneration();

Capability Group

IviFgenBase

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Output | Trigger | StandardWaveform | Arbitrary | AM | FM | Initialize | Close | InitiateGeneration | AbortGeneration | IIviFgen Overview


AbortGeneration Method

IIviFgen.AbortGeneration Method

If the function generator is in the Output Generation State, this function moves the function generator to the Configuration State. If the function generator is already in the Configuration State, the function does nothing and returns Success.

[Visual Basic]
Sub AbortGeneration()
[C++]
HRESULT AbortGeneration();
[ANSI C]
HRESULT IIviFgen_AbortGeneration(
   IIviFgen* This);
[C#]
public void AbortGeneration();

Capability Group

IviFgenBase

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Output | Trigger | StandardWaveform | Arbitrary | AM | FM | Initialize | Close | InitiateGeneration | AbortGeneration | IIviFgen Overview


IIviFgenAM Interface

IVI FGen class-compliant AM interface

Methods

ConfigureInternal Configures the attributes that control the function generator's internal amplitude modulating waveform source.

Properties

Enabled | If true, the function generator applies amplitude modulation to the signal that the function generator produces.
Source | The source of the signal that the function generator uses as the modulating waveform. Applies only when the AM Enabled attribute is set to True.
InternalDepth | The extent of modulation the function generator applies to the carrier waveform when the AM Source attribute is set to AM Internal. The unit is percentage. Applies only when the AM Source attribute is set to AM Internal.
InternalFrequency | The frequency of the internal modulating waveform source. The units are Hertz. Applies only when the AM Source attribute is set to AM Internal.
InternalWaveform | The waveform of the internal modulating waveform source. Applies only when the AM Source attribute is set to AM Internal.


Enabled Property

IIviFgenAM.Enabled Property

If true, the function generator applies amplitude modulation to the signal that the function generator produces.

[Visual Basic]
Property Get Enabled(ChannelName As String) As Boolean
Property Let Enabled(ChannelName As Stringvalue As Boolean)
[C++]
HRESULT get_Enabled(BSTR ChannelName, VARIANT_BOOL* value);
HRESULT put_Enabled(BSTR ChannelName, VARIANT_BOOL value);
[ANSI C]
HRESULT IIviFgenAM_get_Enabled(IIviFgenAM* This, BSTR ChannelName, VARIANT_BOOL* value);
HRESULT IIviFgenAM_put_Enabled(IIviFgenAM* This, BSTR ChannelName, VARIANT_BOOL value);
[C#]HRESULT get_Enabled(string ChannelName, bool value);
HRESULT put_Enabled(string ChannelName, bool value);

Parameters

ChannelName
The ChannelName parameter may be a string defined by the driver or supplied as a virtual name in the configuration store. For single output instruments, the driver may define the empty string as valid ChannelName.

Capability Group

IviFgenModulateAM

Also In This Interface

Enabled | Source | InternalDepth | InternalFrequency | InternalWaveform | ConfigureInternal | IIviFgenAM Overview


Source Property

IIviFgenAM.Source Property

The source of the signal that the function generator uses as the modulating waveform. Applies only when the AM Enabled attribute is set to True.

[Visual Basic]
Property Get Source(ChannelName As String) As IviFgenAMSourceEnum
Property Let Source(ChannelName As Stringvalue As IviFgenAMSourceEnum)
[C++]
HRESULT get_Source(BSTR ChannelName, IviFgenAMSourceEnum* value);
HRESULT put_Source(BSTR ChannelName, IviFgenAMSourceEnum value);
[ANSI C]
HRESULT IIviFgenAM_get_Source(IIviFgenAM* This, BSTR ChannelName, IviFgenAMSourceEnum* value);
HRESULT IIviFgenAM_put_Source(IIviFgenAM* This, BSTR ChannelName, IviFgenAMSourceEnum value);
[C#]HRESULT get_Source(string ChannelName, IviFgenAMSourceEnum value);
HRESULT put_Source(string ChannelName, IviFgenAMSourceEnum value);

Parameters

ChannelName
The ChannelName parameter may be a string defined by the driver or supplied as a virtual name in the configuration store. For single output instruments, the driver may define the empty string as valid ChannelName.

Capability Group

IviFgenModulateAM

Also In This Interface

Enabled | Source | InternalDepth | InternalFrequency | InternalWaveform | ConfigureInternal | IIviFgenAM Overview


InternalDepth Property

IIviFgenAM.InternalDepth Property

The extent of modulation the function generator applies to the carrier waveform when the AM Source attribute is set to AM Internal. The unit is percentage. Applies only when the AM Source attribute is set to AM Internal.

[Visual Basic]
Property Get InternalDepth() As Double
Property Let InternalDepth(value As Double)
[C++]
HRESULT get_InternalDepth(double* value);
HRESULT put_InternalDepth(double value);
[ANSI C]
HRESULT IIviFgenAM_get_InternalDepth(IIviFgenAM* This, double* value);
HRESULT IIviFgenAM_put_InternalDepth(IIviFgenAM* This, double value);
[C#]
public double InternalDepth {get; set;}

Capability Group

IviFgenModulateAM

Related Items

ConfigureInternal

Also In This Interface

Enabled | Source | InternalDepth | InternalFrequency | InternalWaveform | ConfigureInternal | IIviFgenAM Overview


InternalFrequency Property

IIviFgenAM.InternalFrequency Property

The frequency of the internal modulating waveform source. The units are Hertz. Applies only when the AM Source attribute is set to AM Internal.

[Visual Basic]
Property Get InternalFrequency() As Double
Property Let InternalFrequency(value As Double)
[C++]
HRESULT get_InternalFrequency(double* value);
HRESULT put_InternalFrequency(double value);
[ANSI C]
HRESULT IIviFgenAM_get_InternalFrequency(IIviFgenAM* This, double* value);
HRESULT IIviFgenAM_put_InternalFrequency(IIviFgenAM* This, double value);
[C#]
public double InternalFrequency {get; set;}

Capability Group

IviFgenModulateAM

Related Items

ConfigureInternal

Also In This Interface

Enabled | Source | InternalDepth | InternalFrequency | InternalWaveform | ConfigureInternal | IIviFgenAM Overview


InternalWaveform Property

IIviFgenAM.InternalWaveform Property

The waveform of the internal modulating waveform source. Applies only when the AM Source attribute is set to AM Internal.

[Visual Basic]
Property Get InternalWaveform() As IviFgenAMInternalWaveformEnum
Property Let InternalWaveform(value As IviFgenAMInternalWaveformEnum)
[C++]
HRESULT get_InternalWaveform(IviFgenAMInternalWaveformEnum* value);
HRESULT put_InternalWaveform(IviFgenAMInternalWaveformEnum value);
[ANSI C]
HRESULT IIviFgenAM_get_InternalWaveform(IIviFgenAM* This, IviFgenAMInternalWaveformEnum* value);
HRESULT IIviFgenAM_put_InternalWaveform(IIviFgenAM* This, IviFgenAMInternalWaveformEnum value);
[C#]
public IviFgenAMInternalWaveformEnum InternalWaveform {get; set;}

Capability Group

IviFgenModulateAM

Related Items

ConfigureInternal

Also In This Interface

Enabled | Source | InternalDepth | InternalFrequency | InternalWaveform | ConfigureInternal | IIviFgenAM Overview


ConfigureInternal Method

IIviFgenAM.ConfigureInternal Method

Configures the attributes that control the function generator's internal amplitude modulating waveform source.

[Visual Basic]
Sub ConfigureInternal( _
   Depth As Double, _
   Waveform As IviFgenAMInternalWaveformEnum, _
   Frequency As Double _
)
[C++]
HRESULT ConfigureInternal(
   double Depth,
   IviFgenAMInternalWaveformEnum Waveform,
   double Frequency
);
[ANSI C]
HRESULT IIviFgenAM_ConfigureInternal(
   IIviFgenAM* This
   double Depth,
   IviFgenAMInternalWaveformEnum Waveform,
   double Frequency
);
[C#]
public void ConfigureInternal(
   double Depth,
   IviFgenAMInternalWaveformEnum Waveform,
   double Frequency
);

Parameters

Depth
Specifies the internal modulation depth. This value sets the AM Internal Depth property.
Waveform
Specifies the waveform the function generator uses for the internal modulating waveform source. This value sets the AM Internal Waveform property.
Frequency
Specifies the frequency of the internal modulating waveform source. This value sets the AM Internal Frequency property.

Capability Group

IviFgenModulateAM

Related Items

InternalDepth | InternalWaveform | InternalFrequency

Also In This Interface

Enabled | Source | InternalDepth | InternalFrequency | InternalWaveform | ConfigureInternal | IIviFgenAM Overview


IIviFgenArbitrary Interface

IVI FGen class-compliant arbitrary sequence and waveform common interface

Methods

ClearMemory Removes all previously created arbitrary waveforms and sequences from the function generator's memory and invalidates all waveform and sequence handles.

Properties

Gain | The gain of the arbitrary waveform the function generator produces. This value is unitless.
Offset | The offset of the arbitrary waveform the function generator produces. The units are volts.
SampleRate | The sample rate of the arbitrary waveforms the function generator produces. The units are samples per second.
Sequence | Reference to the class-compliant IIviFGenArbitrarySequence interface
Waveform | Reference to the class-compliant IIviFGenArbitraryWaveform interface


Gain Property

IIviFgenArbitrary.Gain Property

The gain of the arbitrary waveform the function generator produces. This value is unitless.

[Visual Basic]
Property Get Gain(ChannelName As String) As Double
Property Let Gain(ChannelName As Stringvalue As Double)
[C++]
HRESULT get_Gain(BSTR ChannelName, double* value);
HRESULT put_Gain(BSTR ChannelName, double value);
[ANSI C]
HRESULT IIviFgenArbitrary_get_Gain(IIviFgenArbitrary* This, BSTR ChannelName, double* value);
HRESULT IIviFgenArbitrary_put_Gain(IIviFgenArbitrary* This, BSTR ChannelName, double value);
[C#]HRESULT get_Gain(string ChannelName, double value);
HRESULT put_Gain(string ChannelName, double value);

Parameters

ChannelName
The ChannelName parameter may be a string defined by the driver or supplied as a virtual name in the configuration store. For single output instruments, the driver may define the empty string as valid ChannelName.

Capability Group

IviFgenArbWfm

Also In This Interface

Gain | Offset | SampleRate | Sequence | Waveform | ClearMemory | IIviFgenArbitrary Overview


Offset Property

IIviFgenArbitrary.Offset Property

The offset of the arbitrary waveform the function generator produces. The units are volts.

[Visual Basic]
Property Get Offset(ChannelName As String) As Double
Property Let Offset(ChannelName As Stringvalue As Double)
[C++]
HRESULT get_Offset(BSTR ChannelName, double* value);
HRESULT put_Offset(BSTR ChannelName, double value);
[ANSI C]
HRESULT IIviFgenArbitrary_get_Offset(IIviFgenArbitrary* This, BSTR ChannelName, double* value);
HRESULT IIviFgenArbitrary_put_Offset(IIviFgenArbitrary* This, BSTR ChannelName, double value);
[C#]HRESULT get_Offset(string ChannelName, double value);
HRESULT put_Offset(string ChannelName, double value);

Parameters

ChannelName
The ChannelName parameter may be a string defined by the driver or supplied as a virtual name in the configuration store. For single output instruments, the driver may define the empty string as valid ChannelName.

Capability Group

IviFgenArbWfm

Also In This Interface

Gain | Offset | SampleRate | Sequence | Waveform | ClearMemory | IIviFgenArbitrary Overview


SampleRate Property

IIviFgenArbitrary.SampleRate Property

The sample rate of the arbitrary waveforms the function generator produces. The units are samples per second.

[Visual Basic]
Property Get SampleRate() As Double
Property Let SampleRate(value As Double)
[C++]
HRESULT get_SampleRate(double* value);
HRESULT put_SampleRate(double value);
[ANSI C]
HRESULT IIviFgenArbitrary_get_SampleRate(IIviFgenArbitrary* This, double* value);
HRESULT IIviFgenArbitrary_put_SampleRate(IIviFgenArbitrary* This, double value);
[C#]
public double SampleRate {get; set;}

Capability Group

IviFgenArbWfm

Also In This Interface

Gain | Offset | SampleRate | Sequence | Waveform | ClearMemory | IIviFgenArbitrary Overview


Sequence Property

IIviFgenArbitrary.Sequence Property

Reference to the class-compliant IIviFGenArbitrarySequence interface

[Visual Basic]
Property Get Sequence() As IIviFgenArbitrarySequence
[C++]
HRESULT get_Sequence(IIviFgenArbitrarySequence** value);
[ANSI C]
HRESULT IIviFgenArbitrary_get_Sequence(IIviFgenArbitrary* This, IIviFgenArbitrarySequence** value);
[C#]
public IIviFgenArbitrarySequence Sequence {get;}

Capability Group

IviFgenArbSeq

Also In This Interface

Gain | Offset | SampleRate | Sequence | Waveform | ClearMemory | IIviFgenArbitrary Overview


Waveform Property

IIviFgenArbitrary.Waveform Property

Reference to the class-compliant IIviFGenArbitraryWaveform interface

[Visual Basic]
Property Get Waveform() As IIviFgenArbitraryWaveform
[C++]
HRESULT get_Waveform(IIviFgenArbitraryWaveform** value);
[ANSI C]
HRESULT IIviFgenArbitrary_get_Waveform(IIviFgenArbitrary* This, IIviFgenArbitraryWaveform** value);
[C#]
public IIviFgenArbitraryWaveform Waveform {get;}

Capability Group

IviFgenArbWfm, IviFgenArbFrequency

Also In This Interface

Gain | Offset | SampleRate | Sequence | Waveform | ClearMemory | IIviFgenArbitrary Overview


ClearMemory Method

IIviFgenArbitrary.ClearMemory Method

Removes all previously created arbitrary waveforms and sequences from the function generator's memory and invalidates all waveform and sequence handles.

[Visual Basic]
Sub ClearMemory()
[C++]
HRESULT ClearMemory();
[ANSI C]
HRESULT IIviFgenArbitrary_ClearMemory(
   IIviFgenArbitrary* This);
[C#]
public void ClearMemory();

Capability Group

IviFgenArbSeq

Also In This Interface

Gain | Offset | SampleRate | Sequence | Waveform | ClearMemory | IIviFgenArbitrary Overview


IIviFgenArbitrarySequence Interface

IVI FGen class-compliant arbitrary sequence interface

Methods

Configure | Configures the attributes of the function generator that affect arbitrary sequence generation.
Clear | Removes a previously created arbitrary sequence from the function generator's memory and invalidates the sequence's handle.
Create | Creates an arbitrary waveform sequence from an array of waveform handles and a corresponding array of loop counts, and returns a handle that identifies the sequence. The handle is used by the Configure, and Clear methods.

Properties

LengthMax | The maximum number of arbitrary waveforms that the function generator allows in an arbitrary sequence.
LengthMin | The minimum number of arbitrary waveforms that the function generator allows in an arbitrary sequence.
LoopCountMax | The maximum number of times that the function generator can repeat a waveform in a sequence.
NumberSequencesMax | The maximum number of arbitrary sequences that the function generator allows.


LengthMax Property

IIviFgenArbitrarySequence.LengthMax Property

The maximum number of arbitrary waveforms that the function generator allows in an arbitrary sequence.

[Visual Basic]
Property Get LengthMax() As Long
[C++]
HRESULT get_LengthMax(long* value);
[ANSI C]
HRESULT IIviFgenArbitrarySequence_get_LengthMax(IIviFgenArbitrarySequence* This, long* value);
[C#]
public long LengthMax {get;}

Capability Group

IviFgenArbSeq

Also In This Interface

LengthMax | LengthMin | LoopCountMax | NumberSequencesMax | Configure | Clear | Create | IIviFgenArbitrarySequence Overview


LengthMin Property

IIviFgenArbitrarySequence.LengthMin Property

The minimum number of arbitrary waveforms that the function generator allows in an arbitrary sequence.

[Visual Basic]
Property Get LengthMin() As Long
[C++]
HRESULT get_LengthMin(long* value);
[ANSI C]
HRESULT IIviFgenArbitrarySequence_get_LengthMin(IIviFgenArbitrarySequence* This, long* value);
[C#]
public long LengthMin {get;}

Capability Group

IviFgenArbSeq

Also In This Interface

LengthMax | LengthMin | LoopCountMax | NumberSequencesMax | Configure | Clear | Create | IIviFgenArbitrarySequence Overview


LoopCountMax Property

IIviFgenArbitrarySequence.LoopCountMax Property

The maximum number of times that the function generator can repeat a waveform in a sequence.

[Visual Basic]
Property Get LoopCountMax() As Long
[C++]
HRESULT get_LoopCountMax(long* value);
[ANSI C]
HRESULT IIviFgenArbitrarySequence_get_LoopCountMax(IIviFgenArbitrarySequence* This, long* value);
[C#]
public long LoopCountMax {get;}

Capability Group

IviFgenArbSeq

Also In This Interface

LengthMax | LengthMin | LoopCountMax | NumberSequencesMax | Configure | Clear | Create | IIviFgenArbitrarySequence Overview


NumberSequencesMax Property

IIviFgenArbitrarySequence.NumberSequencesMax Property

The maximum number of arbitrary sequences that the function generator allows.

[Visual Basic]
Property Get NumberSequencesMax() As Long
[C++]
HRESULT get_NumberSequencesMax(long* value);
[ANSI C]
HRESULT IIviFgenArbitrarySequence_get_NumberSequencesMax(IIviFgenArbitrarySequence* This, long* value);
[C#]
public long NumberSequencesMax {get;}

Capability Group

IviFgenArbSeq

Also In This Interface

LengthMax | LengthMin | LoopCountMax | NumberSequencesMax | Configure | Clear | Create | IIviFgenArbitrarySequence Overview


Configure Method

IIviFgenArbitrarySequence.Configure Method

Configures the attributes of the function generator that affect arbitrary sequence generation.

[Visual Basic]
Sub Configure( _
   ChannelName As String, _
   Handle As Long, _
   Gain As Double, _
   Offset As Double _
)
[C++]
HRESULT Configure(
   BSTR ChannelName,
   long Handle,
   double Gain,
   double Offset
);
[ANSI C]
HRESULT IIviFgenArbitrarySequence_Configure(
   IIviFgenArbitrarySequence* This
   BSTR ChannelName,
   long Handle,
   double Gain,
   double Offset
);
[C#]
public void Configure(
   string ChannelName,
   long Handle,
   double Gain,
   double Offset
);

Parameters

ChannelName
The ChannelName parameter may be a string defined by the driver or supplied as a virtual name in the configuration store. For single output instruments, the driver may define the empty string as valid ChannelName.
Handle
Specifies the handle that identifies the arbitrary sequence to produce. This value sets the Arbitrary Sequence Handle property.
Gain
Specifies the arbitrary waveform gain. Tthis value sets the Arbitrary Gain property.
Offset
Specifies the arbitrary waveform offset. This value sets the Arbitrary Offset property.

Capability Group

IviFgenArbSeq

Also In This Interface

LengthMax | LengthMin | LoopCountMax | NumberSequencesMax | Configure | Clear | Create | IIviFgenArbitrarySequence Overview


Clear Method

IIviFgenArbitrarySequence.Clear Method

Removes a previously created arbitrary sequence from the function generator's memory and invalidates the sequence's handle.

[Visual Basic]
Sub Clear( _
   Handle As Long _
)
[C++]
HRESULT Clear(
   long Handle
);
[ANSI C]
HRESULT IIviFgenArbitrarySequence_Clear(
   IIviFgenArbitrarySequence* This
   long Handle
);
[C#]
public void Clear(
   long Handle
);

Parameters

Handle
Specifies the handle that identifies the arbitrary sequence to clear.

Capability Group

IviFgenArbSeq

Also In This Interface

LengthMax | LengthMin | LoopCountMax | NumberSequencesMax | Configure | Clear | Create | IIviFgenArbitrarySequence Overview


Create Method

IIviFgenArbitrarySequence.Create Method

Creates an arbitrary waveform sequence from an array of waveform handles and a corresponding array of loop counts, and returns a handle that identifies the sequence. The handle is used by the Configure, and Clear methods.

[Visual Basic]
Function Create( _
   WfmHandle As SAFEARRAY(long)*, _
   LoopCount As SAFEARRAY(long)* _
) As Long
[C++]
HRESULT Create(
   SAFEARRAY(long)* WfmHandle,
   SAFEARRAY(long)* LoopCount,
   long* Handle
);
[ANSI C]
HRESULT IIviFgenArbitrarySequence_Create(
   IIviFgenArbitrarySequence* This
   SAFEARRAY(long)* WfmHandle,
   SAFEARRAY(long)* LoopCount,
   long* Handle
);
[C#]
public long Create(
   Array WfmHandle,
   Array LoopCount
);

Parameters

WfmHandle
Specifies the array of waveform handles for the new arbitrary sequence. The array must have at least as many elements as the value in the Length parameter (IVI-C only). Each WfmHandle array element has a corresponding LoopCount array element that specifies how many times that waveform is repeated.
LoopCount
Specifies the array of loop counts for the new arbitrary sequence. The array must have at least as many elements as the value in the length parameter (IVI-C only). Each LoopCount array element corresponds to a WfmHandle array element and indicates how many times to repeat that waveform. Each element of the LoopCount array must be less than or equal to the maximum number of loop counts the function generator allows. The function generator's maximum loop count is stored in the Loop Count Max attribute.
Handle
Returns the handle that identifies the new arbitrary sequence.

Capability Group

IviFgenArbSeq

Also In This Interface

LengthMax | LengthMin | LoopCountMax | NumberSequencesMax | Configure | Clear | Create | IIviFgenArbitrarySequence Overview


IIviFgenArbitraryWaveform Interface

IVI FGen class-compliant arbitrary waveform interface

Methods

Configure | Configures the attributes of the function generator that affect arbitrary waveform generation.
Clear | Removes a previously created arbitrary waveform from the function generator's memory and invalidates the waveform's handle.
Create | Creates an arbitrary waveform and returns a handle to it. The handle is used by the Configure, Clear, and ArbitrarySequence.Create methods.

Properties

Frequency | The rate at which an entire arbitrary waveform is generated. The units are in Hertz.
NumberWaveformsMax | The maximum number of arbitrary waveforms that the function generator allows.
Quantum | The size of each arbitrary waveform must be a multiple of a quantum value. This attribute returns the quantum value the function generator allows. For example, if this attribute returns a value of 8, all waveform sizes must be a multiple of 8.
SizeMax | The maximum number of points the function generator allows in an arbitrary waveform.
SizeMin | The minimum number of points the function generator allows in an arbitrary waveform.


Frequency Property

IIviFgenArbitraryWaveform.Frequency Property

The rate at which an entire arbitrary waveform is generated. The units are in Hertz.

[Visual Basic]
Property Get Frequency(ChannelName As String) As Double
Property Let Frequency(ChannelName As Stringvalue As Double)
[C++]
HRESULT get_Frequency(BSTR ChannelName, double* value);
HRESULT put_Frequency(BSTR ChannelName, double value);
[ANSI C]
HRESULT IIviFgenArbitraryWaveform_get_Frequency(IIviFgenArbitraryWaveform* This, BSTR ChannelName, double* value);
HRESULT IIviFgenArbitraryWaveform_put_Frequency(IIviFgenArbitraryWaveform* This, BSTR ChannelName, double value);
[C#]HRESULT get_Frequency(string ChannelName, double value);
HRESULT put_Frequency(string ChannelName, double value);

Parameters

ChannelName
The ChannelName parameter may be a string defined by the driver or supplied as a virtual name in the configuration store. For single output instruments, the driver may define the empty string as valid ChannelName.

Capability Group

IviFgenArbFrequency

Also In This Interface

Frequency | NumberWaveformsMax | Quantum | SizeMax | SizeMin | Configure | Clear | Create | IIviFgenArbitraryWaveform Overview


NumberWaveformsMax Property

IIviFgenArbitraryWaveform.NumberWaveformsMax Property

The maximum number of arbitrary waveforms that the function generator allows.

[Visual Basic]
Property Get NumberWaveformsMax() As Long
[C++]
HRESULT get_NumberWaveformsMax(long* value);
[ANSI C]
HRESULT IIviFgenArbitraryWaveform_get_NumberWaveformsMax(IIviFgenArbitraryWaveform* This, long* value);
[C#]
public long NumberWaveformsMax {get;}

Capability Group

IviFgenArbWfm

Also In This Interface

Frequency | NumberWaveformsMax | Quantum | SizeMax | SizeMin | Configure | Clear | Create | IIviFgenArbitraryWaveform Overview


Quantum Property

IIviFgenArbitraryWaveform.Quantum Property

The size of each arbitrary waveform must be a multiple of a quantum value. This attribute returns the quantum value the function generator allows. For example, if this attribute returns a value of 8, all waveform sizes must be a multiple of 8.

[Visual Basic]
Property Get Quantum() As Long
[C++]
HRESULT get_Quantum(long* value);
[ANSI C]
HRESULT IIviFgenArbitraryWaveform_get_Quantum(IIviFgenArbitraryWaveform* This, long* value);
[C#]
public long Quantum {get;}

Capability Group

IviFgenArbWfm

Also In This Interface

Frequency | NumberWaveformsMax | Quantum | SizeMax | SizeMin | Configure | Clear | Create | IIviFgenArbitraryWaveform Overview


SizeMax Property

IIviFgenArbitraryWaveform.SizeMax Property

The maximum number of points the function generator allows in an arbitrary waveform.

[Visual Basic]
Property Get SizeMax() As Long
[C++]
HRESULT get_SizeMax(long* value);
[ANSI C]
HRESULT IIviFgenArbitraryWaveform_get_SizeMax(IIviFgenArbitraryWaveform* This, long* value);
[C#]
public long SizeMax {get;}

Capability Group

IviFgenArbWfm

Also In This Interface

Frequency | NumberWaveformsMax | Quantum | SizeMax | SizeMin | Configure | Clear | Create | IIviFgenArbitraryWaveform Overview


SizeMin Property

IIviFgenArbitraryWaveform.SizeMin Property

The minimum number of points the function generator allows in an arbitrary waveform.

[Visual Basic]
Property Get SizeMin() As Long
[C++]
HRESULT get_SizeMin(long* value);
[ANSI C]
HRESULT IIviFgenArbitraryWaveform_get_SizeMin(IIviFgenArbitraryWaveform* This, long* value);
[C#]
public long SizeMin {get;}

Capability Group

IviFgenArbWfm

Also In This Interface

Frequency | NumberWaveformsMax | Quantum | SizeMax | SizeMin | Configure | Clear | Create | IIviFgenArbitraryWaveform Overview


Configure Method

IIviFgenArbitraryWaveform.Configure Method

Configures the attributes of the function generator that affect arbitrary waveform generation.

[Visual Basic]
Sub Configure( _
   ChannelName As String, _
   Handle As Long, _
   Gain As Double, _
   Offset As Double _
)
[C++]
HRESULT Configure(
   BSTR ChannelName,
   long Handle,
   double Gain,
   double Offset
);
[ANSI C]
HRESULT IIviFgenArbitraryWaveform_Configure(
   IIviFgenArbitraryWaveform* This
   BSTR ChannelName,
   long Handle,
   double Gain,
   double Offset
);
[C#]
public void Configure(
   string ChannelName,
   long Handle,
   double Gain,
   double Offset
);

Parameters

ChannelName
The ChannelName parameter may be a string defined by the driver or supplied as a virtual name in the configuration store. For single output instruments, the driver may define the empty string as valid ChannelName.
Handle
Specifies the handle that identifies the arbitrary waveform to produce. This value sets the Arbitrary Waveform Handle attribute.
Gain
Specifies the arbitrary waveform gain. This value sets the Arbitrary Gain attribute.
Offset
Specifies the arbitrary waveform offset. This value sets the Arbitrary Offset attribute.

Capability Group

IviFgenArbWfm

Also In This Interface

Frequency | NumberWaveformsMax | Quantum | SizeMax | SizeMin | Configure | Clear | Create | IIviFgenArbitraryWaveform Overview


Clear Method

IIviFgenArbitraryWaveform.Clear Method

Removes a previously created arbitrary waveform from the function generator's memory and invalidates the waveform's handle.

[Visual Basic]
Sub Clear( _
   Handle As Long _
)
[C++]
HRESULT Clear(
   long Handle
);
[ANSI C]
HRESULT IIviFgenArbitraryWaveform_Clear(
   IIviFgenArbitraryWaveform* This
   long Handle
);
[C#]
public void Clear(
   long Handle
);

Parameters

Handle
Specifies the handle that identifies the arbitrary waveform to clear.

Capability Group

IviFgenArbWfm

Also In This Interface

Frequency | NumberWaveformsMax | Quantum | SizeMax | SizeMin | Configure | Clear | Create | IIviFgenArbitraryWaveform Overview


Create Method

IIviFgenArbitraryWaveform.Create Method

Creates an arbitrary waveform and returns a handle to it. The handle is used by the Configure, Clear, and ArbitrarySequence.Create methods.

[Visual Basic]
Function Create( _
   Data As SAFEARRAY(double)* _
) As Long
[C++]
HRESULT Create(
   SAFEARRAY(double)* Data,
   long* Handle
);
[ANSI C]
HRESULT IIviFgenArbitraryWaveform_Create(
   IIviFgenArbitraryWaveform* This
   SAFEARRAY(double)* Data,
   long* Handle
);
[C#]
public long Create(
   Array Data
);

Parameters

Data
Specifies the array of data to use for the new arbitrary waveform. The array must have at least as many elements as the value in the Size parameter. The array's elements must be normalized between -1.00 and +1.00.
Handle
Returns the handle that identifies the new arbitrary waveform.

Capability Group

IviFgenArbWfm

Also In This Interface

Frequency | NumberWaveformsMax | Quantum | SizeMax | SizeMin | Configure | Clear | Create | IIviFgenArbitraryWaveform Overview


IIviFgenFM Interface

IVI FGen class-compliant FM interface

Methods

ConfigureInternal Configures the attributes that control the function generator's internal frequency modulating waveform source.

Properties

Enabled | If true, the function generator applies amplitude modulation to the carrier waveform.
Source | The source of the signal that the function generator uses as the modulating waveform. Applies only when the FM Enabled attribute is set to True.
InternalDeviation | The maximum frequency deviation the function generator applies to the carrier waveform when the FM Source attribute is set to FM Internal. Applies only when the FM Source attribute is set to FM Internal.
InternalFrequency | The frequency of the internal modulating waveform source. The units are hertz. Applies only when the FM Source attribute is set to FM Internal.
InternalWaveform | The waveform of the internal modulating waveform source. Applies only when the FM Source attribute is set to FM Internal.


Enabled Property

IIviFgenFM.Enabled Property

If true, the function generator applies amplitude modulation to the carrier waveform.

[Visual Basic]
Property Get Enabled(ChannelName As String) As Boolean
Property Let Enabled(ChannelName As Stringvalue As Boolean)
[C++]
HRESULT get_Enabled(BSTR ChannelName, VARIANT_BOOL* value);
HRESULT put_Enabled(BSTR ChannelName, VARIANT_BOOL value);
[ANSI C]
HRESULT IIviFgenFM_get_Enabled(IIviFgenFM* This, BSTR ChannelName, VARIANT_BOOL* value);
HRESULT IIviFgenFM_put_Enabled(IIviFgenFM* This, BSTR ChannelName, VARIANT_BOOL value);
[C#]HRESULT get_Enabled(string ChannelName, bool value);
HRESULT put_Enabled(string ChannelName, bool value);

Parameters

ChannelName
The ChannelName parameter may be a string defined by the driver or supplied as a virtual name in the configuration store. For single output instruments, the driver may define the empty string as valid ChannelName.

Capability Group

IviFgenModulateFM

Also In This Interface

Enabled | Source | InternalDeviation | InternalFrequency | InternalWaveform | ConfigureInternal | IIviFgenFM Overview


Source Property

IIviFgenFM.Source Property

The source of the signal that the function generator uses as the modulating waveform. Applies only when the FM Enabled attribute is set to True.

[Visual Basic]
Property Get Source(ChannelName As String) As IviFgenFMSourceEnum
Property Let Source(ChannelName As Stringvalue As IviFgenFMSourceEnum)
[C++]
HRESULT get_Source(BSTR ChannelName, IviFgenFMSourceEnum* value);
HRESULT put_Source(BSTR ChannelName, IviFgenFMSourceEnum value);
[ANSI C]
HRESULT IIviFgenFM_get_Source(IIviFgenFM* This, BSTR ChannelName, IviFgenFMSourceEnum* value);
HRESULT IIviFgenFM_put_Source(IIviFgenFM* This, BSTR ChannelName, IviFgenFMSourceEnum value);
[C#]HRESULT get_Source(string ChannelName, IviFgenFMSourceEnum value);
HRESULT put_Source(string ChannelName, IviFgenFMSourceEnum value);

Parameters

ChannelName
The ChannelName parameter may be a string defined by the driver or supplied as a virtual name in the configuration store. For single output instruments, the driver may define the empty string as valid ChannelName.

Capability Group

IviFgenModulateFM

Also In This Interface

Enabled | Source | InternalDeviation | InternalFrequency | InternalWaveform | ConfigureInternal | IIviFgenFM Overview


InternalDeviation Property

IIviFgenFM.InternalDeviation Property

The maximum frequency deviation the function generator applies to the carrier waveform when the FM Source attribute is set to FM Internal. Applies only when the FM Source attribute is set to FM Internal.

[Visual Basic]
Property Get InternalDeviation() As Double
Property Let InternalDeviation(value As Double)
[C++]
HRESULT get_InternalDeviation(double* value);
HRESULT put_InternalDeviation(double value);
[ANSI C]
HRESULT IIviFgenFM_get_InternalDeviation(IIviFgenFM* This, double* value);
HRESULT IIviFgenFM_put_InternalDeviation(IIviFgenFM* This, double value);
[C#]
public double InternalDeviation {get; set;}

Capability Group

IviFgenModulateFM

Related Items

ConfigureInternal

Also In This Interface

Enabled | Source | InternalDeviation | InternalFrequency | InternalWaveform | ConfigureInternal | IIviFgenFM Overview


InternalFrequency Property

IIviFgenFM.InternalFrequency Property

The frequency of the internal modulating waveform source. The units are hertz. Applies only when the FM Source attribute is set to FM Internal.

[Visual Basic]
Property Get InternalFrequency() As Double
Property Let InternalFrequency(value As Double)
[C++]
HRESULT get_InternalFrequency(double* value);
HRESULT put_InternalFrequency(double value);
[ANSI C]
HRESULT IIviFgenFM_get_InternalFrequency(IIviFgenFM* This, double* value);
HRESULT IIviFgenFM_put_InternalFrequency(IIviFgenFM* This, double value);
[C#]
public double InternalFrequency {get; set;}

Capability Group

IviFgenModulateFM

Related Items

ConfigureInternal

Also In This Interface

Enabled | Source | InternalDeviation | InternalFrequency | InternalWaveform | ConfigureInternal | IIviFgenFM Overview


InternalWaveform Property

IIviFgenFM.InternalWaveform Property

The waveform of the internal modulating waveform source. Applies only when the FM Source attribute is set to FM Internal.

[Visual Basic]
Property Get InternalWaveform() As IviFgenFMInternalWaveformEnum
Property Let InternalWaveform(value As IviFgenFMInternalWaveformEnum)
[C++]
HRESULT get_InternalWaveform(IviFgenFMInternalWaveformEnum* value);
HRESULT put_InternalWaveform(IviFgenFMInternalWaveformEnum value);
[ANSI C]
HRESULT IIviFgenFM_get_InternalWaveform(IIviFgenFM* This, IviFgenFMInternalWaveformEnum* value);
HRESULT IIviFgenFM_put_InternalWaveform(IIviFgenFM* This, IviFgenFMInternalWaveformEnum value);
[C#]
public IviFgenFMInternalWaveformEnum InternalWaveform {get; set;}

Capability Group

IviFgenModulateFM

Related Items

ConfigureInternal

Also In This Interface

Enabled | Source | InternalDeviation | InternalFrequency | InternalWaveform | ConfigureInternal | IIviFgenFM Overview


ConfigureInternal Method

IIviFgenFM.ConfigureInternal Method

Configures the attributes that control the function generator's internal frequency modulating waveform source.

[Visual Basic]
Sub ConfigureInternal( _
   Deviation As Double, _
   Waveform As IviFgenFMInternalWaveformEnum, _
   Frequency As Double _
)
[C++]
HRESULT ConfigureInternal(
   double Deviation,
   IviFgenFMInternalWaveformEnum Waveform,
   double Frequency
);
[ANSI C]
HRESULT IIviFgenFM_ConfigureInternal(
   IIviFgenFM* This
   double Deviation,
   IviFgenFMInternalWaveformEnum Waveform,
   double Frequency
);
[C#]
public void ConfigureInternal(
   double Deviation,
   IviFgenFMInternalWaveformEnum Waveform,
   double Frequency
);

Parameters

Deviation
Specifies the internal modulation deviation. This value sets the FM Internal Deviation property.
Waveform
Specifies the waveform the function generator uses for the internal modulating waveform source. This value sets the FM Internal Waveform property.
Frequency
Specifies the frequency of the internal modulating waveform source. This value setsthe FM Internal Frequency property.

Capability Group

IviFgenModulateFM

Related Items

InternalDeviation

Also In This Interface

Enabled | Source | InternalDeviation | InternalFrequency | InternalWaveform | ConfigureInternal | IIviFgenFM Overview


IIviFgenOutput Interface

IVI FGen class-compliant output interface

Properties

Enabled | If true, the signal the function generator produces appears at the output connector.
Impedance | The impedance of the output channel. The units are Ohms.
OutputMode | The mode that determines how the function generator produces waveforms. This attribute determines which extension group's functions and attributes are used to configure the waveform the function generator produces.
OperationMode | The mode that determines how the function generator produces output on a channel.
ReferenceClockSource | The source of the reference clock. The function generator derives frequencies and sample rates that it uses to generate waveforms from the reference clock.
Count | The number of output channels supported by the instrument.
Name | The name of the output channel specified.


Enabled Property

IIviFgenOutput.Enabled Property

If true, the signal the function generator produces appears at the output connector.

[Visual Basic]
Property Get Enabled(ChannelName As String) As Boolean
Property Let Enabled(ChannelName As Stringvalue As Boolean)
[C++]
HRESULT get_Enabled(BSTR ChannelName, VARIANT_BOOL* value);
HRESULT put_Enabled(BSTR ChannelName, VARIANT_BOOL value);
[ANSI C]
HRESULT IIviFgenOutput_get_Enabled(IIviFgenOutput* This, BSTR ChannelName, VARIANT_BOOL* value);
HRESULT IIviFgenOutput_put_Enabled(IIviFgenOutput* This, BSTR ChannelName, VARIANT_BOOL value);
[C#]HRESULT get_Enabled(string ChannelName, bool value);
HRESULT put_Enabled(string ChannelName, bool value);

Parameters

ChannelName
The ChannelName parameter may be a string defined by the driver or supplied as a virtual name in the configuration store. For single output instruments, the driver may define the empty string as valid ChannelName.

Capability Group

IviFgenBase

Also In This Interface

Enabled | Impedance | OutputMode | OperationMode | ReferenceClockSource | Count | Name | IIviFgenOutput Overview


Impedance Property

IIviFgenOutput.Impedance Property

The impedance of the output channel. The units are Ohms.

[Visual Basic]
Property Get Impedance(ChannelName As String) As Double
Property Let Impedance(ChannelName As Stringvalue As Double)
[C++]
HRESULT get_Impedance(BSTR ChannelName, double* value);
HRESULT put_Impedance(BSTR ChannelName, double value);
[ANSI C]
HRESULT IIviFgenOutput_get_Impedance(IIviFgenOutput* This, BSTR ChannelName, double* value);
HRESULT IIviFgenOutput_put_Impedance(IIviFgenOutput* This, BSTR ChannelName, double value);
[C#]HRESULT get_Impedance(string ChannelName, double value);
HRESULT put_Impedance(string ChannelName, double value);

Parameters

ChannelName
The ChannelName parameter may be a string defined by the driver or supplied as a virtual name in the configuration store. For single output instruments, the driver may define the empty string as valid ChannelName.

Capability Group

IviFgenBase

Also In This Interface

Enabled | Impedance | OutputMode | OperationMode | ReferenceClockSource | Count | Name | IIviFgenOutput Overview


OutputMode Property

IIviFgenOutput.OutputMode Property

The mode that determines how the function generator produces waveforms. This attribute determines which extension group's functions and attributes are used to configure the waveform the function generator produces.

[Visual Basic]
Property Get OutputMode() As IviFgenOutputModeEnum
Property Let OutputMode(value As IviFgenOutputModeEnum)
[C++]
HRESULT get_OutputMode(IviFgenOutputModeEnum* value);
HRESULT put_OutputMode(IviFgenOutputModeEnum value);
[ANSI C]
HRESULT IIviFgenOutput_get_OutputMode(IIviFgenOutput* This, IviFgenOutputModeEnum* value);
HRESULT IIviFgenOutput_put_OutputMode(IIviFgenOutput* This, IviFgenOutputModeEnum value);
[C#]
public IviFgenOutputModeEnum OutputMode {get; set;}

Capability Group

IviFgenBase

Also In This Interface

Enabled | Impedance | OutputMode | OperationMode | ReferenceClockSource | Count | Name | IIviFgenOutput Overview


OperationMode Property

IIviFgenOutput.OperationMode Property

The mode that determines how the function generator produces output on a channel.

[Visual Basic]
Property Get OperationMode(ChannelName As String) As IviFgenOperationModeEnum
Property Let OperationMode(ChannelName As Stringvalue As IviFgenOperationModeEnum)
[C++]
HRESULT get_OperationMode(BSTR ChannelName, IviFgenOperationModeEnum* value);
HRESULT put_OperationMode(BSTR ChannelName, IviFgenOperationModeEnum value);
[ANSI C]
HRESULT IIviFgenOutput_get_OperationMode(IIviFgenOutput* This, BSTR ChannelName, IviFgenOperationModeEnum* value);
HRESULT IIviFgenOutput_put_OperationMode(IIviFgenOutput* This, BSTR ChannelName, IviFgenOperationModeEnum value);
[C#]HRESULT get_OperationMode(string ChannelName, IviFgenOperationModeEnum value);
HRESULT put_OperationMode(string ChannelName, IviFgenOperationModeEnum value);

Parameters

ChannelName
The ChannelName parameter may be a string defined by the driver or supplied as a virtual name in the configuration store. For single output instruments, the driver may define the empty string as valid ChannelName.

Capability Group

IviFgenBase

Also In This Interface

Enabled | Impedance | OutputMode | OperationMode | ReferenceClockSource | Count | Name | IIviFgenOutput Overview


ReferenceClockSource Property

IIviFgenOutput.ReferenceClockSource Property

The source of the reference clock. The function generator derives frequencies and sample rates that it uses to generate waveforms from the reference clock.

[Visual Basic]
Property Get ReferenceClockSource() As IviFgenReferenceClockSourceEnum
Property Let ReferenceClockSource(value As IviFgenReferenceClockSourceEnum)
[C++]
HRESULT get_ReferenceClockSource(IviFgenReferenceClockSourceEnum* value);
HRESULT put_ReferenceClockSource(IviFgenReferenceClockSourceEnum value);
[ANSI C]
HRESULT IIviFgenOutput_get_ReferenceClockSource(IIviFgenOutput* This, IviFgenReferenceClockSourceEnum* value);
HRESULT IIviFgenOutput_put_ReferenceClockSource(IIviFgenOutput* This, IviFgenReferenceClockSourceEnum value);
[C#]
public IviFgenReferenceClockSourceEnum ReferenceClockSource {get; set;}

Capability Group

IviFgenBase

Also In This Interface

Enabled | Impedance | OutputMode | OperationMode | ReferenceClockSource | Count | Name | IIviFgenOutput Overview


Count Property

IIviFgenOutput.Count Property

The number of output channels supported by the instrument.

[Visual Basic]
Property Get Count() As Long
[C++]
HRESULT get_Count(long* value);
[ANSI C]
HRESULT IIviFgenOutput_get_Count(IIviFgenOutput* This, long* value);
[C#]
public long Count {get;}

Capability Group

IviFgenBase

Also In This Interface

Enabled | Impedance | OutputMode | OperationMode | ReferenceClockSource | Count | Name | IIviFgenOutput Overview


Name Property

IIviFgenOutput.Name Property

The name of the output channel specified.

[Visual Basic]
Property Get Name(Index As Long) As String
[C++]
HRESULT get_Name(long Index, BSTR* value);
[ANSI C]
HRESULT IIviFgenOutput_get_Name(IIviFgenOutput* This, long Index, BSTR* value);
[C#]HRESULT get_Name(long Index, string value);

Parameters

Index
The one-based index into the Outputs collection. Its value must from one to Output.Count.

Capability Group

IviFgenBase

Also In This Interface

Enabled | Impedance | OutputMode | OperationMode | ReferenceClockSource | Count | Name | IIviFgenOutput Overview


IIviFgenStandardWaveform Interface

IVI FGen class-compliant standard waveform interface

Methods

Configure Configures the function generator attributes that affect standard waveform generation. When the Waveform parameter is set to Waveform DC, this function ignores the Amplitude, Frequency, and Start Phase parameters.

Properties

DutyCycleHigh | The duty cycle for a square waveform. This attribute affects function generator behavior only when the Waveform attribute is set to Waveform Square. The value is expressed as a percentage.
Amplitude | The amplitude of the standard waveform output by the function generator. When the Waveform attribute is set to Waveform DC, this attribute does not affect signal output. The units are volts.
DCOffset | The DC offset of the standard waveform output by the function generator. If the Waveform attribute is set to Waveform DC, this attribute specifies the DC level the function generator produces. The units are volts.
Frequency | The frequency of the standard waveform output by the function generator. When the Waveform attribute is set to Waveform DC, this attribute does not affect signal output. The units are Hertz.
StartPhase | The start phase of the standard waveform output by the function generator. When the Waveform attribute is set to Waveform DC, this attribute does not affect signal output. The units are degrees.
Waveform | The standard waveform output by the function generator.


DutyCycleHigh Property

IIviFgenStandardWaveform.DutyCycleHigh Property

The duty cycle for a square waveform. This attribute affects function generator behavior only when the Waveform attribute is set to Waveform Square. The value is expressed as a percentage.

[Visual Basic]
Property Get DutyCycleHigh(ChannelName As String) As Double
Property Let DutyCycleHigh(ChannelName As Stringvalue As Double)
[C++]
HRESULT get_DutyCycleHigh(BSTR ChannelName, double* value);
HRESULT put_DutyCycleHigh(BSTR ChannelName, double value);
[ANSI C]
HRESULT IIviFgenStandardWaveform_get_DutyCycleHigh(IIviFgenStandardWaveform* This, BSTR ChannelName, double* value);
HRESULT IIviFgenStandardWaveform_put_DutyCycleHigh(IIviFgenStandardWaveform* This, BSTR ChannelName, double value);
[C#]HRESULT get_DutyCycleHigh(string ChannelName, double value);
HRESULT put_DutyCycleHigh(string ChannelName, double value);

Parameters

ChannelName
The ChannelName parameter may be a string defined by the driver or supplied as a virtual name in the configuration store. For single output instruments, the driver may define the empty string as valid ChannelName.

Capability Group

IviFgenStdFunc

Also In This Interface

DutyCycleHigh | Amplitude | DCOffset | Frequency | StartPhase | Waveform | Configure | IIviFgenStandardWaveform Overview


Amplitude Property

IIviFgenStandardWaveform.Amplitude Property

The amplitude of the standard waveform output by the function generator. When the Waveform attribute is set to Waveform DC, this attribute does not affect signal output. The units are volts.

[Visual Basic]
Property Get Amplitude(ChannelName As String) As Double
Property Let Amplitude(ChannelName As Stringvalue As Double)
[C++]
HRESULT get_Amplitude(BSTR ChannelName, double* value);
HRESULT put_Amplitude(BSTR ChannelName, double value);
[ANSI C]
HRESULT IIviFgenStandardWaveform_get_Amplitude(IIviFgenStandardWaveform* This, BSTR ChannelName, double* value);
HRESULT IIviFgenStandardWaveform_put_Amplitude(IIviFgenStandardWaveform* This, BSTR ChannelName, double value);
[C#]HRESULT get_Amplitude(string ChannelName, double value);
HRESULT put_Amplitude(string ChannelName, double value);

Parameters

ChannelName
The ChannelName parameter may be a string defined by the driver or supplied as a virtual name in the configuration store. For single output instruments, the driver may define the empty string as valid ChannelName.

Capability Group

IviFgenStdFunc

Related Items

Configure

Also In This Interface

DutyCycleHigh | Amplitude | DCOffset | Frequency | StartPhase | Waveform | Configure | IIviFgenStandardWaveform Overview


DCOffset Property

IIviFgenStandardWaveform.DCOffset Property

The DC offset of the standard waveform output by the function generator. If the Waveform attribute is set to Waveform DC, this attribute specifies the DC level the function generator produces. The units are volts.

[Visual Basic]
Property Get DCOffset(ChannelName As String) As Double
Property Let DCOffset(ChannelName As Stringvalue As Double)
[C++]
HRESULT get_DCOffset(BSTR ChannelName, double* value);
HRESULT put_DCOffset(BSTR ChannelName, double value);
[ANSI C]
HRESULT IIviFgenStandardWaveform_get_DCOffset(IIviFgenStandardWaveform* This, BSTR ChannelName, double* value);
HRESULT IIviFgenStandardWaveform_put_DCOffset(IIviFgenStandardWaveform* This, BSTR ChannelName, double value);
[C#]HRESULT get_DCOffset(string ChannelName, double value);
HRESULT put_DCOffset(string ChannelName, double value);

Parameters

ChannelName
The ChannelName parameter may be a string defined by the driver or supplied as a virtual name in the configuration store. For single output instruments, the driver may define the empty string as valid ChannelName.

Capability Group

IviFgenStdFunc

Related Items

Configure

Also In This Interface

DutyCycleHigh | Amplitude | DCOffset | Frequency | StartPhase | Waveform | Configure | IIviFgenStandardWaveform Overview


Frequency Property

IIviFgenStandardWaveform.Frequency Property

The frequency of the standard waveform output by the function generator. When the Waveform attribute is set to Waveform DC, this attribute does not affect signal output. The units are Hertz.

[Visual Basic]
Property Get Frequency(ChannelName As String) As Double
Property Let Frequency(ChannelName As Stringvalue As Double)
[C++]
HRESULT get_Frequency(BSTR ChannelName, double* value);
HRESULT put_Frequency(BSTR ChannelName, double value);
[ANSI C]
HRESULT IIviFgenStandardWaveform_get_Frequency(IIviFgenStandardWaveform* This, BSTR ChannelName, double* value);
HRESULT IIviFgenStandardWaveform_put_Frequency(IIviFgenStandardWaveform* This, BSTR ChannelName, double value);
[C#]HRESULT get_Frequency(string ChannelName, double value);
HRESULT put_Frequency(string ChannelName, double value);

Parameters

ChannelName
The ChannelName parameter may be a string defined by the driver or supplied as a virtual name in the configuration store. For single output instruments, the driver may define the empty string as valid ChannelName.

Capability Group

IviFgenStdFunc

Related Items

Configure

Also In This Interface

DutyCycleHigh | Amplitude | DCOffset | Frequency | StartPhase | Waveform | Configure | IIviFgenStandardWaveform Overview


StartPhase Property

IIviFgenStandardWaveform.StartPhase Property

The start phase of the standard waveform output by the function generator. When the Waveform attribute is set to Waveform DC, this attribute does not affect signal output. The units are degrees.

[Visual Basic]
Property Get StartPhase(ChannelName As String) As Double
Property Let StartPhase(ChannelName As Stringvalue As Double)
[C++]
HRESULT get_StartPhase(BSTR ChannelName, double* value);
HRESULT put_StartPhase(BSTR ChannelName, double value);
[ANSI C]
HRESULT IIviFgenStandardWaveform_get_StartPhase(IIviFgenStandardWaveform* This, BSTR ChannelName, double* value);
HRESULT IIviFgenStandardWaveform_put_StartPhase(IIviFgenStandardWaveform* This, BSTR ChannelName, double value);
[C#]HRESULT get_StartPhase(string ChannelName, double value);
HRESULT put_StartPhase(string ChannelName, double value);

Parameters

ChannelName
The ChannelName parameter may be a string defined by the driver or supplied as a virtual name in the configuration store. For single output instruments, the driver may define the empty string as valid ChannelName.

Capability Group

IviFgenStdFunc

Related Items

Configure

Also In This Interface

DutyCycleHigh | Amplitude | DCOffset | Frequency | StartPhase | Waveform | Configure | IIviFgenStandardWaveform Overview


Waveform Property

IIviFgenStandardWaveform.Waveform Property

The standard waveform output by the function generator.

[Visual Basic]
Property Get Waveform(ChannelName As String) As IviFgenWaveformEnum
Property Let Waveform(ChannelName As Stringvalue As IviFgenWaveformEnum)
[C++]
HRESULT get_Waveform(BSTR ChannelName, IviFgenWaveformEnum* value);
HRESULT put_Waveform(BSTR ChannelName, IviFgenWaveformEnum value);
[ANSI C]
HRESULT IIviFgenStandardWaveform_get_Waveform(IIviFgenStandardWaveform* This, BSTR ChannelName, IviFgenWaveformEnum* value);
HRESULT IIviFgenStandardWaveform_put_Waveform(IIviFgenStandardWaveform* This, BSTR ChannelName, IviFgenWaveformEnum value);
[C#]HRESULT get_Waveform(string ChannelName, IviFgenWaveformEnum value);
HRESULT put_Waveform(string ChannelName, IviFgenWaveformEnum value);

Parameters

ChannelName
The ChannelName parameter may be a string defined by the driver or supplied as a virtual name in the configuration store. For single output instruments, the driver may define the empty string as valid ChannelName.

Capability Group

IviFgenStdFunc

Related Items

Configure

Also In This Interface

DutyCycleHigh | Amplitude | DCOffset | Frequency | StartPhase | Waveform | Configure | IIviFgenStandardWaveform Overview


Configure Method

IIviFgenStandardWaveform.Configure Method

Configures the function generator attributes that affect standard waveform generation. When the Waveform parameter is set to Waveform DC, this function ignores the Amplitude, Frequency, and Start Phase parameters.

[Visual Basic]
Sub Configure( _
   ChannelName As String, _
   Waveform As IviFgenWaveformEnum, _
   Amplitude As Double, _
   DCOffset As Double, _
   Frequency As Double, _
   StartPhase As Double _
)
[C++]
HRESULT Configure(
   BSTR ChannelName,
   IviFgenWaveformEnum Waveform,
   double Amplitude,
   double DCOffset,
   double Frequency,
   double StartPhase
);
[ANSI C]
HRESULT IIviFgenStandardWaveform_Configure(
   IIviFgenStandardWaveform* This
   BSTR ChannelName,
   IviFgenWaveformEnum Waveform,
   double Amplitude,
   double DCOffset,
   double Frequency,
   double StartPhase
);
[C#]
public void Configure(
   string ChannelName,
   IviFgenWaveformEnum Waveform,
   double Amplitude,
   double DCOffset,
   double Frequency,
   double StartPhase
);

Parameters

ChannelName
The ChannelName parameter may be a string defined by the driver or supplied as a virtual name in the configuration store. For single output instruments, the driver may define the empty string as valid ChannelName.
Waveform
Specifies the standard waveform. This value sets the Waveform property
Amplitude
Specifies the waveform amplitude. This value sets the Amplitude property
DCOffset
Specifies the waveform's DC offset. Tthis value sets the DC Offset attribute.
Frequency
Specifies the waveform frequency. Tthis value sets the Frequency attribute.
StartPhase
Specifies the waveform start phase. This value sets the Start Phase attribute.

Capability Group

IviFgenStdFunc

Related Items

Waveform | Amplitude | DCOffset | StartPhase

Also In This Interface

DutyCycleHigh | Amplitude | DCOffset | Frequency | StartPhase | Waveform | Configure | IIviFgenStandardWaveform Overview


IIviFgenTrigger Interface

IVI FGen class-compliant trigger interface

Methods

SendSoftwareTrigger Sends a software trigger, which will cause the function generator to generate output.

Properties

BurstCount | The number of waveform cycles that the function generator produces after it receives a trigger.
InternalRate | The rate at which the function generator's internal trigger source produces a trigger, in triggers per second.
Source | The trigger source. After the function generator receives a trigger from this source, it produces a signal.


BurstCount Property

IIviFgenTrigger.BurstCount Property

The number of waveform cycles that the function generator produces after it receives a trigger.

[Visual Basic]
Property Get BurstCount(ChannelName As String) As Long
Property Let BurstCount(ChannelName As Stringvalue As Long)
[C++]
HRESULT get_BurstCount(BSTR ChannelName, long* value);
HRESULT put_BurstCount(BSTR ChannelName, long value);
[ANSI C]
HRESULT IIviFgenTrigger_get_BurstCount(IIviFgenTrigger* This, BSTR ChannelName, long* value);
HRESULT IIviFgenTrigger_put_BurstCount(IIviFgenTrigger* This, BSTR ChannelName, long value);
[C#]HRESULT get_BurstCount(string ChannelName, long value);
HRESULT put_BurstCount(string ChannelName, long value);

Parameters

ChannelName
The ChannelName parameter may be a string defined by the driver or supplied as a virtual name in the configuration store. For single output instruments, the driver may define the empty string as valid ChannelName.

Capability Group

IviFgenBurst

Also In This Interface

BurstCount | InternalRate | Source | SendSoftwareTrigger | IIviFgenTrigger Overview


InternalRate Property

IIviFgenTrigger.InternalRate Property

The rate at which the function generator's internal trigger source produces a trigger, in triggers per second.

[Visual Basic]
Property Get InternalRate() As Double
Property Let InternalRate(value As Double)
[C++]
HRESULT get_InternalRate(double* value);
HRESULT put_InternalRate(double value);
[ANSI C]
HRESULT IIviFgenTrigger_get_InternalRate(IIviFgenTrigger* This, double* value);
HRESULT IIviFgenTrigger_put_InternalRate(IIviFgenTrigger* This, double value);
[C#]
public double InternalRate {get; set;}

Capability Group

IviFgenInternalTrigger

Also In This Interface

BurstCount | InternalRate | Source | SendSoftwareTrigger | IIviFgenTrigger Overview


Source Property

IIviFgenTrigger.Source Property

The trigger source. After the function generator receives a trigger from this source, it produces a signal.

[Visual Basic]
Property Get Source(ChannelName As String) As IviFgenTriggerSourceEnum
Property Let Source(ChannelName As Stringvalue As IviFgenTriggerSourceEnum)
[C++]
HRESULT get_Source(BSTR ChannelName, IviFgenTriggerSourceEnum* value);
HRESULT put_Source(BSTR ChannelName, IviFgenTriggerSourceEnum value);
[ANSI C]
HRESULT IIviFgenTrigger_get_Source(IIviFgenTrigger* This, BSTR ChannelName, IviFgenTriggerSourceEnum* value);
HRESULT IIviFgenTrigger_put_Source(IIviFgenTrigger* This, BSTR ChannelName, IviFgenTriggerSourceEnum value);
[C#]HRESULT get_Source(string ChannelName, IviFgenTriggerSourceEnum value);
HRESULT put_Source(string ChannelName, IviFgenTriggerSourceEnum value);

Parameters

ChannelName
The ChannelName parameter may be a string defined by the driver or supplied as a virtual name in the configuration store. For single output instruments, the driver may define the empty string as valid ChannelName.

Capability Group

IviFgenTrigger

Also In This Interface

BurstCount | InternalRate | Source | SendSoftwareTrigger | IIviFgenTrigger Overview


SendSoftwareTrigger Method

IIviFgenTrigger.SendSoftwareTrigger Method

Sends a software trigger, which will cause the function generator to generate output.

[Visual Basic]
Sub SendSoftwareTrigger()
[C++]
HRESULT SendSoftwareTrigger();
[ANSI C]
HRESULT IIviFgenTrigger_SendSoftwareTrigger(
   IIviFgenTrigger* This);
[C#]
public void SendSoftwareTrigger();

Capability Group

IviFgenSoftwareTrigger

Also In This Interface

BurstCount | InternalRate | Source | SendSoftwareTrigger | IIviFgenTrigger Overview


IviFgenAMInternalWaveformEnum Enumeration

IVI FGen class-compliant values for AM Internal Waveform

Members

Member Name | Description
IviFgenAMInternalWaveformSine | The function generator uses a sinusoid waveform as the modulating waveform.
IviFgenAMInternalWaveformSquare | The function generator uses a square waveform as the modulating waveform.
IviFgenAMInternalWaveformTriangle | The function generator uses a triangle waveform as the modulating waveform.
IviFgenAMInternalWaveformRampUp | The function generator uses a positive ramp waveform as the modulating waveform.
IviFgenAMInternalWaveformRampDown | The function generator uses a negative ramp waveform as the modulating waveform.


IviFgenAMSourceEnum Enumeration

IVI FGen class-compliant values for AM Source

Members

Member Name | Description
IviFgenAMSourceInternal | The function generator uses an internally generated waveform as the modulating waveform. You use the AM Internal Depth, AM Internal Waveform, and AM Internal Frequency attributes to configure the internally generated modulating waveform.
IviFgenAMSourceExternal | The function generator uses a waveform from an external source as the modulating waveform.


IviFgenErrorCodesEnum Enumeration

IVI FGen class defined HRESULTS

Members

Member Name | Description
E_IVIFGEN_TRIGGER_NOT_SOFTWARE | The trigger source is not set to software trigger.
E_IVIFGEN_NO_WFMS_AVAILABLE | No Waveforms Available
E_IVIFGEN_WFM_IN_USE | Waveform In Use
E_IVIFGEN_NO_SEQS_AVAILABLE | No Sequences Available
E_IVIFGEN_SEQ_IN_USE | Sequence In Use


IviFgenFMInternalWaveformEnum Enumeration

IVI FGen class-compliant values for FM Internal Waveform

Members

Member Name | Description
IviFgenFMInternalWaveformSine | The function generator uses a sinusoid waveform as the modulating waveform.
IviFgenFMInternalWaveformSquare | The function generator uses a square waveform as the modulating waveform.
IviFgenFMInternalWaveformTriangle | The function generator uses a triangle waveform as the modulating waveform.
IviFgenFMInternalWaveformRampUp | The function generator uses a positive ramp waveform as the modulating waveform.
IviFgenFMInternalWaveformRampDown | The function generator uses a negative ramp waveform as the modulating waveform.


IviFgenFMSourceEnum Enumeration

IVI FGen class-compliant values for FM Source

Members

Member Name | Description
IviFgenFMSourceInternal | The function generator uses an internally generated waveform as the modulating waveform. You use the FM Internal Deviation, FM Internal Waveform, and FM Internal Frequency attributes to configure the internally generated modulating waveform.
IviFgenFMSourceExternal | The function generator uses a waveform from an external source as the modulating waveform.


IviFgenOperationModeEnum Enumeration

IVI FGen class-compliant values for output OperationMode

Members

Member Name | Description
IviFgenOperationModeContinuous | When in the Output Generation State, the function generator produces output continuously.
IviFgenOperationModeBurst | When in the Output Generation State, the function generator produces a burst of waveform cycles based on a trigger condition. A burst consists of a discrete number of waveform cycles. The user uses the attribute of the IviFgenTrigger Extension Group to configure the trigger, and the attributes of the IviFgenBurst extension group to configure how the function generator produces bursts.


IviFgenOutputModeEnum Enumeration

IVI FGen class-compliant values for output Mode

Members

Member Name | Description
IviFgenOutputModeFunction | The driver uses the attributes and functions of the IviFgenStdFunc extension group to configure the function generator's output signal.
IviFgenOutputModeArbitrary | The driver uses the attributes and functions of the IviFgenArbWfm extension group to configure the function generator's output signal.
IviFgenOutputModeSequence | The driver uses the attributes and functions of the IviFgenArbSeq extension group to configure the function generator's output signal.


IviFgenReferenceClockSourceEnum Enumeration

IVI FGen class-compliant values for output ReferenceClockSource

Members

Member Name | Description
IviFgenReferenceClockSourceInternal | The function generator produces the reference clock signal internally.
IviFgenReferenceClockSourceExternal | The function generator receives the reference clock signal from an external source.
IviFgenReferenceClockSourceRTSI | The function generator receives the reference clock signal from the RTSI clock source.


IviFgenTriggerSourceEnum Enumeration

IVI FGen class-compliant values for Trigger Source

Members

Member Name | Description
IviFgenTriggerSourceExternal | The function generator does not produce an output signal until it receives a trigger on its external trigger input terminal.
IviFgenTriggerSourceSoftware | The function generator does not produce an output signal until the Send Software Trigger function executes. Refer to the Standardized Cross Class Capabilities specification for a complete description of this value and the Send Software Trigger function.
IviFgenTriggerSourceInternal | The function generator does not produce an output signal until it receives a trigger from its internal trigger source.
IviFgenTriggerSourceTTL0 | The function generator does not produce an output signal until it receives a trigger from the TTL0 line.
IviFgenTriggerSourceTTL1 | The function generator does not produce an output signal until it receives a trigger from the TTL1 line.
IviFgenTriggerSourceTTL2 | The function generator does not produce an output signal until it receives a trigger from the TTL2 line.
IviFgenTriggerSourceTTL3 | The function generator does not produce an output signal until it receives a trigger from the TTL3 line.
IviFgenTriggerSourceTTL4 | The function generator does not produce an output signal until it receives a trigger from the TTL4 line.
IviFgenTriggerSourceTTL5 | The function generator does not produce an output signal until it receives a trigger from the TTL5 line.
IviFgenTriggerSourceTTL6 | The function generator does not produce an output signal until it receives a trigger from the TTL6 line.
IviFgenTriggerSourceTTL7 | The function generator does not produce an output signal until it receives a trigger from the TTL7 line.
IviFgenTriggerSourceECL0 | The function generator does not produce an output signal until it receives a trigger from the ECL0 line.
IviFgenTriggerSourceECL1 | The function generator does not produce an output signal until it receives a trigger from the ECL1 line.
IviFgenTriggerSourcePXIStar | The function generator does not produce an output signal until it receives a trigger from the PXI Star bus.
IviFgenTriggerSourceRTSI0 | The function generator does not produce an output signal until it receives a trigger from the RTSI 0 line.
IviFgenTriggerSourceRTSI1 | The function generator does not produce an output signal until it receives a trigger from the RTSI 1 line.
IviFgenTriggerSourceRTSI2 | The function generator does not produce an output signal until it receives a trigger from the RTSI 2 line.
IviFgenTriggerSourceRTSI3 | The function generator does not produce an output signal until it receives a trigger from the RTSI 3 line.
IviFgenTriggerSourceRTSI4 | The function generator does not produce an output signal until it receives a trigger from the RTSI 4 line.
IviFgenTriggerSourceRTSI5 | The function generator does not produce an output signal until it receives a trigger from the RTSI 5 line.
IviFgenTriggerSourceRTSI6 | The function generator does not produce an output signal until it receives a trigger from the RTSI 6 line.


IviFgenWaveformEnum Enumeration

IVI FGen class-compliant values for Standard Waveform

Members

Member Name | Description
IviFgenWaveformSine | Configures the function generator to produce a sinusoid waveform.
IviFgenWaveformSquare | Configures the function generator to produce a square waveform.
IviFgenWaveformTriangle | Configures the function generator to produce a triangular waveform.
IviFgenWaveformRampUp | Configures the function generator to produce a positive ramp waveform.
IviFgenWaveformRampDown | Configures the function generator to produce a negative ramp waveform.
IviFgenWaveformDC | Configures the function generator to produce a constant voltage.


Topic Not Found

No matching topic was found. The link may be out of date, incorrectly authored, or the topic may not be available in this release.

You may be able to find the topic by using the index or search tab instead.


Inherent Interface

IVI Inherent Interfaces

IIviDriver | IVI Driver root interface
IIviDriverIdentity | IVI Driver identity interface
IIviDriverOperation | IVI Driver operation interface
IIviDriverUtility | IVI Driver utility interface


Instrument Specific Interfaces


IviDriver_ErrorCodes Enumeration

IVI Driver (inherent features) defined HRESULTS

Members

Member Name | Description
S_IVI_SUCCESS | Success
E_IVI_CANNOT_RECOVER | Unrecoverable failure
E_IVI_INSTRUMENT_STATUS | Instrument error detected
E_IVI_CANNOT_OPEN_FILE | File could not be opened
E_IVI_READING_FILE | File could not be read
E_IVI_WRITING_FILE | File could not be written
E_IVI_INVALID_PATHNAME | The path name is invalid
E_IVI_INVALID_VALUE | Invalid value for parameter or property
E_IVI_METHOD_NOT_SUPPORTED | Method not supported
E_IVI_PROPERTY_NOT_SUPPORTED | Property not supported
E_IVI_VALUE_NOT_SUPPORTED | The enumeration value for the parameter is not supported
E_IVI_NOT_INITIALIZED | A connection to the instrument has not been initialized
E_IVI_UNKNOWN_CHANNEL_NAME | Channel or repeated capability name specified is not valid for the instrument.
E_IVI_TOO_MANY_OPEN_FILES | Too many files opened
E_IVI_CHANNEL_NAME_REQUIRED | Channel or repeated capability name required
E_IVI_MISSING_OPTION_NAME | The option string contains an entry without a name.
E_IVI_MISSING_OPTION_VALUE | The option string contains an entry without a value.
E_IVI_BAD_OPTION_NAME | The option string contains an entry with an unknown option name.
E_IVI_BAD_OPTION_VALUE | The option string contains an entry with an unknown option value.
E_IVI_OUT_OF_MEMORY | The necessary memory could not be allocated
E_IVI_OPERATION_PENDING | Operation in progress
E_IVI_NULL_POINTER | Null pointer passed for parameter or property
E_IVI_UNEXPECTED_RESPONSE | Unexpected response from the instrument
E_IVI_FILE_NOT_FOUND | File not found
E_IVI_INVALID_FILE_FORMAT | The file format is invalid
E_IVI_STATUS_NOT_AVAILABLE | The instrument status is not available
E_IVI_ID_QUERY_FAILED | Instrument ID query failed
E_IVI_RESET_FAILED | Instrument reset failed
E_IVI_RESOURCE_UNKNOWN | Insufficient location information or resource not present in the system.
E_IVI_ALREADY_INITIALIZED | The driver is already initialized
E_IVI_CANNOT_CHANGE_SIMULATION_STATE | The simulation state cannot be changed.
S_IVI_NSUP_ID_QUERY | Identification query not supported
S_IVI_NSUP_RESET | Reset operation not supported
S_IVI_NSUP_SELF_TEST | Self test operation not supported
S_IVI_NSUP_ERROR_QUERY | Error query operation not supported
S_IVI_NSUP_REV_QUERY | Revision query not supported


IIviDriver Interface

IVI Driver root interface

Methods

Initialize | Opens the I/O session to the instrument. Driver methods and properties that access the instrument are only accessible after Initialize is called. Initialize optionally performs a Reset and queries the instrument to validate the instrument model.
Close | Closes the I/O session to the instrument. Driver methods and properties that access the instrument are not accessible after Close is called.

Properties

DriverOperation | Pointer to the IIviDriverOperation interface
Identity | Pointer to the IIviDriverIdentity interface
Utility | Pointer to the IIviDriverUtility interface
Initialized | Initialized is True between a successful call to the Initialize method and a successful call to the Close method, and False at all other times.


IIviDriverIdentity Interface

IVI Driver identity interface

Properties

Description | A brief description of the implementing component. Description is limted to 256 bytes.
Revision | The revision of the implementing component. Refer to IVI 3.1, Section 3.1.2.2, for a description of revision syntax and semantics. Revision is limited to 256 bytes.
Vendor | The name of the vendor that supplies the implementing component. Vendor is limited to 256 bytes.
InstrumentManufacturer | The name of the manufacturer reported by the physical instrument. If Simulation is enabled or the instrument is not capable of reporting the name of the manufacturer, a string is returned that explains the condition. Manufacturer is limited to 256 bytes
InstrumentModel | The model number or name reported by the physical instrument. If Simulation is enabled or the instrument is not capable of reporting the model number or name, a string is returned that explains the condition. Model is limited to 256 bytes
InstrumentFirmwareRevision | The firmware revision reported by the physical instrument. If Simulation is enabled or the instrument is not capable of reporting the firmware revision, a string is returned that explains the condition.
Identifier | The case-sensitive unique identifier of the implementing IVI-COM instrument driver.
SupportedInstrumentModels | A comma-separated list of instrument models that the IVI specific driver can control. The string does not include an abbreviation for the manufacturer if it is the same for all models.
SpecificationMajorVersion | For IVI class-compliant drivers, the major version number of the instrument class specification. If the driver is not class compliant, the driver returns zero.
SpecificationMinorVersion | For IVI class-compliant drivers, the minor version number of the instrument class specification. If the driver is not class compliant, the driver returns zero.
GroupCapabilities | A comma-separated list of the class capability groups implemented by the driver. Capability group names are documented in the IVI class specifications. If the driver is not class compliant, the driver returns an empty string.


IIviDriverOperation Interface

IVI Driver operation interface

Methods

InvalidateAllAttributes | Invalidates all of the driver's cached values.
ClearInterchangeWarnings | Clears the list of interchangeability warnings that the IVI specific driver maintains.
GetNextInterchangeWarning | Returns the oldest warning from the interchange warning list. Records are only added to the list if InterchangeCheck is True.
ResetInterchangeCheck | Resets the interchangeability checking algorithms of the driver so that methods and properties that executed prior to calling this function have no affect on whether future calls to the driver generate interchangeability warnings.
GetNextCoercionRecord | Returns the oldest record from the coercion record list. Records are only added to the list if RecordCoercions is True.

Properties

LogicalName | Logical Name identifies a driver session in the Configuration Store. If Logical Name is not empty, the driver was initialized from information in the driver session. If it is empty, the driver was initialized without using the Configuration Store.
IoResourceDescriptor | The resource descriptor specifies the connection to a physical device. It is either specified in the Configuration Store or passed in the ResourceName parameter of the Initialize function. It is empty if the driver is not initialized.
Cache | Drivers may choose to always cache some instrument settings, never cache others, and optionally cache others, to avoid unecessary I/O to the instrument. If True, the driver caches optionally cached instrument settings.
InterchangeCheck | If True, the driver maintains a record of interchangeability warnings. If the driver does not support interchangeability checking, attempts to set InterchangeCheck to True return an error.
QueryInstrumentStatus | If True, the driver queries the instrument status at the end of each method or property that performs I/O to the instrument. If an error is reported, use ErrorQuery to retrieve error messages one at a time from the instrument.
RangeCheck | Drivers may choose to always validate some property/parameter values, never validate others, and optionally validate others, to avoid sending invalid commands to the instrument. If True, the driver performs optional validations.
RecordCoercions | If True, the driver keeps a list of the value coercions it makes for ViInt32 and ViReal64 attributes. If the driver does not support coercion recording, attempts to set RecordCoercions to True will return an error.
Simulate | If True, the driver does not perform I/O to the instrument, and returns simulated values for output parameters.
DriverSetup | The driver setup string. It is either specified in the Configuration Store or passed in the OptionString parameter of the Initialize function. Driver setup is empty if the driver is not initialized.


IIviDriverUtility Interface

IVI Driver utility interface

Methods

Reset | Places the instrument in a known state and configures instrument options on which the IVI specific driver depends (for example, enabling/disabling headers). For an IEEE 488.2 instrument, Reset sends the command string *RST to the instrument.
ResetWithDefaults | Does the equivalent of Reset and then, (1) disables class extension capability groups, (2) sets attributes to initial values defined by class specs, and (3) configures the driver to option string settings used when Initialize was last executed.
Disable | Quickly places the instrument in a state where it has no, or minimal, effect on the external system to which it is connected. This state is not necessarily a known state.
SelfTest | Performs an instrument self test, waits for the instrument to complete the test, and queries the instrument for the results. If the instrument passes the test, TestResult is zero and TestMessage is 'Self test passed'.
ErrorQuery | Queries the instrument and returns instrument specific error information. This function can be used when QueryInstrumentStatus is True to retrieve error details when the driver detects an instrument error.
LockObject | Obtains a multithread lock on the driver after waiting until all other execution threads have released their locks on the instrument session.
UnlockObject | Releases a previously obtained mutlithread lock.


Close Method

IIviDriver.Close Method

Closes the I/O session to the instrument. Driver methods and properties that access the instrument are not accessible after Close is called.

[Visual Basic]
Sub Close()
[C++]
HRESULT Close();
[ANSI C]
HRESULT IIviDriver_Close(
   IIviDriver* This);
[C#]
public void Close();

Capability Group

IviFgenBase

Related Items

Initialize

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Initialize | Close | IIviDriver Overview


DriverOperation Property

IIviDriver.DriverOperation Property

Pointer to the IIviDriverOperation interface

[Visual Basic]
Property Get DriverOperation() As IIviDriverOperation
[C++]
HRESULT get_DriverOperation(IIviDriverOperation** value);
[ANSI C]
HRESULT IIviDriver_get_DriverOperation(IIviDriver* This, IIviDriverOperation** value);
[C#]
public IIviDriverOperation DriverOperation {get;}

Capability Group

IviFgenBase

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Initialize | Close | IIviDriver Overview


Identity Property

IIviDriver.Identity Property

Pointer to the IIviDriverIdentity interface

[Visual Basic]
Property Get Identity() As IIviDriverIdentity
[C++]
HRESULT get_Identity(IIviDriverIdentity** value);
[ANSI C]
HRESULT IIviDriver_get_Identity(IIviDriver* This, IIviDriverIdentity** value);
[C#]
public IIviDriverIdentity Identity {get;}

Capability Group

IviFgenBase

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Initialize | Close | IIviDriver Overview


Initialize Method

IIviDriver.Initialize Method

Opens the I/O session to the instrument. Driver methods and properties that access the instrument are only accessible after Initialize is called. Initialize optionally performs a Reset and queries the instrument to validate the instrument model.

[Visual Basic]
Sub Initialize( _
   ResourceName As String, _
   IdQuery As Boolean, _
   Reset As Boolean, _
   OptionString As String _
)
[C++]
HRESULT Initialize(
   BSTR ResourceName,
   VARIANT_BOOL IdQuery,
   VARIANT_BOOL Reset,
   BSTR OptionString
);
[ANSI C]
HRESULT IIviDriver_Initialize(
   IIviDriver* This
   BSTR ResourceName,
   VARIANT_BOOL IdQuery,
   VARIANT_BOOL Reset,
   BSTR OptionString
);
[C#]
public void Initialize(
   string ResourceName,
   bool IdQuery,
   bool Reset,
   string OptionString
);

Parameters

ResourceName
An IVI logical name or an instrument specific string that identifies the address of the instrument, such as a VISA resource descriptor string.
IdQuery
Specifies whether to verify the ID of the instrument.
Reset
Specifies whether to reset the instrument.
OptionString
The user can use the OptionsString parameter to specify the initial values of certain IVI inherent attributes for the session.

Capability Group

IviFgenBase

Related Items

Close

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Initialize | Close | IIviDriver Overview


Initialized Property

IIviDriver.Initialized Property

Initialized is True between a successful call to the Initialize method and a successful call to the Close method, and False at all other times.

[Visual Basic]
Property Get Initialized() As Boolean
[C++]
HRESULT get_Initialized(VARIANT_BOOL* value);
[ANSI C]
HRESULT IIviDriver_get_Initialized(IIviDriver* This, VARIANT_BOOL* value);
[C#]
public bool Initialized {get;}

Capability Group

IviFgenBase

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Initialize | Close | IIviDriver Overview


Utility Property

IIviDriver.Utility Property

Pointer to the IIviDriverUtility interface

[Visual Basic]
Property Get Utility() As IIviDriverUtility
[C++]
HRESULT get_Utility(IIviDriverUtility** value);
[ANSI C]
HRESULT IIviDriver_get_Utility(IIviDriver* This, IIviDriverUtility** value);
[C#]
public IIviDriverUtility Utility {get;}

Capability Group

IviFgenBase

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Initialize | Close | IIviDriver Overview


Description Property

IIviDriverIdentity.Description Property

A brief description of the implementing component. Description is limted to 256 bytes.

[Visual Basic]
Property Get Description() As String
[C++]
HRESULT get_Description(BSTR* value);
[ANSI C]
HRESULT IIviDriverIdentity_get_Description(IIviDriverIdentity* This, BSTR* value);
[C#]
public string Description {get;}

Capability Group

IviFgenBase

Also In This Interface

Description | Revision | Vendor | InstrumentManufacturer | InstrumentModel | InstrumentFirmwareRevision | Identifier | SupportedInstrumentModels | SpecificationMajorVersion | SpecificationMinorVersion | GroupCapabilities | IIviDriverIdentity Overview


GroupCapabilities Property

IIviDriverIdentity.GroupCapabilities Property

A comma-separated list of the class capability groups implemented by the driver. Capability group names are documented in the IVI class specifications. If the driver is not class compliant, the driver returns an empty string.

[Visual Basic]
Property Get GroupCapabilities() As String
[C++]
HRESULT get_GroupCapabilities(BSTR* value);
[ANSI C]
HRESULT IIviDriverIdentity_get_GroupCapabilities(IIviDriverIdentity* This, BSTR* value);
[C#]
public string GroupCapabilities {get;}

Capability Group

IviFgenBase

Also In This Interface

Description | Revision | Vendor | InstrumentManufacturer | InstrumentModel | InstrumentFirmwareRevision | Identifier | SupportedInstrumentModels | SpecificationMajorVersion | SpecificationMinorVersion | GroupCapabilities | IIviDriverIdentity Overview


Identifier Property

IIviDriverIdentity.Identifier Property

The case-sensitive unique identifier of the implementing IVI-COM instrument driver.

[Visual Basic]
Property Get Identifier() As String
[C++]
HRESULT get_Identifier(BSTR* value);
[ANSI C]
HRESULT IIviDriverIdentity_get_Identifier(IIviDriverIdentity* This, BSTR* value);
[C#]
public string Identifier {get;}

Capability Group

IviFgenBase

Also In This Interface

Description | Revision | Vendor | InstrumentManufacturer | InstrumentModel | InstrumentFirmwareRevision | Identifier | SupportedInstrumentModels | SpecificationMajorVersion | SpecificationMinorVersion | GroupCapabilities | IIviDriverIdentity Overview


InstrumentFirmwareRevision Property

IIviDriverIdentity.InstrumentFirmwareRevision Property

The firmware revision reported by the physical instrument. If Simulation is enabled or the instrument is not capable of reporting the firmware revision, a string is returned that explains the condition.

[Visual Basic]
Property Get InstrumentFirmwareRevision() As String
[C++]
HRESULT get_InstrumentFirmwareRevision(BSTR* value);
[ANSI C]
HRESULT IIviDriverIdentity_get_InstrumentFirmwareRevision(IIviDriverIdentity* This, BSTR* value);
[C#]
public string InstrumentFirmwareRevision {get;}

Capability Group

IviFgenBase

Also In This Interface

Description | Revision | Vendor | InstrumentManufacturer | InstrumentModel | InstrumentFirmwareRevision | Identifier | SupportedInstrumentModels | SpecificationMajorVersion | SpecificationMinorVersion | GroupCapabilities | IIviDriverIdentity Overview


InstrumentManufacturer Property

IIviDriverIdentity.InstrumentManufacturer Property

The name of the manufacturer reported by the physical instrument. If Simulation is enabled or the instrument is not capable of reporting the name of the manufacturer, a string is returned that explains the condition. Manufacturer is limited to 256 bytes

[Visual Basic]
Property Get InstrumentManufacturer() As String
[C++]
HRESULT get_InstrumentManufacturer(BSTR* value);
[ANSI C]
HRESULT IIviDriverIdentity_get_InstrumentManufacturer(IIviDriverIdentity* This, BSTR* value);
[C#]
public string InstrumentManufacturer {get;}

Capability Group

IviFgenBase

Also In This Interface

Description | Revision | Vendor | InstrumentManufacturer | InstrumentModel | InstrumentFirmwareRevision | Identifier | SupportedInstrumentModels | SpecificationMajorVersion | SpecificationMinorVersion | GroupCapabilities | IIviDriverIdentity Overview


InstrumentModel Property

IIviDriverIdentity.InstrumentModel Property

The model number or name reported by the physical instrument. If Simulation is enabled or the instrument is not capable of reporting the model number or name, a string is returned that explains the condition. Model is limited to 256 bytes

[Visual Basic]
Property Get InstrumentModel() As String
[C++]
HRESULT get_InstrumentModel(BSTR* value);
[ANSI C]
HRESULT IIviDriverIdentity_get_InstrumentModel(IIviDriverIdentity* This, BSTR* value);
[C#]
public string InstrumentModel {get;}

Capability Group

IviFgenBase

Also In This Interface

Description | Revision | Vendor | InstrumentManufacturer | InstrumentModel | InstrumentFirmwareRevision | Identifier | SupportedInstrumentModels | SpecificationMajorVersion | SpecificationMinorVersion | GroupCapabilities | IIviDriverIdentity Overview


Revision Property

IIviDriverIdentity.Revision Property

The revision of the implementing component. Refer to IVI 3.1, Section 3.1.2.2, for a description of revision syntax and semantics. Revision is limited to 256 bytes.

[Visual Basic]
Property Get Revision() As String
[C++]
HRESULT get_Revision(BSTR* value);
[ANSI C]
HRESULT IIviDriverIdentity_get_Revision(IIviDriverIdentity* This, BSTR* value);
[C#]
public string Revision {get;}

Capability Group

IviFgenBase

Also In This Interface

Description | Revision | Vendor | InstrumentManufacturer | InstrumentModel | InstrumentFirmwareRevision | Identifier | SupportedInstrumentModels | SpecificationMajorVersion | SpecificationMinorVersion | GroupCapabilities | IIviDriverIdentity Overview


SpecificationMajorVersion Property

IIviDriverIdentity.SpecificationMajorVersion Property

For IVI class-compliant drivers, the major version number of the instrument class specification. If the driver is not class compliant, the driver returns zero.

[Visual Basic]
Property Get SpecificationMajorVersion() As Long
[C++]
HRESULT get_SpecificationMajorVersion(long* value);
[ANSI C]
HRESULT IIviDriverIdentity_get_SpecificationMajorVersion(IIviDriverIdentity* This, long* value);
[C#]
public long SpecificationMajorVersion {get;}

Capability Group

IviFgenBase

Also In This Interface

Description | Revision | Vendor | InstrumentManufacturer | InstrumentModel | InstrumentFirmwareRevision | Identifier | SupportedInstrumentModels | SpecificationMajorVersion | SpecificationMinorVersion | GroupCapabilities | IIviDriverIdentity Overview


SpecificationMinorVersion Property

IIviDriverIdentity.SpecificationMinorVersion Property

For IVI class-compliant drivers, the minor version number of the instrument class specification. If the driver is not class compliant, the driver returns zero.

[Visual Basic]
Property Get SpecificationMinorVersion() As Long
[C++]
HRESULT get_SpecificationMinorVersion(long* value);
[ANSI C]
HRESULT IIviDriverIdentity_get_SpecificationMinorVersion(IIviDriverIdentity* This, long* value);
[C#]
public long SpecificationMinorVersion {get;}

Capability Group

IviFgenBase

Also In This Interface

Description | Revision | Vendor | InstrumentManufacturer | InstrumentModel | InstrumentFirmwareRevision | Identifier | SupportedInstrumentModels | SpecificationMajorVersion | SpecificationMinorVersion | GroupCapabilities | IIviDriverIdentity Overview


SupportedInstrumentModels Property

IIviDriverIdentity.SupportedInstrumentModels Property

A comma-separated list of instrument models that the IVI specific driver can control. The string does not include an abbreviation for the manufacturer if it is the same for all models.

[Visual Basic]
Property Get SupportedInstrumentModels() As String
[C++]
HRESULT get_SupportedInstrumentModels(BSTR* value);
[ANSI C]
HRESULT IIviDriverIdentity_get_SupportedInstrumentModels(IIviDriverIdentity* This, BSTR* value);
[C#]
public string SupportedInstrumentModels {get;}

Capability Group

IviFgenBase

Also In This Interface

Description | Revision | Vendor | InstrumentManufacturer | InstrumentModel | InstrumentFirmwareRevision | Identifier | SupportedInstrumentModels | SpecificationMajorVersion | SpecificationMinorVersion | GroupCapabilities | IIviDriverIdentity Overview


Vendor Property

IIviDriverIdentity.Vendor Property

The name of the vendor that supplies the implementing component. Vendor is limited to 256 bytes.

[Visual Basic]
Property Get Vendor() As String
[C++]
HRESULT get_Vendor(BSTR* value);
[ANSI C]
HRESULT IIviDriverIdentity_get_Vendor(IIviDriverIdentity* This, BSTR* value);
[C#]
public string Vendor {get;}

Capability Group

IviFgenBase

Also In This Interface

Description | Revision | Vendor | InstrumentManufacturer | InstrumentModel | InstrumentFirmwareRevision | Identifier | SupportedInstrumentModels | SpecificationMajorVersion | SpecificationMinorVersion | GroupCapabilities | IIviDriverIdentity Overview


Cache Property

IIviDriverOperation.Cache Property

Drivers may choose to always cache some instrument settings, never cache others, and optionally cache others, to avoid unecessary I/O to the instrument. If True, the driver caches optionally cached instrument settings.

[Visual Basic]
Property Get Cache() As Boolean
Property Let Cache(value As Boolean)
[C++]
HRESULT get_Cache(VARIANT_BOOL* value);
HRESULT put_Cache(VARIANT_BOOL value);
[ANSI C]
HRESULT IIviDriverOperation_get_Cache(IIviDriverOperation* This, VARIANT_BOOL* value);
HRESULT IIviDriverOperation_put_Cache(IIviDriverOperation* This, VARIANT_BOOL value);
[C#]
public bool Cache {get; set;}

Capability Group

IviFgenBase

Related Items

InvalidateAllAttributes

Also In This Interface

LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


ClearInterchangeWarnings Method

IIviDriverOperation.ClearInterchangeWarnings Method

Clears the list of interchangeability warnings that the IVI specific driver maintains.

[Visual Basic]
Sub ClearInterchangeWarnings()
[C++]
HRESULT ClearInterchangeWarnings();
[ANSI C]
HRESULT IIviDriverOperation_ClearInterchangeWarnings(
   IIviDriverOperation* This);
[C#]
public void ClearInterchangeWarnings();

Capability Group

IviFgenBase

Related Items

GetNextInterchangeWarning | ResetInterchangeCheck | InterchangeCheck

Also In This Interface

LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


DriverSetup Property

IIviDriverOperation.DriverSetup Property

The driver setup string. It is either specified in the Configuration Store or passed in the OptionString parameter of the Initialize function. Driver setup is empty if the driver is not initialized.

[Visual Basic]
Property Get DriverSetup() As String
[C++]
HRESULT get_DriverSetup(BSTR* value);
[ANSI C]
HRESULT IIviDriverOperation_get_DriverSetup(IIviDriverOperation* This, BSTR* value);
[C#]
public string DriverSetup {get;}

Capability Group

IviFgenBase

Also In This Interface

LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


GetNextCoercionRecord Method

IIviDriverOperation.GetNextCoercionRecord Method

Returns the oldest record from the coercion record list. Records are only added to the list if RecordCoercions is True.

[Visual Basic]
Function GetNextCoercionRecord() As String
[C++]
HRESULT GetNextCoercionRecord(
   BSTR* CoercionRecord
);
[ANSI C]
HRESULT IIviDriverOperation_GetNextCoercionRecord(
   IIviDriverOperation* This
   BSTR* CoercionRecord
);
[C#]
public string GetNextCoercionRecord();

Parameters

CoercionRecord
The coercion record string shall contain the following information:
  • The name of the attribute that was coerced. This can be the generic name, the COM property name, or the C defined constant.
  • If the attribute is channel-based, the name of the channel. The channel name can be the specific driver channel string or the virtual channel name that the user specified.
  • If the attribute applies to a repeated capability, the name of the repeated capability. The name can be the specific driver repeated capability token or the virtual repeated capability name that the user specified.
  • The value that the user specified for the attribute.
  • The value to which the attribute was coerced.

    • Capability Group

    IviFgenBase

    Related Items

    RecordCoercions

    Also In This Interface

    LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


GetNextInterchangeWarning Method

IIviDriverOperation.GetNextInterchangeWarning Method

Returns the oldest warning from the interchange warning list. Records are only added to the list if InterchangeCheck is True.

[Visual Basic]
Function GetNextInterchangeWarning() As String
[C++]
HRESULT GetNextInterchangeWarning(
   BSTR* InterchangeWarning
);
[ANSI C]
HRESULT IIviDriverOperation_GetNextInterchangeWarning(
   IIviDriverOperation* This
   BSTR* InterchangeWarning
);
[C#]
public string GetNextInterchangeWarning();

Parameters

InterchangeWarning
A string describing the oldest interchangeability warning or empty string if no warrnings remain.

Capability Group

IviFgenBase

Related Items

ClearInterchangeWarnings | ResetInterchangeCheck | InterchangeCheck

Also In This Interface

LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


InterchangeCheck Property

IIviDriverOperation.InterchangeCheck Property

If True, the driver maintains a record of interchangeability warnings. If the driver does not support interchangeability checking, attempts to set InterchangeCheck to True return an error.

[Visual Basic]
Property Get InterchangeCheck() As Boolean
Property Let InterchangeCheck(value As Boolean)
[C++]
HRESULT get_InterchangeCheck(VARIANT_BOOL* value);
HRESULT put_InterchangeCheck(VARIANT_BOOL value);
[ANSI C]
HRESULT IIviDriverOperation_get_InterchangeCheck(IIviDriverOperation* This, VARIANT_BOOL* value);
HRESULT IIviDriverOperation_put_InterchangeCheck(IIviDriverOperation* This, VARIANT_BOOL value);
[C#]
public bool InterchangeCheck {get; set;}

Capability Group

IviFgenBase

Related Items

ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck

Also In This Interface

LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


InvalidateAllAttributes Method

IIviDriverOperation.InvalidateAllAttributes Method

Invalidates all of the driver's cached values.

[Visual Basic]
Sub InvalidateAllAttributes()
[C++]
HRESULT InvalidateAllAttributes();
[ANSI C]
HRESULT IIviDriverOperation_InvalidateAllAttributes(
   IIviDriverOperation* This);
[C#]
public void InvalidateAllAttributes();

Capability Group

IviFgenBase

Related Items

Cache

Also In This Interface

LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


IoResourceDescriptor Property

IIviDriverOperation.IoResourceDescriptor Property

The resource descriptor specifies the connection to a physical device. It is either specified in the Configuration Store or passed in the ResourceName parameter of the Initialize function. It is empty if the driver is not initialized.

[Visual Basic]
Property Get IoResourceDescriptor() As String
[C++]
HRESULT get_IoResourceDescriptor(BSTR* value);
[ANSI C]
HRESULT IIviDriverOperation_get_IoResourceDescriptor(IIviDriverOperation* This, BSTR* value);
[C#]
public string IoResourceDescriptor {get;}

Capability Group

IviFgenBase

Also In This Interface

LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


LogicalName Property

IIviDriverOperation.LogicalName Property

Logical Name identifies a driver session in the Configuration Store. If Logical Name is not empty, the driver was initialized from information in the driver session. If it is empty, the driver was initialized without using the Configuration Store.

[Visual Basic]
Property Get LogicalName() As String
[C++]
HRESULT get_LogicalName(BSTR* value);
[ANSI C]
HRESULT IIviDriverOperation_get_LogicalName(IIviDriverOperation* This, BSTR* value);
[C#]
public string LogicalName {get;}

Capability Group

IviFgenBase

Also In This Interface

LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


QueryInstrumentStatus Property

IIviDriverOperation.QueryInstrumentStatus Property

If True, the driver queries the instrument status at the end of each method or property that performs I/O to the instrument. If an error is reported, use ErrorQuery to retrieve error messages one at a time from the instrument.

[Visual Basic]
Property Get QueryInstrumentStatus() As Boolean
Property Let QueryInstrumentStatus(value As Boolean)
[C++]
HRESULT get_QueryInstrumentStatus(VARIANT_BOOL* value);
HRESULT put_QueryInstrumentStatus(VARIANT_BOOL value);
[ANSI C]
HRESULT IIviDriverOperation_get_QueryInstrumentStatus(IIviDriverOperation* This, VARIANT_BOOL* value);
HRESULT IIviDriverOperation_put_QueryInstrumentStatus(IIviDriverOperation* This, VARIANT_BOOL value);
[C#]
public bool QueryInstrumentStatus {get; set;}

Capability Group

IviFgenBase

Also In This Interface

LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


RangeCheck Property

IIviDriverOperation.RangeCheck Property

Drivers may choose to always validate some property/parameter values, never validate others, and optionally validate others, to avoid sending invalid commands to the instrument. If True, the driver performs optional validations.

[Visual Basic]
Property Get RangeCheck() As Boolean
Property Let RangeCheck(value As Boolean)
[C++]
HRESULT get_RangeCheck(VARIANT_BOOL* value);
HRESULT put_RangeCheck(VARIANT_BOOL value);
[ANSI C]
HRESULT IIviDriverOperation_get_RangeCheck(IIviDriverOperation* This, VARIANT_BOOL* value);
HRESULT IIviDriverOperation_put_RangeCheck(IIviDriverOperation* This, VARIANT_BOOL value);
[C#]
public bool RangeCheck {get; set;}

Capability Group

IviFgenBase

Also In This Interface

LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


RecordCoercions Property

IIviDriverOperation.RecordCoercions Property

If True, the driver keeps a list of the value coercions it makes for ViInt32 and ViReal64 attributes. If the driver does not support coercion recording, attempts to set RecordCoercions to True will return an error.

[Visual Basic]
Property Get RecordCoercions() As Boolean
Property Let RecordCoercions(value As Boolean)
[C++]
HRESULT get_RecordCoercions(VARIANT_BOOL* value);
HRESULT put_RecordCoercions(VARIANT_BOOL value);
[ANSI C]
HRESULT IIviDriverOperation_get_RecordCoercions(IIviDriverOperation* This, VARIANT_BOOL* value);
HRESULT IIviDriverOperation_put_RecordCoercions(IIviDriverOperation* This, VARIANT_BOOL value);
[C#]
public bool RecordCoercions {get; set;}

Capability Group

IviFgenBase

Related Items

GetNextCoercionRecord

Also In This Interface

LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


ResetInterchangeCheck Method

IIviDriverOperation.ResetInterchangeCheck Method

Resets the interchangeability checking algorithms of the driver so that methods and properties that executed prior to calling this function have no affect on whether future calls to the driver generate interchangeability warnings.

[Visual Basic]
Sub ResetInterchangeCheck()
[C++]
HRESULT ResetInterchangeCheck();
[ANSI C]
HRESULT IIviDriverOperation_ResetInterchangeCheck(
   IIviDriverOperation* This);
[C#]
public void ResetInterchangeCheck();

Capability Group

IviFgenBase

Related Items

GetNextInterchangeWarning | ClearInterchangeWarnings | InterchangeCheck

Also In This Interface

LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


Simulate Property

IIviDriverOperation.Simulate Property

If True, the driver does not perform I/O to the instrument, and returns simulated values for output parameters.

[Visual Basic]
Property Get Simulate() As Boolean
Property Let Simulate(value As Boolean)
[C++]
HRESULT get_Simulate(VARIANT_BOOL* value);
HRESULT put_Simulate(VARIANT_BOOL value);
[ANSI C]
HRESULT IIviDriverOperation_get_Simulate(IIviDriverOperation* This, VARIANT_BOOL* value);
HRESULT IIviDriverOperation_put_Simulate(IIviDriverOperation* This, VARIANT_BOOL value);
[C#]
public bool Simulate {get; set;}

Capability Group

IviFgenBase

Also In This Interface

LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


Disable Method

IIviDriverUtility.Disable Method

Quickly places the instrument in a state where it has no, or minimal, effect on the external system to which it is connected. This state is not necessarily a known state.

[Visual Basic]
Sub Disable()
[C++]
HRESULT Disable();
[ANSI C]
HRESULT IIviDriverUtility_Disable(
   IIviDriverUtility* This);
[C#]
public void Disable();

Capability Group

IviFgenBase

Also In This Interface

Reset | ResetWithDefaults | Disable | SelfTest | ErrorQuery | LockObject | UnlockObject | IIviDriverUtility Overview


ErrorQuery Method

IIviDriverUtility.ErrorQuery Method

Queries the instrument and returns instrument specific error information. This function can be used when QueryInstrumentStatus is True to retrieve error details when the driver detects an instrument error.

[Visual Basic]
Sub ErrorQuery( _
   ErrorCode As Long, _
   ErrorMessage As String _
)
[C++]
HRESULT ErrorQuery(
   long* ErrorCode,
   BSTR* ErrorMessage
);
[ANSI C]
HRESULT IIviDriverUtility_ErrorQuery(
   IIviDriverUtility* This
   long* ErrorCode,
   BSTR* ErrorMessage
);
[C#]
public void ErrorQuery(
   long ErrorCode,
   string ErrorMessage
);

Parameters

ErrorCode
Instrument error code
ErrorMessage
Instrument error message

Capability Group

IviFgenBase

Also In This Interface

Reset | ResetWithDefaults | Disable | SelfTest | ErrorQuery | LockObject | UnlockObject | IIviDriverUtility Overview


LockObject Method

IIviDriverUtility.LockObject Method

Obtains a multithread lock on the driver after waiting until all other execution threads have released their locks on the instrument session.

[Visual Basic]
Sub LockObject()
[C++]
HRESULT LockObject();
[ANSI C]
HRESULT IIviDriverUtility_LockObject(
   IIviDriverUtility* This);
[C#]
public void LockObject();

Capability Group

IviFgenBase

Related Items

UnlockObject

Also In This Interface

Reset | ResetWithDefaults | Disable | SelfTest | ErrorQuery | LockObject | UnlockObject | IIviDriverUtility Overview


Reset Method

IIviDriverUtility.Reset Method

Places the instrument in a known state and configures instrument options on which the IVI specific driver depends (for example, enabling/disabling headers). For an IEEE 488.2 instrument, Reset sends the command string *RST to the instrument.

[Visual Basic]
Sub Reset()
[C++]
HRESULT Reset();
[ANSI C]
HRESULT IIviDriverUtility_Reset(
   IIviDriverUtility* This);
[C#]
public void Reset();

Capability Group

IviFgenBase

Related Items

ResetWithDefaults

Also In This Interface

Reset | ResetWithDefaults | Disable | SelfTest | ErrorQuery | LockObject | UnlockObject | IIviDriverUtility Overview


ResetWithDefaults Method

IIviDriverUtility.ResetWithDefaults Method

Does the equivalent of Reset and then, (1) disables class extension capability groups, (2) sets attributes to initial values defined by class specs, and (3) configures the driver to option string settings used when Initialize was last executed.

[Visual Basic]
Sub ResetWithDefaults()
[C++]
HRESULT ResetWithDefaults();
[ANSI C]
HRESULT IIviDriverUtility_ResetWithDefaults(
   IIviDriverUtility* This);
[C#]
public void ResetWithDefaults();

Capability Group

IviFgenBase

Also In This Interface

Reset | ResetWithDefaults | Disable | SelfTest | ErrorQuery | LockObject | UnlockObject | IIviDriverUtility Overview


SelfTest Method

IIviDriverUtility.SelfTest Method

Performs an instrument self test, waits for the instrument to complete the test, and queries the instrument for the results. If the instrument passes the test, TestResult is zero and TestMessage is 'Self test passed'.

[Visual Basic]
Sub SelfTest( _
   TestResult As Long, _
   TestMessage As String _
)
[C++]
HRESULT SelfTest(
   long* TestResult,
   BSTR* TestMessage
);
[ANSI C]
HRESULT IIviDriverUtility_SelfTest(
   IIviDriverUtility* This
   long* TestResult,
   BSTR* TestMessage
);
[C#]
public void SelfTest(
   long TestResult,
   string TestMessage
);

Parameters

TestResult
The numeric result from the self test operation. 0 = no error (test passed)
TestMessage
The self test status message

Capability Group

IviFgenBase

Also In This Interface

Reset | ResetWithDefaults | Disable | SelfTest | ErrorQuery | LockObject | UnlockObject | IIviDriverUtility Overview


UnlockObject Method

IIviDriverUtility.UnlockObject Method

Releases a previously obtained mutlithread lock.

[Visual Basic]
Sub UnlockObject()
[C++]
HRESULT UnlockObject();
[ANSI C]
HRESULT IIviDriverUtility_UnlockObject(
   IIviDriverUtility* This);
[C#]
public void UnlockObject();

Capability Group

IviFgenBase

Related Items

LockObject

Also In This Interface

Reset | ResetWithDefaults | Disable | SelfTest | ErrorQuery | LockObject | UnlockObject | IIviDriverUtility Overview