IviDriver Reference

© 2003 IVI Foundation

Welcome to the IVI-COM Inherent Capabilities Reference

This section contains the reference material for the inherent capablity intefaces.

This help hierarchy matches the COM hierarchy defined in the inherent capabilities specification, available on the IVI Foundation Web Site. The COM hierarchy groups related capabilities into common interfaces.


Inherent Interface

IVI Inherent Interfaces

IIviDriver | IVI Driver root interface
IIviDriverIdentity | IVI Driver identity interface
IIviDriverOperation | IVI Driver operation interface
IIviDriverUtility | IVI Driver utility interface


IIviDriver Interface

IVI Driver root interface

Properties

DriverOperation | Pointer to the IIviDriverOperation interface
Identity | Pointer to the IIviDriverIdentity interface
Utility | Pointer to the IIviDriverUtility interface
Initialized | Initialized is True between a successful call to the Initialize method and a successful call to the Close method, and False at all other times.

Methods

Initialize | Opens the I/O session to the instrument. Driver methods and properties that access the instrument are only accessible after Initialize is called. Initialize optionally performs a Reset and queries the instrument to validate the instrument model.
Close | Closes the I/O session to the instrument. Driver methods and properties that access the instrument are not accessible after Close is called.


DriverOperation Property

IIviDriver.DriverOperation Property

Pointer to the IIviDriverOperation interface

[Visual Basic]
Property Get DriverOperation() As IIviDriverOperation
[C++]
HRESULT get_DriverOperation(IIviDriverOperation** value);
[ANSI C]
HRESULT IIviDriver_get_DriverOperation(IIviDriver* This, IIviDriverOperation** value);
[C#]
public IIviDriverOperation DriverOperation {get;}

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Initialize | Close | IIviDriver Overview


Identity Property

IIviDriver.Identity Property

Pointer to the IIviDriverIdentity interface

[Visual Basic]
Property Get Identity() As IIviDriverIdentity
[C++]
HRESULT get_Identity(IIviDriverIdentity** value);
[ANSI C]
HRESULT IIviDriver_get_Identity(IIviDriver* This, IIviDriverIdentity** value);
[C#]
public IIviDriverIdentity Identity {get;}

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Initialize | Close | IIviDriver Overview


Utility Property

IIviDriver.Utility Property

Pointer to the IIviDriverUtility interface

[Visual Basic]
Property Get Utility() As IIviDriverUtility
[C++]
HRESULT get_Utility(IIviDriverUtility** value);
[ANSI C]
HRESULT IIviDriver_get_Utility(IIviDriver* This, IIviDriverUtility** value);
[C#]
public IIviDriverUtility Utility {get;}

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Initialize | Close | IIviDriver Overview


Initialized Property

IIviDriver.Initialized Property

Initialized is True between a successful call to the Initialize method and a successful call to the Close method, and False at all other times.

[Visual Basic]
Property Get Initialized() As Boolean
[C++]
HRESULT get_Initialized(VARIANT_BOOL* value);
[ANSI C]
HRESULT IIviDriver_get_Initialized(IIviDriver* This, VARIANT_BOOL* value);
[C#]
public bool Initialized {get;}

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Initialize | Close | IIviDriver Overview


Initialize Method

IIviDriver.Initialize Method

Opens the I/O session to the instrument. Driver methods and properties that access the instrument are only accessible after Initialize is called. Initialize optionally performs a Reset and queries the instrument to validate the instrument model.

[Visual Basic]
Sub Initialize( _
   ResourceName As String, _
   IdQuery As Boolean, _
   Reset As Boolean, _
   OptionString As String _
)
[C++]
HRESULT Initialize(
   BSTR ResourceName,
   VARIANT_BOOL IdQuery,
   VARIANT_BOOL Reset,
   BSTR OptionString
);
[ANSI C]
HRESULT IIviDriver_Initialize(
   IIviDriver* This
   BSTR ResourceName,
   VARIANT_BOOL IdQuery,
   VARIANT_BOOL Reset,
   BSTR OptionString
);
[C#]
public void Initialize(
   string ResourceName,
   bool IdQuery,
   bool Reset,
   string OptionString
);

Parameters

ResourceName
An IVI logical name or an instrument specific string that identifies the address of the instrument, such as a VISA resource descriptor string.
IdQuery
Specifies whether to verify the ID of the instrument.
Reset
Specifies whether to reset the instrument.
OptionString
The user can use the OptionsString parameter to specify the initial values of certain IVI inherent attributes for the session.

Related Items

Close

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Initialize | Close | IIviDriver Overview


Close Method

IIviDriver.Close Method

Closes the I/O session to the instrument. Driver methods and properties that access the instrument are not accessible after Close is called.

[Visual Basic]
Sub Close()
[C++]
HRESULT Close();
[ANSI C]
HRESULT IIviDriver_Close(
   IIviDriver* This);
[C#]
public void Close();

Related Items

Initialize

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Initialize | Close | IIviDriver Overview


IIviDriverIdentity Interface

IVI Driver identity interface

Properties

Description | A brief description of the implementing component. Description is limted to 256 bytes.
Revision | The revision of the implementing component. Refer to IVI-3.2, Section 3.1.2.2, Additional Compliance Rules for Revision String Attributes, for a description of revision syntax and semantics. Revision is limited to 256 bytes.
Vendor | The name of the vendor that supplies the implementing component. Vendor is limited to 256 bytes.
InstrumentManufacturer | The name of the manufacturer reported by the physical instrument. If Simulation is enabled or the instrument is not capable of reporting the name of the manufacturer, a string is returned that explains the condition. Manufacturer is limited to 256 bytes
InstrumentModel | The model number or name reported by the physical instrument. If Simulation is enabled or the instrument is not capable of reporting the model number or name, a string is returned that explains the condition. Model is limited to 256 bytes
InstrumentFirmwareRevision | The firmware revision reported by the physical instrument. If Simulation is enabled or the instrument is not capable of reporting the firmware revision, a string is returned that explains the condition.
Identifier | The case-sensitive unique identifier of the implementing IVI-COM instrument driver.
SupportedInstrumentModels | A comma-separated list of instrument models that the IVI specific driver can control. The string does not include an abbreviation for the manufacturer if it is the same for all models.
SpecificationMajorVersion | For IVI class-compliant drivers, the major version number of the instrument class specification. If the driver is not class compliant, the value of this property is zero.
SpecificationMinorVersion | For IVI class-compliant drivers, the minor version number of the instrument class specification. If the driver is not class compliant, the value of this property is zero.
GroupCapabilities | A comma-separated list of the class capability groups implemented by the driver. Capability group names are documented in the IVI class specifications. If the driver is not class compliant, the driver returns an empty string.


Description Property

IIviDriverIdentity.Description Property

A brief description of the implementing component. Description is limted to 256 bytes.

[Visual Basic]
Property Get Description() As String
[C++]
HRESULT get_Description(BSTR* value);
[ANSI C]
HRESULT IIviDriverIdentity_get_Description(IIviDriverIdentity* This, BSTR* value);
[C#]
public string Description {get;}

Also In This Interface

Description | Revision | Vendor | InstrumentManufacturer | InstrumentModel | InstrumentFirmwareRevision | Identifier | SupportedInstrumentModels | SpecificationMajorVersion | SpecificationMinorVersion | GroupCapabilities | IIviDriverIdentity Overview


Revision Property

IIviDriverIdentity.Revision Property

The revision of the implementing component. Refer to IVI-3.2, Section 3.1.2.2, Additional Compliance Rules for Revision String Attributes, for a description of revision syntax and semantics. Revision is limited to 256 bytes.

[Visual Basic]
Property Get Revision() As String
[C++]
HRESULT get_Revision(BSTR* value);
[ANSI C]
HRESULT IIviDriverIdentity_get_Revision(IIviDriverIdentity* This, BSTR* value);
[C#]
public string Revision {get;}

Also In This Interface

Description | Revision | Vendor | InstrumentManufacturer | InstrumentModel | InstrumentFirmwareRevision | Identifier | SupportedInstrumentModels | SpecificationMajorVersion | SpecificationMinorVersion | GroupCapabilities | IIviDriverIdentity Overview


Vendor Property

IIviDriverIdentity.Vendor Property

The name of the vendor that supplies the implementing component. Vendor is limited to 256 bytes.

[Visual Basic]
Property Get Vendor() As String
[C++]
HRESULT get_Vendor(BSTR* value);
[ANSI C]
HRESULT IIviDriverIdentity_get_Vendor(IIviDriverIdentity* This, BSTR* value);
[C#]
public string Vendor {get;}

Also In This Interface

Description | Revision | Vendor | InstrumentManufacturer | InstrumentModel | InstrumentFirmwareRevision | Identifier | SupportedInstrumentModels | SpecificationMajorVersion | SpecificationMinorVersion | GroupCapabilities | IIviDriverIdentity Overview


InstrumentManufacturer Property

IIviDriverIdentity.InstrumentManufacturer Property

The name of the manufacturer reported by the physical instrument. If Simulation is enabled or the instrument is not capable of reporting the name of the manufacturer, a string is returned that explains the condition. Manufacturer is limited to 256 bytes

[Visual Basic]
Property Get InstrumentManufacturer() As String
[C++]
HRESULT get_InstrumentManufacturer(BSTR* value);
[ANSI C]
HRESULT IIviDriverIdentity_get_InstrumentManufacturer(IIviDriverIdentity* This, BSTR* value);
[C#]
public string InstrumentManufacturer {get;}

Also In This Interface

Description | Revision | Vendor | InstrumentManufacturer | InstrumentModel | InstrumentFirmwareRevision | Identifier | SupportedInstrumentModels | SpecificationMajorVersion | SpecificationMinorVersion | GroupCapabilities | IIviDriverIdentity Overview


InstrumentModel Property

IIviDriverIdentity.InstrumentModel Property

The model number or name reported by the physical instrument. If Simulation is enabled or the instrument is not capable of reporting the model number or name, a string is returned that explains the condition. Model is limited to 256 bytes

[Visual Basic]
Property Get InstrumentModel() As String
[C++]
HRESULT get_InstrumentModel(BSTR* value);
[ANSI C]
HRESULT IIviDriverIdentity_get_InstrumentModel(IIviDriverIdentity* This, BSTR* value);
[C#]
public string InstrumentModel {get;}

Also In This Interface

Description | Revision | Vendor | InstrumentManufacturer | InstrumentModel | InstrumentFirmwareRevision | Identifier | SupportedInstrumentModels | SpecificationMajorVersion | SpecificationMinorVersion | GroupCapabilities | IIviDriverIdentity Overview


InstrumentFirmwareRevision Property

IIviDriverIdentity.InstrumentFirmwareRevision Property

The firmware revision reported by the physical instrument. If Simulation is enabled or the instrument is not capable of reporting the firmware revision, a string is returned that explains the condition.

[Visual Basic]
Property Get InstrumentFirmwareRevision() As String
[C++]
HRESULT get_InstrumentFirmwareRevision(BSTR* value);
[ANSI C]
HRESULT IIviDriverIdentity_get_InstrumentFirmwareRevision(IIviDriverIdentity* This, BSTR* value);
[C#]
public string InstrumentFirmwareRevision {get;}

Also In This Interface

Description | Revision | Vendor | InstrumentManufacturer | InstrumentModel | InstrumentFirmwareRevision | Identifier | SupportedInstrumentModels | SpecificationMajorVersion | SpecificationMinorVersion | GroupCapabilities | IIviDriverIdentity Overview


Identifier Property

IIviDriverIdentity.Identifier Property

The case-sensitive unique identifier of the implementing IVI-COM instrument driver.

[Visual Basic]
Property Get Identifier() As String
[C++]
HRESULT get_Identifier(BSTR* value);
[ANSI C]
HRESULT IIviDriverIdentity_get_Identifier(IIviDriverIdentity* This, BSTR* value);
[C#]
public string Identifier {get;}

Also In This Interface

Description | Revision | Vendor | InstrumentManufacturer | InstrumentModel | InstrumentFirmwareRevision | Identifier | SupportedInstrumentModels | SpecificationMajorVersion | SpecificationMinorVersion | GroupCapabilities | IIviDriverIdentity Overview


SupportedInstrumentModels Property

IIviDriverIdentity.SupportedInstrumentModels Property

A comma-separated list of instrument models that the IVI specific driver can control. The string does not include an abbreviation for the manufacturer if it is the same for all models.

[Visual Basic]
Property Get SupportedInstrumentModels() As String
[C++]
HRESULT get_SupportedInstrumentModels(BSTR* value);
[ANSI C]
HRESULT IIviDriverIdentity_get_SupportedInstrumentModels(IIviDriverIdentity* This, BSTR* value);
[C#]
public string SupportedInstrumentModels {get;}

Also In This Interface

Description | Revision | Vendor | InstrumentManufacturer | InstrumentModel | InstrumentFirmwareRevision | Identifier | SupportedInstrumentModels | SpecificationMajorVersion | SpecificationMinorVersion | GroupCapabilities | IIviDriverIdentity Overview


SpecificationMajorVersion Property

IIviDriverIdentity.SpecificationMajorVersion Property

For IVI class-compliant drivers, the major version number of the instrument class specification. If the driver is not class compliant, the value of this property is zero.

[Visual Basic]
Property Get SpecificationMajorVersion() As Long
[C++]
HRESULT get_SpecificationMajorVersion(long* value);
[ANSI C]
HRESULT IIviDriverIdentity_get_SpecificationMajorVersion(IIviDriverIdentity* This, long* value);
[C#]
public long SpecificationMajorVersion {get;}

Also In This Interface

Description | Revision | Vendor | InstrumentManufacturer | InstrumentModel | InstrumentFirmwareRevision | Identifier | SupportedInstrumentModels | SpecificationMajorVersion | SpecificationMinorVersion | GroupCapabilities | IIviDriverIdentity Overview


SpecificationMinorVersion Property

IIviDriverIdentity.SpecificationMinorVersion Property

For IVI class-compliant drivers, the minor version number of the instrument class specification. If the driver is not class compliant, the value of this property is zero.

[Visual Basic]
Property Get SpecificationMinorVersion() As Long
[C++]
HRESULT get_SpecificationMinorVersion(long* value);
[ANSI C]
HRESULT IIviDriverIdentity_get_SpecificationMinorVersion(IIviDriverIdentity* This, long* value);
[C#]
public long SpecificationMinorVersion {get;}

Also In This Interface

Description | Revision | Vendor | InstrumentManufacturer | InstrumentModel | InstrumentFirmwareRevision | Identifier | SupportedInstrumentModels | SpecificationMajorVersion | SpecificationMinorVersion | GroupCapabilities | IIviDriverIdentity Overview


GroupCapabilities Property

IIviDriverIdentity.GroupCapabilities Property

A comma-separated list of the class capability groups implemented by the driver. Capability group names are documented in the IVI class specifications. If the driver is not class compliant, the driver returns an empty string.

[Visual Basic]
Property Get GroupCapabilities() As String
[C++]
HRESULT get_GroupCapabilities(BSTR* value);
[ANSI C]
HRESULT IIviDriverIdentity_get_GroupCapabilities(IIviDriverIdentity* This, BSTR* value);
[C#]
public string GroupCapabilities {get;}

Also In This Interface

Description | Revision | Vendor | InstrumentManufacturer | InstrumentModel | InstrumentFirmwareRevision | Identifier | SupportedInstrumentModels | SpecificationMajorVersion | SpecificationMinorVersion | GroupCapabilities | IIviDriverIdentity Overview


IIviDriverOperation Interface

IVI Driver operation interface

Properties

LogicalName | Logical Name identifies a driver session in the Configuration Store. If Logical Name is not empty, the driver was initialized from information in the driver session. If it is empty, the driver was initialized without using the Configuration Store.
IoResourceDescriptor | The resource descriptor specifies the connection to a physical device. It is either specified in the Configuration Store or passed in the ResourceName parameter of the Initialize function. It is empty if the driver is not initialized.
Cache | Drivers may choose to always cache some instrument settings, never cache others, and optionally cache others, to avoid unecessary I/O to the instrument. If True, the driver caches optionally cached instrument settings.
InterchangeCheck | If True, the driver maintains a record of interchangeability warnings. If the driver does not support interchangeability checking, attempts to set InterchangeCheck to True return an error.
QueryInstrumentStatus | If True, the driver queries the instrument status at the end of each method or property that performs I/O to the instrument. If an error is reported, use ErrorQuery to retrieve error messages one at a time from the instrument.
RangeCheck | Drivers may choose to always validate some property/parameter values, never validate others, and optionally validate others, to avoid sending invalid commands to the instrument. If True, the driver performs optional validations.
RecordCoercions | If True, the driver keeps a list of the value coercions it makes for ViInt32 and ViReal64 attributes. If the driver does not support coercion recording, attempts to set RecordCoercions to True will return an error.
Simulate | If True, the driver does not perform I/O to the instrument, and returns simulated values for output parameters.
DriverSetup | The driver setup string. It is either specified in the Configuration Store or passed in the OptionString parameter of the Initialize function. Driver setup is empty if the driver is not initialized.

Methods

InvalidateAllAttributes | Invalidates all of the driver's cached values.
ClearInterchangeWarnings | Clears the list of interchangeability warnings that the IVI specific driver maintains.
GetNextInterchangeWarning | Returns the oldest warning from the interchange warning list. Records are only added to the list if InterchangeCheck is True.
ResetInterchangeCheck | Resets the interchangeability checking algorithms of the driver so that methods and properties that executed prior to calling this function have no affect on whether future calls to the driver generate interchangeability warnings.
GetNextCoercionRecord | Returns the oldest record from the coercion record list. Records are only added to the list if RecordCoercions is True.


LogicalName Property

IIviDriverOperation.LogicalName Property

Logical Name identifies a driver session in the Configuration Store. If Logical Name is not empty, the driver was initialized from information in the driver session. If it is empty, the driver was initialized without using the Configuration Store.

[Visual Basic]
Property Get LogicalName() As String
[C++]
HRESULT get_LogicalName(BSTR* value);
[ANSI C]
HRESULT IIviDriverOperation_get_LogicalName(IIviDriverOperation* This, BSTR* value);
[C#]
public string LogicalName {get;}

Also In This Interface

LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


IoResourceDescriptor Property

IIviDriverOperation.IoResourceDescriptor Property

The resource descriptor specifies the connection to a physical device. It is either specified in the Configuration Store or passed in the ResourceName parameter of the Initialize function. It is empty if the driver is not initialized.

[Visual Basic]
Property Get IoResourceDescriptor() As String
[C++]
HRESULT get_IoResourceDescriptor(BSTR* value);
[ANSI C]
HRESULT IIviDriverOperation_get_IoResourceDescriptor(IIviDriverOperation* This, BSTR* value);
[C#]
public string IoResourceDescriptor {get;}

Also In This Interface

LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


Cache Property

IIviDriverOperation.Cache Property

Drivers may choose to always cache some instrument settings, never cache others, and optionally cache others, to avoid unecessary I/O to the instrument. If True, the driver caches optionally cached instrument settings.

[Visual Basic]
Property Get Cache() As Boolean
Property Let Cache(value As Boolean)
[C++]
HRESULT get_Cache(VARIANT_BOOL* value);
HRESULT put_Cache(VARIANT_BOOL value);
[ANSI C]
HRESULT IIviDriverOperation_get_Cache(IIviDriverOperation* This, VARIANT_BOOL* value);
HRESULT IIviDriverOperation_put_Cache(IIviDriverOperation* This, VARIANT_BOOL value);
[C#]
public bool Cache {get; set;}

Related Items

InvalidateAllAttributes

Also In This Interface

LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


InterchangeCheck Property

IIviDriverOperation.InterchangeCheck Property

If True, the driver maintains a record of interchangeability warnings. If the driver does not support interchangeability checking, attempts to set InterchangeCheck to True return an error.

[Visual Basic]
Property Get InterchangeCheck() As Boolean
Property Let InterchangeCheck(value As Boolean)
[C++]
HRESULT get_InterchangeCheck(VARIANT_BOOL* value);
HRESULT put_InterchangeCheck(VARIANT_BOOL value);
[ANSI C]
HRESULT IIviDriverOperation_get_InterchangeCheck(IIviDriverOperation* This, VARIANT_BOOL* value);
HRESULT IIviDriverOperation_put_InterchangeCheck(IIviDriverOperation* This, VARIANT_BOOL value);
[C#]
public bool InterchangeCheck {get; set;}

Related Items

ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck

Also In This Interface

LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


QueryInstrumentStatus Property

IIviDriverOperation.QueryInstrumentStatus Property

If True, the driver queries the instrument status at the end of each method or property that performs I/O to the instrument. If an error is reported, use ErrorQuery to retrieve error messages one at a time from the instrument.

[Visual Basic]
Property Get QueryInstrumentStatus() As Boolean
Property Let QueryInstrumentStatus(value As Boolean)
[C++]
HRESULT get_QueryInstrumentStatus(VARIANT_BOOL* value);
HRESULT put_QueryInstrumentStatus(VARIANT_BOOL value);
[ANSI C]
HRESULT IIviDriverOperation_get_QueryInstrumentStatus(IIviDriverOperation* This, VARIANT_BOOL* value);
HRESULT IIviDriverOperation_put_QueryInstrumentStatus(IIviDriverOperation* This, VARIANT_BOOL value);
[C#]
public bool QueryInstrumentStatus {get; set;}

Also In This Interface

LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


RangeCheck Property

IIviDriverOperation.RangeCheck Property

Drivers may choose to always validate some property/parameter values, never validate others, and optionally validate others, to avoid sending invalid commands to the instrument. If True, the driver performs optional validations.

[Visual Basic]
Property Get RangeCheck() As Boolean
Property Let RangeCheck(value As Boolean)
[C++]
HRESULT get_RangeCheck(VARIANT_BOOL* value);
HRESULT put_RangeCheck(VARIANT_BOOL value);
[ANSI C]
HRESULT IIviDriverOperation_get_RangeCheck(IIviDriverOperation* This, VARIANT_BOOL* value);
HRESULT IIviDriverOperation_put_RangeCheck(IIviDriverOperation* This, VARIANT_BOOL value);
[C#]
public bool RangeCheck {get; set;}

Also In This Interface

LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


RecordCoercions Property

IIviDriverOperation.RecordCoercions Property

If True, the driver keeps a list of the value coercions it makes for ViInt32 and ViReal64 attributes. If the driver does not support coercion recording, attempts to set RecordCoercions to True will return an error.

[Visual Basic]
Property Get RecordCoercions() As Boolean
Property Let RecordCoercions(value As Boolean)
[C++]
HRESULT get_RecordCoercions(VARIANT_BOOL* value);
HRESULT put_RecordCoercions(VARIANT_BOOL value);
[ANSI C]
HRESULT IIviDriverOperation_get_RecordCoercions(IIviDriverOperation* This, VARIANT_BOOL* value);
HRESULT IIviDriverOperation_put_RecordCoercions(IIviDriverOperation* This, VARIANT_BOOL value);
[C#]
public bool RecordCoercions {get; set;}

Related Items

GetNextCoercionRecord

Also In This Interface

LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


Simulate Property

IIviDriverOperation.Simulate Property

If True, the driver does not perform I/O to the instrument, and returns simulated values for output parameters.

[Visual Basic]
Property Get Simulate() As Boolean
Property Let Simulate(value As Boolean)
[C++]
HRESULT get_Simulate(VARIANT_BOOL* value);
HRESULT put_Simulate(VARIANT_BOOL value);
[ANSI C]
HRESULT IIviDriverOperation_get_Simulate(IIviDriverOperation* This, VARIANT_BOOL* value);
HRESULT IIviDriverOperation_put_Simulate(IIviDriverOperation* This, VARIANT_BOOL value);
[C#]
public bool Simulate {get; set;}

Also In This Interface

LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


DriverSetup Property

IIviDriverOperation.DriverSetup Property

The driver setup string. It is either specified in the Configuration Store or passed in the OptionString parameter of the Initialize function. Driver setup is empty if the driver is not initialized.

[Visual Basic]
Property Get DriverSetup() As String
[C++]
HRESULT get_DriverSetup(BSTR* value);
[ANSI C]
HRESULT IIviDriverOperation_get_DriverSetup(IIviDriverOperation* This, BSTR* value);
[C#]
public string DriverSetup {get;}

Also In This Interface

LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


InvalidateAllAttributes Method

IIviDriverOperation.InvalidateAllAttributes Method

Invalidates all of the driver's cached values.

[Visual Basic]
Sub InvalidateAllAttributes()
[C++]
HRESULT InvalidateAllAttributes();
[ANSI C]
HRESULT IIviDriverOperation_InvalidateAllAttributes(
   IIviDriverOperation* This);
[C#]
public void InvalidateAllAttributes();

Related Items

Cache

Also In This Interface

LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


ClearInterchangeWarnings Method

IIviDriverOperation.ClearInterchangeWarnings Method

Clears the list of interchangeability warnings that the IVI specific driver maintains.

[Visual Basic]
Sub ClearInterchangeWarnings()
[C++]
HRESULT ClearInterchangeWarnings();
[ANSI C]
HRESULT IIviDriverOperation_ClearInterchangeWarnings(
   IIviDriverOperation* This);
[C#]
public void ClearInterchangeWarnings();

Related Items

GetNextInterchangeWarning | ResetInterchangeCheck | InterchangeCheck

Also In This Interface

LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


GetNextInterchangeWarning Method

IIviDriverOperation.GetNextInterchangeWarning Method

Returns the oldest warning from the interchange warning list. Records are only added to the list if InterchangeCheck is True.

[Visual Basic]
Function GetNextInterchangeWarning() As String
[C++]
HRESULT GetNextInterchangeWarning(
   BSTR* InterchangeWarning
);
[ANSI C]
HRESULT IIviDriverOperation_GetNextInterchangeWarning(
   IIviDriverOperation* This
   BSTR* InterchangeWarning
);
[C#]
public string GetNextInterchangeWarning();

Parameters

InterchangeWarning
A string describing the oldest interchangeability warning or empty string if no warrnings remain.

Related Items

ClearInterchangeWarnings | ResetInterchangeCheck | InterchangeCheck

Also In This Interface

LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


ResetInterchangeCheck Method

IIviDriverOperation.ResetInterchangeCheck Method

Resets the interchangeability checking algorithms of the driver so that methods and properties that executed prior to calling this function have no affect on whether future calls to the driver generate interchangeability warnings.

[Visual Basic]
Sub ResetInterchangeCheck()
[C++]
HRESULT ResetInterchangeCheck();
[ANSI C]
HRESULT IIviDriverOperation_ResetInterchangeCheck(
   IIviDriverOperation* This);
[C#]
public void ResetInterchangeCheck();

Related Items

GetNextInterchangeWarning | ClearInterchangeWarnings | InterchangeCheck

Also In This Interface

LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


GetNextCoercionRecord Method

IIviDriverOperation.GetNextCoercionRecord Method

Returns the oldest record from the coercion record list. Records are only added to the list if RecordCoercions is True.

[Visual Basic]
Function GetNextCoercionRecord() As String
[C++]
HRESULT GetNextCoercionRecord(
   BSTR* CoercionRecord
);
[ANSI C]
HRESULT IIviDriverOperation_GetNextCoercionRecord(
   IIviDriverOperation* This
   BSTR* CoercionRecord
);
[C#]
public string GetNextCoercionRecord();

Parameters

CoercionRecord
The coercion record string shall contain the following information:
  • The name of the attribute that was coerced. This can be the generic name, the COM property name, or the C defined constant.
  • If the attribute is channel-based, the name of the channel. The channel name can be the specific driver channel string or the virtual channel name that the user specified.
  • If the attribute applies to a repeated capability, the name of the repeated capability. The name can be the specific driver repeated capability token or the virtual repeated capability name that the user specified.
  • The value that the user specified for the attribute.
  • The value to which the attribute was coerced.

    • Related Items

    RecordCoercions

    Also In This Interface

    LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


IIviDriverUtility Interface

IVI Driver utility interface

Methods

Reset | Places the instrument in a known state and configures instrument options on which the IVI specific driver depends (for example, enabling/disabling headers). For an IEEE 488.2 instrument, Reset sends the command string *RST to the instrument.
ResetWithDefaults | Does the equivalent of Reset and then, (1) disables class extension capability groups, (2) sets attributes to initial values defined by class specs, and (3) configures the driver to option string settings used when Initialize was last executed.
Disable | Quickly places the instrument in a state where it has no, or minimal, effect on the external system to which it is connected. This state is not necessarily a known state.
SelfTest | Performs an instrument self test, waits for the instrument to complete the test, and queries the instrument for the results. If the instrument passes the test, TestResult is zero and TestMessage is 'Self test passed'.
ErrorQuery | Queries the instrument and returns instrument specific error information. This function can be used when QueryInstrumentStatus is True to retrieve error details when the driver detects an instrument error.
LockObject | Obtains a multithread lock on the driver after waiting until all other execution threads have released their locks on the instrument session.
UnlockObject | Releases a previously obtained mutlithread lock.


Reset Method

IIviDriverUtility.Reset Method

Places the instrument in a known state and configures instrument options on which the IVI specific driver depends (for example, enabling/disabling headers). For an IEEE 488.2 instrument, Reset sends the command string *RST to the instrument.

[Visual Basic]
Sub Reset()
[C++]
HRESULT Reset();
[ANSI C]
HRESULT IIviDriverUtility_Reset(
   IIviDriverUtility* This);
[C#]
public void Reset();

Related Items

ResetWithDefaults

Also In This Interface

Reset | ResetWithDefaults | Disable | SelfTest | ErrorQuery | LockObject | UnlockObject | IIviDriverUtility Overview


ResetWithDefaults Method

IIviDriverUtility.ResetWithDefaults Method

Does the equivalent of Reset and then, (1) disables class extension capability groups, (2) sets attributes to initial values defined by class specs, and (3) configures the driver to option string settings used when Initialize was last executed.

[Visual Basic]
Sub ResetWithDefaults()
[C++]
HRESULT ResetWithDefaults();
[ANSI C]
HRESULT IIviDriverUtility_ResetWithDefaults(
   IIviDriverUtility* This);
[C#]
public void ResetWithDefaults();

Also In This Interface

Reset | ResetWithDefaults | Disable | SelfTest | ErrorQuery | LockObject | UnlockObject | IIviDriverUtility Overview


Disable Method

IIviDriverUtility.Disable Method

Quickly places the instrument in a state where it has no, or minimal, effect on the external system to which it is connected. This state is not necessarily a known state.

[Visual Basic]
Sub Disable()
[C++]
HRESULT Disable();
[ANSI C]
HRESULT IIviDriverUtility_Disable(
   IIviDriverUtility* This);
[C#]
public void Disable();

Also In This Interface

Reset | ResetWithDefaults | Disable | SelfTest | ErrorQuery | LockObject | UnlockObject | IIviDriverUtility Overview


SelfTest Method

IIviDriverUtility.SelfTest Method

Performs an instrument self test, waits for the instrument to complete the test, and queries the instrument for the results. If the instrument passes the test, TestResult is zero and TestMessage is 'Self test passed'.

[Visual Basic]
Sub SelfTest( _
   TestResult As Long, _
   TestMessage As String _
)
[C++]
HRESULT SelfTest(
   long* TestResult,
   BSTR* TestMessage
);
[ANSI C]
HRESULT IIviDriverUtility_SelfTest(
   IIviDriverUtility* This
   long* TestResult,
   BSTR* TestMessage
);
[C#]
public void SelfTest(
   long TestResult,
   string TestMessage
);

Parameters

TestResult
The numeric result from the self test operation. 0 = no error (test passed)
TestMessage
The self test status message

Also In This Interface

Reset | ResetWithDefaults | Disable | SelfTest | ErrorQuery | LockObject | UnlockObject | IIviDriverUtility Overview


ErrorQuery Method

IIviDriverUtility.ErrorQuery Method

Queries the instrument and returns instrument specific error information. This function can be used when QueryInstrumentStatus is True to retrieve error details when the driver detects an instrument error.

[Visual Basic]
Sub ErrorQuery( _
   ErrorCode As Long, _
   ErrorMessage As String _
)
[C++]
HRESULT ErrorQuery(
   long* ErrorCode,
   BSTR* ErrorMessage
);
[ANSI C]
HRESULT IIviDriverUtility_ErrorQuery(
   IIviDriverUtility* This
   long* ErrorCode,
   BSTR* ErrorMessage
);
[C#]
public void ErrorQuery(
   long ErrorCode,
   string ErrorMessage
);

Parameters

ErrorCode
Instrument error code
ErrorMessage
Instrument error message

Also In This Interface

Reset | ResetWithDefaults | Disable | SelfTest | ErrorQuery | LockObject | UnlockObject | IIviDriverUtility Overview


LockObject Method

IIviDriverUtility.LockObject Method

Obtains a multithread lock on the driver after waiting until all other execution threads have released their locks on the instrument session.

[Visual Basic]
Sub LockObject()
[C++]
HRESULT LockObject();
[ANSI C]
HRESULT IIviDriverUtility_LockObject(
   IIviDriverUtility* This);
[C#]
public void LockObject();

Related Items

UnlockObject

Also In This Interface

Reset | ResetWithDefaults | Disable | SelfTest | ErrorQuery | LockObject | UnlockObject | IIviDriverUtility Overview


UnlockObject Method

IIviDriverUtility.UnlockObject Method

Releases a previously obtained mutlithread lock.

[Visual Basic]
Sub UnlockObject()
[C++]
HRESULT UnlockObject();
[ANSI C]
HRESULT IIviDriverUtility_UnlockObject(
   IIviDriverUtility* This);
[C#]
public void UnlockObject();

Related Items

LockObject

Also In This Interface

Reset | ResetWithDefaults | Disable | SelfTest | ErrorQuery | LockObject | UnlockObject | IIviDriverUtility Overview


IviDriver_ErrorCodes Enumeration

IVI Driver (inherent features) defined HRESULTS

Members

Member Name | Description
S_IVI_SUCCESS | Success
E_IVI_CANNOT_RECOVER | Unrecoverable failure
E_IVI_INSTRUMENT_STATUS | Instrument error detected
E_IVI_CANNOT_OPEN_FILE | File could not be opened
E_IVI_READING_FILE | File could not be read
E_IVI_WRITING_FILE | File could not be written
E_IVI_INVALID_PATHNAME | The path name is invalid
E_IVI_INVALID_VALUE | Invalid value for parameter or property
E_IVI_METHOD_NOT_SUPPORTED | Method not supported
E_IVI_PROPERTY_NOT_SUPPORTED | Property not supported
E_IVI_VALUE_NOT_SUPPORTED | The enumeration value for the parameter is not supported
E_IVI_NOT_INITIALIZED | A connection to the instrument has not been initialized
E_IVI_UNKNOWN_CHANNEL_NAME | Channel or repeated capability name specified is not valid for the instrument.
E_IVI_TOO_MANY_OPEN_FILES | Too many files opened
E_IVI_CHANNEL_NAME_REQUIRED | Channel or repeated capability name required
E_IVI_MISSING_OPTION_NAME | The option string contains an entry without a name.
E_IVI_MISSING_OPTION_VALUE | The option string contains an entry without a value.
E_IVI_BAD_OPTION_NAME | The option string contains an entry with an unknown option name.
E_IVI_BAD_OPTION_VALUE | The option string contains an entry with an unknown option value.
E_IVI_OUT_OF_MEMORY | The necessary memory could not be allocated
E_IVI_OPERATION_PENDING | Operation in progress
E_IVI_NULL_POINTER | Null pointer passed for parameter or property
E_IVI_UNEXPECTED_RESPONSE | Unexpected response from the instrument
E_IVI_FILE_NOT_FOUND | File not found
E_IVI_INVALID_FILE_FORMAT | The file format is invalid
E_IVI_STATUS_NOT_AVAILABLE | The instrument status is not available
E_IVI_ID_QUERY_FAILED | Instrument ID query failed
E_IVI_RESET_FAILED | Instrument reset failed
E_IVI_RESOURCE_UNKNOWN | Insufficient location information or resource not present in the system.
E_IVI_ALREADY_INITIALIZED | The driver is already initialized
E_IVI_CANNOT_CHANGE_SIMULATION_STATE | The simulation state cannot be changed.
S_IVI_NSUP_ID_QUERY | Identification query not supported
S_IVI_NSUP_RESET | Reset operation not supported
S_IVI_NSUP_SELF_TEST | Self test operation not supported
S_IVI_NSUP_ERROR_QUERY | Error query operation not supported
S_IVI_NSUP_REV_QUERY | Revision query not supported


Topic Not Found

No matching topic was found. The link may be out of date, incorrectly authored, or the topic may not be available in this release.

You may be able to find the topic by using the index or search tab instead.