IviDmm Reference

© 2003 IVI Foundation

Welcome to the IviDmm Class-Compliant Interface Reference

This section contains the reference material for the IviDmm class-compliant interface.

This help hierarchy matches the COM hierarchy defined in the IviDmm class specification, available on the IVI Foundation Web Site. The COM hierarchy groups related capabilities into common interfaces. These interfaces often include both IviDmm base and extension capabilities. To help users distinguish between base and extension capabilities, the Capability Group section of each method or property topic lists which of the IviDmm Capability Groups the method or property belongs to.

Since IVI class-compliant specific drivers are not required to support all extension groups, users should refer to the compliance documentation for the particular driver being used to determine if an extension group is supported before using capabilities in that group.

IVI class-compliant specific drivers may have small differences in the way a particular extension group method or property is implemented. For instance, a driver might implement only one of several IVI-defined values for an extension group attribute. Refer to the help documentation provided with the IVI class-compliant specific driver for detailed information about implementation.


Inherent Interface

IviDCPwr Reference

IviDCPwr Capability Groups

Capability Group | Description
IviDmmBase | DMM that complies with the IviDmmBase Capability Group.
IviDmmACMeasurement | DMM with the capability to measure AC voltage, AC current, AC plus DC voltage, and AC plus DC current.
IviDmmFrequencyMeasurement | DMM with the capability to measure frequency and period.
IviDmmTemperatureMeasurement | DMM with the capability to measure temperature.
IviDmmThermocouple | DMM with the capability to measure temperature using a thermocouple.
IviDmmResistanceTemperatureDevice | DMM with the capability to measure temperature using a temperature resistance device.
IviDmmThermistor | DMM with the capability to measure temperature using a thermistor.
IviDmmMultiPoint | DMM with the capability to accept multiple triggers and acquire multiple samples per trigger.
IviDmmTriggerSlope | DMM with the capability to specify the trigger slope.
IviDmmSoftwareTrigger | DMM with the capability to send a software trigger.
IviDmmDeviceInfo | DMM with the capability to return extra information concerning the instrument's state such as aperture time.
IviDmmAutoRangeValue | DMM with the capability to return the actual range when auto ranging.
IviDmmAutoZero | DMM with the capability to take an auto-zero reading.
IviDmmPowerLineFrequency | DMM with the capability to specify the power line frequency.


Inherent Interface

IviDmm Instrument Class Interfaces

IIviDmm | IVI DMM class-compliant root interface
IIviDmmAC | IVI DMM class-compliant AC interface
IIviDmmAdvanced | IVI DMM class-compliant advanced features interface
IIviDmmFrequency | IVI DMM class-compliant frequency interface
IIviDmmMeasurement | IVI DMM class-compliant measurement interface
IIviDmmMultiPoint | IVI DMM class-compliant multipoint interface
IIviDmmRTD | IVI DMM class-compliant RTD interface
IIviDmmTemperature | IVI DMM class-compliant temperature interface
IIviDmmThermistor | IVI DMM class-compliant thermistor interface
IIviDmmThermocouple | IVI DMM class-compliant thermocouple interface
IIviDmmTrigger | IVI DMM class-compliant trigger interface


IIviDmm Interface

IVI DMM class-compliant root interface

Methods

Initialize | Opens the I/O session to the instrument. Driver methods and properties that access the instrument are only accessible after Initialize is called. Initialize optionally performs a Reset and queries the instrument to validate the instrument model.
Close | Closes the I/O session to the instrument. Driver methods and properties that access the instrument are not accessible after Close is called.
Configure | Configures the Function, Range, and Resolution properties. If the value of the Range parameter is Auto Range On, then the Resolution parameter is ignored.

Properties

DriverOperation | Pointer to the IIviDriverOperation interface
Identity | Pointer to the IIviDriverIdentity interface
Utility | Pointer to the IIviDriverUtility interface
Initialized | Initialized is True between a successful call to the Initialize method and a successful call to the Close method, and False at all other times.
Function | The measurement function. This property determines the units for Range and Resolution and the values returned by the Read, Read Multiple Point, Fetch, and Fetch Multiple Point methods.
Range | The measurement range, coerced by the driver to the appropriate range for the instrument. Positive values set the absolute value of the maximum measurement expected. Negative values set Auto Range mode. Units are determined by Function.
Resolution | The measurement resolution in absolute units. Units are determined by Function.
AC | Pointer to the class-compliant IIviDmmAc interface
Advanced | Pointer to the class-compliant IIviDmmAdvanced interface
Frequency | Pointer to the class-compliant IIviDmmFrequency interface
Measurement | Pointer to the class-compliant IIviDmmMeasurement interface
Temperature | Pointer to the class-compliant IIviDmmTemperature interface
Trigger | Pointer to the class-compliant IIviDmmTrigger interface


DriverOperation Property

IIviDmm.DriverOperation Property

Pointer to the IIviDriverOperation interface

[Visual Basic]
Property Get DriverOperation() As IIviDriverOperation*
[C++]
HRESULT get_DriverOperation(IIviDriverOperation** value);
[ANSI C]
HRESULT IIviDmm_get_DriverOperation(IIviDmm* This, IIviDriverOperation** value);
[C#]
public IIviDriverOperation* DriverOperation {get;}

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Function | Range | Resolution | AC | Advanced | Frequency | Measurement | Temperature | Trigger | Initialize | Close | Configure | IIviDmm Overview


Identity Property

IIviDmm.Identity Property

Pointer to the IIviDriverIdentity interface

[Visual Basic]
Property Get Identity() As IIviDriverIdentity*
[C++]
HRESULT get_Identity(IIviDriverIdentity** value);
[ANSI C]
HRESULT IIviDmm_get_Identity(IIviDmm* This, IIviDriverIdentity** value);
[C#]
public IIviDriverIdentity* Identity {get;}

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Function | Range | Resolution | AC | Advanced | Frequency | Measurement | Temperature | Trigger | Initialize | Close | Configure | IIviDmm Overview


Utility Property

IIviDmm.Utility Property

Pointer to the IIviDriverUtility interface

[Visual Basic]
Property Get Utility() As IIviDriverUtility*
[C++]
HRESULT get_Utility(IIviDriverUtility** value);
[ANSI C]
HRESULT IIviDmm_get_Utility(IIviDmm* This, IIviDriverUtility** value);
[C#]
public IIviDriverUtility* Utility {get;}

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Function | Range | Resolution | AC | Advanced | Frequency | Measurement | Temperature | Trigger | Initialize | Close | Configure | IIviDmm Overview


Initialized Property

IIviDmm.Initialized Property

Initialized is True between a successful call to the Initialize method and a successful call to the Close method, and False at all other times.

[Visual Basic]
Property Get Initialized() As Boolean
[C++]
HRESULT get_Initialized(VARIANT_BOOL* value);
[ANSI C]
HRESULT IIviDmm_get_Initialized(IIviDmm* This, VARIANT_BOOL* value);
[C#]
public bool Initialized {get;}

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Function | Range | Resolution | AC | Advanced | Frequency | Measurement | Temperature | Trigger | Initialize | Close | Configure | IIviDmm Overview


Function Property

IIviDmm.Function Property

The measurement function. This property determines the units for Range and Resolution and the values returned by the Read, Read Multiple Point, Fetch, and Fetch Multiple Point methods.

[Visual Basic]
Property Get Function() As IviDmmFunctionEnum
Property Let Function(value As IviDmmFunctionEnum)
[C++]
HRESULT get_Function(IviDmmFunctionEnum* value);
HRESULT put_Function(IviDmmFunctionEnum value);
[ANSI C]
HRESULT IIviDmm_get_Function(IIviDmm* This, IviDmmFunctionEnum* value);
HRESULT IIviDmm_put_Function(IIviDmm* This, IviDmmFunctionEnum value);
[C#]
public IviDmmFunctionEnum Function {get; set;}

Capability Group

IviDmmBase

Related Items

Configure | Range | Resolution

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Function | Range | Resolution | AC | Advanced | Frequency | Measurement | Temperature | Trigger | Initialize | Close | Configure | IIviDmm Overview


Range Property

IIviDmm.Range Property

The measurement range, coerced by the driver to the appropriate range for the instrument. Positive values set the absolute value of the maximum measurement expected. Negative values set Auto Range mode. Units are determined by Function.

[Visual Basic]
Property Get Range() As Double
Property Let Range(value As Double)
[C++]
HRESULT get_Range(double* value);
HRESULT put_Range(double value);
[ANSI C]
HRESULT IIviDmm_get_Range(IIviDmm* This, double* value);
HRESULT IIviDmm_put_Range(IIviDmm* This, double value);
[C#]
public double Range {get; set;}

Capability Group

IviDmmBase

Related Items

Configure | Function | Resolution

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Function | Range | Resolution | AC | Advanced | Frequency | Measurement | Temperature | Trigger | Initialize | Close | Configure | IIviDmm Overview


Resolution Property

IIviDmm.Resolution Property

The measurement resolution in absolute units. Units are determined by Function.

[Visual Basic]
Property Get Resolution() As Double
Property Let Resolution(value As Double)
[C++]
HRESULT get_Resolution(double* value);
HRESULT put_Resolution(double value);
[ANSI C]
HRESULT IIviDmm_get_Resolution(IIviDmm* This, double* value);
HRESULT IIviDmm_put_Resolution(IIviDmm* This, double value);
[C#]
public double Resolution {get; set;}

Capability Group

IviDmmBase

Related Items

Configure | Function | Range

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Function | Range | Resolution | AC | Advanced | Frequency | Measurement | Temperature | Trigger | Initialize | Close | Configure | IIviDmm Overview


AC Property

IIviDmm.AC Property

Pointer to the class-compliant IIviDmmAc interface

[Visual Basic]
Property Get AC() As IIviDmmAC
[C++]
HRESULT get_AC(IIviDmmAC** value);
[ANSI C]
HRESULT IIviDmm_get_AC(IIviDmm* This, IIviDmmAC** value);
[C#]
public IIviDmmAC AC {get;}

Capability Group

IviDmmACMeasurement

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Function | Range | Resolution | AC | Advanced | Frequency | Measurement | Temperature | Trigger | Initialize | Close | Configure | IIviDmm Overview


Advanced Property

IIviDmm.Advanced Property

Pointer to the class-compliant IIviDmmAdvanced interface

[Visual Basic]
Property Get Advanced() As IIviDmmAdvanced
[C++]
HRESULT get_Advanced(IIviDmmAdvanced** value);
[ANSI C]
HRESULT IIviDmm_get_Advanced(IIviDmm* This, IIviDmmAdvanced** value);
[C#]
public IIviDmmAdvanced Advanced {get;}

Capability Group

IviDmmPowerLineFrequency, IviDmmAutoZero, IviDmmDeviceInfo, IviDmmAutoRangeValue

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Function | Range | Resolution | AC | Advanced | Frequency | Measurement | Temperature | Trigger | Initialize | Close | Configure | IIviDmm Overview


Frequency Property

IIviDmm.Frequency Property

Pointer to the class-compliant IIviDmmFrequency interface

[Visual Basic]
Property Get Frequency() As IIviDmmFrequency
[C++]
HRESULT get_Frequency(IIviDmmFrequency** value);
[ANSI C]
HRESULT IIviDmm_get_Frequency(IIviDmm* This, IIviDmmFrequency** value);
[C#]
public IIviDmmFrequency Frequency {get;}

Capability Group

IviDmmFrequencyMeasurement

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Function | Range | Resolution | AC | Advanced | Frequency | Measurement | Temperature | Trigger | Initialize | Close | Configure | IIviDmm Overview


Measurement Property

IIviDmm.Measurement Property

Pointer to the class-compliant IIviDmmMeasurement interface

[Visual Basic]
Property Get Measurement() As IIviDmmMeasurement
[C++]
HRESULT get_Measurement(IIviDmmMeasurement** value);
[ANSI C]
HRESULT IIviDmm_get_Measurement(IIviDmm* This, IIviDmmMeasurement** value);
[C#]
public IIviDmmMeasurement Measurement {get;}

Capability Group

IviDmmBase, IviDmmMultiPoint, IviDmmSoftwareTrigger

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Function | Range | Resolution | AC | Advanced | Frequency | Measurement | Temperature | Trigger | Initialize | Close | Configure | IIviDmm Overview


Temperature Property

IIviDmm.Temperature Property

Pointer to the class-compliant IIviDmmTemperature interface

[Visual Basic]
Property Get Temperature() As IIviDmmTemperature
[C++]
HRESULT get_Temperature(IIviDmmTemperature** value);
[ANSI C]
HRESULT IIviDmm_get_Temperature(IIviDmm* This, IIviDmmTemperature** value);
[C#]
public IIviDmmTemperature Temperature {get;}

Capability Group

IviDmmTemperatureMeasurement, IviDmmResistanceTemperatureDevice, IviDmmThermocouple, IviDmmThermistor

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Function | Range | Resolution | AC | Advanced | Frequency | Measurement | Temperature | Trigger | Initialize | Close | Configure | IIviDmm Overview


Trigger Property

IIviDmm.Trigger Property

Pointer to the class-compliant IIviDmmTrigger interface

[Visual Basic]
Property Get Trigger() As IIviDmmTrigger
[C++]
HRESULT get_Trigger(IIviDmmTrigger** value);
[ANSI C]
HRESULT IIviDmm_get_Trigger(IIviDmm* This, IIviDmmTrigger** value);
[C#]
public IIviDmmTrigger Trigger {get;}

Capability Group

IviDmmBase, IviDmmTriggerSlope, IviDmmMultiPoint

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Function | Range | Resolution | AC | Advanced | Frequency | Measurement | Temperature | Trigger | Initialize | Close | Configure | IIviDmm Overview


Initialize Method

IIviDmm.Initialize Method

Opens the I/O session to the instrument. Driver methods and properties that access the instrument are only accessible after Initialize is called. Initialize optionally performs a Reset and queries the instrument to validate the instrument model.

[Visual Basic]
Sub Initialize( _
   ResourceName As String, _
   IdQuery As Boolean, _
   Reset As Boolean, _
   OptionString As String _
)
[C++]
HRESULT Initialize(
   BSTR ResourceName,
   VARIANT_BOOL IdQuery,
   VARIANT_BOOL Reset,
   BSTR OptionString
);
[ANSI C]
HRESULT IIviDmm_Initialize(
   IIviDmm* This
   BSTR ResourceName,
   VARIANT_BOOL IdQuery,
   VARIANT_BOOL Reset,
   BSTR OptionString
);
[C#]
public void Initialize(
   string ResourceName,
   bool IdQuery,
   bool Reset,
   string OptionString
);

Parameters

ResourceName
An IVI logical name or an instrument specific string that identifies the address of the instrument, such as a VISA resource descriptor string.
IdQuery
Specifies whether to verify the ID of the instrument.
Reset
Specifies whether to reset the instrument.
OptionString
The user can use the OptionsString parameter to specify the initial values of certain IVI inherent attributes for the session.

Related Items

Close

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Function | Range | Resolution | AC | Advanced | Frequency | Measurement | Temperature | Trigger | Initialize | Close | Configure | IIviDmm Overview


Close Method

IIviDmm.Close Method

Closes the I/O session to the instrument. Driver methods and properties that access the instrument are not accessible after Close is called.

[Visual Basic]
Sub Close()
[C++]
HRESULT Close();
[ANSI C]
HRESULT IIviDmm_Close(
   IIviDmm* This);
[C#]
public void Close();

Related Items

Initialize

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Function | Range | Resolution | AC | Advanced | Frequency | Measurement | Temperature | Trigger | Initialize | Close | Configure | IIviDmm Overview


Configure Method

IIviDmm.Configure Method

Configures the Function, Range, and Resolution properties. If the value of the Range parameter is Auto Range On, then the Resolution parameter is ignored.

[Visual Basic]
Sub Configure( _
   Function As IviDmmFunctionEnum, _
   Range As Double, _
   Resolution As Double _
)
[C++]
HRESULT Configure(
   IviDmmFunctionEnum Function,
   double Range,
   double Resolution
);
[ANSI C]
HRESULT IIviDmm_Configure(
   IIviDmm* This
   IviDmmFunctionEnum Function,
   double Range,
   double Resolution
);
[C#]
public void Configure(
   IviDmmFunctionEnum Function,
   double Range,
   double Resolution
);

Parameters

Function
Determines the units for the Range and Resolution Absolute parameters, and the measurement values that are returned by the Read, Read Multiple Point, Fetch, and Fetch Multiple Point methods.
Range
The measurement range. Positive values represent the absolute value of the maximum measurement expected. The driver coerces this value to the appropriate range for the instrument. Negative values represent the Auto Range mode.
Resolution
The measurement resolution in absolute units.

Capability Group

IviDmmBase

Related Items

Function | Range | Resolution

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Function | Range | Resolution | AC | Advanced | Frequency | Measurement | Temperature | Trigger | Initialize | Close | Configure | IIviDmm Overview


IIviDmmAC Interface

IVI DMM class-compliant AC interface

Methods

ConfigureBandwidth Configures the FrequencyMax and FrequencyMin properties for DMMs that take AC voltage or AC current measurements.

Properties

FrequencyMax | The maximum frequency component of the input signal for AC measurements. The value of this property affects instrument behavior only when the Function property is set to an AC voltage or AC current measurement.
FrequencyMin | The minimum frequency component of the input signal for AC measurements. The value of this property affects instrument behavior only when the Function property is set to an AC voltage or AC current measurement.


FrequencyMax Property

IIviDmmAC.FrequencyMax Property

The maximum frequency component of the input signal for AC measurements. The value of this property affects instrument behavior only when the Function property is set to an AC voltage or AC current measurement.

[Visual Basic]
Property Get FrequencyMax() As Double
Property Let FrequencyMax(value As Double)
[C++]
HRESULT get_FrequencyMax(double* value);
HRESULT put_FrequencyMax(double value);
[ANSI C]
HRESULT IIviDmmAC_get_FrequencyMax(IIviDmmAC* This, double* value);
HRESULT IIviDmmAC_put_FrequencyMax(IIviDmmAC* This, double value);
[C#]
public double FrequencyMax {get; set;}

Capability Group

IviDmmACMeasurement

Also In This Interface

FrequencyMax | FrequencyMin | ConfigureBandwidth | IIviDmmAC Overview


FrequencyMin Property

IIviDmmAC.FrequencyMin Property

The minimum frequency component of the input signal for AC measurements. The value of this property affects instrument behavior only when the Function property is set to an AC voltage or AC current measurement.

[Visual Basic]
Property Get FrequencyMin() As Double
Property Let FrequencyMin(value As Double)
[C++]
HRESULT get_FrequencyMin(double* value);
HRESULT put_FrequencyMin(double value);
[ANSI C]
HRESULT IIviDmmAC_get_FrequencyMin(IIviDmmAC* This, double* value);
HRESULT IIviDmmAC_put_FrequencyMin(IIviDmmAC* This, double value);
[C#]
public double FrequencyMin {get; set;}

Capability Group

IviDmmACMeasurement

Also In This Interface

FrequencyMax | FrequencyMin | ConfigureBandwidth | IIviDmmAC Overview


ConfigureBandwidth Method

IIviDmmAC.ConfigureBandwidth Method

Configures the FrequencyMax and FrequencyMin properties for DMMs that take AC voltage or AC current measurements.

[Visual Basic]
Sub ConfigureBandwidth( _
   MinFreq As Double, _
   MaxFreq As Double _
)
[C++]
HRESULT ConfigureBandwidth(
   double MinFreq,
   double MaxFreq
);
[ANSI C]
HRESULT IIviDmmAC_ConfigureBandwidth(
   IIviDmmAC* This
   double MinFreq,
   double MaxFreq
);
[C#]
public void ConfigureBandwidth(
   double MinFreq,
   double MaxFreq
);

Parameters

MinFreq
The minimum frequency component of the input signal for AC measurements.
MaxFreq
The maximum frequency component of the input signal for AC measurements.

Capability Group

IviDmmACMeasurement

Related Items

FrequencyMin | FrequencyMax

Also In This Interface

FrequencyMax | FrequencyMin | ConfigureBandwidth | IIviDmmAC Overview


IIviDmmAdvanced Interface

IVI DMM class-compliant advanced features interface

Properties

ActualRange | The actual range that the DMM is currently using, even if it is auto-ranging.
ApertureTime | The measurement aperture time (also known as integration time) based on the present configuration. Units are specified by the property ApertureTimeUnits.
ApertureTimeUnits | The units for the ApertureTime property.
AutoZero | The auto-zero mode. When the auto-zero mode is enabled, the DMM internally disconnects the input signal and takes a Zero Reading. The DMM then subtracts the Zero Reading from the measurement.
PowerlineFrequency | The power line frequency in Hertz.


ActualRange Property

IIviDmmAdvanced.ActualRange Property

The actual range that the DMM is currently using, even if it is auto-ranging.

[Visual Basic]
Property Get ActualRange() As Double
[C++]
HRESULT get_ActualRange(double* value);
[ANSI C]
HRESULT IIviDmmAdvanced_get_ActualRange(IIviDmmAdvanced* This, double* value);
[C#]
public double ActualRange {get;}

Capability Group

IviDmmAutoRangeValue

Also In This Interface

ActualRange | ApertureTime | ApertureTimeUnits | AutoZero | PowerlineFrequency | IIviDmmAdvanced Overview


ApertureTime Property

IIviDmmAdvanced.ApertureTime Property

The measurement aperture time (also known as integration time) based on the present configuration. Units are specified by the property ApertureTimeUnits.

[Visual Basic]
Property Get ApertureTime() As Double
[C++]
HRESULT get_ApertureTime(double* value);
[ANSI C]
HRESULT IIviDmmAdvanced_get_ApertureTime(IIviDmmAdvanced* This, double* value);
[C#]
public double ApertureTime {get;}

Capability Group

IviDmmDeviceInfo

Also In This Interface

ActualRange | ApertureTime | ApertureTimeUnits | AutoZero | PowerlineFrequency | IIviDmmAdvanced Overview


ApertureTimeUnits Property

IIviDmmAdvanced.ApertureTimeUnits Property

The units for the ApertureTime property.

[Visual Basic]
Property Get ApertureTimeUnits() As IviDmmApertureTimeUnitsEnum
[C++]
HRESULT get_ApertureTimeUnits(IviDmmApertureTimeUnitsEnum* value);
[ANSI C]
HRESULT IIviDmmAdvanced_get_ApertureTimeUnits(IIviDmmAdvanced* This, IviDmmApertureTimeUnitsEnum* value);
[C#]
public IviDmmApertureTimeUnitsEnum ApertureTimeUnits {get;}

Capability Group

IviDmmDeviceInfo

Also In This Interface

ActualRange | ApertureTime | ApertureTimeUnits | AutoZero | PowerlineFrequency | IIviDmmAdvanced Overview


AutoZero Property

IIviDmmAdvanced.AutoZero Property

The auto-zero mode. When the auto-zero mode is enabled, the DMM internally disconnects the input signal and takes a Zero Reading. The DMM then subtracts the Zero Reading from the measurement.

[Visual Basic]
Property Get AutoZero() As IviDmmAutoZeroEnum
Property Let AutoZero(value As IviDmmAutoZeroEnum)
[C++]
HRESULT get_AutoZero(IviDmmAutoZeroEnum* value);
HRESULT put_AutoZero(IviDmmAutoZeroEnum value);
[ANSI C]
HRESULT IIviDmmAdvanced_get_AutoZero(IIviDmmAdvanced* This, IviDmmAutoZeroEnum* value);
HRESULT IIviDmmAdvanced_put_AutoZero(IIviDmmAdvanced* This, IviDmmAutoZeroEnum value);
[C#]
public IviDmmAutoZeroEnum AutoZero {get; set;}

Capability Group

IviDmmAutoZero

Also In This Interface

ActualRange | ApertureTime | ApertureTimeUnits | AutoZero | PowerlineFrequency | IIviDmmAdvanced Overview


PowerlineFrequency Property

IIviDmmAdvanced.PowerlineFrequency Property

The power line frequency in Hertz.

[Visual Basic]
Property Get PowerlineFrequency() As Double
Property Let PowerlineFrequency(value As Double)
[C++]
HRESULT get_PowerlineFrequency(double* value);
HRESULT put_PowerlineFrequency(double value);
[ANSI C]
HRESULT IIviDmmAdvanced_get_PowerlineFrequency(IIviDmmAdvanced* This, double* value);
HRESULT IIviDmmAdvanced_put_PowerlineFrequency(IIviDmmAdvanced* This, double value);
[C#]
public double PowerlineFrequency {get; set;}

Capability Group

IviDmmPowerLineFrequency

Also In This Interface

ActualRange | ApertureTime | ApertureTimeUnits | AutoZero | PowerlineFrequency | IIviDmmAdvanced Overview


IIviDmmFrequency Interface

IVI DMM class-compliant frequency interface

Properties

VoltageRange The expected maximum voltage level of the input signal for frequency and period measurements. Positive values set the manual range. Negative values set Auto Range mode. The units are specified in Volts RMS.


VoltageRange Property

IIviDmmFrequency.VoltageRange Property

The expected maximum voltage level of the input signal for frequency and period measurements. Positive values set the manual range. Negative values set Auto Range mode. The units are specified in Volts RMS.

[Visual Basic]
Property Get VoltageRange() As Double
Property Let VoltageRange(value As Double)
[C++]
HRESULT get_VoltageRange(double* value);
HRESULT put_VoltageRange(double value);
[ANSI C]
HRESULT IIviDmmFrequency_get_VoltageRange(IIviDmmFrequency* This, double* value);
HRESULT IIviDmmFrequency_put_VoltageRange(IIviDmmFrequency* This, double value);
[C#]
public double VoltageRange {get; set;}

Capability Group

IviDmmFrequencyMeasurement

Also In This Interface

VoltageRange | IIviDmmFrequency Overview


IIviDmmMeasurement Interface

IVI DMM class-compliant measurement interface

Methods

Initiate | Initiates a measurement. When this method executes, the DMM leaves the idle state and waits for a trigger.
Abort | Aborts a previously initiated measurement and returns the DMM to the idle state.
Fetch | Returns the measured value from a measurement that the Initiate method initiates. If an overrange condition occurs, the value contains IEEE NaN and the method returns an overrange error.
FetchMultiPoint | Returns an array of values from a measurement that the Initiate method initiates. If an overrange condition occurs, the corresponding element of the array contains IEEE NaN and the method returns an overrange error.
Read | Initiates a measurement, waits for the DMM to return to the idle state, and returns the measured value. If an overrange condition occurrs, the value contains IEEE NaN and the method returns an overrange error.
ReadMultiPoint | Initiates a measurement, waits for the DMM to return to the idle state, and returns an array of values. If an overrange condition occurs, the corresponding element of the array contains IEEE NaN and the method returns an overrange error.
SendSoftwareTrigger | Sends a software trigger, which causes the DMM to take a measurement.
IsOverRange | Takes a measurement value obtained from one of the Read or Fetch methods and determines if the value is a valid measurement value or a value indicating that an overrange condition occurred.


Initiate Method

IIviDmmMeasurement.Initiate Method

Initiates a measurement. When this method executes, the DMM leaves the idle state and waits for a trigger.

[Visual Basic]
Sub Initiate()
[C++]
HRESULT Initiate();
[ANSI C]
HRESULT IIviDmmMeasurement_Initiate(
   IIviDmmMeasurement* This);
[C#]
public void Initiate();

Capability Group

IviDmmBase

Also In This Interface

Initiate | Abort | Fetch | FetchMultiPoint | Read | ReadMultiPoint | SendSoftwareTrigger | IsOverRange | IIviDmmMeasurement Overview


Abort Method

IIviDmmMeasurement.Abort Method

Aborts a previously initiated measurement and returns the DMM to the idle state.

[Visual Basic]
Sub Abort()
[C++]
HRESULT Abort();
[ANSI C]
HRESULT IIviDmmMeasurement_Abort(
   IIviDmmMeasurement* This);
[C#]
public void Abort();

Capability Group

IviDmmBase

Also In This Interface

Initiate | Abort | Fetch | FetchMultiPoint | Read | ReadMultiPoint | SendSoftwareTrigger | IsOverRange | IIviDmmMeasurement Overview


Fetch Method

IIviDmmMeasurement.Fetch Method

Returns the measured value from a measurement that the Initiate method initiates. If an overrange condition occurs, the value contains IEEE NaN and the method returns an overrange error.

[Visual Basic]
Function Fetch( _
   MaxTimeMilliseconds As Long _
) As Double
[C++]
HRESULT Fetch(
   long MaxTimeMilliseconds,
   double* Reading
);
[ANSI C]
HRESULT IIviDmmMeasurement_Fetch(
   IIviDmmMeasurement* This
   long MaxTimeMilliseconds,
   double* Reading
);
[C#]
public double Fetch(
   long MaxTimeMilliseconds
);

Parameters

MaxTimeMilliseconds
The maximum time allowed for the measurement to complete in milliseconds. May also be a value defined in IviDmmMaxTimeEnum.
Reading
Measurement value.

Capability Group

IviDmmBase

Potential Error Sources

Over Range, Max Time Exceeded

Also In This Interface

Initiate | Abort | Fetch | FetchMultiPoint | Read | ReadMultiPoint | SendSoftwareTrigger | IsOverRange | IIviDmmMeasurement Overview


FetchMultiPoint Method

IIviDmmMeasurement.FetchMultiPoint Method

Returns an array of values from a measurement that the Initiate method initiates. If an overrange condition occurs, the corresponding element of the array contains IEEE NaN and the method returns an overrange error.

[Visual Basic]
Function FetchMultiPoint( _
   MaxTimeMilliseconds As Long _
) As SAFEARRAY(double)
[C++]
HRESULT FetchMultiPoint(
   long MaxTimeMilliseconds,
   SAFEARRAY(double)* ReadingArray
);
[ANSI C]
HRESULT IIviDmmMeasurement_FetchMultiPoint(
   IIviDmmMeasurement* This
   long MaxTimeMilliseconds,
   SAFEARRAY(double)* ReadingArray
);
[C#]
public Array FetchMultiPoint(
   long MaxTimeMilliseconds
);

Parameters

MaxTimeMilliseconds
The maximum time allowed for the measurement to complete in milliseconds. May also be a value defined in IviDmmMaxTimeEnum.
ReadingArray
Array of measured values.

Capability Group

IviDmmMultiPoint

Potential Error Sources

Over Range, Max Time Exceeded

Also In This Interface

Initiate | Abort | Fetch | FetchMultiPoint | Read | ReadMultiPoint | SendSoftwareTrigger | IsOverRange | IIviDmmMeasurement Overview


Read Method

IIviDmmMeasurement.Read Method

Initiates a measurement, waits for the DMM to return to the idle state, and returns the measured value. If an overrange condition occurrs, the value contains IEEE NaN and the method returns an overrange error.

[Visual Basic]
Function Read( _
   MaxTimeMilliseconds As Long _
) As Double
[C++]
HRESULT Read(
   long MaxTimeMilliseconds,
   double* Reading
);
[ANSI C]
HRESULT IIviDmmMeasurement_Read(
   IIviDmmMeasurement* This
   long MaxTimeMilliseconds,
   double* Reading
);
[C#]
public double Read(
   long MaxTimeMilliseconds
);

Parameters

MaxTimeMilliseconds
The maximum time allowed for the measurement to complete in milliseconds. May also be a value defined in IviDmmMaxTimeEnum.
Reading
Measurement value.

Capability Group

IviDmmBase

Potential Error Sources

Over Range, Max Time Exceeded

Also In This Interface

Initiate | Abort | Fetch | FetchMultiPoint | Read | ReadMultiPoint | SendSoftwareTrigger | IsOverRange | IIviDmmMeasurement Overview


ReadMultiPoint Method

IIviDmmMeasurement.ReadMultiPoint Method

Initiates a measurement, waits for the DMM to return to the idle state, and returns an array of values. If an overrange condition occurs, the corresponding element of the array contains IEEE NaN and the method returns an overrange error.

[Visual Basic]
Function ReadMultiPoint( _
   MaxTimeMilliseconds As Long _
) As SAFEARRAY(double)
[C++]
HRESULT ReadMultiPoint(
   long MaxTimeMilliseconds,
   SAFEARRAY(double)* ReadingArray
);
[ANSI C]
HRESULT IIviDmmMeasurement_ReadMultiPoint(
   IIviDmmMeasurement* This
   long MaxTimeMilliseconds,
   SAFEARRAY(double)* ReadingArray
);
[C#]
public Array ReadMultiPoint(
   long MaxTimeMilliseconds
);

Parameters

MaxTimeMilliseconds
The maximum time allowed for the measurement to complete in milliseconds. May also be a value defined in IviDmmMaxTimeEnum.
ReadingArray
Array of measured values.

Capability Group

IviDmmMultiPoint

Potential Error Sources

Over Range, Max Time Exceeded

Also In This Interface

Initiate | Abort | Fetch | FetchMultiPoint | Read | ReadMultiPoint | SendSoftwareTrigger | IsOverRange | IIviDmmMeasurement Overview


SendSoftwareTrigger Method

IIviDmmMeasurement.SendSoftwareTrigger Method

Sends a software trigger, which causes the DMM to take a measurement.

[Visual Basic]
Sub SendSoftwareTrigger()
[C++]
HRESULT SendSoftwareTrigger();
[ANSI C]
HRESULT IIviDmmMeasurement_SendSoftwareTrigger(
   IIviDmmMeasurement* This);
[C#]
public void SendSoftwareTrigger();

Capability Group

IviDmmSoftwareTrigger

Also In This Interface

Initiate | Abort | Fetch | FetchMultiPoint | Read | ReadMultiPoint | SendSoftwareTrigger | IsOverRange | IIviDmmMeasurement Overview


IsOverRange Method

IIviDmmMeasurement.IsOverRange Method

Takes a measurement value obtained from one of the Read or Fetch methods and determines if the value is a valid measurement value or a value indicating that an overrange condition occurred.

[Visual Basic]
Function IsOverRange( _
   MeasurementValue As Double _
) As Boolean
[C++]
HRESULT IsOverRange(
   double MeasurementValue,
   VARIANT_BOOL* IsOverRange
);
[ANSI C]
HRESULT IIviDmmMeasurement_IsOverRange(
   IIviDmmMeasurement* This
   double MeasurementValue,
   VARIANT_BOOL* IsOverRange
);
[C#]
public bool IsOverRange(
   double MeasurementValue
);

Parameters

MeasurementValue
The measurement value from one of the Read or Fetch functions.
IsOverRange
True if the measurement value indicates an overrange condition and false otherwise.

Capability Group

IviDmmBase

Also In This Interface

Initiate | Abort | Fetch | FetchMultiPoint | Read | ReadMultiPoint | SendSoftwareTrigger | IsOverRange | IIviDmmMeasurement Overview


IIviDmmMultiPoint Interface

IVI DMM class-compliant multipoint interface

Methods

Configure Configures multipoint trigger Count, SampleCount, SampleTrigger and SampleInterval properties.

Properties

MeasurementComplete | The destination of the measurement-complete signal generated after each measurement.
Count | The number of triggers the DMM accepts before it returns to the idle state.
SampleCount | The number of measurements the DMM takes each time it receives a trigger.
SampleInterval | The interval between samples in seconds. Applies only when Sample Count is greater than 1 and Sample Trigger is Interval.
SampleTrigger | The sample trigger source. If the value of the Sample Count is greater than 1, the DMM enters the Wait-For-Sample-Trigger state after taking a single measurement. When a sample trigger occurs, the DMM takes the next measurement.


MeasurementComplete Property

IIviDmmMultiPoint.MeasurementComplete Property

The destination of the measurement-complete signal generated after each measurement.

[Visual Basic]
Property Get MeasurementComplete() As IviDmmMeasCompleteDestEnum
Property Let MeasurementComplete(value As IviDmmMeasCompleteDestEnum)
[C++]
HRESULT get_MeasurementComplete(IviDmmMeasCompleteDestEnum* value);
HRESULT put_MeasurementComplete(IviDmmMeasCompleteDestEnum value);
[ANSI C]
HRESULT IIviDmmMultiPoint_get_MeasurementComplete(IIviDmmMultiPoint* This, IviDmmMeasCompleteDestEnum* value);
HRESULT IIviDmmMultiPoint_put_MeasurementComplete(IIviDmmMultiPoint* This, IviDmmMeasCompleteDestEnum value);
[C#]
public IviDmmMeasCompleteDestEnum MeasurementComplete {get; set;}

Capability Group

IviDmmMultiPoint

Also In This Interface

MeasurementComplete | Count | SampleCount | SampleInterval | SampleTrigger | Configure | IIviDmmMultiPoint Overview


Count Property

IIviDmmMultiPoint.Count Property

The number of triggers the DMM accepts before it returns to the idle state.

[Visual Basic]
Property Get Count() As Long
Property Let Count(value As Long)
[C++]
HRESULT get_Count(long* value);
HRESULT put_Count(long value);
[ANSI C]
HRESULT IIviDmmMultiPoint_get_Count(IIviDmmMultiPoint* This, long* value);
HRESULT IIviDmmMultiPoint_put_Count(IIviDmmMultiPoint* This, long value);
[C#]
public long Count {get; set;}

Capability Group

IviDmmMultiPoint

Related Items

Configure

Also In This Interface

MeasurementComplete | Count | SampleCount | SampleInterval | SampleTrigger | Configure | IIviDmmMultiPoint Overview


SampleCount Property

IIviDmmMultiPoint.SampleCount Property

The number of measurements the DMM takes each time it receives a trigger.

[Visual Basic]
Property Get SampleCount() As Long
Property Let SampleCount(value As Long)
[C++]
HRESULT get_SampleCount(long* value);
HRESULT put_SampleCount(long value);
[ANSI C]
HRESULT IIviDmmMultiPoint_get_SampleCount(IIviDmmMultiPoint* This, long* value);
HRESULT IIviDmmMultiPoint_put_SampleCount(IIviDmmMultiPoint* This, long value);
[C#]
public long SampleCount {get; set;}

Capability Group

IviDmmMultiPoint

Related Items

Configure

Also In This Interface

MeasurementComplete | Count | SampleCount | SampleInterval | SampleTrigger | Configure | IIviDmmMultiPoint Overview


SampleInterval Property

IIviDmmMultiPoint.SampleInterval Property

The interval between samples in seconds. Applies only when Sample Count is greater than 1 and Sample Trigger is Interval.

[Visual Basic]
Property Get SampleInterval() As Double
Property Let SampleInterval(value As Double)
[C++]
HRESULT get_SampleInterval(double* value);
HRESULT put_SampleInterval(double value);
[ANSI C]
HRESULT IIviDmmMultiPoint_get_SampleInterval(IIviDmmMultiPoint* This, double* value);
HRESULT IIviDmmMultiPoint_put_SampleInterval(IIviDmmMultiPoint* This, double value);
[C#]
public double SampleInterval {get; set;}

Capability Group

IviDmmMultiPoint

Related Items

Configure

Also In This Interface

MeasurementComplete | Count | SampleCount | SampleInterval | SampleTrigger | Configure | IIviDmmMultiPoint Overview


SampleTrigger Property

IIviDmmMultiPoint.SampleTrigger Property

The sample trigger source. If the value of the Sample Count is greater than 1, the DMM enters the Wait-For-Sample-Trigger state after taking a single measurement. When a sample trigger occurs, the DMM takes the next measurement.

[Visual Basic]
Property Get SampleTrigger() As IviDmmSampleTriggerEnum
Property Let SampleTrigger(value As IviDmmSampleTriggerEnum)
[C++]
HRESULT get_SampleTrigger(IviDmmSampleTriggerEnum* value);
HRESULT put_SampleTrigger(IviDmmSampleTriggerEnum value);
[ANSI C]
HRESULT IIviDmmMultiPoint_get_SampleTrigger(IIviDmmMultiPoint* This, IviDmmSampleTriggerEnum* value);
HRESULT IIviDmmMultiPoint_put_SampleTrigger(IIviDmmMultiPoint* This, IviDmmSampleTriggerEnum value);
[C#]
public IviDmmSampleTriggerEnum SampleTrigger {get; set;}

Capability Group

IviDmmMultiPoint

Related Items

Configure

Also In This Interface

MeasurementComplete | Count | SampleCount | SampleInterval | SampleTrigger | Configure | IIviDmmMultiPoint Overview


Configure Method

IIviDmmMultiPoint.Configure Method

Configures multipoint trigger Count, SampleCount, SampleTrigger and SampleInterval properties.

[Visual Basic]
Sub Configure( _
   TriggerCount As Long, _
   SampleCount As Long, _
   SampleTrigger As IviDmmSampleTriggerEnum, _
   SampleInterval As Double _
)
[C++]
HRESULT Configure(
   long TriggerCount,
   long SampleCount,
   IviDmmSampleTriggerEnum SampleTrigger,
   double SampleInterval
);
[ANSI C]
HRESULT IIviDmmMultiPoint_Configure(
   IIviDmmMultiPoint* This
   long TriggerCount,
   long SampleCount,
   IviDmmSampleTriggerEnum SampleTrigger,
   double SampleInterval
);
[C#]
public void Configure(
   long TriggerCount,
   long SampleCount,
   IviDmmSampleTriggerEnum SampleTrigger,
   double SampleInterval
);

Parameters

TriggerCount
The number of triggers the DMM accepts before it returns to the idle state.
SampleCount
The number of measurements the DMM takes each time it receives a trigger.
SampleTrigger
The sample trigger source. If the value of the Sample Count is greater than 1, the DMM enters the Wait-For-Sample-Trigger state after taking a single measurement. When the event specified by this parameter occurs, the DMM exits the Wait-For-Sample-Trigger state and takes the next measurement.
SampleInterval
The interval between samples in seconds.

Capability Group

IviDmmMultiPoint

Related Items

Count | SampleCount | SampleTrigger | SampleInterval

Also In This Interface

MeasurementComplete | Count | SampleCount | SampleInterval | SampleTrigger | Configure | IIviDmmMultiPoint Overview


IIviDmmRTD Interface

IVI DMM class-compliant RTD interface

Methods

Configure Configures the Alpha and Resistance parameters for a resistance temperature device.

Properties

Alpha | The alpha parameter for a resistance temperature device (RTD). Applies only when the Temperature Transducer Type is set to 2 Wire RTD or 4 Wire RTD.
Resistance | The R0 parameter (resistance) for a resistance temperature device (RTD). Also known as the RTD reference value. Applies only when the Temperature Transducer Type is set to 2 Wire RTD or 4 Wire RTD.


Alpha Property

IIviDmmRTD.Alpha Property

The alpha parameter for a resistance temperature device (RTD). Applies only when the Temperature Transducer Type is set to 2 Wire RTD or 4 Wire RTD.

[Visual Basic]
Property Get Alpha() As Double
Property Let Alpha(value As Double)
[C++]
HRESULT get_Alpha(double* value);
HRESULT put_Alpha(double value);
[ANSI C]
HRESULT IIviDmmRTD_get_Alpha(IIviDmmRTD* This, double* value);
HRESULT IIviDmmRTD_put_Alpha(IIviDmmRTD* This, double value);
[C#]
public double Alpha {get; set;}

Capability Group

IviDmmResistanceTemperatureDevice

Related Items

Configure

Also In This Interface

Alpha | Resistance | Configure | IIviDmmRTD Overview


Resistance Property

IIviDmmRTD.Resistance Property

The R0 parameter (resistance) for a resistance temperature device (RTD). Also known as the RTD reference value. Applies only when the Temperature Transducer Type is set to 2 Wire RTD or 4 Wire RTD.

[Visual Basic]
Property Get Resistance() As Double
Property Let Resistance(value As Double)
[C++]
HRESULT get_Resistance(double* value);
HRESULT put_Resistance(double value);
[ANSI C]
HRESULT IIviDmmRTD_get_Resistance(IIviDmmRTD* This, double* value);
HRESULT IIviDmmRTD_put_Resistance(IIviDmmRTD* This, double value);
[C#]
public double Resistance {get; set;}

Capability Group

IviDmmResistanceTemperatureDevice

Related Items

Configure

Also In This Interface

Alpha | Resistance | Configure | IIviDmmRTD Overview


Configure Method

IIviDmmRTD.Configure Method

Configures the Alpha and Resistance parameters for a resistance temperature device.

[Visual Basic]
Sub Configure( _
   Alpha As Double, _
   Resistance As Double _
)
[C++]
HRESULT Configure(
   double Alpha,
   double Resistance
);
[ANSI C]
HRESULT IIviDmmRTD_Configure(
   IIviDmmRTD* This
   double Alpha,
   double Resistance
);
[C#]
public void Configure(
   double Alpha,
   double Resistance
);

Parameters

Alpha
The alpha parameter for a resistance temperature device (RTD).
Resistance
The R0 parameter (resistance) for a resistance temperature device (RTD) also known as the RTD reference value.

Capability Group

IviDmmResistanceTemperatureDevice

Related Items

Alpha | Resistance

Also In This Interface

Alpha | Resistance | Configure | IIviDmmRTD Overview


IIviDmmTemperature Interface

IVI DMM class-compliant temperature interface

Properties

TransducerType | The type of device used to measure the temperature. This property affects instrument behavior only when Function is set to a temperature measurement.
RTD | Pointer to the class-compliant IIviDmmRtd interface
Thermocouple | Pointer to the class-compliant IIviDmmThermocouple interface
Thermistor | Pointer to the class-compliant IIviDmmThermistor interface


TransducerType Property

IIviDmmTemperature.TransducerType Property

The type of device used to measure the temperature. This property affects instrument behavior only when Function is set to a temperature measurement.

[Visual Basic]
Property Get TransducerType() As IviDmmTransducerTypeEnum
Property Let TransducerType(value As IviDmmTransducerTypeEnum)
[C++]
HRESULT get_TransducerType(IviDmmTransducerTypeEnum* value);
HRESULT put_TransducerType(IviDmmTransducerTypeEnum value);
[ANSI C]
HRESULT IIviDmmTemperature_get_TransducerType(IIviDmmTemperature* This, IviDmmTransducerTypeEnum* value);
HRESULT IIviDmmTemperature_put_TransducerType(IIviDmmTemperature* This, IviDmmTransducerTypeEnum value);
[C#]
public IviDmmTransducerTypeEnum TransducerType {get; set;}

Capability Group

IviDmmTemperatureMeasurement

Also In This Interface

TransducerType | RTD | Thermocouple | Thermistor | IIviDmmTemperature Overview


RTD Property

IIviDmmTemperature.RTD Property

Pointer to the class-compliant IIviDmmRtd interface

[Visual Basic]
Property Get RTD() As IIviDmmRTD
[C++]
HRESULT get_RTD(IIviDmmRTD** value);
[ANSI C]
HRESULT IIviDmmTemperature_get_RTD(IIviDmmTemperature* This, IIviDmmRTD** value);
[C#]
public IIviDmmRTD RTD {get;}

Capability Group

IviDmmResistanceTemperatureDevice

Also In This Interface

TransducerType | RTD | Thermocouple | Thermistor | IIviDmmTemperature Overview


Thermocouple Property

IIviDmmTemperature.Thermocouple Property

Pointer to the class-compliant IIviDmmThermocouple interface

[Visual Basic]
Property Get Thermocouple() As IIviDmmThermocouple
[C++]
HRESULT get_Thermocouple(IIviDmmThermocouple** value);
[ANSI C]
HRESULT IIviDmmTemperature_get_Thermocouple(IIviDmmTemperature* This, IIviDmmThermocouple** value);
[C#]
public IIviDmmThermocouple Thermocouple {get;}

Capability Group

IviDmmThermocouple

Also In This Interface

TransducerType | RTD | Thermocouple | Thermistor | IIviDmmTemperature Overview


Thermistor Property

IIviDmmTemperature.Thermistor Property

Pointer to the class-compliant IIviDmmThermistor interface

[Visual Basic]
Property Get Thermistor() As IIviDmmThermistor
[C++]
HRESULT get_Thermistor(IIviDmmThermistor** value);
[ANSI C]
HRESULT IIviDmmTemperature_get_Thermistor(IIviDmmTemperature* This, IIviDmmThermistor** value);
[C#]
public IIviDmmThermistor Thermistor {get;}

Capability Group

IviDmmThermistor

Also In This Interface

TransducerType | RTD | Thermocouple | Thermistor | IIviDmmTemperature Overview


IIviDmmThermistor Interface

IVI DMM class-compliant thermistor interface

Properties

Resistance The resistance of the thermistor in Ohms. Applies only when the Temperature Transducer Type property is Thermistor.


Resistance Property

IIviDmmThermistor.Resistance Property

The resistance of the thermistor in Ohms. Applies only when the Temperature Transducer Type property is Thermistor.

[Visual Basic]
Property Get Resistance() As Double
Property Let Resistance(value As Double)
[C++]
HRESULT get_Resistance(double* value);
HRESULT put_Resistance(double value);
[ANSI C]
HRESULT IIviDmmThermistor_get_Resistance(IIviDmmThermistor* This, double* value);
HRESULT IIviDmmThermistor_put_Resistance(IIviDmmThermistor* This, double value);
[C#]
public double Resistance {get; set;}

Capability Group

IviDmmThermistor

Also In This Interface

Resistance | IIviDmmThermistor Overview


IIviDmmThermocouple Interface

IVI DMM class-compliant thermocouple interface

Methods

Configure Configures the thermocouple Type and RefJunctionType properties of a thermocouple. Applies only when the Temperature Transducer Type is Thermocouple.

Properties

FixedRefJunction | The external reference junction temperature when a fixed reference junction thermocouple is used to measure temperature, or the thermocouple junction temperature of an instrument without an internal temperature sensor, in degrees Celcius.
RefJunctionType | The type of reference junction to be used in the reference junction compensation of a thermocouple measurement. Applies only when the Temperature Transducer Type is Thermocouple.
Type | The type of thermocouple used to measure the temperature. Applies only when the Temperature Transducer Type is Thermocouple.


FixedRefJunction Property

IIviDmmThermocouple.FixedRefJunction Property

The external reference junction temperature when a fixed reference junction thermocouple is used to measure temperature, or the thermocouple junction temperature of an instrument without an internal temperature sensor, in degrees Celcius.

[Visual Basic]
Property Get FixedRefJunction() As Double
Property Let FixedRefJunction(value As Double)
[C++]
HRESULT get_FixedRefJunction(double* value);
HRESULT put_FixedRefJunction(double value);
[ANSI C]
HRESULT IIviDmmThermocouple_get_FixedRefJunction(IIviDmmThermocouple* This, double* value);
HRESULT IIviDmmThermocouple_put_FixedRefJunction(IIviDmmThermocouple* This, double value);
[C#]
public double FixedRefJunction {get; set;}

Capability Group

IviDmmThermocouple

Also In This Interface

FixedRefJunction | RefJunctionType | Type | Configure | IIviDmmThermocouple Overview


RefJunctionType Property

IIviDmmThermocouple.RefJunctionType Property

The type of reference junction to be used in the reference junction compensation of a thermocouple measurement. Applies only when the Temperature Transducer Type is Thermocouple.

[Visual Basic]
Property Get RefJunctionType() As IviDmmRefJunctionTypeEnum
Property Let RefJunctionType(value As IviDmmRefJunctionTypeEnum)
[C++]
HRESULT get_RefJunctionType(IviDmmRefJunctionTypeEnum* value);
HRESULT put_RefJunctionType(IviDmmRefJunctionTypeEnum value);
[ANSI C]
HRESULT IIviDmmThermocouple_get_RefJunctionType(IIviDmmThermocouple* This, IviDmmRefJunctionTypeEnum* value);
HRESULT IIviDmmThermocouple_put_RefJunctionType(IIviDmmThermocouple* This, IviDmmRefJunctionTypeEnum value);
[C#]
public IviDmmRefJunctionTypeEnum RefJunctionType {get; set;}

Capability Group

IviDmmThermocouple

Related Items

Configure

Also In This Interface

FixedRefJunction | RefJunctionType | Type | Configure | IIviDmmThermocouple Overview


Type Property

IIviDmmThermocouple.Type Property

The type of thermocouple used to measure the temperature. Applies only when the Temperature Transducer Type is Thermocouple.

[Visual Basic]
Property Get Type() As IviDmmThermocoupleTypeEnum
Property Let Type(value As IviDmmThermocoupleTypeEnum)
[C++]
HRESULT get_Type(IviDmmThermocoupleTypeEnum* value);
HRESULT put_Type(IviDmmThermocoupleTypeEnum value);
[ANSI C]
HRESULT IIviDmmThermocouple_get_Type(IIviDmmThermocouple* This, IviDmmThermocoupleTypeEnum* value);
HRESULT IIviDmmThermocouple_put_Type(IIviDmmThermocouple* This, IviDmmThermocoupleTypeEnum value);
[C#]
public IviDmmThermocoupleTypeEnum Type {get; set;}

Capability Group

IviDmmThermocouple

Related Items

Configure

Also In This Interface

FixedRefJunction | RefJunctionType | Type | Configure | IIviDmmThermocouple Overview


Configure Method

IIviDmmThermocouple.Configure Method

Configures the thermocouple Type and RefJunctionType properties of a thermocouple. Applies only when the Temperature Transducer Type is Thermocouple.

[Visual Basic]
Sub Configure( _
   Type As IviDmmThermocoupleTypeEnum, _
   RefJunctionType As IviDmmRefJunctionTypeEnum _
)
[C++]
HRESULT Configure(
   IviDmmThermocoupleTypeEnum Type,
   IviDmmRefJunctionTypeEnum RefJunctionType
);
[ANSI C]
HRESULT IIviDmmThermocouple_Configure(
   IIviDmmThermocouple* This
   IviDmmThermocoupleTypeEnum Type,
   IviDmmRefJunctionTypeEnum RefJunctionType
);
[C#]
public void Configure(
   IviDmmThermocoupleTypeEnum Type,
   IviDmmRefJunctionTypeEnum RefJunctionType
);

Parameters

Type
The type of thermocouple used to measure the temperature.
RefJunctionType
The type of reference junction used in the reference junction compensation.

Capability Group

IviDmmThermocouple

Related Items

Type | RefJunctionType

Also In This Interface

FixedRefJunction | RefJunctionType | Type | Configure | IIviDmmThermocouple Overview


IIviDmmTrigger Interface

IVI DMM class-compliant trigger interface

Methods

Configure Configures the trigger Source and Delay properties.

Properties

Slope | The polarity of the external trigger slope, which determines whether the DMM triggers on either the rising or the falling edge of the external trigger source.
Delay | The interval between the time when the DMM receives the trigger and the time when it takes a measurement. Positive values set the trigger delay in seconds. Negative values set auto delay mode.
Source | The trigger source.
MultiPoint | Pointer to the class-compliant IIviDmmMultipoint interface


Slope Property

IIviDmmTrigger.Slope Property

The polarity of the external trigger slope, which determines whether the DMM triggers on either the rising or the falling edge of the external trigger source.

[Visual Basic]
Property Get Slope() As IviDmmTriggerSlopeEnum
Property Let Slope(value As IviDmmTriggerSlopeEnum)
[C++]
HRESULT get_Slope(IviDmmTriggerSlopeEnum* value);
HRESULT put_Slope(IviDmmTriggerSlopeEnum value);
[ANSI C]
HRESULT IIviDmmTrigger_get_Slope(IIviDmmTrigger* This, IviDmmTriggerSlopeEnum* value);
HRESULT IIviDmmTrigger_put_Slope(IIviDmmTrigger* This, IviDmmTriggerSlopeEnum value);
[C#]
public IviDmmTriggerSlopeEnum Slope {get; set;}

Capability Group

IviDmmTriggerSlope

Also In This Interface

Slope | Delay | Source | MultiPoint | Configure | IIviDmmTrigger Overview


Delay Property

IIviDmmTrigger.Delay Property

The interval between the time when the DMM receives the trigger and the time when it takes a measurement. Positive values set the trigger delay in seconds. Negative values set auto delay mode.

[Visual Basic]
Property Get Delay() As Double
Property Let Delay(value As Double)
[C++]
HRESULT get_Delay(double* value);
HRESULT put_Delay(double value);
[ANSI C]
HRESULT IIviDmmTrigger_get_Delay(IIviDmmTrigger* This, double* value);
HRESULT IIviDmmTrigger_put_Delay(IIviDmmTrigger* This, double value);
[C#]
public double Delay {get; set;}

Capability Group

IviDmmBase

Related Items

Configure

Also In This Interface

Slope | Delay | Source | MultiPoint | Configure | IIviDmmTrigger Overview


Source Property

IIviDmmTrigger.Source Property

The trigger source.

[Visual Basic]
Property Get Source() As IviDmmTriggerSourceEnum
Property Let Source(value As IviDmmTriggerSourceEnum)
[C++]
HRESULT get_Source(IviDmmTriggerSourceEnum* value);
HRESULT put_Source(IviDmmTriggerSourceEnum value);
[ANSI C]
HRESULT IIviDmmTrigger_get_Source(IIviDmmTrigger* This, IviDmmTriggerSourceEnum* value);
HRESULT IIviDmmTrigger_put_Source(IIviDmmTrigger* This, IviDmmTriggerSourceEnum value);
[C#]
public IviDmmTriggerSourceEnum Source {get; set;}

Capability Group

IviDmmBase

Related Items

Configure

Also In This Interface

Slope | Delay | Source | MultiPoint | Configure | IIviDmmTrigger Overview


MultiPoint Property

IIviDmmTrigger.MultiPoint Property

Pointer to the class-compliant IIviDmmMultipoint interface

[Visual Basic]
Property Get MultiPoint() As IIviDmmMultiPoint
[C++]
HRESULT get_MultiPoint(IIviDmmMultiPoint** value);
[ANSI C]
HRESULT IIviDmmTrigger_get_MultiPoint(IIviDmmTrigger* This, IIviDmmMultiPoint** value);
[C#]
public IIviDmmMultiPoint MultiPoint {get;}

Capability Group

IviDmmMultiPoint

Also In This Interface

Slope | Delay | Source | MultiPoint | Configure | IIviDmmTrigger Overview


Configure Method

IIviDmmTrigger.Configure Method

Configures the trigger Source and Delay properties.

[Visual Basic]
Sub Configure( _
   TriggerSource As IviDmmTriggerSourceEnum, _
   TriggerDelay As Double _
)
[C++]
HRESULT Configure(
   IviDmmTriggerSourceEnum TriggerSource,
   double TriggerDelay
);
[ANSI C]
HRESULT IIviDmmTrigger_Configure(
   IIviDmmTrigger* This
   IviDmmTriggerSourceEnum TriggerSource,
   double TriggerDelay
);
[C#]
public void Configure(
   IviDmmTriggerSourceEnum TriggerSource,
   double TriggerDelay
);

Parameters

TriggerSource
Trigger source.
TriggerDelay
The length of time between when the DMM receives the trigger and when it takes a measurement. Use positive values to set the trigger delay in seconds. Negative values are reserved for the auto delay mode.

Capability Group

IviDmmBase

Related Items

Source | Delay

Also In This Interface

Slope | Delay | Source | MultiPoint | Configure | IIviDmmTrigger Overview


IviDmmApertureTimeUnitsEnum Enumeration

IVI DMM class-compliant values for ApertureTimeUnits

Members

Member Name | Description
IviDmmApertureSeconds | Units for the value returned by Aperture Time are seconds.
IviDmmAperturePowerLineCycles | Units for the value returned by Aperture Time are Power Line Cycles.


IviDmmAutoRangeEnum Enumeration

IVI DMM class-compliant AutoRange values that can be used for Range

Members

Member Name | Description
IviDmmAutoRangeOn | Sets the DMM to calculate the range before each measurement automatically.
IviDmmAutoRangeOff | Disables auto-ranging.
IviDmmAutoRangeOnce | Sets the DMM to calculate the range before the next measurement and then disable auto-ranging.


IviDmmAutoZeroEnum Enumeration

IVI DMM class-compliant values for AutoZero

Members

Member Name | Description
IviDmmAutoZeroOff | Disables the auto-zero feature.
IviDmmAutoZeroOn | The DMM to take a Zero Reading for each measurement.
IviDmmAutoZeroOnce | The DMM takes one a Zero Reading immediately and then disables the auto-zero feature.


IviDmmErrorCodesEnum Enumeration

IVI DMM class defined HRESULTS

Members

Member Name | Description
E_IVIDMM_TRIGGER_NOT_SOFTWARE | The trigger source is not set to software trigger.
E_IVIDMM_MAX_TIME_EXCEEDED | Max Time Exceeded
S_IVIDMM_OVER_RANGE | Over Range


IviDmmFrequencyVoltageRangeEnum Enumeration

IVI DMM class-compliant values for frequency VoltageRange

Members

Member Name | Description
IviDmmFrequencyVoltageRangeAutoRangeOn | Sets the DMM to calculate the frequency voltage range before each measurement automatically.
IviDmmFrequencyVoltageRangeAutoRangeOff | Disables auto-ranging.


IviDmmFunctionEnum Enumeration

IVI DMM class-compliant values for Function

Members

Member Name | Description
IviDmmFunctionDCVolts | Sets the DMM to measure DC voltage.
IviDmmFunctionACVolts | Sets the DMM to measure AC voltage.
IviDmmFunctionDCCurrent | Sets the DMM to measure DC current..
IviDmmFunctionACCurrent | Sets the DMM to measure AC current.
IviDmmFunction2WireRes | Sets the DMM to measure 2-wire resistance.
IviDmmFunction4WireRes | Sets the DMM to measure 4-wire resistance.
IviDmmFunctionACPlusDCVolts | Sets the DMM to measure AC plus DC voltage.
IviDmmFunctionACPlusDCCurrent | Sets the DMM to measure AC plus DC current.
IviDmmFunctionFreq | Sets the DMM to measure frequency.
IviDmmFunctionPeriod | Sets the DMM to measure period.
IviDmmFunctionTemperature | Sets the DMM to measure temperature.


IviDmmMaxTimeEnum Enumeration

IVI DMM class-compliant values for MaxTime

Members

Member Name | Description
IviDmmMaxTimeInfinite | Wait indefinitely for the measurement to complete.
IviDmmMaxTimeImmediate | Return immediately. If no valid measurement value exists, return an error.


IviDmmMeasCompleteDestEnum Enumeration

IVI DMM class-compliant values for multipoint MeasurementComplete

Members

Member Name | Description
IviDmmMeasCompleteDestNone | The measurement complete signal is not routed.
IviDmmMeasCompleteDestExternal | Routes the measurement complete signal to the external connector.
IviDmmMeasCompleteDestTTL0 | Routes the measurement complete signal to TTL0.
IviDmmMeasCompleteDestTTL1 | Routes the measurement complete signal to TTL1.
IviDmmMeasCompleteDestTTL2 | Routes the measurement complete signal to TTL2.
IviDmmMeasCompleteDestTTL3 | Routes the measurement complete signal to TTL3.
IviDmmMeasCompleteDestTTL4 | Routes the measurement complete signal to TTL4.
IviDmmMeasCompleteDestTTL5 | Routes the measurement complete signal to TTL5.
IviDmmMeasCompleteDestTTL6 | Routes the measurement complete signal to TTL6.
IviDmmMeasCompleteDestTTL7 | Routes the measurement complete signal to TTL7.
IviDmmMeasCompleteDestECL0 | Routes the measurement complete signal to ECL0.
IviDmmMeasCompleteDestECL1 | Routes the measurement complete signal to ECL1.
IviDmmMeasCompleteDestPXIStar | Routes the measurement complete signal to the PXI Star trigger bus.
IviDmmMeasCompleteDestRTSI0 | Routes the measurement complete signal to RTSI0.
IviDmmMeasCompleteDestRTSI1 | Routes the measurement complete signal to RTSI1.
IviDmmMeasCompleteDestRTSI2 | Routes the measurement complete signal to RTSI2.
IviDmmMeasCompleteDestRTSI3 | Routes the measurement complete signal to RTSI3.
IviDmmMeasCompleteDestRTSI4 | Routes the measurement complete signal to RTSI4.
IviDmmMeasCompleteDestRTSI5 | Routes the measurement complete signal to RTSI5.
IviDmmMeasCompleteDestRTSI6 | Routes the measurement complete signal to RTSI6.


IviDmmRefJunctionTypeEnum Enumeration

IVI DMM class-compliant values for thermocouple RefJunctionType

Members

Member Name | Description
IviDmmRefJunctionTypeInternal | Sets the DMM to use an internal sensor at the thermocouple junction for the junction compensation.
IviDmmRefJunctionTypeFixed | Sets the DMM to use an internal sensor at the thermocouple junction for the junction compensation.


IviDmmSampleTriggerEnum Enumeration

IVI DMM class-compliant values for multipoint SampleTrigger

Members

Member Name | Description
IviDmmSampleTriggerImmediate | The DMM exits the Wait-For-Sample-Trigger state immediately after entering. It does not wait for a trigger of any kind.
IviDmmSampleTriggerExternal | The DMM exits the Wait-For-Sample-Trigger state when a trigger occurs on the external trigger input.
IviDmmSampleTriggerSwTrigFunc | The DMM exits the Wait-For-Sample-Trigger state when the Send Software Trigger function executes.
IviDmmSampleTriggerTTL0 | The DMM exits the Wait-For-Sample-Trigger state when it receives a trigger on TTL0.
IviDmmSampleTriggerTTL1 | The DMM exits the Wait-For-Sample-Trigger state when it receives a trigger on TTL1.
IviDmmSampleTriggerTTL2 | The DMM exits the Wait-For-Sample-Trigger state when it receives a trigger on TTL2.
IviDmmSampleTriggerTTL3 | The DMM exits the Wait-For-Sample-Trigger state when it receives a trigger on TTL3.
IviDmmSampleTriggerTTL4 | The DMM exits the Wait-For-Sample-Trigger state when it receives a trigger on TTL4.
IviDmmSampleTriggerTTL5 | The DMM exits the Wait-For-Sample-Trigger state when it receives a trigger on TTL5.
IviDmmSampleTriggerTTL6 | The DMM exits the Wait-For-Sample-Trigger state when it receives a trigger on TTL6.
IviDmmSampleTriggerTTL7 | The DMM exits the Wait-For-Sample-Trigger state when it receives a trigger on TTL7.
IviDmmSampleTriggerECL0 | The DMM exits the Wait-For-Sample-Trigger state when it receives a trigger on ECL0.
IviDmmSampleTriggerECL1 | The DMM exits the Wait-For-Sample-Trigger state when it receives a trigger on ECL1.
IviDmmSampleTriggerPXIStar | The DMM exits the Wait-For-Sample-Trigger state when it receives a trigger on the PXI Star trigger bus.
IviDmmSampleTriggerRTSI0 | The DMM exits the Wait-For-Sample-Trigger state when it receives a trigger on RTSI0.
IviDmmSampleTriggerRTSI1 | The DMM exits the Wait-For-Sample-Trigger state when it receives a trigger on RTSI1.
IviDmmSampleTriggerRTSI2 | The DMM exits the Wait-For-Sample-Trigger state when it receives a trigger on RTSI2.
IviDmmSampleTriggerRTSI3 | The DMM exits the Wait-For-Sample-Trigger state when it receives a trigger on RTSI3.
IviDmmSampleTriggerRTSI4 | The DMM exits the Wait-For-Sample-Trigger state when it receives a trigger on RTSI4.
IviDmmSampleTriggerRTSI5 | The DMM exits the Wait-For-Sample-Trigger state when it receives a trigger on RTSI5.
IviDmmSampleTriggerRTSI6 | The DMM exits the Wait-For-Sample-Trigger state when it receives a trigger on RTSI6.
IviDmmSampleTriggerInterval | The DMM exits the Wait-For-Sample-Trigger state when the length of time specified by the Sample Interval attribute elapses.


IviDmmThermocoupleTypeEnum Enumeration

IVI DMM class-compliant values for thermocouple Type

Members

Member Name | Description
IviDmmThermocoupleTypeB | Sets the DMM to measure temperature from a B-type thermocouple.
IviDmmThermocoupleTypeC | Sets the DMM to measure temperature from a C-type thermocouple.
IviDmmThermocoupleTypeD | Sets the DMM to measure temperature from a D-type thermocouple.
IviDmmThermocoupleTypeE | Sets the DMM to measure temperature from a E-type thermocouple.
IviDmmThermocoupleTypeG | Sets the DMM to measure temperature from a G-type thermocouple.
IviDmmThermocoupleTypeJ | Sets the DMM to measure temperature from a J-type thermocouple.
IviDmmThermocoupleTypeK | Sets the DMM to measure temperature from a K-type thermocouple.
IviDmmThermocoupleTypeN | Sets the DMM to measure temperature from a N-type thermocouple.
IviDmmThermocoupleTypeR | Sets the DMM to measure temperature from a R-type thermocouple.
IviDmmThermocoupleTypeS | Sets the DMM to measure temperature from a S-type thermocouple.
IviDmmThermocoupleTypeT | Sets the DMM to measure temperature from a T-type thermocouple.
IviDmmThermocoupleTypeU | Sets the DMM to measure temperature from a U-type thermocouple.
IviDmmThermocoupleTypeV | Sets the DMM to measure temperature from a V-type thermocouple.


IviDmmTransducerTypeEnum Enumeration

IVI DMM class-compliant values for temperature TransducerType

Members

Member Name | Description
IviDmmTransducerTypeThermocouple | Sets the DMM to measure temperature using a thermocouple.
IviDmmTransducerTypeThermistor | Sets the DMM to measure temperature using a thermistor.
IviDmmTransducerType2WireRtd | Sets the DMM to measure temperature using a 2-wire temperature resistance device.
IviDmmTransducerType4WireRtd | Sets the DMM to measure temperature using a 4-wire temperature resistance device.


IviDmmTriggerDelayEnum Enumeration

IVI DMM class-compliant values for trigger Delay

Members

Member Name | Description
IviDmmTriggerDelayAutoDelayOn | Sets the DMM to calculate the trigger delay before each measurement.
IviDmmTriggerDelayAutoDelayOff | Stops the DMM from calculating the trigger delay.


IviDmmTriggerSlopeEnum Enumeration

IVI DMM class-compliant values for trigger Slope

Members

Member Name | Description
IviDmmTriggerSlopePositive | Sets the trigger event to occur on the rising edge of the trigger pulse.
IviDmmTriggerSlopeNegative | Sets the trigger event to occur on the rising edge of the trigger pulse.


IviDmmTriggerSourceEnum Enumeration

IVI DMM class-compliant values for trigger Source

Members

Member Name | Description
IviDmmTriggerSourceImmediate | The DMM exits the Wait-For-Trigger state immediately after entering. It does not wait for a trigger of any kind.
IviDmmTriggerSourceExternal | The DMM exits the Wait-For-Trigger state when a trigger occurs on the external trigger input.
IviDmmTriggerSourceSwTrigFunc | The DMM exits the Wait-For-Trigger state when the Send Software Trigger function executes.
IviDmmTriggerSourceTTL0 | The DMM exits the Wait-For-Trigger state when it receives a trigger on TTL0.
IviDmmTriggerSourceTTL1 | The DMM exits the Wait-For-Trigger state when it receives a trigger on TTL1.
IviDmmTriggerSourceTTL2 | The DMM exits the Wait-For-Trigger state when it receives a trigger on TTL2.
IviDmmTriggerSourceTTL3 | The DMM exits the Wait-For-Trigger state when it receives a trigger on TTL3.
IviDmmTriggerSourceTTL4 | The DMM exits the Wait-For-Trigger state when it receives a trigger on TTL4.
IviDmmTriggerSourceTTL5 | The DMM exits the Wait-For-Trigger state when it receives a trigger on TTL5.
IviDmmTriggerSourceTTL6 | The DMM exits the Wait-For-Trigger state when it receives a trigger on TTL6.
IviDmmTriggerSourceTTL7 | The DMM exits the Wait-For-Trigger state when it receives a trigger on TTL7.
IviDmmTriggerSourceECL0 | The DMM exits the Wait-For-Trigger state when it receives a trigger on ECL0.
IviDmmTriggerSourceECL1 | The DMM exits the Wait-For-Trigger state when it receives a trigger on ECL1.
IviDmmTriggerSourcePXIStar | The DMM exits the Wait-For-Trigger state when it receives a trigger on the PXI Star trigger bus.
IviDmmTriggerSourceRTSI0 | The DMM exits the Wait-For-Trigger state when it receives a trigger on RTSI0.
IviDmmTriggerSourceRTSI1 | The DMM exits the Wait-For-Trigger state when it receives a trigger on RTSI1.
IviDmmTriggerSourceRTSI2 | The DMM exits the Wait-For-Trigger state when it receives a trigger on RTSI2.
IviDmmTriggerSourceRTSI3 | The DMM exits the Wait-For-Trigger state when it receives a trigger on RTSI3.
IviDmmTriggerSourceRTSI4 | The DMM exits the Wait-For-Trigger state when it receives a trigger on RTSI4.
IviDmmTriggerSourceRTSI5 | The DMM exits the Wait-For-Trigger state when it receives a trigger on RTSI5.
IviDmmTriggerSourceRTSI6 | The DMM exits the Wait-For-Trigger state when it receives a trigger on RTSI6.


Topic Not Found

No matching topic was found. The link may be out of date, incorrectly authored, or the topic may not be available in this release.

You may be able to find the topic by using the index or search tab instead.


Inherent Interface

IVI Inherent Interfaces

IIviDriver | IVI Driver root interface
IIviDriverIdentity | IVI Driver identity interface
IIviDriverOperation | IVI Driver operation interface
IIviDriverUtility | IVI Driver utility interface


IviDriver_ErrorCodes Enumeration

IVI Driver (inherent features) defined HRESULTS

Members

Member Name | Description
S_IVI_SUCCESS | Success
E_IVI_CANNOT_RECOVER | Unrecoverable failure
E_IVI_INSTRUMENT_STATUS | Instrument error detected
E_IVI_CANNOT_OPEN_FILE | File could not be opened
E_IVI_READING_FILE | File could not be read
E_IVI_WRITING_FILE | File could not be written
E_IVI_INVALID_PATHNAME | The path name is invalid
E_IVI_INVALID_VALUE | Invalid value for parameter or property
E_IVI_METHOD_NOT_SUPPORTED | Method not supported
E_IVI_PROPERTY_NOT_SUPPORTED | Property not supported
E_IVI_VALUE_NOT_SUPPORTED | The enumeration value for the parameter is not supported
E_IVI_NOT_INITIALIZED | A connection to the instrument has not been initialized
E_IVI_UNKNOWN_CHANNEL_NAME | Channel or repeated capability name specified is not valid for the instrument.
E_IVI_TOO_MANY_OPEN_FILES | Too many files opened
E_IVI_CHANNEL_NAME_REQUIRED | Channel or repeated capability name required
E_IVI_MISSING_OPTION_NAME | The option string contains an entry without a name.
E_IVI_MISSING_OPTION_VALUE | The option string contains an entry without a value.
E_IVI_BAD_OPTION_NAME | The option string contains an entry with an unknown option name.
E_IVI_BAD_OPTION_VALUE | The option string contains an entry with an unknown option value.
E_IVI_OUT_OF_MEMORY | The necessary memory could not be allocated
E_IVI_OPERATION_PENDING | Operation in progress
E_IVI_NULL_POINTER | Null pointer passed for parameter or property
E_IVI_UNEXPECTED_RESPONSE | Unexpected response from the instrument
E_IVI_FILE_NOT_FOUND | File not found
E_IVI_INVALID_FILE_FORMAT | The file format is invalid
E_IVI_STATUS_NOT_AVAILABLE | The instrument status is not available
E_IVI_ID_QUERY_FAILED | Instrument ID query failed
E_IVI_RESET_FAILED | Instrument reset failed
E_IVI_RESOURCE_UNKNOWN | Insufficient location information or resource not present in the system.
E_IVI_ALREADY_INITIALIZED | The driver is already initialized
E_IVI_CANNOT_CHANGE_SIMULATION_STATE | The simulation state cannot be changed.
S_IVI_NSUP_ID_QUERY | Identification query not supported
S_IVI_NSUP_RESET | Reset operation not supported
S_IVI_NSUP_SELF_TEST | Self test operation not supported
S_IVI_NSUP_ERROR_QUERY | Error query operation not supported
S_IVI_NSUP_REV_QUERY | Revision query not supported


IIviDriver Interface

IVI Driver root interface

Methods

Initialize | Opens the I/O session to the instrument. Driver methods and properties that access the instrument are only accessible after Initialize is called. Initialize optionally performs a Reset and queries the instrument to validate the instrument model.
Close | Closes the I/O session to the instrument. Driver methods and properties that access the instrument are not accessible after Close is called.

Properties

DriverOperation | Pointer to the IIviDriverOperation interface
Identity | Pointer to the IIviDriverIdentity interface
Utility | Pointer to the IIviDriverUtility interface
Initialized | Initialized is True between a successful call to the Initialize method and a successful call to the Close method, and False at all other times.


IIviDriverIdentity Interface

IVI Driver identity interface

Properties

Description | A brief description of the implementing component. Description is limted to 256 bytes.
Revision | The revision of the implementing component. Refer to IVI 3.1, Section 3.1.2.2, for a description of revision syntax and semantics. Revision is limited to 256 bytes.
Vendor | The name of the vendor that supplies the implementing component. Vendor is limited to 256 bytes.
InstrumentManufacturer | The name of the manufacturer reported by the physical instrument. If Simulation is enabled or the instrument is not capable of reporting the name of the manufacturer, a string is returned that explains the condition. Manufacturer is limited to 256 bytes
InstrumentModel | The model number or name reported by the physical instrument. If Simulation is enabled or the instrument is not capable of reporting the model number or name, a string is returned that explains the condition. Model is limited to 256 bytes
InstrumentFirmwareRevision | The firmware revision reported by the physical instrument. If Simulation is enabled or the instrument is not capable of reporting the firmware revision, a string is returned that explains the condition.
Identifier | The case-sensitive unique identifier of the implementing IVI-COM instrument driver.
SupportedInstrumentModels | A comma-separated list of instrument models that the IVI specific driver can control. The string does not include an abbreviation for the manufacturer if it is the same for all models.
SpecificationMajorVersion | For IVI class-compliant drivers, the major version number of the instrument class specification. If the driver is not class compliant, the driver returns zero.
SpecificationMinorVersion | For IVI class-compliant drivers, the minor version number of the instrument class specification. If the driver is not class compliant, the driver returns zero.
GroupCapabilities | A comma-separated list of the class capability groups implemented by the driver. Capability group names are documented in the IVI class specifications. If the driver is not class compliant, the driver returns an empty string.


IIviDriverOperation Interface

IVI Driver operation interface

Methods

InvalidateAllAttributes | Invalidates all of the driver's cached values.
ClearInterchangeWarnings | Clears the list of interchangeability warnings that the IVI specific driver maintains.
GetNextInterchangeWarning | Returns the oldest warning from the interchange warning list. Records are only added to the list if InterchangeCheck is True.
ResetInterchangeCheck | Resets the interchangeability checking algorithms of the driver so that methods and properties that executed prior to calling this function have no affect on whether future calls to the driver generate interchangeability warnings.
GetNextCoercionRecord | Returns the oldest record from the coercion record list. Records are only added to the list if RecordCoercions is True.

Properties

LogicalName | Logical Name identifies a driver session in the Configuration Store. If Logical Name is not empty, the driver was initialized from information in the driver session. If it is empty, the driver was initialized without using the Configuration Store.
IoResourceDescriptor | The resource descriptor specifies the connection to a physical device. It is either specified in the Configuration Store or passed in the ResourceName parameter of the Initialize function. It is empty if the driver is not initialized.
Cache | Drivers may choose to always cache some instrument settings, never cache others, and optionally cache others, to avoid unecessary I/O to the instrument. If True, the driver caches optionally cached instrument settings.
InterchangeCheck | If True, the driver maintains a record of interchangeability warnings. If the driver does not support interchangeability checking, attempts to set InterchangeCheck to True return an error.
QueryInstrumentStatus | If True, the driver queries the instrument status at the end of each method or property that performs I/O to the instrument. If an error is reported, use ErrorQuery to retrieve error messages one at a time from the instrument.
RangeCheck | Drivers may choose to always validate some property/parameter values, never validate others, and optionally validate others, to avoid sending invalid commands to the instrument. If True, the driver performs optional validations.
RecordCoercions | If True, the driver keeps a list of the value coercions it makes for ViInt32 and ViReal64 attributes. If the driver does not support coercion recording, attempts to set RecordCoercions to True will return an error.
Simulate | If True, the driver does not perform I/O to the instrument, and returns simulated values for output parameters.
DriverSetup | The driver setup string. It is either specified in the Configuration Store or passed in the OptionString parameter of the Initialize function. Driver setup is empty if the driver is not initialized.


IIviDriverUtility Interface

IVI Driver utility interface

Methods

Reset | Places the instrument in a known state and configures instrument options on which the IVI specific driver depends (for example, enabling/disabling headers). For an IEEE 488.2 instrument, Reset sends the command string *RST to the instrument.
ResetWithDefaults | Does the equivalent of Reset and then, (1) disables class extension capability groups, (2) sets attributes to initial values defined by class specs, and (3) configures the driver to option string settings used when Initialize was last executed.
Disable | Quickly places the instrument in a state where it has no, or minimal, effect on the external system to which it is connected. This state is not necessarily a known state.
SelfTest | Performs an instrument self test, waits for the instrument to complete the test, and queries the instrument for the results. If the instrument passes the test, TestResult is zero and TestMessage is 'Self test passed'.
ErrorQuery | Queries the instrument and returns instrument specific error information. This function can be used when QueryInstrumentStatus is True to retrieve error details when the driver detects an instrument error.
LockObject | Obtains a multithread lock on the driver after waiting until all other execution threads have released their locks on the instrument session.
UnlockObject | Releases a previously obtained mutlithread lock.


Close Method

IIviDriver.Close Method

Closes the I/O session to the instrument. Driver methods and properties that access the instrument are not accessible after Close is called.

[Visual Basic]
Sub Close()
[C++]
HRESULT Close();
[ANSI C]
HRESULT IIviDriver_Close(
   IIviDriver* This);
[C#]
public void Close();

Related Items

Initialize

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Initialize | Close | IIviDriver Overview


DriverOperation Property

IIviDriver.DriverOperation Property

Pointer to the IIviDriverOperation interface

[Visual Basic]
Property Get DriverOperation() As IIviDriverOperation
[C++]
HRESULT get_DriverOperation(IIviDriverOperation** value);
[ANSI C]
HRESULT IIviDriver_get_DriverOperation(IIviDriver* This, IIviDriverOperation** value);
[C#]
public IIviDriverOperation DriverOperation {get;}

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Initialize | Close | IIviDriver Overview


Identity Property

IIviDriver.Identity Property

Pointer to the IIviDriverIdentity interface

[Visual Basic]
Property Get Identity() As IIviDriverIdentity
[C++]
HRESULT get_Identity(IIviDriverIdentity** value);
[ANSI C]
HRESULT IIviDriver_get_Identity(IIviDriver* This, IIviDriverIdentity** value);
[C#]
public IIviDriverIdentity Identity {get;}

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Initialize | Close | IIviDriver Overview


Initialize Method

IIviDriver.Initialize Method

Opens the I/O session to the instrument. Driver methods and properties that access the instrument are only accessible after Initialize is called. Initialize optionally performs a Reset and queries the instrument to validate the instrument model.

[Visual Basic]
Sub Initialize( _
   ResourceName As String, _
   IdQuery As Boolean, _
   Reset As Boolean, _
   OptionString As String _
)
[C++]
HRESULT Initialize(
   BSTR ResourceName,
   VARIANT_BOOL IdQuery,
   VARIANT_BOOL Reset,
   BSTR OptionString
);
[ANSI C]
HRESULT IIviDriver_Initialize(
   IIviDriver* This
   BSTR ResourceName,
   VARIANT_BOOL IdQuery,
   VARIANT_BOOL Reset,
   BSTR OptionString
);
[C#]
public void Initialize(
   string ResourceName,
   bool IdQuery,
   bool Reset,
   string OptionString
);

Parameters

ResourceName
An IVI logical name or an instrument specific string that identifies the address of the instrument, such as a VISA resource descriptor string.
IdQuery
Specifies whether to verify the ID of the instrument.
Reset
Specifies whether to reset the instrument.
OptionString
The user can use the OptionsString parameter to specify the initial values of certain IVI inherent attributes for the session.

Related Items

Close

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Initialize | Close | IIviDriver Overview


Initialized Property

IIviDriver.Initialized Property

Initialized is True between a successful call to the Initialize method and a successful call to the Close method, and False at all other times.

[Visual Basic]
Property Get Initialized() As Boolean
[C++]
HRESULT get_Initialized(VARIANT_BOOL* value);
[ANSI C]
HRESULT IIviDriver_get_Initialized(IIviDriver* This, VARIANT_BOOL* value);
[C#]
public bool Initialized {get;}

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Initialize | Close | IIviDriver Overview


Utility Property

IIviDriver.Utility Property

Pointer to the IIviDriverUtility interface

[Visual Basic]
Property Get Utility() As IIviDriverUtility
[C++]
HRESULT get_Utility(IIviDriverUtility** value);
[ANSI C]
HRESULT IIviDriver_get_Utility(IIviDriver* This, IIviDriverUtility** value);
[C#]
public IIviDriverUtility Utility {get;}

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Initialize | Close | IIviDriver Overview


Description Property

IIviDriverIdentity.Description Property

A brief description of the implementing component. Description is limted to 256 bytes.

[Visual Basic]
Property Get Description() As String
[C++]
HRESULT get_Description(BSTR* value);
[ANSI C]
HRESULT IIviDriverIdentity_get_Description(IIviDriverIdentity* This, BSTR* value);
[C#]
public string Description {get;}

Also In This Interface

Description | Revision | Vendor | InstrumentManufacturer | InstrumentModel | InstrumentFirmwareRevision | Identifier | SupportedInstrumentModels | SpecificationMajorVersion | SpecificationMinorVersion | GroupCapabilities | IIviDriverIdentity Overview


GroupCapabilities Property

IIviDriverIdentity.GroupCapabilities Property

A comma-separated list of the class capability groups implemented by the driver. Capability group names are documented in the IVI class specifications. If the driver is not class compliant, the driver returns an empty string.

[Visual Basic]
Property Get GroupCapabilities() As String
[C++]
HRESULT get_GroupCapabilities(BSTR* value);
[ANSI C]
HRESULT IIviDriverIdentity_get_GroupCapabilities(IIviDriverIdentity* This, BSTR* value);
[C#]
public string GroupCapabilities {get;}

Also In This Interface

Description | Revision | Vendor | InstrumentManufacturer | InstrumentModel | InstrumentFirmwareRevision | Identifier | SupportedInstrumentModels | SpecificationMajorVersion | SpecificationMinorVersion | GroupCapabilities | IIviDriverIdentity Overview


Identifier Property

IIviDriverIdentity.Identifier Property

The case-sensitive unique identifier of the implementing IVI-COM instrument driver.

[Visual Basic]
Property Get Identifier() As String
[C++]
HRESULT get_Identifier(BSTR* value);
[ANSI C]
HRESULT IIviDriverIdentity_get_Identifier(IIviDriverIdentity* This, BSTR* value);
[C#]
public string Identifier {get;}

Also In This Interface

Description | Revision | Vendor | InstrumentManufacturer | InstrumentModel | InstrumentFirmwareRevision | Identifier | SupportedInstrumentModels | SpecificationMajorVersion | SpecificationMinorVersion | GroupCapabilities | IIviDriverIdentity Overview


InstrumentFirmwareRevision Property

IIviDriverIdentity.InstrumentFirmwareRevision Property

The firmware revision reported by the physical instrument. If Simulation is enabled or the instrument is not capable of reporting the firmware revision, a string is returned that explains the condition.

[Visual Basic]
Property Get InstrumentFirmwareRevision() As String
[C++]
HRESULT get_InstrumentFirmwareRevision(BSTR* value);
[ANSI C]
HRESULT IIviDriverIdentity_get_InstrumentFirmwareRevision(IIviDriverIdentity* This, BSTR* value);
[C#]
public string InstrumentFirmwareRevision {get;}

Also In This Interface

Description | Revision | Vendor | InstrumentManufacturer | InstrumentModel | InstrumentFirmwareRevision | Identifier | SupportedInstrumentModels | SpecificationMajorVersion | SpecificationMinorVersion | GroupCapabilities | IIviDriverIdentity Overview


InstrumentManufacturer Property

IIviDriverIdentity.InstrumentManufacturer Property

The name of the manufacturer reported by the physical instrument. If Simulation is enabled or the instrument is not capable of reporting the name of the manufacturer, a string is returned that explains the condition. Manufacturer is limited to 256 bytes

[Visual Basic]
Property Get InstrumentManufacturer() As String
[C++]
HRESULT get_InstrumentManufacturer(BSTR* value);
[ANSI C]
HRESULT IIviDriverIdentity_get_InstrumentManufacturer(IIviDriverIdentity* This, BSTR* value);
[C#]
public string InstrumentManufacturer {get;}

Also In This Interface

Description | Revision | Vendor | InstrumentManufacturer | InstrumentModel | InstrumentFirmwareRevision | Identifier | SupportedInstrumentModels | SpecificationMajorVersion | SpecificationMinorVersion | GroupCapabilities | IIviDriverIdentity Overview


InstrumentModel Property

IIviDriverIdentity.InstrumentModel Property

The model number or name reported by the physical instrument. If Simulation is enabled or the instrument is not capable of reporting the model number or name, a string is returned that explains the condition. Model is limited to 256 bytes

[Visual Basic]
Property Get InstrumentModel() As String
[C++]
HRESULT get_InstrumentModel(BSTR* value);
[ANSI C]
HRESULT IIviDriverIdentity_get_InstrumentModel(IIviDriverIdentity* This, BSTR* value);
[C#]
public string InstrumentModel {get;}

Also In This Interface

Description | Revision | Vendor | InstrumentManufacturer | InstrumentModel | InstrumentFirmwareRevision | Identifier | SupportedInstrumentModels | SpecificationMajorVersion | SpecificationMinorVersion | GroupCapabilities | IIviDriverIdentity Overview


Revision Property

IIviDriverIdentity.Revision Property

The revision of the implementing component. Refer to IVI 3.1, Section 3.1.2.2, for a description of revision syntax and semantics. Revision is limited to 256 bytes.

[Visual Basic]
Property Get Revision() As String
[C++]
HRESULT get_Revision(BSTR* value);
[ANSI C]
HRESULT IIviDriverIdentity_get_Revision(IIviDriverIdentity* This, BSTR* value);
[C#]
public string Revision {get;}

Also In This Interface

Description | Revision | Vendor | InstrumentManufacturer | InstrumentModel | InstrumentFirmwareRevision | Identifier | SupportedInstrumentModels | SpecificationMajorVersion | SpecificationMinorVersion | GroupCapabilities | IIviDriverIdentity Overview


SpecificationMajorVersion Property

IIviDriverIdentity.SpecificationMajorVersion Property

For IVI class-compliant drivers, the major version number of the instrument class specification. If the driver is not class compliant, the driver returns zero.

[Visual Basic]
Property Get SpecificationMajorVersion() As Long
[C++]
HRESULT get_SpecificationMajorVersion(long* value);
[ANSI C]
HRESULT IIviDriverIdentity_get_SpecificationMajorVersion(IIviDriverIdentity* This, long* value);
[C#]
public long SpecificationMajorVersion {get;}

Also In This Interface

Description | Revision | Vendor | InstrumentManufacturer | InstrumentModel | InstrumentFirmwareRevision | Identifier | SupportedInstrumentModels | SpecificationMajorVersion | SpecificationMinorVersion | GroupCapabilities | IIviDriverIdentity Overview


SpecificationMinorVersion Property

IIviDriverIdentity.SpecificationMinorVersion Property

For IVI class-compliant drivers, the minor version number of the instrument class specification. If the driver is not class compliant, the driver returns zero.

[Visual Basic]
Property Get SpecificationMinorVersion() As Long
[C++]
HRESULT get_SpecificationMinorVersion(long* value);
[ANSI C]
HRESULT IIviDriverIdentity_get_SpecificationMinorVersion(IIviDriverIdentity* This, long* value);
[C#]
public long SpecificationMinorVersion {get;}

Also In This Interface

Description | Revision | Vendor | InstrumentManufacturer | InstrumentModel | InstrumentFirmwareRevision | Identifier | SupportedInstrumentModels | SpecificationMajorVersion | SpecificationMinorVersion | GroupCapabilities | IIviDriverIdentity Overview


SupportedInstrumentModels Property

IIviDriverIdentity.SupportedInstrumentModels Property

A comma-separated list of instrument models that the IVI specific driver can control. The string does not include an abbreviation for the manufacturer if it is the same for all models.

[Visual Basic]
Property Get SupportedInstrumentModels() As String
[C++]
HRESULT get_SupportedInstrumentModels(BSTR* value);
[ANSI C]
HRESULT IIviDriverIdentity_get_SupportedInstrumentModels(IIviDriverIdentity* This, BSTR* value);
[C#]
public string SupportedInstrumentModels {get;}

Also In This Interface

Description | Revision | Vendor | InstrumentManufacturer | InstrumentModel | InstrumentFirmwareRevision | Identifier | SupportedInstrumentModels | SpecificationMajorVersion | SpecificationMinorVersion | GroupCapabilities | IIviDriverIdentity Overview


Vendor Property

IIviDriverIdentity.Vendor Property

The name of the vendor that supplies the implementing component. Vendor is limited to 256 bytes.

[Visual Basic]
Property Get Vendor() As String
[C++]
HRESULT get_Vendor(BSTR* value);
[ANSI C]
HRESULT IIviDriverIdentity_get_Vendor(IIviDriverIdentity* This, BSTR* value);
[C#]
public string Vendor {get;}

Also In This Interface

Description | Revision | Vendor | InstrumentManufacturer | InstrumentModel | InstrumentFirmwareRevision | Identifier | SupportedInstrumentModels | SpecificationMajorVersion | SpecificationMinorVersion | GroupCapabilities | IIviDriverIdentity Overview


Cache Property

IIviDriverOperation.Cache Property

Drivers may choose to always cache some instrument settings, never cache others, and optionally cache others, to avoid unecessary I/O to the instrument. If True, the driver caches optionally cached instrument settings.

[Visual Basic]
Property Get Cache() As Boolean
Property Let Cache(value As Boolean)
[C++]
HRESULT get_Cache(VARIANT_BOOL* value);
HRESULT put_Cache(VARIANT_BOOL value);
[ANSI C]
HRESULT IIviDriverOperation_get_Cache(IIviDriverOperation* This, VARIANT_BOOL* value);
HRESULT IIviDriverOperation_put_Cache(IIviDriverOperation* This, VARIANT_BOOL value);
[C#]
public bool Cache {get; set;}

Related Items

InvalidateAllAttributes

Also In This Interface

LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


ClearInterchangeWarnings Method

IIviDriverOperation.ClearInterchangeWarnings Method

Clears the list of interchangeability warnings that the IVI specific driver maintains.

[Visual Basic]
Sub ClearInterchangeWarnings()
[C++]
HRESULT ClearInterchangeWarnings();
[ANSI C]
HRESULT IIviDriverOperation_ClearInterchangeWarnings(
   IIviDriverOperation* This);
[C#]
public void ClearInterchangeWarnings();

Related Items

GetNextInterchangeWarning | ResetInterchangeCheck | InterchangeCheck

Also In This Interface

LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


DriverSetup Property

IIviDriverOperation.DriverSetup Property

The driver setup string. It is either specified in the Configuration Store or passed in the OptionString parameter of the Initialize function. Driver setup is empty if the driver is not initialized.

[Visual Basic]
Property Get DriverSetup() As String
[C++]
HRESULT get_DriverSetup(BSTR* value);
[ANSI C]
HRESULT IIviDriverOperation_get_DriverSetup(IIviDriverOperation* This, BSTR* value);
[C#]
public string DriverSetup {get;}

Also In This Interface

LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


GetNextCoercionRecord Method

IIviDriverOperation.GetNextCoercionRecord Method

Returns the oldest record from the coercion record list. Records are only added to the list if RecordCoercions is True.

[Visual Basic]
Function GetNextCoercionRecord() As String
[C++]
HRESULT GetNextCoercionRecord(
   BSTR* CoercionRecord
);
[ANSI C]
HRESULT IIviDriverOperation_GetNextCoercionRecord(
   IIviDriverOperation* This
   BSTR* CoercionRecord
);
[C#]
public string GetNextCoercionRecord();

Parameters

CoercionRecord
The coercion record string shall contain the following information:
  • The name of the attribute that was coerced. This can be the generic name, the COM property name, or the C defined constant.
  • If the attribute is channel-based, the name of the channel. The channel name can be the specific driver channel string or the virtual channel name that the user specified.
  • If the attribute applies to a repeated capability, the name of the repeated capability. The name can be the specific driver repeated capability token or the virtual repeated capability name that the user specified.
  • The value that the user specified for the attribute.
  • The value to which the attribute was coerced.

    • Related Items

    RecordCoercions

    Also In This Interface

    LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


GetNextInterchangeWarning Method

IIviDriverOperation.GetNextInterchangeWarning Method

Returns the oldest warning from the interchange warning list. Records are only added to the list if InterchangeCheck is True.

[Visual Basic]
Function GetNextInterchangeWarning() As String
[C++]
HRESULT GetNextInterchangeWarning(
   BSTR* InterchangeWarning
);
[ANSI C]
HRESULT IIviDriverOperation_GetNextInterchangeWarning(
   IIviDriverOperation* This
   BSTR* InterchangeWarning
);
[C#]
public string GetNextInterchangeWarning();

Parameters

InterchangeWarning
A string describing the oldest interchangeability warning or empty string if no warrnings remain.

Related Items

ClearInterchangeWarnings | ResetInterchangeCheck | InterchangeCheck

Also In This Interface

LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


InterchangeCheck Property

IIviDriverOperation.InterchangeCheck Property

If True, the driver maintains a record of interchangeability warnings. If the driver does not support interchangeability checking, attempts to set InterchangeCheck to True return an error.

[Visual Basic]
Property Get InterchangeCheck() As Boolean
Property Let InterchangeCheck(value As Boolean)
[C++]
HRESULT get_InterchangeCheck(VARIANT_BOOL* value);
HRESULT put_InterchangeCheck(VARIANT_BOOL value);
[ANSI C]
HRESULT IIviDriverOperation_get_InterchangeCheck(IIviDriverOperation* This, VARIANT_BOOL* value);
HRESULT IIviDriverOperation_put_InterchangeCheck(IIviDriverOperation* This, VARIANT_BOOL value);
[C#]
public bool InterchangeCheck {get; set;}

Related Items

ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck

Also In This Interface

LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


InvalidateAllAttributes Method

IIviDriverOperation.InvalidateAllAttributes Method

Invalidates all of the driver's cached values.

[Visual Basic]
Sub InvalidateAllAttributes()
[C++]
HRESULT InvalidateAllAttributes();
[ANSI C]
HRESULT IIviDriverOperation_InvalidateAllAttributes(
   IIviDriverOperation* This);
[C#]
public void InvalidateAllAttributes();

Related Items

Cache

Also In This Interface

LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


IoResourceDescriptor Property

IIviDriverOperation.IoResourceDescriptor Property

The resource descriptor specifies the connection to a physical device. It is either specified in the Configuration Store or passed in the ResourceName parameter of the Initialize function. It is empty if the driver is not initialized.

[Visual Basic]
Property Get IoResourceDescriptor() As String
[C++]
HRESULT get_IoResourceDescriptor(BSTR* value);
[ANSI C]
HRESULT IIviDriverOperation_get_IoResourceDescriptor(IIviDriverOperation* This, BSTR* value);
[C#]
public string IoResourceDescriptor {get;}

Also In This Interface

LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


LogicalName Property

IIviDriverOperation.LogicalName Property

Logical Name identifies a driver session in the Configuration Store. If Logical Name is not empty, the driver was initialized from information in the driver session. If it is empty, the driver was initialized without using the Configuration Store.

[Visual Basic]
Property Get LogicalName() As String
[C++]
HRESULT get_LogicalName(BSTR* value);
[ANSI C]
HRESULT IIviDriverOperation_get_LogicalName(IIviDriverOperation* This, BSTR* value);
[C#]
public string LogicalName {get;}

Also In This Interface

LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


QueryInstrumentStatus Property

IIviDriverOperation.QueryInstrumentStatus Property

If True, the driver queries the instrument status at the end of each method or property that performs I/O to the instrument. If an error is reported, use ErrorQuery to retrieve error messages one at a time from the instrument.

[Visual Basic]
Property Get QueryInstrumentStatus() As Boolean
Property Let QueryInstrumentStatus(value As Boolean)
[C++]
HRESULT get_QueryInstrumentStatus(VARIANT_BOOL* value);
HRESULT put_QueryInstrumentStatus(VARIANT_BOOL value);
[ANSI C]
HRESULT IIviDriverOperation_get_QueryInstrumentStatus(IIviDriverOperation* This, VARIANT_BOOL* value);
HRESULT IIviDriverOperation_put_QueryInstrumentStatus(IIviDriverOperation* This, VARIANT_BOOL value);
[C#]
public bool QueryInstrumentStatus {get; set;}

Also In This Interface

LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


RangeCheck Property

IIviDriverOperation.RangeCheck Property

Drivers may choose to always validate some property/parameter values, never validate others, and optionally validate others, to avoid sending invalid commands to the instrument. If True, the driver performs optional validations.

[Visual Basic]
Property Get RangeCheck() As Boolean
Property Let RangeCheck(value As Boolean)
[C++]
HRESULT get_RangeCheck(VARIANT_BOOL* value);
HRESULT put_RangeCheck(VARIANT_BOOL value);
[ANSI C]
HRESULT IIviDriverOperation_get_RangeCheck(IIviDriverOperation* This, VARIANT_BOOL* value);
HRESULT IIviDriverOperation_put_RangeCheck(IIviDriverOperation* This, VARIANT_BOOL value);
[C#]
public bool RangeCheck {get; set;}

Also In This Interface

LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


RecordCoercions Property

IIviDriverOperation.RecordCoercions Property

If True, the driver keeps a list of the value coercions it makes for ViInt32 and ViReal64 attributes. If the driver does not support coercion recording, attempts to set RecordCoercions to True will return an error.

[Visual Basic]
Property Get RecordCoercions() As Boolean
Property Let RecordCoercions(value As Boolean)
[C++]
HRESULT get_RecordCoercions(VARIANT_BOOL* value);
HRESULT put_RecordCoercions(VARIANT_BOOL value);
[ANSI C]
HRESULT IIviDriverOperation_get_RecordCoercions(IIviDriverOperation* This, VARIANT_BOOL* value);
HRESULT IIviDriverOperation_put_RecordCoercions(IIviDriverOperation* This, VARIANT_BOOL value);
[C#]
public bool RecordCoercions {get; set;}

Related Items

GetNextCoercionRecord

Also In This Interface

LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


ResetInterchangeCheck Method

IIviDriverOperation.ResetInterchangeCheck Method

Resets the interchangeability checking algorithms of the driver so that methods and properties that executed prior to calling this function have no affect on whether future calls to the driver generate interchangeability warnings.

[Visual Basic]
Sub ResetInterchangeCheck()
[C++]
HRESULT ResetInterchangeCheck();
[ANSI C]
HRESULT IIviDriverOperation_ResetInterchangeCheck(
   IIviDriverOperation* This);
[C#]
public void ResetInterchangeCheck();

Related Items

GetNextInterchangeWarning | ClearInterchangeWarnings | InterchangeCheck

Also In This Interface

LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


Simulate Property

IIviDriverOperation.Simulate Property

If True, the driver does not perform I/O to the instrument, and returns simulated values for output parameters.

[Visual Basic]
Property Get Simulate() As Boolean
Property Let Simulate(value As Boolean)
[C++]
HRESULT get_Simulate(VARIANT_BOOL* value);
HRESULT put_Simulate(VARIANT_BOOL value);
[ANSI C]
HRESULT IIviDriverOperation_get_Simulate(IIviDriverOperation* This, VARIANT_BOOL* value);
HRESULT IIviDriverOperation_put_Simulate(IIviDriverOperation* This, VARIANT_BOOL value);
[C#]
public bool Simulate {get; set;}

Also In This Interface

LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


Disable Method

IIviDriverUtility.Disable Method

Quickly places the instrument in a state where it has no, or minimal, effect on the external system to which it is connected. This state is not necessarily a known state.

[Visual Basic]
Sub Disable()
[C++]
HRESULT Disable();
[ANSI C]
HRESULT IIviDriverUtility_Disable(
   IIviDriverUtility* This);
[C#]
public void Disable();

Also In This Interface

Reset | ResetWithDefaults | Disable | SelfTest | ErrorQuery | LockObject | UnlockObject | IIviDriverUtility Overview


ErrorQuery Method

IIviDriverUtility.ErrorQuery Method

Queries the instrument and returns instrument specific error information. This function can be used when QueryInstrumentStatus is True to retrieve error details when the driver detects an instrument error.

[Visual Basic]
Sub ErrorQuery( _
   ErrorCode As Long, _
   ErrorMessage As String _
)
[C++]
HRESULT ErrorQuery(
   long* ErrorCode,
   BSTR* ErrorMessage
);
[ANSI C]
HRESULT IIviDriverUtility_ErrorQuery(
   IIviDriverUtility* This
   long* ErrorCode,
   BSTR* ErrorMessage
);
[C#]
public void ErrorQuery(
   long ErrorCode,
   string ErrorMessage
);

Parameters

ErrorCode
Instrument error code
ErrorMessage
Instrument error message

Also In This Interface

Reset | ResetWithDefaults | Disable | SelfTest | ErrorQuery | LockObject | UnlockObject | IIviDriverUtility Overview


LockObject Method

IIviDriverUtility.LockObject Method

Obtains a multithread lock on the driver after waiting until all other execution threads have released their locks on the instrument session.

[Visual Basic]
Sub LockObject()
[C++]
HRESULT LockObject();
[ANSI C]
HRESULT IIviDriverUtility_LockObject(
   IIviDriverUtility* This);
[C#]
public void LockObject();

Related Items

UnlockObject

Also In This Interface

Reset | ResetWithDefaults | Disable | SelfTest | ErrorQuery | LockObject | UnlockObject | IIviDriverUtility Overview


Reset Method

IIviDriverUtility.Reset Method

Places the instrument in a known state and configures instrument options on which the IVI specific driver depends (for example, enabling/disabling headers). For an IEEE 488.2 instrument, Reset sends the command string *RST to the instrument.

[Visual Basic]
Sub Reset()
[C++]
HRESULT Reset();
[ANSI C]
HRESULT IIviDriverUtility_Reset(
   IIviDriverUtility* This);
[C#]
public void Reset();

Related Items

ResetWithDefaults

Also In This Interface

Reset | ResetWithDefaults | Disable | SelfTest | ErrorQuery | LockObject | UnlockObject | IIviDriverUtility Overview


ResetWithDefaults Method

IIviDriverUtility.ResetWithDefaults Method

Does the equivalent of Reset and then, (1) disables class extension capability groups, (2) sets attributes to initial values defined by class specs, and (3) configures the driver to option string settings used when Initialize was last executed.

[Visual Basic]
Sub ResetWithDefaults()
[C++]
HRESULT ResetWithDefaults();
[ANSI C]
HRESULT IIviDriverUtility_ResetWithDefaults(
   IIviDriverUtility* This);
[C#]
public void ResetWithDefaults();

Also In This Interface

Reset | ResetWithDefaults | Disable | SelfTest | ErrorQuery | LockObject | UnlockObject | IIviDriverUtility Overview


SelfTest Method

IIviDriverUtility.SelfTest Method

Performs an instrument self test, waits for the instrument to complete the test, and queries the instrument for the results. If the instrument passes the test, TestResult is zero and TestMessage is 'Self test passed'.

[Visual Basic]
Sub SelfTest( _
   TestResult As Long, _
   TestMessage As String _
)
[C++]
HRESULT SelfTest(
   long* TestResult,
   BSTR* TestMessage
);
[ANSI C]
HRESULT IIviDriverUtility_SelfTest(
   IIviDriverUtility* This
   long* TestResult,
   BSTR* TestMessage
);
[C#]
public void SelfTest(
   long TestResult,
   string TestMessage
);

Parameters

TestResult
The numeric result from the self test operation. 0 = no error (test passed)
TestMessage
The self test status message

Also In This Interface

Reset | ResetWithDefaults | Disable | SelfTest | ErrorQuery | LockObject | UnlockObject | IIviDriverUtility Overview


UnlockObject Method

IIviDriverUtility.UnlockObject Method

Releases a previously obtained mutlithread lock.

[Visual Basic]
Sub UnlockObject()
[C++]
HRESULT UnlockObject();
[ANSI C]
HRESULT IIviDriverUtility_UnlockObject(
   IIviDriverUtility* This);
[C#]
public void UnlockObject();

Related Items

LockObject

Also In This Interface

Reset | ResetWithDefaults | Disable | SelfTest | ErrorQuery | LockObject | UnlockObject | IIviDriverUtility Overview