IviDCPwr Reference

© 2003 IVI Foundation

Welcome to the IviDCPwr Class-Compliant Interface Reference

This section contains the reference material for the IviDCPwr class-compliant interface.

This help hierarchy matches the COM hierarchy defined in the IviDCPwr class specification, available on the IVI Foundation Web Site. The COM hierarchy groups related capabilities into common interfaces. These interfaces often include both IviDCPwr base and extension capabilities. To help users distinguish between base and extension capabilities, the Capability Group section of each method or property topic lists which of the IviDCPwr Capability Groups the method or property belongs to.

Since IVI class-compliant specific drivers are not required to support all extension groups, users should refer to the compliance documentation for the particular driver being used to determine if an extension group is supported before using capabilities in that group.

IVI class-compliant specific drivers may have small differences in the way a particular extension group method or property is implemented. For instance, a driver might implement only one of several IVI-defined values for an extension group attribute. Refer to the help documentation provided with the IVI class-compliant specific driver for detailed information about implementation.


Inherent Interface

IviDCPwr Capability Groups

Capability Group | Description
IIviDCPwrBase | Base capabilities of the IviDCPwr specification. This group supports the ability to generate a DC power signal, to specify output limits, and to control the behavior of the power supply when the output is greater than or equal to one of the limits.
IviDCPwrTrigger | This group supports the ability to make changes to the output signal based on a trigger event.
IviDCPwrSoftwareTrigger | This group supports the ability to make changes to the output signal based on a software trigger event.
IviDCPwrMeasurement | This group supports the ability to query the instrument for the measurement characteristics of the output signal.


Inherent Interface

IviDCPwr Instrument Class Interfaces

IIviDCPwr | IviDCPwr class-compliant root interface
IIviDCPwrOutput | IviDCPwr class-compliant IIviDCPwrOutput interface
IIviDCPwrOutputs | IviDCPwr class-compliant IIviDCPwrOutputs collection interface
IIviDCPwrTrigger | IviDCPwr class-compliant IIviDCPwrTrigger interface


IIviDCPwr Interface

IviDCPwr class-compliant root interface

Properties

DriverOperation | Pointer to the IIviDriverOperation interface
Identity | Pointer to the IIviDriverIdentity interface
Utility | Pointer to the IIviDriverUtility interface
Initialized | Initialized is True between a successful call to the Initialize method and a successful call to the Close method, and False at all other times.
Outputs | Pointer to the class-compliant IIviDCPwrOutputs interface
Trigger | Pointer to the class-compliant IIviDCPwrTrigger interface

Methods

Initialize | Opens the I/O session to the instrument. Driver methods and properties that access the instrument are only accessible after Initialize is called. Initialize optionally performs a Reset and queries the instrument to validate the instrument model.
Close | Closes the I/O session to the instrument. Driver methods and properties that access the instrument are not accessible after Close is called.


DriverOperation Property

IIviDCPwr.DriverOperation Property

Pointer to the IIviDriverOperation interface

[Visual Basic]
Property Get DriverOperation() As IIviDriverOperation
[C++]
HRESULT get_DriverOperation(IIviDriverOperation** value);
[ANSI C]
HRESULT IIviDCPwr_get_DriverOperation(IIviDCPwr* This, IIviDriverOperation** value);
[C#]
public IIviDriverOperation DriverOperation {get;}

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Outputs | Trigger | Initialize | Close | IIviDCPwr Overview


Identity Property

IIviDCPwr.Identity Property

Pointer to the IIviDriverIdentity interface

[Visual Basic]
Property Get Identity() As IIviDriverIdentity
[C++]
HRESULT get_Identity(IIviDriverIdentity** value);
[ANSI C]
HRESULT IIviDCPwr_get_Identity(IIviDCPwr* This, IIviDriverIdentity** value);
[C#]
public IIviDriverIdentity Identity {get;}

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Outputs | Trigger | Initialize | Close | IIviDCPwr Overview


Utility Property

IIviDCPwr.Utility Property

Pointer to the IIviDriverUtility interface

[Visual Basic]
Property Get Utility() As IIviDriverUtility
[C++]
HRESULT get_Utility(IIviDriverUtility** value);
[ANSI C]
HRESULT IIviDCPwr_get_Utility(IIviDCPwr* This, IIviDriverUtility** value);
[C#]
public IIviDriverUtility Utility {get;}

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Outputs | Trigger | Initialize | Close | IIviDCPwr Overview


Initialized Property

IIviDCPwr.Initialized Property

Initialized is True between a successful call to the Initialize method and a successful call to the Close method, and False at all other times.

[Visual Basic]
Property Get Initialized() As Boolean
[C++]
HRESULT get_Initialized(VARIANT_BOOL* value);
[ANSI C]
HRESULT IIviDCPwr_get_Initialized(IIviDCPwr* This, VARIANT_BOOL* value);
[C#]
public bool Initialized {get;}

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Outputs | Trigger | Initialize | Close | IIviDCPwr Overview


Outputs Property

IIviDCPwr.Outputs Property

Pointer to the class-compliant IIviDCPwrOutputs interface

[Visual Basic]
Property Get Outputs() As IIviDCPwrOutputs
[C++]
HRESULT get_Outputs(IIviDCPwrOutputs** value);
[ANSI C]
HRESULT IIviDCPwr_get_Outputs(IIviDCPwr* This, IIviDCPwrOutputs** value);
[C#]
public IIviDCPwrOutputs Outputs {get;}

Capability Group

IviDcPwrBase

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Outputs | Trigger | Initialize | Close | IIviDCPwr Overview


Trigger Property

IIviDCPwr.Trigger Property

Pointer to the class-compliant IIviDCPwrTrigger interface

[Visual Basic]
Property Get Trigger() As IIviDCPwrTrigger
[C++]
HRESULT get_Trigger(IIviDCPwrTrigger** value);
[ANSI C]
HRESULT IIviDCPwr_get_Trigger(IIviDCPwr* This, IIviDCPwrTrigger** value);
[C#]
public IIviDCPwrTrigger Trigger {get;}

Capability Group

IviDcPwrBase

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Outputs | Trigger | Initialize | Close | IIviDCPwr Overview


Initialize Method

IIviDCPwr.Initialize Method

Opens the I/O session to the instrument. Driver methods and properties that access the instrument are only accessible after Initialize is called. Initialize optionally performs a Reset and queries the instrument to validate the instrument model.

[Visual Basic]
Sub Initialize( _
   ResourceName As String, _
   IdQuery As Boolean, _
   Reset As Boolean, _
   OptionString As String _
)
[C++]
HRESULT Initialize(
   BSTR ResourceName,
   VARIANT_BOOL IdQuery,
   VARIANT_BOOL Reset,
   BSTR OptionString
);
[ANSI C]
HRESULT IIviDCPwr_Initialize(
   IIviDCPwr* This
   BSTR ResourceName,
   VARIANT_BOOL IdQuery,
   VARIANT_BOOL Reset,
   BSTR OptionString
);
[C#]
public void Initialize(
   string ResourceName,
   bool IdQuery,
   bool Reset,
   string OptionString
);

Parameters

ResourceName
An IVI logical name or an instrument specific string that identifies the address of the instrument, such as a VISA resource descriptor string.
IdQuery
Specifies whether to verify the ID of the instrument.
Reset
Specifies whether to reset the instrument.
OptionString
The user can use the OptionsString parameter to specify the initial values of certain IVI inherent attributes for the session.

Related Items

Close

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Outputs | Trigger | Initialize | Close | IIviDCPwr Overview


Close Method

IIviDCPwr.Close Method

Closes the I/O session to the instrument. Driver methods and properties that access the instrument are not accessible after Close is called.

[Visual Basic]
Sub Close()
[C++]
HRESULT Close();
[ANSI C]
HRESULT IIviDCPwr_Close(
   IIviDCPwr* This);
[C#]
public void Close();

Related Items

Initialize

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Outputs | Trigger | Initialize | Close | IIviDCPwr Overview


IIviDCPwrOutput Interface

IviDCPwr class-compliant IIviDCPwrOutput interface

Properties

Enabled | Specifies whether the signal the power supply produces appears at the output connector.
TriggerSource | Specifies the trigger source.
TriggeredCurrentLimit | Specifies the value to which the power supply sets the current limit after a trigger event occurs.
TriggeredVoltageLevel | Specifies the value to which the power supply sets the voltage level after a trigger event occurs.
VoltageLevel | Specifies the voltage level the DC power supply attempts to generate. The units are Volts.
CurrentLimit | Specifies the output current limit. The units are Amps.
CurrentLimitBehavior | Specifies the behavior of the power supply when the output current is equal to or greater than the value of the Current Limit property.
OVPLimit | Specifies the voltage the power supply allows. The units are Volts.
OVPEnabled | Specifies whether the power supply provides over-voltage protection. If this property is set to True, the power supply disables the output when the output voltage is greater than or equal to the OVP Limit.

Methods

ConfigureCurrentLimit | Specifies the output current limit value and the behavior of the power supply when the output current is greater than or equal to that value.
ConfigureRange | Specifies the output's range, either current or voltage.
ConfigureOVP | Specifies the over-voltage limit and the behavior of the power supply when the output voltage is greater than or equal to the limit.
Measure | Takes a measurement on the output signal and returns the measured value.
QueryCurrentLimitMax | Returns the maximum programmable current limit that the power supply accepts for a particular voltage level on an output.
QueryState | Returns whether the power supply is in a particular output state.
QueryVoltageLevelMax | Returns the maximum programmable voltage level that the power supply accepts for a particular current limit on an output.
ResetOutputProtection | Resets the power supply's output protection after an over-voltage or over-current condition occurs.


Enabled Property

IIviDCPwrOutput.Enabled Property

Specifies whether the signal the power supply produces appears at the output connector.

[Visual Basic]
Property Get Enabled() As Boolean
Property Let Enabled(value As Boolean)
[C++]
HRESULT get_Enabled(VARIANT_BOOL* value);
HRESULT put_Enabled(VARIANT_BOOL value);
[ANSI C]
HRESULT IIviDCPwrOutput_get_Enabled(IIviDCPwrOutput* This, VARIANT_BOOL* value);
HRESULT IIviDCPwrOutput_put_Enabled(IIviDCPwrOutput* This, VARIANT_BOOL value);
[C#]
public bool Enabled {get; set;}

Capability Group

IviDcPwrBase

Also In This Interface

Enabled | TriggerSource | TriggeredCurrentLimit | TriggeredVoltageLevel | VoltageLevel | CurrentLimit | CurrentLimitBehavior | OVPLimit | OVPEnabled | ConfigureCurrentLimit | ConfigureRange | ConfigureOVP | Measure | QueryCurrentLimitMax | QueryState | QueryVoltageLevelMax | ResetOutputProtection | IIviDCPwrOutput Overview


TriggerSource Property

IIviDCPwrOutput.TriggerSource Property

Specifies the trigger source.

[Visual Basic]
Property Get TriggerSource() As IviDCPwrTriggerSourceEnum
Property Let TriggerSource(value As IviDCPwrTriggerSourceEnum)
[C++]
HRESULT get_TriggerSource(IviDCPwrTriggerSourceEnum* value);
HRESULT put_TriggerSource(IviDCPwrTriggerSourceEnum value);
[ANSI C]
HRESULT IIviDCPwrOutput_get_TriggerSource(IIviDCPwrOutput* This, IviDCPwrTriggerSourceEnum* value);
HRESULT IIviDCPwrOutput_put_TriggerSource(IIviDCPwrOutput* This, IviDCPwrTriggerSourceEnum value);
[C#]
public IviDCPwrTriggerSourceEnum TriggerSource {get; set;}

Capability Group

IviDCPwrTrigger

Also In This Interface

Enabled | TriggerSource | TriggeredCurrentLimit | TriggeredVoltageLevel | VoltageLevel | CurrentLimit | CurrentLimitBehavior | OVPLimit | OVPEnabled | ConfigureCurrentLimit | ConfigureRange | ConfigureOVP | Measure | QueryCurrentLimitMax | QueryState | QueryVoltageLevelMax | ResetOutputProtection | IIviDCPwrOutput Overview


TriggeredCurrentLimit Property

IIviDCPwrOutput.TriggeredCurrentLimit Property

Specifies the value to which the power supply sets the current limit after a trigger event occurs.

[Visual Basic]
Property Get TriggeredCurrentLimit() As Double
Property Let TriggeredCurrentLimit(value As Double)
[C++]
HRESULT get_TriggeredCurrentLimit(double* value);
HRESULT put_TriggeredCurrentLimit(double value);
[ANSI C]
HRESULT IIviDCPwrOutput_get_TriggeredCurrentLimit(IIviDCPwrOutput* This, double* value);
HRESULT IIviDCPwrOutput_put_TriggeredCurrentLimit(IIviDCPwrOutput* This, double value);
[C#]
public double TriggeredCurrentLimit {get; set;}

Capability Group

IviDCPwrTrigger

Also In This Interface

Enabled | TriggerSource | TriggeredCurrentLimit | TriggeredVoltageLevel | VoltageLevel | CurrentLimit | CurrentLimitBehavior | OVPLimit | OVPEnabled | ConfigureCurrentLimit | ConfigureRange | ConfigureOVP | Measure | QueryCurrentLimitMax | QueryState | QueryVoltageLevelMax | ResetOutputProtection | IIviDCPwrOutput Overview


TriggeredVoltageLevel Property

IIviDCPwrOutput.TriggeredVoltageLevel Property

Specifies the value to which the power supply sets the voltage level after a trigger event occurs.

[Visual Basic]
Property Get TriggeredVoltageLevel() As Double
Property Let TriggeredVoltageLevel(value As Double)
[C++]
HRESULT get_TriggeredVoltageLevel(double* value);
HRESULT put_TriggeredVoltageLevel(double value);
[ANSI C]
HRESULT IIviDCPwrOutput_get_TriggeredVoltageLevel(IIviDCPwrOutput* This, double* value);
HRESULT IIviDCPwrOutput_put_TriggeredVoltageLevel(IIviDCPwrOutput* This, double value);
[C#]
public double TriggeredVoltageLevel {get; set;}

Capability Group

IviDCPwrTrigger

Also In This Interface

Enabled | TriggerSource | TriggeredCurrentLimit | TriggeredVoltageLevel | VoltageLevel | CurrentLimit | CurrentLimitBehavior | OVPLimit | OVPEnabled | ConfigureCurrentLimit | ConfigureRange | ConfigureOVP | Measure | QueryCurrentLimitMax | QueryState | QueryVoltageLevelMax | ResetOutputProtection | IIviDCPwrOutput Overview


VoltageLevel Property

IIviDCPwrOutput.VoltageLevel Property

Specifies the voltage level the DC power supply attempts to generate. The units are Volts.

[Visual Basic]
Property Get VoltageLevel() As Double
Property Let VoltageLevel(value As Double)
[C++]
HRESULT get_VoltageLevel(double* value);
HRESULT put_VoltageLevel(double value);
[ANSI C]
HRESULT IIviDCPwrOutput_get_VoltageLevel(IIviDCPwrOutput* This, double* value);
HRESULT IIviDCPwrOutput_put_VoltageLevel(IIviDCPwrOutput* This, double value);
[C#]
public double VoltageLevel {get; set;}

Capability Group

IviDcPwrBase

Also In This Interface

Enabled | TriggerSource | TriggeredCurrentLimit | TriggeredVoltageLevel | VoltageLevel | CurrentLimit | CurrentLimitBehavior | OVPLimit | OVPEnabled | ConfigureCurrentLimit | ConfigureRange | ConfigureOVP | Measure | QueryCurrentLimitMax | QueryState | QueryVoltageLevelMax | ResetOutputProtection | IIviDCPwrOutput Overview


CurrentLimit Property

IIviDCPwrOutput.CurrentLimit Property

Specifies the output current limit. The units are Amps.

[Visual Basic]
Property Get CurrentLimit() As Double
Property Let CurrentLimit(value As Double)
[C++]
HRESULT get_CurrentLimit(double* value);
HRESULT put_CurrentLimit(double value);
[ANSI C]
HRESULT IIviDCPwrOutput_get_CurrentLimit(IIviDCPwrOutput* This, double* value);
HRESULT IIviDCPwrOutput_put_CurrentLimit(IIviDCPwrOutput* This, double value);
[C#]
public double CurrentLimit {get; set;}

Capability Group

IviDcPwrBase

Related Items

ConfigureCurrentLimit

Also In This Interface

Enabled | TriggerSource | TriggeredCurrentLimit | TriggeredVoltageLevel | VoltageLevel | CurrentLimit | CurrentLimitBehavior | OVPLimit | OVPEnabled | ConfigureCurrentLimit | ConfigureRange | ConfigureOVP | Measure | QueryCurrentLimitMax | QueryState | QueryVoltageLevelMax | ResetOutputProtection | IIviDCPwrOutput Overview


CurrentLimitBehavior Property

IIviDCPwrOutput.CurrentLimitBehavior Property

Specifies the behavior of the power supply when the output current is equal to or greater than the value of the Current Limit property.

[Visual Basic]
Property Get CurrentLimitBehavior() As IviDCPwrCurrentLimitBehaviorEnum
Property Let CurrentLimitBehavior(value As IviDCPwrCurrentLimitBehaviorEnum)
[C++]
HRESULT get_CurrentLimitBehavior(IviDCPwrCurrentLimitBehaviorEnum* value);
HRESULT put_CurrentLimitBehavior(IviDCPwrCurrentLimitBehaviorEnum value);
[ANSI C]
HRESULT IIviDCPwrOutput_get_CurrentLimitBehavior(IIviDCPwrOutput* This, IviDCPwrCurrentLimitBehaviorEnum* value);
HRESULT IIviDCPwrOutput_put_CurrentLimitBehavior(IIviDCPwrOutput* This, IviDCPwrCurrentLimitBehaviorEnum value);
[C#]
public IviDCPwrCurrentLimitBehaviorEnum CurrentLimitBehavior {get; set;}

Capability Group

IviDcPwrBase

Related Items

ConfigureCurrentLimit

Also In This Interface

Enabled | TriggerSource | TriggeredCurrentLimit | TriggeredVoltageLevel | VoltageLevel | CurrentLimit | CurrentLimitBehavior | OVPLimit | OVPEnabled | ConfigureCurrentLimit | ConfigureRange | ConfigureOVP | Measure | QueryCurrentLimitMax | QueryState | QueryVoltageLevelMax | ResetOutputProtection | IIviDCPwrOutput Overview


OVPLimit Property

IIviDCPwrOutput.OVPLimit Property

Specifies the voltage the power supply allows. The units are Volts.

[Visual Basic]
Property Get OVPLimit() As Double
Property Let OVPLimit(value As Double)
[C++]
HRESULT get_OVPLimit(double* value);
HRESULT put_OVPLimit(double value);
[ANSI C]
HRESULT IIviDCPwrOutput_get_OVPLimit(IIviDCPwrOutput* This, double* value);
HRESULT IIviDCPwrOutput_put_OVPLimit(IIviDCPwrOutput* This, double value);
[C#]
public double OVPLimit {get; set;}

Capability Group

IviDcPwrBase

Related Items

ConfigureOVP

Also In This Interface

Enabled | TriggerSource | TriggeredCurrentLimit | TriggeredVoltageLevel | VoltageLevel | CurrentLimit | CurrentLimitBehavior | OVPLimit | OVPEnabled | ConfigureCurrentLimit | ConfigureRange | ConfigureOVP | Measure | QueryCurrentLimitMax | QueryState | QueryVoltageLevelMax | ResetOutputProtection | IIviDCPwrOutput Overview


OVPEnabled Property

IIviDCPwrOutput.OVPEnabled Property

Specifies whether the power supply provides over-voltage protection. If this property is set to True, the power supply disables the output when the output voltage is greater than or equal to the OVP Limit.

[Visual Basic]
Property Get OVPEnabled() As Boolean
Property Let OVPEnabled(value As Boolean)
[C++]
HRESULT get_OVPEnabled(VARIANT_BOOL* value);
HRESULT put_OVPEnabled(VARIANT_BOOL value);
[ANSI C]
HRESULT IIviDCPwrOutput_get_OVPEnabled(IIviDCPwrOutput* This, VARIANT_BOOL* value);
HRESULT IIviDCPwrOutput_put_OVPEnabled(IIviDCPwrOutput* This, VARIANT_BOOL value);
[C#]
public bool OVPEnabled {get; set;}

Capability Group

IviDcPwrBase

Related Items

ConfigureOVP

Also In This Interface

Enabled | TriggerSource | TriggeredCurrentLimit | TriggeredVoltageLevel | VoltageLevel | CurrentLimit | CurrentLimitBehavior | OVPLimit | OVPEnabled | ConfigureCurrentLimit | ConfigureRange | ConfigureOVP | Measure | QueryCurrentLimitMax | QueryState | QueryVoltageLevelMax | ResetOutputProtection | IIviDCPwrOutput Overview


ConfigureCurrentLimit Method

IIviDCPwrOutput.ConfigureCurrentLimit Method

Specifies the output current limit value and the behavior of the power supply when the output current is greater than or equal to that value.

[Visual Basic]
Sub ConfigureCurrentLimit( _
   Behavior As IviDCPwrCurrentLimitBehaviorEnum, _
   Limit As Double _
)
[C++]
HRESULT ConfigureCurrentLimit(
   IviDCPwrCurrentLimitBehaviorEnum Behavior,
   double Limit
);
[ANSI C]
HRESULT IIviDCPwrOutput_ConfigureCurrentLimit(
   IIviDCPwrOutput* This
   IviDCPwrCurrentLimitBehaviorEnum Behavior,
   double Limit
);
[C#]
public void ConfigureCurrentLimit(
   IviDCPwrCurrentLimitBehaviorEnum Behavior,
   double Limit
);

Parameters

Behavior
Specifies the behavior of the power supply when the output current is greater than or equal to the value of the Limit parameter. The driver uses this value to set the Current Limit Behavior attribute. See the attribute description for more details.
Limit
Specifies the power supply's output current limit. The driver uses this value to set the Current Limit attribute.

Capability Group

IviDcPwrBase

Related Items

CurrentLimitBehavior | CurrentLimit

Also In This Interface

Enabled | TriggerSource | TriggeredCurrentLimit | TriggeredVoltageLevel | VoltageLevel | CurrentLimit | CurrentLimitBehavior | OVPLimit | OVPEnabled | ConfigureCurrentLimit | ConfigureRange | ConfigureOVP | Measure | QueryCurrentLimitMax | QueryState | QueryVoltageLevelMax | ResetOutputProtection | IIviDCPwrOutput Overview


ConfigureRange Method

IIviDCPwrOutput.ConfigureRange Method

Specifies the output's range, either current or voltage.

[Visual Basic]
Sub ConfigureRange( _
   RangeType As IviDCPwrRangeTypeEnum, _
   Range As Double _
)
[C++]
HRESULT ConfigureRange(
   IviDCPwrRangeTypeEnum RangeType,
   double Range
);
[ANSI C]
HRESULT IIviDCPwrOutput_ConfigureRange(
   IIviDCPwrOutput* This
   IviDCPwrRangeTypeEnum RangeType,
   double Range
);
[C#]
public void ConfigureRange(
   IviDCPwrRangeTypeEnum RangeType,
   double Range
);

Parameters

RangeType
The kind of range to be configured, either Current or Voltage.
Range
The range in which the power supply operates. This value is coerced to the closest value the instrument supports that is greater than or equal to the value specified.

Capability Group

IviDcPwrBase

Also In This Interface

Enabled | TriggerSource | TriggeredCurrentLimit | TriggeredVoltageLevel | VoltageLevel | CurrentLimit | CurrentLimitBehavior | OVPLimit | OVPEnabled | ConfigureCurrentLimit | ConfigureRange | ConfigureOVP | Measure | QueryCurrentLimitMax | QueryState | QueryVoltageLevelMax | ResetOutputProtection | IIviDCPwrOutput Overview


ConfigureOVP Method

IIviDCPwrOutput.ConfigureOVP Method

Specifies the over-voltage limit and the behavior of the power supply when the output voltage is greater than or equal to the limit.

[Visual Basic]
Sub ConfigureOVP( _
   Enabled As Boolean, _
   Limit As Double _
)
[C++]
HRESULT ConfigureOVP(
   VARIANT_BOOL Enabled,
   double Limit
);
[ANSI C]
HRESULT IIviDCPwrOutput_ConfigureOVP(
   IIviDCPwrOutput* This
   VARIANT_BOOL Enabled,
   double Limit
);
[C#]
public void ConfigureOVP(
   bool Enabled,
   double Limit
);

Parameters

Enabled
Specifies the behavior of the power supply when the ouptut voltage is greater than or equal to the value of the Limit parameter. This value sets the OVP Enabled property.
Limit
Specifies the power supply's over-voltage protection limit. This value sets the OVP Limit property

Capability Group

IviDcPwrBase

Related Items

OVPEnabled | OVPLimit

Also In This Interface

Enabled | TriggerSource | TriggeredCurrentLimit | TriggeredVoltageLevel | VoltageLevel | CurrentLimit | CurrentLimitBehavior | OVPLimit | OVPEnabled | ConfigureCurrentLimit | ConfigureRange | ConfigureOVP | Measure | QueryCurrentLimitMax | QueryState | QueryVoltageLevelMax | ResetOutputProtection | IIviDCPwrOutput Overview


Measure Method

IIviDCPwrOutput.Measure Method

Takes a measurement on the output signal and returns the measured value.

[Visual Basic]
Function Measure( _
   MeasurementType As IviDCPwrMeasurementTypeEnum _
) As Double
[C++]
HRESULT Measure(
   IviDCPwrMeasurementTypeEnum MeasurementType,
   double* Measurement
);
[ANSI C]
HRESULT IIviDCPwrOutput_Measure(
   IIviDCPwrOutput* This
   IviDCPwrMeasurementTypeEnum MeasurementType,
   double* Measurement
);
[C#]
public double Measure(
   IviDCPwrMeasurementTypeEnum MeasurementType
);

Parameters

MeasurementType
The type of measurement to take, either Current or Volatge
Measurement
The measured value.

Capability Group

IviDCPwrMeasurement

Also In This Interface

Enabled | TriggerSource | TriggeredCurrentLimit | TriggeredVoltageLevel | VoltageLevel | CurrentLimit | CurrentLimitBehavior | OVPLimit | OVPEnabled | ConfigureCurrentLimit | ConfigureRange | ConfigureOVP | Measure | QueryCurrentLimitMax | QueryState | QueryVoltageLevelMax | ResetOutputProtection | IIviDCPwrOutput Overview


QueryCurrentLimitMax Method

IIviDCPwrOutput.QueryCurrentLimitMax Method

Returns the maximum programmable current limit that the power supply accepts for a particular voltage level on an output.

[Visual Basic]
Function QueryCurrentLimitMax( _
   VoltageLevel As Double _
) As Double
[C++]
HRESULT QueryCurrentLimitMax(
   double VoltageLevel,
   double* MaxCurrentLimit
);
[ANSI C]
HRESULT IIviDCPwrOutput_QueryCurrentLimitMax(
   IIviDCPwrOutput* This
   double VoltageLevel,
   double* MaxCurrentLimit
);
[C#]
public double QueryCurrentLimitMax(
   double VoltageLevel
);

Parameters

VoltageLevel
The voltage level for which to determine the maximum programmable current limit.
MaxCurrentLimit
Returns the maximum programmable current limit for the specified voltage level.

Capability Group

IviDcPwrBase

Also In This Interface

Enabled | TriggerSource | TriggeredCurrentLimit | TriggeredVoltageLevel | VoltageLevel | CurrentLimit | CurrentLimitBehavior | OVPLimit | OVPEnabled | ConfigureCurrentLimit | ConfigureRange | ConfigureOVP | Measure | QueryCurrentLimitMax | QueryState | QueryVoltageLevelMax | ResetOutputProtection | IIviDCPwrOutput Overview


QueryState Method

IIviDCPwrOutput.QueryState Method

Returns whether the power supply is in a particular output state.

[Visual Basic]
Function QueryState( _
   OutputState As IviDCPwrOutputStateEnum _
) As Boolean
[C++]
HRESULT QueryState(
   IviDCPwrOutputStateEnum OutputState,
   VARIANT_BOOL* InState
);
[ANSI C]
HRESULT IIviDCPwrOutput_QueryState(
   IIviDCPwrOutput* This
   IviDCPwrOutputStateEnum OutputState,
   VARIANT_BOOL* InState
);
[C#]
public bool QueryState(
   IviDCPwrOutputStateEnum OutputState
);

Parameters

OutputState
The output state for which to query. Allowed values are those defined in the IviDCPwrOutputStateEnum enumeration.
InState
Returns True if the power supply is currently in the state specified with the OutputState parameter, and False if it is not.

Capability Group

IviDcPwrBase

Also In This Interface

Enabled | TriggerSource | TriggeredCurrentLimit | TriggeredVoltageLevel | VoltageLevel | CurrentLimit | CurrentLimitBehavior | OVPLimit | OVPEnabled | ConfigureCurrentLimit | ConfigureRange | ConfigureOVP | Measure | QueryCurrentLimitMax | QueryState | QueryVoltageLevelMax | ResetOutputProtection | IIviDCPwrOutput Overview


QueryVoltageLevelMax Method

IIviDCPwrOutput.QueryVoltageLevelMax Method

Returns the maximum programmable voltage level that the power supply accepts for a particular current limit on an output.

[Visual Basic]
Function QueryVoltageLevelMax( _
   CurrentLimit As Double _
) As Double
[C++]
HRESULT QueryVoltageLevelMax(
   double CurrentLimit,
   double* MaxVoltageLevel
);
[ANSI C]
HRESULT IIviDCPwrOutput_QueryVoltageLevelMax(
   IIviDCPwrOutput* This
   double CurrentLimit,
   double* MaxVoltageLevel
);
[C#]
public double QueryVoltageLevelMax(
   double CurrentLimit
);

Parameters

CurrentLimit
The current limit for which to determine the maximum programmable voltage level.
MaxVoltageLevel
Returns the maximum programmable voltage level for the specified current limit.

Capability Group

IviDcPwrBase

Also In This Interface

Enabled | TriggerSource | TriggeredCurrentLimit | TriggeredVoltageLevel | VoltageLevel | CurrentLimit | CurrentLimitBehavior | OVPLimit | OVPEnabled | ConfigureCurrentLimit | ConfigureRange | ConfigureOVP | Measure | QueryCurrentLimitMax | QueryState | QueryVoltageLevelMax | ResetOutputProtection | IIviDCPwrOutput Overview


ResetOutputProtection Method

IIviDCPwrOutput.ResetOutputProtection Method

Resets the power supply's output protection after an over-voltage or over-current condition occurs.

[Visual Basic]
Sub ResetOutputProtection()
[C++]
HRESULT ResetOutputProtection();
[ANSI C]
HRESULT IIviDCPwrOutput_ResetOutputProtection(
   IIviDCPwrOutput* This);
[C#]
public void ResetOutputProtection();

Capability Group

IviDcPwrBase

Also In This Interface

Enabled | TriggerSource | TriggeredCurrentLimit | TriggeredVoltageLevel | VoltageLevel | CurrentLimit | CurrentLimitBehavior | OVPLimit | OVPEnabled | ConfigureCurrentLimit | ConfigureRange | ConfigureOVP | Measure | QueryCurrentLimitMax | QueryState | QueryVoltageLevelMax | ResetOutputProtection | IIviDCPwrOutput Overview


IIviDCPwrOutputs Interface

IviDCPwr class-compliant IIviDCPwrOutputs collection interface

Properties

Item | Pointer to a class-compliant IIviDCPwrOutput interface.
Count | How many outputs this DC power supply has. It is also the maximum valid value for the Index parameter to the Name method of the Outputs interface.
Name | The string associated by the driver to the value of Index without ever referring to the configuration store.


Item Property

IIviDCPwrOutputs.Item Property

Pointer to a class-compliant IIviDCPwrOutput interface.

[Visual Basic]
Property Get Item(OutputName As String) As IIviDCPwrOutput
[C++]
HRESULT get_Item(BSTR OutputName, IIviDCPwrOutput** value);
[ANSI C]
HRESULT IIviDCPwrOutputs_get_Item(IIviDCPwrOutputs* This, BSTR OutputName, IIviDCPwrOutput** value);
[C#]HRESULT get_Item(string OutputName, IIviDCPwrOutput value);

Parameters

OutputName
The OutputName parameter may be a string defined by the driver or supplied as a virtual name in the configuration store.

Capability Group

IviDcPwrBase

Also In This Interface

Item | Count | Name | IIviDCPwrOutputs Overview


Count Property

IIviDCPwrOutputs.Count Property

How many outputs this DC power supply has. It is also the maximum valid value for the Index parameter to the Name method of the Outputs interface.

[Visual Basic]
Property Get Count() As Long
[C++]
HRESULT get_Count(long* value);
[ANSI C]
HRESULT IIviDCPwrOutputs_get_Count(IIviDCPwrOutputs* This, long* value);
[C#]
public long Count {get;}

Capability Group

IviDcPwrBase

Also In This Interface

Item | Count | Name | IIviDCPwrOutputs Overview


Name Property

IIviDCPwrOutputs.Name Property

The string associated by the driver to the value of Index without ever referring to the configuration store.

[Visual Basic]
Property Get Name(Index As Long) As String
[C++]
HRESULT get_Name(long Index, BSTR* value);
[ANSI C]
HRESULT IIviDCPwrOutputs_get_Name(IIviDCPwrOutputs* This, long Index, BSTR* value);
[C#]HRESULT get_Name(long Index, string value);

Parameters

Index
The one-based index into the Outputs collection. Its value must range from one to Outputs.Count.

Capability Group

IviDcPwrBase

Also In This Interface

Item | Count | Name | IIviDCPwrOutputs Overview


IIviDCPwrTrigger Interface

IviDCPwr class-compliant IIviDCPwrTrigger interface

Methods

Abort | Returns the power supply to the ignore triggers state if the power supply is currently waiting for a trigger to change the output signal. If the power supply is not waiting for a trigger, this method does nothing.
Initiate | Causes the power supply to wait for a trigger if the power supply is not currently waiting for a trigger. If the power supply is already waiting for a trigger, this method does nothing
SendSoftwareTrigger | Supplies a trigger signal when the trigger source is set to Software Trigger


Abort Method

IIviDCPwrTrigger.Abort Method

Returns the power supply to the ignore triggers state if the power supply is currently waiting for a trigger to change the output signal. If the power supply is not waiting for a trigger, this method does nothing.

[Visual Basic]
Sub Abort()
[C++]
HRESULT Abort();
[ANSI C]
HRESULT IIviDCPwrTrigger_Abort(
   IIviDCPwrTrigger* This);
[C#]
public void Abort();

Capability Group

IviDCPwrTrigger

Also In This Interface

Abort | Initiate | SendSoftwareTrigger | IIviDCPwrTrigger Overview


Initiate Method

IIviDCPwrTrigger.Initiate Method

Causes the power supply to wait for a trigger if the power supply is not currently waiting for a trigger. If the power supply is already waiting for a trigger, this method does nothing

[Visual Basic]
Sub Initiate()
[C++]
HRESULT Initiate();
[ANSI C]
HRESULT IIviDCPwrTrigger_Initiate(
   IIviDCPwrTrigger* This);
[C#]
public void Initiate();

Capability Group

IviDCPwrTrigger

Also In This Interface

Abort | Initiate | SendSoftwareTrigger | IIviDCPwrTrigger Overview


SendSoftwareTrigger Method

IIviDCPwrTrigger.SendSoftwareTrigger Method

Supplies a trigger signal when the trigger source is set to Software Trigger

[Visual Basic]
Sub SendSoftwareTrigger()
[C++]
HRESULT SendSoftwareTrigger();
[ANSI C]
HRESULT IIviDCPwrTrigger_SendSoftwareTrigger(
   IIviDCPwrTrigger* This);
[C#]
public void SendSoftwareTrigger();

Capability Group

IviDCPwrSoftwareTrigger

Also In This Interface

Abort | Initiate | SendSoftwareTrigger | IIviDCPwrTrigger Overview


IviDCPwrCurrentLimitBehaviorEnum Enumeration

IviDCPwr class-compliant values for the CurrentLimitBehavior property in the Output interface.

Members

Member Name | Description
IviDCPwrCurrentLimitRegulate | The power supply restricts the output voltage such that the output current is not greater than the value of the Current Limit attribute.
IviDCPwrCurrentLimitTrip | The power supply disables the output when the output current is equal to or greater than the value of the Current Limit attribute.


IviDCPwrErrorCodesEnum Enumeration

IviDCPwr class defined HRESULTS

Members

Member Name | Description
E_IVIDCPWR_TRIGGER_NOT_SOFTWARE | The trigger source is not set to software trigger.


IviDCPwrMeasurementTypeEnum Enumeration

IviDCPwr class-compliant values for the MeasurementType parameter of the Measure method in Output interface.

Members

Member Name | Description
IviDCPwrMeasurementCurrent | Current is measured.
IviDCPwrMeasurementVoltage | Voltage is measured.


IviDCPwrOutputStateEnum Enumeration

IviDCPwr class-compliant values for the OutputState parameter of the QueryState method in the Output interface.

Members

Member Name | Description
IviDCPwrOutputConstantVoltage | Return value indicates whether a constant voltage condition exists.
IviDCPwrOutputConstantCurrent | Return value indicates whether a constant current condition exists.
IviDCPwrOutputOverVoltage | Return value indicates whether an over-voltage condition exists.
IviDCPwrOutputOverCurrent | Return value indicates whether an over-current condition exists.
IviDCPwrOutputUnregulated | Return value indicates whether an unregulated condition exists.


IviDCPwrRangeTypeEnum Enumeration

IviDCPwr class-compliant values for the RangeType parameter of the ConfigureRange method in the Output interface.

Members

Member Name | Description
IviDCPwrRangeCurrent | Current range is set by the Range parameter.
IviDCPwrRangeVoltage | Voltage range is set by the Range parameter.


IviDCPwrTriggerSourceEnum Enumeration

IviDCPwr class-compliant values for the Source property in the Trigger interface.

Members

Member Name | Description
IviDCPwrTriggerSourceImmediate | The power supply does not wait for a trigger before changing the output signal.
IviDCPwrTriggerSourceExternal | The power supply waits for an external trigger before changing the output signal.
IviDCPwrTriggerSourceSwTrigFunc | The power supply waits for the Send Software Trigger function to execute before changing the output signal.
IviDCPwrTriggerSourceTTL0 | The power supply waits for a trigger on the TTL 0 line before changing the output signal.
IviDCPwrTriggerSourceTTL1 | The power supply waits for a trigger on the TTL 1 line before changing the output signal.
IviDCPwrTriggerSourceTTL2 | The power supply waits for a trigger on the TTL 2 line before changing the output signal.
IviDCPwrTriggerSourceTTL3 | The power supply waits for a trigger on the TTL 3 line before changing the output signal.
IviDCPwrTriggerSourceTTL4 | The power supply waits for a trigger on the TTL 4 line before changing the output signal.
IviDCPwrTriggerSourceTTL5 | The power supply waits for a trigger on the TTL 5 line before changing the output signal.
IviDCPwrTriggerSourceTTL6 | The power supply waits for a trigger on the TTL 6 line before changing the output signal.
IviDCPwrTriggerSourceTTL7 | The power supply waits for a trigger on the TTL 7 line before changing the output signal.
IviDCPwrTriggerSourceECL0 | The power supply waits for a trigger on the ECL 0 line before changing the output signal.
IviDCPwrTriggerSourceECL1 | The power supply waits for a trigger on the ECL 1 line before changing the output signal.
IviDCPwrTriggerSourcePXIStar | The power supply waits for a trigger on the PXI Star line before changing the output signal.
IviDCPwrTriggerSourceRTSI0 | The power supply waits for a trigger on the RTSI 0 line before changing the output signal.
IviDCPwrTriggerSourceRTSI1 | The power supply waits for a trigger on the RTSI 1 line before changing the output signal.
IviDCPwrTriggerSourceRTSI2 | The power supply waits for a trigger on the RTSI 2 line before changing the output signal.
IviDCPwrTriggerSourceRTSI3 | The power supply waits for a trigger on the RTSI 3 line before changing the output signal.
IviDCPwrTriggerSourceRTSI4 | The power supply waits for a trigger on the RTSI 4 line before changing the output signal.
IviDCPwrTriggerSourceRTSI5 | The power supply waits for a trigger on the RTSI 5 line before changing the output signal.
IviDCPwrTriggerSourceRTSI6 | The power supply waits for a trigger on the RTSI 6 line before changing the output signal.


Topic Not Found

No matching topic was found. The link may be out of date, incorrectly authored, or the topic may not be available in this release.

You may be able to find the topic by using the index or search tab instead.


Inherent Interface

IVI Inherent Interfaces

IIviDriver | IVI Driver root interface
IIviDriverIdentity | IVI Driver identity interface
IIviDriverOperation | IVI Driver operation interface
IIviDriverUtility | IVI Driver utility interface


Instrument Specific Interfaces


IviDriver_ErrorCodes Enumeration

IVI Driver (inherent features) defined HRESULTS

Members

Member Name | Description
S_IVI_SUCCESS | Success
E_IVI_CANNOT_RECOVER | Unrecoverable failure
E_IVI_INSTRUMENT_STATUS | Instrument error detected
E_IVI_CANNOT_OPEN_FILE | File could not be opened
E_IVI_READING_FILE | File could not be read
E_IVI_WRITING_FILE | File could not be written
E_IVI_INVALID_PATHNAME | The path name is invalid
E_IVI_INVALID_VALUE | Invalid value for parameter or property
E_IVI_METHOD_NOT_SUPPORTED | Method not supported
E_IVI_PROPERTY_NOT_SUPPORTED | Property not supported
E_IVI_VALUE_NOT_SUPPORTED | The enumeration value for the parameter is not supported
E_IVI_NOT_INITIALIZED | A connection to the instrument has not been initialized
E_IVI_UNKNOWN_CHANNEL_NAME | Channel or repeated capability name specified is not valid for the instrument.
E_IVI_TOO_MANY_OPEN_FILES | Too many files opened
E_IVI_CHANNEL_NAME_REQUIRED | Channel or repeated capability name required
E_IVI_MISSING_OPTION_NAME | The option string contains an entry without a name.
E_IVI_MISSING_OPTION_VALUE | The option string contains an entry without a value.
E_IVI_BAD_OPTION_NAME | The option string contains an entry with an unknown option name.
E_IVI_BAD_OPTION_VALUE | The option string contains an entry with an unknown option value.
E_IVI_OUT_OF_MEMORY | The necessary memory could not be allocated
E_IVI_OPERATION_PENDING | Operation in progress
E_IVI_NULL_POINTER | Null pointer passed for parameter or property
E_IVI_UNEXPECTED_RESPONSE | Unexpected response from the instrument
E_IVI_FILE_NOT_FOUND | File not found
E_IVI_INVALID_FILE_FORMAT | The file format is invalid
E_IVI_STATUS_NOT_AVAILABLE | The instrument status is not available
E_IVI_ID_QUERY_FAILED | Instrument ID query failed
E_IVI_RESET_FAILED | Instrument reset failed
E_IVI_RESOURCE_UNKNOWN | Insufficient location information or resource not present in the system.
E_IVI_ALREADY_INITIALIZED | The driver is already initialized
E_IVI_CANNOT_CHANGE_SIMULATION_STATE | The simulation state cannot be changed.
S_IVI_NSUP_ID_QUERY | Identification query not supported
S_IVI_NSUP_RESET | Reset operation not supported
S_IVI_NSUP_SELF_TEST | Self test operation not supported
S_IVI_NSUP_ERROR_QUERY | Error query operation not supported
S_IVI_NSUP_REV_QUERY | Revision query not supported


IIviDriver Interface

IVI Driver root interface

Properties

DriverOperation | Pointer to the IIviDriverOperation interface
Identity | Pointer to the IIviDriverIdentity interface
Utility | Pointer to the IIviDriverUtility interface
Initialized | Initialized is True between a successful call to the Initialize method and a successful call to the Close method, and False at all other times.

Methods

Initialize | Opens the I/O session to the instrument. Driver methods and properties that access the instrument are only accessible after Initialize is called. Initialize optionally performs a Reset and queries the instrument to validate the instrument model.
Close | Closes the I/O session to the instrument. Driver methods and properties that access the instrument are not accessible after Close is called.


IIviDriverIdentity Interface

IVI Driver identity interface

Properties

Description | A brief description of the implementing component. Description is limted to 256 bytes.
Revision | The revision of the implementing component. Refer to IVI 3.1, Section 3.1.2.2, for a description of revision syntax and semantics. Revision is limited to 256 bytes.
Vendor | The name of the vendor that supplies the implementing component. Vendor is limited to 256 bytes.
InstrumentManufacturer | The name of the manufacturer reported by the physical instrument. If Simulation is enabled or the instrument is not capable of reporting the name of the manufacturer, a string is returned that explains the condition. Manufacturer is limited to 256 bytes
InstrumentModel | The model number or name reported by the physical instrument. If Simulation is enabled or the instrument is not capable of reporting the model number or name, a string is returned that explains the condition. Model is limited to 256 bytes
InstrumentFirmwareRevision | The firmware revision reported by the physical instrument. If Simulation is enabled or the instrument is not capable of reporting the firmware revision, a string is returned that explains the condition.
Identifier | The case-sensitive unique identifier of the implementing IVI-COM instrument driver.
SupportedInstrumentModels | A comma-separated list of instrument models that the IVI specific driver can control. The string does not include an abbreviation for the manufacturer if it is the same for all models.
SpecificationMajorVersion | For IVI class-compliant drivers, the major version number of the instrument class specification. If the driver is not class compliant, the driver returns zero.
SpecificationMinorVersion | For IVI class-compliant drivers, the minor version number of the instrument class specification. If the driver is not class compliant, the driver returns zero.
GroupCapabilities | A comma-separated list of the class capability groups implemented by the driver. Capability group names are documented in the IVI class specifications. If the driver is not class compliant, the driver returns an empty string.


IIviDriverOperation Interface

IVI Driver operation interface

Properties

LogicalName | Logical Name identifies a driver session in the Configuration Store. If Logical Name is not empty, the driver was initialized from information in the driver session. If it is empty, the driver was initialized without using the Configuration Store.
IoResourceDescriptor | The resource descriptor specifies the connection to a physical device. It is either specified in the Configuration Store or passed in the ResourceName parameter of the Initialize function. It is empty if the driver is not initialized.
Cache | Drivers may choose to always cache some instrument settings, never cache others, and optionally cache others, to avoid unecessary I/O to the instrument. If True, the driver caches optionally cached instrument settings.
InterchangeCheck | If True, the driver maintains a record of interchangeability warnings. If the driver does not support interchangeability checking, attempts to set InterchangeCheck to True return an error.
QueryInstrumentStatus | If True, the driver queries the instrument status at the end of each method or property that performs I/O to the instrument. If an error is reported, use ErrorQuery to retrieve error messages one at a time from the instrument.
RangeCheck | Drivers may choose to always validate some property/parameter values, never validate others, and optionally validate others, to avoid sending invalid commands to the instrument. If True, the driver performs optional validations.
RecordCoercions | If True, the driver keeps a list of the value coercions it makes for ViInt32 and ViReal64 attributes. If the driver does not support coercion recording, attempts to set RecordCoercions to True will return an error.
Simulate | If True, the driver does not perform I/O to the instrument, and returns simulated values for output parameters.
DriverSetup | The driver setup string. It is either specified in the Configuration Store or passed in the OptionString parameter of the Initialize function. Driver setup is empty if the driver is not initialized.

Methods

InvalidateAllAttributes | Invalidates all of the driver's cached values.
ClearInterchangeWarnings | Clears the list of interchangeability warnings that the IVI specific driver maintains.
GetNextInterchangeWarning | Returns the oldest warning from the interchange warning list. Records are only added to the list if InterchangeCheck is True.
ResetInterchangeCheck | Resets the interchangeability checking algorithms of the driver so that methods and properties that executed prior to calling this function have no affect on whether future calls to the driver generate interchangeability warnings.
GetNextCoercionRecord | Returns the oldest record from the coercion record list. Records are only added to the list if RecordCoercions is True.


IIviDriverUtility Interface

IVI Driver utility interface

Methods

Reset | Places the instrument in a known state and configures instrument options on which the IVI specific driver depends (for example, enabling/disabling headers). For an IEEE 488.2 instrument, Reset sends the command string *RST to the instrument.
ResetWithDefaults | Does the equivalent of Reset and then, (1) disables class extension capability groups, (2) sets attributes to initial values defined by class specs, and (3) configures the driver to option string settings used when Initialize was last executed.
Disable | Quickly places the instrument in a state where it has no, or minimal, effect on the external system to which it is connected. This state is not necessarily a known state.
SelfTest | Performs an instrument self test, waits for the instrument to complete the test, and queries the instrument for the results. If the instrument passes the test, TestResult is zero and TestMessage is 'Self test passed'.
ErrorQuery | Queries the instrument and returns instrument specific error information. This function can be used when QueryInstrumentStatus is True to retrieve error details when the driver detects an instrument error.
LockObject | Obtains a multithread lock on the driver after waiting until all other execution threads have released their locks on the instrument session.
UnlockObject | Releases a previously obtained mutlithread lock.


Close Method

IIviDriver.Close Method

Closes the I/O session to the instrument. Driver methods and properties that access the instrument are not accessible after Close is called.

[Visual Basic]
Sub Close()
[C++]
HRESULT Close();
[ANSI C]
HRESULT IIviDriver_Close(
   IIviDriver* This);
[C#]
public void Close();

Capability Group

IviDcPwrBase

Related Items

Initialize

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Initialize | Close | IIviDriver Overview


DriverOperation Property

IIviDriver.DriverOperation Property

Pointer to the IIviDriverOperation interface

[Visual Basic]
Property Get DriverOperation() As IIviDriverOperation
[C++]
HRESULT get_DriverOperation(IIviDriverOperation** value);
[ANSI C]
HRESULT IIviDriver_get_DriverOperation(IIviDriver* This, IIviDriverOperation** value);
[C#]
public IIviDriverOperation DriverOperation {get;}

Capability Group

IviDcPwrBase

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Initialize | Close | IIviDriver Overview


Identity Property

IIviDriver.Identity Property

Pointer to the IIviDriverIdentity interface

[Visual Basic]
Property Get Identity() As IIviDriverIdentity
[C++]
HRESULT get_Identity(IIviDriverIdentity** value);
[ANSI C]
HRESULT IIviDriver_get_Identity(IIviDriver* This, IIviDriverIdentity** value);
[C#]
public IIviDriverIdentity Identity {get;}

Capability Group

IviDcPwrBase

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Initialize | Close | IIviDriver Overview


Initialize Method

IIviDriver.Initialize Method

Opens the I/O session to the instrument. Driver methods and properties that access the instrument are only accessible after Initialize is called. Initialize optionally performs a Reset and queries the instrument to validate the instrument model.

[Visual Basic]
Sub Initialize( _
   ResourceName As String, _
   IdQuery As Boolean, _
   Reset As Boolean, _
   OptionString As String _
)
[C++]
HRESULT Initialize(
   BSTR ResourceName,
   VARIANT_BOOL IdQuery,
   VARIANT_BOOL Reset,
   BSTR OptionString
);
[ANSI C]
HRESULT IIviDriver_Initialize(
   IIviDriver* This
   BSTR ResourceName,
   VARIANT_BOOL IdQuery,
   VARIANT_BOOL Reset,
   BSTR OptionString
);
[C#]
public void Initialize(
   string ResourceName,
   bool IdQuery,
   bool Reset,
   string OptionString
);

Parameters

ResourceName
An IVI logical name or an instrument specific string that identifies the address of the instrument, such as a VISA resource descriptor string.
IdQuery
Specifies whether to verify the ID of the instrument.
Reset
Specifies whether to reset the instrument.
OptionString
The user can use the OptionsString parameter to specify the initial values of certain IVI inherent attributes for the session.

Capability Group

IviDcPwrBase

Related Items

Close

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Initialize | Close | IIviDriver Overview


Initialized Property

IIviDriver.Initialized Property

Initialized is True between a successful call to the Initialize method and a successful call to the Close method, and False at all other times.

[Visual Basic]
Property Get Initialized() As Boolean
[C++]
HRESULT get_Initialized(VARIANT_BOOL* value);
[ANSI C]
HRESULT IIviDriver_get_Initialized(IIviDriver* This, VARIANT_BOOL* value);
[C#]
public bool Initialized {get;}

Capability Group

IviDcPwrBase

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Initialize | Close | IIviDriver Overview


Utility Property

IIviDriver.Utility Property

Pointer to the IIviDriverUtility interface

[Visual Basic]
Property Get Utility() As IIviDriverUtility
[C++]
HRESULT get_Utility(IIviDriverUtility** value);
[ANSI C]
HRESULT IIviDriver_get_Utility(IIviDriver* This, IIviDriverUtility** value);
[C#]
public IIviDriverUtility Utility {get;}

Capability Group

IviDcPwrBase

Also In This Interface

DriverOperation | Identity | Utility | Initialized | Initialize | Close | IIviDriver Overview


Description Property

IIviDriverIdentity.Description Property

A brief description of the implementing component. Description is limted to 256 bytes.

[Visual Basic]
Property Get Description() As String
[C++]
HRESULT get_Description(BSTR* value);
[ANSI C]
HRESULT IIviDriverIdentity_get_Description(IIviDriverIdentity* This, BSTR* value);
[C#]
public string Description {get;}

Capability Group

IviDcPwrBase

Also In This Interface

Description | Revision | Vendor | InstrumentManufacturer | InstrumentModel | InstrumentFirmwareRevision | Identifier | SupportedInstrumentModels | SpecificationMajorVersion | SpecificationMinorVersion | GroupCapabilities | IIviDriverIdentity Overview


GroupCapabilities Property

IIviDriverIdentity.GroupCapabilities Property

A comma-separated list of the class capability groups implemented by the driver. Capability group names are documented in the IVI class specifications. If the driver is not class compliant, the driver returns an empty string.

[Visual Basic]
Property Get GroupCapabilities() As String
[C++]
HRESULT get_GroupCapabilities(BSTR* value);
[ANSI C]
HRESULT IIviDriverIdentity_get_GroupCapabilities(IIviDriverIdentity* This, BSTR* value);
[C#]
public string GroupCapabilities {get;}

Capability Group

IviDcPwrBase

Also In This Interface

Description | Revision | Vendor | InstrumentManufacturer | InstrumentModel | InstrumentFirmwareRevision | Identifier | SupportedInstrumentModels | SpecificationMajorVersion | SpecificationMinorVersion | GroupCapabilities | IIviDriverIdentity Overview


Identifier Property

IIviDriverIdentity.Identifier Property

The case-sensitive unique identifier of the implementing IVI-COM instrument driver.

[Visual Basic]
Property Get Identifier() As String
[C++]
HRESULT get_Identifier(BSTR* value);
[ANSI C]
HRESULT IIviDriverIdentity_get_Identifier(IIviDriverIdentity* This, BSTR* value);
[C#]
public string Identifier {get;}

Capability Group

IviDcPwrBase

Also In This Interface

Description | Revision | Vendor | InstrumentManufacturer | InstrumentModel | InstrumentFirmwareRevision | Identifier | SupportedInstrumentModels | SpecificationMajorVersion | SpecificationMinorVersion | GroupCapabilities | IIviDriverIdentity Overview


InstrumentFirmwareRevision Property

IIviDriverIdentity.InstrumentFirmwareRevision Property

The firmware revision reported by the physical instrument. If Simulation is enabled or the instrument is not capable of reporting the firmware revision, a string is returned that explains the condition.

[Visual Basic]
Property Get InstrumentFirmwareRevision() As String
[C++]
HRESULT get_InstrumentFirmwareRevision(BSTR* value);
[ANSI C]
HRESULT IIviDriverIdentity_get_InstrumentFirmwareRevision(IIviDriverIdentity* This, BSTR* value);
[C#]
public string InstrumentFirmwareRevision {get;}

Capability Group

IviDcPwrBase

Also In This Interface

Description | Revision | Vendor | InstrumentManufacturer | InstrumentModel | InstrumentFirmwareRevision | Identifier | SupportedInstrumentModels | SpecificationMajorVersion | SpecificationMinorVersion | GroupCapabilities | IIviDriverIdentity Overview


InstrumentManufacturer Property

IIviDriverIdentity.InstrumentManufacturer Property

The name of the manufacturer reported by the physical instrument. If Simulation is enabled or the instrument is not capable of reporting the name of the manufacturer, a string is returned that explains the condition. Manufacturer is limited to 256 bytes

[Visual Basic]
Property Get InstrumentManufacturer() As String
[C++]
HRESULT get_InstrumentManufacturer(BSTR* value);
[ANSI C]
HRESULT IIviDriverIdentity_get_InstrumentManufacturer(IIviDriverIdentity* This, BSTR* value);
[C#]
public string InstrumentManufacturer {get;}

Capability Group

IviDcPwrBase

Also In This Interface

Description | Revision | Vendor | InstrumentManufacturer | InstrumentModel | InstrumentFirmwareRevision | Identifier | SupportedInstrumentModels | SpecificationMajorVersion | SpecificationMinorVersion | GroupCapabilities | IIviDriverIdentity Overview


InstrumentModel Property

IIviDriverIdentity.InstrumentModel Property

The model number or name reported by the physical instrument. If Simulation is enabled or the instrument is not capable of reporting the model number or name, a string is returned that explains the condition. Model is limited to 256 bytes

[Visual Basic]
Property Get InstrumentModel() As String
[C++]
HRESULT get_InstrumentModel(BSTR* value);
[ANSI C]
HRESULT IIviDriverIdentity_get_InstrumentModel(IIviDriverIdentity* This, BSTR* value);
[C#]
public string InstrumentModel {get;}

Capability Group

IviDcPwrBase

Also In This Interface

Description | Revision | Vendor | InstrumentManufacturer | InstrumentModel | InstrumentFirmwareRevision | Identifier | SupportedInstrumentModels | SpecificationMajorVersion | SpecificationMinorVersion | GroupCapabilities | IIviDriverIdentity Overview


Revision Property

IIviDriverIdentity.Revision Property

The revision of the implementing component. Refer to IVI 3.1, Section 3.1.2.2, for a description of revision syntax and semantics. Revision is limited to 256 bytes.

[Visual Basic]
Property Get Revision() As String
[C++]
HRESULT get_Revision(BSTR* value);
[ANSI C]
HRESULT IIviDriverIdentity_get_Revision(IIviDriverIdentity* This, BSTR* value);
[C#]
public string Revision {get;}

Capability Group

IviDcPwrBase

Also In This Interface

Description | Revision | Vendor | InstrumentManufacturer | InstrumentModel | InstrumentFirmwareRevision | Identifier | SupportedInstrumentModels | SpecificationMajorVersion | SpecificationMinorVersion | GroupCapabilities | IIviDriverIdentity Overview


SpecificationMajorVersion Property

IIviDriverIdentity.SpecificationMajorVersion Property

For IVI class-compliant drivers, the major version number of the instrument class specification. If the driver is not class compliant, the driver returns zero.

[Visual Basic]
Property Get SpecificationMajorVersion() As Long
[C++]
HRESULT get_SpecificationMajorVersion(long* value);
[ANSI C]
HRESULT IIviDriverIdentity_get_SpecificationMajorVersion(IIviDriverIdentity* This, long* value);
[C#]
public long SpecificationMajorVersion {get;}

Capability Group

IviDcPwrBase

Also In This Interface

Description | Revision | Vendor | InstrumentManufacturer | InstrumentModel | InstrumentFirmwareRevision | Identifier | SupportedInstrumentModels | SpecificationMajorVersion | SpecificationMinorVersion | GroupCapabilities | IIviDriverIdentity Overview


SpecificationMinorVersion Property

IIviDriverIdentity.SpecificationMinorVersion Property

For IVI class-compliant drivers, the minor version number of the instrument class specification. If the driver is not class compliant, the driver returns zero.

[Visual Basic]
Property Get SpecificationMinorVersion() As Long
[C++]
HRESULT get_SpecificationMinorVersion(long* value);
[ANSI C]
HRESULT IIviDriverIdentity_get_SpecificationMinorVersion(IIviDriverIdentity* This, long* value);
[C#]
public long SpecificationMinorVersion {get;}

Capability Group

IviDcPwrBase

Also In This Interface

Description | Revision | Vendor | InstrumentManufacturer | InstrumentModel | InstrumentFirmwareRevision | Identifier | SupportedInstrumentModels | SpecificationMajorVersion | SpecificationMinorVersion | GroupCapabilities | IIviDriverIdentity Overview


SupportedInstrumentModels Property

IIviDriverIdentity.SupportedInstrumentModels Property

A comma-separated list of instrument models that the IVI specific driver can control. The string does not include an abbreviation for the manufacturer if it is the same for all models.

[Visual Basic]
Property Get SupportedInstrumentModels() As String
[C++]
HRESULT get_SupportedInstrumentModels(BSTR* value);
[ANSI C]
HRESULT IIviDriverIdentity_get_SupportedInstrumentModels(IIviDriverIdentity* This, BSTR* value);
[C#]
public string SupportedInstrumentModels {get;}

Capability Group

IviDcPwrBase

Also In This Interface

Description | Revision | Vendor | InstrumentManufacturer | InstrumentModel | InstrumentFirmwareRevision | Identifier | SupportedInstrumentModels | SpecificationMajorVersion | SpecificationMinorVersion | GroupCapabilities | IIviDriverIdentity Overview


Vendor Property

IIviDriverIdentity.Vendor Property

The name of the vendor that supplies the implementing component. Vendor is limited to 256 bytes.

[Visual Basic]
Property Get Vendor() As String
[C++]
HRESULT get_Vendor(BSTR* value);
[ANSI C]
HRESULT IIviDriverIdentity_get_Vendor(IIviDriverIdentity* This, BSTR* value);
[C#]
public string Vendor {get;}

Capability Group

IviDcPwrBase

Also In This Interface

Description | Revision | Vendor | InstrumentManufacturer | InstrumentModel | InstrumentFirmwareRevision | Identifier | SupportedInstrumentModels | SpecificationMajorVersion | SpecificationMinorVersion | GroupCapabilities | IIviDriverIdentity Overview


Cache Property

IIviDriverOperation.Cache Property

Drivers may choose to always cache some instrument settings, never cache others, and optionally cache others, to avoid unecessary I/O to the instrument. If True, the driver caches optionally cached instrument settings.

[Visual Basic]
Property Get Cache() As Boolean
Property Let Cache(value As Boolean)
[C++]
HRESULT get_Cache(VARIANT_BOOL* value);
HRESULT put_Cache(VARIANT_BOOL value);
[ANSI C]
HRESULT IIviDriverOperation_get_Cache(IIviDriverOperation* This, VARIANT_BOOL* value);
HRESULT IIviDriverOperation_put_Cache(IIviDriverOperation* This, VARIANT_BOOL value);
[C#]
public bool Cache {get; set;}

Capability Group

IviDcPwrBase

Related Items

InvalidateAllAttributes

Also In This Interface

LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


ClearInterchangeWarnings Method

IIviDriverOperation.ClearInterchangeWarnings Method

Clears the list of interchangeability warnings that the IVI specific driver maintains.

[Visual Basic]
Sub ClearInterchangeWarnings()
[C++]
HRESULT ClearInterchangeWarnings();
[ANSI C]
HRESULT IIviDriverOperation_ClearInterchangeWarnings(
   IIviDriverOperation* This);
[C#]
public void ClearInterchangeWarnings();

Capability Group

IviDcPwrBase

Related Items

GetNextInterchangeWarning | ResetInterchangeCheck | InterchangeCheck

Also In This Interface

LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


DriverSetup Property

IIviDriverOperation.DriverSetup Property

The driver setup string. It is either specified in the Configuration Store or passed in the OptionString parameter of the Initialize function. Driver setup is empty if the driver is not initialized.

[Visual Basic]
Property Get DriverSetup() As String
[C++]
HRESULT get_DriverSetup(BSTR* value);
[ANSI C]
HRESULT IIviDriverOperation_get_DriverSetup(IIviDriverOperation* This, BSTR* value);
[C#]
public string DriverSetup {get;}

Capability Group

IviDcPwrBase

Also In This Interface

LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


GetNextCoercionRecord Method

IIviDriverOperation.GetNextCoercionRecord Method

Returns the oldest record from the coercion record list. Records are only added to the list if RecordCoercions is True.

[Visual Basic]
Function GetNextCoercionRecord() As String
[C++]
HRESULT GetNextCoercionRecord(
   BSTR* CoercionRecord
);
[ANSI C]
HRESULT IIviDriverOperation_GetNextCoercionRecord(
   IIviDriverOperation* This
   BSTR* CoercionRecord
);
[C#]
public string GetNextCoercionRecord();

Parameters

CoercionRecord
The coercion record string shall contain the following information:
  • The name of the attribute that was coerced. This can be the generic name, the COM property name, or the C defined constant.
  • If the attribute is channel-based, the name of the channel. The channel name can be the specific driver channel string or the virtual channel name that the user specified.
  • If the attribute applies to a repeated capability, the name of the repeated capability. The name can be the specific driver repeated capability token or the virtual repeated capability name that the user specified.
  • The value that the user specified for the attribute.
  • The value to which the attribute was coerced.

    • Capability Group

    IviDcPwrBase

    Related Items

    RecordCoercions

    Also In This Interface

    LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


GetNextInterchangeWarning Method

IIviDriverOperation.GetNextInterchangeWarning Method

Returns the oldest warning from the interchange warning list. Records are only added to the list if InterchangeCheck is True.

[Visual Basic]
Function GetNextInterchangeWarning() As String
[C++]
HRESULT GetNextInterchangeWarning(
   BSTR* InterchangeWarning
);
[ANSI C]
HRESULT IIviDriverOperation_GetNextInterchangeWarning(
   IIviDriverOperation* This
   BSTR* InterchangeWarning
);
[C#]
public string GetNextInterchangeWarning();

Parameters

InterchangeWarning
A string describing the oldest interchangeability warning or empty string if no warrnings remain.

Capability Group

IviDcPwrBase

Related Items

ClearInterchangeWarnings | ResetInterchangeCheck | InterchangeCheck

Also In This Interface

LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


InterchangeCheck Property

IIviDriverOperation.InterchangeCheck Property

If True, the driver maintains a record of interchangeability warnings. If the driver does not support interchangeability checking, attempts to set InterchangeCheck to True return an error.

[Visual Basic]
Property Get InterchangeCheck() As Boolean
Property Let InterchangeCheck(value As Boolean)
[C++]
HRESULT get_InterchangeCheck(VARIANT_BOOL* value);
HRESULT put_InterchangeCheck(VARIANT_BOOL value);
[ANSI C]
HRESULT IIviDriverOperation_get_InterchangeCheck(IIviDriverOperation* This, VARIANT_BOOL* value);
HRESULT IIviDriverOperation_put_InterchangeCheck(IIviDriverOperation* This, VARIANT_BOOL value);
[C#]
public bool InterchangeCheck {get; set;}

Capability Group

IviDcPwrBase

Related Items

ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck

Also In This Interface

LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


InvalidateAllAttributes Method

IIviDriverOperation.InvalidateAllAttributes Method

Invalidates all of the driver's cached values.

[Visual Basic]
Sub InvalidateAllAttributes()
[C++]
HRESULT InvalidateAllAttributes();
[ANSI C]
HRESULT IIviDriverOperation_InvalidateAllAttributes(
   IIviDriverOperation* This);
[C#]
public void InvalidateAllAttributes();

Capability Group

IviDcPwrBase

Related Items

Cache

Also In This Interface

LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


IoResourceDescriptor Property

IIviDriverOperation.IoResourceDescriptor Property

The resource descriptor specifies the connection to a physical device. It is either specified in the Configuration Store or passed in the ResourceName parameter of the Initialize function. It is empty if the driver is not initialized.

[Visual Basic]
Property Get IoResourceDescriptor() As String
[C++]
HRESULT get_IoResourceDescriptor(BSTR* value);
[ANSI C]
HRESULT IIviDriverOperation_get_IoResourceDescriptor(IIviDriverOperation* This, BSTR* value);
[C#]
public string IoResourceDescriptor {get;}

Capability Group

IviDcPwrBase

Also In This Interface

LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


LogicalName Property

IIviDriverOperation.LogicalName Property

Logical Name identifies a driver session in the Configuration Store. If Logical Name is not empty, the driver was initialized from information in the driver session. If it is empty, the driver was initialized without using the Configuration Store.

[Visual Basic]
Property Get LogicalName() As String
[C++]
HRESULT get_LogicalName(BSTR* value);
[ANSI C]
HRESULT IIviDriverOperation_get_LogicalName(IIviDriverOperation* This, BSTR* value);
[C#]
public string LogicalName {get;}

Capability Group

IviDcPwrBase

Also In This Interface

LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


QueryInstrumentStatus Property

IIviDriverOperation.QueryInstrumentStatus Property

If True, the driver queries the instrument status at the end of each method or property that performs I/O to the instrument. If an error is reported, use ErrorQuery to retrieve error messages one at a time from the instrument.

[Visual Basic]
Property Get QueryInstrumentStatus() As Boolean
Property Let QueryInstrumentStatus(value As Boolean)
[C++]
HRESULT get_QueryInstrumentStatus(VARIANT_BOOL* value);
HRESULT put_QueryInstrumentStatus(VARIANT_BOOL value);
[ANSI C]
HRESULT IIviDriverOperation_get_QueryInstrumentStatus(IIviDriverOperation* This, VARIANT_BOOL* value);
HRESULT IIviDriverOperation_put_QueryInstrumentStatus(IIviDriverOperation* This, VARIANT_BOOL value);
[C#]
public bool QueryInstrumentStatus {get; set;}

Capability Group

IviDcPwrBase

Also In This Interface

LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


RangeCheck Property

IIviDriverOperation.RangeCheck Property

Drivers may choose to always validate some property/parameter values, never validate others, and optionally validate others, to avoid sending invalid commands to the instrument. If True, the driver performs optional validations.

[Visual Basic]
Property Get RangeCheck() As Boolean
Property Let RangeCheck(value As Boolean)
[C++]
HRESULT get_RangeCheck(VARIANT_BOOL* value);
HRESULT put_RangeCheck(VARIANT_BOOL value);
[ANSI C]
HRESULT IIviDriverOperation_get_RangeCheck(IIviDriverOperation* This, VARIANT_BOOL* value);
HRESULT IIviDriverOperation_put_RangeCheck(IIviDriverOperation* This, VARIANT_BOOL value);
[C#]
public bool RangeCheck {get; set;}

Capability Group

IviDcPwrBase

Also In This Interface

LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


RecordCoercions Property

IIviDriverOperation.RecordCoercions Property

If True, the driver keeps a list of the value coercions it makes for ViInt32 and ViReal64 attributes. If the driver does not support coercion recording, attempts to set RecordCoercions to True will return an error.

[Visual Basic]
Property Get RecordCoercions() As Boolean
Property Let RecordCoercions(value As Boolean)
[C++]
HRESULT get_RecordCoercions(VARIANT_BOOL* value);
HRESULT put_RecordCoercions(VARIANT_BOOL value);
[ANSI C]
HRESULT IIviDriverOperation_get_RecordCoercions(IIviDriverOperation* This, VARIANT_BOOL* value);
HRESULT IIviDriverOperation_put_RecordCoercions(IIviDriverOperation* This, VARIANT_BOOL value);
[C#]
public bool RecordCoercions {get; set;}

Capability Group

IviDcPwrBase

Related Items

GetNextCoercionRecord

Also In This Interface

LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


ResetInterchangeCheck Method

IIviDriverOperation.ResetInterchangeCheck Method

Resets the interchangeability checking algorithms of the driver so that methods and properties that executed prior to calling this function have no affect on whether future calls to the driver generate interchangeability warnings.

[Visual Basic]
Sub ResetInterchangeCheck()
[C++]
HRESULT ResetInterchangeCheck();
[ANSI C]
HRESULT IIviDriverOperation_ResetInterchangeCheck(
   IIviDriverOperation* This);
[C#]
public void ResetInterchangeCheck();

Capability Group

IviDcPwrBase

Related Items

GetNextInterchangeWarning | ClearInterchangeWarnings | InterchangeCheck

Also In This Interface

LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


Simulate Property

IIviDriverOperation.Simulate Property

If True, the driver does not perform I/O to the instrument, and returns simulated values for output parameters.

[Visual Basic]
Property Get Simulate() As Boolean
Property Let Simulate(value As Boolean)
[C++]
HRESULT get_Simulate(VARIANT_BOOL* value);
HRESULT put_Simulate(VARIANT_BOOL value);
[ANSI C]
HRESULT IIviDriverOperation_get_Simulate(IIviDriverOperation* This, VARIANT_BOOL* value);
HRESULT IIviDriverOperation_put_Simulate(IIviDriverOperation* This, VARIANT_BOOL value);
[C#]
public bool Simulate {get; set;}

Capability Group

IviDcPwrBase

Also In This Interface

LogicalName | IoResourceDescriptor | Cache | InterchangeCheck | QueryInstrumentStatus | RangeCheck | RecordCoercions | Simulate | DriverSetup | InvalidateAllAttributes | ClearInterchangeWarnings | GetNextInterchangeWarning | ResetInterchangeCheck | GetNextCoercionRecord | IIviDriverOperation Overview


Disable Method

IIviDriverUtility.Disable Method

Quickly places the instrument in a state where it has no, or minimal, effect on the external system to which it is connected. This state is not necessarily a known state.

[Visual Basic]
Sub Disable()
[C++]
HRESULT Disable();
[ANSI C]
HRESULT IIviDriverUtility_Disable(
   IIviDriverUtility* This);
[C#]
public void Disable();

Capability Group

IviDcPwrBase

Also In This Interface

Reset | ResetWithDefaults | Disable | SelfTest | ErrorQuery | LockObject | UnlockObject | IIviDriverUtility Overview


ErrorQuery Method

IIviDriverUtility.ErrorQuery Method

Queries the instrument and returns instrument specific error information. This function can be used when QueryInstrumentStatus is True to retrieve error details when the driver detects an instrument error.

[Visual Basic]
Sub ErrorQuery( _
   ErrorCode As Long, _
   ErrorMessage As String _
)
[C++]
HRESULT ErrorQuery(
   long* ErrorCode,
   BSTR* ErrorMessage
);
[ANSI C]
HRESULT IIviDriverUtility_ErrorQuery(
   IIviDriverUtility* This
   long* ErrorCode,
   BSTR* ErrorMessage
);
[C#]
public void ErrorQuery(
   long ErrorCode,
   string ErrorMessage
);

Parameters

ErrorCode
Instrument error code
ErrorMessage
Instrument error message

Capability Group

IviDcPwrBase

Also In This Interface

Reset | ResetWithDefaults | Disable | SelfTest | ErrorQuery | LockObject | UnlockObject | IIviDriverUtility Overview


LockObject Method

IIviDriverUtility.LockObject Method

Obtains a multithread lock on the driver after waiting until all other execution threads have released their locks on the instrument session.

[Visual Basic]
Sub LockObject()
[C++]
HRESULT LockObject();
[ANSI C]
HRESULT IIviDriverUtility_LockObject(
   IIviDriverUtility* This);
[C#]
public void LockObject();

Capability Group

IviDcPwrBase

Related Items

UnlockObject

Also In This Interface

Reset | ResetWithDefaults | Disable | SelfTest | ErrorQuery | LockObject | UnlockObject | IIviDriverUtility Overview


Reset Method

IIviDriverUtility.Reset Method

Places the instrument in a known state and configures instrument options on which the IVI specific driver depends (for example, enabling/disabling headers). For an IEEE 488.2 instrument, Reset sends the command string *RST to the instrument.

[Visual Basic]
Sub Reset()
[C++]
HRESULT Reset();
[ANSI C]
HRESULT IIviDriverUtility_Reset(
   IIviDriverUtility* This);
[C#]
public void Reset();

Capability Group

IviDcPwrBase

Related Items

ResetWithDefaults

Also In This Interface

Reset | ResetWithDefaults | Disable | SelfTest | ErrorQuery | LockObject | UnlockObject | IIviDriverUtility Overview


ResetWithDefaults Method

IIviDriverUtility.ResetWithDefaults Method

Does the equivalent of Reset and then, (1) disables class extension capability groups, (2) sets attributes to initial values defined by class specs, and (3) configures the driver to option string settings used when Initialize was last executed.

[Visual Basic]
Sub ResetWithDefaults()
[C++]
HRESULT ResetWithDefaults();
[ANSI C]
HRESULT IIviDriverUtility_ResetWithDefaults(
   IIviDriverUtility* This);
[C#]
public void ResetWithDefaults();

Capability Group

IviDcPwrBase

Also In This Interface

Reset | ResetWithDefaults | Disable | SelfTest | ErrorQuery | LockObject | UnlockObject | IIviDriverUtility Overview


SelfTest Method

IIviDriverUtility.SelfTest Method

Performs an instrument self test, waits for the instrument to complete the test, and queries the instrument for the results. If the instrument passes the test, TestResult is zero and TestMessage is 'Self test passed'.

[Visual Basic]
Sub SelfTest( _
   TestResult As Long, _
   TestMessage As String _
)
[C++]
HRESULT SelfTest(
   long* TestResult,
   BSTR* TestMessage
);
[ANSI C]
HRESULT IIviDriverUtility_SelfTest(
   IIviDriverUtility* This
   long* TestResult,
   BSTR* TestMessage
);
[C#]
public void SelfTest(
   long TestResult,
   string TestMessage
);

Parameters

TestResult
The numeric result from the self test operation. 0 = no error (test passed)
TestMessage
The self test status message

Capability Group

IviDcPwrBase

Also In This Interface

Reset | ResetWithDefaults | Disable | SelfTest | ErrorQuery | LockObject | UnlockObject | IIviDriverUtility Overview


UnlockObject Method

IIviDriverUtility.UnlockObject Method

Releases a previously obtained mutlithread lock.

[Visual Basic]
Sub UnlockObject()
[C++]
HRESULT UnlockObject();
[ANSI C]
HRESULT IIviDriverUtility_UnlockObject(
   IIviDriverUtility* This);
[C#]
public void UnlockObject();

Capability Group

IviDcPwrBase

Related Items

LockObject

Also In This Interface

Reset | ResetWithDefaults | Disable | SelfTest | ErrorQuery | LockObject | UnlockObject | IIviDriverUtility Overview