Citrix 連線中心視窗

Citrix 連線中心可顯示所有從 Citrix Receiver 建立的連線。 您可以使用 Receiver 來存取應用程式、伺服器桌面或管理員所發行的內容 (例如文件或簡報)。 所有您可以存取的項目，統稱為「已發行資源」，這些項目儲存在 Citrix XenApp 伺服器中。 每個伺服器群組都是一個「伺服器陣列」。

Citrix Connection Center 會顯示目前開啟的工作階段。


Citrix 連線中心概觀

Citrix 連線中心可顯示所有從 Citrix Receiver 建立的連線。

[連線] 視窗可顯示使用中的工作階段清單。 清單中的每個伺服器項目均代表一個工作階段。 在每個無縫工作階段的每個伺服器項目之下，都會顯示在該伺服器執行的已發行資源清單。

連線中心提供各種檢視統計資料、控制工作階段及應用程式的選項。

[中斷連線] 按鈕

[中斷連線] 按鈕會中斷與目前選取之伺服器工作階段的連線。

[全螢幕] 按鈕

若選取 [全螢幕] 按鈕，則目前所選取的無縫連線會切換至全螢幕工作階段。 按 SHIFT+F2 鍵可使本工作階段返回無縫模式。

[內容] 按鈕

顯示所選伺服器的通訊統計資料。 也會顯示目前所選工作階段的使用者名稱、伺服器名稱、加密層級、工作階段可靠性及 SpeedScreen 設定。

[登出] 按鈕

若要從伺服器登出，請由清單中選取伺服器項目並按一下 [登出]。 工作階段會結束，且正在該伺服器上執行的所有發行的應用程式也會結束。

工作階段安全性 - 檔案

使用 [檔案] 下拉式功能表可設定已啟動應用程式存取對應本機磁碟機上的檔案的權限。 這些設定不會影響應用程式存取伺服器上的檔案的權限。
  • 選擇 [唯讀] 可授予已啟動應用程式對相關本機檔案的唯讀存取權。
  • 選擇 [要求權限]，在重新導向前會顯示對話方塊，要求指定是否應進行重新導向。
  • 選擇 [完整存取] 可授予已啟動應用程式對相關本機檔案的讀/寫存取權。 只有選擇 [完整存取] 選項才能在本機磁碟機儲存變更。
  • 選擇 [不准存取] 可拒絕已啟動應用程式存取任何本機檔案。
註: 特殊資料夾重新導向需要存取使用者本機電腦的 [文件] 與 [桌面] 資料夾。 當使用者透過 Web Interface 啟動應用程式，並在連線中心的 [檔案] 下拉式功能表中選取 [不准存取] 時，對使用者的本機工作站磁碟機的存取會遭到拒絕，包括對使用者的本機 [文件] 與 [桌面] 資料夾的存取。 如此一來，某些應用程式嘗試對禁止存取的資料夾執行讀/寫操作時，可能無法正常運作。 為避免此狀況，啟用 [特殊資料夾重新導向] 時，請一律授予完整的本機存取權限。

工作階段安全性 - 麥克風/網路攝影機

使用 [音訊安全性] 下拉式功能表可設定已啟動應用程式存取電腦麥克風或網路攝影機的權限。
  • 選擇 [要求權限]，在重新導向前會顯示對話方塊，要求指定是否應進行重新導向
  • 選擇 [完整存取] 可允許已啟動應用程式存取電腦的麥克風或網路攝影機，從而執行錄製傳輸
  • 選擇 [不准存取] 可拒絕已啟動應用程式存取電腦的麥克風或網路攝影機

工作階段安全性 - PDA 裝置

使用 [PDA 安全性] 下拉式功能表可設定已啟動應用程式存取本機 PDA 裝置的權限。
  • 選擇 [要求權限]，在重新導向前會顯示對話方塊，要求指定是否應進行重新導向
  • 選擇 [完整存取] 可允許已啟動應用程式存取 PDA 裝置
  • 選擇 [不准存取] 可拒絕已啟動應用程式存取 PDA 裝置

工作階段安全性 - USB/其他裝置

使用 [USB/其他裝置] 下拉式功能表可設定已啟動應用程式存取本機掃描器、數位相機、銷售點系統或其他裝置的權限，以從上述裝置取得檔案或資訊。
  • 選擇 [要求權限]，在重新導向前會顯示對話方塊，要求指定是否應進行重新導向
  • 選擇 [完整存取] 可允許已啟動應用程式存取您的裝置
  • 選擇 [不准存取] 可拒絕已啟動應用程式存取您的裝置

應用程式 - 結束按鈕

若要結束個別的已發行應用程式連線，請選取已發行應用程式並按一下 [結束]。

如果還有其他發行的應用程式正在該伺服器上執行，工作階段會保持在使用中，且發行的應用程式會保持在執行中。 如果沒有其他發行的應用程式正在伺服器上執行，則會結束與伺服器的連線。


變更已發行資源的檢視方式

您可以在「無縫」與「全螢幕」模式之間切換。

  • 無縫模式。 已發行應用程式和桌面不會包含在工作階段視窗內。 每個已發行應用程式和桌面都會出現在其本身的可調整大小的視窗中，就好像實際安裝在使用者裝置上一樣。 您可以在已發行應用程式與本機桌面之間切換。
  • 全螢幕模式。 已發行應用程式會放在全螢幕大小的桌面中。
  1. 選取伺服器名稱。
  2. 按一下 [全螢幕] 按鈕，然後按一下 [確定]。
  3. 若要返回無縫模式，請按下 Shift + F2。


按鈕為什麼停用了？

在 Citrix 連線中心選取已發行應用程式名稱時，[工作階段] 和 [工作階段安全性] 按鈕會有意停用。 [工作階段] 按鈕只會套用至伺服器工作階段，不會套用至個別已發行應用程式。 您無法根據已發行應用程式，修改工作階段安全性功能的運作方式；不過，如果從連線中心選取伺服器名稱，便可以修改工作階段的工作階段安全性設定。
工作階段選項 | 工作階段安全性選項
中斷連線 | 檔案
全螢幕 | 麥克風/網路攝影機
內容 | PDA 裝置
登出 | USB/其他裝置


顯示伺服器統計資料

您可以使用 Citrix 連線中心顯示特定工作階段的伺服器統計資料。 顯示的部分統計資料包括：

  • Citrix Receiver 版本號碼
  • 用於連線的伺服器
  • 用於登入伺服器的帳戶
  • 加密層級
  • 是否啟用 [工作階段可靠性]
  • 是否啟用 SpeedScreen 功能
  • 透過連線傳輸的傳入和傳出位元組數
  • 透過連線傳輸的傳入和傳出框架數
  • 除以框架數後的位元組數
  • 透過連線錯誤傳輸的傳入或傳出框架數

若要顯示伺服器統計資料和內容，請選取伺服器名稱，然後按一下 [內容]。


中斷連線後讓伺服器工作階段繼續執行

您可以透過 Citrix 連線中心從伺服器中斷連線，但需讓伺服器上的工作階段繼續執行。 如果從伺服器中斷連線，請透過 Citrix Receiver 功能表直接重新連線至工作階段。

  1. 若要中斷特定的工作階段連線，請選取伺服器名稱，然後按一下 [中斷連線] 按鈕。

    若要中斷所有執行中的工作階段連線，請以滑鼠右鍵按一下 Windows 通知區中的外掛程式圖示，然後選取 [中斷線上工作階段連線]。

  2. 若要重新連線至中斷的工作階段，請以滑鼠右鍵按一下 Windows 通知區中的 Receiver 圖示，然後選取 [重新連線線上工作階段]。


結束伺服器工作階段

您可以使用 Citrix 連線中心結束伺服器工作階段，並關閉所有資源。 當工作階段結束時，在該伺服器上執行的所有已發行資源都會終止。

  1. 選取伺服器名稱。
  2. 按一下 [登出]。


終止個別已發行應用程式

您可以使用 Citrix 連線中心結束特定的已發行應用程式。 如果還有其他已發行應用程式正在該伺服器上執行，則該工作階段會保持在使用狀態，且其他已發行應用程式仍會繼續執行。 如果沒有其他已發行應用程式正在伺服器上執行，則會結束與伺服器的連線。

  1. 請確定您的工作階段處於無縫模式下。
  2. 從連線中心的清單中選取已發行應用程式。
  3. 按一下 [結束]。


設定檔案的存取權限

工作階段安全性 - 檔案

使用 [檔案] 下拉式功能表可設定已啟動應用程式存取對應本機磁碟機上的檔案的權限。 這些設定不會影響應用程式存取伺服器上的檔案的權限。
  • 選擇 [唯讀] 可授予已啟動應用程式對相關本機檔案的唯讀存取權。
  • 選擇 [要求權限]，在重新導向前會顯示對話方塊，要求指定是否應進行重新導向。
  • 選擇 [完整存取] 可授予已啟動應用程式對相關本機檔案的讀/寫存取權。 只有選擇 [完整存取] 選項才能在本機磁碟機儲存變更。
  • 選擇 [不准存取] 可拒絕已啟動應用程式存取任何本機檔案。
註: 特殊資料夾重新導向需要存取使用者本機電腦的 [文件] 與 [桌面] 資料夾。 當使用者透過 Web Interface 啟動應用程式，並在連線中心的 [檔案] 下拉式功能表中選取 [不准存取] 時，對使用者的本機工作站磁碟機的存取會遭到拒絕，包括對使用者的本機 [文件] 與 [桌面] 資料夾的存取。 如此一來，某些應用程式嘗試對禁止存取的資料夾執行讀/寫操作時，可能無法正常運作。 為避免此狀況，啟用 [特殊資料夾重新導向] 時，請一律授予完整的本機存取權限。


設定麥克風與網路攝影機的存取權限

工作階段安全性 - 麥克風/網路攝影機

使用 [音訊安全性] 下拉式功能表可設定已啟動應用程式存取電腦麥克風或網路攝影機的權限。
  • 選擇 [要求權限]，在重新導向前會顯示對話方塊，要求指定是否應進行重新導向
  • 選擇 [完整存取] 可允許已啟動應用程式存取電腦的麥克風或網路攝影機，從而執行錄製傳輸
  • 選擇 [不准存取] 可拒絕已啟動應用程式存取電腦的麥克風或網路攝影機


設定本機 PDA 裝置的存取權限

工作階段安全性 - PDA 裝置

使用 [PDA 安全性] 下拉式功能表可設定已啟動應用程式存取本機 PDA 裝置的權限。
  • 選擇 [要求權限]，在重新導向前會顯示對話方塊，要求指定是否應進行重新導向
  • 選擇 [完整存取] 可允許已啟動應用程式存取 PDA 裝置
  • 選擇 [不准存取] 可拒絕已啟動應用程式存取 PDA 裝置


設定 USB/其他裝置的存取權限

工作階段安全性 - USB/其他裝置

使用 [USB/其他裝置] 下拉式功能表可設定已啟動應用程式存取本機掃描器、數位相機、銷售點系統或其他裝置的權限，以從上述裝置取得檔案或資訊。
  • 選擇 [要求權限]，在重新導向前會顯示對話方塊，要求指定是否應進行重新導向
  • 選擇 [完整存取] 可允許已啟動應用程式存取您的裝置
  • 選擇 [不准存取] 可拒絕已啟動應用程式存取您的裝置