Citrix 连接中心窗口

Citrix 连接中心显示使用 Citrix Receiver 建立的所有连接。 可以使用 Receiver 访问管理员发布的应用程序、服务器桌面或内容（例如文档或演示文稿）。 可以访问的所有项目统称为已发布资源，存储在 Citrix XenApp 服务器上。 每组服务器称为服务器场。

Citrix 连接中心会显示当前打开的会话。


Citrix 连接中心概述

Citrix 连接中心显示使用 Citrix Receiver 建立的所有连接。

使用连接窗口可以显示活动会话的列表。 列表中的每个服务器条目都代表一个会话。 对于每个无缝会话，在每个服务器条目下，都会显示一个正在该服务器上运行的已发布资源的列表。

连接中心提供了许多用于查看统计信息及控制会话和应用程序的选项。

“断开连接”按钮

使用断开连接按钮可以断开当前所选服务器会话的连接。

“全屏”按钮

单击全屏按钮后，当前选择的无缝连接会切换为全屏会话。 按 SHIFT+F2 可以将此会话返回到无缝模式。

“属性”按钮

显示选定服务器的通信统计信息， 以及当前选定会话的用户名、服务器名称、加密等级、会话可靠性和 SpeedScreen 设置。

“注销”按钮

要从服务器中注销，请从列表中选择一个服务器条目，然后单击注销。 会话将结束，您在该服务器上运行的所有已发布应用程序将被终止。

会话安全 - 文件

使用文件下拉菜单可设置已启动应用程序对本地映射驱动器上的文件的访问权限。 此设置不会影响应用程序对服务器上的文件的访问权限。
  • 如果选择只读，则允许已启动应用程序对关联的本地文件进行只读访问。
  • 如果选择询问权限，则系统会在重定向之前显示一个对话框，要求您指定是否应进行重定向。
  • 如果选择完全访问权限，则允许已启动应用程序对关联的本地文件进行读写访问。 只有选择完全访问权限选项，才允许将更改保存到本地驱动器。
  • 如果选择无访问权限，则拒绝已启动应用程序对本地文件进行任何形式的访问。
注： 特殊文件夹重定向要求具有对用户本地计算机上的“文档”和“桌面”文件夹的访问权限。 如果用户通过 Web Interface 启动应用程序，并在连接中心的文件下拉菜单中选择无访问权限，访问用户的本地工作站驱动器（包括用户的本地“文档”和“桌面”文件夹）会被拒绝。 因此，尝试对被拒绝访问的文件夹执行读取/写入操作时，某些应用程序可能变得不稳定。 为避免出现此问题，请在启用“特殊文件夹重定向”时始终授予完全本地访问权限。

会话安全 - 麦克风/网络摄像头

使用音频安全下拉菜单可设置已启动应用程序对计算机的麦克风或网络摄像头的访问权限。
  • 如果选择询问权限，则系统会在访问之前显示一个对话框，要求您指定是否应授予访问权限
  • 如果选择完全访问权限，则允许已启动应用程序对计算机的麦克风或网络摄像头进行访问，以便记录传输
  • 如果选择无访问权限，则拒绝已启动应用程序对计算机的麦克风或网络摄像头进行访问

会话安全 - PDA 设备

使用 PDA 安全下拉菜单可设置已启动应用程序对本地 PDA 设备的访问权限。
  • 如果选择询问权限，则系统会在访问之前显示一个对话框，要求您指定是否应授予访问权限
  • 如果选择完全访问权限，则允许已启动应用程序对 PDA 设备进行访问
  • 如果选择无访问权限，则拒绝已启动应用程序对 PDA 设备进行访问

会话安全 - USB/其他设备

使用 USB/其他设备下拉菜单可设置已启动应用程序对本地扫描仪、数码相机、销售点设备或其他设备的访问权限，以便从这些设备获取文件或信息。
  • 如果选择询问权限，则系统会在访问之前显示一个对话框，要求您指定是否应授予访问权限
  • 如果选择完全访问权限，则允许已启动应用程序对设备进行访问
  • 如果选择无访问权限，则拒绝已启动应用程序对设备进行访问

应用程序 - 终止按钮

要终止个别已发布应用程序的连接，请选择一个已发布的应用程序，然后单击终止。

如果该服务器上还有其他已发布应用程序正在运行，则会话将保持活动状态，这些已发布的应用程序将继续运行。 如果该服务器上没有其他已发布的应用程序还在运行，则与服务器之间的连接将被终止。


更改查看已发布资源的方式

可以在“无缝”和“全屏”模式之间切换。

  • 无缝模式。 已发布应用程序和桌面不包含在会话窗口中。 每个已发布应用程序和桌面都显示在自己大小可调的窗口中，如同实际安装在用户设备上一样。 用户可以在已发布应用程序和本地桌面之间进行切换。
  • 全屏模式。 已发布应用程序放置在全屏大小的桌面上。
  1. 选择相应的服务器名称。
  2. 单击全屏按钮并单击确定。
  3. 要返回到无缝模式，请按 Shift + F2。


禁用按钮的原因

如果在 Citrix 连接中心中选择了某个已发布应用程序名称，系统会有目的地禁用会话和会话安全按钮。 会话按钮仅适用于服务器会话，不适用于单个已发布应用程序。 不能根据已发布应用程序修改会话安全功能的行为，但是，如果您在连接中心中选择了服务器名称，则可以修改会话的会话安全设置。
“会话”选项 | “会话安全”选项
断开连接 | 文件
全屏 | 麦克风/网络摄像头
属性 | PDA 设备
注销 | USB/其他设备


显示服务器统计信息

可以使用 Citrix 连接中心显示特定会话的服务器统计信息。 显示的一些统计信息包括：

  • Citrix Receiver 版本号
  • 用于连接的服务器
  • 用于登录服务器的帐户
  • 加密等级
  • 是否启用了会话可靠性
  • 是否启用了 SpeedScreen 功能
  • 通过连接传输的传入或传出字节数
  • 通过连接传输的传入或传出帧数
  • 字节数除以帧数所得的结果
  • 通过连接错误传输的传入或传出帧数

要显示服务器统计信息和属性，请选择相应的服务器名称，然后单击属性。


断开连接时使服务器会话保持运行状态

可以使用 Citrix 连接中心断开与服务器之间的连接，但使会话仍在服务器上运行。 如果断开了与服务器之间的连接，请使用“Citrix Receiver”菜单直接与会话重新建立连接。

  1. 要断开特定会话，请选择相应的服务器名称并单击断开连接按钮。

    要断开所有正在运行的会话，请在 Windows 通知区域的插件图标上单击鼠标右键，然后选择断开联机会话。

  2. 要重新连接到一个或多个已断开连接的会话，请在 Windows 通知区域的“Receiver”图标上单击鼠标右键，然后选择重新连接联机会话。


结束服务器会话

可以使用 Citrix 连接中心结束服务器会话，并关闭所有资源。 会话结束后，在该服务器上运行的所有已发布资源都将终止。

  1. 选择相应的服务器名称。
  2. 单击注销。


终止单个已发布应用程序

可以使用 Citrix 连接中心结束特定的已发布应用程序。 如果该服务器上还有其他已发布应用程序正在运行，会话会保持活动状态，其他已发布应用程序会继续运行。 如果该服务器上没有其他已发布应用程序正在运行，与服务器之间的连接将终止。

  1. 确保会话处于无缝模式下。
  2. 从连接中心的列表中选择已发布应用程序。
  3. 单击终止。


设置文件的访问权限

会话安全 - 文件

使用文件下拉菜单可设置已启动应用程序对本地映射驱动器上的文件的访问权限。 此设置不会影响应用程序对服务器上的文件的访问权限。
  • 如果选择只读，则允许已启动应用程序对关联的本地文件进行只读访问。
  • 如果选择询问权限，则系统会在重定向之前显示一个对话框，要求您指定是否应进行重定向。
  • 如果选择完全访问权限，则允许已启动应用程序对关联的本地文件进行读写访问。 只有选择完全访问权限选项，才允许将更改保存到本地驱动器。
  • 如果选择无访问权限，则拒绝已启动应用程序对本地文件进行任何形式的访问。
注： 特殊文件夹重定向要求具有对用户本地计算机上的“文档”和“桌面”文件夹的访问权限。 如果用户通过 Web Interface 启动应用程序，并在连接中心的文件下拉菜单中选择无访问权限，访问用户的本地工作站驱动器（包括用户的本地“文档”和“桌面”文件夹）会被拒绝。 因此，尝试对被拒绝访问的文件夹执行读取/写入操作时，某些应用程序可能变得不稳定。 为避免出现此问题，请在启用“特殊文件夹重定向”时始终授予完全本地访问权限。


设置麦克风和网络摄像头的访问权限

会话安全 - 麦克风/网络摄像头

使用音频安全下拉菜单可设置已启动应用程序对计算机的麦克风或网络摄像头的访问权限。
  • 如果选择询问权限，则系统会在访问之前显示一个对话框，要求您指定是否应授予访问权限
  • 如果选择完全访问权限，则允许已启动应用程序对计算机的麦克风或网络摄像头进行访问，以便记录传输
  • 如果选择无访问权限，则拒绝已启动应用程序对计算机的麦克风或网络摄像头进行访问


设置本地 PDA 设备的访问权限

会话安全 - PDA 设备

使用 PDA 安全下拉菜单可设置已启动应用程序对本地 PDA 设备的访问权限。
  • 如果选择询问权限，则系统会在访问之前显示一个对话框，要求您指定是否应授予访问权限
  • 如果选择完全访问权限，则允许已启动应用程序对 PDA 设备进行访问
  • 如果选择无访问权限，则拒绝已启动应用程序对 PDA 设备进行访问


设置 USB/其他设备的访问权限

会话安全 - USB/其他设备

使用 USB/其他设备下拉菜单可设置已启动应用程序对本地扫描仪、数码相机、销售点设备或其他设备的访问权限，以便从这些设备获取文件或信息。
  • 如果选择询问权限，则系统会在访问之前显示一个对话框，要求您指定是否应授予访问权限
  • 如果选择完全访问权限，则允许已启动应用程序对设备进行访问
  • 如果选择无访问权限，则拒绝已启动应用程序对设备进行访问