Окно центра подключений Citrix

В центре подключений Citrix отображаются все подключения, открытые в Citrix Receiver. ПО Receiver используется для доступа к приложениям, рабочим столам серверов или содержимому (например, к документам и презентациям), опубликованному администратором. Все доступные объекты (в совокупности они именуются опубликованными ресурсами), хранятся на серверах Citrix XenApp. Группы серверов называются также фермами серверов.

В центре подключений Citrix отображаются открытые сеансы.


Обзор центра подключений Citrix

В центре подключений Citrix отображаются все подключения, открытые из Citrix Receiver.

В окне Подключения отображается список активных сеансов. Каждый сервер в списке представляет сеанс. Для всех бесшовных сеансов под сервером отображается список опубликованных ресурсов, которые используются в настоящий момент.

Центр подключений поддерживает различные параметры просмотра статистики и управления сеансами и приложениями.

Кнопка «Отключить»

Кнопка Отключить позволяет завершить текущий сеанс работы с сервером.

Кнопка «Полный экран»

При нажатии кнопки Полный экран выделенное бесшовное подключение переводится в полноэкранный режим. Нажмите SHIFT+F2, чтобы вернуться к бесшовному режиму.

Кнопка «Свойства»

Отображает характеристики связи для выбранного сервера. Кроме того, для выбранного сеанса отображается имя пользователя, имя сервера, уровень шифрования, надежность сеанса и параметры SpeedScreen.

Кнопка «Выход»

Для отсоединения от сервера, выберите сервер из списка и нажмите кнопку Выход. Сеанс будет завершен и все опубликованные приложения этого сервера, с которыми вы работаете, будут закрыты.

Безопасность сеансов - файлы

В раскрывающемся списке Файлы можно настроить права доступа запущенных приложений к файлам, расположенным на локальном диске, подключенном к сети. Эти параметры не влияют на возможность доступа приложений к файлам, расположенным на сервере.
  • Вариант Только чтение позволяет предоставить запущенным приложениям доступ к локальным файлам только для чтения.
  • Выберите Спросить разрешения, чтобы открывать диалоговое окно перед перенаправлением, запрашивающее согласие пользователя на перенаправление.
  • Чтобы предоставить запущенным приложениям полный доступ к локальным файлам, выберите Полный доступ. Сохранять изменения на локальном диске позволяет только вариант Полный доступ.
  • Выберите вариант Нет доступа, чтобы отказать запущенному приложению в доступе к локальным файлам.
Прим.: Для функции «Указание специальной папки» необходим доступ к папкам «Документы» и «Рабочий стол» на локальном компьютере пользователя. Если пользователь запустит приложение через Web Interface и выберет в раскрывающемся списке центра подключений Файл вариант Нет доступа, то доступ к дискам локальной рабочей станции пользователя будет запрещен, в том числе к папкам «Документы» и «Рабочий стол». Это может привести к нестабильности работы некоторых приложений, которые предпринимают попытки выполнить операции чтения из этих папок или записи в них. Чтобы этого не происходило, рекомендуется всегда разрешать полный доступ при включенной функции «Указание специальной папки».

Безопасность файлов - микрофоны и веб-камеры

Используйте раскрывающееся меню Безопасность аудиосистемы, чтобы настроить права доступа запущенных приложений к микрофону и веб-камере компьютера.
  • Выберите Спросить разрешения, чтобы открывать диалоговое окно перед предоставлением доступа, запрашивающее согласие пользователя на предоставление доступа.
  • Выберите Полный доступ, чтобы предоставить запущенному приложению полный доступ к микрофону или веб-камере компьютера для записи передаваемых данных.
  • Выберите вариант Нет, чтобы отказать запущенному приложению в доступе к локальному микрофону или веб-камере.

Безопасность сеансов - устройства

В раскрывающемся списке Безопасность КПК можно настроить права доступа запущенных приложений к локальному устройству КПК.
  • Выберите Спросить разрешения, чтобы открывать диалоговое окно перед предоставлением доступа, запрашивающее согласие пользователя на предоставление доступа.
  • Выберите вариант Полный доступ, чтобы разрешить запущенному приложению доступ к устройству КПК.
  • Выберите вариант Нет доступа, чтобы отказать запущенному приложению в доступе к устройству КПК.

Безопасность сеансов - USB и другие устройства

Используйте раскрывающееся меню USB и другие устройства, чтобы настроить права доступа опубликованных приложений к локальным сканерам, цифровым фотоаппаратам, кассовым аппаратам и другим устройствам для создания файлов или данных с таких устройств.
  • Выберите Спросить разрешения, чтобы открывать диалоговое окно перед предоставлением доступа, запрашивающее согласие пользователя на предоставление доступа.
  • Выберите вариант Полный доступ, чтобы разрешить запущенному приложению доступ к локальным устройствам.
  • Выберите вариант Нет доступа, чтобы отказать запущенному приложению в доступе к устройствам.

Приложение - кнопка «Завершить»

Чтобы разорвать подключение отдельного опубликованного приложения, выберите приложение и нажмите кнопку Завершить.

Если вы используете другие приложения, работающие на этом сервере, сеанс ICA останется открытым, и опубликованные приложения продолжат работу. Если на сервере нет других опубликованных приложений, подключение к серверу будет разорвано.


Чтобы изменить способ просмотра опубликованных ресурсов

Система позволяет переключаться между бесшовным и полноэкранным режимами.

  • Бесшовный режим. Опубликованные приложения и рабочие столы не ограничиваются окном сеанса. Каждое опубликованное приложение и рабочий стол отображается в собственном окне с изменяемым размером, подобно приложениям, установленным на устройстве пользователя. Пользователь может переключаться между опубликованными приложениями и локальным рабочим столом.
  • Полноэкранный режим. Опубликованные приложения помещаются в полноэкранный рабочий стол.
  1. Выберите имя сервера.
  2. Нажмите кнопку Полноэкранный режим, а затем кнопку OK.
  3. Для возврата в бесшовный режим нажмите Shift + F2.


Почему кнопки отключены?

Когда имя опубликованного приложения выбрано в Центре подключений Citrix, кнопки Сеанс и Защита сеанса будут заблокированы. Кнопки Сеанс применяются, только к сеансам сервера, а не к отдельным опубликованным приложениям. Режим функций Защиты сеанса нельзя изменить для отдельных опубликованных приложений, но если выбрать имя сервера в Центре подключений, можно будет изменить параметры защиты сеансов для соответствующего сеанса.
Параметры сеанса | Параметры защиты сеанса
Отключить | Файлы
Полноэкранный режим | Микрофоны и веб-камеры
Свойства | Устройства КПК
Выход | USB и другие устройства


Для отображения статистики сервера

Можно использовать Центр подключений Citrix для отображения статистики по определенному сеансу. Некоторые из доступных статистических показателей:

  • Номер версии Citrix Receiver
  • Сервер, используемый для подключения
  • Учетная запись, используемая для входа на сервер
  • Уровень шифрования
  • Включена ли функция надежности сеанса
  • Включены ли функции SpeedScreen
  • Количество входящих и исходящих байт, переданных через подключение
  • Количество входящих и исходящих кадров, переданных через подключение
  • Количество байт, деленное на количество кадров
  • Количество входящих и исходящих кадров, переданных через подключение с ошибками

Для вывода свойств и статистики сервера, щелкните имя сервера правой кнопкой мыши и выберите Свойства.


Чтобы оставить сеанс запущенным после отключения

Пользователь может отключиться от сервера с помощью Центра подключений Citrix, но при этом оставить сеанс запущенным. После отключения от сервера он сможет воспользоваться меню Receiver для восстановления подключения к сеансу.

  1. Чтобы отключиться от определенного сеанса, выберите имя сервера и нажмите кнопку Отключить.

    Чтобы отключить все работающие сеансы, щелкните значок модуля в области уведомлений Windows правой кнопкой мыши и выберите пункт Отключить сетевые сеансы.

  2. Чтобы восстановить подключение ко всем работающим сеансам, щелкните значок Receiver в области уведомлений Windows правой кнопкой мыши и выберите пункт Отключить сетевые сеансы.


Чтобы прекратить сервер сеанса

Центр подключений Citrix можно использовать для прекращения сеансов серверов и закрытия всех ресурсов. При прекращении сеанса все опубликованные ресурсы, выполняемые на сервере, закрываются.

  1. Выберите имя сервера.
  2. Нажмите кнопку Выход.


Чтобы завершить работу отдельного опубликованного приложения

Чтобы завершить работу отдельного опубликованного приложения, используйте Центр подключений Citrix. Если используются другие приложения, работающие на этом сервере, сеанс ICA останется открытым и другие опубликованные приложения продолжат работу. Если на сервере нет других опубликованных приложений, подключение к серверу будет закрыто.

  1. Убедитесь, что сеанс работает в бесшовном режиме.
  2. Выберите опубликованное приложение в Центре подключений.
  3. Нажмите кнопку Завершить.


Чтобы установить разрешения для файлов

Безопасность сеансов - файлы

В раскрывающемся списке Файлы можно настроить права доступа запущенных приложений к файлам, расположенным на локальном диске, подключенном к сети. Эти параметры не влияют на возможность доступа приложений к файлам, расположенным на сервере.
  • Вариант Только чтение позволяет предоставить запущенным приложениям доступ к локальным файлам только для чтения.
  • Выберите Спросить разрешения, чтобы открывать диалоговое окно перед перенаправлением, запрашивающее согласие пользователя на перенаправление.
  • Чтобы предоставить запущенным приложениям полный доступ к локальным файлам, выберите Полный доступ. Сохранять изменения на локальном диске позволяет только вариант Полный доступ.
  • Выберите вариант Нет доступа, чтобы отказать запущенному приложению в доступе к локальным файлам.
Прим.: Для функции «Указание специальной папки» необходим доступ к папкам «Документы» и «Рабочий стол» на локальном компьютере пользователя. Если пользователь запустит приложение через Web Interface и выберет в раскрывающемся списке центра подключений Файл вариант Нет доступа, то доступ к дискам локальной рабочей станции пользователя будет запрещен, в том числе к папкам «Документы» и «Рабочий стол». Это может привести к нестабильности работы некоторых приложений, которые предпринимают попытки выполнить операции чтения из этих папок или записи в них. Чтобы этого не происходило, рекомендуется всегда разрешать полный доступ при включенной функции «Указание специальной папки».


Чтобы установить разрешения для микрофонов и веб-камер

Безопасность файлов - микрофоны и веб-камеры

Используйте раскрывающееся меню Безопасность аудиосистемы, чтобы настроить права доступа запущенных приложений к микрофону и веб-камере компьютера.
  • Выберите Спросить разрешения, чтобы открывать диалоговое окно перед предоставлением доступа, запрашивающее согласие пользователя на предоставление доступа.
  • Выберите Полный доступ, чтобы предоставить запущенному приложению полный доступ к микрофону или веб-камере компьютера для записи передаваемых данных.
  • Выберите вариант Нет, чтобы отказать запущенному приложению в доступе к локальному микрофону или веб-камере.


Чтобы установить разрешения для локального устройства КПК

Безопасность сеансов - устройства

В раскрывающемся списке Безопасность КПК можно настроить права доступа запущенных приложений к локальному устройству КПК.
  • Выберите Спросить разрешения, чтобы открывать диалоговое окно перед предоставлением доступа, запрашивающее согласие пользователя на предоставление доступа.
  • Выберите вариант Полный доступ, чтобы разрешить запущенному приложению доступ к устройству КПК.
  • Выберите вариант Нет доступа, чтобы отказать запущенному приложению в доступе к устройству КПК.


Чтобы установить разрешения для USB и других устройств

Безопасность сеансов - USB и другие устройства

Используйте раскрывающееся меню USB и другие устройства, чтобы настроить права доступа опубликованных приложений к локальным сканерам, цифровым фотоаппаратам, кассовым аппаратам и другим устройствам для создания файлов или данных с таких устройств.
  • Выберите Спросить разрешения, чтобы открывать диалоговое окно перед предоставлением доступа, запрашивающее согласие пользователя на предоставление доступа.
  • Выберите вариант Полный доступ, чтобы разрешить запущенному приложению доступ к локальным устройствам.
  • Выберите вариант Нет доступа, чтобы отказать запущенному приложению в доступе к устройствам.